About Jd2chm...

The project files of this HTML Help
Were generated with Jd2chm version 0.3
Copyright © 2000-2003 Andre Burgaud
http://www.burgaud.com


Overview (Struts 2 Core 2.0.6 API)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES

Struts 2 Core 2.0.6 API

Struts Packages
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.components |
org.apache.struts2.components.table |
org.apache.struts2.components.table.renderer | JSP UI tags for rendering table output in HTML.
org.apache.struts2.components.template |
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.dispatcher.multipart | Classes to help dispatch multipart HTTP requests.
org.apache.struts2.impl |
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.debugging |
org.apache.struts2.interceptor.validation |
org.apache.struts2.portlet |
org.apache.struts2.portlet.context |
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.portlet.interceptor |
org.apache.struts2.portlet.result |
org.apache.struts2.portlet.util |
org.apache.struts2.servlet.interceptor |
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.validators |
org.apache.struts2.views |
org.apache.struts2.views.annotations |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.freemarker.tags |
org.apache.struts2.views.jsp | Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.
org.apache.struts2.views.util | Miscellaneous helper classes for all views.
org.apache.struts2.views.velocity | Classes for views using Velocity.
org.apache.struts2.views.velocity.components |
org.apache.struts2.views.xslt | The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

XWork Packages
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.conversion.annotations | Type conversion annotations.
com.opensymphony.xwork2.conversion.metadata | Type conversion meta data classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
com.opensymphony.xwork2.inject.util | Guice util classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.util.location | Classes and utilities used to track location information.
com.opensymphony.xwork2.util.profiling | Classes to enable profiling of action execution.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.annotations | Validator annotations.
com.opensymphony.xwork2.validator.metadata | Validator meta data classes.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES
Copyright © 2000-2007 Apache Software Foundation. All Rights Reserved.


Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For All Packages

Package Hierarchies:
com.opensymphony.xwork2, com.opensymphony.xwork2.config, com.opensymphony.xwork2.config.entities, com.opensymphony.xwork2.config.impl, com.opensymphony.xwork2.config.providers, com.opensymphony.xwork2.conversion.annotations, com.opensymphony.xwork2.conversion.metadata, com.opensymphony.xwork2.inject, com.opensymphony.xwork2.inject.util, com.opensymphony.xwork2.interceptor, com.opensymphony.xwork2.interceptor.annotations, com.opensymphony.xwork2.mock, com.opensymphony.xwork2.spring, com.opensymphony.xwork2.spring.interceptor, com.opensymphony.xwork2.util, com.opensymphony.xwork2.util.location, com.opensymphony.xwork2.util.profiling, com.opensymphony.xwork2.validator, com.opensymphony.xwork2.validator.annotations, com.opensymphony.xwork2.validator.metadata, com.opensymphony.xwork2.validator.validators, org.apache.struts2, org.apache.struts2.components, org.apache.struts2.components.table, org.apache.struts2.components.table.renderer, org.apache.struts2.components.template, org.apache.struts2.config, org.apache.struts2.dispatcher, org.apache.struts2.dispatcher.mapper, org.apache.struts2.dispatcher.multipart, org.apache.struts2.impl, org.apache.struts2.interceptor, org.apache.struts2.interceptor.debugging, org.apache.struts2.interceptor.validation, org.apache.struts2.portlet, org.apache.struts2.portlet.context, org.apache.struts2.portlet.dispatcher, org.apache.struts2.portlet.interceptor, org.apache.struts2.portlet.result, org.apache.struts2.portlet.util, org.apache.struts2.servlet.interceptor, org.apache.struts2.util, org.apache.struts2.validators, org.apache.struts2.views, org.apache.struts2.views.annotations, org.apache.struts2.views.freemarker, org.apache.struts2.views.freemarker.tags, org.apache.struts2.views.jsp, org.apache.struts2.views.jsp.iterator, org.apache.struts2.views.jsp.ui, org.apache.struts2.views.jsp.ui.table, org.apache.struts2.views.util, org.apache.struts2.views.velocity, org.apache.struts2.views.velocity.components, org.apache.struts2.views.xslt

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.views.xslt.AbstractAdapterNode (implements org.apache.struts2.views.xslt.AdapterNode)
      • org.apache.struts2.views.xslt.AbstractAdapterElement (implements org.w3c.dom.Element)
        • org.apache.struts2.views.xslt.ArrayAdapter
        • org.apache.struts2.views.xslt.BeanAdapter
        • org.apache.struts2.views.xslt.CollectionAdapter
        • org.apache.struts2.views.xslt.MapAdapter
        • org.apache.struts2.views.xslt.MapAdapter.EntryElement
        • org.apache.struts2.views.xslt.StringAdapter
      • org.apache.struts2.views.xslt.ProxyNodeAdapter
        • org.apache.struts2.views.xslt.ProxyAttrAdapter (implements org.w3c.dom.Attr)
        • org.apache.struts2.views.xslt.ProxyElementAdapter (implements org.w3c.dom.Element)
        • org.apache.struts2.views.xslt.ProxyTextNodeAdapter (implements org.w3c.dom.Text)
      • org.apache.struts2.views.xslt.SimpleAdapterDocument (implements org.w3c.dom.Document)
      • org.apache.struts2.views.xslt.SimpleTextNode (implements org.w3c.dom.Node, org.w3c.dom.Text)
    • org.apache.struts2.components.table.renderer.AbstractCellRenderer (implements org.apache.struts2.components.table.renderer.CellRenderer)
      • org.apache.struts2.components.table.renderer.BooleanCellRenderer
      • org.apache.struts2.components.table.renderer.DateCellRenderer
      • org.apache.struts2.components.table.renderer.DefaultCellRenderer
      • org.apache.struts2.components.table.renderer.FixedTextCellRenderer
      • org.apache.struts2.components.table.renderer.LinkCellRenderer
      • org.apache.struts2.components.table.renderer.NumericCellRenderer
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • com.opensymphony.xwork2.util.CompoundRoot
          • com.opensymphony.xwork2.util.SurrugateList
          • com.opensymphony.xwork2.util.XWorkList
    • org.apache.velocity.context.AbstractContext (implements org.apache.velocity.context.Context, java.io.Serializable)
      • org.apache.velocity.VelocityContext (implements java.lang.Cloneable)
        • org.apache.struts2.views.velocity.StrutsVelocityContext
    • com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription (implements com.opensymphony.xwork2.validator.metadata.ValidatorDescription)
      • com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
      • com.opensymphony.xwork2.interceptor.AliasInterceptor
      • com.opensymphony.xwork2.interceptor.ChainingInterceptor
      • com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
        • org.apache.struts2.interceptor.StrutsConversionErrorInterceptor
      • org.apache.struts2.interceptor.CreateSessionInterceptor
      • com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
      • org.apache.struts2.interceptor.FileUploadInterceptor
      • com.opensymphony.xwork2.interceptor.I18nInterceptor
      • com.opensymphony.xwork2.interceptor.LoggingInterceptor
      • com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
        • com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
        • org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
        • org.apache.struts2.interceptor.TokenInterceptor
          • org.apache.struts2.interceptor.TokenSessionStoreInterceptor
        • com.opensymphony.xwork2.validator.ValidationInterceptor
          • org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor
      • com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
      • com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
      • com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
      • com.opensymphony.xwork2.interceptor.ParametersInterceptor
      • org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor (implements org.apache.struts2.StrutsStatics)
      • com.opensymphony.xwork2.interceptor.PrepareInterceptor
      • org.apache.struts2.interceptor.ProfilingActivationInterceptor
      • org.apache.struts2.interceptor.RolesInterceptor
      • com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
      • org.apache.struts2.interceptor.ScopeInterceptor (implements com.opensymphony.xwork2.interceptor.PreResultListener)
      • org.apache.struts2.interceptor.ServletConfigInterceptor (implements org.apache.struts2.StrutsStatics)
      • com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
      • com.opensymphony.xwork2.interceptor.TimerInterceptor
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • org.apache.struts2.dispatcher.ApplicationMap (implements java.io.Serializable)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap<K,V>
        • com.opensymphony.xwork2.util.XWorkMap
      • org.apache.struts2.portlet.PortletApplicationMap (implements java.io.Serializable)
      • org.apache.struts2.portlet.PortletRequestMap
      • org.apache.struts2.portlet.PortletSessionMap
      • org.apache.struts2.dispatcher.RequestMap (implements java.io.Serializable)
      • org.apache.struts2.dispatcher.SessionMap (implements java.io.Serializable)
    • javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • org.apache.struts2.components.table.AbstractFilterModel
        • org.apache.struts2.components.table.RenderFilterModel
        • org.apache.struts2.components.table.SortFilterModel (implements org.apache.struts2.components.table.SortableTableModel, javax.swing.event.TableModelListener)
    • com.opensymphony.xwork2.ActionChainResult (implements com.opensymphony.xwork2.Result)
    • com.opensymphony.xwork2.config.impl.ActionConfigMatcher (implements java.io.Serializable)
    • com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping (implements java.io.Serializable)
    • com.opensymphony.xwork2.ActionContext (implements java.io.Serializable)
      • org.apache.struts2.ServletActionContext (implements org.apache.struts2.StrutsStatics)
    • org.apache.struts2.dispatcher.ActionContextCleanUp (implements javax.servlet.Filter)
    • org.apache.struts2.dispatcher.mapper.ActionMapping
    • com.opensymphony.xwork2.ActionSupport (implements com.opensymphony.xwork2.Action, com.opensymphony.xwork2.LocaleProvider, java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Validateable, com.opensymphony.xwork2.ValidationAware)
      • org.apache.struts2.dispatcher.DefaultActionSupport
    • com.opensymphony.xwork2.validator.ActionValidatorManagerFactory
    • org.apache.struts2.views.xslt.AdapterFactory
    • com.opensymphony.xwork2.validator.AnnotationActionValidatorManager (implements com.opensymphony.xwork2.validator.ActionValidatorManager)
    • com.opensymphony.xwork2.util.AnnotationUtils
    • com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder
    • com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor, com.opensymphony.xwork2.interceptor.PreResultListener)
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.opensymphony.xwork2.XWorkTestCase
          • org.apache.struts2.StrutsTestCase
    • org.apache.struts2.util.AttributeMap (implements java.util.Map<K,V>)
    • org.apache.struts2.interceptor.BackgroundProcess (implements java.io.Serializable)
    • org.apache.struts2.components.template.BaseTemplateEngine (implements org.apache.struts2.components.template.TemplateEngine)
      • org.apache.struts2.components.template.FreemarkerTemplateEngine
      • org.apache.struts2.components.template.JspTemplateEngine
      • org.apache.struts2.components.template.VelocityTemplateEngine
    • freemarker.ext.beans.BeanModel (implements freemarker.template.AdapterTemplateModel, freemarker.template.TemplateHashModelEx, freemarker.ext.util.WrapperTemplateModel)
      • freemarker.ext.beans.StringModel (implements freemarker.template.TemplateScalarModel)
        • freemarker.ext.beans.MapModel (implements freemarker.template.TemplateMethodModelEx)
          • org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel (implements freemarker.template.TemplateHashModelEx)
    • org.apache.struts2.config.BeanSelectionProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory (implements com.opensymphony.xwork2.inject.Factory<T>)
    • freemarker.ext.beans.BeansWrapper (implements freemarker.template.ObjectWrapper)
      • org.apache.struts2.views.freemarker.StrutsBeanWrapper
    • org.apache.struts2.interceptor.CheckboxInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • java.lang.ClassLoader
      • com.opensymphony.xwork2.ObjectFactory.ContinuationsClassLoader
    • com.opensymphony.xwork2.util.ClassLoaderUtil
    • com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator<E> (implements java.util.Iterator<E>)
    • org.apache.struts2.util.ClassLoaderUtils
    • org.apache.struts2.config.ClasspathConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • org.apache.struts2.config.ClasspathConfigurationProvider.ClasspathPageLocator (implements org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator)
    • org.apache.struts2.components.Component
      • org.apache.struts2.components.ActionComponent
      • org.apache.struts2.components.AppendIterator (implements org.apache.struts2.components.Param.UnnamedParametric)
      • org.apache.struts2.components.Bean
      • org.apache.struts2.components.Date
      • org.apache.struts2.components.Else
      • org.apache.struts2.components.ElseIf
      • org.apache.struts2.components.I18n
      • org.apache.struts2.components.If
      • org.apache.struts2.components.Include
      • org.apache.struts2.components.IteratorComponent
      • org.apache.struts2.components.MergeIterator (implements org.apache.struts2.components.Param.UnnamedParametric)
      • org.apache.struts2.components.OptGroup
      • org.apache.struts2.components.Param
      • org.apache.struts2.components.Property
      • org.apache.struts2.components.Push
      • org.apache.struts2.components.Set
      • org.apache.struts2.components.Text (implements org.apache.struts2.components.Param.UnnamedParametric)
      • org.apache.struts2.components.UIBean
        • org.apache.struts2.components.ActionError
        • org.apache.struts2.components.ActionMessage
        • org.apache.struts2.components.Checkbox
        • org.apache.struts2.components.ClosingUIBean
          • org.apache.struts2.components.AbstractRemoteCallUIBean (implements org.apache.struts2.components.RemoteUICallBean)
            • org.apache.struts2.components.Anchor
            • org.apache.struts2.components.Div
          • org.apache.struts2.components.Form
          • org.apache.struts2.components.TabbedPanel
          • org.apache.struts2.components.Tree
          • org.apache.struts2.components.TreeNode
        • org.apache.struts2.components.DateTimePicker
        • org.apache.struts2.components.Debug
        • org.apache.struts2.components.FieldError (implements org.apache.struts2.components.Param.UnnamedParametric)
        • org.apache.struts2.components.File
        • org.apache.struts2.components.FormButton
          • org.apache.struts2.components.Reset
          • org.apache.struts2.components.Submit (implements org.apache.struts2.components.RemoteUICallBean)
        • org.apache.struts2.components.GenericUIBean
          • org.apache.struts2.components.table.WebTable
        • org.apache.struts2.components.Head
        • org.apache.struts2.components.Hidden
        • org.apache.struts2.components.Label
        • org.apache.struts2.components.ListUIBean
          • org.apache.struts2.components.CheckboxList
          • org.apache.struts2.components.DoubleListUIBean
            • org.apache.struts2.components.DoubleSelect
            • org.apache.struts2.components.OptionTransferSelect
          • org.apache.struts2.components.InputTransferSelect
          • org.apache.struts2.components.Radio
          • org.apache.struts2.components.Select
            • org.apache.struts2.components.UpDownSelect
        • org.apache.struts2.components.TextArea
        • org.apache.struts2.components.TextField
          • org.apache.struts2.components.ComboBox
            • org.apache.struts2.components.Autocompleter
          • org.apache.struts2.components.Password
        • org.apache.struts2.components.Token
      • org.apache.struts2.components.URL
    • org.apache.struts2.dispatcher.mapper.CompositeActionMapper (implements org.apache.struts2.dispatcher.mapper.ActionMapper)
    • com.opensymphony.xwork2.util.CompoundRootAccessor (implements ognl.ClassResolver, ognl.MethodAccessor, ognl.PropertyAccessor)
    • com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall
    • com.opensymphony.xwork2.config.ConfigurationManager
    • com.opensymphony.xwork2.config.ConfigurationUtil
    • com.opensymphony.xwork2.inject.ConstructionContext<T>
    • com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler<T> (implements java.lang.reflect.InvocationHandler)
    • com.opensymphony.xwork2.inject.ContainerBuilder
    • com.opensymphony.xwork2.inject.ContainerImpl (implements com.opensymphony.xwork2.inject.Container)
    • com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector<T>
    • com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector (implements com.opensymphony.xwork2.inject.ContainerImpl.Injector)
    • com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector (implements com.opensymphony.xwork2.inject.ContainerImpl.Injector)
    • com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector<T>
    • org.apache.struts2.util.ContainUtil
    • org.apache.struts2.views.util.ContextUtil
    • com.opensymphony.xwork2.conversion.metadata.ConversionDescription
    • org.apache.struts2.util.Counter (implements java.util.Iterator<E>, java.io.Serializable)
    • org.apache.struts2.util.DateFormatter
    • org.apache.struts2.components.Debug.DebugMapEntry (implements java.util.Map.Entry<K,V>)
    • org.apache.struts2.interceptor.debugging.DebuggingInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • com.opensymphony.xwork2.DefaultActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
      • org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation
    • org.apache.struts2.dispatcher.mapper.DefaultActionMapper (implements org.apache.struts2.dispatcher.mapper.ActionMapper)
      • org.apache.struts2.dispatcher.mapper.Restful2ActionMapper
    • com.opensymphony.xwork2.DefaultActionProxy (implements com.opensymphony.xwork2.ActionProxy, java.io.Serializable)
      • org.apache.struts2.validators.DWRValidator.ValidatorActionProxy
      • org.apache.struts2.impl.StrutsActionProxy
    • com.opensymphony.xwork2.DefaultActionProxyFactory (implements com.opensymphony.xwork2.ActionProxyFactory)
      • org.apache.struts2.impl.StrutsActionProxyFactory
    • com.opensymphony.xwork2.validator.DefaultActionValidatorManager (implements com.opensymphony.xwork2.validator.ActionValidatorManager)
    • com.opensymphony.xwork2.config.impl.DefaultConfiguration (implements com.opensymphony.xwork2.config.Configuration)
    • com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl (implements com.opensymphony.xwork2.config.RuntimeConfiguration)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.opensymphony.xwork2.util.DomHelper.StartHandler
    • com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer (implements com.opensymphony.xwork2.util.ObjectTypeDeterminer)
      • com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
    • org.apache.struts2.views.DefaultTagLibrary (implements org.apache.struts2.views.TagLibrary)
    • com.opensymphony.xwork2.DefaultTextProvider (implements java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Unchainable)
    • ognl.DefaultTypeConverter (implements ognl.TypeConverter)
      • com.opensymphony.xwork2.util.EnumTypeConverter
      • org.apache.struts2.util.StrutsTypeConverter
      • com.opensymphony.xwork2.util.XWorkBasicConverter
      • com.opensymphony.xwork2.util.XWorkConverter
        • com.opensymphony.xwork2.util.AnnotationXWorkConverter
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext (implements com.opensymphony.xwork2.validator.ValidatorContext)
      • com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext.ActionContextLocaleProvider (implements com.opensymphony.xwork2.LocaleProvider)
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware (implements com.opensymphony.xwork2.ValidationAware)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • com.opensymphony.xwork2.util.location.LocatableProperties (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties
    • org.apache.velocity.runtime.directive.Directive (implements java.lang.Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants)
      • org.apache.struts2.views.velocity.components.AbstractDirective
        • org.apache.struts2.views.velocity.components.ActionDirective
        • org.apache.struts2.views.velocity.components.ActionErrorDirective
        • org.apache.struts2.views.velocity.components.ActionMessageDirective
        • org.apache.struts2.views.velocity.components.AnchorDirective
        • org.apache.struts2.views.velocity.components.AutocompleterDirective
        • org.apache.struts2.views.velocity.components.BeanDirective
        • org.apache.struts2.views.velocity.components.CheckBoxDirective
        • org.apache.struts2.views.velocity.components.CheckBoxListDirective
        • org.apache.struts2.views.velocity.components.ComboBoxDirective
        • org.apache.struts2.views.velocity.components.ComponentDirective
        • org.apache.struts2.views.velocity.components.DateDirective
        • org.apache.struts2.views.velocity.components.DivDirective
        • org.apache.struts2.views.velocity.components.DoubleSelectDirective
        • org.apache.struts2.views.velocity.components.FieldErrorDirective
        • org.apache.struts2.views.velocity.components.FileDirective
        • org.apache.struts2.views.velocity.components.FormDirective
        • org.apache.struts2.views.velocity.components.HeadDirective
        • org.apache.struts2.views.velocity.components.HiddenDirective
        • org.apache.struts2.views.velocity.components.I18nDirective
        • org.apache.struts2.views.velocity.components.IncludeDirective
        • org.apache.struts2.views.velocity.components.InputTransferSelectDirective
        • org.apache.struts2.views.velocity.components.LabelDirective
        • org.apache.struts2.views.velocity.components.OptGroupDirective
        • org.apache.struts2.views.velocity.components.OptionTransferSelectDirective
        • org.apache.struts2.views.velocity.components.ParamDirective
        • org.apache.struts2.views.velocity.components.PasswordDirective
        • org.apache.struts2.views.velocity.components.PropertyDirective
        • org.apache.struts2.views.velocity.components.PushDirective
        • org.apache.struts2.views.velocity.components.RadioDirective
        • org.apache.struts2.views.velocity.components.ResetDirective
        • org.apache.struts2.views.velocity.components.SelectDirective
        • org.apache.struts2.views.velocity.components.SetDirective
        • org.apache.struts2.views.velocity.components.SubmitDirective
        • org.apache.struts2.views.velocity.components.TabbedPanelDirective
        • org.apache.struts2.views.velocity.components.TextAreaDirective
        • org.apache.struts2.views.velocity.components.TextDirective
        • org.apache.struts2.views.velocity.components.TextFieldDirective
          • org.apache.struts2.views.velocity.components.DateTimePickerDirective
        • org.apache.struts2.views.velocity.components.TokenDirective
        • org.apache.struts2.views.velocity.components.TreeDirective
        • org.apache.struts2.views.velocity.components.TreeNodeDirective
        • org.apache.struts2.views.velocity.components.UpDownSelectDirective
        • org.apache.struts2.views.velocity.components.URLDirective
        • org.apache.struts2.views.velocity.components.WebTableDirective
    • org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction (implements com.opensymphony.xwork2.Action, java.io.Serializable)
    • org.apache.struts2.dispatcher.Dispatcher
    • org.apache.struts2.dispatcher.Dispatcher.Locator
    • org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator (implements org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator)
    • com.opensymphony.xwork2.util.DomHelper
    • com.opensymphony.xwork2.util.DomHelper.DOMBuilder (implements org.xml.sax.ContentHandler)
    • org.apache.struts2.validators.DWRValidator
    • com.opensymphony.xwork2.interceptor.ExceptionHolder
    • com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription (implements com.opensymphony.xwork2.validator.metadata.ValidatorDescription)
    • com.opensymphony.xwork2.inject.ExternalContext<T> (implements com.opensymphony.xwork2.inject.Context)
    • com.opensymphony.xwork2.util.FileManager
    • com.opensymphony.xwork2.util.FileManager.FileRevision
    • org.apache.struts2.dispatcher.FilterDispatcher (implements javax.servlet.Filter, org.apache.struts2.StrutsStatics)
      • org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61
    • org.apache.struts2.views.freemarker.FreemarkerManager
    • javax.portlet.GenericPortlet (implements javax.portlet.Portlet, javax.portlet.PortletConfig)
      • org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher (implements org.apache.struts2.portlet.PortletActionConstants, org.apache.struts2.StrutsStatics)
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • org.apache.struts2.views.JspSupportServlet
        • org.apache.struts2.portlet.context.PreparatorServlet (implements org.apache.struts2.StrutsStatics)
    • org.apache.struts2.dispatcher.HttpHeaderResult (implements com.opensymphony.xwork2.Result)
    • org.apache.struts2.portlet.util.HttpServletRequestMock (implements javax.servlet.http.HttpServletRequest)
    • com.opensymphony.xwork2.util.InstantiatingNullHandler (implements ognl.NullHandler)
    • com.opensymphony.xwork2.config.providers.InterceptorBuilder
    • com.opensymphony.xwork2.config.entities.InterceptorMapping (implements java.io.Serializable)
    • com.opensymphony.xwork2.inject.InternalContext
    • org.apache.struts2.util.InvocationSessionStore
    • org.apache.struts2.util.InvocationSessionStore.InvocationContext (implements java.io.Serializable)
    • org.apache.struts2.util.IteratorFilterSupport
      • org.apache.struts2.util.AppendIteratorFilter (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
      • org.apache.struts2.util.MergeIteratorFilter (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
      • org.apache.struts2.util.SortIteratorFilter (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
      • org.apache.struts2.util.SubsetIteratorFilter (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
    • org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator (implements java.util.Iterator<E>)
    • org.apache.struts2.util.IteratorGenerator (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
    • org.apache.struts2.views.jsp.IteratorStatus
    • org.apache.struts2.views.jsp.IteratorStatus.StatusState
    • org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest (implements org.apache.struts2.dispatcher.multipart.MultiPartRequest)
    • com.opensymphony.xwork2.inject.Key<T>
    • org.apache.struts2.config.LegacyPropertiesConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
      • org.apache.struts2.config.DefaultPropertiesProvider
    • org.apache.struts2.util.ListEntry
    • com.opensymphony.xwork2.util.LocalizedTextUtil
    • com.opensymphony.xwork2.util.LocalizedTextUtil.GetDefaultMessageReturnArg
    • com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
      • com.opensymphony.xwork2.config.entities.ActionConfig (implements com.opensymphony.xwork2.config.entities.InterceptorListHolder, com.opensymphony.xwork2.config.entities.Parameterizable, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ExceptionMappingConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.InterceptorConfig (implements com.opensymphony.xwork2.config.entities.Parameterizable, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.InterceptorStackConfig (implements com.opensymphony.xwork2.config.entities.InterceptorListHolder, java.io.Serializable)
      • com.opensymphony.xwork2.config.impl.LocatableConstantFactory<T> (implements com.opensymphony.xwork2.inject.Factory<T>)
      • com.opensymphony.xwork2.config.impl.LocatableFactory<T> (implements com.opensymphony.xwork2.inject.Factory<T>)
      • com.opensymphony.xwork2.config.entities.PackageConfig (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ResultConfig (implements com.opensymphony.xwork2.config.entities.Parameterizable, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ResultTypeConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.validator.ValidatorConfig
    • com.opensymphony.xwork2.util.location.LocationAttributes
    • com.opensymphony.xwork2.util.location.LocationAttributes.Pipe (implements org.xml.sax.ContentHandler)
    • com.opensymphony.xwork2.util.location.LocationImpl (implements com.opensymphony.xwork2.util.location.Location, java.io.Serializable)
    • com.opensymphony.xwork2.util.location.LocationUtils
    • org.apache.struts2.util.MakeIterator
    • ognl.MapPropertyAccessor (implements ognl.PropertyAccessor)
      • com.opensymphony.xwork2.util.XWorkMapPropertyAccessor
    • org.apache.struts2.interceptor.MessageStoreInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • org.apache.struts2.config.MethodConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
    • com.opensymphony.xwork2.mock.MockActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
      • com.opensymphony.xwork2.MockActionInvocation
    • com.opensymphony.xwork2.mock.MockActionProxy (implements com.opensymphony.xwork2.ActionProxy)
    • com.opensymphony.xwork2.config.impl.MockConfiguration (implements com.opensymphony.xwork2.config.Configuration)
    • com.opensymphony.xwork2.mock.MockInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • com.opensymphony.xwork2.mock.MockObjectTypeDeterminer (implements com.opensymphony.xwork2.util.ObjectTypeDeterminer)
    • com.opensymphony.xwork2.mock.MockResult (implements com.opensymphony.xwork2.Result)
    • org.apache.struts2.config.NullResult (implements com.opensymphony.xwork2.Result)
    • com.opensymphony.xwork2.ObjectFactory (implements java.io.Serializable)
      • com.opensymphony.xwork2.spring.SpringObjectFactory
        • com.opensymphony.xwork2.spring.SpringProxyableObjectFactory
      • org.apache.struts2.impl.StrutsObjectFactory
    • ognl.ObjectMethodAccessor (implements ognl.MethodAccessor)
      • com.opensymphony.xwork2.util.XWorkMethodAccessor
    • com.opensymphony.xwork2.util.profiling.ObjectProfiler
    • ognl.ObjectPropertyAccessor (implements ognl.PropertyAccessor)
      • ognl.EnumerationPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.util.XWorkEnumerationAcccessor
      • ognl.IteratorPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor
      • ognl.ListPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.util.XWorkListPropertyAccessor
      • com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor
      • ognl.SetPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor
      • com.opensymphony.xwork2.util.XWorkObjectPropertyAccessor
    • com.opensymphony.xwork2.util.ObjectProxy
    • com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor (implements ognl.PropertyAccessor)
    • com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory
    • com.opensymphony.xwork2.util.OgnlContextState
    • org.apache.struts2.views.jsp.ui.OgnlTool
    • com.opensymphony.xwork2.util.OgnlUtil
    • com.opensymphony.xwork2.util.OgnlValueStack (implements java.io.Serializable, com.opensymphony.xwork2.util.ValueStack)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.apache.struts2.util.FastByteArrayOutputStream
      • javax.servlet.ServletOutputStream
        • org.apache.struts2.components.Include.PageOutputStream
        • org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper
    • org.apache.struts2.portlet.context.PortletActionContext (implements org.apache.struts2.portlet.PortletActionConstants)
    • org.apache.struts2.portlet.interceptor.PortletPrincipalProxy (implements org.apache.struts2.interceptor.PrincipalProxy)
    • org.apache.struts2.portlet.result.PortletResult.IncludeTemplate
    • org.apache.struts2.portlet.util.PortletUrlHelper
    • com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
    • org.apache.struts2.util.PrefixTrie
    • org.apache.struts2.util.PrefixTrie.Node
    • org.apache.struts2.interceptor.debugging.PrettyPrintWriter
    • com.opensymphony.xwork2.util.profiling.ProfilingTimerBean (implements java.io.Serializable)
    • org.apache.struts2.views.xslt.ProxyNamedNodeMap (implements org.w3c.dom.NamedNodeMap)
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
          • com.opensymphony.xwork2.util.PropertiesReader
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizablePhantomReference<T> (implements com.opensymphony.xwork2.inject.util.FinalizableReference)
      • java.lang.ref.SoftReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizableSoftReference<T> (implements com.opensymphony.xwork2.inject.util.FinalizableReference)
          • com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference (implements com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference)
          • com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference (implements com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference)
      • java.lang.ref.WeakReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizableWeakReference<T> (implements com.opensymphony.xwork2.inject.util.FinalizableReference)
          • com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference (implements com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference)
          • com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference (implements com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference)
    • com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate (implements java.util.concurrent.Callable<V>)
    • com.opensymphony.xwork2.inject.util.ReferenceMap<K,V> (implements java.util.Map<K,V>, java.io.Serializable)
      • com.opensymphony.xwork2.inject.util.ReferenceCache<K,V>
    • com.opensymphony.xwork2.inject.util.ReferenceMap.Entry (implements java.util.Map.Entry<K,V>)
    • com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper
      • com.opensymphony.xwork2.inject.util.ReferenceMap.KeyReferenceAwareWrapper
    • java.lang.ref.ReferenceQueue<T>
      • com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue
    • org.apache.struts2.RequestUtils
    • com.opensymphony.xwork2.util.ResolverUtil<T>
    • com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
    • com.opensymphony.xwork2.util.ResolverUtil.IsA (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
    • com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
    • org.apache.velocity.runtime.resource.loader.ResourceLoader
      • org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader
        • org.apache.struts2.views.velocity.StrutsResourceLoader
    • org.apache.struts2.views.util.ResourceUtil
    • org.apache.struts2.dispatcher.mapper.RestfulActionMapper (implements org.apache.struts2.dispatcher.mapper.ActionMapper)
    • org.apache.struts2.portlet.context.ServletContextHolderListener (implements javax.servlet.ServletContextListener)
    • org.apache.struts2.config.ServletContextSingleton
    • org.apache.struts2.portlet.interceptor.ServletPortletPreferences (implements javax.portlet.PortletPreferences)
    • org.apache.struts2.servlet.interceptor.ServletPrincipalProxy (implements org.apache.struts2.interceptor.PrincipalProxy)
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
        • org.apache.struts2.dispatcher.StrutsRequestWrapper
          • org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • org.apache.struts2.components.Include.PageResponse
        • org.apache.struts2.util.StrutsUtil.ResponseWrapper
    • org.apache.struts2.views.xslt.ServletURIResolver (implements javax.xml.transform.URIResolver)
    • org.apache.struts2.config.Settings
      • org.apache.struts2.config.DefaultSettings
      • org.apache.struts2.config.DelegatingSettings
      • org.apache.struts2.config.PropertiesSettings
    • org.apache.struts2.views.xslt.SimpleNodeList (implements org.w3c.dom.NodeList)
    • org.apache.struts2.util.Sorter
    • org.apache.struts2.components.table.SortFilterModel.Row (implements java.lang.Comparable<T>)
    • com.opensymphony.xwork2.inject.util.Strings
    • org.apache.struts2.StrutsConstants
    • org.apache.struts2.views.freemarker.tags.StrutsModels
    • org.apache.struts2.dispatcher.StrutsResultSupport (implements com.opensymphony.xwork2.Result, org.apache.struts2.StrutsStatics)
      • org.apache.struts2.views.freemarker.FreemarkerResult
      • org.apache.struts2.dispatcher.PlainTextResult
      • org.apache.struts2.views.freemarker.PortletFreemarkerResult
      • org.apache.struts2.portlet.result.PortletResult
      • org.apache.struts2.portlet.result.PortletVelocityResult
      • org.apache.struts2.dispatcher.ServletDispatcherResult
      • org.apache.struts2.dispatcher.ServletRedirectResult
        • org.apache.struts2.dispatcher.ServletActionRedirectResult
      • org.apache.struts2.dispatcher.StreamResult
      • org.apache.struts2.dispatcher.VelocityResult
    • org.apache.struts2.util.StrutsTestCaseHelper
    • org.apache.struts2.util.StrutsUtil
      • org.apache.struts2.util.VelocityStrutsUtil
    • org.apache.struts2.util.TabbedPane
    • org.apache.struts2.views.freemarker.tags.TagModel (implements freemarker.template.TemplateTransformModel)
      • org.apache.struts2.views.freemarker.tags.ActionErrorModel
      • org.apache.struts2.views.freemarker.tags.ActionMessageModel
      • org.apache.struts2.views.freemarker.tags.ActionModel
      • org.apache.struts2.views.freemarker.tags.AnchorModel
      • org.apache.struts2.views.freemarker.tags.AutocompleterModel
      • org.apache.struts2.views.freemarker.tags.BeanModel
      • org.apache.struts2.views.freemarker.tags.CheckboxListModel
      • org.apache.struts2.views.freemarker.tags.CheckboxModel
      • org.apache.struts2.views.freemarker.tags.ComboBoxModel
      • org.apache.struts2.views.freemarker.tags.ComponentModel
      • org.apache.struts2.views.freemarker.tags.DateModel
      • org.apache.struts2.views.freemarker.tags.DivModel
      • org.apache.struts2.views.freemarker.tags.DoubleSelectModel
      • org.apache.struts2.views.freemarker.tags.ElseIfModel
      • org.apache.struts2.views.freemarker.tags.ElseModel
      • org.apache.struts2.views.freemarker.tags.FieldErrorModel
      • org.apache.struts2.views.freemarker.tags.FileModel
      • org.apache.struts2.views.freemarker.tags.FormModel
      • org.apache.struts2.views.freemarker.tags.HeadModel
      • org.apache.struts2.views.freemarker.tags.HiddenModel
      • org.apache.struts2.views.freemarker.tags.I18nModel
      • org.apache.struts2.views.freemarker.tags.IfModel
      • org.apache.struts2.views.freemarker.tags.IncludeModel
      • org.apache.struts2.views.freemarker.tags.InputTransferSelectModel
      • org.apache.struts2.views.freemarker.tags.IteratorModel
      • org.apache.struts2.views.freemarker.tags.LabelModel
      • org.apache.struts2.views.freemarker.tags.OptGroupModel
      • org.apache.struts2.views.freemarker.tags.OptionTransferSelectModel
      • org.apache.struts2.views.freemarker.tags.ParamModel
      • org.apache.struts2.views.freemarker.tags.PasswordModel
      • org.apache.struts2.views.freemarker.tags.PropertyModel
      • org.apache.struts2.views.freemarker.tags.PushModel
      • org.apache.struts2.views.freemarker.tags.RadioModel
      • org.apache.struts2.views.freemarker.tags.ResetModel
      • org.apache.struts2.views.freemarker.tags.SelectModel
      • org.apache.struts2.views.freemarker.tags.SetModel
      • org.apache.struts2.views.freemarker.tags.SubmitModel
      • org.apache.struts2.views.freemarker.tags.TabbedPanelModel
      • org.apache.struts2.views.freemarker.tags.TextAreaModel
      • org.apache.struts2.views.freemarker.tags.TextFieldModel
        • org.apache.struts2.views.freemarker.tags.DateTimePickerModel
      • org.apache.struts2.views.freemarker.tags.TextModel
      • org.apache.struts2.views.freemarker.tags.TokenModel
      • org.apache.struts2.views.freemarker.tags.TreeModel
      • org.apache.struts2.views.freemarker.tags.TreeNodeModel
      • org.apache.struts2.views.freemarker.tags.UpDownSelectModel
      • org.apache.struts2.views.freemarker.tags.URLModel
      • org.apache.struts2.views.freemarker.tags.WebTableModel
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • org.apache.struts2.views.jsp.StrutsBodyTagSupport
          • org.apache.struts2.views.jsp.ComponentTagSupport
            • org.apache.struts2.views.jsp.ui.AbstractUITag
              • org.apache.struts2.views.jsp.ui.AbstractClosingTag
                • org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
                  • org.apache.struts2.views.jsp.ui.AnchorTag
                  • org.apache.struts2.views.jsp.ui.DivTag
                • org.apache.struts2.views.jsp.ui.FormTag
                • org.apache.struts2.views.jsp.ui.TabbedPanelTag
                • org.apache.struts2.views.jsp.ui.TreeNodeTag
                • org.apache.struts2.views.jsp.ui.TreeTag
              • org.apache.struts2.views.jsp.ui.AbstractListTag
                • org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                  • org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
                    • org.apache.struts2.views.jsp.ui.DoubleSelectTag
                    • org.apache.struts2.views.jsp.ui.OptionTransferSelectTag
                  • org.apache.struts2.views.jsp.ui.CheckboxListTag
                  • org.apache.struts2.views.jsp.ui.RadioTag
                  • org.apache.struts2.views.jsp.ui.SelectTag
                    • org.apache.struts2.views.jsp.ui.UpDownSelectTag
                • org.apache.struts2.views.jsp.ui.InputTransferSelectTag
              • org.apache.struts2.views.jsp.ui.ActionErrorTag
              • org.apache.struts2.views.jsp.ui.ActionMessageTag
              • org.apache.struts2.views.jsp.ui.CheckboxTag
              • org.apache.struts2.views.jsp.ui.ComponentTag
                • org.apache.struts2.views.jsp.ui.table.WebTableTag
              • org.apache.struts2.views.jsp.ui.DateTimePickerTag
              • org.apache.struts2.views.jsp.ui.DebugTag
              • org.apache.struts2.views.jsp.ui.FieldErrorTag
              • org.apache.struts2.views.jsp.ui.FileTag
              • org.apache.struts2.views.jsp.ui.HeadTag
              • org.apache.struts2.views.jsp.ui.HiddenTag
              • org.apache.struts2.views.jsp.ui.LabelTag
              • org.apache.struts2.views.jsp.ui.ResetTag
              • org.apache.struts2.views.jsp.ui.SubmitTag
              • org.apache.struts2.views.jsp.ui.TextareaTag
              • org.apache.struts2.views.jsp.ui.TextFieldTag
                • org.apache.struts2.views.jsp.ui.ComboBoxTag
                  • org.apache.struts2.views.jsp.ui.AutocompleterTag
                • org.apache.struts2.views.jsp.ui.PasswordTag
              • org.apache.struts2.views.jsp.ui.TokenTag
            • org.apache.struts2.views.jsp.ActionTag
            • org.apache.struts2.views.jsp.iterator.AppendIteratorTag
            • org.apache.struts2.views.jsp.BeanTag
            • org.apache.struts2.views.jsp.DateTag
            • org.apache.struts2.views.jsp.ElseIfTag
            • org.apache.struts2.views.jsp.ElseTag
            • org.apache.struts2.views.jsp.I18nTag
            • org.apache.struts2.views.jsp.IfTag
            • org.apache.struts2.views.jsp.IncludeTag
            • org.apache.struts2.views.jsp.IteratorTag
            • org.apache.struts2.views.jsp.iterator.MergeIteratorTag
            • org.apache.struts2.views.jsp.ui.OptGroupTag
            • org.apache.struts2.views.jsp.ParamTag
            • org.apache.struts2.views.jsp.PropertyTag
            • org.apache.struts2.views.jsp.PushTag
            • org.apache.struts2.views.jsp.SetTag
            • org.apache.struts2.views.jsp.TextTag
            • org.apache.struts2.views.jsp.URLTag
          • org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag
          • org.apache.struts2.views.jsp.iterator.SortIteratorTag
          • org.apache.struts2.views.jsp.iterator.SubsetIteratorTag
    • org.apache.struts2.views.jsp.TagUtils
    • org.apache.struts2.components.template.Template (implements java.lang.Cloneable)
    • org.apache.struts2.components.template.TemplateEngineManager
    • org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory (implements org.apache.struts2.components.template.TemplateEngineManager.EngineFactory)
    • org.apache.struts2.components.template.TemplateRenderingContext
    • com.opensymphony.xwork2.TestNGXWorkTestCase
      • org.apache.struts2.TestNGStrutsTestCase
    • com.opensymphony.xwork2.util.TextParseUtil
    • com.opensymphony.xwork2.TextProviderFactory
    • com.opensymphony.xwork2.TextProviderSupport (implements com.opensymphony.xwork2.TextProvider)
    • org.apache.struts2.views.util.TextUtil
    • com.opensymphony.xwork2.util.TextUtils
    • java.lang.ThreadLocal<T>
      • com.opensymphony.xwork2.ActionContext.ActionContextThreadLocal
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.opensymphony.xwork2.inject.ContainerImpl.MissingDependencyException
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.inject.DependencyException
          • com.opensymphony.xwork2.InvalidMetadataException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.config.ConfigurationException
            • com.opensymphony.xwork2.config.ReferenceResolverException
            • org.apache.struts2.StrutsException (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.util.TypeConversionException
        • com.opensymphony.xwork2.validator.ValidationException
    • org.apache.struts2.util.Timer
    • com.opensymphony.xwork2.util.profiling.TimerInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • org.apache.struts2.util.TokenHelper
    • org.apache.struts2.util.URLBean
    • org.apache.struts2.views.util.UrlHelper
    • freemarker.cache.URLTemplateLoader (implements freemarker.cache.TemplateLoader)
      • org.apache.struts2.views.freemarker.StrutsClassTemplateLoader
    • com.opensymphony.xwork2.util.profiling.UtilTimerStack
    • com.opensymphony.xwork2.ValidationAwareSupport (implements java.io.Serializable, com.opensymphony.xwork2.ValidationAware)
    • com.opensymphony.xwork2.validator.ValidatorFactory
    • com.opensymphony.xwork2.validator.ValidatorFileParser
    • com.opensymphony.xwork2.validator.validators.ValidatorSupport (implements com.opensymphony.xwork2.validator.ShortCircuitableValidator, com.opensymphony.xwork2.validator.Validator)
      • com.opensymphony.xwork2.validator.validators.ExpressionValidator
      • com.opensymphony.xwork2.validator.validators.FieldValidatorSupport (implements com.opensymphony.xwork2.validator.FieldValidator)
        • com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
          • com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
          • com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
        • com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
        • com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
        • com.opensymphony.xwork2.validator.validators.RegexFieldValidator
          • com.opensymphony.xwork2.validator.validators.EmailValidator
        • com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
          • com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
        • com.opensymphony.xwork2.validator.validators.RequiredFieldValidator
        • com.opensymphony.xwork2.validator.validators.RequiredStringValidator
        • com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
        • com.opensymphony.xwork2.validator.validators.URLValidator
        • com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
    • com.opensymphony.xwork2.util.ValueStackFactory
      • com.opensymphony.xwork2.util.OgnlValueStackFactory
    • org.apache.struts2.views.velocity.VelocityManager
    • org.apache.struts2.components.table.WebTable.WebTableRowIterator (implements java.util.Iterator<E>)
    • org.apache.struts2.components.table.WebTableColumn
    • com.opensymphony.xwork2.util.WildcardHelper
    • freemarker.template.WrappingTemplateModel
      • freemarker.template.SimpleHash (implements java.io.Serializable, freemarker.template.TemplateHashModelEx)
        • org.apache.struts2.views.freemarker.ScopesHashModel
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • org.apache.struts2.views.freemarker.tags.CallbackWriter (implements freemarker.template.TransformControl)
    • com.opensymphony.xwork2.config.providers.XmlConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
      • org.apache.struts2.config.StrutsXmlConfigurationProvider
    • com.opensymphony.xwork2.config.providers.XmlHelper
    • org.apache.struts2.views.xslt.XSLTResult (implements com.opensymphony.xwork2.Result)
    • com.opensymphony.xwork2.util.XWorkTestCaseHelper

Interface Hierarchy

  • com.opensymphony.xwork2.Action
  • com.opensymphony.xwork2.ActionEventListener
  • org.apache.struts2.dispatcher.mapper.ActionMapper
  • com.opensymphony.xwork2.ActionProxy
  • com.opensymphony.xwork2.ActionProxyFactory
  • com.opensymphony.xwork2.validator.ActionValidatorManager
  • org.apache.struts2.interceptor.ApplicationAware
  • org.apache.struts2.components.table.renderer.CellRenderer
  • org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator
  • com.opensymphony.xwork2.config.ConfigurationProvider
  • com.opensymphony.xwork2.inject.ContainerBuilder.Command
  • com.opensymphony.xwork2.inject.ContainerImpl.ContextualCallable<T>
  • com.opensymphony.xwork2.inject.ContainerImpl.InjectorFactory<M>
  • com.opensymphony.xwork2.inject.Context
  • org.apache.struts2.dispatcher.mapper.DefaultActionMapper.ParameterAction
  • org.apache.struts2.dispatcher.DispatcherListener
  • com.opensymphony.xwork2.inject.Factory<T>
  • com.opensymphony.xwork2.inject.util.FinalizableReference
  • com.opensymphony.xwork2.inject.util.Function<F,T>
  • com.opensymphony.xwork2.config.entities.InterceptorListHolder
  • org.apache.struts2.util.IteratorGenerator.Converter
  • com.opensymphony.xwork2.LocaleProvider
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.ValidationAware)
  • com.opensymphony.xwork2.util.location.Locatable
  • com.opensymphony.xwork2.util.location.Location
  • com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder
  • com.opensymphony.xwork2.ModelDriven<T>
    • com.opensymphony.xwork2.interceptor.ScopedModelDriven<T>
  • org.apache.struts2.dispatcher.multipart.MultiPartRequest
  • org.w3c.dom.Node
    • org.apache.struts2.views.xslt.AdapterNode
  • com.opensymphony.xwork2.interceptor.NoParameters
    • org.apache.struts2.interceptor.NoParameters
  • org.apache.struts2.util.ObjectFactoryDestroyable
  • com.opensymphony.xwork2.util.ObjectTypeDeterminer
  • org.apache.struts2.components.Param.UnnamedParametric
  • org.apache.struts2.interceptor.ParameterAware
  • com.opensymphony.xwork2.config.entities.Parameterizable
  • com.opensymphony.xwork2.interceptor.ParameterNameAware
  • org.apache.struts2.portlet.PortletActionConstants
  • org.apache.struts2.portlet.interceptor.PortletPreferencesAware
  • com.opensymphony.xwork2.Preparable
  • com.opensymphony.xwork2.interceptor.PreResultListener
  • org.apache.struts2.interceptor.PrincipalAware
  • org.apache.struts2.interceptor.PrincipalProxy
  • com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference
  • com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy
  • org.apache.struts2.components.RemoteUICallBean
  • org.apache.struts2.interceptor.RequestAware
  • com.opensymphony.xwork2.util.ResolverUtil.Test
  • com.opensymphony.xwork2.inject.Scope.Strategy
  • java.io.Serializable
    • com.opensymphony.xwork2.ActionInvocation
    • com.opensymphony.xwork2.config.Configuration
    • com.opensymphony.xwork2.inject.Container
    • com.opensymphony.xwork2.inject.ContainerImpl.Injector
    • com.opensymphony.xwork2.interceptor.Interceptor
    • com.opensymphony.xwork2.inject.InternalFactory<T>
    • com.opensymphony.xwork2.Result
    • com.opensymphony.xwork2.config.RuntimeConfiguration
  • org.apache.struts2.util.ServletContextAware
  • org.apache.struts2.interceptor.ServletRequestAware
  • org.apache.struts2.interceptor.ServletResponseAware
  • org.apache.struts2.interceptor.SessionAware
  • com.opensymphony.xwork2.validator.ShortCircuitableValidator
  • org.apache.struts2.StrutsStatics
  • org.apache.struts2.util.SubsetIteratorFilter.Decider
  • javax.swing.table.TableModel
    • org.apache.struts2.components.table.SortableTableModel
  • org.apache.struts2.views.TagLibrary
  • org.apache.struts2.components.template.TemplateEngine
  • org.apache.struts2.components.template.TemplateEngineManager.EngineFactory
  • com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator
  • com.opensymphony.xwork2.TextProvider
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.LocaleProvider, com.opensymphony.xwork2.ValidationAware)
  • com.opensymphony.xwork2.Unchainable
  • com.opensymphony.xwork2.UnknownHandler
  • org.apache.struts2.components.URL.ExtraParameterProvider
  • com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock<T>
  • com.opensymphony.xwork2.Validateable
  • com.opensymphony.xwork2.ValidationAware
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.LocaleProvider, com.opensymphony.xwork2.TextProvider)
  • com.opensymphony.xwork2.validator.Validator
    • com.opensymphony.xwork2.validator.FieldValidator
  • com.opensymphony.xwork2.validator.metadata.ValidatorDescription
  • com.opensymphony.xwork2.util.ValueStack
  • com.opensymphony.xwork2.XWorkMessages

Annotation Type Hierarchy

  • org.apache.struts2.config.Results (implements java.lang.annotation.Annotation)
  • org.apache.struts2.config.Result (implements java.lang.annotation.Annotation)
  • org.apache.struts2.config.ParentPackage (implements java.lang.annotation.Annotation)
  • org.apache.struts2.config.Namespace (implements java.lang.annotation.Annotation)
  • org.apache.struts2.interceptor.validation.SkipValidation (implements java.lang.annotation.Annotation)
  • org.apache.struts2.views.annotations.StrutsTagAttribute (implements java.lang.annotation.Annotation)
  • org.apache.struts2.views.annotations.StrutsTag (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.conversion.annotations.Conversion (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.conversion.annotations.TypeConversion (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.inject.Inject (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.inject.Scoped (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.After (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.Before (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.BeforeResult (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.CreateIfNull (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.Element (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.Key (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.KeyProperty (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.CustomValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.EmailValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ExpressionValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RegexFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RequiredStringValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.StringRegexValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.UrlValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.Validation (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ValidationParameter (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.Validations (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.conversion.annotations.ConversionRule
      • com.opensymphony.xwork2.conversion.annotations.ConversionType
      • com.opensymphony.xwork2.inject.Scope
      • com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy (implements com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy)
      • com.opensymphony.xwork2.inject.util.ReferenceType
      • com.opensymphony.xwork2.validator.annotations.ValidatorType
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2 (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2

Main Xwork interfaces and classes.

See:
Description

Interface Summary
Action | All actions may implement this interface, which exposes the execute() method.
ActionEventListener | Provides hooks for handling key action events
ActionInvocation | An ActionInvocation represents the execution state of an Action.
ActionProxy | ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
ActionProxyFactory | The ActionProxyFactory is used to create ActionProxies to be executed.
LocaleProvider | Indicates that the implementing class can provide its own Locale.
ModelDriven<T> | ModelDriven Actions provide a model object to be pushed onto the ValueStack in addition to the Action itself, allowing a FormBean type approach like Struts.
Preparable | Preparable Actions will have their prepare() method called if the PrepareInterceptor is applied to the ActionConfig
Result | All results (except for NONE) of an Action are mapped to a View implementation.
TextProvider | Provides access to ResourceBundles and their underlying text messages.
Unchainable | Simple marker interface to indicate an object should not have it's properties copied during chaining.
UnknownHandler | Handles cases when the result or action is unknown.
Validateable | Provides an interface in which a call for a validation check can be done.
ValidationAware | ValidationAware classes can accept Action (class level) or field level error messages.
XWorkMessages | XworkMessages

Class Summary
ActionChainResult | This result invokes an entire other action, complete with it's own interceptor stack and result.
ActionContext | The ActionContext is the context in which an Action is executed.
ActionContext.ActionContextThreadLocal |
ActionSupport | Provides a default implementation for the most common actions.
DefaultActionInvocation | The Default ActionInvocation implementation
DefaultActionProxy | The Default ActionProxy implementation
DefaultActionProxyFactory | DefaultActionProxyFactory
DefaultTextProvider | DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.
MockActionInvocation | Deprecated. Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead
ObjectFactory | ObjectFactory is responsible for building the core framework objects.
ObjectFactory.ContinuationsClassLoader |
TestNGXWorkTestCase | Base test class for TestNG unit tests.
TextProviderFactory | TextProviderFactory
TextProviderSupport | Default TextProvider implementation.
ValidationAwareSupport | Provides a default implementation of ValidationAware.
XWorkTestCase | Base JUnit TestCase to extend for XWork specific JUnit tests.

Exception Summary
InvalidMetadataException | InvalidMetadataException
XWorkException | A generic runtime exception that optionally contains Location information

Package com.opensymphony.xwork2 Description

Main Xwork interfaces and classes.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


com.opensymphony.xwork2 Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.ActionChainResult (implements com.opensymphony.xwork2.Result)
    • com.opensymphony.xwork2.ActionContext (implements java.io.Serializable)
    • com.opensymphony.xwork2.ActionSupport (implements com.opensymphony.xwork2.Action, com.opensymphony.xwork2.LocaleProvider, java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Validateable, com.opensymphony.xwork2.ValidationAware)
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.opensymphony.xwork2.XWorkTestCase
    • java.lang.ClassLoader
      • com.opensymphony.xwork2.ObjectFactory.ContinuationsClassLoader
    • com.opensymphony.xwork2.DefaultActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
    • com.opensymphony.xwork2.DefaultActionProxy (implements com.opensymphony.xwork2.ActionProxy, java.io.Serializable)
    • com.opensymphony.xwork2.DefaultActionProxyFactory (implements com.opensymphony.xwork2.ActionProxyFactory)
    • com.opensymphony.xwork2.DefaultTextProvider (implements java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Unchainable)
    • com.opensymphony.xwork2.mock.MockActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
      • com.opensymphony.xwork2.MockActionInvocation
    • com.opensymphony.xwork2.ObjectFactory (implements java.io.Serializable)
    • com.opensymphony.xwork2.TestNGXWorkTestCase
    • com.opensymphony.xwork2.TextProviderFactory
    • com.opensymphony.xwork2.TextProviderSupport (implements com.opensymphony.xwork2.TextProvider)
    • java.lang.ThreadLocal<T>
      • com.opensymphony.xwork2.ActionContext.ActionContextThreadLocal
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.InvalidMetadataException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
    • com.opensymphony.xwork2.ValidationAwareSupport (implements java.io.Serializable, com.opensymphony.xwork2.ValidationAware)

Interface Hierarchy

  • com.opensymphony.xwork2.Action
  • com.opensymphony.xwork2.ActionEventListener
  • com.opensymphony.xwork2.ActionProxy
  • com.opensymphony.xwork2.ActionProxyFactory
  • com.opensymphony.xwork2.LocaleProvider
  • com.opensymphony.xwork2.ModelDriven<T>
  • com.opensymphony.xwork2.Preparable
  • java.io.Serializable
    • com.opensymphony.xwork2.ActionInvocation
    • com.opensymphony.xwork2.Result
  • com.opensymphony.xwork2.TextProvider
  • com.opensymphony.xwork2.Unchainable
  • com.opensymphony.xwork2.UnknownHandler
  • com.opensymphony.xwork2.Validateable
  • com.opensymphony.xwork2.ValidationAware
  • com.opensymphony.xwork2.XWorkMessages
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package com.opensymphony.xwork2 (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2

Packages that use com.opensymphony.xwork2
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.components |
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.impl |
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.debugging |
org.apache.struts2.interceptor.validation |
org.apache.struts2.portlet.context |
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.portlet.interceptor |
org.apache.struts2.portlet.result |
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.validators |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.velocity | Classes for views using Velocity.
org.apache.struts2.views.xslt | The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2
Action
All actions may implement this interface, which exposes the execute() method.
ActionContext
The ActionContext is the context in which an Action is executed.
ActionEventListener
Provides hooks for handling key action events
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ActionProxy
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
ActionProxyFactory
The ActionProxyFactory is used to create ActionProxies to be executed.
DefaultTextProvider
DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.
LocaleProvider
Indicates that the implementing class can provide its own Locale.
ObjectFactory
ObjectFactory is responsible for building the core framework objects.
Result
All results (except for NONE) of an Action are mapped to a View implementation.
TextProvider
Provides access to ResourceBundles and their underlying text messages.
Unchainable
Simple marker interface to indicate an object should not have it's properties copied during chaining.
UnknownHandler
Handles cases when the result or action is unknown.
Validateable
Provides an interface in which a call for a validation check can be done.
ValidationAware
ValidationAware classes can accept Action (class level) or field level error messages.
ValidationAwareSupport
Provides a default implementation of ValidationAware.
XWorkException
A generic runtime exception that optionally contains Location information

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.config
XWorkException
A generic runtime exception that optionally contains Location information

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.config.impl
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.config.providers
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.interceptor
ActionContext
The ActionContext is the context in which an Action is executed.
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ModelDriven
ModelDriven Actions provide a model object to be pushed onto the ValueStack in addition to the Action itself, allowing a FormBean type approach like Struts.
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.interceptor.annotations
ActionInvocation
An ActionInvocation represents the execution state of an Action.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.mock
ActionContext
The ActionContext is the context in which an Action is executed.
ActionEventListener
Provides hooks for handling key action events
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ActionProxy
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
Result
All results (except for NONE) of an Action are mapped to a View implementation.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.spring
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.spring.interceptor
ActionInvocation
An ActionInvocation represents the execution state of an Action.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.util
XWorkException
A generic runtime exception that optionally contains Location information

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.validator
ActionInvocation
An ActionInvocation represents the execution state of an Action.
LocaleProvider
Indicates that the implementing class can provide its own Locale.
ObjectFactory
ObjectFactory is responsible for building the core framework objects.
TextProvider
Provides access to ResourceBundles and their underlying text messages.
ValidationAware
ValidationAware classes can accept Action (class level) or field level error messages.

Classes in com.opensymphony.xwork2 used by com.opensymphony.xwork2.validator.validators
LocaleProvider
Indicates that the implementing class can provide its own Locale.
TextProvider
Provides access to ResourceBundles and their underlying text messages.
ValidationAware
ValidationAware classes can accept Action (class level) or field level error messages.

Classes in com.opensymphony.xwork2 used by org.apache.struts2
ActionContext
The ActionContext is the context in which an Action is executed.
TestNGXWorkTestCase
Base test class for TestNG unit tests.
XWorkException
A generic runtime exception that optionally contains Location information
XWorkTestCase
Base JUnit TestCase to extend for XWork specific JUnit tests.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.components
ActionProxy
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
ActionProxyFactory
The ActionProxyFactory is used to create ActionProxies to be executed.
ObjectFactory
ObjectFactory is responsible for building the core framework objects.
TextProvider
Provides access to ResourceBundles and their underlying text messages.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.config
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ObjectFactory
ObjectFactory is responsible for building the core framework objects.
Result
All results (except for NONE) of an Action are mapped to a View implementation.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.dispatcher
Action
All actions may implement this interface, which exposes the execute() method.
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ActionSupport
Provides a default implementation for the most common actions.
LocaleProvider
Indicates that the implementing class can provide its own Locale.
Result
All results (except for NONE) of an Action are mapped to a View implementation.
TextProvider
Provides access to ResourceBundles and their underlying text messages.
Validateable
Provides an interface in which a call for a validation check can be done.
ValidationAware
ValidationAware classes can accept Action (class level) or field level error messages.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.dispatcher.mapper
Result
All results (except for NONE) of an Action are mapped to a View implementation.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.impl
ActionProxy
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
ActionProxyFactory
The ActionProxyFactory is used to create ActionProxies to be executed.
DefaultActionProxy
The Default ActionProxy implementation
DefaultActionProxyFactory
DefaultActionProxyFactory
ObjectFactory
ObjectFactory is responsible for building the core framework objects.
Result
All results (except for NONE) of an Action are mapped to a View implementation.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.interceptor
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ActionProxy
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
ValidationAware
ValidationAware classes can accept Action (class level) or field level error messages.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.interceptor.debugging
ActionInvocation
An ActionInvocation represents the execution state of an Action.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.interceptor.validation
ActionInvocation
An ActionInvocation represents the execution state of an Action.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.portlet.context
ActionContext
The ActionContext is the context in which an Action is executed.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.portlet.dispatcher
Action
All actions may implement this interface, which exposes the execute() method.
ActionProxyFactory
The ActionProxyFactory is used to create ActionProxies to be executed.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.portlet.interceptor
ActionInvocation
An ActionInvocation represents the execution state of an Action.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.portlet.result
ActionInvocation
An ActionInvocation represents the execution state of an Action.
Result
All results (except for NONE) of an Action are mapped to a View implementation.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.util
Action
All actions may implement this interface, which exposes the execute() method.
ActionInvocation
An ActionInvocation represents the execution state of an Action.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.validators
ActionInvocation
An ActionInvocation represents the execution state of an Action.
ActionProxy
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
DefaultActionInvocation
The Default ActionInvocation implementation
DefaultActionProxy
The Default ActionProxy implementation
ObjectFactory
ObjectFactory is responsible for building the core framework objects.
UnknownHandler
Handles cases when the result or action is unknown.
ValidationAwareSupport
Provides a default implementation of ValidationAware.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.views.freemarker
ActionInvocation
An ActionInvocation represents the execution state of an Action.
Result
All results (except for NONE) of an Action are mapped to a View implementation.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.views.velocity
ObjectFactory
ObjectFactory is responsible for building the core framework objects.

Classes in com.opensymphony.xwork2 used by org.apache.struts2.views.xslt
ActionInvocation
An ActionInvocation represents the execution state of an Action.
Result
All results (except for NONE) of an Action are mapped to a View implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Action (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Action

All Known Implementing Classes:
ActionSupport, AppendIteratorFilter, DefaultActionSupport, DirectRenderFromEventAction, IteratorGenerator, MergeIteratorFilter, SortIteratorFilter, SubsetIteratorFilter
public interface Action

All actions may implement this interface, which exposes the execute() method. However, as of XWork 1.1, this is not required and is only here to assist users. You are free to create POJOs that honor the same contract defined by this interface without actually implementing the interface.

Field Summary
static String | ERROR The action execution was a failure.
static String | INPUT The action execution require more input in order to succeed.
static String | LOGIN The action could not execute, since the user most was not logged in.
static String | NONE The action execution was successful but do not show a view.
static String | SUCCESS The action execution was successful.
Method Summary
 String execute()
Where the logic of the action is executed.

Field Detail

SUCCESS

static final String SUCCESS
The action execution was successful. Show result view to the end user.

See Also:
Constant Field Values

NONE

static final String NONE
The action execution was successful but do not show a view. This is useful for actions that are handling the view in another fashion like redirect.

See Also:
Constant Field Values

ERROR

static final String ERROR
The action execution was a failure. Show an error view, possibly asking the user to retry entering data.

See Also:
Constant Field Values

INPUT

static final String INPUT
The action execution require more input in order to succeed. This result is typically used if a form handling action has been executed so as to provide defaults for a form. The form associated with the handler should be shown to the end user.

This result is also used if the given input params are invalid, meaning the user should try providing input again.

See Also:
Constant Field Values

LOGIN

static final String LOGIN
The action could not execute, since the user most was not logged in. The login view should be shown.

See Also:
Constant Field Values
Method Detail

execute

String execute()
               throws Exception
Where the logic of the action is executed.

Returns:
a string representing the logical result of the execution. See constants in this interface for a list of standard result values.
Throws:
Exception - thrown if a system level exception occurs. Application level exceptions should be handled by returning an error value, such as Action.ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionEventListener (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ActionEventListener

public interface ActionEventListener

Provides hooks for handling key action events

Method Summary
String | handleException(Throwable t, ValueStack stack) Called when an exception is thrown by the action
Object | prepare(Object action, ValueStack stack) Called after an action has been created.

Method Detail

prepare

Object prepare(Object action,
               ValueStack stack)
Called after an action has been created.

Parameters:
action - The action
stack - The current value stack
Returns:
The action to use

handleException

String handleException(Throwable t,
                       ValueStack stack)
Called when an exception is thrown by the action

Parameters:
t - The exception/error that was thrown
stack - The current value stack
Returns:
A result code to execute, can be null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionInvocation (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ActionInvocation

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultActionInvocation, DWRValidator.ValidatorActionInvocation, MockActionInvocation, MockActionInvocation
public interface ActionInvocation
extends Serializable

An ActionInvocation represents the execution state of an Action. It holds the Interceptors and the Action instance. By repeated re-entrant execution of the invoke() method, initially by the ActionProxy, then by the Interceptors, the Interceptors are all executed, and then the Action and the Result.

Author:
Jason Carreira
See Also:
ActionProxy

Method Summary
void | addPreResultListener(PreResultListener listener) Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
Object | getAction() Get the Action associated with this ActionInvocation
ActionContext | getInvocationContext() Gets the ActionContext associated with this ActionInvocation.
ActionProxy | getProxy() Get the ActionProxy holding this ActionInvocation
Result | getResult() If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
String | getResultCode() Gets the result code returned from this ActionInvocation
ValueStack | getStack()
String | invoke() Invokes the next step in processing this ActionInvocation.
String | invokeActionOnly() Invokes only the action (not interceptors or results).
boolean | isExecuted()
void | setActionEventListener(ActionEventListener listener) Sets the action event listener to respond to key action events
void | setResultCode(String resultCode) Sets the result code, possibly overriding the one returned by the action.

Method Detail

getAction

Object getAction()
Get the Action associated with this ActionInvocation

isExecuted

boolean isExecuted()
Returns:
whether this ActionInvocation has executed before. This will be set after the Action and the Result have executed.

getInvocationContext

ActionContext getInvocationContext()
Gets the ActionContext associated with this ActionInvocation. The ActionProxy is responsible for setting this ActionContext onto the ThreadLocal before invoking the ActionInvocation and resetting the old ActionContext afterwards.

getProxy

ActionProxy getProxy()
Get the ActionProxy holding this ActionInvocation

getResult

Result getResult()
                 throws Exception
If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned. If the ActionInvocation's result has not been executed before, the Result instance will be created and populated with the result params.

Returns:
a Result instance
Throws:
Exception

getResultCode

String getResultCode()
Gets the result code returned from this ActionInvocation

setResultCode

void setResultCode(String resultCode)
Sets the result code, possibly overriding the one returned by the action.

The "intended" purpose of this method is to allow PreResultListeners to override the result code returned by the Action.

If this method is used before the Action executes, the Action's returned result code will override what was set. However the Action could (if specifically coded to do so) inspect the ActionInvocation to see that someone "upstream" (e.g. an Interceptor) had suggested a value as the result, and it could therefore return the same value itself.

If this method is called between the Action execution and the Result execution, then the value set here will override the result code the action had returned. Creating an Interceptor that implements PreResultListener will give you this oportunity.

If this method is called after the Result has been executed, it will have the effect of raising an exception.

Throws:
IllegalStateException - if called after the Result has been executed.
See Also:
isExecuted()

getStack

ValueStack getStack()
Returns:
the ValueStack associated with this ActionInvocation

addPreResultListener

void addPreResultListener(PreResultListener listener)
Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed. The ActionInvocation implementation must guarantee that listeners will be called in the order in which they are registered. Listener registration and execution does not need to be thread-safe.

invoke

String invoke()
              throws Exception
Invokes the next step in processing this ActionInvocation. If there are more Interceptors, this will call the next one. If Interceptors choose not to short-circuit ActionInvocation processing and return their own return code, they will call invoke() to allow the next Interceptor to execute. If there are no more Interceptors to be applied, the Action is executed. If the ActionProxy getExecuteResult() method returns true, the Result is also executed.

Throws:
Exception

invokeActionOnly

String invokeActionOnly()
                        throws Exception
Invokes only the action (not interceptors or results). This is useful in rare situations where advanced usage with the interceptor/action/result workflow is being manipulated for certain functionality.

Throws:
Exception

setActionEventListener

void setActionEventListener(ActionEventListener listener)
Sets the action event listener to respond to key action events

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ActionProxy

All Known Implementing Classes:
DefaultActionProxy, DWRValidator.ValidatorActionProxy, MockActionProxy, StrutsActionProxy
public interface ActionProxy

ActionProxy is an extra layer between XWork and the action so that different proxies are possible.

An example of this would be a remote proxy, where the layer between XWork and the action might be RMI or SOAP.

Author:
Jason Carreira Created Jun 9, 2003 11:27:55 AM

Method Summary
String | execute() Execute this ActionProxy.
Object | getAction()
String | getActionName()
ActionConfig | getConfig()
boolean | getExecuteResult()
ActionInvocation | getInvocation()
String | getMethod() Returns the method to execute, or null if no method has been specified (meaning "execute" will be invoked)
String | getNamespace()
void | prepare() Called after all dependencies are set
void | setExecuteResult(boolean executeResult) Sets whether this ActionProxy should also execute the Result after executing the Action
void | setMethod(String method) Sets the method to execute for the action invocation.

Method Detail

prepare

void prepare()
             throws Exception
Called after all dependencies are set

Throws:
Exception

getAction

Object getAction()
Returns:
the Action instance for this Proxy

getActionName

String getActionName()
Returns:
the alias name this ActionProxy is mapped to

getConfig

ActionConfig getConfig()
Returns:
the ActionConfig this ActionProxy is built from

setExecuteResult

void setExecuteResult(boolean executeResult)
Sets whether this ActionProxy should also execute the Result after executing the Action

Parameters:
executeResult -

getExecuteResult

boolean getExecuteResult()
Returns:
the status of whether the ActionProxy is set to execute the Result after the Action is executed

getInvocation

ActionInvocation getInvocation()
Returns:
the ActionInvocation associated with this ActionProxy

getNamespace

String getNamespace()
Returns:
the namespace the ActionConfig for this ActionProxy is mapped to

execute

String execute()
               throws Exception
Execute this ActionProxy. This will set the ActionContext from the ActionInvocation into the ActionContext ThreadLocal before invoking the ActionInvocation, then set the old ActionContext back into the ThreadLocal.

Returns:
the result code returned from executing the ActionInvocation
Throws:
Exception
See Also:
ActionInvocation

setMethod

void setMethod(String method)
Sets the method to execute for the action invocation. If no method is specified, the method provided by in the action's configuration will be used.

Parameters:
method - the string name of the method to invoke

getMethod

String getMethod()
Returns the method to execute, or null if no method has been specified (meaning "execute" will be invoked)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionProxyFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ActionProxyFactory

All Known Implementing Classes:
DefaultActionProxyFactory, StrutsActionProxyFactory
public interface ActionProxyFactory

The ActionProxyFactory is used to create ActionProxies to be executed. It is the entry point to XWork that is used by a dispatcher to create an ActionProxy to execute for a particular namespace and action name.

Author:
Jason Carreira Created Jun 15, 2003 5:18:30 PM
See Also:
DefaultActionProxyFactory

Method Summary
ActionProxy | createActionProxy(String namespace, String actionName, Map extraContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.
ActionProxy | createActionProxy(String namespace, String actionName, Map extraContext, boolean executeResult, boolean cleanupContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.

Method Detail

createActionProxy

ActionProxy createActionProxy(String namespace,
                              String actionName,
                              Map extraContext)
                              throws Exception
Creates an ActionProxy for the given namespace and action name by looking up the configuration. The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Parameters:
namespace - the namespace of the action
actionName -
extraContext - a Map of extra parameters to be provided to the ActionProxy
Returns:
ActionProxy
Throws:
Exception

createActionProxy

ActionProxy createActionProxy(String namespace,
                              String actionName,
                              Map extraContext,
                              boolean executeResult,
                              boolean cleanupContext)
                              throws Exception
Creates an ActionProxy for the given namespace and action name by looking up the configuration. The ActionProxy should be fully initialized when it is returned, including having an ActionInvocation instance associated.

Parameters:
namespace - the namespace of the action
actionName -
extraContext - a Map of extra parameters to be provided to the ActionProxy
executeResult - flag which tells whether the result should be executed after the action
cleanupContext -
Returns:
ActionProxy
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocaleProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface LocaleProvider

All Known Subinterfaces:
ValidatorContext
All Known Implementing Classes:
ActionSupport, DefaultActionSupport, DelegatingValidatorContext, DelegatingValidatorContext.ActionContextLocaleProvider, VisitorFieldValidator.AppendingValidatorContext
public interface LocaleProvider

Indicates that the implementing class can provide its own Locale. This is useful for when an action may wish override the default locale. All that is needed is to implement this interface and return your own custom locale. The TextProvider interface uses this interface heavily for retrieving internationalized messages from resource bundles.

Author:
Jason Carreira Date: Oct 29, 2003 9:11:22 PM

Method Summary
 Locale getLocale()

Method Detail

getLocale

Locale getLocale()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ModelDriven (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ModelDriven<T>

All Known Subinterfaces:
ScopedModelDriven<T>
public interface ModelDriven<T>

ModelDriven Actions provide a model object to be pushed onto the ValueStack in addition to the Action itself, allowing a FormBean type approach like Struts.

Author:
Jason Carreira Created Apr 8, 2003 6:22:42 PM

Method Summary
 T getModel()

Method Detail

getModel

T getModel()
Returns:
the model to be pushed onto the ValueStack instead of the Action itself
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Preparable (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Preparable

public interface Preparable

Preparable Actions will have their prepare() method called if the PrepareInterceptor is applied to the ActionConfig

Author:
Jason Carreira
See Also:
Date: Nov 5, 2003 2:28:47 AM

Method Summary
 void prepare()
This method is called to allow the action to prepare itself.

Method Detail

prepare

void prepare()
             throws Exception
This method is called to allow the action to prepare itself.

Throws:
Exception - thrown if a system level exception occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Result (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Result

All Superinterfaces:
Serializable
All Known Implementing Classes:
ActionChainResult, FreemarkerResult, HttpHeaderResult, MockResult, NullResult, PlainTextResult, PortletFreemarkerResult, PortletResult, PortletVelocityResult, ServletActionRedirectResult, ServletDispatcherResult, ServletRedirectResult, StreamResult, StrutsResultSupport, VelocityResult, XSLTResult
public interface Result
extends Serializable

All results (except for NONE) of an Action are mapped to a View implementation. Examples of Views might be:

  • SwingPanelView - pops up a new Swing panel
  • ActionChainView - executes another action
  • SerlvetRedirectView - redirects the HTTP response to a URL
  • ServletDispatcherView - dispatches the HTTP response to a URL

Version:
$Revision: 1063 $
Author:
plightbo

Method Summary
 void execute(ActionInvocation invocation)
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Method Detail

execute

void execute(ActionInvocation invocation)
             throws Exception
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface TextProvider

All Known Subinterfaces:
ValidatorContext
All Known Implementing Classes:
ActionSupport, DefaultActionSupport, DefaultTextProvider, DelegatingValidatorContext, TextProviderSupport, VisitorFieldValidator.AppendingValidatorContext
public interface TextProvider

Provides access to ResourceBundles and their underlying text messages. Implementing classes can delegate TextProviderSupport. Messages will be searched in multiple resource bundles, starting with the one associated with this particular class (action in most cases), continuing to try the message bundle associated with each superclass as well. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class.

You can override LocaleProvider.getLocale() to change the behaviour of how to choose locale for the bundles that are returned. Typically you would use the LocaleProvider interface to get the users configured locale.

Author:
Jason Carreira, Rainer Hermanns
See Also:
LocaleProvider, TextProviderSupport

Method Summary
String | getText(String key) Gets a message based on a message key, or null if no message is found.
String | getText(String key, List args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String key, String defaultValue) Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String key, String defaultValue, List args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, List args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String obj) Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
ResourceBundle | getTexts() Get the resource bundle associated with the implementing class (usually an action).
ResourceBundle | getTexts(String bundleName) Get the named bundle, such as "com/acme/Foo".

Method Detail

getText

String getText(String key)
Gets a message based on a message key, or null if no message is found.

Parameters:
key - the resource bundle key that is to be searched for
Returns:
the message as found in the resource bundle, or null if none is found.

getText

String getText(String key,
               String defaultValue)
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               String defaultValue,
               String obj)
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
obj - obj to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               List args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Parameters:
key - the resource bundle key that is to be searched for
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

String getText(String key,
               String[] args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Parameters:
key - the resource bundle key that is to be searched for
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

String getText(String key,
               String defaultValue,
               List args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               String defaultValue,
               String[] args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               String defaultValue,
               List args,
               ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

String getText(String key,
               String defaultValue,
               String[] args,
               ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

ResourceBundle getTexts(String bundleName)
Get the named bundle, such as "com/acme/Foo".

Parameters:
bundleName - the name of the resource bundle, such as "com/acme/Foo"

getTexts

ResourceBundle getTexts()
Get the resource bundle associated with the implementing class (usually an action).

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Unchainable (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Unchainable

All Known Implementing Classes:
DefaultTextProvider
public interface Unchainable

Simple marker interface to indicate an object should not have it's properties copied during chaining.

See Also:
ChainingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UnknownHandler (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface UnknownHandler

public interface UnknownHandler

Handles cases when the result or action is unknown. This allows other classes like Struts plugins to provide intelligent defaults easier.

Method Summary
ActionConfig | handleUnknownAction(String namespace, String actionName) Handles the case when an action configuration is unknown.
Result | handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.

Method Detail

handleUnknownAction

ActionConfig handleUnknownAction(String namespace,
                                 String actionName)
                                 throws XWorkException
Handles the case when an action configuration is unknown. Implementations can return a new ActionConfig to be used to process the request.

Parameters:
namespace - The namespace
actionName - The action name
Returns:
An generated ActionConfig, can return null;
Throws:
XWorkException

handleUnknownResult

Result handleUnknownResult(ActionContext actionContext,
                           String actionName,
                           ActionConfig actionConfig,
                           String resultCode)
                           throws XWorkException
Handles the case when a result cannot be found for an action and result code.

Parameters:
actionContext - The action context
actionName - The action name
actionConfig - The action config
resultCode - The returned result code
Returns:
A result to be executed, can return null
Throws:
XWorkException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Validateable (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface Validateable

All Known Implementing Classes:
ActionSupport, DefaultActionSupport
public interface Validateable

Provides an interface in which a call for a validation check can be done.

Author:
Jason Carreira
See Also:
ActionSupport, DefaultWorkflowInterceptor

Method Summary
 void validate()
Performs validation.

Method Detail

validate

void validate()
Performs validation.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidationAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface ValidationAware

All Known Subinterfaces:
ValidatorContext
All Known Implementing Classes:
ActionSupport, DefaultActionSupport, DelegatingValidatorContext, DelegatingValidatorContext.LoggingValidationAware, ValidationAwareSupport, VisitorFieldValidator.AppendingValidatorContext
public interface ValidationAware

ValidationAware classes can accept Action (class level) or field level error messages. Action level messages are kept in a Collection. Field level error messages are kept in a Map from String field name to a List of field error msgs.

Version:
$Revision: 1063 $
Author:
plightbo

Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addActionMessage(String aMessage) Add an Action-level message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
Collection | getActionErrors() Get the Collection of Action-level error messages for this action.
Collection | getActionMessages() Get the Collection of Action-level messages for this action.
Map | getFieldErrors() Get the field specific errors associated with this action.
boolean | hasActionErrors() Check whether there are any Action-level error messages.
boolean | hasActionMessages() Checks whether there are any Action-level messages.
boolean | hasErrors() Note that this does not have the same meaning as in WW 1.x.
boolean | hasFieldErrors() Check whether there are any field errors associated with this action.
void | setActionErrors(Collection errorMessages) Set the Collection of Action-level String error messages.
void | setActionMessages(Collection messages) Set the Collection of Action-level String messages (not errors).
void | setFieldErrors(Map errorMap) Set the field error map of fieldname (String) to Collection of String error messages.

Method Detail

setActionErrors

void setActionErrors(Collection errorMessages)
Set the Collection of Action-level String error messages.

Parameters:
errorMessages -

getActionErrors

Collection getActionErrors()
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Returns:
Collection of String error messages

setActionMessages

void setActionMessages(Collection messages)
Set the Collection of Action-level String messages (not errors).

getActionMessages

Collection getActionMessages()
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Returns:
Collection of String messages

setFieldErrors

void setFieldErrors(Map errorMap)
Set the field error map of fieldname (String) to Collection of String error messages.

Parameters:
errorMap -

getFieldErrors

Map getFieldErrors()
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

addActionError

void addActionError(String anErrorMessage)
Add an Action-level error message to this Action.

Parameters:
anErrorMessage -

addActionMessage

void addActionMessage(String aMessage)
Add an Action-level message to this Action.

addFieldError

void addFieldError(String fieldName,
                   String errorMessage)
Add an error message for a given field.

Parameters:
fieldName - name of field
errorMessage - the error message

hasActionErrors

boolean hasActionErrors()
Check whether there are any Action-level error messages.

Returns:
true if any Action-level error messages have been registered

hasActionMessages

boolean hasActionMessages()
Checks whether there are any Action-level messages.

Returns:
true if any Action-level messages have been registered

hasErrors

boolean hasErrors()
Note that this does not have the same meaning as in WW 1.x.

Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

boolean hasFieldErrors()
Check whether there are any field errors associated with this action.

Returns:
whether there are any field errors
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkMessages (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Interface XWorkMessages

public interface XWorkMessages

XworkMessages

Author:
Jason Carreira Created Apr 20, 2003 12:10:52 AM

Field Summary
static String | ACTION_EXECUTION_ERROR
static String | DEFAULT_INVALID_FIELDVALUE
static String | MISSING_ACTION_EXCEPTION
static String | MISSING_PACKAGE_ACTION_EXCEPTION

Field Detail

ACTION_EXECUTION_ERROR

static final String ACTION_EXECUTION_ERROR
See Also:
Constant Field Values

MISSING_ACTION_EXCEPTION

static final String MISSING_ACTION_EXCEPTION
See Also:
Constant Field Values

MISSING_PACKAGE_ACTION_EXCEPTION

static final String MISSING_PACKAGE_ACTION_EXCEPTION
See Also:
Constant Field Values

DEFAULT_INVALID_FIELDVALUE

static final String DEFAULT_INVALID_FIELDVALUE
See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionChainResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ActionChainResult

java.lang.Object
    extended by  com.opensymphony.xwork2.ActionChainResult
All Implemented Interfaces:
Result, Serializable
public class ActionChainResult
extends Object
implements Result

This result invokes an entire other action, complete with it's own interceptor stack and result. This result type takes the following parameters:

  • actionName (default) - the name of the action that will be chained to
  • namespace - used to determine which namespace the Action is in that we're chaining. If namespace is null, this defaults to the current namespace
  • method - used to specify another method on target action to be invoked. If null, this defaults to execute method
  • skipActions - (optional) the list of comma separated action names for the actions that could be chained to
Example:

 <package name="public" extends="webwork-default">
     <!-- Chain creatAccount to login, using the default parameter -->
     <action name="createAccount" class="...">
         <result type="chain">login</result>
     </action>

     <action name="login" class="...">
         <!-- Chain to another namespace -->
         <result type="chain">
             <param name="actionName">dashboard</param>
             <param name="namespace">/secure</param>
         </result>
     </action>
 </package>

 <package name="secure" extends="webwork-default" namespace="/secure">
     <action name="dashboard" class="...">
         <result>dashboard.jsp</result>
     </action>
 </package>

Author:
Alexandru Popescu
See Also:
Serialized Form

Field Summary
private String | actionName
private ActionProxyFactory | actionProxyFactory
private static String | CHAIN_HISTORY The action context key to save the chain history.
static String | DEFAULT_PARAM The result parameter name to set the name of the action to chain to.
private static Log | log
private String | methodName
private String | namespace
private ActionProxy | proxy
static String | SKIP_ACTIONS_PARAM The result parameter name to set the name of the action to chain to.
private String | skipActions The list of actions to skip.
Constructor Summary
ActionChainResult()
ActionChainResult(String namespace, String actionName, String methodName)
ActionChainResult(String namespace, String actionName, String methodName, String skipActions)
Method Summary
private void | addToHistory(String namespace, String actionName, String methodName)
boolean | equals(Object o)
void | execute(ActionInvocation invocation) Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.
static LinkedList | getChainHistory() Get the XWork chain history.
ActionProxy | getProxy()
int | hashCode()
private boolean | isInChainHistory(String namespace, String actionName, String methodName)
private String | makeKey(String namespace, String actionName, String methodName)
void | setActionName(String actionName) Set the action name.
void | setActionProxyFactory(ActionProxyFactory actionProxyFactory)
void | setMethod(String method)
void | setNamespace(String namespace) sets the namespace of the Action that we're chaining to.
void | setSkipActions(String actions) Set the list of actions to skip.
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

DEFAULT_PARAM

public static final String DEFAULT_PARAM
The result parameter name to set the name of the action to chain to.

See Also:
Constant Field Values

CHAIN_HISTORY

private static final String CHAIN_HISTORY
The action context key to save the chain history.

See Also:
Constant Field Values

SKIP_ACTIONS_PARAM

public static final String SKIP_ACTIONS_PARAM
The result parameter name to set the name of the action to chain to.

See Also:
Constant Field Values

proxy

private ActionProxy proxy

actionName

private String actionName

namespace

private String namespace

methodName

private String methodName

skipActions

private String skipActions
The list of actions to skip.

actionProxyFactory

private ActionProxyFactory actionProxyFactory
Constructor Detail

ActionChainResult

public ActionChainResult()

ActionChainResult

public ActionChainResult(String namespace,
                         String actionName,
                         String methodName)

ActionChainResult

public ActionChainResult(String namespace,
                         String actionName,
                         String methodName,
                         String skipActions)
Method Detail

setActionProxyFactory

public void setActionProxyFactory(ActionProxyFactory actionProxyFactory)
Parameters:
actionProxyFactory - the actionProxyFactory to set

setActionName

public void setActionName(String actionName)
Set the action name.

Parameters:
actionName - The action name.

setNamespace

public void setNamespace(String namespace)
sets the namespace of the Action that we're chaining to. if namespace is null, this defaults to the current namespace.

Parameters:
namespace - the name of the namespace we're chaining to

setSkipActions

public void setSkipActions(String actions)
Set the list of actions to skip. To test if an action should not throe an infinite recursion, only the action name is used, not the namespace.

Parameters:
actions - The list of action name separated by a white space.

setMethod

public void setMethod(String method)

getProxy

public ActionProxy getProxy()

getChainHistory

public static LinkedList getChainHistory()
Get the XWork chain history. The stack is a list of namespace/action!method keys.

execute

public void execute(ActionInvocation invocation)
             throws Exception
Description copied from interface: Result
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Specified by:
execute in interface Result
Parameters:
invocation - the DefaultActionInvocation calling the action call stack
Throws:
Exception

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

isInChainHistory

private boolean isInChainHistory(String namespace,
                                 String actionName,
                                 String methodName)

addToHistory

private void addToHistory(String namespace,
                          String actionName,
                          String methodName)

makeKey

private String makeKey(String namespace,
                       String actionName,
                       String methodName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ActionContext

java.lang.Object
    extended by  com.opensymphony.xwork2.ActionContext
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
ServletActionContext
public class ActionContext
extends Object
implements Serializable

The ActionContext is the context in which an Action is executed. Each context is basically a container of objects an action needs for execution like the session, parameters, locale, etc.

The ActionContext is thread local which means that values stored in the ActionContext are unique per thread. See the ActionContext.ActionContextThreadLocal class for more information. The benefit of this is you don't need to worry about a user specific action context, you just get it:

    ActionContext context = ActionContext.getContext();

Finally, because of the thread local usage you don't need to worry about making your actions thread safe.

Author:
Patrick Lightbody, Bill Lynch (docs)
See Also:
Serialized Form

Nested Class Summary
private static class ActionContext.ActionContextThreadLocal
Field Summary
static String | ACTION_INVOCATION Constant for the action's invocation context.
static String | ACTION_NAME Constant for the name of the action being executed.
(package private) static ThreadLocal | actionContext
static String | APPLICATION Constant for the action's application context.
(package private) Map | context
static String | CONVERSION_ERRORS Constant for the map of type conversion errors.
static String | LOCALE Constant for the action's locale.
static String | PARAMETERS Constant for the action's parameters.
static String | SESSION Constant for the action's session.
static String | TYPE_CONVERTER Constant for the action's type converter.
static String | VALUE_STACK Constant for the OGNL value stack.
Constructor Summary
ActionContext(Map context)
Creates a new ActionContext initialized with another context.
Method Summary
Object | get(Object key) Returns a value that is stored in the current ActionContext by doing a lookup using the value's key.
ActionInvocation | getActionInvocation() Gets the action invocation (the execution state).
Map | getApplication() Returns a Map of the ServletContext when in a servlet environment or a generic application level Map otherwise.
static ActionContext | getContext() Returns the ActionContext specific to the current thread.
Map | getContextMap() Gets the context map.
Map | getConversionErrors() Gets the map of conversion errors which occurred when executing the action.
Locale | getLocale() Gets the Locale of the current action.
String | getName() Gets the name of the current Action.
Map | getParameters() Returns a Map of the HttpServletRequest parameters when in a servlet environment or a generic Map of parameters otherwise.
Map | getSession() Gets the Map of HttpSession values when in a servlet environment or a generic session map otherwise.
ValueStack | getValueStack() Gets the OGNL value stack.
void | put(Object key, Object value) Stores a value in the current ActionContext.
void | setActionInvocation(ActionInvocation actionInvocation) Sets the action invocation (the execution state).
void | setApplication(Map application) Sets the action's application context.
static void | setContext(ActionContext context) Sets the action context for the current thread.
void | setContextMap(Map contextMap) Sets the action's context map.
void | setConversionErrors(Map conversionErrors) Sets conversion errors which occurred when executing the action.
void | setLocale(Locale locale) Sets the Locale for the current action.
void | setName(String name) Sets the name of the current Action in the ActionContext.
void | setParameters(Map parameters) Sets the action parameters.
void | setSession(Map session) Sets a map of action session values.
void | setValueStack(ValueStack stack) Sets the OGNL value stack.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

actionContext

static ThreadLocal actionContext

ACTION_NAME

public static final String ACTION_NAME
Constant for the name of the action being executed.

See Also:
Constant Field Values

VALUE_STACK

public static final String VALUE_STACK
Constant for the OGNL value stack.

See Also:
Constant Field Values

SESSION

public static final String SESSION
Constant for the action's session.

See Also:
Constant Field Values

APPLICATION

public static final String APPLICATION
Constant for the action's application context.

See Also:
Constant Field Values

PARAMETERS

public static final String PARAMETERS
Constant for the action's parameters.

See Also:
Constant Field Values

LOCALE

public static final String LOCALE
Constant for the action's locale.

See Also:
Constant Field Values

TYPE_CONVERTER

public static final String TYPE_CONVERTER
Constant for the action's type converter.

See Also:
Constant Field Values

ACTION_INVOCATION

public static final String ACTION_INVOCATION
Constant for the action's invocation context.

See Also:
Constant Field Values

CONVERSION_ERRORS

public static final String CONVERSION_ERRORS
Constant for the map of type conversion errors.

See Also:
Constant Field Values

context

Map context
Constructor Detail

ActionContext

public ActionContext(Map context)
Creates a new ActionContext initialized with another context.

Parameters:
context - a context map.
Method Detail

setActionInvocation

public void setActionInvocation(ActionInvocation actionInvocation)
Sets the action invocation (the execution state).

Parameters:
actionInvocation - the action execution state.

getActionInvocation

public ActionInvocation getActionInvocation()
Gets the action invocation (the execution state).

Returns:
the action invocation (the execution state).

setApplication

public void setApplication(Map application)
Sets the action's application context.

Parameters:
application - the action's application context.

getApplication

public Map getApplication()
Returns a Map of the ServletContext when in a servlet environment or a generic application level Map otherwise.

Returns:
a Map of ServletContext or generic application level Map

setContext

public static void setContext(ActionContext context)
Sets the action context for the current thread.

Parameters:
context - the action context.

getContext

public static ActionContext getContext()
Returns the ActionContext specific to the current thread.

Returns:
the ActionContext for the current thread, is never null.

setContextMap

public void setContextMap(Map contextMap)
Sets the action's context map.

Parameters:
contextMap - the context map.

getContextMap

public Map getContextMap()
Gets the context map.

Returns:
the context map.

setConversionErrors

public void setConversionErrors(Map conversionErrors)
Sets conversion errors which occurred when executing the action.

Parameters:
conversionErrors - a Map of errors which occurred when executing the action.

getConversionErrors

public Map getConversionErrors()
Gets the map of conversion errors which occurred when executing the action.

Returns:
the map of conversion errors which occurred when executing the action or an empty map if there were no errors.

setLocale

public void setLocale(Locale locale)
Sets the Locale for the current action.

Parameters:
locale - the Locale for the current action.

getLocale

public Locale getLocale()
Gets the Locale of the current action. If no locale was ever specified the platform's default locale is used.

Returns:
the Locale of the current action.

setName

public void setName(String name)
Sets the name of the current Action in the ActionContext.

Parameters:
name - the name of the current action.

getName

public String getName()
Gets the name of the current Action.

Returns:
the name of the current action.

setParameters

public void setParameters(Map parameters)
Sets the action parameters.

Parameters:
parameters - the parameters for the current action.

getParameters

public Map getParameters()
Returns a Map of the HttpServletRequest parameters when in a servlet environment or a generic Map of parameters otherwise.

Returns:
a Map of HttpServletRequest parameters or a multipart map when in a servlet environment, or a generic Map of parameters otherwise.

setSession

public void setSession(Map session)
Sets a map of action session values.

Parameters:
session - the session values.

getSession

public Map getSession()
Gets the Map of HttpSession values when in a servlet environment or a generic session map otherwise.

Returns:
the Map of HttpSession values when in a servlet environment or a generic session map otherwise.

setValueStack

public void setValueStack(ValueStack stack)
Sets the OGNL value stack.

Parameters:
stack - the OGNL value stack.

getValueStack

public ValueStack getValueStack()
Gets the OGNL value stack.

Returns:
the OGNL value stack.

get

public Object get(Object key)
Returns a value that is stored in the current ActionContext by doing a lookup using the value's key.

Parameters:
key - the key used to find the value.
Returns:
the value that was found using the key or null if the key was not found.

put

public void put(Object key,
                Object value)
Stores a value in the current ActionContext. The value can be looked up using the key.

Parameters:
key - the key of the value.
value - the value to be stored.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionContext.ActionContextThreadLocal (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ActionContext.ActionContextThreadLocal

java.lang.Object
    extended by  java.lang.ThreadLocal
        extended by  com.opensymphony.xwork2.ActionContext.ActionContextThreadLocal
Enclosing class:
ActionContext
private static class ActionContext.ActionContextThreadLocal
extends ThreadLocal

Constructor Summary
private ActionContext.ActionContextThreadLocal()
Method Summary
protected  Object initialValue()
Methods inherited from class java.lang.ThreadLocal
get, remove, set
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionContext.ActionContextThreadLocal

private ActionContext.ActionContextThreadLocal()
Method Detail

initialValue

protected Object initialValue()
Overrides:
initialValue in class ThreadLocal
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ActionSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.ActionSupport
All Implemented Interfaces:
Action, LocaleProvider, TextProvider, Validateable, ValidationAware, Serializable
Direct Known Subclasses:
DefaultActionSupport
public class ActionSupport
extends Object
implements Action, Validateable, ValidationAware, TextProvider, LocaleProvider, Serializable

Provides a default implementation for the most common actions. See the documentation for all the interfaces this class implements for more detailed information.

See Also:
Serialized Form

Field Summary
protected static Log | LOG
private TextProvider | textProvider
private ValidationAwareSupport | validationAware
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
ActionSupport()
Method Summary
 void addActionError(String anErrorMessage)
Add an Action-level error message to this Action.
 void addActionMessage(String aMessage)
Add an Action-level message to this Action.
 void addFieldError(String fieldName, String errorMessage)
Add an error message for a given field.
 void clearErrorsAndMessages()
Clears all errors and messages.
 Object clone()
 String doDefault()
 String execute()
A default implementation that does nothing an returns "success".
 Collection getActionErrors()
Get the Collection of Action-level error messages for this action.
 Collection getActionMessages()
Get the Collection of Action-level messages for this action.
 Collection getErrorMessages()
Deprecated. Use getActionErrors().
 Map getErrors()
Deprecated. Use getFieldErrors().
 Map getFieldErrors()
Get the field specific errors associated with this action.
 Locale getLocale()
 String getText(String aTextName)
Gets a message based on a message key, or null if no message is found.
 String getText(String aTextName, List args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
 String getText(String aTextName, String defaultValue)
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
 String getText(String key, String[] args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
 String getText(String aTextName, String defaultValue, List args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 String getText(String key, String defaultValue, List args, ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 String getText(String aTextName, String defaultValue, String obj)
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 String getText(String key, String defaultValue, String[] args)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 String getText(String key, String defaultValue, String[] args, ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
 ResourceBundle getTexts()
Get the resource bundle associated with the implementing class (usually an action).
 ResourceBundle getTexts(String aBundleName)
Get the named bundle, such as "com/acme/Foo".
 boolean hasActionErrors()
Check whether there are any Action-level error messages.
 boolean hasActionMessages()
Checks whether there are any Action-level messages.
 boolean hasErrors()
Note that this does not have the same meaning as in WW 1.x.
 boolean hasFieldErrors()
Check whether there are any field errors associated with this action.
 String input()
 void pause(String result)
Stops the action invocation immediately (by throwing a PauseException) and causes the action invocation to return the specified result, such as Action.SUCCESS, Action.INPUT, etc.
 void setActionErrors(Collection errorMessages)
Set the Collection of Action-level String error messages.
 void setActionMessages(Collection messages)
Set the Collection of Action-level String messages (not errors).
 void setFieldErrors(Map errorMap)
Set the field error map of fieldname (String) to Collection of String error messages.
 void validate()
A default implementation that validates nothing.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static Log LOG

textProvider

private final transient TextProvider textProvider

validationAware

private final ValidationAwareSupport validationAware
Constructor Detail

ActionSupport

public ActionSupport()
Method Detail

setActionErrors

public void setActionErrors(Collection errorMessages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String error messages.

Specified by:
setActionErrors in interface ValidationAware

getActionErrors

public Collection getActionErrors()
Description copied from interface: ValidationAware
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionErrors in interface ValidationAware
Returns:
Collection of String error messages

setActionMessages

public void setActionMessages(Collection messages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String messages (not errors).

Specified by:
setActionMessages in interface ValidationAware

getActionMessages

public Collection getActionMessages()
Description copied from interface: ValidationAware
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionMessages in interface ValidationAware
Returns:
Collection of String messages

getErrorMessages

public Collection getErrorMessages()
Deprecated. Use getActionErrors().

getErrors

public Map getErrors()
Deprecated. Use getFieldErrors().

setFieldErrors

public void setFieldErrors(Map errorMap)
Description copied from interface: ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.

Specified by:
setFieldErrors in interface ValidationAware

getFieldErrors

public Map getFieldErrors()
Description copied from interface: ValidationAware
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getFieldErrors in interface ValidationAware
Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

getLocale

public Locale getLocale()
Specified by:
getLocale in interface LocaleProvider

getText

public String getText(String aTextName)
Description copied from interface: TextProvider
Gets a message based on a message key, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String aTextName,
                      String defaultValue)
Description copied from interface: TextProvider
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String aTextName,
                      String defaultValue,
                      String obj)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
obj - obj to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String aTextName,
                      List args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String aTextName,
                      String defaultValue,
                      List args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      List args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts()
Description copied from interface: TextProvider
Get the resource bundle associated with the implementing class (usually an action).

Specified by:
getTexts in interface TextProvider

getTexts

public ResourceBundle getTexts(String aBundleName)
Description copied from interface: TextProvider
Get the named bundle, such as "com/acme/Foo".

Specified by:
getTexts in interface TextProvider
Parameters:
aBundleName - the name of the resource bundle, such as "com/acme/Foo"

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware

addActionMessage

public void addActionMessage(String aMessage)
Description copied from interface: ValidationAware
Add an Action-level message to this Action.

Specified by:
addActionMessage in interface ValidationAware

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Parameters:
fieldName - name of field
errorMessage - the error message

input

public String input()
             throws Exception
Throws:
Exception

doDefault

public String doDefault()
                 throws Exception
Throws:
Exception

execute

public String execute()
               throws Exception
A default implementation that does nothing an returns "success".

Subclasses should override this method to provide their business logic.

See also Action.execute().

Specified by:
execute in interface Action
Returns:
returns Action.SUCCESS
Throws:
Exception - can be thrown by subclasses.

hasActionErrors

public boolean hasActionErrors()
Description copied from interface: ValidationAware
Check whether there are any Action-level error messages.

Specified by:
hasActionErrors in interface ValidationAware
Returns:
true if any Action-level error messages have been registered

hasActionMessages

public boolean hasActionMessages()
Description copied from interface: ValidationAware
Checks whether there are any Action-level messages.

Specified by:
hasActionMessages in interface ValidationAware
Returns:
true if any Action-level messages have been registered

hasErrors

public boolean hasErrors()
Description copied from interface: ValidationAware
Note that this does not have the same meaning as in WW 1.x.

Specified by:
hasErrors in interface ValidationAware
Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

public boolean hasFieldErrors()
Description copied from interface: ValidationAware
Check whether there are any field errors associated with this action.

Specified by:
hasFieldErrors in interface ValidationAware
Returns:
whether there are any field errors

clearErrorsAndMessages

public void clearErrorsAndMessages()
Clears all errors and messages. Useful for Continuations and other situations where you might want to clear parts of the state on the same action.

validate

public void validate()
A default implementation that validates nothing. Subclasses should override this method to provide validations.

Specified by:
validate in interface Validateable

clone

public Object clone()
             throws CloneNotSupportedException
Overrides:
clone in class Object
Throws:
CloneNotSupportedException

pause

public void pause(String result)
Stops the action invocation immediately (by throwing a PauseException) and causes the action invocation to return the specified result, such as Action.SUCCESS, Action.INPUT, etc.

The next time this action is invoked (and using the same continuation ID), the method will resume immediately after where this method was called, with the entire call stack in the execute method restored.

Note: this method can only be called within the execute() method.

Parameters:
result - the result to return - the same type of return value in the execute() method.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionInvocation (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultActionInvocation

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionInvocation
All Implemented Interfaces:
ActionInvocation, Serializable
Direct Known Subclasses:
DWRValidator.ValidatorActionInvocation
public class DefaultActionInvocation
extends Object
implements ActionInvocation

The Default ActionInvocation implementation

Version:
$Date: 2007-02-05 00:27:40 +0100 (Mo, 05 Feb 2007) $ $Id: DefaultActionInvocation.java 1328 2007-02-04 23:27:40Z tschneider22 $
Author:
Rainer Hermanns, tmjee
See Also:
DefaultActionProxy, Serialized Form

Field Summary
protected Object | action
protected ActionEventListener | actionEventListener
protected boolean | executed
protected Map | extraContext
protected Iterator | interceptors
protected ActionContext | invocationContext
private static Log | LOG
protected ObjectFactory | objectFactory
protected List | preResultListeners
protected ActionProxy | proxy
protected boolean | pushAction
protected Result | result
protected String | resultCode
private static long | serialVersionUID
protected ValueStack | stack
protected UnknownHandler | unknownHandler
Constructor Summary
protected | DefaultActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext)
protected | DefaultActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext, boolean pushAction)
Method Summary
void | addPreResultListener(PreResultListener listener) Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
protected void | createAction(Map contextMap)
protected Map | createContextMap()
Result | createResult()
private void | executeResult() Uses getResult to get the final Result and executes it
Object | getAction() Get the Action associated with this ActionInvocation
ActionContext | getInvocationContext() Gets the ActionContext associated with this ActionInvocation.
ActionProxy | getProxy() Get the ActionProxy holding this ActionInvocation
Result | getResult() If the DefaultActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
String | getResultCode() Gets the result code returned from this ActionInvocation
ValueStack | getStack()
private void | init()
String | invoke() Invokes the next step in processing this ActionInvocation.
protected String | invokeAction(Object action, ActionConfig actionConfig)
String | invokeActionOnly() Invokes only the action (not interceptors or results).
boolean | isExecuted()
void | setActionEventListener(ActionEventListener listener) Sets the action event listener to respond to key action events
void | setResultCode(String resultCode) Sets the result code, possibly overriding the one returned by the action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

LOG

private static final Log LOG

action

protected Object action

proxy

protected ActionProxy proxy

preResultListeners

protected List preResultListeners

extraContext

protected Map extraContext

invocationContext

protected ActionContext invocationContext

interceptors

protected Iterator interceptors

stack

protected ValueStack stack

result

protected Result result

resultCode

protected String resultCode

executed

protected boolean executed

pushAction

protected boolean pushAction

objectFactory

protected ObjectFactory objectFactory

actionEventListener

protected ActionEventListener actionEventListener

unknownHandler

protected UnknownHandler unknownHandler
Constructor Detail

DefaultActionInvocation

protected DefaultActionInvocation(ObjectFactory objectFactory,
                                  UnknownHandler handler,
                                  ActionProxy proxy,
                                  Map extraContext)
                           throws Exception
Throws:
Exception

DefaultActionInvocation

protected DefaultActionInvocation(ObjectFactory objectFactory,
                                  UnknownHandler handler,
                                  ActionProxy proxy,
                                  Map extraContext,
                                  boolean pushAction)
                           throws Exception
Throws:
Exception
Method Detail

setActionEventListener

public void setActionEventListener(ActionEventListener listener)
Description copied from interface: ActionInvocation
Sets the action event listener to respond to key action events

Specified by:
setActionEventListener in interface ActionInvocation

getAction

public Object getAction()
Description copied from interface: ActionInvocation
Get the Action associated with this ActionInvocation

Specified by:
getAction in interface ActionInvocation

isExecuted

public boolean isExecuted()
Specified by:
isExecuted in interface ActionInvocation
Returns:
whether this ActionInvocation has executed before. This will be set after the Action and the Result have executed.

getInvocationContext

public ActionContext getInvocationContext()
Description copied from interface: ActionInvocation
Gets the ActionContext associated with this ActionInvocation. The ActionProxy is responsible for setting this ActionContext onto the ThreadLocal before invoking the ActionInvocation and resetting the old ActionContext afterwards.

Specified by:
getInvocationContext in interface ActionInvocation

getProxy

public ActionProxy getProxy()
Description copied from interface: ActionInvocation
Get the ActionProxy holding this ActionInvocation

Specified by:
getProxy in interface ActionInvocation

getResult

public Result getResult()
                 throws Exception
If the DefaultActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned. If the DefaultActionInvocation's result has not been executed before, the Result instance will be created and populated with the result params.

Specified by:
getResult in interface ActionInvocation
Returns:
a Result instance
Throws:
Exception

getResultCode

public String getResultCode()
Description copied from interface: ActionInvocation
Gets the result code returned from this ActionInvocation

Specified by:
getResultCode in interface ActionInvocation

setResultCode

public void setResultCode(String resultCode)
Description copied from interface: ActionInvocation
Sets the result code, possibly overriding the one returned by the action.

The "intended" purpose of this method is to allow PreResultListeners to override the result code returned by the Action.

If this method is used before the Action executes, the Action's returned result code will override what was set. However the Action could (if specifically coded to do so) inspect the ActionInvocation to see that someone "upstream" (e.g. an Interceptor) had suggested a value as the result, and it could therefore return the same value itself.

If this method is called between the Action execution and the Result execution, then the value set here will override the result code the action had returned. Creating an Interceptor that implements PreResultListener will give you this oportunity.

If this method is called after the Result has been executed, it will have the effect of raising an exception.

Specified by:
setResultCode in interface ActionInvocation
See Also:
ActionInvocation.isExecuted()

getStack

public ValueStack getStack()
Specified by:
getStack in interface ActionInvocation
Returns:
the ValueStack associated with this ActionInvocation

addPreResultListener

public void addPreResultListener(PreResultListener listener)
Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed. The ActionInvocation implementation must guarantee that listeners will be called in the order in which they are registered. Listener registration and execution does not need to be thread-safe.

Specified by:
addPreResultListener in interface ActionInvocation
Parameters:
listener -

createResult

public Result createResult()
                    throws Exception
Throws:
Exception

invoke

public String invoke()
              throws Exception
Description copied from interface: ActionInvocation
Invokes the next step in processing this ActionInvocation. If there are more Interceptors, this will call the next one. If Interceptors choose not to short-circuit ActionInvocation processing and return their own return code, they will call invoke() to allow the next Interceptor to execute. If there are no more Interceptors to be applied, the Action is executed. If the ActionProxy getExecuteResult() method returns true, the Result is also executed.

Specified by:
invoke in interface ActionInvocation
Throws:
ConfigurationException - If no result can be found with the returned code
Exception

invokeActionOnly

public String invokeActionOnly()
                        throws Exception
Description copied from interface: ActionInvocation
Invokes only the action (not interceptors or results). This is useful in rare situations where advanced usage with the interceptor/action/result workflow is being manipulated for certain functionality.

Specified by:
invokeActionOnly in interface ActionInvocation
Throws:
Exception

createAction

protected void createAction(Map contextMap)

createContextMap

protected Map createContextMap()

executeResult

private void executeResult()
                    throws Exception
Uses getResult to get the final Result and executes it

Throws:
ConfigurationException - If not result can be found with the returned code
Exception

init

private void init()
           throws Exception
Throws:
Exception

invokeAction

protected String invokeAction(Object action,
                              ActionConfig actionConfig)
                       throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultActionProxy

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionProxy
All Implemented Interfaces:
ActionProxy, Serializable
Direct Known Subclasses:
DWRValidator.ValidatorActionProxy, StrutsActionProxy
public class DefaultActionProxy
extends Object
implements ActionProxy, Serializable

The Default ActionProxy implementation

Since:
2005-8-6
Version:
$Date: 2006-12-13 07:17:15 +0100 (Mi, 13 Dez 2006) $ $Id: DefaultActionProxy.java 1269 2006-12-13 06:17:15Z mrdon $
Author:
Rainer Hermanns, Revised by Henry Hu, tmjee
See Also:
Serialized Form

Field Summary
protected ActionEventListener | actionEventListener
protected String | actionName
protected boolean | cleanupContext
protected ActionConfig | config
protected Configuration | configuration
protected boolean | executeResult
protected Map | extraContext
protected ActionInvocation | invocation
private static Log | LOG
protected String | method
protected String | namespace
protected ObjectFactory | objectFactory
private static long | serialVersionUID
protected UnknownHandler | unknownHandler
Constructor Summary
protected DefaultActionProxy(String namespace, String actionName, Map extraContext, boolean executeResult, boolean cleanupContext)
This constructor is private so the builder methods (create*) should be used to create an DefaultActionProxy.
Method Summary
String | execute() Execute this ActionProxy.
Object | getAction()
String | getActionName()
ActionConfig | getConfig()
boolean | getExecuteResult()
ActionInvocation | getInvocation()
String | getMethod() Returns the method to execute, or null if no method has been specified (meaning "execute" will be invoked)
String | getNamespace()
void | prepare() Called after all dependencies are set
private void | resolveMethod()
void | setActionEventListener(ActionEventListener listener)
void | setConfiguration(Configuration config)
void | setExecuteResult(boolean executeResult) Sets whether this ActionProxy should also execute the Result after executing the Action
void | setMethod(String method) Sets the method to execute for the action invocation.
void | setObjectFactory(ObjectFactory factory)
void | setUnknownHandler(UnknownHandler handler)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

LOG

private static final Log LOG

configuration

protected Configuration configuration

config

protected ActionConfig config

invocation

protected ActionInvocation invocation

unknownHandler

protected UnknownHandler unknownHandler

extraContext

protected Map extraContext

actionName

protected String actionName

namespace

protected String namespace

method

protected String method

executeResult

protected boolean executeResult

cleanupContext

protected boolean cleanupContext

objectFactory

protected ObjectFactory objectFactory

actionEventListener

protected ActionEventListener actionEventListener
Constructor Detail

DefaultActionProxy

protected DefaultActionProxy(String namespace,
                             String actionName,
                             Map extraContext,
                             boolean executeResult,
                             boolean cleanupContext)
                      throws Exception
This constructor is private so the builder methods (create*) should be used to create an DefaultActionProxy.

The reason for the builder methods is so that you can use a subclass to create your own DefaultActionProxy instance (like a RMIActionProxy).

Throws:
Exception
Method Detail

setObjectFactory

public void setObjectFactory(ObjectFactory factory)

setConfiguration

public void setConfiguration(Configuration config)

setUnknownHandler

public void setUnknownHandler(UnknownHandler handler)

setActionEventListener

public void setActionEventListener(ActionEventListener listener)

getAction

public Object getAction()
Specified by:
getAction in interface ActionProxy
Returns:
the Action instance for this Proxy

getActionName

public String getActionName()
Specified by:
getActionName in interface ActionProxy
Returns:
the alias name this ActionProxy is mapped to

getConfig

public ActionConfig getConfig()
Specified by:
getConfig in interface ActionProxy
Returns:
the ActionConfig this ActionProxy is built from

setExecuteResult

public void setExecuteResult(boolean executeResult)
Description copied from interface: ActionProxy
Sets whether this ActionProxy should also execute the Result after executing the Action

Specified by:
setExecuteResult in interface ActionProxy

getExecuteResult

public boolean getExecuteResult()
Specified by:
getExecuteResult in interface ActionProxy
Returns:
the status of whether the ActionProxy is set to execute the Result after the Action is executed

getInvocation

public ActionInvocation getInvocation()
Specified by:
getInvocation in interface ActionProxy
Returns:
the ActionInvocation associated with this ActionProxy

getNamespace

public String getNamespace()
Specified by:
getNamespace in interface ActionProxy
Returns:
the namespace the ActionConfig for this ActionProxy is mapped to

execute

public String execute()
               throws Exception
Description copied from interface: ActionProxy
Execute this ActionProxy. This will set the ActionContext from the ActionInvocation into the ActionContext ThreadLocal before invoking the ActionInvocation, then set the old ActionContext back into the ThreadLocal.

Specified by:
execute in interface ActionProxy
Returns:
the result code returned from executing the ActionInvocation
Throws:
Exception
See Also:
ActionInvocation

getMethod

public String getMethod()
Description copied from interface: ActionProxy
Returns the method to execute, or null if no method has been specified (meaning "execute" will be invoked)

Specified by:
getMethod in interface ActionProxy

setMethod

public void setMethod(String method)
Description copied from interface: ActionProxy
Sets the method to execute for the action invocation. If no method is specified, the method provided by in the action's configuration will be used.

Specified by:
setMethod in interface ActionProxy
Parameters:
method - the string name of the method to invoke

resolveMethod

private void resolveMethod()

prepare

public void prepare()
             throws Exception
Description copied from interface: ActionProxy
Called after all dependencies are set

Specified by:
prepare in interface ActionProxy
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionProxyFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultActionProxyFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionProxyFactory
All Implemented Interfaces:
ActionProxyFactory
Direct Known Subclasses:
StrutsActionProxyFactory
public class DefaultActionProxyFactory
extends Object
implements ActionProxyFactory

DefaultActionProxyFactory

Author:
Jason Carreira Created Jun 15, 2003 5:19:13 PM

Field Summary
protected  Container container
Constructor Summary
DefaultActionProxyFactory()
Method Summary
ActionProxy | createActionProxy(String namespace, String actionName, Map extraContext) Use this method to build an DefaultActionProxy instance.
ActionProxy | createActionProxy(String namespace, String actionName, Map extraContext, boolean executeResult, boolean cleanupContext) Use this method to build an DefaultActionProxy instance.
void | setContainer(Container container)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

container

protected Container container
Constructor Detail

DefaultActionProxyFactory

public DefaultActionProxyFactory()
Method Detail

setContainer

public void setContainer(Container container)

createActionProxy

public ActionProxy createActionProxy(String namespace,
                                     String actionName,
                                     Map extraContext)
                              throws Exception
Use this method to build an DefaultActionProxy instance.

Specified by:
createActionProxy in interface ActionProxyFactory
Parameters:
namespace - the namespace of the action
extraContext - a Map of extra parameters to be provided to the ActionProxy
Returns:
ActionProxy
Throws:
Exception

createActionProxy

public ActionProxy createActionProxy(String namespace,
                                     String actionName,
                                     Map extraContext,
                                     boolean executeResult,
                                     boolean cleanupContext)
                              throws Exception
Use this method to build an DefaultActionProxy instance.

Specified by:
createActionProxy in interface ActionProxyFactory
Parameters:
namespace - the namespace of the action
extraContext - a Map of extra parameters to be provided to the ActionProxy
executeResult - flag which tells whether the result should be executed after the action
Returns:
ActionProxy
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultTextProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class DefaultTextProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultTextProvider
All Implemented Interfaces:
TextProvider, Unchainable, Serializable
public class DefaultTextProvider
extends Object
implements TextProvider, Serializable, Unchainable

DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.

Author:
Jason Carreira , Rainer Hermanns
See Also:
LocalizedTextUtil.addDefaultResourceBundle(String), Serialized Form

Field Summary
private static Object[] | EMPTY_ARGS
static DefaultTextProvider | INSTANCE
Constructor Summary
private DefaultTextProvider()
Method Summary
String | getText(String key) Gets a message based on a message key, or null if no message is found.
String | getText(String key, List args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String key, String defaultValue) Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String key, String defaultValue, List args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, List args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String obj) Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
ResourceBundle | getTexts() Get the resource bundle associated with the implementing class (usually an action).
ResourceBundle | getTexts(String bundleName) Get the named bundle, such as "com/acme/Foo".
private Object | readResolve()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EMPTY_ARGS

private static final Object[] EMPTY_ARGS

INSTANCE

public static final DefaultTextProvider INSTANCE
Constructor Detail

DefaultTextProvider

private DefaultTextProvider()
Method Detail

getText

public String getText(String key)
Description copied from interface: TextProvider
Gets a message based on a message key, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String defaultValue)
Description copied from interface: TextProvider
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      List args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String defaultValue,
                      List args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String obj)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
obj - obj to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      List args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts(String bundleName)
Description copied from interface: TextProvider
Get the named bundle, such as "com/acme/Foo".

Specified by:
getTexts in interface TextProvider
Parameters:
bundleName - the name of the resource bundle, such as "com/acme/Foo"

getTexts

public ResourceBundle getTexts()
Description copied from interface: TextProvider
Get the resource bundle associated with the implementing class (usually an action).

Specified by:
getTexts in interface TextProvider

readResolve

private Object readResolve()
                    throws ObjectStreamException
Throws:
ObjectStreamException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockActionInvocation (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class MockActionInvocation

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockActionInvocation
        extended by  com.opensymphony.xwork2.MockActionInvocation
All Implemented Interfaces:
ActionInvocation, Serializable
Deprecated. Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead

public class MockActionInvocation
extends MockActionInvocation

Mock for an ActionInvocation.

Author:
plightbo
See Also:
Serialized Form

Constructor Summary
MockActionInvocation()
Deprecated.
Method Summary
Methods inherited from class com.opensymphony.xwork2.mock.MockActionInvocation
addPreResultListener, getAction, getActionEventListener, getInvocationContext, getProxy, getResult, getResultCode, getStack, invoke, invokeActionOnly, isExecuted, setAction, setActionEventListener, setInvocationContext, setProxy, setResult, setResultCode, setStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MockActionInvocation

public MockActionInvocation()
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ObjectFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ObjectFactory
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
SpringObjectFactory, StrutsObjectFactory
public class ObjectFactory
extends Object
implements Serializable

ObjectFactory is responsible for building the core framework objects. Users may register their own implementation of the ObjectFactory to control instantiation of these Objects.

This default implementation uses the buildBean method to create all classes (interceptors, actions, results, etc).

To add lifecycle hook into an ObjectFactory, either or both of the following interfaces could be implemented by the ObjectFactory itself.

  • org.apache.struts2.util.ObjectFactoryInitializable
  • ObjectFactoryDestroyable
Both will be invoked during the startup and showdown of FilterDispatcher through Dispatcher.

Author:
Jason Carreira
See Also:
Serialized Form

Nested Class Summary
(package private) static class ObjectFactory.ContinuationsClassLoader
Field Summary
private ClassLoader | ccl
private Container | container
private static Log | LOG
private static ThreadLocal<ObjectFactory> | thSelf
Constructor Summary
ObjectFactory()
Method Summary
Object | buildAction(String actionName, String namespace, ActionConfig config, Map extraContext) Build an instance of the action class to handle a particular request (eg.
Object | buildBean(Class clazz, Map extraContext) Build a generic Java object of the given type.
Object | buildBean(String className, Map extraContext) Build a generic Java object of the given type.
Object | buildBean(String className, Map extraContext, boolean injectInternal) Build a generic Java object of the given type.
Interceptor | buildInterceptor(InterceptorConfig interceptorConfig, Map interceptorRefParams) Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.
Result | buildResult(ResultConfig resultConfig, Map extraContext) Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.
Validator | buildValidator(String className, Map params, Map extraContext) Build a Validator of the given type and set the parameters on it
Class | getClassInstance(String className) Utility method to obtain the class matched to className.
static ObjectFactory | getObjectFactory()
protected Object | injectInternalBeans(Object obj)
boolean | isNoArgConstructorRequired() Allows for ObjectFactory implementations that support Actions without no-arg constructors.
void | setClassLoader(ClassLoader cl)
void | setContainer(Container container)
static void | setObjectFactory(ObjectFactory factory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

ccl

private transient ClassLoader ccl

thSelf

private static ThreadLocal<ObjectFactory> thSelf

container

private Container container
Constructor Detail

ObjectFactory

public ObjectFactory()
Method Detail

setClassLoader

public void setClassLoader(ClassLoader cl)

setContainer

public void setContainer(Container container)

setObjectFactory

public static void setObjectFactory(ObjectFactory factory)

getObjectFactory

public static ObjectFactory getObjectFactory()

isNoArgConstructorRequired

public boolean isNoArgConstructorRequired()
Allows for ObjectFactory implementations that support Actions without no-arg constructors.

Returns:
true if no-arg constructor is required, false otherwise

getClassInstance

public Class getClassInstance(String className)
                       throws ClassNotFoundException
Utility method to obtain the class matched to className. Caches look ups so that subsequent lookups will be faster.

Parameters:
className - The fully qualified name of the class to return
Returns:
The class itself
Throws:
ClassNotFoundException

buildAction

public Object buildAction(String actionName,
                          String namespace,
                          ActionConfig config,
                          Map extraContext)
                   throws Exception
Build an instance of the action class to handle a particular request (eg. web request)

Parameters:
actionName - the name the action configuration is set up with in the configuration
namespace - the namespace the action is configured in
config - the action configuration found in the config for the actionName / namespace
extraContext - a Map of extra context which uses the same keys as the ActionContext
Returns:
instance of the action class to handle a web request
Throws:
Exception

buildBean

public Object buildBean(Class clazz,
                        Map extraContext)
                 throws Exception
Build a generic Java object of the given type.

Parameters:
clazz - the type of Object to build
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

injectInternalBeans

protected Object injectInternalBeans(Object obj)
Parameters:
obj -

buildBean

public Object buildBean(String className,
                        Map extraContext)
                 throws Exception
Build a generic Java object of the given type.

Parameters:
className - the type of Object to build
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

buildBean

public Object buildBean(String className,
                        Map extraContext,
                        boolean injectInternal)
                 throws Exception
Build a generic Java object of the given type.

Parameters:
className - the type of Object to build
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

buildInterceptor

public Interceptor buildInterceptor(InterceptorConfig interceptorConfig,
                                    Map interceptorRefParams)
                             throws ConfigurationException
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference. Implementations of this method should ensure that the Interceptor is parameterized with both the parameters from the Interceptor config and the interceptor ref Map (the interceptor ref params take precedence), and that the Interceptor.init() method is called on the Interceptor instance before it is returned.

Parameters:
interceptorConfig - the InterceptorConfig from the configuration
interceptorRefParams - a Map of params provided in the Interceptor reference in the Action mapping or InterceptorStack definition
Throws:
ConfigurationException

buildResult

public Result buildResult(ResultConfig resultConfig,
                          Map extraContext)
                   throws Exception
Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.

Parameters:
resultConfig - the ResultConfig found for the action with the result code returned
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

buildValidator

public Validator buildValidator(String className,
                                Map params,
                                Map extraContext)
                         throws Exception
Build a Validator of the given type and set the parameters on it

Parameters:
className - the type of Validator to build
params - property name -> value Map to set onto the Validator instance
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectFactory.ContinuationsClassLoader (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ObjectFactory.ContinuationsClassLoader

java.lang.Object
    extended by  java.lang.ClassLoader
        extended by  com.opensymphony.xwork2.ObjectFactory.ContinuationsClassLoader
Enclosing class:
ObjectFactory
static class ObjectFactory.ContinuationsClassLoader
extends ClassLoader

Constructor Summary
ObjectFactory.ContinuationsClassLoader()
Method Summary
Methods inherited from class java.lang.ClassLoader
clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findClass, findLibrary, findLoadedClass, findResource, findResources, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectFactory.ContinuationsClassLoader

ObjectFactory.ContinuationsClassLoader()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TestNGXWorkTestCase (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class TestNGXWorkTestCase

java.lang.Object
    extended by  com.opensymphony.xwork2.TestNGXWorkTestCase
Direct Known Subclasses:
TestNGStrutsTestCase
public class TestNGXWorkTestCase
extends Object

Base test class for TestNG unit tests. Provides common XWork variables and performs XWork setup and teardown processes

Field Summary
protected ActionProxyFactory | actionProxyFactory
protected Configuration | configuration
protected ConfigurationManager | configurationManager
protected Container | container
Constructor Summary
TestNGXWorkTestCase()
Method Summary
protected void | loadConfigurationProviders(ConfigurationProvider... providers)
protected void | setUp()
protected void | tearDown()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

configurationManager

protected ConfigurationManager configurationManager

configuration

protected Configuration configuration

container

protected Container container

actionProxyFactory

protected ActionProxyFactory actionProxyFactory
Constructor Detail

TestNGXWorkTestCase

public TestNGXWorkTestCase()
Method Detail

setUp

protected void setUp()
              throws Exception
Throws:
Exception

tearDown

protected void tearDown()
                 throws Exception
Throws:
Exception

loadConfigurationProviders

protected void loadConfigurationProviders(ConfigurationProvider... providers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextProviderFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class TextProviderFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.TextProviderFactory

public class TextProviderFactory
extends Object

TextProviderFactory

Author:
Oleg Gorobets

Field Summary
private static TextProvider instance
Constructor Summary
TextProviderFactory()
Method Summary
static TextProvider | getInstance()
static TextProvider | getInstance(Class clazz, LocaleProvider provider)
static TextProvider | getInstance(ResourceBundle bundle, LocaleProvider provider)
static void | setInstance(TextProvider instance)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

private static TextProvider instance
Constructor Detail

TextProviderFactory

public TextProviderFactory()
Method Detail

setInstance

public static void setInstance(TextProvider instance)
Parameters:
instance - Text provider

getInstance

public static TextProvider getInstance()

getInstance

public static TextProvider getInstance(Class clazz,
                                       LocaleProvider provider)

getInstance

public static TextProvider getInstance(ResourceBundle bundle,
                                       LocaleProvider provider)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextProviderSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class TextProviderSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.TextProviderSupport
All Implemented Interfaces:
TextProvider
public class TextProviderSupport
extends Object
implements TextProvider

Default TextProvider implementation.

Author:
Jason Carreira, Rainer Hermanns

Field Summary
private ResourceBundle | bundle
private Class | clazz
private LocaleProvider | localeProvider
Constructor Summary
TextProviderSupport()
Default constructor
TextProviderSupport(Class clazz, LocaleProvider provider)
Constructor.
TextProviderSupport(ResourceBundle bundle, LocaleProvider provider)
Constructor.
Method Summary
private Locale | getLocale() Get's the locale from the localeProvider.
String | getText(String key) Get a text from the resource bundles associated with this action.
String | getText(String key, List args) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue) Get a text from the resource bundles associated with this action.
String | getText(String key, String[] args) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue, List args) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue, List args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String arg) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue, String[] args) Get a text from the resource bundles associated with this action.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
ResourceBundle | getTexts() Get the resource bundle associated with this action.
ResourceBundle | getTexts(String aBundleName) Get the named bundle.
void | setBundle(ResourceBundle bundle)
void | setClazz(Class clazz)
void | setLocaleProvider(LocaleProvider localeProvider)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

clazz

private Class clazz

localeProvider

private LocaleProvider localeProvider

bundle

private ResourceBundle bundle
Constructor Detail

TextProviderSupport

public TextProviderSupport()
Default constructor

TextProviderSupport

public TextProviderSupport(Class clazz,
                           LocaleProvider provider)
Constructor.

Parameters:
clazz - a clazz to use for reading the resource bundle.
provider - a locale provider.

TextProviderSupport

public TextProviderSupport(ResourceBundle bundle,
                           LocaleProvider provider)
Constructor.

Parameters:
bundle - the resource bundle.
provider - a locale provider.
Method Detail

setBundle

public void setBundle(ResourceBundle bundle)
Parameters:
bundle - the resource bundle.

setClazz

public void setClazz(Class clazz)
Parameters:
clazz - a clazz to use for reading the resource bundle.

setLocaleProvider

public void setLocaleProvider(LocaleProvider localeProvider)
Parameters:
localeProvider - a locale provider.

getText

public String getText(String key)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
defaultValue - the default value which will be returned if no text is found
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue,
                      String arg)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
defaultValue - the default value which will be returned if no text is found
arg - obj to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      List args)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
args - a List of args to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      String[] args)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
args - an array of args to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue,
                      List args)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
defaultValue - the default value which will be returned if no text is found
args - a List of args to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
Get a text from the resource bundles associated with this action. The resource bundles are searched, starting with the one associated with this particular action, and testing all its superclasses' bundles. It will stop once a bundle is found that contains the given text. This gives a cascading style that allow global texts to be defined for an application base class. If no text is found for this text name, the default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - name of text to be found
defaultValue - the default value which will be returned if no text is found
args - an array of args to be used in a MessageFormat message
Returns:
value of named text

getText

public String getText(String key,
                      String defaultValue,
                      List args,
                      ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts(String aBundleName)
Get the named bundle.

You can override the getLocale() methodName to change the behaviour of how to choose locale for the bundles that are returned. Typically you would use the TextProvider interface to get the users configured locale, or use your own methodName to allow the user to select the locale and store it in the session (by using the SessionAware interface).

Specified by:
getTexts in interface TextProvider
Parameters:
aBundleName - bundle name
Returns:
a resource bundle

getTexts

public ResourceBundle getTexts()
Get the resource bundle associated with this action. This will be based on the actual subclass that is used.

Specified by:
getTexts in interface TextProvider
Returns:
resouce bundle

getLocale

private Locale getLocale()
Get's the locale from the localeProvider.

Returns:
the locale from the localeProvider.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidationAwareSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class ValidationAwareSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.ValidationAwareSupport
All Implemented Interfaces:
ValidationAware, Serializable
public class ValidationAwareSupport
extends Object
implements ValidationAware, Serializable

Provides a default implementation of ValidationAware. Returns new collections for errors and messages (defensive copy).

Version:
$Date: 2006-07-10 02:30:29 +0200 (Mo, 10 Jul 2006) $ $Id: ValidationAwareSupport.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Jason Carreira, tm_jee
See Also:
Serialized Form

Field Summary
private Collection | actionErrors
private Collection | actionMessages
private Map | fieldErrors
Constructor Summary
ValidationAwareSupport()
Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addActionMessage(String aMessage) Add an Action-level message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
void | clearErrorsAndMessages() Clears all error and messages list/maps.
Collection | getActionErrors() Get the Collection of Action-level error messages for this action.
Collection | getActionMessages() Get the Collection of Action-level messages for this action.
Map | getFieldErrors() Get the field specific errors associated with this action.
boolean | hasActionErrors() Check whether there are any Action-level error messages.
boolean | hasActionMessages() Checks whether there are any Action-level messages.
boolean | hasErrors() Note that this does not have the same meaning as in WW 1.x.
boolean | hasFieldErrors() Check whether there are any field errors associated with this action.
private Collection | internalGetActionErrors()
private Collection | internalGetActionMessages()
private Map | internalGetFieldErrors()
void | setActionErrors(Collection errorMessages) Set the Collection of Action-level String error messages.
void | setActionMessages(Collection messages) Set the Collection of Action-level String messages (not errors).
void | setFieldErrors(Map errorMap) Set the field error map of fieldname (String) to Collection of String error messages.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

actionErrors

private Collection actionErrors

actionMessages

private Collection actionMessages

fieldErrors

private Map fieldErrors
Constructor Detail

ValidationAwareSupport

public ValidationAwareSupport()
Method Detail

setActionErrors

public void setActionErrors(Collection errorMessages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String error messages.

Specified by:
setActionErrors in interface ValidationAware

getActionErrors

public Collection getActionErrors()
Description copied from interface: ValidationAware
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionErrors in interface ValidationAware
Returns:
Collection of String error messages

setActionMessages

public void setActionMessages(Collection messages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String messages (not errors).

Specified by:
setActionMessages in interface ValidationAware

getActionMessages

public Collection getActionMessages()
Description copied from interface: ValidationAware
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionMessages in interface ValidationAware
Returns:
Collection of String messages

setFieldErrors

public void setFieldErrors(Map errorMap)
Description copied from interface: ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.

Specified by:
setFieldErrors in interface ValidationAware

getFieldErrors

public Map getFieldErrors()
Description copied from interface: ValidationAware
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getFieldErrors in interface ValidationAware
Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware

addActionMessage

public void addActionMessage(String aMessage)
Description copied from interface: ValidationAware
Add an Action-level message to this Action.

Specified by:
addActionMessage in interface ValidationAware

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Parameters:
fieldName - name of field
errorMessage - the error message

hasActionErrors

public boolean hasActionErrors()
Description copied from interface: ValidationAware
Check whether there are any Action-level error messages.

Specified by:
hasActionErrors in interface ValidationAware
Returns:
true if any Action-level error messages have been registered

hasActionMessages

public boolean hasActionMessages()
Description copied from interface: ValidationAware
Checks whether there are any Action-level messages.

Specified by:
hasActionMessages in interface ValidationAware
Returns:
true if any Action-level messages have been registered

hasErrors

public boolean hasErrors()
Description copied from interface: ValidationAware
Note that this does not have the same meaning as in WW 1.x.

Specified by:
hasErrors in interface ValidationAware
Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

public boolean hasFieldErrors()
Description copied from interface: ValidationAware
Check whether there are any field errors associated with this action.

Specified by:
hasFieldErrors in interface ValidationAware
Returns:
whether there are any field errors

internalGetActionErrors

private Collection internalGetActionErrors()

internalGetActionMessages

private Collection internalGetActionMessages()

internalGetFieldErrors

private Map internalGetFieldErrors()

clearErrorsAndMessages

public void clearErrorsAndMessages()
Clears all error and messages list/maps.

Will clear the maps/lists that contain field errors, action errors and action messages.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkTestCase (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class XWorkTestCase

java.lang.Object
    extended by  junit.framework.Assert
        extended by  junit.framework.TestCase
            extended by  com.opensymphony.xwork2.XWorkTestCase
All Implemented Interfaces:
junit.framework.Test
Direct Known Subclasses:
StrutsTestCase
public abstract class XWorkTestCase
extends junit.framework.TestCase

Base JUnit TestCase to extend for XWork specific JUnit tests. Uses the generic test setup for logic.

Author:
plightbo

Field Summary
protected ActionProxyFactory | actionProxyFactory
protected Configuration | configuration
protected ConfigurationManager | configurationManager
protected Container | container
Constructor Summary
XWorkTestCase()
Method Summary
protected void | loadConfigurationProviders(ConfigurationProvider... providers)
protected void | setUp()
protected void | tearDown()
Methods inherited from class junit.framework.TestCase
countTestCases, createResult, getName, run, run, runBare, runTest, setName, toString
Methods inherited from class junit.framework.Assert
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

configurationManager

protected ConfigurationManager configurationManager

configuration

protected Configuration configuration

container

protected Container container

actionProxyFactory

protected ActionProxyFactory actionProxyFactory
Constructor Detail

XWorkTestCase

public XWorkTestCase()
Method Detail

setUp

protected void setUp()
              throws Exception
Overrides:
setUp in class junit.framework.TestCase
Throws:
Exception

tearDown

protected void tearDown()
                 throws Exception
Overrides:
tearDown in class junit.framework.TestCase
Throws:
Exception

loadConfigurationProviders

protected void loadConfigurationProviders(ConfigurationProvider... providers)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InvalidMetadataException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class InvalidMetadataException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.InvalidMetadataException
All Implemented Interfaces:
Serializable
public class InvalidMetadataException
extends RuntimeException

InvalidMetadataException

Version:
$Id: InvalidMetadataException.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns
See Also:
Serialized Form

Constructor Summary
InvalidMetadataException(String msg)
Create a new InvalidMetadataException with the supplied error message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidMetadataException

public InvalidMetadataException(String msg)
Create a new InvalidMetadataException with the supplied error message.

Parameters:
msg - the error message
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2
Class XWorkException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
All Implemented Interfaces:
Locatable, Serializable
Direct Known Subclasses:
ConfigurationException, ReferenceResolverException, StrutsException, TypeConversionException
public class XWorkException
extends RuntimeException
implements Locatable

A generic runtime exception that optionally contains Location information

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
private  Location location
Constructor Summary
XWorkException()
Constructs a XWorkException with no detail message.
XWorkException(String s)
Constructs a XWorkException with the specified detail message.
XWorkException(String s, Object target)
Constructs a XWorkException with the specified detail message and target.
XWorkException(String s, Throwable cause)
Constructs a XWorkException with the specified detail message and exception cause.
XWorkException(String s, Throwable cause, Object target)
Constructs a XWorkException with the specified detail message, cause, and target
XWorkException(Throwable cause)
Constructs a XWorkException with the root cause
XWorkException(Throwable cause, Object target)
Constructs a XWorkException with the root cause and target
Method Summary
 Location getLocation()
Gets the location of the error, if available
 Throwable getThrowable()
Deprecated. Use getCause()
 String toString()
Returns a short description of this throwable object, including the location.
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

location

private Location location
Constructor Detail

XWorkException

public XWorkException()
Constructs a XWorkException with no detail message.

XWorkException

public XWorkException(String s)
Constructs a XWorkException with the specified detail message.

Parameters:
s - the detail message.

XWorkException

public XWorkException(String s,
                      Object target)
Constructs a XWorkException with the specified detail message and target.

Parameters:
s - the detail message.
target - the target of the exception.

XWorkException

public XWorkException(Throwable cause)
Constructs a XWorkException with the root cause

Parameters:
cause - The wrapped exception

XWorkException

public XWorkException(Throwable cause,
                      Object target)
Constructs a XWorkException with the root cause and target

Parameters:
cause - The wrapped exception
target - The target of the exception

XWorkException

public XWorkException(String s,
                      Throwable cause)
Constructs a XWorkException with the specified detail message and exception cause.

Parameters:
s - the detail message.
cause - the wrapped exception

XWorkException

public XWorkException(String s,
                      Throwable cause,
                      Object target)
Constructs a XWorkException with the specified detail message, cause, and target

Parameters:
s - the detail message.
cause - The wrapped exception
target - The target of the exception
Method Detail

getThrowable

public Throwable getThrowable()
Deprecated. Use getCause()

Gets the underlying cause

getLocation

public Location getLocation()
Gets the location of the error, if available

Specified by:
getLocation in interface Locatable
Returns:
the location

toString

public String toString()
Returns a short description of this throwable object, including the location. If no detailed message is available, it will use the message of the underlying exception if available.

Overrides:
toString in class Throwable
Returns:
a string representation of this Throwable.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.config (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.config

Configuration core classes.

See:
Description

Interface Summary
Configuration | XWork configuration.
ConfigurationProvider | Interface to be implemented by all forms of XWork configuration classes.
RuntimeConfiguration | RuntimeConfiguration

Class Summary
ConfigurationManager | ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.
ConfigurationUtil | ConfigurationUtil

Exception Summary
ConfigurationException | ConfigurationException
ReferenceResolverException | Exception when a reference can't be resolved.

Package com.opensymphony.xwork2.config Description

Configuration core classes.

Overview Package Class Use Tree Deprecated Index Help


com.opensymphony.xwork2.config Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.config

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.config.ConfigurationManager
    • com.opensymphony.xwork2.config.ConfigurationUtil
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.config.ConfigurationException
            • com.opensymphony.xwork2.config.ReferenceResolverException

Interface Hierarchy

  • com.opensymphony.xwork2.config.ConfigurationProvider
  • java.io.Serializable
    • com.opensymphony.xwork2.config.Configuration
    • com.opensymphony.xwork2.config.RuntimeConfiguration


Uses of Package com.opensymphony.xwork2.config (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.config

Packages that use com.opensymphony.xwork2.config
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.util | XWork util classes.
org.apache.struts2.components |
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.impl |

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationManager
ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.config
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.
RuntimeConfiguration
RuntimeConfiguration

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.config.impl
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.
RuntimeConfiguration
RuntimeConfiguration

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.config.providers
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.mock
Configuration
XWork configuration.

Classes in com.opensymphony.xwork2.config used by com.opensymphony.xwork2.util
ConfigurationManager
ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.

Classes in com.opensymphony.xwork2.config used by org.apache.struts2.components
Configuration
XWork configuration.

Classes in com.opensymphony.xwork2.config used by org.apache.struts2.config
Configuration
XWork configuration.
ConfigurationException
ConfigurationException
ConfigurationProvider
Interface to be implemented by all forms of XWork configuration classes.

Classes in com.opensymphony.xwork2.config used by org.apache.struts2.dispatcher
ConfigurationManager
ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.

Classes in com.opensymphony.xwork2.config used by org.apache.struts2.dispatcher.mapper
ConfigurationManager
ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.

Classes in com.opensymphony.xwork2.config used by org.apache.struts2.impl
ConfigurationException
ConfigurationException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Configuration (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Interface Configuration

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultConfiguration, MockConfiguration
public interface Configuration
extends Serializable

XWork configuration.

Author:
Mike

Method Summary
void | addPackageConfig(String name, PackageConfig packageConfig)
void | destroy() Allow the Configuration to clean up any resources that have been used.
Container | getContainer()
Set<String> | getLoadedFileNames()
PackageConfig | getPackageConfig(String name)
Set | getPackageConfigNames()
Map | getPackageConfigs()
RuntimeConfiguration | getRuntimeConfiguration() The current runtime configuration.
void | rebuildRuntimeConfiguration()
void | reload(List<ConfigurationProvider> providers)
void | removePackageConfig(String name)

Method Detail

rebuildRuntimeConfiguration

void rebuildRuntimeConfiguration()

getPackageConfig

PackageConfig getPackageConfig(String name)

getPackageConfigNames

Set getPackageConfigNames()

getPackageConfigs

Map getPackageConfigs()

getRuntimeConfiguration

RuntimeConfiguration getRuntimeConfiguration()
The current runtime configuration. Currently, if changes have been made to the Configuration since the last time buildRuntimeConfiguration() was called, you'll need to make sure to.

Returns:
the current runtime configuration

addPackageConfig

void addPackageConfig(String name,
                      PackageConfig packageConfig)

destroy

void destroy()
Allow the Configuration to clean up any resources that have been used.

reload

void reload(List<ConfigurationProvider> providers)
            throws ConfigurationException
Throws:
ConfigurationException

removePackageConfig

void removePackageConfig(String name)

getContainer

Container getContainer()
Returns:
the container

getLoadedFileNames

Set<String> getLoadedFileNames()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConfigurationProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Interface ConfigurationProvider

All Known Implementing Classes:
BeanSelectionProvider, ClasspathConfigurationProvider, DefaultPropertiesProvider, LegacyPropertiesConfigurationProvider, MethodConfigurationProvider, StrutsXmlConfigurationProvider, XmlConfigurationProvider
public interface ConfigurationProvider

Interface to be implemented by all forms of XWork configuration classes.

Version:
$Revision: 1213 $
Author:
$Author: mrdon $

Method Summary
void | destroy()
void | init(Configuration configuration)
void | loadPackages()
boolean | needsReload() Tells whether the ConfigurationProvider should reload its configuration
void | register(ContainerBuilder builder, LocatableProperties props)

Method Detail

destroy

void destroy()

init

void init(Configuration configuration)
          throws ConfigurationException
Throws:
ConfigurationException

register

void register(ContainerBuilder builder,
              LocatableProperties props)
              throws ConfigurationException
Throws:
ConfigurationException

loadPackages

void loadPackages()
                  throws ConfigurationException
Throws:
ConfigurationException

needsReload

boolean needsReload()
Tells whether the ConfigurationProvider should reload its configuration

Returns:
true, whether the ConfigurationProvider should reload its configuration, falseotherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RuntimeConfiguration (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Interface RuntimeConfiguration

All Superinterfaces:
Serializable
All Known Implementing Classes:
DefaultConfiguration.RuntimeConfigurationImpl
public interface RuntimeConfiguration
extends Serializable

RuntimeConfiguration

Author:
Jason Carreira Created Feb 25, 2003 10:56:02 PM

Method Summary
ActionConfig | getActionConfig(String namespace, String name) get the fully expanded ActionConfig for a specified namespace and (action) name
Map | getActionConfigs() returns a Map of all the registered ActionConfigs.

Method Detail

getActionConfig

ActionConfig getActionConfig(String namespace,
                             String name)
get the fully expanded ActionConfig for a specified namespace and (action) name

Parameters:
namespace - the namespace of the Action. if this is null, then the empty namespace, "", will be used
name - the name of the Action. may not be null.
Returns:
the requested ActionConfig or null if there was no ActionConfig associated with the specified namespace and name

getActionConfigs

Map getActionConfigs()
returns a Map of all the registered ActionConfigs. Again, these ActionConfigs are fully expanded so that any inherited interceptors, results, etc. will be included

Returns:
a Map of Map keyed by namespace and name respectively such that
                 ActionConfig config = (ActionConfig)((Map)getActionConfigs.get(namespace)).get(name);
should return a valid config for valid namespace/name pairs
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConfigurationManager (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Class ConfigurationManager

java.lang.Object
    extended by  com.opensymphony.xwork2.config.ConfigurationManager

public class ConfigurationManager
extends Object

ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.

Version:
$Date: 2006-11-18 07:59:15 +0100 (Sa, 18 Nov 2006) $ $Id: ConfigurationManager.java 1218 2006-11-18 06:59:15Z tm_jee $
Author:
Jason Carreira, tm_jee

Field Summary
protected Configuration | configuration
private List<ConfigurationProvider> | configurationProviders
protected String | defaultFrameworkBeanName
protected static Log | LOG
protected Lock | providerLock
Constructor Summary
ConfigurationManager()
ConfigurationManager(String name)
Method Summary
void | addConfigurationProvider(ConfigurationProvider provider) adds a configuration provider to the List of ConfigurationProviders.
void | clearConfigurationProviders() clears the registered ConfigurationProviders.
void | conditionalReload() Reloads the Configuration files if the configuration files indicate that they need to be reloaded.
void | destroyConfiguration() Destroy its managing Configuration instance
Configuration | getConfiguration() Get the current XWork configuration object.
List<ConfigurationProvider> | getConfigurationProviders() Get the current list of ConfigurationProviders.
void | reload()
void | setConfiguration(Configuration configuration)
void | setConfigurationProviders(List<ConfigurationProvider> configurationProviders) Set the list of configuration providers
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Log LOG

configuration

protected Configuration configuration

providerLock

protected Lock providerLock

configurationProviders

private List<ConfigurationProvider> configurationProviders

defaultFrameworkBeanName

protected String defaultFrameworkBeanName
Constructor Detail

ConfigurationManager

public ConfigurationManager()

ConfigurationManager

public ConfigurationManager(String name)
Method Detail

getConfiguration

public Configuration getConfiguration()
Get the current XWork configuration object. By default an instance of DefaultConfiguration will be returned

See Also:
DefaultConfiguration

setConfiguration

public void setConfiguration(Configuration configuration)

getConfigurationProviders

public List<ConfigurationProvider> getConfigurationProviders()
Get the current list of ConfigurationProviders. If no custom ConfigurationProviders have been added, this method will return a list containing only the default ConfigurationProvider, XMLConfigurationProvider. if a custom ConfigurationProvider has been added, then the XmlConfigurationProvider must be added by hand.

TODO: the lazy instantiation of XmlConfigurationProvider should be refactored to be elsewhere. the behavior described above seems unintuitive.

Returns:
the list of registered ConfigurationProvider objects
See Also:
ConfigurationProvider

setConfigurationProviders

public void setConfigurationProviders(List<ConfigurationProvider> configurationProviders)
Set the list of configuration providers

Parameters:
configurationProviders -

addConfigurationProvider

public void addConfigurationProvider(ConfigurationProvider provider)
adds a configuration provider to the List of ConfigurationProviders. a given ConfigurationProvider may be added more than once

Parameters:
provider - the ConfigurationProvider to register

clearConfigurationProviders

public void clearConfigurationProviders()
clears the registered ConfigurationProviders. this method will call destroy() on each of the registered ConfigurationProviders

See Also:
ConfigurationProvider.destroy()

destroyConfiguration

public void destroyConfiguration()
Destroy its managing Configuration instance

conditionalReload

public void conditionalReload()
Reloads the Configuration files if the configuration files indicate that they need to be reloaded.

reload

public void reload()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConfigurationUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Class ConfigurationUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.config.ConfigurationUtil

public class ConfigurationUtil
extends Object

ConfigurationUtil

Author:
Jason Carreira Created May 23, 2003 11:22:49 PM

Field Summary
private static Log LOG
Constructor Summary
private ConfigurationUtil()
Method Summary
static List buildParentsFromString(Configuration configuration, String parent)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG
Constructor Detail

ConfigurationUtil

private ConfigurationUtil()
Method Detail

buildParentsFromString

public static List buildParentsFromString(Configuration configuration,
                                          String parent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConfigurationException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Class ConfigurationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
                    extended by  com.opensymphony.xwork2.config.ConfigurationException
All Implemented Interfaces:
Locatable, Serializable
public class ConfigurationException
extends XWorkException

ConfigurationException

Author:
Jason Carreira
See Also:
Serialized Form

Constructor Summary
ConfigurationException()
Constructs a ConfigurationException with no detail message.
ConfigurationException(String s)
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String s, Object target)
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String s, Throwable cause)
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String s, Throwable cause, Object target)
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(Throwable cause)
Constructs a ConfigurationException with no detail message.
ConfigurationException(Throwable cause, Object target)
Constructs a ConfigurationException with no detail message.
Method Summary
Methods inherited from class com.opensymphony.xwork2.XWorkException
getLocation, getThrowable, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ConfigurationException

public ConfigurationException()
Constructs a ConfigurationException with no detail message.

ConfigurationException

public ConfigurationException(String s)
Constructs a ConfigurationException with the specified detail message.

Parameters:
s - the detail message.

ConfigurationException

public ConfigurationException(String s,
                              Object target)
Constructs a ConfigurationException with the specified detail message.

Parameters:
s - the detail message.

ConfigurationException

public ConfigurationException(Throwable cause)
Constructs a ConfigurationException with no detail message.

ConfigurationException

public ConfigurationException(Throwable cause,
                              Object target)
Constructs a ConfigurationException with no detail message.

ConfigurationException

public ConfigurationException(String s,
                              Throwable cause)
Constructs a ConfigurationException with the specified detail message.

Parameters:
s - the detail message.

ConfigurationException

public ConfigurationException(String s,
                              Throwable cause,
                              Object target)
Constructs a ConfigurationException with the specified detail message.

Parameters:
s - the detail message.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceResolverException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config
Class ReferenceResolverException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
                    extended by  com.opensymphony.xwork2.config.ReferenceResolverException
All Implemented Interfaces:
Locatable, Serializable
public class ReferenceResolverException
extends XWorkException

Exception when a reference can't be resolved.

Author:
Mike
See Also:
Serialized Form

Constructor Summary
ReferenceResolverException()
ReferenceResolverException(String s)
ReferenceResolverException(String s, Throwable cause)
ReferenceResolverException(Throwable cause)
Method Summary
Methods inherited from class com.opensymphony.xwork2.XWorkException
getLocation, getThrowable, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ReferenceResolverException

public ReferenceResolverException()

ReferenceResolverException

public ReferenceResolverException(String s)

ReferenceResolverException

public ReferenceResolverException(String s,
                                  Throwable cause)

ReferenceResolverException

public ReferenceResolverException(Throwable cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.config.entities (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.config.entities

Configuration entity classes.

See:
Description

Interface Summary
InterceptorListHolder | InterceptorListHolder
Parameterizable | Actions implementing Parameterizable will receive a map of the static parameters defined in the action configuration.

Class Summary
ActionConfig | Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
ExceptionMappingConfig | Configuration for exception mapping.
InterceptorConfig | Configuration for Interceptors.
InterceptorMapping | InterceptorMapping
InterceptorStackConfig | Configuration for InterceptorStack.
PackageConfig | Configuration for Package.
ResultConfig | Configuration for Result.
ResultTypeConfig | Configuration class for result types.

Package com.opensymphony.xwork2.config.entities Description

Configuration entity classes.


com.opensymphony.xwork2.config.entities Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.config.entities

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.config.entities.InterceptorMapping (implements java.io.Serializable)
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
      • com.opensymphony.xwork2.config.entities.ActionConfig (implements com.opensymphony.xwork2.config.entities.InterceptorListHolder, com.opensymphony.xwork2.config.entities.Parameterizable, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ExceptionMappingConfig (implements java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.InterceptorConfig (implements com.opensymphony.xwork2.config.entities.Parameterizable, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.InterceptorStackConfig (implements com.opensymphony.xwork2.config.entities.InterceptorListHolder, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.PackageConfig (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ResultConfig (implements com.opensymphony.xwork2.config.entities.Parameterizable, java.io.Serializable)
      • com.opensymphony.xwork2.config.entities.ResultTypeConfig (implements java.io.Serializable)

Interface Hierarchy

  • com.opensymphony.xwork2.config.entities.InterceptorListHolder
  • com.opensymphony.xwork2.config.entities.Parameterizable


Uses of Package com.opensymphony.xwork2.config.entities (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.config.entities

Packages that use com.opensymphony.xwork2.config.entities
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.impl |
org.apache.struts2.validators |

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
InterceptorConfig
Configuration for Interceptors.
ResultConfig
Configuration for Result.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.config
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
PackageConfig
Configuration for Package.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.config.entities
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
ExceptionMappingConfig
Configuration for exception mapping.
InterceptorConfig
Configuration for Interceptors.
InterceptorListHolder
InterceptorListHolder
InterceptorMapping
InterceptorMapping
InterceptorStackConfig
Configuration for InterceptorStack.
PackageConfig
Configuration for Package.
Parameterizable

Actions implementing Parameterizable will receive a map of the static parameters defined in the action configuration.

ResultConfig
Configuration for Result.
ResultTypeConfig
Configuration class for result types.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.config.impl
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
PackageConfig
Configuration for Package.
ResultConfig
Configuration for Result.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.config.providers
InterceptorMapping
InterceptorMapping
InterceptorStackConfig
Configuration for InterceptorStack.
PackageConfig
Configuration for Package.

Classes in com.opensymphony.xwork2.config.entities used by com.opensymphony.xwork2.mock
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.

Classes in com.opensymphony.xwork2.config.entities used by org.apache.struts2.config
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
PackageConfig
Configuration for Package.
ResultConfig
Configuration for Result.

Classes in com.opensymphony.xwork2.config.entities used by org.apache.struts2.impl
InterceptorConfig
Configuration for Interceptors.
ResultConfig
Configuration for Result.

Classes in com.opensymphony.xwork2.config.entities used by org.apache.struts2.validators
ActionConfig
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


InterceptorListHolder (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Interface InterceptorListHolder

All Known Implementing Classes:
ActionConfig, InterceptorStackConfig
public interface InterceptorListHolder

InterceptorListHolder

Author:
Jason Carreira Created Jun 1, 2003 1:02:48 AM

Method Summary
void | addInterceptor(InterceptorMapping interceptor)
void | addInterceptors(List<InterceptorMapping> interceptors)

Method Detail

addInterceptor

void addInterceptor(InterceptorMapping interceptor)

addInterceptors

void addInterceptors(List<InterceptorMapping> interceptors)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Parameterizable (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Interface Parameterizable

All Known Implementing Classes:
ActionConfig, InterceptorConfig, ResultConfig
public interface Parameterizable

Actions implementing Parameterizable will receive a map of the static parameters defined in the action configuration.

The StaticParametersInterceptor must be in the action's interceptor queue for this to work.

Author:
Jason Carreira

Method Summary
void | addParam(String name, Object value)
Map | getParams()
void | setParams(Map<String,Object> params)

Method Detail

addParam

void addParam(String name,
              Object value)

setParams

void setParams(Map<String,Object> params)

getParams

Map getParams()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionConfig (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ActionConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.ActionConfig
All Implemented Interfaces:
InterceptorListHolder, Parameterizable, Locatable, Serializable
public class ActionConfig
extends Located
implements InterceptorListHolder, Parameterizable, Serializable

Contains everything needed to configure and execute an action:

  • methodName - the method name to execute on the action. If this is null, the Action will be cast to the Action Interface and the execute() method called
  • clazz - the class name for the action
  • params - the params to be set for this action just before execution
  • results - the result map {String -> View class}
  • resultParameters - params for results {String -> Map}
  • typeConverter - the Ognl TypeConverter to use when getting/setting properties

Version:
$Revision: 1212 $
Author:
Mike, Rainer Hermanns
See Also:
Serialized Form

Field Summary
protected String | className
protected List<ExceptionMappingConfig> | exceptionMappings
protected List<InterceptorMapping> | interceptors
protected String | methodName
protected String | packageName
protected Map<String,Object> | params
protected Map<String,ResultConfig> | results
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
ActionConfig()
ActionConfig(String methodName, Class clazz, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, Class clazz, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
ActionConfig(String methodName, String className, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, String className, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
ActionConfig(String methodName, String className, String packageName, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, String className, String packageName, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
Method Summary
void | addExceptionMapping(ExceptionMappingConfig exceptionMapping)
void | addExceptionMappings(List<? extends ExceptionMappingConfig> mappings)
void | addInterceptor(InterceptorMapping interceptor)
void | addInterceptors(List<InterceptorMapping> interceptors)
void | addParam(String name, Object value)
void | addResultConfig(ResultConfig resultConfig)
boolean | equals(Object o)
String | getClassName()
List<ExceptionMappingConfig> | getExceptionMappings()
List<InterceptorMapping> | getInterceptors()
String | getMethodName() Returns name of the action method
String | getPackageName()
Map<String,Object> | getParams()
Map<String,ResultConfig> | getResults()
int | hashCode()
void | setClassName(String className)
void | setMethodName(String methodName)
void | setPackageName(String packageName)
void | setParams(Map<String,Object> params)
void | setResults(Map<String,ResultConfig> results)
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

interceptors

protected List<InterceptorMapping> interceptors

params

protected Map<String,Object> params

results

protected Map<String,ResultConfig> results

exceptionMappings

protected List<ExceptionMappingConfig> exceptionMappings

className

protected String className

methodName

protected String methodName

packageName

protected String packageName
Constructor Detail

ActionConfig

public ActionConfig()

ActionConfig

public ActionConfig(String methodName,
                    Class clazz,
                    Map<String,Object> parameters,
                    Map<String,ResultConfig> results,
                    List<InterceptorMapping> interceptors)

ActionConfig

public ActionConfig(String methodName,
                    Class clazz,
                    Map<String,Object> parameters,
                    Map<String,ResultConfig> results,
                    List<InterceptorMapping> interceptors,
                    List<ExceptionMappingConfig> exceptionMappings)

ActionConfig

public ActionConfig(String methodName,
                    String className,
                    Map<String,Object> parameters,
                    Map<String,ResultConfig> results,
                    List<InterceptorMapping> interceptors)

ActionConfig

public ActionConfig(String methodName,
                    String className,
                    Map<String,Object> parameters,
                    Map<String,ResultConfig> results,
                    List<InterceptorMapping> interceptors,
                    List<ExceptionMappingConfig> exceptionMappings)

ActionConfig

public ActionConfig(String methodName,
                    String className,
                    String packageName,
                    Map<String,Object> parameters,
                    Map<String,ResultConfig> results,
                    List<InterceptorMapping> interceptors)

ActionConfig

public ActionConfig(String methodName,
                    String className,
                    String packageName,
                    Map<String,Object> parameters,
                    Map<String,ResultConfig> results,
                    List<InterceptorMapping> interceptors,
                    List<ExceptionMappingConfig> exceptionMappings)
Method Detail

setClassName

public void setClassName(String className)

getClassName

public String getClassName()

getExceptionMappings

public List<ExceptionMappingConfig> getExceptionMappings()

getInterceptors

public List<InterceptorMapping> getInterceptors()

setMethodName

public void setMethodName(String methodName)

getMethodName

public String getMethodName()
Returns name of the action method

Returns:
name of the method to execute

setPackageName

public void setPackageName(String packageName)
Parameters:
packageName - The packageName to set.

getPackageName

public String getPackageName()
Returns:
Returns the packageName.

setParams

public void setParams(Map<String,Object> params)
Specified by:
setParams in interface Parameterizable

getParams

public Map<String,Object> getParams()
Specified by:
getParams in interface Parameterizable

setResults

public void setResults(Map<String,ResultConfig> results)

getResults

public Map<String,ResultConfig> getResults()

addExceptionMapping

public void addExceptionMapping(ExceptionMappingConfig exceptionMapping)

addExceptionMappings

public void addExceptionMappings(List<? extends ExceptionMappingConfig> mappings)

addInterceptor

public void addInterceptor(InterceptorMapping interceptor)
Specified by:
addInterceptor in interface InterceptorListHolder

addInterceptors

public void addInterceptors(List<InterceptorMapping> interceptors)
Specified by:
addInterceptors in interface InterceptorListHolder

addParam

public void addParam(String name,
                     Object value)
Specified by:
addParam in interface Parameterizable

addResultConfig

public void addResultConfig(ResultConfig resultConfig)

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ExceptionMappingConfig (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ExceptionMappingConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.ExceptionMappingConfig
All Implemented Interfaces:
Locatable, Serializable
public class ExceptionMappingConfig
extends Located
implements Serializable

Configuration for exception mapping.

Author:
Rainer Hermanns, Matthew E. Porter (matthew dot porter at metissian dot com)
See Also:
Serialized Form

Field Summary
private String | exceptionClassName
private String | name
private Map | params
private String | result
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
ExceptionMappingConfig()
ExceptionMappingConfig(String name, String exceptionClassName, String result)
ExceptionMappingConfig(String name, String exceptionClassName, String result, Map params)
Method Summary
void | addParam(String name, Object value)
boolean | equals(Object o)
String | getExceptionClassName()
String | getName()
Map | getParams()
String | getResult()
int | hashCode()
void | setExceptionClassName(String exceptionClassName)
void | setName(String name)
void | setResult(String result)
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

private String name

exceptionClassName

private String exceptionClassName

result

private String result

params

private Map params
Constructor Detail

ExceptionMappingConfig

public ExceptionMappingConfig()

ExceptionMappingConfig

public ExceptionMappingConfig(String name,
                              String exceptionClassName,
                              String result)

ExceptionMappingConfig

public ExceptionMappingConfig(String name,
                              String exceptionClassName,
                              String result,
                              Map params)
Method Detail

getName

public String getName()

setName

public void setName(String name)

getExceptionClassName

public String getExceptionClassName()

setExceptionClassName

public void setExceptionClassName(String exceptionClassName)

getResult

public String getResult()

setResult

public void setResult(String result)

getParams

public Map getParams()

addParam

public void addParam(String name,
                     Object value)

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorConfig (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class InterceptorConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.InterceptorConfig
All Implemented Interfaces:
Parameterizable, Locatable, Serializable
public class InterceptorConfig
extends Located
implements Parameterizable, Serializable

Configuration for Interceptors.

In the xml configuration file this is defined as the interceptors tag.

Author:
Mike
See Also:
Serialized Form

Field Summary
(package private) String | className
(package private) String | name
(package private) Map | params
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
InterceptorConfig()
InterceptorConfig(InterceptorConfig parent, Map params)
InterceptorConfig(String name, Class clazz, Map params)
InterceptorConfig(String name, String className, Map params)
Method Summary
void | addParam(String name, Object value)
boolean | equals(Object o)
String | getClassName()
String | getName()
Map | getParams()
int | hashCode()
void | setClassName(String className)
void | setName(String name)
void | setParams(Map params)
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

params

Map params

className

String className

name

String name
Constructor Detail

InterceptorConfig

public InterceptorConfig()

InterceptorConfig

public InterceptorConfig(String name,
                         Class clazz,
                         Map params)

InterceptorConfig

public InterceptorConfig(String name,
                         String className,
                         Map params)

InterceptorConfig

public InterceptorConfig(InterceptorConfig parent,
                         Map params)
Method Detail

setClassName

public void setClassName(String className)

getClassName

public String getClassName()

setName

public void setName(String name)

getName

public String getName()

setParams

public void setParams(Map params)
Specified by:
setParams in interface Parameterizable

getParams

public Map getParams()
Specified by:
getParams in interface Parameterizable

addParam

public void addParam(String name,
                     Object value)
Specified by:
addParam in interface Parameterizable

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorMapping (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class InterceptorMapping

java.lang.Object
    extended by  com.opensymphony.xwork2.config.entities.InterceptorMapping
All Implemented Interfaces:
Serializable
public class InterceptorMapping
extends Object
implements Serializable

InterceptorMapping

Version:
$Id: InterceptorMapping.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Rainer Hermanns
See Also:
Serialized Form

Field Summary
private Interceptor | interceptor
private String | name
Constructor Summary
InterceptorMapping()
InterceptorMapping(String name, Interceptor interceptor)
Method Summary
boolean | equals(Object o)
Interceptor | getInterceptor()
String | getName()
int | hashCode()
void | setInterceptor(Interceptor interceptor)
void | setName(String name)
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

private String name

interceptor

private Interceptor interceptor
Constructor Detail

InterceptorMapping

public InterceptorMapping()

InterceptorMapping

public InterceptorMapping(String name,
                          Interceptor interceptor)
Method Detail

getName

public String getName()

setName

public void setName(String name)

getInterceptor

public Interceptor getInterceptor()

setInterceptor

public void setInterceptor(Interceptor interceptor)

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InterceptorStackConfig (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class InterceptorStackConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.InterceptorStackConfig
All Implemented Interfaces:
InterceptorListHolder, Locatable, Serializable
public class InterceptorStackConfig
extends Located
implements InterceptorListHolder, Serializable

Configuration for InterceptorStack.

In the xml configuration file this is defined as the interceptor-stack tag.

Author:
Mike, Rainer Hermanns
See Also:
Serialized Form

Field Summary
private List<InterceptorMapping> | interceptors
private String | name
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
InterceptorStackConfig()
InterceptorStackConfig(String name)
Method Summary
void | addInterceptor(InterceptorMapping interceptor)
void | addInterceptors(List<InterceptorMapping> interceptors)
boolean | equals(Object o)
Collection<InterceptorMapping> | getInterceptors()
String | getName()
int | hashCode()
void | setName(String name)
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

interceptors

private List<InterceptorMapping> interceptors

name

private String name
Constructor Detail

InterceptorStackConfig

public InterceptorStackConfig()

InterceptorStackConfig

public InterceptorStackConfig(String name)
Method Detail

getInterceptors

public Collection<InterceptorMapping> getInterceptors()

setName

public void setName(String name)

getName

public String getName()

addInterceptor

public void addInterceptor(InterceptorMapping interceptor)
Specified by:
addInterceptor in interface InterceptorListHolder

addInterceptors

public void addInterceptors(List<InterceptorMapping> interceptors)
Specified by:
addInterceptors in interface InterceptorListHolder

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PackageConfig (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class PackageConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.PackageConfig
All Implemented Interfaces:
Locatable, Serializable, Comparable
public class PackageConfig
extends Located
implements Comparable, Serializable

Configuration for Package.

In the xml configuration file this is defined as the package tag.

Version:
$Revision: 1267 $
Author:
Rainer Hermanns
See Also:
Serialized Form

Field Summary
private Map<String,ActionConfig> | actionConfigs
private String | defaultActionRef
private String | defaultClassRef
private String | defaultInterceptorRef
private String | defaultResultType
private List | globalExceptionMappingConfigs
private Map<String,ResultConfig> | globalResultConfigs
private Map | interceptorConfigs
private boolean | isAbstract
private static Log | LOG
private String | name
private String | namespace
private List<PackageConfig> | parents
private Map<String,ResultTypeConfig> | resultTypeConfigs
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
PackageConfig()
PackageConfig(String name)
PackageConfig(String name, String namespace, boolean isAbstract)
PackageConfig(String name, String namespace, boolean isAbstract, List parents)
Method Summary
void | addActionConfig(String name, ActionConfig action)
void | addAllParents(List<PackageConfig> parents)
void | addExceptionMappingConfig(ExceptionMappingConfig exceptionMappingConfig)
void | addGlobalExceptionMappingConfigs(List exceptionMappingConfigs)
void | addGlobalResultConfig(ResultConfig resultConfig)
void | addGlobalResultConfigs(Map resultConfigs)
void | addInterceptorConfig(InterceptorConfig config)
void | addInterceptorStackConfig(InterceptorStackConfig config)
void | addParent(PackageConfig parent)
void | addResultTypeConfig(ResultTypeConfig config)
int | compareTo(Object o)
boolean | equals(Object o)
Map<String,ActionConfig> | getActionConfigs()
Map<String,ActionConfig> | getAllActionConfigs() returns the Map of all the ActionConfigs available in the current package.
List<ExceptionMappingConfig> | getAllExceptionMappingConfigs() returns the List of all the ExceptionMappingConfigs available in the current package.
Map<String,ResultConfig> | getAllGlobalResults() returns the Map of all the global ResultConfigs available in the current package.
Map | getAllInterceptorConfigs() returns the Map of all InterceptorConfigs and InterceptorStackConfigs available in the current package.
Map<String,ResultTypeConfig> | getAllResultTypeConfigs() returns the Map of all the ResultTypeConfigs available in the current package.
String | getDefaultActionRef()
String | getDefaultClassRef()
String | getDefaultInterceptorRef()
String | getDefaultResultType() Returns the default result type for this package.
String | getFullDefaultActionRef() gets the default action-ref name.
String | getFullDefaultInterceptorRef() gets the default interceptor-ref name.
String | getFullDefaultResultType() Returns the default result type for this package.
List<ExceptionMappingConfig> | getGlobalExceptionMappingConfigs() gets the ExceptionMappingConfigs local to this package
Map<String,ResultConfig> | getGlobalResultConfigs() gets the global ResultConfigs local to this package
Map | getInterceptorConfigs() gets the InterceptorConfigs and InterceptorStackConfigs local to this package
String | getName()
String | getNamespace()
List<PackageConfig> | getParents()
Map<String,ResultTypeConfig> | getResultTypeConfigs() gets the ResultTypeConfigs local to this package
int | hashCode()
boolean | isAbstract()
void | removeParent(PackageConfig parent)
void | setAbstract(boolean isAbstract)
void | setDefaultActionRef(String name)
void | setDefaultClassRef(String defaultClassRef)
void | setDefaultInterceptorRef(String name)
void | setDefaultResultType(String defaultResultType) sets the default Result type for this package
void | setName(String name)
void | setNamespace(String namespace)
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

LOG

private static final Log LOG

actionConfigs

private Map<String,ActionConfig> actionConfigs

globalResultConfigs

private Map<String,ResultConfig> globalResultConfigs

interceptorConfigs

private Map interceptorConfigs

resultTypeConfigs

private Map<String,ResultTypeConfig> resultTypeConfigs

globalExceptionMappingConfigs

private List globalExceptionMappingConfigs

parents

private List<PackageConfig> parents

defaultInterceptorRef

private String defaultInterceptorRef

defaultActionRef

private String defaultActionRef

defaultResultType

private String defaultResultType

defaultClassRef

private String defaultClassRef

name

private String name

namespace

private String namespace

isAbstract

private boolean isAbstract
Constructor Detail

PackageConfig

public PackageConfig()

PackageConfig

public PackageConfig(String name)

PackageConfig

public PackageConfig(String name,
                     String namespace,
                     boolean isAbstract)

PackageConfig

public PackageConfig(String name,
                     String namespace,
                     boolean isAbstract,
                     List parents)
Method Detail

setAbstract

public void setAbstract(boolean isAbstract)

isAbstract

public boolean isAbstract()

getActionConfigs

public Map<String,ActionConfig> getActionConfigs()

getAllActionConfigs

public Map<String,ActionConfig> getAllActionConfigs()
returns the Map of all the ActionConfigs available in the current package. ActionConfigs defined in ancestor packages will be included in this Map.

Returns:
a Map of ActionConfig Objects with the action name as the key
See Also:
ActionConfig

getAllGlobalResults

public Map<String,ResultConfig> getAllGlobalResults()
returns the Map of all the global ResultConfigs available in the current package. Global ResultConfigs defined in ancestor packages will be included in this Map.

Returns:
a Map of Result Objects with the result name as the key
See Also:
ResultConfig

getAllInterceptorConfigs

public Map getAllInterceptorConfigs()
returns the Map of all InterceptorConfigs and InterceptorStackConfigs available in the current package. InterceptorConfigs defined in ancestor packages will be included in this Map.

Returns:
a Map of InterceptorConfig and InterceptorStackConfig Objects with the ref-name as the key
See Also:
InterceptorConfig, InterceptorStackConfig

getAllResultTypeConfigs

public Map<String,ResultTypeConfig> getAllResultTypeConfigs()
returns the Map of all the ResultTypeConfigs available in the current package. ResultTypeConfigs defined in ancestor packages will be included in this Map.

Returns:
a Map of ResultTypeConfig Objects with the result type name as the key
See Also:
ResultTypeConfig

getAllExceptionMappingConfigs

public List<ExceptionMappingConfig> getAllExceptionMappingConfigs()
returns the List of all the ExceptionMappingConfigs available in the current package. ExceptionMappingConfigs defined in ancestor packages will be included in this list.

Returns:
a List of ExceptionMappingConfigs Objects with the result type name as the key
See Also:
ExceptionMappingConfig

setDefaultInterceptorRef

public void setDefaultInterceptorRef(String name)

getDefaultInterceptorRef

public String getDefaultInterceptorRef()

setDefaultActionRef

public void setDefaultActionRef(String name)

getDefaultActionRef

public String getDefaultActionRef()

setDefaultClassRef

public void setDefaultClassRef(String defaultClassRef)

getDefaultClassRef

public String getDefaultClassRef()

setDefaultResultType

public void setDefaultResultType(String defaultResultType)
sets the default Result type for this package

Parameters:
defaultResultType -

getDefaultResultType

public String getDefaultResultType()
Returns the default result type for this package.

getFullDefaultInterceptorRef

public String getFullDefaultInterceptorRef()
gets the default interceptor-ref name. If this is not set on this PackageConfig, it searches the parent PackageConfigs in order until it finds one.

getFullDefaultActionRef

public String getFullDefaultActionRef()
gets the default action-ref name. If this is not set on this PackageConfig, it searches the parent PackageConfigs in order until it finds one.

getFullDefaultResultType

public String getFullDefaultResultType()
Returns the default result type for this package.

If there is no default result type, but this package has parents - we will try to look up the default result type of a parent.

getGlobalResultConfigs

public Map<String,ResultConfig> getGlobalResultConfigs()
gets the global ResultConfigs local to this package

Returns:
a Map of ResultConfig objects keyed by result name
See Also:
ResultConfig

getInterceptorConfigs

public Map getInterceptorConfigs()
gets the InterceptorConfigs and InterceptorStackConfigs local to this package

Returns:
a Map of InterceptorConfig and InterceptorStackConfig objects keyed by ref-name
See Also:
InterceptorConfig, InterceptorStackConfig

setName

public void setName(String name)

getName

public String getName()

setNamespace

public void setNamespace(String namespace)

getNamespace

public String getNamespace()

getParents

public List<PackageConfig> getParents()

getResultTypeConfigs

public Map<String,ResultTypeConfig> getResultTypeConfigs()
gets the ResultTypeConfigs local to this package

Returns:
a Map of ResultTypeConfig objects keyed by result name
See Also:
ResultTypeConfig

getGlobalExceptionMappingConfigs

public List<ExceptionMappingConfig> getGlobalExceptionMappingConfigs()
gets the ExceptionMappingConfigs local to this package

Returns:
a Map of ExceptionMappingConfig objects keyed by result name
See Also:
ExceptionMappingConfig

addActionConfig

public void addActionConfig(String name,
                            ActionConfig action)

addAllParents

public void addAllParents(List<PackageConfig> parents)

addGlobalResultConfig

public void addGlobalResultConfig(ResultConfig resultConfig)

addGlobalResultConfigs

public void addGlobalResultConfigs(Map resultConfigs)

addExceptionMappingConfig

public void addExceptionMappingConfig(ExceptionMappingConfig exceptionMappingConfig)

addGlobalExceptionMappingConfigs

public void addGlobalExceptionMappingConfigs(List exceptionMappingConfigs)

addInterceptorConfig

public void addInterceptorConfig(InterceptorConfig config)

addInterceptorStackConfig

public void addInterceptorStackConfig(InterceptorStackConfig config)

addParent

public void addParent(PackageConfig parent)

addResultTypeConfig

public void addResultTypeConfig(ResultTypeConfig config)

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

removeParent

public void removeParent(PackageConfig parent)

toString

public String toString()
Overrides:
toString in class Object

compareTo

public int compareTo(Object o)
Specified by:
compareTo in interface Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultConfig (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ResultConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.ResultConfig
All Implemented Interfaces:
Parameterizable, Locatable, Serializable
public class ResultConfig
extends Located
implements Parameterizable, Serializable

Configuration for Result.

In the xml configuration file this is defined as the result tag.

Author:
Mike
See Also:
Serialized Form

Field Summary
private String | className
private String | name
private Map | params
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
ResultConfig()
ResultConfig(String name, String clazz)
ResultConfig(String name, String className, Map params)
Method Summary
void | addParam(String name, Object value)
boolean | equals(Object o)
String | getClassName()
String | getName()
Map | getParams()
int | hashCode()
void | setClassName(String className)
void | setName(String name)
void | setParams(Map params)
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

params

private Map params

className

private String className

name

private String name
Constructor Detail

ResultConfig

public ResultConfig()

ResultConfig

public ResultConfig(String name,
                    String clazz)

ResultConfig

public ResultConfig(String name,
                    String className,
                    Map params)
Method Detail

setClassName

public void setClassName(String className)

getClassName

public String getClassName()

setName

public void setName(String name)

getName

public String getName()

setParams

public void setParams(Map params)
Specified by:
setParams in interface Parameterizable

getParams

public Map getParams()
Specified by:
getParams in interface Parameterizable

addParam

public void addParam(String name,
                     Object value)
Specified by:
addParam in interface Parameterizable

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResultTypeConfig (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.entities
Class ResultTypeConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.entities.ResultTypeConfig
All Implemented Interfaces:
Locatable, Serializable
public class ResultTypeConfig
extends Located
implements Serializable

Configuration class for result types.

In the xml configuration file this is defined as the result-type tag.

Author:
Mike, Rainer Hermanns, Neo
See Also:
Serialized Form

Field Summary
private String | clazz
private String | defaultResultParam
private String | name
private Map | params
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
ResultTypeConfig()
ResultTypeConfig(String name, String clazz, String defaultResultParam)
Method Summary
void | addParam(String key, String value)
boolean | equals(Object o)
String | getClazz()
String | getDefaultResultParam()
String | getName()
Map | getParams()
int | hashCode()
void | setClazz(String clazz)
void | setDefaultResultParam(String defaultResultParam)
void | setName(String name)
void | setParams(Map params)
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

clazz

private String clazz

name

private String name

defaultResultParam

private String defaultResultParam

params

private Map params
Constructor Detail

ResultTypeConfig

public ResultTypeConfig()

ResultTypeConfig

public ResultTypeConfig(String name,
                        String clazz,
                        String defaultResultParam)
Method Detail

setDefaultResultParam

public void setDefaultResultParam(String defaultResultParam)

getDefaultResultParam

public String getDefaultResultParam()

setClazz

public void setClazz(String clazz)

getClazz

public String getClazz()

setName

public void setName(String name)

getName

public String getName()

addParam

public void addParam(String key,
                     String value)

getParams

public Map getParams()

setParams

public void setParams(Map params)

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.config.impl (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.config.impl

Configuration implementation classes.

See:
Description

Class Summary
ActionConfigMatcher | Matches paths against pre-compiled wildcard expressions pulled from action configs.
DefaultConfiguration | DefaultConfiguration
LocatableConstantFactory<T> | Factory that remembers where a constant came from
LocatableFactory<T> | Attaches location information to the factory.
MockConfiguration | Simple configuration used for unit testing

Package com.opensymphony.xwork2.config.impl Description

Configuration implementation classes.


com.opensymphony.xwork2.config.impl Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.config.impl

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.config.impl.ActionConfigMatcher (implements java.io.Serializable)
    • com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping (implements java.io.Serializable)
    • com.opensymphony.xwork2.config.impl.DefaultConfiguration (implements com.opensymphony.xwork2.config.Configuration)
    • com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl (implements com.opensymphony.xwork2.config.RuntimeConfiguration)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • com.opensymphony.xwork2.util.location.LocatableProperties (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
      • com.opensymphony.xwork2.config.impl.LocatableConstantFactory<T> (implements com.opensymphony.xwork2.inject.Factory<T>)
      • com.opensymphony.xwork2.config.impl.LocatableFactory<T> (implements com.opensymphony.xwork2.inject.Factory<T>)
    • com.opensymphony.xwork2.config.impl.MockConfiguration (implements com.opensymphony.xwork2.config.Configuration)


Uses of Package com.opensymphony.xwork2.config.impl (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.config.impl

Packages that use com.opensymphony.xwork2.config.impl
com.opensymphony.xwork2.config.impl Configuration implementation classes.

Classes in com.opensymphony.xwork2.config.impl used by com.opensymphony.xwork2.config.impl
ActionConfigMatcher
Matches paths against pre-compiled wildcard expressions pulled from action configs.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionConfigMatcher (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class ActionConfigMatcher

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.ActionConfigMatcher
All Implemented Interfaces:
Serializable
public class ActionConfigMatcher
extends Object
implements Serializable

Matches paths against pre-compiled wildcard expressions pulled from action configs. It uses the wildcard matcher from the Apache Cocoon project. Patterns will be matched in the order they exist in the config file. The first match wins, so more specific patterns should be defined before less specific patterns.

See Also:
Serialized Form

Nested Class Summary
private  class ActionConfigMatcher.Mapping
Stores a compiled wildcard pattern and the ActionConfig it came from.
Field Summary
private List | compiledPaths The compiled paths and their associated ActionConfig's
private static Log | log The logging instance
private static WildcardHelper | wildcard Handles all wildcard pattern matching.
Constructor Summary
ActionConfigMatcher(Map<String,ActionConfig> configs)
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
ActionConfigMatcher(Map<String,ActionConfig> configs, boolean looseMatch)
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
Method Summary
protected ActionConfig | convertActionConfig(String path, ActionConfig orig, Map vars) Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.
protected String | convertParam(String val, Map vars) Inserts into a value wildcard-matched strings where specified with the {x} syntax.
ActionConfig | match(String path) Matches the path against the compiled wildcard patterns.
protected Map<String,Object> | replaceParameters(Map<String,Object> orig, Map vars) Replaces parameter values
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

The logging instance

wildcard

private static final WildcardHelper wildcard

Handles all wildcard pattern matching.

compiledPaths

private List compiledPaths

The compiled paths and their associated ActionConfig's

Constructor Detail

ActionConfigMatcher

public ActionConfigMatcher(Map<String,ActionConfig> configs)

Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes. ActionConfig's will be evaluated in the order they exist in the config file. Only paths that actually contain a wildcard will be compiled. Patterns will matched strictly.

Parameters:
configs - An array of ActionConfig's to process

ActionConfigMatcher

public ActionConfigMatcher(Map<String,ActionConfig> configs,
                           boolean looseMatch)

Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes. ActionConfig's will be evaluated in the order they exist in the config file. Only paths that actually contain a wildcard will be compiled.

Patterns can optionally be matched "loosely". When the end of the pattern matches \*[^*]\*$ (wildcard, no wildcard, wildcard), if the pattern fails, it is also matched as if the last two characters didn't exist. The goal is to support the legacy "*!*" syntax, where the "!*" is optional.

Parameters:
configs - An array of ActionConfig's to process
looseMatch - To loosely match wildcards or not
Method Detail

match

public ActionConfig match(String path)

Matches the path against the compiled wildcard patterns.

Parameters:
path - The portion of the request URI for selecting a config.
Returns:
The action config if matched, else null

convertActionConfig

protected ActionConfig convertActionConfig(String path,
                                           ActionConfig orig,
                                           Map vars)

Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.

Parameters:
path - The requested path
orig - The original ActionConfig
vars - A Map of wildcard-matched strings
Returns:
A cloned ActionConfig with appropriate properties replaced with wildcard-matched values

replaceParameters

protected Map<String,Object> replaceParameters(Map<String,Object> orig,
                                               Map vars)

Replaces parameter values

Parameters:
orig - The original parameters with placehold values
vars - A Map of wildcard-matched strings

convertParam

protected String convertParam(String val,
                              Map vars)

Inserts into a value wildcard-matched strings where specified with the {x} syntax. If a wildcard-matched value isn't found, the replacement token is turned into an empty string.

Parameters:
val - The value to convert
vars - A Map of wildcard-matched strings
Returns:
The new value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionConfigMatcher.Mapping (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class ActionConfigMatcher.Mapping

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping
All Implemented Interfaces:
Serializable
Enclosing class:
ActionConfigMatcher
private class ActionConfigMatcher.Mapping
extends Object
implements Serializable

Stores a compiled wildcard pattern and the ActionConfig it came from.

Field Summary
private ActionConfig | config The original ActionConfig.
private String | original The original pattern.
private int[] | pattern The compiled pattern.
Constructor Summary
ActionConfigMatcher.Mapping(String original, int[] pattern, ActionConfig config)
Contructs a read-only Mapping instance.
Method Summary
ActionConfig | getActionConfig() Gets the ActionConfig that contains the pattern.
String | getOriginal() Gets the original wildcard pattern.
int[] | getPattern() Gets the compiled wildcard pattern.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

original

private String original

The original pattern.

pattern

private int[] pattern

The compiled pattern.

config

private ActionConfig config

The original ActionConfig.

Constructor Detail

ActionConfigMatcher.Mapping

public ActionConfigMatcher.Mapping(String original,
                                   int[] pattern,
                                   ActionConfig config)

Contructs a read-only Mapping instance.

Parameters:
original - The original pattern
pattern - The compiled pattern
config - The original ActionConfig
Method Detail

getPattern

public int[] getPattern()

Gets the compiled wildcard pattern.

Returns:
The compiled pattern

getActionConfig

public ActionConfig getActionConfig()

Gets the ActionConfig that contains the pattern.

Returns:
The associated ActionConfig

getOriginal

public String getOriginal()

Gets the original wildcard pattern.

Returns:
The original pattern
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultConfiguration (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class DefaultConfiguration

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.DefaultConfiguration
All Implemented Interfaces:
Configuration, Serializable
public class DefaultConfiguration
extends Object
implements Configuration

DefaultConfiguration

Author:
Jason Carreira Created Feb 24, 2003 7:38:06 AM
See Also:
Serialized Form

Nested Class Summary
(package private) class | DefaultConfiguration.ContainerProperties
private class | DefaultConfiguration.RuntimeConfigurationImpl
Field Summary
protected Container | container
protected String | defaultFrameworkBeanName
protected Set<String> | loadedFileNames
protected static Log | LOG
(package private) ObjectFactory | objectFactory
protected Map<String,PackageConfig> | packageContexts
protected RuntimeConfiguration | runtimeConfiguration
Constructor Summary
DefaultConfiguration()
DefaultConfiguration(String defaultBeanName)
Method Summary
void | addPackageConfig(String name, PackageConfig packageContext)
private ActionConfig | buildFullActionConfig(PackageConfig packageContext, ActionConfig baseConfig) Builds the full runtime actionconfig with all of the defaults and inheritance
protected RuntimeConfiguration | buildRuntimeConfiguration() This methodName builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures.
void | destroy() Allows the configuration to clean up any resources used
Container | getContainer()
Set<String> | getLoadedFileNames()
PackageConfig | getPackageConfig(String name)
Set | getPackageConfigNames()
Map | getPackageConfigs()
RuntimeConfiguration | getRuntimeConfiguration() The current runtime configuration.
void | rebuildRuntimeConfiguration()
void | reload(List<ConfigurationProvider> providers) Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
void | removePackageConfig(String name)
private void | setDefaultResults(Map<String,ResultConfig> results, PackageConfig packageContext)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Log LOG

packageContexts

protected Map<String,PackageConfig> packageContexts

runtimeConfiguration

protected RuntimeConfiguration runtimeConfiguration

container

protected Container container

defaultFrameworkBeanName

protected String defaultFrameworkBeanName

loadedFileNames

protected Set<String> loadedFileNames

objectFactory

ObjectFactory objectFactory
Constructor Detail

DefaultConfiguration

public DefaultConfiguration()

DefaultConfiguration

public DefaultConfiguration(String defaultBeanName)
Method Detail

getPackageConfig

public PackageConfig getPackageConfig(String name)
Specified by:
getPackageConfig in interface Configuration

getPackageConfigNames

public Set getPackageConfigNames()
Specified by:
getPackageConfigNames in interface Configuration

getPackageConfigs

public Map getPackageConfigs()
Specified by:
getPackageConfigs in interface Configuration

getLoadedFileNames

public Set<String> getLoadedFileNames()
Specified by:
getLoadedFileNames in interface Configuration

getRuntimeConfiguration

public RuntimeConfiguration getRuntimeConfiguration()
Description copied from interface: Configuration
The current runtime configuration. Currently, if changes have been made to the Configuration since the last time buildRuntimeConfiguration() was called, you'll need to make sure to.

Specified by:
getRuntimeConfiguration in interface Configuration
Returns:
the current runtime configuration

getContainer

public Container getContainer()
Specified by:
getContainer in interface Configuration
Returns:
the container

addPackageConfig

public void addPackageConfig(String name,
                             PackageConfig packageContext)
Specified by:
addPackageConfig in interface Configuration

destroy

public void destroy()
Allows the configuration to clean up any resources used

Specified by:
destroy in interface Configuration

rebuildRuntimeConfiguration

public void rebuildRuntimeConfiguration()
Specified by:
rebuildRuntimeConfiguration in interface Configuration

reload

public void reload(List<ConfigurationProvider> providers)
            throws ConfigurationException
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().

Specified by:
reload in interface Configuration
Throws:
ConfigurationException

removePackageConfig

public void removePackageConfig(String name)
Specified by:
removePackageConfig in interface Configuration

buildRuntimeConfiguration

protected RuntimeConfiguration buildRuntimeConfiguration()
                                                  throws ConfigurationException
This methodName builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures. All of the old runtime configuration will be discarded and rebuilt.

Throws:
ConfigurationException

setDefaultResults

private void setDefaultResults(Map<String,ResultConfig> results,
                               PackageConfig packageContext)

buildFullActionConfig

private ActionConfig buildFullActionConfig(PackageConfig packageContext,
                                           ActionConfig baseConfig)
                                    throws ConfigurationException
Builds the full runtime actionconfig with all of the defaults and inheritance

Parameters:
packageContext - the PackageConfig which holds the base config we're building from
baseConfig - the ActionConfig which holds only the configuration specific to itself, without the defaults and inheritance
Returns:
a full ActionConfig for runtime configuration with all of the inherited and default params
Throws:
ConfigurationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultConfiguration.ContainerProperties (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class DefaultConfiguration.ContainerProperties

java.lang.Object
    extended by  java.util.Dictionary<K,V>
        extended by  java.util.Hashtable<Object,Object>
            extended by  java.util.Properties
                extended by  com.opensymphony.xwork2.util.location.LocatableProperties
                    extended by  com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties
All Implemented Interfaces:
Locatable, Serializable, Cloneable, Map<Object,Object>
Enclosing class:
DefaultConfiguration
 class DefaultConfiguration.ContainerProperties
extends LocatableProperties

Field Summary
private static long serialVersionUID
Fields inherited from class java.util.Properties
defaults
Constructor Summary
DefaultConfiguration.ContainerProperties()
Method Summary
void | setConstants(ContainerBuilder builder)
Object | setProperty(String key, String value)
Methods inherited from class com.opensymphony.xwork2.util.location.LocatableProperties
getLocation, getPropertyLocation, load, setProperty
Methods inherited from class java.util.Properties
getProperty, getProperty, list, list, loadFromXML, propertyNames, save, store, storeToXML, storeToXML
Methods inherited from class java.util.Hashtable
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

DefaultConfiguration.ContainerProperties

DefaultConfiguration.ContainerProperties()
Method Detail

setProperty

public Object setProperty(String key,
                          String value)
Overrides:
setProperty in class Properties

setConstants

public void setConstants(ContainerBuilder builder)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultConfiguration.RuntimeConfigurationImpl (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class DefaultConfiguration.RuntimeConfigurationImpl

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl
All Implemented Interfaces:
RuntimeConfiguration, Serializable
Enclosing class:
DefaultConfiguration
private class DefaultConfiguration.RuntimeConfigurationImpl
extends Object
implements RuntimeConfiguration

Field Summary
private Map<String,ActionConfigMatcher> | namespaceActionConfigMatchers
private Map<String,Map<String,ActionConfig>> | namespaceActionConfigs
private Map<String,String> | namespaceConfigs
Constructor Summary
DefaultConfiguration.RuntimeConfigurationImpl(Map<String,Map<String,ActionConfig>> namespaceActionConfigs, Map<String,String> namespaceConfigs)
Method Summary
ActionConfig | getActionConfig(String namespace, String name) Gets the configuration information for an action name, or returns null if the name is not recognized.
Map | getActionConfigs() Gets the configuration settings for every action.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

namespaceActionConfigs

private Map<String,Map<String,ActionConfig>> namespaceActionConfigs

namespaceActionConfigMatchers

private Map<String,ActionConfigMatcher> namespaceActionConfigMatchers

namespaceConfigs

private Map<String,String> namespaceConfigs
Constructor Detail

DefaultConfiguration.RuntimeConfigurationImpl

public DefaultConfiguration.RuntimeConfigurationImpl(Map<String,Map<String,ActionConfig>> namespaceActionConfigs,
                                                     Map<String,String> namespaceConfigs)
Method Detail

getActionConfig

public ActionConfig getActionConfig(String namespace,
                                    String name)
Gets the configuration information for an action name, or returns null if the name is not recognized.

Specified by:
getActionConfig in interface RuntimeConfiguration
Parameters:
name - the name of the action
namespace - the namespace for the action or null for the empty namespace, ""
Returns:
the configuration information for action requested

getActionConfigs

public Map getActionConfigs()
Gets the configuration settings for every action.

Specified by:
getActionConfigs in interface RuntimeConfiguration
Returns:
a Map of namespace - > Map of ActionConfig objects, with the key being the action name

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocatableConstantFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class LocatableConstantFactory<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.impl.LocatableConstantFactory<T>
All Implemented Interfaces:
Factory, Locatable
public class LocatableConstantFactory<T>
extends Located
implements Factory

Factory that remembers where a constant came from

Field Summary
(package private)  T constant
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
LocatableConstantFactory(T constant, Object location)
Method Summary
T | create(Context ignored) Creates an object to be injected.
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

constant

T constant
Constructor Detail

LocatableConstantFactory

public LocatableConstantFactory(T constant,
                                Object location)
Method Detail

create

public T create(Context ignored)
Description copied from interface: Factory
Creates an object to be injected.

Specified by:
create in interface Factory
Parameters:
ignored - of this injection
Returns:
instance to be injected

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocatableFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class LocatableFactory<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.config.impl.LocatableFactory<T>
All Implemented Interfaces:
Factory<T>, Locatable
public class LocatableFactory<T>
extends Located
implements Factory<T>

Attaches location information to the factory.

Field Summary
private Class | implementation
private String | name
private Scope | scope
private Class | type
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
LocatableFactory(String name, Class type, Class implementation, Scope scope, Object location)
Method Summary
T | create(Context context) Creates an object to be injected.
String | toString()
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

implementation

private Class implementation

type

private Class type

name

private String name

scope

private Scope scope
Constructor Detail

LocatableFactory

public LocatableFactory(String name,
                        Class type,
                        Class implementation,
                        Scope scope,
                        Object location)
Method Detail

create

public T create(Context context)
Description copied from interface: Factory
Creates an object to be injected.

Specified by:
create in interface Factory<T>
Parameters:
context - of this injection
Returns:
instance to be injected

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockConfiguration (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.impl
Class MockConfiguration

java.lang.Object
    extended by  com.opensymphony.xwork2.config.impl.MockConfiguration
All Implemented Interfaces:
Configuration, Serializable
public class MockConfiguration
extends Object
implements Configuration

Simple configuration used for unit testing

See Also:
Serialized Form

Field Summary
private Container | container
private Set | loadedFiles
private Map | packages
Constructor Summary
MockConfiguration()
Method Summary
void | addPackageConfig(String name, PackageConfig packageContext)
void | buildRuntimeConfiguration()
void | destroy() Allow the Configuration to clean up any resources that have been used.
Container | getContainer()
Set<String> | getLoadedFileNames()
PackageConfig | getPackageConfig(String name)
Set | getPackageConfigNames()
Map | getPackageConfigs()
RuntimeConfiguration | getRuntimeConfiguration() The current runtime configuration.
void | rebuildRuntimeConfiguration()
void | reload(List<ConfigurationProvider> providers)
void | removePackageConfig(String name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

packages

private Map packages

loadedFiles

private Set loadedFiles

container

private Container container
Constructor Detail

MockConfiguration

public MockConfiguration()
Method Detail

getPackageConfig

public PackageConfig getPackageConfig(String name)
Specified by:
getPackageConfig in interface Configuration

getPackageConfigNames

public Set getPackageConfigNames()
Specified by:
getPackageConfigNames in interface Configuration

getPackageConfigs

public Map getPackageConfigs()
Specified by:
getPackageConfigs in interface Configuration

getRuntimeConfiguration

public RuntimeConfiguration getRuntimeConfiguration()
Description copied from interface: Configuration
The current runtime configuration. Currently, if changes have been made to the Configuration since the last time buildRuntimeConfiguration() was called, you'll need to make sure to.

Specified by:
getRuntimeConfiguration in interface Configuration
Returns:
the current runtime configuration

addPackageConfig

public void addPackageConfig(String name,
                             PackageConfig packageContext)
Specified by:
addPackageConfig in interface Configuration

buildRuntimeConfiguration

public void buildRuntimeConfiguration()

destroy

public void destroy()
Description copied from interface: Configuration
Allow the Configuration to clean up any resources that have been used.

Specified by:
destroy in interface Configuration

rebuildRuntimeConfiguration

public void rebuildRuntimeConfiguration()
Specified by:
rebuildRuntimeConfiguration in interface Configuration

reload

public void reload(List<ConfigurationProvider> providers)
            throws ConfigurationException
Specified by:
reload in interface Configuration
Throws:
ConfigurationException

removePackageConfig

public void removePackageConfig(String name)
Specified by:
removePackageConfig in interface Configuration

getContainer

public Container getContainer()
Specified by:
getContainer in interface Configuration
Returns:
the container

getLoadedFileNames

public Set<String> getLoadedFileNames()
Specified by:
getLoadedFileNames in interface Configuration
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.config.providers (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.config.providers

Configuration provider classes.

See:
Description

Class Summary
InterceptorBuilder | Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
XmlConfigurationProvider | Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.
XmlHelper | XML utilities.

Package com.opensymphony.xwork2.config.providers Description

Configuration provider classes.


com.opensymphony.xwork2.config.providers Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.config.providers

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.config.providers.InterceptorBuilder
    • com.opensymphony.xwork2.config.providers.XmlConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • com.opensymphony.xwork2.config.providers.XmlHelper


Uses of Package com.opensymphony.xwork2.config.providers (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.config.providers

Packages that use com.opensymphony.xwork2.config.providers
org.apache.struts2.config Classes for Struts configuration and property handling.

Classes in com.opensymphony.xwork2.config.providers used by org.apache.struts2.config
XmlConfigurationProvider
Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


InterceptorBuilder (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.providers
Class InterceptorBuilder

java.lang.Object
    extended by  com.opensymphony.xwork2.config.providers.InterceptorBuilder

public class InterceptorBuilder
extends Object

Builds a list of interceptors referenced by the refName in the supplied PackageConfig.

Version:
$Date: 2006-11-13 09:05:32 +0100 (Mo, 13 Nov 2006) $ $Id: InterceptorBuilder.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Mike, Rainer Hermanns, tmjee

Field Summary
private static Log LOG
Constructor Summary
InterceptorBuilder()
Method Summary
static List<InterceptorMapping> | constructInterceptorReference(PackageConfig packageConfig, String refName, Map refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
private static List<InterceptorMapping> | constructParameterizedInterceptorReferences(PackageConfig packageConfig, InterceptorStackConfig stackConfig, Map refParams, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig overriding the properties of the referenced interceptor with refParams.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG
Constructor Detail

InterceptorBuilder

public InterceptorBuilder()
Method Detail

constructInterceptorReference

public static List<InterceptorMapping> constructInterceptorReference(PackageConfig packageConfig,
                                                                     String refName,
                                                                     Map refParams,
                                                                     Location location,
                                                                     ObjectFactory objectFactory)
                                                              throws ConfigurationException
Builds a list of interceptors referenced by the refName in the supplied PackageConfig.

Parameters:
packageConfig -
refName -
refParams -
Returns:
list of interceptors referenced by the refName in the supplied PackageConfig.
Throws:
ConfigurationException

constructParameterizedInterceptorReferences

private static List<InterceptorMapping> constructParameterizedInterceptorReferences(PackageConfig packageConfig,
                                                                                InterceptorStackConfig stackConfig,
                                                                                Map refParams,
                                                                                ObjectFactory objectFactory)
Builds a list of interceptors referenced by the refName in the supplied PackageConfig overriding the properties of the referenced interceptor with refParams.

Parameters:
packageConfig -
stackConfig -
refParams - The overridden interceptor properies
Returns:
list of interceptors referenced by the refName in the supplied PackageConfig overridden with refParams.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


XmlConfigurationProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.providers
Class XmlConfigurationProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
All Implemented Interfaces:
ConfigurationProvider
Direct Known Subclasses:
StrutsXmlConfigurationProvider
public class XmlConfigurationProvider
extends Object
implements ConfigurationProvider

Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.

Version:
$Revision: 1365 $
Author:
tmjee, Rainer Hermanns, Neo

Field Summary
private String | configFileName
private Configuration | configuration
private List<Document> | documents
private Map<String,String> | dtdMappings
private boolean | errorIfMissing
private Set<String> | includedFileNames
private Set<String> | loadedFileUrls
private static Log | LOG
private ObjectFactory | objectFactory
Constructor Summary
XmlConfigurationProvider()
XmlConfigurationProvider(String filename)
XmlConfigurationProvider(String filename, boolean errorIfMissing)
Method Summary
protected void | addAction(Element actionElement, PackageConfig packageContext)
protected void | addPackage(Element packageElement) Create a PackageConfig from an XML element representing it.
protected void | addResultTypes(PackageConfig packageContext, Element element)
protected List | buildExceptionMappings(Element element, PackageConfig packageContext) Build a map of ResultConfig objects from below a given XML element.
protected List | buildInterceptorList(Element element, PackageConfig context)
protected PackageConfig | buildPackageContext(Element packageElement) This method builds a package context by looking for the parents of this new package.
protected Map | buildResults(Element element, PackageConfig packageContext) Build a map of ResultConfig objects from below a given XML element.
void | destroy()
boolean | equals(Object o)
protected Iterator<URL> | getConfigurationUrls(String fileName)
Map<String,String> | getDtdMappings() Returns an unmodifiable map of DTD mappings
int | hashCode()
void | init(Configuration configuration)
private List | loadConfigurationFiles(String fileName, Element includeElement)
protected void | loadDefaultActionRef(PackageConfig packageContext, Element element)
protected void | loadDefaultClassRef(PackageConfig packageContext, Element element)
protected void | loadDefaultInterceptorRef(PackageConfig packageContext, Element element)
private void | loadDocuments(String configFileName)
protected void | loadExtraConfiguration(Document doc) Allows subclasses to load extra information from the document
protected void | loadGlobalResults(PackageConfig packageContext, Element packageElement) Load all of the global results for this package from the XML element.
protected void | loadGobalExceptionMappings(PackageConfig packageContext, Element packageElement) Load all of the global results for this package from the XML element.
protected void | loadInterceptors(PackageConfig context, Element element)
protected InterceptorStackConfig | loadInterceptorStack(Element element, PackageConfig context)
protected void | loadInterceptorStacks(Element element, PackageConfig context)
void | loadPackages()
private List | lookupInterceptorReference(PackageConfig context, Element interceptorRefElement) Looks up the Interceptor Class from the interceptor-ref name and creates an instance, which is added to the provided List, or, if this is a ref to a stack, it adds the Interceptor instances from the List to this stack.
boolean | needsReload() Tells whether the ConfigurationProvider should reload its configuration.
void | register(ContainerBuilder containerBuilder, LocatableProperties props)
void | setDtdMappings(Map<String,String> mappings)
void | setObjectFactory(ObjectFactory objectFactory)
protected boolean | verifyAction(String className, String name, Location loc)
protected Class | verifyResultType(String className, Location loc)
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

documents

private List<Document> documents

includedFileNames

private Set<String> includedFileNames

configFileName

private String configFileName

objectFactory

private ObjectFactory objectFactory

loadedFileUrls

private Set<String> loadedFileUrls

errorIfMissing

private boolean errorIfMissing

dtdMappings

private Map<String,String> dtdMappings

configuration

private Configuration configuration
Constructor Detail

XmlConfigurationProvider

public XmlConfigurationProvider()

XmlConfigurationProvider

public XmlConfigurationProvider(String filename)

XmlConfigurationProvider

public XmlConfigurationProvider(String filename,
                                boolean errorIfMissing)
Method Detail

setDtdMappings

public void setDtdMappings(Map<String,String> mappings)

setObjectFactory

public void setObjectFactory(ObjectFactory objectFactory)

getDtdMappings

public Map<String,String> getDtdMappings()
Returns an unmodifiable map of DTD mappings

init

public void init(Configuration configuration)
Specified by:
init in interface ConfigurationProvider

destroy

public void destroy()
Specified by:
destroy in interface ConfigurationProvider

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

loadDocuments

private void loadDocuments(String configFileName)

register

public void register(ContainerBuilder containerBuilder,
                     LocatableProperties props)
              throws ConfigurationException
Specified by:
register in interface ConfigurationProvider
Throws:
ConfigurationException

loadPackages

public void loadPackages()
                  throws ConfigurationException
Specified by:
loadPackages in interface ConfigurationProvider
Throws:
ConfigurationException

needsReload

public boolean needsReload()
Tells whether the ConfigurationProvider should reload its configuration. This method should only be called if ConfigurationManager.isReloadingConfigs() is true.

Specified by:
needsReload in interface ConfigurationProvider
Returns:
true if the file has been changed since the last time we read it

addAction

protected void addAction(Element actionElement,
                         PackageConfig packageContext)
                  throws ConfigurationException
Throws:
ConfigurationException

verifyAction

protected boolean verifyAction(String className,
                               String name,
                               Location loc)

addPackage

protected void addPackage(Element packageElement)
                   throws ConfigurationException
Create a PackageConfig from an XML element representing it.

Throws:
ConfigurationException

addResultTypes

protected void addResultTypes(PackageConfig packageContext,
                              Element element)

verifyResultType

protected Class verifyResultType(String className,
                                 Location loc)

buildInterceptorList

protected List buildInterceptorList(Element element,
                                    PackageConfig context)
                             throws ConfigurationException
Throws:
ConfigurationException

buildPackageContext

protected PackageConfig buildPackageContext(Element packageElement)
This method builds a package context by looking for the parents of this new package.

If no parents are found, it will return a root package.

buildResults

protected Map buildResults(Element element,
                           PackageConfig packageContext)
Build a map of ResultConfig objects from below a given XML element.

buildExceptionMappings

protected List buildExceptionMappings(Element element,
                                      PackageConfig packageContext)
Build a map of ResultConfig objects from below a given XML element.

loadDefaultInterceptorRef

protected void loadDefaultInterceptorRef(PackageConfig packageContext,
                                         Element element)

loadDefaultActionRef

protected void loadDefaultActionRef(PackageConfig packageContext,
                                    Element element)

loadGlobalResults

protected void loadGlobalResults(PackageConfig packageContext,
                                 Element packageElement)
Load all of the global results for this package from the XML element.

loadDefaultClassRef

protected void loadDefaultClassRef(PackageConfig packageContext,
                                   Element element)

loadGobalExceptionMappings

protected void loadGobalExceptionMappings(PackageConfig packageContext,
                                          Element packageElement)
Load all of the global results for this package from the XML element.

loadInterceptorStack

protected InterceptorStackConfig loadInterceptorStack(Element element,
                                                      PackageConfig context)
                                               throws ConfigurationException
Throws:
ConfigurationException

loadInterceptorStacks

protected void loadInterceptorStacks(Element element,
                                     PackageConfig context)
                              throws ConfigurationException
Throws:
ConfigurationException

loadInterceptors

protected void loadInterceptors(PackageConfig context,
                                Element element)
                         throws ConfigurationException
Throws:
ConfigurationException

loadConfigurationFiles

private List loadConfigurationFiles(String fileName,
                                    Element includeElement)

getConfigurationUrls

protected Iterator<URL> getConfigurationUrls(String fileName)
                                      throws IOException
Throws:
IOException

loadExtraConfiguration

protected void loadExtraConfiguration(Document doc)
Allows subclasses to load extra information from the document

Parameters:
doc - The configuration document

lookupInterceptorReference

private List lookupInterceptorReference(PackageConfig context,
                                        Element interceptorRefElement)
                                 throws ConfigurationException
Looks up the Interceptor Class from the interceptor-ref name and creates an instance, which is added to the provided List, or, if this is a ref to a stack, it adds the Interceptor instances from the List to this stack.

Parameters:
interceptorRefElement - Element to pull interceptor ref data from
context - The PackageConfig to lookup the interceptor from
Returns:
A list of Interceptor objects
Throws:
ConfigurationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XmlHelper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.config.providers
Class XmlHelper

java.lang.Object
    extended by  com.opensymphony.xwork2.config.providers.XmlHelper

public class XmlHelper
extends Object

XML utilities.

Author:
Mike

Constructor Summary
XmlHelper()
Method Summary
static Map getParams(Element paramsElement)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XmlHelper

public XmlHelper()
Method Detail

getParams

public static Map getParams(Element paramsElement)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.conversion.annotations (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.conversion.annotations

Type conversion annotations.

See:
Description

Enum Summary
ConversionRule | ConversionRule
ConversionType | ConversionType

Annotation Types Summary
Conversion | A marker annotation for type conversions at Type level.
TypeConversion | This annotation is used for class and application wide conversion rules.

Package com.opensymphony.xwork2.conversion.annotations Description

Type conversion annotations.


com.opensymphony.xwork2.conversion.annotations Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.conversion.annotations

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • com.opensymphony.xwork2.conversion.annotations.Conversion (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.conversion.annotations.TypeConversion (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.conversion.annotations.ConversionRule
      • com.opensymphony.xwork2.conversion.annotations.ConversionType


Uses of Package com.opensymphony.xwork2.conversion.annotations (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.conversion.annotations

Packages that use com.opensymphony.xwork2.conversion.annotations
com.opensymphony.xwork2.conversion.annotations Type conversion annotations.

Classes in com.opensymphony.xwork2.conversion.annotations used by com.opensymphony.xwork2.conversion.annotations
ConversionRule
ConversionRule
ConversionType
ConversionType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ConversionRule (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.conversion.annotations
Enum ConversionRule

java.lang.Object
    extended by  java.lang.Enum<ConversionRule>
        extended by  com.opensymphony.xwork2.conversion.annotations.ConversionRule
All Implemented Interfaces:
Serializable, Comparable<ConversionRule>
public enum ConversionRule
extends Enum<ConversionRule>

ConversionRule

Version:
$Id: ConversionRule.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Rainer Hermanns

Enum Constant Summary
COLLECTION
CREATE_IF_NULL
ELEMENT
KEY
KEY_PROPERTY
MAP
PROPERTY
Method Summary
String | toString()
static ConversionRule | valueOf(String name) Returns the enum constant of this type with the specified name.
static ConversionRule[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

PROPERTY

public static final ConversionRule PROPERTY

COLLECTION

public static final ConversionRule COLLECTION

MAP

public static final ConversionRule MAP

KEY

public static final ConversionRule KEY

KEY_PROPERTY

public static final ConversionRule KEY_PROPERTY

ELEMENT

public static final ConversionRule ELEMENT

CREATE_IF_NULL

public static final ConversionRule CREATE_IF_NULL
Method Detail

values

public static final ConversionRule[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(ConversionRule c : ConversionRule.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static ConversionRule valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name

toString

public String toString()
Overrides:
toString in class Enum<ConversionRule>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


ConversionType (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.conversion.annotations
Enum ConversionType

java.lang.Object
    extended by  java.lang.Enum<ConversionType>
        extended by  com.opensymphony.xwork2.conversion.annotations.ConversionType
All Implemented Interfaces:
Serializable, Comparable<ConversionType>
public enum ConversionType
extends Enum<ConversionType>

ConversionType

Version:
$Id: ConversionType.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Rainer Hermanns

Enum Constant Summary
APPLICATION
CLASS
Method Summary
String | toString()
static ConversionType | valueOf(String name) Returns the enum constant of this type with the specified name.
static ConversionType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

APPLICATION

public static final ConversionType APPLICATION

CLASS

public static final ConversionType CLASS
Method Detail

values

public static final ConversionType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(ConversionType c : ConversionType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static ConversionType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name

toString

public String toString()
Overrides:
toString in class Enum<ConversionType>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Conversion (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.conversion.annotations
Annotation Type Conversion

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Conversion

A marker annotation for type conversions at Type level.

Annotation usage:

The Conversion annotation must be applied at Type level.

Annotation parameters:

Parameter | Required | Default | Description
conversion | no |  | used for Type Conversions applied at Type level.

Example code:

 @Conversion()
 public class ConversionAction implements Action {
 }

Version:
$Id: Conversion.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Rainer Hermanns

Optional Element Summary
 TypeConversion[] conversions
Allow Type Conversions being applied at Type level.

conversions

public abstract TypeConversion[] conversions
Allow Type Conversions being applied at Type level.

Default:
{}
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


TypeConversion (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.conversion.annotations
Annotation Type TypeConversion

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface TypeConversion

This annotation is used for class and application wide conversion rules.

Class wide conversion:
The conversion rules will be assembled in a file called XXXAction-conversion.properties within the same package as the related action class. Set type to: type = ConversionType.CLASS

Allication wide conversion:
The conversion rules will be assembled within the xwork-conversion.properties file within the classpath root. Set type to: type = ConversionType.APPLICATION

Annotation usage: The TypeConversion annotation can be applied at property and method level.

Annotation parameters:

Parameter | Required | Default | Description
key | no | The annotated property/key name | The optional property name mostly used within TYPE level annotations.
type | no | ConversionType.CLASS | Enum value of ConversionType. Determines whether the conversion should be applied at application or class level.
rule | no | ConversionRule.PROPERTY | Enum value of ConversionRule. The ConversionRule can be a property, a Collection or a Map.
converter | either this or value |  | The class name of the TypeConverter to be used as converter.
value | either converter or this |  | The value to set for ConversionRule.KEY_PROPERTY.

Example code:

 @Conversion()
 public class ConversionAction implements Action {

   private String convertInt;

   private String convertDouble;
   private List users = null;

   private HashMap keyValues = null;

   @TypeConversion(type = ConversionType.APPLICATION, converter = "com.opensymphony.xwork2.util.XWorkBasicConverter")
   public void setConvertInt( String convertInt ) {
       this.convertInt = convertInt;
   }

   @TypeConversion(converter = "com.opensymphony.xwork2.util.XWorkBasicConverter")
   public void setConvertDouble( String convertDouble ) {
       this.convertDouble = convertDouble;
   }

   @TypeConversion(rule = ConversionRule.COLLECTION, converter = "java.util.String")
   public void setUsers( List users ) {
       this.users = users;
   }

   @TypeConversion(rule = ConversionRule.MAP, converter = "java.math.BigInteger")
   public void setKeyValues( HashMap keyValues ) {
       this.keyValues = keyValues;
   }

   @TypeConversion(type = ConversionType.APPLICATION, property = "java.util.Date", converter = "com.opensymphony.xwork2.util.XWorkBasicConverter")
   public String execute() throws Exception {
       return SUCCESS;
   }
 }

Version:
$Id: TypeConversion.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Rainer Hermanns

Optional Element Summary
String | converter The class of the TypeConverter to be used as converter.
String | key The optional key name used within TYPE level annotations.
ConversionRule | rule The ConversionRule can be a PROPERTY, KEY, KEY_PROPERTY, ELEMENT, COLLECTION (deprecated) or a MAP.
ConversionType | type The ConversionType can be either APPLICATION or CLASS.
String | value If used with ConversionRule.KEY_PROPERTY specify a value here! Note: If you use ConversionType.APPLICATION, you can not set a value!

key

public abstract String key
The optional key name used within TYPE level annotations. Defaults to the property name.

Default:
""

type

public abstract ConversionType type
The ConversionType can be either APPLICATION or CLASS. Defaults to CLASS. Note: If you use ConversionType.APPLICATION, you can not set a value!

Default:
CLASS

rule

public abstract ConversionRule rule
The ConversionRule can be a PROPERTY, KEY, KEY_PROPERTY, ELEMENT, COLLECTION (deprecated) or a MAP. Note: Collection and Map vonversion rules can be determined via com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer.

See Also:
GenericsObjectTypeDeterminer
Default:
PROPERTY

converter

public abstract String converter
The class of the TypeConverter to be used as converter. Note: This can not be used with ConversionRule.KEY_PROPERTY!

Default:
""

value

public abstract String value
If used with ConversionRule.KEY_PROPERTY specify a value here! Note: If you use ConversionType.APPLICATION, you can not set a value!

Default:
""
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


com.opensymphony.xwork2.conversion.metadata (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.conversion.metadata

Type conversion meta data classes.

See:
Description

Class Summary
ConversionDescription ConversionDescription

Package com.opensymphony.xwork2.conversion.metadata Description

Type conversion meta data classes.


com.opensymphony.xwork2.conversion.metadata Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.conversion.metadata

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.conversion.metadata.ConversionDescription


Uses of Package com.opensymphony.xwork2.conversion.metadata (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.conversion.metadata

No usage of com.opensymphony.xwork2.conversion.metadata

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ConversionDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.conversion.metadata
Class ConversionDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.conversion.metadata.ConversionDescription

public class ConversionDescription
extends Object

ConversionDescription

Version:
$Id: ConversionDescription.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Rainer Hermanns

Field Summary
static String | DEPRECATED_ELEMENT_PREFIX
static String | ELEMENT_PREFIX
String | fullQualifiedClassName
static String | KEY_PREFIX
static String | KEY_PROPERTY_PREFIX
protected static Log | log Jakarta commons-logging reference.
(package private) String | MAP_PREFIX Key used for type conversion of maps.
String | property
String | rule
String | type
String | typeConverter
String | value
Constructor Summary
ConversionDescription()
ConversionDescription(String property)
Creates an ConversionDescription with the specified property name.
Method Summary
String | asProperty() Returns the conversion description as property entry.
String | getFullQualifiedClassName() Returns the fullQualifiedClassName attribute is used to create the special conversion.properties file name.
String | getType()
String | getValue()
void | setFullQualifiedClassName(String fullQualifiedClassName) The fullQualifiedClassName attribute is used to create the special conversion.properties file name.
void | setProperty(String property) Sets the property name to be inserted into the related conversion.properties file. Note: Do not add COLLECTION_PREFIX or MAP_PREFIX keys to property names.
void | setRule(String rule) Sets the rule prefix for COLLECTION_PREFIX or MAP_PREFIX key.
void | setType(String type)
void | setTypeConverter(String typeConverter) Sets the class name of the type converter to be used.
void | setValue(String value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static Log log
Jakarta commons-logging reference.

KEY_PREFIX

public static final String KEY_PREFIX
See Also:
Constant Field Values

ELEMENT_PREFIX

public static final String ELEMENT_PREFIX
See Also:
Constant Field Values

KEY_PROPERTY_PREFIX

public static final String KEY_PROPERTY_PREFIX
See Also:
Constant Field Values

DEPRECATED_ELEMENT_PREFIX

public static final String DEPRECATED_ELEMENT_PREFIX
See Also:
Constant Field Values

MAP_PREFIX

String MAP_PREFIX
Key used for type conversion of maps.

property

public String property

typeConverter

public String typeConverter

rule

public String rule

value

public String value

fullQualifiedClassName

public String fullQualifiedClassName

type

public String type
Constructor Detail

ConversionDescription

public ConversionDescription()

ConversionDescription

public ConversionDescription(String property)
Creates an ConversionDescription with the specified property name.

Parameters:
property -
Method Detail

setProperty

public void setProperty(String property)

Sets the property name to be inserted into the related conversion.properties file.
Note: Do not add COLLECTION_PREFIX or MAP_PREFIX keys to property names.

Parameters:
property - The property to be converted.

setTypeConverter

public void setTypeConverter(String typeConverter)
Sets the class name of the type converter to be used.

Parameters:
typeConverter - The class name of the type converter.

setRule

public void setRule(String rule)
Sets the rule prefix for COLLECTION_PREFIX or MAP_PREFIX key. Defaults to en emtpy String.

Parameters:
rule -

setType

public void setType(String type)

getType

public String getType()

getValue

public String getValue()

setValue

public void setValue(String value)

asProperty

public String asProperty()
Returns the conversion description as property entry.

 Example:
property.name = converter.className
Collection_property.name = converter.className
Map_property.name = converter.className
 KeyProperty_name = id

Returns:
the conversion description as property entry.

getFullQualifiedClassName

public String getFullQualifiedClassName()
Returns the fullQualifiedClassName attribute is used to create the special conversion.properties file name.

Returns:
fullQualifiedClassName

setFullQualifiedClassName

public void setFullQualifiedClassName(String fullQualifiedClassName)
The fullQualifiedClassName attribute is used to create the special conversion.properties file name.

Parameters:
fullQualifiedClassName -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.inject (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.inject

Guice (pronounced "juice").

See:
Description

Interface Summary
Container | Injects dependencies into constructors, methods and fields annotated with Inject.
ContainerBuilder.Command | Implemented by classes which participate in building a container.
ContainerImpl.ContextualCallable<T> |
ContainerImpl.Injector | Injects a field or method in a given object.
ContainerImpl.InjectorFactory<M extends Member & AnnotatedElement> |
Context | Context of the current injection.
Factory<T> | A custom factory.
InternalFactory<T> | Creates objects which will be injected.
Scope.Strategy | Pluggable scoping strategy.

Class Summary
ConstructionContext<T> | Context of a dependency construction.
ConstructionContext.DelegatingInvocationHandler<T> |
ContainerBuilder | Builds a dependency injection Container.
ContainerImpl | Default Container implementation.
ContainerImpl.ConstructorInjector<T> |
ContainerImpl.FieldInjector |
ContainerImpl.MethodInjector |
ContainerImpl.ParameterInjector<T> |
ExternalContext<T> | An immutable snapshot of the current context which is safe to expose to client code.
InternalContext | Internal context.
Key<T> | Dependency mapping key.

Enum Summary
Scope Scope of an injected objects.

Exception Summary
ContainerImpl.MissingDependencyException |
DependencyException | Thrown when a dependency is misconfigured.

Annotation Types Summary
Inject | Annotates members and parameters which should have their value[s] injected.
Scoped | Annotates a scoped implementation class.

Package com.opensymphony.xwork2.inject Description

Guice (pronounced "juice"). A lightweight dependency injection container. Features include:

  • constructor, method, and field injection
  • static method and field injection
  • circular reference support (including constructors if you depend upon interfaces)
  • high performance
  • externalize what needs to be and no more


com.opensymphony.xwork2.inject Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.inject

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.inject.ConstructionContext<T>
    • com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler<T> (implements java.lang.reflect.InvocationHandler)
    • com.opensymphony.xwork2.inject.ContainerBuilder
    • com.opensymphony.xwork2.inject.ContainerImpl (implements com.opensymphony.xwork2.inject.Container)
    • com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector<T>
    • com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector (implements com.opensymphony.xwork2.inject.ContainerImpl.Injector)
    • com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector (implements com.opensymphony.xwork2.inject.ContainerImpl.Injector)
    • com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector<T>
    • com.opensymphony.xwork2.inject.ExternalContext<T> (implements com.opensymphony.xwork2.inject.Context)
    • com.opensymphony.xwork2.inject.InternalContext
    • com.opensymphony.xwork2.inject.Key<T>
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.opensymphony.xwork2.inject.ContainerImpl.MissingDependencyException
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.inject.DependencyException

Interface Hierarchy

  • com.opensymphony.xwork2.inject.ContainerBuilder.Command
  • com.opensymphony.xwork2.inject.ContainerImpl.ContextualCallable<T>
  • com.opensymphony.xwork2.inject.ContainerImpl.InjectorFactory<M>
  • com.opensymphony.xwork2.inject.Context
  • com.opensymphony.xwork2.inject.Factory<T>
  • com.opensymphony.xwork2.inject.Scope.Strategy
  • java.io.Serializable
    • com.opensymphony.xwork2.inject.Container
    • com.opensymphony.xwork2.inject.ContainerImpl.Injector
    • com.opensymphony.xwork2.inject.InternalFactory<T>

Annotation Type Hierarchy

  • com.opensymphony.xwork2.inject.Inject (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.inject.Scoped (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.inject.Scope


Uses of Package com.opensymphony.xwork2.inject (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.inject

Packages that use com.opensymphony.xwork2.inject
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.util | XWork util classes.
org.apache.struts2.components |
org.apache.struts2.components.template |
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.dispatcher.multipart | Classes to help dispatch multipart HTTP requests.
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.debugging |
org.apache.struts2.portlet.result |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.util | Miscellaneous helper classes for all views.
org.apache.struts2.views.velocity | Classes for views using Velocity.
org.apache.struts2.views.xslt | The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.config
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
ContainerBuilder
Builds a dependency injection Container.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.config.impl
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
ContainerBuilder
Builds a dependency injection Container.
Context
Context of the current injection.
Factory
A custom factory.
Scope
Scope of an injected objects.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.config.providers
ContainerBuilder
Builds a dependency injection Container.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.inject
ConstructionContext
Context of a dependency construction.
ConstructionContext.DelegatingInvocationHandler
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
ContainerBuilder
Builds a dependency injection Container.
ContainerImpl
Default Container implementation.
ContainerImpl.ConstructorInjector
ContainerImpl.ContextualCallable
ContainerImpl.Injector
Injects a field or method in a given object.
ContainerImpl.InjectorFactory
ContainerImpl.MissingDependencyException
ContainerImpl.ParameterInjector
Context
Context of the current injection.
ExternalContext
An immutable snapshot of the current context which is safe to expose to client code.
Factory
A custom factory.
Inject
Annotates members and parameters which should have their value[s] injected.
InternalContext
Internal context.
InternalFactory
Creates objects which will be injected.
Key
Dependency mapping key.
Scope
Scope of an injected objects.
Scope.Strategy
Pluggable scoping strategy.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.interceptor
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.spring
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by com.opensymphony.xwork2.util
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.components
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.components.template
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.config
ContainerBuilder
Builds a dependency injection Container.
Context
Context of the current injection.
Factory
A custom factory.
Inject
Annotates members and parameters which should have their value[s] injected.
Scope
Scope of an injected objects.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.dispatcher
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.dispatcher.mapper
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.dispatcher.multipart
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.interceptor
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.interceptor.debugging
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.portlet.result
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.views.freemarker
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.views.util
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.views.velocity
Container
Injects dependencies into constructors, methods and fields annotated with Inject.
Inject
Annotates members and parameters which should have their value[s] injected.

Classes in com.opensymphony.xwork2.inject used by org.apache.struts2.views.xslt
Inject
Annotates members and parameters which should have their value[s] injected.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Container (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface Container

All Superinterfaces:
Serializable
All Known Implementing Classes:
ContainerImpl
public interface Container
extends Serializable

Injects dependencies into constructors, methods and fields annotated with Inject. Immutable.

When injecting a method or constructor, you can additionally annotate its parameters with Inject and specify a dependency name. When a parameter has no annotation, the container uses the name from the method or constructor's Inject annotation respectively.

For example:

  class Foo {

    // Inject the int constant named "i".
    @Inject("i") int i;

    // Inject the default implementation of Bar and the String constant
    // named "s".
    @Inject Foo(Bar bar, @Inject("s") String s) {
      ...
    }

    // Inject the default implementation of Baz and the Bob implementation
    // named "foo".
    @Inject void initialize(Baz baz, @Inject("foo") Bob bob) {
      ...
    }

    // Inject the default implementation of Tee.
    @Inject void setTee(Tee tee) {
      ...
    }
  }

To create and inject an instance of Foo:

  Container c = ...;
  Foo foo = c.inject(Foo.class);

Author:
crazybob@google.com (Bob Lee)
See Also:
ContainerBuilder

Field Summary
static String DEFAULT_NAME
Default dependency name.
Method Summary
<T> T
getInstance(Class<T> type)
Convenience method. Equivalent to getInstance(type, DEFAULT_NAME).
<T> T
getInstance(Class<T> type, String name)
Gets an instance of the given dependency which was declared in ContainerBuilder.
 Set<String> getInstanceNames(Class<?> type)
Gets a set of all registered names for the given type
<T> T
inject(Class<T> implementation)
Creates and injects a new instance of type implementation.
 void inject(Object o)
Injects dependencies into the fields and methods of an existing object.
 void removeScopeStrategy()
Removes the scope strategy for the current thread.
 void setScopeStrategy(Scope.Strategy scopeStrategy)
Sets the scope strategy for the current thread.

Field Detail

DEFAULT_NAME

static final String DEFAULT_NAME
Default dependency name.

See Also:
Constant Field Values
Method Detail

inject

void inject(Object o)
Injects dependencies into the fields and methods of an existing object.

inject

<T> T inject(Class<T> implementation)
Creates and injects a new instance of type implementation.

getInstance

<T> T getInstance(Class<T> type,
                  String name)
Gets an instance of the given dependency which was declared in ContainerBuilder.

getInstance

<T> T getInstance(Class<T> type)
Convenience method. Equivalent to getInstance(type, DEFAULT_NAME).

getInstanceNames

Set<String> getInstanceNames(Class<?> type)
Gets a set of all registered names for the given type

Parameters:
type - The instance type
Returns:
A set of registered names

setScopeStrategy

void setScopeStrategy(Scope.Strategy scopeStrategy)
Sets the scope strategy for the current thread.

removeScopeStrategy

void removeScopeStrategy()
Removes the scope strategy for the current thread.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Context (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface Context

All Known Implementing Classes:
ExternalContext
public interface Context

Context of the current injection.

Author:
crazybob@google.com (Bob Lee)

Method Summary
 Container getContainer()
Gets the Container.
 Member getMember()
Gets the field, method or constructor which is being injected.
 String getName()
Gets the name of the injection specified by Inject.value().
 Scope.Strategy getScopeStrategy()
Gets the current scope strategy.
 Class<?> getType()
Gets the type of the field or parameter which is being injected.

Method Detail

getContainer

Container getContainer()
Gets the Container.

getScopeStrategy

Scope.Strategy getScopeStrategy()
Gets the current scope strategy. See Container.setScopeStrategy(Scope.Strategy).

Throws:
IllegalStateException - if no strategy has been set

getMember

Member getMember()
Gets the field, method or constructor which is being injected. Returns null if the object currently being constructed is pre-loaded as a singleton or requested from Container.getInstance(Class).

getType

Class<?> getType()
Gets the type of the field or parameter which is being injected.

getName

String getName()
Gets the name of the injection specified by Inject.value().

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Factory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface Factory<T>

All Known Implementing Classes:
BeanSelectionProvider.ObjectFactoryDelegateFactory, LocatableConstantFactory, LocatableFactory
public interface Factory<T>

A custom factory. Creates objects which will be injected.

Author:
crazybob@google.com (Bob Lee)

Method Summary
 T create(Context context)
Creates an object to be injected.

Method Detail

create

T create(Context context)
         throws Exception
Creates an object to be injected.

Parameters:
context - of this injection
Returns:
instance to be injected
Throws:
Exception - if unable to create object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InternalFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface InternalFactory<T>

All Superinterfaces:
Serializable
interface InternalFactory<T>
extends Serializable

Creates objects which will be injected.

Author:
crazybob@google.com (Bob Lee)

Method Summary
 T create(InternalContext context)
Creates an object to be injected.

Method Detail

create

T create(InternalContext context)
Creates an object to be injected.

Parameters:
context - of this injection
Returns:
instance to be injected
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConstructionContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ConstructionContext<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ConstructionContext<T>

 class ConstructionContext<T>
extends Object

Context of a dependency construction. Used to manage circular references.

Author:
crazybob@google.com (Bob Lee)

Nested Class Summary
(package private) static class ConstructionContext.DelegatingInvocationHandler<T>
Field Summary
(package private) boolean | constructing
(package private) T | currentReference
(package private) List<ConstructionContext.DelegatingInvocationHandler<T>> | invocationHandlers
Constructor Summary
ConstructionContext()
Method Summary
(package private) Object | createProxy(Class<? super T> expectedType)
(package private) void | finishConstruction()
(package private) T | getCurrentReference()
(package private) boolean | isConstructing()
(package private) void | removeCurrentReference()
(package private) void | setCurrentReference(T currentReference)
(package private) void | setProxyDelegates(T delegate)
(package private) void | startConstruction()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

currentReference

T currentReference

constructing

boolean constructing

invocationHandlers

List<ConstructionContext.DelegatingInvocationHandler<T>> invocationHandlers
Constructor Detail

ConstructionContext

ConstructionContext()
Method Detail

getCurrentReference

T getCurrentReference()

removeCurrentReference

void removeCurrentReference()

setCurrentReference

void setCurrentReference(T currentReference)

isConstructing

boolean isConstructing()

startConstruction

void startConstruction()

finishConstruction

void finishConstruction()

createProxy

Object createProxy(Class<? super T> expectedType)

setProxyDelegates

void setProxyDelegates(T delegate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ContainerBuilder (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ContainerBuilder

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ContainerBuilder

public final class ContainerBuilder
extends Object

Builds a dependency injection Container. The combination of dependency type and name uniquely identifies a dependency mapping; you can use the same name for two different types. Not safe for concurrent use.

Adds the following factories by default:

  • Injects the current Container.
  • Injects the Logger for the injected member's declaring class.

Author:
crazybob@google.com (Bob Lee)

Nested Class Summary
static interface ContainerBuilder.Command
Implemented by classes which participate in building a container.
Field Summary
private static InternalFactory<Container> | CONTAINER_FACTORY
(package private) boolean | created
(package private) Map<Key<?>,InternalFactory<?>> | factories
private static InternalFactory<Logger> | LOGGER_FACTORY
(package private) List<InternalFactory<?>> | singletonFactories
(package private) List<Class<?>> | staticInjections
Constructor Summary
ContainerBuilder()
Constructs a new builder.
Method Summary
<T> ContainerBuilder
alias(Class<T> type, String alias)
Convenience method. Equivalent to alias(type, Container.DEFAULT_NAME, type).
<T> ContainerBuilder
alias(Class<T> type, String name, String alias)
Maps an existing factory to a new name.
private
<T> ContainerBuilder
alias(Key<T> key, Key<T> aliasKey)
Maps an existing dependency.
private  void checkKey(Key<?> key)
Ensures a key isn't already mapped.
private
<T> ContainerBuilder
constant(Class<T> type, String name, T value)
Maps a constant value to the given type and name.
 ContainerBuilder constant(String name, boolean value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, char value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, Class value)
Maps a class to the given name.
 ContainerBuilder constant(String name, double value)
Maps a constant value to the given name.
<E extends Enum<E>>
ContainerBuilder
constant(String name, E value)
Maps an enum to the given name.
 ContainerBuilder constant(String name, float value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, int value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, long value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, short value)
Maps a constant value to the given name.
 ContainerBuilder constant(String name, String value)
Maps a constant value to the given name.
 boolean contains(Class<?> type)
Convenience method. Equivalent to contains(type, Container.DEFAULT_NAME).
 boolean contains(Class<?> type, String name)
Returns true if this builder contains a mapping for the given type and name.
 Container create(boolean loadSingletons)
Creates a Container instance.
private  void ensureNotCreated()
Currently we only support creating one Container instance per builder.
<T> ContainerBuilder
factory(Class<T> type)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type).
<T> ContainerBuilder
factory(Class<T> type, Class<? extends T> implementation)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation).
<T> ContainerBuilder
factory(Class<T> type, Class<? extends T> implementation, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).
<T> ContainerBuilder
factory(Class<T> type, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).
<T> ContainerBuilder
factory(Class<T> type, Factory<? extends T> factory, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
<T> ContainerBuilder
factory(Class<T> type, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).
<T> ContainerBuilder
factory(Class<T> type, String name)
Convenience method. Equivalent to factory(type, name, type).
<T> ContainerBuilder
factory(Class<T> type, String name, Class<? extends T> implementation)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
factory(Class<T> type, String name, Class<? extends T> implementation, Scope scope)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
factory(Class<T> type, String name, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).
<T> ContainerBuilder
factory(Class<T> type, String name, Factory<? extends T> factory, Scope scope)
Maps a factory to a given dependency type and name.
<T> ContainerBuilder
factory(Class<T> type, String name, Scope scope)
Convenience method. Equivalent to factory(type, name, type, scope).
private
<T> ContainerBuilder
factory(Key<T> key, InternalFactory<? extends T> factory, Scope scope)
Maps a dependency.
 ContainerBuilder injectStatics(Class<?>... types)
Upon creation, the Container will inject static fields and methods into the given classes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

factories

final Map<Key<?>,InternalFactory<?>> factories

singletonFactories

final List<InternalFactory<?>> singletonFactories

staticInjections

final List<Class<?>> staticInjections

created

boolean created

CONTAINER_FACTORY

private static final InternalFactory<Container> CONTAINER_FACTORY

LOGGER_FACTORY

private static final InternalFactory<Logger> LOGGER_FACTORY
Constructor Detail

ContainerBuilder

public ContainerBuilder()
Constructs a new builder.

Method Detail

factory

private <T> ContainerBuilder factory(Key<T> key,
                                     InternalFactory<? extends T> factory,
                                     Scope scope)
Maps a dependency. All methods in this class ultimately funnel through here.

checkKey

private void checkKey(Key<?> key)
Ensures a key isn't already mapped.

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Factory<? extends T> factory,
                                    Scope scope)
Maps a factory to a given dependency type and name.

Parameters:
type - of dependency
name - of dependency
factory - creates objects to inject
scope - scope of injected instances
Returns:
this builder

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Factory<? extends T> factory,
                                    Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).

See Also:
factory(Class, String, Factory, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).

See Also:
factory(Class, String, Factory, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).

See Also:
factory(Class, String, Factory, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Class<? extends T> implementation,
                                    Scope scope)
Maps an implementation class to a given dependency type and name. Creates instances using the container, recursively injecting dependencies.

Parameters:
type - of dependency
name - of dependency
implementation - class
scope - scope of injected instances
Returns:
this builder

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Class<? extends T> implementation)
Maps an implementation class to a given dependency type and name. Creates instances using the container, recursively injecting dependencies.

Sets scope to value from Scoped annotation on the implementation class. Defaults to Scope.DEFAULT if no annotation is found.

Parameters:
type - of dependency
name - of dependency
implementation - class
Returns:
this builder

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Class<? extends T> implementation)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation).

See Also:
factory(Class, String, Class)

factory

public <T> ContainerBuilder factory(Class<T> type)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type).

See Also:
factory(Class, String, Class)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name)
Convenience method. Equivalent to factory(type, name, type).

See Also:
factory(Class, String, Class)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Class<? extends T> implementation,
                                    Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).

See Also:
factory(Class, String, Class, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).

See Also:
factory(Class, String, Class, Scope)

factory

public <T> ContainerBuilder factory(Class<T> type,
                                    String name,
                                    Scope scope)
Convenience method. Equivalent to factory(type, name, type, scope).

See Also:
factory(Class, String, Class, Scope)

alias

public <T> ContainerBuilder alias(Class<T> type,
                                  String alias)
Convenience method. Equivalent to alias(type, Container.DEFAULT_NAME, type).

See Also:
alias(Class, String, String)

alias

public <T> ContainerBuilder alias(Class<T> type,
                                  String name,
                                  String alias)
Maps an existing factory to a new name.

Parameters:
type - of dependency
name - of dependency
alias - of to the dependency
Returns:
this builder

alias

private <T> ContainerBuilder alias(Key<T> key,
                                   Key<T> aliasKey)
Maps an existing dependency. All methods in this class ultimately funnel through here.

constant

public ContainerBuilder constant(String name,
                                 String value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 int value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 long value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 boolean value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 double value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 float value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 short value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 char value)
Maps a constant value to the given name.

constant

public ContainerBuilder constant(String name,
                                 Class value)
Maps a class to the given name.

constant

public <E extends Enum<E>> ContainerBuilder constant(String name,
                                                     E value)
Maps an enum to the given name.

constant

private <T> ContainerBuilder constant(Class<T> type,
                                      String name,
                                      T value)
Maps a constant value to the given type and name.

injectStatics

public ContainerBuilder injectStatics(Class<?>... types)
Upon creation, the Container will inject static fields and methods into the given classes.

Parameters:
types - for which static members will be injected

contains

public boolean contains(Class<?> type,
                        String name)
Returns true if this builder contains a mapping for the given type and name.

contains

public boolean contains(Class<?> type)
Convenience method. Equivalent to contains(type, Container.DEFAULT_NAME).

create

public Container create(boolean loadSingletons)
Creates a Container instance. Injects static members for classes which were registered using injectStatics(Class...).

Parameters:
loadSingletons - If true, the container will load all singletons now. If false, the container will lazily load singletons. Eager loading is appropriate for production use while lazy loading can speed development.
Throws:
IllegalStateException - if called more than once

ensureNotCreated

private void ensureNotCreated()
Currently we only support creating one Container instance per builder. If we want to support creating more than one container per builder, we should move to a "factory factory" model where we create a factory instance per Container. Right now, one factory instance would be shared across all the containers, singletons synchronize on the container when lazy loading, etc.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerBuilder.Command (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface ContainerBuilder.Command

Enclosing class:
ContainerBuilder
public static interface ContainerBuilder.Command

Implemented by classes which participate in building a container.

Method Summary
 void build(ContainerBuilder builder)
Contributes factories to the given builder.

Method Detail

build

void build(ContainerBuilder builder)
Contributes factories to the given builder.

Parameters:
builder -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ContainerImpl

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ContainerImpl
All Implemented Interfaces:
Container, Serializable
 class ContainerImpl
extends Object
implements Container

Default Container implementation.

Author:
crazybob@google.com (Bob Lee)
See Also:
ContainerBuilder

Nested Class Summary
(package private) static class | ContainerImpl.ConstructorInjector<T>
(package private) static interface | ContainerImpl.ContextualCallable<T>
(package private) static class | ContainerImpl.FieldInjector
(package private) static interface | ContainerImpl.Injector Injects a field or method in a given object.
(package private) static interface | ContainerImpl.InjectorFactory<M extends Member & AnnotatedElement>
(package private) static class | ContainerImpl.MethodInjector
(package private) static class | ContainerImpl.MissingDependencyException
(package private) static class | ContainerImpl.ParameterInjector<T>
Field Summary
(package private) Map<Class<?>,ContainerImpl.ConstructorInjector> | constructors
(package private) Map<Key<?>,InternalFactory<?>> | factories
(package private) Map<Class<?>,Set<String>> | factoryNamesByType
(package private) Map<Class<?>,List<ContainerImpl.Injector>> | injectors Field and method injectors.
(package private) ThreadLocal<InternalContext[]> | localContext
(package private) ThreadLocal<Scope.Strategy> | localScopeStrategy
Fields inherited from interface com.opensymphony.xwork2.inject.Container
DEFAULT_NAME
Constructor Summary
ContainerImpl(Map<Key<?>,InternalFactory<?>> factories)
Method Summary
(package private)  void addInjectors(Class clazz, List<ContainerImpl.Injector> injectors)
Recursively adds injectors for fields and methods from the given class to the given list.
(package private)  void addInjectorsForFields(Field[] fields, boolean statics, List<ContainerImpl.Injector> injectors)
(package private)
<M extends Member & AnnotatedElement>
void
addInjectorsForMembers(List<M> members, boolean statics, List<ContainerImpl.Injector> injectors, ContainerImpl.InjectorFactory<M> injectorFactory)
(package private)  void addInjectorsForMethods(Method[] methods, boolean statics, List<ContainerImpl.Injector> injectors)
(package private)
<T> T
callInContext(ContainerImpl.ContextualCallable<T> callable)
Looks up thread local context.
(package private)
<T> ContainerImpl.ParameterInjector<T>
createParameterInjector(Key<T> key, Member member)
(package private)  Inject findInject(Annotation[] annotations)
Finds the Inject annotation in an array of annotations.
(package private)
<T> ContainerImpl.ConstructorInjector<T>
getConstructor(Class<T> implementation)
Gets a constructor function for a given implementation class.
(package private)
<T> InternalFactory<? extends T>
getFactory(Key<T> key)
<T> T
getInstance(Class<T> type)
Convenience method. Equivalent to getInstance(type, DEFAULT_NAME).
(package private)
<T> T
getInstance(Class<T> type, InternalContext context)
<T> T
getInstance(Class<T> type, String name)
Gets an instance of the given dependency which was declared in ContainerBuilder.
(package private)
<T> T
getInstance(Class<T> type, String name, InternalContext context)
 Set<String> getInstanceNames(Class<?> type)
Gets a set of all registered names for the given type
private static Object[] getParameters(Member member, InternalContext context, ContainerImpl.ParameterInjector[] parameterInjectors)
(package private)
<M extends AccessibleObject & Member>
ContainerImpl.ParameterInjector<?>[]
getParametersInjectors(M member, Annotation[][] annotations, Class[] parameterTypes, String defaultName)
Gets parameter injectors.
<T> T
inject(Class<T> implementation)
Creates and injects a new instance of type implementation.
(package private)
<T> T
inject(Class<T> implementation, InternalContext context)
 void inject(Object o)
Injects dependencies into the fields and methods of an existing object.
(package private)  void inject(Object o, InternalContext context)
(package private)  void injectStatics(List<Class<?>> staticInjections)
private  boolean isStatic(Member member)
 void removeScopeStrategy()
Removes the scope strategy for the current thread.
 void setScopeStrategy(Scope.Strategy scopeStrategy)
Sets the scope strategy for the current thread.
private  ContainerImpl.ParameterInjector<?>[] toArray(List<ContainerImpl.ParameterInjector<?>> parameterInjections)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

factories

final Map<Key<?>,InternalFactory<?>> factories

factoryNamesByType

final Map<Class<?>,Set<String>> factoryNamesByType

injectors

final Map<Class<?>,List<ContainerImpl.Injector>> injectors
Field and method injectors.

constructors

Map<Class<?>,ContainerImpl.ConstructorInjector> constructors

localContext

ThreadLocal<InternalContext[]> localContext

localScopeStrategy

final ThreadLocal<Scope.Strategy> localScopeStrategy
Constructor Detail

ContainerImpl

ContainerImpl(Map<Key<?>,InternalFactory<?>> factories)
Method Detail

getFactory

<T> InternalFactory<? extends T> getFactory(Key<T> key)

addInjectors

void addInjectors(Class clazz,
                  List<ContainerImpl.Injector> injectors)
Recursively adds injectors for fields and methods from the given class to the given list. Injects parent classes before sub classes.

injectStatics

void injectStatics(List<Class<?>> staticInjections)

addInjectorsForMethods

void addInjectorsForMethods(Method[] methods,
                            boolean statics,
                            List<ContainerImpl.Injector> injectors)

addInjectorsForFields

void addInjectorsForFields(Field[] fields,
                           boolean statics,
                           List<ContainerImpl.Injector> injectors)

addInjectorsForMembers

<M extends Member & AnnotatedElement> void addInjectorsForMembers(List<M> members,
                                                                 boolean statics,
                                                                 List<ContainerImpl.Injector> injectors,
                                                                 ContainerImpl.InjectorFactory<M> injectorFactory)

isStatic

private boolean isStatic(Member member)

getParametersInjectors

<M extends AccessibleObject & Member> ContainerImpl.ParameterInjector<?>[] getParametersInjectors(M member,
                                                                                Annotation[][] annotations,
                                                                                Class[] parameterTypes,
                                                                                String defaultName)
                                                      throws ContainerImpl.MissingDependencyException
Gets parameter injectors.

Parameters:
member - to which the parameters belong
annotations - on the parameters
parameterTypes - parameter types
Returns:
injections
Throws:
ContainerImpl.MissingDependencyException

createParameterInjector

<T> ContainerImpl.ParameterInjector<T> createParameterInjector(Key<T> key,
                                                               Member member)
                                                     throws ContainerImpl.MissingDependencyException
Throws:
ContainerImpl.MissingDependencyException

toArray

private ContainerImpl.ParameterInjector<?>[] toArray(List<ContainerImpl.ParameterInjector<?>> parameterInjections)

findInject

Inject findInject(Annotation[] annotations)
Finds the Inject annotation in an array of annotations.

getParameters

private static Object[] getParameters(Member member,
                                      InternalContext context,
                                      ContainerImpl.ParameterInjector[] parameterInjectors)

inject

void inject(Object o,
            InternalContext context)

inject

<T> T inject(Class<T> implementation,
             InternalContext context)

getInstance

<T> T getInstance(Class<T> type,
                  String name,
                  InternalContext context)

getInstance

<T> T getInstance(Class<T> type,
                  InternalContext context)

inject

public void inject(Object o)
Description copied from interface: Container
Injects dependencies into the fields and methods of an existing object.

Specified by:
inject in interface Container

inject

public <T> T inject(Class<T> implementation)
Description copied from interface: Container
Creates and injects a new instance of type implementation.

Specified by:
inject in interface Container

getInstance

public <T> T getInstance(Class<T> type,
                         String name)
Description copied from interface: Container
Gets an instance of the given dependency which was declared in ContainerBuilder.

Specified by:
getInstance in interface Container

getInstance

public <T> T getInstance(Class<T> type)
Description copied from interface: Container
Convenience method. Equivalent to getInstance(type, DEFAULT_NAME).

Specified by:
getInstance in interface Container

getInstanceNames

public Set<String> getInstanceNames(Class<?> type)
Description copied from interface: Container
Gets a set of all registered names for the given type

Specified by:
getInstanceNames in interface Container
Parameters:
type - The instance type
Returns:
A set of registered names

callInContext

<T> T callInContext(ContainerImpl.ContextualCallable<T> callable)
Looks up thread local context. Creates (and removes) a new context if necessary.

getConstructor

<T> ContainerImpl.ConstructorInjector<T> getConstructor(Class<T> implementation)
Gets a constructor function for a given implementation class.

setScopeStrategy

public void setScopeStrategy(Scope.Strategy scopeStrategy)
Description copied from interface: Container
Sets the scope strategy for the current thread.

Specified by:
setScopeStrategy in interface Container

removeScopeStrategy

public void removeScopeStrategy()
Description copied from interface: Container
Removes the scope strategy for the current thread.

Specified by:
removeScopeStrategy in interface Container
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl.FieldInjector (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ContainerImpl.FieldInjector

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector
All Implemented Interfaces:
ContainerImpl.Injector, Serializable
Enclosing class:
ContainerImpl
static class ContainerImpl.FieldInjector
extends Object
implements ContainerImpl.Injector

Field Summary
(package private) ExternalContext<?> | externalContext
(package private) InternalFactory<?> | factory
(package private) Field | field
Constructor Summary
ContainerImpl.FieldInjector(ContainerImpl container, Field field, String name)
Method Summary
 void inject(InternalContext context, Object o)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

field

final Field field

factory

final InternalFactory<?> factory

externalContext

final ExternalContext<?> externalContext
Constructor Detail

ContainerImpl.FieldInjector

public ContainerImpl.FieldInjector(ContainerImpl container,
                                   Field field,
                                   String name)
                            throws ContainerImpl.MissingDependencyException
Throws:
ContainerImpl.MissingDependencyException
Method Detail

inject

public void inject(InternalContext context,
                   Object o)
Specified by:
inject in interface ContainerImpl.Injector
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl.Injector (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface ContainerImpl.Injector

All Superinterfaces:
Serializable
All Known Implementing Classes:
ContainerImpl.FieldInjector, ContainerImpl.MethodInjector
Enclosing class:
ContainerImpl
static interface ContainerImpl.Injector
extends Serializable

Injects a field or method in a given object.

Method Summary
 void inject(InternalContext context, Object o)

Method Detail

inject

void inject(InternalContext context,
            Object o)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl.MethodInjector (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ContainerImpl.MethodInjector

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector
All Implemented Interfaces:
ContainerImpl.Injector, Serializable
Enclosing class:
ContainerImpl
static class ContainerImpl.MethodInjector
extends Object
implements ContainerImpl.Injector

Field Summary
(package private) Method | method
(package private) ContainerImpl.ParameterInjector<?>[] | parameterInjectors
Constructor Summary
ContainerImpl.MethodInjector(ContainerImpl container, Method method, String name)
Method Summary
 void inject(InternalContext context, Object o)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

method

final Method method

parameterInjectors

final ContainerImpl.ParameterInjector<?>[] parameterInjectors
Constructor Detail

ContainerImpl.MethodInjector

public ContainerImpl.MethodInjector(ContainerImpl container,
                                    Method method,
                                    String name)
                             throws ContainerImpl.MissingDependencyException
Throws:
ContainerImpl.MissingDependencyException
Method Detail

inject

public void inject(InternalContext context,
                   Object o)
Specified by:
inject in interface ContainerImpl.Injector
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl.MissingDependencyException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ContainerImpl.MissingDependencyException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  com.opensymphony.xwork2.inject.ContainerImpl.MissingDependencyException
All Implemented Interfaces:
Serializable
Enclosing class:
ContainerImpl
static class ContainerImpl.MissingDependencyException
extends Exception

Constructor Summary
ContainerImpl.MissingDependencyException(String message)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ContainerImpl.MissingDependencyException

ContainerImpl.MissingDependencyException(String message)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExternalContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ExternalContext<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ExternalContext<T>
All Implemented Interfaces:
Context
 class ExternalContext<T>
extends Object
implements Context

An immutable snapshot of the current context which is safe to expose to client code.

Author:
crazybob@google.com (Bob Lee)

Field Summary
(package private) ContainerImpl | container
(package private) Key<T> | key
(package private) Member | member
Constructor Summary
ExternalContext(Member member, Key<T> key, ContainerImpl container)
Method Summary
 Container getContainer()
Gets the Container.
 Member getMember()
Gets the field, method or constructor which is being injected.
 String getName()
Gets the name of the injection specified by Inject.value().
 Scope.Strategy getScopeStrategy()
Gets the current scope strategy.
 Class<T> getType()
Gets the type of the field or parameter which is being injected.
(package private) static
<T> ExternalContext<T>
newInstance(Member member, Key<T> key, ContainerImpl container)
 String toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

member

final Member member

key

final Key<T> key

container

final ContainerImpl container
Constructor Detail

ExternalContext

public ExternalContext(Member member,
                       Key<T> key,
                       ContainerImpl container)
Method Detail

getType

public Class<T> getType()
Description copied from interface: Context
Gets the type of the field or parameter which is being injected.

Specified by:
getType in interface Context

getScopeStrategy

public Scope.Strategy getScopeStrategy()
Description copied from interface: Context
Gets the current scope strategy. See Container.setScopeStrategy(Scope.Strategy).

Specified by:
getScopeStrategy in interface Context

getContainer

public Container getContainer()
Description copied from interface: Context
Gets the Container.

Specified by:
getContainer in interface Context

getMember

public Member getMember()
Description copied from interface: Context
Gets the field, method or constructor which is being injected. Returns null if the object currently being constructed is pre-loaded as a singleton or requested from Container.getInstance(Class).

Specified by:
getMember in interface Context

getName

public String getName()
Description copied from interface: Context
Gets the name of the injection specified by Inject.value().

Specified by:
getName in interface Context

toString

public String toString()
Overrides:
toString in class Object

newInstance

static <T> ExternalContext<T> newInstance(Member member,
                                          Key<T> key,
                                          ContainerImpl container)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InternalContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class InternalContext

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.InternalContext

 class InternalContext
extends Object

Internal context. Used to coordinate injections and support circular dependencies.

Author:
crazybob@google.com (Bob Lee)

Field Summary
(package private) Map<Object,ConstructionContext<?>> | constructionContexts
(package private) ContainerImpl | container
(package private) ExternalContext<?> | externalContext
(package private) Scope.Strategy | scopeStrategy
Constructor Summary
InternalContext(ContainerImpl container)
Method Summary
(package private)
<T> ConstructionContext<T>
getConstructionContext(Object key)
 Container getContainer()
(package private)  ContainerImpl getContainerImpl()
(package private)
<T> ExternalContext<T>
getExternalContext()
(package private)  Scope.Strategy getScopeStrategy()
(package private)  void setExternalContext(ExternalContext<?> externalContext)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

container

final ContainerImpl container

constructionContexts

final Map<Object,ConstructionContext<?>> constructionContexts

scopeStrategy

Scope.Strategy scopeStrategy

externalContext

ExternalContext<?> externalContext
Constructor Detail

InternalContext

InternalContext(ContainerImpl container)
Method Detail

getContainer

public Container getContainer()

getContainerImpl

ContainerImpl getContainerImpl()

getScopeStrategy

Scope.Strategy getScopeStrategy()

getConstructionContext

<T> ConstructionContext<T> getConstructionContext(Object key)

getExternalContext

<T> ExternalContext<T> getExternalContext()

setExternalContext

void setExternalContext(ExternalContext<?> externalContext)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Key (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class Key<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.Key<T>

 class Key<T>
extends Object

Dependency mapping key. Uniquely identified by the required type and name.

Author:
crazybob@google.com (Bob Lee)

Field Summary
(package private) int | hashCode
(package private) String | name
(package private) Class<T> | type
Constructor Summary
private Key(Class<T> type, String name)
Method Summary
 boolean equals(Object o)
(package private)  String getName()
(package private)  Class<T> getType()
 int hashCode()
(package private) static
<T> Key<T>
newInstance(Class<T> type, String name)
 String toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

type

final Class<T> type

name

final String name

hashCode

final int hashCode
Constructor Detail

Key

private Key(Class<T> type,
            String name)
Method Detail

getType

Class<T> getType()

getName

String getName()

hashCode

public int hashCode()
Overrides:
hashCode in class Object

equals

public boolean equals(Object o)
Overrides:
equals in class Object

toString

public String toString()
Overrides:
toString in class Object

newInstance

static <T> Key<T> newInstance(Class<T> type,
                              String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Scope (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.inject
Enum Scope

java.lang.Object
    extended by  java.lang.Enum<Scope>
        extended by  com.opensymphony.xwork2.inject.Scope
All Implemented Interfaces:
Serializable, Comparable<Scope>
public enum Scope
extends Enum<Scope>

Scope of an injected objects.

Author:
crazybob

Nested Class Summary
static interface Scope.Strategy
Pluggable scoping strategy.
Enum Constant Summary
DEFAULT
One instance per injection.
REQUEST
One instance per request.
SESSION
One instance per session.
SINGLETON
One instance per container.
THREAD
One instance per thread.
WIZARD
One instance per wizard.
Method Summary
(package private) abstract
<T> InternalFactory<? extends T>
scopeFactory(Class<T> type, String name, InternalFactory<? extends T> factory)
Wraps factory with scoping logic.
(package private)
<T> Callable<? extends T>
toCallable(InternalContext context, InternalFactory<? extends T> factory)
static Scope valueOf(String name)
Returns the enum constant of this type with the specified name.
static Scope[] values()
Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

DEFAULT

public static final Scope DEFAULT
One instance per injection.

SINGLETON

public static final Scope SINGLETON
One instance per container.

THREAD

public static final Scope THREAD
One instance per thread.

Note: if a thread local object strongly references its Container, neither the Container nor the object will be eligible for garbage collection, i.e. memory leak.

REQUEST

public static final Scope REQUEST
One instance per request.

SESSION

public static final Scope SESSION
One instance per session.

WIZARD

public static final Scope WIZARD
One instance per wizard.

Method Detail

values

public static final Scope[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(Scope c : Scope.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static Scope valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name

toCallable

<T> Callable<? extends T> toCallable(InternalContext context,
                                     InternalFactory<? extends T> factory)

scopeFactory

abstract <T> InternalFactory<? extends T> scopeFactory(Class<T> type,
                                                       String name,
                                                       InternalFactory<? extends T> factory)
Wraps factory with scoping logic.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


Scope.Strategy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface Scope.Strategy

Enclosing class:
Scope
public static interface Scope.Strategy

Pluggable scoping strategy. Enables users to provide custom implementations of request, session, and wizard scopes. Implement and pass to Container.setScopeStrategy(com.opensymphony.xwork2.inject.Scope.Strategy).

Method Summary
<T> T
findInRequest(Class<T> type, String name, Callable<? extends T> factory)
Finds an object for the given type and name in the request scope.
<T> T
findInSession(Class<T> type, String name, Callable<? extends T> factory)
Finds an object for the given type and name in the session scope.
<T> T
findInWizard(Class<T> type, String name, Callable<? extends T> factory)
Finds an object for the given type and name in the wizard scope.

Method Detail

findInRequest

<T> T findInRequest(Class<T> type,
                    String name,
                    Callable<? extends T> factory)
                throws Exception
Finds an object for the given type and name in the request scope. Creates a new object if necessary using the given factory.

Throws:
Exception

findInSession

<T> T findInSession(Class<T> type,
                    String name,
                    Callable<? extends T> factory)
                throws Exception
Finds an object for the given type and name in the session scope. Creates a new object if necessary using the given factory.

Throws:
Exception

findInWizard

<T> T findInWizard(Class<T> type,
                   String name,
                   Callable<? extends T> factory)
               throws Exception
Finds an object for the given type and name in the wizard scope. Creates a new object if necessary using the given factory.

Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DependencyException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class DependencyException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.inject.DependencyException
All Implemented Interfaces:
Serializable
public class DependencyException
extends RuntimeException

Thrown when a dependency is misconfigured.

Author:
crazybob@google.com (Bob Lee)
See Also:
Serialized Form

Constructor Summary
DependencyException(String message)
DependencyException(String message, Throwable cause)
DependencyException(Throwable cause)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DependencyException

public DependencyException(String message)

DependencyException

public DependencyException(String message,
                           Throwable cause)

DependencyException

public DependencyException(Throwable cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Inject (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.inject
Annotation Type Inject

@Target(value={METHOD,CONSTRUCTOR,FIELD,PARAMETER})
@Retention(value=RUNTIME)
public @interface Inject

Annotates members and parameters which should have their value[s] injected.

Author:
crazybob@google.com (Bob Lee)

Optional Element Summary
boolean | required Whether or not injection is required.
String | value Dependency name.

value

public abstract String value
Dependency name. Defaults to Container.DEFAULT_NAME.

Default:
"default"

required

public abstract boolean required
Whether or not injection is required. Applicable only to methods and fields (not constructors or parameters).

Default:
true
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Scoped (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.inject
Annotation Type Scoped

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Scoped

Annotates a scoped implementation class.

Author:
crazybob

Required Element Summary
 Scope value
Scope.

Element Detail

value

public abstract Scope value
Scope.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


com.opensymphony.xwork2.inject.util (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.inject.util

Guice util classes.

See:
Description

Interface Summary
FinalizableReference | Package-private interface implemented by references that have code to run after garbage collection of their referents.
Function<F,T> | A Function provides a transformation on an object and returns the resulting object.
ReferenceMap.InternalReference | Marker interface to differentiate external and internal references.
ReferenceMap.Strategy |

Class Summary
FinalizablePhantomReference<T> | Phantom reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableReferenceQueue | Starts a background thread that cleans up after reclaimed referents.
FinalizableSoftReference<T> | Soft reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableWeakReference<T> | Weak reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
ReferenceCache<K,V> | Extends ReferenceMap to support lazy loading values by overriding ReferenceCache.create(Object).
ReferenceMap<K,V> | Concurrent hash map that wraps keys and/or values in soft or weak references.
ReferenceMap.KeyReferenceAwareWrapper | Used for keys.
ReferenceMap.ReferenceAwareWrapper | Big hack.
Strings | String utilities.

Enum Summary
ReferenceMap.PutStrategy |
ReferenceType | Reference type.

Package com.opensymphony.xwork2.inject.util Description

Guice util classes.


com.opensymphony.xwork2.inject.util Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.inject.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizablePhantomReference<T> (implements com.opensymphony.xwork2.inject.util.FinalizableReference)
      • java.lang.ref.SoftReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizableSoftReference<T> (implements com.opensymphony.xwork2.inject.util.FinalizableReference)
          • com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference (implements com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference)
          • com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference (implements com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference)
      • java.lang.ref.WeakReference<T>
        • com.opensymphony.xwork2.inject.util.FinalizableWeakReference<T> (implements com.opensymphony.xwork2.inject.util.FinalizableReference)
          • com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference (implements com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference)
          • com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference (implements com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference)
    • com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate (implements java.util.concurrent.Callable<V>)
    • com.opensymphony.xwork2.inject.util.ReferenceMap<K,V> (implements java.util.Map<K,V>, java.io.Serializable)
      • com.opensymphony.xwork2.inject.util.ReferenceCache<K,V>
    • com.opensymphony.xwork2.inject.util.ReferenceMap.Entry (implements java.util.Map.Entry<K,V>)
    • com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper
      • com.opensymphony.xwork2.inject.util.ReferenceMap.KeyReferenceAwareWrapper
    • java.lang.ref.ReferenceQueue<T>
      • com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue
    • com.opensymphony.xwork2.inject.util.Strings

Interface Hierarchy

  • com.opensymphony.xwork2.inject.util.FinalizableReference
  • com.opensymphony.xwork2.inject.util.Function<F,T>
  • com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference
  • com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy (implements com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy)
      • com.opensymphony.xwork2.inject.util.ReferenceType


Uses of Package com.opensymphony.xwork2.inject.util (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.inject.util

Packages that use com.opensymphony.xwork2.inject.util
com.opensymphony.xwork2.inject.util Guice util classes.

Classes in com.opensymphony.xwork2.inject.util used by com.opensymphony.xwork2.inject.util
FinalizableReference
Package-private interface implemented by references that have code to run after garbage collection of their referents.
FinalizableReferenceQueue
Starts a background thread that cleans up after reclaimed referents.
FinalizableSoftReference
Soft reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableWeakReference
Weak reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
Function
A Function provides a transformation on an object and returns the resulting object.
ReferenceCache
Extends ReferenceMap to support lazy loading values by overriding ReferenceCache.create(Object).
ReferenceMap
Concurrent hash map that wraps keys and/or values in soft or weak references.
ReferenceMap.Entry
ReferenceMap.InternalReference
Marker interface to differentiate external and internal references.
ReferenceMap.PutStrategy
ReferenceMap.ReferenceAwareWrapper
Big hack.
ReferenceMap.Strategy
ReferenceType
Reference type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FinalizableReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Interface FinalizableReference

All Known Implementing Classes:
FinalizablePhantomReference, FinalizableSoftReference, FinalizableWeakReference, ReferenceMap.SoftKeyReference, ReferenceMap.SoftValueReference, ReferenceMap.WeakKeyReference, ReferenceMap.WeakValueReference
interface FinalizableReference

Package-private interface implemented by references that have code to run after garbage collection of their referents.

Author:
crazybob@google.com (Bob Lee)

Method Summary
 void finalizeReferent()
Invoked on a background thread after the referent has been garbage collected.

Method Detail

finalizeReferent

void finalizeReferent()
Invoked on a background thread after the referent has been garbage collected.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Function (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Interface Function<F,T>

public interface Function<F,T>

A Function provides a transformation on an object and returns the resulting object. For example, a StringToIntegerFunction may implement Function<String,Integer> and transform integers in String format to Integer format.

The transformation on the source object does not necessarily result in an object of a different type. For example, a FarenheitToCelciusFunction may implement Function<Float,Float>.

Implementors of Function which may cause side effects upon evaluation are strongly encouraged to state this fact clearly in their API documentation.

Method Summary
 T apply(F from)
Applies the function to an object of type F, resulting in an object of type T.

Method Detail

apply

T apply(F from)
Applies the function to an object of type F, resulting in an object of type T. Note that types F and T may or may not be the same.

Parameters:
from - The source object.
Returns:
The resulting object.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FinalizablePhantomReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class FinalizablePhantomReference<T>

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.PhantomReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizablePhantomReference<T>
All Implemented Interfaces:
FinalizableReference
public abstract class FinalizablePhantomReference<T>
extends PhantomReference<T>
implements FinalizableReference

Phantom reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent. This is a simpler alternative to using a ReferenceQueue.

Author:
crazybob@google.com (Bob Lee)

Constructor Summary
protected FinalizablePhantomReference(T referent)
Method Summary
Methods inherited from class java.lang.ref.PhantomReference
get
Methods inherited from class java.lang.ref.Reference
clear, enqueue, isEnqueued
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.inject.util.FinalizableReference
finalizeReferent

Constructor Detail

FinalizablePhantomReference

protected FinalizablePhantomReference(T referent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FinalizableReferenceQueue (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class FinalizableReferenceQueue

java.lang.Object
    extended by  java.lang.ref.ReferenceQueue<Object>
        extended by  com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

 class FinalizableReferenceQueue
extends ReferenceQueue<Object>

Starts a background thread that cleans up after reclaimed referents.

Author:
Bob Lee (crazybob@google.com)

Field Summary
(package private) static ReferenceQueue<Object> | instance
private static Logger | logger
Constructor Summary
private FinalizableReferenceQueue()
Method Summary
(package private) void | cleanUp(Reference reference)
(package private) static FinalizableReferenceQueue | createAndStart()
(package private) void | deliverBadNews(Throwable t)
static ReferenceQueue<Object> | getInstance() Gets instance.
(package private) void | start()
Methods inherited from class java.lang.ref.ReferenceQueue
poll, remove, remove
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

logger

private static final Logger logger

instance

static ReferenceQueue<Object> instance
Constructor Detail

FinalizableReferenceQueue

private FinalizableReferenceQueue()
Method Detail

cleanUp

void cleanUp(Reference reference)

deliverBadNews

void deliverBadNews(Throwable t)

start

void start()

createAndStart

static FinalizableReferenceQueue createAndStart()

getInstance

public static ReferenceQueue<Object> getInstance()
Gets instance.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FinalizableSoftReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class FinalizableSoftReference<T>

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.SoftReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizableSoftReference<T>
All Implemented Interfaces:
FinalizableReference
Direct Known Subclasses:
ReferenceMap.SoftKeyReference, ReferenceMap.SoftValueReference
public abstract class FinalizableSoftReference<T>
extends SoftReference<T>
implements FinalizableReference

Soft reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent. This is a simpler alternative to using a ReferenceQueue.

Author:
crazybob@google.com (Bob Lee)

Constructor Summary
protected FinalizableSoftReference(T referent)
Method Summary
Methods inherited from class java.lang.ref.SoftReference
get
Methods inherited from class java.lang.ref.Reference
clear, enqueue, isEnqueued
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.inject.util.FinalizableReference
finalizeReferent

Constructor Detail

FinalizableSoftReference

protected FinalizableSoftReference(T referent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FinalizableWeakReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class FinalizableWeakReference<T>

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.WeakReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizableWeakReference<T>
All Implemented Interfaces:
FinalizableReference
Direct Known Subclasses:
ReferenceMap.WeakKeyReference, ReferenceMap.WeakValueReference
public abstract class FinalizableWeakReference<T>
extends WeakReference<T>
implements FinalizableReference

Weak reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent. This is a simpler alternative to using a ReferenceQueue.

Author:
crazybob@google.com (Bob Lee)

Constructor Summary
protected FinalizableWeakReference(T referent)
Method Summary
Methods inherited from class java.lang.ref.Reference
clear, enqueue, get, isEnqueued
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.inject.util.FinalizableReference
finalizeReferent

Constructor Detail

FinalizableWeakReference

protected FinalizableWeakReference(T referent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceCache (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceCache<K,V>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.ReferenceMap<K,V>
        extended by  com.opensymphony.xwork2.inject.util.ReferenceCache<K,V>
All Implemented Interfaces:
Serializable, Map<K,V>
public abstract class ReferenceCache<K,V>
extends ReferenceMap<K,V>

Extends ReferenceMap to support lazy loading values by overriding create(Object).

Author:
crazybob@google.com (Bob Lee)
See Also:
Serialized Form

Nested Class Summary
(package private)  class ReferenceCache.CallableCreate
Nested classes/interfaces inherited from class com.opensymphony.xwork2.inject.util.ReferenceMap
ReferenceMap.Entry, ReferenceMap.InternalReference, ReferenceMap.KeyReferenceAwareWrapper, ReferenceMap.ReferenceAwareWrapper, ReferenceMap.SoftKeyReference, ReferenceMap.SoftValueReference, ReferenceMap.Strategy, ReferenceMap.WeakKeyReference, ReferenceMap.WeakValueReference
Field Summary
(package private) ConcurrentMap<Object,Future<V>> | futures
(package private) ThreadLocal<Future<V>> | localFuture
private static long | serialVersionUID
Fields inherited from class com.opensymphony.xwork2.inject.util.ReferenceMap
delegate, keyReferenceType, valueReferenceType
Constructor Summary
ReferenceCache()
Equivalent to new ReferenceCache(STRONG, STRONG).
ReferenceCache(ReferenceType keyReferenceType, ReferenceType valueReferenceType)
Method Summary
protected  void cancel()
Cancels the current create(Object).
protected abstract  V create(K key)
Override to lazy load values.
 V get(Object key)
If this map does not contain an entry for the given key and create(Object) has been overridden, this method will create a new value, put it in the map, and return it.
(package private)  V internalCreate(K key)
static
<K,V> ReferenceCache<K,V>
of(ReferenceType keyReferenceType, ReferenceType valueReferenceType, Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function.
private  void readObject(ObjectInputStream in)
Methods inherited from class com.opensymphony.xwork2.inject.util.ReferenceMap
clear, containsKey, containsValue, dereference, dereferenceCollection, dereferenceEntry, dereferenceKey, dereferenceKeySet, dereferenceValue, dereferenceValues, ensureNotNull, ensureNotNull, entrySet, execute, getPutStrategy, internalGet, isEmpty, keyHashCode, keySet, makeKeyReferenceAware, makeValueReferenceAware, put, putAll, putIfAbsent, putIfAbsentStrategy, putStrategy, referenceEquals, referenceKey, referenceValue, remove, remove, replace, replace, replaceStrategy, size, values
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

futures

transient ConcurrentMap<Object,Future<V>> futures

localFuture

transient ThreadLocal<Future<V>> localFuture
Constructor Detail

ReferenceCache

public ReferenceCache(ReferenceType keyReferenceType,
                      ReferenceType valueReferenceType)

ReferenceCache

public ReferenceCache()
Equivalent to new ReferenceCache(STRONG, STRONG).

Method Detail

create

protected abstract V create(K key)
Override to lazy load values. Use as an alternative to ReferenceMap.put(Object,Object). Invoked by getter if value isn't already cached. Must not return null. This method will not be called again until the garbage collector reclaims the returned value.

internalCreate

V internalCreate(K key)

get

public V get(Object key)
If this map does not contain an entry for the given key and create(Object) has been overridden, this method will create a new value, put it in the map, and return it.

Specified by:
get in interface Map<K,V>
Overrides:
get in class ReferenceMap<K,V>
Throws:
NullPointerException - if create(Object) returns null.
CancellationException - if the creation is cancelled. See cancel().

cancel

protected void cancel()
Cancels the current create(Object). Throws CancellationException to all clients currently blocked on get(Object).

of

public static <K,V> ReferenceCache<K,V> of(ReferenceType keyReferenceType,
                                           ReferenceType valueReferenceType,
                                           Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function. The specified function must not return null.

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceCache.CallableCreate (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceCache.CallableCreate

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate
All Implemented Interfaces:
Callable<V>
Enclosing class:
ReferenceCache<K,V>
 class ReferenceCache.CallableCreate
extends Object
implements Callable<V>

Field Summary
(package private)  K key
Constructor Summary
ReferenceCache.CallableCreate(K key)
Method Summary
 V call()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

key

K key
Constructor Detail

ReferenceCache.CallableCreate

public ReferenceCache.CallableCreate(K key)
Method Detail

call

public V call()
Specified by:
call in interface Callable<V>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap<K,V>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.ReferenceMap<K,V>
All Implemented Interfaces:
Serializable, Map<K,V>
Direct Known Subclasses:
ReferenceCache
public class ReferenceMap<K,V>
extends Object
implements Map<K,V>, Serializable

Concurrent hash map that wraps keys and/or values in soft or weak references. Does not support null keys or values. Uses identity equality for weak and soft keys.

The concurrent semantics of ConcurrentHashMap combined with the fact that the garbage collector can asynchronously reclaim and clean up after keys and values at any time can lead to some racy semantics. For example, size() returns an upper bound on the size, i.e. the actual size may be smaller in cases where the key or value has been reclaimed but the map entry has not been cleaned up yet.

Another example: If get(Object) cannot find an existing entry for a key, it will try to create one. This operation is not atomic. One thread could put(Object, Object) a value between the time another thread running get() checks for an entry and decides to create one. In this case, the newly created value will replace the put value in the map. Also, two threads running get() concurrently can potentially create duplicate values for a given key.

In other words, this class is great for caching but not atomicity.

Author:
crazybob@google.com (Bob Lee)
See Also:
Serialized Form

Nested Class Summary
(package private) class | ReferenceMap.Entry
(package private) static interface | ReferenceMap.InternalReference Marker interface to differentiate external and internal references.
(package private) static class | ReferenceMap.KeyReferenceAwareWrapper Used for keys.
private static class | ReferenceMap.PutStrategy
(package private) static class | ReferenceMap.ReferenceAwareWrapper Big hack.
(package private) class | ReferenceMap.SoftKeyReference
(package private) class | ReferenceMap.SoftValueReference
protected static interface | ReferenceMap.Strategy
(package private) class | ReferenceMap.WeakKeyReference
(package private) class | ReferenceMap.WeakValueReference
Field Summary
private static ReferenceMap.PutStrategy | defaultPutStrategy
(package private) ConcurrentMap<Object,Object> | delegate
(package private) ReferenceType | keyReferenceType
private static long | serialVersionUID
(package private) ReferenceType | valueReferenceType
Constructor Summary
ReferenceMap(ReferenceType keyReferenceType, ReferenceType valueReferenceType)
Concurrent hash map that wraps keys and/or values based on specified reference types.
Method Summary
 void clear()
 boolean containsKey(Object key)
 boolean containsValue(Object value)
(package private)  Object dereference(ReferenceType referenceType, Object reference)
Returns the refererent for reference given its reference type.
(package private)
<T extends Collection<Object>>
T
dereferenceCollection(ReferenceType referenceType, T in, T out)
Dereferences elements in in using referenceType and puts them in out.
(package private)  ReferenceMap.Entry dereferenceEntry(Map.Entry<Object,Object> entry)
Dereferences an entry.
(package private)  K dereferenceKey(Object o)
Converts a reference to a key.
(package private)  Set<K> dereferenceKeySet(Set keyReferences)
Dereferences a set of key references.
(package private)  V dereferenceValue(Object o)
Converts a reference to a value.
(package private)  Collection<V> dereferenceValues(Collection valueReferences)
Dereferences a collection of value references.
(package private) static void ensureNotNull(Object... array)
(package private) static void ensureNotNull(Object o)
 Set<Map.Entry<K,V>> entrySet()
Returns an unmodifiable set view of the entries in this map.
(package private)  V execute(ReferenceMap.Strategy strategy, K key, V value)
 V get(Object key)
protected  ReferenceMap.PutStrategy getPutStrategy()
(package private)  V internalGet(K key)
 boolean isEmpty()
(package private) static int keyHashCode(Object key)
 Set<K> keySet()
Returns an unmodifiable set view of the keys in this map.
(package private)  Object makeKeyReferenceAware(Object o)
Wraps key so it can be compared to a referenced key for equality.
(package private)  Object makeValueReferenceAware(Object o)
Wraps value so it can be compared to a referenced value for equality.
 V put(K key, V value)
 void putAll(Map<? extends K,? extends V> t)
 V putIfAbsent(K key, V value)
protected  ReferenceMap.Strategy putIfAbsentStrategy()
protected  ReferenceMap.Strategy putStrategy()
private  void readObject(ObjectInputStream in)
(package private) static boolean referenceEquals(Reference r, Object o)
Tests weak and soft references for identity equality.
(package private)  Object referenceKey(K key)
Creates a reference for a key.
(package private)  Object referenceValue(Object keyReference, Object value)
Creates a reference for a value.
 V remove(Object key)
 boolean remove(Object key, Object value)
 V replace(K key, V value)
 boolean replace(K key, V oldValue, V newValue)
protected  ReferenceMap.Strategy replaceStrategy()
 int size()
 Collection<V> values()
Returns an unmodifiable set view of the values in this map.
private  void writeObject(ObjectOutputStream out)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

delegate

transient ConcurrentMap<Object,Object> delegate

keyReferenceType

final ReferenceType keyReferenceType

valueReferenceType

final ReferenceType valueReferenceType

defaultPutStrategy

private static ReferenceMap.PutStrategy defaultPutStrategy
Constructor Detail

ReferenceMap

public ReferenceMap(ReferenceType keyReferenceType,
                    ReferenceType valueReferenceType)
Concurrent hash map that wraps keys and/or values based on specified reference types.

Parameters:
keyReferenceType - key reference type
valueReferenceType - value reference type
Method Detail

internalGet

V internalGet(K key)

get

public V get(Object key)
Specified by:
get in interface Map<K,V>

execute

V execute(ReferenceMap.Strategy strategy,
          K key,
          V value)

put

public V put(K key,
             V value)
Specified by:
put in interface Map<K,V>

remove

public V remove(Object key)
Specified by:
remove in interface Map<K,V>

size

public int size()
Specified by:
size in interface Map<K,V>

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface Map<K,V>

containsKey

public boolean containsKey(Object key)
Specified by:
containsKey in interface Map<K,V>

containsValue

public boolean containsValue(Object value)
Specified by:
containsValue in interface Map<K,V>

putAll

public void putAll(Map<? extends K,? extends V> t)
Specified by:
putAll in interface Map<K,V>

clear

public void clear()
Specified by:
clear in interface Map<K,V>

keySet

public Set<K> keySet()
Returns an unmodifiable set view of the keys in this map. As this method creates a defensive copy, the performance is O(n).

Specified by:
keySet in interface Map<K,V>

values

public Collection<V> values()
Returns an unmodifiable set view of the values in this map. As this method creates a defensive copy, the performance is O(n).

Specified by:
values in interface Map<K,V>

putIfAbsent

public V putIfAbsent(K key,
                     V value)

remove

public boolean remove(Object key,
                      Object value)

replace

public boolean replace(K key,
                       V oldValue,
                       V newValue)

replace

public V replace(K key,
                 V value)

entrySet

public Set<Map.Entry<K,V>> entrySet()
Returns an unmodifiable set view of the entries in this map. As this method creates a defensive copy, the performance is O(n).

Specified by:
entrySet in interface Map<K,V>

dereferenceEntry

ReferenceMap.Entry dereferenceEntry(Map.Entry<Object,Object> entry)
Dereferences an entry. Returns null if the key or value has been gc'ed.

referenceKey

Object referenceKey(K key)
Creates a reference for a key.

dereferenceKey

K dereferenceKey(Object o)
Converts a reference to a key.

dereferenceValue

V dereferenceValue(Object o)
Converts a reference to a value.

dereference

Object dereference(ReferenceType referenceType,
                   Object reference)
Returns the refererent for reference given its reference type.

referenceValue

Object referenceValue(Object keyReference,
                      Object value)
Creates a reference for a value.

dereferenceKeySet

Set<K> dereferenceKeySet(Set keyReferences)
Dereferences a set of key references.

dereferenceValues

Collection<V> dereferenceValues(Collection valueReferences)
Dereferences a collection of value references.

makeKeyReferenceAware

Object makeKeyReferenceAware(Object o)
Wraps key so it can be compared to a referenced key for equality.

makeValueReferenceAware

Object makeValueReferenceAware(Object o)
Wraps value so it can be compared to a referenced value for equality.

dereferenceCollection

<T extends Collection<Object>> T dereferenceCollection(ReferenceType referenceType,
                                                       T in,
                                                       T out)
Dereferences elements in in using referenceType and puts them in out. Returns out.

keyHashCode

static int keyHashCode(Object key)

referenceEquals

static boolean referenceEquals(Reference r,
                               Object o)
Tests weak and soft references for identity equality. Compares references to other references and wrappers. If o is a reference, this returns true if r == o or if r and o reference the same non null object. If o is a wrapper, this returns true if r's referent is identical to the wrapped object.

putStrategy

protected ReferenceMap.Strategy putStrategy()

putIfAbsentStrategy

protected ReferenceMap.Strategy putIfAbsentStrategy()

replaceStrategy

protected ReferenceMap.Strategy replaceStrategy()

getPutStrategy

protected ReferenceMap.PutStrategy getPutStrategy()

ensureNotNull

static void ensureNotNull(Object o)

ensureNotNull

static void ensureNotNull(Object... array)

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Throws:
IOException

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.Entry (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap.Entry

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.Entry
All Implemented Interfaces:
Map.Entry<K,V>
Enclosing class:
ReferenceMap<K,V>
 class ReferenceMap.Entry
extends Object
implements Map.Entry<K,V>

Field Summary
(package private) K | key
(package private) V | value
Constructor Summary
ReferenceMap.Entry(K key, V value)
Method Summary
boolean | equals(Object o)
K | getKey()
V | getValue()
int | hashCode()
V | setValue(V value)
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

key

K key

value

V value
Constructor Detail

ReferenceMap.Entry

public ReferenceMap.Entry(K key,
                          V value)
Method Detail

getKey

public K getKey()
Specified by:
getKey in interface Map.Entry<K,V>

getValue

public V getValue()
Specified by:
getValue in interface Map.Entry<K,V>

setValue

public V setValue(V value)
Specified by:
setValue in interface Map.Entry<K,V>

hashCode

public int hashCode()
Specified by:
hashCode in interface Map.Entry<K,V>
Overrides:
hashCode in class Object

equals

public boolean equals(Object o)
Specified by:
equals in interface Map.Entry<K,V>
Overrides:
equals in class Object

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.InternalReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Interface ReferenceMap.InternalReference

All Known Implementing Classes:
ReferenceMap.SoftKeyReference, ReferenceMap.SoftValueReference, ReferenceMap.WeakKeyReference, ReferenceMap.WeakValueReference
Enclosing class:
ReferenceMap<K,V>
static interface ReferenceMap.InternalReference

Marker interface to differentiate external and internal references.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.KeyReferenceAwareWrapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap.KeyReferenceAwareWrapper

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper
        extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.KeyReferenceAwareWrapper
Enclosing class:
ReferenceMap<K,V>
static class ReferenceMap.KeyReferenceAwareWrapper
extends ReferenceMap.ReferenceAwareWrapper

Used for keys. Overrides hash code to use identity hash code.

Field Summary
Fields inherited from class com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper
wrapped
Constructor Summary
ReferenceMap.KeyReferenceAwareWrapper(Object wrapped)
Method Summary
 int hashCode()
Methods inherited from class com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper
equals, unwrap
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ReferenceMap.KeyReferenceAwareWrapper

public ReferenceMap.KeyReferenceAwareWrapper(Object wrapped)
Method Detail

hashCode

public int hashCode()
Overrides:
hashCode in class ReferenceMap.ReferenceAwareWrapper
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.PutStrategy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.inject.util
Enum ReferenceMap.PutStrategy

java.lang.Object
    extended by  java.lang.Enum<ReferenceMap.PutStrategy>
        extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy
All Implemented Interfaces:
ReferenceMap.Strategy, Serializable, Comparable<ReferenceMap.PutStrategy>
Enclosing class:
ReferenceMap<K,V>
private static enum ReferenceMap.PutStrategy
extends Enum<ReferenceMap.PutStrategy>
implements ReferenceMap.Strategy

Enum Constant Summary
PUT
PUT_IF_ABSENT
REPLACE
Method Summary
static ReferenceMap.PutStrategy | valueOf(String name) Returns the enum constant of this type with the specified name.
static ReferenceMap.PutStrategy[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy
execute

Enum Constant Detail

PUT

public static final ReferenceMap.PutStrategy PUT

REPLACE

public static final ReferenceMap.PutStrategy REPLACE

PUT_IF_ABSENT

public static final ReferenceMap.PutStrategy PUT_IF_ABSENT
Method Detail

values

public static final ReferenceMap.PutStrategy[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(ReferenceMap.PutStrategy c : ReferenceMap.PutStrategy.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static ReferenceMap.PutStrategy valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


ReferenceMap.ReferenceAwareWrapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap.ReferenceAwareWrapper

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper
Direct Known Subclasses:
ReferenceMap.KeyReferenceAwareWrapper
Enclosing class:
ReferenceMap<K,V>
static class ReferenceMap.ReferenceAwareWrapper
extends Object

Big hack. Used to compare keys and values to referenced keys and values without creating more references.

Field Summary
(package private)  Object wrapped
Constructor Summary
ReferenceMap.ReferenceAwareWrapper(Object wrapped)
Method Summary
boolean | equals(Object obj)
int | hashCode()
(package private) Object | unwrap()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

wrapped

Object wrapped
Constructor Detail

ReferenceMap.ReferenceAwareWrapper

ReferenceMap.ReferenceAwareWrapper(Object wrapped)
Method Detail

unwrap

Object unwrap()

hashCode

public int hashCode()
Overrides:
hashCode in class Object

equals

public boolean equals(Object obj)
Overrides:
equals in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.SoftKeyReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap.SoftKeyReference

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.SoftReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizableSoftReference<Object>
                extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference
All Implemented Interfaces:
FinalizableReference, ReferenceMap.InternalReference
Enclosing class:
ReferenceMap<K,V>
 class ReferenceMap.SoftKeyReference
extends FinalizableSoftReference<Object>
implements ReferenceMap.InternalReference

Field Summary
(package private)  int hashCode
Constructor Summary
ReferenceMap.SoftKeyReference(Object key)
Method Summary
boolean | equals(Object o)
void | finalizeReferent()
int | hashCode()
Methods inherited from class java.lang.ref.SoftReference
get
Methods inherited from class java.lang.ref.Reference
clear, enqueue, isEnqueued
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

hashCode

int hashCode
Constructor Detail

ReferenceMap.SoftKeyReference

public ReferenceMap.SoftKeyReference(Object key)
Method Detail

finalizeReferent

public void finalizeReferent()
Specified by:
finalizeReferent in interface FinalizableReference

hashCode

public int hashCode()
Overrides:
hashCode in class Object

equals

public boolean equals(Object o)
Overrides:
equals in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.SoftValueReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap.SoftValueReference

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.SoftReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizableSoftReference<Object>
                extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference
All Implemented Interfaces:
FinalizableReference, ReferenceMap.InternalReference
Enclosing class:
ReferenceMap<K,V>
 class ReferenceMap.SoftValueReference
extends FinalizableSoftReference<Object>
implements ReferenceMap.InternalReference

Field Summary
(package private)  Object keyReference
Constructor Summary
ReferenceMap.SoftValueReference(Object keyReference, Object value)
Method Summary
boolean | equals(Object obj)
void | finalizeReferent()
Methods inherited from class java.lang.ref.SoftReference
get
Methods inherited from class java.lang.ref.Reference
clear, enqueue, isEnqueued
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

keyReference

Object keyReference
Constructor Detail

ReferenceMap.SoftValueReference

public ReferenceMap.SoftValueReference(Object keyReference,
                                       Object value)
Method Detail

finalizeReferent

public void finalizeReferent()
Specified by:
finalizeReferent in interface FinalizableReference

equals

public boolean equals(Object obj)
Overrides:
equals in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.Strategy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Interface ReferenceMap.Strategy

All Known Implementing Classes:
ReferenceMap.PutStrategy
Enclosing class:
ReferenceMap<K,V>
protected static interface ReferenceMap.Strategy

Method Summary
 Object execute(ReferenceMap map, Object keyReference, Object valueReference)

Method Detail

execute

Object execute(ReferenceMap map,
               Object keyReference,
               Object valueReference)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.WeakKeyReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap.WeakKeyReference

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.WeakReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizableWeakReference<Object>
                extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference
All Implemented Interfaces:
FinalizableReference, ReferenceMap.InternalReference
Enclosing class:
ReferenceMap<K,V>
 class ReferenceMap.WeakKeyReference
extends FinalizableWeakReference<Object>
implements ReferenceMap.InternalReference

Field Summary
(package private)  int hashCode
Constructor Summary
ReferenceMap.WeakKeyReference(Object key)
Method Summary
boolean | equals(Object o)
void | finalizeReferent()
int | hashCode()
Methods inherited from class java.lang.ref.Reference
clear, enqueue, get, isEnqueued
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

hashCode

int hashCode
Constructor Detail

ReferenceMap.WeakKeyReference

public ReferenceMap.WeakKeyReference(Object key)
Method Detail

finalizeReferent

public void finalizeReferent()
Specified by:
finalizeReferent in interface FinalizableReference

hashCode

public int hashCode()
Overrides:
hashCode in class Object

equals

public boolean equals(Object o)
Overrides:
equals in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ReferenceMap.WeakValueReference (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class ReferenceMap.WeakValueReference

java.lang.Object
    extended by  java.lang.ref.Reference<T>
        extended by  java.lang.ref.WeakReference<T>
            extended by  com.opensymphony.xwork2.inject.util.FinalizableWeakReference<Object>
                extended by  com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference
All Implemented Interfaces:
FinalizableReference, ReferenceMap.InternalReference
Enclosing class:
ReferenceMap<K,V>
 class ReferenceMap.WeakValueReference
extends FinalizableWeakReference<Object>
implements ReferenceMap.InternalReference

Field Summary
(package private)  Object keyReference
Constructor Summary
ReferenceMap.WeakValueReference(Object keyReference, Object value)
Method Summary
boolean | equals(Object obj)
void | finalizeReferent()
Methods inherited from class java.lang.ref.Reference
clear, enqueue, get, isEnqueued
Methods inherited from class java.lang.Object
clone, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

keyReference

Object keyReference
Constructor Detail

ReferenceMap.WeakValueReference

public ReferenceMap.WeakValueReference(Object keyReference,
                                       Object value)
Method Detail

finalizeReferent

public void finalizeReferent()
Specified by:
finalizeReferent in interface FinalizableReference

equals

public boolean equals(Object obj)
Overrides:
equals in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Strings (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject.util
Class Strings

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.util.Strings

public class Strings
extends Object

String utilities.

Author:
crazybob@google.com (Bob Lee)

Constructor Summary
Strings()
Method Summary
static String capitalize(String s)
Returns a string that is equivalent to the specified string with its first character converted to uppercase as by String.toUpperCase(java.util.Locale).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Strings

public Strings()
Method Detail

capitalize

public static String capitalize(String s)
Returns a string that is equivalent to the specified string with its first character converted to uppercase as by String.toUpperCase(java.util.Locale). The returned string will have the same value as the specified string if its first character is non-alphabetic, if its first character is already uppercase, or if the specified string is of length 0.

For example:

    capitalize("foo bar").equals("Foo bar");
    capitalize("2b or not 2b").equals("2b or not 2b")
    capitalize("Foo bar").equals("Foo bar");
    capitalize("").equals("");

Parameters:
s - the string whose first character is to be uppercased
Returns:
a string equivalent to s with its first character converted to uppercase
Throws:
NullPointerException - if s is null
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ReferenceType (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.inject.util
Enum ReferenceType

java.lang.Object
    extended by  java.lang.Enum<ReferenceType>
        extended by  com.opensymphony.xwork2.inject.util.ReferenceType
All Implemented Interfaces:
Serializable, Comparable<ReferenceType>
public enum ReferenceType
extends Enum<ReferenceType>

Reference type. Used to specify what type of reference to keep to a referent.

Author:
crazybob@google.com (Bob Lee)
See Also:
Reference

Enum Constant Summary
PHANTOM
Similar to weak references except the garbage collector doesn't actually reclaim the referent.
SOFT
Referent reclaimed in an LRU fashion when the VM runs low on memory and no strong references exist.
STRONG
Prevents referent from being reclaimed by the garbage collector.
WEAK
Referent reclaimed when no strong or soft references exist.
Method Summary
static ReferenceType | valueOf(String name) Returns the enum constant of this type with the specified name.
static ReferenceType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

STRONG

public static final ReferenceType STRONG
Prevents referent from being reclaimed by the garbage collector.

SOFT

public static final ReferenceType SOFT
Referent reclaimed in an LRU fashion when the VM runs low on memory and no strong references exist.

See Also:
SoftReference

WEAK

public static final ReferenceType WEAK
Referent reclaimed when no strong or soft references exist.

See Also:
WeakReference

PHANTOM

public static final ReferenceType PHANTOM
Similar to weak references except the garbage collector doesn't actually reclaim the referent. More flexible alternative to finalization.

See Also:
PhantomReference
Method Detail

values

public static final ReferenceType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(ReferenceType c : ReferenceType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static ReferenceType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


com.opensymphony.xwork2.interceptor (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.interceptor

Interceptor classes.

See:
Description

Interface Summary
Interceptor | An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
NoParameters | This marker interface should be implemented by actions that do not want any parameters set on them automatically (by the ParametersActionFactoryProxy) This may be useful if one is using the action tag and want to supply the parameters to the action manually using the param tag.
ParameterNameAware | This interface is implemented by actions that want to declare acceptable parameters.
PreResultListener | PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.
ScopedModelDriven<T> | Adds the ability to set a model, probably retrieved from a given state.

Class Summary
AbstractInterceptor | Provides default implementations of optional lifecycle methods
AliasInterceptor | The aim of this Interceptor is to alias a named parameter to a different named parameter.
ChainingInterceptor | An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable.
ConversionErrorInterceptor | This interceptor adds any error found in the ActionContext's conversionErrors map as a field error (provided that the action implements ValidationAware).
DefaultWorkflowInterceptor | An interceptor that does some basic validation workflow before allowing the interceptor chain to continue.
ExceptionHolder | A simple wrapper around an exception, providing an easy way to print out the stack trace of the exception as well as a way to get a handle on the exception itself.
ExceptionMappingInterceptor | This interceptor forms the core functionality of the exception handling feature.
I18nInterceptor | An interceptor that handles setting the locale specified in a session as the locale for the current action request.
LoggingInterceptor | This interceptor logs the the start and end of the execution an action (in English-only, not internationalized).
MethodFilterInterceptor | An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.
MethodFilterInterceptorUtil | Utility class contains common methods used by MethodFilterInterceptor.
ModelDrivenInterceptor | Watches for ModelDriven actions and adds the action's model on to the value stack.
ParameterFilterInterceptor |
ParameterRemoverInterceptor | This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action.
ParametersInterceptor | This interceptor sets all parameters on the value stack.
PrefixMethodInvocationUtil | A utility class for invoking prefixed methods in action class.
PrepareInterceptor | This interceptor calls prepare() on actions which implement Preparable.
ScopedModelDrivenInterceptor | An interceptor that enables scoped model-driven actions.
StaticParametersInterceptor | This interceptor populates the action with the static parameters defined in the action configuration.
TimerInterceptor | This interceptor logs the amount of time in milliseconds.

Package com.opensymphony.xwork2.interceptor Description

Interceptor classes.


com.opensymphony.xwork2.interceptor Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.interceptor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.interceptor.AliasInterceptor
      • com.opensymphony.xwork2.interceptor.ChainingInterceptor
      • com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
      • com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
      • com.opensymphony.xwork2.interceptor.I18nInterceptor
      • com.opensymphony.xwork2.interceptor.LoggingInterceptor
      • com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
        • com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
      • com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
      • com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
      • com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
      • com.opensymphony.xwork2.interceptor.ParametersInterceptor
      • com.opensymphony.xwork2.interceptor.PrepareInterceptor
      • com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
      • com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
      • com.opensymphony.xwork2.interceptor.TimerInterceptor
    • com.opensymphony.xwork2.interceptor.ExceptionHolder
    • com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
    • com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

Interface Hierarchy

  • com.opensymphony.xwork2.ModelDriven<T>
    • com.opensymphony.xwork2.interceptor.ScopedModelDriven<T>
  • com.opensymphony.xwork2.interceptor.NoParameters
  • com.opensymphony.xwork2.interceptor.ParameterNameAware
  • com.opensymphony.xwork2.interceptor.PreResultListener
  • java.io.Serializable
    • com.opensymphony.xwork2.interceptor.Interceptor


Uses of Package com.opensymphony.xwork2.interceptor (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.interceptor

Packages that use com.opensymphony.xwork2.interceptor
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2.impl |
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.debugging |
org.apache.struts2.interceptor.validation |
org.apache.struts2.portlet.interceptor |

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
PreResultListener
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.config.entities
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.interceptor
AbstractInterceptor
Provides default implementations of optional lifecycle methods
ExceptionHolder
A simple wrapper around an exception, providing an easy way to print out the stack trace of the exception as well as a way to get a handle on the exception itself.
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
MethodFilterInterceptor
An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.interceptor.annotations
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
PreResultListener
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.mock
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
PreResultListener
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.spring.interceptor
AbstractInterceptor
Provides default implementations of optional lifecycle methods
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Classes in com.opensymphony.xwork2.interceptor used by com.opensymphony.xwork2.validator
AbstractInterceptor
Provides default implementations of optional lifecycle methods
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
MethodFilterInterceptor
An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.

Classes in com.opensymphony.xwork2.interceptor used by org.apache.struts2.impl
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Classes in com.opensymphony.xwork2.interceptor used by org.apache.struts2.interceptor
AbstractInterceptor
Provides default implementations of optional lifecycle methods
ConversionErrorInterceptor
This interceptor adds any error found in the ActionContext's conversionErrors map as a field error (provided that the action implements ValidationAware).
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
MethodFilterInterceptor
An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.
NoParameters
This marker interface should be implemented by actions that do not want any parameters set on them automatically (by the ParametersActionFactoryProxy) This may be useful if one is using the action tag and want to supply the parameters to the action manually using the param tag.
PreResultListener
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Classes in com.opensymphony.xwork2.interceptor used by org.apache.struts2.interceptor.debugging
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Classes in com.opensymphony.xwork2.interceptor used by org.apache.struts2.interceptor.validation
AbstractInterceptor
Provides default implementations of optional lifecycle methods
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
MethodFilterInterceptor
An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.

Classes in com.opensymphony.xwork2.interceptor used by org.apache.struts2.portlet.interceptor
AbstractInterceptor
Provides default implementations of optional lifecycle methods
Interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Interceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface Interceptor

All Superinterfaces:
Serializable
All Known Implementing Classes:
AbstractInterceptor, ActionAutowiringInterceptor, AliasInterceptor, AnnotationValidationInterceptor, AnnotationWorkflowInterceptor, ChainingInterceptor, CheckboxInterceptor, ConversionErrorInterceptor, CreateSessionInterceptor, DebuggingInterceptor, DefaultWorkflowInterceptor, ExceptionMappingInterceptor, ExecuteAndWaitInterceptor, FileUploadInterceptor, I18nInterceptor, LoggingInterceptor, MessageStoreInterceptor, MethodFilterInterceptor, MockInterceptor, ModelDrivenInterceptor, ParameterFilterInterceptor, ParameterRemoverInterceptor, ParametersInterceptor, PortletPreferencesInterceptor, PrepareInterceptor, ProfilingActivationInterceptor, RolesInterceptor, ScopedModelDrivenInterceptor, ScopeInterceptor, ServletConfigInterceptor, StaticParametersInterceptor, StrutsConversionErrorInterceptor, TimerInterceptor, TokenInterceptor, TokenSessionStoreInterceptor, ValidationInterceptor
public interface Interceptor
extends Serializable

An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.

Interceptors are objects that dynamically intercept Action invocations. They provide the developer with the opportunity to define code that can be executed before and/or after the execution of an action. They also have the ability to prevent an action from executing. Interceptors provide developers a way to encapulate common functionality in a re-usable form that can be applied to one or more Actions.

Interceptors must be stateless and not assume that a new instance will be created for each request or Action. Interceptors may choose to either short-circuit the ActionInvocation execution and return a return code (such as Action.SUCCESS), or it may choose to do some processing before and/or after delegating the rest of the procesing using ActionInvocation.invoke().

Interceptor's parameter could be overriden through the following ways :-

Method 1:

 <action name="myAction" class="myActionClass">
   <interceptor-ref name="exception"/>
     <interceptor-ref name="alias"/>
     <interceptor-ref name="params"/>
     <interceptor-ref name="servlet-config"/>
     <interceptor-ref name="prepare"/>
     <interceptor-ref name="i18n"/>
     <interceptor-ref name="chain"/>
     <interceptor-ref name="model-driven"/>
     <interceptor-ref name="fileUpload"/>
     <interceptor-ref name="static-params"/>
     <interceptor-ref name="params"/>
     <interceptor-ref name="conversionError"/>
     <interceptor-ref name="validation">
       <param name="excludeMethods">myValidationExcudeMethod</param>
     </interceptor-ref>
     <interceptor-ref name="workflow">
       <param name="excludeMethods">myWorkflowExcludeMethod</param>
     </interceptor-ref>
 </action>
Method 2:
 <action name="myAction" class="myActionClass">
   <interceptor-ref name="defaultStack">
     <param name="validation.excludeMethods">myValidationExcludeMethod</param>
     <param name="workflow.excludeMethods">myWorkflowExcludeMethod</param>
   </interceptor-ref>
 </action>

In the first method, the whole default stack is copied and the parameter then changed accordingly.

In the second method, the refer to an existing interceptor-stack, namely default-stack in this example, and override the validator and workflow interceptor excludeMethods typically in this case. Note that in the tag, the name attribute contains a dot (.) the word before the dot(.) specifies the interceptor name whose parameter is to be overriden and the word after the dot (.) specifies the parameter itself. Essetially it is as follows :-

    <interceptor-name>.<parameter-name>
Note also that in this case the name attribute is used to indicate an interceptor stack which makes sense as if it is refering to the interceptor itself it would be just using Method 1 describe above.

Version:
$Date: 2006-07-10 02:30:29 +0200 (Mo, 10 Jul 2006) $ $Id: Interceptor.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Jason Carreira

Method Summary
void | destroy() Called to let an interceptor clean up any resources it has allocated.
void | init() Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.
String | intercept(ActionInvocation invocation) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.

Method Detail

destroy

void destroy()
Called to let an interceptor clean up any resources it has allocated.

init

void init()
Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.

intercept

String intercept(ActionInvocation invocation)
                 throws Exception
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.

Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NoParameters (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface NoParameters

All Known Subinterfaces:
NoParameters
public interface NoParameters

This marker interface should be implemented by actions that do not want any parameters set on them automatically (by the ParametersActionFactoryProxy) This may be useful if one is using the action tag and want to supply the parameters to the action manually using the param tag. It may also be useful if one for security reasons wants to make sure that parameters cannot be set by malicious users.

Version:
$Revision: 1063 $, $Date: 2006-07-10 02:30:29 +0200 (Mo, 10 Jul 2006) $
Author:
Dick Zetterberg (dick@transitor.se)

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterNameAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface ParameterNameAware

public interface ParameterNameAware

This interface is implemented by actions that want to declare acceptable parameters. Works in conjunction with ParametersInterceptor. For example, actions may want to create a whitelist of parameters they will accept or a blacklist of paramters they will reject to prevent clients from setting other unexpected (and possibly dangerous) parameters.

Author:
Bob Lee (crazybob@google.com)

Method Summary
 boolean acceptableParameterName(String parameterName)
Returns true if the action will accept the parameter with the given name.

Method Detail

acceptableParameterName

boolean acceptableParameterName(String parameterName)
Returns true if the action will accept the parameter with the given name.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PreResultListener (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface PreResultListener

All Known Implementing Classes:
AnnotationWorkflowInterceptor, ScopeInterceptor
public interface PreResultListener

PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.

Author:
Jason Carreira Date: Nov 13, 2003 10:55:02 PM

Method Summary
 void beforeResult(ActionInvocation invocation, String resultCode)
This callback method will be called after the Action execution and before the Result execution.

Method Detail

beforeResult

void beforeResult(ActionInvocation invocation,
                  String resultCode)
This callback method will be called after the Action execution and before the Result execution.

Parameters:
invocation -
resultCode -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScopedModelDriven (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Interface ScopedModelDriven<T>

All Superinterfaces:
ModelDriven<T>
public interface ScopedModelDriven<T>
extends ModelDriven<T>

Adds the ability to set a model, probably retrieved from a given state.

Method Summary
String | getScopeKey() Gets the key under which the model is stored
void | setModel(T model) Sets the model
void | setScopeKey(String key) Sets the key under which the model is stored
Methods inherited from interface com.opensymphony.xwork2.ModelDriven
getModel

Method Detail

setModel

void setModel(T model)
Sets the model

setScopeKey

void setScopeKey(String key)
Sets the key under which the model is stored

Parameters:
key - The model key

getScopeKey

String getScopeKey()
Gets the key under which the model is stored

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class AbstractInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
All Implemented Interfaces:
Interceptor, Serializable
Direct Known Subclasses:
ActionAutowiringInterceptor, AliasInterceptor, ChainingInterceptor, ConversionErrorInterceptor, CreateSessionInterceptor, ExceptionMappingInterceptor, FileUploadInterceptor, I18nInterceptor, LoggingInterceptor, MethodFilterInterceptor, ModelDrivenInterceptor, ParameterFilterInterceptor, ParameterRemoverInterceptor, ParametersInterceptor, PortletPreferencesInterceptor, PrepareInterceptor, ProfilingActivationInterceptor, RolesInterceptor, ScopedModelDrivenInterceptor, ScopeInterceptor, ServletConfigInterceptor, StaticParametersInterceptor, TimerInterceptor
public abstract class AbstractInterceptor
extends Object
implements Interceptor

Provides default implementations of optional lifecycle methods

See Also:
Serialized Form

Constructor Summary
AbstractInterceptor()
Method Summary
void | destroy() Does nothing
void | init() Does nothing
abstract String | intercept(ActionInvocation invocation) Override to handle interception
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractInterceptor

public AbstractInterceptor()
Method Detail

init

public void init()
Does nothing

Specified by:
init in interface Interceptor

destroy

public void destroy()
Does nothing

Specified by:
destroy in interface Interceptor

intercept

public abstract String intercept(ActionInvocation invocation)
                          throws Exception
Override to handle interception

Specified by:
intercept in interface Interceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AliasInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class AliasInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.AliasInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class AliasInterceptor
extends AbstractInterceptor

The aim of this Interceptor is to alias a named parameter to a different named parameter. By acting as the glue between actions sharing similiar parameters (but with different names), it can help greatly with action chaining.

Action's alias expressions should be in the form of #{ "name1" : "alias1", "name2" : "alias2" }. This means that assuming an action (or something else in the stack) has a value for the expression named name1 and the action this interceptor is applied to has a setter named alias1, alias1 will be set with the value from name1.

Interceptor parameters:

  • aliasesKey (optional) - the name of the action parameter to look for the alias map (by default this is aliases).

Extending the interceptor:

This interceptor does not have any known extension points.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <!-- The value for the foo parameter will be applied as if it were named bar -->
     <param name="aliases">#{ 'foo' : 'bar' }</param>

     <interceptor-ref name="alias"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Matthew Payne
See Also:
Serialized Form

Field Summary
protected String | aliasesKey
private static String | DEFAULT_ALIAS_KEY
private static Log | log
Constructor Summary
AliasInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
void | setAliasesKey(String aliasesKey)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

DEFAULT_ALIAS_KEY

private static final String DEFAULT_ALIAS_KEY
See Also:
Constant Field Values

aliasesKey

protected String aliasesKey
Constructor Detail

AliasInterceptor

public AliasInterceptor()
Method Detail

setAliasesKey

public void setAliasesKey(String aliasesKey)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ChainingInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ChainingInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ChainingInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ChainingInterceptor
extends AbstractInterceptor

An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable. A collection of optional includes and excludes may be provided to control how and which parameters are copied. Only includes or excludes may be specified. Specifying both results in undefined behavior. See the javadocs for OgnlUtil.copy(Object, Object, java.util.Map, java.util.Collection, java.util.Collection) for more information.

It is important to remember that this interceptor does nothing if there are no objects already on the stack. This means two things: One, you can safely apply it to all your actions without any worry of adverse affects. Two, it is up to you to ensure an object exists in the stack prior to invoking this action. The most typical way this is done is through the use of the chain result type, which combines with this interceptor to make up the action chaining feature.

Interceptor parameters:

  • excludes (optional) - the list of parameter names to exclude from copying (all others will be included).
  • includes (optional) - the list of parameter names to include when copying (all others will be excluded).

Extending the interceptor:

There are no known extension points to this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="basicStack"/>
     <result name="success" type="chain">otherAction</result>
 </action>

 <action name="otherAction" class="com.examples.OtherAction">
     <interceptor-ref name="chain"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Version:
$Revision: 1142 $
Author:
$Author: mrdon $, tm_jee ( tm_jee(at)yahoo.co.uk )
See Also:
Serialized Form

Field Summary
private static Log | _log
(package private) Collection | excludes
(package private) Collection | includes
Constructor Summary
ChainingInterceptor()
Method Summary
Collection | getExcludes()
Collection | getIncludes()
String | intercept(ActionInvocation invocation) Override to handle interception
void | setExcludes(Collection excludes)
void | setIncludes(Collection includes)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

excludes

Collection excludes

includes

Collection includes
Constructor Detail

ChainingInterceptor

public ChainingInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

getExcludes

public Collection getExcludes()

setExcludes

public void setExcludes(Collection excludes)

getIncludes

public Collection getIncludes()

setIncludes

public void setIncludes(Collection includes)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConversionErrorInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ConversionErrorInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
All Implemented Interfaces:
Interceptor, Serializable
Direct Known Subclasses:
StrutsConversionErrorInterceptor
public class ConversionErrorInterceptor
extends AbstractInterceptor

This interceptor adds any error found in the ActionContext's conversionErrors map as a field error (provided that the action implements ValidationAware). In addition, any field that contains a validation error has its original value saved such that any subsequent requests for that value return the original value rather than the value in the action. This is important because if the value "abc" is submitted and can't be converted to an int, we want to display the original string ("abc") again rather than the int value (likely 0, which would make very little sense to the user).

Interceptor parameters:

  • None

Extending the interceptor:

Because this interceptor is not web-specific, it abstracts the logic for whether an error should be added. This allows for web-specific interceptors to use more complex logic in the shouldAddError(java.lang.String, java.lang.Object) method for when a value has a conversion error but is null or empty or otherwise indicates that the value was never actually entered by the user.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="conversionError"/>
     <result name="success">good_result.ftl</result>
 </action>
ConversionErrorInterceptor adds conversion errors from the ActionContext to the Action's field errors.

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
static String ORIGINAL_PROPERTY_OVERRIDE
Constructor Summary
ConversionErrorInterceptor()
Method Summary
protected Object | getOverrideExpr(ActionInvocation invocation, Object value)
String | intercept(ActionInvocation invocation) Override to handle interception
protected boolean | shouldAddError(String propertyName, Object value)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ORIGINAL_PROPERTY_OVERRIDE

public static final String ORIGINAL_PROPERTY_OVERRIDE
See Also:
Constant Field Values
Constructor Detail

ConversionErrorInterceptor

public ConversionErrorInterceptor()
Method Detail

getOverrideExpr

protected Object getOverrideExpr(ActionInvocation invocation,
                                 Object value)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

shouldAddError

protected boolean shouldAddError(String propertyName,
                                 Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultWorkflowInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class DefaultWorkflowInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class DefaultWorkflowInterceptor
extends MethodFilterInterceptor

An interceptor that does some basic validation workflow before allowing the interceptor chain to continue.

This interceptor does nothing if the name of the method being invoked is specified in the excludeMethods parameter. excludeMethods accepts a comma-delimited list of method names. For example, requests to foo!input.action and foo!back.action will be skipped by this interceptor if you set the excludeMethods parameter to "input, back".

The order of execution in the workflow is:

  1. If the action being executed implements Validateable, the action's validate method is called.
  2. Next, if the action implements ValidationAware, the action's hasErrors method is called. If this method returns true, this interceptor stops the chain from continuing and immediately returns Action.INPUT

Note: if the action doesn't implement either interface, this interceptor effectively does nothing. This interceptor is often used with the validation interceptor. However, it does not have to be, especially if you wish to write all your validation rules by hand in the validate() method rather than in XML files.

NOTE: As this method extends off MethodFilterInterceptor, it is capable of deciding if it is applicable only to selective methods in the action class. See MethodFilterInterceptor for more info.

Update: Added logic to execute a validate{MethodName} and then conditionally followed than a general validate method, depending on the 'alwaysInvokeValidate' parameter/property which is by default set to true. This allows us to run some validation logic based on the method name we specify in the ActionProxy. For example, you can specify a validateInput() method that will be run before the invocation of the input method.

Interceptor parameters:

  • alwaysInvokeValidate - Default to true. If true validate() method will always be invoked, otherwise it will not.
  • inputResultName - Default to "input". Determine the result name to be returned when an action / field error is found.

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation"/>
     <interceptor-ref name="workflow"/>
     <result name="success">good_result.ftl</result>
 </action>

 <-- In this case myMethod of the action class will not pass through
        the workflow process -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation"/>
     <interceptor-ref name="workflow">
         <param name="excludeMethods">myMethod</param>
     </interceptor-ref name="workflow">
     <result name="success">good_result.ftl</result>
 </action>

 <-- In this case, the result named "error" will be used when
        an action / field error is found -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation"/>
     <interceptor-ref name="workflow">
        <param name="inputResultName">error</param>
     </interceptor-ref>
     <result name="success">good_result.ftl</result>
 </action>

Version:
$Date: 2006-11-12 08:32:00 +0100 (So, 12 Nov 2006) $ $Id: DefaultWorkflowInterceptor.java 1185 2006-11-12 07:32:00Z tm_jee $
Author:
Jason Carreira, Rainer Hermanns, Alexandru Popescu, Philip Luppens, tm_jee
See Also:
Serialized Form

Field Summary
private static Log | _log
private static String | ALT_VALIDATE_PREFIX
private boolean | alwaysInvokeValidate
private String | inputResultName
private static long | serialVersionUID
private static String | VALIDATE_PREFIX
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
DefaultWorkflowInterceptor()
Method Summary
protected String | doIntercept(ActionInvocation invocation) Intercept ActionInvocation and returns a inputResultName when action / field errors is found registered.
void | setAlwaysInvokeValidate(String alwaysInvokeValidate) Determine if Validateable's validate() should always be invoked.
void | setInputResultName(String inputResultName) Set the inputResultName (result name to be returned when a action / field error is found registered).
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

_log

private static final Log _log

VALIDATE_PREFIX

private static final String VALIDATE_PREFIX
See Also:
Constant Field Values

ALT_VALIDATE_PREFIX

private static final String ALT_VALIDATE_PREFIX
See Also:
Constant Field Values

alwaysInvokeValidate

private boolean alwaysInvokeValidate

inputResultName

private String inputResultName
Constructor Detail

DefaultWorkflowInterceptor

public DefaultWorkflowInterceptor()
Method Detail

setAlwaysInvokeValidate

public void setAlwaysInvokeValidate(String alwaysInvokeValidate)
Determine if Validateable's validate() should always be invoked. Default to "true".

Parameters:
alwaysInvokeValidate -

setInputResultName

public void setInputResultName(String inputResultName)
Set the inputResultName (result name to be returned when a action / field error is found registered). Default to Action.INPUT

Parameters:
inputResultName -

doIntercept

protected String doIntercept(ActionInvocation invocation)
                      throws Exception
Intercept ActionInvocation and returns a inputResultName when action / field errors is found registered.

Specified by:
doIntercept in class MethodFilterInterceptor
Parameters:
invocation - the action invocation
Returns:
String result name
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExceptionHolder (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ExceptionHolder

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.ExceptionHolder

public class ExceptionHolder
extends Object

A simple wrapper around an exception, providing an easy way to print out the stack trace of the exception as well as a way to get a handle on the exception itself.

Author:
Matthew E. Porter (matthew dot porter at metissian dot com) Date: Sep 21, 2005 Time: 3:09:12 PM

Field Summary
private  Exception exception
Constructor Summary
ExceptionHolder(Exception exception)
Method Summary
Exception | getException()
String | getExceptionStack()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

exception

private Exception exception
Constructor Detail

ExceptionHolder

public ExceptionHolder(Exception exception)
Method Detail

getException

public Exception getException()

getExceptionStack

public String getExceptionStack()
                         throws IOException
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExceptionMappingInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ExceptionMappingInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ExceptionMappingInterceptor
extends AbstractInterceptor

This interceptor forms the core functionality of the exception handling feature. Exception handling allows you to map an exception to a result code, just as if the action returned a result code instead of throwing an unexpected exception. When an exception is encountered, it is wrapped with an ExceptionHolder and pushed on the stack, providing easy access to the exception from within your result. Note: While you can configure exception mapping in your configuration file at any point, the configuration will not have any effect if this interceptor is not in the interceptor stack for your actions. It is recommended that you make this interceptor the first interceptor on the stack, ensuring that it has full access to catch any exception, even those caused by other interceptors.

Interceptor parameters:

  • logEnabled (optional) - Should exceptions also be logged? (boolean true|false)
  • logLevel (optional) - what log level should we use (trace, debug, info, warn, error, fatal)? - defaut is debug
  • logCategory (optional) - If provided we would use this category (eg. com.mycompany.app). Default is to use com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor.
The parameters above enables us to log all thrown exceptions with stacktace in our own logfile, and present a friendly webpage (with no stacktrace) to the end user.

Extending the interceptor:

If you want to add custom handling for publishing the Exception, you may override publishException(com.opensymphony.xwork2.ActionInvocation, ExceptionHolder). The default implementation pushes the given ExceptionHolder on value stack. A custom implementation could add additional logging etc.

Example code:

 <xwork>
     <package name="default" extends="xwork-default">
         <global-results>
             <result name="success" type="freemarker">error.ftl</result>
         </global-results>

         <global-exception-mappings>
             <exception-mapping exception="java.lang.Exception" result="error"/>
         </global-exception-mappings>

         <action name="test">
             <interceptor-ref name="exception"/>
             <interceptor-ref name="basicStack"/>
             <exception-mapping exception="com.acme.CustomException" result="custom_error"/>
             <result name="custom_error">custom_error.ftl</result>
             <result name="success" type="freemarker">test.ftl</result>
         </action>
     </package>
 </xwork>

This second example will also log the exceptions using our own category com.mycompany.app.unhandled at WARN level.

 <xwork>
   <package name="something" extends="xwork-default">
      <interceptors>
          <interceptor-stack name="exceptionmapping-stack">
              <interceptor-ref name="exception">
                  <param name="logEnabled">true</param>
                  <param name="logCategory">com.mycompany.app.unhandled</param>
                  <param name="logLevel">WARN</param>
              </interceptor-ref>
              <interceptor-ref name="i18n"/>
              <interceptor-ref name="static-params"/>
              <interceptor-ref name="params"/>
              <interceptor-ref name="validation">
                  <param name="excludeMethods">input,back,cancel,browse</param>
              </interceptor-ref>
          </interceptor-stack>
      </interceptors>

      <default-interceptor-ref name="exceptionmapping-stack"/>

      <global-results>
           <result name="unhandledException">/unhandled-exception.jsp</result>
      </global-results>

      <global-exception-mappings>
           <exception-mapping exception="java.lang.Exception" result="unhandledException"/>
      </global-exception-mappings>

      <action name="exceptionDemo" class="org.apache.struts2.showcase.exceptionmapping.ExceptionMappingAction">
          <exception-mapping exception="org.apache.struts2.showcase.exceptionmapping.ExceptionMappingException"
                             result="damm"/>
          <result name="input">index.jsp</result>
          <result name="success">success.jsp</result>
          <result name="damm">damm.jsp</result>
      </action>

   </package>
 </xwork>

Author:
Matthew E. Porter (matthew dot porter at metissian dot com), Claus Ibsen
See Also:
Serialized Form

Field Summary
protected Log | categoryLogger
protected static Log | log
protected String | logCategory
protected boolean | logEnabled
protected String | logLevel

Constructor Summary
ExceptionMappingInterceptor()

Method Summary
protected void | doLog(Log logger, Exception e) Performs the actual logging.
private String | findResultFromExceptions(List exceptionMappings, Throwable t)
private int | getDepth(String exceptionMapping, Class exceptionClass, int depth)
int | getDepth(String exceptionMapping, Throwable t) Return the depth to the superclass matching.
String | getLogCategory()
String | getLogLevel()
protected void | handleLogging(Exception e) Handles the logging of the exception.
String | intercept(ActionInvocation invocation) Override to handle interception
boolean | isLogEnabled()
protected void | publishException(ActionInvocation invocation, ExceptionHolder exceptionHolder) Default implementation to handle ExceptionHolder publishing.
void | setLogCategory(String logCatgory)
void | setLogEnabled(boolean logEnabled)
void | setLogLevel(String logLevel)

Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init

Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static final Log log

categoryLogger

protected Log categoryLogger

logEnabled

protected boolean logEnabled

logCategory

protected String logCategory

logLevel

protected String logLevel
Constructor Detail

ExceptionMappingInterceptor

public ExceptionMappingInterceptor()
Method Detail

isLogEnabled

public boolean isLogEnabled()

setLogEnabled

public void setLogEnabled(boolean logEnabled)

getLogCategory

public String getLogCategory()

setLogCategory

public void setLogCategory(String logCatgory)

getLogLevel

public String getLogLevel()

setLogLevel

public void setLogLevel(String logLevel)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

handleLogging

protected void handleLogging(Exception e)
Handles the logging of the exception.

Parameters:
e - the exception to log.

doLog

protected void doLog(Log logger,
                     Exception e)
Performs the actual logging.

Parameters:
logger - the provided logger to use.
e - the exception to log.

findResultFromExceptions

private String findResultFromExceptions(List exceptionMappings,
                                        Throwable t)

getDepth

public int getDepth(String exceptionMapping,
                    Throwable t)
Return the depth to the superclass matching. 0 means ex matches exactly. Returns -1 if there's no match. Otherwise, returns depth. Lowest depth wins.

Parameters:
exceptionMapping - the mapping classname
t - the cause
Returns:
the depth, if not found -1 is returned.

getDepth

private int getDepth(String exceptionMapping,
                     Class exceptionClass,
                     int depth)

publishException

protected void publishException(ActionInvocation invocation,
                                ExceptionHolder exceptionHolder)
Default implementation to handle ExceptionHolder publishing. Pushes given ExceptionHolder on the stack. Subclasses may override this to customize publishing.

Parameters:
invocation - The invocation to publish Exception for.
exceptionHolder - The exceptionHolder wrapping the Exception to publish.
Overview  Package   Class  Use  Tree  Deprecated  Index  Help
 PREV CLASS   NEXT CLASS FRAMES    NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


I18nInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class I18nInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.I18nInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class I18nInterceptor
extends AbstractInterceptor

An interceptor that handles setting the locale specified in a session as the locale for the current action request. In addition, this interceptor will look for a specific HTTP request parameter and set the locale to whatever value is provided. This means that this interceptor can be used to allow for your application to dynamically change the locale for the user's session. This is very useful for applications that require multi-lingual support and want the user to be able to set his or her language preference at any point. The locale parameter is removed during the execution of this interceptor, ensuring that properties aren't set on an action (such as request_locale) that have no typical corresponding setter in your action.

For example, using the default parameter name, a request to foo.action?request_locale=en_US, then the locale for US English is saved in the user's session and will be used for all future requests.

Interceptor parameters:

  • parameterName (optional) - the name of the HTTP request parameter that dictates the locale to switch to and save in the session. By default this is request_locale
  • attributeName (optional) - the name of the session key to store the selected locale. By default this is WW_TRANS_I18N_LOCALE

Extending the interceptor:

There are no known extensions points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="i18n"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Aleksei Gopachenko
See Also:
Serialized Form

Field Summary
protected String | attributeName
static String | DEFAULT_PARAMETER
static String | DEFAULT_SESSION_ATTRIBUTE
protected static Log | log
protected String | parameterName
Constructor Summary
I18nInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
protected void | saveLocale(ActionInvocation invocation, Locale locale) Save the given locale to the ActionInvocation.
void | setAttributeName(String attributeName)
void | setParameterName(String parameterName)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static final Log log

DEFAULT_SESSION_ATTRIBUTE

public static final String DEFAULT_SESSION_ATTRIBUTE
See Also:
Constant Field Values

DEFAULT_PARAMETER

public static final String DEFAULT_PARAMETER
See Also:
Constant Field Values

parameterName

protected String parameterName

attributeName

protected String attributeName
Constructor Detail

I18nInterceptor

public I18nInterceptor()
Method Detail

setParameterName

public void setParameterName(String parameterName)

setAttributeName

public void setAttributeName(String attributeName)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

saveLocale

protected void saveLocale(ActionInvocation invocation,
                          Locale locale)
Save the given locale to the ActionInvocation.

Parameters:
invocation - The ActionInvocation.
locale - The locale to save.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LoggingInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class LoggingInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.LoggingInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class LoggingInterceptor
extends AbstractInterceptor

This interceptor logs the the start and end of the execution an action (in English-only, not internationalized). There are no parameters for this interceptor. There are no obvious extensions to the existing interceptor.

 <!-- prints out a message before and after the immediate action execution -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="logger"/>
     <result name="success">good_result.ftl</result>
 </action>

 <!-- prints out a message before any more interceptors continue and after they have finished -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="logger"/>
     <interceptor-ref name="completeStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
private static String | FINISH_MESSAGE
private static Log | log
private static String | START_MESSAGE
Constructor Summary
LoggingInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
private void | logMessage(ActionInvocation invocation, String baseMessage)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

FINISH_MESSAGE

private static final String FINISH_MESSAGE
See Also:
Constant Field Values

START_MESSAGE

private static final String START_MESSAGE
See Also:
Constant Field Values
Constructor Detail

LoggingInterceptor

public LoggingInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

logMessage

private void logMessage(ActionInvocation invocation,
                        String baseMessage)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MethodFilterInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class MethodFilterInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
All Implemented Interfaces:
Interceptor, Serializable
Direct Known Subclasses:
DefaultWorkflowInterceptor, ExecuteAndWaitInterceptor, TokenInterceptor, ValidationInterceptor
public abstract class MethodFilterInterceptor
extends AbstractInterceptor

An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.

Setable parameters are as follows:

  • excludeMethods - methods name to be excluded
  • includeMethods - methods name to be included

NOTE: If method name are available in both includeMethods and excludeMethods, it will still be considered as an included method. In short includeMethods takes precedence over excludeMethods.

Interceptors that extends this capability would be :-

  • TokenInterceptor
  • TokenSessionStoreInterceptor
  • DefaultWorkflowInterceptor
  • ValidationInterceptor

Version:
$Date: 2006-09-24 06:45:01 +0200 (So, 24 Sep 2006) $ $Id: MethodFilterInterceptor.java 1138 2006-09-24 04:45:01Z mrdon $
Author:
Alexandru Popescu, Rainer Hermanns
See Also:
TokenInterceptor, TokenSessionStoreInterceptor, DefaultWorkflowInterceptor, ValidationInterceptor, Serialized Form

Field Summary
protected Set | excludeMethods
protected Set | includeMethods
protected Log | log
Constructor Summary
MethodFilterInterceptor()
Method Summary
protected boolean | applyInterceptor(ActionInvocation invocation)
protected abstract String | doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
Set | getExcludeMethodsSet()
Set | getIncludeMethodsSet()
String | intercept(ActionInvocation invocation) Override to handle interception
void | setExcludeMethods(String excludeMethods)
void | setIncludeMethods(String includeMethods)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected transient Log log

excludeMethods

protected Set excludeMethods

includeMethods

protected Set includeMethods
Constructor Detail

MethodFilterInterceptor

public MethodFilterInterceptor()
Method Detail

setExcludeMethods

public void setExcludeMethods(String excludeMethods)

getExcludeMethodsSet

public Set getExcludeMethodsSet()

setIncludeMethods

public void setIncludeMethods(String includeMethods)

getIncludeMethodsSet

public Set getIncludeMethodsSet()

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

applyInterceptor

protected boolean applyInterceptor(ActionInvocation invocation)

doIntercept

protected abstract String doIntercept(ActionInvocation invocation)
                               throws Exception
Subclasses must override to implement the interceptor logic.

Parameters:
invocation - the action invocation
Returns:
the result of invocation
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MethodFilterInterceptorUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class MethodFilterInterceptorUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil

public class MethodFilterInterceptorUtil
extends Object

Utility class contains common methods used by MethodFilterInterceptor.

Version:
$Date: 2006-11-23 21:33:15 +0100 (Do, 23 Nov 2006) $ $Id: MethodFilterInterceptorUtil.java 1223 2006-11-23 20:33:15Z rainerh $
Author:
tm_jee

Constructor Summary
MethodFilterInterceptorUtil()
Method Summary
static boolean applyMethod(Set excludeMethods, Set includeMethods, String method)
Static method to decide if the specified method should be apply (not filtered) depending on the set of excludeMethods and includeMethods.
static boolean applyMethod(String excludeMethods, String includeMethods, String method)
Same as applyMethod(Set, Set, String), except that excludeMethods and includeMethods are supplied as comma separated string.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MethodFilterInterceptorUtil

public MethodFilterInterceptorUtil()
Method Detail

applyMethod

public static boolean applyMethod(Set excludeMethods,
                                  Set includeMethods,
                                  String method)
Static method to decide if the specified method should be apply (not filtered) depending on the set of excludeMethods and includeMethods.

  • excludeMethods takes precedence over includeMethods

    • asterict '*' could be used to indicate all methods.

    Parameters:
    excludeMethods -
    includeMethods -
    Returns:
    boolean

applyMethod

public static boolean applyMethod(String excludeMethods,
                                  String includeMethods,
                                  String method)
Same as applyMethod(Set, Set, String), except that excludeMethods and includeMethods are supplied as comma separated string.

Parameters:
excludeMethods -
includeMethods -
method -
Returns:
boolean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ModelDrivenInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ModelDrivenInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ModelDrivenInterceptor
extends AbstractInterceptor

Watches for ModelDriven actions and adds the action's model on to the value stack.

Note: The ModelDrivenInterceptor must come before the both StaticParametersInterceptor and ParametersInterceptor if you want the parameters to be applied to the model.

Note: The ModelDrivenInterceptor will only push the model into the stack when the model is not null, else it will be ignored.

Interceptor parameters:

  • None

Extending the interceptor:

There are no known extension points to this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="model-driven"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Version:
$Date: 2006-09-30 07:34:02 +0200 (Sa, 30 Sep 2006) $ $Id: ModelDrivenInterceptor.java 1142 2006-09-30 05:34:02Z mrdon $
Author:
tm_jee
See Also:
Serialized Form

Constructor Summary
ModelDrivenInterceptor()
Method Summary
 String intercept(ActionInvocation invocation)
Override to handle interception
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ModelDrivenInterceptor

public ModelDrivenInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterFilterInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ParameterFilterInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ParameterFilterInterceptor
extends AbstractInterceptor

The Parameter Filter Interceptor blocks parameters from getting to the rest of the stack or your action. You can use multiple parameter filter interceptors for a given action, so, for example, you could use one in your default stack that filtered parameters you wanted blocked from every action and those you wanted blocked from an individual action you could add an additional interceptor for each action.

  • allowed - a comma delimited list of parameter prefixes that are allowed to pass to the action
  • blocked - a comma delimited list of parameter prefixes that are not allowed to pass to the action
  • defaultBlock - boolean (default to false) whether by default a given parameter is blocked. If true, then a parameter must have a prefix in the allowed list in order to be able to pass to the action

The way parameters are filtered for the least configuration is that if a string is in the allowed or blocked lists, then any parameter that is a member of the object represented by the parameter is allowed or blocked respectively.

For example, if the parameters are:

  • blocked: person,person.address.createDate,personDao
  • allowed: person.address
  • defaultBlock: false

The parameters person.name, person.phoneNum etc would be blocked because 'person' is in the blocked list. However, person.address.street and person.address.city would be allowed because person.address is in the allowed list (the longer string determines permissions).

none

   ...

   ...

   ...

     person,person.address.createDate,personDao

   ...

Version:
$Date: 2006-10-31 05:00:17 +0100 (Di, 31 Okt 2006) $ $Id: ParameterFilterInterceptor.java 1179 2006-10-31 04:00:17Z tm_jee $
Author:
Gabe
See Also:
Serialized Form

Field Summary
private Collection | allowed
private Collection | blocked
private boolean | defaultBlock
private Map | includesExcludesMap
private static Log | LOG
Constructor Summary
ParameterFilterInterceptor()
Method Summary
private Collection | asCollection(String commaDelim) Return a collection from the comma delimited String.
Collection | getAllowedCollection()
Collection | getBlockedCollection()
private Map | getIncludesExcludesMap()
String | intercept(ActionInvocation invocation) Override to handle interception
boolean | isDefaultBlock()
private boolean | isPropSeperator(char c)
void | setAllowed(String allowed)
void | setAllowedCollection(Collection allowed)
void | setBlocked(String blocked)
void | setBlockedCollection(Collection blocked)
void | setDefaultBlock(boolean defaultExclude)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

allowed

private Collection allowed

blocked

private Collection blocked

includesExcludesMap

private Map includesExcludesMap

defaultBlock

private boolean defaultBlock
Constructor Detail

ParameterFilterInterceptor

public ParameterFilterInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

isPropSeperator

private boolean isPropSeperator(char c)
Parameters:
c -
Returns:
true, if char is property separator, false otherwise.

getIncludesExcludesMap

private Map getIncludesExcludesMap()

isDefaultBlock

public boolean isDefaultBlock()
Returns:
Returns the defaultBlock.

setDefaultBlock

public void setDefaultBlock(boolean defaultExclude)
Parameters:
defaultExclude - The defaultExclude to set.

getBlockedCollection

public Collection getBlockedCollection()
Returns:
Returns the blocked.

setBlockedCollection

public void setBlockedCollection(Collection blocked)
Parameters:
blocked - The blocked to set.

setBlocked

public void setBlocked(String blocked)
Parameters:
blocked - The blocked paramters as comma separated String.

getAllowedCollection

public Collection getAllowedCollection()
Returns:
Returns the allowed.

setAllowedCollection

public void setAllowedCollection(Collection allowed)
Parameters:
allowed - The allowed to set.

setAllowed

public void setAllowed(String allowed)
Parameters:
allowed - The allowed paramters as comma separated String.

asCollection

private Collection asCollection(String commaDelim)
Return a collection from the comma delimited String.

Parameters:
commaDelim -
Returns:
A collection from the comma delimited String.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterRemoverInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ParameterRemoverInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ParameterRemoverInterceptor
extends AbstractInterceptor

This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action. A typical usage would be to want a dropdown/select to map onto a boolean value on an action. The select had the options none, yes and no with values -1, true and false. The true and false would map across correctly. However the -1 would be set to false. This was not desired as one might needed the value on the action to stay null. This interceptor fixes this by preventing the parameter from ever reaching the action.

  • paramNames - A comma separated value (csv) indicating the parameter name whose param value should be considered that if they match any of the comma separated value (csv) from paramValues attribute, shall be removed from the parameter map such that they will not be applied to the action
  • paramValues - A comma separated value (csv) indicating the parameter value that if matched shall have its parameter be removed from the parameter map such that they will not be applied to the action
No intended extension point

 <action name="sample" class="org.martingilday.Sample">
        <interceptor-ref name="paramRemover">
                <param name="paramNames">aParam,anotherParam</param>
                <param name="paramValues">--,-1</param>
        </interceptor-ref>
        <interceptor-ref name="default-stack" />
        ...
 </action>

Version:
$Date$ $Id$
Author:
martin.gilday
See Also:
Serialized Form

Field Summary
private static Log | LOG
private Set | paramNames
private Set | paramValues
private static long | serialVersionUID
Constructor Summary
ParameterRemoverInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Decide if the parameter should be removed from the parameter map based on paramNames and paramValues.
void | setParamNames(String paramNames) Allows paramNames attribute to be set as comma-separated-values (csv).
void | setParamValues(String paramValues) Allows paramValues attribute to be set as a comma-separated-values (csv).
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

paramNames

private Set paramNames

paramValues

private Set paramValues
Constructor Detail

ParameterRemoverInterceptor

public ParameterRemoverInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Decide if the parameter should be removed from the parameter map based on paramNames and paramValues.

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
See Also:
AbstractInterceptor

setParamNames

public void setParamNames(String paramNames)
Allows paramNames attribute to be set as comma-separated-values (csv).

Parameters:
paramNames - the paramNames to set

setParamValues

public void setParamValues(String paramValues)
Allows paramValues attribute to be set as a comma-separated-values (csv).

Parameters:
paramValues - the paramValues to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParametersInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ParametersInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ParametersInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ParametersInterceptor
extends AbstractInterceptor

This interceptor sets all parameters on the value stack.

This interceptor gets all parameters from ActionContext.getParameters() and sets them on the value stack by calling ValueStack.setValue(String, Object), typically resulting in the values submitted in a form request being applied to an action in the value stack. Note that the parameter map must contain a String key and often containers a String[] for the value.

The interceptor takes one parameter named 'ordered'. When set to true action properties are guaranteed to be set top-down which means that top action's properties are set first. Then it's subcomponents properties are set. The reason for this order is to enable a 'factory' pattern. For example, let's assume that one has an action that contains a property named 'modelClass' that allows to choose what is the underlying implementation of model. By assuring that modelClass property is set before any model properties are set, it's possible to choose model implementation during action.setModelClass() call. Similiarily it's possible to use action.setPrimaryKey() property set call to actually load the model class from persistent storage. Without any assumption on parameter order you have to use patterns like 'Preparable'.

Because parameter names are effectively OGNL statements, it is important that security be taken in to account. This interceptor will not apply any values in the parameters map if the expression contains an assignment (=), multiple expressions (,), or references any objects in the context (#). This is all done in the acceptableName(String) method. In addition to this method, if the action being invoked implements the ParameterNameAware interface, the action will be consulted to determine if the parameter should be set.

In addition to these restrictions, a flag (XWorkMethodAccessor.DENY_METHOD_EXECUTION) is set such that no methods are allowed to be invoked. That means that any expression such as person.doSomething() or person.getName() will be explicitely forbidden. This is needed to make sure that your application is not exposed to attacks by malicious users.

While this interceptor is being invoked, a flag (InstantiatingNullHandler.CREATE_NULL_OBJECTS) is turned on to ensure that any null reference is automatically created - if possible. See the type conversion documentation and the InstantiatingNullHandler javadocs for more information.

Finally, a third flag (XWorkConverter.REPORT_CONVERSION_ERRORS) is set that indicates any errors when converting the the values to their final data type (String[] -> int) an unrecoverable error occured. With this flag set, the type conversion errors will be reported in the action context. See the type conversion documentation and the XWorkConverter javadocs for more information.

If you are looking for detailed logging information about your parameters, turn on DEBUG level logging for this interceptor. A detailed log of all the parameter keys and values will be reported.

Interceptor parameters:

  • ordered - set to true if you want the top-down property setter behaviour

Extending the interceptor:

The best way to add behavior to this interceptor is to utilize the ParameterNameAware interface in your actions. However, if you wish to apply a global rule that isn't implemented in your action, then you could extend this interceptor and override the acceptableName(String) method.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Patrick Lightbody
See Also:
Serialized Form

Field Summary
(package private) static boolean | devMode
(package private) Set<Pattern> | excludeParams
private static Log | LOG
(package private) boolean | ordered
(package private) static Comparator | rbCollator Compares based on number of '.' characters (fewer is higher)
Constructor Summary
ParametersInterceptor()
Method Summary
protected boolean | acceptableName(String name)
private Collection | asCollection(String commaDelim) Return a collection from the comma delimited String.
protected Set | getExcludeParamsSet() Gets a set of regular expressions of parameters to remove from the parameter map
protected Comparator | getOrderedComparator() Gets an instance of the comparator to use for the ordered sorting.
private String | getParameterLogMap(Map parameters)
String | intercept(ActionInvocation invocation) Override to handle interception
protected boolean | isExcluded(String paramName)
boolean | isOrdered() Whether to order the parameters or not
static void | setDevMode(String mode)
void | setExcludeParams(String commaDelim) Sets a comma-delimited list of regular expressions to match parameters that should be removed from the parameter map.
void | setOrdered(boolean ordered) Set whether to order the parameters by object depth or not
protected void | setParameters(Object action, ValueStack stack, Map parameters)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

ordered

boolean ordered

excludeParams

Set<Pattern> excludeParams

devMode

static boolean devMode

rbCollator

static final Comparator rbCollator
Compares based on number of '.' characters (fewer is higher)

Constructor Detail

ParametersInterceptor

public ParametersInterceptor()
Method Detail

setDevMode

public static void setDevMode(String mode)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

setParameters

protected void setParameters(Object action,
                             ValueStack stack,
                             Map parameters)

getOrderedComparator

protected Comparator getOrderedComparator()
Gets an instance of the comparator to use for the ordered sorting. Override this method to customize the ordering of the parameters as they are set to the action.

Returns:
A comparator to sort the parameters

getParameterLogMap

private String getParameterLogMap(Map parameters)

acceptableName

protected boolean acceptableName(String name)

isExcluded

protected boolean isExcluded(String paramName)

isOrdered

public boolean isOrdered()
Whether to order the parameters or not

Returns:
True to order

setOrdered

public void setOrdered(boolean ordered)
Set whether to order the parameters by object depth or not

Parameters:
ordered - True to order them

getExcludeParamsSet

protected Set getExcludeParamsSet()
Gets a set of regular expressions of parameters to remove from the parameter map

Returns:
A set of compiled regular expression patterns

setExcludeParams

public void setExcludeParams(String commaDelim)
Sets a comma-delimited list of regular expressions to match parameters that should be removed from the parameter map.

Parameters:
commaDelim - A comma-delimited list of regular expressions

asCollection

private Collection asCollection(String commaDelim)
Return a collection from the comma delimited String.

Parameters:
commaDelim -
Returns:
A collection from the comma delimited String.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrefixMethodInvocationUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class PrefixMethodInvocationUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

public class PrefixMethodInvocationUtil
extends Object

A utility class for invoking prefixed methods in action class. Interceptors that made use of this class are

  • DefaultWorkflowInterceptor
  • PrepareInterceptor

In DefaultWorkflowInterceptor

applies only when action implements Validateable

  1. if the action class have validate{MethodName}(), it will be invoked
  2. else if the action class have validateDo{MethodName}(), it will be invoked
  3. no matter if 1] or 2] is performed, if alwaysInvokeValidate property of the interceptor is "true" (which is by default "true"), validate() will be invoked.
In PrepareInterceptor

Applies only when action implements Preparable

  1. if the action class have prepare{MethodName}(), it will be invoked
  2. else if the action class have prepareDo(MethodName()}(), it will be invoked
  3. no matter if 1] or 2] is performed, if alwaysinvokePrepare property of the interceptor is "true" (which is by default "true"), prepare() will be invoked.

Version:
$Date: 2006-11-23 21:33:15 +0100 (Do, 23 Nov 2006) $ $Id: PrefixMethodInvocationUtil.java 1223 2006-11-23 20:33:15Z rainerh $
Author:
Philip Luppens, tm_jee

Field Summary
private static Log _log
Constructor Summary
PrefixMethodInvocationUtil()
Method Summary
static String | capitalizeMethodName(String methodName) This method capitalized the first character of methodName.
static Method | getPrefixedMethod(String[] prefixes, String methodName, Object action) This method returns a Method in action.
static void | invokePrefixMethod(ActionInvocation actionInvocation, String[] prefixes) This method will prefix actionInvocation's ActionProxy's method with prefixes before invoking the prefixed method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log
Constructor Detail

PrefixMethodInvocationUtil

public PrefixMethodInvocationUtil()
Method Detail

invokePrefixMethod

public static void invokePrefixMethod(ActionInvocation actionInvocation,
                                      String[] prefixes)
                               throws InvocationTargetException,
                                      IllegalAccessException
This method will prefix actionInvocation's ActionProxy's method with prefixes before invoking the prefixed method. Order of the prefixes is important, as this method will return once a prefixed method is found in the action class.

For example, with

   invokePrefixMethod(actionInvocation, new String[] { "prepare", "prepareDo" });
Assuming actionInvocation.getProxy(),getMethod() returns "submit", the order of invocation would be as follows:-
  1. prepareSubmit()
  2. prepareDoSubmit()
If prepareSubmit() exists, it will be invoked and this method will return, prepareDoSubmit() will NOT be invoked.

On the other hand, if prepareDoSubmit() does not exists, and prepareDoSubmit() exists, it will be invoked.

If none of those two methods exists, nothing will be invoked.

Parameters:
actionInvocation -
prefixes -
Throws:
InvocationTargetException
IllegalAccessException

getPrefixedMethod

public static Method getPrefixedMethod(String[] prefixes,
                                       String methodName,
                                       Object action)
This method returns a Method in action. The method returned is found by searching for method in action whose method name is equals to the result of appending each prefixes to methodName. Only the first method found will be returned, hence the order of prefixes is important. If none is found this method will return null.

Parameters:
prefixes - the prefixes to prefix the methodName
methodName - the method name to be prefixed with prefixes
action - the action class of which the prefixed method is to be search for.
Returns:
a Method if one is found, else null.

capitalizeMethodName

public static String capitalizeMethodName(String methodName)
This method capitalized the first character of methodName.

eg.

   capitalizeMethodName("someMethod");
will return "SomeMethod".

Parameters:
methodName -
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrepareInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class PrepareInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.PrepareInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class PrepareInterceptor
extends AbstractInterceptor

This interceptor calls prepare() on actions which implement Preparable. This interceptor is very useful for any situation where you need to ensure some logic runs before the actual execute method runs.

A typical use of this is to run some logic to load an object from the database so that when parameters are set they can be set on this object. For example, suppose you have a User object with two properties: id and name. Provided that the params interceptor is called twice (once before and once after this interceptor), you can load the User object using the id property, and then when the second params interceptor is called the parameter user.name will be set, as desired, on the actual object loaded from the database. See the example for more info.

Update: Added logic to execute a prepare{MethodName} and conditionally the a general prepare() Method, depending on the 'alwaysInvokePrepare' parameter/property which is by default true. This allows us to run some logic based on the method name we specify in the ActionProxy. For example, you can specify a prepareInput() method that will be run before the invocation of the input method.

Interceptor parameters:

  • alwaysInvokePrepare - Default to true. If true, prepare will always be invoked, otherwise it will not.

Extending the interceptor:

There are no known extension points to this interceptor.

Example code:

 <!-- Calls the params interceptor twice, allowing you to
       pre-load data for the second time parameters are set -->
  <action name="someAction" class="com.examples.SomeAction">
      <interceptor-ref name="params"/>
      <interceptor-ref name="prepare"/>
      <interceptor-ref name="basicStack"/>
      <result name="success">good_result.ftl</result>
  </action>
Date: Nov 5, 2003 2:33:11 AM

Author:
Jason Carreira, Philip Luppens, tm_jee
See Also:
Preparable, Serialized Form

Field Summary
private static Log | _log
private static String | ALT_PREPARE_PREFIX
private boolean | alwaysInvokePrepare
private static String | PREPARE_PREFIX
private static long | serialVersionUID
Constructor Summary
PrepareInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
void | setAlwaysInvokePrepare(String alwaysInvokePrepare)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

_log

private static final Log _log

PREPARE_PREFIX

private static final String PREPARE_PREFIX
See Also:
Constant Field Values

ALT_PREPARE_PREFIX

private static final String ALT_PREPARE_PREFIX
See Also:
Constant Field Values

alwaysInvokePrepare

private boolean alwaysInvokePrepare
Constructor Detail

PrepareInterceptor

public PrepareInterceptor()
Method Detail

setAlwaysInvokePrepare

public void setAlwaysInvokePrepare(String alwaysInvokePrepare)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScopedModelDrivenInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class ScopedModelDrivenInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ScopedModelDrivenInterceptor
extends AbstractInterceptor

An interceptor that enables scoped model-driven actions.

This interceptor only activates on actions that implement the ScopedModelDriven interface. If detected, it will retrieve the model class from the configured scope, then provide it to the Action.

Interceptor parameters:

  • className - The model class name. Defaults to the class name of the object returned by the getModel() method.
  • name - The key to use when storing or retrieving the instance in a scope. Defaults to the model class name.
  • scope - The scope to store and retrieve the model. Defaults to 'request' but can also be 'session'.

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <-- Basic usage -->
 <interceptor name="scoped-model-driven" class="com.opensymphony.interceptor.ScopedModelDrivenInterceptor" />

 <-- Using all available parameters -->
 <interceptor name="gangsterForm" class="com.opensymphony.interceptor.ScopedModelDrivenInterceptor">
      <param name="scope">session</param>
      <param name="name">gangsterForm</param>
      <param name="className">com.opensymphony.example.GangsterForm</param>
  </interceptor>

See Also:
Serialized Form

Field Summary
private String | className
private static String | GET_MODEL
private String | name
private ObjectFactory | objectFactory
private String | scope
Constructor Summary
ScopedModelDrivenInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
protected Object | resolveModel(ObjectFactory factory, ActionContext actionContext, String modelClassName, String modelScope, String modelName)
void | setClassName(String className)
void | setName(String name)
void | setObjectFactory(ObjectFactory factory)
void | setScope(String scope)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

GET_MODEL

private static final String GET_MODEL
See Also:
Constant Field Values

scope

private String scope

name

private String name

className

private String className

objectFactory

private ObjectFactory objectFactory
Constructor Detail

ScopedModelDrivenInterceptor

public ScopedModelDrivenInterceptor()
Method Detail

setObjectFactory

public void setObjectFactory(ObjectFactory factory)

resolveModel

protected Object resolveModel(ObjectFactory factory,
                              ActionContext actionContext,
                              String modelClassName,
                              String modelScope,
                              String modelName)
                       throws Exception
Throws:
Exception

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

setClassName

public void setClassName(String className)
Parameters:
className - the className to set

setName

public void setName(String name)
Parameters:
name - the name to set

setScope

public void setScope(String scope)
Parameters:
scope - the scope to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StaticParametersInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class StaticParametersInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.StaticParametersInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class StaticParametersInterceptor
extends AbstractInterceptor

This interceptor populates the action with the static parameters defined in the action configuration. If the action implements Parameterizable, a map of the static parameters will be also be passed directly to the action.

Parameters are typically defined with <param> elements within xwork.xml.

Interceptor parameters:

  • None

Extending the interceptor:

There are no extension points to this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="static-params">
          <param name="parse">true</param>
     </interceptor-ref>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Patrick Lightbody
See Also:
Serialized Form

Field Summary
private static Log | LOG
private boolean | parse
Constructor Summary
StaticParametersInterceptor()
Method Summary
String | intercept(ActionInvocation invocation) Override to handle interception
void | setParse(String value)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

parse

private boolean parse

LOG

private static final Log LOG
Constructor Detail

StaticParametersInterceptor

public StaticParametersInterceptor()
Method Detail

setParse

public void setParse(String value)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TimerInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor
Class TimerInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.TimerInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class TimerInterceptor
extends AbstractInterceptor

This interceptor logs the amount of time in milliseconds. In order for this interceptor to work properly, the logging framework must be set to at least the INFO level. This interceptor relies on the Commons Logging API to report its execution-time value.

  • logLevel (optional) - what log level should we use (trace, debug, info, warn, error, fatal)? - defaut is info
  • logCategory (optional) - If provided we would use this category (eg. com.mycompany.app). Default is to use com.opensymphony.xwork2.interceptor.TimerInterceptor.
The parameters above enables us to log all action execution times in our own logfile. This interceptor can be extended to provide custom message format. Users should override the invokeUnderTiming method.

 <!-- records only the action's execution time -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="timer"/>
     <result name="success">good_result.ftl</result>
 </action>

 <!-- records action's execution time as well as other interceptors-->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="timer"/>
     <interceptor-ref name="completeStack"/>
     <result name="success">good_result.ftl</result>
 </action>
This second example uses our own log category at debug level.

 <!-- records only the action's execution time -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="timer">
         <param name="logLevel">debug</param>
         <param name="logCategory">com.mycompany.myapp.actiontime</param>
     <interceptor-ref/>
     <result name="success">good_result.ftl</result>
 </action>

 <!-- records action's execution time as well as other interceptors-->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="timer"/>
     <interceptor-ref name="completeStack"/>
     <result name="success">good_result.ftl</result>
 </action>

Author:
Jason Carreira, Claus Ibsen
See Also:
Serialized Form

Field Summary
protected Log | categoryLogger
protected static Log | log
protected String | logCategory
protected String | logLevel
Constructor Summary
TimerInterceptor()
Method Summary
protected void | doLog(Log logger, String message) Performs the actual logging.
String | getLogCategory()
protected Log | getLoggerToUse() Get's the logger to use.
String | getLogLevel()
String | intercept(ActionInvocation invocation) Override to handle interception
protected String | invokeUnderTiming(ActionInvocation invocation) Is called to invoke the action invocation and time the execution time.
private static boolean | isLoggerEnabled(Log logger, String level) Is the given logger enalbed at the given level?
void | setLogCategory(String logCatgory)
void | setLogLevel(String logLevel)
protected boolean | shouldLog() Determines if we should log the time.
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static final Log log

categoryLogger

protected Log categoryLogger

logCategory

protected String logCategory

logLevel

protected String logLevel
Constructor Detail

TimerInterceptor

public TimerInterceptor()
Method Detail

getLogCategory

public String getLogCategory()

setLogCategory

public void setLogCategory(String logCatgory)

getLogLevel

public String getLogLevel()

setLogLevel

public void setLogLevel(String logLevel)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

invokeUnderTiming

protected String invokeUnderTiming(ActionInvocation invocation)
                            throws Exception
Is called to invoke the action invocation and time the execution time.

Parameters:
invocation - the action invocation.
Returns:
the result of the action execution.
Throws:
Exception - can be thrown from the action.

shouldLog

protected boolean shouldLog()
Determines if we should log the time.

Returns:
true to log, false to not log.

getLoggerToUse

protected Log getLoggerToUse()
Get's the logger to use.

Returns:
the logger to use.

doLog

protected void doLog(Log logger,
                     String message)
Performs the actual logging.

Parameters:
logger - the provided logger to use.
message - the message to log.

isLoggerEnabled

private static boolean isLoggerEnabled(Log logger,
                                       String level)
Is the given logger enalbed at the given level?

Parameters:
logger - the logger.
level - the level to check if isXXXEnabled.
Returns:
true if enabled, false if not.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.interceptor.annotations (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.interceptor.annotations

Interceptor annotations.

See:
Description

Class Summary
AnnotationWorkflowInterceptor

Annotation Types Summary
After | Marks a action method that needs to be called after the main action method and the result was executed.
Before | Marks a action method that needs to be executed before the main action method.
BeforeResult | Marks a action method that needs to be executed before the result.

Package com.opensymphony.xwork2.interceptor.annotations Description

Interceptor annotations.


com.opensymphony.xwork2.interceptor.annotations Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.interceptor.annotations

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor, com.opensymphony.xwork2.interceptor.PreResultListener)

Annotation Type Hierarchy

  • com.opensymphony.xwork2.interceptor.annotations.After (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.Before (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.interceptor.annotations.BeforeResult (implements java.lang.annotation.Annotation)


Uses of Package com.opensymphony.xwork2.interceptor.annotations (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.interceptor.annotations

No usage of com.opensymphony.xwork2.interceptor.annotations

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AnnotationWorkflowInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.interceptor.annotations
Class AnnotationWorkflowInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
All Implemented Interfaces:
Interceptor, PreResultListener, Serializable
public class AnnotationWorkflowInterceptor
extends Object
implements Interceptor, PreResultListener

Invokes any annotated methods on the action. Specifically, it supports the following annotations:

  • @Before - will be invoked before the action method. If the returned value is not null, it is returned as the action result code
  • @BeforeResult - will be invoked after the action method but before the result execution
  • @After - will be invoked after the action method and result execution

There can be multiple methods marked with the same annotations, but the order of their execution is not guaranteed. However, the annotated methods on the superclass chain are guaranteed to be invoked before the annotated method in the current class in the case of a Before annotations and after, if the annotations is After.

  public class BaseAnnotatedAction {
        protected String log = "";

        @Before
        public String baseBefore() {
                log = log + "baseBefore-";
                return null;
        }
  }

  public class AnnotatedAction extends BaseAnnotatedAction {
        @Before
        public String before() {
                log = log + "before";
                return null;
        }

        public String execute() {
                log = log + "-execute";
                return Action.SUCCESS;
        }

        @BeforeResult
        public void beforeResult() throws Exception {
                log = log +"-beforeResult";
        }

        @After
        public void after() {
                log = log + "-after";
        }
  }

With the interceptor applied and the action executed on AnnotatedAction the log instance variable will contain baseBefore-before-execute-beforeResult-after.

Configure a stack in xwork.xml that replaces the PrepareInterceptor with the AnnotationWorkflowInterceptor:

 <interceptor-stack name="annotatedStack">
        <interceptor-ref name="static-params"/>
        <interceptor-ref name="params"/>
        <interceptor-ref name="conversionError"/>
        <interceptor-ref name="annotationInterceptor"/>
 </interceptor-stack>

Author:
Zsolt Szasz, zsolt at lorecraft dot com, Rainer Hermanns
See Also:
Serialized Form

Constructor Summary
AnnotationWorkflowInterceptor()
Method Summary
void | beforeResult(ActionInvocation invocation, String resultCode) Invokes any @BeforeResult annotated methods
void | destroy() Called to let an interceptor clean up any resources it has allocated.
void | init() Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.
String | intercept(ActionInvocation invocation) Discovers annotated methods on the action and calls them according to the workflow
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnnotationWorkflowInterceptor

public AnnotationWorkflowInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Discovers annotated methods on the action and calls them according to the workflow

Specified by:
intercept in interface Interceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
See Also:
Interceptor.intercept(com.opensymphony.xwork2.ActionInvocation)

destroy

public void destroy()
Description copied from interface: Interceptor
Called to let an interceptor clean up any resources it has allocated.

Specified by:
destroy in interface Interceptor

init

public void init()
Description copied from interface: Interceptor
Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.

Specified by:
init in interface Interceptor

beforeResult

public void beforeResult(ActionInvocation invocation,
                         String resultCode)
Invokes any @BeforeResult annotated methods

Specified by:
beforeResult in interface PreResultListener
See Also:
PreResultListener.beforeResult(com.opensymphony.xwork2.ActionInvocation, String)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


After (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type After

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface After

Marks a action method that needs to be called after the main action method and the result was executed. Return value is ignored.

Annotation usage: The After annotation can be applied at method level.

Annotation parameters: no parameters

Example code:

 public class SampleAction extends ActionSupport {

  @After
  public void isValid() throws ValidationException {
    // validate model object, throw exception if failed
  }

  public String execute() {
     // perform action
     return SUCCESS;
  }
 }

Author:
Zsolt Szasz, zsolt at lorecraft dot com, Rainer Hermanns

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


Before (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type Before

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface Before

Marks a action method that needs to be executed before the main action method.

Annotation usage: The Before annotation can be applied at method level.

Annotation parameters: no parameters

Example code:

 public class SampleAction extends ActionSupport {

  @Before
  public void isAuthorized() throws AuthenticationException {
    // authorize request, throw exception if failed
  }

  public String execute() {
     // perform secure action
     return SUCCESS;
  }
 }

Author:
Zsolt Szasz, zsolt at lorecraft dot com, Rainer Hermanns

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


BeforeResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.interceptor.annotations
Annotation Type BeforeResult

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface BeforeResult

Marks a action method that needs to be executed before the result. Return value is ignored.

Annotation usage: The BeforeResult annotation can be applied at method level.

Annotation parameters: no parameters

Example code:

 public class SampleAction extends ActionSupport {

  @BeforeResult
  public void isValid() throws ValidationException {
    // validate model object, throw exception if failed
  }

  public String execute() {
     // perform action
     return SUCCESS;
  }
 }

Author:
Zsolt Szasz, zsolt at lorecraft dot com, Rainer Hermanns

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


com.opensymphony.xwork2.mock (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.mock

XWork specific mock classes.

See:
Description

Class Summary
MockActionInvocation | Mock for an ActionInvocation.
MockActionProxy | Mock for an ActionProxy.
MockInterceptor | Mock for an Interceptor.
MockObjectTypeDeterminer | Mocks the function of an ObjectTypeDeterminer for testing purposes.
MockResult | Mock for a Result.

Package com.opensymphony.xwork2.mock Description

XWork specific mock classes.


com.opensymphony.xwork2.mock Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.mock

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.mock.MockActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
    • com.opensymphony.xwork2.mock.MockActionProxy (implements com.opensymphony.xwork2.ActionProxy)
    • com.opensymphony.xwork2.mock.MockInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • com.opensymphony.xwork2.mock.MockObjectTypeDeterminer (implements com.opensymphony.xwork2.util.ObjectTypeDeterminer)
    • com.opensymphony.xwork2.mock.MockResult (implements com.opensymphony.xwork2.Result)


Uses of Package com.opensymphony.xwork2.mock (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.mock

Packages that use com.opensymphony.xwork2.mock
com.opensymphony.xwork2 Main Xwork interfaces and classes.

Classes in com.opensymphony.xwork2.mock used by com.opensymphony.xwork2
MockActionInvocation
Mock for an ActionInvocation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


MockActionInvocation (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockActionInvocation

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockActionInvocation
All Implemented Interfaces:
ActionInvocation, Serializable
Direct Known Subclasses:
MockActionInvocation
public class MockActionInvocation
extends Object
implements ActionInvocation

Mock for an ActionInvocation.

Version:
$Id: MockActionInvocation.java 1269 2006-12-13 06:17:15Z mrdon $
Author:
plightbo, Rainer Hermanns, tm_jee
See Also:
Serialized Form

Field Summary
private Object | action
private ActionEventListener | actionEventListener
private ActionContext | invocationContext
private List | preResultListeners
private ActionProxy | proxy
private Result | result
private String | resultCode
private ValueStack | stack
Constructor Summary
MockActionInvocation()
Method Summary
void | addPreResultListener(PreResultListener listener) Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
Object | getAction() Get the Action associated with this ActionInvocation
ActionEventListener | getActionEventListener()
ActionContext | getInvocationContext() Gets the ActionContext associated with this ActionInvocation.
ActionProxy | getProxy() Get the ActionProxy holding this ActionInvocation
Result | getResult() If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
String | getResultCode() Gets the result code returned from this ActionInvocation
ValueStack | getStack()
String | invoke() Invokes the next step in processing this ActionInvocation.
String | invokeActionOnly() Invokes only the action (not interceptors or results).
boolean | isExecuted()
void | setAction(Object action)
void | setActionEventListener(ActionEventListener listener) Sets the action event listener to respond to key action events
void | setInvocationContext(ActionContext invocationContext)
void | setProxy(ActionProxy proxy)
void | setResult(Result result)
void | setResultCode(String resultCode) Sets the result code, possibly overriding the one returned by the action.
void | setStack(ValueStack stack)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

action

private Object action

invocationContext

private ActionContext invocationContext

actionEventListener

private ActionEventListener actionEventListener

proxy

private ActionProxy proxy

result

private Result result

resultCode

private String resultCode

stack

private ValueStack stack

preResultListeners

private List preResultListeners
Constructor Detail

MockActionInvocation

public MockActionInvocation()
Method Detail

getAction

public Object getAction()
Description copied from interface: ActionInvocation
Get the Action associated with this ActionInvocation

Specified by:
getAction in interface ActionInvocation

setAction

public void setAction(Object action)

getInvocationContext

public ActionContext getInvocationContext()
Description copied from interface: ActionInvocation
Gets the ActionContext associated with this ActionInvocation. The ActionProxy is responsible for setting this ActionContext onto the ThreadLocal before invoking the ActionInvocation and resetting the old ActionContext afterwards.

Specified by:
getInvocationContext in interface ActionInvocation

setInvocationContext

public void setInvocationContext(ActionContext invocationContext)

getProxy

public ActionProxy getProxy()
Description copied from interface: ActionInvocation
Get the ActionProxy holding this ActionInvocation

Specified by:
getProxy in interface ActionInvocation

setProxy

public void setProxy(ActionProxy proxy)

getResult

public Result getResult()
Description copied from interface: ActionInvocation
If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned. If the ActionInvocation's result has not been executed before, the Result instance will be created and populated with the result params.

Specified by:
getResult in interface ActionInvocation
Returns:
a Result instance

setResult

public void setResult(Result result)

getResultCode

public String getResultCode()
Description copied from interface: ActionInvocation
Gets the result code returned from this ActionInvocation

Specified by:
getResultCode in interface ActionInvocation

setResultCode

public void setResultCode(String resultCode)
Description copied from interface: ActionInvocation
Sets the result code, possibly overriding the one returned by the action.

The "intended" purpose of this method is to allow PreResultListeners to override the result code returned by the Action.

If this method is used before the Action executes, the Action's returned result code will override what was set. However the Action could (if specifically coded to do so) inspect the ActionInvocation to see that someone "upstream" (e.g. an Interceptor) had suggested a value as the result, and it could therefore return the same value itself.

If this method is called between the Action execution and the Result execution, then the value set here will override the result code the action had returned. Creating an Interceptor that implements PreResultListener will give you this oportunity.

If this method is called after the Result has been executed, it will have the effect of raising an exception.

Specified by:
setResultCode in interface ActionInvocation
See Also:
ActionInvocation.isExecuted()

getStack

public ValueStack getStack()
Specified by:
getStack in interface ActionInvocation
Returns:
the ValueStack associated with this ActionInvocation

setStack

public void setStack(ValueStack stack)

isExecuted

public boolean isExecuted()
Specified by:
isExecuted in interface ActionInvocation
Returns:
whether this ActionInvocation has executed before. This will be set after the Action and the Result have executed.

addPreResultListener

public void addPreResultListener(PreResultListener listener)
Description copied from interface: ActionInvocation
Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed. The ActionInvocation implementation must guarantee that listeners will be called in the order in which they are registered. Listener registration and execution does not need to be thread-safe.

Specified by:
addPreResultListener in interface ActionInvocation

invoke

public String invoke()
              throws Exception
Description copied from interface: ActionInvocation
Invokes the next step in processing this ActionInvocation. If there are more Interceptors, this will call the next one. If Interceptors choose not to short-circuit ActionInvocation processing and return their own return code, they will call invoke() to allow the next Interceptor to execute. If there are no more Interceptors to be applied, the Action is executed. If the ActionProxy getExecuteResult() method returns true, the Result is also executed.

Specified by:
invoke in interface ActionInvocation
Throws:
Exception

invokeActionOnly

public String invokeActionOnly()
                        throws Exception
Description copied from interface: ActionInvocation
Invokes only the action (not interceptors or results). This is useful in rare situations where advanced usage with the interceptor/action/result workflow is being manipulated for certain functionality.

Specified by:
invokeActionOnly in interface ActionInvocation
Throws:
Exception

setActionEventListener

public void setActionEventListener(ActionEventListener listener)
Description copied from interface: ActionInvocation
Sets the action event listener to respond to key action events

Specified by:
setActionEventListener in interface ActionInvocation

getActionEventListener

public ActionEventListener getActionEventListener()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MockActionProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockActionProxy

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockActionProxy
All Implemented Interfaces:
ActionProxy
public class MockActionProxy
extends Object
implements ActionProxy

Mock for an ActionProxy.

Author:
Patrick Lightbody (plightbo at gmail dot com)

Field Summary
(package private) Object | action
(package private) String | actionName
(package private) ActionConfig | config
(package private) Configuration | configuration
(package private) boolean | executedCalled
(package private) boolean | executeResult
(package private) ActionInvocation | invocation
(package private) String | method
(package private) String | namespace
(package private) String | returnedResult
Constructor Summary
MockActionProxy()
Method Summary
String | execute() Execute this ActionProxy.
Object | getAction()
String | getActionName()
ActionConfig | getConfig()
boolean | getExecuteResult()
ActionInvocation | getInvocation()
String | getMethod() Returns the method to execute, or null if no method has been specified (meaning "execute" will be invoked)
String | getNamespace()
boolean | isExecutedCalled()
void | prepare() Called after all dependencies are set
void | setAction(Object action)
void | setActionName(String actionName)
void | setConfig(ActionConfig config)
void | setExecuteResult(boolean executeResult) Sets whether this ActionProxy should also execute the Result after executing the Action
void | setInvocation(ActionInvocation invocation)
void | setMethod(String method) Sets the method to execute for the action invocation.
void | setNamespace(String namespace)
void | setReturnedResult(String returnedResult)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

action

Object action

actionName

String actionName

config

ActionConfig config

executeResult

boolean executeResult

invocation

ActionInvocation invocation

namespace

String namespace

method

String method

executedCalled

boolean executedCalled

returnedResult

String returnedResult

configuration

Configuration configuration
Constructor Detail

MockActionProxy

public MockActionProxy()
Method Detail

prepare

public void prepare()
             throws Exception
Description copied from interface: ActionProxy
Called after all dependencies are set

Specified by:
prepare in interface ActionProxy
Throws:
Exception

execute

public String execute()
               throws Exception
Description copied from interface: ActionProxy
Execute this ActionProxy. This will set the ActionContext from the ActionInvocation into the ActionContext ThreadLocal before invoking the ActionInvocation, then set the old ActionContext back into the ThreadLocal.

Specified by:
execute in interface ActionProxy
Returns:
the result code returned from executing the ActionInvocation
Throws:
Exception
See Also:
ActionInvocation

setReturnedResult

public void setReturnedResult(String returnedResult)

isExecutedCalled

public boolean isExecutedCalled()

getAction

public Object getAction()
Specified by:
getAction in interface ActionProxy
Returns:
the Action instance for this Proxy

setAction

public void setAction(Object action)

getActionName

public String getActionName()
Specified by:
getActionName in interface ActionProxy
Returns:
the alias name this ActionProxy is mapped to

setActionName

public void setActionName(String actionName)

getConfig

public ActionConfig getConfig()
Specified by:
getConfig in interface ActionProxy
Returns:
the ActionConfig this ActionProxy is built from

setConfig

public void setConfig(ActionConfig config)

getExecuteResult

public boolean getExecuteResult()
Specified by:
getExecuteResult in interface ActionProxy
Returns:
the status of whether the ActionProxy is set to execute the Result after the Action is executed

setExecuteResult

public void setExecuteResult(boolean executeResult)
Description copied from interface: ActionProxy
Sets whether this ActionProxy should also execute the Result after executing the Action

Specified by:
setExecuteResult in interface ActionProxy

getInvocation

public ActionInvocation getInvocation()
Specified by:
getInvocation in interface ActionProxy
Returns:
the ActionInvocation associated with this ActionProxy

setInvocation

public void setInvocation(ActionInvocation invocation)

getNamespace

public String getNamespace()
Specified by:
getNamespace in interface ActionProxy
Returns:
the namespace the ActionConfig for this ActionProxy is mapped to

setNamespace

public void setNamespace(String namespace)

getMethod

public String getMethod()
Description copied from interface: ActionProxy
Returns the method to execute, or null if no method has been specified (meaning "execute" will be invoked)

Specified by:
getMethod in interface ActionProxy

setMethod

public void setMethod(String method)
Description copied from interface: ActionProxy
Sets the method to execute for the action invocation. If no method is specified, the method provided by in the action's configuration will be used.

Specified by:
setMethod in interface ActionProxy
Parameters:
method - the string name of the method to invoke
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class MockInterceptor
extends Object
implements Interceptor

Mock for an Interceptor.

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
static String | DEFAULT_FOO_VALUE
private boolean | executed
private String | expectedFoo
private String | foo
Constructor Summary
MockInterceptor()
Method Summary
 void destroy()
Called to let an interceptor clean up any resources it has allocated.
 boolean equals(Object o)
 String getExpectedFoo()
 String getFoo()
 int hashCode()
 void init()
Called after an Interceptor is created, but before any requests are processed using the intercept() methodName.
 String intercept(ActionInvocation invocation)
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the DefaultActionInvocation or to short-circuit the processing and just return a String return code.
 boolean isExecuted()
 void setExpectedFoo(String expectedFoo)
 void setFoo(String foo)
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_FOO_VALUE

public static final String DEFAULT_FOO_VALUE
See Also:
Constant Field Values

expectedFoo

private String expectedFoo

foo

private String foo

executed

private boolean executed
Constructor Detail

MockInterceptor

public MockInterceptor()
Method Detail

isExecuted

public boolean isExecuted()

setExpectedFoo

public void setExpectedFoo(String expectedFoo)

getExpectedFoo

public String getExpectedFoo()

setFoo

public void setFoo(String foo)

getFoo

public String getFoo()

destroy

public void destroy()
Called to let an interceptor clean up any resources it has allocated.

Specified by:
destroy in interface Interceptor

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

init

public void init()
Called after an Interceptor is created, but before any requests are processed using the intercept() methodName. This gives the Interceptor a chance to initialize any needed resources.

Specified by:
init in interface Interceptor

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the DefaultActionInvocation or to short-circuit the processing and just return a String return code.

Specified by:
intercept in interface Interceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockObjectTypeDeterminer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockObjectTypeDeterminer

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockObjectTypeDeterminer
All Implemented Interfaces:
ObjectTypeDeterminer
public class MockObjectTypeDeterminer
extends Object
implements ObjectTypeDeterminer

Mocks the function of an ObjectTypeDeterminer for testing purposes.

Author:
Gabe

Field Summary
private Class | elementClass
private Class | keyClass
private String | keyProperty
private boolean | shouldCreateIfNew
Constructor Summary
MockObjectTypeDeterminer()
MockObjectTypeDeterminer(Class keyClass, Class elementClass, String keyProperty, boolean shouldCreateIfNew)
Method Summary
Class | getElementClass()
Class | getElementClass(Class parentClass, String property, Object key)
Class | getKeyClass()
Class | getKeyClass(Class parentClass, String property)
String | getKeyProperty()
String | getKeyProperty(Class parentClass, String property)
boolean | isShouldCreateIfNew()
void | setElementClass(Class elementClass)
void | setKeyClass(Class keyClass)
void | setKeyProperty(String keyProperty)
void | setShouldCreateIfNew(boolean shouldCreateIfNew)
boolean | shouldCreateIfNew(Class parentClass, String property, Object target, String keyProperty, boolean isIndexAccessed)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

keyClass

private Class keyClass

elementClass

private Class elementClass

keyProperty

private String keyProperty

shouldCreateIfNew

private boolean shouldCreateIfNew
Constructor Detail

MockObjectTypeDeterminer

public MockObjectTypeDeterminer()

MockObjectTypeDeterminer

public MockObjectTypeDeterminer(Class keyClass,
                                Class elementClass,
                                String keyProperty,
                                boolean shouldCreateIfNew)
Parameters:
keyClass -
elementClass -
keyProperty -
shouldCreateIfNew -
Method Detail

getKeyClass

public Class getKeyClass(Class parentClass,
                         String property)
Specified by:
getKeyClass in interface ObjectTypeDeterminer

getElementClass

public Class getElementClass(Class parentClass,
                             String property,
                             Object key)
Specified by:
getElementClass in interface ObjectTypeDeterminer

getKeyProperty

public String getKeyProperty(Class parentClass,
                             String property)
Specified by:
getKeyProperty in interface ObjectTypeDeterminer

shouldCreateIfNew

public boolean shouldCreateIfNew(Class parentClass,
                                 String property,
                                 Object target,
                                 String keyProperty,
                                 boolean isIndexAccessed)
Specified by:
shouldCreateIfNew in interface ObjectTypeDeterminer

getElementClass

public Class getElementClass()
Returns:
Returns the elementClass.

setElementClass

public void setElementClass(Class elementClass)
Parameters:
elementClass - The elementClass to set.

getKeyClass

public Class getKeyClass()
Returns:
Returns the keyClass.

setKeyClass

public void setKeyClass(Class keyClass)
Parameters:
keyClass - The keyClass to set.

getKeyProperty

public String getKeyProperty()
Returns:
Returns the keyProperty.

setKeyProperty

public void setKeyProperty(String keyProperty)
Parameters:
keyProperty - The keyProperty to set.

isShouldCreateIfNew

public boolean isShouldCreateIfNew()
Returns:
Returns the shouldCreateIfNew.

setShouldCreateIfNew

public void setShouldCreateIfNew(boolean shouldCreateIfNew)
Parameters:
shouldCreateIfNew - The shouldCreateIfNew to set.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MockResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.mock
Class MockResult

java.lang.Object
    extended by  com.opensymphony.xwork2.mock.MockResult
All Implemented Interfaces:
Result, Serializable
public class MockResult
extends Object
implements Result

Mock for a Result.

Author:
Mike, Rainer Hermanns
See Also:
Serialized Form

Constructor Summary
MockResult()
Method Summary
boolean | equals(Object o)
void | execute(ActionInvocation invocation) Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.
int | hashCode()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MockResult

public MockResult()
Method Detail

equals

public boolean equals(Object o)
Overrides:
equals in class Object

execute

public void execute(ActionInvocation invocation)
             throws Exception
Description copied from interface: Result
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Specified by:
execute in interface Result
Throws:
Exception

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.spring (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.spring

Spring ObjectFactory classes.

See:
Description

Class Summary
SpringObjectFactory | Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.
SpringProxyableObjectFactory | SpringProxyableObjectFactory.

Package com.opensymphony.xwork2.spring Description

Spring ObjectFactory classes.


com.opensymphony.xwork2.spring Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.spring

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.ObjectFactory (implements java.io.Serializable)
      • com.opensymphony.xwork2.spring.SpringObjectFactory
        • com.opensymphony.xwork2.spring.SpringProxyableObjectFactory


Uses of Package com.opensymphony.xwork2.spring (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.spring

Packages that use com.opensymphony.xwork2.spring
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.

Classes in com.opensymphony.xwork2.spring used by com.opensymphony.xwork2.spring
SpringObjectFactory
Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.

Classes in com.opensymphony.xwork2.spring used by com.opensymphony.xwork2.spring.interceptor
SpringObjectFactory
Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SpringObjectFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.spring
Class SpringObjectFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ObjectFactory
        extended by  com.opensymphony.xwork2.spring.SpringObjectFactory
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
SpringProxyableObjectFactory
public class SpringObjectFactory
extends ObjectFactory

Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.

In order to use this class in your application, you will need to instantiate a copy of this class and set it as XWork's ObjectFactory before the xwork.xml file is parsed. In a servlet environment, this could be done using a ServletContextListener.

Author:
Simon Stewart (sms@lateral.net)
See Also:
Serialized Form

Field Summary
protected ApplicationContext | appContext
protected int | autowireStrategy
protected AutowireCapableBeanFactory | autoWiringFactory
private Map | classes
private static Log | log
private boolean | useClassCache
Constructor Summary
SpringObjectFactory()
Method Summary
Object | autoWireBean(Object bean)
Object | autoWireBean(Object bean, AutowireCapableBeanFactory autoWiringFactory)
Object | buildBean(Class clazz, Map extraContext) Build a generic Java object of the given type.
Object | buildBean(String beanName, Map extraContext, boolean injectInternal) Looks up beans using Spring's application context before falling back to the method defined in the ObjectFactory.
protected AutowireCapableBeanFactory | findAutoWiringBeanFactory(ApplicationContext context) If the given context is assignable to AutowireCapbleBeanFactory or contains a parent or a factory that is, then set the autoWiringFactory appropriately.
int | getAutowireStrategy()
Class | getClassInstance(String className) Utility method to obtain the class matched to className.
void | initObjectFactory() This method sets the ObjectFactory used by XWork to this object.
boolean | isNoArgConstructorRequired() Allows for ObjectFactory implementations that support Actions without no-arg constructors.
void | setApplicationContext(ApplicationContext appContext) Set the Spring ApplicationContext that should be used to look beans up with.
void | setApplicationContextPath(String ctx)
void | setAutowireStrategy(int autowireStrategy) Sets the autowiring strategy
void | setUseClassCache(boolean useClassCache) Enable / disable caching of classes loaded by Spring.
Methods inherited from class com.opensymphony.xwork2.ObjectFactory
buildAction, buildBean, buildInterceptor, buildResult, buildValidator, getObjectFactory, injectInternalBeans, setClassLoader, setContainer, setObjectFactory
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

appContext

protected ApplicationContext appContext

autoWiringFactory

protected AutowireCapableBeanFactory autoWiringFactory

autowireStrategy

protected int autowireStrategy

classes

private Map classes

useClassCache

private boolean useClassCache
Constructor Detail

SpringObjectFactory

public SpringObjectFactory()
Method Detail

setApplicationContextPath

public void setApplicationContextPath(String ctx)

setApplicationContext

public void setApplicationContext(ApplicationContext appContext)
                           throws BeansException
Set the Spring ApplicationContext that should be used to look beans up with.

Parameters:
appContext - The Spring ApplicationContext that should be used to look beans up with.
Throws:
BeansException

setAutowireStrategy

public void setAutowireStrategy(int autowireStrategy)
Sets the autowiring strategy

Parameters:
autowireStrategy -

getAutowireStrategy

public int getAutowireStrategy()

findAutoWiringBeanFactory

protected AutowireCapableBeanFactory findAutoWiringBeanFactory(ApplicationContext context)
If the given context is assignable to AutowireCapbleBeanFactory or contains a parent or a factory that is, then set the autoWiringFactory appropriately.

Parameters:
context -

buildBean

public Object buildBean(String beanName,
                        Map extraContext,
                        boolean injectInternal)
                 throws Exception
Looks up beans using Spring's application context before falling back to the method defined in the ObjectFactory.

Overrides:
buildBean in class ObjectFactory
Parameters:
beanName - The name of the bean to look up in the application context
extraContext -
Returns:
A bean from Spring or the result of calling the overridden method.
Throws:
Exception

buildBean

public Object buildBean(Class clazz,
                        Map extraContext)
                 throws Exception
Description copied from class: ObjectFactory
Build a generic Java object of the given type.

Overrides:
buildBean in class ObjectFactory
Parameters:
clazz -
extraContext -
Throws:
Exception

autoWireBean

public Object autoWireBean(Object bean)

autoWireBean

public Object autoWireBean(Object bean,
                           AutowireCapableBeanFactory autoWiringFactory)
Parameters:
bean -
autoWiringFactory -

getClassInstance

public Class getClassInstance(String className)
                       throws ClassNotFoundException
Description copied from class: ObjectFactory
Utility method to obtain the class matched to className. Caches look ups so that subsequent lookups will be faster.

Overrides:
getClassInstance in class ObjectFactory
Parameters:
className - The fully qualified name of the class to return
Returns:
The class itself
Throws:
ClassNotFoundException

initObjectFactory

public void initObjectFactory()
This method sets the ObjectFactory used by XWork to this object. It's best used as the "init-method" of a Spring bean definition in order to hook Spring and XWork together properly (as an alternative to the org.apache.struts2.spring.lifecycle.SpringObjectFactoryListener)

isNoArgConstructorRequired

public boolean isNoArgConstructorRequired()
Allows for ObjectFactory implementations that support Actions without no-arg constructors.

Overrides:
isNoArgConstructorRequired in class ObjectFactory
Returns:
false

setUseClassCache

public void setUseClassCache(boolean useClassCache)
Enable / disable caching of classes loaded by Spring.

Parameters:
useClassCache -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SpringProxyableObjectFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.spring
Class SpringProxyableObjectFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ObjectFactory
        extended by  com.opensymphony.xwork2.spring.SpringObjectFactory
            extended by  com.opensymphony.xwork2.spring.SpringProxyableObjectFactory
All Implemented Interfaces:
Serializable
public class SpringProxyableObjectFactory
extends SpringObjectFactory

SpringProxyableObjectFactory.

Author:
Jason Carreira
See Also:
Serialized Form

Field Summary
private static Log | log
private List | skipBeanNames
Fields inherited from class com.opensymphony.xwork2.spring.SpringObjectFactory
appContext, autowireStrategy, autoWiringFactory
Constructor Summary
SpringProxyableObjectFactory()
Method Summary
Object | buildBean(String beanName, Map extraContext) Build a generic Java object of the given type.
protected ApplicationContext | getApplicationContext(Map context) Subclasses may override this to return a different application context.
Methods inherited from class com.opensymphony.xwork2.spring.SpringObjectFactory
autoWireBean, autoWireBean, buildBean, buildBean, findAutoWiringBeanFactory, getAutowireStrategy, getClassInstance, initObjectFactory, isNoArgConstructorRequired, setApplicationContext, setApplicationContextPath, setAutowireStrategy, setUseClassCache
Methods inherited from class com.opensymphony.xwork2.ObjectFactory
buildAction, buildInterceptor, buildResult, buildValidator, getObjectFactory, injectInternalBeans, setClassLoader, setContainer, setObjectFactory
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

skipBeanNames

private List skipBeanNames
Constructor Detail

SpringProxyableObjectFactory

public SpringProxyableObjectFactory()
Method Detail

buildBean

public Object buildBean(String beanName,
                        Map extraContext)
                 throws Exception
Description copied from class: ObjectFactory
Build a generic Java object of the given type.

Overrides:
buildBean in class ObjectFactory
Parameters:
beanName - the type of Object to build
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception

getApplicationContext

protected ApplicationContext getApplicationContext(Map context)
Subclasses may override this to return a different application context. Note that this application context should see any changes made to the autoWiringFactory, so the application context should be either the original or a child context of the original.

Parameters:
context - provided context.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.spring.interceptor (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.spring.interceptor

Spring specific interceptor classes.

See:
Description

Class Summary
ActionAutowiringInterceptor TODO: Give a description of the Interceptor.

Package com.opensymphony.xwork2.spring.interceptor Description

Spring specific interceptor classes.


com.opensymphony.xwork2.spring.interceptor Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.spring.interceptor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor


Uses of Package com.opensymphony.xwork2.spring.interceptor (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.spring.interceptor

No usage of com.opensymphony.xwork2.spring.interceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionAutowiringInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.spring.interceptor
Class ActionAutowiringInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ActionAutowiringInterceptor
extends AbstractInterceptor

TODO: Give a description of the Interceptor. TODO: Describe the paramters for this Interceptor. TODO: Discuss some possible extension of the Interceptor.

 <!-- TODO: Describe how the Interceptor reference will effect execution -->
 <action name="someAction" class="com.examples.SomeAction">
      TODO: fill in the interceptor reference.
     <interceptor-ref name=""/>
     <result name="success">good_result.ftl</result>
 </action>
Autowires action classes to Spring beans. The strategy for autowiring the beans can be configured by setting the parameter on the interceptor. Actions that need access to the ActionContext can implements the ApplicationContextAware interface. The context will also be placed on the action context under the APPLICATION_CONTEXT attribute.

Author:
Simon Stewart, Eric Hauser
See Also:
Serialized Form

Field Summary
static String | APPLICATION_CONTEXT
private Integer | autowireStrategy
private ApplicationContext | context
private SpringObjectFactory | factory
private boolean | initialized
private static Log | log
Constructor Summary
ActionAutowiringInterceptor()
Method Summary
protected ApplicationContext | getApplicationContext()
String | intercept(ActionInvocation invocation) Looks for the ApplicationContext under the attribute that the Spring listener sets in the servlet context.
void | setApplicationContext(ApplicationContext applicationContext)
void | setAutowireStrategy(Integer autowireStrategy)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

APPLICATION_CONTEXT

public static final String APPLICATION_CONTEXT
See Also:
Constant Field Values

initialized

private boolean initialized

context

private ApplicationContext context

factory

private SpringObjectFactory factory

autowireStrategy

private Integer autowireStrategy
Constructor Detail

ActionAutowiringInterceptor

public ActionAutowiringInterceptor()
Method Detail

setAutowireStrategy

public void setAutowireStrategy(Integer autowireStrategy)
Parameters:
autowireStrategy -

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Looks for the ApplicationContext under the attribute that the Spring listener sets in the servlet context. The configuration is done the first time here instead of in init() since the ActionContext is not available during Interceptor initialization.

Autowires the action to Spring beans and places the ApplicationContext on the ActionContext

TODO Should this check to see if the SpringObjectFactory has already been configured instead of instantiating a new one? Or is there a good reason for the interceptor to have it's own factory?

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation -
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception

setApplicationContext

public void setApplicationContext(ApplicationContext applicationContext)
                           throws BeansException
Parameters:
applicationContext -
Throws:
BeansException

getApplicationContext

protected ApplicationContext getApplicationContext()
Returns:
context
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util

XWork util classes.

See:
Description

Interface Summary
ObjectTypeDeterminer | Determines what the key and and element class of a Map or Collection should be.
ResolverUtil.Test | A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.
TextParseUtil.ParsedValueEvaluator | A parsed value evaluator for TextParseUtil.
ValueStack | ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Class Summary
AnnotationUtils | AnnotationUtils Various utility methods dealing with annotations
AnnotationXWorkConverter | Type conversion is great for situations where you need to turn a String in to a more complex object.
ClassLoaderUtil | This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers.
ClassLoaderUtil.AggregateIterator<E> | Aggregates Enumeration instances into one iterator and filters out duplicates.
CompoundRoot | A Stack that is implemented using a List.
CompoundRootAccessor | A stack that is able to call methods on objects in the stack.
CompoundRootAccessor.MethodCall |
DefaultObjectTypeDeterminer | This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections.
DomHelper | Helper class to create and retrieve information from location-enabled DOM-trees.
DomHelper.DOMBuilder | The DOMBuilder is a utility class that will generate a W3C DOM Document from SAX events.
DomHelper.StartHandler |
EnumTypeConverter | EnumTypeConverter This class converts java 5 enums to String and from String[] to enum.
FileManager | FileManager This class was brought in from oscore trunk revision 147.
FileManager.FileRevision |
GenericsObjectTypeDeterminer | GenericsObjectTypeDeterminer
InstantiatingNullHandler | Provided that the key InstantiatingNullHandler.CREATE_NULL_OBJECTS is in the action context with a value of true (this key is set only during the execution of the ParametersInterceptor), OGNL expressions that have caused a NullPointerException will be temporarily stopped for evaluation while the system automatically tries to solve the null references by automatically creating the object.
LocalizedTextUtil | Provides support for localization in XWork.
LocalizedTextUtil.GetDefaultMessageReturnArg |
LocalizedTextUtil.MessageFormatKey |
ObjectProxy | An Object to use within OGNL to proxy other Objects usually Collections that you set in a different place on the ValueStack but want to retain the context information about where they previously were.
ObjectProxyPropertyAccessor | Is able to access (set/get) properties on a given object.
ObjectTypeDeterminerFactory | Factory for getting an instance of ObjectTypeDeterminer.
OgnlContextState | Manages variables in the OgnlContext and returns values to be used by the application.
OgnlUtil | Utility class that provides common access to the Ognl APIs for setting and getting properties from objects (usually Actions).
OgnlValueStack | Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it.
OgnlValueStack.ObjectAccessor |
OgnlValueStackFactory | Creates an Ognl value stack
PropertiesReader | This class is used to read properties lines.
ResolverUtil<T> | ResolverUtil is used to locate classes that are available in the/a class path and meet arbitrary conditions.
ResolverUtil.AnnotatedWith | A Test that checks to see if each class is annotated with a specific annotation.
ResolverUtil.IsA | A Test that checks to see if each class is assignable to the provided class.
ResolverUtil.NameEndsWith | A Test that checks to see if each class name ends with the provided suffix.
SurrugateList |
TextParseUtil | Utility class for text parsing.
TextUtils | Utilities for common String manipulations.
ValueStackFactory | Factory that creates a value stack, defaulting to the OgnlValueStackFactory
WildcardHelper | This class is an utility class that perform wilcard-patterns matching and isolation taken from Apache Cocoon.
XWorkBasicConverter | XWork will automatically handle the most common type conversion for you.
XWorkCollectionPropertyAccessor |
XWorkConverter | XWorkConverter is a singleton used by many of the WebWork's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.
XWorkEnumerationAcccessor |
XWorkIteratorPropertyAccessor |
XWorkList | Deprecated. Native support for expanding lists and maps is provided in XWork 1.1, so this is no longer needed.
XWorkListPropertyAccessor | Overrides the list property accessor so in the case of trying to add properties of a given bean and the JavaBean is not present, this class will create the necessary blank JavaBeans.
XWorkMap | Deprecated. Native support for expanding lists and maps is provided in XWork 1.1, so this is no longer needed.
XWorkMapPropertyAccessor | Implementation of PropertyAccessor that sets and gets properties by storing and looking up values in Maps.
XWorkMethodAccessor | Allows methods to be executed under normal cirumstances, except when XWorkMethodAccessor.DENY_METHOD_EXECUTION is in the action context with a value of true.
XWorkObjectPropertyAccessor |
XWorkTestCaseHelper | Generic test setup methods to be used with any unit testing framework.

Exception Summary
TypeConversionException TypeConversionException should be thrown by any TypeConverters which fail to convert values

Annotation Types Summary
CreateIfNull | Sets the CreateIfNull for type conversion.
Element | Sets the Element for type conversion.
Key | Sets the Key for type conversion.
KeyProperty | Sets the KeyProperty for type conversion.

Package com.opensymphony.xwork2.util Description

XWork util classes.


com.opensymphony.xwork2.util Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • com.opensymphony.xwork2.util.CompoundRoot
          • com.opensymphony.xwork2.util.SurrugateList
          • com.opensymphony.xwork2.util.XWorkList
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • com.opensymphony.xwork2.util.XWorkMap
    • com.opensymphony.xwork2.util.AnnotationUtils
    • com.opensymphony.xwork2.util.ClassLoaderUtil
    • com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator<E> (implements java.util.Iterator<E>)
    • com.opensymphony.xwork2.util.CompoundRootAccessor (implements ognl.ClassResolver, ognl.MethodAccessor, ognl.PropertyAccessor)
    • com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • com.opensymphony.xwork2.util.DomHelper.StartHandler
    • com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer (implements com.opensymphony.xwork2.util.ObjectTypeDeterminer)
      • com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
    • ognl.DefaultTypeConverter (implements ognl.TypeConverter)
      • com.opensymphony.xwork2.util.EnumTypeConverter
      • com.opensymphony.xwork2.util.XWorkBasicConverter
      • com.opensymphony.xwork2.util.XWorkConverter
        • com.opensymphony.xwork2.util.AnnotationXWorkConverter
    • com.opensymphony.xwork2.util.DomHelper
    • com.opensymphony.xwork2.util.DomHelper.DOMBuilder (implements org.xml.sax.ContentHandler)
    • com.opensymphony.xwork2.util.FileManager
    • com.opensymphony.xwork2.util.FileManager.FileRevision
    • com.opensymphony.xwork2.util.InstantiatingNullHandler (implements ognl.NullHandler)
    • com.opensymphony.xwork2.util.LocalizedTextUtil
    • com.opensymphony.xwork2.util.LocalizedTextUtil.GetDefaultMessageReturnArg
    • com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey
    • ognl.MapPropertyAccessor (implements ognl.PropertyAccessor)
      • com.opensymphony.xwork2.util.XWorkMapPropertyAccessor
    • ognl.ObjectMethodAccessor (implements ognl.MethodAccessor)
      • com.opensymphony.xwork2.util.XWorkMethodAccessor
    • ognl.ObjectPropertyAccessor (implements ognl.PropertyAccessor)
      • ognl.EnumerationPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.util.XWorkEnumerationAcccessor
      • ognl.IteratorPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor
      • ognl.ListPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.util.XWorkListPropertyAccessor
      • com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor
      • ognl.SetPropertyAccessor (implements ognl.PropertyAccessor)
        • com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor
      • com.opensymphony.xwork2.util.XWorkObjectPropertyAccessor
    • com.opensymphony.xwork2.util.ObjectProxy
    • com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor (implements ognl.PropertyAccessor)
    • com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory
    • com.opensymphony.xwork2.util.OgnlContextState
    • com.opensymphony.xwork2.util.OgnlUtil
    • com.opensymphony.xwork2.util.OgnlValueStack (implements java.io.Serializable, com.opensymphony.xwork2.util.ValueStack)
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
          • com.opensymphony.xwork2.util.PropertiesReader
    • com.opensymphony.xwork2.util.ResolverUtil<T>
    • com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
    • com.opensymphony.xwork2.util.ResolverUtil.IsA (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
    • com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith (implements com.opensymphony.xwork2.util.ResolverUtil.Test)
    • com.opensymphony.xwork2.util.TextParseUtil
    • com.opensymphony.xwork2.util.TextUtils
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
            • com.opensymphony.xwork2.util.TypeConversionException
    • com.opensymphony.xwork2.util.ValueStackFactory
      • com.opensymphony.xwork2.util.OgnlValueStackFactory
    • com.opensymphony.xwork2.util.WildcardHelper
    • com.opensymphony.xwork2.util.XWorkTestCaseHelper

Interface Hierarchy

  • com.opensymphony.xwork2.util.ObjectTypeDeterminer
  • com.opensymphony.xwork2.util.ResolverUtil.Test
  • com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator
  • com.opensymphony.xwork2.util.ValueStack

Annotation Type Hierarchy

  • com.opensymphony.xwork2.util.CreateIfNull (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.Element (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.Key (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.util.KeyProperty (implements java.lang.annotation.Annotation)


Uses of Package com.opensymphony.xwork2.util (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.util

Packages that use com.opensymphony.xwork2.util
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.components |
org.apache.struts2.components.table |
org.apache.struts2.components.template |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.portlet.result |
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.views |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.freemarker.tags |
org.apache.struts2.views.jsp | Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.
org.apache.struts2.views.util | Miscellaneous helper classes for all views.
org.apache.struts2.views.velocity | Classes for views using Velocity.
org.apache.struts2.views.velocity.components |

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.config.impl
WildcardHelper
This class is an utility class that perform wilcard-patterns matching and isolation taken from Apache Cocoon.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.interceptor
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.mock
ObjectTypeDeterminer
Determines what the key and and element class of a Map or Collection should be.
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.util
ClassLoaderUtil.AggregateIterator
Aggregates Enumeration instances into one iterator and filters out duplicates.
CompoundRoot
A Stack that is implemented using a List.
CompoundRootAccessor
A stack that is able to call methods on objects in the stack.
DefaultObjectTypeDeterminer
This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections.
LocalizedTextUtil.GetDefaultMessageReturnArg
ObjectProxy
An Object to use within OGNL to proxy other Objects usually Collections that you set in a different place on the ValueStack but want to retain the context information about where they previously were.
ObjectTypeDeterminer
Determines what the key and and element class of a Map or Collection should be.
ResolverUtil.Test
A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.
TextParseUtil.ParsedValueEvaluator
A parsed value evaluator for TextParseUtil.
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.
ValueStackFactory
Factory that creates a value stack, defaulting to the OgnlValueStackFactory
XWorkCollectionPropertyAccessor
XWorkConverter
XWorkConverter is a singleton used by many of the WebWork's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.

Classes in com.opensymphony.xwork2.util used by com.opensymphony.xwork2.validator
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.components
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.components.table
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.components.template
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.dispatcher
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.portlet.result
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.util
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.freemarker
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.freemarker.tags
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.jsp
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.jsp.iterator
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.jsp.ui
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.jsp.ui.table
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.util
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.velocity
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Classes in com.opensymphony.xwork2.util used by org.apache.struts2.views.velocity.components
ValueStack
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ObjectTypeDeterminer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface ObjectTypeDeterminer

All Known Implementing Classes:
DefaultObjectTypeDeterminer, GenericsObjectTypeDeterminer, MockObjectTypeDeterminer
public interface ObjectTypeDeterminer

Determines what the key and and element class of a Map or Collection should be. For Maps, the elements are the values. For Collections, the elements are the elements of the collection.

Author:
Gabriel Zimmerman

Method Summary
Class | getElementClass(Class parentClass, String property, Object key)
Class | getKeyClass(Class parentClass, String property)
String | getKeyProperty(Class parentClass, String property)
boolean | shouldCreateIfNew(Class parentClass, String property, Object target, String keyProperty, boolean isIndexAccessed)

Method Detail

getKeyClass

Class getKeyClass(Class parentClass,
                  String property)

getElementClass

Class getElementClass(Class parentClass,
                      String property,
                      Object key)

getKeyProperty

String getKeyProperty(Class parentClass,
                      String property)

shouldCreateIfNew

boolean shouldCreateIfNew(Class parentClass,
                          String property,
                          Object target,
                          String keyProperty,
                          boolean isIndexAccessed)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueStack (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface ValueStack

All Known Implementing Classes:
OgnlValueStack
public interface ValueStack

ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it. When evaluating an expression, the stack will be searched down the stack, from the latest objects pushed in to the earliest, looking for a bean with a getter or setter for the given property or a method of the given name (depending on the expression being evaluated).

Field Summary
static String | REPORT_ERRORS_ON_NO_PROP
static String | VALUE_STACK
Method Summary
 String findString(String expr)
 Object findValue(String expr)
Find a value by evaluating the given expression against the stack in the default search order.
 Object findValue(String expr, Class asType)
Find a value by evaluating the given expression against the stack in the default search order.
 Map getContext()
 Map getExprOverrides()
 CompoundRoot getRoot()
Get the CompoundRoot which holds the objects pushed onto the stack
 Object peek()
Get the object on the top of the stack without changing the stack.
 Object pop()
Get the object on the top of the stack and remove it from the stack.
 void push(Object o)
Put this object onto the top of the stack
 void set(String key, Object o)
Sets an object on the stack with the given key so it is retrievable by findValue(key,...)
 void setDefaultType(Class defaultType)
Sets the default type to convert to if no type is provided when getting a value.
 void setExprOverrides(Map overrides)
 void setValue(String expr, Object value)
Attempts to set a property on a bean in the stack with the given expression using the default search order.
 void setValue(String expr, Object value, boolean throwExceptionOnFailure)
Attempts to set a property on a bean in the stack with the given expression using the default search order.
 int size()
Get the number of objects in the stack s

Field Detail

VALUE_STACK

static final String VALUE_STACK
See Also:
Constant Field Values

REPORT_ERRORS_ON_NO_PROP

static final String REPORT_ERRORS_ON_NO_PROP
See Also:
Constant Field Values
Method Detail

getContext

Map getContext()

setDefaultType

void setDefaultType(Class defaultType)
Sets the default type to convert to if no type is provided when getting a value.

Parameters:
defaultType -

setExprOverrides

void setExprOverrides(Map overrides)

getExprOverrides

Map getExprOverrides()

getRoot

CompoundRoot getRoot()
Get the CompoundRoot which holds the objects pushed onto the stack

setValue

void setValue(String expr,
              Object value)
Attempts to set a property on a bean in the stack with the given expression using the default search order.

Parameters:
expr - the expression defining the path to the property to be set.
value - the value to be set into the neamed property

setValue

void setValue(String expr,
              Object value,
              boolean throwExceptionOnFailure)
Attempts to set a property on a bean in the stack with the given expression using the default search order.

Parameters:
expr - the expression defining the path to the property to be set.
value - the value to be set into the neamed property
throwExceptionOnFailure - a flag to tell whether an exception should be thrown if there is no property with the given name.

findString

String findString(String expr)

findValue

Object findValue(String expr)
Find a value by evaluating the given expression against the stack in the default search order.

Parameters:
expr - the expression giving the path of properties to navigate to find the property value to return
Returns:
the result of evaluating the expression

findValue

Object findValue(String expr,
                 Class asType)
Find a value by evaluating the given expression against the stack in the default search order.

Parameters:
expr - the expression giving the path of properties to navigate to find the property value to return
asType - the type to convert the return value to
Returns:
the result of evaluating the expression

peek

Object peek()
Get the object on the top of the stack without changing the stack.

See Also:
CompoundRoot.peek()

pop

Object pop()
Get the object on the top of the stack and remove it from the stack.

Returns:
the object on the top of the stack
See Also:
CompoundRoot.pop()

push

void push(Object o)
Put this object onto the top of the stack

Parameters:
o - the object to be pushed onto the stack
See Also:
CompoundRoot.push(Object)

set

void set(String key,
         Object o)
Sets an object on the stack with the given key so it is retrievable by findValue(key,...)

Parameters:
key -
o -

size

int size()
Get the number of objects in the stack s

Returns:
the number of objects in the stack
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnnotationUtils (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class AnnotationUtils

java.lang.Object
    extended by  com.opensymphony.xwork2.util.AnnotationUtils

public class AnnotationUtils
extends Object

AnnotationUtils Various utility methods dealing with annotations

Version:
$Id: AnnotationUtils.java 1209 2006-11-17 07:53:04Z mrdon $
Author:
Rainer Hermanns, Zsolt Szasz, zsolt at lorecraft dot com

Field Summary
private static Pattern | GETTER_PATTERN
private static Pattern | SETTER_PATTERN
Constructor Summary
AnnotationUtils()
Method Summary
static void | addAllFields(Class annotationClass, Class clazz, List<Field> allFields) Adds all fields with the specified Annotation of class clazz and its superclasses to allFields
static void | addAllInterfaces(Class clazz, List allInterfaces)
static void | addAllMethods(Class annotationClass, Class clazz, List<Method> allMethods) Adds all methods with the specified Annotation of class clazz and its superclasses to allFields
static String[] | find(Class clazz, String pckgname) Retrieves all classes within a packages.
static List<Method> | findAnnotatedMethods(Class clazz, Class<? extends Annotation> annotationClass)
static void | findRecursively(Class clazz, Class<? extends Annotation> annotationClass, List<Method> methods)
static String | resolvePropertyName(Method method) Returns the property name for a method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SETTER_PATTERN

private static final Pattern SETTER_PATTERN

GETTER_PATTERN

private static final Pattern GETTER_PATTERN
Constructor Detail

AnnotationUtils

public AnnotationUtils()
Method Detail

addAllFields

public static void addAllFields(Class annotationClass,
                                Class clazz,
                                List<Field> allFields)
Adds all fields with the specified Annotation of class clazz and its superclasses to allFields

Parameters:
annotationClass -
clazz -
allFields -

addAllMethods

public static void addAllMethods(Class annotationClass,
                                 Class clazz,
                                 List<Method> allMethods)
Adds all methods with the specified Annotation of class clazz and its superclasses to allFields

Parameters:
annotationClass -
clazz -
allMethods -

addAllInterfaces

public static void addAllInterfaces(Class clazz,
                                    List allInterfaces)
Parameters:
clazz -
allInterfaces -

findAnnotatedMethods

public static List<Method> findAnnotatedMethods(Class clazz,
                                                Class<? extends Annotation> annotationClass)

findRecursively

public static void findRecursively(Class clazz,
                                   Class<? extends Annotation> annotationClass,
                                   List<Method> methods)

resolvePropertyName

public static String resolvePropertyName(Method method)
Returns the property name for a method. This method is independant from property fields.

Parameters:
method - The method to get the property name for.
Returns:
the property name for given method; null if non could be resolved.

find

public static String[] find(Class clazz,
                            String pckgname)
Retrieves all classes within a packages. TODO: this currently does not work with jars.

Parameters:
pckgname -
Returns:
Array of full qualified class names from this package.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AnnotationXWorkConverter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class AnnotationXWorkConverter

java.lang.Object
    extended by  ognl.DefaultTypeConverter
        extended by  com.opensymphony.xwork2.util.XWorkConverter
            extended by  com.opensymphony.xwork2.util.AnnotationXWorkConverter
All Implemented Interfaces:
ognl.TypeConverter
public class AnnotationXWorkConverter
extends XWorkConverter

Type conversion is great for situations where you need to turn a String in to a more complex object. Because the web is type-agnostic (everything is a string in HTTP), XWork's type conversion features are very useful. For instance, if you were prompting a user to enter in coordinates in the form of a string (such as "3, 22"), you could have XWork do the conversion both from String to Point and from Point to String.

Using this "point" example, if your action (or another compound object in which you are setting properties on) has a corresponding ClassName-conversion.properties file, XWork will use the configured type converters for conversion to and from strings. So turning "3, 22" in to new Point(3, 22) is done by merely adding the following entry to ClassName-conversion.properties (Note that the PointConverter should impl the ognl.TypeConverter interface):

point = com.acme.PointConverter

Your type converter should be sure to check what class type it is being requested to convert. Because it is used for both to and from strings, you will need to split the conversion method in to two parts: one that turns Strings in to Points, and one that turns Points in to Strings.

After this is done, you can now reference your point (using <ww:property value="post"/> in JSP or ${point} in FreeMarker) and it will be printed as "3, 22" again. As such, if you submit this back to an action, it will be converted back to a Point once again.

In some situations you may wish to apply a type converter globally. This can be done by editing the file xwork-conversion.properties in the root of your class path (typically WEB-INF/classes) and providing a property in the form of the class name of the object you wish to convert on the left hand side and the class name of the type converter on the right hand side. For example, providing a type converter for all Point objects would mean adding the following entry:

com.acme.Point = com.acme.PointConverter

Type conversion should not be used as a substitute for i18n. It is not recommended to use this feature to print out properly formatted dates. Rather, you should use the i18n features of XWork (and consult the JavaDocs for JDK's MessageFormat object) to see how a properly formatted date should be displayed.

Any error that occurs during type conversion may or may not wish to be reported. For example, reporting that the input "abc" could not be converted to a number might be important. On the other hand, reporting that an empty string, "", cannot be converted to a number might not be important - especially in a web environment where it is hard to distinguish between a user not entering a value vs. entering a blank value.

By default, all conversion errors are reported using the generic i18n key xwork.default.invalid.fieldvalue, which you can override (the default text is Invalid field value for field "xxx", where xxx is the field name) in your global i18n resource bundle.

However, sometimes you may wish to override this message on a per-field basis. You can do this by adding an i18n key associated with just your action (Action.properties) using the pattern invalid.fieldvalue.xxx, where xxx is the field name.

It is important to know that none of these errors are actually reported directly. Rather, they are added to a map called conversionErrors in the ActionContext. There are several ways this map can then be accessed and the errors can be reported accordingly.

Author:
Pat Lightbody, Rainer Hermanns
See Also:
XWorkConverter

Field Summary
private static Log _log
Fields inherited from class com.opensymphony.xwork2.util.XWorkConverter
CONVERSION_COLLECTION_PREFIX, CONVERSION_ERROR_PROPERTY_PREFIX, CONVERSION_PROPERTY_FULLNAME, defaultMappings, defaultTypeConverter, LAST_BEAN_CLASS_ACCESSED, LAST_BEAN_PROPERTY_ACCESSED, LOG, mappings, noMapping, objectTypeDeterminer, REPORT_CONVERSION_ERRORS, unknownMappings
Constructor Summary
AnnotationXWorkConverter()
Method Summary
(package private)  void addConverterMapping(Map mapping, Class clazz)
Looks for converter mappings for the specified class and adds it to an existing map.
Methods inherited from class com.opensymphony.xwork2.util.XWorkConverter
buildConverterFilename, convertValue, convertValue, createTypeConverter, getConversionErrorMessage, getConverter, getInstance, getObjectTypeDeterminer, handleConversionException, loadConversionProperties, lookup, lookup, lookupSuper, registerConverter, registerConverterNotFound, resetInstance, setDefaultConverter, setInstance, setObjectTypeDeterminer
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log
Constructor Detail

AnnotationXWorkConverter

public AnnotationXWorkConverter()
Method Detail

addConverterMapping

void addConverterMapping(Map mapping,
                         Class clazz)
Looks for converter mappings for the specified class and adds it to an existing map. Only new converters are added. If a converter is defined on a key that already exists, the converter is ignored.

Overrides:
addConverterMapping in class XWorkConverter
Parameters:
mapping - an existing map to add new converter mappings to
clazz - class to look for converter mappings for
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassLoaderUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ClassLoaderUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ClassLoaderUtil

public class ClassLoaderUtil
extends Object

This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers. It has come out of many months of frustrating use of multiple application servers at Atlassian, please don't change things unless you're sure they're not going to break in one server or another! It was brought in from oscore trunk revision 147.

Version:
$Revision: 117 $
Author:
$Author: hani $

Nested Class Summary
protected static class ClassLoaderUtil.AggregateIterator<E>
Aggregates Enumeration instances into one iterator and filters out duplicates.
Constructor Summary
ClassLoaderUtil()
Method Summary
static URL | getResource(String resourceName, Class callingClass) Load a given resource.
static InputStream | getResourceAsStream(String resourceName, Class callingClass) This is a convenience method to load a resource as a stream.
static Iterator<URL> | getResources(String resourceName, Class callingClass, boolean aggregate) Load all resources with a given name, potentially aggregating all results from the searched classloaders.
static Class | loadClass(String className, Class callingClass) Load a class with a given name.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassLoaderUtil

public ClassLoaderUtil()
Method Detail

getResources

public static Iterator<URL> getResources(String resourceName,
                                         Class callingClass,
                                         boolean aggregate)
                                  throws IOException
Load all resources with a given name, potentially aggregating all results from the searched classloaders. If no results are found, the resource name is prepended by '/' and tried again. This method will try to load the resources using the following methods (in order):
  • From Thread.currentThread().getContextClassLoader()
  • From ClassLoaderUtil.class.getClassLoader()
  • callingClass.getClassLoader()

Parameters:
resourceName - The name of the resources to load
callingClass - The Class object of the calling object
Throws:
IOException

getResource

public static URL getResource(String resourceName,
                              Class callingClass)
Load a given resource. This method will try to load the resource using the following methods (in order):
  • From Thread.currentThread().getContextClassLoader()
  • From ClassLoaderUtil.class.getClassLoader()
  • callingClass.getClassLoader()

Parameters:
resourceName - The name IllegalStateException("Unable to call ")of the resource to load
callingClass - The Class object of the calling object

getResourceAsStream

public static InputStream getResourceAsStream(String resourceName,
                                              Class callingClass)
This is a convenience method to load a resource as a stream. The algorithm used to find the resource is given in getResource()

Parameters:
resourceName - The name of the resource to load
callingClass - The Class object of the calling object

loadClass

public static Class loadClass(String className,
                              Class callingClass)
                       throws ClassNotFoundException
Load a class with a given name. It will try to load the class in the following order:
  • From Thread.currentThread().getContextClassLoader()
  • Using the basic Class.forName()
  • From ClassLoaderUtil.class.getClassLoader()
  • From the callingClass.getClassLoader()

Parameters:
className - The name of the class to load
callingClass - The Class object of the calling object
Throws:
ClassNotFoundException - If the class cannot be found anywhere.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompoundRoot (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class CompoundRoot

java.lang.Object
    extended by  java.util.AbstractCollection<E>
        extended by  java.util.AbstractList<E>
            extended by  java.util.ArrayList
                extended by  com.opensymphony.xwork2.util.CompoundRoot
All Implemented Interfaces:
Serializable, Cloneable, Iterable, Collection, List, RandomAccess
public class CompoundRoot
extends ArrayList

A Stack that is implemented using a List.

Version:
$Revision: 1063 $
Author:
plightbo
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
CompoundRoot()
CompoundRoot(List list)
Method Summary
CompoundRoot | cutStack(int index)
Object | peek()
Object | pop()
void | push(Object o)
Methods inherited from class java.util.ArrayList
add, add, addAll, addAll, clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, remove, removeRange, set, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

Constructor Detail

CompoundRoot

public CompoundRoot()

CompoundRoot

public CompoundRoot(List list)
Method Detail

cutStack

public CompoundRoot cutStack(int index)

peek

public Object peek()

pop

public Object pop()

push

public void push(Object o)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompoundRootAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class CompoundRootAccessor

java.lang.Object
    extended by  com.opensymphony.xwork2.util.CompoundRootAccessor
All Implemented Interfaces:
ognl.ClassResolver, ognl.MethodAccessor, ognl.PropertyAccessor
public class CompoundRootAccessor
extends Object
implements ognl.PropertyAccessor, ognl.MethodAccessor, ognl.ClassResolver

A stack that is able to call methods on objects in the stack.

Version:
$Revision: 1194 $
Author:
$Author: mrdon $, Rainer Hermanns

Nested Class Summary
(package private) static class CompoundRootAccessor.MethodCall
Field Summary
private static Map | invalidMethods
private static Log | log
Constructor Summary
CompoundRootAccessor()
Method Summary
Object | callMethod(Map context, Object target, String name, Object[] objects)
Object | callStaticMethod(Map transientVars, Class aClass, String s, Object[] objects)
Class | classForName(String className, Map context)
private Class[] | getArgTypes(Object[] args)
Object | getProperty(Map context, Object target, Object name)
void | setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

invalidMethods

private static Map invalidMethods
Constructor Detail

CompoundRootAccessor

public CompoundRootAccessor()
Method Detail

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Throws:
ognl.OgnlException

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object name)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Throws:
ognl.OgnlException

callMethod

public Object callMethod(Map context,
                         Object target,
                         String name,
                         Object[] objects)
                  throws ognl.MethodFailedException
Specified by:
callMethod in interface ognl.MethodAccessor
Throws:
ognl.MethodFailedException

callStaticMethod

public Object callStaticMethod(Map transientVars,
                               Class aClass,
                               String s,
                               Object[] objects)
                        throws ognl.MethodFailedException
Specified by:
callStaticMethod in interface ognl.MethodAccessor
Throws:
ognl.MethodFailedException

classForName

public Class classForName(String className,
                          Map context)
                   throws ClassNotFoundException
Specified by:
classForName in interface ognl.ClassResolver
Throws:
ClassNotFoundException

getArgTypes

private Class[] getArgTypes(Object[] args)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompoundRootAccessor.MethodCall (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class CompoundRootAccessor.MethodCall

java.lang.Object
    extended by  com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall
Enclosing class:
CompoundRootAccessor
static class CompoundRootAccessor.MethodCall
extends Object

Field Summary
(package private) Class[] | args
(package private) Class | clazz
(package private) int | hash
(package private) String | name
Constructor Summary
CompoundRootAccessor.MethodCall(Class clazz, String name, Class[] args)
Method Summary
boolean | equals(Object obj)
int | hashCode()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

clazz

Class clazz

name

String name

args

Class[] args

hash

int hash
Constructor Detail

CompoundRootAccessor.MethodCall

public CompoundRootAccessor.MethodCall(Class clazz,
                                       String name,
                                       Class[] args)
Method Detail

equals

public boolean equals(Object obj)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultObjectTypeDeterminer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class DefaultObjectTypeDeterminer

java.lang.Object
    extended by  com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer
All Implemented Interfaces:
ObjectTypeDeterminer
Direct Known Subclasses:
GenericsObjectTypeDeterminer
public class DefaultObjectTypeDeterminer
extends Object
implements ObjectTypeDeterminer

This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections. For Collections, such as Lists, the element is specified using the pattern Element_xxx, where xxx is the field name of the collection property in your action or object. For Maps, both the key and the value may be specified by using the pattern Key_xxx and Element_xxx, respectively.

From WebWork 2.1.x, the Collection_xxx format is still supported and honored, although it is deprecated and will be removed eventually.

Author:
Gabriel Zimmerman
See Also:
XWorkListPropertyAccessor, XWorkCollectionPropertyAccessor, XWorkMapPropertyAccessor

Field Summary
static String | CREATE_IF_NULL_PREFIX
static String | DEPRECATED_ELEMENT_PREFIX
static String | ELEMENT_PREFIX
static String | KEY_PREFIX
static String | KEY_PROPERTY_PREFIX
protected static Log | LOG
Constructor Summary
DefaultObjectTypeDeterminer()
Method Summary
Class | getElementClass(Class parentClass, String property, Object key) Determines the key class by looking for the value of Element_${property} in the properties file for the given class.
Class | getKeyClass(Class parentClass, String property) Determines the key class by looking for the value of Key_${property} in the properties file for the given class.
String | getKeyProperty(Class parentClass, String property) Determines the String key property for a Collection by getting it from the conversion properties file using the KeyProperty_ prefix.
boolean | shouldCreateIfNew(Class parentClass, String property, Object target, String keyProperty, boolean isIndexAccessed) Determines the boolean CreateIfNull property for a Collection or Map by getting it from the conversion properties file using the CreateIfNull_ prefix.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Log LOG

KEY_PREFIX

public static final String KEY_PREFIX
See Also:
Constant Field Values

ELEMENT_PREFIX

public static final String ELEMENT_PREFIX
See Also:
Constant Field Values

KEY_PROPERTY_PREFIX

public static final String KEY_PROPERTY_PREFIX
See Also:
Constant Field Values

CREATE_IF_NULL_PREFIX

public static final String CREATE_IF_NULL_PREFIX
See Also:
Constant Field Values

DEPRECATED_ELEMENT_PREFIX

public static final String DEPRECATED_ELEMENT_PREFIX
See Also:
Constant Field Values
Constructor Detail

DefaultObjectTypeDeterminer

public DefaultObjectTypeDeterminer()
Method Detail

getKeyClass

public Class getKeyClass(Class parentClass,
                         String property)
Determines the key class by looking for the value of Key_${property} in the properties file for the given class.

Specified by:
getKeyClass in interface ObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
See Also:
ObjectTypeDeterminer.getKeyClass(Class, String)

getElementClass

public Class getElementClass(Class parentClass,
                             String property,
                             Object key)
Determines the key class by looking for the value of Element_${property} in the properties file for the given class. Also looks for the deprecated Collection_${property}

Specified by:
getElementClass in interface ObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
See Also:
ObjectTypeDeterminer.getElementClass(Class, String, Object)

getKeyProperty

public String getKeyProperty(Class parentClass,
                             String property)
Determines the String key property for a Collection by getting it from the conversion properties file using the KeyProperty_ prefix. KeyProperty_${property}=somePropertyOfBeansInTheSet

Specified by:
getKeyProperty in interface ObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the KeyProperty for.
property - the property of the Map or Collection for the given parent class

shouldCreateIfNew

public boolean shouldCreateIfNew(Class parentClass,
                                 String property,
                                 Object target,
                                 String keyProperty,
                                 boolean isIndexAccessed)
Determines the boolean CreateIfNull property for a Collection or Map by getting it from the conversion properties file using the CreateIfNull_ prefix. CreateIfNull_${property}=true|false

Specified by:
shouldCreateIfNew in interface ObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the CreateIfNull for.
property - the property of the Map or Collection for the given parent class
target -
keyProperty -
isIndexAccessed -
Returns:
true, if the Collection or Map should be created, false otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DomHelper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class DomHelper

java.lang.Object
    extended by  com.opensymphony.xwork2.util.DomHelper

public class DomHelper
extends Object

Helper class to create and retrieve information from location-enabled DOM-trees.

Since:
1.2

Nested Class Summary
static class | DomHelper.DOMBuilder The DOMBuilder is a utility class that will generate a W3C DOM Document from SAX events.
static class | DomHelper.StartHandler
Field Summary
private static Log | LOG
static String | XMLNS_URI
Constructor Summary
DomHelper()
Method Summary
static Location | getLocationObject(Element element)
static Document | parse(InputSource inputSource) Creates a W3C Document that remembers the location of each element in the source file.
static Document | parse(InputSource inputSource, Map dtdMappings) Creates a W3C Document that remembers the location of each element in the source file.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

XMLNS_URI

public static final String XMLNS_URI
See Also:
Constant Field Values
Constructor Detail

DomHelper

public DomHelper()
Method Detail

getLocationObject

public static Location getLocationObject(Element element)

parse

public static Document parse(InputSource inputSource)
Creates a W3C Document that remembers the location of each element in the source file. The location of element nodes can then be retrieved using the getLocationObject(Element) method.

Parameters:
inputSource - the inputSource to read the document from

parse

public static Document parse(InputSource inputSource,
                             Map dtdMappings)
Creates a W3C Document that remembers the location of each element in the source file. The location of element nodes can then be retrieved using the getLocationObject(Element) method.

Parameters:
inputSource - the inputSource to read the document from
dtdMappings - a map of DTD names and public ids
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DomHelper.DOMBuilder (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class DomHelper.DOMBuilder

java.lang.Object
    extended by  com.opensymphony.xwork2.util.DomHelper.DOMBuilder
All Implemented Interfaces:
ContentHandler
Enclosing class:
DomHelper
public static class DomHelper.DOMBuilder
extends Object
implements ContentHandler

The DOMBuilder is a utility class that will generate a W3C DOM Document from SAX events.

Author:
Carsten Ziegeler

Field Summary
protected SAXTransformerFactory | factory The transformer factory
protected static SAXTransformerFactory | FACTORY The default transformer factory shared by all instances
protected ContentHandler | nextHandler
protected Node | parentNode The parentNode
protected DOMResult | result The result
Constructor Summary
DomHelper.DOMBuilder()
Construct a new instance of this DOMBuilder.
DomHelper.DOMBuilder(Node parentNode)
Constructs a new instance that appends nodes to the given parent node.
DomHelper.DOMBuilder(SAXTransformerFactory factory)
Construct a new instance of this DOMBuilder.
DomHelper.DOMBuilder(SAXTransformerFactory factory, Node parentNode)
Construct a new instance of this DOMBuilder.
Method Summary
void | characters(char[] arg0, int arg1, int arg2)
void | endDocument()
void | endElement(String arg0, String arg1, String arg2)
void | endPrefixMapping(String arg0)
Document | getDocument() Return the newly built Document.
void | ignorableWhitespace(char[] arg0, int arg1, int arg2)
void | processingInstruction(String arg0, String arg1)
void | setDocumentLocator(Locator locator)
private void | setup() Setup this instance transformer and result objects.
void | skippedEntity(String arg0)
void | startDocument()
void | startElement(String uri, String loc, String raw, Attributes attrs)
void | startPrefixMapping(String arg0, String arg1)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FACTORY

protected static SAXTransformerFactory FACTORY
The default transformer factory shared by all instances

factory

protected SAXTransformerFactory factory
The transformer factory

result

protected DOMResult result
The result

parentNode

protected Node parentNode
The parentNode

nextHandler

protected ContentHandler nextHandler
Constructor Detail

DomHelper.DOMBuilder

public DomHelper.DOMBuilder()
Construct a new instance of this DOMBuilder.

DomHelper.DOMBuilder

public DomHelper.DOMBuilder(SAXTransformerFactory factory)
Construct a new instance of this DOMBuilder.

DomHelper.DOMBuilder

public DomHelper.DOMBuilder(Node parentNode)
Constructs a new instance that appends nodes to the given parent node.

DomHelper.DOMBuilder

public DomHelper.DOMBuilder(SAXTransformerFactory factory,
                            Node parentNode)
Construct a new instance of this DOMBuilder.

Method Detail

setup

private void setup()
Setup this instance transformer and result objects.

getDocument

public Document getDocument()
Return the newly built Document.

setDocumentLocator

public void setDocumentLocator(Locator locator)
Specified by:
setDocumentLocator in interface ContentHandler

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Throws:
SAXException

startElement

public void startElement(String uri,
                         String loc,
                         String raw,
                         Attributes attrs)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Throws:
SAXException

endElement

public void endElement(String arg0,
                       String arg1,
                       String arg2)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String arg0,
                               String arg1)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String arg0)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Throws:
SAXException

characters

public void characters(char[] arg0,
                       int arg1,
                       int arg2)
                throws SAXException
Specified by:
characters in interface ContentHandler
Throws:
SAXException

ignorableWhitespace

public void ignorableWhitespace(char[] arg0,
                                int arg1,
                                int arg2)
                         throws SAXException
Specified by:
ignorableWhitespace in interface ContentHandler
Throws:
SAXException

processingInstruction

public void processingInstruction(String arg0,
                                  String arg1)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Throws:
SAXException

skippedEntity

public void skippedEntity(String arg0)
                   throws SAXException
Specified by:
skippedEntity in interface ContentHandler
Throws:
SAXException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DomHelper.StartHandler (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class DomHelper.StartHandler

java.lang.Object
    extended by  org.xml.sax.helpers.DefaultHandler
        extended by  com.opensymphony.xwork2.util.DomHelper.StartHandler
All Implemented Interfaces:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler
Enclosing class:
DomHelper
public static class DomHelper.StartHandler
extends DefaultHandler

Field Summary
private Map | dtdMappings
private ContentHandler | nextHandler
Constructor Summary
DomHelper.StartHandler(ContentHandler next, Map dtdMappings)
Create a filter that is chained to another handler.
Method Summary
void | characters(char[] arg0, int arg1, int arg2)
void | endDocument()
void | endElement(String arg0, String arg1, String arg2)
void | endPrefixMapping(String arg0)
void | error(SAXParseException exception)
void | fatalError(SAXParseException exception)
void | ignorableWhitespace(char[] arg0, int arg1, int arg2)
void | processingInstruction(String arg0, String arg1)
InputSource | resolveEntity(String publicId, String systemId)
void | setDocumentLocator(Locator locator)
void | skippedEntity(String arg0)
void | startDocument()
void | startElement(String uri, String loc, String raw, Attributes attrs)
void | startPrefixMapping(String arg0, String arg1)
void | warning(SAXParseException exception)
Methods inherited from class org.xml.sax.helpers.DefaultHandler
notationDecl, unparsedEntityDecl
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

nextHandler

private ContentHandler nextHandler

dtdMappings

private Map dtdMappings
Constructor Detail

DomHelper.StartHandler

public DomHelper.StartHandler(ContentHandler next,
                              Map dtdMappings)
Create a filter that is chained to another handler.

Parameters:
next - the next handler in the chain.
Method Detail

setDocumentLocator

public void setDocumentLocator(Locator locator)
Specified by:
setDocumentLocator in interface ContentHandler
Overrides:
setDocumentLocator in class DefaultHandler

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Overrides:
startDocument in class DefaultHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Overrides:
endDocument in class DefaultHandler
Throws:
SAXException

startElement

public void startElement(String uri,
                         String loc,
                         String raw,
                         Attributes attrs)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Overrides:
startElement in class DefaultHandler
Throws:
SAXException

endElement

public void endElement(String arg0,
                       String arg1,
                       String arg2)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Overrides:
endElement in class DefaultHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String arg0,
                               String arg1)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Overrides:
startPrefixMapping in class DefaultHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String arg0)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Overrides:
endPrefixMapping in class DefaultHandler
Throws:
SAXException

characters

public void characters(char[] arg0,
                       int arg1,
                       int arg2)
                throws SAXException
Specified by:
characters in interface ContentHandler
Overrides:
characters in class DefaultHandler
Throws:
SAXException

ignorableWhitespace

public void ignorableWhitespace(char[] arg0,
                                int arg1,
                                int arg2)
                         throws SAXException
Specified by:
ignorableWhitespace in interface ContentHandler
Overrides:
ignorableWhitespace in class DefaultHandler
Throws:
SAXException

processingInstruction

public void processingInstruction(String arg0,
                                  String arg1)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Overrides:
processingInstruction in class DefaultHandler
Throws:
SAXException

skippedEntity

public void skippedEntity(String arg0)
                   throws SAXException
Specified by:
skippedEntity in interface ContentHandler
Overrides:
skippedEntity in class DefaultHandler
Throws:
SAXException

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
Specified by:
resolveEntity in interface EntityResolver
Overrides:
resolveEntity in class DefaultHandler

warning

public void warning(SAXParseException exception)
Specified by:
warning in interface ErrorHandler
Overrides:
warning in class DefaultHandler

error

public void error(SAXParseException exception)
           throws SAXException
Specified by:
error in interface ErrorHandler
Overrides:
error in class DefaultHandler
Throws:
SAXException

fatalError

public void fatalError(SAXParseException exception)
                throws SAXException
Specified by:
fatalError in interface ErrorHandler
Overrides:
fatalError in class DefaultHandler
Throws:
SAXException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EnumTypeConverter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class EnumTypeConverter

java.lang.Object
    extended by  ognl.DefaultTypeConverter
        extended by  com.opensymphony.xwork2.util.EnumTypeConverter
All Implemented Interfaces:
ognl.TypeConverter
public class EnumTypeConverter
extends ognl.DefaultTypeConverter

EnumTypeConverter This class converts java 5 enums to String and from String[] to enum.

One of Java 5's improvements is providing enumeration facility.
Up to now, there existed no enumerations. The only way to simulate was the so-called int Enum pattern:
{code}
public static final int SEASON_WINTER = 0;
public static final int SEASON_SPRING = 1;
public static final int SEASON_SUMMER = 2;
public static final int SEASON_FALL   = 3;
{code}

Java 5.0 now provides the following construct:
{code}
public static enum Season { WINTER, SPRING, SUMMER, FALL };
{code}

h3. Implementing Java 5 Enumeration Type Conversion

1. myAction-conversion.properties*

Place a myAction-conversion.properties-file in the path of your Action.
Add the following entry to the properties-file:
{code}
nameOfYourField=fullyClassifiedNameOfYourConverter
{code}

2. myAction.java*
Your action contains the _enumeration_:
{code}
public enum Criticality {DEBUG, INFO, WARNING, ERROR, FATAL}
{code}

* Your action contains the _private field_:
{code}
private myEnum myFieldForEnum;
{code}

Your action contains _getters and setters_ for your field:
{code}
public myEnum getCriticality() {
        return myFieldForEnum;
    }

    public void setCriticality(myEnum myFieldForEnum) {
        this.myFieldForEnum= myFieldForEnum;
    }
{code}

3. JSP*

In your jsp you can access an enumeration value just normal by using the known -Tag: {code} {code}

Version:
$Id: EnumTypeConverter.java 1050 2006-06-26 21:46:27 +0200 (Mon, 26 Jun 2006) rainerh $
Author:
Tamara Cattivelli, Rainer Hermanns

Constructor Summary
EnumTypeConverter()
Method Summary
Enum | convertFromString(String value, Class toClass) Converts one or more String values to the specified class.
Object | convertValue(Map context, Object o, Class toClass) Converts the given object to a given type.
Methods inherited from class ognl.DefaultTypeConverter
convertValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EnumTypeConverter

public EnumTypeConverter()
Method Detail

convertValue

public Object convertValue(Map context,
                           Object o,
                           Class toClass)
Converts the given object to a given type. How this is to be done is implemented in toClass. The OGNL context, o and toClass are given. This method should be able to handle conversion in general without any context or object specified.

Overrides:
convertValue in class ognl.DefaultTypeConverter
Parameters:
context - - OGNL context under which the conversion is being done
o - - the object to be converted
toClass - - the class that contains the code to convert to enumeration
Returns:
Converted value of type declared in toClass or TypeConverter.NoConversionPossible to indicate that the conversion was not possible.

convertFromString

public Enum convertFromString(String value,
                              Class toClass)
Converts one or more String values to the specified class.

Parameters:
value - - the String values to be converted, such as those submitted from an HTML form
toClass - - the class to convert to
Returns:
the converted object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileManager (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class FileManager

java.lang.Object
    extended by  com.opensymphony.xwork2.util.FileManager

public class FileManager
extends Object

FileManager This class was brought in from oscore trunk revision 147.

Author:
Jason Carreira Created May 7, 2003 8:44:26 PM

Nested Class Summary
private static class FileManager.FileRevision
Field Summary
private static Map | files
protected static boolean | reloadingConfigs
Constructor Summary
private FileManager()
Method Summary
static boolean | fileNeedsReloading(String fileName)
static boolean | isReloadingConfigs()
static InputStream | loadFile(String fileName, Class clazz) Loads opens the named file and returns the InputStream
static InputStream | loadFile(URL fileUrl) Loads opens the named file and returns the InputStream
static void | setReloadingConfigs(boolean reloadingConfigs)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

files

private static Map files

reloadingConfigs

protected static boolean reloadingConfigs
Constructor Detail

FileManager

private FileManager()
Method Detail

setReloadingConfigs

public static void setReloadingConfigs(boolean reloadingConfigs)

isReloadingConfigs

public static boolean isReloadingConfigs()

fileNeedsReloading

public static boolean fileNeedsReloading(String fileName)

loadFile

public static InputStream loadFile(String fileName,
                                   Class clazz)
Loads opens the named file and returns the InputStream

Parameters:
fileName - - the name of the file to open
Returns:
an InputStream of the file contents or null
Throws:
IllegalArgumentException - if there is no file with the given file name

loadFile

public static InputStream loadFile(URL fileUrl)
Loads opens the named file and returns the InputStream

Parameters:
fileUrl - - the URL of the file to open
Returns:
an InputStream of the file contents or null
Throws:
IllegalArgumentException - if there is no file with the given file name
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileManager.FileRevision (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class FileManager.FileRevision

java.lang.Object
    extended by  com.opensymphony.xwork2.util.FileManager.FileRevision
Enclosing class:
FileManager
private static class FileManager.FileRevision
extends Object

Field Summary
private File | file
private long | lastModified
Constructor Summary
FileManager.FileRevision()
FileManager.FileRevision(File file, long lastUpdated)
Method Summary
File | getFile()
long | getLastModified()
void | setLastModified(long lastModified)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

file

private File file

lastModified

private long lastModified
Constructor Detail

FileManager.FileRevision

public FileManager.FileRevision()

FileManager.FileRevision

public FileManager.FileRevision(File file,
                                long lastUpdated)
Method Detail

getFile

public File getFile()

setLastModified

public void setLastModified(long lastModified)

getLastModified

public long getLastModified()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GenericsObjectTypeDeterminer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class GenericsObjectTypeDeterminer

java.lang.Object
    extended by  com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer
        extended by  com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
All Implemented Interfaces:
ObjectTypeDeterminer
public class GenericsObjectTypeDeterminer
extends DefaultObjectTypeDeterminer

GenericsObjectTypeDeterminer

Author:
Patrick Lightbody, Rainer Hermanns, Alexandru Popescu

Field Summary
Fields inherited from class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer
CREATE_IF_NULL_PREFIX, DEPRECATED_ELEMENT_PREFIX, ELEMENT_PREFIX, KEY_PREFIX, KEY_PROPERTY_PREFIX, LOG
Constructor Summary
GenericsObjectTypeDeterminer()
Method Summary
protected
<T extends Annotation>
T
getAnnotation(Class parentClass, String property, Class<T> annotationClass)
Retrieves an annotation for the specified property of field, setter or getter.
private
<T extends Annotation>
T
getAnnotationFromGetter(Class parentClass, String property, Class<T> annotationClass)
Retrieves an annotation for the specified field of getter.
private
<T extends Annotation>
T
getAnnotationFromSetter(Class parentClass, String property, Class<T> annotationClass)
Retrieves an annotation for the specified field of setter.
private  Class getClass(Class parentClass, String property, boolean element)
Returns the class for the given field via generic type check.
 Class getElementClass(Class parentClass, String property, Object key)
Determines the element class by looking for the value of @Element annotation for the given class.
 Class getKeyClass(Class parentClass, String property)
Determines the key class by looking for the value of @Key annotation for the given class.
 String getKeyProperty(Class parentClass, String property)
Determines the key property for a Collection by getting it from the @KeyProperty annotation.
 boolean shouldCreateIfNew(Class parentClass, String property, Object target, String keyProperty, boolean isIndexAccessed)
Determines the createIfNull property for a Collection or Map by getting it from the @CreateIfNull annotation.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

GenericsObjectTypeDeterminer

public GenericsObjectTypeDeterminer()
Method Detail

getKeyClass

public Class getKeyClass(Class parentClass,
                         String property)
Determines the key class by looking for the value of @Key annotation for the given class. If no annotation is found, the key class is determined by using the generic parametrics.

Specified by:
getKeyClass in interface ObjectTypeDeterminer
Overrides:
getKeyClass in class DefaultObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
See Also:
ObjectTypeDeterminer.getKeyClass(Class, String)

getElementClass

public Class getElementClass(Class parentClass,
                             String property,
                             Object key)
Determines the element class by looking for the value of @Element annotation for the given class. If no annotation is found, the element class is determined by using the generic parametrics.

Specified by:
getElementClass in interface ObjectTypeDeterminer
Overrides:
getElementClass in class DefaultObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
See Also:
ObjectTypeDeterminer.getElementClass(Class, String, Object)

getKeyProperty

public String getKeyProperty(Class parentClass,
                             String property)
Determines the key property for a Collection by getting it from the @KeyProperty annotation.

Specified by:
getKeyProperty in interface ObjectTypeDeterminer
Overrides:
getKeyProperty in class DefaultObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
See Also:
ObjectTypeDeterminer.getKeyProperty(Class, String)

shouldCreateIfNew

public boolean shouldCreateIfNew(Class parentClass,
                                 String property,
                                 Object target,
                                 String keyProperty,
                                 boolean isIndexAccessed)
Determines the createIfNull property for a Collection or Map by getting it from the @CreateIfNull annotation.

Specified by:
shouldCreateIfNew in interface ObjectTypeDeterminer
Overrides:
shouldCreateIfNew in class DefaultObjectTypeDeterminer
Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
target -
keyProperty -
isIndexAccessed - true, if the collection or map is accessed via index, false otherwise.
Returns:
true, if the Collection or Map should be created, false otherwise.
See Also:
ObjectTypeDeterminer.getKeyProperty(Class, String)

getAnnotation

protected <T extends Annotation> T getAnnotation(Class parentClass,
                                                 String property,
                                                 Class<T> annotationClass)
Retrieves an annotation for the specified property of field, setter or getter.

Type Parameters:
T - the annotation type to be retrieved
Parameters:
parentClass - the class
property - the property
annotationClass - the annotation
Returns:
the field or setter/getter annotation or null if not found

getAnnotationFromGetter

private <T extends Annotation> T getAnnotationFromGetter(Class parentClass,
                                                         String property,
                                                         Class<T> annotationClass)
Retrieves an annotation for the specified field of getter.

Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
annotationClass - The annotation
Returns:
concrete Annotation instance or null if none could be retrieved.

getAnnotationFromSetter

private <T extends Annotation> T getAnnotationFromSetter(Class parentClass,
                                                         String property,
                                                         Class<T> annotationClass)
Retrieves an annotation for the specified field of setter.

Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
annotationClass - The annotation
Returns:
concrete Annotation instance or null if none could be retrieved.

getClass

private Class getClass(Class parentClass,
                       String property,
                       boolean element)
Returns the class for the given field via generic type check.

Parameters:
parentClass - the Class which contains as a property the Map or Collection we are finding the key for.
property - the property of the Map or Collection for the given parent class
element - true for indexed types and Maps.
Returns:
Class of the specified field.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InstantiatingNullHandler (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class InstantiatingNullHandler

java.lang.Object
    extended by  com.opensymphony.xwork2.util.InstantiatingNullHandler
All Implemented Interfaces:
ognl.NullHandler
public class InstantiatingNullHandler
extends Object
implements ognl.NullHandler

Provided that the key CREATE_NULL_OBJECTS is in the action context with a value of true (this key is set only during the execution of the ParametersInterceptor), OGNL expressions that have caused a NullPointerException will be temporarily stopped for evaluation while the system automatically tries to solve the null references by automatically creating the object.

The following rules are used when handling null references:

  • If the property is declared exactly as a Collection or List, then an ArrayList shall be returned and assigned to the null references.
  • If the property is declared as a Map, then a HashMap will be returned and assigned to the null references.
  • If the null property is a simple bean with a no-arg constructor, it will simply be created using the ObjectFactory.buildBean(java.lang.Class, java.util.Map) method.
For example, if a form element has a text field named person.name and the expression person evaluates to null, then this class will be invoked. Because the person expression evaluates to a Person class, a new Person is created and assigned to the null reference. Finally, the name is set on that object and the overall effect is that the system automatically created a Person object for you, set it by calling setUsers() and then finally called getUsers().setName() as you would typically expect.
Field Summary
static String | CREATE_NULL_OBJECTS
private static Log | LOG
Constructor Summary
InstantiatingNullHandler()
Method Summary
private Object | createObject(Class clazz, Object target, String property, Map context)
Object | nullMethodResult(Map context, Object target, String methodName, Object[] args)
Object | nullPropertyValue(Map context, Object target, Object property)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CREATE_NULL_OBJECTS

public static final String CREATE_NULL_OBJECTS
See Also:
Constant Field Values

LOG

private static final Log LOG
Constructor Detail

InstantiatingNullHandler

public InstantiatingNullHandler()
Method Detail

nullMethodResult

public Object nullMethodResult(Map context,
                               Object target,
                               String methodName,
                               Object[] args)
Specified by:
nullMethodResult in interface ognl.NullHandler

nullPropertyValue

public Object nullPropertyValue(Map context,
                                Object target,
                                Object property)
Specified by:
nullPropertyValue in interface ognl.NullHandler

createObject

private Object createObject(Class clazz,
                            Object target,
                            String property,
                            Map context)
                     throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocalizedTextUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class LocalizedTextUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.util.LocalizedTextUtil

public class LocalizedTextUtil
extends Object

Provides support for localization in XWork. Resource bundles are searched in the following order:

  1. ActionClass.properties
  2. BaseClass.properties (all the way to Object.properties)
  3. Interface.properties (every interface and sub-interface)
  4. ModelDriven's model (if implements ModelDriven), for the model object repeat from 1
  5. package.properties (of the directory where class is located and every parent directory all the way to the root directory)
  6. search up the i18n message key hierarchy itself
  7. global resource properties

To clarify #5, while traversing the package hierarchy, WW will look for a file package.properties:

com/
acme/
package.properties
actions/
package.properties
FooAction.java
FooAction.properties

If FooAction.properties does not exist, com/acme/action/package.properties will be searched for, if not found com/acme/package.properties, if not found com/package.properties, etc.

A global resource bundle could be specified programatically, as well as the locale.

Version:
$Date: 2006-11-17 09:25:48 +0100 (Fr, 17 Nov 2006) $ $Id: LocalizedTextUtil.java 1210 2006-11-17 08:25:48Z mrdon $
Author:
Jason Carreira, Mark Woon, Rainer Hermanns, tm_jee

Nested Class Summary
(package private) static class | LocalizedTextUtil.GetDefaultMessageReturnArg
(package private) static class | LocalizedTextUtil.MessageFormatKey
Field Summary
private static Log | _log
private static List | DEFAULT_RESOURCE_BUNDLES
private static Log | LOG
private static Map | messageFormats
private static Collection | misses
private static boolean | reloadBundles
Constructor Summary
LocalizedTextUtil()
Method Summary
static void addDefaultResourceBundle(String resourceBundleName)
Add's the bundle to the internal list of default bundles.
private static MessageFormat buildMessageFormat(String pattern, Locale locale)
static void clearDefaultResourceBundles()
Clears the internal list of resource bundles.
private static void clearMap(Class cl, Object obj, String name)
private static void clearTomcatCache()
static String findDefaultText(String aTextName, Locale locale)
Returns a localized message for the specified key, aTextName.
static String findDefaultText(String aTextName, Locale locale, Object[] params)
Returns a localized message for the specified key, aTextName, substituting variables from the array of params into the message.
private static String findMessage(Class clazz, String key, String indexedKey, Locale locale, Object[] args, Set checked, ValueStack valueStack)
Traverse up class hierarchy looking for message.
static ResourceBundle findResourceBundle(String aBundleName, Locale locale)
Finds the given resorce bundle by it's name.
static String findText(Class aClass, String aTextName, Locale locale)
Calls findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args) with aTextName as the default message.
static String findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args)
Finds a localized text message for the given key, aTextName.
static String findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args, ValueStack valueStack)
Finds a localized text message for the given key, aTextName.
static String findText(ResourceBundle bundle, String aTextName, Locale locale)
Finds a localized text message for the given key, aTextName, in the specified resource bundle with aTextName as the default message.
static String findText(ResourceBundle bundle, String aTextName, Locale locale, String defaultMessage, Object[] args)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
static String findText(ResourceBundle bundle, String aTextName, Locale locale, String defaultMessage, Object[] args, ValueStack valueStack)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
private static LocalizedTextUtil.GetDefaultMessageReturnArg getDefaultMessage(String key, Locale locale, ValueStack valueStack, Object[] args, String defaultMessage)
Gets the default message.
private static String getMessage(String bundleName, Locale locale, String key, ValueStack valueStack, Object[] args)
Gets the message from the named resource bundle.
static Locale localeFromString(String localeStr, Locale defaultLocale)
Builds a Locale from a String of the form en_US_foo into a Locale with language "en", country "US" and variant "foo".
private static void reloadBundles()
static void reset()
Clears all the internal lists.
static void setReloadBundles(boolean reloadBundles)
Should resorce bundles be reloaded.
private static boolean unableToFindTextForKey(LocalizedTextUtil.GetDefaultMessageReturnArg result)
Determines if we found the text in the bundles.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

DEFAULT_RESOURCE_BUNDLES

private static List DEFAULT_RESOURCE_BUNDLES

LOG

private static final Log LOG

reloadBundles

private static boolean reloadBundles

misses

private static final Collection misses

messageFormats

private static final Map messageFormats
Constructor Detail

LocalizedTextUtil

public LocalizedTextUtil()
Method Detail

clearDefaultResourceBundles

public static void clearDefaultResourceBundles()
Clears the internal list of resource bundles.

setReloadBundles

public static void setReloadBundles(boolean reloadBundles)
Should resorce bundles be reloaded.

Parameters:
reloadBundles - reload bundles?

addDefaultResourceBundle

public static void addDefaultResourceBundle(String resourceBundleName)
Add's the bundle to the internal list of default bundles.

If the bundle already exists in the list it will be readded.

Parameters:
resourceBundleName - the name of the bundle to add.

localeFromString

public static Locale localeFromString(String localeStr,
                                      Locale defaultLocale)
Builds a Locale from a String of the form en_US_foo into a Locale with language "en", country "US" and variant "foo". This will parse the output of Locale.toString().

Parameters:
localeStr - The locale String to parse.
defaultLocale - The locale to use if localeStr is null.
Returns:
requested Locale

findDefaultText

public static String findDefaultText(String aTextName,
                                     Locale locale)
Returns a localized message for the specified key, aTextName. Neither the key nor the message is evaluated.

Parameters:
aTextName - the message key
locale - the locale the message should be for
Returns:
a localized message based on the specified key, or null if no localized message can be found for it

findDefaultText

public static String findDefaultText(String aTextName,
                                     Locale locale,
                                     Object[] params)
Returns a localized message for the specified key, aTextName, substituting variables from the array of params into the message. Neither the key nor the message is evaluated.

Parameters:
aTextName - the message key
locale - the locale the message should be for
params - an array of objects to be substituted into the message text
Returns:
A formatted message based on the specified key, or null if no localized message can be found for it

findResourceBundle

public static ResourceBundle findResourceBundle(String aBundleName,
                                                Locale locale)
Finds the given resorce bundle by it's name.

Will use Thread.currentThread().getContextClassLoader() as the classloader.

Parameters:
aBundleName - the name of the bundle (usually it's FQN classname).
locale - the locale.
Returns:
the bundle, null if not found.

findText

public static String findText(Class aClass,
                              String aTextName,
                              Locale locale)
Calls findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args) with aTextName as the default message.

See Also:
findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args)

findText

public static String findText(Class aClass,
                              String aTextName,
                              Locale locale,
                              String defaultMessage,
                              Object[] args)
Finds a localized text message for the given key, aTextName. Both the key and the message itself is evaluated as required. The following algorithm is used to find the requested message:

  1. Look for message in aClass' class hierarchy.
    1. Look for the message in a resource bundle for aClass
    2. If not found, look for the message in a resource bundle for any implemented interface
    3. If not found, traverse up the Class' hierarchy and repeat from the first sub-step
  2. If not found and aClass is a ModelDriven Action, then look for message in the model's class hierarchy (repeat sub-steps listed above).
  3. If not found, look for message in child property. This is determined by evaluating the message key as an OGNL expression. For example, if the key is user.address.state, then it will attempt to see if "user" can be resolved into an object. If so, repeat the entire process fromthe beginning with the object's class as aClass and "address.state" as the message key.
  4. If not found, look for the message in aClass' package hierarchy.
  5. If still not found, look for the message in the default resource bundles.
  6. Return defaultMessage

When looking for the message, if the key indexes a collection (e.g. user.phone[0]) and a message for that specific key cannot be found, the general form will also be looked up (i.e. user.phone[*]).

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

Parameters:
aClass - the class whose name to use as the start point for the search
aTextName - the key to find the text message for
locale - the locale the message should be for
defaultMessage - the message to be returned if no text message can be found in any resource bundle
Returns:
the localized text, or null if none can be found and no defaultMessage is provided

findText

public static String findText(Class aClass,
                              String aTextName,
                              Locale locale,
                              String defaultMessage,
                              Object[] args,
                              ValueStack valueStack)
Finds a localized text message for the given key, aTextName. Both the key and the message itself is evaluated as required. The following algorithm is used to find the requested message:

  1. Look for message in aClass' class hierarchy.
    1. Look for the message in a resource bundle for aClass
    2. If not found, look for the message in a resource bundle for any implemented interface
    3. If not found, traverse up the Class' hierarchy and repeat from the first sub-step
  2. If not found and aClass is a ModelDriven Action, then look for message in the model's class hierarchy (repeat sub-steps listed above).
  3. If not found, look for message in child property. This is determined by evaluating the message key as an OGNL expression. For example, if the key is user.address.state, then it will attempt to see if "user" can be resolved into an object. If so, repeat the entire process fromthe beginning with the object's class as aClass and "address.state" as the message key.
  4. If not found, look for the message in aClass' package hierarchy.
  5. If still not found, look for the message in the default resource bundles.
  6. Return defaultMessage

When looking for the message, if the key indexes a collection (e.g. user.phone[0]) and a message for that specific key cannot be found, the general form will also be looked up (i.e. user.phone[*]).

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

If a message is not found a WARN log will be logged.

Parameters:
aClass - the class whose name to use as the start point for the search
aTextName - the key to find the text message for
locale - the locale the message should be for
defaultMessage - the message to be returned if no text message can be found in any resource bundle
valueStack - the value stack to use to evaluate expressions instead of the one in the ActionContext ThreadLocal
Returns:
the localized text, or null if none can be found and no defaultMessage is provided

unableToFindTextForKey

private static boolean unableToFindTextForKey(LocalizedTextUtil.GetDefaultMessageReturnArg result)
Determines if we found the text in the bundles.

Parameters:
result - the result so far
locale - the locale
key1 - the first key used for lookup
key2 - the second key (indexed) used for kookup
defaultMessage - the provided default message
Returns:
true if we could not find the text, false if the text was found (=success).

findText

public static String findText(ResourceBundle bundle,
                              String aTextName,
                              Locale locale)
Finds a localized text message for the given key, aTextName, in the specified resource bundle with aTextName as the default message.

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

See Also:
findText(java.util.ResourceBundle, String, java.util.Locale, String, Object[])

findText

public static String findText(ResourceBundle bundle,
                              String aTextName,
                              Locale locale,
                              String defaultMessage,
                              Object[] args)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

If a message is not found a WARN log will be logged.

Parameters:
bundle - the bundle
aTextName - the key
locale - the locale
defaultMessage - the default message to use if no message was found in the bundle
args - arguments for the message formatter.

findText

public static String findText(ResourceBundle bundle,
                              String aTextName,
                              Locale locale,
                              String defaultMessage,
                              Object[] args,
                              ValueStack valueStack)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.

If a message is found, it will also be interpolated. Anything within ${...} will be treated as an OGNL expression and evaluated as such.

If a message is not found a WARN log will be logged.

Parameters:
bundle - the bundle
aTextName - the key
locale - the locale
defaultMessage - the default message to use if no message was found in the bundle
args - arguments for the message formatter.
valueStack - the OGNL value stack.

getDefaultMessage

private static LocalizedTextUtil.GetDefaultMessageReturnArg getDefaultMessage(String key,
                                                                              Locale locale,
                                                                              ValueStack valueStack,
                                                                              Object[] args,
                                                                              String defaultMessage)
Gets the default message.

getMessage

private static String getMessage(String bundleName,
                                 Locale locale,
                                 String key,
                                 ValueStack valueStack,
                                 Object[] args)
Gets the message from the named resource bundle.

buildMessageFormat

private static MessageFormat buildMessageFormat(String pattern,
                                                Locale locale)

findMessage

private static String findMessage(Class clazz,
                                  String key,
                                  String indexedKey,
                                  Locale locale,
                                  Object[] args,
                                  Set checked,
                                  ValueStack valueStack)
Traverse up class hierarchy looking for message. Looks at class, then implemented interface, before going up hierarchy.

reloadBundles

private static void reloadBundles()

clearTomcatCache

private static void clearTomcatCache()

clearMap

private static void clearMap(Class cl,
                             Object obj,
                             String name)
                      throws NoSuchFieldException,
                             IllegalAccessException,
                             NoSuchMethodException,
                             InvocationTargetException
Throws:
NoSuchFieldException
IllegalAccessException
NoSuchMethodException
InvocationTargetException

reset

public static void reset()
Clears all the internal lists.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocalizedTextUtil.GetDefaultMessageReturnArg (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class LocalizedTextUtil.GetDefaultMessageReturnArg

java.lang.Object
    extended by  com.opensymphony.xwork2.util.LocalizedTextUtil.GetDefaultMessageReturnArg
Enclosing class:
LocalizedTextUtil
static class LocalizedTextUtil.GetDefaultMessageReturnArg
extends Object

Field Summary
(package private) boolean | foundInBundle
(package private) String | message
Constructor Summary
LocalizedTextUtil.GetDefaultMessageReturnArg(String message, boolean foundInBundle)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

message

String message

foundInBundle

boolean foundInBundle
Constructor Detail

LocalizedTextUtil.GetDefaultMessageReturnArg

public LocalizedTextUtil.GetDefaultMessageReturnArg(String message,
                                                    boolean foundInBundle)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocalizedTextUtil.MessageFormatKey (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class LocalizedTextUtil.MessageFormatKey

java.lang.Object
    extended by  com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey
Enclosing class:
LocalizedTextUtil
static class LocalizedTextUtil.MessageFormatKey
extends Object

Field Summary
(package private) Locale | locale
(package private) String | pattern
Constructor Summary
LocalizedTextUtil.MessageFormatKey(String pattern, Locale locale)
Method Summary
boolean | equals(Object o)
int | hashCode()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

Field Detail

pattern

String pattern

locale

Locale locale
Constructor Detail

LocalizedTextUtil.MessageFormatKey

LocalizedTextUtil.MessageFormatKey(String pattern,
                                   Locale locale)
Method Detail

equals

public boolean equals(Object o)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ObjectProxy

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ObjectProxy

public class ObjectProxy
extends Object

An Object to use within OGNL to proxy other Objects usually Collections that you set in a different place on the ValueStack but want to retain the context information about where they previously were.

Author:
Gabe

Field Summary
private Class | lastClassAccessed
private String | lastPropertyAccessed
private Object | value
Constructor Summary
ObjectProxy()
Method Summary
Class | getLastClassAccessed()
String | getLastPropertyAccessed()
Object | getValue()
void | setLastClassAccessed(Class lastClassAccessed)
void | setLastPropertyAccessed(String lastPropertyAccessed)
void | setValue(Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

private Object value

lastClassAccessed

private Class lastClassAccessed

lastPropertyAccessed

private String lastPropertyAccessed
Constructor Detail

ObjectProxy

public ObjectProxy()
Method Detail

getLastClassAccessed

public Class getLastClassAccessed()

setLastClassAccessed

public void setLastClassAccessed(Class lastClassAccessed)

getLastPropertyAccessed

public String getLastPropertyAccessed()

setLastPropertyAccessed

public void setLastPropertyAccessed(String lastPropertyAccessed)

getValue

public Object getValue()

setValue

public void setValue(Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectProxyPropertyAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ObjectProxyPropertyAccessor

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class ObjectProxyPropertyAccessor
extends Object
implements ognl.PropertyAccessor

Is able to access (set/get) properties on a given object.

Uses Ognl internal.

Author:
Gabe

Constructor Summary
ObjectProxyPropertyAccessor()
Method Summary
Object | getProperty(Map context, Object target, Object name)
void | setProperty(Map context, Object target, Object name, Object value)
private void | setupContext(Map context, ObjectProxy proxy) Sets up the context with the last property and last class accessed.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectProxyPropertyAccessor

public ObjectProxyPropertyAccessor()
Method Detail

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object name)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Throws:
ognl.OgnlException

setupContext

private void setupContext(Map context,
                          ObjectProxy proxy)
Sets up the context with the last property and last class accessed.

Parameters:
context -
proxy -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ObjectTypeDeterminerFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ObjectTypeDeterminerFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory

public class ObjectTypeDeterminerFactory
extends Object

Factory for getting an instance of ObjectTypeDeterminer.
Will use com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer if running on JDK5 or higher. If not com.opensymphony.xwork2.util.ObjectTypeDeterminer is used.

Author:
plightbo, Rainer Hermanns

Field Summary
private static ObjectTypeDeterminer | instance
private static Log | LOG
Constructor Summary
ObjectTypeDeterminerFactory()
Method Summary
static ObjectTypeDeterminer | getInstance()
static void | setInstance(ObjectTypeDeterminer instance)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

instance

private static ObjectTypeDeterminer instance
Constructor Detail

ObjectTypeDeterminerFactory

public ObjectTypeDeterminerFactory()
Method Detail

setInstance

public static void setInstance(ObjectTypeDeterminer instance)

getInstance

public static ObjectTypeDeterminer getInstance()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlContextState (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class OgnlContextState

java.lang.Object
    extended by  com.opensymphony.xwork2.util.OgnlContextState

public class OgnlContextState
extends Object

Manages variables in the OgnlContext and returns values to be used by the application.

Author:
Gabe

Field Summary
static String | CURRENT_PROPERTY_PATH
static String | FULL_PROPERTY_PATH
private static String | GETTING_BY_KEY_PROPERTY
private static String | SET_MAP_KEY
Constructor Summary
OgnlContextState()
Method Summary
static void | clear(Map context)
static void | clearCurrentPropertyPath(Map context)
private static boolean | getBooleanProperty(String property, Map context)
static String | getCurrentPropertyPath(Map context) Gets the current property path but not completely.
static String | getFullPropertyPath(Map context)
static Class | getLastBeanClassAccessed(Map context)
static String | getLastBeanPropertyAccessed(Map context)
static Map | getSetMap(Map context, String path)
static boolean | isCreatingNullObjects(Map context)
static boolean | isDenyMethodExecution(Map context)
static boolean | isGettingByKeyProperty(Map context)
static boolean | isReportingConversionErrors(Map context)
private static void | setBooleanValue(String property, Map context, boolean value)
static void | setCreatingNullObjects(Map context, boolean creatingNullObjects)
static void | setDenyMethodExecution(Map context, boolean denyMethodExecution)
static void | setFullPropertyPath(Map context, String path)
static void | setGettingByKeyProperty(Map context, boolean gettingByKeyProperty)
static void | setLastBeanClassAccessed(Map context, Class clazz)
static void | setLastBeanPropertyAccessed(Map context, String property)
static void | setReportingConversionErrors(Map context, boolean reportingErrors)
static void | setSetMap(Map context, Map setMap, String path)
static void | updateCurrentPropertyPath(Map context, Object name)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

CURRENT_PROPERTY_PATH

public static final String CURRENT_PROPERTY_PATH
See Also:
Constant Field Values

FULL_PROPERTY_PATH

public static final String FULL_PROPERTY_PATH
See Also:
Constant Field Values

GETTING_BY_KEY_PROPERTY

private static final String GETTING_BY_KEY_PROPERTY
See Also:
Constant Field Values

SET_MAP_KEY

private static final String SET_MAP_KEY
See Also:
Constant Field Values
Constructor Detail

OgnlContextState

public OgnlContextState()
Method Detail

isCreatingNullObjects

public static boolean isCreatingNullObjects(Map context)

setCreatingNullObjects

public static void setCreatingNullObjects(Map context,
                                          boolean creatingNullObjects)

isGettingByKeyProperty

public static boolean isGettingByKeyProperty(Map context)

setDenyMethodExecution

public static void setDenyMethodExecution(Map context,
                                          boolean denyMethodExecution)

isDenyMethodExecution

public static boolean isDenyMethodExecution(Map context)

setGettingByKeyProperty

public static void setGettingByKeyProperty(Map context,
                                           boolean gettingByKeyProperty)

isReportingConversionErrors

public static boolean isReportingConversionErrors(Map context)

setReportingConversionErrors

public static void setReportingConversionErrors(Map context,
                                                boolean reportingErrors)

getLastBeanClassAccessed

public static Class getLastBeanClassAccessed(Map context)

setLastBeanPropertyAccessed

public static void setLastBeanPropertyAccessed(Map context,
                                               String property)

getLastBeanPropertyAccessed

public static String getLastBeanPropertyAccessed(Map context)

setLastBeanClassAccessed

public static void setLastBeanClassAccessed(Map context,
                                            Class clazz)

getCurrentPropertyPath

public static String getCurrentPropertyPath(Map context)
Gets the current property path but not completely. It does not use the [ and ] used in some representations of Maps and Lists. The reason for this is that the current property path is only currently used for caching purposes so there is no real reason to have an exact replica.

So if the real path is myProp.myMap['myKey'] this would return myProp.myMap.myKey.

Parameters:
context -

getFullPropertyPath

public static String getFullPropertyPath(Map context)

setFullPropertyPath

public static void setFullPropertyPath(Map context,
                                       String path)

updateCurrentPropertyPath

public static void updateCurrentPropertyPath(Map context,
                                             Object name)

setSetMap

public static void setSetMap(Map context,
                             Map setMap,
                             String path)

getSetMap

public static Map getSetMap(Map context,
                            String path)

getBooleanProperty

private static boolean getBooleanProperty(String property,
                                          Map context)

setBooleanValue

private static void setBooleanValue(String property,
                                    Map context,
                                    boolean value)

clearCurrentPropertyPath

public static void clearCurrentPropertyPath(Map context)

clear

public static void clear(Map context)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class OgnlUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.util.OgnlUtil

public class OgnlUtil
extends Object

Utility class that provides common access to the Ognl APIs for setting and getting properties from objects (usually Actions).

Author:
Jason Carreira

Field Summary
private static HashMap | beanInfoCache
private static HashMap | expressions
private static Log | log
Constructor Summary
OgnlUtil()
Method Summary
static Object compile(String expression)
static void copy(Object from, Object to, Map context)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
static void copy(Object from, Object to, Map context, Collection exclusions, Collection inclusions)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
static BeanInfo getBeanInfo(Object from)
Get's the java bean info for the given source.
static Map getBeanMap(Object source)
Creates a Map with read properties for the given source object.
static PropertyDescriptor[] getPropertyDescriptors(Object source)
Get's the java beans property descriptors for the given source.
static Object getRealTarget(String property, Map context, Object root)
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.
static Object getValue(String name, Map context, Object root)
static Object getValue(String name, Map context, Object root, Class resultType)
(package private) static void internalSetProperty(String name, Object value, Object o, Map context, boolean throwPropertyExceptions)
static void setProperties(Map properties, Object o)
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.
static void setProperties(Map properties, Object o, boolean throwPropertyExceptions)
Sets the properties on the object using the default context.
static void setProperties(Map props, Object o, Map context)
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.
static void setProperties(Map props, Object o, Map context, boolean throwPropertyExceptions)
Sets the object's properties using the default type converter.
static void setProperty(String name, Object value, Object o, Map context)
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.
static void setProperty(String name, Object value, Object o, Map context, boolean throwPropertyExceptions)
Sets the named property to the supplied value on the Object.
static void setValue(String name, Map context, Object root, Object value)
Wrapper around Ognl.setValue() to handle type conversion for collection elements.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

expressions

private static HashMap expressions

beanInfoCache

private static HashMap beanInfoCache
Constructor Detail

OgnlUtil

public OgnlUtil()
Method Detail

setProperties

public static void setProperties(Map props,
                                 Object o,
                                 Map context)
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.

Parameters:
props - the properties being set
o - the object
context - the action context

setProperties

public static void setProperties(Map props,
                                 Object o,
                                 Map context,
                                 boolean throwPropertyExceptions)
Sets the object's properties using the default type converter.

Parameters:
props - the properties being set
o - the object
context - the action context
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the properties

setProperties

public static void setProperties(Map properties,
                                 Object o)
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.

Parameters:
properties -
o -

setProperties

public static void setProperties(Map properties,
                                 Object o,
                                 boolean throwPropertyExceptions)
Sets the properties on the object using the default context.

Parameters:
properties - the property map to set on the object
o - the object to set the properties into
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the properties

setProperty

public static void setProperty(String name,
                               Object value,
                               Object o,
                               Map context)
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.

Parameters:
name - the name of the property to be set
value - the value to set into the named property
o - the object upon which to set the property
context - the context which may include the TypeConverter

setProperty

public static void setProperty(String name,
                               Object value,
                               Object o,
                               Map context,
                               boolean throwPropertyExceptions)
Sets the named property to the supplied value on the Object.

Parameters:
name - the name of the property to be set
value - the value to set into the named property
o - the object upon which to set the property
context - the context which may include the TypeConverter
throwPropertyExceptions - boolean which tells whether it should throw exceptions for problems setting the property

getRealTarget

public static Object getRealTarget(String property,
                                   Map context,
                                   Object root)
                            throws ognl.OgnlException
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.

Returns:
the real target or null if no object can be found with the specified property
Throws:
ognl.OgnlException

setValue

public static void setValue(String name,
                            Map context,
                            Object root,
                            Object value)
                     throws ognl.OgnlException
Wrapper around Ognl.setValue() to handle type conversion for collection elements. Ideally, this should be handled by OGNL directly.

Throws:
ognl.OgnlException

getValue

public static Object getValue(String name,
                              Map context,
                              Object root)
                       throws ognl.OgnlException
Throws:
ognl.OgnlException

getValue

public static Object getValue(String name,
                              Map context,
                              Object root,
                              Class resultType)
                       throws ognl.OgnlException
Throws:
ognl.OgnlException

compile

public static Object compile(String expression)
                      throws ognl.OgnlException
Throws:
ognl.OgnlException

copy

public static void copy(Object from,
                        Object to,
                        Map context,
                        Collection exclusions,
                        Collection inclusions)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.

Parameters:
from - the source object
to - the target object
context - the action context we're running under
exclusions - collection of method names to excluded from copying ( can be null)
inclusions - collection of method names to included copying (can be null) note if exclusions AND inclusions are supplied and not null nothing will get copied.

copy

public static void copy(Object from,
                        Object to,
                        Map context)
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.

Parameters:
from - the source object
to - the target object
context - the action context we're running under

getPropertyDescriptors

public static PropertyDescriptor[] getPropertyDescriptors(Object source)
                                                   throws IntrospectionException
Get's the java beans property descriptors for the given source.

Parameters:
source - the source object.
Returns:
property descriptors.
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.

getBeanMap

public static Map getBeanMap(Object source)
                      throws IntrospectionException,
                             ognl.OgnlException
Creates a Map with read properties for the given source object.

If the source object does not have a read property (i.e. write-only) then the property is added to the map with the value here is no read method for property-name.

Parameters:
source - the source object.
Returns:
a Map with (key = read property name, value = value of read property).
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.
ognl.OgnlException - is thrown by OGNL if the property value could not be retrieved

getBeanInfo

public static BeanInfo getBeanInfo(Object from)
                            throws IntrospectionException
Get's the java bean info for the given source.

Parameters:
from - the source object.
Returns:
java bean info.
Throws:
IntrospectionException - is thrown if an exception occurs during introspection.

internalSetProperty

static void internalSetProperty(String name,
                                Object value,
                                Object o,
                                Map context,
                                boolean throwPropertyExceptions)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlValueStack (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class OgnlValueStack

java.lang.Object
    extended by  com.opensymphony.xwork2.util.OgnlValueStack
All Implemented Interfaces:
ValueStack, Serializable
public class OgnlValueStack
extends Object
implements Serializable, ValueStack

Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it. When evaluating an expression, the stack will be searched down the stack, from the latest objects pushed in to the earliest, looking for a bean with a getter or setter for the given property or a method of the given name (depending on the expression being evaluated).

Version:
$Date: 2006-11-17 20:46:06 +0100 (Fr, 17 Nov 2006) $ $Id: OgnlValueStack.java 1216 2006-11-17 19:46:06Z jmitchell $
Author:
Patrick Lightbody, tm_jee
See Also:
Serialized Form

Nested Class Summary
static class OgnlValueStack.ObjectAccessor
Field Summary
private static CompoundRootAccessor | accessor
(package private) Map | context
(package private) Class | defaultType
private static boolean | devMode
private static Log | LOG
private static String | MAP_IDENTIFIER_KEY
(package private) Map | overrides
(package private) CompoundRoot | root
private static long | serialVersionUID
Fields inherited from interface com.opensymphony.xwork2.util.ValueStack
REPORT_ERRORS_ON_NO_PROP, VALUE_STACK
Constructor Summary
OgnlValueStack()
OgnlValueStack(ValueStack vs)
Method Summary
private  Object findInContext(String name)
 String findString(String expr)
 Object findValue(String expr)
Find a value by evaluating the given expression against the stack in the default search order.
 Object findValue(String expr, Class asType)
Find a value by evaluating the given expression against the stack in the default search order.
static CompoundRootAccessor getAccessor()
 Map getContext()
 Map getExprOverrides()
 CompoundRoot getRoot()
Get the CompoundRoot which holds the objects pushed onto the stack
static void link(Map context, Class clazz, String name)
private  void logLookupFailure(String expr, Exception e)
Log a failed lookup, being more verbose when devMode=true.
 Object peek()
Get the object on the top of the stack without changing the stack.
 Object pop()
Get the object on the top of the stack and remove it from the stack.
 void push(Object o)
Put this object onto the top of the stack
private  Object readResolve()
static void reset()
 void set(String key, Object o)
Sets an object on the stack with the given key so it is retrievable by findValue(key,...)
 void setDefaultType(Class defaultType)
Sets the default type to convert to if no type is provided when getting a value.
static void setDevMode(String mode)
 void setExprOverrides(Map overrides)
private  void setRoot(CompoundRoot compoundRoot)
 void setValue(String expr, Object value)
Attempts to set a property on a bean in the stack with the given expression using the default search order.
 void setValue(String expr, Object value, boolean throwExceptionOnFailure)
Attempts to set a property on a bean in the stack with the given expression using the default search order.
 int size()
Get the number of objects in the stack s
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

accessor

private static CompoundRootAccessor accessor

LOG

private static Log LOG

devMode

private static boolean devMode

root

CompoundRoot root

context

transient Map context

defaultType

Class defaultType

overrides

Map overrides

MAP_IDENTIFIER_KEY

private static final String MAP_IDENTIFIER_KEY
See Also:
Constant Field Values
Constructor Detail

OgnlValueStack

public OgnlValueStack()

OgnlValueStack

public OgnlValueStack(ValueStack vs)
Method Detail

reset

public static void reset()

link

public static void link(Map context,
                        Class clazz,
                        String name)

getAccessor

public static CompoundRootAccessor getAccessor()

setDevMode

public static void setDevMode(String mode)

getContext

public Map getContext()
Specified by:
getContext in interface ValueStack

setDefaultType

public void setDefaultType(Class defaultType)
Description copied from interface: ValueStack
Sets the default type to convert to if no type is provided when getting a value.

Specified by:
setDefaultType in interface ValueStack

setExprOverrides

public void setExprOverrides(Map overrides)
Specified by:
setExprOverrides in interface ValueStack

getExprOverrides

public Map getExprOverrides()
Specified by:
getExprOverrides in interface ValueStack

getRoot

public CompoundRoot getRoot()
Description copied from interface: ValueStack
Get the CompoundRoot which holds the objects pushed onto the stack

Specified by:
getRoot in interface ValueStack

setValue

public void setValue(String expr,
                     Object value)
Description copied from interface: ValueStack
Attempts to set a property on a bean in the stack with the given expression using the default search order.

Specified by:
setValue in interface ValueStack
Parameters:
expr - the expression defining the path to the property to be set.
value - the value to be set into the neamed property

setValue

public void setValue(String expr,
                     Object value,
                     boolean throwExceptionOnFailure)
Description copied from interface: ValueStack
Attempts to set a property on a bean in the stack with the given expression using the default search order.

Specified by:
setValue in interface ValueStack
Parameters:
expr - the expression defining the path to the property to be set.
value - the value to be set into the neamed property
throwExceptionOnFailure - a flag to tell whether an exception should be thrown if there is no property with the given name.

findString

public String findString(String expr)
Specified by:
findString in interface ValueStack

findValue

public Object findValue(String expr)
Description copied from interface: ValueStack
Find a value by evaluating the given expression against the stack in the default search order.

Specified by:
findValue in interface ValueStack
Parameters:
expr - the expression giving the path of properties to navigate to find the property value to return
Returns:
the result of evaluating the expression

findValue

public Object findValue(String expr,
                        Class asType)
Description copied from interface: ValueStack
Find a value by evaluating the given expression against the stack in the default search order.

Specified by:
findValue in interface ValueStack
Parameters:
expr - the expression giving the path of properties to navigate to find the property value to return
asType - the type to convert the return value to
Returns:
the result of evaluating the expression

findInContext

private Object findInContext(String name)

logLookupFailure

private void logLookupFailure(String expr,
                              Exception e)
Log a failed lookup, being more verbose when devMode=true.

Parameters:
expr - The failed expression
e - The thrown exception.

peek

public Object peek()
Description copied from interface: ValueStack
Get the object on the top of the stack without changing the stack.

Specified by:
peek in interface ValueStack
See Also:
CompoundRoot.peek()

pop

public Object pop()
Description copied from interface: ValueStack
Get the object on the top of the stack and remove it from the stack.

Specified by:
pop in interface ValueStack
Returns:
the object on the top of the stack
See Also:
CompoundRoot.pop()

push

public void push(Object o)
Description copied from interface: ValueStack
Put this object onto the top of the stack

Specified by:
push in interface ValueStack
Parameters:
o - the object to be pushed onto the stack
See Also:
CompoundRoot.push(Object)

set

public void set(String key,
                Object o)
Description copied from interface: ValueStack
Sets an object on the stack with the given key so it is retrievable by findValue(key,...)

Specified by:
set in interface ValueStack

size

public int size()
Description copied from interface: ValueStack
Get the number of objects in the stack s

Specified by:
size in interface ValueStack
Returns:
the number of objects in the stack

setRoot

private void setRoot(CompoundRoot compoundRoot)

readResolve

private Object readResolve()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlValueStack.ObjectAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class OgnlValueStack.ObjectAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
Enclosing class:
OgnlValueStack
public static class OgnlValueStack.ObjectAccessor
extends ognl.ObjectPropertyAccessor

Constructor Summary
OgnlValueStack.ObjectAccessor()
Method Summary
Object | getProperty(Map map, Object o, Object o1)
void | setProperty(Map map, Object o, Object o1, Object o2)
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlValueStack.ObjectAccessor

public OgnlValueStack.ObjectAccessor()
Method Detail

getProperty

public Object getProperty(Map map,
                          Object o,
                          Object o1)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.ObjectPropertyAccessor
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map map,
                        Object o,
                        Object o1,
                        Object o2)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.ObjectPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlValueStackFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class OgnlValueStackFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ValueStackFactory
        extended by  com.opensymphony.xwork2.util.OgnlValueStackFactory

public class OgnlValueStackFactory
extends ValueStackFactory

Creates an Ognl value stack

Constructor Summary
OgnlValueStackFactory()
Method Summary
ValueStack | createValueStack()
ValueStack | createValueStack(ValueStack stack)
Methods inherited from class com.opensymphony.xwork2.util.ValueStackFactory
getFactory, setFactory
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OgnlValueStackFactory

public OgnlValueStackFactory()
Method Detail

createValueStack

public ValueStack createValueStack()
Specified by:
createValueStack in class ValueStackFactory

createValueStack

public ValueStack createValueStack(ValueStack stack)
Specified by:
createValueStack in class ValueStackFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertiesReader (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class PropertiesReader

java.lang.Object
    extended by  java.io.Reader
        extended by  java.io.BufferedReader
            extended by  java.io.LineNumberReader
                extended by  com.opensymphony.xwork2.util.PropertiesReader
All Implemented Interfaces:
Closeable, Readable
public class PropertiesReader
extends LineNumberReader

This class is used to read properties lines. These lines do not terminate with new-line chars but rather when there is no backslash sign a the end of the line. This is used to concatenate multiple lines for readability. This class was pulled out of Jakarta Commons Configuration and Jakarta Commons Lang trunk revision 476093

Field Summary
(package private) static String | COMMENT_CHARS Constant for the supported comment characters.
private List | commentLines Stores the comment lines for the currently processed property.
private char | delimiter Stores the list delimiter character.
private static int | HEX_RADIX Constant for the radix of hex numbers.
private String | propertyName Stores the name of the last read property.
private String | propertyValue Stores the value of the last read property.
private static char[] | SEPARATORS The list of possible key/value separators
private static int | UNICODE_LEN Constant for the length of a unicode literal.
private static char[] | WHITE_SPACE The white space characters used as key/value separators.
Fields inherited from class java.io.Reader
lock
Constructor Summary
PropertiesReader(Reader reader)
Constructor.
PropertiesReader(Reader reader, char listDelimiter)
Creates a new instance of PropertiesReader and sets the underlaying reader and the list delimiter.
Method Summary
private boolean | checkCombineLines(String line) Checks if the passed in line should be combined with the following.
boolean | contains(char[] array, char objectToFind) Checks if the object is in the given array.
List | getCommentLines() Returns the comment lines that have been read for the last property.
String | getPropertyName() Returns the name of the last read property.
String | getPropertyValue() Returns the value of the last read property.
(package private) boolean | isCommentLine(String line) Tests whether a line is a comment, i.e.
boolean | nextProperty() Parses the next property from the input stream and stores the found name and value in internal fields.
private String[] | parseProperty(String line) Parse a property line and return the key and the value in an array.
String | readProperty() Reads a property line.
static String | unescapeJava(String str) Unescapes any Java literals found in the String.
protected static String | unescapeJava(String str, char delimiter) Unescapes any Java literals found in the String to a Writer.
static void | unescapeJava(Writer out, String str) Unescapes any Java literals found in the String to a Writer.
Methods inherited from class java.io.LineNumberReader
getLineNumber, mark, read, read, readLine, reset, setLineNumber, skip
Methods inherited from class java.io.BufferedReader
close, markSupported, ready
Methods inherited from class java.io.Reader
read, read
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

commentLines

private List commentLines
Stores the comment lines for the currently processed property.

propertyName

private String propertyName
Stores the name of the last read property.

propertyValue

private String propertyValue
Stores the value of the last read property.

delimiter

private char delimiter
Stores the list delimiter character.

COMMENT_CHARS

static final String COMMENT_CHARS
Constant for the supported comment characters.

See Also:
Constant Field Values

HEX_RADIX

private static final int HEX_RADIX
Constant for the radix of hex numbers.

See Also:
Constant Field Values

UNICODE_LEN

private static final int UNICODE_LEN
Constant for the length of a unicode literal.

See Also:
Constant Field Values

SEPARATORS

private static final char[] SEPARATORS
The list of possible key/value separators

WHITE_SPACE

private static final char[] WHITE_SPACE
The white space characters used as key/value separators.

Constructor Detail

PropertiesReader

public PropertiesReader(Reader reader)
Constructor.

Parameters:
reader - A Reader.

PropertiesReader

public PropertiesReader(Reader reader,
                        char listDelimiter)
Creates a new instance of PropertiesReader and sets the underlaying reader and the list delimiter.

Parameters:
reader - the reader
listDelimiter - the list delimiter character
Since:
1.3
Method Detail

isCommentLine

boolean isCommentLine(String line)
Tests whether a line is a comment, i.e. whether it starts with a comment character.

Parameters:
line - the line
Returns:
a flag if this is a comment line
Since:
1.3

readProperty

public String readProperty()
                    throws IOException
Reads a property line. Returns null if Stream is at EOF. Concatenates lines ending with "\". Skips lines beginning with "#" or "!" and empty lines. The return value is a property definition (<name> = <value>)

Returns:
A string containing a property value or null
Throws:
IOException - in case of an I/O error

nextProperty

public boolean nextProperty()
                     throws IOException
Parses the next property from the input stream and stores the found name and value in internal fields. These fields can be obtained using the provided getter methods. The return value indicates whether EOF was reached (false) or whether further properties are available (true).

Returns:
a flag if further properties are available
Throws:
IOException - if an error occurs
Since:
1.3

getCommentLines

public List getCommentLines()
Returns the comment lines that have been read for the last property.

Returns:
the comment lines for the last property returned by readProperty()
Since:
1.3

getPropertyName

public String getPropertyName()
Returns the name of the last read property. This method can be called after nextProperty() was invoked and its return value was true.

Returns:
the name of the last read property
Since:
1.3

getPropertyValue

public String getPropertyValue()
Returns the value of the last read property. This method can be called after nextProperty() was invoked and its return value was true.

Returns:
the value of the last read property
Since:
1.3

checkCombineLines

private boolean checkCombineLines(String line)
Checks if the passed in line should be combined with the following. This is true, if the line ends with an odd number of backslashes.

Parameters:
line - the line
Returns:
a flag if the lines should be combined

parseProperty

private String[] parseProperty(String line)
Parse a property line and return the key and the value in an array.

Parameters:
line - the line to parse
Returns:
an array with the property's key and value
Since:
1.2

unescapeJava

protected static String unescapeJava(String str,
                                     char delimiter)

Unescapes any Java literals found in the String to a Writer.

This is a slightly modified version of the StringEscapeUtils.unescapeJava() function in commons-lang that doesn't drop escaped separators (i.e '\,').

Parameters:
str - the String to unescape, may be null
delimiter - the delimiter for multi-valued properties
Returns:
the processed string
Throws:
IllegalArgumentException - if the Writer is null

contains

public boolean contains(char[] array,
                        char objectToFind)

Checks if the object is in the given array.

The method returns false if a null array is passed in.

Parameters:
array - the array to search through
objectToFind - the object to find
Returns:
true if the array contains the object

unescapeJava

public static String unescapeJava(String str)

Unescapes any Java literals found in the String. For example, it will turn a sequence of '\' and 'n' into a newline character, unless the '\' is preceded by another '\'.

Parameters:
str - the String to unescape, may be null
Returns:
a new unescaped String, null if null string input

unescapeJava

public static void unescapeJava(Writer out,
                                String str)
                         throws IOException

Unescapes any Java literals found in the String to a Writer.

For example, it will turn a sequence of '\' and 'n' into a newline character, unless the '\' is preceded by another '\'.

A null string input has no effect.

Parameters:
out - the Writer used to output unescaped characters
str - the String to unescape, may be null
Throws:
IllegalArgumentException - if the Writer is null
IOException - if error occurs on underlying Writer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil<T>

public class ResolverUtil<T>
extends Object

ResolverUtil is used to locate classes that are available in the/a class path and meet arbitrary conditions. The two most common conditions are that a class implements/extends another class, or that is it annotated with a specific annotation. However, through the use of the ResolverUtil.Test class it is possible to search using arbitrary conditions.

A ClassLoader is used to locate all locations (directories and jar files) in the class path that contain classes within certain packages, and then to load those classes and check them. By default the ClassLoader returned by Thread.currentThread().getContextClassLoader() is used, but this can be overridden by calling setClassLoader(ClassLoader) prior to invoking any of the find() methods.

General searches are initiated by calling the find(com.opensymphony.xwork2.util.ResolverUtil.Test, String...) ()} method and supplying a package name and a Test instance. This will cause the named package and all sub-packages to be scanned for classes that meet the test. There are also utility methods for the common use cases of scanning multiple packages for extensions of particular classes, or classes annotated with a specific annotation.

The standard usage pattern for the ResolverUtil class is as follows:

ResolverUtil<ActionBean> resolver = new ResolverUtil<ActionBean>();
resolver.findImplementation(ActionBean.class, pkg1, pkg2);
resolver.find(new CustomTest(), pkg1);
resolver.find(new CustomTest(), pkg2);
Collection<ActionBean> beans = resolver.getClasses();

This class was copied from Stripes - http://stripes.mc4j.org/confluence/display/stripes/Home

Author:
Tim Fennell

Nested Class Summary
static class | ResolverUtil.AnnotatedWith A Test that checks to see if each class is annotated with a specific annotation.
static class | ResolverUtil.IsA A Test that checks to see if each class is assignable to the provided class.
static class | ResolverUtil.NameEndsWith A Test that checks to see if each class name ends with the provided suffix.
static interface | ResolverUtil.Test A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.
Field Summary
private ClassLoader | classloader The ClassLoader to use when looking for classes.
private static Log | log An instance of Log to use for logging in this class.
private Set<Class<? extends T>> | matches The set of matches being accumulated.
Constructor Summary
ResolverUtil()
Method Summary
protected void | addIfMatching(ResolverUtil.Test test, String fqn) Add the class designated by the fully qualified class name provided to the set of resolved classes if and only if it is approved by the Test supplied.
void | find(ResolverUtil.Test test, String... packageNames) Attempts to discover classes that pass the test.
void | findAnnotated(Class<? extends Annotation> annotation, String... packageNames) Attempts to discover classes that are annotated with to the annotation.
void | findImplementations(Class parent, String... packageNames) Attempts to discover classes that are assignable to the type provided.
void | findInPackage(ResolverUtil.Test test, String packageName) Scans for classes starting at the package provided and descending into subpackages.
void | findSuffix(String suffix, String... packageNames) Attempts to discover classes who's name ends with the provided suffix.
Set<Class<? extends T>> | getClasses() Provides access to the classes discovered so far.
ClassLoader | getClassLoader() Returns the classloader that will be used for scanning for classes.
private void | loadImplementationsInDirectory(ResolverUtil.Test test, String parent, File location) Finds matches in a physical directory on a filesystem.
private void | loadImplementationsInJar(ResolverUtil.Test test, String parent, File jarfile) Finds matching classes within a jar files that contains a folder structure matching the package structure.
void | setClassLoader(ClassLoader classloader) Sets an explicit ClassLoader that should be used when scanning for classes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log
An instance of Log to use for logging in this class.

matches

private Set<Class<? extends T>> matches
The set of matches being accumulated.

classloader

private ClassLoader classloader
The ClassLoader to use when looking for classes. If null then the ClassLoader returned by Thread.currentThread().getContextClassLoader() will be used.

Constructor Detail

ResolverUtil

public ResolverUtil()
Method Detail

getClasses

public Set<Class<? extends T>> getClasses()
Provides access to the classes discovered so far. If no calls have been made to any of the find() methods, this set will be empty.

Returns:
the set of classes that have been discovered.

getClassLoader

public ClassLoader getClassLoader()
Returns the classloader that will be used for scanning for classes. If no explicit ClassLoader has been set by the calling, the context class loader will be used.

Returns:
the ClassLoader that will be used to scan for classes

setClassLoader

public void setClassLoader(ClassLoader classloader)
Sets an explicit ClassLoader that should be used when scanning for classes. If none is set then the context classloader will be used.

Parameters:
classloader - a ClassLoader to use when scanning for classes

findImplementations

public void findImplementations(Class parent,
                                String... packageNames)
Attempts to discover classes that are assignable to the type provided. In the case that an interface is provided this method will collect implementations. In the case of a non-interface class, subclasses will be collected. Accumulated classes can be accessed by calling getClasses().

Parameters:
parent - the class of interface to find subclasses or implementations of
packageNames - one or more package names to scan (including subpackages) for classes

findSuffix

public void findSuffix(String suffix,
                       String... packageNames)
Attempts to discover classes who's name ends with the provided suffix. Accumulated classes can be accessed by calling getClasses().

Parameters:
suffix - The class name suffix to match
packageNames - one or more package names to scan (including subpackages) for classes

findAnnotated

public void findAnnotated(Class<? extends Annotation> annotation,
                          String... packageNames)
Attempts to discover classes that are annotated with to the annotation. Accumulated classes can be accessed by calling getClasses().

Parameters:
annotation - the annotation that should be present on matching classes
packageNames - one or more package names to scan (including subpackages) for classes

find

public void find(ResolverUtil.Test test,
                 String... packageNames)
Attempts to discover classes that pass the test. Accumulated classes can be accessed by calling getClasses().

Parameters:
test - the test to determine matching classes
packageNames - one or more package names to scan (including subpackages) for classes

findInPackage

public void findInPackage(ResolverUtil.Test test,
                          String packageName)
Scans for classes starting at the package provided and descending into subpackages. Each class is offered up to the Test as it is discovered, and if the Test returns true the class is retained. Accumulated classes can be fetched by calling getClasses().

Parameters:
test - an instance of ResolverUtil.Test that will be used to filter classes
packageName - the name of the package from which to start scanning for classes, e.g. net.sourceforge.stripes

loadImplementationsInDirectory

private void loadImplementationsInDirectory(ResolverUtil.Test test,
                                            String parent,
                                            File location)
Finds matches in a physical directory on a filesystem. Examines all files within a directory - if the File object is not a directory, and ends with .class the file is loaded and tested to see if it is acceptable according to the Test. Operates recursively to find classes within a folder structure matching the package structure.

Parameters:
test - a Test used to filter the classes that are discovered
parent - the package name up to this directory in the package hierarchy. E.g. if /classes is in the classpath and we wish to examine files in /classes/org/apache then the values of parent would be org/apache
location - a File object representing a directory

loadImplementationsInJar

private void loadImplementationsInJar(ResolverUtil.Test test,
                                      String parent,
                                      File jarfile)
Finds matching classes within a jar files that contains a folder structure matching the package structure. If the File is not a JarFile or does not exist a warning will be logged, but no error will be raised.

Parameters:
test - a Test used to filter the classes that are discovered
parent - the parent package under which classes must be in order to be considered
jarfile - the jar file to be examined for classes

addIfMatching

protected void addIfMatching(ResolverUtil.Test test,
                             String fqn)
Add the class designated by the fully qualified class name provided to the set of resolved classes if and only if it is approved by the Test supplied.

Parameters:
test - the test used to determine if the class matches
fqn - the fully qualified name of a class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.AnnotatedWith (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.AnnotatedWith

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
All Implemented Interfaces:
ResolverUtil.Test
Enclosing class:
ResolverUtil<T>
public static class ResolverUtil.AnnotatedWith
extends Object
implements ResolverUtil.Test

A Test that checks to see if each class is annotated with a specific annotation. If it is, then the test returns true, otherwise false.

Field Summary
private  Class<? extends Annotation> annotation
Constructor Summary
ResolverUtil.AnnotatedWith(Class<? extends Annotation> annotation)
Construts an AnnotatedWith test for the specified annotation type.
Method Summary
boolean | matches(Class type) Returns true if the type is annotated with the class provided to the constructor.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

annotation

private Class<? extends Annotation> annotation
Constructor Detail

ResolverUtil.AnnotatedWith

public ResolverUtil.AnnotatedWith(Class<? extends Annotation> annotation)
Construts an AnnotatedWith test for the specified annotation type.

Method Detail

matches

public boolean matches(Class type)
Returns true if the type is annotated with the class provided to the constructor.

Specified by:
matches in interface ResolverUtil.Test

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.IsA (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.IsA

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.IsA
All Implemented Interfaces:
ResolverUtil.Test
Enclosing class:
ResolverUtil<T>
public static class ResolverUtil.IsA
extends Object
implements ResolverUtil.Test

A Test that checks to see if each class is assignable to the provided class. Note that this test will match the parent type itself if it is presented for matching.

Field Summary
private  Class parent
Constructor Summary
ResolverUtil.IsA(Class parentType)
Constructs an IsA test using the supplied Class as the parent class/interface.
Method Summary
boolean | matches(Class type) Returns true if type is assignable to the parent type supplied in the constructor.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

parent

private Class parent
Constructor Detail

ResolverUtil.IsA

public ResolverUtil.IsA(Class parentType)
Constructs an IsA test using the supplied Class as the parent class/interface.

Method Detail

matches

public boolean matches(Class type)
Returns true if type is assignable to the parent type supplied in the constructor.

Specified by:
matches in interface ResolverUtil.Test

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.NameEndsWith (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ResolverUtil.NameEndsWith

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
All Implemented Interfaces:
ResolverUtil.Test
Enclosing class:
ResolverUtil<T>
public static class ResolverUtil.NameEndsWith
extends Object
implements ResolverUtil.Test

A Test that checks to see if each class name ends with the provided suffix.

Field Summary
private  String suffix
Constructor Summary
ResolverUtil.NameEndsWith(String suffix)
Constructs a NameEndsWith test using the supplied suffix.
Method Summary
boolean | matches(Class type) Returns true if type name ends with the suffix supplied in the constructor.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

suffix

private String suffix
Constructor Detail

ResolverUtil.NameEndsWith

public ResolverUtil.NameEndsWith(String suffix)
Constructs a NameEndsWith test using the supplied suffix.

Method Detail

matches

public boolean matches(Class type)
Returns true if type name ends with the suffix supplied in the constructor.

Specified by:
matches in interface ResolverUtil.Test

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResolverUtil.Test (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface ResolverUtil.Test

All Known Implementing Classes:
ResolverUtil.AnnotatedWith, ResolverUtil.IsA, ResolverUtil.NameEndsWith
Enclosing class:
ResolverUtil<T>
public static interface ResolverUtil.Test

A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.

Method Summary
 boolean matches(Class type)
Will be called repeatedly with candidate classes.

Method Detail

matches

boolean matches(Class type)
Will be called repeatedly with candidate classes. Must return True if a class is to be included in the results, false otherwise.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SurrugateList (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class SurrugateList

java.lang.Object
    extended by  java.util.AbstractCollection<E>
        extended by  java.util.AbstractList<E>
            extended by  java.util.ArrayList
                extended by  com.opensymphony.xwork2.util.SurrugateList
All Implemented Interfaces:
Serializable, Cloneable, Iterable, Collection, List, RandomAccess
 class SurrugateList
extends ArrayList

Author:
Gabe

Field Summary
private  Collection surrugate
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
SurrugateList(Collection surrugate)
Method Summary
void | add(int arg0, Object arg1)
boolean | add(Object arg0)
boolean | addAll(Collection arg0)
boolean | addAll(int arg0, Collection arg1)
Object | set(int arg0, Object arg1)
Methods inherited from class java.util.ArrayList
clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, remove, removeRange, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

Field Detail

surrugate

private Collection surrugate
Constructor Detail

SurrugateList

public SurrugateList(Collection surrugate)
Method Detail

add

public void add(int arg0,
                Object arg1)
Specified by:
add in interface List
Overrides:
add in class ArrayList

add

public boolean add(Object arg0)
Specified by:
add in interface Collection
Specified by:
add in interface List
Overrides:
add in class ArrayList

addAll

public boolean addAll(Collection arg0)
Specified by:
addAll in interface Collection
Specified by:
addAll in interface List
Overrides:
addAll in class ArrayList

addAll

public boolean addAll(int arg0,
                      Collection arg1)
Specified by:
addAll in interface List
Overrides:
addAll in class ArrayList

set

public Object set(int arg0,
                  Object arg1)
Specified by:
set in interface List
Overrides:
set in class ArrayList
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextParseUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class TextParseUtil

java.lang.Object
    extended by  com.opensymphony.xwork2.util.TextParseUtil

public class TextParseUtil
extends Object

Utility class for text parsing.

Version:
$Date: 2006-11-23 21:33:15 +0100 (Do, 23 Nov 2006) $ $Id: TextParseUtil.java 1223 2006-11-23 20:33:15Z rainerh $
Author:
Jason Carreira, Rainer Hermanns, tm_jee

Nested Class Summary
static interface TextParseUtil.ParsedValueEvaluator
A parsed value evaluator for TextParseUtil.
Constructor Summary
TextParseUtil()
Method Summary
static Set commaDelimitedStringToSet(String s)
Returns a set from comma delimted Strings.
static String translateVariables(char open, String expression, ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String).
static Object translateVariables(char open, String expression, ValueStack stack, Class asType)
Converted object from variable translation.
static Object translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static String translateVariables(String expression, ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String).
static String translateVariables(String expression, ValueStack stack, TextParseUtil.ParsedValueEvaluator evaluator)
Function similarly as translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextParseUtil

public TextParseUtil()
Method Detail

translateVariables

public static String translateVariables(String expression,
                                        ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String). If an item cannot be found on the stack (null is returned), then the entire variable ${...} is not displayed, just as if the item was on the stack but returned an empty string.

Parameters:
expression - an expression that hasn't yet been translated
Returns:
the parsed expression

translateVariables

public static String translateVariables(String expression,
                                        ValueStack stack,
                                        TextParseUtil.ParsedValueEvaluator evaluator)
Function similarly as translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator. The evaluator could be null, if it is it will just be skipped as if it is just calling translateVariables(char, String, ValueStack).

A typical use-case would be when we need to URL Encode the parsed value. To do so we could just supply a URLEncodingEvaluator for example.

Parameters:
expression -
stack -
evaluator - The parsed Value evaluator (could be null).
Returns:
the parsed (and possibly evaluated) variable String.

translateVariables

public static String translateVariables(char open,
                                        String expression,
                                        ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String). If an item cannot be found on the stack (null is returned), then the entire variable ${...} is not displayed, just as if the item was on the stack but returned an empty string.

Parameters:
open -
expression -
stack -
Returns:
Translated variable String

translateVariables

public static Object translateVariables(char open,
                                        String expression,
                                        ValueStack stack,
                                        Class asType)
Converted object from variable translation.

Parameters:
open -
expression -
stack -
asType -
Returns:
Converted object from variable translation.

translateVariables

public static Object translateVariables(char open,
                                        String expression,
                                        ValueStack stack,
                                        Class asType,
                                        TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.

Parameters:
open -
expression -
stack -
asType -
evaluator -
Returns:
Converted object from variable translation.

commaDelimitedStringToSet

public static Set commaDelimitedStringToSet(String s)
Returns a set from comma delimted Strings.

Parameters:
s - The String to parse.
Returns:
A set from comma delimted Strings.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextParseUtil.ParsedValueEvaluator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Interface TextParseUtil.ParsedValueEvaluator

Enclosing class:
TextParseUtil
public static interface TextParseUtil.ParsedValueEvaluator

A parsed value evaluator for TextParseUtil. It could be supplied by calling TextParseUtil.translateVariables(char, String, ValueStack, Class, ParsedValueEvaluator).

By supplying this ParsedValueEvaluator, the parsed value (parsed against the value stack) value will be given to ParsedValueEvaluator to be evaluated before the translateVariable process goes on.

A typical use-case would be to have a custom ParseValueEvaluator to URL Encode the parsed value.

Version:
$Date: 2006-11-23 21:33:15 +0100 (Do, 23 Nov 2006) $ $Id: TextParseUtil.java 1223 2006-11-23 20:33:15Z rainerh $
Author:
tm_jee

Method Summary
 Object evaluate(Object parsedValue)
Evaluated the value parsed by Ognl value stack.

Method Detail

evaluate

Object evaluate(Object parsedValue)
Evaluated the value parsed by Ognl value stack.

Parameters:
parsedValue - - value parsed by ognl value stack
Returns:
return the evaluted value.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextUtils (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class TextUtils

java.lang.Object
    extended by  com.opensymphony.xwork2.util.TextUtils

public class TextUtils
extends Object

Utilities for common String manipulations. This is a class contains static methods only and is not meant to be instantiated. It was brought in from oscore trunk revision 147, and trimmed to only contain methods used by XWork.

Version:
$Revision: 147 $
Author:
Joe Walnes, Patrick Kan, Mike Cannon-Brookes, Hani Suleiman, Joseph B. Ottinger, Scott Farquhar

Constructor Summary
TextUtils()
Method Summary
static String | htmlEncode(String s)
static String | htmlEncode(String s, boolean encodeSpecialChars) Escape html entity characters and high characters (eg "curvy" Word quotes).
static String | join(String glue, Collection pieces) Join a Collection of Strings together.
static String | join(String glue, Iterator pieces) Join an Iteration of Strings together.
static String | join(String glue, String[] pieces) Join an array of Strings together.
static String | noNull(String string) Return string, or "" if string is null.
static String | noNull(String string, String defaultString) Return string, or defaultString if string is null or "".
static boolean | stringSet(String string) Check whether string has been set to something other than "" or null.
static boolean | verifyUrl(String url) Verify That the given String is in valid URL format.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextUtils

public TextUtils()
Method Detail

htmlEncode

public static final String htmlEncode(String s)

htmlEncode

public static final String htmlEncode(String s,
                                      boolean encodeSpecialChars)
Escape html entity characters and high characters (eg "curvy" Word quotes). Note this method can also be used to encode XML.

Parameters:
s - the String to escape.
encodeSpecialChars - if true high characters will be encode other wise not.
Returns:
the escaped string

join

public static final String join(String glue,
                                Iterator pieces)
Join an Iteration of Strings together.
Example
   // get Iterator of Strings ("abc","def","123");
   Iterator i = getIterator();
   out.print( TextUtils.join(", ",i) );
   // prints: "abc, def, 123"

Parameters:
glue - Token to place between Strings.
pieces - Iteration of Strings to join.
Returns:
String presentation of joined Strings.

join

public static final String join(String glue,
                                String[] pieces)
Join an array of Strings together.

Parameters:
glue - Token to place between Strings.
pieces - Array of Strings to join.
Returns:
String presentation of joined Strings.
See Also:
join(String, java.util.Iterator)

join

public static final String join(String glue,
                                Collection pieces)
Join a Collection of Strings together.

Parameters:
glue - Token to place between Strings.
pieces - Collection of Strings to join.
Returns:
String presentation of joined Strings.
See Also:
join(String, java.util.Iterator)

noNull

public static final String noNull(String string,
                                  String defaultString)
Return string, or defaultString if string is null or "". Never returns null.

Examples:

 // prints "hello"
 String s=null;
 System.out.println(TextUtils.noNull(s,"hello");

 // prints "hello"
 s="";
 System.out.println(TextUtils.noNull(s,"hello");

 // prints "world"
 s="world";
 System.out.println(TextUtils.noNull(s, "hello");

Parameters:
string - the String to check.
defaultString - The default string to return if string is null or ""
Returns:
string if string is non-empty, and defaultString otherwise
See Also:
stringSet(java.lang.String)

noNull

public static final String noNull(String string)
Return string, or "" if string is null. Never returns null.

Examples:

 // prints 0
 String s=null;
 System.out.println(TextUtils.noNull(s).length());

 // prints 1
 s="a";
 System.out.println(TextUtils.noNull(s).length());

Parameters:
string - the String to check
Returns:
a valid (non-null) string reference

stringSet

public static final boolean stringSet(String string)
Check whether string has been set to something other than "" or null.

Parameters:
string - the String to check
Returns:
a boolean indicating whether the string was non-empty (and non-null)

verifyUrl

public static final boolean verifyUrl(String url)
Verify That the given String is in valid URL format.

Parameters:
url - The url string to verify.
Returns:
a boolean indicating whether the URL seems to be incorrect.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValueStackFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ValueStackFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ValueStackFactory
Direct Known Subclasses:
OgnlValueStackFactory
public abstract class ValueStackFactory
extends Object

Factory that creates a value stack, defaulting to the OgnlValueStackFactory

Field Summary
private static ValueStackFactory factory
Constructor Summary
ValueStackFactory()
Method Summary
abstract ValueStack | createValueStack()
abstract ValueStack | createValueStack(ValueStack stack)
static ValueStackFactory | getFactory()
static void | setFactory(ValueStackFactory factory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

factory

private static ValueStackFactory factory
Constructor Detail

ValueStackFactory

public ValueStackFactory()
Method Detail

setFactory

public static void setFactory(ValueStackFactory factory)

getFactory

public static ValueStackFactory getFactory()

createValueStack

public abstract ValueStack createValueStack()

createValueStack

public abstract ValueStack createValueStack(ValueStack stack)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WildcardHelper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class WildcardHelper

java.lang.Object
    extended by  com.opensymphony.xwork2.util.WildcardHelper

public class WildcardHelper
extends Object

This class is an utility class that perform wilcard-patterns matching and isolation taken from Apache Cocoon.

Version:
$Rev: 1063 $ $Date: 2005-05-07 12:11:38 -0400 (Sat, 07 May 2005) $

Field Summary
protected static int | MATCH_BEGIN The int representing begin in the pattern int [].
protected static int | MATCH_END The int value that terminates the pattern int [].
protected static int | MATCH_FILE The int representing '*' in the pattern int [].
protected static int | MATCH_PATH The int representing '**' in the pattern int [].
protected static int | MATCH_THEEND The int representing end in pattern int [].
Constructor Summary
WildcardHelper()
Method Summary
int[] | compilePattern(String data) Translate the given String into a int [] representing the pattern matchable by this class.
protected int | indexOfArray(int[] r, int rpos, int rend, char[] d, int dpos) Get the offset of a part of an int array within a char array.
protected int | lastIndexOfArray(int[] r, int rpos, int rend, char[] d, int dpos) Get the offset of a last occurance of an int array within a char array.
boolean | match(Map map, String data, int[] expr) Match a pattern agains a string and isolates wildcard replacement into a Stack.
protected boolean | matchArray(int[] r, int rpos, int rend, char[] d, int dpos) Matches elements of array r from rpos to rend with array d, starting from dpos.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MATCH_FILE

protected static final int MATCH_FILE
The int representing '*' in the pattern int [].

See Also:
Constant Field Values

MATCH_PATH

protected static final int MATCH_PATH
The int representing '**' in the pattern int [].

See Also:
Constant Field Values

MATCH_BEGIN

protected static final int MATCH_BEGIN
The int representing begin in the pattern int [].

See Also:
Constant Field Values

MATCH_THEEND

protected static final int MATCH_THEEND
The int representing end in pattern int [].

See Also:
Constant Field Values

MATCH_END

protected static final int MATCH_END
The int value that terminates the pattern int [].

See Also:
Constant Field Values
Constructor Detail

WildcardHelper

public WildcardHelper()
Method Detail

compilePattern

public int[] compilePattern(String data)

Translate the given String into a int [] representing the pattern matchable by this class.
This function translates a String into an int array converting the special '*' and '\' characters.
Here is how the conversion algorithm works:

  • The '*' character is converted to MATCH_FILE, meaning that zero or more characters (excluding the path separator '/') are to be matched.
  • The '**' sequence is converted to MATCH_PATH, meaning that zero or more characters (including the path separator '/') are to be matched.
  • The '\' character is used as an escape sequence ('\*' is translated in '*', not in MATCH_FILE). If an exact '\' character is to be matched the source string must contain a '\\'. sequence.

When more than two '*' characters, not separated by another character, are found their value is considered as '**' (MATCH_PATH).
The array is always terminated by a special value (MATCH_END).
All MATCH* values are less than zero, while normal characters are equal or greater.

Parameters:
data - The string to translate.
Returns:
The encoded string as an int array, terminated by the MATCH_END value (don't consider the array length).
Throws:
NullPointerException - If data is null.

match

public boolean match(Map map,
                     String data,
                     int[] expr)
Match a pattern agains a string and isolates wildcard replacement into a Stack.

Parameters:
map - The map to store matched values
data - The string to match
expr - The compiled wildcard expression
Returns:
True if a match
Throws:
NullPointerException - If any parameters are null

indexOfArray

protected int indexOfArray(int[] r,
                           int rpos,
                           int rend,
                           char[] d,
                           int dpos)
Get the offset of a part of an int array within a char array.
This method return the index in d of the first occurrence after dpos of that part of array specified by r, starting at rpos and terminating at rend.

Parameters:
r - The array containing the data that need to be matched in d.
rpos - The index of the first character in r to look for.
rend - The index of the last character in r to look for plus 1.
d - The array of char that should contain a part of r.
dpos - The starting offset in d for the matching.
Returns:
The offset in d of the part of r matched in d or -1 if that was not found.

lastIndexOfArray

protected int lastIndexOfArray(int[] r,
                               int rpos,
                               int rend,
                               char[] d,
                               int dpos)
Get the offset of a last occurance of an int array within a char array.
This method return the index in d of the last occurrence after dpos of that part of array specified by r, starting at rpos and terminating at rend.

Parameters:
r - The array containing the data that need to be matched in d.
rpos - The index of the first character in r to look for.
rend - The index of the last character in r to look for plus 1.
d - The array of char that should contain a part of r.
dpos - The starting offset in d for the matching.
Returns:
The offset in d of the last part of r matched in d or -1 if that was not found.

matchArray

protected boolean matchArray(int[] r,
                             int rpos,
                             int rend,
                             char[] d,
                             int dpos)
Matches elements of array r from rpos to rend with array d, starting from dpos.
This method return true if elements of array r from rpos to rend equals elements of array d starting from dpos to dpos+(rend-rpos).

Parameters:
r - The array containing the data that need to be matched in d.
rpos - The index of the first character in r to look for.
rend - The index of the last character in r to look for.
d - The array of char that should start from a part of r.
dpos - The starting offset in d for the matching.
Returns:
true if array d starts from portion of array r.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkBasicConverter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkBasicConverter

java.lang.Object
    extended by  ognl.DefaultTypeConverter
        extended by  com.opensymphony.xwork2.util.XWorkBasicConverter
All Implemented Interfaces:
ognl.TypeConverter
public class XWorkBasicConverter
extends ognl.DefaultTypeConverter

XWork will automatically handle the most common type conversion for you. This includes support for converting to and from Strings for each of the following:

  • String

  • boolean / Boolean

  • char / Character

  • int / Integer, float / Float, long / Long, double / Double

  • dates - uses the SHORT format for the Locale associated with the current request

  • arrays - assuming the individual strings can be coverted to the individual items

  • collections - if not object type can be determined, it is assumed to be a String and a new ArrayList is created

Note that with arrays the type conversion will defer to the type of the array elements and try to convert each item individually. As with any other type conversion, if the conversion can't be performed the standard type conversion error reporting is used to indicate a problem occured while processing the type conversion.

Author:
Pat Lightbody, Mike Mosiewicz, Rainer Hermanns, Alexandru Popescu

Field Summary
private static String | MILLISECOND_FORMAT
private static SimpleDateFormat | RFC3399_FORMAT
Constructor Summary
XWorkBasicConverter()
Method Summary
Object | convertValue(Map context, Object o, Member member, String s, Object value, Class toType)
private Collection | createCollection(Object fromObject, String propertyName, Class toType, Class memberType, int size) Creates a Collection of the specified type.
private Object | doConvertToArray(Map context, Object o, Member member, String s, Object value, Class toType)
private Object | doConvertToBoolean(Object value)
private Object | doConvertToCharacter(Object value)
private Class | doConvertToClass(Object value)
private Collection | doConvertToCollection(Map context, Object o, Member member, String prop, Object value, Class toType)
private Object | doConvertToDate(Map context, Object value, Class toType)
private Object | doConvertToNumber(Map context, Object value, Class toType)
private String | doConvertToString(Map context, Object value)
private Locale | getLocale(Map context)
protected boolean | isIntegerType(Class type)
Methods inherited from class ognl.DefaultTypeConverter
convertValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MILLISECOND_FORMAT

private static String MILLISECOND_FORMAT

RFC3399_FORMAT

private static final SimpleDateFormat RFC3399_FORMAT
Constructor Detail

XWorkBasicConverter

public XWorkBasicConverter()
Method Detail

convertValue

public Object convertValue(Map context,
                           Object o,
                           Member member,
                           String s,
                           Object value,
                           Class toType)
Specified by:
convertValue in interface ognl.TypeConverter
Overrides:
convertValue in class ognl.DefaultTypeConverter

getLocale

private Locale getLocale(Map context)

createCollection

private Collection createCollection(Object fromObject,
                                    String propertyName,
                                    Class toType,
                                    Class memberType,
                                    int size)
Creates a Collection of the specified type.

Parameters:
fromObject -
propertyName -
toType - the type of Collection to create
memberType - the type of object elements in this collection must be
size - the initial size of the collection (ignored if 0 or less)
Returns:
a Collection of the specified type

doConvertToArray

private Object doConvertToArray(Map context,
                                Object o,
                                Member member,
                                String s,
                                Object value,
                                Class toType)

doConvertToCharacter

private Object doConvertToCharacter(Object value)

doConvertToBoolean

private Object doConvertToBoolean(Object value)

doConvertToClass

private Class doConvertToClass(Object value)

doConvertToCollection

private Collection doConvertToCollection(Map context,
                                         Object o,
                                         Member member,
                                         String prop,
                                         Object value,
                                         Class toType)

doConvertToDate

private Object doConvertToDate(Map context,
                               Object value,
                               Class toType)

doConvertToNumber

private Object doConvertToNumber(Map context,
                                 Object value,
                                 Class toType)

isIntegerType

protected boolean isIntegerType(Class type)

doConvertToString

private String doConvertToString(Map context,
                                 Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkCollectionPropertyAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkCollectionPropertyAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  ognl.SetPropertyAccessor
            extended by  com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkCollectionPropertyAccessor
extends ognl.SetPropertyAccessor

Author:
Gabe

Field Summary
private ognl.ObjectPropertyAccessor | _accessor
private static String | CONTEXT_COLLECTION_MAP
static String | KEY_PROPERTY_FOR_CREATION
private static Log | LOG
Constructor Summary
XWorkCollectionPropertyAccessor()
Method Summary
Object | getProperty(Map context, Object target, Object key) Gets the property of a Collection by indexing the collection based on a key property.
Object | getPropertyThroughIteration(Map context, Collection collection, String property, Object key)
private Map | getSetMap(Map context, Collection collection, String property, Class valueClass)
void | setProperty(Map arg0, Object arg1, Object arg2, Object arg3)
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

CONTEXT_COLLECTION_MAP

private static final String CONTEXT_COLLECTION_MAP
See Also:
Constant Field Values

KEY_PROPERTY_FOR_CREATION

public static final String KEY_PROPERTY_FOR_CREATION
See Also:
Constant Field Values

_accessor

private ognl.ObjectPropertyAccessor _accessor
Constructor Detail

XWorkCollectionPropertyAccessor

public XWorkCollectionPropertyAccessor()
Method Detail

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object key)
                   throws ognl.OgnlException
Gets the property of a Collection by indexing the collection based on a key property. For example, if the key property were 'id', this method would convert the key Object to whatever type the id property was, and then access the Set like it was a Map returning a JavaBean with the value of id property matching the input.

Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.SetPropertyAccessor
Throws:
ognl.OgnlException
See Also:
PropertyAccessor.getProperty(java.util.Map, Object, Object)

getSetMap

private Map getSetMap(Map context,
                      Collection collection,
                      String property,
                      Class valueClass)
               throws ognl.OgnlException
Throws:
ognl.OgnlException

getPropertyThroughIteration

public Object getPropertyThroughIteration(Map context,
                                          Collection collection,
                                          String property,
                                          Object key)
                                   throws ognl.OgnlException
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map arg0,
                        Object arg1,
                        Object arg2,
                        Object arg3)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.ObjectPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkConverter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkConverter

java.lang.Object
    extended by  ognl.DefaultTypeConverter
        extended by  com.opensymphony.xwork2.util.XWorkConverter
All Implemented Interfaces:
ognl.TypeConverter
Direct Known Subclasses:
AnnotationXWorkConverter
public class XWorkConverter
extends ognl.DefaultTypeConverter

XWorkConverter is a singleton used by many of the WebWork's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion. Type conversion is great for situations where you need to turn a String in to a more complex object. Because the web is type-agnostic (everything is a string in HTTP), WebWork's type conversion features are very useful. For instance, if you were prompting a user to enter in coordinates in the form of a string (such as "3, 22"), you could have WebWork do the conversion both from String to Point and from Point to String.

Using this "point" example, if your action (or another compound object in which you are setting properties on) has a corresponding ClassName-conversion.properties file, WebWork will use the configured type converters for conversion to and from strings. So turning "3, 22" in to new Point(3, 22) is done by merely adding the following entry to ClassName-conversion.properties (Note that the PointConverter should impl the ognl.TypeConverter interface):

point = com.acme.PointConverter

Your type converter should be sure to check what class type it is being requested to convert. Because it is used for both to and from strings, you will need to split the conversion method in to two parts: one that turns Strings in to Points, and one that turns Points in to Strings.

After this is done, you can now reference your point (using <ww:property value="post"/> in JSP or ${point} in FreeMarker) and it will be printed as "3, 22" again. As such, if you submit this back to an action, it will be converted back to a Point once again.

In some situations you may wish to apply a type converter globally. This can be done by editing the file xwork-conversion.properties in the root of your class path (typically WEB-INF/classes) and providing a property in the form of the class name of the object you wish to convert on the left hand side and the class name of the type converter on the right hand side. For example, providing a type converter for all Point objects would mean adding the following entry:

com.acme.Point = com.acme.PointConverter

Type conversion should not be used as a substitute for i18n. It is not recommended to use this feature to print out properly formatted dates. Rather, you should use the i18n features of WebWork (and consult the JavaDocs for JDK's MessageFormat object) to see how a properly formatted date should be displayed.

Any error that occurs during type conversion may or may not wish to be reported. For example, reporting that the input "abc" could not be converted to a number might be important. On the other hand, reporting that an empty string, "", cannot be converted to a number might not be important - especially in a web environment where it is hard to distinguish between a user not entering a value vs. entering a blank value.

By default, all conversion errors are reported using the generic i18n key xwork.default.invalid.fieldvalue, which you can override (the default text is Invalid field value for field "xxx", where xxx is the field name) in your global i18n resource bundle.

However, sometimes you may wish to override this message on a per-field basis. You can do this by adding an i18n key associated with just your action (Action.properties) using the pattern invalid.fieldvalue.xxx, where xxx is the field name.

It is important to know that none of these errors are actually reported directly. Rather, they are added to a map called conversionErrors in the ActionContext. There are several ways this map can then be accessed and the errors can be reported accordingly.

Version:
$Date: 2006-11-17 13:38:31 +0100 (Fr, 17 Nov 2006) $ $Id: XWorkConverter.java 1214 2006-11-17 12:38:31Z rainerh $
Author:
Pat Lightbody, Rainer Hermanns, Alexandru Popescu, tm_jee
See Also:
XWorkBasicConverter

Field Summary
static String | CONVERSION_COLLECTION_PREFIX
static String | CONVERSION_ERROR_PROPERTY_PREFIX
static String | CONVERSION_PROPERTY_FULLNAME
protected HashMap<String,ognl.TypeConverter> | defaultMappings Record class and its type converter mapping.
protected ognl.TypeConverter | defaultTypeConverter
private static XWorkConverter | instance
static String | LAST_BEAN_CLASS_ACCESSED
static String | LAST_BEAN_PROPERTY_ACCESSED
protected static Log | LOG
protected HashMap<Class,Map<String,Object>> | mappings Target class conversion Mappings.
protected HashSet<Class> | noMapping Unavailable target class conversion mappings, serves as a simple cache.
protected ObjectTypeDeterminer | objectTypeDeterminer
static String | REPORT_CONVERSION_ERRORS
protected HashSet<String> | unknownMappings Record classes that doesn't have conversion mapping defined.
Constructor Summary
protected XWorkConverter()
Method Summary
private Object | acceptableErrorValue(Class toClass) not used
(package private) void | addConverterMapping(Map<String,Object> mapping, Class clazz) Looks for converter mappings for the specified class and adds it to an existing map.
static String | buildConverterFilename(Class clazz)
private Map<String,Object> | buildConverterMapping(Class clazz) Looks for converter mappings for the specified class, traversing up its class hierarchy and interfaces and adding any additional mappings it may find.
private Map<String,Object> | conditionalReload(Class clazz, Map<String,Object> oldValues)
Object | convertValue(Map map, Object o, Class aClass)
Object | convertValue(Map context, Object target, Member member, String property, Object value, Class toClass) Convert value from one form to another.
(package private) ognl.TypeConverter | createTypeConverter(String className)
private Object[] | getClassProperty(Map context)
static String | getConversionErrorMessage(String propertyName, ValueStack stack)
protected Object | getConverter(Class clazz, String property)
static XWorkConverter | getInstance()
ObjectTypeDeterminer | getObjectTypeDeterminer()
protected void | handleConversionException(Map context, String property, Object value, Object object)
void | loadConversionProperties(String propsName)
ognl.TypeConverter | lookup(Class clazz) Looks for a TypeConverter in the default mappings.
ognl.TypeConverter | lookup(String className) Looks for a TypeConverter in the default mappings.
(package private) ognl.TypeConverter | lookupSuper(Class clazz) Recurses through a class' interfaces and class hierarchy looking for a TypeConverter in the default mapping that can handle the specified class.
void | registerConverter(String className, ognl.TypeConverter converter)
void | registerConverterNotFound(String className)
static void | resetInstance()
void | setDefaultConverter(ognl.TypeConverter defaultTypeConverter)
static void | setInstance(XWorkConverter instance)
void | setObjectTypeDeterminer(ObjectTypeDeterminer determiner)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

private static XWorkConverter instance

LOG

protected static final Log LOG

REPORT_CONVERSION_ERRORS

public static final String REPORT_CONVERSION_ERRORS
See Also:
Constant Field Values

CONVERSION_PROPERTY_FULLNAME

public static final String CONVERSION_PROPERTY_FULLNAME
See Also:
Constant Field Values

CONVERSION_ERROR_PROPERTY_PREFIX

public static final String CONVERSION_ERROR_PROPERTY_PREFIX
See Also:
Constant Field Values

CONVERSION_COLLECTION_PREFIX

public static final String CONVERSION_COLLECTION_PREFIX
See Also:
Constant Field Values

LAST_BEAN_CLASS_ACCESSED

public static final String LAST_BEAN_CLASS_ACCESSED
See Also:
Constant Field Values

LAST_BEAN_PROPERTY_ACCESSED

public static final String LAST_BEAN_PROPERTY_ACCESSED
See Also:
Constant Field Values

mappings

protected HashMap<Class,Map<String,Object>> mappings
Target class conversion Mappings.
 Map>
  - Class -> convert to class
  - Map
    - String -> property name
                eg. Element_property, property etc.
    - Object -> String to represent properties
                eg. value part of
                    KeyProperty_property=id
             -> TypeConverter to represent an Ognl TypeConverter
                eg. value part of
                    property=foo.bar.MyConverter
             -> Class to represent a class
                eg. value part of
                    Element_property=foo.bar.MyObject

noMapping

protected HashSet<Class> noMapping
Unavailable target class conversion mappings, serves as a simple cache.

defaultMappings

protected HashMap<String,ognl.TypeConverter> defaultMappings
Record class and its type converter mapping.
 - String - classname as String
 - TypeConverter - instance of TypeConverter

unknownMappings

protected HashSet<String> unknownMappings
Record classes that doesn't have conversion mapping defined.
 - String -> classname as String

defaultTypeConverter

protected ognl.TypeConverter defaultTypeConverter

objectTypeDeterminer

protected ObjectTypeDeterminer objectTypeDeterminer
Constructor Detail

XWorkConverter

protected XWorkConverter()
Method Detail

getConversionErrorMessage

public static String getConversionErrorMessage(String propertyName,
                                               ValueStack stack)

getInstance

public static XWorkConverter getInstance()

setInstance

public static void setInstance(XWorkConverter instance)

buildConverterFilename

public static String buildConverterFilename(Class clazz)

resetInstance

public static void resetInstance()

setDefaultConverter

public void setDefaultConverter(ognl.TypeConverter defaultTypeConverter)

convertValue

public Object convertValue(Map map,
                           Object o,
                           Class aClass)
Overrides:
convertValue in class ognl.DefaultTypeConverter

convertValue

public Object convertValue(Map context,
                           Object target,
                           Member member,
                           String property,
                           Object value,
                           Class toClass)
Convert value from one form to another. Minimum requirement of arguments:
  • supplying context, toClass and value
  • supplying context, target and value.

Specified by:
convertValue in interface ognl.TypeConverter
Overrides:
convertValue in class ognl.DefaultTypeConverter
See Also:
TypeConverter.convertValue(java.util.Map, java.lang.Object, java.lang.reflect.Member, java.lang.String, java.lang.Object, java.lang.Class)

lookup

public ognl.TypeConverter lookup(String className)
Looks for a TypeConverter in the default mappings.

Parameters:
className - name of the class the TypeConverter must handle
Returns:
a TypeConverter to handle the specified class or null if none can be found

lookup

public ognl.TypeConverter lookup(Class clazz)
Looks for a TypeConverter in the default mappings.

Parameters:
clazz - the class the TypeConverter must handle
Returns:
a TypeConverter to handle the specified class or null if none can be found

getConverter

protected Object getConverter(Class clazz,
                              String property)

handleConversionException

protected void handleConversionException(Map context,
                                         String property,
                                         Object value,
                                         Object object)

registerConverter

public void registerConverter(String className,
                              ognl.TypeConverter converter)

registerConverterNotFound

public void registerConverterNotFound(String className)

getClassProperty

private Object[] getClassProperty(Map context)

acceptableErrorValue

private Object acceptableErrorValue(Class toClass)
not used

addConverterMapping

void addConverterMapping(Map<String,Object> mapping,
                         Class clazz)
Looks for converter mappings for the specified class and adds it to an existing map. Only new converters are added. If a converter is defined on a key that already exists, the converter is ignored.

Parameters:
mapping - an existing map to add new converter mappings to
clazz - class to look for converter mappings for

buildConverterMapping

private Map<String,Object> buildConverterMapping(Class clazz)
                                          throws Exception
Looks for converter mappings for the specified class, traversing up its class hierarchy and interfaces and adding any additional mappings it may find. Mappings lower in the hierarchy have priority over those higher in the hierarcy.

Parameters:
clazz - the class to look for converter mappings for
Returns:
the converter mappings
Throws:
Exception

conditionalReload

private Map<String,Object> conditionalReload(Class clazz,
                                             Map<String,Object> oldValues)
                                      throws Exception
Throws:
Exception

createTypeConverter

ognl.TypeConverter createTypeConverter(String className)
                                 throws Exception
Throws:
Exception

loadConversionProperties

public void loadConversionProperties(String propsName)
                              throws IOException
Throws:
IOException

lookupSuper

ognl.TypeConverter lookupSuper(Class clazz)
Recurses through a class' interfaces and class hierarchy looking for a TypeConverter in the default mapping that can handle the specified class.

Parameters:
clazz - the class the TypeConverter must handle
Returns:
a TypeConverter to handle the specified class or null if none can be found

getObjectTypeDeterminer

public ObjectTypeDeterminer getObjectTypeDeterminer()

setObjectTypeDeterminer

public void setObjectTypeDeterminer(ObjectTypeDeterminer determiner)
Parameters:
determiner -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkEnumerationAcccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkEnumerationAcccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  ognl.EnumerationPropertyAccessor
            extended by  com.opensymphony.xwork2.util.XWorkEnumerationAcccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkEnumerationAcccessor
extends ognl.EnumerationPropertyAccessor

Author:
plightbo

Field Summary
(package private)  ognl.ObjectPropertyAccessor opa
Constructor Summary
XWorkEnumerationAcccessor()
Method Summary
 void setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class ognl.EnumerationPropertyAccessor
getProperty
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

opa

ognl.ObjectPropertyAccessor opa
Constructor Detail

XWorkEnumerationAcccessor

public XWorkEnumerationAcccessor()
Method Detail

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.EnumerationPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkIteratorPropertyAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkIteratorPropertyAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  ognl.IteratorPropertyAccessor
            extended by  com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkIteratorPropertyAccessor
extends ognl.IteratorPropertyAccessor

Author:
plightbo

Field Summary
(package private)  ognl.ObjectPropertyAccessor opa
Constructor Summary
XWorkIteratorPropertyAccessor()
Method Summary
 void setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class ognl.IteratorPropertyAccessor
getProperty
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

opa

ognl.ObjectPropertyAccessor opa
Constructor Detail

XWorkIteratorPropertyAccessor

public XWorkIteratorPropertyAccessor()
Method Detail

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.IteratorPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkList (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkList

java.lang.Object
    extended by  java.util.AbstractCollection<E>
        extended by  java.util.AbstractList<E>
            extended by  java.util.ArrayList
                extended by  com.opensymphony.xwork2.util.XWorkList
All Implemented Interfaces:
Serializable, Cloneable, Iterable, Collection, List, RandomAccess
Deprecated. Native support for expanding lists and maps is provided in XWork 1.1, so this is no longer needed.

public class XWorkList
extends ArrayList

A simple list that guarantees that inserting and retrieving objects will always work regardless of the current size of the list. Upon insertion, type conversion is also performed if necessary. Empty beans will be created to fill the gap between the current list size and the requested index using ObjectFactory's buildBean method.

Author:
Patrick Lightbody
See Also:
Serialized Form

Field Summary
private Class | clazz Deprecated.
private static Log | LOG Deprecated.
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
XWorkList(Class clazz)
Deprecated.
XWorkList(Class clazz, Collection c)
Deprecated.
XWorkList(Class clazz, int initialCapacity)
Deprecated.
Method Summary
void | add(int index, Object element) Deprecated. Inserts the specified element at the specified position in this list.
boolean | add(Object element) Deprecated. Appends the specified element to the end of this list.
boolean | addAll(Collection c) Deprecated. Appends all of the elements in the specified Collection to the end of this list, in the order that they are returned by the specified Collection's Iterator.
boolean | addAll(int index, Collection c) Deprecated. Inserts all of the elements in the specified Collection into this list, starting at the specified position.
boolean | contains(Object element) Deprecated.
private Object | convert(Object element) Deprecated.
Object | get(int index) Deprecated. Returns the element at the specified position in this list.
Object | set(int index, Object element) Deprecated. Replaces the element at the specified position in this list with the specified element.
Methods inherited from class java.util.ArrayList
clear, clone, ensureCapacity, indexOf, isEmpty, lastIndexOf, remove, remove, removeRange, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

Field Detail

LOG

private static final Log LOG
Deprecated.

clazz

private Class clazz
Deprecated.
Constructor Detail

XWorkList

public XWorkList(Class clazz)
Deprecated.

XWorkList

public XWorkList(Class clazz,
                 Collection c)
Deprecated.

XWorkList

public XWorkList(Class clazz,
                 int initialCapacity)
Deprecated.
Method Detail

add

public void add(int index,
                Object element)
Deprecated.
Inserts the specified element at the specified position in this list. Shifts the element currently at that position (if any) and any subsequent elements to the right (adds one to their indices).

This method is guaranteed to work since it will create empty beans to fill the gap between the current list size and the requested index to enable the element to be set. This method also performs any necessary type conversion.

Specified by:
add in interface List
Overrides:
add in class ArrayList
Parameters:
index - index at which the specified element is to be inserted.
element - element to be inserted.

add

public boolean add(Object element)
Deprecated.
Appends the specified element to the end of this list.

This method performs any necessary type conversion.

Specified by:
add in interface Collection
Specified by:
add in interface List
Overrides:
add in class ArrayList
Parameters:
element - element to be appended to this list.
Returns:
true (as per the general contract of Collection.add).

addAll

public boolean addAll(Collection c)
Deprecated.
Appends all of the elements in the specified Collection to the end of this list, in the order that they are returned by the specified Collection's Iterator. The behavior of this operation is undefined if the specified Collection is modified while the operation is in progress. (This implies that the behavior of this call is undefined if the specified Collection is this list, and this list is nonempty.)

This method performs any necessary type conversion.

Specified by:
addAll in interface Collection
Specified by:
addAll in interface List
Overrides:
addAll in class ArrayList
Parameters:
c - the elements to be inserted into this list.
Returns:
true if this list changed as a result of the call.
Throws:
NullPointerException - if the specified collection is null.

addAll

public boolean addAll(int index,
                      Collection c)
Deprecated.
Inserts all of the elements in the specified Collection into this list, starting at the specified position. Shifts the element currently at that position (if any) and any subsequent elements to the right (increases their indices). The new elements will appear in the list in the order that they are returned by the specified Collection's iterator.

This method is guaranteed to work since it will create empty beans to fill the gap between the current list size and the requested index to enable the element to be set. This method also performs any necessary type conversion.

Specified by:
addAll in interface List
Overrides:
addAll in class ArrayList
Parameters:
index - index at which to insert first element from the specified collection.
c - elements to be inserted into this list.
Returns:
true if this list changed as a result of the call.

get

public Object get(int index)
Deprecated.
Returns the element at the specified position in this list.

An object is guaranteed to be returned since it will create empty beans to fill the gap between the current list size and the requested index.

Specified by:
get in interface List
Overrides:
get in class ArrayList
Parameters:
index - index of element to return.
Returns:
the element at the specified position in this list.

set

public Object set(int index,
                  Object element)
Deprecated.
Replaces the element at the specified position in this list with the specified element.

This method is guaranteed to work since it will create empty beans to fill the gap between the current list size and the requested index to enable the element to be set. This method also performs any necessary type conversion.

Specified by:
set in interface List
Overrides:
set in class ArrayList
Parameters:
index - index of element to replace.
element - element to be stored at the specified position.
Returns:
the element previously at the specified position.

convert

private Object convert(Object element)
Deprecated.

contains

public boolean contains(Object element)
Deprecated.
Specified by:
contains in interface Collection
Specified by:
contains in interface List
Overrides:
contains in class ArrayList
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkListPropertyAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkListPropertyAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  ognl.ListPropertyAccessor
            extended by  com.opensymphony.xwork2.util.XWorkListPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkListPropertyAccessor
extends ognl.ListPropertyAccessor

Overrides the list property accessor so in the case of trying to add properties of a given bean and the JavaBean is not present, this class will create the necessary blank JavaBeans.

Author:
Gabriel Zimmerman

Field Summary
private  XWorkCollectionPropertyAccessor _sAcc
Constructor Summary
XWorkListPropertyAccessor()
Method Summary
Object | getProperty(Map context, Object target, Object name)
private Object | getRealValue(Map context, Object value, Class convertToClass)
void | setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_sAcc

private XWorkCollectionPropertyAccessor _sAcc
Constructor Detail

XWorkListPropertyAccessor

public XWorkListPropertyAccessor()
Method Detail

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object name)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.ListPropertyAccessor
Throws:
ognl.OgnlException

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.ListPropertyAccessor
Throws:
ognl.OgnlException

getRealValue

private Object getRealValue(Map context,
                            Object value,
                            Class convertToClass)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkMap

java.lang.Object
    extended by  java.util.AbstractMap<K,V>
        extended by  java.util.HashMap
            extended by  com.opensymphony.xwork2.util.XWorkMap
All Implemented Interfaces:
Serializable, Cloneable, Map
Deprecated. Native support for expanding lists and maps is provided in XWork 1.1, so this is no longer needed.

public class XWorkMap
extends HashMap

A simple map that guarantees that retrieving objects will never return null and insertions will perform type conversion if necessary. Empty beans will be created for any key that would normally returned null using ObjectFactory's buildBean method.

Author:
Patrick Lightbody, Mark Woon
See Also:
Serialized Form

Field Summary
private  Class clazz
Deprecated.
Constructor Summary
XWorkMap(Class clazz)
Deprecated.
Method Summary
Object | get(Object key) Deprecated. Returns the value to which the specified key is mapped in this identity hash map.
Object | put(Object key, Object value) Deprecated. Associates the specified value with the specified key in this map.
void | putAll(Map m) Deprecated. Copies all of the mappings from the specified map to this map These mappings will replace any mappings that this map had for any of the keys currently in the specified map.
Methods inherited from class java.util.HashMap
clear, clone, containsKey, containsValue, entrySet, isEmpty, keySet, remove, size, values
Methods inherited from class java.util.AbstractMap
equals, hashCode, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Field Detail

clazz

private Class clazz
Deprecated.
Constructor Detail

XWorkMap

public XWorkMap(Class clazz)
Deprecated.
Method Detail

get

public Object get(Object key)
Deprecated.
Returns the value to which the specified key is mapped in this identity hash map. If there is no mapping for this key, create an appropriate object for this key, put it in the map, and return the new object. Use HashMap.containsKey(Object) to check if there really is a mapping for a key or not.

Specified by:
get in interface Map
Overrides:
get in class HashMap
Parameters:
key - the key whose associated value is to be returned.
Returns:
the value to which this map maps the specified key

put

public Object put(Object key,
                  Object value)
Deprecated.
Associates the specified value with the specified key in this map. If the map previously contained a mapping for this key, the old value is replaced.

Specified by:
put in interface Map
Overrides:
put in class HashMap
Parameters:
key - key with which the specified value is to be associated.
value - value to be associated with the specified key.
Returns:
previous value associated with specified key, or null if there was no mapping for key. A null return can also indicate that the HashMap previously associated null with the specified key.

putAll

public void putAll(Map m)
Deprecated.
Copies all of the mappings from the specified map to this map These mappings will replace any mappings that this map had for any of the keys currently in the specified map.

Specified by:
putAll in interface Map
Overrides:
putAll in class HashMap
Parameters:
m - mappings to be stored in this map.
Throws:
NullPointerException - if the specified map is null.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkMapPropertyAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkMapPropertyAccessor

java.lang.Object
    extended by  ognl.MapPropertyAccessor
        extended by  com.opensymphony.xwork2.util.XWorkMapPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkMapPropertyAccessor
extends ognl.MapPropertyAccessor

Implementation of PropertyAccessor that sets and gets properties by storing and looking up values in Maps.

Author:
Gabriel Zimmerman

Field Summary
private static XWorkConverter | _converter
private static Log | _log
private static String[] | INDEX_ACCESS_PROPS
Constructor Summary
XWorkMapPropertyAccessor()
Method Summary
private boolean | contains(String[] array, String name)
private Object | getKey(Map context, Object name)
Object | getProperty(Map context, Object target, Object name)
private Object | getValue(Map context, Object value)
void | setProperty(Map context, Object target, Object name, Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

INDEX_ACCESS_PROPS

private static final String[] INDEX_ACCESS_PROPS

_converter

private static final XWorkConverter _converter
Constructor Detail

XWorkMapPropertyAccessor

public XWorkMapPropertyAccessor()
Method Detail

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object name)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.MapPropertyAccessor
Throws:
ognl.OgnlException

contains

private boolean contains(String[] array,
                         String name)
Parameters:
array -
name -

setProperty

public void setProperty(Map context,
                        Object target,
                        Object name,
                        Object value)
                 throws ognl.OgnlException
Specified by:
setProperty in interface ognl.PropertyAccessor
Overrides:
setProperty in class ognl.MapPropertyAccessor
Throws:
ognl.OgnlException

getValue

private Object getValue(Map context,
                        Object value)

getKey

private Object getKey(Map context,
                      Object name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkMethodAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkMethodAccessor

java.lang.Object
    extended by  ognl.ObjectMethodAccessor
        extended by  com.opensymphony.xwork2.util.XWorkMethodAccessor
All Implemented Interfaces:
ognl.MethodAccessor
public class XWorkMethodAccessor
extends ognl.ObjectMethodAccessor

Allows methods to be executed under normal cirumstances, except when DENY_METHOD_EXECUTION is in the action context with a value of true.

Author:
Patrick Lightbody, tmjee

Field Summary
private static Log | _log
static String | DENY_INDEXED_ACCESS_EXECUTION
static String | DENY_METHOD_EXECUTION
Constructor Summary
XWorkMethodAccessor()
Method Summary
Object | callMethod(Map context, Object object, String string, Object[] objects)
Object | callStaticMethod(Map context, Class aClass, String string, Object[] objects)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

DENY_METHOD_EXECUTION

public static final String DENY_METHOD_EXECUTION
See Also:
Constant Field Values

DENY_INDEXED_ACCESS_EXECUTION

public static final String DENY_INDEXED_ACCESS_EXECUTION
See Also:
Constant Field Values
Constructor Detail

XWorkMethodAccessor

public XWorkMethodAccessor()
Method Detail

callMethod

public Object callMethod(Map context,
                         Object object,
                         String string,
                         Object[] objects)
                  throws ognl.MethodFailedException
Specified by:
callMethod in interface ognl.MethodAccessor
Overrides:
callMethod in class ognl.ObjectMethodAccessor
Throws:
ognl.MethodFailedException

callStaticMethod

public Object callStaticMethod(Map context,
                               Class aClass,
                               String string,
                               Object[] objects)
                        throws ognl.MethodFailedException
Specified by:
callStaticMethod in interface ognl.MethodAccessor
Overrides:
callStaticMethod in class ognl.ObjectMethodAccessor
Throws:
ognl.MethodFailedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkObjectPropertyAccessor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkObjectPropertyAccessor

java.lang.Object
    extended by  ognl.ObjectPropertyAccessor
        extended by  com.opensymphony.xwork2.util.XWorkObjectPropertyAccessor
All Implemented Interfaces:
ognl.PropertyAccessor
public class XWorkObjectPropertyAccessor
extends ognl.ObjectPropertyAccessor

Author:
Gabe

Constructor Summary
XWorkObjectPropertyAccessor()
Method Summary
 Object getProperty(Map context, Object target, Object oname)
Methods inherited from class ognl.ObjectPropertyAccessor
getPossibleProperty, hasGetProperty, hasGetProperty, hasSetProperty, hasSetProperty, setPossibleProperty, setProperty
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkObjectPropertyAccessor

public XWorkObjectPropertyAccessor()
Method Detail

getProperty

public Object getProperty(Map context,
                          Object target,
                          Object oname)
                   throws ognl.OgnlException
Specified by:
getProperty in interface ognl.PropertyAccessor
Overrides:
getProperty in class ognl.ObjectPropertyAccessor
Throws:
ognl.OgnlException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XWorkTestCaseHelper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class XWorkTestCaseHelper

java.lang.Object
    extended by  com.opensymphony.xwork2.util.XWorkTestCaseHelper

public class XWorkTestCaseHelper
extends Object

Generic test setup methods to be used with any unit testing framework.

Constructor Summary
XWorkTestCaseHelper()
Method Summary
static ConfigurationManager | loadConfigurationProviders(ConfigurationManager configurationManager, ConfigurationProvider... providers)
static ConfigurationManager | setUp()
static void | tearDown(ConfigurationManager configurationManager)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XWorkTestCaseHelper

public XWorkTestCaseHelper()
Method Detail

setUp

public static ConfigurationManager setUp()
                                  throws Exception
Throws:
Exception

loadConfigurationProviders

public static ConfigurationManager loadConfigurationProviders(ConfigurationManager configurationManager,
                                                              ConfigurationProvider... providers)

tearDown

public static void tearDown(ConfigurationManager configurationManager)
                     throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


TypeConversionException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class TypeConversionException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
                    extended by  com.opensymphony.xwork2.util.TypeConversionException
All Implemented Interfaces:
Locatable, Serializable
public class TypeConversionException
extends XWorkException

TypeConversionException should be thrown by any TypeConverters which fail to convert values

Author:
Jason Carreira Created Oct 3, 2003 12:18:33 AM
See Also:
Serialized Form

Constructor Summary
TypeConversionException()
Constructs a XWorkException with no detail message.
TypeConversionException(String s)
Constructs a XWorkException with the specified detail message.
TypeConversionException(String s, Throwable cause)
Constructs a XWorkException with the specified detail message.
TypeConversionException(Throwable cause)
Constructs a XWorkException with no detail message.
Method Summary
Methods inherited from class com.opensymphony.xwork2.XWorkException
getLocation, getThrowable, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

TypeConversionException

public TypeConversionException()
Constructs a XWorkException with no detail message.

TypeConversionException

public TypeConversionException(String s)
Constructs a XWorkException with the specified detail message.

Parameters:
s - the detail message.

TypeConversionException

public TypeConversionException(Throwable cause)
Constructs a XWorkException with no detail message.

TypeConversionException

public TypeConversionException(String s,
                               Throwable cause)
Constructs a XWorkException with the specified detail message.

Parameters:
s - the detail message.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CreateIfNull (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.util
Annotation Type CreateIfNull

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface CreateIfNull

Sets the CreateIfNull for type conversion.

Annotation usage:

The CreateIfNull annotation must be applied at field or method level.

Annotation parameters:

Parameter | Required | Default | Description
value | no | false | The CreateIfNull property value.

Example code:

 @CreateIfNull( value = true )
 private List users;

Version:
$Id: CreateIfNull.java 1350 2007-02-16 09:07:53Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
 boolean value
The CreateIfNull value.

value

public abstract boolean value
The CreateIfNull value. Defaults to false.

Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Element (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.util
Annotation Type Element

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface Element

Sets the Element for type conversion.

Annotation usage:

The Element annotation must be applied at field or method level.

Annotation parameters:

Parameter | Required | Default | Description
value | no | java.lang.Object.class | The element property value.

Example code:

 // The key property for User objects within the users collection is the userName attribute.
 @Element( value = com.acme.User )
 private Map userMap;

 @Element( value = com.acme.User )
 public List userList;

Version:
$Id: Element.java 1350 2007-02-16 09:07:53Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
 Class value
The Element value.

value

public abstract Class value
The Element value. Defaults to java.lang.Object.class.

Default:
java.lang.Object.class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Key (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.util
Annotation Type Key

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface Key

Sets the Key for type conversion.

Annotation usage:

The Key annotation must be applied at field or method level.

Annotation parameters:

Parameter | Required | Default | Description
value | no | java.lang.Object.class | The key property value.

Example code:

 // The key property for User objects within the users collection is the userName attribute.
 @Key( value = java.lang.Long.class )
 private Map userMap;

Version:
$Id: Key.java 1350 2007-02-16 09:07:53Z rainerh $
Author:
Rainer Hermanns

Optional Element Summary
 Class value
The Key value.

value

public abstract Class value
The Key value. Defaults to java.lang.Object.class.

Default:
java.lang.Object.class
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


KeyProperty (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.util
Annotation Type KeyProperty

@Retention(value=RUNTIME)
@Target(value={FIELD,METHOD})
public @interface KeyProperty

Sets the KeyProperty for type conversion.

Annotation usage:

The KeyProperty annotation must be applied at field or method level.

This annotation should be used with Generic types, if the key property of the key element needs to be specified.

Annotation parameters:

Parameter | Required | Default | Description
value | no | id | The key property value.

Example code:

 // The key property for User objects within the users collection is the userName attribute.
 @KeyProperty( value = "userName" )
 protected List users = null;

Author:
Patrick Lightbody, Rainer Hermanns

Optional Element Summary
 String value
The KeyProperty value.

value

public abstract String value
The KeyProperty value. Defaults to the id attribute.

Default:
"id"
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


com.opensymphony.xwork2.util.location (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.location

Classes and utilities used to track location information.

See:
Description

Interface Summary
Locatable | A interface that should be implemented by objects knowning their location (i.e.
Location | A location in a resource.
LocationUtils.LocationFinder | An finder or object locations

Class Summary
LocatableProperties | Properties implementation that remembers the location of each property.
Located | Base class for location aware objects
LocationAttributes | A class to handle location information stored in attributes.
LocationAttributes.Pipe | A SAX filter that adds the information available from the Locator as attributes.
LocationImpl | A simple immutable and serializable implementation of Location.
LocationUtils | Location-related utility methods.

Package com.opensymphony.xwork2.util.location Description

Classes and utilities used to track location information.


com.opensymphony.xwork2.util.location Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.location

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • com.opensymphony.xwork2.util.location.LocatableProperties (implements com.opensymphony.xwork2.util.location.Locatable)
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
    • com.opensymphony.xwork2.util.location.LocationAttributes
    • com.opensymphony.xwork2.util.location.LocationAttributes.Pipe (implements org.xml.sax.ContentHandler)
    • com.opensymphony.xwork2.util.location.LocationImpl (implements com.opensymphony.xwork2.util.location.Location, java.io.Serializable)
    • com.opensymphony.xwork2.util.location.LocationUtils

Interface Hierarchy

  • com.opensymphony.xwork2.util.location.Locatable
  • com.opensymphony.xwork2.util.location.Location
  • com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder


Uses of Package com.opensymphony.xwork2.util.location (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.util.location

Packages that use com.opensymphony.xwork2.util.location
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.util.location | Classes and utilities used to track location information.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Location
A location in a resource.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.config
Locatable
A interface that should be implemented by objects knowning their location (i.e.
LocatableProperties
Properties implementation that remembers the location of each property.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.config.entities
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Located
Base class for location aware objects

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.config.impl
Locatable
A interface that should be implemented by objects knowning their location (i.e.
LocatableProperties
Properties implementation that remembers the location of each property.
Located
Base class for location aware objects

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.config.providers
LocatableProperties
Properties implementation that remembers the location of each property.
Location
A location in a resource.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.util
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Location
A location in a resource.

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.util.location
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Location
A location in a resource.
LocationImpl
A simple immutable and serializable implementation of Location.
LocationUtils.LocationFinder
An finder or object locations

Classes in com.opensymphony.xwork2.util.location used by com.opensymphony.xwork2.validator
Locatable
A interface that should be implemented by objects knowning their location (i.e.
Located
Base class for location aware objects

Classes in com.opensymphony.xwork2.util.location used by org.apache.struts2
Locatable
A interface that should be implemented by objects knowning their location (i.e.

Classes in com.opensymphony.xwork2.util.location used by org.apache.struts2.config
LocatableProperties
Properties implementation that remembers the location of each property.
Location
A location in a resource.

Classes in com.opensymphony.xwork2.util.location used by org.apache.struts2.dispatcher
Location
A location in a resource.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Locatable (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Interface Locatable

All Known Implementing Classes:
ActionConfig, ConfigurationException, DefaultConfiguration.ContainerProperties, ExceptionMappingConfig, InterceptorConfig, InterceptorStackConfig, LocatableConstantFactory, LocatableFactory, LocatableProperties, Located, PackageConfig, ReferenceResolverException, ResultConfig, ResultTypeConfig, StrutsException, TypeConversionException, ValidatorConfig, XWorkException
public interface Locatable

A interface that should be implemented by objects knowning their location (i.e. where they have been created from).

Method Summary
 Location getLocation()
Get the location of this object

Method Detail

getLocation

Location getLocation()
Get the location of this object

Returns:
the location
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Location (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Interface Location

All Known Implementing Classes:
LocationImpl
public interface Location

A location in a resource. The location is composed of the URI of the resource, and the line and column numbers within that resource (when available), along with a description.

Locations are mostly provided by Locatables objects.

Field Summary
static Location UNKNOWN
Constant for unknown locations.
Method Summary
int | getColumnNumber() Get the column number of this location
String | getDescription() Get the description of this location
int | getLineNumber() Get the line number of this location
List | getSnippet(int padding) Gets a source code snippet with the default padding
String | getURI() Get the URI of this location

Field Detail

UNKNOWN

static final Location UNKNOWN
Constant for unknown locations.

Method Detail

getDescription

String getDescription()
Get the description of this location

Returns:
the description (can be null)

getURI

String getURI()
Get the URI of this location

Returns:
the URI (null if unknown).

getLineNumber

int getLineNumber()
Get the line number of this location

Returns:
the line number (-1 if unknown)

getColumnNumber

int getColumnNumber()
Get the column number of this location

Returns:
the column number (-1 if unknown)

getSnippet

List getSnippet(int padding)
Gets a source code snippet with the default padding

Parameters:
padding - The amount of lines before and after the error to include
Returns:
A list of source lines
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocatableProperties (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocatableProperties

java.lang.Object
    extended by  java.util.Dictionary<K,V>
        extended by  java.util.Hashtable<Object,Object>
            extended by  java.util.Properties
                extended by  com.opensymphony.xwork2.util.location.LocatableProperties
All Implemented Interfaces:
Locatable, Serializable, Cloneable, Map<Object,Object>
Direct Known Subclasses:
DefaultConfiguration.ContainerProperties
public class LocatableProperties
extends Properties
implements Locatable

Properties implementation that remembers the location of each property. When loaded, a custom properties file parser is used to remember both the line number and preceeding comments for each property entry.

See Also:
Serialized Form

Field Summary
(package private) Location | location
(package private) Map<String,Location> | propLocations
Fields inherited from class java.util.Properties
defaults
Constructor Summary
LocatableProperties()
LocatableProperties(Location loc)
Method Summary
(package private) String | convertCommentsToString(List<String> lines)
Location | getLocation() Get the location of this object
Location | getPropertyLocation(String key)
void | load(InputStream in)
Object | setProperty(String key, String value, Object locationObj)
Methods inherited from class java.util.Properties
getProperty, getProperty, list, list, loadFromXML, propertyNames, save, setProperty, store, storeToXML, storeToXML
Methods inherited from class java.util.Hashtable
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

location

Location location

propLocations

Map<String,Location> propLocations
Constructor Detail

LocatableProperties

public LocatableProperties()

LocatableProperties

public LocatableProperties(Location loc)
Method Detail

load

public void load(InputStream in)
          throws IOException
Overrides:
load in class Properties
Throws:
IOException

convertCommentsToString

String convertCommentsToString(List<String> lines)

setProperty

public Object setProperty(String key,
                          String value,
                          Object locationObj)

getPropertyLocation

public Location getPropertyLocation(String key)

getLocation

public Location getLocation()
Description copied from interface: Locatable
Get the location of this object

Specified by:
getLocation in interface Locatable
Returns:
the location
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Located (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class Located

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
All Implemented Interfaces:
Locatable
Direct Known Subclasses:
ActionConfig, ExceptionMappingConfig, InterceptorConfig, InterceptorStackConfig, LocatableConstantFactory, LocatableFactory, PackageConfig, ResultConfig, ResultTypeConfig, ValidatorConfig
public abstract class Located
extends Object
implements Locatable

Base class for location aware objects

Field Summary
protected  Location location
Constructor Summary
Located()
Method Summary
Location | getLocation() Get the location of this object
void | setLocation(Location loc) Set the location of this object
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

location

protected Location location
Constructor Detail

Located

public Located()
Method Detail

getLocation

public Location getLocation()
Get the location of this object

Specified by:
getLocation in interface Locatable
Returns:
the location

setLocation

public void setLocation(Location loc)
Set the location of this object

Parameters:
loc - the location
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationAttributes (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocationAttributes

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.LocationAttributes

public class LocationAttributes
extends Object

A class to handle location information stored in attributes. These attributes are typically setup using LocationAttributes.Pipe which augments the SAX stream with additional attributes, e.g.:

 <root xmlns:loc="http://opensymphony.com/xwork/location"
       loc:src="file://path/to/file.xml"
       loc:line="1" loc:column="1">
   <foo loc:src="file://path/to/file.xml" loc:line="2" loc:column="3"/>
 </root>

Since:
2.1.8
Version:
$Id: LocationAttributes.java 1223 2006-11-23 20:33:15Z rainerh $
See Also:
LocationAttributes.Pipe

Nested Class Summary
static class LocationAttributes.Pipe
A SAX filter that adds the information available from the Locator as attributes.
Field Summary
static String | COL_ATTR Attribute name for the column number
static String | LINE_ATTR Attribute name for the line number
static String | PREFIX Prefix for the location namespace
static String | Q_COL_ATTR Attribute qualified name for the column number
static String | Q_LINE_ATTR Attribute qualified name for the line number
static String | Q_SRC_ATTR Attribute qualified name for the location URI
static String | SRC_ATTR Attribute name for the location URI
static String | URI Namespace URI for location attributes
Constructor Summary
private LocationAttributes()
Method Summary
static Attributes | addLocationAttributes(Locator locator, Attributes attrs) Add location attributes to a set of SAX attributes.
static int | getColumn(Attributes attrs) Returns the column number of an element (SAX flavor)
static int | getColumn(Element elem) Returns the column number of an element (DOM flavor)
static int | getLine(Attributes attrs) Returns the line number of an element (SAX flavor)
static int | getLine(Element elem) Returns the line number of an element (DOM flavor)
static Location | getLocation(Attributes attrs, String description) Returns the Location of an element (SAX flavor).
static Location | getLocation(Element elem) Same as getLocation(elem, null).
static Location | getLocation(Element elem, String description) Returns the Location of an element (DOM flavor).
static String | getLocationString(Attributes attrs) Returns the location of an element (SAX flavor).
static String | getLocationString(Element elem) Returns the location of an element that has been processed by this pipe (DOM flavor).
static String | getURI(Attributes attrs) Returns the URI of an element (SAX flavor)
static String | getURI(Element elem) Returns the URI of an element (DOM flavor)
static void | remove(Element elem, boolean recurse) Remove the location attributes from a DOM element.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

PREFIX

public static final String PREFIX
Prefix for the location namespace

See Also:
Constant Field Values

URI

public static final String URI
Namespace URI for location attributes

See Also:
Constant Field Values

SRC_ATTR

public static final String SRC_ATTR
Attribute name for the location URI

See Also:
Constant Field Values

LINE_ATTR

public static final String LINE_ATTR
Attribute name for the line number

See Also:
Constant Field Values

COL_ATTR

public static final String COL_ATTR
Attribute name for the column number

See Also:
Constant Field Values

Q_SRC_ATTR

public static final String Q_SRC_ATTR
Attribute qualified name for the location URI

See Also:
Constant Field Values

Q_LINE_ATTR

public static final String Q_LINE_ATTR
Attribute qualified name for the line number

See Also:
Constant Field Values

Q_COL_ATTR

public static final String Q_COL_ATTR
Attribute qualified name for the column number

See Also:
Constant Field Values
Constructor Detail

LocationAttributes

private LocationAttributes()
Method Detail

addLocationAttributes

public static Attributes addLocationAttributes(Locator locator,
                                               Attributes attrs)
Add location attributes to a set of SAX attributes.

Parameters:
locator - the Locator (can be null)
attrs - the Attributes where locator information should be added
Returns:
Location enabled Attributes.

getLocation

public static Location getLocation(Attributes attrs,
                                   String description)
Returns the Location of an element (SAX flavor).

Parameters:
attrs - the element's attributes that hold the location information
description - a description for the location (can be null)
Returns:
a Location object

getLocationString

public static String getLocationString(Attributes attrs)
Returns the location of an element (SAX flavor). If the location is to be kept into an object built from this element, consider using getLocation(Attributes, String) and the Locatable interface.

Parameters:
attrs - the element's attributes that hold the location information
Returns:
a location string as defined by Location.

getURI

public static String getURI(Attributes attrs)
Returns the URI of an element (SAX flavor)

Parameters:
attrs - the element's attributes that hold the location information
Returns:
the element's URI or "[unknown location]" if attrs has no location information.

getLine

public static int getLine(Attributes attrs)
Returns the line number of an element (SAX flavor)

Parameters:
attrs - the element's attributes that hold the location information
Returns:
the element's line number or -1 if attrs has no location information.

getColumn

public static int getColumn(Attributes attrs)
Returns the column number of an element (SAX flavor)

Parameters:
attrs - the element's attributes that hold the location information
Returns:
the element's column number or -1 if attrs has no location information.

getLocation

public static Location getLocation(Element elem,
                                   String description)
Returns the Location of an element (DOM flavor).

Parameters:
elem - the element that holds the location information
description - a description for the location (if null, the element's name is used)
Returns:
a Location object

getLocation

public static Location getLocation(Element elem)
Same as getLocation(elem, null).

getLocationString

public static String getLocationString(Element elem)
Returns the location of an element that has been processed by this pipe (DOM flavor). If the location is to be kept into an object built from this element, consider using getLocation(Element) and the Locatable interface.

Parameters:
elem - the element that holds the location information
Returns:
a location string as defined by Location.

getURI

public static String getURI(Element elem)
Returns the URI of an element (DOM flavor)

Parameters:
elem - the element that holds the location information
Returns:
the element's URI or "[unknown location]" if elem has no location information.

getLine

public static int getLine(Element elem)
Returns the line number of an element (DOM flavor)

Parameters:
elem - the element that holds the location information
Returns:
the element's line number or -1 if elem has no location information.

getColumn

public static int getColumn(Element elem)
Returns the column number of an element (DOM flavor)

Parameters:
elem - the element that holds the location information
Returns:
the element's column number or -1 if elem has no location information.

remove

public static void remove(Element elem,
                          boolean recurse)
Remove the location attributes from a DOM element.

Parameters:
elem - the element to remove the location attributes from.
recurse - if true, also remove location attributes on descendant elements.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationAttributes.Pipe (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocationAttributes.Pipe

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
All Implemented Interfaces:
ContentHandler
Enclosing class:
LocationAttributes
public static class LocationAttributes.Pipe
extends Object
implements ContentHandler

A SAX filter that adds the information available from the Locator as attributes. The purpose of having location as attributes is to allow this information to survive transformations of the document (an XSL could copy these attributes over) or conversion of SAX events to a DOM.

The location is added as 3 attributes in a specific namespace to each element.

 <root xmlns:loc="http://opensymphony.com/xwork/location"
       loc:src="file://path/to/file.xml"
       loc:line="1" loc:column="1">
   <foo loc:src="file://path/to/file.xml" loc:line="2" loc:column="3"/>
 </root>
Note: Although this adds a lot of information to the serialized form of the document, the overhead in SAX events is not that big, as attribute names are interned, and all src attributes point to the same string.

See Also:
LocationAttributes

Field Summary
private Locator | locator
private ContentHandler | nextHandler
Constructor Summary
LocationAttributes.Pipe()
Create a filter.
LocationAttributes.Pipe(ContentHandler next)
Create a filter that is chained to another handler.
Method Summary
void | characters(char[] arg0, int arg1, int arg2)
void | endDocument()
void | endElement(String arg0, String arg1, String arg2)
void | endPrefixMapping(String arg0)
void | ignorableWhitespace(char[] arg0, int arg1, int arg2)
void | processingInstruction(String arg0, String arg1)
void | setDocumentLocator(Locator locator)
void | skippedEntity(String arg0)
void | startDocument()
void | startElement(String uri, String loc, String raw, Attributes attrs)
void | startPrefixMapping(String arg0, String arg1)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

locator

private Locator locator

nextHandler

private ContentHandler nextHandler
Constructor Detail

LocationAttributes.Pipe

public LocationAttributes.Pipe()
Create a filter. It has to be chained to another handler to be really useful.

LocationAttributes.Pipe

public LocationAttributes.Pipe(ContentHandler next)
Create a filter that is chained to another handler.

Parameters:
next - the next handler in the chain.
Method Detail

setDocumentLocator

public void setDocumentLocator(Locator locator)
Specified by:
setDocumentLocator in interface ContentHandler

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Throws:
SAXException

startElement

public void startElement(String uri,
                         String loc,
                         String raw,
                         Attributes attrs)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Throws:
SAXException

endElement

public void endElement(String arg0,
                       String arg1,
                       String arg2)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String arg0,
                               String arg1)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String arg0)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Throws:
SAXException

characters

public void characters(char[] arg0,
                       int arg1,
                       int arg2)
                throws SAXException
Specified by:
characters in interface ContentHandler
Throws:
SAXException

ignorableWhitespace

public void ignorableWhitespace(char[] arg0,
                                int arg1,
                                int arg2)
                         throws SAXException
Specified by:
ignorableWhitespace in interface ContentHandler
Throws:
SAXException

processingInstruction

public void processingInstruction(String arg0,
                                  String arg1)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Throws:
SAXException

skippedEntity

public void skippedEntity(String arg0)
                   throws SAXException
Specified by:
skippedEntity in interface ContentHandler
Throws:
SAXException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationImpl (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocationImpl

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.LocationImpl
All Implemented Interfaces:
Location, Serializable
public class LocationImpl
extends Object
implements Location, Serializable

A simple immutable and serializable implementation of Location.

See Also:
Serialized Form

Field Summary
private int | column
private String | description
private int | line
(package private) static LocationImpl | UNKNOWN
private String | uri
Constructor Summary
LocationImpl(Location location)
Copy constructor.
LocationImpl(String description, Location location)
Create a location from an existing one, but with a different description
LocationImpl(String description, String uri)
Build a location for a given URI, with unknown line and column numbers.
LocationImpl(String description, String uri, int line, int column)
Build a location for a given URI and line and column numbers.
Method Summary
boolean | equals(Object obj)
static LocationImpl | get(Location location) Obtain a LocationImpl from a Location.
int | getColumnNumber() Get the column number of this location
String | getDescription() Get the description of this location
int | getLineNumber() Get the line number of this location
List | getSnippet(int padding) Gets a source code snippet with the default padding
String | getURI() Get the URI of this location
int | hashCode()
private Object | readResolve() Ensure serialized unknown location resolve to Location.UNKNOWN.
private boolean | testEquals(Object object1, Object object2)
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

uri

private final String uri

line

private final int line

column

private final int column

description

private final String description

UNKNOWN

static final LocationImpl UNKNOWN
Constructor Detail

LocationImpl

public LocationImpl(String description,
                    String uri)
Build a location for a given URI, with unknown line and column numbers.

Parameters:
uri - the resource URI

LocationImpl

public LocationImpl(String description,
                    String uri,
                    int line,
                    int column)
Build a location for a given URI and line and column numbers.

Parameters:
uri - the resource URI
line - the line number (starts at 1)
column - the column number (starts at 1)

LocationImpl

public LocationImpl(Location location)
Copy constructor.

Parameters:
location - the location to be copied

LocationImpl

public LocationImpl(String description,
                    Location location)
Create a location from an existing one, but with a different description

Method Detail

get

public static LocationImpl get(Location location)
Obtain a LocationImpl from a Location. If location is already a LocationImpl, it is returned, otherwise it is copied.

This method is useful when an immutable and serializable location is needed, such as in locatable exceptions.

Parameters:
location - the location
Returns:
an immutable and serializable version of location

getDescription

public String getDescription()
Get the description of this location

Specified by:
getDescription in interface Location
Returns:
the description (can be null)

getURI

public String getURI()
Get the URI of this location

Specified by:
getURI in interface Location
Returns:
the URI (null if unknown).

getLineNumber

public int getLineNumber()
Get the line number of this location

Specified by:
getLineNumber in interface Location
Returns:
the line number (-1 if unknown)

getColumnNumber

public int getColumnNumber()
Get the column number of this location

Specified by:
getColumnNumber in interface Location
Returns:
the column number (-1 if unknown)

getSnippet

public List getSnippet(int padding)
Gets a source code snippet with the default padding

Specified by:
getSnippet in interface Location
Parameters:
padding - The amount of lines before and after the error to include
Returns:
A list of source lines

equals

public boolean equals(Object obj)
Overrides:
equals in class Object

hashCode

public int hashCode()
Overrides:
hashCode in class Object

toString

public String toString()
Overrides:
toString in class Object

readResolve

private Object readResolve()
Ensure serialized unknown location resolve to Location.UNKNOWN.

testEquals

private boolean testEquals(Object object1,
                           Object object2)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationUtils (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Class LocationUtils

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.LocationUtils

public class LocationUtils
extends Object

Location-related utility methods.

Nested Class Summary
static interface LocationUtils.LocationFinder
An finder or object locations
Field Summary
private static List | finders
static String | UNKNOWN_STRING The string representation of an unknown location: "[unknown location]".
Constructor Summary
private LocationUtils()
Method Summary
static void addFinder(LocationUtils.LocationFinder finder)
Add a LocationUtils.LocationFinder to the list of finders that will be queried for an object's location by getLocation(Object, String).
static Location getLocation(Object obj)
Get the location of an object.
static Location getLocation(Object obj, String description)
Get the location of an object.
static boolean isKnown(Location location)
Checks if a location is known, i.e.
static boolean isUnknown(Location location)
Checks if a location is unknown, i.e.
static LocationImpl parse(String text)
Parse a location string of the form "uri:line:column" (e.g.
static String toString(Location location)
Builds a string representation of a location, in the "descripton - uri:line:column" format (e.g.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

UNKNOWN_STRING

public static final String UNKNOWN_STRING
The string representation of an unknown location: "[unknown location]".

See Also:
Constant Field Values

finders

private static List finders
Constructor Detail

LocationUtils

private LocationUtils()
Method Detail

toString

public static String toString(Location location)
Builds a string representation of a location, in the "descripton - uri:line:column" format (e.g. "foo - file://path/to/file.xml:3:40"). For an unknown location, returns UNKNOWN_STRING.

Returns:
the string representation

parse

public static LocationImpl parse(String text)
                          throws IllegalArgumentException
Parse a location string of the form "uri:line:column" (e.g. "path/to/file.xml:3:40") to a Location object. Additionally, a description may also optionally be present, separated with an hyphen (e.g. "foo - path/to/file.xml:3.40").

Parameters:
text - the text to parse
Returns:
the location (possibly null if text was null or in an incorrect format)
Throws:
IllegalArgumentException

isKnown

public static boolean isKnown(Location location)
Checks if a location is known, i.e. it is not null nor equal to Location.UNKNOWN.

Parameters:
location - the location to check
Returns:
true if the location is known

isUnknown

public static boolean isUnknown(Location location)
Checks if a location is unknown, i.e. it is either null or equal to Location.UNKNOWN.

Parameters:
location - the location to check
Returns:
true if the location is unknown

addFinder

public static void addFinder(LocationUtils.LocationFinder finder)
Add a LocationUtils.LocationFinder to the list of finders that will be queried for an object's location by getLocation(Object, String).

Important: LocationUtils internally stores a weak reference to the finder. This avoids creating strong links between the classloader holding this class and the finder's classloader, which can cause some weird memory leaks if the finder's classloader is to be reloaded. Therefore, you have to keep a strong reference to the finder in the calling code, e.g.:

   private static LocationUtils.LocationFinder myFinder =
       new LocationUtils.LocationFinder() {
           public Location getLocation(Object obj, String desc) {
               ...
           }
       };

   static {
       LocationUtils.addFinder(myFinder);
   }

Parameters:
finder - the location finder to add

getLocation

public static Location getLocation(Object obj)
Get the location of an object. Some well-known located classes built in the JDK are handled by this method. Handling of other located classes can be handled by adding new location finders.

Parameters:
obj - the object of which to get the location
Returns:
the object's location, or Location.UNKNOWN if no location could be found

getLocation

public static Location getLocation(Object obj,
                                   String description)
Get the location of an object. Some well-known located classes built in the JDK are handled by this method. Handling of other located classes can be handled by adding new location finders.

Parameters:
obj - the object of which to get the location
description - an optional description of the object's location, used if a Location object has to be created.
Returns:
the object's location, or Location.UNKNOWN if no location could be found
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LocationUtils.LocationFinder (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.location
Interface LocationUtils.LocationFinder

Enclosing class:
LocationUtils
public static interface LocationUtils.LocationFinder

An finder or object locations

Method Summary
 Location getLocation(Object obj, String description)
Get the location of an object

Method Detail

getLocation

Location getLocation(Object obj,
                     String description)
Get the location of an object

Parameters:
obj - the object for which to find a location
description - and optional description to be added to the object's location
Returns:
the object's location or null if object's class isn't handled by this finder.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util.profiling (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.util.profiling

Classes to enable profiling of action execution.

See:
Description

Interface Summary
UtilTimerStack.ProfilingBlock<T> A callback interface where code subjected to profile is to be executed.

Class Summary
ObjectProfiler |
ProfilingTimerBean | Bean to contain information about the pages profiled
TimerInvocationHandler |
UtilTimerStack | A timer stack.

Package com.opensymphony.xwork2.util.profiling Description

Classes to enable profiling of action execution.


com.opensymphony.xwork2.util.profiling Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.util.profiling

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.util.profiling.ObjectProfiler
    • com.opensymphony.xwork2.util.profiling.ProfilingTimerBean (implements java.io.Serializable)
    • com.opensymphony.xwork2.util.profiling.TimerInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • com.opensymphony.xwork2.util.profiling.UtilTimerStack

Interface Hierarchy

  • com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock<T>


Uses of Package com.opensymphony.xwork2.util.profiling (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.util.profiling

Packages that use com.opensymphony.xwork2.util.profiling
com.opensymphony.xwork2.util.profiling Classes to enable profiling of action execution.

Classes in com.opensymphony.xwork2.util.profiling used by com.opensymphony.xwork2.util.profiling
ProfilingTimerBean
Bean to contain information about the pages profiled
UtilTimerStack.ProfilingBlock
A callback interface where code subjected to profile is to be executed.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ObjectProfiler (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Class ObjectProfiler

java.lang.Object
    extended by  com.opensymphony.xwork2.util.profiling.ObjectProfiler

public class ObjectProfiler
extends Object

Author:
Scott Farquhar

Constructor Summary
ObjectProfiler()
Method Summary
static Object getProfiledObject(Class interfaceClazz, Object o)
Given a class, and an interface that it implements, return a proxied version of the class that implements the interface.
static String getTrimmedClassName(Method method)
Given a method, get the Method name, with no package information.
static Object profiledInvoke(Method target, Object value, Object[] args)
A profiled call Method.invoke(java.lang.Object, java.lang.Object[]).
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ObjectProfiler

public ObjectProfiler()
Method Detail

getProfiledObject

public static Object getProfiledObject(Class interfaceClazz,
                                       Object o)
Given a class, and an interface that it implements, return a proxied version of the class that implements the interface.

The usual use of this is to profile methods from Factory objects:

 public PersistenceManager getPersistenceManager()
 {
   return new DefaultPersistenceManager();
 }

 instead write:
 public PersistenceManager getPersistenceManager()
 {
   return ObjectProfiler.getProfiledObject(PersistenceManager.class, new DefaultPersistenceManager());
 }

A side effect of this is that you will no longer be able to downcast to DefaultPersistenceManager. This is probably a *good* thing.

Parameters:
interfaceClazz - The interface to implement.
o - The object to proxy
Returns:
A proxied object, or the input object if the interfaceClazz wasn't an interface.

profiledInvoke

public static Object profiledInvoke(Method target,
                                    Object value,
                                    Object[] args)
                             throws IllegalAccessException,
                                    InvocationTargetException
A profiled call Method.invoke(java.lang.Object, java.lang.Object[]). If UtilTimerStack.isActive() returns false, then no profiling is performed.

Throws:
IllegalAccessException
InvocationTargetException

getTrimmedClassName

public static String getTrimmedClassName(Method method)
Given a method, get the Method name, with no package information.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ProfilingTimerBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Class ProfilingTimerBean

java.lang.Object
    extended by  com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
All Implemented Interfaces:
Serializable
public class ProfilingTimerBean
extends Object
implements Serializable

Bean to contain information about the pages profiled

Version:
$Date$ $Id$
Author:
Mike Cannon-Brookes, Scott Farquhar
See Also:
Serialized Form

Field Summary
(package private) List<ProfilingTimerBean> | children
(package private) ProfilingTimerBean | parent
(package private) String | resource
private static long | serialVersionUID
(package private) long | startTime
(package private) long | totalTime
Constructor Summary
ProfilingTimerBean(String resource)
Method Summary
void | addChild(ProfilingTimerBean child)
protected void | addParent(ProfilingTimerBean parent)
ProfilingTimerBean | getParent()
String | getPrintable(long minTime) Get a formatted string representing all the methods that took longer than a specified time.
protected String | getPrintable(String indent, long minTime)
String | getResource()
void | setEndTime()
void | setStartTime()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

children

List<ProfilingTimerBean> children

parent

ProfilingTimerBean parent

resource

String resource

startTime

long startTime

totalTime

long totalTime
Constructor Detail

ProfilingTimerBean

public ProfilingTimerBean(String resource)
Method Detail

addParent

protected void addParent(ProfilingTimerBean parent)

getParent

public ProfilingTimerBean getParent()

addChild

public void addChild(ProfilingTimerBean child)

setStartTime

public void setStartTime()

setEndTime

public void setEndTime()

getResource

public String getResource()

getPrintable

public String getPrintable(long minTime)
Get a formatted string representing all the methods that took longer than a specified time.

getPrintable

protected String getPrintable(String indent,
                              long minTime)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TimerInvocationHandler (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Class TimerInvocationHandler

java.lang.Object
    extended by  com.opensymphony.xwork2.util.profiling.TimerInvocationHandler
All Implemented Interfaces:
InvocationHandler
 class TimerInvocationHandler
extends Object
implements InvocationHandler

Field Summary
protected  Object target
Constructor Summary
TimerInvocationHandler(Object target)
Method Summary
 Object invoke(Object proxy, Method method, Object[] args)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

target

protected Object target
Constructor Detail

TimerInvocationHandler

public TimerInvocationHandler(Object target)
Method Detail

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] args)
              throws Throwable
Specified by:
invoke in interface InvocationHandler
Throws:
Throwable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UtilTimerStack (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Class UtilTimerStack

java.lang.Object
    extended by  com.opensymphony.xwork2.util.profiling.UtilTimerStack

public class UtilTimerStack
extends Object

A timer stack.

Struts2 profiling aspects involves the following :-

  • ActionContextCleanUp
  • FreemarkerPageFilter
  • DispatcherFilter
    • Dispatcher
      • creation of DefaultActionProxy
        • creation of DefaultActionInvocation
          • creation of Action
      • execution of DefaultActionProxy
        • invocation of DefaultActionInvocation
          • invocation of Interceptors
          • invocation of Action
          • invocation of PreResultListener
          • invocation of Result
XWork2 profiling aspects involves the following :-
    • creation of DefaultActionProxy
      • creation of DefaultActionInvocation
        • creation of Action
    • execution of DefaultActionProxy
      • invocation of DefaultActionInvocation
        • invocation of Interceptors
        • invocation of Action
        • invocation of PreResultListener
        • invocation of Result
Activating / Deactivating of the profiling feature could be done through:-

System properties:-

  -Dxwork.profile.activate=true
This could be done in the container startup script eg. CATALINA_OPTS in catalina.sh (tomcat) or using "java -Dxwork.profile.activate=true -jar start.jar" (jetty)

Code :-

  UtilTimerStack.setActivate(true);

  // or

  System.setProperty("xwork.profile.activate", "true");

  // or

  System.setProperty(UtilTimerStack.ACTIVATE_PROPERTY, "true");
This could be done in a static block, in a Spring bean with lazy-init="false", in a Servlet with init-on-startup as some numeric value, in a Filter or Listener's init method etc.

Parameter:-

 <action ... >
  ...
  <interceptor-ref name="profiling">
      <param name="profilingKey">profiling</param>
  </interceptor-ref>
  ...
 </action>

 or

 <action .... >
 ...
  <interceptor-ref name="profiling" />
 ...
 </action>

 through url

 http://host:port/context/namespace/someAction.action?profiling=true

 through code

 ActionContext.getContext().getParameters().put("profiling", "true);
To use profiling activation through parameter, one will need to pass in through the 'profiling' parameter (which is the default) and could be changed through the param tag in the interceptor-ref.

Warning:

Profiling activation through parameter will need the followings:-

  • Profiling interceptor
  • dev mode on (struts.devMode=true in struts.properties)

One could filter out the profile logging by having a System property as follows. With this 'xwork.profile.mintime' property, one could only log profile information when its execution time exceed those specified in 'xwork.profile.mintime' system property. If no such property is specified, it will be assumed to be 0, hence all profile information will be logged.

  -Dxwork.profile.mintime=10000
One could extends the profiling feature provided by Struts2 in their web application as well.

    String logMessage = "Log message";
    UtilTimerStack.push(logMessage);
    try {
      // do some code
    }
    finally {
      UtilTimerStack.pop(logMessage); //this needs to be the same text as above
    }
or

   String result = UtilTimerStack.profile("purchaseItem: ",
       new UtilTimerStack.ProfilingBlock() {
            public String doProfiling() {
               // do some code
               return "Ok";
            }
       });
Profiled result is logged using commons-logging under the logger named 'com.opensymphony.xwork2.util.profiling.UtilTimerStack'. Depending on the underlying logging implementation say if it is Log4j, one could direct the log to appear in a different file, being emailed to someone or have it stored in the db.

Version:
$Date$ $Id$

Nested Class Summary
static interface UtilTimerStack.ProfilingBlock<T>
A callback interface where code subjected to profile is to be executed.
Field Summary
static String | ACTIVATE_PROPERTY System property that controls whether this timer should be used or not.
protected static ThreadLocal<ProfilingTimerBean> | current
private static Log | log
static String | MIN_TIME System property that controls the min time, that if exceeded will cause a log (at INFO level) to be created.
Constructor Summary
UtilTimerStack()
Method Summary
private static long getMinTime()
Get the min time for this profiling, it searches for a System property 'xwork.profile.mintime' and default to 0.
static boolean isActive()
Determine if profiling is being activated, by searching for a system property 'xwork.profile.activate', default to false (profiling is off).
static void pop(String name)
End a preformance profiling with the name given.
private static void printTimes(ProfilingTimerBean currentTimer)
Do a log (at INFO level) of the time taken for this particular profiling.
static
<T> T
profile(String name, UtilTimerStack.ProfilingBlock<T> block)
A convenience method that allows block of code subjected to profiling to be executed and avoid the need of coding boiler code that does pushing (UtilTimeBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ...
static void push(String name)
Create and start a performance profiling with the name given.
static void setActive(boolean active)
Turn profiling on or off.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

current

protected static ThreadLocal<ProfilingTimerBean> current

ACTIVATE_PROPERTY

public static final String ACTIVATE_PROPERTY
System property that controls whether this timer should be used or not. Set to "true" activates the timer. Set to "false" to disactivate.

See Also:
Constant Field Values

MIN_TIME

public static final String MIN_TIME
System property that controls the min time, that if exceeded will cause a log (at INFO level) to be created.

See Also:
Constant Field Values

log

private static final Log log
Constructor Detail

UtilTimerStack

public UtilTimerStack()
Method Detail

push

public static void push(String name)
Create and start a performance profiling with the name given. Deal with profile hierarchy automatically, so caller don't have to be concern about it.

Parameters:
name - profile name

pop

public static void pop(String name)
End a preformance profiling with the name given. Deal with profile hierarchy automatically, so caller don't have to be concern about it.

Parameters:
name - profile name

printTimes

private static void printTimes(ProfilingTimerBean currentTimer)
Do a log (at INFO level) of the time taken for this particular profiling.

Parameters:
currentTimer - profiling timer bean

getMinTime

private static long getMinTime()
Get the min time for this profiling, it searches for a System property 'xwork.profile.mintime' and default to 0.

Returns:
long

isActive

public static boolean isActive()
Determine if profiling is being activated, by searching for a system property 'xwork.profile.activate', default to false (profiling is off).

Returns:
true, if active, false otherwise.

setActive

public static void setActive(boolean active)
Turn profiling on or off.

Parameters:
active -

profile

public static <T> T profile(String name,
                            UtilTimerStack.ProfilingBlock<T> block)
                 throws Exception
A convenience method that allows block of code subjected to profiling to be executed and avoid the need of coding boiler code that does pushing (UtilTimeBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ... finally ... block.

Example of usage:

         // we need a returning result
   String result = UtilTimerStack.profile("purchaseItem: ",
       new UtilTimerStack.ProfilingBlock() {
            public String doProfiling() {
               getMyService().purchaseItem(....)
               return "Ok";
            }
       });
or
   // we don't need a returning result
   UtilTimerStack.profile("purchaseItem: ",
       new UtilTimerStack.ProfilingBlock() {
            public String doProfiling() {
               getMyService().purchaseItem(....)
               return null;
            }
       });

Type Parameters:
T - any return value if there's one.
Parameters:
name - profile name
block - code block subjected to profiling
Returns:
T
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.validator (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.validator

XWork validation subsystem.

See:
Description

Interface Summary
ActionValidatorManager | ActionValidatorManager
FieldValidator | The FieldValidator interface defines the methods to be implemented by FieldValidators, which are used by the XWork validation framework to validate Action properties before executing the Action.
ShortCircuitableValidator | This interface should be implemented by validators that can short-circuit the validator queue that it is in.
Validator |
ValidatorContext | The context for validation.

Class Summary
ActionValidatorManagerFactory | ActionValidatorManagerFactory
AnnotationActionValidatorManager | AnnotationActionValidatorManager This is the entry point into XWork's annotations-based validator framework.
AnnotationValidationConfigurationBuilder | AnnotationValidationConfigurationBuilder
DefaultActionValidatorManager | This is the entry point into XWork's rule-based validation framework.
DelegatingValidatorContext | A default implementation of the ValidatorContext interface.
DelegatingValidatorContext.ActionContextLocaleProvider | An implementation of LocaleProvider which gets the locale from the action context.
DelegatingValidatorContext.LoggingValidationAware | An implementation of ValidationAware which logs errors and messages.
ValidationInterceptor | This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).
ValidatorConfig | Holds the necessary information for configuring an instance of a Validator.
ValidatorFactory | ValidatorFactory
ValidatorFileParser | Parse the validation file.

Exception Summary
ValidationException ValidationException.

Package com.opensymphony.xwork2.validator Description

XWork validation subsystem.


com.opensymphony.xwork2.validator Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.validator

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
        • com.opensymphony.xwork2.validator.ValidationInterceptor
    • com.opensymphony.xwork2.validator.ActionValidatorManagerFactory
    • com.opensymphony.xwork2.validator.AnnotationActionValidatorManager (implements com.opensymphony.xwork2.validator.ActionValidatorManager)
    • com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder
    • com.opensymphony.xwork2.validator.DefaultActionValidatorManager (implements com.opensymphony.xwork2.validator.ActionValidatorManager)
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext (implements com.opensymphony.xwork2.validator.ValidatorContext)
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext.ActionContextLocaleProvider (implements com.opensymphony.xwork2.LocaleProvider)
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware (implements com.opensymphony.xwork2.ValidationAware)
    • com.opensymphony.xwork2.util.location.Located (implements com.opensymphony.xwork2.util.location.Locatable)
      • com.opensymphony.xwork2.validator.ValidatorConfig
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • com.opensymphony.xwork2.validator.ValidationException
    • com.opensymphony.xwork2.validator.ValidatorFactory
    • com.opensymphony.xwork2.validator.ValidatorFileParser

Interface Hierarchy

  • com.opensymphony.xwork2.validator.ActionValidatorManager
  • com.opensymphony.xwork2.LocaleProvider
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.ValidationAware)
  • com.opensymphony.xwork2.validator.ShortCircuitableValidator
  • com.opensymphony.xwork2.TextProvider
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.LocaleProvider, com.opensymphony.xwork2.ValidationAware)
  • com.opensymphony.xwork2.ValidationAware
    • com.opensymphony.xwork2.validator.ValidatorContext (also extends com.opensymphony.xwork2.LocaleProvider, com.opensymphony.xwork2.TextProvider)
  • com.opensymphony.xwork2.validator.Validator
    • com.opensymphony.xwork2.validator.FieldValidator


Uses of Package com.opensymphony.xwork2.validator (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.validator

Packages that use com.opensymphony.xwork2.validator
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.
org.apache.struts2.interceptor.validation |

Classes in com.opensymphony.xwork2.validator used by com.opensymphony.xwork2
Validator

Classes in com.opensymphony.xwork2.validator used by com.opensymphony.xwork2.validator
ActionValidatorManager
ActionValidatorManager
ValidationException
ValidationException.
Validator
ValidatorConfig
Holds the necessary information for configuring an instance of a Validator.
ValidatorContext
The context for validation.

Classes in com.opensymphony.xwork2.validator used by com.opensymphony.xwork2.validator.validators
DelegatingValidatorContext
A default implementation of the ValidatorContext interface.
FieldValidator
The FieldValidator interface defines the methods to be implemented by FieldValidators, which are used by the XWork validation framework to validate Action properties before executing the Action.
ShortCircuitableValidator
This interface should be implemented by validators that can short-circuit the validator queue that it is in.
ValidationException
ValidationException.
Validator
ValidatorContext
The context for validation.

Classes in com.opensymphony.xwork2.validator used by org.apache.struts2.interceptor.validation
ValidationInterceptor
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionValidatorManager (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface ActionValidatorManager

All Known Implementing Classes:
AnnotationActionValidatorManager, DefaultActionValidatorManager
public interface ActionValidatorManager

ActionValidatorManager

Version:
$Id: ActionValidatorManager.java 1359 2007-02-16 12:00:09Z rainerh $
Author:
Rainer Hermanns

Method Summary
List<Validator> | getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method.
void | validate(Object object, String context) Validates the given object using action and its context.
void | validate(Object object, String context, String method) Validates the given object using an action, its context, and the name of the method being invoked on the action.
void | validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context and a validation context.

Method Detail

getValidators

List<Validator> getValidators(Class clazz,
                              String context,
                              String method)
Returns a list of validators for the given class, context, and method. This is the primary lookup method for validators.

Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
method - the name of the method being invoked on the action - can be null.
Returns:
a list of all validators for the given class and context.

getValidators

List<Validator> getValidators(Class clazz,
                              String context)
Returns a list of validators for the given class and context. This is the primary lookup method for validators.

Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
Returns:
a list of all validators for the given class and context.

validate

void validate(Object object,
              String context)
              throws ValidationException
Validates the given object using action and its context.

Parameters:
object - the action to validate.
context - the action's context.
Throws:
ValidationException - if an error happens when validating the action.

validate

void validate(Object object,
              String context,
              ValidatorContext validatorContext)
              throws ValidationException
Validates an action give its context and a validation context.

Parameters:
object - the action to validate.
context - the action's context.
validatorContext -
Throws:
ValidationException - if an error happens when validating the action.

validate

void validate(Object object,
              String context,
              String method)
              throws ValidationException
Validates the given object using an action, its context, and the name of the method being invoked on the action.

Parameters:
object - the action to validate.
context - the action's context.
method - the name of the method being invoked on the action - can be null.
Throws:
ValidationException - if an error happens when validating the action.

validate

void validate(Object object,
              String context,
              ValidatorContext validatorContext,
              String method)
              throws ValidationException
Validates an action give its context and a validation context.

Parameters:
object - the action to validate.
context - the action's context.
validatorContext -
method - the name of the method being invoked on the action - can be null.
Throws:
ValidationException - if an error happens when validating the action.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface FieldValidator

All Superinterfaces:
Validator
All Known Implementing Classes:
AbstractRangeValidator, ConversionErrorFieldValidator, DateRangeFieldValidator, DoubleRangeFieldValidator, EmailValidator, FieldExpressionValidator, FieldValidatorSupport, IntRangeFieldValidator, RegexFieldValidator, RepopulateConversionErrorFieldValidatorSupport, RequiredFieldValidator, RequiredStringValidator, StringLengthFieldValidator, URLValidator, VisitorFieldValidator
public interface FieldValidator
extends Validator

The FieldValidator interface defines the methods to be implemented by FieldValidators, which are used by the XWork validation framework to validate Action properties before executing the Action.

Version:
$Revision: 1063 $
Author:
$author$

Method Summary
String | getFieldName()
void | setFieldName(String fieldName) Sets the field name to validate with this FieldValidator
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, getValidatorType, setDefaultMessage, setMessageKey, setValidatorContext, setValidatorType, validate

Method Detail

setFieldName

void setFieldName(String fieldName)
Sets the field name to validate with this FieldValidator

Parameters:
fieldName -

getFieldName

String getFieldName()
Returns:
the field name to be validated
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ShortCircuitableValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface ShortCircuitableValidator

All Known Implementing Classes:
AbstractRangeValidator, ConversionErrorFieldValidator, DateRangeFieldValidator, DoubleRangeFieldValidator, EmailValidator, ExpressionValidator, FieldExpressionValidator, FieldValidatorSupport, IntRangeFieldValidator, RegexFieldValidator, RepopulateConversionErrorFieldValidatorSupport, RequiredFieldValidator, RequiredStringValidator, StringLengthFieldValidator, URLValidator, ValidatorSupport, VisitorFieldValidator
public interface ShortCircuitableValidator

This interface should be implemented by validators that can short-circuit the validator queue that it is in.

Author:
Mark Woon

Method Summary
boolean | isShortCircuit() Gets whether this field validator should short circuit the validator queue it's in if validation fails.
void | setShortCircuit(boolean shortcircuit) Sets whether this field validator should short circuit the validator queue it's in if validation fails.

Method Detail

setShortCircuit

void setShortCircuit(boolean shortcircuit)
Sets whether this field validator should short circuit the validator queue it's in if validation fails.

Parameters:
shortcircuit - true if this field validator should short circuit on failure, false otherwise

isShortCircuit

boolean isShortCircuit()
Gets whether this field validator should short circuit the validator queue it's in if validation fails.

Returns:
true if this field validator should short circuit on failure, false otherwise
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Validator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface Validator

All Known Subinterfaces:
FieldValidator
All Known Implementing Classes:
AbstractRangeValidator, ConversionErrorFieldValidator, DateRangeFieldValidator, DoubleRangeFieldValidator, EmailValidator, ExpressionValidator, FieldExpressionValidator, FieldValidatorSupport, IntRangeFieldValidator, RegexFieldValidator, RepopulateConversionErrorFieldValidatorSupport, RequiredFieldValidator, RequiredStringValidator, StringLengthFieldValidator, URLValidator, ValidatorSupport, VisitorFieldValidator
public interface Validator

The validators supplied by the Xwork distribution (and any validators you might write yourself) come in two different flavors:

  1. Plain Validators / Non-Field validators
  2. FieldValidators

Plain Validators (such as the ExpressionValidator) perform validation checks that are not inherently tied to a single specified field. When you declare a plain Validator in your -validation.xml file you do not associate a fieldname attribute with it. (You should avoid using plain Validators within the syntax described below.)

FieldValidators (such as the EmailValidator) are designed to perform validation checks on a single field. They require that you specify a fieldname attribute in your -validation.xml file. There are two different (but equivalent) XML syntaxes you can use to declare FieldValidators (see " vs. syntax" below).

There are two places where the differences between the two validator flavors are important to keep in mind:

  1. when choosing the xml syntax used for declaring a validator (either or )
  2. when using the short-circuit capability

NOTE:Note that you do not declare what "flavor" of validator you are using in your -validation.xml file, you just declare the name of the validator to use and WebWork will know whether it's a "plain Validator" or a "FieldValidator" by looking at the validation class that the validator's programmer chose to implement.

To define validation rules for an Action, create a file named ActionName-validation.xml in the same package as the Action. You may also create alias-specific validation rules which add to the default validation rules defined in ActionName-validation.xml by creating another file in the same directory named ActionName-aliasName-validation.xml. In both cases, ActionName is the name of the Action class, and aliasName is the name of the Action alias defined in the xwork.xml configuration for the Action.

The framework will also search up the inheritance tree of the Action to find validation rules for directly implemented interfaces and parent classes of the Action. This is particularly powerful when combined with ModelDriven Actions and the VisitorFieldValidator. Here's an example of how validation rules are discovered. Given the following class structure:

  • interface Animal;
  • interface Quadraped extends Animal;
  • class AnimalImpl implements Animal;
  • class QuadrapedImpl extends AnimalImpl implements Quadraped;
  • class Dog extends QuadrapedImpl;

The framework method will look for the following config files if Dog is to be validated:

  • Animal
  • Animal-aliasname
  • AnimalImpl
  • AnimalImpl-aliasname
  • Quadraped
  • Quadraped-aliasname
  • QuadrapedImpl
  • QuadrapedImpl-aliasname
  • Dog
  • Dog-aliasname

While this process is similar to what the XW:Localization framework does when finding messages, there are some subtle differences. The most important difference is that validation rules are discovered from the parent downwards.

NOTE:Child's *-validation.xml will add on to parent's *-validation.xml according to the class hierarchi defined above. With this feature, one could have more generic validation rule at the parent and more specific validation rule at the child.

There are two ways you can define validators in your -validation.xml file:

  1. <validator>
  2. <field-validator>

Keep the following in mind when using either syntax:

Non-Field-Validator The <validator> element allows you to declare both types of validators (either a plain Validator a field-specific FieldValidator).

    <!-- Declaring a plain Validator using the <validator> syntax: -->

    <validator type="expression>
          <param name="expression">foo gt bar</param>
          <message>foo must be great than bar.</message>
    </validator>

    <!-- Declaring a field validator using the <validator> syntax; -->

    <validator type="required">
         <param name="fieldName">bar</param>
         <message>You must enter a value for bar.</message>
    </validator>

field-validator The <field-validator> elements are basically the same as the <validator> elements except that they inherit the fieldName attribute from the enclosing <field> element. FieldValidators defined within a <field-validator> element will have their fieldName automatically filled with the value of the parent <field> element's fieldName attribute. The reason for this structure is to conveniently group the validators for a particular field under one element, otherwise the fieldName attribute would have to be repeated, over and over, for each individual <validator>.

HINT: It is always better to defined field-validator inside a <field> tag instead of using a <validator> tag and supplying fieldName as its param as the xml code itself is clearer (grouping of field is clearer)

NOTE: Note that you should only use FieldValidators (not plain Validators) within a block. A plain Validator inside a <field> will not be allowed and would generate error when parsing the xml, as it is not allowed in the defined dtd (xwork-validator-1.0.2.dtd)

 Declaring a FieldValidator using the <field-validator> syntax:

 <field name="email_address">
   <field-validator type="required">
       <message>You cannot leave the email address field empty.</message>
   </field-validator>
   <field-validator type="email">
       <message>The email address you entered is not valid.</message>
   </field-validator>
 </field>

The choice is yours. It's perfectly legal to only use elements without the elements and set the fieldName attribute for each of them. The following are effectively equal:

 <field name="email_address">
   <field-validator type="required">
       <message>You cannot leave the email address field empty.</message>
   </field-validator>
   <field-validator type="email">
       <message>The email address you entered is not valid.</message>
   </field-validator>
 </field>

 <validator type="required">
   <param name="fieldName">email_address</param>
   <message>You cannot leave the email address field empty.</message>
 </validator>
 <validator type="email">
   <param name="fieldName">email_address</param>
   <message>The email address you entered is not valid.</message>
 </validator>

Beginning with XWork 1.0.1 (bundled with WebWork 2.1), it is possible to short-circuit a stack of validators. Here is another sample config file containing validation rules from the Xwork test cases: Notice that some of the <field-validator> and <validator> elements have the short-circuit attribute set to true.

 <!-- START SNIPPET: exShortCircuitingValidators -->
 <!DOCTYPE validators PUBLIC
         "-//OpenSymphony Group//XWork Validator 1.0.2//EN"
         "http://www.opensymphony.com/xwork/xwork-validator-1.0.2.dtd">
 <validators>
   <!-- Field Validators for email field -->
   <field name="email">
       <field-validator type="required" short-circuit="true">
           <message>You must enter a value for email.</message>
       </field-validator>
       <field-validator type="email" short-circuit="true">
           <message>Not a valid e-mail.</message>
       </field-validator>
   </field>
   <!-- Field Validators for email2 field -->
   <field name="email2">
      <field-validator type="required">
           <message>You must enter a value for email2.</message>
       </field-validator>
      <field-validator type="email">
           <message>Not a valid e-mail2.</message>
       </field-validator>
   </field>
   <!-- Plain Validator 1 -->
   <validator type="expression">
       <param name="expression">email.equals(email2)</param>
       <message>Email not the same as email2</message>
   </validator>
   <!-- Plain Validator 2 -->
   <validator type="expression" short-circuit="true">
       <param name="expression">email.startsWith('mark')</param>
       <message>Email does not start with mark</message>
   </validator>
 </validators>
 <!-- END SNIPPET: exShortCircuitingValidators -->

short-circuiting and Validator flavors

Plain validator takes precedence over field-validator. They get validated first in the order they are defined and then the field-validator in the order they are defined. Failure of a particular validator marked as short-circuit will prevent the evaluation of subsequent validators and an error (action error or field error depending on the type of validator) will be added to the ValidationContext of the object being validated.

In the example above, the actual execution of validator would be as follows:

  1. Plain Validator 1
  2. Plain Validator 2
  3. Field Validators for email field
  4. Field Validators for email2 field

Since Field Validator 2 is short-circuited, if its validation failed, it will causes Field validators for email field and Field validators for email2 field to not be validated as well.

Usefull Information: More complecated validation should probably be done in the validate() method on the action itself (assuming the action implements Validatable interface which ActionSupport already does).

A plain Validator (non FieldValidator) that gets short-circuited will completely break out of the validation stack� no other validators will be evaluated and plain validator takes precedence over field validator meaning that they get evaluated in the order they are defined before field validator gets a chance to be evaludated again according to their order defined.

Short cuircuiting and validator flavours

A FieldValidator that gets short-circuited will only prevent other FieldValidators for the same field from being evaluated. Note that this "same field" behavior applies regardless of whether the or syntax was used to declare the validation rule. By way of example, given this -validation.xml file:

 <validator type="required" short-circuit="true">
   <param name="fieldName">bar</param>
   <message>You must enter a value for bar.</message>
 </validator>

 <validator type="expression">
   <param name="expression">foo gt bar</param>
   <message>foo must be great than bar.</message>
 </validator>

both validators will be run, even if the "required" validator short-circuits. "required" validators are FieldValidator's and will not short-circuit the plain ExpressionValidator because FieldValidators only short-circuit other checks on that same field. Since the plain Validator is not field specific, it is not short-circuited.

As mentioned above, the framework will also search up the inheritance tree of the action to find default validations for interfaces and parent classes of the Action. If you are using the short-circuit attribute and relying on default validators higher up in the inheritance tree, make sure you don't accidentally short-circuit things higher in the tree that you really want!

Author:
Jason Carreira Created Feb 15, 2003 3:55:51 PM

Method Summary
String | getDefaultMessage()
String | getMessage(Object object)
String | getMessageKey()
ValidatorContext | getValidatorContext()
String | getValidatorType()
void | setDefaultMessage(String message)
void | setMessageKey(String key)
void | setValidatorContext(ValidatorContext validatorContext) This method will be called before validate with a non-null ValidatorContext.
void | setValidatorType(String type)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Method Detail

setDefaultMessage

void setDefaultMessage(String message)

getDefaultMessage

String getDefaultMessage()

getMessage

String getMessage(Object object)

setMessageKey

void setMessageKey(String key)

getMessageKey

String getMessageKey()

setValidatorContext

void setValidatorContext(ValidatorContext validatorContext)
This method will be called before validate with a non-null ValidatorContext.

Parameters:
validatorContext -

getValidatorContext

ValidatorContext getValidatorContext()

validate

void validate(Object object)
              throws ValidationException
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Parameters:
object -
Throws:
ValidationException

setValidatorType

void setValidatorType(String type)

getValidatorType

String getValidatorType()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Interface ValidatorContext

All Superinterfaces:
LocaleProvider, TextProvider, ValidationAware
All Known Implementing Classes:
DelegatingValidatorContext, VisitorFieldValidator.AppendingValidatorContext
public interface ValidatorContext
extends ValidationAware, TextProvider, LocaleProvider

The context for validation. This interface extends others to provide methods for reporting errors and messages as well as looking up error messages in a resource bundle using a specific locale.

Author:
Jason Carreira

Method Summary
 String getFullFieldName(String fieldName)
Translates a simple field name into a full field name in OGNL syntax.
Methods inherited from interface com.opensymphony.xwork2.ValidationAware
addActionError, addActionMessage, addFieldError, getActionErrors, getActionMessages, getFieldErrors, hasActionErrors, hasActionMessages, hasErrors, hasFieldErrors, setActionErrors, setActionMessages, setFieldErrors
Methods inherited from interface com.opensymphony.xwork2.TextProvider
getText, getText, getText, getText, getText, getText, getText, getText, getText, getTexts, getTexts
Methods inherited from interface com.opensymphony.xwork2.LocaleProvider
getLocale

Method Detail

getFullFieldName

String getFullFieldName(String fieldName)
Translates a simple field name into a full field name in OGNL syntax.

Parameters:
fieldName - the field name to lookup.
Returns:
the full field name in OGNL syntax.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionValidatorManagerFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ActionValidatorManagerFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.ActionValidatorManagerFactory

public class ActionValidatorManagerFactory
extends Object

ActionValidatorManagerFactory

Version:
$Id: ActionValidatorManagerFactory.java 1123 2006-09-10 02:40:12Z mrdon $
Author:
Rainer Hermanns

Field Summary
private static ActionValidatorManager | instance
private static Log | LOG
Constructor Summary
ActionValidatorManagerFactory()
Method Summary
static ActionValidatorManager | getInstance()
static void | setInstance(ActionValidatorManager instance)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

instance

private static ActionValidatorManager instance
Constructor Detail

ActionValidatorManagerFactory

public ActionValidatorManagerFactory()
Method Detail

setInstance

public static void setInstance(ActionValidatorManager instance)

getInstance

public static ActionValidatorManager getInstance()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnnotationActionValidatorManager (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class AnnotationActionValidatorManager

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
All Implemented Interfaces:
ActionValidatorManager
public class AnnotationActionValidatorManager
extends Object
implements ActionValidatorManager

AnnotationActionValidatorManager

This is the entry point into XWork's annotations-based validator framework. Validation rules are specified as annotations within the source files.

Version:
$Id: AnnotationActionValidatorManager.java 1359 2007-02-16 12:00:09Z rainerh $
Author:
Rainer Hermanns, jepjep

Field Summary
private static Log | LOG
protected static String | VALIDATION_CONFIG_SUFFIX The file suffix for any validation file.
private static Map<String,List<ValidatorConfig>> | validatorCache
private static Map<String,List<ValidatorConfig>> | validatorFileCache
Constructor Summary
AnnotationActionValidatorManager()
Method Summary
private List<ValidatorConfig> | buildAliasValidatorConfigs(Class aClass, String context, boolean checkFile)
protected List<ValidatorConfig> | buildClassValidatorConfigs(Class aClass, boolean checkFile)
private List<ValidatorConfig> | buildValidatorConfigs(Class clazz, String context, boolean checkFile, Set checked) This method 'collects' all the validator configurations for a given action invocation.
protected static String | buildValidatorKey(Class clazz, String context) Builds a key for validators - used when caching validators.
List<Validator> | getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method.
private List<ValidatorConfig> | loadFile(String fileName, Class clazz, boolean checkFile)
void | validate(Object object, String context) Validates the given object using action and its context.
void | validate(Object object, String context, String method) Validates the given object using action, its context, and the name of the method being invoked on the action.
void | validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context, a validation context, and the name of the method being invoked on the action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VALIDATION_CONFIG_SUFFIX

protected static final String VALIDATION_CONFIG_SUFFIX
The file suffix for any validation file.

See Also:
Constant Field Values

validatorCache

private static final Map<String,List<ValidatorConfig>> validatorCache

validatorFileCache

private static final Map<String,List<ValidatorConfig>> validatorFileCache

LOG

private static final Log LOG
Constructor Detail

AnnotationActionValidatorManager

public AnnotationActionValidatorManager()
Method Detail

getValidators

public List<Validator> getValidators(Class clazz,
                                     String context)
Returns a list of validators for the given class and context. This is the primary lookup method for validators.

Specified by:
getValidators in interface ActionValidatorManager
Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
Returns:
a list of all validators for the given class and context.

getValidators

public List<Validator> getValidators(Class clazz,
                                     String context,
                                     String method)
Returns a list of validators for the given class, context, and method. This is the primary lookup method for validators.

Specified by:
getValidators in interface ActionValidatorManager
Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
method - the name of the method being invoked on the action - can be null.
Returns:
a list of all validators for the given class and context.

validate

public void validate(Object object,
                     String context)
              throws ValidationException
Validates the given object using action and its context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     String method)
              throws ValidationException
Validates the given object using action, its context, and the name of the method being invoked on the action.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
method - the name of the method being invoked on the action.
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     ValidatorContext validatorContext)
              throws ValidationException
Validates an action give its context and a validation context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
validatorContext -
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     ValidatorContext validatorContext,
                     String method)
              throws ValidationException
Validates an action give its context, a validation context, and the name of the method being invoked on the action.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
validatorContext -
method - the name of the method being invoked on the action.
Throws:
ValidationException - if an error happens when validating the action.

buildValidatorKey

protected static String buildValidatorKey(Class clazz,
                                          String context)
Builds a key for validators - used when caching validators.

Parameters:
clazz - the action.
context - the action's context.
Returns:
a validator key which is the class name plus context.

buildAliasValidatorConfigs

private List<ValidatorConfig> buildAliasValidatorConfigs(Class aClass,
                                                         String context,
                                                         boolean checkFile)

buildClassValidatorConfigs

protected List<ValidatorConfig> buildClassValidatorConfigs(Class aClass,
                                                           boolean checkFile)

buildValidatorConfigs

private List<ValidatorConfig> buildValidatorConfigs(Class clazz,
                                                    String context,
                                                    boolean checkFile,
                                                    Set checked)

This method 'collects' all the validator configurations for a given action invocation.

It will traverse up the class hierarchy looking for validators for every super class and directly implemented interface of the current action, as well as adding validators for any alias of this invocation. Nifty!

Given the following class structure:

   interface Thing;
   interface Animal extends Thing;
   interface Quadraped extends Animal;
   class AnimalImpl implements Animal;
   class QuadrapedImpl extends AnimalImpl implements Quadraped;
   class Dog extends QuadrapedImpl;

This method will look for the following config files for Dog:

   Animal
   Animal-context
   AnimalImpl
   AnimalImpl-context
   Quadraped
   Quadraped-context
   QuadrapedImpl
   QuadrapedImpl-context
   Dog
   Dog-context

Note that the validation rules for Thing is never looked for because no class in the hierarchy directly implements Thing.

Parameters:
clazz - the Class to look up validators for.
context - the context to use when looking up validators.
checkFile - true if the validation config file should be checked to see if it has been updated.
checked - the set of previously checked class-contexts, null if none have been checked
Returns:
a list of validator configs for the given class and context.

loadFile

private List<ValidatorConfig> loadFile(String fileName,
                                       Class clazz,
                                       boolean checkFile)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnnotationValidationConfigurationBuilder (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class AnnotationValidationConfigurationBuilder

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

public class AnnotationValidationConfigurationBuilder
extends Object

AnnotationValidationConfigurationBuilder

Version:
$Id: AnnotationValidationConfigurationBuilder.java 1359 2007-02-16 12:00:09Z rainerh $
Author:
Rainer Hermanns, jepjep

Field Summary
private static Pattern | GETTER_PATTERN
private static Pattern | SETTER_PATTERN
Constructor Summary
AnnotationValidationConfigurationBuilder()
Method Summary
static List<ValidatorConfig> | buildAnnotationClassValidatorConfigs(Class aClass)
private static Date | parseDateString(String value)
private static List<ValidatorConfig> | processAnnotations(Object o)
private static ValidatorConfig | processConversionErrorFieldValidatorAnnotation(ConversionErrorFieldValidator v, String fieldName)
private static ValidatorConfig | processCustomValidatorAnnotation(CustomValidator v, String fieldName)
private static ValidatorConfig | processDateRangeFieldValidatorAnnotation(DateRangeFieldValidator v, String fieldName)
private static ValidatorConfig | processDoubleRangeFieldValidatorAnnotation(DoubleRangeFieldValidator v, String fieldName)
private static ValidatorConfig | processEmailValidatorAnnotation(EmailValidator v, String fieldName)
private static ValidatorConfig | processExpressionValidatorAnnotation(ExpressionValidator v, String fieldName)
private static ValidatorConfig | processFieldExpressionValidatorAnnotation(FieldExpressionValidator v, String fieldName)
private static ValidatorConfig | processIntRangeFieldValidatorAnnotation(IntRangeFieldValidator v, String fieldName)
private static ValidatorConfig | processRegexFieldValidatorAnnotation(RegexFieldValidator v, String fieldName)
private static ValidatorConfig | processRequiredFieldValidatorAnnotation(RequiredFieldValidator v, String fieldName)
private static ValidatorConfig | processRequiredStringValidatorAnnotation(RequiredStringValidator v, String fieldName)
private static ValidatorConfig | processStringLengthFieldValidatorAnnotation(StringLengthFieldValidator v, String fieldName)
private static ValidatorConfig | processStringRegexValidatorAnnotation(StringRegexValidator v, String fieldName)
private static ValidatorConfig | processUrlValidatorAnnotation(UrlValidator v, String fieldName)
private static void | processValidationAnnotation(Annotation a, String fieldName, List<ValidatorConfig> result)
private static ValidatorConfig | processVisitorFieldValidatorAnnotation(VisitorFieldValidator v, String fieldName)
static String | resolvePropertyName(Method method) Returns the property name for a method.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SETTER_PATTERN

private static final Pattern SETTER_PATTERN

GETTER_PATTERN

private static final Pattern GETTER_PATTERN
Constructor Detail

AnnotationValidationConfigurationBuilder

public AnnotationValidationConfigurationBuilder()
Method Detail

processAnnotations

private static List<ValidatorConfig> processAnnotations(Object o)

processValidationAnnotation

private static void processValidationAnnotation(Annotation a,
                                                String fieldName,
                                                List<ValidatorConfig> result)

processExpressionValidatorAnnotation

private static ValidatorConfig processExpressionValidatorAnnotation(ExpressionValidator v,
                                                                    String fieldName)

processCustomValidatorAnnotation

private static ValidatorConfig processCustomValidatorAnnotation(CustomValidator v,
                                                                String fieldName)

processStringRegexValidatorAnnotation

private static ValidatorConfig processStringRegexValidatorAnnotation(StringRegexValidator v,
                                                                     String fieldName)

processRegexFieldValidatorAnnotation

private static ValidatorConfig processRegexFieldValidatorAnnotation(RegexFieldValidator v,
                                                                    String fieldName)

processVisitorFieldValidatorAnnotation

private static ValidatorConfig processVisitorFieldValidatorAnnotation(VisitorFieldValidator v,
                                                                      String fieldName)

processUrlValidatorAnnotation

private static ValidatorConfig processUrlValidatorAnnotation(UrlValidator v,
                                                             String fieldName)

processStringLengthFieldValidatorAnnotation

private static ValidatorConfig processStringLengthFieldValidatorAnnotation(StringLengthFieldValidator v,
                                                                           String fieldName)

parseDateString

private static Date parseDateString(String value)

processRequiredStringValidatorAnnotation

private static ValidatorConfig processRequiredStringValidatorAnnotation(RequiredStringValidator v,
                                                                        String fieldName)

processRequiredFieldValidatorAnnotation

private static ValidatorConfig processRequiredFieldValidatorAnnotation(RequiredFieldValidator v,
                                                                       String fieldName)

processIntRangeFieldValidatorAnnotation

private static ValidatorConfig processIntRangeFieldValidatorAnnotation(IntRangeFieldValidator v,
                                                                       String fieldName)

processDoubleRangeFieldValidatorAnnotation

private static ValidatorConfig processDoubleRangeFieldValidatorAnnotation(DoubleRangeFieldValidator v,
                                                                          String fieldName)

processFieldExpressionValidatorAnnotation

private static ValidatorConfig processFieldExpressionValidatorAnnotation(FieldExpressionValidator v,
                                                                         String fieldName)

processEmailValidatorAnnotation

private static ValidatorConfig processEmailValidatorAnnotation(EmailValidator v,
                                                               String fieldName)

processDateRangeFieldValidatorAnnotation

private static ValidatorConfig processDateRangeFieldValidatorAnnotation(DateRangeFieldValidator v,
                                                                        String fieldName)

processConversionErrorFieldValidatorAnnotation

private static ValidatorConfig processConversionErrorFieldValidatorAnnotation(ConversionErrorFieldValidator v,
                                                                              String fieldName)

buildAnnotationClassValidatorConfigs

public static List<ValidatorConfig> buildAnnotationClassValidatorConfigs(Class aClass)

resolvePropertyName

public static String resolvePropertyName(Method method)
Returns the property name for a method. This method is independant from property fields.

Parameters:
method - The method to get the property name for.
Returns:
the property name for given method; null if non could be resolved.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionValidatorManager (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DefaultActionValidatorManager

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DefaultActionValidatorManager
All Implemented Interfaces:
ActionValidatorManager
public class DefaultActionValidatorManager
extends Object
implements ActionValidatorManager

This is the entry point into XWork's rule-based validation framework. Validation rules are specified in XML configuration files named "className-contextName-validation.xml" where className is the name of the class the configuration is for and -contextName is optional (contextName is an arbitrary key that is used to look up additional validation rules for a specific context).

Author:
Jason Carreira, Mark Woon, James House, Rainer Hermanns

Field Summary
private static Log | LOG
protected static String | VALIDATION_CONFIG_SUFFIX The file suffix for any validation file.
private static Map<String,List<ValidatorConfig>> | validatorCache
private static Map<String,List<ValidatorConfig>> | validatorFileCache
Constructor Summary
DefaultActionValidatorManager()
Method Summary
private List<ValidatorConfig> | buildAliasValidatorConfigs(Class aClass, String context, boolean checkFile)
private List<ValidatorConfig> | buildClassValidatorConfigs(Class aClass, boolean checkFile)
private List<ValidatorConfig> | buildValidatorConfigs(Class clazz, String context, boolean checkFile, Set checked) This method 'collects' all the validator configurations for a given action invocation.
protected static String | buildValidatorKey(Class clazz, String context) Builds a key for validators - used when caching validators.
List<Validator> | getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method name.
private List<ValidatorConfig> | loadFile(String fileName, Class clazz, boolean checkFile)
void | validate(Object object, String context) Validates the given object using action and its context.
void | validate(Object object, String context, String method) Validates the given object using action, its context, and the name of the method being invoked on the action.
void | validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context, a validation context, and the name of the method being invoked on the action.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

VALIDATION_CONFIG_SUFFIX

protected static final String VALIDATION_CONFIG_SUFFIX
The file suffix for any validation file.

See Also:
Constant Field Values

validatorCache

private static final Map<String,List<ValidatorConfig>> validatorCache

validatorFileCache

private static final Map<String,List<ValidatorConfig>> validatorFileCache

LOG

private static final Log LOG
Constructor Detail

DefaultActionValidatorManager

public DefaultActionValidatorManager()
Method Detail

getValidators

public List<Validator> getValidators(Class clazz,
                                     String context)
Returns a list of validators for the given class and context. This is the primary lookup method for validators.

Specified by:
getValidators in interface ActionValidatorManager
Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
Returns:
a list of all validators for the given class and context.

getValidators

public List<Validator> getValidators(Class clazz,
                                     String context,
                                     String method)
Returns a list of validators for the given class, context, and method name. This is the primary lookup method for validators.

Specified by:
getValidators in interface ActionValidatorManager
Parameters:
clazz - the class to lookup.
context - the context of the action class - can be null.
method - the name of the method being invoked on the action - can be null.
Returns:
a list of all validators for the given class and context.

validate

public void validate(Object object,
                     String context)
              throws ValidationException
Validates the given object using action and its context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     String method)
              throws ValidationException
Validates the given object using action, its context, and the name of the method being invoked on the action.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
method - the name of the method being invoked on the action.
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     ValidatorContext validatorContext)
              throws ValidationException
Validates an action give its context and a validation context.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
validatorContext -
Throws:
ValidationException - if an error happens when validating the action.

validate

public void validate(Object object,
                     String context,
                     ValidatorContext validatorContext,
                     String method)
              throws ValidationException
Validates an action give its context, a validation context, and the name of the method being invoked on the action.

Specified by:
validate in interface ActionValidatorManager
Parameters:
object - the action to validate.
context - the action's context.
validatorContext -
method - the name of the method being invoked on the action.
Throws:
ValidationException - if an error happens when validating the action.

buildValidatorKey

protected static String buildValidatorKey(Class clazz,
                                          String context)
Builds a key for validators - used when caching validators.

Parameters:
clazz - the action.
context - the action's context.
Returns:
a validator key which is the class name plus context.

buildAliasValidatorConfigs

private List<ValidatorConfig> buildAliasValidatorConfigs(Class aClass,
                                                         String context,
                                                         boolean checkFile)

buildClassValidatorConfigs

private List<ValidatorConfig> buildClassValidatorConfigs(Class aClass,
                                                         boolean checkFile)

buildValidatorConfigs

private List<ValidatorConfig> buildValidatorConfigs(Class clazz,
                                                    String context,
                                                    boolean checkFile,
                                                    Set checked)

This method 'collects' all the validator configurations for a given action invocation.

It will traverse up the class hierarchy looking for validators for every super class and directly implemented interface of the current action, as well as adding validators for any alias of this invocation. Nifty!

Given the following class structure:

   interface Thing;
   interface Animal extends Thing;
   interface Quadraped extends Animal;
   class AnimalImpl implements Animal;
   class QuadrapedImpl extends AnimalImpl implements Quadraped;
   class Dog extends QuadrapedImpl;

This method will look for the following config files for Dog:

   Animal
   Animal-context
   AnimalImpl
   AnimalImpl-context
   Quadraped
   Quadraped-context
   QuadrapedImpl
   QuadrapedImpl-context
   Dog
   Dog-context

Note that the validation rules for Thing is never looked for because no class in the hierarchy directly implements Thing.

Parameters:
clazz - the Class to look up validators for.
context - the context to use when looking up validators.
checkFile - true if the validation config file should be checked to see if it has been updated.
checked - the set of previously checked class-contexts, null if none have been checked
Returns:
a list of validator configs for the given class and context.

loadFile

private List<ValidatorConfig> loadFile(String fileName,
                                       Class clazz,
                                       boolean checkFile)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DelegatingValidatorContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DelegatingValidatorContext

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DelegatingValidatorContext
All Implemented Interfaces:
LocaleProvider, TextProvider, ValidationAware, ValidatorContext
Direct Known Subclasses:
VisitorFieldValidator.AppendingValidatorContext
public class DelegatingValidatorContext
extends Object
implements ValidatorContext

A default implementation of the ValidatorContext interface.

Author:
Jason Carreira, Rainer Hermanns

Nested Class Summary
private static class | DelegatingValidatorContext.ActionContextLocaleProvider An implementation of LocaleProvider which gets the locale from the action context.
private static class | DelegatingValidatorContext.LoggingValidationAware An implementation of ValidationAware which logs errors and messages.
Field Summary
private LocaleProvider | localeProvider
private TextProvider | textProvider
private ValidationAware | validationAware
Constructor Summary
DelegatingValidatorContext(Class clazz)
Create a new validation context given a Class definition.
DelegatingValidatorContext(Object object)
Creates a new validation context given an object - usually an Action.
DelegatingValidatorContext(ValidationAware validationAware, TextProvider textProvider, LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider.
Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addActionMessage(String aMessage) Add an Action-level message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
Collection | getActionErrors() Get the Collection of Action-level error messages for this action.
Collection | getActionMessages() Get the Collection of Action-level messages for this action.
Map | getFieldErrors() Get the field specific errors associated with this action.
String | getFullFieldName(String fieldName) Translates a simple field name into a full field name in OGNL syntax.
Locale | getLocale()
String | getText(String aTextName) Gets a message based on a message key, or null if no message is found.
String | getText(String aTextName, List args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String aTextName, String defaultValue) Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
String | getText(String aTextName, String defaultValue, List args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, List args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String aTextName, String defaultValue, String obj) Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
protected TextProvider | getTextProvider()
ResourceBundle | getTexts() Get the resource bundle associated with the implementing class (usually an action).
ResourceBundle | getTexts(String aBundleName) Get the named bundle, such as "com/acme/Foo".
protected ValidationAware | getValidationAware()
boolean | hasActionErrors() Check whether there are any Action-level error messages.
boolean | hasActionMessages() Checks whether there are any Action-level messages.
boolean | hasErrors() Note that this does not have the same meaning as in WW 1.x.
boolean | hasFieldErrors() Check whether there are any field errors associated with this action.
protected static LocaleProvider | makeLocaleProvider(Object object)
static TextProvider | makeTextProvider(Object object, LocaleProvider localeProvider)
protected static ValidationAware | makeValidationAware(Object object)
void | setActionErrors(Collection errorMessages) Set the Collection of Action-level String error messages.
void | setActionMessages(Collection messages) Set the Collection of Action-level String messages (not errors).
void | setFieldErrors(Map errorMap) Set the field error map of fieldname (String) to Collection of String error messages.
protected void | setTextProvider(TextProvider textProvider)
protected void | setValidationAware(ValidationAware validationAware)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

localeProvider

private LocaleProvider localeProvider

textProvider

private TextProvider textProvider

validationAware

private ValidationAware validationAware
Constructor Detail

DelegatingValidatorContext

public DelegatingValidatorContext(ValidationAware validationAware,
                                  TextProvider textProvider,
                                  LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider. These objects are used internally to set errors and get and set error text.

DelegatingValidatorContext

public DelegatingValidatorContext(Object object)
Creates a new validation context given an object - usually an Action. The internal objects (validation aware instance and a locale and text provider) are created based on the given action.

Parameters:
object - the object to use for validation (usually an Action).

DelegatingValidatorContext

public DelegatingValidatorContext(Class clazz)
Create a new validation context given a Class definition. The locale provider, text provider and the validation context are created based on the class.

Parameters:
clazz - the class to initialize the context with.
Method Detail

setActionErrors

public void setActionErrors(Collection errorMessages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String error messages.

Specified by:
setActionErrors in interface ValidationAware

getActionErrors

public Collection getActionErrors()
Description copied from interface: ValidationAware
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionErrors in interface ValidationAware
Returns:
Collection of String error messages

setActionMessages

public void setActionMessages(Collection messages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String messages (not errors).

Specified by:
setActionMessages in interface ValidationAware

getActionMessages

public Collection getActionMessages()
Description copied from interface: ValidationAware
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionMessages in interface ValidationAware
Returns:
Collection of String messages

setFieldErrors

public void setFieldErrors(Map errorMap)
Description copied from interface: ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.

Specified by:
setFieldErrors in interface ValidationAware

getFieldErrors

public Map getFieldErrors()
Description copied from interface: ValidationAware
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getFieldErrors in interface ValidationAware
Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

getFullFieldName

public String getFullFieldName(String fieldName)
Description copied from interface: ValidatorContext
Translates a simple field name into a full field name in OGNL syntax.

Specified by:
getFullFieldName in interface ValidatorContext
Parameters:
fieldName - the field name to lookup.
Returns:
the full field name in OGNL syntax.

getLocale

public Locale getLocale()
Specified by:
getLocale in interface LocaleProvider

getText

public String getText(String aTextName)
Description copied from interface: TextProvider
Gets a message based on a message key, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String aTextName,
                      String defaultValue)
Description copied from interface: TextProvider
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String aTextName,
                      String defaultValue,
                      String obj)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
obj - obj to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String aTextName,
                      List args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String key,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or null if none is found.

getText

public String getText(String aTextName,
                      String defaultValue,
                      List args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
aTextName - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts(String aBundleName)
Description copied from interface: TextProvider
Get the named bundle, such as "com/acme/Foo".

Specified by:
getTexts in interface TextProvider
Parameters:
aBundleName - the name of the resource bundle, such as "com/acme/Foo"

getText

public String getText(String key,
                      String defaultValue,
                      List args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - a list args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getText

public String getText(String key,
                      String defaultValue,
                      String[] args,
                      ValueStack stack)
Description copied from interface: TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned. Instead of using the value stack in the ActionContext this version of the getText() method uses the provided value stack.

Specified by:
getText in interface TextProvider
Parameters:
key - the resource bundle key that is to be searched for
defaultValue - the default value which will be returned if no message is found
args - an array args to be used in a MessageFormat message
stack - the value stack to use for finding the text
Returns:
the message as found in the resource bundle, or defaultValue if none is found

getTexts

public ResourceBundle getTexts()
Description copied from interface: TextProvider
Get the resource bundle associated with the implementing class (usually an action).

Specified by:
getTexts in interface TextProvider

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware

addActionMessage

public void addActionMessage(String aMessage)
Description copied from interface: ValidationAware
Add an Action-level message to this Action.

Specified by:
addActionMessage in interface ValidationAware

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Parameters:
fieldName - name of field
errorMessage - the error message

hasActionErrors

public boolean hasActionErrors()
Description copied from interface: ValidationAware
Check whether there are any Action-level error messages.

Specified by:
hasActionErrors in interface ValidationAware
Returns:
true if any Action-level error messages have been registered

hasActionMessages

public boolean hasActionMessages()
Description copied from interface: ValidationAware
Checks whether there are any Action-level messages.

Specified by:
hasActionMessages in interface ValidationAware
Returns:
true if any Action-level messages have been registered

hasErrors

public boolean hasErrors()
Description copied from interface: ValidationAware
Note that this does not have the same meaning as in WW 1.x.

Specified by:
hasErrors in interface ValidationAware
Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

public boolean hasFieldErrors()
Description copied from interface: ValidationAware
Check whether there are any field errors associated with this action.

Specified by:
hasFieldErrors in interface ValidationAware
Returns:
whether there are any field errors

makeTextProvider

public static TextProvider makeTextProvider(Object object,
                                            LocaleProvider localeProvider)

makeLocaleProvider

protected static LocaleProvider makeLocaleProvider(Object object)

makeValidationAware

protected static ValidationAware makeValidationAware(Object object)

setTextProvider

protected void setTextProvider(TextProvider textProvider)

getTextProvider

protected TextProvider getTextProvider()

setValidationAware

protected void setValidationAware(ValidationAware validationAware)

getValidationAware

protected ValidationAware getValidationAware()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DelegatingValidatorContext.ActionContextLocaleProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DelegatingValidatorContext.ActionContextLocaleProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DelegatingValidatorContext.ActionContextLocaleProvider
All Implemented Interfaces:
LocaleProvider
Enclosing class:
DelegatingValidatorContext
private static class DelegatingValidatorContext.ActionContextLocaleProvider
extends Object
implements LocaleProvider

An implementation of LocaleProvider which gets the locale from the action context.

Constructor Summary
private DelegatingValidatorContext.ActionContextLocaleProvider()
Method Summary
 Locale getLocale()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DelegatingValidatorContext.ActionContextLocaleProvider

private DelegatingValidatorContext.ActionContextLocaleProvider()
Method Detail

getLocale

public Locale getLocale()
Specified by:
getLocale in interface LocaleProvider
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DelegatingValidatorContext.LoggingValidationAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class DelegatingValidatorContext.LoggingValidationAware

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware
All Implemented Interfaces:
ValidationAware
Enclosing class:
DelegatingValidatorContext
private static class DelegatingValidatorContext.LoggingValidationAware
extends Object
implements ValidationAware

An implementation of ValidationAware which logs errors and messages.

Field Summary
private  Log log
Constructor Summary
DelegatingValidatorContext.LoggingValidationAware(Class clazz)
DelegatingValidatorContext.LoggingValidationAware(Object obj)
Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addActionMessage(String aMessage) Add an Action-level message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
Collection | getActionErrors() Get the Collection of Action-level error messages for this action.
Collection | getActionMessages() Get the Collection of Action-level messages for this action.
Map | getFieldErrors() Get the field specific errors associated with this action.
boolean | hasActionErrors() Check whether there are any Action-level error messages.
boolean | hasActionMessages() Checks whether there are any Action-level messages.
boolean | hasErrors() Note that this does not have the same meaning as in WW 1.x.
boolean | hasFieldErrors() Check whether there are any field errors associated with this action.
void | setActionErrors(Collection errorMessages) Set the Collection of Action-level String error messages.
void | setActionMessages(Collection messages) Set the Collection of Action-level String messages (not errors).
void | setFieldErrors(Map errorMap) Set the field error map of fieldname (String) to Collection of String error messages.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private Log log
Constructor Detail

DelegatingValidatorContext.LoggingValidationAware

public DelegatingValidatorContext.LoggingValidationAware(Class clazz)

DelegatingValidatorContext.LoggingValidationAware

public DelegatingValidatorContext.LoggingValidationAware(Object obj)
Method Detail

setActionErrors

public void setActionErrors(Collection errorMessages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String error messages.

Specified by:
setActionErrors in interface ValidationAware

getActionErrors

public Collection getActionErrors()
Description copied from interface: ValidationAware
Get the Collection of Action-level error messages for this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionErrors in interface ValidationAware
Returns:
Collection of String error messages

setActionMessages

public void setActionMessages(Collection messages)
Description copied from interface: ValidationAware
Set the Collection of Action-level String messages (not errors).

Specified by:
setActionMessages in interface ValidationAware

getActionMessages

public Collection getActionMessages()
Description copied from interface: ValidationAware
Get the Collection of Action-level messages for this action. Messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getActionMessages in interface ValidationAware
Returns:
Collection of String messages

setFieldErrors

public void setFieldErrors(Map errorMap)
Description copied from interface: ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.

Specified by:
setFieldErrors in interface ValidationAware

getFieldErrors

public Map getFieldErrors()
Description copied from interface: ValidationAware
Get the field specific errors associated with this action. Error messages should not be added directly here, as implementations are free to return a new Collection or an Unmodifiable Collection.

Specified by:
getFieldErrors in interface ValidationAware
Returns:
Map with errors mapped from fieldname (String) to Collection of String error messages

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware

addActionMessage

public void addActionMessage(String aMessage)
Description copied from interface: ValidationAware
Add an Action-level message to this Action.

Specified by:
addActionMessage in interface ValidationAware

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Parameters:
fieldName - name of field
errorMessage - the error message

hasActionErrors

public boolean hasActionErrors()
Description copied from interface: ValidationAware
Check whether there are any Action-level error messages.

Specified by:
hasActionErrors in interface ValidationAware
Returns:
true if any Action-level error messages have been registered

hasActionMessages

public boolean hasActionMessages()
Description copied from interface: ValidationAware
Checks whether there are any Action-level messages.

Specified by:
hasActionMessages in interface ValidationAware
Returns:
true if any Action-level messages have been registered

hasErrors

public boolean hasErrors()
Description copied from interface: ValidationAware
Note that this does not have the same meaning as in WW 1.x.

Specified by:
hasErrors in interface ValidationAware
Returns:
(hasActionErrors() || hasFieldErrors())

hasFieldErrors

public boolean hasFieldErrors()
Description copied from interface: ValidationAware
Check whether there are any field errors associated with this action.

Specified by:
hasFieldErrors in interface ValidationAware
Returns:
whether there are any field errors
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidationInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidationInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  com.opensymphony.xwork2.validator.ValidationInterceptor
All Implemented Interfaces:
Interceptor, Serializable
Direct Known Subclasses:
AnnotationValidationInterceptor
public class ValidationInterceptor
extends MethodFilterInterceptor

This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware). This interceptor is often one of the last (or second to last) interceptors applied in a stack, as it assumes that all values have already been set on the action.

This interceptor does nothing if the name of the method being invoked is specified in the excludeMethods parameter. excludeMethods accepts a comma-delimited list of method names. For example, requests to foo!input.action and foo!back.action will be skipped by this interceptor if you set the excludeMethods parameter to "input, back".

Note that this has nothing to do with the Validateable interface and simply adds error messages to the action. The workflow of the action request does not change due to this interceptor. Rather, this interceptor is often used in conjuction with the workflow interceptor.

NOTE: As this method extends off MethodFilterInterceptor, it is capable of deciding if it is applicable only to selective methods in the action class. See MethodFilterInterceptor for more info.

Interceptor parameters:

  • None

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation"/>
     <interceptor-ref name="workflow"/>
     <result name="success">good_result.ftl</result>
 </action>

 <-- in the following case myMethod of the action class will not
        get validated -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation">
         <param name="excludeMethods">myMethod</param>
     </interceptor-ref>
     <interceptor-ref name="workflow"/>
     <result name="success">good_result.ftl</result>
 </action>

 <-- in the following case only annotated methods of the action class will
        be validated -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="validation">
         <param name="validateAnnotatedMethodOnly">true</param>
     </interceptor-ref>
     <interceptor-ref name="workflow"/>
     <result name="success">good_result.ftl</result>
 </action>

Version:
$Date: 2007-02-16 13:21:54 +0100 (Fr, 16 Feb 2007) $ $Id: ValidationInterceptor.java 1362 2007-02-16 12:21:54Z rainerh $
Author:
Jason Carreira, Rainer Hermanns, Alexandru Popescu
See Also:
ActionValidatorManager, DefaultWorkflowInterceptor, Serialized Form

Field Summary
private  boolean validateAnnotatedMethodOnly
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
ValidationInterceptor()
Method Summary
protected void | doBeforeInvocation(ActionInvocation invocation) Gets the current action and its context and calls DefaultActionValidatorManager.validate(Object, String).
protected String | doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
boolean | isValidateAnnotatedMethodOnly()
void | setValidateAnnotatedMethodOnly(String validateAnnotatedMethodOnly) Determine if validate() should always be called or only per annotated method.
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

validateAnnotatedMethodOnly

private boolean validateAnnotatedMethodOnly
Constructor Detail

ValidationInterceptor

public ValidationInterceptor()
Method Detail

isValidateAnnotatedMethodOnly

public boolean isValidateAnnotatedMethodOnly()

setValidateAnnotatedMethodOnly

public void setValidateAnnotatedMethodOnly(String validateAnnotatedMethodOnly)
Determine if validate() should always be called or only per annotated method. Default to "false".

Parameters:
validateAnnotatedMethodOnly -

doBeforeInvocation

protected void doBeforeInvocation(ActionInvocation invocation)
                           throws Exception
Gets the current action and its context and calls DefaultActionValidatorManager.validate(Object, String).

Parameters:
invocation - the execution state of the Action.
Throws:
Exception - if an error occurs validating the action.

doIntercept

protected String doIntercept(ActionInvocation invocation)
                      throws Exception
Description copied from class: MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.

Specified by:
doIntercept in class MethodFilterInterceptor
Parameters:
invocation - the action invocation
Returns:
the result of invocation
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorConfig (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidatorConfig

java.lang.Object
    extended by  com.opensymphony.xwork2.util.location.Located
        extended by  com.opensymphony.xwork2.validator.ValidatorConfig
All Implemented Interfaces:
Locatable
public class ValidatorConfig
extends Located

Holds the necessary information for configuring an instance of a Validator.

Author:
James House, Rainer Hermanns

Field Summary
private String | defaultMessage
private String | messageKey
private Map | params
private boolean | shortCircuit
private String | type
Fields inherited from class com.opensymphony.xwork2.util.location.Located
location
Constructor Summary
ValidatorConfig()
ValidatorConfig(String validatorType, Map params)
Method Summary
String | getDefaultMessage()
String | getMessageKey()
Map | getParams()
String | getType()
boolean | isShortCircuit()
void | setDefaultMessage(String defaultMessage)
void | setMessageKey(String messageKey)
void | setParams(Map params)
void | setShortCircuit(boolean shortCircuit)
void | setType(String validatorType)
Methods inherited from class com.opensymphony.xwork2.util.location.Located
getLocation, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

type

private String type

params

private Map params

defaultMessage

private String defaultMessage

messageKey

private String messageKey

shortCircuit

private boolean shortCircuit
Constructor Detail

ValidatorConfig

public ValidatorConfig()

ValidatorConfig

public ValidatorConfig(String validatorType,
                       Map params)
Parameters:
validatorType -
params -
Method Detail

getDefaultMessage

public String getDefaultMessage()
Returns:
Returns the defaultMessage for the validator.

setDefaultMessage

public void setDefaultMessage(String defaultMessage)
Parameters:
defaultMessage - The defaultMessage to set on the validator.

getMessageKey

public String getMessageKey()
Returns:
Returns the messageKey for the validator.

setMessageKey

public void setMessageKey(String messageKey)
Parameters:
messageKey - The messageKey to set on the validator.

isShortCircuit

public boolean isShortCircuit()
Returns:
Returns wether the shortCircuit flag should be set on the validator.

setShortCircuit

public void setShortCircuit(boolean shortCircuit)
Parameters:
shortCircuit - Whether the validator's shortCircuit flag should be set.

getParams

public Map getParams()
Returns:
Returns the configured params to set on the validator.

setParams

public void setParams(Map params)
Parameters:
params - The configured params to set on the validator.

getType

public String getType()
Returns:
Returns the type of validator to configure.

setType

public void setType(String validatorType)
Parameters:
validatorType - The type of validator to configure.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidatorFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.ValidatorFactory

public class ValidatorFactory
extends Object

ValidatorFactory

Validation rules are handled by validators, which must be registered with the ValidatorFactory (using the registerValidator method). The simplest way to do so is to add a file name validators.xml in the root of the classpath (/WEB-INF/classes) that declares all the validators you intend to use.

INFORMATION validators.xml if being defined should be available in the classpath. However this is not necessary, if no custom validator is needed. Predefined sets of validators will automatically be picked up when defined in com/opensymphony/xwork2/validator/validators/default.xml packaged in in the xwork jar file. See ValidatorFactory static block for details.

WARNING If custom validator is being defined and a validators.xml is created and place in the classpath, do remember to copy all the other pre-defined validators that is needed into the validators.xml as if not they will not be registered. Once a validators.xml is detected in the classpath, the default one (com/opensymphony/xwork2/validator/validators/default.xml) will not be loaded. It is only loaded when a custom validators.xml cannot be found in the classpath. Be careful.

Note: The default validationWorkflowStack already includes this.
All that is required to enable validation for an Action is to put the ValidationInterceptor in the interceptor refs of the action (see xwork.xml) like so:

     <interceptor name="validator" class="com.opensymphony.xwork2.validator.ValidationInterceptor"/>

Field Validators Field validators, as the name indicate, act on single fields accessible through an action. A validator, in contrast, is more generic and can do validations in the full action context, involving more than one field (or even no field at all) in validation rule. Most validations can be defined on per field basis. This should be preferred over non-field validation whereever possible, as field validator messages are bound to the related field and will be presented next to the corresponding input element in the respecting view.

Non Field Validators Non-field validators only add action level messages. Non-field validators are mostly domain specific and therefore offer custom implementations. The most important standard non-field validator provided by XWork is ExpressionValidator.

NOTE: Non-field validators takes precedence over field validators regardless of the order they are defined in *-validation.xml. If a non-field validator is short-circuited, it will causes its non-field validator to not being executed. See validation framework documentation for more info.

VALIDATION RULES: Validation rules can be specified:

  1. Per Action class: in a file named ActionName-validation.xml
  2. Per Action alias: in a file named ActionName-alias-validation.xml
  3. Inheritance hierarchy and interfaces implemented by Action class: XWork searches up the inheritance tree of the action to find default validations for parent classes of the Action and interfaces implemented
Here is an example for SimpleAction-validation.xml:

 <!DOCTYPE validators PUBLIC "-//OpenSymphony Group//XWork Validator 1.0.2//EN"
        "http://www.opensymphony.com/xwork/xwork-validator-1.0.2.dtd">
 <validators>
   <field name="bar">
       <field-validator type="required">
           <message>You must enter a value for bar.</message>
       </field-validator>
       <field-validator type="int">
           <param name="min">6</param>
           <param name="max">10</param>
           <message>bar must be between ${min} and ${max}, current value is ${bar}.</message>
       </field-validator>
   </field>
   <field name="bar2">
       <field-validator type="regex">
           <param name="regex">[0-9],[0-9]</param>
           <message>The value of bar2 must be in the format "x, y", where x and y are between 0 and 9</message>
      </field-validator>
   </field>
   <field name="date">
       <field-validator type="date">
           <param name="min">12/22/2002</param>
           <param name="max">12/25/2002</param>
           <message>The date must be between 12-22-2002 and 12-25-2002.</message>
       </field-validator>
   </field>
   <field name="foo">
       <field-validator type="int">
           <param name="min">0</param>
           <param name="max">100</param>
           <message key="foo.range">Could not find foo.range!</message>
       </field-validator>
   </field>
   <validator type="expression">
       <param name="expression">foo lt bar </param>
       <message>Foo must be greater than Bar. Foo = ${foo}, Bar = ${bar}.</message>
   </validator>
 </validators>

Here we can see the configuration of validators for the SimpleAction class. Validators (and field-validators) must have a type attribute, which refers to a name of an Validator registered with the ValidatorFactory as above. Validator elements may also have <param> elements with name and value attributes to set arbitrary parameters into the Validator instance. See below for discussion of the message element.

Each Validator or Field-Validator element must define one message element inside the validator element body. The message element has 1 attributes, key which is not required. The body of the message tag is taken as the default message which should be added to the Action if the validator fails.Key gives a message key to look up in the Action's ResourceBundles using getText() from LocaleAware if the Action implements that interface (as ActionSupport does). This provides for Localized messages based on the Locale of the user making the request (or whatever Locale you've set into the LocaleAware Action). After either retrieving the message from the ResourceBundle using the Key value, or using the Default message, the current Validator is pushed onto the ValueStack, then the message is parsed for \$\{...\} sections which are replaced with the evaluated value of the string between the \$\{ and \}. This allows you to parameterize your messages with values from the Validator, the Action, or both.

If the validator fails, the validator is pushed onto the ValueStack and the message - either the default or the locale-specific one if the key attribute is defined (and such a message exists) - is parsed for ${...} sections which are replaced with the evaluated value of the string between the ${ and }. This allows you to parameterize your messages with values from the validator, the Action, or both.

NOTE:Since validation rules are in an XML file, you must make sure you escape special characters. For example, notice that in the expression validator rule above we use ">" instead of ">". Consult a resource on XML for the full list of characters that must be escaped. The most commonly used characters that must be escaped are: & (use &), > (user >), and < (use <).

Here is an example of a parameterized message:

This will pull the min and max parameters from the IntRangeFieldValidator and the value of bar from the Action.

    bar must be between ${min} and ${max}, current value is ${bar}.

Version:
$Date: 2007-02-16 10:22:46 +0100 (Fr, 16 Feb 2007) $ $Id: ValidatorFactory.java 1355 2007-02-16 09:22:46Z rainerh $
Author:
Jason Carreira, James House

Field Summary
private static Log | LOG
private static Map | validators
Constructor Summary
private ValidatorFactory()
Method Summary
static Validator | getValidator(ValidatorConfig cfg) Deprecated.
static Validator | getValidator(ValidatorConfig cfg, ObjectFactory objectFactory) Get a Validator that matches the given configuration.
static String | lookupRegisteredValidatorType(String name) Lookup to get the FQ classname of the given validator name.
private static void | parseValidators()
static void | registerValidator(String name, String className) Registers the given validator to the existing map of validators.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

validators

private static Map validators

LOG

private static Log LOG
Constructor Detail

ValidatorFactory

private ValidatorFactory()
Method Detail

getValidator

public static Validator getValidator(ValidatorConfig cfg)
Deprecated.

Get a Validator that matches the given configuration.

Parameters:
cfg - the configurator.
Returns:
the validator.

getValidator

public static Validator getValidator(ValidatorConfig cfg,
                                     ObjectFactory objectFactory)
Get a Validator that matches the given configuration.

Parameters:
cfg - the configurator.
Returns:
the validator.

registerValidator

public static void registerValidator(String name,
                                     String className)
Registers the given validator to the existing map of validators. This will add to the existing list.

Parameters:
name - name of validator to add.
className - the FQ classname of the validator.

lookupRegisteredValidatorType

public static String lookupRegisteredValidatorType(String name)
Lookup to get the FQ classname of the given validator name.

Parameters:
name - name of validator to lookup.
Returns:
the found FQ classname
Throws:
IllegalArgumentException - is thrown if the name is not found.

parseValidators

private static void parseValidators()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorFileParser (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidatorFileParser

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.ValidatorFileParser

public class ValidatorFileParser
extends Object

Parse the validation file. (eg. MyAction-validation.xml, MyAction-actionAlias-validation.xml) to return a List of ValidatorConfig encapsulating the validator information.

Author:
Jason Carreira, James House, tm_jee ( tm_jee (at) yahoo.co.uk ), Rob Harrop, Rene Gielen
See Also:
ValidatorConfig

Field Summary
(package private) static String MULTI_TEXTVALUE_SEPARATOR
Constructor Summary
ValidatorFileParser()
Method Summary
private static void | addValidatorConfigs(NodeList validatorNodes, Map extraParams, List validatorCfgs)
static String | getTextValue(Element valueEle) Extract trimmed text value from the given DOM element, ignoring XML comments.
static List | parseActionValidatorConfigs(InputStream is, String resourceName) Parse resource for a list of ValidatorConfig objects.
static void | parseValidatorDefinitions(InputStream is) Deprecated. Use parseValidatorDefinitions(InputStream, String)
static void | parseValidatorDefinitions(InputStream is, String resourceName) Deprecated.
static void | parseValidatorDefinitions(InputStream is, String resourceName, ObjectFactory objectFactory) Parses validator definitions
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MULTI_TEXTVALUE_SEPARATOR

static final String MULTI_TEXTVALUE_SEPARATOR
See Also:
Constant Field Values
Constructor Detail

ValidatorFileParser

public ValidatorFileParser()
Method Detail

parseActionValidatorConfigs

public static List parseActionValidatorConfigs(InputStream is,
                                               String resourceName)
Parse resource for a list of ValidatorConfig objects.

Parameters:
is - input stream to the resource
resourceName - file name of the resource
Returns:
List list of ValidatorConfig

parseValidatorDefinitions

public static void parseValidatorDefinitions(InputStream is)
Deprecated. Use parseValidatorDefinitions(InputStream, String)

Parses validator definitions

Parameters:
is - The input stream

parseValidatorDefinitions

public static void parseValidatorDefinitions(InputStream is,
                                             String resourceName)
Deprecated.

Parses validator definitions

Parameters:
is - The input stream
resourceName - The location of the input stream

parseValidatorDefinitions

public static void parseValidatorDefinitions(InputStream is,
                                             String resourceName,
                                             ObjectFactory objectFactory)
Parses validator definitions

Parameters:
is - The input stream
resourceName - The location of the input stream
Since:
1.2

getTextValue

public static String getTextValue(Element valueEle)
Extract trimmed text value from the given DOM element, ignoring XML comments. Appends all CharacterData nodes and EntityReference nodes into a single String value, excluding Comment nodes. This method is based on a method originally found in DomUtils class of Springframework.

See Also:
CharacterData, EntityReference, Comment

addValidatorConfigs

private static void addValidatorConfigs(NodeList validatorNodes,
                                        Map extraParams,
                                        List validatorCfgs)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ValidationException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator
Class ValidationException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  com.opensymphony.xwork2.validator.ValidationException
All Implemented Interfaces:
Serializable
public class ValidationException
extends Exception

ValidationException.

Author:
Jason Carreira
See Also:
Serialized Form

Constructor Summary
ValidationException()
Constructs an Exception with no specified detail message.
ValidationException(String s)
Constructs an Exception with the specified detail message.
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ValidationException

public ValidationException()
Constructs an Exception with no specified detail message.

ValidationException

public ValidationException(String s)
Constructs an Exception with the specified detail message.

Parameters:
s - the detail message.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.validator.annotations (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.validator.annotations

Validator annotations.

See:
Description

Enum Summary
ValidatorType ValidatorType

Annotation Types Summary
ConversionErrorFieldValidator | This validator checks if there are any conversion errors for a field and applies them if they exist.
CustomValidator | This annotation can be used for custom validators.
DateRangeFieldValidator | This validator checks that a date field has a value within a specified range.
DoubleRangeFieldValidator | This validator checks that a double field has a value within a specified range.
EmailValidator | This validator checks that a field is a valid e-mail address if it contains a non-empty String.
ExpressionValidator | This non-field level validator validates a supplied regular expression.
FieldExpressionValidator | This validator uses an OGNL expression to perform its validator.
IntRangeFieldValidator | This validator checks that a numeric field has a value within a specified range.
RegexFieldValidator | Validates a string field using a regular expression.
RequiredFieldValidator | This validator checks that a field is non-null.
RequiredStringValidator | This validator checks that a String field is not empty (i.e.
StringLengthFieldValidator | This validator checks that a String field is of the right length.
StringRegexValidator | StringRegexValidator checks that a given String field, if not empty, matches the configured regular expression.
UrlValidator | This validator checks that a field is a valid URL.
Validation | If you want to use annotation based validation, you have to annotate the class or interface with Validation Annotation.
ValidationParameter | The ValidationParameter annotation is used as a parameter for CustomValidators.
Validations |
VisitorFieldValidator | The validator allows you to forward validator to object properties of your action using the objects own validator files.

Package com.opensymphony.xwork2.validator.annotations Description

Validator annotations.


com.opensymphony.xwork2.validator.annotations Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.validator.annotations

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.CustomValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.EmailValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ExpressionValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RegexFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.RequiredStringValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.StringRegexValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.UrlValidator (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.Validation (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.ValidationParameter (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.Validations (implements java.lang.annotation.Annotation)
  • com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • com.opensymphony.xwork2.validator.annotations.ValidatorType


Uses of Package com.opensymphony.xwork2.validator.annotations (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.validator.annotations

Packages that use com.opensymphony.xwork2.validator.annotations
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.annotations | Validator annotations.

Classes in com.opensymphony.xwork2.validator.annotations used by com.opensymphony.xwork2.validator
ConversionErrorFieldValidator
This validator checks if there are any conversion errors for a field and applies them if they exist.
CustomValidator
This annotation can be used for custom validators.
DateRangeFieldValidator
This validator checks that a date field has a value within a specified range.
DoubleRangeFieldValidator
This validator checks that a double field has a value within a specified range.
EmailValidator
This validator checks that a field is a valid e-mail address if it contains a non-empty String.
ExpressionValidator
This non-field level validator validates a supplied regular expression.
FieldExpressionValidator
This validator uses an OGNL expression to perform its validator.
IntRangeFieldValidator
This validator checks that a numeric field has a value within a specified range.
RegexFieldValidator
Validates a string field using a regular expression.
RequiredFieldValidator
This validator checks that a field is non-null.
RequiredStringValidator
This validator checks that a String field is not empty (i.e.
StringLengthFieldValidator
This validator checks that a String field is of the right length.
StringRegexValidator
StringRegexValidator checks that a given String field, if not empty, matches the configured regular expression.
UrlValidator
This validator checks that a field is a valid URL.
VisitorFieldValidator
The validator allows you to forward validator to object properties of your action using the objects own validator files.

Classes in com.opensymphony.xwork2.validator.annotations used by com.opensymphony.xwork2.validator.annotations
ValidatorType
ValidatorType

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ValidatorType (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

com.opensymphony.xwork2.validator.annotations
Enum ValidatorType

java.lang.Object
    extended by  java.lang.Enum<ValidatorType>
        extended by  com.opensymphony.xwork2.validator.annotations.ValidatorType
All Implemented Interfaces:
Serializable, Comparable<ValidatorType>
public enum ValidatorType
extends Enum<ValidatorType>

ValidatorType

Version:
$Id: ValidatorType.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Enum Constant Summary
FIELD
SIMPLE
Method Summary
String | toString()
static ValidatorType | valueOf(String name) Returns the enum constant of this type with the specified name.
static ValidatorType[] | values() Returns an array containing the constants of this enum type, in the order they're declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, getDeclaringClass, hashCode, name, ordinal, valueOf
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

FIELD

public static final ValidatorType FIELD

SIMPLE

public static final ValidatorType SIMPLE
Method Detail

values

public static final ValidatorType[] values()
Returns an array containing the constants of this enum type, in the order they're declared. This method may be used to iterate over the constants as follows:
for(ValidatorType c : ValidatorType.values())
        System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they're declared

valueOf

public static ValidatorType valueOf(String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum type has no constant with the specified name

toString

public String toString()
Overrides:
toString in class Enum<ValidatorType>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


ConversionErrorFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type ConversionErrorFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface ConversionErrorFieldValidator

This validator checks if there are any conversion errors for a field and applies them if they exist. See Type Conversion Error Handling for details.

Annotation usage:

The ConversionErrorFieldValidator annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @ConversionErrorFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true)

Version:
$Id: ConversionErrorFieldValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


CustomValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type CustomValidator

@Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface CustomValidator

This annotation can be used for custom validators. Use the ValidationParameter annotation to supply additional params.

Annotation usage:

The annotation must be applied at method or type level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @CustomValidator(type ="customValidatorName", fieldName = "myField")

Version:
$Id: CustomValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
jepjep, Rainer Hermanns

Required Element Summary
 String type
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key
String | message
ValidationParameter[] | parameters
boolean | shortCircuit

Element Detail

type

public abstract String type

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

message

public abstract String message
Default:
""

key

public abstract String key
Default:
""

parameters

public abstract ValidationParameter[] parameters
Default:
{}

shortCircuit

public abstract boolean shortCircuit
Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


DateRangeFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type DateRangeFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface DateRangeFieldValidator

This validator checks that a date field has a value within a specified range.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
min | no |  | Date property. The minimum the date must be.
max | no |  | Date property. The maximum date can be.

If neither min nor max is set, nothing will be done.

Example code:

 @DateRangeFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, min = "2005/01/01", max = "2005/12/31")

Version:
$Id: DateRangeFieldValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | max Date property.
String | min Date property.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

min

public abstract String min
Date property. The minimum the date must be.

Default:
""

max

public abstract String max
Date property. The maximum date can be.

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


DoubleRangeFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type DoubleRangeFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface DoubleRangeFieldValidator

This validator checks that a double field has a value within a specified range. If neither min nor max is set, nothing will be done.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
minInclusive | no |  | Double property. The inclusive minimum the number must be.
maxInclusive | no |  | Double property. The inclusive maximum number can be.
minExclusive | no |  | Double property. The exclusive minimum the number must be.
maxExclusive | no |  | Double property. The exclusive maximum number can be.

If neither min nor max is set, nothing will be done.

The values for min and max must be inserted as String values so that "0" can be handled as a possible value.

Example code:

 @DoubleRangeFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, minInclusive = "0.123", maxInclusive = "99.987")

Version:
$Id: DoubleRangeFieldValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | maxExclusive Double property.
String | maxInclusive Double property.
String | minExclusive Double property.
String | minInclusive Double property.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

minInclusive

public abstract String minInclusive
Double property. The inclusive minimum the number must be.

Default:
""

maxInclusive

public abstract String maxInclusive
Double property. The inclusive minimum the number must be.

Default:
""

minExclusive

public abstract String minExclusive
Double property. The exclusive maximum number can be.

Default:
""

maxExclusive

public abstract String maxExclusive
Double property. The exclusive maximum number can be.

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


EmailValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type EmailValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface EmailValidator

This validator checks that a field is a valid e-mail address if it contains a non-empty String.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @EmailValidator(message = "Default message", key = "i18n.key", shortCircuit = true)

Version:
$Id: EmailValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


ExpressionValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type ExpressionValidator

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface ExpressionValidator

This non-field level validator validates a supplied regular expression.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
expression | yes |  | An OGNL expression that returns a boolean value.

Example code:

 @ExpressionValidator(message = "Default message", key = "i18n.key", shortCircuit = true, expression = "an OGNL expression" )

Version:
$Id: ExpressionValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
String | expression The expressions to validate.
String | message The default error messages for this validator.
Optional Element Summary
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.

Element Detail

expression

public abstract String expression
The expressions to validate. An OGNL expression that returns a boolean value.

message

public abstract String message
The default error messages for this validator.

key

public abstract String key
The message key to lookup for i18n.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


FieldExpressionValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type FieldExpressionValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface FieldExpressionValidator

This validator uses an OGNL expression to perform its validator. The error message will be added to the field if the expression returns false when it is evaluated against the value stack.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
expression | yes |  | An OGNL expression that returns a boolean value.

Example code:

 @FieldExpressionValidator(message = "Default message", key = "i18n.key", shortCircuit = true, expression = "an OGNL expression")

Version:
$Id: FieldExpressionValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
String | expression An OGNL expression that returns a boolean value.
String | message The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.

Element Detail

expression

public abstract String expression
An OGNL expression that returns a boolean value.

message

public abstract String message
The default error message for this validator.

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


IntRangeFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type IntRangeFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface IntRangeFieldValidator

This validator checks that a numeric field has a value within a specified range. If neither min nor max is set, nothing will be done.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
min | no |  | Integer property. The minimum the number must be.
max | no |  | Integer property. The maximum number can be.

If neither min nor max is set, nothing will be done.

The values for min and max must be inserted as String values so that "0" can be handled as a possible value.

Example code:

 @IntRangeFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, min = "0", max = "42")

Version:
$Id: IntRangeFieldValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | max Integer property.
String | min Integer property.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

min

public abstract String min
Integer property. The minimum the number must be.

Default:
""

max

public abstract String max
Integer property. The maximum number can be.

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


RegexFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type RegexFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface RegexFieldValidator

Validates a string field using a regular expression.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @RegexFieldValidator( key = "regex.field", expression = "yourregexp")

Version:
$Id: RegexFieldValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
String | expression
String | message The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

expression

public abstract String expression

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


RequiredFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type RequiredFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface RequiredFieldValidator

This validator checks that a field is non-null.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @RequiredFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true)

Version:
$Id: RequiredFieldValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


RequiredStringValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type RequiredStringValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface RequiredStringValidator

This validator checks that a String field is not empty (i.e. non-null with a length > 0).

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
trim | no | true | Boolean property. Determines whether the String is trimmed before performing the length check.

Example code:

 @RequiredStringValidator(message = "Default message", key = "i18n.key", shortCircuit = true, trim = true)

Version:
$Id: RequiredStringValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
boolean | trim Boolean property.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

trim

public abstract boolean trim
Boolean property. Determines whether the String is trimmed before performing the length check.

Default:
true

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


StringLengthFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type StringLengthFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface StringLengthFieldValidator

This validator checks that a String field is of the right length. It assumes that the field is a String. If neither minLength nor maxLength is set, nothing will be done.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
trim | no | true | Boolean property. Determines whether the String is trimmed before performing the length check.
minLength | no |  | Integer property. The minimum length the String must be.
maxLength | no |  | Integer property. The maximum length the String can be.

If neither minLength nor maxLength is set, nothing will be done.

Example code:

 @StringLengthFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, trim = true, minLength = "5",  maxLength = "12")

Version:
$Id: StringLengthFieldValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
String | maxLength Integer property.
String | minLength Integer property.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
boolean | trim Boolean property.
ValidatorType[] | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

trim

public abstract boolean trim
Boolean property. Determines whether the String is trimmed before performing the length check.

Default:
true

minLength

public abstract String minLength
Integer property. The minimum length the String must be.

Default:
""

maxLength

public abstract String maxLength
Integer property. The maximum length the String can be.

Default:
""

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType[] type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


StringRegexValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type StringRegexValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface StringRegexValidator

StringRegexValidator checks that a given String field, if not empty, matches the configured regular expression.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
regex | yes | "." | String property. The Regular Expression for which to check a match.
caseSensitive | no | true | Whether the matching of alpha characters in the expression should be done case-sensitively.

Example code:

 @StringRegexValidator(message = "Default message", key = "i18n.key", shortCircuit = true, regex = "a regular expression", caseSensitive = true)

Version:
$Id: StringRegexValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
String | message The default error message for this validator.
String | regex String property.
Optional Element Summary
boolean | caseSensitive Whether the matching of alpha characters in the expression should be done case-sensitively.
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

regex

public abstract String regex
String property. The Regular ExpressionValidator for which to check a match.

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

caseSensitive

public abstract boolean caseSensitive
Whether the matching of alpha characters in the expression should be done case-sensitively.

Default:
true

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


UrlValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type UrlValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface UrlValidator

This validator checks that a field is a valid URL.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code:

 @UrlValidator(message = "Default message", key = "i18n.key", shortCircuit = true)

Version:
$Id: UrlValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.
ValidatorType | type The validation type for this field/method.

Element Detail

message

public abstract String message
The default error message for this validator.

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false

type

public abstract ValidatorType type
The validation type for this field/method.

Default:
FIELD
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Validation (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type Validation

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface Validation

If you want to use annotation based validation, you have to annotate the class or interface with Validation Annotation.

Annotation usage:

The Validation annotation must be applied at Type level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.

Example code: An Annotated Interface

 @Validation()
 public interface AnnotationDataAware {

     void setBarObj(Bar b);

     Bar getBarObj();

     @RequiredFieldValidator(message = "You must enter a value for data.")
     @RequiredStringValidator(message = "You must enter a value for data.")
     void setData(String data);

     String getData();
 }

Example code: An Annotated Class

 @Validation()
 public class SimpleAnnotationAction extends ActionSupport {

     @RequiredFieldValidator(type = ValidatorType.FIELD, message = "You must enter a value for bar.")
     @IntRangeFieldValidator(type = ValidatorType.FIELD, min = "6", max = "10", message = "bar must be between ${min} and ${max}, current value is ${bar}.")
     public void setBar(int bar) {
         this.bar = bar;
     }

     public int getBar() {
         return bar;
     }

     @Validations(
             requiredFields =
                     {@RequiredFieldValidator(type = ValidatorType.SIMPLE, fieldName = "customfield", message = "You must enter a value for field.")},
             requiredStrings =
                     {@RequiredStringValidator(type = ValidatorType.SIMPLE, fieldName = "stringisrequired", message = "You must enter a value for string.")},
             emails =
                     { @EmailValidator(type = ValidatorType.SIMPLE, fieldName = "emailaddress", message = "You must enter a value for email.")},
             urls =
                     { @UrlValidator(type = ValidatorType.SIMPLE, fieldName = "hreflocation", message = "You must enter a value for email.")},
             stringLengthFields =
                     {@StringLengthFieldValidator(type = ValidatorType.SIMPLE, trim = true, minLength="10" , maxLength = "12", fieldName = "needstringlength", message = "You must enter a stringlength.")},
             intRangeFields =
                     { @IntRangeFieldValidator(type = ValidatorType.SIMPLE, fieldName = "intfield", min = "6", max = "10", message = "bar must be between ${min} and ${max}, current value is ${bar}.")},
             dateRangeFields =
                     {@DateRangeFieldValidator(type = ValidatorType.SIMPLE, fieldName = "datefield", min = "-1", max = "99", message = "bar must be between ${min} and ${max}, current value is ${bar}.")},
             expressions = {
                 @ExpressionValidator(expression = "foo > 1", message = "Foo must be greater than Bar 1. Foo = ${foo}, Bar = ${bar}."),
                 @ExpressionValidator(expression = "foo > 2", message = "Foo must be greater than Bar 2. Foo = ${foo}, Bar = ${bar}."),
                 @ExpressionValidator(expression = "foo > 3", message = "Foo must be greater than Bar 3. Foo = ${foo}, Bar = ${bar}."),
                 @ExpressionValidator(expression = "foo > 4", message = "Foo must be greater than Bar 4. Foo = ${foo}, Bar = ${bar}."),
                 @ExpressionValidator(expression = "foo > 5", message = "Foo must be greater than Bar 5. Foo = ${foo}, Bar = ${bar}.")
     }
     )
     public String execute() throws Exception {
         return SUCCESS;
     }
 }

Version:
$Id: Validation.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Optional Element Summary
 Validations[] validations
Used for class or interface validation rules.

validations

public abstract Validations[] validations
Used for class or interface validation rules.

Default:
{}
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


ValidationParameter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type ValidationParameter

@Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface ValidationParameter

The ValidationParameter annotation is used as a parameter for CustomValidators.

Annotation usage:

The annotation must embedded into CustomValidator annotations as a parameter.

Annotation parameters:

Parameter | Required | Default | Notes
name | yes |  | parameter name.
value | yes |  | parameter value.

Example code:

 @CustomValidator(
   type ="customValidatorName",
   fieldName = "myField",
   parameters = { @ValidationParameter( name = "paramName", value = "paramValue" ) }
 )

Author:
jepjep, Rainer Hermanns

Required Element Summary
String | name
String | value

Element Detail

name

public abstract String name

value

public abstract String value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Validations (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type Validations

@Target(value={METHOD,TYPE})
@Retention(value=RUNTIME)
public @interface Validations

If you want to use several annotations of the same type, these annotation must be nested within the @Validations() annotation.

Annotation usage:

Used at METHOD level.

Annotation parameters:

Parameter | Required | Notes
requiredFields | no | Add list of RequiredFieldValidators
customValidators | no | Add list of CustomValidators
conversionErrorFields | no | Add list of ConversionErrorFieldValidators
dateRangeFields | no | Add list of DateRangeFieldValidators
emails | no | Add list of EmailValidators
fieldExpressions | no | Add list of FieldExpressionValidators
intRangeFields | no | Add list of IntRangeFieldValidators
requiredFields | no | Add list of RequiredFieldValidators
requiredStrings | no | Add list of RequiredStringValidators
stringLengthFields | no | Add list of StringLengthFieldValidators
urls | no | Add list of UrlValidators
visitorFields | no | Add list of VisitorFieldValidators
stringRegexs | no | Add list of StringRegexValidator
regexFields | no | Add list of RegexFieldValidator
expressions | no | Add list of ExpressionValidator

Example code:

 @Validations(
           requiredFields =
                   {@RequiredFieldValidator(type = ValidatorType.SIMPLE, fieldName = "customfield", message = "You must enter a value for field.")},
           requiredStrings =
                   {@RequiredStringValidator(type = ValidatorType.SIMPLE, fieldName = "stringisrequired", message = "You must enter a value for string.")},
           emails =
                   { @EmailValidator(type = ValidatorType.SIMPLE, fieldName = "emailaddress", message = "You must enter a value for email.")},
           urls =
                   { @UrlValidator(type = ValidatorType.SIMPLE, fieldName = "hreflocation", message = "You must enter a value for email.")},
           stringLengthFields =
                   {@StringLengthFieldValidator(type = ValidatorType.SIMPLE, trim = true, minLength="10" , maxLength = "12", fieldName = "needstringlength", message = "You must enter a stringlength.")},
           intRangeFields =
                   { @IntRangeFieldValidator(type = ValidatorType.SIMPLE, fieldName = "intfield", min = "6", max = "10", message = "bar must be between ${min} and ${max}, current value is ${bar}.")},
           dateRangeFields =
                   {@DateRangeFieldValidator(type = ValidatorType.SIMPLE, fieldName = "datefield", min = "-1", max = "99", message = "bar must be between ${min} and ${max}, current value is ${bar}.")},
           expressions = {
               @ExpressionValidator(expression = "foo > 1", message = "Foo must be greater than Bar 1. Foo = ${foo}, Bar = ${bar}."),
               @ExpressionValidator(expression = "foo > 2", message = "Foo must be greater than Bar 2. Foo = ${foo}, Bar = ${bar}."),
               @ExpressionValidator(expression = "foo > 3", message = "Foo must be greater than Bar 3. Foo = ${foo}, Bar = ${bar}."),
               @ExpressionValidator(expression = "foo > 4", message = "Foo must be greater than Bar 4. Foo = ${foo}, Bar = ${bar}."),
               @ExpressionValidator(expression = "foo > 5", message = "Foo must be greater than Bar 5. Foo = ${foo}, Bar = ${bar}.")
   }
   )
   public String execute() throws Exception {
       return SUCCESS;
   }

Version:
$Id: Validations.java 1216 2006-11-17 19:46:06Z jmitchell $
Author:
jepjep, Rainer Hermanns

Optional Element Summary
ConversionErrorFieldValidator[] | conversionErrorFields
CustomValidator[] | customValidators Custom Validation rules.
DateRangeFieldValidator[] | dateRangeFields
EmailValidator[] | emails
ExpressionValidator[] | expressions
FieldExpressionValidator[] | fieldExpressions
IntRangeFieldValidator[] | intRangeFields
RegexFieldValidator[] | regexFields
RequiredFieldValidator[] | requiredFields
RequiredStringValidator[] | requiredStrings
StringLengthFieldValidator[] | stringLengthFields
StringRegexValidator[] | stringRegexs
UrlValidator[] | urls
VisitorFieldValidator[] | visitorFields

customValidators

public abstract CustomValidator[] customValidators
Custom Validation rules.

Default:
{}

conversionErrorFields

public abstract ConversionErrorFieldValidator[] conversionErrorFields
Default:
{}

dateRangeFields

public abstract DateRangeFieldValidator[] dateRangeFields
Default:
{}

emails

public abstract EmailValidator[] emails
Default:
{}

fieldExpressions

public abstract FieldExpressionValidator[] fieldExpressions
Default:
{}

intRangeFields

public abstract IntRangeFieldValidator[] intRangeFields
Default:
{}

requiredFields

public abstract RequiredFieldValidator[] requiredFields
Default:
{}

requiredStrings

public abstract RequiredStringValidator[] requiredStrings
Default:
{}

stringLengthFields

public abstract StringLengthFieldValidator[] stringLengthFields
Default:
{}

urls

public abstract UrlValidator[] urls
Default:
{}

visitorFields

public abstract VisitorFieldValidator[] visitorFields
Default:
{}

stringRegexs

public abstract StringRegexValidator[] stringRegexs
Default:
{}

regexFields

public abstract RegexFieldValidator[] regexFields
Default:
{}

expressions

public abstract ExpressionValidator[] expressions
Default:
{}
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


VisitorFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

com.opensymphony.xwork2.validator.annotations
Annotation Type VisitorFieldValidator

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface VisitorFieldValidator

The validator allows you to forward validator to object properties of your action using the objects own validator files. This allows you to use the ModelDriven development pattern and manage your validations for your models in one place, where they belong, next to your model classes. The VisitorFieldValidator can handle either simple Object properties, Collections of Objects, or Arrays. The error message for the VisitorFieldValidator will be appended in front of validator messages added by the validations for the Object message.

Annotation usage:

The annotation must be applied at method level.

Annotation parameters:

Parameter | Required | Default | Notes
message | yes |  | field error message
key | no |  | i18n key from language specific properties file.
fieldName | no |  |
shortCircuit | no | false | If this validator should be used as shortCircuit.
type | yes | ValidatorType.FIELD | Enum value from ValidatorType. Either FIELD or SIMPLE can be used here.
context | no | action alias | Determines the context to use for validating the Object property. If not defined, the context of the Action validation is propogated to the Object property validation. In the case of Action validation, this context is the Action alias.
appendPrefix | no | true | Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. For example, suppose that the bean being validated has a "name" property. If appendPrefix is true, then the field error will be stored under the field "bean.name". If appendPrefix is false, then the field error will be stored under the field "name". If you are using the VisitorFieldValidator to validate the model from a ModelDriven Action, you should set appendPrefix to false unless you are using "model.name" to reference the properties on your model.

Example code:

 @VisitorFieldValidator(message = "Default message", key = "i18n.key", shortCircuit = true, context = "action alias", appendPrefix = true)

Version:
$Id: VisitorFieldValidator.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Required Element Summary
 String message
The default error message for this validator.
Optional Element Summary
boolean | appendPrefix Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
String | context Determines the context to use for validating the Object property.
String | fieldName The optional fieldName for SIMPLE validator types.
String | key The message key to lookup for i18n.
boolean | shortCircuit If this is activated, the validator will be used as short-circuit.

Element Detail

message

public abstract String message
The default error message for this validator.

context

public abstract String context
Determines the context to use for validating the Object property. If not defined, the context of the Action validator is propogated to the Object property validator. In the case of Action validator, this context is the Action alias.

Default:
""

appendPrefix

public abstract boolean appendPrefix
Determines whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. For example, suppose that the bean being validated has a "name" property. If appendPrefix is true, then the field error will be stored under the field "bean.name". If appendPrefix is false, then the field error will be stored under the field "name". If you are using the VisitorFieldValidator to validate the model from a ModelDriven Action, you should set appendPrefix to false unless you are using "model.name" to reference the properties on your model.

Default:
true

key

public abstract String key
The message key to lookup for i18n.

Default:
""

fieldName

public abstract String fieldName
The optional fieldName for SIMPLE validator types.

Default:
""

shortCircuit

public abstract boolean shortCircuit
If this is activated, the validator will be used as short-circuit. Adds the short-circuit="true" attribute value if true.

Default:
false
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


com.opensymphony.xwork2.validator.metadata (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.validator.metadata

Validator meta data classes.

See:
Description

Interface Summary
ValidatorDescription ValidatorDescription

Class Summary
AbstractFieldValidatorDescription | AbstractFieldValidatorDescription
ConversionErrorFieldValidatorDescription | ConversionErrorFieldValidatorDescription
DateRangeFieldValidatorDescription | DateRangeFieldValidatorDescription
DoubleRangeFieldValidatorDescription | DoubleRangeFieldValidatorDescription
EmailValidatorDescription | EmailValidatorDescription
ExpressionValidatorDescription | ExpressionValidatorDescription
FieldExpressionValidatorDescription | FieldExpressionValidatorDescription
IntRangeFieldValidatorDescription | IntRangeFieldValidatorDescription
RequiredFieldValidatorDescription | RequiredFieldValidatorDescription
RequiredStringValidatorDescription | RequiredStringValidatorDescription
StringLengthFieldValidatorDescription | StringLengthFieldValidatorDescription
URLValidatorDescription | URLValidatorDescription
VisitorFieldValidatorDescription | VisitorFieldValidatorDescription

Package com.opensymphony.xwork2.validator.metadata Description

Validator meta data classes.


com.opensymphony.xwork2.validator.metadata Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.validator.metadata

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription (implements com.opensymphony.xwork2.validator.metadata.ValidatorDescription)
      • com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
      • com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
    • com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription (implements com.opensymphony.xwork2.validator.metadata.ValidatorDescription)

Interface Hierarchy

  • com.opensymphony.xwork2.validator.metadata.ValidatorDescription


Uses of Package com.opensymphony.xwork2.validator.metadata (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.validator.metadata

Packages that use com.opensymphony.xwork2.validator.metadata
com.opensymphony.xwork2.validator.metadata Validator meta data classes.

Classes in com.opensymphony.xwork2.validator.metadata used by com.opensymphony.xwork2.validator.metadata
AbstractFieldValidatorDescription
AbstractFieldValidatorDescription
ValidatorDescription
ValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Interface ValidatorDescription

All Known Implementing Classes:
AbstractFieldValidatorDescription, ConversionErrorFieldValidatorDescription, DateRangeFieldValidatorDescription, DoubleRangeFieldValidatorDescription, EmailValidatorDescription, ExpressionValidatorDescription, FieldExpressionValidatorDescription, IntRangeFieldValidatorDescription, RequiredFieldValidatorDescription, RequiredStringValidatorDescription, StringLengthFieldValidatorDescription, URLValidatorDescription, VisitorFieldValidatorDescription
public interface ValidatorDescription

ValidatorDescription

Version:
$Id: ValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Method Summary
String | asXml() Returns the validator XML definition.
String | getFieldName() Returns the field name to create the validation rule for.
boolean | isSimpleValidator()
void | setKey(String key) Sets the I18N message key.
void | setMessage(String message) Sets the default validator failure message.
void | setShortCircuit(boolean shortCircuit) Set the shortCircuit flag.

Method Detail

asXml

String asXml()
Returns the validator XML definition.

Returns:
the validator XML definition.

getFieldName

String getFieldName()
Returns the field name to create the validation rule for.

Returns:
The field name to create the validation rule for

setKey

void setKey(String key)
Sets the I18N message key.

Parameters:
key - the I18N message key

setMessage

void setMessage(String message)
Sets the default validator failure message.

Parameters:
message - the default validator failure message

setShortCircuit

void setShortCircuit(boolean shortCircuit)
Set the shortCircuit flag.

Parameters:
shortCircuit - the shortCircuit flag.

isSimpleValidator

boolean isSimpleValidator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractFieldValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class AbstractFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
Direct Known Subclasses:
ConversionErrorFieldValidatorDescription, DateRangeFieldValidatorDescription, DoubleRangeFieldValidatorDescription, EmailValidatorDescription, FieldExpressionValidatorDescription, IntRangeFieldValidatorDescription, RequiredFieldValidatorDescription, RequiredStringValidatorDescription, StringLengthFieldValidatorDescription, URLValidatorDescription, VisitorFieldValidatorDescription
public abstract class AbstractFieldValidatorDescription
extends Object
implements ValidatorDescription

AbstractFieldValidatorDescription

Version:
$Id: AbstractFieldValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
String | fieldName
String | key
protected static Log | log Jakarta commons-logging reference.
String | message
boolean | shortCircuit
boolean | simpleValidator
Constructor Summary
AbstractFieldValidatorDescription()
AbstractFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
abstract String | asFieldXml() Returns the field validator XML definition.
abstract String | asSimpleXml() Returns the validator XML definition.
String | asXml() Returns the validator XML definition.
String | getFieldName() Sets the field name for this validator rule.
boolean | isSimpleValidator()
void | setFieldName(String fieldName) Sets the field name for this validator rule.
void | setKey(String key) Sets the I18N message key.
void | setMessage(String message) Sets the default validator failure message.
void | setShortCircuit(boolean shortCircuit) Set the shortCircuit flag.
void | setSimpleValidator(boolean simpleValidator)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static Log log
Jakarta commons-logging reference.

fieldName

public String fieldName

key

public String key

message

public String message

shortCircuit

public boolean shortCircuit

simpleValidator

public boolean simpleValidator
Constructor Detail

AbstractFieldValidatorDescription

public AbstractFieldValidatorDescription()

AbstractFieldValidatorDescription

public AbstractFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

getFieldName

public String getFieldName()
Sets the field name for this validator rule.

Specified by:
getFieldName in interface ValidatorDescription
Returns:
fieldName the field name for this validator rule

setFieldName

public void setFieldName(String fieldName)
Sets the field name for this validator rule.

Parameters:
fieldName - the field name for this validator rule

setKey

public void setKey(String key)
Sets the I18N message key.

Specified by:
setKey in interface ValidatorDescription
Parameters:
key - the I18N message key

setMessage

public void setMessage(String message)
Sets the default validator failure message.

Specified by:
setMessage in interface ValidatorDescription
Parameters:
message - the default validator failure message

setShortCircuit

public void setShortCircuit(boolean shortCircuit)
Set the shortCircuit flag.

Specified by:
setShortCircuit in interface ValidatorDescription
Parameters:
shortCircuit - the shortCircuit flag.

setSimpleValidator

public void setSimpleValidator(boolean simpleValidator)

isSimpleValidator

public boolean isSimpleValidator()
Specified by:
isSimpleValidator in interface ValidatorDescription

asXml

public String asXml()
Returns the validator XML definition.

Specified by:
asXml in interface ValidatorDescription
Returns:
the validator XML definition.

asFieldXml

public abstract String asFieldXml()
Returns the field validator XML definition.

Returns:
the field validator XML definition.

asSimpleXml

public abstract String asSimpleXml()
Returns the validator XML definition.

Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConversionErrorFieldValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class ConversionErrorFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class ConversionErrorFieldValidatorDescription
extends AbstractFieldValidatorDescription

ConversionErrorFieldValidatorDescription

Version:
$Id: ConversionErrorFieldValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
ConversionErrorFieldValidatorDescription()
ConversionErrorFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConversionErrorFieldValidatorDescription

public ConversionErrorFieldValidatorDescription()

ConversionErrorFieldValidatorDescription

public ConversionErrorFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateRangeFieldValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class DateRangeFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class DateRangeFieldValidatorDescription
extends AbstractFieldValidatorDescription

DateRangeFieldValidatorDescription

Version:
$Id: DateRangeFieldValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
String | max
String | min
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
DateRangeFieldValidatorDescription()
DateRangeFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setMax(String max)
void | setMin(String min)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

min

public String min

max

public String max
Constructor Detail

DateRangeFieldValidatorDescription

public DateRangeFieldValidatorDescription()

DateRangeFieldValidatorDescription

public DateRangeFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setMin

public void setMin(String min)

setMax

public void setMax(String max)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleRangeFieldValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class DoubleRangeFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class DoubleRangeFieldValidatorDescription
extends AbstractFieldValidatorDescription

DoubleRangeFieldValidatorDescription

Version:
$Id: DoubleRangeFieldValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
String | max
String | min
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
DoubleRangeFieldValidatorDescription()
DoubleRangeFieldValidatorDescription(String fieldName)
Creates an DoubleRangeFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setMax(String max)
void | setMin(String min)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

min

public String min

max

public String max
Constructor Detail

DoubleRangeFieldValidatorDescription

public DoubleRangeFieldValidatorDescription()

DoubleRangeFieldValidatorDescription

public DoubleRangeFieldValidatorDescription(String fieldName)
Creates an DoubleRangeFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setMin

public void setMin(String min)

setMax

public void setMax(String max)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmailValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class EmailValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class EmailValidatorDescription
extends AbstractFieldValidatorDescription

EmailValidatorDescription

Version:
$Id: EmailValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
EmailValidatorDescription()
EmailValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

EmailValidatorDescription

public EmailValidatorDescription()

EmailValidatorDescription

public EmailValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpressionValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class ExpressionValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class ExpressionValidatorDescription
extends Object
implements ValidatorDescription

ExpressionValidatorDescription

Version:
$Id: ExpressionValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
String | expression
String | key
String | message
boolean | shortCircuit
Constructor Summary
ExpressionValidatorDescription()
Method Summary
String | asXml() Returns the validator XML definition.
String | getFieldName() Returns the field name to create the validation rule for.
boolean | isSimpleValidator()
void | setExpression(String expression)
void | setKey(String key) Sets the I18N message key.
void | setMessage(String message) Sets the default validator failure message.
void | setShortCircuit(boolean shortCircuit) Set the shortCircuit flag.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

expression

public String expression

key

public String key

message

public String message

shortCircuit

public boolean shortCircuit
Constructor Detail

ExpressionValidatorDescription

public ExpressionValidatorDescription()
Method Detail

setExpression

public void setExpression(String expression)

setKey

public void setKey(String key)
Description copied from interface: ValidatorDescription
Sets the I18N message key.

Specified by:
setKey in interface ValidatorDescription
Parameters:
key - the I18N message key

setMessage

public void setMessage(String message)
Description copied from interface: ValidatorDescription
Sets the default validator failure message.

Specified by:
setMessage in interface ValidatorDescription
Parameters:
message - the default validator failure message

setShortCircuit

public void setShortCircuit(boolean shortCircuit)
Description copied from interface: ValidatorDescription
Set the shortCircuit flag.

Specified by:
setShortCircuit in interface ValidatorDescription
Parameters:
shortCircuit - the shortCircuit flag.

getFieldName

public String getFieldName()
Returns the field name to create the validation rule for.

Specified by:
getFieldName in interface ValidatorDescription
Returns:
The field name to create the validation rule for

asXml

public String asXml()
Description copied from interface: ValidatorDescription
Returns the validator XML definition.

Specified by:
asXml in interface ValidatorDescription
Returns:
the validator XML definition.

isSimpleValidator

public boolean isSimpleValidator()
Specified by:
isSimpleValidator in interface ValidatorDescription
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldExpressionValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class FieldExpressionValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class FieldExpressionValidatorDescription
extends AbstractFieldValidatorDescription

FieldExpressionValidatorDescription

Version:
$Id: FieldExpressionValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
String | expression
String | key
String | message
boolean | shortCircuit
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, log, simpleValidator
Constructor Summary
FieldExpressionValidatorDescription()
FieldExpressionValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setExpression(String expression)
void | setKey(String key) Sets the I18N message key.
void | setMessage(String message) Sets the default validator failure message.
void | setShortCircuit(boolean shortCircuit) Set the shortCircuit flag.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

expression

public String expression

key

public String key

message

public String message

shortCircuit

public boolean shortCircuit
Constructor Detail

FieldExpressionValidatorDescription

public FieldExpressionValidatorDescription()

FieldExpressionValidatorDescription

public FieldExpressionValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setExpression

public void setExpression(String expression)

setKey

public void setKey(String key)
Description copied from class: AbstractFieldValidatorDescription
Sets the I18N message key.

Specified by:
setKey in interface ValidatorDescription
Overrides:
setKey in class AbstractFieldValidatorDescription
Parameters:
key - the I18N message key

setMessage

public void setMessage(String message)
Description copied from class: AbstractFieldValidatorDescription
Sets the default validator failure message.

Specified by:
setMessage in interface ValidatorDescription
Overrides:
setMessage in class AbstractFieldValidatorDescription
Parameters:
message - the default validator failure message

setShortCircuit

public void setShortCircuit(boolean shortCircuit)
Description copied from class: AbstractFieldValidatorDescription
Set the shortCircuit flag.

Specified by:
setShortCircuit in interface ValidatorDescription
Overrides:
setShortCircuit in class AbstractFieldValidatorDescription
Parameters:
shortCircuit - the shortCircuit flag.

asFieldXml

public String asFieldXml()
Returns the validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntRangeFieldValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class IntRangeFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class IntRangeFieldValidatorDescription
extends AbstractFieldValidatorDescription

IntRangeFieldValidatorDescription

Version:
$Id: IntRangeFieldValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
String | max
String | min
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
IntRangeFieldValidatorDescription()
IntRangeFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setMax(String max)
void | setMin(String min)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

min

public String min

max

public String max
Constructor Detail

IntRangeFieldValidatorDescription

public IntRangeFieldValidatorDescription()

IntRangeFieldValidatorDescription

public IntRangeFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setMin

public void setMin(String min)

setMax

public void setMax(String max)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequiredFieldValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class RequiredFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class RequiredFieldValidatorDescription
extends AbstractFieldValidatorDescription

RequiredFieldValidatorDescription

Version:
$Id: RequiredFieldValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
RequiredFieldValidatorDescription()
RequiredFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RequiredFieldValidatorDescription

public RequiredFieldValidatorDescription()

RequiredFieldValidatorDescription

public RequiredFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequiredStringValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class RequiredStringValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class RequiredStringValidatorDescription
extends AbstractFieldValidatorDescription

RequiredStringValidatorDescription

Version:
$Id: RequiredStringValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
 boolean trim
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
RequiredStringValidatorDescription()
RequiredStringValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setTrim(boolean trim)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

trim

public boolean trim
Constructor Detail

RequiredStringValidatorDescription

public RequiredStringValidatorDescription()

RequiredStringValidatorDescription

public RequiredStringValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setTrim

public void setTrim(boolean trim)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringLengthFieldValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class StringLengthFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class StringLengthFieldValidatorDescription
extends AbstractFieldValidatorDescription

StringLengthFieldValidatorDescription

Version:
$Id: StringLengthFieldValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
String | maxLength
String | minLength
boolean | trim
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
StringLengthFieldValidatorDescription()
StringLengthFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setMaxLength(String maxLength)
void | setMinLength(String minLength)
void | setTrim(boolean trim)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

trim

public boolean trim

minLength

public String minLength

maxLength

public String maxLength
Constructor Detail

StringLengthFieldValidatorDescription

public StringLengthFieldValidatorDescription()

StringLengthFieldValidatorDescription

public StringLengthFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setTrim

public void setTrim(boolean trim)

setMinLength

public void setMinLength(String minLength)

setMaxLength

public void setMaxLength(String maxLength)

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class URLValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class URLValidatorDescription
extends AbstractFieldValidatorDescription

URLValidatorDescription

Version:
$Id: URLValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
URLValidatorDescription()
URLValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified aliasNames.
Method Summary
String | asFieldXml() Returns the field validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

URLValidatorDescription

public URLValidatorDescription()

URLValidatorDescription

public URLValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified aliasNames.

Parameters:
fieldName -
Method Detail

asFieldXml

public String asFieldXml()
Returns the field validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the field validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VisitorFieldValidatorDescription (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.metadata
Class VisitorFieldValidatorDescription

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
        extended by  com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
All Implemented Interfaces:
ValidatorDescription
public class VisitorFieldValidatorDescription
extends AbstractFieldValidatorDescription

VisitorFieldValidatorDescription

Version:
$Id: VisitorFieldValidatorDescription.java 1187 2006-11-13 08:05:32Z mrdon $
Author:
Rainer Hermanns

Field Summary
boolean | appendPrefix
String | context
Fields inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
fieldName, key, log, message, shortCircuit, simpleValidator
Constructor Summary
VisitorFieldValidatorDescription()
VisitorFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.
Method Summary
String | asFieldXml() Returns the validator XML definition.
String | asSimpleXml() Returns the validator XML definition.
void | setAppendPrefix(boolean appendPrefix)
void | setContext(String context)
Methods inherited from class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
asXml, getFieldName, isSimpleValidator, setFieldName, setKey, setMessage, setShortCircuit, setSimpleValidator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

context

public String context

appendPrefix

public boolean appendPrefix
Constructor Detail

VisitorFieldValidatorDescription

public VisitorFieldValidatorDescription()

VisitorFieldValidatorDescription

public VisitorFieldValidatorDescription(String fieldName)
Creates an AbstractFieldValidatorDescription with the specified field name.

Parameters:
fieldName -
Method Detail

setContext

public void setContext(String context)

setAppendPrefix

public void setAppendPrefix(boolean appendPrefix)

asFieldXml

public String asFieldXml()
Returns the validator XML definition.

Specified by:
asFieldXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.

asSimpleXml

public String asSimpleXml()
Returns the validator XML definition.

Specified by:
asSimpleXml in class AbstractFieldValidatorDescription
Returns:
the validator XML definition.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.validator.validators (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package com.opensymphony.xwork2.validator.validators

XWork default validator classes.

See:
Description

Class Summary
AbstractRangeValidator | Base class for range based validators.
ConversionErrorFieldValidator | Field Validator that checks if a conversion error occured for this field.
DateRangeFieldValidator | Field Validator that checks if the date supplied is within a specific range.
DoubleRangeFieldValidator | Field Validator that checks if the double specified is within a certain range.
EmailValidator | EmailValidator checks that a given String field, if not empty, is a valid email address.
ExpressionValidator | A Non-Field Level validator that validates based on regular expression supplied.
FieldExpressionValidator | Validates a field using an OGNL expression.
FieldValidatorSupport | Base class for field validators.
IntRangeFieldValidator | Field Validator that checks if the integer specified is within a certain range.
RegexFieldValidator | Validates a string field using a regular expression.
RepopulateConversionErrorFieldValidatorSupport | An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
RequiredFieldValidator | RequiredFieldValidator checks if the specified field is not null.
RequiredStringValidator | RequiredStringValidator checks that a String field is non-null and has a length > 0.
StringLengthFieldValidator | StringLengthFieldValidator checks that a String field is of a certain length.
URLValidator | URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
ValidatorSupport | Abstract implementation of the Validator interface suitable for subclassing.
VisitorFieldValidator | The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Package com.opensymphony.xwork2.validator.validators Description

XWork default validator classes.


com.opensymphony.xwork2.validator.validators Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package com.opensymphony.xwork2.validator.validators

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.validator.DelegatingValidatorContext (implements com.opensymphony.xwork2.validator.ValidatorContext)
      • com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
    • com.opensymphony.xwork2.validator.validators.ValidatorSupport (implements com.opensymphony.xwork2.validator.ShortCircuitableValidator, com.opensymphony.xwork2.validator.Validator)
      • com.opensymphony.xwork2.validator.validators.ExpressionValidator
      • com.opensymphony.xwork2.validator.validators.FieldValidatorSupport (implements com.opensymphony.xwork2.validator.FieldValidator)
        • com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
          • com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
          • com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
        • com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
        • com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
        • com.opensymphony.xwork2.validator.validators.RegexFieldValidator
          • com.opensymphony.xwork2.validator.validators.EmailValidator
        • com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
          • com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
        • com.opensymphony.xwork2.validator.validators.RequiredFieldValidator
        • com.opensymphony.xwork2.validator.validators.RequiredStringValidator
        • com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
        • com.opensymphony.xwork2.validator.validators.URLValidator
        • com.opensymphony.xwork2.validator.validators.VisitorFieldValidator


Uses of Package com.opensymphony.xwork2.validator.validators (Struts 2 Core 2.0.6 API)

Uses of Package
com.opensymphony.xwork2.validator.validators

Packages that use com.opensymphony.xwork2.validator.validators
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Classes in com.opensymphony.xwork2.validator.validators used by com.opensymphony.xwork2.validator.validators
AbstractRangeValidator
Base class for range based validators.
FieldValidatorSupport
Base class for field validators.
RegexFieldValidator
Validates a string field using a regular expression.
RepopulateConversionErrorFieldValidatorSupport
An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
ValidatorSupport
Abstract implementation of the Validator interface suitable for subclassing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractRangeValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class AbstractRangeValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
DateRangeFieldValidator, IntRangeFieldValidator
public abstract class AbstractRangeValidator
extends FieldValidatorSupport

Base class for range based validators.

Author:
Jason Carreira, Cameron Braid

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
AbstractRangeValidator()
Method Summary
protected abstract Comparable | getMaxComparatorValue()
protected abstract Comparable | getMinComparatorValue()
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Constructor Detail

AbstractRangeValidator

public AbstractRangeValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException

getMaxComparatorValue

protected abstract Comparable getMaxComparatorValue()

getMinComparatorValue

protected abstract Comparable getMinComparatorValue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ConversionErrorFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class ConversionErrorFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
                extended by  com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class ConversionErrorFieldValidator
extends RepopulateConversionErrorFieldValidatorSupport

Field Validator that checks if a conversion error occured for this field.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
     <!-- Plain Validator Syntax -->
     <validator type="conversion">
                <param name="fieldName">myField</param>
          <message>Conversion Error Occurred</message>
     </validator>

     <!-- Field Validator Syntax -->
     <field name="myField">
        <field-validator type="conversion">
           <message>Conversion Error Occurred</message>
        </field-validator>
     </field>

Version:
$Date $Id: ConversionErrorFieldValidator.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Jason Carreira, tm_jee

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
ConversionErrorFieldValidator()
Method Summary
 void doValidate(Object object)
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
getRepopulateField, repopulateField, setRepopulateField, validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Constructor Detail

ConversionErrorFieldValidator

public ConversionErrorFieldValidator()
Method Detail

doValidate

public void doValidate(Object object)
                throws ValidationException
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Specified by:
doValidate in class RepopulateConversionErrorFieldValidatorSupport
Parameters:
object -
Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateRangeFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class DateRangeFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
                extended by  com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class DateRangeFieldValidator
extends AbstractRangeValidator

Field Validator that checks if the date supplied is within a specific range. NOTE: If no date converter is specified, XWorkBasicConverter will kick in to do the date conversion, which by default using the Date.SHORT format using the a programmatically specified locale else falling back to the system default locale.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • min - the min date range. If not specified will not be checked.
  • max - the max date range. If not specified will not be checked.

    <validators>
                <!-- Plain Validator syntax -->
                <validator type="date">
                <param name="fieldName">birthday</param>
              <param name="min">01/01/1990</param>
              <param name="max">01/01/2000</param>
              <message>Birthday must be within ${min} and ${max}</message>
                </validator>

          <!-- Field Validator Syntax -->
          <field name="birthday">
                <field-validator type="date">
                    <param name="min">01/01/1990</param>
                  <param name="max">01/01/2000</param>
                  <message>Birthday must be within ${min} and ${max}</message>
                </field>
          </field>

    </validators>

Version:
$Date: 2006-10-27 07:48:38 +0200 (Fr, 27 Okt 2006) $ $Id: DateRangeFieldValidator.java 1177 2006-10-27 05:48:38Z mrdon $
Author:
Jason Carreira

Field Summary
private Date | max
private Date | min
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
DateRangeFieldValidator()
Method Summary
Date | getMax()
protected Comparable | getMaxComparatorValue()
Date | getMin()
protected Comparable | getMinComparatorValue()
void | setMax(Date max)
void | setMin(Date min)
Methods inherited from class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

max

private Date max

min

private Date min
Constructor Detail

DateRangeFieldValidator

public DateRangeFieldValidator()
Method Detail

setMax

public void setMax(Date max)

getMax

public Date getMax()

setMin

public void setMin(Date min)

getMin

public Date getMin()

getMaxComparatorValue

protected Comparable getMaxComparatorValue()
Specified by:
getMaxComparatorValue in class AbstractRangeValidator

getMinComparatorValue

protected Comparable getMinComparatorValue()
Specified by:
getMinComparatorValue in class AbstractRangeValidator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleRangeFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class DoubleRangeFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class DoubleRangeFieldValidator
extends FieldValidatorSupport

Field Validator that checks if the double specified is within a certain range.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • minInclusive - the minimum inclusive value in FloatValue format specified by Java language (if none is specified, it will not be checked)
  • maxInclusive - the maximum inclusive value in FloatValue format specified by Java language (if none is specified, it will not be checked)
  • minExclusive - the minimum exclusive value in FloatValue format specified by Java language (if none is specified, it will not be checked)
  • maxExclusive - the maximum exclusive value in FloatValue format specified by Java language (if none is specified, it will not be checked)

                 <validators>
           <!-- Plain Validator Syntax -->
           <validator type="double">
               <param name="fieldName">percentage</param>
               <param name="minInclusive">20.1</param>
               <param name="maxInclusive">50.1</param>
               <message>Age needs to be between ${minInclusive} and
${maxInclusive} (inclusive)</message>
           </validator>

           <!-- Field Validator Syntax -->
           <field name="percentage">
               <field-validator type="double">
                   <param name="minExclusive">0.123</param>
                   <param name="maxExclusive">99.98</param>
                   <message>Percentage needs to be between ${minExclusive}
and ${maxExclusive} (exclusive)</message>
               </field-validator>
           </field>
      </validators>

Version:
$Id: DoubleRangeFieldValidator.java 1184 2006-11-12 07:30:31Z tm_jee $
Author:
Rainer Hermanns, Rene Gielen

Field Summary
(package private) String | maxExclusive
(package private) Double | maxExclusiveValue
(package private) String | maxInclusive
(package private) Double | maxInclusiveValue
(package private) String | minExclusive
(package private) Double | minExclusiveValue
(package private) String | minInclusive
(package private) Double | minInclusiveValue
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
DoubleRangeFieldValidator()
Method Summary
String | getMaxExclusive()
String | getMaxInclusive()
String | getMinExclusive()
String | getMinInclusive()
private Double | parseDouble(String value)
private void | parseParameterValues()
void | setMaxExclusive(String maxExclusive)
void | setMaxInclusive(String maxInclusive)
void | setMinExclusive(String minExclusive)
void | setMinInclusive(String minInclusive)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

maxInclusive

String maxInclusive

minInclusive

String minInclusive

minExclusive

String minExclusive

maxExclusive

String maxExclusive

maxInclusiveValue

Double maxInclusiveValue

minInclusiveValue

Double minInclusiveValue

minExclusiveValue

Double minExclusiveValue

maxExclusiveValue

Double maxExclusiveValue
Constructor Detail

DoubleRangeFieldValidator

public DoubleRangeFieldValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException

parseParameterValues

private void parseParameterValues()

parseDouble

private Double parseDouble(String value)

setMaxInclusive

public void setMaxInclusive(String maxInclusive)

getMaxInclusive

public String getMaxInclusive()

setMinInclusive

public void setMinInclusive(String minInclusive)

getMinInclusive

public String getMinInclusive()

getMinExclusive

public String getMinExclusive()

setMinExclusive

public void setMinExclusive(String minExclusive)

getMaxExclusive

public String getMaxExclusive()

setMaxExclusive

public void setMaxExclusive(String maxExclusive)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


EmailValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class EmailValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RegexFieldValidator
                extended by  com.opensymphony.xwork2.validator.validators.EmailValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class EmailValidator
extends RegexFieldValidator

EmailValidator checks that a given String field, if not empty, is a valid email address.

The regular expression used to validate that the string is an email address is:

 \\b(^[_A-Za-z0-9-]+(\\.[_A-Za-z0-9-]+)*@([A-Za-z0-9-])+((\\.com)|(\\.net)|(\\.org)|(\\.info)|(\\.edu)|(\\.mil)|(\\.gov)|(\\.biz)|(\\.ws)|(\\.us)|(\\.tv)|(\\.cc)|(\\.aero)|(\\.arpa)|(\\.coop)|(\\.int)|(\\.jobs)|(\\.museum)|(\\.name)|(\\.pro)|(\\.travel)|(\\.nato)|(\\..{2,3})|(\\..{2,3}\\..{2,3}))$)\\b
  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required

     <!-- Plain Validator Syntax -->
     <validators>
         <validator type="email">
             <param name="fieldName">myEmail</param>
             <message>Must provide a valid email</message>
         </validator>
     </validators>

     <!-- Field Validator Syntax -->
     <field name="myEmail">
        <field-validator type="email">
           <message>Must provide a valid email</message>
        </field-validator>
     </field>

Version:
$Date: 2006-07-10 02:30:29 +0200 (Mo, 10 Jul 2006) $ $Id: EmailValidator.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
jhouse, tm_jee

Field Summary
static String emailAddressPattern
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
EmailValidator()
Method Summary
Methods inherited from class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
getExpression, isCaseSensitive, isTrimed, setCaseSensitive, setExpression, setTrim, validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

emailAddressPattern

public static final String emailAddressPattern
See Also:
Constant Field Values
Constructor Detail

EmailValidator

public EmailValidator()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExpressionValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class ExpressionValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.ExpressionValidator
All Implemented Interfaces:
ShortCircuitableValidator, Validator
public class ExpressionValidator
extends ValidatorSupport

A Non-Field Level validator that validates based on regular expression supplied.

  • expression - the Ognl expression to be evaluated against the stack (Must evaluate to a Boolean)

     <validators>
           <validator type="expression">
              <param name="expression"> .... </param>
              <message>Failed to meet Ognl Expression  .... </message>
           </validator>
     </validators>

Author:
Jason Carreira

Field Summary
private  String expression
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
ExpressionValidator()
Method Summary
String | getExpression()
void | setExpression(String expression)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, getValidatorType, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext, setValidatorType
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

expression

private String expression
Constructor Detail

ExpressionValidator

public ExpressionValidator()
Method Detail

setExpression

public void setExpression(String expression)

getExpression

public String getExpression()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldExpressionValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class FieldExpressionValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.FieldExpressionValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class FieldExpressionValidator
extends FieldValidatorSupport

Validates a field using an OGNL expression.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • expression - The Ognl expression (must evaluate to a boolean) which is to be evalidated the stack

    <!-- Plain Validator Syntax -->
    <validators>
        <!-- Plain Validator Syntax -->
        <validator type="fieldexpression">
           <param name="fieldName">myField</param>
           <param name="expression"><![CDATA[#myCreditLimit > #myGirfriendCreditLimit]]></param>
           <message>My credit limit should be MORE than my girlfriend</message>
        <validator>

        <!-- Field Validator Syntax -->
        <field name="myField">
            <field-validator type="fieldexpression">
                <param name="expression"><![CDATA[#myCreditLimit > #myGirfriendCreditLimit]]></param>
                <message>My credit limit should be MORE than my girlfriend</message>
            </field-validator>
        </field>

    </vaidators>

Version:
$Revision: 1063 $
Author:
$Author: mrdon $

Field Summary
private  String expression
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
FieldExpressionValidator()
Method Summary
String | getExpression()
void | setExpression(String expression)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

expression

private String expression
Constructor Detail

FieldExpressionValidator

public FieldExpressionValidator()
Method Detail

setExpression

public void setExpression(String expression)

getExpression

public String getExpression()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldValidatorSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class FieldValidatorSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
AbstractRangeValidator, DoubleRangeFieldValidator, FieldExpressionValidator, RegexFieldValidator, RepopulateConversionErrorFieldValidatorSupport, RequiredFieldValidator, RequiredStringValidator, StringLengthFieldValidator, URLValidator, VisitorFieldValidator
public abstract class FieldValidatorSupport
extends ValidatorSupport
implements FieldValidator

Base class for field validators.

Author:
Jason Carreira

Field Summary
private String | fieldName
private String | type
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
FieldValidatorSupport()
Method Summary
String | getFieldName()
String | getValidatorType()
void | setFieldName(String fieldName) Sets the field name to validate with this FieldValidator
void | setValidatorType(String type)
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext, validate

Field Detail

fieldName

private String fieldName

type

private String type
Constructor Detail

FieldValidatorSupport

public FieldValidatorSupport()
Method Detail

setFieldName

public void setFieldName(String fieldName)
Description copied from interface: FieldValidator
Sets the field name to validate with this FieldValidator

Specified by:
setFieldName in interface FieldValidator

getFieldName

public String getFieldName()
Specified by:
getFieldName in interface FieldValidator
Returns:
the field name to be validated

setValidatorType

public void setValidatorType(String type)
Specified by:
setValidatorType in interface Validator
Overrides:
setValidatorType in class ValidatorSupport

getValidatorType

public String getValidatorType()
Specified by:
getValidatorType in interface Validator
Overrides:
getValidatorType in class ValidatorSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IntRangeFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class IntRangeFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
                extended by  com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class IntRangeFieldValidator
extends AbstractRangeValidator

Field Validator that checks if the integer specified is within a certain range.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • min - the minimum value (if none is specified, it will not be checked)
  • max - the maximum value (if none is specified, it will not be checked)

                <validators>
           <!-- Plain Validator Syntax -->
           <validator type="int">
               <param name="fieldName">age</param>
               <param name="min">20</param>
               <param name="max">50</param>
               <message>Age needs to be between ${min} and ${max}</message>
           </validator>

           <!-- Field Validator Syntax -->
           <field name="age">
               <field-validator type="int">
                   <param name="min">20</param>
                   <param name="max">50</param>
                   <message>Age needs to be between ${min} and ${max}</message>
               </field-validator>
           </field>
      </validators>

Version:
$Date: 2006-07-10 02:30:29 +0200 (Mo, 10 Jul 2006) $ $Id: IntRangeFieldValidator.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
Jason Carreira

Field Summary
(package private) Integer | max
(package private) Integer | min
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
IntRangeFieldValidator()
Method Summary
Integer | getMax()
Comparable | getMaxComparatorValue()
Integer | getMin()
Comparable | getMinComparatorValue()
void | setMax(Integer max)
void | setMin(Integer min)
Methods inherited from class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator
validate
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

max

Integer max

min

Integer min
Constructor Detail

IntRangeFieldValidator

public IntRangeFieldValidator()
Method Detail

setMax

public void setMax(Integer max)

getMax

public Integer getMax()

getMaxComparatorValue

public Comparable getMaxComparatorValue()
Specified by:
getMaxComparatorValue in class AbstractRangeValidator

setMin

public void setMin(Integer min)

getMin

public Integer getMin()

getMinComparatorValue

public Comparable getMinComparatorValue()
Specified by:
getMinComparatorValue in class AbstractRangeValidator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RegexFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class RegexFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RegexFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
EmailValidator
public class RegexFieldValidator
extends FieldValidatorSupport

Validates a string field using a regular expression.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • expression - The RegExp expression REQUIRED
  • caseSensitive - Boolean (Optional). Sets whether the expression should be matched against in a case-sensitive way. Default is true.

    <validators>
        <!-- Plain Validator Syntax -->
        <validator type="regex">
            <param name="fieldName">myStrangePostcode</param>
            <param name="expression"><![CDATA[([aAbBcCdD][123][eEfFgG][456])]]<>/param>
        </validator>

        <!-- Field Validator Syntax -->
        <field name="myStrangePostcode">
            <field-validator type="regex">
               <param name="expression"><![CDATA[([aAbBcCdD][123][eEfFgG][456])]]></param>
            </field-validator>
        </field>
    </validators>

Version:
$Date: 2007-01-06 11:13:49 +0100 (Sa, 06 Jan 2007) $ $Revision: 1302 $
Author:
Quake Wang

Field Summary
private boolean | caseSensitive
private String | expression
private boolean | trim
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
RegexFieldValidator()
Method Summary
String | getExpression()
boolean | isCaseSensitive()
boolean | isTrimed()
void | setCaseSensitive(boolean caseSensitive) Sets whether the expression should be matched against in a case-sensitive way.
void | setExpression(String expression) Sets the regular expression to be matched.
void | setTrim(boolean trim) Sets whether the expression should be trimed before matching.
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

expression

private String expression

caseSensitive

private boolean caseSensitive

trim

private boolean trim
Constructor Detail

RegexFieldValidator

public RegexFieldValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException

getExpression

public String getExpression()
Returns:
Returns the regular expression to be matched.

setExpression

public void setExpression(String expression)
Sets the regular expression to be matched.

isCaseSensitive

public boolean isCaseSensitive()
Returns:
Returns whether the expression should be matched against in a case-sensitive way. Default is true.

setCaseSensitive

public void setCaseSensitive(boolean caseSensitive)
Sets whether the expression should be matched against in a case-sensitive way. Default is true.

isTrimed

public boolean isTrimed()
Returns:
Returns whether the expression should be trimed before matching. Default is true.

setTrim

public void setTrim(boolean trim)
Sets whether the expression should be trimed before matching. Default is true.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RepopulateConversionErrorFieldValidatorSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class RepopulateConversionErrorFieldValidatorSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
Direct Known Subclasses:
ConversionErrorFieldValidator
public abstract class RepopulateConversionErrorFieldValidatorSupport
extends FieldValidatorSupport

An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".

The capability of auto-repopulating the stack with a fake parameter map when a conversion error has occurred can be done with 'repopulateField' property set to "true".

This is typically usefull when one wants to repopulate the field with the original value when a conversion error occurred. Eg. with a textfield that only allows an Integer (the action class have an Integer field declared), upon conversion error, the incorrectly entered integer (maybe a text 'one') will not appear when dispatched back. With 'repopulateField' porperty set to true, it will, meaning the textfield will have 'one' as its value upon conversion error.

 <!-- myJspPage.jsp -->
 <ww:form action="someAction" method="POST">
   ....
   <ww:textfield
       label="My Integer Field"
       name="myIntegerField" />
   ....
   <ww:submit />
 </ww:form>

 <!-- xwork.xml -->
 <xwork>
 <include file="xwork-default.xml" />
 ....
 <package name="myPackage" extends="xwork-default">
   ....
   <action name="someAction" class="example.MyActionSupport.java">
      <result name="input">myJspPage.jsp</result>
      <result>success.jsp</result>
   </action>
   ....
 </package>
 ....
 </xwork>

 <!-- MyActionSupport.java -->
 public class MyActionSupport extends ActionSupport {
    private Integer myIntegerField;

    public Integer getMyIntegerField() { return this.myIntegerField; }
    public void setMyIntegerField(Integer myIntegerField) {
       this.myIntegerField = myIntegerField;
    }
 }

 <!-- MyActionSupport-someAction-validation.xml -->
 <validators>
   ...
   <field name="myIntegerField">
      <field-validator type="conversion">
         <param name="repopulateField">true</param>
         <message>Conversion Error (Integer Wanted)</message>
      </field-validator>
   </field>
   ...
 </validators>

Version:
$Date: 2006-10-27 07:48:38 +0200 (Fr, 27 Okt 2006) $ $Id: RepopulateConversionErrorFieldValidatorSupport.java 1177 2006-10-27 05:48:38Z mrdon $
Author:
tm_jee

Field Summary
private static Log | _log
private boolean | repopulateFieldAsBoolean
private String | repopulateFieldAsString
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
RepopulateConversionErrorFieldValidatorSupport()
Method Summary
protected abstract void | doValidate(Object object)
String | getRepopulateField()
void | repopulateField(Object object)
void | setRepopulateField(String repopulateField)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

_log

private static final Log _log

repopulateFieldAsString

private String repopulateFieldAsString

repopulateFieldAsBoolean

private boolean repopulateFieldAsBoolean
Constructor Detail

RepopulateConversionErrorFieldValidatorSupport

public RepopulateConversionErrorFieldValidatorSupport()
Method Detail

getRepopulateField

public String getRepopulateField()

setRepopulateField

public void setRepopulateField(String repopulateField)

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException

repopulateField

public void repopulateField(Object object)
                     throws ValidationException
Throws:
ValidationException

doValidate

protected abstract void doValidate(Object object)
                            throws ValidationException
Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequiredFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class RequiredFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RequiredFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class RequiredFieldValidator
extends FieldValidatorSupport

RequiredFieldValidator checks if the specified field is not null.

  • fieldName - field name if plain-validator syntax is used, not needed if field-validator syntax is used

           <validators>

         <!-- Plain Validator Syntax -->
         <validator type="required">
             <param name="fieldName">username</param>
             <message>username must not be null</message>
         </validator>

         <!-- Field Validator Syntax -->
         <field name="username">
             <field-validator type="required">
                   <message>username must not be null</message>
             </field-validator>
         </field>

     </validators>

Version:
$Revision: 1063 $
Author:
rainerh

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
RequiredFieldValidator()
Method Summary
 void validate(Object object)
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Constructor Detail

RequiredFieldValidator

public RequiredFieldValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequiredStringValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class RequiredStringValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.RequiredStringValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class RequiredStringValidator
extends FieldValidatorSupport

RequiredStringValidator checks that a String field is non-null and has a length > 0. (i.e. it isn't ""). The "trim" parameter determines whether it will trim the String before performing the length check. If unspecified, the String will be trimmed.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • trim - trim the field name value before validating (default is true)

     <validators>
         <!-- Plain-Validator Syntax -->
         <validator type="requiredstring">
             <param name="fieldName">username</param>
             <param name="trim">true</param>
             <message>username is required</message>
         </validator>

         <!-- Field-Validator Syntax -->
         <field name="username">
                  <field-validator type="requiredstring">
                 <param name="trim">true</param>
                 <message>username is required</message>
            </field-validator>
         </field>
     </validators>

Version:
$Date: 2006-07-10 02:30:29 +0200 (Mo, 10 Jul 2006) $ $Id: RequiredStringValidator.java 1063 2006-07-10 00:30:29Z mrdon $
Author:
rainerh

Field Summary
private  boolean doTrim
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
RequiredStringValidator()
Method Summary
boolean | getTrim()
void | setTrim(boolean trim)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

doTrim

private boolean doTrim
Constructor Detail

RequiredStringValidator

public RequiredStringValidator()
Method Detail

setTrim

public void setTrim(boolean trim)

getTrim

public boolean getTrim()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringLengthFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class StringLengthFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class StringLengthFieldValidator
extends FieldValidatorSupport

StringLengthFieldValidator checks that a String field is of a certain length. If the "minLength" parameter is specified, it will make sure that the String has at least that many characters. If the "maxLength" parameter is specified, it will make sure that the String has at most that many characters. The "trim" parameter determines whether it will trim the String before performing the length check. If unspecified, the String will be trimmed.

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required
  • maxLength - The max length of the field value. Default ignore.
  • minLength - The min length of the field value. Default ignore.
  • trim - Trim the field value before evaluating its min/max length. Default true

                <validators>
          <!-- Plain Validator Syntax -->
                        <validator type="stringlength">
                                <param name="fieldName">myPurchaseCode</param>
                                <param name="minLength">10</param>
              <param name="maxLength">10</param>
              <param name="trim">true</param>
              <message>Your purchase code needs to be 10 characters long</message>
          </validator>

                        <!-- Field Validator Syntax -->
                        <field name="myPurchaseCode">
                                <param name="minLength">10</param>
              <param name="maxLength>10</param>
              <param name="trim">true</param>
              <message>Your purchase code needs to be 10 characters long</message>
                        </field-name>
      </validators>

Version:
$Date: 2006-10-05 17:39:20 +0200 (Do, 05 Okt 2006) $ $Id: StringLengthFieldValidator.java 1152 2006-10-05 15:39:20Z tm_jee $
Author:
Jason Carreira, Mark Woon, tmjee

Field Summary
private boolean | doTrim
private int | maxLength
private int | minLength
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
StringLengthFieldValidator()
Method Summary
int | getMaxLength()
int | getMinLength()
boolean | getTrim()
void | setMaxLength(int maxLength)
void | setMinLength(int minLength)
void | setTrim(boolean trim)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

doTrim

private boolean doTrim

maxLength

private int maxLength

minLength

private int minLength
Constructor Detail

StringLengthFieldValidator

public StringLengthFieldValidator()
Method Detail

setMaxLength

public void setMaxLength(int maxLength)

getMaxLength

public int getMaxLength()

setMinLength

public void setMinLength(int minLength)

getMinLength

public int getMinLength()

setTrim

public void setTrim(boolean trim)

getTrim

public boolean getTrim()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class URLValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.URLValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class URLValidator
extends FieldValidatorSupport

URLValidator checks that a given field is a String and a valid URL

  • fieldName - The field name this validator is validating. Required if using Plain-Validator Syntax otherwise not required

     <validators>
          <!-- Plain Validator Syntax -->
          <validator type="url">
              <param name="fieldName">myHomePage</param>
              <message>Invalid homepage url</message>
          </validator>

          <!-- Field Validator Syntax -->
          <field name="myHomepage">
              <message>Invalid homepage url</message>
          </field>
     </validators>

Version:
$Date: 2006-09-10 04:40:12 +0200 (So, 10 Sep 2006) $ $Revision: 1123 $
Author:
$Author: mrdon $

Field Summary
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
URLValidator()
Method Summary
 void validate(Object object)
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Constructor Detail

URLValidator

public URLValidator()
Method Detail

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ValidatorSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class ValidatorSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
All Implemented Interfaces:
ShortCircuitableValidator, Validator
Direct Known Subclasses:
ExpressionValidator, FieldValidatorSupport
public abstract class ValidatorSupport
extends Object
implements Validator, ShortCircuitableValidator

Abstract implementation of the Validator interface suitable for subclassing.

Author:
Jason Carreira

Field Summary
protected String | defaultMessage
protected Log | log
protected String | messageKey
private boolean | parse
private boolean | shortCircuit
private String | type
private ValidatorContext | validatorContext
Constructor Summary
ValidatorSupport()
Method Summary
protected void | addActionError(Object object)
protected void | addFieldError(String propertyName, Object object)
protected Object | conditionalParse(String expression) Parse expression passed in against value stack.
String | getDefaultMessage()
protected Object | getFieldValue(String name, Object object) Return the field value named name from object, object should have the appropriate getter/setter.
String | getMessage(Object object)
String | getMessageKey()
boolean | getParse()
ValidatorContext | getValidatorContext()
String | getValidatorType()
boolean | isShortCircuit() Gets whether this field validator should short circuit the validator queue it's in if validation fails.
void | setDefaultMessage(String message)
void | setMessageKey(String key)
void | setParse(boolean parse)
void | setShortCircuit(boolean shortcircuit) Sets whether this field validator should short circuit the validator queue it's in if validation fails.
void | setValidatorContext(ValidatorContext validatorContext) This method will be called before validate with a non-null ValidatorContext.
void | setValidatorType(String type)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
validate

Field Detail

log

protected final Log log

defaultMessage

protected String defaultMessage

messageKey

protected String messageKey

validatorContext

private ValidatorContext validatorContext

shortCircuit

private boolean shortCircuit

parse

private boolean parse

type

private String type
Constructor Detail

ValidatorSupport

public ValidatorSupport()
Method Detail

setDefaultMessage

public void setDefaultMessage(String message)
Specified by:
setDefaultMessage in interface Validator

getDefaultMessage

public String getDefaultMessage()
Specified by:
getDefaultMessage in interface Validator

setParse

public void setParse(boolean parse)

getParse

public boolean getParse()

getMessage

public String getMessage(Object object)
Specified by:
getMessage in interface Validator

setMessageKey

public void setMessageKey(String key)
Specified by:
setMessageKey in interface Validator

getMessageKey

public String getMessageKey()
Specified by:
getMessageKey in interface Validator

setShortCircuit

public void setShortCircuit(boolean shortcircuit)
Description copied from interface: ShortCircuitableValidator
Sets whether this field validator should short circuit the validator queue it's in if validation fails.

Specified by:
setShortCircuit in interface ShortCircuitableValidator
Parameters:
shortcircuit - true if this field validator should short circuit on failure, false otherwise

isShortCircuit

public boolean isShortCircuit()
Description copied from interface: ShortCircuitableValidator
Gets whether this field validator should short circuit the validator queue it's in if validation fails.

Specified by:
isShortCircuit in interface ShortCircuitableValidator
Returns:
true if this field validator should short circuit on failure, false otherwise

setValidatorContext

public void setValidatorContext(ValidatorContext validatorContext)
Description copied from interface: Validator
This method will be called before validate with a non-null ValidatorContext.

Specified by:
setValidatorContext in interface Validator

getValidatorContext

public ValidatorContext getValidatorContext()
Specified by:
getValidatorContext in interface Validator

setValidatorType

public void setValidatorType(String type)
Specified by:
setValidatorType in interface Validator

getValidatorType

public String getValidatorType()
Specified by:
getValidatorType in interface Validator

conditionalParse

protected Object conditionalParse(String expression)
Parse expression passed in against value stack. Only parse when 'parse' param is set to true, else just returns the expression unparsed.

Parameters:
expression -
Returns:
Object

getFieldValue

protected Object getFieldValue(String name,
                               Object object)
                        throws ValidationException
Return the field value named name from object, object should have the appropriate getter/setter.

Parameters:
name -
object -
Returns:
Object as field value
Throws:
ValidationException

addActionError

protected void addActionError(Object object)

addFieldError

protected void addFieldError(String propertyName,
                             Object object)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VisitorFieldValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class VisitorFieldValidator

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.validators.ValidatorSupport
        extended by  com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
            extended by  com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
All Implemented Interfaces:
FieldValidator, ShortCircuitableValidator, Validator
public class VisitorFieldValidator
extends FieldValidatorSupport

The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files. This allows you to use the ModelDriven development pattern and manage your validations for your models in one place, where they belong, next to your model classes. The VisitorFieldValidator can handle either simple Object properties, Collections of Objects, or Arrays.

  • fieldName - field name if plain-validator syntax is used, not needed if field-validator syntax is used
  • context - the context of which validation should take place. Optional
  • appendPrefix - the prefix to be added to field. Optional

    <validators>
        <!-- Plain Validator Syntax -->
        <validator type="visitor">
            <param name="fieldName">user</param>
            <param name="context">myContext</param>
            <param name="appendPrefix">true</param>
        </validator>

        <!-- Field Validator Syntax -->
        <field name="user">
           <field-validator type="visitor">
              <param name="context">myContext</param>
              <param name="appendPrefix">true</param>
           </field-validator>
        </field>
    </validators>

In the example above, if the acion's getUser() method return User object, XWork will look for User-myContext-validation.xml for the validators. Since appednPrefix is true, every field name will be prefixed with 'user' such that if the actual field name for 'name' is 'user.name'

Version:
$Date: 2006-11-30 00:02:19 +0100 (Do, 30 Nov 2006) $ $Id: VisitorFieldValidator.java 1237 2006-11-29 23:02:19Z rainerh $
Author:
Jason Carreira, Rainer Hermanns

Nested Class Summary
private  class VisitorFieldValidator.AppendingValidatorContext
Field Summary
private boolean | appendPrefix
private String | context
Fields inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
defaultMessage, log, messageKey
Constructor Summary
VisitorFieldValidator()
Method Summary
String | getContext()
boolean | isAppendPrefix() Flags whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
void | setAppendPrefix(boolean appendPrefix) Sets whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
void | setContext(String context)
void | validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
private void | validateArrayElements(Object[] array, String fieldName, String visitorContext)
private void | validateObject(String fieldName, Object o, String visitorContext)
Methods inherited from class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport
getFieldName, getValidatorType, setFieldName, setValidatorType
Methods inherited from class com.opensymphony.xwork2.validator.validators.ValidatorSupport
addActionError, addFieldError, conditionalParse, getDefaultMessage, getFieldValue, getMessage, getMessageKey, getParse, getValidatorContext, isShortCircuit, setDefaultMessage, setMessageKey, setParse, setShortCircuit, setValidatorContext
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.validator.Validator
getDefaultMessage, getMessage, getMessageKey, getValidatorContext, setDefaultMessage, setMessageKey, setValidatorContext

Field Detail

context

private String context

appendPrefix

private boolean appendPrefix
Constructor Detail

VisitorFieldValidator

public VisitorFieldValidator()
Method Detail

setAppendPrefix

public void setAppendPrefix(boolean appendPrefix)
Sets whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. The default is true.

isAppendPrefix

public boolean isAppendPrefix()
Flags whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs. The default is true.

setContext

public void setContext(String context)

getContext

public String getContext()

validate

public void validate(Object object)
              throws ValidationException
Description copied from interface: Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.

Throws:
ValidationException

validateArrayElements

private void validateArrayElements(Object[] array,
                                   String fieldName,
                                   String visitorContext)
                            throws ValidationException
Throws:
ValidationException

validateObject

private void validateObject(String fieldName,
                            Object o,
                            String visitorContext)
                     throws ValidationException
Throws:
ValidationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VisitorFieldValidator.AppendingValidatorContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.validator.validators
Class VisitorFieldValidator.AppendingValidatorContext

java.lang.Object
    extended by  com.opensymphony.xwork2.validator.DelegatingValidatorContext
        extended by  com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
All Implemented Interfaces:
LocaleProvider, TextProvider, ValidationAware, ValidatorContext
Enclosing class:
VisitorFieldValidator
private class VisitorFieldValidator.AppendingValidatorContext
extends DelegatingValidatorContext

Field Summary
(package private) String | field
(package private) String | message
(package private) Object | o
Constructor Summary
VisitorFieldValidator.AppendingValidatorContext(ValidatorContext parent, Object object, String field, String message)
Method Summary
void | addActionError(String anErrorMessage) Add an Action-level error message to this Action.
void | addFieldError(String fieldName, String errorMessage) Add an error message for a given field.
String | getFullFieldName(String fieldName) Translates a simple field name into a full field name in Ognl syntax
Methods inherited from class com.opensymphony.xwork2.validator.DelegatingValidatorContext
addActionMessage, getActionErrors, getActionMessages, getFieldErrors, getLocale, getText, getText, getText, getText, getText, getText, getText, getText, getText, getTextProvider, getTexts, getTexts, getValidationAware, hasActionErrors, hasActionMessages, hasErrors, hasFieldErrors, makeLocaleProvider, makeTextProvider, makeValidationAware, setActionErrors, setActionMessages, setFieldErrors, setTextProvider, setValidationAware
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

o

Object o

field

String field

message

String message
Constructor Detail

VisitorFieldValidator.AppendingValidatorContext

public VisitorFieldValidator.AppendingValidatorContext(ValidatorContext parent,
                                                       Object object,
                                                       String field,
                                                       String message)
Method Detail

getFullFieldName

public String getFullFieldName(String fieldName)
Translates a simple field name into a full field name in Ognl syntax

Specified by:
getFullFieldName in interface ValidatorContext
Overrides:
getFullFieldName in class DelegatingValidatorContext
Parameters:
fieldName -
Returns:
field name in OGNL syntax

addActionError

public void addActionError(String anErrorMessage)
Description copied from interface: ValidationAware
Add an Action-level error message to this Action.

Specified by:
addActionError in interface ValidationAware
Overrides:
addActionError in class DelegatingValidatorContext

addFieldError

public void addFieldError(String fieldName,
                          String errorMessage)
Description copied from interface: ValidationAware
Add an error message for a given field.

Specified by:
addFieldError in interface ValidationAware
Overrides:
addFieldError in class DelegatingValidatorContext
Parameters:
fieldName - name of field
errorMessage - the error message
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2 (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2

Main Struts interfaces and classes.

See:
Description

Interface Summary
StrutsStatics Constants used by Struts.

Class Summary
RequestUtils | Request handling utility class.
ServletActionContext | Web-specific context information for actions.
StrutsConstants | This class provides a central location for framework configuration keys used to retrieve and store Struts configuration settings.
StrutsTestCase | Base test case for JUnit testing Struts.
TestNGStrutsTestCase | Base test class for TestNG unit tests.

Exception Summary
StrutsException A generic runtime exception that optionally contains Location information

Package org.apache.struts2 Description

Main Struts interfaces and classes.


org.apache.struts2 Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.ActionContext (implements java.io.Serializable)
      • org.apache.struts2.ServletActionContext (implements org.apache.struts2.StrutsStatics)
    • junit.framework.Assert
      • junit.framework.TestCase (implements junit.framework.Test)
        • com.opensymphony.xwork2.XWorkTestCase
          • org.apache.struts2.StrutsTestCase
    • org.apache.struts2.RequestUtils
    • org.apache.struts2.StrutsConstants
    • com.opensymphony.xwork2.TestNGXWorkTestCase
      • org.apache.struts2.TestNGStrutsTestCase
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • com.opensymphony.xwork2.XWorkException (implements com.opensymphony.xwork2.util.location.Locatable)
            • org.apache.struts2.StrutsException (implements com.opensymphony.xwork2.util.location.Locatable)

Interface Hierarchy

  • org.apache.struts2.StrutsStatics


Uses of Package org.apache.struts2 (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2

Packages that use org.apache.struts2
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.components |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.portlet.context |
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.portlet.interceptor |
org.apache.struts2.portlet.result |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.xslt | The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Classes in org.apache.struts2 used by org.apache.struts2
StrutsStatics
Constants used by Struts.

Classes in org.apache.struts2 used by org.apache.struts2.components
StrutsException
A generic runtime exception that optionally contains Location information

Classes in org.apache.struts2 used by org.apache.struts2.dispatcher
StrutsStatics
Constants used by Struts.

Classes in org.apache.struts2 used by org.apache.struts2.interceptor
StrutsStatics
Constants used by Struts.

Classes in org.apache.struts2 used by org.apache.struts2.portlet.context
StrutsStatics
Constants used by Struts.

Classes in org.apache.struts2 used by org.apache.struts2.portlet.dispatcher
StrutsStatics
Constants used by Struts.

Classes in org.apache.struts2 used by org.apache.struts2.portlet.interceptor
StrutsStatics
Constants used by Struts.

Classes in org.apache.struts2 used by org.apache.struts2.portlet.result
StrutsStatics
Constants used by Struts.

Classes in org.apache.struts2 used by org.apache.struts2.views.freemarker
StrutsStatics
Constants used by Struts.

Classes in org.apache.struts2 used by org.apache.struts2.views.xslt
StrutsException
A generic runtime exception that optionally contains Location information

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


StrutsStatics (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2
Interface StrutsStatics

All Known Implementing Classes:
FilterDispatcher, FilterDispatcherCompatWeblogic61, FreemarkerResult, Jsr168Dispatcher, PlainTextResult, PortletFreemarkerResult, PortletPreferencesInterceptor, PortletResult, PortletVelocityResult, PreparatorServlet, ServletActionContext, ServletActionRedirectResult, ServletConfigInterceptor, ServletDispatcherResult, ServletRedirectResult, StreamResult, StrutsResultSupport, VelocityResult
public interface StrutsStatics

Constants used by Struts. The constants can be used to get or set objects out of the action context or other collections.

Example:

    ActionContext.getContext().put(HTTP_REQUEST, request);

or

    ActionContext context = ActionContext.getContext();
    HttpServletRequest request = (HttpServletRequest)context.get(HTTP_REQUEST);

Field Summary
static String | HTTP_REQUEST Constant for the HTTP request object.
static String | HTTP_RESPONSE Constant for the HTTP response object.
static String | PAGE_CONTEXT Constant for the JSP page context.
static String | SERVLET_CONTEXT Constant for the servlet context object.
static String | SERVLET_DISPATCHER Constant for an HTTP request dispatcher.
static String | STRUTS_PORTLET_CONTEXT Constant for the PortletContext object

Field Detail

HTTP_REQUEST

static final String HTTP_REQUEST
Constant for the HTTP request object.

See Also:
Constant Field Values

HTTP_RESPONSE

static final String HTTP_RESPONSE
Constant for the HTTP response object.

See Also:
Constant Field Values

SERVLET_DISPATCHER

static final String SERVLET_DISPATCHER
Constant for an HTTP request dispatcher.

See Also:
Constant Field Values

SERVLET_CONTEXT

static final String SERVLET_CONTEXT
Constant for the servlet context object.

See Also:
Constant Field Values

PAGE_CONTEXT

static final String PAGE_CONTEXT
Constant for the JSP page context.

See Also:
Constant Field Values

STRUTS_PORTLET_CONTEXT

static final String STRUTS_PORTLET_CONTEXT
Constant for the PortletContext object

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestUtils (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2
Class RequestUtils

java.lang.Object
    extended by  org.apache.struts2.RequestUtils

public class RequestUtils
extends Object

Request handling utility class.

Constructor Summary
RequestUtils()
Method Summary
static String getServletPath(HttpServletRequest request)
Retrieves the current request servlet path.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RequestUtils

public RequestUtils()
Method Detail

getServletPath

public static String getServletPath(HttpServletRequest request)
Retrieves the current request servlet path. Deals with differences between servlet specs (2.2 vs 2.3+)

Parameters:
request - the request
Returns:
the servlet path
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ServletActionContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2
Class ServletActionContext

java.lang.Object
    extended by  com.opensymphony.xwork2.ActionContext
        extended by  org.apache.struts2.ServletActionContext
All Implemented Interfaces:
Serializable, StrutsStatics
public class ServletActionContext
extends ActionContext
implements StrutsStatics

Web-specific context information for actions. This class subclasses ActionContext which provides access to things like the action name, value stack, etc. This class adds access to web objects like servlet parameters, request attributes and things like the HTTP session.

See Also:
Serialized Form

Field Summary
static String | ACTION_MAPPING
private static long | serialVersionUID
static String | STRUTS_VALUESTACK_KEY
Fields inherited from class com.opensymphony.xwork2.ActionContext
ACTION_INVOCATION, ACTION_NAME, APPLICATION, CONVERSION_ERRORS, LOCALE, PARAMETERS, SESSION, TYPE_CONVERTER, VALUE_STACK
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
private ServletActionContext(Map context)
Method Summary
static ActionContext | getActionContext(HttpServletRequest req) Gets the current action context
static ActionMapping | getActionMapping() Gets the action mapping for this context
static PageContext | getPageContext() Returns the HTTP page context.
static HttpServletRequest | getRequest() Gets the HTTP servlet request object.
static HttpServletResponse | getResponse() Gets the HTTP servlet response object.
static ServletContext | getServletContext() Gets the servlet context.
static ValueStack | getValueStack(HttpServletRequest req) Gets the current value stack for this request
static void | setRequest(HttpServletRequest request) Sets the HTTP servlet request object.
static void | setResponse(HttpServletResponse response) Sets the HTTP servlet response object.
static void | setServletContext(ServletContext servletContext) Sets the current servlet context object
Methods inherited from class com.opensymphony.xwork2.ActionContext
get, getActionInvocation, getApplication, getContext, getContextMap, getConversionErrors, getLocale, getName, getParameters, getSession, getValueStack, put, setActionInvocation, setApplication, setContext, setContextMap, setConversionErrors, setLocale, setName, setParameters, setSession, setValueStack
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

STRUTS_VALUESTACK_KEY

public static final String STRUTS_VALUESTACK_KEY
See Also:
Constant Field Values

ACTION_MAPPING

public static final String ACTION_MAPPING
See Also:
Constant Field Values
Constructor Detail

ServletActionContext

private ServletActionContext(Map context)
Method Detail

getActionContext

public static ActionContext getActionContext(HttpServletRequest req)
Gets the current action context

Parameters:
req - The request
Returns:
The current action context

getValueStack

public static ValueStack getValueStack(HttpServletRequest req)
Gets the current value stack for this request

Parameters:
req - The request
Returns:
The value stack

getActionMapping

public static ActionMapping getActionMapping()
Gets the action mapping for this context

Returns:
The action mapping

getPageContext

public static PageContext getPageContext()
Returns the HTTP page context.

Returns:
the HTTP page context.

setRequest

public static void setRequest(HttpServletRequest request)
Sets the HTTP servlet request object.

Parameters:
request - the HTTP servlet request object.

getRequest

public static HttpServletRequest getRequest()
Gets the HTTP servlet request object.

Returns:
the HTTP servlet request object.

setResponse

public static void setResponse(HttpServletResponse response)
Sets the HTTP servlet response object.

Parameters:
response - the HTTP servlet response object.

getResponse

public static HttpServletResponse getResponse()
Gets the HTTP servlet response object.

Returns:
the HTTP servlet response object.

getServletContext

public static ServletContext getServletContext()
Gets the servlet context.

Returns:
the servlet context.

setServletContext

public static void setServletContext(ServletContext servletContext)
Sets the current servlet context object

Parameters:
servletContext - The servlet context to use
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsConstants (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2
Class StrutsConstants

java.lang.Object
    extended by  org.apache.struts2.StrutsConstants

public final class StrutsConstants
extends Object

This class provides a central location for framework configuration keys used to retrieve and store Struts configuration settings.

Field Summary
static String | STRUTS_ACTION_EXTENSION The URL extension to use to determine if the request is meant for a Struts action
static String | STRUTS_ACTIONPROXYFACTORY
static String | STRUTS_ALWAYS_SELECT_FULL_NAMESPACE
static String | STRUTS_CONFIGURATION The org.apache.struts2.config.Configuration implementation class
static String | STRUTS_CONFIGURATION_XML_RELOAD Whether to reload the XML configuration or not
static String | STRUTS_CONTINUATIONS_PACKAGE The package containing actions that use Rife continuations
static String | STRUTS_CUSTOM_I18N_RESOURCES Location of additional localization properties files to load
static String | STRUTS_CUSTOM_PROPERTIES Location of additional configuration properties files to load
static String | STRUTS_DEVMODE Whether Struts is in development mode or not
static String | STRUTS_DISPATCHER_PARAMETERSWORKAROUND Whether to use a Servlet request parameter workaround necessary for some versions of WebLogic
static String | STRUTS_ENABLE_DYNAMIC_METHOD_INVOCATION Allows one to disable dynamic method invocation from the URL
static String | STRUTS_ENABLE_SLASHES_IN_ACTION_NAMES Whether slashes in action names are allowed or not
static String | STRUTS_FREEMARKER_MANAGER_CLASSNAME The org.apache.struts2.views.freemarker.FreemarkerManager implementation class
static String | STRUTS_FREEMARKER_WRAPPER_ALT_MAP
static String | STRUTS_I18N_ENCODING The encoding to use for localization messages
static String | STRUTS_I18N_RELOAD Whether the localization messages should automatically be reloaded
static String | STRUTS_LOCALE The default locale for the Struts application
static String | STRUTS_MAPPER_CLASS The org.apache.struts2.dispatcher.mapper.ActionMapper implementation class
static String | STRUTS_MAPPER_COMPOSITE Prefix used by CompositeActionMapper to identify its containing ActionMapper class.
static String | STRUTS_MULTIPART_MAXSIZE The maximize size of a multipart request (file upload)
static String | STRUTS_MULTIPART_PARSER The org.apache.struts2.dispatcher.multipart.MultiPartRequest parser implementation for a multipart request (file upload)
static String | STRUTS_MULTIPART_SAVEDIR The directory to use for storing uploaded files
static String | STRUTS_OBJECTFACTORY The com.opensymphony.xwork2.ObjectFactory implementation class
static String | STRUTS_OBJECTFACTORY_SPRING_AUTOWIRE Whether Spring should autoWire or not
static String | STRUTS_OBJECTFACTORY_SPRING_USE_CLASS_CACHE Whether Spring should use its class cache or not
static String | STRUTS_OBJECTTYPEDETERMINER The com.opensymphony.xwork2.util.ObjectTypeDeterminer implementation class
static String | STRUTS_SERVE_STATIC_BROWSER_CACHE If static content served by the Struts filter should set browser caching header properties or not
static String | STRUTS_SERVE_STATIC_CONTENT Whether the Struts filter should serve static content or not
static String | STRUTS_TAG_ALTSYNTAX Whether to use the alterative syntax for the tags or not
static String | STRUTS_UI_TEMPLATEDIR The directory containing UI templates
static String | STRUTS_UI_THEME The default UI template theme
static String | STRUTS_URL_HTTP_PORT The HTTP port used by Struts URLs
static String | STRUTS_URL_HTTPS_PORT The HTTPS port used by Struts URLs
static String | STRUTS_URL_INCLUDEPARAMS The default includeParams method to generate Struts URLs
static String | STRUTS_VELOCITY_CONFIGFILE The Velocity configuration file path
static String | STRUTS_VELOCITY_CONTEXTS List of Velocity context names
static String | STRUTS_VELOCITY_MANAGER_CLASSNAME org.apache.struts2.views.velocity.VelocityManager implementation class
static String | STRUTS_VELOCITY_TOOLBOXLOCATION The location of the Velocity toolbox
static String | STRUTS_XSLT_NOCACHE Whether or not XSLT templates should not be cached
static String | STRUTS_XWORKCONVERTER The name of the xwork converter implementation
Constructor Summary
StrutsConstants()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STRUTS_DEVMODE

public static final String STRUTS_DEVMODE
Whether Struts is in development mode or not

See Also:
Constant Field Values

STRUTS_I18N_RELOAD

public static final String STRUTS_I18N_RELOAD
Whether the localization messages should automatically be reloaded

See Also:
Constant Field Values

STRUTS_I18N_ENCODING

public static final String STRUTS_I18N_ENCODING
The encoding to use for localization messages

See Also:
Constant Field Values

STRUTS_CONFIGURATION_XML_RELOAD

public static final String STRUTS_CONFIGURATION_XML_RELOAD
Whether to reload the XML configuration or not

See Also:
Constant Field Values

STRUTS_ACTION_EXTENSION

public static final String STRUTS_ACTION_EXTENSION
The URL extension to use to determine if the request is meant for a Struts action

See Also:
Constant Field Values

STRUTS_TAG_ALTSYNTAX

public static final String STRUTS_TAG_ALTSYNTAX
Whether to use the alterative syntax for the tags or not

See Also:
Constant Field Values

STRUTS_URL_HTTP_PORT

public static final String STRUTS_URL_HTTP_PORT
The HTTP port used by Struts URLs

See Also:
Constant Field Values

STRUTS_URL_HTTPS_PORT

public static final String STRUTS_URL_HTTPS_PORT
The HTTPS port used by Struts URLs

See Also:
Constant Field Values

STRUTS_URL_INCLUDEPARAMS

public static final String STRUTS_URL_INCLUDEPARAMS
The default includeParams method to generate Struts URLs

See Also:
Constant Field Values

STRUTS_OBJECTFACTORY

public static final String STRUTS_OBJECTFACTORY
The com.opensymphony.xwork2.ObjectFactory implementation class

See Also:
Constant Field Values

STRUTS_OBJECTTYPEDETERMINER

public static final String STRUTS_OBJECTTYPEDETERMINER
The com.opensymphony.xwork2.util.ObjectTypeDeterminer implementation class

See Also:
Constant Field Values

STRUTS_CONTINUATIONS_PACKAGE

public static final String STRUTS_CONTINUATIONS_PACKAGE
The package containing actions that use Rife continuations

See Also:
Constant Field Values

STRUTS_CONFIGURATION

public static final String STRUTS_CONFIGURATION
The org.apache.struts2.config.Configuration implementation class

See Also:
Constant Field Values

STRUTS_LOCALE

public static final String STRUTS_LOCALE
The default locale for the Struts application

See Also:
Constant Field Values

STRUTS_DISPATCHER_PARAMETERSWORKAROUND

public static final String STRUTS_DISPATCHER_PARAMETERSWORKAROUND
Whether to use a Servlet request parameter workaround necessary for some versions of WebLogic

See Also:
Constant Field Values

STRUTS_FREEMARKER_MANAGER_CLASSNAME

public static final String STRUTS_FREEMARKER_MANAGER_CLASSNAME
The org.apache.struts2.views.freemarker.FreemarkerManager implementation class

See Also:
Constant Field Values

STRUTS_VELOCITY_MANAGER_CLASSNAME

public static final String STRUTS_VELOCITY_MANAGER_CLASSNAME
org.apache.struts2.views.velocity.VelocityManager implementation class

See Also:
Constant Field Values

STRUTS_VELOCITY_CONFIGFILE

public static final String STRUTS_VELOCITY_CONFIGFILE
The Velocity configuration file path

See Also:
Constant Field Values

STRUTS_VELOCITY_TOOLBOXLOCATION

public static final String STRUTS_VELOCITY_TOOLBOXLOCATION
The location of the Velocity toolbox

See Also:
Constant Field Values

STRUTS_VELOCITY_CONTEXTS

public static final String STRUTS_VELOCITY_CONTEXTS
List of Velocity context names

See Also:
Constant Field Values

STRUTS_UI_TEMPLATEDIR

public static final String STRUTS_UI_TEMPLATEDIR
The directory containing UI templates

See Also:
Constant Field Values

STRUTS_UI_THEME

public static final String STRUTS_UI_THEME
The default UI template theme

See Also:
Constant Field Values

STRUTS_MULTIPART_MAXSIZE

public static final String STRUTS_MULTIPART_MAXSIZE
The maximize size of a multipart request (file upload)

See Also:
Constant Field Values

STRUTS_MULTIPART_SAVEDIR

public static final String STRUTS_MULTIPART_SAVEDIR
The directory to use for storing uploaded files

See Also:
Constant Field Values

STRUTS_MULTIPART_PARSER

public static final String STRUTS_MULTIPART_PARSER
The org.apache.struts2.dispatcher.multipart.MultiPartRequest parser implementation for a multipart request (file upload)

See Also:
Constant Field Values

STRUTS_OBJECTFACTORY_SPRING_AUTOWIRE

public static final String STRUTS_OBJECTFACTORY_SPRING_AUTOWIRE
Whether Spring should autoWire or not

See Also:
Constant Field Values

STRUTS_OBJECTFACTORY_SPRING_USE_CLASS_CACHE

public static final String STRUTS_OBJECTFACTORY_SPRING_USE_CLASS_CACHE
Whether Spring should use its class cache or not

See Also:
Constant Field Values

STRUTS_XSLT_NOCACHE

public static final String STRUTS_XSLT_NOCACHE
Whether or not XSLT templates should not be cached

See Also:
Constant Field Values

STRUTS_CUSTOM_PROPERTIES

public static final String STRUTS_CUSTOM_PROPERTIES
Location of additional configuration properties files to load

See Also:
Constant Field Values

STRUTS_CUSTOM_I18N_RESOURCES

public static final String STRUTS_CUSTOM_I18N_RESOURCES
Location of additional localization properties files to load

See Also:
Constant Field Values

STRUTS_MAPPER_CLASS

public static final String STRUTS_MAPPER_CLASS
The org.apache.struts2.dispatcher.mapper.ActionMapper implementation class

See Also:
Constant Field Values

STRUTS_SERVE_STATIC_CONTENT

public static final String STRUTS_SERVE_STATIC_CONTENT
Whether the Struts filter should serve static content or not

See Also:
Constant Field Values

STRUTS_SERVE_STATIC_BROWSER_CACHE

public static final String STRUTS_SERVE_STATIC_BROWSER_CACHE
If static content served by the Struts filter should set browser caching header properties or not

See Also:
Constant Field Values

STRUTS_ENABLE_DYNAMIC_METHOD_INVOCATION

public static final String STRUTS_ENABLE_DYNAMIC_METHOD_INVOCATION
Allows one to disable dynamic method invocation from the URL

See Also:
Constant Field Values

STRUTS_ENABLE_SLASHES_IN_ACTION_NAMES

public static final String STRUTS_ENABLE_SLASHES_IN_ACTION_NAMES
Whether slashes in action names are allowed or not

See Also:
Constant Field Values

STRUTS_MAPPER_COMPOSITE

public static final String STRUTS_MAPPER_COMPOSITE
Prefix used by CompositeActionMapper to identify its containing ActionMapper class.

See Also:
Constant Field Values

STRUTS_ACTIONPROXYFACTORY

public static final String STRUTS_ACTIONPROXYFACTORY
See Also:
Constant Field Values

STRUTS_FREEMARKER_WRAPPER_ALT_MAP

public static final String STRUTS_FREEMARKER_WRAPPER_ALT_MAP
See Also:
Constant Field Values

STRUTS_XWORKCONVERTER

public static final String STRUTS_XWORKCONVERTER
The name of the xwork converter implementation

See Also:
Constant Field Values

STRUTS_ALWAYS_SELECT_FULL_NAMESPACE

public static final String STRUTS_ALWAYS_SELECT_FULL_NAMESPACE
See Also:
Constant Field Values
Constructor Detail

StrutsConstants

public StrutsConstants()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsTestCase (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2
Class StrutsTestCase

java.lang.Object
    extended by  junit.framework.Assert
        extended by  junit.framework.TestCase
            extended by  com.opensymphony.xwork2.XWorkTestCase
                extended by  org.apache.struts2.StrutsTestCase
All Implemented Interfaces:
junit.framework.Test
public abstract class StrutsTestCase
extends XWorkTestCase

Base test case for JUnit testing Struts.

Field Summary
Fields inherited from class com.opensymphony.xwork2.XWorkTestCase
actionProxyFactory, configuration, configurationManager, container
Constructor Summary
StrutsTestCase()
Method Summary
protected Dispatcher | initDispatcher(Map<String,String> params)
protected void | setUp() Sets up the configuration settings, XWork configuration, and message resources
protected void | tearDown()
Methods inherited from class com.opensymphony.xwork2.XWorkTestCase
loadConfigurationProviders
Methods inherited from class junit.framework.TestCase
countTestCases, createResult, getName, run, run, runBare, runTest, setName, toString
Methods inherited from class junit.framework.Assert
assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertEquals, assertFalse, assertFalse, assertNotNull, assertNotNull, assertNotSame, assertNotSame, assertNull, assertNull, assertSame, assertSame, assertTrue, assertTrue, fail, fail
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

StrutsTestCase

public StrutsTestCase()
Method Detail

setUp

protected void setUp()
              throws Exception
Sets up the configuration settings, XWork configuration, and message resources

Overrides:
setUp in class XWorkTestCase
Throws:
Exception

initDispatcher

protected Dispatcher initDispatcher(Map<String,String> params)

tearDown

protected void tearDown()
                 throws Exception
Overrides:
tearDown in class XWorkTestCase
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TestNGStrutsTestCase (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2
Class TestNGStrutsTestCase

java.lang.Object
    extended by  com.opensymphony.xwork2.TestNGXWorkTestCase
        extended by  org.apache.struts2.TestNGStrutsTestCase

public class TestNGStrutsTestCase
extends TestNGXWorkTestCase

Base test class for TestNG unit tests. Provides common Struts variables and performs Struts setup and teardown processes

Field Summary
Fields inherited from class com.opensymphony.xwork2.TestNGXWorkTestCase
actionProxyFactory, configuration, configurationManager, container
Constructor Summary
TestNGStrutsTestCase()
Method Summary
protected Dispatcher | initDispatcher(Map<String,String> params)
protected void | setUp()
protected void | tearDown()
Methods inherited from class com.opensymphony.xwork2.TestNGXWorkTestCase
loadConfigurationProviders
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TestNGStrutsTestCase

public TestNGStrutsTestCase()
Method Detail

setUp

protected void setUp()
              throws Exception
Overrides:
setUp in class TestNGXWorkTestCase
Throws:
Exception

initDispatcher

protected Dispatcher initDispatcher(Map<String,String> params)

tearDown

protected void tearDown()
                 throws Exception
Overrides:
tearDown in class TestNGXWorkTestCase
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


StrutsException (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2
Class StrutsException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  com.opensymphony.xwork2.XWorkException
                    extended by  org.apache.struts2.StrutsException
All Implemented Interfaces:
Locatable, Serializable
public class StrutsException
extends XWorkException
implements Locatable

A generic runtime exception that optionally contains Location information

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Constructor Summary
StrutsException()
Constructs a StrutsException with no detail message.
StrutsException(String s)
Constructs a StrutsException with the specified detail message.
StrutsException(String s, Object target)
Constructs a StrutsException with the specified detail message and target.
StrutsException(String s, Throwable cause)
Constructs a StrutsException with the specified detail message and exception cause.
StrutsException(String s, Throwable cause, Object target)
Constructs a StrutsException with the specified detail message, cause, and target
StrutsException(Throwable cause)
Constructs a StrutsException with the root cause
StrutsException(Throwable cause, Object target)
Constructs a StrutsException with the root cause and target
Method Summary
Methods inherited from class com.opensymphony.xwork2.XWorkException
getLocation, getThrowable, toString
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface com.opensymphony.xwork2.util.location.Locatable
getLocation

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

StrutsException

public StrutsException()
Constructs a StrutsException with no detail message.

StrutsException

public StrutsException(String s)
Constructs a StrutsException with the specified detail message.

Parameters:
s - the detail message.

StrutsException

public StrutsException(String s,
                       Object target)
Constructs a StrutsException with the specified detail message and target.

Parameters:
s - the detail message.
target - the target of the exception.

StrutsException

public StrutsException(Throwable cause)
Constructs a StrutsException with the root cause

Parameters:
cause - The wrapped exception

StrutsException

public StrutsException(Throwable cause,
                       Object target)
Constructs a StrutsException with the root cause and target

Parameters:
cause - The wrapped exception
target - The target of the exception

StrutsException

public StrutsException(String s,
                       Throwable cause)
Constructs a StrutsException with the specified detail message and exception cause.

Parameters:
s - the detail message.
cause - the wrapped exception

StrutsException

public StrutsException(String s,
                       Throwable cause,
                       Object target)
Constructs a StrutsException with the specified detail message, cause, and target

Parameters:
s - the detail message.
cause - The wrapped exception
target - The target of the exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.components (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.components

Interface Summary
Param.UnnamedParametric | Tags can implement this to support nested param tags without the name attribute.
RemoteUICallBean |
URL.ExtraParameterProvider |

Class Summary
AbstractRemoteCallUIBean | TODO: Document AbstractRemoteCallUIBean.
ActionComponent |
ActionError | Render action errors if they exists the specific layout of the rendering depends on the theme itself.
ActionMessage | Render action messages if they exists, specific rendering layout depends on the theme itself.
Anchor | A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework. THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED href errorText listenTopics notifyTopics executeScripts loadingText listenTopics handler formId formFilter targets showErrorTransportText targets indicator 'resultDivId' Deprecated.
AppendIterator |
Autocompleter | The autocomplete tag is a combobox that can autocomplete text entered on the input box.
Bean |
Checkbox | Renders an HTML input element of type checkbox, populated by the specified property from the ValueStack.
CheckboxList | Creates a series of checkboxes from a list.
ClosingUIBean | ClosingUIBean is the standard superclass for UI components such as div etc.
ComboBox | The combo box is basically an HTML INPUT of type text and HTML SELECT grouped together to give you a combo box functionality.
Component | Base class to extend for UI components.
Date | Format Date object in different ways.
DateTimePicker |
Debug |
Div | The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.
DoubleListUIBean | DoubleListUIBean is the standard superclass of all Struts double list handling components.
DoubleSelect | Renders two HTML select elements with second one changing displayed values depending on selected entry of first one.
Else |
ElseIf |
FieldError | Render field errors if they exists.
File | Renders an HTML file input element.
Form | Renders HTML an input form. The remote form allows the form to be submitted without the page being refreshed.
FormButton | FormButton.
GenericUIBean | Renders an custom UI widget using the specified templates.
Head | Renders parts of the HEAD section for an HTML file.
Hidden | Renders an HTML input element of type hidden, populated by the specified property from the ValueStack.
I18n | Gets a resource bundle and place it on the value stack.
If |
Include |
Include.PageOutputStream | Implementation of ServletOutputStream that stores all data written to it in a temporary buffer accessible from Include.PageOutputStream.getBuffer() .
Include.PageResponse | Simple wrapper to HTTPServletResponse that will allow getWriter() and getResponse() to be called as many times as needed without causing conflicts.
InputTransferSelect | Create a input transfer select component which is basically an text input and <select ...> tag with buttons in the middle of them allowing text to be added to the transfer select.
IteratorComponent |
Label | Renders an HTML LABEL that will allow you to output label:name combination that has the same format treatment as the rest of your UI controls.
ListUIBean | DoubleListUIBean is the standard superclass of all Struts list handling components.
MergeIterator |
OptGroup | Create a optgroup component which needs to resides within a select tag.
OptionTransferSelect | Create a option transfer select component which is basically two <select ...> tag with buttons in the middle of them allowing options in each of the <select ...> to be moved between themselves.
Param |
Password | Render an HTML input tag of type password.
Property | Used to get the property of a value, which will default to the top of the stack if none is specified.
Push |
Radio | Render a radio button input field.
Reset | Render a reset button.
Select | Render an HTML input tag of type select.
Set |
Submit | Render a submit button.
TabbedPanel | The tabbedpanel widget is primarily an AJAX component, where each tab can either be local content or remote content (refreshed each time the user selects that tab).
Text | Render a I18n text message.
TextArea | Render HTML textarea tag.
TextField | Render an HTML input field of type text
Token | Stop double-submission of forms.
Tree | Renders a tree widget with AJAX support. The id attribute is normally specified, such that it could be looked up using javascript if necessary. Examples
TreeNode | Renders a tree node within a tree widget with AJAX support. Either of the following combinations should be used depending on if the tree is to be constrcted dynamically or statically.
UIBean | UIBean is the standard superclass of all Struts UI componentns.
UpDownSelect | Create a Select component with buttons to move the elements in the select component up and down.
URL |


org.apache.struts2.components Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.components

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.components.Component
      • org.apache.struts2.components.ActionComponent
      • org.apache.struts2.components.AppendIterator (implements org.apache.struts2.components.Param.UnnamedParametric)
      • org.apache.struts2.components.Bean
      • org.apache.struts2.components.Date
      • org.apache.struts2.components.Else
      • org.apache.struts2.components.ElseIf
      • org.apache.struts2.components.I18n
      • org.apache.struts2.components.If
      • org.apache.struts2.components.Include
      • org.apache.struts2.components.IteratorComponent
      • org.apache.struts2.components.MergeIterator (implements org.apache.struts2.components.Param.UnnamedParametric)
      • org.apache.struts2.components.OptGroup
      • org.apache.struts2.components.Param
      • org.apache.struts2.components.Property
      • org.apache.struts2.components.Push
      • org.apache.struts2.components.Set
      • org.apache.struts2.components.Text (implements org.apache.struts2.components.Param.UnnamedParametric)
      • org.apache.struts2.components.UIBean
        • org.apache.struts2.components.ActionError
        • org.apache.struts2.components.ActionMessage
        • org.apache.struts2.components.Checkbox
        • org.apache.struts2.components.ClosingUIBean
          • org.apache.struts2.components.AbstractRemoteCallUIBean (implements org.apache.struts2.components.RemoteUICallBean)
            • org.apache.struts2.components.Anchor
            • org.apache.struts2.components.Div
          • org.apache.struts2.components.Form
          • org.apache.struts2.components.TabbedPanel
          • org.apache.struts2.components.Tree
          • org.apache.struts2.components.TreeNode
        • org.apache.struts2.components.DateTimePicker
        • org.apache.struts2.components.Debug
        • org.apache.struts2.components.FieldError (implements org.apache.struts2.components.Param.UnnamedParametric)
        • org.apache.struts2.components.File
        • org.apache.struts2.components.FormButton
          • org.apache.struts2.components.Reset
          • org.apache.struts2.components.Submit (implements org.apache.struts2.components.RemoteUICallBean)
        • org.apache.struts2.components.GenericUIBean
        • org.apache.struts2.components.Head
        • org.apache.struts2.components.Hidden
        • org.apache.struts2.components.Label
        • org.apache.struts2.components.ListUIBean
          • org.apache.struts2.components.CheckboxList
          • org.apache.struts2.components.DoubleListUIBean
            • org.apache.struts2.components.DoubleSelect
            • org.apache.struts2.components.OptionTransferSelect
          • org.apache.struts2.components.InputTransferSelect
          • org.apache.struts2.components.Radio
          • org.apache.struts2.components.Select
            • org.apache.struts2.components.UpDownSelect
        • org.apache.struts2.components.TextArea
        • org.apache.struts2.components.TextField
          • org.apache.struts2.components.ComboBox
            • org.apache.struts2.components.Autocompleter
          • org.apache.struts2.components.Password
        • org.apache.struts2.components.Token
      • org.apache.struts2.components.URL
    • org.apache.struts2.components.Debug.DebugMapEntry (implements java.util.Map.Entry<K,V>)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • javax.servlet.ServletOutputStream
        • org.apache.struts2.components.Include.PageOutputStream
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • org.apache.struts2.components.Include.PageResponse

Interface Hierarchy

  • org.apache.struts2.components.Param.UnnamedParametric
  • org.apache.struts2.components.RemoteUICallBean
  • org.apache.struts2.components.URL.ExtraParameterProvider


Uses of Package org.apache.struts2.components (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.components

Packages that use org.apache.struts2.components
org.apache.struts2.components |
org.apache.struts2.components.table |
org.apache.struts2.components.template |
org.apache.struts2.views.freemarker.tags |
org.apache.struts2.views.jsp | Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.
org.apache.struts2.views.velocity.components |

Classes in org.apache.struts2.components used by org.apache.struts2.components
AbstractRemoteCallUIBean
TODO: Document AbstractRemoteCallUIBean.
ClosingUIBean
ClosingUIBean is the standard superclass for UI components such as div etc.
ComboBox
The combo box is basically an HTML INPUT of type text and HTML SELECT grouped together to give you a combo box functionality.
Component
Base class to extend for UI components.
DoubleListUIBean
DoubleListUIBean is the standard superclass of all Struts double list handling components.
Form

Renders HTML an input form.

The remote form allows the form to be submitted without the page being refreshed.

FormButton
FormButton.
Include.PageOutputStream
Implementation of ServletOutputStream that stores all data written to it in a temporary buffer accessible from Include.PageOutputStream.getBuffer() .
ListUIBean
DoubleListUIBean is the standard superclass of all Struts list handling components.
Param.UnnamedParametric
Tags can implement this to support nested param tags without the name attribute.
RemoteUICallBean
Select
Render an HTML input tag of type select.
TextField
Render an HTML input field of type text
UIBean
UIBean is the standard superclass of all Struts UI componentns.
URL.ExtraParameterProvider

Classes in org.apache.struts2.components used by org.apache.struts2.components.table
Component
Base class to extend for UI components.
GenericUIBean
Renders an custom UI widget using the specified templates.
UIBean
UIBean is the standard superclass of all Struts UI componentns.

Classes in org.apache.struts2.components used by org.apache.struts2.components.template
UIBean
UIBean is the standard superclass of all Struts UI componentns.

Classes in org.apache.struts2.components used by org.apache.struts2.views.freemarker.tags
Component
Base class to extend for UI components.

Classes in org.apache.struts2.components used by org.apache.struts2.views.jsp
Component
Base class to extend for UI components.

Classes in org.apache.struts2.components used by org.apache.struts2.views.jsp.iterator
Component
Base class to extend for UI components.

Classes in org.apache.struts2.components used by org.apache.struts2.views.jsp.ui
Component
Base class to extend for UI components.

Classes in org.apache.struts2.components used by org.apache.struts2.views.jsp.ui.table
Component
Base class to extend for UI components.

Classes in org.apache.struts2.components used by org.apache.struts2.views.velocity.components
Component
Base class to extend for UI components.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RemoteUICallBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Interface RemoteUICallBean

All Known Implementing Classes:
AbstractRemoteCallUIBean, Anchor, Div, Submit
public interface RemoteUICallBean

Method Summary
void | setAfterLoading(String afterLoading)
void | setBeforeLoading(String beforeLoading)
void | setErrorText(String errorText)
void | setExecuteScripts(String executeScripts)
void | setFormFilter(String formFilter)
void | setFormId(String formId)
void | setHandler(String handler)
void | setHref(String href)
void | setIndicator(String indicator)
void | setListenTopics(String topics)
void | setLoadingText(String loadingText)
void | setNotifyTopics(String topics)
void | setShowErrorTransportText(String showError)
void | setShowLoadingText(String showLoadingText)

Method Detail

setListenTopics

void setListenTopics(String topics)

setNotifyTopics

void setNotifyTopics(String topics)

setHref

void setHref(String href)

setErrorText

void setErrorText(String errorText)

setAfterLoading

void setAfterLoading(String afterLoading)

setBeforeLoading

void setBeforeLoading(String beforeLoading)

setExecuteScripts

void setExecuteScripts(String executeScripts)

setLoadingText

void setLoadingText(String loadingText)

setHandler

void setHandler(String handler)

setFormFilter

void setFormFilter(String formFilter)

setFormId

void setFormId(String formId)

setShowErrorTransportText

void setShowErrorTransportText(String showError)

setShowLoadingText

void setShowLoadingText(String showLoadingText)

setIndicator

void setIndicator(String indicator)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractRemoteCallUIBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class AbstractRemoteCallUIBean

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ClosingUIBean
                extended by  org.apache.struts2.components.AbstractRemoteCallUIBean
All Implemented Interfaces:
RemoteUICallBean
Direct Known Subclasses:
Anchor, Div
public abstract class AbstractRemoteCallUIBean
extends ClosingUIBean
implements RemoteUICallBean

TODO: Document AbstractRemoteCallUIBean.

Version:
$Revision: 508280 $ $Date: 2007-02-15 21:07:56 -0500 (Thu, 15 Feb 2007) $
Author:
$Author: musachy $

Field Summary
protected String | afterLoading
protected String | beforeLoading
protected String | errorText
protected String | executeScripts
protected String | formFilter
protected String | formId
protected String | handler
protected String | href
protected String | indicator
protected String | listenTopics
protected String | loadingText
protected String | notifyTopics
protected String | showErrorTransportText
protected String | showLoadingText
Fields inherited from class org.apache.struts2.components.ClosingUIBean
openTemplate
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
AbstractRemoteCallUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
void | setAfterLoading(String afterLoading)
void | setBeforeLoading(String beforeLoading)
void | setErrorText(String errorText)
void | setExecuteScripts(String executeScripts)
void | setFormFilter(String formFilter)
void | setFormId(String formId)
void | setHandler(String handler)
void | setHref(String href)
void | setIndicator(String indicator)
void | setListenTopics(String listenTopics)
void | setLoadingText(String loadingText)
void | setNotifyTopics(String notifyTopics)
void | setShowErrorTransportText(String showError)
void | setShowLoadingText(String showLoadingText)
Methods inherited from class org.apache.struts2.components.ClosingUIBean
getDefaultOpenTemplate, setOpenTemplate, start
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getDefaultTemplate, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

href

protected String href

errorText

protected String errorText

afterLoading

protected String afterLoading

beforeLoading

protected String beforeLoading

executeScripts

protected String executeScripts

loadingText

protected String loadingText

listenTopics

protected String listenTopics

handler

protected String handler

formId

protected String formId

formFilter

protected String formFilter

notifyTopics

protected String notifyTopics

showErrorTransportText

protected String showErrorTransportText

indicator

protected String indicator

showLoadingText

protected String showLoadingText
Constructor Detail

AbstractRemoteCallUIBean

public AbstractRemoteCallUIBean(ValueStack stack,
                                HttpServletRequest request,
                                HttpServletResponse response)
Method Detail

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

setListenTopics

public void setListenTopics(String listenTopics)
Specified by:
setListenTopics in interface RemoteUICallBean

setHref

public void setHref(String href)
Specified by:
setHref in interface RemoteUICallBean

setErrorText

public void setErrorText(String errorText)
Specified by:
setErrorText in interface RemoteUICallBean

setAfterLoading

public void setAfterLoading(String afterLoading)
Specified by:
setAfterLoading in interface RemoteUICallBean

setBeforeLoading

public void setBeforeLoading(String beforeLoading)
Specified by:
setBeforeLoading in interface RemoteUICallBean

setExecuteScripts

public void setExecuteScripts(String executeScripts)
Specified by:
setExecuteScripts in interface RemoteUICallBean

setLoadingText

public void setLoadingText(String loadingText)
Specified by:
setLoadingText in interface RemoteUICallBean

setHandler

public void setHandler(String handler)
Specified by:
setHandler in interface RemoteUICallBean

setFormFilter

public void setFormFilter(String formFilter)
Specified by:
setFormFilter in interface RemoteUICallBean

setFormId

public void setFormId(String formId)
Specified by:
setFormId in interface RemoteUICallBean

setNotifyTopics

public void setNotifyTopics(String notifyTopics)
Specified by:
setNotifyTopics in interface RemoteUICallBean

setShowErrorTransportText

public void setShowErrorTransportText(String showError)
Specified by:
setShowErrorTransportText in interface RemoteUICallBean

setIndicator

public void setIndicator(String indicator)
Specified by:
setIndicator in interface RemoteUICallBean

setShowLoadingText

public void setShowLoadingText(String showLoadingText)
Specified by:
setShowLoadingText in interface RemoteUICallBean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionComponent (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class ActionComponent

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.ActionComponent

public class ActionComponent
extends Component

This tag enables developers to call actions directly from a JSP page by specifying the action name and an optional namespace. The body content of the tag is used to render the results from the Action. Any result processor defined for this action in struts.xml will be ignored, unless the executeResult parameter is specified.

  • id (String) - the id (if specified) to put the action under stack's context.
  • name* (String) - name of the action to be executed (without the extension suffix eg. .action)
  • namespace (String) - default to the namespace where this action tag is invoked
  • executeResult (Boolean) - default is false. Decides wheather the result of this action is to be executed or not
  • ignoreContextParams (Boolean) - default to false. Decides wheather the request parameters are to be included when the action is invoked

 public class ActionTagAction extends ActionSupport {

  public String execute() throws Exception {
      return "done";
  }

  public String doDefault() throws Exception {
      ServletActionContext.getRequest().setAttribute("stringByAction", "This is a String put in by the action's doDefault()");
      return "done";
  }
 }

      ....

         success.jsp

         success.jsp

      ....

The following action tag will execute result and include it in this page

The following action tag will do the same as above, but invokes method specialMethod in action

The following action tag will not execute result, but put a String in request scope
       under an id "stringByAction" which will be retrieved using property tag

Field Summary
protected ActionProxyFactory | actionProxyFactory
protected boolean | executeResult
protected boolean | flush
protected boolean | ignoreContextParams
private static Log | LOG
protected String | name
protected String | namespace
protected ActionProxy | proxy
protected HttpServletRequest | req
protected HttpServletResponse | res
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
ActionComponent(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
private Map | createExtraContext()
boolean | end(Writer writer, String body) Callback for the end tag of this component.
private void | executeAction() Execute the requested action.
ActionProxy | getProxy()
void | setActionProxyFactory(ActionProxyFactory actionProxyFactory)
void | setExecuteResult(boolean executeResult)
void | setFlush(boolean flush)
void | setIgnoreContextParams(boolean ignoreContextParams)
void | setName(String name)
void | setNamespace(String namespace)
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

res

protected HttpServletResponse res

req

protected HttpServletRequest req

actionProxyFactory

protected ActionProxyFactory actionProxyFactory

proxy

protected ActionProxy proxy

name

protected String name

namespace

protected String namespace

executeResult

protected boolean executeResult

ignoreContextParams

protected boolean ignoreContextParams

flush

protected boolean flush
Constructor Detail

ActionComponent

public ActionComponent(ValueStack stack,
                       HttpServletRequest req,
                       HttpServletResponse res)
Method Detail

setActionProxyFactory

public void setActionProxyFactory(ActionProxyFactory actionProxyFactory)
Parameters:
actionProxyFactory - the actionProxyFactory to set

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

createExtraContext

private Map createExtraContext()

getProxy

public ActionProxy getProxy()

executeAction

private void executeAction()
Execute the requested action. If no namespace is provided, we'll attempt to derive a namespace using buildNamespace(). The ActionProxy and the namespace will be saved into the instance variables proxy and namespace respectively.

See Also:
TagUtils.buildNamespace(org.apache.struts2.dispatcher.mapper.ActionMapper, com.opensymphony.xwork2.util.ValueStack, javax.servlet.http.HttpServletRequest)

setName

public void setName(String name)

setNamespace

public void setNamespace(String namespace)

setExecuteResult

public void setExecuteResult(boolean executeResult)

setIgnoreContextParams

public void setIgnoreContextParams(boolean ignoreContextParams)

setFlush

public void setFlush(boolean flush)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionError (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class ActionError

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ActionError

public class ActionError
extends UIBean

Render action errors if they exists the specific layout of the rendering depends on the theme itself.

Examples

    <s:actionerror />
    <s:form .... >>
       ....
    </s:form>

Field Summary
static String TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
ActionError(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected  String getDefaultTemplate()
A contract that requires each concrete UI Tag to specify which template should be used as a default.
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

ActionError

public ActionError(ValueStack stack,
                   HttpServletRequest request,
                   HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionMessage (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class ActionMessage

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ActionMessage

public class ActionMessage
extends UIBean

Render action messages if they exists, specific rendering layout depends on the theme itself.

Examples

    <s:actionmessage />
    <s:form .... >
       ....
    </s:form>

Field Summary
private static String TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
ActionMessage(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected  String getDefaultTemplate()
A contract that requires each concrete UI Tag to specify which template should be used as a default.
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

private static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

ActionMessage

public ActionMessage(ValueStack stack,
                     HttpServletRequest request,
                     HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Anchor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Anchor

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ClosingUIBean
                extended by  org.apache.struts2.components.AbstractRemoteCallUIBean
                    extended by  org.apache.struts2.components.Anchor
All Implemented Interfaces:
RemoteUICallBean
public class Anchor
extends AbstractRemoteCallUIBean

A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework.

THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED

  • href
  • errorText
  • listenTopics
  • notifyTopics
  • executeScripts
  • loadingText
  • listenTopics
  • handler
  • formId
  • formFilter
  • targets
  • showErrorTransportText
  • targets
  • indicator
'resultDivId' Deprecated. Use targets.

'targets' is a list of element ids whose content will be updated with the text returned from request.

'errorText' is the text that will be displayed when there is an error making the request.

'onLoadJS' Deprecated. Use 'notifyTopics'.

'preInvokeJS' Deprecated. Use 'notifyTopics'.

'executeScripts' if set to true will execute javascript sections in the returned text.

'loadingText' is the text that will be displayed on the 'targets' elements while making the request.

'handler' is the name of the function that will take care of making the AJAX request. Dojo's widget and dom node are passed as parameters).

'formId' is the id of the html form whose fields will be seralized and passed as parameters in the request.

'formFilter' is the name of a function which will be used to filter the fields that will be seralized. This function takes as a parameter the element and returns true if the element should be included.

'listenTopics' comma separated list of topics names, that will trigger a request 'indicator' element to be shown while the request executing 'showErrorTransportText': whether errors should be displayed (on 'targets')

'showLoadingText' show loading text on targets

'notifyTopics' comma separated list of topics names, that will be published. Three parameters are passed:

  • data: html or json object when type='load' or type='error'
  • type: 'before' before the request is made, 'load' when the request succeeds, or 'error' when it fails
  • request: request javascript object, when type='load' or type='error'

Examples

 <s:a id="link1" theme="ajax" href="/DoIt.action" errorText="An error ocurred" loadingText="Loading...">
     <img border="none" src="<%=request.getContextPath()%>/images/delete.gif"/>
     <s:param name="id" value="1"/>
 </s:a>

Results in

 <a dojoType="BindAnchor" executeScripts="true" id="link1" href="/DoIt.action?id=1" errorText="An error ocurred"></a>

Here is an example that uses the beforeLoading. This example is in altSyntax=true:

 <s:a id="test" theme="ajax" href="/simpeResult.action" beforeLoading="confirm('Are you sure?')">
  A
 </s:a>

Field Summary
static String | COMPONENT_NAME
static String | OPEN_TEMPLATE
protected String | targets
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.AbstractRemoteCallUIBean
afterLoading, beforeLoading, errorText, executeScripts, formFilter, formId, handler, href, indicator, listenTopics, loadingText, notifyTopics, showErrorTransportText, showLoadingText
Fields inherited from class org.apache.struts2.components.ClosingUIBean
openTemplate
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Anchor(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
String | getDefaultOpenTemplate()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setAfterLoading(String afterLoading)
void | setBeforeLoading(String beforeLoading)
void | setTargets(String targets)
Methods inherited from class org.apache.struts2.components.AbstractRemoteCallUIBean
setErrorText, setExecuteScripts, setFormFilter, setFormId, setHandler, setHref, setIndicator, setListenTopics, setLoadingText, setNotifyTopics, setShowErrorTransportText, setShowLoadingText
Methods inherited from class org.apache.struts2.components.ClosingUIBean
setOpenTemplate, start
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OPEN_TEMPLATE

public static final String OPEN_TEMPLATE
See Also:
Constant Field Values

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

COMPONENT_NAME

public static final String COMPONENT_NAME

targets

protected String targets
Constructor Detail

Anchor

public Anchor(ValueStack stack,
              HttpServletRequest request,
              HttpServletResponse response)
Method Detail

getDefaultOpenTemplate

public String getDefaultOpenTemplate()
Specified by:
getDefaultOpenTemplate in class ClosingUIBean

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class AbstractRemoteCallUIBean

setTargets

public void setTargets(String targets)

setAfterLoading

public void setAfterLoading(String afterLoading)
Specified by:
setAfterLoading in interface RemoteUICallBean
Overrides:
setAfterLoading in class AbstractRemoteCallUIBean

setBeforeLoading

public void setBeforeLoading(String beforeLoading)
Specified by:
setBeforeLoading in interface RemoteUICallBean
Overrides:
setBeforeLoading in class AbstractRemoteCallUIBean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AppendIterator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class AppendIterator

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.AppendIterator
All Implemented Interfaces:
Param.UnnamedParametric
public class AppendIterator
extends Component
implements Param.UnnamedParametric

Component for AppendIteratorTag, which jobs is to append iterators to form an appended iterator whereby entries goes from one iterator to another after each respective iterator is exhausted of entries.

For example, if there are 3 iterator appended (each iterator has 3 entries), the following will be how the appended iterator entries will be arranged:

  1. First Entry of the First Iterator
  2. Second Entry of the First Iterator
  3. Third Entry of the First Iterator
  4. First Entry of the Second Iterator
  5. Second Entry of the Second Iterator
  6. Third Entry of the Second Iterator
  7. First Entry of the Third Iterator
  8. Second Entry of the Third Iterator
  9. Third Entry of the Third ITerator
  • id (String) - the id of which if supplied will have the resultant appended iterator stored under in the stack's context
public class AppendIteratorTagAction extends ActionSupport { private List myList1; private List myList2; private List myList3; public String execute() throws Exception { myList1 = new ArrayList(); myList1.add("1"); myList1.add("2"); myList1.add("3"); myList2 = new ArrayList(); myList2.add("a"); myList2.add("b"); myList2.add("c"); myList3 = new ArrayList(); myList3.add("A"); myList3.add("B"); myList3.add("C"); return "done"; } public List getMyList1() { return myList1; } public List getMyList2() { return myList2; } public List getMyList3() { return myList3; } } <s:append id="myAppendIterator"> <s:param value="%{myList1}" /> <s:param value="%{myList2}" /> <s:param value="%{myList3}" /> </s:append> <s:iterator value="%{#myAppendIterator}"> <s:property /> </s:iterator>

See Also:
AppendIteratorFilter, AppendIteratorTag

Field Summary
private static Log | _log
private List | _parameters
private AppendIteratorFilter | appendIteratorFilter
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
AppendIterator(ValueStack stack)
Method Summary
void | addParameter(Object value) Adds the given value as a parameter to the outer tag.
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setId(String id)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

appendIteratorFilter

private AppendIteratorFilter appendIteratorFilter

_parameters

private List _parameters
Constructor Detail

AppendIterator

public AppendIterator(ValueStack stack)
Method Detail

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

addParameter

public void addParameter(Object value)
Description copied from interface: Param.UnnamedParametric
Adds the given value as a parameter to the outer tag.

Specified by:
addParameter in interface Param.UnnamedParametric
Parameters:
value - the value

setId

public void setId(String id)
Overrides:
setId in class Component
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Autocompleter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Autocompleter

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.TextField
                extended by  org.apache.struts2.components.ComboBox
                    extended by  org.apache.struts2.components.Autocompleter

public class Autocompleter
extends ComboBox

The autocomplete tag is a combobox that can autocomplete text entered on the input box. When used on the "simple" theme, the autocompleter can be used like the ComboBox. When used on the "ajax" theme, the list can be retieved from an action. This action must return a JSON list in the format:

 [
   ["Text 1","Value1"],
   ["Text 2","Value2"],
   ["Text 3","Value3"]
 ]
THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED
  • href
  • errorText
  • listenTopics
  • notifyTopics
  • listenTopics
  • formId
  • formFilter
  • indicator
  • loadOnTextChange
  • loadMinimumCount
  • showDownArrow
  • searchType
'dropdownWidth' width in pixels of the drodpdown, same as autocompleter's width by default

'dropdownHeight' height in pixels of the drodown, 120 px by default

'forceValidOption' if invalid option is selected, clear autocompleter's text when focus is lost

'autoComplete', if true, make suggestions on the textbox

'formId' is the id of the html form whose fields will be seralized and passed as parameters in the request.

'formFilter' is the name of a function which will be used to filter the fields that will be seralized. This function takes as a parameter the element and returns true if the element should be included.

'listenTopics' comma separated list of topics names, that will trigger a request 'indicator' element to be shown while the request executing 'showErrorTransportText': whether errors should be displayed (on 'targets')

'loadOnTextChange' options will be reloaded everytime a character is typed on the textbox

'loadMinimumCount' minimum number of characters that will force the content to be loaded

'showDownError' show or hide the down arrow button 'searchType' how the search must be performed, options are: "startstring", "startword" and "substring"

'keyName' name of the field to which the selected key will be assigned

'iconPath' path of icon used for the dropdown 'templateCssPath' path to css file used to customize Dojo's widget 'notifyTopics' comma separated list of topics names, that will be published. Three parameters are passed:

  • data: selected value when type='valuechanged'
  • type: 'before' before the request is made, 'valuechanged' when selection changes, 'load' when the request succeeds, or 'error' when it fails
  • request: request javascript object, when type='load' or type='error'

      • Field Summary
protected String | autoComplete
private static String | COMPONENT_NAME
protected String | delay
protected String | disabled
protected String | dropdownHeight
protected String | dropdownWidth
protected String | forceValidOption
protected String | formFilter
protected String | formId
protected String | href
protected String | iconPath
protected String | indicator
protected String | keyName
protected String | listenTopics
protected String | loadMinimumCount
protected String | loadOnTextChange
protected String | notifyTopics
protected String | searchType
protected String | showDownArrow
static String | TEMPLATE
protected String | templateCssPath
      Fields inherited from class org.apache.struts2.components.ComboBox
      emptyOption, headerKey, headerValue, list, listKey, listValue
      Fields inherited from class org.apache.struts2.components.TextField
      maxlength, readonly, size
      Fields inherited from class org.apache.struts2.components.UIBean
      accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
      Fields inherited from class org.apache.struts2.components.Component
      actionMapper, COMPONENT_STACK, id, parameters, stack
      Constructor Summary
      Autocompleter(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
      Method Summary
void | evaluateExtraParams()
protected Object | findListValue()
String | getComponentName()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setAutoComplete(String autoComplete)
void | setDelay(String searchDelay)
void | setDisabled(String disabled)
void | setDropdownHeight(String height)
void | setDropdownWidth(String width)
void | setForceValidOption(String forceValidOption)
void | setFormFilter(String formFilter)
void | setFormId(String formId)
void | setHref(String href)
void | setIconPath(String iconPath)
void | setIndicator(String indicator)
void | setKeyName(String keyName)
void | setList(String list)
void | setListenTopics(String listenTopics)
void | setLoadMinimumCount(String loadMinimumCount)
void | setLoadOnTextChange(String loadOnType)
void | setNotifyTopics(String onValueChangedPublishTopic)
void | setSearchType(String searchType)
void | setShowDownArrow(String showDownArrow)
void | setTemplateCssPath(String templateCssPath)
      Methods inherited from class org.apache.struts2.components.ComboBox
      setEmptyOption, setHeaderKey, setHeaderValue, setListKey, setListValue
      Methods inherited from class org.apache.struts2.components.TextField
      setMaxlength, setMaxLength, setReadonly, setSize
      Methods inherited from class org.apache.struts2.components.UIBean
      addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
      Methods inherited from class org.apache.struts2.components.Component
      addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
      Methods inherited from class java.lang.Object
      clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      Field Detail

      TEMPLATE

      public static final String TEMPLATE
      See Also:
      Constant Field Values

      COMPONENT_NAME

      private static final String COMPONENT_NAME

      forceValidOption

      protected String forceValidOption

      searchType

      protected String searchType

      autoComplete

      protected String autoComplete

      delay

      protected String delay

      disabled

      protected String disabled

      href

      protected String href

      dropdownWidth

      protected String dropdownWidth

      dropdownHeight

      protected String dropdownHeight

      formId

      protected String formId

      formFilter

      protected String formFilter

      listenTopics

      protected String listenTopics

      notifyTopics

      protected String notifyTopics

      indicator

      protected String indicator

      loadOnTextChange

      protected String loadOnTextChange

      loadMinimumCount

      protected String loadMinimumCount

      showDownArrow

      protected String showDownArrow

      templateCssPath

      protected String templateCssPath

      iconPath

      protected String iconPath

      keyName

      protected String keyName
      Constructor Detail

      Autocompleter

      public Autocompleter(ValueStack stack,
                     HttpServletRequest request,
                     HttpServletResponse response)
      Method Detail

      getDefaultTemplate

      protected String getDefaultTemplate()
      Description copied from class: UIBean
      A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

      Overrides:
      getDefaultTemplate in class ComboBox
      Returns:
      The name of the template to be used as the default.

      getComponentName

      public String getComponentName()

      evaluateExtraParams

      public void evaluateExtraParams()
      Overrides:
      evaluateExtraParams in class ComboBox

      findListValue

      protected Object findListValue()
      Overrides:
      findListValue in class ComboBox

      setAutoComplete

      public void setAutoComplete(String autoComplete)

      setDisabled

      public void setDisabled(String disabled)
      Overrides:
      setDisabled in class UIBean

      setForceValidOption

      public void setForceValidOption(String forceValidOption)

      setHref

      public void setHref(String href)

      setDelay

      public void setDelay(String searchDelay)

      setSearchType

      public void setSearchType(String searchType)

      setDropdownHeight

      public void setDropdownHeight(String height)

      setDropdownWidth

      public void setDropdownWidth(String width)

      setFormFilter

      public void setFormFilter(String formFilter)

      setFormId

      public void setFormId(String formId)

      setListenTopics

      public void setListenTopics(String listenTopics)

      setNotifyTopics

      public void setNotifyTopics(String onValueChangedPublishTopic)

      setIndicator

      public void setIndicator(String indicator)

      setLoadMinimumCount

      public void setLoadMinimumCount(String loadMinimumCount)

      setLoadOnTextChange

      public void setLoadOnTextChange(String loadOnType)

      setShowDownArrow

      public void setShowDownArrow(String showDownArrow)

      setList

      public void setList(String list)
      Overrides:
      setList in class ComboBox

      setTemplateCssPath

      public void setTemplateCssPath(String templateCssPath)

      setIconPath

      public void setIconPath(String iconPath)

      setKeyName

      public void setKeyName(String keyName)
      Overview Package Class Use Tree Deprecated Index Help
      PREV CLASS NEXT CLASS FRAMES NO FRAMES
      SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Bean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Bean

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Bean

public class Bean
extends Component

Instantiates a class that conforms to the JavaBeans specification. This tag has a body which can contain a number of Param elements to set any mutator methods on that class.

If the id attribute is set on the BeanTag, it will place the instantiated bean into the stack's Context.

  • id - the stack's context id (if supplied) that the created bean will be store under
  • name* - the class name of the bean to be instantiated (must respect JavaBean specification)

Examples:

 <-- in freemarker form -->
 [@s.bean name="org.apache.struts2.example.counter.SimpleCounter" id="counter"]
   [s:param name="foo" value="BAR"/]
   The value of foo is : [s:property value="foo"/], when inside the bean tag.

 [/s:bean]

 <-- in jsp form -->
 <s:bean name="org.apache.struts2.example.counter.SimpleCounter" id="counter">
   <s:param name="foo" value="BAR" />
   The value of foot is : <s:property value="foo"/>, when inside the bean tag <br />
 </s:bean>

This example instantiates a bean called SimpleCounter and sets the foo property (setFoo('BAR')). The SimpleCounter object is then pushed onto the Valuestack, which means that we can call its accessor methods (getFoo()) with the Property tag and get their values.

In the above example, the id has been set to a value of counter. This means that the SimpleCounter class will be placed into the stack's context. You can access the SimpleCounter class using a Struts tag:

 <-- jsp form -->
 <s:property value="#counter" />

 <-- freemarker form -->
 [s:property value="#counter.foo"/]

In the property tag example, the # tells Ognl to search the context for the SimpleCounter class which has an id(key) of counter

See Also:
Param

Field Summary
protected Object | bean
protected static Log | log
protected String | name
protected ObjectFactory | objectFactory
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Bean(ValueStack stack)
Method Summary
void | addParameter(String key, Object value) Add's the given key and value to this components own parameter.
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setName(String name)
void | setObjectFactory(ObjectFactory objectFactory)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static Log log

bean

protected Object bean

name

protected String name

objectFactory

protected ObjectFactory objectFactory
Constructor Detail

Bean

public Bean(ValueStack stack)
Method Detail

setObjectFactory

public void setObjectFactory(ObjectFactory objectFactory)

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

addParameter

public void addParameter(String key,
                         Object value)
Description copied from class: Component
Add's the given key and value to this components own parameter.

If the provided key is null nothing happends. If the provided value is null any existing parameter with the given key name is removed.

Overrides:
addParameter in class Component
Parameters:
key - the key of the new parameter to add.
value - the value assoicated with the key.

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Checkbox (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Checkbox

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.Checkbox

public class Checkbox
extends UIBean

Renders an HTML input element of type checkbox, populated by the specified property from the ValueStack.

Examples

 JSP:
 <s:checkbox label="checkbox test" name="checkboxField1" value="aBoolean" fieldValue="true"/>

 Velocity:
 #tag( Checkbox "label=checkbox test" "name=checkboxField1" "value=aBoolean" )

 Resulting HTML (simple template, aBoolean == true):
 <input type="checkbox" name="checkboxField1" value="true" checked="checked" />

Field Summary
protected String | fieldValue
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Checkbox(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected void | evaluateExtraParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
protected Class | getValueClassType()
void | setFieldValue(String fieldValue)
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

fieldValue

protected String fieldValue
Constructor Detail

Checkbox

public Checkbox(ValueStack stack,
                HttpServletRequest request,
                HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

protected void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

getValueClassType

protected Class getValueClassType()
Overrides:
getValueClassType in class UIBean

setFieldValue

public void setFieldValue(String fieldValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckboxList (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class CheckboxList

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
                extended by  org.apache.struts2.components.CheckboxList

public class CheckboxList
extends ListUIBean

Creates a series of checkboxes from a list. Setup is like <s:select /> or <s:radio />, but creates checkbox tags.

Examples

 <s:checkboxlist name="foo" list="bar"/>

Field Summary
static String TEMPLATE
Fields inherited from class org.apache.struts2.components.ListUIBean
list, listKey, listValue, throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
CheckboxList(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected  String getDefaultTemplate()
A contract that requires each concrete UI Tag to specify which template should be used as a default.
Methods inherited from class org.apache.struts2.components.ListUIBean
contains, evaluateExtraParams, getValueClassType, setList, setListKey, setListValue, setThrowExceptionOnNullValueAttribute
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

CheckboxList

public CheckboxList(ValueStack stack,
                    HttpServletRequest request,
                    HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClosingUIBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class ClosingUIBean

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ClosingUIBean
Direct Known Subclasses:
AbstractRemoteCallUIBean, Form, TabbedPanel, Tree, TreeNode
public abstract class ClosingUIBean
extends UIBean

ClosingUIBean is the standard superclass for UI components such as div etc.

Field Summary
private static Log | LOG
(package private) String | openTemplate
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
protected ClosingUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
abstract String | getDefaultOpenTemplate()
void | setOpenTemplate(String openTemplate)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, evaluateParams, getDefaultTemplate, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

openTemplate

String openTemplate
Constructor Detail

ClosingUIBean

protected ClosingUIBean(ValueStack stack,
                        HttpServletRequest request,
                        HttpServletResponse response)
Method Detail

getDefaultOpenTemplate

public abstract String getDefaultOpenTemplate()

setOpenTemplate

public void setOpenTemplate(String openTemplate)

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComboBox (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class ComboBox

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.TextField
                extended by  org.apache.struts2.components.ComboBox
Direct Known Subclasses:
Autocompleter
public class ComboBox
extends TextField

The combo box is basically an HTML INPUT of type text and HTML SELECT grouped together to give you a combo box functionality. You can place text in the INPUT control by using the SELECT control or type it in directly in the text field.

In this example, the SELECT will be populated from id=year attribute. Counter is itself an Iterator. It will span from first to last. The population is done via javascript, and requires that this tag be surrounded by a <form>.

Note that unlike the <s:select/> tag, there is no ability to define the individual <option> tags' id attribute or content separately. Each of these is simply populated from the toString() method of the list item. Presumably this is because the select box isn't intended to actually submit useful data, but to assist the user in filling out the text field.

Examples

 JSP:
 <-- Example One -->
 <s:bean name="struts.util.Counter" id="year">
   <s:param name="first" value="text('firstBirthYear')"/>
   <s:param name="last" value="2000"/>

   <s:combobox label="Birth year" size="6" maxlength="4" name="birthYear" list="#year"/>
 </s:bean>

 <-- Example Two -->

 <-- Example Two -->

 Velocity:
 #tag( ComboBox "label=Birth year" "size=6" "maxlength=4" "name=birthYear" "list=#year" )

Field Summary
protected String | emptyOption
protected String | headerKey
protected String | headerValue
protected String | list
protected String | listKey
protected String | listValue
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.TextField
maxlength, readonly, size
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
ComboBox(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
protected Object | findListValue()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setEmptyOption(String emptyOption)
void | setHeaderKey(String headerKey)
void | setHeaderValue(String headerValue)
void | setList(String list)
void | setListKey(String listKey)
void | setListValue(String listValue)
Methods inherited from class org.apache.struts2.components.TextField
setMaxlength, setMaxLength, setReadonly, setSize
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

list

protected String list

listKey

protected String listKey

listValue

protected String listValue

headerKey

protected String headerKey

headerValue

protected String headerValue

emptyOption

protected String emptyOption
Constructor Detail

ComboBox

public ComboBox(ValueStack stack,
                HttpServletRequest request,
                HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Overrides:
getDefaultTemplate in class TextField
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class TextField

findListValue

protected Object findListValue()

setList

public void setList(String list)

setEmptyOption

public void setEmptyOption(String emptyOption)

setHeaderKey

public void setHeaderKey(String headerKey)

setHeaderValue

public void setHeaderValue(String headerValue)

setListKey

public void setListKey(String listKey)

setListValue

public void setListValue(String listValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Component (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Component

java.lang.Object
    extended by  org.apache.struts2.components.Component
Direct Known Subclasses:
ActionComponent, AppendIterator, Bean, Date, Else, ElseIf, I18n, If, Include, IteratorComponent, MergeIterator, OptGroup, Param, Property, Push, Set, Text, UIBean, URL
public class Component
extends Object

Base class to extend for UI components.

This class is a good extension point when building reuseable UI components.

Field Summary
protected ActionMapper | actionMapper
static String | COMPONENT_STACK
protected String | id
protected Map | parameters
protected ValueStack | stack
Constructor Summary
Component(ValueStack stack)
Constructor.
Method Summary
void | addAllParameters(Map params) Add's all the given parameters to this componenets own parameters.
void | addParameter(String key, Object value) Add's the given key and value to this components own parameter.
boolean | altSyntax() Is the altSyntax enabled? [TRUE] See struts.properties where the altSyntax flag is defined.
void | copyParams(Map params) Pushes this component's parameter Map as well as the component itself on to the stack and then copies the supplied parameters over.
protected String | determineActionURL(String action, String namespace, String method, HttpServletRequest req, HttpServletResponse res, Map parameters, String scheme, boolean includeContext, boolean encodeResult) Renders an action URL by consulting the ActionMapper.
protected String | determineNamespace(String namespace, ValueStack stack, HttpServletRequest req) Determines the namespace of the current page being renderdd.
boolean | end(Writer writer, String body) Callback for the end tag of this component.
protected boolean | end(Writer writer, String body, boolean popComponentStack) Callback for the start tag of this component.
protected StrutsException | fieldError(String field, String errorMsg, Exception e) Constructs?a RuntimeException based on the given information.
protected Component | findAncestor(Class clazz) Finds the nearest ancestor of this component stack.
protected String | findString(String expr) Evaluates the OGNL stack to find a String value.
protected String | findString(String expr, String field, String errorMsg) Evaluates the OGNL stack to find a String value.
protected Object | findValue(String expr) Finds a value from the OGNL stack based on the given expression.
protected Object | findValue(String expr, Class toType) Evaluates the OGNL stack to find an Object of the given type.
protected Object | findValue(String expr, String field, String errorMsg) Evaluates the OGNL stack to find an Object value.
private String | getComponentName() Get's the name of this component.
Stack | getComponentStack() Get's the component stack of this component.
String | getId() Get's the id for referencing element.
Map | getParameters() Get's the parameters.
ValueStack | getStack() Get's the OGNL value stack assoicated with this component.
protected void | popComponentStack() Pops the component stack.
void | setActionMapper(ActionMapper mapper)
void | setId(String id)
boolean | start(Writer writer) Callback for the start tag of this component.
protected String | toString(Throwable t) Constructs a string representation of the given exception.
boolean | usesBody() Overwrite to set if body shold be used.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

COMPONENT_STACK

public static final String COMPONENT_STACK
See Also:
Constant Field Values

stack

protected ValueStack stack

parameters

protected Map parameters

id

protected String id

actionMapper

protected ActionMapper actionMapper
Constructor Detail

Component

public Component(ValueStack stack)
Constructor.

Parameters:
stack - OGNL value stack.
Method Detail

getComponentName

private String getComponentName()
Get's the name of this component.

Returns:
the name of this component.

setActionMapper

public void setActionMapper(ActionMapper mapper)

getStack

public ValueStack getStack()
Get's the OGNL value stack assoicated with this component.

Returns:
the OGNL value stack assoicated with this component.

getComponentStack

public Stack getComponentStack()
Get's the component stack of this component.

Returns:
the component stack of this component, never null.

start

public boolean start(Writer writer)
Callback for the start tag of this component. Should the body be evaluated?

Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

end

protected boolean end(Writer writer,
                      String body,
                      boolean popComponentStack)
Callback for the start tag of this component. Should the body be evaluated again?

NOTE: has a parameter to determine to pop the component stack.

Parameters:
writer - the output writer.
body - the rendered body.
popComponentStack - should the component stack be popped?
Returns:
true if the body should be evaluated again

popComponentStack

protected void popComponentStack()
Pops the component stack.

findAncestor

protected Component findAncestor(Class clazz)
Finds the nearest ancestor of this component stack.

Parameters:
clazz - the class to look for, or if assignable from.
Returns:
the component if found, null if not.

findString

protected String findString(String expr)
Evaluates the OGNL stack to find a String value.

Parameters:
expr - OGNL expression.
Returns:
the String value found.

findString

protected String findString(String expr,
                            String field,
                            String errorMsg)
Evaluates the OGNL stack to find a String value.

If the given expression is null a error is logged and a RuntimeException is thrown constructed with a messaged based on the given field and errorMsg paramter.

Parameters:
expr - OGNL expression.
field - field name used when throwing RuntimeException.
errorMsg - error message used when throwing RuntimeException.
Returns:
the String value found.
Throws:
StrutsException - is thrown in case of expression is null.

fieldError

protected StrutsException fieldError(String field,
                                     String errorMsg,
                                     Exception e)
Constructs?a RuntimeException based on the given information.

A message is constructed and logged at ERROR level before being returned as a RuntimeException.

Parameters:
field - field name used when throwing RuntimeException.
errorMsg - error message used when throwing RuntimeException.
e - the caused exception, can be null.
Returns:
the constructed StrutsException.

findValue

protected Object findValue(String expr)
Finds a value from the OGNL stack based on the given expression. Will always evaluate expr against stack except when expr is null. If altsyntax (%{...}) is applied, simply strip it off.

Parameters:
expr - the expression. Returns null if expr is null.
Returns:
the value, null if not found.

altSyntax

public boolean altSyntax()
Is the altSyntax enabled? [TRUE]

See struts.properties where the altSyntax flag is defined.

findValue

protected Object findValue(String expr,
                           String field,
                           String errorMsg)
Evaluates the OGNL stack to find an Object value.

Function just like findValue(String) except that if the given expression is null a error is logged and a RuntimeException is thrown constructed with a messaged based on the given field and errorMsg paramter.

Parameters:
expr - OGNL expression.
field - field name used when throwing RuntimeException.
errorMsg - error message used when throwing RuntimeException.
Returns:
the Object found, is never null.
Throws:
StrutsException - is thrown in case of not found in the OGNL stack, or expression is null.

findValue

protected Object findValue(String expr,
                           Class toType)
Evaluates the OGNL stack to find an Object of the given type. Will evaluate expr the portion wrapped with altSyntax (%{...}) against stack when altSyntax is on, else the whole expr is evaluated against the stack.

This method only supports the altSyntax. So this should be set to true.

Parameters:
expr - OGNL expression.
toType - the type expected to find.
Returns:
the Object found, or null if not found.

determineActionURL

protected String determineActionURL(String action,
                                    String namespace,
                                    String method,
                                    HttpServletRequest req,
                                    HttpServletResponse res,
                                    Map parameters,
                                    String scheme,
                                    boolean includeContext,
                                    boolean encodeResult)
Renders an action URL by consulting the ActionMapper.

Parameters:
action - the action
namespace - the namespace
method - the method
req - HTTP request
res - HTTP response
parameters - parameters
scheme - http or https
includeContext - should the context path be included or not
encodeResult - should the url be encoded
Returns:
the action url.

determineNamespace

protected String determineNamespace(String namespace,
                                    ValueStack stack,
                                    HttpServletRequest req)
Determines the namespace of the current page being renderdd. Useful for Form, URL, and href generations.

Parameters:
namespace - the namespace
stack - OGNL value stack
req - HTTP request
Returns:
the namepsace of the current page being rendered, is never null.

copyParams

public void copyParams(Map params)
Pushes this component's parameter Map as well as the component itself on to the stack and then copies the supplied parameters over. Because the component's parameter Map is pushed before the component itself, any key-value pair that can't be assigned to componet will be set in the parameters Map.

Parameters:
params - the parameters to copy.

toString

protected String toString(Throwable t)
Constructs a string representation of the given exception.

Parameters:
t - the exception
Returns:
the exception as a string.

getParameters

public Map getParameters()
Get's the parameters.

Returns:
the parameters. Is never null.

addAllParameters

public void addAllParameters(Map params)
Add's all the given parameters to this componenets own parameters.

Parameters:
params - the parameters to add.

addParameter

public void addParameter(String key,
                         Object value)
Add's the given key and value to this components own parameter.

If the provided key is null nothing happends. If the provided value is null any existing parameter with the given key name is removed.

Parameters:
key - the key of the new parameter to add.
value - the value assoicated with the key.

getId

public String getId()
Get's the id for referencing element.

Returns:
the id for referencing element.

setId

public void setId(String id)

usesBody

public boolean usesBody()
Overwrite to set if body shold be used.

Returns:
always false for this component.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Date (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Date

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Date

public class Date
extends Component

Format Date object in different ways.

The date tag will allow you to format a Date in a quick and easy way. You can specify a custom format (eg. "dd/MM/yyyy hh:mm"), you can generate easy readable notations (like "in 2 hours, 14 minutes"), or you can just fall back on a predefined format with key 'struts.date.format' in your properties file. If that key is not defined, it will finally fall back to the default DateFormat.MEDIUM formatting. Note: If the requested Date object isn't found on the stack, a blank will be returned.

Configurable attributes are :-
  • name
  • nice
  • format

Following how the date component will work, depending on the value of nice attribute (which by default is false) and the format attribute.

Condition 1: With nice attribute as true

i18n key | default
struts.date.format.past | {0} ago
struts.date.format.future | in {0}
struts.date.format.seconds | an instant
struts.date.format.minutes | {0,choice,1#one minute|1<{0} minutes}
struts.date.format.hours | {0,choice,1#one hour|1<{0} hours}{1,choice,0#|1#, one minute|1<, {1} minutes}
struts.date.format.days | {0,choice,1#one day|1<{0} days}{1,choice,0#|1#, one hour|1<, {1} hours}
struts.date.format.years | {0,choice,1#one year|1<{0} years}{1,choice,0#|1#, one day|1<, {1} days}

Condition 2: With nice attribute as false and format attribute is specified eg. dd/MM/yyyyy

In this case the format attribute will be used.

Condition 3: With nice attribute as false and no format attribute is specified

i18n key | default
struts.date.format | if one is not found DateFormat.MEDIUM format will be used

Examples

  <s:date name="person.birthday" format="dd/MM/yyyy" />
  <s:date name="person.birthday" format="%{getText('some.i18n.key')}" />
  <s:date name="person.birthday" nice="true" />
  <s:date name="person.birthday" />
Date

Field Summary
private static String | DATETAG_DEFAULT_DAYS
private static String | DATETAG_DEFAULT_FUTURE
private static String | DATETAG_DEFAULT_HOURS
private static String | DATETAG_DEFAULT_MINUTES
private static String | DATETAG_DEFAULT_PAST
private static String | DATETAG_DEFAULT_SECONDS
private static String | DATETAG_DEFAULT_YEARS
static String | DATETAG_PROPERTY Property name to fall back when no format is specified
static String | DATETAG_PROPERTY_DAYS Property name that defines the days notation (default: {0,choice,1#one day|1<{0} days}{1,choice,0#|1#, one hour|1<, {1} hours})
static String | DATETAG_PROPERTY_FUTURE Property name that defines the future notation (default: in {0})
static String | DATETAG_PROPERTY_HOURS Property name that defines the hours notation (default: {0,choice,1#one hour|1<{0} hours}{1,choice,0#|1#, one minute|1<, {1} minutes})
static String | DATETAG_PROPERTY_MINUTES Property name that defines the minutes notation (default: {0,choice,1#one minute|1<{0} minutes})
static String | DATETAG_PROPERTY_PAST Property name that defines the past notation (default: {0} ago)
static String | DATETAG_PROPERTY_SECONDS Property name that defines the seconds notation (default: in instant)
static String | DATETAG_PROPERTY_YEARS Property name that defines the years notation (default: {0,choice,1#one year|1<{0} years}{1,choice,0#|1#, one day|1<, {1} days})
private String | format
private static Log | LOG
private String | name
private boolean | nice
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Date(ValueStack stack)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
private TextProvider | findProviderInStack()
String | formatTime(TextProvider tp, Date date) Calculates the difference in time from now to the given date, and outputs it nicely.
String | getFormat()
String | getName()
boolean | isNice()
void | setFormat(String format)
void | setName(String name)
void | setNice(boolean nice)
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

DATETAG_PROPERTY

public static final String DATETAG_PROPERTY
Property name to fall back when no format is specified

See Also:
Constant Field Values

DATETAG_PROPERTY_PAST

public static final String DATETAG_PROPERTY_PAST
Property name that defines the past notation (default: {0} ago)

See Also:
Constant Field Values

DATETAG_DEFAULT_PAST

private static final String DATETAG_DEFAULT_PAST
See Also:
Constant Field Values

DATETAG_PROPERTY_FUTURE

public static final String DATETAG_PROPERTY_FUTURE
Property name that defines the future notation (default: in {0})

See Also:
Constant Field Values

DATETAG_DEFAULT_FUTURE

private static final String DATETAG_DEFAULT_FUTURE
See Also:
Constant Field Values

DATETAG_PROPERTY_SECONDS

public static final String DATETAG_PROPERTY_SECONDS
Property name that defines the seconds notation (default: in instant)

See Also:
Constant Field Values

DATETAG_DEFAULT_SECONDS

private static final String DATETAG_DEFAULT_SECONDS
See Also:
Constant Field Values

DATETAG_PROPERTY_MINUTES

public static final String DATETAG_PROPERTY_MINUTES
Property name that defines the minutes notation (default: {0,choice,1#one minute|1<{0} minutes})

See Also:
Constant Field Values

DATETAG_DEFAULT_MINUTES

private static final String DATETAG_DEFAULT_MINUTES
See Also:
Constant Field Values

DATETAG_PROPERTY_HOURS

public static final String DATETAG_PROPERTY_HOURS
Property name that defines the hours notation (default: {0,choice,1#one hour|1<{0} hours}{1,choice,0#|1#, one minute|1<, {1} minutes})

See Also:
Constant Field Values

DATETAG_DEFAULT_HOURS

private static final String DATETAG_DEFAULT_HOURS
See Also:
Constant Field Values

DATETAG_PROPERTY_DAYS

public static final String DATETAG_PROPERTY_DAYS
Property name that defines the days notation (default: {0,choice,1#one day|1<{0} days}{1,choice,0#|1#, one hour|1<, {1} hours})

See Also:
Constant Field Values

DATETAG_DEFAULT_DAYS

private static final String DATETAG_DEFAULT_DAYS
See Also:
Constant Field Values

DATETAG_PROPERTY_YEARS

public static final String DATETAG_PROPERTY_YEARS
Property name that defines the years notation (default: {0,choice,1#one year|1<{0} years}{1,choice,0#|1#, one day|1<, {1} days})

See Also:
Constant Field Values

DATETAG_DEFAULT_YEARS

private static final String DATETAG_DEFAULT_YEARS
See Also:
Constant Field Values

name

private String name

format

private String format

nice

private boolean nice
Constructor Detail

Date

public Date(ValueStack stack)
Method Detail

findProviderInStack

private TextProvider findProviderInStack()

formatTime

public String formatTime(TextProvider tp,
                         Date date)
Calculates the difference in time from now to the given date, and outputs it nicely.

An example:
Now = 2006/03/12 13:38:00, date = 2006/03/12 15:50:00 will output "in 1 hour, 12 minutes".

Parameters:
tp - text provider
date - the date
Returns:
the date nicely

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setFormat

public void setFormat(String format)

setNice

public void setNice(boolean nice)

getName

public String getName()
Returns:
Returns the name.

setName

public void setName(String name)

getFormat

public String getFormat()
Returns:
Returns the format.

isNice

public boolean isNice()
Returns:
Returns the nice.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateTimePicker (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class DateTimePicker

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.DateTimePicker

public class DateTimePicker
extends UIBean

Renders a date/time picker in a dropdown container.

A stand-alone DateTimePicker widget that makes it easy to select a date/time, or increment by week, month, and/or year.

Dates attributes passed in the `RFC 3339` format: Renders date/time picker element.

Format supported by this component are:-
Format | Description
#dd | Display day in two digits format
#d | Try to display day in one digit format, if cannot use 2 digit format
#MM | Display month in two digits format
#M | Try to display month in one digits format, if cannot use 2 digit format
#yyyy | Display year in four digits format
#yy | Display the last two digits of the yaer
#y | Display the last digits of the year

It is possible to customize the user-visible formatting with either the formatLength or displayFormat attributes. The value sent to the server is typically a locale-independent value in a hidden field as defined by the name attribute. RFC3339 representation is used by default, but other options are available with saveFormat

Examples

 Example 1:
     <s:datetimepicker name="order.date" label="Order Date" />
 Example 2:
     <s:datetimepicker name="delivery.date" label="Delivery Date" format="#yyyy-#MM-#dd"  />

The css could be changed by using the following :-

 <s:datetimepicker name="birthday" label="Birthday" templateCss="...." />

Field Summary
protected String | adjustWeeks
protected String | dayWidth
protected String | displayFormat
protected String | displayWeeks
protected String | endDate
protected String | formatLength
protected String | iconPath
protected String | language
protected static Log | LOG
private static SimpleDateFormat | RFC3339_FORMAT
protected String | startDate
protected String | staticDisplay
static String | TEMPLATE
protected String | templateCssPath
protected String | toggleDuration
protected String | toggleType
protected String | type
protected String | weekStartsOn
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
DateTimePicker(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateParams()
private String | format(Object obj)
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setAdjustWeeks(String adjustWeeks)
void | setDayWidth(String dayWidth)
void | setDisplayFormat(String displayFormat)
void | setDisplayWeeks(String displayWeeks)
void | setEndDate(String endDate)
void | setFormatLength(String formatLength)
void | setIconPath(String iconPath)
void | setLanguage(String language)
void | setStartDate(String startDate)
void | setStaticDisplay(String staticDisplay)
void | setTemplateCssPath(String templateCssPath)
void | setToggleDuration(String toggleDuration)
void | setToggleType(String toggleType)
void | setType(String type)
void | setWeekStartsOn(String weekStartsOn)
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

RFC3339_FORMAT

private static final SimpleDateFormat RFC3339_FORMAT

LOG

protected static final Log LOG

iconPath

protected String iconPath

formatLength

protected String formatLength

displayFormat

protected String displayFormat

toggleType

protected String toggleType

toggleDuration

protected String toggleDuration

type

protected String type

displayWeeks

protected String displayWeeks

adjustWeeks

protected String adjustWeeks

startDate

protected String startDate

endDate

protected String endDate

weekStartsOn

protected String weekStartsOn

staticDisplay

protected String staticDisplay

dayWidth

protected String dayWidth

language

protected String language

templateCssPath

protected String templateCssPath
Constructor Detail

DateTimePicker

public DateTimePicker(ValueStack stack,
                      HttpServletRequest request,
                      HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateParams

public void evaluateParams()
Overrides:
evaluateParams in class UIBean

setAdjustWeeks

public void setAdjustWeeks(String adjustWeeks)

setDayWidth

public void setDayWidth(String dayWidth)

setDisplayWeeks

public void setDisplayWeeks(String displayWeeks)

setEndDate

public void setEndDate(String endDate)

setStartDate

public void setStartDate(String startDate)

setStaticDisplay

public void setStaticDisplay(String staticDisplay)

setWeekStartsOn

public void setWeekStartsOn(String weekStartsOn)

setLanguage

public void setLanguage(String language)

setDisplayFormat

public void setDisplayFormat(String displayFormat)

setFormatLength

public void setFormatLength(String formatLength)

setIconPath

public void setIconPath(String iconPath)

setToggleDuration

public void setToggleDuration(String toggleDuration)

setType

public void setType(String type)

setToggleType

public void setToggleType(String toggleType)

setTemplateCssPath

public void setTemplateCssPath(String templateCssPath)

format

private String format(Object obj)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Debug (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Debug

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.Debug

public class Debug
extends UIBean

Nested Class Summary
private  class Debug.DebugMapEntry
Field Summary
static String TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Debug(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

Debug

public Debug(ValueStack stack,
             HttpServletRequest request,
             HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Debug.DebugMapEntry (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Debug.DebugMapEntry

java.lang.Object
    extended by  org.apache.struts2.components.Debug.DebugMapEntry
All Implemented Interfaces:
Map.Entry
Enclosing class:
Debug
private class Debug.DebugMapEntry
extends Object
implements Map.Entry

Field Summary
private Object | key
private Object | value
Constructor Summary
Debug.DebugMapEntry(Object key, Object value)
Method Summary
Object | getKey()
Object | getValue()
Object | setValue(Object newVal)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map.Entry
equals, hashCode

Field Detail

key

private Object key

value

private Object value
Constructor Detail

Debug.DebugMapEntry

Debug.DebugMapEntry(Object key,
                    Object value)
Method Detail

getKey

public Object getKey()
Specified by:
getKey in interface Map.Entry

getValue

public Object getValue()
Specified by:
getValue in interface Map.Entry

setValue

public Object setValue(Object newVal)
Specified by:
setValue in interface Map.Entry
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Div (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Div

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ClosingUIBean
                extended by  org.apache.struts2.components.AbstractRemoteCallUIBean
                    extended by  org.apache.struts2.components.Div
All Implemented Interfaces:
RemoteUICallBean
public class Div
extends AbstractRemoteCallUIBean

The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.

It creates a HTML <DIV /> that obtains it's content via a remote XMLHttpRequest call via the dojo framework.

THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED
  • href
  • errorText
  • afterLoading
  • executeScripts
  • loadingText
  • listenTopics
  • handler
  • formId
  • formFilter
  • targets
  • notifyTopics
  • showErrorTransportText
  • indicator
'targets' is a list of element ids whose content will be updated with the text returned from request.

'href' needs to be set as an url tag reference value.

'errorText' is the text that will be displayed when there is an error making the request.

'afterLoading' Deprecated. Use 'notifyTopics'.

'executeScripts' if set to true will execute javascript sections in the returned text.

'loadingText' is the text that will be displayed on the 'targets' elements while making the request.

'handler' is the name of the function that will take care of making the AJAX request. Dojo's widget and dom node are passed as parameters).

'formId' is the id of the html form whose fields will be seralized and passed as parameters in the request.

'formFilter' is the name of a function which will be used to filter the fields that will be seralized. This function takes as a parameter the element and returns true if the element should be included.

'updateFreq' sets(in milliseconds) the update interval. 'autoStart' if set to true(true by default) starts the timer automatically 'startTimerListenTopics' is a comma-separated list of topics used to start the timer 'stopTimerListenTopics' is a comma-separated list of topics used to stop the timer 'listenTopics' comma separated list of topics names, that will trigger a request 'indicator' element to be shown while the request executing 'showErrorTransportText': whether errors should be displayed (on 'targets')

'showLoadingText' show loading text on targets

'notifyTopics' comma separated list of topics names, that will be published. Three parameters are passed:
  • data: html or json object when type='load' or type='error'
  • type: 'before' before the request is made, 'load' when the request succeeds, or 'error' when it fails
  • request: request javascript object, when type='load' or type='error'

Examples

 <s:url id="url" action="AjaxTest" />
 <s:div
    id="once"
    theme="ajax"
    href="%{url}"
    loadingText="Loading..."
    listenTopics="/refresh"
    updateFreq="3000"
    autoStart="true"
    formId="form"
></s:div>

Field Summary
protected String | autoStart
static String | COMPONENT_NAME
protected String | delay
protected String | refreshOnShow
protected String | startTimerListenTopics
protected String | stopTimerListenTopics
static String | TEMPLATE
static String | TEMPLATE_CLOSE
protected String | updateFreq
Fields inherited from class org.apache.struts2.components.AbstractRemoteCallUIBean
afterLoading, beforeLoading, errorText, executeScripts, formFilter, formId, handler, href, indicator, listenTopics, loadingText, notifyTopics, showErrorTransportText, showLoadingText
Fields inherited from class org.apache.struts2.components.ClosingUIBean
openTemplate
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Div(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
String | getDefaultOpenTemplate()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setAfterLoading(String afterLoading)
void | setAutoStart(String autoStart)
void | setDelay(String delay)
void | setRefreshOnShow(String refreshOnShow)
void | setStartTimerListenTopics(String startTimerListenTopic)
void | setStopTimerListenTopics(String stopTimerListenTopic)
void | setUpdateFreq(String updateInterval)
Methods inherited from class org.apache.struts2.components.AbstractRemoteCallUIBean
setBeforeLoading, setErrorText, setExecuteScripts, setFormFilter, setFormId, setHandler, setHref, setIndicator, setListenTopics, setLoadingText, setNotifyTopics, setShowErrorTransportText, setShowLoadingText
Methods inherited from class org.apache.struts2.components.ClosingUIBean
setOpenTemplate, start
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

TEMPLATE_CLOSE

public static final String TEMPLATE_CLOSE
See Also:
Constant Field Values

COMPONENT_NAME

public static final String COMPONENT_NAME

updateFreq

protected String updateFreq

autoStart

protected String autoStart

delay

protected String delay

startTimerListenTopics

protected String startTimerListenTopics

stopTimerListenTopics

protected String stopTimerListenTopics

refreshOnShow

protected String refreshOnShow
Constructor Detail

Div

public Div(ValueStack stack,
           HttpServletRequest request,
           HttpServletResponse response)
Method Detail

getDefaultOpenTemplate

public String getDefaultOpenTemplate()
Specified by:
getDefaultOpenTemplate in class ClosingUIBean

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class AbstractRemoteCallUIBean

setAutoStart

public void setAutoStart(String autoStart)

setDelay

public void setDelay(String delay)

setUpdateFreq

public void setUpdateFreq(String updateInterval)

setStartTimerListenTopics

public void setStartTimerListenTopics(String startTimerListenTopic)

setStopTimerListenTopics

public void setStopTimerListenTopics(String stopTimerListenTopic)

setRefreshOnShow

public void setRefreshOnShow(String refreshOnShow)

setAfterLoading

public void setAfterLoading(String afterLoading)
Specified by:
setAfterLoading in interface RemoteUICallBean
Overrides:
setAfterLoading in class AbstractRemoteCallUIBean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleListUIBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class DoubleListUIBean

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
                extended by  org.apache.struts2.components.DoubleListUIBean
Direct Known Subclasses:
DoubleSelect, OptionTransferSelect
public abstract class DoubleListUIBean
extends ListUIBean

DoubleListUIBean is the standard superclass of all Struts double list handling components.

Note that the doublelistkey and doublelistvalue attribute will default to "key" and "value" respectively only when the doublelist attribute is evaluated to a Map or its decendant. Other thing else, will result in doublelistkey and doublelistvalue to be null and not used.

Field Summary
protected String | doubleAccesskey
protected String | doubleCssClass
protected String | doubleCssStyle
protected String | doubleDisabled
protected String | doubleEmptyOption
protected String | doubleHeaderKey
protected String | doubleHeaderValue
protected String | doubleId
protected String | doubleList
protected String | doubleListKey
protected String | doubleListValue
protected String | doubleMultiple
protected String | doubleName
protected String | doubleOnblur
protected String | doubleOnchange
protected String | doubleOnclick
protected String | doubleOndblclick
protected String | doubleOnfocus
protected String | doubleOnkeydown
protected String | doubleOnkeypress
protected String | doubleOnkeyup
protected String | doubleOnmousedown
protected String | doubleOnmousemove
protected String | doubleOnmouseout
protected String | doubleOnmouseover
protected String | doubleOnmouseup
protected String | doubleOnselect
protected String | doubleSize
protected String | doubleValue
protected String | emptyOption
protected String | formName
protected String | headerKey
protected String | headerValue
protected String | multiple
protected String | size
Fields inherited from class org.apache.struts2.components.ListUIBean
list, listKey, listValue, throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
DoubleListUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
String | getDoubleCssClass()
String | getDoubleCssStyle()
String | getDoubleDisabled()
String | getDoubleEmptyOption()
String | getDoubleHeaderKey()
String | getDoubleHeaderValue()
String | getDoubleId()
String | getDoubleList()
String | getDoubleListKey()
String | getDoubleListValue()
String | getDoubleMultiple()
String | getDoubleName()
String | getDoubleOnblur()
String | getDoubleOnchange()
String | getDoubleOnclick()
String | getDoubleOndblclick()
String | getDoubleOnfocus()
String | getDoubleOnkeydown()
String | getDoubleOnkeypress()
String | getDoubleOnkeyup()
String | getDoubleOnmousedown()
String | getDoubleOnmousemove()
String | getDoubleOnmouseout()
String | getDoubleOnmouseover()
String | getDoubleOnmouseup()
String | getDoubleOnselect()
String | getDoubleSize()
String | getDoubleValue()
String | getFormName()
void | setDoubleAccesskey(String doubleAccesskey)
void | setDoubleCssClass(String doubleCssClass)
void | setDoubleCssStyle(String doubleCssStyle)
void | setDoubleDisabled(String doubleDisabled)
void | setDoubleEmptyOption(String doubleEmptyOption)
void | setDoubleHeaderKey(String doubleHeaderKey)
void | setDoubleHeaderValue(String doubleHeaderValue)
void | setDoubleId(String doubleId)
void | setDoubleList(String doubleList)
void | setDoubleListKey(String doubleListKey)
void | setDoubleListValue(String doubleListValue)
void | setDoubleMultiple(String doubleMultiple)
void | setDoubleName(String doubleName)
void | setDoubleOnblur(String doubleOnblur)
void | setDoubleOnchange(String doubleOnchange)
void | setDoubleOnclick(String doubleOnclick)
void | setDoubleOndblclick(String doubleOndblclick)
void | setDoubleOnfocus(String doubleOnfocus)
void | setDoubleOnkeydown(String doubleOnkeydown)
void | setDoubleOnkeypress(String doubleOnkeypress)
void | setDoubleOnkeyup(String doubleOnkeyup)
void | setDoubleOnmousedown(String doubleOnmousedown)
void | setDoubleOnmousemove(String doubleOnmousemove)
void | setDoubleOnmouseout(String doubleOnmouseout)
void | setDoubleOnmouseover(String doubleOnmouseover)
void | setDoubleOnmouseup(String doubleOnmouseup)
void | setDoubleOnselect(String doubleOnselect)
void | setDoubleSize(String doubleSize)
void | setDoubleValue(String doubleValue)
void | setEmptyOption(String emptyOption)
void | setFormName(String formName)
void | setHeaderKey(String headerKey)
void | setHeaderValue(String headerValue)
void | setMultiple(String multiple)
void | setSize(String size)
Methods inherited from class org.apache.struts2.components.ListUIBean
contains, getValueClassType, setList, setListKey, setListValue, setThrowExceptionOnNullValueAttribute
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getDefaultTemplate, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

emptyOption

protected String emptyOption

headerKey

protected String headerKey

headerValue

protected String headerValue

multiple

protected String multiple

size

protected String size

doubleList

protected String doubleList

doubleListKey

protected String doubleListKey

doubleListValue

protected String doubleListValue

doubleName

protected String doubleName

doubleValue

protected String doubleValue

formName

protected String formName

doubleId

protected String doubleId

doubleDisabled

protected String doubleDisabled

doubleMultiple

protected String doubleMultiple

doubleSize

protected String doubleSize

doubleHeaderKey

protected String doubleHeaderKey

doubleHeaderValue

protected String doubleHeaderValue

doubleEmptyOption

protected String doubleEmptyOption

doubleCssClass

protected String doubleCssClass

doubleCssStyle

protected String doubleCssStyle

doubleOnclick

protected String doubleOnclick

doubleOndblclick

protected String doubleOndblclick

doubleOnmousedown

protected String doubleOnmousedown

doubleOnmouseup

protected String doubleOnmouseup

doubleOnmouseover

protected String doubleOnmouseover

doubleOnmousemove

protected String doubleOnmousemove

doubleOnmouseout

protected String doubleOnmouseout

doubleOnfocus

protected String doubleOnfocus

doubleOnblur

protected String doubleOnblur

doubleOnkeypress

protected String doubleOnkeypress

doubleOnkeydown

protected String doubleOnkeydown

doubleOnkeyup

protected String doubleOnkeyup

doubleOnselect

protected String doubleOnselect

doubleOnchange

protected String doubleOnchange

doubleAccesskey

protected String doubleAccesskey
Constructor Detail

DoubleListUIBean

public DoubleListUIBean(ValueStack stack,
                        HttpServletRequest request,
                        HttpServletResponse response)
Method Detail

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class ListUIBean

setDoubleList

public void setDoubleList(String doubleList)

setDoubleListKey

public void setDoubleListKey(String doubleListKey)

setDoubleListValue

public void setDoubleListValue(String doubleListValue)

setDoubleName

public void setDoubleName(String doubleName)

setDoubleValue

public void setDoubleValue(String doubleValue)

setFormName

public void setFormName(String formName)

getFormName

public String getFormName()

setDoubleCssClass

public void setDoubleCssClass(String doubleCssClass)

getDoubleCssClass

public String getDoubleCssClass()

setDoubleCssStyle

public void setDoubleCssStyle(String doubleCssStyle)

getDoubleCssStyle

public String getDoubleCssStyle()

setDoubleHeaderKey

public void setDoubleHeaderKey(String doubleHeaderKey)

getDoubleHeaderKey

public String getDoubleHeaderKey()

setDoubleHeaderValue

public void setDoubleHeaderValue(String doubleHeaderValue)

getDoubleHeaderValue

public String getDoubleHeaderValue()

setDoubleEmptyOption

public void setDoubleEmptyOption(String doubleEmptyOption)

getDoubleEmptyOption

public String getDoubleEmptyOption()

getDoubleDisabled

public String getDoubleDisabled()

setDoubleDisabled

public void setDoubleDisabled(String doubleDisabled)

getDoubleId

public String getDoubleId()

setDoubleId

public void setDoubleId(String doubleId)

getDoubleMultiple

public String getDoubleMultiple()

setDoubleMultiple

public void setDoubleMultiple(String doubleMultiple)

getDoubleOnblur

public String getDoubleOnblur()

setDoubleOnblur

public void setDoubleOnblur(String doubleOnblur)

getDoubleOnchange

public String getDoubleOnchange()

setDoubleOnchange

public void setDoubleOnchange(String doubleOnchange)

getDoubleOnclick

public String getDoubleOnclick()

setDoubleOnclick

public void setDoubleOnclick(String doubleOnclick)

getDoubleOndblclick

public String getDoubleOndblclick()

setDoubleOndblclick

public void setDoubleOndblclick(String doubleOndblclick)

getDoubleOnfocus

public String getDoubleOnfocus()

setDoubleOnfocus

public void setDoubleOnfocus(String doubleOnfocus)

getDoubleOnkeydown

public String getDoubleOnkeydown()

setDoubleOnkeydown

public void setDoubleOnkeydown(String doubleOnkeydown)

getDoubleOnkeypress

public String getDoubleOnkeypress()

setDoubleOnkeypress

public void setDoubleOnkeypress(String doubleOnkeypress)

getDoubleOnkeyup

public String getDoubleOnkeyup()

setDoubleOnkeyup

public void setDoubleOnkeyup(String doubleOnkeyup)

getDoubleOnmousedown

public String getDoubleOnmousedown()

setDoubleOnmousedown

public void setDoubleOnmousedown(String doubleOnmousedown)

getDoubleOnmousemove

public String getDoubleOnmousemove()

setDoubleOnmousemove

public void setDoubleOnmousemove(String doubleOnmousemove)

getDoubleOnmouseout

public String getDoubleOnmouseout()

setDoubleOnmouseout

public void setDoubleOnmouseout(String doubleOnmouseout)

getDoubleOnmouseover

public String getDoubleOnmouseover()

setDoubleOnmouseover

public void setDoubleOnmouseover(String doubleOnmouseover)

getDoubleOnmouseup

public String getDoubleOnmouseup()

setDoubleOnmouseup

public void setDoubleOnmouseup(String doubleOnmouseup)

getDoubleOnselect

public String getDoubleOnselect()

setDoubleOnselect

public void setDoubleOnselect(String doubleOnselect)

getDoubleSize

public String getDoubleSize()

setDoubleSize

public void setDoubleSize(String doubleSize)

getDoubleList

public String getDoubleList()

getDoubleListKey

public String getDoubleListKey()

getDoubleListValue

public String getDoubleListValue()

getDoubleName

public String getDoubleName()

getDoubleValue

public String getDoubleValue()

setEmptyOption

public void setEmptyOption(String emptyOption)

setHeaderKey

public void setHeaderKey(String headerKey)

setHeaderValue

public void setHeaderValue(String headerValue)

setMultiple

public void setMultiple(String multiple)

setSize

public void setSize(String size)

setDoubleAccesskey

public void setDoubleAccesskey(String doubleAccesskey)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleSelect (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class DoubleSelect

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
                extended by  org.apache.struts2.components.DoubleListUIBean
                    extended by  org.apache.struts2.components.DoubleSelect

public class DoubleSelect
extends DoubleListUIBean

Renders two HTML select elements with second one changing displayed values depending on selected entry of first one.

Examples

 <s:doubleselect label="doubleselect test1" name="menu" list="{'fruit','other'}" doubleName="dishes" doubleList="top == 'fruit' ? {'apple', 'orange'} : {'monkey', 'chicken'}" />
 <s:doubleselect label="doubleselect test2" name="menu" list="#{'fruit':'Nice Fruits', 'other':'Other Dishes'}" doubleName="dishes" doubleList="top == 'fruit' ? {'apple', 'orange'} : {'monkey', 'chicken'}" />

Field Summary
static String TEMPLATE
Fields inherited from class org.apache.struts2.components.DoubleListUIBean
doubleAccesskey, doubleCssClass, doubleCssStyle, doubleDisabled, doubleEmptyOption, doubleHeaderKey, doubleHeaderValue, doubleId, doubleList, doubleListKey, doubleListValue, doubleMultiple, doubleName, doubleOnblur, doubleOnchange, doubleOnclick, doubleOndblclick, doubleOnfocus, doubleOnkeydown, doubleOnkeypress, doubleOnkeyup, doubleOnmousedown, doubleOnmousemove, doubleOnmouseout, doubleOnmouseover, doubleOnmouseup, doubleOnselect, doubleSize, doubleValue, emptyOption, formName, headerKey, headerValue, multiple, size
Fields inherited from class org.apache.struts2.components.ListUIBean
list, listKey, listValue, throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
DoubleSelect(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
Methods inherited from class org.apache.struts2.components.DoubleListUIBean
getDoubleCssClass, getDoubleCssStyle, getDoubleDisabled, getDoubleEmptyOption, getDoubleHeaderKey, getDoubleHeaderValue, getDoubleId, getDoubleList, getDoubleListKey, getDoubleListValue, getDoubleMultiple, getDoubleName, getDoubleOnblur, getDoubleOnchange, getDoubleOnclick, getDoubleOndblclick, getDoubleOnfocus, getDoubleOnkeydown, getDoubleOnkeypress, getDoubleOnkeyup, getDoubleOnmousedown, getDoubleOnmousemove, getDoubleOnmouseout, getDoubleOnmouseover, getDoubleOnmouseup, getDoubleOnselect, getDoubleSize, getDoubleValue, getFormName, setDoubleAccesskey, setDoubleCssClass, setDoubleCssStyle, setDoubleDisabled, setDoubleEmptyOption, setDoubleHeaderKey, setDoubleHeaderValue, setDoubleId, setDoubleList, setDoubleListKey, setDoubleListValue, setDoubleMultiple, setDoubleName, setDoubleOnblur, setDoubleOnchange, setDoubleOnclick, setDoubleOndblclick, setDoubleOnfocus, setDoubleOnkeydown, setDoubleOnkeypress, setDoubleOnkeyup, setDoubleOnmousedown, setDoubleOnmousemove, setDoubleOnmouseout, setDoubleOnmouseover, setDoubleOnmouseup, setDoubleOnselect, setDoubleSize, setDoubleValue, setEmptyOption, setFormName, setHeaderKey, setHeaderValue, setMultiple, setSize
Methods inherited from class org.apache.struts2.components.ListUIBean
contains, getValueClassType, setList, setListKey, setListValue, setThrowExceptionOnNullValueAttribute
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

DoubleSelect

public DoubleSelect(ValueStack stack,
                    HttpServletRequest request,
                    HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class DoubleListUIBean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Else (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Else

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Else

public class Else
extends Component

Perform basic condition flow. 'If' tag could be used by itself or with 'Else If' Tag and/or single/multiple 'Else' Tag.

no params

  <s:if test="%{false}">
      <div>Will Not Be Executed</div>
  </s:if>
  <s:elseif test="%{true}">
      <div>Will Be Executed</div>
  </s:elseif>
  <s:else>
      <div>Will Not Be Executed</div>
  </s:else>

Field Summary
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Else(ValueStack stack)
Method Summary
 boolean start(Writer writer)
Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Else

public Else(ValueStack stack)
Method Detail

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElseIf (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class ElseIf

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.ElseIf

public class ElseIf
extends Component

Perform basic condition flow. 'If' tag could be used by itself or with 'Else If' Tag and/or single/multiple 'Else' Tag.

  • test* (Boolean) - Logic to determined if body of tag is to be displayed

  <s:if test="%{false}">
      <div>Will Not Be Executed</div>
  </s:if>
  <s:elseif test="%{true}">
      <div>Will Be Executed</div>
  </s:elseif>
  <s:else>
      <div>Will Not Be Executed</div>
  </s:else>

Field Summary
protected Boolean | answer
protected String | test
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
ElseIf(ValueStack stack)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setTest(String test)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

answer

protected Boolean answer

test

protected String test
Constructor Detail

ElseIf

public ElseIf(ValueStack stack)
Method Detail

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setTest

public void setTest(String test)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldError (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class FieldError

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.FieldError
All Implemented Interfaces:
Param.UnnamedParametric
public class FieldError
extends UIBean
implements Param.UnnamedParametric

Render field errors if they exists. Specific layout depends on the particular theme.

Examples

    <!-- example 1 -->
    <s:fielderror />

    <!-- example 2 -->
    <s:fielderror>
         <s:param>field1</s:param>
         <s:param>field2</s:param>
    </s:fielderror>
    <s:form .... >>
       ....
    </s:form>

    OR

    <s:fielderror>
          <s:param value="%{'field1'}" />
          <s:param value="%{'field2'}" />
    </s:fielderror>
    <s:form .... >>
       ....
    </s:form>

Description

 Example 1: display all field errors

 Example 2: display field errors only for 'field1' and 'field2'

Field Summary
private List | errorFieldNames
private static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
FieldError(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | addParameter(Object value) Adds the given value as a parameter to the outer tag.
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
List | getFieldErrorFieldNames()
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

errorFieldNames

private List errorFieldNames

TEMPLATE

private static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

FieldError

public FieldError(ValueStack stack,
                  HttpServletRequest request,
                  HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

addParameter

public void addParameter(Object value)
Description copied from interface: Param.UnnamedParametric
Adds the given value as a parameter to the outer tag.

Specified by:
addParameter in interface Param.UnnamedParametric
Parameters:
value - the value

getFieldErrorFieldNames

public List getFieldErrorFieldNames()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


File (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class File

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.File

public class File
extends UIBean

Renders an HTML file input element.

Examples

 <s:file name="anUploadFile" accept="text/*" />
 <s:file name="anohterUploadFIle" accept="text/html,text/plain" />

Field Summary
protected String | accept
private static Log | log
protected String | size
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
File(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setAccept(String accept)
void | setSize(String size)
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

accept

protected String accept

size

protected String size
Constructor Detail

File

public File(ValueStack stack,
            HttpServletRequest request,
            HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateParams

public void evaluateParams()
Overrides:
evaluateParams in class UIBean

setAccept

public void setAccept(String accept)

setSize

public void setSize(String size)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Form (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Form

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ClosingUIBean
                extended by  org.apache.struts2.components.Form

public class Form
extends ClosingUIBean

Renders HTML an input form.

The remote form allows the form to be submitted without the page being refreshed. The results from the form can be inserted into any HTML element on the page.

NOTE:

The order / logic in determining the posting url of the generated HTML form is as follows:-

  1. If the action attribute is not specified, then the current request will be used to determine the posting url
  2. If the action is given, Struts will try to obtain an ActionConfig. This will be successfull if the action attribute is a valid action alias defined struts.xml.
  3. If the action is given and is not an action alias defined in struts.xml, Struts will used the action attribute as if it is the posting url, separting the namespace from it and using UrlHelper to generate the final url.

Examples

 <s:form ... />

Field Summary
protected String | acceptcharset
protected String | action
protected Configuration | configuration
protected boolean | enableDynamicMethodInvocation
protected String | enctype
protected String | method
protected String | namespace
protected ObjectFactory | objectFactory
protected String | onsubmit
static String | OPEN_TEMPLATE
protected String | portletMode
private int | sequence
protected String | target
static String | TEMPLATE
protected String | validate
protected String | windowState
Fields inherited from class org.apache.struts2.components.ClosingUIBean
openTemplate
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Form(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
private void | evaluateClientSideJsEnablement(String actionName, String namespace, String actionMethod)
protected void | evaluateExtraParams()
private void | evaluateExtraParamsPortletRequest(String namespace, String action) Constructs the action url adapted to a portal environment.
private void | evaluateExtraParamsServletRequest(String action, String namespace, boolean isAjax)
protected boolean | evaluateNameValue()
String | getDefaultOpenTemplate()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
protected int | getSequence() Get a incrementing sequence unique to this Form component.
List | getValidators(String name)
protected void | populateComponentHtmlId(Form form) Form component determine the its HTML element id as follows:- if an 'id' attribute is specified. if an 'action' attribute is specified, it will be used as the id.
void | setAcceptcharset(String acceptcharset)
void | setAction(String action)
void | setConfiguration(Configuration configuration)
void | setEnableDynamicMethodInvocation(String enable)
void | setEnctype(String enctype)
void | setMethod(String method)
void | setNamespace(String namespace)
void | setObjectFactory(ObjectFactory objectFactory)
void | setOnsubmit(String onsubmit)
void | setPortletMode(String portletMode)
void | setTarget(String target)
void | setValidate(String validate)
void | setWindowState(String windowState)
Methods inherited from class org.apache.struts2.components.ClosingUIBean
setOpenTemplate, start
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OPEN_TEMPLATE

public static final String OPEN_TEMPLATE
See Also:
Constant Field Values

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

sequence

private int sequence

onsubmit

protected String onsubmit

action

protected String action

target

protected String target

enctype

protected String enctype

method

protected String method

namespace

protected String namespace

validate

protected String validate

portletMode

protected String portletMode

windowState

protected String windowState

acceptcharset

protected String acceptcharset

enableDynamicMethodInvocation

protected boolean enableDynamicMethodInvocation

configuration

protected Configuration configuration

objectFactory

protected ObjectFactory objectFactory
Constructor Detail

Form

public Form(ValueStack stack,
            HttpServletRequest request,
            HttpServletResponse response)
Method Detail

evaluateNameValue

protected boolean evaluateNameValue()
Overrides:
evaluateNameValue in class UIBean

getDefaultOpenTemplate

public String getDefaultOpenTemplate()
Specified by:
getDefaultOpenTemplate in class ClosingUIBean

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

setEnableDynamicMethodInvocation

public void setEnableDynamicMethodInvocation(String enable)

setConfiguration

public void setConfiguration(Configuration configuration)

setObjectFactory

public void setObjectFactory(ObjectFactory objectFactory)

evaluateExtraParams

protected void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

populateComponentHtmlId

protected void populateComponentHtmlId(Form form)
Form component determine the its HTML element id as follows:-
  1. if an 'id' attribute is specified.
  2. if an 'action' attribute is specified, it will be used as the id.

Overrides:
populateComponentHtmlId in class UIBean

evaluateExtraParamsServletRequest

private void evaluateExtraParamsServletRequest(String action,
                                               String namespace,
                                               boolean isAjax)
Parameters:
isAjax -
namespace -
action -

evaluateClientSideJsEnablement

private void evaluateClientSideJsEnablement(String actionName,
                                            String namespace,
                                            String actionMethod)

evaluateExtraParamsPortletRequest

private void evaluateExtraParamsPortletRequest(String namespace,
                                               String action)
Constructs the action url adapted to a portal environment.

Parameters:
action - The action to create the URL for.

getValidators

public List getValidators(String name)

getSequence

protected int getSequence()
Get a incrementing sequence unique to this Form component. It is used by Form component's child that might need a sequence to make them unique.

Returns:
int

setOnsubmit

public void setOnsubmit(String onsubmit)

setAction

public void setAction(String action)

setTarget

public void setTarget(String target)

setEnctype

public void setEnctype(String enctype)

setMethod

public void setMethod(String method)

setNamespace

public void setNamespace(String namespace)

setValidate

public void setValidate(String validate)

setPortletMode

public void setPortletMode(String portletMode)

setWindowState

public void setWindowState(String windowState)

setAcceptcharset

public void setAcceptcharset(String acceptcharset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormButton (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class FormButton

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.FormButton
Direct Known Subclasses:
Reset, Submit
public abstract class FormButton
extends UIBean

FormButton.

Field Summary
protected String | action
protected String | align
(package private) static String | BUTTONTYPE_BUTTON
(package private) static String | BUTTONTYPE_IMAGE
(package private) static String | BUTTONTYPE_INPUT
protected String | method
protected String | type
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
FormButton(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
protected void | populateComponentHtmlId(Form form) Override UIBean's implementation, such that component Html id is determined in the following order :- This component id attribute [containing_form_id]_[this_component_name] [containing_form_id]_[this_component_action]_[this_component_method] [containing_form_id]_[this_component_method] [this_component_name] [this_component_action]_[this_component_method] [this_component_method] [an increasing sequential number unique to the form starting with 0]
void | setAction(String action)
void | setAlign(String align)
void | setMethod(String method)
void | setType(String type)
protected abstract boolean | supportsImageType() Indicate whether the concrete button supports the type "image".
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getDefaultTemplate, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BUTTONTYPE_INPUT

static final String BUTTONTYPE_INPUT
See Also:
Constant Field Values

BUTTONTYPE_BUTTON

static final String BUTTONTYPE_BUTTON
See Also:
Constant Field Values

BUTTONTYPE_IMAGE

static final String BUTTONTYPE_IMAGE
See Also:
Constant Field Values

action

protected String action

method

protected String method

align

protected String align

type

protected String type
Constructor Detail

FormButton

public FormButton(ValueStack stack,
                  HttpServletRequest request,
                  HttpServletResponse response)
Method Detail

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

populateComponentHtmlId

protected void populateComponentHtmlId(Form form)
Override UIBean's implementation, such that component Html id is determined in the following order :-
  1. This component id attribute
  2. [containing_form_id]_[this_component_name]
  3. [containing_form_id]_[this_component_action]_[this_component_method]
  4. [containing_form_id]_[this_component_method]
  5. [this_component_name]
  6. [this_component_action]_[this_component_method]
  7. [this_component_method]
  8. [an increasing sequential number unique to the form starting with 0]

Overrides:
populateComponentHtmlId in class UIBean

supportsImageType

protected abstract boolean supportsImageType()
Indicate whether the concrete button supports the type "image".

Returns:
true if type image is supported.

setAction

public void setAction(String action)

setMethod

public void setMethod(String method)

setAlign

public void setAlign(String align)

setType

public void setType(String type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


GenericUIBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class GenericUIBean

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.GenericUIBean
Direct Known Subclasses:
WebTable
public class GenericUIBean
extends UIBean

Renders an custom UI widget using the specified templates. Additional objects can be passed in to the template using the param tags.

Freemarker:

Objects provided can be retrieve from within the template via $parameters._paramname_.

Jsp:

Objects provided can be retrieve from within the template via <s:property value="%{parameters._paramname_}" />

In the bottom JSP and Velocity samples, two parameters are being passed in to the component. From within the component, they can be accessed as:-

Freemarker:

$parameters.get('key1') and $parameters.get('key2') or $parameters.key1 and $parameters.key2

Jsp:

<s:property value="%{parameters.key1}" /> and <s:property value="%{'parameters.key2'}" /> or <s:property value="%{parameters.get('key1')}" /> and <s:property value="%{parameters.get('key2')}" />

Currently, your custom UI components can be written in Velocity, JSP, or Freemarker, and the correct rendering engine will be found based on file extension.

Remember: the value params will always be resolved against the ValueStack so if you mean to pass a string literal to your component, make sure to wrap it in quotes i.e. value="'value1'" otherwise, the the value stack will search for an Object on the stack with a method of getValue1(). (now that i've written this, i'm not entirely sure this is the case. i should verify this manana)

Examples

 JSP
     <s:component template="/my/custom/component.vm"/>

       or

     <s:component template="/my/custom/component.vm">
       <s:param name="key1" value="value1"/>
       <s:param name="key2" value="value2"/>
     </s:component>

 Velocity
     #s-component( "template=/my/custom/component.vm" )

       or

     #s-component( "template=/my/custom/component.vm" )
       #s-param( "name=key1" "value=value1" )
       #s-param( "name=key2" "value=value2" )
     #end

 Freemarker
    <@s..component template="/my/custom/component.ftl" />

      or

    <@s..component template="/my/custom/component.ftl">
       <@s..param name="key1" value="%{'value1'}" />
       <@s..param name="key2" value="%{'value2'}" />
    </@s..component>

NOTE: If Jsp is used as the template, the jsp template itself must lie within the webapp itself and not the classpath. Unlike Freemarker or Velocity, JSP template could not be picked up from the classpath.

Field Summary
private static String TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
GenericUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
boolean | contains(Object obj1, Object obj2)
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

private static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

GenericUIBean

public GenericUIBean(ValueStack stack,
                     HttpServletRequest request,
                     HttpServletResponse response)
Method Detail

contains

public boolean contains(Object obj1,
                        Object obj2)

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Head (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Head

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.Head

public class Head
extends UIBean

Renders parts of the HEAD section for an HTML file. This is useful as some themes require certain CSS and JavaScript includes.

If, for example, your page has ajax components integrated, without having the default theme set to ajax, you might want to use the head tag with theme="ajax" so that the typical ajax header setup will be included in the page.

The tag also includes the option to set a custom datepicker theme if needed. See calendarcss parameter for description for details.

If you use the ajax theme you can turn a debug flag on by setting the debug parameter to true.

Examples

 <head>
   <title>My page</title>
   <s:head/>
 </head>

 <head>
   <title>My page</title>
   <s:head theme="ajax" calendarcss="calendar-green"/>
 </head>

 <head>
   <title>My page</title>
   <s:head theme="ajax" debug="true"/>
 </head>

Field Summary
private String | calendarcss
private boolean | debug
private String | encoding
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Head(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateParams()
String | getCalendarcss()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
boolean | isDebug()
void | setCalendarcss(String calendarcss)
void | setDebug(boolean debug)
void | setEncoding(String encoding)
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

calendarcss

private String calendarcss

debug

private boolean debug

encoding

private String encoding
Constructor Detail

Head

public Head(ValueStack stack,
            HttpServletRequest request,
            HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

setEncoding

public void setEncoding(String encoding)

evaluateParams

public void evaluateParams()
Overrides:
evaluateParams in class UIBean

getCalendarcss

public String getCalendarcss()

setCalendarcss

public void setCalendarcss(String calendarcss)

isDebug

public boolean isDebug()

setDebug

public void setDebug(boolean debug)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Hidden (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Hidden

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.Hidden

public class Hidden
extends UIBean

Renders an HTML input element of type hidden, populated by the specified property from the ValueStack.

Examples

 <-- example one -->
 <s:hidden name="foo" />
 <-- example two -->
 <s:hidden name="foo" value="bar" />

 Example One Resulting HTML (if foo evaluates to bar):
 <input type="hidden" name="foo" value="bar" />
 Example Two Resulting HTML (if getBar method of the action returns 'bar')
 <input type="hidden" name="foo" value="bar" />

Field Summary
static String TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Hidden(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected  String getDefaultTemplate()
A contract that requires each concrete UI Tag to specify which template should be used as a default.
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

Hidden

public Hidden(ValueStack stack,
              HttpServletRequest request,
              HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


I18n (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class I18n

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.I18n

public class I18n
extends Component

Gets a resource bundle and place it on the value stack. This allows the text tag to access messages from any bundle, and not just the bundle associated with the current action.

  • name* - the resource bundle's name (eg foo/bar/customBundle)

Example:

 <s:i18n name="myCustomBundle">
    The i18n value for key aaa.bbb.ccc in myCustomBundle is <s:property value="text('aaa.bbb.ccc')" />
 </s:i18n>

 <s:i18n name="some.package.bundle" >
      <s:text name="some.key" />
 </s:i18n>

Field Summary
protected String | name
protected boolean | pushed
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
I18n(ValueStack stack)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setName(String name)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

pushed

protected boolean pushed

name

protected String name
Constructor Detail

I18n

public I18n(ValueStack stack)
Method Detail

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


If (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class If

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.If

public class If
extends Component

Perform basic condition flow. 'If' tag could be used by itself or with 'Else If' Tag and/or single/multiple 'Else' Tag.

  • test* (Boolean) - Logic to determined if body of tag is to be displayed

  <s:if test="%{false}">
      <div>Will Not Be Executed</div>
  </s:if>
  <s:elseif test="%{true}">
      <div>Will Be Executed</div>
  </s:elseif>
  <s:else>
      <div>Will Not Be Executed</div>
  </s:else>

See Also:
Else, ElseIf

Field Summary
(package private) Boolean | answer
static String | ANSWER
(package private) String | test
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
If(ValueStack stack)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setTest(String test)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ANSWER

public static final String ANSWER
See Also:
Constant Field Values

answer

Boolean answer

test

String test
Constructor Detail

If

public If(ValueStack stack)
Method Detail

setTest

public void setTest(String test)

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Include (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Include

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Include

public class Include
extends Component

Include a servlet's output (result of servlet or a JSP page).

Note: Any additional params supplied to the included page are not accessible within the rendered page through the <s:property...> tag!

  • value* (String) - jsp page to be included

Examples

 <-- One: -->
 <s:include value="myJsp.jsp" />

 <-- Two: -->
 <s:include value="myJsp.jsp">
    <s:param name="param1" value="value2" />
    <s:param name="param2" value="value2" />
 </s:include>

 <-- Three: -->
 <s:include value="myJsp.jsp">
    <s:param name="param1">value1</s:param>
    <s:param name="param2">value2<s:param>
 </s:include>

 Example one - do an include myJsp.jsp page
 Example two - do an include to myJsp.jsp page with parameters param1=value1 and param2=value2
 Example three - do an include to myJsp.jsp page with parameters param1=value1 and param2=value2

Nested Class Summary
(package private) static class | Include.PageOutputStream Implementation of ServletOutputStream that stores all data written to it in a temporary buffer accessible from Include.PageOutputStream.getBuffer() .
(package private) static class | Include.PageResponse Simple wrapper to HTTPServletResponse that will allow getWriter() and getResponse() to be called as many times as needed without causing conflicts.
Field Summary
private static Log | _log
private static String | defaultEncoding
private static String | encoding
private static boolean | encodingDefined
private HttpServletRequest | req
private HttpServletResponse | res
protected String | value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Include(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
void | addParameter(String key, Object value) Add's the given key and value to this components own parameter.
boolean | end(Writer writer, String body) Callback for the end tag of this component.
static String | getContextRelativePath(ServletRequest request, String relativePath)
private static String | getEncoding() Get the encoding specified by the property 'struts.i18n.encoding' in struts.properties, or return the default platform encoding if not specified.
static void | include(String aResult, Writer writer, ServletRequest request, HttpServletResponse response)
static void | setDefaultEncoding(String encoding)
void | setValue(String value)
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

encoding

private static String encoding

encodingDefined

private static boolean encodingDefined

value

protected String value

req

private HttpServletRequest req

res

private HttpServletResponse res

defaultEncoding

private static String defaultEncoding
Constructor Detail

Include

public Include(ValueStack stack,
               HttpServletRequest req,
               HttpServletResponse res)
Method Detail

setDefaultEncoding

public static void setDefaultEncoding(String encoding)

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setValue

public void setValue(String value)

getContextRelativePath

public static String getContextRelativePath(ServletRequest request,
                                            String relativePath)

addParameter

public void addParameter(String key,
                         Object value)
Description copied from class: Component
Add's the given key and value to this components own parameter.

If the provided key is null nothing happends. If the provided value is null any existing parameter with the given key name is removed.

Overrides:
addParameter in class Component
Parameters:
key - the key of the new parameter to add.
value - the value assoicated with the key.

include

public static void include(String aResult,
                           Writer writer,
                           ServletRequest request,
                           HttpServletResponse response)
                    throws ServletException,
                           IOException
Throws:
ServletException
IOException

getEncoding

private static String getEncoding()
Get the encoding specified by the property 'struts.i18n.encoding' in struts.properties, or return the default platform encoding if not specified.

Note that if the property is not initially defined, this will return the system default, even if the property is later defined. This is mainly for performance reasons. Undefined properties throw exceptions, which are a costly operation.

If the property is initially defined, it is read every time, until is is undefined, and then the system default is used.

Why not cache it completely? Some applications will wish to be able to dynamically set the encoding at runtime.

Returns:
The encoding to be used.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Include.PageOutputStream (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Include.PageOutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  javax.servlet.ServletOutputStream
            extended by  org.apache.struts2.components.Include.PageOutputStream
All Implemented Interfaces:
Closeable, Flushable
Enclosing class:
Include
static final class Include.PageOutputStream
extends ServletOutputStream

Implementation of ServletOutputStream that stores all data written to it in a temporary buffer accessible from getBuffer() .

Author:
Joe Walnes, Scott Farquhar

Field Summary
private  FastByteArrayOutputStream buffer
Constructor Summary
Include.PageOutputStream()
Method Summary
void | close()
void | flush()
FastByteArrayOutputStream | getBuffer() Return all data that has been written to this OutputStream.
void | write(byte[] b)
void | write(byte[] b, int o, int l)
void | write(int i)
Methods inherited from class javax.servlet.ServletOutputStream
print, print, print, print, print, print, print, println, println, println, println, println, println, println, println
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

buffer

private FastByteArrayOutputStream buffer
Constructor Detail

Include.PageOutputStream

public Include.PageOutputStream()
Method Detail

getBuffer

public FastByteArrayOutputStream getBuffer()
                                    throws IOException
Return all data that has been written to this OutputStream.

Throws:
IOException

close

public void close()
           throws IOException
Specified by:
close in interface Closeable
Overrides:
close in class OutputStream
Throws:
IOException

flush

public void flush()
           throws IOException
Specified by:
flush in interface Flushable
Overrides:
flush in class OutputStream
Throws:
IOException

write

public void write(byte[] b,
                  int o,
                  int l)
           throws IOException
Overrides:
write in class OutputStream
Throws:
IOException

write

public void write(int i)
           throws IOException
Specified by:
write in class OutputStream
Throws:
IOException

write

public void write(byte[] b)
           throws IOException
Overrides:
write in class OutputStream
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Include.PageResponse (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Include.PageResponse

java.lang.Object
    extended by  javax.servlet.ServletResponseWrapper
        extended by  javax.servlet.http.HttpServletResponseWrapper
            extended by  org.apache.struts2.components.Include.PageResponse
All Implemented Interfaces:
HttpServletResponse, ServletResponse
Enclosing class:
Include
static final class Include.PageResponse
extends HttpServletResponseWrapper

Simple wrapper to HTTPServletResponse that will allow getWriter() and getResponse() to be called as many times as needed without causing conflicts.

The underlying outputStream is a wrapper around Include.PageOutputStream which will store the written content to a buffer.

This buffer can later be retrieved by calling getContent().

Author:
Joe Walnes, Scott Farquhar

Field Summary
protected ServletOutputStream | outputStream
private Include.PageOutputStream | pageOutputStream
protected PrintWriter | pagePrintWriter
Fields inherited from interface javax.servlet.http.HttpServletResponse
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_FOUND, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
Constructor Summary
Include.PageResponse(HttpServletResponse response)
Create PageResponse wrapped around an existing HttpServletResponse.
Method Summary
FastByteArrayOutputStream | getContent() Return the content buffered inside the Include.PageOutputStream.
ServletOutputStream | getOutputStream() Return instance of Include.PageOutputStream allowing all data written to stream to be stored in temporary buffer.
PrintWriter | getWriter() Return PrintWriter wrapper around PageOutputStream.
Methods inherited from class javax.servlet.http.HttpServletResponseWrapper
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus
Methods inherited from class javax.servlet.ServletResponseWrapper
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getResponse, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale, setResponse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.ServletResponse
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale

Field Detail

pagePrintWriter

protected PrintWriter pagePrintWriter

outputStream

protected ServletOutputStream outputStream

pageOutputStream

private Include.PageOutputStream pageOutputStream
Constructor Detail

Include.PageResponse

public Include.PageResponse(HttpServletResponse response)
Create PageResponse wrapped around an existing HttpServletResponse.

Method Detail

getContent

public FastByteArrayOutputStream getContent()
                                     throws IOException
Return the content buffered inside the Include.PageOutputStream.

Returns:
Throws:
IOException

getOutputStream

public ServletOutputStream getOutputStream()
                                    throws IOException
Return instance of Include.PageOutputStream allowing all data written to stream to be stored in temporary buffer.

Specified by:
getOutputStream in interface ServletResponse
Overrides:
getOutputStream in class ServletResponseWrapper
Throws:
IOException

getWriter

public PrintWriter getWriter()
                      throws IOException
Return PrintWriter wrapper around PageOutputStream.

Specified by:
getWriter in interface ServletResponse
Overrides:
getWriter in class ServletResponseWrapper
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InputTransferSelect (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class InputTransferSelect

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
                extended by  org.apache.struts2.components.InputTransferSelect

public class InputTransferSelect
extends ListUIBean

Create a input transfer select component which is basically an text input and <select ...> tag with buttons in the middle of them allowing text to be added to the transfer select. Will auto-select all its elements upon its containing form submision.

NOTE: The id and doubleId need not be supplied as they will generated provided that the inputtransferselect tag is being used in a form tag. The generated id and doubleId will be <form_id>_<inputtransferselect_doubleName> and <form_id>_<inputtransferselect_doubleName> respectively.

 <-- minimum configuration -->
 <s:inputtransferselect
      label="Favourite Cartoons Characters"
      name="cartoons"
      list="{'Popeye', 'He-Man', 'Spiderman'}"
  />

Field Summary
private static Log | _log
protected String | addLabel
protected String | allowRemoveAll
protected String | allowUpDown
protected String | buttonCssClass
protected String | buttonCssStyle
protected String | downLabel
protected String | headerKey
protected String | headerValue
protected String | leftTitle
protected String | multiple
protected String | removeAllLabel
protected String | removeLabel
protected String | rightTitle
protected String | size
private static String | TEMPLATE
protected String | upLabel
Fields inherited from class org.apache.struts2.components.ListUIBean
list, listKey, listValue, throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
InputTransferSelect(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
String | getAddLabel()
String | getAllowRemoveAll()
String | getAllowUpDown()
String | getButtonCssClass()
String | getButtonCssStyle()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
String | getDownLabel()
String | getHeaderKey()
String | getHeaderValue()
String | getLeftTitle()
String | getMultiple()
String | getRemoveAllLabel()
String | getRemoveLabel()
String | getRightTitle()
String | getSize()
String | getUpLabel()
void | setAddLabel(String addLabel)
void | setAllowRemoveAll(String allowRemoveAll)
void | setAllowUpDown(String allowUpDown)
void | setButtonCssClass(String buttonCssClass)
void | setButtonCssStyle(String buttonCssStyle)
void | setDownLabel(String downLabel)
void | setHeaderKey(String headerKey)
void | setHeaderValue(String headerValue)
void | setLeftTitle(String leftTitle)
void | setMultiple(String multiple)
void | setRemoveAllLabel(String removeAllLabel)
void | setRemoveLabel(String removeLabel)
void | setRightTitle(String rightTitle)
void | setSize(String size)
void | setUpLabel(String upLabel)
Methods inherited from class org.apache.struts2.components.ListUIBean
contains, getValueClassType, setList, setListKey, setListValue, setThrowExceptionOnNullValueAttribute
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

TEMPLATE

private static final String TEMPLATE
See Also:
Constant Field Values

size

protected String size

multiple

protected String multiple

allowRemoveAll

protected String allowRemoveAll

allowUpDown

protected String allowUpDown

leftTitle

protected String leftTitle

rightTitle

protected String rightTitle

buttonCssClass

protected String buttonCssClass

buttonCssStyle

protected String buttonCssStyle

addLabel

protected String addLabel

removeLabel

protected String removeLabel

removeAllLabel

protected String removeAllLabel

upLabel

protected String upLabel

downLabel

protected String downLabel

headerKey

protected String headerKey

headerValue

protected String headerValue
Constructor Detail

InputTransferSelect

public InputTransferSelect(ValueStack stack,
                           HttpServletRequest request,
                           HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class ListUIBean

getSize

public String getSize()

setSize

public void setSize(String size)

getMultiple

public String getMultiple()

setMultiple

public void setMultiple(String multiple)

getAllowRemoveAll

public String getAllowRemoveAll()

setAllowRemoveAll

public void setAllowRemoveAll(String allowRemoveAll)

getAllowUpDown

public String getAllowUpDown()

setAllowUpDown

public void setAllowUpDown(String allowUpDown)

getLeftTitle

public String getLeftTitle()

setLeftTitle

public void setLeftTitle(String leftTitle)

getRightTitle

public String getRightTitle()

setRightTitle

public void setRightTitle(String rightTitle)

getButtonCssClass

public String getButtonCssClass()

setButtonCssClass

public void setButtonCssClass(String buttonCssClass)

getButtonCssStyle

public String getButtonCssStyle()

setButtonCssStyle

public void setButtonCssStyle(String buttonCssStyle)

getAddLabel

public String getAddLabel()

setAddLabel

public void setAddLabel(String addLabel)

getRemoveLabel

public String getRemoveLabel()

setRemoveLabel

public void setRemoveLabel(String removeLabel)

getRemoveAllLabel

public String getRemoveAllLabel()

setRemoveAllLabel

public void setRemoveAllLabel(String removeAllLabel)

getUpLabel

public String getUpLabel()

setUpLabel

public void setUpLabel(String upLabel)

getDownLabel

public String getDownLabel()

setDownLabel

public void setDownLabel(String downLabel)

getHeaderKey

public String getHeaderKey()

setHeaderKey

public void setHeaderKey(String headerKey)

getHeaderValue

public String getHeaderValue()

setHeaderValue

public void setHeaderValue(String headerValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorComponent (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class IteratorComponent

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.IteratorComponent

public class IteratorComponent
extends Component

Iterator will iterate over a value. An iterable value can be either of: java.util.Collection, java.util.Iterator, java.util.Enumeration, java.util.Map, array.

  • status (String) - if specified, an instanceof IteratorStatus will be pushed into stack upon each iteration
  • value (Object) - the source to iterate over, must be iteratable, else an the object itself will be put into a newly created List (see MakeIterator#convert(Object)
  • id (String) - if specified the current iteration object will be place with this id in Struts stack's context scope

The following example retrieves the value of the getDays() method of the current object on the value stack and uses it to iterate over. The <s:property/> tag prints out the current value of the iterator.

 <s:iterator value="days">
   <p>day is: <s:property/></p>
 </s:iterator>

The following example uses a Bean tag and places it into the ActionContext. The iterator tag will retrieve that object from the ActionContext and then calls its getDays() method as above. The status attribute is also used to create a IteratorStatus object, which in this example, its odd() method is used to alternate row colours:

 <s:bean name="org.apache.struts2.example.IteratorExample" id="it">
   <s:param name="day" value="'foo'"/>
   <s:param name="day" value="'bar'"/>
 </s:bean>

 <table border="0" cellspacing="0" cellpadding="1">
 <tr>
   <th>Days of the week</th>
 </tr>

 <s:iterator value="#it.days" status="rowstatus">
   <tr>
     <s:if test="#rowstatus.odd == true">
       <td style="background: grey"><s:property/></td>
     </s:if>
     <s:else>
       <td><s:property/></td>
     </s:else>
   </tr>
 </s:iterator>
 </table>

The next example will further demonstrate the use of the status attribute, using a DAO obtained from the action class through OGNL, iterating over groups and their users (in a security context). The last() method indicates if the current object is the last available in the iteration, and if not, we need to seperate the users using a comma:

  <s:iterator value="groupDao.groups" status="groupStatus">
      <tr class="<s:if test="#groupStatus.odd == true ">odd</s:if><s:else>even</s:else>">
          <td><s:property value="name" /></td>
          <td><s:property value="description" /></td>
          <td>
              <s:iterator value="users" status="userStatus">
                  <s:property value="fullName" /><s:if test="!#userStatus.last">,</s:if>
              </s:iterator>
          </td>
      </tr>
  </s:iterator>

The next example iterates over a an action collection and passes every iterator value to another action. The trick here lies in the use of the '[0]' operator. It takes the current iterator value and passes it on to the edit action. Using the '[0]' operator has the same effect as using >s:property />. (The latter, however, does not work from inside the param tag).

      <s:action name="entries" id="entries"/>
      <s:iterator value="#entries.entries" >
          <s:property value="name" />
          <s:property />
          <s:push value="...">
              <s:action name="edit" id="edit" >
                  <s:param name="entry" value="[0]" />
              </s:action>
          </push>
      </s:iterator>

To simulate a simple loop with iterator tag, the following could be done. It does the loop 5 times.

 <s:iterator status="stat" value="{1,2,3,4,5}" >
    <!-- grab the index (start with 0 ... ) -->
    <s:property value="#stat.index" />

    <!-- grab the top of the stack which should be the -->
    <!-- current iteration value (0, 1, ... 5) -->
    <s:property value="top" />
 </s:iterator>

Field Summary
protected Iterator | iterator
protected Object | oldStatus
protected IteratorStatus | status
protected String | statusAttr
protected IteratorStatus.StatusState | statusState
protected String | value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
IteratorComponent(ValueStack stack)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setStatus(String status)
void | setValue(String value)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

iterator

protected Iterator iterator

status

protected IteratorStatus status

oldStatus

protected Object oldStatus

statusState

protected IteratorStatus.StatusState statusState

statusAttr

protected String statusAttr

value

protected String value
Constructor Detail

IteratorComponent

public IteratorComponent(ValueStack stack)
Method Detail

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setStatus

public void setStatus(String status)

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Label (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Label

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.Label

public class Label
extends UIBean

Renders an HTML LABEL that will allow you to output label:name combination that has the same format treatment as the rest of your UI controls.

Examples

In this example, a label is rendered. The label is retrieved from a ResourceBundle via the key attribute giving you an output of 'User Name: Ford.Prefect'. Assuming that i18n message userName corresponds to 'User Name' and the action's getUserName() method returns 'Ford.Prefect'

 <s:label key="userName" />

 <s:label name="userName" label="User Name" />

Field Summary
protected String | forAttr
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Label(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected void | evaluateExtraParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setFor(String forAttr)
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

forAttr

protected String forAttr
Constructor Detail

Label

public Label(ValueStack stack,
             HttpServletRequest request,
             HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

protected void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

setFor

public void setFor(String forAttr)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListUIBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class ListUIBean

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
Direct Known Subclasses:
CheckboxList, DoubleListUIBean, InputTransferSelect, Radio, Select
public abstract class ListUIBean
extends UIBean

DoubleListUIBean is the standard superclass of all Struts list handling components.

Note that the listkey and listvalue attribute will default to "key" and "value" respectively only when the list attribute is evaluated to a Map or its decendant. Other thing else, will result in listkey and listvalue to be null and not used.

Field Summary
protected Object | list
protected String | listKey
protected String | listValue
protected boolean | throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
protected ListUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
boolean | contains(Object obj1, Object obj2)
void | evaluateExtraParams()
protected Class | getValueClassType()
void | setList(Object list)
void | setListKey(String listKey)
void | setListValue(String listValue)
void | setThrowExceptionOnNullValueAttribute(boolean throwExceptionOnNullValueAttribute)
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getDefaultTemplate, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

list

protected Object list

listKey

protected String listKey

listValue

protected String listValue

throwExceptionOnNullValueAttribute

protected boolean throwExceptionOnNullValueAttribute
Constructor Detail

ListUIBean

protected ListUIBean(ValueStack stack,
                     HttpServletRequest request,
                     HttpServletResponse response)
Method Detail

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

contains

public boolean contains(Object obj1,
                        Object obj2)

getValueClassType

protected Class getValueClassType()
Overrides:
getValueClassType in class UIBean

setList

public void setList(Object list)

setListKey

public void setListKey(String listKey)

setListValue

public void setListValue(String listValue)

setThrowExceptionOnNullValueAttribute

public void setThrowExceptionOnNullValueAttribute(boolean throwExceptionOnNullValueAttribute)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MergeIterator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class MergeIterator

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.MergeIterator
All Implemented Interfaces:
Param.UnnamedParametric
public class MergeIterator
extends Component
implements Param.UnnamedParametric

Component for MergeIteratorTag, which job is to merge iterators and successive call to the merged iterator will cause each merge iterator to have a chance to expose its element, subsequently next call will allow the next iterator to expose its element. Once the last iterator is done exposing its element, the first iterator is allowed to do so again (unless it is exhausted of entries).

Internally the task are delegated to MergeIteratorFilter

Example if there are 3 lists being merged, each list have 3 entries, the following will be the logic.

  1. Display first element of the first list
  2. Display first element of the second list
  3. Display first element of the third list
  4. Display second element of the first list
  5. Display second element of the second list
  6. Display second element of the third list
  7. Display third element of the first list
  8. Display thrid element of the second list
  9. Display third element of the thrid list
  • id (String) - the id where the resultant merged iterator will be stored in the stack's context
public class MergeIteratorTagAction extends ActionSupport { private List myList1; private List myList2; private List myList3; public List getMyList1() { return myList1; } public List getMyList2() { return myList2; } public List getMyList3() { return myList3; } public String execute() throws Exception { myList1 = new ArrayList(); myList1.add("1"); myList1.add("2"); myList1.add("3"); myList2 = new ArrayList(); myList2.add("a"); myList2.add("b"); myList2.add("c"); myList3 = new ArrayList(); myList3.add("A"); myList3.add("B"); myList3.add("C"); return "done"; } } <s:merge id="myMergedIterator1"> <s:param value="%{myList1}" /> <s:param value="%{myList2}" /> <s:param value="%{myList3}" /> </s:merge> <s:iterator value="%{#myMergedIterator1}"> <s:property /> </s:iterator> This wil generate "1aA2bB3cC".

See Also:
MergeIteratorFilter, MergeIteratorTag

Field Summary
private static Log | _log
private List | _parameters
private MergeIteratorFilter | mergeIteratorFilter
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
MergeIterator(ValueStack stack)
Method Summary
void | addParameter(Object value) Adds the given value as a parameter to the outer tag.
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setId(String id)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

mergeIteratorFilter

private MergeIteratorFilter mergeIteratorFilter

_parameters

private List _parameters
Constructor Detail

MergeIterator

public MergeIterator(ValueStack stack)
Method Detail

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setId

public void setId(String id)
Overrides:
setId in class Component

addParameter

public void addParameter(Object value)
Description copied from interface: Param.UnnamedParametric
Adds the given value as a parameter to the outer tag.

Specified by:
addParameter in interface Param.UnnamedParametric
Parameters:
value - the value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptGroup (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class OptGroup

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.OptGroup

public class OptGroup
extends Component

Create a optgroup component which needs to resides within a select tag.

This component is to be used within a Select component.

 <s:select label="My Selection"
            name="mySelection"
            value="%{'POPEYE'}"
            list="%{#{'SUPERMAN':'Superman', 'SPIDERMAN':'spiderman'}}">
    <s:optgroup label="Adult"
                 list="%{#{'SOUTH_PARK':'South Park'}}" />
    <s:optgroup label="Japanese"
                 list="%{#{'POKEMON':'pokemon','DIGIMON':'digimon','SAILORMOON':'Sailormoon'}}" />
 </s:select>

Field Summary
private static Log | _log
static String | INTERNAL_LIST_UI_BEAN_LIST_PARAMETER_KEY
protected ListUIBean | internalUiBean
protected HttpServletRequest | req
protected HttpServletResponse | res
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
OptGroup(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setContainer(Container container)
void | setDisabled(String disabled)
void | setLabel(String label)
void | setList(String list)
void | setListKey(String listKey)
void | setListValue(String listValue)
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INTERNAL_LIST_UI_BEAN_LIST_PARAMETER_KEY

public static final String INTERNAL_LIST_UI_BEAN_LIST_PARAMETER_KEY
See Also:
Constant Field Values

_log

private static Log _log

req

protected HttpServletRequest req

res

protected HttpServletResponse res

internalUiBean

protected ListUIBean internalUiBean
Constructor Detail

OptGroup

public OptGroup(ValueStack stack,
                HttpServletRequest req,
                HttpServletResponse res)
Method Detail

setContainer

public void setContainer(Container container)

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setLabel

public void setLabel(String label)

setDisabled

public void setDisabled(String disabled)

setList

public void setList(String list)

setListKey

public void setListKey(String listKey)

setListValue

public void setListValue(String listValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptionTransferSelect (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class OptionTransferSelect

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
                extended by  org.apache.struts2.components.DoubleListUIBean
                    extended by  org.apache.struts2.components.OptionTransferSelect

public class OptionTransferSelect
extends DoubleListUIBean

Create a option transfer select component which is basically two <select ...> tag with buttons in the middle of them allowing options in each of the <select ...> to be moved between themselves. Will auto-select all its elements upon its containing form submision.

NOTE: The id and doubleId need not be supplied as they will generated provided that the optiontransferselect tag is being used in a form tag. The generated id and doubleId will be <form_id>_<optiontransferselect_doubleName> and <form_id>_<optiontransferselect_doubleName> respectively.

 <-- minimum configuration -->
 <s:optiontransferselect
      label="Favourite Cartoons Characters"
      name="leftSideCartoonCharacters"
      list="{'Popeye', 'He-Man', 'Spiderman'}"
      doubleName="rightSideCartoonCharacters"
      doubleList="{'Superman', 'Mickey Mouse', 'Donald Duck'}"
  />

  <-- possible configuration -->
  <s:optiontransferselect
      label="Favourite Cartoons Characters"
      name="leftSideCartoonCharacters"
      leftTitle="Left Title"
      rightTitle="Right Title"
      list="{'Popeye', 'He-Man', 'Spiderman'}"
      multiple="true"
      headerKey="headerKey"
      headerValue="--- Please Select ---"
      emptyOption="true"
      doubleList="{'Superman', 'Mickey Mouse', 'Donald Duck'}"
      doubleName="rightSideCartoonCharacters"
      doubleHeaderKey="doubleHeaderKey"
      doubleHeaderValue="--- Please Select ---"
      doubleEmptyOption="true"
      doubleMultiple="true"
  />

Field Summary
private static Log | _log
protected String | addAllToLeftLabel
protected String | addAllToRightLabel
protected String | addToLeftLabel
protected String | addToRightLabel
protected String | allowAddAllToLeft
protected String | allowAddAllToRight
protected String | allowAddToLeft
protected String | allowAddToRight
protected String | allowSelectAll
protected String | allowUpDownOnLeft
protected String | allowUpDownOnRight
protected String | buttonCssClass
protected String | buttonCssStyle
protected String | leftDownlabel
protected String | leftTitle
protected String | leftUpLabel
protected String | rightDownLabel
protected String | rightTitle
protected String | rightUpLabel
protected String | selectAllLabel
private static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.DoubleListUIBean
doubleAccesskey, doubleCssClass, doubleCssStyle, doubleDisabled, doubleEmptyOption, doubleHeaderKey, doubleHeaderValue, doubleId, doubleList, doubleListKey, doubleListValue, doubleMultiple, doubleName, doubleOnblur, doubleOnchange, doubleOnclick, doubleOndblclick, doubleOnfocus, doubleOnkeydown, doubleOnkeypress, doubleOnkeyup, doubleOnmousedown, doubleOnmousemove, doubleOnmouseout, doubleOnmouseover, doubleOnmouseup, doubleOnselect, doubleSize, doubleValue, emptyOption, formName, headerKey, headerValue, multiple, size
Fields inherited from class org.apache.struts2.components.ListUIBean
list, listKey, listValue, throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
OptionTransferSelect(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
String | getAddAllToLeftLabel()
String | getAddAllToRightLabel()
String | getAddToLeftLabel()
String | getAddToRightLabel()
String | getAllowAddAllToLeft()
String | getAllowAddAllToRight()
String | getAllowAddToLeft()
String | getAllowAddToRight()
String | getAllowSelectAll()
String | getAllowUpDownOnLeft()
String | getAllowUpDownOnRight()
String | getButtonCssClass()
String | getButtonCssStyle()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
String | getLeftDownLabel()
String | getLeftTitle()
String | getLeftUpLabel()
String | getRightDownLabel()
String | getRightTitle()
String | getRightUpLabel()
String | getSelectAllLabel()
void | setAddAllToLeftLabel(String addAllToLeftLabel)
void | setAddAllToRightLabel(String addAllToRightLabel)
void | setAddToLeftLabel(String addToLeftLabel)
void | setAddToRightLabel(String addToRightLabel)
void | setAllowAddAllToLeft(String allowAddAllToLeft)
void | setAllowAddAllToRight(String allowAddAllToRight)
void | setAllowAddToLeft(String allowAddToLeft)
void | setAllowAddToRight(String allowAddToRight)
void | setAllowSelectAll(String allowSelectAll)
void | setAllowUpDownOnLeft(String allowUpDownOnLeft)
void | setAllowUpDownOnRight(String allowUpDownOnRight)
void | setButtonCssClass(String buttonCssClass)
void | setButtonCssStyle(String buttonCssStyle)
void | setLeftDownLabel(String leftDownLabel)
void | setLeftTitle(String leftTitle)
void | setLeftUpLabel(String leftUpLabel)
void | setRightDownLabel(String rightDownlabel)
void | setRightTitle(String rightTitle)
void | setRightUpLabel(String rightUpLabel)
void | setSelectAllLabel(String selectAllLabel)
Methods inherited from class org.apache.struts2.components.DoubleListUIBean
getDoubleCssClass, getDoubleCssStyle, getDoubleDisabled, getDoubleEmptyOption, getDoubleHeaderKey, getDoubleHeaderValue, getDoubleId, getDoubleList, getDoubleListKey, getDoubleListValue, getDoubleMultiple, getDoubleName, getDoubleOnblur, getDoubleOnchange, getDoubleOnclick, getDoubleOndblclick, getDoubleOnfocus, getDoubleOnkeydown, getDoubleOnkeypress, getDoubleOnkeyup, getDoubleOnmousedown, getDoubleOnmousemove, getDoubleOnmouseout, getDoubleOnmouseover, getDoubleOnmouseup, getDoubleOnselect, getDoubleSize, getDoubleValue, getFormName, setDoubleAccesskey, setDoubleCssClass, setDoubleCssStyle, setDoubleDisabled, setDoubleEmptyOption, setDoubleHeaderKey, setDoubleHeaderValue, setDoubleId, setDoubleList, setDoubleListKey, setDoubleListValue, setDoubleMultiple, setDoubleName, setDoubleOnblur, setDoubleOnchange, setDoubleOnclick, setDoubleOndblclick, setDoubleOnfocus, setDoubleOnkeydown, setDoubleOnkeypress, setDoubleOnkeyup, setDoubleOnmousedown, setDoubleOnmousemove, setDoubleOnmouseout, setDoubleOnmouseover, setDoubleOnmouseup, setDoubleOnselect, setDoubleSize, setDoubleValue, setEmptyOption, setFormName, setHeaderKey, setHeaderValue, setMultiple, setSize
Methods inherited from class org.apache.struts2.components.ListUIBean
contains, getValueClassType, setList, setListKey, setListValue, setThrowExceptionOnNullValueAttribute
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

TEMPLATE

private static final String TEMPLATE
See Also:
Constant Field Values

allowAddToLeft

protected String allowAddToLeft

allowAddToRight

protected String allowAddToRight

allowAddAllToLeft

protected String allowAddAllToLeft

allowAddAllToRight

protected String allowAddAllToRight

allowSelectAll

protected String allowSelectAll

allowUpDownOnLeft

protected String allowUpDownOnLeft

allowUpDownOnRight

protected String allowUpDownOnRight

leftTitle

protected String leftTitle

rightTitle

protected String rightTitle

buttonCssClass

protected String buttonCssClass

buttonCssStyle

protected String buttonCssStyle

addToLeftLabel

protected String addToLeftLabel

addToRightLabel

protected String addToRightLabel

addAllToLeftLabel

protected String addAllToLeftLabel

addAllToRightLabel

protected String addAllToRightLabel

selectAllLabel

protected String selectAllLabel

leftUpLabel

protected String leftUpLabel

leftDownlabel

protected String leftDownlabel

rightUpLabel

protected String rightUpLabel

rightDownLabel

protected String rightDownLabel
Constructor Detail

OptionTransferSelect

public OptionTransferSelect(ValueStack stack,
                            HttpServletRequest request,
                            HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class DoubleListUIBean

getAddAllToLeftLabel

public String getAddAllToLeftLabel()

setAddAllToLeftLabel

public void setAddAllToLeftLabel(String addAllToLeftLabel)

getAddAllToRightLabel

public String getAddAllToRightLabel()

setAddAllToRightLabel

public void setAddAllToRightLabel(String addAllToRightLabel)

getAddToLeftLabel

public String getAddToLeftLabel()

setAddToLeftLabel

public void setAddToLeftLabel(String addToLeftLabel)

getAddToRightLabel

public String getAddToRightLabel()

setAddToRightLabel

public void setAddToRightLabel(String addToRightLabel)

getAllowAddAllToLeft

public String getAllowAddAllToLeft()

setAllowAddAllToLeft

public void setAllowAddAllToLeft(String allowAddAllToLeft)

getAllowAddAllToRight

public String getAllowAddAllToRight()

setAllowAddAllToRight

public void setAllowAddAllToRight(String allowAddAllToRight)

getAllowAddToLeft

public String getAllowAddToLeft()

setAllowAddToLeft

public void setAllowAddToLeft(String allowAddToLeft)

getAllowAddToRight

public String getAllowAddToRight()

setAllowAddToRight

public void setAllowAddToRight(String allowAddToRight)

getLeftTitle

public String getLeftTitle()

setAllowUpDownOnLeft

public void setAllowUpDownOnLeft(String allowUpDownOnLeft)

getAllowUpDownOnLeft

public String getAllowUpDownOnLeft()

setAllowUpDownOnRight

public void setAllowUpDownOnRight(String allowUpDownOnRight)

getAllowUpDownOnRight

public String getAllowUpDownOnRight()

setLeftTitle

public void setLeftTitle(String leftTitle)

getRightTitle

public String getRightTitle()

setRightTitle

public void setRightTitle(String rightTitle)

setAllowSelectAll

public void setAllowSelectAll(String allowSelectAll)

getAllowSelectAll

public String getAllowSelectAll()

setSelectAllLabel

public void setSelectAllLabel(String selectAllLabel)

getSelectAllLabel

public String getSelectAllLabel()

setButtonCssClass

public void setButtonCssClass(String buttonCssClass)

getButtonCssClass

public String getButtonCssClass()

setButtonCssStyle

public void setButtonCssStyle(String buttonCssStyle)

getButtonCssStyle

public String getButtonCssStyle()

setLeftUpLabel

public void setLeftUpLabel(String leftUpLabel)

getLeftUpLabel

public String getLeftUpLabel()

setLeftDownLabel

public void setLeftDownLabel(String leftDownLabel)

getLeftDownLabel

public String getLeftDownLabel()

setRightUpLabel

public void setRightUpLabel(String rightUpLabel)

getRightUpLabel

public String getRightUpLabel()

setRightDownLabel

public void setRightDownLabel(String rightDownlabel)

getRightDownLabel

public String getRightDownLabel()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Param (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Param

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Param

public class Param
extends Component

This tag can be used to parameterize other tags.

The include tag and bean tag are examples of such tags.

The parameters can be added with or without a name as key. If the tag provides a name attribute the parameters are added using the addParamter method. For unnamed parameters the Tag must implement the Param.UnnamedParametric interface defined in this class (e.g. The TextTag does this).

This tag has the following two paramters.

  • name (String) - the name of the parameter
  • value (Object) - the value of the parameter

Note: When you declare the param tag, the value can be defined in either a value attribute or as text between the start and end tag. Struts behaves a bit different according to these two situations. This is best illustrated using an example:
<param name="color">blue</param> <-- (A) -->
<param name="color" value="blue"/> <-- (B) -->
In the first situation (A) the value would be evaluated to the stack as a java.lang.String object. And in situation (B) the value would be evaluated to the stack as a java.lang.Object object.
For more information see WW-808.

Examples

 <ui:component>
  <ui:param name="key"     value="[0]"/>
  <ui:param name="value"   value="[1]"/>
  <ui:param name="context" value="[2]"/>
 </ui:component>

where the key will be the identifier and the value the result of an OGNL expression run against the current ValueStack.

This second example demonstrates how the text tag can use parameters from this param tag.

 <s:text name="cart.total.cost">
     <s:param value="#session.cartTotal"/>
 </s:text>

See Also:
Include, Bean, Text

Nested Class Summary
static interface Param.UnnamedParametric
Tags can implement this to support nested param tags without the name attribute.
Field Summary
protected String | name
protected String | value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Param(ValueStack stack)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setName(String name)
void | setValue(String value)
boolean | usesBody() Overwrite to set if body shold be used.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

protected String name

value

protected String value
Constructor Detail

Param

public Param(ValueStack stack)
Method Detail

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

usesBody

public boolean usesBody()
Description copied from class: Component
Overwrite to set if body shold be used.

Overrides:
usesBody in class Component
Returns:
always false for this component.

setName

public void setName(String name)

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Param.UnnamedParametric (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Interface Param.UnnamedParametric

All Known Implementing Classes:
AppendIterator, FieldError, MergeIterator, Text
Enclosing class:
Param
public static interface Param.UnnamedParametric

Tags can implement this to support nested param tags without the name attribute.

The TextTag uses this approach. For unnamed parameters an example is given in the class javadoc for ParamTag.

Method Summary
 void addParameter(Object value)
Adds the given value as a parameter to the outer tag.

Method Detail

addParameter

void addParameter(Object value)
Adds the given value as a parameter to the outer tag.

Parameters:
value - the value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Password (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Password

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.TextField
                extended by  org.apache.struts2.components.Password

public class Password
extends TextField

Render an HTML input tag of type password.

Examples

In this example, a password control is displayed. For the label, we are calling ActionSupport's getText() to retrieve password label from a resource bundle.

 <s:password label="%{text('password')}" name="password" size="10" maxlength="15" />

Field Summary
protected String | showPassword
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.TextField
maxlength, readonly, size
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Password(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setShowPassword(String showPassword)
Methods inherited from class org.apache.struts2.components.TextField
setMaxlength, setMaxLength, setReadonly, setSize
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

showPassword

protected String showPassword
Constructor Detail

Password

public Password(ValueStack stack,
                HttpServletRequest request,
                HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Overrides:
getDefaultTemplate in class TextField
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class TextField

setShowPassword

public void setShowPassword(String showPassword)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Property (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Property

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Property

public class Property
extends Component

Used to get the property of a value, which will default to the top of the stack if none is specified.

  • default (String) - The default value to be used if value attribute is null
  • escape (Boolean) - Escape HTML. Default to true
  • value (Object) - value to be displayed

     TextUtils

 Example 1 prints the result of myBean's getMyBeanProperty() method.
 Example 2 prints the result of myBean's getMyBeanProperty() method and if it is null, print 'a default value' instead.

 <s:property value="getText('some.key')" />

Field Summary
private String | defaultValue
private boolean | escape
private static Log | LOG
private String | value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Property(ValueStack stack)
Method Summary
private String | prepare(String value)
void | setDefault(String defaultValue)
void | setEscape(boolean escape)
void | setValue(String value)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

defaultValue

private String defaultValue

value

private String value

escape

private boolean escape
Constructor Detail

Property

public Property(ValueStack stack)
Method Detail

setDefault

public void setDefault(String defaultValue)

setEscape

public void setEscape(boolean escape)

setValue

public void setValue(String value)

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

prepare

private String prepare(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Push (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Push

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Push

public class Push
extends Component

Push value on stack for simplified usage.

  • value* (Object) - value to be pushed into the top of the stack

Examples

 <s:push value="user">
     <s:propery value="firstName" />
     <s:propery value="lastName" />
 </s:push>
Pushed user into the stack, and hence property tag could access user's properties (firstName, lastName etc) since user is not at the top of the stack

  <s:push value="myObject">                              ----- (1)
       <s:bean name="jp.SomeBean" id="myBean"/>        ----- (2)
          <s:param name="myParam" value="top"/>        ----- (3)
       </s:bean>
   </s:push>

 when in (1), myObject is at the top of the stack
 when in (2), jp.SomeBean is in the top of stack, also in stack's context with key myBean
 when in (3), top will get the jp.SomeBean instance

 <s:push value="myObject">                                       ---(A)
    <s:bean name="jp.SomeBean" id="myBean"/>                   ---(B)
       <s:param name="myParam" value="top.mySomeOtherValue"/>  ---(C)
    </s:bean>
 </s:push>

 when in (A), myObject is at the top of the stack
 when in (B), jp.SomeBean is at the top of the stack, also in context with key myBean
 when in (C), top refers to jp.SomeBean instance. so top.mySomeOtherValue would invoke SomeBean's mySomeOtherValue() method

 <s:push value="myObject">                                 ---- (i)
    <s:bean name="jp.SomeBean" id="myBean"/>             ---- (ii)
       <s:param name="myParam" value="[1].top"/>         -----(iii)
    </s:bean>
 </s:push>

 when in (i), myObject is at the top of the stack
 when in (ii), jp.SomeBean is at the top of the stack, followed by myObject
 when in (iii), [1].top will returned top of the cut of stack starting from myObject, namely myObject itself

Field Summary
protected boolean | pushed
protected String | value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Push(ValueStack stack)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setValue(String value)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

protected String value

pushed

protected boolean pushed
Constructor Detail

Push

public Push(ValueStack stack)
Method Detail

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Radio (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Radio

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
                extended by  org.apache.struts2.components.Radio

public class Radio
extends ListUIBean

Render a radio button input field.

Examples

In this example, a radio control is displayed with a list of genders. The gender list is built from attribute id=genders. The framework calls getGenders() which will return a Map. For examples using listKey and listValue attributes, see the section select tag. The default selected one will be determined (in this case) by the getMale() method in the action class which should retun a value similar to the key of the getGenters() map if that particular gender is to be selected.

 <s:action name="GenderMap" id="genders"/>
 <s:radio label="Gender" name="male" list="#genders.genders"/>

Field Summary
static String TEMPLATE
Fields inherited from class org.apache.struts2.components.ListUIBean
list, listKey, listValue, throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Radio(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected  String getDefaultTemplate()
A contract that requires each concrete UI Tag to specify which template should be used as a default.
Methods inherited from class org.apache.struts2.components.ListUIBean
contains, evaluateExtraParams, getValueClassType, setList, setListKey, setListValue, setThrowExceptionOnNullValueAttribute
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

Radio

public Radio(ValueStack stack,
             HttpServletRequest request,
             HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Reset (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Reset

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.FormButton
                extended by  org.apache.struts2.components.Reset

public class Reset
extends FormButton

Render a reset button. The reset tag is used together with the form tag to provide form resetting. The reset can have two different types of rendering:

  • input: renders as html <input type="reset"...>
  • button: renders as html <button type="reset"...>
Please note that the button type has advantages by adding the possibility to seperate the submitted value from the text shown on the button face, but has issues with Microsoft Internet Explorer at least up to 6.0

Examples

 <s:reset value="Reset" />

 Render an button reset:
 <s:reset type="button" key="reset"/>

Field Summary
protected String | action
protected String | align
protected String | method
static String | TEMPLATE
protected String | type
Fields inherited from class org.apache.struts2.components.FormButton
BUTTONTYPE_BUTTON, BUTTONTYPE_IMAGE, BUTTONTYPE_INPUT
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Reset(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setLabel(String label)
protected boolean | supportsImageType() Indicate whether the concrete button supports the type "image".
Methods inherited from class org.apache.struts2.components.FormButton
evaluateExtraParams, populateComponentHtmlId, setAction, setAlign, setMethod, setType
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

action

protected String action

method

protected String method

align

protected String align

type

protected String type
Constructor Detail

Reset

public Reset(ValueStack stack,
             HttpServletRequest request,
             HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateParams

public void evaluateParams()
Overrides:
evaluateParams in class UIBean

supportsImageType

protected boolean supportsImageType()
Indicate whether the concrete button supports the type "image".

Specified by:
supportsImageType in class FormButton
Returns:
false to indicate type image is supported.

setLabel

public void setLabel(String label)
Overrides:
setLabel in class UIBean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Select (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Select

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
                extended by  org.apache.struts2.components.Select
Direct Known Subclasses:
UpDownSelect
public class Select
extends ListUIBean

Render an HTML input tag of type select.

Examples

 <s:select label="Pets"
        name="petIds"
        list="petDao.pets"
        listKey="id"
        listValue="name"
        multiple="true"
        size="3"
        required="true"
 />

 <s:select label="Months"
        name="months"
        headerKey="-1" headerValue="Select Month"
        list="#{'01':'Jan', '02':'Feb', [...]}"
        value="selectedMonth"
        required="true"
 />

 // The month id (01, 02, ...) returned by the getSelectedMonth() call
 // against the stack will be auto-selected

Note: For any of the tags that use lists (select probably being the most ubiquitous), which uses the OGNL list notation (see the "months" example above), it should be noted that the map key created (in the months example, the '01', '02', etc.) is typed. '1' is a char, '01' is a String, "1" is a String. This is important since if the value returned by your "value" attribute is NOT the same type as the key in the "list" attribute, they WILL NOT MATCH, even though their String values may be equivalent. If they don't match, nothing in your list will be auto-selected.

Field Summary
protected String | emptyOption
protected String | headerKey
protected String | headerValue
protected String | multiple
protected String | size
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.ListUIBean
list, listKey, listValue, throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Select(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setEmptyOption(String emptyOption)
void | setHeaderKey(String headerKey)
void | setHeaderValue(String headerValue)
void | setMultiple(String multiple)
void | setSize(String size)
Methods inherited from class org.apache.struts2.components.ListUIBean
contains, getValueClassType, setList, setListKey, setListValue, setThrowExceptionOnNullValueAttribute
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

emptyOption

protected String emptyOption

headerKey

protected String headerKey

headerValue

protected String headerValue

multiple

protected String multiple

size

protected String size
Constructor Detail

Select

public Select(ValueStack stack,
              HttpServletRequest request,
              HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class ListUIBean

setEmptyOption

public void setEmptyOption(String emptyOption)

setHeaderKey

public void setHeaderKey(String headerKey)

setHeaderValue

public void setHeaderValue(String headerValue)

setMultiple

public void setMultiple(String multiple)

setSize

public void setSize(String size)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Set (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Set

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Set

public class Set
extends Component

The set tag assigns a value to a variable in a specified scope. It is useful when you wish to assign a variable to a complex expression and then simply reference that variable each time rather than the complex expression. This is useful in both cases: when the complex expression takes time (performance improvement) or is hard to read (code readability improvement).

The scopes available are as follows :-
  • application - the value will be set in application scope according to servlet spec. using the name as its key
  • session - the value will be set in session scope according to servlet spec. using the name as key
  • request - the value will be set in request scope according to servlet spec. using the name as key
  • page - the value will be set in request scope according to servlet sepc. using the name as key
  • action - the value will be set in the request scope and Struts' action context using the name as key
NOTE:

If no scope is specified, it will default to action scope.

Parameters

  • name* (String): The name of the new variable that is assigned the value of value
  • value (Object): The value that is assigned to the variable named name
  • scope (String): The scope in which to assign the variable. Can be application, session, request, page, or action. By default it is action.

Examples

 <s:set name="personName" value="person.name"/>
 Hello, <s:property value="#personName"/>. How are you?

Field Summary
protected String | name
protected String | scope
protected String | value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Set(ValueStack stack)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setName(String name)
void | setScope(String scope)
void | setValue(String value)
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

protected String name

scope

protected String scope

value

protected String value
Constructor Detail

Set

public Set(ValueStack stack)
Method Detail

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setName

public void setName(String name)

setScope

public void setScope(String scope)

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Submit (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Submit

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.FormButton
                extended by  org.apache.struts2.components.Submit
All Implemented Interfaces:
RemoteUICallBean
public class Submit
extends FormButton
implements RemoteUICallBean

Render a submit button. The submit tag is used together with the form tag to provide asynchronous form submissions. The submit can have three different types of rendering:

  • input: renders as html <input type="submit"...>
  • image: renders as html <input type="image"...>
  • button: renders as html <button type="submit"...>
Please note that the button type has advantages by adding the possibility to seperate the submitted value from the text shown on the button face, but has issues with Microsoft Internet Explorer at least up to 6.0

Examples

 <s:submit value="%{'Submit'}" />

 Render an image submit:
 <s:submit type="image" value="%{'Submit'}" label="Submit the form" src="submit.gif"/>

 Render an button submit:
 <s:submit type="button" value="%{'Submit'}" label="Submit the form"/>
THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED
  • href
  • errorText
  • listenTopics
  • notifyTopics
  • executeScripts
  • loadingText
  • listenTopics
  • handler
  • formId
  • formFilter
  • targets
  • showErrorTransportText
  • targets
  • indicator
'resultDivId' Deprecated. Use targets.

'targets' is a list of element ids whose content will be updated with the text returned from request.

'errorText' is the text that will be displayed when there is an error making the request.

'onLoadJS' Deprecated. Use 'notifyTopics'.

'preInvokeJS' Deprecated. Use 'notifyTopics'.

'executeScripts' if set to true will execute javascript sections in the returned text.

'loadingText' is the text that will be displayed on the 'targets' elements while making the request.

'handler' is the name of the function that will take care of making the AJAX request. Dojo's widget and dom node are passed as parameters).

'formId' is the id of the html form whose fields will be seralized and passed as parameters in the request.

'formFilter' is the name of a function which will be used to filter the fields that will be seralized. This function takes as a parameter the element and returns true if the element should be included.

'listenTopics' comma separated list of topics names, that will trigger a request 'indicator' element to be shown while the request executing 'showErrorTransportText': whether errors should be displayed (on 'targets')

'showLoadingText' show loading text on targets

'notifyTopics' comma separated list of topics names, that will be published. Three parameters are passed:

  • data: html or json object when type='load' or type='error'
  • type: 'before' before the request is made, 'load' when the request succeeds, or 'error' when it fails
  • request: request javascript object, when type='load' or type='error'
Show the results in another div. If you want your results to be shown in a div, use the resultDivId where the id is the id of the div you want them shown in. This is an inner HTML approah. Your results get jammed into the div for you. Here is a sample of this approach:

 Remote form replacing another div:
 <div id='two' style="border: 1px solid yellow;">Initial content</div>
 <s:form
       id='theForm2'
       cssStyle="border: 1px solid green;"
       action='/AjaxRemoteForm.action'
       method='post'
       theme="ajax">

   <input type='text' name='data' value='Struts User' />
   <s:submit value="GO2" theme="ajax" resultDivId="two" />

 </s:form >

Field Summary
protected String | afterLoading
protected String | beforeLoading
protected String | errorText
protected String | executeScripts
protected String | formFilter
protected String | formId
protected String | handler
protected String | href
protected String | indicator
protected String | listenTopics
protected String | loadingText
private static Log | LOG
protected String | notifyTopics
protected String | showErrorTransportText
protected String | showLoadingText
protected String | src
protected String | targets
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.FormButton
action, align, BUTTONTYPE_BUTTON, BUTTONTYPE_IMAGE, BUTTONTYPE_INPUT, method, type
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Submit(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
boolean | end(Writer writer, String body) Overrides to be able to render body in a template rather than always before the template
void | evaluateExtraParams()
void | evaluateParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setAfterLoading(String afterLoading)
void | setBeforeLoading(String beforeLoading)
void | setErrorText(String errorText)
void | setExecuteScripts(String executeScripts)
void | setFormFilter(String formFilter)
void | setFormId(String formId)
void | setHandler(String handler)
void | setHref(String href)
void | setIndicator(String indicator)
void | setListenTopics(String listenTopics)
void | setLoadingText(String loadingText)
void | setNotifyTopics(String notifyTopics)
void | setShowErrorTransportText(String showErrorTransportText)
void | setShowLoadingText(String showLoadingText)
void | setSrc(String src)
void | setTargets(String targets)
void | setTheme(String theme)
protected boolean | supportsImageType() Indicate whether the concrete button supports the type "image".
Methods inherited from class org.apache.struts2.components.FormButton
populateComponentHtmlId, setAction, setAlign, setMethod, setType
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, escape, evaluateNameValue, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

href

protected String href

errorText

protected String errorText

executeScripts

protected String executeScripts

loadingText

protected String loadingText

listenTopics

protected String listenTopics

handler

protected String handler

formId

protected String formId

formFilter

protected String formFilter

src

protected String src

notifyTopics

protected String notifyTopics

showErrorTransportText

protected String showErrorTransportText

indicator

protected String indicator

showLoadingText

protected String showLoadingText

beforeLoading

protected String beforeLoading

afterLoading

protected String afterLoading

targets

protected String targets
Constructor Detail

Submit

public Submit(ValueStack stack,
              HttpServletRequest request,
              HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateParams

public void evaluateParams()
Overrides:
evaluateParams in class UIBean

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class FormButton

supportsImageType

protected boolean supportsImageType()
Indicate whether the concrete button supports the type "image".

Specified by:
supportsImageType in class FormButton
Returns:
true to indicate type image is supported.

end

public boolean end(Writer writer,
                   String body)
Overrides to be able to render body in a template rather than always before the template

Overrides:
end in class UIBean
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setListenTopics

public void setListenTopics(String listenTopics)
Specified by:
setListenTopics in interface RemoteUICallBean

setTheme

public void setTheme(String theme)
Overrides:
setTheme in class UIBean

setHref

public void setHref(String href)
Specified by:
setHref in interface RemoteUICallBean

setErrorText

public void setErrorText(String errorText)
Specified by:
setErrorText in interface RemoteUICallBean

setAfterLoading

public void setAfterLoading(String afterLoading)
Specified by:
setAfterLoading in interface RemoteUICallBean

setBeforeLoading

public void setBeforeLoading(String beforeLoading)
Specified by:
setBeforeLoading in interface RemoteUICallBean

setExecuteScripts

public void setExecuteScripts(String executeScripts)
Specified by:
setExecuteScripts in interface RemoteUICallBean

setLoadingText

public void setLoadingText(String loadingText)
Specified by:
setLoadingText in interface RemoteUICallBean

setHandler

public void setHandler(String handler)
Specified by:
setHandler in interface RemoteUICallBean

setFormFilter

public void setFormFilter(String formFilter)
Specified by:
setFormFilter in interface RemoteUICallBean

setFormId

public void setFormId(String formId)
Specified by:
setFormId in interface RemoteUICallBean

setSrc

public void setSrc(String src)

setTargets

public void setTargets(String targets)

setNotifyTopics

public void setNotifyTopics(String notifyTopics)
Specified by:
setNotifyTopics in interface RemoteUICallBean

setShowErrorTransportText

public void setShowErrorTransportText(String showErrorTransportText)
Specified by:
setShowErrorTransportText in interface RemoteUICallBean

setIndicator

public void setIndicator(String indicator)
Specified by:
setIndicator in interface RemoteUICallBean

setShowLoadingText

public void setShowLoadingText(String showLoadingText)
Specified by:
setShowLoadingText in interface RemoteUICallBean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabbedPanel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class TabbedPanel

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ClosingUIBean
                extended by  org.apache.struts2.components.TabbedPanel

public class TabbedPanel
extends ClosingUIBean

The tabbedpanel widget is primarily an AJAX component, where each tab can either be local content or remote content (refreshed each time the user selects that tab).

Examples

The following is an example of a tabbedpanel and panel tag utilizing local and remote content.

 <s:tabbedPanel id="test" >
    <s:div id="one" label="one" theme="ajax" labelposition="top" >
        This is the first pane<br/>
        <s:form>
            <s:textfield name="tt" label="Test Text"/>  <br/>
            <s:textfield name="tt2" label="Test Text2"/>
        </s:form>
    </s:div>
    <s:div id="three" label="remote" theme="ajax" href="/AjaxTest.action" >
        This is the remote tab
    </s:div>
 </s:tabbedPanel>

Field Summary
protected String | closeButton
private static String | COMPONENT_NAME
protected String | doLayout
protected String | selectedTab
static String | TEMPLATE
static String | TEMPLATE_CLOSE
protected String | templateCssPath
Fields inherited from class org.apache.struts2.components.ClosingUIBean
openTemplate
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
TabbedPanel(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected void | evaluateExtraParams()
String | getComponentName()
String | getDefaultOpenTemplate()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setCloseButton(String closeButton)
void | setDoLayout(String doLayout)
void | setId(String id)
void | setSelectedTab(String selectedTab)
void | setTemplateCssPath(String templateCssPath)
Methods inherited from class org.apache.struts2.components.ClosingUIBean
setOpenTemplate, start
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

TEMPLATE_CLOSE

public static final String TEMPLATE_CLOSE
See Also:
Constant Field Values

COMPONENT_NAME

private static final String COMPONENT_NAME

selectedTab

protected String selectedTab

closeButton

protected String closeButton

doLayout

protected String doLayout

templateCssPath

protected String templateCssPath
Constructor Detail

TabbedPanel

public TabbedPanel(ValueStack stack,
                   HttpServletRequest request,
                   HttpServletResponse response)
Method Detail

evaluateExtraParams

protected void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

getDefaultOpenTemplate

public String getDefaultOpenTemplate()
Specified by:
getDefaultOpenTemplate in class ClosingUIBean

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

getComponentName

public String getComponentName()

setId

public void setId(String id)
Overrides:
setId in class Component

setSelectedTab

public void setSelectedTab(String selectedTab)

setCloseButton

public void setCloseButton(String closeButton)

setDoLayout

public void setDoLayout(String doLayout)

setTemplateCssPath

public void setTemplateCssPath(String templateCssPath)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Text (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Text

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.Text
All Implemented Interfaces:
Param.UnnamedParametric
public class Text
extends Component
implements Param.UnnamedParametric

Render a I18n text message.

The message must be in a resource bundle with the same name as the action that it is associated with. In practice this means that you should create a properties file in the same package as your Java class with the same name as your class, but with .properties extension.

If the named message is not found, then the body of the tag will be used as default message. If no body is used, then the name of the message will be used.

  • name* (String) - the i18n message key

Example:

 Accessing messages from a given bundle (the i18n Shop example bundle in the first example) and using bundle defined through the framework in the second example.

 <!-- First Example -->
 <s:i18n name="struts.action.test.i18n.Shop">
     <s:text name="main.title"/>
 </s:i18n>

 <!-- Second Example -->
 <s:text name="main.title" />

 <!-- Third Examlpe -->
 <s:text name="i18n.label.greetings">
    <s:param >Mr Smith</s:param>
 </s:text>

 <-- Fourth Example -->
 <s:text name="some.key" />

 <-- Fifth Example -->
 <s:text name="some.invalid.key" >
    The Default Message That Will Be Displayed
 </s:text>

See Also:
Param

Field Summary
protected String | actualName
private static Log | LOG
protected String | name
protected List | values
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Text(ValueStack stack)
Method Summary
void | addParameter(Object value) Adds the given value as a parameter to the outer tag.
void | addParameter(String key, Object value) Add's the given key and value to this components own parameter.
boolean | end(Writer writer, String body) Callback for the end tag of this component.
void | setName(String name)
boolean | usesBody() Overwrite to set if body shold be used.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

values

protected List values

actualName

protected String actualName

name

protected String name
Constructor Detail

Text

public Text(ValueStack stack)
Method Detail

setName

public void setName(String name)

usesBody

public boolean usesBody()
Description copied from class: Component
Overwrite to set if body shold be used.

Overrides:
usesBody in class Component
Returns:
always false for this component.

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

addParameter

public void addParameter(String key,
                         Object value)
Description copied from class: Component
Add's the given key and value to this components own parameter.

If the provided key is null nothing happends. If the provided value is null any existing parameter with the given key name is removed.

Overrides:
addParameter in class Component
Parameters:
key - the key of the new parameter to add.
value - the value assoicated with the key.

addParameter

public void addParameter(Object value)
Description copied from interface: Param.UnnamedParametric
Adds the given value as a parameter to the outer tag.

Specified by:
addParameter in interface Param.UnnamedParametric
Parameters:
value - the value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextArea (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class TextArea

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.TextArea

public class TextArea
extends UIBean

Render HTML textarea tag.

Examples

 <s:textarea label="Comments" name="comments" cols="30" rows="8"/>

See Also:
TabbedPanel

Field Summary
protected String | cols
protected String | readonly
protected String | rows
static String | TEMPLATE
protected String | wrap
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
TextArea(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateExtraParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setCols(String cols)
void | setReadonly(String readonly)
void | setRows(String rows)
void | setWrap(String wrap)
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

cols

protected String cols

readonly

protected String readonly

rows

protected String rows

wrap

protected String wrap
Constructor Detail

TextArea

public TextArea(ValueStack stack,
                HttpServletRequest request,
                HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

public void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

setCols

public void setCols(String cols)

setReadonly

public void setReadonly(String readonly)

setRows

public void setRows(String rows)

setWrap

public void setWrap(String wrap)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextField (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class TextField

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.TextField
Direct Known Subclasses:
ComboBox, Password
public class TextField
extends UIBean

Render an HTML input field of type text

Examples

In this example, a text control for the "user" property is rendered. The label is also retrieved from a ResourceBundle via the key attribute.

 <s:textfield key="user" />

 <s:textfield name="user" label="User Name" />

Field Summary
protected String | maxlength
protected String | readonly
protected String | size
static String | TEMPLATE The name of the default template for the TextFieldTag
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
TextField(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected void | evaluateExtraParams()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setMaxlength(String maxlength)
void | setMaxLength(String maxlength)
void | setReadonly(String readonly)
void | setSize(String size)
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
The name of the default template for the TextFieldTag

See Also:
Constant Field Values

maxlength

protected String maxlength

readonly

protected String readonly

size

protected String size
Constructor Detail

TextField

public TextField(ValueStack stack,
                 HttpServletRequest request,
                 HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

protected void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

setMaxlength

public void setMaxlength(String maxlength)

setMaxLength

public void setMaxLength(String maxlength)

setReadonly

public void setReadonly(String readonly)

setSize

public void setSize(String size)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Token (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Token

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.Token

public class Token
extends UIBean

Stop double-submission of forms.

The token tag is used to help with the "double click" submission problem. It is needed if you are using the TokenInterceptor or the TokenSessionInterceptor. The s:token tag merely places a hidden element that contains the unique token.

Examples

 <s:token />

See Also:
TokenInterceptor, TokenSessionStoreInterceptor

Field Summary
static String TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Token(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
private String | buildToken(String name)
protected void | evaluateExtraParams() First looks for the token in the PageContext using the supplied name (or TokenHelper.DEFAULT_TOKEN_NAME if no name is provided) so that the same token can be re-used for the scope of a request for the same name.
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
String | getTokenNameField() Deprecated. Templates should use $parameters from now on, not $tag.
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values
Constructor Detail

Token

public Token(ValueStack stack,
             HttpServletRequest request,
             HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

evaluateExtraParams

protected void evaluateExtraParams()
First looks for the token in the PageContext using the supplied name (or TokenHelper.DEFAULT_TOKEN_NAME if no name is provided) so that the same token can be re-used for the scope of a request for the same name. If the token is not in the PageContext, a new Token is created and set into the Session and the PageContext with the name.

Overrides:
evaluateExtraParams in class UIBean

getTokenNameField

public String getTokenNameField()
Deprecated. Templates should use $parameters from now on, not $tag.

This will be removed in a future version of Struts.

buildToken

private String buildToken(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Tree (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class Tree

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ClosingUIBean
                extended by  org.apache.struts2.components.Tree

public class Tree
extends ClosingUIBean

Renders a tree widget with AJAX support.

The id attribute is normally specified, such that it could be looked up using javascript if necessary.

Examples

 <-- statically -->
 <s:tree id="..." label="...">
    <s:treenode id="..." label="..." />
    <s:treenode id="..." label="...">
        <s:treenode id="..." label="..." />
        <s:treenode id="..." label="..." />
    &;lt;/s:treenode>
    <s:treenode id="..." label="..." />
 </s:tree>

 <-- dynamically -->
 <s:tree
          id="..."
          rootNode="..."
          nodeIdProperty="..."
          nodeTitleProperty="..."
          childCollectionProperty="..." />

Field Summary
private String | blankIconSrc
protected String | childCollectionProperty
private String | expandIconSrcMinus
private String | expandIconSrcPlus
private String | gridIconSrcC
private String | gridIconSrcL
private String | gridIconSrcP
private String | gridIconSrcV
private String | gridIconSrcX
private String | gridIconSrcY
private String | iconHeight
private String | iconWidth
protected String | nodeIdProperty
protected String | nodeTitleProperty
private static String | OPEN_TEMPLATE
protected String | rootNodeAttr
private String | showGrid
private String | showRootGrid
private static String | TEMPLATE
private String | templateCssPath
private String | toggle
private String | toggleDuration
private String | treeCollapsedTopic
private String | treeExpandedTopic
private String | treeSelectedTopic
Fields inherited from class org.apache.struts2.components.ClosingUIBean
openTemplate
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
Tree(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
protected void | evaluateExtraParams()
String | getBlankIconSrc()
String | getChildCollectionProperty()
String | getDefaultOpenTemplate()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
String | getExpandIconSrcMinus()
String | getExpandIconSrcPlus()
String | getGridIconSrcC()
String | getGridIconSrcL()
String | getGridIconSrcP()
String | getGridIconSrcV()
String | getGridIconSrcX()
String | getGridIconSrcY()
String | getIconHeight()
String | getIconWidth()
String | getNodeIdProperty()
String | getNodeTitleProperty()
String | getRootNode()
String | getShowGrid()
String | getShowRootGrid()
String | getTemplateCssPath()
String | getToggle()
String | getToggleDuration()
String | getTreeCollapsedTopic()
String | getTreeExpandedTopic()
String | getTreeSelectedTopic()
void | setBlankIconSrc(String blankIconSrc)
void | setChildCollectionProperty(String childCollectionProperty)
void | setExpandIconSrcMinus(String expandIconSrcMinus)
void | setExpandIconSrcPlus(String expandIconSrcPlus)
void | setGridIconSrcC(String gridIconSrcC)
void | setGridIconSrcL(String gridIconSrcL)
void | setGridIconSrcP(String gridIconSrcP)
void | setGridIconSrcV(String gridIconSrcV)
void | setGridIconSrcX(String gridIconSrcX)
void | setGridIconSrcY(String gridIconSrcY)
void | setIconHeight(String iconHeight)
void | setIconWidth(String iconWidth)
void | setNodeIdProperty(String nodeIdProperty)
void | setNodeTitleProperty(String nodeTitleProperty)
void | setRootNode(String rootNode)
void | setShowGrid(String showGrid)
void | setShowRootGrid(String showRootGrid)
void | setTemplateCssPath(String templateCssPath)
void | setToggle(String toggle)
void | setToggleDuration(String toggleDuration)
void | setTreeCollapsedTopic(String treeCollapsedTopic)
void | setTreeExpandedTopic(String treeExpandedTopic)
void | setTreeSelectedTopic(String treeSelectedTopic)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.ClosingUIBean
setOpenTemplate
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

private static final String TEMPLATE
See Also:
Constant Field Values

OPEN_TEMPLATE

private static final String OPEN_TEMPLATE
See Also:
Constant Field Values

toggle

private String toggle

treeSelectedTopic

private String treeSelectedTopic

treeExpandedTopic

private String treeExpandedTopic

treeCollapsedTopic

private String treeCollapsedTopic

rootNodeAttr

protected String rootNodeAttr

childCollectionProperty

protected String childCollectionProperty

nodeTitleProperty

protected String nodeTitleProperty

nodeIdProperty

protected String nodeIdProperty

showRootGrid

private String showRootGrid

showGrid

private String showGrid

blankIconSrc

private String blankIconSrc

gridIconSrcL

private String gridIconSrcL

gridIconSrcV

private String gridIconSrcV

gridIconSrcP

private String gridIconSrcP

gridIconSrcC

private String gridIconSrcC

gridIconSrcX

private String gridIconSrcX

gridIconSrcY

private String gridIconSrcY

expandIconSrcPlus

private String expandIconSrcPlus

expandIconSrcMinus

private String expandIconSrcMinus

iconWidth

private String iconWidth

iconHeight

private String iconHeight

toggleDuration

private String toggleDuration

templateCssPath

private String templateCssPath
Constructor Detail

Tree

public Tree(ValueStack stack,
            HttpServletRequest request,
            HttpServletResponse response)
Method Detail

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class ClosingUIBean
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

evaluateExtraParams

protected void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

getDefaultOpenTemplate

public String getDefaultOpenTemplate()
Specified by:
getDefaultOpenTemplate in class ClosingUIBean

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

getToggle

public String getToggle()

setToggle

public void setToggle(String toggle)

getTreeSelectedTopic

public String getTreeSelectedTopic()

setTreeSelectedTopic

public void setTreeSelectedTopic(String treeSelectedTopic)

getTreeExpandedTopic

public String getTreeExpandedTopic()

setTreeExpandedTopic

public void setTreeExpandedTopic(String treeExpandedTopic)

getTreeCollapsedTopic

public String getTreeCollapsedTopic()

setTreeCollapsedTopic

public void setTreeCollapsedTopic(String treeCollapsedTopic)

getRootNode

public String getRootNode()

setRootNode

public void setRootNode(String rootNode)

getChildCollectionProperty

public String getChildCollectionProperty()

setChildCollectionProperty

public void setChildCollectionProperty(String childCollectionProperty)

getNodeTitleProperty

public String getNodeTitleProperty()

setNodeTitleProperty

public void setNodeTitleProperty(String nodeTitleProperty)

getNodeIdProperty

public String getNodeIdProperty()

setNodeIdProperty

public void setNodeIdProperty(String nodeIdProperty)

setShowRootGrid

public void setShowRootGrid(String showRootGrid)

getShowRootGrid

public String getShowRootGrid()

getBlankIconSrc

public String getBlankIconSrc()

setBlankIconSrc

public void setBlankIconSrc(String blankIconSrc)

getExpandIconSrcMinus

public String getExpandIconSrcMinus()

setExpandIconSrcMinus

public void setExpandIconSrcMinus(String expandIconSrcMinus)

getExpandIconSrcPlus

public String getExpandIconSrcPlus()

setExpandIconSrcPlus

public void setExpandIconSrcPlus(String expandIconSrcPlus)

getGridIconSrcC

public String getGridIconSrcC()

setGridIconSrcC

public void setGridIconSrcC(String gridIconSrcC)

getGridIconSrcL

public String getGridIconSrcL()

setGridIconSrcL

public void setGridIconSrcL(String gridIconSrcL)

getGridIconSrcP

public String getGridIconSrcP()

setGridIconSrcP

public void setGridIconSrcP(String gridIconSrcP)

getGridIconSrcV

public String getGridIconSrcV()

setGridIconSrcV

public void setGridIconSrcV(String gridIconSrcV)

getGridIconSrcX

public String getGridIconSrcX()

setGridIconSrcX

public void setGridIconSrcX(String gridIconSrcX)

getGridIconSrcY

public String getGridIconSrcY()

setGridIconSrcY

public void setGridIconSrcY(String gridIconSrcY)

getIconHeight

public String getIconHeight()

setIconHeight

public void setIconHeight(String iconHeight)

getIconWidth

public String getIconWidth()

setIconWidth

public void setIconWidth(String iconWidth)

getTemplateCssPath

public String getTemplateCssPath()

setTemplateCssPath

public void setTemplateCssPath(String templateCssPath)

getToggleDuration

public String getToggleDuration()

setToggleDuration

public void setToggleDuration(String toggleDuration)

getShowGrid

public String getShowGrid()

setShowGrid

public void setShowGrid(String showGrid)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeNode (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class TreeNode

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ClosingUIBean
                extended by  org.apache.struts2.components.TreeNode

public class TreeNode
extends ClosingUIBean

Renders a tree node within a tree widget with AJAX support.

Either of the following combinations should be used depending on if the tree is to be constrcted dynamically or statically.

Dynamically

  • id - id of this tree node
  • title - label to be displayed for this tree node
Statically
  • rootNode - the parent node of which this tree is derived from
  • nodeIdProperty - property to obtained this current tree node's id
  • nodeTitleProperty - property to obtained this current tree node's title
  • childCollectionProperty - property that returnds this current tree node's children

Examples

 <-- statically -->
 <s:tree id="..." label="...">
    <s:treenode id="..." label="..." />
    <s:treenode id="..." label="...">
        <s:treenode id="..." label="..." />
        <s:treenode id="..." label="..." />
    &;lt;/s:treenode>
    <s:treenode id="..." label="..." />
 </s:tree>

 <-- dynamically -->
 <s:tree
          id="..."
          rootNode="..."
          nodeIdProperty="..."
          nodeTitleProperty="..."
          childCollectionProperty="..." />

Field Summary
private static String | OPEN_TEMPLATE
private static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.ClosingUIBean
openTemplate
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
TreeNode(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
String | getDefaultOpenTemplate()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
void | setLabel(String label)
Methods inherited from class org.apache.struts2.components.ClosingUIBean
setOpenTemplate, start
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateExtraParams, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

TEMPLATE

private static final String TEMPLATE
See Also:
Constant Field Values

OPEN_TEMPLATE

private static final String OPEN_TEMPLATE
See Also:
Constant Field Values
Constructor Detail

TreeNode

public TreeNode(ValueStack stack,
                HttpServletRequest request,
                HttpServletResponse response)
Method Detail

getDefaultOpenTemplate

public String getDefaultOpenTemplate()
Specified by:
getDefaultOpenTemplate in class ClosingUIBean

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Specified by:
getDefaultTemplate in class UIBean
Returns:
The name of the template to be used as the default.

setLabel

public void setLabel(String label)
Overrides:
setLabel in class UIBean
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UIBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class UIBean

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
Direct Known Subclasses:
ActionError, ActionMessage, Checkbox, ClosingUIBean, DateTimePicker, Debug, FieldError, File, FormButton, GenericUIBean, Head, Hidden, Label, ListUIBean, TextArea, TextField, Token
public abstract class UIBean
extends Component

UIBean is the standard superclass of all Struts UI componentns. It defines common Struts and html properties all UI components should present for usage.

Attribute | Theme | Data Types | Description
templateDir | n/a | String | define the template directory
theme | n/a | String | define the theme name
template | n/a | String | define the template name

Attribute | Theme | Data Types | Description
cssClass | simple | String | define html class attribute
cssStyle | simple | String | define html style attribute
title | simple | String | define html title attribute
disabled | simple | String | define html disabled attribute
label | xhtml | String | define label of form element
labelPosition | xhtml | String | define label position of form element (top/left), default to left
requiredposition | xhtml | String | define required label position of form element (left/right), default to right
name | simple | String | Form Element's field name mapping
required | xhtml | Boolean | add * to label (true to add false otherwise)
tabIndex | simple | String | define html tabindex attribute
value | simple | Object | define value of form element

Attribute | Theme | Data Types | Description
onclick | simple | String | html javascript onclick attribute
ondbclick | simple | String | html javascript ondbclick attribute
onmousedown | simple | String | html javascript onmousedown attribute
onmouseup | simple | String | html javascript onmouseup attribute
onmouseover | simple | String | html javascript onmouseover attribute
onmouseout | simple | String | html javascript onmouseout attribute
onfocus | simple | String | html javascript onfocus attribute
onblur | simple | String | html javascript onblur attribute
onkeypress | simple | String | html javascript onkeypress attribute
onkeyup | simple | String | html javascript onkeyup attribute
onkeydown | simple | String | html javascript onkeydown attribute
onselect | simple | String | html javascript onselect attribute
onchange | simple | String | html javascript onchange attribute

Attribute | Data Type | Default | Description
tooltip | String | none | Set the tooltip of this particular component
jsTooltipEnabled | String | false | Enable js tooltip rendering
tooltipIcon | String | /struts/static/tooltip/tooltip.gif | The url to the tooltip icon
tooltipDelay | String | 500 | Tooltip shows up after the specified timeout (miliseconds). A behavior similar to that of OS based tooltips.
key | simple | String | The name of the property this input field represents. This will auto populate the name, label, and value
Every Form UI component (in xhtml / css_xhtml or any others that extends of them) could have tooltip assigned to a them. The Form component's tooltip related attribute once defined will be applicable to all form UI component that is created under it unless explicitly overriden by having the Form UI component itself defined that tooltip attribute.

In Example 1, the textfield will inherit the tooltipDelay adn tooltipIcon attribte from its containing form. In other words, although it doesn't defined a tooltipAboveMousePointer attribute, it will have that attributes inherited from its containing form.

In Example 2, the the textfield will inherite both the tooltipDelay and tooltipIcon attribute from its containing form but tooltipDelay attribute is overriden at the textfield itself. Hence, the textfield actually will have tooltipIcon defined as /myImages/myIcon.gif, inherited from its containing form and tooltipDelay defined as 5000, due to overriden at the textfield itself.

Example 3, 4 and 5 shows different way of setting the tooltipConfig attribute.
Example 3:Set tooltip config through body of param tag
Example 4:Set tooltip config through value attribute of param tag
Example 5:Set tooltip config through tooltipConfig attribute of component tag

 <!-- Example 1: -->
 <s:form
          tooltipConfig="#{'tooltipDelay':'500',
                           'tooltipIcon='/myImages/myIcon.gif'}" .... >
   ....
     <s:textfield label="Customer Name" tooltip="Enter the customer name" .... />
   ....
 </s:form>

 <!-- Example 2: -->
 <s:form
         tooltipConfig="#{'tooltipDelay':'500',
                          'tooltipIcon':'/myImages/myIcon.gif'}" ... >
   ....
     <s:textfield label="Address"
          tooltip="Enter your address"
          tooltipConfig="#{'tooltipDelay':'5000'}" />
   ....
 </s:form>

 <-- Example 3: -->
 <s:textfield
        label="Customer Name"
        tooltip="One of our customer Details'">
        <s:param name="tooltipConfig">
             tooltipDelay = 500 |
             tooltipIcon = /myImages/myIcon.gif
        </s:param>
 </s:textfield>

 <-- Example 4: -->
 <s:textfield
          label="Customer Address"
          tooltip="Enter The Customer Address" >
          <s:param
              name="tooltipConfig"
              value="#{'tooltipDelay':'500',
                       'tooltipIcon':'/myImages/myIcon.gif'}" />
 </s:textfield>

 <-- Example 5: -->
 <s:textfield
          label="Customer Telephone Number"
          tooltip="Enter customer Telephone Number"
          tooltipConfig="#{'tooltipDelay':'500',
                           'tooltipIcon':'/myImages/myIcon.gif'}" />

Field Summary
protected String | accesskey
protected String | cssClass
protected String | cssStyle
protected String | defaultTemplateDir
protected String | defaultUITheme
protected String | disabled
protected String | key
protected String | label
protected String | labelPosition
private static Log | LOG
protected String | name
protected String | onblur
protected String | onchange
protected String | onclick
protected String | ondblclick
protected String | onfocus
protected String | onkeydown
protected String | onkeypress
protected String | onkeyup
protected String | onmousedown
protected String | onmousemove
protected String | onmouseout
protected String | onmouseover
protected String | onmouseup
protected String | onselect
protected HttpServletRequest | request
protected String | required
protected String | requiredposition
protected HttpServletResponse | response
protected String | tabindex
protected String | template
protected String | templateDir
protected TemplateEngineManager | templateEngineManager
protected String | templateSuffix
protected String | theme
protected String | title
protected String | tooltip
protected String | tooltipConfig
protected String | value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
UIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | addFormParameter(String key, Object value)
protected Template | buildTemplateName(String myTemplate, String myDefaultTemplate)
protected void | enableAncestorFormCustomOnsubmit()
boolean | end(Writer writer, String body) Callback for the end tag of this component.
protected String | escape(String name)
protected void | evaluateExtraParams()
protected boolean | evaluateNameValue()
void | evaluateParams()
protected abstract String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
String | getTemplate()
String | getTemplateDir()
String | getTheme()
protected Map | getTooltipConfig(UIBean component)
protected Class | getValueClassType()
protected void | mergeTemplate(Writer writer, Template template)
protected void | populateComponentHtmlId(Form form) Create HTML id element for the component and populate this component parmaeter map.
void | setAccesskey(String accesskey)
void | setCssClass(String cssClass)
void | setCssStyle(String cssStyle)
void | setDefaultTemplateDir(String dir)
void | setDefaultUITheme(String theme)
void | setDisabled(String disabled)
void | setKey(String key)
void | setLabel(String label)
void | setLabelposition(String labelPosition)
void | setName(String name)
void | setOnblur(String onblur)
void | setOnchange(String onchange)
void | setOnclick(String onclick)
void | setOndblclick(String ondblclick)
void | setOnfocus(String onfocus)
void | setOnkeydown(String onkeydown)
void | setOnkeypress(String onkeypress)
void | setOnkeyup(String onkeyup)
void | setOnmousedown(String onmousedown)
void | setOnmousemove(String onmousemove)
void | setOnmouseout(String onmouseout)
void | setOnmouseover(String onmouseover)
void | setOnmouseup(String onmouseup)
void | setOnselect(String onselect)
void | setRequired(String required)
void | setRequiredposition(String requiredposition)
void | setTabindex(String tabindex)
void | setTemplate(String template)
void | setTemplateDir(String templateDir)
void | setTemplateEngineManager(TemplateEngineManager mgr)
void | setTheme(String theme)
void | setTitle(String title)
void | setTooltip(String tooltip)
void | setTooltipConfig(String tooltipConfig)
void | setValue(String value)
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

request

protected HttpServletRequest request

response

protected HttpServletResponse response

templateSuffix

protected String templateSuffix

template

protected String template

templateDir

protected String templateDir

theme

protected String theme

key

protected String key

cssClass

protected String cssClass

cssStyle

protected String cssStyle

disabled

protected String disabled

label

protected String label

labelPosition

protected String labelPosition

requiredposition

protected String requiredposition

name

protected String name

required

protected String required

tabindex

protected String tabindex

value

protected String value

title

protected String title

onclick

protected String onclick

ondblclick

protected String ondblclick

onmousedown

protected String onmousedown

onmouseup

protected String onmouseup

onmouseover

protected String onmouseover

onmousemove

protected String onmousemove

onmouseout

protected String onmouseout

onfocus

protected String onfocus

onblur

protected String onblur

onkeypress

protected String onkeypress

onkeydown

protected String onkeydown

onkeyup

protected String onkeyup

onselect

protected String onselect

onchange

protected String onchange

accesskey

protected String accesskey

tooltip

protected String tooltip

tooltipConfig

protected String tooltipConfig

defaultTemplateDir

protected String defaultTemplateDir

defaultUITheme

protected String defaultUITheme

templateEngineManager

protected TemplateEngineManager templateEngineManager
Constructor Detail

UIBean

public UIBean(ValueStack stack,
              HttpServletRequest request,
              HttpServletResponse response)
Method Detail

setDefaultTemplateDir

public void setDefaultTemplateDir(String dir)

setDefaultUITheme

public void setDefaultUITheme(String theme)

setTemplateEngineManager

public void setTemplateEngineManager(TemplateEngineManager mgr)

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

getDefaultTemplate

protected abstract String getDefaultTemplate()
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Returns:
The name of the template to be used as the default.

buildTemplateName

protected Template buildTemplateName(String myTemplate,
                                     String myDefaultTemplate)

mergeTemplate

protected void mergeTemplate(Writer writer,
                             Template template)
                      throws Exception
Throws:
Exception

getTemplateDir

public String getTemplateDir()

getTheme

public String getTheme()

evaluateParams

public void evaluateParams()

escape

protected String escape(String name)

evaluateExtraParams

protected void evaluateExtraParams()

evaluateNameValue

protected boolean evaluateNameValue()

getValueClassType

protected Class getValueClassType()

addFormParameter

public void addFormParameter(String key,
                             Object value)

enableAncestorFormCustomOnsubmit

protected void enableAncestorFormCustomOnsubmit()

getTooltipConfig

protected Map getTooltipConfig(UIBean component)

populateComponentHtmlId

protected void populateComponentHtmlId(Form form)
Create HTML id element for the component and populate this component parmaeter map. The order is as follows :-
  1. This component id attribute
  2. [containing_form_id]_[this_component_name]
  3. [this_component_name]

Parameters:
form -

setTemplateDir

public void setTemplateDir(String templateDir)

setTheme

public void setTheme(String theme)

getTemplate

public String getTemplate()

setTemplate

public void setTemplate(String template)

setCssClass

public void setCssClass(String cssClass)

setCssStyle

public void setCssStyle(String cssStyle)

setTitle

public void setTitle(String title)

setDisabled

public void setDisabled(String disabled)

setLabel

public void setLabel(String label)

setLabelposition

public void setLabelposition(String labelPosition)

setRequiredposition

public void setRequiredposition(String requiredposition)

setName

public void setName(String name)

setRequired

public void setRequired(String required)

setTabindex

public void setTabindex(String tabindex)

setValue

public void setValue(String value)

setOnclick

public void setOnclick(String onclick)

setOndblclick

public void setOndblclick(String ondblclick)

setOnmousedown

public void setOnmousedown(String onmousedown)

setOnmouseup

public void setOnmouseup(String onmouseup)

setOnmouseover

public void setOnmouseover(String onmouseover)

setOnmousemove

public void setOnmousemove(String onmousemove)

setOnmouseout

public void setOnmouseout(String onmouseout)

setOnfocus

public void setOnfocus(String onfocus)

setOnblur

public void setOnblur(String onblur)

setOnkeypress

public void setOnkeypress(String onkeypress)

setOnkeydown

public void setOnkeydown(String onkeydown)

setOnkeyup

public void setOnkeyup(String onkeyup)

setOnselect

public void setOnselect(String onselect)

setOnchange

public void setOnchange(String onchange)

setAccesskey

public void setAccesskey(String accesskey)

setTooltip

public void setTooltip(String tooltip)

setTooltipConfig

public void setTooltipConfig(String tooltipConfig)

setKey

public void setKey(String key)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpDownSelect (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class UpDownSelect

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.ListUIBean
                extended by  org.apache.struts2.components.Select
                    extended by  org.apache.struts2.components.UpDownSelect

public class UpDownSelect
extends Select

Create a Select component with buttons to move the elements in the select component up and down. When the containing form is submited, its elements will be submitted in the order they are arranged (top to bottom).

 <!-- Example 1: simple example -->
 <s:updownselect
 list="#{'england':'England', 'america':'America', 'germany':'Germany'}"
 name="prioritisedFavouriteCountries"
 headerKey="-1"
 headerValue="--- Please Order Them Accordingly ---"
 emptyOption="true" />

 <!-- Example 2: more complex example -->
 <s:updownselect
 list="defaultFavouriteCartoonCharacters"
 name="prioritisedFavouriteCartoonCharacters"
 headerKey="-1"
 headerValue="--- Please Order ---"
 emptyOption="true"
 allowMoveUp="true"
 allowMoveDown="true"
 allowSelectAll="true"
 moveUpLabel="Move Up"
 moveDownLabel="Move Down"
 selectAllLabel="Select All" />

Version:
$Date: 2007-01-18 19:21:57 -0500 (Thu, 18 Jan 2007) $ $Id: UpDownSelect.java 497654 2007-01-19 00:21:57Z rgielen $

Field Summary
private static Log | _log
protected String | allowMoveDown
protected String | allowMoveUp
protected String | allowSelectAll
protected String | moveDownLabel
protected String | moveUpLabel
protected String | selectAllLabel
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.Select
emptyOption, headerKey, headerValue, multiple, size
Fields inherited from class org.apache.struts2.components.ListUIBean
list, listKey, listValue, throwExceptionOnNullValueAttribute
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
UpDownSelect(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
void | evaluateParams()
String | getAllowMoveDown()
String | getAllowMoveUp()
String | getAllowSelectAll()
String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
String | getMoveDownLabel()
String | getMoveUpLabel()
String | getSelectAllLabel()
void | setAllowMoveDown(String allowMoveDown)
void | setAllowMoveUp(String allowMoveUp)
void | setAllowSelectAll(String allowSelectAll)
void | setMoveDownLabel(String moveDownLabel)
void | setMoveUpLabel(String moveUpLabel)
void | setSelectAllLabel(String selectAllLabel)
Methods inherited from class org.apache.struts2.components.Select
evaluateExtraParams, setEmptyOption, setHeaderKey, setHeaderValue, setMultiple, setSize
Methods inherited from class org.apache.struts2.components.ListUIBean
contains, getValueClassType, setList, setListKey, setListValue, setThrowExceptionOnNullValueAttribute
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, end, escape, evaluateNameValue, getTemplate, getTemplateDir, getTheme, getTooltipConfig, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

allowMoveUp

protected String allowMoveUp

allowMoveDown

protected String allowMoveDown

allowSelectAll

protected String allowSelectAll

moveUpLabel

protected String moveUpLabel

moveDownLabel

protected String moveDownLabel

selectAllLabel

protected String selectAllLabel
Constructor Detail

UpDownSelect

public UpDownSelect(ValueStack stack,
                    HttpServletRequest request,
                    HttpServletResponse response)
Method Detail

getDefaultTemplate

public String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Overrides:
getDefaultTemplate in class Select
Returns:
The name of the template to be used as the default.

evaluateParams

public void evaluateParams()
Overrides:
evaluateParams in class UIBean

getAllowMoveUp

public String getAllowMoveUp()

setAllowMoveUp

public void setAllowMoveUp(String allowMoveUp)

getAllowMoveDown

public String getAllowMoveDown()

setAllowMoveDown

public void setAllowMoveDown(String allowMoveDown)

getAllowSelectAll

public String getAllowSelectAll()

setAllowSelectAll

public void setAllowSelectAll(String allowSelectAll)

getMoveUpLabel

public String getMoveUpLabel()

setMoveUpLabel

public void setMoveUpLabel(String moveUpLabel)

getMoveDownLabel

public String getMoveDownLabel()

setMoveDownLabel

public void setMoveDownLabel(String moveDownLabel)

getSelectAllLabel

public String getSelectAllLabel()

setSelectAllLabel

public void setSelectAllLabel(String selectAllLabel)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URL (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Class URL

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.URL

public class URL
extends Component

This tag is used to create a URL.

You can use the "param" tag inside the body to provide additional request parameters.

NOTE:

When includeParams is 'all' or 'get', the parameter defined in param tag will take precedence and will not be overriden if they exists in the parameter submitted. For example, in Example 3 below, if there is a id parameter in the url where the page this tag is included like http://://editUser.action?id=3333&name=John the generated url will be http://:/context>/editUser.action?id=22&name=John cause the parameter defined in the param tag will take precedence.

  • action (String) - (value or action choose either one, if both exist value takes precedence) action's name (alias)
  • value (String) - (value or action choose either one, if both exist value takes precedence) the url itself
  • scheme (String) - http scheme (http, https) default to the scheme this request is in
  • namespace - action's namespace
  • method (String) - action's method, default to execute()
  • encode (Boolean) - url encode the generated url. Default is true
  • includeParams (String) - The includeParams attribute may have the value 'none', 'get' or 'all'. Default is 'get'. none - include no parameters in the URL get - include only GET parameters in the URL (default) all - include both GET and POST parameters in the URL
  • includeContext (Boolean) - determine wheather to include the web app context path. Default is true.

Examples

 <-- Example 1 -->
 <s:url value="editGadget.action">
     <s:param name="id" value="%{selected}" />
 </s:url>

 <-- Example 2 -->
 <s:url action="editGadget">
     <s:param name="id" value="%{selected}" />
 </s:url>

 <-- Example 3-->
 <s:url includeParams="get"  >
     <:param name="id" value="%{'22'}" />
 </s:url>

See Also:
Param

Nested Class Summary
static interface URL.ExtraParameterProvider
Field Summary
protected String | action
static String | ALL
protected String | anchor
protected boolean | encode
protected URL.ExtraParameterProvider | extraParameterProvider
static String | GET
protected boolean | includeContext
protected String | includeParams
private static Log | LOG
protected String | method
protected String | namespace
static String | NONE The includeParams attribute may have the value 'none', 'get' or 'all'.
protected String | portletMode
protected String | portletUrlType
private HttpServletRequest | req
private HttpServletResponse | res
protected String | scheme
protected String | urlIncludeParams
protected String | value
protected String | windowState
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
URL(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
private String | extractQueryString()
private void | includeExtraParameters()
private void | includeGetParameters()
protected void | mergeRequestParameters(String value, Map parameters, Map contextParameters) Merge request parameters into current parameters.
void | setAction(String action)
void | setAnchor(String anchor)
void | setEncode(boolean encode)
void | setExtraParameterProvider(URL.ExtraParameterProvider provider)
void | setIncludeContext(boolean includeContext)
void | setIncludeParams(String includeParams)
void | setMethod(String method)
void | setNamespace(String namespace)
void | setPortletMode(String portletMode)
void | setPortletUrlType(String portletUrlType)
void | setScheme(String scheme)
void | setUrlIncludeParams(String urlIncludeParams)
void | setValue(String value)
void | setWindowState(String windowState)
boolean | start(Writer writer) Callback for the start tag of this component.
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

NONE

public static final String NONE
The includeParams attribute may have the value 'none', 'get' or 'all'. It is used when the url tag is used without a value attribute. Its value is looked up on the ValueStack If no includeParams is specified then 'get' is used. none - include no parameters in the URL get - include only GET parameters in the URL (default) all - include both GET and POST parameters in the URL

See Also:
Constant Field Values

GET

public static final String GET
See Also:
Constant Field Values

ALL

public static final String ALL
See Also:
Constant Field Values

req

private HttpServletRequest req

res

private HttpServletResponse res

includeParams

protected String includeParams

scheme

protected String scheme

value

protected String value

action

protected String action

namespace

protected String namespace

method

protected String method

encode

protected boolean encode

includeContext

protected boolean includeContext

portletMode

protected String portletMode

windowState

protected String windowState

portletUrlType

protected String portletUrlType

anchor

protected String anchor

urlIncludeParams

protected String urlIncludeParams

extraParameterProvider

protected URL.ExtraParameterProvider extraParameterProvider
Constructor Detail

URL

public URL(ValueStack stack,
           HttpServletRequest req,
           HttpServletResponse res)
Method Detail

setUrlIncludeParams

public void setUrlIncludeParams(String urlIncludeParams)

setExtraParameterProvider

public void setExtraParameterProvider(URL.ExtraParameterProvider provider)

start

public boolean start(Writer writer)
Description copied from class: Component
Callback for the start tag of this component. Should the body be evaluated?

Overrides:
start in class Component
Parameters:
writer - the output writer.
Returns:
true if the body should be evaluated

includeExtraParameters

private void includeExtraParameters()

includeGetParameters

private void includeGetParameters()

extractQueryString

private String extractQueryString()

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class Component
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

setIncludeParams

public void setIncludeParams(String includeParams)

setScheme

public void setScheme(String scheme)

setValue

public void setValue(String value)

setAction

public void setAction(String action)

setNamespace

public void setNamespace(String namespace)

setMethod

public void setMethod(String method)

setEncode

public void setEncode(boolean encode)

setIncludeContext

public void setIncludeContext(boolean includeContext)

setPortletMode

public void setPortletMode(String portletMode)

setWindowState

public void setWindowState(String windowState)

setPortletUrlType

public void setPortletUrlType(String portletUrlType)

setAnchor

public void setAnchor(String anchor)

mergeRequestParameters

protected void mergeRequestParameters(String value,
                                      Map parameters,
                                      Map contextParameters)
Merge request parameters into current parameters. If a parameter is already present, than the request parameter in the current request and value atrribute will not override its value. The priority is as follows:-
  • parameter from the current request (least priority)
  • parameter form the value attribute (more priority)
  • parameter from the param tag (most priority)

Parameters:
value - the value attribute (url to be generated by this component)
parameters - component parameters
contextParameters - request parameters
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URL.ExtraParameterProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components
Interface URL.ExtraParameterProvider

Enclosing class:
URL
public static interface URL.ExtraParameterProvider

Method Summary
 Map getExtraParameters()

Method Detail

getExtraParameters

Map getExtraParameters()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.components.table (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.components.table

Interface Summary
SortableTableModel

Class Summary
AbstractFilterModel
RenderFilterModel
SortFilterModel
WebTable
WebTableColumn


org.apache.struts2.components.table Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.components.table

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • org.apache.struts2.components.table.AbstractFilterModel
        • org.apache.struts2.components.table.RenderFilterModel
        • org.apache.struts2.components.table.SortFilterModel (implements org.apache.struts2.components.table.SortableTableModel, javax.swing.event.TableModelListener)
    • org.apache.struts2.components.Component
      • org.apache.struts2.components.UIBean
        • org.apache.struts2.components.GenericUIBean
          • org.apache.struts2.components.table.WebTable
    • org.apache.struts2.components.table.SortFilterModel.Row (implements java.lang.Comparable<T>)
    • org.apache.struts2.components.table.WebTable.WebTableRowIterator (implements java.util.Iterator<E>)
    • org.apache.struts2.components.table.WebTableColumn

Interface Hierarchy

  • javax.swing.table.TableModel
    • org.apache.struts2.components.table.SortableTableModel


Uses of Package org.apache.struts2.components.table (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.components.table

Packages that use org.apache.struts2.components.table
org.apache.struts2.components.table |
org.apache.struts2.components.table.renderer | JSP UI tags for rendering table output in HTML.

Classes in org.apache.struts2.components.table used by org.apache.struts2.components.table
AbstractFilterModel
SortableTableModel
WebTable
WebTableColumn

Classes in org.apache.struts2.components.table used by org.apache.struts2.components.table.renderer
WebTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SortableTableModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table
Interface SortableTableModel

All Superinterfaces:
TableModel
All Known Implementing Classes:
SortFilterModel
public interface SortableTableModel
extends TableModel

Field Summary
static String | ASC
static String | DESC
static String | NONE
Method Summary
int | getSortedColumnNumber()
String | getSortedDirection(int columnNumber)
void | sort(int columnNumber, String direction)
Methods inherited from interface javax.swing.table.TableModel
addTableModelListener, getColumnClass, getColumnCount, getColumnName, getRowCount, getValueAt, isCellEditable, removeTableModelListener, setValueAt

Field Detail

NONE

static final String NONE
See Also:
Constant Field Values

ASC

static final String ASC
See Also:
Constant Field Values

DESC

static final String DESC
See Also:
Constant Field Values
Method Detail

getSortedColumnNumber

int getSortedColumnNumber()

getSortedDirection

String getSortedDirection(int columnNumber)

sort

void sort(int columnNumber,
          String direction)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractFilterModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table
Class AbstractFilterModel

java.lang.Object
    extended by  javax.swing.table.AbstractTableModel
        extended by  org.apache.struts2.components.table.AbstractFilterModel
All Implemented Interfaces:
Serializable, TableModel
Direct Known Subclasses:
RenderFilterModel, SortFilterModel
public abstract class AbstractFilterModel
extends AbstractTableModel

See Also:
Serialized Form

Field Summary
protected  TableModel model
Fields inherited from class javax.swing.table.AbstractTableModel
listenerList
Constructor Summary
AbstractFilterModel(TableModel tm)
Method Summary
void | addRow(Vector data)
Class | getColumnClass(int par1)
int | getColumnCount()
String | getColumnName(int par1)
TableModel | getModel()
int | getRowCount()
Object | getValueAt(int par1, int par2)
boolean | isCellEditable(int par1, int par2)
void | removeAllRows()
void | removeRow(int rowNum)
void | setModel(TableModel model)
void | setValueAt(Object par1, int par2, int par3)
Methods inherited from class javax.swing.table.AbstractTableModel
addTableModelListener, findColumn, fireTableCellUpdated, fireTableChanged, fireTableDataChanged, fireTableRowsDeleted, fireTableRowsInserted, fireTableRowsUpdated, fireTableStructureChanged, getListeners, getTableModelListeners, removeTableModelListener
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

model

protected TableModel model
Constructor Detail

AbstractFilterModel

public AbstractFilterModel(TableModel tm)
Method Detail

isCellEditable

public boolean isCellEditable(int par1,
                              int par2)
Specified by:
isCellEditable in interface TableModel
Overrides:
isCellEditable in class AbstractTableModel

getColumnClass

public Class getColumnClass(int par1)
Specified by:
getColumnClass in interface TableModel
Overrides:
getColumnClass in class AbstractTableModel

getColumnCount

public int getColumnCount()

getColumnName

public String getColumnName(int par1)
Specified by:
getColumnName in interface TableModel
Overrides:
getColumnName in class AbstractTableModel

setModel

public void setModel(TableModel model)

getModel

public TableModel getModel()

getRowCount

public int getRowCount()

setValueAt

public void setValueAt(Object par1,
                       int par2,
                       int par3)
Specified by:
setValueAt in interface TableModel
Overrides:
setValueAt in class AbstractTableModel

getValueAt

public Object getValueAt(int par1,
                         int par2)

addRow

public void addRow(Vector data)
            throws IllegalStateException
Throws:
IllegalStateException

removeAllRows

public void removeAllRows()
                   throws ArrayIndexOutOfBoundsException,
                          IllegalStateException
Throws:
ArrayIndexOutOfBoundsException
IllegalStateException

removeRow

public void removeRow(int rowNum)
               throws ArrayIndexOutOfBoundsException,
                      IllegalStateException
Throws:
ArrayIndexOutOfBoundsException
IllegalStateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


RenderFilterModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table
Class RenderFilterModel

java.lang.Object
    extended by  javax.swing.table.AbstractTableModel
        extended by  org.apache.struts2.components.table.AbstractFilterModel
            extended by  org.apache.struts2.components.table.RenderFilterModel
All Implemented Interfaces:
Serializable, TableModel
public class RenderFilterModel
extends AbstractFilterModel

See Also:
Serialized Form

Field Summary
private boolean | rendered
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.components.table.AbstractFilterModel
model
Fields inherited from class javax.swing.table.AbstractTableModel
listenerList
Constructor Summary
RenderFilterModel(TableModel tm)
Method Summary
boolean | isRendered()
void | setRendered(boolean rendered)
Methods inherited from class org.apache.struts2.components.table.AbstractFilterModel
addRow, getColumnClass, getColumnCount, getColumnName, getModel, getRowCount, getValueAt, isCellEditable, removeAllRows, removeRow, setModel, setValueAt
Methods inherited from class javax.swing.table.AbstractTableModel
addTableModelListener, findColumn, fireTableCellUpdated, fireTableChanged, fireTableDataChanged, fireTableRowsDeleted, fireTableRowsInserted, fireTableRowsUpdated, fireTableStructureChanged, getListeners, getTableModelListeners, removeTableModelListener
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

rendered

private boolean rendered
Constructor Detail

RenderFilterModel

public RenderFilterModel(TableModel tm)
Method Detail

setRendered

public void setRendered(boolean rendered)

isRendered

public boolean isRendered()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SortFilterModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table
Class SortFilterModel

java.lang.Object
    extended by  javax.swing.table.AbstractTableModel
        extended by  org.apache.struts2.components.table.AbstractFilterModel
            extended by  org.apache.struts2.components.table.SortFilterModel
All Implemented Interfaces:
Serializable, EventListener, TableModelListener, TableModel, SortableTableModel
public class SortFilterModel
extends AbstractFilterModel
implements TableModelListener, SortableTableModel

See Also:
Serialized Form

Nested Class Summary
private  class SortFilterModel.Row
Field Summary
private String | _sortDirection These are just here to implement the interface
private boolean | dirty
private ArrayList | rows
private static long | serialVersionUID
private int | sortColumn
Fields inherited from class org.apache.struts2.components.table.AbstractFilterModel
model
Fields inherited from class javax.swing.table.AbstractTableModel
listenerList
Fields inherited from interface org.apache.struts2.components.table.SortableTableModel
ASC, DESC, NONE
Constructor Summary
SortFilterModel(TableModel tm)
Method Summary
void | addMouseListener(JTable table)
int | getSortedColumnNumber()
String | getSortedDirection(int columnNumber)
Object | getValueAt(int r, int c)
boolean | isCellEditable(int r, int c)
protected void | refresh()
void | removeRow(int rowNum)
void | setModel(TableModel tm)
void | setValueAt(Object aValue, int r, int c)
protected void | sort(int c)
void | sort(int columnNumber, String direction)
void | tableChanged(TableModelEvent e) Implements the TableModelListener interface to receive notifications of * changes to the table model.
Methods inherited from class org.apache.struts2.components.table.AbstractFilterModel
addRow, getColumnClass, getColumnCount, getColumnName, getModel, getRowCount, removeAllRows
Methods inherited from class javax.swing.table.AbstractTableModel
addTableModelListener, findColumn, fireTableCellUpdated, fireTableChanged, fireTableDataChanged, fireTableRowsDeleted, fireTableRowsInserted, fireTableRowsUpdated, fireTableStructureChanged, getListeners, getTableModelListeners, removeTableModelListener
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.swing.table.TableModel
addTableModelListener, getColumnClass, getColumnCount, getColumnName, getRowCount, removeTableModelListener

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

rows

private ArrayList rows

_sortDirection

private String _sortDirection
These are just here to implement the interface

dirty

private boolean dirty

sortColumn

private int sortColumn
Constructor Detail

SortFilterModel

public SortFilterModel(TableModel tm)
Method Detail

isCellEditable

public boolean isCellEditable(int r,
                              int c)
Specified by:
isCellEditable in interface TableModel
Overrides:
isCellEditable in class AbstractFilterModel

setModel

public void setModel(TableModel tm)
Overrides:
setModel in class AbstractFilterModel

getSortedColumnNumber

public int getSortedColumnNumber()
Specified by:
getSortedColumnNumber in interface SortableTableModel

getSortedDirection

public String getSortedDirection(int columnNumber)
Specified by:
getSortedDirection in interface SortableTableModel

setValueAt

public void setValueAt(Object aValue,
                       int r,
                       int c)
Specified by:
setValueAt in interface TableModel
Overrides:
setValueAt in class AbstractFilterModel

getValueAt

public Object getValueAt(int r,
                         int c)
Specified by:
getValueAt in interface TableModel
Overrides:
getValueAt in class AbstractFilterModel

addMouseListener

public void addMouseListener(JTable table)

removeRow

public void removeRow(int rowNum)
               throws ArrayIndexOutOfBoundsException,
                      IllegalStateException
Overrides:
removeRow in class AbstractFilterModel
Throws:
ArrayIndexOutOfBoundsException
IllegalStateException

sort

public void sort(int columnNumber,
                 String direction)
Specified by:
sort in interface SortableTableModel

tableChanged

public void tableChanged(TableModelEvent e)
Implements the TableModelListener interface to receive notifications of * changes to the table model. SortFilterModel needs to receive events for adding and removing rows.

Specified by:
tableChanged in interface TableModelListener

refresh

protected void refresh()

sort

protected void sort(int c)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SortFilterModel.Row (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table
Class SortFilterModel.Row

java.lang.Object
    extended by  org.apache.struts2.components.table.SortFilterModel.Row
All Implemented Interfaces:
Comparable
Enclosing class:
SortFilterModel
private class SortFilterModel.Row
extends Object
implements Comparable

Field Summary
 int index
Constructor Summary
SortFilterModel.Row(int index)
Method Summary
 int compareTo(Object other)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

index

public int index
Constructor Detail

SortFilterModel.Row

public SortFilterModel.Row(int index)
Method Detail

compareTo

public int compareTo(Object other)
Specified by:
compareTo in interface Comparable
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WebTable (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table
Class WebTable

java.lang.Object
    extended by  org.apache.struts2.components.Component
        extended by  org.apache.struts2.components.UIBean
            extended by  org.apache.struts2.components.GenericUIBean
                extended by  org.apache.struts2.components.table.WebTable

public class WebTable
extends GenericUIBean

Nested Class Summary
 class WebTable.WebTableRowIterator
inner class to iteratoe over a row of the table.
Field Summary
protected WebTableColumn[] | columns
protected int | curRow
private static Log | LOG
protected TableModel | model
protected String | modelName
protected boolean | sortableAttr
protected int | sortColumn
protected String | sortOrder
static String | TEMPLATE
Fields inherited from class org.apache.struts2.components.UIBean
accesskey, cssClass, cssStyle, defaultTemplateDir, defaultUITheme, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, request, required, requiredposition, response, tabindex, template, templateDir, templateEngineManager, templateSuffix, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.components.Component
actionMapper, COMPONENT_STACK, id, parameters, stack
Constructor Summary
WebTable(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
boolean | end(Writer writer, String body) Callback for the end tag of this component.
protected void | evaluateExtraParams()
WebTableColumn | getColumn(int index)
int | getColumnCount()
void | getColumnDisplayName(int column)
CellRenderer | getColumnRenderer(int column)
WebTableColumn[] | getColumns()
protected String | getDefaultTemplate() A contract that requires each concrete UI Tag to specify which template should be used as a default.
String[] | getFormattedRow(int row)
TableModel | getModel()
String | getModelName()
protected int | getNumberOfVisibleColumns()
Object | getRawData(int row, int column)
Iterator | getRawDataRowIterator()
Object[] | getRow(int row)
int | getRowCount()
Iterator | getRowIterator()
int | getSortColumn()
String | getSortColumnLinkName()
String | getSortOrder()
String | getSortOrderLinkName()
boolean | isColumnHidden(int column)
boolean | isSortable()
void | setColumnDisplayName(int column, String displayName)
void | setColumnHidden(int column, boolean hide)
void | setColumnRenderer(int column, CellRenderer renderer)
void | setModel(TableModel model)
void | setModelName(String modelName) The name of model to use
void | setSortable(boolean sortable)
void | setSortColumn(int sortColumn)
void | setSortOrder(String sortOrder)
Methods inherited from class org.apache.struts2.components.GenericUIBean
contains
Methods inherited from class org.apache.struts2.components.UIBean
addFormParameter, buildTemplateName, enableAncestorFormCustomOnsubmit, escape, evaluateNameValue, evaluateParams, getTemplate, getTemplateDir, getTheme, getTooltipConfig, getValueClassType, mergeTemplate, populateComponentHtmlId, setAccesskey, setCssClass, setCssStyle, setDefaultTemplateDir, setDefaultUITheme, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTemplateEngineManager, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.components.Component
addAllParameters, addParameter, altSyntax, copyParams, determineActionURL, determineNamespace, end, fieldError, findAncestor, findString, findString, findValue, findValue, findValue, getComponentStack, getId, getParameters, getStack, popComponentStack, setActionMapper, setId, start, toString, usesBody
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

TEMPLATE

public static final String TEMPLATE
See Also:
Constant Field Values

sortOrder

protected String sortOrder

modelName

protected String modelName

model

protected TableModel model

columns

protected WebTableColumn[] columns

sortableAttr

protected boolean sortableAttr

sortColumn

protected int sortColumn

curRow

protected int curRow
Constructor Detail

WebTable

public WebTable(ValueStack stack,
                HttpServletRequest request,
                HttpServletResponse response)
Method Detail

getDefaultTemplate

protected String getDefaultTemplate()
Description copied from class: UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default. For example, the CheckboxTab might return "checkbox.vm" while the RadioTag might return "radio.vm". This value not begin with a '/' unless you intend to make the path absolute rather than relative to the current theme.

Overrides:
getDefaultTemplate in class GenericUIBean
Returns:
The name of the template to be used as the default.

end

public boolean end(Writer writer,
                   String body)
Description copied from class: Component
Callback for the end tag of this component. Should the body be evaluated again?

NOTE: will pop component stack.

Overrides:
end in class UIBean
Parameters:
writer - the output writer.
body - the rendered body.
Returns:
true if the body should be evaluated again

getColumn

public WebTableColumn getColumn(int index)

evaluateExtraParams

protected void evaluateExtraParams()
Overrides:
evaluateExtraParams in class UIBean

getNumberOfVisibleColumns

protected int getNumberOfVisibleColumns()

getColumnCount

public int getColumnCount()

setColumnDisplayName

public void setColumnDisplayName(int column,
                                 String displayName)

getColumnDisplayName

public void getColumnDisplayName(int column)

setColumnHidden

public void setColumnHidden(int column,
                            boolean hide)

isColumnHidden

public boolean isColumnHidden(int column)

setColumnRenderer

public void setColumnRenderer(int column,
                              CellRenderer renderer)

getColumnRenderer

public CellRenderer getColumnRenderer(int column)

getColumns

public WebTableColumn[] getColumns()

getFormattedRow

public String[] getFormattedRow(int row)

setModel

public void setModel(TableModel model)

getModel

public TableModel getModel()

setModelName

public void setModelName(String modelName)
The name of model to use

getModelName

public String getModelName()

getRawData

public Object getRawData(int row,
                         int column)

getRawDataRowIterator

public Iterator getRawDataRowIterator()

getRow

public Object[] getRow(int row)

getRowCount

public int getRowCount()

getRowIterator

public Iterator getRowIterator()

setSortColumn

public void setSortColumn(int sortColumn)

getSortColumn

public int getSortColumn()

getSortColumnLinkName

public String getSortColumnLinkName()

setSortOrder

public void setSortOrder(String sortOrder)

getSortOrder

public String getSortOrder()

getSortOrderLinkName

public String getSortOrderLinkName()

setSortable

public void setSortable(boolean sortable)

isSortable

public boolean isSortable()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WebTable.WebTableRowIterator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table
Class WebTable.WebTableRowIterator

java.lang.Object
    extended by  org.apache.struts2.components.table.WebTable.WebTableRowIterator
All Implemented Interfaces:
Iterator
Enclosing class:
WebTable
public class WebTable.WebTableRowIterator
extends Object
implements Iterator

inner class to iteratoe over a row of the table. It can return formatted data, using the columnRenderer for the column or it can return the raw data.

Field Summary
protected int | _curRow
protected int | _mode
protected WebTable | _table
static int | FORMATTED_DATA
static int | RAW_DATA
Constructor Summary
protected | WebTable.WebTableRowIterator(WebTable table)
protected | WebTable.WebTableRowIterator(WebTable table, int mode)
Method Summary
boolean | hasNext()
Object | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

FORMATTED_DATA

public static final int FORMATTED_DATA
See Also:
Constant Field Values

RAW_DATA

public static final int RAW_DATA
See Also:
Constant Field Values

_table

protected WebTable _table

_curRow

protected int _curRow

_mode

protected int _mode
Constructor Detail

WebTable.WebTableRowIterator

protected WebTable.WebTableRowIterator(WebTable table)

WebTable.WebTableRowIterator

protected WebTable.WebTableRowIterator(WebTable table,
                                       int mode)
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
            throws NoSuchElementException
Specified by:
next in interface Iterator
Throws:
NoSuchElementException

remove

public void remove()
            throws UnsupportedOperationException,
                   IllegalStateException
Specified by:
remove in interface Iterator
Throws:
UnsupportedOperationException
IllegalStateException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WebTableColumn (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table
Class WebTableColumn

java.lang.Object
    extended by  org.apache.struts2.components.table.WebTableColumn

public class WebTableColumn
extends Object

Field Summary
(package private) String | _displayName
(package private) boolean | _hidden
(package private) String | _name
(package private) int | _offset
(package private) CellRenderer | _renderer
private static CellRenderer | DEFAULT_RENDERER
Constructor Summary
WebTableColumn(String name, int offset)
Method Summary
String | getDisplayName()
String | getName()
int | getOffset()
CellRenderer | getRenderer()
boolean | isHidden()
boolean | isVisible()
void | setDisplayName(String displayName)
void | setHidden(boolean hidden)
void | setRenderer(CellRenderer renderer)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_RENDERER

private static final CellRenderer DEFAULT_RENDERER

_renderer

CellRenderer _renderer

_displayName

String _displayName

_name

String _name

_hidden

boolean _hidden

_offset

int _offset
Constructor Detail

WebTableColumn

public WebTableColumn(String name,
                      int offset)
Method Detail

setDisplayName

public void setDisplayName(String displayName)

getDisplayName

public String getDisplayName()

setHidden

public void setHidden(boolean hidden)

isHidden

public boolean isHidden()

getName

public String getName()

getOffset

public int getOffset()

setRenderer

public void setRenderer(CellRenderer renderer)

getRenderer

public CellRenderer getRenderer()

isVisible

public boolean isVisible()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.components.table.renderer (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.components.table.renderer

JSP UI tags for rendering table output in HTML.

See:
Description

Interface Summary
CellRenderer

Class Summary
AbstractCellRenderer | this is the base class that most renderers will be derived from.
BooleanCellRenderer |
DateCellRenderer |
DefaultCellRenderer |
FixedTextCellRenderer | usefull if a column has an embeded ID number needed for a link but you want it to say something else.
LinkCellRenderer |
NumericCellRenderer |

Package org.apache.struts2.components.table.renderer Description

JSP UI tags for rendering table output in HTML.


org.apache.struts2.components.table.renderer Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.components.table.renderer

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.components.table.renderer.AbstractCellRenderer (implements org.apache.struts2.components.table.renderer.CellRenderer)
      • org.apache.struts2.components.table.renderer.BooleanCellRenderer
      • org.apache.struts2.components.table.renderer.DateCellRenderer
      • org.apache.struts2.components.table.renderer.DefaultCellRenderer
      • org.apache.struts2.components.table.renderer.FixedTextCellRenderer
      • org.apache.struts2.components.table.renderer.LinkCellRenderer
      • org.apache.struts2.components.table.renderer.NumericCellRenderer

Interface Hierarchy

  • org.apache.struts2.components.table.renderer.CellRenderer


Uses of Package org.apache.struts2.components.table.renderer (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.components.table.renderer

Packages that use org.apache.struts2.components.table.renderer
org.apache.struts2.components.table |
org.apache.struts2.components.table.renderer | JSP UI tags for rendering table output in HTML.

Classes in org.apache.struts2.components.table.renderer used by org.apache.struts2.components.table
CellRenderer

Classes in org.apache.struts2.components.table.renderer used by org.apache.struts2.components.table.renderer
AbstractCellRenderer
this is the base class that most renderers will be derived from.
CellRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


CellRenderer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table.renderer
Interface CellRenderer

All Known Implementing Classes:
AbstractCellRenderer, BooleanCellRenderer, DateCellRenderer, DefaultCellRenderer, FixedTextCellRenderer, LinkCellRenderer, NumericCellRenderer
public interface CellRenderer

Method Summary
 String renderCell(WebTable table, Object data, int row, int col)

Method Detail

renderCell

String renderCell(WebTable table,
                  Object data,
                  int row,
                  int col)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractCellRenderer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table.renderer
Class AbstractCellRenderer

java.lang.Object
    extended by  org.apache.struts2.components.table.renderer.AbstractCellRenderer
All Implemented Interfaces:
CellRenderer
Direct Known Subclasses:
BooleanCellRenderer, DateCellRenderer, DefaultCellRenderer, FixedTextCellRenderer, LinkCellRenderer, NumericCellRenderer
public abstract class AbstractCellRenderer
extends Object
implements CellRenderer

this is the base class that most renderers will be derived from. It allows setting the alignment. Subclasses should set there actuall content by implementing getCellValue

Field Summary
protected  String _alignment
used for horizontal cell alignmnet
Constructor Summary
AbstractCellRenderer()
Method Summary
String | getAlignment()
protected abstract String | getCellValue(WebTable table, Object data, int row, int col) this is the method that subclasses need to implement to set their value.
protected boolean | isAligned()
String | renderCell(WebTable table, Object data, int row, int col) implememnts CellRenderer renderCell.
void | setAlignment(String alignment)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_alignment

protected String _alignment
used for horizontal cell alignmnet

Constructor Detail

AbstractCellRenderer

public AbstractCellRenderer()
Method Detail

setAlignment

public void setAlignment(String alignment)

getAlignment

public String getAlignment()

renderCell

public String renderCell(WebTable table,
                         Object data,
                         int row,
                         int col)
implememnts CellRenderer renderCell. It sets the alignment. gets the actual data from getCellValue

Specified by:
renderCell in interface CellRenderer

isAligned

protected boolean isAligned()

getCellValue

protected abstract String getCellValue(WebTable table,
                                       Object data,
                                       int row,
                                       int col)
this is the method that subclasses need to implement to set their value. they should not override renderCell unless they want to change the alignmnent renderering

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BooleanCellRenderer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table.renderer
Class BooleanCellRenderer

java.lang.Object
    extended by  org.apache.struts2.components.table.renderer.AbstractCellRenderer
        extended by  org.apache.struts2.components.table.renderer.BooleanCellRenderer
All Implemented Interfaces:
CellRenderer
public class BooleanCellRenderer
extends AbstractCellRenderer

Field Summary
protected String | _falseValue value used if the boolean object is false
protected String | _trueValue value used if the boolean object is true
Fields inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
_alignment
Constructor Summary
BooleanCellRenderer()
Method Summary
String | getCellValue(WebTable table, Object data, int row, int col) this is the method that subclasses need to implement to set their value.
void | setFalseValue(String falseValue)
void | setTrueValue(String trueValue)
Methods inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
getAlignment, isAligned, renderCell, setAlignment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_falseValue

protected String _falseValue
value used if the boolean object is false

_trueValue

protected String _trueValue
value used if the boolean object is true

Constructor Detail

BooleanCellRenderer

public BooleanCellRenderer()
Method Detail

getCellValue

public String getCellValue(WebTable table,
                           Object data,
                           int row,
                           int col)
Description copied from class: AbstractCellRenderer
this is the method that subclasses need to implement to set their value. they should not override renderCell unless they want to change the alignmnent renderering

Specified by:
getCellValue in class AbstractCellRenderer

setFalseValue

public void setFalseValue(String falseValue)

setTrueValue

public void setTrueValue(String trueValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateCellRenderer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table.renderer
Class DateCellRenderer

java.lang.Object
    extended by  org.apache.struts2.components.table.renderer.AbstractCellRenderer
        extended by  org.apache.struts2.components.table.renderer.DateCellRenderer
All Implemented Interfaces:
CellRenderer
public class DateCellRenderer
extends AbstractCellRenderer

Field Summary
(package private) SimpleDateFormat | _formater
(package private) String | _formatString this is the string that SimpleDateFormat needs to display the date
Fields inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
_alignment
Constructor Summary
DateCellRenderer()
Method Summary
String | getCellValue(WebTable table, Object data, int row, int col) this is the method that subclasses need to implement to set their value.
void | setFormatString(String format)
Methods inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
getAlignment, isAligned, renderCell, setAlignment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_formater

SimpleDateFormat _formater

_formatString

String _formatString
this is the string that SimpleDateFormat needs to display the date

See Also:
SimpleDateFormat
Constructor Detail

DateCellRenderer

public DateCellRenderer()
Method Detail

getCellValue

public String getCellValue(WebTable table,
                           Object data,
                           int row,
                           int col)
Description copied from class: AbstractCellRenderer
this is the method that subclasses need to implement to set their value. they should not override renderCell unless they want to change the alignmnent renderering

Specified by:
getCellValue in class AbstractCellRenderer

setFormatString

public void setFormatString(String format)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultCellRenderer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table.renderer
Class DefaultCellRenderer

java.lang.Object
    extended by  org.apache.struts2.components.table.renderer.AbstractCellRenderer
        extended by  org.apache.struts2.components.table.renderer.DefaultCellRenderer
All Implemented Interfaces:
CellRenderer
public class DefaultCellRenderer
extends AbstractCellRenderer

Field Summary
Fields inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
_alignment
Constructor Summary
DefaultCellRenderer()
Method Summary
 String getCellValue(WebTable table, Object data, int row, int col)
this is the method that subclasses need to implement to set their value.
Methods inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
getAlignment, isAligned, renderCell, setAlignment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultCellRenderer

public DefaultCellRenderer()
Method Detail

getCellValue

public String getCellValue(WebTable table,
                           Object data,
                           int row,
                           int col)
Description copied from class: AbstractCellRenderer
this is the method that subclasses need to implement to set their value. they should not override renderCell unless they want to change the alignmnent renderering

Specified by:
getCellValue in class AbstractCellRenderer
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FixedTextCellRenderer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table.renderer
Class FixedTextCellRenderer

java.lang.Object
    extended by  org.apache.struts2.components.table.renderer.AbstractCellRenderer
        extended by  org.apache.struts2.components.table.renderer.FixedTextCellRenderer
All Implemented Interfaces:
CellRenderer
public class FixedTextCellRenderer
extends AbstractCellRenderer

usefull if a column has an embeded ID number needed for a link but you want it to say something else.

Field Summary
protected  String _text
this is the text that will be shown in the column
Fields inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
_alignment
Constructor Summary
FixedTextCellRenderer()
Method Summary
String | getCellValue(WebTable table, Object data, int row, int col) this is the method that subclasses need to implement to set their value.
String | getText()
void | setText(String text)
Methods inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
getAlignment, isAligned, renderCell, setAlignment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_text

protected String _text
this is the text that will be shown in the column

Constructor Detail

FixedTextCellRenderer

public FixedTextCellRenderer()
Method Detail

getCellValue

public String getCellValue(WebTable table,
                           Object data,
                           int row,
                           int col)
Description copied from class: AbstractCellRenderer
this is the method that subclasses need to implement to set their value. they should not override renderCell unless they want to change the alignmnent renderering

Specified by:
getCellValue in class AbstractCellRenderer

setText

public void setText(String text)

getText

public String getText()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LinkCellRenderer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table.renderer
Class LinkCellRenderer

java.lang.Object
    extended by  org.apache.struts2.components.table.renderer.AbstractCellRenderer
        extended by  org.apache.struts2.components.table.renderer.LinkCellRenderer
All Implemented Interfaces:
CellRenderer
public class LinkCellRenderer
extends AbstractCellRenderer

Field Summary
protected String | _cssClass the CSS class this link belongs to.
protected String | _cssId the id attribute this link belongs to.
protected CellRenderer | _delegateRenderer this is the actual renderer tha will be used to display the text
protected String | _link this is the link we are setting (required)
protected String | _onclick the (Java)script/ function to execute when the link is clicked.
protected String | _ondblclick the (Java)script/ function to execute when the link is clicked twice.
protected String | _onmouseout the (Java)script/ function to execute when cursor is away from the link.
protected String | _onmouseover the (Java)script/ function to execute when cursor is over the link.
protected String | _param if set there will be a parameter attached to link.
protected int | _paramColumn if used the param value will be taken from another column in the table.
protected String | _paramValue directly set the value for the param.
protected String | _target the target frame to open in.
protected String | _title the title attribute this link belongs to.
protected String | _trailParams additional parameters after the above parameter is generated.
Fields inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
_alignment
Constructor Summary
LinkCellRenderer()
Method Summary
String | getCellValue(WebTable table, Object data, int row, int col) should the link data be encodeed?
void | setCssClass(String cssClass)
void | setCssId(String cssId)
void | setLink(String link)
void | setOnclick(String onclick)
void | setOndblclick(String ondblclick)
void | setOnmouseout(String onmouseout)
void | setOnmouseover(String onmouseover)
void | setParam(String param)
void | setParamColumn(int paramColumn)
void | setParamValue(String paramValue)
void | setRenderer(CellRenderer delegateRenderer) used to set the renderer to delgate to.
void | setTarget(String target)
void | setTitle(String title)
void | setTrailParams(String trailParams)
Methods inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
getAlignment, isAligned, renderCell, setAlignment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_delegateRenderer

protected CellRenderer _delegateRenderer
this is the actual renderer tha will be used to display the text

_cssClass

protected String _cssClass
the CSS class this link belongs to. Optional

_cssId

protected String _cssId
the id attribute this link belongs to. Optional

_link

protected String _link
this is the link we are setting (required)

_onclick

protected String _onclick
the (Java)script/ function to execute when the link is clicked. Optional

_ondblclick

protected String _ondblclick
the (Java)script/ function to execute when the link is clicked twice. Optional

_onmouseout

protected String _onmouseout
the (Java)script/ function to execute when cursor is away from the link. Optional

_onmouseover

protected String _onmouseover
the (Java)script/ function to execute when cursor is over the link. Optional

_param

protected String _param
if set there will be a parameter attached to link. (optional) This should be extended to allow multiple parameters

_paramValue

protected String _paramValue
directly set the value for the param. Will overide paramColumn if set. optional. Either this or paramColumn must be set if param is used. Will be ignored if param not used

_target

protected String _target
the target frame to open in. Optional

_title

protected String _title
the title attribute this link belongs to. Optional

_trailParams

protected String _trailParams
additional parameters after the above parameter is generated. Optional

_paramColumn

protected int _paramColumn
if used the param value will be taken from another column in the table. Useful if each row needs a different paramter. The paramter can be taken from a hidden cell. if paramValue is also set it will overrid this. (option either this or paramValue must be set if param is used. Will be ignored if param not used

Constructor Detail

LinkCellRenderer

public LinkCellRenderer()
Method Detail

getCellValue

public String getCellValue(WebTable table,
                           Object data,
                           int row,
                           int col)
should the link data be encodeed?

Specified by:
getCellValue in class AbstractCellRenderer

setCssClass

public void setCssClass(String cssClass)

setCssId

public void setCssId(String cssId)

setLink

public void setLink(String link)

setOnclick

public void setOnclick(String onclick)

setOndblclick

public void setOndblclick(String ondblclick)

setOnmouseout

public void setOnmouseout(String onmouseout)

setOnmouseover

public void setOnmouseover(String onmouseover)

setParam

public void setParam(String param)

setParamColumn

public void setParamColumn(int paramColumn)

setParamValue

public void setParamValue(String paramValue)

setRenderer

public void setRenderer(CellRenderer delegateRenderer)
used to set the renderer to delgate to. if the render is an AbstractCellRenderer then it will take the alignment from the delegate renderer and set it that way.

setTarget

public void setTarget(String target)

setTitle

public void setTitle(String title)

setTrailParams

public void setTrailParams(String trailParams)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NumericCellRenderer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.table.renderer
Class NumericCellRenderer

java.lang.Object
    extended by  org.apache.struts2.components.table.renderer.AbstractCellRenderer
        extended by  org.apache.struts2.components.table.renderer.NumericCellRenderer
All Implemented Interfaces:
CellRenderer
public class NumericCellRenderer
extends AbstractCellRenderer

Field Summary
(package private) DecimalFormat | _formater
(package private) String | _formatString this is the format string that DecimalFormat would use.
(package private) String | _negativeColor if set the is the color to use if Number is negative.
(package private) String | _positiveColor if set this is the color to render if number is positive
Fields inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
_alignment
Constructor Summary
NumericCellRenderer()
Method Summary
String | getCellValue(WebTable table, Object data, int row, int col) this is the method that subclasses need to implement to set their value.
protected void | processNumber(StringBuffer buf, String color, double cellValue)
void | setFormatString(String format)
void | setNegativeColor(String color)
void | setPositiveColor(String color)
Methods inherited from class org.apache.struts2.components.table.renderer.AbstractCellRenderer
getAlignment, isAligned, renderCell, setAlignment
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_formater

DecimalFormat _formater

_formatString

String _formatString
this is the format string that DecimalFormat would use.

See Also:
DecimalFormat

_negativeColor

String _negativeColor
if set the is the color to use if Number is negative.

_positiveColor

String _positiveColor
if set this is the color to render if number is positive

Constructor Detail

NumericCellRenderer

public NumericCellRenderer()
Method Detail

getCellValue

public String getCellValue(WebTable table,
                           Object data,
                           int row,
                           int col)
Description copied from class: AbstractCellRenderer
this is the method that subclasses need to implement to set their value. they should not override renderCell unless they want to change the alignmnent renderering

Specified by:
getCellValue in class AbstractCellRenderer

setFormatString

public void setFormatString(String format)

setNegativeColor

public void setNegativeColor(String color)

setPositiveColor

public void setPositiveColor(String color)

processNumber

protected void processNumber(StringBuffer buf,
                             String color,
                             double cellValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.components.template (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.components.template

Interface Summary
TemplateEngine | Any template language which wants to support UI tag templating needs to provide an implementation of this interface to handle rendering the template
TemplateEngineManager.EngineFactory | Abstracts loading of the template engine

Class Summary
BaseTemplateEngine | Base class for template engines.
FreemarkerTemplateEngine | Freemarker based template engine.
JspTemplateEngine | JSP based template engine.
Template | A template.
TemplateEngineManager | The TemplateEngineManager will return a template engine for the template
TemplateRenderingContext | Context used when rendering templates.
VelocityTemplateEngine | Velocity based template engine.


org.apache.struts2.components.template Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.components.template

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.components.template.BaseTemplateEngine (implements org.apache.struts2.components.template.TemplateEngine)
      • org.apache.struts2.components.template.FreemarkerTemplateEngine
      • org.apache.struts2.components.template.JspTemplateEngine
      • org.apache.struts2.components.template.VelocityTemplateEngine
    • org.apache.struts2.components.template.Template (implements java.lang.Cloneable)
    • org.apache.struts2.components.template.TemplateEngineManager
    • org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory (implements org.apache.struts2.components.template.TemplateEngineManager.EngineFactory)
    • org.apache.struts2.components.template.TemplateRenderingContext

Interface Hierarchy

  • org.apache.struts2.components.template.TemplateEngine
  • org.apache.struts2.components.template.TemplateEngineManager.EngineFactory


Uses of Package org.apache.struts2.components.template (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.components.template

Packages that use org.apache.struts2.components.template
org.apache.struts2.components
org.apache.struts2.components.template

Classes in org.apache.struts2.components.template used by org.apache.struts2.components
Template
A template.
TemplateEngineManager
The TemplateEngineManager will return a template engine for the template

Classes in org.apache.struts2.components.template used by org.apache.struts2.components.template
BaseTemplateEngine
Base class for template engines.
Template
A template.
TemplateEngine
Any template language which wants to support UI tag templating needs to provide an implementation of this interface to handle rendering the template
TemplateEngineManager.EngineFactory
Abstracts loading of the template engine
TemplateRenderingContext
Context used when rendering templates.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


TemplateEngine (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Interface TemplateEngine

All Known Implementing Classes:
BaseTemplateEngine, FreemarkerTemplateEngine, JspTemplateEngine, VelocityTemplateEngine
public interface TemplateEngine

Any template language which wants to support UI tag templating needs to provide an implementation of this interface to handle rendering the template

Method Summary
Map | getThemeProps(Template template) Get's the properties for the given template.
void | renderTemplate(TemplateRenderingContext templateContext) Renders the template

Method Detail

renderTemplate

void renderTemplate(TemplateRenderingContext templateContext)
                    throws Exception
Renders the template

Parameters:
templateContext - context for the given template.
Throws:
Exception - is thrown if there is a failure when rendering.

getThemeProps

Map getThemeProps(Template template)
Get's the properties for the given template.

Parameters:
template - the template.
Returns:
the properties as key value pairs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BaseTemplateEngine (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Class BaseTemplateEngine

java.lang.Object
    extended by  org.apache.struts2.components.template.BaseTemplateEngine
All Implemented Interfaces:
TemplateEngine
Direct Known Subclasses:
FreemarkerTemplateEngine, JspTemplateEngine, VelocityTemplateEngine
public abstract class BaseTemplateEngine
extends Object
implements TemplateEngine

Base class for template engines.

Field Summary
static String | DEFAULT_THEME_PROPERTIES_FILE_NAME The default theme properties file name.
private static Log | LOG
(package private) Map<String,Properties> | themeProps
Constructor Summary
BaseTemplateEngine()
Method Summary
protected String | getFinalTemplateName(Template template)
protected abstract String | getSuffix()
protected String | getThemePropertiesFileName()
Map | getThemeProps(Template template) Get's the properties for the given template.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.apache.struts2.components.template.TemplateEngine
renderTemplate

Field Detail

LOG

private static final Log LOG

DEFAULT_THEME_PROPERTIES_FILE_NAME

public static final String DEFAULT_THEME_PROPERTIES_FILE_NAME
The default theme properties file name. Default is 'theme.properties'

See Also:
Constant Field Values

themeProps

final Map<String,Properties> themeProps
Constructor Detail

BaseTemplateEngine

public BaseTemplateEngine()
Method Detail

getThemeProps

public Map getThemeProps(Template template)
Description copied from interface: TemplateEngine
Get's the properties for the given template.

Specified by:
getThemeProps in interface TemplateEngine
Parameters:
template - the template.
Returns:
the properties as key value pairs.

getFinalTemplateName

protected String getFinalTemplateName(Template template)

getThemePropertiesFileName

protected String getThemePropertiesFileName()

getSuffix

protected abstract String getSuffix()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FreemarkerTemplateEngine (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Class FreemarkerTemplateEngine

java.lang.Object
    extended by  org.apache.struts2.components.template.BaseTemplateEngine
        extended by  org.apache.struts2.components.template.FreemarkerTemplateEngine
All Implemented Interfaces:
TemplateEngine
public class FreemarkerTemplateEngine
extends BaseTemplateEngine

Freemarker based template engine.

Field Summary
(package private) static Class | bodyContent
private FreemarkerManager | freemarkerManager
private static Log | LOG
Fields inherited from class org.apache.struts2.components.template.BaseTemplateEngine
DEFAULT_THEME_PROPERTIES_FILE_NAME, themeProps
Constructor Summary
FreemarkerTemplateEngine()
Method Summary
protected String | getSuffix()
void | renderTemplate(TemplateRenderingContext templateContext) Renders the template
void | setFreemarkerManager(FreemarkerManager mgr)
Methods inherited from class org.apache.struts2.components.template.BaseTemplateEngine
getFinalTemplateName, getThemePropertiesFileName, getThemeProps
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

bodyContent

static Class bodyContent

freemarkerManager

private FreemarkerManager freemarkerManager

LOG

private static final Log LOG
Constructor Detail

FreemarkerTemplateEngine

public FreemarkerTemplateEngine()
Method Detail

setFreemarkerManager

public void setFreemarkerManager(FreemarkerManager mgr)

renderTemplate

public void renderTemplate(TemplateRenderingContext templateContext)
                    throws Exception
Description copied from interface: TemplateEngine
Renders the template

Parameters:
templateContext - context for the given template.
Throws:
Exception - is thrown if there is a failure when rendering.

getSuffix

protected String getSuffix()
Specified by:
getSuffix in class BaseTemplateEngine
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JspTemplateEngine (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Class JspTemplateEngine

java.lang.Object
    extended by  org.apache.struts2.components.template.BaseTemplateEngine
        extended by  org.apache.struts2.components.template.JspTemplateEngine
All Implemented Interfaces:
TemplateEngine
public class JspTemplateEngine
extends BaseTemplateEngine

JSP based template engine.

Field Summary
private static Log LOG
Fields inherited from class org.apache.struts2.components.template.BaseTemplateEngine
DEFAULT_THEME_PROPERTIES_FILE_NAME, themeProps
Constructor Summary
JspTemplateEngine()
Method Summary
protected String | getSuffix()
void | renderTemplate(TemplateRenderingContext templateContext) Renders the template
Methods inherited from class org.apache.struts2.components.template.BaseTemplateEngine
getFinalTemplateName, getThemePropertiesFileName, getThemeProps
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG
Constructor Detail

JspTemplateEngine

public JspTemplateEngine()
Method Detail

renderTemplate

public void renderTemplate(TemplateRenderingContext templateContext)
                    throws Exception
Description copied from interface: TemplateEngine
Renders the template

Parameters:
templateContext - context for the given template.
Throws:
Exception - is thrown if there is a failure when rendering.

getSuffix

protected String getSuffix()
Specified by:
getSuffix in class BaseTemplateEngine
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Template (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Class Template

java.lang.Object
    extended by  org.apache.struts2.components.template.Template
All Implemented Interfaces:
Cloneable
public class Template
extends Object
implements Cloneable

A template.

A template is used as a model for rendering output. This object contains basic common template information

Field Summary
(package private) String | dir
(package private) String | name
(package private) String | theme
Constructor Summary
Template(String dir, String theme, String name)
Constructor.
Method Summary
protected Object | clone()
String | getDir()
String | getName()
List | getPossibleTemplates(TemplateEngine engine)
String | getTheme()
String | toString() Constructs a string in the format /dir/theme/name.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

dir

String dir

theme

String theme

name

String name
Constructor Detail

Template

public Template(String dir,
                String theme,
                String name)
Constructor.

Parameters:
dir - base folder where the template is stored.
theme - the theme of the template
name - the name of the template.
Method Detail

getDir

public String getDir()

getTheme

public String getTheme()

getName

public String getName()

getPossibleTemplates

public List getPossibleTemplates(TemplateEngine engine)

toString

public String toString()
Constructs a string in the format /dir/theme/name.

Overrides:
toString in class Object
Returns:
a string in the format /dir/theme/name.

clone

protected Object clone()
                throws CloneNotSupportedException
Overrides:
clone in class Object
Throws:
CloneNotSupportedException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TemplateEngineManager (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Class TemplateEngineManager

java.lang.Object
    extended by  org.apache.struts2.components.template.TemplateEngineManager

public class TemplateEngineManager
extends Object

The TemplateEngineManager will return a template engine for the template

Nested Class Summary
(package private) static interface | TemplateEngineManager.EngineFactory Abstracts loading of the template engine
(package private) class | TemplateEngineManager.LazyEngineFactory Allows the template engine to be loaded at request time, so that engines that are missing dependencies aren't accessed if never used.
Field Summary
(package private) Container | container
static String | DEFAULT_TEMPLATE_TYPE The default template extenstion is ftl.
static String | DEFAULT_TEMPLATE_TYPE_CONFIG_KEY
(package private) String | defaultTemplateType
(package private) Map<String,TemplateEngineManager.EngineFactory> | templateEngines
Constructor Summary
TemplateEngineManager()
Method Summary
TemplateEngine | getTemplateEngine(Template template, String templateTypeOverride) Gets the TemplateEngine for the template name.
void | registerTemplateEngine(String templateExtension, TemplateEngine templateEngine) Registers the given template engine.
void | setContainer(Container container)
void | setDefaultTemplateType(String type)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_TEMPLATE_TYPE_CONFIG_KEY

public static final String DEFAULT_TEMPLATE_TYPE_CONFIG_KEY
See Also:
Constant Field Values

DEFAULT_TEMPLATE_TYPE

public static final String DEFAULT_TEMPLATE_TYPE
The default template extenstion is ftl.

See Also:
Constant Field Values

templateEngines

Map<String,TemplateEngineManager.EngineFactory> templateEngines

container

Container container

defaultTemplateType

String defaultTemplateType
Constructor Detail

TemplateEngineManager

public TemplateEngineManager()
Method Detail

setDefaultTemplateType

public void setDefaultTemplateType(String type)

setContainer

public void setContainer(Container container)

registerTemplateEngine

public void registerTemplateEngine(String templateExtension,
                                   TemplateEngine templateEngine)
Registers the given template engine.

Will add the engine to the existing list of known engines.

Parameters:
templateExtension - filename extension (eg. .jsp, .ftl, .vm).
templateEngine - the engine.

getTemplateEngine

public TemplateEngine getTemplateEngine(Template template,
                                        String templateTypeOverride)
Gets the TemplateEngine for the template name. If the template name has an extension (for instance foo.jsp), then this extension will be used to look up the appropriate TemplateEngine. If it does not have an extension, it will look for a Configuration setting "struts.ui.templateSuffix" for the extension, and if that is not set, it will fall back to "ftl" as the default.

Parameters:
template - Template used to determine which TemplateEngine to return
templateTypeOverride - Overrides the default template type
Returns:
the engine.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TemplateEngineManager.EngineFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Interface TemplateEngineManager.EngineFactory

All Known Implementing Classes:
TemplateEngineManager.LazyEngineFactory
Enclosing class:
TemplateEngineManager
static interface TemplateEngineManager.EngineFactory

Abstracts loading of the template engine

Method Summary
 TemplateEngine create()

Method Detail

create

TemplateEngine create()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TemplateEngineManager.LazyEngineFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Class TemplateEngineManager.LazyEngineFactory

java.lang.Object
    extended by  org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory
All Implemented Interfaces:
TemplateEngineManager.EngineFactory
Enclosing class:
TemplateEngineManager
 class TemplateEngineManager.LazyEngineFactory
extends Object
implements TemplateEngineManager.EngineFactory

Allows the template engine to be loaded at request time, so that engines that are missing dependencies aren't accessed if never used.

Field Summary
private  String name
Constructor Summary
TemplateEngineManager.LazyEngineFactory(String name)
Method Summary
 TemplateEngine create()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

private String name
Constructor Detail

TemplateEngineManager.LazyEngineFactory

public TemplateEngineManager.LazyEngineFactory(String name)
Method Detail

create

public TemplateEngine create()
Specified by:
create in interface TemplateEngineManager.EngineFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TemplateRenderingContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Class TemplateRenderingContext

java.lang.Object
    extended by  org.apache.struts2.components.template.TemplateRenderingContext

public class TemplateRenderingContext
extends Object

Context used when rendering templates.

Field Summary
(package private) Map | parameters
(package private) ValueStack | stack
(package private) UIBean | tag
(package private) Template | template
(package private) Writer | writer
Constructor Summary
TemplateRenderingContext(Template template, Writer writer, ValueStack stack, Map params, UIBean tag)
Constructor
Method Summary
Map | getParameters()
ValueStack | getStack()
UIBean | getTag()
Template | getTemplate()
Writer | getWriter()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

template

Template template

stack

ValueStack stack

parameters

Map parameters

tag

UIBean tag

writer

Writer writer
Constructor Detail

TemplateRenderingContext

public TemplateRenderingContext(Template template,
                                Writer writer,
                                ValueStack stack,
                                Map params,
                                UIBean tag)
Constructor

Parameters:
template - the template.
writer - the writer.
stack - OGNL value stack.
params - parameters to this template.
tag - the tag UI component.
Method Detail

getTemplate

public Template getTemplate()

getStack

public ValueStack getStack()

getParameters

public Map getParameters()

getTag

public UIBean getTag()

getWriter

public Writer getWriter()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VelocityTemplateEngine (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.components.template
Class VelocityTemplateEngine

java.lang.Object
    extended by  org.apache.struts2.components.template.BaseTemplateEngine
        extended by  org.apache.struts2.components.template.VelocityTemplateEngine
All Implemented Interfaces:
TemplateEngine
public class VelocityTemplateEngine
extends BaseTemplateEngine

Velocity based template engine.

Field Summary
private static Log | LOG
private VelocityManager | velocityManager
Fields inherited from class org.apache.struts2.components.template.BaseTemplateEngine
DEFAULT_THEME_PROPERTIES_FILE_NAME, themeProps
Constructor Summary
VelocityTemplateEngine()
Method Summary
protected String | getSuffix()
void | renderTemplate(TemplateRenderingContext templateContext) Renders the template
void | setVelocityManager(VelocityManager mgr)
Methods inherited from class org.apache.struts2.components.template.BaseTemplateEngine
getFinalTemplateName, getThemePropertiesFileName, getThemeProps
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

velocityManager

private VelocityManager velocityManager
Constructor Detail

VelocityTemplateEngine

public VelocityTemplateEngine()
Method Detail

setVelocityManager

public void setVelocityManager(VelocityManager mgr)

renderTemplate

public void renderTemplate(TemplateRenderingContext templateContext)
                    throws Exception
Description copied from interface: TemplateEngine
Renders the template

Parameters:
templateContext - context for the given template.
Throws:
Exception - is thrown if there is a failure when rendering.

getSuffix

protected String getSuffix()
Specified by:
getSuffix in class BaseTemplateEngine
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.config (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.config

Classes for Struts configuration and property handling.

See:
Description

Interface Summary
ClasspathConfigurationProvider.PageLocator PageLocator defines a locate method that can be used to discover server pages.

Class Summary
BeanSelectionProvider | Selects the implementations of key framework extension points, using the loaded property constants.
ClasspathConfigurationProvider | ClasspathConfigurationProvider loads the configuration by scanning the classpath or selected packages for Action classes.
ClasspathConfigurationProvider.ClasspathPageLocator | ClasspathPathLocator searches the classpath for server pages.
DefaultPropertiesProvider | Loads the default properties, separate from the usual struts.properties loading
DefaultSettings | DefaultSettings implements optional methods of Settings.
DelegatingSettings | DelegatingSettings stores an internal list of Settings objects to update settings or retrieve settings values.
LegacyPropertiesConfigurationProvider |
MethodConfigurationProvider | MethodConfigurationProvider creates ActionConfigs for potential action methods that lack a corresponding action mapping, so that these methods can be invoked without extra or redundant configuration.
NullResult | Null result to get around annotation defaults that can't be null
PropertiesSettings | A class to handle settings via a properties file.
ServletContextSingleton | This singleton holds an instance of the web servlet context.
Settings | Settings retrieves and exposes default values used by the framework.
StrutsXmlConfigurationProvider | Override Xwork class so we can use an arbitrary config file

Annotation Types Summary
Namespace | Allows an action class to specify its namespace
ParentPackage | Allows an action class to specify an xwork package to inherit
Result | Defines an XWork Result
Results | Defines multiple XWork Results

Package org.apache.struts2.config Description

Classes for Struts configuration and property handling.


org.apache.struts2.config Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.config

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap<K,V>
    • org.apache.struts2.config.BeanSelectionProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory (implements com.opensymphony.xwork2.inject.Factory<T>)
    • org.apache.struts2.config.ClasspathConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • org.apache.struts2.config.ClasspathConfigurationProvider.ClasspathPageLocator (implements org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator)
    • org.apache.struts2.config.LegacyPropertiesConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
      • org.apache.struts2.config.DefaultPropertiesProvider
    • org.apache.struts2.config.MethodConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
    • org.apache.struts2.config.NullResult (implements com.opensymphony.xwork2.Result)
    • org.apache.struts2.config.ServletContextSingleton
    • org.apache.struts2.config.Settings
      • org.apache.struts2.config.DefaultSettings
      • org.apache.struts2.config.DelegatingSettings
      • org.apache.struts2.config.PropertiesSettings
    • com.opensymphony.xwork2.config.providers.XmlConfigurationProvider (implements com.opensymphony.xwork2.config.ConfigurationProvider)
      • org.apache.struts2.config.StrutsXmlConfigurationProvider

Interface Hierarchy

  • org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator

Annotation Type Hierarchy

  • org.apache.struts2.config.Results (implements java.lang.annotation.Annotation)
  • org.apache.struts2.config.Result (implements java.lang.annotation.Annotation)
  • org.apache.struts2.config.ParentPackage (implements java.lang.annotation.Annotation)
  • org.apache.struts2.config.Namespace (implements java.lang.annotation.Annotation)


Uses of Package org.apache.struts2.config (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.config

Packages that use org.apache.struts2.config
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).

Classes in org.apache.struts2.config used by org.apache.struts2.config
ClasspathConfigurationProvider.PageLocator
PageLocator defines a locate method that can be used to discover server pages.
LegacyPropertiesConfigurationProvider
Result
Defines an XWork Result
ServletContextSingleton
This singleton holds an instance of the web servlet context.
Settings
Settings retrieves and exposes default values used by the framework.

Classes in org.apache.struts2.config used by org.apache.struts2.dispatcher
ClasspathConfigurationProvider.ClasspathPageLocator
ClasspathPathLocator searches the classpath for server pages.
ClasspathConfigurationProvider.PageLocator
PageLocator defines a locate method that can be used to discover server pages.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BeanSelectionProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class BeanSelectionProvider

java.lang.Object
    extended by  org.apache.struts2.config.BeanSelectionProvider
All Implemented Interfaces:
ConfigurationProvider
public class BeanSelectionProvider
extends Object
implements ConfigurationProvider

Selects the implementations of key framework extension points, using the loaded property constants. The implementations are selected from the container builder using the name defined in its associated property. The default implementation name will always be "struts".

The following is a list of the allowed extension points:

Type | Property | Scope | Description
com.opensymphony.xwork2.ObjectFactory | struts.objectFactory | singleton | Creates actions, results, and interceptors
com.opensymphony.xwork2.ActionProxyFactory | struts.actionProxyFactory | singleton | Creates the ActionProxy
com.opensymphony.xwork2.util.ObjectTypeDeterminer | struts.objectTypeDeterminer | singleton | Determines what the key and and element class of a Map or Collection should be
org.apache.struts2.dispatcher.mapper.ActionMapper | struts.mapper.class | singleton | Determines the ActionMapping from a request and a URI from an ActionMapping
org.apache.struts2.dispatcher.multipart.MultiPartRequest | struts.multipart.parser | per request | Parses a multipart request (file upload)
org.apache.struts2.views.freemarker.FreemarkerManager | struts.freemarker.manager.classname | singleton | Loads and processes Freemarker templates
org.apache.struts2.views.velocity.VelocityManager | struts.velocity.manager.classname | singleton | Loads and processes Velocity templates

Implementations are selected using the value of its associated property. That property is used to determine the implementation by:

  1. Trying to find an existing bean by that name in the container
  2. Trying to find a class by that name, then creating a new bean factory for it
  3. Creating a new delegation bean factory that delegates to the configured ObjectFactory at runtime

Finally, this class overrides certain properties if dev mode is enabled:

  • struts.i18n.reload = true
  • struts.configuration.xml.reload = true

Nested Class Summary
(package private)  class BeanSelectionProvider.ObjectFactoryDelegateFactory
Field Summary
static String | DEFAULT_BEAN_NAME
private static Log | LOG
Constructor Summary
BeanSelectionProvider()
Method Summary
(package private) void | alias(Class type, String key, ContainerBuilder builder, Properties props)
(package private) void | alias(Class type, String key, ContainerBuilder builder, Properties props, Scope scope)
void | destroy()
void | init(Configuration configuration)
void | loadPackages()
boolean | needsReload() Tells whether the ConfigurationProvider should reload its configuration
void | register(ContainerBuilder builder, LocatableProperties props)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_BEAN_NAME

public static final String DEFAULT_BEAN_NAME
See Also:
Constant Field Values

LOG

private static final Log LOG
Constructor Detail

BeanSelectionProvider

public BeanSelectionProvider()
Method Detail

destroy

public void destroy()
Specified by:
destroy in interface ConfigurationProvider

loadPackages

public void loadPackages()
                  throws ConfigurationException
Specified by:
loadPackages in interface ConfigurationProvider
Throws:
ConfigurationException

init

public void init(Configuration configuration)
          throws ConfigurationException
Specified by:
init in interface ConfigurationProvider
Throws:
ConfigurationException

needsReload

public boolean needsReload()
Description copied from interface: ConfigurationProvider
Tells whether the ConfigurationProvider should reload its configuration

Specified by:
needsReload in interface ConfigurationProvider
Returns:
true, whether the ConfigurationProvider should reload its configuration, falseotherwise.

register

public void register(ContainerBuilder builder,
                     LocatableProperties props)
Specified by:
register in interface ConfigurationProvider

alias

void alias(Class type,
           String key,
           ContainerBuilder builder,
           Properties props)

alias

void alias(Class type,
           String key,
           ContainerBuilder builder,
           Properties props,
           Scope scope)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BeanSelectionProvider.ObjectFactoryDelegateFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class BeanSelectionProvider.ObjectFactoryDelegateFactory

java.lang.Object
    extended by  org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory
All Implemented Interfaces:
Factory
Enclosing class:
BeanSelectionProvider
 class BeanSelectionProvider.ObjectFactoryDelegateFactory
extends Object
implements Factory

Field Summary
(package private) String | name
(package private) Class | type
Constructor Summary
BeanSelectionProvider.ObjectFactoryDelegateFactory(String name, Class type)
Method Summary
 Object create(Context context)
Creates an object to be injected.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

String name

type

Class type
Constructor Detail

BeanSelectionProvider.ObjectFactoryDelegateFactory

BeanSelectionProvider.ObjectFactoryDelegateFactory(String name,
                                                   Class type)
Method Detail

create

public Object create(Context context)
              throws Exception
Description copied from interface: Factory
Creates an object to be injected.

Specified by:
create in interface Factory
Parameters:
context - of this injection
Returns:
instance to be injected
Throws:
Exception - if unable to create object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClasspathConfigurationProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class ClasspathConfigurationProvider

java.lang.Object
    extended by  org.apache.struts2.config.ClasspathConfigurationProvider
All Implemented Interfaces:
ConfigurationProvider
public class ClasspathConfigurationProvider
extends Object
implements ConfigurationProvider

ClasspathConfigurationProvider loads the configuration by scanning the classpath or selected packages for Action classes.

This provider is only invoked if one or more action packages are passed to the dispatcher, usually from the web.xml. Configurations are created for objects that either implement Action or have classnames that end with "Action".

Nested Class Summary
static class | ClasspathConfigurationProvider.ClasspathPageLocator ClasspathPathLocator searches the classpath for server pages.
static interface | ClasspathConfigurationProvider.PageLocator PageLocator defines a locate method that can be used to discover server pages.
(package private) class | ClasspathConfigurationProvider.ResultMap<K,V> Creates ResultConfig objects from result annotations, and if a result isn't found, creates it on the fly.
Field Summary
private static String | ACTION Default suffix that can be used to indicate POJO "Action" classes.
private Configuration | configuration The XWork Configuration for this application.
private static String | DEFAULT_PAGE_EXTENSION The default page extension, to use in place of ".jsp".
private static String | DEFAULT_PAGE_PREFIX The default page prefix (or "path").
private static String | DEFAULT_PARENT_PACKAGE A setting to indicate a custom default parent package, to use in place of "struts-default".
private String | defaultPageExtension The defacto default page extension, usually associated with JavaServer Pages.
private String | defaultPagePrefix The default page prefix (none).
private String | defaultParentPackage Name of the framework's default configuration package, that application configuration packages automatically inherit.
private static String | FORCE_LOWER_CASE The default page prefix (or "path").
private boolean | forceLowerCase Whether to use a lowercase letter as the initial letter of an action.
private boolean | initialized Flag to indicate the packages have been loaded.
private Map<String,PackageConfig> | loadedPackageConfigs The package configurations for scanned Actions.
private static Log | LOG Logging instance for this class.
private String[] | packages The list of packages to scan for Action classes.
private ClasspathConfigurationProvider.PageLocator | pageLocator Helper class to scan class path for server pages.
Constructor Summary
ClasspathConfigurationProvider(String[] pkgs)
Create instance utilizing a list of packages to scan for Action classes.
Method Summary
void | destroy() Default destructor.
void | init(Configuration config) Register this application's configuration.
protected PackageConfig | loadPackageConfig(String actionNamespace, String actionPackage, Class actionClass) Finds or creates the package configuration for an Action class.
void | loadPackages() Clears and loads the list of packages registered at construction.
protected void | loadPackages(String[] pkgs) Scan a list of packages for Action classes.
boolean | needsReload() Indicates whether the packages have been initialized.
protected void | processActionClass(Class cls, String[] pkgs) Create a default action mapping for a class instance.
void | register(ContainerBuilder builder, LocatableProperties props)
void | setDefaultPageExtension(String defaultPageExtension) Register a default page extension to use when locating pages.
void | setDefaultPagePrefix(String defaultPagePrefix) Reigster a default page prefix to use when locating pages.
void | setDefaultParentPackage(String defaultParentPackage) Register a default parent package for the actions.
void | setForceLowerCase(String force) Whether to use a lowercase letter as the initial letter of an action.
void | setPageLocator(ClasspathConfigurationProvider.PageLocator locator) Register a PageLocation to use to scan for server pages.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_PAGE_PREFIX

private static final String DEFAULT_PAGE_PREFIX
The default page prefix (or "path"). Some applications may place pages under "/WEB-INF" as an extreme security precaution.

See Also:
Constant Field Values

defaultPagePrefix

private String defaultPagePrefix
The default page prefix (none).

DEFAULT_PAGE_EXTENSION

private static final String DEFAULT_PAGE_EXTENSION
The default page extension, to use in place of ".jsp".

See Also:
Constant Field Values

defaultPageExtension

private String defaultPageExtension
The defacto default page extension, usually associated with JavaServer Pages.

DEFAULT_PARENT_PACKAGE

private static final String DEFAULT_PARENT_PACKAGE
A setting to indicate a custom default parent package, to use in place of "struts-default".

See Also:
Constant Field Values

defaultParentPackage

private String defaultParentPackage
Name of the framework's default configuration package, that application configuration packages automatically inherit.

FORCE_LOWER_CASE

private static final String FORCE_LOWER_CASE
The default page prefix (or "path"). Some applications may place pages under "/WEB-INF" as an extreme security precaution.

See Also:
Constant Field Values

forceLowerCase

private boolean forceLowerCase
Whether to use a lowercase letter as the initial letter of an action. If false, actions will retain the initial uppercase letter from the Action class. (view.action (true) versus View.action (false)).

ACTION

private static final String ACTION
Default suffix that can be used to indicate POJO "Action" classes.

See Also:
Constant Field Values

pageLocator

private ClasspathConfigurationProvider.PageLocator pageLocator
Helper class to scan class path for server pages.

initialized

private boolean initialized
Flag to indicate the packages have been loaded.

See Also:
loadPackages(java.lang.String[]), needsReload()

packages

private String[] packages
The list of packages to scan for Action classes.

loadedPackageConfigs

private Map<String,PackageConfig> loadedPackageConfigs
The package configurations for scanned Actions.

See Also:
loadPackageConfig(java.lang.String, java.lang.String, java.lang.Class)

LOG

private static final Log LOG
Logging instance for this class.

configuration

private Configuration configuration
The XWork Configuration for this application.

See Also:
init(com.opensymphony.xwork2.config.Configuration)
Constructor Detail

ClasspathConfigurationProvider

public ClasspathConfigurationProvider(String[] pkgs)
Create instance utilizing a list of packages to scan for Action classes.

Parameters:
pkgs - List of pacaktges to scan for Action Classes.
Method Detail

setDefaultParentPackage

public void setDefaultParentPackage(String defaultParentPackage)
Register a default parent package for the actions.

Parameters:
defaultParentPackage - the new defaultParentPackage

setDefaultPageExtension

public void setDefaultPageExtension(String defaultPageExtension)
Register a default page extension to use when locating pages.

Parameters:
defaultPageExtension - the new defaultPageExtension

setDefaultPagePrefix

public void setDefaultPagePrefix(String defaultPagePrefix)
Reigster a default page prefix to use when locating pages.

Parameters:
defaultPagePrefix - the defaultPagePrefix to set

setForceLowerCase

public void setForceLowerCase(String force)
Whether to use a lowercase letter as the initial letter of an action.

Parameters:
force - If false, actions will retain the initial uppercase letter from the Action class. (view.action (true) versus View.action (false)).

setPageLocator

public void setPageLocator(ClasspathConfigurationProvider.PageLocator locator)
Register a PageLocation to use to scan for server pages.

Parameters:
locator -

loadPackages

protected void loadPackages(String[] pkgs)
Scan a list of packages for Action classes. This method loads classes that implement the Action interface or have a class name that ends with the letters "Action".

Parameters:
pkgs - A list of packages to load
See Also:
processActionClass(java.lang.Class, java.lang.String[])

processActionClass

protected void processActionClass(Class cls,
                                  String[] pkgs)
Create a default action mapping for a class instance. The namespace annotation is honored, if found, otherwise the Java package is converted into the namespace by changing the dots (".") to slashes ("/").

Parameters:
cls - Action or POJO instance to process
pkgs - List of packages that were scanned for Actions

loadPackageConfig

protected PackageConfig loadPackageConfig(String actionNamespace,
                                          String actionPackage,
                                          Class actionClass)
Finds or creates the package configuration for an Action class. The namespace annotation is honored, if found, and the namespace is checked for a parent configuration.

Parameters:
actionNamespace - The configuration namespace
actionPackage - The Java package containing our Action classes
actionClass - The Action class instance
Returns:
PackageConfig object for the Action class

destroy

public void destroy()
Default destructor. Override to provide behavior.

Specified by:
destroy in interface ConfigurationProvider

init

public void init(Configuration config)
Register this application's configuration.

Specified by:
init in interface ConfigurationProvider
Parameters:
config - The configuration for this application.

loadPackages

public void loadPackages()
                  throws ConfigurationException
Clears and loads the list of packages registered at construction.

Specified by:
loadPackages in interface ConfigurationProvider
Throws:
ConfigurationException

needsReload

public boolean needsReload()
Indicates whether the packages have been initialized.

Specified by:
needsReload in interface ConfigurationProvider
Returns:
True if the packages have been initialized

register

public void register(ContainerBuilder builder,
                     LocatableProperties props)
              throws ConfigurationException
Specified by:
register in interface ConfigurationProvider
Throws:
ConfigurationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClasspathConfigurationProvider.ClasspathPageLocator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class ClasspathConfigurationProvider.ClasspathPageLocator

java.lang.Object
    extended by  org.apache.struts2.config.ClasspathConfigurationProvider.ClasspathPageLocator
All Implemented Interfaces:
ClasspathConfigurationProvider.PageLocator
Enclosing class:
ClasspathConfigurationProvider
public static class ClasspathConfigurationProvider.ClasspathPageLocator
extends Object
implements ClasspathConfigurationProvider.PageLocator

ClasspathPathLocator searches the classpath for server pages.

Constructor Summary
ClasspathConfigurationProvider.ClasspathPageLocator()
Method Summary
 URL locate(String path)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClasspathConfigurationProvider.ClasspathPageLocator

public ClasspathConfigurationProvider.ClasspathPageLocator()
Method Detail

locate

public URL locate(String path)
Specified by:
locate in interface ClasspathConfigurationProvider.PageLocator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClasspathConfigurationProvider.PageLocator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Interface ClasspathConfigurationProvider.PageLocator

All Known Implementing Classes:
ClasspathConfigurationProvider.ClasspathPageLocator, Dispatcher.ServletContextPageLocator
Enclosing class:
ClasspathConfigurationProvider
public static interface ClasspathConfigurationProvider.PageLocator

PageLocator defines a locate method that can be used to discover server pages.

Method Summary
 URL locate(String path)

Method Detail

locate

URL locate(String path)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultPropertiesProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class DefaultPropertiesProvider

java.lang.Object
    extended by  org.apache.struts2.config.LegacyPropertiesConfigurationProvider
        extended by  org.apache.struts2.config.DefaultPropertiesProvider
All Implemented Interfaces:
ConfigurationProvider
public class DefaultPropertiesProvider
extends LegacyPropertiesConfigurationProvider

Loads the default properties, separate from the usual struts.properties loading

Constructor Summary
DefaultPropertiesProvider()
Method Summary
void | destroy()
void | init(Configuration configuration)
void | register(ContainerBuilder builder, LocatableProperties props)
Methods inherited from class org.apache.struts2.config.LegacyPropertiesConfigurationProvider
loadPackages, loadSettings, needsReload
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultPropertiesProvider

public DefaultPropertiesProvider()
Method Detail

destroy

public void destroy()
Specified by:
destroy in interface ConfigurationProvider
Overrides:
destroy in class LegacyPropertiesConfigurationProvider

init

public void init(Configuration configuration)
          throws ConfigurationException
Specified by:
init in interface ConfigurationProvider
Overrides:
init in class LegacyPropertiesConfigurationProvider
Throws:
ConfigurationException

register

public void register(ContainerBuilder builder,
                     LocatableProperties props)
              throws ConfigurationException
Specified by:
register in interface ConfigurationProvider
Overrides:
register in class LegacyPropertiesConfigurationProvider
Throws:
ConfigurationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultSettings (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class DefaultSettings

java.lang.Object
    extended by  org.apache.struts2.config.Settings
        extended by  org.apache.struts2.config.DefaultSettings

public class DefaultSettings
extends Settings

DefaultSettings implements optional methods of Settings.

This class creates and delegates to other settings by using an internal DelegatingSettings object.

Field Summary
(package private) Settings | delegate The Settings object that handles API calls.
protected Log | log The logging instance for this class.
Fields inherited from class org.apache.struts2.config.Settings
defaultImpl, locale, settingsImpl
Constructor Summary
DefaultSettings()
Constructs an instance by loading the standard property files, any custom property files (struts.custom.properties), and any custom message resources ().
Method Summary
 String getImpl(String aName)
Implements the Settings.get(String) method.
 boolean isSetImpl(String aName)
Implements the Settings.isSet(String) method.
 Iterator listImpl()
Implements the Settings.list() method.
 void setImpl(String name, String value)
Implements the Settings.set(String, String) method.
Methods inherited from class org.apache.struts2.config.Settings
get, getInstance, getLocale, getLocation, getLocationImpl, isSet, list, reset, set, setInstance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected Log log
The logging instance for this class.

delegate

Settings delegate
The Settings object that handles API calls.

Constructor Detail

DefaultSettings

public DefaultSettings()
Constructs an instance by loading the standard property files, any custom property files (struts.custom.properties), and any custom message resources ().

Since this constructor combines Settings from multiple resources, it utilizes a DelegatingSettings instance, and all API calls are handled by that instance.

Method Detail

setImpl

public void setImpl(String name,
                    String value)
             throws IllegalArgumentException,
                    UnsupportedOperationException
Description copied from class: Settings
Implements the Settings.set(String, String) method.

Overrides:
setImpl in class Settings
Parameters:
name - Identifer for the setting to change.
value - The new value for the setting.
Throws:
IllegalArgumentException - if an error occurs when setting the value.
UnsupportedOperationException - if the config implementation does not support setting values.
See Also:
Settings.set(String, String)

getImpl

public String getImpl(String aName)
               throws IllegalArgumentException
Description copied from class: Settings
Implements the Settings.get(String) method.

Overrides:
getImpl in class Settings
Parameters:
aName - The name of the setting value to retreive
Returns:
The setting value as a String
Throws:
IllegalArgumentException - if an error occurs when retrieving the value
See Also:
Settings.get(String)

isSetImpl

public boolean isSetImpl(String aName)
Description copied from class: Settings
Implements the Settings.isSet(String) method.

Overrides:
isSetImpl in class Settings
Parameters:
aName - Identifier for the setting value to change
Returns:
True if the setting exists and has a value, false otherwise.
See Also:
Settings.isSet(String)

listImpl

public Iterator listImpl()
Description copied from class: Settings
Implements the Settings.list() method.

Overrides:
listImpl in class Settings
Returns:
A list of the settings as an iterator
See Also:
Settings.list()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DelegatingSettings (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class DelegatingSettings

java.lang.Object
    extended by  org.apache.struts2.config.Settings
        extended by  org.apache.struts2.config.DelegatingSettings

 class DelegatingSettings
extends Settings

DelegatingSettings stores an internal list of Settings objects to update settings or retrieve settings values.

Each time a Settings method is called (get, set, list, and so forth), this class goes through the list of Settings objects and calls that method for each delegate, withholding any exception until all delegates have been called.

Field Summary
(package private)  Settings[] delegates
The Settings objects.
Fields inherited from class org.apache.struts2.config.Settings
defaultImpl, locale, settingsImpl
Constructor Summary
DelegatingSettings(Settings[] delegates)
Creates a new DelegatingSettings object utilizing the list of Settings objects.
Method Summary
 String getImpl(String name)
Implements the Settings.get(String) method.
 boolean isSetImpl(String aName)
Implements the Settings.isSet(String) method.
 Iterator listImpl()
Implements the Settings.list() method.
 void setImpl(String name, String value)
Implements the Settings.set(String, String) method.
Methods inherited from class org.apache.struts2.config.Settings
get, getInstance, getLocale, getLocation, getLocationImpl, isSet, list, reset, set, setInstance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

delegates

Settings[] delegates
The Settings objects.

Constructor Detail

DelegatingSettings

public DelegatingSettings(Settings[] delegates)
Creates a new DelegatingSettings object utilizing the list of Settings objects.

Parameters:
delegates - The Settings objects to use as delegates
Method Detail

setImpl

public void setImpl(String name,
                    String value)
             throws IllegalArgumentException,
                    UnsupportedOperationException
Description copied from class: Settings
Implements the Settings.set(String, String) method.

Overrides:
setImpl in class Settings
Parameters:
name - Identifer for the setting to change.
value - The new value for the setting.
Throws:
IllegalArgumentException - if an error occurs when setting the value.
UnsupportedOperationException - if the config implementation does not support setting values.
See Also:
Settings.set(String, String)

getImpl

public String getImpl(String name)
               throws IllegalArgumentException
Description copied from class: Settings
Implements the Settings.get(String) method.

Overrides:
getImpl in class Settings
Parameters:
name - The name of the setting value to retreive
Returns:
The setting value as a String
Throws:
IllegalArgumentException - if an error occurs when retrieving the value
See Also:
Settings.get(String)

isSetImpl

public boolean isSetImpl(String aName)
Description copied from class: Settings
Implements the Settings.isSet(String) method.

Overrides:
isSetImpl in class Settings
Parameters:
aName - Identifier for the setting value to change
Returns:
True if the setting exists and has a value, false otherwise.
See Also:
Settings.isSet(String)

listImpl

public Iterator listImpl()
Description copied from class: Settings
Implements the Settings.list() method.

Overrides:
listImpl in class Settings
Returns:
A list of the settings as an iterator
See Also:
Settings.list()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LegacyPropertiesConfigurationProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class LegacyPropertiesConfigurationProvider

java.lang.Object
    extended by  org.apache.struts2.config.LegacyPropertiesConfigurationProvider
All Implemented Interfaces:
ConfigurationProvider
Direct Known Subclasses:
DefaultPropertiesProvider
public class LegacyPropertiesConfigurationProvider
extends Object
implements ConfigurationProvider

Constructor Summary
LegacyPropertiesConfigurationProvider()
Method Summary
void | destroy()
void | init(Configuration configuration)
void | loadPackages()
protected void | loadSettings(LocatableProperties props, Settings settings)
boolean | needsReload() Tells whether the ConfigurationProvider should reload its configuration
void | register(ContainerBuilder builder, LocatableProperties props)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LegacyPropertiesConfigurationProvider

public LegacyPropertiesConfigurationProvider()
Method Detail

destroy

public void destroy()
Specified by:
destroy in interface ConfigurationProvider

init

public void init(Configuration configuration)
          throws ConfigurationException
Specified by:
init in interface ConfigurationProvider
Throws:
ConfigurationException

loadPackages

public void loadPackages()
                  throws ConfigurationException
Specified by:
loadPackages in interface ConfigurationProvider
Throws:
ConfigurationException

needsReload

public boolean needsReload()
Description copied from interface: ConfigurationProvider
Tells whether the ConfigurationProvider should reload its configuration

Specified by:
needsReload in interface ConfigurationProvider
Returns:
true, whether the ConfigurationProvider should reload its configuration, falseotherwise.

register

public void register(ContainerBuilder builder,
                     LocatableProperties props)
              throws ConfigurationException
Specified by:
register in interface ConfigurationProvider
Throws:
ConfigurationException

loadSettings

protected void loadSettings(LocatableProperties props,
                            Settings settings)
Parameters:
props -
settings -
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MethodConfigurationProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class MethodConfigurationProvider

java.lang.Object
    extended by  org.apache.struts2.config.MethodConfigurationProvider
All Implemented Interfaces:
ConfigurationProvider
public class MethodConfigurationProvider
extends Object
implements ConfigurationProvider

MethodConfigurationProvider creates ActionConfigs for potential action methods that lack a corresponding action mapping, so that these methods can be invoked without extra or redundant configuration.

As a dynamic method, the behavior of this class could be represented as:

int bang = name.indexOf('!');
if (bang != -1) {
String method = name.substring(bang + 1);
mapping.setMethod(method);
name = name.substring(0, bang);
}

If the action URL is "foo!bar", the the "foo" action is invoked, calling "bar" instead of "execute".

Instead of scanning each request at runtime, the provider creates action mappings for each method that could be matched using a dynamic approach. Advantages over a dynamic approach are that:

      The "dynamic" methods are not a special case, but just another action mapping, with all the features of a hardcoded mapping.
        When needed, a manual action can be provided for a method and invoked with the same syntax as an automatic action.
          The ConfigBrowser can display all potential actions.

Field Summary
private Configuration | configuration Stores configuration property.
(package private) ObjectFactory | factory Stores ObjectFactory property.
(package private) boolean | reload Store needsReload property.
Constructor Summary
MethodConfigurationProvider()
Method Summary
protected boolean | addDynamicMethods(Map actions, String actionName, ActionConfig actionConfig) Scans class for potential Action mehods, automatically generating and registering ActionConfigs as needed.
void | destroy()
private ObjectFactory | getObjectFactory() Provides ObjectFactory property.
void | init(Configuration configuration)
void | loadPackages()
boolean | needsReload() Tells whether the ConfigurationProvider should reload its configuration
void | register(ContainerBuilder containerBuilder, LocatableProperties locatableProperties)
void | setConfiguration(Configuration configuration) Updates configuration property.
void | setObjectFactory(ObjectFactory factory) Updates ObjectFactory property.
private boolean | upperAt(int pos, String string) Verifies that character at a String position is upper case.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

configuration

private Configuration configuration
Stores configuration property.

reload

boolean reload
Store needsReload property.

factory

ObjectFactory factory
Stores ObjectFactory property.

Constructor Detail

MethodConfigurationProvider

public MethodConfigurationProvider()
Method Detail

setConfiguration

public void setConfiguration(Configuration configuration)
Updates configuration property.

Parameters:
configuration - New configuration

destroy

public void destroy()
Specified by:
destroy in interface ConfigurationProvider

init

public void init(Configuration configuration)
          throws ConfigurationException
Specified by:
init in interface ConfigurationProvider
Throws:
ConfigurationException

register

public void register(ContainerBuilder containerBuilder,
                     LocatableProperties locatableProperties)
              throws ConfigurationException
Specified by:
register in interface ConfigurationProvider
Throws:
ConfigurationException

loadPackages

public void loadPackages()
                  throws ConfigurationException
Specified by:
loadPackages in interface ConfigurationProvider
Throws:
ConfigurationException

needsReload

public boolean needsReload()
Description copied from interface: ConfigurationProvider
Tells whether the ConfigurationProvider should reload its configuration

Specified by:
needsReload in interface ConfigurationProvider
Returns:
true, whether the ConfigurationProvider should reload its configuration, falseotherwise.

setObjectFactory

public void setObjectFactory(ObjectFactory factory)
Updates ObjectFactory property.

Parameters:
factory -

getObjectFactory

private ObjectFactory getObjectFactory()
                                throws ConfigurationException
Provides ObjectFactory property.

Returns:
Throws:
ConfigurationException - if ObjectFactory has not been set.

upperAt

private boolean upperAt(int pos,
                        String string)
Verifies that character at a String position is upper case.

Parameters:
pos - Position to test
string - Text containing position
Returns:
True if character at a String position is upper case

addDynamicMethods

protected boolean addDynamicMethods(Map actions,
                                    String actionName,
                                    ActionConfig actionConfig)
                             throws ConfigurationException
Scans class for potential Action mehods, automatically generating and registering ActionConfigs as needed.

The system iterates over the set of namespaces and the set of actionNames in a Configuration and retrieves each ActionConfig. For each ActionConfig that invokes the default "execute" method, the provider inspects the className class for other non-void, no-argument methods that do not begin with "getX" or "isX". For each qualifying method, the provider looks for another actionName in the same namespace that equals action.name + "!" + method.name. If that actionName is not found, System copies the ActionConfig, changes the method property, and adds it to the package configuration under the new actionName (action!method).

The system ignores ActionConfigs with a method property set so as to avoid creating alias methods for alias methods. The system ignores "getX" and "isX" methods since these would appear to be JavaBeans property and would not be intended as action methods. (The X represents any upper character or non-letter.)

Parameters:
actions - All ActionConfigs in namespace
actionName - Name of ActionConfig to analyze
actionConfig - ActionConfig corresponding to actionName
Throws:
ConfigurationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NullResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class NullResult

java.lang.Object
    extended by  org.apache.struts2.config.NullResult
All Implemented Interfaces:
Result, Serializable
public class NullResult
extends Object
implements Result

Null result to get around annotation defaults that can't be null

See Also:
Serialized Form

Constructor Summary
NullResult()
Method Summary
 void execute(ActionInvocation invocation)
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

NullResult

public NullResult()
Method Detail

execute

public void execute(ActionInvocation invocation)
             throws Exception
Description copied from interface: Result
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Specified by:
execute in interface Result
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertiesSettings (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class PropertiesSettings

java.lang.Object
    extended by  org.apache.struts2.config.Settings
        extended by  org.apache.struts2.config.PropertiesSettings

 class PropertiesSettings
extends Settings

A class to handle settings via a properties file.

Field Summary
(package private) static Log | LOG
(package private) LocatableProperties | settings
Fields inherited from class org.apache.struts2.config.Settings
defaultImpl, locale, settingsImpl
Constructor Summary
PropertiesSettings(String name)
Creates a new properties config given the name of a properties file.
Method Summary
String | getImpl(String aName) Gets a property from the properties file.
Location | getLocationImpl(String aName) Gets the location of a property from the properties file.
boolean | isSetImpl(String aName) Tests to see if a property exists in the properties file.
Iterator | listImpl() Lists all keys in the properties file.
void | setImpl(String aName, String aValue) Sets a property in the properties file.
Methods inherited from class org.apache.struts2.config.Settings
get, getInstance, getLocale, getLocation, isSet, list, reset, set, setInstance
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

settings

LocatableProperties settings

LOG

static Log LOG
Constructor Detail

PropertiesSettings

public PropertiesSettings(String name)
Creates a new properties config given the name of a properties file. The name is expected to NOT have the ".properties" file extension. So when new PropertiesSettings("foo") is called this class will look in the classpath for the foo.properties file.

Parameters:
name - the name of the properties file, excluding the ".properties" extension.
Method Detail

setImpl

public void setImpl(String aName,
                    String aValue)
Sets a property in the properties file.

Overrides:
setImpl in class Settings
Parameters:
aName - Identifer for the setting to change.
aValue - The new value for the setting.
See Also:
Settings.set(String, String)

getImpl

public String getImpl(String aName)
               throws IllegalArgumentException
Gets a property from the properties file.

Overrides:
getImpl in class Settings
Parameters:
aName - The name of the setting value to retreive
Returns:
The setting value as a String
Throws:
IllegalArgumentException - if an error occurs when retrieving the value
See Also:
Settings.get(String)

getLocationImpl

public Location getLocationImpl(String aName)
                         throws IllegalArgumentException
Gets the location of a property from the properties file.

Overrides:
getLocationImpl in class Settings
Parameters:
aName - Name of the setting to locate
Returns:
The location of the setting
Throws:
IllegalArgumentException - if an error occurs when retrieving the value
See Also:
Settings.getLocation(String)

isSetImpl

public boolean isSetImpl(String aName)
Tests to see if a property exists in the properties file.

Overrides:
isSetImpl in class Settings
Parameters:
aName - Identifier for the setting value to change
Returns:
True if the setting exists and has a value, false otherwise.
See Also:
Settings.isSet(String)

listImpl

public Iterator listImpl()
Lists all keys in the properties file.

Overrides:
listImpl in class Settings
Returns:
A list of the settings as an iterator
See Also:
Settings.list()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletContextSingleton (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class ServletContextSingleton

java.lang.Object
    extended by  org.apache.struts2.config.ServletContextSingleton

public class ServletContextSingleton
extends Object

This singleton holds an instance of the web servlet context.

This is needed for running Struts on Weblogic Server 6.1 because there is no provision to retrieve the servlet context from the web session object.

This class is created to bet that this singleton can be set by FilterDispatcherCompatWeblogic61 before the servlet context is needed by org.apache.struts2.lifecycle.SessionLifecycleListener which will use this object to get it.

Field Summary
private ServletContext | servletContext The web servlet context.
private static ServletContextSingleton | singleton The sole instance of this class.
Constructor Summary
private ServletContextSingleton()
Constructor which cannot be called publicly.
Method Summary
static ServletContextSingleton | getInstance() Answers the singleton.
ServletContext | getServletContext() Gets the servlet context
void | setServletContext(ServletContext context) Sets the servlet context
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

servletContext

private ServletContext servletContext
The web servlet context. Holding this is the purpose of this singleton.

singleton

private static ServletContextSingleton singleton
The sole instance of this class.

Constructor Detail

ServletContextSingleton

private ServletContextSingleton()
Constructor which cannot be called publicly.

Method Detail

getInstance

public static ServletContextSingleton getInstance()
Answers the singleton.

At some point, the caller must populate the web servlet context.

Returns:
Answers the singleton instance of this class

getServletContext

public ServletContext getServletContext()
Gets the servlet context

Returns:
The web servlet context

setServletContext

public void setServletContext(ServletContext context)
Sets the servlet context

Parameters:
context - The web servlet context
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Settings (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class Settings

java.lang.Object
    extended by  org.apache.struts2.config.Settings
Direct Known Subclasses:
DefaultSettings, DelegatingSettings, PropertiesSettings
 class Settings
extends Object

Settings retrieves and exposes default values used by the framework. An application can override a factory default and provide its own value for a setting.

Implementation of the class is pluggable (the default implementation is DefaultSettings). Pluggability gives applications to ability to customize how settings are retrieved. As an example, an application may wish to check some custom property store before delegating to the usual configuration and property files.

Key methods:

  • getLocale()
  • get(String)
  • set(String, String)
  • list()

Key methods for subclasses (plugins):

  • getImpl(String)
  • setImpl(String, String)
  • listImpl()
  • isSetImpl(String)

Field Summary
(package private) static Settings | defaultImpl An instance of DefaultSettings to use when another implementation is not provided (plugged in).
(package private) static Locale | locale An instance of the default locale as specified by the struts.locale setting.
private static Log | LOG The Logging instance for this class.
(package private) static Settings | settingsImpl A pluggable implementation of Settings, provided through the setInstance(org.apache.struts2.config.Settings) method.
Constructor Summary
Settings()
Method Summary
static String get(String name)
Provides a setting value as a String.
private static Settings getDefaultInstance()
Creates a default Settings object.
 String getImpl(String name)
Implements the get(String) method.
static Settings getInstance()
Provides the Settings object.
static Locale getLocale()
Provides the Struts default locale.
static Location getLocation(String name)
Provides the Location of a setting.
 Location getLocationImpl(String name)
Implements the getLocation(String) method.
static boolean isSet(String name)
Determines whether or not a setting has a registered value.
 boolean isSetImpl(String name)
Implements the isSet(String) method.
static Iterator list()
Provides an Iterator of all properties names.
 Iterator listImpl()
Implements the list() method.
static void reset()
Resets the default and any plugin Setting instance to null.
static void set(String name, String value)
Registers a value for a setting.
 void setImpl(String name, String value)
Implements the set(String, String) method.
static void setInstance(Settings config)
Registers a custom Settings implementation (plugin), and resets the cached locale.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

settingsImpl

static Settings settingsImpl
A pluggable implementation of Settings, provided through the setInstance(org.apache.struts2.config.Settings) method.

defaultImpl

static Settings defaultImpl
An instance of DefaultSettings to use when another implementation is not provided (plugged in).

locale

static Locale locale
An instance of the default locale as specified by the struts.locale setting.

See Also:
getLocale()

LOG

private static final Log LOG
The Logging instance for this class.

Constructor Detail

Settings

Settings()
Method Detail

setInstance

public static void setInstance(Settings config)
                        throws IllegalStateException
Registers a custom Settings implementation (plugin), and resets the cached locale.

This method can only be called once.

Parameters:
config - a Settings implementation
Throws:
IllegalStateException - if an error occurs when setting the settings implementation.

getInstance

public static Settings getInstance()
Provides the Settings object.

This method will substitute the default instance if another instance is not registered.

Returns:
the Settings object.

getLocale

public static Locale getLocale()
Provides the Struts default locale.

This method utilizes the struts.locale setting, which should be given as the Java toString() representation of a Locale object ("en", "de_DE", "_GB", "en_US_WIN", "de__POSIX", "fr_MAC", and so forth).

If a struts.locale setting is not registered, then the default virtual machine locale is substituted and cached.

Returns:
the Struts default locale if specified or the VM default locale.
See Also:
Locale.getDefault()

isSet

public static boolean isSet(String name)
Determines whether or not a setting has a registered value.

This method is useful for testing for the existance of setting without throwing an IllegalArgumentException.

Parameters:
name - the name of a setting to test.
Returns:
true if the setting exists and has a value, false otherwise.

get

public static String get(String name)
                  throws IllegalArgumentException
Provides a setting value as a String.

The method will throw an IllegalArgumentException if an error occurs while retrieveing the property or if the property doesn't exist.

Parameters:
name - the name of the setting to retrieve.
Returns:
the setting value as a String.
Throws:
IllegalArgumentException - if an error occurs retrieving the property or the property does not exist.

getLocation

public static Location getLocation(String name)
                            throws IllegalArgumentException
Provides the Location of a setting.

The Location is utilized as part of precise error reporting.

This method will throw an IllegalArgumentException if an error occurs while retrieving the value or if the setting doesn't exist.

Parameters:
name - the name of the property to get.
Returns:
the Location of a property.
Throws:
IllegalArgumentException - if an error occurs retrieving the property or the property does not exist.

list

public static Iterator list()
Provides an Iterator of all properties names.

Returns:
an Iterator of all properties names.

isSetImpl

public boolean isSetImpl(String name)
Implements the isSet(String) method.

Parameters:
name - Identifier for the setting value to change
Returns:
True if the setting exists and has a value, false otherwise.
See Also:
isSet(String)

set

public static void set(String name,
                       String value)
                throws IllegalArgumentException,
                       UnsupportedOperationException
Registers a value for a setting.

This method raises an exception if an error occurs when setting the value or if the settings implementation does not support setting values.

Parameters:
name - the name of the setting.
value - the value to register for the setting.
Throws:
IllegalArgumentException - if an error occurs when setting the value.
UnsupportedOperationException - if the config implementation does not support setting values.

setImpl

public void setImpl(String name,
                    String value)
             throws IllegalArgumentException,
                    UnsupportedOperationException
Implements the set(String, String) method.

Parameters:
name - Identifer for the setting to change.
value - The new value for the setting.
Throws:
IllegalArgumentException - if an error occurs when setting the value.
UnsupportedOperationException - if the config implementation does not support setting values.
See Also:
set(String, String)

getImpl

public String getImpl(String name)
               throws IllegalArgumentException
Implements the get(String) method.

Parameters:
name - The name of the setting value to retreive
Returns:
The setting value as a String
Throws:
IllegalArgumentException - if an error occurs when retrieving the value
See Also:
get(String)

getLocationImpl

public Location getLocationImpl(String name)
                         throws IllegalArgumentException
Implements the getLocation(String) method.

Parameters:
name - Name of the setting to locate
Returns:
The location of the setting
Throws:
IllegalArgumentException - if an error occurs when retrieving the value
See Also:
getLocation(String)

listImpl

public Iterator listImpl()
Implements the list() method.

Returns:
A list of the settings as an iterator
See Also:
list()

getDefaultInstance

private static Settings getDefaultInstance()
Creates a default Settings object.

A default implementation may be specified by the struts.configuration setting; otherwise, this method instantiates DefaultSettings as the default implementation.

Returns:
A default Settings object.

reset

public static void reset()
Resets the default and any plugin Setting instance to null.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsXmlConfigurationProvider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class StrutsXmlConfigurationProvider

java.lang.Object
    extended by  com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
        extended by  org.apache.struts2.config.StrutsXmlConfigurationProvider
All Implemented Interfaces:
ConfigurationProvider
public class StrutsXmlConfigurationProvider
extends XmlConfigurationProvider

Override Xwork class so we can use an arbitrary config file

Field Summary
private File | baseDir
private String | filename
private static Log | LOG
private String | reloadKey
private ServletContext | servletContext
Constructor Summary
StrutsXmlConfigurationProvider(boolean errorIfMissing)
Constructs the configuration provider
StrutsXmlConfigurationProvider(String filename, boolean errorIfMissing, ServletContext ctx)
Constructs the configuration provider
Method Summary
protected URL | findInFileSystem(String fileName)
protected Iterator<URL> | getConfigurationUrls(String fileName) Look for the configuration file on the classpath and in the file system
void | loadPackages()
boolean | needsReload() Overrides needs reload to ensure it is only checked once per request
void | register(ContainerBuilder containerBuilder, LocatableProperties props)
String | toString()
Methods inherited from class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
addAction, addPackage, addResultTypes, buildExceptionMappings, buildInterceptorList, buildPackageContext, buildResults, destroy, equals, getDtdMappings, hashCode, init, loadDefaultActionRef, loadDefaultClassRef, loadDefaultInterceptorRef, loadExtraConfiguration, loadGlobalResults, loadGobalExceptionMappings, loadInterceptors, loadInterceptorStack, loadInterceptorStacks, setDtdMappings, setObjectFactory, verifyAction, verifyResultType
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

LOG

private static final Log LOG

baseDir

private File baseDir

filename

private String filename

reloadKey

private String reloadKey

servletContext

private ServletContext servletContext
Constructor Detail

StrutsXmlConfigurationProvider

public StrutsXmlConfigurationProvider(boolean errorIfMissing)
Constructs the configuration provider

Parameters:
errorIfMissing - If we should throw an exception if the file can't be found

StrutsXmlConfigurationProvider

public StrutsXmlConfigurationProvider(String filename,
                                      boolean errorIfMissing,
                                      ServletContext ctx)
Constructs the configuration provider

Parameters:
filename - The filename to look for
errorIfMissing - If we should throw an exception if the file can't be found
ctx - Our ServletContext
Method Detail

register

public void register(ContainerBuilder containerBuilder,
                     LocatableProperties props)
              throws ConfigurationException
Specified by:
register in interface ConfigurationProvider
Overrides:
register in class XmlConfigurationProvider
Throws:
ConfigurationException

loadPackages

public void loadPackages()
Specified by:
loadPackages in interface ConfigurationProvider
Overrides:
loadPackages in class XmlConfigurationProvider

getConfigurationUrls

protected Iterator<URL> getConfigurationUrls(String fileName)
                                      throws IOException
Look for the configuration file on the classpath and in the file system

Overrides:
getConfigurationUrls in class XmlConfigurationProvider
Parameters:
fileName - The file name to retrieve
Throws:
IOException
See Also:
XmlConfigurationProvider.getConfigurationUrls(java.lang.String)

findInFileSystem

protected URL findInFileSystem(String fileName)
                        throws IOException
Throws:
IOException

needsReload

public boolean needsReload()
Overrides needs reload to ensure it is only checked once per request

Specified by:
needsReload in interface ConfigurationProvider
Overrides:
needsReload in class XmlConfigurationProvider
Returns:
true if the file has been changed since the last time we read it

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Namespace (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

org.apache.struts2.config
Annotation Type Namespace

@Retention(value=RUNTIME)
public @interface Namespace

Allows an action class to specify its namespace

Required Element Summary
 String value

Element Detail

value

public abstract String value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


ParentPackage (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

org.apache.struts2.config
Annotation Type ParentPackage

@Retention(value=RUNTIME)
public @interface ParentPackage

Allows an action class to specify an xwork package to inherit

Required Element Summary
 String value

Element Detail

value

public abstract String value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Result (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

org.apache.struts2.config
Annotation Type Result

@Retention(value=RUNTIME)
public @interface Result

Defines an XWork Result

Required Element Summary
 String value
Optional Element Summary
String | name
String[] | params
Class | type

Element Detail

value

public abstract String value

name

public abstract String name
Default:
"success"

type

public abstract Class type
Default:
org.apache.struts2.config.NullResult.class

params

public abstract String[] params
Default:
{}
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


Results (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT

org.apache.struts2.config
Annotation Type Results

@Retention(value=RUNTIME)
public @interface Results

Defines multiple XWork Results

Required Element Summary
 Result[] value

Element Detail

value

public abstract Result[] value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL DETAIL: ELEMENT


org.apache.struts2.dispatcher (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.dispatcher

Classes for action dispatching in Struts (the Controller part of MVC).

See:
Description

Interface Summary
DispatcherListener A interface to tag those that want to execute code on the init and destory of a Dispatcher.

Class Summary
ActionContextCleanUp | Special filter designed to work with the FilterDispatcher and allow for easier integration with SiteMesh.
ApplicationMap | A simple implementation of the Map interface to handle a collection of attributes and init parameters in a ServletContext object.
DefaultActionSupport | A simple action support class that sets properties to be able to serve
Dispatcher | A utility class the actual dispatcher delegates most of its tasks to.
FilterDispatcher | Master filter for Struts that handles four distinct responsibilities: Executing actions Cleaning up the ActionContext (see note) Serving static content Kicking off XWork's interceptor chain for the request lifecycle IMPORTANT: this filter must be mapped to all requests.
FilterDispatcherCompatWeblogic61 | When running Weblogic Server 6.1, this class should be specified in web.xml instead of FilterDispatcher.
HttpHeaderResult | A custom Result type for setting HTTP headers and status by optionally evaluating against the ValueStack.
PlainTextResult | A result that send the content out as plain text.
RequestMap | A simple implementation of the Map interface to handle a collection of request attributes.
ServletActionRedirectResult | This result uses the ActionMapper provided by the ActionMapperFactory to redirect the browser to a URL that invokes the specified action and (optional) namespace.
ServletDispatcherResult | Includes or forwards to a view (usually a jsp).
ServletRedirectResult | Calls the sendRedirect method to the location specified.
SessionMap | A simple implementation of the Map interface to handle a collection of HTTP session attributes.
StreamResult | A custom Result type for send raw data (via an InputStream) directly to the HttpServletResponse.
StrutsRequestWrapper | All Struts requests are wrapped with this class, which provides simple JSTL accessibility.
StrutsResultSupport | A base class for all Struts action execution results.
VelocityResult | Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

Package org.apache.struts2.dispatcher Description

Classes for action dispatching in Struts (the Controller part of MVC).


org.apache.struts2.dispatcher Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.dispatcher

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • org.apache.struts2.dispatcher.ApplicationMap (implements java.io.Serializable)
      • org.apache.struts2.dispatcher.RequestMap (implements java.io.Serializable)
      • org.apache.struts2.dispatcher.SessionMap (implements java.io.Serializable)
    • org.apache.struts2.dispatcher.ActionContextCleanUp (implements javax.servlet.Filter)
    • com.opensymphony.xwork2.ActionSupport (implements com.opensymphony.xwork2.Action, com.opensymphony.xwork2.LocaleProvider, java.io.Serializable, com.opensymphony.xwork2.TextProvider, com.opensymphony.xwork2.Validateable, com.opensymphony.xwork2.ValidationAware)
      • org.apache.struts2.dispatcher.DefaultActionSupport
    • org.apache.struts2.dispatcher.Dispatcher
    • org.apache.struts2.dispatcher.Dispatcher.Locator
    • org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator (implements org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator)
    • org.apache.struts2.dispatcher.FilterDispatcher (implements javax.servlet.Filter, org.apache.struts2.StrutsStatics)
      • org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61
    • org.apache.struts2.dispatcher.HttpHeaderResult (implements com.opensymphony.xwork2.Result)
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
        • org.apache.struts2.dispatcher.StrutsRequestWrapper
    • org.apache.struts2.dispatcher.StrutsResultSupport (implements com.opensymphony.xwork2.Result, org.apache.struts2.StrutsStatics)
      • org.apache.struts2.dispatcher.PlainTextResult
      • org.apache.struts2.dispatcher.ServletDispatcherResult
      • org.apache.struts2.dispatcher.ServletRedirectResult
        • org.apache.struts2.dispatcher.ServletActionRedirectResult
      • org.apache.struts2.dispatcher.StreamResult
      • org.apache.struts2.dispatcher.VelocityResult

Interface Hierarchy

  • org.apache.struts2.dispatcher.DispatcherListener


Uses of Package org.apache.struts2.dispatcher (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.dispatcher

Packages that use org.apache.struts2.dispatcher
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.multipart | Classes to help dispatch multipart HTTP requests.
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.portlet.result |
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.

Classes in org.apache.struts2.dispatcher used by org.apache.struts2
Dispatcher
A utility class the actual dispatcher delegates most of its tasks to.

Classes in org.apache.struts2.dispatcher used by org.apache.struts2.dispatcher
Dispatcher
A utility class the actual dispatcher delegates most of its tasks to.
DispatcherListener
A interface to tag those that want to execute code on the init and destory of a Dispatcher.
FilterDispatcher
Master filter for Struts that handles four distinct responsibilities: Executing actions Cleaning up the ActionContext (see note) Serving static content Kicking off XWork's interceptor chain for the request lifecycle

IMPORTANT: this filter must be mapped to all requests.

ServletActionRedirectResult
This result uses the ActionMapper provided by the ActionMapperFactory to redirect the browser to a URL that invokes the specified action and (optional) namespace.
ServletRedirectResult
Calls the sendRedirect method to the location specified.
StrutsResultSupport
A base class for all Struts action execution results.

Classes in org.apache.struts2.dispatcher used by org.apache.struts2.dispatcher.multipart
StrutsRequestWrapper
All Struts requests are wrapped with this class, which provides simple JSTL accessibility.

Classes in org.apache.struts2.dispatcher used by org.apache.struts2.portlet.dispatcher
Dispatcher
A utility class the actual dispatcher delegates most of its tasks to.

Classes in org.apache.struts2.dispatcher used by org.apache.struts2.portlet.result
StrutsResultSupport
A base class for all Struts action execution results.

Classes in org.apache.struts2.dispatcher used by org.apache.struts2.util
Dispatcher
A utility class the actual dispatcher delegates most of its tasks to.

Classes in org.apache.struts2.dispatcher used by org.apache.struts2.views.freemarker
StrutsResultSupport
A base class for all Struts action execution results.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DispatcherListener (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Interface DispatcherListener

public interface DispatcherListener

A interface to tag those that want to execute code on the init and destory of a Dispatcher.

Method Summary
void | dispatcherDestroyed(Dispatcher du) Called when the dispatcher is destroyed
void | dispatcherInitialized(Dispatcher du) Called when the dispatcher is initialized

Method Detail

dispatcherInitialized

void dispatcherInitialized(Dispatcher du)
Called when the dispatcher is initialized

Parameters:
du - The dispatcher instance

dispatcherDestroyed

void dispatcherDestroyed(Dispatcher du)
Called when the dispatcher is destroyed

Parameters:
du - The dispatcher instance
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionContextCleanUp (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class ActionContextCleanUp

java.lang.Object
    extended by  org.apache.struts2.dispatcher.ActionContextCleanUp
All Implemented Interfaces:
Filter
public class ActionContextCleanUp
extends Object
implements Filter

Special filter designed to work with the FilterDispatcher and allow for easier integration with SiteMesh. Normally, ordering your filters to have SiteMesh go first, and then FilterDispatcher go second is perfectly fine. However, sometimes you may wish to access Struts features, including the value stack, from within your SiteMesh decorators. Because FilterDispatcher cleans up the ActionContext, your decorator won't have access to the data you want.

By adding this filter, the FilterDispatcher will know to not clean up and instead defer cleanup to this filter. The ordering of the filters should then be:

  • this filter
  • SiteMesh filter
  • FilterDispatcher

Version:
$Date: 2006-12-08 14:57:59 -0500 (Fri, 08 Dec 2006) $ $Id: ActionContextCleanUp.java 484717 2006-12-08 19:57:59Z mrdon $
See Also:
FilterDispatcher, AbstractFilter, Dispatcher

Field Summary
private static String | COUNTER
private static Log | LOG
Constructor Summary
ActionContextCleanUp()
Method Summary
protected static void | cleanUp(ServletRequest req) Clean up the request of threadlocals if this is the last execution
void | destroy()
void | doFilter(ServletRequest req, ServletResponse res, FilterChain chain)
void | init(FilterConfig arg0)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

COUNTER

private static final String COUNTER
See Also:
Constant Field Values
Constructor Detail

ActionContextCleanUp

public ActionContextCleanUp()
Method Detail

doFilter

public void doFilter(ServletRequest req,
                     ServletResponse res,
                     FilterChain chain)
              throws IOException,
                     ServletException
Specified by:
doFilter in interface Filter
Throws:
IOException
ServletException
See Also:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)

cleanUp

protected static void cleanUp(ServletRequest req)
Clean up the request of threadlocals if this is the last execution

Parameters:
req - The servlet request

destroy

public void destroy()
Specified by:
destroy in interface Filter

init

public void init(FilterConfig arg0)
          throws ServletException
Specified by:
init in interface Filter
Throws:
ServletException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ApplicationMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class ApplicationMap

java.lang.Object
    extended by  java.util.AbstractMap
        extended by  org.apache.struts2.dispatcher.ApplicationMap
All Implemented Interfaces:
Serializable, Map
public class ApplicationMap
extends AbstractMap
implements Serializable

A simple implementation of the Map interface to handle a collection of attributes and init parameters in a ServletContext object. The entrySet() method enumerates over all servlet context attributes and init parameters and returns a collection of both. Note, this will occur lazily - only when the entry set is asked for.

See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
private ServletContext | context
private Set<Object> | entries
private static long | serialVersionUID
Constructor Summary
ApplicationMap(ServletContext ctx)
Creates a new map object given the servlet context.
Method Summary
void | clear() Removes all entries from the Map and removes all attributes from the servlet context.
Set | entrySet() Creates a Set of all servlet context attributes as well as context init parameters.
Object | get(Object key) Returns the servlet context attribute or init parameter based on the given key.
Object | put(Object key, Object value) Sets a servlet context attribute given a attribute name and value.
Object | remove(Object key) Removes the specified servlet context attribute.
Methods inherited from class java.util.AbstractMap
clone, containsKey, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

context

private ServletContext context

entries

private Set<Object> entries
Constructor Detail

ApplicationMap

public ApplicationMap(ServletContext ctx)
Creates a new map object given the servlet context.

Parameters:
ctx - the servlet context
Method Detail

clear

public void clear()
Removes all entries from the Map and removes all attributes from the servlet context.

Specified by:
clear in interface Map
Overrides:
clear in class AbstractMap

entrySet

public Set entrySet()
Creates a Set of all servlet context attributes as well as context init parameters.

Specified by:
entrySet in interface Map
Specified by:
entrySet in class AbstractMap
Returns:
a Set of all servlet context attributes as well as context init parameters.

get

public Object get(Object key)
Returns the servlet context attribute or init parameter based on the given key. If the entry is not found, null is returned.

Specified by:
get in interface Map
Overrides:
get in class AbstractMap
Parameters:
key - the entry key.
Returns:
the servlet context attribute or init parameter or null if the entry is not found.

put

public Object put(Object key,
                  Object value)
Sets a servlet context attribute given a attribute name and value.

Specified by:
put in interface Map
Overrides:
put in class AbstractMap
Parameters:
key - the name of the attribute.
value - the value to set.
Returns:
the attribute that was just set.

remove

public Object remove(Object key)
Removes the specified servlet context attribute.

Specified by:
remove in interface Map
Overrides:
remove in class AbstractMap
Parameters:
key - the attribute to remove.
Returns:
the entry that was just removed.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class DefaultActionSupport

java.lang.Object
    extended by  com.opensymphony.xwork2.ActionSupport
        extended by  org.apache.struts2.dispatcher.DefaultActionSupport
All Implemented Interfaces:
Action, LocaleProvider, TextProvider, Validateable, ValidationAware, Serializable
public class DefaultActionSupport
extends ActionSupport

A simple action support class that sets properties to be able to serve

See Also:
Serialized Form

Field Summary
private static long | serialVersionUID
private String | successResultValue
Fields inherited from class com.opensymphony.xwork2.ActionSupport
LOG
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
DefaultActionSupport()
Constructor
Method Summary
String | execute() A default implementation that does nothing an returns "success".
String | getSuccessResultValue()
void | setSuccessResultValue(String successResultValue)
Methods inherited from class com.opensymphony.xwork2.ActionSupport
addActionError, addActionMessage, addFieldError, clearErrorsAndMessages, clone, doDefault, getActionErrors, getActionMessages, getErrorMessages, getErrors, getFieldErrors, getLocale, getText, getText, getText, getText, getText, getText, getText, getText, getText, getTexts, getTexts, hasActionErrors, hasActionMessages, hasErrors, hasFieldErrors, input, pause, setActionErrors, setActionMessages, setFieldErrors, validate
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

successResultValue

private String successResultValue
Constructor Detail

DefaultActionSupport

public DefaultActionSupport()
Constructor

Method Detail

execute

public String execute()
               throws Exception
Description copied from class: ActionSupport
A default implementation that does nothing an returns "success".

Subclasses should override this method to provide their business logic.

See also Action.execute().

Specified by:
execute in interface Action
Overrides:
execute in class ActionSupport
Returns:
returns Action.SUCCESS
Throws:
Exception - can be thrown by subclasses.

getSuccessResultValue

public String getSuccessResultValue()
Returns:
Returns the successResultValue.

setSuccessResultValue

public void setSuccessResultValue(String successResultValue)
Parameters:
successResultValue - The successResultValue to set.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dispatcher (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class Dispatcher

java.lang.Object
    extended by  org.apache.struts2.dispatcher.Dispatcher

public class Dispatcher
extends Object

A utility class the actual dispatcher delegates most of its tasks to. Each instance of the primary dispatcher holds an instance of this dispatcher to be shared for all requests.

See Also:
FilterDispatcher, Jsr168Dispatcher

Nested Class Summary
class | Dispatcher.Locator Provide an accessor class for static XWork utility.
private class | Dispatcher.ServletContextPageLocator Search classpath for a page.
Field Summary
private ConfigurationManager | configurationManager Store ConfigurationManager instance, set on init.
private static String | DEFAULT_CONFIGURATION_PATHS Provide list of default configuration files.
private static String | defaultEncoding Store state of StrutsConstants.STRUTS_I18N_ENCODING setting.
private static String | defaultLocale Store state of StrutsConstants.STRUTS_LOCALE setting.
private static boolean | devMode Store state of StrutsConstants.STRUTS_DEVMODE setting.
private static List<DispatcherListener> | dispatcherListeners Store list of DispatcherListeners.
private Map<String,String> | initParams
private static ThreadLocal<Dispatcher> | instance Provide a thread local instance.
private static Log | LOG Provide a logging instance.
private static String | multipartSaveDir Store state of StrutsConstants.STRUTS_MULTIPART_SAVEDIR setting.
private boolean | paramsWorkaroundEnabled Store state of STRUTS_DISPATCHER_PARAMETERSWORKAROUND.
private static boolean | portletSupportActive Store whether portlet support is active (set to true by Jsr168Dispatcher).
private ServletContext | servletContext
Constructor Summary
Dispatcher(ServletContext servletContext, Map<String,String> initParams)
Create the Dispatcher instance for a given ServletContext and set of initialization parameters.
Method Summary
static void | addDispatcherListener(DispatcherListener listener) Add a dispatcher lifecycle listener.
void | cleanup() Releases all instances bound to this dispatcher instance.
Map<String,Object> | createContextMap(HttpServletRequest request, HttpServletResponse response, ActionMapping mapping, ServletContext context) Create a context map containing all the wrapped request objects
HashMap<String,Object> | createContextMap(Map requestMap, Map parameterMap, Map sessionMap, Map applicationMap, HttpServletRequest request, HttpServletResponse response, ServletContext servletContext) Merge all application and servlet attributes into a single HashMap to represent the entire Action context.
ConfigurationManager | getConfigurationManager() Expose the ConfigurationManager instance.
Container | getContainer() Expose the dependency injection container.
static Dispatcher | getInstance() Provide the dispatcher instance for the current thread.
private String | getSaveDir(ServletContext servletContext) Return the path to save uploaded files to (this is configurable).
private void | init_AliasStandardObjects()
private void | init_CheckConfigurationReloading(Container container)
private void | init_CheckWebLogicWorkaround(Container container)
private void | init_CustomConfigurationProviders()
private void | init_DefaultProperties()
private void | init_FilterInitParameters()
private void | init_LegacyStrutsProperties()
private void | init_MethodConfigurationProvider()
private Container | init_PreloadConfiguration()
private void | init_TraditionalXmlConfigurations()
private void | init_ZeroConfiguration()
void | init() Load configurations, including both XML and zero-configuration strategies, and update optional settings, including whether to reload configurations and resource files.
boolean | isPortletSupportActive() Return true, if portlet support is active, false otherwise.
void | prepare(HttpServletRequest request, HttpServletResponse response) Prepare a request, including setting the encoding and locale.
static void | removeDispatcherListener(DispatcherListener listener) Remove a specific dispatcher lifecycle listener.
void | sendError(HttpServletRequest request, HttpServletResponse response, ServletContext ctx, int code, Exception e) Send an HTTP error response code.
void | serviceAction(HttpServletRequest request, HttpServletResponse response, ServletContext context, ActionMapping mapping) Load Action class for mapping and invoke the appropriate Action method, or go directly to the Result.
void | setConfigurationManager(ConfigurationManager mgr) Modify the ConfigurationManager instance
static void | setDefaultEncoding(String val) Modify state of StrutsConstants.STRUTS_I18N_ENCODING setting.
static void | setDefaultLocale(String val) Modify state of StrutsConstants.STRUTS_LOCALE setting.
static void | setDevMode(String mode) Modify state of StrutsConstants.STRUTS_DEVMODE setting.
static void | setInstance(Dispatcher instance) Store the dispatcher instance for this thread.
static void | setMultipartSaveDir(String val) Modify state of StrutsConstants.STRUTS_MULTIPART_SAVEDIR setting.
static void | setPortletSupportActive(boolean portletSupportActive) Modify the portlet support mode.
HttpServletRequest | wrapRequest(HttpServletRequest request, ServletContext servletContext) Wrap and return the given request or return the original request object.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG
Provide a logging instance.

instance

private static ThreadLocal<Dispatcher> instance
Provide a thread local instance.

dispatcherListeners

private static List<DispatcherListener> dispatcherListeners
Store list of DispatcherListeners.

configurationManager

private ConfigurationManager configurationManager
Store ConfigurationManager instance, set on init.

portletSupportActive

private static boolean portletSupportActive
Store whether portlet support is active (set to true by Jsr168Dispatcher).

devMode

private static boolean devMode
Store state of StrutsConstants.STRUTS_DEVMODE setting.

defaultEncoding

private static String defaultEncoding
Store state of StrutsConstants.STRUTS_I18N_ENCODING setting.

defaultLocale

private static String defaultLocale
Store state of StrutsConstants.STRUTS_LOCALE setting.

multipartSaveDir

private static String multipartSaveDir
Store state of StrutsConstants.STRUTS_MULTIPART_SAVEDIR setting.

DEFAULT_CONFIGURATION_PATHS

private static final String DEFAULT_CONFIGURATION_PATHS
Provide list of default configuration files.

See Also:
Constant Field Values

paramsWorkaroundEnabled

private boolean paramsWorkaroundEnabled
Store state of STRUTS_DISPATCHER_PARAMETERSWORKAROUND.

The workaround is for WebLogic. We try to autodect WebLogic on Dispatcher init. The workaround can also be enabled manually.

servletContext

private ServletContext servletContext

initParams

private Map<String,String> initParams
Constructor Detail

Dispatcher

public Dispatcher(ServletContext servletContext,
                  Map<String,String> initParams)
Create the Dispatcher instance for a given ServletContext and set of initialization parameters.

Parameters:
servletContext - Our servlet context
initParams - The set of initialization parameters
Method Detail

getInstance

public static Dispatcher getInstance()
Provide the dispatcher instance for the current thread.

Returns:
The dispatcher instance

setInstance

public static void setInstance(Dispatcher instance)
Store the dispatcher instance for this thread.

Parameters:
instance - The instance

addDispatcherListener

public static void addDispatcherListener(DispatcherListener listener)
Add a dispatcher lifecycle listener.

Parameters:
listener - The listener to add

removeDispatcherListener

public static void removeDispatcherListener(DispatcherListener listener)
Remove a specific dispatcher lifecycle listener.

Parameters:
listener - The listener

setDevMode

public static void setDevMode(String mode)
Modify state of StrutsConstants.STRUTS_DEVMODE setting.

Parameters:
mode - New setting

setDefaultLocale

public static void setDefaultLocale(String val)
Modify state of StrutsConstants.STRUTS_LOCALE setting.

Parameters:
val - New setting

setDefaultEncoding

public static void setDefaultEncoding(String val)
Modify state of StrutsConstants.STRUTS_I18N_ENCODING setting.

Parameters:
val - New setting

setMultipartSaveDir

public static void setMultipartSaveDir(String val)
Modify state of StrutsConstants.STRUTS_MULTIPART_SAVEDIR setting.

Parameters:
val - New setting

cleanup

public void cleanup()
Releases all instances bound to this dispatcher instance.

init_DefaultProperties

private void init_DefaultProperties()

init_LegacyStrutsProperties

private void init_LegacyStrutsProperties()

init_TraditionalXmlConfigurations

private void init_TraditionalXmlConfigurations()

init_ZeroConfiguration

private void init_ZeroConfiguration()

init_CustomConfigurationProviders

private void init_CustomConfigurationProviders()

init_MethodConfigurationProvider

private void init_MethodConfigurationProvider()

init_FilterInitParameters

private void init_FilterInitParameters()

init_AliasStandardObjects

private void init_AliasStandardObjects()

init_PreloadConfiguration

private Container init_PreloadConfiguration()

init_CheckConfigurationReloading

private void init_CheckConfigurationReloading(Container container)

init_CheckWebLogicWorkaround

private void init_CheckWebLogicWorkaround(Container container)

init

public void init()
Load configurations, including both XML and zero-configuration strategies, and update optional settings, including whether to reload configurations and resource files.

serviceAction

public void serviceAction(HttpServletRequest request,
                          HttpServletResponse response,
                          ServletContext context,
                          ActionMapping mapping)
                   throws ServletException
Load Action class for mapping and invoke the appropriate Action method, or go directly to the Result.

This method first creates the action context from the given parameters, and then loads an ActionProxy from the given action name and namespace. After that, the Action method is executed and output channels through the response object. Actions not found are sent back to the user via the sendError(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse, javax.servlet.ServletContext, int, java.lang.Exception) method, using the 404 return code. All other errors are reported by throwing a ServletException.

Parameters:
request - the HttpServletRequest object
response - the HttpServletResponse object
mapping - the action mapping object
context - Our ServletContext object
Throws:
ServletException - when an unknown error occurs (not a 404, but typically something that would end up as a 5xx by the servlet container)

createContextMap

public Map<String,Object> createContextMap(HttpServletRequest request,
                                           HttpServletResponse response,
                                           ActionMapping mapping,
                                           ServletContext context)
Create a context map containing all the wrapped request objects

Parameters:
request - The servlet request
response - The servlet response
mapping - The action mapping
context - The servlet context
Returns:
A map of context objects

createContextMap

public HashMap<String,Object> createContextMap(Map requestMap,
                                               Map parameterMap,
                                               Map sessionMap,
                                               Map applicationMap,
                                               HttpServletRequest request,
                                               HttpServletResponse response,
                                               ServletContext servletContext)
Merge all application and servlet attributes into a single HashMap to represent the entire Action context.

Parameters:
requestMap - a Map of all request attributes.
parameterMap - a Map of all request parameters.
sessionMap - a Map of all session attributes.
applicationMap - a Map of all servlet context attributes.
request - the HttpServletRequest object.
response - the HttpServletResponse object.
servletContext - the ServletContextmapping object.
Returns:
a HashMap representing the Action context.

getSaveDir

private String getSaveDir(ServletContext servletContext)
Return the path to save uploaded files to (this is configurable).

Parameters:
servletContext - Our ServletContext
Returns:
the path to save uploaded files to

prepare

public void prepare(HttpServletRequest request,
                    HttpServletResponse response)
Prepare a request, including setting the encoding and locale.

Parameters:
request - The request
response - The response

wrapRequest

public HttpServletRequest wrapRequest(HttpServletRequest request,
                                      ServletContext servletContext)
                               throws IOException
Wrap and return the given request or return the original request object.

This method transparently handles multipart data as a wrapped class around the given request. Override this method to handle multipart requests in a special way or to handle other types of requests. Note, MultiPartRequestWrapper is flexible - look first to that object before overriding this method to handle multipart data.

Parameters:
request - the HttpServletRequest object.
servletContext - Our ServletContext object
Returns:
a wrapped request or original request.
Throws:
IOException - on any error.
See Also:
MultiPartRequestWrapper

sendError

public void sendError(HttpServletRequest request,
                      HttpServletResponse response,
                      ServletContext ctx,
                      int code,
                      Exception e)
Send an HTTP error response code.

Parameters:
request - the HttpServletRequest object.
response - the HttpServletResponse object.
code - the HttpServletResponse error code (see HttpServletResponse for possible error codes).
e - the Exception that is reported.
ctx - the ServletContext object.

isPortletSupportActive

public boolean isPortletSupportActive()
Return true, if portlet support is active, false otherwise.

Returns:
true, if portlet support is active, false otherwise.

setPortletSupportActive

public static void setPortletSupportActive(boolean portletSupportActive)
Modify the portlet support mode.

Parameters:
portletSupportActive - true or false

getConfigurationManager

public ConfigurationManager getConfigurationManager()
Expose the ConfigurationManager instance.

Returns:
The instance

setConfigurationManager

public void setConfigurationManager(ConfigurationManager mgr)
Modify the ConfigurationManager instance

Parameters:
mgr - The configuration manager

getContainer

public Container getContainer()
Expose the dependency injection container.

Returns:
Our dependency injection container
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dispatcher.Locator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class Dispatcher.Locator

java.lang.Object
    extended by  org.apache.struts2.dispatcher.Dispatcher.Locator
Enclosing class:
Dispatcher
public class Dispatcher.Locator
extends Object

Provide an accessor class for static XWork utility.

Constructor Summary
Dispatcher.Locator()
Method Summary
 Location getLocation(Object obj)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Dispatcher.Locator

public Dispatcher.Locator()
Method Detail

getLocation

public Location getLocation(Object obj)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Dispatcher.ServletContextPageLocator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class Dispatcher.ServletContextPageLocator

java.lang.Object
    extended by  org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator
All Implemented Interfaces:
ClasspathConfigurationProvider.PageLocator
Enclosing class:
Dispatcher
private final class Dispatcher.ServletContextPageLocator
extends Object
implements ClasspathConfigurationProvider.PageLocator

Search classpath for a page.

Field Summary
private ClasspathConfigurationProvider.ClasspathPageLocator | classpathPageLocator
private ServletContext | context
Constructor Summary
private Dispatcher.ServletContextPageLocator(ServletContext context)
Method Summary
 URL locate(String path)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

context

private final ServletContext context

classpathPageLocator

private ClasspathConfigurationProvider.ClasspathPageLocator classpathPageLocator
Constructor Detail

Dispatcher.ServletContextPageLocator

private Dispatcher.ServletContextPageLocator(ServletContext context)
Method Detail

locate

public URL locate(String path)
Specified by:
locate in interface ClasspathConfigurationProvider.PageLocator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterDispatcher (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class FilterDispatcher

java.lang.Object
    extended by  org.apache.struts2.dispatcher.FilterDispatcher
All Implemented Interfaces:
Filter, StrutsStatics
Direct Known Subclasses:
FilterDispatcherCompatWeblogic61
public class FilterDispatcher
extends Object
implements StrutsStatics, Filter

Master filter for Struts that handles four distinct responsibilities:

  • Executing actions
  • Cleaning up the ActionContext (see note)
  • Serving static content
  • Kicking off XWork's interceptor chain for the request lifecycle

IMPORTANT: this filter must be mapped to all requests. Unless you know exactly what you are doing, always map to this URL pattern: /*

Executing actions

This filter executes actions by consulting the ActionMapper and determining if the requested URL should invoke an action. If the mapper indicates it should, the rest of the filter chain is stopped and the action is invoked. This is important, as it means that filters like the SiteMesh filter must be placed before this filter or they will not be able to decorate the output of actions.

Cleaning up the ActionContext

This filter will also automatically clean up the ActionContext for you, ensuring that no memory leaks take place. However, this can sometimes cause problems integrating with other products like SiteMesh. See ActionContextCleanUp for more information on how to deal with this.

Serving static content

This filter also serves common static content needed when using various parts of Struts, such as JavaScript files, CSS files, etc. It works by looking for requests to /struts/*, and then mapping the value after "/struts/" to common packages in Struts and, optionally, in your class path. By default, the following packages are automatically searched:

  • org.apache.struts2.static
  • template

This means that you can simply request /struts/xhtml/styles.css and the XHTML UI theme's default stylesheet will be returned. Likewise, many of the AJAX UI components require various JavaScript files, which are found in the org.apache.struts2.static package. If you wish to add additional packages to be searched, you can add a comma separated (space, tab and new line will do as well) list in the filter init parameter named "packages". Be careful, however, to expose any packages that may have sensitive information, such as properties file with database access credentials.

This filter supports the following init-params:

  • config - a comma-delimited list of XML configuration files to load.
  • actionPackages - a comma-delimited list of Java packages to scan for Actions.
  • configProviders - a comma-delimited list of Java classes that implement the ConfigurationProvider interface that should be used for building the Configuration.
  • * - any other parameters are treated as framework constants.

To use a custom Dispatcher, the createDispatcher() method could be overriden by the subclass.

Version:
$Date: 2007-01-03 14:53:44 -0500 (Wed, 03 Jan 2007) $ $Id: FilterDispatcher.java 492272 2007-01-03 19:53:44Z mrdon $
See Also:
ActionMapper, ActionContextCleanUp

Field Summary
private static ActionMapper | actionMapper Provide ActionMapper instance, set by injection.
protected Dispatcher | dispatcher Expose Dispatcher instance to subclass.
private static String | encoding Store state of StrutsConstants.STRUTS_I18N_ENCODING setting.
private FilterConfig | filterConfig Provide FilterConfig instance, set on init.
private Calendar | lastModifiedCal Provide a formatted date for setting heading information when caching static content.
private static Log | LOG Provide a logging instance.
private String[] | pathPrefixes Store set of path prefixes to use with static resources.
private static boolean | serveStatic Store state of StrutsConstants.STRUTS_SERVE_STATIC_CONTENT setting.
private static boolean | serveStaticBrowserCache Store state of StrutsConstants.STRUTS_SERVE_STATIC_BROWSER_CACHE setting.
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
FilterDispatcher()
Method Summary
protected void | copy(InputStream input, OutputStream output) Copy bytes from the input stream to the output stream.
protected Dispatcher | createDispatcher(FilterConfig filterConfig) Create a default Dispatcher that subclasses can override with a custom Dispatcher, if needed.
void | destroy() Calls dispatcher.cleanup, which in turn releases local threads and destroys any DispatchListeners.
void | doFilter(ServletRequest req, ServletResponse res, FilterChain chain) Process an action or handle a request a static resource.
protected InputStream | findInputStream(String name, String packagePrefix) Look for a static resource in the classpath.
protected void | findStaticResource(String name, HttpServletRequest request, HttpServletResponse response) Locate a static resource and copy directly to the response, setting the appropriate caching headers.
protected String | getContentType(String name) Determine the content type for the resource name.
protected FilterConfig | getFilterConfig() Expose the FilterConfig instance.
protected ServletContext | getServletContext() Provide a workaround for some versions of WebLogic.
void | init(FilterConfig filterConfig) Initializes the filter by creating a default dispatcher and setting the default packages for static resources.
protected String[] | parse(String packages) Create a string array from a comma-delimited list of packages.
protected HttpServletRequest | prepareDispatcherAndWrapRequest(HttpServletRequest request, HttpServletResponse response) Wrap and return the given request, if needed, so as to to transparently handle multipart data as a wrapped class around the given request.
static void | setActionMapper(ActionMapper mapper) Modify ActionMapper instance.
static void | setEncoding(String val) Modify state of StrutsConstants.STRUTS_I18N_ENCODING setting.
static void | setServeStaticBrowserCache(String val) Modify state of StrutsConstants.STRUTS_SERVE_STATIC_BROWSER_CACHE setting.
static void | setServeStaticContent(String val) Modify state of StrutsConstants.STRUTS_SERVE_STATIC_CONTENT setting.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG
Provide a logging instance.

pathPrefixes

private String[] pathPrefixes
Store set of path prefixes to use with static resources.

lastModifiedCal

private final Calendar lastModifiedCal
Provide a formatted date for setting heading information when caching static content.

serveStatic

private static boolean serveStatic
Store state of StrutsConstants.STRUTS_SERVE_STATIC_CONTENT setting.

serveStaticBrowserCache

private static boolean serveStaticBrowserCache
Store state of StrutsConstants.STRUTS_SERVE_STATIC_BROWSER_CACHE setting.

encoding

private static String encoding
Store state of StrutsConstants.STRUTS_I18N_ENCODING setting.

actionMapper

private static ActionMapper actionMapper
Provide ActionMapper instance, set by injection.

filterConfig

private FilterConfig filterConfig
Provide FilterConfig instance, set on init.

dispatcher

protected Dispatcher dispatcher
Expose Dispatcher instance to subclass.

Constructor Detail

FilterDispatcher

public FilterDispatcher()
Method Detail

init

public void init(FilterConfig filterConfig)
          throws ServletException
Initializes the filter by creating a default dispatcher and setting the default packages for static resources.

Specified by:
init in interface Filter
Parameters:
filterConfig - The filter configuration
Throws:
ServletException

destroy

public void destroy()
Calls dispatcher.cleanup, which in turn releases local threads and destroys any DispatchListeners.

Specified by:
destroy in interface Filter
See Also:
Filter.destroy()

createDispatcher

protected Dispatcher createDispatcher(FilterConfig filterConfig)
Create a default Dispatcher that subclasses can override with a custom Dispatcher, if needed.

Parameters:
filterConfig - Our FilterConfig
Returns:
Initialized Dispatcher

setServeStaticContent

public static void setServeStaticContent(String val)
Modify state of StrutsConstants.STRUTS_SERVE_STATIC_CONTENT setting.

Parameters:
val - New setting

setServeStaticBrowserCache

public static void setServeStaticBrowserCache(String val)
Modify state of StrutsConstants.STRUTS_SERVE_STATIC_BROWSER_CACHE setting.

Parameters:
val - New setting

setEncoding

public static void setEncoding(String val)
Modify state of StrutsConstants.STRUTS_I18N_ENCODING setting.

Parameters:
val - New setting

setActionMapper

public static void setActionMapper(ActionMapper mapper)
Modify ActionMapper instance.

Parameters:
mapper - New instance

getServletContext

protected ServletContext getServletContext()
Provide a workaround for some versions of WebLogic.

Servlet 2.3 specifies that the servlet context can be retrieved from the session. Unfortunately, some versions of WebLogic can only retrieve the servlet context from the filter config. Hence, this method enables subclasses to retrieve the servlet context from other sources.

Returns:
the servlet context.

getFilterConfig

protected FilterConfig getFilterConfig()
Expose the FilterConfig instance.

Returns:
Our FilterConfit instance

prepareDispatcherAndWrapRequest

protected HttpServletRequest prepareDispatcherAndWrapRequest(HttpServletRequest request,
                                                             HttpServletResponse response)
                                                      throws ServletException
Wrap and return the given request, if needed, so as to to transparently handle multipart data as a wrapped class around the given request.

Parameters:
request - Our ServletRequest object
response - Our ServerResponse object
Returns:
Wrapped HttpServletRequest object
Throws:
ServletException - on any error

parse

protected String[] parse(String packages)
Create a string array from a comma-delimited list of packages.

Parameters:
packages - A comma-delimited String listing packages
Returns:
A string array of packages

doFilter

public void doFilter(ServletRequest req,
                     ServletResponse res,
                     FilterChain chain)
              throws IOException,
                     ServletException
Process an action or handle a request a static resource.

The filter tries to match the request to an action mapping. If mapping is found, the action processes is delegated to the dispatcher's serviceAction method. If action processing fails, doFilter will try to create an error page via the dispatcher.

Otherwise, if the request is for a static resource, the resource is copied directly to the response, with the appropriate caching headers set.

If the request does not match an action mapping, or a static resource page, then it passes through.

Specified by:
doFilter in interface Filter
Throws:
IOException
ServletException
See Also:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)

findStaticResource

protected void findStaticResource(String name,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
                           throws IOException
Locate a static resource and copy directly to the response, setting the appropriate caching headers.

Parameters:
name - The resource name
request - The request
response - The response
Throws:
IOException - If anything goes wrong

getContentType

protected String getContentType(String name)
Determine the content type for the resource name.

Parameters:
name - The resource name
Returns:
The mime type

copy

protected void copy(InputStream input,
                    OutputStream output)
             throws IOException
Copy bytes from the input stream to the output stream.

Parameters:
input - The input stream
output - The output stream
Throws:
IOException - If anything goes wrong

findInputStream

protected InputStream findInputStream(String name,
                                      String packagePrefix)
                               throws IOException
Look for a static resource in the classpath.

Parameters:
name - The resource name
packagePrefix - The package prefix to use to locate the resource
Returns:
The inputstream of the resource
Throws:
IOException - If there is a problem locating the resource
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterDispatcherCompatWeblogic61 (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class FilterDispatcherCompatWeblogic61

java.lang.Object
    extended by  org.apache.struts2.dispatcher.FilterDispatcher
        extended by  org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61
All Implemented Interfaces:
Filter, StrutsStatics
public class FilterDispatcherCompatWeblogic61
extends FilterDispatcher

When running Weblogic Server 6.1, this class should be specified in web.xml instead of FilterDispatcher.

This class properly handles the weblogic.jar handling of servlet filters. There is one serious incompatibility, and that is that while FilterDispatcher.init(FilterConfig) throws a ServletException, this class's method setFilterConfig(FilterConfig) does not throw the exception. Since setFilterConfig(FilterConfig) invokes FilterDispatcher.init(FilterConfig), the setter must "swallow" the exception. This it does by logging the exception as an error.

Field Summary
private static Log log
Fields inherited from class org.apache.struts2.dispatcher.FilterDispatcher
dispatcher
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
FilterDispatcherCompatWeblogic61()
Method Summary
FilterConfig | getFilterConfig() This method is required by Weblogic 6.1 SP4 because they defined this as a required method just before the Servlet 2.3 specification was finalized.
protected ServletContext | getServletContext(HttpSession session) answers the servlet context.
void | setFilterConfig(FilterConfig filterConfig) dummy setter for FilterDispatcher.filterConfig; this method sets up the ServletContextSingleton with the servlet context from the filter configuration.
Methods inherited from class org.apache.struts2.dispatcher.FilterDispatcher
copy, createDispatcher, destroy, doFilter, findInputStream, findStaticResource, getContentType, getServletContext, init, parse, prepareDispatcherAndWrapRequest, setActionMapper, setEncoding, setServeStaticBrowserCache, setServeStaticContent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static Log log
Constructor Detail

FilterDispatcherCompatWeblogic61

public FilterDispatcherCompatWeblogic61()
Method Detail

setFilterConfig

public void setFilterConfig(FilterConfig filterConfig)
dummy setter for FilterDispatcher.filterConfig; this method sets up the ServletContextSingleton with the servlet context from the filter configuration.

This is needed by Weblogic Server 6.1 because it uses a slightly obsolete Servlet 2.3-minus spec whose Filter interface requires this method.

Parameters:
filterConfig - the filter configuration.

getServletContext

protected ServletContext getServletContext(HttpSession session)
answers the servlet context.

Servlet 2.3 specifies that this can be retrieved from the session. Unfortunately, weblogic.jar can only retrieve the servlet context from the filter config. Hence, this returns the servlet context from the singleton that was setup by setFilterConfig(FilterConfig).

Parameters:
session - the HTTP session. Not used
Returns:
the servlet context.

getFilterConfig

public FilterConfig getFilterConfig()
This method is required by Weblogic 6.1 SP4 because they defined this as a required method just before the Servlet 2.3 specification was finalized.

Overrides:
getFilterConfig in class FilterDispatcher
Returns:
the filter's filter configuration
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HttpHeaderResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class HttpHeaderResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.HttpHeaderResult
All Implemented Interfaces:
Result, Serializable
public class HttpHeaderResult
extends Object
implements Result

A custom Result type for setting HTTP headers and status by optionally evaluating against the ValueStack.

This result type takes the following parameters:

  • status - the http servlet response status code that should be set on a response.
  • parse - true by default. If set to false, the headers param will not be parsed for Ognl expressions.
  • headers - header values.
Example:

 <result name="success" type="httpheader">
   <param name="status">204</param>
   <param name="headers.a">a custom header value</param>
   <param name="headers.b">another custom header value</param>
 </result>

See Also:
Serialized Form

Field Summary
static String | DEFAULT_PARAM The default parameter
private Map<String,String> | headers
private boolean | parse
private static long | serialVersionUID
private int | status
Constructor Summary
HttpHeaderResult()
HttpHeaderResult(int status)
Method Summary
void | addHeader(String name, String value) Adds an HTTP header to the response
void | execute(ActionInvocation invocation) Sets the optional HTTP response status code and also re-sets HTTP headers after they've been optionally evaluated against the ValueStack.
Map | getHeaders() Returns a Map of all HTTP headers.
void | setParse(boolean parse) Sets whether or not the HTTP header values should be evaluated against the ValueStack (by default they are).
void | setStatus(int status) Sets the http servlet response status code that should be set on a response.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

DEFAULT_PARAM

public static final String DEFAULT_PARAM
The default parameter

See Also:
Constant Field Values

parse

private boolean parse

headers

private Map<String,String> headers

status

private int status
Constructor Detail

HttpHeaderResult

public HttpHeaderResult()

HttpHeaderResult

public HttpHeaderResult(int status)
Method Detail

getHeaders

public Map getHeaders()
Returns a Map of all HTTP headers.

Returns:
a Map of all HTTP headers.

setParse

public void setParse(boolean parse)
Sets whether or not the HTTP header values should be evaluated against the ValueStack (by default they are).

Parameters:
parse - true if HTTP header values should be evaluated agains the ValueStack, false otherwise.

setStatus

public void setStatus(int status)
Sets the http servlet response status code that should be set on a response.

Parameters:
status - the Http status code
See Also:
HttpServletResponse.setStatus(int)

addHeader

public void addHeader(String name,
                      String value)
Adds an HTTP header to the response

Parameters:
name -
value -

execute

public void execute(ActionInvocation invocation)
             throws Exception
Sets the optional HTTP response status code and also re-sets HTTP headers after they've been optionally evaluated against the ValueStack.

Specified by:
execute in interface Result
Parameters:
invocation - an encapsulation of the action execution state.
Throws:
Exception - if an error occurs when re-setting the headers.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PlainTextResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class PlainTextResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.dispatcher.PlainTextResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class PlainTextResult
extends StrutsResultSupport

A result that send the content out as plain text. Usefull typically when needed to display the raw content of a JSP or Html file for example.

  • location (default) = location of the file (jsp/html) to be displayed as plain text.
  • charSet (optional) = character set to be used. This character set will be used to set the response type (eg. Content-Type=text/plain; charset=UTF-8) and when reading using a Reader. Some example of charSet would be UTF-8, ISO-8859-1 etc.

 <action name="displayJspRawContent" >
   <result type="plaintext">/myJspFile.jsp</result>
 </action>

 <action name="displayJspRawContent" >
   <result type="plaintext">
      <param name="location">/myJspFile.jsp</param>
      <param name="charSet">UTF-8</param>
   </result>
 </action>

See Also:
Serialized Form

Field Summary
private static Log | _log
static int | BUFFER_SIZE
private String | charSet
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
DEFAULT_PARAM
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
PlainTextResult()
PlainTextResult(String location)
Method Summary
protected void | doExecute(String finalLocation, ActionInvocation invocation) Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed).
String | getCharSet() Set the character set
void | setCharSet(String charSet) Set the character set
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

BUFFER_SIZE

public static final int BUFFER_SIZE
See Also:
Constant Field Values

_log

private static final Log _log

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

charSet

private String charSet
Constructor Detail

PlainTextResult

public PlainTextResult()

PlainTextResult

public PlainTextResult(String location)
Method Detail

getCharSet

public String getCharSet()
Set the character set

Returns:
The character set

setCharSet

public void setCharSet(String charSet)
Set the character set

Parameters:
charSet - The character set

doExecute

protected void doExecute(String finalLocation,
                         ActionInvocation invocation)
                  throws Exception
Description copied from class: StrutsResultSupport
Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed). Subclasses must implement this class to handle custom logic for result handling.

Specified by:
doExecute in class StrutsResultSupport
Parameters:
finalLocation - the location (jsp page, action, etc) to go to.
invocation - the execution state of the action.
Throws:
Exception - if an error occurs while executing the result.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class RequestMap

java.lang.Object
    extended by  java.util.AbstractMap
        extended by  org.apache.struts2.dispatcher.RequestMap
All Implemented Interfaces:
Serializable, Map
public class RequestMap
extends AbstractMap
implements Serializable

A simple implementation of the Map interface to handle a collection of request attributes.

See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
private Set<Object> | entries
private HttpServletRequest | request
private static long | serialVersionUID
Constructor Summary
RequestMap(HttpServletRequest request)
Saves the request to use as the backing for getting and setting values
Method Summary
void | clear() Removes all attributes from the request as well as clears entries in this map.
Set | entrySet() Returns a Set of attributes from the http request.
Object | get(Object key) Returns the request attribute associated with the given key or null if it doesn't exist.
Object | put(Object key, Object value) Saves an attribute in the request.
Object | remove(Object key) Removes the specified request attribute.
Methods inherited from class java.util.AbstractMap
clone, containsKey, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

entries

private Set<Object> entries

request

private HttpServletRequest request
Constructor Detail

RequestMap

public RequestMap(HttpServletRequest request)
Saves the request to use as the backing for getting and setting values

Parameters:
request - the http servlet request.
Method Detail

clear

public void clear()
Removes all attributes from the request as well as clears entries in this map.

Specified by:
clear in interface Map
Overrides:
clear in class AbstractMap

entrySet

public Set entrySet()
Returns a Set of attributes from the http request.

Specified by:
entrySet in interface Map
Specified by:
entrySet in class AbstractMap
Returns:
a Set of attributes from the http request.

get

public Object get(Object key)
Returns the request attribute associated with the given key or null if it doesn't exist.

Specified by:
get in interface Map
Overrides:
get in class AbstractMap
Parameters:
key - the name of the request attribute.
Returns:
the request attribute or null if it doesn't exist.

put

public Object put(Object key,
                  Object value)
Saves an attribute in the request.

Specified by:
put in interface Map
Overrides:
put in class AbstractMap
Parameters:
key - the name of the request attribute.
value - the value to set.
Returns:
the object that was just set.

remove

public Object remove(Object key)
Removes the specified request attribute.

Specified by:
remove in interface Map
Overrides:
remove in class AbstractMap
Parameters:
key - the name of the attribute to remove.
Returns:
the value that was removed or null if the value was not found (and hence, not removed).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletActionRedirectResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class ServletActionRedirectResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.dispatcher.ServletRedirectResult
            extended by  org.apache.struts2.dispatcher.ServletActionRedirectResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class ServletActionRedirectResult
extends ServletRedirectResult

This result uses the ActionMapper provided by the ActionMapperFactory to redirect the browser to a URL that invokes the specified action and (optional) namespace. This is better than the ServletRedirectResult because it does not require you to encode the URL patterns processed by the ActionMapper in to your struts.xml configuration files. This means you can change your URL patterns at any point and your application will still work. It is strongly recommended that if you are redirecting to another action, you use this result rather than the standard redirect result.

See Also:
ActionMapper, Serialized Form

Field Summary
protected String | actionName
static String | DEFAULT_PARAM The default parameter
protected String | method
protected String | namespace
protected List<String> | prohibitedResultParam
private Map<String,String> | requestParameters
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.dispatcher.ServletRedirectResult
actionMapper, prependServletContext
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
ServletActionRedirectResult()
ServletActionRedirectResult(String actionName)
ServletActionRedirectResult(String actionName, String method)
ServletActionRedirectResult(String namespace, String actionName, String method)
Method Summary
ServletActionRedirectResult | addParameter(String key, Object value) Adds a request parameter to be added to the redirect url
void | execute(ActionInvocation invocation) Implementation of the execute method from the Result interface.
void | setActionName(String actionName) Sets the action name
void | setMethod(String method) Sets the method
void | setNamespace(String namespace) Sets the namespace
Methods inherited from class org.apache.struts2.dispatcher.ServletRedirectResult
doExecute, setActionMapper, setPrependServletContext
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

DEFAULT_PARAM

public static final String DEFAULT_PARAM
The default parameter

See Also:
Constant Field Values

actionName

protected String actionName

namespace

protected String namespace

method

protected String method

requestParameters

private Map<String,String> requestParameters

prohibitedResultParam

protected List<String> prohibitedResultParam
Constructor Detail

ServletActionRedirectResult

public ServletActionRedirectResult()

ServletActionRedirectResult

public ServletActionRedirectResult(String actionName)

ServletActionRedirectResult

public ServletActionRedirectResult(String actionName,
                                   String method)

ServletActionRedirectResult

public ServletActionRedirectResult(String namespace,
                                   String actionName,
                                   String method)
Method Detail

execute

public void execute(ActionInvocation invocation)
             throws Exception
Description copied from class: StrutsResultSupport
Implementation of the execute method from the Result interface. This will call the abstract method StrutsResultSupport.doExecute(String, ActionInvocation) after optionally evaluating the location as an OGNL evaluation.

Specified by:
execute in interface Result
Overrides:
execute in class StrutsResultSupport
Parameters:
invocation - the execution state of the action.
Throws:
Exception - if an error occurs while executing the result.
See Also:
Result.execute(com.opensymphony.xwork2.ActionInvocation)

setActionName

public void setActionName(String actionName)
Sets the action name

Parameters:
actionName - The name

setNamespace

public void setNamespace(String namespace)
Sets the namespace

Parameters:
namespace - The namespace

setMethod

public void setMethod(String method)
Sets the method

Parameters:
method - The method

addParameter

public ServletActionRedirectResult addParameter(String key,
                                                Object value)
Adds a request parameter to be added to the redirect url

Parameters:
key - The parameter name
value - The parameter value
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletDispatcherResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class ServletDispatcherResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.dispatcher.ServletDispatcherResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class ServletDispatcherResult
extends StrutsResultSupport

Includes or forwards to a view (usually a jsp). Behind the scenes Struts will use a RequestDispatcher, where the target servlet/JSP receives the same request/response objects as the original servlet/JSP. Therefore, you can pass data between them using request.setAttribute() - the Struts action is available.

There are three possible ways the result can be executed:

  • If we are in the scope of a JSP (a PageContext is available), PageContext's include method is called.
  • If there is no PageContext and we're not in any sort of include (there is no "javax.servlet.include.servlet_path" in the request attributes), then a call to forward is made.
  • Otherwise, include is called.
This result type takes the following parameters:
  • location (default) - the location to go to after execution (ex. jsp).
  • parse - true by default. If set to false, the location param will not be parsed for Ognl expressions.
Example:

 <result name="success" type="dispatcher">
   <param name="location">foo.jsp</param>
 </result>
This result follows the same rules from StrutsResultSupport.

See Also:
RequestDispatcher, Serialized Form

Field Summary
private static Log | log
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
DEFAULT_PARAM
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
ServletDispatcherResult()
ServletDispatcherResult(String location)
Method Summary
 void doExecute(String finalLocation, ActionInvocation invocation)
Dispatches to the given location.
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

log

private static final Log log
Constructor Detail

ServletDispatcherResult

public ServletDispatcherResult()

ServletDispatcherResult

public ServletDispatcherResult(String location)
Method Detail

doExecute

public void doExecute(String finalLocation,
                      ActionInvocation invocation)
               throws Exception
Dispatches to the given location. Does its forward via a RequestDispatcher. If the dispatch fails a 404 error will be sent back in the http response.

Specified by:
doExecute in class StrutsResultSupport
Parameters:
finalLocation - the location to dispatch to.
invocation - the execution state of the action
Throws:
Exception - if an error occurs. If the dispatch fails the error will go back via the HTTP request.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletRedirectResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class ServletRedirectResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.dispatcher.ServletRedirectResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
Direct Known Subclasses:
ServletActionRedirectResult
public class ServletRedirectResult
extends StrutsResultSupport

Calls the sendRedirect method to the location specified. The response is told to redirect the browser to the specified location (a new request from the client). The consequence of doing this means that the action (action instance, action errors, field errors, etc) that was just executed is lost and no longer available. This is because actions are built on a single-thread model. The only way to pass data is through the session or with web parameters (url?name=value) which can be OGNL expressions.

This result type takes the following parameters:

  • location (default) - the location to go to after execution.
  • parse - true by default. If set to false, the location param will not be parsed for Ognl expressions.

This result follows the same rules from StrutsResultSupport.

Example:

 <result name="success" type="redirect">
   <param name="location">foo.jsp</param>
   <param name="parse">false</param>
 </result>

See Also:
Serialized Form

Field Summary
protected ActionMapper | actionMapper
private static Log | log
protected boolean | prependServletContext
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
DEFAULT_PARAM
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
ServletRedirectResult()
ServletRedirectResult(String location)
Method Summary
protected  void doExecute(String finalLocation, ActionInvocation invocation)
Redirects to the location specified by calling HttpServletResponse.sendRedirect(String).
private static boolean isPathUrl(String url)
 void setActionMapper(ActionMapper mapper)
 void setPrependServletContext(boolean prependServletContext)
Sets whether or not to prepend the servlet context path to the redirected URL.
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

log

private static final Log log

prependServletContext

protected boolean prependServletContext

actionMapper

protected ActionMapper actionMapper
Constructor Detail

ServletRedirectResult

public ServletRedirectResult()

ServletRedirectResult

public ServletRedirectResult(String location)
Method Detail

setActionMapper

public void setActionMapper(ActionMapper mapper)

setPrependServletContext

public void setPrependServletContext(boolean prependServletContext)
Sets whether or not to prepend the servlet context path to the redirected URL.

Parameters:
prependServletContext - true to prepend the location with the servlet context path, false otherwise.

doExecute

protected void doExecute(String finalLocation,
                         ActionInvocation invocation)
                  throws Exception
Redirects to the location specified by calling HttpServletResponse.sendRedirect(String).

Specified by:
doExecute in class StrutsResultSupport
Parameters:
finalLocation - the location to redirect to.
invocation - an encapsulation of the action execution state.
Throws:
Exception - if an error occurs when redirecting.

isPathUrl

private static boolean isPathUrl(String url)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class SessionMap

java.lang.Object
    extended by  java.util.AbstractMap
        extended by  org.apache.struts2.dispatcher.SessionMap
All Implemented Interfaces:
Serializable, Map
public class SessionMap
extends AbstractMap
implements Serializable

A simple implementation of the Map interface to handle a collection of HTTP session attributes. The entrySet() method enumerates over all session attributes and creates a Set of entries. Note, this will occur lazily - only when the entry set is asked for.

See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
protected Set<Object> | entries
protected HttpServletRequest | request
private static long | serialVersionUID
protected HttpSession | session
Constructor Summary
SessionMap(HttpServletRequest request)
Creates a new session map given a http servlet request.
Method Summary
void | clear() Removes all attributes from the session as well as clears entries in this map.
Set | entrySet() Returns a Set of attributes from the http session.
Object | get(Object key) Returns the session attribute associated with the given key or null if it doesn't exist.
void | invalidate() Invalidate the http session.
Object | put(Object key, Object value) Saves an attribute in the session.
Object | remove(Object key) Removes the specified session attribute.
Methods inherited from class java.util.AbstractMap
clone, containsKey, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

session

protected HttpSession session

entries

protected Set<Object> entries

request

protected HttpServletRequest request
Constructor Detail

SessionMap

public SessionMap(HttpServletRequest request)
Creates a new session map given a http servlet request. Note, ths enumeration of request attributes will occur when the map entries are asked for.

Parameters:
request - the http servlet request object.
Method Detail

invalidate

public void invalidate()
Invalidate the http session.

clear

public void clear()
Removes all attributes from the session as well as clears entries in this map.

Specified by:
clear in interface Map
Overrides:
clear in class AbstractMap

entrySet

public Set entrySet()
Returns a Set of attributes from the http session.

Specified by:
entrySet in interface Map
Specified by:
entrySet in class AbstractMap
Returns:
a Set of attributes from the http session.

get

public Object get(Object key)
Returns the session attribute associated with the given key or null if it doesn't exist.

Specified by:
get in interface Map
Overrides:
get in class AbstractMap
Parameters:
key - the name of the session attribute.
Returns:
the session attribute or null if it doesn't exist.

put

public Object put(Object key,
                  Object value)
Saves an attribute in the session.

Specified by:
put in interface Map
Overrides:
put in class AbstractMap
Parameters:
key - the name of the session attribute.
value - the value to set.
Returns:
the object that was just set.

remove

public Object remove(Object key)
Removes the specified session attribute.

Specified by:
remove in interface Map
Overrides:
remove in class AbstractMap
Parameters:
key - the name of the attribute to remove.
Returns:
the value that was removed or null if the value was not found (and hence, not removed).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StreamResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class StreamResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.dispatcher.StreamResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class StreamResult
extends StrutsResultSupport

A custom Result type for send raw data (via an InputStream) directly to the HttpServletResponse. Very useful for allowing users to download content.

This result type takes the following parameters:

  • contentType - the stream mime-type as sent to the web browser (default = text/plain).
  • contentLength - the stream length in bytes (the browser displays a progress bar).
  • contentDispostion - the content disposition header value for specifing the file name (default = inline, values are typically filename="document.pdf".
  • inputName - the name of the InputStream property from the chained action (default = inputStream).
  • bufferSize - the size of the buffer to copy from input to output (default = 1024).
Example:

 <result name="success" type="stream">
   <param name="contentType">image/jpeg</param>
   <param name="inputName">imageStream</param>
   <param name="contentDisposition">filename="document.pdf"</param>
   <param name="bufferSize">1024</param>
 </result>

See Also:
Serialized Form

Field Summary
protected int | bufferSize
protected String | contentDisposition
protected String | contentLength
protected String | contentType
static String | DEFAULT_PARAM
protected String | inputName
protected InputStream | inputStream
protected static Log | log
private static long | serialVersionUID
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
StreamResult()
StreamResult(InputStream in)
Method Summary
protected void | doExecute(String finalLocation, ActionInvocation invocation) Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed).
int | getBufferSize()
String | getContentDisposition()
String | getContentLength()
String | getContentType()
String | getInputName()
void | setBufferSize(int bufferSize)
void | setContentDisposition(String contentDisposition)
void | setContentLength(String contentLength)
void | setContentType(String contentType)
void | setInputName(String inputName)
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

log

protected static final Log log

DEFAULT_PARAM

public static final String DEFAULT_PARAM
See Also:
Constant Field Values

contentType

protected String contentType

contentLength

protected String contentLength

contentDisposition

protected String contentDisposition

inputName

protected String inputName

inputStream

protected InputStream inputStream

bufferSize

protected int bufferSize
Constructor Detail

StreamResult

public StreamResult()

StreamResult

public StreamResult(InputStream in)
Method Detail

getBufferSize

public int getBufferSize()
Returns:
Returns the bufferSize.

setBufferSize

public void setBufferSize(int bufferSize)
Parameters:
bufferSize - The bufferSize to set.

getContentType

public String getContentType()
Returns:
Returns the contentType.

setContentType

public void setContentType(String contentType)
Parameters:
contentType - The contentType to set.

getContentLength

public String getContentLength()
Returns:
Returns the contentLength.

setContentLength

public void setContentLength(String contentLength)
Parameters:
contentLength - The contentLength to set.

getContentDisposition

public String getContentDisposition()
Returns:
Returns the Content-disposition header value.

setContentDisposition

public void setContentDisposition(String contentDisposition)
Parameters:
contentDisposition - the Content-disposition header value to use.

getInputName

public String getInputName()
Returns:
Returns the inputName.

setInputName

public void setInputName(String inputName)
Parameters:
inputName - The inputName to set.

doExecute

protected void doExecute(String finalLocation,
                         ActionInvocation invocation)
                  throws Exception
Description copied from class: StrutsResultSupport
Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed). Subclasses must implement this class to handle custom logic for result handling.

Specified by:
doExecute in class StrutsResultSupport
Parameters:
finalLocation - the location (jsp page, action, etc) to go to.
invocation - the execution state of the action.
Throws:
Exception - if an error occurs while executing the result.
See Also:
StrutsResultSupport.doExecute(java.lang.String, com.opensymphony.xwork2.ActionInvocation)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsRequestWrapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class StrutsRequestWrapper

java.lang.Object
    extended by  javax.servlet.ServletRequestWrapper
        extended by  javax.servlet.http.HttpServletRequestWrapper
            extended by  org.apache.struts2.dispatcher.StrutsRequestWrapper
All Implemented Interfaces:
HttpServletRequest, ServletRequest
Direct Known Subclasses:
MultiPartRequestWrapper
public class StrutsRequestWrapper
extends HttpServletRequestWrapper

All Struts requests are wrapped with this class, which provides simple JSTL accessibility. This is because JSTL works with request attributes, so this class delegates to the value stack except for a few cases where required to prevent infinite loops. Namely, we don't let any attribute name with "#" in it delegate out to the value stack, as it could potentially cause an infinite loop. For example, an infinite loop would take place if you called: request.getAttribute("#attr.foo").

Field Summary
Fields inherited from interface javax.servlet.http.HttpServletRequest
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
Constructor Summary
StrutsRequestWrapper(HttpServletRequest req)
The constructor
Method Summary
 Object getAttribute(String s)
Gets the object, looking in the value stack if not found
Methods inherited from class javax.servlet.http.HttpServletRequestWrapper
getAuthType, getContextPath, getCookies, getDateHeader, getHeader, getHeaderNames, getHeaders, getIntHeader, getMethod, getPathInfo, getPathTranslated, getQueryString, getRemoteUser, getRequestedSessionId, getRequestURI, getRequestURL, getServletPath, getSession, getSession, getUserPrincipal, isRequestedSessionIdFromCookie, isRequestedSessionIdFromUrl, isRequestedSessionIdFromURL, isRequestedSessionIdValid, isUserInRole
Methods inherited from class javax.servlet.ServletRequestWrapper
getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequest, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding, setRequest
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.ServletRequest
getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

Constructor Detail

StrutsRequestWrapper

public StrutsRequestWrapper(HttpServletRequest req)
The constructor

Parameters:
req - The request
Method Detail

getAttribute

public Object getAttribute(String s)
Gets the object, looking in the value stack if not found

Specified by:
getAttribute in interface ServletRequest
Overrides:
getAttribute in class ServletRequestWrapper
Parameters:
s - The attribute key
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsResultSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class StrutsResultSupport

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
All Implemented Interfaces:
Result, Serializable, StrutsStatics
Direct Known Subclasses:
FreemarkerResult, PlainTextResult, PortletFreemarkerResult, PortletResult, PortletVelocityResult, ServletDispatcherResult, ServletRedirectResult, StreamResult, VelocityResult
public abstract class StrutsResultSupport
extends Object
implements Result, StrutsStatics

A base class for all Struts action execution results. The "location" param is the default parameter, meaning the most common usage of this result would be:

This class provides two common parameters for any subclass:

  • location - the location to go to after execution (could be a jsp page or another action). It can be parsed as per the rules definied in the translateVariables method
  • parse - true by default. If set to false, the location param will not be parsed for expressions
  • encode - false by default. If set to false, the location param will not be url encoded. This only have effect when parse is true
NOTE: The encode param will only have effect when parse is true

In the struts.xml configuration file, these would be included as:

  <result name="success" type="redirect">
      <param name="location">foo.jsp</param>
  </result>

or

  <result name="success" type="redirect" >
      <param name="location">foo.jsp?url=${myUrl}</param>
      <param name="parse">true</param>
      <param name="encode">true</param>
  </result>

In the above case, myUrl will be parsed against Ognl Value Stack and then URL encoded.

or when using the default parameter feature

  <result name="success" type="redirect">foo.jsp</result>

You should subclass this class if you're interested in adding more parameters or functionality to your Result. If you do subclass this class you will need to override doExecute(String, ActionInvocation).

Any custom result can be defined in struts.xml as:

  <result-types>
      ...
      <result-type name="myresult" class="com.foo.MyResult" />
  </result-types>

Please see the Result class for more info on Results in general.

See Also:
Result, Serialized Form

Field Summary
private static Log | _log
static String | DEFAULT_PARAM The default parameter
private boolean | encode
private String | lastFinalLocation
private String | location
private boolean | parse
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
StrutsResultSupport()
StrutsResultSupport(String location)
StrutsResultSupport(String location, boolean parse, boolean encode)
Method Summary
protected String | conditionalParse(String param, ActionInvocation invocation) Parses the parameter for OGNL expressions against the valuestack
protected abstract void | doExecute(String finalLocation, ActionInvocation invocation) Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed).
void | execute(ActionInvocation invocation) Implementation of the execute method from the Result interface.
String | getLastFinalLocation() Returns the last parsed and encoded location value
void | setEncode(boolean encode) Set encode to true to indicate that the location should be url encoded.
void | setLocation(String location) The location to go to after action execution.
void | setParse(boolean parse) Set parse to true to indicate that the location should be parsed as an OGNL expression.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

DEFAULT_PARAM

public static final String DEFAULT_PARAM
The default parameter

See Also:
Constant Field Values

parse

private boolean parse

encode

private boolean encode

location

private String location

lastFinalLocation

private String lastFinalLocation
Constructor Detail

StrutsResultSupport

public StrutsResultSupport()

StrutsResultSupport

public StrutsResultSupport(String location)

StrutsResultSupport

public StrutsResultSupport(String location,
                           boolean parse,
                           boolean encode)
Method Detail

setLocation

public void setLocation(String location)
The location to go to after action execution. This could be a JSP page or another action. The location can contain OGNL expressions which will be evaulated if the parse parameter is set to true.

Parameters:
location - the location to go to after action execution.
See Also:
setParse(boolean)

getLastFinalLocation

public String getLastFinalLocation()
Returns the last parsed and encoded location value

setParse

public void setParse(boolean parse)
Set parse to true to indicate that the location should be parsed as an OGNL expression. This is set to true by default.

Parameters:
parse - true if the location parameter is an OGNL expression, false otherwise.

setEncode

public void setEncode(boolean encode)
Set encode to true to indicate that the location should be url encoded. This is set to true by default

Parameters:
encode - true if the location parameter should be url encode, false otherwise.

execute

public void execute(ActionInvocation invocation)
             throws Exception
Implementation of the execute method from the Result interface. This will call the abstract method doExecute(String, ActionInvocation) after optionally evaluating the location as an OGNL evaluation.

Specified by:
execute in interface Result
Parameters:
invocation - the execution state of the action.
Throws:
Exception - if an error occurs while executing the result.

conditionalParse

protected String conditionalParse(String param,
                                  ActionInvocation invocation)
Parses the parameter for OGNL expressions against the valuestack

Parameters:
param - The parameter value
invocation - The action invocation instance
Returns:
The resulting string

doExecute

protected abstract void doExecute(String finalLocation,
                                  ActionInvocation invocation)
                           throws Exception
Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed). Subclasses must implement this class to handle custom logic for result handling.

Parameters:
finalLocation - the location (jsp page, action, etc) to go to.
invocation - the execution state of the action.
Throws:
Exception - if an error occurs while executing the result.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VelocityResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher
Class VelocityResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.dispatcher.VelocityResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class VelocityResult
extends StrutsResultSupport

Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

This result type takes the following parameters:

  • location (default) - the location of the template to process.
  • parse - true by default. If set to false, the location param will not be parsed for Ognl expressions.

This result follows the same rules from StrutsResultSupport.

Example:

 <result name="success" type="velocity">
   <param name="location">foo.vm</param>
 </result>

See Also:
Serialized Form

Field Summary
private String | defaultEncoding
private static Log | log
private static long | serialVersionUID
private VelocityManager | velocityManager
Fields inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
DEFAULT_PARAM
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
VelocityResult()
VelocityResult(String location)
Method Summary
protected org.apache.velocity.context.Context | createContext(VelocityManager velocityManager, ValueStack stack, HttpServletRequest request, HttpServletResponse response, String location) Creates the VelocityContext that we'll use to render this page.
void | doExecute(String finalLocation, ActionInvocation invocation) Creates a Velocity context from the action, loads a Velocity template and executes the template.
protected String | getContentType(String templateLocation) Retrieve the content type for this template.
protected String | getEncoding(String templateLocation) Retrieve the encoding for this template.
protected org.apache.velocity.Template | getTemplate(ValueStack stack, org.apache.velocity.app.VelocityEngine velocity, ActionInvocation invocation, String location, String encoding) Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.
void | setDefaultEncoding(String val)
void | setVelocityManager(VelocityManager mgr)
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

log

private static final Log log

defaultEncoding

private String defaultEncoding

velocityManager

private VelocityManager velocityManager
Constructor Detail

VelocityResult

public VelocityResult()

VelocityResult

public VelocityResult(String location)
Method Detail

setDefaultEncoding

public void setDefaultEncoding(String val)

setVelocityManager

public void setVelocityManager(VelocityManager mgr)

doExecute

public void doExecute(String finalLocation,
                      ActionInvocation invocation)
               throws Exception
Creates a Velocity context from the action, loads a Velocity template and executes the template. Output is written to the servlet output stream.

Specified by:
doExecute in class StrutsResultSupport
Parameters:
finalLocation - the location of the Velocity template
invocation - an encapsulation of the action execution state.
Throws:
Exception - if an error occurs when creating the Velocity context, loading or executing the template or writing output to the servlet response stream.

getContentType

protected String getContentType(String templateLocation)
Retrieve the content type for this template.

People can override this method if they want to provide specific content types for specific templates (eg text/xml).

Returns:
The content type associated with this template (default "text/html")

getEncoding

protected String getEncoding(String templateLocation)
Retrieve the encoding for this template.

People can override this method if they want to provide specific encodings for specific templates.

Returns:
The encoding associated with this template (defaults to the value of 'struts.i18n.encoding' property)

getTemplate

protected org.apache.velocity.Template getTemplate(ValueStack stack,
                                                   org.apache.velocity.app.VelocityEngine velocity,
                                                   ActionInvocation invocation,
                                                   String location,
                                                   String encoding)
                                            throws Exception
Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.

Parameters:
stack - the value stack to resolve the location again (when parse equals true)
velocity - the velocity engine to process the request against
invocation - an encapsulation of the action execution state.
location - the location of the template
encoding - the charset encoding of the template
Returns:
the template to render
Throws:
Exception - when the requested template could not be found

createContext

protected org.apache.velocity.context.Context createContext(VelocityManager velocityManager,
                                                            ValueStack stack,
                                                            HttpServletRequest request,
                                                            HttpServletResponse response,
                                                            String location)
Creates the VelocityContext that we'll use to render this page.

Parameters:
velocityManager - a reference to the velocityManager to use
stack - the value stack to resolve the location against (when parse equals true)
location - the name of the template that is being used
Returns:
the a minted Velocity context.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.dispatcher.mapper (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.dispatcher.mapper

Interface Summary
ActionMapper | Provide a mapping between HTTP requests and action invocation requests and vice-versa.
DefaultActionMapper.ParameterAction | Defines a parameter action prefix

Class Summary
ActionMapping | Simple class that holds the action mapping information used to invoke a Struts action.
CompositeActionMapper | A composite action mapper that is capable of delegating to a series of ActionMapper if the former failed to obtained a valid ActionMapping or uri.
DefaultActionMapper | Default action mapper implementation, using the standard *.[ext] (where ext usually "action") pattern.
Restful2ActionMapper | Improved restful action mapper that adds several ReST-style improvements to action mapping, but supports fully-customized URL's via XML.
RestfulActionMapper | A custom action mapper using the following format: http://HOST/ACTION_NAME/PARAM_NAME1/PARAM_VALUE1/PARAM_NAME2/PARAM_VALUE2 You can have as many parameters you'd like to use.


org.apache.struts2.dispatcher.mapper Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.dispatcher.mapper

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.dispatcher.mapper.ActionMapping
    • org.apache.struts2.dispatcher.mapper.CompositeActionMapper (implements org.apache.struts2.dispatcher.mapper.ActionMapper)
    • org.apache.struts2.dispatcher.mapper.DefaultActionMapper (implements org.apache.struts2.dispatcher.mapper.ActionMapper)
      • org.apache.struts2.dispatcher.mapper.Restful2ActionMapper
    • org.apache.struts2.dispatcher.mapper.RestfulActionMapper (implements org.apache.struts2.dispatcher.mapper.ActionMapper)

Interface Hierarchy

  • org.apache.struts2.dispatcher.mapper.ActionMapper
  • org.apache.struts2.dispatcher.mapper.DefaultActionMapper.ParameterAction


Uses of Package org.apache.struts2.dispatcher.mapper (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.dispatcher.mapper

Packages that use org.apache.struts2.dispatcher.mapper
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.components |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.portlet.context |
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.views.jsp | Struts's JSP tag library.

Classes in org.apache.struts2.dispatcher.mapper used by org.apache.struts2
ActionMapping
Simple class that holds the action mapping information used to invoke a Struts action.

Classes in org.apache.struts2.dispatcher.mapper used by org.apache.struts2.components
ActionMapper
Provide a mapping between HTTP requests and action invocation requests and vice-versa.

Classes in org.apache.struts2.dispatcher.mapper used by org.apache.struts2.dispatcher
ActionMapper
Provide a mapping between HTTP requests and action invocation requests and vice-versa.
ActionMapping
Simple class that holds the action mapping information used to invoke a Struts action.

Classes in org.apache.struts2.dispatcher.mapper used by org.apache.struts2.dispatcher.mapper
ActionMapper
Provide a mapping between HTTP requests and action invocation requests and vice-versa.
ActionMapping
Simple class that holds the action mapping information used to invoke a Struts action.
DefaultActionMapper
Default action mapper implementation, using the standard *.[ext] (where ext usually "action") pattern.

Classes in org.apache.struts2.dispatcher.mapper used by org.apache.struts2.portlet.context
ActionMapping
Simple class that holds the action mapping information used to invoke a Struts action.

Classes in org.apache.struts2.dispatcher.mapper used by org.apache.struts2.portlet.dispatcher
ActionMapper
Provide a mapping between HTTP requests and action invocation requests and vice-versa.
ActionMapping
Simple class that holds the action mapping information used to invoke a Struts action.

Classes in org.apache.struts2.dispatcher.mapper used by org.apache.struts2.views.jsp
ActionMapper
Provide a mapping between HTTP requests and action invocation requests and vice-versa.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionMapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.mapper
Interface ActionMapper

All Known Implementing Classes:
CompositeActionMapper, DefaultActionMapper, Restful2ActionMapper, RestfulActionMapper
public interface ActionMapper

Provide a mapping between HTTP requests and action invocation requests and vice-versa.

When given an HttpServletRequest, the ActionMapper may return null if no action invocation request matches, or it may return an ActionMapping that describes an action invocation for the framework to try.

The ActionMapper is not required to guarantee that the ActionMapping returned be a real action or otherwise ensure a valid request. Accordingly, most ActionMappers do not need to consult the Struts configuration just to determine if a request should be mapped.

Just as requests can be mapped from HTTP to an action invocation, the opposite is true as well. However, because HTTP requests (when shown in HTTP responses) must be in String form, a String is returned rather than an actual request object.

Method Summary
ActionMapping | getMapping(HttpServletRequest request, ConfigurationManager configManager) Expose the ActionMapping for the current request
String | getUriFromActionMapping(ActionMapping mapping) Convert an ActionMapping into a URI string

Method Detail

getMapping

ActionMapping getMapping(HttpServletRequest request,
                         ConfigurationManager configManager)
Expose the ActionMapping for the current request

Parameters:
request - The servlet request
configManager - The current configuration manager
Returns:
The appropriate action mapping

getUriFromActionMapping

String getUriFromActionMapping(ActionMapping mapping)
Convert an ActionMapping into a URI string

Parameters:
mapping - The action mapping
Returns:
The URI string that represents this mapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionMapping (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.mapper
Class ActionMapping

java.lang.Object
    extended by  org.apache.struts2.dispatcher.mapper.ActionMapping

public class ActionMapping
extends Object

Simple class that holds the action mapping information used to invoke a Struts action. The name and namespace are required, but the params map is optional, and as such may be null. If a params map is supplied, it must be a mutable map, such as a HashMap.

Field Summary
private String | method
private String | name
private String | namespace
private Map | params
private Result | result
Constructor Summary
ActionMapping()
Constructs an ActionMapping
ActionMapping(Result result)
Constructs an ActionMapping with a default result
ActionMapping(String name, String namespace, String method, Map params)
Constructs an ActionMapping with its values
Method Summary
String | getMethod()
String | getName()
String | getNamespace()
Map | getParams()
Result | getResult()
void | setMethod(String method)
void | setName(String name)
void | setNamespace(String namespace)
void | setParams(Map params)
void | setResult(Result result)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

name

private String name

namespace

private String namespace

method

private String method

params

private Map params

result

private Result result
Constructor Detail

ActionMapping

public ActionMapping()
Constructs an ActionMapping

ActionMapping

public ActionMapping(Result result)
Constructs an ActionMapping with a default result

Parameters:
result - The default result

ActionMapping

public ActionMapping(String name,
                     String namespace,
                     String method,
                     Map params)
Constructs an ActionMapping with its values

Parameters:
name - The action name
namespace - The action namespace
method - The method
params - The extra parameters
Method Detail

getName

public String getName()
Returns:
The action name

getNamespace

public String getNamespace()
Returns:
The action namespace

getParams

public Map getParams()
Returns:
The extra parameters

getMethod

public String getMethod()
Returns:
The method

getResult

public Result getResult()
Returns:
The default result

setResult

public void setResult(Result result)
Parameters:
result - The result

setName

public void setName(String name)
Parameters:
name - The action name

setNamespace

public void setNamespace(String namespace)
Parameters:
namespace - The action namespace

setMethod

public void setMethod(String method)
Parameters:
method - The method name to call on the action

setParams

public void setParams(Map params)
Parameters:
params - The extra parameters for this mapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CompositeActionMapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.mapper
Class CompositeActionMapper

java.lang.Object
    extended by  org.apache.struts2.dispatcher.mapper.CompositeActionMapper
All Implemented Interfaces:
ActionMapper
public class CompositeActionMapper
extends Object
implements ActionMapper

A composite action mapper that is capable of delegating to a series of ActionMapper if the former failed to obtained a valid ActionMapping or uri.

It is configured through struts.properties.

For example, with the following entries in struts.properties

 <bean type="org.apache.struts2.dispatcher.mapper.ActionMapper" name="struts"
       class="org.apache.struts2.dispatcher.mapper.CompositeActionMapper" />
 <constant name="struts.mapper.composite"
       value="org.apache.struts2.dispatcher.mapper.DefaultActionMapper,org.apache.struts2.dispatcher.mapper.RestfulActionMapperorg.apache.struts2.dispatcher.mapper.Restful2ActionMapper" />

When getMapping(HttpServletRequest, ConfigurationManager) or getUriFromActionMapping(ActionMapping) is invoked, CompositeActionMapper would go through these ActionMappers in sequence starting from ActionMapper identified by 'struts.mapper.composite.1', followed by 'struts.mapper.composite.2' and finally 'struts.mapper.composite.3' (in this case) until either one of the ActionMapper return a valid result (not null) or it runs out of ActionMapper in which case it will just return null for both getMapping(HttpServletRequest, ConfigurationManager) and getUriFromActionMapping(ActionMapping) methods.

For example with the following in struts-*.xml :-

    <bean type="org.apache.struts2.dispatcher.mapper.ActionMapper" name="struts"
       class="org.apache.struts2.dispatcher.mapper.CompositeActionMapper" />
    <constant name="struts.mapper.composite"
       value="org.apache.struts2.dispatcher.mapper.DefaultActionMapper,foo.bar.MyActionMapper,foo.bar.MyAnotherActionMapper" />

CompositeActionMapper will be configured with 3 ActionMapper, namely "DefaultActionMapper", "MyActionMapper" and "MyAnotherActionMapper". CompositeActionMapper would consult each of them in order described above.

Version:
$Date: 2006-11-23 12:31:52 -0500 (Thu, 23 Nov 2006) $ $Id: CompositeActionMapper.java 478625 2006-11-23 17:31:52Z wsmoak $
See Also:
ActionMapper, ActionMapperFactory, ActionMapping, IndividualActionMapperEntry

Field Summary
protected List<ActionMapper> | actionMappers
protected Container | container
private static Log | LOG
Constructor Summary
CompositeActionMapper()
Method Summary
ActionMapping | getMapping(HttpServletRequest request, ConfigurationManager configManager) Expose the ActionMapping for the current request
String | getUriFromActionMapping(ActionMapping mapping) Convert an ActionMapping into a URI string
void | setActionMappers(String list)
void | setContainer(Container container)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

container

protected Container container

actionMappers

protected List<ActionMapper> actionMappers
Constructor Detail

CompositeActionMapper

public CompositeActionMapper()
Method Detail

setContainer

public void setContainer(Container container)

setActionMappers

public void setActionMappers(String list)

getMapping

public ActionMapping getMapping(HttpServletRequest request,
                                ConfigurationManager configManager)
Description copied from interface: ActionMapper
Expose the ActionMapping for the current request

Specified by:
getMapping in interface ActionMapper
Parameters:
request - The servlet request
configManager - The current configuration manager
Returns:
The appropriate action mapping

getUriFromActionMapping

public String getUriFromActionMapping(ActionMapping mapping)
Description copied from interface: ActionMapper
Convert an ActionMapping into a URI string

Specified by:
getUriFromActionMapping in interface ActionMapper
Parameters:
mapping - The action mapping
Returns:
The URI string that represents this mapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionMapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.mapper
Class DefaultActionMapper

java.lang.Object
    extended by  org.apache.struts2.dispatcher.mapper.DefaultActionMapper
All Implemented Interfaces:
ActionMapper
Direct Known Subclasses:
Restful2ActionMapper
public class DefaultActionMapper
extends Object
implements ActionMapper

Default action mapper implementation, using the standard *.[ext] (where ext usually "action") pattern. The extension is looked up from the Struts configuration key struts.action.exection.

To help with dealing with buttons and other related requirements, this mapper (and other ActionMappers, we hope) has the ability to name a button with some predefined prefix and have that button name alter the execution behaviour. The four prefixes are:

  • Method prefix - method:default
  • Action prefix - action:dashboard
  • Redirect prefix - redirect:cancel.jsp
  • Redirect-action prefix - redirect-action:cancel

In addition to these four prefixes, this mapper also understands the action naming pattern of foo!bar in either the extension form (eg: foo!bar.action) or in the prefix form (eg: action:foo!bar). This syntax tells this mapper to map to the action named foo and the method bar.

Method Prefix

With method-prefix, instead of calling baz action's execute() method (by default if it isn't overriden in struts.xml to be something else), the baz action's anotherMethod() will be called. A very elegant way determine which button is clicked. Alternatively, one would have submit button set a particular value on the action when clicked, and the execute() method decides on what to do with the setted value depending on which button is clicked.

  <!-- START SNIPPET: method-example -->
  <a:form action="baz">
      <a:textfield label="Enter your name" name="person.name"/>
      <a:submit value="Create person"/>
      <a:submit name="method:anotherMethod" value="Cancel"/>
  </a:form>
  <!-- END SNIPPET: method-example -->

Action prefix

With action-prefix, instead of executing baz action's execute() method (by default if it isn't overriden in struts.xml to be something else), the anotherAction action's execute() method (assuming again if it isn't overriden with something else in struts.xml) will be executed.

  <!-- START SNIPPET: action-example -->
  <a:form action="baz">
      <a:textfield label="Enter your name" name="person.name"/>
      <a:submit value="Create person"/>
      <a:submit name="action:anotherAction" value="Cancel"/>
  </a:form>
  <!-- END SNIPPET: action-example -->

Redirect prefix

With redirect-prefix, instead of executing baz action's execute() method (by default it isn't overriden in struts.xml to be something else), it will get redirected to, in this case to www.google.com. Internally it uses ServletRedirectResult to do the task.

  <!-- START SNIPPET: redirect-example -->
  <a:form action="baz">
      <a:textfield label="Enter your name" name="person.name"/>
      <a:submit value="Create person"/>
      <a:submit name="redirect:www.google.com" value="Cancel"/>
  </a:form>
  <!-- END SNIPPET: redirect-example -->

Redirect-action prefix

With redirect-action-prefix, instead of executing baz action's execute() method (by default it isn't overriden in struts.xml to be something else), it will get redirected to, in this case 'dashboard.action'. Internally it uses ServletRedirectResult to do the task and read off the extension from the struts.properties.

  <!-- START SNIPPET: redirect-action-example -->
  <a:form action="baz">
      <a:textfield label="Enter your name" name="person.name"/>
      <a:submit value="Create person"/>
      <a:submit name="redirect-action:dashboard" value="Cancel"/>
  </a:form>
  <!-- END SNIPPET: redirect-action-example -->

Nested Class Summary
(package private) static interface DefaultActionMapper.ParameterAction
Defines a parameter action prefix
Field Summary
(package private) static String | ACTION_PREFIX
private boolean | allowDynamicMethodCalls
private boolean | allowSlashesInActionNames
private boolean | alwaysSelectFullNamespace
private Container | container
(package private) List | extensions
(package private) static String | METHOD_PREFIX
private PrefixTrie | prefixTrie
(package private) static String | REDIRECT_ACTION_PREFIX
(package private) static String | REDIRECT_PREFIX
Constructor Summary
DefaultActionMapper()
Method Summary
(package private) String | dropExtension(String name) Drops the extension from the action name
(package private) String | getDefaultExtension() Returns null if no extension is specified.
ActionMapping | getMapping(HttpServletRequest request, ConfigurationManager configManager) Expose the ActionMapping for the current request
(package private) String | getUri(HttpServletRequest request) Gets the uri from the request
String | getUriFromActionMapping(ActionMapping mapping) Convert an ActionMapping into a URI string
void | handleSpecialParameters(HttpServletRequest request, ActionMapping mapping) Special parameters, as described in the class-level comment, are searched for and handled.
(package private) void | parseNameAndNamespace(String uri, ActionMapping mapping, ConfigurationManager configManager) Parses the name and namespace from the uri
void | setAllowDynamicMethodCalls(String allow)
void | setAlwaysSelectFullNamespace(String val)
void | setContainer(Container container)
void | setExtensions(String extensions)
void | setSlashesInActionNames(String allow)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

METHOD_PREFIX

static final String METHOD_PREFIX
See Also:
Constant Field Values

ACTION_PREFIX

static final String ACTION_PREFIX
See Also:
Constant Field Values

REDIRECT_PREFIX

static final String REDIRECT_PREFIX
See Also:
Constant Field Values

REDIRECT_ACTION_PREFIX

static final String REDIRECT_ACTION_PREFIX
See Also:
Constant Field Values

allowDynamicMethodCalls

private boolean allowDynamicMethodCalls

allowSlashesInActionNames

private boolean allowSlashesInActionNames

alwaysSelectFullNamespace

private boolean alwaysSelectFullNamespace

prefixTrie

private PrefixTrie prefixTrie

extensions

List extensions

container

private Container container
Constructor Detail

DefaultActionMapper

public DefaultActionMapper()
Method Detail

setAllowDynamicMethodCalls

public void setAllowDynamicMethodCalls(String allow)

setSlashesInActionNames

public void setSlashesInActionNames(String allow)

setAlwaysSelectFullNamespace

public void setAlwaysSelectFullNamespace(String val)

setContainer

public void setContainer(Container container)

getMapping

public ActionMapping getMapping(HttpServletRequest request,
                                ConfigurationManager configManager)
Description copied from interface: ActionMapper
Expose the ActionMapping for the current request

Specified by:
getMapping in interface ActionMapper
Parameters:
request - The servlet request
configManager - The current configuration manager
Returns:
The appropriate action mapping

handleSpecialParameters

public void handleSpecialParameters(HttpServletRequest request,
                                    ActionMapping mapping)
Special parameters, as described in the class-level comment, are searched for and handled.

Parameters:
request - The request
mapping - The action mapping

parseNameAndNamespace

void parseNameAndNamespace(String uri,
                           ActionMapping mapping,
                           ConfigurationManager configManager)
Parses the name and namespace from the uri

Parameters:
uri - The uri
mapping - The action mapping to populate

dropExtension

String dropExtension(String name)
Drops the extension from the action name

Parameters:
name - The action name
Returns:
The action name without its extension

getDefaultExtension

String getDefaultExtension()
Returns null if no extension is specified.

setExtensions

public void setExtensions(String extensions)

getUri

String getUri(HttpServletRequest request)
Gets the uri from the request

Parameters:
request - The request
Returns:
The uri

getUriFromActionMapping

public String getUriFromActionMapping(ActionMapping mapping)
Description copied from interface: ActionMapper
Convert an ActionMapping into a URI string

Specified by:
getUriFromActionMapping in interface ActionMapper
Parameters:
mapping - The action mapping
Returns:
The URI string that represents this mapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultActionMapper.ParameterAction (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.mapper
Interface DefaultActionMapper.ParameterAction

Enclosing class:
DefaultActionMapper
static interface DefaultActionMapper.ParameterAction

Defines a parameter action prefix

Method Summary
 void execute(String key, ActionMapping mapping)

Method Detail

execute

void execute(String key,
             ActionMapping mapping)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Restful2ActionMapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.mapper
Class Restful2ActionMapper

java.lang.Object
    extended by  org.apache.struts2.dispatcher.mapper.DefaultActionMapper
        extended by  org.apache.struts2.dispatcher.mapper.Restful2ActionMapper
All Implemented Interfaces:
ActionMapper
public class Restful2ActionMapper
extends DefaultActionMapper

Improved restful action mapper that adds several ReST-style improvements to action mapping, but supports fully-customized URL's via XML. The two primary ReST enhancements are:

  • If the method is not specified (via '!' or 'method:' prefix), the method is "guessed" at using ReST-style conventions that examine the URL and the HTTP method.
  • Parameters are extracted from the action name, if parameter name/value pairs are specified using PARAM_NAME/PARAM_VALUE syntax.

These two improvements allow a GET request for 'category/action/movie/Thrillers' to be mapped to the action name 'movie' with an id of 'Thrillers' with an extra parameter named 'category' with a value of 'action'. A single action mapping can then handle all CRUD operations using wildcards, e.g.

   <action name="movie/*" className="app.MovieAction">
     <param name="id">{0}</param>
     ...
   </action>

The following URL's will invoke its methods:

  • GET: /movie => method="index"
  • GET: /movie/Thrillers => method="view", id="Thrillers"
  • GET: /movie/Thrillers!edit => method="edit", id="Thrillers"
  • GET: /movie/new => method="editNew"
  • POST: /movie/Thrillers => method="create"
  • PUT: /movie/ => method="update"
  • DELETE: /movie/Thrillers => method="remove"

To simulate the HTTP methods PUT and DELETE, since they aren't supported by HTML, the HTTP parameter "__http_method" will be used.

The syntax and design for this feature was inspired by the ReST support in Ruby on Rails. See http://ryandaigle.com/articles/2006/08/01/whats-new-in-edge-rails-simply-restful-support-and-how-to-use-it

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.struts2.dispatcher.mapper.DefaultActionMapper
DefaultActionMapper.ParameterAction
Field Summary
private static String | HTTP_METHOD_PARAM
protected static Log | LOG
Fields inherited from class org.apache.struts2.dispatcher.mapper.DefaultActionMapper
ACTION_PREFIX, extensions, METHOD_PREFIX, REDIRECT_ACTION_PREFIX, REDIRECT_PREFIX
Constructor Summary
Restful2ActionMapper()
Method Summary
ActionMapping | getMapping(HttpServletRequest request, ConfigurationManager configManager) Expose the ActionMapping for the current request
protected boolean | isDelete(HttpServletRequest request)
protected boolean | isGet(HttpServletRequest request)
protected boolean | isPost(HttpServletRequest request)
protected boolean | isPut(HttpServletRequest request)
Methods inherited from class org.apache.struts2.dispatcher.mapper.DefaultActionMapper
dropExtension, getDefaultExtension, getUri, getUriFromActionMapping, handleSpecialParameters, parseNameAndNamespace, setAllowDynamicMethodCalls, setAlwaysSelectFullNamespace, setContainer, setExtensions, setSlashesInActionNames
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Log LOG

HTTP_METHOD_PARAM

private static final String HTTP_METHOD_PARAM
See Also:
Constant Field Values
Constructor Detail

Restful2ActionMapper

public Restful2ActionMapper()
Method Detail

getMapping

public ActionMapping getMapping(HttpServletRequest request,
                                ConfigurationManager configManager)
Description copied from interface: ActionMapper
Expose the ActionMapping for the current request

Specified by:
getMapping in interface ActionMapper
Overrides:
getMapping in class DefaultActionMapper
Parameters:
request - The servlet request
configManager - The current configuration manager
Returns:
The appropriate action mapping

isGet

protected boolean isGet(HttpServletRequest request)

isPost

protected boolean isPost(HttpServletRequest request)

isPut

protected boolean isPut(HttpServletRequest request)

isDelete

protected boolean isDelete(HttpServletRequest request)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RestfulActionMapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.mapper
Class RestfulActionMapper

java.lang.Object
    extended by  org.apache.struts2.dispatcher.mapper.RestfulActionMapper
All Implemented Interfaces:
ActionMapper
public class RestfulActionMapper
extends Object
implements ActionMapper

A custom action mapper using the following format:

    http://HOST/ACTION_NAME/PARAM_NAME1/PARAM_VALUE1/PARAM_NAME2/PARAM_VALUE2

You can have as many parameters you'd like to use. Alternatively the URL can be shortened to the following:

    http://HOST/ACTION_NAME/PARAM_VALUE1/PARAM_NAME2/PARAM_VALUE2

This is the same as:

    http://HOST/ACTION_NAME/ACTION_NAME + "Id"/PARAM_VALUE1/PARAM_NAME2/PARAM_VALUE2

Suppose for example we would like to display some articles by id at using the following URL sheme:

    http://HOST/article/Id

Your action just needs a setArticleId() method, and requests such as /article/1, /article/2, etc will all map to that URL pattern.

Field Summary
protected static Log LOG
Constructor Summary
RestfulActionMapper()
Method Summary
ActionMapping | getMapping(HttpServletRequest request, ConfigurationManager configManager) Expose the ActionMapping for the current request
String | getUriFromActionMapping(ActionMapping mapping) Convert an ActionMapping into a URI string
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

protected static final Log LOG
Constructor Detail

RestfulActionMapper

public RestfulActionMapper()
Method Detail

getMapping

public ActionMapping getMapping(HttpServletRequest request,
                                ConfigurationManager configManager)
Description copied from interface: ActionMapper
Expose the ActionMapping for the current request

Specified by:
getMapping in interface ActionMapper
Parameters:
request - The servlet request
configManager - The current configuration manager
Returns:
The appropriate action mapping

getUriFromActionMapping

public String getUriFromActionMapping(ActionMapping mapping)
Description copied from interface: ActionMapper
Convert an ActionMapping into a URI string

Specified by:
getUriFromActionMapping in interface ActionMapper
Parameters:
mapping - The action mapping
Returns:
The URI string that represents this mapping
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.dispatcher.multipart (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.dispatcher.multipart

Classes to help dispatch multipart HTTP requests.

See:
Description

Interface Summary
MultiPartRequest Abstract wrapper class HTTP requests to handle multi-part data.

Class Summary
JakartaMultiPartRequest | Multipart form data request adapter for Jakarta Commons Fileupload package.
MultiPartRequestWrapper | Parse a multipart request and provide a wrapper around the request.

Package org.apache.struts2.dispatcher.multipart Description

Classes to help dispatch multipart HTTP requests.


org.apache.struts2.dispatcher.multipart Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.dispatcher.multipart

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest (implements org.apache.struts2.dispatcher.multipart.MultiPartRequest)
    • javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
        • org.apache.struts2.dispatcher.StrutsRequestWrapper
          • org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

Interface Hierarchy

  • org.apache.struts2.dispatcher.multipart.MultiPartRequest


Uses of Package org.apache.struts2.dispatcher.multipart (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.dispatcher.multipart

Packages that use org.apache.struts2.dispatcher.multipart
org.apache.struts2.dispatcher.multipart Classes to help dispatch multipart HTTP requests.

Classes in org.apache.struts2.dispatcher.multipart used by org.apache.struts2.dispatcher.multipart
MultiPartRequest
Abstract wrapper class HTTP requests to handle multi-part data.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


MultiPartRequest (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.multipart
Interface MultiPartRequest

All Known Implementing Classes:
JakartaMultiPartRequest
public interface MultiPartRequest

Abstract wrapper class HTTP requests to handle multi-part data.

Method Summary
String[] | getContentType(String fieldName) Returns the content type(s) of the file(s) associated with the specified field name (as supplied by the client browser), or null if no files are associated with the given field name.
List | getErrors() Returns a list of error messages that may have occurred while processing the request.
File[] | getFile(String fieldName) Returns a File object for the filename specified or null if no files are associated with the given field name.
String[] | getFileNames(String fieldName) Returns a String[] of file names for files associated with the specified input field name
Enumeration<String> | getFileParameterNames() Returns an enumeration of the parameter names for uploaded files
String[] | getFilesystemName(String fieldName) Returns the file system name(s) of files associated with the given field name or null if no files are associated with the given field name.
String | getParameter(String name) Returns the specified request parameter.
Enumeration<String> | getParameterNames() Returns an enumeration of String parameter names.
String[] | getParameterValues(String name) Returns a list of all parameter values associated with a parameter name.
void | parse(HttpServletRequest request, String saveDir)

Method Detail

parse

void parse(HttpServletRequest request,
           String saveDir)
           throws IOException
Throws:
IOException

getFileParameterNames

Enumeration<String> getFileParameterNames()
Returns an enumeration of the parameter names for uploaded files

Returns:
an enumeration of the parameter names for uploaded files

getContentType

String[] getContentType(String fieldName)
Returns the content type(s) of the file(s) associated with the specified field name (as supplied by the client browser), or null if no files are associated with the given field name.

Parameters:
fieldName - input field name
Returns:
an array of content encoding for the specified input field name or null if no content type was specified.

getFile

File[] getFile(String fieldName)
Returns a File object for the filename specified or null if no files are associated with the given field name.

Parameters:
fieldName - input field name
Returns:
a File[] object for files associated with the specified input field name

getFileNames

String[] getFileNames(String fieldName)
Returns a String[] of file names for files associated with the specified input field name

Parameters:
fieldName - input field name
Returns:
a String[] of file names for files associated with the specified input field name

getFilesystemName

String[] getFilesystemName(String fieldName)
Returns the file system name(s) of files associated with the given field name or null if no files are associated with the given field name.

Parameters:
fieldName - input field name
Returns:
the file system name(s) of files associated with the given field name

getParameter

String getParameter(String name)
Returns the specified request parameter.

Parameters:
name - the name of the parameter to get
Returns:
the parameter or null if it was not found.

getParameterNames

Enumeration<String> getParameterNames()
Returns an enumeration of String parameter names.

Returns:
an enumeration of String parameter names.

getParameterValues

String[] getParameterValues(String name)
Returns a list of all parameter values associated with a parameter name. If there is only one parameter value per name the resulting array will be of length 1.

Parameters:
name - the name of the parameter.
Returns:
an array of all values associated with the parameter name.

getErrors

List getErrors()
Returns a list of error messages that may have occurred while processing the request. If there are no errors, an empty list is returned. If the underlying implementation (ie: pell, cos, jakarta, etc) cannot support providing these errors, an empty list is also returned. This list of errors is repoted back to the MultiPartRequestWrapper's errors field.

Returns:
a list of Strings that represent various errors during parsing
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JakartaMultiPartRequest (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.multipart
Class JakartaMultiPartRequest

java.lang.Object
    extended by  org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest
All Implemented Interfaces:
MultiPartRequest
public class JakartaMultiPartRequest
extends Object
implements MultiPartRequest

Multipart form data request adapter for Jakarta Commons Fileupload package.

Field Summary
private List<String> | errors
private Map<String,List<org.apache.commons.fileupload.FileItem>> | files
(package private) static Log | log
private long | maxSize
private Map<String,List<String>> | params
Constructor Summary
JakartaMultiPartRequest()
Method Summary
private org.apache.commons.fileupload.RequestContext | createRequestContext(HttpServletRequest req) Creates a RequestContext needed by Jakarta Commons Upload.
private String | getCanonicalName(String filename) Returns the canonical name of the given file.
String[] | getContentType(String fieldName) Returns the content type(s) of the file(s) associated with the specified field name (as supplied by the client browser), or null if no files are associated with the given field name.
List | getErrors() Returns a list of error messages that may have occurred while processing the request.
File[] | getFile(String fieldName) Returns a File object for the filename specified or null if no files are associated with the given field name.
String[] | getFileNames(String fieldName) Returns a String[] of file names for files associated with the specified input field name
Enumeration<String> | getFileParameterNames() Returns an enumeration of the parameter names for uploaded files
String[] | getFilesystemName(String fieldName) Returns the file system name(s) of files associated with the given field name or null if no files are associated with the given field name.
String | getParameter(String name) Returns the specified request parameter.
Enumeration<String> | getParameterNames() Returns an enumeration of String parameter names.
String[] | getParameterValues(String name) Returns a list of all parameter values associated with a parameter name.
void | parse(HttpServletRequest servletRequest, String saveDir) Creates a new request wrapper to handle multi-part data using methods adapted from Jason Pell's multipart classes (see class description).
void | setMaxSize(String maxSize)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

static final Log log

files

private Map<String,List<org.apache.commons.fileupload.FileItem>> files

params

private Map<String,List<String>> params

errors

private List<String> errors

maxSize

private long maxSize
Constructor Detail

JakartaMultiPartRequest

public JakartaMultiPartRequest()
Method Detail

setMaxSize

public void setMaxSize(String maxSize)

parse

public void parse(HttpServletRequest servletRequest,
                  String saveDir)
           throws IOException
Creates a new request wrapper to handle multi-part data using methods adapted from Jason Pell's multipart classes (see class description).

Specified by:
parse in interface MultiPartRequest
Parameters:
saveDir - the directory to save off the file
servletRequest - the request containing the multipart
Throws:
IOException - is thrown if encoding fails.

getFileParameterNames

public Enumeration<String> getFileParameterNames()
Description copied from interface: MultiPartRequest
Returns an enumeration of the parameter names for uploaded files

Specified by:
getFileParameterNames in interface MultiPartRequest
Returns:
an enumeration of the parameter names for uploaded files

getContentType

public String[] getContentType(String fieldName)
Description copied from interface: MultiPartRequest
Returns the content type(s) of the file(s) associated with the specified field name (as supplied by the client browser), or null if no files are associated with the given field name.

Specified by:
getContentType in interface MultiPartRequest
Parameters:
fieldName - input field name
Returns:
an array of content encoding for the specified input field name or null if no content type was specified.

getFile

public File[] getFile(String fieldName)
Description copied from interface: MultiPartRequest
Returns a File object for the filename specified or null if no files are associated with the given field name.

Specified by:
getFile in interface MultiPartRequest
Parameters:
fieldName - input field name
Returns:
a File[] object for files associated with the specified input field name

getFileNames

public String[] getFileNames(String fieldName)
Description copied from interface: MultiPartRequest
Returns a String[] of file names for files associated with the specified input field name

Specified by:
getFileNames in interface MultiPartRequest
Parameters:
fieldName - input field name
Returns:
a String[] of file names for files associated with the specified input field name

getFilesystemName

public String[] getFilesystemName(String fieldName)
Description copied from interface: MultiPartRequest
Returns the file system name(s) of files associated with the given field name or null if no files are associated with the given field name.

Specified by:
getFilesystemName in interface MultiPartRequest
Parameters:
fieldName - input field name
Returns:
the file system name(s) of files associated with the given field name

getParameter

public String getParameter(String name)
Description copied from interface: MultiPartRequest
Returns the specified request parameter.

Specified by:
getParameter in interface MultiPartRequest
Parameters:
name - the name of the parameter to get
Returns:
the parameter or null if it was not found.

getParameterNames

public Enumeration<String> getParameterNames()
Description copied from interface: MultiPartRequest
Returns an enumeration of String parameter names.

Specified by:
getParameterNames in interface MultiPartRequest
Returns:
an enumeration of String parameter names.

getParameterValues

public String[] getParameterValues(String name)
Description copied from interface: MultiPartRequest
Returns a list of all parameter values associated with a parameter name. If there is only one parameter value per name the resulting array will be of length 1.

Specified by:
getParameterValues in interface MultiPartRequest
Parameters:
name - the name of the parameter.
Returns:
an array of all values associated with the parameter name.

getErrors

public List getErrors()
Description copied from interface: MultiPartRequest
Returns a list of error messages that may have occurred while processing the request. If there are no errors, an empty list is returned. If the underlying implementation (ie: pell, cos, jakarta, etc) cannot support providing these errors, an empty list is also returned. This list of errors is repoted back to the MultiPartRequestWrapper's errors field.

Specified by:
getErrors in interface MultiPartRequest
Returns:
a list of Strings that represent various errors during parsing

getCanonicalName

private String getCanonicalName(String filename)
Returns the canonical name of the given file.

Parameters:
filename - the given file
Returns:
the canonical name of the given file

createRequestContext

private org.apache.commons.fileupload.RequestContext createRequestContext(HttpServletRequest req)
Creates a RequestContext needed by Jakarta Commons Upload.

Parameters:
req - the request.
Returns:
a new request context.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


MultiPartRequestWrapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.dispatcher.multipart
Class MultiPartRequestWrapper

java.lang.Object
    extended by  javax.servlet.ServletRequestWrapper
        extended by  javax.servlet.http.HttpServletRequestWrapper
            extended by  org.apache.struts2.dispatcher.StrutsRequestWrapper
                extended by  org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
All Implemented Interfaces:
HttpServletRequest, ServletRequest
public class MultiPartRequestWrapper
extends StrutsRequestWrapper

Parse a multipart request and provide a wrapper around the request. The parsing implementation used depends on the struts.multipart.parser setting. It should be set to a class which extends MultiPartRequest.

The struts.multipart.parser property should be set to jakarta for the Jakarta implementation, pell for the Pell implementation and cos for the Jason Hunter implementation.

The files are uploaded when the object is instantiated. If there are any errors they are logged using addError(String). An action handling a multipart form should first check hasErrors() before doing any other processing.

An alternate implementation, PellMultiPartRequest, is provided as a plugin.

Field Summary
(package private) Collection<String> | errors
protected static Log | log
(package private) MultiPartRequest | multi
Fields inherited from interface javax.servlet.http.HttpServletRequest
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
Constructor Summary
MultiPartRequestWrapper(MultiPartRequest multiPartRequest, HttpServletRequest request, String saveDir)
Process file downloads and log any errors.
Method Summary
protected void | addError(String anErrorMessage) Adds an error message.
String[] | getContentTypes(String name) Get an array of content encoding for the specified input field name or null if no content type was specified.
Collection<String> | getErrors() Returns a collection of any errors generated when parsing the multipart request.
String[] | getFileNames(String fieldName) Get a String array of the file names for uploaded files
Enumeration<String> | getFileParameterNames() Get an enumeration of the parameter names for uploaded files
File[] | getFiles(String fieldName) Get a File[] for the given input field name.
String[] | getFileSystemNames(String fieldName) Get the filename(s) of the file(s) uploaded for the given input field name.
String | getParameter(String name)
Map | getParameterMap()
Enumeration | getParameterNames()
String[] | getParameterValues(String name)
boolean | hasErrors() Returns true if any errors occured when parsing the HTTP multipart request, false otherwise.
protected Enumeration | mergeParams(Enumeration params1, Enumeration params2) Merges 2 enumeration of parameters as one.
Methods inherited from class org.apache.struts2.dispatcher.StrutsRequestWrapper
getAttribute
Methods inherited from class javax.servlet.http.HttpServletRequestWrapper
getAuthType, getContextPath, getCookies, getDateHeader, getHeader, getHeaderNames, getHeaders, getIntHeader, getMethod, getPathInfo, getPathTranslated, getQueryString, getRemoteUser, getRequestedSessionId, getRequestURI, getRequestURL, getServletPath, getSession, getSession, getUserPrincipal, isRequestedSessionIdFromCookie, isRequestedSessionIdFromUrl, isRequestedSessionIdFromURL, isRequestedSessionIdValid, isUserInRole
Methods inherited from class javax.servlet.ServletRequestWrapper
getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequest, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding, setRequest
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.ServletRequest
getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocalAddr, getLocale, getLocales, getLocalName, getLocalPort, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRemotePort, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

Field Detail

log

protected static final Log log

errors

Collection<String> errors

multi

MultiPartRequest multi
Constructor Detail

MultiPartRequestWrapper

public MultiPartRequestWrapper(MultiPartRequest multiPartRequest,
                               HttpServletRequest request,
                               String saveDir)
Process file downloads and log any errors.

Parameters:
request - Our HttpServletRequest object
saveDir - Target directory for any files that we save
multiPartRequest - Our MultiPartRequest object
Method Detail

getFileParameterNames

public Enumeration<String> getFileParameterNames()
Get an enumeration of the parameter names for uploaded files

Returns:
enumeration of parameter names for uploaded files

getContentTypes

public String[] getContentTypes(String name)
Get an array of content encoding for the specified input field name or null if no content type was specified.

Parameters:
name - input field name
Returns:
an array of content encoding for the specified input field name

getFiles

public File[] getFiles(String fieldName)
Get a File[] for the given input field name.

Parameters:
fieldName - input field name
Returns:
a File[] object for files associated with the specified input field name

getFileNames

public String[] getFileNames(String fieldName)
Get a String array of the file names for uploaded files

Parameters:
fieldName - Field to check for file names.
Returns:
a String[] of file names for uploaded files

getFileSystemNames

public String[] getFileSystemNames(String fieldName)
Get the filename(s) of the file(s) uploaded for the given input field name. Returns null if the file is not found.

Parameters:
fieldName - input field name
Returns:
the filename(s) of the file(s) uploaded for the given input field name or null if name not found.

getParameter

public String getParameter(String name)
Specified by:
getParameter in interface ServletRequest
Overrides:
getParameter in class ServletRequestWrapper
See Also:
ServletRequest.getParameter(String)

getParameterMap

public Map getParameterMap()
Specified by:
getParameterMap in interface ServletRequest
Overrides:
getParameterMap in class ServletRequestWrapper
See Also:
ServletRequest.getParameterMap()

getParameterNames

public Enumeration getParameterNames()
Specified by:
getParameterNames in interface ServletRequest
Overrides:
getParameterNames in class ServletRequestWrapper
See Also:
ServletRequest.getParameterNames()

getParameterValues

public String[] getParameterValues(String name)
Specified by:
getParameterValues in interface ServletRequest
Overrides:
getParameterValues in class ServletRequestWrapper
See Also:
ServletRequest.getParameterValues(String)

hasErrors

public boolean hasErrors()
Returns true if any errors occured when parsing the HTTP multipart request, false otherwise.

Returns:
true if any errors occured when parsing the HTTP multipart request, false otherwise.

getErrors

public Collection<String> getErrors()
Returns a collection of any errors generated when parsing the multipart request.

Returns:
the error Collection.

addError

protected void addError(String anErrorMessage)
Adds an error message.

Parameters:
anErrorMessage - the error message to report.

mergeParams

protected Enumeration mergeParams(Enumeration params1,
                                  Enumeration params2)
Merges 2 enumeration of parameters as one.

Parameters:
params1 - the first enumeration.
params2 - the second enumeration.
Returns:
a single Enumeration of all elements from both Enumerations.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.impl (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.impl

Class Summary
StrutsActionProxy
StrutsActionProxyFactory
StrutsObjectFactory


org.apache.struts2.impl Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.impl

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.DefaultActionProxy (implements com.opensymphony.xwork2.ActionProxy, java.io.Serializable)
      • org.apache.struts2.impl.StrutsActionProxy
    • com.opensymphony.xwork2.DefaultActionProxyFactory (implements com.opensymphony.xwork2.ActionProxyFactory)
      • org.apache.struts2.impl.StrutsActionProxyFactory
    • com.opensymphony.xwork2.ObjectFactory (implements java.io.Serializable)
      • org.apache.struts2.impl.StrutsObjectFactory


Uses of Package org.apache.struts2.impl (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.impl

No usage of org.apache.struts2.impl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


StrutsActionProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.impl
Class StrutsActionProxy

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionProxy
        extended by  org.apache.struts2.impl.StrutsActionProxy
All Implemented Interfaces:
ActionProxy, Serializable
public class StrutsActionProxy
extends DefaultActionProxy

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class com.opensymphony.xwork2.DefaultActionProxy
actionEventListener, actionName, cleanupContext, config, configuration, executeResult, extraContext, invocation, method, namespace, objectFactory, unknownHandler
Constructor Summary
StrutsActionProxy(String namespace, String actionName, Map extraContext, boolean executeResult, boolean cleanupContext)
Method Summary
 String execute()
Execute this ActionProxy.
Methods inherited from class com.opensymphony.xwork2.DefaultActionProxy
getAction, getActionName, getConfig, getExecuteResult, getInvocation, getMethod, getNamespace, prepare, setActionEventListener, setConfiguration, setExecuteResult, setMethod, setObjectFactory, setUnknownHandler
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

StrutsActionProxy

public StrutsActionProxy(String namespace,
                         String actionName,
                         Map extraContext,
                         boolean executeResult,
                         boolean cleanupContext)
                  throws Exception
Throws:
Exception
Method Detail

execute

public String execute()
               throws Exception
Description copied from interface: ActionProxy
Execute this ActionProxy. This will set the ActionContext from the ActionInvocation into the ActionContext ThreadLocal before invoking the ActionInvocation, then set the old ActionContext back into the ThreadLocal.

Specified by:
execute in interface ActionProxy
Overrides:
execute in class DefaultActionProxy
Returns:
the result code returned from executing the ActionInvocation
Throws:
Exception
See Also:
ActionInvocation
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


StrutsActionProxyFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.impl
Class StrutsActionProxyFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionProxyFactory
        extended by  org.apache.struts2.impl.StrutsActionProxyFactory
All Implemented Interfaces:
ActionProxyFactory
public class StrutsActionProxyFactory
extends DefaultActionProxyFactory

Field Summary
Fields inherited from class com.opensymphony.xwork2.DefaultActionProxyFactory
container
Constructor Summary
StrutsActionProxyFactory()
Method Summary
ActionProxy | createActionProxy(String namespace, String actionName, Map extraContext) Use this method to build an DefaultActionProxy instance.
ActionProxy | createActionProxy(String namespace, String actionName, Map extraContext, boolean executeResult, boolean cleanupContext) Use this method to build an DefaultActionProxy instance.
Methods inherited from class com.opensymphony.xwork2.DefaultActionProxyFactory
setContainer
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StrutsActionProxyFactory

public StrutsActionProxyFactory()
Method Detail

createActionProxy

public ActionProxy createActionProxy(String namespace,
                                     String actionName,
                                     Map extraContext)
                              throws Exception
Description copied from class: DefaultActionProxyFactory
Use this method to build an DefaultActionProxy instance.

Specified by:
createActionProxy in interface ActionProxyFactory
Overrides:
createActionProxy in class DefaultActionProxyFactory
Parameters:
namespace - the namespace of the action
extraContext - a Map of extra parameters to be provided to the ActionProxy
Returns:
ActionProxy
Throws:
Exception

createActionProxy

public ActionProxy createActionProxy(String namespace,
                                     String actionName,
                                     Map extraContext,
                                     boolean executeResult,
                                     boolean cleanupContext)
                              throws Exception
Description copied from class: DefaultActionProxyFactory
Use this method to build an DefaultActionProxy instance.

Specified by:
createActionProxy in interface ActionProxyFactory
Overrides:
createActionProxy in class DefaultActionProxyFactory
Parameters:
namespace - the namespace of the action
extraContext - a Map of extra parameters to be provided to the ActionProxy
executeResult - flag which tells whether the result should be executed after the action
Returns:
ActionProxy
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsObjectFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.impl
Class StrutsObjectFactory

java.lang.Object
    extended by  com.opensymphony.xwork2.ObjectFactory
        extended by  org.apache.struts2.impl.StrutsObjectFactory
All Implemented Interfaces:
Serializable
public class StrutsObjectFactory
extends ObjectFactory

See Also:
Serialized Form

Constructor Summary
StrutsObjectFactory()
Method Summary
Interceptor | buildInterceptor(InterceptorConfig interceptorConfig, Map refParams) Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.
Result | buildResult(ResultConfig resultConfig, Map extraContext) Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.
Methods inherited from class com.opensymphony.xwork2.ObjectFactory
buildAction, buildBean, buildBean, buildBean, buildValidator, getClassInstance, getObjectFactory, injectInternalBeans, isNoArgConstructorRequired, setClassLoader, setContainer, setObjectFactory
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StrutsObjectFactory

public StrutsObjectFactory()
Method Detail

buildInterceptor

public Interceptor buildInterceptor(InterceptorConfig interceptorConfig,
                                    Map refParams)
                             throws ConfigurationException
Description copied from class: ObjectFactory
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference. Implementations of this method should ensure that the Interceptor is parameterized with both the parameters from the Interceptor config and the interceptor ref Map (the interceptor ref params take precedence), and that the Interceptor.init() method is called on the Interceptor instance before it is returned.

Overrides:
buildInterceptor in class ObjectFactory
Parameters:
interceptorConfig - the InterceptorConfig from the configuration
refParams - a Map of params provided in the Interceptor reference in the Action mapping or InterceptorStack definition
Throws:
ConfigurationException

buildResult

public Result buildResult(ResultConfig resultConfig,
                          Map extraContext)
                   throws Exception
Description copied from class: ObjectFactory
Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.

Overrides:
buildResult in class ObjectFactory
Parameters:
resultConfig - the ResultConfig found for the action with the result code returned
extraContext - a Map of extra context which uses the same keys as the ActionContext
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.interceptor (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.interceptor

Web specific interceptor classes.

See:
Description

Interface Summary
ApplicationAware | Actions that want to be aware of the application Map object should implement this interface.
NoParameters | This marker interface should be implemented by actions that do not want any parameters set on them automatically.
ParameterAware | This interface gives actions an alternative way of receiving input parameters.
PrincipalAware | Actions that want access to the Principal information from HttpServletRequest object should implement this interface.
PrincipalProxy | Proxy interface used together with PrincipalAware interface.
RequestAware | Actions that want access to the current serlvet request attributes should implement this interface. This interface is only relevant if the Action is used in a servlet environment. Note that using this interface makes the Action tied to a servlet environment, so it should be avoided if possible since things like unit testing will become more difficult.
ServletRequestAware | All Actions that want to have access to the servlet request object must implement this interface.
ServletResponseAware | All Actions that want to have access to the servlet response object must implement this interface.
SessionAware | Actions that want access to the user's HTTP session should implement this interface.

Class Summary
BackgroundProcess | Background thread to be executed by the ExecuteAndWaitInterceptor.
CheckboxInterceptor | Looks for a hidden identification field that specifies the original value of the checkbox.
CreateSessionInterceptor | This interceptor creates the HttpSession.
ExecuteAndWaitInterceptor | The ExecuteAndWaitInterceptor is great for running long-lived actions in the background while showing the user a nice progress meter.
FileUploadInterceptor | Interceptor that is based off of MultiPartRequestWrapper, which is automatically applied for any request that includes a file.
MessageStoreInterceptor | An interceptor to store ValidationAware action's messages / errors and field errors into Http Session, such that it will be retrieveable at a later stage.
ProfilingActivationInterceptor | Allows profiling to be enabled or disabled via request parameters, when devMode is enabled.
RolesInterceptor | This interceptor ensures that the action will only be executed if the user has the correct role.
ScopeInterceptor | This is designed to solve a few simple issues related to wizard-like functionality in Struts.
ServletConfigInterceptor | An interceptor which sets action properties based on the interfaces an action implements.
StrutsConversionErrorInterceptor | This interceptor extends ConversionErrorInterceptor but only adds conversion errors from the ActionContext to the field errors of the action if the field value is not null, "", or {""} (a size 1 String array with only an empty String).
TokenInterceptor | Ensures that only one request per token is processed.
TokenSessionStoreInterceptor | This interceptor builds off of the TokenInterceptor, providing advanced logic for handling invalid tokens.

Package org.apache.struts2.interceptor Description

Web specific interceptor classes.


org.apache.struts2.interceptor Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.interceptor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
        • org.apache.struts2.interceptor.StrutsConversionErrorInterceptor
      • org.apache.struts2.interceptor.CreateSessionInterceptor
      • org.apache.struts2.interceptor.FileUploadInterceptor
      • com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
        • org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
        • org.apache.struts2.interceptor.TokenInterceptor
          • org.apache.struts2.interceptor.TokenSessionStoreInterceptor
      • org.apache.struts2.interceptor.ProfilingActivationInterceptor
      • org.apache.struts2.interceptor.RolesInterceptor
      • org.apache.struts2.interceptor.ScopeInterceptor (implements com.opensymphony.xwork2.interceptor.PreResultListener)
      • org.apache.struts2.interceptor.ServletConfigInterceptor (implements org.apache.struts2.StrutsStatics)
    • org.apache.struts2.interceptor.BackgroundProcess (implements java.io.Serializable)
    • org.apache.struts2.interceptor.CheckboxInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • org.apache.struts2.interceptor.MessageStoreInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)

Interface Hierarchy

  • org.apache.struts2.interceptor.ApplicationAware
  • com.opensymphony.xwork2.interceptor.NoParameters
    • org.apache.struts2.interceptor.NoParameters
  • org.apache.struts2.interceptor.ParameterAware
  • org.apache.struts2.interceptor.PrincipalAware
  • org.apache.struts2.interceptor.PrincipalProxy
  • org.apache.struts2.interceptor.RequestAware
  • org.apache.struts2.interceptor.ServletRequestAware
  • org.apache.struts2.interceptor.ServletResponseAware
  • org.apache.struts2.interceptor.SessionAware


Uses of Package org.apache.struts2.interceptor (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.interceptor

Packages that use org.apache.struts2.interceptor
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.portlet.interceptor |
org.apache.struts2.servlet.interceptor |

Classes in org.apache.struts2.interceptor used by org.apache.struts2.interceptor
BackgroundProcess
Background thread to be executed by the ExecuteAndWaitInterceptor.
PrincipalProxy
Proxy interface used together with PrincipalAware interface.
TokenInterceptor
Ensures that only one request per token is processed.

Classes in org.apache.struts2.interceptor used by org.apache.struts2.portlet.interceptor
PrincipalProxy
Proxy interface used together with PrincipalAware interface.

Classes in org.apache.struts2.interceptor used by org.apache.struts2.servlet.interceptor
PrincipalProxy
Proxy interface used together with PrincipalAware interface.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ApplicationAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface ApplicationAware

public interface ApplicationAware

Actions that want to be aware of the application Map object should implement this interface. This will give them access to a Map where they can put objects that should be available to other parts of the application.

Typical uses are configuration objects and caches.

Method Summary
 void setApplication(Map application)
Sets the map of application properties in the implementing class.

Method Detail

setApplication

void setApplication(Map application)
Sets the map of application properties in the implementing class.

Parameters:
application - a Map of application properties.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NoParameters (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface NoParameters

All Superinterfaces:
NoParameters
public interface NoParameters
extends NoParameters

This marker interface should be implemented by actions that do not want any parameters set on them automatically. This may be useful if one is using the action tag and want to supply the parameters to the action manually using the param tag. It may also be useful if one for security reasons wants to make sure that parameters cannot be set by malicious users.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParameterAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface ParameterAware

public interface ParameterAware

This interface gives actions an alternative way of receiving input parameters. The map will contain all input parameters as name/value entries. Actions that need this should simply implement it.

One common use for this is to have the action propagate parameters to internally instantiated data objects.

Note that all parameter values for a given name will be returned, so the type of the objects in the map is java.lang.String[].

Method Summary
 void setParameters(Map parameters)
Sets the map of input parameters in the implementing class.

Method Detail

setParameters

void setParameters(Map parameters)
Sets the map of input parameters in the implementing class.

Parameters:
parameters - a Map of parameters (name/value Strings).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrincipalAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface PrincipalAware

public interface PrincipalAware

Actions that want access to the Principal information from HttpServletRequest object should implement this interface.

This interface is only relevant if the Action is used in a servlet environment. By using this interface you will not become tied to servlet environment.

Method Summary
 void setPrincipalProxy(PrincipalProxy principalProxy)

Method Detail

setPrincipalProxy

void setPrincipalProxy(PrincipalProxy principalProxy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrincipalProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface PrincipalProxy

All Known Implementing Classes:
PortletPrincipalProxy, ServletPrincipalProxy
public interface PrincipalProxy

Proxy interface used together with PrincipalAware interface. It allows to get indirect access to HttpServletRequest or PortletRequest Principal related methods.

Method Summary
String | getRemoteUser() Gets the user id
HttpServletRequest | getRequest() Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
Principal | getUserPrincipal() Gets the user principal
boolean | isRequestSecure() Is the request using https?
boolean | isUserInRole(String role) True if the user is in the given role

Method Detail

isUserInRole

boolean isUserInRole(String role)
True if the user is in the given role

Parameters:
role - The role
Returns:
True if the user is in that role

getUserPrincipal

Principal getUserPrincipal()
Gets the user principal

Returns:
The principal

getRemoteUser

String getRemoteUser()
Gets the user id

Returns:
The user id

isRequestSecure

boolean isRequestSecure()
Is the request using https?

Returns:
True if using https

getRequest

HttpServletRequest getRequest()
Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.

Gets the request.

Returns:
The request
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RequestAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface RequestAware

public interface RequestAware

Actions that want access to the current serlvet request attributes should implement this interface.

This interface is only relevant if the Action is used in a servlet environment.

Note that using this interface makes the Action tied to a servlet environment, so it should be avoided if possible since things like unit testing will become more difficult.

Method Summary
 void setRequest(Map request)
Sets the Map of request attributes in the implementing class.

Method Detail

setRequest

void setRequest(Map request)
Sets the Map of request attributes in the implementing class.

Parameters:
request - a Map of HTTP request attribute name/value pairs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletRequestAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface ServletRequestAware

public interface ServletRequestAware

All Actions that want to have access to the servlet request object must implement this interface.

This interface is only relevant if the Action is used in a servlet environment.

Note that using this interface makes the Action tied to a servlet environment, so it should be avoided if possible since things like unit testing will become more difficult.

Method Summary
 void setServletRequest(HttpServletRequest request)
Sets the HTTP request object in implementing classes.

Method Detail

setServletRequest

void setServletRequest(HttpServletRequest request)
Sets the HTTP request object in implementing classes.

Parameters:
request - the HTTP request.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletResponseAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface ServletResponseAware

public interface ServletResponseAware

All Actions that want to have access to the servlet response object must implement this interface.

This interface is only relevant if the Action is used in a servlet environment.

Note that using this interface makes the Action tied to a servlet environment, so it should be avoided if possible since things like unit testing will become more difficult.

Method Summary
 void setServletResponse(HttpServletResponse response)
Sets the HTTP response object in implementing classes.

Method Detail

setServletResponse

void setServletResponse(HttpServletResponse response)
Sets the HTTP response object in implementing classes.

Parameters:
response - the HTTP response.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SessionAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Interface SessionAware

public interface SessionAware

Actions that want access to the user's HTTP session should implement this interface.

This interface is only relevant if the Action is used in a servlet environment.

Note that using this interface makes the Action tied to a servlet environment, so it should be avoided if possible since things like unit testing will become more difficult.

Method Summary
 void setSession(Map session)
Sets the Map of session attributes in the implementing class.

Method Detail

setSession

void setSession(Map session)
Sets the Map of session attributes in the implementing class.

Parameters:
session - a Map of HTTP session attribute name/value pairs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BackgroundProcess (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class BackgroundProcess

java.lang.Object
    extended by  org.apache.struts2.interceptor.BackgroundProcess
All Implemented Interfaces:
Serializable
public class BackgroundProcess
extends Object
implements Serializable

Background thread to be executed by the ExecuteAndWaitInterceptor.

See Also:
Serialized Form

Field Summary
protected Object | action
protected boolean | done
protected Exception | exception
protected ActionInvocation | invocation
protected String | result
private static long | serialVersionUID
Constructor Summary
BackgroundProcess(String threadName, ActionInvocation invocation, int threadPriority)
Constructs a background process
Method Summary
protected void | afterInvocation() Called after the background thread determines the result code from the ActionInvocation, but before the background thread is marked as done.
protected void | beforeInvocation() Called before the background thread determines the result code from the ActionInvocation.
Object | getAction() Retrieves the action.
Exception | getException() Gets the exception if any was thrown during the execution of the background process.
ActionInvocation | getInvocation() Retrieves the action invocation.
String | getResult() Gets the result of the background process.
boolean | isDone() Returns the status of the background process.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

action

protected Object action

invocation

protected ActionInvocation invocation

result

protected String result

exception

protected Exception exception

done

protected boolean done
Constructor Detail

BackgroundProcess

public BackgroundProcess(String threadName,
                         ActionInvocation invocation,
                         int threadPriority)
Constructs a background process

Parameters:
threadName - The thread name
invocation - The action invocation
threadPriority - The thread priority
Method Detail

beforeInvocation

protected void beforeInvocation()
                         throws Exception
Called before the background thread determines the result code from the ActionInvocation.

Throws:
Exception - any exception thrown will be thrown, in turn, by the ExecuteAndWaitInterceptor

afterInvocation

protected void afterInvocation()
                        throws Exception
Called after the background thread determines the result code from the ActionInvocation, but before the background thread is marked as done.

Throws:
Exception - any exception thrown will be thrown, in turn, by the ExecuteAndWaitInterceptor

getAction

public Object getAction()
Retrieves the action.

Returns:
the action.

getInvocation

public ActionInvocation getInvocation()
Retrieves the action invocation.

Returns:
the action invocation

getResult

public String getResult()
Gets the result of the background process.

Returns:
the result; null if not done.

getException

public Exception getException()
Gets the exception if any was thrown during the execution of the background process.

Returns:
the exception or null if no exception was thrown.

isDone

public boolean isDone()
Returns the status of the background process.

Returns:
true if finished, false otherwise
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckboxInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class CheckboxInterceptor

java.lang.Object
    extended by  org.apache.struts2.interceptor.CheckboxInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class CheckboxInterceptor
extends Object
implements Interceptor

Looks for a hidden identification field that specifies the original value of the checkbox. If the checkbox isn't submitted, insert it into the parameters as if it was with the value of 'false'.

  • setUncheckedValue - The default value of an unchecked box can be overridden by setting the 'uncheckedValue' property.

See Also:
Serialized Form

Field Summary
private static long | serialVersionUID Auto-generated serialization id
private String | uncheckedValue
Constructor Summary
CheckboxInterceptor()
Method Summary
void | destroy() Called to let an interceptor clean up any resources it has allocated.
void | init() Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.
String | intercept(ActionInvocation ai) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.
void | setUncheckedValue(String uncheckedValue) Overrides the default value for an unchecked checkbox
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
Auto-generated serialization id

See Also:
Constant Field Values

uncheckedValue

private String uncheckedValue
Constructor Detail

CheckboxInterceptor

public CheckboxInterceptor()
Method Detail

destroy

public void destroy()
Description copied from interface: Interceptor
Called to let an interceptor clean up any resources it has allocated.

Specified by:
destroy in interface Interceptor

init

public void init()
Description copied from interface: Interceptor
Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.

Specified by:
init in interface Interceptor

intercept

public String intercept(ActionInvocation ai)
                 throws Exception
Description copied from interface: Interceptor
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.

Specified by:
intercept in interface Interceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

setUncheckedValue

public void setUncheckedValue(String uncheckedValue)
Overrides the default value for an unchecked checkbox

Parameters:
uncheckedValue - The uncheckedValue to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CreateSessionInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class CreateSessionInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  org.apache.struts2.interceptor.CreateSessionInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class CreateSessionInterceptor
extends AbstractInterceptor

This interceptor creates the HttpSession.

This is particular usefull when using the <@s.token> tag in freemarker templates. The tag do require that a HttpSession is already created since freemarker commits the response to the client immediately.

Interceptor parameters:

  • none
  • None
Example:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="create-session"/>
     <interceptor-ref name="defaultStack"/>
     <result name="input">input_with_token_tag.ftl</result>
 </action>

Version:
$Date: 2006-11-06 10:01:43 -0500 (Mon, 06 Nov 2006) $ $Id: CreateSessionInterceptor.java 471756 2006-11-06 15:01:43Z husted $
See Also:
Serialized Form

Field Summary
private static Log | _log
private static long | serialVersionUID
Constructor Summary
CreateSessionInterceptor()
Method Summary
 String intercept(ActionInvocation invocation)
Override to handle interception
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

_log

private static final Log _log
Constructor Detail

CreateSessionInterceptor

public CreateSessionInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExecuteAndWaitInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class ExecuteAndWaitInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ExecuteAndWaitInterceptor
extends MethodFilterInterceptor

The ExecuteAndWaitInterceptor is great for running long-lived actions in the background while showing the user a nice progress meter. This also prevents the HTTP request from timing out when the action takes more than 5 or 10 minutes.

Using this interceptor is pretty straight forward. Assuming that you are including struts-default.xml, this interceptor is already configured but is not part of any of the default stacks. Because of the nature of this interceptor, it must be the last interceptor in the stack.

This interceptor works on a per-session basis. That means that the same action name (myLongRunningAction, in the above example) cannot be run more than once at a time in a given session. On the initial request or any subsequent requests (before the action has completed), the wait result will be returned. The wait result is responsible for issuing a subsequent request back to the action, giving the effect of a self-updating progress meter.

If no "wait" result is found, Struts will automatically generate a wait result on the fly. This result is written in FreeMarker and cannot run unless FreeMarker is installed. If you don't wish to deploy with FreeMarker, you must provide your own wait result. This is generally a good thing to do anyway, as the default wait page is very plain.

Whenever the wait result is returned, the action that is currently running in the background will be placed on top of the stack. This allows you to display progress data, such as a count, in the wait page. By making the wait page automatically reload the request to the action (which will be short-circuited by the interceptor), you can give the appearance of an automatic progress meter.

This interceptor also supports using an initial wait delay. An initial delay is a time in milliseconds we let the server wait before the wait page is shown to the user. During the wait this interceptor will wake every 100 millis to check if the background process is done premature, thus if the job for some reason doesn't take to long the wait page is not shown to the user.
This is useful for e.g. search actions that have a wide span of execution time. Using a delay time of 2000 millis we ensure the user is presented fast search results immediately and for the slow results a wait page is used.

Important: Because the action will be running in a seperate thread, you can't use ActionContext because it is a ThreadLocal. This means if you need to access, for example, session data, you need to implement SessionAware rather than calling ActionContext.getSesion().

The thread kicked off by this interceptor will be named in the form actionNameBrackgroundProcess. For example, the search action would run as a thread named searchBackgroundProcess.

Interceptor parameters:

  • threadPriority (optional) - the priority to assign the thread. Default is Thread.NORM_PRIORITY.
  • delay (optional) - an initial delay in millis to wait before the wait page is shown (returning wait as result code). Default is no initial delay.
  • delaySleepInterval (optional) - only used with delay. Used for waking up at certain intervals to check if the background process is already done. Default is 100 millis.

Extending the interceptor:

If you wish to make special preparations before and/or after the invocation of the background thread, you can extend the BackgroundProcess class and implement the beforeInvocation() and afterInvocation() methods. This may be useful for obtaining and releasing resources that the background process will need to execute successfully. To use your background process extension, extend ExecuteAndWaitInterceptor and implement the getNewBackgroundProcess() method.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="execAndWait"/>
     <result name="wait">longRunningAction-wait.jsp</result>
     <result name="success">longRunningAction-success.jsp</result>
 </action>

 <%@ taglib prefix="s" uri="/struts" %>
 <html>
   <head>
     <title>Please wait</title>
     <meta http-equiv="refresh" content="5;url=<a:url includeParams="all" />"/>
   </head>
   <body>
     Please wait while we process your request.
     Click <a href="<a:url includeParams="all" />"></a> if this page does not reload automatically.
   </body>
 </html>

Example code2: This example will wait 2 second (2000 millis) before the wait page is shown to the user. Therefore if the long process didn't last long anyway the user isn't shown a wait page.

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="execAndWait">
         <param name="delay">2000<param>
     <interceptor-ref>
     <result name="wait">longRunningAction-wait.jsp</result>
     <result name="success">longRunningAction-success.jsp</result>
 </action>

Example code3: This example will wait 1 second (1000 millis) before the wait page is shown to the user. And at every 50 millis this interceptor will check if the background process is done, if so it will return before the 1 second has elapsed, and the user isn't shown a wait page.

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="completeStack"/>
     <interceptor-ref name="execAndWait">
         <param name="delay">1000<param>
         <param name="delaySleepInterval">50<param>
     <interceptor-ref>
     <result name="wait">longRunningAction-wait.jsp</result>
     <result name="success">longRunningAction-success.jsp</result>
 </action>

See Also:
Serialized Form

Field Summary
protected int | delay
protected int | delaySleepInterval
protected boolean | executeAfterValidationPass
static String | KEY
private static Log | LOG
private static long | serialVersionUID
private int | threadPriority
static String | WAIT
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
ExecuteAndWaitInterceptor()
Method Summary
void | destroy() Does nothing
protected String | doIntercept(ActionInvocation actionInvocation) Subclasses must override to implement the interceptor logic.
protected String | getBackgroundProcessName(ActionProxy proxy) Returns the name to associate the background process.
protected BackgroundProcess | getNewBackgroundProcess(String name, ActionInvocation actionInvocation, int threadPriority) Creates a new background process
void | init() Does nothing
protected void | performInitialDelay(BackgroundProcess bp) Performs the initial delay.
void | setDelay(int delay) Sets the initial delay in millis (msec).
void | setDelaySleepInterval(int delaySleepInterval) Sets the sleep interval in millis (msec) when performing the initial delay.
void | setExecuteAfterValidationPass(boolean executeAfterValidationPass) Whether to start the background process after the second pass (first being validation) or not
void | setThreadPriority(int threadPriority) Sets the thread priority of the background process.
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

LOG

private static final Log LOG

KEY

public static final String KEY
See Also:
Constant Field Values

WAIT

public static final String WAIT
See Also:
Constant Field Values

delay

protected int delay

delaySleepInterval

protected int delaySleepInterval

executeAfterValidationPass

protected boolean executeAfterValidationPass

threadPriority

private int threadPriority
Constructor Detail

ExecuteAndWaitInterceptor

public ExecuteAndWaitInterceptor()
Method Detail

init

public void init()
Description copied from class: AbstractInterceptor
Does nothing

Specified by:
init in interface Interceptor
Overrides:
init in class AbstractInterceptor

getNewBackgroundProcess

protected BackgroundProcess getNewBackgroundProcess(String name,
                                                    ActionInvocation actionInvocation,
                                                    int threadPriority)
Creates a new background process

Parameters:
name - The process name
actionInvocation - The action invocation
threadPriority - The thread priority
Returns:
The new process

getBackgroundProcessName

protected String getBackgroundProcessName(ActionProxy proxy)
Returns the name to associate the background process. Override to change the way background processes are mapped to requests.

Parameters:
actionInvocation - The action invocation
Returns:
the name of the background thread

doIntercept

protected String doIntercept(ActionInvocation actionInvocation)
                      throws Exception
Description copied from class: MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.

Specified by:
doIntercept in class MethodFilterInterceptor
Parameters:
actionInvocation - the action invocation
Returns:
the result of invocation
Throws:
Exception

destroy

public void destroy()
Description copied from class: AbstractInterceptor
Does nothing

Specified by:
destroy in interface Interceptor
Overrides:
destroy in class AbstractInterceptor

performInitialDelay

protected void performInitialDelay(BackgroundProcess bp)
                            throws InterruptedException
Performs the initial delay.

When this interceptor is executed for the first time this methods handles any provided initial delay. An initial delay is a time in miliseconds we let the server wait before we continue.
During the wait this interceptor will wake every 100 millis to check if the background process is done premature, thus if the job for some reason doesn't take to long the wait page is not shown to the user.

Parameters:
bp - the background process
Throws:
InterruptedException - is thrown by Thread.sleep

setThreadPriority

public void setThreadPriority(int threadPriority)
Sets the thread priority of the background process.

Parameters:
threadPriority - the priority from Thread.XXX

setDelay

public void setDelay(int delay)
Sets the initial delay in millis (msec).

Parameters:
delay - in millis. (0 for not used)

setDelaySleepInterval

public void setDelaySleepInterval(int delaySleepInterval)
Sets the sleep interval in millis (msec) when performing the initial delay.

Parameters:
delaySleepInterval - in millis (0 for not used)

setExecuteAfterValidationPass

public void setExecuteAfterValidationPass(boolean executeAfterValidationPass)
Whether to start the background process after the second pass (first being validation) or not

Parameters:
executeAfterValidationPass - the executeAfterValidationPass to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileUploadInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class FileUploadInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  org.apache.struts2.interceptor.FileUploadInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class FileUploadInterceptor
extends AbstractInterceptor

Interceptor that is based off of MultiPartRequestWrapper, which is automatically applied for any request that includes a file. It adds the following parameters, where [File Name] is the name given to the file uploaded by the HTML form:

  • [File Name] : File - the actual File
  • [File Name]ContentType : String - the content type of the file
  • [File Name]FileName : String - the actual name of the file uploaded (not the HTML name)

You can get access to these files by merely providing setters in your action that correspond to any of the three patterns above, such as setDocument(File document), setDocumentContentType(String contentType), etc.
See the example code section.

This interceptor will add several field errors, assuming that the action implements ValidationAware. These error messages are based on several i18n values stored in struts-messages.properties, a default i18n file processed for all i18n requests. You can override the text of these messages by providing text for the following keys:

  • struts.messages.error.uploading - a general error that occurs when the file could not be uploaded
  • struts.messages.error.file.too.large - occurs when the uploaded file is too large
  • struts.messages.error.content.type.not.allowed - occurs when the uploaded file does not match the expected content types specified

Interceptor parameters:

  • maximumSize (optional) - the maximum size (in bytes) that the interceptor will allow a file reference to be set on the action. Note, this is not related to the various properties found in struts.properties. Default to approximately 2MB.
  • allowedTypes (optional) - a comma separated list of content types (ie: text/html) that the interceptor will allow a file reference to be set on the action. If none is specified allow all types to be uploaded.

Extending the interceptor:

You can extend this interceptor and override the acceptFile(java.io.File, java.lang.String, java.lang.String, com.opensymphony.xwork2.ValidationAware, java.util.Locale) method to provide more control over which files are supported and which are not.

Example code:

 <action name="doUpload" class="com.examples.UploadAction">
     <interceptor-ref name="fileUpload"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>
And then you need to set encoding multipart/form-data in the form where the user selects the file to upload.
   <a:form action="doUpload" method="post" enctype="multipart/form-data">
       <a:file name="upload" label="File"/>
       <a:submit/>
   </a:form>
And then in your action code you'll have access to the File object if you provide setters according to the naming convention documented in the start.
    public com.examples.UploadAction implemements Action {
       private File file;
       private String contentType;
       private String filename;

       public void setUpload(File file) {
          this.file = file;
       }

       public void setUploadContentType(String contentType) {
          this.contentType = contentType;
       }

       public void setUploadFileName(String filename) {
          this.filename = filename;
       }

       ...
  }

See Also:
Serialized Form

Field Summary
protected String | allowedTypes
protected Set | allowedTypesSet
private static String | DEFAULT_DELIMITER
private static String | DEFAULT_MESSAGE
protected static Log | log
protected Long | maximumSize
private static long | serialVersionUID
Constructor Summary
FileUploadInterceptor()
Method Summary
protected boolean | acceptFile(File file, String contentType, String inputName, ValidationAware validation, Locale locale) Override for added functionality.
private static boolean | containsItem(Collection itemCollection, String key)
private static Set | getDelimitedValues(String delimitedString)
private String | getTextMessage(String messageKey, Object[] args, Locale locale)
String | intercept(ActionInvocation invocation) Override to handle interception
private static boolean | isNonEmpty(Object[] objArray)
void | setAllowedTypes(String allowedTypes) Sets the allowed mimetypes
void | setMaximumSize(Long maximumSize) Sets the maximum size of an uploaded file
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

log

protected static final Log log

DEFAULT_DELIMITER

private static final String DEFAULT_DELIMITER
See Also:
Constant Field Values

DEFAULT_MESSAGE

private static final String DEFAULT_MESSAGE
See Also:
Constant Field Values

maximumSize

protected Long maximumSize

allowedTypes

protected String allowedTypes

allowedTypesSet

protected Set allowedTypesSet
Constructor Detail

FileUploadInterceptor

public FileUploadInterceptor()
Method Detail

setAllowedTypes

public void setAllowedTypes(String allowedTypes)
Sets the allowed mimetypes

Parameters:
allowedTypes - A comma-delimited list of types

setMaximumSize

public void setMaximumSize(Long maximumSize)
Sets the maximum size of an uploaded file

Parameters:
maximumSize - The maximum size in bytes

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

acceptFile

protected boolean acceptFile(File file,
                             String contentType,
                             String inputName,
                             ValidationAware validation,
                             Locale locale)
Override for added functionality. Checks if the proposed file is acceptable based on contentType and size.

Parameters:
file - - proposed upload file.
contentType - - contentType of the file.
inputName - - inputName of the file.
validation - - Non-null ValidationAware if the action implements ValidationAware, allowing for better logging.
locale -
Returns:
true if the proposed file is acceptable by contentType and size.

containsItem

private static boolean containsItem(Collection itemCollection,
                                    String key)
Parameters:
itemCollection - - Collection of string items (all lowercase).
key - - Key to search for.
Returns:
true if itemCollection contains the key, false otherwise.

getDelimitedValues

private static Set getDelimitedValues(String delimitedString)

isNonEmpty

private static boolean isNonEmpty(Object[] objArray)

getTextMessage

private String getTextMessage(String messageKey,
                              Object[] args,
                              Locale locale)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MessageStoreInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class MessageStoreInterceptor

java.lang.Object
    extended by  org.apache.struts2.interceptor.MessageStoreInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class MessageStoreInterceptor
extends Object
implements Interceptor

An interceptor to store ValidationAware action's messages / errors and field errors into Http Session, such that it will be retrieveable at a later stage. This allows the action's message / errors and field errors to be available longer that just the particular http request.

In the 'STORE' mode, the interceptor will store the ValidationAware action's message / errors and field errors into Http session.

In the 'RETRIEVE' mode, the interceptor will retrieve the stored action's message / errors and field errors and put them back into the ValidationAware action.

The interceptor does nothing in the 'NONE' mode, which is the default.

The operation mode could be switched using :-

1] Setting the iterceptor parameter eg.

   <action name="submitApplication" ...>
      <interceptor-ref name="store">
         <param name="operationMode">l;STORE</param>
      </interceptor-ref>
      <interceptor-ref name="defaultStack" />
      ....
   </action>
2] Through request parameter (allowRequestParameterSwitch must be 'true' which is the default)
   // the request will have the operation mode in 'STORE'
   http://localhost:8080/context/submitApplication.action?operationMode=STORE
  • allowRequestParameterSwitch - To enable request parameter that could switch the operation mode of this interceptor.
  • requestParameterSwitch - The request parameter that will indicate what mode this interceptor is in.
  • operationMode - The operation mode this interceptor should be in (either 'STORE', 'RETRIEVE' or 'NONE'). 'NONE' being the default.

The following method could be overriden :-

  • getRequestOperationMode - get the operation mode of this interceptor based on the request parameters
  • mergeCollection - merge two collections
  • mergeMap - merge two map

 <action name="submitApplication" ....>
    <interceptor-ref name="store">
      <param name="operationMode">STORE</param>
    </interceptor-ref>
    <interceptor-ref name="defaultStack" />
    <result name="input" type="redirect">applicationFailed.action</result>
    <result type="dispatcher">applicationSuccess.jsp</result>
 </action>

 <action name="applicationFailed" ....>
    <interceptor-ref name="store">
       <param name="operationMode">RETRIEVE</param>
    </interceptor-ref>
    <result>applicationFailed.jsp</result>
 </action>
With the example above, 'submitApplication.action' will have the action messages / errors / field errors stored in the Http Session. Later when needed, (in this case, when 'applicationFailed.action' is fired, it will get the action messages / errors / field errors stored in the Http Session and put them back into the action.

Version:
$Date: 2006-11-06 10:01:43 -0500 (Mon, 06 Nov 2006) $ $Id: MessageStoreInterceptor.java 471756 2006-11-06 15:01:43Z husted $
See Also:
Serialized Form

Field Summary
private static Log | _log
static String | actionErrorsSessionKey
static String | actionMessagesSessionKey
private boolean | allowRequestParameterSwitch
static String | fieldErrorsSessionKey
static String | NONE
private String | operationMode
private String | requestParameterSwitch
static String | RETRIEVE_MODE
private static long | serialVersionUID
static String | STORE_MODE
Constructor Summary
MessageStoreInterceptor()
Method Summary
protected void | after(ActionInvocation invocation, String result) Handle the storing of field errors / action messages / field errors, which is done after action invocation, and the operationMode is in 'STORE'.
protected void | before(ActionInvocation invocation) Handle the retrieving of field errors / action messages / field errors, which is done before action invocation, and the operationMode is 'RETRIEVE'.
void | destroy() Called to let an interceptor clean up any resources it has allocated.
boolean | getAllowRequestParameterSwitch()
String | getOperationModel()
protected String | getRequestOperationMode(ActionInvocation invocation) Get the operationMode through request paramter, if allowRequestParameterSwitch is 'true', else it simply returns 'NONE', meaning its neither in the 'STORE_MODE' nor 'RETRIEVE_MODE'.
String | getRequestParameterSwitch()
void | init() Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.
String | intercept(ActionInvocation invocation) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.
protected Collection | mergeCollection(Collection col1, Collection col2) Merge col1 and col2 and return the composite Collection.
protected Map | mergeMap(Map map1, Map map2) Merge map1 and map2 and return the composite Map
void | setAllowRequestParameterSwitch(boolean allowRequestParameterSwitch)
void | setOperationMode(String operationMode)
void | setRequestParameterSwitch(String requestParameterSwitch)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

_log

private static final Log _log

STORE_MODE

public static final String STORE_MODE
See Also:
Constant Field Values

RETRIEVE_MODE

public static final String RETRIEVE_MODE
See Also:
Constant Field Values

NONE

public static final String NONE
See Also:
Constant Field Values

allowRequestParameterSwitch

private boolean allowRequestParameterSwitch

requestParameterSwitch

private String requestParameterSwitch

operationMode

private String operationMode

fieldErrorsSessionKey

public static String fieldErrorsSessionKey

actionErrorsSessionKey

public static String actionErrorsSessionKey

actionMessagesSessionKey

public static String actionMessagesSessionKey
Constructor Detail

MessageStoreInterceptor

public MessageStoreInterceptor()
Method Detail

setAllowRequestParameterSwitch

public void setAllowRequestParameterSwitch(boolean allowRequestParameterSwitch)

getAllowRequestParameterSwitch

public boolean getAllowRequestParameterSwitch()

setRequestParameterSwitch

public void setRequestParameterSwitch(String requestParameterSwitch)

getRequestParameterSwitch

public String getRequestParameterSwitch()

setOperationMode

public void setOperationMode(String operationMode)

getOperationModel

public String getOperationModel()

destroy

public void destroy()
Description copied from interface: Interceptor
Called to let an interceptor clean up any resources it has allocated.

Specified by:
destroy in interface Interceptor

init

public void init()
Description copied from interface: Interceptor
Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.

Specified by:
init in interface Interceptor

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from interface: Interceptor
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.

Specified by:
intercept in interface Interceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

before

protected void before(ActionInvocation invocation)
               throws Exception
Handle the retrieving of field errors / action messages / field errors, which is done before action invocation, and the operationMode is 'RETRIEVE'.

Parameters:
invocation -
Throws:
Exception

after

protected void after(ActionInvocation invocation,
                     String result)
              throws Exception
Handle the storing of field errors / action messages / field errors, which is done after action invocation, and the operationMode is in 'STORE'.

Parameters:
invocation -
result -
Throws:
Exception

getRequestOperationMode

protected String getRequestOperationMode(ActionInvocation invocation)
Get the operationMode through request paramter, if allowRequestParameterSwitch is 'true', else it simply returns 'NONE', meaning its neither in the 'STORE_MODE' nor 'RETRIEVE_MODE'.

Returns:
String

mergeCollection

protected Collection mergeCollection(Collection col1,
                                     Collection col2)
Merge col1 and col2 and return the composite Collection.

Parameters:
col1 -
col2 -
Returns:
Collection

mergeMap

protected Map mergeMap(Map map1,
                       Map map2)
Merge map1 and map2 and return the composite Map

Parameters:
map1 -
map2 -
Returns:
Map
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProfilingActivationInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class ProfilingActivationInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  org.apache.struts2.interceptor.ProfilingActivationInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class ProfilingActivationInterceptor
extends AbstractInterceptor

Allows profiling to be enabled or disabled via request parameters, when devMode is enabled.

  • profilingKey
none

 // to change the profiling key

   ...

      profilingKey

   ...

Version:
$Date: 2006-11-23 12:31:52 -0500 (Thu, 23 Nov 2006) $ $Id: ProfilingActivationInterceptor.java 478625 2006-11-23 17:31:52Z wsmoak $
See Also:
Serialized Form

Field Summary
private boolean | devMode
private String | profilingKey
Constructor Summary
ProfilingActivationInterceptor()
Method Summary
String | getProfilingKey()
String | intercept(ActionInvocation invocation) Override to handle interception
void | setDevMode(String mode)
void | setProfilingKey(String profilingKey)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

profilingKey

private String profilingKey

devMode

private boolean devMode
Constructor Detail

ProfilingActivationInterceptor

public ProfilingActivationInterceptor()
Method Detail

getProfilingKey

public String getProfilingKey()
Returns:
the profilingKey

setProfilingKey

public void setProfilingKey(String profilingKey)
Parameters:
profilingKey - the profilingKey to set

setDevMode

public void setDevMode(String mode)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RolesInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class RolesInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  org.apache.struts2.interceptor.RolesInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class RolesInterceptor
extends AbstractInterceptor

This interceptor ensures that the action will only be executed if the user has the correct role.

Interceptor parameters:

  • allowedRoles - a comma-separated list of roles to allow
  • disallowedRoles - a comma-separated list of roles to disallow
There are two extensions to the existing interceptor:
  • isAllowed(HttpServletRequest,Object) - whether or not to allow the passed action execution with this request
  • handleRejection(ActionInvocation) - handles an unauthorized request.
  <!-- START SNIPPET: example -->
  <!-- only allows the admin and member roles -->
  <action name="someAction" class="com.examples.SomeAction">
      <interceptor-ref name="completeStack"/>
      <interceptor-ref name="roles">
        <param name="allowedRoles">admin,member</param>
      </interceptor-ref>
      <result name="success">good_result.ftl</result>
  </action>
  <!-- END SNIPPET: example -->

See Also:
Serialized Form

Field Summary
private List<String> | allowedRoles
private List<String> | disallowedRoles
Constructor Summary
RolesInterceptor()
Method Summary
protected String | handleRejection(ActionInvocation invocation, HttpServletResponse response) Handles a rejection by sending a 403 HTTP error
String | intercept(ActionInvocation invocation) Override to handle interception
protected boolean | isAllowed(HttpServletRequest request, Object action) Determines if the request should be allowed for the action
void | setAllowedRoles(String roles)
void | setDisallowedRoles(String roles)
protected List<String> | stringToList(String val) Splits a string into a List
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

allowedRoles

private List<String> allowedRoles

disallowedRoles

private List<String> disallowedRoles
Constructor Detail

RolesInterceptor

public RolesInterceptor()
Method Detail

setAllowedRoles

public void setAllowedRoles(String roles)

setDisallowedRoles

public void setDisallowedRoles(String roles)

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

stringToList

protected List<String> stringToList(String val)
Splits a string into a List

isAllowed

protected boolean isAllowed(HttpServletRequest request,
                            Object action)
Determines if the request should be allowed for the action

Parameters:
request - The request
action - The action object
Returns:
True if allowed, false otherwise

handleRejection

protected String handleRejection(ActionInvocation invocation,
                                 HttpServletResponse response)
                          throws Exception
Handles a rejection by sending a 403 HTTP error

Parameters:
invocation - The invocation
Returns:
The result code
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScopeInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class ScopeInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  org.apache.struts2.interceptor.ScopeInterceptor
All Implemented Interfaces:
Interceptor, PreResultListener, Serializable
public class ScopeInterceptor
extends AbstractInterceptor
implements PreResultListener

This is designed to solve a few simple issues related to wizard-like functionality in Struts. One of those issues is that some applications have a application-wide parameters commonly used, such pageLen (used for records per page). Rather than requiring that each action check if such parameters are supplied, this interceptor can look for specified parameters and pull them out of the session.

This works by setting listed properties at action start with values from session/application attributes keyed after the action's class, the action's name, or any supplied key. After action is executed all the listed properties are taken back and put in session or application context.

To make sure that each execution of the action is consistent it makes use of session-level locking. This way it guarantees that each action execution is atomic at the session level. It doesn't guarantee application level consistency however there has yet to be enough reasons to do so. Application level consistency would also be a big performance overkill.

Note that this interceptor takes a snapshot of action properties just before result is presented (using a PreResultListener), rather than after action is invoked. There is a reason for that: At this moment we know that action's state is "complete" as it's values may depend on the rest of the stack and specifically - on the values of nested interceptors.

Interceptor parameters:

  • session - a list of action properties to be bound to session scope
  • application - a list of action properties to be bound to application scope
  • key - a session/application attribute key prefix, can contain following values:
    • CLASS - that creates a unique key prefix based on action namespace and action class, it's a default value
    • ACTION - creates a unique key prefix based on action namespace and action name
    • any other value is taken literally as key prefix
  • type - with one of the following
    • start - means it's a start action of the wizard-like action sequence and all session scoped properties are reset to their defaults
    • end - means that session scoped properties are removed from session after action is run
    • any other value or no value means that it's in-the-middle action that is set with session properties before it's executed, and it's properties are put back to session after execution
  • sessionReset - boolean value causing all session values to be reset to action's default values or application scope values, note that it is similliar to type="start" and in fact it does the same, but in our team it is sometimes semantically preferred. We use session scope in two patterns - sometimes there are wizzard-like action sequences that have start and end, and sometimes we just want simply reset current session values.

Extending the interceptor:

There are no know extension points for this interceptor.

Example code:

 <!-- As the filter and orderBy parameters are common for all my browse-type actions,
      you can move control to the scope interceptor. In the session parameter you can list
      action properties that are going to be automatically managed over session. You can
      do the same for application-scoped variables-->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="basicStack"/>
     <interceptor-ref name="hibernate"/>
     <interceptor-ref name="scope">
         <param name="session">filter,orderBy</param>
         <param name="autoCreateSession">true</param>
     </interceptor-ref>
     <result name="success">good_result.ftl</result>
 </action>

See Also:
Serialized Form

Field Summary
private String[] | application
private boolean | autoCreateSession
private String | key
private static Map | locks
private static Log | LOG
private static Object | NULL
private boolean | reset
private static long | serialVersionUID
private String[] | session
private String | sessionReset
private String | type
Constructor Summary
ScopeInterceptor()
The constructor
Method Summary
protected void | after(ActionInvocation invocation, String result)
protected void | before(ActionInvocation invocation)
void | beforeResult(ActionInvocation invocation, String resultCode) This callback method will be called after the Action execution and before the Result execution.
private String | getKey(ActionInvocation invocation)
String | getSessionReset()
String | getType()
String | intercept(ActionInvocation invocation) Override to handle interception
boolean | isReset()
(package private) static void | lock(Object o, ActionInvocation invocation)
private static Object | nullConvert(Object o)
void | setApplication(String s) Sets a list of application scoped properties
void | setAutoCreateSession(String value) Sets if the session should be automatically created
void | setKey(String key)
void | setReset(boolean reset)
void | setSession(String s) Sets a list of session scoped properties
void | setSessionReset(String sessionReset)
void | setType(String type) Sets the type of scope operation
(package private) static void | unlock(Object o)
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

LOG

private static final Log LOG

application

private String[] application

session

private String[] session

key

private String key

type

private String type

autoCreateSession

private boolean autoCreateSession

sessionReset

private String sessionReset

reset

private boolean reset

NULL

private static final Object NULL

locks

private static Map locks
Constructor Detail

ScopeInterceptor

public ScopeInterceptor()
The constructor

Method Detail

setApplication

public void setApplication(String s)
Sets a list of application scoped properties

Parameters:
s - A comma-delimited list

setSession

public void setSession(String s)
Sets a list of session scoped properties

Parameters:
s - A comma-delimited list

setAutoCreateSession

public void setAutoCreateSession(String value)
Sets if the session should be automatically created

Parameters:
value - True if it should be created

getKey

private String getKey(ActionInvocation invocation)

nullConvert

private static final Object nullConvert(Object o)

lock

static final void lock(Object o,
                       ActionInvocation invocation)
                throws Exception
Throws:
Exception

unlock

static final void unlock(Object o)

after

protected void after(ActionInvocation invocation,
                     String result)
              throws Exception
Throws:
Exception

before

protected void before(ActionInvocation invocation)
               throws Exception
Throws:
Exception

setKey

public void setKey(String key)

beforeResult

public void beforeResult(ActionInvocation invocation,
                         String resultCode)
Description copied from interface: PreResultListener
This callback method will be called after the Action execution and before the Result execution.

Specified by:
beforeResult in interface PreResultListener

getType

public String getType()
Returns:
The type of scope operation, "start" or "end"

setType

public void setType(String type)
Sets the type of scope operation

Parameters:
type - Either "start" or "end"

getSessionReset

public String getSessionReset()
Returns:
Gets the session reset parameter name

setSessionReset

public void setSessionReset(String sessionReset)
Parameters:
sessionReset - The session reset parameter name

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

isReset

public boolean isReset()
Returns:
True if the scope is reset

setReset

public void setReset(boolean reset)
Parameters:
reset - True if the scope should be reset
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletConfigInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class ServletConfigInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  org.apache.struts2.interceptor.ServletConfigInterceptor
All Implemented Interfaces:
Interceptor, Serializable, StrutsStatics
public class ServletConfigInterceptor
extends AbstractInterceptor
implements StrutsStatics

An interceptor which sets action properties based on the interfaces an action implements. For example, if the action implements ParameterAware then the action context's parameter map will be set on it.

This interceptor is designed to set all properties an action needs if it's aware of servlet parameters, the servlet context, the session, etc. Interfaces that it supports are:

  • ServletContextAware
  • ServletRequestAware
  • ServletResponseAware
  • ParameterAware
  • RequestAware
  • SessionAware
  • ApplicationAware
  • PrincipalAware

Interceptor parameters:

  • None

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="servlet-config"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

See Also:
ServletContextAware, ServletRequestAware, ServletResponseAware, ParameterAware, SessionAware, ApplicationAware, PrincipalAware, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
ServletConfigInterceptor()
Method Summary
 String intercept(ActionInvocation invocation)
Sets action properties based on the interfaces an action implements.
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

ServletConfigInterceptor

public ServletConfigInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Sets action properties based on the interfaces an action implements. Things like application properties, parameters, session attributes, etc are set based on the implementing interface.

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Parameters:
invocation - an encapsulation of the action execution state.
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - if an error occurs when setting action properties.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsConversionErrorInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class StrutsConversionErrorInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
            extended by  org.apache.struts2.interceptor.StrutsConversionErrorInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class StrutsConversionErrorInterceptor
extends ConversionErrorInterceptor

This interceptor extends ConversionErrorInterceptor but only adds conversion errors from the ActionContext to the field errors of the action if the field value is not null, "", or {""} (a size 1 String array with only an empty String). See ConversionErrorInterceptor for more information, as well as the Type Conversion documentation.

Interceptor parameters:

  • None

Extending the interceptor:

There are no known extension points for this interceptor.

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="params"/>
     <interceptor-ref name="conversionError"/>
     <result name="success">good_result.ftl</result>
 </action>

See Also:
ActionContext.getConversionErrors(), ConversionErrorInterceptor, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
ORIGINAL_PROPERTY_OVERRIDE
Constructor Summary
StrutsConversionErrorInterceptor()
Method Summary
protected Object | getOverrideExpr(ActionInvocation invocation, Object value)
protected boolean | shouldAddError(String propertyName, Object value) Returns false if the value is null, "", or {""} (array of size 1 with a blank element).
Methods inherited from class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
intercept
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

StrutsConversionErrorInterceptor

public StrutsConversionErrorInterceptor()
Method Detail

getOverrideExpr

protected Object getOverrideExpr(ActionInvocation invocation,
                                 Object value)
Overrides:
getOverrideExpr in class ConversionErrorInterceptor

shouldAddError

protected boolean shouldAddError(String propertyName,
                                 Object value)
Returns false if the value is null, "", or {""} (array of size 1 with a blank element). Returns true otherwise.

Overrides:
shouldAddError in class ConversionErrorInterceptor
Parameters:
propertyName - the name of the property to check.
value - the value to error check.
Returns:
false if the value is null, "", or {""}, true otherwise.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TokenInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class TokenInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  org.apache.struts2.interceptor.TokenInterceptor
All Implemented Interfaces:
Interceptor, Serializable
Direct Known Subclasses:
TokenSessionStoreInterceptor
public class TokenInterceptor
extends MethodFilterInterceptor

Ensures that only one request per token is processed. This interceptor can make sure that back buttons and double clicks don't cause un-intended side affects. For example, you can use this to prevent careless users who might double click on a "checkout" button at an online store. This interceptor uses a fairly primitive technique for when an invalid token is found: it returns the result invalid.token, which can be mapped in your action configuration. A more complex implementation, TokenSessionStoreInterceptor, can provide much better logic for when invalid tokens are found.

Note: To set a token in your form, you should use the token tag. This tag is required and must be used in the forms that submit to actions protected by this interceptor. Any request that does not provide a token (using the token tag) will be processed as a request with an invalid token.

Internationalization Note: The following key could be used to internationalized the action errors generated by this token interceptor

  • struts.messages.invalid.token

NOTE: As this method extends off MethodFilterInterceptor, it is capable of deciding if it is applicable only to selective methods in the action class. See MethodFilterInterceptor for more info.

Interceptor parameters:

  • None

Extending the interceptor:

While not very common for users to extend, this interceptor is extended by the TokenSessionStoreInterceptor. The handleInvalidToken(com.opensymphony.xwork2.ActionInvocation) and handleValidToken(com.opensymphony.xwork2.ActionInvocation) methods are protected and available for more interesting logic, such as done with the token session interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="token"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

 <-- In this case, myMethod of the action class will not
        get checked for invalidity of token -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="token">
        <param name="excludeMethods">myMethod</param>
     </interceptor-ref name="token"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

See Also:
TokenSessionStoreInterceptor, TokenHelper, Serialized Form

Field Summary
static String | INVALID_TOKEN_CODE
private static long | serialVersionUID
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
TokenInterceptor()
Method Summary
protected String | doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
protected String | handleInvalidToken(ActionInvocation invocation) Determines what to do if an invalida token is provided.
protected String | handleValidToken(ActionInvocation invocation) Called when a valid token is found.
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

INVALID_TOKEN_CODE

public static final String INVALID_TOKEN_CODE
See Also:
Constant Field Values
Constructor Detail

TokenInterceptor

public TokenInterceptor()
Method Detail

doIntercept

protected String doIntercept(ActionInvocation invocation)
                      throws Exception
Description copied from class: MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.

Specified by:
doIntercept in class MethodFilterInterceptor
Parameters:
invocation - the action invocation
Returns:
the result of invocation
Throws:
Exception
See Also:
MethodFilterInterceptor.doIntercept(com.opensymphony.xwork2.ActionInvocation)

handleInvalidToken

protected String handleInvalidToken(ActionInvocation invocation)
                             throws Exception
Determines what to do if an invalida token is provided. If the action implements ValidationAware

Parameters:
invocation - the action invocation where the invalid token failed
Returns:
the return code to indicate should be processed
Throws:
Exception - when any unexpected error occurs.

handleValidToken

protected String handleValidToken(ActionInvocation invocation)
                           throws Exception
Called when a valid token is found. This method invokes the action by can be changed to do something more interesting.

Parameters:
invocation - the action invocation
Throws:
Exception - when any unexpected error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TokenSessionStoreInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor
Class TokenSessionStoreInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  org.apache.struts2.interceptor.TokenInterceptor
                extended by  org.apache.struts2.interceptor.TokenSessionStoreInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class TokenSessionStoreInterceptor
extends TokenInterceptor

This interceptor builds off of the TokenInterceptor, providing advanced logic for handling invalid tokens. Unlike the normal token interceptor, this interceptor will attempt to provide intelligent fail-over in the event of multiple requests using the same session. That is, it will block subsequent requests until the first request is complete, and then instead of returning the invalid.token code, it will attempt to display the same response that the original, valid action invocation would have displayed if no multiple requests were submitted in the first place.

NOTE: As this method extends off MethodFilterInterceptor, it is capable of deciding if it is applicable only to selective methods in the action class. See MethodFilterInterceptor for more info.

Interceptor parameters:

  • None

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="token-session/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

 <-- In this case, myMethod of the action class will not
        get checked for invalidity of token -->
 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="token-session>
         <param name="excludeMethods">myMethod</param>
     </interceptor-ref name="token-session>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.interceptor.TokenInterceptor
INVALID_TOKEN_CODE
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
TokenSessionStoreInterceptor()
Method Summary
protected String | handleInvalidToken(ActionInvocation invocation) Determines what to do if an invalida token is provided.
protected String | handleValidToken(ActionInvocation invocation) Called when a valid token is found.
Methods inherited from class org.apache.struts2.interceptor.TokenInterceptor
doIntercept
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

TokenSessionStoreInterceptor

public TokenSessionStoreInterceptor()
Method Detail

handleInvalidToken

protected String handleInvalidToken(ActionInvocation invocation)
                             throws Exception
Description copied from class: TokenInterceptor
Determines what to do if an invalida token is provided. If the action implements ValidationAware

Overrides:
handleInvalidToken in class TokenInterceptor
Parameters:
invocation - the action invocation where the invalid token failed
Returns:
the return code to indicate should be processed
Throws:
Exception - when any unexpected error occurs.

handleValidToken

protected String handleValidToken(ActionInvocation invocation)
                           throws Exception
Description copied from class: TokenInterceptor
Called when a valid token is found. This method invokes the action by can be changed to do something more interesting.

Overrides:
handleValidToken in class TokenInterceptor
Parameters:
invocation - the action invocation
Throws:
Exception - when any unexpected error occurs.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.interceptor.debugging (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.interceptor.debugging

Class Summary
DebuggingInterceptor | Provides several different debugging screens to provide insight into the data behind the page.
PrettyPrintWriter |


org.apache.struts2.interceptor.debugging Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.interceptor.debugging

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.interceptor.debugging.DebuggingInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
    • org.apache.struts2.interceptor.debugging.PrettyPrintWriter


Uses of Package org.apache.struts2.interceptor.debugging (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.interceptor.debugging

Packages that use org.apache.struts2.interceptor.debugging
org.apache.struts2.interceptor.debugging

Classes in org.apache.struts2.interceptor.debugging used by org.apache.struts2.interceptor.debugging
PrettyPrintWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DebuggingInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor.debugging
Class DebuggingInterceptor

java.lang.Object
    extended by  org.apache.struts2.interceptor.debugging.DebuggingInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class DebuggingInterceptor
extends Object
implements Interceptor

Provides several different debugging screens to provide insight into the data behind the page. The value of the 'debug' request parameter determines the screen:

  • xml - Dumps the parameters, context, session, and value stack as an XML document.
  • console - Shows a popup 'OGNL Console' that allows the user to test OGNL expressions against the value stack. The XML data from the 'xml' mode is inserted at the top of the page.
  • command - Tests an OGNL expression and returns the string result. Only used by the OGNL console.

Example: http://localhost:8080/Welcome.action?debug=xml

This interceptor only is activated when devMode is enabled in struts.properties. The 'debug' parameter is removed from the parameter list before the action is executed. All operations occur before the natural Result has a chance to execute.

See Also:
Serialized Form

Field Summary
private String[] | _ignoreKeys
private static String | COMMAND_MODE
private static String | CONSOLE_MODE
private boolean | consoleEnabled
private static String | DEBUG_PARAM
private boolean | devMode
private boolean | enableXmlWithConsole
private static String | EXPRESSION_PARAM
private FreemarkerManager | freemarkerManager
private HashSet<String> | ignoreKeys
private String[] | ignorePrefixes
private static Log | log
private static long | serialVersionUID
private static String | SESSION_KEY
private static String | XML_MODE
Constructor Summary
DebuggingInterceptor()
Method Summary
void | destroy() Unused.
private String | getParameter(String key) Gets a single string from the request parameters
void | init() Unused.
String | intercept(ActionInvocation inv) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.
protected void | printContext() Prints the current context to the response in XML format.
protected void | printContext(PrettyPrintWriter writer) Prints the current request to the existing writer.
protected void | serializeIt(Object bean, String name, PrettyPrintWriter writer, List<Object> stack) Recursive function to serialize objects to XML.
void | setDevMode(String mode)
void | setEnableXmlWithConsole(boolean enableXmlWithConsole)
void | setFreemarkerManager(FreemarkerManager mgr)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

log

private static final Log log

ignorePrefixes

private String[] ignorePrefixes

_ignoreKeys

private String[] _ignoreKeys

ignoreKeys

private HashSet<String> ignoreKeys

XML_MODE

private static final String XML_MODE
See Also:
Constant Field Values

CONSOLE_MODE

private static final String CONSOLE_MODE
See Also:
Constant Field Values

COMMAND_MODE

private static final String COMMAND_MODE
See Also:
Constant Field Values

SESSION_KEY

private static final String SESSION_KEY
See Also:
Constant Field Values

DEBUG_PARAM

private static final String DEBUG_PARAM
See Also:
Constant Field Values

EXPRESSION_PARAM

private static final String EXPRESSION_PARAM
See Also:
Constant Field Values

enableXmlWithConsole

private boolean enableXmlWithConsole

devMode

private boolean devMode

freemarkerManager

private FreemarkerManager freemarkerManager

consoleEnabled

private boolean consoleEnabled
Constructor Detail

DebuggingInterceptor

public DebuggingInterceptor()
Method Detail

setDevMode

public void setDevMode(String mode)

setFreemarkerManager

public void setFreemarkerManager(FreemarkerManager mgr)

init

public void init()
Unused.

Specified by:
init in interface Interceptor

destroy

public void destroy()
Unused.

Specified by:
destroy in interface Interceptor

intercept

public String intercept(ActionInvocation inv)
                 throws Exception
Description copied from interface: Interceptor
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.

Specified by:
intercept in interface Interceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().

getParameter

private String getParameter(String key)
Gets a single string from the request parameters

Parameters:
key - The key
Returns:
The parameter value

printContext

protected void printContext()
Prints the current context to the response in XML format.

printContext

protected void printContext(PrettyPrintWriter writer)
Prints the current request to the existing writer.

Parameters:
writer - The XML writer

serializeIt

protected void serializeIt(Object bean,
                           String name,
                           PrettyPrintWriter writer,
                           List<Object> stack)
Recursive function to serialize objects to XML. Currently it will serialize Collections, maps, Arrays, and JavaBeans. It maintains a stack of objects serialized already in the current functioncall. This is used to avoid looping (stack overflow) of circular linked objects. Struts and XWork objects are ignored.

Parameters:
bean - The object you want serialized.
name - The name of the object, used for element <name/>
writer - The XML writer
stack - List of objects we're serializing since the first calling of this function (to prevent looping on circular references).

setEnableXmlWithConsole

public void setEnableXmlWithConsole(boolean enableXmlWithConsole)
Parameters:
enableXmlWithConsole - the enableXmlWithConsole to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PrettyPrintWriter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor.debugging
Class PrettyPrintWriter

java.lang.Object
    extended by  org.apache.struts2.interceptor.debugging.PrettyPrintWriter

public class PrettyPrintWriter
extends Object

Field Summary
private static char[] | AMP
private static char[] | APOS
private static char[] | CLOSE
private int | depth
private Stack<String> | elementStack
private static char[] | GT
private char[] | lineIndenter
private static char[] | LT
private String | newLine
private static char[] | NULL
private static char[] | QUOT
private boolean | readyForNewLine
private static char[] | SLASH_R
private boolean | tagInProgress
private boolean | tagIsEmpty
private PrintWriter | writer
Constructor Summary
PrettyPrintWriter(Writer writer)
PrettyPrintWriter(Writer writer, char[] lineIndenter)
PrettyPrintWriter(Writer writer, char[] lineIndenter, String newLine)
PrettyPrintWriter(Writer writer, String lineIndenter)
PrettyPrintWriter(Writer writer, String lineIndenter, String newLine)
Method Summary
void | addAttribute(String key, String value)
void | close()
void | endNode()
protected void | endOfLine()
private void | finishTag()
void | flush()
void | setValue(String text)
void | startNode(String name)
protected void | writeAttributeValue(PrintWriter writer, String text)
protected void | writeText(PrintWriter writer, String text)
private void | writeText(String text)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

writer

private final PrintWriter writer

elementStack

private final Stack<String> elementStack

lineIndenter

private final char[] lineIndenter

tagInProgress

private boolean tagInProgress

depth

private int depth

readyForNewLine

private boolean readyForNewLine

tagIsEmpty

private boolean tagIsEmpty

newLine

private String newLine

NULL

private static final char[] NULL

AMP

private static final char[] AMP

LT

private static final char[] LT

GT

private static final char[] GT

SLASH_R

private static final char[] SLASH_R

QUOT

private static final char[] QUOT

APOS

private static final char[] APOS

CLOSE

private static final char[] CLOSE
Constructor Detail

PrettyPrintWriter

public PrettyPrintWriter(Writer writer,
                         char[] lineIndenter,
                         String newLine)

PrettyPrintWriter

public PrettyPrintWriter(Writer writer,
                         char[] lineIndenter)

PrettyPrintWriter

public PrettyPrintWriter(Writer writer,
                         String lineIndenter,
                         String newLine)

PrettyPrintWriter

public PrettyPrintWriter(Writer writer,
                         String lineIndenter)

PrettyPrintWriter

public PrettyPrintWriter(Writer writer)
Method Detail

startNode

public void startNode(String name)

setValue

public void setValue(String text)

addAttribute

public void addAttribute(String key,
                         String value)

writeAttributeValue

protected void writeAttributeValue(PrintWriter writer,
                                   String text)

writeText

protected void writeText(PrintWriter writer,
                         String text)

writeText

private void writeText(String text)

endNode

public void endNode()

finishTag

private void finishTag()

endOfLine

protected void endOfLine()

flush

public void flush()

close

public void close()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.interceptor.validation (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.interceptor.validation

Class Summary
AnnotationValidationInterceptor Extends the xwork validation interceptor to also check for a @SkipValidation annotation, and if found, don't validate this action method

Annotation Types Summary
SkipValidation Marks an Action method to not be validated


org.apache.struts2.interceptor.validation Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.interceptor.validation

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
        • com.opensymphony.xwork2.validator.ValidationInterceptor
          • org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor

Annotation Type Hierarchy

  • org.apache.struts2.interceptor.validation.SkipValidation (implements java.lang.annotation.Annotation)


Uses of Package org.apache.struts2.interceptor.validation (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.interceptor.validation

No usage of org.apache.struts2.interceptor.validation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AnnotationValidationInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.interceptor.validation
Class AnnotationValidationInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
            extended by  com.opensymphony.xwork2.validator.ValidationInterceptor
                extended by  org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor
All Implemented Interfaces:
Interceptor, Serializable
public class AnnotationValidationInterceptor
extends ValidationInterceptor

Extends the xwork validation interceptor to also check for a @SkipValidation annotation, and if found, don't validate this action method

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Auto-generated serialization id
Fields inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
excludeMethods, includeMethods, log
Constructor Summary
AnnotationValidationInterceptor()
Method Summary
protected String | doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
protected Method | getActionMethod(Class actionClass, String methodName)
Methods inherited from class com.opensymphony.xwork2.validator.ValidationInterceptor
doBeforeInvocation, isValidateAnnotatedMethodOnly, setValidateAnnotatedMethodOnly
Methods inherited from class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
applyInterceptor, getExcludeMethodsSet, getIncludeMethodsSet, intercept, setExcludeMethods, setIncludeMethods
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
Auto-generated serialization id

See Also:
Constant Field Values
Constructor Detail

AnnotationValidationInterceptor

public AnnotationValidationInterceptor()
Method Detail

doIntercept

protected String doIntercept(ActionInvocation invocation)
                      throws Exception
Description copied from class: MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.

Overrides:
doIntercept in class ValidationInterceptor
Parameters:
invocation - the action invocation
Returns:
the result of invocation
Throws:
Exception

getActionMethod

protected Method getActionMethod(Class actionClass,
                                 String methodName)
                          throws NoSuchMethodException
Throws:
NoSuchMethodException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


SkipValidation (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

org.apache.struts2.interceptor.validation
Annotation Type SkipValidation

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface SkipValidation

Marks an Action method to not be validated

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


org.apache.struts2.portlet (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.portlet

Interface Summary
PortletActionConstants Interface defining some constants used in the Struts portlet implementation

Class Summary
PortletApplicationMap | Portlet specific Map implementation representing the PortletContext of a Portlet.
PortletRequestMap | A simple implementation of the Map interface to handle a collection of request attributes.
PortletSessionMap | A simple implementation of the Map interface to handle a collection of portlet session attributes.


org.apache.struts2.portlet Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.portlet

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • org.apache.struts2.portlet.PortletApplicationMap (implements java.io.Serializable)
      • org.apache.struts2.portlet.PortletRequestMap
      • org.apache.struts2.portlet.PortletSessionMap

Interface Hierarchy

  • org.apache.struts2.portlet.PortletActionConstants


Uses of Package org.apache.struts2.portlet (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.portlet

Packages that use org.apache.struts2.portlet
org.apache.struts2.portlet.context
org.apache.struts2.portlet.dispatcher

Classes in org.apache.struts2.portlet used by org.apache.struts2.portlet.context
PortletActionConstants
Interface defining some constants used in the Struts portlet implementation

Classes in org.apache.struts2.portlet used by org.apache.struts2.portlet.dispatcher
PortletActionConstants
Interface defining some constants used in the Struts portlet implementation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PortletActionConstants (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet
Interface PortletActionConstants

All Known Implementing Classes:
Jsr168Dispatcher, PortletActionContext
public interface PortletActionConstants

Interface defining some constants used in the Struts portlet implementation

Field Summary
static String | ACTION_PARAM Action name parameter name
static String | DEFAULT_ACTION_FOR_MODE Key for the default action name for the portlet, stored in the PortletActionContext.
static String | DEFAULT_ACTION_NAME Default action name to use when no default action has been configured in the portlet init parameters.
static String | ERROR_ACTION Name of the action used as error handler
static String | EVENT_ACTION Key used for looking up and storing the action that was invoked in the event phase.
static Integer | EVENT_PHASE Constant used for the event phase ( Portlet.processAction(javax.portlet.ActionRequest, javax.portlet.ActionResponse))
static String | MODE_NAMESPACE_MAP Key for the mode-to-namespace map stored in the PortletActionContext.
static String | MODE_PARAM Key for parameter holding the last executed portlet mode.
static String | PHASE Key used for looking up and storing the portlet phase
static String | PORTLET_CONFIG Key used for looking up and storing the PortletConfig
static String | PORTLET_NAMESPACE Key for the portlet namespace stored in the PortletActionContext.
static Integer | RENDER_PHASE Constant used for the render phase ( Portlet.render(javax.portlet.RenderRequest, javax.portlet.RenderResponse))
static String | REQUEST Key used for looking up and storing the PortletRequest
static String | RESPONSE Key used for looking up and storing the PortletResponse

Field Detail

DEFAULT_ACTION_NAME

static final String DEFAULT_ACTION_NAME
Default action name to use when no default action has been configured in the portlet init parameters.

See Also:
Constant Field Values

ACTION_PARAM

static final String ACTION_PARAM
Action name parameter name

See Also:
Constant Field Values

MODE_PARAM

static final String MODE_PARAM
Key for parameter holding the last executed portlet mode.

See Also:
Constant Field Values

PHASE

static final String PHASE
Key used for looking up and storing the portlet phase

See Also:
Constant Field Values

RENDER_PHASE

static final Integer RENDER_PHASE
Constant used for the render phase ( Portlet.render(javax.portlet.RenderRequest, javax.portlet.RenderResponse))

EVENT_PHASE

static final Integer EVENT_PHASE
Constant used for the event phase ( Portlet.processAction(javax.portlet.ActionRequest, javax.portlet.ActionResponse))

REQUEST

static final String REQUEST
Key used for looking up and storing the PortletRequest

See Also:
Constant Field Values

RESPONSE

static final String RESPONSE
Key used for looking up and storing the PortletResponse

See Also:
Constant Field Values

EVENT_ACTION

static final String EVENT_ACTION
Key used for looking up and storing the action that was invoked in the event phase.

See Also:
Constant Field Values

PORTLET_CONFIG

static final String PORTLET_CONFIG
Key used for looking up and storing the PortletConfig

See Also:
Constant Field Values

ERROR_ACTION

static final String ERROR_ACTION
Name of the action used as error handler

See Also:
Constant Field Values

PORTLET_NAMESPACE

static final String PORTLET_NAMESPACE
Key for the portlet namespace stored in the PortletActionContext.

See Also:
Constant Field Values

MODE_NAMESPACE_MAP

static final String MODE_NAMESPACE_MAP
Key for the mode-to-namespace map stored in the PortletActionContext.

See Also:
Constant Field Values

DEFAULT_ACTION_FOR_MODE

static final String DEFAULT_ACTION_FOR_MODE
Key for the default action name for the portlet, stored in the PortletActionContext.

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PortletApplicationMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet
Class PortletApplicationMap

java.lang.Object
    extended by  java.util.AbstractMap
        extended by  org.apache.struts2.portlet.PortletApplicationMap
All Implemented Interfaces:
Serializable, Map
public class PortletApplicationMap
extends AbstractMap
implements Serializable

Portlet specific Map implementation representing the PortletContext of a Portlet.

See Also:
Serialized Form

Nested Class Summary
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
private javax.portlet.PortletContext | context
private Set<Object> | entries
private static long | serialVersionUID
Constructor Summary
PortletApplicationMap(javax.portlet.PortletContext ctx)
Creates a new map object given the PortletContext.
Method Summary
void | clear() Removes all entries from the Map and removes all attributes from the portlet context.
Set | entrySet() Creates a Set of all portlet context attributes as well as context init parameters.
Object | get(Object key) Returns the portlet context attribute or init parameter based on the given key.
Object | put(Object key, Object value) Sets a portlet context attribute given a attribute name and value.
Object | remove(Object key) Removes the specified portlet context attribute.
Methods inherited from class java.util.AbstractMap
clone, containsKey, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

context

private javax.portlet.PortletContext context

entries

private Set<Object> entries
Constructor Detail

PortletApplicationMap

public PortletApplicationMap(javax.portlet.PortletContext ctx)
Creates a new map object given the PortletContext.

Parameters:
ctx - The portlet context.
Method Detail

clear

public void clear()
Removes all entries from the Map and removes all attributes from the portlet context.

Specified by:
clear in interface Map
Overrides:
clear in class AbstractMap

entrySet

public Set entrySet()
Creates a Set of all portlet context attributes as well as context init parameters.

Specified by:
entrySet in interface Map
Specified by:
entrySet in class AbstractMap
Returns:
a Set of all portlet context attributes as well as context init parameters.

get

public Object get(Object key)
Returns the portlet context attribute or init parameter based on the given key. If the entry is not found, null is returned.

Specified by:
get in interface Map
Overrides:
get in class AbstractMap
Parameters:
key - the entry key.
Returns:
the portlet context attribute or init parameter or null if the entry is not found.

put

public Object put(Object key,
                  Object value)
Sets a portlet context attribute given a attribute name and value.

Specified by:
put in interface Map
Overrides:
put in class AbstractMap
Parameters:
key - the name of the attribute.
value - the value to set.
Returns:
the attribute that was just set.

remove

public Object remove(Object key)
Removes the specified portlet context attribute.

Specified by:
remove in interface Map
Overrides:
remove in class AbstractMap
Parameters:
key - the attribute to remove.
Returns:
the entry that was just removed.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PortletRequestMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet
Class PortletRequestMap

java.lang.Object
    extended by  java.util.AbstractMap
        extended by  org.apache.struts2.portlet.PortletRequestMap
All Implemented Interfaces:
Map
public class PortletRequestMap
extends AbstractMap

A simple implementation of the Map interface to handle a collection of request attributes.

Nested Class Summary
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
private Set<Object> | entries
private static Log | LOG
private javax.portlet.PortletRequest | request
Constructor Summary
PortletRequestMap(javax.portlet.PortletRequest request)
Saves the request to use as the backing for getting and setting values
Method Summary
void | clear() Removes all attributes from the request as well as clears entries in this map.
Set | entrySet() Returns a Set of attributes from the portlet request.
Object | get(Object key) Returns the request attribute associated with the given key or null if it doesn't exist.
Object | put(Object key, Object value) Saves an attribute in the request.
Object | remove(Object key) Removes the specified request attribute.
Methods inherited from class java.util.AbstractMap
clone, containsKey, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

LOG

private static final Log LOG

entries

private Set<Object> entries

request

private javax.portlet.PortletRequest request
Constructor Detail

PortletRequestMap

public PortletRequestMap(javax.portlet.PortletRequest request)
Saves the request to use as the backing for getting and setting values

Parameters:
request - the portlet request.
Method Detail

clear

public void clear()
Removes all attributes from the request as well as clears entries in this map.

Specified by:
clear in interface Map
Overrides:
clear in class AbstractMap

entrySet

public Set entrySet()
Returns a Set of attributes from the portlet request.

Specified by:
entrySet in interface Map
Specified by:
entrySet in class AbstractMap
Returns:
a Set of attributes from the portlet request.

get

public Object get(Object key)
Returns the request attribute associated with the given key or null if it doesn't exist.

Specified by:
get in interface Map
Overrides:
get in class AbstractMap
Parameters:
key - the name of the request attribute.
Returns:
the request attribute or null if it doesn't exist.

put

public Object put(Object key,
                  Object value)
Saves an attribute in the request.

Specified by:
put in interface Map
Overrides:
put in class AbstractMap
Parameters:
key - the name of the request attribute.
value - the value to set.
Returns:
the object that was just set.

remove

public Object remove(Object key)
Removes the specified request attribute.

Specified by:
remove in interface Map
Overrides:
remove in class AbstractMap
Parameters:
key - the name of the attribute to remove.
Returns:
the value that was removed or null if the value was not found (and hence, not removed).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PortletSessionMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet
Class PortletSessionMap

java.lang.Object
    extended by  java.util.AbstractMap
        extended by  org.apache.struts2.portlet.PortletSessionMap
All Implemented Interfaces:
Map
public class PortletSessionMap
extends AbstractMap

A simple implementation of the Map interface to handle a collection of portlet session attributes. The entrySet() method enumerates over all session attributes and creates a Set of entries. Note, this will occur lazily - only when the entry set is asked for.

Nested Class Summary
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
private Set<Object> | entries
private static Log | LOG
private javax.portlet.PortletSession | session
Constructor Summary
PortletSessionMap(javax.portlet.PortletRequest request)
Creates a new session map given a portlet request.
Method Summary
void | clear()
Set | entrySet()
Object | get(Object key) Returns the session attribute associated with the given key or null if it doesn't exist.
Object | put(Object key, Object value) Saves an attribute in the session.
Object | remove(Object key) Removes the specified session attribute.
Methods inherited from class java.util.AbstractMap
clone, containsKey, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

LOG

private static final Log LOG

session

private javax.portlet.PortletSession session

entries

private Set<Object> entries
Constructor Detail

PortletSessionMap

public PortletSessionMap(javax.portlet.PortletRequest request)
Creates a new session map given a portlet request.

Parameters:
request - the portlet request object.
Method Detail

entrySet

public Set entrySet()
Specified by:
entrySet in interface Map
Specified by:
entrySet in class AbstractMap
See Also:
Map.entrySet()

get

public Object get(Object key)
Returns the session attribute associated with the given key or null if it doesn't exist.

Specified by:
get in interface Map
Overrides:
get in class AbstractMap
Parameters:
key - the name of the session attribute.
Returns:
the session attribute or null if it doesn't exist.

put

public Object put(Object key,
                  Object value)
Saves an attribute in the session.

Specified by:
put in interface Map
Overrides:
put in class AbstractMap
Parameters:
key - the name of the session attribute.
value - the value to set.
Returns:
the object that was just set.

clear

public void clear()
Specified by:
clear in interface Map
Overrides:
clear in class AbstractMap
See Also:
Map.clear()

remove

public Object remove(Object key)
Removes the specified session attribute.

Specified by:
remove in interface Map
Overrides:
remove in class AbstractMap
Parameters:
key - the name of the attribute to remove.
Returns:
the value that was removed or null if the value was not found (and hence, not removed).
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.portlet.context (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.portlet.context

Class Summary
PortletActionContext | PortletActionContext.
PreparatorServlet | Since a portlet is not dispatched the same way as a servlet, the ServletActionContext is not immediately available, as it depends on objects from the servlet API.
ServletContextHolderListener | Some of the factory/managers (e.g.


org.apache.struts2.portlet.context Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.portlet.context

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • org.apache.struts2.portlet.context.PreparatorServlet (implements org.apache.struts2.StrutsStatics)
    • org.apache.struts2.portlet.context.PortletActionContext (implements org.apache.struts2.portlet.PortletActionConstants)
    • org.apache.struts2.portlet.context.ServletContextHolderListener (implements javax.servlet.ServletContextListener)


Uses of Package org.apache.struts2.portlet.context (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.portlet.context

No usage of org.apache.struts2.portlet.context

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PortletActionContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.context
Class PortletActionContext

java.lang.Object
    extended by  org.apache.struts2.portlet.context.PortletActionContext
All Implemented Interfaces:
PortletActionConstants
public class PortletActionContext
extends Object
implements PortletActionConstants

PortletActionContext. ActionContext thread local for the portlet environment.

Version:
$Revision: 495502 $ $Date: 2007-01-12 02:15:43 -0500 (Fri, 12 Jan 2007) $

Field Summary
Fields inherited from interface org.apache.struts2.portlet.PortletActionConstants
ACTION_PARAM, DEFAULT_ACTION_FOR_MODE, DEFAULT_ACTION_NAME, ERROR_ACTION, EVENT_ACTION, EVENT_PHASE, MODE_NAMESPACE_MAP, MODE_PARAM, PHASE, PORTLET_CONFIG, PORTLET_NAMESPACE, RENDER_PHASE, REQUEST, RESPONSE
Constructor Summary
PortletActionContext()
Method Summary
static javax.portlet.ActionRequest | getActionRequest() Get the ActionRequest.
static javax.portlet.ActionResponse | getActionResponse() Get the ActionRequest.
private static ActionContext | getContext()
static ActionMapping | getDefaultActionForMode() Get the default action mapping for the current mode.
static Map | getModeNamespaceMap() Get the namespace to mode mappings.
static Integer | getPhase() Get the phase that the portlet is executing in.
static javax.portlet.PortletConfig | getPortletConfig() Get the PortletConfig of the portlet that is executing.
static String | getPortletNamespace() Get the action namespace of the portlet.
static javax.portlet.RenderRequest | getRenderRequest() Get the RenderRequest.
static javax.portlet.RenderResponse | getRenderResponse() Get the RenderResponse.
static javax.portlet.PortletRequest | getRequest() Get the current PortletRequest.
static javax.portlet.PortletResponse | getResponse() Get the current PortletResponse
static boolean | isEvent()
static boolean | isPortletRequest() Check to see if the current request is a portlet request.
static boolean | isRender()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PortletActionContext

public PortletActionContext()
Method Detail

getPortletConfig

public static javax.portlet.PortletConfig getPortletConfig()
Get the PortletConfig of the portlet that is executing.

Returns:
The PortletConfig of the executing portlet.

getRenderRequest

public static javax.portlet.RenderRequest getRenderRequest()
Get the RenderRequest. Can only be invoked in the render phase.

Returns:
The current RenderRequest.
Throws:
IllegalStateException - If the method is invoked in the wrong phase.

getRenderResponse

public static javax.portlet.RenderResponse getRenderResponse()
Get the RenderResponse. Can only be invoked in the render phase.

Returns:
The current RenderResponse.
Throws:
IllegalStateException - If the method is invoked in the wrong phase.

getActionRequest

public static javax.portlet.ActionRequest getActionRequest()
Get the ActionRequest. Can only be invoked in the event phase.

Returns:
The current ActionRequest.
Throws:
IllegalStateException - If the method is invoked in the wrong phase.

getActionResponse

public static javax.portlet.ActionResponse getActionResponse()
Get the ActionRequest. Can only be invoked in the event phase.

Returns:
The current ActionRequest.
Throws:
IllegalStateException - If the method is invoked in the wrong phase.

getPortletNamespace

public static String getPortletNamespace()
Get the action namespace of the portlet. Used to organize actions for multiple portlets in the same portlet application.

Returns:
The portlet namespace as defined in portlet.xml and struts.xml

getRequest

public static javax.portlet.PortletRequest getRequest()
Get the current PortletRequest.

Returns:
The current PortletRequest.

getResponse

public static javax.portlet.PortletResponse getResponse()
Get the current PortletResponse

Returns:
The current PortletResponse.

getPhase

public static Integer getPhase()
Get the phase that the portlet is executing in.

Returns:
PortletActionConstants.RENDER_PHASE in render phase, and PortletActionConstants.EVENT_PHASE in the event phase.

isRender

public static boolean isRender()
Returns:
true if the Portlet is executing in render phase.

isEvent

public static boolean isEvent()
Returns:
true if the Portlet is executing in the event phase.

getContext

private static ActionContext getContext()
Returns:
The current ActionContext.

isPortletRequest

public static boolean isPortletRequest()
Check to see if the current request is a portlet request.

Returns:
true if the current request is a portlet request.

getDefaultActionForMode

public static ActionMapping getDefaultActionForMode()
Get the default action mapping for the current mode.

Returns:
The default action mapping for the current portlet mode.

getModeNamespaceMap

public static Map getModeNamespaceMap()
Get the namespace to mode mappings.

Returns:
The map of the namespaces for each mode.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PreparatorServlet (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.context
Class PreparatorServlet

java.lang.Object
    extended by  javax.servlet.GenericServlet
        extended by  javax.servlet.http.HttpServlet
            extended by  org.apache.struts2.portlet.context.PreparatorServlet
All Implemented Interfaces:
Serializable, Servlet, ServletConfig, StrutsStatics
public class PreparatorServlet
extends HttpServlet
implements StrutsStatics

Since a portlet is not dispatched the same way as a servlet, the ServletActionContext is not immediately available, as it depends on objects from the servlet API. However, the WW2 view implementations require access to the objects in the ServletActionContext, and this servlet makes sure that these are available when the portlet actions are executing the render results.

See Also:
Serialized Form

Field Summary
private static Log | LOG
private static long | serialVersionUID
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
PreparatorServlet()
Method Summary
 void service(HttpServletRequest servletRequest, HttpServletResponse servletResponse)
Prepares the ServletActionContext with the ServletContext, HttpServletRequest and HttpServletResponse.
Methods inherited from class javax.servlet.http.HttpServlet
doDelete, doGet, doHead, doOptions, doPost, doPut, doTrace, getLastModified, service
Methods inherited from class javax.servlet.GenericServlet
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, init, log, log
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

LOG

private static final Log LOG
Constructor Detail

PreparatorServlet

public PreparatorServlet()
Method Detail

service

public void service(HttpServletRequest servletRequest,
                    HttpServletResponse servletResponse)
             throws ServletException,
                    IOException
Prepares the ServletActionContext with the ServletContext, HttpServletRequest and HttpServletResponse.

Overrides:
service in class HttpServlet
Throws:
ServletException
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletContextHolderListener (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.context
Class ServletContextHolderListener

java.lang.Object
    extended by  org.apache.struts2.portlet.context.ServletContextHolderListener
All Implemented Interfaces:
EventListener, ServletContextListener
public class ServletContextHolderListener
extends Object
implements ServletContextListener

Some of the factory/managers (e.g. the ObjectFactory) need access to the ServletActionContext object when initializing. This ServletContextListener keeps a reference to the ServletContext and exposes it through a public static method.

Field Summary
private static ServletContext context
Constructor Summary
ServletContextHolderListener()
Method Summary
void | contextDestroyed(ServletContextEvent event)
void | contextInitialized(ServletContextEvent event) Stores the reference to the ServletContext.
static ServletContext | getServletContext()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

context

private static ServletContext context
Constructor Detail

ServletContextHolderListener

public ServletContextHolderListener()
Method Detail

getServletContext

public static ServletContext getServletContext()
Returns:
The current servlet context

contextInitialized

public void contextInitialized(ServletContextEvent event)
Stores the reference to the ServletContext.

Specified by:
contextInitialized in interface ServletContextListener
See Also:
ServletContextListener.contextInitialized(javax.servlet.ServletContextEvent)

contextDestroyed

public void contextDestroyed(ServletContextEvent event)
Specified by:
contextDestroyed in interface ServletContextListener
See Also:
ServletContextListener.contextDestroyed(javax.servlet.ServletContextEvent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.portlet.dispatcher (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.portlet.dispatcher

Class Summary
DirectRenderFromEventAction | When a portlet is targetted for an event, the portlet will receive two portlet requests, one for the event phase, and then followed by a render operation.
Jsr168Dispatcher |


org.apache.struts2.portlet.dispatcher Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.portlet.dispatcher

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction (implements com.opensymphony.xwork2.Action, java.io.Serializable)
    • javax.portlet.GenericPortlet (implements javax.portlet.Portlet, javax.portlet.PortletConfig)
      • org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher (implements org.apache.struts2.portlet.PortletActionConstants, org.apache.struts2.StrutsStatics)


Uses of Package org.apache.struts2.portlet.dispatcher (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.portlet.dispatcher

No usage of org.apache.struts2.portlet.dispatcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DirectRenderFromEventAction (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.dispatcher
Class DirectRenderFromEventAction

java.lang.Object
    extended by  org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction
All Implemented Interfaces:
Action, Serializable
public class DirectRenderFromEventAction
extends Object
implements Action, Serializable

When a portlet is targetted for an event, the portlet will receive two portlet requests, one for the event phase, and then followed by a render operation. When in the event phase, the action that is executed can't render any output. This means that if an action in the XWork configuration is executed in the event phase, and the action is set up with a result that should render something, the result can't immediately be executed. The portlet needs to "wait" to the render phase to do the rendering.

When the PortletResult detects such a scenario, instead of executing the actual view, it prepares a couple of render parameters specifying this action and the location of the view, which then will be executed in the following render request.

See Also:
Serialized Form

Field Summary
private String | location
private static long | serialVersionUID
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
DirectRenderFromEventAction()
Method Summary
String | execute() Always return success.
String | getLocation() Get the location of the view.
void | setLocation(String location) Set the location of the view.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

location

private String location
Constructor Detail

DirectRenderFromEventAction

public DirectRenderFromEventAction()
Method Detail

getLocation

public String getLocation()
Get the location of the view.

Returns:
Returns the location.

setLocation

public void setLocation(String location)
Set the location of the view.

Parameters:
location - The location to set.

execute

public String execute()
               throws Exception
Always return success.

Specified by:
execute in interface Action
Returns:
SUCCESS
Throws:
Exception - thrown if a system level exception occurs. Application level exceptions should be handled by returning an error value, such as Action.ERROR.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Jsr168Dispatcher (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.dispatcher
Class Jsr168Dispatcher

java.lang.Object
    extended by  javax.portlet.GenericPortlet
        extended by  org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
All Implemented Interfaces:
javax.portlet.Portlet, javax.portlet.PortletConfig, PortletActionConstants, StrutsStatics
public class Jsr168Dispatcher
extends javax.portlet.GenericPortlet
implements StrutsStatics, PortletActionConstants

Struts JSR-168 portlet dispatcher. Similar to the WW2 Servlet dispatcher, but adjusted to a portal environment. The portlet is configured through the portlet.xml descriptor. Examples and descriptions follow below:

Author:
Nils-Helge Garli , Rainer Hermanns

Init parameters

Name | Description | Default value
portletNamespace | The namespace for the portlet in the xwork configuration. This namespace is prepended to all action lookups, and makes it possible to host multiple portlets in the same portlet application. If this parameter is set, the complete namespace will be /portletNamespace/modeNamespace/actionName | The default namespace
viewNamespace | Base namespace in the xwork configuration for the view portlet mode | The default namespace
editNamespace | Base namespace in the xwork configuration for the edit portlet mode | The default namespace
helpNamespace | Base namespace in the xwork configuration for the help portlet mode | The default namespace
defaultViewAction | Default action to invoke in the view portlet mode if no action is specified | default
defaultEditAction | Default action to invoke in the edit portlet mode if no action is specified | default
defaultHelpAction | Default action to invoke in the help portlet mode if no action is specified | default

Example:

 <init-param>
     <!-- The view mode namespace. Maps to a namespace in the xwork config file -->
     <name>viewNamespace</name>
     <value>/view</value>
 </init-param>
 <init-param>
    <!-- The default action to invoke in view mode -->
    <name>defaultViewAction</name>
    <value>index</value>
 </init-param>
 <init-param>
     <!-- The view mode namespace. Maps to a namespace in the xwork config file -->
     <name>editNamespace</name>
     <value>/edit</value>
 </init-param>
 <init-param>
     <!-- The default action to invoke in view mode -->
     <name>defaultEditAction</name>
     <value>index</value>
 </init-param>
 <init-param>
     <!-- The view mode namespace. Maps to a namespace in the xwork config file -->
     <name>helpNamespace</name>
     <value>/help</value>
 </init-param>
 <init-param>
     <!-- The default action to invoke in view mode -->
     <name>defaultHelpAction</name>
     <value>index</value>
 </init-param>

Field Summary
private Map<javax.portlet.PortletMode,ActionMapping> | actionMap
private ActionMapper | actionMapper
private Dispatcher | dispatcherUtils
private ActionProxyFactory | factory
private static Log | LOG
private Map<javax.portlet.PortletMode,String> | modeMap
private String | portletNamespace
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Fields inherited from interface org.apache.struts2.portlet.PortletActionConstants
ACTION_PARAM, DEFAULT_ACTION_FOR_MODE, DEFAULT_ACTION_NAME, ERROR_ACTION, EVENT_ACTION, EVENT_PHASE, MODE_NAMESPACE_MAP, MODE_PARAM, PHASE, PORTLET_CONFIG, PORTLET_NAMESPACE, RENDER_PHASE, REQUEST, RESPONSE
Constructor Summary
Jsr168Dispatcher()
Method Summary
HashMap | createContextMap(Map requestMap, Map parameterMap, Map sessionMap, Map applicationMap, javax.portlet.PortletRequest request, javax.portlet.PortletResponse response, javax.portlet.PortletConfig portletConfig, Integer phase) Merges all application and portlet attributes into a single HashMap to represent the entire Action context.
void | destroy()
protected ActionMapping | getActionMapping(javax.portlet.PortletRequest request) Gets the namespace of the action from the request.
(package private) String | getActionName(String actionPath) Get the action name part of the action path.
protected Map | getApplicationMap() Returns a Map of all application attributes.
(package private) String | getNamespace(String actionPath) Get the namespace part of the action path.
protected Map | getParameterMap(javax.portlet.PortletRequest request) Returns a Map of all request parameters.
protected Map | getRequestMap(javax.portlet.PortletRequest request) Returns a Map of all request attributes.
protected Map | getSessionMap(javax.portlet.PortletRequest request) Returns a Map of all session attributes.
void | init(javax.portlet.PortletConfig cfg) Initialize the portlet with the init parameters from portlet.xml
private void | parseModeConfig(javax.portlet.PortletConfig portletConfig, javax.portlet.PortletMode portletMode, String nameSpaceParam, String defaultActionParam) Parse the mode to namespace mappings configured in portlet.xml
void | processAction(javax.portlet.ActionRequest request, javax.portlet.ActionResponse response) Service an action from the event phase.
void | render(javax.portlet.RenderRequest request, javax.portlet.RenderResponse response) Service an action from the render phase.
private boolean | resetAction(javax.portlet.PortletRequest request) Check to see if the action parameter is valid for the current portlet mode.
private void | resetActionContext() Reset the action context.
void | serviceAction(javax.portlet.PortletRequest request, javax.portlet.PortletResponse response, ActionMapping mapping, Map requestMap, Map parameterMap, Map sessionMap, Map applicationMap, String portletNamespace, Integer phase) Loads the action and executes it.
void | setActionMapper(ActionMapper actionMapper)
protected void | setActionProxyFactory(ActionProxyFactory factory) Convenience method to ease testing.
Methods inherited from class javax.portlet.GenericPortlet
doDispatch, doEdit, doHelp, doView, getInitParameter, getInitParameterNames, getPortletConfig, getPortletContext, getPortletName, getResourceBundle, getTitle, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

factory

private ActionProxyFactory factory

modeMap

private Map<javax.portlet.PortletMode,String> modeMap

actionMap

private Map<javax.portlet.PortletMode,ActionMapping> actionMap

portletNamespace

private String portletNamespace

dispatcherUtils

private Dispatcher dispatcherUtils

actionMapper

private ActionMapper actionMapper
Constructor Detail

Jsr168Dispatcher

public Jsr168Dispatcher()
Method Detail

init

public void init(javax.portlet.PortletConfig cfg)
          throws javax.portlet.PortletException
Initialize the portlet with the init parameters from portlet.xml

Specified by:
init in interface javax.portlet.Portlet
Overrides:
init in class javax.portlet.GenericPortlet
Throws:
javax.portlet.PortletException

parseModeConfig

private void parseModeConfig(javax.portlet.PortletConfig portletConfig,
                             javax.portlet.PortletMode portletMode,
                             String nameSpaceParam,
                             String defaultActionParam)
Parse the mode to namespace mappings configured in portlet.xml

Parameters:
portletConfig - The PortletConfig
portletMode - The PortletMode
nameSpaceParam - Name of the init parameter where the namespace for the mode is configured.
defaultActionParam - Name of the init parameter where the default action to execute for the mode is configured.

processAction

public void processAction(javax.portlet.ActionRequest request,
                          javax.portlet.ActionResponse response)
                   throws javax.portlet.PortletException,
                          IOException
Service an action from the event phase.

Specified by:
processAction in interface javax.portlet.Portlet
Overrides:
processAction in class javax.portlet.GenericPortlet
Throws:
javax.portlet.PortletException
IOException
See Also:
Portlet.processAction(javax.portlet.ActionRequest, javax.portlet.ActionResponse)

render

public void render(javax.portlet.RenderRequest request,
                   javax.portlet.RenderResponse response)
            throws javax.portlet.PortletException,
                   IOException
Service an action from the render phase.

Specified by:
render in interface javax.portlet.Portlet
Overrides:
render in class javax.portlet.GenericPortlet
Throws:
javax.portlet.PortletException
IOException
See Also:
Portlet.render(javax.portlet.RenderRequest, javax.portlet.RenderResponse)

resetActionContext

private void resetActionContext()
Reset the action context.

createContextMap

public HashMap createContextMap(Map requestMap,
                                Map parameterMap,
                                Map sessionMap,
                                Map applicationMap,
                                javax.portlet.PortletRequest request,
                                javax.portlet.PortletResponse response,
                                javax.portlet.PortletConfig portletConfig,
                                Integer phase)
Merges all application and portlet attributes into a single HashMap to represent the entire Action context.

Parameters:
requestMap - a Map of all request attributes.
parameterMap - a Map of all request parameters.
sessionMap - a Map of all session attributes.
applicationMap - a Map of all servlet context attributes.
request - the PortletRequest object.
response - the PortletResponse object.
portletConfig - the PortletConfig object.
phase - The portlet phase (render or action, see PortletActionConstants)
Returns:
a HashMap representing the Action context.

serviceAction

public void serviceAction(javax.portlet.PortletRequest request,
                          javax.portlet.PortletResponse response,
                          ActionMapping mapping,
                          Map requestMap,
                          Map parameterMap,
                          Map sessionMap,
                          Map applicationMap,
                          String portletNamespace,
                          Integer phase)
                   throws javax.portlet.PortletException
Loads the action and executes it. This method first creates the action context from the given parameters then loads an ActionProxy from the given action name and namespace. After that, the action is executed and output channels throught the response object.

Parameters:
request - the HttpServletRequest object.
response - the HttpServletResponse object.
mapping - the action mapping.
requestMap - a Map of request attributes.
parameterMap - a Map of request parameters.
sessionMap - a Map of all session attributes.
applicationMap - a Map of all application attributes.
portletNamespace - the namespace or context of the action.
phase - The portlet phase (render or action, see PortletActionConstants)
Throws:
javax.portlet.PortletException

getApplicationMap

protected Map getApplicationMap()
Returns a Map of all application attributes. Copies all attributes from the PortletActionContextinto an ApplicationMap.

Returns:
a Map of all application attributes.

getActionMapping

protected ActionMapping getActionMapping(javax.portlet.PortletRequest request)
Gets the namespace of the action from the request. The namespace is the same as the portlet mode. E.g, view mode is mapped to namespace view, and edit mode is mapped to the namespace edit

Parameters:
request - the PortletRequest object.
Returns:
the namespace of the action.

getNamespace

String getNamespace(String actionPath)
Get the namespace part of the action path.

Parameters:
actionPath - Full path to action
Returns:
The namespace part.

getActionName

String getActionName(String actionPath)
Get the action name part of the action path.

Parameters:
actionPath - Full path to action
Returns:
The action name.

getParameterMap

protected Map getParameterMap(javax.portlet.PortletRequest request)
                       throws IOException
Returns a Map of all request parameters. This implementation just calls PortletRequest.getParameterMap().

Parameters:
request - the PortletRequest object.
Returns:
a Map of all request parameters.
Throws:
IOException - if an exception occurs while retrieving the parameter map.

getRequestMap

protected Map getRequestMap(javax.portlet.PortletRequest request)
Returns a Map of all request attributes. The default implementation is to wrap the request in a RequestMap. Override this method to customize how request attributes are mapped.

Parameters:
request - the PortletRequest object.
Returns:
a Map of all request attributes.

getSessionMap

protected Map getSessionMap(javax.portlet.PortletRequest request)
Returns a Map of all session attributes. The default implementation is to wrap the reqeust in a SessionMap. Override this method to customize how session attributes are mapped.

Parameters:
request - the PortletRequest object.
Returns:
a Map of all session attributes.

setActionProxyFactory

protected void setActionProxyFactory(ActionProxyFactory factory)
Convenience method to ease testing.

Parameters:
factory -

resetAction

private boolean resetAction(javax.portlet.PortletRequest request)
Check to see if the action parameter is valid for the current portlet mode. If the portlet mode has been changed with the portal widgets, the action name is invalid, since the action name belongs to the previous executing portlet mode. If this method evaluates to true the default<Mode>Action is used instead.

Parameters:
request - The portlet request.
Returns:
true if the action should be reset.

destroy

public void destroy()
Specified by:
destroy in interface javax.portlet.Portlet
Overrides:
destroy in class javax.portlet.GenericPortlet

setActionMapper

public void setActionMapper(ActionMapper actionMapper)
Parameters:
actionMapper - the actionMapper to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.portlet.interceptor (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.portlet.interceptor

Interface Summary
PortletPreferencesAware All Actions that want to have access to the portlet preferences should implement this interface.

Class Summary
PortletPreferencesInterceptor | An interceptor which provides an implementation of PortletPreferences if the Action implements PortletPreferencesAware.
PortletPrincipalProxy | PrincipalProxy implementation for using PortletRequest Principal related methods.
ServletPortletPreferences | Simple portlet preferences implementation that uses a map in the Session as storage.


org.apache.struts2.portlet.interceptor Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.portlet.interceptor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.interceptor.AbstractInterceptor (implements com.opensymphony.xwork2.interceptor.Interceptor)
      • org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor (implements org.apache.struts2.StrutsStatics)
    • org.apache.struts2.portlet.interceptor.PortletPrincipalProxy (implements org.apache.struts2.interceptor.PrincipalProxy)
    • org.apache.struts2.portlet.interceptor.ServletPortletPreferences (implements javax.portlet.PortletPreferences)

Interface Hierarchy

  • org.apache.struts2.portlet.interceptor.PortletPreferencesAware


Uses of Package org.apache.struts2.portlet.interceptor (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.portlet.interceptor

No usage of org.apache.struts2.portlet.interceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PortletPreferencesAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.interceptor
Interface PortletPreferencesAware

public interface PortletPreferencesAware

All Actions that want to have access to the portlet preferences should implement this interface. If running in a servlet environment, an appropriate testing implementation will be provided.

Method Summary
 void setPortletPreferences(javax.portlet.PortletPreferences prefs)
Sets the HTTP request object in implementing classes.

Method Detail

setPortletPreferences

void setPortletPreferences(javax.portlet.PortletPreferences prefs)
Sets the HTTP request object in implementing classes.

Parameters:
request - the HTTP request.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PortletPreferencesInterceptor (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.interceptor
Class PortletPreferencesInterceptor

java.lang.Object
    extended by  com.opensymphony.xwork2.interceptor.AbstractInterceptor
        extended by  org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor
All Implemented Interfaces:
Interceptor, Serializable, StrutsStatics
public class PortletPreferencesInterceptor
extends AbstractInterceptor
implements StrutsStatics

An interceptor which provides an implementation of PortletPreferences if the Action implements PortletPreferencesAware. If running in a servlet environment, a testing implementation of PortletPreferences will be created and provided, but it should not be used in a production environment.

Interceptor parameters:

  • None

Extending the interceptor:

There are no known extension points for this interceptor.

Example code:

 <action name="someAction" class="com.examples.SomeAction">
     <interceptor-ref name="portlet-preferences"/>
     <interceptor-ref name="basicStack"/>
     <result name="success">good_result.ftl</result>
 </action>

See Also:
PortletPreferencesAware, Serialized Form

Field Summary
private static Log LOG
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
PortletPreferencesInterceptor()
Method Summary
 String intercept(ActionInvocation invocation)
Override to handle interception
Methods inherited from class com.opensymphony.xwork2.interceptor.AbstractInterceptor
destroy, init
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG
Constructor Detail

PortletPreferencesInterceptor

public PortletPreferencesInterceptor()
Method Detail

intercept

public String intercept(ActionInvocation invocation)
                 throws Exception
Description copied from class: AbstractInterceptor
Override to handle interception

Specified by:
intercept in interface Interceptor
Specified by:
intercept in class AbstractInterceptor
Returns:
the return code, either returned from ActionInvocation.invoke(), or from the interceptor itself.
Throws:
Exception - any system-level error, as defined in Action.execute().
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PortletPrincipalProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.interceptor
Class PortletPrincipalProxy

java.lang.Object
    extended by  org.apache.struts2.portlet.interceptor.PortletPrincipalProxy
All Implemented Interfaces:
PrincipalProxy
public class PortletPrincipalProxy
extends Object
implements PrincipalProxy

PrincipalProxy implementation for using PortletRequest Principal related methods.

Field Summary
private  javax.portlet.PortletRequest request
Constructor Summary
PortletPrincipalProxy(javax.portlet.PortletRequest request)
Constructs a proxy
Method Summary
String | getRemoteUser() Gets the user id
HttpServletRequest | getRequest() Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
Principal | getUserPrincipal() Gets the user principal
boolean | isRequestSecure() Is the request using https?
boolean | isUserInRole(String role) True if the user is in the given role
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

request

private javax.portlet.PortletRequest request
Constructor Detail

PortletPrincipalProxy

public PortletPrincipalProxy(javax.portlet.PortletRequest request)
Constructs a proxy

Parameters:
request - The underlying request
Method Detail

isUserInRole

public boolean isUserInRole(String role)
True if the user is in the given role

Specified by:
isUserInRole in interface PrincipalProxy
Parameters:
role - The role
Returns:
True if the user is in that role

getUserPrincipal

public Principal getUserPrincipal()
Gets the user principal

Specified by:
getUserPrincipal in interface PrincipalProxy
Returns:
The principal

getRemoteUser

public String getRemoteUser()
Gets the user id

Specified by:
getRemoteUser in interface PrincipalProxy
Returns:
The user id

isRequestSecure

public boolean isRequestSecure()
Is the request using https?

Specified by:
isRequestSecure in interface PrincipalProxy
Returns:
True if using https

getRequest

public HttpServletRequest getRequest()
Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.

Gets the request.

Specified by:
getRequest in interface PrincipalProxy
Returns:
The request
Throws:
UnsupportedOperationException - not supported in this implementation.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletPortletPreferences (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.interceptor
Class ServletPortletPreferences

java.lang.Object
    extended by  org.apache.struts2.portlet.interceptor.ServletPortletPreferences
All Implemented Interfaces:
javax.portlet.PortletPreferences
public class ServletPortletPreferences
extends Object
implements javax.portlet.PortletPreferences

Simple portlet preferences implementation that uses a map in the Session as storage.

Field Summary
private String | PREFERENCES_KEY
private Map | session
Constructor Summary
ServletPortletPreferences(Map session)
Method Summary
Map | getMap()
Enumeration | getNames()
String | getValue(String key, String def)
String[] | getValues(String key, String[] def)
boolean | isReadOnly(String arg0)
void | reset(String arg0)
void | setValue(String key, String value)
void | setValues(String key, String[] value)
void | store()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

session

private Map session

PREFERENCES_KEY

private String PREFERENCES_KEY
Constructor Detail

ServletPortletPreferences

public ServletPortletPreferences(Map session)
Method Detail

getMap

public Map getMap()
Specified by:
getMap in interface javax.portlet.PortletPreferences

getNames

public Enumeration getNames()
Specified by:
getNames in interface javax.portlet.PortletPreferences

getValue

public String getValue(String key,
                       String def)
Specified by:
getValue in interface javax.portlet.PortletPreferences

getValues

public String[] getValues(String key,
                          String[] def)
Specified by:
getValues in interface javax.portlet.PortletPreferences

isReadOnly

public boolean isReadOnly(String arg0)
Specified by:
isReadOnly in interface javax.portlet.PortletPreferences

reset

public void reset(String arg0)
           throws javax.portlet.ReadOnlyException
Specified by:
reset in interface javax.portlet.PortletPreferences
Throws:
javax.portlet.ReadOnlyException

setValue

public void setValue(String key,
                     String value)
              throws javax.portlet.ReadOnlyException
Specified by:
setValue in interface javax.portlet.PortletPreferences
Throws:
javax.portlet.ReadOnlyException

setValues

public void setValues(String key,
                      String[] value)
               throws javax.portlet.ReadOnlyException
Specified by:
setValues in interface javax.portlet.PortletPreferences
Throws:
javax.portlet.ReadOnlyException

store

public void store()
           throws IOException,
                  javax.portlet.ValidatorException
Specified by:
store in interface javax.portlet.PortletPreferences
Throws:
IOException
javax.portlet.ValidatorException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.portlet.result (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.portlet.result

Class Summary
PortletResult | Result type that includes a JSP to render.
PortletResult.IncludeTemplate |
PortletVelocityResult | Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.


org.apache.struts2.portlet.result Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.portlet.result

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.portlet.result.PortletResult.IncludeTemplate
    • org.apache.struts2.dispatcher.StrutsResultSupport (implements com.opensymphony.xwork2.Result, org.apache.struts2.StrutsStatics)
      • org.apache.struts2.portlet.result.PortletResult
      • org.apache.struts2.portlet.result.PortletVelocityResult


Uses of Package org.apache.struts2.portlet.result (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.portlet.result

No usage of org.apache.struts2.portlet.result

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


PortletResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.result
Class PortletResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.portlet.result.PortletResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class PortletResult
extends StrutsResultSupport

Result type that includes a JSP to render.

See Also:
Serialized Form

Nested Class Summary
(package private) static class PortletResult.IncludeTemplate
Field Summary
private String | contentType
private static Log | LOG Logger instance.
private static long | serialVersionUID
private String | title
Fields inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
DEFAULT_PARAM
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
PortletResult()
PortletResult(String location)
Method Summary
protected static void | convertQueryParamsToRenderParams(javax.portlet.ActionResponse response, String queryParams) Converts the query params to render params.
void | doExecute(String finalLocation, ActionInvocation actionInvocation) Execute the result.
protected void | executeActionResult(String finalLocation, ActionInvocation invocation) Executes the action result.
private void | executeRegularServletResult(String finalLocation, ActionInvocation actionInvocation) Executes the regular servlet result.
protected void | executeRenderResult(String finalLocation) Executes the render result.
void | setContentType(String contentType) Sets the content type.
void | setTitle(String title) Sets the title.
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

LOG

private static final Log LOG
Logger instance.

contentType

private String contentType

title

private String title
Constructor Detail

PortletResult

public PortletResult()

PortletResult

public PortletResult(String location)
Method Detail

doExecute

public void doExecute(String finalLocation,
                      ActionInvocation actionInvocation)
               throws Exception
Execute the result. Obtains the PortletRequestDispatcherfrom the PortletActionContextand includes the JSP.

Specified by:
doExecute in class StrutsResultSupport
Parameters:
finalLocation - the location (jsp page, action, etc) to go to.
actionInvocation - the execution state of the action.
Throws:
Exception - if an error occurs while executing the result.
See Also:
Result.execute(com.opensymphony.xwork2.ActionInvocation)

executeRegularServletResult

private void executeRegularServletResult(String finalLocation,
                                         ActionInvocation actionInvocation)
                                  throws ServletException,
                                         IOException
Executes the regular servlet result.

Parameters:
finalLocation -
actionInvocation -
Throws:
ServletException
IOException

executeActionResult

protected void executeActionResult(String finalLocation,
                                   ActionInvocation invocation)
Executes the action result.

Parameters:
finalLocation -
invocation -

convertQueryParamsToRenderParams

protected static void convertQueryParamsToRenderParams(javax.portlet.ActionResponse response,
                                                       String queryParams)
Converts the query params to render params.

Parameters:
response -
queryParams -

executeRenderResult

protected void executeRenderResult(String finalLocation)
                            throws javax.portlet.PortletException,
                                   IOException
Executes the render result.

Parameters:
finalLocation -
Throws:
javax.portlet.PortletException
IOException

setContentType

public void setContentType(String contentType)
Sets the content type.

Parameters:
contentType - The content type to set.

setTitle

public void setTitle(String title)
Sets the title.

Parameters:
title - The title to set.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PortletResult.IncludeTemplate (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.result
Class PortletResult.IncludeTemplate

java.lang.Object
    extended by  org.apache.struts2.portlet.result.PortletResult.IncludeTemplate
Enclosing class:
PortletResult
static class PortletResult.IncludeTemplate
extends Object

Constructor Summary
PortletResult.IncludeTemplate()
Method Summary
protected void | include(javax.portlet.PortletRequestDispatcher dispatcher, javax.portlet.RenderRequest req, javax.portlet.RenderResponse res)
protected void | when(IOException e)
protected void | when(javax.portlet.PortletException e)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PortletResult.IncludeTemplate

PortletResult.IncludeTemplate()
Method Detail

include

protected void include(javax.portlet.PortletRequestDispatcher dispatcher,
                       javax.portlet.RenderRequest req,
                       javax.portlet.RenderResponse res)
                throws javax.portlet.PortletException,
                       IOException
Throws:
javax.portlet.PortletException
IOException

when

protected void when(javax.portlet.PortletException e)

when

protected void when(IOException e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PortletVelocityResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.result
Class PortletVelocityResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.portlet.result.PortletVelocityResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class PortletVelocityResult
extends StrutsResultSupport

Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

This result type takes the following parameters:

  • location (default) - the location of the template to process.
  • parse - true by default. If set to false, the location param will not be parsed for Ognl expressions.

This result follows the same rules from StrutsResultSupport.

Example:
 <!-- START SNIPPET: example -->
  <result name="success" type="velocity">
    <param name="location">foo.vm</param>
  </result>
  <!-- END SNIPPET: example -->

See Also:
Serialized Form

Field Summary
private String | defaultEncoding
private static Log | log
private static long | serialVersionUID
private VelocityManager | velocityManager
Fields inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
DEFAULT_PARAM
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
PortletVelocityResult()
PortletVelocityResult(String location)
Method Summary
protected org.apache.velocity.context.Context | createContext(VelocityManager velocityManager, ValueStack stack, HttpServletRequest request, HttpServletResponse response, String location) Creates the VelocityContext that we'll use to render this page.
void | doExecute(String location, ActionInvocation invocation) Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed).
private void | executeActionResult(String location, ActionInvocation invocation) Executes the result
void | executeRenderResult(String finalLocation, ActionInvocation invocation) Creates a Velocity context from the action, loads a Velocity template and executes the template.
protected String | getContentType(String templateLocation) Retrieve the content type for this template.
protected String | getEncoding(String templateLocation) Retrieve the encoding for this template.
protected org.apache.velocity.Template | getTemplate(ValueStack stack, org.apache.velocity.app.VelocityEngine velocity, ActionInvocation invocation, String location, String encoding) Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.
private void | prepareServletActionContext() Prepares the servlet action context for this request
void | setDefaultEncoding(String encoding)
void | setVelocityManager(VelocityManager mgr)
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

log

private static final Log log

defaultEncoding

private String defaultEncoding

velocityManager

private VelocityManager velocityManager
Constructor Detail

PortletVelocityResult

public PortletVelocityResult()

PortletVelocityResult

public PortletVelocityResult(String location)
Method Detail

setVelocityManager

public void setVelocityManager(VelocityManager mgr)

setDefaultEncoding

public void setDefaultEncoding(String encoding)

doExecute

public void doExecute(String location,
                      ActionInvocation invocation)
               throws Exception
Description copied from class: StrutsResultSupport
Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed). Subclasses must implement this class to handle custom logic for result handling.

Specified by:
doExecute in class StrutsResultSupport
Parameters:
location - the location (jsp page, action, etc) to go to.
invocation - the execution state of the action.
Throws:
Exception - if an error occurs while executing the result.

executeActionResult

private void executeActionResult(String location,
                                 ActionInvocation invocation)
Executes the result

Parameters:
location - The location string
invocation - The action invocation

executeRenderResult

public void executeRenderResult(String finalLocation,
                                ActionInvocation invocation)
                         throws Exception
Creates a Velocity context from the action, loads a Velocity template and executes the template. Output is written to the servlet output stream.

Parameters:
finalLocation - the location of the Velocity template
invocation - an encapsulation of the action execution state.
Throws:
Exception - if an error occurs when creating the Velocity context, loading or executing the template or writing output to the servlet response stream.

getContentType

protected String getContentType(String templateLocation)
Retrieve the content type for this template.

People can override this method if they want to provide specific content types for specific templates (eg text/xml).

Returns:
The content type associated with this template (default "text/html")

getEncoding

protected String getEncoding(String templateLocation)
Retrieve the encoding for this template.

People can override this method if they want to provide specific encodings for specific templates.

Returns:
The encoding associated with this template (defaults to the value of 'struts.i18n.encoding' property)

getTemplate

protected org.apache.velocity.Template getTemplate(ValueStack stack,
                                                   org.apache.velocity.app.VelocityEngine velocity,
                                                   ActionInvocation invocation,
                                                   String location,
                                                   String encoding)
                                            throws Exception
Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.

Parameters:
stack - the value stack to resolve the location again (when parse equals true)
velocity - the velocity engine to process the request against
invocation - an encapsulation of the action execution state.
location - the location of the template
encoding - the charset encoding of the template
Returns:
the template to render
Throws:
Exception - when the requested template could not be found

createContext

protected org.apache.velocity.context.Context createContext(VelocityManager velocityManager,
                                                            ValueStack stack,
                                                            HttpServletRequest request,
                                                            HttpServletResponse response,
                                                            String location)
Creates the VelocityContext that we'll use to render this page.

Parameters:
velocityManager - a reference to the velocityManager to use
stack - the value stack to resolve the location against (when parse equals true)
location - the name of the template that is being used
Returns:
the a minted Velocity context.

prepareServletActionContext

private void prepareServletActionContext()
                                  throws javax.portlet.PortletException,
                                         IOException
Prepares the servlet action context for this request

Throws:
javax.portlet.PortletException
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.portlet.util (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.portlet.util

Class Summary
HttpServletRequestMock | A simple mock class to interact with Struts 2 API's that require a servlet request
PortletUrlHelper | Helper class for creating Portlet URLs.


org.apache.struts2.portlet.util Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.portlet.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.portlet.util.HttpServletRequestMock (implements javax.servlet.http.HttpServletRequest)
    • org.apache.struts2.portlet.util.PortletUrlHelper


Uses of Package org.apache.struts2.portlet.util (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.portlet.util

Packages that use org.apache.struts2.portlet.util
org.apache.struts2.portlet.util

Classes in org.apache.struts2.portlet.util used by org.apache.struts2.portlet.util
HttpServletRequestMock
A simple mock class to interact with Struts 2 API's that require a servlet request

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


HttpServletRequestMock (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.util
Class HttpServletRequestMock

java.lang.Object
    extended by  org.apache.struts2.portlet.util.HttpServletRequestMock
All Implemented Interfaces:
HttpServletRequest, ServletRequest
public class HttpServletRequestMock
extends Object
implements HttpServletRequest

A simple mock class to interact with Struts 2 API's that require a servlet request

Field Summary
private Map | parameterMap
private String | servletPath
Fields inherited from interface javax.servlet.http.HttpServletRequest
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
Constructor Summary
HttpServletRequestMock()
Method Summary
Object | getAttribute(String arg0)
Enumeration | getAttributeNames()
String | getAuthType()
String | getCharacterEncoding()
int | getContentLength()
String | getContentType()
String | getContextPath()
Cookie[] | getCookies()
long | getDateHeader(String arg0)
String | getHeader(String arg0)
Enumeration | getHeaderNames()
Enumeration | getHeaders(String arg0)
ServletInputStream | getInputStream()
int | getIntHeader(String arg0)
String | getLocalAddr()
Locale | getLocale()
Enumeration | getLocales()
String | getLocalName()
int | getLocalPort()
String | getMethod()
String | getParameter(String arg0)
Map | getParameterMap()
Enumeration | getParameterNames()
String[] | getParameterValues(String arg0)
String | getPathInfo()
String | getPathTranslated()
String | getProtocol()
String | getQueryString()
BufferedReader | getReader()
String | getRealPath(String arg0)
String | getRemoteAddr()
String | getRemoteHost()
int | getRemotePort()
String | getRemoteUser()
RequestDispatcher | getRequestDispatcher(String arg0)
String | getRequestedSessionId()
String | getRequestURI()
StringBuffer | getRequestURL()
String | getScheme()
String | getServerName()
int | getServerPort()
String | getServletPath()
HttpSession | getSession()
HttpSession | getSession(boolean arg0)
Principal | getUserPrincipal()
boolean | isRequestedSessionIdFromCookie()
boolean | isRequestedSessionIdFromUrl()
boolean | isRequestedSessionIdFromURL()
boolean | isRequestedSessionIdValid()
boolean | isSecure()
boolean | isUserInRole(String arg0)
void | removeAttribute(String arg0)
void | setAttribute(String arg0, Object arg1)
void | setCharacterEncoding(String arg0)
HttpServletRequestMock | setParameterMap(Map parameterMap)
HttpServletRequestMock | setServletPath(String servletPath)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

servletPath

private String servletPath

parameterMap

private Map parameterMap
Constructor Detail

HttpServletRequestMock

public HttpServletRequestMock()
Method Detail

getAuthType

public String getAuthType()
Specified by:
getAuthType in interface HttpServletRequest

getContextPath

public String getContextPath()
Specified by:
getContextPath in interface HttpServletRequest

getCookies

public Cookie[] getCookies()
Specified by:
getCookies in interface HttpServletRequest

getDateHeader

public long getDateHeader(String arg0)
Specified by:
getDateHeader in interface HttpServletRequest

getHeader

public String getHeader(String arg0)
Specified by:
getHeader in interface HttpServletRequest

getHeaderNames

public Enumeration getHeaderNames()
Specified by:
getHeaderNames in interface HttpServletRequest

getHeaders

public Enumeration getHeaders(String arg0)
Specified by:
getHeaders in interface HttpServletRequest

getIntHeader

public int getIntHeader(String arg0)
Specified by:
getIntHeader in interface HttpServletRequest

getMethod

public String getMethod()
Specified by:
getMethod in interface HttpServletRequest

getPathInfo

public String getPathInfo()
Specified by:
getPathInfo in interface HttpServletRequest

getPathTranslated

public String getPathTranslated()
Specified by:
getPathTranslated in interface HttpServletRequest

getQueryString

public String getQueryString()
Specified by:
getQueryString in interface HttpServletRequest

getRemoteUser

public String getRemoteUser()
Specified by:
getRemoteUser in interface HttpServletRequest

getRequestURI

public String getRequestURI()
Specified by:
getRequestURI in interface HttpServletRequest

getRequestURL

public StringBuffer getRequestURL()
Specified by:
getRequestURL in interface HttpServletRequest

getRequestedSessionId

public String getRequestedSessionId()
Specified by:
getRequestedSessionId in interface HttpServletRequest

getServletPath

public String getServletPath()
Specified by:
getServletPath in interface HttpServletRequest

getSession

public HttpSession getSession()
Specified by:
getSession in interface HttpServletRequest

getSession

public HttpSession getSession(boolean arg0)
Specified by:
getSession in interface HttpServletRequest

getUserPrincipal

public Principal getUserPrincipal()
Specified by:
getUserPrincipal in interface HttpServletRequest

isRequestedSessionIdFromCookie

public boolean isRequestedSessionIdFromCookie()
Specified by:
isRequestedSessionIdFromCookie in interface HttpServletRequest

isRequestedSessionIdFromURL

public boolean isRequestedSessionIdFromURL()
Specified by:
isRequestedSessionIdFromURL in interface HttpServletRequest

isRequestedSessionIdFromUrl

public boolean isRequestedSessionIdFromUrl()
Specified by:
isRequestedSessionIdFromUrl in interface HttpServletRequest

isRequestedSessionIdValid

public boolean isRequestedSessionIdValid()
Specified by:
isRequestedSessionIdValid in interface HttpServletRequest

isUserInRole

public boolean isUserInRole(String arg0)
Specified by:
isUserInRole in interface HttpServletRequest

getAttribute

public Object getAttribute(String arg0)
Specified by:
getAttribute in interface ServletRequest

getAttributeNames

public Enumeration getAttributeNames()
Specified by:
getAttributeNames in interface ServletRequest

getCharacterEncoding

public String getCharacterEncoding()
Specified by:
getCharacterEncoding in interface ServletRequest

getContentLength

public int getContentLength()
Specified by:
getContentLength in interface ServletRequest

getContentType

public String getContentType()
Specified by:
getContentType in interface ServletRequest

getInputStream

public ServletInputStream getInputStream()
                                  throws IOException
Specified by:
getInputStream in interface ServletRequest
Throws:
IOException

getLocalAddr

public String getLocalAddr()
Specified by:
getLocalAddr in interface ServletRequest

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface ServletRequest

getLocalPort

public int getLocalPort()
Specified by:
getLocalPort in interface ServletRequest

getLocale

public Locale getLocale()
Specified by:
getLocale in interface ServletRequest

getLocales

public Enumeration getLocales()
Specified by:
getLocales in interface ServletRequest

getParameter

public String getParameter(String arg0)
Specified by:
getParameter in interface ServletRequest

getParameterMap

public Map getParameterMap()
Specified by:
getParameterMap in interface ServletRequest

getParameterNames

public Enumeration getParameterNames()
Specified by:
getParameterNames in interface ServletRequest

getParameterValues

public String[] getParameterValues(String arg0)
Specified by:
getParameterValues in interface ServletRequest

getProtocol

public String getProtocol()
Specified by:
getProtocol in interface ServletRequest

getReader

public BufferedReader getReader()
                         throws IOException
Specified by:
getReader in interface ServletRequest
Throws:
IOException

getRealPath

public String getRealPath(String arg0)
Specified by:
getRealPath in interface ServletRequest

getRemoteAddr

public String getRemoteAddr()
Specified by:
getRemoteAddr in interface ServletRequest

getRemoteHost

public String getRemoteHost()
Specified by:
getRemoteHost in interface ServletRequest

getRemotePort

public int getRemotePort()
Specified by:
getRemotePort in interface ServletRequest

getRequestDispatcher

public RequestDispatcher getRequestDispatcher(String arg0)
Specified by:
getRequestDispatcher in interface ServletRequest

getScheme

public String getScheme()
Specified by:
getScheme in interface ServletRequest

getServerName

public String getServerName()
Specified by:
getServerName in interface ServletRequest

getServerPort

public int getServerPort()
Specified by:
getServerPort in interface ServletRequest

isSecure

public boolean isSecure()
Specified by:
isSecure in interface ServletRequest

removeAttribute

public void removeAttribute(String arg0)
Specified by:
removeAttribute in interface ServletRequest

setAttribute

public void setAttribute(String arg0,
                         Object arg1)
Specified by:
setAttribute in interface ServletRequest

setCharacterEncoding

public void setCharacterEncoding(String arg0)
                          throws UnsupportedEncodingException
Specified by:
setCharacterEncoding in interface ServletRequest
Throws:
UnsupportedEncodingException

setParameterMap

public HttpServletRequestMock setParameterMap(Map parameterMap)
Parameters:
parameterMap - the parameterMap to set

setServletPath

public HttpServletRequestMock setServletPath(String servletPath)
Parameters:
servletPath - the servletPath to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


PortletUrlHelper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.portlet.util
Class PortletUrlHelper

java.lang.Object
    extended by  org.apache.struts2.portlet.util.PortletUrlHelper

public class PortletUrlHelper
extends Object

Helper class for creating Portlet URLs. Portlet URLs are fundamentally different from regular servlet URLs since they never target the application itself; all requests go through the portlet container and must therefore be programatically constructed using the RenderResponse.createActionURL() and RenderResponse.createRenderURL() APIs.

Field Summary
static String | ENCODING
private static Log | LOG
Constructor Summary
PortletUrlHelper()
Method Summary
static String | buildResourceUrl(String value, Map params) Encode an url to a non Struts action resource, like stylesheet, image or servlet.
static String | buildUrl(String action, String namespace, Map params, String type, String mode, String state) Create a portlet URL with for the specified action and namespace.
static String | buildUrl(String action, String namespace, Map params, String scheme, String type, String portletMode, String windowState, boolean includeContext, boolean encodeResult) Create a portlet URL with for the specified action and namespace.
static Map | ensureParamsAreStringArrays(Map params) Will ensure that all entries in params are String arrays, as requried by the setParameters on the PortletURL.
private static javax.portlet.PortletMode | getPortletMode(javax.portlet.RenderRequest portletReq, String portletMode) Convert the given String to a PortletMode object.
private static javax.portlet.WindowState | getWindowState(javax.portlet.RenderRequest portletReq, String windowState) Convert the given String to a WindowState object.
private static String | prependNamespace(String namespace, String portletMode) Prepend the namespace configuration for the specified namespace and PortletMode.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ENCODING

public static final String ENCODING
See Also:
Constant Field Values

LOG

private static final Log LOG
Constructor Detail

PortletUrlHelper

public PortletUrlHelper()
Method Detail

buildUrl

public static String buildUrl(String action,
                              String namespace,
                              Map params,
                              String type,
                              String mode,
                              String state)
Create a portlet URL with for the specified action and namespace.

Parameters:
action - The action the URL should invoke.
namespace - The namespace of the action to invoke.
params - The parameters of the URL.
type - The type of the url, either action or render
mode - The PortletMode of the URL.
state - The WindowState of the URL.
Returns:
The URL String.

buildUrl

public static String buildUrl(String action,
                              String namespace,
                              Map params,
                              String scheme,
                              String type,
                              String portletMode,
                              String windowState,
                              boolean includeContext,
                              boolean encodeResult)
Create a portlet URL with for the specified action and namespace.

See Also:
buildUrl(String, String, Map, String, String, String)

prependNamespace

private static String prependNamespace(String namespace,
                                       String portletMode)
Prepend the namespace configuration for the specified namespace and PortletMode.

Parameters:
namespace - The base namespace.
portletMode - The PortletMode.
Returns:
prepended namespace.

buildResourceUrl

public static String buildResourceUrl(String value,
                                      Map params)
Encode an url to a non Struts action resource, like stylesheet, image or servlet.

Parameters:
value -
Returns:
encoded url to non Struts action resources.

ensureParamsAreStringArrays

public static Map ensureParamsAreStringArrays(Map params)
Will ensure that all entries in params are String arrays, as requried by the setParameters on the PortletURL.

Parameters:
params - The parameters to the URL.
Returns:
A Map with all parameters as String arrays.

getWindowState

private static javax.portlet.WindowState getWindowState(javax.portlet.RenderRequest portletReq,
                                                        String windowState)
Convert the given String to a WindowState object.

Parameters:
portletReq - The RenderRequest.
windowState - The WindowState as a String.
Returns:
The WindowState that mathces the windowState String, or if the Sring is blank, the current WindowState.

getPortletMode

private static javax.portlet.PortletMode getPortletMode(javax.portlet.RenderRequest portletReq,
                                                        String portletMode)
Convert the given String to a PortletMode object.

Parameters:
portletReq - The RenderRequest.
portletMode - The PortletMode as a String.
Returns:
The PortletMode that mathces the portletMode String, or if the Sring is blank, the current PortletMode.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.servlet.interceptor (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.servlet.interceptor

Class Summary
ServletPrincipalProxy PrincipalProxy implementation for using HttpServletRequest Principal related methods.


org.apache.struts2.servlet.interceptor Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.servlet.interceptor

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.servlet.interceptor.ServletPrincipalProxy (implements org.apache.struts2.interceptor.PrincipalProxy)


Uses of Package org.apache.struts2.servlet.interceptor (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.servlet.interceptor

No usage of org.apache.struts2.servlet.interceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ServletPrincipalProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.servlet.interceptor
Class ServletPrincipalProxy

java.lang.Object
    extended by  org.apache.struts2.servlet.interceptor.ServletPrincipalProxy
All Implemented Interfaces:
PrincipalProxy
public class ServletPrincipalProxy
extends Object
implements PrincipalProxy

PrincipalProxy implementation for using HttpServletRequest Principal related methods.

Field Summary
private  HttpServletRequest request
Constructor Summary
ServletPrincipalProxy(HttpServletRequest request)
Constructs a proxy
Method Summary
String | getRemoteUser() Gets the user id
HttpServletRequest | getRequest() Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
Principal | getUserPrincipal() Gets the user principal
boolean | isRequestSecure() Is the request using https?
boolean | isUserInRole(String role) True if the user is in the given role
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

request

private HttpServletRequest request
Constructor Detail

ServletPrincipalProxy

public ServletPrincipalProxy(HttpServletRequest request)
Constructs a proxy

Parameters:
request - The underlying request
Method Detail

isUserInRole

public boolean isUserInRole(String role)
True if the user is in the given role

Specified by:
isUserInRole in interface PrincipalProxy
Parameters:
role - The role
Returns:
True if the user is in that role

getUserPrincipal

public Principal getUserPrincipal()
Gets the user principal

Specified by:
getUserPrincipal in interface PrincipalProxy
Returns:
The principal

getRemoteUser

public String getRemoteUser()
Gets the user id

Specified by:
getRemoteUser in interface PrincipalProxy
Returns:
The user id

isRequestSecure

public boolean isRequestSecure()
Is the request using https?

Specified by:
isRequestSecure in interface PrincipalProxy
Returns:
True if using https

getRequest

public HttpServletRequest getRequest()
Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.

Gets the request.

Specified by:
getRequest in interface PrincipalProxy
Returns:
The request
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.util (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.util

Miscellaneous helper classes.

See:
Description

Interface Summary
IteratorGenerator.Converter | Interface for converting each separated token into an Object of choice.
ObjectFactoryDestroyable | An interface to be implemented by any ObjectFactory implementation if it requires shutdown hook whenever an ObjectFactory is to be destroyed.
ServletContextAware | For components that have a dependence on the Servlet context.
SubsetIteratorFilter.Decider | A decider determines if the given element should be added to the list or not.

Class Summary
AppendIteratorFilter | A bean that takes several iterators and outputs them in sequence
AttributeMap | A Map that holds 4 levels of scope.
ClassLoaderUtils | This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers.
ContainUtil | ContainUtil will check if object 1 contains object 2.
Counter | A bean that can be used to keep track of a counter.
DateFormatter | A bean that can be used to format dates
FastByteArrayOutputStream | A speedy implementation of ByteArrayOutputStream.
InvocationSessionStore | InvocationSessionStore
InvocationSessionStore.InvocationContext |
IteratorFilterSupport | A base class for iterator filters
IteratorGenerator | A bean that generates an iterator filled with a given object depending on the count, separator and converter defined.
ListEntry | Entry in a list.
MakeIterator | MakeIterator.
MergeIteratorFilter | A bean that takes several iterators and outputs the merge of them.
PrefixTrie | Quickly matches a prefix to an object.
PrefixTrie.Node |
Sorter | Sorters.
SortIteratorFilter | A bean that takes a source and comparator then attempt to sort the source utilizing the comparator.
StrutsTestCaseHelper | Generic test setup methods to be used with any unit testing framework.
StrutsTypeConverter | Base class for type converters used in Struts.
StrutsUtil | Struts base utility class, for use in Velocity and Freemarker templates
StrutsUtil.ResponseWrapper |
StrutsUtil.ServletOutputStreamWrapper |
SubsetIteratorFilter | A bean that takes an iterator and outputs a subset of it.
TabbedPane | A bean that helps implement a tabbed pane
Timer | A bean that can be used to time execution of pages
TokenHelper | TokenHelper
URLBean | A bean that can generate a URL.
VelocityStrutsUtil | Struts velocity related util.

Package org.apache.struts2.util Description

Miscellaneous helper classes.


org.apache.struts2.util Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.util.AttributeMap (implements java.util.Map<K,V>)
    • org.apache.struts2.util.ClassLoaderUtils
    • org.apache.struts2.util.ContainUtil
    • org.apache.struts2.util.Counter (implements java.util.Iterator<E>, java.io.Serializable)
    • org.apache.struts2.util.DateFormatter
    • ognl.DefaultTypeConverter (implements ognl.TypeConverter)
      • org.apache.struts2.util.StrutsTypeConverter
    • org.apache.struts2.util.InvocationSessionStore
    • org.apache.struts2.util.InvocationSessionStore.InvocationContext (implements java.io.Serializable)
    • org.apache.struts2.util.IteratorFilterSupport
      • org.apache.struts2.util.AppendIteratorFilter (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
      • org.apache.struts2.util.MergeIteratorFilter (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
      • org.apache.struts2.util.SortIteratorFilter (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
      • org.apache.struts2.util.SubsetIteratorFilter (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
    • org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator (implements java.util.Iterator<E>)
    • org.apache.struts2.util.IteratorGenerator (implements com.opensymphony.xwork2.Action, java.util.Iterator<E>)
    • org.apache.struts2.util.ListEntry
    • org.apache.struts2.util.MakeIterator
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • org.apache.struts2.util.FastByteArrayOutputStream
      • javax.servlet.ServletOutputStream
        • org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper
    • org.apache.struts2.util.PrefixTrie
    • org.apache.struts2.util.PrefixTrie.Node
    • javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • org.apache.struts2.util.StrutsUtil.ResponseWrapper
    • org.apache.struts2.util.Sorter
    • org.apache.struts2.util.StrutsTestCaseHelper
    • org.apache.struts2.util.StrutsUtil
      • org.apache.struts2.util.VelocityStrutsUtil
    • org.apache.struts2.util.TabbedPane
    • org.apache.struts2.util.Timer
    • org.apache.struts2.util.TokenHelper
    • org.apache.struts2.util.URLBean

Interface Hierarchy

  • org.apache.struts2.util.IteratorGenerator.Converter
  • org.apache.struts2.util.ObjectFactoryDestroyable
  • org.apache.struts2.util.ServletContextAware
  • org.apache.struts2.util.SubsetIteratorFilter.Decider


Uses of Package org.apache.struts2.util (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.util

Packages that use org.apache.struts2.util
org.apache.struts2.components |
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.

Classes in org.apache.struts2.util used by org.apache.struts2.components
AppendIteratorFilter
A bean that takes several iterators and outputs them in sequence
FastByteArrayOutputStream
A speedy implementation of ByteArrayOutputStream.
MergeIteratorFilter
A bean that takes several iterators and outputs the merge of them.

Classes in org.apache.struts2.util used by org.apache.struts2.dispatcher.mapper
PrefixTrie
Quickly matches a prefix to an object.

Classes in org.apache.struts2.util used by org.apache.struts2.util
IteratorFilterSupport
A base class for iterator filters
IteratorGenerator.Converter
Interface for converting each separated token into an Object of choice.
PrefixTrie.Node
StrutsUtil
Struts base utility class, for use in Velocity and Freemarker templates
SubsetIteratorFilter.Decider
A decider determines if the given element should be added to the list or not.
URLBean
A bean that can generate a URL.

Classes in org.apache.struts2.util used by org.apache.struts2.views.jsp.iterator
IteratorGenerator
A bean that generates an iterator filled with a given object depending on the count, separator and converter defined.
SortIteratorFilter
A bean that takes a source and comparator then attempt to sort the source utilizing the comparator.
SubsetIteratorFilter
A bean that takes an iterator and outputs a subset of it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ObjectFactoryDestroyable (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Interface ObjectFactoryDestroyable

public interface ObjectFactoryDestroyable

An interface to be implemented by any ObjectFactory implementation if it requires shutdown hook whenever an ObjectFactory is to be destroyed.

See Also:
FilterDispatcher, Dispatcher

Method Summary
 void destroy()

Method Detail

destroy

void destroy()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletContextAware (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Interface ServletContextAware

public interface ServletContextAware

For components that have a dependence on the Servlet context.

Method Summary
 void setServletContext(ServletContext context)

Method Detail

setServletContext

void setServletContext(ServletContext context)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AppendIteratorFilter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class AppendIteratorFilter

java.lang.Object
    extended by  org.apache.struts2.util.IteratorFilterSupport
        extended by  org.apache.struts2.util.AppendIteratorFilter
All Implemented Interfaces:
Action, Iterator
public class AppendIteratorFilter
extends IteratorFilterSupport
implements Iterator, Action

A bean that takes several iterators and outputs them in sequence

See Also:
AppendIterator, AppendIteratorTag

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.struts2.util.IteratorFilterSupport
IteratorFilterSupport.EnumerationIterator
Field Summary
(package private) List | iterators
(package private) List | sources
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
AppendIteratorFilter()
Method Summary
String | execute() Where the logic of the action is executed.
boolean | hasNext()
Object | next()
void | remove()
void | setSource(Object anIterator)
Methods inherited from class org.apache.struts2.util.IteratorFilterSupport
getIterator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

iterators

List iterators

sources

List sources
Constructor Detail

AppendIteratorFilter

public AppendIteratorFilter()
Method Detail

setSource

public void setSource(Object anIterator)

execute

public String execute()
Description copied from interface: Action
Where the logic of the action is executed.

Specified by:
execute in interface Action
Returns:
a string representing the logical result of the execution. See constants in this interface for a list of standard result values.

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AttributeMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class AttributeMap

java.lang.Object
    extended by  org.apache.struts2.util.AttributeMap
All Implemented Interfaces:
Map
public class AttributeMap
extends Object
implements Map

A Map that holds 4 levels of scope.

The scopes are the ones known in the web world.:

  • Page scope
  • Request scope
  • Session scope
  • Application scope
A object is searched in the order above, starting from page and ending at application scope.

Nested Class Summary
Nested classes/interfaces inherited from interface java.util.Map
Map.Entry<K,V>
Field Summary
(package private) Map | context
protected static String | UNSUPPORTED
Constructor Summary
AttributeMap(Map context)
Method Summary
void | clear()
boolean | containsKey(Object key)
boolean | containsValue(Object value)
Set | entrySet()
Object | get(Object key)
private PageContext | getPageContext()
boolean | isEmpty()
Set | keySet()
Object | put(Object key, Object value)
void | putAll(Map t)
Object | remove(Object key)
int | size()
Collection | values()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Field Detail

UNSUPPORTED

protected static final String UNSUPPORTED
See Also:
Constant Field Values

context

Map context
Constructor Detail

AttributeMap

public AttributeMap(Map context)
Method Detail

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface Map

clear

public void clear()
Specified by:
clear in interface Map

containsKey

public boolean containsKey(Object key)
Specified by:
containsKey in interface Map

containsValue

public boolean containsValue(Object value)
Specified by:
containsValue in interface Map

entrySet

public Set entrySet()
Specified by:
entrySet in interface Map

get

public Object get(Object key)
Specified by:
get in interface Map

keySet

public Set keySet()
Specified by:
keySet in interface Map

put

public Object put(Object key,
                  Object value)
Specified by:
put in interface Map

putAll

public void putAll(Map t)
Specified by:
putAll in interface Map

remove

public Object remove(Object key)
Specified by:
remove in interface Map

size

public int size()
Specified by:
size in interface Map

values

public Collection values()
Specified by:
values in interface Map

getPageContext

private PageContext getPageContext()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ClassLoaderUtils (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class ClassLoaderUtils

java.lang.Object
    extended by  org.apache.struts2.util.ClassLoaderUtils

public class ClassLoaderUtils
extends Object

This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers.

It has come out of many months of frustrating use of multiple application servers at Atlassian, please don't change things unless you're sure they're not going to break in one server or another!

Constructor Summary
ClassLoaderUtils()
Method Summary
static URL | getResource(String resourceName, Class callingClass) Load a given resource.
static InputStream | getResourceAsStream(String resourceName, Class callingClass) This is a convenience method to load a resource as a stream.
static Class | loadClass(String className, Class callingClass) Load a class with a given name.
static void | printClassLoader() Prints the current classloader hierarchy - useful for debugging.
static void | printClassLoader(ClassLoader cl) Prints the classloader hierarchy from a given classloader - useful for debugging.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ClassLoaderUtils

public ClassLoaderUtils()
Method Detail

getResource

public static URL getResource(String resourceName,
                              Class callingClass)
Load a given resource.

This method will try to load the resource using the following methods (in order):

  • From Thread.currentThread().getContextClassLoader()
  • From ClassLoaderUtil.class.getClassLoader()
  • From the callingClass.getClassLoader()

Parameters:
resourceName - The name of the resource to load
callingClass - The Class object of the calling object

getResourceAsStream

public static InputStream getResourceAsStream(String resourceName,
                                              Class callingClass)
This is a convenience method to load a resource as a stream.

The algorithm used to find the resource is given in getResource()

Parameters:
resourceName - The name of the resource to load
callingClass - The Class object of the calling object

loadClass

public static Class loadClass(String className,
                              Class callingClass)
                       throws ClassNotFoundException
Load a class with a given name.

It will try to load the class in the following order:

  • From Thread.currentThread().getContextClassLoader()
  • Using the basic Class.forName(java.lang.String)
  • From ClassLoaderUtil.class.getClassLoader()
  • From the callingClass.getClassLoader()

Parameters:
className - The name of the class to load
callingClass - The Class object of the calling object
Throws:
ClassNotFoundException - If the class cannot be found anywhere.

printClassLoader

public static void printClassLoader()
Prints the current classloader hierarchy - useful for debugging.

printClassLoader

public static void printClassLoader(ClassLoader cl)
Prints the classloader hierarchy from a given classloader - useful for debugging.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class ContainUtil

java.lang.Object
    extended by  org.apache.struts2.util.ContainUtil

public class ContainUtil
extends Object

ContainUtil will check if object 1 contains object 2. Object 1 may be an Object, array, Collection, or a Map

Version:
$Date: 2006-11-06 10:01:43 -0500 (Mon, 06 Nov 2006) $ $Id: ContainUtil.java 471756 2006-11-06 15:01:43Z husted $

Constructor Summary
ContainUtil()
Method Summary
static boolean contains(Object obj1, Object obj2)
Determine if obj2 exists in obj1.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ContainUtil

public ContainUtil()
Method Detail

contains

public static boolean contains(Object obj1,
                               Object obj2)
Determine if obj2 exists in obj1.
Type Of obj1 | Comparison type
null | always return false
Map | Map containsKey(obj2)
Collection | Collection contains(obj2)
Array | there's an array element (e) where e.equals(obj2)
Object | obj1.equals(obj2)

Parameters:
obj1 -
obj2 -
Returns:
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Counter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class Counter

java.lang.Object
    extended by  org.apache.struts2.util.Counter
All Implemented Interfaces:
Serializable, Iterator
public class Counter
extends Object
implements Iterator, Serializable

A bean that can be used to keep track of a counter.

Since it is an Iterator it can be used by the iterator tag

See Also:
Serialized Form

Field Summary
(package private) long | current
(package private) long | first
(package private) long | interval
(package private) long | last
private static long | serialVersionUID
(package private) boolean | wrap
Constructor Summary
Counter()
Method Summary
long | getCurrent()
long | getFirst()
long | getInterval()
long | getLast()
long | getNext()
long | getPrevious()
boolean | hasNext()
boolean | isWrap()
Object | next()
void | remove()
void | setAdd(long addition)
void | setCurrent(long current)
void | setFirst(long first)
void | setInterval(long interval)
void | setLast(long last)
void | setWrap(boolean wrap)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

wrap

boolean wrap

first

long first

current

long current

interval

long interval

last

long last
Constructor Detail

Counter

public Counter()
Method Detail

setAdd

public void setAdd(long addition)

setCurrent

public void setCurrent(long current)

getCurrent

public long getCurrent()

setFirst

public void setFirst(long first)

getFirst

public long getFirst()

setInterval

public void setInterval(long interval)

getInterval

public long getInterval()

setLast

public void setLast(long last)

getLast

public long getLast()

getNext

public long getNext()

getPrevious

public long getPrevious()

setWrap

public void setWrap(boolean wrap)

isWrap

public boolean isWrap()

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateFormatter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class DateFormatter

java.lang.Object
    extended by  org.apache.struts2.util.DateFormatter

public class DateFormatter
extends Object

A bean that can be used to format dates

Field Summary
(package private) Date | date
(package private) DateFormat | format
(package private) DateFormat | parser
Constructor Summary
DateFormatter()
Method Summary
Date | getDate()
String | getFormattedDate()
void | setDate(Date date)
void | setDate(int date)
void | setDate(String date)
void | setFormat(DateFormat format)
void | setFormat(String format)
void | setParseFormat(String format)
void | setParser(DateFormat parser)
void | setTime(long time)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

date

Date date

format

DateFormat format

parser

DateFormat parser
Constructor Detail

DateFormatter

public DateFormatter()
Method Detail

setDate

public void setDate(String date)

setDate

public void setDate(Date date)

setDate

public void setDate(int date)

getDate

public Date getDate()

setFormat

public void setFormat(String format)

setFormat

public void setFormat(DateFormat format)

getFormattedDate

public String getFormattedDate()

setParseFormat

public void setParseFormat(String format)

setParser

public void setParser(DateFormat parser)

setTime

public void setTime(long time)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FastByteArrayOutputStream (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class FastByteArrayOutputStream

java.lang.Object
    extended by  java.io.OutputStream
        extended by  org.apache.struts2.util.FastByteArrayOutputStream
All Implemented Interfaces:
Closeable, Flushable
public class FastByteArrayOutputStream
extends OutputStream

A speedy implementation of ByteArrayOutputStream. It's not synchronized, and it does not copy buffers when it's expanded. There's also no copying of the internal buffer if it's contents is extracted with the writeTo(stream) method.

Field Summary
private int | blockSize
private byte[] | buffer
private LinkedList | buffers
private boolean | closed
private static int | DEFAULT_BLOCK_SIZE
private int | index
private int | size
Constructor Summary
FastByteArrayOutputStream()
FastByteArrayOutputStream(int aSize)
Method Summary
protected void | addBuffer() Create a new buffer and store the current one in linked list
void | close()
int | getSize()
byte[] | toByteArray()
String | toString()
void | write(byte[] data, int offset, int length)
void | write(int datum)
void | writeTo(OutputStream out)
void | writeTo(RandomAccessFile out)
void | writeTo(Writer out, String encoding)
Methods inherited from class java.io.OutputStream
flush, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

DEFAULT_BLOCK_SIZE

private static final int DEFAULT_BLOCK_SIZE
See Also:
Constant Field Values

buffers

private LinkedList buffers

buffer

private byte[] buffer

closed

private boolean closed

blockSize

private int blockSize

index

private int index

size

private int size
Constructor Detail

FastByteArrayOutputStream

public FastByteArrayOutputStream()

FastByteArrayOutputStream

public FastByteArrayOutputStream(int aSize)
Method Detail

getSize

public int getSize()

close

public void close()
Specified by:
close in interface Closeable
Overrides:
close in class OutputStream

toByteArray

public byte[] toByteArray()

toString

public String toString()
Overrides:
toString in class Object

write

public void write(int datum)
           throws IOException
Specified by:
write in class OutputStream
Throws:
IOException

write

public void write(byte[] data,
                  int offset,
                  int length)
           throws IOException
Overrides:
write in class OutputStream
Throws:
IOException

writeTo

public void writeTo(OutputStream out)
             throws IOException
Throws:
IOException

writeTo

public void writeTo(RandomAccessFile out)
             throws IOException
Throws:
IOException

writeTo

public void writeTo(Writer out,
                    String encoding)
             throws IOException
Throws:
IOException

addBuffer

protected void addBuffer()
Create a new buffer and store the current one in linked list

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvocationSessionStore (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class InvocationSessionStore

java.lang.Object
    extended by  org.apache.struts2.util.InvocationSessionStore

public class InvocationSessionStore
extends Object

InvocationSessionStore

Nested Class Summary
private static class InvocationSessionStore.InvocationContext
Field Summary
private static String INVOCATION_MAP_KEY
Constructor Summary
private InvocationSessionStore()
Method Summary
(package private) static Map getInvocationMap()
static ActionInvocation loadInvocation(String key, String token)
Checks the Map in the Session for the key and the token.
(package private) static void setInvocationMap(Map invocationMap)
static void storeInvocation(String key, String token, ActionInvocation invocation)
Stores the DefaultActionInvocation and ActionContext into the Session using the provided key for loading later using loadInvocation(java.lang.String, java.lang.String)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

INVOCATION_MAP_KEY

private static final String INVOCATION_MAP_KEY
See Also:
Constant Field Values
Constructor Detail

InvocationSessionStore

private InvocationSessionStore()
Method Detail

loadInvocation

public static ActionInvocation loadInvocation(String key,
                                              String token)
Checks the Map in the Session for the key and the token. If the ActionInvocation is saved in the Session, the ValueStack from the ActionProxy associated with the ActionInvocation is set into the ActionContext and the ActionInvocation is returned.

Parameters:
key - the name the DefaultActionInvocation and ActionContext were saved as
Returns:
the DefaultActionInvocation saved using the key, or null if none was found

storeInvocation

public static void storeInvocation(String key,
                                   String token,
                                   ActionInvocation invocation)
Stores the DefaultActionInvocation and ActionContext into the Session using the provided key for loading later using loadInvocation(java.lang.String, java.lang.String)

Parameters:
key -
invocation -

setInvocationMap

static void setInvocationMap(Map invocationMap)

getInvocationMap

static Map getInvocationMap()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvocationSessionStore.InvocationContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class InvocationSessionStore.InvocationContext

java.lang.Object
    extended by  org.apache.struts2.util.InvocationSessionStore.InvocationContext
All Implemented Interfaces:
Serializable
Enclosing class:
InvocationSessionStore
private static class InvocationSessionStore.InvocationContext
extends Object
implements Serializable

Field Summary
(package private) ActionInvocation | invocation
private static long | serialVersionUID
(package private) String | token
Constructor Summary
InvocationSessionStore.InvocationContext(ActionInvocation invocation, String token)
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

invocation

ActionInvocation invocation

token

String token
Constructor Detail

InvocationSessionStore.InvocationContext

public InvocationSessionStore.InvocationContext(ActionInvocation invocation,
                                                String token)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorFilterSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class IteratorFilterSupport

java.lang.Object
    extended by  org.apache.struts2.util.IteratorFilterSupport
Direct Known Subclasses:
AppendIteratorFilter, MergeIteratorFilter, SortIteratorFilter, SubsetIteratorFilter
public abstract class IteratorFilterSupport
extends Object

A base class for iterator filters

Nested Class Summary
 class IteratorFilterSupport.EnumerationIterator
Constructor Summary
IteratorFilterSupport()
Method Summary
protected  Object getIterator(Object source)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IteratorFilterSupport

public IteratorFilterSupport()
Method Detail

getIterator

protected Object getIterator(Object source)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorFilterSupport.EnumerationIterator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class IteratorFilterSupport.EnumerationIterator

java.lang.Object
    extended by  org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator
All Implemented Interfaces:
Iterator
Enclosing class:
IteratorFilterSupport
public class IteratorFilterSupport.EnumerationIterator
extends Object
implements Iterator

Field Summary
(package private)  Enumeration enumeration
Constructor Summary
IteratorFilterSupport.EnumerationIterator(Enumeration aEnum)
Method Summary
boolean | hasNext()
Object | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

enumeration

Enumeration enumeration
Constructor Detail

IteratorFilterSupport.EnumerationIterator

public IteratorFilterSupport.EnumerationIterator(Enumeration aEnum)
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorGenerator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class IteratorGenerator

java.lang.Object
    extended by  org.apache.struts2.util.IteratorGenerator
All Implemented Interfaces:
Action, Iterator
public class IteratorGenerator
extends Object
implements Iterator, Action

A bean that generates an iterator filled with a given object depending on the count, separator and converter defined. It is being used by IteratorGeneratorTag.

Nested Class Summary
static interface IteratorGenerator.Converter
Interface for converting each separated token into an Object of choice.
Field Summary
private static Log | _log
(package private) IteratorGenerator.Converter | converter
(package private) int | count
(package private) int | currentCount
(package private) String | separator
(package private) Object | value
(package private) List | values
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
IteratorGenerator()
Method Summary
String | execute() Where the logic of the action is executed.
boolean | getHasNext()
Object | getNext()
boolean | hasNext()
Object | next()
void | remove()
void | setConverter(IteratorGenerator.Converter aConverter)
void | setCount(int aCount)
void | setSeparator(String aChar)
void | setValues(Object aValue)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

values

List values

value

Object value

separator

String separator

converter

IteratorGenerator.Converter converter

count

int count

currentCount

int currentCount
Constructor Detail

IteratorGenerator

public IteratorGenerator()
Method Detail

setCount

public void setCount(int aCount)

getHasNext

public boolean getHasNext()

getNext

public Object getNext()

setSeparator

public void setSeparator(String aChar)

setConverter

public void setConverter(IteratorGenerator.Converter aConverter)

setValues

public void setValues(Object aValue)

execute

public String execute()
Description copied from interface: Action
Where the logic of the action is executed.

Specified by:
execute in interface Action
Returns:
a string representing the logical result of the execution. See constants in this interface for a list of standard result values.

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorGenerator.Converter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Interface IteratorGenerator.Converter

Enclosing class:
IteratorGenerator
public static interface IteratorGenerator.Converter

Interface for converting each separated token into an Object of choice.

Method Summary
 Object convert(String token)

Method Detail

convert

Object convert(String token)
               throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ListEntry (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class ListEntry

java.lang.Object
    extended by  org.apache.struts2.util.ListEntry

public class ListEntry
extends Object

Entry in a list.

Field Summary
private boolean | isSelected
private Object | key
private Object | value
Constructor Summary
ListEntry(Object key, Object value, boolean isSelected)
Method Summary
boolean | getIsSelected()
Object | getKey()
Object | getValue()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

key

private final Object key

value

private final Object value

isSelected

private final boolean isSelected
Constructor Detail

ListEntry

public ListEntry(Object key,
                 Object value,
                 boolean isSelected)
Method Detail

getIsSelected

public boolean getIsSelected()

getKey

public Object getKey()

getValue

public Object getValue()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MakeIterator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class MakeIterator

java.lang.Object
    extended by  org.apache.struts2.util.MakeIterator

public class MakeIterator
extends Object

MakeIterator.

Constructor Summary
MakeIterator()
Method Summary
static Iterator | convert(Object value)
static boolean | isIterable(Object object) Determine whether a given object can be made into an Iterator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

MakeIterator

public MakeIterator()
Method Detail

isIterable

public static boolean isIterable(Object object)
Determine whether a given object can be made into an Iterator

Parameters:
object - the object to check
Returns:
true if the object can be converted to an iterator and false otherwise

convert

public static Iterator convert(Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MergeIteratorFilter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class MergeIteratorFilter

java.lang.Object
    extended by  org.apache.struts2.util.IteratorFilterSupport
        extended by  org.apache.struts2.util.MergeIteratorFilter
All Implemented Interfaces:
Action, Iterator
public class MergeIteratorFilter
extends IteratorFilterSupport
implements Iterator, Action

A bean that takes several iterators and outputs the merge of them. Used by MergeIteratorTag.

See Also:
MergeIteratorTag, MergeIterator

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.struts2.util.IteratorFilterSupport
IteratorFilterSupport.EnumerationIterator
Field Summary
(package private) int | idx
(package private) List | iterators
(package private) List | sources
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
MergeIteratorFilter()
Method Summary
String | execute() Where the logic of the action is executed.
boolean | hasNext()
Object | next()
void | remove()
void | setSource(Object anIterator)
Methods inherited from class org.apache.struts2.util.IteratorFilterSupport
getIterator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

iterators

List iterators

sources

List sources

idx

int idx
Constructor Detail

MergeIteratorFilter

public MergeIteratorFilter()
Method Detail

setSource

public void setSource(Object anIterator)

execute

public String execute()
Description copied from interface: Action
Where the logic of the action is executed.

Specified by:
execute in interface Action
Returns:
a string representing the logical result of the execution. See constants in this interface for a list of standard result values.

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrefixTrie (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class PrefixTrie

java.lang.Object
    extended by  org.apache.struts2.util.PrefixTrie

public class PrefixTrie
extends Object

Quickly matches a prefix to an object.

Nested Class Summary
(package private) static class PrefixTrie.Node
Field Summary
(package private) PrefixTrie.Node | root
private static int | SIZE
Constructor Summary
PrefixTrie()
Method Summary
Object | get(String key)
void | put(String prefix, Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SIZE

private static final int SIZE
See Also:
Constant Field Values

root

PrefixTrie.Node root
Constructor Detail

PrefixTrie

public PrefixTrie()
Method Detail

put

public void put(String prefix,
                Object value)

get

public Object get(String key)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PrefixTrie.Node (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class PrefixTrie.Node

java.lang.Object
    extended by  org.apache.struts2.util.PrefixTrie.Node
Enclosing class:
PrefixTrie
static class PrefixTrie.Node
extends Object

Field Summary
(package private) PrefixTrie.Node[] | next
(package private) Object | value
Constructor Summary
PrefixTrie.Node()
Method Summary
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

value

Object value

next

PrefixTrie.Node[] next
Constructor Detail

PrefixTrie.Node

PrefixTrie.Node()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Sorter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class Sorter

java.lang.Object
    extended by  org.apache.struts2.util.Sorter

public class Sorter
extends Object

Sorters. Utility sorters for use with the "sort" tag.

See Also:
SortIteratorTag, SortIteratorFilter

Constructor Summary
Sorter()
Method Summary
Comparator | getAscending()
Comparator | getAscending(String anExpression)
Comparator | getComparator(String anExpression, boolean ascending)
Comparator | getDescending()
Comparator | getDescending(String anExpression)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Sorter

public Sorter()
Method Detail

getAscending

public Comparator getAscending()

getAscending

public Comparator getAscending(String anExpression)

getComparator

public Comparator getComparator(String anExpression,
                                boolean ascending)

getDescending

public Comparator getDescending()

getDescending

public Comparator getDescending(String anExpression)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SortIteratorFilter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class SortIteratorFilter

java.lang.Object
    extended by  org.apache.struts2.util.IteratorFilterSupport
        extended by  org.apache.struts2.util.SortIteratorFilter
All Implemented Interfaces:
Action, Iterator
public class SortIteratorFilter
extends IteratorFilterSupport
implements Iterator, Action

A bean that takes a source and comparator then attempt to sort the source utilizing the comparator. It is being used in SortIteratorTag.

See Also:
SortIteratorTag

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.struts2.util.IteratorFilterSupport
IteratorFilterSupport.EnumerationIterator
Field Summary
(package private) Comparator | comparator
(package private) Iterator | iterator
(package private) List | list
(package private) Object | source
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
SortIteratorFilter()
Method Summary
String | execute() Where the logic of the action is executed.
List | getList()
boolean | hasNext()
Object | next()
void | remove()
void | setComparator(Comparator aComparator)
void | setSource(Object anIterator)
Methods inherited from class org.apache.struts2.util.IteratorFilterSupport
getIterator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

comparator

Comparator comparator

iterator

Iterator iterator

list

List list

source

Object source
Constructor Detail

SortIteratorFilter

public SortIteratorFilter()
Method Detail

setComparator

public void setComparator(Comparator aComparator)

getList

public List getList()

setSource

public void setSource(Object anIterator)

execute

public String execute()
Description copied from interface: Action
Where the logic of the action is executed.

Specified by:
execute in interface Action
Returns:
a string representing the logical result of the execution. See constants in this interface for a list of standard result values.

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsTestCaseHelper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class StrutsTestCaseHelper

java.lang.Object
    extended by  org.apache.struts2.util.StrutsTestCaseHelper

public class StrutsTestCaseHelper
extends Object

Generic test setup methods to be used with any unit testing framework.

Constructor Summary
StrutsTestCaseHelper()
Method Summary
static Dispatcher | initDispatcher(Map<String,String> params)
static void | setUp() Sets up the configuration settings, XWork configuration, and message resources
static void | tearDown()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StrutsTestCaseHelper

public StrutsTestCaseHelper()
Method Detail

setUp

public static void setUp()
                  throws Exception
Sets up the configuration settings, XWork configuration, and message resources

Throws:
Exception

initDispatcher

public static Dispatcher initDispatcher(Map<String,String> params)

tearDown

public static void tearDown()
                     throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsTypeConverter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class StrutsTypeConverter

java.lang.Object
    extended by  ognl.DefaultTypeConverter
        extended by  org.apache.struts2.util.StrutsTypeConverter
All Implemented Interfaces:
ognl.TypeConverter
public abstract class StrutsTypeConverter
extends ognl.DefaultTypeConverter

Base class for type converters used in Struts. This class provides two abstract methods that are used to convert both to and from strings -- the critical functionality that is core to Struts's type coversion system.

Type converters do not have to use this class. It is merely a helper base class, although it is recommended that you use this class as it provides the common type conversion contract required for all web-based type conversion.

There's a hook (fall back method) called performFallbackConversion of which could be used to perform some fallback conversion if convertValue method of this failed. By default it just ask its super class (Ognl's DefaultTypeConverter) to do the conversion.

To allow the framework to recognize that a conversion error has occurred, throw an XWorkException or preferable a TypeConversionException.

Constructor Summary
StrutsTypeConverter()
Method Summary
abstract Object | convertFromString(Map context, String[] values, Class toClass) Converts one or more String values to the specified class.
abstract String | convertToString(Map context, Object o) Converts the specified object to a String.
Object | convertValue(Map context, Object o, Class toClass)
protected Object | performFallbackConversion(Map context, Object o, Class toClass) Hook to perform a fallback conversion if every default options failed.
Methods inherited from class ognl.DefaultTypeConverter
convertValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StrutsTypeConverter

public StrutsTypeConverter()
Method Detail

convertValue

public Object convertValue(Map context,
                           Object o,
                           Class toClass)
Overrides:
convertValue in class ognl.DefaultTypeConverter

performFallbackConversion

protected Object performFallbackConversion(Map context,
                                           Object o,
                                           Class toClass)
Hook to perform a fallback conversion if every default options failed. By default this will ask Ognl's DefaultTypeConverter (of which this class extends) to perform the conversion.

Parameters:
context -
o -
toClass -
Returns:
The fallback conversion

convertFromString

public abstract Object convertFromString(Map context,
                                         String[] values,
                                         Class toClass)
Converts one or more String values to the specified class.

Parameters:
context - the action context
values - the String values to be converted, such as those submitted from an HTML form
toClass - the class to convert to
Returns:
the converted object

convertToString

public abstract String convertToString(Map context,
                                       Object o)
Converts the specified object to a String.

Parameters:
context - the action context
o - the object to be converted
Returns:
the converted String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class StrutsUtil

java.lang.Object
    extended by  org.apache.struts2.util.StrutsUtil
Direct Known Subclasses:
VelocityStrutsUtil
public class StrutsUtil
extends Object

Struts base utility class, for use in Velocity and Freemarker templates

Nested Class Summary
(package private) static class | StrutsUtil.ResponseWrapper
(package private) static class | StrutsUtil.ServletOutputStreamWrapper
Field Summary
protected Map | classes
protected static Log | log
protected OgnlTool | ognl
protected HttpServletRequest | request
protected HttpServletResponse | response
protected ValueStack | stack
Constructor Summary
StrutsUtil(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
Object | bean(Object aName)
String | buildUrl(String url)
Object | findString(String name)
Object | findValue(String expression, String className)
String | getContext()
String | getText(String text)
String | htmlEncode(Object obj)
String | include(Object aName)
String | include(Object aName, HttpServletRequest aRequest, HttpServletResponse aResponse) Deprecated. the request and response are stored in this util class, please use include(string)
boolean | isTrue(String expression)
List | makeSelectList(String selectedList, String list, String listKey, String listValue) the selectedList objects are matched to the list.listValue listKey and listValue are optional, and if not provided, the list item is used
int | toInt(long aLong)
long | toLong(int anInt)
long | toLong(String aLong)
String | toString(int anInt)
String | toString(long aLong)
String | urlEncode(String s)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

protected static final Log log

request

protected HttpServletRequest request

response

protected HttpServletResponse response

classes

protected Map classes

ognl

protected OgnlTool ognl

stack

protected ValueStack stack
Constructor Detail

StrutsUtil

public StrutsUtil(ValueStack stack,
                  HttpServletRequest request,
                  HttpServletResponse response)
Method Detail

bean

public Object bean(Object aName)
            throws Exception
Throws:
Exception

isTrue

public boolean isTrue(String expression)

findString

public Object findString(String name)

include

public String include(Object aName)
               throws Exception
Throws:
Exception

include

public String include(Object aName,
                      HttpServletRequest aRequest,
                      HttpServletResponse aResponse)
               throws Exception
Deprecated. the request and response are stored in this util class, please use include(string)

Throws:
Exception

urlEncode

public String urlEncode(String s)

buildUrl

public String buildUrl(String url)

findValue

public Object findValue(String expression,
                        String className)
                 throws ClassNotFoundException
Throws:
ClassNotFoundException

getText

public String getText(String text)

getContext

public String getContext()

makeSelectList

public List makeSelectList(String selectedList,
                           String list,
                           String listKey,
                           String listValue)
the selectedList objects are matched to the list.listValue

listKey and listValue are optional, and if not provided, the list item is used

Parameters:
selectedList - the name of the action property that contains the list of selected items or single item if its not an array or list
list - the name of the action property that contains the list of selectable items
listKey - an ognl expression that is exaluated relative to the list item to use as the key of the ListEntry
listValue - an ognl expression that is exaluated relative to the list item to use as the value of the ListEntry
Returns:
a List of ListEntry

htmlEncode

public String htmlEncode(Object obj)

toInt

public int toInt(long aLong)

toLong

public long toLong(int anInt)

toLong

public long toLong(String aLong)

toString

public String toString(long aLong)

toString

public String toString(int anInt)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsUtil.ResponseWrapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class StrutsUtil.ResponseWrapper

java.lang.Object
    extended by  javax.servlet.ServletResponseWrapper
        extended by  javax.servlet.http.HttpServletResponseWrapper
            extended by  org.apache.struts2.util.StrutsUtil.ResponseWrapper
All Implemented Interfaces:
HttpServletResponse, ServletResponse
Enclosing class:
StrutsUtil
static class StrutsUtil.ResponseWrapper
extends HttpServletResponseWrapper

Field Summary
(package private) ServletOutputStream | sout
(package private) StringWriter | strout
(package private) PrintWriter | writer
Fields inherited from interface javax.servlet.http.HttpServletResponse
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_FOUND, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
Constructor Summary
StrutsUtil.ResponseWrapper(HttpServletResponse aResponse)
Method Summary
String | getData()
ServletOutputStream | getOutputStream()
PrintWriter | getWriter()
Methods inherited from class javax.servlet.http.HttpServletResponseWrapper
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus
Methods inherited from class javax.servlet.ServletResponseWrapper
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, getResponse, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale, setResponse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.ServletResponse
flushBuffer, getBufferSize, getCharacterEncoding, getContentType, getLocale, isCommitted, reset, resetBuffer, setBufferSize, setCharacterEncoding, setContentLength, setContentType, setLocale

Field Detail

strout

StringWriter strout

writer

PrintWriter writer

sout

ServletOutputStream sout
Constructor Detail

StrutsUtil.ResponseWrapper

StrutsUtil.ResponseWrapper(HttpServletResponse aResponse)
Method Detail

getData

public String getData()

getOutputStream

public ServletOutputStream getOutputStream()
Specified by:
getOutputStream in interface ServletResponse
Overrides:
getOutputStream in class ServletResponseWrapper

getWriter

public PrintWriter getWriter()
                      throws IOException
Specified by:
getWriter in interface ServletResponse
Overrides:
getWriter in class ServletResponseWrapper
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsUtil.ServletOutputStreamWrapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class StrutsUtil.ServletOutputStreamWrapper

java.lang.Object
    extended by  java.io.OutputStream
        extended by  javax.servlet.ServletOutputStream
            extended by  org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper
All Implemented Interfaces:
Closeable, Flushable
Enclosing class:
StrutsUtil
static class StrutsUtil.ServletOutputStreamWrapper
extends ServletOutputStream

Field Summary
(package private)  StringWriter writer
Constructor Summary
StrutsUtil.ServletOutputStreamWrapper(StringWriter aWriter)
Method Summary
 void write(int aByte)
Methods inherited from class javax.servlet.ServletOutputStream
print, print, print, print, print, print, print, println, println, println, println, println, println, println, println
Methods inherited from class java.io.OutputStream
close, flush, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

writer

StringWriter writer
Constructor Detail

StrutsUtil.ServletOutputStreamWrapper

StrutsUtil.ServletOutputStreamWrapper(StringWriter aWriter)
Method Detail

write

public void write(int aByte)
Specified by:
write in class OutputStream
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubsetIteratorFilter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class SubsetIteratorFilter

java.lang.Object
    extended by  org.apache.struts2.util.IteratorFilterSupport
        extended by  org.apache.struts2.util.SubsetIteratorFilter
All Implemented Interfaces:
Action, Iterator
public class SubsetIteratorFilter
extends IteratorFilterSupport
implements Iterator, Action

A bean that takes an iterator and outputs a subset of it.

Nested Class Summary
static interface SubsetIteratorFilter.Decider
A decider determines if the given element should be added to the list or not.
Nested classes/interfaces inherited from class org.apache.struts2.util.IteratorFilterSupport
IteratorFilterSupport.EnumerationIterator
Field Summary
private static Log | _log
(package private) int | count
(package private) int | currentCount
(package private) SubsetIteratorFilter.Decider | decider
(package private) Iterator | iterator
(package private) Object | source
(package private) int | start
Fields inherited from interface com.opensymphony.xwork2.Action
ERROR, INPUT, LOGIN, NONE, SUCCESS
Constructor Summary
SubsetIteratorFilter()
Method Summary
protected boolean | decide(Object element)
String | execute() Where the logic of the action is executed.
boolean | hasNext()
Object | next()
void | remove()
void | setCount(int aCount)
void | setDecider(SubsetIteratorFilter.Decider aDecider)
void | setSource(Object anIterator)
void | setStart(int aStart)
Methods inherited from class org.apache.struts2.util.IteratorFilterSupport
getIterator
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

_log

private static final Log _log

iterator

Iterator iterator

source

Object source

count

int count

currentCount

int currentCount

decider

SubsetIteratorFilter.Decider decider

start

int start
Constructor Detail

SubsetIteratorFilter

public SubsetIteratorFilter()
Method Detail

setCount

public void setCount(int aCount)

setSource

public void setSource(Object anIterator)

setStart

public void setStart(int aStart)

setDecider

public void setDecider(SubsetIteratorFilter.Decider aDecider)

execute

public String execute()
Description copied from interface: Action
Where the logic of the action is executed.

Specified by:
execute in interface Action
Returns:
a string representing the logical result of the execution. See constants in this interface for a list of standard result values.

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator

decide

protected boolean decide(Object element)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubsetIteratorFilter.Decider (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Interface SubsetIteratorFilter.Decider

Enclosing class:
SubsetIteratorFilter
public static interface SubsetIteratorFilter.Decider

A decider determines if the given element should be added to the list or not.

Method Summary
 boolean decide(Object element)
Should the object be added to the list?

Method Detail

decide

boolean decide(Object element)
               throws Exception
Should the object be added to the list?

Parameters:
element - the object
Returns:
true to add.
Throws:
Exception - can be thrown.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabbedPane (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class TabbedPane

java.lang.Object
    extended by  org.apache.struts2.util.TabbedPane

public class TabbedPane
extends Object

A bean that helps implement a tabbed pane

Field Summary
protected Vector | content
protected int | selectedIndex
protected String | tabAlign
Constructor Summary
TabbedPane(int defaultIndex)
Method Summary
Vector | getContent()
int | getSelectedIndex()
String | getTabAlign()
void | setContent(Vector content)
void | setSelectedIndex(int selectedIndex)
void | setTabAlign(String tabAlign)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

tabAlign

protected String tabAlign

content

protected Vector content

selectedIndex

protected int selectedIndex
Constructor Detail

TabbedPane

public TabbedPane(int defaultIndex)
Method Detail

setContent

public void setContent(Vector content)

getContent

public Vector getContent()

setSelectedIndex

public void setSelectedIndex(int selectedIndex)

getSelectedIndex

public int getSelectedIndex()

setTabAlign

public void setTabAlign(String tabAlign)

getTabAlign

public String getTabAlign()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Timer (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class Timer

java.lang.Object
    extended by  org.apache.struts2.util.Timer

public class Timer
extends Object

A bean that can be used to time execution of pages

Field Summary
(package private) long | current
(package private) long | start
Constructor Summary
Timer()
Method Summary
long | getTime()
long | getTotal()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

current

long current

start

long start
Constructor Detail

Timer

public Timer()
Method Detail

getTime

public long getTime()

getTotal

public long getTotal()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TokenHelper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class TokenHelper

java.lang.Object
    extended by  org.apache.struts2.util.TokenHelper

public class TokenHelper
extends Object

TokenHelper

Field Summary
static String | DEFAULT_TOKEN_NAME The default name to map the token value
private static Log | LOG
private static Random | RANDOM
static String | TOKEN_NAME_FIELD The name of the field which will hold the token name
Constructor Summary
TokenHelper()
Method Summary
static String | generateGUID()
static String | getToken() Gets a transaction token into the session using the default token name.
static String | getToken(String tokenName) Gets the Token value from the params in the ServletActionContext using the given name
static String | getTokenName() Gets the token name from the Parameters in the ServletActionContext
static String | setToken() Sets a transaction token into the session using the default token name.
static String | setToken(String tokenName) Sets a transaction token into the session using the provided token name.
static boolean | validToken() Checks for a valid transaction token in the current request params.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_TOKEN_NAME

public static final String DEFAULT_TOKEN_NAME
The default name to map the token value

See Also:
Constant Field Values

TOKEN_NAME_FIELD

public static final String TOKEN_NAME_FIELD
The name of the field which will hold the token name

See Also:
Constant Field Values

LOG

private static final Log LOG

RANDOM

private static final Random RANDOM
Constructor Detail

TokenHelper

public TokenHelper()
Method Detail

setToken

public static String setToken()
Sets a transaction token into the session using the default token name.

Returns:
the token string

setToken

public static String setToken(String tokenName)
Sets a transaction token into the session using the provided token name.

Parameters:
tokenName - the name to store into the session with the token as the value
Returns:
the token string

getToken

public static String getToken()
Gets a transaction token into the session using the default token name.

Returns:
token

getToken

public static String getToken(String tokenName)
Gets the Token value from the params in the ServletActionContext using the given name

Parameters:
tokenName - the name of the parameter which holds the token value
Returns:
the token String or null, if the token could not be found

getTokenName

public static String getTokenName()
Gets the token name from the Parameters in the ServletActionContext

Returns:
the token name found in the params, or null if it could not be found

validToken

public static boolean validToken()
Checks for a valid transaction token in the current request params. If a valid token is found, it is removed so the it is not valid again.

Returns:
false if there was no token set into the params (check by looking for TOKEN_NAME_FIELD), true if a valid token is found

generateGUID

public static String generateGUID()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLBean (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class URLBean

java.lang.Object
    extended by  org.apache.struts2.util.URLBean

public class URLBean
extends Object

A bean that can generate a URL.

Field Summary
(package private) String | page
(package private) HashMap | params
(package private) HttpServletRequest | request
(package private) HttpServletResponse | response
Constructor Summary
URLBean()
Method Summary
URLBean | addParameter(String name, Object value)
String | getURL()
URLBean | setPage(String page)
void | setRequest(HttpServletRequest request)
void | setResponse(HttpServletResponse response)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

params

HashMap params

request

HttpServletRequest request

response

HttpServletResponse response

page

String page
Constructor Detail

URLBean

public URLBean()
Method Detail

setPage

public URLBean setPage(String page)

setRequest

public void setRequest(HttpServletRequest request)

setResponse

public void setResponse(HttpServletResponse response)

getURL

public String getURL()

addParameter

public URLBean addParameter(String name,
                            Object value)

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VelocityStrutsUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.util
Class VelocityStrutsUtil

java.lang.Object
    extended by  org.apache.struts2.util.StrutsUtil
        extended by  org.apache.struts2.util.VelocityStrutsUtil

public class VelocityStrutsUtil
extends StrutsUtil

Struts velocity related util.

Nested Class Summary
Nested classes/interfaces inherited from class org.apache.struts2.util.StrutsUtil
StrutsUtil.ResponseWrapper, StrutsUtil.ServletOutputStreamWrapper
Field Summary
private org.apache.velocity.context.Context | ctx
private org.apache.velocity.app.VelocityEngine | velocityEngine
Fields inherited from class org.apache.struts2.util.StrutsUtil
classes, log, ognl, request, response, stack
Constructor Summary
VelocityStrutsUtil(org.apache.velocity.app.VelocityEngine engine, org.apache.velocity.context.Context ctx, ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Method Summary
 String evaluate(String expression)
Methods inherited from class org.apache.struts2.util.StrutsUtil
bean, buildUrl, findString, findValue, getContext, getText, htmlEncode, include, include, isTrue, makeSelectList, toInt, toLong, toLong, toString, toString, urlEncode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ctx

private org.apache.velocity.context.Context ctx

velocityEngine

private org.apache.velocity.app.VelocityEngine velocityEngine
Constructor Detail

VelocityStrutsUtil

public VelocityStrutsUtil(org.apache.velocity.app.VelocityEngine engine,
                          org.apache.velocity.context.Context ctx,
                          ValueStack stack,
                          HttpServletRequest request,
                          HttpServletResponse response)
Method Detail

evaluate

public String evaluate(String expression)
                throws IOException,
                       org.apache.velocity.exception.ResourceNotFoundException,
                       org.apache.velocity.exception.MethodInvocationException,
                       org.apache.velocity.exception.ParseErrorException
Throws:
IOException
org.apache.velocity.exception.ResourceNotFoundException
org.apache.velocity.exception.MethodInvocationException
org.apache.velocity.exception.ParseErrorException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.validators (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.validators

Class Summary
DWRValidator | Use the dwr configuration as follows :-
DWRValidator.ValidatorActionInvocation |
DWRValidator.ValidatorActionProxy |


org.apache.struts2.validators Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.validators

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • com.opensymphony.xwork2.DefaultActionInvocation (implements com.opensymphony.xwork2.ActionInvocation)
      • org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation
    • com.opensymphony.xwork2.DefaultActionProxy (implements com.opensymphony.xwork2.ActionProxy, java.io.Serializable)
      • org.apache.struts2.validators.DWRValidator.ValidatorActionProxy
    • org.apache.struts2.validators.DWRValidator


Uses of Package org.apache.struts2.validators (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.validators

No usage of org.apache.struts2.validators

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DWRValidator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.validators
Class DWRValidator

java.lang.Object
    extended by  org.apache.struts2.validators.DWRValidator

public class DWRValidator
extends Object

Use the dwr configuration as follows :-

 <dwr<
    <allow<
      <create creator="new" javascript="validator" class="org.apache.struts2.validators.DWRValidator"/<
      <convert converter="bean" match="com.opensymphony.xwork2.ValidationAwareSupport"/<
    </allow<
 </dwr<

Nested Class Summary
static class | DWRValidator.ValidatorActionInvocation
static class | DWRValidator.ValidatorActionProxy
Field Summary
private static Log LOG
Constructor Summary
DWRValidator()
Method Summary
 ValidationAwareSupport doPost(String namespace, String action, Map params)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG
Constructor Detail

DWRValidator

public DWRValidator()
Method Detail

doPost

public ValidationAwareSupport doPost(String namespace,
                                     String action,
                                     Map params)
                              throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DWRValidator.ValidatorActionInvocation (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.validators
Class DWRValidator.ValidatorActionInvocation

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionInvocation
        extended by  org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation
All Implemented Interfaces:
ActionInvocation, Serializable
Enclosing class:
DWRValidator
public static class DWRValidator.ValidatorActionInvocation
extends DefaultActionInvocation

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class com.opensymphony.xwork2.DefaultActionInvocation
action, actionEventListener, executed, extraContext, interceptors, invocationContext, objectFactory, preResultListeners, proxy, pushAction, result, resultCode, stack, unknownHandler
Constructor Summary
protected DWRValidator.ValidatorActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext)
Method Summary
protected  String invokeAction(Object action, ActionConfig actionConfig)
Methods inherited from class com.opensymphony.xwork2.DefaultActionInvocation
addPreResultListener, createAction, createContextMap, createResult, getAction, getInvocationContext, getProxy, getResult, getResultCode, getStack, invoke, invokeActionOnly, isExecuted, setActionEventListener, setResultCode
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

DWRValidator.ValidatorActionInvocation

protected DWRValidator.ValidatorActionInvocation(ObjectFactory objectFactory,
                                                 UnknownHandler handler,
                                                 ActionProxy proxy,
                                                 Map extraContext)
                                          throws Exception
Throws:
Exception
Method Detail

invokeAction

protected String invokeAction(Object action,
                              ActionConfig actionConfig)
                       throws Exception
Overrides:
invokeAction in class DefaultActionInvocation
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DWRValidator.ValidatorActionProxy (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.validators
Class DWRValidator.ValidatorActionProxy

java.lang.Object
    extended by  com.opensymphony.xwork2.DefaultActionProxy
        extended by  org.apache.struts2.validators.DWRValidator.ValidatorActionProxy
All Implemented Interfaces:
ActionProxy, Serializable
Enclosing class:
DWRValidator
public static class DWRValidator.ValidatorActionProxy
extends DefaultActionProxy

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class com.opensymphony.xwork2.DefaultActionProxy
actionEventListener, actionName, cleanupContext, config, configuration, executeResult, extraContext, invocation, method, namespace, objectFactory, unknownHandler
Constructor Summary
protected DWRValidator.ValidatorActionProxy(String namespace, String actionName, Map extraContext)
Method Summary
 void prepare()
Called after all dependencies are set
Methods inherited from class com.opensymphony.xwork2.DefaultActionProxy
execute, getAction, getActionName, getConfig, getExecuteResult, getInvocation, getMethod, getNamespace, setActionEventListener, setConfiguration, setExecuteResult, setMethod, setObjectFactory, setUnknownHandler
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

DWRValidator.ValidatorActionProxy

protected DWRValidator.ValidatorActionProxy(String namespace,
                                            String actionName,
                                            Map extraContext)
                                     throws Exception
Throws:
Exception
Method Detail

prepare

public void prepare()
             throws Exception
Description copied from interface: ActionProxy
Called after all dependencies are set

Specified by:
prepare in interface ActionProxy
Overrides:
prepare in class DefaultActionProxy
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views

Interface Summary
TagLibrary Provides Velocity and Freemarker implementation classes for a tag library

Class Summary
DefaultTagLibrary | The default Struts tag library
JspSupportServlet |


org.apache.struts2.views Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.views.DefaultTagLibrary (implements org.apache.struts2.views.TagLibrary)
    • javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • org.apache.struts2.views.JspSupportServlet

Interface Hierarchy

  • org.apache.struts2.views.TagLibrary


Uses of Package org.apache.struts2.views (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views

Packages that use org.apache.struts2.views
org.apache.struts2.views |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.velocity | Classes for views using Velocity.

Classes in org.apache.struts2.views used by org.apache.struts2.views
JspSupportServlet
TagLibrary
Provides Velocity and Freemarker implementation classes for a tag library

Classes in org.apache.struts2.views used by org.apache.struts2.views.freemarker
TagLibrary
Provides Velocity and Freemarker implementation classes for a tag library

Classes in org.apache.struts2.views used by org.apache.struts2.views.velocity
TagLibrary
Provides Velocity and Freemarker implementation classes for a tag library

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


TagLibrary (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views
Interface TagLibrary

All Known Implementing Classes:
DefaultTagLibrary
public interface TagLibrary

Provides Velocity and Freemarker implementation classes for a tag library

Method Summary
Object | getFreemarkerModels(ValueStack stack, HttpServletRequest req, HttpServletResponse res) Gets a Java object that contains getters for the tag library's Freemarker models.
List<Class> | getVelocityDirectiveClasses() Gets a list of Velocity directive classes for the tag library.

Method Detail

getFreemarkerModels

Object getFreemarkerModels(ValueStack stack,
                           HttpServletRequest req,
                           HttpServletResponse res)
Gets a Java object that contains getters for the tag library's Freemarker models. Called once per Freemarker template processing.

Parameters:
stack - The current value stack
req - The HTTP request
res - The HTTP response
Returns:
The Java object containing the Freemarker model getter methods

getVelocityDirectiveClasses

List<Class> getVelocityDirectiveClasses()
Gets a list of Velocity directive classes for the tag library. Called once on framework startup when initializing Velocity.

Returns:
A list of Velocity directive classes
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DefaultTagLibrary (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views
Class DefaultTagLibrary

java.lang.Object
    extended by  org.apache.struts2.views.DefaultTagLibrary
All Implemented Interfaces:
TagLibrary
public class DefaultTagLibrary
extends Object
implements TagLibrary

The default Struts tag library

Constructor Summary
DefaultTagLibrary()
Method Summary
Object | getFreemarkerModels(ValueStack stack, HttpServletRequest req, HttpServletResponse res) Gets a Java object that contains getters for the tag library's Freemarker models.
List<Class> | getVelocityDirectiveClasses() Gets a list of Velocity directive classes for the tag library.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultTagLibrary

public DefaultTagLibrary()
Method Detail

getFreemarkerModels

public Object getFreemarkerModels(ValueStack stack,
                                  HttpServletRequest req,
                                  HttpServletResponse res)
Description copied from interface: TagLibrary
Gets a Java object that contains getters for the tag library's Freemarker models. Called once per Freemarker template processing.

Specified by:
getFreemarkerModels in interface TagLibrary
Parameters:
stack - The current value stack
req - The HTTP request
res - The HTTP response
Returns:
The Java object containing the Freemarker model getter methods

getVelocityDirectiveClasses

public List<Class> getVelocityDirectiveClasses()
Description copied from interface: TagLibrary
Gets a list of Velocity directive classes for the tag library. Called once on framework startup when initializing Velocity.

Specified by:
getVelocityDirectiveClasses in interface TagLibrary
Returns:
A list of Velocity directive classes
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JspSupportServlet (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views
Class JspSupportServlet

java.lang.Object
    extended by  javax.servlet.GenericServlet
        extended by  javax.servlet.http.HttpServlet
            extended by  org.apache.struts2.views.JspSupportServlet
All Implemented Interfaces:
Serializable, Servlet, ServletConfig
public class JspSupportServlet
extends HttpServlet

See Also:
Serialized Form

Field Summary
static JspSupportServlet | jspSupportServlet
private static long | serialVersionUID
Constructor Summary
JspSupportServlet()
Method Summary
 void init(ServletConfig servletConfig)
Methods inherited from class javax.servlet.http.HttpServlet
doDelete, doGet, doHead, doOptions, doPost, doPut, doTrace, getLastModified, service, service
Methods inherited from class javax.servlet.GenericServlet
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

jspSupportServlet

public static JspSupportServlet jspSupportServlet
Constructor Detail

JspSupportServlet

public JspSupportServlet()
Method Detail

init

public void init(ServletConfig servletConfig)
          throws ServletException
Specified by:
init in interface Servlet
Overrides:
init in class GenericServlet
Throws:
ServletException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.annotations (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.annotations

Annotation Types Summary
StrutsTag | An annotation to document a Struts jsp/freemarker/velocity tag
StrutsTagAttribute | Documents an attribute to a Struts tag


org.apache.struts2.views.annotations Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.annotations

Package Hierarchies:
All Packages

Annotation Type Hierarchy

  • org.apache.struts2.views.annotations.StrutsTagAttribute (implements java.lang.annotation.Annotation)
  • org.apache.struts2.views.annotations.StrutsTag (implements java.lang.annotation.Annotation)


Uses of Package org.apache.struts2.views.annotations (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.annotations

Packages that use org.apache.struts2.views.annotations
org.apache.struts2.components |
org.apache.struts2.components.table |
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.

Classes in org.apache.struts2.views.annotations used by org.apache.struts2.components
StrutsTag
An annotation to document a Struts jsp/freemarker/velocity tag
StrutsTagAttribute
Documents an attribute to a Struts tag

Classes in org.apache.struts2.views.annotations used by org.apache.struts2.components.table
StrutsTag
An annotation to document a Struts jsp/freemarker/velocity tag
StrutsTagAttribute
Documents an attribute to a Struts tag

Classes in org.apache.struts2.views.annotations used by org.apache.struts2.views.jsp.iterator
StrutsTag
An annotation to document a Struts jsp/freemarker/velocity tag
StrutsTagAttribute
Documents an attribute to a Struts tag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


StrutsTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

org.apache.struts2.views.annotations
Annotation Type StrutsTag

@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface StrutsTag

An annotation to document a Struts jsp/freemarker/velocity tag

Required Element Summary
String | description
String | name
String | tldTagClass
Optional Element Summary
 String tldBodyContent

Element Detail

name

public abstract String name

tldTagClass

public abstract String tldTagClass

description

public abstract String description

tldBodyContent

public abstract String tldBodyContent
Default:
"JSP"
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


StrutsTagAttribute (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT

org.apache.struts2.views.annotations
Annotation Type StrutsTagAttribute

@Target(value=METHOD)
@Retention(value=RUNTIME)
public @interface StrutsTagAttribute

Documents an attribute to a Struts tag

Required Element Summary
 String description
Optional Element Summary
String | defaultValue
String | name
boolean | required
boolean | rtexprvalue
String | type

Element Detail

description

public abstract String description

name

public abstract String name
Default:
""

required

public abstract boolean required
Default:
false

rtexprvalue

public abstract boolean rtexprvalue
Default:
true

defaultValue

public abstract String defaultValue
Default:
""

type

public abstract String type
Default:
"String"
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: REQUIRED | OPTIONAL | DETAIL: ELEMENT


org.apache.struts2.views.freemarker (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.freemarker

Classes for views using FreeMarker.

See:
Description

Class Summary
FreemarkerManager | Static Configuration Manager for the FreemarkerResult's configuration Possible extension points are :- createConfiguration method loadSettings method getTemplateLoader method populateContext method createConfiguration method Create a freemarker Configuration.
FreemarkerResult | Renders a view using the Freemarker template engine.
PortletFreemarkerResult |
ScopesHashModel | Simple Hash model that also searches other scopes.
StrutsBeanWrapper | The StrutsBeanWrapper extends the default FreeMarker BeansWrapper and provides almost no change in functionality, except for how it handles maps.
StrutsBeanWrapper.FriendlyMapModel | Attempting to get the best of both worlds of FM's MapModel and SimpleMapModel, by reimplementing the isEmpty(), keySet() and values() methods.
StrutsClassTemplateLoader |

Package org.apache.struts2.views.freemarker Description

Classes for views using FreeMarker.


org.apache.struts2.views.freemarker Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.freemarker

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • freemarker.ext.beans.BeanModel (implements freemarker.template.AdapterTemplateModel, freemarker.template.TemplateHashModelEx, freemarker.ext.util.WrapperTemplateModel)
      • freemarker.ext.beans.StringModel (implements freemarker.template.TemplateScalarModel)
        • freemarker.ext.beans.MapModel (implements freemarker.template.TemplateMethodModelEx)
          • org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel (implements freemarker.template.TemplateHashModelEx)
    • freemarker.ext.beans.BeansWrapper (implements freemarker.template.ObjectWrapper)
      • org.apache.struts2.views.freemarker.StrutsBeanWrapper
    • org.apache.struts2.views.freemarker.FreemarkerManager
    • org.apache.struts2.dispatcher.StrutsResultSupport (implements com.opensymphony.xwork2.Result, org.apache.struts2.StrutsStatics)
      • org.apache.struts2.views.freemarker.FreemarkerResult
      • org.apache.struts2.views.freemarker.PortletFreemarkerResult
    • freemarker.cache.URLTemplateLoader (implements freemarker.cache.TemplateLoader)
      • org.apache.struts2.views.freemarker.StrutsClassTemplateLoader
    • freemarker.template.WrappingTemplateModel
      • freemarker.template.SimpleHash (implements java.io.Serializable, freemarker.template.TemplateHashModelEx)
        • org.apache.struts2.views.freemarker.ScopesHashModel


Uses of Package org.apache.struts2.views.freemarker (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.freemarker

Packages that use org.apache.struts2.views.freemarker
org.apache.struts2.components.template |
org.apache.struts2.interceptor.debugging |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.

Classes in org.apache.struts2.views.freemarker used by org.apache.struts2.components.template
FreemarkerManager
Static Configuration Manager for the FreemarkerResult's configuration

Possible extension points are :- createConfiguration method loadSettings method getTemplateLoader method populateContext method

createConfiguration method
Create a freemarker Configuration.

Classes in org.apache.struts2.views.freemarker used by org.apache.struts2.interceptor.debugging
FreemarkerManager
Static Configuration Manager for the FreemarkerResult's configuration

Possible extension points are :- createConfiguration method loadSettings method getTemplateLoader method populateContext method

createConfiguration method
Create a freemarker Configuration.

Classes in org.apache.struts2.views.freemarker used by org.apache.struts2.views.freemarker
FreemarkerManager
Static Configuration Manager for the FreemarkerResult's configuration

Possible extension points are :- createConfiguration method loadSettings method getTemplateLoader method populateContext method

createConfiguration method
Create a freemarker Configuration.

ScopesHashModel
Simple Hash model that also searches other scopes.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


FreemarkerManager (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker
Class FreemarkerManager

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.FreemarkerManager

public class FreemarkerManager
extends Object

Static Configuration Manager for the FreemarkerResult's configuration

Possible extension points are :-

  • createConfiguration method
  • loadSettings method
  • getTemplateLoader method
  • populateContext method

createConfiguration method
Create a freemarker Configuration.

loadSettings method
Load freemarker settings, default to freemarker.properties (if found in classpath)

getTemplateLoader method
create a freemarker TemplateLoader that loads freemarker template in the following order :-

  1. path defined in ServletContext init parameter named 'templatePath' or 'TemplatePath' (must be an absolute path)
  2. webapp classpath
  3. struts's static folder (under [STRUT2_SOURCE]/org/apache/struts2/static/

populateContext method
populate the created model.

Field Summary
private boolean | altMapWrapper
private static String | ATTR_APPLICATION_MODEL
private static String | ATTR_JSP_TAGLIBS_MODEL
private static String | ATTR_REQUEST_MODEL
private static String | ATTR_REQUEST_PARAMETERS_MODEL
static String | CONFIG_SERVLET_CONTEXT_KEY
private String | encoding
static String | KEY_APPLICATION
static String | KEY_EXCEPTION
static String | KEY_JSP_TAGLIBS
static String | KEY_REQUEST_MODEL
static String | KEY_REQUEST_PARAMETER_MODEL
static String | KEY_SESSION_MODEL
private static Log | log
private Map<String,TagLibrary> | tagLibraries
Constructor Summary
FreemarkerManager()
Method Summary
protected ScopesHashModel | buildScopesHashModel(ServletContext servletContext, HttpServletRequest request, HttpServletResponse response, freemarker.template.ObjectWrapper wrapper, ValueStack stack)
freemarker.template.SimpleHash | buildTemplateModel(ValueStack stack, Object action, ServletContext servletContext, HttpServletRequest request, HttpServletResponse response, freemarker.template.ObjectWrapper wrapper)
protected freemarker.template.Configuration | createConfiguration(ServletContext servletContext) Create the instance of the freemarker Configuration object.
freemarker.template.Configuration | getConfiguration(ServletContext servletContext)
protected freemarker.ext.beans.BeansWrapper | getObjectWrapper()
protected freemarker.cache.TemplateLoader | getTemplateLoader(ServletContext servletContext) The default template loader is a MultiTemplateLoader which includes a ClassTemplateLoader and a WebappTemplateLoader (and a FileTemplateLoader depending on the init-parameter 'TemplatePath').
protected void | loadSettings(ServletContext servletContext, freemarker.template.Configuration configuration) Load the settings from the /freemarker.properties file on the classpath
protected void | populateContext(ScopesHashModel model, ValueStack stack, Object action, HttpServletRequest request, HttpServletResponse response)
void | setContainer(Container container)
void | setEncoding(String encoding)
void | setWrapperAltMap(String val)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

CONFIG_SERVLET_CONTEXT_KEY

public static final String CONFIG_SERVLET_CONTEXT_KEY
See Also:
Constant Field Values

KEY_EXCEPTION

public static final String KEY_EXCEPTION
See Also:
Constant Field Values

ATTR_APPLICATION_MODEL

private static final String ATTR_APPLICATION_MODEL
See Also:
Constant Field Values

ATTR_JSP_TAGLIBS_MODEL

private static final String ATTR_JSP_TAGLIBS_MODEL
See Also:
Constant Field Values

ATTR_REQUEST_MODEL

private static final String ATTR_REQUEST_MODEL
See Also:
Constant Field Values

ATTR_REQUEST_PARAMETERS_MODEL

private static final String ATTR_REQUEST_PARAMETERS_MODEL
See Also:
Constant Field Values

KEY_APPLICATION

public static final String KEY_APPLICATION
See Also:
Constant Field Values

KEY_REQUEST_MODEL

public static final String KEY_REQUEST_MODEL
See Also:
Constant Field Values

KEY_SESSION_MODEL

public static final String KEY_SESSION_MODEL
See Also:
Constant Field Values

KEY_JSP_TAGLIBS

public static final String KEY_JSP_TAGLIBS
See Also:
Constant Field Values

KEY_REQUEST_PARAMETER_MODEL

public static final String KEY_REQUEST_PARAMETER_MODEL
See Also:
Constant Field Values

encoding

private String encoding

altMapWrapper

private boolean altMapWrapper

tagLibraries

private Map<String,TagLibrary> tagLibraries
Constructor Detail

FreemarkerManager

public FreemarkerManager()
Method Detail

setEncoding

public void setEncoding(String encoding)

setWrapperAltMap

public void setWrapperAltMap(String val)

setContainer

public void setContainer(Container container)

getConfiguration

public final freemarker.template.Configuration getConfiguration(ServletContext servletContext)
                                                         throws freemarker.template.TemplateException
Throws:
freemarker.template.TemplateException

buildScopesHashModel

protected ScopesHashModel buildScopesHashModel(ServletContext servletContext,
                                               HttpServletRequest request,
                                               HttpServletResponse response,
                                               freemarker.template.ObjectWrapper wrapper,
                                               ValueStack stack)

populateContext

protected void populateContext(ScopesHashModel model,
                               ValueStack stack,
                               Object action,
                               HttpServletRequest request,
                               HttpServletResponse response)

getObjectWrapper

protected freemarker.ext.beans.BeansWrapper getObjectWrapper()

getTemplateLoader

protected freemarker.cache.TemplateLoader getTemplateLoader(ServletContext servletContext)
The default template loader is a MultiTemplateLoader which includes a ClassTemplateLoader and a WebappTemplateLoader (and a FileTemplateLoader depending on the init-parameter 'TemplatePath').

The ClassTemplateLoader will resolve fully qualified template includes that begin with a slash. for example /com/company/template/common.ftl

The WebappTemplateLoader attempts to resolve templates relative to the web root folder

createConfiguration

protected freemarker.template.Configuration createConfiguration(ServletContext servletContext)
                                                         throws freemarker.template.TemplateException
Create the instance of the freemarker Configuration object.

this implementation

  • obtains the default configuration from Configuration.getDefaultConfiguration()
  • sets up template loading from a ClassTemplateLoader and a WebappTemplateLoader
  • sets up the object wrapper to be the BeansWrapper
  • loads settings from the classpath file /freemarker.properties

Parameters:
servletContext -
Throws:
freemarker.template.TemplateException

loadSettings

protected void loadSettings(ServletContext servletContext,
                            freemarker.template.Configuration configuration)
Load the settings from the /freemarker.properties file on the classpath

See Also:
for the definition of valid settings

buildTemplateModel

public freemarker.template.SimpleHash buildTemplateModel(ValueStack stack,
                                                         Object action,
                                                         ServletContext servletContext,
                                                         HttpServletRequest request,
                                                         HttpServletResponse response,
                                                         freemarker.template.ObjectWrapper wrapper)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


FreemarkerResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker
Class FreemarkerResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.views.freemarker.FreemarkerResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class FreemarkerResult
extends StrutsResultSupport

Renders a view using the Freemarker template engine.

The FreemarkarManager class configures the template loaders so that the template location can be either

  • relative to the web root folder. eg /WEB-INF/views/home.ftl
  • a classpath resuorce. eg com/company/web/views/home.ftl
This result type takes the following parameters:
  • location (default) - the location of the template to process.
  • parse - true by default. If set to false, the location param will not be parsed for Ognl expressions.
  • contentType - defaults to "text/html" unless specified.
Example:

 <result name="success" type="freemarker">foo.ftl</result>

See Also:
Serialized Form

Field Summary
protected freemarker.template.Configuration | configuration
protected FreemarkerManager | freemarkerManager
protected ActionInvocation | invocation
protected String | location
private String | pContentType
private static long | serialVersionUID
protected freemarker.template.ObjectWrapper | wrapper
private Writer | writer
Fields inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
DEFAULT_PARAM
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
FreemarkerResult()
FreemarkerResult(String location)
Method Summary
protected  freemarker.template.TemplateModel createModel()
Build the instance of the ScopesHashModel, including JspTagLib support

Objects added to the model are

Application - servlet context attributes hash model JspTaglibs - jsp tag lib factory model Request - request attributes hash model Session - session attributes hash model request - the HttpServletRequst object for direct access response - the HttpServletResponse object for direct access stack - the OgnLValueStack instance for direct access ognl - the instance of the OgnlTool action - the action itself exception - optional : the JSP or Servlet exception as per the servlet spec (for JSP Exception pages) struts - instance of the StrutsUtil class

protected  Locale deduceLocale()
Returns the locale used for the Configuration.getTemplate(String, Locale) call.
 void doExecute(String location, ActionInvocation invocation)
Execute this result, using the specified template location.
protected  freemarker.template.Configuration getConfiguration()
This method is called from doExecute(String, ActionInvocation) to obtain the FreeMarker configuration object that this result will use for template loading.
 String getContentType()
allow parameterization of the contentType the default being text/html
protected  freemarker.template.ObjectWrapper getObjectWrapper()
This method is called from doExecute(String, ActionInvocation) to obtain the FreeMarker object wrapper object that this result will use for adapting objects into template models.
protected  Writer getWriter()
The default writer writes directly to the response writer.
protected  void postTemplateProcess(freemarker.template.Template template, freemarker.template.TemplateModel data)
the default implementation of postTemplateProcess applies the contentType parameter
protected  boolean preTemplateProcess(freemarker.template.Template template, freemarker.template.TemplateModel model)
Called before the execution is passed to template.process().
 void setContentType(String aContentType)
 void setFreemarkerManager(FreemarkerManager mgr)
 void setWriter(Writer writer)
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

invocation

protected ActionInvocation invocation

configuration

protected freemarker.template.Configuration configuration

wrapper

protected freemarker.template.ObjectWrapper wrapper

freemarkerManager

protected FreemarkerManager freemarkerManager

writer

private Writer writer

location

protected String location

pContentType

private String pContentType
Constructor Detail

FreemarkerResult

public FreemarkerResult()

FreemarkerResult

public FreemarkerResult(String location)
Method Detail

setFreemarkerManager

public void setFreemarkerManager(FreemarkerManager mgr)

setContentType

public void setContentType(String aContentType)

getContentType

public String getContentType()
allow parameterization of the contentType the default being text/html

doExecute

public void doExecute(String location,
                      ActionInvocation invocation)
               throws IOException,
                      freemarker.template.TemplateException
Execute this result, using the specified template location.

The template location has already been interoplated for any variable substitutions

this method obtains the freemarker configuration and the object wrapper from the provided hooks. It them implements the template processing workflow by calling the hooks for preTemplateProcess and postTemplateProcess

Specified by:
doExecute in class StrutsResultSupport
Parameters:
location - the location (jsp page, action, etc) to go to.
invocation - the execution state of the action.
Throws:
IOException
freemarker.template.TemplateException

getConfiguration

protected freemarker.template.Configuration getConfiguration()
                                                      throws freemarker.template.TemplateException
This method is called from doExecute(String, ActionInvocation) to obtain the FreeMarker configuration object that this result will use for template loading. This is a hook that allows you to custom-configure the configuration object in a subclass, or to fetch it from an IoC container.

The default implementation obtains the configuration from the ConfigurationManager instance.

Throws:
freemarker.template.TemplateException

getObjectWrapper

protected freemarker.template.ObjectWrapper getObjectWrapper()
This method is called from doExecute(String, ActionInvocation) to obtain the FreeMarker object wrapper object that this result will use for adapting objects into template models. This is a hook that allows you to custom-configure the wrapper object in a subclass.

The default implementation returns Configurable.getObjectWrapper()

setWriter

public void setWriter(Writer writer)

getWriter

protected Writer getWriter()
                    throws IOException
The default writer writes directly to the response writer.

Throws:
IOException

createModel

protected freemarker.template.TemplateModel createModel()
                                                 throws freemarker.template.TemplateModelException
Build the instance of the ScopesHashModel, including JspTagLib support

Objects added to the model are

  • Application - servlet context attributes hash model
  • JspTaglibs - jsp tag lib factory model
  • Request - request attributes hash model
  • Session - session attributes hash model
  • request - the HttpServletRequst object for direct access
  • response - the HttpServletResponse object for direct access
  • stack - the OgnLValueStack instance for direct access
  • ognl - the instance of the OgnlTool
  • action - the action itself
  • exception - optional : the JSP or Servlet exception as per the servlet spec (for JSP Exception pages)
  • struts - instance of the StrutsUtil class

Throws:
freemarker.template.TemplateModelException

deduceLocale

protected Locale deduceLocale()
Returns the locale used for the Configuration.getTemplate(String, Locale) call. The base implementation simply returns the locale setting of the action (assuming the action implements LocaleProvider) or, if the action does not the configuration's locale is returned. Override this method to provide different behaviour,

postTemplateProcess

protected void postTemplateProcess(freemarker.template.Template template,
                                   freemarker.template.TemplateModel data)
                            throws IOException
the default implementation of postTemplateProcess applies the contentType parameter

Throws:
IOException

preTemplateProcess

protected boolean preTemplateProcess(freemarker.template.Template template,
                                     freemarker.template.TemplateModel model)
                              throws IOException
Called before the execution is passed to template.process(). This is a generic hook you might use in subclasses to perform a specific action before the template is processed. By default does nothing. A typical action to perform here is to inject application-specific objects into the model root

Returns:
true to process the template, false to suppress template processing.
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PortletFreemarkerResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker
Class PortletFreemarkerResult

java.lang.Object
    extended by  org.apache.struts2.dispatcher.StrutsResultSupport
        extended by  org.apache.struts2.views.freemarker.PortletFreemarkerResult
All Implemented Interfaces:
Result, Serializable, StrutsStatics
public class PortletFreemarkerResult
extends StrutsResultSupport

See Also:
Serialized Form

Field Summary
protected freemarker.template.Configuration | configuration
protected FreemarkerManager | freemarkerManager
protected ActionInvocation | invocation
protected String | location
private String | pContentType
private static long | serialVersionUID
protected freemarker.template.ObjectWrapper | wrapper
Fields inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
DEFAULT_PARAM
Fields inherited from interface org.apache.struts2.StrutsStatics
HTTP_REQUEST, HTTP_RESPONSE, PAGE_CONTEXT, SERVLET_CONTEXT, SERVLET_DISPATCHER, STRUTS_PORTLET_CONTEXT
Constructor Summary
PortletFreemarkerResult()
PortletFreemarkerResult(String location)
Method Summary
protected  freemarker.template.TemplateModel createModel()
Build the instance of the ScopesHashModel, including JspTagLib support

Objects added to the model are

Application - servlet context attributes hash model JspTaglibs - jsp tag lib factory model Request - request attributes hash model Session - session attributes hash model request - the HttpServletRequst object for direct access response - the HttpServletResponse object for direct access stack - the OgnLValueStack instance for direct access ognl - the instance of the OgnlTool action - the action itself exception - optional : the JSP or Servlet exception as per the servlet spec (for JSP Exception pages) struts - instance of the StrutsUtil class

protected  Locale deduceLocale()
Returns the locale used for the Configuration.getTemplate(String, Locale)call.
 void doExecute(String location, ActionInvocation invocation)
Execute this result, using the specified template location.
private  void executeActionResult(String location, ActionInvocation invocation)
private  void executeRenderResult(String location, ActionInvocation invocation)
protected  freemarker.template.Configuration getConfiguration()
This method is called from doExecute(String, ActionInvocation) to obtain the FreeMarker configuration object that this result will use for template loading.
 String getContentType()
allow parameterization of the contentType the default being text/html
protected  freemarker.template.ObjectWrapper getObjectWrapper()
This method is called from doExecute(String, ActionInvocation) to obtain the FreeMarker object wrapper object that this result will use for adapting objects into template models.
protected  Writer getWriter()
The default writer writes directly to the response writer.
protected  void postTemplateProcess(freemarker.template.Template template, freemarker.template.TemplateModel data)
the default implementation of postTemplateProcess applies the contentType parameter
private  void prepareServletActionContext()
protected  boolean preTemplateProcess(freemarker.template.Template template, freemarker.template.TemplateModel model)
Called before the execution is passed to template.process().
 void setContentType(String aContentType)
 void setFreemarkerManager(FreemarkerManager mgr)
Methods inherited from class org.apache.struts2.dispatcher.StrutsResultSupport
conditionalParse, execute, getLastFinalLocation, setEncode, setLocation, setParse
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

invocation

protected ActionInvocation invocation

configuration

protected freemarker.template.Configuration configuration

wrapper

protected freemarker.template.ObjectWrapper wrapper

freemarkerManager

protected FreemarkerManager freemarkerManager

location

protected String location

pContentType

private String pContentType
Constructor Detail

PortletFreemarkerResult

public PortletFreemarkerResult()

PortletFreemarkerResult

public PortletFreemarkerResult(String location)
Method Detail

setFreemarkerManager

public void setFreemarkerManager(FreemarkerManager mgr)

setContentType

public void setContentType(String aContentType)

getContentType

public String getContentType()
allow parameterization of the contentType the default being text/html

doExecute

public void doExecute(String location,
                      ActionInvocation invocation)
               throws IOException,
                      freemarker.template.TemplateException,
                      javax.portlet.PortletException
Execute this result, using the specified template location.

The template location has already been interoplated for any variable substitutions

this method obtains the freemarker configuration and the object wrapper from the provided hooks. It them implements the template processing workflow by calling the hooks for preTemplateProcess and postTemplateProcess

Specified by:
doExecute in class StrutsResultSupport
Parameters:
location - the location (jsp page, action, etc) to go to.
invocation - the execution state of the action.
Throws:
IOException
freemarker.template.TemplateException
javax.portlet.PortletException

executeActionResult

private void executeActionResult(String location,
                                 ActionInvocation invocation)
Parameters:
location -
invocation -

executeRenderResult

private void executeRenderResult(String location,
                                 ActionInvocation invocation)
                          throws freemarker.template.TemplateException,
                                 IOException,
                                 freemarker.template.TemplateModelException,
                                 javax.portlet.PortletException
Parameters:
location -
invocation -
Throws:
freemarker.template.TemplateException
IOException
freemarker.template.TemplateModelException
javax.portlet.PortletException

prepareServletActionContext

private void prepareServletActionContext()
                                  throws javax.portlet.PortletException,
                                         IOException
Throws:
javax.portlet.PortletException
IOException

getConfiguration

protected freemarker.template.Configuration getConfiguration()
                                                      throws freemarker.template.TemplateException
This method is called from doExecute(String, ActionInvocation) to obtain the FreeMarker configuration object that this result will use for template loading. This is a hook that allows you to custom-configure the configuration object in a subclass, or to fetch it from an IoC container.

The default implementation obtains the configuration from the ConfigurationManager instance.

Throws:
freemarker.template.TemplateException

getObjectWrapper

protected freemarker.template.ObjectWrapper getObjectWrapper()
This method is called from doExecute(String, ActionInvocation) to obtain the FreeMarker object wrapper object that this result will use for adapting objects into template models. This is a hook that allows you to custom-configure the wrapper object in a subclass.

The default implementation returns Configurable.getObjectWrapper()

getWriter

protected Writer getWriter()
                    throws IOException
The default writer writes directly to the response writer.

Throws:
IOException

createModel

protected freemarker.template.TemplateModel createModel()
                                                 throws freemarker.template.TemplateModelException
Build the instance of the ScopesHashModel, including JspTagLib support

Objects added to the model are

  • Application - servlet context attributes hash model
  • JspTaglibs - jsp tag lib factory model
  • Request - request attributes hash model
  • Session - session attributes hash model
  • request - the HttpServletRequst object for direct access
  • response - the HttpServletResponse object for direct access
  • stack - the OgnLValueStack instance for direct access
  • ognl - the instance of the OgnlTool
  • action - the action itself
  • exception - optional : the JSP or Servlet exception as per the servlet spec (for JSP Exception pages)
  • struts - instance of the StrutsUtil class

Throws:
freemarker.template.TemplateModelException

deduceLocale

protected Locale deduceLocale()
Returns the locale used for the Configuration.getTemplate(String, Locale)call. The base implementation simply returns the locale setting of the configuration. Override this method to provide different behaviour,

postTemplateProcess

protected void postTemplateProcess(freemarker.template.Template template,
                                   freemarker.template.TemplateModel data)
                            throws IOException
the default implementation of postTemplateProcess applies the contentType parameter

Throws:
IOException

preTemplateProcess

protected boolean preTemplateProcess(freemarker.template.Template template,
                                     freemarker.template.TemplateModel model)
                              throws IOException
Called before the execution is passed to template.process(). This is a generic hook you might use in subclasses to perform a specific action before the template is processed. By default does nothing. A typical action to perform here is to inject application-specific objects into the model root

Returns:
true to process the template, false to suppress template processing.
Throws:
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ScopesHashModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker
Class ScopesHashModel

java.lang.Object
    extended by  freemarker.template.WrappingTemplateModel
        extended by  freemarker.template.SimpleHash
            extended by  org.apache.struts2.views.freemarker.ScopesHashModel
All Implemented Interfaces:
freemarker.template.TemplateHashModel, freemarker.template.TemplateHashModelEx, freemarker.template.TemplateModel, Serializable
public class ScopesHashModel
extends freemarker.template.SimpleHash

Simple Hash model that also searches other scopes.

If the key doesn't exist in this hash, this template model tries to resolve the key within the attributes of the following scopes, in the order stated: Request, Session, Servlet Context

See Also:
Serialized Form

Field Summary
private HttpServletRequest | request
private static long | serialVersionUID
private ServletContext | servletContext
private ValueStack | stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ScopesHashModel(freemarker.template.ObjectWrapper objectWrapper, ServletContext context, HttpServletRequest request, ValueStack stack)
Method Summary
freemarker.template.TemplateModel | get(String key)
void | put(String string, boolean b)
void | put(String string, Object object)
Methods inherited from class freemarker.template.SimpleHash
copyMap, isEmpty, keys, putAll, remove, size, synchronizedWrapper, toMap, toString, values
Methods inherited from class freemarker.template.WrappingTemplateModel
getDefaultObjectWrapper, getObjectWrapper, setDefaultObjectWrapper, setObjectWrapper, wrap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

request

private HttpServletRequest request

servletContext

private ServletContext servletContext

stack

private ValueStack stack
Constructor Detail

ScopesHashModel

public ScopesHashModel(freemarker.template.ObjectWrapper objectWrapper,
                       ServletContext context,
                       HttpServletRequest request,
                       ValueStack stack)
Method Detail

get

public freemarker.template.TemplateModel get(String key)
                                      throws freemarker.template.TemplateModelException
Specified by:
get in interface freemarker.template.TemplateHashModel
Overrides:
get in class freemarker.template.SimpleHash
Throws:
freemarker.template.TemplateModelException

put

public void put(String string,
                boolean b)
Overrides:
put in class freemarker.template.SimpleHash

put

public void put(String string,
                Object object)
Overrides:
put in class freemarker.template.SimpleHash
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsBeanWrapper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker
Class StrutsBeanWrapper

java.lang.Object
    extended by  freemarker.ext.beans.BeansWrapper
        extended by  org.apache.struts2.views.freemarker.StrutsBeanWrapper
All Implemented Interfaces:
freemarker.template.ObjectWrapper
public class StrutsBeanWrapper
extends freemarker.ext.beans.BeansWrapper

The StrutsBeanWrapper extends the default FreeMarker BeansWrapper and provides almost no change in functionality, except for how it handles maps. Normally, FreeMarker has two modes of operation: either support for friendly map built-ins (?keys, ?values, etc) but only support for String keys; OR no special built-in support (ie: ?keys returns the methods on the map instead of the keys) but support for String and non-String keys alike. Struts provides an alternative implementation that gives us the best of both worlds.

It is possible that this special behavior may be confusing or can cause problems. Therefore, you can set the struts.freemarker.wrapper.altMap property in struts.properties to false, allowing the normal BeansWrapper logic to take place instead.

Nested Class Summary
private static class StrutsBeanWrapper.FriendlyMapModel
Attempting to get the best of both worlds of FM's MapModel and SimpleMapModel, by reimplementing the isEmpty(), keySet() and values() methods.
Field Summary
private  boolean altMapWrapper
Fields inherited from class freemarker.ext.beans.BeansWrapper
EXPOSE_ALL, EXPOSE_NOTHING, EXPOSE_PROPERTIES_ONLY, EXPOSE_SAFE
Fields inherited from interface freemarker.template.ObjectWrapper
BEANS_WRAPPER, DEFAULT_WRAPPER, SIMPLE_WRAPPER
Constructor Summary
StrutsBeanWrapper(boolean altMapWrapper)
Method Summary
 freemarker.template.TemplateModel wrap(Object object)
Methods inherited from class freemarker.ext.beans.BeansWrapper
coerceBigDecimals, create, getDefaultDateType, getDefaultInstance, getInstance, getOuterIdentity, getStaticModels, isSimpleMapWrapper, isStrict, newInstance, setDefaultDateType, setExposureLevel, setMethodsShadowItems, setNullModel, setOuterIdentity, setSimpleMapWrapper, setStrict, setUseCache, unwrap, unwrap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

altMapWrapper

private boolean altMapWrapper
Constructor Detail

StrutsBeanWrapper

StrutsBeanWrapper(boolean altMapWrapper)
Method Detail

wrap

public freemarker.template.TemplateModel wrap(Object object)
                                       throws freemarker.template.TemplateModelException
Specified by:
wrap in interface freemarker.template.ObjectWrapper
Overrides:
wrap in class freemarker.ext.beans.BeansWrapper
Throws:
freemarker.template.TemplateModelException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsBeanWrapper.FriendlyMapModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker
Class StrutsBeanWrapper.FriendlyMapModel

java.lang.Object
    extended by  freemarker.ext.beans.BeanModel
        extended by  freemarker.ext.beans.StringModel
            extended by  freemarker.ext.beans.MapModel
                extended by  org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel
All Implemented Interfaces:
freemarker.ext.util.WrapperTemplateModel, freemarker.template.AdapterTemplateModel, freemarker.template.TemplateHashModel, freemarker.template.TemplateHashModelEx, freemarker.template.TemplateMethodModel, freemarker.template.TemplateMethodModelEx, freemarker.template.TemplateModel, freemarker.template.TemplateScalarModel
Enclosing class:
StrutsBeanWrapper
private static final class StrutsBeanWrapper.FriendlyMapModel
extends freemarker.ext.beans.MapModel
implements freemarker.template.TemplateHashModelEx

Attempting to get the best of both worlds of FM's MapModel and SimpleMapModel, by reimplementing the isEmpty(), keySet() and values() methods. ?keys and ?values built-ins are thus available, just as well as plain Map methods.

Field Summary
(package private) static freemarker.ext.util.ModelFactory FACTORY
Fields inherited from class freemarker.ext.beans.BeanModel
object, wrapper
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Fields inherited from interface freemarker.template.TemplateScalarModel
EMPTY_STRING
Constructor Summary
StrutsBeanWrapper.FriendlyMapModel(Map map, freemarker.ext.beans.BeansWrapper wrapper)
Method Summary
boolean | isEmpty()
protected Set | keySet()
freemarker.template.TemplateCollectionModel | values()
Methods inherited from class freemarker.ext.beans.MapModel
exec, invokeGenericGet, size
Methods inherited from class freemarker.ext.beans.StringModel
getAsString
Methods inherited from class freemarker.ext.beans.BeanModel
get, getAdaptedObject, getWrappedObject, hasPlainGetMethod, keys, toString, unwrap, wrap
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface freemarker.template.TemplateHashModelEx
keys, size
Methods inherited from interface freemarker.template.TemplateHashModel
get

Field Detail

FACTORY

static final freemarker.ext.util.ModelFactory FACTORY
Constructor Detail

StrutsBeanWrapper.FriendlyMapModel

public StrutsBeanWrapper.FriendlyMapModel(Map map,
                                          freemarker.ext.beans.BeansWrapper wrapper)
Method Detail

isEmpty

public boolean isEmpty()
Specified by:
isEmpty in interface freemarker.template.TemplateHashModel
Overrides:
isEmpty in class freemarker.ext.beans.MapModel

keySet

protected Set keySet()
Overrides:
keySet in class freemarker.ext.beans.MapModel

values

public freemarker.template.TemplateCollectionModel values()
Specified by:
values in interface freemarker.template.TemplateHashModelEx
Overrides:
values in class freemarker.ext.beans.BeanModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsClassTemplateLoader (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker
Class StrutsClassTemplateLoader

java.lang.Object
    extended by  freemarker.cache.URLTemplateLoader
        extended by  org.apache.struts2.views.freemarker.StrutsClassTemplateLoader
All Implemented Interfaces:
freemarker.cache.TemplateLoader
public class StrutsClassTemplateLoader
extends freemarker.cache.URLTemplateLoader

Constructor Summary
StrutsClassTemplateLoader()
Method Summary
protected  URL getURL(String name)
Methods inherited from class freemarker.cache.URLTemplateLoader
canonicalizePrefix, closeTemplateSource, findTemplateSource, getLastModified, getReader
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StrutsClassTemplateLoader

public StrutsClassTemplateLoader()
Method Detail

getURL

protected URL getURL(String name)
Specified by:
getURL in class freemarker.cache.URLTemplateLoader
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.freemarker.tags (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.freemarker.tags

Class Summary
ActionErrorModel |
ActionMessageModel |
ActionModel |
AnchorModel |
AutocompleterModel |
BeanModel |
CallbackWriter |
CheckboxListModel |
CheckboxModel |
ComboBoxModel |
ComponentModel |
DateModel | DateModel
DateTimePickerModel |
DivModel |
DoubleSelectModel |
ElseIfModel |
ElseModel |
FieldErrorModel |
FileModel |
FormModel |
HeadModel |
HiddenModel |
I18nModel |
IfModel |
IncludeModel |
InputTransferSelectModel |
IteratorModel |
LabelModel |
OptGroupModel | Freemarker's TransformModel for OptGroup component.
OptionTransferSelectModel |
ParamModel |
PasswordModel |
PropertyModel |
PushModel |
RadioModel |
ResetModel |
SelectModel |
SetModel |
StrutsModels | Provides @s.tag access for various tags.
SubmitModel |
TabbedPanelModel |
TagModel |
TextAreaModel |
TextFieldModel |
TextModel |
TokenModel |
TreeModel | TreeModel
TreeNodeModel | TreeNodeModel
UpDownSelectModel |
URLModel |
WebTableModel |


org.apache.struts2.views.freemarker.tags Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.freemarker.tags

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.views.freemarker.tags.StrutsModels
    • org.apache.struts2.views.freemarker.tags.TagModel (implements freemarker.template.TemplateTransformModel)
      • org.apache.struts2.views.freemarker.tags.ActionErrorModel
      • org.apache.struts2.views.freemarker.tags.ActionMessageModel
      • org.apache.struts2.views.freemarker.tags.ActionModel
      • org.apache.struts2.views.freemarker.tags.AnchorModel
      • org.apache.struts2.views.freemarker.tags.AutocompleterModel
      • org.apache.struts2.views.freemarker.tags.BeanModel
      • org.apache.struts2.views.freemarker.tags.CheckboxListModel
      • org.apache.struts2.views.freemarker.tags.CheckboxModel
      • org.apache.struts2.views.freemarker.tags.ComboBoxModel
      • org.apache.struts2.views.freemarker.tags.ComponentModel
      • org.apache.struts2.views.freemarker.tags.DateModel
      • org.apache.struts2.views.freemarker.tags.DivModel
      • org.apache.struts2.views.freemarker.tags.DoubleSelectModel
      • org.apache.struts2.views.freemarker.tags.ElseIfModel
      • org.apache.struts2.views.freemarker.tags.ElseModel
      • org.apache.struts2.views.freemarker.tags.FieldErrorModel
      • org.apache.struts2.views.freemarker.tags.FileModel
      • org.apache.struts2.views.freemarker.tags.FormModel
      • org.apache.struts2.views.freemarker.tags.HeadModel
      • org.apache.struts2.views.freemarker.tags.HiddenModel
      • org.apache.struts2.views.freemarker.tags.I18nModel
      • org.apache.struts2.views.freemarker.tags.IfModel
      • org.apache.struts2.views.freemarker.tags.IncludeModel
      • org.apache.struts2.views.freemarker.tags.InputTransferSelectModel
      • org.apache.struts2.views.freemarker.tags.IteratorModel
      • org.apache.struts2.views.freemarker.tags.LabelModel
      • org.apache.struts2.views.freemarker.tags.OptGroupModel
      • org.apache.struts2.views.freemarker.tags.OptionTransferSelectModel
      • org.apache.struts2.views.freemarker.tags.ParamModel
      • org.apache.struts2.views.freemarker.tags.PasswordModel
      • org.apache.struts2.views.freemarker.tags.PropertyModel
      • org.apache.struts2.views.freemarker.tags.PushModel
      • org.apache.struts2.views.freemarker.tags.RadioModel
      • org.apache.struts2.views.freemarker.tags.ResetModel
      • org.apache.struts2.views.freemarker.tags.SelectModel
      • org.apache.struts2.views.freemarker.tags.SetModel
      • org.apache.struts2.views.freemarker.tags.SubmitModel
      • org.apache.struts2.views.freemarker.tags.TabbedPanelModel
      • org.apache.struts2.views.freemarker.tags.TextAreaModel
      • org.apache.struts2.views.freemarker.tags.TextFieldModel
        • org.apache.struts2.views.freemarker.tags.DateTimePickerModel
      • org.apache.struts2.views.freemarker.tags.TextModel
      • org.apache.struts2.views.freemarker.tags.TokenModel
      • org.apache.struts2.views.freemarker.tags.TreeModel
      • org.apache.struts2.views.freemarker.tags.TreeNodeModel
      • org.apache.struts2.views.freemarker.tags.UpDownSelectModel
      • org.apache.struts2.views.freemarker.tags.URLModel
      • org.apache.struts2.views.freemarker.tags.WebTableModel
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • org.apache.struts2.views.freemarker.tags.CallbackWriter (implements freemarker.template.TransformControl)


Uses of Package org.apache.struts2.views.freemarker.tags (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.freemarker.tags

Packages that use org.apache.struts2.views.freemarker.tags
org.apache.struts2.views.freemarker.tags

Classes in org.apache.struts2.views.freemarker.tags used by org.apache.struts2.views.freemarker.tags
ActionErrorModel
ActionMessageModel
ActionModel
AnchorModel
AutocompleterModel
BeanModel
CheckboxListModel
CheckboxModel
ComboBoxModel
ComponentModel
DateModel
DateModel
DateTimePickerModel
DivModel
DoubleSelectModel
ElseIfModel
ElseModel
FieldErrorModel
FileModel
FormModel
HeadModel
HiddenModel
I18nModel
IfModel
IncludeModel
InputTransferSelectModel
IteratorModel
LabelModel
OptGroupModel
Freemarker's TransformModel for OptGroup component.
OptionTransferSelectModel
ParamModel
PasswordModel
PropertyModel
PushModel
RadioModel
ResetModel
SelectModel
SetModel
SubmitModel
TabbedPanelModel
TagModel
TextAreaModel
TextFieldModel
TextModel
TokenModel
TreeModel
TreeModel
TreeNodeModel
TreeNodeModel
UpDownSelectModel
URLModel
WebTableModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionErrorModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ActionErrorModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ActionErrorModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ActionErrorModel
extends TagModel

See Also:
ActionError

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ActionErrorModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionErrorModel

public ActionErrorModel(ValueStack stack,
                        HttpServletRequest req,
                        HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionMessageModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ActionMessageModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ActionMessageModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ActionMessageModel
extends TagModel

See Also:
ActionMessage

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ActionMessageModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionMessageModel

public ActionMessageModel(ValueStack stack,
                          HttpServletRequest req,
                          HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ActionModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ActionModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ActionModel
extends TagModel

See Also:
ActionComponent

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ActionModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionModel

public ActionModel(ValueStack stack,
                   HttpServletRequest req,
                   HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnchorModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class AnchorModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.AnchorModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class AnchorModel
extends TagModel

See Also:
Anchor

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
AnchorModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnchorModel

public AnchorModel(ValueStack stack,
                   HttpServletRequest req,
                   HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AutocompleterModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class AutocompleterModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.AutocompleterModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class AutocompleterModel
extends TagModel

See Also:
Autocompleter

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
AutocompleterModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutocompleterModel

public AutocompleterModel(ValueStack stack,
                          HttpServletRequest req,
                          HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BeanModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class BeanModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.BeanModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class BeanModel
extends TagModel

See Also:
Bean

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
BeanModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BeanModel

public BeanModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CallbackWriter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class CallbackWriter

java.lang.Object
    extended by  java.io.Writer
        extended by  org.apache.struts2.views.freemarker.tags.CallbackWriter
All Implemented Interfaces:
freemarker.template.TransformControl, Closeable, Flushable, Appendable
public class CallbackWriter
extends Writer
implements freemarker.template.TransformControl

Field Summary
private boolean | afterBody
private Component | bean
private StringWriter | body
private Writer | writer
Fields inherited from class java.io.Writer
lock
Fields inherited from interface freemarker.template.TransformControl
END_EVALUATION, EVALUATE_BODY, REPEAT_EVALUATION, SKIP_BODY
Constructor Summary
CallbackWriter(Component bean, Writer writer)
Method Summary
int | afterBody()
void | close()
void | flush()
Component | getBean()
void | onError(Throwable throwable)
int | onStart()
void | write(char[] cbuf, int off, int len)
Methods inherited from class java.io.Writer
append, append, append, write, write, write, write
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

bean

private Component bean

writer

private Writer writer

body

private StringWriter body

afterBody

private boolean afterBody
Constructor Detail

CallbackWriter

public CallbackWriter(Component bean,
                      Writer writer)
Method Detail

close

public void close()
           throws IOException
Specified by:
close in interface Closeable
Specified by:
close in class Writer
Throws:
IOException

flush

public void flush()
           throws IOException
Specified by:
flush in interface Flushable
Specified by:
flush in class Writer
Throws:
IOException

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
Specified by:
write in class Writer
Throws:
IOException

onStart

public int onStart()
            throws freemarker.template.TemplateModelException,
                   IOException
Specified by:
onStart in interface freemarker.template.TransformControl
Throws:
freemarker.template.TemplateModelException
IOException

afterBody

public int afterBody()
              throws freemarker.template.TemplateModelException,
                     IOException
Specified by:
afterBody in interface freemarker.template.TransformControl
Throws:
freemarker.template.TemplateModelException
IOException

onError

public void onError(Throwable throwable)
             throws Throwable
Specified by:
onError in interface freemarker.template.TransformControl
Throws:
Throwable

getBean

public Component getBean()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckboxListModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class CheckboxListModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.CheckboxListModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class CheckboxListModel
extends TagModel

See Also:
CheckboxList

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
CheckboxListModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CheckboxListModel

public CheckboxListModel(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckboxModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class CheckboxModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.CheckboxModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class CheckboxModel
extends TagModel

See Also:
Checkbox

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
CheckboxModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CheckboxModel

public CheckboxModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComboBoxModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ComboBoxModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ComboBoxModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ComboBoxModel
extends TagModel

See Also:
ComboBox

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ComboBoxModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ComboBoxModel

public ComboBoxModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComponentModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ComponentModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ComponentModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ComponentModel
extends TagModel

See Also:
ComponentModel

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ComponentModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ComponentModel

public ComponentModel(ValueStack stack,
                      HttpServletRequest req,
                      HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class DateModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.DateModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class DateModel
extends TagModel

DateModel

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
DateModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DateModel

public DateModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateTimePickerModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class DateTimePickerModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.TextFieldModel
            extended by  org.apache.struts2.views.freemarker.tags.DateTimePickerModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class DateTimePickerModel
extends TextFieldModel

See Also:
DropdownDateTimePicker

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
DateTimePickerModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DateTimePickerModel

public DateTimePickerModel(ValueStack stack,
                           HttpServletRequest req,
                           HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Overrides:
getBean in class TextFieldModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DivModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class DivModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.DivModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class DivModel
extends TagModel

See Also:
Div

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
DivModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DivModel

public DivModel(ValueStack stack,
                HttpServletRequest req,
                HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleSelectModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class DoubleSelectModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.DoubleSelectModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class DoubleSelectModel
extends TagModel

See Also:
DoubleSelect

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
DoubleSelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DoubleSelectModel

public DoubleSelectModel(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElseIfModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ElseIfModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ElseIfModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ElseIfModel
extends TagModel

Version:
$Date: 2006-11-06 10:01:43 -0500 (Mon, 06 Nov 2006) $ $Id: ElseIfModel.java 471756 2006-11-06 15:01:43Z husted $

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ElseIfModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ElseIfModel

public ElseIfModel(ValueStack stack,
                   HttpServletRequest req,
                   HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElseModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ElseModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ElseModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ElseModel
extends TagModel

Version:
$Date: 2006-11-06 10:01:43 -0500 (Mon, 06 Nov 2006) $ $Id: ElseModel.java 471756 2006-11-06 15:01:43Z husted $

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ElseModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ElseModel

public ElseModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldErrorModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class FieldErrorModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.FieldErrorModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class FieldErrorModel
extends TagModel

See Also:
FieldError

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
FieldErrorModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FieldErrorModel

public FieldErrorModel(ValueStack stack,
                       HttpServletRequest req,
                       HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class FileModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.FileModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class FileModel
extends TagModel

See Also:
File

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
FileModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FileModel

public FileModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class FormModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.FormModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class FormModel
extends TagModel

See Also:
Form

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
FormModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormModel

public FormModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeadModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class HeadModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.HeadModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class HeadModel
extends TagModel

See Also:
Head

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
HeadModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HeadModel

public HeadModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HiddenModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class HiddenModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.HiddenModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class HiddenModel
extends TagModel

See Also:
Hidden

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
HiddenModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HiddenModel

public HiddenModel(ValueStack stack,
                   HttpServletRequest req,
                   HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


I18nModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class I18nModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.I18nModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class I18nModel
extends TagModel

See Also:
I18n

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
I18nModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

I18nModel

public I18nModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IfModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class IfModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.IfModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class IfModel
extends TagModel

Version:
$Date: 2006-11-06 10:01:43 -0500 (Mon, 06 Nov 2006) $ $Id: IfModel.java 471756 2006-11-06 15:01:43Z husted $

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
IfModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IfModel

public IfModel(ValueStack stack,
               HttpServletRequest req,
               HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IncludeModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class IncludeModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.IncludeModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class IncludeModel
extends TagModel

See Also:
Include

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
IncludeModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IncludeModel

public IncludeModel(ValueStack stack,
                    HttpServletRequest req,
                    HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InputTransferSelectModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class InputTransferSelectModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.InputTransferSelectModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class InputTransferSelectModel
extends TagModel

See Also:
InputTransferSelect

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
InputTransferSelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InputTransferSelectModel

public InputTransferSelectModel(ValueStack stack,
                                HttpServletRequest req,
                                HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class IteratorModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.IteratorModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class IteratorModel
extends TagModel

See Also:
IteratorComponent

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
IteratorModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IteratorModel

public IteratorModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class LabelModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.LabelModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class LabelModel
extends TagModel

See Also:
Label

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
LabelModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LabelModel

public LabelModel(ValueStack stack,
                  HttpServletRequest req,
                  HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptGroupModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class OptGroupModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.OptGroupModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class OptGroupModel
extends TagModel

Freemarker's TransformModel for OptGroup component.

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
OptGroupModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OptGroupModel

public OptGroupModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptionTransferSelectModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class OptionTransferSelectModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.OptionTransferSelectModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class OptionTransferSelectModel
extends TagModel

See Also:
OptionTransferSelect

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
OptionTransferSelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OptionTransferSelectModel

public OptionTransferSelectModel(ValueStack stack,
                                 HttpServletRequest req,
                                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParamModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ParamModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ParamModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ParamModel
extends TagModel

See Also:
Param

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ParamModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParamModel

public ParamModel(ValueStack stack,
                  HttpServletRequest req,
                  HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PasswordModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class PasswordModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.PasswordModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class PasswordModel
extends TagModel

See Also:
Password

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
PasswordModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PasswordModel

public PasswordModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class PropertyModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.PropertyModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class PropertyModel
extends TagModel

See Also:
Property

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
PropertyModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertyModel

public PropertyModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PushModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class PushModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.PushModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class PushModel
extends TagModel

See Also:
Push

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
PushModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PushModel

public PushModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RadioModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class RadioModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.RadioModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class RadioModel
extends TagModel

See Also:
Radio

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
RadioModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RadioModel

public RadioModel(ValueStack stack,
                  HttpServletRequest req,
                  HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResetModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class ResetModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.ResetModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class ResetModel
extends TagModel

See Also:
Reset

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
ResetModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResetModel

public ResetModel(ValueStack stack,
                  HttpServletRequest req,
                  HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class SelectModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.SelectModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class SelectModel
extends TagModel

See Also:
Select

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
SelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectModel

public SelectModel(ValueStack stack,
                   HttpServletRequest req,
                   HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SetModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class SetModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.SetModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class SetModel
extends TagModel

See Also:
Set

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
SetModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SetModel

public SetModel(ValueStack stack,
                HttpServletRequest req,
                HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsModels (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class StrutsModels

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.StrutsModels

public class StrutsModels
extends Object

Provides @s.tag access for various tags.

Field Summary
protected AnchorModel | a
protected ActionModel | action
protected ActionErrorModel | actionerror
protected ActionMessageModel | actionmessage
protected AutocompleterModel | autocompleterModel
protected BeanModel | bean
protected CheckboxModel | checkbox
protected CheckboxListModel | checkboxlist
protected ComboBoxModel | comboBox
protected ComponentModel | component
protected DateModel | date
protected DateTimePickerModel | dateTimePicker
protected DivModel | div
protected DoubleSelectModel | doubleselect
protected ElseIfModel | elseIfModel
protected ElseModel | elseModel
protected FieldErrorModel | fielderror
protected FileModel | file
protected FormModel | form
protected HeadModel | head
protected HiddenModel | hidden
protected I18nModel | i18n
protected IfModel | ifModel
protected IncludeModel | include
protected InputTransferSelectModel | inputtransferselect
protected IteratorModel | iterator
protected LabelModel | label
protected OptGroupModel | optGroupModel
protected OptionTransferSelectModel | optiontransferselect
protected ParamModel | param
protected PasswordModel | password
protected PropertyModel | property
protected PushModel | push
protected RadioModel | radio
protected HttpServletRequest | req
protected HttpServletResponse | res
protected ResetModel | reset
protected SelectModel | select
protected SetModel | set
protected ValueStack | stack
protected SubmitModel | submit
protected TabbedPanelModel | tabbedPanel
protected WebTableModel | table
protected TextModel | text
protected TextAreaModel | textarea
protected TextFieldModel | textfield
protected TokenModel | token
protected TreeModel | treeModel
protected TreeNodeModel | treenodeModel
protected UpDownSelectModel | updownselect
protected URLModel | url
Constructor Summary
StrutsModels(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
AnchorModel | getA()
ActionModel | getAction()
ActionErrorModel | getActionerror()
ActionMessageModel | getActionmessage()
AutocompleterModel | getAutocompleterModel()
BeanModel | getBean()
CheckboxModel | getCheckbox()
CheckboxListModel | getCheckboxlist()
ComboBoxModel | getComboBox()
ComponentModel | getComponent()
DateModel | getDate()
DateTimePickerModel | getDateTimePicker()
DivModel | getDiv()
DoubleSelectModel | getDoubleselect()
ElseModel | getElse()
ElseIfModel | getElseif()
FieldErrorModel | getFielderror()
FileModel | getFile()
FormModel | getForm()
HeadModel | getHead()
HiddenModel | getHidden()
AnchorModel | getHref()
I18nModel | getI18n()
IfModel | getIf()
IncludeModel | getInclude()
InputTransferSelectModel | getInputtransferselect()
IteratorModel | getIterator()
LabelModel | getLabel()
OptGroupModel | getOptgroup()
OptionTransferSelectModel | getOptiontransferselect()
ParamModel | getParam()
PasswordModel | getPassword()
PropertyModel | getProperty()
PushModel | getPush()
RadioModel | getRadio()
ResetModel | getReset()
SelectModel | getSelect()
SetModel | getSet()
SubmitModel | getSubmit()
TabbedPanelModel | getTabbedPanel()
WebTableModel | getTable()
TextModel | getText()
TextAreaModel | getTextarea()
TextFieldModel | getTextfield()
TokenModel | getToken()
TreeModel | getTree()
TreeNodeModel | getTreenode()
UpDownSelectModel | getUpdownselect()
URLModel | getUrl()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

stack

protected ValueStack stack

req

protected HttpServletRequest req

res

protected HttpServletResponse res

action

protected ActionModel action

bean

protected BeanModel bean

checkbox

protected CheckboxModel checkbox

checkboxlist

protected CheckboxListModel checkboxlist

comboBox

protected ComboBoxModel comboBox

component

protected ComponentModel component

date

protected DateModel date

dateTimePicker

protected DateTimePickerModel dateTimePicker

div

protected DivModel div

doubleselect

protected DoubleSelectModel doubleselect

file

protected FileModel file

form

protected FormModel form

head

protected HeadModel head

hidden

protected HiddenModel hidden

a

protected AnchorModel a

i18n

protected I18nModel i18n

include

protected IncludeModel include

label

protected LabelModel label

password

protected PasswordModel password

push

protected PushModel push

param

protected ParamModel param

radio

protected RadioModel radio

select

protected SelectModel select

set

protected SetModel set

submit

protected SubmitModel submit

reset

protected ResetModel reset

tabbedPanel

protected TabbedPanelModel tabbedPanel

textarea

protected TextAreaModel textarea

text

protected TextModel text

textfield

protected TextFieldModel textfield

token

protected TokenModel token

url

protected URLModel url

table

protected WebTableModel table

property

protected PropertyModel property

iterator

protected IteratorModel iterator

actionerror

protected ActionErrorModel actionerror

actionmessage

protected ActionMessageModel actionmessage

fielderror

protected FieldErrorModel fielderror

optiontransferselect

protected OptionTransferSelectModel optiontransferselect

treeModel

protected TreeModel treeModel

treenodeModel

protected TreeNodeModel treenodeModel

updownselect

protected UpDownSelectModel updownselect

optGroupModel

protected OptGroupModel optGroupModel

ifModel

protected IfModel ifModel

elseModel

protected ElseModel elseModel

elseIfModel

protected ElseIfModel elseIfModel

autocompleterModel

protected AutocompleterModel autocompleterModel

inputtransferselect

protected InputTransferSelectModel inputtransferselect
Constructor Detail

StrutsModels

public StrutsModels(ValueStack stack,
                    HttpServletRequest req,
                    HttpServletResponse res)
Method Detail

getCheckboxlist

public CheckboxListModel getCheckboxlist()

getCheckbox

public CheckboxModel getCheckbox()

getComboBox

public ComboBoxModel getComboBox()

getAutocompleterModel

public AutocompleterModel getAutocompleterModel()

getComponent

public ComponentModel getComponent()

getDoubleselect

public DoubleSelectModel getDoubleselect()

getFile

public FileModel getFile()

getForm

public FormModel getForm()

getHead

public HeadModel getHead()

getHidden

public HiddenModel getHidden()

getLabel

public LabelModel getLabel()

getPassword

public PasswordModel getPassword()

getRadio

public RadioModel getRadio()

getSelect

public SelectModel getSelect()

getSubmit

public SubmitModel getSubmit()

getReset

public ResetModel getReset()

getTextarea

public TextAreaModel getTextarea()

getTextfield

public TextFieldModel getTextfield()

getDate

public DateModel getDate()

getDateTimePicker

public DateTimePickerModel getDateTimePicker()

getToken

public TokenModel getToken()

getTable

public WebTableModel getTable()

getUrl

public URLModel getUrl()

getInclude

public IncludeModel getInclude()

getParam

public ParamModel getParam()

getAction

public ActionModel getAction()

getA

public AnchorModel getA()

getHref

public AnchorModel getHref()

getDiv

public DivModel getDiv()

getText

public TextModel getText()

getTabbedPanel

public TabbedPanelModel getTabbedPanel()

getBean

public BeanModel getBean()

getI18n

public I18nModel getI18n()

getPush

public PushModel getPush()

getSet

public SetModel getSet()

getProperty

public PropertyModel getProperty()

getIterator

public IteratorModel getIterator()

getActionerror

public ActionErrorModel getActionerror()

getActionmessage

public ActionMessageModel getActionmessage()

getFielderror

public FieldErrorModel getFielderror()

getOptiontransferselect

public OptionTransferSelectModel getOptiontransferselect()

getTree

public TreeModel getTree()

getTreenode

public TreeNodeModel getTreenode()

getUpdownselect

public UpDownSelectModel getUpdownselect()

getOptgroup

public OptGroupModel getOptgroup()

getIf

public IfModel getIf()

getElse

public ElseModel getElse()

getElseif

public ElseIfModel getElseif()

getInputtransferselect

public InputTransferSelectModel getInputtransferselect()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubmitModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class SubmitModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.SubmitModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class SubmitModel
extends TagModel

See Also:
Submit

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
SubmitModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubmitModel

public SubmitModel(ValueStack stack,
                   HttpServletRequest req,
                   HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabbedPanelModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class TabbedPanelModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.TabbedPanelModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class TabbedPanelModel
extends TagModel

See Also:
TabbedPanel

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
TabbedPanelModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TabbedPanelModel

public TabbedPanelModel(ValueStack stack,
                        HttpServletRequest req,
                        HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TagModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class TagModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
Direct Known Subclasses:
ActionErrorModel, ActionMessageModel, ActionModel, AnchorModel, AutocompleterModel, BeanModel, CheckboxListModel, CheckboxModel, ComboBoxModel, ComponentModel, DateModel, DivModel, DoubleSelectModel, ElseIfModel, ElseModel, FieldErrorModel, FileModel, FormModel, HeadModel, HiddenModel, I18nModel, IfModel, IncludeModel, InputTransferSelectModel, IteratorModel, LabelModel, OptGroupModel, OptionTransferSelectModel, ParamModel, PasswordModel, PropertyModel, PushModel, RadioModel, ResetModel, SelectModel, SetModel, SubmitModel, TabbedPanelModel, TextAreaModel, TextFieldModel, TextModel, TokenModel, TreeModel, TreeNodeModel, UpDownSelectModel, URLModel, WebTableModel
public abstract class TagModel
extends Object
implements freemarker.template.TemplateTransformModel

Field Summary
private static Log | LOG
protected HttpServletRequest | req
protected HttpServletResponse | res
protected ValueStack | stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
TagModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected boolean | complexType(Object value)
protected Map | convertParams(Map params)
protected abstract Component | getBean()
protected Map | getComplexParams(Map params)
Writer | getWriter(Writer writer, Map params)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

stack

protected ValueStack stack

req

protected HttpServletRequest req

res

protected HttpServletResponse res
Constructor Detail

TagModel

public TagModel(ValueStack stack,
                HttpServletRequest req,
                HttpServletResponse res)
Method Detail

getWriter

public Writer getWriter(Writer writer,
                        Map params)
                 throws freemarker.template.TemplateModelException,
                        IOException
Specified by:
getWriter in interface freemarker.template.TemplateTransformModel
Throws:
freemarker.template.TemplateModelException
IOException

getBean

protected abstract Component getBean()

convertParams

protected Map convertParams(Map params)

getComplexParams

protected Map getComplexParams(Map params)

complexType

protected boolean complexType(Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextAreaModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class TextAreaModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.TextAreaModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class TextAreaModel
extends TagModel

See Also:
TextArea

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
TextAreaModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextAreaModel

public TextAreaModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextFieldModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class TextFieldModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.TextFieldModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
Direct Known Subclasses:
DateTimePickerModel
public class TextFieldModel
extends TagModel

See Also:
TextField

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
TextFieldModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextFieldModel

public TextFieldModel(ValueStack stack,
                      HttpServletRequest req,
                      HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class TextModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.TextModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class TextModel
extends TagModel

See Also:
Text

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
TextModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextModel

public TextModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TokenModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class TokenModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.TokenModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class TokenModel
extends TagModel

See Also:
Token

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
TokenModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TokenModel

public TokenModel(ValueStack stack,
                  HttpServletRequest req,
                  HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class TreeModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.TreeModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class TreeModel
extends TagModel

TreeModel

See Also:
Tree

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
TreeModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TreeModel

public TreeModel(ValueStack stack,
                 HttpServletRequest req,
                 HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeNodeModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class TreeNodeModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.TreeNodeModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class TreeNodeModel
extends TagModel

TreeNodeModel

See Also:
TreeNode

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
TreeNodeModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TreeNodeModel

public TreeNodeModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpDownSelectModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class UpDownSelectModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.UpDownSelectModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class UpDownSelectModel
extends TagModel

See Also:
UpDownSelect

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
UpDownSelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UpDownSelectModel

public UpDownSelectModel(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class URLModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.URLModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class URLModel
extends TagModel

See Also:
URL

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
URLModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

URLModel

public URLModel(ValueStack stack,
                HttpServletRequest req,
                HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WebTableModel (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.freemarker.tags
Class WebTableModel

java.lang.Object
    extended by  org.apache.struts2.views.freemarker.tags.TagModel
        extended by  org.apache.struts2.views.freemarker.tags.WebTableModel
All Implemented Interfaces:
freemarker.template.TemplateModel, freemarker.template.TemplateTransformModel
public class WebTableModel
extends TagModel

See Also:
WebTable

Field Summary
Fields inherited from class org.apache.struts2.views.freemarker.tags.TagModel
req, res, stack
Fields inherited from interface freemarker.template.TemplateModel
NOTHING
Constructor Summary
WebTableModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Method Summary
protected  Component getBean()
Methods inherited from class org.apache.struts2.views.freemarker.tags.TagModel
complexType, convertParams, getComplexParams, getWriter
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WebTableModel

public WebTableModel(ValueStack stack,
                     HttpServletRequest req,
                     HttpServletResponse res)
Method Detail

getBean

protected Component getBean()
Specified by:
getBean in class TagModel
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.jsp (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.jsp

Struts's JSP tag library.

See:
Description

Class Summary
ActionTag |
BeanTag |
ComponentTagSupport |
DateTag |
ElseIfTag |
ElseTag |
I18nTag |
IfTag |
IncludeTag |
IteratorStatus | The iterator tag can export an IteratorStatus object so that one can get information about the status of the iteration, such as the size, current index, and whether any more items are available.
IteratorStatus.StatusState |
IteratorTag |
ParamTag |
PropertyTag |
PushTag |
SetTag |
StrutsBodyTagSupport | Contains common functonalities for Struts JSP Tags.
TagUtils |
TextTag |
URLTag |

Package org.apache.struts2.views.jsp Description

Struts's JSP tag library.


org.apache.struts2.views.jsp Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.jsp

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.views.jsp.IteratorStatus
    • org.apache.struts2.views.jsp.IteratorStatus.StatusState
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • org.apache.struts2.views.jsp.StrutsBodyTagSupport
          • org.apache.struts2.views.jsp.ComponentTagSupport
            • org.apache.struts2.views.jsp.ActionTag
            • org.apache.struts2.views.jsp.BeanTag
            • org.apache.struts2.views.jsp.DateTag
            • org.apache.struts2.views.jsp.ElseIfTag
            • org.apache.struts2.views.jsp.ElseTag
            • org.apache.struts2.views.jsp.I18nTag
            • org.apache.struts2.views.jsp.IfTag
            • org.apache.struts2.views.jsp.IncludeTag
            • org.apache.struts2.views.jsp.IteratorTag
            • org.apache.struts2.views.jsp.ParamTag
            • org.apache.struts2.views.jsp.PropertyTag
            • org.apache.struts2.views.jsp.PushTag
            • org.apache.struts2.views.jsp.SetTag
            • org.apache.struts2.views.jsp.TextTag
            • org.apache.struts2.views.jsp.URLTag
    • org.apache.struts2.views.jsp.TagUtils


Uses of Package org.apache.struts2.views.jsp (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.jsp

Packages that use org.apache.struts2.views.jsp
org.apache.struts2.components |
org.apache.struts2.views.jsp | Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.

Classes in org.apache.struts2.views.jsp used by org.apache.struts2.components
IteratorStatus
The iterator tag can export an IteratorStatus object so that one can get information about the status of the iteration, such as the size, current index, and whether any more items are available.
IteratorStatus.StatusState

Classes in org.apache.struts2.views.jsp used by org.apache.struts2.views.jsp
ComponentTagSupport
IteratorStatus.StatusState
StrutsBodyTagSupport
Contains common functonalities for Struts JSP Tags.

Classes in org.apache.struts2.views.jsp used by org.apache.struts2.views.jsp.iterator
ComponentTagSupport
StrutsBodyTagSupport
Contains common functonalities for Struts JSP Tags.

Classes in org.apache.struts2.views.jsp used by org.apache.struts2.views.jsp.ui
ComponentTagSupport
StrutsBodyTagSupport
Contains common functonalities for Struts JSP Tags.

Classes in org.apache.struts2.views.jsp used by org.apache.struts2.views.jsp.ui.table
ComponentTagSupport
StrutsBodyTagSupport
Contains common functonalities for Struts JSP Tags.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ActionTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class ActionTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ActionTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class ActionTag
extends ComponentTagSupport

See Also:
ActionComponent, Serialized Form

Field Summary
protected boolean | executeResult
protected boolean | flush
protected boolean | ignoreContextParams
protected String | name
protected String | namespace
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ActionTag()
Method Summary
protected void | addParameter(String name, Object value)
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
boolean | getFlush()
protected void | populateParams()
void | setExecuteResult(boolean executeResult)
void | setFlush(boolean flush)
void | setIgnoreContextParams(boolean ignoreContextParams)
void | setName(String name)
void | setNamespace(String namespace)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

name

protected String name

namespace

protected String namespace

executeResult

protected boolean executeResult

ignoreContextParams

protected boolean ignoreContextParams

flush

protected boolean flush
Constructor Detail

ActionTag

public ActionTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

addParameter

protected void addParameter(String name,
                            Object value)

setName

public void setName(String name)

setNamespace

public void setNamespace(String namespace)

setExecuteResult

public void setExecuteResult(boolean executeResult)

setIgnoreContextParams

public void setIgnoreContextParams(boolean ignoreContextParams)

setFlush

public void setFlush(boolean flush)

getFlush

public boolean getFlush()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BeanTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class BeanTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.BeanTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class BeanTag
extends ComponentTagSupport

See Also:
Bean, Serialized Form

Field Summary
protected static Log | log
protected String | name
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
BeanTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setName(String name)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

log

protected static Log log

name

protected String name
Constructor Detail

BeanTag

public BeanTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComponentTagSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class ComponentTagSupport

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
AbstractUITag, ActionTag, AppendIteratorTag, BeanTag, DateTag, ElseIfTag, ElseTag, I18nTag, IfTag, IncludeTag, IteratorTag, MergeIteratorTag, OptGroupTag, ParamTag, PropertyTag, PushTag, SetTag, TextTag, URLTag
public abstract class ComponentTagSupport
extends StrutsBodyTagSupport

See Also:
Serialized Form

Field Summary
protected  Component component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ComponentTagSupport()
Method Summary
int | doEndTag()
int | doStartTag()
abstract Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | getComponent()
protected void | populateParams()
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

component

protected Component component
Constructor Detail

ComponentTagSupport

public ComponentTagSupport()
Method Detail

getBean

public abstract Component getBean(ValueStack stack,
                                  HttpServletRequest req,
                                  HttpServletResponse res)

doEndTag

public int doEndTag()
             throws JspException
Specified by:
doEndTag in interface Tag
Overrides:
doEndTag in class BodyTagSupport
Throws:
JspException

doStartTag

public int doStartTag()
               throws JspException
Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class BodyTagSupport
Throws:
JspException

populateParams

protected void populateParams()

getComponent

public Component getComponent()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class DateTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.DateTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class DateTag
extends ComponentTagSupport

See Also:
Date, Serialized Form

Field Summary
protected String | format
protected String | name
protected boolean | nice
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
DateTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setFormat(String format)
void | setName(String name)
void | setNice(boolean nice)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

name

protected String name

format

protected String format

nice

protected boolean nice
Constructor Detail

DateTag

public DateTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setFormat

public void setFormat(String format)

setNice

public void setNice(boolean nice)

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElseIfTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class ElseIfTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ElseIfTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class ElseIfTag
extends ComponentTagSupport

See Also:
ElseIf, Serialized Form

Field Summary
private static long | serialVersionUID
protected String | test
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ElseIfTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setTest(String test)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

test

protected String test
Constructor Detail

ElseIfTag

public ElseIfTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setTest

public void setTest(String test)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElseTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class ElseTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ElseTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class ElseTag
extends ComponentTagSupport

See Also:
Else, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ElseTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent, populateParams
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

ElseTag

public ElseTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


I18nTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class I18nTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.I18nTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class I18nTag
extends ComponentTagSupport

See Also:
I18n, Serialized Form

Field Summary
protected String | name
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
I18nTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setName(String name)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

name

protected String name
Constructor Detail

I18nTag

public I18nTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IfTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class IfTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.IfTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class IfTag
extends ComponentTagSupport

See Also:
If, Serialized Form

Field Summary
private static long | serialVersionUID
(package private) String | test
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
IfTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setTest(String test)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

test

String test
Constructor Detail

IfTag

public IfTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setTest

public void setTest(String test)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IncludeTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class IncludeTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.IncludeTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class IncludeTag
extends ComponentTagSupport

See Also:
Include, Serialized Form

Field Summary
private static long | serialVersionUID
protected String | value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
IncludeTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setValue(String value)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

value

protected String value
Constructor Detail

IncludeTag

public IncludeTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorStatus (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class IteratorStatus

java.lang.Object
    extended by  org.apache.struts2.views.jsp.IteratorStatus

public class IteratorStatus
extends Object

The iterator tag can export an IteratorStatus object so that one can get information about the status of the iteration, such as the size, current index, and whether any more items are available.

Nested Class Summary
static class IteratorStatus.StatusState
Field Summary
protected  IteratorStatus.StatusState state
Constructor Summary
IteratorStatus(IteratorStatus.StatusState aState)
Method Summary
int | getCount()
int | getIndex()
boolean | isEven()
boolean | isFirst()
boolean | isLast()
boolean | isOdd()
int | modulus(int operand)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

state

protected IteratorStatus.StatusState state
Constructor Detail

IteratorStatus

public IteratorStatus(IteratorStatus.StatusState aState)
Method Detail

getCount

public int getCount()

isEven

public boolean isEven()

isFirst

public boolean isFirst()

getIndex

public int getIndex()

isLast

public boolean isLast()

isOdd

public boolean isOdd()

modulus

public int modulus(int operand)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorStatus.StatusState (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class IteratorStatus.StatusState

java.lang.Object
    extended by  org.apache.struts2.views.jsp.IteratorStatus.StatusState
Enclosing class:
IteratorStatus
public static class IteratorStatus.StatusState
extends Object

Field Summary
(package private) int | index
(package private) boolean | last
Constructor Summary
IteratorStatus.StatusState()
Method Summary
void | next()
void | setLast(boolean isLast)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

last

boolean last

index

int index
Constructor Detail

IteratorStatus.StatusState

public IteratorStatus.StatusState()
Method Detail

setLast

public void setLast(boolean isLast)

next

public void next()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IteratorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class IteratorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.IteratorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class IteratorTag
extends ComponentTagSupport

See Also:
IteratorComponent, Serialized Form

Field Summary
private static long | serialVersionUID
protected String | statusAttr
protected String | value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
IteratorTag()
Method Summary
int | doAfterBody()
int | doEndTag()
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setStatus(String status)
void | setValue(String value)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

statusAttr

protected String statusAttr

value

protected String value
Constructor Detail

IteratorTag

public IteratorTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setStatus

public void setStatus(String status)

setValue

public void setValue(String value)

doEndTag

public int doEndTag()
             throws JspException
Specified by:
doEndTag in interface Tag
Overrides:
doEndTag in class ComponentTagSupport
Throws:
JspException

doAfterBody

public int doAfterBody()
                throws JspException
Specified by:
doAfterBody in interface IterationTag
Overrides:
doAfterBody in class BodyTagSupport
Throws:
JspException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParamTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class ParamTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ParamTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class ParamTag
extends ComponentTagSupport

See Also:
Param, Serialized Form

Field Summary
protected String | name
private static long | serialVersionUID
protected String | value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ParamTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setName(String name)
void | setValue(String value)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

name

protected String name

value

protected String value
Constructor Detail

ParamTag

public ParamTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setName

public void setName(String name)

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class PropertyTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.PropertyTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class PropertyTag
extends ComponentTagSupport

See Also:
Property, Serialized Form

Field Summary
private String | defaultValue
private boolean | escape
private static long | serialVersionUID
private String | value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
PropertyTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setDefault(String defaultValue)
void | setEscape(boolean escape)
void | setValue(String value)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

defaultValue

private String defaultValue

value

private String value

escape

private boolean escape
Constructor Detail

PropertyTag

public PropertyTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setDefault

public void setDefault(String defaultValue)

setEscape

public void setEscape(boolean escape)

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PushTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class PushTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.PushTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class PushTag
extends ComponentTagSupport

See Also:
Push, Serialized Form

Field Summary
private static long | serialVersionUID
protected String | value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
PushTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setValue(String value)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

value

protected String value
Constructor Detail

PushTag

public PushTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SetTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class SetTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.SetTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class SetTag
extends ComponentTagSupport

See Also:
Set, Serialized Form

Field Summary
protected String | name
protected String | scope
private static long | serialVersionUID
protected String | value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
SetTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setName(String name)
void | setScope(String scope)
void | setValue(String value)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

name

protected String name

scope

protected String scope

value

protected String value
Constructor Detail

SetTag

public SetTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setName

public void setName(String name)

setScope

public void setScope(String scope)

setValue

public void setValue(String value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StrutsBodyTagSupport (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class StrutsBodyTagSupport

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
ComponentTagSupport, IteratorGeneratorTag, SortIteratorTag, SubsetIteratorTag
public class StrutsBodyTagSupport
extends BodyTagSupport

Contains common functonalities for Struts JSP Tags.

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
StrutsBodyTagSupport()
Method Summary
protected boolean | altSyntax()
protected String | findString(String expr)
protected Object | findValue(String expr)
protected Object | findValue(String expr, Class toType)
protected String | getBody()
protected ValueStack | getStack()
void | setId(String string)
protected String | toString(Throwable t)
static String | translateVariables(String expression, ValueStack stack)
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doEndTag, doInitBody, doStartTag, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

StrutsBodyTagSupport

public StrutsBodyTagSupport()
Method Detail

setId

public void setId(String string)
Overrides:
setId in class TagSupport

altSyntax

protected boolean altSyntax()

getStack

protected ValueStack getStack()

findString

protected String findString(String expr)

findValue

protected Object findValue(String expr)

findValue

protected Object findValue(String expr,
                           Class toType)

toString

protected String toString(Throwable t)

getBody

protected String getBody()

translateVariables

public static String translateVariables(String expression,
                                        ValueStack stack)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TagUtils (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class TagUtils

java.lang.Object
    extended by  org.apache.struts2.views.jsp.TagUtils

public class TagUtils
extends Object

Constructor Summary
TagUtils()
Method Summary
static String | buildNamespace(ActionMapper mapper, ValueStack stack, HttpServletRequest request)
static ValueStack | getStack(PageContext pageContext)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TagUtils

public TagUtils()
Method Detail

getStack

public static ValueStack getStack(PageContext pageContext)

buildNamespace

public static String buildNamespace(ActionMapper mapper,
                                    ValueStack stack,
                                    HttpServletRequest request)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class TextTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.TextTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class TextTag
extends ComponentTagSupport

See Also:
Text, Serialized Form

Field Summary
protected String | name
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TextTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setName(String name)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

name

protected String name
Constructor Detail

TextTag

public TextTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setName

public void setName(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp
Class URLTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.URLTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class URLTag
extends ComponentTagSupport

See Also:
URL, Serialized Form

Field Summary
protected String | action
protected String | anchor
protected String | encode
protected String | includeContext
protected String | includeParams
protected String | method
protected String | namespace
protected String | portletMode
protected String | portletUrlType
protected String | scheme
private static long | serialVersionUID
protected String | value
protected String | windowState
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
URLTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setAction(String action)
void | setAnchor(String anchor)
void | setEncode(String encode)
void | setIncludeContext(String includeContext)
void | setIncludeParams(String name)
void | setMethod(String method)
void | setNamespace(String namespace)
void | setPortletMode(String portletMode)
void | setPortletUrlType(String portletUrlType)
void | setScheme(String scheme)
void | setValue(String value)
void | setWindowState(String windowState)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

includeParams

protected String includeParams

scheme

protected String scheme

value

protected String value

action

protected String action

namespace

protected String namespace

method

protected String method

encode

protected String encode

includeContext

protected String includeContext

portletMode

protected String portletMode

windowState

protected String windowState

portletUrlType

protected String portletUrlType

anchor

protected String anchor
Constructor Detail

URLTag

public URLTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setEncode

public void setEncode(String encode)

setIncludeContext

public void setIncludeContext(String includeContext)

setIncludeParams

public void setIncludeParams(String name)

setAction

public void setAction(String action)

setNamespace

public void setNamespace(String namespace)

setMethod

public void setMethod(String method)

setScheme

public void setScheme(String scheme)

setValue

public void setValue(String value)

setPortletMode

public void setPortletMode(String portletMode)

setPortletUrlType

public void setPortletUrlType(String portletUrlType)

setWindowState

public void setWindowState(String windowState)

setAnchor

public void setAnchor(String anchor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.jsp.iterator (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.jsp.iterator

Struts's JSP tag library for iterator handling.

See:
Description

Class Summary
AppendIteratorTag | Append a list of iterators.
IteratorGeneratorTag | NOTE: JSP-TAG
MergeIteratorTag | Append a list of iterators.
SortIteratorTag | NOTE: JSP-TAG
SubsetIteratorTag | NOTE: JSP-TAG

Package org.apache.struts2.views.jsp.iterator Description

Struts's JSP tag library for iterator handling.


org.apache.struts2.views.jsp.iterator Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.jsp.iterator

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • org.apache.struts2.views.jsp.StrutsBodyTagSupport
          • org.apache.struts2.views.jsp.ComponentTagSupport
            • org.apache.struts2.views.jsp.iterator.AppendIteratorTag
            • org.apache.struts2.views.jsp.iterator.MergeIteratorTag
          • org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag
          • org.apache.struts2.views.jsp.iterator.SortIteratorTag
          • org.apache.struts2.views.jsp.iterator.SubsetIteratorTag


Uses of Package org.apache.struts2.views.jsp.iterator (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.jsp.iterator

No usage of org.apache.struts2.views.jsp.iterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AppendIteratorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.iterator
Class AppendIteratorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.iterator.AppendIteratorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class AppendIteratorTag
extends ComponentTagSupport

Append a list of iterators. The values of the iterators will be merged into one iterator.

See Also:
AppendIterator, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AppendIteratorTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent, populateParams
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

AppendIteratorTag

public AppendIteratorTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


IteratorGeneratorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.iterator
Class IteratorGeneratorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class IteratorGeneratorTag
extends StrutsBodyTagSupport

NOTE: JSP-TAG

Generate an iterator based on the val attribute supplied.

NOTE: The generated iterator will ALWAYS be pushed into the top of the stack, and poped at the end of the tag.
  • val* (Object) - the source to be parsed into an iterator
  • count (Object) - the max number (Integer, Float, Double, Long, String) entries to be in the iterator
  • separator (String) - the separator to be used in separating the val into entries of the iterator
  • id (String) - the id to store the resultant iterator into page context, if such id is supplied
  • converter (Object) - the converter (must extends off IteratorGenerator.Converter interface) to convert the String entry parsed from val into an object
Example One:
 Generate a simple iterator
 <s:generator val="%{'aaa,bbb,ccc,ddd,eee'}">
  <s:iterator>
      <s:property /><br/>
  </s:iterator>
 </s:generator>
This generates an iterator and print it out using the iterator tag. Example Two:
 Generate an iterator with count attribute
 <s:generator val="%{'aaa,bbb,ccc,ddd,eee'}" count="3">
  <s:iterator>
      <s:property /><br/>
  </s:iterator>
 </s:generator>
This generates an iterator, but only 3 entries will be available in the iterator generated, namely aaa, bbb and ccc respectively because count attribute is set to 3 Example Three:
 Generate an iterator with id attribute
 <s:generator val="%{'aaa,bbb,ccc,ddd,eee'}" count="4" separator="," id="myAtt" />
 <%
  Iterator i = (Iterator) pageContext.getAttribute("myAtt");
  while(i.hasNext()) {
      String s = (String) i.next(); %>
      <%=s%> <br/>
 <%    }
 %>
This generates an iterator and put it in the PageContext under the key as specified by the id attribute. Example Four:
 Generate an iterator with comparator attribute
 <s:generator val="%{'aaa,bbb,ccc,ddd,eee'}" converter="%{myConverter}">
  <s:iterator>
      <s:property /><br/>
  </s:iterator>
 </s:generator>

 public class GeneratorTagAction extends ActionSupport {

   ....

   public Converter getMyConverter() {
      return new Converter() {
          public Object convert(String value) throws Exception {
              return "converter-"+value;
          }
      };
   }

   ...

 }
This will generate an iterator with each entries decided by the converter supplied. With this converter, it simply add "converter-" to each entries.

See Also:
IteratorGenerator, Serialized Form

Field Summary
private static Log | _log
(package private) String | converterAttr
(package private) String | countAttr
static String | DEFAULT_SEPARATOR
(package private) IteratorGenerator | iteratorGenerator
(package private) String | separatorAttr
private static long | serialVersionUID
(package private) String | valueAttr
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
IteratorGeneratorTag()
Method Summary
int | doEndTag()
int | doStartTag()
void | setConverter(String aConverter)
void | setCount(String count)
void | setId(String string)
void | setSeparator(String separator)
void | setVal(String val)
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

DEFAULT_SEPARATOR

public static final String DEFAULT_SEPARATOR
See Also:
Constant Field Values

_log

private static final Log _log

countAttr

String countAttr

separatorAttr

String separatorAttr

valueAttr

String valueAttr

converterAttr

String converterAttr

iteratorGenerator

IteratorGenerator iteratorGenerator
Constructor Detail

IteratorGeneratorTag

public IteratorGeneratorTag()
Method Detail

setCount

public void setCount(String count)

setSeparator

public void setSeparator(String separator)

setVal

public void setVal(String val)

setConverter

public void setConverter(String aConverter)

setId

public void setId(String string)
Overrides:
setId in class StrutsBodyTagSupport

doStartTag

public int doStartTag()
               throws JspException
Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class BodyTagSupport
Throws:
JspException

doEndTag

public int doEndTag()
             throws JspException
Specified by:
doEndTag in interface Tag
Overrides:
doEndTag in class BodyTagSupport
Throws:
JspException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MergeIteratorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.iterator
Class MergeIteratorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.iterator.MergeIteratorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class MergeIteratorTag
extends ComponentTagSupport

Append a list of iterators. The values of the iterators will be merged into one iterator.

See Also:
MergeIterator, MergeIteratorFilter, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
MergeIteratorTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent, populateParams
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

MergeIteratorTag

public MergeIteratorTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SortIteratorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.iterator
Class SortIteratorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.iterator.SortIteratorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class SortIteratorTag
extends StrutsBodyTagSupport

NOTE: JSP-TAG

A Tag that sorts a List using a Comparator both passed in as the tag attribute. If 'id' attribute is specified, the sorted list will be placed into the PageContext attribute using the key specified by 'id'. The sorted list will ALWAYS be pushed into the stack and poped at the end of this tag.

  • id (String) - if specified, the sorted iterator will be place with this id under page context
  • source (Object) - the source for the sort to take place (should be iteratable) else JspException will be thrown
  • comparator* (Object) - the comparator used to do sorting (should be a type of Comparator or its decendent) else JspException will be thrown

 USAGE 1:
 <s:sort comparator="myComparator" source="myList">
      <s:iterator>
      <!-- do something with each sorted elements -->
      <s:property value="..." />
      </s:iterator>
 </s:sort>

 USAGE 2:
 <s:sort id="mySortedList" comparator="myComparator" source="myList" />

 <%
    Iterator sortedIterator = (Iterator) pageContext.getAttribute("mySortedList");
    for (Iterator i = sortedIterator; i.hasNext(); ) {
      // do something with each of the sorted elements
    }
 %>

See Also:
SortIteratorFilter, Serialized Form

Field Summary
(package private) String | comparatorAttr
private static long | serialVersionUID
(package private) SortIteratorFilter | sortIteratorFilter
(package private) String | sourceAttr
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
SortIteratorTag()
Method Summary
int | doEndTag()
int | doStartTag()
void | setComparator(String comparator)
void | setSource(String source)
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

comparatorAttr

String comparatorAttr

sourceAttr

String sourceAttr

sortIteratorFilter

SortIteratorFilter sortIteratorFilter
Constructor Detail

SortIteratorTag

public SortIteratorTag()
Method Detail

setComparator

public void setComparator(String comparator)

setSource

public void setSource(String source)

doStartTag

public int doStartTag()
               throws JspException
Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class BodyTagSupport
Throws:
JspException

doEndTag

public int doEndTag()
             throws JspException
Specified by:
doEndTag in interface Tag
Overrides:
doEndTag in class BodyTagSupport
Throws:
JspException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubsetIteratorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.iterator
Class SubsetIteratorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.iterator.SubsetIteratorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class SubsetIteratorTag
extends StrutsBodyTagSupport

NOTE: JSP-TAG

A tag that takes an iterator and outputs a subset of it. It delegates to SubsetIteratorFilter internally to perform the subset functionality.

  • count (Object) - Indicate the number of entries to be in the resulting subset iterator
  • source* (Object) - Indicate the source of which the resulting subset iterator is to be derived base on
  • start (Object) - Indicate the starting index (eg. first entry is 0) of entries in the source to be available as the first entry in the resulting subset iterator
  • decider (Object) - Extension to plug-in a decider to determine if that particular entry is to be included in the resulting subset iterator
  • id (String) - Indicate the pageContext attribute id to store the resultant subset iterator in

 public class MySubsetTagAction extends ActionSupport {
      public String execute() throws Exception {
         l = new ArrayList();
         l.add(new Integer(1));
         l.add(new Integer(2));
         l.add(new Integer(3));
         l.add(new Integer(4));
         l.add(new Integer(5));
         return "done";
      }

      public Integer[] getMyArray() {
         return a;
      }

      public List getMyList() {
         return l;
       }

      public Decider getMyDecider() {
      return new Decider() {
          public boolean decide(Object element) throws Exception {
              int i = ((Integer)element).intValue();
              return (((i % 2) == 0)?true:false);
          }
      };
      }
  }

 <!-- s: List basic -->
    <s:subset source="myList">
       <s:iterator>
          <s:property />
       </s:iterator>
    </s:subset>

 <!-- B: List with count -->
    <s:subset source="myList" count="3">
       <s:iterator>
           <s:property />
       </s:iterator>
     </s:subset>

 <!--  C: List with start -->
      <s:subset source="myList" count="13" start="3">
         <s:iterator>
           <s:property />
         </s:iterator>
      </s:subset>

 <!--  D: List with id -->
      <s:subset id="mySubset" source="myList" count="13" start="3" />
      <%
          Iterator i = (Iterator) pageContext.getAttribute("mySubset");
          while(i.hasNext()) {
      %>
      <%=i.next() %>
      <%  } %>

  <!--  D: List with Decider -->
      <s:subset source="myList" decider="myDecider">
             <s:iterator>
                  <s:property />
             </s:iterator>
      </s:subset>

See Also:
Serialized Form

Field Summary
private static Log | _log
(package private) String | countAttr
(package private) String | deciderAttr
private static long | serialVersionUID
(package private) String | sourceAttr
(package private) String | startAttr
(package private) SubsetIteratorFilter | subsetIteratorFilter
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
SubsetIteratorTag()
Method Summary
int | doEndTag()
int | doStartTag()
void | setCount(String count)
void | setDecider(String decider)
void | setSource(String source)
void | setStart(String start)
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

_log

private static final Log _log

countAttr

String countAttr

sourceAttr

String sourceAttr

startAttr

String startAttr

deciderAttr

String deciderAttr

subsetIteratorFilter

SubsetIteratorFilter subsetIteratorFilter
Constructor Detail

SubsetIteratorTag

public SubsetIteratorTag()
Method Detail

setCount

public void setCount(String count)

setSource

public void setSource(String source)

setStart

public void setStart(String start)

setDecider

public void setDecider(String decider)

doStartTag

public int doStartTag()
               throws JspException
Specified by:
doStartTag in interface Tag
Overrides:
doStartTag in class BodyTagSupport
Throws:
JspException

doEndTag

public int doEndTag()
             throws JspException
Specified by:
doEndTag in interface Tag
Overrides:
doEndTag in class BodyTagSupport
Throws:
JspException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.jsp.ui (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.jsp.ui

Struts' JSP UI tags.

See:
Description

Class Summary
AbstractClosingTag |
AbstractDoubleListTag |
AbstractListTag |
AbstractRemoteCallUITag |
AbstractRequiredListTag |
AbstractUITag | Abstract base class for all UI tags.
ActionErrorTag | ActionError Tag.
ActionMessageTag | ActionMessage Tag.
AnchorTag |
AutocompleterTag |
CheckboxListTag |
CheckboxTag |
ComboBoxTag |
ComponentTag |
DateTimePickerTag |
DebugTag |
DivTag |
DoubleSelectTag |
FieldErrorTag | FieldError Tag.
FileTag |
FormTag |
HeadTag |
HiddenTag |
InputTransferSelectTag | InputTransferSelect jsp tag.
LabelTag |
OgnlTool |
OptGroupTag |
OptionTransferSelectTag | OptionTransferSelect jsp tag.
PasswordTag |
RadioTag |
ResetTag |
SelectTag |
SubmitTag |
TabbedPanelTag |
TextareaTag |
TextFieldTag |
TokenTag |
TreeNodeTag |
TreeTag |
UpDownSelectTag |

Package org.apache.struts2.views.jsp.ui Description

Struts' JSP UI tags.


org.apache.struts2.views.jsp.ui Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.jsp.ui

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.views.jsp.ui.OgnlTool
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • org.apache.struts2.views.jsp.StrutsBodyTagSupport
          • org.apache.struts2.views.jsp.ComponentTagSupport
            • org.apache.struts2.views.jsp.ui.AbstractUITag
              • org.apache.struts2.views.jsp.ui.AbstractClosingTag
                • org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
                  • org.apache.struts2.views.jsp.ui.AnchorTag
                  • org.apache.struts2.views.jsp.ui.DivTag
                • org.apache.struts2.views.jsp.ui.FormTag
                • org.apache.struts2.views.jsp.ui.TabbedPanelTag
                • org.apache.struts2.views.jsp.ui.TreeNodeTag
                • org.apache.struts2.views.jsp.ui.TreeTag
              • org.apache.struts2.views.jsp.ui.AbstractListTag
                • org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                  • org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
                    • org.apache.struts2.views.jsp.ui.DoubleSelectTag
                    • org.apache.struts2.views.jsp.ui.OptionTransferSelectTag
                  • org.apache.struts2.views.jsp.ui.CheckboxListTag
                  • org.apache.struts2.views.jsp.ui.RadioTag
                  • org.apache.struts2.views.jsp.ui.SelectTag
                    • org.apache.struts2.views.jsp.ui.UpDownSelectTag
                • org.apache.struts2.views.jsp.ui.InputTransferSelectTag
              • org.apache.struts2.views.jsp.ui.ActionErrorTag
              • org.apache.struts2.views.jsp.ui.ActionMessageTag
              • org.apache.struts2.views.jsp.ui.CheckboxTag
              • org.apache.struts2.views.jsp.ui.ComponentTag
              • org.apache.struts2.views.jsp.ui.DateTimePickerTag
              • org.apache.struts2.views.jsp.ui.DebugTag
              • org.apache.struts2.views.jsp.ui.FieldErrorTag
              • org.apache.struts2.views.jsp.ui.FileTag
              • org.apache.struts2.views.jsp.ui.HeadTag
              • org.apache.struts2.views.jsp.ui.HiddenTag
              • org.apache.struts2.views.jsp.ui.LabelTag
              • org.apache.struts2.views.jsp.ui.ResetTag
              • org.apache.struts2.views.jsp.ui.SubmitTag
              • org.apache.struts2.views.jsp.ui.TextareaTag
              • org.apache.struts2.views.jsp.ui.TextFieldTag
                • org.apache.struts2.views.jsp.ui.ComboBoxTag
                  • org.apache.struts2.views.jsp.ui.AutocompleterTag
                • org.apache.struts2.views.jsp.ui.PasswordTag
              • org.apache.struts2.views.jsp.ui.TokenTag
            • org.apache.struts2.views.jsp.ui.OptGroupTag


Uses of Package org.apache.struts2.views.jsp.ui (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.jsp.ui

Packages that use org.apache.struts2.views.jsp.ui
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.

Classes in org.apache.struts2.views.jsp.ui used by org.apache.struts2.util
OgnlTool

Classes in org.apache.struts2.views.jsp.ui used by org.apache.struts2.views.jsp.ui
AbstractClosingTag
AbstractDoubleListTag
AbstractListTag
AbstractRemoteCallUITag
AbstractRequiredListTag
AbstractUITag
Abstract base class for all UI tags.
ComboBoxTag
OgnlTool
SelectTag
TextFieldTag

Classes in org.apache.struts2.views.jsp.ui used by org.apache.struts2.views.jsp.ui.table
AbstractUITag
Abstract base class for all UI tags.
ComponentTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractClosingTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class AbstractClosingTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractClosingTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
AbstractRemoteCallUITag, FormTag, TabbedPanelTag, TreeNodeTag, TreeTag
public abstract class AbstractClosingTag
extends AbstractUITag

See Also:
Serialized Form

Field Summary
protected  String openTemplate
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AbstractClosingTag()
Method Summary
protected void | populateParams()
void | setOpenTemplate(String openTemplate)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getBean, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

openTemplate

protected String openTemplate
Constructor Detail

AbstractClosingTag

public AbstractClosingTag()
Method Detail

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setOpenTemplate

public void setOpenTemplate(String openTemplate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractDoubleListTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class AbstractDoubleListTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                                extended by  org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
DoubleSelectTag, OptionTransferSelectTag
public abstract class AbstractDoubleListTag
extends AbstractRequiredListTag

See Also:
Serialized Form

Field Summary
protected String | doubleAccesskey
protected String | doubleCssClass
protected String | doubleCssStyle
protected String | doubleDisabled
protected String | doubleEmptyOption
protected String | doubleHeaderKey
protected String | doubleHeaderValue
protected String | doubleId
protected String | doubleList
protected String | doubleListKey
protected String | doubleListValue
protected String | doubleMultiple
protected String | doubleName
protected String | doubleOnblur
protected String | doubleOnchange
protected String | doubleOnclick
protected String | doubleOndblclick
protected String | doubleOnfocus
protected String | doubleOnkeydown
protected String | doubleOnkeypress
protected String | doubleOnkeyup
protected String | doubleOnmousedown
protected String | doubleOnmousemove
protected String | doubleOnmouseout
protected String | doubleOnmouseover
protected String | doubleOnmouseup
protected String | doubleOnselect
protected String | doubleSize
protected String | doubleValue
protected String | emptyOption
protected String | formName
protected String | headerKey
protected String | headerValue
protected String | multiple
protected String | size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AbstractDoubleListTag()
Method Summary
String | getDoubleCssClass()
String | getDoubleCssStyle()
String | getDoubleDisabled()
String | getDoubleEmptyOption()
String | getDoubleHeaderKey()
String | getDoubleHeaderValue()
String | getDoubleId()
String | getDoubleList()
String | getDoubleListKey()
String | getDoubleListValue()
String | getDoubleMultiple()
String | getDoubleName()
String | getDoubleOnblur()
String | getDoubleOnchange()
String | getDoubleOnclick()
String | getDoubleOndblclick()
String | getDoubleOnfocus()
String | getDoubleOnkeydown()
String | getDoubleOnkeypress()
String | getDoubleOnkeyup()
String | getDoubleOnmousedown()
String | getDoubleOnmousemove()
String | getDoubleOnmouseout()
String | getDoubleOnmouseover()
String | getDoubleOnmouseup()
String | getDoubleOnselect()
String | getDoubleSize()
String | getDoubleValue()
String | getFormName()
protected void | populateParams()
void | setDoubleAccesskey(String doubleAccesskey)
void | setDoubleCssClass(String doubleCssClass)
void | setDoubleCssStyle(String doubleCssStyle)
void | setDoubleDisabled(String doubleDisabled)
void | setDoubleEmptyOption(String doubleEmptyOption)
void | setDoubleHeaderKey(String doubleHeaderKey)
void | setDoubleHeaderValue(String doubleHeaderValue)
void | setDoubleId(String doubleId)
void | setDoubleList(String list)
void | setDoubleListKey(String listKey)
void | setDoubleListValue(String listValue)
void | setDoubleMultiple(String doubleMultiple)
void | setDoubleName(String aName)
void | setDoubleOnblur(String doubleOnblur)
void | setDoubleOnchange(String doubleOnchange)
void | setDoubleOnclick(String doubleOnclick)
void | setDoubleOndblclick(String doubleOndblclick)
void | setDoubleOnfocus(String doubleOnfocus)
void | setDoubleOnkeydown(String doubleOnkeydown)
void | setDoubleOnkeypress(String doubleOnkeypress)
void | setDoubleOnkeyup(String doubleOnkeyup)
void | setDoubleOnmousedown(String doubleOnmousedown)
void | setDoubleOnmousemove(String doubleOnmousemove)
void | setDoubleOnmouseout(String doubleOnmouseout)
void | setDoubleOnmouseover(String doubleOnmouseover)
void | setDoubleOnmouseup(String doubleOnmouseup)
void | setDoubleOnselect(String doubleOnselect)
void | setDoubleSize(String doubleSize)
void | setDoubleValue(String doubleValue)
void | setEmptyOption(String emptyOption)
void | setFormName(String formName)
void | setHeaderKey(String headerKey)
void | setHeaderValue(String headerValue)
void | setMultiple(String multiple)
void | setSize(String size)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getBean, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

doubleList

protected String doubleList

doubleListKey

protected String doubleListKey

doubleListValue

protected String doubleListValue

doubleName

protected String doubleName

doubleValue

protected String doubleValue

formName

protected String formName

emptyOption

protected String emptyOption

headerKey

protected String headerKey

headerValue

protected String headerValue

multiple

protected String multiple

size

protected String size

doubleId

protected String doubleId

doubleDisabled

protected String doubleDisabled

doubleMultiple

protected String doubleMultiple

doubleSize

protected String doubleSize

doubleHeaderKey

protected String doubleHeaderKey

doubleHeaderValue

protected String doubleHeaderValue

doubleEmptyOption

protected String doubleEmptyOption

doubleCssClass

protected String doubleCssClass

doubleCssStyle

protected String doubleCssStyle

doubleOnclick

protected String doubleOnclick

doubleOndblclick

protected String doubleOndblclick

doubleOnmousedown

protected String doubleOnmousedown

doubleOnmouseup

protected String doubleOnmouseup

doubleOnmouseover

protected String doubleOnmouseover

doubleOnmousemove

protected String doubleOnmousemove

doubleOnmouseout

protected String doubleOnmouseout

doubleOnfocus

protected String doubleOnfocus

doubleOnblur

protected String doubleOnblur

doubleOnkeypress

protected String doubleOnkeypress

doubleOnkeydown

protected String doubleOnkeydown

doubleOnkeyup

protected String doubleOnkeyup

doubleOnselect

protected String doubleOnselect

doubleOnchange

protected String doubleOnchange

doubleAccesskey

protected String doubleAccesskey
Constructor Detail

AbstractDoubleListTag

public AbstractDoubleListTag()
Method Detail

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractRequiredListTag

setDoubleList

public void setDoubleList(String list)

setDoubleListKey

public void setDoubleListKey(String listKey)

setDoubleListValue

public void setDoubleListValue(String listValue)

setDoubleName

public void setDoubleName(String aName)

setDoubleValue

public void setDoubleValue(String doubleValue)

setFormName

public void setFormName(String formName)

getDoubleCssClass

public String getDoubleCssClass()

setDoubleCssClass

public void setDoubleCssClass(String doubleCssClass)

getDoubleCssStyle

public String getDoubleCssStyle()

setDoubleCssStyle

public void setDoubleCssStyle(String doubleCssStyle)

getDoubleDisabled

public String getDoubleDisabled()

setDoubleDisabled

public void setDoubleDisabled(String doubleDisabled)

getDoubleEmptyOption

public String getDoubleEmptyOption()

setDoubleEmptyOption

public void setDoubleEmptyOption(String doubleEmptyOption)

getDoubleHeaderKey

public String getDoubleHeaderKey()

setDoubleHeaderKey

public void setDoubleHeaderKey(String doubleHeaderKey)

getDoubleHeaderValue

public String getDoubleHeaderValue()

setDoubleHeaderValue

public void setDoubleHeaderValue(String doubleHeaderValue)

getDoubleId

public String getDoubleId()

setDoubleId

public void setDoubleId(String doubleId)

getDoubleMultiple

public String getDoubleMultiple()

setDoubleMultiple

public void setDoubleMultiple(String doubleMultiple)

getDoubleOnblur

public String getDoubleOnblur()

setDoubleOnblur

public void setDoubleOnblur(String doubleOnblur)

getDoubleOnchange

public String getDoubleOnchange()

setDoubleOnchange

public void setDoubleOnchange(String doubleOnchange)

getDoubleOnclick

public String getDoubleOnclick()

setDoubleOnclick

public void setDoubleOnclick(String doubleOnclick)

getDoubleOndblclick

public String getDoubleOndblclick()

setDoubleOndblclick

public void setDoubleOndblclick(String doubleOndblclick)

getDoubleOnfocus

public String getDoubleOnfocus()

setDoubleOnfocus

public void setDoubleOnfocus(String doubleOnfocus)

getDoubleOnkeydown

public String getDoubleOnkeydown()

setDoubleOnkeydown

public void setDoubleOnkeydown(String doubleOnkeydown)

getDoubleOnkeypress

public String getDoubleOnkeypress()

setDoubleOnkeypress

public void setDoubleOnkeypress(String doubleOnkeypress)

getDoubleOnkeyup

public String getDoubleOnkeyup()

setDoubleOnkeyup

public void setDoubleOnkeyup(String doubleOnkeyup)

getDoubleOnmousedown

public String getDoubleOnmousedown()

setDoubleOnmousedown

public void setDoubleOnmousedown(String doubleOnmousedown)

getDoubleOnmousemove

public String getDoubleOnmousemove()

setDoubleOnmousemove

public void setDoubleOnmousemove(String doubleOnmousemove)

getDoubleOnmouseout

public String getDoubleOnmouseout()

setDoubleOnmouseout

public void setDoubleOnmouseout(String doubleOnmouseout)

getDoubleOnmouseover

public String getDoubleOnmouseover()

setDoubleOnmouseover

public void setDoubleOnmouseover(String doubleOnmouseover)

getDoubleOnmouseup

public String getDoubleOnmouseup()

setDoubleOnmouseup

public void setDoubleOnmouseup(String doubleOnmouseup)

getDoubleOnselect

public String getDoubleOnselect()

setDoubleOnselect

public void setDoubleOnselect(String doubleOnselect)

getDoubleSize

public String getDoubleSize()

setDoubleSize

public void setDoubleSize(String doubleSize)

getDoubleList

public String getDoubleList()

getDoubleListKey

public String getDoubleListKey()

getDoubleListValue

public String getDoubleListValue()

getDoubleName

public String getDoubleName()

getDoubleValue

public String getDoubleValue()

getFormName

public String getFormName()

setEmptyOption

public void setEmptyOption(String emptyOption)

setHeaderKey

public void setHeaderKey(String headerKey)

setHeaderValue

public void setHeaderValue(String headerValue)

setMultiple

public void setMultiple(String multiple)

setSize

public void setSize(String size)

setDoubleAccesskey

public void setDoubleAccesskey(String doubleAccesskey)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractListTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class AbstractListTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
AbstractRequiredListTag, InputTransferSelectTag
public abstract class AbstractListTag
extends AbstractUITag

See Also:
Serialized Form

Field Summary
protected String | list
protected String | listKey
protected String | listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AbstractListTag()
Method Summary
protected void | populateParams()
void | setList(String list)
void | setListKey(String listKey)
void | setListValue(String listValue)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getBean, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

list

protected String list

listKey

protected String listKey

listValue

protected String listValue
Constructor Detail

AbstractListTag

public AbstractListTag()
Method Detail

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setList

public void setList(String list)

setListKey

public void setListKey(String listKey)

setListValue

public void setListValue(String listValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractRemoteCallUITag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class AbstractRemoteCallUITag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractClosingTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
AnchorTag, DivTag
public abstract class AbstractRemoteCallUITag
extends AbstractClosingTag

See Also:
Serialized Form

Field Summary
protected String | afterLoading
protected String | beforeLoading
protected String | errorText
protected String | executeScripts
protected String | formFilter
protected String | formId
protected String | handler
protected String | href
protected String | indicator
protected String | listenTopics
protected String | loadingText
protected String | notifyTopics
protected String | showErrorTransportText
protected String | showLoadingText
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
openTemplate
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AbstractRemoteCallUITag()
Method Summary
protected void | populateParams()
void | setAfterLoading(String afterLoading)
void | setBeforeLoading(String beforeLoading)
void | setErrorText(String errorText)
void | setExecuteScripts(String executeScripts)
void | setFormFilter(String formFilter)
void | setFormId(String formId)
void | setHandler(String handler)
void | setHref(String href)
void | setIndicator(String indicator)
void | setListenTopics(String listenTopics)
void | setLoadingText(String loadingText)
void | setNotifyTopics(String notifyTopics)
void | setShowErrorTransportText(String showErrorTransportText)
void | setShowLoadingText(String showLoadingText)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
setOpenTemplate
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getBean, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

href

protected String href

listenTopics

protected String listenTopics

notifyTopics

protected String notifyTopics

loadingText

protected String loadingText

errorText

protected String errorText

beforeLoading

protected String beforeLoading

afterLoading

protected String afterLoading

executeScripts

protected String executeScripts

handler

protected String handler

formId

protected String formId

formFilter

protected String formFilter

showErrorTransportText

protected String showErrorTransportText

indicator

protected String indicator

showLoadingText

protected String showLoadingText
Constructor Detail

AbstractRemoteCallUITag

public AbstractRemoteCallUITag()
Method Detail

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractClosingTag

setHref

public void setHref(String href)

setErrorText

public void setErrorText(String errorText)

setLoadingText

public void setLoadingText(String loadingText)

setListenTopics

public void setListenTopics(String listenTopics)

setAfterLoading

public void setAfterLoading(String afterLoading)

setBeforeLoading

public void setBeforeLoading(String beforeLoading)

setExecuteScripts

public void setExecuteScripts(String executeScripts)

setHandler

public void setHandler(String handler)

setFormFilter

public void setFormFilter(String formFilter)

setFormId

public void setFormId(String formId)

setNotifyTopics

public void setNotifyTopics(String notifyTopics)

setShowErrorTransportText

public void setShowErrorTransportText(String showErrorTransportText)

setIndicator

public void setIndicator(String indicator)
Parameters:
indicator - The indicator to set.

setShowLoadingText

public void setShowLoadingText(String showLoadingText)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractRequiredListTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class AbstractRequiredListTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
AbstractDoubleListTag, CheckboxListTag, RadioTag, SelectTag
public abstract class AbstractRequiredListTag
extends AbstractListTag

See Also:
Serialized Form

Field Summary
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AbstractRequiredListTag()
Method Summary
protected  void populateParams()
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getBean, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Constructor Detail

AbstractRequiredListTag

public AbstractRequiredListTag()
Method Detail

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractListTag
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractUITag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class AbstractUITag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
AbstractClosingTag, AbstractListTag, ActionErrorTag, ActionMessageTag, CheckboxTag, ComponentTag, DateTimePickerTag, DebugTag, FieldErrorTag, FileTag, HeadTag, HiddenTag, LabelTag, ResetTag, SubmitTag, TextareaTag, TextFieldTag, TokenTag
public abstract class AbstractUITag
extends ComponentTagSupport

Abstract base class for all UI tags.

See Also:
Serialized Form

Field Summary
protected String | accesskey
protected String | cssClass
protected String | cssStyle
protected String | disabled
protected String | key
protected String | label
protected String | labelPosition
protected String | name
protected String | onblur
protected String | onchange
protected String | onclick
protected String | ondblclick
protected String | onfocus
protected String | onkeydown
protected String | onkeypress
protected String | onkeyup
protected String | onmousedown
protected String | onmousemove
protected String | onmouseout
protected String | onmouseover
protected String | onmouseup
protected String | onselect
protected String | required
protected String | requiredposition
protected String | tabindex
protected String | template
protected String | templateDir
protected String | theme
protected String | title
protected String | tooltip
protected String | tooltipConfig
protected String | value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AbstractUITag()
Method Summary
protected void | populateParams()
void | setAccesskey(String accesskey)
void | setCssClass(String cssClass)
void | setCssStyle(String cssStyle)
void | setDisabled(String disabled)
void | setKey(String key)
void | setLabel(String label)
void | setLabelposition(String labelPosition)
void | setName(String name)
void | setOnblur(String onblur)
void | setOnchange(String onchange)
void | setOnclick(String onclick)
void | setOndblclick(String ondblclick)
void | setOnfocus(String onfocus)
void | setOnkeydown(String onkeydown)
void | setOnkeypress(String onkeypress)
void | setOnkeyup(String onkeyup)
void | setOnmousedown(String onmousedown)
void | setOnmousemove(String onmousemove)
void | setOnmouseout(String onmouseout)
void | setOnmouseover(String onmouseover)
void | setOnmouseup(String onmouseup)
void | setOnselect(String onselect)
void | setRequired(String required)
void | setRequiredposition(String requiredPosition)
void | setTabindex(String tabindex)
void | setTemplate(String template)
void | setTemplateDir(String templateDir)
void | setTheme(String theme)
void | setTitle(String title)
void | setTooltip(String tooltip)
void | setTooltipConfig(String tooltipConfig)
void | setValue(String value)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getBean, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

cssClass

protected String cssClass

cssStyle

protected String cssStyle

title

protected String title

disabled

protected String disabled

label

protected String label

labelPosition

protected String labelPosition

requiredposition

protected String requiredposition

name

protected String name

required

protected String required

tabindex

protected String tabindex

value

protected String value

template

protected String template

theme

protected String theme

templateDir

protected String templateDir

onclick

protected String onclick

ondblclick

protected String ondblclick

onmousedown

protected String onmousedown

onmouseup

protected String onmouseup

onmouseover

protected String onmouseover

onmousemove

protected String onmousemove

onmouseout

protected String onmouseout

onfocus

protected String onfocus

onblur

protected String onblur

onkeypress

protected String onkeypress

onkeydown

protected String onkeydown

onkeyup

protected String onkeyup

onselect

protected String onselect

onchange

protected String onchange

accesskey

protected String accesskey

key

protected String key

tooltip

protected String tooltip

tooltipConfig

protected String tooltipConfig
Constructor Detail

AbstractUITag

public AbstractUITag()
Method Detail

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setCssClass

public void setCssClass(String cssClass)

setCssStyle

public void setCssStyle(String cssStyle)

setTitle

public void setTitle(String title)

setDisabled

public void setDisabled(String disabled)

setLabel

public void setLabel(String label)

setLabelposition

public void setLabelposition(String labelPosition)

setRequiredposition

public void setRequiredposition(String requiredPosition)

setName

public void setName(String name)

setRequired

public void setRequired(String required)

setTabindex

public void setTabindex(String tabindex)

setValue

public void setValue(String value)

setTemplateDir

public void setTemplateDir(String templateDir)

setTemplate

public void setTemplate(String template)

setTheme

public void setTheme(String theme)

setOnclick

public void setOnclick(String onclick)

setOndblclick

public void setOndblclick(String ondblclick)

setOnmousedown

public void setOnmousedown(String onmousedown)

setOnmouseup

public void setOnmouseup(String onmouseup)

setOnmouseover

public void setOnmouseover(String onmouseover)

setOnmousemove

public void setOnmousemove(String onmousemove)

setOnmouseout

public void setOnmouseout(String onmouseout)

setOnfocus

public void setOnfocus(String onfocus)

setOnblur

public void setOnblur(String onblur)

setOnkeypress

public void setOnkeypress(String onkeypress)

setOnkeydown

public void setOnkeydown(String onkeydown)

setOnkeyup

public void setOnkeyup(String onkeyup)

setOnselect

public void setOnselect(String onselect)

setOnchange

public void setOnchange(String onchange)

setTooltip

public void setTooltip(String tooltip)

setTooltipConfig

public void setTooltipConfig(String tooltipConfig)

setAccesskey

public void setAccesskey(String accesskey)

setKey

public void setKey(String key)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionErrorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class ActionErrorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.ActionErrorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class ActionErrorTag
extends AbstractUITag

ActionError Tag.

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ActionErrorTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
populateParams, setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

ActionErrorTag

public ActionErrorTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionMessageTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class ActionMessageTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.ActionMessageTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class ActionMessageTag
extends AbstractUITag

ActionMessage Tag.

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ActionMessageTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
populateParams, setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

ActionMessageTag

public ActionMessageTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnchorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class AnchorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractClosingTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
                                extended by  org.apache.struts2.views.jsp.ui.AnchorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class AnchorTag
extends AbstractRemoteCallUITag

See Also:
Anchor, Serialized Form

Field Summary
protected String | preInvokeJS
private static long | serialVersionUID
protected String | targets
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
afterLoading, beforeLoading, errorText, executeScripts, formFilter, formId, handler, href, indicator, listenTopics, loadingText, notifyTopics, showErrorTransportText, showLoadingText
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
openTemplate
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AnchorTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setPreInvokeJS(String preInvokeJS) Deprecated.
void | setTargets(String targets)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
setAfterLoading, setBeforeLoading, setErrorText, setExecuteScripts, setFormFilter, setFormId, setHandler, setHref, setIndicator, setListenTopics, setLoadingText, setNotifyTopics, setShowErrorTransportText, setShowLoadingText
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
setOpenTemplate
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

targets

protected String targets

preInvokeJS

protected String preInvokeJS
Constructor Detail

AnchorTag

public AnchorTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractRemoteCallUITag

setTargets

public void setTargets(String targets)

setPreInvokeJS

@Deprecated
public void setPreInvokeJS(String preInvokeJS)
Deprecated.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AutocompleterTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class AutocompleterTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.TextFieldTag
                            extended by  org.apache.struts2.views.jsp.ui.ComboBoxTag
                                extended by  org.apache.struts2.views.jsp.ui.AutocompleterTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class AutocompleterTag
extends ComboBoxTag

See Also:
Autocompleter, Serialized Form

Field Summary
protected String | autoComplete
protected String | delay
protected String | disabled
protected String | dropdownHeight
protected String | dropdownWidth
protected String | forceValidOption
protected String | formFilter
protected String | formId
protected String | href
protected String | iconPath
protected String | indicator
protected String | keyName
protected String | listenTopics
protected String | loadMinimumCount
protected String | loadOnTextChange
protected String | notifyTopics
protected String | searchType
private static long | serialVersionUID
protected String | showDownArrow
protected String | templateCssPath
Fields inherited from class org.apache.struts2.views.jsp.ui.ComboBoxTag
emptyOption, headerKey, headerValue, list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.TextFieldTag
maxlength, readonly, size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
AutocompleterTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getLoadMinimumCount()
protected void | populateParams()
void | setAutoComplete(String autoComplete)
void | setDelay(String searchDelay)
void | setDisabled(String disabled)
void | setDropdownHeight(String height)
void | setDropdownWidth(String width)
void | setForceValidOption(String forceValidOption)
void | setFormFilter(String formFilter)
void | setFormId(String formId)
void | setHref(String href)
void | setIconPath(String iconPath)
void | setIndicator(String indicator)
void | setKeyName(String keyName)
void | setListenTopics(String listenTopics)
void | setLoadMinimumCount(String loadMinimumCount)
void | setLoadOnTextChange(String loadOnTextChange)
void | setNotifyTopics(String onValueChangedPublishTopic)
void | setSearchType(String searchType)
void | setShowDownArrow(String showDownArrow)
void | setTemplateCssPath(String templateCssPath)
Methods inherited from class org.apache.struts2.views.jsp.ui.ComboBoxTag
setEmptyOption, setHeaderKey, setHeaderValue, setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.TextFieldTag
setMaxlength, setMaxLength, setReadonly, setSize
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

forceValidOption

protected String forceValidOption

searchType

protected String searchType

autoComplete

protected String autoComplete

delay

protected String delay

disabled

protected String disabled

href

protected String href

dropdownWidth

protected String dropdownWidth

dropdownHeight

protected String dropdownHeight

formId

protected String formId

formFilter

protected String formFilter

listenTopics

protected String listenTopics

notifyTopics

protected String notifyTopics

indicator

protected String indicator

loadOnTextChange

protected String loadOnTextChange

loadMinimumCount

protected String loadMinimumCount

showDownArrow

protected String showDownArrow

templateCssPath

protected String templateCssPath

iconPath

protected String iconPath

keyName

protected String keyName
Constructor Detail

AutocompleterTag

public AutocompleterTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Overrides:
getBean in class ComboBoxTag

populateParams

protected void populateParams()
Overrides:
populateParams in class ComboBoxTag

setAutoComplete

public void setAutoComplete(String autoComplete)

setDisabled

public void setDisabled(String disabled)
Overrides:
setDisabled in class AbstractUITag

setForceValidOption

public void setForceValidOption(String forceValidOption)

setHref

public void setHref(String href)

setDelay

public void setDelay(String searchDelay)

setSearchType

public void setSearchType(String searchType)

setDropdownHeight

public void setDropdownHeight(String height)

setDropdownWidth

public void setDropdownWidth(String width)

setFormFilter

public void setFormFilter(String formFilter)

setFormId

public void setFormId(String formId)

setListenTopics

public void setListenTopics(String listenTopics)

setNotifyTopics

public void setNotifyTopics(String onValueChangedPublishTopic)

setIndicator

public void setIndicator(String indicator)

setLoadMinimumCount

public void setLoadMinimumCount(String loadMinimumCount)

getLoadMinimumCount

public String getLoadMinimumCount()

setLoadOnTextChange

public void setLoadOnTextChange(String loadOnTextChange)

setShowDownArrow

public void setShowDownArrow(String showDownArrow)

setTemplateCssPath

public void setTemplateCssPath(String templateCssPath)

setIconPath

public void setIconPath(String iconPath)

setKeyName

public void setKeyName(String keyName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckboxListTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class CheckboxListTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                                extended by  org.apache.struts2.views.jsp.ui.CheckboxListTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class CheckboxListTag
extends AbstractRequiredListTag

See Also:
CheckboxList, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
CheckboxListTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
populateParams
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

CheckboxListTag

public CheckboxListTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckboxTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class CheckboxTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.CheckboxTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class CheckboxTag
extends AbstractUITag

See Also:
Checkbox, Serialized Form

Field Summary
protected String | fieldValue
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
CheckboxTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setFieldValue(String aValue)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

fieldValue

protected String fieldValue
Constructor Detail

CheckboxTag

public CheckboxTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setFieldValue

public void setFieldValue(String aValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComboBoxTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class ComboBoxTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.TextFieldTag
                            extended by  org.apache.struts2.views.jsp.ui.ComboBoxTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
AutocompleterTag
public class ComboBoxTag
extends TextFieldTag

See Also:
ComboBox, Serialized Form

Field Summary
protected String | emptyOption
protected String | headerKey
protected String | headerValue
protected String | list
protected String | listKey
protected String | listValue
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.TextFieldTag
maxlength, readonly, size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ComboBoxTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setEmptyOption(String emptyOption)
void | setHeaderKey(String headerKey)
void | setHeaderValue(String headerValue)
void | setList(String list)
void | setListKey(String listKey)
void | setListValue(String listValue)
Methods inherited from class org.apache.struts2.views.jsp.ui.TextFieldTag
setMaxlength, setMaxLength, setReadonly, setSize
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

list

protected String list

listKey

protected String listKey

listValue

protected String listValue

headerKey

protected String headerKey

headerValue

protected String headerValue

emptyOption

protected String emptyOption
Constructor Detail

ComboBoxTag

public ComboBoxTag()
Method Detail

setEmptyOption

public void setEmptyOption(String emptyOption)

setHeaderKey

public void setHeaderKey(String headerKey)

setHeaderValue

public void setHeaderValue(String headerValue)

setListKey

public void setListKey(String listKey)

setListValue

public void setListValue(String listValue)

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Overrides:
getBean in class TextFieldTag

populateParams

protected void populateParams()
Overrides:
populateParams in class TextFieldTag

setList

public void setList(String list)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComponentTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class ComponentTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.ComponentTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
WebTableTag
public class ComponentTag
extends AbstractUITag

See Also:
GenericUIBean, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ComponentTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
populateParams, setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

ComponentTag

public ComponentTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateTimePickerTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class DateTimePickerTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.DateTimePickerTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class DateTimePickerTag
extends AbstractUITag

See Also:
DateTimePicker, Serialized Form

Field Summary
protected String | adjustWeeks
protected String | dayWidth
protected String | displayFormat
protected String | displayWeeks
protected String | endDate
protected String | formatLength
protected String | iconPath
protected String | language
private static long | serialVersionUID
protected String | startDate
protected String | staticDisplay
protected String | templateCssPath
protected String | toggleDuration
protected String | toggleType
protected String | type
protected String | weekStartsOn
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
DateTimePickerTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setAdjustWeeks(String adjustWeeks)
void | setDayWidth(String dayWidth)
void | setDisplayFormat(String displayFormat)
void | setDisplayWeeks(String displayWeeks)
void | setEndDate(String endDate)
void | setFormatLength(String formatLength)
void | setIconPath(String iconPath)
void | setLanguage(String language)
void | setStartDate(String startDate)
void | setStaticDisplay(String staticDisplay)
void | setTemplateCssPath(String templateCssPath)
void | setToggleDuration(String toggleDuration)
void | setToggleType(String toggleType)
void | setType(String type)
void | setWeekStartsOn(String weekStartsOn)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

displayWeeks

protected String displayWeeks

adjustWeeks

protected String adjustWeeks

startDate

protected String startDate

endDate

protected String endDate

weekStartsOn

protected String weekStartsOn

staticDisplay

protected String staticDisplay

dayWidth

protected String dayWidth

language

protected String language

iconPath

protected String iconPath

formatLength

protected String formatLength

displayFormat

protected String displayFormat

toggleType

protected String toggleType

toggleDuration

protected String toggleDuration

type

protected String type

templateCssPath

protected String templateCssPath
Constructor Detail

DateTimePickerTag

public DateTimePickerTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setAdjustWeeks

public void setAdjustWeeks(String adjustWeeks)

setDayWidth

public void setDayWidth(String dayWidth)

setDisplayWeeks

public void setDisplayWeeks(String displayWeeks)

setEndDate

public void setEndDate(String endDate)

setStartDate

public void setStartDate(String startDate)

setStaticDisplay

public void setStaticDisplay(String staticDisplay)

setWeekStartsOn

public void setWeekStartsOn(String weekStartsOn)

setLanguage

public void setLanguage(String language)

setDisplayFormat

public void setDisplayFormat(String displayFormat)

setFormatLength

public void setFormatLength(String formatLength)

setIconPath

public void setIconPath(String iconPath)

setToggleDuration

public void setToggleDuration(String toggleDuration)

setToggleType

public void setToggleType(String toggleType)

setType

public void setType(String type)

setTemplateCssPath

public void setTemplateCssPath(String templateCssPath)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DebugTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class DebugTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.DebugTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class DebugTag
extends AbstractUITag

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
DebugTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
populateParams, setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

DebugTag

public DebugTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DivTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class DivTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractClosingTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
                                extended by  org.apache.struts2.views.jsp.ui.DivTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class DivTag
extends AbstractRemoteCallUITag

See Also:
Serialized Form

Field Summary
protected String | autoStart
protected String | delay
protected String | refreshOnShow
private static long | serialVersionUID
protected String | startTimerListenTopics
protected String | stopTimerListenTopics
protected String | updateFreq
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
afterLoading, beforeLoading, errorText, executeScripts, formFilter, formId, handler, href, indicator, listenTopics, loadingText, notifyTopics, showErrorTransportText, showLoadingText
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
openTemplate
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
DivTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setAutoStart(String autoStart)
void | setDelay(String delay)
void | setRefreshOnShow(String refreshOnShow)
void | setStartTimerListenTopics(String startTimerListenTopic)
void | setStopTimerListenTopics(String stopTimerListenTopic)
void | setUpdateFreq(String updateInterval)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag
setAfterLoading, setBeforeLoading, setErrorText, setExecuteScripts, setFormFilter, setFormId, setHandler, setHref, setIndicator, setListenTopics, setLoadingText, setNotifyTopics, setShowErrorTransportText, setShowLoadingText
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
setOpenTemplate
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

updateFreq

protected String updateFreq

autoStart

protected String autoStart

delay

protected String delay

startTimerListenTopics

protected String startTimerListenTopics

stopTimerListenTopics

protected String stopTimerListenTopics

refreshOnShow

protected String refreshOnShow
Constructor Detail

DivTag

public DivTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractRemoteCallUITag

setAutoStart

public void setAutoStart(String autoStart)

setDelay

public void setDelay(String delay)

setUpdateFreq

public void setUpdateFreq(String updateInterval)

setStartTimerListenTopics

public void setStartTimerListenTopics(String startTimerListenTopic)

setStopTimerListenTopics

public void setStopTimerListenTopics(String stopTimerListenTopic)

setRefreshOnShow

public void setRefreshOnShow(String refreshOnShow)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleSelectTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class DoubleSelectTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                                extended by  org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
                                    extended by  org.apache.struts2.views.jsp.ui.DoubleSelectTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class DoubleSelectTag
extends AbstractDoubleListTag

See Also:
DoubleSelect, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
doubleAccesskey, doubleCssClass, doubleCssStyle, doubleDisabled, doubleEmptyOption, doubleHeaderKey, doubleHeaderValue, doubleId, doubleList, doubleListKey, doubleListValue, doubleMultiple, doubleName, doubleOnblur, doubleOnchange, doubleOnclick, doubleOndblclick, doubleOnfocus, doubleOnkeydown, doubleOnkeypress, doubleOnkeyup, doubleOnmousedown, doubleOnmousemove, doubleOnmouseout, doubleOnmouseover, doubleOnmouseup, doubleOnselect, doubleSize, doubleValue, emptyOption, formName, headerKey, headerValue, multiple, size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
DoubleSelectTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
getDoubleCssClass, getDoubleCssStyle, getDoubleDisabled, getDoubleEmptyOption, getDoubleHeaderKey, getDoubleHeaderValue, getDoubleId, getDoubleList, getDoubleListKey, getDoubleListValue, getDoubleMultiple, getDoubleName, getDoubleOnblur, getDoubleOnchange, getDoubleOnclick, getDoubleOndblclick, getDoubleOnfocus, getDoubleOnkeydown, getDoubleOnkeypress, getDoubleOnkeyup, getDoubleOnmousedown, getDoubleOnmousemove, getDoubleOnmouseout, getDoubleOnmouseover, getDoubleOnmouseup, getDoubleOnselect, getDoubleSize, getDoubleValue, getFormName, setDoubleAccesskey, setDoubleCssClass, setDoubleCssStyle, setDoubleDisabled, setDoubleEmptyOption, setDoubleHeaderKey, setDoubleHeaderValue, setDoubleId, setDoubleList, setDoubleListKey, setDoubleListValue, setDoubleMultiple, setDoubleName, setDoubleOnblur, setDoubleOnchange, setDoubleOnclick, setDoubleOndblclick, setDoubleOnfocus, setDoubleOnkeydown, setDoubleOnkeypress, setDoubleOnkeyup, setDoubleOnmousedown, setDoubleOnmousemove, setDoubleOnmouseout, setDoubleOnmouseover, setDoubleOnmouseup, setDoubleOnselect, setDoubleSize, setDoubleValue, setEmptyOption, setFormName, setHeaderKey, setHeaderValue, setMultiple, setSize
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

DoubleSelectTag

public DoubleSelectTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractDoubleListTag
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldErrorTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class FieldErrorTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.FieldErrorTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class FieldErrorTag
extends AbstractUITag

FieldError Tag.

See Also:
Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
FieldErrorTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
populateParams, setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

FieldErrorTag

public FieldErrorTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class FileTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.FileTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class FileTag
extends AbstractUITag

See Also:
File, Serialized Form

Field Summary
protected String | accept
private static long | serialVersionUID
protected String | size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
FileTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setAccept(String accept)
void | setSize(String size)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

accept

protected String accept

size

protected String size
Constructor Detail

FileTag

public FileTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setAccept

public void setAccept(String accept)

setSize

public void setSize(String size)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class FormTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractClosingTag
                            extended by  org.apache.struts2.views.jsp.ui.FormTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class FormTag
extends AbstractClosingTag

See Also:
Form, Serialized Form

Field Summary
protected String | acceptcharset
protected String | action
protected String | enctype
protected String | method
protected String | namespace
protected String | onsubmit
protected String | portletMode
private static long | serialVersionUID
protected String | target
protected String | validate
protected String | windowState
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
openTemplate
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
FormTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setAcceptcharset(String acceptcharset)
void | setAction(String action)
void | setEnctype(String enctype)
void | setMethod(String method)
void | setNamespace(String namespace)
void | setOnsubmit(String onsubmit)
void | setPortletMode(String portletMode)
void | setTarget(String target)
void | setValidate(String validate)
void | setWindowState(String windowState)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
setOpenTemplate
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

action

protected String action

target

protected String target

enctype

protected String enctype

method

protected String method

namespace

protected String namespace

validate

protected String validate

onsubmit

protected String onsubmit

portletMode

protected String portletMode

windowState

protected String windowState

acceptcharset

protected String acceptcharset
Constructor Detail

FormTag

public FormTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractClosingTag

setAction

public void setAction(String action)

setTarget

public void setTarget(String target)

setEnctype

public void setEnctype(String enctype)

setMethod

public void setMethod(String method)

setNamespace

public void setNamespace(String namespace)

setValidate

public void setValidate(String validate)

setOnsubmit

public void setOnsubmit(String onsubmit)

setPortletMode

public void setPortletMode(String portletMode)

setWindowState

public void setWindowState(String windowState)

setAcceptcharset

public void setAcceptcharset(String acceptcharset)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeadTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class HeadTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.HeadTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class HeadTag
extends AbstractUITag

See Also:
Head, Serialized Form

Field Summary
private String | calendarcss
private String | debug
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
HeadTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getCalendarcss()
protected void | populateParams()
void | setCalendarcss(String calendarcss)
void | setDebug(String debug)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

calendarcss

private String calendarcss

debug

private String debug
Constructor Detail

HeadTag

public HeadTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

getCalendarcss

public String getCalendarcss()

setCalendarcss

public void setCalendarcss(String calendarcss)

setDebug

public void setDebug(String debug)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HiddenTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class HiddenTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.HiddenTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class HiddenTag
extends AbstractUITag

See Also:
Hidden, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
HiddenTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
populateParams, setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

HiddenTag

public HiddenTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InputTransferSelectTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class InputTransferSelectTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.InputTransferSelectTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class InputTransferSelectTag
extends AbstractListTag

InputTransferSelect jsp tag.

See Also:
Serialized Form

Field Summary
protected String | addLabel
protected String | allowRemoveAll
protected String | allowUpDown
protected String | buttonCssClass
protected String | buttonCssStyle
protected String | downLabel
protected String | headerKey
protected String | headerValue
protected String | leftTitle
protected String | multiple
protected String | removeAllLabel
protected String | removeLabel
protected String | rightTitle
private static long | serialVersionUID
protected String | size
protected String | upLabel
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
InputTransferSelectTag()
Method Summary
String | getAddLabel()
String | getAllowRemoveAll()
String | getAllowUpDown()
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getButtonCssClass()
String | getButtonCssStyle()
String | getDownLabel()
String | getHeaderKey()
String | getHeaderValue()
String | getLeftTitle()
String | getMultiple()
String | getRemoveAllLabel()
String | getRemoveLabel()
String | getRightTitle()
String | getSize()
String | getUpLabel()
protected void | populateParams()
void | setAddLabel(String addLabel)
void | setAllowRemoveAll(String allowRemoveAll)
void | setAllowUpDown(String allowUpDown)
void | setButtonCssClass(String buttonCssClass)
void | setButtonCssStyle(String buttonCssStyle)
void | setDownLabel(String downLabel)
void | setHeaderKey(String headerKey)
void | setHeaderValue(String headerValue)
void | setLeftTitle(String leftTitle)
void | setMultiple(String multiple)
void | setRemoveAllLabel(String removeAllLabel)
void | setRemoveLabel(String removeLabel)
void | setRightTitle(String rightTitle)
void | setSize(String size)
void | setUpLabel(String upLabel)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

size

protected String size

multiple

protected String multiple

allowRemoveAll

protected String allowRemoveAll

allowUpDown

protected String allowUpDown

leftTitle

protected String leftTitle

rightTitle

protected String rightTitle

buttonCssClass

protected String buttonCssClass

buttonCssStyle

protected String buttonCssStyle

addLabel

protected String addLabel

removeLabel

protected String removeLabel

removeAllLabel

protected String removeAllLabel

upLabel

protected String upLabel

downLabel

protected String downLabel

headerKey

protected String headerKey

headerValue

protected String headerValue
Constructor Detail

InputTransferSelectTag

public InputTransferSelectTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractListTag

getSize

public String getSize()

setSize

public void setSize(String size)

getMultiple

public String getMultiple()

setMultiple

public void setMultiple(String multiple)

getAllowRemoveAll

public String getAllowRemoveAll()

setAllowRemoveAll

public void setAllowRemoveAll(String allowRemoveAll)

getAllowUpDown

public String getAllowUpDown()

setAllowUpDown

public void setAllowUpDown(String allowUpDown)

getLeftTitle

public String getLeftTitle()

setLeftTitle

public void setLeftTitle(String leftTitle)

getRightTitle

public String getRightTitle()

setRightTitle

public void setRightTitle(String rightTitle)

getButtonCssClass

public String getButtonCssClass()

setButtonCssClass

public void setButtonCssClass(String buttonCssClass)

getButtonCssStyle

public String getButtonCssStyle()

setButtonCssStyle

public void setButtonCssStyle(String buttonCssStyle)

getAddLabel

public String getAddLabel()

setAddLabel

public void setAddLabel(String addLabel)

getRemoveLabel

public String getRemoveLabel()

setRemoveLabel

public void setRemoveLabel(String removeLabel)

getRemoveAllLabel

public String getRemoveAllLabel()

setRemoveAllLabel

public void setRemoveAllLabel(String removeAllLabel)

getUpLabel

public String getUpLabel()

setUpLabel

public void setUpLabel(String upLabel)

getDownLabel

public String getDownLabel()

setDownLabel

public void setDownLabel(String downLabel)

getHeaderKey

public String getHeaderKey()

setHeaderKey

public void setHeaderKey(String headerKey)

getHeaderValue

public String getHeaderValue()

setHeaderValue

public void setHeaderValue(String headerValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class LabelTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.LabelTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class LabelTag
extends AbstractUITag

See Also:
Label, Serialized Form

Field Summary
protected String | forAttr
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
LabelTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setFor(String aFor)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

forAttr

protected String forAttr
Constructor Detail

LabelTag

public LabelTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setFor

public void setFor(String aFor)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OgnlTool (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class OgnlTool

java.lang.Object
    extended by  org.apache.struts2.views.jsp.ui.OgnlTool

public class OgnlTool
extends Object

Field Summary
private static OgnlTool instance
Constructor Summary
private OgnlTool()
Method Summary
Object | findValue(String expr, Object context)
static OgnlTool | getInstance()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

instance

private static OgnlTool instance
Constructor Detail

OgnlTool

private OgnlTool()
Method Detail

getInstance

public static OgnlTool getInstance()

findValue

public Object findValue(String expr,
                        Object context)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptGroupTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class OptGroupTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.OptGroupTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class OptGroupTag
extends ComponentTagSupport

See Also:
Serialized Form

Field Summary
protected String | disabled
protected String | label
protected String | list
protected String | listKey
protected String | listValue
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
OptGroupTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setDisabled(String disabled)
void | setLabel(String label)
void | setList(String list)
void | setListKey(String listKey)
void | setListValue(String listValue)
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

list

protected String list

label

protected String label

disabled

protected String disabled

listKey

protected String listKey

listValue

protected String listValue
Constructor Detail

OptGroupTag

public OptGroupTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class ComponentTagSupport

setList

public void setList(String list)

setLabel

public void setLabel(String label)

setDisabled

public void setDisabled(String disabled)

setListKey

public void setListKey(String listKey)

setListValue

public void setListValue(String listValue)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptionTransferSelectTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class OptionTransferSelectTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                                extended by  org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
                                    extended by  org.apache.struts2.views.jsp.ui.OptionTransferSelectTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class OptionTransferSelectTag
extends AbstractDoubleListTag

OptionTransferSelect jsp tag.

See Also:
Serialized Form

Field Summary
protected String | addAllToLeftLabel
protected String | addAllToRightLabel
protected String | addToLeftLabel
protected String | addToRightLabel
protected String | allowAddAllToLeft
protected String | allowAddAllToRight
protected String | allowAddToLeft
protected String | allowAddToRight
protected String | allowSelectAll
protected String | allowUpDownOnLeft
protected String | allowUpDownOnRight
protected String | buttonCssClass
protected String | buttonCssStyle
protected String | leftDownLabel
protected String | leftTitle
protected String | leftUpLabel
protected String | rightDownLabel
protected String | rightTitle
protected String | rightUpLabel
protected String | selectAllLabel
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
doubleAccesskey, doubleCssClass, doubleCssStyle, doubleDisabled, doubleEmptyOption, doubleHeaderKey, doubleHeaderValue, doubleId, doubleList, doubleListKey, doubleListValue, doubleMultiple, doubleName, doubleOnblur, doubleOnchange, doubleOnclick, doubleOndblclick, doubleOnfocus, doubleOnkeydown, doubleOnkeypress, doubleOnkeyup, doubleOnmousedown, doubleOnmousemove, doubleOnmouseout, doubleOnmouseover, doubleOnmouseup, doubleOnselect, doubleSize, doubleValue, emptyOption, formName, headerKey, headerValue, multiple, size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
OptionTransferSelectTag()
Method Summary
String | getAddAllToLeftLabel()
String | getAddAllToRightLabel()
String | getAddToLeftLabel()
String | getAddToRightLabel()
String | getAllowAddAllToLeft()
String | getAllowAddAllToRight()
String | getAllowAddToLeft()
String | getAllowAddToRight()
String | getAllowSelectAll()
String | getAllowUpDownOnLeft()
String | getAllowUpDownOnRight()
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getButtonCssClass()
String | getButtonCssStyle()
String | getLeftDownLabel()
String | getLeftTitle()
String | getLeftUpLabel()
String | getRightDownLabel()
String | getRightTitle()
String | getRightUpLabel()
String | getSelectAllLabel()
protected void | populateParams()
void | setAddAllToLeftLabel(String addAllToLeftLabel)
void | setAddAllToRightLabel(String addAllToRightLabel)
void | setAddToLeftLabel(String addToLeftLabel)
void | setAddToRightLabel(String addToRightLabel)
void | setAllowAddAllToLeft(String allowAddAllToLeft)
void | setAllowAddAllToRight(String allowAddAllToRight)
void | setAllowAddToLeft(String allowAddToLeft)
void | setAllowAddToRight(String allowAddToRight)
void | setAllowSelectAll(String allowSelectAll)
void | setAllowUpDownOnLeft(String allowUpDownOnLeft)
void | setAllowUpDownOnRight(String allowUpDownOnRight)
void | setButtonCssClass(String buttonCssId)
void | setButtonCssStyle(String buttonCssStyle)
void | setLeftDownLabel(String leftDownLabel)
void | setLeftTitle(String leftTitle)
void | setLeftUpLabel(String leftUpLabel)
void | setRightDownLabel(String rightDownLabel)
void | setRightTitle(String rightTitle)
void | setRightUpLabel(String rightUpLabel)
void | setSelectAllLabel(String selectAllLabel)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag
getDoubleCssClass, getDoubleCssStyle, getDoubleDisabled, getDoubleEmptyOption, getDoubleHeaderKey, getDoubleHeaderValue, getDoubleId, getDoubleList, getDoubleListKey, getDoubleListValue, getDoubleMultiple, getDoubleName, getDoubleOnblur, getDoubleOnchange, getDoubleOnclick, getDoubleOndblclick, getDoubleOnfocus, getDoubleOnkeydown, getDoubleOnkeypress, getDoubleOnkeyup, getDoubleOnmousedown, getDoubleOnmousemove, getDoubleOnmouseout, getDoubleOnmouseover, getDoubleOnmouseup, getDoubleOnselect, getDoubleSize, getDoubleValue, getFormName, setDoubleAccesskey, setDoubleCssClass, setDoubleCssStyle, setDoubleDisabled, setDoubleEmptyOption, setDoubleHeaderKey, setDoubleHeaderValue, setDoubleId, setDoubleList, setDoubleListKey, setDoubleListValue, setDoubleMultiple, setDoubleName, setDoubleOnblur, setDoubleOnchange, setDoubleOnclick, setDoubleOndblclick, setDoubleOnfocus, setDoubleOnkeydown, setDoubleOnkeypress, setDoubleOnkeyup, setDoubleOnmousedown, setDoubleOnmousemove, setDoubleOnmouseout, setDoubleOnmouseover, setDoubleOnmouseup, setDoubleOnselect, setDoubleSize, setDoubleValue, setEmptyOption, setFormName, setHeaderKey, setHeaderValue, setMultiple, setSize
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

allowAddToLeft

protected String allowAddToLeft

allowAddToRight

protected String allowAddToRight

allowAddAllToLeft

protected String allowAddAllToLeft

allowAddAllToRight

protected String allowAddAllToRight

allowSelectAll

protected String allowSelectAll

allowUpDownOnLeft

protected String allowUpDownOnLeft

allowUpDownOnRight

protected String allowUpDownOnRight

leftTitle

protected String leftTitle

rightTitle

protected String rightTitle

buttonCssClass

protected String buttonCssClass

buttonCssStyle

protected String buttonCssStyle

addToLeftLabel

protected String addToLeftLabel

addToRightLabel

protected String addToRightLabel

addAllToLeftLabel

protected String addAllToLeftLabel

addAllToRightLabel

protected String addAllToRightLabel

selectAllLabel

protected String selectAllLabel

leftUpLabel

protected String leftUpLabel

leftDownLabel

protected String leftDownLabel

rightUpLabel

protected String rightUpLabel

rightDownLabel

protected String rightDownLabel
Constructor Detail

OptionTransferSelectTag

public OptionTransferSelectTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractDoubleListTag

getAddAllToLeftLabel

public String getAddAllToLeftLabel()

setAddAllToLeftLabel

public void setAddAllToLeftLabel(String addAllToLeftLabel)

getAddAllToRightLabel

public String getAddAllToRightLabel()

setAddAllToRightLabel

public void setAddAllToRightLabel(String addAllToRightLabel)

getAddToLeftLabel

public String getAddToLeftLabel()

setAddToLeftLabel

public void setAddToLeftLabel(String addToLeftLabel)

getAddToRightLabel

public String getAddToRightLabel()

setAddToRightLabel

public void setAddToRightLabel(String addToRightLabel)

getAllowAddAllToLeft

public String getAllowAddAllToLeft()

setAllowAddAllToLeft

public void setAllowAddAllToLeft(String allowAddAllToLeft)

getAllowAddAllToRight

public String getAllowAddAllToRight()

setAllowAddAllToRight

public void setAllowAddAllToRight(String allowAddAllToRight)

getAllowAddToLeft

public String getAllowAddToLeft()

setAllowAddToLeft

public void setAllowAddToLeft(String allowAddToLeft)

getAllowAddToRight

public String getAllowAddToRight()

setAllowAddToRight

public void setAllowAddToRight(String allowAddToRight)

getAllowUpDownOnLeft

public String getAllowUpDownOnLeft()

setAllowUpDownOnLeft

public void setAllowUpDownOnLeft(String allowUpDownOnLeft)

getAllowUpDownOnRight

public String getAllowUpDownOnRight()

setAllowUpDownOnRight

public void setAllowUpDownOnRight(String allowUpDownOnRight)

getLeftUpLabel

public String getLeftUpLabel()

setLeftUpLabel

public void setLeftUpLabel(String leftUpLabel)

getLeftDownLabel

public String getLeftDownLabel()

setLeftDownLabel

public void setLeftDownLabel(String leftDownLabel)

getRightUpLabel

public String getRightUpLabel()

setRightUpLabel

public void setRightUpLabel(String rightUpLabel)

getRightDownLabel

public String getRightDownLabel()

setRightDownLabel

public void setRightDownLabel(String rightDownLabel)

getLeftTitle

public String getLeftTitle()

setLeftTitle

public void setLeftTitle(String leftTitle)

getRightTitle

public String getRightTitle()

setRightTitle

public void setRightTitle(String rightTitle)

setAllowSelectAll

public void setAllowSelectAll(String allowSelectAll)

getAllowSelectAll

public String getAllowSelectAll()

setSelectAllLabel

public void setSelectAllLabel(String selectAllLabel)

getSelectAllLabel

public String getSelectAllLabel()

setButtonCssClass

public void setButtonCssClass(String buttonCssId)

getButtonCssClass

public String getButtonCssClass()

setButtonCssStyle

public void setButtonCssStyle(String buttonCssStyle)

getButtonCssStyle

public String getButtonCssStyle()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PasswordTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class PasswordTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.TextFieldTag
                            extended by  org.apache.struts2.views.jsp.ui.PasswordTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class PasswordTag
extends TextFieldTag

See Also:
Password, Serialized Form

Field Summary
private static long | serialVersionUID
protected String | showPassword
Fields inherited from class org.apache.struts2.views.jsp.ui.TextFieldTag
maxlength, readonly, size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
PasswordTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setShow(String showPassword)
void | setShowPassword(String showPassword)
Methods inherited from class org.apache.struts2.views.jsp.ui.TextFieldTag
setMaxlength, setMaxLength, setReadonly, setSize
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

showPassword

protected String showPassword
Constructor Detail

PasswordTag

public PasswordTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Overrides:
getBean in class TextFieldTag

populateParams

protected void populateParams()
Overrides:
populateParams in class TextFieldTag

setShow

public void setShow(String showPassword)

setShowPassword

public void setShowPassword(String showPassword)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RadioTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class RadioTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                                extended by  org.apache.struts2.views.jsp.ui.RadioTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class RadioTag
extends AbstractRequiredListTag

See Also:
Radio, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
RadioTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
populateParams
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

RadioTag

public RadioTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResetTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class ResetTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.ResetTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class ResetTag
extends AbstractUITag

See Also:
Reset, Serialized Form

Field Summary
protected String | action
protected String | align
protected String | method
private static long | serialVersionUID
protected String | type
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
ResetTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setAction(String action)
void | setAlign(String align)
void | setMethod(String method)
void | setType(String type)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

action

protected String action

method

protected String method

align

protected String align

type

protected String type
Constructor Detail

ResetTag

public ResetTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setAction

public void setAction(String action)

setMethod

public void setMethod(String method)

setAlign

public void setAlign(String align)

setType

public void setType(String type)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class SelectTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                                extended by  org.apache.struts2.views.jsp.ui.SelectTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
UpDownSelectTag
public class SelectTag
extends AbstractRequiredListTag

See Also:
Select, Serialized Form

Field Summary
protected String | emptyOption
protected String | headerKey
protected String | headerValue
protected String | multiple
private static long | serialVersionUID
protected String | size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
SelectTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setEmptyOption(String emptyOption)
void | setHeaderKey(String headerKey)
void | setHeaderValue(String headerValue)
void | setMultiple(String multiple)
void | setSize(String size)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

emptyOption

protected String emptyOption

headerKey

protected String headerKey

headerValue

protected String headerValue

multiple

protected String multiple

size

protected String size
Constructor Detail

SelectTag

public SelectTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractRequiredListTag

setEmptyOption

public void setEmptyOption(String emptyOption)

setHeaderKey

public void setHeaderKey(String headerKey)

setHeaderValue

public void setHeaderValue(String headerValue)

setMultiple

public void setMultiple(String multiple)

setSize

public void setSize(String size)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubmitTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class SubmitTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.SubmitTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class SubmitTag
extends AbstractUITag

See Also:
Submit, Serialized Form

Field Summary
protected String | action
protected String | afterLoading
protected String | align
protected String | beforeLoading
protected String | errorText
protected String | executeScripts
protected String | formFilter
protected String | formId
protected String | handler
protected String | href
protected String | indicator
protected String | listenTopics
protected String | loadingText
protected String | method
protected String | notifyTopics
private static long | serialVersionUID
protected String | showErrorTransportText
protected String | showLoadingText
protected String | src
protected String | targets
protected String | type
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
SubmitTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getType()
protected void | populateParams()
void | setAction(String action)
void | setAlign(String align)
void | setErrorText(String errorText)
void | setExecuteScripts(String executeScripts)
void | setFormFilter(String formFilter)
void | setFormId(String formId)
void | setHandler(String handler)
void | setHref(String href)
void | setIndicator(String indicator)
void | setListenTopics(String listenTopics)
void | setLoadingText(String loadingText)
void | setMethod(String method)
void | setNotifyTopics(String notifyTopics)
void | setOnLoadJS(String postJS) Deprecated.
void | setPreInvokeJS(String preJS) Deprecated.
void | setResultDivId(String id) Deprecated.
void | setShowErrorTransportText(String showErrorTransportText)
void | setShowLoadingText(String showLoadingText)
void | setSrc(String src)
void | setTargets(String targets)
void | setType(String type)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

action

protected String action

method

protected String method

align

protected String align

type

protected String type

href

protected String href

listenTopics

protected String listenTopics

notifyTopics

protected String notifyTopics

loadingText

protected String loadingText

errorText

protected String errorText

executeScripts

protected String executeScripts

handler

protected String handler

formId

protected String formId

formFilter

protected String formFilter

src

protected String src

showErrorTransportText

protected String showErrorTransportText

indicator

protected String indicator

showLoadingText

protected String showLoadingText

beforeLoading

protected String beforeLoading

afterLoading

protected String afterLoading

targets

protected String targets
Constructor Detail

SubmitTag

public SubmitTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setAction

public void setAction(String action)

setMethod

public void setMethod(String method)

setAlign

public void setAlign(String align)

getType

public String getType()

setType

public void setType(String type)

setHref

public void setHref(String href)

setErrorText

public void setErrorText(String errorText)

setLoadingText

public void setLoadingText(String loadingText)

setListenTopics

public void setListenTopics(String listenTopics)

setExecuteScripts

public void setExecuteScripts(String executeScripts)

setHandler

public void setHandler(String handler)

setFormFilter

public void setFormFilter(String formFilter)

setFormId

public void setFormId(String formId)

setSrc

public void setSrc(String src)

setTargets

public void setTargets(String targets)

setResultDivId

@Deprecated
public void setResultDivId(String id)
Deprecated.

setOnLoadJS

@Deprecated
public void setOnLoadJS(String postJS)
Deprecated.

setPreInvokeJS

@Deprecated
public void setPreInvokeJS(String preJS)
Deprecated.

setNotifyTopics

public void setNotifyTopics(String notifyTopics)

setShowErrorTransportText

public void setShowErrorTransportText(String showErrorTransportText)

setIndicator

public void setIndicator(String indicator)

setShowLoadingText

public void setShowLoadingText(String showLoadingText)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabbedPanelTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class TabbedPanelTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractClosingTag
                            extended by  org.apache.struts2.views.jsp.ui.TabbedPanelTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class TabbedPanelTag
extends AbstractClosingTag

See Also:
TabbedPanel, Serialized Form

Field Summary
private String | closeButton
private String | doLayout
private String | selectedTab
private static long | serialVersionUID
private String | templateCssPath
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
openTemplate
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TabbedPanelTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setCloseButton(String closeButton)
void | setDoLayout(String doLayout)
void | setSelectedTab(String selectedTab)
void | setTemplateCssPath(String templateCssPath)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
setOpenTemplate
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

selectedTab

private String selectedTab

closeButton

private String closeButton

doLayout

private String doLayout

templateCssPath

private String templateCssPath
Constructor Detail

TabbedPanelTag

public TabbedPanelTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractClosingTag

setSelectedTab

public void setSelectedTab(String selectedTab)

setCloseButton

public void setCloseButton(String closeButton)

setDoLayout

public void setDoLayout(String doLayout)

setTemplateCssPath

public void setTemplateCssPath(String templateCssPath)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextareaTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class TextareaTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.TextareaTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class TextareaTag
extends AbstractUITag

See Also:
TextArea, Serialized Form

Field Summary
protected String | cols
protected String | readonly
protected String | rows
private static long | serialVersionUID
protected String | wrap
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TextareaTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setCols(String cols)
void | setReadonly(String readonly)
void | setRows(String rows)
void | setWrap(String wrap)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

cols

protected String cols

readonly

protected String readonly

rows

protected String rows

wrap

protected String wrap
Constructor Detail

TextareaTag

public TextareaTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setCols

public void setCols(String cols)

setReadonly

public void setReadonly(String readonly)

setRows

public void setRows(String rows)

setWrap

public void setWrap(String wrap)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextFieldTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class TextFieldTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.TextFieldTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
Direct Known Subclasses:
ComboBoxTag, PasswordTag
public class TextFieldTag
extends AbstractUITag

See Also:
TextField, Serialized Form

Field Summary
protected String | maxlength
protected String | readonly
private static long | serialVersionUID
protected String | size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TextFieldTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setMaxlength(String maxlength)
void | setMaxLength(String maxlength) Deprecated. please use setMaxlength(java.lang.String) instead
void | setReadonly(String readonly)
void | setSize(String size)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

maxlength

protected String maxlength

readonly

protected String readonly

size

protected String size
Constructor Detail

TextFieldTag

public TextFieldTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setMaxLength

public void setMaxLength(String maxlength)
Deprecated. please use setMaxlength(java.lang.String) instead

setMaxlength

public void setMaxlength(String maxlength)

setReadonly

public void setReadonly(String readonly)

setSize

public void setSize(String size)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TokenTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class TokenTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.TokenTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class TokenTag
extends AbstractUITag

See Also:
Token, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TokenTag()
Method Summary
 Component getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
populateParams, setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

TokenTag

public TokenTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeNodeTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class TreeNodeTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractClosingTag
                            extended by  org.apache.struts2.views.jsp.ui.TreeNodeTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class TreeNodeTag
extends AbstractClosingTag

See Also:
TreeNode, Serialized Form

Field Summary
private static long serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
openTemplate
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TreeNodeTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
void | setLabel(String label)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
populateParams, setOpenTemplate
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

TreeNodeTag

public TreeNodeTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

setLabel

public void setLabel(String label)
Overrides:
setLabel in class AbstractUITag
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class TreeTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractClosingTag
                            extended by  org.apache.struts2.views.jsp.ui.TreeTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class TreeTag
extends AbstractClosingTag

See Also:
Tree, Serialized Form

Field Summary
private String | blankIconSrc
private String | childCollectionProperty
private String | expandIconSrcMinus
private String | expandIconSrcPlus
private String | gridIconSrcC
private String | gridIconSrcL
private String | gridIconSrcP
private String | gridIconSrcV
private String | gridIconSrcX
private String | gridIconSrcY
private String | iconHeight
private String | iconWidth
private String | nodeIdProperty
private String | nodeTitleProperty
private String | rootNode
private static long | serialVersionUID
private String | showGrid
private String | showRootGrid
private String | templateCssPath
private String | toggle
private String | toggleDuration
private String | treeCollapsedTopic
private String | treeExpandedTopic
private String | treeSelectedTopic
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
openTemplate
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
TreeTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBlankIconSrc()
String | getChildCollectionProperty()
String | getExpandIconSrcMinus()
String | getExpandIconSrcPlus()
String | getGridIconSrcC()
String | getGridIconSrcL()
String | getGridIconSrcP()
String | getGridIconSrcV()
String | getGridIconSrcX()
String | getGridIconSrcY()
String | getIconHeight()
String | getIconWidth()
String | getNodeIdProperty()
String | getNodeTitleProperty()
String | getRootNode()
String | getShowGrid()
String | getShowRootGrid()
String | getTemplateCssPath()
String | getToggle()
String | getToggleDuration()
String | getTreeCollapsedTopic()
String | getTreeExpandedTopic()
String | getTreeSelectedTopic()
protected void | populateParams()
void | setBlankIconSrc(String blankIconSrc)
void | setChildCollectionProperty(String childCollectionProperty)
void | setExpandIconSrcMinus(String expandIconSrcMinus)
void | setExpandIconSrcPlus(String expandIconSrcPlus)
void | setGridIconSrcC(String gridIconSrcC)
void | setGridIconSrcL(String gridIconSrcL)
void | setGridIconSrcP(String gridIconSrcP)
void | setGridIconSrcV(String gridIconSrcV)
void | setGridIconSrcX(String gridIconSrcX)
void | setGridIconSrcY(String gridIconSrcY)
void | setIconHeight(String iconHeight)
void | setIconWidth(String iconWidth)
void | setNodeIdProperty(String nodeIdProperty)
void | setNodeTitleProperty(String nodeTitleProperty)
void | setRootNode(String rootNode)
void | setShowGrid(String showGrid)
void | setShowRootGrid(String showRootGrid)
void | setTemplateCssPath(String templateCssPath)
void | setToggle(String toggle)
void | setToggleDuration(String toggleDuration)
void | setTreeCollapsedTopic(String treeCollapsedTopic)
void | setTreeExpandedTopic(String treeExpandedTopic)
void | setTreeSelectedTopic(String treeSelectedTopic)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractClosingTag
setOpenTemplate
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

toggle

private String toggle

treeSelectedTopic

private String treeSelectedTopic

treeExpandedTopic

private String treeExpandedTopic

treeCollapsedTopic

private String treeCollapsedTopic

rootNode

private String rootNode

childCollectionProperty

private String childCollectionProperty

nodeTitleProperty

private String nodeTitleProperty

nodeIdProperty

private String nodeIdProperty

showRootGrid

private String showRootGrid

showGrid

private String showGrid

blankIconSrc

private String blankIconSrc

gridIconSrcL

private String gridIconSrcL

gridIconSrcV

private String gridIconSrcV

gridIconSrcP

private String gridIconSrcP

gridIconSrcC

private String gridIconSrcC

gridIconSrcX

private String gridIconSrcX

gridIconSrcY

private String gridIconSrcY

expandIconSrcPlus

private String expandIconSrcPlus

expandIconSrcMinus

private String expandIconSrcMinus

iconWidth

private String iconWidth

iconHeight

private String iconHeight

toggleDuration

private String toggleDuration

templateCssPath

private String templateCssPath
Constructor Detail

TreeTag

public TreeTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Specified by:
getBean in class ComponentTagSupport

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractClosingTag

getToggle

public String getToggle()

setToggle

public void setToggle(String toggle)

getTreeSelectedTopic

public String getTreeSelectedTopic()

setTreeSelectedTopic

public void setTreeSelectedTopic(String treeSelectedTopic)

getTreeExpandedTopic

public String getTreeExpandedTopic()

setTreeExpandedTopic

public void setTreeExpandedTopic(String treeExpandedTopic)

getTreeCollapsedTopic

public String getTreeCollapsedTopic()

setTreeCollapsedTopic

public void setTreeCollapsedTopic(String treeCollapsedTopic)

getRootNode

public String getRootNode()

setRootNode

public void setRootNode(String rootNode)

getChildCollectionProperty

public String getChildCollectionProperty()

setChildCollectionProperty

public void setChildCollectionProperty(String childCollectionProperty)

getNodeTitleProperty

public String getNodeTitleProperty()

setNodeTitleProperty

public void setNodeTitleProperty(String nodeTitleProperty)

getNodeIdProperty

public String getNodeIdProperty()

setNodeIdProperty

public void setNodeIdProperty(String nodeIdProperty)

getShowRootGrid

public String getShowRootGrid()

setShowRootGrid

public void setShowRootGrid(String showRootGrid)

getBlankIconSrc

public String getBlankIconSrc()

setBlankIconSrc

public void setBlankIconSrc(String blankIconSrc)

getExpandIconSrcMinus

public String getExpandIconSrcMinus()

setExpandIconSrcMinus

public void setExpandIconSrcMinus(String expandIconSrcMinus)

getExpandIconSrcPlus

public String getExpandIconSrcPlus()

setExpandIconSrcPlus

public void setExpandIconSrcPlus(String expandIconSrcPlus)

getGridIconSrcC

public String getGridIconSrcC()

setGridIconSrcC

public void setGridIconSrcC(String gridIconSrcC)

getGridIconSrcL

public String getGridIconSrcL()

setGridIconSrcL

public void setGridIconSrcL(String gridIconSrcL)

getGridIconSrcP

public String getGridIconSrcP()

setGridIconSrcP

public void setGridIconSrcP(String gridIconSrcP)

getGridIconSrcV

public String getGridIconSrcV()

setGridIconSrcV

public void setGridIconSrcV(String gridIconSrcV)

getGridIconSrcX

public String getGridIconSrcX()

setGridIconSrcX

public void setGridIconSrcX(String gridIconSrcX)

getGridIconSrcY

public String getGridIconSrcY()

setGridIconSrcY

public void setGridIconSrcY(String gridIconSrcY)

getIconHeight

public String getIconHeight()

setIconHeight

public void setIconHeight(String iconHeight)

getIconWidth

public String getIconWidth()

setIconWidth

public void setIconWidth(String iconWidth)

getTemplateCssPath

public String getTemplateCssPath()

setTemplateCssPath

public void setTemplateCssPath(String templateCssPath)

getToggleDuration

public String getToggleDuration()

setToggleDuration

public void setToggleDuration(String toggleDuration)

getShowGrid

public String getShowGrid()

setShowGrid

public void setShowGrid(String showGrid)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpDownSelectTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui
Class UpDownSelectTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.AbstractListTag
                            extended by  org.apache.struts2.views.jsp.ui.AbstractRequiredListTag
                                extended by  org.apache.struts2.views.jsp.ui.SelectTag
                                    extended by  org.apache.struts2.views.jsp.ui.UpDownSelectTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class UpDownSelectTag
extends SelectTag

See Also:
UpDownSelect, Serialized Form

Field Summary
protected String | allowMoveDown
protected String | allowMoveUp
protected String | allowSelectAll
protected String | moveDownLabel
protected String | moveUpLabel
protected String | selectAllLabel
private static long | serialVersionUID
Fields inherited from class org.apache.struts2.views.jsp.ui.SelectTag
emptyOption, headerKey, headerValue, multiple, size
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
list, listKey, listValue
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
UpDownSelectTag()
Method Summary
String | getAllowMoveDown()
String | getAllowMoveUp()
String | getAllowSelectAll()
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getMoveDownLabel()
String | getMoveUpLabel()
String | getSelectAllLabel()
protected void | populateParams()
void | setAllowMoveDown(String allowMoveDown)
void | setAllowMoveUp(String allowMoveUp)
void | setAllowSelectAll(String allowSelectAll)
void | setMoveDownLabel(String moveDownLabel)
void | setMoveUpLabel(String moveUpLabel)
void | setSelectAllLabel(String selectAllLabel)
Methods inherited from class org.apache.struts2.views.jsp.ui.SelectTag
setEmptyOption, setHeaderKey, setHeaderValue, setMultiple, setSize
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractListTag
setList, setListKey, setListValue
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

allowMoveUp

protected String allowMoveUp

allowMoveDown

protected String allowMoveDown

allowSelectAll

protected String allowSelectAll

moveUpLabel

protected String moveUpLabel

moveDownLabel

protected String moveDownLabel

selectAllLabel

protected String selectAllLabel
Constructor Detail

UpDownSelectTag

public UpDownSelectTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Overrides:
getBean in class SelectTag

populateParams

protected void populateParams()
Overrides:
populateParams in class SelectTag

getAllowMoveUp

public String getAllowMoveUp()

setAllowMoveUp

public void setAllowMoveUp(String allowMoveUp)

getAllowMoveDown

public String getAllowMoveDown()

setAllowMoveDown

public void setAllowMoveDown(String allowMoveDown)

getAllowSelectAll

public String getAllowSelectAll()

setAllowSelectAll

public void setAllowSelectAll(String allowSelectAll)

getMoveUpLabel

public String getMoveUpLabel()

setMoveUpLabel

public void setMoveUpLabel(String moveUpLabel)

getMoveDownLabel

public String getMoveDownLabel()

setMoveDownLabel

public void setMoveDownLabel(String moveDownLabel)

getSelectAllLabel

public String getSelectAllLabel()

setSelectAllLabel

public void setSelectAllLabel(String selectAllLabel)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.jsp.ui.table (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.jsp.ui.table

JSP UI tags for modeling tables.

See:
Description

Class Summary
WebTableTag

Package org.apache.struts2.views.jsp.ui.table Description

JSP UI tags for modeling tables.


org.apache.struts2.views.jsp.ui.table Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.jsp.ui.table

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • org.apache.struts2.views.jsp.StrutsBodyTagSupport
          • org.apache.struts2.views.jsp.ComponentTagSupport
            • org.apache.struts2.views.jsp.ui.AbstractUITag
              • org.apache.struts2.views.jsp.ui.ComponentTag
                • org.apache.struts2.views.jsp.ui.table.WebTableTag


Uses of Package org.apache.struts2.views.jsp.ui.table (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.jsp.ui.table

No usage of org.apache.struts2.views.jsp.ui.table

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


WebTableTag (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.jsp.ui.table
Class WebTableTag

java.lang.Object
    extended by  javax.servlet.jsp.tagext.TagSupport
        extended by  javax.servlet.jsp.tagext.BodyTagSupport
            extended by  org.apache.struts2.views.jsp.StrutsBodyTagSupport
                extended by  org.apache.struts2.views.jsp.ComponentTagSupport
                    extended by  org.apache.struts2.views.jsp.ui.AbstractUITag
                        extended by  org.apache.struts2.views.jsp.ui.ComponentTag
                            extended by  org.apache.struts2.views.jsp.ui.table.WebTableTag
All Implemented Interfaces:
Serializable, BodyTag, IterationTag, JspTag, Tag
public class WebTableTag
extends ComponentTag

See Also:
WebTable, Serialized Form

Field Summary
protected String | modelName
private static long | serialVersionUID
protected boolean | sortable
protected int | sortColumn
protected String | sortOrder
Fields inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
accesskey, cssClass, cssStyle, disabled, key, label, labelPosition, name, onblur, onchange, onclick, ondblclick, onfocus, onkeydown, onkeypress, onkeyup, onmousedown, onmousemove, onmouseout, onmouseover, onmouseup, onselect, required, requiredposition, tabindex, template, templateDir, theme, title, tooltip, tooltipConfig, value
Fields inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
component
Fields inherited from class javax.servlet.jsp.tagext.BodyTagSupport
bodyContent
Fields inherited from class javax.servlet.jsp.tagext.TagSupport
id, pageContext
Fields inherited from interface javax.servlet.jsp.tagext.BodyTag
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
Fields inherited from interface javax.servlet.jsp.tagext.IterationTag
EVAL_BODY_AGAIN
Fields inherited from interface javax.servlet.jsp.tagext.Tag
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
Constructor Summary
WebTableTag()
Method Summary
Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected void | populateParams()
void | setModelName(String modelName)
void | setSortable(boolean sortable)
void | setSortColumn(int sortColumn)
void | setSortOrder(String sortOrder)
Methods inherited from class org.apache.struts2.views.jsp.ui.AbstractUITag
setAccesskey, setCssClass, setCssStyle, setDisabled, setKey, setLabel, setLabelposition, setName, setOnblur, setOnchange, setOnclick, setOndblclick, setOnfocus, setOnkeydown, setOnkeypress, setOnkeyup, setOnmousedown, setOnmousemove, setOnmouseout, setOnmouseover, setOnmouseup, setOnselect, setRequired, setRequiredposition, setTabindex, setTemplate, setTemplateDir, setTheme, setTitle, setTooltip, setTooltipConfig, setValue
Methods inherited from class org.apache.struts2.views.jsp.ComponentTagSupport
doEndTag, doStartTag, getComponent
Methods inherited from class org.apache.struts2.views.jsp.StrutsBodyTagSupport
altSyntax, findString, findValue, findValue, getBody, getStack, setId, toString, translateVariables
Methods inherited from class javax.servlet.jsp.tagext.BodyTagSupport
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
Methods inherited from class javax.servlet.jsp.tagext.TagSupport
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setPageContext, setParent, setValue
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface javax.servlet.jsp.tagext.Tag
getParent, setPageContext, setParent

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

sortOrder

protected String sortOrder

modelName

protected String modelName

sortable

protected boolean sortable

sortColumn

protected int sortColumn
Constructor Detail

WebTableTag

public WebTableTag()
Method Detail

getBean

public Component getBean(ValueStack stack,
                         HttpServletRequest req,
                         HttpServletResponse res)
Overrides:
getBean in class ComponentTag

populateParams

protected void populateParams()
Overrides:
populateParams in class AbstractUITag

setSortOrder

public void setSortOrder(String sortOrder)

setModelName

public void setModelName(String modelName)

setSortable

public void setSortable(boolean sortable)

setSortColumn

public void setSortColumn(int sortColumn)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.util (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.util

Miscellaneous helper classes for all views.

See:
Description

Class Summary
ContextUtil | Value Stack's Context related Utilities.
ResourceUtil |
TextUtil | This class handles HTML escaping of text.
UrlHelper | UrlHelper

Package org.apache.struts2.views.util Description

Miscellaneous helper classes for all views.


org.apache.struts2.views.util Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.util

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.views.util.ContextUtil
    • org.apache.struts2.views.util.ResourceUtil
    • org.apache.struts2.views.util.TextUtil
    • org.apache.struts2.views.util.UrlHelper


Uses of Package org.apache.struts2.views.util (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.util

No usage of org.apache.struts2.views.util

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ContextUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.util
Class ContextUtil

java.lang.Object
    extended by  org.apache.struts2.views.util.ContextUtil

public class ContextUtil
extends Object

Value Stack's Context related Utilities.

Field Summary
static String | ACTION
static boolean | altSyntax
static String | BASE
static String | OGNL
static String | REQUEST
static String | REQUEST2
static String | RESPONSE
static String | RESPONSE2
static String | SESSION
static String | STACK
static String | STRUTS
Constructor Summary
ContextUtil()
Method Summary
static Map | getStandardContext(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
static String | getTemplateSuffix(Map context) Returns a String for overriding the default templateSuffix if templateSuffix is on the stack
static boolean | isUseAltSyntax(Map context) Return true if either Configuration's altSyntax is on or the stack context's useAltSyntax is on
static void | setAltSyntax(String val)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

REQUEST

public static final String REQUEST
See Also:
Constant Field Values

REQUEST2

public static final String REQUEST2
See Also:
Constant Field Values

RESPONSE

public static final String RESPONSE
See Also:
Constant Field Values

RESPONSE2

public static final String RESPONSE2
See Also:
Constant Field Values

SESSION

public static final String SESSION
See Also:
Constant Field Values

BASE

public static final String BASE
See Also:
Constant Field Values

STACK

public static final String STACK
See Also:
Constant Field Values

OGNL

public static final String OGNL
See Also:
Constant Field Values

STRUTS

public static final String STRUTS
See Also:
Constant Field Values

ACTION

public static final String ACTION
See Also:
Constant Field Values

altSyntax

public static boolean altSyntax
Constructor Detail

ContextUtil

public ContextUtil()
Method Detail

setAltSyntax

public static void setAltSyntax(String val)

getStandardContext

public static Map getStandardContext(ValueStack stack,
                                     HttpServletRequest req,
                                     HttpServletResponse res)

isUseAltSyntax

public static boolean isUseAltSyntax(Map context)
Return true if either Configuration's altSyntax is on or the stack context's useAltSyntax is on

Parameters:
context - stack's context
Returns:
boolean

getTemplateSuffix

public static String getTemplateSuffix(Map context)
Returns a String for overriding the default templateSuffix if templateSuffix is on the stack

Parameters:
context - stack's context
Returns:
String
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ResourceUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.util
Class ResourceUtil

java.lang.Object
    extended by  org.apache.struts2.views.util.ResourceUtil

public class ResourceUtil
extends Object

Constructor Summary
ResourceUtil()
Method Summary
static String getResourceBase(HttpServletRequest req)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResourceUtil

public ResourceUtil()
Method Detail

getResourceBase

public static String getResourceBase(HttpServletRequest req)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextUtil (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.util
Class TextUtil

java.lang.Object
    extended by  org.apache.struts2.views.util.TextUtil

public class TextUtil
extends Object

This class handles HTML escaping of text. It was written and optimized to be as fast as possible.

Field Summary
protected static char[][] | _stringChars We use arrays of char in the lookup table because it is faster appending this to a StringBuffer than appending a String
protected static int | MAX_LENGTH
Constructor Summary
TextUtil()
Method Summary
protected static void | addMapping(int c, String txt, String[] strings)
static String | escapeHTML(String s) Call escapeHTML(s, false)
static String | escapeHTML(String s, boolean escapeEmpty) Escape HTML.
protected static void | initMapping()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

MAX_LENGTH

protected static final int MAX_LENGTH
See Also:
Constant Field Values

_stringChars

protected static final char[][] _stringChars
We use arrays of char in the lookup table because it is faster appending this to a StringBuffer than appending a String

Constructor Detail

TextUtil

public TextUtil()
Method Detail

escapeHTML

public static final String escapeHTML(String s)
Call escapeHTML(s, false)

escapeHTML

public static final String escapeHTML(String s,
                                      boolean escapeEmpty)
Escape HTML.

Parameters:
s - string to be escaped
escapeEmpty - if true, then empty string will be escaped.

addMapping

protected static void addMapping(int c,
                                 String txt,
                                 String[] strings)

initMapping

protected static void initMapping()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UrlHelper (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.util
Class UrlHelper

java.lang.Object
    extended by  org.apache.struts2.views.util.UrlHelper

public class UrlHelper
extends Object

UrlHelper

Field Summary
private static String | AMP
private static String | customEncoding
private static int | DEFAULT_HTTP_PORT Default HTTP port (80).
private static int | DEFAULT_HTTPS_PORT Default HTTPS port (443).
private static int | httpPort
private static int | httpsPort
private static Log | LOG
Constructor Summary
UrlHelper()
Method Summary
static void | buildParametersString(Map params, StringBuffer link)
static void | buildParametersString(Map params, StringBuffer link, String paramSeparator)
static String | buildUrl(String action, HttpServletRequest request, HttpServletResponse response, Map params)
static String | buildUrl(String action, HttpServletRequest request, HttpServletResponse response, Map params, String scheme, boolean includeContext, boolean encodeResult)
static String | buildUrl(String action, HttpServletRequest request, HttpServletResponse response, Map params, String scheme, boolean includeContext, boolean encodeResult, boolean forceAddSchemeHostAndPort)
private static String | getEncodingFromConfiguration()
static Map | parseQueryString(String queryString)
static void | setCustomEncoding(String val)
static void | setHttpPort(String val)
static void | setHttpsPort(String val)
static String | translateAndDecode(String input)
static String | translateAndEncode(String input) Translates any script expressions using TextParseUtil.translateVariables(java.lang.String, com.opensymphony.xwork2.util.ValueStack) and encodes the URL using URLEncoder.encode(java.lang.String) with the encoding specified in the configuration.
private static String | translateVariable(String input)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LOG

private static final Log LOG

DEFAULT_HTTP_PORT

private static final int DEFAULT_HTTP_PORT
Default HTTP port (80).

See Also:
Constant Field Values

DEFAULT_HTTPS_PORT

private static final int DEFAULT_HTTPS_PORT
Default HTTPS port (443).

See Also:
Constant Field Values

AMP

private static final String AMP
See Also:
Constant Field Values

httpPort

private static int httpPort

httpsPort

private static int httpsPort

customEncoding

private static String customEncoding
Constructor Detail

UrlHelper

public UrlHelper()
Method Detail

setHttpPort

public static void setHttpPort(String val)

setHttpsPort

public static void setHttpsPort(String val)

setCustomEncoding

public static void setCustomEncoding(String val)

buildUrl

public static String buildUrl(String action,
                              HttpServletRequest request,
                              HttpServletResponse response,
                              Map params)

buildUrl

public static String buildUrl(String action,
                              HttpServletRequest request,
                              HttpServletResponse response,
                              Map params,
                              String scheme,
                              boolean includeContext,
                              boolean encodeResult)

buildUrl

public static String buildUrl(String action,
                              HttpServletRequest request,
                              HttpServletResponse response,
                              Map params,
                              String scheme,
                              boolean includeContext,
                              boolean encodeResult,
                              boolean forceAddSchemeHostAndPort)

buildParametersString

public static void buildParametersString(Map params,
                                         StringBuffer link)

buildParametersString

public static void buildParametersString(Map params,
                                         StringBuffer link,
                                         String paramSeparator)

translateAndEncode

public static String translateAndEncode(String input)
Translates any script expressions using TextParseUtil.translateVariables(java.lang.String, com.opensymphony.xwork2.util.ValueStack) and encodes the URL using URLEncoder.encode(java.lang.String) with the encoding specified in the configuration.

Parameters:
input -
Returns:
the translated and encoded string

translateAndDecode

public static String translateAndDecode(String input)

translateVariable

private static String translateVariable(String input)

getEncodingFromConfiguration

private static String getEncodingFromConfiguration()

parseQueryString

public static Map parseQueryString(String queryString)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.velocity (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.velocity

Classes for views using Velocity.

See:
Description

Class Summary
StrutsResourceLoader | Loads resource from the Thread's context ClassLoader.
StrutsVelocityContext |
VelocityManager | Manages the environment for Velocity result types

Package org.apache.struts2.views.velocity Description

Classes for views using Velocity.


org.apache.struts2.views.velocity Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.velocity

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.velocity.context.AbstractContext (implements org.apache.velocity.context.Context, java.io.Serializable)
      • org.apache.velocity.VelocityContext (implements java.lang.Cloneable)
        • org.apache.struts2.views.velocity.StrutsVelocityContext
    • org.apache.velocity.runtime.resource.loader.ResourceLoader
      • org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader
        • org.apache.struts2.views.velocity.StrutsResourceLoader
    • org.apache.struts2.views.velocity.VelocityManager


Uses of Package org.apache.struts2.views.velocity (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.velocity

Packages that use org.apache.struts2.views.velocity
org.apache.struts2.components.template |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.portlet.result |

Classes in org.apache.struts2.views.velocity used by org.apache.struts2.components.template
VelocityManager
Manages the environment for Velocity result types

Classes in org.apache.struts2.views.velocity used by org.apache.struts2.dispatcher
VelocityManager
Manages the environment for Velocity result types

Classes in org.apache.struts2.views.velocity used by org.apache.struts2.portlet.result
VelocityManager
Manages the environment for Velocity result types

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


StrutsResourceLoader (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity
Class StrutsResourceLoader

java.lang.Object
    extended by  org.apache.velocity.runtime.resource.loader.ResourceLoader
        extended by  org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader
            extended by  org.apache.struts2.views.velocity.StrutsResourceLoader

public class StrutsResourceLoader
extends org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader

Loads resource from the Thread's context ClassLoader.

Field Summary
Fields inherited from class org.apache.velocity.runtime.resource.loader.ResourceLoader
className, isCachingOn, modificationCheckInterval, rsvc
Constructor Summary
StrutsResourceLoader()
Method Summary
 InputStream getResourceStream(String name)
Methods inherited from class org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader
getLastModified, init, isSourceModified
Methods inherited from class org.apache.velocity.runtime.resource.loader.ResourceLoader
commonInit, getClassName, getModificationCheckInterval, isCachingOn, setCachingOn, setModificationCheckInterval
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

StrutsResourceLoader

public StrutsResourceLoader()
Method Detail

getResourceStream

public InputStream getResourceStream(String name)
                              throws org.apache.velocity.exception.ResourceNotFoundException
Overrides:
getResourceStream in class org.apache.velocity.runtime.resource.loader.ClasspathResourceLoader
Throws:
org.apache.velocity.exception.ResourceNotFoundException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


StrutsVelocityContext (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity
Class StrutsVelocityContext

java.lang.Object
    extended by  org.apache.velocity.context.AbstractContext
        extended by  org.apache.velocity.VelocityContext
            extended by  org.apache.struts2.views.velocity.StrutsVelocityContext
All Implemented Interfaces:
Serializable, Cloneable, org.apache.velocity.context.Context, org.apache.velocity.context.InternalEventContext
public class StrutsVelocityContext
extends org.apache.velocity.VelocityContext

See Also:
Serialized Form

Field Summary
(package private) org.apache.velocity.VelocityContext[] | chainedContexts
private static long | serialVersionUID
(package private) ValueStack | stack
Constructor Summary
StrutsVelocityContext(ValueStack stack)
StrutsVelocityContext(org.apache.velocity.VelocityContext[] chainedContexts, ValueStack stack)
Method Summary
org.apache.velocity.app.event.EventCartridge | attachEventCartridge(org.apache.velocity.app.event.EventCartridge arg0)
org.apache.velocity.runtime.resource.Resource | getCurrentResource()
String | getCurrentTemplateName()
org.apache.velocity.app.event.EventCartridge | getEventCartridge()
Object[] | getTemplateNameStack()
org.apache.velocity.util.introspection.IntrospectionCacheData | icacheGet(Object arg0)
void | icachePut(Object arg0, org.apache.velocity.util.introspection.IntrospectionCacheData arg1)
boolean | internalContainsKey(Object key)
Object | internalGet(String key)
void | popCurrentTemplateName()
void | pushCurrentTemplateName(String arg0)
void | setCurrentResource(org.apache.velocity.runtime.resource.Resource arg0)
Methods inherited from class org.apache.velocity.VelocityContext
clone, internalGetKeys, internalPut, internalRemove
Methods inherited from class org.apache.velocity.context.AbstractContext
containsKey, get, getChainedContext, getKeys, put, remove
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

stack

ValueStack stack

chainedContexts

org.apache.velocity.VelocityContext[] chainedContexts
Constructor Detail

StrutsVelocityContext

public StrutsVelocityContext(ValueStack stack)

StrutsVelocityContext

public StrutsVelocityContext(org.apache.velocity.VelocityContext[] chainedContexts,
                             ValueStack stack)
Method Detail

internalContainsKey

public boolean internalContainsKey(Object key)
Overrides:
internalContainsKey in class org.apache.velocity.VelocityContext

internalGet

public Object internalGet(String key)
Overrides:
internalGet in class org.apache.velocity.VelocityContext

pushCurrentTemplateName

public void pushCurrentTemplateName(String arg0)

popCurrentTemplateName

public void popCurrentTemplateName()

getCurrentTemplateName

public String getCurrentTemplateName()

getTemplateNameStack

public Object[] getTemplateNameStack()

icacheGet

public org.apache.velocity.util.introspection.IntrospectionCacheData icacheGet(Object arg0)

icachePut

public void icachePut(Object arg0,
                      org.apache.velocity.util.introspection.IntrospectionCacheData arg1)

setCurrentResource

public void setCurrentResource(org.apache.velocity.runtime.resource.Resource arg0)

getCurrentResource

public org.apache.velocity.runtime.resource.Resource getCurrentResource()

attachEventCartridge

public org.apache.velocity.app.event.EventCartridge attachEventCartridge(org.apache.velocity.app.event.EventCartridge arg0)
Specified by:
attachEventCartridge in interface org.apache.velocity.context.InternalEventContext

getEventCartridge

public org.apache.velocity.app.event.EventCartridge getEventCartridge()
Specified by:
getEventCartridge in interface org.apache.velocity.context.InternalEventContext
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VelocityManager (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity
Class VelocityManager

java.lang.Object
    extended by  org.apache.struts2.views.velocity.VelocityManager

public class VelocityManager
extends Object

Manages the environment for Velocity result types

Field Summary
private String[] | chainedContextNames Names of contexts that will be chained on every request
private String | customConfigFile
private static Log | log
private ObjectFactory | objectFactory
static String | PARENT the parent JSP tag
static String | STRUTS
static String | TAG the current JSP tag
private List<TagLibrary> | tagLibraries
private String | toolBoxLocation
protected org.apache.velocity.tools.view.ToolboxManager | toolboxManager A reference to the toolbox manager.
private org.apache.velocity.app.VelocityEngine | velocityEngine
private Properties | velocityProperties
Constructor Summary
VelocityManager()
Method Summary
private void | addDirective(StringBuffer sb, Class clazz)
private void | applyDefaultConfiguration(ServletContext context, Properties p) once we've loaded up the user defined configurations, we will want to apply Struts specification configurations.
org.apache.velocity.context.Context | createContext(ValueStack stack, HttpServletRequest req, HttpServletResponse res) This method is responsible for creating the standard VelocityContext used by all WW2 velocity views.
org.apache.velocity.app.VelocityEngine | getVelocityEngine()
Properties | getVelocityProperties()
void | init(ServletContext context) initializes the VelocityManager.
protected void | initToolbox(ServletContext context) Initializes the ServletToolboxManager for this servlet's toolbox (if any).
Properties | loadConfiguration(ServletContext context) load optional velocity properties using the following loading strategy relative to the servlet context path relative to the WEB-INF directory on the classpath
protected org.apache.velocity.app.VelocityEngine | newVelocityEngine(ServletContext context) Instantiates a new VelocityEngine.
protected org.apache.velocity.VelocityContext[] | prepareChainedContexts(HttpServletRequest servletRequest, HttpServletResponse servletResponse, Map extraContext) constructs contexts for chaining on this request.
private static String | replace(String string, String oldString, String newString)
void | setChainedContexts(String contexts) allow users to specify via the struts.properties file a set of additional VelocityContexts to chain to the the StrutsVelocityContext.
void | setContainer(Container container)
void | setCustomConfigFile(String val)
void | setObjectFactory(ObjectFactory fac)
void | setToolBoxLocation(String toolboxLocation)
void | setVelocityProperties(Properties velocityProperties)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private static final Log log

STRUTS

public static final String STRUTS
See Also:
Constant Field Values

objectFactory

private ObjectFactory objectFactory

PARENT

public static final String PARENT
the parent JSP tag

See Also:
Constant Field Values

TAG

public static final String TAG
the current JSP tag

See Also:
Constant Field Values

velocityEngine

private org.apache.velocity.app.VelocityEngine velocityEngine

toolboxManager

protected org.apache.velocity.tools.view.ToolboxManager toolboxManager
A reference to the toolbox manager.

toolBoxLocation

private String toolBoxLocation

chainedContextNames

private String[] chainedContextNames
Names of contexts that will be chained on every request

velocityProperties

private Properties velocityProperties

customConfigFile

private String customConfigFile

tagLibraries

private List<TagLibrary> tagLibraries
Constructor Detail

VelocityManager

public VelocityManager()
Method Detail

setObjectFactory

public void setObjectFactory(ObjectFactory fac)

setContainer

public void setContainer(Container container)

getVelocityEngine

public org.apache.velocity.app.VelocityEngine getVelocityEngine()
Returns:
a reference to the VelocityEngine used by all struts velocity thingies with the exception of directly accessed *.vm pages

createContext

public org.apache.velocity.context.Context createContext(ValueStack stack,
                                                         HttpServletRequest req,
                                                         HttpServletResponse res)
This method is responsible for creating the standard VelocityContext used by all WW2 velocity views. The following context parameters are defined:

  • request - the current HttpServletRequest
  • response - the current HttpServletResponse
  • stack - the current ValueStack
  • ognl - an OgnlTool
  • struts - an instance of StrutsUtil
  • action - the current Struts action

Returns:
a new StrutsVelocityContext

prepareChainedContexts

protected org.apache.velocity.VelocityContext[] prepareChainedContexts(HttpServletRequest servletRequest,
                                                                       HttpServletResponse servletResponse,
                                                                       Map extraContext)
constructs contexts for chaining on this request. This method does not perform any initialization of the contexts. All that must be done in the context itself.

Parameters:
servletRequest -
servletResponse -
extraContext -
Returns:
an VelocityContext[] of contexts to chain

init

public void init(ServletContext context)
initializes the VelocityManager. this should be called during the initialization process, say by ServletDispatcher. this may be called multiple times safely although calls beyond the first won't do anything

Parameters:
context - the current servlet context

loadConfiguration

public Properties loadConfiguration(ServletContext context)
load optional velocity properties using the following loading strategy
  • relative to the servlet context path
  • relative to the WEB-INF directory
  • on the classpath

Parameters:
context - the current ServletContext. may not be null
Returns:
the optional properties if struts.velocity.configfile was specified, an empty Properties file otherwise

setCustomConfigFile

public void setCustomConfigFile(String val)

setToolBoxLocation

public void setToolBoxLocation(String toolboxLocation)

setChainedContexts

public void setChainedContexts(String contexts)
allow users to specify via the struts.properties file a set of additional VelocityContexts to chain to the the StrutsVelocityContext. The intent is to allow these contexts to store helper objects that the ui developer may want access to. Examples of reasonable VelocityContexts would be an IoCVelocityContext, a SpringReferenceVelocityContext, and a ToolboxVelocityContext

initToolbox

protected void initToolbox(ServletContext context)
Initializes the ServletToolboxManager for this servlet's toolbox (if any).

newVelocityEngine

protected org.apache.velocity.app.VelocityEngine newVelocityEngine(ServletContext context)

Instantiates a new VelocityEngine.

The following is the default Velocity configuration

  resource.loader = file, class
  file.resource.loader.path = real path of webapp
  class.resource.loader.description = Velocity Classpath Resource Loader
  class.resource.loader.class = org.apache.struts2.views.velocity.StrutsResourceLoader

this default configuration can be overridden by specifying a struts.velocity.configfile property in the struts.properties file. the specified config file will be searched for in the following order:

  • relative to the servlet context path
  • relative to the WEB-INF directory
  • on the classpath

Parameters:
context - the current ServletContext. may not be null

applyDefaultConfiguration

private void applyDefaultConfiguration(ServletContext context,
                                       Properties p)
once we've loaded up the user defined configurations, we will want to apply Struts specification configurations.
  • if Velocity.RESOURCE_LOADER has not been defined, then we will use the defaults which is a joined file, class loader for unpackaed wars and a straight class loader otherwise
  • we need to define the various Struts custom user directives such as #param, #tag, and #bodytag

Parameters:
context -
p -

addDirective

private void addDirective(StringBuffer sb,
                          Class clazz)

replace

private static final String replace(String string,
                                    String oldString,
                                    String newString)

getVelocityProperties

public Properties getVelocityProperties()
Returns:
the velocityProperties

setVelocityProperties

public void setVelocityProperties(Properties velocityProperties)
Parameters:
velocityProperties - the velocityProperties to set
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.velocity.components (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.velocity.components

Class Summary
AbstractDirective |
ActionDirective |
ActionErrorDirective |
ActionMessageDirective |
AnchorDirective |
AutocompleterDirective |
BeanDirective |
CheckBoxDirective |
CheckBoxListDirective |
ComboBoxDirective |
ComponentDirective |
DateDirective | DateDirective
DateTimePickerDirective |
DivDirective |
DoubleSelectDirective |
FieldErrorDirective |
FileDirective |
FormDirective |
HeadDirective |
HiddenDirective |
I18nDirective |
IncludeDirective |
InputTransferSelectDirective |
LabelDirective |
OptGroupDirective | OptGroup velocity directive.
OptionTransferSelectDirective |
ParamDirective |
PasswordDirective |
PropertyDirective |
PushDirective |
RadioDirective |
ResetDirective |
SelectDirective |
SetDirective |
SubmitDirective |
TabbedPanelDirective |
TextAreaDirective |
TextDirective |
TextFieldDirective |
TokenDirective |
TreeDirective | TreeDirective
TreeNodeDirective | TreeNodeDirective
UpDownSelectDirective |
URLDirective |
WebTableDirective |


org.apache.struts2.views.velocity.components Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.velocity.components

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.velocity.runtime.directive.Directive (implements java.lang.Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants)
      • org.apache.struts2.views.velocity.components.AbstractDirective
        • org.apache.struts2.views.velocity.components.ActionDirective
        • org.apache.struts2.views.velocity.components.ActionErrorDirective
        • org.apache.struts2.views.velocity.components.ActionMessageDirective
        • org.apache.struts2.views.velocity.components.AnchorDirective
        • org.apache.struts2.views.velocity.components.AutocompleterDirective
        • org.apache.struts2.views.velocity.components.BeanDirective
        • org.apache.struts2.views.velocity.components.CheckBoxDirective
        • org.apache.struts2.views.velocity.components.CheckBoxListDirective
        • org.apache.struts2.views.velocity.components.ComboBoxDirective
        • org.apache.struts2.views.velocity.components.ComponentDirective
        • org.apache.struts2.views.velocity.components.DateDirective
        • org.apache.struts2.views.velocity.components.DivDirective
        • org.apache.struts2.views.velocity.components.DoubleSelectDirective
        • org.apache.struts2.views.velocity.components.FieldErrorDirective
        • org.apache.struts2.views.velocity.components.FileDirective
        • org.apache.struts2.views.velocity.components.FormDirective
        • org.apache.struts2.views.velocity.components.HeadDirective
        • org.apache.struts2.views.velocity.components.HiddenDirective
        • org.apache.struts2.views.velocity.components.I18nDirective
        • org.apache.struts2.views.velocity.components.IncludeDirective
        • org.apache.struts2.views.velocity.components.InputTransferSelectDirective
        • org.apache.struts2.views.velocity.components.LabelDirective
        • org.apache.struts2.views.velocity.components.OptGroupDirective
        • org.apache.struts2.views.velocity.components.OptionTransferSelectDirective
        • org.apache.struts2.views.velocity.components.ParamDirective
        • org.apache.struts2.views.velocity.components.PasswordDirective
        • org.apache.struts2.views.velocity.components.PropertyDirective
        • org.apache.struts2.views.velocity.components.PushDirective
        • org.apache.struts2.views.velocity.components.RadioDirective
        • org.apache.struts2.views.velocity.components.ResetDirective
        • org.apache.struts2.views.velocity.components.SelectDirective
        • org.apache.struts2.views.velocity.components.SetDirective
        • org.apache.struts2.views.velocity.components.SubmitDirective
        • org.apache.struts2.views.velocity.components.TabbedPanelDirective
        • org.apache.struts2.views.velocity.components.TextAreaDirective
        • org.apache.struts2.views.velocity.components.TextDirective
        • org.apache.struts2.views.velocity.components.TextFieldDirective
          • org.apache.struts2.views.velocity.components.DateTimePickerDirective
        • org.apache.struts2.views.velocity.components.TokenDirective
        • org.apache.struts2.views.velocity.components.TreeDirective
        • org.apache.struts2.views.velocity.components.TreeNodeDirective
        • org.apache.struts2.views.velocity.components.UpDownSelectDirective
        • org.apache.struts2.views.velocity.components.URLDirective
        • org.apache.struts2.views.velocity.components.WebTableDirective


Uses of Package org.apache.struts2.views.velocity.components (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.velocity.components

Packages that use org.apache.struts2.views.velocity.components
org.apache.struts2.views.velocity.components

Classes in org.apache.struts2.views.velocity.components used by org.apache.struts2.views.velocity.components
AbstractDirective
TextFieldDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class AbstractDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
Direct Known Subclasses:
ActionDirective, ActionErrorDirective, ActionMessageDirective, AnchorDirective, AutocompleterDirective, BeanDirective, CheckBoxDirective, CheckBoxListDirective, ComboBoxDirective, ComponentDirective, DateDirective, DivDirective, DoubleSelectDirective, FieldErrorDirective, FileDirective, FormDirective, HeadDirective, HiddenDirective, I18nDirective, IncludeDirective, InputTransferSelectDirective, LabelDirective, OptGroupDirective, OptionTransferSelectDirective, ParamDirective, PasswordDirective, PropertyDirective, PushDirective, RadioDirective, ResetDirective, SelectDirective, SetDirective, SubmitDirective, TabbedPanelDirective, TextAreaDirective, TextDirective, TextFieldDirective, TokenDirective, TreeDirective, TreeNodeDirective, UpDownSelectDirective, URLDirective, WebTableDirective
public abstract class AbstractDirective
extends org.apache.velocity.runtime.directive.Directive

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
AbstractDirective()
Method Summary
protected Map | createPropertyMap(org.apache.velocity.context.InternalContextAdapter contextAdapter, org.apache.velocity.runtime.parser.node.Node node) create a Map of properties that the user has passed in.
protected abstract Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
abstract String | getBeanName()
String | getName()
int | getType() All components, unless otherwise stated, are LINE-level directives.
protected void | putProperty(Map propertyMap, org.apache.velocity.context.InternalContextAdapter contextAdapter, org.apache.velocity.runtime.parser.node.Node node) adds a given Node's key/value pair to the propertyMap.
boolean | render(org.apache.velocity.context.InternalContextAdapter ctx, Writer writer, org.apache.velocity.runtime.parser.node.Node node)
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AbstractDirective

public AbstractDirective()
Method Detail

getName

public String getName()
Specified by:
getName in class org.apache.velocity.runtime.directive.Directive

getBeanName

public abstract String getBeanName()

getType

public int getType()
All components, unless otherwise stated, are LINE-level directives.

Specified by:
getType in class org.apache.velocity.runtime.directive.Directive

getBean

protected abstract Component getBean(ValueStack stack,
                                     HttpServletRequest req,
                                     HttpServletResponse res)

render

public boolean render(org.apache.velocity.context.InternalContextAdapter ctx,
                      Writer writer,
                      org.apache.velocity.runtime.parser.node.Node node)
               throws IOException,
                      org.apache.velocity.exception.ResourceNotFoundException,
                      org.apache.velocity.exception.ParseErrorException,
                      org.apache.velocity.exception.MethodInvocationException
Specified by:
render in class org.apache.velocity.runtime.directive.Directive
Throws:
IOException
org.apache.velocity.exception.ResourceNotFoundException
org.apache.velocity.exception.ParseErrorException
org.apache.velocity.exception.MethodInvocationException

createPropertyMap

protected Map createPropertyMap(org.apache.velocity.context.InternalContextAdapter contextAdapter,
                                org.apache.velocity.runtime.parser.node.Node node)
                         throws org.apache.velocity.exception.ParseErrorException,
                                org.apache.velocity.exception.MethodInvocationException
create a Map of properties that the user has passed in. for example,
 #xxx("name=hello" "value=world" "template=foo")
would yield a params that contains {["name", "hello"], ["value", "world"], ["template", "foo"]}

Parameters:
node - the Node passed in to the render method
Returns:
a Map of the user specified properties
Throws:
org.apache.velocity.exception.ParseErrorException - if the was an error in the format of the property
org.apache.velocity.exception.MethodInvocationException

putProperty

protected void putProperty(Map propertyMap,
                           org.apache.velocity.context.InternalContextAdapter contextAdapter,
                           org.apache.velocity.runtime.parser.node.Node node)
                    throws org.apache.velocity.exception.ParseErrorException,
                           org.apache.velocity.exception.MethodInvocationException
adds a given Node's key/value pair to the propertyMap. For example, if this Node contained the value "rows=20", then the key, rows, would be added to the propertyMap with the String value, 20.

Parameters:
propertyMap - a params containing all the properties that we wish to set
node - the parameter to set expressed in "name=value" format
Throws:
org.apache.velocity.exception.ParseErrorException
org.apache.velocity.exception.MethodInvocationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActionDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class ActionDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.ActionDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class ActionDirective
extends AbstractDirective

See Also:
ActionComponent

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
ActionDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionDirective

public ActionDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionErrorDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class ActionErrorDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.ActionErrorDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class ActionErrorDirective
extends AbstractDirective

See Also:
ActionError

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
ActionErrorDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionErrorDirective

public ActionErrorDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ActionMessageDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class ActionMessageDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.ActionMessageDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class ActionMessageDirective
extends AbstractDirective

See Also:
ActionMessage

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
ActionMessageDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ActionMessageDirective

public ActionMessageDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AnchorDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class AnchorDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.AnchorDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class AnchorDirective
extends AbstractDirective

See Also:
Anchor

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
AnchorDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
int | getType() All components, unless otherwise stated, are LINE-level directives.
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AnchorDirective

public AnchorDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getType

public int getType()
Description copied from class: AbstractDirective
All components, unless otherwise stated, are LINE-level directives.

Overrides:
getType in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AutocompleterDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class AutocompleterDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.AutocompleterDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class AutocompleterDirective
extends AbstractDirective

See Also:
Autocompleter

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
AutocompleterDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AutocompleterDirective

public AutocompleterDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BeanDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class BeanDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.BeanDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class BeanDirective
extends AbstractDirective

See Also:
Bean

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
BeanDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BeanDirective

public BeanDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckBoxDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class CheckBoxDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.CheckBoxDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class CheckBoxDirective
extends AbstractDirective

See Also:
Checkbox

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
CheckBoxDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CheckBoxDirective

public CheckBoxDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CheckBoxListDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class CheckBoxListDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.CheckBoxListDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class CheckBoxListDirective
extends AbstractDirective

See Also:
CheckboxList

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
CheckBoxListDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

CheckBoxListDirective

public CheckBoxListDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComboBoxDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class ComboBoxDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.ComboBoxDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class ComboBoxDirective
extends AbstractDirective

See Also:
ComboBox

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
ComboBoxDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ComboBoxDirective

public ComboBoxDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ComponentDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class ComponentDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.ComponentDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class ComponentDirective
extends AbstractDirective

See Also:
GenericUIBean

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
ComponentDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
int | getType() All components, unless otherwise stated, are LINE-level directives.
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ComponentDirective

public ComponentDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getType

public int getType()
Description copied from class: AbstractDirective
All components, unless otherwise stated, are LINE-level directives.

Overrides:
getType in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class DateDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.DateDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class DateDirective
extends AbstractDirective

DateDirective

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
DateDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DateDirective

public DateDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DateTimePickerDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class DateTimePickerDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.TextFieldDirective
                extended by  org.apache.struts2.views.velocity.components.DateTimePickerDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class DateTimePickerDirective
extends TextFieldDirective

See Also:
DateTimePicker

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
DateTimePickerDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DateTimePickerDirective

public DateTimePickerDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Overrides:
getBean in class TextFieldDirective

getBeanName

public String getBeanName()
Overrides:
getBeanName in class TextFieldDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DivDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class DivDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.DivDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class DivDirective
extends AbstractDirective

See Also:
Div

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
DivDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
int | getType() All components, unless otherwise stated, are LINE-level directives.
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DivDirective

public DivDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getType

public int getType()
Description copied from class: AbstractDirective
All components, unless otherwise stated, are LINE-level directives.

Overrides:
getType in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DoubleSelectDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class DoubleSelectDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.DoubleSelectDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class DoubleSelectDirective
extends AbstractDirective

See Also:
DoubleSelect

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
DoubleSelectDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DoubleSelectDirective

public DoubleSelectDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FieldErrorDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class FieldErrorDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.FieldErrorDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class FieldErrorDirective
extends AbstractDirective

See Also:
FieldError

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
FieldErrorDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FieldErrorDirective

public FieldErrorDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FileDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class FileDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.FileDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class FileDirective
extends AbstractDirective

See Also:
File

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
FileDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FileDirective

public FileDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FormDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class FormDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.FormDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class FormDirective
extends AbstractDirective

See Also:
Form

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
FormDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
int | getType() All components, unless otherwise stated, are LINE-level directives.
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

FormDirective

public FormDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getType

public int getType()
Description copied from class: AbstractDirective
All components, unless otherwise stated, are LINE-level directives.

Overrides:
getType in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HeadDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class HeadDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.HeadDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class HeadDirective
extends AbstractDirective

See Also:
Head

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
HeadDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HeadDirective

public HeadDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HiddenDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class HiddenDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.HiddenDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class HiddenDirective
extends AbstractDirective

See Also:
Hidden

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
HiddenDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

HiddenDirective

public HiddenDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


I18nDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class I18nDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.I18nDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class I18nDirective
extends AbstractDirective

See Also:
I18n

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
I18nDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

I18nDirective

public I18nDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IncludeDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class IncludeDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.IncludeDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class IncludeDirective
extends AbstractDirective

See Also:
Include

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
IncludeDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

IncludeDirective

public IncludeDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InputTransferSelectDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class InputTransferSelectDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.InputTransferSelectDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class InputTransferSelectDirective
extends AbstractDirective

See Also:
InputTransferSelect

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
InputTransferSelectDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

InputTransferSelectDirective

public InputTransferSelectDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LabelDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class LabelDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.LabelDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class LabelDirective
extends AbstractDirective

See Also:
Label

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
LabelDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

LabelDirective

public LabelDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptGroupDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class OptGroupDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.OptGroupDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class OptGroupDirective
extends AbstractDirective

OptGroup velocity directive.

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
OptGroupDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OptGroupDirective

public OptGroupDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OptionTransferSelectDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class OptionTransferSelectDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.OptionTransferSelectDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class OptionTransferSelectDirective
extends AbstractDirective

See Also:
OptionTransferSelect

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
OptionTransferSelectDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

OptionTransferSelectDirective

public OptionTransferSelectDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParamDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class ParamDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.ParamDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class ParamDirective
extends AbstractDirective

See Also:
Param

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
ParamDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ParamDirective

public ParamDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PasswordDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class PasswordDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.PasswordDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class PasswordDirective
extends AbstractDirective

See Also:
Password

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
PasswordDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PasswordDirective

public PasswordDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PropertyDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class PropertyDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.PropertyDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class PropertyDirective
extends AbstractDirective

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
PropertyDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PropertyDirective

public PropertyDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PushDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class PushDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.PushDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class PushDirective
extends AbstractDirective

See Also:
Push

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
PushDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PushDirective

public PushDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RadioDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class RadioDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.RadioDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class RadioDirective
extends AbstractDirective

See Also:
Radio

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
RadioDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RadioDirective

public RadioDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ResetDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class ResetDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.ResetDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class ResetDirective
extends AbstractDirective

See Also:
Reset

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
ResetDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ResetDirective

public ResetDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SelectDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class SelectDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.SelectDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class SelectDirective
extends AbstractDirective

See Also:
Select

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
SelectDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SelectDirective

public SelectDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SetDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class SetDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.SetDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class SetDirective
extends AbstractDirective

See Also:
Set

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
SetDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SetDirective

public SetDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SubmitDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class SubmitDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.SubmitDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class SubmitDirective
extends AbstractDirective

See Also:
Submit

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
SubmitDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SubmitDirective

public SubmitDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TabbedPanelDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class TabbedPanelDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.TabbedPanelDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class TabbedPanelDirective
extends AbstractDirective

See Also:
TabbedPanel

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
TabbedPanelDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TabbedPanelDirective

public TabbedPanelDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextAreaDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class TextAreaDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.TextAreaDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class TextAreaDirective
extends AbstractDirective

See Also:
TextArea

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
TextAreaDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextAreaDirective

public TextAreaDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class TextDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.TextDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class TextDirective
extends AbstractDirective

See Also:
Text

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
TextDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextDirective

public TextDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TextFieldDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class TextFieldDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.TextFieldDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
Direct Known Subclasses:
DateTimePickerDirective
public class TextFieldDirective
extends AbstractDirective

See Also:
TextField

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
TextFieldDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TextFieldDirective

public TextFieldDirective()
Method Detail

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TokenDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class TokenDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.TokenDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class TokenDirective
extends AbstractDirective

See Also:
Token

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
TokenDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TokenDirective

public TokenDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class TreeDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.TreeDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class TreeDirective
extends AbstractDirective

TreeDirective

See Also:
Tree

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
TreeDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TreeDirective

public TreeDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TreeNodeDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class TreeNodeDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.TreeNodeDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class TreeNodeDirective
extends AbstractDirective

TreeNodeDirective

See Also:
TreeNode

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
TreeNodeDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

TreeNodeDirective

public TreeNodeDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UpDownSelectDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class UpDownSelectDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.UpDownSelectDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class UpDownSelectDirective
extends AbstractDirective

See Also:
UpDownSelect

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
UpDownSelectDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

UpDownSelectDirective

public UpDownSelectDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


URLDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class URLDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.URLDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class URLDirective
extends AbstractDirective

See Also:
URL

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
URLDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

URLDirective

public URLDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


WebTableDirective (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.velocity.components
Class WebTableDirective

java.lang.Object
    extended by  org.apache.velocity.runtime.directive.Directive
        extended by  org.apache.struts2.views.velocity.components.AbstractDirective
            extended by  org.apache.struts2.views.velocity.components.WebTableDirective
All Implemented Interfaces:
Cloneable, org.apache.velocity.runtime.directive.DirectiveConstants
public class WebTableDirective
extends AbstractDirective

See Also:
WebTable

Field Summary
Fields inherited from class org.apache.velocity.runtime.directive.Directive
rsvc
Fields inherited from interface org.apache.velocity.runtime.directive.DirectiveConstants
BLOCK, LINE
Constructor Summary
WebTableDirective()
Method Summary
protected Component | getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
String | getBeanName()
Methods inherited from class org.apache.struts2.views.velocity.components.AbstractDirective
createPropertyMap, getName, getType, putProperty, render
Methods inherited from class org.apache.velocity.runtime.directive.Directive
getColumn, getLine, init, setLocation
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

WebTableDirective

public WebTableDirective()
Method Detail

getBeanName

public String getBeanName()
Specified by:
getBeanName in class AbstractDirective

getBean

protected Component getBean(ValueStack stack,
                            HttpServletRequest req,
                            HttpServletResponse res)
Specified by:
getBean in class AbstractDirective
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.views.xslt (Struts 2 Core 2.0.6 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.apache.struts2.views.xslt

The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

See:
Description

Interface Summary
AdapterNode

Class Summary
AbstractAdapterElement | AbstractAdapterElement extends the abstract Node type and implements the DOM Element interface.
AbstractAdapterNode | AbstractAdapterNode is the base for childAdapters that expose a read-only view of a Java object as a DOM Node.
AdapterFactory | AdapterFactory produces Node adapters for Java object types.
ArrayAdapter |
BeanAdapter | This class is the most general type of adapter, utilizing reflective introspection to present a DOM view of all of the public properties of its value.
CollectionAdapter |
MapAdapter | MapAdapter adapters a java.util.Map type to an XML DOM with the following structure:
ProxyAttrAdapter | ProxyAttrAdapter is a pass-through adapter for objects which already implement the Attr interface.
ProxyElementAdapter | ProxyElementAdapter is a pass-through adapter for objects which already implement the Element interface.
ProxyNamedNodeMap | A NamedNodeMap that wraps the Nodes returned in their proxies.
ProxyNodeAdapter | ProxyNodeAdapter is a read-only delegating adapter for objects which already implement the Node interface.
ProxyTextNodeAdapter | ProxyTextNodeAdapter is a pass-through adapter for objects which already implement the Text interface.
ServletURIResolver | ServletURIResolver is a URIResolver that can retrieve resources from the servlet context using the scheme "response".
SimpleAdapterDocument | SimpleAdapterDocument adapted a Java object and presents it as a Document.
SimpleNodeList |
SimpleTextNode |
StringAdapter | StringAdapter adapts a Java String value to a DOM Element with the specified property name containing the String's text.
XSLTResult | XSLTResult uses XSLT to transform action object to XML.

Package org.apache.struts2.views.xslt Description

The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

The XSLTResult class now uses an extensible adapter factory for rendering the Struts action Java object tree to an XML DOM for consumption by the stylesheet. Users can easily register their own adapters to produce custom XML views of Java types or simply extend a default "String" adapter and return plain or XML text to be incorporated into the DOM. The new adapter mechanism is capable of proxying existing DOM trees and incorporating them into the results, so you can freely mix DOMs produced from other sources into your result tree.

A default java.util.Map adapter is also now provided to render Maps to XML.

Please see the javadoc on the AdapterFactory for more details.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.apache.struts2.views.xslt Class Hierarchy (Struts 2 Core 2.0.6 API)

Hierarchy For Package org.apache.struts2.views.xslt

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.apache.struts2.views.xslt.AbstractAdapterNode (implements org.apache.struts2.views.xslt.AdapterNode)
      • org.apache.struts2.views.xslt.AbstractAdapterElement (implements org.w3c.dom.Element)
        • org.apache.struts2.views.xslt.ArrayAdapter
        • org.apache.struts2.views.xslt.BeanAdapter
        • org.apache.struts2.views.xslt.CollectionAdapter
        • org.apache.struts2.views.xslt.MapAdapter
        • org.apache.struts2.views.xslt.MapAdapter.EntryElement
        • org.apache.struts2.views.xslt.StringAdapter
      • org.apache.struts2.views.xslt.ProxyNodeAdapter
        • org.apache.struts2.views.xslt.ProxyAttrAdapter (implements org.w3c.dom.Attr)
        • org.apache.struts2.views.xslt.ProxyElementAdapter (implements org.w3c.dom.Element)
        • org.apache.struts2.views.xslt.ProxyTextNodeAdapter (implements org.w3c.dom.Text)
      • org.apache.struts2.views.xslt.SimpleAdapterDocument (implements org.w3c.dom.Document)
      • org.apache.struts2.views.xslt.SimpleTextNode (implements org.w3c.dom.Node, org.w3c.dom.Text)
    • org.apache.struts2.views.xslt.AdapterFactory
    • org.apache.struts2.views.xslt.ProxyNamedNodeMap (implements org.w3c.dom.NamedNodeMap)
    • org.apache.struts2.views.xslt.ServletURIResolver (implements javax.xml.transform.URIResolver)
    • org.apache.struts2.views.xslt.SimpleNodeList (implements org.w3c.dom.NodeList)
    • org.apache.struts2.views.xslt.XSLTResult (implements com.opensymphony.xwork2.Result)

Interface Hierarchy

  • org.w3c.dom.Node
    • org.apache.struts2.views.xslt.AdapterNode
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.apache.struts2.views.xslt (Struts 2 Core 2.0.6 API)

Uses of Package
org.apache.struts2.views.xslt

Packages that use org.apache.struts2.views.xslt
org.apache.struts2.views.xslt The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Classes in org.apache.struts2.views.xslt used by org.apache.struts2.views.xslt
AbstractAdapterElement
AbstractAdapterElement extends the abstract Node type and implements the DOM Element interface.
AbstractAdapterNode
AbstractAdapterNode is the base for childAdapters that expose a read-only view of a Java object as a DOM Node.
AdapterFactory
AdapterFactory produces Node adapters for Java object types.
AdapterNode
BeanAdapter
This class is the most general type of adapter, utilizing reflective introspection to present a DOM view of all of the public properties of its value.
ProxyNodeAdapter
ProxyNodeAdapter is a read-only delegating adapter for objects which already implement the Node interface.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AdapterNode (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Interface AdapterNode

All Superinterfaces:
Node
All Known Implementing Classes:
AbstractAdapterElement, AbstractAdapterNode, ArrayAdapter, BeanAdapter, CollectionAdapter, MapAdapter, MapAdapter.EntryElement, ProxyAttrAdapter, ProxyElementAdapter, ProxyNodeAdapter, ProxyTextNodeAdapter, SimpleAdapterDocument, SimpleTextNode, StringAdapter
public interface AdapterNode
extends Node

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Method Summary
AdapterFactory | getAdapterFactory() The adapter factory that created this node.
Node | getChildAfter(Node thisNode) The child node after the specified sibling
Node | getChildBefore(Node thisNode) The child node before the specified sibling
AdapterNode | getParent() The parent adapter node of this node.
String | getPropertyName() The name of the Java object (property) that we are adapting
Object | getPropertyValue() The Java object (property) that we are adapting
void | setAdapterFactory(AdapterFactory factory) The adapter factory that created this node.
void | setParent(AdapterNode parent) The parent adapter node of this node.
void | setPropertyName(String name) The name of the Java object (property) that we are adapting
void | setPropertyValue(Object prop) The Java object (property) that we are adapting
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Method Detail

getAdapterFactory

AdapterFactory getAdapterFactory()
The adapter factory that created this node.

setAdapterFactory

void setAdapterFactory(AdapterFactory factory)
The adapter factory that created this node.

getParent

AdapterNode getParent()
The parent adapter node of this node. Note that our parent must be another adapter node, but our children may be any kind of Node.

setParent

void setParent(AdapterNode parent)
The parent adapter node of this node. Note that our parent must be another adapter node, but our children may be any kind of Node.

getChildBefore

Node getChildBefore(Node thisNode)
The child node before the specified sibling

getChildAfter

Node getChildAfter(Node thisNode)
The child node after the specified sibling

getPropertyName

String getPropertyName()
The name of the Java object (property) that we are adapting

setPropertyName

void setPropertyName(String name)
The name of the Java object (property) that we are adapting

getPropertyValue

Object getPropertyValue()
The Java object (property) that we are adapting

setPropertyValue

void setPropertyValue(Object prop)
The Java object (property) that we are adapting

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractAdapterElement (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class AbstractAdapterElement

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.AbstractAdapterElement
All Implemented Interfaces:
AdapterNode, Element, Node
Direct Known Subclasses:
ArrayAdapter, BeanAdapter, CollectionAdapter, MapAdapter, MapAdapter.EntryElement, StringAdapter
public abstract class AbstractAdapterElement
extends AbstractAdapterNode
implements Element

AbstractAdapterElement extends the abstract Node type and implements the DOM Element interface.

Field Summary
private  Map attributeAdapters
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
AbstractAdapterElement()
Method Summary
protected Map | buildAttributeAdapters()
String | getAttribute(String string) No attributes, return empty attributes if asked.
protected Map | getAttributeAdapters()
Attr | getAttributeNode(String name)
Attr | getAttributeNodeNS(String string, String string1)
String | getAttributeNS(String string, String string1)
String | getNodeName()
short | getNodeType()
TypeInfo | getSchemaTypeInfo()
String | getTagName()
boolean | hasAttribute(String string)
boolean | hasAttributeNS(String string, String string1)
boolean | hasChildNodes()
void | removeAttribute(String string)
Attr | removeAttributeNode(Attr attr)
void | removeAttributeNS(String string, String string1)
void | setAttribute(String string, String string1)
Attr | setAttributeNode(Attr attr)
Attr | setAttributeNodeNS(Attr attr)
void | setAttributeNS(String string, String string1, String string2)
void | setIdAttribute(String string, boolean b)
void | setIdAttributeNode(Attr attr, boolean b)
void | setIdAttributeNS(String string, String string1, boolean b)
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, buildChildAdapters, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Element
getElementsByTagName, getElementsByTagNameNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Field Detail

attributeAdapters

private Map attributeAdapters
Constructor Detail

AbstractAdapterElement

public AbstractAdapterElement()
Method Detail

setAttribute

public void setAttribute(String string,
                         String string1)
                  throws DOMException
Specified by:
setAttribute in interface Element
Throws:
DOMException

getAttributeAdapters

protected Map getAttributeAdapters()

buildAttributeAdapters

protected Map buildAttributeAdapters()

getAttribute

public String getAttribute(String string)
No attributes, return empty attributes if asked.

Specified by:
getAttribute in interface Element

setAttributeNS

public void setAttributeNS(String string,
                           String string1,
                           String string2)
                    throws DOMException
Specified by:
setAttributeNS in interface Element
Throws:
DOMException

getAttributeNS

public String getAttributeNS(String string,
                             String string1)
Specified by:
getAttributeNS in interface Element

setAttributeNode

public Attr setAttributeNode(Attr attr)
                      throws DOMException
Specified by:
setAttributeNode in interface Element
Throws:
DOMException

getAttributeNode

public Attr getAttributeNode(String name)
Specified by:
getAttributeNode in interface Element

setAttributeNodeNS

public Attr setAttributeNodeNS(Attr attr)
                        throws DOMException
Specified by:
setAttributeNodeNS in interface Element
Throws:
DOMException

getAttributeNodeNS

public Attr getAttributeNodeNS(String string,
                               String string1)
Specified by:
getAttributeNodeNS in interface Element

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node
Overrides:
getNodeName in class AbstractAdapterNode

getNodeType

public short getNodeType()
Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractAdapterNode

getTagName

public String getTagName()
Specified by:
getTagName in interface Element

hasAttribute

public boolean hasAttribute(String string)
Specified by:
hasAttribute in interface Element

hasAttributeNS

public boolean hasAttributeNS(String string,
                              String string1)
Specified by:
hasAttributeNS in interface Element

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node
Overrides:
hasChildNodes in class AbstractAdapterNode

removeAttribute

public void removeAttribute(String string)
                     throws DOMException
Specified by:
removeAttribute in interface Element
Throws:
DOMException

removeAttributeNS

public void removeAttributeNS(String string,
                              String string1)
                       throws DOMException
Specified by:
removeAttributeNS in interface Element
Throws:
DOMException

removeAttributeNode

public Attr removeAttributeNode(Attr attr)
                         throws DOMException
Specified by:
removeAttributeNode in interface Element
Throws:
DOMException

setIdAttributeNode

public void setIdAttributeNode(Attr attr,
                               boolean b)
                        throws DOMException
Specified by:
setIdAttributeNode in interface Element
Throws:
DOMException

getSchemaTypeInfo

public TypeInfo getSchemaTypeInfo()
Specified by:
getSchemaTypeInfo in interface Element

setIdAttribute

public void setIdAttribute(String string,
                           boolean b)
                    throws DOMException
Specified by:
setIdAttribute in interface Element
Throws:
DOMException

setIdAttributeNS

public void setIdAttributeNS(String string,
                             String string1,
                             boolean b)
                      throws DOMException
Specified by:
setIdAttributeNS in interface Element
Throws:
DOMException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractAdapterNode (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class AbstractAdapterNode

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
All Implemented Interfaces:
AdapterNode, Node
Direct Known Subclasses:
AbstractAdapterElement, ProxyNodeAdapter, SimpleAdapterDocument, SimpleTextNode
public abstract class AbstractAdapterNode
extends Object
implements AdapterNode

AbstractAdapterNode is the base for childAdapters that expose a read-only view of a Java object as a DOM Node. This class implements the core parent-child and sibling node traversal functionality shared by all adapter type nodes and used in proxy node support.

See Also:
AbstractAdapterElement

Field Summary
private AdapterFactory | adapterFactory
private List<Node> | childAdapters
private static NamedNodeMap | EMPTY_NAMEDNODEMAP
private Log | log
private AdapterNode | parent
private String | propertyName
private Object | propertyValue
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
AbstractAdapterNode()
Method Summary
Node | appendChild(Node node)
protected List<Node> | buildChildAdapters() subclasses override to produce their children
Node | cloneNode(boolean b)
short | compareDocumentPosition(Node node)
AdapterFactory | getAdapterFactory() The adapter factory that created this node.
NamedNodeMap | getAttributes()
String | getBaseURI()
protected List<Node> | getChildAdapters() Lazily initialize child childAdapters
Node | getChildAfter(Node child) The child node after the specified sibling
Node | getChildBefore(Node child) The child node before the specified sibling
Node | getChildBeforeOrAfter(Node child, boolean before)
NodeList | getChildNodes()
NodeList | getElementsByTagName(String tagName)
NodeList | getElementsByTagNameNS(String string, String string1)
Object | getFeature(String string, String string1)
Node | getFirstChild()
Node | getLastChild()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
short | getNodeType()
String | getNodeValue()
Document | getOwnerDocument()
AdapterNode | getParent() The parent adapter node of this node.
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
String | getPropertyName() The name of the Java object (property) that we are adapting
Object | getPropertyValue() The Java object (property) that we are adapting
String | getTextContent()
Object | getUserData(String string)
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node node, Node node1)
boolean | isDefaultNamespace(String string)
boolean | isEqualNode(Node node)
boolean | isSameNode(Node node)
boolean | isSupported(String string, String string1)
String | lookupNamespaceURI(String string)
String | lookupPrefix(String string)
void | normalize()
protected StrutsException | operationNotSupported()
Node | removeChild(Node node)
Node | replaceChild(Node node, Node node1)
void | setAdapterFactory(AdapterFactory adapterFactory) The adapter factory that created this node.
protected void | setContext(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
void | setNodeValue(String string)
void | setParent(AdapterNode parent) The parent adapter node of this node.
void | setPrefix(String string)
void | setPropertyName(String name) The name of the Java object (property) that we are adapting
void | setPropertyValue(Object prop) The Java object (property) that we are adapting
void | setTextContent(String string)
Object | setUserData(String string, Object object, UserDataHandler userDataHandler)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EMPTY_NAMEDNODEMAP

private static final NamedNodeMap EMPTY_NAMEDNODEMAP

childAdapters

private List<Node> childAdapters

log

private Log log

propertyValue

private Object propertyValue

propertyName

private String propertyName

parent

private AdapterNode parent

adapterFactory

private AdapterFactory adapterFactory
Constructor Detail

AbstractAdapterNode

public AbstractAdapterNode()
Method Detail

setContext

protected void setContext(AdapterFactory adapterFactory,
                          AdapterNode parent,
                          String propertyName,
                          Object value)
Parameters:
adapterFactory -
parent -
propertyName -
value -

buildChildAdapters

protected List<Node> buildChildAdapters()
subclasses override to produce their children

Returns:
List of child adapters.

getChildAdapters

protected List<Node> getChildAdapters()
Lazily initialize child childAdapters

getChildBeforeOrAfter

public Node getChildBeforeOrAfter(Node child,
                                  boolean before)

getChildAfter

public Node getChildAfter(Node child)
Description copied from interface: AdapterNode
The child node after the specified sibling

Specified by:
getChildAfter in interface AdapterNode

getChildBefore

public Node getChildBefore(Node child)
Description copied from interface: AdapterNode
The child node before the specified sibling

Specified by:
getChildBefore in interface AdapterNode

getElementsByTagName

public NodeList getElementsByTagName(String tagName)

getElementsByTagNameNS

public NodeList getElementsByTagNameNS(String string,
                                       String string1)

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

setNodeValue

public void setNodeValue(String string)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getParent

public AdapterNode getParent()
Description copied from interface: AdapterNode
The parent adapter node of this node. Note that our parent must be another adapter node, but our children may be any kind of Node.

Specified by:
getParent in interface AdapterNode

setParent

public void setParent(AdapterNode parent)
Description copied from interface: AdapterNode
The parent adapter node of this node. Note that our parent must be another adapter node, but our children may be any kind of Node.

Specified by:
setParent in interface AdapterNode

getPropertyValue

public Object getPropertyValue()
Description copied from interface: AdapterNode
The Java object (property) that we are adapting

Specified by:
getPropertyValue in interface AdapterNode

setPropertyValue

public void setPropertyValue(Object prop)
Description copied from interface: AdapterNode
The Java object (property) that we are adapting

Specified by:
setPropertyValue in interface AdapterNode

setPrefix

public void setPrefix(String string)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getPropertyName

public String getPropertyName()
Description copied from interface: AdapterNode
The name of the Java object (property) that we are adapting

Specified by:
getPropertyName in interface AdapterNode

setPropertyName

public void setPropertyName(String name)
Description copied from interface: AdapterNode
The name of the Java object (property) that we are adapting

Specified by:
setPropertyName in interface AdapterNode

getAdapterFactory

public AdapterFactory getAdapterFactory()
Description copied from interface: AdapterNode
The adapter factory that created this node.

Specified by:
getAdapterFactory in interface AdapterNode

setAdapterFactory

public void setAdapterFactory(AdapterFactory adapterFactory)
Description copied from interface: AdapterNode
The adapter factory that created this node.

Specified by:
setAdapterFactory in interface AdapterNode

isSupported

public boolean isSupported(String string,
                           String string1)
Specified by:
isSupported in interface Node

appendChild

public Node appendChild(Node node)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

cloneNode

public Node cloneNode(boolean b)
Specified by:
cloneNode in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

insertBefore

public Node insertBefore(Node node,
                         Node node1)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

normalize

public void normalize()
Specified by:
normalize in interface Node

removeChild

public Node removeChild(Node node)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node node,
                         Node node1)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

isDefaultNamespace

public boolean isDefaultNamespace(String string)
Specified by:
isDefaultNamespace in interface Node

lookupNamespaceURI

public String lookupNamespaceURI(String string)
Specified by:
lookupNamespaceURI in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeType

public short getNodeType()
Specified by:
getNodeType in interface Node

getBaseURI

public String getBaseURI()
Specified by:
getBaseURI in interface Node

compareDocumentPosition

public short compareDocumentPosition(Node node)
                              throws DOMException
Specified by:
compareDocumentPosition in interface Node
Throws:
DOMException

getTextContent

public String getTextContent()
                      throws DOMException
Specified by:
getTextContent in interface Node
Throws:
DOMException

setTextContent

public void setTextContent(String string)
                    throws DOMException
Specified by:
setTextContent in interface Node
Throws:
DOMException

isSameNode

public boolean isSameNode(Node node)
Specified by:
isSameNode in interface Node

lookupPrefix

public String lookupPrefix(String string)
Specified by:
lookupPrefix in interface Node

isEqualNode

public boolean isEqualNode(Node node)
Specified by:
isEqualNode in interface Node

getFeature

public Object getFeature(String string,
                         String string1)
Specified by:
getFeature in interface Node

setUserData

public Object setUserData(String string,
                          Object object,
                          UserDataHandler userDataHandler)
Specified by:
setUserData in interface Node

getUserData

public Object getUserData(String string)
Specified by:
getUserData in interface Node

operationNotSupported

protected StrutsException operationNotSupported()

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AdapterFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class AdapterFactory

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AdapterFactory

public class AdapterFactory
extends Object

AdapterFactory produces Node adapters for Java object types. Adapter classes are generally instantiated dynamically via a no-args constructor and populated with their context information via the AdapterNode interface. This factory supports proxying of generic DOM Node trees, allowing arbitrary Node types to be mixed together. You may simply return a Document or Node type as an object property and it will appear as a sub-tree in the XML as you'd expect. See #proxyNode(). Customization of the result XML can be accomplished by providing alternate adapters for Java types. Adapters are associated with Java types through the registerAdapterType() method. For example, since there is no default Date adapter, Date objects will be rendered with the generic Bean introspecting adapter, producing output like:

        19
        1
        0
        7
        8
        4
        1127106424531
        300
        105
By extending the StringAdapter and overriding its normal behavior we can create a custom Date formatter:
      public static class CustomDateAdapter extends StringAdapter {
        protected String getStringValue() {
            Date date = (Date)getPropertyValue();
            return DateFormat.getTimeInstance( DateFormat.FULL ).format( date );
        }
    }
Producing output like:
     12:02:54 AM CDT
The StringAdapter (which is normally invoked only to adapt String values) is a useful base for these kinds of customizations and can produce structured XML output as well as plain text by setting its parseStringAsXML() property to true. See provided examples.

Field Summary
private  Map<Class,Class> adapterTypes
Constructor Summary
AdapterFactory()
Method Summary
Document | adaptDocument(String propertyName, Object propertyValue) Create a top level Document adapter for the specified Java object.
Node | adaptNode(AdapterNode parent, String propertyName, Object value) Create an Node adapter for a child element.
Node | adaptNullValue(BeanAdapter parent, String propertyName) Create an appropriate adapter for a null value.
private Node | constructAdapterInstance(Class adapterClass, AdapterNode parent, String propertyName, Object propertyValue) Create an instance of an adapter dynamically and set its context via the AdapterNode interface.
Class | getAdapterForValue(Object value)
NamedNodeMap | proxyNamedNodeMap(AdapterNode parent, NamedNodeMap nnm)
Node | proxyNode(AdapterNode parent, Node node) Construct a proxy adapter for a value that is an existing DOM Node.
void | registerAdapterType(Class type, Class adapterType) Register an adapter type for a Java class type.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

adapterTypes

private Map<Class,Class> adapterTypes
Constructor Detail

AdapterFactory

public AdapterFactory()
Method Detail

registerAdapterType

public void registerAdapterType(Class type,
                                Class adapterType)
Register an adapter type for a Java class type.

Parameters:
type - the Java class type which is to be handled by the adapter.
adapterType - The adapter class, which implements AdapterNode.

adaptDocument

public Document adaptDocument(String propertyName,
                              Object propertyValue)
                       throws IllegalAccessException,
                              InstantiationException
Create a top level Document adapter for the specified Java object. The document will have a root element with the specified property name and contain the specified Java object content.

Parameters:
propertyName - The name of the root document element
Returns:
Throws:
IllegalAccessException
InstantiationException

adaptNode

public Node adaptNode(AdapterNode parent,
                      String propertyName,
                      Object value)
Create an Node adapter for a child element. Note that the parent of the created node must be an AdapterNode, however the child node itself may be any type of Node.

See Also:
adaptDocument( String, Object )

proxyNode

public Node proxyNode(AdapterNode parent,
                      Node node)
Construct a proxy adapter for a value that is an existing DOM Node. This allows arbitrary DOM Node trees to be mixed in with our results. The proxied nodes are read-only and currently support only limited types of Nodes including Element, Text, and Attributes. (Other Node types may be ignored by the proxy and not appear in the result tree).

// TODO: NameSpaces are not yet supported.

This method is primarily for use by the adapter node classes.

proxyNamedNodeMap

public NamedNodeMap proxyNamedNodeMap(AdapterNode parent,
                                      NamedNodeMap nnm)

constructAdapterInstance

private Node constructAdapterInstance(Class adapterClass,
                                      AdapterNode parent,
                                      String propertyName,
                                      Object propertyValue)
Create an instance of an adapter dynamically and set its context via the AdapterNode interface.

adaptNullValue

public Node adaptNullValue(BeanAdapter parent,
                           String propertyName)
Create an appropriate adapter for a null value.

Parameters:
parent -
propertyName -

getAdapterForValue

public Class getAdapterForValue(Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ArrayAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class ArrayAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.AbstractAdapterElement
            extended by  org.apache.struts2.views.xslt.ArrayAdapter
All Implemented Interfaces:
AdapterNode, Element, Node
public class ArrayAdapter
extends AbstractAdapterElement

Field Summary
private  Log log
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
ArrayAdapter()
ArrayAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
Method Summary
protected  List<Node> buildChildAdapters()
subclasses override to produce their children
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterElement
buildAttributeAdapters, getAttribute, getAttributeAdapters, getAttributeNode, getAttributeNodeNS, getAttributeNS, getNodeName, getNodeType, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, hasChildNodes, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Element
getElementsByTagName, getElementsByTagNameNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Field Detail

log

private Log log
Constructor Detail

ArrayAdapter

public ArrayAdapter()

ArrayAdapter

public ArrayAdapter(AdapterFactory adapterFactory,
                    AdapterNode parent,
                    String propertyName,
                    Object value)
Method Detail

buildChildAdapters

protected List<Node> buildChildAdapters()
Description copied from class: AbstractAdapterNode
subclasses override to produce their children

Overrides:
buildChildAdapters in class AbstractAdapterNode
Returns:
List of child adapters.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BeanAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class BeanAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.AbstractAdapterElement
            extended by  org.apache.struts2.views.xslt.BeanAdapter
All Implemented Interfaces:
AdapterNode, Element, Node
public class BeanAdapter
extends AbstractAdapterElement

This class is the most general type of adapter, utilizing reflective introspection to present a DOM view of all of the public properties of its value. For example, a property returning a JavaBean such as:

 public Person getMyPerson() { ... }
 ...
 class Person {
      public String getFirstName();
      public String getLastName();
 }
would be rendered as: ... ...

Field Summary
private Log | log
private static Object[] | NULLPARAMS
private static Map<Class,PropertyDescriptor[]> | propertyDescriptorCache Cache can savely be static because the cached information is the same for all instances of this class.
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
BeanAdapter()
BeanAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
Method Summary
protected List<Node> | buildChildAdapters() subclasses override to produce their children
NodeList | getChildNodes()
private PropertyDescriptor[] | getPropertyDescriptors(Object bean) Caching facade method to Introspector.getBeanInfo(Class, Class).getPropertyDescriptors();
String | getTagName()
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterElement
buildAttributeAdapters, getAttribute, getAttributeAdapters, getAttributeNode, getAttributeNodeNS, getAttributeNS, getNodeName, getNodeType, getSchemaTypeInfo, hasAttribute, hasAttributeNS, hasChildNodes, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Element
getElementsByTagName, getElementsByTagNameNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Field Detail

NULLPARAMS

private static final Object[] NULLPARAMS

propertyDescriptorCache

private static Map<Class,PropertyDescriptor[]> propertyDescriptorCache
Cache can savely be static because the cached information is the same for all instances of this class.

log

private Log log
Constructor Detail

BeanAdapter

public BeanAdapter()

BeanAdapter

public BeanAdapter(AdapterFactory adapterFactory,
                   AdapterNode parent,
                   String propertyName,
                   Object value)
Method Detail

getTagName

public String getTagName()
Specified by:
getTagName in interface Element
Overrides:
getTagName in class AbstractAdapterElement

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node
Overrides:
getChildNodes in class AbstractAdapterNode

buildChildAdapters

protected List<Node> buildChildAdapters()
Description copied from class: AbstractAdapterNode
subclasses override to produce their children

Overrides:
buildChildAdapters in class AbstractAdapterNode
Returns:
List of child adapters.

getPropertyDescriptors

private PropertyDescriptor[] getPropertyDescriptors(Object bean)
Caching facade method to Introspector.getBeanInfo(Class, Class).getPropertyDescriptors();

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CollectionAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class CollectionAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.AbstractAdapterElement
            extended by  org.apache.struts2.views.xslt.CollectionAdapter
All Implemented Interfaces:
AdapterNode, Element, Node
public class CollectionAdapter
extends AbstractAdapterElement

Field Summary
private  Log log
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
CollectionAdapter()
CollectionAdapter(AdapterFactory rootAdapterFactory, AdapterNode parent, String propertyName, Object value)
Method Summary
protected  List<Node> buildChildAdapters()
subclasses override to produce their children
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterElement
buildAttributeAdapters, getAttribute, getAttributeAdapters, getAttributeNode, getAttributeNodeNS, getAttributeNS, getNodeName, getNodeType, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, hasChildNodes, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Element
getElementsByTagName, getElementsByTagNameNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Field Detail

log

private Log log
Constructor Detail

CollectionAdapter

public CollectionAdapter()

CollectionAdapter

public CollectionAdapter(AdapterFactory rootAdapterFactory,
                         AdapterNode parent,
                         String propertyName,
                         Object value)
Method Detail

buildChildAdapters

protected List<Node> buildChildAdapters()
Description copied from class: AbstractAdapterNode
subclasses override to produce their children

Overrides:
buildChildAdapters in class AbstractAdapterNode
Returns:
List of child adapters.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MapAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class MapAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.AbstractAdapterElement
            extended by  org.apache.struts2.views.xslt.MapAdapter
All Implemented Interfaces:
AdapterNode, Element, Node
public class MapAdapter
extends AbstractAdapterElement

MapAdapter adapters a java.util.Map type to an XML DOM with the following structure:

          ...
          ...

      ...

Nested Class Summary
(package private)  class MapAdapter.EntryElement
Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
MapAdapter()
MapAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Map value)
Method Summary
protected List<Node> | buildChildAdapters() subclasses override to produce their children
Map | map()
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterElement
buildAttributeAdapters, getAttribute, getAttributeAdapters, getAttributeNode, getAttributeNodeNS, getAttributeNS, getNodeName, getNodeType, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, hasChildNodes, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Element
getElementsByTagName, getElementsByTagNameNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Constructor Detail

MapAdapter

public MapAdapter()

MapAdapter

public MapAdapter(AdapterFactory adapterFactory,
                  AdapterNode parent,
                  String propertyName,
                  Map value)
Method Detail

map

public Map map()

buildChildAdapters

protected List<Node> buildChildAdapters()
Description copied from class: AbstractAdapterNode
subclasses override to produce their children

Overrides:
buildChildAdapters in class AbstractAdapterNode
Returns:
List of child adapters.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


MapAdapter.EntryElement (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class MapAdapter.EntryElement

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.AbstractAdapterElement
            extended by  org.apache.struts2.views.xslt.MapAdapter.EntryElement
All Implemented Interfaces:
AdapterNode, Element, Node
Enclosing class:
MapAdapter
 class MapAdapter.EntryElement
extends AbstractAdapterElement

Field Summary
(package private) Object | key
(package private) Object | value
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
MapAdapter.EntryElement(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object key, Object value)
Method Summary
protected  List<Node> buildChildAdapters()
subclasses override to produce their children
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterElement
buildAttributeAdapters, getAttribute, getAttributeAdapters, getAttributeNode, getAttributeNodeNS, getAttributeNS, getNodeName, getNodeType, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, hasChildNodes, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Element
getElementsByTagName, getElementsByTagNameNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Field Detail

key

Object key

value

Object value
Constructor Detail

MapAdapter.EntryElement

public MapAdapter.EntryElement(AdapterFactory adapterFactory,
                               AdapterNode parent,
                               String propertyName,
                               Object key,
                               Object value)
Method Detail

buildChildAdapters

protected List<Node> buildChildAdapters()
Description copied from class: AbstractAdapterNode
subclasses override to produce their children

Overrides:
buildChildAdapters in class AbstractAdapterNode
Returns:
List of child adapters.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyAttrAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class ProxyAttrAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.ProxyNodeAdapter
            extended by  org.apache.struts2.views.xslt.ProxyAttrAdapter
All Implemented Interfaces:
AdapterNode, Attr, Node
public class ProxyAttrAdapter
extends ProxyNodeAdapter
implements Attr

ProxyAttrAdapter is a pass-through adapter for objects which already implement the Attr interface. All methods are proxied to the underlying Node except node traversal (e.g. getParent()) related methods which are implemented by the abstract adapter node to work with the parent adapter.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
ProxyAttrAdapter(AdapterFactory factory, AdapterNode parent, Attr value)
Method Summary
protected Attr | attr()
String | getName()
Element | getOwnerElement()
TypeInfo | getSchemaTypeInfo()
boolean | getSpecified()
String | getValue()
boolean | isId()
void | setValue(String string)
String | toString()
Methods inherited from class org.apache.struts2.views.xslt.ProxyNodeAdapter
getAttributes, getLocalName, getNamespaceURI, getNodeName, getNodeType, getNodeValue, getPrefix, hasAttributes, hasChildNodes, isSupported, node, wrap, wrap
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, buildChildAdapters, cloneNode, compareDocumentPosition, getAdapterFactory, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getNextSibling, getOwnerDocument, getParent, getParentNode, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Constructor Detail

ProxyAttrAdapter

public ProxyAttrAdapter(AdapterFactory factory,
                        AdapterNode parent,
                        Attr value)
Method Detail

attr

protected Attr attr()

getName

public String getName()
Specified by:
getName in interface Attr

getSpecified

public boolean getSpecified()
Specified by:
getSpecified in interface Attr

getValue

public String getValue()
Specified by:
getValue in interface Attr

setValue

public void setValue(String string)
              throws DOMException
Specified by:
setValue in interface Attr
Throws:
DOMException

getOwnerElement

public Element getOwnerElement()
Specified by:
getOwnerElement in interface Attr

getSchemaTypeInfo

public TypeInfo getSchemaTypeInfo()
Specified by:
getSchemaTypeInfo in interface Attr

isId

public boolean isId()
Specified by:
isId in interface Attr

toString

public String toString()
Overrides:
toString in class ProxyNodeAdapter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyElementAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class ProxyElementAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.ProxyNodeAdapter
            extended by  org.apache.struts2.views.xslt.ProxyElementAdapter
All Implemented Interfaces:
AdapterNode, Element, Node
public class ProxyElementAdapter
extends ProxyNodeAdapter
implements Element

ProxyElementAdapter is a pass-through adapter for objects which already implement the Element interface. All methods are proxied to the underlying Node except getParent(), getNextSibling() and getPreviousSibling(), which are implemented by the abstract adapter node to work with the parent adapter. Note: this class wants to be (extend) both an AbstractElementAdapter and ProxyElementAdapter, but its proxy-ness is winning right now.

Field Summary
private  Log log
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
ProxyElementAdapter(AdapterFactory factory, AdapterNode parent, Element value)
Method Summary
protected List<Node> | buildChildAdapters() subclasses override to produce their children
protected Element | element() Get the proxied Element
String | getAttribute(String name)
Attr | getAttributeNode(String name)
Attr | getAttributeNodeNS(String namespaceURI, String localName)
String | getAttributeNS(String namespaceURI, String localName)
NodeList | getElementsByTagName(String name)
NodeList | getElementsByTagNameNS(String namespaceURI, String localName)
TypeInfo | getSchemaTypeInfo()
String | getTagName()
boolean | hasAttribute(String name)
boolean | hasAttributeNS(String namespaceURI, String localName)
void | removeAttribute(String name)
Attr | removeAttributeNode(Attr oldAttr)
void | removeAttributeNS(String namespaceURI, String localName)
void | setAttribute(String name, String value)
Attr | setAttributeNode(Attr newAttr)
Attr | setAttributeNodeNS(Attr newAttr)
void | setAttributeNS(String namespaceURI, String qualifiedName, String value)
void | setIdAttribute(String string, boolean b)
void | setIdAttributeNode(Attr attr, boolean b)
void | setIdAttributeNS(String string, String string1, boolean b)
String | toString()
Methods inherited from class org.apache.struts2.views.xslt.ProxyNodeAdapter
getAttributes, getLocalName, getNamespaceURI, getNodeName, getNodeType, getNodeValue, getPrefix, hasAttributes, hasChildNodes, isSupported, node, wrap, wrap
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, cloneNode, compareDocumentPosition, getAdapterFactory, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getFeature, getFirstChild, getLastChild, getNextSibling, getOwnerDocument, getParent, getParentNode, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Field Detail

log

private Log log
Constructor Detail

ProxyElementAdapter

public ProxyElementAdapter(AdapterFactory factory,
                           AdapterNode parent,
                           Element value)
Method Detail

element

protected Element element()
Get the proxied Element

buildChildAdapters

protected List<Node> buildChildAdapters()
Description copied from class: AbstractAdapterNode
subclasses override to produce their children

Overrides:
buildChildAdapters in class AbstractAdapterNode
Returns:
List of child adapters.

getTagName

public String getTagName()
Specified by:
getTagName in interface Element

hasAttribute

public boolean hasAttribute(String name)
Specified by:
hasAttribute in interface Element

getAttribute

public String getAttribute(String name)
Specified by:
getAttribute in interface Element

hasAttributeNS

public boolean hasAttributeNS(String namespaceURI,
                              String localName)
Specified by:
hasAttributeNS in interface Element

getAttributeNode

public Attr getAttributeNode(String name)
Specified by:
getAttributeNode in interface Element

getElementsByTagName

public NodeList getElementsByTagName(String name)
Specified by:
getElementsByTagName in interface Element
Overrides:
getElementsByTagName in class AbstractAdapterNode

getAttributeNS

public String getAttributeNS(String namespaceURI,
                             String localName)
Specified by:
getAttributeNS in interface Element

getAttributeNodeNS

public Attr getAttributeNodeNS(String namespaceURI,
                               String localName)
Specified by:
getAttributeNodeNS in interface Element

getElementsByTagNameNS

public NodeList getElementsByTagNameNS(String namespaceURI,
                                       String localName)
Specified by:
getElementsByTagNameNS in interface Element
Overrides:
getElementsByTagNameNS in class AbstractAdapterNode

removeAttribute

public void removeAttribute(String name)
                     throws DOMException
Specified by:
removeAttribute in interface Element
Throws:
DOMException

removeAttributeNS

public void removeAttributeNS(String namespaceURI,
                              String localName)
                       throws DOMException
Specified by:
removeAttributeNS in interface Element
Throws:
DOMException

setAttribute

public void setAttribute(String name,
                         String value)
                  throws DOMException
Specified by:
setAttribute in interface Element
Throws:
DOMException

removeAttributeNode

public Attr removeAttributeNode(Attr oldAttr)
                         throws DOMException
Specified by:
removeAttributeNode in interface Element
Throws:
DOMException

setAttributeNode

public Attr setAttributeNode(Attr newAttr)
                      throws DOMException
Specified by:
setAttributeNode in interface Element
Throws:
DOMException

setAttributeNodeNS

public Attr setAttributeNodeNS(Attr newAttr)
                        throws DOMException
Specified by:
setAttributeNodeNS in interface Element
Throws:
DOMException

setAttributeNS

public void setAttributeNS(String namespaceURI,
                           String qualifiedName,
                           String value)
                    throws DOMException
Specified by:
setAttributeNS in interface Element
Throws:
DOMException

getSchemaTypeInfo

public TypeInfo getSchemaTypeInfo()
Specified by:
getSchemaTypeInfo in interface Element

setIdAttribute

public void setIdAttribute(String string,
                           boolean b)
                    throws DOMException
Specified by:
setIdAttribute in interface Element
Throws:
DOMException

setIdAttributeNS

public void setIdAttributeNS(String string,
                             String string1,
                             boolean b)
                      throws DOMException
Specified by:
setIdAttributeNS in interface Element
Throws:
DOMException

setIdAttributeNode

public void setIdAttributeNode(Attr attr,
                               boolean b)
                        throws DOMException
Specified by:
setIdAttributeNode in interface Element
Throws:
DOMException

toString

public String toString()
Overrides:
toString in class ProxyNodeAdapter
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyNamedNodeMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class ProxyNamedNodeMap

java.lang.Object
    extended by  org.apache.struts2.views.xslt.ProxyNamedNodeMap
All Implemented Interfaces:
NamedNodeMap
public class ProxyNamedNodeMap
extends Object
implements NamedNodeMap

A NamedNodeMap that wraps the Nodes returned in their proxies. Note: Since maps have no guaranteed order we don't need to worry about identity here as we do with "child" adapters. In that case we need to preserve identity in order to support finding the next/previous siblings.

Field Summary
private AdapterFactory | adapterFactory
private NamedNodeMap | nodes
private AdapterNode | parent
Constructor Summary
ProxyNamedNodeMap(AdapterFactory factory, AdapterNode parent, NamedNodeMap nodes)
Method Summary
int | getLength()
Node | getNamedItem(String name)
Node | getNamedItemNS(String namespaceURI, String localName)
Node | item(int index)
Node | removeNamedItem(String name)
Node | removeNamedItemNS(String namespaceURI, String localName)
Node | setNamedItem(Node arg)
Node | setNamedItemNS(Node arg)
protected Node | wrap(Node node)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

nodes

private NamedNodeMap nodes

adapterFactory

private AdapterFactory adapterFactory

parent

private AdapterNode parent
Constructor Detail

ProxyNamedNodeMap

public ProxyNamedNodeMap(AdapterFactory factory,
                         AdapterNode parent,
                         NamedNodeMap nodes)
Method Detail

wrap

protected Node wrap(Node node)

getLength

public int getLength()
Specified by:
getLength in interface NamedNodeMap

item

public Node item(int index)
Specified by:
item in interface NamedNodeMap

getNamedItem

public Node getNamedItem(String name)
Specified by:
getNamedItem in interface NamedNodeMap

removeNamedItem

public Node removeNamedItem(String name)
                     throws DOMException
Specified by:
removeNamedItem in interface NamedNodeMap
Throws:
DOMException

setNamedItem

public Node setNamedItem(Node arg)
                  throws DOMException
Specified by:
setNamedItem in interface NamedNodeMap
Throws:
DOMException

setNamedItemNS

public Node setNamedItemNS(Node arg)
                    throws DOMException
Specified by:
setNamedItemNS in interface NamedNodeMap
Throws:
DOMException

getNamedItemNS

public Node getNamedItemNS(String namespaceURI,
                           String localName)
Specified by:
getNamedItemNS in interface NamedNodeMap

removeNamedItemNS

public Node removeNamedItemNS(String namespaceURI,
                              String localName)
                       throws DOMException
Specified by:
removeNamedItemNS in interface NamedNodeMap
Throws:
DOMException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyNodeAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class ProxyNodeAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.ProxyNodeAdapter
All Implemented Interfaces:
AdapterNode, Node
Direct Known Subclasses:
ProxyAttrAdapter, ProxyElementAdapter, ProxyTextNodeAdapter
public abstract class ProxyNodeAdapter
extends AbstractAdapterNode

ProxyNodeAdapter is a read-only delegating adapter for objects which already implement the Node interface. All methods are proxied to the underlying Node except getParent(), getNextSibling() and getPreviousSibling(), which are implemented by the abstract adapter node to work with the parent adapter.

Field Summary
private  Log log
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
ProxyNodeAdapter(AdapterFactory factory, AdapterNode parent, Node value)
Method Summary
NamedNodeMap | getAttributes()
String | getLocalName()
String | getNamespaceURI()
String | getNodeName()
short | getNodeType()
String | getNodeValue()
String | getPrefix()
boolean | hasAttributes()
boolean | hasChildNodes()
boolean | isSupported(String s, String s1)
protected Node | node() Get the proxied Node value
String | toString()
protected NamedNodeMap | wrap(NamedNodeMap nnm)
protected Node | wrap(Node node) Get and adapter to wrap the proxied node.
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, buildChildAdapters, cloneNode, compareDocumentPosition, getAdapterFactory, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getNextSibling, getOwnerDocument, getParent, getParentNode, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

log

private Log log
Constructor Detail

ProxyNodeAdapter

public ProxyNodeAdapter(AdapterFactory factory,
                        AdapterNode parent,
                        Node value)
Method Detail

node

protected Node node()
Get the proxied Node value

wrap

protected Node wrap(Node node)
Get and adapter to wrap the proxied node.

Parameters:
node -

wrap

protected NamedNodeMap wrap(NamedNodeMap nnm)

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node
Overrides:
getNodeName in class AbstractAdapterNode

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Overrides:
getNodeValue in class AbstractAdapterNode
Throws:
DOMException

getNodeType

public short getNodeType()
Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractAdapterNode

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node
Overrides:
getAttributes in class AbstractAdapterNode

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node
Overrides:
hasChildNodes in class AbstractAdapterNode

isSupported

public boolean isSupported(String s,
                           String s1)
Specified by:
isSupported in interface Node
Overrides:
isSupported in class AbstractAdapterNode

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node
Overrides:
getNamespaceURI in class AbstractAdapterNode

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node
Overrides:
getPrefix in class AbstractAdapterNode

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node
Overrides:
getLocalName in class AbstractAdapterNode

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node
Overrides:
hasAttributes in class AbstractAdapterNode

toString

public String toString()
Overrides:
toString in class AbstractAdapterNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyTextNodeAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class ProxyTextNodeAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.ProxyNodeAdapter
            extended by  org.apache.struts2.views.xslt.ProxyTextNodeAdapter
All Implemented Interfaces:
AdapterNode, CharacterData, Node, Text
public class ProxyTextNodeAdapter
extends ProxyNodeAdapter
implements Text

ProxyTextNodeAdapter is a pass-through adapter for objects which already implement the Text interface. All methods are proxied to the underlying Node except getParent(), getNextSibling() and getPreviousSibling(), which are implemented by the abstract adapter node to work with the parent adapter.

Field Summary
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
ProxyTextNodeAdapter(AdapterFactory factory, AdapterNode parent, Text value)
Method Summary
void | appendData(String arg)
void | deleteData(int offset, int count)
String | getData()
int | getLength()
String | getWholeText()
void | insertData(int offset, String arg)
boolean | isElementContentWhitespace()
void | replaceData(int offset, int count, String arg)
Text | replaceWholeText(String string)
void | setData(String data)
Text | splitText(int offset)
String | substringData(int offset, int count)
(package private) Text | text()
String | toString()
Methods inherited from class org.apache.struts2.views.xslt.ProxyNodeAdapter
getAttributes, getLocalName, getNamespaceURI, getNodeName, getNodeType, getNodeValue, getPrefix, hasAttributes, hasChildNodes, isSupported, node, wrap, wrap
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, buildChildAdapters, cloneNode, compareDocumentPosition, getAdapterFactory, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getNextSibling, getOwnerDocument, getParent, getParentNode, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Constructor Detail

ProxyTextNodeAdapter

public ProxyTextNodeAdapter(AdapterFactory factory,
                            AdapterNode parent,
                            Text value)
Method Detail

text

Text text()

toString

public String toString()
Overrides:
toString in class ProxyNodeAdapter

splitText

public Text splitText(int offset)
               throws DOMException
Specified by:
splitText in interface Text
Throws:
DOMException

getLength

public int getLength()
Specified by:
getLength in interface CharacterData

deleteData

public void deleteData(int offset,
                       int count)
                throws DOMException
Specified by:
deleteData in interface CharacterData
Throws:
DOMException

getData

public String getData()
               throws DOMException
Specified by:
getData in interface CharacterData
Throws:
DOMException

substringData

public String substringData(int offset,
                            int count)
                     throws DOMException
Specified by:
substringData in interface CharacterData
Throws:
DOMException

replaceData

public void replaceData(int offset,
                        int count,
                        String arg)
                 throws DOMException
Specified by:
replaceData in interface CharacterData
Throws:
DOMException

insertData

public void insertData(int offset,
                       String arg)
                throws DOMException
Specified by:
insertData in interface CharacterData
Throws:
DOMException

appendData

public void appendData(String arg)
                throws DOMException
Specified by:
appendData in interface CharacterData
Throws:
DOMException

setData

public void setData(String data)
             throws DOMException
Specified by:
setData in interface CharacterData
Throws:
DOMException

isElementContentWhitespace

public boolean isElementContentWhitespace()
Specified by:
isElementContentWhitespace in interface Text

getWholeText

public String getWholeText()
Specified by:
getWholeText in interface Text

replaceWholeText

public Text replaceWholeText(String string)
                      throws DOMException
Specified by:
replaceWholeText in interface Text
Throws:
DOMException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ServletURIResolver (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class ServletURIResolver

java.lang.Object
    extended by  org.apache.struts2.views.xslt.ServletURIResolver
All Implemented Interfaces:
URIResolver
public class ServletURIResolver
extends Object
implements URIResolver

ServletURIResolver is a URIResolver that can retrieve resources from the servlet context using the scheme "response". e.g. A URI resolver is called when a stylesheet uses an xsl:include, xsl:import, or document() function to find the resource (file).

Field Summary
private Log | log
(package private) static String | PROTOCOL
private ServletContext | sc
Constructor Summary
ServletURIResolver(ServletContext sc)
Method Summary
 Source resolve(String href, String base)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

log

private Log log

PROTOCOL

static final String PROTOCOL
See Also:
Constant Field Values

sc

private ServletContext sc
Constructor Detail

ServletURIResolver

public ServletURIResolver(ServletContext sc)
Method Detail

resolve

public Source resolve(String href,
                      String base)
               throws TransformerException
Specified by:
resolve in interface URIResolver
Throws:
TransformerException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleAdapterDocument (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class SimpleAdapterDocument

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.SimpleAdapterDocument
All Implemented Interfaces:
AdapterNode, Document, Node
public class SimpleAdapterDocument
extends AbstractAdapterNode
implements Document

SimpleAdapterDocument adapted a Java object and presents it as a Document. This class represents the Document container and uses the AdapterFactory to produce a child adapter for the wrapped object. The adapter produced must be of an Element type or an exception is thrown. Note: in theory we could base this on AbstractAdapterElement and then allow the wrapped object to be a more general Node type. We would just use ourselves as the root element. However I don't think this is an issue as people expect Documents to wrap Elements.

Field Summary
private  Element rootElement
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
SimpleAdapterDocument(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
Method Summary
Node | adoptNode(Node node)
Attr | createAttribute(String string)
Attr | createAttributeNS(String string, String string1)
CDATASection | createCDATASection(String string)
Comment | createComment(String string)
DocumentFragment | createDocumentFragment()
Element | createElement(String string)
Element | createElementNS(String string, String string1)
EntityReference | createEntityReference(String string)
ProcessingInstruction | createProcessingInstruction(String string, String string1)
Text | createTextNode(String string)
protected List<Node> | getChildAdapters() Lazily initialize child childAdapters
Node | getChildAfter(Node child) The child node after the specified sibling
Node | getChildBefore(Node child) The child node before the specified sibling
NodeList | getChildNodes()
DocumentType | getDoctype()
Element | getDocumentElement()
String | getDocumentURI()
DOMConfiguration | getDomConfig()
Element | getElementById(String string)
NodeList | getElementsByTagName(String string)
NodeList | getElementsByTagNameNS(String string, String string1)
Node | getFirstChild()
DOMImplementation | getImplementation()
String | getInputEncoding()
Node | getLastChild()
String | getNodeName()
short | getNodeType()
private Element | getRootElement() Lazily construct the root element adapter from the value object.
boolean | getStrictErrorChecking()
String | getXmlEncoding()
boolean | getXmlStandalone()
String | getXmlVersion()
boolean | hasChildNodes()
Node | importNode(Node node, boolean b)
void | normalizeDocument()
Node | renameNode(Node node, String string, String string1)
void | setDocumentURI(String string)
void | setPropertyValue(Object prop) The Java object (property) that we are adapting
void | setStrictErrorChecking(boolean b)
void | setXmlStandalone(boolean b)
void | setXmlVersion(String string)
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, buildChildAdapters, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildBeforeOrAfter, getFeature, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getFeature, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Field Detail

rootElement

private Element rootElement
Constructor Detail

SimpleAdapterDocument

public SimpleAdapterDocument(AdapterFactory adapterFactory,
                             AdapterNode parent,
                             String propertyName,
                             Object value)
Method Detail

setPropertyValue

public void setPropertyValue(Object prop)
Description copied from interface: AdapterNode
The Java object (property) that we are adapting

Specified by:
setPropertyValue in interface AdapterNode
Overrides:
setPropertyValue in class AbstractAdapterNode

getRootElement

private Element getRootElement()
Lazily construct the root element adapter from the value object.

getChildAdapters

protected List<Node> getChildAdapters()
Description copied from class: AbstractAdapterNode
Lazily initialize child childAdapters

Overrides:
getChildAdapters in class AbstractAdapterNode

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node
Overrides:
getChildNodes in class AbstractAdapterNode

getDoctype

public DocumentType getDoctype()
Specified by:
getDoctype in interface Document

getDocumentElement

public Element getDocumentElement()
Specified by:
getDocumentElement in interface Document

getElementById

public Element getElementById(String string)
Specified by:
getElementById in interface Document

getElementsByTagName

public NodeList getElementsByTagName(String string)
Specified by:
getElementsByTagName in interface Document
Overrides:
getElementsByTagName in class AbstractAdapterNode

getElementsByTagNameNS

public NodeList getElementsByTagNameNS(String string,
                                       String string1)
Specified by:
getElementsByTagNameNS in interface Document
Overrides:
getElementsByTagNameNS in class AbstractAdapterNode

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node
Overrides:
getFirstChild in class AbstractAdapterNode

getImplementation

public DOMImplementation getImplementation()
Specified by:
getImplementation in interface Document

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node
Overrides:
getLastChild in class AbstractAdapterNode

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node
Overrides:
getNodeName in class AbstractAdapterNode

getNodeType

public short getNodeType()
Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractAdapterNode

createAttribute

public Attr createAttribute(String string)
                     throws DOMException
Specified by:
createAttribute in interface Document
Throws:
DOMException

createAttributeNS

public Attr createAttributeNS(String string,
                              String string1)
                       throws DOMException
Specified by:
createAttributeNS in interface Document
Throws:
DOMException

createCDATASection

public CDATASection createCDATASection(String string)
                                throws DOMException
Specified by:
createCDATASection in interface Document
Throws:
DOMException

createComment

public Comment createComment(String string)
Specified by:
createComment in interface Document

createDocumentFragment

public DocumentFragment createDocumentFragment()
Specified by:
createDocumentFragment in interface Document

createElement

public Element createElement(String string)
                      throws DOMException
Specified by:
createElement in interface Document
Throws:
DOMException

createElementNS

public Element createElementNS(String string,
                               String string1)
                        throws DOMException
Specified by:
createElementNS in interface Document
Throws:
DOMException

createEntityReference

public EntityReference createEntityReference(String string)
                                      throws DOMException
Specified by:
createEntityReference in interface Document
Throws:
DOMException

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(String string,
                                                         String string1)
                                                  throws DOMException
Specified by:
createProcessingInstruction in interface Document
Throws:
DOMException

createTextNode

public Text createTextNode(String string)
Specified by:
createTextNode in interface Document

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node
Overrides:
hasChildNodes in class AbstractAdapterNode

importNode

public Node importNode(Node node,
                       boolean b)
                throws DOMException
Specified by:
importNode in interface Document
Throws:
DOMException

getChildAfter

public Node getChildAfter(Node child)
Description copied from interface: AdapterNode
The child node after the specified sibling

Specified by:
getChildAfter in interface AdapterNode
Overrides:
getChildAfter in class AbstractAdapterNode

getChildBefore

public Node getChildBefore(Node child)
Description copied from interface: AdapterNode
The child node before the specified sibling

Specified by:
getChildBefore in interface AdapterNode
Overrides:
getChildBefore in class AbstractAdapterNode

getInputEncoding

public String getInputEncoding()
Specified by:
getInputEncoding in interface Document

getXmlEncoding

public String getXmlEncoding()
Specified by:
getXmlEncoding in interface Document

getXmlStandalone

public boolean getXmlStandalone()
Specified by:
getXmlStandalone in interface Document

setXmlStandalone

public void setXmlStandalone(boolean b)
                      throws DOMException
Specified by:
setXmlStandalone in interface Document
Throws:
DOMException

getXmlVersion

public String getXmlVersion()
Specified by:
getXmlVersion in interface Document

setXmlVersion

public void setXmlVersion(String string)
                   throws DOMException
Specified by:
setXmlVersion in interface Document
Throws:
DOMException

getStrictErrorChecking

public boolean getStrictErrorChecking()
Specified by:
getStrictErrorChecking in interface Document

setStrictErrorChecking

public void setStrictErrorChecking(boolean b)
Specified by:
setStrictErrorChecking in interface Document

getDocumentURI

public String getDocumentURI()
Specified by:
getDocumentURI in interface Document

setDocumentURI

public void setDocumentURI(String string)
Specified by:
setDocumentURI in interface Document

adoptNode

public Node adoptNode(Node node)
               throws DOMException
Specified by:
adoptNode in interface Document
Throws:
DOMException

getDomConfig

public DOMConfiguration getDomConfig()
Specified by:
getDomConfig in interface Document

normalizeDocument

public void normalizeDocument()
Specified by:
normalizeDocument in interface Document

renameNode

public Node renameNode(Node node,
                       String string,
                       String string1)
                throws DOMException
Specified by:
renameNode in interface Document
Throws:
DOMException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleNodeList (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class SimpleNodeList

java.lang.Object
    extended by  org.apache.struts2.views.xslt.SimpleNodeList
All Implemented Interfaces:
NodeList
public class SimpleNodeList
extends Object
implements NodeList

Field Summary
private Log | log
private List<Node> | nodes
Constructor Summary
SimpleNodeList(List<Node> nodes)
Method Summary
int | getLength()
Node | item(int i)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

log

private Log log

nodes

private List<Node> nodes
Constructor Detail

SimpleNodeList

public SimpleNodeList(List<Node> nodes)
Method Detail

getLength

public int getLength()
Specified by:
getLength in interface NodeList

item

public Node item(int i)
Specified by:
item in interface NodeList

toString

public String toString()
Overrides:
toString in class Object
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleTextNode (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class SimpleTextNode

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.SimpleTextNode
All Implemented Interfaces:
AdapterNode, CharacterData, Node, Text
public class SimpleTextNode
extends AbstractAdapterNode
implements Node, Text

Constructor Summary
SimpleTextNode(AdapterFactory rootAdapterFactory, AdapterNode parent, String propertyName, Object value)
Method Summary
void | appendData(String string)
void | deleteData(int i, int i1)
String | getData()
int | getLength()
String | getNodeName()
short | getNodeType()
String | getNodeValue()
protected String | getStringValue()
String | getWholeText()
void | insertData(int i, String string)
boolean | isElementContentWhitespace()
void | replaceData(int i, int i1, String string)
Text | replaceWholeText(String string)
void | setData(String string)
Text | splitText(int i)
String | substringData(int beginIndex, int endIndex)
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, buildChildAdapters, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

SimpleTextNode

public SimpleTextNode(AdapterFactory rootAdapterFactory,
                      AdapterNode parent,
                      String propertyName,
                      Object value)
Method Detail

getStringValue

protected String getStringValue()

setData

public void setData(String string)
             throws DOMException
Specified by:
setData in interface CharacterData
Throws:
DOMException

getData

public String getData()
               throws DOMException
Specified by:
getData in interface CharacterData
Throws:
DOMException

getLength

public int getLength()
Specified by:
getLength in interface CharacterData

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node
Overrides:
getNodeName in class AbstractAdapterNode

getNodeType

public short getNodeType()
Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractAdapterNode

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Overrides:
getNodeValue in class AbstractAdapterNode
Throws:
DOMException

appendData

public void appendData(String string)
                throws DOMException
Specified by:
appendData in interface CharacterData
Throws:
DOMException

deleteData

public void deleteData(int i,
                       int i1)
                throws DOMException
Specified by:
deleteData in interface CharacterData
Throws:
DOMException

insertData

public void insertData(int i,
                       String string)
                throws DOMException
Specified by:
insertData in interface CharacterData
Throws:
DOMException

replaceData

public void replaceData(int i,
                        int i1,
                        String string)
                 throws DOMException
Specified by:
replaceData in interface CharacterData
Throws:
DOMException

splitText

public Text splitText(int i)
               throws DOMException
Specified by:
splitText in interface Text
Throws:
DOMException

substringData

public String substringData(int beginIndex,
                            int endIndex)
                     throws DOMException
Specified by:
substringData in interface CharacterData
Throws:
DOMException

isElementContentWhitespace

public boolean isElementContentWhitespace()
Specified by:
isElementContentWhitespace in interface Text

getWholeText

public String getWholeText()
Specified by:
getWholeText in interface Text

replaceWholeText

public Text replaceWholeText(String string)
                      throws DOMException
Specified by:
replaceWholeText in interface Text
Throws:
DOMException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


StringAdapter (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class StringAdapter

java.lang.Object
    extended by  org.apache.struts2.views.xslt.AbstractAdapterNode
        extended by  org.apache.struts2.views.xslt.AbstractAdapterElement
            extended by  org.apache.struts2.views.xslt.StringAdapter
All Implemented Interfaces:
AdapterNode, Element, Node
public class StringAdapter
extends AbstractAdapterElement

StringAdapter adapts a Java String value to a DOM Element with the specified property name containing the String's text. e.g. a property

String getFoo() { return "My Text!"; }
will appear in the result DOM as: MyText! Subclasses may override the getStringValue() method in order to use StringAdapter as a simplified custom XML adapter for Java types. A subclass can enable XML parsing of the value string via the setParseStringAsXML() method and then override getStringValue() to return a String containing the custom formatted XML.

Field Summary
private Log | log
(package private) boolean | parseStringAsXML
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Constructor Summary
StringAdapter()
StringAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, String value)
Method Summary
protected List<Node> | buildChildAdapters() subclasses override to produce their children
boolean | getParseStringAsXML() Is this StringAdapter to interpret its string values as containing XML Text?
protected String | getStringValue() Get the object to be adapted as a String value.
void | setParseStringAsXML(boolean parseStringAsXML) When set to true the StringAdapter will interpret its String value as containing XML text and parse it to a DOM Element.
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterElement
buildAttributeAdapters, getAttribute, getAttributeAdapters, getAttributeNode, getAttributeNodeNS, getAttributeNS, getNodeName, getNodeType, getSchemaTypeInfo, getTagName, hasAttribute, hasAttributeNS, hasChildNodes, removeAttribute, removeAttributeNode, removeAttributeNS, setAttribute, setAttributeNode, setAttributeNodeNS, setAttributeNS, setIdAttribute, setIdAttributeNode, setIdAttributeNS
Methods inherited from class org.apache.struts2.views.xslt.AbstractAdapterNode
appendChild, cloneNode, compareDocumentPosition, getAdapterFactory, getAttributes, getBaseURI, getChildAdapters, getChildAfter, getChildBefore, getChildBeforeOrAfter, getChildNodes, getElementsByTagName, getElementsByTagNameNS, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParent, getParentNode, getPrefix, getPreviousSibling, getPropertyName, getPropertyValue, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, operationNotSupported, removeChild, replaceChild, setAdapterFactory, setContext, setNodeValue, setParent, setPrefix, setPropertyName, setPropertyValue, setTextContent, setUserData, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Element
getElementsByTagName, getElementsByTagNameNS
Methods inherited from interface org.w3c.dom.Node
appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

Field Detail

log

private Log log

parseStringAsXML

boolean parseStringAsXML
Constructor Detail

StringAdapter

public StringAdapter()

StringAdapter

public StringAdapter(AdapterFactory adapterFactory,
                     AdapterNode parent,
                     String propertyName,
                     String value)
Method Detail

getStringValue

protected String getStringValue()
Get the object to be adapted as a String value.

This method can be overridden by subclasses that wish to use StringAdapter as a simplified customizable XML adapter for Java types. A subclass can enable parsing of the value string as containing XML text via the setParseStringAsXML() method and then override getStringValue() to return a String containing the custom formatted XML.

buildChildAdapters

protected List<Node> buildChildAdapters()
Description copied from class: AbstractAdapterNode
subclasses override to produce their children

Overrides:
buildChildAdapters in class AbstractAdapterNode
Returns:
List of child adapters.

getParseStringAsXML

public boolean getParseStringAsXML()
Is this StringAdapter to interpret its string values as containing XML Text?

See Also:
setParseStringAsXML(boolean)

setParseStringAsXML

public void setParseStringAsXML(boolean parseStringAsXML)
When set to true the StringAdapter will interpret its String value as containing XML text and parse it to a DOM Element. The new DOM Element will be a child of this String element. (i.e. wrapped in an element of the property name specified for this StringAdapter).

Parameters:
parseStringAsXML -
See Also:
getParseStringAsXML()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XSLTResult (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.views.xslt
Class XSLTResult

java.lang.Object
    extended by  org.apache.struts2.views.xslt.XSLTResult
All Implemented Interfaces:
Result, Serializable
public class XSLTResult
extends Object
implements Result

XSLTResult uses XSLT to transform action object to XML. Recent version has been specifically modified to deal with Xalan flaws. When using Xalan you may notice that even though you have very minimal stylesheet like this one

 <xsl:template match="/result">
   <result />
 </xsl:template>

then Xalan would still iterate through every property of your action and it's all descendants.

If you had double-linked objects then Xalan would work forever analysing infinite object tree. Even if your stylesheet was not constructed to process them all. It's becouse current Xalan eagerly and extensively converts everything to it's internal DTM model before further processing.

Thet's why there's a loop eliminator added that works by indexing every object-property combination during processing. If it notices that some object's property were already walked through, it doesn't get any deeper. Say, you have two objects x and y with the following properties set (pseudocode):

 x.y = y;
 and
 y.x = x;
 action.x=x;

Due to that modification the resulting XML document based on x would be:

 <result>
   <x>
     <y/>
   </x>
 </result>

Without it there would be an endless x/y/x/y/x/y/... elements.

The XSLTResult code tries also to deal with the fact that DTM model is built in a manner that childs are processed before siblings. The result is that if there is object x that is both set in action's x property, and very deeply under action's a property then it would only appear under a, not under x. That's not what we expect, and that's why XSLTResult allows objects to repeat in various places to some extent.

Sometimes the object mesh is still very dense and you may notice that even though you have relatively simple stylesheet execution takes a tremendous amount of time. To help you to deal with that obstacle of Xalan you may attach regexp filters to elements paths (xpath).

Note: In your .xsl file the root match must be named result.
This example will output the username by using getUsername on your action class:

 <xsl:template match="result">
   <html>
   <body>
   Hello <xsl:value-of select="username"/> how are you?
   </body>
   <html>
 <xsl:template/>

In the following example the XSLT result would only walk through action's properties without their childs. It would also skip every property that has "hugeCollection" in their name. Element's path is first compared to excludingPattern - if it matches it's no longer processed. Then it is compared to matchingPattern and processed only if there's a match.

 <result name="success" type="xslt">
   <param name="location">foo.xslt</param>
   <param name="matchingPattern">^/result/[^/*]$</param>
   <param name="excludingPattern">.*(hugeCollection).*</param>
 </result>

In the following example the XSLT result would use the action's user property instead of the action as it's base document and walk through it's properties. The exposedValue uses an ognl expression to derive it's value.

 <result name="success" type="xslt">
   <param name="location">foo.xslt</param>
   <param name="exposedValue">user$</param>
 </result>
* This result type takes the following parameters:
  • location (default) - the location to go to after execution.
  • parse - true by default. If set to false, the location param will not be parsed for Ognl expressions.
  • matchingPattern - Pattern that matches only desired elements, by default it matches everything.
  • excludingPattern - Pattern that eliminates unwanted elements, by default it matches none.

struts.properties related configuration:

  • struts.xslt.nocache - Defaults to false. If set to true, disables stylesheet caching. Good for development, bad for production.
Example:

 <result name="success" type="xslt">foo.xslt</result>

See Also:
Serialized Form

Field Summary
private AdapterFactory | adapterFactory
static String | DEFAULT_PARAM 'stylesheetLocation' parameter.
private String | exludingPattern Indicates the property name patterns which should be excluded from the xml.
private String | exposedValue Indicates the ognl expression respresenting the bean which is to be exposed as xml.
private static Log | LOG Log instance for this result.
private String | matchingPattern Indicates the property name patterns which should be exposed to the xml.
protected boolean | noCache Determines whether or not the result should allow caching.
private boolean | parse
private static long | serialVersionUID
private String | stylesheetLocation Indicates the location of the xsl template.
private static Map<String,Templates> | templatesCache Cache of all tempaltes.
Constructor Summary
XSLTResult()
XSLTResult(String stylesheetLocation)
Method Summary
 void execute(ActionInvocation invocation)
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.
protected  AdapterFactory getAdapterFactory()
protected  Source getDOMSourceForStack(Object value)
 String getExludingPattern()
 String getExposedValue()
 String getMatchingPattern()
 String getStylesheetLocation()
protected  Templates getTemplates(String path)
protected  URIResolver getURIResolver()
Get the URI Resolver to be called by the processor when it encounters an xsl:include, xsl:import, or document() function.
protected  void setAdapterFactory(AdapterFactory adapterFactory)
 void setExludingPattern(String exludingPattern)
 void setExposedValue(String exposedValue)
 void setLocation(String location)
Deprecated. Use #setStylesheetLocation(String)
 void setMatchingPattern(String matchingPattern)
 void setNoCache(String val)
 void setParse(boolean parse)
If true, parse the stylesheet location for OGNL expressions.
 void setStylesheetLocation(String location)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

serialVersionUID

private static final long serialVersionUID
See Also:
Constant Field Values

LOG

private static final Log LOG
Log instance for this result.

DEFAULT_PARAM

public static final String DEFAULT_PARAM
'stylesheetLocation' parameter. Points to the xsl.

See Also:
Constant Field Values

templatesCache

private static final Map<String,Templates> templatesCache
Cache of all tempaltes.

noCache

protected boolean noCache
Determines whether or not the result should allow caching.

stylesheetLocation

private String stylesheetLocation
Indicates the location of the xsl template.

matchingPattern

private String matchingPattern
Indicates the property name patterns which should be exposed to the xml.

exludingPattern

private String exludingPattern
Indicates the property name patterns which should be excluded from the xml.

exposedValue

private String exposedValue
Indicates the ognl expression respresenting the bean which is to be exposed as xml.

parse

private boolean parse

adapterFactory

private AdapterFactory adapterFactory
Constructor Detail

XSLTResult

public XSLTResult()

XSLTResult

public XSLTResult(String stylesheetLocation)
Method Detail

setNoCache

public void setNoCache(String val)

setLocation

public void setLocation(String location)
Deprecated. Use #setStylesheetLocation(String)

setStylesheetLocation

public void setStylesheetLocation(String location)

getStylesheetLocation

public String getStylesheetLocation()

getExposedValue

public String getExposedValue()

setExposedValue

public void setExposedValue(String exposedValue)

getMatchingPattern

public String getMatchingPattern()

setMatchingPattern

public void setMatchingPattern(String matchingPattern)

getExludingPattern

public String getExludingPattern()

setExludingPattern

public void setExludingPattern(String exludingPattern)

setParse

public void setParse(boolean parse)
If true, parse the stylesheet location for OGNL expressions.

Parameters:
parse -

execute

public void execute(ActionInvocation invocation)
             throws Exception
Description copied from interface: Result
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.

Specified by:
execute in interface Result
Throws:
Exception

getAdapterFactory

protected AdapterFactory getAdapterFactory()

setAdapterFactory

protected void setAdapterFactory(AdapterFactory adapterFactory)

getURIResolver

protected URIResolver getURIResolver()
Get the URI Resolver to be called by the processor when it encounters an xsl:include, xsl:import, or document() function. The default is an instance of ServletURIResolver, which operates relative to the servlet context.

getTemplates

protected Templates getTemplates(String path)
                          throws TransformerException,
                                 IOException
Throws:
TransformerException
IOException

getDOMSourceForStack

protected Source getDOMSourceForStack(Object value)
                               throws IllegalAccessException,
                                      InstantiationException
Throws:
IllegalAccessException
InstantiationException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


All Classes (Struts 2 Core 2.0.6 API)

 All Classes
AbstractAdapterElement
AbstractAdapterNode
AbstractCellRenderer
AbstractClosingTag
AbstractDirective
AbstractDoubleListTag
AbstractFieldValidatorDescription
AbstractFilterModel
AbstractInterceptor
AbstractListTag
AbstractRangeValidator
AbstractRemoteCallUIBean
AbstractRemoteCallUITag
AbstractRequiredListTag
AbstractUITag
Action
ActionAutowiringInterceptor
ActionChainResult
ActionComponent
ActionConfig
ActionConfigMatcher
ActionContext
ActionContext.ActionContextThreadLocal
ActionContextCleanUp
ActionDirective
ActionError
ActionErrorDirective
ActionErrorModel
ActionErrorTag
ActionEventListener
ActionInvocation
ActionMapper
ActionMapping
ActionMessage
ActionMessageDirective
ActionMessageModel
ActionMessageTag
ActionModel
ActionProxy
ActionProxyFactory
ActionSupport
ActionTag
ActionValidatorManager
ActionValidatorManagerFactory
AdapterFactory
AdapterNode
After
AliasInterceptor
Anchor
AnchorDirective
AnchorModel
AnchorTag
AnnotationActionValidatorManager
AnnotationUtils
AnnotationValidationConfigurationBuilder
AnnotationValidationInterceptor
AnnotationWorkflowInterceptor
AnnotationXWorkConverter
AppendIterator
AppendIteratorFilter
AppendIteratorTag
ApplicationAware
ApplicationMap
ArrayAdapter
AttributeMap
Autocompleter
AutocompleterDirective
AutocompleterModel
AutocompleterTag
BackgroundProcess
BaseTemplateEngine
Bean
BeanAdapter
BeanDirective
BeanModel
BeanSelectionProvider
BeanTag
Before
BeforeResult
BooleanCellRenderer
CallbackWriter
CellRenderer
ChainingInterceptor
Checkbox
CheckBoxDirective
CheckboxInterceptor
CheckboxList
CheckBoxListDirective
CheckboxListModel
CheckboxListTag
CheckboxModel
CheckboxTag
ClassLoaderUtil
ClassLoaderUtil.AggregateIterator
ClassLoaderUtils
ClasspathConfigurationProvider
ClasspathConfigurationProvider.ClasspathPageLocator
ClasspathConfigurationProvider.PageLocator
ClosingUIBean
CollectionAdapter
ComboBox
ComboBoxDirective
ComboBoxModel
ComboBoxTag
Component
ComponentDirective
ComponentModel
ComponentTag
ComponentTagSupport
CompositeActionMapper
CompoundRoot
CompoundRootAccessor
CompoundRootAccessor.MethodCall
Configuration
ConfigurationException
ConfigurationManager
ConfigurationProvider
ConfigurationUtil
ConstructionContext
ConstructionContext.DelegatingInvocationHandler
Container
ContainerBuilder
ContainerBuilder.Command
ContainerImpl
ContainerImpl.ConstructorInjector
ContainerImpl.ContextualCallable
ContainerImpl.FieldInjector
ContainerImpl.Injector
ContainerImpl.InjectorFactory
ContainerImpl.MethodInjector
ContainerImpl.MissingDependencyException
ContainerImpl.ParameterInjector
ContainUtil
Context
ContextUtil
Conversion
ConversionDescription
ConversionErrorFieldValidator
ConversionErrorFieldValidator
ConversionErrorFieldValidatorDescription
ConversionErrorInterceptor
ConversionRule
ConversionType
Counter
CreateIfNull
CreateSessionInterceptor
CustomValidator
Date
DateCellRenderer
DateDirective
DateFormatter
DateModel
DateRangeFieldValidator
DateRangeFieldValidator
DateRangeFieldValidatorDescription
DateTag
DateTimePicker
DateTimePickerDirective
DateTimePickerModel
DateTimePickerTag
Debug
DebuggingInterceptor
DebugTag
DefaultActionInvocation
DefaultActionMapper
DefaultActionMapper.ParameterAction
DefaultActionProxy
DefaultActionProxyFactory
DefaultActionSupport
DefaultActionValidatorManager
DefaultCellRenderer
DefaultConfiguration
DefaultObjectTypeDeterminer
DefaultPropertiesProvider
DefaultSettings
DefaultTagLibrary
DefaultTextProvider
DefaultWorkflowInterceptor
DelegatingSettings
DelegatingValidatorContext
DelegatingValidatorContext.ActionContextLocaleProvider
DelegatingValidatorContext.LoggingValidationAware
DependencyException
DirectRenderFromEventAction
Dispatcher
DispatcherListener
Div
DivDirective
DivModel
DivTag
DomHelper
DomHelper.DOMBuilder
DomHelper.StartHandler
DoubleListUIBean
DoubleRangeFieldValidator
DoubleRangeFieldValidator
DoubleRangeFieldValidatorDescription
DoubleSelect
DoubleSelectDirective
DoubleSelectModel
DoubleSelectTag
DWRValidator
DWRValidator.ValidatorActionInvocation
DWRValidator.ValidatorActionProxy
Element
Else
ElseIf
ElseIfModel
ElseIfTag
ElseModel
ElseTag
EmailValidator
EmailValidator
EmailValidatorDescription
EnumTypeConverter
ExceptionHolder
ExceptionMappingConfig
ExceptionMappingInterceptor
ExecuteAndWaitInterceptor
ExpressionValidator
ExpressionValidator
ExpressionValidatorDescription
ExternalContext
Factory
FastByteArrayOutputStream
FieldError
FieldErrorDirective
FieldErrorModel
FieldErrorTag
FieldExpressionValidator
FieldExpressionValidator
FieldExpressionValidatorDescription
FieldValidator
FieldValidatorSupport
File
FileDirective
FileManager
FileManager.FileRevision
FileModel
FileTag
FileUploadInterceptor
FilterDispatcher
FilterDispatcherCompatWeblogic61
FinalizablePhantomReference
FinalizableReference
FinalizableReferenceQueue
FinalizableSoftReference
FinalizableWeakReference
FixedTextCellRenderer
Form
FormButton
FormDirective
FormModel
FormTag
FreemarkerManager
FreemarkerResult
FreemarkerTemplateEngine
Function
GenericsObjectTypeDeterminer
GenericUIBean
Head
HeadDirective
HeadModel
HeadTag
Hidden
HiddenDirective
HiddenModel
HiddenTag
HttpHeaderResult
HttpServletRequestMock
I18n
I18nDirective
I18nInterceptor
I18nModel
I18nTag
If
IfModel
IfTag
Include
Include.PageOutputStream
Include.PageResponse
IncludeDirective
IncludeModel
IncludeTag
Inject
InputTransferSelect
InputTransferSelectDirective
InputTransferSelectModel
InputTransferSelectTag
InstantiatingNullHandler
Interceptor
InterceptorBuilder
InterceptorConfig
InterceptorListHolder
InterceptorMapping
InterceptorStackConfig
InternalContext
InternalFactory
IntRangeFieldValidator
IntRangeFieldValidator
IntRangeFieldValidatorDescription
InvalidMetadataException
InvocationSessionStore
InvocationSessionStore.InvocationContext
IteratorComponent
IteratorFilterSupport
IteratorGenerator
IteratorGenerator.Converter
IteratorGeneratorTag
IteratorModel
IteratorStatus
IteratorStatus.StatusState
IteratorTag
JakartaMultiPartRequest
JspSupportServlet
JspTemplateEngine
Jsr168Dispatcher
Key
Key
KeyProperty
Label
LabelDirective
LabelModel
LabelTag
LegacyPropertiesConfigurationProvider
LinkCellRenderer
ListEntry
ListUIBean
LocaleProvider
LocalizedTextUtil
LocalizedTextUtil.GetDefaultMessageReturnArg
LocalizedTextUtil.MessageFormatKey
Locatable
LocatableConstantFactory
LocatableFactory
LocatableProperties
Located
Location
LocationAttributes
LocationAttributes.Pipe
LocationImpl
LocationUtils
LocationUtils.LocationFinder
LoggingInterceptor
MakeIterator
MapAdapter
MergeIterator
MergeIteratorFilter
MergeIteratorTag
MessageStoreInterceptor
MethodConfigurationProvider
MethodFilterInterceptor
MethodFilterInterceptorUtil
MockActionInvocation
MockActionInvocation
MockActionProxy
MockConfiguration
MockInterceptor
MockObjectTypeDeterminer
MockResult
ModelDriven
ModelDrivenInterceptor
MultiPartRequest
MultiPartRequestWrapper
Namespace
NoParameters
NoParameters
NullResult
NumericCellRenderer
ObjectFactory
ObjectFactory.ContinuationsClassLoader
ObjectFactoryDestroyable
ObjectProfiler
ObjectProxy
ObjectProxyPropertyAccessor
ObjectTypeDeterminer
ObjectTypeDeterminerFactory
OgnlContextState
OgnlTool
OgnlUtil
OgnlValueStack
OgnlValueStack.ObjectAccessor
OgnlValueStackFactory
OptGroup
OptGroupDirective
OptGroupModel
OptGroupTag
OptionTransferSelect
OptionTransferSelectDirective
OptionTransferSelectModel
OptionTransferSelectTag
PackageConfig
Param
Param.UnnamedParametric
ParamDirective
ParameterAware
ParameterFilterInterceptor
Parameterizable
ParameterNameAware
ParameterRemoverInterceptor
ParametersInterceptor
ParamModel
ParamTag
ParentPackage
Password
PasswordDirective
PasswordModel
PasswordTag
PlainTextResult
PortletActionConstants
PortletActionContext
PortletApplicationMap
PortletFreemarkerResult
PortletPreferencesAware
PortletPreferencesInterceptor
PortletPrincipalProxy
PortletRequestMap
PortletResult
PortletResult.IncludeTemplate
PortletSessionMap
PortletUrlHelper
PortletVelocityResult
PrefixMethodInvocationUtil
PrefixTrie
PrefixTrie.Node
Preparable
PreparatorServlet
PrepareInterceptor
PreResultListener
PrettyPrintWriter
PrincipalAware
PrincipalProxy
ProfilingActivationInterceptor
ProfilingTimerBean
PropertiesReader
PropertiesSettings
Property
PropertyDirective
PropertyModel
PropertyTag
ProxyAttrAdapter
ProxyElementAdapter
ProxyNamedNodeMap
ProxyNodeAdapter
ProxyTextNodeAdapter
Push
PushDirective
PushModel
PushTag
Radio
RadioDirective
RadioModel
RadioTag
ReferenceCache
ReferenceMap
ReferenceMap.InternalReference
ReferenceMap.KeyReferenceAwareWrapper
ReferenceMap.PutStrategy
ReferenceMap.ReferenceAwareWrapper
ReferenceMap.Strategy
ReferenceResolverException
ReferenceType
RegexFieldValidator
RegexFieldValidator
RemoteUICallBean
RenderFilterModel
RepopulateConversionErrorFieldValidatorSupport
RequestAware
RequestMap
RequestUtils
RequiredFieldValidator
RequiredFieldValidator
RequiredFieldValidatorDescription
RequiredStringValidator
RequiredStringValidator
RequiredStringValidatorDescription
Reset
ResetDirective
ResetModel
ResetTag
ResolverUtil
ResolverUtil.AnnotatedWith
ResolverUtil.IsA
ResolverUtil.NameEndsWith
ResolverUtil.Test
ResourceUtil
Restful2ActionMapper
RestfulActionMapper
Result
Result
ResultConfig
Results
ResultTypeConfig
RolesInterceptor
RuntimeConfiguration
Scope
Scope.Strategy
Scoped
ScopedModelDriven
ScopedModelDrivenInterceptor
ScopeInterceptor
ScopesHashModel
Select
SelectDirective
SelectModel
SelectTag
ServletActionContext
ServletActionRedirectResult
ServletConfigInterceptor
ServletContextAware
ServletContextHolderListener
ServletContextSingleton
ServletDispatcherResult
ServletPortletPreferences
ServletPrincipalProxy
ServletRedirectResult
ServletRequestAware
ServletResponseAware
ServletURIResolver
SessionAware
SessionMap
Set
SetDirective
SetModel
SetTag
Settings
ShortCircuitableValidator
SimpleAdapterDocument
SimpleNodeList
SimpleTextNode
SkipValidation
SortableTableModel
Sorter
SortFilterModel
SortIteratorFilter
SortIteratorTag
SpringObjectFactory
SpringProxyableObjectFactory
StaticParametersInterceptor
StreamResult
StringAdapter
StringLengthFieldValidator
StringLengthFieldValidator
StringLengthFieldValidatorDescription
StringRegexValidator
Strings
StrutsActionProxy
StrutsActionProxyFactory
StrutsBeanWrapper
StrutsBeanWrapper.FriendlyMapModel
StrutsBodyTagSupport
StrutsClassTemplateLoader
StrutsConstants
StrutsConversionErrorInterceptor
StrutsException
StrutsModels
StrutsObjectFactory
StrutsRequestWrapper
StrutsResourceLoader
StrutsResultSupport
StrutsStatics
StrutsTag
StrutsTagAttribute
StrutsTestCase
StrutsTestCaseHelper
StrutsTypeConverter
StrutsUtil
StrutsUtil.ResponseWrapper
StrutsUtil.ServletOutputStreamWrapper
StrutsVelocityContext
StrutsXmlConfigurationProvider
Submit
SubmitDirective
SubmitModel
SubmitTag
SubsetIteratorFilter
SubsetIteratorFilter.Decider
SubsetIteratorTag
SurrugateList
TabbedPane
TabbedPanel
TabbedPanelDirective
TabbedPanelModel
TabbedPanelTag
TagLibrary
TagModel
TagUtils
Template
TemplateEngine
TemplateEngineManager
TemplateEngineManager.EngineFactory
TemplateRenderingContext
TestNGStrutsTestCase
TestNGXWorkTestCase
Text
TextArea
TextAreaDirective
TextAreaModel
TextareaTag
TextDirective
TextField
TextFieldDirective
TextFieldModel
TextFieldTag
TextModel
TextParseUtil
TextParseUtil.ParsedValueEvaluator
TextProvider
TextProviderFactory
TextProviderSupport
TextTag
TextUtil
TextUtils
Timer
TimerInterceptor
TimerInvocationHandler
Token
TokenDirective
TokenHelper
TokenInterceptor
TokenModel
TokenSessionStoreInterceptor
TokenTag
Tree
TreeDirective
TreeModel
TreeNode
TreeNodeDirective
TreeNodeModel
TreeNodeTag
TreeTag
TypeConversion
TypeConversionException
UIBean
Unchainable
UnknownHandler
UpDownSelect
UpDownSelectDirective
UpDownSelectModel
UpDownSelectTag
URL
URL.ExtraParameterProvider
URLBean
URLDirective
UrlHelper
URLModel
URLTag
UrlValidator
URLValidator
URLValidatorDescription
UtilTimerStack
UtilTimerStack.ProfilingBlock
Validateable
Validation
ValidationAware
ValidationAwareSupport
ValidationException
ValidationInterceptor
ValidationParameter
Validations
Validator
ValidatorConfig
ValidatorContext
ValidatorDescription
ValidatorFactory
ValidatorFileParser
ValidatorSupport
ValidatorType
ValueStack
ValueStackFactory
VelocityManager
VelocityResult
VelocityStrutsUtil
VelocityTemplateEngine
VisitorFieldValidator
VisitorFieldValidator
VisitorFieldValidatorDescription
WebTable
WebTableColumn
WebTableDirective
WebTableModel
WebTableTag
WildcardHelper
XmlConfigurationProvider
XmlHelper
XSLTResult
XWorkBasicConverter
XWorkCollectionPropertyAccessor
XWorkConverter
XWorkEnumerationAcccessor
XWorkException
XWorkIteratorPropertyAccessor
XWorkList
XWorkListPropertyAccessor
XWorkMap
XWorkMapPropertyAccessor
XWorkMessages
XWorkMethodAccessor
XWorkObjectPropertyAccessor
XWorkTestCase
XWorkTestCaseHelper


Constant Field Values (Struts 2 Core 2.0.6 API)

Constant Field Values

Contents
  • com.opensymphony.*
  • org.apache.*
com.opensymphony.*

com.opensymphony.xwork2.Action
public static final String | ERROR | "error"
public static final String | INPUT | "input"
public static final String | LOGIN | "login"
public static final String | NONE | "none"
public static final String | SUCCESS | "success"

com.opensymphony.xwork2.ActionChainResult
private static final String | CHAIN_HISTORY | "CHAIN_HISTORY"
public static final String | DEFAULT_PARAM | "actionName"
public static final String | SKIP_ACTIONS_PARAM | "skipActions"

com.opensymphony.xwork2.ActionContext
public static final String | ACTION_INVOCATION | "com.opensymphony.xwork2.ActionContext.actionInvocation"
public static final String | ACTION_NAME | "com.opensymphony.xwork2.ActionContext.name"
public static final String | APPLICATION | "com.opensymphony.xwork2.ActionContext.application"
public static final String | CONVERSION_ERRORS | "com.opensymphony.xwork2.ActionContext.conversionErrors"
public static final String | LOCALE | "com.opensymphony.xwork2.ActionContext.locale"
public static final String | PARAMETERS | "com.opensymphony.xwork2.ActionContext.parameters"
public static final String | SESSION | "com.opensymphony.xwork2.ActionContext.session"
public static final String | TYPE_CONVERTER | "com.opensymphony.xwork2.ActionContext.typeConverter"
public static final String | VALUE_STACK | "com.opensymphony.xwork2.util.ValueStack.ValueStack"

com.opensymphony.xwork2.DefaultActionInvocation
private static final long serialVersionUID -585293628862447329L

com.opensymphony.xwork2.DefaultActionProxy
private static final long serialVersionUID 3293074152487468527L

com.opensymphony.xwork2.XWorkMessages
public static final String | ACTION_EXECUTION_ERROR | "xwork.error.action.execution"
public static final String | DEFAULT_INVALID_FIELDVALUE | "xwork.default.invalid.fieldvalue"
public static final String | MISSING_ACTION_EXCEPTION | "xwork.exception.missing-action"
public static final String | MISSING_PACKAGE_ACTION_EXCEPTION | "xwork.exception.missing-package-action"

com.opensymphony.xwork2.config.impl.com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties
private static final long serialVersionUID -7320625750836896089L

com.opensymphony.xwork2.conversion.metadata.ConversionDescription
public static final String | DEPRECATED_ELEMENT_PREFIX | "Collection_"
public static final String | ELEMENT_PREFIX | "Element_"
public static final String | KEY_PREFIX | "Key_"
public static final String | KEY_PROPERTY_PREFIX | "KeyProperty_"

com.opensymphony.xwork2.inject.Container
public static final String DEFAULT_NAME "default"

com.opensymphony.xwork2.inject.util.ReferenceCache<K,V>
private static final long serialVersionUID 0L

com.opensymphony.xwork2.inject.util.ReferenceMap<K,V>
private static final long serialVersionUID 0L

com.opensymphony.xwork2.interceptor.AliasInterceptor
private static final String DEFAULT_ALIAS_KEY "aliases"

com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor
public static final String ORIGINAL_PROPERTY_OVERRIDE "original.property.override"

com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
private static final String | ALT_VALIDATE_PREFIX | "validateDo"
private static final long | serialVersionUID | 7563014655616490865L
private static final String | VALIDATE_PREFIX | "validate"

com.opensymphony.xwork2.interceptor.I18nInterceptor
public static final String | DEFAULT_PARAMETER | "request_locale"
public static final String | DEFAULT_SESSION_ATTRIBUTE | "WW_TRANS_I18N_LOCALE"

com.opensymphony.xwork2.interceptor.LoggingInterceptor
private static final String | FINISH_MESSAGE | "Finishing execution stack for action "
private static final String | START_MESSAGE | "Starting execution stack for action "

com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
private static final long serialVersionUID 1L

com.opensymphony.xwork2.interceptor.PrepareInterceptor
private static final String | ALT_PREPARE_PREFIX | "prepareDo"
private static final String | PREPARE_PREFIX | "prepare"
private static final long | serialVersionUID | -5216969014510719786L

com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor
private static final String GET_MODEL "getModel"

com.opensymphony.xwork2.mock.MockInterceptor
public static final String DEFAULT_FOO_VALUE "fooDefault"

com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
public static final String APPLICATION_CONTEXT "com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor.applicationContext"

com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer
public static final String | CREATE_IF_NULL_PREFIX | "CreateIfNull_"
public static final String | DEPRECATED_ELEMENT_PREFIX | "Collection_"
public static final String | ELEMENT_PREFIX | "Element_"
public static final String | KEY_PREFIX | "Key_"
public static final String | KEY_PROPERTY_PREFIX | "KeyProperty_"

com.opensymphony.xwork2.util.DomHelper
public static final String XMLNS_URI "http://www.w3.org/2000/xmlns/"

com.opensymphony.xwork2.util.InstantiatingNullHandler
public static final String CREATE_NULL_OBJECTS "xwork.NullHandler.createNullObjects"

com.opensymphony.xwork2.util.OgnlContextState
public static final String | CURRENT_PROPERTY_PATH | "current.property.path"
public static final String | FULL_PROPERTY_PATH | "current.property.path"
private static final String | GETTING_BY_KEY_PROPERTY | "xwork.getting.by.key.property"
private static final String | SET_MAP_KEY | "set.map.key"

com.opensymphony.xwork2.util.OgnlValueStack
private static final String | MAP_IDENTIFIER_KEY | "com.opensymphony.xwork2.util.OgnlValueStack.MAP_IDENTIFIER_KEY"
private static final long | serialVersionUID | 370737852934925530L

com.opensymphony.xwork2.util.PropertiesReader
static final String | COMMENT_CHARS | "#!"
private static final int | HEX_RADIX | 16
private static final int | UNICODE_LEN | 4

com.opensymphony.xwork2.util.ValueStack
public static final String | REPORT_ERRORS_ON_NO_PROP | "com.opensymphony.xwork2.util.ValueStack.ReportErrorsOnNoProp"
public static final String | VALUE_STACK | "com.opensymphony.xwork2.util.ValueStack.ValueStack"

com.opensymphony.xwork2.util.WildcardHelper
protected static final int | MATCH_BEGIN | -4
protected static final int | MATCH_END | -3
protected static final int | MATCH_FILE | -1
protected static final int | MATCH_PATH | -2
protected static final int | MATCH_THEEND | -5

com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor
private static final String | CONTEXT_COLLECTION_MAP | "xworkCollectionPropertyAccessorContextSetMap"
public static final String | KEY_PROPERTY_FOR_CREATION | "makeNew"

com.opensymphony.xwork2.util.XWorkConverter
public static final String | CONVERSION_COLLECTION_PREFIX | "Collection_"
public static final String | CONVERSION_ERROR_PROPERTY_PREFIX | "invalid.fieldvalue."
public static final String | CONVERSION_PROPERTY_FULLNAME | "conversion.property.fullName"
public static final String | LAST_BEAN_CLASS_ACCESSED | "last.bean.accessed"
public static final String | LAST_BEAN_PROPERTY_ACCESSED | "last.property.accessed"
public static final String | REPORT_CONVERSION_ERRORS | "report.conversion.errors"

com.opensymphony.xwork2.util.XWorkMethodAccessor
public static final String | DENY_INDEXED_ACCESS_EXECUTION | "xwork.IndexedPropertyAccessor.denyMethodExecution"
public static final String | DENY_METHOD_EXECUTION | "xwork.MethodAccessor.denyMethodExecution"

com.opensymphony.xwork2.util.location.LocationAttributes
public static final String | COL_ATTR | "column"
public static final String | LINE_ATTR | "line"
public static final String | PREFIX | "loc"
public static final String | Q_COL_ATTR | "loc:column"
public static final String | Q_LINE_ATTR | "loc:line"
public static final String | Q_SRC_ATTR | "loc:src"
public static final String | SRC_ATTR | "src"
public static final String | URI | "http://opensymphony.com/xwork/location"

com.opensymphony.xwork2.util.location.LocationUtils
public static final String UNKNOWN_STRING "[unknown location]"

com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
private static final long serialVersionUID -6180672043920208784L

com.opensymphony.xwork2.util.profiling.UtilTimerStack
public static final String | ACTIVATE_PROPERTY | "xwork.profile.activate"
public static final String | MIN_TIME | "xwork.profile.mintime"

com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
protected static final String VALIDATION_CONFIG_SUFFIX "-validation.xml"

com.opensymphony.xwork2.validator.DefaultActionValidatorManager
protected static final String VALIDATION_CONFIG_SUFFIX "-validation.xml"

com.opensymphony.xwork2.validator.ValidatorFileParser
static final String MULTI_TEXTVALUE_SEPARATOR " "

com.opensymphony.xwork2.validator.validators.EmailValidator
public static final String emailAddressPattern "\\b(^[_A-Za-z0-9-]+(\\.[_A-Za-z0-9-]+)*@([A-Za-z0-9-])+(\\.[A-Za-z0-9-]+)*((\\.[A-Za-z0-9]{2,})|(\\.[A-Za-z0-9]{2,}\\.[A-Za-z0-9]{2,}))$)\\b"

org.apache.*

org.apache.struts2.ServletActionContext
public static final String | ACTION_MAPPING | "struts.actionMapping"
private static final long | serialVersionUID | -666854718275106687L
public static final String | STRUTS_VALUESTACK_KEY | "struts.valueStack"

org.apache.struts2.StrutsConstants
public static final String | STRUTS_ACTION_EXTENSION | "struts.action.extension"
public static final String | STRUTS_ACTIONPROXYFACTORY | "struts.actionProxyFactory"
public static final String | STRUTS_ALWAYS_SELECT_FULL_NAMESPACE | "struts.mapper.alwaysSelectFullNamespace"
public static final String | STRUTS_CONFIGURATION | "struts.configuration"
public static final String | STRUTS_CONFIGURATION_XML_RELOAD | "struts.configuration.xml.reload"
public static final String | STRUTS_CONTINUATIONS_PACKAGE | "struts.continuations.package"
public static final String | STRUTS_CUSTOM_I18N_RESOURCES | "struts.custom.i18n.resources"
public static final String | STRUTS_CUSTOM_PROPERTIES | "struts.custom.properties"
public static final String | STRUTS_DEVMODE | "struts.devMode"
public static final String | STRUTS_DISPATCHER_PARAMETERSWORKAROUND | "struts.dispatcher.parametersWorkaround"
public static final String | STRUTS_ENABLE_DYNAMIC_METHOD_INVOCATION | "struts.enable.DynamicMethodInvocation"
public static final String | STRUTS_ENABLE_SLASHES_IN_ACTION_NAMES | "struts.enable.SlashesInActionNames"
public static final String | STRUTS_FREEMARKER_MANAGER_CLASSNAME | "struts.freemarker.manager.classname"
public static final String | STRUTS_FREEMARKER_WRAPPER_ALT_MAP | "struts.freemarker.wrapper.altMap"
public static final String | STRUTS_I18N_ENCODING | "struts.i18n.encoding"
public static final String | STRUTS_I18N_RELOAD | "struts.i18n.reload"
public static final String | STRUTS_LOCALE | "struts.locale"
public static final String | STRUTS_MAPPER_CLASS | "struts.mapper.class"
public static final String | STRUTS_MAPPER_COMPOSITE | "struts.mapper.composite"
public static final String | STRUTS_MULTIPART_MAXSIZE | "struts.multipart.maxSize"
public static final String | STRUTS_MULTIPART_PARSER | "struts.multipart.parser"
public static final String | STRUTS_MULTIPART_SAVEDIR | "struts.multipart.saveDir"
public static final String | STRUTS_OBJECTFACTORY | "struts.objectFactory"
public static final String | STRUTS_OBJECTFACTORY_SPRING_AUTOWIRE | "struts.objectFactory.spring.autoWire"
public static final String | STRUTS_OBJECTFACTORY_SPRING_USE_CLASS_CACHE | "struts.objectFactory.spring.useClassCache"
public static final String | STRUTS_OBJECTTYPEDETERMINER | "struts.objectTypeDeterminer"
public static final String | STRUTS_SERVE_STATIC_BROWSER_CACHE | "struts.serve.static.browserCache"
public static final String | STRUTS_SERVE_STATIC_CONTENT | "struts.serve.static"
public static final String | STRUTS_TAG_ALTSYNTAX | "struts.tag.altSyntax"
public static final String | STRUTS_UI_TEMPLATEDIR | "struts.ui.templateDir"
public static final String | STRUTS_UI_THEME | "struts.ui.theme"
public static final String | STRUTS_URL_HTTP_PORT | "struts.url.http.port"
public static final String | STRUTS_URL_HTTPS_PORT | "struts.url.https.port"
public static final String | STRUTS_URL_INCLUDEPARAMS | "struts.url.includeParams"
public static final String | STRUTS_VELOCITY_CONFIGFILE | "struts.velocity.configfile"
public static final String | STRUTS_VELOCITY_CONTEXTS | "struts.velocity.contexts"
public static final String | STRUTS_VELOCITY_MANAGER_CLASSNAME | "struts.velocity.manager.classname"
public static final String | STRUTS_VELOCITY_TOOLBOXLOCATION | "struts.velocity.toolboxlocation"
public static final String | STRUTS_XSLT_NOCACHE | "struts.xslt.nocache"
public static final String | STRUTS_XWORKCONVERTER | "struts.xworkConverter"

org.apache.struts2.StrutsException
private static final long serialVersionUID 888724366243600135L

org.apache.struts2.StrutsStatics
public static final String | HTTP_REQUEST | "com.opensymphony.xwork2.dispatcher.HttpServletRequest"
public static final String | HTTP_RESPONSE | "com.opensymphony.xwork2.dispatcher.HttpServletResponse"
public static final String | PAGE_CONTEXT | "com.opensymphony.xwork2.dispatcher.PageContext"
public static final String | SERVLET_CONTEXT | "com.opensymphony.xwork2.dispatcher.ServletContext"
public static final String | SERVLET_DISPATCHER | "com.opensymphony.xwork2.dispatcher.ServletDispatcher"
public static final String | STRUTS_PORTLET_CONTEXT | "struts.portlet.context"

org.apache.struts2.components.ActionError
public static final String TEMPLATE "actionerror"

org.apache.struts2.components.ActionMessage
private static final String TEMPLATE "actionmessage"

org.apache.struts2.components.Anchor
public static final String | OPEN_TEMPLATE | "a"
public static final String | TEMPLATE | "a-close"

org.apache.struts2.components.Autocompleter
public static final String TEMPLATE "autocompleter"

org.apache.struts2.components.Checkbox
public static final String TEMPLATE "checkbox"

org.apache.struts2.components.CheckboxList
public static final String TEMPLATE "checkboxlist"

org.apache.struts2.components.ComboBox
public static final String TEMPLATE "combobox"

org.apache.struts2.components.Component
public static final String COMPONENT_STACK "__component_stack"

org.apache.struts2.components.Date
private static final String | DATETAG_DEFAULT_DAYS | "{0,choice,1#one day|1<{0} days}{1,choice,0#|1#, one hour|1<, {1} hours}"
private static final String | DATETAG_DEFAULT_FUTURE | "in {0}"
private static final String | DATETAG_DEFAULT_HOURS | "{0,choice,1#one hour|1<{0} hours}{1,choice,0#|1#, one minute|1<, {1} minutes}"
private static final String | DATETAG_DEFAULT_MINUTES | "{0,choice,1#one minute|1<{0} minutes}"
private static final String | DATETAG_DEFAULT_PAST | "{0} ago"
private static final String | DATETAG_DEFAULT_SECONDS | "an instant"
private static final String | DATETAG_DEFAULT_YEARS | "{0,choice,1#one year|1<{0} years}{1,choice,0#|1#, one day|1<, {1} days}"
public static final String | DATETAG_PROPERTY | "struts.date.format"
public static final String | DATETAG_PROPERTY_DAYS | "struts.date.format.days"
public static final String | DATETAG_PROPERTY_FUTURE | "struts.date.format.future"
public static final String | DATETAG_PROPERTY_HOURS | "struts.date.format.hours"
public static final String | DATETAG_PROPERTY_MINUTES | "struts.date.format.minutes"
public static final String | DATETAG_PROPERTY_PAST | "struts.date.format.past"
public static final String | DATETAG_PROPERTY_SECONDS | "struts.date.format.seconds"
public static final String | DATETAG_PROPERTY_YEARS | "struts.date.format.years"

org.apache.struts2.components.DateTimePicker
public static final String TEMPLATE "datetimepicker"

org.apache.struts2.components.Debug
public static final String TEMPLATE "debug"

org.apache.struts2.components.Div
public static final String | TEMPLATE | "div"
public static final String | TEMPLATE_CLOSE | "div-close"

org.apache.struts2.components.DoubleSelect
public static final String TEMPLATE "doubleselect"

org.apache.struts2.components.FieldError
private static final String TEMPLATE "fielderror"

org.apache.struts2.components.File
public static final String TEMPLATE "file"

org.apache.struts2.components.Form
public static final String | OPEN_TEMPLATE | "form"
public static final String | TEMPLATE | "form-close"

org.apache.struts2.components.FormButton
static final String | BUTTONTYPE_BUTTON | "button"
static final String | BUTTONTYPE_IMAGE | "image"
static final String | BUTTONTYPE_INPUT | "input"

org.apache.struts2.components.GenericUIBean
private static final String TEMPLATE "empty"

org.apache.struts2.components.Head
public static final String TEMPLATE "head"

org.apache.struts2.components.Hidden
public static final String TEMPLATE "hidden"

org.apache.struts2.components.If
public static final String ANSWER "struts.if.answer"

org.apache.struts2.components.InputTransferSelect
private static final String TEMPLATE "inputtransferselect"

org.apache.struts2.components.Label
public static final String TEMPLATE "label"

org.apache.struts2.components.OptGroup
public static final String INTERNAL_LIST_UI_BEAN_LIST_PARAMETER_KEY "optGroupInternalListUiBeanList"

org.apache.struts2.components.OptionTransferSelect
private static final String TEMPLATE "optiontransferselect"

org.apache.struts2.components.Password
public static final String TEMPLATE "password"

org.apache.struts2.components.Radio
public static final String TEMPLATE "radiomap"

org.apache.struts2.components.Reset
public static final String TEMPLATE "reset"

org.apache.struts2.components.Select
public static final String TEMPLATE "select"

org.apache.struts2.components.Submit
public static final String TEMPLATE "submit"

org.apache.struts2.components.TabbedPanel
public static final String | TEMPLATE | "tabbedpanel"
public static final String | TEMPLATE_CLOSE | "tabbedpanel-close"

org.apache.struts2.components.TextArea
public static final String TEMPLATE "textarea"

org.apache.struts2.components.TextField
public static final String TEMPLATE "text"

org.apache.struts2.components.Token
public static final String TEMPLATE "token"

org.apache.struts2.components.Tree
private static final String | OPEN_TEMPLATE | "tree"
private static final String | TEMPLATE | "tree-close"

org.apache.struts2.components.TreeNode
private static final String | OPEN_TEMPLATE | "treenode"
private static final String | TEMPLATE | "treenode-close"

org.apache.struts2.components.UpDownSelect
public static final String TEMPLATE "updownselect"

org.apache.struts2.components.URL
public static final String | ALL | "all"
public static final String | GET | "get"
public static final String | NONE | "none"

org.apache.struts2.components.table.RenderFilterModel
private static final long serialVersionUID -2501708467650344057L

org.apache.struts2.components.table.SortableTableModel
public static final String | ASC | "ASC"
public static final String | DESC | "DESC"
public static final String | NONE | "NONE"

org.apache.struts2.components.table.SortFilterModel
private static final long serialVersionUID 2214225803442793597L

org.apache.struts2.components.table.WebTable
public static final String TEMPLATE "table"

org.apache.struts2.components.table.WebTable.WebTableRowIterator
public static final int | FORMATTED_DATA | 0
public static final int | RAW_DATA | 1

org.apache.struts2.components.template.BaseTemplateEngine
public static final String DEFAULT_THEME_PROPERTIES_FILE_NAME "theme.properties"

org.apache.struts2.components.template.TemplateEngineManager
public static final String | DEFAULT_TEMPLATE_TYPE | "ftl"
public static final String | DEFAULT_TEMPLATE_TYPE_CONFIG_KEY | "struts.ui.templateSuffix"

org.apache.struts2.config.BeanSelectionProvider
public static final String DEFAULT_BEAN_NAME "struts"

org.apache.struts2.config.ClasspathConfigurationProvider
private static final String | ACTION | "Action"
private static final String | DEFAULT_PAGE_EXTENSION | "struts.configuration.classpath.defaultPageExtension"
private static final String | DEFAULT_PAGE_PREFIX | "struts.configuration.classpath.defaultPagePrefix"
private static final String | DEFAULT_PARENT_PACKAGE | "struts.configuration.classpath.defaultParentPackage"
private static final String | FORCE_LOWER_CASE | "struts.configuration.classpath.forceLowerCase"

org.apache.struts2.dispatcher.ActionContextCleanUp
private static final String COUNTER "__cleanup_recursion_counter"

org.apache.struts2.dispatcher.ApplicationMap
private static final long serialVersionUID 9136809763083228202L

org.apache.struts2.dispatcher.DefaultActionSupport
private static final long serialVersionUID -2426166391283746095L

org.apache.struts2.dispatcher.Dispatcher
private static final String DEFAULT_CONFIGURATION_PATHS "struts-default.xml,struts-plugin.xml,struts.xml"

org.apache.struts2.dispatcher.HttpHeaderResult
public static final String | DEFAULT_PARAM | "status"
private static final long | serialVersionUID | 195648957144219214L

org.apache.struts2.dispatcher.PlainTextResult
public static final int | BUFFER_SIZE | 1024
private static final long | serialVersionUID | 3633371605905583950L

org.apache.struts2.dispatcher.RequestMap
private static final long serialVersionUID -7675640869293787926L

org.apache.struts2.dispatcher.ServletActionRedirectResult
public static final String | DEFAULT_PARAM | "actionName"
private static final long | serialVersionUID | -9042425229314584066L

org.apache.struts2.dispatcher.ServletDispatcherResult
private static final long serialVersionUID -1970659272360685627L

org.apache.struts2.dispatcher.ServletRedirectResult
private static final long serialVersionUID 6316947346435301270L

org.apache.struts2.dispatcher.SessionMap
private static final long serialVersionUID 4678843241638046854L

org.apache.struts2.dispatcher.StreamResult
public static final String | DEFAULT_PARAM | "inputName"
private static final long | serialVersionUID | -1468409635999059850L

org.apache.struts2.dispatcher.StrutsResultSupport
public static final String DEFAULT_PARAM "location"

org.apache.struts2.dispatcher.VelocityResult
private static final long serialVersionUID 7268830767762559424L

org.apache.struts2.dispatcher.mapper.DefaultActionMapper
static final String | ACTION_PREFIX | "action:"
static final String | METHOD_PREFIX | "method:"
static final String | REDIRECT_ACTION_PREFIX | "redirect-action:"
static final String | REDIRECT_PREFIX | "redirect:"

org.apache.struts2.dispatcher.mapper.Restful2ActionMapper
private static final String HTTP_METHOD_PARAM "__http_method"

org.apache.struts2.impl.StrutsActionProxy
private static final long serialVersionUID -2434901249671934080L

org.apache.struts2.interceptor.BackgroundProcess
private static final long serialVersionUID 3884464776311686443L

org.apache.struts2.interceptor.CheckboxInterceptor
private static final long serialVersionUID -586878104807229585L

org.apache.struts2.interceptor.CreateSessionInterceptor
private static final long serialVersionUID -4590322556118858869L

org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
public static final String | KEY | "__execWait"
private static final long | serialVersionUID | -2754639196749652512L
public static final String | WAIT | "wait"

org.apache.struts2.interceptor.FileUploadInterceptor
private static final String | DEFAULT_DELIMITER | ","
private static final String | DEFAULT_MESSAGE | "no.message.found"
private static final long | serialVersionUID | -4764627478894962478L

org.apache.struts2.interceptor.MessageStoreInterceptor
public static final String | NONE | "NONE"
public static final String | RETRIEVE_MODE | "RETRIEVE"
private static final long | serialVersionUID | 4491997514314242420L
public static final String | STORE_MODE | "STORE"

org.apache.struts2.interceptor.ScopeInterceptor
private static final long serialVersionUID 9120762699600054395L

org.apache.struts2.interceptor.ServletConfigInterceptor
private static final long serialVersionUID 605261777858676638L

org.apache.struts2.interceptor.StrutsConversionErrorInterceptor
private static final long serialVersionUID 2759744840082921602L

org.apache.struts2.interceptor.TokenInterceptor
public static final String | INVALID_TOKEN_CODE | "invalid.token"
private static final long | serialVersionUID | -6680894220590585506L

org.apache.struts2.interceptor.TokenSessionStoreInterceptor
private static final long serialVersionUID -9032347965469098195L

org.apache.struts2.interceptor.debugging.DebuggingInterceptor
private static final String | COMMAND_MODE | "command"
private static final String | CONSOLE_MODE | "console"
private static final String | DEBUG_PARAM | "debug"
private static final String | EXPRESSION_PARAM | "expression"
private static final long | serialVersionUID | -3097324155953078783L
private static final String | SESSION_KEY | "org.apache.struts2.interceptor.debugging.VALUE_STACK"
private static final String | XML_MODE | "xml"

org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor
private static final long serialVersionUID 1813272797367431184L

org.apache.struts2.portlet.PortletActionConstants
public static final String | ACTION_PARAM | "struts.portlet.action"
public static final String | DEFAULT_ACTION_FOR_MODE | "struts.portlet.defaultActionForMode"
public static final String | DEFAULT_ACTION_NAME | "default"
public static final String | ERROR_ACTION | "errorHandler"
public static final String | EVENT_ACTION | "struts.portlet.eventAction"
public static final String | MODE_NAMESPACE_MAP | "struts.portlet.modeNamespaceMap"
public static final String | MODE_PARAM | "struts.portlet.mode"
public static final String | PHASE | "struts.portlet.phase"
public static final String | PORTLET_CONFIG | "struts.portlet.config"
public static final String | PORTLET_NAMESPACE | "struts.portlet.portletNamespace"
public static final String | REQUEST | "struts.portlet.request"
public static final String | RESPONSE | "struts.portlet.response"

org.apache.struts2.portlet.PortletApplicationMap
private static final long serialVersionUID 2296107511063504414L

org.apache.struts2.portlet.context.PreparatorServlet
private static final long serialVersionUID 1853399729352984089L

org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction
private static final long serialVersionUID -1814807772308405785L

org.apache.struts2.portlet.result.PortletResult
private static final long serialVersionUID 434251393926178567L

org.apache.struts2.portlet.result.PortletVelocityResult
private static final long serialVersionUID -8241086555872212274L

org.apache.struts2.portlet.util.PortletUrlHelper
public static final String ENCODING "UTF-8"

org.apache.struts2.util.AttributeMap
protected static final String UNSUPPORTED "method makes no sense for a simplified map"

org.apache.struts2.util.Counter
private static final long serialVersionUID 2796965884308060179L

org.apache.struts2.util.FastByteArrayOutputStream
private static final int DEFAULT_BLOCK_SIZE 8192

org.apache.struts2.util.InvocationSessionStore
private static final String INVOCATION_MAP_KEY "org.apache.struts2.util.InvocationSessionStore.invocationMap"

org.apache.struts2.util.org.apache.struts2.util.InvocationSessionStore.InvocationContext
private static final long serialVersionUID -286697666275777888L

org.apache.struts2.util.PrefixTrie
private static final int SIZE 128

org.apache.struts2.util.TokenHelper
public static final String | DEFAULT_TOKEN_NAME | "struts.token"
public static final String | TOKEN_NAME_FIELD | "struts.token.name"

org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation
private static final long serialVersionUID -7645433725470191275L

org.apache.struts2.validators.DWRValidator.ValidatorActionProxy
private static final long serialVersionUID 5754781916414047963L

org.apache.struts2.views.JspSupportServlet
private static final long serialVersionUID 8302309812391541933L

org.apache.struts2.views.freemarker.FreemarkerManager
private static final String | ATTR_APPLICATION_MODEL | ".freemarker.Application"
private static final String | ATTR_JSP_TAGLIBS_MODEL | ".freemarker.JspTaglibs"
private static final String | ATTR_REQUEST_MODEL | ".freemarker.Request"
private static final String | ATTR_REQUEST_PARAMETERS_MODEL | ".freemarker.RequestParameters"
public static final String | CONFIG_SERVLET_CONTEXT_KEY | "freemarker.Configuration"
public static final String | KEY_APPLICATION | "Application"
public static final String | KEY_EXCEPTION | "exception"
public static final String | KEY_JSP_TAGLIBS | "JspTaglibs"
public static final String | KEY_REQUEST_MODEL | "Request"
public static final String | KEY_REQUEST_PARAMETER_MODEL | "Parameters"
public static final String | KEY_SESSION_MODEL | "Session"

org.apache.struts2.views.freemarker.FreemarkerResult
private static final long serialVersionUID -3778230771704661631L

org.apache.struts2.views.freemarker.PortletFreemarkerResult
private static final long serialVersionUID -5570612389289887543L

org.apache.struts2.views.freemarker.ScopesHashModel
private static final long serialVersionUID 5551686380141886764L

org.apache.struts2.views.jsp.ActionTag
private static final long serialVersionUID -5384167073331678855L

org.apache.struts2.views.jsp.BeanTag
private static final long serialVersionUID -3863152522071209267L

org.apache.struts2.views.jsp.DateTag
private static final long serialVersionUID -6216963123295613440L

org.apache.struts2.views.jsp.ElseIfTag
private static final long serialVersionUID -3872016920741400345L

org.apache.struts2.views.jsp.ElseTag
private static final long serialVersionUID 8166807953193406785L

org.apache.struts2.views.jsp.I18nTag
private static final long serialVersionUID -7914587341936116887L

org.apache.struts2.views.jsp.IfTag
private static final long serialVersionUID 4448870162549923833L

org.apache.struts2.views.jsp.IncludeTag
private static final long serialVersionUID -1585165567043278243L

org.apache.struts2.views.jsp.IteratorTag
private static final long serialVersionUID -1827978135193581901L

org.apache.struts2.views.jsp.ParamTag
private static final long serialVersionUID -968332732207156408L

org.apache.struts2.views.jsp.PropertyTag
private static final long serialVersionUID 435308349113743852L

org.apache.struts2.views.jsp.PushTag
private static final long serialVersionUID -1357895305148907931L

org.apache.struts2.views.jsp.SetTag
private static final long serialVersionUID -5074213926790716974L

org.apache.struts2.views.jsp.StrutsBodyTagSupport
private static final long serialVersionUID -1201668454354226175L

org.apache.struts2.views.jsp.TextTag
private static final long serialVersionUID -3075088084198264581L

org.apache.struts2.views.jsp.URLTag
private static final long serialVersionUID 1722460444125206226L

org.apache.struts2.views.jsp.iterator.AppendIteratorTag
private static final long serialVersionUID -6017337859763283691L

org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag
public static final String | DEFAULT_SEPARATOR | ","
private static final long | serialVersionUID | 2968037295463973936L

org.apache.struts2.views.jsp.iterator.MergeIteratorTag
private static final long serialVersionUID 4999729472466011218L

org.apache.struts2.views.jsp.iterator.SortIteratorTag
private static final long serialVersionUID -7835719609764092235L

org.apache.struts2.views.jsp.iterator.SubsetIteratorTag
private static final long serialVersionUID -6252696081713080102L

org.apache.struts2.views.jsp.ui.ActionErrorTag
private static final long serialVersionUID -3710234378022378639L

org.apache.struts2.views.jsp.ui.ActionMessageTag
private static final long serialVersionUID 243396927554182506L

org.apache.struts2.views.jsp.ui.AnchorTag
private static final long serialVersionUID -1034616578492431113L

org.apache.struts2.views.jsp.ui.AutocompleterTag
private static final long serialVersionUID -1112470447573172581L

org.apache.struts2.views.jsp.ui.CheckboxListTag
private static final long serialVersionUID 4023034029558150010L

org.apache.struts2.views.jsp.ui.CheckboxTag
private static final long serialVersionUID -350752809266337636L

org.apache.struts2.views.jsp.ui.ComboBoxTag
private static final long serialVersionUID 3509392460170385605L

org.apache.struts2.views.jsp.ui.ComponentTag
private static final long serialVersionUID 5448365363044104731L

org.apache.struts2.views.jsp.ui.DateTimePickerTag
private static final long serialVersionUID 4054114507143447232L

org.apache.struts2.views.jsp.ui.DebugTag
private static final long serialVersionUID 3487684841317160628L

org.apache.struts2.views.jsp.ui.DivTag
private static final long serialVersionUID 5309231035916461758L

org.apache.struts2.views.jsp.ui.DoubleSelectTag
private static final long serialVersionUID 7426011596359509386L

org.apache.struts2.views.jsp.ui.FieldErrorTag
private static final long serialVersionUID -182532967507726323L

org.apache.struts2.views.jsp.ui.FileTag
private static final long serialVersionUID -2154950640215144864L

org.apache.struts2.views.jsp.ui.FormTag
private static final long serialVersionUID 2792301046860819658L

org.apache.struts2.views.jsp.ui.HeadTag
private static final long serialVersionUID 6876765769175246030L

org.apache.struts2.views.jsp.ui.HiddenTag
private static final long serialVersionUID -1124367972048371675L

org.apache.struts2.views.jsp.ui.InputTransferSelectTag
private static final long serialVersionUID 250474334495763536L

org.apache.struts2.views.jsp.ui.LabelTag
private static final long serialVersionUID 4008321310097730458L

org.apache.struts2.views.jsp.ui.OptGroupTag
private static final long serialVersionUID 7367401003498678762L

org.apache.struts2.views.jsp.ui.OptionTransferSelectTag
private static final long serialVersionUID 250474334495763536L

org.apache.struts2.views.jsp.ui.PasswordTag
private static final long serialVersionUID 6802043323617377573L

org.apache.struts2.views.jsp.ui.RadioTag
private static final long serialVersionUID -6497403399521333624L

org.apache.struts2.views.jsp.ui.ResetTag
private static final long serialVersionUID 4742704832277392108L

org.apache.struts2.views.jsp.ui.SelectTag
private static final long serialVersionUID 6121715260335609618L

org.apache.struts2.views.jsp.ui.SubmitTag
private static final long serialVersionUID 2179281109958301343L

org.apache.struts2.views.jsp.ui.TabbedPanelTag
private static final long serialVersionUID -4719930205515386252L

org.apache.struts2.views.jsp.ui.TextareaTag
private static final long serialVersionUID -4107122506712927927L

org.apache.struts2.views.jsp.ui.TextFieldTag
private static final long serialVersionUID 5811285953670562288L

org.apache.struts2.views.jsp.ui.TokenTag
private static final long serialVersionUID 722480798151703457L

org.apache.struts2.views.jsp.ui.TreeNodeTag
private static final long serialVersionUID 7340746943017900803L

org.apache.struts2.views.jsp.ui.TreeTag
private static final long serialVersionUID 2735218501058548013L

org.apache.struts2.views.jsp.ui.UpDownSelectTag
private static final long serialVersionUID -8136573053799541353L

org.apache.struts2.views.jsp.ui.table.WebTableTag
private static final long serialVersionUID 2978932111492397942L

org.apache.struts2.views.util.ContextUtil
public static final String | ACTION | "action"
public static final String | BASE | "base"
public static final String | OGNL | "ognl"
public static final String | REQUEST | "request"
public static final String | REQUEST2 | "request"
public static final String | RESPONSE | "response"
public static final String | RESPONSE2 | "response"
public static final String | SESSION | "session"
public static final String | STACK | "stack"
public static final String | STRUTS | "struts"

org.apache.struts2.views.util.TextUtil
protected static final int MAX_LENGTH 300

org.apache.struts2.views.util.UrlHelper
private static final String | AMP | "&amp;"
private static final int | DEFAULT_HTTP_PORT | 80
private static final int | DEFAULT_HTTPS_PORT | 443

org.apache.struts2.views.velocity.StrutsVelocityContext
private static final long serialVersionUID 8497212428904436963L

org.apache.struts2.views.velocity.VelocityManager
public static final String | PARENT | "parent"
public static final String | STRUTS | "struts"
public static final String | TAG | "tag"

org.apache.struts2.views.xslt.ServletURIResolver
static final String PROTOCOL "response:"

org.apache.struts2.views.xslt.XSLTResult
public static final String | DEFAULT_PARAM | "stylesheetLocation"
private static final long | serialVersionUID | 6424691441777176763L

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Deprecated List (Struts 2 Core 2.0.6 API)

Deprecated API

Contents
  • Deprecated Classes
  • Deprecated Methods
Deprecated Classes
com.opensymphony.xwork2.MockActionInvocation
Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead
com.opensymphony.xwork2.util.XWorkList
Native support for expanding lists and maps is provided in XWork 1.1, so this is no longer needed.
com.opensymphony.xwork2.util.XWorkMap
Native support for expanding lists and maps is provided in XWork 1.1, so this is no longer needed.

Deprecated Methods
com.opensymphony.xwork2.ActionSupport.getErrorMessages()
Use ActionSupport.getActionErrors().
com.opensymphony.xwork2.ActionSupport.getErrors()
Use ActionSupport.getFieldErrors().
org.apache.struts2.interceptor.PrincipalProxy.getRequest()
To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
org.apache.struts2.portlet.interceptor.PortletPrincipalProxy.getRequest()
To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
org.apache.struts2.servlet.interceptor.ServletPrincipalProxy.getRequest()
To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
com.opensymphony.xwork2.XWorkException.getThrowable()
Use getCause()
org.apache.struts2.components.Token.getTokenNameField()
Templates should use $parameters from now on, not $tag.
com.opensymphony.xwork2.validator.ValidatorFactory.getValidator(ValidatorConfig)
org.apache.struts2.util.StrutsUtil.include(Object, HttpServletRequest, HttpServletResponse)
the request and response are stored in this util class, please use include(string)
com.opensymphony.xwork2.validator.ValidatorFileParser.parseValidatorDefinitions(InputStream)
Use parseValidatorDefinitions(InputStream, String)
com.opensymphony.xwork2.validator.ValidatorFileParser.parseValidatorDefinitions(InputStream, String)
org.apache.struts2.views.xslt.XSLTResult.setLocation(String)
Use #setStylesheetLocation(String)
org.apache.struts2.views.jsp.ui.TextFieldTag.setMaxLength(String)
please use TextFieldTag.setMaxlength(java.lang.String) instead
org.apache.struts2.views.jsp.ui.SubmitTag.setOnLoadJS(String)
org.apache.struts2.views.jsp.ui.SubmitTag.setPreInvokeJS(String)
org.apache.struts2.views.jsp.ui.AnchorTag.setPreInvokeJS(String)
org.apache.struts2.views.jsp.ui.SubmitTag.setResultDivId(String)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help (Struts 2 Core 2.0.6 API)

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Struts 2 Core 2.0.6 API

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Index (Struts 2 Core 2.0.6 API)

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV NEXT

FRAMES NO FRAMES

A B C D E F G H I J K L M N O P Q R S T U V W X _

A

a - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

AbstractAdapterElement - Class in org.apache.struts2.views.xslt
AbstractAdapterElement extends the abstract Node type and implements the DOM Element interface.
AbstractAdapterElement() - Constructor for class org.apache.struts2.views.xslt.AbstractAdapterElement

AbstractAdapterNode - Class in org.apache.struts2.views.xslt
AbstractAdapterNode is the base for childAdapters that expose a read-only view of a Java object as a DOM Node.
AbstractAdapterNode() - Constructor for class org.apache.struts2.views.xslt.AbstractAdapterNode

AbstractCellRenderer - Class in org.apache.struts2.components.table.renderer
this is the base class that most renderers will be derived from.
AbstractCellRenderer() - Constructor for class org.apache.struts2.components.table.renderer.AbstractCellRenderer

AbstractClosingTag - Class in org.apache.struts2.views.jsp.ui

AbstractClosingTag() - Constructor for class org.apache.struts2.views.jsp.ui.AbstractClosingTag

AbstractDirective - Class in org.apache.struts2.views.velocity.components

AbstractDirective() - Constructor for class org.apache.struts2.views.velocity.components.AbstractDirective

AbstractDoubleListTag - Class in org.apache.struts2.views.jsp.ui

AbstractDoubleListTag() - Constructor for class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

AbstractFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
AbstractFieldValidatorDescription
AbstractFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

AbstractFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
AbstractFilterModel - Class in org.apache.struts2.components.table

AbstractFilterModel(TableModel) - Constructor for class org.apache.struts2.components.table.AbstractFilterModel

AbstractInterceptor - Class in com.opensymphony.xwork2.interceptor
Provides default implementations of optional lifecycle methods
AbstractInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.AbstractInterceptor

AbstractListTag - Class in org.apache.struts2.views.jsp.ui

AbstractListTag() - Constructor for class org.apache.struts2.views.jsp.ui.AbstractListTag

AbstractRangeValidator - Class in com.opensymphony.xwork2.validator.validators
Base class for range based validators.
AbstractRangeValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator

AbstractRemoteCallUIBean - Class in org.apache.struts2.components
TODO: Document AbstractRemoteCallUIBean.
AbstractRemoteCallUIBean(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.AbstractRemoteCallUIBean

AbstractRemoteCallUITag - Class in org.apache.struts2.views.jsp.ui

AbstractRemoteCallUITag() - Constructor for class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

AbstractRequiredListTag - Class in org.apache.struts2.views.jsp.ui

AbstractRequiredListTag() - Constructor for class org.apache.struts2.views.jsp.ui.AbstractRequiredListTag

AbstractUITag - Class in org.apache.struts2.views.jsp.ui
Abstract base class for all UI tags.
AbstractUITag() - Constructor for class org.apache.struts2.views.jsp.ui.AbstractUITag

accept - Variable in class org.apache.struts2.components.File

accept - Variable in class org.apache.struts2.views.jsp.ui.FileTag

acceptableErrorValue(Class) - Method in class com.opensymphony.xwork2.util.XWorkConverter
not used
acceptableName(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

acceptableParameterName(String) - Method in interface com.opensymphony.xwork2.interceptor.ParameterNameAware
Returns true if the action will accept the parameter with the given name.
acceptcharset - Variable in class org.apache.struts2.components.Form

acceptcharset - Variable in class org.apache.struts2.views.jsp.ui.FormTag

acceptFile(File, String, String, ValidationAware, Locale) - Method in class org.apache.struts2.interceptor.FileUploadInterceptor
Override for added functionality.
accesskey - Variable in class org.apache.struts2.components.UIBean

accesskey - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

accessor - Static variable in class com.opensymphony.xwork2.util.OgnlValueStack

Action - Interface in com.opensymphony.xwork2
All actions may implement this interface, which exposes the execute() method.
action - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

action - Variable in class com.opensymphony.xwork2.mock.MockActionInvocation

action - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

action - Variable in class org.apache.struts2.components.Form

action - Variable in class org.apache.struts2.components.FormButton

action - Variable in class org.apache.struts2.components.Reset

action - Variable in class org.apache.struts2.components.URL

ACTION - Static variable in class org.apache.struts2.config.ClasspathConfigurationProvider
Default suffix that can be used to indicate POJO "Action" classes.
action - Variable in class org.apache.struts2.interceptor.BackgroundProcess

action - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

action - Variable in class org.apache.struts2.views.jsp.ui.FormTag

action - Variable in class org.apache.struts2.views.jsp.ui.ResetTag

action - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

action - Variable in class org.apache.struts2.views.jsp.URLTag

ACTION - Static variable in class org.apache.struts2.views.util.ContextUtil

ACTION_EXECUTION_ERROR - Static variable in interface com.opensymphony.xwork2.XWorkMessages

ACTION_INVOCATION - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's invocation context.
ACTION_MAPPING - Static variable in class org.apache.struts2.ServletActionContext

ACTION_NAME - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the name of the action being executed.
ACTION_PARAM - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Action name parameter name
ACTION_PREFIX - Static variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

ActionAutowiringInterceptor - Class in com.opensymphony.xwork2.spring.interceptor
TODO: Give a description of the Interceptor.
ActionAutowiringInterceptor() - Constructor for class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

ActionChainResult - Class in com.opensymphony.xwork2
This result invokes an entire other action, complete with it's own interceptor stack and result.
ActionChainResult() - Constructor for class com.opensymphony.xwork2.ActionChainResult

ActionChainResult(String, String, String) - Constructor for class com.opensymphony.xwork2.ActionChainResult

ActionChainResult(String, String, String, String) - Constructor for class com.opensymphony.xwork2.ActionChainResult

actionClass - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap

ActionComponent - Class in org.apache.struts2.components

ActionComponent(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.ActionComponent

ActionConfig - Class in com.opensymphony.xwork2.config.entities
Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
ActionConfig() - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig

ActionConfig(String, Class, Map<String, Object>, Map<String, ResultConfig>, List<InterceptorMapping>) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig

ActionConfig(String, Class, Map<String, Object>, Map<String, ResultConfig>, List<InterceptorMapping>, List<ExceptionMappingConfig>) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig

ActionConfig(String, String, Map<String, Object>, Map<String, ResultConfig>, List<InterceptorMapping>) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig

ActionConfig(String, String, Map<String, Object>, Map<String, ResultConfig>, List<InterceptorMapping>, List<ExceptionMappingConfig>) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig

ActionConfig(String, String, String, Map<String, Object>, Map<String, ResultConfig>, List<InterceptorMapping>) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig

ActionConfig(String, String, String, Map<String, Object>, Map<String, ResultConfig>, List<InterceptorMapping>, List<ExceptionMappingConfig>) - Constructor for class com.opensymphony.xwork2.config.entities.ActionConfig

ActionConfigMatcher - Class in com.opensymphony.xwork2.config.impl
Matches paths against pre-compiled wildcard expressions pulled from action configs.
ActionConfigMatcher(Map<String, ActionConfig>) - Constructor for class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
ActionConfigMatcher(Map<String, ActionConfig>, boolean) - Constructor for class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
ActionConfigMatcher.Mapping - Class in com.opensymphony.xwork2.config.impl
Stores a compiled wildcard pattern and the ActionConfig it came from.
ActionConfigMatcher.Mapping(String, int[], ActionConfig) - Constructor for class com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping
Contructs a read-only Mapping instance.
actionConfigs - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

ActionContext - Class in com.opensymphony.xwork2
The ActionContext is the context in which an Action is executed.
ActionContext(Map) - Constructor for class com.opensymphony.xwork2.ActionContext
Creates a new ActionContext initialized with another context.
actionContext - Static variable in class com.opensymphony.xwork2.ActionContext

ActionContext.ActionContextThreadLocal - Class in com.opensymphony.xwork2

ActionContext.ActionContextThreadLocal() - Constructor for class com.opensymphony.xwork2.ActionContext.ActionContextThreadLocal

ActionContextCleanUp - Class in org.apache.struts2.dispatcher
Special filter designed to work with the FilterDispatcher and allow for easier integration with SiteMesh.
ActionContextCleanUp() - Constructor for class org.apache.struts2.dispatcher.ActionContextCleanUp

ActionDirective - Class in org.apache.struts2.views.velocity.components

ActionDirective() - Constructor for class org.apache.struts2.views.velocity.components.ActionDirective

ActionError - Class in org.apache.struts2.components
Render action errors if they exists the specific layout of the rendering depends on the theme itself.
ActionError(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.ActionError

actionerror - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

ActionErrorDirective - Class in org.apache.struts2.views.velocity.components

ActionErrorDirective() - Constructor for class org.apache.struts2.views.velocity.components.ActionErrorDirective

ActionErrorModel - Class in org.apache.struts2.views.freemarker.tags

ActionErrorModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ActionErrorModel

actionErrors - Variable in class com.opensymphony.xwork2.ValidationAwareSupport

actionErrorsSessionKey - Static variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

ActionErrorTag - Class in org.apache.struts2.views.jsp.ui
ActionError Tag.
ActionErrorTag() - Constructor for class org.apache.struts2.views.jsp.ui.ActionErrorTag

ActionEventListener - Interface in com.opensymphony.xwork2
Provides hooks for handling key action events
actionEventListener - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

actionEventListener - Variable in class com.opensymphony.xwork2.DefaultActionProxy

actionEventListener - Variable in class com.opensymphony.xwork2.mock.MockActionInvocation

ActionInvocation - Interface in com.opensymphony.xwork2
An ActionInvocation represents the execution state of an Action.
actionMap - Variable in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

actionMapper - Variable in class org.apache.struts2.components.Component

actionMapper - Static variable in class org.apache.struts2.dispatcher.FilterDispatcher
Provide ActionMapper instance, set by injection.
ActionMapper - Interface in org.apache.struts2.dispatcher.mapper
Provide a mapping between HTTP requests and action invocation requests and vice-versa.
actionMapper - Variable in class org.apache.struts2.dispatcher.ServletRedirectResult

actionMapper - Variable in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

actionMappers - Variable in class org.apache.struts2.dispatcher.mapper.CompositeActionMapper

ActionMapping - Class in org.apache.struts2.dispatcher.mapper
Simple class that holds the action mapping information used to invoke a Struts action.
ActionMapping() - Constructor for class org.apache.struts2.dispatcher.mapper.ActionMapping
Constructs an ActionMapping
ActionMapping(Result) - Constructor for class org.apache.struts2.dispatcher.mapper.ActionMapping
Constructs an ActionMapping with a default result
ActionMapping(String, String, String, Map) - Constructor for class org.apache.struts2.dispatcher.mapper.ActionMapping
Constructs an ActionMapping with its values
ActionMessage - Class in org.apache.struts2.components
Render action messages if they exists, specific rendering layout depends on the theme itself.
ActionMessage(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.ActionMessage

actionmessage - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

ActionMessageDirective - Class in org.apache.struts2.views.velocity.components

ActionMessageDirective() - Constructor for class org.apache.struts2.views.velocity.components.ActionMessageDirective

ActionMessageModel - Class in org.apache.struts2.views.freemarker.tags

ActionMessageModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ActionMessageModel

actionMessages - Variable in class com.opensymphony.xwork2.ValidationAwareSupport

actionMessagesSessionKey - Static variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

ActionMessageTag - Class in org.apache.struts2.views.jsp.ui
ActionMessage Tag.
ActionMessageTag() - Constructor for class org.apache.struts2.views.jsp.ui.ActionMessageTag

ActionModel - Class in org.apache.struts2.views.freemarker.tags

ActionModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ActionModel

actionName - Variable in class com.opensymphony.xwork2.ActionChainResult

actionName - Variable in class com.opensymphony.xwork2.DefaultActionProxy

actionName - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

actionName - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap

actionName - Variable in class org.apache.struts2.dispatcher.ServletActionRedirectResult

ActionProxy - Interface in com.opensymphony.xwork2
ActionProxy is an extra layer between XWork and the action so that different proxies are possible.
actionProxyFactory - Variable in class com.opensymphony.xwork2.ActionChainResult

ActionProxyFactory - Interface in com.opensymphony.xwork2
The ActionProxyFactory is used to create ActionProxies to be executed.
actionProxyFactory - Variable in class com.opensymphony.xwork2.TestNGXWorkTestCase

actionProxyFactory - Variable in class com.opensymphony.xwork2.XWorkTestCase

actionProxyFactory - Variable in class org.apache.struts2.components.ActionComponent

ActionSupport - Class in com.opensymphony.xwork2
Provides a default implementation for the most common actions.
ActionSupport() - Constructor for class com.opensymphony.xwork2.ActionSupport

ActionTag - Class in org.apache.struts2.views.jsp

ActionTag() - Constructor for class org.apache.struts2.views.jsp.ActionTag

ActionValidatorManager - Interface in com.opensymphony.xwork2.validator
ActionValidatorManager
ActionValidatorManagerFactory - Class in com.opensymphony.xwork2.validator
ActionValidatorManagerFactory
ActionValidatorManagerFactory() - Constructor for class com.opensymphony.xwork2.validator.ActionValidatorManagerFactory

ACTIVATE_PROPERTY - Static variable in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
System property that controls whether this timer should be used or not.
actualName - Variable in class org.apache.struts2.components.Text

adaptDocument(String, Object) - Method in class org.apache.struts2.views.xslt.AdapterFactory
Create a top level Document adapter for the specified Java object.
adapterFactory - Variable in class org.apache.struts2.views.xslt.AbstractAdapterNode

AdapterFactory - Class in org.apache.struts2.views.xslt
AdapterFactory produces Node adapters for Java object types.
AdapterFactory() - Constructor for class org.apache.struts2.views.xslt.AdapterFactory

adapterFactory - Variable in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

adapterFactory - Variable in class org.apache.struts2.views.xslt.XSLTResult

AdapterNode - Interface in org.apache.struts2.views.xslt

adapterTypes - Variable in class org.apache.struts2.views.xslt.AdapterFactory

adaptNode(AdapterNode, String, Object) - Method in class org.apache.struts2.views.xslt.AdapterFactory
Create an Node adapter for a child element.
adaptNullValue(BeanAdapter, String) - Method in class org.apache.struts2.views.xslt.AdapterFactory
Create an appropriate adapter for a null value.
add(int, Object) - Method in class com.opensymphony.xwork2.util.SurrugateList

add(Object) - Method in class com.opensymphony.xwork2.util.SurrugateList

add(int, Object) - Method in class com.opensymphony.xwork2.util.XWorkList
Deprecated. Inserts the specified element at the specified position in this list.
add(Object) - Method in class com.opensymphony.xwork2.util.XWorkList
Deprecated. Appends the specified element to the end of this list.
addAction(Element, PackageConfig) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

addActionConfig(String, ActionConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addActionError(String) - Method in class com.opensymphony.xwork2.ActionSupport

addActionError(String) - Method in interface com.opensymphony.xwork2.ValidationAware
Add an Action-level error message to this Action.
addActionError(String) - Method in class com.opensymphony.xwork2.ValidationAwareSupport

addActionError(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

addActionError(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

addActionError(Object) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

addActionError(String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

addActionMessage(String) - Method in class com.opensymphony.xwork2.ActionSupport

addActionMessage(String) - Method in interface com.opensymphony.xwork2.ValidationAware
Add an Action-level message to this Action.
addActionMessage(String) - Method in class com.opensymphony.xwork2.ValidationAwareSupport

addActionMessage(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

addActionMessage(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

addAll(Collection) - Method in class com.opensymphony.xwork2.util.SurrugateList

addAll(int, Collection) - Method in class com.opensymphony.xwork2.util.SurrugateList

addAll(Collection) - Method in class com.opensymphony.xwork2.util.XWorkList
Deprecated. Appends all of the elements in the specified Collection to the end of this list, in the order that they are returned by the specified Collection's Iterator.
addAll(int, Collection) - Method in class com.opensymphony.xwork2.util.XWorkList
Deprecated. Inserts all of the elements in the specified Collection into this list, starting at the specified position.
addAllFields(Class, Class, List<Field>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Adds all fields with the specified Annotation of class clazz and its superclasses to allFields
addAllInterfaces(Class, List) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils

addAllMethods(Class, Class, List<Method>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Adds all methods with the specified Annotation of class clazz and its superclasses to allFields
addAllParameters(Map) - Method in class org.apache.struts2.components.Component
Add's all the given parameters to this componenets own parameters.
addAllParents(List<PackageConfig>) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addAllToLeftLabel - Variable in class org.apache.struts2.components.OptionTransferSelect

addAllToLeftLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

addAllToRightLabel - Variable in class org.apache.struts2.components.OptionTransferSelect

addAllToRightLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

addAttribute(String, String) - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

addBuffer() - Method in class org.apache.struts2.util.FastByteArrayOutputStream
Create a new buffer and store the current one in linked list
addChild(ProfilingTimerBean) - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

addConfigurationProvider(ConfigurationProvider) - Method in class com.opensymphony.xwork2.config.ConfigurationManager
adds a configuration provider to the List of ConfigurationProviders.
addConverterMapping(Map, Class) - Method in class com.opensymphony.xwork2.util.AnnotationXWorkConverter
Looks for converter mappings for the specified class and adds it to an existing map.
addConverterMapping(Map<String, Object>, Class) - Method in class com.opensymphony.xwork2.util.XWorkConverter
Looks for converter mappings for the specified class and adds it to an existing map.
addDefaultResourceBundle(String) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Add's the bundle to the internal list of default bundles.
addDirective(StringBuffer, Class) - Method in class org.apache.struts2.views.velocity.VelocityManager

addDispatcherListener(DispatcherListener) - Static method in class org.apache.struts2.dispatcher.Dispatcher
Add a dispatcher lifecycle listener.
addDynamicMethods(Map, String, ActionConfig) - Method in class org.apache.struts2.config.MethodConfigurationProvider
Scans class for potential Action mehods, automatically generating and registering ActionConfigs as needed.
addEnumeration(Enumeration<E>) - Method in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

addError(String) - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Adds an error message.
addExceptionMapping(ExceptionMappingConfig) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

addExceptionMappingConfig(ExceptionMappingConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addExceptionMappings(List<? extends ExceptionMappingConfig>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

addFieldError(String, String) - Method in class com.opensymphony.xwork2.ActionSupport

addFieldError(String, String) - Method in interface com.opensymphony.xwork2.ValidationAware
Add an error message for a given field.
addFieldError(String, String) - Method in class com.opensymphony.xwork2.ValidationAwareSupport

addFieldError(String, String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

addFieldError(String, String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

addFieldError(String, Object) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

addFieldError(String, String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

addFinder(LocationUtils.LocationFinder) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Add a LocationUtils.LocationFinder to the list of finders that will be queried for an object's location by LocationUtils.getLocation(Object, String).
addFormParameter(String, Object) - Method in class org.apache.struts2.components.UIBean

addGlobalExceptionMappingConfigs(List) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addGlobalResultConfig(ResultConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addGlobalResultConfigs(Map) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addHeader(String, String) - Method in class org.apache.struts2.dispatcher.HttpHeaderResult
Adds an HTTP header to the response
addIfMatching(ResolverUtil.Test, String) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Add the class designated by the fully qualified class name provided to the set of resolved classes if and only if it is approved by the Test supplied.
addInjectors(Class, List<ContainerImpl.Injector>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl
Recursively adds injectors for fields and methods from the given class to the given list.
addInjectorsForFields(Field[], boolean, List<ContainerImpl.Injector>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

addInjectorsForMembers(List<M>, boolean, List<ContainerImpl.Injector>, ContainerImpl.InjectorFactory<M>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

addInjectorsForMethods(Method[], boolean, List<ContainerImpl.Injector>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

addInterceptor(InterceptorMapping) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

addInterceptor(InterceptorMapping) - Method in interface com.opensymphony.xwork2.config.entities.InterceptorListHolder

addInterceptor(InterceptorMapping) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

addInterceptorConfig(InterceptorConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addInterceptors(List<InterceptorMapping>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

addInterceptors(List<InterceptorMapping>) - Method in interface com.opensymphony.xwork2.config.entities.InterceptorListHolder

addInterceptors(List<InterceptorMapping>) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

addInterceptorStackConfig(InterceptorStackConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addLabel - Variable in class org.apache.struts2.components.InputTransferSelect

addLabel - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

addLocationAttributes(Locator, Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Add location attributes to a set of SAX attributes.
addMapping(int, String, String[]) - Static method in class org.apache.struts2.views.util.TextUtil

addMouseListener(JTable) - Method in class org.apache.struts2.components.table.SortFilterModel

addPackage(Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Create a PackageConfig from an XML element representing it.
addPackageConfig(String, PackageConfig) - Method in interface com.opensymphony.xwork2.config.Configuration

addPackageConfig(String, PackageConfig) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

addPackageConfig(String, PackageConfig) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

addParam(String, Object) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

addParam(String, Object) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

addParam(String, Object) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

addParam(String, Object) - Method in interface com.opensymphony.xwork2.config.entities.Parameterizable

addParam(String, Object) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

addParam(String, String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

addParameter(Object) - Method in class org.apache.struts2.components.AppendIterator

addParameter(String, Object) - Method in class org.apache.struts2.components.Bean

addParameter(String, Object) - Method in class org.apache.struts2.components.Component
Add's the given key and value to this components own parameter.
addParameter(Object) - Method in class org.apache.struts2.components.FieldError

addParameter(String, Object) - Method in class org.apache.struts2.components.Include

addParameter(Object) - Method in class org.apache.struts2.components.MergeIterator

addParameter(Object) - Method in interface org.apache.struts2.components.Param.UnnamedParametric
Adds the given value as a parameter to the outer tag.
addParameter(String, Object) - Method in class org.apache.struts2.components.Text

addParameter(Object) - Method in class org.apache.struts2.components.Text

addParameter(String, Object) - Method in class org.apache.struts2.dispatcher.ServletActionRedirectResult
Adds a request parameter to be added to the redirect url
addParameter(String, Object) - Method in class org.apache.struts2.util.URLBean

addParameter(String, Object) - Method in class org.apache.struts2.views.jsp.ActionTag

addParent(PackageConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addParent(ProfilingTimerBean) - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

addPreResultListener(PreResultListener) - Method in interface com.opensymphony.xwork2.ActionInvocation
Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
addPreResultListener(PreResultListener) - Method in class com.opensymphony.xwork2.DefaultActionInvocation
Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
addPreResultListener(PreResultListener) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

addResultConfig(ResultConfig) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

addResultTypeConfig(ResultTypeConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

addResultTypes(PackageConfig, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

addRow(Vector) - Method in class org.apache.struts2.components.table.AbstractFilterModel

addToHistory(String, String, String) - Method in class com.opensymphony.xwork2.ActionChainResult

addToLeftLabel - Variable in class org.apache.struts2.components.OptionTransferSelect

addToLeftLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

addToRightLabel - Variable in class org.apache.struts2.components.OptionTransferSelect

addToRightLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

addValidatorConfigs(NodeList, Map, List) - Static method in class com.opensymphony.xwork2.validator.ValidatorFileParser

adjustWeeks - Variable in class org.apache.struts2.components.DateTimePicker

adjustWeeks - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

adoptNode(Node) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

After - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Marks a action method that needs to be called after the main action method and the result was executed.
after(ActionInvocation, String) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor
Handle the storing of field errors / action messages / field errors, which is done after action invocation, and the operationMode is in 'STORE'.
after(ActionInvocation, String) - Method in class org.apache.struts2.interceptor.ScopeInterceptor

afterBody - Variable in class org.apache.struts2.views.freemarker.tags.CallbackWriter

afterBody() - Method in class org.apache.struts2.views.freemarker.tags.CallbackWriter

afterInvocation() - Method in class org.apache.struts2.interceptor.BackgroundProcess
Called after the background thread determines the result code from the ActionInvocation, but before the background thread is marked as done.
afterLoading - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

afterLoading - Variable in class org.apache.struts2.components.Submit

afterLoading - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

afterLoading - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

alias(Class<T>, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to alias(type, Container.DEFAULT_NAME, type).
alias(Class<T>, String, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an existing factory to a new name.
alias(Key<T>, Key<T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an existing dependency.
alias(Class, String, ContainerBuilder, Properties) - Method in class org.apache.struts2.config.BeanSelectionProvider

alias(Class, String, ContainerBuilder, Properties, Scope) - Method in class org.apache.struts2.config.BeanSelectionProvider

aliasesKey - Variable in class com.opensymphony.xwork2.interceptor.AliasInterceptor

AliasInterceptor - Class in com.opensymphony.xwork2.interceptor
The aim of this Interceptor is to alias a named parameter to a different named parameter.
AliasInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.AliasInterceptor

align - Variable in class org.apache.struts2.components.FormButton

align - Variable in class org.apache.struts2.components.Reset

align - Variable in class org.apache.struts2.views.jsp.ui.ResetTag

align - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

ALL - Static variable in class org.apache.struts2.components.URL

allowAddAllToLeft - Variable in class org.apache.struts2.components.OptionTransferSelect

allowAddAllToLeft - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

allowAddAllToRight - Variable in class org.apache.struts2.components.OptionTransferSelect

allowAddAllToRight - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

allowAddToLeft - Variable in class org.apache.struts2.components.OptionTransferSelect

allowAddToLeft - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

allowAddToRight - Variable in class org.apache.struts2.components.OptionTransferSelect

allowAddToRight - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

allowDynamicMethodCalls - Variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

allowed - Variable in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

allowedRoles - Variable in class org.apache.struts2.interceptor.RolesInterceptor

allowedTypes - Variable in class org.apache.struts2.interceptor.FileUploadInterceptor

allowedTypesSet - Variable in class org.apache.struts2.interceptor.FileUploadInterceptor

allowMoveDown - Variable in class org.apache.struts2.components.UpDownSelect

allowMoveDown - Variable in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

allowMoveUp - Variable in class org.apache.struts2.components.UpDownSelect

allowMoveUp - Variable in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

allowRemoveAll - Variable in class org.apache.struts2.components.InputTransferSelect

allowRemoveAll - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

allowRequestParameterSwitch - Variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

allowSelectAll - Variable in class org.apache.struts2.components.OptionTransferSelect

allowSelectAll - Variable in class org.apache.struts2.components.UpDownSelect

allowSelectAll - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

allowSelectAll - Variable in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

allowSlashesInActionNames - Variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

allowUpDown - Variable in class org.apache.struts2.components.InputTransferSelect

allowUpDown - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

allowUpDownOnLeft - Variable in class org.apache.struts2.components.OptionTransferSelect

allowUpDownOnLeft - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

allowUpDownOnRight - Variable in class org.apache.struts2.components.OptionTransferSelect

allowUpDownOnRight - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

ALT_PREPARE_PREFIX - Static variable in class com.opensymphony.xwork2.interceptor.PrepareInterceptor

ALT_VALIDATE_PREFIX - Static variable in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

altMapWrapper - Variable in class org.apache.struts2.views.freemarker.FreemarkerManager

altMapWrapper - Variable in class org.apache.struts2.views.freemarker.StrutsBeanWrapper

altSyntax() - Method in class org.apache.struts2.components.Component
Is the altSyntax enabled? [TRUE]
See struts.properties where the altSyntax flag is defined.
altSyntax() - Method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

altSyntax - Static variable in class org.apache.struts2.views.util.ContextUtil

alwaysInvokePrepare - Variable in class com.opensymphony.xwork2.interceptor.PrepareInterceptor

alwaysInvokeValidate - Variable in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

alwaysSelectFullNamespace - Variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

AMP - Static variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

AMP - Static variable in class org.apache.struts2.views.util.UrlHelper

Anchor - Class in org.apache.struts2.components
A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework.
THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED href errorText listenTopics notifyTopics executeScripts loadingText listenTopics handler formId formFilter targets showErrorTransportText targets indicator 'resultDivId' Deprecated.
Anchor(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Anchor

anchor - Variable in class org.apache.struts2.components.URL

anchor - Variable in class org.apache.struts2.views.jsp.URLTag

AnchorDirective - Class in org.apache.struts2.views.velocity.components

AnchorDirective() - Constructor for class org.apache.struts2.views.velocity.components.AnchorDirective

AnchorModel - Class in org.apache.struts2.views.freemarker.tags

AnchorModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.AnchorModel

AnchorTag - Class in org.apache.struts2.views.jsp.ui

AnchorTag() - Constructor for class org.apache.struts2.views.jsp.ui.AnchorTag

annotation - Variable in class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith

AnnotationActionValidatorManager - Class in com.opensymphony.xwork2.validator
AnnotationActionValidatorManager
This is the entry point into XWork's annotations-based validator framework.
AnnotationActionValidatorManager() - Constructor for class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

AnnotationUtils - Class in com.opensymphony.xwork2.util
AnnotationUtils Various utility methods dealing with annotations
AnnotationUtils() - Constructor for class com.opensymphony.xwork2.util.AnnotationUtils

AnnotationValidationConfigurationBuilder - Class in com.opensymphony.xwork2.validator
AnnotationValidationConfigurationBuilder
AnnotationValidationConfigurationBuilder() - Constructor for class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

AnnotationValidationInterceptor - Class in org.apache.struts2.interceptor.validation
Extends the xwork validation interceptor to also check for a @SkipValidation annotation, and if found, don't validate this action method
AnnotationValidationInterceptor() - Constructor for class org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor

AnnotationWorkflowInterceptor - Class in com.opensymphony.xwork2.interceptor.annotations

AnnotationWorkflowInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor

AnnotationXWorkConverter - Class in com.opensymphony.xwork2.util

Type conversion is great for situations where you need to turn a String in to a more complex object.
AnnotationXWorkConverter() - Constructor for class com.opensymphony.xwork2.util.AnnotationXWorkConverter

answer - Variable in class org.apache.struts2.components.ElseIf

ANSWER - Static variable in class org.apache.struts2.components.If

answer - Variable in class org.apache.struts2.components.If

APOS - Static variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

appContext - Variable in class com.opensymphony.xwork2.spring.SpringObjectFactory

appendChild(Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

appendData(String) - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

appendData(String) - Method in class org.apache.struts2.views.xslt.SimpleTextNode

AppendIterator - Class in org.apache.struts2.components

AppendIterator(ValueStack) - Constructor for class org.apache.struts2.components.AppendIterator

appendIteratorFilter - Variable in class org.apache.struts2.components.AppendIterator

AppendIteratorFilter - Class in org.apache.struts2.util
A bean that takes several iterators and outputs them in sequence
AppendIteratorFilter() - Constructor for class org.apache.struts2.util.AppendIteratorFilter

AppendIteratorTag - Class in org.apache.struts2.views.jsp.iterator
Append a list of iterators.
AppendIteratorTag() - Constructor for class org.apache.struts2.views.jsp.iterator.AppendIteratorTag

appendPrefix - Variable in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

appendPrefix - Variable in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

APPLICATION - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's application context.
application - Variable in class org.apache.struts2.interceptor.ScopeInterceptor

APPLICATION_CONTEXT - Static variable in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

ApplicationAware - Interface in org.apache.struts2.interceptor
Actions that want to be aware of the application Map object should implement this interface.
ApplicationMap - Class in org.apache.struts2.dispatcher
A simple implementation of the Map interface to handle a collection of attributes and init parameters in a ServletContext object.
ApplicationMap(ServletContext) - Constructor for class org.apache.struts2.dispatcher.ApplicationMap
Creates a new map object given the servlet context.
apply(F) - Method in interface com.opensymphony.xwork2.inject.util.Function
Applies the function to an object of type F, resulting in an object of type T.
applyDefaultConfiguration(ServletContext, Properties) - Method in class org.apache.struts2.views.velocity.VelocityManager
once we've loaded up the user defined configurations, we will want to apply Struts specification configurations.
applyInterceptor(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

applyMethod(Set, Set, String) - Static method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
Static method to decide if the specified method should be apply (not filtered) depending on the set of excludeMethods and includeMethods.
applyMethod(String, String, String) - Static method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil
Same as MethodFilterInterceptorUtil.applyMethod(Set, Set, String), except that excludeMethods and includeMethods are supplied as comma separated string.
args - Variable in class com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

ArrayAdapter - Class in org.apache.struts2.views.xslt

ArrayAdapter() - Constructor for class org.apache.struts2.views.xslt.ArrayAdapter

ArrayAdapter(AdapterFactory, AdapterNode, String, Object) - Constructor for class org.apache.struts2.views.xslt.ArrayAdapter

ASC - Static variable in interface org.apache.struts2.components.table.SortableTableModel

asCollection(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor
Return a collection from the comma delimited String.
asCollection(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Return a collection from the comma delimited String.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
Returns the validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
Returns the field validator XML definition.
asFieldXml() - Method in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
Returns the validator XML definition.
asProperty() - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Returns the conversion description as property entry.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
Returns the validator XML definition.
asSimpleXml() - Method in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
Returns the validator XML definition.
asXml() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Returns the validator XML definition.
asXml() - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

asXml() - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Returns the validator XML definition.
attr() - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

ATTR_APPLICATION_MODEL - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

ATTR_JSP_TAGLIBS_MODEL - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

ATTR_REQUEST_MODEL - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

ATTR_REQUEST_PARAMETERS_MODEL - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

attributeAdapters - Variable in class org.apache.struts2.views.xslt.AbstractAdapterElement

AttributeMap - Class in org.apache.struts2.util
A Map that holds 4 levels of scope.
AttributeMap(Map) - Constructor for class org.apache.struts2.util.AttributeMap

attributeName - Variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor

autoComplete - Variable in class org.apache.struts2.components.Autocompleter

autoComplete - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

Autocompleter - Class in org.apache.struts2.components
The autocomplete tag is a combobox that can autocomplete text entered on the input box.
Autocompleter(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Autocompleter

AutocompleterDirective - Class in org.apache.struts2.views.velocity.components

AutocompleterDirective() - Constructor for class org.apache.struts2.views.velocity.components.AutocompleterDirective

AutocompleterModel - Class in org.apache.struts2.views.freemarker.tags

AutocompleterModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.AutocompleterModel

autocompleterModel - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

AutocompleterTag - Class in org.apache.struts2.views.jsp.ui

AutocompleterTag() - Constructor for class org.apache.struts2.views.jsp.ui.AutocompleterTag

autoCreateSession - Variable in class org.apache.struts2.interceptor.ScopeInterceptor

autoStart - Variable in class org.apache.struts2.components.Div

autoStart - Variable in class org.apache.struts2.views.jsp.ui.DivTag

autoWireBean(Object) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory

autoWireBean(Object, AutowireCapableBeanFactory) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory

autowireStrategy - Variable in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

autowireStrategy - Variable in class com.opensymphony.xwork2.spring.SpringObjectFactory

autoWiringFactory - Variable in class com.opensymphony.xwork2.spring.SpringObjectFactory

B

BackgroundProcess - Class in org.apache.struts2.interceptor
Background thread to be executed by the ExecuteAndWaitInterceptor.
BackgroundProcess(String, ActionInvocation, int) - Constructor for class org.apache.struts2.interceptor.BackgroundProcess
Constructs a background process
BASE - Static variable in class org.apache.struts2.views.util.ContextUtil

baseDir - Variable in class org.apache.struts2.config.StrutsXmlConfigurationProvider

BaseTemplateEngine - Class in org.apache.struts2.components.template
Base class for template engines.
BaseTemplateEngine() - Constructor for class org.apache.struts2.components.template.BaseTemplateEngine

Bean - Class in org.apache.struts2.components

Bean(ValueStack) - Constructor for class org.apache.struts2.components.Bean

bean - Variable in class org.apache.struts2.components.Bean

bean(Object) - Method in class org.apache.struts2.util.StrutsUtil

bean - Variable in class org.apache.struts2.views.freemarker.tags.CallbackWriter

bean - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

BeanAdapter - Class in org.apache.struts2.views.xslt
This class is the most general type of adapter, utilizing reflective introspection to present a DOM view of all of the public properties of its value.
BeanAdapter() - Constructor for class org.apache.struts2.views.xslt.BeanAdapter

BeanAdapter(AdapterFactory, AdapterNode, String, Object) - Constructor for class org.apache.struts2.views.xslt.BeanAdapter

BeanDirective - Class in org.apache.struts2.views.velocity.components

BeanDirective() - Constructor for class org.apache.struts2.views.velocity.components.BeanDirective

beanInfoCache - Static variable in class com.opensymphony.xwork2.util.OgnlUtil

BeanModel - Class in org.apache.struts2.views.freemarker.tags

BeanModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.BeanModel

BeanSelectionProvider - Class in org.apache.struts2.config
Selects the implementations of key framework extension points, using the loaded property constants.
BeanSelectionProvider() - Constructor for class org.apache.struts2.config.BeanSelectionProvider

BeanSelectionProvider.ObjectFactoryDelegateFactory - Class in org.apache.struts2.config

BeanSelectionProvider.ObjectFactoryDelegateFactory(String, Class) - Constructor for class org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory

BeanTag - Class in org.apache.struts2.views.jsp

BeanTag() - Constructor for class org.apache.struts2.views.jsp.BeanTag

Before - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Marks a action method that needs to be executed before the main action method.
before(ActionInvocation) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor
Handle the retrieving of field errors / action messages / field errors, which is done before action invocation, and the operationMode is 'RETRIEVE'.
before(ActionInvocation) - Method in class org.apache.struts2.interceptor.ScopeInterceptor

beforeInvocation() - Method in class org.apache.struts2.interceptor.BackgroundProcess
Called before the background thread determines the result code from the ActionInvocation.
beforeLoading - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

beforeLoading - Variable in class org.apache.struts2.components.Submit

beforeLoading - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

beforeLoading - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

beforeResult(ActionInvocation, String) - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
Invokes any @BeforeResult annotated methods
BeforeResult - Annotation Type in com.opensymphony.xwork2.interceptor.annotations
Marks a action method that needs to be executed before the result.
beforeResult(ActionInvocation, String) - Method in interface com.opensymphony.xwork2.interceptor.PreResultListener
This callback method will be called after the Action execution and before the Result execution.
beforeResult(ActionInvocation, String) - Method in class org.apache.struts2.interceptor.ScopeInterceptor

blankIconSrc - Variable in class org.apache.struts2.components.Tree

blankIconSrc - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

blocked - Variable in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

blockSize - Variable in class org.apache.struts2.util.FastByteArrayOutputStream

body - Variable in class org.apache.struts2.views.freemarker.tags.CallbackWriter

bodyContent - Static variable in class org.apache.struts2.components.template.FreemarkerTemplateEngine

BooleanCellRenderer - Class in org.apache.struts2.components.table.renderer

BooleanCellRenderer() - Constructor for class org.apache.struts2.components.table.renderer.BooleanCellRenderer

buffer - Variable in class org.apache.struts2.components.Include.PageOutputStream

buffer - Variable in class org.apache.struts2.util.FastByteArrayOutputStream

BUFFER_SIZE - Static variable in class org.apache.struts2.dispatcher.PlainTextResult

buffers - Variable in class org.apache.struts2.util.FastByteArrayOutputStream

bufferSize - Variable in class org.apache.struts2.dispatcher.StreamResult

build(ContainerBuilder) - Method in interface com.opensymphony.xwork2.inject.ContainerBuilder.Command
Contributes factories to the given builder.
buildAction(String, String, ActionConfig, Map) - Method in class com.opensymphony.xwork2.ObjectFactory
Build an instance of the action class to handle a particular request (eg.
buildAliasValidatorConfigs(Class, String, boolean) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

buildAliasValidatorConfigs(Class, String, boolean) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager

buildAnnotationClassValidatorConfigs(Class) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

buildAttributeAdapters() - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

buildBean(Class, Map) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a generic Java object of the given type.
buildBean(String, Map) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a generic Java object of the given type.
buildBean(String, Map, boolean) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a generic Java object of the given type.
buildBean(String, Map, boolean) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Looks up beans using Spring's application context before falling back to the method defined in the ObjectFactory.
buildBean(Class, Map) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory

buildBean(String, Map) - Method in class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory

buildChildAdapters() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode
subclasses override to produce their children
buildChildAdapters() - Method in class org.apache.struts2.views.xslt.ArrayAdapter

buildChildAdapters() - Method in class org.apache.struts2.views.xslt.BeanAdapter

buildChildAdapters() - Method in class org.apache.struts2.views.xslt.CollectionAdapter

buildChildAdapters() - Method in class org.apache.struts2.views.xslt.MapAdapter

buildChildAdapters() - Method in class org.apache.struts2.views.xslt.MapAdapter.EntryElement

buildChildAdapters() - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

buildChildAdapters() - Method in class org.apache.struts2.views.xslt.StringAdapter

buildClassValidatorConfigs(Class, boolean) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

buildClassValidatorConfigs(Class, boolean) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager

buildConverterFilename(Class) - Static method in class com.opensymphony.xwork2.util.XWorkConverter

buildConverterMapping(Class) - Method in class com.opensymphony.xwork2.util.XWorkConverter
Looks for converter mappings for the specified class, traversing up its class hierarchy and interfaces and adding any additional mappings it may find.
buildExceptionMappings(Element, PackageConfig) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Build a map of ResultConfig objects from below a given XML element.
buildFullActionConfig(PackageConfig, ActionConfig) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
Builds the full runtime actionconfig with all of the defaults and inheritance
buildInterceptor(InterceptorConfig, Map) - Method in class com.opensymphony.xwork2.ObjectFactory
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.
buildInterceptor(InterceptorConfig, Map) - Method in class org.apache.struts2.impl.StrutsObjectFactory

buildInterceptorList(Element, PackageConfig) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

buildMessageFormat(String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil

buildNamespace(ActionMapper, ValueStack, HttpServletRequest) - Static method in class org.apache.struts2.views.jsp.TagUtils

buildPackageContext(Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
This method builds a package context by looking for the parents of this new package.
buildParametersString(Map, StringBuffer) - Static method in class org.apache.struts2.views.util.UrlHelper

buildParametersString(Map, StringBuffer, String) - Static method in class org.apache.struts2.views.util.UrlHelper

buildParentsFromString(Configuration, String) - Static method in class com.opensymphony.xwork2.config.ConfigurationUtil

buildResourceUrl(String, Map) - Static method in class org.apache.struts2.portlet.util.PortletUrlHelper
Encode an url to a non Struts action resource, like stylesheet, image or servlet.
buildResult(ResultConfig, Map) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.
buildResult(ResultConfig, Map) - Method in class org.apache.struts2.impl.StrutsObjectFactory

buildResults(Element, PackageConfig) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Build a map of ResultConfig objects from below a given XML element.
buildRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
This methodName builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures.
buildRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

buildScopesHashModel(ServletContext, HttpServletRequest, HttpServletResponse, ObjectWrapper, ValueStack) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager

buildTemplateModel(ValueStack, Object, ServletContext, HttpServletRequest, HttpServletResponse, ObjectWrapper) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager

buildTemplateName(String, String) - Method in class org.apache.struts2.components.UIBean

buildToken(String) - Method in class org.apache.struts2.components.Token

buildUrl(String, String, Map, String, String, String) - Static method in class org.apache.struts2.portlet.util.PortletUrlHelper
Create a portlet URL with for the specified action and namespace.
buildUrl(String, String, Map, String, String, String, String, boolean, boolean) - Static method in class org.apache.struts2.portlet.util.PortletUrlHelper
Create a portlet URL with for the specified action and namespace.
buildUrl(String) - Method in class org.apache.struts2.util.StrutsUtil

buildUrl(String, HttpServletRequest, HttpServletResponse, Map) - Static method in class org.apache.struts2.views.util.UrlHelper

buildUrl(String, HttpServletRequest, HttpServletResponse, Map, String, boolean, boolean) - Static method in class org.apache.struts2.views.util.UrlHelper

buildUrl(String, HttpServletRequest, HttpServletResponse, Map, String, boolean, boolean, boolean) - Static method in class org.apache.struts2.views.util.UrlHelper

buildValidator(String, Map, Map) - Method in class com.opensymphony.xwork2.ObjectFactory
Build a Validator of the given type and set the parameters on it
buildValidatorConfigs(Class, String, boolean, Set) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
This method 'collects' all the validator configurations for a given action invocation.
buildValidatorConfigs(Class, String, boolean, Set) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
This method 'collects' all the validator configurations for a given action invocation.
buildValidatorKey(Class, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
Builds a key for validators - used when caching validators.
buildValidatorKey(Class, String) - Static method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
Builds a key for validators - used when caching validators.
bundle - Variable in class com.opensymphony.xwork2.TextProviderSupport

buttonCssClass - Variable in class org.apache.struts2.components.InputTransferSelect

buttonCssClass - Variable in class org.apache.struts2.components.OptionTransferSelect

buttonCssClass - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

buttonCssClass - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

buttonCssStyle - Variable in class org.apache.struts2.components.InputTransferSelect

buttonCssStyle - Variable in class org.apache.struts2.components.OptionTransferSelect

buttonCssStyle - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

buttonCssStyle - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

BUTTONTYPE_BUTTON - Static variable in class org.apache.struts2.components.FormButton

BUTTONTYPE_IMAGE - Static variable in class org.apache.struts2.components.FormButton

BUTTONTYPE_INPUT - Static variable in class org.apache.struts2.components.FormButton

C

calendarcss - Variable in class org.apache.struts2.components.Head

calendarcss - Variable in class org.apache.struts2.views.jsp.ui.HeadTag

call(InternalContext) - Method in interface com.opensymphony.xwork2.inject.ContainerImpl.ContextualCallable

call() - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate

CallbackWriter - Class in org.apache.struts2.views.freemarker.tags

CallbackWriter(Component, Writer) - Constructor for class org.apache.struts2.views.freemarker.tags.CallbackWriter

callInContext(ContainerImpl.ContextualCallable<T>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl
Looks up thread local context.
callMethod(Map, Object, String, Object[]) - Method in class com.opensymphony.xwork2.util.CompoundRootAccessor

callMethod(Map, Object, String, Object[]) - Method in class com.opensymphony.xwork2.util.XWorkMethodAccessor

callStaticMethod(Map, Class, String, Object[]) - Method in class com.opensymphony.xwork2.util.CompoundRootAccessor

callStaticMethod(Map, Class, String, Object[]) - Method in class com.opensymphony.xwork2.util.XWorkMethodAccessor

cancel() - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache
Cancels the current ReferenceCache.create(Object).
capitalize(String) - Static method in class com.opensymphony.xwork2.inject.util.Strings
Returns a string that is equivalent to the specified string with its first character converted to uppercase as by String.toUpperCase(java.util.Locale).
capitalizeMethodName(String) - Static method in class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
This method capitalized the first character of methodName.
caseSensitive - Variable in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator

categoryLogger - Variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

categoryLogger - Variable in class com.opensymphony.xwork2.interceptor.TimerInterceptor

ccl - Variable in class com.opensymphony.xwork2.ObjectFactory

CellRenderer - Interface in org.apache.struts2.components.table.renderer

CHAIN_HISTORY - Static variable in class com.opensymphony.xwork2.ActionChainResult
The action context key to save the chain history.
chainedContextNames - Variable in class org.apache.struts2.views.velocity.VelocityManager
Names of contexts that will be chained on every request
chainedContexts - Variable in class org.apache.struts2.views.velocity.StrutsVelocityContext

ChainingInterceptor - Class in com.opensymphony.xwork2.interceptor
An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable.
ChainingInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ChainingInterceptor

characters(char[], int, int) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

characters(char[], int, int) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

characters(char[], int, int) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

charSet - Variable in class org.apache.struts2.dispatcher.PlainTextResult

Checkbox - Class in org.apache.struts2.components
Renders an HTML input element of type checkbox, populated by the specified property from the ValueStack.
Checkbox(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Checkbox

checkbox - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

CheckBoxDirective - Class in org.apache.struts2.views.velocity.components

CheckBoxDirective() - Constructor for class org.apache.struts2.views.velocity.components.CheckBoxDirective

CheckboxInterceptor - Class in org.apache.struts2.interceptor
Looks for a hidden identification field that specifies the original value of the checkbox.
CheckboxInterceptor() - Constructor for class org.apache.struts2.interceptor.CheckboxInterceptor

CheckboxList - Class in org.apache.struts2.components
Creates a series of checkboxes from a list.
CheckboxList(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.CheckboxList

checkboxlist - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

CheckBoxListDirective - Class in org.apache.struts2.views.velocity.components

CheckBoxListDirective() - Constructor for class org.apache.struts2.views.velocity.components.CheckBoxListDirective

CheckboxListModel - Class in org.apache.struts2.views.freemarker.tags

CheckboxListModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.CheckboxListModel

CheckboxListTag - Class in org.apache.struts2.views.jsp.ui

CheckboxListTag() - Constructor for class org.apache.struts2.views.jsp.ui.CheckboxListTag

CheckboxModel - Class in org.apache.struts2.views.freemarker.tags

CheckboxModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.CheckboxModel

CheckboxTag - Class in org.apache.struts2.views.jsp.ui

CheckboxTag() - Constructor for class org.apache.struts2.views.jsp.ui.CheckboxTag

checkCombineLines(String) - Method in class com.opensymphony.xwork2.util.PropertiesReader
Checks if the passed in line should be combined with the following.
checkKey(Key<?>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Ensures a key isn't already mapped.
childAdapters - Variable in class org.apache.struts2.views.xslt.AbstractAdapterNode

childCollectionProperty - Variable in class org.apache.struts2.components.Tree

childCollectionProperty - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

children - Variable in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

classes - Variable in class com.opensymphony.xwork2.spring.SpringObjectFactory

classes - Variable in class org.apache.struts2.util.StrutsUtil

classForName(String, Map) - Method in class com.opensymphony.xwork2.util.CompoundRootAccessor

classloader - Variable in class com.opensymphony.xwork2.util.ResolverUtil
The ClassLoader to use when looking for classes.
ClassLoaderUtil - Class in com.opensymphony.xwork2.util
This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers.
ClassLoaderUtil() - Constructor for class com.opensymphony.xwork2.util.ClassLoaderUtil

ClassLoaderUtil.AggregateIterator<E> - Class in com.opensymphony.xwork2.util
Aggregates Enumeration instances into one iterator and filters out duplicates.
ClassLoaderUtil.AggregateIterator() - Constructor for class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

ClassLoaderUtils - Class in org.apache.struts2.util
This class is extremely useful for loading resources and classes in a fault tolerant manner that works across different applications servers.
ClassLoaderUtils() - Constructor for class org.apache.struts2.util.ClassLoaderUtils

className - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig

className - Variable in class com.opensymphony.xwork2.config.entities.InterceptorConfig

className - Variable in class com.opensymphony.xwork2.config.entities.ResultConfig

className - Variable in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

ClasspathConfigurationProvider - Class in org.apache.struts2.config
ClasspathConfigurationProvider loads the configuration by scanning the classpath or selected packages for Action classes.
ClasspathConfigurationProvider(String[]) - Constructor for class org.apache.struts2.config.ClasspathConfigurationProvider
Create instance utilizing a list of packages to scan for Action classes.
ClasspathConfigurationProvider.ClasspathPageLocator - Class in org.apache.struts2.config
ClasspathPathLocator searches the classpath for server pages.
ClasspathConfigurationProvider.ClasspathPageLocator() - Constructor for class org.apache.struts2.config.ClasspathConfigurationProvider.ClasspathPageLocator

ClasspathConfigurationProvider.PageLocator - Interface in org.apache.struts2.config
PageLocator defines a locate method that can be used to discover server pages.
ClasspathConfigurationProvider.ResultMap<K,V> - Class in org.apache.struts2.config
Creates ResultConfig objects from result annotations, and if a result isn't found, creates it on the fly.
ClasspathConfigurationProvider.ResultMap(Class, String, PackageConfig) - Constructor for class org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap

classpathPageLocator - Variable in class org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator

clazz - Variable in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

clazz - Variable in class com.opensymphony.xwork2.TextProviderSupport

clazz - Variable in class com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

clazz - Variable in class com.opensymphony.xwork2.util.XWorkList
Deprecated.
clazz - Variable in class com.opensymphony.xwork2.util.XWorkMap
Deprecated.
cleanUp(Reference) - Method in class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

cleanUp(ServletRequest) - Static method in class org.apache.struts2.dispatcher.ActionContextCleanUp
Clean up the request of threadlocals if this is the last execution
cleanup() - Method in class org.apache.struts2.dispatcher.Dispatcher
Releases all instances bound to this dispatcher instance.
cleanupContext - Variable in class com.opensymphony.xwork2.DefaultActionProxy

clear() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

clear(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

clear() - Method in class org.apache.struts2.dispatcher.ApplicationMap
Removes all entries from the Map and removes all attributes from the servlet context.
clear() - Method in class org.apache.struts2.dispatcher.RequestMap
Removes all attributes from the request as well as clears entries in this map.
clear() - Method in class org.apache.struts2.dispatcher.SessionMap
Removes all attributes from the session as well as clears entries in this map.
clear() - Method in class org.apache.struts2.portlet.PortletApplicationMap
Removes all entries from the Map and removes all attributes from the portlet context.
clear() - Method in class org.apache.struts2.portlet.PortletRequestMap
Removes all attributes from the request as well as clears entries in this map.
clear() - Method in class org.apache.struts2.portlet.PortletSessionMap

clear() - Method in class org.apache.struts2.util.AttributeMap

clearConfigurationProviders() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
clears the registered ConfigurationProviders.
clearCurrentPropertyPath(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

clearDefaultResourceBundles() - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Clears the internal list of resource bundles.
clearErrorsAndMessages() - Method in class com.opensymphony.xwork2.ActionSupport
Clears all errors and messages.
clearErrorsAndMessages() - Method in class com.opensymphony.xwork2.ValidationAwareSupport
Clears all error and messages list/maps.
clearMap(Class, Object, String) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil

clearTomcatCache() - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil

clone() - Method in class com.opensymphony.xwork2.ActionSupport

clone() - Method in class org.apache.struts2.components.template.Template

cloneNode(boolean) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

close() - Method in class org.apache.struts2.components.Include.PageOutputStream

CLOSE - Static variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

close() - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

close() - Method in class org.apache.struts2.util.FastByteArrayOutputStream

close() - Method in class org.apache.struts2.views.freemarker.tags.CallbackWriter

closeButton - Variable in class org.apache.struts2.components.TabbedPanel

closeButton - Variable in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

closed - Variable in class org.apache.struts2.util.FastByteArrayOutputStream

ClosingUIBean - Class in org.apache.struts2.components
ClosingUIBean is the standard superclass for UI components such as div etc.
ClosingUIBean(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.ClosingUIBean

COL_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute name for the column number
CollectionAdapter - Class in org.apache.struts2.views.xslt

CollectionAdapter() - Constructor for class org.apache.struts2.views.xslt.CollectionAdapter

CollectionAdapter(AdapterFactory, AdapterNode, String, Object) - Constructor for class org.apache.struts2.views.xslt.CollectionAdapter

cols - Variable in class org.apache.struts2.components.TextArea

cols - Variable in class org.apache.struts2.views.jsp.ui.TextareaTag

column - Variable in class com.opensymphony.xwork2.util.location.LocationImpl

columns - Variable in class org.apache.struts2.components.table.WebTable

com.opensymphony.xwork2 - package com.opensymphony.xwork2
Main Xwork interfaces and classes.
com.opensymphony.xwork2.config - package com.opensymphony.xwork2.config
Configuration core classes.
com.opensymphony.xwork2.config.entities - package com.opensymphony.xwork2.config.entities
Configuration entity classes.
com.opensymphony.xwork2.config.impl - package com.opensymphony.xwork2.config.impl
Configuration implementation classes.
com.opensymphony.xwork2.config.providers - package com.opensymphony.xwork2.config.providers
Configuration provider classes.
com.opensymphony.xwork2.conversion.annotations - package com.opensymphony.xwork2.conversion.annotations
Type conversion annotations.
com.opensymphony.xwork2.conversion.metadata - package com.opensymphony.xwork2.conversion.metadata
Type conversion meta data classes.
com.opensymphony.xwork2.inject - package com.opensymphony.xwork2.inject
Guice (pronounced "juice").
com.opensymphony.xwork2.inject.util - package com.opensymphony.xwork2.inject.util
Guice util classes.
com.opensymphony.xwork2.interceptor - package com.opensymphony.xwork2.interceptor
Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations - package com.opensymphony.xwork2.interceptor.annotations
Interceptor annotations.
com.opensymphony.xwork2.mock - package com.opensymphony.xwork2.mock
XWork specific mock classes.
com.opensymphony.xwork2.spring - package com.opensymphony.xwork2.spring
Spring ObjectFactory classes.
com.opensymphony.xwork2.spring.interceptor - package com.opensymphony.xwork2.spring.interceptor
Spring specific interceptor classes.
com.opensymphony.xwork2.util - package com.opensymphony.xwork2.util
XWork util classes.
com.opensymphony.xwork2.util.location - package com.opensymphony.xwork2.util.location
Classes and utilities used to track location information.
com.opensymphony.xwork2.util.profiling - package com.opensymphony.xwork2.util.profiling
Classes to enable profiling of action execution.
com.opensymphony.xwork2.validator - package com.opensymphony.xwork2.validator
XWork validation subsystem.
com.opensymphony.xwork2.validator.annotations - package com.opensymphony.xwork2.validator.annotations
Validator annotations.
com.opensymphony.xwork2.validator.metadata - package com.opensymphony.xwork2.validator.metadata
Validator meta data classes.
com.opensymphony.xwork2.validator.validators - package com.opensymphony.xwork2.validator.validators
XWork default validator classes.
ComboBox - Class in org.apache.struts2.components
The combo box is basically an HTML INPUT of type text and HTML SELECT grouped together to give you a combo box functionality.
ComboBox(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.ComboBox

comboBox - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

ComboBoxDirective - Class in org.apache.struts2.views.velocity.components

ComboBoxDirective() - Constructor for class org.apache.struts2.views.velocity.components.ComboBoxDirective

ComboBoxModel - Class in org.apache.struts2.views.freemarker.tags

ComboBoxModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ComboBoxModel

ComboBoxTag - Class in org.apache.struts2.views.jsp.ui

ComboBoxTag() - Constructor for class org.apache.struts2.views.jsp.ui.ComboBoxTag

commaDelimitedStringToSet(String) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Returns a set from comma delimted Strings.
COMMAND_MODE - Static variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

COMMENT_CHARS - Static variable in class com.opensymphony.xwork2.util.PropertiesReader
Constant for the supported comment characters.
commentLines - Variable in class com.opensymphony.xwork2.util.PropertiesReader
Stores the comment lines for the currently processed property.
comparator - Variable in class org.apache.struts2.util.SortIteratorFilter

comparatorAttr - Variable in class org.apache.struts2.views.jsp.iterator.SortIteratorTag

compareDocumentPosition(Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

compareTo(Object) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

compareTo(Object) - Method in class org.apache.struts2.components.table.SortFilterModel.Row

compile(String) - Static method in class com.opensymphony.xwork2.util.OgnlUtil

compiledPaths - Variable in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
The compiled paths and their associated ActionConfig's
compilePattern(String) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Translate the given String into a int [] representing the pattern matchable by this class.
complexType(Object) - Method in class org.apache.struts2.views.freemarker.tags.TagModel

Component - Class in org.apache.struts2.components
Base class to extend for UI components.
Component(ValueStack) - Constructor for class org.apache.struts2.components.Component
Constructor.
component - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

component - Variable in class org.apache.struts2.views.jsp.ComponentTagSupport

COMPONENT_NAME - Static variable in class org.apache.struts2.components.Anchor

COMPONENT_NAME - Static variable in class org.apache.struts2.components.Autocompleter

COMPONENT_NAME - Static variable in class org.apache.struts2.components.Div

COMPONENT_NAME - Static variable in class org.apache.struts2.components.TabbedPanel

COMPONENT_STACK - Static variable in class org.apache.struts2.components.Component

ComponentDirective - Class in org.apache.struts2.views.velocity.components

ComponentDirective() - Constructor for class org.apache.struts2.views.velocity.components.ComponentDirective

ComponentModel - Class in org.apache.struts2.views.freemarker.tags

ComponentModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ComponentModel

ComponentTag - Class in org.apache.struts2.views.jsp.ui

ComponentTag() - Constructor for class org.apache.struts2.views.jsp.ui.ComponentTag

ComponentTagSupport - Class in org.apache.struts2.views.jsp

ComponentTagSupport() - Constructor for class org.apache.struts2.views.jsp.ComponentTagSupport

CompositeActionMapper - Class in org.apache.struts2.dispatcher.mapper
A composite action mapper that is capable of delegating to a series of ActionMapper if the former failed to obtained a valid ActionMapping or uri.
CompositeActionMapper() - Constructor for class org.apache.struts2.dispatcher.mapper.CompositeActionMapper

CompoundRoot - Class in com.opensymphony.xwork2.util
A Stack that is implemented using a List.
CompoundRoot() - Constructor for class com.opensymphony.xwork2.util.CompoundRoot

CompoundRoot(List) - Constructor for class com.opensymphony.xwork2.util.CompoundRoot

CompoundRootAccessor - Class in com.opensymphony.xwork2.util
A stack that is able to call methods on objects in the stack.
CompoundRootAccessor() - Constructor for class com.opensymphony.xwork2.util.CompoundRootAccessor

CompoundRootAccessor.MethodCall - Class in com.opensymphony.xwork2.util

CompoundRootAccessor.MethodCall(Class, String, Class[]) - Constructor for class com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

conditionalParse(String) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
Parse expression passed in against value stack.
conditionalParse(String, ActionInvocation) - Method in class org.apache.struts2.dispatcher.StrutsResultSupport
Parses the parameter for OGNL expressions against the valuestack
conditionalReload() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Reloads the Configuration files if the configuration files indicate that they need to be reloaded.
conditionalReload(Class, Map<String, Object>) - Method in class com.opensymphony.xwork2.util.XWorkConverter

config - Variable in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping
The original ActionConfig.
config - Variable in class com.opensymphony.xwork2.DefaultActionProxy

config - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

CONFIG_SERVLET_CONTEXT_KEY - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

configFileName - Variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

Configuration - Interface in com.opensymphony.xwork2.config
XWork configuration.
configuration - Variable in class com.opensymphony.xwork2.config.ConfigurationManager

configuration - Variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

configuration - Variable in class com.opensymphony.xwork2.DefaultActionProxy

configuration - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

configuration - Variable in class com.opensymphony.xwork2.TestNGXWorkTestCase

configuration - Variable in class com.opensymphony.xwork2.XWorkTestCase

configuration - Variable in class org.apache.struts2.components.Form

configuration - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
The XWork Configuration for this application.
configuration - Variable in class org.apache.struts2.config.MethodConfigurationProvider
Stores configuration property.
configuration - Variable in class org.apache.struts2.views.freemarker.FreemarkerResult

configuration - Variable in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

ConfigurationException - Exception in com.opensymphony.xwork2.config
ConfigurationException
ConfigurationException() - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with no detail message.
ConfigurationException(String) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String, Object) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(Throwable) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with no detail message.
ConfigurationException(Throwable, Object) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with no detail message.
ConfigurationException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with the specified detail message.
ConfigurationException(String, Throwable, Object) - Constructor for exception com.opensymphony.xwork2.config.ConfigurationException
Constructs a ConfigurationException with the specified detail message.
ConfigurationManager - Class in com.opensymphony.xwork2.config
ConfigurationManager - central for XWork Configuration management, including its ConfigurationProvider.
ConfigurationManager() - Constructor for class com.opensymphony.xwork2.config.ConfigurationManager

ConfigurationManager(String) - Constructor for class com.opensymphony.xwork2.config.ConfigurationManager

configurationManager - Variable in class com.opensymphony.xwork2.TestNGXWorkTestCase

configurationManager - Variable in class com.opensymphony.xwork2.XWorkTestCase

configurationManager - Variable in class org.apache.struts2.dispatcher.Dispatcher
Store ConfigurationManager instance, set on init.
ConfigurationProvider - Interface in com.opensymphony.xwork2.config
Interface to be implemented by all forms of XWork configuration classes.
configurationProviders - Variable in class com.opensymphony.xwork2.config.ConfigurationManager

ConfigurationUtil - Class in com.opensymphony.xwork2.config
ConfigurationUtil
ConfigurationUtil() - Constructor for class com.opensymphony.xwork2.config.ConfigurationUtil

CONSOLE_MODE - Static variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

consoleEnabled - Variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

constant - Variable in class com.opensymphony.xwork2.config.impl.LocatableConstantFactory

constant(String, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, int) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, long) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, boolean) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, double) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, float) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, short) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, char) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given name.
constant(String, Class) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a class to the given name.
constant(String, E) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an enum to the given name.
constant(Class<T>, String, T) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a constant value to the given type and name.
construct(InternalContext, Class<? super T>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector
Construct an instance.
constructAdapterInstance(Class, AdapterNode, String, Object) - Method in class org.apache.struts2.views.xslt.AdapterFactory
Create an instance of an adapter dynamically and set its context via the AdapterNode interface.
constructing - Variable in class com.opensymphony.xwork2.inject.ConstructionContext

constructInterceptorReference(PackageConfig, String, Map, Location, ObjectFactory) - Static method in class com.opensymphony.xwork2.config.providers.InterceptorBuilder
Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
ConstructionContext<T> - Class in com.opensymphony.xwork2.inject
Context of a dependency construction.
ConstructionContext() - Constructor for class com.opensymphony.xwork2.inject.ConstructionContext

ConstructionContext.DelegatingInvocationHandler<T> - Class in com.opensymphony.xwork2.inject

ConstructionContext.DelegatingInvocationHandler() - Constructor for class com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler

constructionContexts - Variable in class com.opensymphony.xwork2.inject.InternalContext

constructor - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector

constructors - Variable in class com.opensymphony.xwork2.inject.ContainerImpl

constructParameterizedInterceptorReferences(PackageConfig, InterceptorStackConfig, Map, ObjectFactory) - Static method in class com.opensymphony.xwork2.config.providers.InterceptorBuilder
Builds a list of interceptors referenced by the refName in the supplied PackageConfig overriding the properties of the referenced interceptor with refParams.
container - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

container - Variable in class com.opensymphony.xwork2.config.impl.MockConfiguration

container - Variable in class com.opensymphony.xwork2.DefaultActionProxyFactory

Container - Interface in com.opensymphony.xwork2.inject
Injects dependencies into constructors, methods and fields annotated with Inject.
container - Variable in class com.opensymphony.xwork2.inject.ExternalContext

container - Variable in class com.opensymphony.xwork2.inject.InternalContext

container - Variable in class com.opensymphony.xwork2.ObjectFactory

container - Variable in class com.opensymphony.xwork2.TestNGXWorkTestCase

container - Variable in class com.opensymphony.xwork2.XWorkTestCase

container - Variable in class org.apache.struts2.components.template.TemplateEngineManager

container - Variable in class org.apache.struts2.dispatcher.mapper.CompositeActionMapper

container - Variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

CONTAINER_FACTORY - Static variable in class com.opensymphony.xwork2.inject.ContainerBuilder

ContainerBuilder - Class in com.opensymphony.xwork2.inject
Builds a dependency injection Container.
ContainerBuilder() - Constructor for class com.opensymphony.xwork2.inject.ContainerBuilder
Constructs a new builder.
ContainerBuilder.Command - Interface in com.opensymphony.xwork2.inject
Implemented by classes which participate in building a container.
ContainerImpl - Class in com.opensymphony.xwork2.inject
Default Container implementation.
ContainerImpl(Map<Key<?>, InternalFactory<?>>) - Constructor for class com.opensymphony.xwork2.inject.ContainerImpl

ContainerImpl.ConstructorInjector<T> - Class in com.opensymphony.xwork2.inject

ContainerImpl.ConstructorInjector(ContainerImpl, Class<T>) - Constructor for class com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector

ContainerImpl.ContextualCallable<T> - Interface in com.opensymphony.xwork2.inject

ContainerImpl.FieldInjector - Class in com.opensymphony.xwork2.inject

ContainerImpl.FieldInjector(ContainerImpl, Field, String) - Constructor for class com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector

ContainerImpl.Injector - Interface in com.opensymphony.xwork2.inject
Injects a field or method in a given object.
ContainerImpl.InjectorFactory<M extends Member & AnnotatedElement> - Interface in com.opensymphony.xwork2.inject

ContainerImpl.MethodInjector - Class in com.opensymphony.xwork2.inject

ContainerImpl.MethodInjector(ContainerImpl, Method, String) - Constructor for class com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector

ContainerImpl.MissingDependencyException - Exception in com.opensymphony.xwork2.inject

ContainerImpl.MissingDependencyException(String) - Constructor for exception com.opensymphony.xwork2.inject.ContainerImpl.MissingDependencyException

ContainerImpl.ParameterInjector<T> - Class in com.opensymphony.xwork2.inject

ContainerImpl.ParameterInjector(ExternalContext<T>, InternalFactory<? extends T>) - Constructor for class com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector

contains(Class<?>, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Returns true if this builder contains a mapping for the given type and name.
contains(Class<?>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to contains(type, Container.DEFAULT_NAME).
contains(char[], char) - Method in class com.opensymphony.xwork2.util.PropertiesReader
Checks if the object is in the given array.
contains(Object) - Method in class com.opensymphony.xwork2.util.XWorkList
Deprecated.
contains(String[], String) - Method in class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

contains(Object, Object) - Method in class org.apache.struts2.components.GenericUIBean

contains(Object, Object) - Method in class org.apache.struts2.components.ListUIBean

contains(Object, Object) - Static method in class org.apache.struts2.util.ContainUtil
Determine if obj2 exists in obj1.
containsItem(Collection, String) - Static method in class org.apache.struts2.interceptor.FileUploadInterceptor

containsKey(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

containsKey(Object) - Method in class org.apache.struts2.util.AttributeMap

containsValue(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

containsValue(Object) - Method in class org.apache.struts2.util.AttributeMap

ContainUtil - Class in org.apache.struts2.util
ContainUtil will check if object 1 contains object 2.
ContainUtil() - Constructor for class org.apache.struts2.util.ContainUtil

content - Variable in class org.apache.struts2.util.TabbedPane

contentDisposition - Variable in class org.apache.struts2.dispatcher.StreamResult

contentLength - Variable in class org.apache.struts2.dispatcher.StreamResult

contentType - Variable in class org.apache.struts2.dispatcher.StreamResult

contentType - Variable in class org.apache.struts2.portlet.result.PortletResult

context - Variable in class com.opensymphony.xwork2.ActionContext

Context - Interface in com.opensymphony.xwork2.inject
Context of the current injection.
context - Variable in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

context - Variable in class com.opensymphony.xwork2.util.OgnlValueStack

context - Variable in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

context - Variable in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

context - Variable in class org.apache.struts2.dispatcher.ApplicationMap

context - Variable in class org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator

context - Static variable in class org.apache.struts2.portlet.context.ServletContextHolderListener

context - Variable in class org.apache.struts2.portlet.PortletApplicationMap

context - Variable in class org.apache.struts2.util.AttributeMap

CONTEXT_COLLECTION_MAP - Static variable in class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

contextDestroyed(ServletContextEvent) - Method in class org.apache.struts2.portlet.context.ServletContextHolderListener

contextInitialized(ServletContextEvent) - Method in class org.apache.struts2.portlet.context.ServletContextHolderListener
Stores the reference to the ServletContext.
ContextUtil - Class in org.apache.struts2.views.util
Value Stack's Context related Utilities.
ContextUtil() - Constructor for class org.apache.struts2.views.util.ContextUtil

Conversion - Annotation Type in com.opensymphony.xwork2.conversion.annotations

A marker annotation for type conversions at Type level.
CONVERSION_COLLECTION_PREFIX - Static variable in class com.opensymphony.xwork2.util.XWorkConverter

CONVERSION_ERROR_PROPERTY_PREFIX - Static variable in class com.opensymphony.xwork2.util.XWorkConverter

CONVERSION_ERRORS - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the map of type conversion errors.
CONVERSION_PROPERTY_FULLNAME - Static variable in class com.opensymphony.xwork2.util.XWorkConverter

ConversionDescription - Class in com.opensymphony.xwork2.conversion.metadata
ConversionDescription
ConversionDescription() - Constructor for class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

ConversionDescription(String) - Constructor for class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Creates an ConversionDescription with the specified property name.
ConversionErrorFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks if there are any conversion errors for a field and applies them if they exist.
ConversionErrorFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if a conversion error occured for this field.
ConversionErrorFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator

ConversionErrorFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
ConversionErrorFieldValidatorDescription
ConversionErrorFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription

ConversionErrorFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
ConversionErrorInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor adds any error found in the ActionContext's conversionErrors map as a field error (provided that the action implements ValidationAware).
ConversionErrorInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

ConversionRule - Enum in com.opensymphony.xwork2.conversion.annotations
ConversionRule
ConversionRule() - Constructor for enum com.opensymphony.xwork2.conversion.annotations.ConversionRule

ConversionType - Enum in com.opensymphony.xwork2.conversion.annotations
ConversionType
ConversionType() - Constructor for enum com.opensymphony.xwork2.conversion.annotations.ConversionType

convert(Object) - Method in class com.opensymphony.xwork2.util.XWorkList
Deprecated.
convert(String) - Method in interface org.apache.struts2.util.IteratorGenerator.Converter

convert(Object) - Static method in class org.apache.struts2.util.MakeIterator

convertActionConfig(String, ActionConfig, Map) - Method in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.
convertCommentsToString(List<String>) - Method in class com.opensymphony.xwork2.util.location.LocatableProperties

converter - Variable in class org.apache.struts2.util.IteratorGenerator

converterAttr - Variable in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

convertFromString(String, Class) - Method in class com.opensymphony.xwork2.util.EnumTypeConverter
Converts one or more String values to the specified class.
convertFromString(Map, String[], Class) - Method in class org.apache.struts2.util.StrutsTypeConverter
Converts one or more String values to the specified class.
convertParam(String, Map) - Method in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Inserts into a value wildcard-matched strings where specified with the {x} syntax.
convertParams(Map) - Method in class org.apache.struts2.views.freemarker.tags.TagModel

convertQueryParamsToRenderParams(ActionResponse, String) - Static method in class org.apache.struts2.portlet.result.PortletResult
Converts the query params to render params.
convertToString(Map, Object) - Method in class org.apache.struts2.util.StrutsTypeConverter
Converts the specified object to a String.
convertValue(Map, Object, Class) - Method in class com.opensymphony.xwork2.util.EnumTypeConverter
Converts the given object to a given type.
convertValue(Map, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

convertValue(Map, Object, Class) - Method in class com.opensymphony.xwork2.util.XWorkConverter

convertValue(Map, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.util.XWorkConverter
Convert value from one form to another.
convertValue(Map, Object, Class) - Method in class org.apache.struts2.util.StrutsTypeConverter

copy(Object, Object, Map, Collection, Collection) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
copy(Object, Object, Map) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Copies the properties in the object "from" and sets them in the object "to" using specified type converter, or XWorkConverter if none is specified.
copy(InputStream, OutputStream) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Copy bytes from the input stream to the output stream.
copyParams(Map) - Method in class org.apache.struts2.components.Component
Pushes this component's parameter Map as well as the component itself on to the stack and then copies the supplied parameters over.
count - Variable in class org.apache.struts2.util.IteratorGenerator

count - Variable in class org.apache.struts2.util.SubsetIteratorFilter

countAttr - Variable in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

countAttr - Variable in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

COUNTER - Static variable in class org.apache.struts2.dispatcher.ActionContextCleanUp

Counter - Class in org.apache.struts2.util
A bean that can be used to keep track of a counter.
Counter() - Constructor for class org.apache.struts2.util.Counter

create(Context) - Method in class com.opensymphony.xwork2.config.impl.LocatableConstantFactory

create(Context) - Method in class com.opensymphony.xwork2.config.impl.LocatableFactory

create(boolean) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Creates a Container instance.
create(ContainerImpl, M, String) - Method in interface com.opensymphony.xwork2.inject.ContainerImpl.InjectorFactory

create(Context) - Method in interface com.opensymphony.xwork2.inject.Factory
Creates an object to be injected.
create(InternalContext) - Method in interface com.opensymphony.xwork2.inject.InternalFactory
Creates an object to be injected.
create(K) - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache
Override to lazy load values.
create() - Method in interface org.apache.struts2.components.template.TemplateEngineManager.EngineFactory

create() - Method in class org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory

create(Context) - Method in class org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory

CREATE_IF_NULL_PREFIX - Static variable in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer

CREATE_NULL_OBJECTS - Static variable in class com.opensymphony.xwork2.util.InstantiatingNullHandler

createAction(Map) - Method in class com.opensymphony.xwork2.DefaultActionInvocation

createActionProxy(String, String, Map) - Method in interface com.opensymphony.xwork2.ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.
createActionProxy(String, String, Map, boolean, boolean) - Method in interface com.opensymphony.xwork2.ActionProxyFactory
Creates an ActionProxy for the given namespace and action name by looking up the configuration.
createActionProxy(String, String, Map) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
Use this method to build an DefaultActionProxy instance.
createActionProxy(String, String, Map, boolean, boolean) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory
Use this method to build an DefaultActionProxy instance.
createActionProxy(String, String, Map) - Method in class org.apache.struts2.impl.StrutsActionProxyFactory

createActionProxy(String, String, Map, boolean, boolean) - Method in class org.apache.struts2.impl.StrutsActionProxyFactory

createAndStart() - Static method in class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

createAttribute(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createAttributeNS(String, String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createCDATASection(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createCollection(Object, String, Class, Class, int) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter
Creates a Collection of the specified type.
createComment(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createConfiguration(ServletContext) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager
Create the instance of the freemarker Configuration object.
createContext(VelocityManager, ValueStack, HttpServletRequest, HttpServletResponse, String) - Method in class org.apache.struts2.dispatcher.VelocityResult
Creates the VelocityContext that we'll use to render this page.
createContext(VelocityManager, ValueStack, HttpServletRequest, HttpServletResponse, String) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult
Creates the VelocityContext that we'll use to render this page.
createContext(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.VelocityManager
This method is responsible for creating the standard VelocityContext used by all WW2 velocity views.
createContextMap() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

createContextMap(HttpServletRequest, HttpServletResponse, ActionMapping, ServletContext) - Method in class org.apache.struts2.dispatcher.Dispatcher
Create a context map containing all the wrapped request objects
createContextMap(Map, Map, Map, Map, HttpServletRequest, HttpServletResponse, ServletContext) - Method in class org.apache.struts2.dispatcher.Dispatcher
Merge all application and servlet attributes into a single HashMap to represent the entire Action context.
createContextMap(Map, Map, Map, Map, PortletRequest, PortletResponse, PortletConfig, Integer) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Merges all application and portlet attributes into a single HashMap to represent the entire Action context.
created - Variable in class com.opensymphony.xwork2.inject.ContainerBuilder

createDispatcher(FilterConfig) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Create a default Dispatcher that subclasses can override with a custom Dispatcher, if needed.
createDocumentFragment() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createElement(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createElementNS(String, String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createEntityReference(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createExtraContext() - Method in class org.apache.struts2.components.ActionComponent

CreateIfNull - Annotation Type in com.opensymphony.xwork2.util

Sets the CreateIfNull for type conversion.
createModel() - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
Build the instance of the ScopesHashModel, including JspTagLib support
Objects added to the model are
Application - servlet context attributes hash model JspTaglibs - jsp tag lib factory model Request - request attributes hash model Session - session attributes hash model request - the HttpServletRequst object for direct access response - the HttpServletResponse object for direct access stack - the OgnLValueStack instance for direct access ognl - the instance of the OgnlTool action - the action itself exception - optional : the JSP or Servlet exception as per the servlet spec (for JSP Exception pages) struts - instance of the StrutsUtil class
createModel() - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
Build the instance of the ScopesHashModel, including JspTagLib support
Objects added to the model are
Application - servlet context attributes hash model JspTaglibs - jsp tag lib factory model Request - request attributes hash model Session - session attributes hash model request - the HttpServletRequst object for direct access response - the HttpServletResponse object for direct access stack - the OgnLValueStack instance for direct access ognl - the instance of the OgnlTool action - the action itself exception - optional : the JSP or Servlet exception as per the servlet spec (for JSP Exception pages) struts - instance of the StrutsUtil class
createObject(Class, Object, String, Map) - Method in class com.opensymphony.xwork2.util.InstantiatingNullHandler

createParameterInjector(Key<T>, Member) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

createParameterMap(String[]) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap

createProcessingInstruction(String, String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createPropertyMap(InternalContextAdapter, Node) - Method in class org.apache.struts2.views.velocity.components.AbstractDirective
create a Map of properties that the user has passed in.
createProxy(Class<? super T>) - Method in class com.opensymphony.xwork2.inject.ConstructionContext

createRequestContext(HttpServletRequest) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest
Creates a RequestContext needed by Jakarta Commons Upload.
createResult() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

createResultConfig(Result) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap
Extracts result name and value and calls ClasspathConfigurationProvider.ResultMap.createResultConfig(org.apache.struts2.config.Result).
createResultConfig(Object, Class<? extends Object>, String, Map<? extends Object, ? extends Object>) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap
Creates a default ResultConfig, using either the resultClass or the default ResultType for configuration package associated this ResultMap class.
CreateSessionInterceptor - Class in org.apache.struts2.interceptor
This interceptor creates the HttpSession.
CreateSessionInterceptor() - Constructor for class org.apache.struts2.interceptor.CreateSessionInterceptor

createTextNode(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

createTypeConverter(String) - Method in class com.opensymphony.xwork2.util.XWorkConverter

createValueStack() - Method in class com.opensymphony.xwork2.util.OgnlValueStackFactory

createValueStack(ValueStack) - Method in class com.opensymphony.xwork2.util.OgnlValueStackFactory

createValueStack() - Method in class com.opensymphony.xwork2.util.ValueStackFactory

createValueStack(ValueStack) - Method in class com.opensymphony.xwork2.util.ValueStackFactory

cssClass - Variable in class org.apache.struts2.components.UIBean

cssClass - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

cssStyle - Variable in class org.apache.struts2.components.UIBean

cssStyle - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

ctx - Variable in class org.apache.struts2.util.VelocityStrutsUtil

cur - Variable in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

current - Static variable in class com.opensymphony.xwork2.util.profiling.UtilTimerStack

current - Variable in class org.apache.struts2.util.Counter

current - Variable in class org.apache.struts2.util.Timer

CURRENT_PROPERTY_PATH - Static variable in class com.opensymphony.xwork2.util.OgnlContextState

currentCount - Variable in class org.apache.struts2.util.IteratorGenerator

currentCount - Variable in class org.apache.struts2.util.SubsetIteratorFilter

currentReference - Variable in class com.opensymphony.xwork2.inject.ConstructionContext

curRow - Variable in class org.apache.struts2.components.table.WebTable

customConfigFile - Variable in class org.apache.struts2.views.velocity.VelocityManager

customEncoding - Static variable in class org.apache.struts2.views.util.UrlHelper

CustomValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This annotation can be used for custom validators.
cutStack(int) - Method in class com.opensymphony.xwork2.util.CompoundRoot

D

Date - Class in org.apache.struts2.components
Format Date object in different ways.
Date(ValueStack) - Constructor for class org.apache.struts2.components.Date

date - Variable in class org.apache.struts2.util.DateFormatter

date - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

DateCellRenderer - Class in org.apache.struts2.components.table.renderer

DateCellRenderer() - Constructor for class org.apache.struts2.components.table.renderer.DateCellRenderer

DateDirective - Class in org.apache.struts2.views.velocity.components
DateDirective
DateDirective() - Constructor for class org.apache.struts2.views.velocity.components.DateDirective

DateFormatter - Class in org.apache.struts2.util
A bean that can be used to format dates
DateFormatter() - Constructor for class org.apache.struts2.util.DateFormatter

DateModel - Class in org.apache.struts2.views.freemarker.tags
DateModel
DateModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.DateModel

DateRangeFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a date field has a value within a specified range.
DateRangeFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if the date supplied is within a specific range.
DateRangeFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

DateRangeFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
DateRangeFieldValidatorDescription
DateRangeFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

DateRangeFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
DateTag - Class in org.apache.struts2.views.jsp

DateTag() - Constructor for class org.apache.struts2.views.jsp.DateTag

DATETAG_DEFAULT_DAYS - Static variable in class org.apache.struts2.components.Date

DATETAG_DEFAULT_FUTURE - Static variable in class org.apache.struts2.components.Date

DATETAG_DEFAULT_HOURS - Static variable in class org.apache.struts2.components.Date

DATETAG_DEFAULT_MINUTES - Static variable in class org.apache.struts2.components.Date

DATETAG_DEFAULT_PAST - Static variable in class org.apache.struts2.components.Date

DATETAG_DEFAULT_SECONDS - Static variable in class org.apache.struts2.components.Date

DATETAG_DEFAULT_YEARS - Static variable in class org.apache.struts2.components.Date

DATETAG_PROPERTY - Static variable in class org.apache.struts2.components.Date
Property name to fall back when no format is specified
DATETAG_PROPERTY_DAYS - Static variable in class org.apache.struts2.components.Date
Property name that defines the days notation (default: {0,choice,1#one day|1<{0} days}{1,choice,0#|1#, one hour|1<, {1} hours})
DATETAG_PROPERTY_FUTURE - Static variable in class org.apache.struts2.components.Date
Property name that defines the future notation (default: in {0})
DATETAG_PROPERTY_HOURS - Static variable in class org.apache.struts2.components.Date
Property name that defines the hours notation (default: {0,choice,1#one hour|1<{0} hours}{1,choice,0#|1#, one minute|1<, {1} minutes})
DATETAG_PROPERTY_MINUTES - Static variable in class org.apache.struts2.components.Date
Property name that defines the minutes notation (default: {0,choice,1#one minute|1<{0} minutes})
DATETAG_PROPERTY_PAST - Static variable in class org.apache.struts2.components.Date
Property name that defines the past notation (default: {0} ago)
DATETAG_PROPERTY_SECONDS - Static variable in class org.apache.struts2.components.Date
Property name that defines the seconds notation (default: in instant)
DATETAG_PROPERTY_YEARS - Static variable in class org.apache.struts2.components.Date
Property name that defines the years notation (default: {0,choice,1#one year|1<{0} years}{1,choice,0#|1#, one day|1<, {1} days})
DateTimePicker - Class in org.apache.struts2.components

DateTimePicker(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.DateTimePicker

dateTimePicker - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

DateTimePickerDirective - Class in org.apache.struts2.views.velocity.components

DateTimePickerDirective() - Constructor for class org.apache.struts2.views.velocity.components.DateTimePickerDirective

DateTimePickerModel - Class in org.apache.struts2.views.freemarker.tags

DateTimePickerModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.DateTimePickerModel

DateTimePickerTag - Class in org.apache.struts2.views.jsp.ui

DateTimePickerTag() - Constructor for class org.apache.struts2.views.jsp.ui.DateTimePickerTag

dayWidth - Variable in class org.apache.struts2.components.DateTimePicker

dayWidth - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

Debug - Class in org.apache.struts2.components

Debug(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Debug

debug - Variable in class org.apache.struts2.components.Head

debug - Variable in class org.apache.struts2.views.jsp.ui.HeadTag

Debug.DebugMapEntry - Class in org.apache.struts2.components

Debug.DebugMapEntry(Object, Object) - Constructor for class org.apache.struts2.components.Debug.DebugMapEntry

DEBUG_PARAM - Static variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

DebuggingInterceptor - Class in org.apache.struts2.interceptor.debugging
Provides several different debugging screens to provide insight into the data behind the page.
DebuggingInterceptor() - Constructor for class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

DebugTag - Class in org.apache.struts2.views.jsp.ui

DebugTag() - Constructor for class org.apache.struts2.views.jsp.ui.DebugTag

decide(Object) - Method in class org.apache.struts2.util.SubsetIteratorFilter

decide(Object) - Method in interface org.apache.struts2.util.SubsetIteratorFilter.Decider
Should the object be added to the list?
decider - Variable in class org.apache.struts2.util.SubsetIteratorFilter

deciderAttr - Variable in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

deduceLocale() - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
Returns the locale used for the Configuration.getTemplate(String, Locale) call.
deduceLocale() - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
Returns the locale used for the Configuration.getTemplate(String, Locale)call.
DEFAULT_ACTION_FOR_MODE - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key for the default action name for the portlet, stored in the PortletActionContext.
DEFAULT_ACTION_NAME - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Default action name to use when no default action has been configured in the portlet init parameters.
DEFAULT_ALIAS_KEY - Static variable in class com.opensymphony.xwork2.interceptor.AliasInterceptor

DEFAULT_BEAN_NAME - Static variable in class org.apache.struts2.config.BeanSelectionProvider

DEFAULT_BLOCK_SIZE - Static variable in class org.apache.struts2.util.FastByteArrayOutputStream

DEFAULT_CONFIGURATION_PATHS - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Provide list of default configuration files.
DEFAULT_DELIMITER - Static variable in class org.apache.struts2.interceptor.FileUploadInterceptor

DEFAULT_FOO_VALUE - Static variable in class com.opensymphony.xwork2.mock.MockInterceptor

DEFAULT_HTTP_PORT - Static variable in class org.apache.struts2.views.util.UrlHelper
Default HTTP port (80).
DEFAULT_HTTPS_PORT - Static variable in class org.apache.struts2.views.util.UrlHelper
Default HTTPS port (443).
DEFAULT_INVALID_FIELDVALUE - Static variable in interface com.opensymphony.xwork2.XWorkMessages

DEFAULT_MESSAGE - Static variable in class org.apache.struts2.interceptor.FileUploadInterceptor

DEFAULT_NAME - Static variable in interface com.opensymphony.xwork2.inject.Container
Default dependency name.
DEFAULT_PAGE_EXTENSION - Static variable in class org.apache.struts2.config.ClasspathConfigurationProvider
The default page extension, to use in place of ".jsp".
DEFAULT_PAGE_PREFIX - Static variable in class org.apache.struts2.config.ClasspathConfigurationProvider
The default page prefix (or "path").
DEFAULT_PARAM - Static variable in class com.opensymphony.xwork2.ActionChainResult
The result parameter name to set the name of the action to chain to.
DEFAULT_PARAM - Static variable in class org.apache.struts2.dispatcher.HttpHeaderResult
The default parameter
DEFAULT_PARAM - Static variable in class org.apache.struts2.dispatcher.ServletActionRedirectResult
The default parameter
DEFAULT_PARAM - Static variable in class org.apache.struts2.dispatcher.StreamResult

DEFAULT_PARAM - Static variable in class org.apache.struts2.dispatcher.StrutsResultSupport
The default parameter
DEFAULT_PARAM - Static variable in class org.apache.struts2.views.xslt.XSLTResult
'stylesheetLocation' parameter.
DEFAULT_PARAMETER - Static variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor

DEFAULT_PARENT_PACKAGE - Static variable in class org.apache.struts2.config.ClasspathConfigurationProvider
A setting to indicate a custom default parent package, to use in place of "struts-default".
DEFAULT_RENDERER - Static variable in class org.apache.struts2.components.table.WebTableColumn

DEFAULT_RESOURCE_BUNDLES - Static variable in class com.opensymphony.xwork2.util.LocalizedTextUtil

DEFAULT_SEPARATOR - Static variable in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

DEFAULT_SESSION_ATTRIBUTE - Static variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor

DEFAULT_TEMPLATE_TYPE - Static variable in class org.apache.struts2.components.template.TemplateEngineManager
The default template extenstion is ftl.
DEFAULT_TEMPLATE_TYPE_CONFIG_KEY - Static variable in class org.apache.struts2.components.template.TemplateEngineManager

DEFAULT_THEME_PROPERTIES_FILE_NAME - Static variable in class org.apache.struts2.components.template.BaseTemplateEngine
The default theme properties file name.
DEFAULT_TOKEN_NAME - Static variable in class org.apache.struts2.util.TokenHelper
The default name to map the token value
DefaultActionInvocation - Class in com.opensymphony.xwork2
The Default ActionInvocation implementation
DefaultActionInvocation(ObjectFactory, UnknownHandler, ActionProxy, Map) - Constructor for class com.opensymphony.xwork2.DefaultActionInvocation

DefaultActionInvocation(ObjectFactory, UnknownHandler, ActionProxy, Map, boolean) - Constructor for class com.opensymphony.xwork2.DefaultActionInvocation

DefaultActionMapper - Class in org.apache.struts2.dispatcher.mapper
Default action mapper implementation, using the standard *.[ext] (where ext usually "action") pattern.
DefaultActionMapper() - Constructor for class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

DefaultActionMapper.ParameterAction - Interface in org.apache.struts2.dispatcher.mapper
Defines a parameter action prefix
DefaultActionProxy - Class in com.opensymphony.xwork2
The Default ActionProxy implementation
DefaultActionProxy(String, String, Map, boolean, boolean) - Constructor for class com.opensymphony.xwork2.DefaultActionProxy
This constructor is private so the builder methods (create*) should be used to create an DefaultActionProxy.
DefaultActionProxyFactory - Class in com.opensymphony.xwork2
DefaultActionProxyFactory
DefaultActionProxyFactory() - Constructor for class com.opensymphony.xwork2.DefaultActionProxyFactory

defaultActionRef - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

DefaultActionSupport - Class in org.apache.struts2.dispatcher
A simple action support class that sets properties to be able to serve
DefaultActionSupport() - Constructor for class org.apache.struts2.dispatcher.DefaultActionSupport
Constructor
DefaultActionValidatorManager - Class in com.opensymphony.xwork2.validator
This is the entry point into XWork's rule-based validation framework.
DefaultActionValidatorManager() - Constructor for class com.opensymphony.xwork2.validator.DefaultActionValidatorManager

defaultBlock - Variable in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

DefaultCellRenderer - Class in org.apache.struts2.components.table.renderer

DefaultCellRenderer() - Constructor for class org.apache.struts2.components.table.renderer.DefaultCellRenderer

defaultClassRef - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

DefaultConfiguration - Class in com.opensymphony.xwork2.config.impl
DefaultConfiguration
DefaultConfiguration() - Constructor for class com.opensymphony.xwork2.config.impl.DefaultConfiguration

DefaultConfiguration(String) - Constructor for class com.opensymphony.xwork2.config.impl.DefaultConfiguration

DefaultConfiguration.ContainerProperties - Class in com.opensymphony.xwork2.config.impl

DefaultConfiguration.ContainerProperties() - Constructor for class com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties

DefaultConfiguration.RuntimeConfigurationImpl - Class in com.opensymphony.xwork2.config.impl

DefaultConfiguration.RuntimeConfigurationImpl(Map<String, Map<String, ActionConfig>>, Map<String, String>) - Constructor for class com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl

defaultEncoding - Static variable in class org.apache.struts2.components.Include

defaultEncoding - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Store state of StrutsConstants.STRUTS_I18N_ENCODING setting.
defaultEncoding - Variable in class org.apache.struts2.dispatcher.VelocityResult

defaultEncoding - Variable in class org.apache.struts2.portlet.result.PortletVelocityResult

defaultFrameworkBeanName - Variable in class com.opensymphony.xwork2.config.ConfigurationManager

defaultFrameworkBeanName - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

defaultImpl - Static variable in class org.apache.struts2.config.Settings
An instance of DefaultSettings to use when another implementation is not provided (plugged in).
defaultInterceptorRef - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

defaultLocale - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Store state of StrutsConstants.STRUTS_LOCALE setting.
defaultMappings - Variable in class com.opensymphony.xwork2.util.XWorkConverter
Record class and its type converter mapping.
defaultMessage - Variable in class com.opensymphony.xwork2.validator.ValidatorConfig

defaultMessage - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

DefaultObjectTypeDeterminer - Class in com.opensymphony.xwork2.util
This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections.
DefaultObjectTypeDeterminer() - Constructor for class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer

defaultPageExtension - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
The defacto default page extension, usually associated with JavaServer Pages.
defaultPagePrefix - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
The default page prefix (none).
defaultParentPackage - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
Name of the framework's default configuration package, that application configuration packages automatically inherit.
DefaultPropertiesProvider - Class in org.apache.struts2.config
Loads the default properties, separate from the usual struts.properties loading
DefaultPropertiesProvider() - Constructor for class org.apache.struts2.config.DefaultPropertiesProvider

defaultPutStrategy - Static variable in class com.opensymphony.xwork2.inject.util.ReferenceMap

defaultResultParam - Variable in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

defaultResultType - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

DefaultSettings - Class in org.apache.struts2.config
DefaultSettings implements optional methods of Settings.
DefaultSettings() - Constructor for class org.apache.struts2.config.DefaultSettings
Constructs an instance by loading the standard property files, any custom property files (struts.custom.properties), and any custom message resources ().
DefaultTagLibrary - Class in org.apache.struts2.views
The default Struts tag library
DefaultTagLibrary() - Constructor for class org.apache.struts2.views.DefaultTagLibrary

defaultTemplateDir - Variable in class org.apache.struts2.components.UIBean

defaultTemplateType - Variable in class org.apache.struts2.components.template.TemplateEngineManager

DefaultTextProvider - Class in com.opensymphony.xwork2
DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.
DefaultTextProvider() - Constructor for class com.opensymphony.xwork2.DefaultTextProvider

defaultType - Variable in class com.opensymphony.xwork2.util.OgnlValueStack

defaultTypeConverter - Variable in class com.opensymphony.xwork2.util.XWorkConverter

defaultUITheme - Variable in class org.apache.struts2.components.UIBean

defaultValue - Variable in class org.apache.struts2.components.Property

defaultValue - Variable in class org.apache.struts2.views.jsp.PropertyTag

DefaultWorkflowInterceptor - Class in com.opensymphony.xwork2.interceptor
An interceptor that does some basic validation workflow before allowing the interceptor chain to continue.
DefaultWorkflowInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

delay - Variable in class org.apache.struts2.components.Autocompleter

delay - Variable in class org.apache.struts2.components.Div

delay - Variable in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

delay - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

delay - Variable in class org.apache.struts2.views.jsp.ui.DivTag

delaySleepInterval - Variable in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

delegate - Variable in class com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler

delegate - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap

delegate - Variable in class org.apache.struts2.config.DefaultSettings
The Settings object that handles API calls.
delegates - Variable in class org.apache.struts2.config.DelegatingSettings
The Settings objects.
DelegatingSettings - Class in org.apache.struts2.config
DelegatingSettings stores an internal list of Settings objects to update settings or retrieve settings values.
DelegatingSettings(Settings[]) - Constructor for class org.apache.struts2.config.DelegatingSettings
Creates a new DelegatingSettings object utilizing the list of Settings objects.
DelegatingValidatorContext - Class in com.opensymphony.xwork2.validator
A default implementation of the ValidatorContext interface.
DelegatingValidatorContext(ValidationAware, TextProvider, LocaleProvider) - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext
Creates a new validation context given a ValidationAware object, and a text and locale provider.
DelegatingValidatorContext(Object) - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext
Creates a new validation context given an object - usually an Action.
DelegatingValidatorContext(Class) - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext
Create a new validation context given a Class definition.
DelegatingValidatorContext.ActionContextLocaleProvider - Class in com.opensymphony.xwork2.validator
An implementation of LocaleProvider which gets the locale from the action context.
DelegatingValidatorContext.ActionContextLocaleProvider() - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext.ActionContextLocaleProvider

DelegatingValidatorContext.LoggingValidationAware - Class in com.opensymphony.xwork2.validator
An implementation of ValidationAware which logs errors and messages.
DelegatingValidatorContext.LoggingValidationAware(Class) - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

DelegatingValidatorContext.LoggingValidationAware(Object) - Constructor for class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

deleteData(int, int) - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

deleteData(int, int) - Method in class org.apache.struts2.views.xslt.SimpleTextNode

delimiter - Variable in class com.opensymphony.xwork2.util.PropertiesReader
Stores the list delimiter character.
deliverBadNews(Throwable) - Method in class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

DENY_INDEXED_ACCESS_EXECUTION - Static variable in class com.opensymphony.xwork2.util.XWorkMethodAccessor

DENY_METHOD_EXECUTION - Static variable in class com.opensymphony.xwork2.util.XWorkMethodAccessor

DependencyException - Exception in com.opensymphony.xwork2.inject
Thrown when a dependency is misconfigured.
DependencyException(String) - Constructor for exception com.opensymphony.xwork2.inject.DependencyException

DependencyException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.inject.DependencyException

DependencyException(Throwable) - Constructor for exception com.opensymphony.xwork2.inject.DependencyException

DEPRECATED_ELEMENT_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

DEPRECATED_ELEMENT_PREFIX - Static variable in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer

depth - Variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

dereference(ReferenceType, Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Returns the refererent for reference given its reference type.
dereferenceCollection(ReferenceType, T, T) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Dereferences elements in in using referenceType and puts them in out.
dereferenceEntry(Map.Entry<Object, Object>) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Dereferences an entry.
dereferenceKey(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Converts a reference to a key.
dereferenceKeySet(Set) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Dereferences a set of key references.
dereferenceValue(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Converts a reference to a value.
dereferenceValues(Collection) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Dereferences a collection of value references.
DESC - Static variable in interface org.apache.struts2.components.table.SortableTableModel

description - Variable in class com.opensymphony.xwork2.util.location.LocationImpl

destroy() - Method in interface com.opensymphony.xwork2.config.Configuration
Allow the Configuration to clean up any resources that have been used.
destroy() - Method in interface com.opensymphony.xwork2.config.ConfigurationProvider

destroy() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
Allows the configuration to clean up any resources used
destroy() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

destroy() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

destroy() - Method in class com.opensymphony.xwork2.interceptor.AbstractInterceptor
Does nothing
destroy() - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor

destroy() - Method in interface com.opensymphony.xwork2.interceptor.Interceptor
Called to let an interceptor clean up any resources it has allocated.
destroy() - Method in class com.opensymphony.xwork2.mock.MockInterceptor
Called to let an interceptor clean up any resources it has allocated.
destroy() - Method in class org.apache.struts2.config.BeanSelectionProvider

destroy() - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Default destructor.
destroy() - Method in class org.apache.struts2.config.DefaultPropertiesProvider

destroy() - Method in class org.apache.struts2.config.LegacyPropertiesConfigurationProvider

destroy() - Method in class org.apache.struts2.config.MethodConfigurationProvider

destroy() - Method in class org.apache.struts2.dispatcher.ActionContextCleanUp

destroy() - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Calls dispatcher.cleanup, which in turn releases local threads and destroys any DispatchListeners.
destroy() - Method in class org.apache.struts2.interceptor.CheckboxInterceptor

destroy() - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor
Unused.
destroy() - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

destroy() - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

destroy() - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

destroy() - Method in interface org.apache.struts2.util.ObjectFactoryDestroyable

destroyConfiguration() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Destroy its managing Configuration instance
determineActionURL(String, String, String, HttpServletRequest, HttpServletResponse, Map, String, boolean, boolean) - Method in class org.apache.struts2.components.Component
Renders an action URL by consulting the ActionMapper.
determineCurrentEnumeration() - Method in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

determineNamespace(String, ValueStack, HttpServletRequest) - Method in class org.apache.struts2.components.Component
Determines the namespace of the current page being renderdd.
devMode - Static variable in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

devMode - Static variable in class com.opensymphony.xwork2.util.OgnlValueStack

devMode - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Store state of StrutsConstants.STRUTS_DEVMODE setting.
devMode - Variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

devMode - Variable in class org.apache.struts2.interceptor.ProfilingActivationInterceptor

dir - Variable in class org.apache.struts2.components.template.Template

DirectRenderFromEventAction - Class in org.apache.struts2.portlet.dispatcher
When a portlet is targetted for an event, the portlet will receive two portlet requests, one for the event phase, and then followed by a render operation.
DirectRenderFromEventAction() - Constructor for class org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction

dirty - Variable in class org.apache.struts2.components.table.SortFilterModel

disabled - Variable in class org.apache.struts2.components.Autocompleter

disabled - Variable in class org.apache.struts2.components.UIBean

disabled - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

disabled - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

disabled - Variable in class org.apache.struts2.views.jsp.ui.OptGroupTag

disallowedRoles - Variable in class org.apache.struts2.interceptor.RolesInterceptor

Dispatcher - Class in org.apache.struts2.dispatcher
A utility class the actual dispatcher delegates most of its tasks to.
Dispatcher(ServletContext, Map<String, String>) - Constructor for class org.apache.struts2.dispatcher.Dispatcher
Create the Dispatcher instance for a given ServletContext and set of initialization parameters.
dispatcher - Variable in class org.apache.struts2.dispatcher.FilterDispatcher
Expose Dispatcher instance to subclass.
Dispatcher.Locator - Class in org.apache.struts2.dispatcher
Provide an accessor class for static XWork utility.
Dispatcher.Locator() - Constructor for class org.apache.struts2.dispatcher.Dispatcher.Locator

Dispatcher.ServletContextPageLocator - Class in org.apache.struts2.dispatcher
Search classpath for a page.
Dispatcher.ServletContextPageLocator(ServletContext) - Constructor for class org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator

dispatcherDestroyed(Dispatcher) - Method in interface org.apache.struts2.dispatcher.DispatcherListener
Called when the dispatcher is destroyed
dispatcherInitialized(Dispatcher) - Method in interface org.apache.struts2.dispatcher.DispatcherListener
Called when the dispatcher is initialized
DispatcherListener - Interface in org.apache.struts2.dispatcher
A interface to tag those that want to execute code on the init and destory of a Dispatcher.
dispatcherListeners - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Store list of DispatcherListeners.
dispatcherUtils - Variable in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

displayFormat - Variable in class org.apache.struts2.components.DateTimePicker

displayFormat - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

displayWeeks - Variable in class org.apache.struts2.components.DateTimePicker

displayWeeks - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

Div - Class in org.apache.struts2.components
The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.
Div(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Div

div - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

DivDirective - Class in org.apache.struts2.views.velocity.components

DivDirective() - Constructor for class org.apache.struts2.views.velocity.components.DivDirective

DivModel - Class in org.apache.struts2.views.freemarker.tags

DivModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.DivModel

DivTag - Class in org.apache.struts2.views.jsp.ui

DivTag() - Constructor for class org.apache.struts2.views.jsp.ui.DivTag

doAfterBody() - Method in class org.apache.struts2.views.jsp.IteratorTag

doBeforeInvocation(ActionInvocation) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
Gets the current action and its context and calls DefaultActionValidatorManager.validate(Object, String).
doConvertToArray(Map, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

doConvertToBoolean(Object) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

doConvertToCharacter(Object) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

doConvertToClass(Object) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

doConvertToCollection(Map, Object, Member, String, Object, Class) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

doConvertToDate(Map, Object, Class) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

doConvertToNumber(Map, Object, Class) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

doConvertToString(Map, Object) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

documents - Variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

doDefault() - Method in class com.opensymphony.xwork2.ActionSupport

doEndTag() - Method in class org.apache.struts2.views.jsp.ComponentTagSupport

doEndTag() - Method in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

doEndTag() - Method in class org.apache.struts2.views.jsp.iterator.SortIteratorTag

doEndTag() - Method in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

doEndTag() - Method in class org.apache.struts2.views.jsp.IteratorTag

doExecute(String, ActionInvocation) - Method in class org.apache.struts2.dispatcher.PlainTextResult

doExecute(String, ActionInvocation) - Method in class org.apache.struts2.dispatcher.ServletDispatcherResult
Dispatches to the given location.
doExecute(String, ActionInvocation) - Method in class org.apache.struts2.dispatcher.ServletRedirectResult
Redirects to the location specified by calling HttpServletResponse.sendRedirect(String).
doExecute(String, ActionInvocation) - Method in class org.apache.struts2.dispatcher.StreamResult

doExecute(String, ActionInvocation) - Method in class org.apache.struts2.dispatcher.StrutsResultSupport
Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed).
doExecute(String, ActionInvocation) - Method in class org.apache.struts2.dispatcher.VelocityResult
Creates a Velocity context from the action, loads a Velocity template and executes the template.
doExecute(String, ActionInvocation) - Method in class org.apache.struts2.portlet.result.PortletResult
Execute the result.
doExecute(String, ActionInvocation) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult

doExecute(String, ActionInvocation) - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
Execute this result, using the specified template location.
doExecute(String, ActionInvocation) - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
Execute this result, using the specified template location.
doFilter(ServletRequest, ServletResponse, FilterChain) - Method in class org.apache.struts2.dispatcher.ActionContextCleanUp

doFilter(ServletRequest, ServletResponse, FilterChain) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Process an action or handle a request a static resource.
doIntercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
Intercept ActionInvocation and returns a inputResultName when action / field errors is found registered.
doIntercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor
Subclasses must override to implement the interceptor logic.
doIntercept(ActionInvocation) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor

doIntercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

doIntercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.TokenInterceptor

doIntercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor

doLayout - Variable in class org.apache.struts2.components.TabbedPanel

doLayout - Variable in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

doLog(Log, Exception) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Performs the actual logging.
doLog(Log, String) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Performs the actual logging.
DomHelper - Class in com.opensymphony.xwork2.util
Helper class to create and retrieve information from location-enabled DOM-trees.
DomHelper() - Constructor for class com.opensymphony.xwork2.util.DomHelper

DomHelper.DOMBuilder - Class in com.opensymphony.xwork2.util
The DOMBuilder is a utility class that will generate a W3C DOM Document from SAX events.
DomHelper.DOMBuilder() - Constructor for class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Construct a new instance of this DOMBuilder.
DomHelper.DOMBuilder(SAXTransformerFactory) - Constructor for class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Construct a new instance of this DOMBuilder.
DomHelper.DOMBuilder(Node) - Constructor for class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Constructs a new instance that appends nodes to the given parent node.
DomHelper.DOMBuilder(SAXTransformerFactory, Node) - Constructor for class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Construct a new instance of this DOMBuilder.
DomHelper.StartHandler - Class in com.opensymphony.xwork2.util

DomHelper.StartHandler(ContentHandler, Map) - Constructor for class com.opensymphony.xwork2.util.DomHelper.StartHandler
Create a filter that is chained to another handler.
done - Variable in class org.apache.struts2.interceptor.BackgroundProcess

doPost(String, String, Map) - Method in class org.apache.struts2.validators.DWRValidator

doProfiling() - Method in interface com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock
Method that execute the code subjected to profiling.
doStartTag() - Method in class org.apache.struts2.views.jsp.ComponentTagSupport

doStartTag() - Method in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

doStartTag() - Method in class org.apache.struts2.views.jsp.iterator.SortIteratorTag

doStartTag() - Method in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

doTrim - Variable in class com.opensymphony.xwork2.validator.validators.RequiredStringValidator

doTrim - Variable in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

doubleAccesskey - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleAccesskey - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleCssClass - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleCssClass - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleCssStyle - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleCssStyle - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleDisabled - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleDisabled - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleEmptyOption - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleEmptyOption - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleHeaderKey - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleHeaderKey - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleHeaderValue - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleHeaderValue - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleId - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleId - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleList - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleList - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleListKey - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleListKey - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

DoubleListUIBean - Class in org.apache.struts2.components
DoubleListUIBean is the standard superclass of all Struts double list handling components.
DoubleListUIBean(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.DoubleListUIBean

doubleListValue - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleListValue - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleMultiple - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleMultiple - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleName - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleName - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnblur - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnblur - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnchange - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnchange - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnclick - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnclick - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOndblclick - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOndblclick - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnfocus - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnfocus - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnkeydown - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnkeydown - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnkeypress - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnkeypress - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnkeyup - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnkeyup - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnmousedown - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnmousedown - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnmousemove - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnmousemove - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnmouseout - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnmouseout - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnmouseover - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnmouseover - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnmouseup - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnmouseup - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleOnselect - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleOnselect - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

DoubleRangeFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a double field has a value within a specified range.
DoubleRangeFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if the double specified is within a certain range.
DoubleRangeFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

DoubleRangeFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
DoubleRangeFieldValidatorDescription
DoubleRangeFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

DoubleRangeFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription
Creates an DoubleRangeFieldValidatorDescription with the specified field name.
DoubleSelect - Class in org.apache.struts2.components
Renders two HTML select elements with second one changing displayed values depending on selected entry of first one.
DoubleSelect(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.DoubleSelect

doubleselect - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

DoubleSelectDirective - Class in org.apache.struts2.views.velocity.components

DoubleSelectDirective() - Constructor for class org.apache.struts2.views.velocity.components.DoubleSelectDirective

DoubleSelectModel - Class in org.apache.struts2.views.freemarker.tags

DoubleSelectModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.DoubleSelectModel

DoubleSelectTag - Class in org.apache.struts2.views.jsp.ui

DoubleSelectTag() - Constructor for class org.apache.struts2.views.jsp.ui.DoubleSelectTag

doubleSize - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleSize - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doubleValue - Variable in class org.apache.struts2.components.DoubleListUIBean

doubleValue - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

doValidate(Object) - Method in class com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
doValidate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

downLabel - Variable in class org.apache.struts2.components.InputTransferSelect

downLabel - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

dropdownHeight - Variable in class org.apache.struts2.components.Autocompleter

dropdownHeight - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

dropdownWidth - Variable in class org.apache.struts2.components.Autocompleter

dropdownWidth - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

dropExtension(String) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper
Drops the extension from the action name
dtdMappings - Variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

dtdMappings - Variable in class com.opensymphony.xwork2.util.DomHelper.StartHandler

DWRValidator - Class in org.apache.struts2.validators

Use the dwr configuration as follows :-
DWRValidator() - Constructor for class org.apache.struts2.validators.DWRValidator

DWRValidator.ValidatorActionInvocation - Class in org.apache.struts2.validators

DWRValidator.ValidatorActionInvocation(ObjectFactory, UnknownHandler, ActionProxy, Map) - Constructor for class org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation

DWRValidator.ValidatorActionProxy - Class in org.apache.struts2.validators

DWRValidator.ValidatorActionProxy(String, String, Map) - Constructor for class org.apache.struts2.validators.DWRValidator.ValidatorActionProxy

E

Element - Annotation Type in com.opensymphony.xwork2.util

Sets the Element for type conversion.
element() - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter
Get the proxied Element
ELEMENT_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

ELEMENT_PREFIX - Static variable in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer

elementClass - Variable in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

elementStack - Variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

Else - Class in org.apache.struts2.components

Else(ValueStack) - Constructor for class org.apache.struts2.components.Else

ElseIf - Class in org.apache.struts2.components

ElseIf(ValueStack) - Constructor for class org.apache.struts2.components.ElseIf

ElseIfModel - Class in org.apache.struts2.views.freemarker.tags

ElseIfModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ElseIfModel

elseIfModel - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

ElseIfTag - Class in org.apache.struts2.views.jsp

ElseIfTag() - Constructor for class org.apache.struts2.views.jsp.ElseIfTag

ElseModel - Class in org.apache.struts2.views.freemarker.tags

ElseModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ElseModel

elseModel - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

ElseTag - Class in org.apache.struts2.views.jsp

ElseTag() - Constructor for class org.apache.struts2.views.jsp.ElseTag

emailAddressPattern - Static variable in class com.opensymphony.xwork2.validator.validators.EmailValidator

EmailValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a field is a valid e-mail address if it contains a non-empty String.
EmailValidator - Class in com.opensymphony.xwork2.validator.validators
EmailValidator checks that a given String field, if not empty, is a valid email address.
EmailValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.EmailValidator

EmailValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
EmailValidatorDescription
EmailValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription

EmailValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
EMPTY_ARGS - Static variable in class com.opensymphony.xwork2.DefaultTextProvider

EMPTY_NAMEDNODEMAP - Static variable in class org.apache.struts2.views.xslt.AbstractAdapterNode

emptyOption - Variable in class org.apache.struts2.components.ComboBox

emptyOption - Variable in class org.apache.struts2.components.DoubleListUIBean

emptyOption - Variable in class org.apache.struts2.components.Select

emptyOption - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

emptyOption - Variable in class org.apache.struts2.views.jsp.ui.ComboBoxTag

emptyOption - Variable in class org.apache.struts2.views.jsp.ui.SelectTag

enableAncestorFormCustomOnsubmit() - Method in class org.apache.struts2.components.UIBean

enableDynamicMethodInvocation - Variable in class org.apache.struts2.components.Form

enableXmlWithConsole - Variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

encode - Variable in class org.apache.struts2.components.URL

encode - Variable in class org.apache.struts2.dispatcher.StrutsResultSupport

encode - Variable in class org.apache.struts2.views.jsp.URLTag

encoding - Variable in class org.apache.struts2.components.Head

encoding - Static variable in class org.apache.struts2.components.Include

encoding - Static variable in class org.apache.struts2.dispatcher.FilterDispatcher
Store state of StrutsConstants.STRUTS_I18N_ENCODING setting.
ENCODING - Static variable in class org.apache.struts2.portlet.util.PortletUrlHelper

encoding - Variable in class org.apache.struts2.views.freemarker.FreemarkerManager

encodingDefined - Static variable in class org.apache.struts2.components.Include

enctype - Variable in class org.apache.struts2.components.Form

enctype - Variable in class org.apache.struts2.views.jsp.ui.FormTag

end(Writer, String) - Method in class org.apache.struts2.components.ActionComponent

end(Writer, String) - Method in class org.apache.struts2.components.AppendIterator

end(Writer, String) - Method in class org.apache.struts2.components.Bean

end(Writer, String) - Method in class org.apache.struts2.components.Component
Callback for the end tag of this component.
end(Writer, String, boolean) - Method in class org.apache.struts2.components.Component
Callback for the start tag of this component.
end(Writer, String) - Method in class org.apache.struts2.components.Date

end(Writer, String) - Method in class org.apache.struts2.components.ElseIf

end(Writer, String) - Method in class org.apache.struts2.components.I18n

end(Writer, String) - Method in class org.apache.struts2.components.If

end(Writer, String) - Method in class org.apache.struts2.components.Include

end(Writer, String) - Method in class org.apache.struts2.components.IteratorComponent

end(Writer, String) - Method in class org.apache.struts2.components.MergeIterator

end(Writer, String) - Method in class org.apache.struts2.components.OptGroup

end(Writer, String) - Method in class org.apache.struts2.components.Param

end(Writer, String) - Method in class org.apache.struts2.components.Push

end(Writer, String) - Method in class org.apache.struts2.components.Set

end(Writer, String) - Method in class org.apache.struts2.components.Submit
Overrides to be able to render body in a template rather than always before the template
end(Writer, String) - Method in class org.apache.struts2.components.table.WebTable

end(Writer, String) - Method in class org.apache.struts2.components.Text

end(Writer, String) - Method in class org.apache.struts2.components.UIBean

end(Writer, String) - Method in class org.apache.struts2.components.URL

endDate - Variable in class org.apache.struts2.components.DateTimePicker

endDate - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

endDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

endDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

endDocument() - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

endElement(String, String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

endElement(String, String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

endElement(String, String, String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

endNode() - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

endOfLine() - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

endPrefixMapping(String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

endPrefixMapping(String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

endPrefixMapping(String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

ensureNotCreated() - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Currently we only support creating one Container instance per builder.
ensureNotNull(Object) - Static method in class com.opensymphony.xwork2.inject.util.ReferenceMap

ensureNotNull(Object...) - Static method in class com.opensymphony.xwork2.inject.util.ReferenceMap

ensureParamsAreStringArrays(Map) - Static method in class org.apache.struts2.portlet.util.PortletUrlHelper
Will ensure that all entries in params are String arrays, as requried by the setParameters on the PortletURL.
entries - Variable in class org.apache.struts2.dispatcher.ApplicationMap

entries - Variable in class org.apache.struts2.dispatcher.RequestMap

entries - Variable in class org.apache.struts2.dispatcher.SessionMap

entries - Variable in class org.apache.struts2.portlet.PortletApplicationMap

entries - Variable in class org.apache.struts2.portlet.PortletRequestMap

entries - Variable in class org.apache.struts2.portlet.PortletSessionMap

entrySet() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Returns an unmodifiable set view of the entries in this map.
entrySet() - Method in class org.apache.struts2.dispatcher.ApplicationMap
Creates a Set of all servlet context attributes as well as context init parameters.
entrySet() - Method in class org.apache.struts2.dispatcher.RequestMap
Returns a Set of attributes from the http request.
entrySet() - Method in class org.apache.struts2.dispatcher.SessionMap
Returns a Set of attributes from the http session.
entrySet() - Method in class org.apache.struts2.portlet.PortletApplicationMap
Creates a Set of all portlet context attributes as well as context init parameters.
entrySet() - Method in class org.apache.struts2.portlet.PortletRequestMap
Returns a Set of attributes from the portlet request.
entrySet() - Method in class org.apache.struts2.portlet.PortletSessionMap

entrySet() - Method in class org.apache.struts2.util.AttributeMap

enumeration - Variable in class org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator

enums - Variable in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

EnumTypeConverter - Class in com.opensymphony.xwork2.util
EnumTypeConverter This class converts java 5 enums to String and from String[] to enum.
EnumTypeConverter() - Constructor for class com.opensymphony.xwork2.util.EnumTypeConverter

equals(Object) - Method in class com.opensymphony.xwork2.ActionChainResult

equals(Object) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

equals(Object) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

equals(Object) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

equals(Object) - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping

equals(Object) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

equals(Object) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

equals(Object) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

equals(Object) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

equals(Object) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

equals(Object) - Method in class com.opensymphony.xwork2.inject.Key

equals(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

equals(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper

equals(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference

equals(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference

equals(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference

equals(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference

equals(Object) - Method in class com.opensymphony.xwork2.mock.MockInterceptor

equals(Object) - Method in class com.opensymphony.xwork2.mock.MockResult

equals(Object) - Method in class com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

equals(Object) - Method in class com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey

equals(Object) - Method in class com.opensymphony.xwork2.util.location.LocationImpl

ERROR - Static variable in interface com.opensymphony.xwork2.Action
The action execution was a failure.
error(SAXParseException) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

ERROR_ACTION - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Name of the action used as error handler
errorFieldNames - Variable in class org.apache.struts2.components.FieldError

errorIfMissing - Variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

errors - Variable in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

errors - Variable in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

errorText - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

errorText - Variable in class org.apache.struts2.components.Submit

errorText - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

errorText - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

escape - Variable in class org.apache.struts2.components.Property

escape(String) - Method in class org.apache.struts2.components.UIBean

escape - Variable in class org.apache.struts2.views.jsp.PropertyTag

escapeHTML(String) - Static method in class org.apache.struts2.views.util.TextUtil
Call escapeHTML(s, false)
escapeHTML(String, boolean) - Static method in class org.apache.struts2.views.util.TextUtil
Escape HTML.
evaluate(Object) - Method in interface com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator
Evaluated the value parsed by Ognl value stack.
evaluate(String) - Method in class org.apache.struts2.util.VelocityStrutsUtil

evaluateClientSideJsEnablement(String, String, String) - Method in class org.apache.struts2.components.Form

evaluateExtraParams() - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

evaluateExtraParams() - Method in class org.apache.struts2.components.Anchor

evaluateExtraParams() - Method in class org.apache.struts2.components.Autocompleter

evaluateExtraParams() - Method in class org.apache.struts2.components.Checkbox

evaluateExtraParams() - Method in class org.apache.struts2.components.ComboBox

evaluateExtraParams() - Method in class org.apache.struts2.components.Div

evaluateExtraParams() - Method in class org.apache.struts2.components.DoubleListUIBean

evaluateExtraParams() - Method in class org.apache.struts2.components.DoubleSelect

evaluateExtraParams() - Method in class org.apache.struts2.components.Form

evaluateExtraParams() - Method in class org.apache.struts2.components.FormButton

evaluateExtraParams() - Method in class org.apache.struts2.components.InputTransferSelect

evaluateExtraParams() - Method in class org.apache.struts2.components.Label

evaluateExtraParams() - Method in class org.apache.struts2.components.ListUIBean

evaluateExtraParams() - Method in class org.apache.struts2.components.OptionTransferSelect

evaluateExtraParams() - Method in class org.apache.struts2.components.Password

evaluateExtraParams() - Method in class org.apache.struts2.components.Select

evaluateExtraParams() - Method in class org.apache.struts2.components.Submit

evaluateExtraParams() - Method in class org.apache.struts2.components.TabbedPanel

evaluateExtraParams() - Method in class org.apache.struts2.components.table.WebTable

evaluateExtraParams() - Method in class org.apache.struts2.components.TextArea

evaluateExtraParams() - Method in class org.apache.struts2.components.TextField

evaluateExtraParams() - Method in class org.apache.struts2.components.Token
First looks for the token in the PageContext using the supplied name (or TokenHelper.DEFAULT_TOKEN_NAME if no name is provided) so that the same token can be re-used for the scope of a request for the same name.
evaluateExtraParams() - Method in class org.apache.struts2.components.Tree

evaluateExtraParams() - Method in class org.apache.struts2.components.UIBean

evaluateExtraParamsPortletRequest(String, String) - Method in class org.apache.struts2.components.Form
Constructs the action url adapted to a portal environment.
evaluateExtraParamsServletRequest(String, String, boolean) - Method in class org.apache.struts2.components.Form

evaluateNameValue() - Method in class org.apache.struts2.components.Form

evaluateNameValue() - Method in class org.apache.struts2.components.UIBean

evaluateParams() - Method in class org.apache.struts2.components.DateTimePicker

evaluateParams() - Method in class org.apache.struts2.components.File

evaluateParams() - Method in class org.apache.struts2.components.Head

evaluateParams() - Method in class org.apache.struts2.components.Reset

evaluateParams() - Method in class org.apache.struts2.components.Submit

evaluateParams() - Method in class org.apache.struts2.components.UIBean

evaluateParams() - Method in class org.apache.struts2.components.UpDownSelect

EVENT_ACTION - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key used for looking up and storing the action that was invoked in the event phase.
EVENT_PHASE - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Constant used for the event phase ( Portlet.processAction(javax.portlet.ActionRequest, javax.portlet.ActionResponse))
exception - Variable in class com.opensymphony.xwork2.interceptor.ExceptionHolder

exception - Variable in class org.apache.struts2.interceptor.BackgroundProcess

exceptionClassName - Variable in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

ExceptionHolder - Class in com.opensymphony.xwork2.interceptor
A simple wrapper around an exception, providing an easy way to print out the stack trace of the exception as well as a way to get a handle on the exception itself.
ExceptionHolder(Exception) - Constructor for class com.opensymphony.xwork2.interceptor.ExceptionHolder

ExceptionMappingConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for exception mapping.
ExceptionMappingConfig() - Constructor for class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

ExceptionMappingConfig(String, String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

ExceptionMappingConfig(String, String, String, Map) - Constructor for class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

ExceptionMappingInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor forms the core functionality of the exception handling feature.
ExceptionMappingInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

exceptionMappings - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig

excludeMethods - Variable in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

excludeParams - Variable in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

excludes - Variable in class com.opensymphony.xwork2.interceptor.ChainingInterceptor

execute() - Method in interface com.opensymphony.xwork2.Action
Where the logic of the action is executed.
execute(ActionInvocation) - Method in class com.opensymphony.xwork2.ActionChainResult

execute() - Method in interface com.opensymphony.xwork2.ActionProxy
Execute this ActionProxy.
execute() - Method in class com.opensymphony.xwork2.ActionSupport
A default implementation that does nothing an returns "success".
execute() - Method in class com.opensymphony.xwork2.DefaultActionProxy

execute(ReferenceMap.Strategy, K, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

execute(ReferenceMap, Object, Object) - Method in interface com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy

execute() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

execute(ActionInvocation) - Method in class com.opensymphony.xwork2.mock.MockResult

execute(ActionInvocation) - Method in interface com.opensymphony.xwork2.Result
Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.
execute(ActionInvocation) - Method in class org.apache.struts2.config.NullResult

execute() - Method in class org.apache.struts2.dispatcher.DefaultActionSupport

execute(ActionInvocation) - Method in class org.apache.struts2.dispatcher.HttpHeaderResult
Sets the optional HTTP response status code and also re-sets HTTP headers after they've been optionally evaluated against the ValueStack.
execute(String, ActionMapping) - Method in interface org.apache.struts2.dispatcher.mapper.DefaultActionMapper.ParameterAction

execute(ActionInvocation) - Method in class org.apache.struts2.dispatcher.ServletActionRedirectResult

execute(ActionInvocation) - Method in class org.apache.struts2.dispatcher.StrutsResultSupport
Implementation of the execute method from the Result interface.
execute() - Method in class org.apache.struts2.impl.StrutsActionProxy

execute() - Method in class org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction
Always return success.
execute() - Method in class org.apache.struts2.util.AppendIteratorFilter

execute() - Method in class org.apache.struts2.util.IteratorGenerator

execute() - Method in class org.apache.struts2.util.MergeIteratorFilter

execute() - Method in class org.apache.struts2.util.SortIteratorFilter

execute() - Method in class org.apache.struts2.util.SubsetIteratorFilter

execute(ActionInvocation) - Method in class org.apache.struts2.views.xslt.XSLTResult

executeAction() - Method in class org.apache.struts2.components.ActionComponent
Execute the requested action.
executeActionResult(String, ActionInvocation) - Method in class org.apache.struts2.portlet.result.PortletResult
Executes the action result.
executeActionResult(String, ActionInvocation) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult
Executes the result
executeActionResult(String, ActionInvocation) - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

executeAfterValidationPass - Variable in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

ExecuteAndWaitInterceptor - Class in org.apache.struts2.interceptor
The ExecuteAndWaitInterceptor is great for running long-lived actions in the background while showing the user a nice progress meter.
ExecuteAndWaitInterceptor() - Constructor for class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

executed - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

executed - Variable in class com.opensymphony.xwork2.mock.MockInterceptor

executedCalled - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

executeRegularServletResult(String, ActionInvocation) - Method in class org.apache.struts2.portlet.result.PortletResult
Executes the regular servlet result.
executeRenderResult(String) - Method in class org.apache.struts2.portlet.result.PortletResult
Executes the render result.
executeRenderResult(String, ActionInvocation) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult
Creates a Velocity context from the action, loads a Velocity template and executes the template.
executeRenderResult(String, ActionInvocation) - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

executeResult() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
Uses getResult to get the final Result and executes it
executeResult - Variable in class com.opensymphony.xwork2.DefaultActionProxy

executeResult - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

executeResult - Variable in class org.apache.struts2.components.ActionComponent

executeResult - Variable in class org.apache.struts2.views.jsp.ActionTag

executeScripts - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

executeScripts - Variable in class org.apache.struts2.components.Submit

executeScripts - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

executeScripts - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

exludingPattern - Variable in class org.apache.struts2.views.xslt.XSLTResult
Indicates the property name patterns which should be excluded from the xml.
expandIconSrcMinus - Variable in class org.apache.struts2.components.Tree

expandIconSrcMinus - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

expandIconSrcPlus - Variable in class org.apache.struts2.components.Tree

expandIconSrcPlus - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

expectedFoo - Variable in class com.opensymphony.xwork2.mock.MockInterceptor

exposedValue - Variable in class org.apache.struts2.views.xslt.XSLTResult
Indicates the ognl expression respresenting the bean which is to be exposed as xml.
expression - Variable in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

expression - Variable in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

expression - Variable in class com.opensymphony.xwork2.validator.validators.ExpressionValidator

expression - Variable in class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

expression - Variable in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator

EXPRESSION_PARAM - Static variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

expressions - Static variable in class com.opensymphony.xwork2.util.OgnlUtil

ExpressionValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This non-field level validator validates a supplied regular expression.
ExpressionValidator - Class in com.opensymphony.xwork2.validator.validators
A Non-Field Level validator that validates based on regular expression supplied.
ExpressionValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.ExpressionValidator

ExpressionValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
ExpressionValidatorDescription
ExpressionValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

extensions - Variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

externalContext - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector

externalContext - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector

ExternalContext<T> - Class in com.opensymphony.xwork2.inject
An immutable snapshot of the current context which is safe to expose to client code.
ExternalContext(Member, Key<T>, ContainerImpl) - Constructor for class com.opensymphony.xwork2.inject.ExternalContext

externalContext - Variable in class com.opensymphony.xwork2.inject.InternalContext

extraContext - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

extraContext - Variable in class com.opensymphony.xwork2.DefaultActionProxy

extractQueryString() - Method in class org.apache.struts2.components.URL

extraParameterProvider - Variable in class org.apache.struts2.components.URL

F

factories - Variable in class com.opensymphony.xwork2.inject.ContainerBuilder

factories - Variable in class com.opensymphony.xwork2.inject.ContainerImpl

factory(Key<T>, InternalFactory<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a dependency.
factory(Class<T>, String, Factory<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps a factory to a given dependency type and name.
factory(Class<T>, Factory<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
factory(Class<T>, String, Factory<? extends T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).
factory(Class<T>, Factory<? extends T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).
factory(Class<T>, String, Class<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an implementation class to a given dependency type and name.
factory(Class<T>, String, Class<? extends T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Maps an implementation class to a given dependency type and name.
factory(Class<T>, Class<? extends T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation).
factory(Class<T>) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type).
factory(Class<T>, String) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, name, type).
factory(Class<T>, Class<? extends T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).
factory(Class<T>, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).
factory(Class<T>, String, Scope) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Convenience method. Equivalent to factory(type, name, type, scope).
factory - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector

factory - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector

Factory<T> - Interface in com.opensymphony.xwork2.inject
A custom factory.
factory - Variable in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

FACTORY - Static variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
The default transformer factory shared by all instances
factory - Variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
The transformer factory
factory - Static variable in class com.opensymphony.xwork2.util.ValueStackFactory

factory - Variable in class org.apache.struts2.config.MethodConfigurationProvider
Stores ObjectFactory property.
factory - Variable in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

FACTORY - Static variable in class org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel

factoryNamesByType - Variable in class com.opensymphony.xwork2.inject.ContainerImpl

FastByteArrayOutputStream - Class in org.apache.struts2.util
A speedy implementation of ByteArrayOutputStream.
FastByteArrayOutputStream() - Constructor for class org.apache.struts2.util.FastByteArrayOutputStream

FastByteArrayOutputStream(int) - Constructor for class org.apache.struts2.util.FastByteArrayOutputStream

fatalError(SAXParseException) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

field - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector

field - Variable in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

fieldError(String, String, Exception) - Method in class org.apache.struts2.components.Component
Constructs?a RuntimeException based on the given information.
FieldError - Class in org.apache.struts2.components
Render field errors if they exists.
FieldError(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.FieldError

fielderror - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

FieldErrorDirective - Class in org.apache.struts2.views.velocity.components

FieldErrorDirective() - Constructor for class org.apache.struts2.views.velocity.components.FieldErrorDirective

FieldErrorModel - Class in org.apache.struts2.views.freemarker.tags

FieldErrorModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.FieldErrorModel

fieldErrors - Variable in class com.opensymphony.xwork2.ValidationAwareSupport

fieldErrorsSessionKey - Static variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

FieldErrorTag - Class in org.apache.struts2.views.jsp.ui
FieldError Tag.
FieldErrorTag() - Constructor for class org.apache.struts2.views.jsp.ui.FieldErrorTag

FieldExpressionValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator uses an OGNL expression to perform its validator.
FieldExpressionValidator - Class in com.opensymphony.xwork2.validator.validators
Validates a field using an OGNL expression.
FieldExpressionValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

FieldExpressionValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
FieldExpressionValidatorDescription
FieldExpressionValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

FieldExpressionValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
fieldName - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

fieldName - Variable in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

FieldValidator - Interface in com.opensymphony.xwork2.validator
The FieldValidator interface defines the methods to be implemented by FieldValidators, which are used by the XWork validation framework to validate Action properties before executing the Action.
FieldValidatorSupport - Class in com.opensymphony.xwork2.validator.validators
Base class for field validators.
FieldValidatorSupport() - Constructor for class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

fieldValue - Variable in class org.apache.struts2.components.Checkbox

fieldValue - Variable in class org.apache.struts2.views.jsp.ui.CheckboxTag

file - Variable in class com.opensymphony.xwork2.util.FileManager.FileRevision

File - Class in org.apache.struts2.components
Renders an HTML file input element.
File(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.File

file - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

FileDirective - Class in org.apache.struts2.views.velocity.components

FileDirective() - Constructor for class org.apache.struts2.views.velocity.components.FileDirective

FileManager - Class in com.opensymphony.xwork2.util
FileManager This class was brought in from oscore trunk revision 147.
FileManager() - Constructor for class com.opensymphony.xwork2.util.FileManager

FileManager.FileRevision - Class in com.opensymphony.xwork2.util

FileManager.FileRevision() - Constructor for class com.opensymphony.xwork2.util.FileManager.FileRevision

FileManager.FileRevision(File, long) - Constructor for class com.opensymphony.xwork2.util.FileManager.FileRevision

FileModel - Class in org.apache.struts2.views.freemarker.tags

FileModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.FileModel

filename - Variable in class org.apache.struts2.config.StrutsXmlConfigurationProvider

fileNeedsReloading(String) - Static method in class com.opensymphony.xwork2.util.FileManager

files - Static variable in class com.opensymphony.xwork2.util.FileManager

files - Variable in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

FileTag - Class in org.apache.struts2.views.jsp.ui

FileTag() - Constructor for class org.apache.struts2.views.jsp.ui.FileTag

FileUploadInterceptor - Class in org.apache.struts2.interceptor
Interceptor that is based off of MultiPartRequestWrapper, which is automatically applied for any request that includes a file.
FileUploadInterceptor() - Constructor for class org.apache.struts2.interceptor.FileUploadInterceptor

filterConfig - Variable in class org.apache.struts2.dispatcher.FilterDispatcher
Provide FilterConfig instance, set on init.
FilterDispatcher - Class in org.apache.struts2.dispatcher
Master filter for Struts that handles four distinct responsibilities: Executing actions Cleaning up the ActionContext (see note) Serving static content Kicking off XWork's interceptor chain for the request lifecycle
IMPORTANT: this filter must be mapped to all requests.
FilterDispatcher() - Constructor for class org.apache.struts2.dispatcher.FilterDispatcher

FilterDispatcherCompatWeblogic61 - Class in org.apache.struts2.dispatcher
When running Weblogic Server 6.1, this class should be specified in web.xml instead of FilterDispatcher.
FilterDispatcherCompatWeblogic61() - Constructor for class org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61

FinalizablePhantomReference<T> - Class in com.opensymphony.xwork2.inject.util
Phantom reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizablePhantomReference(T) - Constructor for class com.opensymphony.xwork2.inject.util.FinalizablePhantomReference

FinalizableReference - Interface in com.opensymphony.xwork2.inject.util
Package-private interface implemented by references that have code to run after garbage collection of their referents.
FinalizableReferenceQueue - Class in com.opensymphony.xwork2.inject.util
Starts a background thread that cleans up after reclaimed referents.
FinalizableReferenceQueue() - Constructor for class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

FinalizableSoftReference<T> - Class in com.opensymphony.xwork2.inject.util
Soft reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableSoftReference(T) - Constructor for class com.opensymphony.xwork2.inject.util.FinalizableSoftReference

FinalizableWeakReference<T> - Class in com.opensymphony.xwork2.inject.util
Weak reference with a FinalizableReference.finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
FinalizableWeakReference(T) - Constructor for class com.opensymphony.xwork2.inject.util.FinalizableWeakReference

finalizeReferent() - Method in interface com.opensymphony.xwork2.inject.util.FinalizableReference
Invoked on a background thread after the referent has been garbage collected.
finalizeReferent() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference

finalizeReferent() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference

finalizeReferent() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference

finalizeReferent() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference

find(Class, String) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Retrieves all classes within a packages.
find(ResolverUtil.Test, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Attempts to discover classes that pass the test.
findAncestor(Class) - Method in class org.apache.struts2.components.Component
Finds the nearest ancestor of this component stack.
findAnnotated(Class<? extends Annotation>, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Attempts to discover classes that are annotated with to the annotation.
findAnnotatedMethods(Class, Class<? extends Annotation>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils

findAutoWiringBeanFactory(ApplicationContext) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
If the given context is assignable to AutowireCapbleBeanFactory or contains a parent or a factory that is, then set the autoWiringFactory appropriately.
findConstructorIn(Class<T>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector

findDefaultText(String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Returns a localized message for the specified key, aTextName.
findDefaultText(String, Locale, Object[]) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Returns a localized message for the specified key, aTextName, substituting variables from the array of params into the message.
finders - Static variable in class com.opensymphony.xwork2.util.location.LocationUtils

findImplementations(Class, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Attempts to discover classes that are assignable to the type provided.
findInContext(String) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

findInFileSystem(String) - Method in class org.apache.struts2.config.StrutsXmlConfigurationProvider

findInject(Annotation[]) - Method in class com.opensymphony.xwork2.inject.ContainerImpl
Finds the Inject annotation in an array of annotations.
findInPackage(ResolverUtil.Test, String) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Scans for classes starting at the package provided and descending into subpackages.
findInputStream(String, String) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Look for a static resource in the classpath.
findInRequest(Class<T>, String, Callable<? extends T>) - Method in interface com.opensymphony.xwork2.inject.Scope.Strategy
Finds an object for the given type and name in the request scope.
findInSession(Class<T>, String, Callable<? extends T>) - Method in interface com.opensymphony.xwork2.inject.Scope.Strategy
Finds an object for the given type and name in the session scope.
findInWizard(Class<T>, String, Callable<? extends T>) - Method in interface com.opensymphony.xwork2.inject.Scope.Strategy
Finds an object for the given type and name in the wizard scope.
findListValue() - Method in class org.apache.struts2.components.Autocompleter

findListValue() - Method in class org.apache.struts2.components.ComboBox

findMessage(Class, String, String, Locale, Object[], Set, ValueStack) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Traverse up class hierarchy looking for message.
findProviderInStack() - Method in class org.apache.struts2.components.Date

findRecursively(Class, Class<? extends Annotation>, List<Method>) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils

findResourceBundle(String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds the given resorce bundle by it's name.
findResultFromExceptions(List, Throwable) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

findStaticResource(String, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Locate a static resource and copy directly to the response, setting the appropriate caching headers.
findString(String) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

findString(String) - Method in interface com.opensymphony.xwork2.util.ValueStack

findString(String) - Method in class org.apache.struts2.components.Component
Evaluates the OGNL stack to find a String value.
findString(String, String, String) - Method in class org.apache.struts2.components.Component
Evaluates the OGNL stack to find a String value.
findString(String) - Method in class org.apache.struts2.util.StrutsUtil

findString(String) - Method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

findSuffix(String, String...) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Attempts to discover classes who's name ends with the provided suffix.
findText(Class, String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Calls LocalizedTextUtil.findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args) with aTextName as the default message.
findText(Class, String, Locale, String, Object[]) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName.
findText(Class, String, Locale, String, Object[], ValueStack) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName.
findText(ResourceBundle, String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName, in the specified resource bundle with aTextName as the default message.
findText(ResourceBundle, String, Locale, String, Object[]) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
findText(ResourceBundle, String, Locale, String, Object[], ValueStack) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
findValue(String) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

findValue(String, Class) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

findValue(String) - Method in interface com.opensymphony.xwork2.util.ValueStack
Find a value by evaluating the given expression against the stack in the default search order.
findValue(String, Class) - Method in interface com.opensymphony.xwork2.util.ValueStack
Find a value by evaluating the given expression against the stack in the default search order.
findValue(String) - Method in class org.apache.struts2.components.Component
Finds a value from the OGNL stack based on the given expression.
findValue(String, String, String) - Method in class org.apache.struts2.components.Component
Evaluates the OGNL stack to find an Object value.
findValue(String, Class) - Method in class org.apache.struts2.components.Component
Evaluates the OGNL stack to find an Object of the given type.
findValue(String, String) - Method in class org.apache.struts2.util.StrutsUtil

findValue(String) - Method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

findValue(String, Class) - Method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

findValue(String, Object) - Method in class org.apache.struts2.views.jsp.ui.OgnlTool

FINISH_MESSAGE - Static variable in class com.opensymphony.xwork2.interceptor.LoggingInterceptor

finishConstruction() - Method in class com.opensymphony.xwork2.inject.ConstructionContext

finishTag() - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

first - Variable in class org.apache.struts2.util.Counter

FixedTextCellRenderer - Class in org.apache.struts2.components.table.renderer
usefull if a column has an embeded ID number needed for a link but you want it to say something else.
FixedTextCellRenderer() - Constructor for class org.apache.struts2.components.table.renderer.FixedTextCellRenderer

flush - Variable in class org.apache.struts2.components.ActionComponent

flush() - Method in class org.apache.struts2.components.Include.PageOutputStream

flush() - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

flush() - Method in class org.apache.struts2.views.freemarker.tags.CallbackWriter

flush - Variable in class org.apache.struts2.views.jsp.ActionTag

foo - Variable in class com.opensymphony.xwork2.mock.MockInterceptor

forAttr - Variable in class org.apache.struts2.components.Label

forAttr - Variable in class org.apache.struts2.views.jsp.ui.LabelTag

FORCE_LOWER_CASE - Static variable in class org.apache.struts2.config.ClasspathConfigurationProvider
The default page prefix (or "path").
forceLowerCase - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
Whether to use a lowercase letter as the initial letter of an action.
forceValidOption - Variable in class org.apache.struts2.components.Autocompleter

forceValidOption - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

Form - Class in org.apache.struts2.components

Renders HTML an input form.

The remote form allows the form to be submitted without the page being refreshed.
Form(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Form

form - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

format - Variable in class org.apache.struts2.components.Date

format(Object) - Method in class org.apache.struts2.components.DateTimePicker

format - Variable in class org.apache.struts2.util.DateFormatter

format - Variable in class org.apache.struts2.views.jsp.DateTag

formatLength - Variable in class org.apache.struts2.components.DateTimePicker

formatLength - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

FORMATTED_DATA - Static variable in class org.apache.struts2.components.table.WebTable.WebTableRowIterator

formatTime(TextProvider, Date) - Method in class org.apache.struts2.components.Date
Calculates the difference in time from now to the given date, and outputs it nicely.
FormButton - Class in org.apache.struts2.components
FormButton.
FormButton(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.FormButton

FormDirective - Class in org.apache.struts2.views.velocity.components

FormDirective() - Constructor for class org.apache.struts2.views.velocity.components.FormDirective

formFilter - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

formFilter - Variable in class org.apache.struts2.components.Autocompleter

formFilter - Variable in class org.apache.struts2.components.Submit

formFilter - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

formFilter - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

formFilter - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

formId - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

formId - Variable in class org.apache.struts2.components.Autocompleter

formId - Variable in class org.apache.struts2.components.Submit

formId - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

formId - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

formId - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

FormModel - Class in org.apache.struts2.views.freemarker.tags

FormModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.FormModel

formName - Variable in class org.apache.struts2.components.DoubleListUIBean

formName - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

FormTag - Class in org.apache.struts2.views.jsp.ui

FormTag() - Constructor for class org.apache.struts2.views.jsp.ui.FormTag

foundInBundle - Variable in class com.opensymphony.xwork2.util.LocalizedTextUtil.GetDefaultMessageReturnArg

freemarkerManager - Variable in class org.apache.struts2.components.template.FreemarkerTemplateEngine

freemarkerManager - Variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

FreemarkerManager - Class in org.apache.struts2.views.freemarker
Static Configuration Manager for the FreemarkerResult's configuration
Possible extension points are :- createConfiguration method loadSettings method getTemplateLoader method populateContext method
createConfiguration method
Create a freemarker Configuration.
FreemarkerManager() - Constructor for class org.apache.struts2.views.freemarker.FreemarkerManager

freemarkerManager - Variable in class org.apache.struts2.views.freemarker.FreemarkerResult

freemarkerManager - Variable in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

FreemarkerResult - Class in org.apache.struts2.views.freemarker
Renders a view using the Freemarker template engine.
FreemarkerResult() - Constructor for class org.apache.struts2.views.freemarker.FreemarkerResult

FreemarkerResult(String) - Constructor for class org.apache.struts2.views.freemarker.FreemarkerResult

FreemarkerTemplateEngine - Class in org.apache.struts2.components.template
Freemarker based template engine.
FreemarkerTemplateEngine() - Constructor for class org.apache.struts2.components.template.FreemarkerTemplateEngine

FULL_PROPERTY_PATH - Static variable in class com.opensymphony.xwork2.util.OgnlContextState

fullQualifiedClassName - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

Function<F,T> - Interface in com.opensymphony.xwork2.inject.util
A Function provides a transformation on an object and returns the resulting object.
futures - Variable in class com.opensymphony.xwork2.inject.util.ReferenceCache

G

generateGUID() - Static method in class org.apache.struts2.util.TokenHelper

GenericsObjectTypeDeterminer - Class in com.opensymphony.xwork2.util
GenericsObjectTypeDeterminer
GenericsObjectTypeDeterminer() - Constructor for class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer

GenericUIBean - Class in org.apache.struts2.components
Renders an custom UI widget using the specified templates.
GenericUIBean(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.GenericUIBean

get(Object) - Method in class com.opensymphony.xwork2.ActionContext
Returns a value that is stored in the current ActionContext by doing a lookup using the value's key.
get(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache
If this map does not contain an entry for the given key and ReferenceCache.create(Object) has been overridden, this method will create a new value, put it in the map, and return it.
get(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

get(Location) - Static method in class com.opensymphony.xwork2.util.location.LocationImpl
Obtain a LocationImpl from a Location.
get(int) - Method in class com.opensymphony.xwork2.util.XWorkList
Deprecated. Returns the element at the specified position in this list.
get(Object) - Method in class com.opensymphony.xwork2.util.XWorkMap
Deprecated. Returns the value to which the specified key is mapped in this identity hash map.
GET - Static variable in class org.apache.struts2.components.URL

get(String) - Static method in class org.apache.struts2.config.Settings
Provides a setting value as a String.
get(Object) - Method in class org.apache.struts2.dispatcher.ApplicationMap
Returns the servlet context attribute or init parameter based on the given key.
get(Object) - Method in class org.apache.struts2.dispatcher.RequestMap
Returns the request attribute associated with the given key or null if it doesn't exist.
get(Object) - Method in class org.apache.struts2.dispatcher.SessionMap
Returns the session attribute associated with the given key or null if it doesn't exist.
get(Object) - Method in class org.apache.struts2.portlet.PortletApplicationMap
Returns the portlet context attribute or init parameter based on the given key.
get(Object) - Method in class org.apache.struts2.portlet.PortletRequestMap
Returns the request attribute associated with the given key or null if it doesn't exist.
get(Object) - Method in class org.apache.struts2.portlet.PortletSessionMap
Returns the session attribute associated with the given key or null if it doesn't exist.
get(Object) - Method in class org.apache.struts2.util.AttributeMap

get(String) - Method in class org.apache.struts2.util.PrefixTrie

get(String) - Method in class org.apache.struts2.views.freemarker.ScopesHashModel

GET_MODEL - Static variable in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

getA() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getAccessor() - Static method in class com.opensymphony.xwork2.util.OgnlValueStack

getAction() - Method in interface com.opensymphony.xwork2.ActionInvocation
Get the Action associated with this ActionInvocation
getAction() - Method in interface com.opensymphony.xwork2.ActionProxy

getAction() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

getAction() - Method in class com.opensymphony.xwork2.DefaultActionProxy

getAction() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

getAction() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

getAction() - Method in class org.apache.struts2.interceptor.BackgroundProcess
Retrieves the action.
getAction() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getActionConfig() - Method in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping
Gets the ActionConfig that contains the pattern.
getActionConfig(String, String) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl
Gets the configuration information for an action name, or returns null if the name is not recognized.
getActionConfig(String, String) - Method in interface com.opensymphony.xwork2.config.RuntimeConfiguration
get the fully expanded ActionConfig for a specified namespace and (action) name
getActionConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

getActionConfigs() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl
Gets the configuration settings for every action.
getActionConfigs() - Method in interface com.opensymphony.xwork2.config.RuntimeConfiguration
returns a Map of all the registered ActionConfigs.
getActionContext(HttpServletRequest) - Static method in class org.apache.struts2.ServletActionContext
Gets the current action context
getActionerror() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getActionErrors() - Method in class com.opensymphony.xwork2.ActionSupport

getActionErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Get the Collection of Action-level error messages for this action.
getActionErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

getActionErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getActionErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

getActionEventListener() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

getActionInvocation() - Method in class com.opensymphony.xwork2.ActionContext
Gets the action invocation (the execution state).
getActionMapping(PortletRequest) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Gets the namespace of the action from the request.
getActionMapping() - Static method in class org.apache.struts2.ServletActionContext
Gets the action mapping for this context
getActionmessage() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getActionMessages() - Method in class com.opensymphony.xwork2.ActionSupport

getActionMessages() - Method in interface com.opensymphony.xwork2.ValidationAware
Get the Collection of Action-level messages for this action.
getActionMessages() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

getActionMessages() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getActionMessages() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

getActionMethod(Class, String) - Method in class org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor

getActionName() - Method in interface com.opensymphony.xwork2.ActionProxy

getActionName() - Method in class com.opensymphony.xwork2.DefaultActionProxy

getActionName() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

getActionName(String) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Get the action name part of the action path.
getActionRequest() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the ActionRequest.
getActionResponse() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the ActionRequest.
getAdapterFactory() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getAdapterFactory() - Method in interface org.apache.struts2.views.xslt.AdapterNode
The adapter factory that created this node.
getAdapterFactory() - Method in class org.apache.struts2.views.xslt.XSLTResult

getAdapterForValue(Object) - Method in class org.apache.struts2.views.xslt.AdapterFactory

getAddAllToLeftLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getAddAllToLeftLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAddAllToRightLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getAddAllToRightLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAddLabel() - Method in class org.apache.struts2.components.InputTransferSelect

getAddLabel() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getAddToLeftLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getAddToLeftLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAddToRightLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getAddToRightLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAlignment() - Method in class org.apache.struts2.components.table.renderer.AbstractCellRenderer

getAllActionConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the Map of all the ActionConfigs available in the current package.
getAllExceptionMappingConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the List of all the ExceptionMappingConfigs available in the current package.
getAllGlobalResults() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the Map of all the global ResultConfigs available in the current package.
getAllInterceptorConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the Map of all InterceptorConfigs and InterceptorStackConfigs available in the current package.
getAllowAddAllToLeft() - Method in class org.apache.struts2.components.OptionTransferSelect

getAllowAddAllToLeft() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAllowAddAllToRight() - Method in class org.apache.struts2.components.OptionTransferSelect

getAllowAddAllToRight() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAllowAddToLeft() - Method in class org.apache.struts2.components.OptionTransferSelect

getAllowAddToLeft() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAllowAddToRight() - Method in class org.apache.struts2.components.OptionTransferSelect

getAllowAddToRight() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAllowedCollection() - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

getAllowMoveDown() - Method in class org.apache.struts2.components.UpDownSelect

getAllowMoveDown() - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

getAllowMoveUp() - Method in class org.apache.struts2.components.UpDownSelect

getAllowMoveUp() - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

getAllowRemoveAll() - Method in class org.apache.struts2.components.InputTransferSelect

getAllowRemoveAll() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getAllowRequestParameterSwitch() - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

getAllowSelectAll() - Method in class org.apache.struts2.components.OptionTransferSelect

getAllowSelectAll() - Method in class org.apache.struts2.components.UpDownSelect

getAllowSelectAll() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAllowSelectAll() - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

getAllowUpDown() - Method in class org.apache.struts2.components.InputTransferSelect

getAllowUpDown() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getAllowUpDownOnLeft() - Method in class org.apache.struts2.components.OptionTransferSelect

getAllowUpDownOnLeft() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAllowUpDownOnRight() - Method in class org.apache.struts2.components.OptionTransferSelect

getAllowUpDownOnRight() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getAllResultTypeConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
returns the Map of all the ResultTypeConfigs available in the current package.
getAnnotation(Class, String, Class<T>) - Method in class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
Retrieves an annotation for the specified property of field, setter or getter.
getAnnotationFromGetter(Class, String, Class<T>) - Method in class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
Retrieves an annotation for the specified field of getter.
getAnnotationFromSetter(Class, String, Class<T>) - Method in class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
Retrieves an annotation for the specified field of setter.
getApplication() - Method in class com.opensymphony.xwork2.ActionContext
Returns a Map of the ServletContext when in a servlet environment or a generic application level Map otherwise.
getApplicationContext() - Method in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

getApplicationContext(Map) - Method in class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory
Subclasses may override this to return a different application context.
getApplicationMap() - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Returns a Map of all application attributes.
getArgTypes(Object[]) - Method in class com.opensymphony.xwork2.util.CompoundRootAccessor

getAscending() - Method in class org.apache.struts2.util.Sorter

getAscending(String) - Method in class org.apache.struts2.util.Sorter

getAttribute(String) - Method in class org.apache.struts2.dispatcher.StrutsRequestWrapper
Gets the object, looking in the value stack if not found
getAttribute(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getAttribute(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement
No attributes, return empty attributes if asked.
getAttribute(String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

getAttributeAdapters() - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

getAttributeNames() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getAttributeNode(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

getAttributeNode(String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

getAttributeNodeNS(String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

getAttributeNodeNS(String, String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

getAttributeNS(String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

getAttributeNS(String, String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

getAttributes() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getAttributes() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

getAuthType() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getAutocompleterModel() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getAutowireStrategy() - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory

getBackgroundProcessName(ActionProxy) - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
Returns the name to associate the background process.
getBaseURI() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ActionErrorModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ActionMessageModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ActionModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.AnchorModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.AutocompleterModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.BeanModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.CallbackWriter

getBean() - Method in class org.apache.struts2.views.freemarker.tags.CheckboxListModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.CheckboxModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ComboBoxModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ComponentModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.DateModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.DateTimePickerModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.DivModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.DoubleSelectModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ElseIfModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ElseModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.FieldErrorModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.FileModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.FormModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.HeadModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.HiddenModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.I18nModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.IfModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.IncludeModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.InputTransferSelectModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.IteratorModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.LabelModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.OptGroupModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.OptionTransferSelectModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ParamModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.PasswordModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.PropertyModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.PushModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.RadioModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.ResetModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.SelectModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.SetModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getBean() - Method in class org.apache.struts2.views.freemarker.tags.SubmitModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.TabbedPanelModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.TagModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.TextAreaModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.TextFieldModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.TextModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.TokenModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.TreeModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.TreeNodeModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.UpDownSelectModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.URLModel

getBean() - Method in class org.apache.struts2.views.freemarker.tags.WebTableModel

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ActionTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.BeanTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ComponentTagSupport

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.DateTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ElseIfTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ElseTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.I18nTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.IfTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.IncludeTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.iterator.AppendIteratorTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.iterator.MergeIteratorTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.IteratorTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ParamTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.PropertyTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.PushTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.SetTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.TextTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.ActionErrorTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.ActionMessageTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.AnchorTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.CheckboxListTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.CheckboxTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.ComboBoxTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.ComponentTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.DebugTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.DivTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.DoubleSelectTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.FieldErrorTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.FileTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.FormTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.HeadTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.HiddenTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.LabelTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.OptGroupTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.PasswordTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.RadioTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.ResetTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.SelectTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.table.WebTableTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.TextareaTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.TextFieldTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.TokenTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.TreeNodeTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.jsp.URLTag

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.AbstractDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.ActionDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.ActionErrorDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.ActionMessageDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.AnchorDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.AutocompleterDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.BeanDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.CheckBoxDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.CheckBoxListDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.ComboBoxDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.ComponentDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.DateDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.DateTimePickerDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.DivDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.DoubleSelectDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.FieldErrorDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.FileDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.FormDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.HeadDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.HiddenDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.I18nDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.IncludeDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.InputTransferSelectDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.LabelDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.OptGroupDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.OptionTransferSelectDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.ParamDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.PasswordDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.PropertyDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.PushDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.RadioDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.ResetDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.SelectDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.SetDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.SubmitDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.TabbedPanelDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.TextAreaDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.TextDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.TextFieldDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.TokenDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.TreeDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.TreeNodeDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.UpDownSelectDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.URLDirective

getBean(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.velocity.components.WebTableDirective

getBeanInfo(Object) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Get's the java bean info for the given source.
getBeanMap(Object) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Creates a Map with read properties for the given source object.
getBeanName() - Method in class org.apache.struts2.views.velocity.components.AbstractDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.ActionDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.ActionErrorDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.ActionMessageDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.AnchorDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.AutocompleterDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.BeanDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.CheckBoxDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.CheckBoxListDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.ComboBoxDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.ComponentDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.DateDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.DateTimePickerDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.DivDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.DoubleSelectDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.FieldErrorDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.FileDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.FormDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.HeadDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.HiddenDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.I18nDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.IncludeDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.InputTransferSelectDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.LabelDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.OptGroupDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.OptionTransferSelectDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.ParamDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.PasswordDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.PropertyDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.PushDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.RadioDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.ResetDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.SelectDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.SetDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.SubmitDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.TabbedPanelDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.TextAreaDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.TextDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.TextFieldDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.TokenDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.TreeDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.TreeNodeDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.UpDownSelectDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.URLDirective

getBeanName() - Method in class org.apache.struts2.views.velocity.components.WebTableDirective

getBlankIconSrc() - Method in class org.apache.struts2.components.Tree

getBlankIconSrc() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getBlockedCollection() - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

getBody() - Method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

getBooleanProperty(String, Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

getBuffer() - Method in class org.apache.struts2.components.Include.PageOutputStream
Return all data that has been written to this OutputStream.
getBufferSize() - Method in class org.apache.struts2.dispatcher.StreamResult

getButtonCssClass() - Method in class org.apache.struts2.components.InputTransferSelect

getButtonCssClass() - Method in class org.apache.struts2.components.OptionTransferSelect

getButtonCssClass() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getButtonCssClass() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getButtonCssStyle() - Method in class org.apache.struts2.components.InputTransferSelect

getButtonCssStyle() - Method in class org.apache.struts2.components.OptionTransferSelect

getButtonCssStyle() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getButtonCssStyle() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getCalendarcss() - Method in class org.apache.struts2.components.Head

getCalendarcss() - Method in class org.apache.struts2.views.jsp.ui.HeadTag

getCanonicalName(String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest
Returns the canonical name of the given file.
getCellValue(WebTable, Object, int, int) - Method in class org.apache.struts2.components.table.renderer.AbstractCellRenderer
this is the method that subclasses need to implement to set their value.
getCellValue(WebTable, Object, int, int) - Method in class org.apache.struts2.components.table.renderer.BooleanCellRenderer

getCellValue(WebTable, Object, int, int) - Method in class org.apache.struts2.components.table.renderer.DateCellRenderer

getCellValue(WebTable, Object, int, int) - Method in class org.apache.struts2.components.table.renderer.DefaultCellRenderer

getCellValue(WebTable, Object, int, int) - Method in class org.apache.struts2.components.table.renderer.FixedTextCellRenderer

getCellValue(WebTable, Object, int, int) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer
should the link data be encodeed?
getCellValue(WebTable, Object, int, int) - Method in class org.apache.struts2.components.table.renderer.NumericCellRenderer

getChainHistory() - Static method in class com.opensymphony.xwork2.ActionChainResult
Get the XWork chain history.
getCharacterEncoding() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getCharSet() - Method in class org.apache.struts2.dispatcher.PlainTextResult
Set the character set
getCheckbox() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getCheckboxlist() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getChildAdapters() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode
Lazily initialize child childAdapters
getChildAdapters() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getChildAfter(Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getChildAfter(Node) - Method in interface org.apache.struts2.views.xslt.AdapterNode
The child node after the specified sibling
getChildAfter(Node) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getChildBefore(Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getChildBefore(Node) - Method in interface org.apache.struts2.views.xslt.AdapterNode
The child node before the specified sibling
getChildBefore(Node) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getChildBeforeOrAfter(Node, boolean) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getChildCollectionProperty() - Method in class org.apache.struts2.components.Tree

getChildCollectionProperty() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getChildNodes() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getChildNodes() - Method in class org.apache.struts2.views.xslt.BeanAdapter

getChildNodes() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getClass(Class, String, boolean) - Method in class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
Returns the class for the given field via generic type check.
getClasses() - Method in class com.opensymphony.xwork2.util.ResolverUtil
Provides access to the classes discovered so far.
getClassInstance(String) - Method in class com.opensymphony.xwork2.ObjectFactory
Utility method to obtain the class matched to className.
getClassInstance(String) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory

getClassLoader() - Method in class com.opensymphony.xwork2.util.ResolverUtil
Returns the classloader that will be used for scanning for classes.
getClassName() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

getClassName() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

getClassName() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

getClassProperty(Map) - Method in class com.opensymphony.xwork2.util.XWorkConverter

getClazz() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

getColumn(Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the column number of an element (SAX flavor)
getColumn(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the column number of an element (DOM flavor)
getColumn(int) - Method in class org.apache.struts2.components.table.WebTable

getColumnClass(int) - Method in class org.apache.struts2.components.table.AbstractFilterModel

getColumnCount() - Method in class org.apache.struts2.components.table.AbstractFilterModel

getColumnCount() - Method in class org.apache.struts2.components.table.WebTable

getColumnDisplayName(int) - Method in class org.apache.struts2.components.table.WebTable

getColumnName(int) - Method in class org.apache.struts2.components.table.AbstractFilterModel

getColumnNumber() - Method in interface com.opensymphony.xwork2.util.location.Location
Get the column number of this location
getColumnNumber() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Get the column number of this location
getColumnRenderer(int) - Method in class org.apache.struts2.components.table.WebTable

getColumns() - Method in class org.apache.struts2.components.table.WebTable

getComboBox() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getCommentLines() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Returns the comment lines that have been read for the last property.
getComparator(String, boolean) - Method in class org.apache.struts2.util.Sorter

getComplexParams(Map) - Method in class org.apache.struts2.views.freemarker.tags.TagModel

getComponent() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getComponent() - Method in class org.apache.struts2.views.jsp.ComponentTagSupport

getComponentName() - Method in class org.apache.struts2.components.Autocompleter

getComponentName() - Method in class org.apache.struts2.components.Component
Get's the name of this component.
getComponentName() - Method in class org.apache.struts2.components.TabbedPanel

getComponentStack() - Method in class org.apache.struts2.components.Component
Get's the component stack of this component.
getConfig() - Method in interface com.opensymphony.xwork2.ActionProxy

getConfig() - Method in class com.opensymphony.xwork2.DefaultActionProxy

getConfig() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

getConfiguration() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Get the current XWork configuration object.
getConfiguration(ServletContext) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager

getConfiguration() - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
This method is called from FreemarkerResult.doExecute(String, ActionInvocation) to obtain the FreeMarker configuration object that this result will use for template loading.
getConfiguration() - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
This method is called from PortletFreemarkerResult.doExecute(String, ActionInvocation) to obtain the FreeMarker configuration object that this result will use for template loading.
getConfigurationManager() - Method in class org.apache.struts2.dispatcher.Dispatcher
Expose the ConfigurationManager instance.
getConfigurationProviders() - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Get the current list of ConfigurationProviders.
getConfigurationUrls(String) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

getConfigurationUrls(String) - Method in class org.apache.struts2.config.StrutsXmlConfigurationProvider
Look for the configuration file on the classpath and in the file system
getConstructionContext(Object) - Method in class com.opensymphony.xwork2.inject.InternalContext

getConstructor(Class<T>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl
Gets a constructor function for a given implementation class.
getContainer() - Method in interface com.opensymphony.xwork2.config.Configuration

getContainer() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

getContainer() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

getContainer() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the Container.
getContainer() - Method in class com.opensymphony.xwork2.inject.ExternalContext

getContainer() - Method in class com.opensymphony.xwork2.inject.InternalContext

getContainer() - Method in class org.apache.struts2.dispatcher.Dispatcher
Expose the dependency injection container.
getContainerImpl() - Method in class com.opensymphony.xwork2.inject.InternalContext

getContent() - Method in class org.apache.struts2.components.Include.PageResponse
Return the content buffered inside the Include.PageOutputStream.
getContent() - Method in class org.apache.struts2.util.TabbedPane

getContentDisposition() - Method in class org.apache.struts2.dispatcher.StreamResult

getContentLength() - Method in class org.apache.struts2.dispatcher.StreamResult

getContentLength() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getContentType(String) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Determine the content type for the resource name.
getContentType(String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getContentType(String) - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns the content type(s) of the file(s) associated with the specified field name (as supplied by the client browser), or null if no files are associated with the given field name.
getContentType() - Method in class org.apache.struts2.dispatcher.StreamResult

getContentType(String) - Method in class org.apache.struts2.dispatcher.VelocityResult
Retrieve the content type for this template.
getContentType(String) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult
Retrieve the content type for this template.
getContentType() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getContentType() - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
allow parameterization of the contentType the default being text/html
getContentType() - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
allow parameterization of the contentType the default being text/html
getContentTypes(String) - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Get an array of content encoding for the specified input field name or null if no content type was specified.
getContext() - Static method in class com.opensymphony.xwork2.ActionContext
Returns the ActionContext specific to the current thread.
getContext() - Method in class com.opensymphony.xwork2.util.OgnlValueStack

getContext() - Method in interface com.opensymphony.xwork2.util.ValueStack

getContext() - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

getContext() - Static method in class org.apache.struts2.portlet.context.PortletActionContext

getContext() - Method in class org.apache.struts2.util.StrutsUtil

getContextMap() - Method in class com.opensymphony.xwork2.ActionContext
Gets the context map.
getContextPath() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getContextRelativePath(ServletRequest, String) - Static method in class org.apache.struts2.components.Include

getConversionErrorMessage(String, ValueStack) - Static method in class com.opensymphony.xwork2.util.XWorkConverter

getConversionErrors() - Method in class com.opensymphony.xwork2.ActionContext
Gets the map of conversion errors which occurred when executing the action.
getConverter(Class, String) - Method in class com.opensymphony.xwork2.util.XWorkConverter

getCookies() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getCount() - Method in class org.apache.struts2.views.jsp.IteratorStatus

getCurrent() - Method in class org.apache.struts2.util.Counter

getCurrentPropertyPath(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState
Gets the current property path but not completely.
getCurrentReference() - Method in class com.opensymphony.xwork2.inject.ConstructionContext

getData() - Method in class org.apache.struts2.util.StrutsUtil.ResponseWrapper

getData() - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

getData() - Method in class org.apache.struts2.views.xslt.SimpleTextNode

getDate() - Method in class org.apache.struts2.util.DateFormatter

getDate() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getDateHeader(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getDateTimePicker() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getDefaultActionForMode() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the default action mapping for the current mode.
getDefaultActionRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

getDefaultClassRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

getDefaultExtension() - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper
Returns null if no extension is specified.
getDefaultInstance() - Static method in class org.apache.struts2.config.Settings
Creates a default Settings object.
getDefaultInterceptorRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

getDefaultMessage(String, Locale, ValueStack, Object[], String) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Gets the default message.
getDefaultMessage() - Method in interface com.opensymphony.xwork2.validator.Validator

getDefaultMessage() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

getDefaultMessage() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

getDefaultOpenTemplate() - Method in class org.apache.struts2.components.Anchor

getDefaultOpenTemplate() - Method in class org.apache.struts2.components.ClosingUIBean

getDefaultOpenTemplate() - Method in class org.apache.struts2.components.Div

getDefaultOpenTemplate() - Method in class org.apache.struts2.components.Form

getDefaultOpenTemplate() - Method in class org.apache.struts2.components.TabbedPanel

getDefaultOpenTemplate() - Method in class org.apache.struts2.components.Tree

getDefaultOpenTemplate() - Method in class org.apache.struts2.components.TreeNode

getDefaultResultParam() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

getDefaultResultType() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
Returns the default result type for this package.
getDefaultTemplate() - Method in class org.apache.struts2.components.ActionError

getDefaultTemplate() - Method in class org.apache.struts2.components.ActionMessage

getDefaultTemplate() - Method in class org.apache.struts2.components.Anchor

getDefaultTemplate() - Method in class org.apache.struts2.components.Autocompleter

getDefaultTemplate() - Method in class org.apache.struts2.components.Checkbox

getDefaultTemplate() - Method in class org.apache.struts2.components.CheckboxList

getDefaultTemplate() - Method in class org.apache.struts2.components.ComboBox

getDefaultTemplate() - Method in class org.apache.struts2.components.DateTimePicker

getDefaultTemplate() - Method in class org.apache.struts2.components.Debug

getDefaultTemplate() - Method in class org.apache.struts2.components.Div

getDefaultTemplate() - Method in class org.apache.struts2.components.DoubleSelect

getDefaultTemplate() - Method in class org.apache.struts2.components.FieldError

getDefaultTemplate() - Method in class org.apache.struts2.components.File

getDefaultTemplate() - Method in class org.apache.struts2.components.Form

getDefaultTemplate() - Method in class org.apache.struts2.components.GenericUIBean

getDefaultTemplate() - Method in class org.apache.struts2.components.Head

getDefaultTemplate() - Method in class org.apache.struts2.components.Hidden

getDefaultTemplate() - Method in class org.apache.struts2.components.InputTransferSelect

getDefaultTemplate() - Method in class org.apache.struts2.components.Label

getDefaultTemplate() - Method in class org.apache.struts2.components.OptionTransferSelect

getDefaultTemplate() - Method in class org.apache.struts2.components.Password

getDefaultTemplate() - Method in class org.apache.struts2.components.Radio

getDefaultTemplate() - Method in class org.apache.struts2.components.Reset

getDefaultTemplate() - Method in class org.apache.struts2.components.Select

getDefaultTemplate() - Method in class org.apache.struts2.components.Submit

getDefaultTemplate() - Method in class org.apache.struts2.components.TabbedPanel

getDefaultTemplate() - Method in class org.apache.struts2.components.table.WebTable

getDefaultTemplate() - Method in class org.apache.struts2.components.TextArea

getDefaultTemplate() - Method in class org.apache.struts2.components.TextField

getDefaultTemplate() - Method in class org.apache.struts2.components.Token

getDefaultTemplate() - Method in class org.apache.struts2.components.Tree

getDefaultTemplate() - Method in class org.apache.struts2.components.TreeNode

getDefaultTemplate() - Method in class org.apache.struts2.components.UIBean
A contract that requires each concrete UI Tag to specify which template should be used as a default.
getDefaultTemplate() - Method in class org.apache.struts2.components.UpDownSelect

getDelimitedValues(String) - Static method in class org.apache.struts2.interceptor.FileUploadInterceptor

getDepth(String, Throwable) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Return the depth to the superclass matching.
getDepth(String, Class, int) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

getDescending() - Method in class org.apache.struts2.util.Sorter

getDescending(String) - Method in class org.apache.struts2.util.Sorter

getDescription() - Method in interface com.opensymphony.xwork2.util.location.Location
Get the description of this location
getDescription() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Get the description of this location
getDir() - Method in class org.apache.struts2.components.template.Template

getDisplayName() - Method in class org.apache.struts2.components.table.WebTableColumn

getDiv() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getDoctype() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Return the newly built Document.
getDocumentElement() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getDocumentURI() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getDomConfig() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getDOMSourceForStack(Object) - Method in class org.apache.struts2.views.xslt.XSLTResult

getDoubleCssClass() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleCssClass() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleCssStyle() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleCssStyle() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleDisabled() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleDisabled() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleEmptyOption() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleEmptyOption() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleHeaderKey() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleHeaderKey() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleHeaderValue() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleHeaderValue() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleId() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleId() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleList() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleList() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleListKey() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleListKey() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleListValue() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleListValue() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleMultiple() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleMultiple() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleName() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleName() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnblur() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnblur() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnchange() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnchange() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnclick() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnclick() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOndblclick() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOndblclick() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnfocus() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnfocus() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnkeydown() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnkeydown() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnkeypress() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnkeypress() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnkeyup() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnkeyup() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnmousedown() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnmousedown() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnmousemove() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnmousemove() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnmouseout() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnmouseout() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnmouseover() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnmouseover() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnmouseup() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnmouseup() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleOnselect() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleOnselect() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleselect() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getDoubleSize() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleSize() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDoubleValue() - Method in class org.apache.struts2.components.DoubleListUIBean

getDoubleValue() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getDownLabel() - Method in class org.apache.struts2.components.InputTransferSelect

getDownLabel() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getDtdMappings() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Returns an unmodifiable map of DTD mappings
getElementById(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getElementClass(Class, String, Object) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

getElementClass() - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

getElementClass(Class, String, Object) - Method in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer
Determines the key class by looking for the value of Element_${property} in the properties file for the given class.
getElementClass(Class, String, Object) - Method in class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
Determines the element class by looking for the value of @Element annotation for the given class.
getElementClass(Class, String, Object) - Method in interface com.opensymphony.xwork2.util.ObjectTypeDeterminer

getElementsByTagName(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getElementsByTagName(String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

getElementsByTagName(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getElementsByTagNameNS(String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getElementsByTagNameNS(String, String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

getElementsByTagNameNS(String, String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getElse() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getElseif() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getEncoding() - Static method in class org.apache.struts2.components.Include
Get the encoding specified by the property 'struts.i18n.encoding' in struts.properties, or return the default platform encoding if not specified.
getEncoding(String) - Method in class org.apache.struts2.dispatcher.VelocityResult
Retrieve the encoding for this template.
getEncoding(String) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult
Retrieve the encoding for this template.
getEncodingFromConfiguration() - Static method in class org.apache.struts2.views.util.UrlHelper

getErrorMessages() - Method in class com.opensymphony.xwork2.ActionSupport
Deprecated. Use ActionSupport.getActionErrors().
getErrors() - Method in class com.opensymphony.xwork2.ActionSupport
Deprecated. Use ActionSupport.getFieldErrors().
getErrors() - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getErrors() - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns a list of error messages that may have occurred while processing the request.
getErrors() - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Returns a collection of any errors generated when parsing the multipart request.
getException() - Method in class com.opensymphony.xwork2.interceptor.ExceptionHolder

getException() - Method in class org.apache.struts2.interceptor.BackgroundProcess
Gets the exception if any was thrown during the execution of the background process.
getExceptionClassName() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

getExceptionMappings() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

getExceptionStack() - Method in class com.opensymphony.xwork2.interceptor.ExceptionHolder

getExcludeMethodsSet() - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

getExcludeParamsSet() - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Gets a set of regular expressions of parameters to remove from the parameter map
getExcludes() - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor

getExecuteResult() - Method in interface com.opensymphony.xwork2.ActionProxy

getExecuteResult() - Method in class com.opensymphony.xwork2.DefaultActionProxy

getExecuteResult() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

getExludingPattern() - Method in class org.apache.struts2.views.xslt.XSLTResult

getExpandIconSrcMinus() - Method in class org.apache.struts2.components.Tree

getExpandIconSrcMinus() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getExpandIconSrcPlus() - Method in class org.apache.struts2.components.Tree

getExpandIconSrcPlus() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getExpectedFoo() - Method in class com.opensymphony.xwork2.mock.MockInterceptor

getExposedValue() - Method in class org.apache.struts2.views.xslt.XSLTResult

getExpression() - Method in class com.opensymphony.xwork2.validator.validators.ExpressionValidator

getExpression() - Method in class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

getExpression() - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator

getExprOverrides() - Method in class com.opensymphony.xwork2.util.OgnlValueStack

getExprOverrides() - Method in interface com.opensymphony.xwork2.util.ValueStack

getExternalContext() - Method in class com.opensymphony.xwork2.inject.InternalContext

getExtraParameters() - Method in interface org.apache.struts2.components.URL.ExtraParameterProvider

getFactory(Key<T>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

getFactory() - Static method in class com.opensymphony.xwork2.util.ValueStackFactory

getFeature(String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getFielderror() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getFieldErrorFieldNames() - Method in class org.apache.struts2.components.FieldError

getFieldErrors() - Method in class com.opensymphony.xwork2.ActionSupport

getFieldErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Get the field specific errors associated with this action.
getFieldErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

getFieldErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getFieldErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

getFieldName() - Method in interface com.opensymphony.xwork2.validator.FieldValidator

getFieldName() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Sets the field name for this validator rule.
getFieldName() - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription
Returns the field name to create the validation rule for.
getFieldName() - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Returns the field name to create the validation rule for.
getFieldName() - Method in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

getFieldValue(String, Object) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport
Return the field value named name from object, object should have the appropriate getter/setter.
getFile() - Method in class com.opensymphony.xwork2.util.FileManager.FileRevision

getFile(String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getFile(String) - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns a File object for the filename specified or null if no files are associated with the given field name.
getFile() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getFileNames(String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getFileNames(String) - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns a String[] of file names for files associated with the specified input field name
getFileNames(String) - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Get a String array of the file names for uploaded files
getFileParameterNames() - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getFileParameterNames() - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns an enumeration of the parameter names for uploaded files
getFileParameterNames() - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Get an enumeration of the parameter names for uploaded files
getFiles(String) - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Get a File[] for the given input field name.
getFilesystemName(String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getFilesystemName(String) - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns the file system name(s) of files associated with the given field name or null if no files are associated with the given field name.
getFileSystemNames(String) - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Get the filename(s) of the file(s) uploaded for the given input field name.
getFilterConfig() - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Expose the FilterConfig instance.
getFilterConfig() - Method in class org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61
This method is required by Weblogic 6.1 SP4 because they defined this as a required method just before the Servlet 2.3 specification was finalized.
getFinalTemplateName(Template) - Method in class org.apache.struts2.components.template.BaseTemplateEngine

getFirst() - Method in class org.apache.struts2.util.Counter

getFirstChild() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getFirstChild() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getFlush() - Method in class org.apache.struts2.views.jsp.ActionTag

getFoo() - Method in class com.opensymphony.xwork2.mock.MockInterceptor

getForm() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getFormat() - Method in class org.apache.struts2.components.Date

getFormattedDate() - Method in class org.apache.struts2.util.DateFormatter

getFormattedRow(int) - Method in class org.apache.struts2.components.table.WebTable

getFormName() - Method in class org.apache.struts2.components.DoubleListUIBean

getFormName() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

getFreemarkerModels(ValueStack, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.DefaultTagLibrary

getFreemarkerModels(ValueStack, HttpServletRequest, HttpServletResponse) - Method in interface org.apache.struts2.views.TagLibrary
Gets a Java object that contains getters for the tag library's Freemarker models.
getFullDefaultActionRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the default action-ref name.
getFullDefaultInterceptorRef() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the default interceptor-ref name.
getFullDefaultResultType() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
Returns the default result type for this package.
getFullFieldName(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getFullFieldName(String) - Method in interface com.opensymphony.xwork2.validator.ValidatorContext
Translates a simple field name into a full field name in OGNL syntax.
getFullFieldName(String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext
Translates a simple field name into a full field name in Ognl syntax
getFullPropertyPath(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

getFullQualifiedClassName() - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Returns the fullQualifiedClassName attribute is used to create the special conversion.properties file name.
getGlobalExceptionMappingConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the ExceptionMappingConfigs local to this package
getGlobalResultConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the global ResultConfigs local to this package
getGridIconSrcC() - Method in class org.apache.struts2.components.Tree

getGridIconSrcC() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getGridIconSrcL() - Method in class org.apache.struts2.components.Tree

getGridIconSrcL() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getGridIconSrcP() - Method in class org.apache.struts2.components.Tree

getGridIconSrcP() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getGridIconSrcV() - Method in class org.apache.struts2.components.Tree

getGridIconSrcV() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getGridIconSrcX() - Method in class org.apache.struts2.components.Tree

getGridIconSrcX() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getGridIconSrcY() - Method in class org.apache.struts2.components.Tree

getGridIconSrcY() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getHasNext() - Method in class org.apache.struts2.util.IteratorGenerator

getHead() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getHeader(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getHeaderKey() - Method in class org.apache.struts2.components.InputTransferSelect

getHeaderKey() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getHeaderNames() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getHeaders() - Method in class org.apache.struts2.dispatcher.HttpHeaderResult
Returns a Map of all HTTP headers.
getHeaders(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getHeaderValue() - Method in class org.apache.struts2.components.InputTransferSelect

getHeaderValue() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getHidden() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getHref() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getI18n() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getIconHeight() - Method in class org.apache.struts2.components.Tree

getIconHeight() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getIconWidth() - Method in class org.apache.struts2.components.Tree

getIconWidth() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getId() - Method in class org.apache.struts2.components.Component
Get's the id for referencing element.
getIf() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getImpl(String) - Method in class org.apache.struts2.config.DefaultSettings

getImpl(String) - Method in class org.apache.struts2.config.DelegatingSettings

getImpl(String) - Method in class org.apache.struts2.config.PropertiesSettings
Gets a property from the properties file.
getImpl(String) - Method in class org.apache.struts2.config.Settings
Implements the Settings.get(String) method.
getImplementation() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getInclude() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getIncludeMethodsSet() - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

getIncludes() - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor

getIncludesExcludesMap() - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

getIndex() - Method in class org.apache.struts2.views.jsp.IteratorStatus

getInputEncoding() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getInputName() - Method in class org.apache.struts2.dispatcher.StreamResult

getInputStream() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getInputtransferselect() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getInstance(Class<T>, String) - Method in interface com.opensymphony.xwork2.inject.Container
Gets an instance of the given dependency which was declared in ContainerBuilder.
getInstance(Class<T>) - Method in interface com.opensymphony.xwork2.inject.Container
Convenience method. Equivalent to getInstance(type, DEFAULT_NAME).
getInstance(Class<T>, String, InternalContext) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

getInstance(Class<T>, InternalContext) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

getInstance(Class<T>, String) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

getInstance(Class<T>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

getInstance() - Static method in class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue
Gets instance.
getInstance() - Static method in class com.opensymphony.xwork2.TextProviderFactory

getInstance(Class, LocaleProvider) - Static method in class com.opensymphony.xwork2.TextProviderFactory

getInstance(ResourceBundle, LocaleProvider) - Static method in class com.opensymphony.xwork2.TextProviderFactory

getInstance() - Static method in class com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory

getInstance() - Static method in class com.opensymphony.xwork2.util.XWorkConverter

getInstance() - Static method in class com.opensymphony.xwork2.validator.ActionValidatorManagerFactory

getInstance() - Static method in class org.apache.struts2.config.ServletContextSingleton
Answers the singleton.
getInstance() - Static method in class org.apache.struts2.config.Settings
Provides the Settings object.
getInstance() - Static method in class org.apache.struts2.dispatcher.Dispatcher
Provide the dispatcher instance for the current thread.
getInstance() - Static method in class org.apache.struts2.views.jsp.ui.OgnlTool

getInstanceNames(Class<?>) - Method in interface com.opensymphony.xwork2.inject.Container
Gets a set of all registered names for the given type
getInstanceNames(Class<?>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

getInterceptor() - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping

getInterceptorConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the InterceptorConfigs and InterceptorStackConfigs local to this package
getInterceptors() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

getInterceptors() - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

getInterval() - Method in class org.apache.struts2.util.Counter

getIntHeader(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getInvocation() - Method in interface com.opensymphony.xwork2.ActionProxy

getInvocation() - Method in class com.opensymphony.xwork2.DefaultActionProxy

getInvocation() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

getInvocation() - Method in class org.apache.struts2.interceptor.BackgroundProcess
Retrieves the action invocation.
getInvocationContext() - Method in interface com.opensymphony.xwork2.ActionInvocation
Gets the ActionContext associated with this ActionInvocation.
getInvocationContext() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

getInvocationContext() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

getInvocationMap() - Static method in class org.apache.struts2.util.InvocationSessionStore

getIsSelected() - Method in class org.apache.struts2.util.ListEntry

getIterator(Object) - Method in class org.apache.struts2.util.IteratorFilterSupport

getIterator() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getKey() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

getKey(Map, Object) - Method in class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

getKey() - Method in class org.apache.struts2.components.Debug.DebugMapEntry

getKey(ActionInvocation) - Method in class org.apache.struts2.interceptor.ScopeInterceptor

getKey() - Method in class org.apache.struts2.util.ListEntry

getKeyClass(Class, String) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

getKeyClass() - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

getKeyClass(Class, String) - Method in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer
Determines the key class by looking for the value of Key_${property} in the properties file for the given class.
getKeyClass(Class, String) - Method in class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
Determines the key class by looking for the value of @Key annotation for the given class.
getKeyClass(Class, String) - Method in interface com.opensymphony.xwork2.util.ObjectTypeDeterminer

getKeyProperty(Class, String) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

getKeyProperty() - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

getKeyProperty(Class, String) - Method in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer
Determines the String key property for a Collection by getting it from the conversion properties file using the KeyProperty_ prefix.
getKeyProperty(Class, String) - Method in class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
Determines the key property for a Collection by getting it from the @KeyProperty annotation.
getKeyProperty(Class, String) - Method in interface com.opensymphony.xwork2.util.ObjectTypeDeterminer

getLabel() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getLast() - Method in class org.apache.struts2.util.Counter

getLastBeanClassAccessed(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

getLastBeanPropertyAccessed(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

getLastChild() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getLastChild() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getLastClassAccessed() - Method in class com.opensymphony.xwork2.util.ObjectProxy

getLastFinalLocation() - Method in class org.apache.struts2.dispatcher.StrutsResultSupport
Returns the last parsed and encoded location value
getLastModified() - Method in class com.opensymphony.xwork2.util.FileManager.FileRevision

getLastPropertyAccessed() - Method in class com.opensymphony.xwork2.util.ObjectProxy

getLeftDownLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getLeftDownLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getLeftTitle() - Method in class org.apache.struts2.components.InputTransferSelect

getLeftTitle() - Method in class org.apache.struts2.components.OptionTransferSelect

getLeftTitle() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getLeftTitle() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getLeftUpLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getLeftUpLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getLength() - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

getLength() - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

getLength() - Method in class org.apache.struts2.views.xslt.SimpleNodeList

getLength() - Method in class org.apache.struts2.views.xslt.SimpleTextNode

getLine(Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the line number of an element (SAX flavor)
getLine(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the line number of an element (DOM flavor)
getLineNumber() - Method in interface com.opensymphony.xwork2.util.location.Location
Get the line number of this location
getLineNumber() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Get the line number of this location
getList() - Method in class org.apache.struts2.util.SortIteratorFilter

getLoadedFileNames() - Method in interface com.opensymphony.xwork2.config.Configuration

getLoadedFileNames() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

getLoadedFileNames() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

getLoadMinimumCount() - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

getLocalAddr() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getLocale() - Method in class com.opensymphony.xwork2.ActionContext
Gets the Locale of the current action.
getLocale() - Method in class com.opensymphony.xwork2.ActionSupport

getLocale() - Method in interface com.opensymphony.xwork2.LocaleProvider

getLocale() - Method in class com.opensymphony.xwork2.TextProviderSupport
Get's the locale from the localeProvider.
getLocale(Map) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

getLocale() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.ActionContextLocaleProvider

getLocale() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getLocale() - Static method in class org.apache.struts2.config.Settings
Provides the Struts default locale.
getLocale() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getLocales() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getLocalName() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getLocalName() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getLocalName() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

getLocalPort() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getLocation() - Method in interface com.opensymphony.xwork2.util.location.Locatable
Get the location of this object
getLocation() - Method in class com.opensymphony.xwork2.util.location.LocatableProperties

getLocation() - Method in class com.opensymphony.xwork2.util.location.Located
Get the location of this object
getLocation(Attributes, String) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the Location of an element (SAX flavor).
getLocation(Element, String) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the Location of an element (DOM flavor).
getLocation(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Same as getLocation(elem, null).
getLocation(Object) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Get the location of an object.
getLocation(Object, String) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Get the location of an object.
getLocation(Object, String) - Method in interface com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder
Get the location of an object
getLocation() - Method in exception com.opensymphony.xwork2.XWorkException
Gets the location of the error, if available
getLocation(String) - Static method in class org.apache.struts2.config.Settings
Provides the Location of a setting.
getLocation(Object) - Method in class org.apache.struts2.dispatcher.Dispatcher.Locator

getLocation() - Method in class org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction
Get the location of the view.
getLocationImpl(String) - Method in class org.apache.struts2.config.PropertiesSettings
Gets the location of a property from the properties file.
getLocationImpl(String) - Method in class org.apache.struts2.config.Settings
Implements the Settings.getLocation(String) method.
getLocationObject(Element) - Static method in class com.opensymphony.xwork2.util.DomHelper

getLocationString(Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the location of an element (SAX flavor).
getLocationString(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the location of an element that has been processed by this pipe (DOM flavor).
getLogCategory() - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

getLogCategory() - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor

getLoggerToUse() - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Get's the logger to use.
getLogLevel() - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

getLogLevel() - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor

getMap() - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

getMapping(HttpServletRequest, ConfigurationManager) - Method in interface org.apache.struts2.dispatcher.mapper.ActionMapper
Expose the ActionMapping for the current request
getMapping(HttpServletRequest, ConfigurationManager) - Method in class org.apache.struts2.dispatcher.mapper.CompositeActionMapper

getMapping(HttpServletRequest, ConfigurationManager) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

getMapping(HttpServletRequest, ConfigurationManager) - Method in class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

getMapping(HttpServletRequest, ConfigurationManager) - Method in class org.apache.struts2.dispatcher.mapper.RestfulActionMapper

getMatchingPattern() - Method in class org.apache.struts2.views.xslt.XSLTResult

getMax() - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

getMax() - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

getMaxComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator

getMaxComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

getMaxComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

getMaxExclusive() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

getMaxInclusive() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

getMaxLength() - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

getMember() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the field, method or constructor which is being injected.
getMember() - Method in class com.opensymphony.xwork2.inject.ExternalContext

getMessage(String, Locale, String, ValueStack, Object[]) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Gets the message from the named resource bundle.
getMessage(Object) - Method in interface com.opensymphony.xwork2.validator.Validator

getMessage(Object) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

getMessageKey() - Method in interface com.opensymphony.xwork2.validator.Validator

getMessageKey() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

getMessageKey() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

getMethod() - Method in interface com.opensymphony.xwork2.ActionProxy
Returns the method to execute, or null if no method has been specified (meaning "execute" will be invoked)
getMethod() - Method in class com.opensymphony.xwork2.DefaultActionProxy

getMethod() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

getMethod() - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

getMethod() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getMethodName() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig
Returns name of the action method
getMin() - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

getMin() - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

getMinComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator

getMinComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

getMinComparatorValue() - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

getMinExclusive() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

getMinInclusive() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

getMinLength() - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

getMinTime() - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
Get the min time for this profiling, it searches for a System property 'xwork.profile.mintime' and default to 0.
getModel() - Method in interface com.opensymphony.xwork2.ModelDriven

getModel() - Method in class org.apache.struts2.components.table.AbstractFilterModel

getModel() - Method in class org.apache.struts2.components.table.WebTable

getModelName() - Method in class org.apache.struts2.components.table.WebTable

getModeNamespaceMap() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the namespace to mode mappings.
getMoveDownLabel() - Method in class org.apache.struts2.components.UpDownSelect

getMoveDownLabel() - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

getMoveUpLabel() - Method in class org.apache.struts2.components.UpDownSelect

getMoveUpLabel() - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

getMultiple() - Method in class org.apache.struts2.components.InputTransferSelect

getMultiple() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getName() - Method in class com.opensymphony.xwork2.ActionContext
Gets the name of the current Action.
getName() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

getName() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

getName() - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping

getName() - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

getName() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

getName() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

getName() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

getName() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the name of the injection specified by Inject.value().
getName() - Method in class com.opensymphony.xwork2.inject.ExternalContext

getName() - Method in class com.opensymphony.xwork2.inject.Key

getName() - Method in class org.apache.struts2.components.Date

getName() - Method in class org.apache.struts2.components.table.WebTableColumn

getName() - Method in class org.apache.struts2.components.template.Template

getName() - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

getName() - Method in class org.apache.struts2.views.velocity.components.AbstractDirective

getName() - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

getNamedItem(String) - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

getNamedItemNS(String, String) - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

getNames() - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

getNamespace() - Method in interface com.opensymphony.xwork2.ActionProxy

getNamespace() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

getNamespace() - Method in class com.opensymphony.xwork2.DefaultActionProxy

getNamespace() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

getNamespace() - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

getNamespace(String) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Get the namespace part of the action path.
getNamespaceURI() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getNamespaceURI() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

getNewBackgroundProcess(String, ActionInvocation, int) - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
Creates a new background process
getNext() - Method in class org.apache.struts2.util.Counter

getNext() - Method in class org.apache.struts2.util.IteratorGenerator

getNextSibling() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getNodeIdProperty() - Method in class org.apache.struts2.components.Tree

getNodeIdProperty() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getNodeName() - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

getNodeName() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getNodeName() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

getNodeName() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getNodeName() - Method in class org.apache.struts2.views.xslt.SimpleTextNode

getNodeTitleProperty() - Method in class org.apache.struts2.components.Tree

getNodeTitleProperty() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getNodeType() - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

getNodeType() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getNodeType() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

getNodeType() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getNodeType() - Method in class org.apache.struts2.views.xslt.SimpleTextNode

getNodeValue() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getNodeValue() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

getNodeValue() - Method in class org.apache.struts2.views.xslt.SimpleTextNode

getNumberOfVisibleColumns() - Method in class org.apache.struts2.components.table.WebTable

getObjectFactory() - Static method in class com.opensymphony.xwork2.ObjectFactory

getObjectFactory() - Method in class org.apache.struts2.config.MethodConfigurationProvider
Provides ObjectFactory property.
getObjectTypeDeterminer() - Method in class com.opensymphony.xwork2.util.XWorkConverter

getObjectWrapper() - Method in class org.apache.struts2.views.freemarker.FreemarkerManager

getObjectWrapper() - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
This method is called from FreemarkerResult.doExecute(String, ActionInvocation) to obtain the FreeMarker object wrapper object that this result will use for adapting objects into template models.
getObjectWrapper() - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
This method is called from PortletFreemarkerResult.doExecute(String, ActionInvocation) to obtain the FreeMarker object wrapper object that this result will use for adapting objects into template models.
getOffset() - Method in class org.apache.struts2.components.table.WebTableColumn

getOperationModel() - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

getOptgroup() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getOptiontransferselect() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getOrderedComparator() - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Gets an instance of the comparator to use for the ordered sorting.
getOriginal() - Method in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping
Gets the original wildcard pattern.
getOutputStream() - Method in class org.apache.struts2.components.Include.PageResponse
Return instance of Include.PageOutputStream allowing all data written to stream to be stored in temporary buffer.
getOutputStream() - Method in class org.apache.struts2.util.StrutsUtil.ResponseWrapper

getOverrideExpr(ActionInvocation, Object) - Method in class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

getOverrideExpr(ActionInvocation, Object) - Method in class org.apache.struts2.interceptor.StrutsConversionErrorInterceptor

getOwnerDocument() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getOwnerElement() - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

getPackageConfig(String) - Method in interface com.opensymphony.xwork2.config.Configuration

getPackageConfig(String) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

getPackageConfig(String) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

getPackageConfigNames() - Method in interface com.opensymphony.xwork2.config.Configuration

getPackageConfigNames() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

getPackageConfigNames() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

getPackageConfigs() - Method in interface com.opensymphony.xwork2.config.Configuration

getPackageConfigs() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

getPackageConfigs() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

getPackageName() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

getPageContext() - Static method in class org.apache.struts2.ServletActionContext
Returns the HTTP page context.
getPageContext() - Method in class org.apache.struts2.util.AttributeMap

getParam() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getParameter(String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getParameter(String) - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns the specified request parameter.
getParameter(String) - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

getParameter(String) - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor
Gets a single string from the request parameters
getParameter(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getParameterLogMap(Map) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

getParameterMap() - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

getParameterMap(PortletRequest) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Returns a Map of all request parameters.
getParameterMap() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getParameterNames() - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getParameterNames() - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns an enumeration of String parameter names.
getParameterNames() - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

getParameterNames() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getParameters() - Method in class com.opensymphony.xwork2.ActionContext
Returns a Map of the HttpServletRequest parameters when in a servlet environment or a generic Map of parameters otherwise.
getParameters(Member, InternalContext, ContainerImpl.ParameterInjector[]) - Static method in class com.opensymphony.xwork2.inject.ContainerImpl

getParameters() - Method in class org.apache.struts2.components.Component
Get's the parameters.
getParameters() - Method in class org.apache.struts2.components.template.TemplateRenderingContext

getParametersInjectors(M, Annotation[][], Class[], String) - Method in class com.opensymphony.xwork2.inject.ContainerImpl
Gets parameter injectors.
getParameterValues(String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

getParameterValues(String) - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest
Returns a list of all parameter values associated with a parameter name.
getParameterValues(String) - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

getParameterValues(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getParams() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

getParams() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

getParams() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

getParams() - Method in interface com.opensymphony.xwork2.config.entities.Parameterizable

getParams() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

getParams() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

getParams(Element) - Static method in class com.opensymphony.xwork2.config.providers.XmlHelper

getParams() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

getParams() - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

getParent() - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

getParent() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getParent() - Method in interface org.apache.struts2.views.xslt.AdapterNode
The parent adapter node of this node.
getParentNode() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getParents() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

getParse() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

getParseStringAsXML() - Method in class org.apache.struts2.views.xslt.StringAdapter
Is this StringAdapter to interpret its string values as containing XML Text?
getPassword() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getPathInfo() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getPathTranslated() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getPattern() - Method in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping
Gets the compiled wildcard pattern.
getPhase() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the phase that the portlet is executing in.
getPortletConfig() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the PortletConfig of the portlet that is executing.
getPortletMode(RenderRequest, String) - Static method in class org.apache.struts2.portlet.util.PortletUrlHelper
Convert the given String to a PortletMode object.
getPortletNamespace() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the action namespace of the portlet.
getPossibleTemplates(TemplateEngine) - Method in class org.apache.struts2.components.template.Template

getPrefix() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getPrefix() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

getPrefixedMethod(String[], String, Object) - Static method in class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
This method returns a Method in action.
getPrevious() - Method in class org.apache.struts2.util.Counter

getPreviousSibling() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getPrintable(long) - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean
Get a formatted string representing all the methods that took longer than a specified time.
getPrintable(String, long) - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

getProfiledObject(Class, Object) - Static method in class com.opensymphony.xwork2.util.profiling.ObjectProfiler
Given a class, and an interface that it implements, return a proxied version of the class that implements the interface.
getProfilingKey() - Method in class org.apache.struts2.interceptor.ProfilingActivationInterceptor

getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.util.CompoundRootAccessor

getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor

getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor

getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor
Gets the property of a Collection by indexing the collection based on a key property.
getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkListPropertyAccessor

getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

getProperty(Map, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkObjectPropertyAccessor

getProperty() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getPropertyDescriptors(Object) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Get's the java beans property descriptors for the given source.
getPropertyDescriptors(Object) - Method in class org.apache.struts2.views.xslt.BeanAdapter
Caching facade method to Introspector.getBeanInfo(Class, Class).getPropertyDescriptors();
getPropertyLocation(String) - Method in class com.opensymphony.xwork2.util.location.LocatableProperties

getPropertyName() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Returns the name of the last read property.
getPropertyName() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getPropertyName() - Method in interface org.apache.struts2.views.xslt.AdapterNode
The name of the Java object (property) that we are adapting
getPropertyThroughIteration(Map, Collection, String, Object) - Method in class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

getPropertyValue() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Returns the value of the last read property.
getPropertyValue() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getPropertyValue() - Method in interface org.apache.struts2.views.xslt.AdapterNode
The Java object (property) that we are adapting
getProtocol() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getProxy() - Method in class com.opensymphony.xwork2.ActionChainResult

getProxy() - Method in interface com.opensymphony.xwork2.ActionInvocation
Get the ActionProxy holding this ActionInvocation
getProxy() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

getProxy() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

getProxy() - Method in class org.apache.struts2.components.ActionComponent

getPush() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getPutStrategy() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

getQueryString() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRadio() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getRawData(int, int) - Method in class org.apache.struts2.components.table.WebTable

getRawDataRowIterator() - Method in class org.apache.struts2.components.table.WebTable

getReader() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRealPath(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRealTarget(String, Map, Object) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Looks for the real target with the specified property given a root Object which may be a CompoundRoot.
getRealValue(Map, Object, Class) - Method in class com.opensymphony.xwork2.util.XWorkListPropertyAccessor

getRemoteAddr() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRemoteHost() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRemotePort() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRemoteUser() - Method in interface org.apache.struts2.interceptor.PrincipalProxy
Gets the user id
getRemoteUser() - Method in class org.apache.struts2.portlet.interceptor.PortletPrincipalProxy
Gets the user id
getRemoteUser() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRemoteUser() - Method in class org.apache.struts2.servlet.interceptor.ServletPrincipalProxy
Gets the user id
getRemoveAllLabel() - Method in class org.apache.struts2.components.InputTransferSelect

getRemoveAllLabel() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getRemoveLabel() - Method in class org.apache.struts2.components.InputTransferSelect

getRemoveLabel() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getRenderer() - Method in class org.apache.struts2.components.table.WebTableColumn

getRenderRequest() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the RenderRequest.
getRenderResponse() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the RenderResponse.
getRepopulateField() - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

getRequest() - Method in interface org.apache.struts2.interceptor.PrincipalProxy
Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
getRequest() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the current PortletRequest.
getRequest() - Method in class org.apache.struts2.portlet.interceptor.PortletPrincipalProxy
Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
getRequest() - Method in class org.apache.struts2.servlet.interceptor.ServletPrincipalProxy
Deprecated. To obtain the HttpServletRequest in your action, use org.apache.struts2.servlet.ServletRequestAware, since this method will be dropped in future.
getRequest() - Static method in class org.apache.struts2.ServletActionContext
Gets the HTTP servlet request object.
getRequestDispatcher(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRequestedSessionId() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRequestMap(PortletRequest) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Returns a Map of all request attributes.
getRequestOperationMode(ActionInvocation) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor
Get the operationMode through request paramter, if allowRequestParameterSwitch is 'true', else it simply returns 'NONE', meaning its neither in the 'STORE_MODE' nor 'RETRIEVE_MODE'.
getRequestParameterSwitch() - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

getRequestURI() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getRequestURL() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getReset() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getResource(String, Class) - Static method in class com.opensymphony.xwork2.util.ClassLoaderUtil
Load a given resource.
getResource() - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

getResource(String, Class) - Static method in class org.apache.struts2.util.ClassLoaderUtils
Load a given resource.
getResourceAsStream(String, Class) - Static method in class com.opensymphony.xwork2.util.ClassLoaderUtil
This is a convenience method to load a resource as a stream.
getResourceAsStream(String, Class) - Static method in class org.apache.struts2.util.ClassLoaderUtils
This is a convenience method to load a resource as a stream.
getResourceBase(HttpServletRequest) - Static method in class org.apache.struts2.views.util.ResourceUtil

getResources(String, Class, boolean) - Static method in class com.opensymphony.xwork2.util.ClassLoaderUtil
Load all resources with a given name, potentially aggregating all results from the searched classloaders.
getResourceStream(String) - Method in class org.apache.struts2.views.velocity.StrutsResourceLoader

getResponse() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Get the current PortletResponse
getResponse() - Static method in class org.apache.struts2.ServletActionContext
Gets the HTTP servlet response object.
getResult() - Method in interface com.opensymphony.xwork2.ActionInvocation
If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
getResult() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

getResult() - Method in class com.opensymphony.xwork2.DefaultActionInvocation
If the DefaultActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
getResult() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

getResult() - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

getResult() - Method in class org.apache.struts2.interceptor.BackgroundProcess
Gets the result of the background process.
getResultCode() - Method in interface com.opensymphony.xwork2.ActionInvocation
Gets the result code returned from this ActionInvocation
getResultCode() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

getResultCode() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

getResults() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

getResultTypeConfigs() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
gets the ResultTypeConfigs local to this package
getRightDownLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getRightDownLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getRightTitle() - Method in class org.apache.struts2.components.InputTransferSelect

getRightTitle() - Method in class org.apache.struts2.components.OptionTransferSelect

getRightTitle() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getRightTitle() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getRightUpLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getRightUpLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getRoot() - Method in class com.opensymphony.xwork2.util.OgnlValueStack

getRoot() - Method in interface com.opensymphony.xwork2.util.ValueStack
Get the CompoundRoot which holds the objects pushed onto the stack
getRootElement() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument
Lazily construct the root element adapter from the value object.
getRootNode() - Method in class org.apache.struts2.components.Tree

getRootNode() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getRow(int) - Method in class org.apache.struts2.components.table.WebTable

getRowCount() - Method in class org.apache.struts2.components.table.AbstractFilterModel

getRowCount() - Method in class org.apache.struts2.components.table.WebTable

getRowIterator() - Method in class org.apache.struts2.components.table.WebTable

getRuntimeConfiguration() - Method in interface com.opensymphony.xwork2.config.Configuration
The current runtime configuration.
getRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

getRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

getSaveDir(ServletContext) - Method in class org.apache.struts2.dispatcher.Dispatcher
Return the path to save uploaded files to (this is configurable).
getSchemaTypeInfo() - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

getSchemaTypeInfo() - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

getSchemaTypeInfo() - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

getScheme() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getScopeKey() - Method in interface com.opensymphony.xwork2.interceptor.ScopedModelDriven
Gets the key under which the model is stored
getScopeStrategy() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the current scope strategy.
getScopeStrategy() - Method in class com.opensymphony.xwork2.inject.ExternalContext

getScopeStrategy() - Method in class com.opensymphony.xwork2.inject.InternalContext

getSelect() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getSelectAllLabel() - Method in class org.apache.struts2.components.OptionTransferSelect

getSelectAllLabel() - Method in class org.apache.struts2.components.UpDownSelect

getSelectAllLabel() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

getSelectAllLabel() - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

getSelectedIndex() - Method in class org.apache.struts2.util.TabbedPane

getSequence() - Method in class org.apache.struts2.components.Form
Get a incrementing sequence unique to this Form component.
getServerName() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getServerPort() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getServletContext() - Method in class org.apache.struts2.config.ServletContextSingleton
Gets the servlet context
getServletContext() - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Provide a workaround for some versions of WebLogic.
getServletContext(HttpSession) - Method in class org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61
answers the servlet context.
getServletContext() - Static method in class org.apache.struts2.portlet.context.ServletContextHolderListener

getServletContext() - Static method in class org.apache.struts2.ServletActionContext
Gets the servlet context.
getServletPath() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getServletPath(HttpServletRequest) - Static method in class org.apache.struts2.RequestUtils
Retrieves the current request servlet path.
getSession() - Method in class com.opensymphony.xwork2.ActionContext
Gets the Map of HttpSession values when in a servlet environment or a generic session map otherwise.
getSession() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getSession(boolean) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getSessionMap(PortletRequest) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Returns a Map of all session attributes.
getSessionReset() - Method in class org.apache.struts2.interceptor.ScopeInterceptor

getSet() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getSetMap(Map, String) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

getSetMap(Map, Collection, String, Class) - Method in class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

getShowGrid() - Method in class org.apache.struts2.components.Tree

getShowGrid() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getShowRootGrid() - Method in class org.apache.struts2.components.Tree

getShowRootGrid() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getSize() - Method in class org.apache.struts2.components.InputTransferSelect

getSize() - Method in class org.apache.struts2.util.FastByteArrayOutputStream

getSize() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getSnippet(int) - Method in interface com.opensymphony.xwork2.util.location.Location
Gets a source code snippet with the default padding
getSnippet(int) - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Gets a source code snippet with the default padding
getSortColumn() - Method in class org.apache.struts2.components.table.WebTable

getSortColumnLinkName() - Method in class org.apache.struts2.components.table.WebTable

getSortedColumnNumber() - Method in interface org.apache.struts2.components.table.SortableTableModel

getSortedColumnNumber() - Method in class org.apache.struts2.components.table.SortFilterModel

getSortedDirection(int) - Method in interface org.apache.struts2.components.table.SortableTableModel

getSortedDirection(int) - Method in class org.apache.struts2.components.table.SortFilterModel

getSortOrder() - Method in class org.apache.struts2.components.table.WebTable

getSortOrderLinkName() - Method in class org.apache.struts2.components.table.WebTable

getSpecified() - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

getStack() - Method in interface com.opensymphony.xwork2.ActionInvocation

getStack() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

getStack() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

getStack() - Method in class org.apache.struts2.components.Component
Get's the OGNL value stack assoicated with this component.
getStack() - Method in class org.apache.struts2.components.template.TemplateRenderingContext

getStack() - Method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

getStack(PageContext) - Static method in class org.apache.struts2.views.jsp.TagUtils

getStandardContext(ValueStack, HttpServletRequest, HttpServletResponse) - Static method in class org.apache.struts2.views.util.ContextUtil

getStrictErrorChecking() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getStringValue() - Method in class org.apache.struts2.views.xslt.SimpleTextNode

getStringValue() - Method in class org.apache.struts2.views.xslt.StringAdapter
Get the object to be adapted as a String value.
getStylesheetLocation() - Method in class org.apache.struts2.views.xslt.XSLTResult

getSubmit() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getSuccessResultValue() - Method in class org.apache.struts2.dispatcher.DefaultActionSupport

getSuffix() - Method in class org.apache.struts2.components.template.BaseTemplateEngine

getSuffix() - Method in class org.apache.struts2.components.template.FreemarkerTemplateEngine

getSuffix() - Method in class org.apache.struts2.components.template.JspTemplateEngine

getSuffix() - Method in class org.apache.struts2.components.template.VelocityTemplateEngine

getTabAlign() - Method in class org.apache.struts2.util.TabbedPane

getTabbedPanel() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getTable() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getTag() - Method in class org.apache.struts2.components.template.TemplateRenderingContext

getTagName() - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

getTagName() - Method in class org.apache.struts2.views.xslt.BeanAdapter

getTagName() - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

getTemplate() - Method in class org.apache.struts2.components.template.TemplateRenderingContext

getTemplate() - Method in class org.apache.struts2.components.UIBean

getTemplate(ValueStack, VelocityEngine, ActionInvocation, String, String) - Method in class org.apache.struts2.dispatcher.VelocityResult
Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.
getTemplate(ValueStack, VelocityEngine, ActionInvocation, String, String) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult
Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.
getTemplateCssPath() - Method in class org.apache.struts2.components.Tree

getTemplateCssPath() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getTemplateDir() - Method in class org.apache.struts2.components.UIBean

getTemplateEngine(Template, String) - Method in class org.apache.struts2.components.template.TemplateEngineManager
Gets the TemplateEngine for the template name.
getTemplateLoader(ServletContext) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager
The default template loader is a MultiTemplateLoader which includes a ClassTemplateLoader and a WebappTemplateLoader (and a FileTemplateLoader depending on the init-parameter 'TemplatePath').
getTemplates(String) - Method in class org.apache.struts2.views.xslt.XSLTResult

getTemplateSuffix(Map) - Static method in class org.apache.struts2.views.util.ContextUtil
Returns a String for overriding the default templateSuffix if templateSuffix is on the stack
GETTER_PATTERN - Static variable in class com.opensymphony.xwork2.util.AnnotationUtils

GETTER_PATTERN - Static variable in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

getText(String) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String, String) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String, String, String) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String, List) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String, String[]) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String, String, List) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String, String, String[]) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String, String, List, ValueStack) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.ActionSupport

getText(String) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String, String) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String, List) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String, String[]) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String, String, List) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String, String, String[]) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String, String, String) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String, String, List, ValueStack) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getText(String) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a message key, or null if no message is found.
getText(String, String) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key, or, if the message is not found, a supplied default value is returned.
getText(String, String, String) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied obj, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, List) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
getText(String, String[]) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or null if no message is found.
getText(String, String, List) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, String, String[]) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, String, List, ValueStack) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, String, String[], ValueStack) - Method in interface com.opensymphony.xwork2.TextProvider
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String, String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, List) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String[]) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String, List) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String, String[]) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get a text from the resource bundles associated with this action.
getText(String, String, List, ValueStack) - Method in class com.opensymphony.xwork2.TextProviderSupport
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.TextProviderSupport
Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
getText(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText(String, String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText(String, String, String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText(String, List) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText(String, String[]) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText(String, String, List) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText(String, String, String[]) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText(String, String, List, ValueStack) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText(String, String, String[], ValueStack) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getText() - Method in class org.apache.struts2.components.table.renderer.FixedTextCellRenderer

getText(String) - Method in class org.apache.struts2.util.StrutsUtil

getText() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getTextarea() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getTextContent() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getTextfield() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getTextMessage(String, Object[], Locale) - Method in class org.apache.struts2.interceptor.FileUploadInterceptor

getTextProvider() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getTexts() - Method in class com.opensymphony.xwork2.ActionSupport

getTexts(String) - Method in class com.opensymphony.xwork2.ActionSupport

getTexts(String) - Method in class com.opensymphony.xwork2.DefaultTextProvider

getTexts() - Method in class com.opensymphony.xwork2.DefaultTextProvider

getTexts(String) - Method in interface com.opensymphony.xwork2.TextProvider
Get the named bundle, such as "com/acme/Foo".
getTexts() - Method in interface com.opensymphony.xwork2.TextProvider
Get the resource bundle associated with the implementing class (usually an action).
getTexts(String) - Method in class com.opensymphony.xwork2.TextProviderSupport
Get the named bundle.
getTexts() - Method in class com.opensymphony.xwork2.TextProviderSupport
Get the resource bundle associated with this action.
getTexts(String) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getTexts() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getTextValue(Element) - Static method in class com.opensymphony.xwork2.validator.ValidatorFileParser
Extract trimmed text value from the given DOM element, ignoring XML comments.
getTheme() - Method in class org.apache.struts2.components.template.Template

getTheme() - Method in class org.apache.struts2.components.UIBean

getThemePropertiesFileName() - Method in class org.apache.struts2.components.template.BaseTemplateEngine

getThemeProps(Template) - Method in class org.apache.struts2.components.template.BaseTemplateEngine

getThemeProps(Template) - Method in interface org.apache.struts2.components.template.TemplateEngine
Get's the properties for the given template.
getThrowable() - Method in exception com.opensymphony.xwork2.XWorkException
Deprecated. Use getCause()
getTime() - Method in class org.apache.struts2.util.Timer

GETTING_BY_KEY_PROPERTY - Static variable in class com.opensymphony.xwork2.util.OgnlContextState

getToggle() - Method in class org.apache.struts2.components.Tree

getToggle() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getToggleDuration() - Method in class org.apache.struts2.components.Tree

getToggleDuration() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getToken() - Static method in class org.apache.struts2.util.TokenHelper
Gets a transaction token into the session using the default token name.
getToken(String) - Static method in class org.apache.struts2.util.TokenHelper
Gets the Token value from the params in the ServletActionContext using the given name
getToken() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getTokenName() - Static method in class org.apache.struts2.util.TokenHelper
Gets the token name from the Parameters in the ServletActionContext
getTokenNameField() - Method in class org.apache.struts2.components.Token
Deprecated. Templates should use $parameters from now on, not $tag.
getTooltipConfig(UIBean) - Method in class org.apache.struts2.components.UIBean

getTotal() - Method in class org.apache.struts2.util.Timer

getTree() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getTreeCollapsedTopic() - Method in class org.apache.struts2.components.Tree

getTreeCollapsedTopic() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getTreeExpandedTopic() - Method in class org.apache.struts2.components.Tree

getTreeExpandedTopic() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getTreenode() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getTreeSelectedTopic() - Method in class org.apache.struts2.components.Tree

getTreeSelectedTopic() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

getTrim() - Method in class com.opensymphony.xwork2.validator.validators.RequiredStringValidator

getTrim() - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

getTrimmedClassName(Method) - Static method in class com.opensymphony.xwork2.util.profiling.ObjectProfiler
Given a method, get the Method name, with no package information.
getType() - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

getType() - Method in interface com.opensymphony.xwork2.inject.Context
Gets the type of the field or parameter which is being injected.
getType() - Method in class com.opensymphony.xwork2.inject.ExternalContext

getType() - Method in class com.opensymphony.xwork2.inject.Key

getType() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

getType() - Method in class org.apache.struts2.interceptor.ScopeInterceptor

getType() - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

getType() - Method in class org.apache.struts2.views.velocity.components.AbstractDirective
All components, unless otherwise stated, are LINE-level directives.
getType() - Method in class org.apache.struts2.views.velocity.components.AnchorDirective

getType() - Method in class org.apache.struts2.views.velocity.components.ComponentDirective

getType() - Method in class org.apache.struts2.views.velocity.components.DivDirective

getType() - Method in class org.apache.struts2.views.velocity.components.FormDirective

getUpdownselect() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getUpLabel() - Method in class org.apache.struts2.components.InputTransferSelect

getUpLabel() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

getURI() - Method in interface com.opensymphony.xwork2.util.location.Location
Get the URI of this location
getURI(Attributes) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the URI of an element (SAX flavor)
getURI(Element) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Returns the URI of an element (DOM flavor)
getURI() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Get the URI of this location
getUri(HttpServletRequest) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper
Gets the uri from the request
getUriFromActionMapping(ActionMapping) - Method in interface org.apache.struts2.dispatcher.mapper.ActionMapper
Convert an ActionMapping into a URI string
getUriFromActionMapping(ActionMapping) - Method in class org.apache.struts2.dispatcher.mapper.CompositeActionMapper

getUriFromActionMapping(ActionMapping) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

getUriFromActionMapping(ActionMapping) - Method in class org.apache.struts2.dispatcher.mapper.RestfulActionMapper

getURIResolver() - Method in class org.apache.struts2.views.xslt.XSLTResult
Get the URI Resolver to be called by the processor when it encounters an xsl:include, xsl:import, or document() function.
getURL() - Method in class org.apache.struts2.util.URLBean

getURL(String) - Method in class org.apache.struts2.views.freemarker.StrutsClassTemplateLoader

getUrl() - Method in class org.apache.struts2.views.freemarker.tags.StrutsModels

getUserData(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

getUserPrincipal() - Method in interface org.apache.struts2.interceptor.PrincipalProxy
Gets the user principal
getUserPrincipal() - Method in class org.apache.struts2.portlet.interceptor.PortletPrincipalProxy
Gets the user principal
getUserPrincipal() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

getUserPrincipal() - Method in class org.apache.struts2.servlet.interceptor.ServletPrincipalProxy
Gets the user principal
getValidationAware() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

getValidator(ValidatorConfig) - Static method in class com.opensymphony.xwork2.validator.ValidatorFactory
Deprecated.
getValidator(ValidatorConfig, ObjectFactory) - Static method in class com.opensymphony.xwork2.validator.ValidatorFactory
Get a Validator that matches the given configuration.
getValidatorContext() - Method in interface com.opensymphony.xwork2.validator.Validator

getValidatorContext() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

getValidators(Class, String, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Returns a list of validators for the given class, context, and method.
getValidators(Class, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Returns a list of validators for the given class and context.
getValidators(Class, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
Returns a list of validators for the given class and context.
getValidators(Class, String, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
Returns a list of validators for the given class, context, and method.
getValidators(Class, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
Returns a list of validators for the given class and context.
getValidators(Class, String, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
Returns a list of validators for the given class, context, and method name.
getValidators(String) - Method in class org.apache.struts2.components.Form

getValidatorType() - Method in interface com.opensymphony.xwork2.validator.Validator

getValidatorType() - Method in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

getValidatorType() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

getValue() - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

getValue() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

getValue() - Method in class com.opensymphony.xwork2.util.ObjectProxy

getValue(String, Map, Object) - Static method in class com.opensymphony.xwork2.util.OgnlUtil

getValue(String, Map, Object, Class) - Static method in class com.opensymphony.xwork2.util.OgnlUtil

getValue(Map, Object) - Method in class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

getValue() - Method in class org.apache.struts2.components.Debug.DebugMapEntry

getValue(String, String) - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

getValue() - Method in class org.apache.struts2.util.ListEntry

getValue() - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

getValueAt(int, int) - Method in class org.apache.struts2.components.table.AbstractFilterModel

getValueAt(int, int) - Method in class org.apache.struts2.components.table.SortFilterModel

getValueClassType() - Method in class org.apache.struts2.components.Checkbox

getValueClassType() - Method in class org.apache.struts2.components.ListUIBean

getValueClassType() - Method in class org.apache.struts2.components.UIBean

getValues(String, String[]) - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

getValueStack() - Method in class com.opensymphony.xwork2.ActionContext
Gets the OGNL value stack.
getValueStack(HttpServletRequest) - Static method in class org.apache.struts2.ServletActionContext
Gets the current value stack for this request
getVelocityDirectiveClasses() - Method in class org.apache.struts2.views.DefaultTagLibrary

getVelocityDirectiveClasses() - Method in interface org.apache.struts2.views.TagLibrary
Gets a list of Velocity directive classes for the tag library.
getVelocityEngine() - Method in class org.apache.struts2.views.velocity.VelocityManager

getVelocityProperties() - Method in class org.apache.struts2.views.velocity.VelocityManager

getWholeText() - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

getWholeText() - Method in class org.apache.struts2.views.xslt.SimpleTextNode

getWindowState(RenderRequest, String) - Static method in class org.apache.struts2.portlet.util.PortletUrlHelper
Convert the given String to a WindowState object.
getWriter() - Method in class org.apache.struts2.components.Include.PageResponse
Return PrintWriter wrapper around PageOutputStream.
getWriter() - Method in class org.apache.struts2.components.template.TemplateRenderingContext

getWriter() - Method in class org.apache.struts2.util.StrutsUtil.ResponseWrapper

getWriter() - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
The default writer writes directly to the response writer.
getWriter() - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
The default writer writes directly to the response writer.
getWriter(Writer, Map) - Method in class org.apache.struts2.views.freemarker.tags.TagModel

getXmlEncoding() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getXmlStandalone() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

getXmlVersion() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

globalExceptionMappingConfigs - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

globalResultConfigs - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

gridIconSrcC - Variable in class org.apache.struts2.components.Tree

gridIconSrcC - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

gridIconSrcL - Variable in class org.apache.struts2.components.Tree

gridIconSrcL - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

gridIconSrcP - Variable in class org.apache.struts2.components.Tree

gridIconSrcP - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

gridIconSrcV - Variable in class org.apache.struts2.components.Tree

gridIconSrcV - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

gridIconSrcX - Variable in class org.apache.struts2.components.Tree

gridIconSrcX - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

gridIconSrcY - Variable in class org.apache.struts2.components.Tree

gridIconSrcY - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

GT - Static variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

H

handleConversionException(Map, String, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkConverter

handleException(Throwable, ValueStack) - Method in interface com.opensymphony.xwork2.ActionEventListener
Called when an exception is thrown by the action
handleInvalidToken(ActionInvocation) - Method in class org.apache.struts2.interceptor.TokenInterceptor
Determines what to do if an invalida token is provided.
handleInvalidToken(ActionInvocation) - Method in class org.apache.struts2.interceptor.TokenSessionStoreInterceptor

handleLogging(Exception) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Handles the logging of the exception.
handler - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

handler - Variable in class org.apache.struts2.components.Submit

handler - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

handler - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

handleRejection(ActionInvocation, HttpServletResponse) - Method in class org.apache.struts2.interceptor.RolesInterceptor
Handles a rejection by sending a 403 HTTP error
handleSpecialParameters(HttpServletRequest, ActionMapping) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper
Special parameters, as described in the class-level comment, are searched for and handled.
handleUnknownAction(String, String) - Method in interface com.opensymphony.xwork2.UnknownHandler
Handles the case when an action configuration is unknown.
handleUnknownResult(ActionContext, String, ActionConfig, String) - Method in interface com.opensymphony.xwork2.UnknownHandler
Handles the case when a result cannot be found for an action and result code.
handleValidToken(ActionInvocation) - Method in class org.apache.struts2.interceptor.TokenInterceptor
Called when a valid token is found.
handleValidToken(ActionInvocation) - Method in class org.apache.struts2.interceptor.TokenSessionStoreInterceptor

hasActionErrors() - Method in class com.opensymphony.xwork2.ActionSupport

hasActionErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Check whether there are any Action-level error messages.
hasActionErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

hasActionErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

hasActionErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

hasActionMessages() - Method in class com.opensymphony.xwork2.ActionSupport

hasActionMessages() - Method in interface com.opensymphony.xwork2.ValidationAware
Checks whether there are any Action-level messages.
hasActionMessages() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

hasActionMessages() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

hasActionMessages() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

hasAttribute(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

hasAttribute(String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

hasAttributeNS(String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

hasAttributeNS(String, String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

hasAttributes() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

hasAttributes() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

hasChildNodes() - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

hasChildNodes() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

hasChildNodes() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

hasChildNodes() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

hasErrors() - Method in class com.opensymphony.xwork2.ActionSupport

hasErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Note that this does not have the same meaning as in WW 1.x.
hasErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

hasErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

hasErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

hasErrors() - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Returns true if any errors occured when parsing the HTTP multipart request, false otherwise.
hasFieldErrors() - Method in class com.opensymphony.xwork2.ActionSupport

hasFieldErrors() - Method in interface com.opensymphony.xwork2.ValidationAware
Check whether there are any field errors associated with this action.
hasFieldErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

hasFieldErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

hasFieldErrors() - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

hash - Variable in class com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

hashCode() - Method in class com.opensymphony.xwork2.ActionChainResult

hashCode() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

hashCode() - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

hashCode() - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

hashCode() - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping

hashCode() - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

hashCode() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

hashCode() - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

hashCode() - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

hashCode() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

hashCode - Variable in class com.opensymphony.xwork2.inject.Key

hashCode() - Method in class com.opensymphony.xwork2.inject.Key

hashCode() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

hashCode() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.KeyReferenceAwareWrapper

hashCode() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper

hashCode - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference

hashCode() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference

hashCode - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference

hashCode() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference

hashCode() - Method in class com.opensymphony.xwork2.mock.MockInterceptor

hashCode() - Method in class com.opensymphony.xwork2.mock.MockResult

hashCode() - Method in class com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

hashCode() - Method in class com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey

hashCode() - Method in class com.opensymphony.xwork2.util.location.LocationImpl

hasNext() - Method in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

hasNext() - Method in class org.apache.struts2.components.table.WebTable.WebTableRowIterator

hasNext() - Method in class org.apache.struts2.util.AppendIteratorFilter

hasNext() - Method in class org.apache.struts2.util.Counter

hasNext() - Method in class org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator

hasNext() - Method in class org.apache.struts2.util.IteratorGenerator

hasNext() - Method in class org.apache.struts2.util.MergeIteratorFilter

hasNext() - Method in class org.apache.struts2.util.SortIteratorFilter

hasNext() - Method in class org.apache.struts2.util.SubsetIteratorFilter

Head - Class in org.apache.struts2.components
Renders parts of the HEAD section for an HTML file.
Head(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Head

head - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

HeadDirective - Class in org.apache.struts2.views.velocity.components

HeadDirective() - Constructor for class org.apache.struts2.views.velocity.components.HeadDirective

headerKey - Variable in class org.apache.struts2.components.ComboBox

headerKey - Variable in class org.apache.struts2.components.DoubleListUIBean

headerKey - Variable in class org.apache.struts2.components.InputTransferSelect

headerKey - Variable in class org.apache.struts2.components.Select

headerKey - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

headerKey - Variable in class org.apache.struts2.views.jsp.ui.ComboBoxTag

headerKey - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

headerKey - Variable in class org.apache.struts2.views.jsp.ui.SelectTag

headers - Variable in class org.apache.struts2.dispatcher.HttpHeaderResult

headerValue - Variable in class org.apache.struts2.components.ComboBox

headerValue - Variable in class org.apache.struts2.components.DoubleListUIBean

headerValue - Variable in class org.apache.struts2.components.InputTransferSelect

headerValue - Variable in class org.apache.struts2.components.Select

headerValue - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

headerValue - Variable in class org.apache.struts2.views.jsp.ui.ComboBoxTag

headerValue - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

headerValue - Variable in class org.apache.struts2.views.jsp.ui.SelectTag

HeadModel - Class in org.apache.struts2.views.freemarker.tags

HeadModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.HeadModel

HeadTag - Class in org.apache.struts2.views.jsp.ui

HeadTag() - Constructor for class org.apache.struts2.views.jsp.ui.HeadTag

HEX_RADIX - Static variable in class com.opensymphony.xwork2.util.PropertiesReader
Constant for the radix of hex numbers.
Hidden - Class in org.apache.struts2.components
Renders an HTML input element of type hidden, populated by the specified property from the ValueStack.
Hidden(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Hidden

hidden - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

HiddenDirective - Class in org.apache.struts2.views.velocity.components

HiddenDirective() - Constructor for class org.apache.struts2.views.velocity.components.HiddenDirective

HiddenModel - Class in org.apache.struts2.views.freemarker.tags

HiddenModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.HiddenModel

HiddenTag - Class in org.apache.struts2.views.jsp.ui

HiddenTag() - Constructor for class org.apache.struts2.views.jsp.ui.HiddenTag

href - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

href - Variable in class org.apache.struts2.components.Autocompleter

href - Variable in class org.apache.struts2.components.Submit

href - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

href - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

href - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

htmlEncode(String) - Static method in class com.opensymphony.xwork2.util.TextUtils

htmlEncode(String, boolean) - Static method in class com.opensymphony.xwork2.util.TextUtils
Escape html entity characters and high characters (eg "curvy" Word quotes).
htmlEncode(Object) - Method in class org.apache.struts2.util.StrutsUtil

HTTP_METHOD_PARAM - Static variable in class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

HTTP_REQUEST - Static variable in interface org.apache.struts2.StrutsStatics
Constant for the HTTP request object.
HTTP_RESPONSE - Static variable in interface org.apache.struts2.StrutsStatics
Constant for the HTTP response object.
HttpHeaderResult - Class in org.apache.struts2.dispatcher
A custom Result type for setting HTTP headers and status by optionally evaluating against the ValueStack.
HttpHeaderResult() - Constructor for class org.apache.struts2.dispatcher.HttpHeaderResult

HttpHeaderResult(int) - Constructor for class org.apache.struts2.dispatcher.HttpHeaderResult

httpPort - Static variable in class org.apache.struts2.views.util.UrlHelper

HttpServletRequestMock - Class in org.apache.struts2.portlet.util
A simple mock class to interact with Struts 2 API's that require a servlet request
HttpServletRequestMock() - Constructor for class org.apache.struts2.portlet.util.HttpServletRequestMock

httpsPort - Static variable in class org.apache.struts2.views.util.UrlHelper

I

I18n - Class in org.apache.struts2.components
Gets a resource bundle and place it on the value stack.
I18n(ValueStack) - Constructor for class org.apache.struts2.components.I18n

i18n - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

I18nDirective - Class in org.apache.struts2.views.velocity.components

I18nDirective() - Constructor for class org.apache.struts2.views.velocity.components.I18nDirective

I18nInterceptor - Class in com.opensymphony.xwork2.interceptor
An interceptor that handles setting the locale specified in a session as the locale for the current action request.
I18nInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.I18nInterceptor

I18nModel - Class in org.apache.struts2.views.freemarker.tags

I18nModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.I18nModel

I18nTag - Class in org.apache.struts2.views.jsp

I18nTag() - Constructor for class org.apache.struts2.views.jsp.I18nTag

iconHeight - Variable in class org.apache.struts2.components.Tree

iconHeight - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

iconPath - Variable in class org.apache.struts2.components.Autocompleter

iconPath - Variable in class org.apache.struts2.components.DateTimePicker

iconPath - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

iconPath - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

iconWidth - Variable in class org.apache.struts2.components.Tree

iconWidth - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

id - Variable in class org.apache.struts2.components.Component

idx - Variable in class org.apache.struts2.util.MergeIteratorFilter

If - Class in org.apache.struts2.components

If(ValueStack) - Constructor for class org.apache.struts2.components.If

IfModel - Class in org.apache.struts2.views.freemarker.tags

IfModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.IfModel

ifModel - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

IfTag - Class in org.apache.struts2.views.jsp

IfTag() - Constructor for class org.apache.struts2.views.jsp.IfTag

ignorableWhitespace(char[], int, int) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

ignorableWhitespace(char[], int, int) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

ignorableWhitespace(char[], int, int) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

ignoreContextParams - Variable in class org.apache.struts2.components.ActionComponent

ignoreContextParams - Variable in class org.apache.struts2.views.jsp.ActionTag

ignoreKeys - Variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

ignorePrefixes - Variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

implementation - Variable in class com.opensymphony.xwork2.config.impl.LocatableFactory

implementation - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector

importNode(Node, boolean) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

Include - Class in org.apache.struts2.components

Include(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Include

include(String, Writer, ServletRequest, HttpServletResponse) - Static method in class org.apache.struts2.components.Include

include(PortletRequestDispatcher, RenderRequest, RenderResponse) - Method in class org.apache.struts2.portlet.result.PortletResult.IncludeTemplate

include(Object) - Method in class org.apache.struts2.util.StrutsUtil

include(Object, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.util.StrutsUtil
Deprecated. the request and response are stored in this util class, please use include(string)
include - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

Include.PageOutputStream - Class in org.apache.struts2.components
Implementation of ServletOutputStream that stores all data written to it in a temporary buffer accessible from Include.PageOutputStream.getBuffer() .
Include.PageOutputStream() - Constructor for class org.apache.struts2.components.Include.PageOutputStream

Include.PageResponse - Class in org.apache.struts2.components
Simple wrapper to HTTPServletResponse that will allow getWriter() and getResponse() to be called as many times as needed without causing conflicts.
Include.PageResponse(HttpServletResponse) - Constructor for class org.apache.struts2.components.Include.PageResponse
Create PageResponse wrapped around an existing HttpServletResponse.
includeContext - Variable in class org.apache.struts2.components.URL

includeContext - Variable in class org.apache.struts2.views.jsp.URLTag

includedFileNames - Variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

IncludeDirective - Class in org.apache.struts2.views.velocity.components

IncludeDirective() - Constructor for class org.apache.struts2.views.velocity.components.IncludeDirective

includeExtraParameters() - Method in class org.apache.struts2.components.URL

includeGetParameters() - Method in class org.apache.struts2.components.URL

includeMethods - Variable in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

IncludeModel - Class in org.apache.struts2.views.freemarker.tags

IncludeModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.IncludeModel

includeParams - Variable in class org.apache.struts2.components.URL

includeParams - Variable in class org.apache.struts2.views.jsp.URLTag

includes - Variable in class com.opensymphony.xwork2.interceptor.ChainingInterceptor

includesExcludesMap - Variable in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

IncludeTag - Class in org.apache.struts2.views.jsp

IncludeTag() - Constructor for class org.apache.struts2.views.jsp.IncludeTag

index - Variable in class org.apache.struts2.components.table.SortFilterModel.Row

index - Variable in class org.apache.struts2.util.FastByteArrayOutputStream

index - Variable in class org.apache.struts2.views.jsp.IteratorStatus.StatusState

INDEX_ACCESS_PROPS - Static variable in class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

indexOfArray(int[], int, int, char[], int) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Get the offset of a part of an int array within a char array.
indicator - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

indicator - Variable in class org.apache.struts2.components.Autocompleter

indicator - Variable in class org.apache.struts2.components.Submit

indicator - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

indicator - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

indicator - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

init(Configuration) - Method in interface com.opensymphony.xwork2.config.ConfigurationProvider

init(Configuration) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

init() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

init() - Method in class com.opensymphony.xwork2.interceptor.AbstractInterceptor
Does nothing
init() - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor

init() - Method in interface com.opensymphony.xwork2.interceptor.Interceptor
Called after an interceptor is created, but before any requests are processed using intercept , giving the Interceptor a chance to initialize any needed resources.
init() - Method in class com.opensymphony.xwork2.mock.MockInterceptor
Called after an Interceptor is created, but before any requests are processed using the intercept() methodName.
init(Configuration) - Method in class org.apache.struts2.config.BeanSelectionProvider

init(Configuration) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Register this application's configuration.
init(Configuration) - Method in class org.apache.struts2.config.DefaultPropertiesProvider

init(Configuration) - Method in class org.apache.struts2.config.LegacyPropertiesConfigurationProvider

init(Configuration) - Method in class org.apache.struts2.config.MethodConfigurationProvider

init(FilterConfig) - Method in class org.apache.struts2.dispatcher.ActionContextCleanUp

init() - Method in class org.apache.struts2.dispatcher.Dispatcher
Load configurations, including both XML and zero-configuration strategies, and update optional settings, including whether to reload configurations and resource files.
init(FilterConfig) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Initializes the filter by creating a default dispatcher and setting the default packages for static resources.
init() - Method in class org.apache.struts2.interceptor.CheckboxInterceptor

init() - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor
Unused.
init() - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

init() - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

init(PortletConfig) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Initialize the portlet with the init parameters from portlet.xml
init(ServletConfig) - Method in class org.apache.struts2.views.JspSupportServlet

init(ServletContext) - Method in class org.apache.struts2.views.velocity.VelocityManager
initializes the VelocityManager.
init_AliasStandardObjects() - Method in class org.apache.struts2.dispatcher.Dispatcher

init_CheckConfigurationReloading(Container) - Method in class org.apache.struts2.dispatcher.Dispatcher

init_CheckWebLogicWorkaround(Container) - Method in class org.apache.struts2.dispatcher.Dispatcher

init_CustomConfigurationProviders() - Method in class org.apache.struts2.dispatcher.Dispatcher

init_DefaultProperties() - Method in class org.apache.struts2.dispatcher.Dispatcher

init_FilterInitParameters() - Method in class org.apache.struts2.dispatcher.Dispatcher

init_LegacyStrutsProperties() - Method in class org.apache.struts2.dispatcher.Dispatcher

init_MethodConfigurationProvider() - Method in class org.apache.struts2.dispatcher.Dispatcher

init_PreloadConfiguration() - Method in class org.apache.struts2.dispatcher.Dispatcher

init_TraditionalXmlConfigurations() - Method in class org.apache.struts2.dispatcher.Dispatcher

init_ZeroConfiguration() - Method in class org.apache.struts2.dispatcher.Dispatcher

initDispatcher(Map<String, String>) - Method in class org.apache.struts2.StrutsTestCase

initDispatcher(Map<String, String>) - Method in class org.apache.struts2.TestNGStrutsTestCase

initDispatcher(Map<String, String>) - Static method in class org.apache.struts2.util.StrutsTestCaseHelper

initialized - Variable in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

initialized - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
Flag to indicate the packages have been loaded.
initialValue() - Method in class com.opensymphony.xwork2.ActionContext.ActionContextThreadLocal

initMapping() - Static method in class org.apache.struts2.views.util.TextUtil

initObjectFactory() - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
This method sets the ObjectFactory used by XWork to this object.
initParams - Variable in class org.apache.struts2.dispatcher.Dispatcher

initToolbox(ServletContext) - Method in class org.apache.struts2.views.velocity.VelocityManager
Initializes the ServletToolboxManager for this servlet's toolbox (if any).
inject(Object) - Method in interface com.opensymphony.xwork2.inject.Container
Injects dependencies into the fields and methods of an existing object.
inject(Class<T>) - Method in interface com.opensymphony.xwork2.inject.Container
Creates and injects a new instance of type implementation.
inject(InternalContext, Object) - Method in class com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector

inject(Object, InternalContext) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

inject(Class<T>, InternalContext) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

inject(Object) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

inject(Class<T>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

inject(InternalContext, Object) - Method in interface com.opensymphony.xwork2.inject.ContainerImpl.Injector

inject(InternalContext, Object) - Method in class com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector

inject(Member, InternalContext) - Method in class com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector

Inject - Annotation Type in com.opensymphony.xwork2.inject
Annotates members and parameters which should have their value[s] injected.
injectInternalBeans(Object) - Method in class com.opensymphony.xwork2.ObjectFactory

injectors - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector

injectors - Variable in class com.opensymphony.xwork2.inject.ContainerImpl
Field and method injectors.
injectStatics(Class<?>...) - Method in class com.opensymphony.xwork2.inject.ContainerBuilder
Upon creation, the Container will inject static fields and methods into the given classes.
injectStatics(List<Class<?>>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

INPUT - Static variable in interface com.opensymphony.xwork2.Action
The action execution require more input in order to succeed.
input() - Method in class com.opensymphony.xwork2.ActionSupport

inputName - Variable in class org.apache.struts2.dispatcher.StreamResult

inputResultName - Variable in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

inputStream - Variable in class org.apache.struts2.dispatcher.StreamResult

InputTransferSelect - Class in org.apache.struts2.components
Create a input transfer select component which is basically an text input and <select ...> tag with buttons in the middle of them allowing text to be added to the transfer select.
InputTransferSelect(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.InputTransferSelect

inputtransferselect - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

InputTransferSelectDirective - Class in org.apache.struts2.views.velocity.components

InputTransferSelectDirective() - Constructor for class org.apache.struts2.views.velocity.components.InputTransferSelectDirective

InputTransferSelectModel - Class in org.apache.struts2.views.freemarker.tags

InputTransferSelectModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.InputTransferSelectModel

InputTransferSelectTag - Class in org.apache.struts2.views.jsp.ui
InputTransferSelect jsp tag.
InputTransferSelectTag() - Constructor for class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

insertBefore(Node, Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

insertData(int, String) - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

insertData(int, String) - Method in class org.apache.struts2.views.xslt.SimpleTextNode

INSTANCE - Static variable in class com.opensymphony.xwork2.DefaultTextProvider

instance - Static variable in class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

instance - Static variable in class com.opensymphony.xwork2.TextProviderFactory

instance - Static variable in class com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory

instance - Static variable in class com.opensymphony.xwork2.util.XWorkConverter

instance - Static variable in class com.opensymphony.xwork2.validator.ActionValidatorManagerFactory

instance - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Provide a thread local instance.
instance - Static variable in class org.apache.struts2.views.jsp.ui.OgnlTool

InstantiatingNullHandler - Class in com.opensymphony.xwork2.util
Provided that the key InstantiatingNullHandler.CREATE_NULL_OBJECTS is in the action context with a value of true (this key is set only during the execution of the ParametersInterceptor), OGNL expressions that have caused a NullPointerException will be temporarily stopped for evaluation while the system automatically tries to solve the null references by automatically creating the object.
InstantiatingNullHandler() - Constructor for class com.opensymphony.xwork2.util.InstantiatingNullHandler

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.AbstractInterceptor
Override to handle interception
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.AliasInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor
Discovers annotated methods on the action and calls them according to the workflow
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor

intercept(ActionInvocation) - Method in interface com.opensymphony.xwork2.interceptor.Interceptor
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.LoggingInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
Decide if the parameter should be removed from the parameter map based on paramNames and paramValues.
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.PrepareInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor

intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.mock.MockInterceptor
Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the DefaultActionInvocation or to short-circuit the processing and just return a String return code.
intercept(ActionInvocation) - Method in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor
Looks for the ApplicationContext under the attribute that the Spring listener sets in the servlet context.
intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.CheckboxInterceptor

intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.CreateSessionInterceptor

intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.FileUploadInterceptor

intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.ProfilingActivationInterceptor

intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.RolesInterceptor

intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.ScopeInterceptor

intercept(ActionInvocation) - Method in class org.apache.struts2.interceptor.ServletConfigInterceptor
Sets action properties based on the interfaces an action implements.
intercept(ActionInvocation) - Method in class org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor

interceptor - Variable in class com.opensymphony.xwork2.config.entities.InterceptorMapping

Interceptor - Interface in com.opensymphony.xwork2.interceptor
An interceptor is a stateless class that follows the interceptor pattern, as found in Filter and in AOP languages.
InterceptorBuilder - Class in com.opensymphony.xwork2.config.providers
Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
InterceptorBuilder() - Constructor for class com.opensymphony.xwork2.config.providers.InterceptorBuilder

InterceptorConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for Interceptors.
InterceptorConfig() - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorConfig

InterceptorConfig(String, Class, Map) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorConfig

InterceptorConfig(String, String, Map) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorConfig

InterceptorConfig(InterceptorConfig, Map) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorConfig

interceptorConfigs - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

InterceptorListHolder - Interface in com.opensymphony.xwork2.config.entities
InterceptorListHolder
InterceptorMapping - Class in com.opensymphony.xwork2.config.entities
InterceptorMapping
InterceptorMapping() - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorMapping

InterceptorMapping(String, Interceptor) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorMapping

interceptors - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig

interceptors - Variable in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

interceptors - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

InterceptorStackConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for InterceptorStack.
InterceptorStackConfig() - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

InterceptorStackConfig(String) - Constructor for class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

INTERNAL_LIST_UI_BEAN_LIST_PARAMETER_KEY - Static variable in class org.apache.struts2.components.OptGroup

internalContainsKey(Object) - Method in class org.apache.struts2.views.velocity.StrutsVelocityContext

InternalContext - Class in com.opensymphony.xwork2.inject
Internal context.
InternalContext(ContainerImpl) - Constructor for class com.opensymphony.xwork2.inject.InternalContext

internalCreate(K) - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache

InternalFactory<T> - Interface in com.opensymphony.xwork2.inject
Creates objects which will be injected.
internalGet(K) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

internalGet(String) - Method in class org.apache.struts2.views.velocity.StrutsVelocityContext

internalGetActionErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

internalGetActionMessages() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

internalGetFieldErrors() - Method in class com.opensymphony.xwork2.ValidationAwareSupport

internalSetProperty(String, Object, Object, Map, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlUtil

internalUiBean - Variable in class org.apache.struts2.components.OptGroup

interval - Variable in class org.apache.struts2.util.Counter

IntRangeFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a numeric field has a value within a specified range.
IntRangeFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Field Validator that checks if the integer specified is within a certain range.
IntRangeFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

IntRangeFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
IntRangeFieldValidatorDescription
IntRangeFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

IntRangeFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
INVALID_TOKEN_CODE - Static variable in class org.apache.struts2.interceptor.TokenInterceptor

invalidate() - Method in class org.apache.struts2.dispatcher.SessionMap
Invalidate the http session.
InvalidMetadataException - Exception in com.opensymphony.xwork2
InvalidMetadataException
InvalidMetadataException(String) - Constructor for exception com.opensymphony.xwork2.InvalidMetadataException
Create a new InvalidMetadataException with the supplied error message.
invalidMethods - Static variable in class com.opensymphony.xwork2.util.CompoundRootAccessor

invocation - Variable in class com.opensymphony.xwork2.DefaultActionProxy

invocation - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

invocation - Variable in class org.apache.struts2.interceptor.BackgroundProcess

invocation - Variable in class org.apache.struts2.util.InvocationSessionStore.InvocationContext

invocation - Variable in class org.apache.struts2.views.freemarker.FreemarkerResult

invocation - Variable in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

INVOCATION_MAP_KEY - Static variable in class org.apache.struts2.util.InvocationSessionStore

invocationContext - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

invocationContext - Variable in class com.opensymphony.xwork2.mock.MockActionInvocation

invocationHandlers - Variable in class com.opensymphony.xwork2.inject.ConstructionContext

InvocationSessionStore - Class in org.apache.struts2.util
InvocationSessionStore
InvocationSessionStore() - Constructor for class org.apache.struts2.util.InvocationSessionStore

InvocationSessionStore.InvocationContext - Class in org.apache.struts2.util

InvocationSessionStore.InvocationContext(ActionInvocation, String) - Constructor for class org.apache.struts2.util.InvocationSessionStore.InvocationContext

invoke() - Method in interface com.opensymphony.xwork2.ActionInvocation
Invokes the next step in processing this ActionInvocation.
invoke() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

invoke(Object, Method, Object[]) - Method in class com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler

invoke() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

invoke(Object, Method, Object[]) - Method in class com.opensymphony.xwork2.util.profiling.TimerInvocationHandler

invokeAction(Object, ActionConfig) - Method in class com.opensymphony.xwork2.DefaultActionInvocation

invokeAction(Object, ActionConfig) - Method in class org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation

invokeActionOnly() - Method in interface com.opensymphony.xwork2.ActionInvocation
Invokes only the action (not interceptors or results).
invokeActionOnly() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

invokeActionOnly() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

invokePrefixMethod(ActionInvocation, String[]) - Static method in class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil
This method will prefix actionInvocation's ActionProxy's method with prefixes before invoking the prefixed method.
invokeUnderTiming(ActionInvocation) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Is called to invoke the action invocation and time the execution time.
isAbstract - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

isAbstract() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

isActive() - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
Determine if profiling is being activated, by searching for a system property 'xwork.profile.activate', default to false (profiling is off).
isAligned() - Method in class org.apache.struts2.components.table.renderer.AbstractCellRenderer

isAllowed(HttpServletRequest, Object) - Method in class org.apache.struts2.interceptor.RolesInterceptor
Determines if the request should be allowed for the action
isAppendPrefix() - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
Flags whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
isCaseSensitive() - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator

isCellEditable(int, int) - Method in class org.apache.struts2.components.table.AbstractFilterModel

isCellEditable(int, int) - Method in class org.apache.struts2.components.table.SortFilterModel

isColumnHidden(int) - Method in class org.apache.struts2.components.table.WebTable

isCommentLine(String) - Method in class com.opensymphony.xwork2.util.PropertiesReader
Tests whether a line is a comment, i.e.
isConstructing() - Method in class com.opensymphony.xwork2.inject.ConstructionContext

isCreatingNullObjects(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

isDebug() - Method in class org.apache.struts2.components.Head

isDefaultBlock() - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

isDefaultNamespace(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

isDelete(HttpServletRequest) - Method in class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

isDenyMethodExecution(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

isDone() - Method in class org.apache.struts2.interceptor.BackgroundProcess
Returns the status of the background process.
isElementContentWhitespace() - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

isElementContentWhitespace() - Method in class org.apache.struts2.views.xslt.SimpleTextNode

isEmpty() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

isEmpty() - Method in class org.apache.struts2.util.AttributeMap

isEmpty() - Method in class org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel

isEqualNode(Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

isEven() - Method in class org.apache.struts2.views.jsp.IteratorStatus

isEvent() - Static method in class org.apache.struts2.portlet.context.PortletActionContext

isExcluded(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

isExecuted() - Method in interface com.opensymphony.xwork2.ActionInvocation

isExecuted() - Method in class com.opensymphony.xwork2.DefaultActionInvocation

isExecuted() - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

isExecuted() - Method in class com.opensymphony.xwork2.mock.MockInterceptor

isExecutedCalled() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

isFirst() - Method in class org.apache.struts2.views.jsp.IteratorStatus

isGet(HttpServletRequest) - Method in class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

isGettingByKeyProperty(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

isHidden() - Method in class org.apache.struts2.components.table.WebTableColumn

isId() - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

isInChainHistory(String, String, String) - Method in class com.opensymphony.xwork2.ActionChainResult

isIntegerType(Class) - Method in class com.opensymphony.xwork2.util.XWorkBasicConverter

isIterable(Object) - Static method in class org.apache.struts2.util.MakeIterator
Determine whether a given object can be made into an Iterator
isKnown(Location) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Checks if a location is known, i.e.
isLast() - Method in class org.apache.struts2.views.jsp.IteratorStatus

isLogEnabled() - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

isLoggerEnabled(Log, String) - Static method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Is the given logger enalbed at the given level?
isNice() - Method in class org.apache.struts2.components.Date

isNoArgConstructorRequired() - Method in class com.opensymphony.xwork2.ObjectFactory
Allows for ObjectFactory implementations that support Actions without no-arg constructors.
isNoArgConstructorRequired() - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Allows for ObjectFactory implementations that support Actions without no-arg constructors.
isNonEmpty(Object[]) - Static method in class org.apache.struts2.interceptor.FileUploadInterceptor

isOdd() - Method in class org.apache.struts2.views.jsp.IteratorStatus

isOrdered() - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Whether to order the parameters or not
isPathUrl(String) - Static method in class org.apache.struts2.dispatcher.ServletRedirectResult

isPortletRequest() - Static method in class org.apache.struts2.portlet.context.PortletActionContext
Check to see if the current request is a portlet request.
isPortletSupportActive() - Method in class org.apache.struts2.dispatcher.Dispatcher
Return true, if portlet support is active, false otherwise.
isPost(HttpServletRequest) - Method in class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

isPropSeperator(char) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

isPut(HttpServletRequest) - Method in class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

isReadOnly(String) - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

isReloadingConfigs() - Static method in class com.opensymphony.xwork2.util.FileManager

isRender() - Static method in class org.apache.struts2.portlet.context.PortletActionContext

isRendered() - Method in class org.apache.struts2.components.table.RenderFilterModel

isReportingConversionErrors(Map) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

isRequestedSessionIdFromCookie() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

isRequestedSessionIdFromURL() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

isRequestedSessionIdFromUrl() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

isRequestedSessionIdValid() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

isRequestSecure() - Method in interface org.apache.struts2.interceptor.PrincipalProxy
Is the request using https?
isRequestSecure() - Method in class org.apache.struts2.portlet.interceptor.PortletPrincipalProxy
Is the request using https?
isRequestSecure() - Method in class org.apache.struts2.servlet.interceptor.ServletPrincipalProxy
Is the request using https?
isReset() - Method in class org.apache.struts2.interceptor.ScopeInterceptor

isSameNode(Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

isSecure() - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

isSelected - Variable in class org.apache.struts2.util.ListEntry

isSet(String) - Static method in class org.apache.struts2.config.Settings
Determines whether or not a setting has a registered value.
isSetImpl(String) - Method in class org.apache.struts2.config.DefaultSettings

isSetImpl(String) - Method in class org.apache.struts2.config.DelegatingSettings

isSetImpl(String) - Method in class org.apache.struts2.config.PropertiesSettings
Tests to see if a property exists in the properties file.
isSetImpl(String) - Method in class org.apache.struts2.config.Settings
Implements the Settings.isSet(String) method.
isShortCircuit() - Method in interface com.opensymphony.xwork2.validator.ShortCircuitableValidator
Gets whether this field validator should short circuit the validator queue it's in if validation fails.
isShortCircuit() - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

isShortCircuit() - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

isShouldCreateIfNew() - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

isSimpleValidator() - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

isSimpleValidator() - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

isSimpleValidator() - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription

isSortable() - Method in class org.apache.struts2.components.table.WebTable

isStatic(Member) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

isSupported(String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

isSupported(String, String) - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

isTrimed() - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator

isTrue(String) - Method in class org.apache.struts2.util.StrutsUtil

isUnknown(Location) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Checks if a location is unknown, i.e.
isUseAltSyntax(Map) - Static method in class org.apache.struts2.views.util.ContextUtil
Return true if either Configuration's altSyntax is on or the stack context's useAltSyntax is on
isUserInRole(String) - Method in interface org.apache.struts2.interceptor.PrincipalProxy
True if the user is in the given role
isUserInRole(String) - Method in class org.apache.struts2.portlet.interceptor.PortletPrincipalProxy
True if the user is in the given role
isUserInRole(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

isUserInRole(String) - Method in class org.apache.struts2.servlet.interceptor.ServletPrincipalProxy
True if the user is in the given role
isValidateAnnotatedMethodOnly() - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor

isVisible() - Method in class org.apache.struts2.components.table.WebTableColumn

isWrap() - Method in class org.apache.struts2.util.Counter

item(int) - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

item(int) - Method in class org.apache.struts2.views.xslt.SimpleNodeList

iterator - Variable in class org.apache.struts2.components.IteratorComponent

iterator - Variable in class org.apache.struts2.util.SortIteratorFilter

iterator - Variable in class org.apache.struts2.util.SubsetIteratorFilter

iterator - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

IteratorComponent - Class in org.apache.struts2.components

IteratorComponent(ValueStack) - Constructor for class org.apache.struts2.components.IteratorComponent

IteratorFilterSupport - Class in org.apache.struts2.util
A base class for iterator filters
IteratorFilterSupport() - Constructor for class org.apache.struts2.util.IteratorFilterSupport

IteratorFilterSupport.EnumerationIterator - Class in org.apache.struts2.util

IteratorFilterSupport.EnumerationIterator(Enumeration) - Constructor for class org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator

IteratorGenerator - Class in org.apache.struts2.util
A bean that generates an iterator filled with a given object depending on the count, separator and converter defined.
IteratorGenerator() - Constructor for class org.apache.struts2.util.IteratorGenerator

iteratorGenerator - Variable in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

IteratorGenerator.Converter - Interface in org.apache.struts2.util
Interface for converting each separated token into an Object of choice.
IteratorGeneratorTag - Class in org.apache.struts2.views.jsp.iterator
NOTE: JSP-TAG
IteratorGeneratorTag() - Constructor for class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

IteratorModel - Class in org.apache.struts2.views.freemarker.tags

IteratorModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.IteratorModel

iterators - Variable in class org.apache.struts2.util.AppendIteratorFilter

iterators - Variable in class org.apache.struts2.util.MergeIteratorFilter

IteratorStatus - Class in org.apache.struts2.views.jsp
The iterator tag can export an IteratorStatus object so that one can get information about the status of the iteration, such as the size, current index, and whether any more items are available.
IteratorStatus(IteratorStatus.StatusState) - Constructor for class org.apache.struts2.views.jsp.IteratorStatus

IteratorStatus.StatusState - Class in org.apache.struts2.views.jsp

IteratorStatus.StatusState() - Constructor for class org.apache.struts2.views.jsp.IteratorStatus.StatusState

IteratorTag - Class in org.apache.struts2.views.jsp

IteratorTag() - Constructor for class org.apache.struts2.views.jsp.IteratorTag

J

JakartaMultiPartRequest - Class in org.apache.struts2.dispatcher.multipart
Multipart form data request adapter for Jakarta Commons Fileupload package.
JakartaMultiPartRequest() - Constructor for class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

join(String, Iterator) - Static method in class com.opensymphony.xwork2.util.TextUtils
Join an Iteration of Strings together.
join(String, String[]) - Static method in class com.opensymphony.xwork2.util.TextUtils
Join an array of Strings together.
join(String, Collection) - Static method in class com.opensymphony.xwork2.util.TextUtils
Join a Collection of Strings together.
JspSupportServlet - Class in org.apache.struts2.views

JspSupportServlet() - Constructor for class org.apache.struts2.views.JspSupportServlet

jspSupportServlet - Static variable in class org.apache.struts2.views.JspSupportServlet

JspTemplateEngine - Class in org.apache.struts2.components.template
JSP based template engine.
JspTemplateEngine() - Constructor for class org.apache.struts2.components.template.JspTemplateEngine

Jsr168Dispatcher - Class in org.apache.struts2.portlet.dispatcher

Jsr168Dispatcher() - Constructor for class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

K

key - Variable in class com.opensymphony.xwork2.inject.ExternalContext

Key<T> - Class in com.opensymphony.xwork2.inject
Dependency mapping key.
Key(Class<T>, String) - Constructor for class com.opensymphony.xwork2.inject.Key

key - Variable in class com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate

key - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

Key - Annotation Type in com.opensymphony.xwork2.util

Sets the Key for type conversion.
key - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

key - Variable in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

key - Variable in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

key - Variable in class org.apache.struts2.components.Debug.DebugMapEntry

key - Variable in class org.apache.struts2.components.UIBean

KEY - Static variable in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

key - Variable in class org.apache.struts2.interceptor.ScopeInterceptor

key - Variable in class org.apache.struts2.util.ListEntry

key - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

key - Variable in class org.apache.struts2.views.xslt.MapAdapter.EntryElement

KEY_APPLICATION - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

KEY_EXCEPTION - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

KEY_JSP_TAGLIBS - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

KEY_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

KEY_PREFIX - Static variable in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer

KEY_PROPERTY_FOR_CREATION - Static variable in class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

KEY_PROPERTY_PREFIX - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

KEY_PROPERTY_PREFIX - Static variable in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer

KEY_REQUEST_MODEL - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

KEY_REQUEST_PARAMETER_MODEL - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

KEY_SESSION_MODEL - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

keyClass - Variable in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

keyHashCode(Object) - Static method in class com.opensymphony.xwork2.inject.util.ReferenceMap

keyName - Variable in class org.apache.struts2.components.Autocompleter

keyName - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

keyProperty - Variable in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

KeyProperty - Annotation Type in com.opensymphony.xwork2.util

Sets the KeyProperty for type conversion.
keyReference - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference

keyReference - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference

keyReferenceType - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap

keySet() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Returns an unmodifiable set view of the keys in this map.
keySet() - Method in class org.apache.struts2.util.AttributeMap

keySet() - Method in class org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel

L

Label - Class in org.apache.struts2.components
Renders an HTML LABEL that will allow you to output label:name combination that has the same format treatment as the rest of your UI controls.
Label(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Label

label - Variable in class org.apache.struts2.components.UIBean

label - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

label - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

label - Variable in class org.apache.struts2.views.jsp.ui.OptGroupTag

LabelDirective - Class in org.apache.struts2.views.velocity.components

LabelDirective() - Constructor for class org.apache.struts2.views.velocity.components.LabelDirective

LabelModel - Class in org.apache.struts2.views.freemarker.tags

LabelModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.LabelModel

labelPosition - Variable in class org.apache.struts2.components.UIBean

labelPosition - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

LabelTag - Class in org.apache.struts2.views.jsp.ui

LabelTag() - Constructor for class org.apache.struts2.views.jsp.ui.LabelTag

language - Variable in class org.apache.struts2.components.DateTimePicker

language - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

last - Variable in class org.apache.struts2.util.Counter

last - Variable in class org.apache.struts2.views.jsp.IteratorStatus.StatusState

LAST_BEAN_CLASS_ACCESSED - Static variable in class com.opensymphony.xwork2.util.XWorkConverter

LAST_BEAN_PROPERTY_ACCESSED - Static variable in class com.opensymphony.xwork2.util.XWorkConverter

lastClassAccessed - Variable in class com.opensymphony.xwork2.util.ObjectProxy

lastFinalLocation - Variable in class org.apache.struts2.dispatcher.StrutsResultSupport

lastIndexOfArray(int[], int, int, char[], int) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Get the offset of a last occurance of an int array within a char array.
lastModified - Variable in class com.opensymphony.xwork2.util.FileManager.FileRevision

lastModifiedCal - Variable in class org.apache.struts2.dispatcher.FilterDispatcher
Provide a formatted date for setting heading information when caching static content.
lastPropertyAccessed - Variable in class com.opensymphony.xwork2.util.ObjectProxy

leftDownlabel - Variable in class org.apache.struts2.components.OptionTransferSelect

leftDownLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

leftTitle - Variable in class org.apache.struts2.components.InputTransferSelect

leftTitle - Variable in class org.apache.struts2.components.OptionTransferSelect

leftTitle - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

leftTitle - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

leftUpLabel - Variable in class org.apache.struts2.components.OptionTransferSelect

leftUpLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

LegacyPropertiesConfigurationProvider - Class in org.apache.struts2.config

LegacyPropertiesConfigurationProvider() - Constructor for class org.apache.struts2.config.LegacyPropertiesConfigurationProvider

line - Variable in class com.opensymphony.xwork2.util.location.LocationImpl

LINE_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute name for the line number
lineIndenter - Variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

link(Map, Class, String) - Static method in class com.opensymphony.xwork2.util.OgnlValueStack

LinkCellRenderer - Class in org.apache.struts2.components.table.renderer

LinkCellRenderer() - Constructor for class org.apache.struts2.components.table.renderer.LinkCellRenderer

list - Variable in class org.apache.struts2.components.ComboBox

list - Variable in class org.apache.struts2.components.ListUIBean

list() - Static method in class org.apache.struts2.config.Settings
Provides an Iterator of all properties names.
list - Variable in class org.apache.struts2.util.SortIteratorFilter

list - Variable in class org.apache.struts2.views.jsp.ui.AbstractListTag

list - Variable in class org.apache.struts2.views.jsp.ui.ComboBoxTag

list - Variable in class org.apache.struts2.views.jsp.ui.OptGroupTag

listenTopics - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

listenTopics - Variable in class org.apache.struts2.components.Autocompleter

listenTopics - Variable in class org.apache.struts2.components.Submit

listenTopics - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

listenTopics - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

listenTopics - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

ListEntry - Class in org.apache.struts2.util
Entry in a list.
ListEntry(Object, Object, boolean) - Constructor for class org.apache.struts2.util.ListEntry

listImpl() - Method in class org.apache.struts2.config.DefaultSettings

listImpl() - Method in class org.apache.struts2.config.DelegatingSettings

listImpl() - Method in class org.apache.struts2.config.PropertiesSettings
Lists all keys in the properties file.
listImpl() - Method in class org.apache.struts2.config.Settings
Implements the Settings.list() method.
listKey - Variable in class org.apache.struts2.components.ComboBox

listKey - Variable in class org.apache.struts2.components.ListUIBean

listKey - Variable in class org.apache.struts2.views.jsp.ui.AbstractListTag

listKey - Variable in class org.apache.struts2.views.jsp.ui.ComboBoxTag

listKey - Variable in class org.apache.struts2.views.jsp.ui.OptGroupTag

ListUIBean - Class in org.apache.struts2.components
DoubleListUIBean is the standard superclass of all Struts list handling components.
ListUIBean(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.ListUIBean

listValue - Variable in class org.apache.struts2.components.ComboBox

listValue - Variable in class org.apache.struts2.components.ListUIBean

listValue - Variable in class org.apache.struts2.views.jsp.ui.AbstractListTag

listValue - Variable in class org.apache.struts2.views.jsp.ui.ComboBoxTag

listValue - Variable in class org.apache.struts2.views.jsp.ui.OptGroupTag

load(InputStream) - Method in class com.opensymphony.xwork2.util.location.LocatableProperties

loadClass(String, Class) - Static method in class com.opensymphony.xwork2.util.ClassLoaderUtil
Load a class with a given name.
loadClass(String, Class) - Static method in class org.apache.struts2.util.ClassLoaderUtils
Load a class with a given name.
loadConfiguration(ServletContext) - Method in class org.apache.struts2.views.velocity.VelocityManager
load optional velocity properties using the following loading strategy relative to the servlet context path relative to the WEB-INF directory on the classpath
loadConfigurationFiles(String, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadConfigurationProviders(ConfigurationProvider...) - Method in class com.opensymphony.xwork2.TestNGXWorkTestCase

loadConfigurationProviders(ConfigurationManager, ConfigurationProvider...) - Static method in class com.opensymphony.xwork2.util.XWorkTestCaseHelper

loadConfigurationProviders(ConfigurationProvider...) - Method in class com.opensymphony.xwork2.XWorkTestCase

loadConversionProperties(String) - Method in class com.opensymphony.xwork2.util.XWorkConverter

loadDefaultActionRef(PackageConfig, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadDefaultClassRef(PackageConfig, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadDefaultInterceptorRef(PackageConfig, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadDocuments(String) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loaded - Variable in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

loadedFileNames - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

loadedFiles - Variable in class com.opensymphony.xwork2.config.impl.MockConfiguration

loadedFileUrls - Variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadedPackageConfigs - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
The package configurations for scanned Actions.
loadExtraConfiguration(Document) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Allows subclasses to load extra information from the document
loadFile(String, Class) - Static method in class com.opensymphony.xwork2.util.FileManager
Loads opens the named file and returns the InputStream
loadFile(URL) - Static method in class com.opensymphony.xwork2.util.FileManager
Loads opens the named file and returns the InputStream
loadFile(String, Class, boolean) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

loadFile(String, Class, boolean) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager

loadGlobalResults(PackageConfig, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Load all of the global results for this package from the XML element.
loadGobalExceptionMappings(PackageConfig, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Load all of the global results for this package from the XML element.
loadImplementationsInDirectory(ResolverUtil.Test, String, File) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Finds matches in a physical directory on a filesystem.
loadImplementationsInJar(ResolverUtil.Test, String, File) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Finds matching classes within a jar files that contains a folder structure matching the package structure.
loadingText - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

loadingText - Variable in class org.apache.struts2.components.Submit

loadingText - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

loadingText - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

loadInterceptors(PackageConfig, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadInterceptorStack(Element, PackageConfig) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadInterceptorStacks(Element, PackageConfig) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadInvocation(String, String) - Static method in class org.apache.struts2.util.InvocationSessionStore
Checks the Map in the Session for the key and the token.
loadMinimumCount - Variable in class org.apache.struts2.components.Autocompleter

loadMinimumCount - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

loadNext() - Method in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

loadOnTextChange - Variable in class org.apache.struts2.components.Autocompleter

loadOnTextChange - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

loadPackageConfig(String, String, Class) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Finds or creates the package configuration for an Action class.
loadPackages() - Method in interface com.opensymphony.xwork2.config.ConfigurationProvider

loadPackages() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

loadPackages() - Method in class org.apache.struts2.config.BeanSelectionProvider

loadPackages(String[]) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Scan a list of packages for Action classes.
loadPackages() - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Clears and loads the list of packages registered at construction.
loadPackages() - Method in class org.apache.struts2.config.LegacyPropertiesConfigurationProvider

loadPackages() - Method in class org.apache.struts2.config.MethodConfigurationProvider

loadPackages() - Method in class org.apache.struts2.config.StrutsXmlConfigurationProvider

loadSettings(LocatableProperties, Settings) - Method in class org.apache.struts2.config.LegacyPropertiesConfigurationProvider

loadSettings(ServletContext, Configuration) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager
Load the settings from the /freemarker.properties file on the classpath
localContext - Variable in class com.opensymphony.xwork2.inject.ContainerImpl

LOCALE - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's locale.
locale - Variable in class com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey

locale - Static variable in class org.apache.struts2.config.Settings
An instance of the default locale as specified by the struts.locale setting.
localeFromString(String, Locale) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Builds a Locale from a String of the form en_US_foo into a Locale with language "en", country "US" and variant "foo".
LocaleProvider - Interface in com.opensymphony.xwork2
Indicates that the implementing class can provide its own Locale.
localeProvider - Variable in class com.opensymphony.xwork2.TextProviderSupport

localeProvider - Variable in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

localFuture - Variable in class com.opensymphony.xwork2.inject.util.ReferenceCache

LocalizedTextUtil - Class in com.opensymphony.xwork2.util
Provides support for localization in XWork.
LocalizedTextUtil() - Constructor for class com.opensymphony.xwork2.util.LocalizedTextUtil

LocalizedTextUtil.GetDefaultMessageReturnArg - Class in com.opensymphony.xwork2.util

LocalizedTextUtil.GetDefaultMessageReturnArg(String, boolean) - Constructor for class com.opensymphony.xwork2.util.LocalizedTextUtil.GetDefaultMessageReturnArg

LocalizedTextUtil.MessageFormatKey - Class in com.opensymphony.xwork2.util

LocalizedTextUtil.MessageFormatKey(String, Locale) - Constructor for class com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey

localScopeStrategy - Variable in class com.opensymphony.xwork2.inject.ContainerImpl

Locatable - Interface in com.opensymphony.xwork2.util.location
A interface that should be implemented by objects knowning their location (i.e.
LocatableConstantFactory<T> - Class in com.opensymphony.xwork2.config.impl
Factory that remembers where a constant came from
LocatableConstantFactory(T, Object) - Constructor for class com.opensymphony.xwork2.config.impl.LocatableConstantFactory

LocatableFactory<T> - Class in com.opensymphony.xwork2.config.impl
Attaches location information to the factory.
LocatableFactory(String, Class, Class, Scope, Object) - Constructor for class com.opensymphony.xwork2.config.impl.LocatableFactory

LocatableProperties - Class in com.opensymphony.xwork2.util.location
Properties implementation that remembers the location of each property.
LocatableProperties() - Constructor for class com.opensymphony.xwork2.util.location.LocatableProperties

LocatableProperties(Location) - Constructor for class com.opensymphony.xwork2.util.location.LocatableProperties

locate(String) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider.ClasspathPageLocator

locate(String) - Method in interface org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator

locate(String) - Method in class org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator

Located - Class in com.opensymphony.xwork2.util.location
Base class for location aware objects
Located() - Constructor for class com.opensymphony.xwork2.util.location.Located

location - Variable in class com.opensymphony.xwork2.util.location.LocatableProperties

location - Variable in class com.opensymphony.xwork2.util.location.Located

Location - Interface in com.opensymphony.xwork2.util.location
A location in a resource.
location - Variable in exception com.opensymphony.xwork2.XWorkException

location - Variable in class org.apache.struts2.dispatcher.StrutsResultSupport

location - Variable in class org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction

location - Variable in class org.apache.struts2.views.freemarker.FreemarkerResult

location - Variable in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

LocationAttributes - Class in com.opensymphony.xwork2.util.location
A class to handle location information stored in attributes.
LocationAttributes() - Constructor for class com.opensymphony.xwork2.util.location.LocationAttributes

LocationAttributes.Pipe - Class in com.opensymphony.xwork2.util.location
A SAX filter that adds the information available from the Locator as attributes.
LocationAttributes.Pipe() - Constructor for class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
Create a filter.
LocationAttributes.Pipe(ContentHandler) - Constructor for class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe
Create a filter that is chained to another handler.
LocationImpl - Class in com.opensymphony.xwork2.util.location
A simple immutable and serializable implementation of Location.
LocationImpl(String, String) - Constructor for class com.opensymphony.xwork2.util.location.LocationImpl
Build a location for a given URI, with unknown line and column numbers.
LocationImpl(String, String, int, int) - Constructor for class com.opensymphony.xwork2.util.location.LocationImpl
Build a location for a given URI and line and column numbers.
LocationImpl(Location) - Constructor for class com.opensymphony.xwork2.util.location.LocationImpl
Copy constructor.
LocationImpl(String, Location) - Constructor for class com.opensymphony.xwork2.util.location.LocationImpl
Create a location from an existing one, but with a different description
LocationUtils - Class in com.opensymphony.xwork2.util.location
Location-related utility methods.
LocationUtils() - Constructor for class com.opensymphony.xwork2.util.location.LocationUtils

LocationUtils.LocationFinder - Interface in com.opensymphony.xwork2.util.location
An finder or object locations
locator - Variable in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

lock(Object, ActionInvocation) - Static method in class org.apache.struts2.interceptor.ScopeInterceptor

locks - Static variable in class org.apache.struts2.interceptor.ScopeInterceptor

log - Static variable in class com.opensymphony.xwork2.ActionChainResult

LOG - Static variable in class com.opensymphony.xwork2.ActionSupport

LOG - Static variable in class com.opensymphony.xwork2.config.ConfigurationManager

LOG - Static variable in class com.opensymphony.xwork2.config.ConfigurationUtil

LOG - Static variable in class com.opensymphony.xwork2.config.entities.PackageConfig

log - Static variable in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
The logging instance
LOG - Static variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

LOG - Static variable in class com.opensymphony.xwork2.config.providers.InterceptorBuilder

LOG - Static variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

log - Static variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Jakarta commons-logging reference.
LOG - Static variable in class com.opensymphony.xwork2.DefaultActionInvocation

LOG - Static variable in class com.opensymphony.xwork2.DefaultActionProxy

log - Static variable in class com.opensymphony.xwork2.interceptor.AliasInterceptor

log - Static variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

log - Static variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor

log - Static variable in class com.opensymphony.xwork2.interceptor.LoggingInterceptor

log - Variable in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

LOG - Static variable in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

LOG - Static variable in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

LOG - Static variable in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

LOG - Static variable in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

log - Static variable in class com.opensymphony.xwork2.interceptor.TimerInterceptor

LOG - Static variable in class com.opensymphony.xwork2.ObjectFactory

log - Static variable in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

log - Static variable in class com.opensymphony.xwork2.spring.SpringObjectFactory

log - Static variable in class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory

log - Static variable in class com.opensymphony.xwork2.util.CompoundRootAccessor

LOG - Static variable in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer

LOG - Static variable in class com.opensymphony.xwork2.util.DomHelper

LOG - Static variable in class com.opensymphony.xwork2.util.InstantiatingNullHandler

LOG - Static variable in class com.opensymphony.xwork2.util.LocalizedTextUtil

LOG - Static variable in class com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory

log - Static variable in class com.opensymphony.xwork2.util.OgnlUtil

LOG - Static variable in class com.opensymphony.xwork2.util.OgnlValueStack

log - Static variable in class com.opensymphony.xwork2.util.profiling.UtilTimerStack

log - Static variable in class com.opensymphony.xwork2.util.ResolverUtil
An instance of Log to use for logging in this class.
LOG - Static variable in class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

LOG - Static variable in class com.opensymphony.xwork2.util.XWorkConverter

LOG - Static variable in class com.opensymphony.xwork2.util.XWorkList
Deprecated.
LOG - Static variable in class com.opensymphony.xwork2.validator.ActionValidatorManagerFactory

LOG - Static variable in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

LOG - Static variable in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager

log - Variable in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

log - Static variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Jakarta commons-logging reference.
LOG - Static variable in class com.opensymphony.xwork2.validator.ValidatorFactory

log - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

LOG - Static variable in class org.apache.struts2.components.ActionComponent

log - Static variable in class org.apache.struts2.components.Bean

LOG - Static variable in class org.apache.struts2.components.ClosingUIBean

LOG - Static variable in class org.apache.struts2.components.Date

LOG - Static variable in class org.apache.struts2.components.DateTimePicker

log - Static variable in class org.apache.struts2.components.File

LOG - Static variable in class org.apache.struts2.components.Property

LOG - Static variable in class org.apache.struts2.components.Submit

LOG - Static variable in class org.apache.struts2.components.table.WebTable

LOG - Static variable in class org.apache.struts2.components.template.BaseTemplateEngine

LOG - Static variable in class org.apache.struts2.components.template.FreemarkerTemplateEngine

LOG - Static variable in class org.apache.struts2.components.template.JspTemplateEngine

LOG - Static variable in class org.apache.struts2.components.template.VelocityTemplateEngine

LOG - Static variable in class org.apache.struts2.components.Text

LOG - Static variable in class org.apache.struts2.components.UIBean

LOG - Static variable in class org.apache.struts2.components.URL

LOG - Static variable in class org.apache.struts2.config.BeanSelectionProvider

LOG - Static variable in class org.apache.struts2.config.ClasspathConfigurationProvider
Logging instance for this class.
log - Variable in class org.apache.struts2.config.DefaultSettings
The logging instance for this class.
LOG - Static variable in class org.apache.struts2.config.PropertiesSettings

LOG - Static variable in class org.apache.struts2.config.Settings
The Logging instance for this class.
LOG - Static variable in class org.apache.struts2.config.StrutsXmlConfigurationProvider

LOG - Static variable in class org.apache.struts2.dispatcher.ActionContextCleanUp

LOG - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Provide a logging instance.
LOG - Static variable in class org.apache.struts2.dispatcher.FilterDispatcher
Provide a logging instance.
log - Static variable in class org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61

LOG - Static variable in class org.apache.struts2.dispatcher.mapper.CompositeActionMapper

LOG - Static variable in class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

LOG - Static variable in class org.apache.struts2.dispatcher.mapper.RestfulActionMapper

log - Static variable in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

log - Static variable in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

log - Static variable in class org.apache.struts2.dispatcher.ServletDispatcherResult

log - Static variable in class org.apache.struts2.dispatcher.ServletRedirectResult

log - Static variable in class org.apache.struts2.dispatcher.StreamResult

log - Static variable in class org.apache.struts2.dispatcher.VelocityResult

log - Static variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

LOG - Static variable in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

log - Static variable in class org.apache.struts2.interceptor.FileUploadInterceptor

LOG - Static variable in class org.apache.struts2.interceptor.ScopeInterceptor

LOG - Static variable in class org.apache.struts2.portlet.context.PreparatorServlet

LOG - Static variable in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

LOG - Static variable in class org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor

LOG - Static variable in class org.apache.struts2.portlet.PortletRequestMap

LOG - Static variable in class org.apache.struts2.portlet.PortletSessionMap

LOG - Static variable in class org.apache.struts2.portlet.result.PortletResult
Logger instance.
log - Static variable in class org.apache.struts2.portlet.result.PortletVelocityResult

LOG - Static variable in class org.apache.struts2.portlet.util.PortletUrlHelper

log - Static variable in class org.apache.struts2.util.StrutsUtil

LOG - Static variable in class org.apache.struts2.util.TokenHelper

LOG - Static variable in class org.apache.struts2.validators.DWRValidator

log - Static variable in class org.apache.struts2.views.freemarker.FreemarkerManager

LOG - Static variable in class org.apache.struts2.views.freemarker.tags.TagModel

log - Static variable in class org.apache.struts2.views.jsp.BeanTag

LOG - Static variable in class org.apache.struts2.views.util.UrlHelper

log - Static variable in class org.apache.struts2.views.velocity.VelocityManager

log - Variable in class org.apache.struts2.views.xslt.AbstractAdapterNode

log - Variable in class org.apache.struts2.views.xslt.ArrayAdapter

log - Variable in class org.apache.struts2.views.xslt.BeanAdapter

log - Variable in class org.apache.struts2.views.xslt.CollectionAdapter

log - Variable in class org.apache.struts2.views.xslt.ProxyElementAdapter

log - Variable in class org.apache.struts2.views.xslt.ProxyNodeAdapter

log - Variable in class org.apache.struts2.views.xslt.ServletURIResolver

log - Variable in class org.apache.struts2.views.xslt.SimpleNodeList

log - Variable in class org.apache.struts2.views.xslt.StringAdapter

LOG - Static variable in class org.apache.struts2.views.xslt.XSLTResult
Log instance for this result.
logCategory - Variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

logCategory - Variable in class com.opensymphony.xwork2.interceptor.TimerInterceptor

logEnabled - Variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

logger - Static variable in class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

LOGGER_FACTORY - Static variable in class com.opensymphony.xwork2.inject.ContainerBuilder

LoggingInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor logs the the start and end of the execution an action (in English-only, not internationalized).
LoggingInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.LoggingInterceptor

LOGIN - Static variable in interface com.opensymphony.xwork2.Action
The action could not execute, since the user most was not logged in.
logLevel - Variable in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

logLevel - Variable in class com.opensymphony.xwork2.interceptor.TimerInterceptor

logLookupFailure(String, Exception) - Method in class com.opensymphony.xwork2.util.OgnlValueStack
Log a failed lookup, being more verbose when devMode=true.
logMessage(ActionInvocation, String) - Method in class com.opensymphony.xwork2.interceptor.LoggingInterceptor

lookup(String) - Method in class com.opensymphony.xwork2.util.XWorkConverter
Looks for a TypeConverter in the default mappings.
lookup(Class) - Method in class com.opensymphony.xwork2.util.XWorkConverter
Looks for a TypeConverter in the default mappings.
lookupInterceptorReference(PackageConfig, Element) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Looks up the Interceptor Class from the interceptor-ref name and creates an instance, which is added to the provided List, or, if this is a ref to a stack, it adds the Interceptor instances from the List to this stack.
lookupNamespaceURI(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

lookupPrefix(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

lookupRegisteredValidatorType(String) - Static method in class com.opensymphony.xwork2.validator.ValidatorFactory
Lookup to get the FQ classname of the given validator name.
lookupSuper(Class) - Method in class com.opensymphony.xwork2.util.XWorkConverter
Recurses through a class' interfaces and class hierarchy looking for a TypeConverter in the default mapping that can handle the specified class.
LT - Static variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

M

MakeIterator - Class in org.apache.struts2.util
MakeIterator.
MakeIterator() - Constructor for class org.apache.struts2.util.MakeIterator

makeKey(String, String, String) - Method in class com.opensymphony.xwork2.ActionChainResult

makeKeyReferenceAware(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Wraps key so it can be compared to a referenced key for equality.
makeLocaleProvider(Object) - Static method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

makeSelectList(String, String, String, String) - Method in class org.apache.struts2.util.StrutsUtil
the selectedList objects are matched to the list.listValue
listKey and listValue are optional, and if not provided, the list item is used
makeTextProvider(Object, LocaleProvider) - Static method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

makeValidationAware(Object) - Static method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

makeValueReferenceAware(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Wraps value so it can be compared to a referenced value for equality.
map() - Method in class org.apache.struts2.views.xslt.MapAdapter

MAP_IDENTIFIER_KEY - Static variable in class com.opensymphony.xwork2.util.OgnlValueStack

MAP_PREFIX - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Key used for type conversion of maps.
MapAdapter - Class in org.apache.struts2.views.xslt
MapAdapter adapters a java.util.Map type to an XML DOM with the following structure:
MapAdapter() - Constructor for class org.apache.struts2.views.xslt.MapAdapter

MapAdapter(AdapterFactory, AdapterNode, String, Map) - Constructor for class org.apache.struts2.views.xslt.MapAdapter

MapAdapter.EntryElement - Class in org.apache.struts2.views.xslt

MapAdapter.EntryElement(AdapterFactory, AdapterNode, String, Object, Object) - Constructor for class org.apache.struts2.views.xslt.MapAdapter.EntryElement

mappings - Variable in class com.opensymphony.xwork2.util.XWorkConverter
Target class conversion Mappings.
match(String) - Method in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Matches the path against the compiled wildcard patterns.
match(Map, String, int[]) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Match a pattern agains a string and isolates wildcard replacement into a Stack.
MATCH_BEGIN - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int representing begin in the pattern int [].
MATCH_END - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int value that terminates the pattern int [].
MATCH_FILE - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int representing '*' in the pattern int [].
MATCH_PATH - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int representing '**' in the pattern int [].
MATCH_THEEND - Static variable in class com.opensymphony.xwork2.util.WildcardHelper
The int representing end in pattern int [].
matchArray(int[], int, int, char[], int) - Method in class com.opensymphony.xwork2.util.WildcardHelper
Matches elements of array r from rpos to rend with array d, starting from dpos.
matches(Class) - Method in class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
Returns true if the type is annotated with the class provided to the constructor.
matches(Class) - Method in class com.opensymphony.xwork2.util.ResolverUtil.IsA
Returns true if type is assignable to the parent type supplied in the constructor.
matches - Variable in class com.opensymphony.xwork2.util.ResolverUtil
The set of matches being accumulated.
matches(Class) - Method in class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
Returns true if type name ends with the suffix supplied in the constructor.
matches(Class) - Method in interface com.opensymphony.xwork2.util.ResolverUtil.Test
Will be called repeatedly with candidate classes.
matchingPattern - Variable in class org.apache.struts2.views.xslt.XSLTResult
Indicates the property name patterns which should be exposed to the xml.
max - Variable in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

max - Variable in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

max - Variable in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

max - Variable in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

max - Variable in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

MAX_LENGTH - Static variable in class org.apache.struts2.views.util.TextUtil

maxExclusive - Variable in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

maxExclusiveValue - Variable in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

maximumSize - Variable in class org.apache.struts2.interceptor.FileUploadInterceptor

maxInclusive - Variable in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

maxInclusiveValue - Variable in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

maxLength - Variable in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

maxLength - Variable in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

maxlength - Variable in class org.apache.struts2.components.TextField

maxlength - Variable in class org.apache.struts2.views.jsp.ui.TextFieldTag

maxSize - Variable in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

member - Variable in class com.opensymphony.xwork2.inject.ExternalContext

mergeCollection(Collection, Collection) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor
Merge col1 and col2 and return the composite Collection.
MergeIterator - Class in org.apache.struts2.components

MergeIterator(ValueStack) - Constructor for class org.apache.struts2.components.MergeIterator

mergeIteratorFilter - Variable in class org.apache.struts2.components.MergeIterator

MergeIteratorFilter - Class in org.apache.struts2.util
A bean that takes several iterators and outputs the merge of them.
MergeIteratorFilter() - Constructor for class org.apache.struts2.util.MergeIteratorFilter

MergeIteratorTag - Class in org.apache.struts2.views.jsp.iterator
Append a list of iterators.
MergeIteratorTag() - Constructor for class org.apache.struts2.views.jsp.iterator.MergeIteratorTag

mergeMap(Map, Map) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor
Merge map1 and map2 and return the composite Map
mergeParams(Enumeration, Enumeration) - Method in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Merges 2 enumeration of parameters as one.
mergeRequestParameters(String, Map, Map) - Method in class org.apache.struts2.components.URL
Merge request parameters into current parameters.
mergeTemplate(Writer, Template) - Method in class org.apache.struts2.components.UIBean

message - Variable in class com.opensymphony.xwork2.util.LocalizedTextUtil.GetDefaultMessageReturnArg

message - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

message - Variable in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

message - Variable in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

message - Variable in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

messageFormats - Static variable in class com.opensymphony.xwork2.util.LocalizedTextUtil

messageKey - Variable in class com.opensymphony.xwork2.validator.ValidatorConfig

messageKey - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

MessageStoreInterceptor - Class in org.apache.struts2.interceptor
An interceptor to store ValidationAware action's messages / errors and field errors into Http Session, such that it will be retrieveable at a later stage.
MessageStoreInterceptor() - Constructor for class org.apache.struts2.interceptor.MessageStoreInterceptor

method - Variable in class com.opensymphony.xwork2.DefaultActionProxy

method - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector

method - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

method - Variable in class org.apache.struts2.components.Form

method - Variable in class org.apache.struts2.components.FormButton

method - Variable in class org.apache.struts2.components.Reset

method - Variable in class org.apache.struts2.components.URL

method - Variable in class org.apache.struts2.dispatcher.mapper.ActionMapping

method - Variable in class org.apache.struts2.dispatcher.ServletActionRedirectResult

method - Variable in class org.apache.struts2.views.jsp.ui.FormTag

method - Variable in class org.apache.struts2.views.jsp.ui.ResetTag

method - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

method - Variable in class org.apache.struts2.views.jsp.URLTag

METHOD_PREFIX - Static variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

MethodConfigurationProvider - Class in org.apache.struts2.config
MethodConfigurationProvider creates ActionConfigs for potential action methods that lack a corresponding action mapping, so that these methods can be invoked without extra or redundant configuration.
MethodConfigurationProvider() - Constructor for class org.apache.struts2.config.MethodConfigurationProvider

MethodFilterInterceptor - Class in com.opensymphony.xwork2.interceptor
An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.
MethodFilterInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

MethodFilterInterceptorUtil - Class in com.opensymphony.xwork2.interceptor
Utility class contains common methods used by MethodFilterInterceptor.
MethodFilterInterceptorUtil() - Constructor for class com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil

methodName - Variable in class com.opensymphony.xwork2.ActionChainResult

methodName - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig

MILLISECOND_FORMAT - Static variable in class com.opensymphony.xwork2.util.XWorkBasicConverter

min - Variable in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

min - Variable in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

min - Variable in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

min - Variable in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

min - Variable in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

MIN_TIME - Static variable in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
System property that controls the min time, that if exceeded will cause a log (at INFO level) to be created.
minExclusive - Variable in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

minExclusiveValue - Variable in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

minInclusive - Variable in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

minInclusiveValue - Variable in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

minLength - Variable in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

minLength - Variable in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

misses - Static variable in class com.opensymphony.xwork2.util.LocalizedTextUtil

MISSING_ACTION_EXCEPTION - Static variable in interface com.opensymphony.xwork2.XWorkMessages

MISSING_PACKAGE_ACTION_EXCEPTION - Static variable in interface com.opensymphony.xwork2.XWorkMessages

MockActionInvocation - Class in com.opensymphony.xwork2.mock
Mock for an ActionInvocation.
MockActionInvocation() - Constructor for class com.opensymphony.xwork2.mock.MockActionInvocation

MockActionInvocation - Class in com.opensymphony.xwork2
Deprecated. Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead
MockActionInvocation() - Constructor for class com.opensymphony.xwork2.MockActionInvocation
Deprecated.
MockActionProxy - Class in com.opensymphony.xwork2.mock
Mock for an ActionProxy.
MockActionProxy() - Constructor for class com.opensymphony.xwork2.mock.MockActionProxy

MockConfiguration - Class in com.opensymphony.xwork2.config.impl
Simple configuration used for unit testing
MockConfiguration() - Constructor for class com.opensymphony.xwork2.config.impl.MockConfiguration

MockInterceptor - Class in com.opensymphony.xwork2.mock
Mock for an Interceptor.
MockInterceptor() - Constructor for class com.opensymphony.xwork2.mock.MockInterceptor

MockObjectTypeDeterminer - Class in com.opensymphony.xwork2.mock
Mocks the function of an ObjectTypeDeterminer for testing purposes.
MockObjectTypeDeterminer() - Constructor for class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

MockObjectTypeDeterminer(Class, Class, String, boolean) - Constructor for class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

MockResult - Class in com.opensymphony.xwork2.mock
Mock for a Result.
MockResult() - Constructor for class com.opensymphony.xwork2.mock.MockResult

MODE_NAMESPACE_MAP - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key for the mode-to-namespace map stored in the PortletActionContext.
MODE_PARAM - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key for parameter holding the last executed portlet mode.
model - Variable in class org.apache.struts2.components.table.AbstractFilterModel

model - Variable in class org.apache.struts2.components.table.WebTable

ModelDriven<T> - Interface in com.opensymphony.xwork2
ModelDriven Actions provide a model object to be pushed onto the ValueStack in addition to the Action itself, allowing a FormBean type approach like Struts.
ModelDrivenInterceptor - Class in com.opensymphony.xwork2.interceptor
Watches for ModelDriven actions and adds the action's model on to the value stack.
ModelDrivenInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor

modelName - Variable in class org.apache.struts2.components.table.WebTable

modelName - Variable in class org.apache.struts2.views.jsp.ui.table.WebTableTag

modeMap - Variable in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

modulus(int) - Method in class org.apache.struts2.views.jsp.IteratorStatus

moveDownLabel - Variable in class org.apache.struts2.components.UpDownSelect

moveDownLabel - Variable in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

moveUpLabel - Variable in class org.apache.struts2.components.UpDownSelect

moveUpLabel - Variable in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

multi - Variable in class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

MULTI_TEXTVALUE_SEPARATOR - Static variable in class com.opensymphony.xwork2.validator.ValidatorFileParser

MultiPartRequest - Interface in org.apache.struts2.dispatcher.multipart
Abstract wrapper class HTTP requests to handle multi-part data.
MultiPartRequestWrapper - Class in org.apache.struts2.dispatcher.multipart
Parse a multipart request and provide a wrapper around the request.
MultiPartRequestWrapper(MultiPartRequest, HttpServletRequest, String) - Constructor for class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper
Process file downloads and log any errors.
multipartSaveDir - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Store state of StrutsConstants.STRUTS_MULTIPART_SAVEDIR setting.
multiple - Variable in class org.apache.struts2.components.DoubleListUIBean

multiple - Variable in class org.apache.struts2.components.InputTransferSelect

multiple - Variable in class org.apache.struts2.components.Select

multiple - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

multiple - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

multiple - Variable in class org.apache.struts2.views.jsp.ui.SelectTag

N

name - Variable in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

name - Variable in class com.opensymphony.xwork2.config.entities.InterceptorConfig

name - Variable in class com.opensymphony.xwork2.config.entities.InterceptorMapping

name - Variable in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

name - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

name - Variable in class com.opensymphony.xwork2.config.entities.ResultConfig

name - Variable in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

name - Variable in class com.opensymphony.xwork2.config.impl.LocatableFactory

name - Variable in class com.opensymphony.xwork2.inject.Key

name - Variable in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

name - Variable in class com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

name - Variable in class org.apache.struts2.components.ActionComponent

name - Variable in class org.apache.struts2.components.Bean

name - Variable in class org.apache.struts2.components.Date

name - Variable in class org.apache.struts2.components.I18n

name - Variable in class org.apache.struts2.components.Param

name - Variable in class org.apache.struts2.components.Set

name - Variable in class org.apache.struts2.components.template.Template

name - Variable in class org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory

name - Variable in class org.apache.struts2.components.Text

name - Variable in class org.apache.struts2.components.UIBean

name - Variable in class org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory

name - Variable in class org.apache.struts2.dispatcher.mapper.ActionMapping

name - Variable in class org.apache.struts2.views.jsp.ActionTag

name - Variable in class org.apache.struts2.views.jsp.BeanTag

name - Variable in class org.apache.struts2.views.jsp.DateTag

name - Variable in class org.apache.struts2.views.jsp.I18nTag

name - Variable in class org.apache.struts2.views.jsp.ParamTag

name - Variable in class org.apache.struts2.views.jsp.SetTag

name - Variable in class org.apache.struts2.views.jsp.TextTag

name - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

namespace - Variable in class com.opensymphony.xwork2.ActionChainResult

namespace - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

namespace - Variable in class com.opensymphony.xwork2.DefaultActionProxy

namespace - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

namespace - Variable in class org.apache.struts2.components.ActionComponent

namespace - Variable in class org.apache.struts2.components.Form

namespace - Variable in class org.apache.struts2.components.URL

Namespace - Annotation Type in org.apache.struts2.config
Allows an action class to specify its namespace
namespace - Variable in class org.apache.struts2.dispatcher.mapper.ActionMapping

namespace - Variable in class org.apache.struts2.dispatcher.ServletActionRedirectResult

namespace - Variable in class org.apache.struts2.views.jsp.ActionTag

namespace - Variable in class org.apache.struts2.views.jsp.ui.FormTag

namespace - Variable in class org.apache.struts2.views.jsp.URLTag

namespaceActionConfigMatchers - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl

namespaceActionConfigs - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl

namespaceConfigs - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl

needsReload() - Method in interface com.opensymphony.xwork2.config.ConfigurationProvider
Tells whether the ConfigurationProvider should reload its configuration
needsReload() - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider
Tells whether the ConfigurationProvider should reload its configuration.
needsReload() - Method in class org.apache.struts2.config.BeanSelectionProvider

needsReload() - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Indicates whether the packages have been initialized.
needsReload() - Method in class org.apache.struts2.config.LegacyPropertiesConfigurationProvider

needsReload() - Method in class org.apache.struts2.config.MethodConfigurationProvider

needsReload() - Method in class org.apache.struts2.config.StrutsXmlConfigurationProvider
Overrides needs reload to ensure it is only checked once per request
newInstance(Member, Key<T>, ContainerImpl) - Static method in class com.opensymphony.xwork2.inject.ExternalContext

newInstance(Class<T>, String) - Static method in class com.opensymphony.xwork2.inject.Key

newLine - Variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

newVelocityEngine(ServletContext) - Method in class org.apache.struts2.views.velocity.VelocityManager

Instantiates a new VelocityEngine.
next - Variable in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

next() - Method in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

next() - Method in class org.apache.struts2.components.table.WebTable.WebTableRowIterator

next() - Method in class org.apache.struts2.util.AppendIteratorFilter

next() - Method in class org.apache.struts2.util.Counter

next() - Method in class org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator

next() - Method in class org.apache.struts2.util.IteratorGenerator

next() - Method in class org.apache.struts2.util.MergeIteratorFilter

next - Variable in class org.apache.struts2.util.PrefixTrie.Node

next() - Method in class org.apache.struts2.util.SortIteratorFilter

next() - Method in class org.apache.struts2.util.SubsetIteratorFilter

next() - Method in class org.apache.struts2.views.jsp.IteratorStatus.StatusState

nextHandler - Variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

nextHandler - Variable in class com.opensymphony.xwork2.util.DomHelper.StartHandler

nextHandler - Variable in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

nextProperty() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Parses the next property from the input stream and stores the found name and value in internal fields.
nice - Variable in class org.apache.struts2.components.Date

nice - Variable in class org.apache.struts2.views.jsp.DateTag

noCache - Variable in class org.apache.struts2.views.xslt.XSLTResult
Determines whether or not the result should allow caching.
node() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter
Get the proxied Node value
nodeIdProperty - Variable in class org.apache.struts2.components.Tree

nodeIdProperty - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

nodes - Variable in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

nodes - Variable in class org.apache.struts2.views.xslt.SimpleNodeList

nodeTitleProperty - Variable in class org.apache.struts2.components.Tree

nodeTitleProperty - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

noMapping - Variable in class com.opensymphony.xwork2.util.XWorkConverter
Unavailable target class conversion mappings, serves as a simple cache.
NONE - Static variable in interface com.opensymphony.xwork2.Action
The action execution was successful but do not show a view.
NONE - Static variable in interface org.apache.struts2.components.table.SortableTableModel

NONE - Static variable in class org.apache.struts2.components.URL
The includeParams attribute may have the value 'none', 'get' or 'all'.
NONE - Static variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

noNull(String, String) - Static method in class com.opensymphony.xwork2.util.TextUtils
Return string, or defaultString if string is null or "".
noNull(String) - Static method in class com.opensymphony.xwork2.util.TextUtils
Return string, or "" if string is null.
NoParameters - Interface in com.opensymphony.xwork2.interceptor
This marker interface should be implemented by actions that do not want any parameters set on them automatically (by the ParametersActionFactoryProxy) This may be useful if one is using the action tag and want to supply the parameters to the action manually using the param tag.
NoParameters - Interface in org.apache.struts2.interceptor
This marker interface should be implemented by actions that do not want any parameters set on them automatically.
normalize() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

normalizeDocument() - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

notifyTopics - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

notifyTopics - Variable in class org.apache.struts2.components.Autocompleter

notifyTopics - Variable in class org.apache.struts2.components.Submit

notifyTopics - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

notifyTopics - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

notifyTopics - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

NULL - Static variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

NULL - Static variable in class org.apache.struts2.interceptor.ScopeInterceptor

nullConvert(Object) - Static method in class org.apache.struts2.interceptor.ScopeInterceptor

nullMethodResult(Map, Object, String, Object[]) - Method in class com.opensymphony.xwork2.util.InstantiatingNullHandler

NULLPARAMS - Static variable in class org.apache.struts2.views.xslt.BeanAdapter

nullPropertyValue(Map, Object, Object) - Method in class com.opensymphony.xwork2.util.InstantiatingNullHandler

NullResult - Class in org.apache.struts2.config
Null result to get around annotation defaults that can't be null
NullResult() - Constructor for class org.apache.struts2.config.NullResult

NumericCellRenderer - Class in org.apache.struts2.components.table.renderer

NumericCellRenderer() - Constructor for class org.apache.struts2.components.table.renderer.NumericCellRenderer

O

o - Variable in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

objectFactory - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

objectFactory - Variable in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

objectFactory - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

objectFactory - Variable in class com.opensymphony.xwork2.DefaultActionProxy

objectFactory - Variable in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

ObjectFactory - Class in com.opensymphony.xwork2
ObjectFactory is responsible for building the core framework objects.
ObjectFactory() - Constructor for class com.opensymphony.xwork2.ObjectFactory

objectFactory - Variable in class org.apache.struts2.components.Bean

objectFactory - Variable in class org.apache.struts2.components.Form

objectFactory - Variable in class org.apache.struts2.views.velocity.VelocityManager

ObjectFactory.ContinuationsClassLoader - Class in com.opensymphony.xwork2

ObjectFactory.ContinuationsClassLoader() - Constructor for class com.opensymphony.xwork2.ObjectFactory.ContinuationsClassLoader

ObjectFactoryDestroyable - Interface in org.apache.struts2.util
An interface to be implemented by any ObjectFactory implementation if it requires shutdown hook whenever an ObjectFactory is to be destroyed.
ObjectProfiler - Class in com.opensymphony.xwork2.util.profiling

ObjectProfiler() - Constructor for class com.opensymphony.xwork2.util.profiling.ObjectProfiler

ObjectProxy - Class in com.opensymphony.xwork2.util
An Object to use within OGNL to proxy other Objects usually Collections that you set in a different place on the ValueStack but want to retain the context information about where they previously were.
ObjectProxy() - Constructor for class com.opensymphony.xwork2.util.ObjectProxy

ObjectProxyPropertyAccessor - Class in com.opensymphony.xwork2.util
Is able to access (set/get) properties on a given object.
ObjectProxyPropertyAccessor() - Constructor for class com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor

ObjectTypeDeterminer - Interface in com.opensymphony.xwork2.util
Determines what the key and and element class of a Map or Collection should be.
objectTypeDeterminer - Variable in class com.opensymphony.xwork2.util.XWorkConverter

ObjectTypeDeterminerFactory - Class in com.opensymphony.xwork2.util
Factory for getting an instance of ObjectTypeDeterminer.
ObjectTypeDeterminerFactory() - Constructor for class com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory

of(ReferenceType, ReferenceType, Function<? super K, ? extends V>) - Static method in class com.opensymphony.xwork2.inject.util.ReferenceCache
Returns a ReferenceCache delegating to the specified function.
ognl - Variable in class org.apache.struts2.util.StrutsUtil

OGNL - Static variable in class org.apache.struts2.views.util.ContextUtil

OgnlContextState - Class in com.opensymphony.xwork2.util
Manages variables in the OgnlContext and returns values to be used by the application.
OgnlContextState() - Constructor for class com.opensymphony.xwork2.util.OgnlContextState

OgnlTool - Class in org.apache.struts2.views.jsp.ui

OgnlTool() - Constructor for class org.apache.struts2.views.jsp.ui.OgnlTool

OgnlUtil - Class in com.opensymphony.xwork2.util
Utility class that provides common access to the Ognl APIs for setting and getting properties from objects (usually Actions).
OgnlUtil() - Constructor for class com.opensymphony.xwork2.util.OgnlUtil

OgnlValueStack - Class in com.opensymphony.xwork2.util
Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it.
OgnlValueStack() - Constructor for class com.opensymphony.xwork2.util.OgnlValueStack

OgnlValueStack(ValueStack) - Constructor for class com.opensymphony.xwork2.util.OgnlValueStack

OgnlValueStack.ObjectAccessor - Class in com.opensymphony.xwork2.util

OgnlValueStack.ObjectAccessor() - Constructor for class com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor

OgnlValueStackFactory - Class in com.opensymphony.xwork2.util
Creates an Ognl value stack
OgnlValueStackFactory() - Constructor for class com.opensymphony.xwork2.util.OgnlValueStackFactory

oldStatus - Variable in class org.apache.struts2.components.IteratorComponent

onblur - Variable in class org.apache.struts2.components.UIBean

onblur - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onchange - Variable in class org.apache.struts2.components.UIBean

onchange - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onclick - Variable in class org.apache.struts2.components.UIBean

onclick - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

ondblclick - Variable in class org.apache.struts2.components.UIBean

ondblclick - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onError(Throwable) - Method in class org.apache.struts2.views.freemarker.tags.CallbackWriter

onfocus - Variable in class org.apache.struts2.components.UIBean

onfocus - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onkeydown - Variable in class org.apache.struts2.components.UIBean

onkeydown - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onkeypress - Variable in class org.apache.struts2.components.UIBean

onkeypress - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onkeyup - Variable in class org.apache.struts2.components.UIBean

onkeyup - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onmousedown - Variable in class org.apache.struts2.components.UIBean

onmousedown - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onmousemove - Variable in class org.apache.struts2.components.UIBean

onmousemove - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onmouseout - Variable in class org.apache.struts2.components.UIBean

onmouseout - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onmouseover - Variable in class org.apache.struts2.components.UIBean

onmouseover - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onmouseup - Variable in class org.apache.struts2.components.UIBean

onmouseup - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onselect - Variable in class org.apache.struts2.components.UIBean

onselect - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

onStart() - Method in class org.apache.struts2.views.freemarker.tags.CallbackWriter

onsubmit - Variable in class org.apache.struts2.components.Form

onsubmit - Variable in class org.apache.struts2.views.jsp.ui.FormTag

opa - Variable in class com.opensymphony.xwork2.util.XWorkEnumerationAcccessor

opa - Variable in class com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor

OPEN_TEMPLATE - Static variable in class org.apache.struts2.components.Anchor

OPEN_TEMPLATE - Static variable in class org.apache.struts2.components.Form

OPEN_TEMPLATE - Static variable in class org.apache.struts2.components.Tree

OPEN_TEMPLATE - Static variable in class org.apache.struts2.components.TreeNode

openTemplate - Variable in class org.apache.struts2.components.ClosingUIBean

openTemplate - Variable in class org.apache.struts2.views.jsp.ui.AbstractClosingTag

operationMode - Variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

operationNotSupported() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

OptGroup - Class in org.apache.struts2.components
Create a optgroup component which needs to resides within a select tag.
OptGroup(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.OptGroup

OptGroupDirective - Class in org.apache.struts2.views.velocity.components
OptGroup velocity directive.
OptGroupDirective() - Constructor for class org.apache.struts2.views.velocity.components.OptGroupDirective

OptGroupModel - Class in org.apache.struts2.views.freemarker.tags
Freemarker's TransformModel for OptGroup component.
OptGroupModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.OptGroupModel

optGroupModel - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

OptGroupTag - Class in org.apache.struts2.views.jsp.ui

OptGroupTag() - Constructor for class org.apache.struts2.views.jsp.ui.OptGroupTag

OptionTransferSelect - Class in org.apache.struts2.components
Create a option transfer select component which is basically two <select ...> tag with buttons in the middle of them allowing options in each of the <select ...> to be moved between themselves.
OptionTransferSelect(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.OptionTransferSelect

optiontransferselect - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

OptionTransferSelectDirective - Class in org.apache.struts2.views.velocity.components

OptionTransferSelectDirective() - Constructor for class org.apache.struts2.views.velocity.components.OptionTransferSelectDirective

OptionTransferSelectModel - Class in org.apache.struts2.views.freemarker.tags

OptionTransferSelectModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.OptionTransferSelectModel

OptionTransferSelectTag - Class in org.apache.struts2.views.jsp.ui
OptionTransferSelect jsp tag.
OptionTransferSelectTag() - Constructor for class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

ordered - Variable in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

org.apache.struts2 - package org.apache.struts2
Main Struts interfaces and classes.
org.apache.struts2.components - package org.apache.struts2.components

org.apache.struts2.components.table - package org.apache.struts2.components.table

org.apache.struts2.components.table.renderer - package org.apache.struts2.components.table.renderer
JSP UI tags for rendering table output in HTML.
org.apache.struts2.components.template - package org.apache.struts2.components.template

org.apache.struts2.config - package org.apache.struts2.config
Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher - package org.apache.struts2.dispatcher
Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper - package org.apache.struts2.dispatcher.mapper

org.apache.struts2.dispatcher.multipart - package org.apache.struts2.dispatcher.multipart
Classes to help dispatch multipart HTTP requests.
org.apache.struts2.impl - package org.apache.struts2.impl

org.apache.struts2.interceptor - package org.apache.struts2.interceptor
Web specific interceptor classes.
org.apache.struts2.interceptor.debugging - package org.apache.struts2.interceptor.debugging

org.apache.struts2.interceptor.validation - package org.apache.struts2.interceptor.validation

org.apache.struts2.portlet - package org.apache.struts2.portlet

org.apache.struts2.portlet.context - package org.apache.struts2.portlet.context

org.apache.struts2.portlet.dispatcher - package org.apache.struts2.portlet.dispatcher

org.apache.struts2.portlet.interceptor - package org.apache.struts2.portlet.interceptor

org.apache.struts2.portlet.result - package org.apache.struts2.portlet.result

org.apache.struts2.portlet.util - package org.apache.struts2.portlet.util

org.apache.struts2.servlet.interceptor - package org.apache.struts2.servlet.interceptor

org.apache.struts2.util - package org.apache.struts2.util
Miscellaneous helper classes.
org.apache.struts2.validators - package org.apache.struts2.validators

org.apache.struts2.views - package org.apache.struts2.views

org.apache.struts2.views.annotations - package org.apache.struts2.views.annotations

org.apache.struts2.views.freemarker - package org.apache.struts2.views.freemarker
Classes for views using FreeMarker.
org.apache.struts2.views.freemarker.tags - package org.apache.struts2.views.freemarker.tags

org.apache.struts2.views.jsp - package org.apache.struts2.views.jsp
Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator - package org.apache.struts2.views.jsp.iterator
Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui - package org.apache.struts2.views.jsp.ui
Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table - package org.apache.struts2.views.jsp.ui.table
JSP UI tags for modeling tables.
org.apache.struts2.views.util - package org.apache.struts2.views.util
Miscellaneous helper classes for all views.
org.apache.struts2.views.velocity - package org.apache.struts2.views.velocity
Classes for views using Velocity.
org.apache.struts2.views.velocity.components - package org.apache.struts2.views.velocity.components

org.apache.struts2.views.xslt - package org.apache.struts2.views.xslt
The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.
original - Variable in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping
The original pattern.
ORIGINAL_PROPERTY_OVERRIDE - Static variable in class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

outputStream - Variable in class org.apache.struts2.components.Include.PageResponse

overrides - Variable in class com.opensymphony.xwork2.util.OgnlValueStack

P

PackageConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for Package.
PackageConfig() - Constructor for class com.opensymphony.xwork2.config.entities.PackageConfig

PackageConfig(String) - Constructor for class com.opensymphony.xwork2.config.entities.PackageConfig

PackageConfig(String, String, boolean) - Constructor for class com.opensymphony.xwork2.config.entities.PackageConfig

PackageConfig(String, String, boolean, List) - Constructor for class com.opensymphony.xwork2.config.entities.PackageConfig

packageContexts - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

packageName - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig

packages - Variable in class com.opensymphony.xwork2.config.impl.MockConfiguration

packages - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
The list of packages to scan for Action classes.
page - Variable in class org.apache.struts2.util.URLBean

PAGE_CONTEXT - Static variable in interface org.apache.struts2.StrutsStatics
Constant for the JSP page context.
pageLocator - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider
Helper class to scan class path for server pages.
pageOutputStream - Variable in class org.apache.struts2.components.Include.PageResponse

pagePrintWriter - Variable in class org.apache.struts2.components.Include.PageResponse

Param - Class in org.apache.struts2.components

Param(ValueStack) - Constructor for class org.apache.struts2.components.Param

param - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

Param.UnnamedParametric - Interface in org.apache.struts2.components
Tags can implement this to support nested param tags without the name attribute.
ParamDirective - Class in org.apache.struts2.views.velocity.components

ParamDirective() - Constructor for class org.apache.struts2.views.velocity.components.ParamDirective

ParameterAware - Interface in org.apache.struts2.interceptor
This interface gives actions an alternative way of receiving input parameters.
ParameterFilterInterceptor - Class in com.opensymphony.xwork2.interceptor

ParameterFilterInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

parameterInjectors - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector

parameterInjectors - Variable in class com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector

Parameterizable - Interface in com.opensymphony.xwork2.config.entities

Actions implementing Parameterizable will receive a map of the static parameters defined in the action configuration.
parameterMap - Variable in class org.apache.struts2.portlet.util.HttpServletRequestMock

parameterName - Variable in class com.opensymphony.xwork2.interceptor.I18nInterceptor

ParameterNameAware - Interface in com.opensymphony.xwork2.interceptor
This interface is implemented by actions that want to declare acceptable parameters.
ParameterRemoverInterceptor - Class in com.opensymphony.xwork2.interceptor
This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action.
ParameterRemoverInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

PARAMETERS - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's parameters.
parameters - Variable in class org.apache.struts2.components.Component

parameters - Variable in class org.apache.struts2.components.template.TemplateRenderingContext

ParametersInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor sets all parameters on the value stack.
ParametersInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ParametersInterceptor

ParamModel - Class in org.apache.struts2.views.freemarker.tags

ParamModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ParamModel

paramNames - Variable in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

params - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig

params - Variable in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

params - Variable in class com.opensymphony.xwork2.config.entities.InterceptorConfig

params - Variable in class com.opensymphony.xwork2.config.entities.ResultConfig

params - Variable in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

params - Variable in class com.opensymphony.xwork2.validator.ValidatorConfig

params - Variable in class org.apache.struts2.dispatcher.mapper.ActionMapping

params - Variable in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

params - Variable in class org.apache.struts2.util.URLBean

paramsWorkaroundEnabled - Variable in class org.apache.struts2.dispatcher.Dispatcher
Store state of STRUTS_DISPATCHER_PARAMETERSWORKAROUND.
ParamTag - Class in org.apache.struts2.views.jsp

ParamTag() - Constructor for class org.apache.struts2.views.jsp.ParamTag

paramValues - Variable in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

parent - Variable in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

parent - Variable in class com.opensymphony.xwork2.util.ResolverUtil.IsA

PARENT - Static variable in class org.apache.struts2.views.velocity.VelocityManager
the parent JSP tag
parent - Variable in class org.apache.struts2.views.xslt.AbstractAdapterNode

parent - Variable in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

parentNode - Variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
The parentNode
ParentPackage - Annotation Type in org.apache.struts2.config
Allows an action class to specify an xwork package to inherit
parents - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

parse - Variable in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

parse(InputSource) - Static method in class com.opensymphony.xwork2.util.DomHelper
Creates a W3C Document that remembers the location of each element in the source file.
parse(InputSource, Map) - Static method in class com.opensymphony.xwork2.util.DomHelper
Creates a W3C Document that remembers the location of each element in the source file.
parse(String) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Parse a location string of the form "uri:line:column" (e.g.
parse - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

parse(String) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Create a string array from a comma-delimited list of packages.
parse - Variable in class org.apache.struts2.dispatcher.HttpHeaderResult

parse(HttpServletRequest, String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest
Creates a new request wrapper to handle multi-part data using methods adapted from Jason Pell's multipart classes (see class description).
parse(HttpServletRequest, String) - Method in interface org.apache.struts2.dispatcher.multipart.MultiPartRequest

parse - Variable in class org.apache.struts2.dispatcher.StrutsResultSupport

parse - Variable in class org.apache.struts2.views.xslt.XSLTResult

parseActionValidatorConfigs(InputStream, String) - Static method in class com.opensymphony.xwork2.validator.ValidatorFileParser
Parse resource for a list of ValidatorConfig objects.
parseDateString(String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

parseDouble(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

parseModeConfig(PortletConfig, PortletMode, String, String) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Parse the mode to namespace mappings configured in portlet.xml
parseNameAndNamespace(String, ActionMapping, ConfigurationManager) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper
Parses the name and namespace from the uri
parseParameterValues() - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

parseProperty(String) - Method in class com.opensymphony.xwork2.util.PropertiesReader
Parse a property line and return the key and the value in an array.
parseQueryString(String) - Static method in class org.apache.struts2.views.util.UrlHelper

parser - Variable in class org.apache.struts2.util.DateFormatter

parseStringAsXML - Variable in class org.apache.struts2.views.xslt.StringAdapter

parseValidatorDefinitions(InputStream) - Static method in class com.opensymphony.xwork2.validator.ValidatorFileParser
Deprecated. Use parseValidatorDefinitions(InputStream, String)
parseValidatorDefinitions(InputStream, String) - Static method in class com.opensymphony.xwork2.validator.ValidatorFileParser
Deprecated.
parseValidatorDefinitions(InputStream, String, ObjectFactory) - Static method in class com.opensymphony.xwork2.validator.ValidatorFileParser
Parses validator definitions
parseValidators() - Static method in class com.opensymphony.xwork2.validator.ValidatorFactory

Password - Class in org.apache.struts2.components
Render an HTML input tag of type password.
Password(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Password

password - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

PasswordDirective - Class in org.apache.struts2.views.velocity.components

PasswordDirective() - Constructor for class org.apache.struts2.views.velocity.components.PasswordDirective

PasswordModel - Class in org.apache.struts2.views.freemarker.tags

PasswordModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.PasswordModel

PasswordTag - Class in org.apache.struts2.views.jsp.ui

PasswordTag() - Constructor for class org.apache.struts2.views.jsp.ui.PasswordTag

pathPrefixes - Variable in class org.apache.struts2.dispatcher.FilterDispatcher
Store set of path prefixes to use with static resources.
pattern - Variable in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping
The compiled pattern.
pattern - Variable in class com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey

pause(String) - Method in class com.opensymphony.xwork2.ActionSupport
Stops the action invocation immediately (by throwing a PauseException) and causes the action invocation to return the specified result, such as Action.SUCCESS, Action.INPUT, etc.
pContentType - Variable in class org.apache.struts2.views.freemarker.FreemarkerResult

pContentType - Variable in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

peek() - Method in class com.opensymphony.xwork2.util.CompoundRoot

peek() - Method in class com.opensymphony.xwork2.util.OgnlValueStack

peek() - Method in interface com.opensymphony.xwork2.util.ValueStack
Get the object on the top of the stack without changing the stack.
performFallbackConversion(Map, Object, Class) - Method in class org.apache.struts2.util.StrutsTypeConverter
Hook to perform a fallback conversion if every default options failed.
performInitialDelay(BackgroundProcess) - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
Performs the initial delay.
PHASE - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key used for looking up and storing the portlet phase
pkgConfig - Variable in class org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap

PlainTextResult - Class in org.apache.struts2.dispatcher
A result that send the content out as plain text.
PlainTextResult() - Constructor for class org.apache.struts2.dispatcher.PlainTextResult

PlainTextResult(String) - Constructor for class org.apache.struts2.dispatcher.PlainTextResult

pop() - Method in class com.opensymphony.xwork2.util.CompoundRoot

pop() - Method in class com.opensymphony.xwork2.util.OgnlValueStack

pop(String) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
End a preformance profiling with the name given.
pop() - Method in interface com.opensymphony.xwork2.util.ValueStack
Get the object on the top of the stack and remove it from the stack.
popComponentStack() - Method in class org.apache.struts2.components.Component
Pops the component stack.
populateComponentHtmlId(Form) - Method in class org.apache.struts2.components.Form
Form component determine the its HTML element id as follows:- if an 'id' attribute is specified. if an 'action' attribute is specified, it will be used as the id.
populateComponentHtmlId(Form) - Method in class org.apache.struts2.components.FormButton
Override UIBean's implementation, such that component Html id is determined in the following order :- This component id attribute [containing_form_id]_[this_component_name] [containing_form_id]_[this_component_action]_[this_component_method] [containing_form_id]_[this_component_method] [this_component_name] [this_component_action]_[this_component_method] [this_component_method] [an increasing sequential number unique to the form starting with 0]
populateComponentHtmlId(Form) - Method in class org.apache.struts2.components.UIBean
Create HTML id element for the component and populate this component parmaeter map.
populateContext(ScopesHashModel, ValueStack, Object, HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager

populateParams() - Method in class org.apache.struts2.views.jsp.ActionTag

populateParams() - Method in class org.apache.struts2.views.jsp.BeanTag

populateParams() - Method in class org.apache.struts2.views.jsp.ComponentTagSupport

populateParams() - Method in class org.apache.struts2.views.jsp.DateTag

populateParams() - Method in class org.apache.struts2.views.jsp.ElseIfTag

populateParams() - Method in class org.apache.struts2.views.jsp.I18nTag

populateParams() - Method in class org.apache.struts2.views.jsp.IfTag

populateParams() - Method in class org.apache.struts2.views.jsp.IncludeTag

populateParams() - Method in class org.apache.struts2.views.jsp.IteratorTag

populateParams() - Method in class org.apache.struts2.views.jsp.ParamTag

populateParams() - Method in class org.apache.struts2.views.jsp.PropertyTag

populateParams() - Method in class org.apache.struts2.views.jsp.PushTag

populateParams() - Method in class org.apache.struts2.views.jsp.SetTag

populateParams() - Method in class org.apache.struts2.views.jsp.TextTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.AbstractClosingTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.AbstractListTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.AbstractRequiredListTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.AnchorTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.CheckboxTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.ComboBoxTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.DivTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.DoubleSelectTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.FileTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.FormTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.HeadTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.LabelTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.OptGroupTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.PasswordTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.ResetTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.SelectTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.table.WebTableTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.TextareaTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.TextFieldTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.TreeTag

populateParams() - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

populateParams() - Method in class org.apache.struts2.views.jsp.URLTag

PORTLET_CONFIG - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key used for looking up and storing the PortletConfig
PORTLET_NAMESPACE - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key for the portlet namespace stored in the PortletActionContext.
PortletActionConstants - Interface in org.apache.struts2.portlet
Interface defining some constants used in the Struts portlet implementation
PortletActionContext - Class in org.apache.struts2.portlet.context
PortletActionContext.
PortletActionContext() - Constructor for class org.apache.struts2.portlet.context.PortletActionContext

PortletApplicationMap - Class in org.apache.struts2.portlet
Portlet specific Map implementation representing the PortletContext of a Portlet.
PortletApplicationMap(PortletContext) - Constructor for class org.apache.struts2.portlet.PortletApplicationMap
Creates a new map object given the PortletContext.
PortletFreemarkerResult - Class in org.apache.struts2.views.freemarker

PortletFreemarkerResult() - Constructor for class org.apache.struts2.views.freemarker.PortletFreemarkerResult

PortletFreemarkerResult(String) - Constructor for class org.apache.struts2.views.freemarker.PortletFreemarkerResult

portletMode - Variable in class org.apache.struts2.components.Form

portletMode - Variable in class org.apache.struts2.components.URL

portletMode - Variable in class org.apache.struts2.views.jsp.ui.FormTag

portletMode - Variable in class org.apache.struts2.views.jsp.URLTag

portletNamespace - Variable in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

PortletPreferencesAware - Interface in org.apache.struts2.portlet.interceptor
All Actions that want to have access to the portlet preferences should implement this interface.
PortletPreferencesInterceptor - Class in org.apache.struts2.portlet.interceptor
An interceptor which provides an implementation of PortletPreferences if the Action implements PortletPreferencesAware.
PortletPreferencesInterceptor() - Constructor for class org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor

PortletPrincipalProxy - Class in org.apache.struts2.portlet.interceptor
PrincipalProxy implementation for using PortletRequest Principal related methods.
PortletPrincipalProxy(PortletRequest) - Constructor for class org.apache.struts2.portlet.interceptor.PortletPrincipalProxy
Constructs a proxy
PortletRequestMap - Class in org.apache.struts2.portlet
A simple implementation of the Map interface to handle a collection of request attributes.
PortletRequestMap(PortletRequest) - Constructor for class org.apache.struts2.portlet.PortletRequestMap
Saves the request to use as the backing for getting and setting values
PortletResult - Class in org.apache.struts2.portlet.result
Result type that includes a JSP to render.
PortletResult() - Constructor for class org.apache.struts2.portlet.result.PortletResult

PortletResult(String) - Constructor for class org.apache.struts2.portlet.result.PortletResult

PortletResult.IncludeTemplate - Class in org.apache.struts2.portlet.result

PortletResult.IncludeTemplate() - Constructor for class org.apache.struts2.portlet.result.PortletResult.IncludeTemplate

PortletSessionMap - Class in org.apache.struts2.portlet
A simple implementation of the Map interface to handle a collection of portlet session attributes.
PortletSessionMap(PortletRequest) - Constructor for class org.apache.struts2.portlet.PortletSessionMap
Creates a new session map given a portlet request.
portletSupportActive - Static variable in class org.apache.struts2.dispatcher.Dispatcher
Store whether portlet support is active (set to true by Jsr168Dispatcher).
PortletUrlHelper - Class in org.apache.struts2.portlet.util
Helper class for creating Portlet URLs.
PortletUrlHelper() - Constructor for class org.apache.struts2.portlet.util.PortletUrlHelper

portletUrlType - Variable in class org.apache.struts2.components.URL

portletUrlType - Variable in class org.apache.struts2.views.jsp.URLTag

PortletVelocityResult - Class in org.apache.struts2.portlet.result
Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.
PortletVelocityResult() - Constructor for class org.apache.struts2.portlet.result.PortletVelocityResult

PortletVelocityResult(String) - Constructor for class org.apache.struts2.portlet.result.PortletVelocityResult

postTemplateProcess(Template, TemplateModel) - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
the default implementation of postTemplateProcess applies the contentType parameter
postTemplateProcess(Template, TemplateModel) - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
the default implementation of postTemplateProcess applies the contentType parameter
PREFERENCES_KEY - Variable in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

PREFIX - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Prefix for the location namespace
PrefixMethodInvocationUtil - Class in com.opensymphony.xwork2.interceptor
A utility class for invoking prefixed methods in action class.
PrefixMethodInvocationUtil() - Constructor for class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

prefixTrie - Variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

PrefixTrie - Class in org.apache.struts2.util
Quickly matches a prefix to an object.
PrefixTrie() - Constructor for class org.apache.struts2.util.PrefixTrie

PrefixTrie.Node - Class in org.apache.struts2.util

PrefixTrie.Node() - Constructor for class org.apache.struts2.util.PrefixTrie.Node

preInvokeJS - Variable in class org.apache.struts2.views.jsp.ui.AnchorTag

Preparable - Interface in com.opensymphony.xwork2
Preparable Actions will have their prepare() method called if the PrepareInterceptor is applied to the ActionConfig
PreparatorServlet - Class in org.apache.struts2.portlet.context
Since a portlet is not dispatched the same way as a servlet, the ServletActionContext is not immediately available, as it depends on objects from the servlet API.
PreparatorServlet() - Constructor for class org.apache.struts2.portlet.context.PreparatorServlet

prepare(Object, ValueStack) - Method in interface com.opensymphony.xwork2.ActionEventListener
Called after an action has been created.
prepare() - Method in interface com.opensymphony.xwork2.ActionProxy
Called after all dependencies are set
prepare() - Method in class com.opensymphony.xwork2.DefaultActionProxy

prepare() - Method in class com.opensymphony.xwork2.mock.MockActionProxy

prepare() - Method in interface com.opensymphony.xwork2.Preparable
This method is called to allow the action to prepare itself.
prepare(String) - Method in class org.apache.struts2.components.Property

prepare(HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.dispatcher.Dispatcher
Prepare a request, including setting the encoding and locale.
prepare() - Method in class org.apache.struts2.validators.DWRValidator.ValidatorActionProxy

PREPARE_PREFIX - Static variable in class com.opensymphony.xwork2.interceptor.PrepareInterceptor

prepareChainedContexts(HttpServletRequest, HttpServletResponse, Map) - Method in class org.apache.struts2.views.velocity.VelocityManager
constructs contexts for chaining on this request.
prepareDispatcherAndWrapRequest(HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.dispatcher.FilterDispatcher
Wrap and return the given request, if needed, so as to to transparently handle multipart data as a wrapped class around the given request.
PrepareInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor calls prepare() on actions which implement Preparable.
PrepareInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.PrepareInterceptor

prepareServletActionContext() - Method in class org.apache.struts2.portlet.result.PortletVelocityResult
Prepares the servlet action context for this request
prepareServletActionContext() - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

prependNamespace(String, String) - Static method in class org.apache.struts2.portlet.util.PortletUrlHelper
Prepend the namespace configuration for the specified namespace and PortletMode.
prependServletContext - Variable in class org.apache.struts2.dispatcher.ServletRedirectResult

PreResultListener - Interface in com.opensymphony.xwork2.interceptor
PreResultListeners may be registered with an ActionInvocation to get a callback after the Action has been executed but before the Result is executed.
preResultListeners - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

preResultListeners - Variable in class com.opensymphony.xwork2.mock.MockActionInvocation

preTemplateProcess(Template, TemplateModel) - Method in class org.apache.struts2.views.freemarker.FreemarkerResult
Called before the execution is passed to template.process().
preTemplateProcess(Template, TemplateModel) - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult
Called before the execution is passed to template.process().
PrettyPrintWriter - Class in org.apache.struts2.interceptor.debugging

PrettyPrintWriter(Writer, char[], String) - Constructor for class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

PrettyPrintWriter(Writer, char[]) - Constructor for class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

PrettyPrintWriter(Writer, String, String) - Constructor for class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

PrettyPrintWriter(Writer, String) - Constructor for class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

PrettyPrintWriter(Writer) - Constructor for class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

PrincipalAware - Interface in org.apache.struts2.interceptor
Actions that want access to the Principal information from HttpServletRequest object should implement this interface.
PrincipalProxy - Interface in org.apache.struts2.interceptor
Proxy interface used together with PrincipalAware interface.
printClassLoader() - Static method in class org.apache.struts2.util.ClassLoaderUtils
Prints the current classloader hierarchy - useful for debugging.
printClassLoader(ClassLoader) - Static method in class org.apache.struts2.util.ClassLoaderUtils
Prints the classloader hierarchy from a given classloader - useful for debugging.
printContext() - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor
Prints the current context to the response in XML format.
printContext(PrettyPrintWriter) - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor
Prints the current request to the existing writer.
printTimes(ProfilingTimerBean) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
Do a log (at INFO level) of the time taken for this particular profiling.
processAction(ActionRequest, ActionResponse) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Service an action from the event phase.
processActionClass(Class, String[]) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Create a default action mapping for a class instance.
processAnnotations(Object) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processConversionErrorFieldValidatorAnnotation(ConversionErrorFieldValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processCustomValidatorAnnotation(CustomValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processDateRangeFieldValidatorAnnotation(DateRangeFieldValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processDoubleRangeFieldValidatorAnnotation(DoubleRangeFieldValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processEmailValidatorAnnotation(EmailValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processExpressionValidatorAnnotation(ExpressionValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processFieldExpressionValidatorAnnotation(FieldExpressionValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processingInstruction(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

processingInstruction(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

processingInstruction(String, String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

processIntRangeFieldValidatorAnnotation(IntRangeFieldValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processNumber(StringBuffer, String, double) - Method in class org.apache.struts2.components.table.renderer.NumericCellRenderer

processRegexFieldValidatorAnnotation(RegexFieldValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processRequiredFieldValidatorAnnotation(RequiredFieldValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processRequiredStringValidatorAnnotation(RequiredStringValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processStringLengthFieldValidatorAnnotation(StringLengthFieldValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processStringRegexValidatorAnnotation(StringRegexValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processUrlValidatorAnnotation(UrlValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processValidationAnnotation(Annotation, String, List<ValidatorConfig>) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

processVisitorFieldValidatorAnnotation(VisitorFieldValidator, String) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

profile(String, UtilTimerStack.ProfilingBlock<T>) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
A convenience method that allows block of code subjected to profiling to be executed and avoid the need of coding boiler code that does pushing (UtilTimeBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ...
profiledInvoke(Method, Object, Object[]) - Static method in class com.opensymphony.xwork2.util.profiling.ObjectProfiler
A profiled call Method.invoke(java.lang.Object, java.lang.Object[]).
ProfilingActivationInterceptor - Class in org.apache.struts2.interceptor
Allows profiling to be enabled or disabled via request parameters, when devMode is enabled.
ProfilingActivationInterceptor() - Constructor for class org.apache.struts2.interceptor.ProfilingActivationInterceptor

profilingKey - Variable in class org.apache.struts2.interceptor.ProfilingActivationInterceptor

ProfilingTimerBean - Class in com.opensymphony.xwork2.util.profiling
Bean to contain information about the pages profiled
ProfilingTimerBean(String) - Constructor for class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

prohibitedResultParam - Variable in class org.apache.struts2.dispatcher.ServletActionRedirectResult

PropertiesReader - Class in com.opensymphony.xwork2.util
This class is used to read properties lines.
PropertiesReader(Reader) - Constructor for class com.opensymphony.xwork2.util.PropertiesReader
Constructor.
PropertiesReader(Reader, char) - Constructor for class com.opensymphony.xwork2.util.PropertiesReader
Creates a new instance of PropertiesReader and sets the underlaying reader and the list delimiter.
PropertiesSettings - Class in org.apache.struts2.config
A class to handle settings via a properties file.
PropertiesSettings(String) - Constructor for class org.apache.struts2.config.PropertiesSettings
Creates a new properties config given the name of a properties file.
property - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

Property - Class in org.apache.struts2.components
Used to get the property of a value, which will default to the top of the stack if none is specified.
Property(ValueStack) - Constructor for class org.apache.struts2.components.Property

property - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

propertyDescriptorCache - Static variable in class org.apache.struts2.views.xslt.BeanAdapter
Cache can savely be static because the cached information is the same for all instances of this class.
PropertyDirective - Class in org.apache.struts2.views.velocity.components

PropertyDirective() - Constructor for class org.apache.struts2.views.velocity.components.PropertyDirective

PropertyModel - Class in org.apache.struts2.views.freemarker.tags

PropertyModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.PropertyModel

propertyName - Variable in class com.opensymphony.xwork2.util.PropertiesReader
Stores the name of the last read property.
propertyName - Variable in class org.apache.struts2.views.xslt.AbstractAdapterNode

PropertyTag - Class in org.apache.struts2.views.jsp

PropertyTag() - Constructor for class org.apache.struts2.views.jsp.PropertyTag

propertyValue - Variable in class com.opensymphony.xwork2.util.PropertiesReader
Stores the value of the last read property.
propertyValue - Variable in class org.apache.struts2.views.xslt.AbstractAdapterNode

propLocations - Variable in class com.opensymphony.xwork2.util.location.LocatableProperties

PROTOCOL - Static variable in class org.apache.struts2.views.xslt.ServletURIResolver

providerLock - Variable in class com.opensymphony.xwork2.config.ConfigurationManager

proxy - Variable in class com.opensymphony.xwork2.ActionChainResult

proxy - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

proxy - Variable in class com.opensymphony.xwork2.mock.MockActionInvocation

proxy - Variable in class org.apache.struts2.components.ActionComponent

ProxyAttrAdapter - Class in org.apache.struts2.views.xslt
ProxyAttrAdapter is a pass-through adapter for objects which already implement the Attr interface.
ProxyAttrAdapter(AdapterFactory, AdapterNode, Attr) - Constructor for class org.apache.struts2.views.xslt.ProxyAttrAdapter

ProxyElementAdapter - Class in org.apache.struts2.views.xslt
ProxyElementAdapter is a pass-through adapter for objects which already implement the Element interface.
ProxyElementAdapter(AdapterFactory, AdapterNode, Element) - Constructor for class org.apache.struts2.views.xslt.ProxyElementAdapter

proxyNamedNodeMap(AdapterNode, NamedNodeMap) - Method in class org.apache.struts2.views.xslt.AdapterFactory

ProxyNamedNodeMap - Class in org.apache.struts2.views.xslt
A NamedNodeMap that wraps the Nodes returned in their proxies.
ProxyNamedNodeMap(AdapterFactory, AdapterNode, NamedNodeMap) - Constructor for class org.apache.struts2.views.xslt.ProxyNamedNodeMap

proxyNode(AdapterNode, Node) - Method in class org.apache.struts2.views.xslt.AdapterFactory
Construct a proxy adapter for a value that is an existing DOM Node.
ProxyNodeAdapter - Class in org.apache.struts2.views.xslt
ProxyNodeAdapter is a read-only delegating adapter for objects which already implement the Node interface.
ProxyNodeAdapter(AdapterFactory, AdapterNode, Node) - Constructor for class org.apache.struts2.views.xslt.ProxyNodeAdapter

ProxyTextNodeAdapter - Class in org.apache.struts2.views.xslt
ProxyTextNodeAdapter is a pass-through adapter for objects which already implement the Text interface.
ProxyTextNodeAdapter(AdapterFactory, AdapterNode, Text) - Constructor for class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

publishException(ActionInvocation, ExceptionHolder) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor
Default implementation to handle ExceptionHolder publishing.
push(Object) - Method in class com.opensymphony.xwork2.util.CompoundRoot

push(Object) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

push(String) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
Create and start a performance profiling with the name given.
push(Object) - Method in interface com.opensymphony.xwork2.util.ValueStack
Put this object onto the top of the stack
Push - Class in org.apache.struts2.components

Push(ValueStack) - Constructor for class org.apache.struts2.components.Push

push - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

pushAction - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

PushDirective - Class in org.apache.struts2.views.velocity.components

PushDirective() - Constructor for class org.apache.struts2.views.velocity.components.PushDirective

pushed - Variable in class org.apache.struts2.components.I18n

pushed - Variable in class org.apache.struts2.components.Push

PushModel - Class in org.apache.struts2.views.freemarker.tags

PushModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.PushModel

PushTag - Class in org.apache.struts2.views.jsp

PushTag() - Constructor for class org.apache.struts2.views.jsp.PushTag

put(Object, Object) - Method in class com.opensymphony.xwork2.ActionContext
Stores a value in the current ActionContext.
put(K, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

put(Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkMap
Deprecated. Associates the specified value with the specified key in this map.
put(Object, Object) - Method in class org.apache.struts2.dispatcher.ApplicationMap
Sets a servlet context attribute given a attribute name and value.
put(Object, Object) - Method in class org.apache.struts2.dispatcher.RequestMap
Saves an attribute in the request.
put(Object, Object) - Method in class org.apache.struts2.dispatcher.SessionMap
Saves an attribute in the session.
put(Object, Object) - Method in class org.apache.struts2.portlet.PortletApplicationMap
Sets a portlet context attribute given a attribute name and value.
put(Object, Object) - Method in class org.apache.struts2.portlet.PortletRequestMap
Saves an attribute in the request.
put(Object, Object) - Method in class org.apache.struts2.portlet.PortletSessionMap
Saves an attribute in the session.
put(Object, Object) - Method in class org.apache.struts2.util.AttributeMap

put(String, Object) - Method in class org.apache.struts2.util.PrefixTrie

put(String, boolean) - Method in class org.apache.struts2.views.freemarker.ScopesHashModel

put(String, Object) - Method in class org.apache.struts2.views.freemarker.ScopesHashModel

putAll(Map<? extends K, ? extends V>) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

putAll(Map) - Method in class com.opensymphony.xwork2.util.XWorkMap
Deprecated. Copies all of the mappings from the specified map to this map These mappings will replace any mappings that this map had for any of the keys currently in the specified map.
putAll(Map) - Method in class org.apache.struts2.util.AttributeMap

putIfAbsent(K, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

putIfAbsentStrategy() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

putProperty(Map, InternalContextAdapter, Node) - Method in class org.apache.struts2.views.velocity.components.AbstractDirective
adds a given Node's key/value pair to the propertyMap.
putStrategy() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

Q

Q_COL_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute qualified name for the column number
Q_LINE_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute qualified name for the line number
Q_SRC_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute qualified name for the location URI
QUOT - Static variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

R

Radio - Class in org.apache.struts2.components
Render a radio button input field.
Radio(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Radio

radio - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

RadioDirective - Class in org.apache.struts2.views.velocity.components

RadioDirective() - Constructor for class org.apache.struts2.views.velocity.components.RadioDirective

RadioModel - Class in org.apache.struts2.views.freemarker.tags

RadioModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.RadioModel

RadioTag - Class in org.apache.struts2.views.jsp.ui

RadioTag() - Constructor for class org.apache.struts2.views.jsp.ui.RadioTag

RANDOM - Static variable in class org.apache.struts2.util.TokenHelper

RAW_DATA - Static variable in class org.apache.struts2.components.table.WebTable.WebTableRowIterator

rbCollator - Static variable in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Compares based on number of '.' characters (fewer is higher)
readObject(ObjectInputStream) - Method in class com.opensymphony.xwork2.inject.util.ReferenceCache

readObject(ObjectInputStream) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

readonly - Variable in class org.apache.struts2.components.TextArea

readonly - Variable in class org.apache.struts2.components.TextField

readonly - Variable in class org.apache.struts2.views.jsp.ui.TextareaTag

readonly - Variable in class org.apache.struts2.views.jsp.ui.TextFieldTag

readProperty() - Method in class com.opensymphony.xwork2.util.PropertiesReader
Reads a property line.
readResolve() - Method in class com.opensymphony.xwork2.DefaultTextProvider

readResolve() - Method in class com.opensymphony.xwork2.util.location.LocationImpl
Ensure serialized unknown location resolve to Location.UNKNOWN.
readResolve() - Method in class com.opensymphony.xwork2.util.OgnlValueStack

readyForNewLine - Variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

rebuildRuntimeConfiguration() - Method in interface com.opensymphony.xwork2.config.Configuration

rebuildRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

rebuildRuntimeConfiguration() - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

REDIRECT_ACTION_PREFIX - Static variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

REDIRECT_PREFIX - Static variable in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

ReferenceCache<K,V> - Class in com.opensymphony.xwork2.inject.util
Extends ReferenceMap to support lazy loading values by overriding ReferenceCache.create(Object).
ReferenceCache(ReferenceType, ReferenceType) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceCache

ReferenceCache() - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceCache
Equivalent to new ReferenceCache(STRONG, STRONG).
ReferenceCache.CallableCreate - Class in com.opensymphony.xwork2.inject.util

ReferenceCache.CallableCreate(K) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate

referenceEquals(Reference, Object) - Static method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Tests weak and soft references for identity equality.
referenceKey(K) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Creates a reference for a key.
ReferenceMap<K,V> - Class in com.opensymphony.xwork2.inject.util
Concurrent hash map that wraps keys and/or values in soft or weak references.
ReferenceMap(ReferenceType, ReferenceType) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap
Concurrent hash map that wraps keys and/or values based on specified reference types.
ReferenceMap.Entry - Class in com.opensymphony.xwork2.inject.util

ReferenceMap.Entry(K, V) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

ReferenceMap.InternalReference - Interface in com.opensymphony.xwork2.inject.util
Marker interface to differentiate external and internal references.
ReferenceMap.KeyReferenceAwareWrapper - Class in com.opensymphony.xwork2.inject.util
Used for keys.
ReferenceMap.KeyReferenceAwareWrapper(Object) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap.KeyReferenceAwareWrapper

ReferenceMap.PutStrategy - Enum in com.opensymphony.xwork2.inject.util

ReferenceMap.PutStrategy() - Constructor for enum com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy

ReferenceMap.ReferenceAwareWrapper - Class in com.opensymphony.xwork2.inject.util
Big hack.
ReferenceMap.ReferenceAwareWrapper(Object) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper

ReferenceMap.SoftKeyReference - Class in com.opensymphony.xwork2.inject.util

ReferenceMap.SoftKeyReference(Object) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference

ReferenceMap.SoftValueReference - Class in com.opensymphony.xwork2.inject.util

ReferenceMap.SoftValueReference(Object, Object) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference

ReferenceMap.Strategy - Interface in com.opensymphony.xwork2.inject.util

ReferenceMap.WeakKeyReference - Class in com.opensymphony.xwork2.inject.util

ReferenceMap.WeakKeyReference(Object) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference

ReferenceMap.WeakValueReference - Class in com.opensymphony.xwork2.inject.util

ReferenceMap.WeakValueReference(Object, Object) - Constructor for class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference

ReferenceResolverException - Exception in com.opensymphony.xwork2.config
Exception when a reference can't be resolved.
ReferenceResolverException() - Constructor for exception com.opensymphony.xwork2.config.ReferenceResolverException

ReferenceResolverException(String) - Constructor for exception com.opensymphony.xwork2.config.ReferenceResolverException

ReferenceResolverException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.config.ReferenceResolverException

ReferenceResolverException(Throwable) - Constructor for exception com.opensymphony.xwork2.config.ReferenceResolverException

ReferenceType - Enum in com.opensymphony.xwork2.inject.util
Reference type.
ReferenceType() - Constructor for enum com.opensymphony.xwork2.inject.util.ReferenceType

referenceValue(Object, Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Creates a reference for a value.
refresh() - Method in class org.apache.struts2.components.table.SortFilterModel

refreshOnShow - Variable in class org.apache.struts2.components.Div

refreshOnShow - Variable in class org.apache.struts2.views.jsp.ui.DivTag

RegexFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
Validates a string field using a regular expression.
RegexFieldValidator - Class in com.opensymphony.xwork2.validator.validators
Validates a string field using a regular expression.
RegexFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.RegexFieldValidator

register(ContainerBuilder, LocatableProperties) - Method in interface com.opensymphony.xwork2.config.ConfigurationProvider

register(ContainerBuilder, LocatableProperties) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

register(ContainerBuilder, LocatableProperties) - Method in class org.apache.struts2.config.BeanSelectionProvider

register(ContainerBuilder, LocatableProperties) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider

register(ContainerBuilder, LocatableProperties) - Method in class org.apache.struts2.config.DefaultPropertiesProvider

register(ContainerBuilder, LocatableProperties) - Method in class org.apache.struts2.config.LegacyPropertiesConfigurationProvider

register(ContainerBuilder, LocatableProperties) - Method in class org.apache.struts2.config.MethodConfigurationProvider

register(ContainerBuilder, LocatableProperties) - Method in class org.apache.struts2.config.StrutsXmlConfigurationProvider

registerAdapterType(Class, Class) - Method in class org.apache.struts2.views.xslt.AdapterFactory
Register an adapter type for a Java class type.
registerConverter(String, TypeConverter) - Method in class com.opensymphony.xwork2.util.XWorkConverter

registerConverterNotFound(String) - Method in class com.opensymphony.xwork2.util.XWorkConverter

registerTemplateEngine(String, TemplateEngine) - Method in class org.apache.struts2.components.template.TemplateEngineManager
Registers the given template engine.
registerValidator(String, String) - Static method in class com.opensymphony.xwork2.validator.ValidatorFactory
Registers the given validator to the existing map of validators.
reload(List<ConfigurationProvider>) - Method in interface com.opensymphony.xwork2.config.Configuration

reload() - Method in class com.opensymphony.xwork2.config.ConfigurationManager

reload(List<ConfigurationProvider>) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
reload(List<ConfigurationProvider>) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

reload - Variable in class org.apache.struts2.config.MethodConfigurationProvider
Store needsReload property.
reloadBundles - Static variable in class com.opensymphony.xwork2.util.LocalizedTextUtil

reloadBundles() - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil

reloadingConfigs - Static variable in class com.opensymphony.xwork2.util.FileManager

reloadKey - Variable in class org.apache.struts2.config.StrutsXmlConfigurationProvider

RemoteUICallBean - Interface in org.apache.struts2.components

remove(Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

remove(Object, Object) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

remove() - Method in class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

remove(Element, boolean) - Static method in class com.opensymphony.xwork2.util.location.LocationAttributes
Remove the location attributes from a DOM element.
remove() - Method in class org.apache.struts2.components.table.WebTable.WebTableRowIterator

remove(Object) - Method in class org.apache.struts2.dispatcher.ApplicationMap
Removes the specified servlet context attribute.
remove(Object) - Method in class org.apache.struts2.dispatcher.RequestMap
Removes the specified request attribute.
remove(Object) - Method in class org.apache.struts2.dispatcher.SessionMap
Removes the specified session attribute.
remove(Object) - Method in class org.apache.struts2.portlet.PortletApplicationMap
Removes the specified portlet context attribute.
remove(Object) - Method in class org.apache.struts2.portlet.PortletRequestMap
Removes the specified request attribute.
remove(Object) - Method in class org.apache.struts2.portlet.PortletSessionMap
Removes the specified session attribute.
remove() - Method in class org.apache.struts2.util.AppendIteratorFilter

remove(Object) - Method in class org.apache.struts2.util.AttributeMap

remove() - Method in class org.apache.struts2.util.Counter

remove() - Method in class org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator

remove() - Method in class org.apache.struts2.util.IteratorGenerator

remove() - Method in class org.apache.struts2.util.MergeIteratorFilter

remove() - Method in class org.apache.struts2.util.SortIteratorFilter

remove() - Method in class org.apache.struts2.util.SubsetIteratorFilter

removeAllLabel - Variable in class org.apache.struts2.components.InputTransferSelect

removeAllLabel - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

removeAllRows() - Method in class org.apache.struts2.components.table.AbstractFilterModel

removeAttribute(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

removeAttribute(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

removeAttribute(String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

removeAttributeNode(Attr) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

removeAttributeNode(Attr) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

removeAttributeNS(String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

removeAttributeNS(String, String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

removeChild(Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

removeCurrentReference() - Method in class com.opensymphony.xwork2.inject.ConstructionContext

removeDispatcherListener(DispatcherListener) - Static method in class org.apache.struts2.dispatcher.Dispatcher
Remove a specific dispatcher lifecycle listener.
removeLabel - Variable in class org.apache.struts2.components.InputTransferSelect

removeLabel - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

removeNamedItem(String) - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

removeNamedItemNS(String, String) - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

removePackageConfig(String) - Method in interface com.opensymphony.xwork2.config.Configuration

removePackageConfig(String) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

removePackageConfig(String) - Method in class com.opensymphony.xwork2.config.impl.MockConfiguration

removeParent(PackageConfig) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

removeRow(int) - Method in class org.apache.struts2.components.table.AbstractFilterModel

removeRow(int) - Method in class org.apache.struts2.components.table.SortFilterModel

removeScopeStrategy() - Method in interface com.opensymphony.xwork2.inject.Container
Removes the scope strategy for the current thread.
removeScopeStrategy() - Method in class com.opensymphony.xwork2.inject.ContainerImpl

renameNode(Node, String, String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

render(RenderRequest, RenderResponse) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Service an action from the render phase.
render(InternalContextAdapter, Writer, Node) - Method in class org.apache.struts2.views.velocity.components.AbstractDirective

RENDER_PHASE - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Constant used for the render phase ( Portlet.render(javax.portlet.RenderRequest, javax.portlet.RenderResponse))
renderCell(WebTable, Object, int, int) - Method in class org.apache.struts2.components.table.renderer.AbstractCellRenderer
implememnts CellRenderer renderCell.
renderCell(WebTable, Object, int, int) - Method in interface org.apache.struts2.components.table.renderer.CellRenderer

rendered - Variable in class org.apache.struts2.components.table.RenderFilterModel

RenderFilterModel - Class in org.apache.struts2.components.table

RenderFilterModel(TableModel) - Constructor for class org.apache.struts2.components.table.RenderFilterModel

renderTemplate(TemplateRenderingContext) - Method in class org.apache.struts2.components.template.FreemarkerTemplateEngine

renderTemplate(TemplateRenderingContext) - Method in class org.apache.struts2.components.template.JspTemplateEngine

renderTemplate(TemplateRenderingContext) - Method in interface org.apache.struts2.components.template.TemplateEngine
Renders the template
renderTemplate(TemplateRenderingContext) - Method in class org.apache.struts2.components.template.VelocityTemplateEngine

replace(K, V, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

replace(K, V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

replace(String, String, String) - Static method in class org.apache.struts2.views.velocity.VelocityManager

replaceChild(Node, Node) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

replaceData(int, int, String) - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

replaceData(int, int, String) - Method in class org.apache.struts2.views.xslt.SimpleTextNode

replaceParameters(Map<String, Object>, Map) - Method in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Replaces parameter values
replaceStrategy() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

replaceWholeText(String) - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

replaceWholeText(String) - Method in class org.apache.struts2.views.xslt.SimpleTextNode

RepopulateConversionErrorFieldValidatorSupport - Class in com.opensymphony.xwork2.validator.validators
An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
RepopulateConversionErrorFieldValidatorSupport() - Constructor for class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

repopulateField(Object) - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

repopulateFieldAsBoolean - Variable in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

repopulateFieldAsString - Variable in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

REPORT_CONVERSION_ERRORS - Static variable in class com.opensymphony.xwork2.util.XWorkConverter

REPORT_ERRORS_ON_NO_PROP - Static variable in interface com.opensymphony.xwork2.util.ValueStack

req - Variable in class org.apache.struts2.components.ActionComponent

req - Variable in class org.apache.struts2.components.Include

req - Variable in class org.apache.struts2.components.OptGroup

req - Variable in class org.apache.struts2.components.URL

req - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

req - Variable in class org.apache.struts2.views.freemarker.tags.TagModel

request - Variable in class org.apache.struts2.components.UIBean

request - Variable in class org.apache.struts2.dispatcher.RequestMap

request - Variable in class org.apache.struts2.dispatcher.SessionMap

request - Variable in class org.apache.struts2.portlet.interceptor.PortletPrincipalProxy

REQUEST - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key used for looking up and storing the PortletRequest
request - Variable in class org.apache.struts2.portlet.PortletRequestMap

request - Variable in class org.apache.struts2.servlet.interceptor.ServletPrincipalProxy

request - Variable in class org.apache.struts2.util.StrutsUtil

request - Variable in class org.apache.struts2.util.URLBean

request - Variable in class org.apache.struts2.views.freemarker.ScopesHashModel

REQUEST - Static variable in class org.apache.struts2.views.util.ContextUtil

REQUEST2 - Static variable in class org.apache.struts2.views.util.ContextUtil

RequestAware - Interface in org.apache.struts2.interceptor
Actions that want access to the current serlvet request attributes should implement this interface.
This interface is only relevant if the Action is used in a servlet environment.
Note that using this interface makes the Action tied to a servlet environment, so it should be avoided if possible since things like unit testing will become more difficult.
RequestMap - Class in org.apache.struts2.dispatcher
A simple implementation of the Map interface to handle a collection of request attributes.
RequestMap(HttpServletRequest) - Constructor for class org.apache.struts2.dispatcher.RequestMap
Saves the request to use as the backing for getting and setting values
requestParameters - Variable in class org.apache.struts2.dispatcher.ServletActionRedirectResult

requestParameterSwitch - Variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

RequestUtils - Class in org.apache.struts2
Request handling utility class.
RequestUtils() - Constructor for class org.apache.struts2.RequestUtils

required - Variable in class org.apache.struts2.components.UIBean

required - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

RequiredFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a field is non-null.
RequiredFieldValidator - Class in com.opensymphony.xwork2.validator.validators
RequiredFieldValidator checks if the specified field is not null.
RequiredFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.RequiredFieldValidator

RequiredFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
RequiredFieldValidatorDescription
RequiredFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription

RequiredFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
requiredposition - Variable in class org.apache.struts2.components.UIBean

requiredposition - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

RequiredStringValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a String field is not empty (i.e.
RequiredStringValidator - Class in com.opensymphony.xwork2.validator.validators
RequiredStringValidator checks that a String field is non-null and has a length > 0.
RequiredStringValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.RequiredStringValidator

RequiredStringValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
RequiredStringValidatorDescription
RequiredStringValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription

RequiredStringValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
res - Variable in class org.apache.struts2.components.ActionComponent

res - Variable in class org.apache.struts2.components.Include

res - Variable in class org.apache.struts2.components.OptGroup

res - Variable in class org.apache.struts2.components.URL

res - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

res - Variable in class org.apache.struts2.views.freemarker.tags.TagModel

reset() - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Clears all the internal lists.
reset() - Static method in class com.opensymphony.xwork2.util.OgnlValueStack

Reset - Class in org.apache.struts2.components
Render a reset button.
Reset(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Reset

reset() - Static method in class org.apache.struts2.config.Settings
Resets the default and any plugin Setting instance to null.
reset - Variable in class org.apache.struts2.interceptor.ScopeInterceptor

reset(String) - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

reset - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

resetAction(PortletRequest) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Check to see if the action parameter is valid for the current portlet mode.
resetActionContext() - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Reset the action context.
ResetDirective - Class in org.apache.struts2.views.velocity.components

ResetDirective() - Constructor for class org.apache.struts2.views.velocity.components.ResetDirective

resetInstance() - Static method in class com.opensymphony.xwork2.util.XWorkConverter

ResetModel - Class in org.apache.struts2.views.freemarker.tags

ResetModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.ResetModel

ResetTag - Class in org.apache.struts2.views.jsp.ui

ResetTag() - Constructor for class org.apache.struts2.views.jsp.ui.ResetTag

resolve(String, String) - Method in class org.apache.struts2.views.xslt.ServletURIResolver

resolveEntity(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

resolveMethod() - Method in class com.opensymphony.xwork2.DefaultActionProxy

resolveModel(ObjectFactory, ActionContext, String, String, String) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

resolvePropertyName(Method) - Static method in class com.opensymphony.xwork2.util.AnnotationUtils
Returns the property name for a method.
resolvePropertyName(Method) - Static method in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder
Returns the property name for a method.
ResolverUtil<T> - Class in com.opensymphony.xwork2.util
ResolverUtil is used to locate classes that are available in the/a class path and meet arbitrary conditions.
ResolverUtil() - Constructor for class com.opensymphony.xwork2.util.ResolverUtil

ResolverUtil.AnnotatedWith - Class in com.opensymphony.xwork2.util
A Test that checks to see if each class is annotated with a specific annotation.
ResolverUtil.AnnotatedWith(Class<? extends Annotation>) - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith
Construts an AnnotatedWith test for the specified annotation type.
ResolverUtil.IsA - Class in com.opensymphony.xwork2.util
A Test that checks to see if each class is assignable to the provided class.
ResolverUtil.IsA(Class) - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.IsA
Constructs an IsA test using the supplied Class as the parent class/interface.
ResolverUtil.NameEndsWith - Class in com.opensymphony.xwork2.util
A Test that checks to see if each class name ends with the provided suffix.
ResolverUtil.NameEndsWith(String) - Constructor for class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith
Constructs a NameEndsWith test using the supplied suffix.
ResolverUtil.Test - Interface in com.opensymphony.xwork2.util
A simple interface that specifies how to test classes to determine if they are to be included in the results produced by the ResolverUtil.
resource - Variable in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

ResourceUtil - Class in org.apache.struts2.views.util

ResourceUtil() - Constructor for class org.apache.struts2.views.util.ResourceUtil

response - Variable in class org.apache.struts2.components.UIBean

RESPONSE - Static variable in interface org.apache.struts2.portlet.PortletActionConstants
Key used for looking up and storing the PortletResponse
response - Variable in class org.apache.struts2.util.StrutsUtil

response - Variable in class org.apache.struts2.util.URLBean

RESPONSE - Static variable in class org.apache.struts2.views.util.ContextUtil

RESPONSE2 - Static variable in class org.apache.struts2.views.util.ContextUtil

Restful2ActionMapper - Class in org.apache.struts2.dispatcher.mapper
Improved restful action mapper that adds several ReST-style improvements to action mapping, but supports fully-customized URL's via XML.
Restful2ActionMapper() - Constructor for class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

RestfulActionMapper - Class in org.apache.struts2.dispatcher.mapper
A custom action mapper using the following format:

http://HOST/ACTION_NAME/PARAM_NAME1/PARAM_VALUE1/PARAM_NAME2/PARAM_VALUE2
You can have as many parameters you'd like to use.
RestfulActionMapper() - Constructor for class org.apache.struts2.dispatcher.mapper.RestfulActionMapper

result - Variable in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

result - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

result - Variable in class com.opensymphony.xwork2.mock.MockActionInvocation

Result - Interface in com.opensymphony.xwork2
All results (except for NONE) of an Action are mapped to a View implementation.
result - Variable in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
The result
Result - Annotation Type in org.apache.struts2.config
Defines an XWork Result
result - Variable in class org.apache.struts2.dispatcher.mapper.ActionMapping

result - Variable in class org.apache.struts2.interceptor.BackgroundProcess

resultCode - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

resultCode - Variable in class com.opensymphony.xwork2.mock.MockActionInvocation

ResultConfig - Class in com.opensymphony.xwork2.config.entities
Configuration for Result.
ResultConfig() - Constructor for class com.opensymphony.xwork2.config.entities.ResultConfig

ResultConfig(String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ResultConfig

ResultConfig(String, String, Map) - Constructor for class com.opensymphony.xwork2.config.entities.ResultConfig

results - Variable in class com.opensymphony.xwork2.config.entities.ActionConfig

Results - Annotation Type in org.apache.struts2.config
Defines multiple XWork Results
ResultTypeConfig - Class in com.opensymphony.xwork2.config.entities
Configuration class for result types.
ResultTypeConfig() - Constructor for class com.opensymphony.xwork2.config.entities.ResultTypeConfig

ResultTypeConfig(String, String, String) - Constructor for class com.opensymphony.xwork2.config.entities.ResultTypeConfig

resultTypeConfigs - Variable in class com.opensymphony.xwork2.config.entities.PackageConfig

RETRIEVE_MODE - Static variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

returnedResult - Variable in class com.opensymphony.xwork2.mock.MockActionProxy

RFC3339_FORMAT - Static variable in class org.apache.struts2.components.DateTimePicker

RFC3399_FORMAT - Static variable in class com.opensymphony.xwork2.util.XWorkBasicConverter

rightDownLabel - Variable in class org.apache.struts2.components.OptionTransferSelect

rightDownLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

rightTitle - Variable in class org.apache.struts2.components.InputTransferSelect

rightTitle - Variable in class org.apache.struts2.components.OptionTransferSelect

rightTitle - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

rightTitle - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

rightUpLabel - Variable in class org.apache.struts2.components.OptionTransferSelect

rightUpLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

RolesInterceptor - Class in org.apache.struts2.interceptor
This interceptor ensures that the action will only be executed if the user has the correct role.
RolesInterceptor() - Constructor for class org.apache.struts2.interceptor.RolesInterceptor

root - Variable in class com.opensymphony.xwork2.util.OgnlValueStack

root - Variable in class org.apache.struts2.util.PrefixTrie

rootElement - Variable in class org.apache.struts2.views.xslt.SimpleAdapterDocument

rootNode - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

rootNodeAttr - Variable in class org.apache.struts2.components.Tree

rows - Variable in class org.apache.struts2.components.table.SortFilterModel

rows - Variable in class org.apache.struts2.components.TextArea

rows - Variable in class org.apache.struts2.views.jsp.ui.TextareaTag

rule - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

runtimeConfiguration - Variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

RuntimeConfiguration - Interface in com.opensymphony.xwork2.config
RuntimeConfiguration

S

saveLocale(ActionInvocation, Locale) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor
Save the given locale to the ActionInvocation.
sc - Variable in class org.apache.struts2.views.xslt.ServletURIResolver

scheme - Variable in class org.apache.struts2.components.URL

scheme - Variable in class org.apache.struts2.views.jsp.URLTag

scope - Variable in class com.opensymphony.xwork2.config.impl.LocatableFactory

Scope - Enum in com.opensymphony.xwork2.inject
Scope of an injected objects.
Scope() - Constructor for enum com.opensymphony.xwork2.inject.Scope

scope - Variable in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

scope - Variable in class org.apache.struts2.components.Set

scope - Variable in class org.apache.struts2.views.jsp.SetTag

Scope.Strategy - Interface in com.opensymphony.xwork2.inject
Pluggable scoping strategy.
Scoped - Annotation Type in com.opensymphony.xwork2.inject
Annotates a scoped implementation class.
ScopedModelDriven<T> - Interface in com.opensymphony.xwork2.interceptor
Adds the ability to set a model, probably retrieved from a given state.
ScopedModelDrivenInterceptor - Class in com.opensymphony.xwork2.interceptor
An interceptor that enables scoped model-driven actions.
ScopedModelDrivenInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

scopeFactory(Class<T>, String, InternalFactory<? extends T>) - Method in enum com.opensymphony.xwork2.inject.Scope
Wraps factory with scoping logic.
ScopeInterceptor - Class in org.apache.struts2.interceptor
This is designed to solve a few simple issues related to wizard-like functionality in Struts.
ScopeInterceptor() - Constructor for class org.apache.struts2.interceptor.ScopeInterceptor
The constructor
ScopesHashModel - Class in org.apache.struts2.views.freemarker
Simple Hash model that also searches other scopes.
ScopesHashModel(ObjectWrapper, ServletContext, HttpServletRequest, ValueStack) - Constructor for class org.apache.struts2.views.freemarker.ScopesHashModel

scopeStrategy - Variable in class com.opensymphony.xwork2.inject.InternalContext

searchType - Variable in class org.apache.struts2.components.Autocompleter

searchType - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

Select - Class in org.apache.struts2.components
Render an HTML input tag of type select.
Select(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Select

select - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

selectAllLabel - Variable in class org.apache.struts2.components.OptionTransferSelect

selectAllLabel - Variable in class org.apache.struts2.components.UpDownSelect

selectAllLabel - Variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

selectAllLabel - Variable in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

SelectDirective - Class in org.apache.struts2.views.velocity.components

SelectDirective() - Constructor for class org.apache.struts2.views.velocity.components.SelectDirective

selectedIndex - Variable in class org.apache.struts2.util.TabbedPane

selectedTab - Variable in class org.apache.struts2.components.TabbedPanel

selectedTab - Variable in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

SelectModel - Class in org.apache.struts2.views.freemarker.tags

SelectModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.SelectModel

SelectTag - Class in org.apache.struts2.views.jsp.ui

SelectTag() - Constructor for class org.apache.struts2.views.jsp.ui.SelectTag

sendError(HttpServletRequest, HttpServletResponse, ServletContext, int, Exception) - Method in class org.apache.struts2.dispatcher.Dispatcher
Send an HTTP error response code.
separator - Variable in class org.apache.struts2.util.IteratorGenerator

separatorAttr - Variable in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

SEPARATORS - Static variable in class com.opensymphony.xwork2.util.PropertiesReader
The list of possible key/value separators
sequence - Variable in class org.apache.struts2.components.Form

serializeIt(Object, String, PrettyPrintWriter, List<Object>) - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor
Recursive function to serialize objects to XML.
serialVersionUID - Static variable in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties

serialVersionUID - Static variable in class com.opensymphony.xwork2.DefaultActionInvocation

serialVersionUID - Static variable in class com.opensymphony.xwork2.DefaultActionProxy

serialVersionUID - Static variable in class com.opensymphony.xwork2.inject.util.ReferenceCache

serialVersionUID - Static variable in class com.opensymphony.xwork2.inject.util.ReferenceMap

serialVersionUID - Static variable in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

serialVersionUID - Static variable in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

serialVersionUID - Static variable in class com.opensymphony.xwork2.interceptor.PrepareInterceptor

serialVersionUID - Static variable in class com.opensymphony.xwork2.util.OgnlValueStack

serialVersionUID - Static variable in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

serialVersionUID - Static variable in class org.apache.struts2.components.table.RenderFilterModel

serialVersionUID - Static variable in class org.apache.struts2.components.table.SortFilterModel

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.ApplicationMap

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.DefaultActionSupport

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.HttpHeaderResult

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.PlainTextResult

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.RequestMap

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.ServletActionRedirectResult

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.ServletDispatcherResult

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.ServletRedirectResult

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.SessionMap

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.StreamResult

serialVersionUID - Static variable in class org.apache.struts2.dispatcher.VelocityResult

serialVersionUID - Static variable in class org.apache.struts2.impl.StrutsActionProxy

serialVersionUID - Static variable in class org.apache.struts2.interceptor.BackgroundProcess

serialVersionUID - Static variable in class org.apache.struts2.interceptor.CheckboxInterceptor
Auto-generated serialization id
serialVersionUID - Static variable in class org.apache.struts2.interceptor.CreateSessionInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.FileUploadInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.ScopeInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.ServletConfigInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.StrutsConversionErrorInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.TokenInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.TokenSessionStoreInterceptor

serialVersionUID - Static variable in class org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor
Auto-generated serialization id
serialVersionUID - Static variable in class org.apache.struts2.portlet.context.PreparatorServlet

serialVersionUID - Static variable in class org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction

serialVersionUID - Static variable in class org.apache.struts2.portlet.PortletApplicationMap

serialVersionUID - Static variable in class org.apache.struts2.portlet.result.PortletResult

serialVersionUID - Static variable in class org.apache.struts2.portlet.result.PortletVelocityResult

serialVersionUID - Static variable in class org.apache.struts2.ServletActionContext

serialVersionUID - Static variable in exception org.apache.struts2.StrutsException

serialVersionUID - Static variable in class org.apache.struts2.util.Counter

serialVersionUID - Static variable in class org.apache.struts2.util.InvocationSessionStore.InvocationContext

serialVersionUID - Static variable in class org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation

serialVersionUID - Static variable in class org.apache.struts2.validators.DWRValidator.ValidatorActionProxy

serialVersionUID - Static variable in class org.apache.struts2.views.freemarker.FreemarkerResult

serialVersionUID - Static variable in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

serialVersionUID - Static variable in class org.apache.struts2.views.freemarker.ScopesHashModel

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ActionTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.BeanTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.DateTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ElseIfTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ElseTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.I18nTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.IfTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.IncludeTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.iterator.AppendIteratorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.iterator.MergeIteratorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.iterator.SortIteratorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.IteratorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ParamTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.PropertyTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.PushTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.SetTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.TextTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.ActionErrorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.ActionMessageTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.AnchorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.CheckboxListTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.CheckboxTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.ComboBoxTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.ComponentTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.DebugTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.DivTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.DoubleSelectTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.FieldErrorTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.FileTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.FormTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.HeadTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.HiddenTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.LabelTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.OptGroupTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.PasswordTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.RadioTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.ResetTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.SelectTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.SubmitTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.table.WebTableTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.TextareaTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.TextFieldTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.TokenTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.TreeNodeTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.TreeTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

serialVersionUID - Static variable in class org.apache.struts2.views.jsp.URLTag

serialVersionUID - Static variable in class org.apache.struts2.views.JspSupportServlet

serialVersionUID - Static variable in class org.apache.struts2.views.velocity.StrutsVelocityContext

serialVersionUID - Static variable in class org.apache.struts2.views.xslt.XSLTResult

serveStatic - Static variable in class org.apache.struts2.dispatcher.FilterDispatcher
Store state of StrutsConstants.STRUTS_SERVE_STATIC_CONTENT setting.
serveStaticBrowserCache - Static variable in class org.apache.struts2.dispatcher.FilterDispatcher
Store state of StrutsConstants.STRUTS_SERVE_STATIC_BROWSER_CACHE setting.
service(HttpServletRequest, HttpServletResponse) - Method in class org.apache.struts2.portlet.context.PreparatorServlet
Prepares the ServletActionContext with the ServletContext, HttpServletRequest and HttpServletResponse.
serviceAction(HttpServletRequest, HttpServletResponse, ServletContext, ActionMapping) - Method in class org.apache.struts2.dispatcher.Dispatcher
Load Action class for mapping and invoke the appropriate Action method, or go directly to the Result.
serviceAction(PortletRequest, PortletResponse, ActionMapping, Map, Map, Map, Map, String, Integer) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Loads the action and executes it.
SERVLET_CONTEXT - Static variable in interface org.apache.struts2.StrutsStatics
Constant for the servlet context object.
SERVLET_DISPATCHER - Static variable in interface org.apache.struts2.StrutsStatics
Constant for an HTTP request dispatcher.
ServletActionContext - Class in org.apache.struts2
Web-specific context information for actions.
ServletActionContext(Map) - Constructor for class org.apache.struts2.ServletActionContext

ServletActionRedirectResult - Class in org.apache.struts2.dispatcher
This result uses the ActionMapper provided by the ActionMapperFactory to redirect the browser to a URL that invokes the specified action and (optional) namespace.
ServletActionRedirectResult() - Constructor for class org.apache.struts2.dispatcher.ServletActionRedirectResult

ServletActionRedirectResult(String) - Constructor for class org.apache.struts2.dispatcher.ServletActionRedirectResult

ServletActionRedirectResult(String, String) - Constructor for class org.apache.struts2.dispatcher.ServletActionRedirectResult

ServletActionRedirectResult(String, String, String) - Constructor for class org.apache.struts2.dispatcher.ServletActionRedirectResult

ServletConfigInterceptor - Class in org.apache.struts2.interceptor
An interceptor which sets action properties based on the interfaces an action implements.
ServletConfigInterceptor() - Constructor for class org.apache.struts2.interceptor.ServletConfigInterceptor

servletContext - Variable in class org.apache.struts2.config.ServletContextSingleton
The web servlet context.
servletContext - Variable in class org.apache.struts2.config.StrutsXmlConfigurationProvider

servletContext - Variable in class org.apache.struts2.dispatcher.Dispatcher

servletContext - Variable in class org.apache.struts2.views.freemarker.ScopesHashModel

ServletContextAware - Interface in org.apache.struts2.util
For components that have a dependence on the Servlet context.
ServletContextHolderListener - Class in org.apache.struts2.portlet.context
Some of the factory/managers (e.g.
ServletContextHolderListener() - Constructor for class org.apache.struts2.portlet.context.ServletContextHolderListener

ServletContextSingleton - Class in org.apache.struts2.config
This singleton holds an instance of the web servlet context.
ServletContextSingleton() - Constructor for class org.apache.struts2.config.ServletContextSingleton
Constructor which cannot be called publicly.
ServletDispatcherResult - Class in org.apache.struts2.dispatcher
Includes or forwards to a view (usually a jsp).
ServletDispatcherResult() - Constructor for class org.apache.struts2.dispatcher.ServletDispatcherResult

ServletDispatcherResult(String) - Constructor for class org.apache.struts2.dispatcher.ServletDispatcherResult

servletPath - Variable in class org.apache.struts2.portlet.util.HttpServletRequestMock

ServletPortletPreferences - Class in org.apache.struts2.portlet.interceptor
Simple portlet preferences implementation that uses a map in the Session as storage.
ServletPortletPreferences(Map) - Constructor for class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

ServletPrincipalProxy - Class in org.apache.struts2.servlet.interceptor
PrincipalProxy implementation for using HttpServletRequest Principal related methods.
ServletPrincipalProxy(HttpServletRequest) - Constructor for class org.apache.struts2.servlet.interceptor.ServletPrincipalProxy
Constructs a proxy
ServletRedirectResult - Class in org.apache.struts2.dispatcher
Calls the sendRedirect method to the location specified.
ServletRedirectResult() - Constructor for class org.apache.struts2.dispatcher.ServletRedirectResult

ServletRedirectResult(String) - Constructor for class org.apache.struts2.dispatcher.ServletRedirectResult

ServletRequestAware - Interface in org.apache.struts2.interceptor
All Actions that want to have access to the servlet request object must implement this interface.
ServletResponseAware - Interface in org.apache.struts2.interceptor
All Actions that want to have access to the servlet response object must implement this interface.
ServletURIResolver - Class in org.apache.struts2.views.xslt
ServletURIResolver is a URIResolver that can retrieve resources from the servlet context using the scheme "response".
ServletURIResolver(ServletContext) - Constructor for class org.apache.struts2.views.xslt.ServletURIResolver

SESSION - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's session.
session - Variable in class org.apache.struts2.dispatcher.SessionMap

session - Variable in class org.apache.struts2.interceptor.ScopeInterceptor

session - Variable in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

session - Variable in class org.apache.struts2.portlet.PortletSessionMap

SESSION - Static variable in class org.apache.struts2.views.util.ContextUtil

SESSION_KEY - Static variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

SessionAware - Interface in org.apache.struts2.interceptor
Actions that want access to the user's HTTP session should implement this interface.
SessionMap - Class in org.apache.struts2.dispatcher
A simple implementation of the Map interface to handle a collection of HTTP session attributes.
SessionMap(HttpServletRequest) - Constructor for class org.apache.struts2.dispatcher.SessionMap
Creates a new session map given a http servlet request.
sessionReset - Variable in class org.apache.struts2.interceptor.ScopeInterceptor

set(String, Object) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

set(int, Object) - Method in class com.opensymphony.xwork2.util.SurrugateList

set(String, Object) - Method in interface com.opensymphony.xwork2.util.ValueStack
Sets an object on the stack with the given key so it is retrievable by findValue(key,...)
set(int, Object) - Method in class com.opensymphony.xwork2.util.XWorkList
Deprecated. Replaces the element at the specified position in this list with the specified element.
Set - Class in org.apache.struts2.components

Set(ValueStack) - Constructor for class org.apache.struts2.components.Set

set(String, String) - Static method in class org.apache.struts2.config.Settings
Registers a value for a setting.
set - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

SET_MAP_KEY - Static variable in class com.opensymphony.xwork2.util.OgnlContextState

setAbstract(boolean) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

setAccept(String) - Method in class org.apache.struts2.components.File

setAccept(String) - Method in class org.apache.struts2.views.jsp.ui.FileTag

setAcceptcharset(String) - Method in class org.apache.struts2.components.Form

setAcceptcharset(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setAccesskey(String) - Method in class org.apache.struts2.components.UIBean

setAccesskey(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setAction(Object) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

setAction(Object) - Method in class com.opensymphony.xwork2.mock.MockActionProxy

setAction(String) - Method in class org.apache.struts2.components.Form

setAction(String) - Method in class org.apache.struts2.components.FormButton

setAction(String) - Method in class org.apache.struts2.components.URL

setAction(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setAction(String) - Method in class org.apache.struts2.views.jsp.ui.ResetTag

setAction(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setAction(String) - Method in class org.apache.struts2.views.jsp.URLTag

setActionErrors(Collection) - Method in class com.opensymphony.xwork2.ActionSupport

setActionErrors(Collection) - Method in interface com.opensymphony.xwork2.ValidationAware
Set the Collection of Action-level String error messages.
setActionErrors(Collection) - Method in class com.opensymphony.xwork2.ValidationAwareSupport

setActionErrors(Collection) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

setActionErrors(Collection) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

setActionEventListener(ActionEventListener) - Method in interface com.opensymphony.xwork2.ActionInvocation
Sets the action event listener to respond to key action events
setActionEventListener(ActionEventListener) - Method in class com.opensymphony.xwork2.DefaultActionInvocation

setActionEventListener(ActionEventListener) - Method in class com.opensymphony.xwork2.DefaultActionProxy

setActionEventListener(ActionEventListener) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

setActionInvocation(ActionInvocation) - Method in class com.opensymphony.xwork2.ActionContext
Sets the action invocation (the execution state).
setActionMapper(ActionMapper) - Method in class org.apache.struts2.components.Component

setActionMapper(ActionMapper) - Static method in class org.apache.struts2.dispatcher.FilterDispatcher
Modify ActionMapper instance.
setActionMapper(ActionMapper) - Method in class org.apache.struts2.dispatcher.ServletRedirectResult

setActionMapper(ActionMapper) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

setActionMappers(String) - Method in class org.apache.struts2.dispatcher.mapper.CompositeActionMapper

setActionMessages(Collection) - Method in class com.opensymphony.xwork2.ActionSupport

setActionMessages(Collection) - Method in interface com.opensymphony.xwork2.ValidationAware
Set the Collection of Action-level String messages (not errors).
setActionMessages(Collection) - Method in class com.opensymphony.xwork2.ValidationAwareSupport

setActionMessages(Collection) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

setActionMessages(Collection) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

setActionName(String) - Method in class com.opensymphony.xwork2.ActionChainResult
Set the action name.
setActionName(String) - Method in class com.opensymphony.xwork2.mock.MockActionProxy

setActionName(String) - Method in class org.apache.struts2.dispatcher.ServletActionRedirectResult
Sets the action name
setActionProxyFactory(ActionProxyFactory) - Method in class com.opensymphony.xwork2.ActionChainResult

setActionProxyFactory(ActionProxyFactory) - Method in class org.apache.struts2.components.ActionComponent

setActionProxyFactory(ActionProxyFactory) - Method in class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher
Convenience method to ease testing.
setActive(boolean) - Static method in class com.opensymphony.xwork2.util.profiling.UtilTimerStack
Turn profiling on or off.
setAdapterFactory(AdapterFactory) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setAdapterFactory(AdapterFactory) - Method in interface org.apache.struts2.views.xslt.AdapterNode
The adapter factory that created this node.
setAdapterFactory(AdapterFactory) - Method in class org.apache.struts2.views.xslt.XSLTResult

setAdd(long) - Method in class org.apache.struts2.util.Counter

setAddAllToLeftLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAddAllToLeftLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAddAllToRightLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAddAllToRightLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAddLabel(String) - Method in class org.apache.struts2.components.InputTransferSelect

setAddLabel(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setAddToLeftLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAddToLeftLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAddToRightLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAddToRightLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAdjustWeeks(String) - Method in class org.apache.struts2.components.DateTimePicker

setAdjustWeeks(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setAfterLoading(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setAfterLoading(String) - Method in class org.apache.struts2.components.Anchor

setAfterLoading(String) - Method in class org.apache.struts2.components.Div

setAfterLoading(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setAfterLoading(String) - Method in class org.apache.struts2.components.Submit

setAfterLoading(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setAliasesKey(String) - Method in class com.opensymphony.xwork2.interceptor.AliasInterceptor

setAlign(String) - Method in class org.apache.struts2.components.FormButton

setAlign(String) - Method in class org.apache.struts2.views.jsp.ui.ResetTag

setAlign(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setAlignment(String) - Method in class org.apache.struts2.components.table.renderer.AbstractCellRenderer

setAllowAddAllToLeft(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAllowAddAllToLeft(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAllowAddAllToRight(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAllowAddAllToRight(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAllowAddToLeft(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAllowAddToLeft(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAllowAddToRight(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAllowAddToRight(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAllowDynamicMethodCalls(String) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

setAllowed(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

setAllowedCollection(Collection) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

setAllowedRoles(String) - Method in class org.apache.struts2.interceptor.RolesInterceptor

setAllowedTypes(String) - Method in class org.apache.struts2.interceptor.FileUploadInterceptor
Sets the allowed mimetypes
setAllowMoveDown(String) - Method in class org.apache.struts2.components.UpDownSelect

setAllowMoveDown(String) - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

setAllowMoveUp(String) - Method in class org.apache.struts2.components.UpDownSelect

setAllowMoveUp(String) - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

setAllowRemoveAll(String) - Method in class org.apache.struts2.components.InputTransferSelect

setAllowRemoveAll(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setAllowRequestParameterSwitch(boolean) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

setAllowSelectAll(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAllowSelectAll(String) - Method in class org.apache.struts2.components.UpDownSelect

setAllowSelectAll(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAllowSelectAll(String) - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

setAllowUpDown(String) - Method in class org.apache.struts2.components.InputTransferSelect

setAllowUpDown(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setAllowUpDownOnLeft(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAllowUpDownOnLeft(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAllowUpDownOnRight(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setAllowUpDownOnRight(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setAltSyntax(String) - Static method in class org.apache.struts2.views.util.ContextUtil

setAlwaysInvokePrepare(String) - Method in class com.opensymphony.xwork2.interceptor.PrepareInterceptor

setAlwaysInvokeValidate(String) - Method in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
Determine if Validateable's validate() should always be invoked.
setAlwaysSelectFullNamespace(String) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

setAnchor(String) - Method in class org.apache.struts2.components.URL

setAnchor(String) - Method in class org.apache.struts2.views.jsp.URLTag

setAppendPrefix(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

setAppendPrefix(boolean) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator
Sets whether the field name of this field validator should be prepended to the field name of the visited field to determine the full field name when an error occurs.
setApplication(Map) - Method in class com.opensymphony.xwork2.ActionContext
Sets the action's application context.
setApplication(Map) - Method in interface org.apache.struts2.interceptor.ApplicationAware
Sets the map of application properties in the implementing class.
setApplication(String) - Method in class org.apache.struts2.interceptor.ScopeInterceptor
Sets a list of application scoped properties
setApplicationContext(ApplicationContext) - Method in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

setApplicationContext(ApplicationContext) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Set the Spring ApplicationContext that should be used to look beans up with.
setApplicationContextPath(String) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory

setAttribute(String, Object) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

setAttribute(String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

setAttribute(String, String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

setAttributeName(String) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor

setAttributeNode(Attr) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

setAttributeNode(Attr) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

setAttributeNodeNS(Attr) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

setAttributeNodeNS(Attr) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

setAttributeNS(String, String, String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

setAttributeNS(String, String, String) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

setAutoComplete(String) - Method in class org.apache.struts2.components.Autocompleter

setAutoComplete(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setAutoCreateSession(String) - Method in class org.apache.struts2.interceptor.ScopeInterceptor
Sets if the session should be automatically created
setAutoStart(String) - Method in class org.apache.struts2.components.Div

setAutoStart(String) - Method in class org.apache.struts2.views.jsp.ui.DivTag

setAutowireStrategy(Integer) - Method in class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

setAutowireStrategy(int) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Sets the autowiring strategy
setBeforeLoading(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setBeforeLoading(String) - Method in class org.apache.struts2.components.Anchor

setBeforeLoading(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setBeforeLoading(String) - Method in class org.apache.struts2.components.Submit

setBeforeLoading(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setBlankIconSrc(String) - Method in class org.apache.struts2.components.Tree

setBlankIconSrc(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setBlocked(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

setBlockedCollection(Collection) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

setBooleanValue(String, Map, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setBufferSize(int) - Method in class org.apache.struts2.dispatcher.StreamResult

setBundle(ResourceBundle) - Method in class com.opensymphony.xwork2.TextProviderSupport

setButtonCssClass(String) - Method in class org.apache.struts2.components.InputTransferSelect

setButtonCssClass(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setButtonCssClass(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setButtonCssClass(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setButtonCssStyle(String) - Method in class org.apache.struts2.components.InputTransferSelect

setButtonCssStyle(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setButtonCssStyle(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setButtonCssStyle(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setCalendarcss(String) - Method in class org.apache.struts2.components.Head

setCalendarcss(String) - Method in class org.apache.struts2.views.jsp.ui.HeadTag

setCaseSensitive(boolean) - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
Sets whether the expression should be matched against in a case-sensitive way.
setChainedContexts(String) - Method in class org.apache.struts2.views.velocity.VelocityManager
allow users to specify via the struts.properties file a set of additional VelocityContexts to chain to the the StrutsVelocityContext.
setCharacterEncoding(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

setCharSet(String) - Method in class org.apache.struts2.dispatcher.PlainTextResult
Set the character set
setChildCollectionProperty(String) - Method in class org.apache.struts2.components.Tree

setChildCollectionProperty(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setClassLoader(ClassLoader) - Method in class com.opensymphony.xwork2.ObjectFactory

setClassLoader(ClassLoader) - Method in class com.opensymphony.xwork2.util.ResolverUtil
Sets an explicit ClassLoader that should be used when scanning for classes.
setClassName(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

setClassName(String) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

setClassName(String) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

setClassName(String) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

setClazz(String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

setClazz(Class) - Method in class com.opensymphony.xwork2.TextProviderSupport

setCloseButton(String) - Method in class org.apache.struts2.components.TabbedPanel

setCloseButton(String) - Method in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

setCols(String) - Method in class org.apache.struts2.components.TextArea

setCols(String) - Method in class org.apache.struts2.views.jsp.ui.TextareaTag

setColumnDisplayName(int, String) - Method in class org.apache.struts2.components.table.WebTable

setColumnHidden(int, boolean) - Method in class org.apache.struts2.components.table.WebTable

setColumnRenderer(int, CellRenderer) - Method in class org.apache.struts2.components.table.WebTable

setComparator(Comparator) - Method in class org.apache.struts2.util.SortIteratorFilter

setComparator(String) - Method in class org.apache.struts2.views.jsp.iterator.SortIteratorTag

setConfig(ActionConfig) - Method in class com.opensymphony.xwork2.mock.MockActionProxy

setConfiguration(Configuration) - Method in class com.opensymphony.xwork2.config.ConfigurationManager

setConfiguration(Configuration) - Method in class com.opensymphony.xwork2.DefaultActionProxy

setConfiguration(Configuration) - Method in class org.apache.struts2.components.Form

setConfiguration(Configuration) - Method in class org.apache.struts2.config.MethodConfigurationProvider
Updates configuration property.
setConfigurationManager(ConfigurationManager) - Method in class org.apache.struts2.dispatcher.Dispatcher
Modify the ConfigurationManager instance
setConfigurationProviders(List<ConfigurationProvider>) - Method in class com.opensymphony.xwork2.config.ConfigurationManager
Set the list of configuration providers
setConstants(ContainerBuilder) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties

setContainer(Container) - Method in class com.opensymphony.xwork2.DefaultActionProxyFactory

setContainer(Container) - Method in class com.opensymphony.xwork2.ObjectFactory

setContainer(Container) - Method in class org.apache.struts2.components.OptGroup

setContainer(Container) - Method in class org.apache.struts2.components.template.TemplateEngineManager

setContainer(Container) - Method in class org.apache.struts2.dispatcher.mapper.CompositeActionMapper

setContainer(Container) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

setContainer(Container) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager

setContainer(Container) - Method in class org.apache.struts2.views.velocity.VelocityManager

setContent(Vector) - Method in class org.apache.struts2.util.TabbedPane

setContentDisposition(String) - Method in class org.apache.struts2.dispatcher.StreamResult

setContentLength(String) - Method in class org.apache.struts2.dispatcher.StreamResult

setContentType(String) - Method in class org.apache.struts2.dispatcher.StreamResult

setContentType(String) - Method in class org.apache.struts2.portlet.result.PortletResult
Sets the content type.
setContentType(String) - Method in class org.apache.struts2.views.freemarker.FreemarkerResult

setContentType(String) - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

setContext(ActionContext) - Static method in class com.opensymphony.xwork2.ActionContext
Sets the action context for the current thread.
setContext(String) - Method in class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

setContext(String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

setContext(AdapterFactory, AdapterNode, String, Object) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setContextMap(Map) - Method in class com.opensymphony.xwork2.ActionContext
Sets the action's context map.
setConversionErrors(Map) - Method in class com.opensymphony.xwork2.ActionContext
Sets conversion errors which occurred when executing the action.
setConverter(IteratorGenerator.Converter) - Method in class org.apache.struts2.util.IteratorGenerator

setConverter(String) - Method in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

setCount(int) - Method in class org.apache.struts2.util.IteratorGenerator

setCount(int) - Method in class org.apache.struts2.util.SubsetIteratorFilter

setCount(String) - Method in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

setCount(String) - Method in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

setCreatingNullObjects(Map, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setCssClass(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setCssClass(String) - Method in class org.apache.struts2.components.UIBean

setCssClass(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setCssId(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setCssStyle(String) - Method in class org.apache.struts2.components.UIBean

setCssStyle(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setCurrent(long) - Method in class org.apache.struts2.util.Counter

setCurrentReference(T) - Method in class com.opensymphony.xwork2.inject.ConstructionContext

setCustomConfigFile(String) - Method in class org.apache.struts2.views.velocity.VelocityManager

setCustomEncoding(String) - Static method in class org.apache.struts2.views.util.UrlHelper

setData(String) - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

setData(String) - Method in class org.apache.struts2.views.xslt.SimpleTextNode

setDate(String) - Method in class org.apache.struts2.util.DateFormatter

setDate(Date) - Method in class org.apache.struts2.util.DateFormatter

setDate(int) - Method in class org.apache.struts2.util.DateFormatter

setDayWidth(String) - Method in class org.apache.struts2.components.DateTimePicker

setDayWidth(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setDebug(boolean) - Method in class org.apache.struts2.components.Head

setDebug(String) - Method in class org.apache.struts2.views.jsp.ui.HeadTag

setDecider(SubsetIteratorFilter.Decider) - Method in class org.apache.struts2.util.SubsetIteratorFilter

setDecider(String) - Method in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

setDefault(String) - Method in class org.apache.struts2.components.Property

setDefault(String) - Method in class org.apache.struts2.views.jsp.PropertyTag

setDefaultActionRef(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

setDefaultBlock(boolean) - Method in class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

setDefaultClassRef(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

setDefaultConverter(TypeConverter) - Method in class com.opensymphony.xwork2.util.XWorkConverter

setDefaultEncoding(String) - Static method in class org.apache.struts2.components.Include

setDefaultEncoding(String) - Static method in class org.apache.struts2.dispatcher.Dispatcher
Modify state of StrutsConstants.STRUTS_I18N_ENCODING setting.
setDefaultEncoding(String) - Method in class org.apache.struts2.dispatcher.VelocityResult

setDefaultEncoding(String) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult

setDefaultInterceptorRef(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

setDefaultLocale(String) - Static method in class org.apache.struts2.dispatcher.Dispatcher
Modify state of StrutsConstants.STRUTS_LOCALE setting.
setDefaultMessage(String) - Method in interface com.opensymphony.xwork2.validator.Validator

setDefaultMessage(String) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

setDefaultMessage(String) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

setDefaultPageExtension(String) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Register a default page extension to use when locating pages.
setDefaultPagePrefix(String) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Reigster a default page prefix to use when locating pages.
setDefaultParentPackage(String) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Register a default parent package for the actions.
setDefaultResultParam(String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

setDefaultResults(Map<String, ResultConfig>, PackageConfig) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration

setDefaultResultType(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig
sets the default Result type for this package
setDefaultTemplateDir(String) - Method in class org.apache.struts2.components.UIBean

setDefaultTemplateType(String) - Method in class org.apache.struts2.components.template.TemplateEngineManager

setDefaultType(Class) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

setDefaultType(Class) - Method in interface com.opensymphony.xwork2.util.ValueStack
Sets the default type to convert to if no type is provided when getting a value.
setDefaultUITheme(String) - Method in class org.apache.struts2.components.UIBean

setDelay(String) - Method in class org.apache.struts2.components.Autocompleter

setDelay(String) - Method in class org.apache.struts2.components.Div

setDelay(int) - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
Sets the initial delay in millis (msec).
setDelay(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setDelay(String) - Method in class org.apache.struts2.views.jsp.ui.DivTag

setDelaySleepInterval(int) - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
Sets the sleep interval in millis (msec) when performing the initial delay.
setDelegate(T) - Method in class com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler

setDenyMethodExecution(Map, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setDevMode(String) - Static method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

setDevMode(String) - Static method in class com.opensymphony.xwork2.util.OgnlValueStack

setDevMode(String) - Static method in class org.apache.struts2.dispatcher.Dispatcher
Modify state of StrutsConstants.STRUTS_DEVMODE setting.
setDevMode(String) - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

setDevMode(String) - Method in class org.apache.struts2.interceptor.ProfilingActivationInterceptor

SetDirective - Class in org.apache.struts2.views.velocity.components

SetDirective() - Constructor for class org.apache.struts2.views.velocity.components.SetDirective

setDisabled(String) - Method in class org.apache.struts2.components.Autocompleter

setDisabled(String) - Method in class org.apache.struts2.components.OptGroup

setDisabled(String) - Method in class org.apache.struts2.components.UIBean

setDisabled(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setDisabled(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setDisabled(String) - Method in class org.apache.struts2.views.jsp.ui.OptGroupTag

setDisallowedRoles(String) - Method in class org.apache.struts2.interceptor.RolesInterceptor

setDisplayFormat(String) - Method in class org.apache.struts2.components.DateTimePicker

setDisplayFormat(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setDisplayName(String) - Method in class org.apache.struts2.components.table.WebTableColumn

setDisplayWeeks(String) - Method in class org.apache.struts2.components.DateTimePicker

setDisplayWeeks(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setDocumentLocator(Locator) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

setDocumentLocator(Locator) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

setDocumentLocator(Locator) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

setDocumentURI(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

setDoLayout(String) - Method in class org.apache.struts2.components.TabbedPanel

setDoLayout(String) - Method in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

setDoubleAccesskey(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleAccesskey(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleCssClass(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleCssClass(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleCssStyle(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleCssStyle(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleDisabled(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleDisabled(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleEmptyOption(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleEmptyOption(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleHeaderKey(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleHeaderKey(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleHeaderValue(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleHeaderValue(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleId(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleId(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleList(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleList(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleListKey(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleListKey(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleListValue(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleListValue(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleMultiple(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleMultiple(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleName(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleName(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnblur(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnblur(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnchange(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnchange(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnclick(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnclick(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOndblclick(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOndblclick(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnfocus(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnfocus(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnkeydown(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnkeydown(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnkeypress(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnkeypress(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnkeyup(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnkeyup(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnmousedown(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnmousedown(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnmousemove(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnmousemove(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnmouseout(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnmouseout(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnmouseover(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnmouseover(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnmouseup(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnmouseup(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleOnselect(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleOnselect(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleSize(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleSize(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDoubleValue(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setDoubleValue(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setDownLabel(String) - Method in class org.apache.struts2.components.InputTransferSelect

setDownLabel(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setDropdownHeight(String) - Method in class org.apache.struts2.components.Autocompleter

setDropdownHeight(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setDropdownWidth(String) - Method in class org.apache.struts2.components.Autocompleter

setDropdownWidth(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setDtdMappings(Map<String, String>) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

setElementClass(Class) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

setEmptyOption(String) - Method in class org.apache.struts2.components.ComboBox

setEmptyOption(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setEmptyOption(String) - Method in class org.apache.struts2.components.Select

setEmptyOption(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setEmptyOption(String) - Method in class org.apache.struts2.views.jsp.ui.ComboBoxTag

setEmptyOption(String) - Method in class org.apache.struts2.views.jsp.ui.SelectTag

setEnableDynamicMethodInvocation(String) - Method in class org.apache.struts2.components.Form

setEnableXmlWithConsole(boolean) - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

setEncode(boolean) - Method in class org.apache.struts2.components.URL

setEncode(boolean) - Method in class org.apache.struts2.dispatcher.StrutsResultSupport
Set encode to true to indicate that the location should be url encoded.
setEncode(String) - Method in class org.apache.struts2.views.jsp.URLTag

setEncoding(String) - Method in class org.apache.struts2.components.Head

setEncoding(String) - Static method in class org.apache.struts2.dispatcher.FilterDispatcher
Modify state of StrutsConstants.STRUTS_I18N_ENCODING setting.
setEncoding(String) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager

setEnctype(String) - Method in class org.apache.struts2.components.Form

setEnctype(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setEndDate(String) - Method in class org.apache.struts2.components.DateTimePicker

setEndDate(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setEndTime() - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

setErrorText(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setErrorText(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setErrorText(String) - Method in class org.apache.struts2.components.Submit

setErrorText(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setErrorText(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setEscape(boolean) - Method in class org.apache.struts2.components.Property

setEscape(boolean) - Method in class org.apache.struts2.views.jsp.PropertyTag

setExceptionClassName(String) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

setExcludeMethods(String) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

setExcludeParams(String) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Sets a comma-delimited list of regular expressions to match parameters that should be removed from the parameter map.
setExcludes(Collection) - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor

setExecuteAfterValidationPass(boolean) - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
Whether to start the background process after the second pass (first being validation) or not
setExecuteResult(boolean) - Method in interface com.opensymphony.xwork2.ActionProxy
Sets whether this ActionProxy should also execute the Result after executing the Action
setExecuteResult(boolean) - Method in class com.opensymphony.xwork2.DefaultActionProxy

setExecuteResult(boolean) - Method in class com.opensymphony.xwork2.mock.MockActionProxy

setExecuteResult(boolean) - Method in class org.apache.struts2.components.ActionComponent

setExecuteResult(boolean) - Method in class org.apache.struts2.views.jsp.ActionTag

setExecuteScripts(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setExecuteScripts(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setExecuteScripts(String) - Method in class org.apache.struts2.components.Submit

setExecuteScripts(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setExecuteScripts(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setExludingPattern(String) - Method in class org.apache.struts2.views.xslt.XSLTResult

setExpandIconSrcMinus(String) - Method in class org.apache.struts2.components.Tree

setExpandIconSrcMinus(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setExpandIconSrcPlus(String) - Method in class org.apache.struts2.components.Tree

setExpandIconSrcPlus(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setExpectedFoo(String) - Method in class com.opensymphony.xwork2.mock.MockInterceptor

setExposedValue(String) - Method in class org.apache.struts2.views.xslt.XSLTResult

setExpression(String) - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

setExpression(String) - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

setExpression(String) - Method in class com.opensymphony.xwork2.validator.validators.ExpressionValidator

setExpression(String) - Method in class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

setExpression(String) - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
Sets the regular expression to be matched.
setExprOverrides(Map) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

setExprOverrides(Map) - Method in interface com.opensymphony.xwork2.util.ValueStack

setExtensions(String) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

setExternalContext(ExternalContext<?>) - Method in class com.opensymphony.xwork2.inject.InternalContext

setExtraParameterProvider(URL.ExtraParameterProvider) - Method in class org.apache.struts2.components.URL

setFactory(ValueStackFactory) - Static method in class com.opensymphony.xwork2.util.ValueStackFactory

setFalseValue(String) - Method in class org.apache.struts2.components.table.renderer.BooleanCellRenderer

setFieldErrors(Map) - Method in class com.opensymphony.xwork2.ActionSupport

setFieldErrors(Map) - Method in interface com.opensymphony.xwork2.ValidationAware
Set the field error map of fieldname (String) to Collection of String error messages.
setFieldErrors(Map) - Method in class com.opensymphony.xwork2.ValidationAwareSupport

setFieldErrors(Map) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

setFieldErrors(Map) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

setFieldName(String) - Method in interface com.opensymphony.xwork2.validator.FieldValidator
Sets the field name to validate with this FieldValidator
setFieldName(String) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Sets the field name for this validator rule.
setFieldName(String) - Method in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

setFieldValue(String) - Method in class org.apache.struts2.components.Checkbox

setFieldValue(String) - Method in class org.apache.struts2.views.jsp.ui.CheckboxTag

setFilterConfig(FilterConfig) - Method in class org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61
dummy setter for FilterDispatcher.filterConfig; this method sets up the ServletContextSingleton with the servlet context from the filter configuration.
setFirst(long) - Method in class org.apache.struts2.util.Counter

setFlush(boolean) - Method in class org.apache.struts2.components.ActionComponent

setFlush(boolean) - Method in class org.apache.struts2.views.jsp.ActionTag

setFoo(String) - Method in class com.opensymphony.xwork2.mock.MockInterceptor

setFor(String) - Method in class org.apache.struts2.components.Label

setFor(String) - Method in class org.apache.struts2.views.jsp.ui.LabelTag

setForceLowerCase(String) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Whether to use a lowercase letter as the initial letter of an action.
setForceValidOption(String) - Method in class org.apache.struts2.components.Autocompleter

setForceValidOption(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setFormat(String) - Method in class org.apache.struts2.components.Date

setFormat(String) - Method in class org.apache.struts2.util.DateFormatter

setFormat(DateFormat) - Method in class org.apache.struts2.util.DateFormatter

setFormat(String) - Method in class org.apache.struts2.views.jsp.DateTag

setFormatLength(String) - Method in class org.apache.struts2.components.DateTimePicker

setFormatLength(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setFormatString(String) - Method in class org.apache.struts2.components.table.renderer.DateCellRenderer

setFormatString(String) - Method in class org.apache.struts2.components.table.renderer.NumericCellRenderer

setFormFilter(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setFormFilter(String) - Method in class org.apache.struts2.components.Autocompleter

setFormFilter(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setFormFilter(String) - Method in class org.apache.struts2.components.Submit

setFormFilter(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setFormFilter(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setFormFilter(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setFormId(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setFormId(String) - Method in class org.apache.struts2.components.Autocompleter

setFormId(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setFormId(String) - Method in class org.apache.struts2.components.Submit

setFormId(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setFormId(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setFormId(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setFormName(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setFormName(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setFreemarkerManager(FreemarkerManager) - Method in class org.apache.struts2.components.template.FreemarkerTemplateEngine

setFreemarkerManager(FreemarkerManager) - Method in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

setFreemarkerManager(FreemarkerManager) - Method in class org.apache.struts2.views.freemarker.FreemarkerResult

setFreemarkerManager(FreemarkerManager) - Method in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

setFullPropertyPath(Map, String) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setFullQualifiedClassName(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
The fullQualifiedClassName attribute is used to create the special conversion.properties file name.
setGettingByKeyProperty(Map, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setGridIconSrcC(String) - Method in class org.apache.struts2.components.Tree

setGridIconSrcC(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setGridIconSrcL(String) - Method in class org.apache.struts2.components.Tree

setGridIconSrcL(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setGridIconSrcP(String) - Method in class org.apache.struts2.components.Tree

setGridIconSrcP(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setGridIconSrcV(String) - Method in class org.apache.struts2.components.Tree

setGridIconSrcV(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setGridIconSrcX(String) - Method in class org.apache.struts2.components.Tree

setGridIconSrcX(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setGridIconSrcY(String) - Method in class org.apache.struts2.components.Tree

setGridIconSrcY(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setHandler(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setHandler(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setHandler(String) - Method in class org.apache.struts2.components.Submit

setHandler(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setHandler(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setHeaderKey(String) - Method in class org.apache.struts2.components.ComboBox

setHeaderKey(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setHeaderKey(String) - Method in class org.apache.struts2.components.InputTransferSelect

setHeaderKey(String) - Method in class org.apache.struts2.components.Select

setHeaderKey(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setHeaderKey(String) - Method in class org.apache.struts2.views.jsp.ui.ComboBoxTag

setHeaderKey(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setHeaderKey(String) - Method in class org.apache.struts2.views.jsp.ui.SelectTag

setHeaderValue(String) - Method in class org.apache.struts2.components.ComboBox

setHeaderValue(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setHeaderValue(String) - Method in class org.apache.struts2.components.InputTransferSelect

setHeaderValue(String) - Method in class org.apache.struts2.components.Select

setHeaderValue(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setHeaderValue(String) - Method in class org.apache.struts2.views.jsp.ui.ComboBoxTag

setHeaderValue(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setHeaderValue(String) - Method in class org.apache.struts2.views.jsp.ui.SelectTag

setHidden(boolean) - Method in class org.apache.struts2.components.table.WebTableColumn

setHref(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setHref(String) - Method in class org.apache.struts2.components.Autocompleter

setHref(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setHref(String) - Method in class org.apache.struts2.components.Submit

setHref(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setHref(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setHref(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setHttpPort(String) - Static method in class org.apache.struts2.views.util.UrlHelper

setHttpsPort(String) - Static method in class org.apache.struts2.views.util.UrlHelper

setIconHeight(String) - Method in class org.apache.struts2.components.Tree

setIconHeight(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setIconPath(String) - Method in class org.apache.struts2.components.Autocompleter

setIconPath(String) - Method in class org.apache.struts2.components.DateTimePicker

setIconPath(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setIconPath(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setIconWidth(String) - Method in class org.apache.struts2.components.Tree

setIconWidth(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setId(String) - Method in class org.apache.struts2.components.AppendIterator

setId(String) - Method in class org.apache.struts2.components.Component

setId(String) - Method in class org.apache.struts2.components.MergeIterator

setId(String) - Method in class org.apache.struts2.components.TabbedPanel

setId(String) - Method in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

setId(String) - Method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

setIdAttribute(String, boolean) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

setIdAttribute(String, boolean) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

setIdAttributeNode(Attr, boolean) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

setIdAttributeNode(Attr, boolean) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

setIdAttributeNS(String, String, boolean) - Method in class org.apache.struts2.views.xslt.AbstractAdapterElement

setIdAttributeNS(String, String, boolean) - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

setIgnoreContextParams(boolean) - Method in class org.apache.struts2.components.ActionComponent

setIgnoreContextParams(boolean) - Method in class org.apache.struts2.views.jsp.ActionTag

setImpl(String, String) - Method in class org.apache.struts2.config.DefaultSettings

setImpl(String, String) - Method in class org.apache.struts2.config.DelegatingSettings

setImpl(String, String) - Method in class org.apache.struts2.config.PropertiesSettings
Sets a property in the properties file.
setImpl(String, String) - Method in class org.apache.struts2.config.Settings
Implements the Settings.set(String, String) method.
setIncludeContext(boolean) - Method in class org.apache.struts2.components.URL

setIncludeContext(String) - Method in class org.apache.struts2.views.jsp.URLTag

setIncludeMethods(String) - Method in class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

setIncludeParams(String) - Method in class org.apache.struts2.components.URL

setIncludeParams(String) - Method in class org.apache.struts2.views.jsp.URLTag

setIncludes(Collection) - Method in class com.opensymphony.xwork2.interceptor.ChainingInterceptor

setIndicator(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setIndicator(String) - Method in class org.apache.struts2.components.Autocompleter

setIndicator(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setIndicator(String) - Method in class org.apache.struts2.components.Submit

setIndicator(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setIndicator(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setIndicator(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setInputName(String) - Method in class org.apache.struts2.dispatcher.StreamResult

setInputResultName(String) - Method in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor
Set the inputResultName (result name to be returned when a action / field error is found registered).
setInstance(TextProvider) - Static method in class com.opensymphony.xwork2.TextProviderFactory

setInstance(ObjectTypeDeterminer) - Static method in class com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory

setInstance(XWorkConverter) - Static method in class com.opensymphony.xwork2.util.XWorkConverter

setInstance(ActionValidatorManager) - Static method in class com.opensymphony.xwork2.validator.ActionValidatorManagerFactory

setInstance(Settings) - Static method in class org.apache.struts2.config.Settings
Registers a custom Settings implementation (plugin), and resets the cached locale.
setInstance(Dispatcher) - Static method in class org.apache.struts2.dispatcher.Dispatcher
Store the dispatcher instance for this thread.
setInterceptor(Interceptor) - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping

setInterval(long) - Method in class org.apache.struts2.util.Counter

setInvocation(ActionInvocation) - Method in class com.opensymphony.xwork2.mock.MockActionProxy

setInvocationContext(ActionContext) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

setInvocationMap(Map) - Static method in class org.apache.struts2.util.InvocationSessionStore

setKey(String) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Sets the I18N message key.
setKey(String) - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

setKey(String) - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

setKey(String) - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Sets the I18N message key.
setKey(String) - Method in class org.apache.struts2.components.UIBean

setKey(String) - Method in class org.apache.struts2.interceptor.ScopeInterceptor

setKey(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setKeyClass(Class) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

setKeyName(String) - Method in class org.apache.struts2.components.Autocompleter

setKeyName(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setKeyProperty(String) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

setLabel(String) - Method in class org.apache.struts2.components.OptGroup

setLabel(String) - Method in class org.apache.struts2.components.Reset

setLabel(String) - Method in class org.apache.struts2.components.TreeNode

setLabel(String) - Method in class org.apache.struts2.components.UIBean

setLabel(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptGroupTag

setLabel(String) - Method in class org.apache.struts2.views.jsp.ui.TreeNodeTag

setLabelposition(String) - Method in class org.apache.struts2.components.UIBean

setLabelposition(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setLanguage(String) - Method in class org.apache.struts2.components.DateTimePicker

setLanguage(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setLast(long) - Method in class org.apache.struts2.util.Counter

setLast(boolean) - Method in class org.apache.struts2.views.jsp.IteratorStatus.StatusState

setLastBeanClassAccessed(Map, Class) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setLastBeanPropertyAccessed(Map, String) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setLastClassAccessed(Class) - Method in class com.opensymphony.xwork2.util.ObjectProxy

setLastModified(long) - Method in class com.opensymphony.xwork2.util.FileManager.FileRevision

setLastPropertyAccessed(String) - Method in class com.opensymphony.xwork2.util.ObjectProxy

setLeftDownLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setLeftDownLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setLeftTitle(String) - Method in class org.apache.struts2.components.InputTransferSelect

setLeftTitle(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setLeftTitle(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setLeftTitle(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setLeftUpLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setLeftUpLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setLink(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setList(String) - Method in class org.apache.struts2.components.Autocompleter

setList(String) - Method in class org.apache.struts2.components.ComboBox

setList(Object) - Method in class org.apache.struts2.components.ListUIBean

setList(String) - Method in class org.apache.struts2.components.OptGroup

setList(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractListTag

setList(String) - Method in class org.apache.struts2.views.jsp.ui.ComboBoxTag

setList(String) - Method in class org.apache.struts2.views.jsp.ui.OptGroupTag

setListenTopics(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setListenTopics(String) - Method in class org.apache.struts2.components.Autocompleter

setListenTopics(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setListenTopics(String) - Method in class org.apache.struts2.components.Submit

setListenTopics(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setListenTopics(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setListenTopics(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setListKey(String) - Method in class org.apache.struts2.components.ComboBox

setListKey(String) - Method in class org.apache.struts2.components.ListUIBean

setListKey(String) - Method in class org.apache.struts2.components.OptGroup

setListKey(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractListTag

setListKey(String) - Method in class org.apache.struts2.views.jsp.ui.ComboBoxTag

setListKey(String) - Method in class org.apache.struts2.views.jsp.ui.OptGroupTag

setListValue(String) - Method in class org.apache.struts2.components.ComboBox

setListValue(String) - Method in class org.apache.struts2.components.ListUIBean

setListValue(String) - Method in class org.apache.struts2.components.OptGroup

setListValue(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractListTag

setListValue(String) - Method in class org.apache.struts2.views.jsp.ui.ComboBoxTag

setListValue(String) - Method in class org.apache.struts2.views.jsp.ui.OptGroupTag

setLoadingText(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setLoadingText(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setLoadingText(String) - Method in class org.apache.struts2.components.Submit

setLoadingText(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setLoadingText(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setLoadMinimumCount(String) - Method in class org.apache.struts2.components.Autocompleter

setLoadMinimumCount(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setLoadOnTextChange(String) - Method in class org.apache.struts2.components.Autocompleter

setLoadOnTextChange(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setLocale(Locale) - Method in class com.opensymphony.xwork2.ActionContext
Sets the Locale for the current action.
setLocaleProvider(LocaleProvider) - Method in class com.opensymphony.xwork2.TextProviderSupport

setLocation(Location) - Method in class com.opensymphony.xwork2.util.location.Located
Set the location of this object
setLocation(String) - Method in class org.apache.struts2.dispatcher.StrutsResultSupport
The location to go to after action execution.
setLocation(String) - Method in class org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction
Set the location of the view.
setLocation(String) - Method in class org.apache.struts2.views.xslt.XSLTResult
Deprecated. Use #setStylesheetLocation(String)
setLogCategory(String) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

setLogCategory(String) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor

setLogEnabled(boolean) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

setLogLevel(String) - Method in class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

setLogLevel(String) - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor

setMatchingPattern(String) - Method in class org.apache.struts2.views.xslt.XSLTResult

setMax(String) - Method in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

setMax(String) - Method in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

setMax(String) - Method in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

setMax(Date) - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

setMax(Integer) - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

setMaxExclusive(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

setMaximumSize(Long) - Method in class org.apache.struts2.interceptor.FileUploadInterceptor
Sets the maximum size of an uploaded file
setMaxInclusive(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

setMaxLength(String) - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

setMaxLength(int) - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

setMaxlength(String) - Method in class org.apache.struts2.components.TextField

setMaxLength(String) - Method in class org.apache.struts2.components.TextField

setMaxLength(String) - Method in class org.apache.struts2.views.jsp.ui.TextFieldTag
Deprecated. please use TextFieldTag.setMaxlength(java.lang.String) instead
setMaxlength(String) - Method in class org.apache.struts2.views.jsp.ui.TextFieldTag

setMaxSize(String) - Method in class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

setMessage(String) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Sets the default validator failure message.
setMessage(String) - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

setMessage(String) - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

setMessage(String) - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Sets the default validator failure message.
setMessageKey(String) - Method in interface com.opensymphony.xwork2.validator.Validator

setMessageKey(String) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

setMessageKey(String) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

setMethod(String) - Method in class com.opensymphony.xwork2.ActionChainResult

setMethod(String) - Method in interface com.opensymphony.xwork2.ActionProxy
Sets the method to execute for the action invocation.
setMethod(String) - Method in class com.opensymphony.xwork2.DefaultActionProxy

setMethod(String) - Method in class com.opensymphony.xwork2.mock.MockActionProxy

setMethod(String) - Method in class org.apache.struts2.components.Form

setMethod(String) - Method in class org.apache.struts2.components.FormButton

setMethod(String) - Method in class org.apache.struts2.components.URL

setMethod(String) - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

setMethod(String) - Method in class org.apache.struts2.dispatcher.ServletActionRedirectResult
Sets the method
setMethod(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setMethod(String) - Method in class org.apache.struts2.views.jsp.ui.ResetTag

setMethod(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setMethod(String) - Method in class org.apache.struts2.views.jsp.URLTag

setMethodName(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

setMin(String) - Method in class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

setMin(String) - Method in class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

setMin(String) - Method in class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

setMin(Date) - Method in class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

setMin(Integer) - Method in class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

setMinExclusive(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

setMinInclusive(String) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

setMinLength(String) - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

setMinLength(int) - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

setModel(T) - Method in interface com.opensymphony.xwork2.interceptor.ScopedModelDriven
Sets the model
setModel(TableModel) - Method in class org.apache.struts2.components.table.AbstractFilterModel

setModel(TableModel) - Method in class org.apache.struts2.components.table.SortFilterModel

setModel(TableModel) - Method in class org.apache.struts2.components.table.WebTable

SetModel - Class in org.apache.struts2.views.freemarker.tags

SetModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.SetModel

setModelName(String) - Method in class org.apache.struts2.components.table.WebTable
The name of model to use
setModelName(String) - Method in class org.apache.struts2.views.jsp.ui.table.WebTableTag

setMoveDownLabel(String) - Method in class org.apache.struts2.components.UpDownSelect

setMoveDownLabel(String) - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

setMoveUpLabel(String) - Method in class org.apache.struts2.components.UpDownSelect

setMoveUpLabel(String) - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

setMultipartSaveDir(String) - Static method in class org.apache.struts2.dispatcher.Dispatcher
Modify state of StrutsConstants.STRUTS_MULTIPART_SAVEDIR setting.
setMultiple(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setMultiple(String) - Method in class org.apache.struts2.components.InputTransferSelect

setMultiple(String) - Method in class org.apache.struts2.components.Select

setMultiple(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setMultiple(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setMultiple(String) - Method in class org.apache.struts2.views.jsp.ui.SelectTag

setName(String) - Method in class com.opensymphony.xwork2.ActionContext
Sets the name of the current Action in the ActionContext.
setName(String) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

setName(String) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

setName(String) - Method in class com.opensymphony.xwork2.config.entities.InterceptorMapping

setName(String) - Method in class com.opensymphony.xwork2.config.entities.InterceptorStackConfig

setName(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

setName(String) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

setName(String) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

setName(String) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

setName(String) - Method in class org.apache.struts2.components.ActionComponent

setName(String) - Method in class org.apache.struts2.components.Bean

setName(String) - Method in class org.apache.struts2.components.Date

setName(String) - Method in class org.apache.struts2.components.I18n

setName(String) - Method in class org.apache.struts2.components.Param

setName(String) - Method in class org.apache.struts2.components.Set

setName(String) - Method in class org.apache.struts2.components.Text

setName(String) - Method in class org.apache.struts2.components.UIBean

setName(String) - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

setName(String) - Method in class org.apache.struts2.views.jsp.ActionTag

setName(String) - Method in class org.apache.struts2.views.jsp.BeanTag

setName(String) - Method in class org.apache.struts2.views.jsp.DateTag

setName(String) - Method in class org.apache.struts2.views.jsp.I18nTag

setName(String) - Method in class org.apache.struts2.views.jsp.ParamTag

setName(String) - Method in class org.apache.struts2.views.jsp.SetTag

setName(String) - Method in class org.apache.struts2.views.jsp.TextTag

setName(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setNamedItem(Node) - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

setNamedItemNS(Node) - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

setNamespace(String) - Method in class com.opensymphony.xwork2.ActionChainResult
sets the namespace of the Action that we're chaining to.
setNamespace(String) - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

setNamespace(String) - Method in class com.opensymphony.xwork2.mock.MockActionProxy

setNamespace(String) - Method in class org.apache.struts2.components.ActionComponent

setNamespace(String) - Method in class org.apache.struts2.components.Form

setNamespace(String) - Method in class org.apache.struts2.components.URL

setNamespace(String) - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

setNamespace(String) - Method in class org.apache.struts2.dispatcher.ServletActionRedirectResult
Sets the namespace
setNamespace(String) - Method in class org.apache.struts2.views.jsp.ActionTag

setNamespace(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setNamespace(String) - Method in class org.apache.struts2.views.jsp.URLTag

setNegativeColor(String) - Method in class org.apache.struts2.components.table.renderer.NumericCellRenderer

setNice(boolean) - Method in class org.apache.struts2.components.Date

setNice(boolean) - Method in class org.apache.struts2.views.jsp.DateTag

setNoCache(String) - Method in class org.apache.struts2.views.xslt.XSLTResult

setNodeIdProperty(String) - Method in class org.apache.struts2.components.Tree

setNodeIdProperty(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setNodeTitleProperty(String) - Method in class org.apache.struts2.components.Tree

setNodeTitleProperty(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setNodeValue(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setNotifyTopics(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setNotifyTopics(String) - Method in class org.apache.struts2.components.Autocompleter

setNotifyTopics(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setNotifyTopics(String) - Method in class org.apache.struts2.components.Submit

setNotifyTopics(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setNotifyTopics(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setNotifyTopics(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.DefaultActionProxy

setObjectFactory(ObjectFactory) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

setObjectFactory(ObjectFactory) - Static method in class com.opensymphony.xwork2.ObjectFactory

setObjectFactory(ObjectFactory) - Method in class org.apache.struts2.components.Bean

setObjectFactory(ObjectFactory) - Method in class org.apache.struts2.components.Form

setObjectFactory(ObjectFactory) - Method in class org.apache.struts2.config.MethodConfigurationProvider
Updates ObjectFactory property.
setObjectFactory(ObjectFactory) - Method in class org.apache.struts2.views.velocity.VelocityManager

setObjectTypeDeterminer(ObjectTypeDeterminer) - Method in class com.opensymphony.xwork2.util.XWorkConverter

setOnblur(String) - Method in class org.apache.struts2.components.UIBean

setOnblur(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnchange(String) - Method in class org.apache.struts2.components.UIBean

setOnchange(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnclick(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setOnclick(String) - Method in class org.apache.struts2.components.UIBean

setOnclick(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOndblclick(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setOndblclick(String) - Method in class org.apache.struts2.components.UIBean

setOndblclick(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnfocus(String) - Method in class org.apache.struts2.components.UIBean

setOnfocus(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnkeydown(String) - Method in class org.apache.struts2.components.UIBean

setOnkeydown(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnkeypress(String) - Method in class org.apache.struts2.components.UIBean

setOnkeypress(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnkeyup(String) - Method in class org.apache.struts2.components.UIBean

setOnkeyup(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnLoadJS(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag
Deprecated.
setOnmousedown(String) - Method in class org.apache.struts2.components.UIBean

setOnmousedown(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnmousemove(String) - Method in class org.apache.struts2.components.UIBean

setOnmousemove(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnmouseout(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setOnmouseout(String) - Method in class org.apache.struts2.components.UIBean

setOnmouseout(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnmouseover(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setOnmouseover(String) - Method in class org.apache.struts2.components.UIBean

setOnmouseover(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnmouseup(String) - Method in class org.apache.struts2.components.UIBean

setOnmouseup(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnselect(String) - Method in class org.apache.struts2.components.UIBean

setOnselect(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setOnsubmit(String) - Method in class org.apache.struts2.components.Form

setOnsubmit(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setOpenTemplate(String) - Method in class org.apache.struts2.components.ClosingUIBean

setOpenTemplate(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractClosingTag

setOperationMode(String) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

setOrdered(boolean) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor
Set whether to order the parameters by object depth or not
setPackageName(String) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

setPage(String) - Method in class org.apache.struts2.util.URLBean

setPageLocator(ClasspathConfigurationProvider.PageLocator) - Method in class org.apache.struts2.config.ClasspathConfigurationProvider
Register a PageLocation to use to scan for server pages.
setParam(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setParamColumn(int) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setParameterMap(Map) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

setParameterName(String) - Method in class com.opensymphony.xwork2.interceptor.I18nInterceptor

setParameters(Map) - Method in class com.opensymphony.xwork2.ActionContext
Sets the action parameters.
setParameters(Object, ValueStack, Map) - Method in class com.opensymphony.xwork2.interceptor.ParametersInterceptor

setParameters(Map) - Method in interface org.apache.struts2.interceptor.ParameterAware
Sets the map of input parameters in the implementing class.
setParamNames(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
Allows paramNames attribute to be set as comma-separated-values (csv).
setParams(Map<String, Object>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

setParams(Map) - Method in class com.opensymphony.xwork2.config.entities.InterceptorConfig

setParams(Map<String, Object>) - Method in interface com.opensymphony.xwork2.config.entities.Parameterizable

setParams(Map) - Method in class com.opensymphony.xwork2.config.entities.ResultConfig

setParams(Map) - Method in class com.opensymphony.xwork2.config.entities.ResultTypeConfig

setParams(Map) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

setParams(Map) - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

setParamValue(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setParamValues(String) - Method in class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor
Allows paramValues attribute to be set as a comma-separated-values (csv).
setParent(AdapterNode) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setParent(AdapterNode) - Method in interface org.apache.struts2.views.xslt.AdapterNode
The parent adapter node of this node.
setParse(String) - Method in class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

setParse(boolean) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

setParse(boolean) - Method in class org.apache.struts2.dispatcher.HttpHeaderResult
Sets whether or not the HTTP header values should be evaluated against the ValueStack (by default they are).
setParse(boolean) - Method in class org.apache.struts2.dispatcher.StrutsResultSupport
Set parse to true to indicate that the location should be parsed as an OGNL expression.
setParse(boolean) - Method in class org.apache.struts2.views.xslt.XSLTResult
If true, parse the stylesheet location for OGNL expressions.
setParseFormat(String) - Method in class org.apache.struts2.util.DateFormatter

setParser(DateFormat) - Method in class org.apache.struts2.util.DateFormatter

setParseStringAsXML(boolean) - Method in class org.apache.struts2.views.xslt.StringAdapter
When set to true the StringAdapter will interpret its String value as containing XML text and parse it to a DOM Element.
setPortletMode(String) - Method in class org.apache.struts2.components.Form

setPortletMode(String) - Method in class org.apache.struts2.components.URL

setPortletMode(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setPortletMode(String) - Method in class org.apache.struts2.views.jsp.URLTag

setPortletPreferences(PortletPreferences) - Method in interface org.apache.struts2.portlet.interceptor.PortletPreferencesAware
Sets the HTTP request object in implementing classes.
setPortletSupportActive(boolean) - Static method in class org.apache.struts2.dispatcher.Dispatcher
Modify the portlet support mode.
setPortletUrlType(String) - Method in class org.apache.struts2.components.URL

setPortletUrlType(String) - Method in class org.apache.struts2.views.jsp.URLTag

setPositiveColor(String) - Method in class org.apache.struts2.components.table.renderer.NumericCellRenderer

setPrefix(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setPreInvokeJS(String) - Method in class org.apache.struts2.views.jsp.ui.AnchorTag
Deprecated.
setPreInvokeJS(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag
Deprecated.
setPrependServletContext(boolean) - Method in class org.apache.struts2.dispatcher.ServletRedirectResult
Sets whether or not to prepend the servlet context path to the redirected URL.
setPrincipalProxy(PrincipalProxy) - Method in interface org.apache.struts2.interceptor.PrincipalAware

setProfilingKey(String) - Method in class org.apache.struts2.interceptor.ProfilingActivationInterceptor

setProperties(Map, Object, Map) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Sets the object's properties using the default type converter, defaulting to not throw exceptions for problems setting the properties.
setProperties(Map, Object, Map, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Sets the object's properties using the default type converter.
setProperties(Map, Object) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Sets the properties on the object using the default context, defaulting to not throwing exceptions for problems setting the properties.
setProperties(Map, Object, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Sets the properties on the object using the default context.
setProperty(String, String) - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties

setProperty(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Sets the property name to be inserted into the related conversion.properties file.
Note: Do not add COLLECTION_PREFIX or MAP_PREFIX keys to property names.
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.util.CompoundRootAccessor

setProperty(String, String, Object) - Method in class com.opensymphony.xwork2.util.location.LocatableProperties

setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor

setProperty(String, Object, Object, Map) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Sets the named property to the supplied value on the Object, defaults to not throwing property exceptions.
setProperty(String, Object, Object, Map, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Sets the named property to the supplied value on the Object.
setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor

setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkEnumerationAcccessor

setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor

setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkListPropertyAccessor

setProperty(Map, Object, Object, Object) - Method in class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

setPropertyName(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setPropertyName(String) - Method in interface org.apache.struts2.views.xslt.AdapterNode
The name of the Java object (property) that we are adapting
setPropertyValue(Object) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setPropertyValue(Object) - Method in interface org.apache.struts2.views.xslt.AdapterNode
The Java object (property) that we are adapting
setPropertyValue(Object) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

setProxy(ActionProxy) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

setProxyDelegates(T) - Method in class com.opensymphony.xwork2.inject.ConstructionContext

setReadonly(String) - Method in class org.apache.struts2.components.TextArea

setReadonly(String) - Method in class org.apache.struts2.components.TextField

setReadonly(String) - Method in class org.apache.struts2.views.jsp.ui.TextareaTag

setReadonly(String) - Method in class org.apache.struts2.views.jsp.ui.TextFieldTag

setRefreshOnShow(String) - Method in class org.apache.struts2.components.Div

setRefreshOnShow(String) - Method in class org.apache.struts2.views.jsp.ui.DivTag

setReloadBundles(boolean) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Should resorce bundles be reloaded.
setReloadingConfigs(boolean) - Static method in class com.opensymphony.xwork2.util.FileManager

setRemoveAllLabel(String) - Method in class org.apache.struts2.components.InputTransferSelect

setRemoveAllLabel(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setRemoveLabel(String) - Method in class org.apache.struts2.components.InputTransferSelect

setRemoveLabel(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setRendered(boolean) - Method in class org.apache.struts2.components.table.RenderFilterModel

setRenderer(CellRenderer) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer
used to set the renderer to delgate to.
setRenderer(CellRenderer) - Method in class org.apache.struts2.components.table.WebTableColumn

setRepopulateField(String) - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

setReportingConversionErrors(Map, boolean) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setRequest(Map) - Method in interface org.apache.struts2.interceptor.RequestAware
Sets the Map of request attributes in the implementing class.
setRequest(HttpServletRequest) - Static method in class org.apache.struts2.ServletActionContext
Sets the HTTP servlet request object.
setRequest(HttpServletRequest) - Method in class org.apache.struts2.util.URLBean

setRequestParameterSwitch(String) - Method in class org.apache.struts2.interceptor.MessageStoreInterceptor

setRequired(String) - Method in class org.apache.struts2.components.UIBean

setRequired(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setRequiredposition(String) - Method in class org.apache.struts2.components.UIBean

setRequiredposition(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setReset(boolean) - Method in class org.apache.struts2.interceptor.ScopeInterceptor

setResponse(HttpServletResponse) - Static method in class org.apache.struts2.ServletActionContext
Sets the HTTP servlet response object.
setResponse(HttpServletResponse) - Method in class org.apache.struts2.util.URLBean

setResult(String) - Method in class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

setResult(Result) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

setResult(Result) - Method in class org.apache.struts2.dispatcher.mapper.ActionMapping

setResultCode(String) - Method in interface com.opensymphony.xwork2.ActionInvocation
Sets the result code, possibly overriding the one returned by the action.
setResultCode(String) - Method in class com.opensymphony.xwork2.DefaultActionInvocation

setResultCode(String) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

setResultDivId(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag
Deprecated.
setResults(Map<String, ResultConfig>) - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

setReturnedResult(String) - Method in class com.opensymphony.xwork2.mock.MockActionProxy

setRightDownLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setRightDownLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setRightTitle(String) - Method in class org.apache.struts2.components.InputTransferSelect

setRightTitle(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setRightTitle(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setRightTitle(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setRightUpLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setRightUpLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setRoot(CompoundRoot) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

setRootNode(String) - Method in class org.apache.struts2.components.Tree

setRootNode(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setRows(String) - Method in class org.apache.struts2.components.TextArea

setRows(String) - Method in class org.apache.struts2.views.jsp.ui.TextareaTag

setRule(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Sets the rule prefix for COLLECTION_PREFIX or MAP_PREFIX key.
setScheme(String) - Method in class org.apache.struts2.components.URL

setScheme(String) - Method in class org.apache.struts2.views.jsp.URLTag

setScope(String) - Method in class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

setScope(String) - Method in class org.apache.struts2.components.Set

setScope(String) - Method in class org.apache.struts2.views.jsp.SetTag

setScopeKey(String) - Method in interface com.opensymphony.xwork2.interceptor.ScopedModelDriven
Sets the key under which the model is stored
setScopeStrategy(Scope.Strategy) - Method in interface com.opensymphony.xwork2.inject.Container
Sets the scope strategy for the current thread.
setScopeStrategy(Scope.Strategy) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

setSearchType(String) - Method in class org.apache.struts2.components.Autocompleter

setSearchType(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setSelectAllLabel(String) - Method in class org.apache.struts2.components.OptionTransferSelect

setSelectAllLabel(String) - Method in class org.apache.struts2.components.UpDownSelect

setSelectAllLabel(String) - Method in class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

setSelectAllLabel(String) - Method in class org.apache.struts2.views.jsp.ui.UpDownSelectTag

setSelectedIndex(int) - Method in class org.apache.struts2.util.TabbedPane

setSelectedTab(String) - Method in class org.apache.struts2.components.TabbedPanel

setSelectedTab(String) - Method in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

setSeparator(String) - Method in class org.apache.struts2.util.IteratorGenerator

setSeparator(String) - Method in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

setServeStaticBrowserCache(String) - Static method in class org.apache.struts2.dispatcher.FilterDispatcher
Modify state of StrutsConstants.STRUTS_SERVE_STATIC_BROWSER_CACHE setting.
setServeStaticContent(String) - Static method in class org.apache.struts2.dispatcher.FilterDispatcher
Modify state of StrutsConstants.STRUTS_SERVE_STATIC_CONTENT setting.
setServletContext(ServletContext) - Method in class org.apache.struts2.config.ServletContextSingleton
Sets the servlet context
setServletContext(ServletContext) - Static method in class org.apache.struts2.ServletActionContext
Sets the current servlet context object
setServletContext(ServletContext) - Method in interface org.apache.struts2.util.ServletContextAware

setServletPath(String) - Method in class org.apache.struts2.portlet.util.HttpServletRequestMock

setServletRequest(HttpServletRequest) - Method in interface org.apache.struts2.interceptor.ServletRequestAware
Sets the HTTP request object in implementing classes.
setServletResponse(HttpServletResponse) - Method in interface org.apache.struts2.interceptor.ServletResponseAware
Sets the HTTP response object in implementing classes.
setSession(Map) - Method in class com.opensymphony.xwork2.ActionContext
Sets a map of action session values.
setSession(String) - Method in class org.apache.struts2.interceptor.ScopeInterceptor
Sets a list of session scoped properties
setSession(Map) - Method in interface org.apache.struts2.interceptor.SessionAware
Sets the Map of session attributes in the implementing class.
setSessionReset(String) - Method in class org.apache.struts2.interceptor.ScopeInterceptor

setSetMap(Map, Map, String) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription
Set the shortCircuit flag.
setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

setShortCircuit(boolean) - Method in interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription
Set the shortCircuit flag.
setShortCircuit(boolean) - Method in interface com.opensymphony.xwork2.validator.ShortCircuitableValidator
Sets whether this field validator should short circuit the validator queue it's in if validation fails.
setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

setShortCircuit(boolean) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

setShouldCreateIfNew(boolean) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

setShow(String) - Method in class org.apache.struts2.views.jsp.ui.PasswordTag

setShowDownArrow(String) - Method in class org.apache.struts2.components.Autocompleter

setShowDownArrow(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setShowErrorTransportText(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setShowErrorTransportText(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setShowErrorTransportText(String) - Method in class org.apache.struts2.components.Submit

setShowErrorTransportText(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setShowErrorTransportText(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setShowGrid(String) - Method in class org.apache.struts2.components.Tree

setShowGrid(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setShowLoadingText(String) - Method in class org.apache.struts2.components.AbstractRemoteCallUIBean

setShowLoadingText(String) - Method in interface org.apache.struts2.components.RemoteUICallBean

setShowLoadingText(String) - Method in class org.apache.struts2.components.Submit

setShowLoadingText(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

setShowLoadingText(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setShowPassword(String) - Method in class org.apache.struts2.components.Password

setShowPassword(String) - Method in class org.apache.struts2.views.jsp.ui.PasswordTag

setShowRootGrid(String) - Method in class org.apache.struts2.components.Tree

setShowRootGrid(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setSimpleValidator(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

setSize(String) - Method in class org.apache.struts2.components.DoubleListUIBean

setSize(String) - Method in class org.apache.struts2.components.File

setSize(String) - Method in class org.apache.struts2.components.InputTransferSelect

setSize(String) - Method in class org.apache.struts2.components.Select

setSize(String) - Method in class org.apache.struts2.components.TextField

setSize(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

setSize(String) - Method in class org.apache.struts2.views.jsp.ui.FileTag

setSize(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setSize(String) - Method in class org.apache.struts2.views.jsp.ui.SelectTag

setSize(String) - Method in class org.apache.struts2.views.jsp.ui.TextFieldTag

setSkipActions(String) - Method in class com.opensymphony.xwork2.ActionChainResult
Set the list of actions to skip.
setSlashesInActionNames(String) - Method in class org.apache.struts2.dispatcher.mapper.DefaultActionMapper

setSortable(boolean) - Method in class org.apache.struts2.components.table.WebTable

setSortable(boolean) - Method in class org.apache.struts2.views.jsp.ui.table.WebTableTag

setSortColumn(int) - Method in class org.apache.struts2.components.table.WebTable

setSortColumn(int) - Method in class org.apache.struts2.views.jsp.ui.table.WebTableTag

setSortOrder(String) - Method in class org.apache.struts2.components.table.WebTable

setSortOrder(String) - Method in class org.apache.struts2.views.jsp.ui.table.WebTableTag

setSource(Object) - Method in class org.apache.struts2.util.AppendIteratorFilter

setSource(Object) - Method in class org.apache.struts2.util.MergeIteratorFilter

setSource(Object) - Method in class org.apache.struts2.util.SortIteratorFilter

setSource(Object) - Method in class org.apache.struts2.util.SubsetIteratorFilter

setSource(String) - Method in class org.apache.struts2.views.jsp.iterator.SortIteratorTag

setSource(String) - Method in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

setSrc(String) - Method in class org.apache.struts2.components.Submit

setSrc(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setStack(ValueStack) - Method in class com.opensymphony.xwork2.mock.MockActionInvocation

setStart(int) - Method in class org.apache.struts2.util.SubsetIteratorFilter

setStart(String) - Method in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

setStartDate(String) - Method in class org.apache.struts2.components.DateTimePicker

setStartDate(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setStartTime() - Method in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

setStartTimerListenTopics(String) - Method in class org.apache.struts2.components.Div

setStartTimerListenTopics(String) - Method in class org.apache.struts2.views.jsp.ui.DivTag

setStaticDisplay(String) - Method in class org.apache.struts2.components.DateTimePicker

setStaticDisplay(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setStatus(String) - Method in class org.apache.struts2.components.IteratorComponent

setStatus(int) - Method in class org.apache.struts2.dispatcher.HttpHeaderResult
Sets the http servlet response status code that should be set on a response.
setStatus(String) - Method in class org.apache.struts2.views.jsp.IteratorTag

setStopTimerListenTopics(String) - Method in class org.apache.struts2.components.Div

setStopTimerListenTopics(String) - Method in class org.apache.struts2.views.jsp.ui.DivTag

setStrictErrorChecking(boolean) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

setStylesheetLocation(String) - Method in class org.apache.struts2.views.xslt.XSLTResult

setSuccessResultValue(String) - Method in class org.apache.struts2.dispatcher.DefaultActionSupport

setTabAlign(String) - Method in class org.apache.struts2.util.TabbedPane

setTabindex(String) - Method in class org.apache.struts2.components.UIBean

setTabindex(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

SetTag - Class in org.apache.struts2.views.jsp

SetTag() - Constructor for class org.apache.struts2.views.jsp.SetTag

setTarget(String) - Method in class org.apache.struts2.components.Form

setTarget(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setTarget(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setTargets(String) - Method in class org.apache.struts2.components.Anchor

setTargets(String) - Method in class org.apache.struts2.components.Submit

setTargets(String) - Method in class org.apache.struts2.views.jsp.ui.AnchorTag

setTargets(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setTemplate(String) - Method in class org.apache.struts2.components.UIBean

setTemplate(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setTemplateCssPath(String) - Method in class org.apache.struts2.components.Autocompleter

setTemplateCssPath(String) - Method in class org.apache.struts2.components.DateTimePicker

setTemplateCssPath(String) - Method in class org.apache.struts2.components.TabbedPanel

setTemplateCssPath(String) - Method in class org.apache.struts2.components.Tree

setTemplateCssPath(String) - Method in class org.apache.struts2.views.jsp.ui.AutocompleterTag

setTemplateCssPath(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setTemplateCssPath(String) - Method in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

setTemplateCssPath(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setTemplateDir(String) - Method in class org.apache.struts2.components.UIBean

setTemplateDir(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setTemplateEngineManager(TemplateEngineManager) - Method in class org.apache.struts2.components.UIBean

SETTER_PATTERN - Static variable in class com.opensymphony.xwork2.util.AnnotationUtils

SETTER_PATTERN - Static variable in class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

setTest(String) - Method in class org.apache.struts2.components.ElseIf

setTest(String) - Method in class org.apache.struts2.components.If

setTest(String) - Method in class org.apache.struts2.views.jsp.ElseIfTag

setTest(String) - Method in class org.apache.struts2.views.jsp.IfTag

setText(String) - Method in class org.apache.struts2.components.table.renderer.FixedTextCellRenderer

setTextContent(String) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setTextProvider(TextProvider) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

setTheme(String) - Method in class org.apache.struts2.components.Submit

setTheme(String) - Method in class org.apache.struts2.components.UIBean

setTheme(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setThreadPriority(int) - Method in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor
Sets the thread priority of the background process.
setThrowExceptionOnNullValueAttribute(boolean) - Method in class org.apache.struts2.components.ListUIBean

setTime(long) - Method in class org.apache.struts2.util.DateFormatter

settings - Variable in class org.apache.struts2.config.PropertiesSettings

Settings - Class in org.apache.struts2.config
Settings retrieves and exposes default values used by the framework.
Settings() - Constructor for class org.apache.struts2.config.Settings

settingsImpl - Static variable in class org.apache.struts2.config.Settings
A pluggable implementation of Settings, provided through the Settings.setInstance(org.apache.struts2.config.Settings) method.
setTitle(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setTitle(String) - Method in class org.apache.struts2.components.UIBean

setTitle(String) - Method in class org.apache.struts2.portlet.result.PortletResult
Sets the title.
setTitle(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setToggle(String) - Method in class org.apache.struts2.components.Tree

setToggle(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setToggleDuration(String) - Method in class org.apache.struts2.components.DateTimePicker

setToggleDuration(String) - Method in class org.apache.struts2.components.Tree

setToggleDuration(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setToggleDuration(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setToggleType(String) - Method in class org.apache.struts2.components.DateTimePicker

setToggleType(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setToken() - Static method in class org.apache.struts2.util.TokenHelper
Sets a transaction token into the session using the default token name.
setToken(String) - Static method in class org.apache.struts2.util.TokenHelper
Sets a transaction token into the session using the provided token name.
setToolBoxLocation(String) - Method in class org.apache.struts2.views.velocity.VelocityManager

setTooltip(String) - Method in class org.apache.struts2.components.UIBean

setTooltip(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setTooltipConfig(String) - Method in class org.apache.struts2.components.UIBean

setTooltipConfig(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setTrailParams(String) - Method in class org.apache.struts2.components.table.renderer.LinkCellRenderer

setTreeCollapsedTopic(String) - Method in class org.apache.struts2.components.Tree

setTreeCollapsedTopic(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setTreeExpandedTopic(String) - Method in class org.apache.struts2.components.Tree

setTreeExpandedTopic(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setTreeSelectedTopic(String) - Method in class org.apache.struts2.components.Tree

setTreeSelectedTopic(String) - Method in class org.apache.struts2.views.jsp.ui.TreeTag

setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription

setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator
Sets whether the expression should be trimed before matching.
setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.validators.RequiredStringValidator

setTrim(boolean) - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

setTrueValue(String) - Method in class org.apache.struts2.components.table.renderer.BooleanCellRenderer

setType(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

setType(String) - Method in class com.opensymphony.xwork2.validator.ValidatorConfig

setType(String) - Method in class org.apache.struts2.components.DateTimePicker

setType(String) - Method in class org.apache.struts2.components.FormButton

setType(String) - Method in class org.apache.struts2.interceptor.ScopeInterceptor
Sets the type of scope operation
setType(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setType(String) - Method in class org.apache.struts2.views.jsp.ui.ResetTag

setType(String) - Method in class org.apache.struts2.views.jsp.ui.SubmitTag

setTypeConverter(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription
Sets the class name of the type converter to be used.
setUncheckedValue(String) - Method in class org.apache.struts2.interceptor.CheckboxInterceptor
Overrides the default value for an unchecked checkbox
setUnknownHandler(UnknownHandler) - Method in class com.opensymphony.xwork2.DefaultActionProxy

setUp() - Method in class com.opensymphony.xwork2.TestNGXWorkTestCase

setup() - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder
Setup this instance transformer and result objects.
setUp() - Static method in class com.opensymphony.xwork2.util.XWorkTestCaseHelper

setUp() - Method in class com.opensymphony.xwork2.XWorkTestCase

setUp() - Method in class org.apache.struts2.StrutsTestCase
Sets up the configuration settings, XWork configuration, and message resources
setUp() - Method in class org.apache.struts2.TestNGStrutsTestCase

setUp() - Static method in class org.apache.struts2.util.StrutsTestCaseHelper
Sets up the configuration settings, XWork configuration, and message resources
setupContext(Map, ObjectProxy) - Method in class com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor
Sets up the context with the last property and last class accessed.
setUpdateFreq(String) - Method in class org.apache.struts2.components.Div

setUpdateFreq(String) - Method in class org.apache.struts2.views.jsp.ui.DivTag

setUpLabel(String) - Method in class org.apache.struts2.components.InputTransferSelect

setUpLabel(String) - Method in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

setUrlIncludeParams(String) - Method in class org.apache.struts2.components.URL

setUseClassCache(boolean) - Method in class com.opensymphony.xwork2.spring.SpringObjectFactory
Enable / disable caching of classes loaded by Spring.
setUserData(String, Object, UserDataHandler) - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

setVal(String) - Method in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

setValidate(String) - Method in class org.apache.struts2.components.Form

setValidate(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setValidateAnnotatedMethodOnly(String) - Method in class com.opensymphony.xwork2.validator.ValidationInterceptor
Determine if validate() should always be called or only per annotated method.
setValidationAware(ValidationAware) - Method in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

setValidatorContext(ValidatorContext) - Method in interface com.opensymphony.xwork2.validator.Validator
This method will be called before validate with a non-null ValidatorContext.
setValidatorContext(ValidatorContext) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

setValidatorType(String) - Method in interface com.opensymphony.xwork2.validator.Validator

setValidatorType(String) - Method in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

setValidatorType(String) - Method in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

setValue(String) - Method in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

setValue(V) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

setValue(Object) - Method in class com.opensymphony.xwork2.util.ObjectProxy

setValue(String, Map, Object, Object) - Static method in class com.opensymphony.xwork2.util.OgnlUtil
Wrapper around Ognl.setValue() to handle type conversion for collection elements.
setValue(String, Object) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

setValue(String, Object, boolean) - Method in class com.opensymphony.xwork2.util.OgnlValueStack

setValue(String, Object) - Method in interface com.opensymphony.xwork2.util.ValueStack
Attempts to set a property on a bean in the stack with the given expression using the default search order.
setValue(String, Object, boolean) - Method in interface com.opensymphony.xwork2.util.ValueStack
Attempts to set a property on a bean in the stack with the given expression using the default search order.
setValue(Object) - Method in class org.apache.struts2.components.Debug.DebugMapEntry

setValue(String) - Method in class org.apache.struts2.components.Include

setValue(String) - Method in class org.apache.struts2.components.IteratorComponent

setValue(String) - Method in class org.apache.struts2.components.Param

setValue(String) - Method in class org.apache.struts2.components.Property

setValue(String) - Method in class org.apache.struts2.components.Push

setValue(String) - Method in class org.apache.struts2.components.Set

setValue(String) - Method in class org.apache.struts2.components.UIBean

setValue(String) - Method in class org.apache.struts2.components.URL

setValue(String) - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

setValue(String, String) - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

setValue(String) - Method in class org.apache.struts2.views.jsp.IncludeTag

setValue(String) - Method in class org.apache.struts2.views.jsp.IteratorTag

setValue(String) - Method in class org.apache.struts2.views.jsp.ParamTag

setValue(String) - Method in class org.apache.struts2.views.jsp.PropertyTag

setValue(String) - Method in class org.apache.struts2.views.jsp.PushTag

setValue(String) - Method in class org.apache.struts2.views.jsp.SetTag

setValue(String) - Method in class org.apache.struts2.views.jsp.ui.AbstractUITag

setValue(String) - Method in class org.apache.struts2.views.jsp.URLTag

setValue(String) - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

setValueAt(Object, int, int) - Method in class org.apache.struts2.components.table.AbstractFilterModel

setValueAt(Object, int, int) - Method in class org.apache.struts2.components.table.SortFilterModel

setValues(String, String[]) - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

setValues(Object) - Method in class org.apache.struts2.util.IteratorGenerator

setValueStack(ValueStack) - Method in class com.opensymphony.xwork2.ActionContext
Sets the OGNL value stack.
setVelocityManager(VelocityManager) - Method in class org.apache.struts2.components.template.VelocityTemplateEngine

setVelocityManager(VelocityManager) - Method in class org.apache.struts2.dispatcher.VelocityResult

setVelocityManager(VelocityManager) - Method in class org.apache.struts2.portlet.result.PortletVelocityResult

setVelocityProperties(Properties) - Method in class org.apache.struts2.views.velocity.VelocityManager

setWeekStartsOn(String) - Method in class org.apache.struts2.components.DateTimePicker

setWeekStartsOn(String) - Method in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

setWindowState(String) - Method in class org.apache.struts2.components.Form

setWindowState(String) - Method in class org.apache.struts2.components.URL

setWindowState(String) - Method in class org.apache.struts2.views.jsp.ui.FormTag

setWindowState(String) - Method in class org.apache.struts2.views.jsp.URLTag

setWrap(String) - Method in class org.apache.struts2.components.TextArea

setWrap(boolean) - Method in class org.apache.struts2.util.Counter

setWrap(String) - Method in class org.apache.struts2.views.jsp.ui.TextareaTag

setWrapperAltMap(String) - Method in class org.apache.struts2.views.freemarker.FreemarkerManager

setWriter(Writer) - Method in class org.apache.struts2.views.freemarker.FreemarkerResult

setXmlStandalone(boolean) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

setXmlVersion(String) - Method in class org.apache.struts2.views.xslt.SimpleAdapterDocument

shortCircuit - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

shortCircuit - Variable in class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

shortCircuit - Variable in class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

shortCircuit - Variable in class com.opensymphony.xwork2.validator.ValidatorConfig

shortCircuit - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

ShortCircuitableValidator - Interface in com.opensymphony.xwork2.validator
This interface should be implemented by validators that can short-circuit the validator queue that it is in.
shouldAddError(String, Object) - Method in class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

shouldAddError(String, Object) - Method in class org.apache.struts2.interceptor.StrutsConversionErrorInterceptor
Returns false if the value is null, "", or {""} (array of size 1 with a blank element).
shouldCreateIfNew - Variable in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

shouldCreateIfNew(Class, String, Object, String, boolean) - Method in class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

shouldCreateIfNew(Class, String, Object, String, boolean) - Method in class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer
Determines the boolean CreateIfNull property for a Collection or Map by getting it from the conversion properties file using the CreateIfNull_ prefix.
shouldCreateIfNew(Class, String, Object, String, boolean) - Method in class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer
Determines the createIfNull property for a Collection or Map by getting it from the @CreateIfNull annotation.
shouldCreateIfNew(Class, String, Object, String, boolean) - Method in interface com.opensymphony.xwork2.util.ObjectTypeDeterminer

shouldLog() - Method in class com.opensymphony.xwork2.interceptor.TimerInterceptor
Determines if we should log the time.
showDownArrow - Variable in class org.apache.struts2.components.Autocompleter

showDownArrow - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

showErrorTransportText - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

showErrorTransportText - Variable in class org.apache.struts2.components.Submit

showErrorTransportText - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

showErrorTransportText - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

showGrid - Variable in class org.apache.struts2.components.Tree

showGrid - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

showLoadingText - Variable in class org.apache.struts2.components.AbstractRemoteCallUIBean

showLoadingText - Variable in class org.apache.struts2.components.Submit

showLoadingText - Variable in class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

showLoadingText - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

showPassword - Variable in class org.apache.struts2.components.Password

showPassword - Variable in class org.apache.struts2.views.jsp.ui.PasswordTag

showRootGrid - Variable in class org.apache.struts2.components.Tree

showRootGrid - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

SimpleAdapterDocument - Class in org.apache.struts2.views.xslt
SimpleAdapterDocument adapted a Java object and presents it as a Document.
SimpleAdapterDocument(AdapterFactory, AdapterNode, String, Object) - Constructor for class org.apache.struts2.views.xslt.SimpleAdapterDocument

SimpleNodeList - Class in org.apache.struts2.views.xslt

SimpleNodeList(List<Node>) - Constructor for class org.apache.struts2.views.xslt.SimpleNodeList

SimpleTextNode - Class in org.apache.struts2.views.xslt

SimpleTextNode(AdapterFactory, AdapterNode, String, Object) - Constructor for class org.apache.struts2.views.xslt.SimpleTextNode

simpleValidator - Variable in class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

singleton - Static variable in class org.apache.struts2.config.ServletContextSingleton
The sole instance of this class.
singletonFactories - Variable in class com.opensymphony.xwork2.inject.ContainerBuilder

size() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

size() - Method in class com.opensymphony.xwork2.util.OgnlValueStack

size() - Method in interface com.opensymphony.xwork2.util.ValueStack
Get the number of objects in the stack s
size - Variable in class org.apache.struts2.components.DoubleListUIBean

size - Variable in class org.apache.struts2.components.File

size - Variable in class org.apache.struts2.components.InputTransferSelect

size - Variable in class org.apache.struts2.components.Select

size - Variable in class org.apache.struts2.components.TextField

size() - Method in class org.apache.struts2.util.AttributeMap

size - Variable in class org.apache.struts2.util.FastByteArrayOutputStream

SIZE - Static variable in class org.apache.struts2.util.PrefixTrie

size - Variable in class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

size - Variable in class org.apache.struts2.views.jsp.ui.FileTag

size - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

size - Variable in class org.apache.struts2.views.jsp.ui.SelectTag

size - Variable in class org.apache.struts2.views.jsp.ui.TextFieldTag

SKIP_ACTIONS_PARAM - Static variable in class com.opensymphony.xwork2.ActionChainResult
The result parameter name to set the name of the action to chain to.
skipActions - Variable in class com.opensymphony.xwork2.ActionChainResult
The list of actions to skip.
skipBeanNames - Variable in class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory

skippedEntity(String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

skippedEntity(String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

skippedEntity(String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

SkipValidation - Annotation Type in org.apache.struts2.interceptor.validation
Marks an Action method to not be validated
SLASH_R - Static variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

sort(int, String) - Method in interface org.apache.struts2.components.table.SortableTableModel

sort(int, String) - Method in class org.apache.struts2.components.table.SortFilterModel

sort(int) - Method in class org.apache.struts2.components.table.SortFilterModel

sortable - Variable in class org.apache.struts2.views.jsp.ui.table.WebTableTag

sortableAttr - Variable in class org.apache.struts2.components.table.WebTable

SortableTableModel - Interface in org.apache.struts2.components.table

sortColumn - Variable in class org.apache.struts2.components.table.SortFilterModel

sortColumn - Variable in class org.apache.struts2.components.table.WebTable

sortColumn - Variable in class org.apache.struts2.views.jsp.ui.table.WebTableTag

Sorter - Class in org.apache.struts2.util
Sorters.
Sorter() - Constructor for class org.apache.struts2.util.Sorter

SortFilterModel - Class in org.apache.struts2.components.table

SortFilterModel(TableModel) - Constructor for class org.apache.struts2.components.table.SortFilterModel

SortFilterModel.Row - Class in org.apache.struts2.components.table

SortFilterModel.Row(int) - Constructor for class org.apache.struts2.components.table.SortFilterModel.Row

SortIteratorFilter - Class in org.apache.struts2.util
A bean that takes a source and comparator then attempt to sort the source utilizing the comparator.
SortIteratorFilter() - Constructor for class org.apache.struts2.util.SortIteratorFilter

sortIteratorFilter - Variable in class org.apache.struts2.views.jsp.iterator.SortIteratorTag

SortIteratorTag - Class in org.apache.struts2.views.jsp.iterator
NOTE: JSP-TAG
SortIteratorTag() - Constructor for class org.apache.struts2.views.jsp.iterator.SortIteratorTag

sortOrder - Variable in class org.apache.struts2.components.table.WebTable

sortOrder - Variable in class org.apache.struts2.views.jsp.ui.table.WebTableTag

source - Variable in class org.apache.struts2.util.SortIteratorFilter

source - Variable in class org.apache.struts2.util.SubsetIteratorFilter

sourceAttr - Variable in class org.apache.struts2.views.jsp.iterator.SortIteratorTag

sourceAttr - Variable in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

sources - Variable in class org.apache.struts2.util.AppendIteratorFilter

sources - Variable in class org.apache.struts2.util.MergeIteratorFilter

sout - Variable in class org.apache.struts2.util.StrutsUtil.ResponseWrapper

splitText(int) - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

splitText(int) - Method in class org.apache.struts2.views.xslt.SimpleTextNode

SpringObjectFactory - Class in com.opensymphony.xwork2.spring
Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.
SpringObjectFactory() - Constructor for class com.opensymphony.xwork2.spring.SpringObjectFactory

SpringProxyableObjectFactory - Class in com.opensymphony.xwork2.spring
SpringProxyableObjectFactory.
SpringProxyableObjectFactory() - Constructor for class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory

src - Variable in class org.apache.struts2.components.Submit

src - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

SRC_ATTR - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Attribute name for the location URI
stack - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

stack - Variable in class com.opensymphony.xwork2.mock.MockActionInvocation

stack - Variable in class org.apache.struts2.components.Component

stack - Variable in class org.apache.struts2.components.template.TemplateRenderingContext

stack - Variable in class org.apache.struts2.util.StrutsUtil

stack - Variable in class org.apache.struts2.views.freemarker.ScopesHashModel

stack - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

stack - Variable in class org.apache.struts2.views.freemarker.tags.TagModel

STACK - Static variable in class org.apache.struts2.views.util.ContextUtil

stack - Variable in class org.apache.struts2.views.velocity.StrutsVelocityContext

start() - Method in class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

start(Writer) - Method in class org.apache.struts2.components.AppendIterator

start(Writer) - Method in class org.apache.struts2.components.Bean

start(Writer) - Method in class org.apache.struts2.components.ClosingUIBean

start(Writer) - Method in class org.apache.struts2.components.Component
Callback for the start tag of this component.
start(Writer) - Method in class org.apache.struts2.components.Debug

start(Writer) - Method in class org.apache.struts2.components.Else

start(Writer) - Method in class org.apache.struts2.components.ElseIf

start(Writer) - Method in class org.apache.struts2.components.I18n

start(Writer) - Method in class org.apache.struts2.components.If

start(Writer) - Method in class org.apache.struts2.components.IteratorComponent

start(Writer) - Method in class org.apache.struts2.components.MergeIterator

start(Writer) - Method in class org.apache.struts2.components.Property

start(Writer) - Method in class org.apache.struts2.components.Push

start(Writer) - Method in class org.apache.struts2.components.Tree

start(Writer) - Method in class org.apache.struts2.components.URL

start - Variable in class org.apache.struts2.util.SubsetIteratorFilter

start - Variable in class org.apache.struts2.util.Timer

START_MESSAGE - Static variable in class com.opensymphony.xwork2.interceptor.LoggingInterceptor

startAttr - Variable in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

startConstruction() - Method in class com.opensymphony.xwork2.inject.ConstructionContext

startDate - Variable in class org.apache.struts2.components.DateTimePicker

startDate - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

startDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

startDocument() - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

startDocument() - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

startElement(String, String, String, Attributes) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

startElement(String, String, String, Attributes) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

startElement(String, String, String, Attributes) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

startNode(String) - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

startPrefixMapping(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.DOMBuilder

startPrefixMapping(String, String) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

startPrefixMapping(String, String) - Method in class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

startTime - Variable in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

startTimerListenTopics - Variable in class org.apache.struts2.components.Div

startTimerListenTopics - Variable in class org.apache.struts2.views.jsp.ui.DivTag

state - Variable in class org.apache.struts2.views.jsp.IteratorStatus

staticDisplay - Variable in class org.apache.struts2.components.DateTimePicker

staticDisplay - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

staticInjections - Variable in class com.opensymphony.xwork2.inject.ContainerBuilder

StaticParametersInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor populates the action with the static parameters defined in the action configuration.
StaticParametersInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

status - Variable in class org.apache.struts2.components.IteratorComponent

status - Variable in class org.apache.struts2.dispatcher.HttpHeaderResult

statusAttr - Variable in class org.apache.struts2.components.IteratorComponent

statusAttr - Variable in class org.apache.struts2.views.jsp.IteratorTag

statusState - Variable in class org.apache.struts2.components.IteratorComponent

stopTimerListenTopics - Variable in class org.apache.struts2.components.Div

stopTimerListenTopics - Variable in class org.apache.struts2.views.jsp.ui.DivTag

store() - Method in class org.apache.struts2.portlet.interceptor.ServletPortletPreferences

STORE_MODE - Static variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

storeInvocation(String, String, ActionInvocation) - Static method in class org.apache.struts2.util.InvocationSessionStore
Stores the DefaultActionInvocation and ActionContext into the Session using the provided key for loading later using InvocationSessionStore.loadInvocation(java.lang.String, java.lang.String)
StreamResult - Class in org.apache.struts2.dispatcher
A custom Result type for send raw data (via an InputStream) directly to the HttpServletResponse.
StreamResult() - Constructor for class org.apache.struts2.dispatcher.StreamResult

StreamResult(InputStream) - Constructor for class org.apache.struts2.dispatcher.StreamResult

StringAdapter - Class in org.apache.struts2.views.xslt
StringAdapter adapts a Java String value to a DOM Element with the specified property name containing the String's text.
StringAdapter() - Constructor for class org.apache.struts2.views.xslt.StringAdapter

StringAdapter(AdapterFactory, AdapterNode, String, String) - Constructor for class org.apache.struts2.views.xslt.StringAdapter

StringLengthFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a String field is of the right length.
StringLengthFieldValidator - Class in com.opensymphony.xwork2.validator.validators
StringLengthFieldValidator checks that a String field is of a certain length.
StringLengthFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

StringLengthFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
StringLengthFieldValidatorDescription
StringLengthFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

StringLengthFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.
StringRegexValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
StringRegexValidator checks that a given String field, if not empty, matches the configured regular expression.
Strings - Class in com.opensymphony.xwork2.inject.util
String utilities.
Strings() - Constructor for class com.opensymphony.xwork2.inject.util.Strings

stringSet(String) - Static method in class com.opensymphony.xwork2.util.TextUtils
Check whether string has been set to something other than "" or null.
stringToList(String) - Method in class org.apache.struts2.interceptor.RolesInterceptor
Splits a string into a List
strout - Variable in class org.apache.struts2.util.StrutsUtil.ResponseWrapper

STRUTS - Static variable in class org.apache.struts2.views.util.ContextUtil

STRUTS - Static variable in class org.apache.struts2.views.velocity.VelocityManager

STRUTS_ACTION_EXTENSION - Static variable in class org.apache.struts2.StrutsConstants
The URL extension to use to determine if the request is meant for a Struts action
STRUTS_ACTIONPROXYFACTORY - Static variable in class org.apache.struts2.StrutsConstants

STRUTS_ALWAYS_SELECT_FULL_NAMESPACE - Static variable in class org.apache.struts2.StrutsConstants

STRUTS_CONFIGURATION - Static variable in class org.apache.struts2.StrutsConstants
The org.apache.struts2.config.Configuration implementation class
STRUTS_CONFIGURATION_XML_RELOAD - Static variable in class org.apache.struts2.StrutsConstants
Whether to reload the XML configuration or not
STRUTS_CONTINUATIONS_PACKAGE - Static variable in class org.apache.struts2.StrutsConstants
The package containing actions that use Rife continuations
STRUTS_CUSTOM_I18N_RESOURCES - Static variable in class org.apache.struts2.StrutsConstants
Location of additional localization properties files to load
STRUTS_CUSTOM_PROPERTIES - Static variable in class org.apache.struts2.StrutsConstants
Location of additional configuration properties files to load
STRUTS_DEVMODE - Static variable in class org.apache.struts2.StrutsConstants
Whether Struts is in development mode or not
STRUTS_DISPATCHER_PARAMETERSWORKAROUND - Static variable in class org.apache.struts2.StrutsConstants
Whether to use a Servlet request parameter workaround necessary for some versions of WebLogic
STRUTS_ENABLE_DYNAMIC_METHOD_INVOCATION - Static variable in class org.apache.struts2.StrutsConstants
Allows one to disable dynamic method invocation from the URL
STRUTS_ENABLE_SLASHES_IN_ACTION_NAMES - Static variable in class org.apache.struts2.StrutsConstants
Whether slashes in action names are allowed or not
STRUTS_FREEMARKER_MANAGER_CLASSNAME - Static variable in class org.apache.struts2.StrutsConstants
The org.apache.struts2.views.freemarker.FreemarkerManager implementation class
STRUTS_FREEMARKER_WRAPPER_ALT_MAP - Static variable in class org.apache.struts2.StrutsConstants

STRUTS_I18N_ENCODING - Static variable in class org.apache.struts2.StrutsConstants
The encoding to use for localization messages
STRUTS_I18N_RELOAD - Static variable in class org.apache.struts2.StrutsConstants
Whether the localization messages should automatically be reloaded
STRUTS_LOCALE - Static variable in class org.apache.struts2.StrutsConstants
The default locale for the Struts application
STRUTS_MAPPER_CLASS - Static variable in class org.apache.struts2.StrutsConstants
The org.apache.struts2.dispatcher.mapper.ActionMapper implementation class
STRUTS_MAPPER_COMPOSITE - Static variable in class org.apache.struts2.StrutsConstants
Prefix used by CompositeActionMapper to identify its containing ActionMapper class.
STRUTS_MULTIPART_MAXSIZE - Static variable in class org.apache.struts2.StrutsConstants
The maximize size of a multipart request (file upload)
STRUTS_MULTIPART_PARSER - Static variable in class org.apache.struts2.StrutsConstants
The org.apache.struts2.dispatcher.multipart.MultiPartRequest parser implementation for a multipart request (file upload)
STRUTS_MULTIPART_SAVEDIR - Static variable in class org.apache.struts2.StrutsConstants
The directory to use for storing uploaded files
STRUTS_OBJECTFACTORY - Static variable in class org.apache.struts2.StrutsConstants
The com.opensymphony.xwork2.ObjectFactory implementation class
STRUTS_OBJECTFACTORY_SPRING_AUTOWIRE - Static variable in class org.apache.struts2.StrutsConstants
Whether Spring should autoWire or not
STRUTS_OBJECTFACTORY_SPRING_USE_CLASS_CACHE - Static variable in class org.apache.struts2.StrutsConstants
Whether Spring should use its class cache or not
STRUTS_OBJECTTYPEDETERMINER - Static variable in class org.apache.struts2.StrutsConstants
The com.opensymphony.xwork2.util.ObjectTypeDeterminer implementation class
STRUTS_PORTLET_CONTEXT - Static variable in interface org.apache.struts2.StrutsStatics
Constant for the PortletContext object
STRUTS_SERVE_STATIC_BROWSER_CACHE - Static variable in class org.apache.struts2.StrutsConstants
If static content served by the Struts filter should set browser caching header properties or not
STRUTS_SERVE_STATIC_CONTENT - Static variable in class org.apache.struts2.StrutsConstants
Whether the Struts filter should serve static content or not
STRUTS_TAG_ALTSYNTAX - Static variable in class org.apache.struts2.StrutsConstants
Whether to use the alterative syntax for the tags or not
STRUTS_UI_TEMPLATEDIR - Static variable in class org.apache.struts2.StrutsConstants
The directory containing UI templates
STRUTS_UI_THEME - Static variable in class org.apache.struts2.StrutsConstants
The default UI template theme
STRUTS_URL_HTTP_PORT - Static variable in class org.apache.struts2.StrutsConstants
The HTTP port used by Struts URLs
STRUTS_URL_HTTPS_PORT - Static variable in class org.apache.struts2.StrutsConstants
The HTTPS port used by Struts URLs
STRUTS_URL_INCLUDEPARAMS - Static variable in class org.apache.struts2.StrutsConstants
The default includeParams method to generate Struts URLs
STRUTS_VALUESTACK_KEY - Static variable in class org.apache.struts2.ServletActionContext

STRUTS_VELOCITY_CONFIGFILE - Static variable in class org.apache.struts2.StrutsConstants
The Velocity configuration file path
STRUTS_VELOCITY_CONTEXTS - Static variable in class org.apache.struts2.StrutsConstants
List of Velocity context names
STRUTS_VELOCITY_MANAGER_CLASSNAME - Static variable in class org.apache.struts2.StrutsConstants
org.apache.struts2.views.velocity.VelocityManager implementation class
STRUTS_VELOCITY_TOOLBOXLOCATION - Static variable in class org.apache.struts2.StrutsConstants
The location of the Velocity toolbox
STRUTS_XSLT_NOCACHE - Static variable in class org.apache.struts2.StrutsConstants
Whether or not XSLT templates should not be cached
STRUTS_XWORKCONVERTER - Static variable in class org.apache.struts2.StrutsConstants
The name of the xwork converter implementation
StrutsActionProxy - Class in org.apache.struts2.impl

StrutsActionProxy(String, String, Map, boolean, boolean) - Constructor for class org.apache.struts2.impl.StrutsActionProxy

StrutsActionProxyFactory - Class in org.apache.struts2.impl

StrutsActionProxyFactory() - Constructor for class org.apache.struts2.impl.StrutsActionProxyFactory

StrutsBeanWrapper - Class in org.apache.struts2.views.freemarker
The StrutsBeanWrapper extends the default FreeMarker BeansWrapper and provides almost no change in functionality, except for how it handles maps.
StrutsBeanWrapper(boolean) - Constructor for class org.apache.struts2.views.freemarker.StrutsBeanWrapper

StrutsBeanWrapper.FriendlyMapModel - Class in org.apache.struts2.views.freemarker
Attempting to get the best of both worlds of FM's MapModel and SimpleMapModel, by reimplementing the isEmpty(), keySet() and values() methods.
StrutsBeanWrapper.FriendlyMapModel(Map, BeansWrapper) - Constructor for class org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel

StrutsBodyTagSupport - Class in org.apache.struts2.views.jsp
Contains common functonalities for Struts JSP Tags.
StrutsBodyTagSupport() - Constructor for class org.apache.struts2.views.jsp.StrutsBodyTagSupport

StrutsClassTemplateLoader - Class in org.apache.struts2.views.freemarker

StrutsClassTemplateLoader() - Constructor for class org.apache.struts2.views.freemarker.StrutsClassTemplateLoader

StrutsConstants - Class in org.apache.struts2
This class provides a central location for framework configuration keys used to retrieve and store Struts configuration settings.
StrutsConstants() - Constructor for class org.apache.struts2.StrutsConstants

StrutsConversionErrorInterceptor - Class in org.apache.struts2.interceptor
This interceptor extends ConversionErrorInterceptor but only adds conversion errors from the ActionContext to the field errors of the action if the field value is not null, "", or {""} (a size 1 String array with only an empty String).
StrutsConversionErrorInterceptor() - Constructor for class org.apache.struts2.interceptor.StrutsConversionErrorInterceptor

StrutsException - Exception in org.apache.struts2
A generic runtime exception that optionally contains Location information
StrutsException() - Constructor for exception org.apache.struts2.StrutsException
Constructs a StrutsException with no detail message.
StrutsException(String) - Constructor for exception org.apache.struts2.StrutsException
Constructs a StrutsException with the specified detail message.
StrutsException(String, Object) - Constructor for exception org.apache.struts2.StrutsException
Constructs a StrutsException with the specified detail message and target.
StrutsException(Throwable) - Constructor for exception org.apache.struts2.StrutsException
Constructs a StrutsException with the root cause
StrutsException(Throwable, Object) - Constructor for exception org.apache.struts2.StrutsException
Constructs a StrutsException with the root cause and target
StrutsException(String, Throwable) - Constructor for exception org.apache.struts2.StrutsException
Constructs a StrutsException with the specified detail message and exception cause.
StrutsException(String, Throwable, Object) - Constructor for exception org.apache.struts2.StrutsException
Constructs a StrutsException with the specified detail message, cause, and target
StrutsModels - Class in org.apache.struts2.views.freemarker.tags
Provides @s.tag access for various tags.
StrutsModels(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.StrutsModels

StrutsObjectFactory - Class in org.apache.struts2.impl

StrutsObjectFactory() - Constructor for class org.apache.struts2.impl.StrutsObjectFactory

StrutsRequestWrapper - Class in org.apache.struts2.dispatcher
All Struts requests are wrapped with this class, which provides simple JSTL accessibility.
StrutsRequestWrapper(HttpServletRequest) - Constructor for class org.apache.struts2.dispatcher.StrutsRequestWrapper
The constructor
StrutsResourceLoader - Class in org.apache.struts2.views.velocity
Loads resource from the Thread's context ClassLoader.
StrutsResourceLoader() - Constructor for class org.apache.struts2.views.velocity.StrutsResourceLoader

StrutsResultSupport - Class in org.apache.struts2.dispatcher
A base class for all Struts action execution results.
StrutsResultSupport() - Constructor for class org.apache.struts2.dispatcher.StrutsResultSupport

StrutsResultSupport(String) - Constructor for class org.apache.struts2.dispatcher.StrutsResultSupport

StrutsResultSupport(String, boolean, boolean) - Constructor for class org.apache.struts2.dispatcher.StrutsResultSupport

StrutsStatics - Interface in org.apache.struts2
Constants used by Struts.
StrutsTag - Annotation Type in org.apache.struts2.views.annotations
An annotation to document a Struts jsp/freemarker/velocity tag
StrutsTagAttribute - Annotation Type in org.apache.struts2.views.annotations
Documents an attribute to a Struts tag
StrutsTestCase - Class in org.apache.struts2
Base test case for JUnit testing Struts.
StrutsTestCase() - Constructor for class org.apache.struts2.StrutsTestCase

StrutsTestCaseHelper - Class in org.apache.struts2.util
Generic test setup methods to be used with any unit testing framework.
StrutsTestCaseHelper() - Constructor for class org.apache.struts2.util.StrutsTestCaseHelper

StrutsTypeConverter - Class in org.apache.struts2.util
Base class for type converters used in Struts.
StrutsTypeConverter() - Constructor for class org.apache.struts2.util.StrutsTypeConverter

StrutsUtil - Class in org.apache.struts2.util
Struts base utility class, for use in Velocity and Freemarker templates
StrutsUtil(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.util.StrutsUtil

StrutsUtil.ResponseWrapper - Class in org.apache.struts2.util

StrutsUtil.ResponseWrapper(HttpServletResponse) - Constructor for class org.apache.struts2.util.StrutsUtil.ResponseWrapper

StrutsUtil.ServletOutputStreamWrapper - Class in org.apache.struts2.util

StrutsUtil.ServletOutputStreamWrapper(StringWriter) - Constructor for class org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper

StrutsVelocityContext - Class in org.apache.struts2.views.velocity

StrutsVelocityContext(ValueStack) - Constructor for class org.apache.struts2.views.velocity.StrutsVelocityContext

StrutsVelocityContext(VelocityContext[], ValueStack) - Constructor for class org.apache.struts2.views.velocity.StrutsVelocityContext

StrutsXmlConfigurationProvider - Class in org.apache.struts2.config
Override Xwork class so we can use an arbitrary config file
StrutsXmlConfigurationProvider(boolean) - Constructor for class org.apache.struts2.config.StrutsXmlConfigurationProvider
Constructs the configuration provider
StrutsXmlConfigurationProvider(String, boolean, ServletContext) - Constructor for class org.apache.struts2.config.StrutsXmlConfigurationProvider
Constructs the configuration provider
stylesheetLocation - Variable in class org.apache.struts2.views.xslt.XSLTResult
Indicates the location of the xsl template.
Submit - Class in org.apache.struts2.components
Render a submit button.
Submit(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Submit

submit - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

SubmitDirective - Class in org.apache.struts2.views.velocity.components

SubmitDirective() - Constructor for class org.apache.struts2.views.velocity.components.SubmitDirective

SubmitModel - Class in org.apache.struts2.views.freemarker.tags

SubmitModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.SubmitModel

SubmitTag - Class in org.apache.struts2.views.jsp.ui

SubmitTag() - Constructor for class org.apache.struts2.views.jsp.ui.SubmitTag

SubsetIteratorFilter - Class in org.apache.struts2.util
A bean that takes an iterator and outputs a subset of it.
SubsetIteratorFilter() - Constructor for class org.apache.struts2.util.SubsetIteratorFilter

subsetIteratorFilter - Variable in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

SubsetIteratorFilter.Decider - Interface in org.apache.struts2.util
A decider determines if the given element should be added to the list or not.
SubsetIteratorTag - Class in org.apache.struts2.views.jsp.iterator
NOTE: JSP-TAG
SubsetIteratorTag() - Constructor for class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

substringData(int, int) - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

substringData(int, int) - Method in class org.apache.struts2.views.xslt.SimpleTextNode

SUCCESS - Static variable in interface com.opensymphony.xwork2.Action
The action execution was successful.
successResultValue - Variable in class org.apache.struts2.dispatcher.DefaultActionSupport

suffix - Variable in class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith

supportsImageType() - Method in class org.apache.struts2.components.FormButton
Indicate whether the concrete button supports the type "image".
supportsImageType() - Method in class org.apache.struts2.components.Reset
Indicate whether the concrete button supports the type "image".
supportsImageType() - Method in class org.apache.struts2.components.Submit
Indicate whether the concrete button supports the type "image".
surrugate - Variable in class com.opensymphony.xwork2.util.SurrugateList

SurrugateList - Class in com.opensymphony.xwork2.util

SurrugateList(Collection) - Constructor for class com.opensymphony.xwork2.util.SurrugateList

T

tabAlign - Variable in class org.apache.struts2.util.TabbedPane

TabbedPane - Class in org.apache.struts2.util
A bean that helps implement a tabbed pane
TabbedPane(int) - Constructor for class org.apache.struts2.util.TabbedPane

TabbedPanel - Class in org.apache.struts2.components
The tabbedpanel widget is primarily an AJAX component, where each tab can either be local content or remote content (refreshed each time the user selects that tab).
TabbedPanel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.TabbedPanel

tabbedPanel - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

TabbedPanelDirective - Class in org.apache.struts2.views.velocity.components

TabbedPanelDirective() - Constructor for class org.apache.struts2.views.velocity.components.TabbedPanelDirective

TabbedPanelModel - Class in org.apache.struts2.views.freemarker.tags

TabbedPanelModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.TabbedPanelModel

TabbedPanelTag - Class in org.apache.struts2.views.jsp.ui

TabbedPanelTag() - Constructor for class org.apache.struts2.views.jsp.ui.TabbedPanelTag

tabindex - Variable in class org.apache.struts2.components.UIBean

tabindex - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

table - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

tableChanged(TableModelEvent) - Method in class org.apache.struts2.components.table.SortFilterModel
Implements the TableModelListener interface to receive notifications of * changes to the table model.
tag - Variable in class org.apache.struts2.components.template.TemplateRenderingContext

TAG - Static variable in class org.apache.struts2.views.velocity.VelocityManager
the current JSP tag
tagInProgress - Variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

tagIsEmpty - Variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

tagLibraries - Variable in class org.apache.struts2.views.freemarker.FreemarkerManager

tagLibraries - Variable in class org.apache.struts2.views.velocity.VelocityManager

TagLibrary - Interface in org.apache.struts2.views
Provides Velocity and Freemarker implementation classes for a tag library
TagModel - Class in org.apache.struts2.views.freemarker.tags

TagModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.TagModel

TagUtils - Class in org.apache.struts2.views.jsp

TagUtils() - Constructor for class org.apache.struts2.views.jsp.TagUtils

target - Variable in class com.opensymphony.xwork2.util.profiling.TimerInvocationHandler

target - Variable in class org.apache.struts2.components.Form

target - Variable in class org.apache.struts2.views.jsp.ui.FormTag

targets - Variable in class org.apache.struts2.components.Anchor

targets - Variable in class org.apache.struts2.components.Submit

targets - Variable in class org.apache.struts2.views.jsp.ui.AnchorTag

targets - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

tearDown() - Method in class com.opensymphony.xwork2.TestNGXWorkTestCase

tearDown(ConfigurationManager) - Static method in class com.opensymphony.xwork2.util.XWorkTestCaseHelper

tearDown() - Method in class com.opensymphony.xwork2.XWorkTestCase

tearDown() - Method in class org.apache.struts2.StrutsTestCase

tearDown() - Method in class org.apache.struts2.TestNGStrutsTestCase

tearDown() - Static method in class org.apache.struts2.util.StrutsTestCaseHelper

TEMPLATE - Static variable in class org.apache.struts2.components.ActionError

TEMPLATE - Static variable in class org.apache.struts2.components.ActionMessage

TEMPLATE - Static variable in class org.apache.struts2.components.Anchor

TEMPLATE - Static variable in class org.apache.struts2.components.Autocompleter

TEMPLATE - Static variable in class org.apache.struts2.components.Checkbox

TEMPLATE - Static variable in class org.apache.struts2.components.CheckboxList

TEMPLATE - Static variable in class org.apache.struts2.components.ComboBox

TEMPLATE - Static variable in class org.apache.struts2.components.DateTimePicker

TEMPLATE - Static variable in class org.apache.struts2.components.Debug

TEMPLATE - Static variable in class org.apache.struts2.components.Div

TEMPLATE - Static variable in class org.apache.struts2.components.DoubleSelect

TEMPLATE - Static variable in class org.apache.struts2.components.FieldError

TEMPLATE - Static variable in class org.apache.struts2.components.File

TEMPLATE - Static variable in class org.apache.struts2.components.Form

TEMPLATE - Static variable in class org.apache.struts2.components.GenericUIBean

TEMPLATE - Static variable in class org.apache.struts2.components.Head

TEMPLATE - Static variable in class org.apache.struts2.components.Hidden

TEMPLATE - Static variable in class org.apache.struts2.components.InputTransferSelect

TEMPLATE - Static variable in class org.apache.struts2.components.Label

TEMPLATE - Static variable in class org.apache.struts2.components.OptionTransferSelect

TEMPLATE - Static variable in class org.apache.struts2.components.Password

TEMPLATE - Static variable in class org.apache.struts2.components.Radio

TEMPLATE - Static variable in class org.apache.struts2.components.Reset

TEMPLATE - Static variable in class org.apache.struts2.components.Select

TEMPLATE - Static variable in class org.apache.struts2.components.Submit

TEMPLATE - Static variable in class org.apache.struts2.components.TabbedPanel

TEMPLATE - Static variable in class org.apache.struts2.components.table.WebTable

Template - Class in org.apache.struts2.components.template
A template.
Template(String, String, String) - Constructor for class org.apache.struts2.components.template.Template
Constructor.
template - Variable in class org.apache.struts2.components.template.TemplateRenderingContext

TEMPLATE - Static variable in class org.apache.struts2.components.TextArea

TEMPLATE - Static variable in class org.apache.struts2.components.TextField
The name of the default template for the TextFieldTag
TEMPLATE - Static variable in class org.apache.struts2.components.Token

TEMPLATE - Static variable in class org.apache.struts2.components.Tree

TEMPLATE - Static variable in class org.apache.struts2.components.TreeNode

template - Variable in class org.apache.struts2.components.UIBean

TEMPLATE - Static variable in class org.apache.struts2.components.UpDownSelect

template - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

TEMPLATE_CLOSE - Static variable in class org.apache.struts2.components.Div

TEMPLATE_CLOSE - Static variable in class org.apache.struts2.components.TabbedPanel

templateCssPath - Variable in class org.apache.struts2.components.Autocompleter

templateCssPath - Variable in class org.apache.struts2.components.DateTimePicker

templateCssPath - Variable in class org.apache.struts2.components.TabbedPanel

templateCssPath - Variable in class org.apache.struts2.components.Tree

templateCssPath - Variable in class org.apache.struts2.views.jsp.ui.AutocompleterTag

templateCssPath - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

templateCssPath - Variable in class org.apache.struts2.views.jsp.ui.TabbedPanelTag

templateCssPath - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

templateDir - Variable in class org.apache.struts2.components.UIBean

templateDir - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

TemplateEngine - Interface in org.apache.struts2.components.template
Any template language which wants to support UI tag templating needs to provide an implementation of this interface to handle rendering the template
TemplateEngineManager - Class in org.apache.struts2.components.template
The TemplateEngineManager will return a template engine for the template
TemplateEngineManager() - Constructor for class org.apache.struts2.components.template.TemplateEngineManager

templateEngineManager - Variable in class org.apache.struts2.components.UIBean

TemplateEngineManager.EngineFactory - Interface in org.apache.struts2.components.template
Abstracts loading of the template engine
TemplateEngineManager.LazyEngineFactory - Class in org.apache.struts2.components.template
Allows the template engine to be loaded at request time, so that engines that are missing dependencies aren't accessed if never used.
TemplateEngineManager.LazyEngineFactory(String) - Constructor for class org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory

templateEngines - Variable in class org.apache.struts2.components.template.TemplateEngineManager

TemplateRenderingContext - Class in org.apache.struts2.components.template
Context used when rendering templates.
TemplateRenderingContext(Template, Writer, ValueStack, Map, UIBean) - Constructor for class org.apache.struts2.components.template.TemplateRenderingContext
Constructor
templatesCache - Static variable in class org.apache.struts2.views.xslt.XSLTResult
Cache of all tempaltes.
templateSuffix - Variable in class org.apache.struts2.components.UIBean

test - Variable in class org.apache.struts2.components.ElseIf

test - Variable in class org.apache.struts2.components.If

test - Variable in class org.apache.struts2.views.jsp.ElseIfTag

test - Variable in class org.apache.struts2.views.jsp.IfTag

testEquals(Object, Object) - Method in class com.opensymphony.xwork2.util.location.LocationImpl

TestNGStrutsTestCase - Class in org.apache.struts2
Base test class for TestNG unit tests.
TestNGStrutsTestCase() - Constructor for class org.apache.struts2.TestNGStrutsTestCase

TestNGXWorkTestCase - Class in com.opensymphony.xwork2
Base test class for TestNG unit tests.
TestNGXWorkTestCase() - Constructor for class com.opensymphony.xwork2.TestNGXWorkTestCase

Text - Class in org.apache.struts2.components
Render a I18n text message.
Text(ValueStack) - Constructor for class org.apache.struts2.components.Text

text - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

text() - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

TextArea - Class in org.apache.struts2.components
Render HTML textarea tag.
TextArea(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.TextArea

textarea - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

TextAreaDirective - Class in org.apache.struts2.views.velocity.components

TextAreaDirective() - Constructor for class org.apache.struts2.views.velocity.components.TextAreaDirective

TextAreaModel - Class in org.apache.struts2.views.freemarker.tags

TextAreaModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.TextAreaModel

TextareaTag - Class in org.apache.struts2.views.jsp.ui

TextareaTag() - Constructor for class org.apache.struts2.views.jsp.ui.TextareaTag

TextDirective - Class in org.apache.struts2.views.velocity.components

TextDirective() - Constructor for class org.apache.struts2.views.velocity.components.TextDirective

TextField - Class in org.apache.struts2.components
Render an HTML input field of type text
TextField(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.TextField

textfield - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

TextFieldDirective - Class in org.apache.struts2.views.velocity.components

TextFieldDirective() - Constructor for class org.apache.struts2.views.velocity.components.TextFieldDirective

TextFieldModel - Class in org.apache.struts2.views.freemarker.tags

TextFieldModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.TextFieldModel

TextFieldTag - Class in org.apache.struts2.views.jsp.ui

TextFieldTag() - Constructor for class org.apache.struts2.views.jsp.ui.TextFieldTag

TextModel - Class in org.apache.struts2.views.freemarker.tags

TextModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.TextModel

TextParseUtil - Class in com.opensymphony.xwork2.util
Utility class for text parsing.
TextParseUtil() - Constructor for class com.opensymphony.xwork2.util.TextParseUtil

TextParseUtil.ParsedValueEvaluator - Interface in com.opensymphony.xwork2.util
A parsed value evaluator for TextParseUtil.
textProvider - Variable in class com.opensymphony.xwork2.ActionSupport

TextProvider - Interface in com.opensymphony.xwork2
Provides access to ResourceBundles and their underlying text messages.
textProvider - Variable in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

TextProviderFactory - Class in com.opensymphony.xwork2
TextProviderFactory
TextProviderFactory() - Constructor for class com.opensymphony.xwork2.TextProviderFactory

TextProviderSupport - Class in com.opensymphony.xwork2
Default TextProvider implementation.
TextProviderSupport() - Constructor for class com.opensymphony.xwork2.TextProviderSupport
Default constructor
TextProviderSupport(Class, LocaleProvider) - Constructor for class com.opensymphony.xwork2.TextProviderSupport
Constructor.
TextProviderSupport(ResourceBundle, LocaleProvider) - Constructor for class com.opensymphony.xwork2.TextProviderSupport
Constructor.
TextTag - Class in org.apache.struts2.views.jsp

TextTag() - Constructor for class org.apache.struts2.views.jsp.TextTag

TextUtil - Class in org.apache.struts2.views.util
This class handles HTML escaping of text.
TextUtil() - Constructor for class org.apache.struts2.views.util.TextUtil

TextUtils - Class in com.opensymphony.xwork2.util
Utilities for common String manipulations.
TextUtils() - Constructor for class com.opensymphony.xwork2.util.TextUtils

theme - Variable in class org.apache.struts2.components.template.Template

theme - Variable in class org.apache.struts2.components.UIBean

theme - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

themeProps - Variable in class org.apache.struts2.components.template.BaseTemplateEngine

threadPriority - Variable in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

throwExceptionOnNullValueAttribute - Variable in class org.apache.struts2.components.ListUIBean

thSelf - Static variable in class com.opensymphony.xwork2.ObjectFactory

Timer - Class in org.apache.struts2.util
A bean that can be used to time execution of pages
Timer() - Constructor for class org.apache.struts2.util.Timer

TimerInterceptor - Class in com.opensymphony.xwork2.interceptor
This interceptor logs the amount of time in milliseconds.
TimerInterceptor() - Constructor for class com.opensymphony.xwork2.interceptor.TimerInterceptor

TimerInvocationHandler - Class in com.opensymphony.xwork2.util.profiling

TimerInvocationHandler(Object) - Constructor for class com.opensymphony.xwork2.util.profiling.TimerInvocationHandler

title - Variable in class org.apache.struts2.components.UIBean

title - Variable in class org.apache.struts2.portlet.result.PortletResult

title - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

toArray(List<ContainerImpl.ParameterInjector<?>>) - Method in class com.opensymphony.xwork2.inject.ContainerImpl

toByteArray() - Method in class org.apache.struts2.util.FastByteArrayOutputStream

toCallable(InternalContext, InternalFactory<? extends T>) - Method in enum com.opensymphony.xwork2.inject.Scope

toggle - Variable in class org.apache.struts2.components.Tree

toggle - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

toggleDuration - Variable in class org.apache.struts2.components.DateTimePicker

toggleDuration - Variable in class org.apache.struts2.components.Tree

toggleDuration - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

toggleDuration - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

toggleType - Variable in class org.apache.struts2.components.DateTimePicker

toggleType - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

toInt(long) - Method in class org.apache.struts2.util.StrutsUtil

Token - Class in org.apache.struts2.components
Stop double-submission of forms.
Token(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Token

token - Variable in class org.apache.struts2.util.InvocationSessionStore.InvocationContext

token - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

TOKEN_NAME_FIELD - Static variable in class org.apache.struts2.util.TokenHelper
The name of the field which will hold the token name
TokenDirective - Class in org.apache.struts2.views.velocity.components

TokenDirective() - Constructor for class org.apache.struts2.views.velocity.components.TokenDirective

TokenHelper - Class in org.apache.struts2.util
TokenHelper
TokenHelper() - Constructor for class org.apache.struts2.util.TokenHelper

TokenInterceptor - Class in org.apache.struts2.interceptor
Ensures that only one request per token is processed.
TokenInterceptor() - Constructor for class org.apache.struts2.interceptor.TokenInterceptor

TokenModel - Class in org.apache.struts2.views.freemarker.tags

TokenModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.TokenModel

TokenSessionStoreInterceptor - Class in org.apache.struts2.interceptor
This interceptor builds off of the TokenInterceptor, providing advanced logic for handling invalid tokens.
TokenSessionStoreInterceptor() - Constructor for class org.apache.struts2.interceptor.TokenSessionStoreInterceptor

TokenTag - Class in org.apache.struts2.views.jsp.ui

TokenTag() - Constructor for class org.apache.struts2.views.jsp.ui.TokenTag

toLong(int) - Method in class org.apache.struts2.util.StrutsUtil

toLong(String) - Method in class org.apache.struts2.util.StrutsUtil

toolBoxLocation - Variable in class org.apache.struts2.views.velocity.VelocityManager

toolboxManager - Variable in class org.apache.struts2.views.velocity.VelocityManager
A reference to the toolbox manager.
tooltip - Variable in class org.apache.struts2.components.UIBean

tooltip - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

tooltipConfig - Variable in class org.apache.struts2.components.UIBean

tooltipConfig - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

toString() - Method in class com.opensymphony.xwork2.config.entities.ActionConfig

toString() - Method in class com.opensymphony.xwork2.config.entities.PackageConfig

toString() - Method in class com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl

toString() - Method in class com.opensymphony.xwork2.config.impl.LocatableConstantFactory

toString() - Method in class com.opensymphony.xwork2.config.impl.LocatableFactory

toString() - Method in enum com.opensymphony.xwork2.conversion.annotations.ConversionRule

toString() - Method in enum com.opensymphony.xwork2.conversion.annotations.ConversionType

toString() - Method in class com.opensymphony.xwork2.inject.ExternalContext

toString() - Method in class com.opensymphony.xwork2.inject.Key

toString() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

toString() - Method in class com.opensymphony.xwork2.util.location.LocationImpl

toString(Location) - Static method in class com.opensymphony.xwork2.util.location.LocationUtils
Builds a string representation of a location, in the "descripton - uri:line:column" format (e.g.
toString() - Method in class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith

toString() - Method in class com.opensymphony.xwork2.util.ResolverUtil.IsA

toString() - Method in class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith

toString() - Method in enum com.opensymphony.xwork2.validator.annotations.ValidatorType

toString() - Method in exception com.opensymphony.xwork2.XWorkException
Returns a short description of this throwable object, including the location.
toString(Throwable) - Method in class org.apache.struts2.components.Component
Constructs a string representation of the given exception.
toString() - Method in class org.apache.struts2.components.template.Template
Constructs a string in the format /dir/theme/name.
toString() - Method in class org.apache.struts2.config.StrutsXmlConfigurationProvider

toString() - Method in class org.apache.struts2.util.FastByteArrayOutputStream

toString(long) - Method in class org.apache.struts2.util.StrutsUtil

toString(int) - Method in class org.apache.struts2.util.StrutsUtil

toString() - Method in class org.apache.struts2.util.URLBean

toString(Throwable) - Method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

toString() - Method in class org.apache.struts2.views.xslt.AbstractAdapterNode

toString() - Method in class org.apache.struts2.views.xslt.ProxyAttrAdapter

toString() - Method in class org.apache.struts2.views.xslt.ProxyElementAdapter

toString() - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

toString() - Method in class org.apache.struts2.views.xslt.ProxyTextNodeAdapter

toString() - Method in class org.apache.struts2.views.xslt.SimpleNodeList

totalTime - Variable in class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

translateAndDecode(String) - Static method in class org.apache.struts2.views.util.UrlHelper

translateAndEncode(String) - Static method in class org.apache.struts2.views.util.UrlHelper
Translates any script expressions using TextParseUtil.translateVariables(java.lang.String, com.opensymphony.xwork2.util.ValueStack) and encodes the URL using URLEncoder.encode(java.lang.String) with the encoding specified in the configuration.
translateVariable(String) - Static method in class org.apache.struts2.views.util.UrlHelper

translateVariables(String, ValueStack) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String).
translateVariables(String, ValueStack, TextParseUtil.ParsedValueEvaluator) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Function similarly as TextParseUtil.translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator.
translateVariables(char, String, ValueStack) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converts all instances of ${...} in expression to the value returned by a call to ValueStack.findValue(java.lang.String).
translateVariables(char, String, ValueStack, Class) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converted object from variable translation.
translateVariables(char, String, ValueStack, Class, TextParseUtil.ParsedValueEvaluator) - Static method in class com.opensymphony.xwork2.util.TextParseUtil
Converted object from variable translation.
translateVariables(String, ValueStack) - Static method in class org.apache.struts2.views.jsp.StrutsBodyTagSupport

Tree - Class in org.apache.struts2.components
Renders a tree widget with AJAX support.
The id attribute is normally specified, such that it could be looked up using javascript if necessary.

Examples
Tree(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.Tree

treeCollapsedTopic - Variable in class org.apache.struts2.components.Tree

treeCollapsedTopic - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

TreeDirective - Class in org.apache.struts2.views.velocity.components
TreeDirective
TreeDirective() - Constructor for class org.apache.struts2.views.velocity.components.TreeDirective

treeExpandedTopic - Variable in class org.apache.struts2.components.Tree

treeExpandedTopic - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

treeModel - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

TreeModel - Class in org.apache.struts2.views.freemarker.tags
TreeModel
TreeModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.TreeModel

TreeNode - Class in org.apache.struts2.components
Renders a tree node within a tree widget with AJAX support.
Either of the following combinations should be used depending on if the tree is to be constrcted dynamically or statically.
TreeNode(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.TreeNode

TreeNodeDirective - Class in org.apache.struts2.views.velocity.components
TreeNodeDirective
TreeNodeDirective() - Constructor for class org.apache.struts2.views.velocity.components.TreeNodeDirective

treenodeModel - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

TreeNodeModel - Class in org.apache.struts2.views.freemarker.tags
TreeNodeModel
TreeNodeModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.TreeNodeModel

TreeNodeTag - Class in org.apache.struts2.views.jsp.ui

TreeNodeTag() - Constructor for class org.apache.struts2.views.jsp.ui.TreeNodeTag

treeSelectedTopic - Variable in class org.apache.struts2.components.Tree

treeSelectedTopic - Variable in class org.apache.struts2.views.jsp.ui.TreeTag

TreeTag - Class in org.apache.struts2.views.jsp.ui

TreeTag() - Constructor for class org.apache.struts2.views.jsp.ui.TreeTag

trim - Variable in class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription

trim - Variable in class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

trim - Variable in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator

type - Variable in class com.opensymphony.xwork2.config.impl.LocatableFactory

type - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

type - Variable in class com.opensymphony.xwork2.inject.Key

type - Variable in class com.opensymphony.xwork2.validator.ValidatorConfig

type - Variable in class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

type - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

type - Variable in class org.apache.struts2.components.DateTimePicker

type - Variable in class org.apache.struts2.components.FormButton

type - Variable in class org.apache.struts2.components.Reset

type - Variable in class org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory

type - Variable in class org.apache.struts2.interceptor.ScopeInterceptor

type - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

type - Variable in class org.apache.struts2.views.jsp.ui.ResetTag

type - Variable in class org.apache.struts2.views.jsp.ui.SubmitTag

TYPE_CONVERTER - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the action's type converter.
TypeConversion - Annotation Type in com.opensymphony.xwork2.conversion.annotations

This annotation is used for class and application wide conversion rules.
TypeConversionException - Exception in com.opensymphony.xwork2.util
TypeConversionException should be thrown by any TypeConverters which fail to convert values
TypeConversionException() - Constructor for exception com.opensymphony.xwork2.util.TypeConversionException
Constructs a XWorkException with no detail message.
TypeConversionException(String) - Constructor for exception com.opensymphony.xwork2.util.TypeConversionException
Constructs a XWorkException with the specified detail message.
TypeConversionException(Throwable) - Constructor for exception com.opensymphony.xwork2.util.TypeConversionException
Constructs a XWorkException with no detail message.
TypeConversionException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.util.TypeConversionException
Constructs a XWorkException with the specified detail message.
typeConverter - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

U

UIBean - Class in org.apache.struts2.components
UIBean is the standard superclass of all Struts UI componentns.
UIBean(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.UIBean

unableToFindTextForKey(LocalizedTextUtil.GetDefaultMessageReturnArg) - Static method in class com.opensymphony.xwork2.util.LocalizedTextUtil
Determines if we found the text in the bundles.
Unchainable - Interface in com.opensymphony.xwork2
Simple marker interface to indicate an object should not have it's properties copied during chaining.
uncheckedValue - Variable in class org.apache.struts2.interceptor.CheckboxInterceptor

unescapeJava(String, char) - Static method in class com.opensymphony.xwork2.util.PropertiesReader
Unescapes any Java literals found in the String to a Writer.
unescapeJava(String) - Static method in class com.opensymphony.xwork2.util.PropertiesReader
Unescapes any Java literals found in the String.
unescapeJava(Writer, String) - Static method in class com.opensymphony.xwork2.util.PropertiesReader
Unescapes any Java literals found in the String to a Writer.
UNICODE_LEN - Static variable in class com.opensymphony.xwork2.util.PropertiesReader
Constant for the length of a unicode literal.
UNKNOWN - Static variable in interface com.opensymphony.xwork2.util.location.Location
Constant for unknown locations.
UNKNOWN - Static variable in class com.opensymphony.xwork2.util.location.LocationImpl

UNKNOWN_STRING - Static variable in class com.opensymphony.xwork2.util.location.LocationUtils
The string representation of an unknown location: "[unknown location]".
unknownHandler - Variable in class com.opensymphony.xwork2.DefaultActionInvocation

unknownHandler - Variable in class com.opensymphony.xwork2.DefaultActionProxy

UnknownHandler - Interface in com.opensymphony.xwork2
Handles cases when the result or action is unknown.
unknownMappings - Variable in class com.opensymphony.xwork2.util.XWorkConverter
Record classes that doesn't have conversion mapping defined.
unlock(Object) - Static method in class org.apache.struts2.interceptor.ScopeInterceptor

UNSUPPORTED - Static variable in class org.apache.struts2.util.AttributeMap

unwrap() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper

updateCurrentPropertyPath(Map, Object) - Static method in class com.opensymphony.xwork2.util.OgnlContextState

updateFreq - Variable in class org.apache.struts2.components.Div

updateFreq - Variable in class org.apache.struts2.views.jsp.ui.DivTag

UpDownSelect - Class in org.apache.struts2.components
Create a Select component with buttons to move the elements in the select component up and down.
UpDownSelect(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.UpDownSelect

updownselect - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

UpDownSelectDirective - Class in org.apache.struts2.views.velocity.components

UpDownSelectDirective() - Constructor for class org.apache.struts2.views.velocity.components.UpDownSelectDirective

UpDownSelectModel - Class in org.apache.struts2.views.freemarker.tags

UpDownSelectModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.UpDownSelectModel

UpDownSelectTag - Class in org.apache.struts2.views.jsp.ui

UpDownSelectTag() - Constructor for class org.apache.struts2.views.jsp.ui.UpDownSelectTag

upLabel - Variable in class org.apache.struts2.components.InputTransferSelect

upLabel - Variable in class org.apache.struts2.views.jsp.ui.InputTransferSelectTag

upperAt(int, String) - Method in class org.apache.struts2.config.MethodConfigurationProvider
Verifies that character at a String position is upper case.
URI - Static variable in class com.opensymphony.xwork2.util.location.LocationAttributes
Namespace URI for location attributes
uri - Variable in class com.opensymphony.xwork2.util.location.LocationImpl

URL - Class in org.apache.struts2.components

URL(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.URL

url - Variable in class org.apache.struts2.views.freemarker.tags.StrutsModels

URL.ExtraParameterProvider - Interface in org.apache.struts2.components

URLBean - Class in org.apache.struts2.util
A bean that can generate a URL.
URLBean() - Constructor for class org.apache.struts2.util.URLBean

URLDirective - Class in org.apache.struts2.views.velocity.components

URLDirective() - Constructor for class org.apache.struts2.views.velocity.components.URLDirective

urlEncode(String) - Method in class org.apache.struts2.util.StrutsUtil

UrlHelper - Class in org.apache.struts2.views.util
UrlHelper
UrlHelper() - Constructor for class org.apache.struts2.views.util.UrlHelper

urlIncludeParams - Variable in class org.apache.struts2.components.URL

URLModel - Class in org.apache.struts2.views.freemarker.tags

URLModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.URLModel

URLTag - Class in org.apache.struts2.views.jsp

URLTag() - Constructor for class org.apache.struts2.views.jsp.URLTag

UrlValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
This validator checks that a field is a valid URL.
URLValidator - Class in com.opensymphony.xwork2.validator.validators
URLValidator checks that a given field is a String and a valid URL
fieldName - The field name this validator is validating.
URLValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.URLValidator

URLValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
URLValidatorDescription
URLValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription

URLValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified aliasNames.
useClassCache - Variable in class com.opensymphony.xwork2.spring.SpringObjectFactory

usesBody() - Method in class org.apache.struts2.components.Component
Overwrite to set if body shold be used.
usesBody() - Method in class org.apache.struts2.components.Param

usesBody() - Method in class org.apache.struts2.components.Text

UtilTimerStack - Class in com.opensymphony.xwork2.util.profiling
A timer stack.
UtilTimerStack() - Constructor for class com.opensymphony.xwork2.util.profiling.UtilTimerStack

UtilTimerStack.ProfilingBlock<T> - Interface in com.opensymphony.xwork2.util.profiling
A callback interface where code subjected to profile is to be executed.

V

validate() - Method in class com.opensymphony.xwork2.ActionSupport
A default implementation that validates nothing.
validate() - Method in interface com.opensymphony.xwork2.Validateable
Performs validation.
validate(Object, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Validates the given object using action and its context.
validate(Object, String, ValidatorContext) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Validates an action give its context and a validation context.
validate(Object, String, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Validates the given object using an action, its context, and the name of the method being invoked on the action.
validate(Object, String, ValidatorContext, String) - Method in interface com.opensymphony.xwork2.validator.ActionValidatorManager
Validates an action give its context and a validation context.
validate(Object, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
Validates the given object using action and its context.
validate(Object, String, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
Validates the given object using action, its context, and the name of the method being invoked on the action.
validate(Object, String, ValidatorContext) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
Validates an action give its context and a validation context.
validate(Object, String, ValidatorContext, String) - Method in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
Validates an action give its context, a validation context, and the name of the method being invoked on the action.
validate(Object, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
Validates the given object using action and its context.
validate(Object, String, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
Validates the given object using action, its context, and the name of the method being invoked on the action.
validate(Object, String, ValidatorContext) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
Validates an action give its context and a validation context.
validate(Object, String, ValidatorContext, String) - Method in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
Validates an action give its context, a validation context, and the name of the method being invoked on the action.
validate(Object) - Method in interface com.opensymphony.xwork2.validator.Validator
The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.ExpressionValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RegexFieldValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RequiredFieldValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.RequiredStringValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.URLValidator

validate(Object) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

validate - Variable in class org.apache.struts2.components.Form

validate - Variable in class org.apache.struts2.views.jsp.ui.FormTag

VALIDATE_PREFIX - Static variable in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

Validateable - Interface in com.opensymphony.xwork2
Provides an interface in which a call for a validation check can be done.
validateAnnotatedMethodOnly - Variable in class com.opensymphony.xwork2.validator.ValidationInterceptor

validateArrayElements(Object[], String, String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

validateObject(String, Object, String) - Method in class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

Validation - Annotation Type in com.opensymphony.xwork2.validator.annotations
If you want to use annotation based validation, you have to annotate the class or interface with Validation Annotation.
VALIDATION_CONFIG_SUFFIX - Static variable in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager
The file suffix for any validation file.
VALIDATION_CONFIG_SUFFIX - Static variable in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager
The file suffix for any validation file.
validationAware - Variable in class com.opensymphony.xwork2.ActionSupport

ValidationAware - Interface in com.opensymphony.xwork2
ValidationAware classes can accept Action (class level) or field level error messages.
validationAware - Variable in class com.opensymphony.xwork2.validator.DelegatingValidatorContext

ValidationAwareSupport - Class in com.opensymphony.xwork2
Provides a default implementation of ValidationAware.
ValidationAwareSupport() - Constructor for class com.opensymphony.xwork2.ValidationAwareSupport

ValidationException - Exception in com.opensymphony.xwork2.validator
ValidationException.
ValidationException() - Constructor for exception com.opensymphony.xwork2.validator.ValidationException
Constructs an Exception with no specified detail message.
ValidationException(String) - Constructor for exception com.opensymphony.xwork2.validator.ValidationException
Constructs an Exception with the specified detail message.
ValidationInterceptor - Class in com.opensymphony.xwork2.validator
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).
ValidationInterceptor() - Constructor for class com.opensymphony.xwork2.validator.ValidationInterceptor

ValidationParameter - Annotation Type in com.opensymphony.xwork2.validator.annotations
The ValidationParameter annotation is used as a parameter for CustomValidators.
Validations - Annotation Type in com.opensymphony.xwork2.validator.annotations

Validator - Interface in com.opensymphony.xwork2.validator

validatorCache - Static variable in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

validatorCache - Static variable in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager

ValidatorConfig - Class in com.opensymphony.xwork2.validator
Holds the necessary information for configuring an instance of a Validator.
ValidatorConfig() - Constructor for class com.opensymphony.xwork2.validator.ValidatorConfig

ValidatorConfig(String, Map) - Constructor for class com.opensymphony.xwork2.validator.ValidatorConfig

ValidatorContext - Interface in com.opensymphony.xwork2.validator
The context for validation.
validatorContext - Variable in class com.opensymphony.xwork2.validator.validators.ValidatorSupport

ValidatorDescription - Interface in com.opensymphony.xwork2.validator.metadata
ValidatorDescription
ValidatorFactory - Class in com.opensymphony.xwork2.validator
ValidatorFactory
ValidatorFactory() - Constructor for class com.opensymphony.xwork2.validator.ValidatorFactory

validatorFileCache - Static variable in class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

validatorFileCache - Static variable in class com.opensymphony.xwork2.validator.DefaultActionValidatorManager

ValidatorFileParser - Class in com.opensymphony.xwork2.validator
Parse the validation file.
ValidatorFileParser() - Constructor for class com.opensymphony.xwork2.validator.ValidatorFileParser

validators - Static variable in class com.opensymphony.xwork2.validator.ValidatorFactory

ValidatorSupport - Class in com.opensymphony.xwork2.validator.validators
Abstract implementation of the Validator interface suitable for subclassing.
ValidatorSupport() - Constructor for class com.opensymphony.xwork2.validator.validators.ValidatorSupport

ValidatorType - Enum in com.opensymphony.xwork2.validator.annotations
ValidatorType
ValidatorType() - Constructor for enum com.opensymphony.xwork2.validator.annotations.ValidatorType

validToken() - Static method in class org.apache.struts2.util.TokenHelper
Checks for a valid transaction token in the current request params.
value - Variable in class com.opensymphony.xwork2.conversion.metadata.ConversionDescription

value - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

value - Variable in class com.opensymphony.xwork2.util.ObjectProxy

value - Variable in class org.apache.struts2.components.Debug.DebugMapEntry

value - Variable in class org.apache.struts2.components.Include

value - Variable in class org.apache.struts2.components.IteratorComponent

value - Variable in class org.apache.struts2.components.Param

value - Variable in class org.apache.struts2.components.Property

value - Variable in class org.apache.struts2.components.Push

value - Variable in class org.apache.struts2.components.Set

value - Variable in class org.apache.struts2.components.UIBean

value - Variable in class org.apache.struts2.components.URL

value - Variable in class org.apache.struts2.util.IteratorGenerator

value - Variable in class org.apache.struts2.util.ListEntry

value - Variable in class org.apache.struts2.util.PrefixTrie.Node

value - Variable in class org.apache.struts2.views.jsp.IncludeTag

value - Variable in class org.apache.struts2.views.jsp.IteratorTag

value - Variable in class org.apache.struts2.views.jsp.ParamTag

value - Variable in class org.apache.struts2.views.jsp.PropertyTag

value - Variable in class org.apache.struts2.views.jsp.PushTag

value - Variable in class org.apache.struts2.views.jsp.SetTag

value - Variable in class org.apache.struts2.views.jsp.ui.AbstractUITag

value - Variable in class org.apache.struts2.views.jsp.URLTag

value - Variable in class org.apache.struts2.views.xslt.MapAdapter.EntryElement

VALUE_STACK - Static variable in class com.opensymphony.xwork2.ActionContext
Constant for the OGNL value stack.
VALUE_STACK - Static variable in interface com.opensymphony.xwork2.util.ValueStack

valueAttr - Variable in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

valueOf(String) - Static method in enum com.opensymphony.xwork2.conversion.annotations.ConversionRule
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.conversion.annotations.ConversionType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.inject.Scope
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.inject.util.ReferenceType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum com.opensymphony.xwork2.validator.annotations.ValidatorType
Returns the enum constant of this type with the specified name.
valueReferenceType - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap

values() - Static method in enum com.opensymphony.xwork2.conversion.annotations.ConversionRule
Returns an array containing the constants of this enum type, in the order they're declared.
values() - Static method in enum com.opensymphony.xwork2.conversion.annotations.ConversionType
Returns an array containing the constants of this enum type, in the order they're declared.
values() - Static method in enum com.opensymphony.xwork2.inject.Scope
Returns an array containing the constants of this enum type, in the order they're declared.
values() - Static method in enum com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy
Returns an array containing the constants of this enum type, in the order they're declared.
values() - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap
Returns an unmodifiable set view of the values in this map.
values() - Static method in enum com.opensymphony.xwork2.inject.util.ReferenceType
Returns an array containing the constants of this enum type, in the order they're declared.
values() - Static method in enum com.opensymphony.xwork2.validator.annotations.ValidatorType
Returns an array containing the constants of this enum type, in the order they're declared.
values - Variable in class org.apache.struts2.components.Text

values() - Method in class org.apache.struts2.util.AttributeMap

values - Variable in class org.apache.struts2.util.IteratorGenerator

values() - Method in class org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel

ValueStack - Interface in com.opensymphony.xwork2.util
ValueStack allows multiple beans to be pushed in and dynamic EL expressions to be evaluated against it.
ValueStackFactory - Class in com.opensymphony.xwork2.util
Factory that creates a value stack, defaulting to the OgnlValueStackFactory
ValueStackFactory() - Constructor for class com.opensymphony.xwork2.util.ValueStackFactory

velocityEngine - Variable in class org.apache.struts2.util.VelocityStrutsUtil

velocityEngine - Variable in class org.apache.struts2.views.velocity.VelocityManager

velocityManager - Variable in class org.apache.struts2.components.template.VelocityTemplateEngine

velocityManager - Variable in class org.apache.struts2.dispatcher.VelocityResult

velocityManager - Variable in class org.apache.struts2.portlet.result.PortletVelocityResult

VelocityManager - Class in org.apache.struts2.views.velocity
Manages the environment for Velocity result types
VelocityManager() - Constructor for class org.apache.struts2.views.velocity.VelocityManager

velocityProperties - Variable in class org.apache.struts2.views.velocity.VelocityManager

VelocityResult - Class in org.apache.struts2.dispatcher
Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.
VelocityResult() - Constructor for class org.apache.struts2.dispatcher.VelocityResult

VelocityResult(String) - Constructor for class org.apache.struts2.dispatcher.VelocityResult

VelocityStrutsUtil - Class in org.apache.struts2.util
Struts velocity related util.
VelocityStrutsUtil(VelocityEngine, Context, ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.util.VelocityStrutsUtil

VelocityTemplateEngine - Class in org.apache.struts2.components.template
Velocity based template engine.
VelocityTemplateEngine() - Constructor for class org.apache.struts2.components.template.VelocityTemplateEngine

verifyAction(String, String, Location) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

verifyResultType(String, Location) - Method in class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

verifyUrl(String) - Static method in class com.opensymphony.xwork2.util.TextUtils
Verify That the given String is in valid URL format.
VisitorFieldValidator - Annotation Type in com.opensymphony.xwork2.validator.annotations
The validator allows you to forward validator to object properties of your action using the objects own validator files.
VisitorFieldValidator - Class in com.opensymphony.xwork2.validator.validators
The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.
VisitorFieldValidator() - Constructor for class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

VisitorFieldValidator.AppendingValidatorContext - Class in com.opensymphony.xwork2.validator.validators

VisitorFieldValidator.AppendingValidatorContext(ValidatorContext, Object, String, String) - Constructor for class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

VisitorFieldValidatorDescription - Class in com.opensymphony.xwork2.validator.metadata
VisitorFieldValidatorDescription
VisitorFieldValidatorDescription() - Constructor for class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

VisitorFieldValidatorDescription(String) - Constructor for class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription
Creates an AbstractFieldValidatorDescription with the specified field name.

W

WAIT - Static variable in class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

warning(SAXParseException) - Method in class com.opensymphony.xwork2.util.DomHelper.StartHandler

WebTable - Class in org.apache.struts2.components.table

WebTable(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.components.table.WebTable

WebTable.WebTableRowIterator - Class in org.apache.struts2.components.table
inner class to iteratoe over a row of the table.
WebTable.WebTableRowIterator(WebTable) - Constructor for class org.apache.struts2.components.table.WebTable.WebTableRowIterator

WebTable.WebTableRowIterator(WebTable, int) - Constructor for class org.apache.struts2.components.table.WebTable.WebTableRowIterator

WebTableColumn - Class in org.apache.struts2.components.table

WebTableColumn(String, int) - Constructor for class org.apache.struts2.components.table.WebTableColumn

WebTableDirective - Class in org.apache.struts2.views.velocity.components

WebTableDirective() - Constructor for class org.apache.struts2.views.velocity.components.WebTableDirective

WebTableModel - Class in org.apache.struts2.views.freemarker.tags

WebTableModel(ValueStack, HttpServletRequest, HttpServletResponse) - Constructor for class org.apache.struts2.views.freemarker.tags.WebTableModel

WebTableTag - Class in org.apache.struts2.views.jsp.ui.table

WebTableTag() - Constructor for class org.apache.struts2.views.jsp.ui.table.WebTableTag

weekStartsOn - Variable in class org.apache.struts2.components.DateTimePicker

weekStartsOn - Variable in class org.apache.struts2.views.jsp.ui.DateTimePickerTag

when(PortletException) - Method in class org.apache.struts2.portlet.result.PortletResult.IncludeTemplate

when(IOException) - Method in class org.apache.struts2.portlet.result.PortletResult.IncludeTemplate

WHITE_SPACE - Static variable in class com.opensymphony.xwork2.util.PropertiesReader
The white space characters used as key/value separators.
wildcard - Static variable in class com.opensymphony.xwork2.config.impl.ActionConfigMatcher
Handles all wildcard pattern matching.
WildcardHelper - Class in com.opensymphony.xwork2.util
This class is an utility class that perform wilcard-patterns matching and isolation taken from Apache Cocoon.
WildcardHelper() - Constructor for class com.opensymphony.xwork2.util.WildcardHelper

windowState - Variable in class org.apache.struts2.components.Form

windowState - Variable in class org.apache.struts2.components.URL

windowState - Variable in class org.apache.struts2.views.jsp.ui.FormTag

windowState - Variable in class org.apache.struts2.views.jsp.URLTag

wrap - Variable in class org.apache.struts2.components.TextArea

wrap - Variable in class org.apache.struts2.util.Counter

wrap(Object) - Method in class org.apache.struts2.views.freemarker.StrutsBeanWrapper

wrap - Variable in class org.apache.struts2.views.jsp.ui.TextareaTag

wrap(Node) - Method in class org.apache.struts2.views.xslt.ProxyNamedNodeMap

wrap(Node) - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter
Get and adapter to wrap the proxied node.
wrap(NamedNodeMap) - Method in class org.apache.struts2.views.xslt.ProxyNodeAdapter

wrapped - Variable in class com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper

wrapper - Variable in class org.apache.struts2.views.freemarker.FreemarkerResult

wrapper - Variable in class org.apache.struts2.views.freemarker.PortletFreemarkerResult

wrapRequest(HttpServletRequest, ServletContext) - Method in class org.apache.struts2.dispatcher.Dispatcher
Wrap and return the given request or return the original request object.
write(byte[], int, int) - Method in class org.apache.struts2.components.Include.PageOutputStream

write(int) - Method in class org.apache.struts2.components.Include.PageOutputStream

write(byte[]) - Method in class org.apache.struts2.components.Include.PageOutputStream

write(int) - Method in class org.apache.struts2.util.FastByteArrayOutputStream

write(byte[], int, int) - Method in class org.apache.struts2.util.FastByteArrayOutputStream

write(int) - Method in class org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper

write(char[], int, int) - Method in class org.apache.struts2.views.freemarker.tags.CallbackWriter

writeAttributeValue(PrintWriter, String) - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

writeObject(ObjectOutputStream) - Method in class com.opensymphony.xwork2.inject.util.ReferenceMap

writer - Variable in class org.apache.struts2.components.template.TemplateRenderingContext

writer - Variable in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

writer - Variable in class org.apache.struts2.util.StrutsUtil.ResponseWrapper

writer - Variable in class org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper

writer - Variable in class org.apache.struts2.views.freemarker.FreemarkerResult

writer - Variable in class org.apache.struts2.views.freemarker.tags.CallbackWriter

writeText(PrintWriter, String) - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

writeText(String) - Method in class org.apache.struts2.interceptor.debugging.PrettyPrintWriter

writeTo(OutputStream) - Method in class org.apache.struts2.util.FastByteArrayOutputStream

writeTo(RandomAccessFile) - Method in class org.apache.struts2.util.FastByteArrayOutputStream

writeTo(Writer, String) - Method in class org.apache.struts2.util.FastByteArrayOutputStream

X

XML_MODE - Static variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

XmlConfigurationProvider - Class in com.opensymphony.xwork2.config.providers
Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.
XmlConfigurationProvider() - Constructor for class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

XmlConfigurationProvider(String) - Constructor for class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

XmlConfigurationProvider(String, boolean) - Constructor for class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

XmlHelper - Class in com.opensymphony.xwork2.config.providers
XML utilities.
XmlHelper() - Constructor for class com.opensymphony.xwork2.config.providers.XmlHelper

XMLNS_URI - Static variable in class com.opensymphony.xwork2.util.DomHelper

XSLTResult - Class in org.apache.struts2.views.xslt
XSLTResult uses XSLT to transform action object to XML.
XSLTResult() - Constructor for class org.apache.struts2.views.xslt.XSLTResult

XSLTResult(String) - Constructor for class org.apache.struts2.views.xslt.XSLTResult

XWorkBasicConverter - Class in com.opensymphony.xwork2.util

XWork will automatically handle the most common type conversion for you.
XWorkBasicConverter() - Constructor for class com.opensymphony.xwork2.util.XWorkBasicConverter

XWorkCollectionPropertyAccessor - Class in com.opensymphony.xwork2.util

XWorkCollectionPropertyAccessor() - Constructor for class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

XWorkConverter - Class in com.opensymphony.xwork2.util
XWorkConverter is a singleton used by many of the WebWork's Ognl extention points, such as InstantiatingNullHandler, XWorkListPropertyAccessor etc to do object conversion.
XWorkConverter() - Constructor for class com.opensymphony.xwork2.util.XWorkConverter

XWorkEnumerationAcccessor - Class in com.opensymphony.xwork2.util

XWorkEnumerationAcccessor() - Constructor for class com.opensymphony.xwork2.util.XWorkEnumerationAcccessor

XWorkException - Exception in com.opensymphony.xwork2
A generic runtime exception that optionally contains Location information
XWorkException() - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with no detail message.
XWorkException(String) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the specified detail message.
XWorkException(String, Object) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the specified detail message and target.
XWorkException(Throwable) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the root cause
XWorkException(Throwable, Object) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the root cause and target
XWorkException(String, Throwable) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the specified detail message and exception cause.
XWorkException(String, Throwable, Object) - Constructor for exception com.opensymphony.xwork2.XWorkException
Constructs a XWorkException with the specified detail message, cause, and target
XWorkIteratorPropertyAccessor - Class in com.opensymphony.xwork2.util

XWorkIteratorPropertyAccessor() - Constructor for class com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor

XWorkList - Class in com.opensymphony.xwork2.util
Deprecated. Native support for expanding lists and maps is provided in XWork 1.1, so this is no longer needed.
XWorkList(Class) - Constructor for class com.opensymphony.xwork2.util.XWorkList
Deprecated.
XWorkList(Class, Collection) - Constructor for class com.opensymphony.xwork2.util.XWorkList
Deprecated.
XWorkList(Class, int) - Constructor for class com.opensymphony.xwork2.util.XWorkList
Deprecated.
XWorkListPropertyAccessor - Class in com.opensymphony.xwork2.util
Overrides the list property accessor so in the case of trying to add properties of a given bean and the JavaBean is not present, this class will create the necessary blank JavaBeans.
XWorkListPropertyAccessor() - Constructor for class com.opensymphony.xwork2.util.XWorkListPropertyAccessor

XWorkMap - Class in com.opensymphony.xwork2.util
Deprecated. Native support for expanding lists and maps is provided in XWork 1.1, so this is no longer needed.
XWorkMap(Class) - Constructor for class com.opensymphony.xwork2.util.XWorkMap
Deprecated.
XWorkMapPropertyAccessor - Class in com.opensymphony.xwork2.util
Implementation of PropertyAccessor that sets and gets properties by storing and looking up values in Maps.
XWorkMapPropertyAccessor() - Constructor for class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

XWorkMessages - Interface in com.opensymphony.xwork2
XworkMessages
XWorkMethodAccessor - Class in com.opensymphony.xwork2.util
Allows methods to be executed under normal cirumstances, except when XWorkMethodAccessor.DENY_METHOD_EXECUTION is in the action context with a value of true.
XWorkMethodAccessor() - Constructor for class com.opensymphony.xwork2.util.XWorkMethodAccessor

XWorkObjectPropertyAccessor - Class in com.opensymphony.xwork2.util

XWorkObjectPropertyAccessor() - Constructor for class com.opensymphony.xwork2.util.XWorkObjectPropertyAccessor

XWorkTestCase - Class in com.opensymphony.xwork2
Base JUnit TestCase to extend for XWork specific JUnit tests.
XWorkTestCase() - Constructor for class com.opensymphony.xwork2.XWorkTestCase

XWorkTestCaseHelper - Class in com.opensymphony.xwork2.util
Generic test setup methods to be used with any unit testing framework.
XWorkTestCaseHelper() - Constructor for class com.opensymphony.xwork2.util.XWorkTestCaseHelper

_

_accessor - Variable in class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

_alignment - Variable in class org.apache.struts2.components.table.renderer.AbstractCellRenderer
used for horizontal cell alignmnet
_converter - Static variable in class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

_cssClass - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
the CSS class this link belongs to.
_cssId - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
the id attribute this link belongs to.
_curRow - Variable in class org.apache.struts2.components.table.WebTable.WebTableRowIterator

_delegateRenderer - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
this is the actual renderer tha will be used to display the text
_displayName - Variable in class org.apache.struts2.components.table.WebTableColumn

_falseValue - Variable in class org.apache.struts2.components.table.renderer.BooleanCellRenderer
value used if the boolean object is false
_formater - Variable in class org.apache.struts2.components.table.renderer.DateCellRenderer

_formater - Variable in class org.apache.struts2.components.table.renderer.NumericCellRenderer

_formatString - Variable in class org.apache.struts2.components.table.renderer.DateCellRenderer
this is the string that SimpleDateFormat needs to display the date
_formatString - Variable in class org.apache.struts2.components.table.renderer.NumericCellRenderer
this is the format string that DecimalFormat would use.
_hidden - Variable in class org.apache.struts2.components.table.WebTableColumn

_ignoreKeys - Variable in class org.apache.struts2.interceptor.debugging.DebuggingInterceptor

_link - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
this is the link we are setting (required)
_log - Static variable in class com.opensymphony.xwork2.interceptor.ChainingInterceptor

_log - Static variable in class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

_log - Static variable in class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

_log - Static variable in class com.opensymphony.xwork2.interceptor.PrepareInterceptor

_log - Static variable in class com.opensymphony.xwork2.util.AnnotationXWorkConverter

_log - Static variable in class com.opensymphony.xwork2.util.LocalizedTextUtil

_log - Static variable in class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

_log - Static variable in class com.opensymphony.xwork2.util.XWorkMethodAccessor

_log - Static variable in class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

_log - Static variable in class org.apache.struts2.components.AppendIterator

_log - Static variable in class org.apache.struts2.components.Include

_log - Static variable in class org.apache.struts2.components.InputTransferSelect

_log - Static variable in class org.apache.struts2.components.MergeIterator

_log - Static variable in class org.apache.struts2.components.OptGroup

_log - Static variable in class org.apache.struts2.components.OptionTransferSelect

_log - Static variable in class org.apache.struts2.components.UpDownSelect

_log - Static variable in class org.apache.struts2.dispatcher.PlainTextResult

_log - Static variable in class org.apache.struts2.dispatcher.StrutsResultSupport

_log - Static variable in class org.apache.struts2.interceptor.CreateSessionInterceptor

_log - Static variable in class org.apache.struts2.interceptor.MessageStoreInterceptor

_log - Static variable in class org.apache.struts2.util.IteratorGenerator

_log - Static variable in class org.apache.struts2.util.SubsetIteratorFilter

_log - Static variable in class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

_log - Static variable in class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

_mode - Variable in class org.apache.struts2.components.table.WebTable.WebTableRowIterator

_name - Variable in class org.apache.struts2.components.table.WebTableColumn

_negativeColor - Variable in class org.apache.struts2.components.table.renderer.NumericCellRenderer
if set the is the color to use if Number is negative.
_offset - Variable in class org.apache.struts2.components.table.WebTableColumn

_onclick - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
the (Java)script/ function to execute when the link is clicked.
_ondblclick - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
the (Java)script/ function to execute when the link is clicked twice.
_onmouseout - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
the (Java)script/ function to execute when cursor is away from the link.
_onmouseover - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
the (Java)script/ function to execute when cursor is over the link.
_param - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
if set there will be a parameter attached to link.
_paramColumn - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
if used the param value will be taken from another column in the table.
_parameters - Variable in class org.apache.struts2.components.AppendIterator

_parameters - Variable in class org.apache.struts2.components.MergeIterator

_paramValue - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
directly set the value for the param.
_positiveColor - Variable in class org.apache.struts2.components.table.renderer.NumericCellRenderer
if set this is the color to render if number is positive
_renderer - Variable in class org.apache.struts2.components.table.WebTableColumn

_sAcc - Variable in class com.opensymphony.xwork2.util.XWorkListPropertyAccessor

_sortDirection - Variable in class org.apache.struts2.components.table.SortFilterModel
These are just here to implement the interface
_stringChars - Static variable in class org.apache.struts2.views.util.TextUtil
We use arrays of char in the lookup table because it is faster appending this to a StringBuffer than appending a String
_table - Variable in class org.apache.struts2.components.table.WebTable.WebTableRowIterator

_target - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
the target frame to open in.
_text - Variable in class org.apache.struts2.components.table.renderer.FixedTextCellRenderer
this is the text that will be shown in the column
_title - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
the title attribute this link belongs to.
_trailParams - Variable in class org.apache.struts2.components.table.renderer.LinkCellRenderer
additional parameters after the above parameter is generated.
_trueValue - Variable in class org.apache.struts2.components.table.renderer.BooleanCellRenderer
value used if the boolean object is true
A B C D E F G H I J K L M N O P Q R S T U V W X _

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

PREV NEXT

FRAMES NO FRAMES


Overview (Struts 2 Core 2.0.6 API)

All Classes

Packages
com.opensymphony.xwork2
com.opensymphony.xwork2.config
com.opensymphony.xwork2.config.entities
com.opensymphony.xwork2.config.impl
com.opensymphony.xwork2.config.providers
com.opensymphony.xwork2.conversion.annotations
com.opensymphony.xwork2.conversion.metadata
com.opensymphony.xwork2.inject
com.opensymphony.xwork2.inject.util
com.opensymphony.xwork2.interceptor
com.opensymphony.xwork2.interceptor.annotations
com.opensymphony.xwork2.mock
com.opensymphony.xwork2.spring
com.opensymphony.xwork2.spring.interceptor
com.opensymphony.xwork2.util
com.opensymphony.xwork2.util.location
com.opensymphony.xwork2.util.profiling
com.opensymphony.xwork2.validator
com.opensymphony.xwork2.validator.annotations
com.opensymphony.xwork2.validator.metadata
com.opensymphony.xwork2.validator.validators
org.apache.struts2
org.apache.struts2.components
org.apache.struts2.components.table
org.apache.struts2.components.table.renderer
org.apache.struts2.components.template
org.apache.struts2.config
org.apache.struts2.dispatcher
org.apache.struts2.dispatcher.mapper
org.apache.struts2.dispatcher.multipart
org.apache.struts2.impl
org.apache.struts2.interceptor
org.apache.struts2.interceptor.debugging
org.apache.struts2.interceptor.validation
org.apache.struts2.portlet
org.apache.struts2.portlet.context
org.apache.struts2.portlet.dispatcher
org.apache.struts2.portlet.interceptor
org.apache.struts2.portlet.result
org.apache.struts2.portlet.util
org.apache.struts2.servlet.interceptor
org.apache.struts2.util
org.apache.struts2.validators
org.apache.struts2.views
org.apache.struts2.views.annotations
org.apache.struts2.views.freemarker
org.apache.struts2.views.freemarker.tags
org.apache.struts2.views.jsp
org.apache.struts2.views.jsp.iterator
org.apache.struts2.views.jsp.ui
org.apache.struts2.views.jsp.ui.table
org.apache.struts2.views.util
org.apache.struts2.views.velocity
org.apache.struts2.views.velocity.components
org.apache.struts2.views.xslt


Serialized Form (Struts 2 Core 2.0.6 API)

Serialized Form

Package com.opensymphony.xwork2

Class com.opensymphony.xwork2.ActionChainResult extends Object implements Serializable

Serialized Fields

proxy

ActionProxy proxy

actionName

String actionName

namespace

String namespace

methodName

String methodName

skipActions

String skipActions
The list of actions to skip.

actionProxyFactory

ActionProxyFactory actionProxyFactory

Class com.opensymphony.xwork2.ActionContext extends Object implements Serializable

Serialized Fields

context

Map<K,V> context

Class com.opensymphony.xwork2.ActionSupport extends Object implements Serializable

Serialized Fields

validationAware

ValidationAwareSupport validationAware

Class com.opensymphony.xwork2.DefaultActionInvocation extends Object implements Serializable

serialVersionUID: -585293628862447329L

Serialized Fields

action

Object action

proxy

ActionProxy proxy

preResultListeners

List<E> preResultListeners

extraContext

Map<K,V> extraContext

invocationContext

ActionContext invocationContext

interceptors

Iterator<E> interceptors

stack

ValueStack stack

result

Result result

resultCode

String resultCode

executed

boolean executed

pushAction

boolean pushAction

objectFactory

ObjectFactory objectFactory

actionEventListener

ActionEventListener actionEventListener

unknownHandler

UnknownHandler unknownHandler

Class com.opensymphony.xwork2.DefaultActionProxy extends Object implements Serializable

serialVersionUID: 3293074152487468527L

Serialized Fields

configuration

Configuration configuration

config

ActionConfig config

invocation

ActionInvocation invocation

unknownHandler

UnknownHandler unknownHandler

extraContext

Map<K,V> extraContext

actionName

String actionName

namespace

String namespace

method

String method

executeResult

boolean executeResult

cleanupContext

boolean cleanupContext

objectFactory

ObjectFactory objectFactory

actionEventListener

ActionEventListener actionEventListener

Class com.opensymphony.xwork2.DefaultTextProvider extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
                    throws ObjectStreamException
Throws:
ObjectStreamException

Class com.opensymphony.xwork2.InvalidMetadataException extends RuntimeException implements Serializable

Class com.opensymphony.xwork2.MockActionInvocation extends MockActionInvocation implements Serializable

Class com.opensymphony.xwork2.ObjectFactory extends Object implements Serializable

Serialized Fields

container

Container container

Class com.opensymphony.xwork2.ValidationAwareSupport extends Object implements Serializable

Serialized Fields

actionErrors

Collection<E> actionErrors

actionMessages

Collection<E> actionMessages

fieldErrors

Map<K,V> fieldErrors

Class com.opensymphony.xwork2.XWorkException extends RuntimeException implements Serializable

Serialized Fields

location

Location location
Package com.opensymphony.xwork2.config

Class com.opensymphony.xwork2.config.ConfigurationException extends XWorkException implements Serializable

Class com.opensymphony.xwork2.config.ReferenceResolverException extends XWorkException implements Serializable

Package com.opensymphony.xwork2.config.entities

Class com.opensymphony.xwork2.config.entities.ActionConfig extends Located implements Serializable

Serialized Fields

interceptors

List<E> interceptors

params

Map<K,V> params

results

Map<K,V> results

exceptionMappings

List<E> exceptionMappings

className

String className

methodName

String methodName

packageName

String packageName

Class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig extends Located implements Serializable

Serialized Fields

name

String name

exceptionClassName

String exceptionClassName

result

String result

params

Map<K,V> params

Class com.opensymphony.xwork2.config.entities.InterceptorConfig extends Located implements Serializable

Serialized Fields

params

Map<K,V> params

className

String className

name

String name

Class com.opensymphony.xwork2.config.entities.InterceptorMapping extends Object implements Serializable

Serialized Fields

name

String name

interceptor

Interceptor interceptor

Class com.opensymphony.xwork2.config.entities.InterceptorStackConfig extends Located implements Serializable

Serialized Fields

interceptors

List<E> interceptors

name

String name

Class com.opensymphony.xwork2.config.entities.PackageConfig extends Located implements Serializable

Serialized Fields

actionConfigs

Map<K,V> actionConfigs

globalResultConfigs

Map<K,V> globalResultConfigs

interceptorConfigs

Map<K,V> interceptorConfigs

resultTypeConfigs

Map<K,V> resultTypeConfigs

globalExceptionMappingConfigs

List<E> globalExceptionMappingConfigs

parents

List<E> parents

defaultInterceptorRef

String defaultInterceptorRef

defaultActionRef

String defaultActionRef

defaultResultType

String defaultResultType

defaultClassRef

String defaultClassRef

name

String name

namespace

String namespace

isAbstract

boolean isAbstract

Class com.opensymphony.xwork2.config.entities.ResultConfig extends Located implements Serializable

Serialized Fields

params

Map<K,V> params

className

String className

name

String name

Class com.opensymphony.xwork2.config.entities.ResultTypeConfig extends Located implements Serializable

Serialized Fields

clazz

String clazz

name

String name

defaultResultParam

String defaultResultParam

params

Map<K,V> params
Package com.opensymphony.xwork2.config.impl

Class com.opensymphony.xwork2.config.impl.ActionConfigMatcher extends Object implements Serializable

Serialized Fields

compiledPaths

List<E> compiledPaths

The compiled paths and their associated ActionConfig's

Class com.opensymphony.xwork2.config.impl.DefaultConfiguration extends Object implements Serializable

Serialized Fields

packageContexts

Map<K,V> packageContexts

runtimeConfiguration

RuntimeConfiguration runtimeConfiguration

container

Container container

defaultFrameworkBeanName

String defaultFrameworkBeanName

loadedFileNames

Set<E> loadedFileNames

objectFactory

ObjectFactory objectFactory

Class com.opensymphony.xwork2.config.impl.MockConfiguration extends Object implements Serializable

Serialized Fields

packages

Map<K,V> packages

loadedFiles

Set<E> loadedFiles

container

Container container
Package com.opensymphony.xwork2.inject

Class com.opensymphony.xwork2.inject.ContainerBuilder$3 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.ContainerBuilder$4 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.ContainerBuilder$5 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.ContainerBuilder$6 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.ContainerImpl$7 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.ContainerImpl$8 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.ContainerImpl$9 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.DependencyException extends RuntimeException implements Serializable

Class com.opensymphony.xwork2.inject.Scope$2$1 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.Scope$3$1 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.Scope$4$1 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.Scope$5$1 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.Scope$6$1 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.Scope$7 extends Object implements Serializable

Package com.opensymphony.xwork2.inject.util

Class com.opensymphony.xwork2.inject.util.ReferenceCache extends ReferenceMap<K,V> implements Serializable

serialVersionUID: 0L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

Class com.opensymphony.xwork2.inject.util.ReferenceCache$1 extends Object implements Serializable

Class com.opensymphony.xwork2.inject.util.ReferenceMap extends Object implements Serializable

serialVersionUID: 0L

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Throws:
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Throws:
IOException
Serialized Fields

keyReferenceType

ReferenceType keyReferenceType

valueReferenceType

ReferenceType valueReferenceType
Package com.opensymphony.xwork2.interceptor

Class com.opensymphony.xwork2.interceptor.AbstractInterceptor extends Object implements Serializable

Class com.opensymphony.xwork2.interceptor.AliasInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

aliasesKey

String aliasesKey

Class com.opensymphony.xwork2.interceptor.ChainingInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

excludes

Collection<E> excludes

includes

Collection<E> includes

Class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor extends AbstractInterceptor implements Serializable

Class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor extends MethodFilterInterceptor implements Serializable

serialVersionUID: 7563014655616490865L

Serialized Fields

alwaysInvokeValidate

boolean alwaysInvokeValidate

inputResultName

String inputResultName

Class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

categoryLogger

Log categoryLogger

logEnabled

boolean logEnabled

logCategory

String logCategory

logLevel

String logLevel

Class com.opensymphony.xwork2.interceptor.I18nInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

parameterName

String parameterName

attributeName

String attributeName

Class com.opensymphony.xwork2.interceptor.LoggingInterceptor extends AbstractInterceptor implements Serializable

Class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

excludeMethods

Set<E> excludeMethods

includeMethods

Set<E> includeMethods

Class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor extends AbstractInterceptor implements Serializable

Class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

allowed

Collection<E> allowed

blocked

Collection<E> blocked

includesExcludesMap

Map<K,V> includesExcludesMap

defaultBlock

boolean defaultBlock

Class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor extends AbstractInterceptor implements Serializable

serialVersionUID: 1L

Serialized Fields

paramNames

Set<E> paramNames

paramValues

Set<E> paramValues

Class com.opensymphony.xwork2.interceptor.ParametersInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

ordered

boolean ordered

excludeParams

Set<E> excludeParams

Class com.opensymphony.xwork2.interceptor.PrepareInterceptor extends AbstractInterceptor implements Serializable

serialVersionUID: -5216969014510719786L

Serialized Fields

alwaysInvokePrepare

boolean alwaysInvokePrepare

Class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

scope

String scope

name

String name

className

String className

objectFactory

ObjectFactory objectFactory

Class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

parse

boolean parse

Class com.opensymphony.xwork2.interceptor.TimerInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

categoryLogger

Log categoryLogger

logCategory

String logCategory

logLevel

String logLevel
Package com.opensymphony.xwork2.interceptor.annotations

Class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor extends Object implements Serializable

Package com.opensymphony.xwork2.mock

Class com.opensymphony.xwork2.mock.MockActionInvocation extends Object implements Serializable

Serialized Fields

action

Object action

invocationContext

ActionContext invocationContext

actionEventListener

ActionEventListener actionEventListener

proxy

ActionProxy proxy

result

Result result

resultCode

String resultCode

stack

ValueStack stack

preResultListeners

List<E> preResultListeners

Class com.opensymphony.xwork2.mock.MockInterceptor extends Object implements Serializable

Serialized Fields

expectedFoo

String expectedFoo

foo

String foo

executed

boolean executed

Class com.opensymphony.xwork2.mock.MockResult extends Object implements Serializable

Package com.opensymphony.xwork2.spring

Class com.opensymphony.xwork2.spring.SpringObjectFactory extends ObjectFactory implements Serializable

Serialized Fields

appContext

ApplicationContext appContext

autoWiringFactory

AutowireCapableBeanFactory autoWiringFactory

autowireStrategy

int autowireStrategy

classes

Map<K,V> classes

useClassCache

boolean useClassCache

Class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory extends SpringObjectFactory implements Serializable

Serialized Fields

skipBeanNames

List<E> skipBeanNames
Package com.opensymphony.xwork2.spring.interceptor

Class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

initialized

boolean initialized

context

ApplicationContext context

factory

SpringObjectFactory factory

autowireStrategy

Integer autowireStrategy
Package com.opensymphony.xwork2.util

Class com.opensymphony.xwork2.util.CompoundRoot extends ArrayList implements Serializable

Class com.opensymphony.xwork2.util.OgnlValueStack extends Object implements Serializable

serialVersionUID: 370737852934925530L

Serialization Methods

readResolve

private Object readResolve()
Serialized Fields

root

CompoundRoot root

defaultType

Class<T> defaultType

overrides

Map<K,V> overrides

Class com.opensymphony.xwork2.util.TypeConversionException extends XWorkException implements Serializable

Class com.opensymphony.xwork2.util.XWorkList extends ArrayList implements Serializable

Serialized Fields

clazz

Class<T> clazz
Deprecated.

Class com.opensymphony.xwork2.util.XWorkMap extends HashMap implements Serializable

Serialized Fields

clazz

Class<T> clazz
Deprecated.
Package com.opensymphony.xwork2.util.location

Class com.opensymphony.xwork2.util.location.LocatableProperties extends Properties implements Serializable

Serialized Fields

location

Location location

propLocations

Map<K,V> propLocations

Class com.opensymphony.xwork2.util.location.LocationImpl extends Object implements Serializable

Serialization Methods

readResolve

private Object readResolve()
Ensure serialized unknown location resolve to Location.UNKNOWN.

Serialized Fields

uri

String uri

line

int line

column

int column

description

String description
Package com.opensymphony.xwork2.util.profiling

Class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean extends Object implements Serializable

serialVersionUID: -6180672043920208784L

Serialized Fields

children

List<E> children

parent

ProfilingTimerBean parent

resource

String resource

startTime

long startTime

totalTime

long totalTime
Package com.opensymphony.xwork2.validator

Class com.opensymphony.xwork2.validator.ValidationException extends Exception implements Serializable

Class com.opensymphony.xwork2.validator.ValidationInterceptor extends MethodFilterInterceptor implements Serializable

Serialized Fields

validateAnnotatedMethodOnly

boolean validateAnnotatedMethodOnly
Package org.apache.struts2

Class org.apache.struts2.ServletActionContext extends ActionContext implements Serializable

serialVersionUID: -666854718275106687L

Class org.apache.struts2.StrutsException extends XWorkException implements Serializable

serialVersionUID: 888724366243600135L

Package org.apache.struts2.components.table

Class org.apache.struts2.components.table.AbstractFilterModel extends AbstractTableModel implements Serializable

Serialized Fields

model

TableModel model

Class org.apache.struts2.components.table.RenderFilterModel extends AbstractFilterModel implements Serializable

serialVersionUID: -2501708467650344057L

Serialized Fields

rendered

boolean rendered

Class org.apache.struts2.components.table.SortFilterModel extends AbstractFilterModel implements Serializable

serialVersionUID: 2214225803442793597L

Serialized Fields

rows

ArrayList<E> rows

_sortDirection

String _sortDirection
These are just here to implement the interface

dirty

boolean dirty

sortColumn

int sortColumn
Package org.apache.struts2.config

Class org.apache.struts2.config.NullResult extends Object implements Serializable

Package org.apache.struts2.dispatcher

Class org.apache.struts2.dispatcher.ApplicationMap extends AbstractMap implements Serializable

serialVersionUID: 9136809763083228202L

Serialized Fields

context

ServletContext context

entries

Set<E> entries

Class org.apache.struts2.dispatcher.DefaultActionSupport extends ActionSupport implements Serializable

serialVersionUID: -2426166391283746095L

Serialized Fields

successResultValue

String successResultValue

Class org.apache.struts2.dispatcher.HttpHeaderResult extends Object implements Serializable

serialVersionUID: 195648957144219214L

Serialized Fields

parse

boolean parse

headers

Map<K,V> headers

status

int status

Class org.apache.struts2.dispatcher.PlainTextResult extends StrutsResultSupport implements Serializable

serialVersionUID: 3633371605905583950L

Serialized Fields

charSet

String charSet

Class org.apache.struts2.dispatcher.RequestMap extends AbstractMap implements Serializable

serialVersionUID: -7675640869293787926L

Serialized Fields

entries

Set<E> entries

request

HttpServletRequest request

Class org.apache.struts2.dispatcher.ServletActionRedirectResult extends ServletRedirectResult implements Serializable

serialVersionUID: -9042425229314584066L

Serialized Fields

actionName

String actionName

namespace

String namespace

method

String method

requestParameters

Map<K,V> requestParameters

prohibitedResultParam

List<E> prohibitedResultParam

Class org.apache.struts2.dispatcher.ServletDispatcherResult extends StrutsResultSupport implements Serializable

serialVersionUID: -1970659272360685627L

Class org.apache.struts2.dispatcher.ServletRedirectResult extends StrutsResultSupport implements Serializable

serialVersionUID: 6316947346435301270L

Serialized Fields

prependServletContext

boolean prependServletContext

actionMapper

ActionMapper actionMapper

Class org.apache.struts2.dispatcher.SessionMap extends AbstractMap implements Serializable

serialVersionUID: 4678843241638046854L

Serialized Fields

session

HttpSession session

entries

Set<E> entries

request

HttpServletRequest request

Class org.apache.struts2.dispatcher.StreamResult extends StrutsResultSupport implements Serializable

serialVersionUID: -1468409635999059850L

Serialized Fields

contentType

String contentType

contentLength

String contentLength

contentDisposition

String contentDisposition

inputName

String inputName

inputStream

InputStream inputStream

bufferSize

int bufferSize

Class org.apache.struts2.dispatcher.StrutsResultSupport extends Object implements Serializable

Serialized Fields

parse

boolean parse

encode

boolean encode

location

String location

lastFinalLocation

String lastFinalLocation

Class org.apache.struts2.dispatcher.VelocityResult extends StrutsResultSupport implements Serializable

serialVersionUID: 7268830767762559424L

Serialized Fields

defaultEncoding

String defaultEncoding

velocityManager

VelocityManager velocityManager
Package org.apache.struts2.impl

Class org.apache.struts2.impl.StrutsActionProxy extends DefaultActionProxy implements Serializable

serialVersionUID: -2434901249671934080L

Class org.apache.struts2.impl.StrutsObjectFactory extends ObjectFactory implements Serializable

Package org.apache.struts2.interceptor

Class org.apache.struts2.interceptor.BackgroundProcess extends Object implements Serializable

serialVersionUID: 3884464776311686443L

Serialized Fields

action

Object action

invocation

ActionInvocation invocation

result

String result

exception

Exception exception

done

boolean done

Class org.apache.struts2.interceptor.CheckboxInterceptor extends Object implements Serializable

serialVersionUID: -586878104807229585L

Serialized Fields

uncheckedValue

String uncheckedValue

Class org.apache.struts2.interceptor.CreateSessionInterceptor extends AbstractInterceptor implements Serializable

serialVersionUID: -4590322556118858869L

Class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor extends MethodFilterInterceptor implements Serializable

serialVersionUID: -2754639196749652512L

Serialized Fields

delay

int delay

delaySleepInterval

int delaySleepInterval

executeAfterValidationPass

boolean executeAfterValidationPass

threadPriority

int threadPriority

Class org.apache.struts2.interceptor.FileUploadInterceptor extends AbstractInterceptor implements Serializable

serialVersionUID: -4764627478894962478L

Serialized Fields

maximumSize

Long maximumSize

allowedTypes

String allowedTypes

allowedTypesSet

Set<E> allowedTypesSet

Class org.apache.struts2.interceptor.MessageStoreInterceptor extends Object implements Serializable

serialVersionUID: 4491997514314242420L

Serialized Fields

allowRequestParameterSwitch

boolean allowRequestParameterSwitch

requestParameterSwitch

String requestParameterSwitch

operationMode

String operationMode

Class org.apache.struts2.interceptor.ProfilingActivationInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

profilingKey

String profilingKey

devMode

boolean devMode

Class org.apache.struts2.interceptor.RolesInterceptor extends AbstractInterceptor implements Serializable

Serialized Fields

allowedRoles

List<E> allowedRoles

disallowedRoles

List<E> disallowedRoles

Class org.apache.struts2.interceptor.ScopeInterceptor extends AbstractInterceptor implements Serializable

serialVersionUID: 9120762699600054395L

Serialized Fields

application

String[] application

session

String[] session

key

String key

type

String type

autoCreateSession

boolean autoCreateSession

sessionReset

String sessionReset

reset

boolean reset

Class org.apache.struts2.interceptor.ServletConfigInterceptor extends AbstractInterceptor implements Serializable

serialVersionUID: 605261777858676638L

Class org.apache.struts2.interceptor.StrutsConversionErrorInterceptor extends ConversionErrorInterceptor implements Serializable

serialVersionUID: 2759744840082921602L

Class org.apache.struts2.interceptor.TokenInterceptor extends MethodFilterInterceptor implements Serializable

serialVersionUID: -6680894220590585506L

Class org.apache.struts2.interceptor.TokenSessionStoreInterceptor extends TokenInterceptor implements Serializable

serialVersionUID: -9032347965469098195L

Package org.apache.struts2.interceptor.debugging

Class org.apache.struts2.interceptor.debugging.DebuggingInterceptor extends Object implements Serializable

serialVersionUID: -3097324155953078783L

Serialized Fields

ignorePrefixes

String[] ignorePrefixes

_ignoreKeys

String[] _ignoreKeys

ignoreKeys

HashSet<E> ignoreKeys

enableXmlWithConsole

boolean enableXmlWithConsole

devMode

boolean devMode

freemarkerManager

FreemarkerManager freemarkerManager

consoleEnabled

boolean consoleEnabled
Package org.apache.struts2.interceptor.validation

Class org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor extends ValidationInterceptor implements Serializable

serialVersionUID: 1813272797367431184L

Package org.apache.struts2.portlet

Class org.apache.struts2.portlet.PortletApplicationMap extends AbstractMap implements Serializable

serialVersionUID: 2296107511063504414L

Serialized Fields

context

javax.portlet.PortletContext context

entries

Set<E> entries
Package org.apache.struts2.portlet.context

Class org.apache.struts2.portlet.context.PreparatorServlet extends HttpServlet implements Serializable

serialVersionUID: 1853399729352984089L

Package org.apache.struts2.portlet.dispatcher

Class org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction extends Object implements Serializable

serialVersionUID: -1814807772308405785L

Serialized Fields

location

String location
Package org.apache.struts2.portlet.interceptor

Class org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor extends AbstractInterceptor implements Serializable

Package org.apache.struts2.portlet.result

Class org.apache.struts2.portlet.result.PortletResult extends StrutsResultSupport implements Serializable

serialVersionUID: 434251393926178567L

Serialized Fields

contentType

String contentType

title

String title

Class org.apache.struts2.portlet.result.PortletVelocityResult extends StrutsResultSupport implements Serializable

serialVersionUID: -8241086555872212274L

Serialized Fields

defaultEncoding

String defaultEncoding

velocityManager

VelocityManager velocityManager
Package org.apache.struts2.util

Class org.apache.struts2.util.Counter extends Object implements Serializable

serialVersionUID: 2796965884308060179L

Serialized Fields

wrap

boolean wrap

first

long first

current

long current

interval

long interval

last

long last
Package org.apache.struts2.validators

Class org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation extends DefaultActionInvocation implements Serializable

serialVersionUID: -7645433725470191275L

Class org.apache.struts2.validators.DWRValidator.ValidatorActionProxy extends DefaultActionProxy implements Serializable

serialVersionUID: 5754781916414047963L

Package org.apache.struts2.views

Class org.apache.struts2.views.JspSupportServlet extends HttpServlet implements Serializable

serialVersionUID: 8302309812391541933L

Package org.apache.struts2.views.freemarker

Class org.apache.struts2.views.freemarker.FreemarkerResult extends StrutsResultSupport implements Serializable

serialVersionUID: -3778230771704661631L

Serialized Fields

invocation

ActionInvocation invocation

configuration

freemarker.template.Configuration configuration

wrapper

freemarker.template.ObjectWrapper wrapper

freemarkerManager

FreemarkerManager freemarkerManager

writer

Writer writer

location

String location

pContentType

String pContentType

Class org.apache.struts2.views.freemarker.PortletFreemarkerResult extends StrutsResultSupport implements Serializable

serialVersionUID: -5570612389289887543L

Serialized Fields

invocation

ActionInvocation invocation

configuration

freemarker.template.Configuration configuration

wrapper

freemarker.template.ObjectWrapper wrapper

freemarkerManager

FreemarkerManager freemarkerManager

location

String location

pContentType

String pContentType

Class org.apache.struts2.views.freemarker.ScopesHashModel extends freemarker.template.SimpleHash implements Serializable

serialVersionUID: 5551686380141886764L

Serialized Fields

request

HttpServletRequest request

servletContext

ServletContext servletContext

stack

ValueStack stack
Package org.apache.struts2.views.jsp

Class org.apache.struts2.views.jsp.ActionTag extends ComponentTagSupport implements Serializable

serialVersionUID: -5384167073331678855L

Serialized Fields

name

String name

namespace

String namespace

executeResult

boolean executeResult

ignoreContextParams

boolean ignoreContextParams

flush

boolean flush

Class org.apache.struts2.views.jsp.BeanTag extends ComponentTagSupport implements Serializable

serialVersionUID: -3863152522071209267L

Serialized Fields

name

String name

Class org.apache.struts2.views.jsp.ComponentTagSupport extends StrutsBodyTagSupport implements Serializable

Serialized Fields

component

Component component

Class org.apache.struts2.views.jsp.DateTag extends ComponentTagSupport implements Serializable

serialVersionUID: -6216963123295613440L

Serialized Fields

name

String name

format

String format

nice

boolean nice

Class org.apache.struts2.views.jsp.ElseIfTag extends ComponentTagSupport implements Serializable

serialVersionUID: -3872016920741400345L

Serialized Fields

test

String test

Class org.apache.struts2.views.jsp.ElseTag extends ComponentTagSupport implements Serializable

serialVersionUID: 8166807953193406785L

Class org.apache.struts2.views.jsp.I18nTag extends ComponentTagSupport implements Serializable

serialVersionUID: -7914587341936116887L

Serialized Fields

name

String name

Class org.apache.struts2.views.jsp.IfTag extends ComponentTagSupport implements Serializable

serialVersionUID: 4448870162549923833L

Serialized Fields

test

String test

Class org.apache.struts2.views.jsp.IncludeTag extends ComponentTagSupport implements Serializable

serialVersionUID: -1585165567043278243L

Serialized Fields

value

String value

Class org.apache.struts2.views.jsp.IteratorTag extends ComponentTagSupport implements Serializable

serialVersionUID: -1827978135193581901L

Serialized Fields

statusAttr

String statusAttr

value

String value

Class org.apache.struts2.views.jsp.ParamTag extends ComponentTagSupport implements Serializable

serialVersionUID: -968332732207156408L

Serialized Fields

name

String name

value

String value

Class org.apache.struts2.views.jsp.PropertyTag extends ComponentTagSupport implements Serializable

serialVersionUID: 435308349113743852L

Serialized Fields

defaultValue

String defaultValue

value

String value

escape

boolean escape

Class org.apache.struts2.views.jsp.PushTag extends ComponentTagSupport implements Serializable

serialVersionUID: -1357895305148907931L

Serialized Fields

value

String value

Class org.apache.struts2.views.jsp.SetTag extends ComponentTagSupport implements Serializable

serialVersionUID: -5074213926790716974L

Serialized Fields

name

String name

scope

String scope

value

String value

Class org.apache.struts2.views.jsp.StrutsBodyTagSupport extends BodyTagSupport implements Serializable

serialVersionUID: -1201668454354226175L

Class org.apache.struts2.views.jsp.TextTag extends ComponentTagSupport implements Serializable

serialVersionUID: -3075088084198264581L

Serialized Fields

name

String name

Class org.apache.struts2.views.jsp.URLTag extends ComponentTagSupport implements Serializable

serialVersionUID: 1722460444125206226L

Serialized Fields

includeParams

String includeParams

scheme

String scheme

value

String value

action

String action

namespace

String namespace

method

String method

encode

String encode

includeContext

String includeContext

portletMode

String portletMode

windowState

String windowState

portletUrlType

String portletUrlType

anchor

String anchor
Package org.apache.struts2.views.jsp.iterator

Class org.apache.struts2.views.jsp.iterator.AppendIteratorTag extends ComponentTagSupport implements Serializable

serialVersionUID: -6017337859763283691L

Class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag extends StrutsBodyTagSupport implements Serializable

serialVersionUID: 2968037295463973936L

Serialized Fields

countAttr

String countAttr

separatorAttr

String separatorAttr

valueAttr

String valueAttr

converterAttr

String converterAttr

iteratorGenerator

IteratorGenerator iteratorGenerator

Class org.apache.struts2.views.jsp.iterator.MergeIteratorTag extends ComponentTagSupport implements Serializable

serialVersionUID: 4999729472466011218L

Class org.apache.struts2.views.jsp.iterator.SortIteratorTag extends StrutsBodyTagSupport implements Serializable

serialVersionUID: -7835719609764092235L

Serialized Fields

comparatorAttr

String comparatorAttr

sourceAttr

String sourceAttr

sortIteratorFilter

SortIteratorFilter sortIteratorFilter

Class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag extends StrutsBodyTagSupport implements Serializable

serialVersionUID: -6252696081713080102L

Serialized Fields

countAttr

String countAttr

sourceAttr

String sourceAttr

startAttr

String startAttr

deciderAttr

String deciderAttr

subsetIteratorFilter

SubsetIteratorFilter subsetIteratorFilter
Package org.apache.struts2.views.jsp.ui

Class org.apache.struts2.views.jsp.ui.AbstractClosingTag extends AbstractUITag implements Serializable

Serialized Fields

openTemplate

String openTemplate

Class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag extends AbstractRequiredListTag implements Serializable

Serialized Fields

doubleList

String doubleList

doubleListKey

String doubleListKey

doubleListValue

String doubleListValue

doubleName

String doubleName

doubleValue

String doubleValue

formName

String formName

emptyOption

String emptyOption

headerKey

String headerKey

headerValue

String headerValue

multiple

String multiple

size

String size

doubleId

String doubleId

doubleDisabled

String doubleDisabled

doubleMultiple

String doubleMultiple

doubleSize

String doubleSize

doubleHeaderKey

String doubleHeaderKey

doubleHeaderValue

String doubleHeaderValue

doubleEmptyOption

String doubleEmptyOption

doubleCssClass

String doubleCssClass

doubleCssStyle

String doubleCssStyle

doubleOnclick

String doubleOnclick

doubleOndblclick

String doubleOndblclick

doubleOnmousedown

String doubleOnmousedown

doubleOnmouseup

String doubleOnmouseup

doubleOnmouseover

String doubleOnmouseover

doubleOnmousemove

String doubleOnmousemove

doubleOnmouseout

String doubleOnmouseout

doubleOnfocus

String doubleOnfocus

doubleOnblur

String doubleOnblur

doubleOnkeypress

String doubleOnkeypress

doubleOnkeydown

String doubleOnkeydown

doubleOnkeyup

String doubleOnkeyup

doubleOnselect

String doubleOnselect

doubleOnchange

String doubleOnchange

doubleAccesskey

String doubleAccesskey

Class org.apache.struts2.views.jsp.ui.AbstractListTag extends AbstractUITag implements Serializable

Serialized Fields

list

String list

listKey

String listKey

listValue

String listValue

Class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag extends AbstractClosingTag implements Serializable

Serialized Fields

href

String href

listenTopics

String listenTopics

notifyTopics

String notifyTopics

loadingText

String loadingText

errorText

String errorText

beforeLoading

String beforeLoading

afterLoading

String afterLoading

executeScripts

String executeScripts

handler

String handler

formId

String formId

formFilter

String formFilter

showErrorTransportText

String showErrorTransportText

indicator

String indicator

showLoadingText

String showLoadingText

Class org.apache.struts2.views.jsp.ui.AbstractRequiredListTag extends AbstractListTag implements Serializable

Class org.apache.struts2.views.jsp.ui.AbstractUITag extends ComponentTagSupport implements Serializable

Serialized Fields

cssClass

String cssClass

cssStyle

String cssStyle

title

String title

disabled

String disabled

label

String label

labelPosition

String labelPosition

requiredposition

String requiredposition

name

String name

required

String required

tabindex

String tabindex

value

String value

template

String template

theme

String theme

templateDir

String templateDir

onclick

String onclick

ondblclick

String ondblclick

onmousedown

String onmousedown

onmouseup

String onmouseup

onmouseover

String onmouseover

onmousemove

String onmousemove

onmouseout

String onmouseout

onfocus

String onfocus

onblur

String onblur

onkeypress

String onkeypress

onkeydown

String onkeydown

onkeyup

String onkeyup

onselect

String onselect

onchange

String onchange

accesskey

String accesskey

key

String key

tooltip

String tooltip

tooltipConfig

String tooltipConfig

Class org.apache.struts2.views.jsp.ui.ActionErrorTag extends AbstractUITag implements Serializable

serialVersionUID: -3710234378022378639L

Class org.apache.struts2.views.jsp.ui.ActionMessageTag extends AbstractUITag implements Serializable

serialVersionUID: 243396927554182506L

Class org.apache.struts2.views.jsp.ui.AnchorTag extends AbstractRemoteCallUITag implements Serializable

serialVersionUID: -1034616578492431113L

Serialized Fields

targets

String targets

preInvokeJS

String preInvokeJS

Class org.apache.struts2.views.jsp.ui.AutocompleterTag extends ComboBoxTag implements Serializable

serialVersionUID: -1112470447573172581L

Serialized Fields

forceValidOption

String forceValidOption

searchType

String searchType

autoComplete

String autoComplete

delay

String delay

disabled

String disabled

href

String href

dropdownWidth

String dropdownWidth

dropdownHeight

String dropdownHeight

formId

String formId

formFilter

String formFilter

listenTopics

String listenTopics

notifyTopics

String notifyTopics

indicator

String indicator

loadOnTextChange

String loadOnTextChange

loadMinimumCount

String loadMinimumCount

showDownArrow

String showDownArrow

templateCssPath

String templateCssPath

iconPath

String iconPath

keyName

String keyName

Class org.apache.struts2.views.jsp.ui.CheckboxListTag extends AbstractRequiredListTag implements Serializable

serialVersionUID: 4023034029558150010L

Class org.apache.struts2.views.jsp.ui.CheckboxTag extends AbstractUITag implements Serializable

serialVersionUID: -350752809266337636L

Serialized Fields

fieldValue

String fieldValue

Class org.apache.struts2.views.jsp.ui.ComboBoxTag extends TextFieldTag implements Serializable

serialVersionUID: 3509392460170385605L

Serialized Fields

list

String list

listKey

String listKey

listValue

String listValue

headerKey

String headerKey

headerValue

String headerValue

emptyOption

String emptyOption

Class org.apache.struts2.views.jsp.ui.ComponentTag extends AbstractUITag implements Serializable

serialVersionUID: 5448365363044104731L

Class org.apache.struts2.views.jsp.ui.DateTimePickerTag extends AbstractUITag implements Serializable

serialVersionUID: 4054114507143447232L

Serialized Fields

displayWeeks

String displayWeeks

adjustWeeks

String adjustWeeks

startDate

String startDate

endDate

String endDate

weekStartsOn

String weekStartsOn

staticDisplay

String staticDisplay

dayWidth

String dayWidth

language

String language

iconPath

String iconPath

formatLength

String formatLength

displayFormat

String displayFormat

toggleType

String toggleType

toggleDuration

String toggleDuration

type

String type

templateCssPath

String templateCssPath

Class org.apache.struts2.views.jsp.ui.DebugTag extends AbstractUITag implements Serializable

serialVersionUID: 3487684841317160628L

Class org.apache.struts2.views.jsp.ui.DivTag extends AbstractRemoteCallUITag implements Serializable

serialVersionUID: 5309231035916461758L

Serialized Fields

updateFreq

String updateFreq

autoStart

String autoStart

delay

String delay

startTimerListenTopics

String startTimerListenTopics

stopTimerListenTopics

String stopTimerListenTopics

refreshOnShow

String refreshOnShow

Class org.apache.struts2.views.jsp.ui.DoubleSelectTag extends AbstractDoubleListTag implements Serializable

serialVersionUID: 7426011596359509386L

Class org.apache.struts2.views.jsp.ui.FieldErrorTag extends AbstractUITag implements Serializable

serialVersionUID: -182532967507726323L

Class org.apache.struts2.views.jsp.ui.FileTag extends AbstractUITag implements Serializable

serialVersionUID: -2154950640215144864L

Serialized Fields

accept

String accept

size

String size

Class org.apache.struts2.views.jsp.ui.FormTag extends AbstractClosingTag implements Serializable

serialVersionUID: 2792301046860819658L

Serialized Fields

action

String action

target

String target

enctype

String enctype

method

String method

namespace

String namespace

validate

String validate

onsubmit

String onsubmit

portletMode

String portletMode

windowState

String windowState

acceptcharset

String acceptcharset

Class org.apache.struts2.views.jsp.ui.HeadTag extends AbstractUITag implements Serializable

serialVersionUID: 6876765769175246030L

Serialized Fields

calendarcss

String calendarcss

debug

String debug

Class org.apache.struts2.views.jsp.ui.HiddenTag extends AbstractUITag implements Serializable

serialVersionUID: -1124367972048371675L

Class org.apache.struts2.views.jsp.ui.InputTransferSelectTag extends AbstractListTag implements Serializable

serialVersionUID: 250474334495763536L

Serialized Fields

size

String size

multiple

String multiple

allowRemoveAll

String allowRemoveAll

allowUpDown

String allowUpDown

leftTitle

String leftTitle

rightTitle

String rightTitle

buttonCssClass

String buttonCssClass

buttonCssStyle

String buttonCssStyle

addLabel

String addLabel

removeLabel

String removeLabel

removeAllLabel

String removeAllLabel

upLabel

String upLabel

downLabel

String downLabel

headerKey

String headerKey

headerValue

String headerValue

Class org.apache.struts2.views.jsp.ui.LabelTag extends AbstractUITag implements Serializable

serialVersionUID: 4008321310097730458L

Serialized Fields

forAttr

String forAttr

Class org.apache.struts2.views.jsp.ui.OptGroupTag extends ComponentTagSupport implements Serializable

serialVersionUID: 7367401003498678762L

Serialized Fields

list

String list

label

String label

disabled

String disabled

listKey

String listKey

listValue

String listValue

Class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag extends AbstractDoubleListTag implements Serializable

serialVersionUID: 250474334495763536L

Serialized Fields

allowAddToLeft

String allowAddToLeft

allowAddToRight

String allowAddToRight

allowAddAllToLeft

String allowAddAllToLeft

allowAddAllToRight

String allowAddAllToRight

allowSelectAll

String allowSelectAll

allowUpDownOnLeft

String allowUpDownOnLeft

allowUpDownOnRight

String allowUpDownOnRight

leftTitle

String leftTitle

rightTitle

String rightTitle

buttonCssClass

String buttonCssClass

buttonCssStyle

String buttonCssStyle

addToLeftLabel

String addToLeftLabel

addToRightLabel

String addToRightLabel

addAllToLeftLabel

String addAllToLeftLabel

addAllToRightLabel

String addAllToRightLabel

selectAllLabel

String selectAllLabel

leftUpLabel

String leftUpLabel

leftDownLabel

String leftDownLabel

rightUpLabel

String rightUpLabel

rightDownLabel

String rightDownLabel

Class org.apache.struts2.views.jsp.ui.PasswordTag extends TextFieldTag implements Serializable

serialVersionUID: 6802043323617377573L

Serialized Fields

showPassword

String showPassword

Class org.apache.struts2.views.jsp.ui.RadioTag extends AbstractRequiredListTag implements Serializable

serialVersionUID: -6497403399521333624L

Class org.apache.struts2.views.jsp.ui.ResetTag extends AbstractUITag implements Serializable

serialVersionUID: 4742704832277392108L

Serialized Fields

action

String action

method

String method

align

String align

type

String type

Class org.apache.struts2.views.jsp.ui.SelectTag extends AbstractRequiredListTag implements Serializable

serialVersionUID: 6121715260335609618L

Serialized Fields

emptyOption

String emptyOption

headerKey

String headerKey

headerValue

String headerValue

multiple

String multiple

size

String size

Class org.apache.struts2.views.jsp.ui.SubmitTag extends AbstractUITag implements Serializable

serialVersionUID: 2179281109958301343L

Serialized Fields

action

String action

method

String method

align

String align

type

String type

href

String href

listenTopics

String listenTopics

notifyTopics

String notifyTopics

loadingText

String loadingText

errorText

String errorText

executeScripts

String executeScripts

handler

String handler

formId

String formId

formFilter

String formFilter

src

String src

showErrorTransportText

String showErrorTransportText

indicator

String indicator

showLoadingText

String showLoadingText

beforeLoading

String beforeLoading

afterLoading

String afterLoading

targets

String targets

Class org.apache.struts2.views.jsp.ui.TabbedPanelTag extends AbstractClosingTag implements Serializable

serialVersionUID: -4719930205515386252L

Serialized Fields

selectedTab

String selectedTab

closeButton

String closeButton

doLayout

String doLayout

templateCssPath

String templateCssPath

Class org.apache.struts2.views.jsp.ui.TextareaTag extends AbstractUITag implements Serializable

serialVersionUID: -4107122506712927927L

Serialized Fields

cols

String cols

readonly

String readonly

rows

String rows

wrap

String wrap

Class org.apache.struts2.views.jsp.ui.TextFieldTag extends AbstractUITag implements Serializable

serialVersionUID: 5811285953670562288L

Serialized Fields

maxlength

String maxlength

readonly

String readonly

size

String size

Class org.apache.struts2.views.jsp.ui.TokenTag extends AbstractUITag implements Serializable

serialVersionUID: 722480798151703457L

Class org.apache.struts2.views.jsp.ui.TreeNodeTag extends AbstractClosingTag implements Serializable

serialVersionUID: 7340746943017900803L

Class org.apache.struts2.views.jsp.ui.TreeTag extends AbstractClosingTag implements Serializable

serialVersionUID: 2735218501058548013L

Serialized Fields

toggle

String toggle

treeSelectedTopic

String treeSelectedTopic

treeExpandedTopic

String treeExpandedTopic

treeCollapsedTopic

String treeCollapsedTopic

rootNode

String rootNode

childCollectionProperty

String childCollectionProperty

nodeTitleProperty

String nodeTitleProperty

nodeIdProperty

String nodeIdProperty

showRootGrid

String showRootGrid

showGrid

String showGrid

blankIconSrc

String blankIconSrc

gridIconSrcL

String gridIconSrcL

gridIconSrcV

String gridIconSrcV

gridIconSrcP

String gridIconSrcP

gridIconSrcC

String gridIconSrcC

gridIconSrcX

String gridIconSrcX

gridIconSrcY

String gridIconSrcY

expandIconSrcPlus

String expandIconSrcPlus

expandIconSrcMinus

String expandIconSrcMinus

iconWidth

String iconWidth

iconHeight

String iconHeight

toggleDuration

String toggleDuration

templateCssPath

String templateCssPath

Class org.apache.struts2.views.jsp.ui.UpDownSelectTag extends SelectTag implements Serializable

serialVersionUID: -8136573053799541353L

Serialized Fields

allowMoveUp

String allowMoveUp

allowMoveDown

String allowMoveDown

allowSelectAll

String allowSelectAll

moveUpLabel

String moveUpLabel

moveDownLabel

String moveDownLabel

selectAllLabel

String selectAllLabel
Package org.apache.struts2.views.jsp.ui.table

Class org.apache.struts2.views.jsp.ui.table.WebTableTag extends ComponentTag implements Serializable

serialVersionUID: 2978932111492397942L

Serialized Fields

sortOrder

String sortOrder

modelName

String modelName

sortable

boolean sortable

sortColumn

int sortColumn
Package org.apache.struts2.views.velocity

Class org.apache.struts2.views.velocity.StrutsVelocityContext extends org.apache.velocity.VelocityContext implements Serializable

serialVersionUID: 8497212428904436963L

Serialized Fields

stack

ValueStack stack

chainedContexts

org.apache.velocity.VelocityContext[] chainedContexts
Package org.apache.struts2.views.xslt

Class org.apache.struts2.views.xslt.XSLTResult extends Object implements Serializable

serialVersionUID: 6424691441777176763L

Serialized Fields

noCache

boolean noCache
Determines whether or not the result should allow caching.

stylesheetLocation

String stylesheetLocation
Indicates the location of the xsl template.

matchingPattern

String matchingPattern
Indicates the property name patterns which should be exposed to the xml.

exludingPattern

String exludingPattern
Indicates the property name patterns which should be excluded from the xml.

exposedValue

String exposedValue
Indicates the ognl expression respresenting the bean which is to be exposed as xml.

parse

boolean parse

adapterFactory

AdapterFactory adapterFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2 (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2
Interfaces
Action
ActionEventListener
ActionInvocation
ActionProxy
ActionProxyFactory
LocaleProvider
ModelDriven
Preparable
Result
TextProvider
Unchainable
UnknownHandler
Validateable
ValidationAware
XWorkMessages
Classes
ActionChainResult
ActionContext
ActionContext.ActionContextThreadLocal
ActionSupport
DefaultActionInvocation
DefaultActionProxy
DefaultActionProxyFactory
DefaultTextProvider
MockActionInvocation
ObjectFactory
ObjectFactory.ContinuationsClassLoader
TestNGXWorkTestCase
TextProviderFactory
TextProviderSupport
ValidationAwareSupport
XWorkTestCase
Exceptions
InvalidMetadataException
XWorkException


Uses of Interface com.opensymphony.xwork2.Action (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.Action

Packages that use Action
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.util | Miscellaneous helper classes.

Uses of Action in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Action
 class ActionSupport
Provides a default implementation for the most common actions.

Uses of Action in org.apache.struts2.dispatcher

Classes in org.apache.struts2.dispatcher that implement Action
 class DefaultActionSupport
A simple action support class that sets properties to be able to serve

Uses of Action in org.apache.struts2.portlet.dispatcher

Classes in org.apache.struts2.portlet.dispatcher that implement Action
 class DirectRenderFromEventAction
When a portlet is targetted for an event, the portlet will receive two portlet requests, one for the event phase, and then followed by a render operation.

Uses of Action in org.apache.struts2.util

Classes in org.apache.struts2.util that implement Action
class | AppendIteratorFilter A bean that takes several iterators and outputs them in sequence
class | IteratorGenerator A bean that generates an iterator filled with a given object depending on the count, separator and converter defined.
class | MergeIteratorFilter A bean that takes several iterators and outputs the merge of them.
class | SortIteratorFilter A bean that takes a source and comparator then attempt to sort the source utilizing the comparator.
class | SubsetIteratorFilter A bean that takes an iterator and outputs a subset of it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ActionChainResult (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.ActionChainResult

No usage of com.opensymphony.xwork2.ActionChainResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ActionContext (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.ActionContext

Packages that use ActionContext
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.portlet.context |

Uses of ActionContext in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ActionContext
protected  ActionContext DefaultActionInvocation.invocationContext

Methods in com.opensymphony.xwork2 that return ActionContext
static ActionContext | ActionContext.getContext() Returns the ActionContext specific to the current thread.
ActionContext | ActionInvocation.getInvocationContext() Gets the ActionContext associated with this ActionInvocation.
ActionContext | DefaultActionInvocation.getInvocationContext()

Methods in com.opensymphony.xwork2 with parameters of type ActionContext
Result | UnknownHandler.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.
static void | ActionContext.setContext(ActionContext context) Sets the action context for the current thread.

Uses of ActionContext in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ActionContext
protected  Object ScopedModelDrivenInterceptor.resolveModel(ObjectFactory factory, ActionContext actionContext, String modelClassName, String modelScope, String modelName)

Uses of ActionContext in com.opensymphony.xwork2.mock

Fields in com.opensymphony.xwork2.mock declared as ActionContext
private  ActionContext MockActionInvocation.invocationContext

Methods in com.opensymphony.xwork2.mock that return ActionContext
 ActionContext MockActionInvocation.getInvocationContext()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionContext
 void MockActionInvocation.setInvocationContext(ActionContext invocationContext)

Uses of ActionContext in org.apache.struts2

Subclasses of ActionContext in org.apache.struts2
 class ServletActionContext
Web-specific context information for actions.

Methods in org.apache.struts2 that return ActionContext
static ActionContext ServletActionContext.getActionContext(HttpServletRequest req)
Gets the current action context

Uses of ActionContext in org.apache.struts2.portlet.context

Methods in org.apache.struts2.portlet.context that return ActionContext
private static ActionContext PortletActionContext.getContext()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ActionContext.ActionContextThreadLocal (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.ActionContext.ActionContextThreadLocal

No usage of com.opensymphony.xwork2.ActionContext.ActionContextThreadLocal

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ActionEventListener (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.ActionEventListener

Packages that use ActionEventListener
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.

Uses of ActionEventListener in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ActionEventListener
protected ActionEventListener | DefaultActionInvocation.actionEventListener
protected ActionEventListener | DefaultActionProxy.actionEventListener

Methods in com.opensymphony.xwork2 with parameters of type ActionEventListener
void | ActionInvocation.setActionEventListener(ActionEventListener listener) Sets the action event listener to respond to key action events
void | DefaultActionInvocation.setActionEventListener(ActionEventListener listener)
void | DefaultActionProxy.setActionEventListener(ActionEventListener listener)

Uses of ActionEventListener in com.opensymphony.xwork2.mock

Fields in com.opensymphony.xwork2.mock declared as ActionEventListener
private  ActionEventListener MockActionInvocation.actionEventListener

Methods in com.opensymphony.xwork2.mock that return ActionEventListener
 ActionEventListener MockActionInvocation.getActionEventListener()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionEventListener
 void MockActionInvocation.setActionEventListener(ActionEventListener listener)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ActionInvocation (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.ActionInvocation

Packages that use ActionInvocation
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.debugging |
org.apache.struts2.interceptor.validation |
org.apache.struts2.portlet.interceptor |
org.apache.struts2.portlet.result |
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.validators |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.xslt | The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of ActionInvocation in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ActionInvocation
 class DefaultActionInvocation
The Default ActionInvocation implementation

Fields in com.opensymphony.xwork2 declared as ActionInvocation
protected  ActionInvocation DefaultActionProxy.invocation

Methods in com.opensymphony.xwork2 that return ActionInvocation
ActionInvocation | ActionContext.getActionInvocation() Gets the action invocation (the execution state).
ActionInvocation | ActionProxy.getInvocation()
ActionInvocation | DefaultActionProxy.getInvocation()

Methods in com.opensymphony.xwork2 with parameters of type ActionInvocation
void | ActionChainResult.execute(ActionInvocation invocation)
void | Result.execute(ActionInvocation invocation) Represents a generic interface for all action execution results, whether that be displaying a webpage, generating an email, sending a JMS message, etc.
void | ActionContext.setActionInvocation(ActionInvocation actionInvocation) Sets the action invocation (the execution state).

Uses of ActionInvocation in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ActionInvocation
protected boolean | MethodFilterInterceptor.applyInterceptor(ActionInvocation invocation)
void | PreResultListener.beforeResult(ActionInvocation invocation, String resultCode) This callback method will be called after the Action execution and before the Result execution.
protected String | DefaultWorkflowInterceptor.doIntercept(ActionInvocation invocation) Intercept ActionInvocation and returns a inputResultName when action / field errors is found registered.
protected abstract String | MethodFilterInterceptor.doIntercept(ActionInvocation invocation) Subclasses must override to implement the interceptor logic.
protected Object | ConversionErrorInterceptor.getOverrideExpr(ActionInvocation invocation, Object value)
abstract String | AbstractInterceptor.intercept(ActionInvocation invocation) Override to handle interception
String | AliasInterceptor.intercept(ActionInvocation invocation)
String | ChainingInterceptor.intercept(ActionInvocation invocation)
String | ConversionErrorInterceptor.intercept(ActionInvocation invocation)
String | ExceptionMappingInterceptor.intercept(ActionInvocation invocation)
String | I18nInterceptor.intercept(ActionInvocation invocation)
String | Interceptor.intercept(ActionInvocation invocation) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the ActionInvocation or to short-circuit the processing and just return a String return code.
String | LoggingInterceptor.intercept(ActionInvocation invocation)
String | MethodFilterInterceptor.intercept(ActionInvocation invocation)
String | ModelDrivenInterceptor.intercept(ActionInvocation invocation)
String | ParameterFilterInterceptor.intercept(ActionInvocation invocation)
String | ParameterRemoverInterceptor.intercept(ActionInvocation invocation) Decide if the parameter should be removed from the parameter map based on paramNames and paramValues.
String | ParametersInterceptor.intercept(ActionInvocation invocation)
String | PrepareInterceptor.intercept(ActionInvocation invocation)
String | ScopedModelDrivenInterceptor.intercept(ActionInvocation invocation)
String | StaticParametersInterceptor.intercept(ActionInvocation invocation)
String | TimerInterceptor.intercept(ActionInvocation invocation)
static void | PrefixMethodInvocationUtil.invokePrefixMethod(ActionInvocation actionInvocation, String[] prefixes) This method will prefix actionInvocation's ActionProxy's method with prefixes before invoking the prefixed method.
protected String | TimerInterceptor.invokeUnderTiming(ActionInvocation invocation) Is called to invoke the action invocation and time the execution time.
private void | LoggingInterceptor.logMessage(ActionInvocation invocation, String baseMessage)
protected void | ExceptionMappingInterceptor.publishException(ActionInvocation invocation, ExceptionHolder exceptionHolder) Default implementation to handle ExceptionHolder publishing.
protected void | I18nInterceptor.saveLocale(ActionInvocation invocation, Locale locale) Save the given locale to the ActionInvocation.

Uses of ActionInvocation in com.opensymphony.xwork2.interceptor.annotations

Methods in com.opensymphony.xwork2.interceptor.annotations with parameters of type ActionInvocation
void | AnnotationWorkflowInterceptor.beforeResult(ActionInvocation invocation, String resultCode) Invokes any @BeforeResult annotated methods
String | AnnotationWorkflowInterceptor.intercept(ActionInvocation invocation) Discovers annotated methods on the action and calls them according to the workflow

Uses of ActionInvocation in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement ActionInvocation
 class MockActionInvocation
Mock for an ActionInvocation.

Fields in com.opensymphony.xwork2.mock declared as ActionInvocation
(package private)  ActionInvocation MockActionProxy.invocation

Methods in com.opensymphony.xwork2.mock that return ActionInvocation
 ActionInvocation MockActionProxy.getInvocation()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionInvocation
void | MockResult.execute(ActionInvocation invocation)
String | MockInterceptor.intercept(ActionInvocation invocation) Allows the Interceptor to do some processing on the request before and/or after the rest of the processing of the request by the DefaultActionInvocation or to short-circuit the processing and just return a String return code.
void | MockActionProxy.setInvocation(ActionInvocation invocation)

Uses of ActionInvocation in com.opensymphony.xwork2.spring.interceptor

Methods in com.opensymphony.xwork2.spring.interceptor with parameters of type ActionInvocation
 String ActionAutowiringInterceptor.intercept(ActionInvocation invocation)
Looks for the ApplicationContext under the attribute that the Spring listener sets in the servlet context.

Uses of ActionInvocation in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type ActionInvocation
protected  void ValidationInterceptor.doBeforeInvocation(ActionInvocation invocation)
Gets the current action and its context and calls DefaultActionValidatorManager.validate(Object, String).
protected  String ValidationInterceptor.doIntercept(ActionInvocation invocation)

Uses of ActionInvocation in org.apache.struts2.config

Methods in org.apache.struts2.config with parameters of type ActionInvocation
 void NullResult.execute(ActionInvocation invocation)

Uses of ActionInvocation in org.apache.struts2.dispatcher

Methods in org.apache.struts2.dispatcher with parameters of type ActionInvocation
protected  String StrutsResultSupport.conditionalParse(String param, ActionInvocation invocation)
Parses the parameter for OGNL expressions against the valuestack
 void VelocityResult.doExecute(String finalLocation, ActionInvocation invocation)
Creates a Velocity context from the action, loads a Velocity template and executes the template.
protected abstract  void StrutsResultSupport.doExecute(String finalLocation, ActionInvocation invocation)
Executes the result given a final location (jsp page, action, etc) and the action invocation (the state in which the action was executed).
protected  void StreamResult.doExecute(String finalLocation, ActionInvocation invocation)
protected  void ServletRedirectResult.doExecute(String finalLocation, ActionInvocation invocation)
Redirects to the location specified by calling HttpServletResponse.sendRedirect(String).
 void ServletDispatcherResult.doExecute(String finalLocation, ActionInvocation invocation)
Dispatches to the given location.
protected  void PlainTextResult.doExecute(String finalLocation, ActionInvocation invocation)
 void StrutsResultSupport.execute(ActionInvocation invocation)
Implementation of the execute method from the Result interface.
 void ServletActionRedirectResult.execute(ActionInvocation invocation)
 void HttpHeaderResult.execute(ActionInvocation invocation)
Sets the optional HTTP response status code and also re-sets HTTP headers after they've been optionally evaluated against the ValueStack.
protected  org.apache.velocity.Template VelocityResult.getTemplate(ValueStack stack, org.apache.velocity.app.VelocityEngine velocity, ActionInvocation invocation, String location, String encoding)
Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.

Uses of ActionInvocation in org.apache.struts2.interceptor

Fields in org.apache.struts2.interceptor declared as ActionInvocation
protected  ActionInvocation BackgroundProcess.invocation

Methods in org.apache.struts2.interceptor that return ActionInvocation
 ActionInvocation BackgroundProcess.getInvocation()
Retrieves the action invocation.

Methods in org.apache.struts2.interceptor with parameters of type ActionInvocation
protected void | ScopeInterceptor.after(ActionInvocation invocation, String result)
protected void | MessageStoreInterceptor.after(ActionInvocation invocation, String result) Handle the storing of field errors / action messages / field errors, which is done after action invocation, and the operationMode is in 'STORE'.
protected void | ScopeInterceptor.before(ActionInvocation invocation)
protected void | MessageStoreInterceptor.before(ActionInvocation invocation) Handle the retrieving of field errors / action messages / field errors, which is done before action invocation, and the operationMode is 'RETRIEVE'.
void | ScopeInterceptor.beforeResult(ActionInvocation invocation, String resultCode)
protected String | TokenInterceptor.doIntercept(ActionInvocation invocation)
protected String | ExecuteAndWaitInterceptor.doIntercept(ActionInvocation actionInvocation)
private String | ScopeInterceptor.getKey(ActionInvocation invocation)
protected BackgroundProcess | ExecuteAndWaitInterceptor.getNewBackgroundProcess(String name, ActionInvocation actionInvocation, int threadPriority) Creates a new background process
protected Object | StrutsConversionErrorInterceptor.getOverrideExpr(ActionInvocation invocation, Object value)
protected String | MessageStoreInterceptor.getRequestOperationMode(ActionInvocation invocation) Get the operationMode through request paramter, if allowRequestParameterSwitch is 'true', else it simply returns 'NONE', meaning its neither in the 'STORE_MODE' nor 'RETRIEVE_MODE'.
protected String | TokenSessionStoreInterceptor.handleInvalidToken(ActionInvocation invocation)
protected String | TokenInterceptor.handleInvalidToken(ActionInvocation invocation) Determines what to do if an invalida token is provided.
protected String | RolesInterceptor.handleRejection(ActionInvocation invocation, HttpServletResponse response) Handles a rejection by sending a 403 HTTP error
protected String | TokenSessionStoreInterceptor.handleValidToken(ActionInvocation invocation)
protected String | TokenInterceptor.handleValidToken(ActionInvocation invocation) Called when a valid token is found.
String | ServletConfigInterceptor.intercept(ActionInvocation invocation) Sets action properties based on the interfaces an action implements.
String | ScopeInterceptor.intercept(ActionInvocation invocation)
String | RolesInterceptor.intercept(ActionInvocation invocation)
String | ProfilingActivationInterceptor.intercept(ActionInvocation invocation)
String | MessageStoreInterceptor.intercept(ActionInvocation invocation)
String | FileUploadInterceptor.intercept(ActionInvocation invocation)
String | CreateSessionInterceptor.intercept(ActionInvocation invocation)
String | CheckboxInterceptor.intercept(ActionInvocation ai)
(package private) static void | ScopeInterceptor.lock(Object o, ActionInvocation invocation)

Constructors in org.apache.struts2.interceptor with parameters of type ActionInvocation
BackgroundProcess(String threadName, ActionInvocation invocation, int threadPriority)
Constructs a background process

Uses of ActionInvocation in org.apache.struts2.interceptor.debugging

Methods in org.apache.struts2.interceptor.debugging with parameters of type ActionInvocation
 String DebuggingInterceptor.intercept(ActionInvocation inv)

Uses of ActionInvocation in org.apache.struts2.interceptor.validation

Methods in org.apache.struts2.interceptor.validation with parameters of type ActionInvocation
protected  String AnnotationValidationInterceptor.doIntercept(ActionInvocation invocation)

Uses of ActionInvocation in org.apache.struts2.portlet.interceptor

Methods in org.apache.struts2.portlet.interceptor with parameters of type ActionInvocation
 String PortletPreferencesInterceptor.intercept(ActionInvocation invocation)

Uses of ActionInvocation in org.apache.struts2.portlet.result

Methods in org.apache.struts2.portlet.result with parameters of type ActionInvocation
void | PortletVelocityResult.doExecute(String location, ActionInvocation invocation)
void | PortletResult.doExecute(String finalLocation, ActionInvocation actionInvocation) Execute the result.
private void | PortletVelocityResult.executeActionResult(String location, ActionInvocation invocation) Executes the result
protected void | PortletResult.executeActionResult(String finalLocation, ActionInvocation invocation) Executes the action result.
private void | PortletResult.executeRegularServletResult(String finalLocation, ActionInvocation actionInvocation) Executes the regular servlet result.
void | PortletVelocityResult.executeRenderResult(String finalLocation, ActionInvocation invocation) Creates a Velocity context from the action, loads a Velocity template and executes the template.
protected org.apache.velocity.Template | PortletVelocityResult.getTemplate(ValueStack stack, org.apache.velocity.app.VelocityEngine velocity, ActionInvocation invocation, String location, String encoding) Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.

Uses of ActionInvocation in org.apache.struts2.util

Fields in org.apache.struts2.util declared as ActionInvocation
(package private)  ActionInvocation InvocationSessionStore.InvocationContext.invocation

Methods in org.apache.struts2.util that return ActionInvocation
static ActionInvocation InvocationSessionStore.loadInvocation(String key, String token)
Checks the Map in the Session for the key and the token.

Methods in org.apache.struts2.util with parameters of type ActionInvocation
static void InvocationSessionStore.storeInvocation(String key, String token, ActionInvocation invocation)
Stores the DefaultActionInvocation and ActionContext into the Session using the provided key for loading later using InvocationSessionStore.loadInvocation(java.lang.String, java.lang.String)

Constructors in org.apache.struts2.util with parameters of type ActionInvocation
InvocationSessionStore.InvocationContext(ActionInvocation invocation, String token)

Uses of ActionInvocation in org.apache.struts2.validators

Classes in org.apache.struts2.validators that implement ActionInvocation
static class DWRValidator.ValidatorActionInvocation

Uses of ActionInvocation in org.apache.struts2.views.freemarker

Fields in org.apache.struts2.views.freemarker declared as ActionInvocation
protected ActionInvocation | PortletFreemarkerResult.invocation
protected ActionInvocation | FreemarkerResult.invocation

Methods in org.apache.struts2.views.freemarker with parameters of type ActionInvocation
void | PortletFreemarkerResult.doExecute(String location, ActionInvocation invocation) Execute this result, using the specified template location.
void | FreemarkerResult.doExecute(String location, ActionInvocation invocation) Execute this result, using the specified template location.
private void | PortletFreemarkerResult.executeActionResult(String location, ActionInvocation invocation)
private void | PortletFreemarkerResult.executeRenderResult(String location, ActionInvocation invocation)

Uses of ActionInvocation in org.apache.struts2.views.xslt

Methods in org.apache.struts2.views.xslt with parameters of type ActionInvocation
 void XSLTResult.execute(ActionInvocation invocation)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ActionProxy (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.ActionProxy

Packages that use ActionProxy
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
org.apache.struts2.components |
org.apache.struts2.impl |
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.validators |

Uses of ActionProxy in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ActionProxy
 class DefaultActionProxy
The Default ActionProxy implementation

Fields in com.opensymphony.xwork2 declared as ActionProxy
private ActionProxy | ActionChainResult.proxy
protected ActionProxy | DefaultActionInvocation.proxy

Methods in com.opensymphony.xwork2 that return ActionProxy
ActionProxy | ActionProxyFactory.createActionProxy(String namespace, String actionName, Map extraContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.
ActionProxy | DefaultActionProxyFactory.createActionProxy(String namespace, String actionName, Map extraContext) Use this method to build an DefaultActionProxy instance.
ActionProxy | ActionProxyFactory.createActionProxy(String namespace, String actionName, Map extraContext, boolean executeResult, boolean cleanupContext) Creates an ActionProxy for the given namespace and action name by looking up the configuration.
ActionProxy | DefaultActionProxyFactory.createActionProxy(String namespace, String actionName, Map extraContext, boolean executeResult, boolean cleanupContext) Use this method to build an DefaultActionProxy instance.
ActionProxy | ActionChainResult.getProxy()
ActionProxy | ActionInvocation.getProxy() Get the ActionProxy holding this ActionInvocation
ActionProxy | DefaultActionInvocation.getProxy()

Constructors in com.opensymphony.xwork2 with parameters of type ActionProxy
DefaultActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext)
DefaultActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext, boolean pushAction)

Uses of ActionProxy in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement ActionProxy
 class MockActionProxy
Mock for an ActionProxy.

Fields in com.opensymphony.xwork2.mock declared as ActionProxy
private  ActionProxy MockActionInvocation.proxy

Methods in com.opensymphony.xwork2.mock that return ActionProxy
 ActionProxy MockActionInvocation.getProxy()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionProxy
 void MockActionInvocation.setProxy(ActionProxy proxy)

Uses of ActionProxy in org.apache.struts2.components

Fields in org.apache.struts2.components declared as ActionProxy
protected  ActionProxy ActionComponent.proxy

Methods in org.apache.struts2.components that return ActionProxy
 ActionProxy ActionComponent.getProxy()

Uses of ActionProxy in org.apache.struts2.impl

Classes in org.apache.struts2.impl that implement ActionProxy
 class StrutsActionProxy

Methods in org.apache.struts2.impl that return ActionProxy
ActionProxy | StrutsActionProxyFactory.createActionProxy(String namespace, String actionName, Map extraContext)
ActionProxy | StrutsActionProxyFactory.createActionProxy(String namespace, String actionName, Map extraContext, boolean executeResult, boolean cleanupContext)

Uses of ActionProxy in org.apache.struts2.interceptor

Methods in org.apache.struts2.interceptor with parameters of type ActionProxy
protected  String ExecuteAndWaitInterceptor.getBackgroundProcessName(ActionProxy proxy)
Returns the name to associate the background process.

Uses of ActionProxy in org.apache.struts2.validators

Classes in org.apache.struts2.validators that implement ActionProxy
static class DWRValidator.ValidatorActionProxy

Constructors in org.apache.struts2.validators with parameters of type ActionProxy
DWRValidator.ValidatorActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ActionProxyFactory (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.ActionProxyFactory

Packages that use ActionProxyFactory
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
org.apache.struts2.components |
org.apache.struts2.impl |
org.apache.struts2.portlet.dispatcher |

Uses of ActionProxyFactory in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ActionProxyFactory
 class DefaultActionProxyFactory
DefaultActionProxyFactory

Fields in com.opensymphony.xwork2 declared as ActionProxyFactory
private ActionProxyFactory | ActionChainResult.actionProxyFactory
protected ActionProxyFactory | TestNGXWorkTestCase.actionProxyFactory
protected ActionProxyFactory | XWorkTestCase.actionProxyFactory

Methods in com.opensymphony.xwork2 with parameters of type ActionProxyFactory
 void ActionChainResult.setActionProxyFactory(ActionProxyFactory actionProxyFactory)

Uses of ActionProxyFactory in org.apache.struts2.components

Fields in org.apache.struts2.components declared as ActionProxyFactory
protected  ActionProxyFactory ActionComponent.actionProxyFactory

Methods in org.apache.struts2.components with parameters of type ActionProxyFactory
 void ActionComponent.setActionProxyFactory(ActionProxyFactory actionProxyFactory)

Uses of ActionProxyFactory in org.apache.struts2.impl

Classes in org.apache.struts2.impl that implement ActionProxyFactory
 class StrutsActionProxyFactory

Uses of ActionProxyFactory in org.apache.struts2.portlet.dispatcher

Fields in org.apache.struts2.portlet.dispatcher declared as ActionProxyFactory
private  ActionProxyFactory Jsr168Dispatcher.factory

Methods in org.apache.struts2.portlet.dispatcher with parameters of type ActionProxyFactory
protected  void Jsr168Dispatcher.setActionProxyFactory(ActionProxyFactory factory)
Convenience method to ease testing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ActionSupport (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.ActionSupport

Packages that use ActionSupport
org.apache.struts2.dispatcher Classes for action dispatching in Struts (the Controller part of MVC).

Uses of ActionSupport in org.apache.struts2.dispatcher

Subclasses of ActionSupport in org.apache.struts2.dispatcher
 class DefaultActionSupport
A simple action support class that sets properties to be able to serve

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultActionInvocation (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultActionInvocation

Packages that use DefaultActionInvocation
org.apache.struts2.validators

Uses of DefaultActionInvocation in org.apache.struts2.validators

Subclasses of DefaultActionInvocation in org.apache.struts2.validators
static class DWRValidator.ValidatorActionInvocation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultActionProxy (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultActionProxy

Packages that use DefaultActionProxy
org.apache.struts2.impl
org.apache.struts2.validators

Uses of DefaultActionProxy in org.apache.struts2.impl

Subclasses of DefaultActionProxy in org.apache.struts2.impl
 class StrutsActionProxy

Uses of DefaultActionProxy in org.apache.struts2.validators

Subclasses of DefaultActionProxy in org.apache.struts2.validators
static class DWRValidator.ValidatorActionProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultActionProxyFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultActionProxyFactory

Packages that use DefaultActionProxyFactory
org.apache.struts2.impl

Uses of DefaultActionProxyFactory in org.apache.struts2.impl

Subclasses of DefaultActionProxyFactory in org.apache.struts2.impl
 class StrutsActionProxyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.DefaultTextProvider (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.DefaultTextProvider

Packages that use DefaultTextProvider
com.opensymphony.xwork2 Main Xwork interfaces and classes.

Uses of DefaultTextProvider in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as DefaultTextProvider
static DefaultTextProvider DefaultTextProvider.INSTANCE

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.InvalidMetadataException (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.InvalidMetadataException

No usage of com.opensymphony.xwork2.InvalidMetadataException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.LocaleProvider (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.LocaleProvider

Packages that use LocaleProvider
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).

Uses of LocaleProvider in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement LocaleProvider
 class ActionSupport
Provides a default implementation for the most common actions.

Fields in com.opensymphony.xwork2 declared as LocaleProvider
private  LocaleProvider TextProviderSupport.localeProvider

Methods in com.opensymphony.xwork2 with parameters of type LocaleProvider
static TextProvider | TextProviderFactory.getInstance(Class clazz, LocaleProvider provider)
static TextProvider | TextProviderFactory.getInstance(ResourceBundle bundle, LocaleProvider provider)
void | TextProviderSupport.setLocaleProvider(LocaleProvider localeProvider)

Constructors in com.opensymphony.xwork2 with parameters of type LocaleProvider
TextProviderSupport(Class clazz, LocaleProvider provider)
Constructor.
TextProviderSupport(ResourceBundle bundle, LocaleProvider provider)
Constructor.

Uses of LocaleProvider in com.opensymphony.xwork2.validator

Subinterfaces of LocaleProvider in com.opensymphony.xwork2.validator
 interface ValidatorContext
The context for validation.

Classes in com.opensymphony.xwork2.validator that implement LocaleProvider
class | DelegatingValidatorContext A default implementation of the ValidatorContext interface.
private static class | DelegatingValidatorContext.ActionContextLocaleProvider An implementation of LocaleProvider which gets the locale from the action context.

Fields in com.opensymphony.xwork2.validator declared as LocaleProvider
private  LocaleProvider DelegatingValidatorContext.localeProvider

Methods in com.opensymphony.xwork2.validator that return LocaleProvider
protected static LocaleProvider DelegatingValidatorContext.makeLocaleProvider(Object object)

Methods in com.opensymphony.xwork2.validator with parameters of type LocaleProvider
static TextProvider DelegatingValidatorContext.makeTextProvider(Object object, LocaleProvider localeProvider)

Constructors in com.opensymphony.xwork2.validator with parameters of type LocaleProvider
DelegatingValidatorContext(ValidationAware validationAware, TextProvider textProvider, LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider.

Uses of LocaleProvider in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement LocaleProvider
private  class VisitorFieldValidator.AppendingValidatorContext

Uses of LocaleProvider in org.apache.struts2.dispatcher

Classes in org.apache.struts2.dispatcher that implement LocaleProvider
 class DefaultActionSupport
A simple action support class that sets properties to be able to serve

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.MockActionInvocation (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.MockActionInvocation

No usage of com.opensymphony.xwork2.MockActionInvocation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ModelDriven (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.ModelDriven

Packages that use ModelDriven
com.opensymphony.xwork2.interceptor Interceptor classes.

Uses of ModelDriven in com.opensymphony.xwork2.interceptor

Subinterfaces of ModelDriven in com.opensymphony.xwork2.interceptor
 interface ScopedModelDriven<T>
Adds the ability to set a model, probably retrieved from a given state.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ObjectFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.ObjectFactory

Packages that use ObjectFactory
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2.components |
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.impl |
org.apache.struts2.validators |
org.apache.struts2.views.velocity | Classes for views using Velocity.

Uses of ObjectFactory in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ObjectFactory
protected ObjectFactory | DefaultActionInvocation.objectFactory
protected ObjectFactory | DefaultActionProxy.objectFactory

Fields in com.opensymphony.xwork2 with type parameters of type ObjectFactory
private static ThreadLocal<ObjectFactory> ObjectFactory.thSelf

Methods in com.opensymphony.xwork2 that return ObjectFactory
static ObjectFactory ObjectFactory.getObjectFactory()

Methods in com.opensymphony.xwork2 with parameters of type ObjectFactory
void | DefaultActionProxy.setObjectFactory(ObjectFactory factory)
static void | ObjectFactory.setObjectFactory(ObjectFactory factory)

Constructors in com.opensymphony.xwork2 with parameters of type ObjectFactory
DefaultActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext)
DefaultActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext, boolean pushAction)

Uses of ObjectFactory in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl declared as ObjectFactory
(package private)  ObjectFactory DefaultConfiguration.objectFactory

Uses of ObjectFactory in com.opensymphony.xwork2.config.providers

Fields in com.opensymphony.xwork2.config.providers declared as ObjectFactory
private  ObjectFactory XmlConfigurationProvider.objectFactory

Methods in com.opensymphony.xwork2.config.providers with parameters of type ObjectFactory
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(PackageConfig packageConfig, String refName, Map refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
private static List<InterceptorMapping> | InterceptorBuilder.constructParameterizedInterceptorReferences(PackageConfig packageConfig, InterceptorStackConfig stackConfig, Map refParams, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig overriding the properties of the referenced interceptor with refParams.
void | XmlConfigurationProvider.setObjectFactory(ObjectFactory objectFactory)

Uses of ObjectFactory in com.opensymphony.xwork2.interceptor

Fields in com.opensymphony.xwork2.interceptor declared as ObjectFactory
private  ObjectFactory ScopedModelDrivenInterceptor.objectFactory

Methods in com.opensymphony.xwork2.interceptor with parameters of type ObjectFactory
protected Object | ScopedModelDrivenInterceptor.resolveModel(ObjectFactory factory, ActionContext actionContext, String modelClassName, String modelScope, String modelName)
void | ScopedModelDrivenInterceptor.setObjectFactory(ObjectFactory factory)

Uses of ObjectFactory in com.opensymphony.xwork2.spring

Subclasses of ObjectFactory in com.opensymphony.xwork2.spring
class | SpringObjectFactory Simple implementation of the ObjectFactory that makes use of Spring's application context if one has been configured, before falling back on the default mechanism of instantiating a new class using the class name.
class | SpringProxyableObjectFactory SpringProxyableObjectFactory.

Uses of ObjectFactory in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type ObjectFactory
static Validator | ValidatorFactory.getValidator(ValidatorConfig cfg, ObjectFactory objectFactory) Get a Validator that matches the given configuration.
static void | ValidatorFileParser.parseValidatorDefinitions(InputStream is, String resourceName, ObjectFactory objectFactory) Parses validator definitions

Uses of ObjectFactory in org.apache.struts2.components

Fields in org.apache.struts2.components declared as ObjectFactory
protected ObjectFactory | Form.objectFactory
protected ObjectFactory | Bean.objectFactory

Methods in org.apache.struts2.components with parameters of type ObjectFactory
void | Form.setObjectFactory(ObjectFactory objectFactory)
void | Bean.setObjectFactory(ObjectFactory objectFactory)

Uses of ObjectFactory in org.apache.struts2.config

Fields in org.apache.struts2.config declared as ObjectFactory
(package private)  ObjectFactory MethodConfigurationProvider.factory
Stores ObjectFactory property.

Methods in org.apache.struts2.config that return ObjectFactory
private  ObjectFactory MethodConfigurationProvider.getObjectFactory()
Provides ObjectFactory property.

Methods in org.apache.struts2.config with parameters of type ObjectFactory
 void MethodConfigurationProvider.setObjectFactory(ObjectFactory factory)
Updates ObjectFactory property.

Uses of ObjectFactory in org.apache.struts2.impl

Subclasses of ObjectFactory in org.apache.struts2.impl
 class StrutsObjectFactory

Uses of ObjectFactory in org.apache.struts2.validators

Constructors in org.apache.struts2.validators with parameters of type ObjectFactory
DWRValidator.ValidatorActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext)

Uses of ObjectFactory in org.apache.struts2.views.velocity

Fields in org.apache.struts2.views.velocity declared as ObjectFactory
private  ObjectFactory VelocityManager.objectFactory

Methods in org.apache.struts2.views.velocity with parameters of type ObjectFactory
 void VelocityManager.setObjectFactory(ObjectFactory fac)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ObjectFactory.ContinuationsClassLoader (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.ObjectFactory.ContinuationsClassLoader

No usage of com.opensymphony.xwork2.ObjectFactory.ContinuationsClassLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.Preparable (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.Preparable

No usage of com.opensymphony.xwork2.Preparable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.Result (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.Result

Packages that use Result
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.impl |
org.apache.struts2.portlet.result |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.xslt | The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of Result in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Result
 class ActionChainResult
This result invokes an entire other action, complete with it's own interceptor stack and result.

Fields in com.opensymphony.xwork2 declared as Result
protected  Result DefaultActionInvocation.result

Methods in com.opensymphony.xwork2 that return Result
Result | ObjectFactory.buildResult(ResultConfig resultConfig, Map extraContext) Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.
Result | DefaultActionInvocation.createResult()
Result | ActionInvocation.getResult() If the ActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
Result | DefaultActionInvocation.getResult() If the DefaultActionInvocation has been executed before and the Result is an instance of ActionChainResult, this method will walk down the chain of ActionChainResults until it finds a non-chain result, which will be returned.
Result | UnknownHandler.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.

Uses of Result in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement Result
 class MockResult
Mock for a Result.

Fields in com.opensymphony.xwork2.mock declared as Result
private  Result MockActionInvocation.result

Methods in com.opensymphony.xwork2.mock that return Result
 Result MockActionInvocation.getResult()

Methods in com.opensymphony.xwork2.mock with parameters of type Result
 void MockActionInvocation.setResult(Result result)

Uses of Result in org.apache.struts2.config

Classes in org.apache.struts2.config that implement Result
 class NullResult
Null result to get around annotation defaults that can't be null

Uses of Result in org.apache.struts2.dispatcher

Classes in org.apache.struts2.dispatcher that implement Result
class | HttpHeaderResult A custom Result type for setting HTTP headers and status by optionally evaluating against the ValueStack.
class | PlainTextResult A result that send the content out as plain text.
class | ServletActionRedirectResult This result uses the ActionMapper provided by the ActionMapperFactory to redirect the browser to a URL that invokes the specified action and (optional) namespace.
class | ServletDispatcherResult Includes or forwards to a view (usually a jsp).
class | ServletRedirectResult Calls the sendRedirect method to the location specified.
class | StreamResult A custom Result type for send raw data (via an InputStream) directly to the HttpServletResponse.
class | StrutsResultSupport A base class for all Struts action execution results.
class | VelocityResult Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

Uses of Result in org.apache.struts2.dispatcher.mapper

Fields in org.apache.struts2.dispatcher.mapper declared as Result
private  Result ActionMapping.result

Methods in org.apache.struts2.dispatcher.mapper that return Result
 Result ActionMapping.getResult()

Methods in org.apache.struts2.dispatcher.mapper with parameters of type Result
 void ActionMapping.setResult(Result result)

Constructors in org.apache.struts2.dispatcher.mapper with parameters of type Result
ActionMapping(Result result)
Constructs an ActionMapping with a default result

Uses of Result in org.apache.struts2.impl

Methods in org.apache.struts2.impl that return Result
 Result StrutsObjectFactory.buildResult(ResultConfig resultConfig, Map extraContext)

Uses of Result in org.apache.struts2.portlet.result

Classes in org.apache.struts2.portlet.result that implement Result
class | PortletResult Result type that includes a JSP to render.
class | PortletVelocityResult Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

Uses of Result in org.apache.struts2.views.freemarker

Classes in org.apache.struts2.views.freemarker that implement Result
class | FreemarkerResult Renders a view using the Freemarker template engine.
class | PortletFreemarkerResult

Uses of Result in org.apache.struts2.views.xslt

Classes in org.apache.struts2.views.xslt that implement Result
 class XSLTResult
XSLTResult uses XSLT to transform action object to XML.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.TestNGXWorkTestCase (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.TestNGXWorkTestCase

Packages that use TestNGXWorkTestCase
org.apache.struts2 Main Struts interfaces and classes.

Uses of TestNGXWorkTestCase in org.apache.struts2

Subclasses of TestNGXWorkTestCase in org.apache.struts2
 class TestNGStrutsTestCase
Base test class for TestNG unit tests.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.TextProvider (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.TextProvider

Packages that use TextProvider
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.
org.apache.struts2.components |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).

Uses of TextProvider in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement TextProvider
class | ActionSupport Provides a default implementation for the most common actions.
class | DefaultTextProvider DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.
class | TextProviderSupport Default TextProvider implementation.

Fields in com.opensymphony.xwork2 declared as TextProvider
private static TextProvider | TextProviderFactory.instance
private TextProvider | ActionSupport.textProvider

Methods in com.opensymphony.xwork2 that return TextProvider
static TextProvider | TextProviderFactory.getInstance()
static TextProvider | TextProviderFactory.getInstance(Class clazz, LocaleProvider provider)
static TextProvider | TextProviderFactory.getInstance(ResourceBundle bundle, LocaleProvider provider)

Methods in com.opensymphony.xwork2 with parameters of type TextProvider
static void TextProviderFactory.setInstance(TextProvider instance)

Uses of TextProvider in com.opensymphony.xwork2.validator

Subinterfaces of TextProvider in com.opensymphony.xwork2.validator
 interface ValidatorContext
The context for validation.

Classes in com.opensymphony.xwork2.validator that implement TextProvider
 class DelegatingValidatorContext
A default implementation of the ValidatorContext interface.

Fields in com.opensymphony.xwork2.validator declared as TextProvider
private  TextProvider DelegatingValidatorContext.textProvider

Methods in com.opensymphony.xwork2.validator that return TextProvider
protected TextProvider | DelegatingValidatorContext.getTextProvider()
static TextProvider | DelegatingValidatorContext.makeTextProvider(Object object, LocaleProvider localeProvider)

Methods in com.opensymphony.xwork2.validator with parameters of type TextProvider
protected  void DelegatingValidatorContext.setTextProvider(TextProvider textProvider)

Constructors in com.opensymphony.xwork2.validator with parameters of type TextProvider
DelegatingValidatorContext(ValidationAware validationAware, TextProvider textProvider, LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider.

Uses of TextProvider in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement TextProvider
private  class VisitorFieldValidator.AppendingValidatorContext

Uses of TextProvider in org.apache.struts2.components

Methods in org.apache.struts2.components that return TextProvider
private  TextProvider Date.findProviderInStack()

Methods in org.apache.struts2.components with parameters of type TextProvider
 String Date.formatTime(TextProvider tp, Date date)
Calculates the difference in time from now to the given date, and outputs it nicely.

Uses of TextProvider in org.apache.struts2.dispatcher

Classes in org.apache.struts2.dispatcher that implement TextProvider
 class DefaultActionSupport
A simple action support class that sets properties to be able to serve

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.TextProviderFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.TextProviderFactory

No usage of com.opensymphony.xwork2.TextProviderFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.TextProviderSupport (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.TextProviderSupport

No usage of com.opensymphony.xwork2.TextProviderSupport

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.Unchainable (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.Unchainable

Packages that use Unchainable
com.opensymphony.xwork2 Main Xwork interfaces and classes.

Uses of Unchainable in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Unchainable
 class DefaultTextProvider
DefaultTextProvider gets texts from only the default resource bundles associated with the LocalizedTextUtil.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.UnknownHandler (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.UnknownHandler

Packages that use UnknownHandler
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
org.apache.struts2.validators |

Uses of UnknownHandler in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as UnknownHandler
protected UnknownHandler | DefaultActionInvocation.unknownHandler
protected UnknownHandler | DefaultActionProxy.unknownHandler

Methods in com.opensymphony.xwork2 with parameters of type UnknownHandler
 void DefaultActionProxy.setUnknownHandler(UnknownHandler handler)

Constructors in com.opensymphony.xwork2 with parameters of type UnknownHandler
DefaultActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext)
DefaultActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext, boolean pushAction)

Uses of UnknownHandler in org.apache.struts2.validators

Constructors in org.apache.struts2.validators with parameters of type UnknownHandler
DWRValidator.ValidatorActionInvocation(ObjectFactory objectFactory, UnknownHandler handler, ActionProxy proxy, Map extraContext)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.Validateable (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.Validateable

Packages that use Validateable
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).

Uses of Validateable in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Validateable
 class ActionSupport
Provides a default implementation for the most common actions.

Uses of Validateable in org.apache.struts2.dispatcher

Classes in org.apache.struts2.dispatcher that implement Validateable
 class DefaultActionSupport
A simple action support class that sets properties to be able to serve

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.ValidationAware (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.ValidationAware

Packages that use ValidationAware
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.interceptor | Web specific interceptor classes.

Uses of ValidationAware in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement ValidationAware
class | ActionSupport Provides a default implementation for the most common actions.
class | ValidationAwareSupport Provides a default implementation of ValidationAware.

Uses of ValidationAware in com.opensymphony.xwork2.validator

Subinterfaces of ValidationAware in com.opensymphony.xwork2.validator
 interface ValidatorContext
The context for validation.

Classes in com.opensymphony.xwork2.validator that implement ValidationAware
class | DelegatingValidatorContext A default implementation of the ValidatorContext interface.
private static class | DelegatingValidatorContext.LoggingValidationAware An implementation of ValidationAware which logs errors and messages.

Fields in com.opensymphony.xwork2.validator declared as ValidationAware
private  ValidationAware DelegatingValidatorContext.validationAware

Methods in com.opensymphony.xwork2.validator that return ValidationAware
protected ValidationAware | DelegatingValidatorContext.getValidationAware()
protected static ValidationAware | DelegatingValidatorContext.makeValidationAware(Object object)

Methods in com.opensymphony.xwork2.validator with parameters of type ValidationAware
protected  void DelegatingValidatorContext.setValidationAware(ValidationAware validationAware)

Constructors in com.opensymphony.xwork2.validator with parameters of type ValidationAware
DelegatingValidatorContext(ValidationAware validationAware, TextProvider textProvider, LocaleProvider localeProvider)
Creates a new validation context given a ValidationAware object, and a text and locale provider.

Uses of ValidationAware in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement ValidationAware
private  class VisitorFieldValidator.AppendingValidatorContext

Uses of ValidationAware in org.apache.struts2.dispatcher

Classes in org.apache.struts2.dispatcher that implement ValidationAware
 class DefaultActionSupport
A simple action support class that sets properties to be able to serve

Uses of ValidationAware in org.apache.struts2.interceptor

Methods in org.apache.struts2.interceptor with parameters of type ValidationAware
protected  boolean FileUploadInterceptor.acceptFile(File file, String contentType, String inputName, ValidationAware validation, Locale locale)
Override for added functionality.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.ValidationAwareSupport (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.ValidationAwareSupport

Packages that use ValidationAwareSupport
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
org.apache.struts2.validators |

Uses of ValidationAwareSupport in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ValidationAwareSupport
private  ValidationAwareSupport ActionSupport.validationAware

Uses of ValidationAwareSupport in org.apache.struts2.validators

Methods in org.apache.struts2.validators that return ValidationAwareSupport
 ValidationAwareSupport DWRValidator.doPost(String namespace, String action, Map params)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.XWorkException (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.XWorkException

Packages that use XWorkException
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.util | XWork util classes.
org.apache.struts2 | Main Struts interfaces and classes.

Uses of XWorkException in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that throw XWorkException
ActionConfig | UnknownHandler.handleUnknownAction(String namespace, String actionName) Handles the case when an action configuration is unknown.
Result | UnknownHandler.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.

Uses of XWorkException in com.opensymphony.xwork2.config

Subclasses of XWorkException in com.opensymphony.xwork2.config
class | ConfigurationException ConfigurationException
class | ReferenceResolverException Exception when a reference can't be resolved.

Uses of XWorkException in com.opensymphony.xwork2.util

Subclasses of XWorkException in com.opensymphony.xwork2.util
 class TypeConversionException
TypeConversionException should be thrown by any TypeConverters which fail to convert values

Uses of XWorkException in org.apache.struts2

Subclasses of XWorkException in org.apache.struts2
 class StrutsException
A generic runtime exception that optionally contains Location information

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.XWorkMessages (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.XWorkMessages

No usage of com.opensymphony.xwork2.XWorkMessages

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.XWorkTestCase (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.XWorkTestCase

Packages that use XWorkTestCase
org.apache.struts2 Main Struts interfaces and classes.

Uses of XWorkTestCase in org.apache.struts2

Subclasses of XWorkTestCase in org.apache.struts2
 class StrutsTestCase
Base test case for JUnit testing Struts.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.config (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.config
Interfaces
Configuration
ConfigurationProvider
RuntimeConfiguration
Classes
ConfigurationManager
ConfigurationUtil
Exceptions
ConfigurationException
ReferenceResolverException


Uses of Interface com.opensymphony.xwork2.config.Configuration (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.config.Configuration

Packages that use Configuration
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
org.apache.struts2.components |
org.apache.struts2.config | Classes for Struts configuration and property handling.

Uses of Configuration in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as Configuration
protected Configuration | DefaultActionProxy.configuration
protected Configuration | TestNGXWorkTestCase.configuration
protected Configuration | XWorkTestCase.configuration

Methods in com.opensymphony.xwork2 with parameters of type Configuration
 void DefaultActionProxy.setConfiguration(Configuration config)

Uses of Configuration in com.opensymphony.xwork2.config

Fields in com.opensymphony.xwork2.config declared as Configuration
protected  Configuration ConfigurationManager.configuration

Methods in com.opensymphony.xwork2.config that return Configuration
 Configuration ConfigurationManager.getConfiguration()
Get the current XWork configuration object.

Methods in com.opensymphony.xwork2.config with parameters of type Configuration
static List | ConfigurationUtil.buildParentsFromString(Configuration configuration, String parent)
void | ConfigurationProvider.init(Configuration configuration)
void | ConfigurationManager.setConfiguration(Configuration configuration)

Uses of Configuration in com.opensymphony.xwork2.config.impl

Classes in com.opensymphony.xwork2.config.impl that implement Configuration
class | DefaultConfiguration DefaultConfiguration
class | MockConfiguration Simple configuration used for unit testing

Uses of Configuration in com.opensymphony.xwork2.config.providers

Fields in com.opensymphony.xwork2.config.providers declared as Configuration
private  Configuration XmlConfigurationProvider.configuration

Methods in com.opensymphony.xwork2.config.providers with parameters of type Configuration
 void XmlConfigurationProvider.init(Configuration configuration)

Uses of Configuration in com.opensymphony.xwork2.mock

Fields in com.opensymphony.xwork2.mock declared as Configuration
(package private)  Configuration MockActionProxy.configuration

Uses of Configuration in org.apache.struts2.components

Fields in org.apache.struts2.components declared as Configuration
protected  Configuration Form.configuration

Methods in org.apache.struts2.components with parameters of type Configuration
 void Form.setConfiguration(Configuration configuration)

Uses of Configuration in org.apache.struts2.config

Fields in org.apache.struts2.config declared as Configuration
private Configuration | MethodConfigurationProvider.configuration Stores configuration property.
private Configuration | ClasspathConfigurationProvider.configuration The XWork Configuration for this application.

Methods in org.apache.struts2.config with parameters of type Configuration
void | MethodConfigurationProvider.init(Configuration configuration)
void | LegacyPropertiesConfigurationProvider.init(Configuration configuration)
void | DefaultPropertiesProvider.init(Configuration configuration)
void | ClasspathConfigurationProvider.init(Configuration config) Register this application's configuration.
void | BeanSelectionProvider.init(Configuration configuration)
void | MethodConfigurationProvider.setConfiguration(Configuration configuration) Updates configuration property.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.ConfigurationException (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.ConfigurationException

Packages that use ConfigurationException
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.impl |

Uses of ConfigurationException in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that throw ConfigurationException
 Interceptor ObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map interceptorRefParams)
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.

Uses of ConfigurationException in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that throw ConfigurationException
void | ConfigurationProvider.init(Configuration configuration)
void | ConfigurationProvider.loadPackages()
void | ConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | Configuration.reload(List<ConfigurationProvider> providers)

Uses of ConfigurationException in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl that throw ConfigurationException
private  ActionConfig DefaultConfiguration.buildFullActionConfig(PackageConfig packageContext, ActionConfig baseConfig)
Builds the full runtime actionconfig with all of the defaults and inheritance
protected  RuntimeConfiguration DefaultConfiguration.buildRuntimeConfiguration()
This methodName builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures.
 void DefaultConfiguration.reload(List<ConfigurationProvider> providers)
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
 void MockConfiguration.reload(List<ConfigurationProvider> providers)

Uses of ConfigurationException in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that throw ConfigurationException
protected void | XmlConfigurationProvider.addAction(Element actionElement, PackageConfig packageContext)
protected void | XmlConfigurationProvider.addPackage(Element packageElement) Create a PackageConfig from an XML element representing it.
protected List | XmlConfigurationProvider.buildInterceptorList(Element element, PackageConfig context)
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(PackageConfig packageConfig, String refName, Map refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
protected void | XmlConfigurationProvider.loadInterceptors(PackageConfig context, Element element)
protected InterceptorStackConfig | XmlConfigurationProvider.loadInterceptorStack(Element element, PackageConfig context)
protected void | XmlConfigurationProvider.loadInterceptorStacks(Element element, PackageConfig context)
void | XmlConfigurationProvider.loadPackages()
private List | XmlConfigurationProvider.lookupInterceptorReference(PackageConfig context, Element interceptorRefElement) Looks up the Interceptor Class from the interceptor-ref name and creates an instance, which is added to the provided List, or, if this is a ref to a stack, it adds the Interceptor instances from the List to this stack.
void | XmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)

Uses of ConfigurationException in org.apache.struts2.config

Methods in org.apache.struts2.config that throw ConfigurationException
protected boolean | MethodConfigurationProvider.addDynamicMethods(Map actions, String actionName, ActionConfig actionConfig) Scans class for potential Action mehods, automatically generating and registering ActionConfigs as needed.
private ObjectFactory | MethodConfigurationProvider.getObjectFactory() Provides ObjectFactory property.
void | MethodConfigurationProvider.init(Configuration configuration)
void | LegacyPropertiesConfigurationProvider.init(Configuration configuration)
void | DefaultPropertiesProvider.init(Configuration configuration)
void | BeanSelectionProvider.init(Configuration configuration)
void | MethodConfigurationProvider.loadPackages()
void | LegacyPropertiesConfigurationProvider.loadPackages()
void | ClasspathConfigurationProvider.loadPackages() Clears and loads the list of packages registered at construction.
void | BeanSelectionProvider.loadPackages()
void | StrutsXmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)
void | MethodConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties locatableProperties)
void | LegacyPropertiesConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | DefaultPropertiesProvider.register(ContainerBuilder builder, LocatableProperties props)
void | ClasspathConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)

Uses of ConfigurationException in org.apache.struts2.impl

Methods in org.apache.struts2.impl that throw ConfigurationException
 Interceptor StrutsObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map refParams)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.ConfigurationManager (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.ConfigurationManager

Packages that use ConfigurationManager
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.util | XWork util classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |

Uses of ConfigurationManager in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ConfigurationManager
protected ConfigurationManager | TestNGXWorkTestCase.configurationManager
protected ConfigurationManager | XWorkTestCase.configurationManager

Uses of ConfigurationManager in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return ConfigurationManager
static ConfigurationManager | XWorkTestCaseHelper.loadConfigurationProviders(ConfigurationManager configurationManager, ConfigurationProvider... providers)
static ConfigurationManager | XWorkTestCaseHelper.setUp()

Methods in com.opensymphony.xwork2.util with parameters of type ConfigurationManager
static ConfigurationManager | XWorkTestCaseHelper.loadConfigurationProviders(ConfigurationManager configurationManager, ConfigurationProvider... providers)
static void | XWorkTestCaseHelper.tearDown(ConfigurationManager configurationManager)

Uses of ConfigurationManager in org.apache.struts2.dispatcher

Fields in org.apache.struts2.dispatcher declared as ConfigurationManager
private  ConfigurationManager Dispatcher.configurationManager
Store ConfigurationManager instance, set on init.

Methods in org.apache.struts2.dispatcher that return ConfigurationManager
 ConfigurationManager Dispatcher.getConfigurationManager()
Expose the ConfigurationManager instance.

Methods in org.apache.struts2.dispatcher with parameters of type ConfigurationManager
 void Dispatcher.setConfigurationManager(ConfigurationManager mgr)
Modify the ConfigurationManager instance

Uses of ConfigurationManager in org.apache.struts2.dispatcher.mapper

Methods in org.apache.struts2.dispatcher.mapper with parameters of type ConfigurationManager
ActionMapping | RestfulActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager)
ActionMapping | Restful2ActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager)
ActionMapping | DefaultActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager)
ActionMapping | CompositeActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager)
ActionMapping | ActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager) Expose the ActionMapping for the current request
(package private) void | DefaultActionMapper.parseNameAndNamespace(String uri, ActionMapping mapping, ConfigurationManager configManager) Parses the name and namespace from the uri

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.ConfigurationProvider (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.config.ConfigurationProvider

Packages that use ConfigurationProvider
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.util | XWork util classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.

Uses of ConfigurationProvider in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with parameters of type ConfigurationProvider
protected void | TestNGXWorkTestCase.loadConfigurationProviders(ConfigurationProvider... providers)
protected void | XWorkTestCase.loadConfigurationProviders(ConfigurationProvider... providers)

Uses of ConfigurationProvider in com.opensymphony.xwork2.config

Fields in com.opensymphony.xwork2.config with type parameters of type ConfigurationProvider
private  List<ConfigurationProvider> ConfigurationManager.configurationProviders

Methods in com.opensymphony.xwork2.config that return types with arguments of type ConfigurationProvider
 List<ConfigurationProvider> ConfigurationManager.getConfigurationProviders()
Get the current list of ConfigurationProviders.

Methods in com.opensymphony.xwork2.config with parameters of type ConfigurationProvider
 void ConfigurationManager.addConfigurationProvider(ConfigurationProvider provider)
adds a configuration provider to the List of ConfigurationProviders.

Method parameters in com.opensymphony.xwork2.config with type arguments of type ConfigurationProvider
void | Configuration.reload(List<ConfigurationProvider> providers)
void | ConfigurationManager.setConfigurationProviders(List<ConfigurationProvider> configurationProviders) Set the list of configuration providers

Uses of ConfigurationProvider in com.opensymphony.xwork2.config.impl

Method parameters in com.opensymphony.xwork2.config.impl with type arguments of type ConfigurationProvider
 void DefaultConfiguration.reload(List<ConfigurationProvider> providers)
Calls the ConfigurationProviderFactory.getConfig() to tell it to reload the configuration and then calls buildRuntimeConfiguration().
 void MockConfiguration.reload(List<ConfigurationProvider> providers)

Uses of ConfigurationProvider in com.opensymphony.xwork2.config.providers

Classes in com.opensymphony.xwork2.config.providers that implement ConfigurationProvider
 class XmlConfigurationProvider
Looks in the classpath for an XML file, "xwork.xml" by default, and uses it for the XWork configuration.

Uses of ConfigurationProvider in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util with parameters of type ConfigurationProvider
static ConfigurationManager XWorkTestCaseHelper.loadConfigurationProviders(ConfigurationManager configurationManager, ConfigurationProvider... providers)

Uses of ConfigurationProvider in org.apache.struts2.config

Classes in org.apache.struts2.config that implement ConfigurationProvider
class | BeanSelectionProvider Selects the implementations of key framework extension points, using the loaded property constants.
class | ClasspathConfigurationProvider ClasspathConfigurationProvider loads the configuration by scanning the classpath or selected packages for Action classes.
class | DefaultPropertiesProvider Loads the default properties, separate from the usual struts.properties loading
class | LegacyPropertiesConfigurationProvider
class | MethodConfigurationProvider MethodConfigurationProvider creates ActionConfigs for potential action methods that lack a corresponding action mapping, so that these methods can be invoked without extra or redundant configuration.
class | StrutsXmlConfigurationProvider Override Xwork class so we can use an arbitrary config file

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.ConfigurationUtil (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.ConfigurationUtil

No usage of com.opensymphony.xwork2.config.ConfigurationUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.ReferenceResolverException (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.ReferenceResolverException

No usage of com.opensymphony.xwork2.config.ReferenceResolverException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.RuntimeConfiguration (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.config.RuntimeConfiguration

Packages that use RuntimeConfiguration
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.

Uses of RuntimeConfiguration in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return RuntimeConfiguration
 RuntimeConfiguration Configuration.getRuntimeConfiguration()
The current runtime configuration.

Uses of RuntimeConfiguration in com.opensymphony.xwork2.config.impl

Classes in com.opensymphony.xwork2.config.impl that implement RuntimeConfiguration
private  class DefaultConfiguration.RuntimeConfigurationImpl

Fields in com.opensymphony.xwork2.config.impl declared as RuntimeConfiguration
protected  RuntimeConfiguration DefaultConfiguration.runtimeConfiguration

Methods in com.opensymphony.xwork2.config.impl that return RuntimeConfiguration
protected RuntimeConfiguration | DefaultConfiguration.buildRuntimeConfiguration() This methodName builds the internal runtime configuration used by Xwork for finding and configuring Actions from the programmatic configuration data structures.
RuntimeConfiguration | DefaultConfiguration.getRuntimeConfiguration()
RuntimeConfiguration | MockConfiguration.getRuntimeConfiguration()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.config.entities (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.config.entities
Interfaces
InterceptorListHolder
Parameterizable
Classes
ActionConfig
ExceptionMappingConfig
InterceptorConfig
InterceptorMapping
InterceptorStackConfig
PackageConfig
ResultConfig
ResultTypeConfig


Uses of Class com.opensymphony.xwork2.config.entities.ActionConfig (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ActionConfig

Packages that use ActionConfig
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.validators |

Uses of ActionConfig in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ActionConfig
protected  ActionConfig DefaultActionProxy.config

Methods in com.opensymphony.xwork2 that return ActionConfig
ActionConfig | ActionProxy.getConfig()
ActionConfig | DefaultActionProxy.getConfig()
ActionConfig | UnknownHandler.handleUnknownAction(String namespace, String actionName) Handles the case when an action configuration is unknown.

Methods in com.opensymphony.xwork2 with parameters of type ActionConfig
Object | ObjectFactory.buildAction(String actionName, String namespace, ActionConfig config, Map extraContext) Build an instance of the action class to handle a particular request (eg.
Result | UnknownHandler.handleUnknownResult(ActionContext actionContext, String actionName, ActionConfig actionConfig, String resultCode) Handles the case when a result cannot be found for an action and result code.
protected String | DefaultActionInvocation.invokeAction(Object action, ActionConfig actionConfig)

Uses of ActionConfig in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return ActionConfig
 ActionConfig RuntimeConfiguration.getActionConfig(String namespace, String name)
get the fully expanded ActionConfig for a specified namespace and (action) name

Uses of ActionConfig in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type ActionConfig
private  Map<String,ActionConfig> PackageConfig.actionConfigs

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type ActionConfig
Map<String,ActionConfig> | PackageConfig.getActionConfigs()
Map<String,ActionConfig> | PackageConfig.getAllActionConfigs() returns the Map of all the ActionConfigs available in the current package.

Methods in com.opensymphony.xwork2.config.entities with parameters of type ActionConfig
 void PackageConfig.addActionConfig(String name, ActionConfig action)

Uses of ActionConfig in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl declared as ActionConfig
private  ActionConfig ActionConfigMatcher.Mapping.config
The original ActionConfig.

Fields in com.opensymphony.xwork2.config.impl with type parameters of type ActionConfig
private  Map<String,Map<String,ActionConfig>> DefaultConfiguration.RuntimeConfigurationImpl.namespaceActionConfigs

Methods in com.opensymphony.xwork2.config.impl that return ActionConfig
private ActionConfig | DefaultConfiguration.buildFullActionConfig(PackageConfig packageContext, ActionConfig baseConfig) Builds the full runtime actionconfig with all of the defaults and inheritance
protected ActionConfig | ActionConfigMatcher.convertActionConfig(String path, ActionConfig orig, Map vars) Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.
ActionConfig | ActionConfigMatcher.Mapping.getActionConfig() Gets the ActionConfig that contains the pattern.
ActionConfig | DefaultConfiguration.RuntimeConfigurationImpl.getActionConfig(String namespace, String name) Gets the configuration information for an action name, or returns null if the name is not recognized.
ActionConfig | ActionConfigMatcher.match(String path) Matches the path against the compiled wildcard patterns.

Methods in com.opensymphony.xwork2.config.impl with parameters of type ActionConfig
private ActionConfig | DefaultConfiguration.buildFullActionConfig(PackageConfig packageContext, ActionConfig baseConfig) Builds the full runtime actionconfig with all of the defaults and inheritance
protected ActionConfig | ActionConfigMatcher.convertActionConfig(String path, ActionConfig orig, Map vars) Clones the ActionConfig and its children, replacing various properties with the values of the wildcard-matched strings.

Constructors in com.opensymphony.xwork2.config.impl with parameters of type ActionConfig
ActionConfigMatcher.Mapping(String original, int[] pattern, ActionConfig config)
Contructs a read-only Mapping instance.

Constructor parameters in com.opensymphony.xwork2.config.impl with type arguments of type ActionConfig
ActionConfigMatcher(Map<String,ActionConfig> configs)
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
ActionConfigMatcher(Map<String,ActionConfig> configs, boolean looseMatch)
Finds and precompiles the wildcard patterns from the ActionConfig "path" attributes.
DefaultConfiguration.RuntimeConfigurationImpl(Map<String,Map<String,ActionConfig>> namespaceActionConfigs, Map<String,String> namespaceConfigs)

Uses of ActionConfig in com.opensymphony.xwork2.mock

Fields in com.opensymphony.xwork2.mock declared as ActionConfig
(package private)  ActionConfig MockActionProxy.config

Methods in com.opensymphony.xwork2.mock that return ActionConfig
 ActionConfig MockActionProxy.getConfig()

Methods in com.opensymphony.xwork2.mock with parameters of type ActionConfig
 void MockActionProxy.setConfig(ActionConfig config)

Uses of ActionConfig in org.apache.struts2.config

Methods in org.apache.struts2.config with parameters of type ActionConfig
protected  boolean MethodConfigurationProvider.addDynamicMethods(Map actions, String actionName, ActionConfig actionConfig)
Scans class for potential Action mehods, automatically generating and registering ActionConfigs as needed.

Uses of ActionConfig in org.apache.struts2.validators

Methods in org.apache.struts2.validators with parameters of type ActionConfig
protected  String DWRValidator.ValidatorActionInvocation.invokeAction(Object action, ActionConfig actionConfig)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ExceptionMappingConfig (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ExceptionMappingConfig

Packages that use ExceptionMappingConfig
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of ExceptionMappingConfig in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type ExceptionMappingConfig
protected  List<ExceptionMappingConfig> ActionConfig.exceptionMappings

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type ExceptionMappingConfig
List<ExceptionMappingConfig> | PackageConfig.getAllExceptionMappingConfigs() returns the List of all the ExceptionMappingConfigs available in the current package.
List<ExceptionMappingConfig> | ActionConfig.getExceptionMappings()
List<ExceptionMappingConfig> | PackageConfig.getGlobalExceptionMappingConfigs() gets the ExceptionMappingConfigs local to this package

Methods in com.opensymphony.xwork2.config.entities with parameters of type ExceptionMappingConfig
void | ActionConfig.addExceptionMapping(ExceptionMappingConfig exceptionMapping)
void | PackageConfig.addExceptionMappingConfig(ExceptionMappingConfig exceptionMappingConfig)

Method parameters in com.opensymphony.xwork2.config.entities with type arguments of type ExceptionMappingConfig
 void ActionConfig.addExceptionMappings(List<? extends ExceptionMappingConfig> mappings)

Constructor parameters in com.opensymphony.xwork2.config.entities with type arguments of type ExceptionMappingConfig
ActionConfig(String methodName, Class clazz, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
ActionConfig(String methodName, String className, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
ActionConfig(String methodName, String className, String packageName, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.InterceptorConfig (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.InterceptorConfig

Packages that use InterceptorConfig
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
org.apache.struts2.impl |

Uses of InterceptorConfig in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with parameters of type InterceptorConfig
 Interceptor ObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map interceptorRefParams)
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.

Uses of InterceptorConfig in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities with parameters of type InterceptorConfig
 void PackageConfig.addInterceptorConfig(InterceptorConfig config)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type InterceptorConfig
InterceptorConfig(InterceptorConfig parent, Map params)

Uses of InterceptorConfig in org.apache.struts2.impl

Methods in org.apache.struts2.impl with parameters of type InterceptorConfig
 Interceptor StrutsObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map refParams)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.entities.InterceptorListHolder (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.config.entities.InterceptorListHolder

Packages that use InterceptorListHolder
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of InterceptorListHolder in com.opensymphony.xwork2.config.entities

Classes in com.opensymphony.xwork2.config.entities that implement InterceptorListHolder
class | ActionConfig Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
class | InterceptorStackConfig Configuration for InterceptorStack.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.InterceptorMapping (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.InterceptorMapping

Packages that use InterceptorMapping
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.

Uses of InterceptorMapping in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type InterceptorMapping
protected List<InterceptorMapping> | ActionConfig.interceptors
private List<InterceptorMapping> | InterceptorStackConfig.interceptors

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type InterceptorMapping
List<InterceptorMapping> | ActionConfig.getInterceptors()
Collection<InterceptorMapping> | InterceptorStackConfig.getInterceptors()

Methods in com.opensymphony.xwork2.config.entities with parameters of type InterceptorMapping
void | ActionConfig.addInterceptor(InterceptorMapping interceptor)
void | InterceptorListHolder.addInterceptor(InterceptorMapping interceptor)
void | InterceptorStackConfig.addInterceptor(InterceptorMapping interceptor)

Method parameters in com.opensymphony.xwork2.config.entities with type arguments of type InterceptorMapping
void | ActionConfig.addInterceptors(List<InterceptorMapping> interceptors)
void | InterceptorListHolder.addInterceptors(List<InterceptorMapping> interceptors)
void | InterceptorStackConfig.addInterceptors(List<InterceptorMapping> interceptors)

Constructor parameters in com.opensymphony.xwork2.config.entities with type arguments of type InterceptorMapping
ActionConfig(String methodName, Class clazz, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, Class clazz, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
ActionConfig(String methodName, String className, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, String className, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
ActionConfig(String methodName, String className, String packageName, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, String className, String packageName, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)

Uses of InterceptorMapping in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return types with arguments of type InterceptorMapping
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(PackageConfig packageConfig, String refName, Map refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
private static List<InterceptorMapping> | InterceptorBuilder.constructParameterizedInterceptorReferences(PackageConfig packageConfig, InterceptorStackConfig stackConfig, Map refParams, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig overriding the properties of the referenced interceptor with refParams.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.InterceptorStackConfig (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.InterceptorStackConfig

Packages that use InterceptorStackConfig
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.

Uses of InterceptorStackConfig in com.opensymphony.xwork2.config.entities

Methods in com.opensymphony.xwork2.config.entities with parameters of type InterceptorStackConfig
 void PackageConfig.addInterceptorStackConfig(InterceptorStackConfig config)

Uses of InterceptorStackConfig in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return InterceptorStackConfig
protected  InterceptorStackConfig XmlConfigurationProvider.loadInterceptorStack(Element element, PackageConfig context)

Methods in com.opensymphony.xwork2.config.providers with parameters of type InterceptorStackConfig
private static List<InterceptorMapping> InterceptorBuilder.constructParameterizedInterceptorReferences(PackageConfig packageConfig, InterceptorStackConfig stackConfig, Map refParams, ObjectFactory objectFactory)
Builds a list of interceptors referenced by the refName in the supplied PackageConfig overriding the properties of the referenced interceptor with refParams.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.PackageConfig (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.PackageConfig

Packages that use PackageConfig
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.

Uses of PackageConfig in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return PackageConfig
 PackageConfig Configuration.getPackageConfig(String name)

Methods in com.opensymphony.xwork2.config with parameters of type PackageConfig
 void Configuration.addPackageConfig(String name, PackageConfig packageConfig)

Uses of PackageConfig in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type PackageConfig
private  List<PackageConfig> PackageConfig.parents

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type PackageConfig
 List<PackageConfig> PackageConfig.getParents()

Methods in com.opensymphony.xwork2.config.entities with parameters of type PackageConfig
void | PackageConfig.addParent(PackageConfig parent)
void | PackageConfig.removeParent(PackageConfig parent)

Method parameters in com.opensymphony.xwork2.config.entities with type arguments of type PackageConfig
 void PackageConfig.addAllParents(List<PackageConfig> parents)

Uses of PackageConfig in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl with type parameters of type PackageConfig
protected  Map<String,PackageConfig> DefaultConfiguration.packageContexts

Methods in com.opensymphony.xwork2.config.impl that return PackageConfig
PackageConfig | DefaultConfiguration.getPackageConfig(String name)
PackageConfig | MockConfiguration.getPackageConfig(String name)

Methods in com.opensymphony.xwork2.config.impl with parameters of type PackageConfig
void | DefaultConfiguration.addPackageConfig(String name, PackageConfig packageContext)
void | MockConfiguration.addPackageConfig(String name, PackageConfig packageContext)
private ActionConfig | DefaultConfiguration.buildFullActionConfig(PackageConfig packageContext, ActionConfig baseConfig) Builds the full runtime actionconfig with all of the defaults and inheritance
private void | DefaultConfiguration.setDefaultResults(Map<String,ResultConfig> results, PackageConfig packageContext)

Uses of PackageConfig in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers that return PackageConfig
protected  PackageConfig XmlConfigurationProvider.buildPackageContext(Element packageElement)
This method builds a package context by looking for the parents of this new package.

Methods in com.opensymphony.xwork2.config.providers with parameters of type PackageConfig
protected void | XmlConfigurationProvider.addAction(Element actionElement, PackageConfig packageContext)
protected void | XmlConfigurationProvider.addResultTypes(PackageConfig packageContext, Element element)
protected List | XmlConfigurationProvider.buildExceptionMappings(Element element, PackageConfig packageContext) Build a map of ResultConfig objects from below a given XML element.
protected List | XmlConfigurationProvider.buildInterceptorList(Element element, PackageConfig context)
protected Map | XmlConfigurationProvider.buildResults(Element element, PackageConfig packageContext) Build a map of ResultConfig objects from below a given XML element.
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(PackageConfig packageConfig, String refName, Map refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
private static List<InterceptorMapping> | InterceptorBuilder.constructParameterizedInterceptorReferences(PackageConfig packageConfig, InterceptorStackConfig stackConfig, Map refParams, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig overriding the properties of the referenced interceptor with refParams.
protected void | XmlConfigurationProvider.loadDefaultActionRef(PackageConfig packageContext, Element element)
protected void | XmlConfigurationProvider.loadDefaultClassRef(PackageConfig packageContext, Element element)
protected void | XmlConfigurationProvider.loadDefaultInterceptorRef(PackageConfig packageContext, Element element)
protected void | XmlConfigurationProvider.loadGlobalResults(PackageConfig packageContext, Element packageElement) Load all of the global results for this package from the XML element.
protected void | XmlConfigurationProvider.loadGobalExceptionMappings(PackageConfig packageContext, Element packageElement) Load all of the global results for this package from the XML element.
protected void | XmlConfigurationProvider.loadInterceptors(PackageConfig context, Element element)
protected InterceptorStackConfig | XmlConfigurationProvider.loadInterceptorStack(Element element, PackageConfig context)
protected void | XmlConfigurationProvider.loadInterceptorStacks(Element element, PackageConfig context)
private List | XmlConfigurationProvider.lookupInterceptorReference(PackageConfig context, Element interceptorRefElement) Looks up the Interceptor Class from the interceptor-ref name and creates an instance, which is added to the provided List, or, if this is a ref to a stack, it adds the Interceptor instances from the List to this stack.

Uses of PackageConfig in org.apache.struts2.config

Fields in org.apache.struts2.config declared as PackageConfig
private  PackageConfig ClasspathConfigurationProvider.ResultMap.pkgConfig

Fields in org.apache.struts2.config with type parameters of type PackageConfig
private  Map<String,PackageConfig> ClasspathConfigurationProvider.loadedPackageConfigs
The package configurations for scanned Actions.

Methods in org.apache.struts2.config that return PackageConfig
protected  PackageConfig ClasspathConfigurationProvider.loadPackageConfig(String actionNamespace, String actionPackage, Class actionClass)
Finds or creates the package configuration for an Action class.

Constructors in org.apache.struts2.config with parameters of type PackageConfig
ClasspathConfigurationProvider.ResultMap(Class actionClass, String actionName, PackageConfig pkgConfig)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.config.entities.Parameterizable (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.config.entities.Parameterizable

Packages that use Parameterizable
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of Parameterizable in com.opensymphony.xwork2.config.entities

Classes in com.opensymphony.xwork2.config.entities that implement Parameterizable
class | ActionConfig Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
class | InterceptorConfig Configuration for Interceptors.
class | ResultConfig Configuration for Result.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ResultConfig (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ResultConfig

Packages that use ResultConfig
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.impl |

Uses of ResultConfig in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with parameters of type ResultConfig
 Result ObjectFactory.buildResult(ResultConfig resultConfig, Map extraContext)
Build a Result using the type in the ResultConfig and set the parameters in the ResultConfig.

Uses of ResultConfig in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type ResultConfig
private Map<String,ResultConfig> | PackageConfig.globalResultConfigs
protected Map<String,ResultConfig> | ActionConfig.results

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type ResultConfig
Map<String,ResultConfig> | PackageConfig.getAllGlobalResults() returns the Map of all the global ResultConfigs available in the current package.
Map<String,ResultConfig> | PackageConfig.getGlobalResultConfigs() gets the global ResultConfigs local to this package
Map<String,ResultConfig> | ActionConfig.getResults()

Methods in com.opensymphony.xwork2.config.entities with parameters of type ResultConfig
void | PackageConfig.addGlobalResultConfig(ResultConfig resultConfig)
void | ActionConfig.addResultConfig(ResultConfig resultConfig)

Method parameters in com.opensymphony.xwork2.config.entities with type arguments of type ResultConfig
 void ActionConfig.setResults(Map<String,ResultConfig> results)

Constructor parameters in com.opensymphony.xwork2.config.entities with type arguments of type ResultConfig
ActionConfig(String methodName, Class clazz, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, Class clazz, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
ActionConfig(String methodName, String className, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, String className, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)
ActionConfig(String methodName, String className, String packageName, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors)
ActionConfig(String methodName, String className, String packageName, Map<String,Object> parameters, Map<String,ResultConfig> results, List<InterceptorMapping> interceptors, List<ExceptionMappingConfig> exceptionMappings)

Uses of ResultConfig in com.opensymphony.xwork2.config.impl

Method parameters in com.opensymphony.xwork2.config.impl with type arguments of type ResultConfig
private  void DefaultConfiguration.setDefaultResults(Map<String,ResultConfig> results, PackageConfig packageContext)

Uses of ResultConfig in org.apache.struts2.config

Methods in org.apache.struts2.config that return ResultConfig
private  ResultConfig ClasspathConfigurationProvider.ResultMap.createResultConfig(Object key, Class<? extends Object> resultClass, String location, Map<? extends Object,? extends Object> configParams)
Creates a default ResultConfig, using either the resultClass or the default ResultType for configuration package associated this ResultMap class.
protected  ResultConfig ClasspathConfigurationProvider.ResultMap.createResultConfig(Result result)
Extracts result name and value and calls ClasspathConfigurationProvider.ResultMap.createResultConfig(org.apache.struts2.config.Result).

Uses of ResultConfig in org.apache.struts2.impl

Methods in org.apache.struts2.impl with parameters of type ResultConfig
 Result StrutsObjectFactory.buildResult(ResultConfig resultConfig, Map extraContext)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.entities.ResultTypeConfig (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.entities.ResultTypeConfig

Packages that use ResultTypeConfig
com.opensymphony.xwork2.config.entities Configuration entity classes.

Uses of ResultTypeConfig in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities with type parameters of type ResultTypeConfig
private  Map<String,ResultTypeConfig> PackageConfig.resultTypeConfigs

Methods in com.opensymphony.xwork2.config.entities that return types with arguments of type ResultTypeConfig
Map<String,ResultTypeConfig> | PackageConfig.getAllResultTypeConfigs() returns the Map of all the ResultTypeConfigs available in the current package.
Map<String,ResultTypeConfig> | PackageConfig.getResultTypeConfigs() gets the ResultTypeConfigs local to this package

Methods in com.opensymphony.xwork2.config.entities with parameters of type ResultTypeConfig
 void PackageConfig.addResultTypeConfig(ResultTypeConfig config)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.config.impl (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.config.impl
Classes
ActionConfigMatcher
DefaultConfiguration
LocatableConstantFactory
LocatableFactory
MockConfiguration


Uses of Class com.opensymphony.xwork2.config.impl.ActionConfigMatcher (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.ActionConfigMatcher

Packages that use ActionConfigMatcher
com.opensymphony.xwork2.config.impl Configuration implementation classes.

Uses of ActionConfigMatcher in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl with type parameters of type ActionConfigMatcher
private  Map<String,ActionConfigMatcher> DefaultConfiguration.RuntimeConfigurationImpl.namespaceActionConfigMatchers

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping

No usage of com.opensymphony.xwork2.config.impl.ActionConfigMatcher.Mapping

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.DefaultConfiguration (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.DefaultConfiguration

No usage of com.opensymphony.xwork2.config.impl.DefaultConfiguration

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties

No usage of com.opensymphony.xwork2.config.impl.DefaultConfiguration.ContainerProperties

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl

No usage of com.opensymphony.xwork2.config.impl.DefaultConfiguration.RuntimeConfigurationImpl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.LocatableConstantFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.LocatableConstantFactory

No usage of com.opensymphony.xwork2.config.impl.LocatableConstantFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.LocatableFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.LocatableFactory

No usage of com.opensymphony.xwork2.config.impl.LocatableFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.impl.MockConfiguration (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.impl.MockConfiguration

No usage of com.opensymphony.xwork2.config.impl.MockConfiguration

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.config.providers (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.config.providers
Classes
InterceptorBuilder
XmlConfigurationProvider
XmlHelper


Uses of Class com.opensymphony.xwork2.config.providers.InterceptorBuilder (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.providers.InterceptorBuilder

No usage of com.opensymphony.xwork2.config.providers.InterceptorBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.providers.XmlConfigurationProvider (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.providers.XmlConfigurationProvider

Packages that use XmlConfigurationProvider
org.apache.struts2.config Classes for Struts configuration and property handling.

Uses of XmlConfigurationProvider in org.apache.struts2.config

Subclasses of XmlConfigurationProvider in org.apache.struts2.config
 class StrutsXmlConfigurationProvider
Override Xwork class so we can use an arbitrary config file

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.config.providers.XmlHelper (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.config.providers.XmlHelper

No usage of com.opensymphony.xwork2.config.providers.XmlHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.conversion.annotations (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.conversion.annotations
Enums
ConversionRule
ConversionType
Annotation Types
Conversion
TypeConversion


Uses of Class com.opensymphony.xwork2.conversion.annotations.Conversion (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.annotations.Conversion

No usage of com.opensymphony.xwork2.conversion.annotations.Conversion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.annotations.ConversionRule (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.annotations.ConversionRule

Packages that use ConversionRule
com.opensymphony.xwork2.conversion.annotations Type conversion annotations.

Uses of ConversionRule in com.opensymphony.xwork2.conversion.annotations

Methods in com.opensymphony.xwork2.conversion.annotations that return ConversionRule
static ConversionRule | ConversionRule.valueOf(String name) Returns the enum constant of this type with the specified name.
static ConversionRule[] | ConversionRule.values() Returns an array containing the constants of this enum type, in the order they're declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.annotations.ConversionType (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.annotations.ConversionType

Packages that use ConversionType
com.opensymphony.xwork2.conversion.annotations Type conversion annotations.

Uses of ConversionType in com.opensymphony.xwork2.conversion.annotations

Methods in com.opensymphony.xwork2.conversion.annotations that return ConversionType
static ConversionType | ConversionType.valueOf(String name) Returns the enum constant of this type with the specified name.
static ConversionType[] | ConversionType.values() Returns an array containing the constants of this enum type, in the order they're declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.conversion.annotations.TypeConversion (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.annotations.TypeConversion

No usage of com.opensymphony.xwork2.conversion.annotations.TypeConversion

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.conversion.metadata (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.conversion.metadata
Classes
ConversionDescription


Uses of Class com.opensymphony.xwork2.conversion.metadata.ConversionDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.conversion.metadata.ConversionDescription

No usage of com.opensymphony.xwork2.conversion.metadata.ConversionDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ConstructionContext.DelegatingInvocationHandler (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ConstructionContext.DelegatingInvocationHandler<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler<T>
All Implemented Interfaces:
InvocationHandler
Enclosing class:
ConstructionContext<T>
static class ConstructionContext.DelegatingInvocationHandler<T>
extends Object
implements InvocationHandler

Field Summary
(package private)  T delegate
Constructor Summary
ConstructionContext.DelegatingInvocationHandler()
Method Summary
Object | invoke(Object proxy, Method method, Object[] args)
(package private) void | setDelegate(T delegate)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

delegate

T delegate
Constructor Detail

ConstructionContext.DelegatingInvocationHandler

ConstructionContext.DelegatingInvocationHandler()
Method Detail

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] args)
              throws Throwable
Specified by:
invoke in interface InvocationHandler
Throws:
Throwable

setDelegate

void setDelegate(T delegate)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl.ConstructorInjector (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ContainerImpl.ConstructorInjector<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector<T>
Enclosing class:
ContainerImpl
static class ContainerImpl.ConstructorInjector<T>
extends Object

Field Summary
(package private) Constructor<T> | constructor
(package private) Class<T> | implementation
(package private) List<ContainerImpl.Injector> | injectors
(package private) ContainerImpl.ParameterInjector<?>[] | parameterInjectors
Constructor Summary
ContainerImpl.ConstructorInjector(ContainerImpl container, Class<T> implementation)
Method Summary
(package private) Object | construct(InternalContext context, Class<? super T> expectedType) Construct an instance.
private Constructor<T> | findConstructorIn(Class<T> implementation)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

implementation

final Class<T> implementation

injectors

final List<ContainerImpl.Injector> injectors

constructor

final Constructor<T> constructor

parameterInjectors

final ContainerImpl.ParameterInjector<?>[] parameterInjectors
Constructor Detail

ContainerImpl.ConstructorInjector

ContainerImpl.ConstructorInjector(ContainerImpl container,
                                  Class<T> implementation)
Method Detail

findConstructorIn

private Constructor<T> findConstructorIn(Class<T> implementation)

construct

Object construct(InternalContext context,
                 Class<? super T> expectedType)
Construct an instance. Returns Object instead of T because it may return a proxy.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl.ContextualCallable (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface ContainerImpl.ContextualCallable<T>

Enclosing class:
ContainerImpl
static interface ContainerImpl.ContextualCallable<T>

Method Summary
 T call(InternalContext context)

Method Detail

call

T call(InternalContext context)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl.InjectorFactory (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Interface ContainerImpl.InjectorFactory<M extends Member & AnnotatedElement>

Enclosing class:
ContainerImpl
static interface ContainerImpl.InjectorFactory<M extends Member & AnnotatedElement>

Method Summary
 ContainerImpl.Injector create(ContainerImpl container, M member, String name)

Method Detail

create

ContainerImpl.Injector create(ContainerImpl container,
                              M member,
                              String name)
                              throws ContainerImpl.MissingDependencyException
Throws:
ContainerImpl.MissingDependencyException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContainerImpl.ParameterInjector (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.inject
Class ContainerImpl.ParameterInjector<T>

java.lang.Object
    extended by  com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector<T>
Enclosing class:
ContainerImpl
static class ContainerImpl.ParameterInjector<T>
extends Object

Field Summary
(package private) ExternalContext<T> | externalContext
(package private) InternalFactory<? extends T> | factory
Constructor Summary
ContainerImpl.ParameterInjector(ExternalContext<T> externalContext, InternalFactory<? extends T> factory)
Method Summary
(package private)  T inject(Member member, InternalContext context)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

externalContext

final ExternalContext<T> externalContext

factory

final InternalFactory<? extends T> factory
Constructor Detail

ContainerImpl.ParameterInjector

public ContainerImpl.ParameterInjector(ExternalContext<T> externalContext,
                                       InternalFactory<? extends T> factory)
Method Detail

inject

T inject(Member member,
         InternalContext context)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.inject (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.inject
Interfaces
Container
ContainerBuilder.Command
ContainerImpl.ContextualCallable
ContainerImpl.Injector
ContainerImpl.InjectorFactory
Context
Factory
InternalFactory
Scope.Strategy
Classes
ConstructionContext
ConstructionContext.DelegatingInvocationHandler
ContainerBuilder
ContainerImpl
ContainerImpl.ConstructorInjector
ContainerImpl.FieldInjector
ContainerImpl.MethodInjector
ContainerImpl.ParameterInjector
ExternalContext
InternalContext
Key
Enums
Scope
Exceptions
ContainerImpl.MissingDependencyException
DependencyException
Annotation Types
Inject
Scoped


Uses of Class com.opensymphony.xwork2.inject.ConstructionContext (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ConstructionContext

Packages that use ConstructionContext
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ConstructionContext in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject with type parameters of type ConstructionContext
(package private)  Map<Object,ConstructionContext<?>> InternalContext.constructionContexts

Methods in com.opensymphony.xwork2.inject that return ConstructionContext
(package private)
<T> ConstructionContext<T>
InternalContext.getConstructionContext(Object key)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ConstructionContext.DelegatingInvocationHandler

Packages that use ConstructionContext.DelegatingInvocationHandler
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ConstructionContext.DelegatingInvocationHandler in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject with type parameters of type ConstructionContext.DelegatingInvocationHandler
(package private)  List<ConstructionContext.DelegatingInvocationHandler<T>> ConstructionContext.invocationHandlers

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.Container (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.Container

Packages that use Container
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
org.apache.struts2.components |
org.apache.struts2.components.template |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.velocity | Classes for views using Velocity.

Uses of Container in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as Container
protected Container | DefaultActionProxyFactory.container
private Container | ObjectFactory.container
protected Container | TestNGXWorkTestCase.container
protected Container | XWorkTestCase.container

Methods in com.opensymphony.xwork2 with parameters of type Container
void | DefaultActionProxyFactory.setContainer(Container container)
void | ObjectFactory.setContainer(Container container)

Uses of Container in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config that return Container
 Container Configuration.getContainer()

Uses of Container in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl declared as Container
protected Container | DefaultConfiguration.container
private Container | MockConfiguration.container

Methods in com.opensymphony.xwork2.config.impl that return Container
Container | DefaultConfiguration.getContainer()
Container | MockConfiguration.getContainer()

Uses of Container in com.opensymphony.xwork2.inject

Classes in com.opensymphony.xwork2.inject that implement Container
(package private)  class ContainerImpl
Default Container implementation.

Fields in com.opensymphony.xwork2.inject with type parameters of type Container
private static InternalFactory<Container> ContainerBuilder.CONTAINER_FACTORY

Methods in com.opensymphony.xwork2.inject that return Container
Container | ContainerBuilder.create(boolean loadSingletons) Creates a Container instance.
Container | Context.getContainer() Gets the Container.
Container | ExternalContext.getContainer()
Container | InternalContext.getContainer()

Uses of Container in org.apache.struts2.components

Methods in org.apache.struts2.components with parameters of type Container
 void OptGroup.setContainer(Container container)

Uses of Container in org.apache.struts2.components.template

Fields in org.apache.struts2.components.template declared as Container
(package private)  Container TemplateEngineManager.container

Methods in org.apache.struts2.components.template with parameters of type Container
 void TemplateEngineManager.setContainer(Container container)

Uses of Container in org.apache.struts2.dispatcher

Methods in org.apache.struts2.dispatcher that return Container
Container | Dispatcher.getContainer() Expose the dependency injection container.
private Container | Dispatcher.init_PreloadConfiguration()

Methods in org.apache.struts2.dispatcher with parameters of type Container
private void | Dispatcher.init_CheckConfigurationReloading(Container container)
private void | Dispatcher.init_CheckWebLogicWorkaround(Container container)

Uses of Container in org.apache.struts2.dispatcher.mapper

Fields in org.apache.struts2.dispatcher.mapper declared as Container
private Container | DefaultActionMapper.container
protected Container | CompositeActionMapper.container

Methods in org.apache.struts2.dispatcher.mapper with parameters of type Container
void | DefaultActionMapper.setContainer(Container container)
void | CompositeActionMapper.setContainer(Container container)

Uses of Container in org.apache.struts2.views.freemarker

Methods in org.apache.struts2.views.freemarker with parameters of type Container
 void FreemarkerManager.setContainer(Container container)

Uses of Container in org.apache.struts2.views.velocity

Methods in org.apache.struts2.views.velocity with parameters of type Container
 void VelocityManager.setContainer(Container container)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ContainerBuilder (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ContainerBuilder

Packages that use ContainerBuilder
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
org.apache.struts2.config | Classes for Struts configuration and property handling.

Uses of ContainerBuilder in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config with parameters of type ContainerBuilder
 void ConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)

Uses of ContainerBuilder in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl with parameters of type ContainerBuilder
 void DefaultConfiguration.ContainerProperties.setConstants(ContainerBuilder builder)

Uses of ContainerBuilder in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type ContainerBuilder
 void XmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)

Uses of ContainerBuilder in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject that return ContainerBuilder
<T> ContainerBuilder
ContainerBuilder.alias(Class<T> type, String alias)
Convenience method. Equivalent to alias(type, Container.DEFAULT_NAME, type).
<T> ContainerBuilder
ContainerBuilder.alias(Class<T> type, String name, String alias)
Maps an existing factory to a new name.
private
<T> ContainerBuilder
ContainerBuilder.alias(Key<T> key, Key<T> aliasKey)
Maps an existing dependency.
private
<T> ContainerBuilder
ContainerBuilder.constant(Class<T> type, String name, T value)
Maps a constant value to the given type and name.
 ContainerBuilder ContainerBuilder.constant(String name, boolean value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, char value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, Class value)
Maps a class to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, double value)
Maps a constant value to the given name.
<E extends Enum<E>>
ContainerBuilder
ContainerBuilder.constant(String name, E value)
Maps an enum to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, float value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, int value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, long value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, short value)
Maps a constant value to the given name.
 ContainerBuilder ContainerBuilder.constant(String name, String value)
Maps a constant value to the given name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Class<? extends T> implementation)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Class<? extends T> implementation, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name)
Convenience method. Equivalent to factory(type, name, type).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Class<? extends T> implementation)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Class<? extends T> implementation, Scope scope)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory, Scope scope)
Maps a factory to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Scope scope)
Convenience method. Equivalent to factory(type, name, type, scope).
private
<T> ContainerBuilder
ContainerBuilder.factory(Key<T> key, InternalFactory<? extends T> factory, Scope scope)
Maps a dependency.
 ContainerBuilder ContainerBuilder.injectStatics(Class<?>... types)
Upon creation, the Container will inject static fields and methods into the given classes.

Methods in com.opensymphony.xwork2.inject with parameters of type ContainerBuilder
 void ContainerBuilder.Command.build(ContainerBuilder builder)
Contributes factories to the given builder.

Uses of ContainerBuilder in org.apache.struts2.config

Methods in org.apache.struts2.config with parameters of type ContainerBuilder
(package private) void | BeanSelectionProvider.alias(Class type, String key, ContainerBuilder builder, Properties props)
(package private) void | BeanSelectionProvider.alias(Class type, String key, ContainerBuilder builder, Properties props, Scope scope)
void | StrutsXmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)
void | MethodConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties locatableProperties)
void | LegacyPropertiesConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | DefaultPropertiesProvider.register(ContainerBuilder builder, LocatableProperties props)
void | ClasspathConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | BeanSelectionProvider.register(ContainerBuilder builder, LocatableProperties props)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.ContainerBuilder.Command (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.ContainerBuilder.Command

No usage of com.opensymphony.xwork2.inject.ContainerBuilder.Command

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ContainerImpl (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ContainerImpl

Packages that use ContainerImpl
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ContainerImpl in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject declared as ContainerImpl
(package private) ContainerImpl | ExternalContext.container
(package private) ContainerImpl | InternalContext.container

Methods in com.opensymphony.xwork2.inject that return ContainerImpl
(package private)  ContainerImpl InternalContext.getContainerImpl()

Methods in com.opensymphony.xwork2.inject with parameters of type ContainerImpl
 ContainerImpl.Injector ContainerImpl.InjectorFactory.create(ContainerImpl container, M member, String name)
(package private) static
<T> ExternalContext<T>
ExternalContext.newInstance(Member member, Key<T> key, ContainerImpl container)

Constructors in com.opensymphony.xwork2.inject with parameters of type ContainerImpl
ContainerImpl.ConstructorInjector(ContainerImpl container, Class<T> implementation)
ContainerImpl.FieldInjector(ContainerImpl container, Field field, String name)
ContainerImpl.MethodInjector(ContainerImpl container, Method method, String name)
ExternalContext(Member member, Key<T> key, ContainerImpl container)
InternalContext(ContainerImpl container)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ContainerImpl.ConstructorInjector

Packages that use ContainerImpl.ConstructorInjector
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ContainerImpl.ConstructorInjector in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject with type parameters of type ContainerImpl.ConstructorInjector
(package private)  Map<Class<?>,ContainerImpl.ConstructorInjector> ContainerImpl.constructors

Methods in com.opensymphony.xwork2.inject that return ContainerImpl.ConstructorInjector
(package private)
<T> ContainerImpl.ConstructorInjector<T>
ContainerImpl.getConstructor(Class<T> implementation)
Gets a constructor function for a given implementation class.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.ContainerImpl.ContextualCallable (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.ContainerImpl.ContextualCallable

Packages that use ContainerImpl.ContextualCallable
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ContainerImpl.ContextualCallable in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject with parameters of type ContainerImpl.ContextualCallable
(package private)
<T> T
ContainerImpl.callInContext(ContainerImpl.ContextualCallable<T> callable)
Looks up thread local context.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector

No usage of com.opensymphony.xwork2.inject.ContainerImpl.FieldInjector

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.ContainerImpl.Injector (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.ContainerImpl.Injector

Packages that use ContainerImpl.Injector
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ContainerImpl.Injector in com.opensymphony.xwork2.inject

Classes in com.opensymphony.xwork2.inject that implement ContainerImpl.Injector
(package private) static class | ContainerImpl.FieldInjector
(package private) static class | ContainerImpl.MethodInjector

Fields in com.opensymphony.xwork2.inject with type parameters of type ContainerImpl.Injector
(package private) Map<Class<?>,List<ContainerImpl.Injector>> | ContainerImpl.injectors Field and method injectors.
(package private) List<ContainerImpl.Injector> | ContainerImpl.ConstructorInjector.injectors

Methods in com.opensymphony.xwork2.inject that return ContainerImpl.Injector
 ContainerImpl.Injector ContainerImpl.InjectorFactory.create(ContainerImpl container, M member, String name)

Method parameters in com.opensymphony.xwork2.inject with type arguments of type ContainerImpl.Injector
(package private)  void ContainerImpl.addInjectors(Class clazz, List<ContainerImpl.Injector> injectors)
Recursively adds injectors for fields and methods from the given class to the given list.
(package private)  void ContainerImpl.addInjectorsForFields(Field[] fields, boolean statics, List<ContainerImpl.Injector> injectors)
(package private)
<M extends Member & AnnotatedElement>
void
ContainerImpl.addInjectorsForMembers(List<M> members, boolean statics, List<ContainerImpl.Injector> injectors, ContainerImpl.InjectorFactory<M> injectorFactory)
(package private)  void ContainerImpl.addInjectorsForMethods(Method[] methods, boolean statics, List<ContainerImpl.Injector> injectors)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.ContainerImpl.InjectorFactory (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.ContainerImpl.InjectorFactory

Packages that use ContainerImpl.InjectorFactory
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ContainerImpl.InjectorFactory in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject with parameters of type ContainerImpl.InjectorFactory
(package private)
<M extends Member & AnnotatedElement>
void
ContainerImpl.addInjectorsForMembers(List<M> members, boolean statics, List<ContainerImpl.Injector> injectors, ContainerImpl.InjectorFactory<M> injectorFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector

No usage of com.opensymphony.xwork2.inject.ContainerImpl.MethodInjector

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ContainerImpl.MissingDependencyException (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ContainerImpl.MissingDependencyException

Packages that use ContainerImpl.MissingDependencyException
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ContainerImpl.MissingDependencyException in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject that throw ContainerImpl.MissingDependencyException
 ContainerImpl.Injector ContainerImpl.InjectorFactory.create(ContainerImpl container, M member, String name)
(package private)
<T> ContainerImpl.ParameterInjector<T>
ContainerImpl.createParameterInjector(Key<T> key, Member member)
(package private)
<M extends AccessibleObject & Member>
ContainerImpl.ParameterInjector<?>[]
ContainerImpl.getParametersInjectors(M member, Annotation[][] annotations, Class[] parameterTypes, String defaultName)
Gets parameter injectors.

Constructors in com.opensymphony.xwork2.inject that throw ContainerImpl.MissingDependencyException
ContainerImpl.FieldInjector(ContainerImpl container, Field field, String name)
ContainerImpl.MethodInjector(ContainerImpl container, Method method, String name)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ContainerImpl.ParameterInjector

Packages that use ContainerImpl.ParameterInjector
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ContainerImpl.ParameterInjector in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject declared as ContainerImpl.ParameterInjector
(package private) ContainerImpl.ParameterInjector<?>[] | ContainerImpl.MethodInjector.parameterInjectors
(package private) ContainerImpl.ParameterInjector<?>[] | ContainerImpl.ConstructorInjector.parameterInjectors

Methods in com.opensymphony.xwork2.inject that return ContainerImpl.ParameterInjector
(package private)
<T> ContainerImpl.ParameterInjector<T>
ContainerImpl.createParameterInjector(Key<T> key, Member member)
(package private)
<M extends AccessibleObject & Member>
ContainerImpl.ParameterInjector<?>[]
ContainerImpl.getParametersInjectors(M member, Annotation[][] annotations, Class[] parameterTypes, String defaultName)
Gets parameter injectors.
private  ContainerImpl.ParameterInjector<?>[] ContainerImpl.toArray(List<ContainerImpl.ParameterInjector<?>> parameterInjections)

Methods in com.opensymphony.xwork2.inject with parameters of type ContainerImpl.ParameterInjector
private static Object[] ContainerImpl.getParameters(Member member, InternalContext context, ContainerImpl.ParameterInjector[] parameterInjectors)

Method parameters in com.opensymphony.xwork2.inject with type arguments of type ContainerImpl.ParameterInjector
private  ContainerImpl.ParameterInjector<?>[] ContainerImpl.toArray(List<ContainerImpl.ParameterInjector<?>> parameterInjections)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.Context (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.Context

Packages that use Context
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
org.apache.struts2.config | Classes for Struts configuration and property handling.

Uses of Context in com.opensymphony.xwork2.config.impl

Methods in com.opensymphony.xwork2.config.impl with parameters of type Context
T | LocatableConstantFactory.create(Context ignored)
T | LocatableFactory.create(Context context)

Uses of Context in com.opensymphony.xwork2.inject

Classes in com.opensymphony.xwork2.inject that implement Context
(package private)  class ExternalContext<T>
An immutable snapshot of the current context which is safe to expose to client code.

Methods in com.opensymphony.xwork2.inject with parameters of type Context
 T Factory.create(Context context)
Creates an object to be injected.

Uses of Context in org.apache.struts2.config

Methods in org.apache.struts2.config with parameters of type Context
 Object BeanSelectionProvider.ObjectFactoryDelegateFactory.create(Context context)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.DependencyException (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.DependencyException

No usage of com.opensymphony.xwork2.inject.DependencyException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.ExternalContext (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.ExternalContext

Packages that use ExternalContext
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of ExternalContext in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject declared as ExternalContext
(package private) ExternalContext<?> | ContainerImpl.FieldInjector.externalContext
(package private) ExternalContext<T> | ContainerImpl.ParameterInjector.externalContext
(package private) ExternalContext<?> | InternalContext.externalContext

Methods in com.opensymphony.xwork2.inject that return ExternalContext
(package private)
<T> ExternalContext<T>
InternalContext.getExternalContext()
(package private) static
<T> ExternalContext<T>
ExternalContext.newInstance(Member member, Key<T> key, ContainerImpl container)

Methods in com.opensymphony.xwork2.inject with parameters of type ExternalContext
(package private)  void InternalContext.setExternalContext(ExternalContext<?> externalContext)

Constructors in com.opensymphony.xwork2.inject with parameters of type ExternalContext
ContainerImpl.ParameterInjector(ExternalContext<T> externalContext, InternalFactory<? extends T> factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.Factory (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.Factory

Packages that use Factory
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
org.apache.struts2.config | Classes for Struts configuration and property handling.

Uses of Factory in com.opensymphony.xwork2.config.impl

Classes in com.opensymphony.xwork2.config.impl that implement Factory
class | LocatableConstantFactory<T> Factory that remembers where a constant came from
class | LocatableFactory<T> Attaches location information to the factory.

Uses of Factory in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject with parameters of type Factory
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, Scope.DEFAULT).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory)
Convenience method. Equivalent to factory(type, name, factory, Scope.DEFAULT).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory, Scope scope)
Maps a factory to a given dependency type and name.

Uses of Factory in org.apache.struts2.config

Classes in org.apache.struts2.config that implement Factory
(package private)  class BeanSelectionProvider.ObjectFactoryDelegateFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.Inject (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.Inject

Packages that use Inject
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.util | XWork util classes.
org.apache.struts2.components |
org.apache.struts2.components.template |
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.dispatcher.multipart | Classes to help dispatch multipart HTTP requests.
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.debugging |
org.apache.struts2.portlet.result |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.util | Miscellaneous helper classes for all views.
org.apache.struts2.views.velocity | Classes for views using Velocity.
org.apache.struts2.views.xslt | The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of Inject in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with annotations of type Inject
void | DefaultActionProxy.setActionEventListener(ActionEventListener listener)
void | ActionChainResult.setActionProxyFactory(ActionProxyFactory actionProxyFactory)
void | ObjectFactory.setClassLoader(ClassLoader cl)
void | DefaultActionProxy.setConfiguration(Configuration config)
void | DefaultActionProxyFactory.setContainer(Container container)
void | ObjectFactory.setContainer(Container container)
void | DefaultActionProxy.setObjectFactory(ObjectFactory factory)
static void | ObjectFactory.setObjectFactory(ObjectFactory factory)
void | DefaultActionProxy.setUnknownHandler(UnknownHandler handler)

Uses of Inject in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with annotations of type Inject
 void XmlConfigurationProvider.setObjectFactory(ObjectFactory objectFactory)

Uses of Inject in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject that return Inject
(package private)  Inject ContainerImpl.findInject(Annotation[] annotations)
Finds the Inject annotation in an array of annotations.

Uses of Inject in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with annotations of type Inject
static void | ParametersInterceptor.setDevMode(String mode)
void | ScopedModelDrivenInterceptor.setObjectFactory(ObjectFactory factory)

Uses of Inject in com.opensymphony.xwork2.spring

Methods in com.opensymphony.xwork2.spring with annotations of type Inject
 void SpringObjectFactory.setApplicationContextPath(String ctx)

Uses of Inject in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util with annotations of type Inject
static void | OgnlValueStack.setDevMode(String mode)
static void | XWorkConverter.setInstance(XWorkConverter instance)

Uses of Inject in org.apache.struts2.components

Methods in org.apache.struts2.components with annotations of type Inject
void | Component.setActionMapper(ActionMapper mapper)
void | ActionComponent.setActionProxyFactory(ActionProxyFactory actionProxyFactory)
void | Form.setConfiguration(Configuration configuration)
void | OptGroup.setContainer(Container container)
static void | Include.setDefaultEncoding(String encoding)
void | UIBean.setDefaultTemplateDir(String dir)
void | UIBean.setDefaultUITheme(String theme)
void | Form.setEnableDynamicMethodInvocation(String enable)
void | Head.setEncoding(String encoding)
void | URL.setExtraParameterProvider(URL.ExtraParameterProvider provider)
void | Form.setObjectFactory(ObjectFactory objectFactory)
void | Bean.setObjectFactory(ObjectFactory objectFactory)
void | UIBean.setTemplateEngineManager(TemplateEngineManager mgr)
void | URL.setUrlIncludeParams(String urlIncludeParams)

Uses of Inject in org.apache.struts2.components.template

Methods in org.apache.struts2.components.template with annotations of type Inject
void | TemplateEngineManager.setContainer(Container container)
void | TemplateEngineManager.setDefaultTemplateType(String type)
void | FreemarkerTemplateEngine.setFreemarkerManager(FreemarkerManager mgr)
void | VelocityTemplateEngine.setVelocityManager(VelocityManager mgr)

Uses of Inject in org.apache.struts2.config

Methods in org.apache.struts2.config with annotations of type Inject
void | ClasspathConfigurationProvider.setDefaultPageExtension(String defaultPageExtension) Register a default page extension to use when locating pages.
void | ClasspathConfigurationProvider.setDefaultPagePrefix(String defaultPagePrefix) Reigster a default page prefix to use when locating pages.
void | ClasspathConfigurationProvider.setDefaultParentPackage(String defaultParentPackage) Register a default parent package for the actions.
void | ClasspathConfigurationProvider.setForceLowerCase(String force) Whether to use a lowercase letter as the initial letter of an action.

Uses of Inject in org.apache.struts2.dispatcher

Methods in org.apache.struts2.dispatcher with annotations of type Inject
void | ServletRedirectResult.setActionMapper(ActionMapper mapper)
static void | FilterDispatcher.setActionMapper(ActionMapper mapper) Modify ActionMapper instance.
void | VelocityResult.setDefaultEncoding(String val)
static void | Dispatcher.setDefaultEncoding(String val) Modify state of StrutsConstants.STRUTS_I18N_ENCODING setting.
static void | Dispatcher.setDefaultLocale(String val) Modify state of StrutsConstants.STRUTS_LOCALE setting.
static void | Dispatcher.setDevMode(String mode) Modify state of StrutsConstants.STRUTS_DEVMODE setting.
static void | FilterDispatcher.setEncoding(String val) Modify state of StrutsConstants.STRUTS_I18N_ENCODING setting.
static void | Dispatcher.setMultipartSaveDir(String val) Modify state of StrutsConstants.STRUTS_MULTIPART_SAVEDIR setting.
static void | FilterDispatcher.setServeStaticBrowserCache(String val) Modify state of StrutsConstants.STRUTS_SERVE_STATIC_BROWSER_CACHE setting.
static void | FilterDispatcher.setServeStaticContent(String val) Modify state of StrutsConstants.STRUTS_SERVE_STATIC_CONTENT setting.
void | VelocityResult.setVelocityManager(VelocityManager mgr)

Uses of Inject in org.apache.struts2.dispatcher.mapper

Methods in org.apache.struts2.dispatcher.mapper with annotations of type Inject
void | CompositeActionMapper.setActionMappers(String list)
void | DefaultActionMapper.setAllowDynamicMethodCalls(String allow)
void | DefaultActionMapper.setAlwaysSelectFullNamespace(String val)
void | DefaultActionMapper.setContainer(Container container)
void | CompositeActionMapper.setContainer(Container container)
void | DefaultActionMapper.setExtensions(String extensions)
void | DefaultActionMapper.setSlashesInActionNames(String allow)

Uses of Inject in org.apache.struts2.dispatcher.multipart

Methods in org.apache.struts2.dispatcher.multipart with annotations of type Inject
 void JakartaMultiPartRequest.setMaxSize(String maxSize)

Uses of Inject in org.apache.struts2.interceptor

Methods in org.apache.struts2.interceptor with annotations of type Inject
 void ProfilingActivationInterceptor.setDevMode(String mode)

Uses of Inject in org.apache.struts2.interceptor.debugging

Methods in org.apache.struts2.interceptor.debugging with annotations of type Inject
void | DebuggingInterceptor.setDevMode(String mode)
void | DebuggingInterceptor.setFreemarkerManager(FreemarkerManager mgr)

Uses of Inject in org.apache.struts2.portlet.result

Methods in org.apache.struts2.portlet.result with annotations of type Inject
void | PortletVelocityResult.setDefaultEncoding(String encoding)
void | PortletVelocityResult.setVelocityManager(VelocityManager mgr)

Uses of Inject in org.apache.struts2.views.freemarker

Methods in org.apache.struts2.views.freemarker with annotations of type Inject
void | FreemarkerManager.setContainer(Container container)
void | FreemarkerManager.setEncoding(String encoding)
void | PortletFreemarkerResult.setFreemarkerManager(FreemarkerManager mgr)
void | FreemarkerResult.setFreemarkerManager(FreemarkerManager mgr)
void | FreemarkerManager.setWrapperAltMap(String val)

Uses of Inject in org.apache.struts2.views.util

Methods in org.apache.struts2.views.util with annotations of type Inject
static void | ContextUtil.setAltSyntax(String val)
static void | UrlHelper.setCustomEncoding(String val)
static void | UrlHelper.setHttpPort(String val)
static void | UrlHelper.setHttpsPort(String val)

Uses of Inject in org.apache.struts2.views.velocity

Methods in org.apache.struts2.views.velocity with annotations of type Inject
void | VelocityManager.setChainedContexts(String contexts) allow users to specify via the struts.properties file a set of additional VelocityContexts to chain to the the StrutsVelocityContext.
void | VelocityManager.setContainer(Container container)
void | VelocityManager.setCustomConfigFile(String val)
void | VelocityManager.setObjectFactory(ObjectFactory fac)
void | VelocityManager.setToolBoxLocation(String toolboxLocation)

Uses of Inject in org.apache.struts2.views.xslt

Methods in org.apache.struts2.views.xslt with annotations of type Inject
 void XSLTResult.setNoCache(String val)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.InternalContext (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.InternalContext

Packages that use InternalContext
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of InternalContext in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject with parameters of type InternalContext
 T ContainerImpl.ContextualCallable.call(InternalContext context)
(package private)  Object ContainerImpl.ConstructorInjector.construct(InternalContext context, Class<? super T> expectedType)
Construct an instance.
 T InternalFactory.create(InternalContext context)
Creates an object to be injected.
(package private)
<T> T
ContainerImpl.getInstance(Class<T> type, InternalContext context)
(package private)
<T> T
ContainerImpl.getInstance(Class<T> type, String name, InternalContext context)
private static Object[] ContainerImpl.getParameters(Member member, InternalContext context, ContainerImpl.ParameterInjector[] parameterInjectors)
(package private)
<T> T
ContainerImpl.inject(Class<T> implementation, InternalContext context)
 void ContainerImpl.FieldInjector.inject(InternalContext context, Object o)
 void ContainerImpl.MethodInjector.inject(InternalContext context, Object o)
 void ContainerImpl.Injector.inject(InternalContext context, Object o)
(package private)  T ContainerImpl.ParameterInjector.inject(Member member, InternalContext context)
(package private)  void ContainerImpl.inject(Object o, InternalContext context)
(package private)
<T> Callable<? extends T>
Scope.toCallable(InternalContext context, InternalFactory<? extends T> factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.InternalFactory (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.InternalFactory

Packages that use InternalFactory
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of InternalFactory in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject declared as InternalFactory
private static InternalFactory<Container> | ContainerBuilder.CONTAINER_FACTORY
(package private) InternalFactory<?> | ContainerImpl.FieldInjector.factory
(package private) InternalFactory<? extends T> | ContainerImpl.ParameterInjector.factory
private static InternalFactory<Logger> | ContainerBuilder.LOGGER_FACTORY

Fields in com.opensymphony.xwork2.inject with type parameters of type InternalFactory
(package private) Map<Key<?>,InternalFactory<?>> | ContainerBuilder.factories
(package private) Map<Key<?>,InternalFactory<?>> | ContainerImpl.factories
(package private) List<InternalFactory<?>> | ContainerBuilder.singletonFactories

Methods in com.opensymphony.xwork2.inject that return InternalFactory
(package private)
<T> InternalFactory<? extends T>
ContainerImpl.getFactory(Key<T> key)
(package private) abstract
<T> InternalFactory<? extends T>
Scope.scopeFactory(Class<T> type, String name, InternalFactory<? extends T> factory)
Wraps factory with scoping logic.

Methods in com.opensymphony.xwork2.inject with parameters of type InternalFactory
private
<T> ContainerBuilder
ContainerBuilder.factory(Key<T> key, InternalFactory<? extends T> factory, Scope scope)
Maps a dependency.
(package private) abstract
<T> InternalFactory<? extends T>
Scope.scopeFactory(Class<T> type, String name, InternalFactory<? extends T> factory)
Wraps factory with scoping logic.
(package private)
<T> Callable<? extends T>
Scope.toCallable(InternalContext context, InternalFactory<? extends T> factory)

Constructors in com.opensymphony.xwork2.inject with parameters of type InternalFactory
ContainerImpl.ParameterInjector(ExternalContext<T> externalContext, InternalFactory<? extends T> factory)

Constructor parameters in com.opensymphony.xwork2.inject with type arguments of type InternalFactory
ContainerImpl(Map<Key<?>,InternalFactory<?>> factories)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.Key (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.Key

Packages that use Key
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of Key in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject declared as Key
(package private)  Key<T> ExternalContext.key

Fields in com.opensymphony.xwork2.inject with type parameters of type Key
(package private) Map<Key<?>,InternalFactory<?>> | ContainerBuilder.factories
(package private) Map<Key<?>,InternalFactory<?>> | ContainerImpl.factories

Methods in com.opensymphony.xwork2.inject that return Key
(package private) static
<T> Key<T>
Key.newInstance(Class<T> type, String name)

Methods in com.opensymphony.xwork2.inject with parameters of type Key
private
<T> ContainerBuilder
ContainerBuilder.alias(Key<T> key, Key<T> aliasKey)
Maps an existing dependency.
private
<T> ContainerBuilder
ContainerBuilder.alias(Key<T> key, Key<T> aliasKey)
Maps an existing dependency.
private  void ContainerBuilder.checkKey(Key<?> key)
Ensures a key isn't already mapped.
(package private)
<T> ContainerImpl.ParameterInjector<T>
ContainerImpl.createParameterInjector(Key<T> key, Member member)
private
<T> ContainerBuilder
ContainerBuilder.factory(Key<T> key, InternalFactory<? extends T> factory, Scope scope)
Maps a dependency.
(package private)
<T> InternalFactory<? extends T>
ContainerImpl.getFactory(Key<T> key)
(package private) static
<T> ExternalContext<T>
ExternalContext.newInstance(Member member, Key<T> key, ContainerImpl container)

Constructors in com.opensymphony.xwork2.inject with parameters of type Key
ExternalContext(Member member, Key<T> key, ContainerImpl container)

Constructor parameters in com.opensymphony.xwork2.inject with type arguments of type Key
ContainerImpl(Map<Key<?>,InternalFactory<?>> factories)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.Scope (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.Scope

Packages that use Scope
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.inject | Guice (pronounced "juice").
org.apache.struts2.config | Classes for Struts configuration and property handling.

Uses of Scope in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl declared as Scope
private  Scope LocatableFactory.scope

Constructors in com.opensymphony.xwork2.config.impl with parameters of type Scope
LocatableFactory(String name, Class type, Class implementation, Scope scope, Object location)

Uses of Scope in com.opensymphony.xwork2.inject

Methods in com.opensymphony.xwork2.inject that return Scope
static Scope | Scope.valueOf(String name) Returns the enum constant of this type with the specified name.
static Scope[] | Scope.values() Returns an array containing the constants of this enum type, in the order they're declared.

Methods in com.opensymphony.xwork2.inject with parameters of type Scope
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Class<? extends T> implementation, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, implementation, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Factory<? extends T> factory, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, factory, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, Scope scope)
Convenience method. Equivalent to factory(type, Container.DEFAULT_NAME, type, scope).
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Class<? extends T> implementation, Scope scope)
Maps an implementation class to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Factory<? extends T> factory, Scope scope)
Maps a factory to a given dependency type and name.
<T> ContainerBuilder
ContainerBuilder.factory(Class<T> type, String name, Scope scope)
Convenience method. Equivalent to factory(type, name, type, scope).
private
<T> ContainerBuilder
ContainerBuilder.factory(Key<T> key, InternalFactory<? extends T> factory, Scope scope)
Maps a dependency.

Uses of Scope in org.apache.struts2.config

Methods in org.apache.struts2.config with parameters of type Scope
(package private)  void BeanSelectionProvider.alias(Class type, String key, ContainerBuilder builder, Properties props, Scope scope)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.Scope.Strategy (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.Scope.Strategy

Packages that use Scope.Strategy
com.opensymphony.xwork2.inject Guice (pronounced "juice").

Uses of Scope.Strategy in com.opensymphony.xwork2.inject

Fields in com.opensymphony.xwork2.inject declared as Scope.Strategy
(package private)  Scope.Strategy InternalContext.scopeStrategy

Fields in com.opensymphony.xwork2.inject with type parameters of type Scope.Strategy
(package private)  ThreadLocal<Scope.Strategy> ContainerImpl.localScopeStrategy

Methods in com.opensymphony.xwork2.inject that return Scope.Strategy
Scope.Strategy | Context.getScopeStrategy() Gets the current scope strategy.
Scope.Strategy | ExternalContext.getScopeStrategy()
(package private) Scope.Strategy | InternalContext.getScopeStrategy()

Methods in com.opensymphony.xwork2.inject with parameters of type Scope.Strategy
void | Container.setScopeStrategy(Scope.Strategy scopeStrategy) Sets the scope strategy for the current thread.
void | ContainerImpl.setScopeStrategy(Scope.Strategy scopeStrategy)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.Scoped (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.Scoped

No usage of com.opensymphony.xwork2.inject.Scoped

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.inject.util (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.inject.util
Interfaces
FinalizableReference
Function
ReferenceMap.InternalReference
ReferenceMap.Strategy
Classes
FinalizablePhantomReference
FinalizableReferenceQueue
FinalizableSoftReference
FinalizableWeakReference
ReferenceCache
ReferenceMap
ReferenceMap.KeyReferenceAwareWrapper
ReferenceMap.ReferenceAwareWrapper
Strings
Enums
ReferenceMap.PutStrategy
ReferenceType


Uses of Class com.opensymphony.xwork2.inject.util.FinalizablePhantomReference (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.FinalizablePhantomReference

No usage of com.opensymphony.xwork2.inject.util.FinalizablePhantomReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.util.FinalizableReference (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.util.FinalizableReference

Packages that use FinalizableReference
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of FinalizableReference in com.opensymphony.xwork2.inject.util

Classes in com.opensymphony.xwork2.inject.util that implement FinalizableReference
class | FinalizablePhantomReference<T> Phantom reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
class | FinalizableSoftReference<T> Soft reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
class | FinalizableWeakReference<T> Weak reference with a finalizeReferent() method which a background thread invokes after the garbage collector reclaims the referent.
(package private) class | ReferenceMap.SoftKeyReference
(package private) class | ReferenceMap.SoftValueReference
(package private) class | ReferenceMap.WeakKeyReference
(package private) class | ReferenceMap.WeakValueReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.FinalizableReferenceQueue

Packages that use FinalizableReferenceQueue
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of FinalizableReferenceQueue in com.opensymphony.xwork2.inject.util

Methods in com.opensymphony.xwork2.inject.util that return FinalizableReferenceQueue
(package private) static FinalizableReferenceQueue FinalizableReferenceQueue.createAndStart()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.FinalizableSoftReference (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.FinalizableSoftReference

Packages that use FinalizableSoftReference
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of FinalizableSoftReference in com.opensymphony.xwork2.inject.util

Subclasses of FinalizableSoftReference in com.opensymphony.xwork2.inject.util
(package private) class | ReferenceMap.SoftKeyReference
(package private) class | ReferenceMap.SoftValueReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.FinalizableWeakReference (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.FinalizableWeakReference

Packages that use FinalizableWeakReference
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of FinalizableWeakReference in com.opensymphony.xwork2.inject.util

Subclasses of FinalizableWeakReference in com.opensymphony.xwork2.inject.util
(package private) class | ReferenceMap.WeakKeyReference
(package private) class | ReferenceMap.WeakValueReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.util.Function (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.util.Function

Packages that use Function
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of Function in com.opensymphony.xwork2.inject.util

Methods in com.opensymphony.xwork2.inject.util with parameters of type Function
static
<K,V> ReferenceCache<K,V>
ReferenceCache.of(ReferenceType keyReferenceType, ReferenceType valueReferenceType, Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceCache (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceCache

Packages that use ReferenceCache
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceCache in com.opensymphony.xwork2.inject.util

Methods in com.opensymphony.xwork2.inject.util that return ReferenceCache
static
<K,V> ReferenceCache<K,V>
ReferenceCache.of(ReferenceType keyReferenceType, ReferenceType valueReferenceType, Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate

No usage of com.opensymphony.xwork2.inject.util.ReferenceCache.CallableCreate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap

Packages that use ReferenceMap
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceMap in com.opensymphony.xwork2.inject.util

Subclasses of ReferenceMap in com.opensymphony.xwork2.inject.util
 class ReferenceCache<K,V>
Extends ReferenceMap to support lazy loading values by overriding ReferenceCache.create(Object).

Methods in com.opensymphony.xwork2.inject.util with parameters of type ReferenceMap
 Object ReferenceMap.Strategy.execute(ReferenceMap map, Object keyReference, Object valueReference)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap.Entry (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap.Entry

Packages that use ReferenceMap.Entry
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceMap.Entry in com.opensymphony.xwork2.inject.util

Methods in com.opensymphony.xwork2.inject.util that return ReferenceMap.Entry
(package private)  ReferenceMap.Entry ReferenceMap.dereferenceEntry(Map.Entry<Object,Object> entry)
Dereferences an entry.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.util.ReferenceMap.InternalReference

Packages that use ReferenceMap.InternalReference
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceMap.InternalReference in com.opensymphony.xwork2.inject.util

Classes in com.opensymphony.xwork2.inject.util that implement ReferenceMap.InternalReference
(package private) class | ReferenceMap.SoftKeyReference
(package private) class | ReferenceMap.SoftValueReference
(package private) class | ReferenceMap.WeakKeyReference
(package private) class | ReferenceMap.WeakValueReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap.KeyReferenceAwareWrapper (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap.KeyReferenceAwareWrapper

No usage of com.opensymphony.xwork2.inject.util.ReferenceMap.KeyReferenceAwareWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap.PutStrategy

Packages that use ReferenceMap.PutStrategy
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceMap.PutStrategy in com.opensymphony.xwork2.inject.util

Fields in com.opensymphony.xwork2.inject.util declared as ReferenceMap.PutStrategy
private static ReferenceMap.PutStrategy ReferenceMap.defaultPutStrategy

Methods in com.opensymphony.xwork2.inject.util that return ReferenceMap.PutStrategy
protected ReferenceMap.PutStrategy | ReferenceMap.getPutStrategy()
static ReferenceMap.PutStrategy | ReferenceMap.PutStrategy.valueOf(String name) Returns the enum constant of this type with the specified name.
static ReferenceMap.PutStrategy[] | ReferenceMap.PutStrategy.values() Returns an array containing the constants of this enum type, in the order they're declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap.ReferenceAwareWrapper

Packages that use ReferenceMap.ReferenceAwareWrapper
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceMap.ReferenceAwareWrapper in com.opensymphony.xwork2.inject.util

Subclasses of ReferenceMap.ReferenceAwareWrapper in com.opensymphony.xwork2.inject.util
(package private) static class ReferenceMap.KeyReferenceAwareWrapper
Used for keys.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference

No usage of com.opensymphony.xwork2.inject.util.ReferenceMap.SoftKeyReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference

No usage of com.opensymphony.xwork2.inject.util.ReferenceMap.SoftValueReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.inject.util.ReferenceMap.Strategy

Packages that use ReferenceMap.Strategy
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceMap.Strategy in com.opensymphony.xwork2.inject.util

Classes in com.opensymphony.xwork2.inject.util that implement ReferenceMap.Strategy
private static class ReferenceMap.PutStrategy

Methods in com.opensymphony.xwork2.inject.util that return ReferenceMap.Strategy
protected ReferenceMap.Strategy | ReferenceMap.putIfAbsentStrategy()
protected ReferenceMap.Strategy | ReferenceMap.putStrategy()
protected ReferenceMap.Strategy | ReferenceMap.replaceStrategy()

Methods in com.opensymphony.xwork2.inject.util with parameters of type ReferenceMap.Strategy
(package private)  V ReferenceMap.execute(ReferenceMap.Strategy strategy, K key, V value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference

No usage of com.opensymphony.xwork2.inject.util.ReferenceMap.WeakKeyReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference

No usage of com.opensymphony.xwork2.inject.util.ReferenceMap.WeakValueReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.ReferenceType (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.ReferenceType

Packages that use ReferenceType
com.opensymphony.xwork2.inject.util Guice util classes.

Uses of ReferenceType in com.opensymphony.xwork2.inject.util

Fields in com.opensymphony.xwork2.inject.util declared as ReferenceType
(package private) ReferenceType | ReferenceMap.keyReferenceType
(package private) ReferenceType | ReferenceMap.valueReferenceType

Methods in com.opensymphony.xwork2.inject.util that return ReferenceType
static ReferenceType | ReferenceType.valueOf(String name) Returns the enum constant of this type with the specified name.
static ReferenceType[] | ReferenceType.values() Returns an array containing the constants of this enum type, in the order they're declared.

Methods in com.opensymphony.xwork2.inject.util with parameters of type ReferenceType
(package private)  Object ReferenceMap.dereference(ReferenceType referenceType, Object reference)
Returns the refererent for reference given its reference type.
(package private)
<T extends Collection<Object>>
T
ReferenceMap.dereferenceCollection(ReferenceType referenceType, T in, T out)
Dereferences elements in in using referenceType and puts them in out.
static
<K,V> ReferenceCache<K,V>
ReferenceCache.of(ReferenceType keyReferenceType, ReferenceType valueReferenceType, Function<? super K,? extends V> function)
Returns a ReferenceCache delegating to the specified function.

Constructors in com.opensymphony.xwork2.inject.util with parameters of type ReferenceType
ReferenceCache(ReferenceType keyReferenceType, ReferenceType valueReferenceType)
ReferenceMap(ReferenceType keyReferenceType, ReferenceType valueReferenceType)
Concurrent hash map that wraps keys and/or values based on specified reference types.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.inject.util.Strings (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.inject.util.Strings

No usage of com.opensymphony.xwork2.inject.util.Strings

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.interceptor (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.interceptor
Interfaces
Interceptor
NoParameters
ParameterNameAware
PreResultListener
ScopedModelDriven
Classes
AbstractInterceptor
AliasInterceptor
ChainingInterceptor
ConversionErrorInterceptor
DefaultWorkflowInterceptor
ExceptionHolder
ExceptionMappingInterceptor
I18nInterceptor
LoggingInterceptor
MethodFilterInterceptor
MethodFilterInterceptorUtil
ModelDrivenInterceptor
ParameterFilterInterceptor
ParameterRemoverInterceptor
ParametersInterceptor
PrefixMethodInvocationUtil
PrepareInterceptor
ScopedModelDrivenInterceptor
StaticParametersInterceptor
TimerInterceptor


com.opensymphony.xwork2.interceptor.annotations (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.interceptor.annotations
Classes
AnnotationWorkflowInterceptor
Annotation Types
After
Before
BeforeResult


Uses of Class com.opensymphony.xwork2.interceptor.annotations.After (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.After

No usage of com.opensymphony.xwork2.interceptor.annotations.After

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor

No usage of com.opensymphony.xwork2.interceptor.annotations.AnnotationWorkflowInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.Before (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.Before

No usage of com.opensymphony.xwork2.interceptor.annotations.Before

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.annotations.BeforeResult (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.annotations.BeforeResult

No usage of com.opensymphony.xwork2.interceptor.annotations.BeforeResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.AbstractInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.AbstractInterceptor

Packages that use AbstractInterceptor
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.validation |
org.apache.struts2.portlet.interceptor |

Uses of AbstractInterceptor in com.opensymphony.xwork2.interceptor

Subclasses of AbstractInterceptor in com.opensymphony.xwork2.interceptor
class | AliasInterceptor The aim of this Interceptor is to alias a named parameter to a different named parameter.
class | ChainingInterceptor An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable.
class | ConversionErrorInterceptor This interceptor adds any error found in the ActionContext's conversionErrors map as a field error (provided that the action implements ValidationAware).
class | DefaultWorkflowInterceptor An interceptor that does some basic validation workflow before allowing the interceptor chain to continue.
class | ExceptionMappingInterceptor This interceptor forms the core functionality of the exception handling feature.
class | I18nInterceptor An interceptor that handles setting the locale specified in a session as the locale for the current action request.
class | LoggingInterceptor This interceptor logs the the start and end of the execution an action (in English-only, not internationalized).
class | MethodFilterInterceptor An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.
class | ModelDrivenInterceptor Watches for ModelDriven actions and adds the action's model on to the value stack.
class | ParameterFilterInterceptor
class | ParameterRemoverInterceptor This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action.
class | ParametersInterceptor This interceptor sets all parameters on the value stack.
class | PrepareInterceptor This interceptor calls prepare() on actions which implement Preparable.
class | ScopedModelDrivenInterceptor An interceptor that enables scoped model-driven actions.
class | StaticParametersInterceptor This interceptor populates the action with the static parameters defined in the action configuration.
class | TimerInterceptor This interceptor logs the amount of time in milliseconds.

Uses of AbstractInterceptor in com.opensymphony.xwork2.spring.interceptor

Subclasses of AbstractInterceptor in com.opensymphony.xwork2.spring.interceptor
 class ActionAutowiringInterceptor
TODO: Give a description of the Interceptor.

Uses of AbstractInterceptor in com.opensymphony.xwork2.validator

Subclasses of AbstractInterceptor in com.opensymphony.xwork2.validator
 class ValidationInterceptor
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).

Uses of AbstractInterceptor in org.apache.struts2.interceptor

Subclasses of AbstractInterceptor in org.apache.struts2.interceptor
class | CreateSessionInterceptor This interceptor creates the HttpSession.
class | ExecuteAndWaitInterceptor The ExecuteAndWaitInterceptor is great for running long-lived actions in the background while showing the user a nice progress meter.
class | FileUploadInterceptor Interceptor that is based off of MultiPartRequestWrapper, which is automatically applied for any request that includes a file.
class | ProfilingActivationInterceptor Allows profiling to be enabled or disabled via request parameters, when devMode is enabled.
class | RolesInterceptor This interceptor ensures that the action will only be executed if the user has the correct role.
class | ScopeInterceptor This is designed to solve a few simple issues related to wizard-like functionality in Struts.
class | ServletConfigInterceptor An interceptor which sets action properties based on the interfaces an action implements.
class | StrutsConversionErrorInterceptor This interceptor extends ConversionErrorInterceptor but only adds conversion errors from the ActionContext to the field errors of the action if the field value is not null, "", or {""} (a size 1 String array with only an empty String).
class | TokenInterceptor Ensures that only one request per token is processed.
class | TokenSessionStoreInterceptor This interceptor builds off of the TokenInterceptor, providing advanced logic for handling invalid tokens.

Uses of AbstractInterceptor in org.apache.struts2.interceptor.validation

Subclasses of AbstractInterceptor in org.apache.struts2.interceptor.validation
 class AnnotationValidationInterceptor
Extends the xwork validation interceptor to also check for a @SkipValidation annotation, and if found, don't validate this action method

Uses of AbstractInterceptor in org.apache.struts2.portlet.interceptor

Subclasses of AbstractInterceptor in org.apache.struts2.portlet.interceptor
 class PortletPreferencesInterceptor
An interceptor which provides an implementation of PortletPreferences if the Action implements PortletPreferencesAware.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.AliasInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.AliasInterceptor

No usage of com.opensymphony.xwork2.interceptor.AliasInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ChainingInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ChainingInterceptor

No usage of com.opensymphony.xwork2.interceptor.ChainingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ConversionErrorInterceptor

Packages that use ConversionErrorInterceptor
org.apache.struts2.interceptor Web specific interceptor classes.

Uses of ConversionErrorInterceptor in org.apache.struts2.interceptor

Subclasses of ConversionErrorInterceptor in org.apache.struts2.interceptor
 class StrutsConversionErrorInterceptor
This interceptor extends ConversionErrorInterceptor but only adds conversion errors from the ActionContext to the field errors of the action if the field value is not null, "", or {""} (a size 1 String array with only an empty String).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

No usage of com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ExceptionHolder (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ExceptionHolder

Packages that use ExceptionHolder
com.opensymphony.xwork2.interceptor Interceptor classes.

Uses of ExceptionHolder in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ExceptionHolder
protected  void ExceptionMappingInterceptor.publishException(ActionInvocation invocation, ExceptionHolder exceptionHolder)
Default implementation to handle ExceptionHolder publishing.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

No usage of com.opensymphony.xwork2.interceptor.ExceptionMappingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.I18nInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.I18nInterceptor

No usage of com.opensymphony.xwork2.interceptor.I18nInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.Interceptor (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.Interceptor

Packages that use Interceptor
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2.impl |
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.debugging |
org.apache.struts2.interceptor.validation |
org.apache.struts2.portlet.interceptor |

Uses of Interceptor in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that return Interceptor
 Interceptor ObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map interceptorRefParams)
Builds an Interceptor from the InterceptorConfig and the Map of parameters from the interceptor reference.

Uses of Interceptor in com.opensymphony.xwork2.config.entities

Fields in com.opensymphony.xwork2.config.entities declared as Interceptor
private  Interceptor InterceptorMapping.interceptor

Methods in com.opensymphony.xwork2.config.entities that return Interceptor
 Interceptor InterceptorMapping.getInterceptor()

Methods in com.opensymphony.xwork2.config.entities with parameters of type Interceptor
 void InterceptorMapping.setInterceptor(Interceptor interceptor)

Constructors in com.opensymphony.xwork2.config.entities with parameters of type Interceptor
InterceptorMapping(String name, Interceptor interceptor)

Uses of Interceptor in com.opensymphony.xwork2.interceptor

Classes in com.opensymphony.xwork2.interceptor that implement Interceptor
class | AbstractInterceptor Provides default implementations of optional lifecycle methods
class | AliasInterceptor The aim of this Interceptor is to alias a named parameter to a different named parameter.
class | ChainingInterceptor An interceptor that copies all the properties of every object in the value stack to the currently executing object, except for any object that implements Unchainable.
class | ConversionErrorInterceptor This interceptor adds any error found in the ActionContext's conversionErrors map as a field error (provided that the action implements ValidationAware).
class | DefaultWorkflowInterceptor An interceptor that does some basic validation workflow before allowing the interceptor chain to continue.
class | ExceptionMappingInterceptor This interceptor forms the core functionality of the exception handling feature.
class | I18nInterceptor An interceptor that handles setting the locale specified in a session as the locale for the current action request.
class | LoggingInterceptor This interceptor logs the the start and end of the execution an action (in English-only, not internationalized).
class | MethodFilterInterceptor An abstract Interceptor that is applied to selectively according to specified included/excluded method lists.
class | ModelDrivenInterceptor Watches for ModelDriven actions and adds the action's model on to the value stack.
class | ParameterFilterInterceptor
class | ParameterRemoverInterceptor This is a simple XWork interceptor that allows parameters (matching one of the paramNames attribute csv value) to be removed from the parameter map if they match a certain value (matching one of the paramValues attribute csv value), before they are set on the action.
class | ParametersInterceptor This interceptor sets all parameters on the value stack.
class | PrepareInterceptor This interceptor calls prepare() on actions which implement Preparable.
class | ScopedModelDrivenInterceptor An interceptor that enables scoped model-driven actions.
class | StaticParametersInterceptor This interceptor populates the action with the static parameters defined in the action configuration.
class | TimerInterceptor This interceptor logs the amount of time in milliseconds.

Uses of Interceptor in com.opensymphony.xwork2.interceptor.annotations

Classes in com.opensymphony.xwork2.interceptor.annotations that implement Interceptor
 class AnnotationWorkflowInterceptor

Uses of Interceptor in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement Interceptor
 class MockInterceptor
Mock for an Interceptor.

Uses of Interceptor in com.opensymphony.xwork2.spring.interceptor

Classes in com.opensymphony.xwork2.spring.interceptor that implement Interceptor
 class ActionAutowiringInterceptor
TODO: Give a description of the Interceptor.

Uses of Interceptor in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement Interceptor
 class ValidationInterceptor
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).

Uses of Interceptor in org.apache.struts2.impl

Methods in org.apache.struts2.impl that return Interceptor
 Interceptor StrutsObjectFactory.buildInterceptor(InterceptorConfig interceptorConfig, Map refParams)

Uses of Interceptor in org.apache.struts2.interceptor

Classes in org.apache.struts2.interceptor that implement Interceptor
class | CheckboxInterceptor Looks for a hidden identification field that specifies the original value of the checkbox.
class | CreateSessionInterceptor This interceptor creates the HttpSession.
class | ExecuteAndWaitInterceptor The ExecuteAndWaitInterceptor is great for running long-lived actions in the background while showing the user a nice progress meter.
class | FileUploadInterceptor Interceptor that is based off of MultiPartRequestWrapper, which is automatically applied for any request that includes a file.
class | MessageStoreInterceptor An interceptor to store ValidationAware action's messages / errors and field errors into Http Session, such that it will be retrieveable at a later stage.
class | ProfilingActivationInterceptor Allows profiling to be enabled or disabled via request parameters, when devMode is enabled.
class | RolesInterceptor This interceptor ensures that the action will only be executed if the user has the correct role.
class | ScopeInterceptor This is designed to solve a few simple issues related to wizard-like functionality in Struts.
class | ServletConfigInterceptor An interceptor which sets action properties based on the interfaces an action implements.
class | StrutsConversionErrorInterceptor This interceptor extends ConversionErrorInterceptor but only adds conversion errors from the ActionContext to the field errors of the action if the field value is not null, "", or {""} (a size 1 String array with only an empty String).
class | TokenInterceptor Ensures that only one request per token is processed.
class | TokenSessionStoreInterceptor This interceptor builds off of the TokenInterceptor, providing advanced logic for handling invalid tokens.

Uses of Interceptor in org.apache.struts2.interceptor.debugging

Classes in org.apache.struts2.interceptor.debugging that implement Interceptor
 class DebuggingInterceptor
Provides several different debugging screens to provide insight into the data behind the page.

Uses of Interceptor in org.apache.struts2.interceptor.validation

Classes in org.apache.struts2.interceptor.validation that implement Interceptor
 class AnnotationValidationInterceptor
Extends the xwork validation interceptor to also check for a @SkipValidation annotation, and if found, don't validate this action method

Uses of Interceptor in org.apache.struts2.portlet.interceptor

Classes in org.apache.struts2.portlet.interceptor that implement Interceptor
 class PortletPreferencesInterceptor
An interceptor which provides an implementation of PortletPreferences if the Action implements PortletPreferencesAware.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.LoggingInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.LoggingInterceptor

No usage of com.opensymphony.xwork2.interceptor.LoggingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.MethodFilterInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.MethodFilterInterceptor

Packages that use MethodFilterInterceptor
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.interceptor.validation |

Uses of MethodFilterInterceptor in com.opensymphony.xwork2.interceptor

Subclasses of MethodFilterInterceptor in com.opensymphony.xwork2.interceptor
 class DefaultWorkflowInterceptor
An interceptor that does some basic validation workflow before allowing the interceptor chain to continue.

Uses of MethodFilterInterceptor in com.opensymphony.xwork2.validator

Subclasses of MethodFilterInterceptor in com.opensymphony.xwork2.validator
 class ValidationInterceptor
This interceptor runs the action through the standard validation framework, which in turn checks the action against any validation rules (found in files such as ActionClass-validation.xml) and adds field-level and action-level error messages (provided that the action implements ValidationAware).

Uses of MethodFilterInterceptor in org.apache.struts2.interceptor

Subclasses of MethodFilterInterceptor in org.apache.struts2.interceptor
class | ExecuteAndWaitInterceptor The ExecuteAndWaitInterceptor is great for running long-lived actions in the background while showing the user a nice progress meter.
class | TokenInterceptor Ensures that only one request per token is processed.
class | TokenSessionStoreInterceptor This interceptor builds off of the TokenInterceptor, providing advanced logic for handling invalid tokens.

Uses of MethodFilterInterceptor in org.apache.struts2.interceptor.validation

Subclasses of MethodFilterInterceptor in org.apache.struts2.interceptor.validation
 class AnnotationValidationInterceptor
Extends the xwork validation interceptor to also check for a @SkipValidation annotation, and if found, don't validate this action method

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil

No usage of com.opensymphony.xwork2.interceptor.MethodFilterInterceptorUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor

No usage of com.opensymphony.xwork2.interceptor.ModelDrivenInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.NoParameters (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.NoParameters

Packages that use NoParameters
org.apache.struts2.interceptor Web specific interceptor classes.

Uses of NoParameters in org.apache.struts2.interceptor

Subinterfaces of NoParameters in org.apache.struts2.interceptor
 interface NoParameters
This marker interface should be implemented by actions that do not want any parameters set on them automatically.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

No usage of com.opensymphony.xwork2.interceptor.ParameterFilterInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.ParameterNameAware (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.ParameterNameAware

No usage of com.opensymphony.xwork2.interceptor.ParameterNameAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

No usage of com.opensymphony.xwork2.interceptor.ParameterRemoverInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ParametersInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ParametersInterceptor

No usage of com.opensymphony.xwork2.interceptor.ParametersInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

No usage of com.opensymphony.xwork2.interceptor.PrefixMethodInvocationUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.PrepareInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.PrepareInterceptor

No usage of com.opensymphony.xwork2.interceptor.PrepareInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.PreResultListener (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.PreResultListener

Packages that use PreResultListener
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.interceptor.annotations | Interceptor annotations.
com.opensymphony.xwork2.mock | XWork specific mock classes.
org.apache.struts2.interceptor | Web specific interceptor classes.

Uses of PreResultListener in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 with parameters of type PreResultListener
void | ActionInvocation.addPreResultListener(PreResultListener listener) Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.
void | DefaultActionInvocation.addPreResultListener(PreResultListener listener) Register a com.opensymphony.xwork2.interceptor.PreResultListener to be notified after the Action is executed and before the Result is executed.

Uses of PreResultListener in com.opensymphony.xwork2.interceptor.annotations

Classes in com.opensymphony.xwork2.interceptor.annotations that implement PreResultListener
 class AnnotationWorkflowInterceptor

Uses of PreResultListener in com.opensymphony.xwork2.mock

Methods in com.opensymphony.xwork2.mock with parameters of type PreResultListener
 void MockActionInvocation.addPreResultListener(PreResultListener listener)

Uses of PreResultListener in org.apache.struts2.interceptor

Classes in org.apache.struts2.interceptor that implement PreResultListener
 class ScopeInterceptor
This is designed to solve a few simple issues related to wizard-like functionality in Struts.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.interceptor.ScopedModelDriven (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.interceptor.ScopedModelDriven

No usage of com.opensymphony.xwork2.interceptor.ScopedModelDriven

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

No usage of com.opensymphony.xwork2.interceptor.ScopedModelDrivenInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.StaticParametersInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

No usage of com.opensymphony.xwork2.interceptor.StaticParametersInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.interceptor.TimerInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.interceptor.TimerInterceptor

No usage of com.opensymphony.xwork2.interceptor.TimerInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.mock (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.mock
Classes
MockActionInvocation
MockActionProxy
MockInterceptor
MockObjectTypeDeterminer
MockResult


Uses of Class com.opensymphony.xwork2.mock.MockActionInvocation (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockActionInvocation

Packages that use MockActionInvocation
com.opensymphony.xwork2 Main Xwork interfaces and classes.

Uses of MockActionInvocation in com.opensymphony.xwork2

Subclasses of MockActionInvocation in com.opensymphony.xwork2
 class MockActionInvocation
Deprecated. Please use @see com.opensymphony.xwork2.mock.MockActionInvocation instead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockActionProxy (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockActionProxy

No usage of com.opensymphony.xwork2.mock.MockActionProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockInterceptor

No usage of com.opensymphony.xwork2.mock.MockInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockObjectTypeDeterminer (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

No usage of com.opensymphony.xwork2.mock.MockObjectTypeDeterminer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.mock.MockResult (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.mock.MockResult

No usage of com.opensymphony.xwork2.mock.MockResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.spring (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.spring
Classes
SpringObjectFactory
SpringProxyableObjectFactory


Uses of Class com.opensymphony.xwork2.spring.SpringObjectFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.spring.SpringObjectFactory

Packages that use SpringObjectFactory
com.opensymphony.xwork2.spring | Spring ObjectFactory classes.
com.opensymphony.xwork2.spring.interceptor | Spring specific interceptor classes.

Uses of SpringObjectFactory in com.opensymphony.xwork2.spring

Subclasses of SpringObjectFactory in com.opensymphony.xwork2.spring
 class SpringProxyableObjectFactory
SpringProxyableObjectFactory.

Uses of SpringObjectFactory in com.opensymphony.xwork2.spring.interceptor

Fields in com.opensymphony.xwork2.spring.interceptor declared as SpringObjectFactory
private  SpringObjectFactory ActionAutowiringInterceptor.factory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.spring.SpringProxyableObjectFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.spring.SpringProxyableObjectFactory

No usage of com.opensymphony.xwork2.spring.SpringProxyableObjectFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.spring.interceptor (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.spring.interceptor
Classes
ActionAutowiringInterceptor


Uses of Class com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

No usage of com.opensymphony.xwork2.spring.interceptor.ActionAutowiringInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ClassLoaderUtil.AggregateIterator (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util
Class ClassLoaderUtil.AggregateIterator<E>

java.lang.Object
    extended by  com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator<E>
All Implemented Interfaces:
Iterator<E>
Enclosing class:
ClassLoaderUtil
protected static class ClassLoaderUtil.AggregateIterator<E>
extends Object
implements Iterator<E>

Aggregates Enumeration instances into one iterator and filters out duplicates. Always keeps one ahead of the enumerator to protect against returning duplicates.

Field Summary
(package private) Enumeration<E> | cur
(package private) LinkedList<Enumeration<E>> | enums
(package private) Set<E> | loaded
(package private) E | next
Constructor Summary
protected ClassLoaderUtil.AggregateIterator()
Method Summary
ClassLoaderUtil.AggregateIterator | addEnumeration(Enumeration<E> e)
private Enumeration<E> | determineCurrentEnumeration()
boolean | hasNext()
private E | loadNext()
E | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

enums

LinkedList<Enumeration<E>> enums

cur

Enumeration<E> cur

next

E next

loaded

Set<E> loaded
Constructor Detail

ClassLoaderUtil.AggregateIterator

protected ClassLoaderUtil.AggregateIterator()
Method Detail

addEnumeration

public ClassLoaderUtil.AggregateIterator addEnumeration(Enumeration<E> e)

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator<E>

next

public E next()
Specified by:
next in interface Iterator<E>

determineCurrentEnumeration

private Enumeration<E> determineCurrentEnumeration()

loadNext

private E loadNext()

remove

public void remove()
Specified by:
remove in interface Iterator<E>
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


com.opensymphony.xwork2.util (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.util
Interfaces
ObjectTypeDeterminer
ResolverUtil.Test
TextParseUtil.ParsedValueEvaluator
ValueStack
Classes
AnnotationUtils
AnnotationXWorkConverter
ClassLoaderUtil
ClassLoaderUtil.AggregateIterator
CompoundRoot
CompoundRootAccessor
CompoundRootAccessor.MethodCall
DefaultObjectTypeDeterminer
DomHelper
DomHelper.DOMBuilder
DomHelper.StartHandler
EnumTypeConverter
FileManager
FileManager.FileRevision
GenericsObjectTypeDeterminer
InstantiatingNullHandler
LocalizedTextUtil
LocalizedTextUtil.GetDefaultMessageReturnArg
LocalizedTextUtil.MessageFormatKey
ObjectProxy
ObjectProxyPropertyAccessor
ObjectTypeDeterminerFactory
OgnlContextState
OgnlUtil
OgnlValueStack
OgnlValueStack.ObjectAccessor
OgnlValueStackFactory
PropertiesReader
ResolverUtil
ResolverUtil.AnnotatedWith
ResolverUtil.IsA
ResolverUtil.NameEndsWith
SurrugateList
TextParseUtil
TextUtils
ValueStackFactory
WildcardHelper
XWorkBasicConverter
XWorkCollectionPropertyAccessor
XWorkConverter
XWorkEnumerationAcccessor
XWorkIteratorPropertyAccessor
XWorkList
XWorkListPropertyAccessor
XWorkMap
XWorkMapPropertyAccessor
XWorkMethodAccessor
XWorkObjectPropertyAccessor
XWorkTestCaseHelper
Exceptions
TypeConversionException
Annotation Types
CreateIfNull
Element
Key
KeyProperty


Uses of Class com.opensymphony.xwork2.util.AnnotationUtils (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.AnnotationUtils

No usage of com.opensymphony.xwork2.util.AnnotationUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.AnnotationXWorkConverter (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.AnnotationXWorkConverter

No usage of com.opensymphony.xwork2.util.AnnotationXWorkConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ClassLoaderUtil (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ClassLoaderUtil

No usage of com.opensymphony.xwork2.util.ClassLoaderUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ClassLoaderUtil.AggregateIterator

Packages that use ClassLoaderUtil.AggregateIterator
com.opensymphony.xwork2.util XWork util classes.

Uses of ClassLoaderUtil.AggregateIterator in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return ClassLoaderUtil.AggregateIterator
 ClassLoaderUtil.AggregateIterator ClassLoaderUtil.AggregateIterator.addEnumeration(Enumeration<E> e)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.CompoundRoot (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.CompoundRoot

Packages that use CompoundRoot
com.opensymphony.xwork2.util XWork util classes.

Uses of CompoundRoot in com.opensymphony.xwork2.util

Fields in com.opensymphony.xwork2.util declared as CompoundRoot
(package private)  CompoundRoot OgnlValueStack.root

Methods in com.opensymphony.xwork2.util that return CompoundRoot
CompoundRoot | CompoundRoot.cutStack(int index)
CompoundRoot | OgnlValueStack.getRoot()
CompoundRoot | ValueStack.getRoot() Get the CompoundRoot which holds the objects pushed onto the stack

Methods in com.opensymphony.xwork2.util with parameters of type CompoundRoot
private  void OgnlValueStack.setRoot(CompoundRoot compoundRoot)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.CompoundRootAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.CompoundRootAccessor

Packages that use CompoundRootAccessor
com.opensymphony.xwork2.util XWork util classes.

Uses of CompoundRootAccessor in com.opensymphony.xwork2.util

Fields in com.opensymphony.xwork2.util declared as CompoundRootAccessor
private static CompoundRootAccessor OgnlValueStack.accessor

Methods in com.opensymphony.xwork2.util that return CompoundRootAccessor
static CompoundRootAccessor OgnlValueStack.getAccessor()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

No usage of com.opensymphony.xwork2.util.CompoundRootAccessor.MethodCall

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.CreateIfNull (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.CreateIfNull

No usage of com.opensymphony.xwork2.util.CreateIfNull

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.DefaultObjectTypeDeterminer

Packages that use DefaultObjectTypeDeterminer
com.opensymphony.xwork2.util XWork util classes.

Uses of DefaultObjectTypeDeterminer in com.opensymphony.xwork2.util

Subclasses of DefaultObjectTypeDeterminer in com.opensymphony.xwork2.util
 class GenericsObjectTypeDeterminer
GenericsObjectTypeDeterminer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.DomHelper (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.DomHelper

No usage of com.opensymphony.xwork2.util.DomHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.DomHelper.DOMBuilder (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.DomHelper.DOMBuilder

No usage of com.opensymphony.xwork2.util.DomHelper.DOMBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.DomHelper.StartHandler (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.DomHelper.StartHandler

No usage of com.opensymphony.xwork2.util.DomHelper.StartHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.Element (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.Element

No usage of com.opensymphony.xwork2.util.Element

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.EnumTypeConverter (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.EnumTypeConverter

No usage of com.opensymphony.xwork2.util.EnumTypeConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.FileManager (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.FileManager

No usage of com.opensymphony.xwork2.util.FileManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.FileManager.FileRevision (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.FileManager.FileRevision

No usage of com.opensymphony.xwork2.util.FileManager.FileRevision

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer

No usage of com.opensymphony.xwork2.util.GenericsObjectTypeDeterminer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.InstantiatingNullHandler (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.InstantiatingNullHandler

No usage of com.opensymphony.xwork2.util.InstantiatingNullHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.Key (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.Key

No usage of com.opensymphony.xwork2.util.Key

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.KeyProperty (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.KeyProperty

No usage of com.opensymphony.xwork2.util.KeyProperty

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.LocalizedTextUtil (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.LocalizedTextUtil

No usage of com.opensymphony.xwork2.util.LocalizedTextUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.LocalizedTextUtil.GetDefaultMessageReturnArg (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.LocalizedTextUtil.GetDefaultMessageReturnArg

Packages that use LocalizedTextUtil.GetDefaultMessageReturnArg
com.opensymphony.xwork2.util XWork util classes.

Uses of LocalizedTextUtil.GetDefaultMessageReturnArg in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return LocalizedTextUtil.GetDefaultMessageReturnArg
private static LocalizedTextUtil.GetDefaultMessageReturnArg LocalizedTextUtil.getDefaultMessage(String key, Locale locale, ValueStack valueStack, Object[] args, String defaultMessage)
Gets the default message.

Methods in com.opensymphony.xwork2.util with parameters of type LocalizedTextUtil.GetDefaultMessageReturnArg
private static boolean LocalizedTextUtil.unableToFindTextForKey(LocalizedTextUtil.GetDefaultMessageReturnArg result)
Determines if we found the text in the bundles.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey

No usage of com.opensymphony.xwork2.util.LocalizedTextUtil.MessageFormatKey

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ObjectProxy (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ObjectProxy

Packages that use ObjectProxy
com.opensymphony.xwork2.util XWork util classes.

Uses of ObjectProxy in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util with parameters of type ObjectProxy
private  void ObjectProxyPropertyAccessor.setupContext(Map context, ObjectProxy proxy)
Sets up the context with the last property and last class accessed.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor

No usage of com.opensymphony.xwork2.util.ObjectProxyPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.ObjectTypeDeterminer (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.util.ObjectTypeDeterminer

Packages that use ObjectTypeDeterminer
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.util | XWork util classes.

Uses of ObjectTypeDeterminer in com.opensymphony.xwork2.mock

Classes in com.opensymphony.xwork2.mock that implement ObjectTypeDeterminer
 class MockObjectTypeDeterminer
Mocks the function of an ObjectTypeDeterminer for testing purposes.

Uses of ObjectTypeDeterminer in com.opensymphony.xwork2.util

Classes in com.opensymphony.xwork2.util that implement ObjectTypeDeterminer
class | DefaultObjectTypeDeterminer This ObjectTypeDeterminer looks at the Class-conversion.properties for entries that indicated what objects are contained within Maps and Collections.
class | GenericsObjectTypeDeterminer GenericsObjectTypeDeterminer

Fields in com.opensymphony.xwork2.util declared as ObjectTypeDeterminer
private static ObjectTypeDeterminer | ObjectTypeDeterminerFactory.instance
protected ObjectTypeDeterminer | XWorkConverter.objectTypeDeterminer

Methods in com.opensymphony.xwork2.util that return ObjectTypeDeterminer
static ObjectTypeDeterminer | ObjectTypeDeterminerFactory.getInstance()
ObjectTypeDeterminer | XWorkConverter.getObjectTypeDeterminer()

Methods in com.opensymphony.xwork2.util with parameters of type ObjectTypeDeterminer
static void | ObjectTypeDeterminerFactory.setInstance(ObjectTypeDeterminer instance)
void | XWorkConverter.setObjectTypeDeterminer(ObjectTypeDeterminer determiner)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory

No usage of com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.OgnlContextState (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.OgnlContextState

No usage of com.opensymphony.xwork2.util.OgnlContextState

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.OgnlUtil (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.OgnlUtil

No usage of com.opensymphony.xwork2.util.OgnlUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.OgnlValueStack (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.OgnlValueStack

No usage of com.opensymphony.xwork2.util.OgnlValueStack

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor

No usage of com.opensymphony.xwork2.util.OgnlValueStack.ObjectAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.OgnlValueStackFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.OgnlValueStackFactory

No usage of com.opensymphony.xwork2.util.OgnlValueStackFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.PropertiesReader (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.PropertiesReader

No usage of com.opensymphony.xwork2.util.PropertiesReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil

No usage of com.opensymphony.xwork2.util.ResolverUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith

No usage of com.opensymphony.xwork2.util.ResolverUtil.AnnotatedWith

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.IsA (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.IsA

No usage of com.opensymphony.xwork2.util.ResolverUtil.IsA

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith

No usage of com.opensymphony.xwork2.util.ResolverUtil.NameEndsWith

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.ResolverUtil.Test (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.util.ResolverUtil.Test

Packages that use ResolverUtil.Test
com.opensymphony.xwork2.util XWork util classes.

Uses of ResolverUtil.Test in com.opensymphony.xwork2.util

Classes in com.opensymphony.xwork2.util that implement ResolverUtil.Test
static class | ResolverUtil.AnnotatedWith A Test that checks to see if each class is annotated with a specific annotation.
static class | ResolverUtil.IsA A Test that checks to see if each class is assignable to the provided class.
static class | ResolverUtil.NameEndsWith A Test that checks to see if each class name ends with the provided suffix.

Methods in com.opensymphony.xwork2.util with parameters of type ResolverUtil.Test
protected void | ResolverUtil.addIfMatching(ResolverUtil.Test test, String fqn) Add the class designated by the fully qualified class name provided to the set of resolved classes if and only if it is approved by the Test supplied.
void | ResolverUtil.find(ResolverUtil.Test test, String... packageNames) Attempts to discover classes that pass the test.
void | ResolverUtil.findInPackage(ResolverUtil.Test test, String packageName) Scans for classes starting at the package provided and descending into subpackages.
private void | ResolverUtil.loadImplementationsInDirectory(ResolverUtil.Test test, String parent, File location) Finds matches in a physical directory on a filesystem.
private void | ResolverUtil.loadImplementationsInJar(ResolverUtil.Test test, String parent, File jarfile) Finds matching classes within a jar files that contains a folder structure matching the package structure.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.SurrugateList (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.SurrugateList

No usage of com.opensymphony.xwork2.util.SurrugateList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.TextParseUtil (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.TextParseUtil

No usage of com.opensymphony.xwork2.util.TextParseUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.util.TextParseUtil.ParsedValueEvaluator

Packages that use TextParseUtil.ParsedValueEvaluator
com.opensymphony.xwork2.util XWork util classes.

Uses of TextParseUtil.ParsedValueEvaluator in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util with parameters of type TextParseUtil.ParsedValueEvaluator
static Object TextParseUtil.translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static String TextParseUtil.translateVariables(String expression, ValueStack stack, TextParseUtil.ParsedValueEvaluator evaluator)
Function similarly as TextParseUtil.translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.TextUtils (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.TextUtils

No usage of com.opensymphony.xwork2.util.TextUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.TypeConversionException (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.TypeConversionException

No usage of com.opensymphony.xwork2.util.TypeConversionException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.ValueStack (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.util.ValueStack

Packages that use ValueStack
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.interceptor | Interceptor classes.
com.opensymphony.xwork2.mock | XWork specific mock classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.components |
org.apache.struts2.components.table |
org.apache.struts2.components.template |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.portlet.result |
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.views |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.freemarker.tags |
org.apache.struts2.views.jsp | Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.
org.apache.struts2.views.util | Miscellaneous helper classes for all views.
org.apache.struts2.views.velocity | Classes for views using Velocity.
org.apache.struts2.views.velocity.components |

Uses of ValueStack in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as ValueStack
protected  ValueStack DefaultActionInvocation.stack

Methods in com.opensymphony.xwork2 that return ValueStack
ValueStack | ActionInvocation.getStack()
ValueStack | DefaultActionInvocation.getStack()
ValueStack | ActionContext.getValueStack() Gets the OGNL value stack.

Methods in com.opensymphony.xwork2 with parameters of type ValueStack
String | ActionSupport.getText(String key, String defaultValue, List args, ValueStack stack)
String | DefaultTextProvider.getText(String key, String defaultValue, List args, ValueStack stack)
String | TextProvider.getText(String key, String defaultValue, List args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | TextProviderSupport.getText(String key, String defaultValue, List args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | ActionSupport.getText(String key, String defaultValue, String[] args, ValueStack stack)
String | DefaultTextProvider.getText(String key, String defaultValue, String[] args, ValueStack stack)
String | TextProvider.getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | TextProviderSupport.getText(String key, String defaultValue, String[] args, ValueStack stack) Gets a message based on a key using the supplied args, as defined in MessageFormat, or, if the message is not found, a supplied default value is returned.
String | ActionEventListener.handleException(Throwable t, ValueStack stack) Called when an exception is thrown by the action
Object | ActionEventListener.prepare(Object action, ValueStack stack) Called after an action has been created.
void | ActionContext.setValueStack(ValueStack stack) Sets the OGNL value stack.

Uses of ValueStack in com.opensymphony.xwork2.interceptor

Methods in com.opensymphony.xwork2.interceptor with parameters of type ValueStack
protected  void ParametersInterceptor.setParameters(Object action, ValueStack stack, Map parameters)

Uses of ValueStack in com.opensymphony.xwork2.mock

Fields in com.opensymphony.xwork2.mock declared as ValueStack
private  ValueStack MockActionInvocation.stack

Methods in com.opensymphony.xwork2.mock that return ValueStack
 ValueStack MockActionInvocation.getStack()

Methods in com.opensymphony.xwork2.mock with parameters of type ValueStack
 void MockActionInvocation.setStack(ValueStack stack)

Uses of ValueStack in com.opensymphony.xwork2.util

Classes in com.opensymphony.xwork2.util that implement ValueStack
 class OgnlValueStack
Ognl implementation of a value stack that allows for dynamic Ognl expressions to be evaluated against it.

Methods in com.opensymphony.xwork2.util that return ValueStack
ValueStack | OgnlValueStackFactory.createValueStack()
abstract ValueStack | ValueStackFactory.createValueStack()
ValueStack | OgnlValueStackFactory.createValueStack(ValueStack stack)
abstract ValueStack | ValueStackFactory.createValueStack(ValueStack stack)

Methods in com.opensymphony.xwork2.util with parameters of type ValueStack
 ValueStack OgnlValueStackFactory.createValueStack(ValueStack stack)
abstract  ValueStack ValueStackFactory.createValueStack(ValueStack stack)
private static String LocalizedTextUtil.findMessage(Class clazz, String key, String indexedKey, Locale locale, Object[] args, Set checked, ValueStack valueStack)
Traverse up class hierarchy looking for message.
static String LocalizedTextUtil.findText(Class aClass, String aTextName, Locale locale, String defaultMessage, Object[] args, ValueStack valueStack)
Finds a localized text message for the given key, aTextName.
static String LocalizedTextUtil.findText(ResourceBundle bundle, String aTextName, Locale locale, String defaultMessage, Object[] args, ValueStack valueStack)
Finds a localized text message for the given key, aTextName, in the specified resource bundle.
static String XWorkConverter.getConversionErrorMessage(String propertyName, ValueStack stack)
private static LocalizedTextUtil.GetDefaultMessageReturnArg LocalizedTextUtil.getDefaultMessage(String key, Locale locale, ValueStack valueStack, Object[] args, String defaultMessage)
Gets the default message.
private static String LocalizedTextUtil.getMessage(String bundleName, Locale locale, String key, ValueStack valueStack, Object[] args)
Gets the message from the named resource bundle.
static String TextParseUtil.translateVariables(char open, String expression, ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to findValue(java.lang.String).
static Object TextParseUtil.translateVariables(char open, String expression, ValueStack stack, Class asType)
Converted object from variable translation.
static Object TextParseUtil.translateVariables(char open, String expression, ValueStack stack, Class asType, TextParseUtil.ParsedValueEvaluator evaluator)
Converted object from variable translation.
static String TextParseUtil.translateVariables(String expression, ValueStack stack)
Converts all instances of ${...} in expression to the value returned by a call to findValue(java.lang.String).
static String TextParseUtil.translateVariables(String expression, ValueStack stack, TextParseUtil.ParsedValueEvaluator evaluator)
Function similarly as TextParseUtil.translateVariables(char, String, ValueStack) except for the introduction of an additional evaluator that allows the parsed value to be evaluated by the evaluator.

Constructors in com.opensymphony.xwork2.util with parameters of type ValueStack
OgnlValueStack(ValueStack vs)

Uses of ValueStack in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type ValueStack
String | DelegatingValidatorContext.getText(String key, String defaultValue, List args, ValueStack stack)
String | DelegatingValidatorContext.getText(String key, String defaultValue, String[] args, ValueStack stack)

Uses of ValueStack in org.apache.struts2

Methods in org.apache.struts2 that return ValueStack
static ValueStack ServletActionContext.getValueStack(HttpServletRequest req)
Gets the current value stack for this request

Uses of ValueStack in org.apache.struts2.components

Fields in org.apache.struts2.components declared as ValueStack
protected  ValueStack Component.stack

Methods in org.apache.struts2.components that return ValueStack
 ValueStack Component.getStack()
Get's the OGNL value stack assoicated with this component.

Methods in org.apache.struts2.components with parameters of type ValueStack
protected  String Component.determineNamespace(String namespace, ValueStack stack, HttpServletRequest req)
Determines the namespace of the current page being renderdd.

Constructors in org.apache.struts2.components with parameters of type ValueStack
AbstractRemoteCallUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
ActionComponent(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ActionError(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
ActionMessage(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Anchor(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
AppendIterator(ValueStack stack)
Autocompleter(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Bean(ValueStack stack)
Checkbox(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
CheckboxList(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
ClosingUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
ComboBox(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Component(ValueStack stack)
Constructor.
Date(ValueStack stack)
DateTimePicker(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Debug(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Div(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
DoubleListUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
DoubleSelect(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Else(ValueStack stack)
ElseIf(ValueStack stack)
FieldError(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
File(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Form(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
FormButton(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
GenericUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Head(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Hidden(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
I18n(ValueStack stack)
If(ValueStack stack)
Include(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
InputTransferSelect(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
IteratorComponent(ValueStack stack)
Label(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
ListUIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
MergeIterator(ValueStack stack)
OptGroup(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
OptionTransferSelect(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Param(ValueStack stack)
Password(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Property(ValueStack stack)
Push(ValueStack stack)
Radio(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Reset(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Select(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Set(ValueStack stack)
Submit(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
TabbedPanel(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Text(ValueStack stack)
TextArea(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
TextField(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Token(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
Tree(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
TreeNode(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
UIBean(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
UpDownSelect(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
URL(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of ValueStack in org.apache.struts2.components.table

Constructors in org.apache.struts2.components.table with parameters of type ValueStack
WebTable(ValueStack stack, HttpServletRequest request, HttpServletResponse response)

Uses of ValueStack in org.apache.struts2.components.template

Fields in org.apache.struts2.components.template declared as ValueStack
(package private)  ValueStack TemplateRenderingContext.stack

Methods in org.apache.struts2.components.template that return ValueStack
 ValueStack TemplateRenderingContext.getStack()

Constructors in org.apache.struts2.components.template with parameters of type ValueStack
TemplateRenderingContext(Template template, Writer writer, ValueStack stack, Map params, UIBean tag)
Constructor

Uses of ValueStack in org.apache.struts2.dispatcher

Methods in org.apache.struts2.dispatcher with parameters of type ValueStack
protected org.apache.velocity.context.Context | VelocityResult.createContext(VelocityManager velocityManager, ValueStack stack, HttpServletRequest request, HttpServletResponse response, String location) Creates the VelocityContext that we'll use to render this page.
protected org.apache.velocity.Template | VelocityResult.getTemplate(ValueStack stack, org.apache.velocity.app.VelocityEngine velocity, ActionInvocation invocation, String location, String encoding) Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.

Uses of ValueStack in org.apache.struts2.portlet.result

Methods in org.apache.struts2.portlet.result with parameters of type ValueStack
protected org.apache.velocity.context.Context | PortletVelocityResult.createContext(VelocityManager velocityManager, ValueStack stack, HttpServletRequest request, HttpServletResponse response, String location) Creates the VelocityContext that we'll use to render this page.
protected org.apache.velocity.Template | PortletVelocityResult.getTemplate(ValueStack stack, org.apache.velocity.app.VelocityEngine velocity, ActionInvocation invocation, String location, String encoding) Given a value stack, a Velocity engine, and an action invocation, this method returns the appropriate Velocity template to render.

Uses of ValueStack in org.apache.struts2.util

Fields in org.apache.struts2.util declared as ValueStack
protected  ValueStack StrutsUtil.stack

Constructors in org.apache.struts2.util with parameters of type ValueStack
StrutsUtil(ValueStack stack, HttpServletRequest request, HttpServletResponse response)
VelocityStrutsUtil(org.apache.velocity.app.VelocityEngine engine, org.apache.velocity.context.Context ctx, ValueStack stack, HttpServletRequest request, HttpServletResponse response)

Uses of ValueStack in org.apache.struts2.views

Methods in org.apache.struts2.views with parameters of type ValueStack
Object | TagLibrary.getFreemarkerModels(ValueStack stack, HttpServletRequest req, HttpServletResponse res) Gets a Java object that contains getters for the tag library's Freemarker models.
Object | DefaultTagLibrary.getFreemarkerModels(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of ValueStack in org.apache.struts2.views.freemarker

Fields in org.apache.struts2.views.freemarker declared as ValueStack
private  ValueStack ScopesHashModel.stack

Methods in org.apache.struts2.views.freemarker with parameters of type ValueStack
protected ScopesHashModel | FreemarkerManager.buildScopesHashModel(ServletContext servletContext, HttpServletRequest request, HttpServletResponse response, freemarker.template.ObjectWrapper wrapper, ValueStack stack)
freemarker.template.SimpleHash | FreemarkerManager.buildTemplateModel(ValueStack stack, Object action, ServletContext servletContext, HttpServletRequest request, HttpServletResponse response, freemarker.template.ObjectWrapper wrapper)
protected void | FreemarkerManager.populateContext(ScopesHashModel model, ValueStack stack, Object action, HttpServletRequest request, HttpServletResponse response)

Constructors in org.apache.struts2.views.freemarker with parameters of type ValueStack
ScopesHashModel(freemarker.template.ObjectWrapper objectWrapper, ServletContext context, HttpServletRequest request, ValueStack stack)

Uses of ValueStack in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ValueStack
protected ValueStack | TagModel.stack
protected ValueStack | StrutsModels.stack

Constructors in org.apache.struts2.views.freemarker.tags with parameters of type ValueStack
ActionErrorModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ActionMessageModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ActionModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
AnchorModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
AutocompleterModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
BeanModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
CheckboxListModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
CheckboxModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ComboBoxModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ComponentModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
DateModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
DateTimePickerModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
DivModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
DoubleSelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ElseIfModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ElseModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
FieldErrorModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
FileModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
FormModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
HeadModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
HiddenModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
I18nModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
IfModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
IncludeModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
InputTransferSelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
IteratorModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
LabelModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
OptGroupModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
OptionTransferSelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ParamModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
PasswordModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
PropertyModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
PushModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
RadioModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
ResetModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
SelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
SetModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
StrutsModels(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
SubmitModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
TabbedPanelModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
TagModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
TextAreaModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
TextFieldModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
TextModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
TokenModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
TreeModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
TreeNodeModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
UpDownSelectModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
URLModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
WebTableModel(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of ValueStack in org.apache.struts2.views.jsp

Methods in org.apache.struts2.views.jsp that return ValueStack
protected ValueStack | StrutsBodyTagSupport.getStack()
static ValueStack | TagUtils.getStack(PageContext pageContext)

Methods in org.apache.struts2.views.jsp with parameters of type ValueStack
static String | TagUtils.buildNamespace(ActionMapper mapper, ValueStack stack, HttpServletRequest request)
Component | URLTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TextTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | SetTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | PushTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | PropertyTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ParamTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | IteratorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | IncludeTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | IfTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | I18nTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ElseTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ElseIfTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DateTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
abstract Component | ComponentTagSupport.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | BeanTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ActionTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
static String | StrutsBodyTagSupport.translateVariables(String expression, ValueStack stack)

Uses of ValueStack in org.apache.struts2.views.jsp.iterator

Methods in org.apache.struts2.views.jsp.iterator with parameters of type ValueStack
Component | MergeIteratorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | AppendIteratorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of ValueStack in org.apache.struts2.views.jsp.ui

Methods in org.apache.struts2.views.jsp.ui with parameters of type ValueStack
Component | UpDownSelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TreeTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TreeNodeTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TokenTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TextFieldTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TextareaTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TabbedPanelTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | SubmitTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | SelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ResetTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | RadioTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | PasswordTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | OptionTransferSelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | OptGroupTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | LabelTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | InputTransferSelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | HiddenTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | HeadTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | FormTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | FileTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | FieldErrorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DoubleSelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DivTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DebugTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DateTimePickerTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ComponentTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ComboBoxTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | CheckboxTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | CheckboxListTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | AutocompleterTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | AnchorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ActionMessageTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ActionErrorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of ValueStack in org.apache.struts2.views.jsp.ui.table

Methods in org.apache.struts2.views.jsp.ui.table with parameters of type ValueStack
 Component WebTableTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of ValueStack in org.apache.struts2.views.util

Methods in org.apache.struts2.views.util with parameters of type ValueStack
static Map ContextUtil.getStandardContext(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of ValueStack in org.apache.struts2.views.velocity

Fields in org.apache.struts2.views.velocity declared as ValueStack
(package private)  ValueStack StrutsVelocityContext.stack

Methods in org.apache.struts2.views.velocity with parameters of type ValueStack
 org.apache.velocity.context.Context VelocityManager.createContext(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
This method is responsible for creating the standard VelocityContext used by all WW2 velocity views.

Constructors in org.apache.struts2.views.velocity with parameters of type ValueStack
StrutsVelocityContext(ValueStack stack)
StrutsVelocityContext(org.apache.velocity.VelocityContext[] chainedContexts, ValueStack stack)

Uses of ValueStack in org.apache.struts2.views.velocity.components

Methods in org.apache.struts2.views.velocity.components with parameters of type ValueStack
protected Component | WebTableDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | URLDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | UpDownSelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TreeNodeDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TreeDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TokenDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TextFieldDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TextDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TextAreaDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TabbedPanelDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | SubmitDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | SetDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | SelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ResetDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | RadioDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | PushDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | PropertyDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | PasswordDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ParamDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | OptionTransferSelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | OptGroupDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | LabelDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | InputTransferSelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | IncludeDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | I18nDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | HiddenDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | HeadDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | FormDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | FileDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | FieldErrorDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | DoubleSelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | DivDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | DateTimePickerDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | DateDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ComponentDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ComboBoxDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | CheckBoxListDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | CheckBoxDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | BeanDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | AutocompleterDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | AnchorDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ActionMessageDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ActionErrorDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ActionDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected abstract Component | AbstractDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.ValueStackFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.ValueStackFactory

Packages that use ValueStackFactory
com.opensymphony.xwork2.util XWork util classes.

Uses of ValueStackFactory in com.opensymphony.xwork2.util

Subclasses of ValueStackFactory in com.opensymphony.xwork2.util
 class OgnlValueStackFactory
Creates an Ognl value stack

Fields in com.opensymphony.xwork2.util declared as ValueStackFactory
private static ValueStackFactory ValueStackFactory.factory

Methods in com.opensymphony.xwork2.util that return ValueStackFactory
static ValueStackFactory ValueStackFactory.getFactory()

Methods in com.opensymphony.xwork2.util with parameters of type ValueStackFactory
static void ValueStackFactory.setFactory(ValueStackFactory factory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.WildcardHelper (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.WildcardHelper

Packages that use WildcardHelper
com.opensymphony.xwork2.config.impl Configuration implementation classes.

Uses of WildcardHelper in com.opensymphony.xwork2.config.impl

Fields in com.opensymphony.xwork2.config.impl declared as WildcardHelper
private static WildcardHelper ActionConfigMatcher.wildcard
Handles all wildcard pattern matching.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkBasicConverter (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkBasicConverter

No usage of com.opensymphony.xwork2.util.XWorkBasicConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkCollectionPropertyAccessor

Packages that use XWorkCollectionPropertyAccessor
com.opensymphony.xwork2.util XWork util classes.

Uses of XWorkCollectionPropertyAccessor in com.opensymphony.xwork2.util

Fields in com.opensymphony.xwork2.util declared as XWorkCollectionPropertyAccessor
private  XWorkCollectionPropertyAccessor XWorkListPropertyAccessor._sAcc

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkConverter (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkConverter

Packages that use XWorkConverter
com.opensymphony.xwork2.util XWork util classes.

Uses of XWorkConverter in com.opensymphony.xwork2.util

Subclasses of XWorkConverter in com.opensymphony.xwork2.util
 class AnnotationXWorkConverter

Type conversion is great for situations where you need to turn a String in to a more complex object.

Fields in com.opensymphony.xwork2.util declared as XWorkConverter
private static XWorkConverter | XWorkMapPropertyAccessor._converter
private static XWorkConverter | XWorkConverter.instance

Methods in com.opensymphony.xwork2.util that return XWorkConverter
static XWorkConverter XWorkConverter.getInstance()

Methods in com.opensymphony.xwork2.util with parameters of type XWorkConverter
static void XWorkConverter.setInstance(XWorkConverter instance)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkEnumerationAcccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkEnumerationAcccessor

No usage of com.opensymphony.xwork2.util.XWorkEnumerationAcccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor

No usage of com.opensymphony.xwork2.util.XWorkIteratorPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkList (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkList

No usage of com.opensymphony.xwork2.util.XWorkList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkListPropertyAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkListPropertyAccessor

No usage of com.opensymphony.xwork2.util.XWorkListPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkMap (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkMap

No usage of com.opensymphony.xwork2.util.XWorkMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkMapPropertyAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

No usage of com.opensymphony.xwork2.util.XWorkMapPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkMethodAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkMethodAccessor

No usage of com.opensymphony.xwork2.util.XWorkMethodAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkObjectPropertyAccessor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkObjectPropertyAccessor

No usage of com.opensymphony.xwork2.util.XWorkObjectPropertyAccessor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.XWorkTestCaseHelper (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.XWorkTestCaseHelper

No usage of com.opensymphony.xwork2.util.XWorkTestCaseHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.util.location (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.util.location
Interfaces
Locatable
Location
LocationUtils.LocationFinder
Classes
LocatableProperties
Located
LocationAttributes
LocationAttributes.Pipe
LocationImpl
LocationUtils


Uses of Interface com.opensymphony.xwork2.util.location.Locatable (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.util.location.Locatable

Packages that use Locatable
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.util.location | Classes and utilities used to track location information.
com.opensymphony.xwork2.validator | XWork validation subsystem.
org.apache.struts2 | Main Struts interfaces and classes.

Uses of Locatable in com.opensymphony.xwork2

Classes in com.opensymphony.xwork2 that implement Locatable
 class XWorkException
A generic runtime exception that optionally contains Location information

Uses of Locatable in com.opensymphony.xwork2.config

Classes in com.opensymphony.xwork2.config that implement Locatable
class | ConfigurationException ConfigurationException
class | ReferenceResolverException Exception when a reference can't be resolved.

Uses of Locatable in com.opensymphony.xwork2.config.entities

Classes in com.opensymphony.xwork2.config.entities that implement Locatable
class | ActionConfig Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
class | ExceptionMappingConfig Configuration for exception mapping.
class | InterceptorConfig Configuration for Interceptors.
class | InterceptorStackConfig Configuration for InterceptorStack.
class | PackageConfig Configuration for Package.
class | ResultConfig Configuration for Result.
class | ResultTypeConfig Configuration class for result types.

Uses of Locatable in com.opensymphony.xwork2.config.impl

Classes in com.opensymphony.xwork2.config.impl that implement Locatable
(package private) class | DefaultConfiguration.ContainerProperties
class | LocatableConstantFactory<T> Factory that remembers where a constant came from
class | LocatableFactory<T> Attaches location information to the factory.

Uses of Locatable in com.opensymphony.xwork2.util

Classes in com.opensymphony.xwork2.util that implement Locatable
 class TypeConversionException
TypeConversionException should be thrown by any TypeConverters which fail to convert values

Uses of Locatable in com.opensymphony.xwork2.util.location

Classes in com.opensymphony.xwork2.util.location that implement Locatable
class | LocatableProperties Properties implementation that remembers the location of each property.
class | Located Base class for location aware objects

Uses of Locatable in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement Locatable
 class ValidatorConfig
Holds the necessary information for configuring an instance of a Validator.

Uses of Locatable in org.apache.struts2

Classes in org.apache.struts2 that implement Locatable
 class StrutsException
A generic runtime exception that optionally contains Location information

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocatableProperties (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocatableProperties

Packages that use LocatableProperties
com.opensymphony.xwork2.config | Configuration core classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
org.apache.struts2.config | Classes for Struts configuration and property handling.

Uses of LocatableProperties in com.opensymphony.xwork2.config

Methods in com.opensymphony.xwork2.config with parameters of type LocatableProperties
 void ConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)

Uses of LocatableProperties in com.opensymphony.xwork2.config.impl

Subclasses of LocatableProperties in com.opensymphony.xwork2.config.impl
(package private)  class DefaultConfiguration.ContainerProperties

Uses of LocatableProperties in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type LocatableProperties
 void XmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)

Uses of LocatableProperties in org.apache.struts2.config

Fields in org.apache.struts2.config declared as LocatableProperties
(package private)  LocatableProperties PropertiesSettings.settings

Methods in org.apache.struts2.config with parameters of type LocatableProperties
protected void | LegacyPropertiesConfigurationProvider.loadSettings(LocatableProperties props, Settings settings)
void | StrutsXmlConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties props)
void | MethodConfigurationProvider.register(ContainerBuilder containerBuilder, LocatableProperties locatableProperties)
void | LegacyPropertiesConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | DefaultPropertiesProvider.register(ContainerBuilder builder, LocatableProperties props)
void | ClasspathConfigurationProvider.register(ContainerBuilder builder, LocatableProperties props)
void | BeanSelectionProvider.register(ContainerBuilder builder, LocatableProperties props)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.Located (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.Located

Packages that use Located
com.opensymphony.xwork2.config.entities | Configuration entity classes.
com.opensymphony.xwork2.config.impl | Configuration implementation classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.

Uses of Located in com.opensymphony.xwork2.config.entities

Subclasses of Located in com.opensymphony.xwork2.config.entities
class | ActionConfig Contains everything needed to configure and execute an action: methodName - the method name to execute on the action.
class | ExceptionMappingConfig Configuration for exception mapping.
class | InterceptorConfig Configuration for Interceptors.
class | InterceptorStackConfig Configuration for InterceptorStack.
class | PackageConfig Configuration for Package.
class | ResultConfig Configuration for Result.
class | ResultTypeConfig Configuration class for result types.

Uses of Located in com.opensymphony.xwork2.config.impl

Subclasses of Located in com.opensymphony.xwork2.config.impl
class | LocatableConstantFactory<T> Factory that remembers where a constant came from
class | LocatableFactory<T> Attaches location information to the factory.

Uses of Located in com.opensymphony.xwork2.validator

Subclasses of Located in com.opensymphony.xwork2.validator
 class ValidatorConfig
Holds the necessary information for configuring an instance of a Validator.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.location.Location (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.util.location.Location

Packages that use Location
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.config.providers | Configuration provider classes.
com.opensymphony.xwork2.util | XWork util classes.
com.opensymphony.xwork2.util.location | Classes and utilities used to track location information.
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).

Uses of Location in com.opensymphony.xwork2

Fields in com.opensymphony.xwork2 declared as Location
private  Location XWorkException.location

Methods in com.opensymphony.xwork2 that return Location
 Location XWorkException.getLocation()
Gets the location of the error, if available

Uses of Location in com.opensymphony.xwork2.config.providers

Methods in com.opensymphony.xwork2.config.providers with parameters of type Location
static List<InterceptorMapping> | InterceptorBuilder.constructInterceptorReference(PackageConfig packageConfig, String refName, Map refParams, Location location, ObjectFactory objectFactory) Builds a list of interceptors referenced by the refName in the supplied PackageConfig.
protected boolean | XmlConfigurationProvider.verifyAction(String className, String name, Location loc)
protected Class | XmlConfigurationProvider.verifyResultType(String className, Location loc)

Uses of Location in com.opensymphony.xwork2.util

Methods in com.opensymphony.xwork2.util that return Location
static Location DomHelper.getLocationObject(Element element)

Uses of Location in com.opensymphony.xwork2.util.location

Classes in com.opensymphony.xwork2.util.location that implement Location
 class LocationImpl
A simple immutable and serializable implementation of Location.

Fields in com.opensymphony.xwork2.util.location declared as Location
(package private) Location | LocatableProperties.location
protected Location | Located.location
static Location | Location.UNKNOWN Constant for unknown locations.

Fields in com.opensymphony.xwork2.util.location with type parameters of type Location
(package private)  Map<String,Location> LocatableProperties.propLocations

Methods in com.opensymphony.xwork2.util.location that return Location
 Location Locatable.getLocation()
Get the location of this object
 Location LocatableProperties.getLocation()
 Location Located.getLocation()
Get the location of this object
static Location LocationAttributes.getLocation(Attributes attrs, String description)
Returns the Location of an element (SAX flavor).
static Location LocationAttributes.getLocation(Element elem)
Same as getLocation(elem, null).
static Location LocationAttributes.getLocation(Element elem, String description)
Returns the Location of an element (DOM flavor).
static Location LocationUtils.getLocation(Object obj)
Get the location of an object.
static Location LocationUtils.getLocation(Object obj, String description)
Get the location of an object.
 Location LocationUtils.LocationFinder.getLocation(Object obj, String description)
Get the location of an object
 Location LocatableProperties.getPropertyLocation(String key)

Methods in com.opensymphony.xwork2.util.location with parameters of type Location
static LocationImpl | LocationImpl.get(Location location) Obtain a LocationImpl from a Location.
static boolean | LocationUtils.isKnown(Location location) Checks if a location is known, i.e.
static boolean | LocationUtils.isUnknown(Location location) Checks if a location is unknown, i.e.
void | Located.setLocation(Location loc) Set the location of this object
static String | LocationUtils.toString(Location location) Builds a string representation of a location, in the "descripton - uri:line:column" format (e.g.

Constructors in com.opensymphony.xwork2.util.location with parameters of type Location
LocatableProperties(Location loc)
LocationImpl(Location location)
Copy constructor.
LocationImpl(String description, Location location)
Create a location from an existing one, but with a different description

Uses of Location in org.apache.struts2.config

Methods in org.apache.struts2.config that return Location
static Location Settings.getLocation(String name)
Provides the Location of a setting.
 Location Settings.getLocationImpl(String name)
Implements the Settings.getLocation(String) method.
 Location PropertiesSettings.getLocationImpl(String aName)
Gets the location of a property from the properties file.

Uses of Location in org.apache.struts2.dispatcher

Methods in org.apache.struts2.dispatcher that return Location
 Location Dispatcher.Locator.getLocation(Object obj)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocationAttributes (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocationAttributes

No usage of com.opensymphony.xwork2.util.location.LocationAttributes

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocationAttributes.Pipe (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

No usage of com.opensymphony.xwork2.util.location.LocationAttributes.Pipe

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocationImpl (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocationImpl

Packages that use LocationImpl
com.opensymphony.xwork2.util.location Classes and utilities used to track location information.

Uses of LocationImpl in com.opensymphony.xwork2.util.location

Fields in com.opensymphony.xwork2.util.location declared as LocationImpl
(package private) static LocationImpl LocationImpl.UNKNOWN

Methods in com.opensymphony.xwork2.util.location that return LocationImpl
static LocationImpl | LocationImpl.get(Location location) Obtain a LocationImpl from a Location.
static LocationImpl | LocationUtils.parse(String text) Parse a location string of the form "uri:line:column" (e.g.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.location.LocationUtils (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.location.LocationUtils

No usage of com.opensymphony.xwork2.util.location.LocationUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.util.location.LocationUtils.LocationFinder

Packages that use LocationUtils.LocationFinder
com.opensymphony.xwork2.util.location Classes and utilities used to track location information.

Uses of LocationUtils.LocationFinder in com.opensymphony.xwork2.util.location

Methods in com.opensymphony.xwork2.util.location with parameters of type LocationUtils.LocationFinder
static void LocationUtils.addFinder(LocationUtils.LocationFinder finder)
Add a LocationUtils.LocationFinder to the list of finders that will be queried for an object's location by LocationUtils.getLocation(Object, String).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.util.profiling (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.util.profiling
Interfaces
UtilTimerStack.ProfilingBlock
Classes
ObjectProfiler
ProfilingTimerBean
TimerInvocationHandler
UtilTimerStack


UtilTimerStack.ProfilingBlock (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

com.opensymphony.xwork2.util.profiling
Interface UtilTimerStack.ProfilingBlock<T>

Type Parameters:
T -
Enclosing class:
UtilTimerStack
public static interface UtilTimerStack.ProfilingBlock<T>

A callback interface where code subjected to profile is to be executed. This eliminates the need of coding boiler code that does pushing (UtilTimerBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ... finally ... block.

Version:
$Date$ $Id$

Method Summary
 T doProfiling()
Method that execute the code subjected to profiling.

Method Detail

doProfiling

T doProfiling()
              throws Exception
Method that execute the code subjected to profiling.

Returns:
profiles Type
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Uses of Class com.opensymphony.xwork2.util.profiling.ObjectProfiler (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.profiling.ObjectProfiler

No usage of com.opensymphony.xwork2.util.profiling.ObjectProfiler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.profiling.ProfilingTimerBean (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.profiling.ProfilingTimerBean

Packages that use ProfilingTimerBean
com.opensymphony.xwork2.util.profiling Classes to enable profiling of action execution.

Uses of ProfilingTimerBean in com.opensymphony.xwork2.util.profiling

Fields in com.opensymphony.xwork2.util.profiling declared as ProfilingTimerBean
(package private)  ProfilingTimerBean ProfilingTimerBean.parent

Fields in com.opensymphony.xwork2.util.profiling with type parameters of type ProfilingTimerBean
(package private) List<ProfilingTimerBean> | ProfilingTimerBean.children
protected static ThreadLocal<ProfilingTimerBean> | UtilTimerStack.current

Methods in com.opensymphony.xwork2.util.profiling that return ProfilingTimerBean
 ProfilingTimerBean ProfilingTimerBean.getParent()

Methods in com.opensymphony.xwork2.util.profiling with parameters of type ProfilingTimerBean
void | ProfilingTimerBean.addChild(ProfilingTimerBean child)
protected void | ProfilingTimerBean.addParent(ProfilingTimerBean parent)
private static void | UtilTimerStack.printTimes(ProfilingTimerBean currentTimer) Do a log (at INFO level) of the time taken for this particular profiling.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.profiling.TimerInvocationHandler (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.profiling.TimerInvocationHandler

No usage of com.opensymphony.xwork2.util.profiling.TimerInvocationHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.util.profiling.UtilTimerStack (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.util.profiling.UtilTimerStack

No usage of com.opensymphony.xwork2.util.profiling.UtilTimerStack

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.util.profiling.UtilTimerStack.ProfilingBlock

Packages that use UtilTimerStack.ProfilingBlock
com.opensymphony.xwork2.util.profiling Classes to enable profiling of action execution.

Uses of UtilTimerStack.ProfilingBlock in com.opensymphony.xwork2.util.profiling

Methods in com.opensymphony.xwork2.util.profiling with parameters of type UtilTimerStack.ProfilingBlock
static
<T> T
UtilTimerStack.profile(String name, UtilTimerStack.ProfilingBlock<T> block)
A convenience method that allows block of code subjected to profiling to be executed and avoid the need of coding boiler code that does pushing (UtilTimeBean.push(...)) and poping (UtilTimerBean.pop(...)) in a try ...

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.validator (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.validator
Interfaces
ActionValidatorManager
FieldValidator
ShortCircuitableValidator
Validator
ValidatorContext
Classes
ActionValidatorManagerFactory
AnnotationActionValidatorManager
AnnotationValidationConfigurationBuilder
DefaultActionValidatorManager
DelegatingValidatorContext
DelegatingValidatorContext.ActionContextLocaleProvider
DelegatingValidatorContext.LoggingValidationAware
ValidationInterceptor
ValidatorConfig
ValidatorFactory
ValidatorFileParser
Exceptions
ValidationException


com.opensymphony.xwork2.validator.annotations (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.validator.annotations
Enums
ValidatorType
Annotation Types
ConversionErrorFieldValidator
CustomValidator
DateRangeFieldValidator
DoubleRangeFieldValidator
EmailValidator
ExpressionValidator
FieldExpressionValidator
IntRangeFieldValidator
RegexFieldValidator
RequiredFieldValidator
RequiredStringValidator
StringLengthFieldValidator
StringRegexValidator
UrlValidator
Validation
ValidationParameter
Validations
VisitorFieldValidator


Uses of Class com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ConversionErrorFieldValidator

Packages that use ConversionErrorFieldValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of ConversionErrorFieldValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type ConversionErrorFieldValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processConversionErrorFieldValidatorAnnotation(ConversionErrorFieldValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.CustomValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.CustomValidator

Packages that use CustomValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of CustomValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type CustomValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processCustomValidatorAnnotation(CustomValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.DateRangeFieldValidator

Packages that use DateRangeFieldValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of DateRangeFieldValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type DateRangeFieldValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processDateRangeFieldValidatorAnnotation(DateRangeFieldValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.DoubleRangeFieldValidator

Packages that use DoubleRangeFieldValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of DoubleRangeFieldValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type DoubleRangeFieldValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processDoubleRangeFieldValidatorAnnotation(DoubleRangeFieldValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.EmailValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.EmailValidator

Packages that use EmailValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of EmailValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type EmailValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processEmailValidatorAnnotation(EmailValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.ExpressionValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ExpressionValidator

Packages that use ExpressionValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of ExpressionValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type ExpressionValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processExpressionValidatorAnnotation(ExpressionValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.FieldExpressionValidator

Packages that use FieldExpressionValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of FieldExpressionValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type FieldExpressionValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processFieldExpressionValidatorAnnotation(FieldExpressionValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.IntRangeFieldValidator

Packages that use IntRangeFieldValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of IntRangeFieldValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type IntRangeFieldValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processIntRangeFieldValidatorAnnotation(IntRangeFieldValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.RegexFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.RegexFieldValidator

Packages that use RegexFieldValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of RegexFieldValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type RegexFieldValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processRegexFieldValidatorAnnotation(RegexFieldValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.RequiredFieldValidator

Packages that use RequiredFieldValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of RequiredFieldValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type RequiredFieldValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processRequiredFieldValidatorAnnotation(RequiredFieldValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.RequiredStringValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.RequiredStringValidator

Packages that use RequiredStringValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of RequiredStringValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type RequiredStringValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processRequiredStringValidatorAnnotation(RequiredStringValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.StringLengthFieldValidator

Packages that use StringLengthFieldValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of StringLengthFieldValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type StringLengthFieldValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processStringLengthFieldValidatorAnnotation(StringLengthFieldValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.StringRegexValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.StringRegexValidator

Packages that use StringRegexValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of StringRegexValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type StringRegexValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processStringRegexValidatorAnnotation(StringRegexValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.UrlValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.UrlValidator

Packages that use UrlValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of UrlValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type UrlValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processUrlValidatorAnnotation(UrlValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.Validation (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.Validation

No usage of com.opensymphony.xwork2.validator.annotations.Validation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.ValidationParameter (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ValidationParameter

No usage of com.opensymphony.xwork2.validator.annotations.ValidationParameter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.Validations (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.Validations

No usage of com.opensymphony.xwork2.validator.annotations.Validations

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.ValidatorType (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.ValidatorType

Packages that use ValidatorType
com.opensymphony.xwork2.validator.annotations Validator annotations.

Uses of ValidatorType in com.opensymphony.xwork2.validator.annotations

Methods in com.opensymphony.xwork2.validator.annotations that return ValidatorType
static ValidatorType | ValidatorType.valueOf(String name) Returns the enum constant of this type with the specified name.
static ValidatorType[] | ValidatorType.values() Returns an array containing the constants of this enum type, in the order they're declared.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.annotations.VisitorFieldValidator

Packages that use VisitorFieldValidator
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of VisitorFieldValidator in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator with parameters of type VisitorFieldValidator
private static ValidatorConfig AnnotationValidationConfigurationBuilder.processVisitorFieldValidatorAnnotation(VisitorFieldValidator v, String fieldName)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.ActionValidatorManager (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.ActionValidatorManager

Packages that use ActionValidatorManager
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of ActionValidatorManager in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement ActionValidatorManager
class | AnnotationActionValidatorManager AnnotationActionValidatorManager This is the entry point into XWork's annotations-based validator framework.
class | DefaultActionValidatorManager This is the entry point into XWork's rule-based validation framework.

Fields in com.opensymphony.xwork2.validator declared as ActionValidatorManager
private static ActionValidatorManager ActionValidatorManagerFactory.instance

Methods in com.opensymphony.xwork2.validator that return ActionValidatorManager
static ActionValidatorManager ActionValidatorManagerFactory.getInstance()

Methods in com.opensymphony.xwork2.validator with parameters of type ActionValidatorManager
static void ActionValidatorManagerFactory.setInstance(ActionValidatorManager instance)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ActionValidatorManagerFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ActionValidatorManagerFactory

No usage of com.opensymphony.xwork2.validator.ActionValidatorManagerFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.AnnotationActionValidatorManager (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

No usage of com.opensymphony.xwork2.validator.AnnotationActionValidatorManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

No usage of com.opensymphony.xwork2.validator.AnnotationValidationConfigurationBuilder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DefaultActionValidatorManager (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DefaultActionValidatorManager

No usage of com.opensymphony.xwork2.validator.DefaultActionValidatorManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DelegatingValidatorContext (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DelegatingValidatorContext

Packages that use DelegatingValidatorContext
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of DelegatingValidatorContext in com.opensymphony.xwork2.validator.validators

Subclasses of DelegatingValidatorContext in com.opensymphony.xwork2.validator.validators
private  class VisitorFieldValidator.AppendingValidatorContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DelegatingValidatorContext.ActionContextLocaleProvider (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DelegatingValidatorContext.ActionContextLocaleProvider

No usage of com.opensymphony.xwork2.validator.DelegatingValidatorContext.ActionContextLocaleProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

No usage of com.opensymphony.xwork2.validator.DelegatingValidatorContext.LoggingValidationAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.FieldValidator (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.FieldValidator

Packages that use FieldValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of FieldValidator in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement FieldValidator
class | AbstractRangeValidator Base class for range based validators.
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | FieldValidatorSupport Base class for field validators.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.ShortCircuitableValidator (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.ShortCircuitableValidator

Packages that use ShortCircuitableValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of ShortCircuitableValidator in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement ShortCircuitableValidator
class | AbstractRangeValidator Base class for range based validators.
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | ExpressionValidator A Non-Field Level validator that validates based on regular expression supplied.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | FieldValidatorSupport Base class for field validators.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | ValidatorSupport Abstract implementation of the Validator interface suitable for subclassing.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidationException (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidationException

Packages that use ValidationException
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of ValidationException in com.opensymphony.xwork2.validator

Methods in com.opensymphony.xwork2.validator that throw ValidationException
void | Validator.validate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
void | ActionValidatorManager.validate(Object object, String context) Validates the given object using action and its context.
void | AnnotationActionValidatorManager.validate(Object object, String context) Validates the given object using action and its context.
void | DefaultActionValidatorManager.validate(Object object, String context) Validates the given object using action and its context.
void | ActionValidatorManager.validate(Object object, String context, String method) Validates the given object using an action, its context, and the name of the method being invoked on the action.
void | AnnotationActionValidatorManager.validate(Object object, String context, String method) Validates the given object using action, its context, and the name of the method being invoked on the action.
void | DefaultActionValidatorManager.validate(Object object, String context, String method) Validates the given object using action, its context, and the name of the method being invoked on the action.
void | ActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | AnnotationActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | DefaultActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | ActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context and a validation context.
void | AnnotationActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context, a validation context, and the name of the method being invoked on the action.
void | DefaultActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context, a validation context, and the name of the method being invoked on the action.

Uses of ValidationException in com.opensymphony.xwork2.validator.validators

Methods in com.opensymphony.xwork2.validator.validators that throw ValidationException
void | ConversionErrorFieldValidator.doValidate(Object object) The validation implementation must guarantee that setValidatorContext will be called with a non-null ValidatorContext before validate is called.
protected abstract void | RepopulateConversionErrorFieldValidatorSupport.doValidate(Object object)
protected Object | ValidatorSupport.getFieldValue(String name, Object object) Return the field value named name from object, object should have the appropriate getter/setter.
void | RepopulateConversionErrorFieldValidatorSupport.repopulateField(Object object)
void | AbstractRangeValidator.validate(Object object)
void | DoubleRangeFieldValidator.validate(Object object)
void | ExpressionValidator.validate(Object object)
void | FieldExpressionValidator.validate(Object object)
void | RegexFieldValidator.validate(Object object)
void | RepopulateConversionErrorFieldValidatorSupport.validate(Object object)
void | RequiredFieldValidator.validate(Object object)
void | RequiredStringValidator.validate(Object object)
void | StringLengthFieldValidator.validate(Object object)
void | URLValidator.validate(Object object)
void | VisitorFieldValidator.validate(Object object)
private void | VisitorFieldValidator.validateArrayElements(Object[] array, String fieldName, String visitorContext)
private void | VisitorFieldValidator.validateObject(String fieldName, Object o, String visitorContext)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidationInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidationInterceptor

Packages that use ValidationInterceptor
org.apache.struts2.interceptor.validation

Uses of ValidationInterceptor in org.apache.struts2.interceptor.validation

Subclasses of ValidationInterceptor in org.apache.struts2.interceptor.validation
 class AnnotationValidationInterceptor
Extends the xwork validation interceptor to also check for a @SkipValidation annotation, and if found, don't validate this action method

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.Validator (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.Validator

Packages that use Validator
com.opensymphony.xwork2 | Main Xwork interfaces and classes.
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of Validator in com.opensymphony.xwork2

Methods in com.opensymphony.xwork2 that return Validator
 Validator ObjectFactory.buildValidator(String className, Map params, Map extraContext)
Build a Validator of the given type and set the parameters on it

Uses of Validator in com.opensymphony.xwork2.validator

Subinterfaces of Validator in com.opensymphony.xwork2.validator
 interface FieldValidator
The FieldValidator interface defines the methods to be implemented by FieldValidators, which are used by the XWork validation framework to validate Action properties before executing the Action.

Methods in com.opensymphony.xwork2.validator that return Validator
static Validator | ValidatorFactory.getValidator(ValidatorConfig cfg) Deprecated.
static Validator | ValidatorFactory.getValidator(ValidatorConfig cfg, ObjectFactory objectFactory) Get a Validator that matches the given configuration.

Methods in com.opensymphony.xwork2.validator that return types with arguments of type Validator
List<Validator> | ActionValidatorManager.getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | AnnotationActionValidatorManager.getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | DefaultActionValidatorManager.getValidators(Class clazz, String context) Returns a list of validators for the given class and context.
List<Validator> | ActionValidatorManager.getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method.
List<Validator> | AnnotationActionValidatorManager.getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method.
List<Validator> | DefaultActionValidatorManager.getValidators(Class clazz, String context, String method) Returns a list of validators for the given class, context, and method name.

Uses of Validator in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement Validator
class | AbstractRangeValidator Base class for range based validators.
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | ExpressionValidator A Non-Field Level validator that validates based on regular expression supplied.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | FieldValidatorSupport Base class for field validators.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | ValidatorSupport Abstract implementation of the Validator interface suitable for subclassing.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidatorConfig (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidatorConfig

Packages that use ValidatorConfig
com.opensymphony.xwork2.validator XWork validation subsystem.

Uses of ValidatorConfig in com.opensymphony.xwork2.validator

Fields in com.opensymphony.xwork2.validator with type parameters of type ValidatorConfig
private static Map<String,List<ValidatorConfig>> | AnnotationActionValidatorManager.validatorCache
private static Map<String,List<ValidatorConfig>> | DefaultActionValidatorManager.validatorCache
private static Map<String,List<ValidatorConfig>> | AnnotationActionValidatorManager.validatorFileCache
private static Map<String,List<ValidatorConfig>> | DefaultActionValidatorManager.validatorFileCache

Methods in com.opensymphony.xwork2.validator that return ValidatorConfig
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processConversionErrorFieldValidatorAnnotation(ConversionErrorFieldValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processCustomValidatorAnnotation(CustomValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processDateRangeFieldValidatorAnnotation(DateRangeFieldValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processDoubleRangeFieldValidatorAnnotation(DoubleRangeFieldValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processEmailValidatorAnnotation(EmailValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processExpressionValidatorAnnotation(ExpressionValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processFieldExpressionValidatorAnnotation(FieldExpressionValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processIntRangeFieldValidatorAnnotation(IntRangeFieldValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processRegexFieldValidatorAnnotation(RegexFieldValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processRequiredFieldValidatorAnnotation(RequiredFieldValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processRequiredStringValidatorAnnotation(RequiredStringValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processStringLengthFieldValidatorAnnotation(StringLengthFieldValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processStringRegexValidatorAnnotation(StringRegexValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processUrlValidatorAnnotation(UrlValidator v, String fieldName)
private static ValidatorConfig | AnnotationValidationConfigurationBuilder.processVisitorFieldValidatorAnnotation(VisitorFieldValidator v, String fieldName)

Methods in com.opensymphony.xwork2.validator that return types with arguments of type ValidatorConfig
private List<ValidatorConfig> | AnnotationActionValidatorManager.buildAliasValidatorConfigs(Class aClass, String context, boolean checkFile)
private List<ValidatorConfig> | DefaultActionValidatorManager.buildAliasValidatorConfigs(Class aClass, String context, boolean checkFile)
static List<ValidatorConfig> | AnnotationValidationConfigurationBuilder.buildAnnotationClassValidatorConfigs(Class aClass)
protected List<ValidatorConfig> | AnnotationActionValidatorManager.buildClassValidatorConfigs(Class aClass, boolean checkFile)
private List<ValidatorConfig> | DefaultActionValidatorManager.buildClassValidatorConfigs(Class aClass, boolean checkFile)
private List<ValidatorConfig> | AnnotationActionValidatorManager.buildValidatorConfigs(Class clazz, String context, boolean checkFile, Set checked) This method 'collects' all the validator configurations for a given action invocation.
private List<ValidatorConfig> | DefaultActionValidatorManager.buildValidatorConfigs(Class clazz, String context, boolean checkFile, Set checked) This method 'collects' all the validator configurations for a given action invocation.
private List<ValidatorConfig> | AnnotationActionValidatorManager.loadFile(String fileName, Class clazz, boolean checkFile)
private List<ValidatorConfig> | DefaultActionValidatorManager.loadFile(String fileName, Class clazz, boolean checkFile)
private static List<ValidatorConfig> | AnnotationValidationConfigurationBuilder.processAnnotations(Object o)

Methods in com.opensymphony.xwork2.validator with parameters of type ValidatorConfig
static Validator | ValidatorFactory.getValidator(ValidatorConfig cfg) Deprecated.
static Validator | ValidatorFactory.getValidator(ValidatorConfig cfg, ObjectFactory objectFactory) Get a Validator that matches the given configuration.

Method parameters in com.opensymphony.xwork2.validator with type arguments of type ValidatorConfig
private static void AnnotationValidationConfigurationBuilder.processValidationAnnotation(Annotation a, String fieldName, List<ValidatorConfig> result)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.ValidatorContext (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.ValidatorContext

Packages that use ValidatorContext
com.opensymphony.xwork2.validator | XWork validation subsystem.
com.opensymphony.xwork2.validator.validators | XWork default validator classes.

Uses of ValidatorContext in com.opensymphony.xwork2.validator

Classes in com.opensymphony.xwork2.validator that implement ValidatorContext
 class DelegatingValidatorContext
A default implementation of the ValidatorContext interface.

Methods in com.opensymphony.xwork2.validator that return ValidatorContext
 ValidatorContext Validator.getValidatorContext()

Methods in com.opensymphony.xwork2.validator with parameters of type ValidatorContext
void | Validator.setValidatorContext(ValidatorContext validatorContext) This method will be called before validate with a non-null ValidatorContext.
void | ActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | AnnotationActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | DefaultActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext) Validates an action give its context and a validation context.
void | ActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context and a validation context.
void | AnnotationActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context, a validation context, and the name of the method being invoked on the action.
void | DefaultActionValidatorManager.validate(Object object, String context, ValidatorContext validatorContext, String method) Validates an action give its context, a validation context, and the name of the method being invoked on the action.

Uses of ValidatorContext in com.opensymphony.xwork2.validator.validators

Classes in com.opensymphony.xwork2.validator.validators that implement ValidatorContext
private  class VisitorFieldValidator.AppendingValidatorContext

Fields in com.opensymphony.xwork2.validator.validators declared as ValidatorContext
private  ValidatorContext ValidatorSupport.validatorContext

Methods in com.opensymphony.xwork2.validator.validators that return ValidatorContext
 ValidatorContext ValidatorSupport.getValidatorContext()

Methods in com.opensymphony.xwork2.validator.validators with parameters of type ValidatorContext
 void ValidatorSupport.setValidatorContext(ValidatorContext validatorContext)

Constructors in com.opensymphony.xwork2.validator.validators with parameters of type ValidatorContext
VisitorFieldValidator.AppendingValidatorContext(ValidatorContext parent, Object object, String field, String message)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidatorFactory (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidatorFactory

No usage of com.opensymphony.xwork2.validator.ValidatorFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.ValidatorFileParser (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.ValidatorFileParser

No usage of com.opensymphony.xwork2.validator.ValidatorFileParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.validator.metadata (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.validator.metadata
Interfaces
ValidatorDescription
Classes
AbstractFieldValidatorDescription
ConversionErrorFieldValidatorDescription
DateRangeFieldValidatorDescription
DoubleRangeFieldValidatorDescription
EmailValidatorDescription
ExpressionValidatorDescription
FieldExpressionValidatorDescription
IntRangeFieldValidatorDescription
RequiredFieldValidatorDescription
RequiredStringValidatorDescription
StringLengthFieldValidatorDescription
URLValidatorDescription
VisitorFieldValidatorDescription


Uses of Class com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.AbstractFieldValidatorDescription

Packages that use AbstractFieldValidatorDescription
com.opensymphony.xwork2.validator.metadata Validator meta data classes.

Uses of AbstractFieldValidatorDescription in com.opensymphony.xwork2.validator.metadata

Subclasses of AbstractFieldValidatorDescription in com.opensymphony.xwork2.validator.metadata
class | ConversionErrorFieldValidatorDescription ConversionErrorFieldValidatorDescription
class | DateRangeFieldValidatorDescription DateRangeFieldValidatorDescription
class | DoubleRangeFieldValidatorDescription DoubleRangeFieldValidatorDescription
class | EmailValidatorDescription EmailValidatorDescription
class | FieldExpressionValidatorDescription FieldExpressionValidatorDescription
class | IntRangeFieldValidatorDescription IntRangeFieldValidatorDescription
class | RequiredFieldValidatorDescription RequiredFieldValidatorDescription
class | RequiredStringValidatorDescription RequiredStringValidatorDescription
class | StringLengthFieldValidatorDescription StringLengthFieldValidatorDescription
class | URLValidatorDescription URLValidatorDescription
class | VisitorFieldValidatorDescription VisitorFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.ConversionErrorFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.DateRangeFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.DoubleRangeFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.EmailValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.ExpressionValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.FieldExpressionValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.IntRangeFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.RequiredFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.RequiredStringValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.StringLengthFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.URLValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.URLValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.URLValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface com.opensymphony.xwork2.validator.metadata.ValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Interface
com.opensymphony.xwork2.validator.metadata.ValidatorDescription

Packages that use ValidatorDescription
com.opensymphony.xwork2.validator.metadata Validator meta data classes.

Uses of ValidatorDescription in com.opensymphony.xwork2.validator.metadata

Classes in com.opensymphony.xwork2.validator.metadata that implement ValidatorDescription
class | AbstractFieldValidatorDescription AbstractFieldValidatorDescription
class | ConversionErrorFieldValidatorDescription ConversionErrorFieldValidatorDescription
class | DateRangeFieldValidatorDescription DateRangeFieldValidatorDescription
class | DoubleRangeFieldValidatorDescription DoubleRangeFieldValidatorDescription
class | EmailValidatorDescription EmailValidatorDescription
class | ExpressionValidatorDescription ExpressionValidatorDescription
class | FieldExpressionValidatorDescription FieldExpressionValidatorDescription
class | IntRangeFieldValidatorDescription IntRangeFieldValidatorDescription
class | RequiredFieldValidatorDescription RequiredFieldValidatorDescription
class | RequiredStringValidatorDescription RequiredStringValidatorDescription
class | StringLengthFieldValidatorDescription StringLengthFieldValidatorDescription
class | URLValidatorDescription URLValidatorDescription
class | VisitorFieldValidatorDescription VisitorFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

No usage of com.opensymphony.xwork2.validator.metadata.VisitorFieldValidatorDescription

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


com.opensymphony.xwork2.validator.validators (Struts 2 Core 2.0.6 API)

 com.opensymphony.xwork2.validator.validators
Classes
AbstractRangeValidator
ConversionErrorFieldValidator
DateRangeFieldValidator
DoubleRangeFieldValidator
EmailValidator
ExpressionValidator
FieldExpressionValidator
FieldValidatorSupport
IntRangeFieldValidator
RegexFieldValidator
RepopulateConversionErrorFieldValidatorSupport
RequiredFieldValidator
RequiredStringValidator
StringLengthFieldValidator
URLValidator
ValidatorSupport
VisitorFieldValidator


Uses of Class com.opensymphony.xwork2.validator.validators.AbstractRangeValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.AbstractRangeValidator

Packages that use AbstractRangeValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of AbstractRangeValidator in com.opensymphony.xwork2.validator.validators

Subclasses of AbstractRangeValidator in com.opensymphony.xwork2.validator.validators
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.ConversionErrorFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.DateRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.DoubleRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.EmailValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.EmailValidator

No usage of com.opensymphony.xwork2.validator.validators.EmailValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.ExpressionValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.ExpressionValidator

No usage of com.opensymphony.xwork2.validator.validators.ExpressionValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.FieldExpressionValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

No usage of com.opensymphony.xwork2.validator.validators.FieldExpressionValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.FieldValidatorSupport (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.FieldValidatorSupport

Packages that use FieldValidatorSupport
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of FieldValidatorSupport in com.opensymphony.xwork2.validator.validators

Subclasses of FieldValidatorSupport in com.opensymphony.xwork2.validator.validators
class | AbstractRangeValidator Base class for range based validators.
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.IntRangeFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.RegexFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.RegexFieldValidator

Packages that use RegexFieldValidator
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of RegexFieldValidator in com.opensymphony.xwork2.validator.validators

Subclasses of RegexFieldValidator in com.opensymphony.xwork2.validator.validators
 class EmailValidator
EmailValidator checks that a given String field, if not empty, is a valid email address.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.RepopulateConversionErrorFieldValidatorSupport

Packages that use RepopulateConversionErrorFieldValidatorSupport
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of RepopulateConversionErrorFieldValidatorSupport in com.opensymphony.xwork2.validator.validators

Subclasses of RepopulateConversionErrorFieldValidatorSupport in com.opensymphony.xwork2.validator.validators
 class ConversionErrorFieldValidator
Field Validator that checks if a conversion error occured for this field.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.RequiredFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.RequiredFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.RequiredFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.RequiredStringValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.RequiredStringValidator

No usage of com.opensymphony.xwork2.validator.validators.RequiredStringValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.StringLengthFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.URLValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.URLValidator

No usage of com.opensymphony.xwork2.validator.validators.URLValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.ValidatorSupport (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.ValidatorSupport

Packages that use ValidatorSupport
com.opensymphony.xwork2.validator.validators XWork default validator classes.

Uses of ValidatorSupport in com.opensymphony.xwork2.validator.validators

Subclasses of ValidatorSupport in com.opensymphony.xwork2.validator.validators
class | AbstractRangeValidator Base class for range based validators.
class | ConversionErrorFieldValidator Field Validator that checks if a conversion error occured for this field.
class | DateRangeFieldValidator Field Validator that checks if the date supplied is within a specific range.
class | DoubleRangeFieldValidator Field Validator that checks if the double specified is within a certain range.
class | EmailValidator EmailValidator checks that a given String field, if not empty, is a valid email address.
class | ExpressionValidator A Non-Field Level validator that validates based on regular expression supplied.
class | FieldExpressionValidator Validates a field using an OGNL expression.
class | FieldValidatorSupport Base class for field validators.
class | IntRangeFieldValidator Field Validator that checks if the integer specified is within a certain range.
class | RegexFieldValidator Validates a string field using a regular expression.
class | RepopulateConversionErrorFieldValidatorSupport An abstract base class that adds in the capability to populate the stack with a fake parameter map when a conversion error has occurred and the 'repopulateField' property is set to "true".
class | RequiredFieldValidator RequiredFieldValidator checks if the specified field is not null.
class | RequiredStringValidator RequiredStringValidator checks that a String field is non-null and has a length > 0.
class | StringLengthFieldValidator StringLengthFieldValidator checks that a String field is of a certain length.
class | URLValidator URLValidator checks that a given field is a String and a valid URL fieldName - The field name this validator is validating.
class | VisitorFieldValidator The VisitorFieldValidator allows you to forward validation to object properties of your action using the object's own validation files.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

No usage of com.opensymphony.xwork2.validator.validators.VisitorFieldValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext (Struts 2 Core 2.0.6 API)

Uses of Class
com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

No usage of com.opensymphony.xwork2.validator.validators.VisitorFieldValidator.AppendingValidatorContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2 (Struts 2 Core 2.0.6 API)

 org.apache.struts2
Interfaces
StrutsStatics
Classes
RequestUtils
ServletActionContext
StrutsConstants
StrutsTestCase
TestNGStrutsTestCase
Exceptions
StrutsException


Uses of Class org.apache.struts2.RequestUtils (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.RequestUtils

No usage of org.apache.struts2.RequestUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.ServletActionContext (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.ServletActionContext

No usage of org.apache.struts2.ServletActionContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.StrutsConstants (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.StrutsConstants

No usage of org.apache.struts2.StrutsConstants

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.StrutsException (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.StrutsException

Packages that use StrutsException
org.apache.struts2.components |
org.apache.struts2.views.xslt | The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of StrutsException in org.apache.struts2.components

Methods in org.apache.struts2.components that return StrutsException
protected  StrutsException Component.fieldError(String field, String errorMsg, Exception e)
Constructs?a RuntimeException based on the given information.

Uses of StrutsException in org.apache.struts2.views.xslt

Methods in org.apache.struts2.views.xslt that return StrutsException
protected  StrutsException AbstractAdapterNode.operationNotSupported()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.StrutsStatics (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.StrutsStatics

Packages that use StrutsStatics
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.portlet.context |
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.portlet.interceptor |
org.apache.struts2.portlet.result |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.

Uses of StrutsStatics in org.apache.struts2

Classes in org.apache.struts2 that implement StrutsStatics
 class ServletActionContext
Web-specific context information for actions.

Uses of StrutsStatics in org.apache.struts2.dispatcher

Classes in org.apache.struts2.dispatcher that implement StrutsStatics
class | FilterDispatcher Master filter for Struts that handles four distinct responsibilities: Executing actions Cleaning up the ActionContext (see note) Serving static content Kicking off XWork's interceptor chain for the request lifecycle IMPORTANT: this filter must be mapped to all requests.
class | FilterDispatcherCompatWeblogic61 When running Weblogic Server 6.1, this class should be specified in web.xml instead of FilterDispatcher.
class | PlainTextResult A result that send the content out as plain text.
class | ServletActionRedirectResult This result uses the ActionMapper provided by the ActionMapperFactory to redirect the browser to a URL that invokes the specified action and (optional) namespace.
class | ServletDispatcherResult Includes or forwards to a view (usually a jsp).
class | ServletRedirectResult Calls the sendRedirect method to the location specified.
class | StreamResult A custom Result type for send raw data (via an InputStream) directly to the HttpServletResponse.
class | StrutsResultSupport A base class for all Struts action execution results.
class | VelocityResult Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

Uses of StrutsStatics in org.apache.struts2.interceptor

Classes in org.apache.struts2.interceptor that implement StrutsStatics
 class ServletConfigInterceptor
An interceptor which sets action properties based on the interfaces an action implements.

Uses of StrutsStatics in org.apache.struts2.portlet.context

Classes in org.apache.struts2.portlet.context that implement StrutsStatics
 class PreparatorServlet
Since a portlet is not dispatched the same way as a servlet, the ServletActionContext is not immediately available, as it depends on objects from the servlet API.

Uses of StrutsStatics in org.apache.struts2.portlet.dispatcher

Classes in org.apache.struts2.portlet.dispatcher that implement StrutsStatics
 class Jsr168Dispatcher

Uses of StrutsStatics in org.apache.struts2.portlet.interceptor

Classes in org.apache.struts2.portlet.interceptor that implement StrutsStatics
 class PortletPreferencesInterceptor
An interceptor which provides an implementation of PortletPreferences if the Action implements PortletPreferencesAware.

Uses of StrutsStatics in org.apache.struts2.portlet.result

Classes in org.apache.struts2.portlet.result that implement StrutsStatics
class | PortletResult Result type that includes a JSP to render.
class | PortletVelocityResult Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

Uses of StrutsStatics in org.apache.struts2.views.freemarker

Classes in org.apache.struts2.views.freemarker that implement StrutsStatics
class | FreemarkerResult Renders a view using the Freemarker template engine.
class | PortletFreemarkerResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.StrutsTestCase (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.StrutsTestCase

No usage of org.apache.struts2.StrutsTestCase

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.TestNGStrutsTestCase (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.TestNGStrutsTestCase

No usage of org.apache.struts2.TestNGStrutsTestCase

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.components (Struts 2 Core 2.0.6 API)

 org.apache.struts2.components
Interfaces
Param.UnnamedParametric
RemoteUICallBean
URL.ExtraParameterProvider
Classes
AbstractRemoteCallUIBean
ActionComponent
ActionError
ActionMessage
Anchor
AppendIterator
Autocompleter
Bean
Checkbox
CheckboxList
ClosingUIBean
ComboBox
Component
Date
DateTimePicker
Debug
Div
DoubleListUIBean
DoubleSelect
Else
ElseIf
FieldError
File
Form
FormButton
GenericUIBean
Head
Hidden
I18n
If
Include
Include.PageOutputStream
Include.PageResponse
InputTransferSelect
IteratorComponent
Label
ListUIBean
MergeIterator
OptGroup
OptionTransferSelect
Param
Password
Property
Push
Radio
Reset
Select
Set
Submit
TabbedPanel
Text
TextArea
TextField
Token
Tree
TreeNode
UIBean
UpDownSelect
URL


Uses of Class org.apache.struts2.components.AbstractRemoteCallUIBean (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.AbstractRemoteCallUIBean

Packages that use AbstractRemoteCallUIBean
org.apache.struts2.components

Uses of AbstractRemoteCallUIBean in org.apache.struts2.components

Subclasses of AbstractRemoteCallUIBean in org.apache.struts2.components
class | Anchor A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework. THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED href errorText listenTopics notifyTopics executeScripts loadingText listenTopics handler formId formFilter targets showErrorTransportText targets indicator 'resultDivId' Deprecated.
class | Div The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.ActionComponent (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.ActionComponent

No usage of org.apache.struts2.components.ActionComponent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.ActionError (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.ActionError

No usage of org.apache.struts2.components.ActionError

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.ActionMessage (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.ActionMessage

No usage of org.apache.struts2.components.ActionMessage

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Anchor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Anchor

No usage of org.apache.struts2.components.Anchor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.AppendIterator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.AppendIterator

No usage of org.apache.struts2.components.AppendIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Autocompleter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Autocompleter

No usage of org.apache.struts2.components.Autocompleter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Bean (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Bean

No usage of org.apache.struts2.components.Bean

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Checkbox (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Checkbox

No usage of org.apache.struts2.components.Checkbox

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.CheckboxList (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.CheckboxList

No usage of org.apache.struts2.components.CheckboxList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.ClosingUIBean (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.ClosingUIBean

Packages that use ClosingUIBean
org.apache.struts2.components

Uses of ClosingUIBean in org.apache.struts2.components

Subclasses of ClosingUIBean in org.apache.struts2.components
class | AbstractRemoteCallUIBean TODO: Document AbstractRemoteCallUIBean.
class | Anchor A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework. THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED href errorText listenTopics notifyTopics executeScripts loadingText listenTopics handler formId formFilter targets showErrorTransportText targets indicator 'resultDivId' Deprecated.
class | Div The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.
class | Form Renders HTML an input form. The remote form allows the form to be submitted without the page being refreshed.
class | TabbedPanel The tabbedpanel widget is primarily an AJAX component, where each tab can either be local content or remote content (refreshed each time the user selects that tab).
class | Tree Renders a tree widget with AJAX support. The id attribute is normally specified, such that it could be looked up using javascript if necessary. Examples
class | TreeNode Renders a tree node within a tree widget with AJAX support. Either of the following combinations should be used depending on if the tree is to be constrcted dynamically or statically.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.ComboBox (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.ComboBox

Packages that use ComboBox
org.apache.struts2.components

Uses of ComboBox in org.apache.struts2.components

Subclasses of ComboBox in org.apache.struts2.components
 class Autocompleter
The autocomplete tag is a combobox that can autocomplete text entered on the input box.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Component (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Component

Packages that use Component
org.apache.struts2.components |
org.apache.struts2.components.table |
org.apache.struts2.views.freemarker.tags |
org.apache.struts2.views.jsp | Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.
org.apache.struts2.views.velocity.components |

Uses of Component in org.apache.struts2.components

Subclasses of Component in org.apache.struts2.components
class | AbstractRemoteCallUIBean TODO: Document AbstractRemoteCallUIBean.
class | ActionComponent
class | ActionError Render action errors if they exists the specific layout of the rendering depends on the theme itself.
class | ActionMessage Render action messages if they exists, specific rendering layout depends on the theme itself.
class | Anchor A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework. THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED href errorText listenTopics notifyTopics executeScripts loadingText listenTopics handler formId formFilter targets showErrorTransportText targets indicator 'resultDivId' Deprecated.
class | AppendIterator
class | Autocompleter The autocomplete tag is a combobox that can autocomplete text entered on the input box.
class | Bean
class | Checkbox Renders an HTML input element of type checkbox, populated by the specified property from the ValueStack.
class | CheckboxList Creates a series of checkboxes from a list.
class | ClosingUIBean ClosingUIBean is the standard superclass for UI components such as div etc.
class | ComboBox The combo box is basically an HTML INPUT of type text and HTML SELECT grouped together to give you a combo box functionality.
class | Date Format Date object in different ways.
class | DateTimePicker
class | Debug
class | Div The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.
class | DoubleListUIBean DoubleListUIBean is the standard superclass of all Struts double list handling components.
class | DoubleSelect Renders two HTML select elements with second one changing displayed values depending on selected entry of first one.
class | Else
class | ElseIf
class | FieldError Render field errors if they exists.
class | File Renders an HTML file input element.
class | Form Renders HTML an input form. The remote form allows the form to be submitted without the page being refreshed.
class | FormButton FormButton.
class | GenericUIBean Renders an custom UI widget using the specified templates.
class | Head Renders parts of the HEAD section for an HTML file.
class | Hidden Renders an HTML input element of type hidden, populated by the specified property from the ValueStack.
class | I18n Gets a resource bundle and place it on the value stack.
class | If
class | Include
class | InputTransferSelect Create a input transfer select component which is basically an text input and <select ...> tag with buttons in the middle of them allowing text to be added to the transfer select.
class | IteratorComponent
class | Label Renders an HTML LABEL that will allow you to output label:name combination that has the same format treatment as the rest of your UI controls.
class | ListUIBean DoubleListUIBean is the standard superclass of all Struts list handling components.
class | MergeIterator
class | OptGroup Create a optgroup component which needs to resides within a select tag.
class | OptionTransferSelect Create a option transfer select component which is basically two <select ...> tag with buttons in the middle of them allowing options in each of the <select ...> to be moved between themselves.
class | Param
class | Password Render an HTML input tag of type password.
class | Property Used to get the property of a value, which will default to the top of the stack if none is specified.
class | Push
class | Radio Render a radio button input field.
class | Reset Render a reset button.
class | Select Render an HTML input tag of type select.
class | Set
class | Submit Render a submit button.
class | TabbedPanel The tabbedpanel widget is primarily an AJAX component, where each tab can either be local content or remote content (refreshed each time the user selects that tab).
class | Text Render a I18n text message.
class | TextArea Render HTML textarea tag.
class | TextField Render an HTML input field of type text
class | Token Stop double-submission of forms.
class | Tree Renders a tree widget with AJAX support. The id attribute is normally specified, such that it could be looked up using javascript if necessary. Examples
class | TreeNode Renders a tree node within a tree widget with AJAX support. Either of the following combinations should be used depending on if the tree is to be constrcted dynamically or statically.
class | UIBean UIBean is the standard superclass of all Struts UI componentns.
class | UpDownSelect Create a Select component with buttons to move the elements in the select component up and down.
class | URL

Methods in org.apache.struts2.components that return Component
protected  Component Component.findAncestor(Class clazz)
Finds the nearest ancestor of this component stack.

Uses of Component in org.apache.struts2.components.table

Subclasses of Component in org.apache.struts2.components.table
 class WebTable

Uses of Component in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as Component
private  Component CallbackWriter.bean

Methods in org.apache.struts2.views.freemarker.tags that return Component
protected Component | WebTableModel.getBean()
protected Component | URLModel.getBean()
protected Component | UpDownSelectModel.getBean()
protected Component | TreeNodeModel.getBean()
protected Component | TreeModel.getBean()
protected Component | TokenModel.getBean()
protected Component | TextModel.getBean()
protected Component | TextFieldModel.getBean()
protected Component | TextAreaModel.getBean()
protected abstract Component | TagModel.getBean()
protected Component | TabbedPanelModel.getBean()
protected Component | SubmitModel.getBean()
protected Component | SetModel.getBean()
protected Component | SelectModel.getBean()
protected Component | ResetModel.getBean()
protected Component | RadioModel.getBean()
protected Component | PushModel.getBean()
protected Component | PropertyModel.getBean()
protected Component | PasswordModel.getBean()
protected Component | ParamModel.getBean()
protected Component | OptionTransferSelectModel.getBean()
protected Component | OptGroupModel.getBean()
protected Component | LabelModel.getBean()
protected Component | IteratorModel.getBean()
protected Component | InputTransferSelectModel.getBean()
protected Component | IncludeModel.getBean()
protected Component | IfModel.getBean()
protected Component | I18nModel.getBean()
protected Component | HiddenModel.getBean()
protected Component | HeadModel.getBean()
protected Component | FormModel.getBean()
protected Component | FileModel.getBean()
protected Component | FieldErrorModel.getBean()
protected Component | ElseModel.getBean()
protected Component | ElseIfModel.getBean()
protected Component | DoubleSelectModel.getBean()
protected Component | DivModel.getBean()
protected Component | DateTimePickerModel.getBean()
protected Component | DateModel.getBean()
protected Component | ComponentModel.getBean()
protected Component | ComboBoxModel.getBean()
protected Component | CheckboxModel.getBean()
protected Component | CheckboxListModel.getBean()
Component | CallbackWriter.getBean()
protected Component | BeanModel.getBean()
protected Component | AutocompleterModel.getBean()
protected Component | AnchorModel.getBean()
protected Component | ActionModel.getBean()
protected Component | ActionMessageModel.getBean()
protected Component | ActionErrorModel.getBean()

Constructors in org.apache.struts2.views.freemarker.tags with parameters of type Component
CallbackWriter(Component bean, Writer writer)

Uses of Component in org.apache.struts2.views.jsp

Fields in org.apache.struts2.views.jsp declared as Component
protected  Component ComponentTagSupport.component

Methods in org.apache.struts2.views.jsp that return Component
Component | URLTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TextTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | SetTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | PushTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | PropertyTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ParamTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | IteratorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | IncludeTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | IfTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | I18nTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ElseTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ElseIfTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DateTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
abstract Component | ComponentTagSupport.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | BeanTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ActionTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ComponentTagSupport.getComponent()

Uses of Component in org.apache.struts2.views.jsp.iterator

Methods in org.apache.struts2.views.jsp.iterator that return Component
Component | MergeIteratorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | AppendIteratorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of Component in org.apache.struts2.views.jsp.ui

Methods in org.apache.struts2.views.jsp.ui that return Component
Component | UpDownSelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TreeTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TreeNodeTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TokenTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TextFieldTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TextareaTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | TabbedPanelTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | SubmitTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | SelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ResetTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | RadioTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | PasswordTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | OptionTransferSelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | OptGroupTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | LabelTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | InputTransferSelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | HiddenTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | HeadTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | FormTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | FileTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | FieldErrorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DoubleSelectTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DivTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DebugTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | DateTimePickerTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ComponentTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ComboBoxTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | CheckboxTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | CheckboxListTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | AutocompleterTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | AnchorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ActionMessageTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
Component | ActionErrorTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of Component in org.apache.struts2.views.jsp.ui.table

Methods in org.apache.struts2.views.jsp.ui.table that return Component
 Component WebTableTag.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Uses of Component in org.apache.struts2.views.velocity.components

Methods in org.apache.struts2.views.velocity.components that return Component
protected Component | WebTableDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | URLDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | UpDownSelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TreeNodeDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TreeDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TokenDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TextFieldDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TextDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TextAreaDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | TabbedPanelDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | SubmitDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | SetDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | SelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ResetDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | RadioDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | PushDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | PropertyDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | PasswordDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ParamDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | OptionTransferSelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | OptGroupDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | LabelDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | InputTransferSelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | IncludeDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | I18nDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | HiddenDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | HeadDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | FormDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | FileDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | FieldErrorDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | DoubleSelectDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | DivDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | DateTimePickerDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | DateDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ComponentDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ComboBoxDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | CheckBoxListDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | CheckBoxDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | BeanDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | AutocompleterDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | AnchorDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ActionMessageDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ActionErrorDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected Component | ActionDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)
protected abstract Component | AbstractDirective.getBean(ValueStack stack, HttpServletRequest req, HttpServletResponse res)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Date (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Date

No usage of org.apache.struts2.components.Date

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.DateTimePicker (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.DateTimePicker

No usage of org.apache.struts2.components.DateTimePicker

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Debug (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Debug

No usage of org.apache.struts2.components.Debug

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Debug.DebugMapEntry (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Debug.DebugMapEntry

No usage of org.apache.struts2.components.Debug.DebugMapEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Div (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Div

No usage of org.apache.struts2.components.Div

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.DoubleListUIBean (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.DoubleListUIBean

Packages that use DoubleListUIBean
org.apache.struts2.components

Uses of DoubleListUIBean in org.apache.struts2.components

Subclasses of DoubleListUIBean in org.apache.struts2.components
class | DoubleSelect Renders two HTML select elements with second one changing displayed values depending on selected entry of first one.
class | OptionTransferSelect Create a option transfer select component which is basically two <select ...> tag with buttons in the middle of them allowing options in each of the <select ...> to be moved between themselves.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.DoubleSelect (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.DoubleSelect

No usage of org.apache.struts2.components.DoubleSelect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Else (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Else

No usage of org.apache.struts2.components.Else

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.ElseIf (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.ElseIf

No usage of org.apache.struts2.components.ElseIf

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.FieldError (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.FieldError

No usage of org.apache.struts2.components.FieldError

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.File (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.File

No usage of org.apache.struts2.components.File

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Form (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Form

Packages that use Form
org.apache.struts2.components

Uses of Form in org.apache.struts2.components

Methods in org.apache.struts2.components with parameters of type Form
protected void | UIBean.populateComponentHtmlId(Form form) Create HTML id element for the component and populate this component parmaeter map.
protected void | FormButton.populateComponentHtmlId(Form form) Override UIBean's implementation, such that component Html id is determined in the following order :- This component id attribute [containing_form_id]_[this_component_name] [containing_form_id]_[this_component_action]_[this_component_method] [containing_form_id]_[this_component_method] [this_component_name] [this_component_action]_[this_component_method] [this_component_method] [an increasing sequential number unique to the form starting with 0]
protected void | Form.populateComponentHtmlId(Form form) Form component determine the its HTML element id as follows:- if an 'id' attribute is specified. if an 'action' attribute is specified, it will be used as the id.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.FormButton (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.FormButton

Packages that use FormButton
org.apache.struts2.components

Uses of FormButton in org.apache.struts2.components

Subclasses of FormButton in org.apache.struts2.components
class | Reset Render a reset button.
class | Submit Render a submit button.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.GenericUIBean (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.GenericUIBean

Packages that use GenericUIBean
org.apache.struts2.components.table

Uses of GenericUIBean in org.apache.struts2.components.table

Subclasses of GenericUIBean in org.apache.struts2.components.table
 class WebTable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Head (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Head

No usage of org.apache.struts2.components.Head

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Hidden (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Hidden

No usage of org.apache.struts2.components.Hidden

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.I18n (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.I18n

No usage of org.apache.struts2.components.I18n

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.If (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.If

No usage of org.apache.struts2.components.If

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Include (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Include

No usage of org.apache.struts2.components.Include

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Include.PageOutputStream (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Include.PageOutputStream

Packages that use Include.PageOutputStream
org.apache.struts2.components

Uses of Include.PageOutputStream in org.apache.struts2.components

Fields in org.apache.struts2.components declared as Include.PageOutputStream
private  Include.PageOutputStream Include.PageResponse.pageOutputStream

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Include.PageResponse (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Include.PageResponse

No usage of org.apache.struts2.components.Include.PageResponse

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.InputTransferSelect (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.InputTransferSelect

No usage of org.apache.struts2.components.InputTransferSelect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.IteratorComponent (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.IteratorComponent

No usage of org.apache.struts2.components.IteratorComponent

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Label (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Label

No usage of org.apache.struts2.components.Label

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.ListUIBean (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.ListUIBean

Packages that use ListUIBean
org.apache.struts2.components

Uses of ListUIBean in org.apache.struts2.components

Subclasses of ListUIBean in org.apache.struts2.components
class | CheckboxList Creates a series of checkboxes from a list.
class | DoubleListUIBean DoubleListUIBean is the standard superclass of all Struts double list handling components.
class | DoubleSelect Renders two HTML select elements with second one changing displayed values depending on selected entry of first one.
class | InputTransferSelect Create a input transfer select component which is basically an text input and <select ...> tag with buttons in the middle of them allowing text to be added to the transfer select.
class | OptionTransferSelect Create a option transfer select component which is basically two <select ...> tag with buttons in the middle of them allowing options in each of the <select ...> to be moved between themselves.
class | Radio Render a radio button input field.
class | Select Render an HTML input tag of type select.
class | UpDownSelect Create a Select component with buttons to move the elements in the select component up and down.

Fields in org.apache.struts2.components declared as ListUIBean
protected  ListUIBean OptGroup.internalUiBean

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.MergeIterator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.MergeIterator

No usage of org.apache.struts2.components.MergeIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.OptGroup (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.OptGroup

No usage of org.apache.struts2.components.OptGroup

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.OptionTransferSelect (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.OptionTransferSelect

No usage of org.apache.struts2.components.OptionTransferSelect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Param (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Param

No usage of org.apache.struts2.components.Param

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.components.Param.UnnamedParametric (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.components.Param.UnnamedParametric

Packages that use Param.UnnamedParametric
org.apache.struts2.components

Uses of Param.UnnamedParametric in org.apache.struts2.components

Classes in org.apache.struts2.components that implement Param.UnnamedParametric
class | AppendIterator
class | FieldError Render field errors if they exists.
class | MergeIterator
class | Text Render a I18n text message.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Password (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Password

No usage of org.apache.struts2.components.Password

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Property (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Property

No usage of org.apache.struts2.components.Property

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Push (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Push

No usage of org.apache.struts2.components.Push

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Radio (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Radio

No usage of org.apache.struts2.components.Radio

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.components.RemoteUICallBean (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.components.RemoteUICallBean

Packages that use RemoteUICallBean
org.apache.struts2.components

Uses of RemoteUICallBean in org.apache.struts2.components

Classes in org.apache.struts2.components that implement RemoteUICallBean
class | AbstractRemoteCallUIBean TODO: Document AbstractRemoteCallUIBean.
class | Anchor A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework. THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED href errorText listenTopics notifyTopics executeScripts loadingText listenTopics handler formId formFilter targets showErrorTransportText targets indicator 'resultDivId' Deprecated.
class | Div The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.
class | Submit Render a submit button.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Reset (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Reset

No usage of org.apache.struts2.components.Reset

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Select (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Select

Packages that use Select
org.apache.struts2.components

Uses of Select in org.apache.struts2.components

Subclasses of Select in org.apache.struts2.components
 class UpDownSelect
Create a Select component with buttons to move the elements in the select component up and down.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Set (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Set

No usage of org.apache.struts2.components.Set

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Submit (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Submit

No usage of org.apache.struts2.components.Submit

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.TabbedPanel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.TabbedPanel

No usage of org.apache.struts2.components.TabbedPanel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Text (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Text

No usage of org.apache.struts2.components.Text

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.TextArea (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.TextArea

No usage of org.apache.struts2.components.TextArea

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.TextField (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.TextField

Packages that use TextField
org.apache.struts2.components

Uses of TextField in org.apache.struts2.components

Subclasses of TextField in org.apache.struts2.components
class | Autocompleter The autocomplete tag is a combobox that can autocomplete text entered on the input box.
class | ComboBox The combo box is basically an HTML INPUT of type text and HTML SELECT grouped together to give you a combo box functionality.
class | Password Render an HTML input tag of type password.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Token (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Token

No usage of org.apache.struts2.components.Token

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.Tree (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.Tree

No usage of org.apache.struts2.components.Tree

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.TreeNode (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.TreeNode

No usage of org.apache.struts2.components.TreeNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.UIBean (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.UIBean

Packages that use UIBean
org.apache.struts2.components
org.apache.struts2.components.table
org.apache.struts2.components.template

Uses of UIBean in org.apache.struts2.components

Subclasses of UIBean in org.apache.struts2.components
class | AbstractRemoteCallUIBean TODO: Document AbstractRemoteCallUIBean.
class | ActionError Render action errors if they exists the specific layout of the rendering depends on the theme itself.
class | ActionMessage Render action messages if they exists, specific rendering layout depends on the theme itself.
class | Anchor A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework. THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED href errorText listenTopics notifyTopics executeScripts loadingText listenTopics handler formId formFilter targets showErrorTransportText targets indicator 'resultDivId' Deprecated.
class | Autocompleter The autocomplete tag is a combobox that can autocomplete text entered on the input box.
class | Checkbox Renders an HTML input element of type checkbox, populated by the specified property from the ValueStack.
class | CheckboxList Creates a series of checkboxes from a list.
class | ClosingUIBean ClosingUIBean is the standard superclass for UI components such as div etc.
class | ComboBox The combo box is basically an HTML INPUT of type text and HTML SELECT grouped together to give you a combo box functionality.
class | DateTimePicker
class | Debug
class | Div The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.
class | DoubleListUIBean DoubleListUIBean is the standard superclass of all Struts double list handling components.
class | DoubleSelect Renders two HTML select elements with second one changing displayed values depending on selected entry of first one.
class | FieldError Render field errors if they exists.
class | File Renders an HTML file input element.
class | Form Renders HTML an input form. The remote form allows the form to be submitted without the page being refreshed.
class | FormButton FormButton.
class | GenericUIBean Renders an custom UI widget using the specified templates.
class | Head Renders parts of the HEAD section for an HTML file.
class | Hidden Renders an HTML input element of type hidden, populated by the specified property from the ValueStack.
class | InputTransferSelect Create a input transfer select component which is basically an text input and <select ...> tag with buttons in the middle of them allowing text to be added to the transfer select.
class | Label Renders an HTML LABEL that will allow you to output label:name combination that has the same format treatment as the rest of your UI controls.
class | ListUIBean DoubleListUIBean is the standard superclass of all Struts list handling components.
class | OptionTransferSelect Create a option transfer select component which is basically two <select ...> tag with buttons in the middle of them allowing options in each of the <select ...> to be moved between themselves.
class | Password Render an HTML input tag of type password.
class | Radio Render a radio button input field.
class | Reset Render a reset button.
class | Select Render an HTML input tag of type select.
class | Submit Render a submit button.
class | TabbedPanel The tabbedpanel widget is primarily an AJAX component, where each tab can either be local content or remote content (refreshed each time the user selects that tab).
class | TextArea Render HTML textarea tag.
class | TextField Render an HTML input field of type text
class | Token Stop double-submission of forms.
class | Tree Renders a tree widget with AJAX support. The id attribute is normally specified, such that it could be looked up using javascript if necessary. Examples
class | TreeNode Renders a tree node within a tree widget with AJAX support. Either of the following combinations should be used depending on if the tree is to be constrcted dynamically or statically.
class | UpDownSelect Create a Select component with buttons to move the elements in the select component up and down.

Methods in org.apache.struts2.components with parameters of type UIBean
protected  Map UIBean.getTooltipConfig(UIBean component)

Uses of UIBean in org.apache.struts2.components.table

Subclasses of UIBean in org.apache.struts2.components.table
 class WebTable

Uses of UIBean in org.apache.struts2.components.template

Fields in org.apache.struts2.components.template declared as UIBean
(package private)  UIBean TemplateRenderingContext.tag

Methods in org.apache.struts2.components.template that return UIBean
 UIBean TemplateRenderingContext.getTag()

Constructors in org.apache.struts2.components.template with parameters of type UIBean
TemplateRenderingContext(Template template, Writer writer, ValueStack stack, Map params, UIBean tag)
Constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.UpDownSelect (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.UpDownSelect

No usage of org.apache.struts2.components.UpDownSelect

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.URL (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.URL

No usage of org.apache.struts2.components.URL

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.components.URL.ExtraParameterProvider (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.components.URL.ExtraParameterProvider

Packages that use URL.ExtraParameterProvider
org.apache.struts2.components

Uses of URL.ExtraParameterProvider in org.apache.struts2.components

Fields in org.apache.struts2.components declared as URL.ExtraParameterProvider
protected  URL.ExtraParameterProvider URL.extraParameterProvider

Methods in org.apache.struts2.components with parameters of type URL.ExtraParameterProvider
 void URL.setExtraParameterProvider(URL.ExtraParameterProvider provider)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.components.table (Struts 2 Core 2.0.6 API)

 org.apache.struts2.components.table
Interfaces
SortableTableModel
Classes
AbstractFilterModel
RenderFilterModel
SortFilterModel
WebTable
WebTableColumn


Uses of Class org.apache.struts2.components.table.AbstractFilterModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.AbstractFilterModel

Packages that use AbstractFilterModel
org.apache.struts2.components.table

Uses of AbstractFilterModel in org.apache.struts2.components.table

Subclasses of AbstractFilterModel in org.apache.struts2.components.table
class | RenderFilterModel
class | SortFilterModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.RenderFilterModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.RenderFilterModel

No usage of org.apache.struts2.components.table.RenderFilterModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.components.table.SortableTableModel (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.components.table.SortableTableModel

Packages that use SortableTableModel
org.apache.struts2.components.table

Uses of SortableTableModel in org.apache.struts2.components.table

Classes in org.apache.struts2.components.table that implement SortableTableModel
 class SortFilterModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.SortFilterModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.SortFilterModel

No usage of org.apache.struts2.components.table.SortFilterModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.SortFilterModel.Row (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.SortFilterModel.Row

No usage of org.apache.struts2.components.table.SortFilterModel.Row

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.WebTable (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.WebTable

Packages that use WebTable
org.apache.struts2.components.table |
org.apache.struts2.components.table.renderer | JSP UI tags for rendering table output in HTML.

Uses of WebTable in org.apache.struts2.components.table

Fields in org.apache.struts2.components.table declared as WebTable
protected  WebTable WebTable.WebTableRowIterator._table

Constructors in org.apache.struts2.components.table with parameters of type WebTable
WebTable.WebTableRowIterator(WebTable table)
WebTable.WebTableRowIterator(WebTable table, int mode)

Uses of WebTable in org.apache.struts2.components.table.renderer

Methods in org.apache.struts2.components.table.renderer with parameters of type WebTable
String | NumericCellRenderer.getCellValue(WebTable table, Object data, int row, int col)
String | LinkCellRenderer.getCellValue(WebTable table, Object data, int row, int col) should the link data be encodeed?
String | FixedTextCellRenderer.getCellValue(WebTable table, Object data, int row, int col)
String | DefaultCellRenderer.getCellValue(WebTable table, Object data, int row, int col)
String | DateCellRenderer.getCellValue(WebTable table, Object data, int row, int col)
String | BooleanCellRenderer.getCellValue(WebTable table, Object data, int row, int col)
protected abstract String | AbstractCellRenderer.getCellValue(WebTable table, Object data, int row, int col) this is the method that subclasses need to implement to set their value.
String | CellRenderer.renderCell(WebTable table, Object data, int row, int col)
String | AbstractCellRenderer.renderCell(WebTable table, Object data, int row, int col) implememnts CellRenderer renderCell.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.WebTable.WebTableRowIterator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.WebTable.WebTableRowIterator

No usage of org.apache.struts2.components.table.WebTable.WebTableRowIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.WebTableColumn (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.WebTableColumn

Packages that use WebTableColumn
org.apache.struts2.components.table

Uses of WebTableColumn in org.apache.struts2.components.table

Fields in org.apache.struts2.components.table declared as WebTableColumn
protected  WebTableColumn[] WebTable.columns

Methods in org.apache.struts2.components.table that return WebTableColumn
WebTableColumn | WebTable.getColumn(int index)
WebTableColumn[] | WebTable.getColumns()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.components.table.renderer (Struts 2 Core 2.0.6 API)

 org.apache.struts2.components.table.renderer
Interfaces
CellRenderer
Classes
AbstractCellRenderer
BooleanCellRenderer
DateCellRenderer
DefaultCellRenderer
FixedTextCellRenderer
LinkCellRenderer
NumericCellRenderer


Uses of Class org.apache.struts2.components.table.renderer.AbstractCellRenderer (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.renderer.AbstractCellRenderer

Packages that use AbstractCellRenderer
org.apache.struts2.components.table.renderer JSP UI tags for rendering table output in HTML.

Uses of AbstractCellRenderer in org.apache.struts2.components.table.renderer

Subclasses of AbstractCellRenderer in org.apache.struts2.components.table.renderer
class | BooleanCellRenderer
class | DateCellRenderer
class | DefaultCellRenderer
class | FixedTextCellRenderer usefull if a column has an embeded ID number needed for a link but you want it to say something else.
class | LinkCellRenderer
class | NumericCellRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.renderer.BooleanCellRenderer (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.renderer.BooleanCellRenderer

No usage of org.apache.struts2.components.table.renderer.BooleanCellRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.components.table.renderer.CellRenderer (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.components.table.renderer.CellRenderer

Packages that use CellRenderer
org.apache.struts2.components.table |
org.apache.struts2.components.table.renderer | JSP UI tags for rendering table output in HTML.

Uses of CellRenderer in org.apache.struts2.components.table

Fields in org.apache.struts2.components.table declared as CellRenderer
(package private) CellRenderer | WebTableColumn._renderer
private static CellRenderer | WebTableColumn.DEFAULT_RENDERER

Methods in org.apache.struts2.components.table that return CellRenderer
CellRenderer | WebTable.getColumnRenderer(int column)
CellRenderer | WebTableColumn.getRenderer()

Methods in org.apache.struts2.components.table with parameters of type CellRenderer
void | WebTable.setColumnRenderer(int column, CellRenderer renderer)
void | WebTableColumn.setRenderer(CellRenderer renderer)

Uses of CellRenderer in org.apache.struts2.components.table.renderer

Classes in org.apache.struts2.components.table.renderer that implement CellRenderer
class | AbstractCellRenderer this is the base class that most renderers will be derived from.
class | BooleanCellRenderer
class | DateCellRenderer
class | DefaultCellRenderer
class | FixedTextCellRenderer usefull if a column has an embeded ID number needed for a link but you want it to say something else.
class | LinkCellRenderer
class | NumericCellRenderer

Fields in org.apache.struts2.components.table.renderer declared as CellRenderer
protected  CellRenderer LinkCellRenderer._delegateRenderer
this is the actual renderer tha will be used to display the text

Methods in org.apache.struts2.components.table.renderer with parameters of type CellRenderer
 void LinkCellRenderer.setRenderer(CellRenderer delegateRenderer)
used to set the renderer to delgate to.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.renderer.DateCellRenderer (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.renderer.DateCellRenderer

No usage of org.apache.struts2.components.table.renderer.DateCellRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.renderer.DefaultCellRenderer (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.renderer.DefaultCellRenderer

No usage of org.apache.struts2.components.table.renderer.DefaultCellRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.renderer.FixedTextCellRenderer (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.renderer.FixedTextCellRenderer

No usage of org.apache.struts2.components.table.renderer.FixedTextCellRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.renderer.LinkCellRenderer (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.renderer.LinkCellRenderer

No usage of org.apache.struts2.components.table.renderer.LinkCellRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.table.renderer.NumericCellRenderer (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.table.renderer.NumericCellRenderer

No usage of org.apache.struts2.components.table.renderer.NumericCellRenderer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.components.template (Struts 2 Core 2.0.6 API)

 org.apache.struts2.components.template
Interfaces
TemplateEngine
TemplateEngineManager.EngineFactory
Classes
BaseTemplateEngine
FreemarkerTemplateEngine
JspTemplateEngine
Template
TemplateEngineManager
TemplateRenderingContext
VelocityTemplateEngine


Uses of Class org.apache.struts2.components.template.BaseTemplateEngine (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.template.BaseTemplateEngine

Packages that use BaseTemplateEngine
org.apache.struts2.components.template

Uses of BaseTemplateEngine in org.apache.struts2.components.template

Subclasses of BaseTemplateEngine in org.apache.struts2.components.template
class | FreemarkerTemplateEngine Freemarker based template engine.
class | JspTemplateEngine JSP based template engine.
class | VelocityTemplateEngine Velocity based template engine.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.template.FreemarkerTemplateEngine (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.template.FreemarkerTemplateEngine

No usage of org.apache.struts2.components.template.FreemarkerTemplateEngine

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.template.JspTemplateEngine (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.template.JspTemplateEngine

No usage of org.apache.struts2.components.template.JspTemplateEngine

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.template.Template (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.template.Template

Packages that use Template
org.apache.struts2.components
org.apache.struts2.components.template

Uses of Template in org.apache.struts2.components

Methods in org.apache.struts2.components that return Template
protected  Template UIBean.buildTemplateName(String myTemplate, String myDefaultTemplate)

Methods in org.apache.struts2.components with parameters of type Template
protected  void UIBean.mergeTemplate(Writer writer, Template template)

Uses of Template in org.apache.struts2.components.template

Fields in org.apache.struts2.components.template declared as Template
(package private)  Template TemplateRenderingContext.template

Methods in org.apache.struts2.components.template that return Template
 Template TemplateRenderingContext.getTemplate()

Methods in org.apache.struts2.components.template with parameters of type Template
protected String | BaseTemplateEngine.getFinalTemplateName(Template template)
TemplateEngine | TemplateEngineManager.getTemplateEngine(Template template, String templateTypeOverride) Gets the TemplateEngine for the template name.
Map | TemplateEngine.getThemeProps(Template template) Get's the properties for the given template.
Map | BaseTemplateEngine.getThemeProps(Template template)

Constructors in org.apache.struts2.components.template with parameters of type Template
TemplateRenderingContext(Template template, Writer writer, ValueStack stack, Map params, UIBean tag)
Constructor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.components.template.TemplateEngine (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.components.template.TemplateEngine

Packages that use TemplateEngine
org.apache.struts2.components.template

Uses of TemplateEngine in org.apache.struts2.components.template

Classes in org.apache.struts2.components.template that implement TemplateEngine
class | BaseTemplateEngine Base class for template engines.
class | FreemarkerTemplateEngine Freemarker based template engine.
class | JspTemplateEngine JSP based template engine.
class | VelocityTemplateEngine Velocity based template engine.

Methods in org.apache.struts2.components.template that return TemplateEngine
TemplateEngine | TemplateEngineManager.EngineFactory.create()
TemplateEngine | TemplateEngineManager.LazyEngineFactory.create()
TemplateEngine | TemplateEngineManager.getTemplateEngine(Template template, String templateTypeOverride) Gets the TemplateEngine for the template name.

Methods in org.apache.struts2.components.template with parameters of type TemplateEngine
List | Template.getPossibleTemplates(TemplateEngine engine)
void | TemplateEngineManager.registerTemplateEngine(String templateExtension, TemplateEngine templateEngine) Registers the given template engine.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.template.TemplateEngineManager (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.template.TemplateEngineManager

Packages that use TemplateEngineManager
org.apache.struts2.components

Uses of TemplateEngineManager in org.apache.struts2.components

Fields in org.apache.struts2.components declared as TemplateEngineManager
protected  TemplateEngineManager UIBean.templateEngineManager

Methods in org.apache.struts2.components with parameters of type TemplateEngineManager
 void UIBean.setTemplateEngineManager(TemplateEngineManager mgr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.components.template.TemplateEngineManager.EngineFactory (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.components.template.TemplateEngineManager.EngineFactory

Packages that use TemplateEngineManager.EngineFactory
org.apache.struts2.components.template

Uses of TemplateEngineManager.EngineFactory in org.apache.struts2.components.template

Classes in org.apache.struts2.components.template that implement TemplateEngineManager.EngineFactory
(package private)  class TemplateEngineManager.LazyEngineFactory
Allows the template engine to be loaded at request time, so that engines that are missing dependencies aren't accessed if never used.

Fields in org.apache.struts2.components.template with type parameters of type TemplateEngineManager.EngineFactory
(package private)  Map<String,TemplateEngineManager.EngineFactory> TemplateEngineManager.templateEngines

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory

No usage of org.apache.struts2.components.template.TemplateEngineManager.LazyEngineFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.template.TemplateRenderingContext (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.template.TemplateRenderingContext

Packages that use TemplateRenderingContext
org.apache.struts2.components.template

Uses of TemplateRenderingContext in org.apache.struts2.components.template

Methods in org.apache.struts2.components.template with parameters of type TemplateRenderingContext
void | VelocityTemplateEngine.renderTemplate(TemplateRenderingContext templateContext)
void | TemplateEngine.renderTemplate(TemplateRenderingContext templateContext) Renders the template
void | JspTemplateEngine.renderTemplate(TemplateRenderingContext templateContext)
void | FreemarkerTemplateEngine.renderTemplate(TemplateRenderingContext templateContext)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.components.template.VelocityTemplateEngine (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.components.template.VelocityTemplateEngine

No usage of org.apache.struts2.components.template.VelocityTemplateEngine

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ClasspathConfigurationProvider.ResultMap (Struts 2 Core 2.0.6 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.apache.struts2.config
Class ClasspathConfigurationProvider.ResultMap<K,V>

java.lang.Object
    extended by  java.util.AbstractMap<K,V>
        extended by  java.util.HashMap<K,V>
            extended by  org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap<K,V>
All Implemented Interfaces:
Serializable, Cloneable, Map<K,V>
Enclosing class:
ClasspathConfigurationProvider
 class ClasspathConfigurationProvider.ResultMap<K,V>
extends HashMap<K,V>

Creates ResultConfig objects from result annotations, and if a result isn't found, creates it on the fly.

Field Summary
private Class | actionClass
private String | actionName
private PackageConfig | pkgConfig
Constructor Summary
ClasspathConfigurationProvider.ResultMap(Class actionClass, String actionName, PackageConfig pkgConfig)
Method Summary
protected Map<String,String> | createParameterMap(String[] parms)
private ResultConfig | createResultConfig(Object key, Class<? extends Object> resultClass, String location, Map<? extends Object,? extends Object> configParams) Creates a default ResultConfig, using either the resultClass or the default ResultType for configuration package associated this ResultMap class.
protected ResultConfig | createResultConfig(Result result) Extracts result name and value and calls createResultConfig(org.apache.struts2.config.Result).
Methods inherited from class java.util.HashMap
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
Methods inherited from class java.util.AbstractMap
equals, hashCode, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.Map
equals, hashCode

Field Detail

actionClass

private Class actionClass

actionName

private String actionName

pkgConfig

private PackageConfig pkgConfig
Constructor Detail

ClasspathConfigurationProvider.ResultMap

public ClasspathConfigurationProvider.ResultMap(Class actionClass,
                                                String actionName,
                                                PackageConfig pkgConfig)
Method Detail

createResultConfig

protected ResultConfig createResultConfig(Result result)
Extracts result name and value and calls createResultConfig(org.apache.struts2.config.Result).

Parameters:
result - Result annotation reference representing result type to create
Returns:
New or cached ResultConfig object for result

createParameterMap

protected Map<String,String> createParameterMap(String[] parms)

createResultConfig

private ResultConfig createResultConfig(Object key,
                                        Class<? extends Object> resultClass,
                                        String location,
                                        Map<? extends Object,? extends Object> configParams)
Creates a default ResultConfig, using either the resultClass or the default ResultType for configuration package associated this ResultMap class.

Parameters:
key - The result type name
resultClass - The class for the result type
location - Path to the resource represented by this type
Returns:
A ResultConfig for key mapped to location
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.apache.struts2.config (Struts 2 Core 2.0.6 API)

 org.apache.struts2.config
Interfaces
ClasspathConfigurationProvider.PageLocator
Classes
BeanSelectionProvider
ClasspathConfigurationProvider
ClasspathConfigurationProvider.ClasspathPageLocator
DefaultPropertiesProvider
DefaultSettings
DelegatingSettings
LegacyPropertiesConfigurationProvider
MethodConfigurationProvider
NullResult
PropertiesSettings
ServletContextSingleton
Settings
StrutsXmlConfigurationProvider
Annotation Types
Namespace
ParentPackage
Result
Results


Uses of Class org.apache.struts2.config.BeanSelectionProvider (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.BeanSelectionProvider

No usage of org.apache.struts2.config.BeanSelectionProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory

No usage of org.apache.struts2.config.BeanSelectionProvider.ObjectFactoryDelegateFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.ClasspathConfigurationProvider (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.ClasspathConfigurationProvider

No usage of org.apache.struts2.config.ClasspathConfigurationProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.ClasspathConfigurationProvider.ClasspathPageLocator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.ClasspathConfigurationProvider.ClasspathPageLocator

Packages that use ClasspathConfigurationProvider.ClasspathPageLocator
org.apache.struts2.dispatcher Classes for action dispatching in Struts (the Controller part of MVC).

Uses of ClasspathConfigurationProvider.ClasspathPageLocator in org.apache.struts2.dispatcher

Fields in org.apache.struts2.dispatcher declared as ClasspathConfigurationProvider.ClasspathPageLocator
private  ClasspathConfigurationProvider.ClasspathPageLocator Dispatcher.ServletContextPageLocator.classpathPageLocator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.config.ClasspathConfigurationProvider.PageLocator

Packages that use ClasspathConfigurationProvider.PageLocator
org.apache.struts2.config | Classes for Struts configuration and property handling.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).

Uses of ClasspathConfigurationProvider.PageLocator in org.apache.struts2.config

Classes in org.apache.struts2.config that implement ClasspathConfigurationProvider.PageLocator
static class ClasspathConfigurationProvider.ClasspathPageLocator
ClasspathPathLocator searches the classpath for server pages.

Fields in org.apache.struts2.config declared as ClasspathConfigurationProvider.PageLocator
private  ClasspathConfigurationProvider.PageLocator ClasspathConfigurationProvider.pageLocator
Helper class to scan class path for server pages.

Methods in org.apache.struts2.config with parameters of type ClasspathConfigurationProvider.PageLocator
 void ClasspathConfigurationProvider.setPageLocator(ClasspathConfigurationProvider.PageLocator locator)
Register a PageLocation to use to scan for server pages.

Uses of ClasspathConfigurationProvider.PageLocator in org.apache.struts2.dispatcher

Classes in org.apache.struts2.dispatcher that implement ClasspathConfigurationProvider.PageLocator
private  class Dispatcher.ServletContextPageLocator
Search classpath for a page.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap

No usage of org.apache.struts2.config.ClasspathConfigurationProvider.ResultMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.DefaultPropertiesProvider (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.DefaultPropertiesProvider

No usage of org.apache.struts2.config.DefaultPropertiesProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.DefaultSettings (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.DefaultSettings

No usage of org.apache.struts2.config.DefaultSettings

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.DelegatingSettings (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.DelegatingSettings

No usage of org.apache.struts2.config.DelegatingSettings

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.LegacyPropertiesConfigurationProvider (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.LegacyPropertiesConfigurationProvider

Packages that use LegacyPropertiesConfigurationProvider
org.apache.struts2.config Classes for Struts configuration and property handling.

Uses of LegacyPropertiesConfigurationProvider in org.apache.struts2.config

Subclasses of LegacyPropertiesConfigurationProvider in org.apache.struts2.config
 class DefaultPropertiesProvider
Loads the default properties, separate from the usual struts.properties loading

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.MethodConfigurationProvider (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.MethodConfigurationProvider

No usage of org.apache.struts2.config.MethodConfigurationProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.Namespace (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.Namespace

No usage of org.apache.struts2.config.Namespace

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.NullResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.NullResult

No usage of org.apache.struts2.config.NullResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.ParentPackage (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.ParentPackage

No usage of org.apache.struts2.config.ParentPackage

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.PropertiesSettings (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.PropertiesSettings

No usage of org.apache.struts2.config.PropertiesSettings

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.Result (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.Result

Packages that use Result
org.apache.struts2.config Classes for Struts configuration and property handling.

Uses of Result in org.apache.struts2.config

Methods in org.apache.struts2.config with parameters of type Result
protected  ResultConfig ClasspathConfigurationProvider.ResultMap.createResultConfig(Result result)
Extracts result name and value and calls ClasspathConfigurationProvider.ResultMap.createResultConfig(org.apache.struts2.config.Result).

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.Results (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.Results

No usage of org.apache.struts2.config.Results

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.ServletContextSingleton (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.ServletContextSingleton

Packages that use ServletContextSingleton
org.apache.struts2.config Classes for Struts configuration and property handling.

Uses of ServletContextSingleton in org.apache.struts2.config

Fields in org.apache.struts2.config declared as ServletContextSingleton
private static ServletContextSingleton ServletContextSingleton.singleton
The sole instance of this class.

Methods in org.apache.struts2.config that return ServletContextSingleton
static ServletContextSingleton ServletContextSingleton.getInstance()
Answers the singleton.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.Settings (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.Settings

Packages that use Settings
org.apache.struts2.config Classes for Struts configuration and property handling.

Uses of Settings in org.apache.struts2.config

Subclasses of Settings in org.apache.struts2.config
class | DefaultSettings DefaultSettings implements optional methods of Settings.
(package private) class | DelegatingSettings DelegatingSettings stores an internal list of Settings objects to update settings or retrieve settings values.
(package private) class | PropertiesSettings A class to handle settings via a properties file.

Fields in org.apache.struts2.config declared as Settings
(package private) static Settings | Settings.defaultImpl An instance of DefaultSettings to use when another implementation is not provided (plugged in).
(package private) Settings | DefaultSettings.delegate The Settings object that handles API calls.
(package private) Settings[] | DelegatingSettings.delegates The Settings objects.
(package private) static Settings | Settings.settingsImpl A pluggable implementation of Settings, provided through the setInstance(org.apache.struts2.config.Settings) method.

Methods in org.apache.struts2.config that return Settings
private static Settings | Settings.getDefaultInstance() Creates a default Settings object.
static Settings | Settings.getInstance() Provides the Settings object.

Methods in org.apache.struts2.config with parameters of type Settings
protected void | LegacyPropertiesConfigurationProvider.loadSettings(LocatableProperties props, Settings settings)
static void | Settings.setInstance(Settings config) Registers a custom Settings implementation (plugin), and resets the cached locale.

Constructors in org.apache.struts2.config with parameters of type Settings
DelegatingSettings(Settings[] delegates)
Creates a new DelegatingSettings object utilizing the list of Settings objects.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.config.StrutsXmlConfigurationProvider (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.config.StrutsXmlConfigurationProvider

No usage of org.apache.struts2.config.StrutsXmlConfigurationProvider

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.dispatcher (Struts 2 Core 2.0.6 API)

 org.apache.struts2.dispatcher
Interfaces
DispatcherListener
Classes
ActionContextCleanUp
ApplicationMap
DefaultActionSupport
Dispatcher
FilterDispatcher
FilterDispatcherCompatWeblogic61
HttpHeaderResult
PlainTextResult
RequestMap
ServletActionRedirectResult
ServletDispatcherResult
ServletRedirectResult
SessionMap
StreamResult
StrutsRequestWrapper
StrutsResultSupport
VelocityResult


Uses of Class org.apache.struts2.dispatcher.ActionContextCleanUp (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.ActionContextCleanUp

No usage of org.apache.struts2.dispatcher.ActionContextCleanUp

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.ApplicationMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.ApplicationMap

No usage of org.apache.struts2.dispatcher.ApplicationMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.DefaultActionSupport (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.DefaultActionSupport

No usage of org.apache.struts2.dispatcher.DefaultActionSupport

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.Dispatcher (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.Dispatcher

Packages that use Dispatcher
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.util | Miscellaneous helper classes.

Uses of Dispatcher in org.apache.struts2

Methods in org.apache.struts2 that return Dispatcher
protected Dispatcher | TestNGStrutsTestCase.initDispatcher(Map<String,String> params)
protected Dispatcher | StrutsTestCase.initDispatcher(Map<String,String> params)

Uses of Dispatcher in org.apache.struts2.dispatcher

Fields in org.apache.struts2.dispatcher declared as Dispatcher
protected  Dispatcher FilterDispatcher.dispatcher
Expose Dispatcher instance to subclass.

Fields in org.apache.struts2.dispatcher with type parameters of type Dispatcher
private static ThreadLocal<Dispatcher> Dispatcher.instance
Provide a thread local instance.

Methods in org.apache.struts2.dispatcher that return Dispatcher
protected Dispatcher | FilterDispatcher.createDispatcher(FilterConfig filterConfig) Create a default Dispatcher that subclasses can override with a custom Dispatcher, if needed.
static Dispatcher | Dispatcher.getInstance() Provide the dispatcher instance for the current thread.

Methods in org.apache.struts2.dispatcher with parameters of type Dispatcher
void | DispatcherListener.dispatcherDestroyed(Dispatcher du) Called when the dispatcher is destroyed
void | DispatcherListener.dispatcherInitialized(Dispatcher du) Called when the dispatcher is initialized
static void | Dispatcher.setInstance(Dispatcher instance) Store the dispatcher instance for this thread.

Uses of Dispatcher in org.apache.struts2.portlet.dispatcher

Fields in org.apache.struts2.portlet.dispatcher declared as Dispatcher
private  Dispatcher Jsr168Dispatcher.dispatcherUtils

Uses of Dispatcher in org.apache.struts2.util

Methods in org.apache.struts2.util that return Dispatcher
static Dispatcher StrutsTestCaseHelper.initDispatcher(Map<String,String> params)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.Dispatcher.Locator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.Dispatcher.Locator

No usage of org.apache.struts2.dispatcher.Dispatcher.Locator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator

No usage of org.apache.struts2.dispatcher.Dispatcher.ServletContextPageLocator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.dispatcher.DispatcherListener (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.dispatcher.DispatcherListener

Packages that use DispatcherListener
org.apache.struts2.dispatcher Classes for action dispatching in Struts (the Controller part of MVC).

Uses of DispatcherListener in org.apache.struts2.dispatcher

Fields in org.apache.struts2.dispatcher with type parameters of type DispatcherListener
private static List<DispatcherListener> Dispatcher.dispatcherListeners
Store list of DispatcherListeners.

Methods in org.apache.struts2.dispatcher with parameters of type DispatcherListener
static void | Dispatcher.addDispatcherListener(DispatcherListener listener) Add a dispatcher lifecycle listener.
static void | Dispatcher.removeDispatcherListener(DispatcherListener listener) Remove a specific dispatcher lifecycle listener.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.FilterDispatcher (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.FilterDispatcher

Packages that use FilterDispatcher
org.apache.struts2.dispatcher Classes for action dispatching in Struts (the Controller part of MVC).

Uses of FilterDispatcher in org.apache.struts2.dispatcher

Subclasses of FilterDispatcher in org.apache.struts2.dispatcher
 class FilterDispatcherCompatWeblogic61
When running Weblogic Server 6.1, this class should be specified in web.xml instead of FilterDispatcher.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61 (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61

No usage of org.apache.struts2.dispatcher.FilterDispatcherCompatWeblogic61

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.HttpHeaderResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.HttpHeaderResult

No usage of org.apache.struts2.dispatcher.HttpHeaderResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.PlainTextResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.PlainTextResult

No usage of org.apache.struts2.dispatcher.PlainTextResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.RequestMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.RequestMap

No usage of org.apache.struts2.dispatcher.RequestMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.ServletActionRedirectResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.ServletActionRedirectResult

Packages that use ServletActionRedirectResult
org.apache.struts2.dispatcher Classes for action dispatching in Struts (the Controller part of MVC).

Uses of ServletActionRedirectResult in org.apache.struts2.dispatcher

Methods in org.apache.struts2.dispatcher that return ServletActionRedirectResult
 ServletActionRedirectResult ServletActionRedirectResult.addParameter(String key, Object value)
Adds a request parameter to be added to the redirect url

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.ServletDispatcherResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.ServletDispatcherResult

No usage of org.apache.struts2.dispatcher.ServletDispatcherResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.ServletRedirectResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.ServletRedirectResult

Packages that use ServletRedirectResult
org.apache.struts2.dispatcher Classes for action dispatching in Struts (the Controller part of MVC).

Uses of ServletRedirectResult in org.apache.struts2.dispatcher

Subclasses of ServletRedirectResult in org.apache.struts2.dispatcher
 class ServletActionRedirectResult
This result uses the ActionMapper provided by the ActionMapperFactory to redirect the browser to a URL that invokes the specified action and (optional) namespace.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.SessionMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.SessionMap

No usage of org.apache.struts2.dispatcher.SessionMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.StreamResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.StreamResult

No usage of org.apache.struts2.dispatcher.StreamResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.StrutsRequestWrapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.StrutsRequestWrapper

Packages that use StrutsRequestWrapper
org.apache.struts2.dispatcher.multipart Classes to help dispatch multipart HTTP requests.

Uses of StrutsRequestWrapper in org.apache.struts2.dispatcher.multipart

Subclasses of StrutsRequestWrapper in org.apache.struts2.dispatcher.multipart
 class MultiPartRequestWrapper
Parse a multipart request and provide a wrapper around the request.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.StrutsResultSupport (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.StrutsResultSupport

Packages that use StrutsResultSupport
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.portlet.result |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.

Uses of StrutsResultSupport in org.apache.struts2.dispatcher

Subclasses of StrutsResultSupport in org.apache.struts2.dispatcher
class | PlainTextResult A result that send the content out as plain text.
class | ServletActionRedirectResult This result uses the ActionMapper provided by the ActionMapperFactory to redirect the browser to a URL that invokes the specified action and (optional) namespace.
class | ServletDispatcherResult Includes or forwards to a view (usually a jsp).
class | ServletRedirectResult Calls the sendRedirect method to the location specified.
class | StreamResult A custom Result type for send raw data (via an InputStream) directly to the HttpServletResponse.
class | VelocityResult Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

Uses of StrutsResultSupport in org.apache.struts2.portlet.result

Subclasses of StrutsResultSupport in org.apache.struts2.portlet.result
class | PortletResult Result type that includes a JSP to render.
class | PortletVelocityResult Using the Servlet container's JspFactory, this result mocks a JSP execution environment and then displays a Velocity template that will be streamed directly to the servlet output.

Uses of StrutsResultSupport in org.apache.struts2.views.freemarker

Subclasses of StrutsResultSupport in org.apache.struts2.views.freemarker
class | FreemarkerResult Renders a view using the Freemarker template engine.
class | PortletFreemarkerResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.VelocityResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.VelocityResult

No usage of org.apache.struts2.dispatcher.VelocityResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.dispatcher.mapper (Struts 2 Core 2.0.6 API)

 org.apache.struts2.dispatcher.mapper
Interfaces
ActionMapper
DefaultActionMapper.ParameterAction
Classes
ActionMapping
CompositeActionMapper
DefaultActionMapper
Restful2ActionMapper
RestfulActionMapper


Uses of Interface org.apache.struts2.dispatcher.mapper.ActionMapper (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.dispatcher.mapper.ActionMapper

Packages that use ActionMapper
org.apache.struts2.components |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.portlet.dispatcher |
org.apache.struts2.views.jsp | Struts's JSP tag library.

Uses of ActionMapper in org.apache.struts2.components

Fields in org.apache.struts2.components declared as ActionMapper
protected  ActionMapper Component.actionMapper

Methods in org.apache.struts2.components with parameters of type ActionMapper
 void Component.setActionMapper(ActionMapper mapper)

Uses of ActionMapper in org.apache.struts2.dispatcher

Fields in org.apache.struts2.dispatcher declared as ActionMapper
protected ActionMapper | ServletRedirectResult.actionMapper
private static ActionMapper | FilterDispatcher.actionMapper Provide ActionMapper instance, set by injection.

Methods in org.apache.struts2.dispatcher with parameters of type ActionMapper
void | ServletRedirectResult.setActionMapper(ActionMapper mapper)
static void | FilterDispatcher.setActionMapper(ActionMapper mapper) Modify ActionMapper instance.

Uses of ActionMapper in org.apache.struts2.dispatcher.mapper

Classes in org.apache.struts2.dispatcher.mapper that implement ActionMapper
class | CompositeActionMapper A composite action mapper that is capable of delegating to a series of ActionMapper if the former failed to obtained a valid ActionMapping or uri.
class | DefaultActionMapper Default action mapper implementation, using the standard *.[ext] (where ext usually "action") pattern.
class | Restful2ActionMapper Improved restful action mapper that adds several ReST-style improvements to action mapping, but supports fully-customized URL's via XML.
class | RestfulActionMapper A custom action mapper using the following format: http://HOST/ACTION_NAME/PARAM_NAME1/PARAM_VALUE1/PARAM_NAME2/PARAM_VALUE2 You can have as many parameters you'd like to use.

Fields in org.apache.struts2.dispatcher.mapper with type parameters of type ActionMapper
protected  List<ActionMapper> CompositeActionMapper.actionMappers

Uses of ActionMapper in org.apache.struts2.portlet.dispatcher

Fields in org.apache.struts2.portlet.dispatcher declared as ActionMapper
private  ActionMapper Jsr168Dispatcher.actionMapper

Methods in org.apache.struts2.portlet.dispatcher with parameters of type ActionMapper
 void Jsr168Dispatcher.setActionMapper(ActionMapper actionMapper)

Uses of ActionMapper in org.apache.struts2.views.jsp

Methods in org.apache.struts2.views.jsp with parameters of type ActionMapper
static String TagUtils.buildNamespace(ActionMapper mapper, ValueStack stack, HttpServletRequest request)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.mapper.ActionMapping (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.mapper.ActionMapping

Packages that use ActionMapping
org.apache.struts2 | Main Struts interfaces and classes.
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.dispatcher.mapper |
org.apache.struts2.portlet.context |
org.apache.struts2.portlet.dispatcher |

Uses of ActionMapping in org.apache.struts2

Methods in org.apache.struts2 that return ActionMapping
static ActionMapping ServletActionContext.getActionMapping()
Gets the action mapping for this context

Uses of ActionMapping in org.apache.struts2.dispatcher

Methods in org.apache.struts2.dispatcher with parameters of type ActionMapping
Map<String,Object> | Dispatcher.createContextMap(HttpServletRequest request, HttpServletResponse response, ActionMapping mapping, ServletContext context) Create a context map containing all the wrapped request objects
void | Dispatcher.serviceAction(HttpServletRequest request, HttpServletResponse response, ServletContext context, ActionMapping mapping) Load Action class for mapping and invoke the appropriate Action method, or go directly to the Result.

Uses of ActionMapping in org.apache.struts2.dispatcher.mapper

Methods in org.apache.struts2.dispatcher.mapper that return ActionMapping
ActionMapping | RestfulActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager)
ActionMapping | Restful2ActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager)
ActionMapping | DefaultActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager)
ActionMapping | CompositeActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager)
ActionMapping | ActionMapper.getMapping(HttpServletRequest request, ConfigurationManager configManager) Expose the ActionMapping for the current request

Methods in org.apache.struts2.dispatcher.mapper with parameters of type ActionMapping
void | DefaultActionMapper.ParameterAction.execute(String key, ActionMapping mapping)
String | RestfulActionMapper.getUriFromActionMapping(ActionMapping mapping)
String | DefaultActionMapper.getUriFromActionMapping(ActionMapping mapping)
String | CompositeActionMapper.getUriFromActionMapping(ActionMapping mapping)
String | ActionMapper.getUriFromActionMapping(ActionMapping mapping) Convert an ActionMapping into a URI string
void | DefaultActionMapper.handleSpecialParameters(HttpServletRequest request, ActionMapping mapping) Special parameters, as described in the class-level comment, are searched for and handled.
(package private) void | DefaultActionMapper.parseNameAndNamespace(String uri, ActionMapping mapping, ConfigurationManager configManager) Parses the name and namespace from the uri

Uses of ActionMapping in org.apache.struts2.portlet.context

Methods in org.apache.struts2.portlet.context that return ActionMapping
static ActionMapping PortletActionContext.getDefaultActionForMode()
Get the default action mapping for the current mode.

Uses of ActionMapping in org.apache.struts2.portlet.dispatcher

Fields in org.apache.struts2.portlet.dispatcher with type parameters of type ActionMapping
private  Map<javax.portlet.PortletMode,ActionMapping> Jsr168Dispatcher.actionMap

Methods in org.apache.struts2.portlet.dispatcher that return ActionMapping
protected  ActionMapping Jsr168Dispatcher.getActionMapping(javax.portlet.PortletRequest request)
Gets the namespace of the action from the request.

Methods in org.apache.struts2.portlet.dispatcher with parameters of type ActionMapping
 void Jsr168Dispatcher.serviceAction(javax.portlet.PortletRequest request, javax.portlet.PortletResponse response, ActionMapping mapping, Map requestMap, Map parameterMap, Map sessionMap, Map applicationMap, String portletNamespace, Integer phase)
Loads the action and executes it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.mapper.CompositeActionMapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.mapper.CompositeActionMapper

No usage of org.apache.struts2.dispatcher.mapper.CompositeActionMapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.mapper.DefaultActionMapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.mapper.DefaultActionMapper

Packages that use DefaultActionMapper
org.apache.struts2.dispatcher.mapper

Uses of DefaultActionMapper in org.apache.struts2.dispatcher.mapper

Subclasses of DefaultActionMapper in org.apache.struts2.dispatcher.mapper
 class Restful2ActionMapper
Improved restful action mapper that adds several ReST-style improvements to action mapping, but supports fully-customized URL's via XML.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.dispatcher.mapper.DefaultActionMapper.ParameterAction (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.dispatcher.mapper.DefaultActionMapper.ParameterAction

No usage of org.apache.struts2.dispatcher.mapper.DefaultActionMapper.ParameterAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.mapper.Restful2ActionMapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

No usage of org.apache.struts2.dispatcher.mapper.Restful2ActionMapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.mapper.RestfulActionMapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.mapper.RestfulActionMapper

No usage of org.apache.struts2.dispatcher.mapper.RestfulActionMapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.dispatcher.multipart (Struts 2 Core 2.0.6 API)

 org.apache.struts2.dispatcher.multipart
Interfaces
MultiPartRequest
Classes
JakartaMultiPartRequest
MultiPartRequestWrapper


Uses of Class org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

No usage of org.apache.struts2.dispatcher.multipart.JakartaMultiPartRequest

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.dispatcher.multipart.MultiPartRequest (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.dispatcher.multipart.MultiPartRequest

Packages that use MultiPartRequest
org.apache.struts2.dispatcher.multipart Classes to help dispatch multipart HTTP requests.

Uses of MultiPartRequest in org.apache.struts2.dispatcher.multipart

Classes in org.apache.struts2.dispatcher.multipart that implement MultiPartRequest
 class JakartaMultiPartRequest
Multipart form data request adapter for Jakarta Commons Fileupload package.

Fields in org.apache.struts2.dispatcher.multipart declared as MultiPartRequest
(package private)  MultiPartRequest MultiPartRequestWrapper.multi

Constructors in org.apache.struts2.dispatcher.multipart with parameters of type MultiPartRequest
MultiPartRequestWrapper(MultiPartRequest multiPartRequest, HttpServletRequest request, String saveDir)
Process file downloads and log any errors.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

No usage of org.apache.struts2.dispatcher.multipart.MultiPartRequestWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.impl (Struts 2 Core 2.0.6 API)

 org.apache.struts2.impl
Classes
StrutsActionProxy
StrutsActionProxyFactory
StrutsObjectFactory


Uses of Class org.apache.struts2.impl.StrutsActionProxy (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.impl.StrutsActionProxy

No usage of org.apache.struts2.impl.StrutsActionProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.impl.StrutsActionProxyFactory (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.impl.StrutsActionProxyFactory

No usage of org.apache.struts2.impl.StrutsActionProxyFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.impl.StrutsObjectFactory (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.impl.StrutsObjectFactory

No usage of org.apache.struts2.impl.StrutsObjectFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.interceptor (Struts 2 Core 2.0.6 API)

 org.apache.struts2.interceptor
Interfaces
ApplicationAware
NoParameters
ParameterAware
PrincipalAware
PrincipalProxy
RequestAware
ServletRequestAware
ServletResponseAware
SessionAware
Classes
BackgroundProcess
CheckboxInterceptor
CreateSessionInterceptor
ExecuteAndWaitInterceptor
FileUploadInterceptor
MessageStoreInterceptor
ProfilingActivationInterceptor
RolesInterceptor
ScopeInterceptor
ServletConfigInterceptor
StrutsConversionErrorInterceptor
TokenInterceptor
TokenSessionStoreInterceptor


Uses of Interface org.apache.struts2.interceptor.ApplicationAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.ApplicationAware

No usage of org.apache.struts2.interceptor.ApplicationAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.BackgroundProcess (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.BackgroundProcess

Packages that use BackgroundProcess
org.apache.struts2.interceptor Web specific interceptor classes.

Uses of BackgroundProcess in org.apache.struts2.interceptor

Methods in org.apache.struts2.interceptor that return BackgroundProcess
protected  BackgroundProcess ExecuteAndWaitInterceptor.getNewBackgroundProcess(String name, ActionInvocation actionInvocation, int threadPriority)
Creates a new background process

Methods in org.apache.struts2.interceptor with parameters of type BackgroundProcess
protected  void ExecuteAndWaitInterceptor.performInitialDelay(BackgroundProcess bp)
Performs the initial delay.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.CheckboxInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.CheckboxInterceptor

No usage of org.apache.struts2.interceptor.CheckboxInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.CreateSessionInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.CreateSessionInterceptor

No usage of org.apache.struts2.interceptor.CreateSessionInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.ExecuteAndWaitInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

No usage of org.apache.struts2.interceptor.ExecuteAndWaitInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.FileUploadInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.FileUploadInterceptor

No usage of org.apache.struts2.interceptor.FileUploadInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.MessageStoreInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.MessageStoreInterceptor

No usage of org.apache.struts2.interceptor.MessageStoreInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.interceptor.NoParameters (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.NoParameters

No usage of org.apache.struts2.interceptor.NoParameters

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.interceptor.ParameterAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.ParameterAware

No usage of org.apache.struts2.interceptor.ParameterAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.interceptor.PrincipalAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.PrincipalAware

No usage of org.apache.struts2.interceptor.PrincipalAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.interceptor.PrincipalProxy (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.PrincipalProxy

Packages that use PrincipalProxy
org.apache.struts2.interceptor | Web specific interceptor classes.
org.apache.struts2.portlet.interceptor |
org.apache.struts2.servlet.interceptor |

Uses of PrincipalProxy in org.apache.struts2.interceptor

Methods in org.apache.struts2.interceptor with parameters of type PrincipalProxy
 void PrincipalAware.setPrincipalProxy(PrincipalProxy principalProxy)

Uses of PrincipalProxy in org.apache.struts2.portlet.interceptor

Classes in org.apache.struts2.portlet.interceptor that implement PrincipalProxy
 class PortletPrincipalProxy
PrincipalProxy implementation for using PortletRequest Principal related methods.

Uses of PrincipalProxy in org.apache.struts2.servlet.interceptor

Classes in org.apache.struts2.servlet.interceptor that implement PrincipalProxy
 class ServletPrincipalProxy
PrincipalProxy implementation for using HttpServletRequest Principal related methods.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.ProfilingActivationInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.ProfilingActivationInterceptor

No usage of org.apache.struts2.interceptor.ProfilingActivationInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.interceptor.RequestAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.RequestAware

No usage of org.apache.struts2.interceptor.RequestAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.RolesInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.RolesInterceptor

No usage of org.apache.struts2.interceptor.RolesInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.ScopeInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.ScopeInterceptor

No usage of org.apache.struts2.interceptor.ScopeInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.ServletConfigInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.ServletConfigInterceptor

No usage of org.apache.struts2.interceptor.ServletConfigInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.interceptor.ServletRequestAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.ServletRequestAware

No usage of org.apache.struts2.interceptor.ServletRequestAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.interceptor.ServletResponseAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.ServletResponseAware

No usage of org.apache.struts2.interceptor.ServletResponseAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.interceptor.SessionAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.interceptor.SessionAware

No usage of org.apache.struts2.interceptor.SessionAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.StrutsConversionErrorInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.StrutsConversionErrorInterceptor

No usage of org.apache.struts2.interceptor.StrutsConversionErrorInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.TokenInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.TokenInterceptor

Packages that use TokenInterceptor
org.apache.struts2.interceptor Web specific interceptor classes.

Uses of TokenInterceptor in org.apache.struts2.interceptor

Subclasses of TokenInterceptor in org.apache.struts2.interceptor
 class TokenSessionStoreInterceptor
This interceptor builds off of the TokenInterceptor, providing advanced logic for handling invalid tokens.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.TokenSessionStoreInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.TokenSessionStoreInterceptor

No usage of org.apache.struts2.interceptor.TokenSessionStoreInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.interceptor.debugging (Struts 2 Core 2.0.6 API)

 org.apache.struts2.interceptor.debugging
Classes
DebuggingInterceptor
PrettyPrintWriter


Uses of Class org.apache.struts2.interceptor.debugging.DebuggingInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.debugging.DebuggingInterceptor

No usage of org.apache.struts2.interceptor.debugging.DebuggingInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.debugging.PrettyPrintWriter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.debugging.PrettyPrintWriter

Packages that use PrettyPrintWriter
org.apache.struts2.interceptor.debugging

Uses of PrettyPrintWriter in org.apache.struts2.interceptor.debugging

Methods in org.apache.struts2.interceptor.debugging with parameters of type PrettyPrintWriter
protected void | DebuggingInterceptor.printContext(PrettyPrintWriter writer) Prints the current request to the existing writer.
protected void | DebuggingInterceptor.serializeIt(Object bean, String name, PrettyPrintWriter writer, List<Object> stack) Recursive function to serialize objects to XML.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.interceptor.validation (Struts 2 Core 2.0.6 API)

 org.apache.struts2.interceptor.validation
Classes
AnnotationValidationInterceptor
Annotation Types
SkipValidation


Uses of Class org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor

No usage of org.apache.struts2.interceptor.validation.AnnotationValidationInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.interceptor.validation.SkipValidation (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.interceptor.validation.SkipValidation

No usage of org.apache.struts2.interceptor.validation.SkipValidation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.portlet (Struts 2 Core 2.0.6 API)

 org.apache.struts2.portlet
Interfaces
PortletActionConstants
Classes
PortletApplicationMap
PortletRequestMap
PortletSessionMap


Uses of Interface org.apache.struts2.portlet.PortletActionConstants (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.portlet.PortletActionConstants

Packages that use PortletActionConstants
org.apache.struts2.portlet.context
org.apache.struts2.portlet.dispatcher

Uses of PortletActionConstants in org.apache.struts2.portlet.context

Classes in org.apache.struts2.portlet.context that implement PortletActionConstants
 class PortletActionContext
PortletActionContext.

Uses of PortletActionConstants in org.apache.struts2.portlet.dispatcher

Classes in org.apache.struts2.portlet.dispatcher that implement PortletActionConstants
 class Jsr168Dispatcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.PortletApplicationMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.PortletApplicationMap

No usage of org.apache.struts2.portlet.PortletApplicationMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.PortletRequestMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.PortletRequestMap

No usage of org.apache.struts2.portlet.PortletRequestMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.PortletSessionMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.PortletSessionMap

No usage of org.apache.struts2.portlet.PortletSessionMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.portlet.context (Struts 2 Core 2.0.6 API)

 org.apache.struts2.portlet.context
Classes
PortletActionContext
PreparatorServlet
ServletContextHolderListener


Uses of Class org.apache.struts2.portlet.context.PortletActionContext (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.context.PortletActionContext

No usage of org.apache.struts2.portlet.context.PortletActionContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.context.PreparatorServlet (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.context.PreparatorServlet

No usage of org.apache.struts2.portlet.context.PreparatorServlet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.context.ServletContextHolderListener (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.context.ServletContextHolderListener

No usage of org.apache.struts2.portlet.context.ServletContextHolderListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.portlet.dispatcher (Struts 2 Core 2.0.6 API)

 org.apache.struts2.portlet.dispatcher
Classes
DirectRenderFromEventAction
Jsr168Dispatcher


Uses of Class org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction

No usage of org.apache.struts2.portlet.dispatcher.DirectRenderFromEventAction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

No usage of org.apache.struts2.portlet.dispatcher.Jsr168Dispatcher

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.portlet.interceptor (Struts 2 Core 2.0.6 API)

 org.apache.struts2.portlet.interceptor
Interfaces
PortletPreferencesAware
Classes
PortletPreferencesInterceptor
PortletPrincipalProxy
ServletPortletPreferences


Uses of Interface org.apache.struts2.portlet.interceptor.PortletPreferencesAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.portlet.interceptor.PortletPreferencesAware

No usage of org.apache.struts2.portlet.interceptor.PortletPreferencesAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor

No usage of org.apache.struts2.portlet.interceptor.PortletPreferencesInterceptor

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.interceptor.PortletPrincipalProxy (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.interceptor.PortletPrincipalProxy

No usage of org.apache.struts2.portlet.interceptor.PortletPrincipalProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.interceptor.ServletPortletPreferences (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.interceptor.ServletPortletPreferences

No usage of org.apache.struts2.portlet.interceptor.ServletPortletPreferences

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.portlet.result (Struts 2 Core 2.0.6 API)

 org.apache.struts2.portlet.result
Classes
PortletResult
PortletResult.IncludeTemplate
PortletVelocityResult


Uses of Class org.apache.struts2.portlet.result.PortletResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.result.PortletResult

No usage of org.apache.struts2.portlet.result.PortletResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.result.PortletResult.IncludeTemplate (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.result.PortletResult.IncludeTemplate

No usage of org.apache.struts2.portlet.result.PortletResult.IncludeTemplate

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.result.PortletVelocityResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.result.PortletVelocityResult

No usage of org.apache.struts2.portlet.result.PortletVelocityResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.portlet.util (Struts 2 Core 2.0.6 API)

 org.apache.struts2.portlet.util
Classes
HttpServletRequestMock
PortletUrlHelper


Uses of Class org.apache.struts2.portlet.util.HttpServletRequestMock (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.util.HttpServletRequestMock

Packages that use HttpServletRequestMock
org.apache.struts2.portlet.util

Uses of HttpServletRequestMock in org.apache.struts2.portlet.util

Methods in org.apache.struts2.portlet.util that return HttpServletRequestMock
HttpServletRequestMock | HttpServletRequestMock.setParameterMap(Map parameterMap)
HttpServletRequestMock | HttpServletRequestMock.setServletPath(String servletPath)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.portlet.util.PortletUrlHelper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.portlet.util.PortletUrlHelper

No usage of org.apache.struts2.portlet.util.PortletUrlHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.servlet.interceptor (Struts 2 Core 2.0.6 API)

 org.apache.struts2.servlet.interceptor
Classes
ServletPrincipalProxy


Uses of Class org.apache.struts2.servlet.interceptor.ServletPrincipalProxy (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.servlet.interceptor.ServletPrincipalProxy

No usage of org.apache.struts2.servlet.interceptor.ServletPrincipalProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.util (Struts 2 Core 2.0.6 API)

 org.apache.struts2.util
Interfaces
IteratorGenerator.Converter
ObjectFactoryDestroyable
ServletContextAware
SubsetIteratorFilter.Decider
Classes
AppendIteratorFilter
AttributeMap
ClassLoaderUtils
ContainUtil
Counter
DateFormatter
FastByteArrayOutputStream
InvocationSessionStore
InvocationSessionStore.InvocationContext
IteratorFilterSupport
IteratorGenerator
ListEntry
MakeIterator
MergeIteratorFilter
PrefixTrie
PrefixTrie.Node
Sorter
SortIteratorFilter
StrutsTestCaseHelper
StrutsTypeConverter
StrutsUtil
StrutsUtil.ResponseWrapper
StrutsUtil.ServletOutputStreamWrapper
SubsetIteratorFilter
TabbedPane
Timer
TokenHelper
URLBean
VelocityStrutsUtil


Uses of Class org.apache.struts2.util.AppendIteratorFilter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.AppendIteratorFilter

Packages that use AppendIteratorFilter
org.apache.struts2.components

Uses of AppendIteratorFilter in org.apache.struts2.components

Fields in org.apache.struts2.components declared as AppendIteratorFilter
private  AppendIteratorFilter AppendIterator.appendIteratorFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.AttributeMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.AttributeMap

No usage of org.apache.struts2.util.AttributeMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.ClassLoaderUtils (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.ClassLoaderUtils

No usage of org.apache.struts2.util.ClassLoaderUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.ContainUtil (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.ContainUtil

No usage of org.apache.struts2.util.ContainUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.Counter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.Counter

No usage of org.apache.struts2.util.Counter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.DateFormatter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.DateFormatter

No usage of org.apache.struts2.util.DateFormatter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.FastByteArrayOutputStream (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.FastByteArrayOutputStream

Packages that use FastByteArrayOutputStream
org.apache.struts2.components

Uses of FastByteArrayOutputStream in org.apache.struts2.components

Fields in org.apache.struts2.components declared as FastByteArrayOutputStream
private  FastByteArrayOutputStream Include.PageOutputStream.buffer

Methods in org.apache.struts2.components that return FastByteArrayOutputStream
FastByteArrayOutputStream | Include.PageOutputStream.getBuffer() Return all data that has been written to this OutputStream.
FastByteArrayOutputStream | Include.PageResponse.getContent() Return the content buffered inside the Include.PageOutputStream.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.InvocationSessionStore (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.InvocationSessionStore

No usage of org.apache.struts2.util.InvocationSessionStore

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.InvocationSessionStore.InvocationContext (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.InvocationSessionStore.InvocationContext

No usage of org.apache.struts2.util.InvocationSessionStore.InvocationContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.IteratorFilterSupport (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.IteratorFilterSupport

Packages that use IteratorFilterSupport
org.apache.struts2.util Miscellaneous helper classes.

Uses of IteratorFilterSupport in org.apache.struts2.util

Subclasses of IteratorFilterSupport in org.apache.struts2.util
class | AppendIteratorFilter A bean that takes several iterators and outputs them in sequence
class | MergeIteratorFilter A bean that takes several iterators and outputs the merge of them.
class | SortIteratorFilter A bean that takes a source and comparator then attempt to sort the source utilizing the comparator.
class | SubsetIteratorFilter A bean that takes an iterator and outputs a subset of it.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator

No usage of org.apache.struts2.util.IteratorFilterSupport.EnumerationIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.IteratorGenerator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.IteratorGenerator

Packages that use IteratorGenerator
org.apache.struts2.views.jsp.iterator Struts's JSP tag library for iterator handling.

Uses of IteratorGenerator in org.apache.struts2.views.jsp.iterator

Fields in org.apache.struts2.views.jsp.iterator declared as IteratorGenerator
(package private)  IteratorGenerator IteratorGeneratorTag.iteratorGenerator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.util.IteratorGenerator.Converter (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.util.IteratorGenerator.Converter

Packages that use IteratorGenerator.Converter
org.apache.struts2.util Miscellaneous helper classes.

Uses of IteratorGenerator.Converter in org.apache.struts2.util

Fields in org.apache.struts2.util declared as IteratorGenerator.Converter
(package private)  IteratorGenerator.Converter IteratorGenerator.converter

Methods in org.apache.struts2.util with parameters of type IteratorGenerator.Converter
 void IteratorGenerator.setConverter(IteratorGenerator.Converter aConverter)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.ListEntry (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.ListEntry

No usage of org.apache.struts2.util.ListEntry

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.MakeIterator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.MakeIterator

No usage of org.apache.struts2.util.MakeIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.MergeIteratorFilter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.MergeIteratorFilter

Packages that use MergeIteratorFilter
org.apache.struts2.components

Uses of MergeIteratorFilter in org.apache.struts2.components

Fields in org.apache.struts2.components declared as MergeIteratorFilter
private  MergeIteratorFilter MergeIterator.mergeIteratorFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.util.ObjectFactoryDestroyable (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.util.ObjectFactoryDestroyable

No usage of org.apache.struts2.util.ObjectFactoryDestroyable

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.PrefixTrie (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.PrefixTrie

Packages that use PrefixTrie
org.apache.struts2.dispatcher.mapper

Uses of PrefixTrie in org.apache.struts2.dispatcher.mapper

Fields in org.apache.struts2.dispatcher.mapper declared as PrefixTrie
private  PrefixTrie DefaultActionMapper.prefixTrie

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.PrefixTrie.Node (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.PrefixTrie.Node

Packages that use PrefixTrie.Node
org.apache.struts2.util Miscellaneous helper classes.

Uses of PrefixTrie.Node in org.apache.struts2.util

Fields in org.apache.struts2.util declared as PrefixTrie.Node
(package private) PrefixTrie.Node[] | PrefixTrie.Node.next
(package private) PrefixTrie.Node | PrefixTrie.root

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.util.ServletContextAware (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.util.ServletContextAware

No usage of org.apache.struts2.util.ServletContextAware

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.Sorter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.Sorter

No usage of org.apache.struts2.util.Sorter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.SortIteratorFilter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.SortIteratorFilter

Packages that use SortIteratorFilter
org.apache.struts2.views.jsp.iterator Struts's JSP tag library for iterator handling.

Uses of SortIteratorFilter in org.apache.struts2.views.jsp.iterator

Fields in org.apache.struts2.views.jsp.iterator declared as SortIteratorFilter
(package private)  SortIteratorFilter SortIteratorTag.sortIteratorFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.StrutsTestCaseHelper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.StrutsTestCaseHelper

No usage of org.apache.struts2.util.StrutsTestCaseHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.StrutsTypeConverter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.StrutsTypeConverter

No usage of org.apache.struts2.util.StrutsTypeConverter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.StrutsUtil (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.StrutsUtil

Packages that use StrutsUtil
org.apache.struts2.util Miscellaneous helper classes.

Uses of StrutsUtil in org.apache.struts2.util

Subclasses of StrutsUtil in org.apache.struts2.util
 class VelocityStrutsUtil
Struts velocity related util.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.StrutsUtil.ResponseWrapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.StrutsUtil.ResponseWrapper

No usage of org.apache.struts2.util.StrutsUtil.ResponseWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper

No usage of org.apache.struts2.util.StrutsUtil.ServletOutputStreamWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.SubsetIteratorFilter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.SubsetIteratorFilter

Packages that use SubsetIteratorFilter
org.apache.struts2.views.jsp.iterator Struts's JSP tag library for iterator handling.

Uses of SubsetIteratorFilter in org.apache.struts2.views.jsp.iterator

Fields in org.apache.struts2.views.jsp.iterator declared as SubsetIteratorFilter
(package private)  SubsetIteratorFilter SubsetIteratorTag.subsetIteratorFilter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.util.SubsetIteratorFilter.Decider (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.util.SubsetIteratorFilter.Decider

Packages that use SubsetIteratorFilter.Decider
org.apache.struts2.util Miscellaneous helper classes.

Uses of SubsetIteratorFilter.Decider in org.apache.struts2.util

Fields in org.apache.struts2.util declared as SubsetIteratorFilter.Decider
(package private)  SubsetIteratorFilter.Decider SubsetIteratorFilter.decider

Methods in org.apache.struts2.util with parameters of type SubsetIteratorFilter.Decider
 void SubsetIteratorFilter.setDecider(SubsetIteratorFilter.Decider aDecider)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.TabbedPane (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.TabbedPane

No usage of org.apache.struts2.util.TabbedPane

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.Timer (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.Timer

No usage of org.apache.struts2.util.Timer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.TokenHelper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.TokenHelper

No usage of org.apache.struts2.util.TokenHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.URLBean (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.URLBean

Packages that use URLBean
org.apache.struts2.util Miscellaneous helper classes.

Uses of URLBean in org.apache.struts2.util

Methods in org.apache.struts2.util that return URLBean
URLBean | URLBean.addParameter(String name, Object value)
URLBean | URLBean.setPage(String page)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.util.VelocityStrutsUtil (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.util.VelocityStrutsUtil

No usage of org.apache.struts2.util.VelocityStrutsUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.validators (Struts 2 Core 2.0.6 API)

 org.apache.struts2.validators
Classes
DWRValidator
DWRValidator.ValidatorActionInvocation
DWRValidator.ValidatorActionProxy


Uses of Class org.apache.struts2.validators.DWRValidator (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.validators.DWRValidator

No usage of org.apache.struts2.validators.DWRValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation

No usage of org.apache.struts2.validators.DWRValidator.ValidatorActionInvocation

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.validators.DWRValidator.ValidatorActionProxy (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.validators.DWRValidator.ValidatorActionProxy

No usage of org.apache.struts2.validators.DWRValidator.ValidatorActionProxy

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views
Interfaces
TagLibrary
Classes
DefaultTagLibrary
JspSupportServlet


org.apache.struts2.views.annotations (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.annotations
Annotation Types
StrutsTag
StrutsTagAttribute


Uses of Class org.apache.struts2.views.annotations.StrutsTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.annotations.StrutsTag

Packages that use StrutsTag
org.apache.struts2.components |
org.apache.struts2.components.table |
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.

Uses of StrutsTag in org.apache.struts2.components

Classes in org.apache.struts2.components with annotations of type StrutsTag
class | ActionComponent
class | ActionError Render action errors if they exists the specific layout of the rendering depends on the theme itself.
class | ActionMessage Render action messages if they exists, specific rendering layout depends on the theme itself.
class | Anchor A tag that creates a HTML <a href='' /> that when clicked calls a URL remote XMLHttpRequest call via the dojo framework. THE FOLLOWING IS ONLY VALID WHEN AJAX IS CONFIGURED href errorText listenTopics notifyTopics executeScripts loadingText listenTopics handler formId formFilter targets showErrorTransportText targets indicator 'resultDivId' Deprecated.
class | AppendIterator
class | Autocompleter The autocomplete tag is a combobox that can autocomplete text entered on the input box.
class | Bean
class | Checkbox Renders an HTML input element of type checkbox, populated by the specified property from the ValueStack.
class | CheckboxList Creates a series of checkboxes from a list.
class | ComboBox The combo box is basically an HTML INPUT of type text and HTML SELECT grouped together to give you a combo box functionality.
class | Date Format Date object in different ways.
class | DateTimePicker
class | Debug
class | Div The div tag when used on the ajax theme, provides a remote call from the current page to update a section of content without having to refresh the entire page.
class | DoubleSelect Renders two HTML select elements with second one changing displayed values depending on selected entry of first one.
class | Else
class | ElseIf
class | FieldError Render field errors if they exists.
class | File Renders an HTML file input element.
class | Form Renders HTML an input form. The remote form allows the form to be submitted without the page being refreshed.
class | GenericUIBean Renders an custom UI widget using the specified templates.
class | Head Renders parts of the HEAD section for an HTML file.
class | Hidden Renders an HTML input element of type hidden, populated by the specified property from the ValueStack.
class | I18n Gets a resource bundle and place it on the value stack.
class | If
class | Include
class | InputTransferSelect Create a input transfer select component which is basically an text input and <select ...> tag with buttons in the middle of them allowing text to be added to the transfer select.
class | IteratorComponent
class | Label Renders an HTML LABEL that will allow you to output label:name combination that has the same format treatment as the rest of your UI controls.
class | MergeIterator
class | OptGroup Create a optgroup component which needs to resides within a select tag.
class | OptionTransferSelect Create a option transfer select component which is basically two <select ...> tag with buttons in the middle of them allowing options in each of the <select ...> to be moved between themselves.
class | Param
class | Password Render an HTML input tag of type password.
class | Property Used to get the property of a value, which will default to the top of the stack if none is specified.
class | Push
class | Radio Render a radio button input field.
class | Reset Render a reset button.
class | Select Render an HTML input tag of type select.
class | Set
class | Submit Render a submit button.
class | TabbedPanel The tabbedpanel widget is primarily an AJAX component, where each tab can either be local content or remote content (refreshed each time the user selects that tab).
class | Text Render a I18n text message.
class | TextArea Render HTML textarea tag.
class | TextField Render an HTML input field of type text
class | Token Stop double-submission of forms.
class | Tree Renders a tree widget with AJAX support. The id attribute is normally specified, such that it could be looked up using javascript if necessary. Examples
class | TreeNode Renders a tree node within a tree widget with AJAX support. Either of the following combinations should be used depending on if the tree is to be constrcted dynamically or statically.
class | UpDownSelect Create a Select component with buttons to move the elements in the select component up and down.
class | URL

Uses of StrutsTag in org.apache.struts2.components.table

Classes in org.apache.struts2.components.table with annotations of type StrutsTag
 class WebTable

Uses of StrutsTag in org.apache.struts2.views.jsp.iterator

Classes in org.apache.struts2.views.jsp.iterator with annotations of type StrutsTag
class | IteratorGeneratorTag NOTE: JSP-TAG
class | SortIteratorTag NOTE: JSP-TAG
class | SubsetIteratorTag NOTE: JSP-TAG

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.annotations.StrutsTagAttribute (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.annotations.StrutsTagAttribute

Packages that use StrutsTagAttribute
org.apache.struts2.components |
org.apache.struts2.components.table |
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.

Uses of StrutsTagAttribute in org.apache.struts2.components

Methods in org.apache.struts2.components with annotations of type StrutsTagAttribute
void | File.setAccept(String accept)
void | Form.setAcceptcharset(String acceptcharset)
void | UIBean.setAccesskey(String accesskey)
void | URL.setAction(String action)
void | FormButton.setAction(String action)
void | Form.setAction(String action)
void | OptionTransferSelect.setAddAllToLeftLabel(String addAllToLeftLabel)
void | OptionTransferSelect.setAddAllToRightLabel(String addAllToRightLabel)
void | InputTransferSelect.setAddLabel(String addLabel)
void | OptionTransferSelect.setAddToLeftLabel(String addToLeftLabel)
void | OptionTransferSelect.setAddToRightLabel(String addToRightLabel)
void | DateTimePicker.setAdjustWeeks(String adjustWeeks)
void | Submit.setAfterLoading(String afterLoading)
void | Div.setAfterLoading(String afterLoading)
void | Anchor.setAfterLoading(String afterLoading)
void | FormButton.setAlign(String align)
void | OptionTransferSelect.setAllowAddAllToLeft(String allowAddAllToLeft)
void | OptionTransferSelect.setAllowAddAllToRight(String allowAddAllToRight)
void | OptionTransferSelect.setAllowAddToLeft(String allowAddToLeft)
void | OptionTransferSelect.setAllowAddToRight(String allowAddToRight)
void | UpDownSelect.setAllowMoveDown(String allowMoveDown)
void | UpDownSelect.setAllowMoveUp(String allowMoveUp)
void | InputTransferSelect.setAllowRemoveAll(String allowRemoveAll)
void | UpDownSelect.setAllowSelectAll(String allowSelectAll)
void | OptionTransferSelect.setAllowSelectAll(String allowSelectAll)
void | InputTransferSelect.setAllowUpDown(String allowUpDown)
void | OptionTransferSelect.setAllowUpDownOnLeft(String allowUpDownOnLeft)
void | OptionTransferSelect.setAllowUpDownOnRight(String allowUpDownOnRight)
void | URL.setAnchor(String anchor)
void | Autocompleter.setAutoComplete(String autoComplete)
void | Div.setAutoStart(String autoStart)
void | Submit.setBeforeLoading(String beforeLoading)
void | Anchor.setBeforeLoading(String beforeLoading)
void | Tree.setBlankIconSrc(String blankIconSrc)
void | OptionTransferSelect.setButtonCssClass(String buttonCssClass)
void | InputTransferSelect.setButtonCssClass(String buttonCssClass)
void | OptionTransferSelect.setButtonCssStyle(String buttonCssStyle)
void | InputTransferSelect.setButtonCssStyle(String buttonCssStyle)
void | Head.setCalendarcss(String calendarcss)
void | Tree.setChildCollectionProperty(String childCollectionProperty)
void | TabbedPanel.setCloseButton(String closeButton)
void | TextArea.setCols(String cols)
void | UIBean.setCssClass(String cssClass)
void | UIBean.setCssStyle(String cssStyle)
void | DateTimePicker.setDayWidth(String dayWidth)
void | Head.setDebug(boolean debug)
void | Property.setDefault(String defaultValue)
void | Div.setDelay(String delay)
void | Autocompleter.setDelay(String searchDelay)
void | UIBean.setDisabled(String disabled)
void | OptGroup.setDisabled(String disabled)
void | Autocompleter.setDisabled(String disabled)
void | DateTimePicker.setDisplayFormat(String displayFormat)
void | DateTimePicker.setDisplayWeeks(String displayWeeks)
void | TabbedPanel.setDoLayout(String doLayout)
void | DoubleListUIBean.setDoubleAccesskey(String doubleAccesskey)
void | DoubleListUIBean.setDoubleCssClass(String doubleCssClass)
void | DoubleListUIBean.setDoubleCssStyle(String doubleCssStyle)
void | DoubleListUIBean.setDoubleDisabled(String doubleDisabled)
void | DoubleListUIBean.setDoubleEmptyOption(String doubleEmptyOption)
void | DoubleListUIBean.setDoubleHeaderKey(String doubleHeaderKey)
void | DoubleListUIBean.setDoubleHeaderValue(String doubleHeaderValue)
void | DoubleListUIBean.setDoubleId(String doubleId)
void | DoubleListUIBean.setDoubleList(String doubleList)
void | DoubleListUIBean.setDoubleListKey(String doubleListKey)
void | DoubleListUIBean.setDoubleListValue(String doubleListValue)
void | DoubleListUIBean.setDoubleMultiple(String doubleMultiple)
void | DoubleListUIBean.setDoubleName(String doubleName)
void | DoubleListUIBean.setDoubleOnblur(String doubleOnblur)
void | DoubleListUIBean.setDoubleOnchange(String doubleOnchange)
void | DoubleListUIBean.setDoubleOnclick(String doubleOnclick)
void | DoubleListUIBean.setDoubleOndblclick(String doubleOndblclick)
void | DoubleListUIBean.setDoubleOnfocus(String doubleOnfocus)
void | DoubleListUIBean.setDoubleOnkeydown(String doubleOnkeydown)
void | DoubleListUIBean.setDoubleOnkeypress(String doubleOnkeypress)
void | DoubleListUIBean.setDoubleOnkeyup(String doubleOnkeyup)
void | DoubleListUIBean.setDoubleOnmousedown(String doubleOnmousedown)
void | DoubleListUIBean.setDoubleOnmousemove(String doubleOnmousemove)
void | DoubleListUIBean.setDoubleOnmouseout(String doubleOnmouseout)
void | DoubleListUIBean.setDoubleOnmouseover(String doubleOnmouseover)
void | DoubleListUIBean.setDoubleOnmouseup(String doubleOnmouseup)
void | DoubleListUIBean.setDoubleOnselect(String doubleOnselect)
void | DoubleListUIBean.setDoubleSize(String doubleSize)
void | DoubleListUIBean.setDoubleValue(String doubleValue)
void | InputTransferSelect.setDownLabel(String downLabel)
void | Autocompleter.setDropdownHeight(String height)
void | Autocompleter.setDropdownWidth(String width)
void | Select.setEmptyOption(String emptyOption)
void | DoubleListUIBean.setEmptyOption(String emptyOption)
void | ComboBox.setEmptyOption(String emptyOption)
void | URL.setEncode(boolean encode)
void | Form.setEnctype(String enctype)
void | DateTimePicker.setEndDate(String endDate)
void | Submit.setErrorText(String errorText)
void | AbstractRemoteCallUIBean.setErrorText(String errorText)
void | Property.setEscape(boolean escape)
void | ActionComponent.setExecuteResult(boolean executeResult)
void | Submit.setExecuteScripts(String executeScripts)
void | AbstractRemoteCallUIBean.setExecuteScripts(String executeScripts)
void | Tree.setExpandIconSrcMinus(String expandIconSrcMinus)
void | Tree.setExpandIconSrcPlus(String expandIconSrcPlus)
void | Checkbox.setFieldValue(String fieldValue)
void | ActionComponent.setFlush(boolean flush)
void | Label.setFor(String forAttr)
void | Autocompleter.setForceValidOption(String forceValidOption)
void | Date.setFormat(String format)
void | DateTimePicker.setFormatLength(String formatLength)
void | Submit.setFormFilter(String formFilter)
void | Autocompleter.setFormFilter(String formFilter)
void | AbstractRemoteCallUIBean.setFormFilter(String formFilter)
void | Submit.setFormId(String formId)
void | Autocompleter.setFormId(String formId)
void | AbstractRemoteCallUIBean.setFormId(String formId)
void | DoubleListUIBean.setFormName(String formName)
void | Tree.setGridIconSrcC(String gridIconSrcC)
void | Tree.setGridIconSrcL(String gridIconSrcL)
void | Tree.setGridIconSrcP(String gridIconSrcP)
void | Tree.setGridIconSrcV(String gridIconSrcV)
void | Tree.setGridIconSrcX(String gridIconSrcX)
void | Tree.setGridIconSrcY(String gridIconSrcY)
void | Submit.setHandler(String handler)
void | AbstractRemoteCallUIBean.setHandler(String handler)
void | Select.setHeaderKey(String headerKey)
void | InputTransferSelect.setHeaderKey(String headerKey)
void | DoubleListUIBean.setHeaderKey(String headerKey)
void | ComboBox.setHeaderKey(String headerKey)
void | Select.setHeaderValue(String headerValue)
void | InputTransferSelect.setHeaderValue(String headerValue)
void | DoubleListUIBean.setHeaderValue(String headerValue)
void | ComboBox.setHeaderValue(String headerValue)
void | Submit.setHref(String href)
void | Autocompleter.setHref(String href)
void | AbstractRemoteCallUIBean.setHref(String href)
void | Tree.setIconHeight(String iconHeight)
void | DateTimePicker.setIconPath(String iconPath)
void | Autocompleter.setIconPath(String iconPath)
void | Tree.setIconWidth(String iconWidth)
void | TabbedPanel.setId(String id)
void | MergeIterator.setId(String id)
void | Component.setId(String id)
void | AppendIterator.setId(String id)
void | ActionComponent.setIgnoreContextParams(boolean ignoreContextParams)
void | URL.setIncludeContext(boolean includeContext)
void | URL.setIncludeParams(String includeParams)
void | Submit.setIndicator(String indicator)
void | Autocompleter.setIndicator(String indicator)
void | AbstractRemoteCallUIBean.setIndicator(String indicator)
void | UIBean.setKey(String key)
void | Autocompleter.setKeyName(String keyName)
void | UIBean.setLabel(String label)
void | TreeNode.setLabel(String label)
void | Reset.setLabel(String label)
void | OptGroup.setLabel(String label)
void | UIBean.setLabelposition(String labelPosition)
void | DateTimePicker.setLanguage(String language)
void | OptionTransferSelect.setLeftDownLabel(String leftDownLabel)
void | OptionTransferSelect.setLeftTitle(String leftTitle)
void | InputTransferSelect.setLeftTitle(String leftTitle)
void | OptionTransferSelect.setLeftUpLabel(String leftUpLabel)
void | ListUIBean.setList(Object list)
void | OptGroup.setList(String list)
void | ComboBox.setList(String list)
void | Autocompleter.setList(String list)
void | Submit.setListenTopics(String listenTopics)
void | Autocompleter.setListenTopics(String listenTopics)
void | AbstractRemoteCallUIBean.setListenTopics(String listenTopics)
void | OptGroup.setListKey(String listKey)
void | ListUIBean.setListKey(String listKey)
void | ComboBox.setListKey(String listKey)
void | OptGroup.setListValue(String listValue)
void | ListUIBean.setListValue(String listValue)
void | ComboBox.setListValue(String listValue)
void | Submit.setLoadingText(String loadingText)
void | AbstractRemoteCallUIBean.setLoadingText(String loadingText)
void | Autocompleter.setLoadMinimumCount(String loadMinimumCount)
void | Autocompleter.setLoadOnTextChange(String loadOnType)
void | TextField.setMaxlength(String maxlength)
void | TextField.setMaxLength(String maxlength)
void | URL.setMethod(String method)
void | FormButton.setMethod(String method)
void | Form.setMethod(String method)
void | UpDownSelect.setMoveDownLabel(String moveDownLabel)
void | UpDownSelect.setMoveUpLabel(String moveUpLabel)
void | Select.setMultiple(String multiple)
void | InputTransferSelect.setMultiple(String multiple)
void | DoubleListUIBean.setMultiple(String multiple)
void | UIBean.setName(String name)
void | Text.setName(String name)
void | Set.setName(String name)
void | Param.setName(String name)
void | I18n.setName(String name)
void | Date.setName(String name)
void | Bean.setName(String name)
void | ActionComponent.setName(String name)
void | URL.setNamespace(String namespace)
void | Form.setNamespace(String namespace)
void | ActionComponent.setNamespace(String namespace)
void | Date.setNice(boolean nice)
void | Tree.setNodeIdProperty(String nodeIdProperty)
void | Tree.setNodeTitleProperty(String nodeTitleProperty)
void | Submit.setNotifyTopics(String notifyTopics)
void | Autocompleter.setNotifyTopics(String onValueChangedPublishTopic)
void | AbstractRemoteCallUIBean.setNotifyTopics(String notifyTopics)
void | UIBean.setOnblur(String onblur)
void | UIBean.setOnchange(String onchange)
void | UIBean.setOnclick(String onclick)
void | UIBean.setOndblclick(String ondblclick)
void | UIBean.setOnfocus(String onfocus)
void | UIBean.setOnkeydown(String onkeydown)
void | UIBean.setOnkeypress(String onkeypress)
void | UIBean.setOnkeyup(String onkeyup)
void | UIBean.setOnmousedown(String onmousedown)
void | UIBean.setOnmousemove(String onmousemove)
void | UIBean.setOnmouseout(String onmouseout)
void | UIBean.setOnmouseover(String onmouseover)
void | UIBean.setOnmouseup(String onmouseup)
void | UIBean.setOnselect(String onselect)
void | Form.setOnsubmit(String onsubmit)
void | ClosingUIBean.setOpenTemplate(String openTemplate)
void | URL.setPortletMode(String portletMode)
void | Form.setPortletMode(String portletMode)
void | URL.setPortletUrlType(String portletUrlType)
void | TextField.setReadonly(String readonly)
void | TextArea.setReadonly(String readonly)
void | Div.setRefreshOnShow(String refreshOnShow)
void | InputTransferSelect.setRemoveAllLabel(String removeAllLabel)
void | InputTransferSelect.setRemoveLabel(String removeLabel)
void | UIBean.setRequired(String required)
void | UIBean.setRequiredposition(String requiredposition)
void | OptionTransferSelect.setRightDownLabel(String rightDownlabel)
void | OptionTransferSelect.setRightTitle(String rightTitle)
void | InputTransferSelect.setRightTitle(String rightTitle)
void | OptionTransferSelect.setRightUpLabel(String rightUpLabel)
void | Tree.setRootNode(String rootNode)
void | TextArea.setRows(String rows)
void | URL.setScheme(String scheme)
void | Set.setScope(String scope)
void | Autocompleter.setSearchType(String searchType)
void | UpDownSelect.setSelectAllLabel(String selectAllLabel)
void | OptionTransferSelect.setSelectAllLabel(String selectAllLabel)
void | TabbedPanel.setSelectedTab(String selectedTab)
void | Autocompleter.setShowDownArrow(String showDownArrow)
void | Submit.setShowErrorTransportText(String showErrorTransportText)
void | AbstractRemoteCallUIBean.setShowErrorTransportText(String showError)
void | Tree.setShowGrid(String showGrid)
void | Submit.setShowLoadingText(String showLoadingText)
void | AbstractRemoteCallUIBean.setShowLoadingText(String showLoadingText)
void | Password.setShowPassword(String showPassword)
void | Tree.setShowRootGrid(String showRootGrid)
void | TextField.setSize(String size)
void | Select.setSize(String size)
void | InputTransferSelect.setSize(String size)
void | File.setSize(String size)
void | DoubleListUIBean.setSize(String size)
void | Submit.setSrc(String src)
void | DateTimePicker.setStartDate(String startDate)
void | Div.setStartTimerListenTopics(String startTimerListenTopic)
void | DateTimePicker.setStaticDisplay(String staticDisplay)
void | IteratorComponent.setStatus(String status)
void | Div.setStopTimerListenTopics(String stopTimerListenTopic)
void | UIBean.setTabindex(String tabindex)
void | Form.setTarget(String target)
void | Submit.setTargets(String targets)
void | Anchor.setTargets(String targets)
void | UIBean.setTemplate(String template)
void | Tree.setTemplateCssPath(String templateCssPath)
void | TabbedPanel.setTemplateCssPath(String templateCssPath)
void | DateTimePicker.setTemplateCssPath(String templateCssPath)
void | Autocompleter.setTemplateCssPath(String templateCssPath)
void | UIBean.setTemplateDir(String templateDir)
void | If.setTest(String test)
void | ElseIf.setTest(String test)
void | UIBean.setTheme(String theme)
void | Submit.setTheme(String theme)
void | UIBean.setTitle(String title)
void | Tree.setToggle(String toggle)
void | Tree.setToggleDuration(String toggleDuration)
void | DateTimePicker.setToggleDuration(String toggleDuration)
void | DateTimePicker.setToggleType(String toggleType)
void | UIBean.setTooltip(String tooltip)
void | UIBean.setTooltipConfig(String tooltipConfig)
void | Tree.setTreeCollapsedTopic(String treeCollapsedTopic)
void | Tree.setTreeExpandedTopic(String treeExpandedTopic)
void | Tree.setTreeSelectedTopic(String treeSelectedTopic)
void | FormButton.setType(String type)
void | DateTimePicker.setType(String type)
void | Div.setUpdateFreq(String updateInterval)
void | InputTransferSelect.setUpLabel(String upLabel)
void | Form.setValidate(String validate)
void | URL.setValue(String value)
void | UIBean.setValue(String value)
void | Set.setValue(String value)
void | Push.setValue(String value)
void | Property.setValue(String value)
void | Param.setValue(String value)
void | IteratorComponent.setValue(String value)
void | Include.setValue(String value)
void | DateTimePicker.setWeekStartsOn(String weekStartsOn)
void | URL.setWindowState(String windowState)
void | Form.setWindowState(String windowState)
void | TextArea.setWrap(String wrap)

Uses of StrutsTagAttribute in org.apache.struts2.components.table

Methods in org.apache.struts2.components.table with annotations of type StrutsTagAttribute
void | WebTable.setSortable(boolean sortable)
void | WebTable.setSortColumn(int sortColumn)
void | WebTable.setSortOrder(String sortOrder)

Uses of StrutsTagAttribute in org.apache.struts2.views.jsp.iterator

Methods in org.apache.struts2.views.jsp.iterator with annotations of type StrutsTagAttribute
void | SortIteratorTag.setComparator(String comparator)
void | IteratorGeneratorTag.setConverter(String aConverter)
void | SubsetIteratorTag.setCount(String count)
void | IteratorGeneratorTag.setCount(String count)
void | SubsetIteratorTag.setDecider(String decider)
void | IteratorGeneratorTag.setId(String string)
void | IteratorGeneratorTag.setSeparator(String separator)
void | SubsetIteratorTag.setSource(String source)
void | SortIteratorTag.setSource(String source)
void | SubsetIteratorTag.setStart(String start)
void | IteratorGeneratorTag.setVal(String val)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.DefaultTagLibrary (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.DefaultTagLibrary

No usage of org.apache.struts2.views.DefaultTagLibrary

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.JspSupportServlet (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.JspSupportServlet

Packages that use JspSupportServlet
org.apache.struts2.views

Uses of JspSupportServlet in org.apache.struts2.views

Fields in org.apache.struts2.views declared as JspSupportServlet
static JspSupportServlet JspSupportServlet.jspSupportServlet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.views.TagLibrary (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.views.TagLibrary

Packages that use TagLibrary
org.apache.struts2.views |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.
org.apache.struts2.views.velocity | Classes for views using Velocity.

Uses of TagLibrary in org.apache.struts2.views

Classes in org.apache.struts2.views that implement TagLibrary
 class DefaultTagLibrary
The default Struts tag library

Uses of TagLibrary in org.apache.struts2.views.freemarker

Fields in org.apache.struts2.views.freemarker with type parameters of type TagLibrary
private  Map<String,TagLibrary> FreemarkerManager.tagLibraries

Uses of TagLibrary in org.apache.struts2.views.velocity

Fields in org.apache.struts2.views.velocity with type parameters of type TagLibrary
private  List<TagLibrary> VelocityManager.tagLibraries

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.freemarker (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.freemarker
Classes
FreemarkerManager
FreemarkerResult
PortletFreemarkerResult
ScopesHashModel
StrutsBeanWrapper
StrutsBeanWrapper.FriendlyMapModel
StrutsClassTemplateLoader


Uses of Class org.apache.struts2.views.freemarker.FreemarkerManager (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.FreemarkerManager

Packages that use FreemarkerManager
org.apache.struts2.components.template |
org.apache.struts2.interceptor.debugging |
org.apache.struts2.views.freemarker | Classes for views using FreeMarker.

Uses of FreemarkerManager in org.apache.struts2.components.template

Fields in org.apache.struts2.components.template declared as FreemarkerManager
private  FreemarkerManager FreemarkerTemplateEngine.freemarkerManager

Methods in org.apache.struts2.components.template with parameters of type FreemarkerManager
 void FreemarkerTemplateEngine.setFreemarkerManager(FreemarkerManager mgr)

Uses of FreemarkerManager in org.apache.struts2.interceptor.debugging

Fields in org.apache.struts2.interceptor.debugging declared as FreemarkerManager
private  FreemarkerManager DebuggingInterceptor.freemarkerManager

Methods in org.apache.struts2.interceptor.debugging with parameters of type FreemarkerManager
 void DebuggingInterceptor.setFreemarkerManager(FreemarkerManager mgr)

Uses of FreemarkerManager in org.apache.struts2.views.freemarker

Fields in org.apache.struts2.views.freemarker declared as FreemarkerManager
protected FreemarkerManager | PortletFreemarkerResult.freemarkerManager
protected FreemarkerManager | FreemarkerResult.freemarkerManager

Methods in org.apache.struts2.views.freemarker with parameters of type FreemarkerManager
void | PortletFreemarkerResult.setFreemarkerManager(FreemarkerManager mgr)
void | FreemarkerResult.setFreemarkerManager(FreemarkerManager mgr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.FreemarkerResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.FreemarkerResult

No usage of org.apache.struts2.views.freemarker.FreemarkerResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.PortletFreemarkerResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.PortletFreemarkerResult

No usage of org.apache.struts2.views.freemarker.PortletFreemarkerResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.ScopesHashModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.ScopesHashModel

Packages that use ScopesHashModel
org.apache.struts2.views.freemarker Classes for views using FreeMarker.

Uses of ScopesHashModel in org.apache.struts2.views.freemarker

Methods in org.apache.struts2.views.freemarker that return ScopesHashModel
protected  ScopesHashModel FreemarkerManager.buildScopesHashModel(ServletContext servletContext, HttpServletRequest request, HttpServletResponse response, freemarker.template.ObjectWrapper wrapper, ValueStack stack)

Methods in org.apache.struts2.views.freemarker with parameters of type ScopesHashModel
protected  void FreemarkerManager.populateContext(ScopesHashModel model, ValueStack stack, Object action, HttpServletRequest request, HttpServletResponse response)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.StrutsBeanWrapper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.StrutsBeanWrapper

No usage of org.apache.struts2.views.freemarker.StrutsBeanWrapper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel

No usage of org.apache.struts2.views.freemarker.StrutsBeanWrapper.FriendlyMapModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.StrutsClassTemplateLoader (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.StrutsClassTemplateLoader

No usage of org.apache.struts2.views.freemarker.StrutsClassTemplateLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.freemarker.tags (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.freemarker.tags
Classes
ActionErrorModel
ActionMessageModel
ActionModel
AnchorModel
AutocompleterModel
BeanModel
CallbackWriter
CheckboxListModel
CheckboxModel
ComboBoxModel
ComponentModel
DateModel
DateTimePickerModel
DivModel
DoubleSelectModel
ElseIfModel
ElseModel
FieldErrorModel
FileModel
FormModel
HeadModel
HiddenModel
I18nModel
IfModel
IncludeModel
InputTransferSelectModel
IteratorModel
LabelModel
OptGroupModel
OptionTransferSelectModel
ParamModel
PasswordModel
PropertyModel
PushModel
RadioModel
ResetModel
SelectModel
SetModel
StrutsModels
SubmitModel
TabbedPanelModel
TagModel
TextAreaModel
TextFieldModel
TextModel
TokenModel
TreeModel
TreeNodeModel
UpDownSelectModel
URLModel
WebTableModel


Uses of Class org.apache.struts2.views.freemarker.tags.ActionErrorModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ActionErrorModel

Packages that use ActionErrorModel
org.apache.struts2.views.freemarker.tags

Uses of ActionErrorModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ActionErrorModel
protected  ActionErrorModel StrutsModels.actionerror

Methods in org.apache.struts2.views.freemarker.tags that return ActionErrorModel
 ActionErrorModel StrutsModels.getActionerror()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.ActionMessageModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ActionMessageModel

Packages that use ActionMessageModel
org.apache.struts2.views.freemarker.tags

Uses of ActionMessageModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ActionMessageModel
protected  ActionMessageModel StrutsModels.actionmessage

Methods in org.apache.struts2.views.freemarker.tags that return ActionMessageModel
 ActionMessageModel StrutsModels.getActionmessage()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.ActionModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ActionModel

Packages that use ActionModel
org.apache.struts2.views.freemarker.tags

Uses of ActionModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ActionModel
protected  ActionModel StrutsModels.action

Methods in org.apache.struts2.views.freemarker.tags that return ActionModel
 ActionModel StrutsModels.getAction()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.AnchorModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.AnchorModel

Packages that use AnchorModel
org.apache.struts2.views.freemarker.tags

Uses of AnchorModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as AnchorModel
protected  AnchorModel StrutsModels.a

Methods in org.apache.struts2.views.freemarker.tags that return AnchorModel
AnchorModel | StrutsModels.getA()
AnchorModel | StrutsModels.getHref()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.AutocompleterModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.AutocompleterModel

Packages that use AutocompleterModel
org.apache.struts2.views.freemarker.tags

Uses of AutocompleterModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as AutocompleterModel
protected  AutocompleterModel StrutsModels.autocompleterModel

Methods in org.apache.struts2.views.freemarker.tags that return AutocompleterModel
 AutocompleterModel StrutsModels.getAutocompleterModel()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.BeanModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.BeanModel

Packages that use BeanModel
org.apache.struts2.views.freemarker.tags

Uses of BeanModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as BeanModel
protected  BeanModel StrutsModels.bean

Methods in org.apache.struts2.views.freemarker.tags that return BeanModel
 BeanModel StrutsModels.getBean()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.CallbackWriter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.CallbackWriter

No usage of org.apache.struts2.views.freemarker.tags.CallbackWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.CheckboxListModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.CheckboxListModel

Packages that use CheckboxListModel
org.apache.struts2.views.freemarker.tags

Uses of CheckboxListModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as CheckboxListModel
protected  CheckboxListModel StrutsModels.checkboxlist

Methods in org.apache.struts2.views.freemarker.tags that return CheckboxListModel
 CheckboxListModel StrutsModels.getCheckboxlist()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.CheckboxModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.CheckboxModel

Packages that use CheckboxModel
org.apache.struts2.views.freemarker.tags

Uses of CheckboxModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as CheckboxModel
protected  CheckboxModel StrutsModels.checkbox

Methods in org.apache.struts2.views.freemarker.tags that return CheckboxModel
 CheckboxModel StrutsModels.getCheckbox()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.ComboBoxModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ComboBoxModel

Packages that use ComboBoxModel
org.apache.struts2.views.freemarker.tags

Uses of ComboBoxModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ComboBoxModel
protected  ComboBoxModel StrutsModels.comboBox

Methods in org.apache.struts2.views.freemarker.tags that return ComboBoxModel
 ComboBoxModel StrutsModels.getComboBox()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.ComponentModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ComponentModel

Packages that use ComponentModel
org.apache.struts2.views.freemarker.tags

Uses of ComponentModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ComponentModel
protected  ComponentModel StrutsModels.component

Methods in org.apache.struts2.views.freemarker.tags that return ComponentModel
 ComponentModel StrutsModels.getComponent()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.DateModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.DateModel

Packages that use DateModel
org.apache.struts2.views.freemarker.tags

Uses of DateModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as DateModel
protected  DateModel StrutsModels.date

Methods in org.apache.struts2.views.freemarker.tags that return DateModel
 DateModel StrutsModels.getDate()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.DateTimePickerModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.DateTimePickerModel

Packages that use DateTimePickerModel
org.apache.struts2.views.freemarker.tags

Uses of DateTimePickerModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as DateTimePickerModel
protected  DateTimePickerModel StrutsModels.dateTimePicker

Methods in org.apache.struts2.views.freemarker.tags that return DateTimePickerModel
 DateTimePickerModel StrutsModels.getDateTimePicker()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.DivModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.DivModel

Packages that use DivModel
org.apache.struts2.views.freemarker.tags

Uses of DivModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as DivModel
protected  DivModel StrutsModels.div

Methods in org.apache.struts2.views.freemarker.tags that return DivModel
 DivModel StrutsModels.getDiv()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.DoubleSelectModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.DoubleSelectModel

Packages that use DoubleSelectModel
org.apache.struts2.views.freemarker.tags

Uses of DoubleSelectModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as DoubleSelectModel
protected  DoubleSelectModel StrutsModels.doubleselect

Methods in org.apache.struts2.views.freemarker.tags that return DoubleSelectModel
 DoubleSelectModel StrutsModels.getDoubleselect()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.ElseIfModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ElseIfModel

Packages that use ElseIfModel
org.apache.struts2.views.freemarker.tags

Uses of ElseIfModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ElseIfModel
protected  ElseIfModel StrutsModels.elseIfModel

Methods in org.apache.struts2.views.freemarker.tags that return ElseIfModel
 ElseIfModel StrutsModels.getElseif()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.ElseModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ElseModel

Packages that use ElseModel
org.apache.struts2.views.freemarker.tags

Uses of ElseModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ElseModel
protected  ElseModel StrutsModels.elseModel

Methods in org.apache.struts2.views.freemarker.tags that return ElseModel
 ElseModel StrutsModels.getElse()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.FieldErrorModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.FieldErrorModel

Packages that use FieldErrorModel
org.apache.struts2.views.freemarker.tags

Uses of FieldErrorModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as FieldErrorModel
protected  FieldErrorModel StrutsModels.fielderror

Methods in org.apache.struts2.views.freemarker.tags that return FieldErrorModel
 FieldErrorModel StrutsModels.getFielderror()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.FileModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.FileModel

Packages that use FileModel
org.apache.struts2.views.freemarker.tags

Uses of FileModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as FileModel
protected  FileModel StrutsModels.file

Methods in org.apache.struts2.views.freemarker.tags that return FileModel
 FileModel StrutsModels.getFile()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.FormModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.FormModel

Packages that use FormModel
org.apache.struts2.views.freemarker.tags

Uses of FormModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as FormModel
protected  FormModel StrutsModels.form

Methods in org.apache.struts2.views.freemarker.tags that return FormModel
 FormModel StrutsModels.getForm()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.HeadModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.HeadModel

Packages that use HeadModel
org.apache.struts2.views.freemarker.tags

Uses of HeadModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as HeadModel
protected  HeadModel StrutsModels.head

Methods in org.apache.struts2.views.freemarker.tags that return HeadModel
 HeadModel StrutsModels.getHead()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.HiddenModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.HiddenModel

Packages that use HiddenModel
org.apache.struts2.views.freemarker.tags

Uses of HiddenModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as HiddenModel
protected  HiddenModel StrutsModels.hidden

Methods in org.apache.struts2.views.freemarker.tags that return HiddenModel
 HiddenModel StrutsModels.getHidden()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.I18nModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.I18nModel

Packages that use I18nModel
org.apache.struts2.views.freemarker.tags

Uses of I18nModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as I18nModel
protected  I18nModel StrutsModels.i18n

Methods in org.apache.struts2.views.freemarker.tags that return I18nModel
 I18nModel StrutsModels.getI18n()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.IfModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.IfModel

Packages that use IfModel
org.apache.struts2.views.freemarker.tags

Uses of IfModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as IfModel
protected  IfModel StrutsModels.ifModel

Methods in org.apache.struts2.views.freemarker.tags that return IfModel
 IfModel StrutsModels.getIf()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.IncludeModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.IncludeModel

Packages that use IncludeModel
org.apache.struts2.views.freemarker.tags

Uses of IncludeModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as IncludeModel
protected  IncludeModel StrutsModels.include

Methods in org.apache.struts2.views.freemarker.tags that return IncludeModel
 IncludeModel StrutsModels.getInclude()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.InputTransferSelectModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.InputTransferSelectModel

Packages that use InputTransferSelectModel
org.apache.struts2.views.freemarker.tags

Uses of InputTransferSelectModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as InputTransferSelectModel
protected  InputTransferSelectModel StrutsModels.inputtransferselect

Methods in org.apache.struts2.views.freemarker.tags that return InputTransferSelectModel
 InputTransferSelectModel StrutsModels.getInputtransferselect()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.IteratorModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.IteratorModel

Packages that use IteratorModel
org.apache.struts2.views.freemarker.tags

Uses of IteratorModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as IteratorModel
protected  IteratorModel StrutsModels.iterator

Methods in org.apache.struts2.views.freemarker.tags that return IteratorModel
 IteratorModel StrutsModels.getIterator()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.LabelModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.LabelModel

Packages that use LabelModel
org.apache.struts2.views.freemarker.tags

Uses of LabelModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as LabelModel
protected  LabelModel StrutsModels.label

Methods in org.apache.struts2.views.freemarker.tags that return LabelModel
 LabelModel StrutsModels.getLabel()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.OptGroupModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.OptGroupModel

Packages that use OptGroupModel
org.apache.struts2.views.freemarker.tags

Uses of OptGroupModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as OptGroupModel
protected  OptGroupModel StrutsModels.optGroupModel

Methods in org.apache.struts2.views.freemarker.tags that return OptGroupModel
 OptGroupModel StrutsModels.getOptgroup()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.OptionTransferSelectModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.OptionTransferSelectModel

Packages that use OptionTransferSelectModel
org.apache.struts2.views.freemarker.tags

Uses of OptionTransferSelectModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as OptionTransferSelectModel
protected  OptionTransferSelectModel StrutsModels.optiontransferselect

Methods in org.apache.struts2.views.freemarker.tags that return OptionTransferSelectModel
 OptionTransferSelectModel StrutsModels.getOptiontransferselect()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.ParamModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ParamModel

Packages that use ParamModel
org.apache.struts2.views.freemarker.tags

Uses of ParamModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ParamModel
protected  ParamModel StrutsModels.param

Methods in org.apache.struts2.views.freemarker.tags that return ParamModel
 ParamModel StrutsModels.getParam()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.PasswordModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.PasswordModel

Packages that use PasswordModel
org.apache.struts2.views.freemarker.tags

Uses of PasswordModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as PasswordModel
protected  PasswordModel StrutsModels.password

Methods in org.apache.struts2.views.freemarker.tags that return PasswordModel
 PasswordModel StrutsModels.getPassword()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.PropertyModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.PropertyModel

Packages that use PropertyModel
org.apache.struts2.views.freemarker.tags

Uses of PropertyModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as PropertyModel
protected  PropertyModel StrutsModels.property

Methods in org.apache.struts2.views.freemarker.tags that return PropertyModel
 PropertyModel StrutsModels.getProperty()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.PushModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.PushModel

Packages that use PushModel
org.apache.struts2.views.freemarker.tags

Uses of PushModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as PushModel
protected  PushModel StrutsModels.push

Methods in org.apache.struts2.views.freemarker.tags that return PushModel
 PushModel StrutsModels.getPush()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.RadioModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.RadioModel

Packages that use RadioModel
org.apache.struts2.views.freemarker.tags

Uses of RadioModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as RadioModel
protected  RadioModel StrutsModels.radio

Methods in org.apache.struts2.views.freemarker.tags that return RadioModel
 RadioModel StrutsModels.getRadio()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.ResetModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.ResetModel

Packages that use ResetModel
org.apache.struts2.views.freemarker.tags

Uses of ResetModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as ResetModel
protected  ResetModel StrutsModels.reset

Methods in org.apache.struts2.views.freemarker.tags that return ResetModel
 ResetModel StrutsModels.getReset()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.SelectModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.SelectModel

Packages that use SelectModel
org.apache.struts2.views.freemarker.tags

Uses of SelectModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as SelectModel
protected  SelectModel StrutsModels.select

Methods in org.apache.struts2.views.freemarker.tags that return SelectModel
 SelectModel StrutsModels.getSelect()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.SetModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.SetModel

Packages that use SetModel
org.apache.struts2.views.freemarker.tags

Uses of SetModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as SetModel
protected  SetModel StrutsModels.set

Methods in org.apache.struts2.views.freemarker.tags that return SetModel
 SetModel StrutsModels.getSet()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.StrutsModels (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.StrutsModels

No usage of org.apache.struts2.views.freemarker.tags.StrutsModels

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.SubmitModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.SubmitModel

Packages that use SubmitModel
org.apache.struts2.views.freemarker.tags

Uses of SubmitModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as SubmitModel
protected  SubmitModel StrutsModels.submit

Methods in org.apache.struts2.views.freemarker.tags that return SubmitModel
 SubmitModel StrutsModels.getSubmit()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.TabbedPanelModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.TabbedPanelModel

Packages that use TabbedPanelModel
org.apache.struts2.views.freemarker.tags

Uses of TabbedPanelModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as TabbedPanelModel
protected  TabbedPanelModel StrutsModels.tabbedPanel

Methods in org.apache.struts2.views.freemarker.tags that return TabbedPanelModel
 TabbedPanelModel StrutsModels.getTabbedPanel()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.TagModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.TagModel

Packages that use TagModel
org.apache.struts2.views.freemarker.tags

Uses of TagModel in org.apache.struts2.views.freemarker.tags

Subclasses of TagModel in org.apache.struts2.views.freemarker.tags
class | ActionErrorModel
class | ActionMessageModel
class | ActionModel
class | AnchorModel
class | AutocompleterModel
class | BeanModel
class | CheckboxListModel
class | CheckboxModel
class | ComboBoxModel
class | ComponentModel
class | DateModel DateModel
class | DateTimePickerModel
class | DivModel
class | DoubleSelectModel
class | ElseIfModel
class | ElseModel
class | FieldErrorModel
class | FileModel
class | FormModel
class | HeadModel
class | HiddenModel
class | I18nModel
class | IfModel
class | IncludeModel
class | InputTransferSelectModel
class | IteratorModel
class | LabelModel
class | OptGroupModel Freemarker's TransformModel for OptGroup component.
class | OptionTransferSelectModel
class | ParamModel
class | PasswordModel
class | PropertyModel
class | PushModel
class | RadioModel
class | ResetModel
class | SelectModel
class | SetModel
class | SubmitModel
class | TabbedPanelModel
class | TextAreaModel
class | TextFieldModel
class | TextModel
class | TokenModel
class | TreeModel TreeModel
class | TreeNodeModel TreeNodeModel
class | UpDownSelectModel
class | URLModel
class | WebTableModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.TextAreaModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.TextAreaModel

Packages that use TextAreaModel
org.apache.struts2.views.freemarker.tags

Uses of TextAreaModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as TextAreaModel
protected  TextAreaModel StrutsModels.textarea

Methods in org.apache.struts2.views.freemarker.tags that return TextAreaModel
 TextAreaModel StrutsModels.getTextarea()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.TextFieldModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.TextFieldModel

Packages that use TextFieldModel
org.apache.struts2.views.freemarker.tags

Uses of TextFieldModel in org.apache.struts2.views.freemarker.tags

Subclasses of TextFieldModel in org.apache.struts2.views.freemarker.tags
 class DateTimePickerModel

Fields in org.apache.struts2.views.freemarker.tags declared as TextFieldModel
protected  TextFieldModel StrutsModels.textfield

Methods in org.apache.struts2.views.freemarker.tags that return TextFieldModel
 TextFieldModel StrutsModels.getTextfield()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.TextModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.TextModel

Packages that use TextModel
org.apache.struts2.views.freemarker.tags

Uses of TextModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as TextModel
protected  TextModel StrutsModels.text

Methods in org.apache.struts2.views.freemarker.tags that return TextModel
 TextModel StrutsModels.getText()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.TokenModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.TokenModel

Packages that use TokenModel
org.apache.struts2.views.freemarker.tags

Uses of TokenModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as TokenModel
protected  TokenModel StrutsModels.token

Methods in org.apache.struts2.views.freemarker.tags that return TokenModel
 TokenModel StrutsModels.getToken()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.TreeModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.TreeModel

Packages that use TreeModel
org.apache.struts2.views.freemarker.tags

Uses of TreeModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as TreeModel
protected  TreeModel StrutsModels.treeModel

Methods in org.apache.struts2.views.freemarker.tags that return TreeModel
 TreeModel StrutsModels.getTree()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.TreeNodeModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.TreeNodeModel

Packages that use TreeNodeModel
org.apache.struts2.views.freemarker.tags

Uses of TreeNodeModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as TreeNodeModel
protected  TreeNodeModel StrutsModels.treenodeModel

Methods in org.apache.struts2.views.freemarker.tags that return TreeNodeModel
 TreeNodeModel StrutsModels.getTreenode()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.UpDownSelectModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.UpDownSelectModel

Packages that use UpDownSelectModel
org.apache.struts2.views.freemarker.tags

Uses of UpDownSelectModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as UpDownSelectModel
protected  UpDownSelectModel StrutsModels.updownselect

Methods in org.apache.struts2.views.freemarker.tags that return UpDownSelectModel
 UpDownSelectModel StrutsModels.getUpdownselect()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.URLModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.URLModel

Packages that use URLModel
org.apache.struts2.views.freemarker.tags

Uses of URLModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as URLModel
protected  URLModel StrutsModels.url

Methods in org.apache.struts2.views.freemarker.tags that return URLModel
 URLModel StrutsModels.getUrl()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.freemarker.tags.WebTableModel (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.freemarker.tags.WebTableModel

Packages that use WebTableModel
org.apache.struts2.views.freemarker.tags

Uses of WebTableModel in org.apache.struts2.views.freemarker.tags

Fields in org.apache.struts2.views.freemarker.tags declared as WebTableModel
protected  WebTableModel StrutsModels.table

Methods in org.apache.struts2.views.freemarker.tags that return WebTableModel
 WebTableModel StrutsModels.getTable()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.jsp (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.jsp
Classes
ActionTag
BeanTag
ComponentTagSupport
DateTag
ElseIfTag
ElseTag
I18nTag
IfTag
IncludeTag
IteratorStatus
IteratorStatus.StatusState
IteratorTag
ParamTag
PropertyTag
PushTag
SetTag
StrutsBodyTagSupport
TagUtils
TextTag
URLTag


Uses of Class org.apache.struts2.views.jsp.ActionTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ActionTag

No usage of org.apache.struts2.views.jsp.ActionTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.BeanTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.BeanTag

No usage of org.apache.struts2.views.jsp.BeanTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ComponentTagSupport (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ComponentTagSupport

Packages that use ComponentTagSupport
org.apache.struts2.views.jsp | Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.

Uses of ComponentTagSupport in org.apache.struts2.views.jsp

Subclasses of ComponentTagSupport in org.apache.struts2.views.jsp
class | ActionTag
class | BeanTag
class | DateTag
class | ElseIfTag
class | ElseTag
class | I18nTag
class | IfTag
class | IncludeTag
class | IteratorTag
class | ParamTag
class | PropertyTag
class | PushTag
class | SetTag
class | TextTag
class | URLTag

Uses of ComponentTagSupport in org.apache.struts2.views.jsp.iterator

Subclasses of ComponentTagSupport in org.apache.struts2.views.jsp.iterator
class | AppendIteratorTag Append a list of iterators.
class | MergeIteratorTag Append a list of iterators.

Uses of ComponentTagSupport in org.apache.struts2.views.jsp.ui

Subclasses of ComponentTagSupport in org.apache.struts2.views.jsp.ui
class | AbstractClosingTag
class | AbstractDoubleListTag
class | AbstractListTag
class | AbstractRemoteCallUITag
class | AbstractRequiredListTag
class | AbstractUITag Abstract base class for all UI tags.
class | ActionErrorTag ActionError Tag.
class | ActionMessageTag ActionMessage Tag.
class | AnchorTag
class | AutocompleterTag
class | CheckboxListTag
class | CheckboxTag
class | ComboBoxTag
class | ComponentTag
class | DateTimePickerTag
class | DebugTag
class | DivTag
class | DoubleSelectTag
class | FieldErrorTag FieldError Tag.
class | FileTag
class | FormTag
class | HeadTag
class | HiddenTag
class | InputTransferSelectTag InputTransferSelect jsp tag.
class | LabelTag
class | OptGroupTag
class | OptionTransferSelectTag OptionTransferSelect jsp tag.
class | PasswordTag
class | RadioTag
class | ResetTag
class | SelectTag
class | SubmitTag
class | TabbedPanelTag
class | TextareaTag
class | TextFieldTag
class | TokenTag
class | TreeNodeTag
class | TreeTag
class | UpDownSelectTag

Uses of ComponentTagSupport in org.apache.struts2.views.jsp.ui.table

Subclasses of ComponentTagSupport in org.apache.struts2.views.jsp.ui.table
 class WebTableTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.DateTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.DateTag

No usage of org.apache.struts2.views.jsp.DateTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ElseIfTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ElseIfTag

No usage of org.apache.struts2.views.jsp.ElseIfTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ElseTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ElseTag

No usage of org.apache.struts2.views.jsp.ElseTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.I18nTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.I18nTag

No usage of org.apache.struts2.views.jsp.I18nTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.IfTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.IfTag

No usage of org.apache.struts2.views.jsp.IfTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.IncludeTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.IncludeTag

No usage of org.apache.struts2.views.jsp.IncludeTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.IteratorStatus (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.IteratorStatus

Packages that use IteratorStatus
org.apache.struts2.components

Uses of IteratorStatus in org.apache.struts2.components

Fields in org.apache.struts2.components declared as IteratorStatus
protected  IteratorStatus IteratorComponent.status

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.IteratorStatus.StatusState (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.IteratorStatus.StatusState

Packages that use IteratorStatus.StatusState
org.apache.struts2.components |
org.apache.struts2.views.jsp | Struts's JSP tag library.

Uses of IteratorStatus.StatusState in org.apache.struts2.components

Fields in org.apache.struts2.components declared as IteratorStatus.StatusState
protected  IteratorStatus.StatusState IteratorComponent.statusState

Uses of IteratorStatus.StatusState in org.apache.struts2.views.jsp

Fields in org.apache.struts2.views.jsp declared as IteratorStatus.StatusState
protected  IteratorStatus.StatusState IteratorStatus.state

Constructors in org.apache.struts2.views.jsp with parameters of type IteratorStatus.StatusState
IteratorStatus(IteratorStatus.StatusState aState)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.IteratorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.IteratorTag

No usage of org.apache.struts2.views.jsp.IteratorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ParamTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ParamTag

No usage of org.apache.struts2.views.jsp.ParamTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.PropertyTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.PropertyTag

No usage of org.apache.struts2.views.jsp.PropertyTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.PushTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.PushTag

No usage of org.apache.struts2.views.jsp.PushTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.SetTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.SetTag

No usage of org.apache.struts2.views.jsp.SetTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.StrutsBodyTagSupport (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.StrutsBodyTagSupport

Packages that use StrutsBodyTagSupport
org.apache.struts2.views.jsp | Struts's JSP tag library.
org.apache.struts2.views.jsp.iterator | Struts's JSP tag library for iterator handling.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.

Uses of StrutsBodyTagSupport in org.apache.struts2.views.jsp

Subclasses of StrutsBodyTagSupport in org.apache.struts2.views.jsp
class | ActionTag
class | BeanTag
class | ComponentTagSupport
class | DateTag
class | ElseIfTag
class | ElseTag
class | I18nTag
class | IfTag
class | IncludeTag
class | IteratorTag
class | ParamTag
class | PropertyTag
class | PushTag
class | SetTag
class | TextTag
class | URLTag

Uses of StrutsBodyTagSupport in org.apache.struts2.views.jsp.iterator

Subclasses of StrutsBodyTagSupport in org.apache.struts2.views.jsp.iterator
class | AppendIteratorTag Append a list of iterators.
class | IteratorGeneratorTag NOTE: JSP-TAG
class | MergeIteratorTag Append a list of iterators.
class | SortIteratorTag NOTE: JSP-TAG
class | SubsetIteratorTag NOTE: JSP-TAG

Uses of StrutsBodyTagSupport in org.apache.struts2.views.jsp.ui

Subclasses of StrutsBodyTagSupport in org.apache.struts2.views.jsp.ui
class | AbstractClosingTag
class | AbstractDoubleListTag
class | AbstractListTag
class | AbstractRemoteCallUITag
class | AbstractRequiredListTag
class | AbstractUITag Abstract base class for all UI tags.
class | ActionErrorTag ActionError Tag.
class | ActionMessageTag ActionMessage Tag.
class | AnchorTag
class | AutocompleterTag
class | CheckboxListTag
class | CheckboxTag
class | ComboBoxTag
class | ComponentTag
class | DateTimePickerTag
class | DebugTag
class | DivTag
class | DoubleSelectTag
class | FieldErrorTag FieldError Tag.
class | FileTag
class | FormTag
class | HeadTag
class | HiddenTag
class | InputTransferSelectTag InputTransferSelect jsp tag.
class | LabelTag
class | OptGroupTag
class | OptionTransferSelectTag OptionTransferSelect jsp tag.
class | PasswordTag
class | RadioTag
class | ResetTag
class | SelectTag
class | SubmitTag
class | TabbedPanelTag
class | TextareaTag
class | TextFieldTag
class | TokenTag
class | TreeNodeTag
class | TreeTag
class | UpDownSelectTag

Uses of StrutsBodyTagSupport in org.apache.struts2.views.jsp.ui.table

Subclasses of StrutsBodyTagSupport in org.apache.struts2.views.jsp.ui.table
 class WebTableTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.TagUtils (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.TagUtils

No usage of org.apache.struts2.views.jsp.TagUtils

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.TextTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.TextTag

No usage of org.apache.struts2.views.jsp.TextTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.URLTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.URLTag

No usage of org.apache.struts2.views.jsp.URLTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.jsp.iterator (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.jsp.iterator
Classes
AppendIteratorTag
IteratorGeneratorTag
MergeIteratorTag
SortIteratorTag
SubsetIteratorTag


Uses of Class org.apache.struts2.views.jsp.iterator.AppendIteratorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.iterator.AppendIteratorTag

No usage of org.apache.struts2.views.jsp.iterator.AppendIteratorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

No usage of org.apache.struts2.views.jsp.iterator.IteratorGeneratorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.iterator.MergeIteratorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.iterator.MergeIteratorTag

No usage of org.apache.struts2.views.jsp.iterator.MergeIteratorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.iterator.SortIteratorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.iterator.SortIteratorTag

No usage of org.apache.struts2.views.jsp.iterator.SortIteratorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.iterator.SubsetIteratorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

No usage of org.apache.struts2.views.jsp.iterator.SubsetIteratorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.jsp.ui (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.jsp.ui
Classes
AbstractClosingTag
AbstractDoubleListTag
AbstractListTag
AbstractRemoteCallUITag
AbstractRequiredListTag
AbstractUITag
ActionErrorTag
ActionMessageTag
AnchorTag
AutocompleterTag
CheckboxListTag
CheckboxTag
ComboBoxTag
ComponentTag
DateTimePickerTag
DebugTag
DivTag
DoubleSelectTag
FieldErrorTag
FileTag
FormTag
HeadTag
HiddenTag
InputTransferSelectTag
LabelTag
OgnlTool
OptGroupTag
OptionTransferSelectTag
PasswordTag
RadioTag
ResetTag
SelectTag
SubmitTag
TabbedPanelTag
TextareaTag
TextFieldTag
TokenTag
TreeNodeTag
TreeTag
UpDownSelectTag


Uses of Class org.apache.struts2.views.jsp.ui.AbstractClosingTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.AbstractClosingTag

Packages that use AbstractClosingTag
org.apache.struts2.views.jsp.ui Struts' JSP UI tags.

Uses of AbstractClosingTag in org.apache.struts2.views.jsp.ui

Subclasses of AbstractClosingTag in org.apache.struts2.views.jsp.ui
class | AbstractRemoteCallUITag
class | AnchorTag
class | DivTag
class | FormTag
class | TabbedPanelTag
class | TreeNodeTag
class | TreeTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.AbstractDoubleListTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.AbstractDoubleListTag

Packages that use AbstractDoubleListTag
org.apache.struts2.views.jsp.ui Struts' JSP UI tags.

Uses of AbstractDoubleListTag in org.apache.struts2.views.jsp.ui

Subclasses of AbstractDoubleListTag in org.apache.struts2.views.jsp.ui
class | DoubleSelectTag
class | OptionTransferSelectTag OptionTransferSelect jsp tag.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.AbstractListTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.AbstractListTag

Packages that use AbstractListTag
org.apache.struts2.views.jsp.ui Struts' JSP UI tags.

Uses of AbstractListTag in org.apache.struts2.views.jsp.ui

Subclasses of AbstractListTag in org.apache.struts2.views.jsp.ui
class | AbstractDoubleListTag
class | AbstractRequiredListTag
class | CheckboxListTag
class | DoubleSelectTag
class | InputTransferSelectTag InputTransferSelect jsp tag.
class | OptionTransferSelectTag OptionTransferSelect jsp tag.
class | RadioTag
class | SelectTag
class | UpDownSelectTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.AbstractRemoteCallUITag

Packages that use AbstractRemoteCallUITag
org.apache.struts2.views.jsp.ui Struts' JSP UI tags.

Uses of AbstractRemoteCallUITag in org.apache.struts2.views.jsp.ui

Subclasses of AbstractRemoteCallUITag in org.apache.struts2.views.jsp.ui
class | AnchorTag
class | DivTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.AbstractRequiredListTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.AbstractRequiredListTag

Packages that use AbstractRequiredListTag
org.apache.struts2.views.jsp.ui Struts' JSP UI tags.

Uses of AbstractRequiredListTag in org.apache.struts2.views.jsp.ui

Subclasses of AbstractRequiredListTag in org.apache.struts2.views.jsp.ui
class | AbstractDoubleListTag
class | CheckboxListTag
class | DoubleSelectTag
class | OptionTransferSelectTag OptionTransferSelect jsp tag.
class | RadioTag
class | SelectTag
class | UpDownSelectTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.AbstractUITag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.AbstractUITag

Packages that use AbstractUITag
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.
org.apache.struts2.views.jsp.ui.table | JSP UI tags for modeling tables.

Uses of AbstractUITag in org.apache.struts2.views.jsp.ui

Subclasses of AbstractUITag in org.apache.struts2.views.jsp.ui
class | AbstractClosingTag
class | AbstractDoubleListTag
class | AbstractListTag
class | AbstractRemoteCallUITag
class | AbstractRequiredListTag
class | ActionErrorTag ActionError Tag.
class | ActionMessageTag ActionMessage Tag.
class | AnchorTag
class | AutocompleterTag
class | CheckboxListTag
class | CheckboxTag
class | ComboBoxTag
class | ComponentTag
class | DateTimePickerTag
class | DebugTag
class | DivTag
class | DoubleSelectTag
class | FieldErrorTag FieldError Tag.
class | FileTag
class | FormTag
class | HeadTag
class | HiddenTag
class | InputTransferSelectTag InputTransferSelect jsp tag.
class | LabelTag
class | OptionTransferSelectTag OptionTransferSelect jsp tag.
class | PasswordTag
class | RadioTag
class | ResetTag
class | SelectTag
class | SubmitTag
class | TabbedPanelTag
class | TextareaTag
class | TextFieldTag
class | TokenTag
class | TreeNodeTag
class | TreeTag
class | UpDownSelectTag

Uses of AbstractUITag in org.apache.struts2.views.jsp.ui.table

Subclasses of AbstractUITag in org.apache.struts2.views.jsp.ui.table
 class WebTableTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.ActionErrorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.ActionErrorTag

No usage of org.apache.struts2.views.jsp.ui.ActionErrorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.ActionMessageTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.ActionMessageTag

No usage of org.apache.struts2.views.jsp.ui.ActionMessageTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.AnchorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.AnchorTag

No usage of org.apache.struts2.views.jsp.ui.AnchorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.AutocompleterTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.AutocompleterTag

No usage of org.apache.struts2.views.jsp.ui.AutocompleterTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.CheckboxListTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.CheckboxListTag

No usage of org.apache.struts2.views.jsp.ui.CheckboxListTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.CheckboxTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.CheckboxTag

No usage of org.apache.struts2.views.jsp.ui.CheckboxTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.ComboBoxTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.ComboBoxTag

Packages that use ComboBoxTag
org.apache.struts2.views.jsp.ui Struts' JSP UI tags.

Uses of ComboBoxTag in org.apache.struts2.views.jsp.ui

Subclasses of ComboBoxTag in org.apache.struts2.views.jsp.ui
 class AutocompleterTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.ComponentTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.ComponentTag

Packages that use ComponentTag
org.apache.struts2.views.jsp.ui.table JSP UI tags for modeling tables.

Uses of ComponentTag in org.apache.struts2.views.jsp.ui.table

Subclasses of ComponentTag in org.apache.struts2.views.jsp.ui.table
 class WebTableTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.DateTimePickerTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.DateTimePickerTag

No usage of org.apache.struts2.views.jsp.ui.DateTimePickerTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.DebugTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.DebugTag

No usage of org.apache.struts2.views.jsp.ui.DebugTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.DivTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.DivTag

No usage of org.apache.struts2.views.jsp.ui.DivTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.DoubleSelectTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.DoubleSelectTag

No usage of org.apache.struts2.views.jsp.ui.DoubleSelectTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.FieldErrorTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.FieldErrorTag

No usage of org.apache.struts2.views.jsp.ui.FieldErrorTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.FileTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.FileTag

No usage of org.apache.struts2.views.jsp.ui.FileTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.FormTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.FormTag

No usage of org.apache.struts2.views.jsp.ui.FormTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.HeadTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.HeadTag

No usage of org.apache.struts2.views.jsp.ui.HeadTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.HiddenTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.HiddenTag

No usage of org.apache.struts2.views.jsp.ui.HiddenTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.InputTransferSelectTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.InputTransferSelectTag

No usage of org.apache.struts2.views.jsp.ui.InputTransferSelectTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.LabelTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.LabelTag

No usage of org.apache.struts2.views.jsp.ui.LabelTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.OgnlTool (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.OgnlTool

Packages that use OgnlTool
org.apache.struts2.util | Miscellaneous helper classes.
org.apache.struts2.views.jsp.ui | Struts' JSP UI tags.

Uses of OgnlTool in org.apache.struts2.util

Fields in org.apache.struts2.util declared as OgnlTool
protected  OgnlTool StrutsUtil.ognl

Uses of OgnlTool in org.apache.struts2.views.jsp.ui

Fields in org.apache.struts2.views.jsp.ui declared as OgnlTool
private static OgnlTool OgnlTool.instance

Methods in org.apache.struts2.views.jsp.ui that return OgnlTool
static OgnlTool OgnlTool.getInstance()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.OptGroupTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.OptGroupTag

No usage of org.apache.struts2.views.jsp.ui.OptGroupTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.OptionTransferSelectTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

No usage of org.apache.struts2.views.jsp.ui.OptionTransferSelectTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.PasswordTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.PasswordTag

No usage of org.apache.struts2.views.jsp.ui.PasswordTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.RadioTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.RadioTag

No usage of org.apache.struts2.views.jsp.ui.RadioTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.ResetTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.ResetTag

No usage of org.apache.struts2.views.jsp.ui.ResetTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.SelectTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.SelectTag

Packages that use SelectTag
org.apache.struts2.views.jsp.ui Struts' JSP UI tags.

Uses of SelectTag in org.apache.struts2.views.jsp.ui

Subclasses of SelectTag in org.apache.struts2.views.jsp.ui
 class UpDownSelectTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.SubmitTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.SubmitTag

No usage of org.apache.struts2.views.jsp.ui.SubmitTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.TabbedPanelTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.TabbedPanelTag

No usage of org.apache.struts2.views.jsp.ui.TabbedPanelTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.TextareaTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.TextareaTag

No usage of org.apache.struts2.views.jsp.ui.TextareaTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.TextFieldTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.TextFieldTag

Packages that use TextFieldTag
org.apache.struts2.views.jsp.ui Struts' JSP UI tags.

Uses of TextFieldTag in org.apache.struts2.views.jsp.ui

Subclasses of TextFieldTag in org.apache.struts2.views.jsp.ui
class | AutocompleterTag
class | ComboBoxTag
class | PasswordTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.TokenTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.TokenTag

No usage of org.apache.struts2.views.jsp.ui.TokenTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.TreeNodeTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.TreeNodeTag

No usage of org.apache.struts2.views.jsp.ui.TreeNodeTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.TreeTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.TreeTag

No usage of org.apache.struts2.views.jsp.ui.TreeTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.jsp.ui.UpDownSelectTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.UpDownSelectTag

No usage of org.apache.struts2.views.jsp.ui.UpDownSelectTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.jsp.ui.table (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.jsp.ui.table
Classes
WebTableTag


Uses of Class org.apache.struts2.views.jsp.ui.table.WebTableTag (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.jsp.ui.table.WebTableTag

No usage of org.apache.struts2.views.jsp.ui.table.WebTableTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.util (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.util
Classes
ContextUtil
ResourceUtil
TextUtil
UrlHelper


Uses of Class org.apache.struts2.views.util.ContextUtil (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.util.ContextUtil

No usage of org.apache.struts2.views.util.ContextUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.util.ResourceUtil (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.util.ResourceUtil

No usage of org.apache.struts2.views.util.ResourceUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.util.TextUtil (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.util.TextUtil

No usage of org.apache.struts2.views.util.TextUtil

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.util.UrlHelper (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.util.UrlHelper

No usage of org.apache.struts2.views.util.UrlHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.velocity (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.velocity
Classes
StrutsResourceLoader
StrutsVelocityContext
VelocityManager


Uses of Class org.apache.struts2.views.velocity.StrutsResourceLoader (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.StrutsResourceLoader

No usage of org.apache.struts2.views.velocity.StrutsResourceLoader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.StrutsVelocityContext (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.StrutsVelocityContext

No usage of org.apache.struts2.views.velocity.StrutsVelocityContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.VelocityManager (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.VelocityManager

Packages that use VelocityManager
org.apache.struts2.components.template |
org.apache.struts2.dispatcher | Classes for action dispatching in Struts (the Controller part of MVC).
org.apache.struts2.portlet.result |

Uses of VelocityManager in org.apache.struts2.components.template

Fields in org.apache.struts2.components.template declared as VelocityManager
private  VelocityManager VelocityTemplateEngine.velocityManager

Methods in org.apache.struts2.components.template with parameters of type VelocityManager
 void VelocityTemplateEngine.setVelocityManager(VelocityManager mgr)

Uses of VelocityManager in org.apache.struts2.dispatcher

Fields in org.apache.struts2.dispatcher declared as VelocityManager
private  VelocityManager VelocityResult.velocityManager

Methods in org.apache.struts2.dispatcher with parameters of type VelocityManager
protected org.apache.velocity.context.Context | VelocityResult.createContext(VelocityManager velocityManager, ValueStack stack, HttpServletRequest request, HttpServletResponse response, String location) Creates the VelocityContext that we'll use to render this page.
void | VelocityResult.setVelocityManager(VelocityManager mgr)

Uses of VelocityManager in org.apache.struts2.portlet.result

Fields in org.apache.struts2.portlet.result declared as VelocityManager
private  VelocityManager PortletVelocityResult.velocityManager

Methods in org.apache.struts2.portlet.result with parameters of type VelocityManager
protected org.apache.velocity.context.Context | PortletVelocityResult.createContext(VelocityManager velocityManager, ValueStack stack, HttpServletRequest request, HttpServletResponse response, String location) Creates the VelocityContext that we'll use to render this page.
void | PortletVelocityResult.setVelocityManager(VelocityManager mgr)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.velocity.components (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.velocity.components
Classes
AbstractDirective
ActionDirective
ActionErrorDirective
ActionMessageDirective
AnchorDirective
AutocompleterDirective
BeanDirective
CheckBoxDirective
CheckBoxListDirective
ComboBoxDirective
ComponentDirective
DateDirective
DateTimePickerDirective
DivDirective
DoubleSelectDirective
FieldErrorDirective
FileDirective
FormDirective
HeadDirective
HiddenDirective
I18nDirective
IncludeDirective
InputTransferSelectDirective
LabelDirective
OptGroupDirective
OptionTransferSelectDirective
ParamDirective
PasswordDirective
PropertyDirective
PushDirective
RadioDirective
ResetDirective
SelectDirective
SetDirective
SubmitDirective
TabbedPanelDirective
TextAreaDirective
TextDirective
TextFieldDirective
TokenDirective
TreeDirective
TreeNodeDirective
UpDownSelectDirective
URLDirective
WebTableDirective


Uses of Class org.apache.struts2.views.velocity.components.AbstractDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.AbstractDirective

Packages that use AbstractDirective
org.apache.struts2.views.velocity.components

Uses of AbstractDirective in org.apache.struts2.views.velocity.components

Subclasses of AbstractDirective in org.apache.struts2.views.velocity.components
class | ActionDirective
class | ActionErrorDirective
class | ActionMessageDirective
class | AnchorDirective
class | AutocompleterDirective
class | BeanDirective
class | CheckBoxDirective
class | CheckBoxListDirective
class | ComboBoxDirective
class | ComponentDirective
class | DateDirective DateDirective
class | DateTimePickerDirective
class | DivDirective
class | DoubleSelectDirective
class | FieldErrorDirective
class | FileDirective
class | FormDirective
class | HeadDirective
class | HiddenDirective
class | I18nDirective
class | IncludeDirective
class | InputTransferSelectDirective
class | LabelDirective
class | OptGroupDirective OptGroup velocity directive.
class | OptionTransferSelectDirective
class | ParamDirective
class | PasswordDirective
class | PropertyDirective
class | PushDirective
class | RadioDirective
class | ResetDirective
class | SelectDirective
class | SetDirective
class | SubmitDirective
class | TabbedPanelDirective
class | TextAreaDirective
class | TextDirective
class | TextFieldDirective
class | TokenDirective
class | TreeDirective TreeDirective
class | TreeNodeDirective TreeNodeDirective
class | UpDownSelectDirective
class | URLDirective
class | WebTableDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.ActionDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.ActionDirective

No usage of org.apache.struts2.views.velocity.components.ActionDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.ActionErrorDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.ActionErrorDirective

No usage of org.apache.struts2.views.velocity.components.ActionErrorDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.ActionMessageDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.ActionMessageDirective

No usage of org.apache.struts2.views.velocity.components.ActionMessageDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.AnchorDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.AnchorDirective

No usage of org.apache.struts2.views.velocity.components.AnchorDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.AutocompleterDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.AutocompleterDirective

No usage of org.apache.struts2.views.velocity.components.AutocompleterDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.BeanDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.BeanDirective

No usage of org.apache.struts2.views.velocity.components.BeanDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.CheckBoxDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.CheckBoxDirective

No usage of org.apache.struts2.views.velocity.components.CheckBoxDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.CheckBoxListDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.CheckBoxListDirective

No usage of org.apache.struts2.views.velocity.components.CheckBoxListDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.ComboBoxDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.ComboBoxDirective

No usage of org.apache.struts2.views.velocity.components.ComboBoxDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.ComponentDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.ComponentDirective

No usage of org.apache.struts2.views.velocity.components.ComponentDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.DateDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.DateDirective

No usage of org.apache.struts2.views.velocity.components.DateDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.DateTimePickerDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.DateTimePickerDirective

No usage of org.apache.struts2.views.velocity.components.DateTimePickerDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.DivDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.DivDirective

No usage of org.apache.struts2.views.velocity.components.DivDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.DoubleSelectDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.DoubleSelectDirective

No usage of org.apache.struts2.views.velocity.components.DoubleSelectDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.FieldErrorDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.FieldErrorDirective

No usage of org.apache.struts2.views.velocity.components.FieldErrorDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.FileDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.FileDirective

No usage of org.apache.struts2.views.velocity.components.FileDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.FormDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.FormDirective

No usage of org.apache.struts2.views.velocity.components.FormDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.HeadDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.HeadDirective

No usage of org.apache.struts2.views.velocity.components.HeadDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.HiddenDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.HiddenDirective

No usage of org.apache.struts2.views.velocity.components.HiddenDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.I18nDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.I18nDirective

No usage of org.apache.struts2.views.velocity.components.I18nDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.IncludeDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.IncludeDirective

No usage of org.apache.struts2.views.velocity.components.IncludeDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.InputTransferSelectDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.InputTransferSelectDirective

No usage of org.apache.struts2.views.velocity.components.InputTransferSelectDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.LabelDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.LabelDirective

No usage of org.apache.struts2.views.velocity.components.LabelDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.OptGroupDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.OptGroupDirective

No usage of org.apache.struts2.views.velocity.components.OptGroupDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.OptionTransferSelectDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.OptionTransferSelectDirective

No usage of org.apache.struts2.views.velocity.components.OptionTransferSelectDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.ParamDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.ParamDirective

No usage of org.apache.struts2.views.velocity.components.ParamDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.PasswordDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.PasswordDirective

No usage of org.apache.struts2.views.velocity.components.PasswordDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.PropertyDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.PropertyDirective

No usage of org.apache.struts2.views.velocity.components.PropertyDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.PushDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.PushDirective

No usage of org.apache.struts2.views.velocity.components.PushDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.RadioDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.RadioDirective

No usage of org.apache.struts2.views.velocity.components.RadioDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.ResetDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.ResetDirective

No usage of org.apache.struts2.views.velocity.components.ResetDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.SelectDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.SelectDirective

No usage of org.apache.struts2.views.velocity.components.SelectDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.SetDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.SetDirective

No usage of org.apache.struts2.views.velocity.components.SetDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.SubmitDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.SubmitDirective

No usage of org.apache.struts2.views.velocity.components.SubmitDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.TabbedPanelDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.TabbedPanelDirective

No usage of org.apache.struts2.views.velocity.components.TabbedPanelDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.TextAreaDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.TextAreaDirective

No usage of org.apache.struts2.views.velocity.components.TextAreaDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.TextDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.TextDirective

No usage of org.apache.struts2.views.velocity.components.TextDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.TextFieldDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.TextFieldDirective

Packages that use TextFieldDirective
org.apache.struts2.views.velocity.components

Uses of TextFieldDirective in org.apache.struts2.views.velocity.components

Subclasses of TextFieldDirective in org.apache.struts2.views.velocity.components
 class DateTimePickerDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.TokenDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.TokenDirective

No usage of org.apache.struts2.views.velocity.components.TokenDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.TreeDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.TreeDirective

No usage of org.apache.struts2.views.velocity.components.TreeDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.TreeNodeDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.TreeNodeDirective

No usage of org.apache.struts2.views.velocity.components.TreeNodeDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.UpDownSelectDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.UpDownSelectDirective

No usage of org.apache.struts2.views.velocity.components.UpDownSelectDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.URLDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.URLDirective

No usage of org.apache.struts2.views.velocity.components.URLDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.velocity.components.WebTableDirective (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.velocity.components.WebTableDirective

No usage of org.apache.struts2.views.velocity.components.WebTableDirective

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.apache.struts2.views.xslt (Struts 2 Core 2.0.6 API)

 org.apache.struts2.views.xslt
Interfaces
AdapterNode
Classes
AbstractAdapterElement
AbstractAdapterNode
AdapterFactory
ArrayAdapter
BeanAdapter
CollectionAdapter
MapAdapter
ProxyAttrAdapter
ProxyElementAdapter
ProxyNamedNodeMap
ProxyNodeAdapter
ProxyTextNodeAdapter
ServletURIResolver
SimpleAdapterDocument
SimpleNodeList
SimpleTextNode
StringAdapter
XSLTResult


Uses of Class org.apache.struts2.views.xslt.AbstractAdapterElement (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.AbstractAdapterElement

Packages that use AbstractAdapterElement
org.apache.struts2.views.xslt The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of AbstractAdapterElement in org.apache.struts2.views.xslt

Subclasses of AbstractAdapterElement in org.apache.struts2.views.xslt
class | ArrayAdapter
class | BeanAdapter This class is the most general type of adapter, utilizing reflective introspection to present a DOM view of all of the public properties of its value.
class | CollectionAdapter
class | MapAdapter MapAdapter adapters a java.util.Map type to an XML DOM with the following structure:
(package private) class | MapAdapter.EntryElement
class | StringAdapter StringAdapter adapts a Java String value to a DOM Element with the specified property name containing the String's text.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.AbstractAdapterNode (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.AbstractAdapterNode

Packages that use AbstractAdapterNode
org.apache.struts2.views.xslt The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of AbstractAdapterNode in org.apache.struts2.views.xslt

Subclasses of AbstractAdapterNode in org.apache.struts2.views.xslt
class | AbstractAdapterElement AbstractAdapterElement extends the abstract Node type and implements the DOM Element interface.
class | ArrayAdapter
class | BeanAdapter This class is the most general type of adapter, utilizing reflective introspection to present a DOM view of all of the public properties of its value.
class | CollectionAdapter
class | MapAdapter MapAdapter adapters a java.util.Map type to an XML DOM with the following structure:
(package private) class | MapAdapter.EntryElement
class | ProxyAttrAdapter ProxyAttrAdapter is a pass-through adapter for objects which already implement the Attr interface.
class | ProxyElementAdapter ProxyElementAdapter is a pass-through adapter for objects which already implement the Element interface.
class | ProxyNodeAdapter ProxyNodeAdapter is a read-only delegating adapter for objects which already implement the Node interface.
class | ProxyTextNodeAdapter ProxyTextNodeAdapter is a pass-through adapter for objects which already implement the Text interface.
class | SimpleAdapterDocument SimpleAdapterDocument adapted a Java object and presents it as a Document.
class | SimpleTextNode
class | StringAdapter StringAdapter adapts a Java String value to a DOM Element with the specified property name containing the String's text.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.AdapterFactory (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.AdapterFactory

Packages that use AdapterFactory
org.apache.struts2.views.xslt The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of AdapterFactory in org.apache.struts2.views.xslt

Fields in org.apache.struts2.views.xslt declared as AdapterFactory
private AdapterFactory | XSLTResult.adapterFactory
private AdapterFactory | ProxyNamedNodeMap.adapterFactory
private AdapterFactory | AbstractAdapterNode.adapterFactory

Methods in org.apache.struts2.views.xslt that return AdapterFactory
protected AdapterFactory | XSLTResult.getAdapterFactory()
AdapterFactory | AdapterNode.getAdapterFactory() The adapter factory that created this node.
AdapterFactory | AbstractAdapterNode.getAdapterFactory()

Methods in org.apache.struts2.views.xslt with parameters of type AdapterFactory
protected void | XSLTResult.setAdapterFactory(AdapterFactory adapterFactory)
void | AdapterNode.setAdapterFactory(AdapterFactory factory) The adapter factory that created this node.
void | AbstractAdapterNode.setAdapterFactory(AdapterFactory adapterFactory)
protected void | AbstractAdapterNode.setContext(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)

Constructors in org.apache.struts2.views.xslt with parameters of type AdapterFactory
ArrayAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
BeanAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
CollectionAdapter(AdapterFactory rootAdapterFactory, AdapterNode parent, String propertyName, Object value)
MapAdapter.EntryElement(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object key, Object value)
MapAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Map value)
ProxyAttrAdapter(AdapterFactory factory, AdapterNode parent, Attr value)
ProxyElementAdapter(AdapterFactory factory, AdapterNode parent, Element value)
ProxyNamedNodeMap(AdapterFactory factory, AdapterNode parent, NamedNodeMap nodes)
ProxyNodeAdapter(AdapterFactory factory, AdapterNode parent, Node value)
ProxyTextNodeAdapter(AdapterFactory factory, AdapterNode parent, Text value)
SimpleAdapterDocument(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
SimpleTextNode(AdapterFactory rootAdapterFactory, AdapterNode parent, String propertyName, Object value)
StringAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, String value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.apache.struts2.views.xslt.AdapterNode (Struts 2 Core 2.0.6 API)

Uses of Interface
org.apache.struts2.views.xslt.AdapterNode

Packages that use AdapterNode
org.apache.struts2.views.xslt The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of AdapterNode in org.apache.struts2.views.xslt

Classes in org.apache.struts2.views.xslt that implement AdapterNode
class | AbstractAdapterElement AbstractAdapterElement extends the abstract Node type and implements the DOM Element interface.
class | AbstractAdapterNode AbstractAdapterNode is the base for childAdapters that expose a read-only view of a Java object as a DOM Node.
class | ArrayAdapter
class | BeanAdapter This class is the most general type of adapter, utilizing reflective introspection to present a DOM view of all of the public properties of its value.
class | CollectionAdapter
class | MapAdapter MapAdapter adapters a java.util.Map type to an XML DOM with the following structure:
(package private) class | MapAdapter.EntryElement
class | ProxyAttrAdapter ProxyAttrAdapter is a pass-through adapter for objects which already implement the Attr interface.
class | ProxyElementAdapter ProxyElementAdapter is a pass-through adapter for objects which already implement the Element interface.
class | ProxyNodeAdapter ProxyNodeAdapter is a read-only delegating adapter for objects which already implement the Node interface.
class | ProxyTextNodeAdapter ProxyTextNodeAdapter is a pass-through adapter for objects which already implement the Text interface.
class | SimpleAdapterDocument SimpleAdapterDocument adapted a Java object and presents it as a Document.
class | SimpleTextNode
class | StringAdapter StringAdapter adapts a Java String value to a DOM Element with the specified property name containing the String's text.

Fields in org.apache.struts2.views.xslt declared as AdapterNode
private AdapterNode | ProxyNamedNodeMap.parent
private AdapterNode | AbstractAdapterNode.parent

Methods in org.apache.struts2.views.xslt that return AdapterNode
AdapterNode | AdapterNode.getParent() The parent adapter node of this node.
AdapterNode | AbstractAdapterNode.getParent()

Methods in org.apache.struts2.views.xslt with parameters of type AdapterNode
Node | AdapterFactory.adaptNode(AdapterNode parent, String propertyName, Object value) Create an Node adapter for a child element.
private Node | AdapterFactory.constructAdapterInstance(Class adapterClass, AdapterNode parent, String propertyName, Object propertyValue) Create an instance of an adapter dynamically and set its context via the AdapterNode interface.
NamedNodeMap | AdapterFactory.proxyNamedNodeMap(AdapterNode parent, NamedNodeMap nnm)
Node | AdapterFactory.proxyNode(AdapterNode parent, Node node) Construct a proxy adapter for a value that is an existing DOM Node.
protected void | AbstractAdapterNode.setContext(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
void | AdapterNode.setParent(AdapterNode parent) The parent adapter node of this node.
void | AbstractAdapterNode.setParent(AdapterNode parent)

Constructors in org.apache.struts2.views.xslt with parameters of type AdapterNode
ArrayAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
BeanAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
CollectionAdapter(AdapterFactory rootAdapterFactory, AdapterNode parent, String propertyName, Object value)
MapAdapter.EntryElement(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object key, Object value)
MapAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Map value)
ProxyAttrAdapter(AdapterFactory factory, AdapterNode parent, Attr value)
ProxyElementAdapter(AdapterFactory factory, AdapterNode parent, Element value)
ProxyNamedNodeMap(AdapterFactory factory, AdapterNode parent, NamedNodeMap nodes)
ProxyNodeAdapter(AdapterFactory factory, AdapterNode parent, Node value)
ProxyTextNodeAdapter(AdapterFactory factory, AdapterNode parent, Text value)
SimpleAdapterDocument(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, Object value)
SimpleTextNode(AdapterFactory rootAdapterFactory, AdapterNode parent, String propertyName, Object value)
StringAdapter(AdapterFactory adapterFactory, AdapterNode parent, String propertyName, String value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.ArrayAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.ArrayAdapter

No usage of org.apache.struts2.views.xslt.ArrayAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.BeanAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.BeanAdapter

Packages that use BeanAdapter
org.apache.struts2.views.xslt The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of BeanAdapter in org.apache.struts2.views.xslt

Methods in org.apache.struts2.views.xslt with parameters of type BeanAdapter
 Node AdapterFactory.adaptNullValue(BeanAdapter parent, String propertyName)
Create an appropriate adapter for a null value.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.CollectionAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.CollectionAdapter

No usage of org.apache.struts2.views.xslt.CollectionAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.MapAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.MapAdapter

No usage of org.apache.struts2.views.xslt.MapAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.MapAdapter.EntryElement (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.MapAdapter.EntryElement

No usage of org.apache.struts2.views.xslt.MapAdapter.EntryElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.ProxyAttrAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.ProxyAttrAdapter

No usage of org.apache.struts2.views.xslt.ProxyAttrAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.ProxyElementAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.ProxyElementAdapter

No usage of org.apache.struts2.views.xslt.ProxyElementAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.ProxyNamedNodeMap (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.ProxyNamedNodeMap

No usage of org.apache.struts2.views.xslt.ProxyNamedNodeMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.ProxyNodeAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.ProxyNodeAdapter

Packages that use ProxyNodeAdapter
org.apache.struts2.views.xslt The new xslt view supports an extensible Java XML adapter framework that makes it easy to customize the XML rendering of objects and to incorporate structured XML text and arbitarary DOM fragments into the output.

Uses of ProxyNodeAdapter in org.apache.struts2.views.xslt

Subclasses of ProxyNodeAdapter in org.apache.struts2.views.xslt
class | ProxyAttrAdapter ProxyAttrAdapter is a pass-through adapter for objects which already implement the Attr interface.
class | ProxyElementAdapter ProxyElementAdapter is a pass-through adapter for objects which already implement the Element interface.
class | ProxyTextNodeAdapter ProxyTextNodeAdapter is a pass-through adapter for objects which already implement the Text interface.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.ProxyTextNodeAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.ProxyTextNodeAdapter

No usage of org.apache.struts2.views.xslt.ProxyTextNodeAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.ServletURIResolver (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.ServletURIResolver

No usage of org.apache.struts2.views.xslt.ServletURIResolver

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.SimpleAdapterDocument (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.SimpleAdapterDocument

No usage of org.apache.struts2.views.xslt.SimpleAdapterDocument

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.SimpleNodeList (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.SimpleNodeList

No usage of org.apache.struts2.views.xslt.SimpleNodeList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.SimpleTextNode (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.SimpleTextNode

No usage of org.apache.struts2.views.xslt.SimpleTextNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.StringAdapter (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.StringAdapter

No usage of org.apache.struts2.views.xslt.StringAdapter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.apache.struts2.views.xslt.XSLTResult (Struts 2 Core 2.0.6 API)

Uses of Class
org.apache.struts2.views.xslt.XSLTResult

No usage of org.apache.struts2.views.xslt.XSLTResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES