About Jd2chm...

The project files of this HTML Help
Were generated with Jd2chm version 0.3
Copyright © 2000-2003 Andre Burgaud
http://www.burgaud.com


Overview (dom4j 1.6.1 API)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES

dom4j 1.6.1 API

Core Developer API
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.

Utility classes
org.dom4j.util A collection of utility classes for the dom4j API.

XRule engine for declarative XSLT style processing
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.rule.pattern |

Alternative dom4j implementations
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.

Swing helper classes
org.dom4j.swing A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.

Implementation classes
org.dom4j.dtd | Classes to represent the DTD declarations.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.xpath | Provides the core tools needed to use the XPath library
org.dom4j.xpp | Provides implementation classes to cleanly integrate dom4j with the XML Pull Parser XPP

Other Packages
org.dom4j.jaxb

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES
Copyright © 2001-2005 MetaStuff Ltd.. All Rights Reserved.


Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For All Packages

Package Hierarchies:
org.dom4j, org.dom4j.bean, org.dom4j.datatype, org.dom4j.dom, org.dom4j.dtd, org.dom4j.io, org.dom4j.jaxb, org.dom4j.rule, org.dom4j.rule.pattern, org.dom4j.swing, org.dom4j.tree, org.dom4j.util, org.dom4j.xpath, org.dom4j.xpp

Class Hierarchy

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class org.dom4j.tree.BackedList
        • class org.dom4j.bean.BeanAttributeList
        • class org.dom4j.tree.ContentListFacade
    • class org.dom4j.tree.AbstractNode (implements java.lang.Cloneable, org.dom4j.Node, java.io.Serializable)
      • class org.dom4j.tree.AbstractAttribute (implements org.dom4j.Attribute)
        • class org.dom4j.bean.BeanAttribute
        • class org.dom4j.datatype.DatatypeAttribute (implements com.sun.msv.datatype.SerializationContext, org.relaxng.datatype.ValidationContext)
        • class org.dom4j.tree.FlyweightAttribute
          • class org.dom4j.tree.DefaultAttribute
            • class org.dom4j.dom.DOMAttribute (implements org.w3c.dom.Attr)
            • class org.dom4j.util.UserDataAttribute
      • class org.dom4j.tree.AbstractBranch (implements org.dom4j.Branch)
        • class org.dom4j.tree.AbstractDocument (implements org.dom4j.Document)
          • class org.dom4j.tree.DefaultDocument
            • class org.dom4j.dom.DOMDocument (implements org.w3c.dom.Document)
        • class org.dom4j.tree.AbstractElement (implements org.dom4j.Element)
          • class org.dom4j.tree.BaseElement
            • class org.dom4j.util.NonLazyElement
          • class org.dom4j.tree.DefaultElement
            • class org.dom4j.bean.BeanElement
            • class org.dom4j.datatype.DatatypeElement (implements com.sun.msv.datatype.SerializationContext, org.relaxng.datatype.ValidationContext)
            • class org.dom4j.dom.DOMElement (implements org.w3c.dom.Element)
            • class org.dom4j.util.IndexedElement
            • class org.dom4j.util.UserDataElement
      • class org.dom4j.tree.AbstractCharacterData (implements org.dom4j.CharacterData)
        • class org.dom4j.tree.AbstractCDATA (implements org.dom4j.CDATA)
          • class org.dom4j.tree.FlyweightCDATA (implements org.dom4j.CDATA)
            • class org.dom4j.tree.DefaultCDATA
              • class org.dom4j.dom.DOMCDATA (implements org.w3c.dom.CDATASection)
        • class org.dom4j.tree.AbstractComment (implements org.dom4j.Comment)
          • class org.dom4j.tree.FlyweightComment (implements org.dom4j.Comment)
            • class org.dom4j.tree.DefaultComment
              • class org.dom4j.dom.DOMComment (implements org.w3c.dom.Comment)
        • class org.dom4j.tree.AbstractText (implements org.dom4j.Text)
          • class org.dom4j.tree.FlyweightText (implements org.dom4j.Text)
            • class org.dom4j.tree.DefaultText
              • class org.dom4j.dom.DOMText (implements org.w3c.dom.Text)
      • class org.dom4j.tree.AbstractDocumentType (implements org.dom4j.DocumentType)
        • class org.dom4j.tree.DefaultDocumentType
          • class org.dom4j.dom.DOMDocumentType (implements org.w3c.dom.DocumentType)
      • class org.dom4j.tree.AbstractEntity (implements org.dom4j.Entity)
        • class org.dom4j.tree.FlyweightEntity
          • class org.dom4j.tree.DefaultEntity
            • class org.dom4j.dom.DOMEntityReference (implements org.w3c.dom.EntityReference)
      • class org.dom4j.tree.AbstractProcessingInstruction (implements org.dom4j.ProcessingInstruction)
        • class org.dom4j.tree.FlyweightProcessingInstruction
          • class org.dom4j.tree.DefaultProcessingInstruction
            • class org.dom4j.dom.DOMProcessingInstruction (implements org.w3c.dom.ProcessingInstruction)
      • class org.dom4j.Namespace
        • class org.dom4j.tree.DefaultNamespace
          • class org.dom4j.dom.DOMNamespace (implements org.w3c.dom.Node)
    • class javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • class org.dom4j.swing.XMLTableModel
    • class org.dom4j.dtd.AttributeDecl
    • class org.dom4j.util.AttributeHelper
    • class org.dom4j.bean.BeanMetaData
    • class org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock (implements java.io.Serializable)
    • class org.dom4j.tree.ConcurrentReaderHashMap.Entry (implements java.util.Map.Entry)
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class org.dom4j.io.SAXContentHandler (implements org.xml.sax.ext.DeclHandler, org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
      • class org.dom4j.io.SAXEventRecorder (implements org.xml.sax.ext.DeclHandler, org.xml.sax.DTDHandler, java.io.Externalizable, org.xml.sax.ext.LexicalHandler)
    • class org.dom4j.xpath.DefaultNamespaceContext (implements org.jaxen.NamespaceContext, java.io.Serializable)
    • class org.dom4j.rule.pattern.DefaultPattern (implements org.dom4j.rule.Pattern)
    • class javax.swing.tree.DefaultTreeModel (implements java.io.Serializable, javax.swing.tree.TreeModel)
      • class org.dom4j.swing.DocumentTreeModel
    • class org.dom4j.xpath.DefaultXPath (implements org.dom4j.NodeFilter, java.io.Serializable, org.dom4j.XPath)
    • class org.dom4j.DocumentFactory (implements java.io.Serializable)
      • class org.dom4j.bean.BeanDocumentFactory
      • class org.dom4j.datatype.DatatypeDocumentFactory
      • class org.dom4j.datatype.DatatypeElementFactory
      • class org.dom4j.dom.DOMDocumentFactory (implements org.w3c.dom.DOMImplementation)
      • class org.dom4j.util.IndexedDocumentFactory
      • class org.dom4j.util.NonLazyDocumentFactory
      • class org.dom4j.util.UserDataDocumentFactory
    • class org.dom4j.DocumentHelper
    • class org.dom4j.dom.DOMAttributeNodeMap (implements org.w3c.dom.NamedNodeMap)
    • class org.dom4j.dom.DOMNodeHelper
    • class org.dom4j.dom.DOMNodeHelper.EmptyNodeList (implements org.w3c.dom.NodeList)
    • class org.dom4j.io.DOMReader
    • class org.dom4j.io.DOMWriter
    • class org.dom4j.dtd.ElementDecl
    • class org.dom4j.dtd.ExternalEntityDecl
    • class org.dom4j.tree.FilterIterator (implements java.util.Iterator)
      • class org.dom4j.tree.ElementIterator
      • class org.dom4j.tree.ElementNameIterator
      • class org.dom4j.tree.ElementQNameIterator
    • class org.dom4j.dtd.InternalEntityDecl
    • class org.dom4j.jaxb.JAXBSupport
      • class org.dom4j.jaxb.JAXBModifier
      • class org.dom4j.jaxb.JAXBReader
      • class org.dom4j.jaxb.JAXBWriter
    • class org.dom4j.swing.LeafTreeNode (implements javax.swing.tree.TreeNode)
      • class org.dom4j.swing.BranchTreeNode
    • class org.dom4j.rule.Mode
    • class org.dom4j.tree.NamespaceCache
    • class org.dom4j.tree.NamespaceStack
    • class org.dom4j.util.NodeComparator (implements java.util.Comparator)
    • class org.dom4j.rule.pattern.NodeTypePattern (implements org.dom4j.rule.Pattern)
    • class org.dom4j.rule.NullAction (implements org.dom4j.rule.Action)
    • class org.dom4j.io.OutputFormat (implements java.lang.Cloneable)
    • class org.dom4j.util.PerThreadSingleton (implements org.dom4j.util.SingletonStrategy)
    • class org.dom4j.util.ProxyDocumentFactory
    • class org.dom4j.xpp.ProxyXmlStartTag (implements org.gjt.xpp.XmlStartTag)
    • class org.dom4j.QName (implements java.io.Serializable)
    • class org.dom4j.tree.QNameCache
    • class org.dom4j.rule.Rule (implements java.lang.Comparable)
    • class org.dom4j.rule.RuleManager
    • class org.dom4j.rule.RuleSet
    • class org.dom4j.io.SAXModifier
    • class org.dom4j.io.SAXReader
    • class org.dom4j.io.SAXReader.SAXEntityResolver (implements org.xml.sax.EntityResolver, java.io.Serializable)
    • class javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • class org.dom4j.io.DocumentResult
      • class org.dom4j.io.XMLResult
    • class javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • class org.dom4j.io.DocumentSource
    • class org.dom4j.io.SAXValidator
    • class org.dom4j.io.SAXWriter (implements org.xml.sax.XMLReader)
    • class org.dom4j.datatype.SchemaParser
    • class org.dom4j.util.SimpleSingleton (implements org.dom4j.util.SingletonStrategy)
    • class org.dom4j.tree.SingleIterator (implements java.util.Iterator)
    • class org.dom4j.io.STAXEventReader
    • class org.dom4j.io.STAXEventWriter
    • class org.dom4j.rule.Stylesheet
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class org.dom4j.DocumentException
        • class java.lang.RuntimeException
          • class java.lang.IllegalArgumentException
            • class org.dom4j.IllegalAddException
            • class org.dom4j.datatype.InvalidSchemaException
            • class org.dom4j.InvalidXPathException
          • class org.dom4j.XPathException
    • class org.dom4j.VisitorSupport (implements org.dom4j.Visitor)
    • class org.dom4j.util.XMLErrorHandler (implements org.xml.sax.ErrorHandler)
    • class org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
      • class org.dom4j.io.XMLWriter (implements org.xml.sax.ext.LexicalHandler)
        • class org.dom4j.io.HTMLWriter
    • class org.dom4j.swing.XMLTableColumnDefinition (implements java.io.Serializable)
    • class org.dom4j.swing.XMLTableDefinition (implements java.io.Serializable, org.jaxen.VariableContext)
    • class org.dom4j.xpath.XPathPattern (implements org.dom4j.rule.Pattern)
    • class org.dom4j.io.XPP3Reader
    • class org.dom4j.io.XPPReader

Interface Hierarchy

  • interface org.dom4j.rule.Action
  • interface java.lang.Cloneable
    • interface org.dom4j.Attribute
    • interface org.dom4j.Branch
      • interface org.dom4j.Document
      • interface org.dom4j.Element
    • interface org.dom4j.CDATA
    • interface org.dom4j.CharacterData
      • interface org.dom4j.CDATA
      • interface org.dom4j.Comment
      • interface org.dom4j.Text
    • interface org.dom4j.Comment
    • interface org.dom4j.Document
    • interface org.dom4j.DocumentType
    • interface org.dom4j.Element
    • interface org.dom4j.Entity
    • interface org.dom4j.Node
      • interface org.dom4j.Attribute
      • interface org.dom4j.Branch
        • interface org.dom4j.Document
        • interface org.dom4j.Element
      • interface org.dom4j.CDATA
      • interface org.dom4j.CharacterData
        • interface org.dom4j.CDATA
        • interface org.dom4j.Comment
        • interface org.dom4j.Text
      • interface org.dom4j.Comment
      • interface org.dom4j.Document
      • interface org.dom4j.DocumentType
      • interface org.dom4j.Element
      • interface org.dom4j.Entity
      • interface org.dom4j.ProcessingInstruction
      • interface org.dom4j.Text
    • interface org.dom4j.ProcessingInstruction
    • interface org.dom4j.Text
  • interface org.dom4j.ElementHandler
  • interface org.dom4j.io.ElementModifier
  • interface org.dom4j.ElementPath
  • interface org.dom4j.jaxb.JAXBObjectHandler
  • interface org.dom4j.jaxb.JAXBObjectModifier
  • interface org.dom4j.NodeFilter
    • interface org.dom4j.rule.Pattern
    • interface org.dom4j.XPath
  • interface org.dom4j.util.SingletonStrategy
  • interface org.dom4j.Visitor
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j

Defines the XML Document Object Model in Java interfaces together with some helper classes.

See:
Description

Interface Summary
Attribute | Attribute defines an XML attribute.
Branch | Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
CDATA | CDATA defines an XML CDATA section.
CharacterData | CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.
Comment | Comment defines the behavior of an XML comment.
Document | Document defines an XML Document.
DocumentType | DocumentType defines an XML DOCTYPE declaration.
Element | Element interface defines an XML element.
ElementHandler | ElementHandler interface defines a handler of Element objects.
ElementPath | This interface is used by ElementHandlerinstances to retrieve information about the current path hierarchy they are to process.
Entity | Entity defines an XML entity.
Node | Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
NodeFilter | NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node.
ProcessingInstruction | ProcessingInstruction defines an XML processing instruction.
Text | Text defines an XML Text node.
Visitor | Visitor is used to implement the Visitor pattern in DOM4J.
XPath | XPath represents an XPath expression after it has been parsed from a String.

Class Summary
DocumentFactory | DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
DocumentHelper | DocumentHelper is a collection of helper methods for using DOM4J.
Namespace | Namespace is a Flyweight Namespace that can be shared amongst nodes.
QName | QName represents a qualified name value of an XML element or attribute.
VisitorSupport | VisitorSupport is an abstract base class which is useful for implementation inheritence or when using anonymous inner classes to create simple Visitor implementations.

Exception Summary
DocumentException | DocumentException is a nested Exception which may be thrown during the processing of a DOM4J document.
IllegalAddException | IllegalAddException is thrown when a node is added incorrectly to an Element
InvalidXPathException | InvalidXPathException is thrown when an invalid XPath expression is used to traverse an XML document
XPathException | XPathException is thrown when an exception occurs while evaluating an XPath expression, usually due to some function throwing an exception.

Package org.dom4j Description

Defines the XML Document Object Model in Java interfaces together with some helper classes.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.dom4j Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.tree.AbstractNode (implements java.lang.Cloneable, org.dom4j.Node, java.io.Serializable)
      • class org.dom4j.Namespace
    • class org.dom4j.DocumentFactory (implements java.io.Serializable)
    • class org.dom4j.DocumentHelper
    • class org.dom4j.QName (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class org.dom4j.DocumentException
        • class java.lang.RuntimeException
          • class java.lang.IllegalArgumentException
            • class org.dom4j.IllegalAddException
            • class org.dom4j.InvalidXPathException
          • class org.dom4j.XPathException
    • class org.dom4j.VisitorSupport (implements org.dom4j.Visitor)

Interface Hierarchy

  • interface java.lang.Cloneable
    • interface org.dom4j.Node
      • interface org.dom4j.Attribute
      • interface org.dom4j.Branch
        • interface org.dom4j.Document
        • interface org.dom4j.Element
      • interface org.dom4j.CharacterData
        • interface org.dom4j.CDATA
        • interface org.dom4j.Comment
        • interface org.dom4j.Text
      • interface org.dom4j.DocumentType
      • interface org.dom4j.Entity
      • interface org.dom4j.ProcessingInstruction
  • interface org.dom4j.ElementHandler
  • interface org.dom4j.ElementPath
  • interface org.dom4j.NodeFilter
    • interface org.dom4j.XPath
  • interface org.dom4j.Visitor
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.dom4j (dom4j 1.6.1 API)

Uses of Package
org.dom4j

Packages that use org.dom4j
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.jaxb |
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.rule.pattern |
org.dom4j.swing | A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.
org.dom4j.xpath | Provides the core tools needed to use the XPath library
org.dom4j.xpp | Provides implementation classes to cleanly integrate dom4j with the XML Pull Parser XPP

Classes in org.dom4j used by org.dom4j
Attribute
Attribute defines an XML attribute.
Branch
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
CDATA
CDATA defines an XML CDATA section.
CharacterData
CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.
Comment
Comment defines the behavior of an XML comment.
Document
Document defines an XML Document.
DocumentException
DocumentException is a nested Exception which may be thrown during the processing of a DOM4J document.
DocumentFactory
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
DocumentType
DocumentType defines an XML DOCTYPE declaration.
Element
Element interface defines an XML element.
ElementHandler
ElementHandler interface defines a handler of Element objects.
ElementPath
This interface is used by ElementHandlerinstances to retrieve information about the current path hierarchy they are to process.
Entity
Entity defines an XML entity.
InvalidXPathException
InvalidXPathException is thrown when an invalid XPath expression is used to traverse an XML document
Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
NodeFilter
NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node.
ProcessingInstruction
ProcessingInstruction defines an XML processing instruction.
QName
QName represents a qualified name value of an XML element or attribute.
Text
Text defines an XML Text node.
Visitor
Visitor is used to implement the Visitor pattern in DOM4J.
XPath
XPath represents an XPath expression after it has been parsed from a String.

Classes in org.dom4j used by org.dom4j.bean
Attribute
Attribute defines an XML attribute.
Branch
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
DocumentFactory
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
Element
Element interface defines an XML element.
Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
QName
QName represents a qualified name value of an XML element or attribute.

Classes in org.dom4j used by org.dom4j.datatype
Attribute
Attribute defines an XML attribute.
Branch
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
Document
Document defines an XML Document.
DocumentFactory
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
Element
Element interface defines an XML element.
Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
QName
QName represents a qualified name value of an XML element or attribute.

Classes in org.dom4j used by org.dom4j.dom
Attribute
Attribute defines an XML attribute.
Branch
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
CDATA
CDATA defines an XML CDATA section.
CharacterData
CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.
Comment
Comment defines the behavior of an XML comment.
Document
Document defines an XML Document.
DocumentFactory
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
DocumentType
DocumentType defines an XML DOCTYPE declaration.
Element
Element interface defines an XML element.
Entity
Entity defines an XML entity.
Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
ProcessingInstruction
ProcessingInstruction defines an XML processing instruction.
QName
QName represents a qualified name value of an XML element or attribute.
Text
Text defines an XML Text node.

Classes in org.dom4j used by org.dom4j.io
Attribute
Attribute defines an XML attribute.
Branch
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
CDATA
CDATA defines an XML CDATA section.
CharacterData
CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.
Comment
Comment defines the behavior of an XML comment.
Document
Document defines an XML Document.
DocumentException
DocumentException is a nested Exception which may be thrown during the processing of a DOM4J document.
DocumentFactory
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
DocumentType
DocumentType defines an XML DOCTYPE declaration.
Element
Element interface defines an XML element.
ElementHandler
ElementHandler interface defines a handler of Element objects.
Entity
Entity defines an XML entity.
Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
ProcessingInstruction
ProcessingInstruction defines an XML processing instruction.
QName
QName represents a qualified name value of an XML element or attribute.
Text
Text defines an XML Text node.

Classes in org.dom4j used by org.dom4j.jaxb
Document
Document defines an XML Document.
DocumentException
DocumentException is a nested Exception which may be thrown during the processing of a DOM4J document.
Element
Element interface defines an XML element.
ElementHandler
ElementHandler interface defines a handler of Element objects.

Classes in org.dom4j used by org.dom4j.rule
Document
Document defines an XML Document.
Element
Element interface defines an XML element.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
NodeFilter
NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node.
XPath
XPath represents an XPath expression after it has been parsed from a String.

Classes in org.dom4j used by org.dom4j.rule.pattern
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
NodeFilter
NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node.

Classes in org.dom4j used by org.dom4j.swing
Branch
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
Document
Document defines an XML Document.
Element
Element interface defines an XML element.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
XPath
XPath represents an XPath expression after it has been parsed from a String.

Classes in org.dom4j used by org.dom4j.tree
Attribute
Attribute defines an XML attribute.
Branch
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
CDATA
CDATA defines an XML CDATA section.
CharacterData
CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.
Comment
Comment defines the behavior of an XML comment.
Document
Document defines an XML Document.
DocumentFactory
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
DocumentType
DocumentType defines an XML DOCTYPE declaration.
Element
Element interface defines an XML element.
Entity
Entity defines an XML entity.
Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
NodeFilter
NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node.
ProcessingInstruction
ProcessingInstruction defines an XML processing instruction.
QName
QName represents a qualified name value of an XML element or attribute.
Text
Text defines an XML Text node.
Visitor
Visitor is used to implement the Visitor pattern in DOM4J.
XPath
XPath represents an XPath expression after it has been parsed from a String.

Classes in org.dom4j used by org.dom4j.util
Attribute
Attribute defines an XML attribute.
Branch
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
CDATA
CDATA defines an XML CDATA section.
CharacterData
CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.
Comment
Comment defines the behavior of an XML comment.
Document
Document defines an XML Document.
DocumentFactory
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
DocumentType
DocumentType defines an XML DOCTYPE declaration.
Element
Element interface defines an XML element.
Entity
Entity defines an XML entity.
Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
NodeFilter
NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node.
ProcessingInstruction
ProcessingInstruction defines an XML processing instruction.
QName
QName represents a qualified name value of an XML element or attribute.
Text
Text defines an XML Text node.
XPath
XPath represents an XPath expression after it has been parsed from a String.

Classes in org.dom4j used by org.dom4j.xpath
Element
Element interface defines an XML element.
InvalidXPathException
InvalidXPathException is thrown when an invalid XPath expression is used to traverse an XML document
Node
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
NodeFilter
NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node.
XPath
XPath represents an XPath expression after it has been parsed from a String.
XPathException
XPathException is thrown when an exception occurs while evaluating an XPath expression, usually due to some function throwing an exception.

Classes in org.dom4j used by org.dom4j.xpp
DocumentFactory
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
Element
Element interface defines an XML element.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Attribute (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Attribute

All Superinterfaces:
Cloneable, Node
All Known Implementing Classes:
AbstractAttribute
public interface Attribute
extends Node

Attribute defines an XML attribute. An attribute may have a name, an optional namespace and a value.

Version:
$Revision: 1.9 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Method Summary
 Object getData()
Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node.getText().
 Namespace getNamespace()
Returns the Namespace of this element if one exists otherwise null is returned returned.
 String getNamespacePrefix()
Returns the namespace prefix of this element if one exists otherwise an empty String is returned.
 String getNamespaceURI()
Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.
 QName getQName()
Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.
 String getQualifiedName()
Returns the fully qualified name of this element.
 String getValue()
Returns the value of the attribute.
 void setData(Object data)
Sets the data value of this attribute if this element supports data binding or calls Node.setText(String)if it doesn't.
 void setNamespace(Namespace namespace)
Sets the Namespace of this element or if this element is read only then an UnsupportedOperationException is thrown.
 void setValue(String value)
Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Method Detail

getQName

public QName getQName()

Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.

Returns:
the QName associated with this attribute

getNamespace

public Namespace getNamespace()

Returns the Namespace of this element if one exists otherwise null is returned returned.

Returns:
the Namespace associated with this node

setNamespace

public void setNamespace(Namespace namespace)

Sets the Namespace of this element or if this element is read only then an UnsupportedOperationException is thrown.

Parameters:
namespace - is the Namespace to associate with this element

getNamespacePrefix

public String getNamespacePrefix()

Returns the namespace prefix of this element if one exists otherwise an empty String is returned.

Returns:
the prefix of the Namespace of this element or an empty String

getNamespaceURI

public String getNamespaceURI()

Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.

Returns:
the URI for the Namespace of this element or an empty String

getQualifiedName

public String getQualifiedName()

Returns the fully qualified name of this element.

This will be the same as the value returned from Node.getName() if this element has no namespace attached to this element or an expression of the form

 getNamespacePrefix() + ":" + getName()
will be returned.

Returns:
the fully qualified name of the element

getValue

public String getValue()

Returns the value of the attribute. This method returns the same value as the Node.getText()method.

Returns:
the value of the attribute

setValue

public void setValue(String value)

Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.

Parameters:
value - is the new value of this attribute

getData

public Object getData()

Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node.getText().

Returns:
the attribute data

setData

public void setData(Object data)

Sets the data value of this attribute if this element supports data binding or calls Node.setText(String)if it doesn't.

Parameters:
data - the attribute data
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Branch (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Branch

All Superinterfaces:
Cloneable, Node
All Known Subinterfaces:
Document, Element
All Known Implementing Classes:
AbstractBranch, AbstractDocument, AbstractElement
public interface Branch
extends Node

Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents. This interface allows both elements and documents to be treated in a polymorphic manner when changing or navigating child nodes (content).

Version:
$Revision: 1.32 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Method Summary
void | add(Comment comment) Adds the given Comment to this branch.
void | add(Element element) Adds the given Element to this branch.
void | add(Node node) Adds the given Node or throws IllegalAddException if the given node is not of a valid type.
void | add(ProcessingInstruction pi) Adds the given ProcessingInstruction to this branch.
Element | addElement(QName qname) Adds a new Element node with the given QNameto this branch and returns a reference to the new node.
Element | addElement(String name) Adds a new Element node with the given name to this branch and returns a reference to the new node.
Element | addElement(String qualifiedName, String namespaceURI) Adds a new Element node with the given qualified name and namespace URI to this branch and returns a reference to the new node.
void | appendContent(Branch branch) Appends the content of the given branch to this branch instance.
void | clearContent() Clears the content for this branch, removing any Node instances this branch may contain.
List | content() Returns the content nodes of this branch as a backed Listso that the content of this branch may be modified directly using the Listinterface.
Element | elementByID(String elementID) Returns the element of the given ID attribute value.
int | indexOf(Node node) Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.
Node | node(int index) Returns the Node at the specified index position.
int | nodeCount() Returns the number of Node instances that this branch contains.
Iterator | nodeIterator() Returns an iterator through the content nodes of this branch
void | normalize() Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
ProcessingInstruction | processingInstruction(String target) DOCUMENT ME!
List | processingInstructions() Returns a list of all the processing instructions in this branch.
List | processingInstructions(String target) Returns a list of the processing instructions for the given target.
boolean | remove(Comment comment) Removes the given Comment if the node is an immediate child of this branch.
boolean | remove(Element element) Removes the given Element if the node is an immediate child of this branch.
boolean | remove(Node node) Removes the given Node if the node is an immediate child of this branch.
boolean | remove(ProcessingInstruction pi) Removes the given ProcessingInstruction if the node is an immediate child of this branch.
boolean | removeProcessingInstruction(String target) Removes the processing instruction for the given target if it exists
void | setContent(List content) Sets the contents of this branch as a List of Node instances.
void | setProcessingInstructions(List listOfPIs) Sets all the processing instructions for this branch
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Method Detail

node

public Node node(int index)
          throws IndexOutOfBoundsException
Returns the Node at the specified index position.

Parameters:
index - the index of the node to return.
Returns:
the Node at the specified position.
Throws:
IndexOutOfBoundsException - if the index is out of range (index < 0 || index >= nodeCount()).

indexOf

public int indexOf(Node node)
Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.

Parameters:
node - the content child node to find.
Returns:
the index of the given node starting at 0 or -1 if the node is not a child node of this branch

nodeCount

public int nodeCount()
Returns the number of Node instances that this branch contains.

Returns:
the number of nodes this branch contains

elementByID

public Element elementByID(String elementID)
Returns the element of the given ID attribute value. If this tree is capable of understanding which attribute value should be used for the ID then it should be used, otherwise this method should return null.

Parameters:
elementID - DOCUMENT ME!
Returns:
DOCUMENT ME!

content

public List content()

Returns the content nodes of this branch as a backed Listso that the content of this branch may be modified directly using the Listinterface. The List is backed by the Branch so that changes to the list are reflected in the branch and vice versa.

Returns:
the nodes that this branch contains as a List

nodeIterator

public Iterator nodeIterator()
Returns an iterator through the content nodes of this branch

Returns:
an iterator through the content nodes of this branch

setContent

public void setContent(List content)
Sets the contents of this branch as a List of Node instances.

Parameters:
content - is the list of nodes to use as the content for this branch.

appendContent

public void appendContent(Branch branch)
Appends the content of the given branch to this branch instance. This method behaves like the Collection.addAll(java.util.Collection) method.

Parameters:
branch - is the branch whose content will be added to me.

clearContent

public void clearContent()
Clears the content for this branch, removing any Node instances this branch may contain.

processingInstructions

public List processingInstructions()

Returns a list of all the processing instructions in this branch. The list is backed by this branch so that changes to the list will be reflected in the branch but the reverse is not the case.

Returns:
a backed list of the processing instructions

processingInstructions

public List processingInstructions(String target)

Returns a list of the processing instructions for the given target. The list is backed by this branch so that changes to the list will be reflected in the branch but the reverse is not the case.

Parameters:
target - DOCUMENT ME!
Returns:
a backed list of the processing instructions

processingInstruction

public ProcessingInstruction processingInstruction(String target)
DOCUMENT ME!

Parameters:
target - DOCUMENT ME!
Returns:
the processing instruction for the given target

setProcessingInstructions

public void setProcessingInstructions(List listOfPIs)
Sets all the processing instructions for this branch

Parameters:
listOfPIs - DOCUMENT ME!

addElement

public Element addElement(String name)
Adds a new Element node with the given name to this branch and returns a reference to the new node.

Parameters:
name - is the name for the Element node.
Returns:
the newly added Element node.

addElement

public Element addElement(QName qname)
Adds a new Element node with the given QNameto this branch and returns a reference to the new node.

Parameters:
qname - is the qualified name for the Element node.
Returns:
the newly added Element node.

addElement

public Element addElement(String qualifiedName,
                          String namespaceURI)
Adds a new Element node with the given qualified name and namespace URI to this branch and returns a reference to the new node.

Parameters:
qualifiedName - is the fully qualified name of the Element
namespaceURI - is the URI of the namespace to use
Returns:
the newly added Element node.

removeProcessingInstruction

public boolean removeProcessingInstruction(String target)
Removes the processing instruction for the given target if it exists

Parameters:
target - DOCUMENT ME!
Returns:
true if a processing instruction was removed else false

add

public void add(Node node)
Adds the given Node or throws IllegalAddException if the given node is not of a valid type. This is a polymorphic method which will call the typesafe method for the node type such as add(Element) or add(Comment).

Parameters:
node - is the given node to add

add

public void add(Comment comment)
Adds the given Comment to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Parameters:
comment - is the comment to be added

add

public void add(Element element)
Adds the given Element to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Parameters:
element - is the element to be added

add

public void add(ProcessingInstruction pi)
Adds the given ProcessingInstruction to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Parameters:
pi - is the processing instruction to be added

remove

public boolean remove(Node node)
Removes the given Node if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead. This is a polymorphic method which will call the typesafe method for the node type such as remove(Element) or remove(Comment).

Parameters:
node - is the given node to be removed
Returns:
true if the node was removed

remove

public boolean remove(Comment comment)
Removes the given Comment if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Parameters:
comment - is the comment to be removed
Returns:
true if the comment was removed

remove

public boolean remove(Element element)
Removes the given Element if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Parameters:
element - is the element to be removed
Returns:
true if the element was removed

remove

public boolean remove(ProcessingInstruction pi)
Removes the given ProcessingInstruction if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Parameters:
pi - is the processing instruction to be removed
Returns:
true if the processing instruction was removed

normalize

public void normalize()
Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes. This can be used to ensure that the DOM view of a document is the same as if it were saved and re-loaded, and is useful when operations (such as XPointer lookups) that depend on a particular document tree structure are to be used.In cases where the document contains CDATASections, the normalize operation alone may not be sufficient, since XPointers do not differentiate between Text nodes and CDATASection nodes.

Since:
DOM Level 2
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CDATA (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface CDATA

All Superinterfaces:
CharacterData, Cloneable, Node
All Known Implementing Classes:
AbstractCDATA, FlyweightCDATA
public interface CDATA
extends CharacterData

CDATA defines an XML CDATA section.

Version:
$Revision: 1.7 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


CharacterData (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface CharacterData

All Superinterfaces:
Cloneable, Node
All Known Subinterfaces:
CDATA, Comment, Text
All Known Implementing Classes:
AbstractCDATA, AbstractCharacterData, AbstractComment, AbstractText, FlyweightCDATA, FlyweightComment, FlyweightText
public interface CharacterData
extends Node

CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.

Version:
$Revision: 1.9 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Method Summary
 void appendText(String text)
Appends the given text to this nodes text value.
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Method Detail

appendText

public void appendText(String text)
Appends the given text to this nodes text value. Calling this method is equivalent of the code node.setText(node.getText() + text) but allows for possible implementation optimisations (such as a text based node storing a StringBuffer internally

Parameters:
text - the text to append
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Comment (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Comment

All Superinterfaces:
CharacterData, Cloneable, Node
All Known Implementing Classes:
AbstractComment, FlyweightComment
public interface Comment
extends CharacterData

Comment defines the behavior of an XML comment.

Version:
$Revision: 1.7 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Document (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Document

All Superinterfaces:
Branch, Cloneable, Node
All Known Implementing Classes:
AbstractDocument
public interface Document
extends Branch

Document defines an XML Document.

Version:
$Revision: 1.14 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Method Summary
Document | addComment(String comment) Adds a new Comment node with the given text to this branch.
Document | addDocType(String name, String publicId, String systemId) Adds a DOCTYPE declaration to this document
Document | addProcessingInstruction(String target, Map data) Adds a processing instruction for the given target
Document | addProcessingInstruction(String target, String text) Adds a processing instruction for the given target
DocumentType | getDocType() DOCUMENT ME!
EntityResolver | getEntityResolver() DOCUMENT ME!
Element | getRootElement() Returns the root Elementfor this document.
String | getXMLEncoding() Return the encoding of this document, as part of the XML declaration This is null when unspecified or when it is not known (such as when the Document was created in memory) or when the implementation does not support this operation.
void | setDocType(DocumentType docType) Sets the DocumentType property
void | setEntityResolver(EntityResolver entityResolver) Sets the EntityResolver used to find resolve URIs such as for DTDs, or XML Schema documents
void | setRootElement(Element rootElement) Sets the root element for this document
void | setXMLEncoding(String encoding) Sets the encoding of this document as it will appear in the XML declaration part of the document.
Methods inherited from interface org.dom4j.Branch
add, add, add, add, addElement, addElement, addElement, appendContent, clearContent, content, elementByID, indexOf, node, nodeCount, nodeIterator, normalize, processingInstruction, processingInstructions, processingInstructions, remove, remove, remove, remove, removeProcessingInstruction, setContent, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Method Detail

getRootElement

public Element getRootElement()
Returns the root Elementfor this document.

Returns:
the root element for this document

setRootElement

public void setRootElement(Element rootElement)
Sets the root element for this document

Parameters:
rootElement - the new root element for this document

addComment

public Document addComment(String comment)
Adds a new Comment node with the given text to this branch.

Parameters:
comment - is the text for the Comment node.
Returns:
this Document instance.

addProcessingInstruction

public Document addProcessingInstruction(String target,
                                         String text)
Adds a processing instruction for the given target

Parameters:
target - is the target of the processing instruction
text - is the textual data (key/value pairs) of the processing instruction
Returns:
this Document instance.

addProcessingInstruction

public Document addProcessingInstruction(String target,
                                         Map data)
Adds a processing instruction for the given target

Parameters:
target - is the target of the processing instruction
data - is a Map of the key / value pairs of the processing instruction
Returns:
this Document instance.

addDocType

public Document addDocType(String name,
                           String publicId,
                           String systemId)
Adds a DOCTYPE declaration to this document

Parameters:
name - is the name of the root element
publicId - is the PUBLIC URI
systemId - is the SYSTEM URI
Returns:
this Document instance.

getDocType

public DocumentType getDocType()
DOCUMENT ME!

Returns:
the DocumentType property

setDocType

public void setDocType(DocumentType docType)
Sets the DocumentType property

Parameters:
docType - DOCUMENT ME!

getEntityResolver

public EntityResolver getEntityResolver()
DOCUMENT ME!

Returns:
the EntityResolver used to find resolve URIs such as for DTDs, or XML Schema documents

setEntityResolver

public void setEntityResolver(EntityResolver entityResolver)
Sets the EntityResolver used to find resolve URIs such as for DTDs, or XML Schema documents

Parameters:
entityResolver - DOCUMENT ME!

getXMLEncoding

public String getXMLEncoding()
Return the encoding of this document, as part of the XML declaration This is null when unspecified or when it is not known (such as when the Document was created in memory) or when the implementation does not support this operation.

The way this encoding is retrieved also depends on the way the XML source is parsed. For instance, if the SAXReader is used and if the underlying XMLReader implementation support the org.xml.sax.ext.Locator2 interface, the result returned by this method is specified by the getEncoding() method of that interface.

Returns:
The encoding of this document, as stated in the XML declaration, or null if unknown.
Since:
1.5

setXMLEncoding

public void setXMLEncoding(String encoding)
Sets the encoding of this document as it will appear in the XML declaration part of the document.

Parameters:
encoding - the encoding of the document
Since:
1.6
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DocumentType (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface DocumentType

All Superinterfaces:
Cloneable, Node
All Known Implementing Classes:
AbstractDocumentType
public interface DocumentType
extends Node

DocumentType defines an XML DOCTYPE declaration.

Version:
$Revision: 1.10 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Method Summary
 String getElementName()
This method is the equivalent to the Node.getName()method.
 List getExternalDeclarations()
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
 List getInternalDeclarations()
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
 String getPublicID()
 String getSystemID()
 void setElementName(String elementName)
This method is the equivalent to the Node.setName(java.lang.String)method.
 void setExternalDeclarations(List declarations)
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
 void setInternalDeclarations(List declarations)
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
 void setPublicID(String publicID)
 void setSystemID(String systemID)
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Method Detail

getElementName

public String getElementName()
This method is the equivalent to the Node.getName()method. It is added for clarity.

Returns:
the root element name for the document type.

setElementName

public void setElementName(String elementName)
This method is the equivalent to the Node.setName(java.lang.String)method. It is added for clarity.

Parameters:
elementName - DOCUMENT ME!

getPublicID

public String getPublicID()

setPublicID

public void setPublicID(String publicID)

getSystemID

public String getSystemID()

setSystemID

public void setSystemID(String systemID)

getInternalDeclarations

public List getInternalDeclarations()
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage

Returns:
DOCUMENT ME!

setInternalDeclarations

public void setInternalDeclarations(List declarations)
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage

Parameters:
declarations - DOCUMENT ME!

getExternalDeclarations

public List getExternalDeclarations()
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage

Returns:
DOCUMENT ME!

setExternalDeclarations

public void setExternalDeclarations(List declarations)
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage

Parameters:
declarations - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Element (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Element

All Superinterfaces:
Branch, Cloneable, Node
All Known Implementing Classes:
AbstractElement
public interface Element
extends Branch

Element interface defines an XML element. An element can have declared namespaces, attributes, child nodes and textual content.

Some of this interface is optional. Some implementations may be read-only and not support being modified. Some implementations may not support the parent relationship and methods such as Node.getParent()or .

Version:
$Revision: 1.47 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Method Summary
 void add(Attribute attribute)
Adds the given Attribute to this element.
 void add(CDATA cdata)
Adds the given CDATA to this element.
 void add(Entity entity)
Adds the given Entity to this element.
 void add(Namespace namespace)
Adds the given Namespace to this element.
 void add(Text text)
Adds the given Text to this element.
 Element addAttribute(QName qName, String value)
Adds the attribute value of the given fully qualified name.
 Element addAttribute(String name, String value)
Adds the attribute value of the given local name.
 Element addCDATA(String cdata)
Adds a new CDATA node with the given text to this element.
 Element addComment(String comment)
Adds a new Comment node with the given text to this element.
 Element addEntity(String name, String text)
Adds a new Entity node with the given name and text to this element and returns a reference to the new node.
 List additionalNamespaces()
Returns any additional namespaces declarations for this element other than namespace returned via the getNamespace()method.
 Element addNamespace(String prefix, String uri)
Adds a namespace to this element for use by its child content
 Element addProcessingInstruction(String target, Map data)
Adds a processing instruction for the given target
 Element addProcessingInstruction(String target, String text)
Adds a processing instruction for the given target
 Element addText(String text)
Adds a new Text node with the given text to this element.
 void appendAttributes(Element element)
Appends the attributes of the given element to me.
 Attribute attribute(int index)
Returns the attribute at the specified indexGets the
 Attribute attribute(QName qName)
DOCUMENT ME!
 Attribute attribute(String name)
Returns the attribute with the given name
 int attributeCount()
DOCUMENT ME!
 Iterator attributeIterator()
DOCUMENT ME!
 List attributes()
Returns the Attributeinstances this element contains as a backed Listso that the attributes may be modified directly using the Listinterface.
 String attributeValue(QName qName)
This returns the attribute value for the attribute with the given fully qualified name or null if there is no such attribute or the empty string if the attribute value is empty.
 String attributeValue(QName qName, String defaultValue)
This returns the attribute value for the attribute with the given fully qualified name or the default value if there is no such attribute value.
 String attributeValue(String name)
This returns the attribute value for the attribute with the given name and any namespace or null if there is no such attribute or the empty string if the attribute value is empty.
 String attributeValue(String name, String defaultValue)
This returns the attribute value for the attribute with the given name and any namespace or the default value if there is no such attribute value.
 Element createCopy()
Creates a deep copy of this element The new element is detached from its parent, and getParent() on the clone will return null.
 Element createCopy(QName qName)
Creates a deep copy of this element with the given fully qualified name.
 Element createCopy(String name)
Creates a deep copy of this element with the given local name The new element is detached from its parent, and getParent() on the clone will return null.
 List declaredNamespaces()
Returns all the namespaces declared by this element.
 Element element(QName qName)
Returns the first element for the given fully qualified name.
 Element element(String name)
Returns the first element for the given local name and any namespace.
 Iterator elementIterator()
Returns an iterator over all this elements child elements.
 Iterator elementIterator(QName qName)
Returns an iterator over the elements contained in this element which match the given fully qualified name.
 Iterator elementIterator(String name)
Returns an iterator over the elements contained in this element which match the given local name and any namespace.
 List elements()
Returns the elements contained in this element.
 List elements(QName qName)
Returns the elements contained in this element with the given fully qualified name.
 List elements(String name)
Returns the elements contained in this element with the given local name and any namespace.
 String elementText(QName qname)
 String elementText(String name)
 String elementTextTrim(QName qname)
 String elementTextTrim(String name)
 Object getData()
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as getText()
 Namespace getNamespace()
Returns the Namespace of this element if one exists otherwise Namespace.NO_NAMESPACE is returned.
 Namespace getNamespaceForPrefix(String prefix)
Returns the Namespace which is mapped to the given prefix or null if it could not be found.
 Namespace getNamespaceForURI(String uri)
Returns the Namespace which is mapped to the given URI or null if it could not be found.
 String getNamespacePrefix()
Returns the namespace prefix of this element if one exists otherwise an empty String is returned.
 List getNamespacesForURI(String uri)
Returns the all namespaces which are mapped to the given URI or an empty list if no such namespaces could be found.
 String getNamespaceURI()
Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.
 QName getQName()
Returns the QName of this element which represents the local name, the qualified name and the Namespace.
 QName getQName(String qualifiedName)
Returns the QName for the given qualified name, using the namespace URI in scope for the given prefix of the qualified name or the default namespace if the qualified name has no prefix.
 String getQualifiedName()
Returns the fully qualified name of this element.
 String getStringValue()
Returns the XPath string-value of this node.
 String getText()
Returns the text value of this element without recursing through child elements.
 String getTextTrim()
DOCUMENT ME!
 Node getXPathResult(int index)
Returns a node at the given index suitable for an XPath result set.
 boolean hasMixedContent()
Returns true if this Element has mixed content.
 boolean isRootElement()
DOCUMENT ME!
 boolean isTextOnly()
Returns true if this Element has text only content.
 boolean remove(Attribute attribute)
Removes the given Attribute from this element.
 boolean remove(CDATA cdata)
Removes the given CDATA if the node is an immediate child of this element.
 boolean remove(Entity entity)
Removes the given Entity if the node is an immediate child of this element.
 boolean remove(Namespace namespace)
Removes the given Namespace if the node is an immediate child of this element.
 boolean remove(Text text)
Removes the given Text if the node is an immediate child of this element.
 void setAttributes(List attributes)
Sets the attributes that this element contains
 void setAttributeValue(QName qName, String value)
Deprecated. As of version 0.5. Please use addAttribute(QName,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
 void setAttributeValue(String name, String value)
Deprecated. As of version 0.5. Please use addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
 void setData(Object data)
Sets the data value of this element if this element supports data binding or calls Node.setText(java.lang.String)if it doesn't
 void setQName(QName qname)
Sets the QName of this element which represents the local name, the qualified name and the Namespace.
Methods inherited from interface org.dom4j.Branch
add, add, add, add, addElement, addElement, addElement, appendContent, clearContent, content, elementByID, indexOf, node, nodeCount, nodeIterator, normalize, processingInstruction, processingInstructions, processingInstructions, remove, remove, remove, remove, removeProcessingInstruction, setContent, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Method Detail

getQName

public QName getQName()

Returns the QName of this element which represents the local name, the qualified name and the Namespace.

Returns:
the QName associated with this element

setQName

public void setQName(QName qname)

Sets the QName of this element which represents the local name, the qualified name and the Namespace.

Parameters:
qname - is the QName to be associated with this element

getNamespace

public Namespace getNamespace()

Returns the Namespace of this element if one exists otherwise Namespace.NO_NAMESPACE is returned.

Returns:
the Namespace associated with this element

getQName

public QName getQName(String qualifiedName)

Returns the QName for the given qualified name, using the namespace URI in scope for the given prefix of the qualified name or the default namespace if the qualified name has no prefix.

Parameters:
qualifiedName - DOCUMENT ME!
Returns:
the QName for the given qualified name

getNamespaceForPrefix

public Namespace getNamespaceForPrefix(String prefix)

Returns the Namespace which is mapped to the given prefix or null if it could not be found.

Parameters:
prefix - DOCUMENT ME!
Returns:
the Namespace associated with the given prefix

getNamespaceForURI

public Namespace getNamespaceForURI(String uri)

Returns the Namespace which is mapped to the given URI or null if it could not be found. If there is more than one Namespace mapped to the URI, which of them will be returned is undetermined.

Parameters:
uri - DOCUMENT ME!
Returns:
the Namespace associated with the given URI

getNamespacesForURI

public List getNamespacesForURI(String uri)

Returns the all namespaces which are mapped to the given URI or an empty list if no such namespaces could be found.

Parameters:
uri - DOCUMENT ME!
Returns:
the namespaces associated with the given URI
Since:
1.5

getNamespacePrefix

public String getNamespacePrefix()

Returns the namespace prefix of this element if one exists otherwise an empty String is returned.

Returns:
the prefix of the Namespace of this element or an empty String

getNamespaceURI

public String getNamespaceURI()

Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.

Returns:
the URI for the Namespace of this element or an empty String

getQualifiedName

public String getQualifiedName()

Returns the fully qualified name of this element. This will be the same as the value returned from Node.getName()if this element has no namespace attached to this element or an expression of the form

 getNamespacePrefix() + ":" + getName()
will be returned.

Returns:
the fully qualified name of the element.

additionalNamespaces

public List additionalNamespaces()

Returns any additional namespaces declarations for this element other than namespace returned via the getNamespace()method. If no additional namespace declarations are present for this element then an empty list will be returned. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Returns:
a list of any additional namespace declarations.

declaredNamespaces

public List declaredNamespaces()

Returns all the namespaces declared by this element. If no namespaces are declared for this element then an empty list will be returned. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Returns:
a list of namespaces declared for this element.

addAttribute

public Element addAttribute(String name,
                            String value)

Adds the attribute value of the given local name. If an attribute already exists for the given name it will be replaced. Attributes with null values are silently ignored. If the value of the attribute is null then this method call will remove any attributes with the given name.

Parameters:
name - is the name of the attribute whose value is to be added or updated
value - is the attribute's value
Returns:
this Element instance.

addAttribute

public Element addAttribute(QName qName,
                            String value)

Adds the attribute value of the given fully qualified name. If an attribute already exists for the given name it will be replaced. Attributes with null values are silently ignored. If the value of the attribute is null then this method call will remove any attributes with the given name.

Parameters:
qName - is the fully qualified name of the attribute whose value is to be added or updated
value - is the attribute's value
Returns:
this Element instance.

addComment

public Element addComment(String comment)
Adds a new Comment node with the given text to this element.

Parameters:
comment - is the text for the Comment node.
Returns:
this Element instance.

addCDATA

public Element addCDATA(String cdata)
Adds a new CDATA node with the given text to this element.

Parameters:
cdata - is the text for the CDATA node.
Returns:
this Element instance.

addEntity

public Element addEntity(String name,
                         String text)
Adds a new Entity node with the given name and text to this element and returns a reference to the new node.

Parameters:
name - is the name for the Entity node.
text - is the text for the Entity node.
Returns:
this Element instance.

addNamespace

public Element addNamespace(String prefix,
                            String uri)
Adds a namespace to this element for use by its child content

Parameters:
prefix - is the prefix to use, which should not be null or blank
uri - is the namespace URI
Returns:
this Element instance.

addProcessingInstruction

public Element addProcessingInstruction(String target,
                                        String text)
Adds a processing instruction for the given target

Parameters:
target - is the target of the processing instruction
text - is the textual data (key/value pairs) of the processing instruction
Returns:
this Element instance.

addProcessingInstruction

public Element addProcessingInstruction(String target,
                                        Map data)
Adds a processing instruction for the given target

Parameters:
target - is the target of the processing instruction
data - is a Map of the key / value pairs of the processing instruction
Returns:
this Element instance.

addText

public Element addText(String text)
Adds a new Text node with the given text to this element.

Parameters:
text - is the text for the Text node.
Returns:
this Element instance.

add

public void add(Attribute attribute)
Adds the given Attribute to this element. If the given node already has a parent defined then an IllegalAddException will be thrown. Attributes with null values are silently ignored.

If the value of the attribute is null then this method call will remove any attributes with the QName of this attribute.

Parameters:
attribute - is the attribute to be added

add

public void add(CDATA cdata)
Adds the given CDATA to this element. If the given node already has a parent defined then an IllegalAddException will be thrown.

Parameters:
cdata - is the CDATA to be added

add

public void add(Entity entity)
Adds the given Entity to this element. If the given node already has a parent defined then an IllegalAddException will be thrown.

Parameters:
entity - is the entity to be added

add

public void add(Text text)
Adds the given Text to this element. If the given node already has a parent defined then an IllegalAddException will be thrown.

Parameters:
text - is the text to be added

add

public void add(Namespace namespace)
Adds the given Namespace to this element. If the given node already has a parent defined then an IllegalAddException will be thrown.

Parameters:
namespace - is the namespace to be added

remove

public boolean remove(Attribute attribute)
Removes the given Attribute from this element.

Parameters:
attribute - is the attribute to be removed
Returns:
true if the attribute was removed

remove

public boolean remove(CDATA cdata)
Removes the given CDATA if the node is an immediate child of this element. If the given node is not an immediate child of this element then the Node.detach()method should be used instead.

Parameters:
cdata - is the CDATA to be removed
Returns:
true if the cdata was removed

remove

public boolean remove(Entity entity)
Removes the given Entity if the node is an immediate child of this element. If the given node is not an immediate child of this element then the Node.detach()method should be used instead.

Parameters:
entity - is the entity to be removed
Returns:
true if the entity was removed

remove

public boolean remove(Namespace namespace)
Removes the given Namespace if the node is an immediate child of this element. If the given node is not an immediate child of this element then the Node.detach()method should be used instead.

Parameters:
namespace - is the namespace to be removed
Returns:
true if the namespace was removed

remove

public boolean remove(Text text)
Removes the given Text if the node is an immediate child of this element. If the given node is not an immediate child of this element then the Node.detach()method should be used instead.

Parameters:
text - is the text to be removed
Returns:
true if the text was removed

getText

public String getText()
Returns the text value of this element without recursing through child elements. This method iterates through all Text,CDATA and Entitynodes that this element contains and appends the text values together.

Specified by:
getText in interface Node
Returns:
the textual content of this Element. Child elements are not navigated. This method does not return null;

getTextTrim

public String getTextTrim()
DOCUMENT ME!

Returns:
the trimmed text value where whitespace is trimmed and normalised into single spaces. This method does not return null.

getStringValue

public String getStringValue()
Returns the XPath string-value of this node. The behaviour of this method is defined in the XPath specification . This method returns the string-value of all the contained Text,CDATA,Entityand Element nodes all appended together.

Specified by:
getStringValue in interface Node
Returns:
the text from all the child Text and Element nodes appended together.

getData

public Object getData()
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as getText()

Returns:
DOCUMENT ME!

setData

public void setData(Object data)
Sets the data value of this element if this element supports data binding or calls Node.setText(java.lang.String)if it doesn't

Parameters:
data - DOCUMENT ME!

attributes

public List attributes()

Returns the Attributeinstances this element contains as a backed Listso that the attributes may be modified directly using the Listinterface. The List is backed by the Element so that changes to the list are reflected in the element and vice versa.

Returns:
the attributes that this element contains as a List

setAttributes

public void setAttributes(List attributes)
Sets the attributes that this element contains

Parameters:
attributes - DOCUMENT ME!

attributeCount

public int attributeCount()
DOCUMENT ME!

Returns:
the number of attributes this element contains

attributeIterator

public Iterator attributeIterator()
DOCUMENT ME!

Returns:
an iterator over the attributes of this element

attribute

public Attribute attribute(int index)
Returns the attribute at the specified indexGets the

Parameters:
index - DOCUMENT ME!
Returns:
the attribute at the specified index where index >= 0 and index < number of attributes or throws an IndexOutOfBoundsException if the index is not within the allowable range

attribute

public Attribute attribute(String name)
Returns the attribute with the given name

Parameters:
name - DOCUMENT ME!
Returns:
the attribute for the given local name in any namespace. If there are more than one attributes with the given local name in different namespaces then the first one is returned.

attribute

public Attribute attribute(QName qName)
DOCUMENT ME!

Parameters:
qName - is the fully qualified name
Returns:
the attribute for the given fully qualified name or null if it could not be found.

attributeValue

public String attributeValue(String name)

This returns the attribute value for the attribute with the given name and any namespace or null if there is no such attribute or the empty string if the attribute value is empty.

Parameters:
name - is the name of the attribute value to be returnd
Returns:
the value of the attribute, null if the attribute does not exist or the empty string

attributeValue

public String attributeValue(String name,
                             String defaultValue)

This returns the attribute value for the attribute with the given name and any namespace or the default value if there is no such attribute value.

Parameters:
name - is the name of the attribute value to be returnd
defaultValue - is the default value to be returned if the attribute has no value defined.
Returns:
the value of the attribute or the defaultValue if the attribute has no value defined.

attributeValue

public String attributeValue(QName qName)

This returns the attribute value for the attribute with the given fully qualified name or null if there is no such attribute or the empty string if the attribute value is empty.

Parameters:
qName - is the fully qualified name
Returns:
the value of the attribute, null if the attribute does not exist or the empty string

attributeValue

public String attributeValue(QName qName,
                             String defaultValue)

This returns the attribute value for the attribute with the given fully qualified name or the default value if there is no such attribute value.

Parameters:
qName - is the fully qualified name
defaultValue - is the default value to be returned if the attribute has no value defined.
Returns:
the value of the attribute or the defaultValue if the attribute has no value defined.

setAttributeValue

public void setAttributeValue(String name,
                              String value)
Deprecated. As of version 0.5. Please use addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!

Sets the attribute value of the given local name.

Parameters:
name - is the name of the attribute whose value is to be added or updated
value - is the attribute's value

setAttributeValue

public void setAttributeValue(QName qName,
                              String value)
Deprecated. As of version 0.5. Please use addAttribute(QName,String) instead. WILL BE REMOVED IN dom4j-1.6 !!

Sets the attribute value of the given fully qualified name.

Parameters:
qName - is the fully qualified name of the attribute whose value is to be added or updated
value - is the attribute's value

element

public Element element(String name)
Returns the first element for the given local name and any namespace.

Parameters:
name - DOCUMENT ME!
Returns:
the first element with the given local name

element

public Element element(QName qName)
Returns the first element for the given fully qualified name.

Parameters:
qName - is the fully qualified name to search for
Returns:
the first element with the given fully qualified name

elements

public List elements()

Returns the elements contained in this element. If this element does not contain any elements then this method returns an empty list. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Returns:
a list of all the elements in this element.

elements

public List elements(String name)

Returns the elements contained in this element with the given local name and any namespace. If no elements are found then this method returns an empty list. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Parameters:
name - DOCUMENT ME!
Returns:
a list of all the elements in this element for the given local name

elements

public List elements(QName qName)

Returns the elements contained in this element with the given fully qualified name. If no elements are found then this method returns an empty list. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Parameters:
qName - is the fully qualified name to search for
Returns:
a list of all the elements in this element for the given fully qualified name.

elementIterator

public Iterator elementIterator()
Returns an iterator over all this elements child elements.

Returns:
an iterator over the contained elements

elementIterator

public Iterator elementIterator(String name)
Returns an iterator over the elements contained in this element which match the given local name and any namespace.

Parameters:
name - DOCUMENT ME!
Returns:
an iterator over the contained elements matching the given local name

elementIterator

public Iterator elementIterator(QName qName)
Returns an iterator over the elements contained in this element which match the given fully qualified name.

Parameters:
qName - is the fully qualified name to search for
Returns:
an iterator over the contained elements matching the given fully qualified name

isRootElement

public boolean isRootElement()
DOCUMENT ME!

Returns:
true if this element is the root element of a document and this element supports the parent relationship else false.

hasMixedContent

public boolean hasMixedContent()

Returns true if this Element has mixed content. Mixed content means that an element contains both textual data and child elements.

Returns:
true if this element contains mixed content.

isTextOnly

public boolean isTextOnly()

Returns true if this Element has text only content.

Returns:
true if this element is empty or only contains text content.

appendAttributes

public void appendAttributes(Element element)
Appends the attributes of the given element to me. This method behaves like the Collection.addAll(java.util.Collection) method.

Parameters:
element - is the element whose attributes will be added to me.

createCopy

public Element createCopy()

Creates a deep copy of this element The new element is detached from its parent, and getParent() on the clone will return null.

Returns:
a new deep copy Element

createCopy

public Element createCopy(String name)

Creates a deep copy of this element with the given local name The new element is detached from its parent, and getParent() on the clone will return null.

Parameters:
name - DOCUMENT ME!
Returns:
a new deep copy Element

createCopy

public Element createCopy(QName qName)

Creates a deep copy of this element with the given fully qualified name. The new element is detached from its parent, and getParent() on the clone will return null.

Parameters:
qName - DOCUMENT ME!
Returns:
a new deep copy Element

elementText

public String elementText(String name)

elementText

public String elementText(QName qname)

elementTextTrim

public String elementTextTrim(String name)

elementTextTrim

public String elementTextTrim(QName qname)

getXPathResult

public Node getXPathResult(int index)
Returns a node at the given index suitable for an XPath result set. This means the resulting Node will either be null or it will support the parent relationship.

Parameters:
index - DOCUMENT ME!
Returns:
the Node for the given index which will support the parent relationship or null if there is not a node at the given index.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElementHandler (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface ElementHandler

public interface ElementHandler

ElementHandler interface defines a handler of Element objects. It is used primarily in event based processing models such as for processing large XML documents as they are being parsed rather than waiting until the whole document is parsed.

Version:
$Revision: 1.8 $
Author:
James Strachan

Method Summary
void | onEnd(ElementPath elementPath) Called by an event based processor when an elements closing tag is encountered.
void | onStart(ElementPath elementPath) Called by an event based processor when an elements openning tag is encountered.

Method Detail

onStart

public void onStart(ElementPath elementPath)
Called by an event based processor when an elements openning tag is encountered.

Parameters:
elementPath - is the current ElementPath to process

onEnd

public void onEnd(ElementPath elementPath)
Called by an event based processor when an elements closing tag is encountered.

Parameters:
elementPath - is the current ElementPath to process
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElementPath (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface ElementPath

public interface ElementPath

This interface is used by ElementHandlerinstances to retrieve information about the current path hierarchy they are to process. It's primary use is to retrieve the current Elementbeing processed.

Version:
$Revision: 1.6 $
Author:
Dave White

Method Summary
void | addHandler(String path, ElementHandler handler) Adds the ElementHandler to be called when the specified path is encounted.
Element | getCurrent() DOCUMENT ME!
Element | getElement(int depth) DOCUMENT ME!
String | getPath() DOCUMENT ME!
void | removeHandler(String path) Removes the ElementHandler from the event based processor, for the specified path.
int | size() DOCUMENT ME!

Method Detail

size

public int size()
DOCUMENT ME!

Returns:
the number of elements in the path

getElement

public Element getElement(int depth)
DOCUMENT ME!

Parameters:
depth - DOCUMENT ME!
Returns:
the element at the specified depth index, 0 = root element

getPath

public String getPath()
DOCUMENT ME!

Returns:
the path as a string

getCurrent

public Element getCurrent()
DOCUMENT ME!

Returns:
the current element

addHandler

public void addHandler(String path,
                       ElementHandler handler)
Adds the ElementHandler to be called when the specified path is encounted. The path can be either an absolute path (i.e. prefixed with "/") or a relative path (i.e. assummed to be a child of the current path as retrieved by getPath .

Parameters:
path - is the path to be handled
handler - is the ElementHandler to be called by the event based processor.

removeHandler

public void removeHandler(String path)
Removes the ElementHandler from the event based processor, for the specified path. The path can be either an absolute path (i.e. prefixed with "/") or a relative path (i.e. assummed to be a child of the current path as retrieved by getPath .

Parameters:
path - is the path to remove the ElementHandler for.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Entity (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Entity

All Superinterfaces:
Cloneable, Node
All Known Implementing Classes:
AbstractEntity
public interface Entity
extends Node

Entity defines an XML entity.

Version:
$Revision: 1.7 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Node (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Node

All Superinterfaces:
Cloneable
All Known Subinterfaces:
Attribute, Branch, CDATA, CharacterData, Comment, Document, DocumentType, Element, Entity, ProcessingInstruction, Text
All Known Implementing Classes:
AbstractAttribute, AbstractBranch, AbstractCDATA, AbstractCharacterData, AbstractComment, AbstractDocument, AbstractDocumentType, AbstractElement, AbstractEntity, AbstractNode, AbstractProcessingInstruction, AbstractText, FlyweightCDATA, FlyweightComment, FlyweightText
public interface Node
extends Cloneable

Node defines the polymorphic behavior for all XML nodes in a dom4j tree.

A node can be output as its XML format, can be detached from its position in a document and can have XPath expressions evaluated on itself.

A node may optionally support the parent relationship and may be read only.

Version:
$Revision: 1.31 $
Author:
James Strachan
See Also:
supportsParent(), isReadOnly()

Field Summary
static short | ANY_NODE Matches Element nodes
static short | ATTRIBUTE_NODE Matches elements nodes
static short | CDATA_SECTION_NODE Matches elements nodes
static short | COMMENT_NODE Matches Comments nodes
static short | DOCUMENT_NODE Matches Document nodes
static short | DOCUMENT_TYPE_NODE Matches DocumentType nodes
static short | ELEMENT_NODE Matches Element nodes
static short | ENTITY_REFERENCE_NODE Matches elements nodes
static short | MAX_NODE_TYPE The maximum number of node types for sizing purposes
static short | NAMESPACE_NODE Matchs a Namespace Node - NOTE this differs from DOM
static short | PROCESSING_INSTRUCTION_NODE Matches ProcessingInstruction
static short | TEXT_NODE Matches elements nodes
static short | UNKNOWN_NODE Does not match any valid node
Method Summary
void | accept(Visitor visitor) accept is the method used in the Visitor Pattern.
String | asXML() asXML returns the textual XML representation of this node.
Node | asXPathResult(Element parent) asXPathResult returns a version of this node which is capable of being an XPath result.
Object | clone() clone will return a deep clone or if this node is read-only then clone will return the same instance.
XPath | createXPath(String xpathExpression) createXPath creates an XPath object for the given xpathExpression.
Node | detach() Removes this node from its parent if there is one.
Document | getDocument() getDocument returns the Document that this Node is part of if this node supports the parent relationship.
String | getName() getName returns the name of this node.
short | getNodeType() Returns the code according to the type of node.
String | getNodeTypeName() DOCUMENT ME!
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
String | getPath() Returns the XPath expression which will return a node set containing the given node such as /a/b/@c.
String | getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | getStringValue() Returns the XPath string-value of this node.
String | getText() Returns the text of this node.
String | getUniquePath() Returns the XPath expression which will return a nodeset of one node which is the current node.
String | getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
boolean | hasContent() hasContent returns true if this node is a Branch (either an Element or a Document) and it contains at least one content node such as a child Element or Text node.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
boolean | matches(String xpathExpression) matches returns true if evaluating the given XPath expression on this node returns a non-empty node set containing this node.
Number | numberValueOf(String xpathExpression) numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results in a number, or null if the result is not a number.
List | selectNodes(String xpathExpression) selectNodes evaluates an XPath expression and returns the result as a List of Node instances or String instances depending on the XPath expression.
List | selectNodes(String xpathExpression, String comparisonXPathExpression) selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.
List | selectNodes(String xpathExpression, String comparisonXPathExpression, boolean removeDuplicates) selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.
Object | selectObject(String xpathExpression) selectObject evaluates an XPath expression and returns the result as an Object.
Node | selectSingleNode(String xpathExpression) selectSingleNode evaluates an XPath expression and returns the result as a single Node instance.
void | setDocument(Document document) setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setName(String name) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setText(String text) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
String | valueOf(String xpathExpression) valueOf evaluates an XPath expression and returns the textual representation of the results the XPath string-value of this node.
void | write(Writer writer) write writes this node as the default XML notation for this node.

Field Detail

ANY_NODE

public static final short ANY_NODE
Matches Element nodes

See Also:
Constant Field Values

ELEMENT_NODE

public static final short ELEMENT_NODE
Matches Element nodes

See Also:
Constant Field Values

ATTRIBUTE_NODE

public static final short ATTRIBUTE_NODE
Matches elements nodes

See Also:
Constant Field Values

TEXT_NODE

public static final short TEXT_NODE
Matches elements nodes

See Also:
Constant Field Values

CDATA_SECTION_NODE

public static final short CDATA_SECTION_NODE
Matches elements nodes

See Also:
Constant Field Values

ENTITY_REFERENCE_NODE

public static final short ENTITY_REFERENCE_NODE
Matches elements nodes

See Also:
Constant Field Values

PROCESSING_INSTRUCTION_NODE

public static final short PROCESSING_INSTRUCTION_NODE
Matches ProcessingInstruction

See Also:
Constant Field Values

COMMENT_NODE

public static final short COMMENT_NODE
Matches Comments nodes

See Also:
Constant Field Values

DOCUMENT_NODE

public static final short DOCUMENT_NODE
Matches Document nodes

See Also:
Constant Field Values

DOCUMENT_TYPE_NODE

public static final short DOCUMENT_TYPE_NODE
Matches DocumentType nodes

See Also:
Constant Field Values

NAMESPACE_NODE

public static final short NAMESPACE_NODE
Matchs a Namespace Node - NOTE this differs from DOM

See Also:
Constant Field Values

UNKNOWN_NODE

public static final short UNKNOWN_NODE
Does not match any valid node

See Also:
Constant Field Values

MAX_NODE_TYPE

public static final short MAX_NODE_TYPE
The maximum number of node types for sizing purposes

See Also:
Constant Field Values
Method Detail

supportsParent

public boolean supportsParent()

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Returns:
true if this node supports the parent relationship or false it is not supported

getParent

public Element getParent()

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Returns:
the parent of this node or null if it is the root of the tree or the parent relationship is not supported.

setParent

public void setParent(Element parent)

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Parameters:
parent - is the new parent of this node.

getDocument

public Document getDocument()

getDocument returns the Document that this Node is part of if this node supports the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Returns:
the document of this node or null if this feature is not supported or the node is not associated with a Document

setDocument

public void setDocument(Document document)

setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside a Document implementation method and is not intended for general use.

Parameters:
document - is the new document of this node.

isReadOnly

public boolean isReadOnly()

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Returns:
true if this Node is read only and cannot be modified otherwise false.

hasContent

public boolean hasContent()

hasContent returns true if this node is a Branch (either an Element or a Document) and it contains at least one content node such as a child Element or Text node.

Returns:
true if this Node is a Branch with a nodeCount() of one or more.

getName

public String getName()

getName returns the name of this node. This is the XML local name of the element, attribute, entity or processing instruction. For CDATA and Text nodes this method will return null.

Returns:
the XML name of this node

setName

public void setName(String name)

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Parameters:
name - is the new name of this node

getText

public String getText()

Returns the text of this node.

Returns:
the text for this node.

setText

public void setText(String text)

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Parameters:
text - is the new textual value of this node

getStringValue

public String getStringValue()
Returns the XPath string-value of this node. The behaviour of this method is defined in the XPath specification .

Returns:
the text from all the child Text and Element nodes appended together.

getPath

public String getPath()

Returns the XPath expression which will return a node set containing the given node such as /a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Returns:
the XPath expression which will return a nodeset containing at least this node.

getPath

public String getPath(Element context)
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath()

Returns the XPath expression which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Returns:
the XPath expression which will return a nodeset containing just this node.

getUniquePath

public String getUniquePath(Element context)

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

asXML

public String asXML()

asXML returns the textual XML representation of this node.

Returns:
the XML representation of this node

write

public void write(Writer writer)
           throws IOException

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Parameters:
writer - is the Writer to output the XML to
Throws:
IOException - DOCUMENT ME!

getNodeType

public short getNodeType()
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Returns:
a W3C DOM complient code for the node type such as ELEMENT_NODE or ATTRIBUTE_NODE

getNodeTypeName

public String getNodeTypeName()
DOCUMENT ME!

Returns:
the name of the type of node such as "Document", "Element", "Attribute" or "Text"

detach

public Node detach()

Removes this node from its parent if there is one. If this node is the root element of a document then it is removed from the document as well.

This method is useful if you want to remove a node from its source document and add it to another document. For example

Node node = ...; Element someOtherElement = ...; someOtherElement.add( node.detach() );

Returns:
the node that has been removed from its parent node if any and its document if any.

selectNodes

public List selectNodes(String xpathExpression)

selectNodes evaluates an XPath expression and returns the result as a List of Node instances or String instances depending on the XPath expression.

Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the list of Node or String instances depending on the XPath expression

selectObject

public Object selectObject(String xpathExpression)

selectObject evaluates an XPath expression and returns the result as an Object. The object returned can either be a List of one or more Nodeinstances or a scalar object like a Stringor a Numberinstance depending on the XPath expression.

Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the value of the XPath expression as a Listof Node instances, a Stringor a Numberinstance depending on the XPath expression.

selectNodes

public List selectNodes(String xpathExpression,
                        String comparisonXPathExpression)

selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.

Parameters:
xpathExpression - is the XPath expression to be evaluated
comparisonXPathExpression - is the XPath expression used to compare the results by for sorting
Returns:
the list of Node instances sorted by the comparisonXPathExpression

selectNodes

public List selectNodes(String xpathExpression,
                        String comparisonXPathExpression,
                        boolean removeDuplicates)

selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.

Parameters:
xpathExpression - is the XPath expression to be evaluated
comparisonXPathExpression - is the XPath expression used to compare the results by for sorting
removeDuplicates - if this parameter is true then duplicate values (using the comparisonXPathExpression) are removed from the result List.
Returns:
the list of Node instances sorted by the comparisonXPathExpression

selectSingleNode

public Node selectSingleNode(String xpathExpression)

selectSingleNode evaluates an XPath expression and returns the result as a single Node instance.

Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the Node matching the XPath expression

valueOf

public String valueOf(String xpathExpression)

valueOf evaluates an XPath expression and returns the textual representation of the results the XPath string-value of this node. The string-value for a given node type is defined in the XPath specification .

Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the string-value representation of the results of the XPath expression

numberValueOf

public Number numberValueOf(String xpathExpression)

numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results in a number, or null if the result is not a number.

Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the numeric result of the XPath expression or null if the result is not a number.

matches

public boolean matches(String xpathExpression)

matches returns true if evaluating the given XPath expression on this node returns a non-empty node set containing this node.

This method does not behave like the <xsl:if> element - if you want that behaviour, to evaluate if an XPath expression matches something, then you can use the following code to be equivalent...

if ( node.selectSingleNode( "/some/path" ) != nulll )

Parameters:
xpathExpression - is an XPath expression
Returns:
true if this node is returned by the given XPath expression

createXPath

public XPath createXPath(String xpathExpression)
                  throws InvalidXPathException

createXPath creates an XPath object for the given xpathExpression. The XPath object allows the variable context to be specified.

Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
an XPath object represeting the given expression
Throws:
InvalidXPathException - if the XPath expression is invalid

asXPathResult

public Node asXPathResult(Element parent)

asXPathResult returns a version of this node which is capable of being an XPath result. The result of an XPath expression should always support the parent relationship, whether the original XML tree was singly or doubly linked. If the node does not support the parent relationship then a new node will be created which is linked to its parent and returned.

Parameters:
parent - DOCUMENT ME!
Returns:
a Node which supports the parent relationship

accept

public void accept(Visitor visitor)

accept is the method used in the Visitor Pattern.

Parameters:
visitor - is the visitor in the Visitor Pattern

clone

public Object clone()

clone will return a deep clone or if this node is read-only then clone will return the same instance.

Returns:
a deep clone of myself or myself if I am read only.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NodeFilter (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface NodeFilter

All Known Subinterfaces:
Pattern, XPath
All Known Implementing Classes:
DefaultPattern, DefaultXPath, NodeTypePattern, XPathPattern
public interface NodeFilter

NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node. Instances can be generated from an DocumentFactory.

Version:
$Revision: 1.7 $
Author:
James Strachan

Method Summary
 boolean matches(Node node)
matches returns true if the given node matches the filter condition.

Method Detail

matches

public boolean matches(Node node)

matches returns true if the given node matches the filter condition.

Parameters:
node - DOCUMENT ME!
Returns:
true if this filter matches the given node
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProcessingInstruction (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface ProcessingInstruction

All Superinterfaces:
Cloneable, Node
All Known Implementing Classes:
AbstractProcessingInstruction
public interface ProcessingInstruction
extends Node

ProcessingInstruction defines an XML processing instruction. The Node.getName()method will return the target of the PI and the Node.getText()method will return the data from all of the instructions.

Version:
$Revision: 1.10 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Method Summary
 String getTarget()
This method is the equivalent to the Node.getName()method.
 String getText()
DOCUMENT ME!
 String getValue(String name)
Returns the value of a specific name in the PI.
 Map getValues()
DOCUMENT ME!
 boolean removeValue(String name)
 void setTarget(String target)
This method is the equivalent to the Node.setName(java.lang.String)method.
 void setValue(String name, String value)
 void setValues(Map data)
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Method Detail

getTarget

public String getTarget()
This method is the equivalent to the Node.getName()method. It is added for clarity.

Returns:
the target of this PI

setTarget

public void setTarget(String target)
This method is the equivalent to the Node.setName(java.lang.String)method. It is added for clarity.

Parameters:
target - DOCUMENT ME!

getText

public String getText()
DOCUMENT ME!

Specified by:
getText in interface Node
Returns:
the text for all the data associated with the processing instruction

getValue

public String getValue(String name)

Returns the value of a specific name in the PI.

Parameters:
name - is the name of the attribute to lookup.
Returns:
the value of the named attribute

getValues

public Map getValues()
DOCUMENT ME!

Returns:
the values for this processing instruction as a Map

setValue

public void setValue(String name,
                     String value)

setValues

public void setValues(Map data)

removeValue

public boolean removeValue(String name)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Text (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Text

All Superinterfaces:
CharacterData, Cloneable, Node
All Known Implementing Classes:
AbstractText, FlyweightText
public interface Text
extends CharacterData

Text defines an XML Text node.

Version:
$Revision: 1.7 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Visitor (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface Visitor

All Known Implementing Classes:
VisitorSupport
public interface Visitor

Visitor is used to implement the Visitor pattern in DOM4J. An object of this interface can be passed to a Node which will then call its typesafe methods. Please refer to the Gang of Four book of Design Patterns for more details on the Visitor pattern.

This site has further discussion on design patterns and links to the GOF book. This link describes the Visitor pattern in detail.

Version:
$Revision: 1.8 $
Author:
James Strachan

Method Summary
void | visit(Attribute node) Visits the given Attribute
void | visit(CDATA node) Visits the given CDATA
void | visit(Comment node) Visits the given Comment
void | visit(Document document) Visits the given Document
void | visit(DocumentType documentType) Visits the given DocumentType
void | visit(Element node) Visits the given Element
void | visit(Entity node) Visits the given Entity
void | visit(Namespace namespace) Visits the given Namespace
void | visit(ProcessingInstruction node) Visits the given ProcessingInstruction
void | visit(Text node) Visits the given Text

Method Detail

visit

public void visit(Document document)

Visits the given Document

Parameters:
document - is the Document node to visit.

visit

public void visit(DocumentType documentType)

Visits the given DocumentType

Parameters:
documentType - is the DocumentType node to visit.

visit

public void visit(Element node)

Visits the given Element

Parameters:
node - is the Element node to visit.

visit

public void visit(Attribute node)

Visits the given Attribute

Parameters:
node - is the Attribute node to visit.

visit

public void visit(CDATA node)

Visits the given CDATA

Parameters:
node - is the CDATA node to visit.

visit

public void visit(Comment node)

Visits the given Comment

Parameters:
node - is the Comment node to visit.

visit

public void visit(Entity node)

Visits the given Entity

Parameters:
node - is the Entity node to visit.

visit

public void visit(Namespace namespace)

Visits the given Namespace

Parameters:
namespace - is the Namespace node to visit.

visit

public void visit(ProcessingInstruction node)

Visits the given ProcessingInstruction

Parameters:
node - is the ProcessingInstruction node to visit.

visit

public void visit(Text node)

Visits the given Text

Parameters:
node - is the Text node to visit.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XPath (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Interface XPath

All Superinterfaces:
NodeFilter
All Known Implementing Classes:
DefaultXPath
public interface XPath
extends NodeFilter

XPath represents an XPath expression after it has been parsed from a String.

Version:
$Revision: 1.20 $
Author:
James Strachan

Method Summary
boolean | booleanValueOf(Object context) Retrieve a boolean-value interpretation of this XPath expression when evaluated against a given context.
Object | evaluate(Object context) evaluate evaluates an XPath expression and returns the result as an Object.
org.jaxen.FunctionContext | getFunctionContext() DOCUMENT ME!
org.jaxen.NamespaceContext | getNamespaceContext() DOCUMENT ME!
String | getText() getText will return the textual version of the XPath expression.
org.jaxen.VariableContext | getVariableContext() DOCUMENT ME!
boolean | matches(Node node) matches returns true if the given node matches the XPath expression.
Number | numberValueOf(Object context) numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results is a number, or null if the result is not a number.
List | selectNodes(Object context) selectNodes performs this XPath expression on the given Nodeor Listof Nodes instances appending all the results together into a single list.
List | selectNodes(Object context, XPath sortXPath) selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.
List | selectNodes(Object context, XPath sortXPath, boolean distinct) selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.
Object | selectObject(Object context) Deprecated. please use evaluate(Object) instead. WILL BE REMOVED IN dom4j-1.6 !!
Node | selectSingleNode(Object context) selectSingleNode evaluates this XPath expression on the given Nodeor Listof Nodes and returns the result as a single Node instance.
void | setFunctionContext(org.jaxen.FunctionContext functionContext) Sets the function context to be used when evaluating XPath expressions
void | setNamespaceContext(org.jaxen.NamespaceContext namespaceContext) Sets the namespace context to be used when evaluating XPath expressions
void | setNamespaceURIs(Map map) Sets the current NamespaceContext from a Map where the keys are the String namespace prefixes and the values are the namespace URIs.
void | setVariableContext(org.jaxen.VariableContext variableContext) Sets the variable context to be used when evaluating XPath expressions
void | sort(List list) sort sorts the given List of Nodes using this XPath expression as a Comparator.
void | sort(List list, boolean distinct) sort sorts the given List of Nodes using this XPath expression as a Comparatorand optionally removing duplicates.
String | valueOf(Object context) valueOf evaluates this XPath expression and returns the textual representation of the results using the XPath string() function.

Method Detail

getText

public String getText()

getText will return the textual version of the XPath expression.

Returns:
the textual format of the XPath expression.

matches

public boolean matches(Node node)

matches returns true if the given node matches the XPath expression. To be more precise when evaluating this XPath expression on the given node the result set must include the node.

Specified by:
matches in interface NodeFilter
Parameters:
node - DOCUMENT ME!
Returns:
true if the given node matches this XPath expression

evaluate

public Object evaluate(Object context)

evaluate evaluates an XPath expression and returns the result as an Object. The object returned can either be a List of Nodeinstances, a Nodeinstance, a String or a Numberinstance depending on the XPath expression.

Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the value of the XPath expression as a Listof Node instances, a Nodeinstance, a Stringor a Numberinstance depending on the XPath expression.

selectObject

public Object selectObject(Object context)
Deprecated. please use evaluate(Object) instead. WILL BE REMOVED IN dom4j-1.6 !!

selectObject evaluates an XPath expression and returns the result as an Object. The object returned can either be a List of Nodeinstances, a Nodeinstance, a String or a Numberinstance depending on the XPath expression.

Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the value of the XPath expression as a Listof Node instances, a Nodeinstance, a Stringor a Numberinstance depending on the XPath expression.

selectNodes

public List selectNodes(Object context)

selectNodes performs this XPath expression on the given Nodeor Listof Nodes instances appending all the results together into a single list.

Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the results of all the XPath evaluations as a single list

selectNodes

public List selectNodes(Object context,
                        XPath sortXPath)

selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.

Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
sortXPath - is the XPath expression to sort by
Returns:
a list of Node instances

selectNodes

public List selectNodes(Object context,
                        XPath sortXPath,
                        boolean distinct)

selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.

Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
sortXPath - is the XPath expression to sort by
distinct - specifies whether or not duplicate values of the sort expression are allowed. If this parameter is true then only distinct sort expressions values are included in the result
Returns:
a list of Node instances

selectSingleNode

public Node selectSingleNode(Object context)

selectSingleNode evaluates this XPath expression on the given Nodeor Listof Nodes and returns the result as a single Node instance.

Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
a single matching Node instance

valueOf

public String valueOf(Object context)

valueOf evaluates this XPath expression and returns the textual representation of the results using the XPath string() function.

Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the string representation of the results of the XPath expression

numberValueOf

public Number numberValueOf(Object context)

numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results is a number, or null if the result is not a number.

Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the numeric result of the XPath expression or null if the result is not a number.

booleanValueOf

public boolean booleanValueOf(Object context)
Retrieve a boolean-value interpretation of this XPath expression when evaluated against a given context.

The boolean-value of the expression is determined per the boolean(..) core function as defined in the XPath specification. This means that an expression that selects zero nodes will return false, while an expression that selects one-or-more nodes will return true.

Parameters:
context - The node, nodeset or Context object for evaluation. This value can be null
Returns:
The boolean-value interpretation of this expression.
Since:
1.5

sort

public void sort(List list)

sort sorts the given List of Nodes using this XPath expression as a Comparator.

Parameters:
list - is the list of Nodes to sort

sort

public void sort(List list,
                 boolean distinct)

sort sorts the given List of Nodes using this XPath expression as a Comparatorand optionally removing duplicates.

Parameters:
list - is the list of Nodes to sort
distinct - if true then duplicate values (using the sortXPath for comparisions) will be removed from the List

getFunctionContext

public org.jaxen.FunctionContext getFunctionContext()
DOCUMENT ME!

Returns:
the current function context

setFunctionContext

public void setFunctionContext(org.jaxen.FunctionContext functionContext)
Sets the function context to be used when evaluating XPath expressions

Parameters:
functionContext - DOCUMENT ME!

getNamespaceContext

public org.jaxen.NamespaceContext getNamespaceContext()
DOCUMENT ME!

Returns:
the current namespace context

setNamespaceContext

public void setNamespaceContext(org.jaxen.NamespaceContext namespaceContext)
Sets the namespace context to be used when evaluating XPath expressions

Parameters:
namespaceContext - DOCUMENT ME!

setNamespaceURIs

public void setNamespaceURIs(Map map)

Sets the current NamespaceContext from a Map where the keys are the String namespace prefixes and the values are the namespace URIs.

For example:

 Map uris = new HashMap();
 uris.put("SOAP-ENV", "http://schemas.xmlsoap.org/soap/envelope/");
 uris.put("m", "urn:xmethodsBabelFish");
 XPath xpath = document
         .createXPath("SOAP-ENV:Envelope/SOAP-ENV:Body/m:BabelFish");
 xpath.setNamespaceURIs(uris);
 Node babelfish = xpath.selectSingleNode(document);

Parameters:
map - the map containing the namespace mappings

getVariableContext

public org.jaxen.VariableContext getVariableContext()
DOCUMENT ME!

Returns:
the current variable context

setVariableContext

public void setVariableContext(org.jaxen.VariableContext variableContext)
Sets the variable context to be used when evaluating XPath expressions

Parameters:
variableContext - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DocumentFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class DocumentFactory

java.lang.Object
    extended by org.dom4j.DocumentFactory
All Implemented Interfaces:
Serializable
Direct Known Subclasses:
BeanDocumentFactory, DatatypeDocumentFactory, DatatypeElementFactory, DOMDocumentFactory, IndexedDocumentFactory, NonLazyDocumentFactory, UserDataDocumentFactory
public class DocumentFactory
extends Object
implements Serializable

DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees. The default tree that is built uses a doubly linked tree.

The tree built allows full XPath expressions from anywhere on the tree.

Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected  QNameCache cache
Constructor Summary
DocumentFactory()
Method Summary
Attribute | createAttribute(Element owner, QName qname, String value)
Attribute | createAttribute(Element owner, String name, String value)
CDATA | createCDATA(String text)
Comment | createComment(String text)
DocumentType | createDocType(String name, String publicId, String systemId)
Document | createDocument()
Document | createDocument(Element rootElement)
Document | createDocument(String encoding) DOCUMENT ME!
Element | createElement(QName qname)
Element | createElement(String name)
Element | createElement(String qualifiedName, String namespaceURI)
Entity | createEntity(String name, String text)
Namespace | createNamespace(String prefix, String uri)
Pattern | createPattern(String xpathPattern) createPattern parses the given XPath expression to create an XSLT style Patterninstance which can then be used in an XSLT processing model.
ProcessingInstruction | createProcessingInstruction(String target, Map data)
ProcessingInstruction | createProcessingInstruction(String target, String data)
QName | createQName(String localName)
QName | createQName(String localName, Namespace namespace)
QName | createQName(String qualifiedName, String uri)
QName | createQName(String name, String prefix, String uri)
protected QNameCache | createQNameCache() Factory method to create the QNameCache.
protected static DocumentFactory | createSingleton(String className) createSingleton creates the singleton instance from the given class name.
Text | createText(String text)
XPath | createXPath(String xpathExpression) createXPath parses an XPath expression and creates a new XPath XPath instance.
XPath | createXPath(String xpathExpression, org.jaxen.VariableContext variableContext) createXPath parses an XPath expression and creates a new XPath XPath instance.
NodeFilter | createXPathFilter(String xpathFilterExpression) createXPathFilter parses a NodeFilter from the given XPath filter expression.
NodeFilter | createXPathFilter(String xpathFilterExpression, org.jaxen.VariableContext variableContext) createXPathFilter parses a NodeFilter from the given XPath filter expression.
static DocumentFactory | getInstance() Access to singleton implementation of DocumentFactory which is used if no DocumentFactory is specified when building using the standard builders.
List | getQNames() Returns a list of all the QName instances currently used by this document factory
Map | getXPathNamespaceURIs() DOCUMENT ME!
protected void | init()
protected QName | intern(QName qname) DOCUMENT ME!
void | setXPathNamespaceURIs(Map namespaceURIs) Sets the namespace URIs to be used by XPath expressions created by this factory or by nodes associated with this factory.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

cache

protected transient QNameCache cache
Constructor Detail

DocumentFactory

public DocumentFactory()
Method Detail

getInstance

public static DocumentFactory getInstance()

Access to singleton implementation of DocumentFactory which is used if no DocumentFactory is specified when building using the standard builders.

Returns:
the default singleon instance

createDocument

public Document createDocument()

createDocument

public Document createDocument(String encoding)
DOCUMENT ME!

Parameters:
encoding - DOCUMENT ME!
Returns:
DOCUMENT ME!
Since:
1.5

createDocument

public Document createDocument(Element rootElement)

createDocType

public DocumentType createDocType(String name,
                                  String publicId,
                                  String systemId)

createElement

public Element createElement(QName qname)

createElement

public Element createElement(String name)

createElement

public Element createElement(String qualifiedName,
                             String namespaceURI)

createAttribute

public Attribute createAttribute(Element owner,
                                 QName qname,
                                 String value)

createAttribute

public Attribute createAttribute(Element owner,
                                 String name,
                                 String value)

createCDATA

public CDATA createCDATA(String text)

createComment

public Comment createComment(String text)

createText

public Text createText(String text)

createEntity

public Entity createEntity(String name,
                           String text)

createNamespace

public Namespace createNamespace(String prefix,
                                 String uri)

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(String target,
                                                         String data)

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(String target,
                                                         Map data)

createQName

public QName createQName(String localName,
                         Namespace namespace)

createQName

public QName createQName(String localName)

createQName

public QName createQName(String name,
                         String prefix,
                         String uri)

createQName

public QName createQName(String qualifiedName,
                         String uri)

createXPath

public XPath createXPath(String xpathExpression)
                  throws InvalidXPathException

createXPath parses an XPath expression and creates a new XPath XPath instance.

Parameters:
xpathExpression - is the XPath expression to create
Returns:
a new XPath instance
Throws:
InvalidXPathException - if the XPath expression is invalid

createXPath

public XPath createXPath(String xpathExpression,
                         org.jaxen.VariableContext variableContext)

createXPath parses an XPath expression and creates a new XPath XPath instance.

Parameters:
xpathExpression - is the XPath expression to create
variableContext - is the variable context to use when evaluating the XPath
Returns:
a new XPath instance

createXPathFilter

public NodeFilter createXPathFilter(String xpathFilterExpression,
                                    org.jaxen.VariableContext variableContext)

createXPathFilter parses a NodeFilter from the given XPath filter expression. XPath filter expressions occur within XPath expressions such as self::node()[ filterExpression ]

Parameters:
xpathFilterExpression - is the XPath filter expression to create
variableContext - is the variable context to use when evaluating the XPath
Returns:
a new NodeFilter instance

createXPathFilter

public NodeFilter createXPathFilter(String xpathFilterExpression)

createXPathFilter parses a NodeFilter from the given XPath filter expression. XPath filter expressions occur within XPath expressions such as self::node()[ filterExpression ]

Parameters:
xpathFilterExpression - is the XPath filter expression to create
Returns:
a new NodeFilter instance

createPattern

public Pattern createPattern(String xpathPattern)

createPattern parses the given XPath expression to create an XSLT style Patterninstance which can then be used in an XSLT processing model.

Parameters:
xpathPattern - is the XPath pattern expression to create
Returns:
a new Pattern instance

getQNames

public List getQNames()
Returns a list of all the QName instances currently used by this document factory

Returns:
DOCUMENT ME!

getXPathNamespaceURIs

public Map getXPathNamespaceURIs()
DOCUMENT ME!

Returns:
the Map of namespace URIs that will be used by by XPath expressions to resolve namespace prefixes into namespace URIs. The map is keyed by namespace prefix and the value is the namespace URI. This value could well be null to indicate no namespace URIs are being mapped.

setXPathNamespaceURIs

public void setXPathNamespaceURIs(Map namespaceURIs)
Sets the namespace URIs to be used by XPath expressions created by this factory or by nodes associated with this factory. The keys are namespace prefixes and the values are namespace URIs.

Parameters:
namespaceURIs - DOCUMENT ME!

createSingleton

protected static DocumentFactory createSingleton(String className)

createSingleton creates the singleton instance from the given class name.

Parameters:
className - is the name of the DocumentFactory class to use
Returns:
a new singleton instance.

intern

protected QName intern(QName qname)
DOCUMENT ME!

Parameters:
qname - DOCUMENT ME!
Returns:
the cached QName instance if there is one or adds the given qname to the cache if not

createQNameCache

protected QNameCache createQNameCache()
Factory method to create the QNameCache. This method should be overloaded if you wish to use your own derivation of QName.

Returns:
DOCUMENT ME!

init

protected void init()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DocumentHelper (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class DocumentHelper

java.lang.Object
    extended by org.dom4j.DocumentHelper
public final class DocumentHelper
extends Object

DocumentHelper is a collection of helper methods for using DOM4J.

Version:
$Revision: 1.26 $
Author:
James Strachan

Method Summary
static Attribute | createAttribute(Element owner, QName qname, String value)
static Attribute | createAttribute(Element owner, String name, String value)
static CDATA | createCDATA(String text)
static Comment | createComment(String text)
static Document | createDocument()
static Document | createDocument(Element rootElement)
static Element | createElement(QName qname)
static Element | createElement(String name)
static Entity | createEntity(String name, String text)
static Namespace | createNamespace(String prefix, String uri)
static Pattern | createPattern(String xpathPattern) createPattern parses the given XPath expression to create an XSLT style Patterninstance which can then be used in an XSLT processing model.
static ProcessingInstruction | createProcessingInstruction(String pi, Map data)
static ProcessingInstruction | createProcessingInstruction(String pi, String d)
static QName | createQName(String localName)
static QName | createQName(String localName, Namespace namespace)
static Text | createText(String text)
static XPath | createXPath(String xpathExpression) createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.
static XPath | createXPath(String xpathExpression, org.jaxen.VariableContext context) createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.
static NodeFilter | createXPathFilter(String xpathFilterExpression) createXPathFilter parses a NodeFilter from the given XPath filter expression using the singleton DocumentFactory.
static Element | makeElement(Branch source, String path) makeElement a helper method which navigates from the given Document or Element node to some Element using the path expression, creating any necessary elements along the way.
static Document | parseText(String text) parseText parses the given text as an XML document and returns the newly created Document.
static List | selectNodes(String xpathFilterExpression, List nodes) selectNodes performs the given XPath expression on the Listof Nodeinstances appending all the results together into a single list.
static List | selectNodes(String xpathFilterExpression, Node node) selectNodes performs the given XPath expression on the Listof Nodeinstances appending all the results together into a single list.
static void | sort(List list, String xpathExpression) sort sorts the given List of Nodes using an XPath expression as a Comparator.
static void | sort(List list, String expression, boolean distinct) sort sorts the given List of Nodes using an XPath expression as a Comparatorand optionally removing duplicates.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Method Detail

createDocument

public static Document createDocument()

createDocument

public static Document createDocument(Element rootElement)

createElement

public static Element createElement(QName qname)

createElement

public static Element createElement(String name)

createAttribute

public static Attribute createAttribute(Element owner,
                                        QName qname,
                                        String value)

createAttribute

public static Attribute createAttribute(Element owner,
                                        String name,
                                        String value)

createCDATA

public static CDATA createCDATA(String text)

createComment

public static Comment createComment(String text)

createText

public static Text createText(String text)

createEntity

public static Entity createEntity(String name,
                                  String text)

createNamespace

public static Namespace createNamespace(String prefix,
                                        String uri)

createProcessingInstruction

public static ProcessingInstruction createProcessingInstruction(String pi,
                                                                String d)

createProcessingInstruction

public static ProcessingInstruction createProcessingInstruction(String pi,
                                                                Map data)

createQName

public static QName createQName(String localName,
                                Namespace namespace)

createQName

public static QName createQName(String localName)

createXPath

public static XPath createXPath(String xpathExpression)
                         throws InvalidXPathException

createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.

Parameters:
xpathExpression - is the XPath expression to create
Returns:
a new XPath instance
Throws:
InvalidXPathException - if the XPath expression is invalid

createXPath

public static XPath createXPath(String xpathExpression,
                                org.jaxen.VariableContext context)
                         throws InvalidXPathException

createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.

Parameters:
xpathExpression - is the XPath expression to create
context - is the variable context to use when evaluating the XPath
Returns:
a new XPath instance
Throws:
InvalidXPathException - if the XPath expression is invalid

createXPathFilter

public static NodeFilter createXPathFilter(String xpathFilterExpression)

createXPathFilter parses a NodeFilter from the given XPath filter expression using the singleton DocumentFactory. XPath filter expressions occur within XPath expressions such as self::node()[ filterExpression ]

Parameters:
xpathFilterExpression - is the XPath filter expression to create
Returns:
a new NodeFilter instance

createPattern

public static Pattern createPattern(String xpathPattern)

createPattern parses the given XPath expression to create an XSLT style Patterninstance which can then be used in an XSLT processing model.

Parameters:
xpathPattern - is the XPath pattern expression to create
Returns:
a new Pattern instance

selectNodes

public static List selectNodes(String xpathFilterExpression,
                               List nodes)

selectNodes performs the given XPath expression on the Listof Nodeinstances appending all the results together into a single list.

Parameters:
xpathFilterExpression - is the XPath filter expression to evaluate
nodes - is the list of nodes on which to evalute the XPath
Returns:
the results of all the XPath evaluations as a single list

selectNodes

public static List selectNodes(String xpathFilterExpression,
                               Node node)

selectNodes performs the given XPath expression on the Listof Nodeinstances appending all the results together into a single list.

Parameters:
xpathFilterExpression - is the XPath filter expression to evaluate
node - is the Node on which to evalute the XPath
Returns:
the results of all the XPath evaluations as a single list

sort

public static void sort(List list,
                        String xpathExpression)

sort sorts the given List of Nodes using an XPath expression as a Comparator.

Parameters:
list - is the list of Nodes to sort
xpathExpression - is the XPath expression used for comparison

sort

public static void sort(List list,
                        String expression,
                        boolean distinct)

sort sorts the given List of Nodes using an XPath expression as a Comparatorand optionally removing duplicates.

Parameters:
list - is the list of Nodes to sort
expression - is the XPath expression used for comparison
distinct - if true then duplicate values (using the sortXPath for comparisions) will be removed from the List

parseText

public static Document parseText(String text)
                          throws DocumentException

parseText parses the given text as an XML document and returns the newly created Document.

Parameters:
text - the XML text to be parsed
Returns:
a newly parsed Document
Throws:
DocumentException - if the document could not be parsed

makeElement

public static Element makeElement(Branch source,
                                  String path)

makeElement

a helper method which navigates from the given Document or Element node to some Element using the path expression, creating any necessary elements along the way. For example the path a/b/c would get the first child <a> element, which would be created if it did not exist, then the next child <b> and so on until finally a <c> element is returned.

Parameters:
source - is the Element or Document to start navigating from
path - is a simple path expression, seperated by '/' which denotes the path from the source to the resulting element such as a/b/c
Returns:
the first Element on the given path which either already existed on the path or were created by this method.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Namespace (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class Namespace

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.Namespace
All Implemented Interfaces:
Cloneable, Node, Serializable
Direct Known Subclasses:
DefaultNamespace
public class Namespace
extends AbstractNode

Namespace is a Flyweight Namespace that can be shared amongst nodes.

Version:
$Revision: 1.22 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static NamespaceCache | CACHE Cache of Namespace instances
static Namespace | NO_NAMESPACE No Namespace present
static Namespace | XML_NAMESPACE XML Namespace
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
Namespace(String prefix, String uri)
DOCUMENT ME!
Method Summary
void | accept(Visitor visitor) accept is the method used in the Visitor Pattern.
String | asXML() asXML returns the textual XML representation of this node.
protected int | createHashCode() Factory method to create the hashcode allowing derived classes to change the behaviour
protected Node | createXPathResult(Element parent)
boolean | equals(Object object) Checks whether this Namespace equals the given Namespace.
static Namespace | get(String uri) A helper method to return the Namespace instance for no prefix and the URI
static Namespace | get(String prefix, String uri) A helper method to return the Namespace instance for the given prefix and URI
short | getNodeType() Returns the code according to the type of node.
String | getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | getPrefix() DOCUMENT ME!
String | getStringValue() Returns the XPath string-value of this node.
String | getText() Returns the text of this node.
String | getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
String | getURI() DOCUMENT ME!
String | getXPathNameStep()
int | hashCode() DOCUMENT ME!
String | toString()
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

CACHE

protected static final NamespaceCache CACHE
Cache of Namespace instances

XML_NAMESPACE

public static final Namespace XML_NAMESPACE
XML Namespace

NO_NAMESPACE

public static final Namespace NO_NAMESPACE
No Namespace present

Constructor Detail

Namespace

public Namespace(String prefix,
                 String uri)
DOCUMENT ME!

Parameters:
prefix - is the prefix for this namespace
uri - is the URI for this namespace
Method Detail

get

public static Namespace get(String prefix,
                            String uri)
A helper method to return the Namespace instance for the given prefix and URI

Parameters:
prefix - DOCUMENT ME!
uri - DOCUMENT ME!
Returns:
an interned Namespace object

get

public static Namespace get(String uri)
A helper method to return the Namespace instance for no prefix and the URI

Parameters:
uri - DOCUMENT ME!
Returns:
an interned Namespace object

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

hashCode

public int hashCode()
DOCUMENT ME!

Returns:
the hash code based on the qualified name and the URI of the namespace.

createHashCode

protected int createHashCode()
Factory method to create the hashcode allowing derived classes to change the behaviour

Returns:
DOCUMENT ME!

equals

public boolean equals(Object object)
Checks whether this Namespace equals the given Namespace. Two Namespaces are equals if their URI and prefix are equal.

Parameters:
object - DOCUMENT ME!
Returns:
DOCUMENT ME!

getText

public String getText()
Description copied from interface: Node

Returns the text of this node.

Specified by:
getText in interface Node
Overrides:
getText in class AbstractNode

getStringValue

public String getStringValue()
Description copied from interface: Node
Returns the XPath string-value of this node. The behaviour of this method is defined in the XPath specification .

Specified by:
getStringValue in interface Node
Overrides:
getStringValue in class AbstractNode

getPrefix

public String getPrefix()
DOCUMENT ME!

Returns:
the prefix for this Namespace.

getURI

public String getURI()
DOCUMENT ME!

Returns:
the URI for this Namespace.

getXPathNameStep

public String getXPathNameStep()

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

toString

public String toString()

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Returns:
the XML representation of this node

accept

public void accept(Visitor visitor)
Description copied from interface: Node

accept is the method used in the Visitor Pattern.

Parameters:
visitor - is the visitor in the Visitor Pattern

createXPathResult

protected Node createXPathResult(Element parent)
Overrides:
createXPathResult in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QName (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class QName

java.lang.Object
    extended by org.dom4j.QName
All Implemented Interfaces:
Serializable
public class QName
extends Object
implements Serializable

QName represents a qualified name value of an XML element or attribute. It consists of a local name and a Namespaceinstance. This object is immutable.

Author:
James Strachan
See Also:
Serialized Form

Constructor Summary
QName(String name)
QName(String name, Namespace namespace)
QName(String name, Namespace namespace, String qualifiedName)
Method Summary
boolean | equals(Object object)
static QName | get(String name)
static QName | get(String name, Namespace namespace)
static QName | get(String localName, Namespace namespace, String qualifiedName)
static QName | get(String qualifiedName, String uri)
static QName | get(String name, String prefix, String uri)
DocumentFactory | getDocumentFactory() DOCUMENT ME!
String | getName() DOCUMENT ME!
Namespace | getNamespace() DOCUMENT ME!
String | getNamespacePrefix() DOCUMENT ME!
String | getNamespaceURI() DOCUMENT ME!
String | getQualifiedName() DOCUMENT ME!
int | hashCode() DOCUMENT ME!
void | setDocumentFactory(DocumentFactory documentFactory)
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

QName

public QName(String name)

QName

public QName(String name,
             Namespace namespace)

QName

public QName(String name,
             Namespace namespace,
             String qualifiedName)
Method Detail

get

public static QName get(String name)

get

public static QName get(String name,
                        Namespace namespace)

get

public static QName get(String name,
                        String prefix,
                        String uri)

get

public static QName get(String qualifiedName,
                        String uri)

get

public static QName get(String localName,
                        Namespace namespace,
                        String qualifiedName)

getName

public String getName()
DOCUMENT ME!

Returns:
the local name

getQualifiedName

public String getQualifiedName()
DOCUMENT ME!

Returns:
the qualified name in the format prefix:localName

getNamespace

public Namespace getNamespace()
DOCUMENT ME!

Returns:
the namespace of this QName

getNamespacePrefix

public String getNamespacePrefix()
DOCUMENT ME!

Returns:
the namespace URI of this QName

getNamespaceURI

public String getNamespaceURI()
DOCUMENT ME!

Returns:
the namespace URI of this QName

hashCode

public int hashCode()
DOCUMENT ME!

Returns:
the hash code based on the qualified name and the URI of the namespace.

equals

public boolean equals(Object object)

toString

public String toString()

getDocumentFactory

public DocumentFactory getDocumentFactory()
DOCUMENT ME!

Returns:
the factory that should be used for Elements of this QName

setDocumentFactory

public void setDocumentFactory(DocumentFactory documentFactory)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VisitorSupport (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class VisitorSupport

java.lang.Object
    extended by org.dom4j.VisitorSupport
All Implemented Interfaces:
Visitor
public abstract class VisitorSupport
extends Object
implements Visitor

VisitorSupport is an abstract base class which is useful for implementation inheritence or when using anonymous inner classes to create simple Visitor implementations.

Version:
$Revision: 1.6 $
Author:
James Strachan

Constructor Summary
VisitorSupport()
Method Summary
void | visit(Attribute node) Visits the given Attribute
void | visit(CDATA node) Visits the given CDATA
void | visit(Comment node) Visits the given Comment
void | visit(Document document) Visits the given Document
void | visit(DocumentType documentType) Visits the given DocumentType
void | visit(Element node) Visits the given Element
void | visit(Entity node) Visits the given Entity
void | visit(Namespace namespace) Visits the given Namespace
void | visit(ProcessingInstruction node) Visits the given ProcessingInstruction
void | visit(Text node) Visits the given Text
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VisitorSupport

public VisitorSupport()
Method Detail

visit

public void visit(Document document)
Description copied from interface: Visitor

Visits the given Document

Specified by:
visit in interface Visitor
Parameters:
document - is the Document node to visit.

visit

public void visit(DocumentType documentType)
Description copied from interface: Visitor

Visits the given DocumentType

Specified by:
visit in interface Visitor
Parameters:
documentType - is the DocumentType node to visit.

visit

public void visit(Element node)
Description copied from interface: Visitor

Visits the given Element

Specified by:
visit in interface Visitor
Parameters:
node - is the Element node to visit.

visit

public void visit(Attribute node)
Description copied from interface: Visitor

Visits the given Attribute

Specified by:
visit in interface Visitor
Parameters:
node - is the Attribute node to visit.

visit

public void visit(CDATA node)
Description copied from interface: Visitor

Visits the given CDATA

Specified by:
visit in interface Visitor
Parameters:
node - is the CDATA node to visit.

visit

public void visit(Comment node)
Description copied from interface: Visitor

Visits the given Comment

Specified by:
visit in interface Visitor
Parameters:
node - is the Comment node to visit.

visit

public void visit(Entity node)
Description copied from interface: Visitor

Visits the given Entity

Specified by:
visit in interface Visitor
Parameters:
node - is the Entity node to visit.

visit

public void visit(Namespace namespace)
Description copied from interface: Visitor

Visits the given Namespace

Specified by:
visit in interface Visitor
Parameters:
namespace - is the Namespace node to visit.

visit

public void visit(ProcessingInstruction node)
Description copied from interface: Visitor

Visits the given ProcessingInstruction

Specified by:
visit in interface Visitor
Parameters:
node - is the ProcessingInstruction node to visit.

visit

public void visit(Text node)
Description copied from interface: Visitor

Visits the given Text

Specified by:
visit in interface Visitor
Parameters:
node - is the Text node to visit.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DocumentException (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class DocumentException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by org.dom4j.DocumentException
All Implemented Interfaces:
Serializable
public class DocumentException
extends Exception

DocumentException is a nested Exception which may be thrown during the processing of a DOM4J document.

Version:
$Revision: 1.7 $
Author:
James Strachan
See Also:
Serialized Form

Constructor Summary
DocumentException()
DocumentException(String message)
DocumentException(String message, Throwable nestedException)
DocumentException(Throwable nestedException)
Method Summary
String | getMessage()
Throwable | getNestedException()
void | printStackTrace()
void | printStackTrace(PrintStream out)
void | printStackTrace(PrintWriter writer)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DocumentException

public DocumentException()

DocumentException

public DocumentException(String message)

DocumentException

public DocumentException(Throwable nestedException)

DocumentException

public DocumentException(String message,
                         Throwable nestedException)
Method Detail

getNestedException

public Throwable getNestedException()

getMessage

public String getMessage()

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream out)

printStackTrace

public void printStackTrace(PrintWriter writer)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


IllegalAddException (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class IllegalAddException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by java.lang.IllegalArgumentException
                    extended by org.dom4j.IllegalAddException
All Implemented Interfaces:
Serializable
public class IllegalAddException
extends IllegalArgumentException

IllegalAddException is thrown when a node is added incorrectly to an Element

Version:
$Revision: 1.6 $
See Also:
Serialized Form

Constructor Summary
IllegalAddException(Branch parent, Node node, String reason)
IllegalAddException(Element parent, Node node, String reason)
IllegalAddException(String reason)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

IllegalAddException

public IllegalAddException(String reason)

IllegalAddException

public IllegalAddException(Element parent,
                           Node node,
                           String reason)

IllegalAddException

public IllegalAddException(Branch parent,
                           Node node,
                           String reason)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InvalidXPathException (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class InvalidXPathException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by java.lang.IllegalArgumentException
                    extended by org.dom4j.InvalidXPathException
All Implemented Interfaces:
Serializable
public class InvalidXPathException
extends IllegalArgumentException

InvalidXPathException is thrown when an invalid XPath expression is used to traverse an XML document

Version:
$Revision: 1.6.2.1 $
See Also:
Serialized Form

Constructor Summary
InvalidXPathException(String xpath)
InvalidXPathException(String xpath, String reason)
InvalidXPathException(String xpath, Throwable t)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidXPathException

public InvalidXPathException(String xpath)

InvalidXPathException

public InvalidXPathException(String xpath,
                             String reason)

InvalidXPathException

public InvalidXPathException(String xpath,
                             Throwable t)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XPathException (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j
Class XPathException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by org.dom4j.XPathException
All Implemented Interfaces:
Serializable
public class XPathException
extends RuntimeException

XPathException is thrown when an exception occurs while evaluating an XPath expression, usually due to some function throwing an exception.

Version:
$Revision: 1.6 $
See Also:
Serialized Form

Constructor Summary
XPathException(String xpath)
XPathException(String xpath, Exception e)
XPathException(String xpath, String reason)
Method Summary
 String getXPath()
Returns the XPath expression that caused the problem
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XPathException

public XPathException(String xpath)

XPathException

public XPathException(String xpath,
                      String reason)

XPathException

public XPathException(String xpath,
                      Exception e)
Method Detail

getXPath

public String getXPath()
Returns the XPath expression that caused the problem

Returns:
DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.bean (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.bean

An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.

See:
Description

Class Summary
BeanAttribute | BeanAttribute represents a mutable XML attribute which is backed by a property of the JavaBean of its parent element.
BeanAttributeList | BeanAttributeList implements a list of Attributes which are the properties of a JavaBean.
BeanDocumentFactory | BeanDocumentFactory is a factory of DOM4J objects which may be BeanElements which are backed by JavaBeans and their properties.
BeanElement | BeanElement uses a Java Bean to store its attributes.
BeanMetaData | BeanMetaData contains metadata about a bean class.

Package org.dom4j.bean Description

An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.

Overview Package Class Use Tree Deprecated Index Help


org.dom4j.bean Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.bean

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class org.dom4j.bean.BeanAttributeList
    • class org.dom4j.tree.AbstractNode (implements java.lang.Cloneable, org.dom4j.Node, java.io.Serializable)
      • class org.dom4j.tree.AbstractAttribute (implements org.dom4j.Attribute)
        • class org.dom4j.bean.BeanAttribute
      • class org.dom4j.tree.AbstractBranch (implements org.dom4j.Branch)
        • class org.dom4j.tree.AbstractElement (implements org.dom4j.Element)
          • class org.dom4j.tree.DefaultElement
            • class org.dom4j.bean.BeanElement
    • class org.dom4j.bean.BeanMetaData
    • class org.dom4j.DocumentFactory (implements java.io.Serializable)
      • class org.dom4j.bean.BeanDocumentFactory


Uses of Package org.dom4j.bean (dom4j 1.6.1 API)

Uses of Package
org.dom4j.bean

Packages that use org.dom4j.bean
org.dom4j.bean An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.

Classes in org.dom4j.bean used by org.dom4j.bean
BeanAttribute
BeanAttribute represents a mutable XML attribute which is backed by a property of the JavaBean of its parent element.
BeanAttributeList
BeanAttributeList implements a list of Attributes which are the properties of a JavaBean.
BeanElement
BeanElement uses a Java Bean to store its attributes.
BeanMetaData
BeanMetaData contains metadata about a bean class.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BeanAttribute (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.bean
Class BeanAttribute

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractAttribute
            extended by org.dom4j.bean.BeanAttribute
All Implemented Interfaces:
Attribute, Cloneable, Node, Serializable
public class BeanAttribute
extends AbstractAttribute

BeanAttribute represents a mutable XML attribute which is backed by a property of the JavaBean of its parent element.

Version:
$Revision: 1.7 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
BeanAttribute(BeanAttributeList beanList, int index)
Method Summary
 Object getData()
Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node#getText().
 Element getParent()
getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
 QName getQName()
Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.
 String getValue()
Returns the value of the attribute.
 void setData(Object data)
Sets the data value of this attribute if this element supports data binding or calls Node#setText(String)if it doesn't.
 void setValue(String data)
Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.
Methods inherited from class org.dom4j.tree.AbstractAttribute
accept, asXML, createXPathResult, getName, getNamespace, getNamespacePrefix, getNamespaceURI, getNodeType, getPath, getQualifiedName, getText, getUniquePath, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, supportsParent, valueOf

Constructor Detail

BeanAttribute

public BeanAttribute(BeanAttributeList beanList,
                     int index)
Method Detail

getQName

public QName getQName()
Description copied from interface: Attribute

Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.

Returns:
the QName associated with this attribute

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

getValue

public String getValue()
Description copied from interface: Attribute

Returns the value of the attribute. This method returns the same value as the Node.getText()method.

Returns:
the value of the attribute

setValue

public void setValue(String data)
Description copied from interface: Attribute

Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setValue in interface Attribute
Overrides:
setValue in class AbstractAttribute

getData

public Object getData()
Description copied from interface: Attribute

Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node.getText().

Specified by:
getData in interface Attribute
Overrides:
getData in class AbstractAttribute

setData

public void setData(Object data)
Description copied from interface: Attribute

Sets the data value of this attribute if this element supports data binding or calls Node.setText(String)if it doesn't.

Specified by:
setData in interface Attribute
Overrides:
setData in class AbstractAttribute
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


BeanAttributeList (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.bean
Class BeanAttributeList

java.lang.Object
    extended by java.util.AbstractCollection
        extended by java.util.AbstractList
            extended by org.dom4j.bean.BeanAttributeList
All Implemented Interfaces:
Collection, List
public class BeanAttributeList
extends AbstractList

BeanAttributeList implements a list of Attributes which are the properties of a JavaBean.

Version:
$Revision: 1.9 $
Author:
James Strachan

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
BeanAttributeList(BeanElement parent)
BeanAttributeList(BeanElement parent, BeanMetaData beanMetaData)
Method Summary
void | add(int index, Object object)
boolean | add(Object object)
BeanAttribute | attribute(int index)
Attribute | attribute(QName qname)
Attribute | attribute(String name)
void | clear()
protected BeanAttribute | createAttribute(BeanElement element, int index)
Object | get(int index)
Object | getData(int index)
BeanElement | getParent()
QName | getQName(int index)
Object | remove(int index)
boolean | remove(Object object)
Object | set(int index, Object object)
void | setData(int index, Object data)
int | size()
Methods inherited from class java.util.AbstractList
addAll, equals, hashCode, indexOf, iterator, lastIndexOf, listIterator, listIterator, removeRange, subList
Methods inherited from class java.util.AbstractCollection
addAll, contains, containsAll, isEmpty, removeAll, retainAll, toArray, toArray, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
addAll, contains, containsAll, isEmpty, removeAll, retainAll, toArray, toArray

Constructor Detail

BeanAttributeList

public BeanAttributeList(BeanElement parent,
                         BeanMetaData beanMetaData)

BeanAttributeList

public BeanAttributeList(BeanElement parent)
Method Detail

attribute

public Attribute attribute(String name)

attribute

public Attribute attribute(QName qname)

attribute

public BeanAttribute attribute(int index)

getParent

public BeanElement getParent()

getQName

public QName getQName(int index)

getData

public Object getData(int index)

setData

public void setData(int index,
                    Object data)

size

public int size()

get

public Object get(int index)

add

public boolean add(Object object)

add

public void add(int index,
                Object object)

set

public Object set(int index,
                  Object object)

remove

public boolean remove(Object object)

remove

public Object remove(int index)

clear

public void clear()

createAttribute

protected BeanAttribute createAttribute(BeanElement element,
                                        int index)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BeanDocumentFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.bean
Class BeanDocumentFactory

java.lang.Object
    extended by org.dom4j.DocumentFactory
        extended by org.dom4j.bean.BeanDocumentFactory
All Implemented Interfaces:
Serializable
public class BeanDocumentFactory
extends DocumentFactory

BeanDocumentFactory is a factory of DOM4J objects which may be BeanElements which are backed by JavaBeans and their properties.

The tree built allows full XPath expressions from anywhere on the tree.

Version:
$Revision: 1.14 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.DocumentFactory
cache
Constructor Summary
BeanDocumentFactory()
Method Summary
Attribute | createAttribute(Element owner, QName qname, String value)
protected Object | createBean(QName qname)
protected Object | createBean(QName qname, Attributes attributes)
Element | createElement(QName qname)
Element | createElement(QName qname, Attributes attributes)
static DocumentFactory | getInstance() Access to the singleton instance of this factory.
protected void | handleException(Exception e)
Methods inherited from class org.dom4j.DocumentFactory
createAttribute, createCDATA, createComment, createDocType, createDocument, createDocument, createDocument, createElement, createElement, createEntity, createNamespace, createPattern, createProcessingInstruction, createProcessingInstruction, createQName, createQName, createQName, createQName, createQNameCache, createSingleton, createText, createXPath, createXPath, createXPathFilter, createXPathFilter, getQNames, getXPathNamespaceURIs, init, intern, setXPathNamespaceURIs
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

BeanDocumentFactory

public BeanDocumentFactory()
Method Detail

getInstance

public static DocumentFactory getInstance()

Access to the singleton instance of this factory.

Returns:
the default singleon instance

createElement

public Element createElement(QName qname)
Overrides:
createElement in class DocumentFactory

createElement

public Element createElement(QName qname,
                             Attributes attributes)

createAttribute

public Attribute createAttribute(Element owner,
                                 QName qname,
                                 String value)
Overrides:
createAttribute in class DocumentFactory

createBean

protected Object createBean(QName qname)

createBean

protected Object createBean(QName qname,
                            Attributes attributes)

handleException

protected void handleException(Exception e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BeanElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.bean
Class BeanElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
                extended by org.dom4j.tree.DefaultElement
                    extended by org.dom4j.bean.BeanElement
All Implemented Interfaces:
Branch, Cloneable, Element, Node, Serializable
public class BeanElement
extends DefaultElement

BeanElement uses a Java Bean to store its attributes.

Version:
$Revision: 1.15 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR, EMPTY_LIST, USE_STRINGVALUE_SEPARATOR, VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
BeanElement(QName qname)
BeanElement(QName qname, Object bean)
BeanElement(String name, Namespace namespace, Object bean)
BeanElement(String name, Object bean)
Method Summary
Element | addAttribute(QName qName, String value) Adds the attribute value of the given fully qualified name.
Element | addAttribute(String name, String value) Adds the attribute value of the given local name.
Attribute | attribute(QName qname) DOCUMENT ME!
Attribute | attribute(String name) Returns the attribute with the given name
protected List | createAttributeList() A Factory Method pattern which lazily creates a List implementation used to store content
protected List | createAttributeList(int size) A Factory Method pattern which creates a List implementation used to store attributes
protected BeanAttributeList | getBeanAttributeList()
Object | getData() DOCUMENT ME!
protected DocumentFactory | getDocumentFactory()
void | setAttributes(Attributes attributes, NamespaceStack namespaceStack, boolean noNamespaceAttributes) This method provides a more optimal way of setting all the attributes on an Element particularly for use in SAXReader.
void | setAttributes(List attributes) Sets the attributes that this element contains
void | setData(Object data) Sets the data value of this element if this element supports data binding or calls AbstractElement.setText(java.lang.String)if it doesn't
Methods inherited from class org.dom4j.tree.DefaultElement
add, additionalNamespaces, additionalNamespaces, addNewNode, attribute, attribute, attributeCount, attributeIterator, attributeList, attributeList, attributes, clearContent, clone, contentList, declaredNamespaces, element, element, element, getDocument, getNamespaceForPrefix, getNamespaceForURI, getParent, getQName, getStringValue, getText, indexOf, node, nodeCount, nodeIterator, processingInstruction, processingInstructions, processingInstructions, remove, removeNode, removeProcessingInstruction, setAttributeList, setContent, setDocument, setParent, setQName, supportsParent
Methods inherited from class org.dom4j.tree.AbstractElement
accept, add, add, add, add, add, add, add, add, addCDATA, addComment, addElement, addEntity, addNamespace, addNewNode, addNode, addNode, addProcessingInstruction, addProcessingInstruction, addText, appendAttributes, asXML, attributeValue, attributeValue, attributeValue, attributeValue, childAdded, childRemoved, createCopy, createCopy, createCopy, createElement, createElement, createSingleIterator, elementIterator, elementIterator, elementIterator, elementIterator, elements, elements, elements, elements, elementText, elementText, elementTextTrim, elementTextTrim, ensureAttributesCapacity, getName, getNamespace, getNamespacePrefix, getNamespacesForURI, getNamespaceURI, getNodeType, getPath, getQName, getQualifiedName, getUniquePath, getXPathNameStep, getXPathResult, hasMixedContent, isRootElement, isTextOnly, normalize, remove, remove, remove, remove, remove, remove, remove, remove, setAttributeValue, setAttributeValue, setName, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Element
getTextTrim
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, content, elementByID, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, createXPath, detach, getNodeTypeName, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf

Constructor Detail

BeanElement

public BeanElement(String name,
                   Object bean)

BeanElement

public BeanElement(String name,
                   Namespace namespace,
                   Object bean)

BeanElement

public BeanElement(QName qname,
                   Object bean)

BeanElement

public BeanElement(QName qname)
Method Detail

getData

public Object getData()
DOCUMENT ME!

Specified by:
getData in interface Element
Overrides:
getData in class AbstractElement
Returns:
the JavaBean associated with this element

setData

public void setData(Object data)
Description copied from interface: Element
Sets the data value of this element if this element supports data binding or calls Node.setText(java.lang.String)if it doesn't

Specified by:
setData in interface Element
Overrides:
setData in class AbstractElement

attribute

public Attribute attribute(String name)
Description copied from interface: Element
Returns the attribute with the given name

Specified by:
attribute in interface Element
Overrides:
attribute in class DefaultElement

attribute

public Attribute attribute(QName qname)
Description copied from interface: Element
DOCUMENT ME!

Specified by:
attribute in interface Element
Overrides:
attribute in class DefaultElement

addAttribute

public Element addAttribute(String name,
                            String value)
Description copied from interface: Element

Adds the attribute value of the given local name. If an attribute already exists for the given name it will be replaced. Attributes with null values are silently ignored. If the value of the attribute is null then this method call will remove any attributes with the given name.

Specified by:
addAttribute in interface Element
Overrides:
addAttribute in class AbstractElement

addAttribute

public Element addAttribute(QName qName,
                            String value)
Description copied from interface: Element

Adds the attribute value of the given fully qualified name. If an attribute already exists for the given name it will be replaced. Attributes with null values are silently ignored. If the value of the attribute is null then this method call will remove any attributes with the given name.

Specified by:
addAttribute in interface Element
Overrides:
addAttribute in class AbstractElement

setAttributes

public void setAttributes(List attributes)
Description copied from interface: Element
Sets the attributes that this element contains

Specified by:
setAttributes in interface Element
Overrides:
setAttributes in class DefaultElement

setAttributes

public void setAttributes(Attributes attributes,
                          NamespaceStack namespaceStack,
                          boolean noNamespaceAttributes)
Description copied from class: AbstractElement
This method provides a more optimal way of setting all the attributes on an Element particularly for use in SAXReader.

Overrides:
setAttributes in class AbstractElement
Parameters:
attributes - DOCUMENT ME!
namespaceStack - DOCUMENT ME!
noNamespaceAttributes - DOCUMENT ME!

getDocumentFactory

protected DocumentFactory getDocumentFactory()
Overrides:
getDocumentFactory in class DefaultElement

getBeanAttributeList

protected BeanAttributeList getBeanAttributeList()

createAttributeList

protected List createAttributeList()
A Factory Method pattern which lazily creates a List implementation used to store content

Overrides:
createAttributeList in class AbstractElement
Returns:
DOCUMENT ME!

createAttributeList

protected List createAttributeList(int size)
Description copied from class: AbstractElement
A Factory Method pattern which creates a List implementation used to store attributes

Overrides:
createAttributeList in class AbstractElement
Parameters:
size - DOCUMENT ME!
Returns:
DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BeanMetaData (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.bean
Class BeanMetaData

java.lang.Object
    extended by org.dom4j.bean.BeanMetaData
public class BeanMetaData
extends Object

BeanMetaData contains metadata about a bean class.

Version:
$Revision: 1.10 $
Author:
James Strachan

Field Summary
protected static Object[] NULL_ARGS
Empty arguments for reflection calls
Constructor Summary
BeanMetaData(Class beanClass)
Method Summary
int | attributeCount() DOCUMENT ME!
BeanAttributeList | createAttributeList(BeanElement parent)
static BeanMetaData | get(Class beanClass) Static helper method to find and cache meta data objects for bean types
Object | getData(int index, Object bean)
int | getIndex(QName qName)
int | getIndex(String name)
QName | getQName(int index)
protected void | handleException(Exception e)
void | setData(int index, Object bean, Object data)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

NULL_ARGS

protected static final Object[] NULL_ARGS
Empty arguments for reflection calls

Constructor Detail

BeanMetaData

public BeanMetaData(Class beanClass)
Method Detail

get

public static BeanMetaData get(Class beanClass)
Static helper method to find and cache meta data objects for bean types

Parameters:
beanClass - DOCUMENT ME!
Returns:
DOCUMENT ME!

attributeCount

public int attributeCount()
DOCUMENT ME!

Returns:
the number of attribtutes for this bean type

createAttributeList

public BeanAttributeList createAttributeList(BeanElement parent)

getQName

public QName getQName(int index)

getIndex

public int getIndex(String name)

getIndex

public int getIndex(QName qName)

getData

public Object getData(int index,
                      Object bean)

setData

public void setData(int index,
                    Object bean,
                    Object data)

handleException

protected void handleException(Exception e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.datatype (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.datatype

An implementation of the dom4j API which supports the XML Schema Data Types specification.

See:
Description

Class Summary
DatatypeAttribute | DatatypeAttribute represents an Attribute which supports the XML Schema Data Types specification.
DatatypeDocumentFactory | DatatypeDocumentFactory is a factory of XML objects which support the XML Schema Data Types specification.
DatatypeElement | DatatypeElement represents an Element which supports the XML Schema Data Types specification.
DatatypeElementFactory | DatatypeElementFactory is a factory for a specific Element in an XML Schema.
SchemaParser | SchemaParser reads an XML Schema Document.

Exception Summary
InvalidSchemaException InvalidSchemaException is thrown when an invalid XML Schema document is used

Package org.dom4j.datatype Description

An implementation of the dom4j API which supports the XML Schema Data Types specification.


org.dom4j.datatype Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.datatype

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.tree.AbstractNode (implements java.lang.Cloneable, org.dom4j.Node, java.io.Serializable)
      • class org.dom4j.tree.AbstractAttribute (implements org.dom4j.Attribute)
        • class org.dom4j.datatype.DatatypeAttribute (implements com.sun.msv.datatype.SerializationContext, org.relaxng.datatype.ValidationContext)
      • class org.dom4j.tree.AbstractBranch (implements org.dom4j.Branch)
        • class org.dom4j.tree.AbstractElement (implements org.dom4j.Element)
          • class org.dom4j.tree.DefaultElement
            • class org.dom4j.datatype.DatatypeElement (implements com.sun.msv.datatype.SerializationContext, org.relaxng.datatype.ValidationContext)
    • class org.dom4j.DocumentFactory (implements java.io.Serializable)
      • class org.dom4j.datatype.DatatypeDocumentFactory
      • class org.dom4j.datatype.DatatypeElementFactory
    • class org.dom4j.datatype.SchemaParser
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class java.lang.IllegalArgumentException
            • class org.dom4j.datatype.InvalidSchemaException


Uses of Package org.dom4j.datatype (dom4j 1.6.1 API)

Uses of Package
org.dom4j.datatype

Packages that use org.dom4j.datatype
org.dom4j.datatype An implementation of the dom4j API which supports the XML Schema Data Types specification.

Classes in org.dom4j.datatype used by org.dom4j.datatype
DatatypeDocumentFactory
DatatypeDocumentFactory is a factory of XML objects which support the XML Schema Data Types specification.
DatatypeElementFactory
DatatypeElementFactory is a factory for a specific Element in an XML Schema.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DatatypeAttribute (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.datatype
Class DatatypeAttribute

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractAttribute
            extended by org.dom4j.datatype.DatatypeAttribute
All Implemented Interfaces:
Attribute, Cloneable, Node, Serializable, com.sun.msv.datatype.SerializationContext, org.relaxng.datatype.ValidationContext
public class DatatypeAttribute
extends AbstractAttribute
implements com.sun.msv.datatype.SerializationContext, org.relaxng.datatype.ValidationContext

DatatypeAttribute represents an Attribute which supports the XML Schema Data Types specification.

Version:
$Revision: 1.9 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DatatypeAttribute(QName qname, com.sun.msv.datatype.xsd.XSDatatype datatype)
DatatypeAttribute(QName qname, com.sun.msv.datatype.xsd.XSDatatype datatype, String text)
Method Summary
protected  Object convertToValue(String txt)
 String getBaseUri()
 Object getData()
Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node#getText().
 String getNamespacePrefix(String uri)
 Element getParent()
getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
 QName getQName()
Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.
 String getValue()
Returns the value of the attribute.
 com.sun.msv.datatype.xsd.XSDatatype getXSDatatype()
Returns the MSV XSDatatype for this node
 boolean isNotation(String notationName)
 boolean isReadOnly()
isReadOnly returns true if this node is read only and cannot be modified.
 boolean isUnparsedEntity(String entityName)
 String resolveNamespacePrefix(String prefix)
 void setData(Object data)
Sets the data value of this attribute if this element supports data binding or calls Node#setText(String)if it doesn't.
 void setParent(Element parent)
setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
 void setValue(String value)
Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.
 boolean supportsParent()
supportsParent returns true if this node supports the parent relationship.
 String toString()
protected  void validate(String txt)
Methods inherited from class org.dom4j.tree.AbstractAttribute
accept, asXML, createXPathResult, getName, getNamespace, getNamespacePrefix, getNamespaceURI, getNodeType, getPath, getQualifiedName, getText, getUniquePath, setNamespace, setText, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf

Constructor Detail

DatatypeAttribute

public DatatypeAttribute(QName qname,
                         com.sun.msv.datatype.xsd.XSDatatype datatype)

DatatypeAttribute

public DatatypeAttribute(QName qname,
                         com.sun.msv.datatype.xsd.XSDatatype datatype,
                         String text)
Method Detail

toString

public String toString()
Overrides:
toString in class AbstractAttribute

getXSDatatype

public com.sun.msv.datatype.xsd.XSDatatype getXSDatatype()
Returns the MSV XSDatatype for this node

Returns:
DOCUMENT ME!

getNamespacePrefix

public String getNamespacePrefix(String uri)
Specified by:
getNamespacePrefix in interface com.sun.msv.datatype.SerializationContext

getBaseUri

public String getBaseUri()
Specified by:
getBaseUri in interface org.relaxng.datatype.ValidationContext

isNotation

public boolean isNotation(String notationName)
Specified by:
isNotation in interface org.relaxng.datatype.ValidationContext

isUnparsedEntity

public boolean isUnparsedEntity(String entityName)
Specified by:
isUnparsedEntity in interface org.relaxng.datatype.ValidationContext

resolveNamespacePrefix

public String resolveNamespacePrefix(String prefix)
Specified by:
resolveNamespacePrefix in interface org.relaxng.datatype.ValidationContext

getQName

public QName getQName()
Description copied from interface: Attribute

Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.

Specified by:
getQName in interface Attribute
Returns:
the QName associated with this attribute

getValue

public String getValue()
Description copied from interface: Attribute

Returns the value of the attribute. This method returns the same value as the Node.getText()method.

Specified by:
getValue in interface Attribute
Returns:
the value of the attribute

setValue

public void setValue(String value)
Description copied from interface: Attribute

Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setValue in interface Attribute
Overrides:
setValue in class AbstractAttribute

getData

public Object getData()
Description copied from interface: Attribute

Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node.getText().

Specified by:
getData in interface Attribute
Overrides:
getData in class AbstractAttribute

setData

public void setData(Object data)
Description copied from interface: Attribute

Sets the data value of this attribute if this element supports data binding or calls Node.setText(String)if it doesn't.

Specified by:
setData in interface Attribute
Overrides:
setData in class AbstractAttribute

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode

validate

protected void validate(String txt)
                 throws IllegalArgumentException
Throws:
IllegalArgumentException

convertToValue

protected Object convertToValue(String txt)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DatatypeDocumentFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.datatype
Class DatatypeDocumentFactory

java.lang.Object
    extended by org.dom4j.DocumentFactory
        extended by org.dom4j.datatype.DatatypeDocumentFactory
All Implemented Interfaces:
Serializable
public class DatatypeDocumentFactory
extends DocumentFactory

DatatypeDocumentFactory is a factory of XML objects which support the XML Schema Data Types specification.

Version:
$Revision: 1.9 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static DatatypeDocumentFactory singleton
The Singleton instance
Fields inherited from class org.dom4j.DocumentFactory
cache
Constructor Summary
DatatypeDocumentFactory()
Method Summary
Attribute | createAttribute(Element owner, QName qname, String value)
DatatypeElementFactory | getElementFactory(QName elementQName) Registers the given DatatypeElementFactory for the given <element> schema element
static DocumentFactory | getInstance() Access to the singleton instance of this factory.
void | loadSchema(Document schemaDocument) Loads the given XML Schema document into this factory so schema-aware Document, Elements and Attributes will be created by this factory.
void | loadSchema(Document schemaDocument, Namespace targetNamespace)
protected void | loadSchema(Document document, String schemaInstanceURI)
protected void | loadSchema(Document document, String schemaInstanceURI, Namespace namespace)
Methods inherited from class org.dom4j.DocumentFactory
createAttribute, createCDATA, createComment, createDocType, createDocument, createDocument, createDocument, createElement, createElement, createElement, createEntity, createNamespace, createPattern, createProcessingInstruction, createProcessingInstruction, createQName, createQName, createQName, createQName, createQNameCache, createSingleton, createText, createXPath, createXPath, createXPathFilter, createXPathFilter, getQNames, getXPathNamespaceURIs, init, intern, setXPathNamespaceURIs
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

singleton

protected static transient DatatypeDocumentFactory singleton
The Singleton instance

Constructor Detail

DatatypeDocumentFactory

public DatatypeDocumentFactory()
Method Detail

getInstance

public static DocumentFactory getInstance()

Access to the singleton instance of this factory.

Returns:
the default singleon instance

loadSchema

public void loadSchema(Document schemaDocument)
Loads the given XML Schema document into this factory so schema-aware Document, Elements and Attributes will be created by this factory.

Parameters:
schemaDocument - is an XML Schema Document instance.

loadSchema

public void loadSchema(Document schemaDocument,
                       Namespace targetNamespace)

getElementFactory

public DatatypeElementFactory getElementFactory(QName elementQName)
Registers the given DatatypeElementFactory for the given <element> schema element

Parameters:
elementQName - DOCUMENT ME!
Returns:
DOCUMENT ME!

createAttribute

public Attribute createAttribute(Element owner,
                                 QName qname,
                                 String value)
Overrides:
createAttribute in class DocumentFactory

loadSchema

protected void loadSchema(Document document,
                          String schemaInstanceURI)

loadSchema

protected void loadSchema(Document document,
                          String schemaInstanceURI,
                          Namespace namespace)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatatypeElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.datatype
Class DatatypeElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
                extended by org.dom4j.tree.DefaultElement
                    extended by org.dom4j.datatype.DatatypeElement
All Implemented Interfaces:
Branch, Cloneable, Element, Node, Serializable, com.sun.msv.datatype.SerializationContext, org.relaxng.datatype.ValidationContext
public class DatatypeElement
extends DefaultElement
implements com.sun.msv.datatype.SerializationContext, org.relaxng.datatype.ValidationContext

DatatypeElement represents an Element which supports the XML Schema Data Types specification.

Version:
$Revision: 1.9 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR, EMPTY_LIST, USE_STRINGVALUE_SEPARATOR, VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DatatypeElement(QName qname, int attributeCount, com.sun.msv.datatype.xsd.XSDatatype type)
DatatypeElement(QName qname, com.sun.msv.datatype.xsd.XSDatatype datatype)
Method Summary
 Element addText(String text)
Adds a new Text node with the given text to this element.
protected  void childAdded(Node node)
Override to force lazy recreation of data object
protected  void childRemoved(Node node)
Override to force lazy recreation of data object
 String getBaseUri()
 Object getData()
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as DefaultElement.getText()
 String getNamespacePrefix(String uri)
 com.sun.msv.datatype.xsd.XSDatatype getXSDatatype()
Returns the MSV XSDatatype for this node
 boolean isNotation(String notationName)
 boolean isUnparsedEntity(String entityName)
 String resolveNamespacePrefix(String prefix)
 void setData(Object data)
Sets the data value of this element if this element supports data binding or calls setText(java.lang.String)if it doesn't
 void setText(String text)
Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
 String toString()
protected  void validate(String text)
Methods inherited from class org.dom4j.tree.DefaultElement
add, additionalNamespaces, additionalNamespaces, addNewNode, attribute, attribute, attribute, attribute, attributeCount, attributeIterator, attributeList, attributeList, attributes, clearContent, clone, contentList, declaredNamespaces, element, element, element, getDocument, getDocumentFactory, getNamespaceForPrefix, getNamespaceForURI, getParent, getQName, getStringValue, getText, indexOf, node, nodeCount, nodeIterator, processingInstruction, processingInstructions, processingInstructions, remove, removeNode, removeProcessingInstruction, setAttributeList, setAttributes, setContent, setDocument, setParent, setQName, supportsParent
Methods inherited from class org.dom4j.tree.AbstractElement
accept, add, add, add, add, add, add, add, add, addAttribute, addAttribute, addCDATA, addComment, addElement, addEntity, addNamespace, addNewNode, addNode, addNode, addProcessingInstruction, addProcessingInstruction, appendAttributes, asXML, attributeValue, attributeValue, attributeValue, attributeValue, createAttributeList, createAttributeList, createCopy, createCopy, createCopy, createElement, createElement, createSingleIterator, elementIterator, elementIterator, elementIterator, elementIterator, elements, elements, elements, elements, elementText, elementText, elementTextTrim, elementTextTrim, ensureAttributesCapacity, getName, getNamespace, getNamespacePrefix, getNamespacesForURI, getNamespaceURI, getNodeType, getPath, getQName, getQualifiedName, getUniquePath, getXPathNameStep, getXPathResult, hasMixedContent, isRootElement, isTextOnly, normalize, remove, remove, remove, remove, remove, remove, remove, remove, setAttributes, setAttributeValue, setAttributeValue, setName, setNamespace, write
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Element
getTextTrim
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, content, elementByID, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, createXPath, detach, getNodeTypeName, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf

Constructor Detail

DatatypeElement

public DatatypeElement(QName qname,
                       com.sun.msv.datatype.xsd.XSDatatype datatype)

DatatypeElement

public DatatypeElement(QName qname,
                       int attributeCount,
                       com.sun.msv.datatype.xsd.XSDatatype type)
Method Detail

toString

public String toString()
Overrides:
toString in class AbstractElement

getXSDatatype

public com.sun.msv.datatype.xsd.XSDatatype getXSDatatype()
Returns the MSV XSDatatype for this node

Returns:
DOCUMENT ME!

getNamespacePrefix

public String getNamespacePrefix(String uri)
Specified by:
getNamespacePrefix in interface com.sun.msv.datatype.SerializationContext

getBaseUri

public String getBaseUri()
Specified by:
getBaseUri in interface org.relaxng.datatype.ValidationContext

isNotation

public boolean isNotation(String notationName)
Specified by:
isNotation in interface org.relaxng.datatype.ValidationContext

isUnparsedEntity

public boolean isUnparsedEntity(String entityName)
Specified by:
isUnparsedEntity in interface org.relaxng.datatype.ValidationContext

resolveNamespacePrefix

public String resolveNamespacePrefix(String prefix)
Specified by:
resolveNamespacePrefix in interface org.relaxng.datatype.ValidationContext

getData

public Object getData()
Description copied from interface: Element
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Element.getText()

Specified by:
getData in interface Element
Overrides:
getData in class AbstractElement

setData

public void setData(Object data)
Description copied from interface: Element
Sets the data value of this element if this element supports data binding or calls Node.setText(java.lang.String)if it doesn't

Specified by:
setData in interface Element
Overrides:
setData in class AbstractElement

addText

public Element addText(String text)
Description copied from interface: Element
Adds a new Text node with the given text to this element.

Specified by:
addText in interface Element
Overrides:
addText in class AbstractElement

setText

public void setText(String text)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setText in interface Node
Overrides:
setText in class AbstractElement

childAdded

protected void childAdded(Node node)
Override to force lazy recreation of data object

Overrides:
childAdded in class AbstractElement
Parameters:
node - DOCUMENT ME!

childRemoved

protected void childRemoved(Node node)
Override to force lazy recreation of data object

Overrides:
childRemoved in class AbstractElement
Parameters:
node - DOCUMENT ME!

validate

protected void validate(String text)
                 throws IllegalArgumentException
Throws:
IllegalArgumentException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DatatypeElementFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.datatype
Class DatatypeElementFactory

java.lang.Object
    extended by org.dom4j.DocumentFactory
        extended by org.dom4j.datatype.DatatypeElementFactory
All Implemented Interfaces:
Serializable
public class DatatypeElementFactory
extends DocumentFactory

DatatypeElementFactory is a factory for a specific Element in an XML Schema.

Version:
$Revision: 1.9 $
Author:
James Strachan , Yuxin Ruan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.DocumentFactory
cache
Constructor Summary
DatatypeElementFactory(QName elementQName)
Method Summary
Attribute | createAttribute(Element owner, QName qname, String value)
Element | createElement(QName qname)
com.sun.msv.datatype.xsd.XSDatatype | getAttributeXSDatatype(QName attributeQName) DOCUMENT ME!
com.sun.msv.datatype.xsd.XSDatatype | getChildElementXSDatatype(QName qname) DOCUMENT ME!
QName | getQName() DOCUMENT ME!
void | setAttributeXSDatatype(QName attributeQName, com.sun.msv.datatype.xsd.XSDatatype type) Registers the given XSDatatype for the given <attribute> QNames
void | setChildElementXSDatatype(QName qname, com.sun.msv.datatype.xsd.XSDatatype dataType)
Methods inherited from class org.dom4j.DocumentFactory
createAttribute, createCDATA, createComment, createDocType, createDocument, createDocument, createDocument, createElement, createElement, createEntity, createNamespace, createPattern, createProcessingInstruction, createProcessingInstruction, createQName, createQName, createQName, createQName, createQNameCache, createSingleton, createText, createXPath, createXPath, createXPathFilter, createXPathFilter, getInstance, getQNames, getXPathNamespaceURIs, init, intern, setXPathNamespaceURIs
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DatatypeElementFactory

public DatatypeElementFactory(QName elementQName)
Method Detail

getQName

public QName getQName()
DOCUMENT ME!

Returns:
the QName this element factory is associated with

getAttributeXSDatatype

public com.sun.msv.datatype.xsd.XSDatatype getAttributeXSDatatype(QName attributeQName)
DOCUMENT ME!

Parameters:
attributeQName - DOCUMENT ME!
Returns:
the XSDatatype associated with the given Attribute QName

setAttributeXSDatatype

public void setAttributeXSDatatype(QName attributeQName,
                                   com.sun.msv.datatype.xsd.XSDatatype type)
Registers the given XSDatatype for the given <attribute> QNames

Parameters:
attributeQName - DOCUMENT ME!
type - DOCUMENT ME!

getChildElementXSDatatype

public com.sun.msv.datatype.xsd.XSDatatype getChildElementXSDatatype(QName qname)
DOCUMENT ME!

Parameters:
qname - DOCUMENT ME!
Returns:
the XSDatatype associated with the given child Element QName

setChildElementXSDatatype

public void setChildElementXSDatatype(QName qname,
                                      com.sun.msv.datatype.xsd.XSDatatype dataType)

createElement

public Element createElement(QName qname)
Overrides:
createElement in class DocumentFactory

createAttribute

public Attribute createAttribute(Element owner,
                                 QName qname,
                                 String value)
Overrides:
createAttribute in class DocumentFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SchemaParser (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.datatype
Class SchemaParser

java.lang.Object
    extended by org.dom4j.datatype.SchemaParser
public class SchemaParser
extends Object

SchemaParser reads an XML Schema Document.

Version:
$Revision: 1.19 $
Author:
James Strachan , Yuxin Ruan

Constructor Summary
SchemaParser()
SchemaParser(DatatypeDocumentFactory documentFactory)
Method Summary
void | build(Document schemaDocument) Parses the given schema document
void | build(Document schemaDocument, Namespace namespace)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SchemaParser

public SchemaParser()

SchemaParser

public SchemaParser(DatatypeDocumentFactory documentFactory)
Method Detail

build

public void build(Document schemaDocument)
Parses the given schema document

Parameters:
schemaDocument - is the document of the XML Schema

build

public void build(Document schemaDocument,
                  Namespace namespace)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


InvalidSchemaException (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.datatype
Class InvalidSchemaException

java.lang.Object
    extended by java.lang.Throwable
        extended by java.lang.Exception
            extended by java.lang.RuntimeException
                extended by java.lang.IllegalArgumentException
                    extended by org.dom4j.datatype.InvalidSchemaException
All Implemented Interfaces:
Serializable
public class InvalidSchemaException
extends IllegalArgumentException

InvalidSchemaException is thrown when an invalid XML Schema document is used

Version:
$Revision: 1.6 $
See Also:
Serialized Form

Constructor Summary
InvalidSchemaException(String reason)
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InvalidSchemaException

public InvalidSchemaException(String reason)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.dom (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.dom

An implementation of the dom4j API which also supports the W3C object model.

See:
Description

Class Summary
DOMAttribute | DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.
DOMAttributeNodeMap | DOMAttributeNodeMap implements a W3C NameNodeMap for the attributes of an element.
DOMCDATA | DOMCDATA implements a CDATA Section which supports the W3C DOM API.
DOMComment | DOMText implements a Text node which supports the W3C DOM API.
DOMDocument | DOMDocument implements an XML document which supports the W3C DOM API.
DOMDocumentFactory | DOMDocumentFactory is a factory of DOM4J objects which implement the W3C DOM API.
DOMDocumentType | DOMDocumentType implements a DocumentType node which supports the W3C DOM API.
DOMElement | DOMElement implements an XML element which supports the W3C DOM API.
DOMEntityReference | DOMEntity implements a Entity node which supports the W3C DOM API.
DOMNamespace | DOMNamespace implements a Namespace that is compatable with the DOM API.
DOMNodeHelper | DOMNodeHelper contains a collection of utility methods for use across Node implementations.
DOMNodeHelper.EmptyNodeList |
DOMProcessingInstruction | DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.
DOMText | DOMText implements a Text node which supports the W3C DOM API.

Package org.dom4j.dom Description

An implementation of the dom4j API which also supports the W3C object model.


org.dom4j.dom Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.dom

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.tree.AbstractNode (implements java.lang.Cloneable, org.dom4j.Node, java.io.Serializable)
      • class org.dom4j.tree.AbstractAttribute (implements org.dom4j.Attribute)
        • class org.dom4j.tree.FlyweightAttribute
          • class org.dom4j.tree.DefaultAttribute
            • class org.dom4j.dom.DOMAttribute (implements org.w3c.dom.Attr)
      • class org.dom4j.tree.AbstractBranch (implements org.dom4j.Branch)
        • class org.dom4j.tree.AbstractDocument (implements org.dom4j.Document)
          • class org.dom4j.tree.DefaultDocument
            • class org.dom4j.dom.DOMDocument (implements org.w3c.dom.Document)
        • class org.dom4j.tree.AbstractElement (implements org.dom4j.Element)
          • class org.dom4j.tree.DefaultElement
            • class org.dom4j.dom.DOMElement (implements org.w3c.dom.Element)
      • class org.dom4j.tree.AbstractCharacterData (implements org.dom4j.CharacterData)
        • class org.dom4j.tree.AbstractCDATA (implements org.dom4j.CDATA)
          • class org.dom4j.tree.FlyweightCDATA (implements org.dom4j.CDATA)
            • class org.dom4j.tree.DefaultCDATA
              • class org.dom4j.dom.DOMCDATA (implements org.w3c.dom.CDATASection)
        • class org.dom4j.tree.AbstractComment (implements org.dom4j.Comment)
          • class org.dom4j.tree.FlyweightComment (implements org.dom4j.Comment)
            • class org.dom4j.tree.DefaultComment
              • class org.dom4j.dom.DOMComment (implements org.w3c.dom.Comment)
        • class org.dom4j.tree.AbstractText (implements org.dom4j.Text)
          • class org.dom4j.tree.FlyweightText (implements org.dom4j.Text)
            • class org.dom4j.tree.DefaultText
              • class org.dom4j.dom.DOMText (implements org.w3c.dom.Text)
      • class org.dom4j.tree.AbstractDocumentType (implements org.dom4j.DocumentType)
        • class org.dom4j.tree.DefaultDocumentType
          • class org.dom4j.dom.DOMDocumentType (implements org.w3c.dom.DocumentType)
      • class org.dom4j.tree.AbstractEntity (implements org.dom4j.Entity)
        • class org.dom4j.tree.FlyweightEntity
          • class org.dom4j.tree.DefaultEntity
            • class org.dom4j.dom.DOMEntityReference (implements org.w3c.dom.EntityReference)
      • class org.dom4j.tree.AbstractProcessingInstruction (implements org.dom4j.ProcessingInstruction)
        • class org.dom4j.tree.FlyweightProcessingInstruction
          • class org.dom4j.tree.DefaultProcessingInstruction
            • class org.dom4j.dom.DOMProcessingInstruction (implements org.w3c.dom.ProcessingInstruction)
      • class org.dom4j.Namespace
        • class org.dom4j.tree.DefaultNamespace
          • class org.dom4j.dom.DOMNamespace (implements org.w3c.dom.Node)
    • class org.dom4j.DocumentFactory (implements java.io.Serializable)
      • class org.dom4j.dom.DOMDocumentFactory (implements org.w3c.dom.DOMImplementation)
    • class org.dom4j.dom.DOMAttributeNodeMap (implements org.w3c.dom.NamedNodeMap)
    • class org.dom4j.dom.DOMNodeHelper
    • class org.dom4j.dom.DOMNodeHelper.EmptyNodeList (implements org.w3c.dom.NodeList)


Uses of Package org.dom4j.dom (dom4j 1.6.1 API)

Uses of Package
org.dom4j.dom

Packages that use org.dom4j.dom
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Classes in org.dom4j.dom used by org.dom4j.dom
DOMDocumentType
DOMDocumentType implements a DocumentType node which supports the W3C DOM API.
DOMElement
DOMElement implements an XML element which supports the W3C DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DOMAttribute (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMAttribute

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractAttribute
            extended by org.dom4j.tree.FlyweightAttribute
                extended by org.dom4j.tree.DefaultAttribute
                    extended by org.dom4j.dom.DOMAttribute
All Implemented Interfaces:
Attr, Attribute, Cloneable, Node, Node, Serializable
public class DOMAttribute
extends DefaultAttribute
implements Attr

DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.

Version:
$Revision: 1.14 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightAttribute
value
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMAttribute(Element parent, QName qname, String value)
DOMAttribute(QName qname)
DOMAttribute(QName qname, String value)
Method Summary
Node | appendChild(Node newChild)
Node | cloneNode(boolean deep)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
Node | getFirstChild()
Node | getLastChild()
String | getLocalName()
String | getNamespaceURI() Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Element | getOwnerElement()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
boolean | getSpecified()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
boolean | isSupported(String feature, String version)
void | normalize()
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultAttribute
getParent, isReadOnly, setParent, setValue, supportsParent
Methods inherited from class org.dom4j.tree.FlyweightAttribute
getQName, getValue
Methods inherited from class org.dom4j.tree.AbstractAttribute
accept, asXML, createXPathResult, getData, getName, getNamespace, getNamespacePrefix, getNodeType, getPath, getQualifiedName, getText, getUniquePath, setData, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Attr
getName, getValue, setValue
Methods inherited from interface org.w3c.dom.Node
getNodeType
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf

Constructor Detail

DOMAttribute

public DOMAttribute(QName qname)

DOMAttribute

public DOMAttribute(QName qname,
                    String value)

DOMAttribute

public DOMAttribute(Element parent,
                    QName qname,
                    String value)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Description copied from interface: Attribute

Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.

Specified by:
getNamespaceURI in interface Node
Overrides:
getNamespaceURI in class AbstractAttribute

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

normalize

public void normalize()
Specified by:
normalize in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

getSpecified

public boolean getSpecified()
Specified by:
getSpecified in interface Attr

getOwnerElement

public Element getOwnerElement()
Specified by:
getOwnerElement in interface Attr
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DOMAttributeNodeMap (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMAttributeNodeMap

java.lang.Object
    extended by org.dom4j.dom.DOMAttributeNodeMap
All Implemented Interfaces:
NamedNodeMap
public class DOMAttributeNodeMap
extends Object
implements NamedNodeMap

DOMAttributeNodeMap implements a W3C NameNodeMap for the attributes of an element.

Version:
$Revision: 1.8 $
Author:
James Strachan

Constructor Summary
DOMAttributeNodeMap(DOMElement element)
Method Summary
void | foo()
int | getLength()
Node | getNamedItem(String name)
Node | getNamedItemNS(String namespaceURI, String localName)
Node | item(int index)
Node | removeNamedItem(String name)
Node | removeNamedItemNS(String namespaceURI, String localName)
Node | setNamedItem(Node arg)
Node | setNamedItemNS(Node arg)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DOMAttributeNodeMap

public DOMAttributeNodeMap(DOMElement element)
Method Detail

foo

public void foo()
         throws DOMException
Throws:
DOMException

getNamedItem

public Node getNamedItem(String name)
Specified by:
getNamedItem in interface NamedNodeMap

setNamedItem

public Node setNamedItem(Node arg)
                  throws DOMException
Specified by:
setNamedItem in interface NamedNodeMap
Throws:
DOMException

removeNamedItem

public Node removeNamedItem(String name)
                     throws DOMException
Specified by:
removeNamedItem in interface NamedNodeMap
Throws:
DOMException

item

public Node item(int index)
Specified by:
item in interface NamedNodeMap

getLength

public int getLength()
Specified by:
getLength in interface NamedNodeMap

getNamedItemNS

public Node getNamedItemNS(String namespaceURI,
                           String localName)
Specified by:
getNamedItemNS in interface NamedNodeMap

setNamedItemNS

public Node setNamedItemNS(Node arg)
                    throws DOMException
Specified by:
setNamedItemNS in interface NamedNodeMap
Throws:
DOMException

removeNamedItemNS

public Node removeNamedItemNS(String namespaceURI,
                              String localName)
                       throws DOMException
Specified by:
removeNamedItemNS in interface NamedNodeMap
Throws:
DOMException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMCDATA (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMCDATA

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractCDATA
                extended by org.dom4j.tree.FlyweightCDATA
                    extended by org.dom4j.tree.DefaultCDATA
                        extended by org.dom4j.dom.DOMCDATA
All Implemented Interfaces:
CDATA, CDATASection, CharacterData, CharacterData, Cloneable, Node, Node, Serializable, Text
public class DOMCDATA
extends DefaultCDATA
implements CDATASection

DOMCDATA implements a CDATA Section which supports the W3C DOM API.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightCDATA
text
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMCDATA(Element parent, String text)
DOMCDATA(String text)
Method Summary
Node | appendChild(Node newChild)
void | appendData(String arg)
Node | cloneNode(boolean deep)
protected CDATA | createCDATA(String text)
void | deleteData(int offset, int count)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
String | getData()
Node | getFirstChild()
Node | getLastChild()
int | getLength()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
void | insertData(int offset, String arg)
boolean | isSupported(String feature, String version)
void | normalize()
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | replaceData(int offset, int count, String arg)
void | setData(String data)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
Text | splitText(int offset)
String | substringData(int offset, int count)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultCDATA
getParent, isReadOnly, setParent, setText, supportsParent
Methods inherited from class org.dom4j.tree.FlyweightCDATA
createXPathResult, getText
Methods inherited from class org.dom4j.tree.AbstractCDATA
accept, asXML, getNodeType, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText, getPath, getUniquePath
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
getNodeType
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf, write

Constructor Detail

DOMCDATA

public DOMCDATA(String text)

DOMCDATA

public DOMCDATA(Element parent,
                String text)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

normalize

public void normalize()
Specified by:
normalize in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

getData

public String getData()
               throws DOMException
Specified by:
getData in interface CharacterData
Throws:
DOMException

setData

public void setData(String data)
             throws DOMException
Specified by:
setData in interface CharacterData
Throws:
DOMException

getLength

public int getLength()
Specified by:
getLength in interface CharacterData

substringData

public String substringData(int offset,
                            int count)
                     throws DOMException
Specified by:
substringData in interface CharacterData
Throws:
DOMException

appendData

public void appendData(String arg)
                throws DOMException
Specified by:
appendData in interface CharacterData
Throws:
DOMException

insertData

public void insertData(int offset,
                       String arg)
                throws DOMException
Specified by:
insertData in interface CharacterData
Throws:
DOMException

deleteData

public void deleteData(int offset,
                       int count)
                throws DOMException
Specified by:
deleteData in interface CharacterData
Throws:
DOMException

replaceData

public void replaceData(int offset,
                        int count,
                        String arg)
                 throws DOMException
Specified by:
replaceData in interface CharacterData
Throws:
DOMException

splitText

public Text splitText(int offset)
               throws DOMException
Specified by:
splitText in interface Text
Throws:
DOMException

createCDATA

protected CDATA createCDATA(String text)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMComment (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMComment

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractComment
                extended by org.dom4j.tree.FlyweightComment
                    extended by org.dom4j.tree.DefaultComment
                        extended by org.dom4j.dom.DOMComment
All Implemented Interfaces:
CharacterData, CharacterData, Cloneable, Comment, Comment, Node, Node, Serializable
public class DOMComment
extends DefaultComment
implements Comment

DOMText implements a Text node which supports the W3C DOM API.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightComment
text
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMComment(Element parent, String text)
DOMComment(String text)
Method Summary
Node | appendChild(Node newChild)
void | appendData(String arg)
Node | cloneNode(boolean deep)
void | deleteData(int offset, int count)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
String | getData()
Node | getFirstChild()
Node | getLastChild()
int | getLength()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
void | insertData(int offset, String arg)
boolean | isSupported(String feature, String version)
void | normalize()
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | replaceData(int offset, int count, String arg)
void | setData(String data)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
String | substringData(int offset, int count)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultComment
getParent, isReadOnly, setParent, setText, supportsParent
Methods inherited from class org.dom4j.tree.FlyweightComment
createXPathResult, getText
Methods inherited from class org.dom4j.tree.AbstractComment
accept, asXML, getNodeType, getPath, getUniquePath, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
getNodeType
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf, write

Constructor Detail

DOMComment

public DOMComment(String text)

DOMComment

public DOMComment(Element parent,
                  String text)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

normalize

public void normalize()
Specified by:
normalize in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

getData

public String getData()
               throws DOMException
Specified by:
getData in interface CharacterData
Throws:
DOMException

setData

public void setData(String data)
             throws DOMException
Specified by:
setData in interface CharacterData
Throws:
DOMException

getLength

public int getLength()
Specified by:
getLength in interface CharacterData

substringData

public String substringData(int offset,
                            int count)
                     throws DOMException
Specified by:
substringData in interface CharacterData
Throws:
DOMException

appendData

public void appendData(String arg)
                throws DOMException
Specified by:
appendData in interface CharacterData
Throws:
DOMException

insertData

public void insertData(int offset,
                       String arg)
                throws DOMException
Specified by:
insertData in interface CharacterData
Throws:
DOMException

deleteData

public void deleteData(int offset,
                       int count)
                throws DOMException
Specified by:
deleteData in interface CharacterData
Throws:
DOMException

replaceData

public void replaceData(int offset,
                        int count,
                        String arg)
                 throws DOMException
Specified by:
replaceData in interface CharacterData
Throws:
DOMException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMDocument (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMDocument

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractDocument
                extended by org.dom4j.tree.DefaultDocument
                    extended by org.dom4j.dom.DOMDocument
All Implemented Interfaces:
Branch, Cloneable, Document, Document, Node, Node, Serializable
public class DOMDocument
extends DefaultDocument
implements Document

DOMDocument implements an XML document which supports the W3C DOM API.

Version:
$Revision: 1.17 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.DefaultDocument
EMPTY_ITERATOR, EMPTY_LIST
Fields inherited from class org.dom4j.tree.AbstractDocument
encoding
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMDocument()
DOMDocument(DOMDocumentType docType)
DOMDocument(DOMElement rootElement)
DOMDocument(DOMElement rootElement, DOMDocumentType docType)
DOMDocument(String name)
DOMDocument(String name, DOMElement rootElement, DOMDocumentType docType)
Method Summary
Node | appendChild(Node newChild)
Node | cloneNode(boolean deep)
Attr | createAttribute(String name)
Attr | createAttributeNS(String namespaceURI, String qualifiedName)
CDATASection | createCDATASection(String data)
Comment | createComment(String data)
DocumentFragment | createDocumentFragment()
Element | createElement(String name)
Element | createElementNS(String namespaceURI, String qualifiedName)
EntityReference | createEntityReference(String name)
ProcessingInstruction | createProcessingInstruction(String target, String data)
Text | createTextNode(String data)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
DocumentType | getDoctype()
Element | getDocumentElement()
protected DocumentFactory | getDocumentFactory()
Element | getElementById(String elementId)
NodeList | getElementsByTagName(String name)
NodeList | getElementsByTagNameNS(String namespace, String name)
Node | getFirstChild()
DOMImplementation | getImplementation()
Node | getLastChild()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | importNode(Node importedNode, boolean deep)
Node | insertBefore(Node newChild, Node refChild)
boolean | isSupported(String feature, String version)
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultDocument
addDocType, addNode, addNode, clearContent, clone, contentList, getDocType, getEntityResolver, getName, getRootElement, getXMLEncoding, processingInstruction, processingInstructions, processingInstructions, removeNode, removeProcessingInstruction, rootElementAdded, setContent, setDocType, setDocumentFactory, setEntityResolver, setName
Methods inherited from class org.dom4j.tree.AbstractDocument
accept, add, addComment, addElement, addElement, addElement, addProcessingInstruction, addProcessingInstruction, asXML, asXPathResult, checkAddElementAllowed, childAdded, childRemoved, getDocument, getNodeType, getPath, getStringValue, getUniquePath, normalize, remove, setRootElement, setXMLEncoding, toString, write
Methods inherited from class org.dom4j.tree.AbstractBranch
add, add, add, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getText, getTextTrim, hasContent, indexOf, invalidNodeTypeAddException, isReadOnly, node, nodeCount, nodeIterator, remove, remove, remove, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getParent, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
getNodeType, normalize
Methods inherited from interface org.dom4j.Branch
add, add, add, appendContent, content, elementByID, indexOf, node, nodeCount, nodeIterator, remove, remove, remove, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
createXPath, detach, getNodeTypeName, getParent, getPath, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf

Constructor Detail

DOMDocument

public DOMDocument()

DOMDocument

public DOMDocument(String name)

DOMDocument

public DOMDocument(DOMElement rootElement)

DOMDocument

public DOMDocument(DOMDocumentType docType)

DOMDocument

public DOMDocument(DOMElement rootElement,
                   DOMDocumentType docType)

DOMDocument

public DOMDocument(String name,
                   DOMElement rootElement,
                   DOMDocumentType docType)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

getElementsByTagName

public NodeList getElementsByTagName(String name)
Specified by:
getElementsByTagName in interface Document

getElementsByTagNameNS

public NodeList getElementsByTagNameNS(String namespace,
                                       String name)
Specified by:
getElementsByTagNameNS in interface Document

getDoctype

public DocumentType getDoctype()
Specified by:
getDoctype in interface Document

getImplementation

public DOMImplementation getImplementation()
Specified by:
getImplementation in interface Document

getDocumentElement

public Element getDocumentElement()
Specified by:
getDocumentElement in interface Document

createElement

public Element createElement(String name)
                      throws DOMException
Specified by:
createElement in interface Document
Throws:
DOMException

createDocumentFragment

public DocumentFragment createDocumentFragment()
Specified by:
createDocumentFragment in interface Document

createTextNode

public Text createTextNode(String data)
Specified by:
createTextNode in interface Document

createComment

public Comment createComment(String data)
Specified by:
createComment in interface Document

createCDATASection

public CDATASection createCDATASection(String data)
                                throws DOMException
Specified by:
createCDATASection in interface Document
Throws:
DOMException

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(String target,
                                                         String data)
                                                  throws DOMException
Specified by:
createProcessingInstruction in interface Document
Throws:
DOMException

createAttribute

public Attr createAttribute(String name)
                     throws DOMException
Specified by:
createAttribute in interface Document
Throws:
DOMException

createEntityReference

public EntityReference createEntityReference(String name)
                                      throws DOMException
Specified by:
createEntityReference in interface Document
Throws:
DOMException

importNode

public Node importNode(Node importedNode,
                       boolean deep)
                throws DOMException
Specified by:
importNode in interface Document
Throws:
DOMException

createElementNS

public Element createElementNS(String namespaceURI,
                               String qualifiedName)
                        throws DOMException
Specified by:
createElementNS in interface Document
Throws:
DOMException

createAttributeNS

public Attr createAttributeNS(String namespaceURI,
                              String qualifiedName)
                       throws DOMException
Specified by:
createAttributeNS in interface Document
Throws:
DOMException

getElementById

public Element getElementById(String elementId)
Specified by:
getElementById in interface Document

getDocumentFactory

protected DocumentFactory getDocumentFactory()
Overrides:
getDocumentFactory in class DefaultDocument
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMDocumentFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMDocumentFactory

java.lang.Object
    extended by org.dom4j.DocumentFactory
        extended by org.dom4j.dom.DOMDocumentFactory
All Implemented Interfaces:
DOMImplementation, Serializable
public class DOMDocumentFactory
extends DocumentFactory
implements DOMImplementation

DOMDocumentFactory is a factory of DOM4J objects which implement the W3C DOM API.

Version:
$Revision: 1.21 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.DocumentFactory
cache
Constructor Summary
DOMDocumentFactory()
Method Summary
protected DOMDocumentType | asDocumentType(DocumentType docType)
Attribute | createAttribute(Element owner, QName qname, String value)
CDATA | createCDATA(String text)
Comment | createComment(String text)
DocumentType | createDocType(String name, String publicId, String systemId)
Document | createDocument()
Document | createDocument(String namespaceURI, String qualifiedName, DocumentType docType)
DocumentType | createDocumentType(String qualifiedName, String publicId, String systemId)
Element | createElement(QName qname)
Element | createElement(QName qname, int attributeCount)
Entity | createEntity(String name)
Entity | createEntity(String name, String text)
Namespace | createNamespace(String prefix, String uri)
ProcessingInstruction | createProcessingInstruction(String target, Map data)
ProcessingInstruction | createProcessingInstruction(String target, String data)
Text | createText(String text)
static DocumentFactory | getInstance() Access to the singleton instance of this factory.
boolean | hasFeature(String feat, String version)
Methods inherited from class org.dom4j.DocumentFactory
createAttribute, createDocument, createDocument, createElement, createElement, createPattern, createQName, createQName, createQName, createQName, createQNameCache, createSingleton, createXPath, createXPath, createXPathFilter, createXPathFilter, getQNames, getXPathNamespaceURIs, init, intern, setXPathNamespaceURIs
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DOMDocumentFactory

public DOMDocumentFactory()
Method Detail

getInstance

public static DocumentFactory getInstance()

Access to the singleton instance of this factory.

Returns:
the default singleon instance

createDocument

public Document createDocument()
Overrides:
createDocument in class DocumentFactory

createDocType

public DocumentType createDocType(String name,
                                  String publicId,
                                  String systemId)
Overrides:
createDocType in class DocumentFactory

createElement

public Element createElement(QName qname)
Overrides:
createElement in class DocumentFactory

createElement

public Element createElement(QName qname,
                             int attributeCount)

createAttribute

public Attribute createAttribute(Element owner,
                                 QName qname,
                                 String value)
Overrides:
createAttribute in class DocumentFactory

createCDATA

public CDATA createCDATA(String text)
Overrides:
createCDATA in class DocumentFactory

createComment

public Comment createComment(String text)
Overrides:
createComment in class DocumentFactory

createText

public Text createText(String text)
Overrides:
createText in class DocumentFactory

createEntity

public Entity createEntity(String name)

createEntity

public Entity createEntity(String name,
                           String text)
Overrides:
createEntity in class DocumentFactory

createNamespace

public Namespace createNamespace(String prefix,
                                 String uri)
Overrides:
createNamespace in class DocumentFactory

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(String target,
                                                         String data)
Overrides:
createProcessingInstruction in class DocumentFactory

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(String target,
                                                         Map data)
Overrides:
createProcessingInstruction in class DocumentFactory

hasFeature

public boolean hasFeature(String feat,
                          String version)
Specified by:
hasFeature in interface DOMImplementation

createDocumentType

public DocumentType createDocumentType(String qualifiedName,
                                       String publicId,
                                       String systemId)
                                throws DOMException
Specified by:
createDocumentType in interface DOMImplementation
Throws:
DOMException

createDocument

public Document createDocument(String namespaceURI,
                               String qualifiedName,
                               DocumentType docType)
                        throws DOMException
Specified by:
createDocument in interface DOMImplementation
Throws:
DOMException

asDocumentType

protected DOMDocumentType asDocumentType(DocumentType docType)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMDocumentType (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMDocumentType

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractDocumentType
            extended by org.dom4j.tree.DefaultDocumentType
                extended by org.dom4j.dom.DOMDocumentType
All Implemented Interfaces:
Cloneable, DocumentType, DocumentType, Node, Node, Serializable
public class DOMDocumentType
extends DefaultDocumentType
implements DocumentType

DOMDocumentType implements a DocumentType node which supports the W3C DOM API.

Version:
$Revision: 1.11 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.DefaultDocumentType
elementName
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMDocumentType()
DOMDocumentType(String elementName, String systemID)
DOMDocumentType(String name, String publicID, String systemID)
Method Summary
Node | appendChild(Node newChild)
Node | cloneNode(boolean deep)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
NamedNodeMap | getEntities()
Node | getFirstChild()
String | getInternalSubset()
Node | getLastChild()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
NamedNodeMap | getNotations()
Document | getOwnerDocument()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
String | getPublicId()
String | getSystemId()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
boolean | isSupported(String feature, String version)
void | normalize()
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultDocumentType
getElementName, getExternalDeclarations, getInternalDeclarations, getPublicID, getSystemID, setElementName, setExternalDeclarations, setInternalDeclarations, setPublicID, setSystemID
Methods inherited from class org.dom4j.tree.AbstractDocumentType
accept, asXML, getName, getNodeType, getPath, getText, getUniquePath, setName, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.DocumentType
getName
Methods inherited from interface org.w3c.dom.Node
getNodeType
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf

Constructor Detail

DOMDocumentType

public DOMDocumentType()

DOMDocumentType

public DOMDocumentType(String elementName,
                       String systemID)

DOMDocumentType

public DOMDocumentType(String name,
                       String publicID,
                       String systemID)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

normalize

public void normalize()
Specified by:
normalize in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

getEntities

public NamedNodeMap getEntities()
Specified by:
getEntities in interface DocumentType

getNotations

public NamedNodeMap getNotations()
Specified by:
getNotations in interface DocumentType

getPublicId

public String getPublicId()
Specified by:
getPublicId in interface DocumentType

getSystemId

public String getSystemId()
Specified by:
getSystemId in interface DocumentType

getInternalSubset

public String getInternalSubset()
Specified by:
getInternalSubset in interface DocumentType
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
                extended by org.dom4j.tree.DefaultElement
                    extended by org.dom4j.dom.DOMElement
All Implemented Interfaces:
Branch, Cloneable, Element, Element, Node, Node, Serializable
public class DOMElement
extends DefaultElement
implements Element

DOMElement implements an XML element which supports the W3C DOM API.

Version:
$Revision: 1.23 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR, EMPTY_LIST, USE_STRINGVALUE_SEPARATOR, VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMElement(QName qname)
DOMElement(QName qname, int attributeCount)
DOMElement(String name)
DOMElement(String name, Namespace namespace)
Method Summary
Node | appendChild(Node newChild)
protected Attribute | attribute(Attr attr)
protected Attribute | attribute(String namespaceURI, String localName)
Node | cloneNode(boolean deep)
protected Attribute | createAttribute(Attr newAttr)
String | getAttribute(String name)
Attr | getAttributeNode(String name)
Attr | getAttributeNodeNS(String namespaceURI, String localName)
String | getAttributeNS(String namespaceURI, String localName)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
protected DocumentFactory | getDocumentFactory()
NodeList | getElementsByTagName(String name)
NodeList | getElementsByTagNameNS(String namespace, String lName)
Node | getFirstChild()
Node | getLastChild()
String | getLocalName()
String | getNamespaceURI() Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
protected QName | getQName(String namespace, String qualifiedName)
String | getTagName()
boolean | hasAttribute(String name)
boolean | hasAttributeNS(String namespaceURI, String localName)
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
boolean | isSupported(String feature, String version)
void | removeAttribute(String name)
Attr | removeAttributeNode(Attr oldAttr)
void | removeAttributeNS(String namespaceURI, String localName)
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | setAttribute(String name, String value)
Attr | setAttributeNode(Attr newAttr)
Attr | setAttributeNodeNS(Attr newAttr)
void | setAttributeNS(String namespaceURI, String qualifiedName, String value)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultElement
add, additionalNamespaces, additionalNamespaces, addNewNode, attribute, attribute, attribute, attribute, attributeCount, attributeIterator, attributeList, attributeList, attributes, clearContent, clone, contentList, declaredNamespaces, element, element, element, getDocument, getNamespaceForPrefix, getNamespaceForURI, getParent, getQName, getStringValue, getText, indexOf, node, nodeCount, nodeIterator, processingInstruction, processingInstructions, processingInstructions, remove, removeNode, removeProcessingInstruction, setAttributeList, setAttributes, setContent, setDocument, setParent, setQName, supportsParent
Methods inherited from class org.dom4j.tree.AbstractElement
accept, add, add, add, add, add, add, add, add, addAttribute, addAttribute, addCDATA, addComment, addElement, addEntity, addNamespace, addNewNode, addNode, addNode, addProcessingInstruction, addProcessingInstruction, addText, appendAttributes, asXML, attributeValue, attributeValue, attributeValue, attributeValue, childAdded, childRemoved, createAttributeList, createAttributeList, createCopy, createCopy, createCopy, createElement, createElement, createSingleIterator, elementIterator, elementIterator, elementIterator, elementIterator, elements, elements, elements, elements, elementText, elementText, elementTextTrim, elementTextTrim, ensureAttributesCapacity, getData, getName, getNamespace, getNamespacePrefix, getNamespacesForURI, getNodeType, getPath, getQName, getQualifiedName, getUniquePath, getXPathNameStep, getXPathResult, hasMixedContent, isRootElement, isTextOnly, normalize, remove, remove, remove, remove, remove, remove, remove, remove, setAttributes, setAttributeValue, setAttributeValue, setData, setName, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
getNodeType, normalize
Methods inherited from interface org.dom4j.Element
getTextTrim
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, content, elementByID, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, createXPath, detach, getNodeTypeName, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf

Constructor Detail

DOMElement

public DOMElement(String name)

DOMElement

public DOMElement(QName qname)

DOMElement

public DOMElement(QName qname,
                  int attributeCount)

DOMElement

public DOMElement(String name,
                  Namespace namespace)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Description copied from interface: Element

Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.

Specified by:
getNamespaceURI in interface Node
Overrides:
getNamespaceURI in class AbstractElement

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

getTagName

public String getTagName()
Specified by:
getTagName in interface Element

getAttribute

public String getAttribute(String name)
Specified by:
getAttribute in interface Element

setAttribute

public void setAttribute(String name,
                         String value)
                  throws DOMException
Specified by:
setAttribute in interface Element
Throws:
DOMException

removeAttribute

public void removeAttribute(String name)
                     throws DOMException
Specified by:
removeAttribute in interface Element
Throws:
DOMException

getAttributeNode

public Attr getAttributeNode(String name)
Specified by:
getAttributeNode in interface Element

setAttributeNode

public Attr setAttributeNode(Attr newAttr)
                      throws DOMException
Specified by:
setAttributeNode in interface Element
Throws:
DOMException

removeAttributeNode

public Attr removeAttributeNode(Attr oldAttr)
                         throws DOMException
Specified by:
removeAttributeNode in interface Element
Throws:
DOMException

getAttributeNS

public String getAttributeNS(String namespaceURI,
                             String localName)
Specified by:
getAttributeNS in interface Element

setAttributeNS

public void setAttributeNS(String namespaceURI,
                           String qualifiedName,
                           String value)
                    throws DOMException
Specified by:
setAttributeNS in interface Element
Throws:
DOMException

removeAttributeNS

public void removeAttributeNS(String namespaceURI,
                              String localName)
                       throws DOMException
Specified by:
removeAttributeNS in interface Element
Throws:
DOMException

getAttributeNodeNS

public Attr getAttributeNodeNS(String namespaceURI,
                               String localName)
Specified by:
getAttributeNodeNS in interface Element

setAttributeNodeNS

public Attr setAttributeNodeNS(Attr newAttr)
                        throws DOMException
Specified by:
setAttributeNodeNS in interface Element
Throws:
DOMException

getElementsByTagName

public NodeList getElementsByTagName(String name)
Specified by:
getElementsByTagName in interface Element

getElementsByTagNameNS

public NodeList getElementsByTagNameNS(String namespace,
                                       String lName)
Specified by:
getElementsByTagNameNS in interface Element

hasAttribute

public boolean hasAttribute(String name)
Specified by:
hasAttribute in interface Element

hasAttributeNS

public boolean hasAttributeNS(String namespaceURI,
                              String localName)
Specified by:
hasAttributeNS in interface Element

getDocumentFactory

protected DocumentFactory getDocumentFactory()
Overrides:
getDocumentFactory in class DefaultElement

attribute

protected Attribute attribute(Attr attr)

attribute

protected Attribute attribute(String namespaceURI,
                              String localName)

createAttribute

protected Attribute createAttribute(Attr newAttr)

getQName

protected QName getQName(String namespace,
                         String qualifiedName)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMEntityReference (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMEntityReference

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractEntity
            extended by org.dom4j.tree.FlyweightEntity
                extended by org.dom4j.tree.DefaultEntity
                    extended by org.dom4j.dom.DOMEntityReference
All Implemented Interfaces:
Cloneable, Entity, EntityReference, Node, Node, Serializable
public class DOMEntityReference
extends DefaultEntity
implements EntityReference

DOMEntity implements a Entity node which supports the W3C DOM API.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightEntity
name, text
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMEntityReference(Element parent, String name, String text)
DOMEntityReference(String name)
DOMEntityReference(String name, String text)
Method Summary
Node | appendChild(Node newChild)
Node | cloneNode(boolean deep)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
Node | getFirstChild()
Node | getLastChild()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
boolean | isSupported(String feature, String version)
void | normalize()
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultEntity
getParent, isReadOnly, setName, setParent, setText, supportsParent
Methods inherited from class org.dom4j.tree.FlyweightEntity
createXPathResult, getName, getText
Methods inherited from class org.dom4j.tree.AbstractEntity
accept, asXML, getNodeType, getPath, getStringValue, getUniquePath, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
getNodeType
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, valueOf

Constructor Detail

DOMEntityReference

public DOMEntityReference(String name)

DOMEntityReference

public DOMEntityReference(String name,
                          String text)

DOMEntityReference

public DOMEntityReference(Element parent,
                          String name,
                          String text)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

normalize

public void normalize()
Specified by:
normalize in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMNamespace (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMNamespace

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.Namespace
            extended by org.dom4j.tree.DefaultNamespace
                extended by org.dom4j.dom.DOMNamespace
All Implemented Interfaces:
Cloneable, Node, Node, Serializable
public class DOMNamespace
extends DefaultNamespace
implements Node

DOMNamespace implements a Namespace that is compatable with the DOM API.

Version:
$Revision: 1.10 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.Namespace
CACHE, NO_NAMESPACE, XML_NAMESPACE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMNamespace(Element parent, String prefix, String uri)
DOMNamespace(String prefix, String uri)
Method Summary
Node | appendChild(Node newChild)
Node | cloneNode(boolean deep)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
Node | getFirstChild()
Node | getLastChild()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Node | getParentNode()
Node | getPreviousSibling()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
boolean | isSupported(String feature, String version)
void | normalize()
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultNamespace
createHashCode, equals, getParent, hashCode, isReadOnly, setParent, supportsParent
Methods inherited from class org.dom4j.Namespace
accept, asXML, createXPathResult, get, get, getNodeType, getPath, getPrefix, getStringValue, getText, getUniquePath, getURI, getXPathNameStep, toString
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getPath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setText, valueOf, write
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
getNodeType, getPrefix

Constructor Detail

DOMNamespace

public DOMNamespace(String prefix,
                    String uri)

DOMNamespace

public DOMNamespace(Element parent,
                    String prefix,
                    String uri)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

normalize

public void normalize()
Specified by:
normalize in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMNodeHelper (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMNodeHelper

java.lang.Object
    extended by org.dom4j.dom.DOMNodeHelper
public class DOMNodeHelper
extends Object

DOMNodeHelper contains a collection of utility methods for use across Node implementations.

Version:
$Revision: 1.20 $
Author:
James Strachan

Nested Class Summary
static class DOMNodeHelper.EmptyNodeList
Field Summary
static NodeList EMPTY_NODE_LIST
Constructor Summary
protected DOMNodeHelper()
Method Summary
static Node | appendChild(Node node, Node newChild)
static void | appendData(CharacterData charData, String arg)
static void | appendElementsByTagName(List list, Branch parent, String name)
static void | appendElementsByTagNameNS(List list, Branch parent, String namespace, String localName)
static Attr | asDOMAttr(Node attribute)
static Document | asDOMDocument(Document document)
static DocumentType | asDOMDocumentType(DocumentType dt)
static Element | asDOMElement(Node element)
static Node | asDOMNode(Node node)
static Text | asDOMText(CharacterData text)
static Node | cloneNode(Node node, boolean deep)
static NodeList | createNodeList(List list)
static void | deleteData(CharacterData charData, int offset, int count)
static NamedNodeMap | getAttributes(Node node)
static NodeList | getChildNodes(Node node)
static String | getData(CharacterData charData)
static Node | getFirstChild(Node node)
static Node | getLastChild(Node node)
static int | getLength(CharacterData charData)
static String | getLocalName(Node node)
static String | getNamespaceURI(Node node)
static Node | getNextSibling(Node node)
static String | getNodeValue(Node node)
static Document | getOwnerDocument(Node node)
static Node | getParentNode(Node node)
static String | getPrefix(Node node)
static Node | getPreviousSibling(Node node)
static boolean | hasAttributes(Node node)
static boolean | hasChildNodes(Node node)
static Node | insertBefore(Node node, Node newChild, Node refChild)
static void | insertData(CharacterData data, int offset, String arg)
static boolean | isSupported(Node n, String feature, String version)
static void | normalize(Node node)
static void | notSupported() Called when a method has not been implemented yet
static Node | removeChild(Node node, Node oldChild)
static Node | replaceChild(Node node, Node newChild, Node oldChild)
static void | replaceData(CharacterData charData, int offset, int count, String arg)
static void | setData(CharacterData charData, String data)
static void | setNodeValue(Node node, String nodeValue)
static void | setPrefix(Node node, String prefix)
static String | substringData(CharacterData charData, int offset, int count)
static boolean | supports(Node node, String feature, String version)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

EMPTY_NODE_LIST

public static final NodeList EMPTY_NODE_LIST
Constructor Detail

DOMNodeHelper

protected DOMNodeHelper()
Method Detail

supports

public static boolean supports(Node node,
                               String feature,
                               String version)

getNamespaceURI

public static String getNamespaceURI(Node node)

getPrefix

public static String getPrefix(Node node)

getLocalName

public static String getLocalName(Node node)

setPrefix

public static void setPrefix(Node node,
                             String prefix)
                      throws DOMException
Throws:
DOMException

getNodeValue

public static String getNodeValue(Node node)
                           throws DOMException
Throws:
DOMException

setNodeValue

public static void setNodeValue(Node node,
                                String nodeValue)
                         throws DOMException
Throws:
DOMException

getParentNode

public static Node getParentNode(Node node)

getChildNodes

public static NodeList getChildNodes(Node node)

getFirstChild

public static Node getFirstChild(Node node)

getLastChild

public static Node getLastChild(Node node)

getPreviousSibling

public static Node getPreviousSibling(Node node)

getNextSibling

public static Node getNextSibling(Node node)

getAttributes

public static NamedNodeMap getAttributes(Node node)

getOwnerDocument

public static Document getOwnerDocument(Node node)

insertBefore

public static Node insertBefore(Node node,
                                Node newChild,
                                Node refChild)
                         throws DOMException
Throws:
DOMException

replaceChild

public static Node replaceChild(Node node,
                                Node newChild,
                                Node oldChild)
                         throws DOMException
Throws:
DOMException

removeChild

public static Node removeChild(Node node,
                               Node oldChild)
                        throws DOMException
Throws:
DOMException

appendChild

public static Node appendChild(Node node,
                               Node newChild)
                        throws DOMException
Throws:
DOMException

hasChildNodes

public static boolean hasChildNodes(Node node)

cloneNode

public static Node cloneNode(Node node,
                             boolean deep)

normalize

public static void normalize(Node node)

isSupported

public static boolean isSupported(Node n,
                                  String feature,
                                  String version)

hasAttributes

public static boolean hasAttributes(Node node)

getData

public static String getData(CharacterData charData)
                      throws DOMException
Throws:
DOMException

setData

public static void setData(CharacterData charData,
                           String data)
                    throws DOMException
Throws:
DOMException

getLength

public static int getLength(CharacterData charData)

substringData

public static String substringData(CharacterData charData,
                                   int offset,
                                   int count)
                            throws DOMException
Throws:
DOMException

appendData

public static void appendData(CharacterData charData,
                              String arg)
                       throws DOMException
Throws:
DOMException

insertData

public static void insertData(CharacterData data,
                              int offset,
                              String arg)
                       throws DOMException
Throws:
DOMException

deleteData

public static void deleteData(CharacterData charData,
                              int offset,
                              int count)
                       throws DOMException
Throws:
DOMException

replaceData

public static void replaceData(CharacterData charData,
                               int offset,
                               int count,
                               String arg)
                        throws DOMException
Throws:
DOMException

appendElementsByTagName

public static void appendElementsByTagName(List list,
                                           Branch parent,
                                           String name)

appendElementsByTagNameNS

public static void appendElementsByTagNameNS(List list,
                                             Branch parent,
                                             String namespace,
                                             String localName)

createNodeList

public static NodeList createNodeList(List list)

asDOMNode

public static Node asDOMNode(Node node)

asDOMDocument

public static Document asDOMDocument(Document document)

asDOMDocumentType

public static DocumentType asDOMDocumentType(DocumentType dt)

asDOMText

public static Text asDOMText(CharacterData text)

asDOMElement

public static Element asDOMElement(Node element)

asDOMAttr

public static Attr asDOMAttr(Node attribute)

notSupported

public static void notSupported()
Called when a method has not been implemented yet

Throws:
DOMException - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMNodeHelper.EmptyNodeList (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMNodeHelper.EmptyNodeList

java.lang.Object
    extended by org.dom4j.dom.DOMNodeHelper.EmptyNodeList
All Implemented Interfaces:
NodeList
Enclosing class:
DOMNodeHelper
public static class DOMNodeHelper.EmptyNodeList
extends Object
implements NodeList

Constructor Summary
DOMNodeHelper.EmptyNodeList()
Method Summary
int | getLength()
Node | item(int index)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DOMNodeHelper.EmptyNodeList

public DOMNodeHelper.EmptyNodeList()
Method Detail

item

public Node item(int index)
Specified by:
item in interface NodeList

getLength

public int getLength()
Specified by:
getLength in interface NodeList
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMProcessingInstruction (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMProcessingInstruction

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractProcessingInstruction
            extended by org.dom4j.tree.FlyweightProcessingInstruction
                extended by org.dom4j.tree.DefaultProcessingInstruction
                    extended by org.dom4j.dom.DOMProcessingInstruction
All Implemented Interfaces:
Cloneable, Node, Node, ProcessingInstruction, ProcessingInstruction, Serializable
public class DOMProcessingInstruction
extends DefaultProcessingInstruction
implements ProcessingInstruction

DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightProcessingInstruction
target, text, values
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMProcessingInstruction(Element parent, String target, String val)
DOMProcessingInstruction(String target, Map values)
DOMProcessingInstruction(String target, String values)
Method Summary
Node | appendChild(Node newChild)
Node | cloneNode(boolean deep)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
String | getData()
Node | getFirstChild()
Node | getLastChild()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
boolean | isSupported(String feature, String version)
void | normalize()
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | setData(String data)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultProcessingInstruction
getParent, isReadOnly, setParent, setTarget, setText, setValue, setValues, supportsParent
Methods inherited from class org.dom4j.tree.FlyweightProcessingInstruction
createXPathResult, getTarget, getText, getValue, getValues
Methods inherited from class org.dom4j.tree.AbstractProcessingInstruction
accept, asXML, getName, getNodeType, getPath, getUniquePath, parseValues, removeValue, setName, toString, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.ProcessingInstruction
getTarget
Methods inherited from interface org.w3c.dom.Node
getNodeType
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, valueOf

Constructor Detail

DOMProcessingInstruction

public DOMProcessingInstruction(String target,
                                Map values)

DOMProcessingInstruction

public DOMProcessingInstruction(String target,
                                String values)

DOMProcessingInstruction

public DOMProcessingInstruction(Element parent,
                                String target,
                                String val)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

normalize

public void normalize()
Specified by:
normalize in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

getData

public String getData()
Specified by:
getData in interface ProcessingInstruction

setData

public void setData(String data)
             throws DOMException
Specified by:
setData in interface ProcessingInstruction
Throws:
DOMException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMText (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dom
Class DOMText

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractText
                extended by org.dom4j.tree.FlyweightText
                    extended by org.dom4j.tree.DefaultText
                        extended by org.dom4j.dom.DOMText
All Implemented Interfaces:
CharacterData, CharacterData, Cloneable, Node, Node, Serializable, Text, Text
public class DOMText
extends DefaultText
implements Text

DOMText implements a Text node which supports the W3C DOM API.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightText
text
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.w3c.dom.Node
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DOMText(Element parent, String text)
DOMText(String text)
Method Summary
Node | appendChild(Node newChild)
void | appendData(String arg)
Node | cloneNode(boolean deep)
protected Text | createText(String text)
void | deleteData(int offset, int count)
NamedNodeMap | getAttributes()
NodeList | getChildNodes()
String | getData()
Node | getFirstChild()
Node | getLastChild()
int | getLength()
String | getLocalName()
String | getNamespaceURI()
Node | getNextSibling()
String | getNodeName()
String | getNodeValue()
Document | getOwnerDocument()
Node | getParentNode()
String | getPrefix()
Node | getPreviousSibling()
boolean | hasAttributes()
boolean | hasChildNodes()
Node | insertBefore(Node newChild, Node refChild)
void | insertData(int offset, String arg)
boolean | isSupported(String feature, String version)
void | normalize()
Node | removeChild(Node oldChild)
Node | replaceChild(Node newChild, Node oldChild)
void | replaceData(int offset, int count, String arg)
void | setData(String data)
void | setNodeValue(String nodeValue)
void | setPrefix(String prefix)
Text | splitText(int offset)
String | substringData(int offset, int count)
boolean | supports(String feature, String version)
Methods inherited from class org.dom4j.tree.DefaultText
getParent, isReadOnly, setParent, setText, supportsParent
Methods inherited from class org.dom4j.tree.FlyweightText
createXPathResult, getText
Methods inherited from class org.dom4j.tree.AbstractText
accept, asXML, getNodeType, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText, getPath, getUniquePath
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.w3c.dom.Node
getNodeType
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf, write

Constructor Detail

DOMText

public DOMText(String text)

DOMText

public DOMText(Element parent,
               String text)
Method Detail

supports

public boolean supports(String feature,
                        String version)

getNamespaceURI

public String getNamespaceURI()
Specified by:
getNamespaceURI in interface Node

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface Node

setPrefix

public void setPrefix(String prefix)
               throws DOMException
Specified by:
setPrefix in interface Node
Throws:
DOMException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface Node

getNodeName

public String getNodeName()
Specified by:
getNodeName in interface Node

getNodeValue

public String getNodeValue()
                    throws DOMException
Specified by:
getNodeValue in interface Node
Throws:
DOMException

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
Specified by:
setNodeValue in interface Node
Throws:
DOMException

getParentNode

public Node getParentNode()
Specified by:
getParentNode in interface Node

getChildNodes

public NodeList getChildNodes()
Specified by:
getChildNodes in interface Node

getFirstChild

public Node getFirstChild()
Specified by:
getFirstChild in interface Node

getLastChild

public Node getLastChild()
Specified by:
getLastChild in interface Node

getPreviousSibling

public Node getPreviousSibling()
Specified by:
getPreviousSibling in interface Node

getNextSibling

public Node getNextSibling()
Specified by:
getNextSibling in interface Node

getAttributes

public NamedNodeMap getAttributes()
Specified by:
getAttributes in interface Node

getOwnerDocument

public Document getOwnerDocument()
Specified by:
getOwnerDocument in interface Node

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
                  throws DOMException
Specified by:
insertBefore in interface Node
Throws:
DOMException

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
                  throws DOMException
Specified by:
replaceChild in interface Node
Throws:
DOMException

removeChild

public Node removeChild(Node oldChild)
                 throws DOMException
Specified by:
removeChild in interface Node
Throws:
DOMException

appendChild

public Node appendChild(Node newChild)
                 throws DOMException
Specified by:
appendChild in interface Node
Throws:
DOMException

hasChildNodes

public boolean hasChildNodes()
Specified by:
hasChildNodes in interface Node

cloneNode

public Node cloneNode(boolean deep)
Specified by:
cloneNode in interface Node

normalize

public void normalize()
Specified by:
normalize in interface Node

isSupported

public boolean isSupported(String feature,
                           String version)
Specified by:
isSupported in interface Node

hasAttributes

public boolean hasAttributes()
Specified by:
hasAttributes in interface Node

getData

public String getData()
               throws DOMException
Specified by:
getData in interface CharacterData
Throws:
DOMException

setData

public void setData(String data)
             throws DOMException
Specified by:
setData in interface CharacterData
Throws:
DOMException

getLength

public int getLength()
Specified by:
getLength in interface CharacterData

substringData

public String substringData(int offset,
                            int count)
                     throws DOMException
Specified by:
substringData in interface CharacterData
Throws:
DOMException

appendData

public void appendData(String arg)
                throws DOMException
Specified by:
appendData in interface CharacterData
Throws:
DOMException

insertData

public void insertData(int offset,
                       String arg)
                throws DOMException
Specified by:
insertData in interface CharacterData
Throws:
DOMException

deleteData

public void deleteData(int offset,
                       int count)
                throws DOMException
Specified by:
deleteData in interface CharacterData
Throws:
DOMException

replaceData

public void replaceData(int offset,
                        int count,
                        String arg)
                 throws DOMException
Specified by:
replaceData in interface CharacterData
Throws:
DOMException

splitText

public Text splitText(int offset)
               throws DOMException
Specified by:
splitText in interface Text
Throws:
DOMException

createText

protected Text createText(String text)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.dtd (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.dtd

Classes to represent the DTD declarations.

See:
Description

Class Summary
AttributeDecl | AttributeDecl represents an attribute declaration in a DTD.
ElementDecl | AttributeDecl represents an element declaration in a DTD.
ExternalEntityDecl | ExternalEntityDecl represents an external entity declaration in a DTD.
InternalEntityDecl | InternalEntityDecl represents an internal entity declaration in a DTD.

Package org.dom4j.dtd Description

Classes to represent the DTD declarations. They are used inside the DocumentType interface.


org.dom4j.dtd Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.dtd

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.dtd.AttributeDecl
    • class org.dom4j.dtd.ElementDecl
    • class org.dom4j.dtd.ExternalEntityDecl
    • class org.dom4j.dtd.InternalEntityDecl


Uses of Package org.dom4j.dtd (dom4j 1.6.1 API)

Uses of Package
org.dom4j.dtd

No usage of org.dom4j.dtd

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AttributeDecl (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dtd
Class AttributeDecl

java.lang.Object
    extended by org.dom4j.dtd.AttributeDecl
public class AttributeDecl
extends Object

AttributeDecl represents an attribute declaration in a DTD.

Version:
$Revision: 1.7 $
Author:
James Strachan

Constructor Summary
AttributeDecl()
AttributeDecl(String elementName, String attributeName, String type, String valueDefault, String value)
Method Summary
String | getAttributeName() Getter for property attributeName.
String | getElementName() Getter for property elementName.
String | getType() Getter for property type.
String | getValue() Getter for property value.
String | getValueDefault() Getter for property valueDefault.
void | setAttributeName(String attributeName) Setter for property attributeName.
void | setElementName(String elementName) Setter for property elementName.
void | setType(String type) Setter for property type.
void | setValue(String value) Setter for property value.
void | setValueDefault(String valueDefault) Setter for property valueDefault.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

AttributeDecl

public AttributeDecl()

AttributeDecl

public AttributeDecl(String elementName,
                     String attributeName,
                     String type,
                     String valueDefault,
                     String value)
Method Detail

getElementName

public String getElementName()
Getter for property elementName.

Returns:
Value of property elementName.

setElementName

public void setElementName(String elementName)
Setter for property elementName.

Parameters:
elementName - New value of property elementName.

getAttributeName

public String getAttributeName()
Getter for property attributeName.

Returns:
Value of property attributeName.

setAttributeName

public void setAttributeName(String attributeName)
Setter for property attributeName.

Parameters:
attributeName - New value of property attributeName.

getType

public String getType()
Getter for property type.

Returns:
Value of property type.

setType

public void setType(String type)
Setter for property type.

Parameters:
type - New value of property type.

getValue

public String getValue()
Getter for property value.

Returns:
Value of property value.

setValue

public void setValue(String value)
Setter for property value.

Parameters:
value - New value of property value.

getValueDefault

public String getValueDefault()
Getter for property valueDefault.

Returns:
Value of property valueDefault.

setValueDefault

public void setValueDefault(String valueDefault)
Setter for property valueDefault.

Parameters:
valueDefault - New value of property valueDefault.

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ElementDecl (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dtd
Class ElementDecl

java.lang.Object
    extended by org.dom4j.dtd.ElementDecl
public class ElementDecl
extends Object

AttributeDecl represents an element declaration in a DTD.

Version:
$Revision: 1.6 $
Author:
James Strachan

Constructor Summary
ElementDecl()
ElementDecl(String name, String model)
Method Summary
String | getModel() Getter for property model.
String | getName() Getter for property name.
void | setModel(String model) Setter for property model.
void | setName(String name) Setter for property name.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ElementDecl

public ElementDecl()

ElementDecl

public ElementDecl(String name,
                   String model)
Method Detail

getName

public String getName()
Getter for property name.

Returns:
Value of property name.

setName

public void setName(String name)
Setter for property name.

Parameters:
name - New value of property name.

getModel

public String getModel()
Getter for property model.

Returns:
Value of property model.

setModel

public void setModel(String model)
Setter for property model.

Parameters:
model - New value of property model.

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExternalEntityDecl (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dtd
Class ExternalEntityDecl

java.lang.Object
    extended by org.dom4j.dtd.ExternalEntityDecl
public class ExternalEntityDecl
extends Object

ExternalEntityDecl represents an external entity declaration in a DTD.

Version:
$Revision: 1.9 $
Author:
James Strachan

Constructor Summary
ExternalEntityDecl()
ExternalEntityDecl(String name, String publicID, String systemID)
Method Summary
String | getName() Getter for property name.
String | getPublicID() Getter for property publicID.
String | getSystemID() Getter for property systemID.
void | setName(String name) Setter for property name.
void | setPublicID(String publicID) Setter for property publicID.
void | setSystemID(String systemID) Setter for property systemID.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

ExternalEntityDecl

public ExternalEntityDecl()

ExternalEntityDecl

public ExternalEntityDecl(String name,
                          String publicID,
                          String systemID)
Method Detail

getName

public String getName()
Getter for property name.

Returns:
Value of property name.

setName

public void setName(String name)
Setter for property name.

Parameters:
name - New value of property name.

getPublicID

public String getPublicID()
Getter for property publicID.

Returns:
Value of property publicID.

setPublicID

public void setPublicID(String publicID)
Setter for property publicID.

Parameters:
publicID - New value of property publicID.

getSystemID

public String getSystemID()
Getter for property systemID.

Returns:
Value of property systemID.

setSystemID

public void setSystemID(String systemID)
Setter for property systemID.

Parameters:
systemID - New value of property systemID.

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


InternalEntityDecl (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.dtd
Class InternalEntityDecl

java.lang.Object
    extended by org.dom4j.dtd.InternalEntityDecl
public class InternalEntityDecl
extends Object

InternalEntityDecl represents an internal entity declaration in a DTD.

Version:
$Revision: 1.9 $
Author:
James Strachan

Constructor Summary
InternalEntityDecl()
InternalEntityDecl(String name, String value)
Method Summary
String | getName() Getter for property name.
String | getValue() Getter for property value.
void | setName(String name) Setter for property name.
void | setValue(String value) Setter for property value.
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

InternalEntityDecl

public InternalEntityDecl()

InternalEntityDecl

public InternalEntityDecl(String name,
                          String value)
Method Detail

getName

public String getName()
Getter for property name.

Returns:
Value of property name.

setName

public void setName(String name)
Setter for property name.

Parameters:
name - New value of property name.

getValue

public String getValue()
Getter for property value.

Returns:
Value of property value.

setValue

public void setValue(String value)
Setter for property value.

Parameters:
value - New value of property value.

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.io (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.io

Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.

See:
Description

Interface Summary
ElementModifier ElementModifier defines a modifier of Elementobjects.

Class Summary
DocumentResult | DocumentResult implements a JAXP SAXResultfor a Document.
DocumentSource | DocumentSource implements a JAXP SAXSourcefor a .
DOMReader | DOMReader navigates a W3C DOM tree and creates a DOM4J tree from it.
DOMWriter | DOMWriter takes a DOM4J tree and outputs it as a W3C DOM object
HTMLWriter | HTMLWriter takes a DOM4J tree and formats it to a stream as HTML.
OutputFormat | OutputFormat represents the format configuration used by and its base classes to format the XML output
SAXContentHandler | SAXContentHandler builds a dom4j tree via SAX events.
SAXEventRecorder | Records SAX events such that they may be "replayed" at a later time.
SAXModifier | The SAXModifier reads, modifies and writes XML documents using SAX.
SAXReader | SAXReader creates a DOM4J tree from SAX parsing events.
SAXReader.SAXEntityResolver |
SAXValidator | SAXValidator validates an XML document by writing the document to a text buffer and parsing it with a validating SAX parser.
SAXWriter | SAXWriter writes a DOM4J tree to a SAX ContentHandler.
STAXEventReader | Reads a DOM4J Document, as well as other Nodes, from a StAX XMLEventReader.
STAXEventWriter | Writes DOM4J Nodes to a StAX event stream.
XMLResult | XMLResult implements a JAXP SAXResultfor an output stream with support for pretty printing and control over how the XML is formatted.
XMLWriter | XMLWriter takes a DOM4J tree and formats it to a stream as XML.
XPP3Reader | XPP3Reader is a Reader of DOM4J documents that uses the fast XML Pull Parser 3.x .
XPPReader | XPPReader is a Reader of DOM4J documents that uses the fast XML Pull Parser 2.x .

Package org.dom4j.io Description

Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.


org.dom4j.io Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.io

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class org.dom4j.io.SAXContentHandler (implements org.xml.sax.ext.DeclHandler, org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
      • class org.dom4j.io.SAXEventRecorder (implements org.xml.sax.ext.DeclHandler, org.xml.sax.DTDHandler, java.io.Externalizable, org.xml.sax.ext.LexicalHandler)
    • class org.dom4j.io.DOMReader
    • class org.dom4j.io.DOMWriter
    • class org.dom4j.io.OutputFormat (implements java.lang.Cloneable)
    • class org.dom4j.io.SAXModifier
    • class org.dom4j.io.SAXReader
    • class org.dom4j.io.SAXReader.SAXEntityResolver (implements org.xml.sax.EntityResolver, java.io.Serializable)
    • class javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • class org.dom4j.io.DocumentResult
      • class org.dom4j.io.XMLResult
    • class javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • class org.dom4j.io.DocumentSource
    • class org.dom4j.io.SAXValidator
    • class org.dom4j.io.SAXWriter (implements org.xml.sax.XMLReader)
    • class org.dom4j.io.STAXEventReader
    • class org.dom4j.io.STAXEventWriter
    • class org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
      • class org.dom4j.io.XMLWriter (implements org.xml.sax.ext.LexicalHandler)
        • class org.dom4j.io.HTMLWriter
    • class org.dom4j.io.XPP3Reader
    • class org.dom4j.io.XPPReader

Interface Hierarchy

  • interface org.dom4j.io.ElementModifier


Uses of Package org.dom4j.io (dom4j 1.6.1 API)

Uses of Package
org.dom4j.io

Packages that use org.dom4j.io
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.jaxb |

Classes in org.dom4j.io used by org.dom4j.io
ElementModifier
ElementModifier defines a modifier of Elementobjects.
OutputFormat
OutputFormat represents the format configuration used by and its base classes to format the XML output
SAXContentHandler
SAXContentHandler builds a dom4j tree via SAX events.
XMLWriter
XMLWriter takes a DOM4J tree and formats it to a stream as XML.

Classes in org.dom4j.io used by org.dom4j.jaxb
OutputFormat
OutputFormat represents the format configuration used by and its base classes to format the XML output

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ElementModifier (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Interface ElementModifier

public interface ElementModifier

ElementModifier defines a modifier of Elementobjects.
It can be used in the event based SAXModifier, in order to modify elements on the fly, rather than waiting until the complete document is parsed.

Author:
Wonne Keysers (Realsoftware.be)

Method Summary
 Element modifyElement(Element element)
Called by an event based processor when an elements closing tag is encountered.

Method Detail

modifyElement

public Element modifyElement(Element element)
                      throws Exception
Called by an event based processor when an elements closing tag is encountered. This method must return the modified version of the provided Elementor null if it has to be removed from the document.
The incoming Elementis disconnected from the DOM4J tree. This means that navigation to the elements parent Element and Documentare not available. Only the element itself can be modified!

Parameters:
element - Elementto be parsed
Returns:
the modified Element
Throws:
Exception - of any kind
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DocumentResult (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class DocumentResult

java.lang.Object
    extended by javax.xml.transform.sax.SAXResult
        extended by org.dom4j.io.DocumentResult
All Implemented Interfaces:
Result
public class DocumentResult
extends SAXResult

DocumentResult implements a JAXP SAXResultfor a Document.

Version:
$Revision: 1.8 $
Author:
James Strachan

Field Summary
Fields inherited from class javax.xml.transform.sax.SAXResult
FEATURE
Fields inherited from interface javax.xml.transform.Result
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
Constructor Summary
DocumentResult()
DocumentResult(SAXContentHandler contentHandler)
Method Summary
Document | getDocument() DOCUMENT ME!
void | setHandler(ContentHandler handler)
void | setLexicalHandler(LexicalHandler handler)
Methods inherited from class javax.xml.transform.sax.SAXResult
getHandler, getLexicalHandler, getSystemId, setSystemId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DocumentResult

public DocumentResult()

DocumentResult

public DocumentResult(SAXContentHandler contentHandler)
Method Detail

getDocument

public Document getDocument()
DOCUMENT ME!

Returns:
the Document created by the transformation

setHandler

public void setHandler(ContentHandler handler)

setLexicalHandler

public void setLexicalHandler(LexicalHandler handler)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DocumentSource (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class DocumentSource

java.lang.Object
    extended by javax.xml.transform.sax.SAXSource
        extended by org.dom4j.io.DocumentSource
All Implemented Interfaces:
Source
public class DocumentSource
extends SAXSource

DocumentSource implements a JAXP SAXSourcefor a .

Version:
$Revision: 1.10 $
Author:
James Strachan

Field Summary
static String DOM4J_FEATURE
If TransformerFactory.getFeature(java.lang.String)returns true when passed this value as an argument then the Transformer natively supports dom4j .
Fields inherited from class javax.xml.transform.sax.SAXSource
FEATURE
Constructor Summary
DocumentSource(Document document)
Creates a JAXP SAXSourcefor the given Document.
DocumentSource(Node node)
Creates a JAXP SAXSourcefor the given Node.
Method Summary
Document | getDocument() DOCUMENT ME!
XMLReader | getXMLReader() DOCUMENT ME!
void | setDocument(Document document) Sets the document used as the JAXP SAXSource
void | setInputSource(InputSource inputSource) This method is not supported as this source is always a instance.
void | setXMLReader(XMLReader reader) Sets the XMLReader used for the JAXP SAXSource.
Methods inherited from class javax.xml.transform.sax.SAXSource
getInputSource, getSystemId, setSystemId, sourceToInputSource
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DOM4J_FEATURE

public static final String DOM4J_FEATURE
If TransformerFactory.getFeature(java.lang.String)returns true when passed this value as an argument then the Transformer natively supports dom4j .

See Also:
Constant Field Values
Constructor Detail

DocumentSource

public DocumentSource(Node node)
Creates a JAXP SAXSourcefor the given Node.

Parameters:
node - DOCUMENT ME!

DocumentSource

public DocumentSource(Document document)
Creates a JAXP SAXSourcefor the given Document.

Parameters:
document - DOCUMENT ME!
Method Detail

getDocument

public Document getDocument()
DOCUMENT ME!

Returns:
the document which is being used as the JAXP SAXSource

setDocument

public void setDocument(Document document)
Sets the document used as the JAXP SAXSource

Parameters:
document - DOCUMENT ME!

getXMLReader

public XMLReader getXMLReader()
DOCUMENT ME!

Returns:
the XMLReader to be used for the JAXP SAXSource.

setInputSource

public void setInputSource(InputSource inputSource)
                    throws UnsupportedOperationException
This method is not supported as this source is always a instance.

Parameters:
inputSource - DOCUMENT ME!
Throws:
UnsupportedOperationException - as this method is unsupported

setXMLReader

public void setXMLReader(XMLReader reader)
                  throws UnsupportedOperationException
Sets the XMLReader used for the JAXP SAXSource.

Parameters:
reader - DOCUMENT ME!
Throws:
UnsupportedOperationException - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMReader (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class DOMReader

java.lang.Object
    extended by org.dom4j.io.DOMReader
public class DOMReader
extends Object

DOMReader navigates a W3C DOM tree and creates a DOM4J tree from it.

Version:
$Revision: 1.17 $
Author:
James Strachan

Constructor Summary
DOMReader()
DOMReader(DocumentFactory factory)
Method Summary
protected void | clearNamespaceStack()
protected Document | createDocument()
DocumentFactory | getDocumentFactory() DOCUMENT ME!
protected Namespace | getNamespace(String prefix, String uri)
Document | read(Document domDocument)
protected void | readElement(Node node, Branch current)
protected void | readTree(Node node, Branch current)
void | setDocumentFactory(DocumentFactory docFactory) This sets the DocumentFactory used to create new documents.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DOMReader

public DOMReader()

DOMReader

public DOMReader(DocumentFactory factory)
Method Detail

getDocumentFactory

public DocumentFactory getDocumentFactory()
DOCUMENT ME!

Returns:
the DocumentFactory used to create document objects

setDocumentFactory

public void setDocumentFactory(DocumentFactory docFactory)

This sets the DocumentFactory used to create new documents. This method allows the building of custom DOM4J tree objects to be implemented easily using a custom derivation of DocumentFactory

Parameters:
docFactory - DocumentFactory used to create DOM4J objects

read

public Document read(Document domDocument)

readTree

protected void readTree(Node node,
                        Branch current)

readElement

protected void readElement(Node node,
                           Branch current)

getNamespace

protected Namespace getNamespace(String prefix,
                                 String uri)

createDocument

protected Document createDocument()

clearNamespaceStack

protected void clearNamespaceStack()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DOMWriter (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class DOMWriter

java.lang.Object
    extended by org.dom4j.io.DOMWriter
public class DOMWriter
extends Object

DOMWriter takes a DOM4J tree and outputs it as a W3C DOM object

Version:
$Revision: 1.17 $
Author:
James Strachan

Constructor Summary
DOMWriter()
DOMWriter(Class domDocumentClass)
Method Summary
protected void | appendDOMTree(Document domDocument, Node domCurrent, CDATA cdata)
protected void | appendDOMTree(Document domDocument, Node domCurrent, Comment comment)
protected void | appendDOMTree(Document domDocument, Node domCurrent, Element element)
protected void | appendDOMTree(Document domDocument, Node domCurrent, Entity entity)
protected void | appendDOMTree(Document domDocument, Node domCurrent, List content)
protected void | appendDOMTree(Document domDoc, Node domCurrent, ProcessingInstruction pi)
protected void | appendDOMTree(Document domDocument, Node domCurrent, String text)
protected String | attributeNameForNamespace(Namespace namespace)
protected Document | createDomDocument(Document document)
protected Document | createDomDocument(Document document, DOMImplementation domImpl)
protected Document | createDomDocumentViaJAXP()
Class | getDomDocumentClass()
protected boolean | isNamespaceDeclaration(Namespace ns)
protected void | resetNamespaceStack()
void | setDomDocumentClass(Class domDocumentClass) Sets the DOM Documentimplementation class used by the writer when creating DOM documents.
void | setDomDocumentClassName(String name) Sets the DOM Documentimplementation class name used by the writer when creating DOM documents.
Document | write(Document document)
Document | write(Document document, DOMImplementation domImpl)
protected void | writeNamespace(Element domElement, Namespace namespace)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DOMWriter

public DOMWriter()

DOMWriter

public DOMWriter(Class domDocumentClass)
Method Detail

getDomDocumentClass

public Class getDomDocumentClass()
                          throws DocumentException
Throws:
DocumentException

setDomDocumentClass

public void setDomDocumentClass(Class domDocumentClass)
Sets the DOM Documentimplementation class used by the writer when creating DOM documents.

Parameters:
domDocumentClass - is the Class implementing the interface

setDomDocumentClassName

public void setDomDocumentClassName(String name)
                             throws DocumentException
Sets the DOM Documentimplementation class name used by the writer when creating DOM documents.

Parameters:
name - is the name of the Class implementing the Document interface
Throws:
DocumentException - if the class could not be loaded

write

public Document write(Document document)
               throws DocumentException
Throws:
DocumentException

write

public Document write(Document document,
                      DOMImplementation domImpl)
               throws DocumentException
Throws:
DocumentException

appendDOMTree

protected void appendDOMTree(Document domDocument,
                             Node domCurrent,
                             List content)

appendDOMTree

protected void appendDOMTree(Document domDocument,
                             Node domCurrent,
                             Element element)

appendDOMTree

protected void appendDOMTree(Document domDocument,
                             Node domCurrent,
                             CDATA cdata)

appendDOMTree

protected void appendDOMTree(Document domDocument,
                             Node domCurrent,
                             Comment comment)

appendDOMTree

protected void appendDOMTree(Document domDocument,
                             Node domCurrent,
                             String text)

appendDOMTree

protected void appendDOMTree(Document domDocument,
                             Node domCurrent,
                             Entity entity)

appendDOMTree

protected void appendDOMTree(Document domDoc,
                             Node domCurrent,
                             ProcessingInstruction pi)

writeNamespace

protected void writeNamespace(Element domElement,
                              Namespace namespace)

attributeNameForNamespace

protected String attributeNameForNamespace(Namespace namespace)

createDomDocument

protected Document createDomDocument(Document document)
                              throws DocumentException
Throws:
DocumentException

createDomDocumentViaJAXP

protected Document createDomDocumentViaJAXP()
                                     throws DocumentException
Throws:
DocumentException

createDomDocument

protected Document createDomDocument(Document document,
                                     DOMImplementation domImpl)
                              throws DocumentException
Throws:
DocumentException

isNamespaceDeclaration

protected boolean isNamespaceDeclaration(Namespace ns)

resetNamespaceStack

protected void resetNamespaceStack()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HTMLWriter (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class HTMLWriter

java.lang.Object
    extended by org.xml.sax.helpers.XMLFilterImpl
        extended by org.dom4j.io.XMLWriter
            extended by org.dom4j.io.HTMLWriter
All Implemented Interfaces:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler, LexicalHandler, XMLFilter, XMLReader
public class HTMLWriter
extends XMLWriter

HTMLWriter takes a DOM4J tree and formats it to a stream as HTML. This formatter is similar to XMLWriter but it outputs the text of CDATA and Entity sections rather than the serialised format as in XML, it has an XHTML mode, it retains whitespace in certain elements such as <PRE>, and it supports certain elements which have no corresponding close tag such as for <BR> and <P>.

The OutputFormat passed in to the constructor is checked for isXHTML() and isExpandEmptyElements(). See OutputFormatfor details. Here are the rules for this class based on an OutputFormat, "format", passed in to the constructor:

  • If an element is in getOmitElementCloseSet, then it is treated specially:
    • It never expands, since some browsers treat this as two separate Horizontal Rules: <HR></HR>
    • If format.isXHTML(), then it has a space before the closing single-tag slash, since Netscape 4.x- treats this: <HR /> as an element named "HR" with an attribute named "/", but that's better than when it refuses to recognize this: <hr/> which it thinks is an element named "HR/".
  • If format.isXHTML(), all elements must have either a close element, or be a closed single tag.
  • If format.isExpandEmptyElements()() is true, all elements are expanded except as above.
Examples

If isXHTML == true, CDATA sections look like this:

 <myelement><![CDATA[My data]]></myelement>
Otherwise, they look like this:

 <myelement>My data</myelement>

Basically, OutputFormat.isXHTML() == true will produce valid XML, while format.isExpandEmptyElements() determines whether empty elements are expanded if isXHTML is true, excepting the special HTML single tags.

Also, HTMLWriter handles tags whose contents should be preformatted, that is, whitespace-preserved. By default, this set includes the tags <PRE>, <SCRIPT>, <STYLE>, and <TEXTAREA>, case insensitively. It does not include <IFRAME>. Other tags, such as <CODE>, <KBD>, <TT>, <VAR>, are usually rendered in a different font in most browsers, but don't preserve whitespace, so they also don't appear in the default list. HTML Comments are always whitespace-preserved. However, the parser you use may store comments with linefeed-only text nodes (\n) even if your platform uses another line.separator character, and HTMLWriter outputs Comment nodes exactly as the DOM is set up by the parser. See examples and discussion here:

Examples

Pretty Printing

This example shows how to pretty print a string containing a valid HTML document to a string. You can also just call the static methods of this class:
prettyPrintHTML(String)or
prettyPrintHTML(String,boolean,boolean,boolean,boolean) or,
prettyPrintXHTML(String)for XHTML (note the X)

 String testPrettyPrint(String html) {
     StringWriter sw = new StringWriter();
     OutputFormat format = OutputFormat.createPrettyPrint();
     // These are the default values for createPrettyPrint,
     // so you needn't set them:
     // format.setNewlines(true);
     // format.setTrimText(true);</font>
     format.setXHTML(true);
     HTMLWriter writer = new HTMLWriter(sw, format);
     Document document = DocumentHelper.parseText(html);
     writer.write(document);
     writer.flush();
     return sw.toString();
 }

This example shows how to create a "squeezed" document, but one that will work in browsers even if the browser line length is limited. No newlines are included, no extra whitespace at all, except where it it required by setPreformattedTags.

 String testCrunch(String html) {
     StringWriter sw = new StringWriter();
     OutputFormat format = OutputFormat.createPrettyPrint();
     format.setNewlines(false);
     format.setTrimText(true);
     format.setIndent("");
     format.setXHTML(true);
     format.setExpandEmptyElements(false);
     format.setNewLineAfterNTags(20);
     org.dom4j.io.HTMLWriter writer = new HTMLWriter(sw, format);
     org.dom4j.Document document = DocumentHelper.parseText(html);
     writer.write(document);
     writer.flush();
     return sw.toString();
 }

Version:
$Revision: 1.21 $
Author:
James Strachan , Laramie Crocker

Field Summary
protected static OutputFormat | DEFAULT_HTML_FORMAT
protected static HashSet | DEFAULT_PREFORMATTED_TAGS
Fields inherited from class org.dom4j.io.XMLWriter
DEFAULT_FORMAT, lastOutputNodeType, LEXICAL_HANDLER_NAMES, preserve, writer
Constructor Summary
HTMLWriter()
HTMLWriter(OutputFormat format)
HTMLWriter(OutputStream out)
HTMLWriter(OutputStream out, OutputFormat format)
HTMLWriter(Writer writer)
HTMLWriter(Writer writer, OutputFormat format)
Method Summary
void | endCDATA()
Set | getOmitElementCloseSet() A clone of the Set of elements that can have their close-tags omitted.
Set | getPreformattedTags()
boolean | isPreformattedTag(String qualifiedName) DOCUMENT ME!
protected void | loadOmitElementCloseSet(Set set)
protected boolean | omitElementClose(String qualifiedName)
static String | prettyPrintHTML(String html) Convenience method to just get a String result.
static String | prettyPrintHTML(String html, boolean newlines, boolean trim, boolean isXHTML, boolean expandEmpty) DOCUMENT ME!
static String | prettyPrintXHTML(String html) Convenience method to just get a String result, but As XHTML .
void | setOmitElementCloseSet(Set newSet) To use the empty set, pass an empty Set, or null: setOmitElementCloseSet(new HashSet()); or setOmitElementCloseSet(null);
void | setPreformattedTags(Set newSet) Override the default set, which includes PRE, SCRIPT, STYLE, and TEXTAREA, case insensitively.
void | startCDATA()
protected void | writeCDATA(String text)
protected void | writeClose(String qualifiedName) Overriden method to not close certain element names to avoid wierd behaviour from browsers for versions up to 5.x
protected void | writeDeclaration() This will write the declaration to the given Writer.
protected void | writeElement(Element element) This override handles any elements that should not remove whitespace, such as <PRE>, <SCRIPT>, <STYLE>, and <TEXTAREA>.
protected void | writeEmptyElementClose(String qualifiedName)
protected void | writeEntity(Entity entity)
protected void | writeString(String text)
Methods inherited from class org.dom4j.io.XMLWriter
characters, close, comment, createWriter, defaultMaximumAllowedCharacter, endDocument, endDTD, endElement, endEntity, endPrefixMapping, escapeAttributeEntities, escapeElementEntities, flush, getLexicalHandler, getMaximumAllowedCharacter, getOutputFormat, getProperty, handleException, ignorableWhitespace, indent, installLexicalHandler, isElementSpacePreserved, isEscapeText, isExpandEmptyElements, isNamespaceDeclaration, notationDecl, parse, println, processingInstruction, resolveEntityRefs, setDocumentLocator, setEscapeText, setIndentLevel, setLexicalHandler, setMaximumAllowedCharacter, setOutputStream, setProperty, setResolveEntityRefs, setWriter, shouldEncodeChar, startDocument, startDTD, startElement, startEntity, startPrefixMapping, unparsedEntityDecl, write, write, write, write, write, write, write, write, write, write, write, write, write, writeAttribute, writeAttribute, writeAttributes, writeAttributes, writeClose, writeComment, writeDocType, writeDocType, writeElementContent, writeEntityRef, writeEscapeAttributeEntities, writeNamespace, writeNamespace, writeNamespaces, writeNode, writeNodeText, writeOpen, writePrintln, writeProcessingInstruction
Methods inherited from class org.xml.sax.helpers.XMLFilterImpl
error, fatalError, getContentHandler, getDTDHandler, getEntityResolver, getErrorHandler, getFeature, getParent, parse, resolveEntity, setContentHandler, setDTDHandler, setEntityResolver, setErrorHandler, setFeature, setParent, skippedEntity, warning
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

DEFAULT_PREFORMATTED_TAGS

protected static final HashSet DEFAULT_PREFORMATTED_TAGS

DEFAULT_HTML_FORMAT

protected static final OutputFormat DEFAULT_HTML_FORMAT
Constructor Detail

HTMLWriter

public HTMLWriter(Writer writer)

HTMLWriter

public HTMLWriter(Writer writer,
                  OutputFormat format)

HTMLWriter

public HTMLWriter()
           throws UnsupportedEncodingException

HTMLWriter

public HTMLWriter(OutputFormat format)
           throws UnsupportedEncodingException

HTMLWriter

public HTMLWriter(OutputStream out)
           throws UnsupportedEncodingException

HTMLWriter

public HTMLWriter(OutputStream out,
                  OutputFormat format)
           throws UnsupportedEncodingException
Method Detail

startCDATA

public void startCDATA()
                throws SAXException
Specified by:
startCDATA in interface LexicalHandler
Overrides:
startCDATA in class XMLWriter
Throws:
SAXException

endCDATA

public void endCDATA()
              throws SAXException
Specified by:
endCDATA in interface LexicalHandler
Overrides:
endCDATA in class XMLWriter
Throws:
SAXException

writeCDATA

protected void writeCDATA(String text)
                   throws IOException
Overrides:
writeCDATA in class XMLWriter
Throws:
IOException

writeEntity

protected void writeEntity(Entity entity)
                    throws IOException
Overrides:
writeEntity in class XMLWriter
Throws:
IOException

writeDeclaration

protected void writeDeclaration()
                         throws IOException
Description copied from class: XMLWriter

This will write the declaration to the given Writer. Assumes XML version 1.0 since we don't directly know.

Overrides:
writeDeclaration in class XMLWriter
Throws:
IOException - DOCUMENT ME!

writeString

protected void writeString(String text)
                    throws IOException
Overrides:
writeString in class XMLWriter
Throws:
IOException

writeClose

protected void writeClose(String qualifiedName)
                   throws IOException
Overriden method to not close certain element names to avoid wierd behaviour from browsers for versions up to 5.x

Overrides:
writeClose in class XMLWriter
Parameters:
qualifiedName - DOCUMENT ME!
Throws:
IOException - DOCUMENT ME!

writeEmptyElementClose

protected void writeEmptyElementClose(String qualifiedName)
                               throws IOException
Overrides:
writeEmptyElementClose in class XMLWriter
Throws:
IOException

omitElementClose

protected boolean omitElementClose(String qualifiedName)

loadOmitElementCloseSet

protected void loadOmitElementCloseSet(Set set)

getOmitElementCloseSet

public Set getOmitElementCloseSet()
A clone of the Set of elements that can have their close-tags omitted. By default it should be "AREA", "BASE", "BR", "COL", "HR", "IMG", "INPUT", "LINK", "META", "P", "PARAM"

Returns:
A clone of the Set.

setOmitElementCloseSet

public void setOmitElementCloseSet(Set newSet)
To use the empty set, pass an empty Set, or null:

       setOmitElementCloseSet(new HashSet());
     or
       setOmitElementCloseSet(null);

Parameters:
newSet - DOCUMENT ME!

getPreformattedTags

public Set getPreformattedTags()
See Also:
setPreformattedTags

setPreformattedTags

public void setPreformattedTags(Set newSet)

Override the default set, which includes PRE, SCRIPT, STYLE, and TEXTAREA, case insensitively.

Setting Preformatted Tags

Pass in a Set of Strings, one for each tag name that should be treated like a PRE tag. You may pass in null or an empty Set to assign the empty set, in which case no tags will be treated as preformatted, except that HTML Comments will continue to be preformatted. If a tag is included in the set of preformatted tags, all whitespace within the tag will be preserved, including whitespace on the same line preceding the close tag. This will generally make the close tag not line up with the start tag, but it preserves the intention of the whitespace within the tag.

The browser considers leading whitespace before the close tag to be significant, but leading whitespace before the open tag to be insignificant. For example, if the HTML author doesn't put the close TEXTAREA tag flush to the left margin, then the TEXTAREA control in the browser will have spaces on the last line inside the control. This may be the HTML author's intent. Similarly, in a PRE, the browser treats a flushed left close PRE tag as different from a close tag with leading whitespace. Again, this must be left up to the HTML author.

Examples

Here is an example of how you can set the PreformattedTags list using setPreformattedTags to include IFRAME, as well as the default set, if you have an instance of this class named myHTMLWriter:

 Set current = myHTMLWriter.getPreformattedTags();
 current.add("IFRAME");
 myHTMLWriter.setPreformattedTags(current);

 //The set is now <b>PRE, SCRIPT, STYLE, TEXTAREA, IFRAME</b>
Similarly, you can simply replace it with your own:

       HashSet newset = new HashSet();
       newset.add("PRE");
       newset.add("TEXTAREA");
       myHTMLWriter.setPreformattedTags(newset);

       //The set is now <b>{PRE, TEXTAREA}</b>
You can remove all tags from the preformatted tags list, with an empty set, like this:

       myHTMLWriter.setPreformattedTags(new HashSet());

       //The set is now <b>{}</b>
or with null, like this:

       myHTMLWriter.setPreformattedTags(null);

       //The set is now <b>{}</b>

Parameters:
newSet - DOCUMENT ME!

isPreformattedTag

public boolean isPreformattedTag(String qualifiedName)
DOCUMENT ME!

Parameters:
qualifiedName - DOCUMENT ME!
Returns:
true if the qualifiedName passed in matched (case-insensitively) a tag in the preformattedTags set, or false if not found or if the set is empty or null.
See Also:
setPreformattedTags

writeElement

protected void writeElement(Element element)
                     throws IOException
This override handles any elements that should not remove whitespace, such as <PRE>, <SCRIPT>, <STYLE>, and <TEXTAREA>. Note: the close tags won't line up with the open tag, but we can't alter that. See javadoc note at setPreformattedTags.

Overrides:
writeElement in class XMLWriter
Parameters:
element - DOCUMENT ME!
Throws:
IOException - When the stream could not be written to.
See Also:
setPreformattedTags

prettyPrintHTML

public static String prettyPrintHTML(String html)
                              throws IOException,
                                     UnsupportedEncodingException,
                                     DocumentException
Convenience method to just get a String result.

Parameters:
html - DOCUMENT ME!
Returns:
a pretty printed String from the source string, preserving whitespace in the defaultPreformattedTags set, and leaving the close tags off of the default omitElementCloseSet set. Use one of the write methods if you want stream output.
Throws:
IOException
UnsupportedEncodingException
DocumentException

prettyPrintXHTML

public static String prettyPrintXHTML(String html)
                               throws IOException,
                                      UnsupportedEncodingException,
                                      DocumentException
Convenience method to just get a String result, but As XHTML .

Parameters:
html - DOCUMENT ME!
Returns:
a pretty printed String from the source string, preserving whitespace in the defaultPreformattedTags set, but conforming to XHTML: no close tags are omitted (though if empty, they will be converted to XHTML empty tags: <HR/> Use one of the write methods if you want stream output.
Throws:
IOException
UnsupportedEncodingException
DocumentException

prettyPrintHTML

public static String prettyPrintHTML(String html,
                                     boolean newlines,
                                     boolean trim,
                                     boolean isXHTML,
                                     boolean expandEmpty)
                              throws IOException,
                                     UnsupportedEncodingException,
                                     DocumentException
DOCUMENT ME!

Parameters:
html - DOCUMENT ME!
newlines - DOCUMENT ME!
trim - DOCUMENT ME!
isXHTML - DOCUMENT ME!
expandEmpty - DOCUMENT ME!
Returns:
a pretty printed String from the source string, preserving whitespace in the defaultPreformattedTags set, and leaving the close tags off of the default omitElementCloseSet set. This override allows you to specify various formatter options. Use one of the write methods if you want stream output.
Throws:
IOException
UnsupportedEncodingException
DocumentException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OutputFormat (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class OutputFormat

java.lang.Object
    extended by org.dom4j.io.OutputFormat
All Implemented Interfaces:
Cloneable
public class OutputFormat
extends Object
implements Cloneable

OutputFormat represents the format configuration used by and its base classes to format the XML output

Version:
$Revision: 1.17 $
Author:
James Strachan

Field Summary
protected static String STANDARD_INDENT
standard value to indent by, if we are indenting
Constructor Summary
OutputFormat()
Creates an OutputFormat with no additional whitespace (indent or new lines) added.
OutputFormat(String indent)
Creates an OutputFormat with the given indent added but no new lines added.
OutputFormat(String indent, boolean newlines)
Creates an OutputFormat with the given indent added with optional newlines between the Elements.
OutputFormat(String indent, boolean newlines, String encoding)
Creates an OutputFormat with the given indent added with optional newlines between the Elements and the given encoding format.
Method Summary
static OutputFormat | createCompactFormat() A static helper method to create the default compact format.
static OutputFormat | createPrettyPrint() A static helper method to create the default pretty printing format.
char | getAttributeQuoteCharacter()
String | getEncoding()
String | getIndent()
String | getLineSeparator()
int | getNewLineAfterNTags()
boolean | isExpandEmptyElements()
boolean | isNewLineAfterDeclaration() DOCUMENT ME!
boolean | isNewlines()
boolean | isOmitEncoding()
boolean | isPadText()
boolean | isSuppressDeclaration() DOCUMENT ME!
boolean | isTrimText()
boolean | isXHTML() Whether or not to use the XHTML standard: like HTML but passes an XML parser with real, closed tags.
int | parseOptions(String[] args, int i) Parses command line arguments of the form -omitEncoding -indentSize 3 -newlines -trimText
void | setAttributeQuoteCharacter(char quoteChar) Sets the character used to quote attribute values.
void | setEncoding(String encoding) DOCUMENT ME!
void | setExpandEmptyElements(boolean expandEmptyElements) This will set whether empty elements are expanded from <tagName> to <tagName></tagName>.
void | setIndent(boolean doIndent) Set the indent on or off.
void | setIndent(String indent) This will set the indent String to use; this is usually a String of empty spaces.
void | setIndentSize(int indentSize) This will set the indent String's size; an indentSize of 4 would result in the indention being equivalent to the String " " (four space characters).
void | setLineSeparator(String separator) This will set the new-line separator.
void | setNewLineAfterDeclaration(boolean newLineAfterDeclaration) This will set whether a new line is printed after the XML declaration (assuming it is not supressed.)
void | setNewLineAfterNTags(int tagCount) Controls output of a line.separator every tagCount tags when isNewlines is false.
void | setNewlines(boolean newlines) DOCUMENT ME!
void | setOmitEncoding(boolean omitEncoding) This will set whether the XML declaration (<?
void | setPadText(boolean padText) Ensure that text immediately preceded by or followed by an element will be "padded" with a single space.
void | setSuppressDeclaration(boolean suppressDeclaration) This will set whether the XML declaration (<?
void | setTrimText(boolean trimText) This will set whether the text is output verbatim (false) or with whitespace stripped as per Element.getTextTrim().
void | setXHTML(boolean xhtml) This will set whether or not to use the XHTML standard: like HTML but passes an XML parser with real, closed tags.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

STANDARD_INDENT

protected static final String STANDARD_INDENT
standard value to indent by, if we are indenting

See Also:
Constant Field Values
Constructor Detail

OutputFormat

public OutputFormat()
Creates an OutputFormat with no additional whitespace (indent or new lines) added. The whitespace from the element text content is fully preserved.

OutputFormat

public OutputFormat(String indent)
Creates an OutputFormat with the given indent added but no new lines added. All whitespace from element text will be included.

Parameters:
indent - is the indent string to be used for indentation (usually a number of spaces).

OutputFormat

public OutputFormat(String indent,
                    boolean newlines)
Creates an OutputFormat with the given indent added with optional newlines between the Elements. All whitespace from element text will be included.

Parameters:
indent - is the indent string to be used for indentation (usually a number of spaces).
newlines - whether new lines are added to layout the

OutputFormat

public OutputFormat(String indent,
                    boolean newlines,
                    String encoding)
Creates an OutputFormat with the given indent added with optional newlines between the Elements and the given encoding format.

Parameters:
indent - is the indent string to be used for indentation (usually a number of spaces).
newlines - whether new lines are added to layout the
encoding - is the text encoding to use for writing the XML
Method Detail

getLineSeparator

public String getLineSeparator()

setLineSeparator

public void setLineSeparator(String separator)

This will set the new-line separator. The default is \n. Note that if the "newlines" property is false, this value is irrelevant. To make it output the system default line ending string, call setLineSeparator(System.getProperty("line.separator"))

Parameters:
separator - String line separator to use.
See Also:
setNewlines(boolean)

isNewlines

public boolean isNewlines()

setNewlines

public void setNewlines(boolean newlines)
DOCUMENT ME!

Parameters:
newlines - true indicates new lines should be printed, else new lines are ignored (compacted).
See Also:
setLineSeparator(String)

getEncoding

public String getEncoding()

setEncoding

public void setEncoding(String encoding)
DOCUMENT ME!

Parameters:
encoding - encoding format

isOmitEncoding

public boolean isOmitEncoding()

setOmitEncoding

public void setOmitEncoding(boolean omitEncoding)

This will set whether the XML declaration (<?xml version="1.0" encoding="UTF-8"?>) includes the encoding of the document. It is common to suppress this in protocols such as WML and SOAP.

Parameters:
omitEncoding - boolean indicating whether or not the XML declaration should indicate the document encoding.

setSuppressDeclaration

public void setSuppressDeclaration(boolean suppressDeclaration)

This will set whether the XML declaration (<?xml version="1.0" encoding="UTF-8"?>) is included or not. It is common to suppress this in protocols such as WML and SOAP.

Parameters:
suppressDeclaration - boolean indicating whether or not the XML declaration should be suppressed.

isSuppressDeclaration

public boolean isSuppressDeclaration()
DOCUMENT ME!

Returns:
true if the output of the XML declaration (<?xml version="1.0"?>) should be suppressed else false.

setNewLineAfterDeclaration

public void setNewLineAfterDeclaration(boolean newLineAfterDeclaration)

This will set whether a new line is printed after the XML declaration (assuming it is not supressed.)

Parameters:
newLineAfterDeclaration - boolean indicating whether or not to print new line following the XML declaration. The default is true.

isNewLineAfterDeclaration

public boolean isNewLineAfterDeclaration()
DOCUMENT ME!

Returns:
true if a new line should be printed following XML declaration

isExpandEmptyElements

public boolean isExpandEmptyElements()

setExpandEmptyElements

public void setExpandEmptyElements(boolean expandEmptyElements)

This will set whether empty elements are expanded from <tagName> to <tagName></tagName>.

Parameters:
expandEmptyElements - boolean indicating whether or not empty elements should be expanded.

isTrimText

public boolean isTrimText()

setTrimText

public void setTrimText(boolean trimText)

This will set whether the text is output verbatim (false) or with whitespace stripped as per Element.getTextTrim().

Default: false

Parameters:
trimText - boolean true=>trim the whitespace, false=>use text verbatim

isPadText

public boolean isPadText()

setPadText

public void setPadText(boolean padText)

Ensure that text immediately preceded by or followed by an element will be "padded" with a single space. This is used to allow make browser-friendly HTML, avoiding trimText's transformation of, e.g., The quick <b>brown</b> fox into The quick<b>brown</b>fox (the latter will run the three separate words together into a single word). This setting is not too useful if you haven't also called setTrimText(boolean).

The padding string will only be added if the text itself starts or ends with some whitespace characters.

Default: false

Parameters:
padText - boolean if true, pad string-element boundaries

getIndent

public String getIndent()

setIndent

public void setIndent(String indent)

This will set the indent String to use; this is usually a String of empty spaces. If you pass null, or the empty string (""), then no indentation will happen.

Default: none (null)

Parameters:
indent - String to use for indentation.

setIndent

public void setIndent(boolean doIndent)
Set the indent on or off. If setting on, will use the value of STANDARD_INDENT, which is usually two spaces.

Parameters:
doIndent - if true, set indenting on; if false, set indenting off

setIndentSize

public void setIndentSize(int indentSize)

This will set the indent String's size; an indentSize of 4 would result in the indention being equivalent to the String " " (four space characters).

Parameters:
indentSize - int number of spaces in indentation.

isXHTML

public boolean isXHTML()

Whether or not to use the XHTML standard: like HTML but passes an XML parser with real, closed tags. Also, XHTML CDATA sections will be output with the CDATA delimiters: ( " <![CDATA[ " and " ]]> " ) otherwise, the class HTMLWriter will output the CDATA text, but not the delimiters.

Default is false

Returns:
DOCUMENT ME!

setXHTML

public void setXHTML(boolean xhtml)

This will set whether or not to use the XHTML standard: like HTML but passes an XML parser with real, closed tags. Also, XHTML CDATA sections will be output with the CDATA delimiters: ( " <[CDATA[ " and " ]]< ) otherwise, the class HTMLWriter will output the CDATA text, but not the delimiters.

Default: false

Parameters:
xhtml - boolean true=>conform to XHTML, false=>conform to HTML, can have unclosed tags, etc.

getNewLineAfterNTags

public int getNewLineAfterNTags()

setNewLineAfterNTags

public void setNewLineAfterNTags(int tagCount)
Controls output of a line.separator every tagCount tags when isNewlines is false. If tagCount equals zero, it means don't do anything special. If greater than zero, then a line.separator will be output after tagCount tags have been output. Used when you would like to squeeze the html as much as possible, but some browsers don't like really long lines. A tag count of 10 would produce a line.separator in the output after 10 close tags (including single tags).

Parameters:
tagCount - DOCUMENT ME!

getAttributeQuoteCharacter

public char getAttributeQuoteCharacter()

setAttributeQuoteCharacter

public void setAttributeQuoteCharacter(char quoteChar)
Sets the character used to quote attribute values. The specified character must be a valid XML attribute quote character, otherwise an IllegalArgumentException will be thrown.

Parameters:
quoteChar - The character to use when quoting attribute values.
Throws:
IllegalArgumentException - If the specified character is not a valid XML attribute quote character.

parseOptions

public int parseOptions(String[] args,
                        int i)
Parses command line arguments of the form -omitEncoding -indentSize 3 -newlines -trimText

Parameters:
args - is the array of command line arguments
i - is the index in args to start parsing options
Returns:
the index of first parameter that we didn't understand

createPrettyPrint

public static OutputFormat createPrettyPrint()
A static helper method to create the default pretty printing format. This format consists of an indent of 2 spaces, newlines after each element and all other whitespace trimmed, and XMTML is false.

Returns:
DOCUMENT ME!

createCompactFormat

public static OutputFormat createCompactFormat()
A static helper method to create the default compact format. This format does not have any indentation or newlines after an alement and all other whitespace trimmed

Returns:
DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SAXContentHandler (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class SAXContentHandler

java.lang.Object
    extended by org.xml.sax.helpers.DefaultHandler
        extended by org.dom4j.io.SAXContentHandler
All Implemented Interfaces:
ContentHandler, DeclHandler, DTDHandler, EntityResolver, ErrorHandler, LexicalHandler
public class SAXContentHandler
extends DefaultHandler
implements LexicalHandler, DeclHandler, DTDHandler

SAXContentHandler builds a dom4j tree via SAX events.

Version:
$Revision: 1.61 $
Author:
James Strachan

Constructor Summary
SAXContentHandler()
SAXContentHandler(DocumentFactory documentFactory)
SAXContentHandler(DocumentFactory documentFactory, ElementHandler elementHandler)
SAXContentHandler(DocumentFactory documentFactory, ElementHandler elementHandler, org.dom4j.io.ElementStack elementStack)
Method Summary
protected void | addAttributes(Element element, Attributes attributes) Add all the attributes to the given elements
protected void | addDeclaredNamespaces(Element element) Add all namespaces declared before the startElement() SAX event to the current element so that they are available to child elements and attributes
protected void | addDTDDeclaration(Object declaration) Adds an internal DTD declaration to the list of declarations
protected void | addExternalDTDDeclaration(Object declaration) Adds an external DTD declaration to the list of declarations
void | attributeDecl(String eName, String aName, String type, String valueDefault, String val) Report an attribute type declaration.
void | characters(char[] ch, int start, int end)
void | comment(char[] ch, int start, int end)
protected void | completeCurrentTextNode() If the current text buffer contains any text then create a new text node with it and add it to the current element
protected Document | createDocument() DOCUMENT ME!
protected org.dom4j.io.ElementStack | createElementStack()
void | elementDecl(String name, String model) Report an element type declaration.
void | endCDATA()
void | endDocument()
void | endDTD()
void | endElement(String namespaceURI, String localName, String qName)
void | endEntity(String name)
void | endPrefixMapping(String prefix)
void | error(SAXParseException exception) This method is called when an error is detected during parsing such as a validation error.
void | externalEntityDecl(String name, String publicId, String sysId) Report a parsed external entity declaration.
void | fatalError(SAXParseException exception) This method is called when a fatal error occurs during parsing.
Document | getDocument() DOCUMENT ME!
org.dom4j.io.ElementStack | getElementStack()
EntityResolver | getEntityResolver()
InputSource | getInputSource()
void | internalEntityDecl(String name, String value) Report an internal entity declaration.
protected boolean | isIgnorableEntity(String name) a Strategy Method to determine if a given entity name is ignorable
boolean | isIgnoreComments() Returns whether we should ignore comments or not.
boolean | isIncludeExternalDTDDeclarations() DOCUMENT ME!
boolean | isIncludeInternalDTDDeclarations() DOCUMENT ME!
boolean | isMergeAdjacentText() Returns whether adjacent text nodes should be merged together.
boolean | isStripWhitespaceText() Sets whether whitespace between element start and end tags should be ignored
void | notationDecl(String name, String publicId, String systemId) Receive notification of a notation declaration event.
void | processingInstruction(String target, String data)
void | setDocumentLocator(Locator documentLocator)
void | setElementStack(org.dom4j.io.ElementStack elementStack)
void | setEntityResolver(EntityResolver entityResolver)
void | setIgnoreComments(boolean ignoreComments) Sets whether we should ignore comments or not.
void | setIncludeExternalDTDDeclarations(boolean include) Sets whether DTD external declarations should be expanded into the DocumentType object or not.
void | setIncludeInternalDTDDeclarations(boolean include) Sets whether internal DTD declarations should be expanded into the DocumentType object or not.
void | setInputSource(InputSource inputSource)
void | setMergeAdjacentText(boolean mergeAdjacentText) Sets whether or not adjacent text nodes should be merged together when parsing.
void | setStripWhitespaceText(boolean stripWhitespaceText) Sets whether whitespace between element start and end tags should be ignored.
void | startCDATA()
void | startDocument()
void | startDTD(String name, String publicId, String systemId)
void | startElement(String namespaceURI, String localName, String qualifiedName, Attributes attributes)
void | startEntity(String name)
void | startPrefixMapping(String prefix, String uri)
void | unparsedEntityDecl(String name, String publicId, String systemId, String notationName) Receive notification of an unparsed entity declaration event.
void | warning(SAXParseException exception) This method is called when a warning occurs during the parsing of the document.
Methods inherited from class org.xml.sax.helpers.DefaultHandler
ignorableWhitespace, resolveEntity, skippedEntity
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SAXContentHandler

public SAXContentHandler()

SAXContentHandler

public SAXContentHandler(DocumentFactory documentFactory)

SAXContentHandler

public SAXContentHandler(DocumentFactory documentFactory,
                         ElementHandler elementHandler)

SAXContentHandler

public SAXContentHandler(DocumentFactory documentFactory,
                         ElementHandler elementHandler,
                         org.dom4j.io.ElementStack elementStack)
Method Detail

getDocument

public Document getDocument()
DOCUMENT ME!

Returns:
the document that has been or is being built

setDocumentLocator

public void setDocumentLocator(Locator documentLocator)
Specified by:
setDocumentLocator in interface ContentHandler

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String prefix)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Throws:
SAXException

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Throws:
SAXException

startElement

public void startElement(String namespaceURI,
                         String localName,
                         String qualifiedName,
                         Attributes attributes)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Throws:
SAXException

endElement

public void endElement(String namespaceURI,
                       String localName,
                       String qName)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Throws:
SAXException

characters

public void characters(char[] ch,
                       int start,
                       int end)
                throws SAXException
Specified by:
characters in interface ContentHandler
Throws:
SAXException

warning

public void warning(SAXParseException exception)
             throws SAXException
This method is called when a warning occurs during the parsing of the document. This method does nothing.

Specified by:
warning in interface ErrorHandler
Parameters:
exception - DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

error

public void error(SAXParseException exception)
           throws SAXException
This method is called when an error is detected during parsing such as a validation error. This method rethrows the exception

Specified by:
error in interface ErrorHandler
Parameters:
exception - DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

fatalError

public void fatalError(SAXParseException exception)
                throws SAXException
This method is called when a fatal error occurs during parsing. This method rethrows the exception

Specified by:
fatalError in interface ErrorHandler
Parameters:
exception - DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

startDTD

public void startDTD(String name,
                     String publicId,
                     String systemId)
              throws SAXException
Specified by:
startDTD in interface LexicalHandler
Throws:
SAXException

endDTD

public void endDTD()
            throws SAXException
Specified by:
endDTD in interface LexicalHandler
Throws:
SAXException

startEntity

public void startEntity(String name)
                 throws SAXException
Specified by:
startEntity in interface LexicalHandler
Throws:
SAXException

endEntity

public void endEntity(String name)
               throws SAXException
Specified by:
endEntity in interface LexicalHandler
Throws:
SAXException

startCDATA

public void startCDATA()
                throws SAXException
Specified by:
startCDATA in interface LexicalHandler
Throws:
SAXException

endCDATA

public void endCDATA()
              throws SAXException
Specified by:
endCDATA in interface LexicalHandler
Throws:
SAXException

comment

public void comment(char[] ch,
                    int start,
                    int end)
             throws SAXException
Specified by:
comment in interface LexicalHandler
Throws:
SAXException

elementDecl

public void elementDecl(String name,
                        String model)
                 throws SAXException
Report an element type declaration.

The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

Specified by:
elementDecl in interface DeclHandler
Parameters:
name - The element type name.
model - The content model as a normalized string.
Throws:
SAXException - The application may raise an exception.

attributeDecl

public void attributeDecl(String eName,
                          String aName,
                          String type,
                          String valueDefault,
                          String val)
                   throws SAXException
Report an attribute type declaration.

Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

Any parameter entities in the attribute value will be expanded, but general entities will not.

Specified by:
attributeDecl in interface DeclHandler
Parameters:
eName - The name of the associated element.
aName - The name of the attribute.
type - A string representing the attribute type.
valueDefault - A string representing the attribute default ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
val - A string representing the attribute's default value, or null if there is none.
Throws:
SAXException - The application may raise an exception.

internalEntityDecl

public void internalEntityDecl(String name,
                               String value)
                        throws SAXException
Report an internal entity declaration.

Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

Specified by:
internalEntityDecl in interface DeclHandler
Parameters:
name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
value - The replacement text of the entity.
Throws:
SAXException - The application may raise an exception.
See Also:
externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

externalEntityDecl

public void externalEntityDecl(String name,
                               String publicId,
                               String sysId)
                        throws SAXException
Report a parsed external entity declaration.

Only the effective (first) declaration for each entity will be reported.

Specified by:
externalEntityDecl in interface DeclHandler
Parameters:
name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
publicId - The declared public identifier of the entity, or null if none was declared.
sysId - The declared system identifier of the entity.
Throws:
SAXException - The application may raise an exception.
See Also:
internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

notationDecl

public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
Receive notification of a notation declaration event.

It is up to the application to record the notation for later reference, if necessary.

At least one of publicId and systemId must be non-null. If a system identifier is present, and it is a URL, the SAX parser must resolve it fully before passing it to the application through this event.

There is no guarantee that the notation declaration will be reported before any unparsed entities that use it.

Specified by:
notationDecl in interface DTDHandler
Parameters:
name - The notation name.
publicId - The notation's public identifier, or null if none was given.
systemId - The notation's system identifier, or null if none was given.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), AttributeList

unparsedEntityDecl

public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
Receive notification of an unparsed entity declaration event.

Note that the notation name corresponds to a notation reported by the notationDeclevent. It is up to the application to record the entity for later reference, if necessary.

If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

Specified by:
unparsedEntityDecl in interface DTDHandler
Parameters:
name - The unparsed entity's name.
publicId - The entity's public identifier, or null if none was given.
systemId - The entity's system identifier.
notationName - The name of the associated notation.
Throws:
SAXException - Any SAX exception, possibly wrapping another exception.
See Also:
notationDecl(java.lang.String, java.lang.String, java.lang.String), AttributeList

getElementStack

public org.dom4j.io.ElementStack getElementStack()

setElementStack

public void setElementStack(org.dom4j.io.ElementStack elementStack)

getEntityResolver

public EntityResolver getEntityResolver()

setEntityResolver

public void setEntityResolver(EntityResolver entityResolver)

getInputSource

public InputSource getInputSource()

setInputSource

public void setInputSource(InputSource inputSource)

isIncludeInternalDTDDeclarations

public boolean isIncludeInternalDTDDeclarations()
DOCUMENT ME!

Returns:
whether internal DTD declarations should be expanded into the DocumentType object or not.

setIncludeInternalDTDDeclarations

public void setIncludeInternalDTDDeclarations(boolean include)
Sets whether internal DTD declarations should be expanded into the DocumentType object or not.

Parameters:
include - whether or not DTD declarations should be expanded and included into the DocumentType object.

isIncludeExternalDTDDeclarations

public boolean isIncludeExternalDTDDeclarations()
DOCUMENT ME!

Returns:
whether external DTD declarations should be expanded into the DocumentType object or not.

setIncludeExternalDTDDeclarations

public void setIncludeExternalDTDDeclarations(boolean include)
Sets whether DTD external declarations should be expanded into the DocumentType object or not.

Parameters:
include - whether or not DTD declarations should be expanded and included into the DocumentType object.

isMergeAdjacentText

public boolean isMergeAdjacentText()
Returns whether adjacent text nodes should be merged together.

Returns:
Value of property mergeAdjacentText.

setMergeAdjacentText

public void setMergeAdjacentText(boolean mergeAdjacentText)
Sets whether or not adjacent text nodes should be merged together when parsing.

Parameters:
mergeAdjacentText - New value of property mergeAdjacentText.

isStripWhitespaceText

public boolean isStripWhitespaceText()
Sets whether whitespace between element start and end tags should be ignored

Returns:
Value of property stripWhitespaceText.

setStripWhitespaceText

public void setStripWhitespaceText(boolean stripWhitespaceText)
Sets whether whitespace between element start and end tags should be ignored.

Parameters:
stripWhitespaceText - New value of property stripWhitespaceText.

isIgnoreComments

public boolean isIgnoreComments()
Returns whether we should ignore comments or not.

Returns:
boolean

setIgnoreComments

public void setIgnoreComments(boolean ignoreComments)
Sets whether we should ignore comments or not.

Parameters:
ignoreComments - whether we should ignore comments or not.

completeCurrentTextNode

protected void completeCurrentTextNode()
If the current text buffer contains any text then create a new text node with it and add it to the current element

createDocument

protected Document createDocument()
DOCUMENT ME!

Returns:
the current document

isIgnorableEntity

protected boolean isIgnorableEntity(String name)
a Strategy Method to determine if a given entity name is ignorable

Parameters:
name - DOCUMENT ME!
Returns:
DOCUMENT ME!

addDeclaredNamespaces

protected void addDeclaredNamespaces(Element element)
Add all namespaces declared before the startElement() SAX event to the current element so that they are available to child elements and attributes

Parameters:
element - DOCUMENT ME!

addAttributes

protected void addAttributes(Element element,
                             Attributes attributes)
Add all the attributes to the given elements

Parameters:
element - DOCUMENT ME!
attributes - DOCUMENT ME!

addDTDDeclaration

protected void addDTDDeclaration(Object declaration)
Adds an internal DTD declaration to the list of declarations

Parameters:
declaration - DOCUMENT ME!

addExternalDTDDeclaration

protected void addExternalDTDDeclaration(Object declaration)
Adds an external DTD declaration to the list of declarations

Parameters:
declaration - DOCUMENT ME!

createElementStack

protected org.dom4j.io.ElementStack createElementStack()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SAXEventRecorder (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class SAXEventRecorder

java.lang.Object
    extended by org.xml.sax.helpers.DefaultHandler
        extended by org.dom4j.io.SAXEventRecorder
All Implemented Interfaces:
ContentHandler, DeclHandler, DTDHandler, EntityResolver, ErrorHandler, Externalizable, LexicalHandler, Serializable
public class SAXEventRecorder
extends DefaultHandler
implements LexicalHandler, DeclHandler, DTDHandler, Externalizable

Records SAX events such that they may be "replayed" at a later time. Provides an alternative serialization approach when externalizing a DOM4J document. Rather than serializing a document as text and re-parsing, the sax events may be serialized instead.

Example usage:

         SAXEventRecorder recorder = new SAXEventRecorder();
         SAXWriter saxWriter = new SAXWriter(recorder, recorder);
         saxWriter.write(document);
         out.writeObject(recorder);
         ...
         SAXEventRecorder recorder = (SAXEventRecorder)in.readObject();
         SAXContentHandler saxContentHandler = new SAXContentHandler();
         recorder.replay(saxContentHandler);
         Document document = saxContentHandler.getDocument();

Author:
Todd Wolff (Bluestem Software)
See Also:
Serialized Form

Field Summary
static long serialVersionUID
Constructor Summary
SAXEventRecorder()
Method Summary
void | attributeDecl(String eName, String aName, String type, String valueDefault, String value)
void | characters(char[] ch, int start, int end)
void | comment(char[] ch, int start, int end)
void | elementDecl(String name, String model)
void | endCDATA()
void | endDocument()
void | endDTD()
void | endElement(String namespaceURI, String localName, String qName)
void | endEntity(String name)
void | endPrefixMapping(String prefix)
void | externalEntityDecl(String name, String publicId, String sysId)
void | internalEntityDecl(String name, String value)
void | processingInstruction(String target, String data)
void | readExternal(ObjectInput in)
void | replay(ContentHandler handler)
void | startCDATA()
void | startDocument()
void | startDTD(String name, String publicId, String systemId)
void | startElement(String namespaceURI, String localName, String qualifiedName, Attributes attributes)
void | startEntity(String name)
void | startPrefixMapping(String prefix, String uri)
void | writeExternal(ObjectOutput out)
Methods inherited from class org.xml.sax.helpers.DefaultHandler
error, fatalError, ignorableWhitespace, notationDecl, resolveEntity, setDocumentLocator, skippedEntity, unparsedEntityDecl, warning
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.xml.sax.DTDHandler
notationDecl, unparsedEntityDecl

Field Detail

serialVersionUID

public static final long serialVersionUID
See Also:
Constant Field Values
Constructor Detail

SAXEventRecorder

public SAXEventRecorder()
Method Detail

replay

public void replay(ContentHandler handler)
            throws SAXException
Throws:
SAXException

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String prefix)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Throws:
SAXException

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Throws:
SAXException

startElement

public void startElement(String namespaceURI,
                         String localName,
                         String qualifiedName,
                         Attributes attributes)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Throws:
SAXException

endElement

public void endElement(String namespaceURI,
                       String localName,
                       String qName)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Throws:
SAXException

characters

public void characters(char[] ch,
                       int start,
                       int end)
                throws SAXException
Specified by:
characters in interface ContentHandler
Throws:
SAXException

startDTD

public void startDTD(String name,
                     String publicId,
                     String systemId)
              throws SAXException
Specified by:
startDTD in interface LexicalHandler
Throws:
SAXException

endDTD

public void endDTD()
            throws SAXException
Specified by:
endDTD in interface LexicalHandler
Throws:
SAXException

startEntity

public void startEntity(String name)
                 throws SAXException
Specified by:
startEntity in interface LexicalHandler
Throws:
SAXException

endEntity

public void endEntity(String name)
               throws SAXException
Specified by:
endEntity in interface LexicalHandler
Throws:
SAXException

startCDATA

public void startCDATA()
                throws SAXException
Specified by:
startCDATA in interface LexicalHandler
Throws:
SAXException

endCDATA

public void endCDATA()
              throws SAXException
Specified by:
endCDATA in interface LexicalHandler
Throws:
SAXException

comment

public void comment(char[] ch,
                    int start,
                    int end)
             throws SAXException
Specified by:
comment in interface LexicalHandler
Throws:
SAXException

elementDecl

public void elementDecl(String name,
                        String model)
                 throws SAXException
Specified by:
elementDecl in interface DeclHandler
Throws:
SAXException

attributeDecl

public void attributeDecl(String eName,
                          String aName,
                          String type,
                          String valueDefault,
                          String value)
                   throws SAXException
Specified by:
attributeDecl in interface DeclHandler
Throws:
SAXException

internalEntityDecl

public void internalEntityDecl(String name,
                               String value)
                        throws SAXException
Specified by:
internalEntityDecl in interface DeclHandler
Throws:
SAXException

externalEntityDecl

public void externalEntityDecl(String name,
                               String publicId,
                               String sysId)
                        throws SAXException
Specified by:
externalEntityDecl in interface DeclHandler
Throws:
SAXException

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
Specified by:
writeExternal in interface Externalizable
Throws:
IOException

readExternal

public void readExternal(ObjectInput in)
                  throws ClassNotFoundException,
                         IOException
Specified by:
readExternal in interface Externalizable
Throws:
ClassNotFoundException
IOException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SAXModifier (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class SAXModifier

java.lang.Object
    extended by org.dom4j.io.SAXModifier
public class SAXModifier
extends Object

The SAXModifier reads, modifies and writes XML documents using SAX.

Registered ElementModifierobjects can provide modifications to (part of) the xml tree, while the document is still being processed. This makes it possible to change large xml documents without having them in memory.

The modified document is written when the XMLWriteris specified.

Author:
Wonne Keysers (Realsoftware.be)
See Also:
SAXReader, XMLWriter

Constructor Summary
SAXModifier()
Creates a new modifier.
SAXModifier(boolean pruneElements)
Creates a new modifier.
SAXModifier(XMLReader xmlReader)
Creates a new modifier that will the specified XMLReader to parse the source.
SAXModifier(XMLReader xmlReader, boolean pruneElements)
Creates a new modifier that will the specified XMLReader to parse the source.
Method Summary
void | addModifier(String path, ElementModifier modifier) Adds the ElementModifierto be called when the specified element path is encounted while parsing the source.
DocumentFactory | getDocumentFactory() Get the DocumentFactoryused to create the DOM4J document structure
XMLWriter | getXMLWriter() Returns the current XMLWriter.
boolean | isPruneElements() Returns true when xml elements are not kept in memory while parsing.
Document | modify(File source) Reads a Document from the given Fileand writes it to the specified XMLWriterusing SAX.
Document | modify(InputSource source) Reads a Document from the given InputSourceand writes it to the specified XMLWriterusing SAX.
Document | modify(InputStream source) Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX.
Document | modify(InputStream source, String systemId) Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX.
Document | modify(Reader source) Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX.
Document | modify(Reader source, String systemId) Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX.
Document | modify(String source) Reads a Document from the given URL or filename and writes it to the specified XMLWriterusing SAX.
Document | modify(URL source) Reads a Document from the given URLand writes it to the specified XMLWriterusing SAX.
void | removeModifier(String path) Removes the ElementModifierfrom the event based processor, for the specified element path.
void | resetModifiers() Removes all registered ElementModifierinstances from the event based processor.
void | setDocumentFactory(DocumentFactory factory) Sets the DocumentFactoryused to create the DOM4J document tree.
void | setXMLWriter(XMLWriter writer) Sets the XMLWriterused to write the modified document.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SAXModifier

public SAXModifier()
Creates a new modifier.
The XMLReader to parse the source will be created via the org.xml.sax.driver system property or JAXP if the system property is not set.

SAXModifier

public SAXModifier(boolean pruneElements)
Creates a new modifier.
The XMLReader to parse the source will be created via the org.xml.sax.driver system property or JAXP if the system property is not set.

Parameters:
pruneElements - Set to true when the modified document must NOT be kept in memory.

SAXModifier

public SAXModifier(XMLReader xmlReader)
Creates a new modifier that will the specified XMLReader to parse the source.

Parameters:
xmlReader - The XMLReader to use

SAXModifier

public SAXModifier(XMLReader xmlReader,
                   boolean pruneElements)
Creates a new modifier that will the specified XMLReader to parse the source.

Parameters:
xmlReader - The XMLReader to use
pruneElements - Set to true when the modified document must NOT be kept in memory.
Method Detail

modify

public Document modify(File source)
                throws DocumentException
Reads a Document from the given Fileand writes it to the specified XMLWriterusing SAX. Registered objects are invoked on the fly.

Parameters:
source - is the File to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - DocumentException org.dom4j.DocumentException} if an error occurs during parsing.

modify

public Document modify(InputSource source)
                throws DocumentException
Reads a Document from the given InputSourceand writes it to the specified XMLWriterusing SAX. Registered ElementModifierobjects are invoked on the fly.

Parameters:
source - is the org.xml.sax.InputSource to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - DocumentException org.dom4j.DocumentException} if an error occurs during parsing.

modify

public Document modify(InputStream source)
                throws DocumentException
Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX. Registered ElementModifier objects are invoked on the fly.

Parameters:
source - is the java.io.InputStream to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - DocumentException org.dom4j.DocumentException} if an error occurs during parsing.

modify

public Document modify(InputStream source,
                       String systemId)
                throws DocumentException
Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX. Registered ElementModifier objects are invoked on the fly.

Parameters:
source - is the java.io.InputStream to read from.
systemId - DOCUMENT ME!
Returns:
the newly created Document instance
Throws:
DocumentException - DocumentException org.dom4j.DocumentException} if an error occurs during parsing.

modify

public Document modify(Reader source)
                throws DocumentException
Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX. Registered ElementModifier objects are invoked on the fly.

Parameters:
source - is the java.io.Reader to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - DocumentException org.dom4j.DocumentException} if an error occurs during parsing.

modify

public Document modify(Reader source,
                       String systemId)
                throws DocumentException
Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX. Registered ElementModifier objects are invoked on the fly.

Parameters:
source - is the java.io.Reader to read from.
systemId - DOCUMENT ME!
Returns:
the newly created Document instance
Throws:
DocumentException - DocumentException org.dom4j.DocumentException} if an error occurs during parsing.

modify

public Document modify(URL source)
                throws DocumentException
Reads a Document from the given URLand writes it to the specified XMLWriterusing SAX. Registered objects are invoked on the fly.

Parameters:
source - is the java.net.URL to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - DocumentException org.dom4j.DocumentException} if an error occurs during parsing.

modify

public Document modify(String source)
                throws DocumentException
Reads a Document from the given URL or filename and writes it to the specified XMLWriterusing SAX. Registered objects are invoked on the fly.

Parameters:
source - is the URL or filename to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - DocumentException org.dom4j.DocumentException} if an error occurs during parsing.

addModifier

public void addModifier(String path,
                        ElementModifier modifier)
Adds the ElementModifierto be called when the specified element path is encounted while parsing the source.

Parameters:
path - The element path to be handled
modifier - The ElementModifierto be called by the event based processor.

resetModifiers

public void resetModifiers()
Removes all registered ElementModifierinstances from the event based processor.

removeModifier

public void removeModifier(String path)
Removes the ElementModifierfrom the event based processor, for the specified element path.

Parameters:
path - The path to remove the ElementModifierfor.

getDocumentFactory

public DocumentFactory getDocumentFactory()
Get the DocumentFactoryused to create the DOM4J document structure

Returns:
DocumentFactory that will be used

setDocumentFactory

public void setDocumentFactory(DocumentFactory factory)
Sets the DocumentFactoryused to create the DOM4J document tree.

Parameters:
factory - DocumentFactory to be used

getXMLWriter

public XMLWriter getXMLWriter()
Returns the current XMLWriter.

Returns:
XMLWriter

setXMLWriter

public void setXMLWriter(XMLWriter writer)
Sets the XMLWriterused to write the modified document.

Parameters:
writer - The writer to use.

isPruneElements

public boolean isPruneElements()
Returns true when xml elements are not kept in memory while parsing. The Documentreturned by the modify methods will be null.

Returns:
Returns the pruneElements.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SAXReader (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class SAXReader

java.lang.Object
    extended by org.dom4j.io.SAXReader
public class SAXReader
extends Object

SAXReader creates a DOM4J tree from SAX parsing events.

The actual SAX parser that is used by this class is configurable so you can use your favourite SAX parser if you wish. DOM4J comes configured with its own SAX parser so you do not need to worry about configuring the SAX parser.

To explicitly configure the SAX parser that is used via Java code you can use a constructor or use the setXMLReader(XMLReader)or setXMLReaderClassName(String) methods.

If the parser is not specified explicitly then the standard SAX policy of using the org.xml.sax.driver system property is used to determine the implementation class of XMLReader.

If the org.xml.sax.driver system property is not defined then JAXP is used via reflection (so that DOM4J is not explicitly dependent on the JAXP classes) to load the JAXP configured SAXParser. If there is any error creating a JAXP SAXParser an informational message is output and then the default (Aelfred) SAX parser is used instead.

If you are trying to use JAXP to explicitly set your SAX parser and are experiencing problems, you can turn on verbose error reporting by defining the system property org.dom4j.verbose to be "true" which will output a more detailed description of why JAXP could not find a SAX parser

For more information on JAXP please go to Sun's Java & XML site

Version:
$Revision: 1.58 $
Author:
James Strachan

Nested Class Summary
protected static class SAXReader.SAXEntityResolver
Constructor Summary
SAXReader()
SAXReader(boolean validating)
SAXReader(DocumentFactory factory)
SAXReader(DocumentFactory factory, boolean validating)
SAXReader(String xmlReaderClassName)
SAXReader(String xmlReaderClassName, boolean validating)
SAXReader(XMLReader xmlReader)
SAXReader(XMLReader xmlReader, boolean validating)
Method Summary
void | addHandler(String path, ElementHandler handler) Adds the ElementHandler to be called when the specified path is encounted.
protected void | configureReader(XMLReader reader, DefaultHandler handler) Configures the XMLReader before use
protected SAXContentHandler | createContentHandler(XMLReader reader) Factory Method to allow user derived SAXContentHandler objects to be used
protected EntityResolver | createDefaultEntityResolver(String systemId)
protected XMLReader | createXMLReader() Factory Method to allow alternate methods of creating and configuring XMLReader objects
protected org.dom4j.io.DispatchHandler | getDispatchHandler()
DocumentFactory | getDocumentFactory() DOCUMENT ME!
String | getEncoding() Returns encoding used for InputSource (null means system default encoding)
EntityResolver | getEntityResolver() Returns the current entity resolver used to resolve entities
ErrorHandler | getErrorHandler() DOCUMENT ME!
XMLFilter | getXMLFilter() Returns the SAX filter being used to filter SAX events.
XMLReader | getXMLReader() DOCUMENT ME!
protected XMLReader | installXMLFilter(XMLReader reader) Installs any XMLFilter objects required to allow the SAX event stream to be filtered and preprocessed before it gets to dom4j.
boolean | isIgnoreComments() Returns whether we should ignore comments or not.
boolean | isIncludeExternalDTDDeclarations() DOCUMENT ME!
boolean | isIncludeInternalDTDDeclarations() DOCUMENT ME!
boolean | isMergeAdjacentText() Returns whether adjacent text nodes should be merged together.
boolean | isStringInternEnabled() Sets whether String interning is enabled or disabled for element & attribute names and namespace URIs.
boolean | isStripWhitespaceText() Sets whether whitespace between element start and end tags should be ignored
boolean | isValidating() DOCUMENT ME!
Document | read(File file) Reads a Document from the given File
Document | read(InputSource in) Reads a Document from the given InputSource using SAX
Document | read(InputStream in) Reads a Document from the given stream using SAX
Document | read(InputStream in, String systemId) Reads a Document from the given stream using SAX
Document | read(Reader reader) Reads a Document from the given Reader using SAX
Document | read(Reader reader, String systemId) Reads a Document from the given Reader using SAX
Document | read(String systemId) Reads a Document from the given URL or filename using SAX.
Document | read(URL url) Reads a Document from the given URL using SAX
void | removeHandler(String path) Removes the ElementHandler from the event based processor, for the specified path.
void | resetHandlers() This method clears out all the existing handlers and default handler setting things back as if no handler existed.
void | setDefaultHandler(ElementHandler handler) When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.
protected void | setDispatchHandler(org.dom4j.io.DispatchHandler dispatchHandler)
void | setDocumentFactory(DocumentFactory documentFactory) This sets the DocumentFactory used to create new documents.
void | setEncoding(String encoding) Sets encoding used for InputSource (null means system default encoding)
void | setEntityResolver(EntityResolver entityResolver) Sets the entity resolver used to resolve entities.
void | setErrorHandler(ErrorHandler errorHandler) Sets the ErrorHandler used by the SAX XMLReader.
void | setFeature(String name, boolean value) Sets a SAX feature on the underlying SAX parser.
void | setIgnoreComments(boolean ignoreComments) Sets whether we should ignore comments or not.
void | setIncludeExternalDTDDeclarations(boolean include) Sets whether DTD external declarations should be expanded into the DocumentType object or not.
void | setIncludeInternalDTDDeclarations(boolean include) Sets whether internal DTD declarations should be expanded into the DocumentType object or not.
void | setMergeAdjacentText(boolean mergeAdjacentText) Sets whether or not adjacent text nodes should be merged together when parsing.
void | setProperty(String name, Object value) Allows a SAX property to be set on the underlying SAX parser.
void | setStringInternEnabled(boolean stringInternEnabled) Sets whether String interning is enabled or disabled for element & attribute names and namespace URIs
void | setStripWhitespaceText(boolean stripWhitespaceText) Sets whether whitespace between element start and end tags should be ignored.
void | setValidation(boolean validation) Sets the validation mode.
void | setXMLFilter(XMLFilter filter) Sets the SAX filter to be used when filtering SAX events
void | setXMLReader(XMLReader reader) Sets the XMLReader used to parse SAX events
void | setXMLReaderClassName(String xmlReaderClassName) Sets the class name of the XMLReader to be used to parse SAX events.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SAXReader

public SAXReader()

SAXReader

public SAXReader(boolean validating)

SAXReader

public SAXReader(DocumentFactory factory)

SAXReader

public SAXReader(DocumentFactory factory,
                 boolean validating)

SAXReader

public SAXReader(XMLReader xmlReader)

SAXReader

public SAXReader(XMLReader xmlReader,
                 boolean validating)

SAXReader

public SAXReader(String xmlReaderClassName)
          throws SAXException

SAXReader

public SAXReader(String xmlReaderClassName,
                 boolean validating)
          throws SAXException
Method Detail

setProperty

public void setProperty(String name,
                        Object value)
                 throws SAXException
Allows a SAX property to be set on the underlying SAX parser. This can be useful to set parser-specific properties such as the location of schema or DTD resources. Though use this method with caution as it has the possibility of breaking the standard behaviour. An alternative to calling this method is to correctly configure an XMLReader object instance and call the setXMLReader(XMLReader)method

Parameters:
name - is the SAX property name
value - is the value of the SAX property
Throws:
SAXException - if the XMLReader could not be created or the property could not be changed.

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXException
Sets a SAX feature on the underlying SAX parser. This can be useful to set parser-specific features. Though use this method with caution as it has the possibility of breaking the standard behaviour. An alternative to calling this method is to correctly configure an XMLReader object instance and call the setXMLReader(XMLReader)method

Parameters:
name - is the SAX feature name
value - is the value of the SAX feature
Throws:
SAXException - if the XMLReader could not be created or the feature could not be changed.

read

public Document read(File file)
              throws DocumentException

Reads a Document from the given File

Parameters:
file - is the File to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.

read

public Document read(URL url)
              throws DocumentException

Reads a Document from the given URL using SAX

Parameters:
url - URL to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.

read

public Document read(String systemId)
              throws DocumentException

Reads a Document from the given URL or filename using SAX.

If the systemId contains a ':' character then it is assumed to be a URL otherwise its assumed to be a file name. If you want finer grained control over this mechansim then please explicitly pass in either a URLor a Fileinstance instead of a String to denote the source of the document.

Parameters:
systemId - is a URL for a document or a file name.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.

read

public Document read(InputStream in)
              throws DocumentException

Reads a Document from the given stream using SAX

Parameters:
in - InputStream to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.

read

public Document read(Reader reader)
              throws DocumentException

Reads a Document from the given Reader using SAX

Parameters:
reader - is the reader for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.

read

public Document read(InputStream in,
                     String systemId)
              throws DocumentException

Reads a Document from the given stream using SAX

Parameters:
in - InputStream to read from.
systemId - is the URI for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.

read

public Document read(Reader reader,
                     String systemId)
              throws DocumentException

Reads a Document from the given Reader using SAX

Parameters:
reader - is the reader for the input
systemId - is the URI for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.

read

public Document read(InputSource in)
              throws DocumentException

Reads a Document from the given InputSource using SAX

Parameters:
in - InputSource to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.

isValidating

public boolean isValidating()
DOCUMENT ME!

Returns:
the validation mode, true if validating will be done otherwise false.

setValidation

public void setValidation(boolean validation)
Sets the validation mode.

Parameters:
validation - indicates whether or not validation should occur.

isIncludeInternalDTDDeclarations

public boolean isIncludeInternalDTDDeclarations()
DOCUMENT ME!

Returns:
whether internal DTD declarations should be expanded into the DocumentType object or not.

setIncludeInternalDTDDeclarations

public void setIncludeInternalDTDDeclarations(boolean include)
Sets whether internal DTD declarations should be expanded into the DocumentType object or not.

Parameters:
include - whether or not DTD declarations should be expanded and included into the DocumentType object.

isIncludeExternalDTDDeclarations

public boolean isIncludeExternalDTDDeclarations()
DOCUMENT ME!

Returns:
whether external DTD declarations should be expanded into the DocumentType object or not.

setIncludeExternalDTDDeclarations

public void setIncludeExternalDTDDeclarations(boolean include)
Sets whether DTD external declarations should be expanded into the DocumentType object or not.

Parameters:
include - whether or not DTD declarations should be expanded and included into the DocumentType object.

isStringInternEnabled

public boolean isStringInternEnabled()
Sets whether String interning is enabled or disabled for element & attribute names and namespace URIs. This proprety is enabled by default.

Returns:
DOCUMENT ME!

setStringInternEnabled

public void setStringInternEnabled(boolean stringInternEnabled)
Sets whether String interning is enabled or disabled for element & attribute names and namespace URIs

Parameters:
stringInternEnabled - DOCUMENT ME!

isMergeAdjacentText

public boolean isMergeAdjacentText()
Returns whether adjacent text nodes should be merged together.

Returns:
Value of property mergeAdjacentText.

setMergeAdjacentText

public void setMergeAdjacentText(boolean mergeAdjacentText)
Sets whether or not adjacent text nodes should be merged together when parsing.

Parameters:
mergeAdjacentText - New value of property mergeAdjacentText.

isStripWhitespaceText

public boolean isStripWhitespaceText()
Sets whether whitespace between element start and end tags should be ignored

Returns:
Value of property stripWhitespaceText.

setStripWhitespaceText

public void setStripWhitespaceText(boolean stripWhitespaceText)
Sets whether whitespace between element start and end tags should be ignored.

Parameters:
stripWhitespaceText - New value of property stripWhitespaceText.

isIgnoreComments

public boolean isIgnoreComments()
Returns whether we should ignore comments or not.

Returns:
boolean

setIgnoreComments

public void setIgnoreComments(boolean ignoreComments)
Sets whether we should ignore comments or not.

Parameters:
ignoreComments - whether we should ignore comments or not.

getDocumentFactory

public DocumentFactory getDocumentFactory()
DOCUMENT ME!

Returns:
the DocumentFactory used to create document objects

setDocumentFactory

public void setDocumentFactory(DocumentFactory documentFactory)

This sets the DocumentFactory used to create new documents. This method allows the building of custom DOM4J tree objects to be implemented easily using a custom derivation of DocumentFactory

Parameters:
documentFactory - DocumentFactory used to create DOM4J objects

getErrorHandler

public ErrorHandler getErrorHandler()
DOCUMENT ME!

Returns:
the ErrorHandler used by SAX

setErrorHandler

public void setErrorHandler(ErrorHandler errorHandler)
Sets the ErrorHandler used by the SAX XMLReader.

Parameters:
errorHandler - is the ErrorHandler used by SAX

getEntityResolver

public EntityResolver getEntityResolver()
Returns the current entity resolver used to resolve entities

Returns:
DOCUMENT ME!

setEntityResolver

public void setEntityResolver(EntityResolver entityResolver)
Sets the entity resolver used to resolve entities.

Parameters:
entityResolver - DOCUMENT ME!

getXMLReader

public XMLReader getXMLReader()
                       throws SAXException
DOCUMENT ME!

Returns:
the XMLReader used to parse SAX events
Throws:
SAXException - DOCUMENT ME!

setXMLReader

public void setXMLReader(XMLReader reader)
Sets the XMLReader used to parse SAX events

Parameters:
reader - is the XMLReader to parse SAX events

getEncoding

public String getEncoding()
Returns encoding used for InputSource (null means system default encoding)

Returns:
encoding used for InputSource

setEncoding

public void setEncoding(String encoding)
Sets encoding used for InputSource (null means system default encoding)

Parameters:
encoding - is encoding used for InputSource

setXMLReaderClassName

public void setXMLReaderClassName(String xmlReaderClassName)
                           throws SAXException
Sets the class name of the XMLReader to be used to parse SAX events.

Parameters:
xmlReaderClassName - is the class name of the XMLReader to parse SAX events
Throws:
SAXException - DOCUMENT ME!

addHandler

public void addHandler(String path,
                       ElementHandler handler)
Adds the ElementHandler to be called when the specified path is encounted.

Parameters:
path - is the path to be handled
handler - is the ElementHandler to be called by the event based processor.

removeHandler

public void removeHandler(String path)
Removes the ElementHandler from the event based processor, for the specified path.

Parameters:
path - is the path to remove the ElementHandler for.

setDefaultHandler

public void setDefaultHandler(ElementHandler handler)
When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.

Parameters:
handler - is the ElementHandler to be called by the event based processor.

resetHandlers

public void resetHandlers()
This method clears out all the existing handlers and default handler setting things back as if no handler existed. Useful when reusing an object instance.

getXMLFilter

public XMLFilter getXMLFilter()
Returns the SAX filter being used to filter SAX events.

Returns:
the SAX filter being used or null if no SAX filter is installed

setXMLFilter

public void setXMLFilter(XMLFilter filter)
Sets the SAX filter to be used when filtering SAX events

Parameters:
filter - is the SAX filter to use or null to disable filtering

installXMLFilter

protected XMLReader installXMLFilter(XMLReader reader)
Installs any XMLFilter objects required to allow the SAX event stream to be filtered and preprocessed before it gets to dom4j.

Parameters:
reader - DOCUMENT ME!
Returns:
the new XMLFilter if applicable or the original XMLReader if no filter is being used.

getDispatchHandler

protected org.dom4j.io.DispatchHandler getDispatchHandler()

setDispatchHandler

protected void setDispatchHandler(org.dom4j.io.DispatchHandler dispatchHandler)

createXMLReader

protected XMLReader createXMLReader()
                             throws SAXException
Factory Method to allow alternate methods of creating and configuring XMLReader objects

Returns:
DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

configureReader

protected void configureReader(XMLReader reader,
                               DefaultHandler handler)
                        throws DocumentException
Configures the XMLReader before use

Parameters:
reader - DOCUMENT ME!
handler - DOCUMENT ME!
Throws:
DocumentException - DOCUMENT ME!

createContentHandler

protected SAXContentHandler createContentHandler(XMLReader reader)
Factory Method to allow user derived SAXContentHandler objects to be used

Parameters:
reader - DOCUMENT ME!
Returns:
DOCUMENT ME!

createDefaultEntityResolver

protected EntityResolver createDefaultEntityResolver(String systemId)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SAXReader.SAXEntityResolver (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class SAXReader.SAXEntityResolver

java.lang.Object
    extended by org.dom4j.io.SAXReader.SAXEntityResolver
All Implemented Interfaces:
EntityResolver, Serializable
Enclosing class:
SAXReader
protected static class SAXReader.SAXEntityResolver
extends Object
implements EntityResolver, Serializable

See Also:
Serialized Form

Field Summary
protected  String uriPrefix
Constructor Summary
SAXReader.SAXEntityResolver(String uriPrefix)
Method Summary
 InputSource resolveEntity(String publicId, String systemId)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

uriPrefix

protected String uriPrefix
Constructor Detail

SAXReader.SAXEntityResolver

public SAXReader.SAXEntityResolver(String uriPrefix)
Method Detail

resolveEntity

public InputSource resolveEntity(String publicId,
                                 String systemId)
Specified by:
resolveEntity in interface EntityResolver
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SAXValidator (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class SAXValidator

java.lang.Object
    extended by org.dom4j.io.SAXValidator
public class SAXValidator
extends Object

SAXValidator validates an XML document by writing the document to a text buffer and parsing it with a validating SAX parser. This could be implemented much more efficiently by validating against the dom4j object model directly but at least allows the reuse of existing SAX based validating parsers.

Version:
$Revision: 1.10 $
Author:
James Strachan

Constructor Summary
SAXValidator()
SAXValidator(XMLReader xmlReader)
Method Summary
protected void | configureReader() Configures the XMLReader before use
protected XMLReader | createXMLReader() Factory Method to allow alternate methods of creating and configuring XMLReader objects
ErrorHandler | getErrorHandler() DOCUMENT ME!
XMLReader | getXMLReader() DOCUMENT ME!
void | setErrorHandler(ErrorHandler errorHandler) Sets the ErrorHandler used by the SAX XMLReader.
void | setXMLReader(XMLReader reader) Sets the XMLReader used to parse SAX events
void | validate(Document document) Validates the given Document by writing it to a validating SAX Parser.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SAXValidator

public SAXValidator()

SAXValidator

public SAXValidator(XMLReader xmlReader)
Method Detail

validate

public void validate(Document document)
              throws SAXException
Validates the given Document by writing it to a validating SAX Parser.

Parameters:
document - is the Document to validate
Throws:
SAXException - if a validation error occurs
RuntimeException - DOCUMENT ME!

getXMLReader

public XMLReader getXMLReader()
                       throws SAXException
DOCUMENT ME!

Returns:
the XMLReader used to parse SAX events
Throws:
SAXException - DOCUMENT ME!

setXMLReader

public void setXMLReader(XMLReader reader)
                  throws SAXException
Sets the XMLReader used to parse SAX events

Parameters:
reader - is the XMLReader to parse SAX events
Throws:
SAXException - DOCUMENT ME!

getErrorHandler

public ErrorHandler getErrorHandler()
DOCUMENT ME!

Returns:
the ErrorHandler used by SAX

setErrorHandler

public void setErrorHandler(ErrorHandler errorHandler)
Sets the ErrorHandler used by the SAX XMLReader.

Parameters:
errorHandler - is the ErrorHandler used by SAX

createXMLReader

protected XMLReader createXMLReader()
                             throws SAXException
Factory Method to allow alternate methods of creating and configuring XMLReader objects

Returns:
DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

configureReader

protected void configureReader()
                        throws SAXException
Configures the XMLReader before use

Throws:
SAXException - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SAXWriter (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class SAXWriter

java.lang.Object
    extended by org.dom4j.io.SAXWriter
All Implemented Interfaces:
XMLReader
public class SAXWriter
extends Object
implements XMLReader

SAXWriter writes a DOM4J tree to a SAX ContentHandler.

Version:
$Revision: 1.24 $
Author:
James Strachan

Field Summary
protected static String | FEATURE_NAMESPACE_PREFIXES
protected static String | FEATURE_NAMESPACES
protected static String[] | LEXICAL_HANDLER_NAMES
Constructor Summary
SAXWriter()
SAXWriter(ContentHandler contentHandler)
SAXWriter(ContentHandler contentHandler, LexicalHandler lexicalHandler)
SAXWriter(ContentHandler contentHandler, LexicalHandler lexicalHandler, EntityResolver entityResolver)
Method Summary
protected  AttributesImpl addNamespaceAttribute(AttributesImpl attrs, Namespace namespace)
If isDelcareNamespaceAttributes() is enabled then this method will add the given namespace declaration to the supplied attributes object, creating one if it does not exist.
protected  void checkForNullHandlers()
Ensures non-null content handlers?
protected  Attributes createAttributes(Element element, Attributes namespaceAttributes)
protected  void documentLocator(Document document)
The Locatoris only really useful when parsing a textual document as its main purpose is to identify the line and column number.
protected  void dtdHandler(Document document)
We do not yet support DTD or XML Schemas so this method does nothing right now.
protected  void endDocument()
protected  void endElement(Element element)
protected  void endPrefixMapping(NamespaceStack stack, int stackSize)
Fires a SAX endPrefixMapping event for all the namespaceStack which have gone out of scope
protected  void entityResolver(Document document)
 ContentHandler getContentHandler()
DOCUMENT ME!
 DTDHandler getDTDHandler()
DOCUMENT ME!
 EntityResolver getEntityResolver()
DOCUMENT ME!
 ErrorHandler getErrorHandler()
DOCUMENT ME!
 boolean getFeature(String name)
Looks up the value of a feature.
 LexicalHandler getLexicalHandler()
DOCUMENT ME!
 Object getProperty(String name)
Gets the given SAX property
 boolean isDeclareNamespaceAttributes()
Should namespace declarations be converted to "xmlns" attributes.
protected  boolean isIgnoreableNamespace(Namespace namespace, NamespaceStack namespaceStack)
DOCUMENT ME!
 void parse(InputSource input)
Parses an XML document.
 void parse(String systemId)
This method is not supported.
 void setContentHandler(ContentHandler contentHandler)
Sets the ContentHandler called when SAX events are raised
 void setDeclareNamespaceAttributes(boolean declareNamespaceAttrs)
Sets whether namespace declarations should be exported as "xmlns" attributes or not.
 void setDTDHandler(DTDHandler handler)
Sets the DTDHandler.
 void setEntityResolver(EntityResolver entityResolver)
Sets the EntityResolver.
 void setErrorHandler(ErrorHandler errorHandler)
Sets the ErrorHandler.
 void setFeature(String name, boolean value)
This implementation does actually use any features but just stores them for later retrieval
 void setLexicalHandler(LexicalHandler lexicalHandler)
Sets the LexicalHandler.
 void setProperty(String name, Object value)
Sets the given SAX property
 void setXMLReader(XMLReader xmlReader)
Sets the XMLReader used to write SAX events to
protected  void startDocument()
protected  void startElement(Element element, AttributesImpl namespaceAttributes)
protected  AttributesImpl startPrefixMapping(Element element, NamespaceStack namespaceStack)
Fires a SAX startPrefixMapping event for all the namespaceStack which have just come into scope
 void write(CDATA cdata)
Generates SAX events for the given CDATA
 void write(Comment comment)
Generates SAX events for the given Comment
 void write(Document document)
Generates SAX events for the given Document and all its content
 void write(Element element)
Generates SAX events for the given Element and all its content
protected  void write(Element element, NamespaceStack namespaceStack)
 void write(Entity entity)
Generates SAX events for the given Entity
 void write(Node node)
A polymorphic method to write any Node to this SAX stream
 void write(ProcessingInstruction pi)
Generates SAX events for the given ProcessingInstruction
 void write(String text)
Generates SAX events for the given text
 void writeClose(Element element)
Writes the closing tag of an Element
protected  void writeContent(Branch branch, NamespaceStack namespaceStack)
 void writeOpen(Element element)
Writes the opening tag of an Element, including its Attributes but without its content.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LEXICAL_HANDLER_NAMES

protected static final String[] LEXICAL_HANDLER_NAMES

FEATURE_NAMESPACE_PREFIXES

protected static final String FEATURE_NAMESPACE_PREFIXES
See Also:
Constant Field Values

FEATURE_NAMESPACES

protected static final String FEATURE_NAMESPACES
See Also:
Constant Field Values
Constructor Detail

SAXWriter

public SAXWriter()

SAXWriter

public SAXWriter(ContentHandler contentHandler)

SAXWriter

public SAXWriter(ContentHandler contentHandler,
                 LexicalHandler lexicalHandler)

SAXWriter

public SAXWriter(ContentHandler contentHandler,
                 LexicalHandler lexicalHandler,
                 EntityResolver entityResolver)
Method Detail

write

public void write(Node node)
           throws SAXException
A polymorphic method to write any Node to this SAX stream

Parameters:
node - DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

write

public void write(Document document)
           throws SAXException
Generates SAX events for the given Document and all its content

Parameters:
document - is the Document to parse
Throws:
SAXException - if there is a SAX error processing the events

write

public void write(Element element)
           throws SAXException
Generates SAX events for the given Element and all its content

Parameters:
element - is the Element to parse
Throws:
SAXException - if there is a SAX error processing the events

writeOpen

public void writeOpen(Element element)
               throws SAXException

Writes the opening tag of an Element, including its Attributes but without its content.

Parameters:
element - Element to output.
Throws:
SAXException - DOCUMENT ME!

writeClose

public void writeClose(Element element)
                throws SAXException

Writes the closing tag of an Element

Parameters:
element - Element to output.
Throws:
SAXException - DOCUMENT ME!

write

public void write(String text)
           throws SAXException
Generates SAX events for the given text

Parameters:
text - is the text to send to the SAX ContentHandler
Throws:
SAXException - if there is a SAX error processing the events

write

public void write(CDATA cdata)
           throws SAXException
Generates SAX events for the given CDATA

Parameters:
cdata - is the CDATA to parse
Throws:
SAXException - if there is a SAX error processing the events

write

public void write(Comment comment)
           throws SAXException
Generates SAX events for the given Comment

Parameters:
comment - is the Comment to parse
Throws:
SAXException - if there is a SAX error processing the events

write

public void write(Entity entity)
           throws SAXException
Generates SAX events for the given Entity

Parameters:
entity - is the Entity to parse
Throws:
SAXException - if there is a SAX error processing the events

write

public void write(ProcessingInstruction pi)
           throws SAXException
Generates SAX events for the given ProcessingInstruction

Parameters:
pi - is the ProcessingInstruction to parse
Throws:
SAXException - if there is a SAX error processing the events

isDeclareNamespaceAttributes

public boolean isDeclareNamespaceAttributes()
Should namespace declarations be converted to "xmlns" attributes. This property defaults to false as per the SAX specification. This property is set via the SAX feature "http://xml.org/sax/features/namespace-prefixes"

Returns:
DOCUMENT ME!

setDeclareNamespaceAttributes

public void setDeclareNamespaceAttributes(boolean declareNamespaceAttrs)
Sets whether namespace declarations should be exported as "xmlns" attributes or not. This property is set from the SAX feature "http://xml.org/sax/features/namespace-prefixes"

Parameters:
declareNamespaceAttrs - DOCUMENT ME!

getContentHandler

public ContentHandler getContentHandler()
DOCUMENT ME!

Specified by:
getContentHandler in interface XMLReader
Returns:
the ContentHandler called when SAX events are raised

setContentHandler

public void setContentHandler(ContentHandler contentHandler)
Sets the ContentHandler called when SAX events are raised

Specified by:
setContentHandler in interface XMLReader
Parameters:
contentHandler - is the ContentHandler called when SAX events are raised

getDTDHandler

public DTDHandler getDTDHandler()
DOCUMENT ME!

Specified by:
getDTDHandler in interface XMLReader
Returns:
the DTDHandler

setDTDHandler

public void setDTDHandler(DTDHandler handler)
Sets the DTDHandler.

Specified by:
setDTDHandler in interface XMLReader
Parameters:
handler - DOCUMENT ME!

getErrorHandler

public ErrorHandler getErrorHandler()
DOCUMENT ME!

Specified by:
getErrorHandler in interface XMLReader
Returns:
the ErrorHandler

setErrorHandler

public void setErrorHandler(ErrorHandler errorHandler)
Sets the ErrorHandler.

Specified by:
setErrorHandler in interface XMLReader
Parameters:
errorHandler - DOCUMENT ME!

getEntityResolver

public EntityResolver getEntityResolver()
DOCUMENT ME!

Specified by:
getEntityResolver in interface XMLReader
Returns:
the EntityResolver used when a Document contains a DTD

setEntityResolver

public void setEntityResolver(EntityResolver entityResolver)
Sets the EntityResolver.

Specified by:
setEntityResolver in interface XMLReader
Parameters:
entityResolver - is the EntityResolver

getLexicalHandler

public LexicalHandler getLexicalHandler()
DOCUMENT ME!

Returns:
the LexicalHandler used when a Document contains a DTD

setLexicalHandler

public void setLexicalHandler(LexicalHandler lexicalHandler)
Sets the LexicalHandler.

Parameters:
lexicalHandler - is the LexicalHandler

setXMLReader

public void setXMLReader(XMLReader xmlReader)
Sets the XMLReader used to write SAX events to

Parameters:
xmlReader - is the XMLReader

getFeature

public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Looks up the value of a feature.

Specified by:
getFeature in interface XMLReader
Parameters:
name - DOCUMENT ME!
Returns:
DOCUMENT ME!
Throws:
SAXNotRecognizedException - DOCUMENT ME!
SAXNotSupportedException - DOCUMENT ME!

setFeature

public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
This implementation does actually use any features but just stores them for later retrieval

Specified by:
setFeature in interface XMLReader
Parameters:
name - DOCUMENT ME!
value - DOCUMENT ME!
Throws:
SAXNotRecognizedException - DOCUMENT ME!
SAXNotSupportedException - DOCUMENT ME!

setProperty

public void setProperty(String name,
                        Object value)
Sets the given SAX property

Specified by:
setProperty in interface XMLReader
Parameters:
name - DOCUMENT ME!
value - DOCUMENT ME!

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Gets the given SAX property

Specified by:
getProperty in interface XMLReader
Parameters:
name - DOCUMENT ME!
Returns:
DOCUMENT ME!
Throws:
SAXNotRecognizedException - DOCUMENT ME!
SAXNotSupportedException - DOCUMENT ME!

parse

public void parse(String systemId)
           throws SAXNotSupportedException
This method is not supported.

Specified by:
parse in interface XMLReader
Parameters:
systemId - DOCUMENT ME!
Throws:
SAXNotSupportedException - DOCUMENT ME!

parse

public void parse(InputSource input)
           throws SAXException
Parses an XML document. This method can only accept DocumentInputSource inputs otherwise a SAXNotSupportedExceptionexception is thrown.

Specified by:
parse in interface XMLReader
Parameters:
input - DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!
SAXNotSupportedException - if the input source is not wrapping a dom4j document

writeContent

protected void writeContent(Branch branch,
                            NamespaceStack namespaceStack)
                     throws SAXException
Throws:
SAXException

documentLocator

protected void documentLocator(Document document)
                        throws SAXException
The Locatoris only really useful when parsing a textual document as its main purpose is to identify the line and column number. Since we are processing an in memory tree which will probably have its line number information removed, we'll just use -1 for the line and column numbers.

Parameters:
document - DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

entityResolver

protected void entityResolver(Document document)
                       throws SAXException
Throws:
SAXException

dtdHandler

protected void dtdHandler(Document document)
                   throws SAXException
We do not yet support DTD or XML Schemas so this method does nothing right now.

Parameters:
document - DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

startDocument

protected void startDocument()
                      throws SAXException
Throws:
SAXException

endDocument

protected void endDocument()
                    throws SAXException
Throws:
SAXException

write

protected void write(Element element,
                     NamespaceStack namespaceStack)
              throws SAXException
Throws:
SAXException

startPrefixMapping

protected AttributesImpl startPrefixMapping(Element element,
                                            NamespaceStack namespaceStack)
                                     throws SAXException
Fires a SAX startPrefixMapping event for all the namespaceStack which have just come into scope

Parameters:
element - DOCUMENT ME!
namespaceStack - DOCUMENT ME!
Returns:
DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

endPrefixMapping

protected void endPrefixMapping(NamespaceStack stack,
                                int stackSize)
                         throws SAXException
Fires a SAX endPrefixMapping event for all the namespaceStack which have gone out of scope

Parameters:
stack - DOCUMENT ME!
stackSize - DOCUMENT ME!
Throws:
SAXException - DOCUMENT ME!

startElement

protected void startElement(Element element,
                            AttributesImpl namespaceAttributes)
                     throws SAXException
Throws:
SAXException

endElement

protected void endElement(Element element)
                   throws SAXException
Throws:
SAXException

createAttributes

protected Attributes createAttributes(Element element,
                                      Attributes namespaceAttributes)
                               throws SAXException
Throws:
SAXException

addNamespaceAttribute

protected AttributesImpl addNamespaceAttribute(AttributesImpl attrs,
                                               Namespace namespace)
If isDelcareNamespaceAttributes() is enabled then this method will add the given namespace declaration to the supplied attributes object, creating one if it does not exist.

Parameters:
attrs - DOCUMENT ME!
namespace - DOCUMENT ME!
Returns:
DOCUMENT ME!

isIgnoreableNamespace

protected boolean isIgnoreableNamespace(Namespace namespace,
                                        NamespaceStack namespaceStack)
DOCUMENT ME!

Parameters:
namespace - DOCUMENT ME!
namespaceStack - DOCUMENT ME!
Returns:
true if the given namespace is an ignorable namespace (such as Namespace.NO_NAMESPACE or Namespace.XML_NAMESPACE) or if the namespace has already been declared in the current scope

checkForNullHandlers

protected void checkForNullHandlers()
Ensures non-null content handlers?

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


STAXEventReader (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class STAXEventReader

java.lang.Object
    extended by org.dom4j.io.STAXEventReader
public class STAXEventReader
extends Object

Reads a DOM4J Document, as well as other Nodes, from a StAX XMLEventReader.

Author:
Christian Niles

Constructor Summary
STAXEventReader()
Constructs a default STAXEventReader instance with a default DocumentFactory.
STAXEventReader(DocumentFactory factory)
Constructs a STAXEventReader instance that uses the specified DocumentFactoryto construct DOM4J Nodes.
Method Summary
Attribute | createAttribute(Element elem, javax.xml.stream.events.Attribute attr) Constructs a new DOM4J Attribute from the provided StAX Attribute event.
CharacterData | createCharacterData(javax.xml.stream.events.Characters characters) Constructs a new DOM4J Text or CDATA object from the provided Characters event.
Comment | createComment(javax.xml.stream.events.Comment comment) Constructs a new DOM4J Comment from the provided StAX Comment event.
Element | createElement(javax.xml.stream.events.StartElement startEvent) Constructs a new DOM4J Element from the provided StartElement event.
Entity | createEntity(javax.xml.stream.events.EntityReference entityRef) Constructs a new DOM4J Entity from the provided StAX EntityReference event.
Namespace | createNamespace(javax.xml.stream.events.Namespace ns) Constructs a new DOM4J Namespace from the provided StAX Namespace event.
ProcessingInstruction | createProcessingInstruction(javax.xml.stream.events.ProcessingInstruction pi) Constructs a new DOM4J ProcessingInstruction from the provided StAX ProcessingInstruction event.
QName | createQName(javax.xml.namespace.QName qname) Constructs a new DOM4J QName from the provided JAXP QName.
Attribute | readAttribute(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Attribute from the provided event stream.
CharacterData | readCharacters(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Text or CDATA section from the provided event stream.
Comment | readComment(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Comment from the provided event stream.
Document | readDocument(InputStream is) Constructs a StAX event stream from the provided I/O stream and reads a DOM4J document from it.
Document | readDocument(InputStream is, String systemId) Constructs a StAX event stream from the provided I/O stream and reads a DOM4J document from it.
Document | readDocument(Reader reader) Constructs a StAX event stream from the provided I/O character stream and reads a DOM4J document from it.
Document | readDocument(Reader reader, String systemId) Constructs a StAX event stream from the provided I/O character stream and reads a DOM4J document from it.
Document | readDocument(javax.xml.stream.XMLEventReader reader) Reads a DOM4J Documentfrom the provided stream.
Element | readElement(javax.xml.stream.XMLEventReader eventReader) Reads a DOM4J Element from the provided event stream.
Entity | readEntityReference(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Entity from the provided event stream.
Namespace | readNamespace(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Namespace from the provided event stream.
Node | readNode(javax.xml.stream.XMLEventReader reader) Reads a Nodefrom the event stream.
ProcessingInstruction | readProcessingInstruction(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J ProcessingInstruction from the provided event stream.
void | setDocumentFactory(DocumentFactory documentFactory) Sets the DocumentFactory to be used when constructing DOM4J nodes.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

STAXEventReader

public STAXEventReader()
Constructs a default STAXEventReader instance with a default DocumentFactory.

STAXEventReader

public STAXEventReader(DocumentFactory factory)
Constructs a STAXEventReader instance that uses the specified DocumentFactoryto construct DOM4J Nodes.

Parameters:
factory - The DocumentFactory to use when constructing DOM4J nodes, or null if a default should be used.
Method Detail

setDocumentFactory

public void setDocumentFactory(DocumentFactory documentFactory)
Sets the DocumentFactory to be used when constructing DOM4J nodes.

Parameters:
documentFactory - The DocumentFactory to use when constructing DOM4J nodes, or null if a default should be used.

readDocument

public Document readDocument(InputStream is)
                      throws javax.xml.stream.XMLStreamException
Constructs a StAX event stream from the provided I/O stream and reads a DOM4J document from it.

Parameters:
is - The I/O stream from which the Document will be read.
Returns:
The Document that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs reading content from the stream.

readDocument

public Document readDocument(Reader reader)
                      throws javax.xml.stream.XMLStreamException
Constructs a StAX event stream from the provided I/O character stream and reads a DOM4J document from it.

Parameters:
reader - The character stream from which the Document will be read.
Returns:
The Document that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs reading content from the stream.

readDocument

public Document readDocument(InputStream is,
                             String systemId)
                      throws javax.xml.stream.XMLStreamException
Constructs a StAX event stream from the provided I/O stream and reads a DOM4J document from it.

Parameters:
is - The I/O stream from which the Document will be read.
systemId - A system id used to resolve entities.
Returns:
The Document that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs reading content from the stream.

readDocument

public Document readDocument(Reader reader,
                             String systemId)
                      throws javax.xml.stream.XMLStreamException
Constructs a StAX event stream from the provided I/O character stream and reads a DOM4J document from it.

Parameters:
reader - The character stream from which the Document will be read.
systemId - A system id used to resolve entities.
Returns:
The Document that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs reading content from the stream.

readNode

public Node readNode(javax.xml.stream.XMLEventReader reader)
              throws javax.xml.stream.XMLStreamException
Reads a Nodefrom the event stream. If the next event is a StartElement, all events until the closing EndElement will be read, and the resulting nodes will be added to the returned Element.

Pre-Conditions : The stream must be positioned before an event other than an EndElement,EndDocument, or any DTD-related events, which are not currently supported.

Parameters:
reader - The reader from which events will be read.
Returns:
A DOM4J Nodeconstructed from the read events.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs reading from the stream, or the stream was positioned before an unsupported event.

readDocument

public Document readDocument(javax.xml.stream.XMLEventReader reader)
                      throws javax.xml.stream.XMLStreamException
Reads a DOM4J Documentfrom the provided stream. The stream should be positioned at the start of a document, or before a StartElement event.

Parameters:
reader - The event stream from which to read the Document.
Returns:
The Documentthat was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs reading events from the stream.

readElement

public Element readElement(javax.xml.stream.XMLEventReader eventReader)
                    throws javax.xml.stream.XMLStreamException
Reads a DOM4J Element from the provided event stream. The stream must be positioned before an StartElementevent. In addition to the initial start event, all events up to and including the closing EndElement will be read, and included with the returned element.

Parameters:
eventReader - The event stream from which to read the Element.
Returns:
The Element that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occured reading events from the stream, or the stream was not positioned before a event.

readAttribute

public Attribute readAttribute(javax.xml.stream.XMLEventReader reader)
                        throws javax.xml.stream.XMLStreamException
Constructs a DOM4J Attribute from the provided event stream. The stream must be positioned before an Attributeevent.

Parameters:
reader - The event stream from which to read the Attribute.
Returns:
The Attribute that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occured reading events from the stream, or the stream was not positioned before an event.

readNamespace

public Namespace readNamespace(javax.xml.stream.XMLEventReader reader)
                        throws javax.xml.stream.XMLStreamException
Constructs a DOM4J Namespace from the provided event stream. The stream must be positioned before a Namespaceevent.

Parameters:
reader - The event stream from which to read the Namespace.
Returns:
The Namespace that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occured reading events from the stream, or the stream was not positioned before a event.

readCharacters

public CharacterData readCharacters(javax.xml.stream.XMLEventReader reader)
                             throws javax.xml.stream.XMLStreamException
Constructs a DOM4J Text or CDATA section from the provided event stream. The stream must be positioned before a Charactersevent.

Parameters:
reader - The event stream from which to read the Text or CDATA.
Returns:
The Text or CDATA that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occured reading events from the stream, or the stream was not positioned before a event.

readComment

public Comment readComment(javax.xml.stream.XMLEventReader reader)
                    throws javax.xml.stream.XMLStreamException
Constructs a DOM4J Comment from the provided event stream. The stream must be positioned before a Commentevent.

Parameters:
reader - The event stream from which to read the Comment.
Returns:
The Comment that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occured reading events from the stream, or the stream was not positioned before a event.

readEntityReference

public Entity readEntityReference(javax.xml.stream.XMLEventReader reader)
                           throws javax.xml.stream.XMLStreamException
Constructs a DOM4J Entity from the provided event stream. The stream must be positioned before an EntityReferenceevent.

Parameters:
reader - The event stream from which to read the EntityReference.
Returns:
The Entitythat was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occured reading events from the stream, or the stream was not positioned before an event.

readProcessingInstruction

public ProcessingInstruction readProcessingInstruction(javax.xml.stream.XMLEventReader reader)
                                                throws javax.xml.stream.XMLStreamException
Constructs a DOM4J ProcessingInstruction from the provided event stream. The stream must be positioned before a ProcessingInstruction event.

Parameters:
reader - The event stream from which to read the ProcessingInstruction.
Returns:
The ProcessingInstruction that was read from the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occured reading events from the stream, or the stream was not positioned before a ProcessingInstruction event.

createElement

public Element createElement(javax.xml.stream.events.StartElement startEvent)
Constructs a new DOM4J Element from the provided StartElement event. All attributes and namespaces will be added to the returned element.

Parameters:
startEvent - The StartElement event from which to construct the new DOM4J Element.
Returns:
The Element constructed from the provided StartElement event.

createAttribute

public Attribute createAttribute(Element elem,
                                 javax.xml.stream.events.Attribute attr)
Constructs a new DOM4J Attribute from the provided StAX Attribute event.

Parameters:
elem - DOCUMENT ME!
attr - The Attribute event from which to construct the new DOM4J Attribute.
Returns:
The Attribute constructed from the provided Attribute event.

createNamespace

public Namespace createNamespace(javax.xml.stream.events.Namespace ns)
Constructs a new DOM4J Namespace from the provided StAX Namespace event.

Parameters:
ns - The Namespace event from which to construct the new DOM4J Namespace.
Returns:
The Namespace constructed from the provided Namespace event.

createCharacterData

public CharacterData createCharacterData(javax.xml.stream.events.Characters characters)
Constructs a new DOM4J Text or CDATA object from the provided Characters event.

Parameters:
characters - The Characters event from which to construct the new DOM4J Text or CDATA object.
Returns:
The Text or CDATA object constructed from the provided Characters event.

createComment

public Comment createComment(javax.xml.stream.events.Comment comment)
Constructs a new DOM4J Comment from the provided StAX Comment event.

Parameters:
comment - The Comment event from which to construct the new DOM4J Comment.
Returns:
The Comment constructed from the provided Comment event.

createEntity

public Entity createEntity(javax.xml.stream.events.EntityReference entityRef)
Constructs a new DOM4J Entity from the provided StAX EntityReference event.

Parameters:
entityRef - The EntityReference event from which to construct the new DOM4J Entity.
Returns:
The Entity constructed from the provided EntityReference event.

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(javax.xml.stream.events.ProcessingInstruction pi)
Constructs a new DOM4J ProcessingInstruction from the provided StAX ProcessingInstruction event.

Parameters:
pi - The ProcessingInstruction event from which to construct the new DOM4J ProcessingInstruction.
Returns:
The ProcessingInstruction constructed from the provided ProcessingInstruction event.

createQName

public QName createQName(javax.xml.namespace.QName qname)
Constructs a new DOM4J QName from the provided JAXP QName.

Parameters:
qname - The JAXP QName from which to create a DOM4J QName.
Returns:
The newly constructed DOM4J QName.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


STAXEventWriter (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class STAXEventWriter

java.lang.Object
    extended by org.dom4j.io.STAXEventWriter
public class STAXEventWriter
extends Object

Writes DOM4J Nodes to a StAX event stream. In addition the createXXX methods are provided to directly create STAX events from DOM4J nodes.

Author:
Christian Niles

Constructor Summary
STAXEventWriter()
STAXEventWriter(File file)
Constructs a STAXEventWriter that writes events to the provided file.
STAXEventWriter(OutputStream stream)
Constructs a STAXEventWriter that writes events to the provided stream.
STAXEventWriter(Writer writer)
Constructs a STAXEventWriter that writes events to the provided character stream.
STAXEventWriter(javax.xml.stream.util.XMLEventConsumer consumer)
Constructs a STAXEventWriter that writes events to the provided event stream.
Method Summary
javax.xml.stream.events.Attribute | createAttribute(Attribute attr) Constructs a STAX Attributeevent from a DOM4J Attribute.
javax.xml.stream.events.Characters | createCharacters(CDATA cdata) Constructs a STAX Charactersevent from a DOM4J CDATA.
javax.xml.stream.events.Characters | createCharacters(Text text) Constructs a STAX Charactersevent from a DOM4J Text.
javax.xml.stream.events.Comment | createComment(Comment comment) Constructs a STAX Commentevent from a DOM4J Comment.
javax.xml.stream.events.DTD | createDTD(DocumentType docType) Constructs a STAX DTDevent from a DOM4J DocumentType.
javax.xml.stream.events.EndDocument | createEndDocument(Document doc) Constructs a STAX EndDocumentevent from a DOM4J Document.
javax.xml.stream.events.EndElement | createEndElement(Element elem) Constructs a STAX EndElementevent from a DOM4J Element.
javax.xml.stream.events.Namespace | createNamespace(Namespace ns) Constructs a STAX Namespaceevent from a DOM4J Namespace.
javax.xml.stream.events.ProcessingInstruction | createProcessingInstruction(ProcessingInstruction pi) Constructs a STAX ProcessingInstruction event from a DOM4J ProcessingInstruction.
javax.xml.namespace.QName | createQName(QName qname) Constructs a STAX QNamefrom a DOM4J QName.
javax.xml.stream.events.StartDocument | createStartDocument(Document doc) Constructs a STAX StartDocumentevent from a DOM4J Document.
javax.xml.stream.events.StartElement | createStartElement(Element elem) Constructs a STAX StartElementevent from a DOM4J Element.
javax.xml.stream.util.XMLEventConsumer | getConsumer() Returns a reference to the underlying event consumer to which events are written.
javax.xml.stream.XMLEventFactory | getEventFactory() Returns a reference to the event factory used to construct STAX events.
void | setConsumer(javax.xml.stream.util.XMLEventConsumer consumer) Sets the underlying event consumer to which events are written.
void | setEventFactory(javax.xml.stream.XMLEventFactory eventFactory) Sets the event factory used to construct STAX events.
void | writeAttribute(Attribute attr) Writes a DOM4J Attributeto the stream.
void | writeCDATA(CDATA cdata) Writes a DOM4J CDATAto the event stream.
void | writeChildNodes(Branch branch) Writes each child node within the provided Branchinstance.
void | writeComment(Comment comment) Writes a DOM4J Commentto the stream.
void | writeDocument(Document doc) Writes a DOM4J Documentnode, and all its contents, to the stream.
void | writeDocumentType(DocumentType docType) Writes a DOM4J DocumentTypeto the stream.
void | writeElement(Element elem) Writes a DOM4J Elementnode and its children to the stream.
void | writeEntity(Entity entity) Writes a DOM4J Entityto the stream.
void | writeNamespace(Namespace ns) Writes a DOM4J Namespaceto the stream.
void | writeNode(Node n) Writes a DOM4J Nodeto the stream.
void | writeProcessingInstruction(ProcessingInstruction pi) Writes a DOM4J ProcessingInstructionto the stream.
void | writeText(Text text) Writes a DOM4J Textto the stream.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

STAXEventWriter

public STAXEventWriter()

STAXEventWriter

public STAXEventWriter(File file)
                throws javax.xml.stream.XMLStreamException,
                       IOException
Constructs a STAXEventWriter that writes events to the provided file.

Parameters:
file - The file to which events will be written.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs creating an event writer from the file.
IOException - If an error occurs openin the file for writing.

STAXEventWriter

public STAXEventWriter(Writer writer)
                throws javax.xml.stream.XMLStreamException
Constructs a STAXEventWriter that writes events to the provided character stream.

Parameters:
writer - The character stream to which events will be written.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs constructing an event writer from the character stream.

STAXEventWriter

public STAXEventWriter(OutputStream stream)
                throws javax.xml.stream.XMLStreamException
Constructs a STAXEventWriter that writes events to the provided stream.

Parameters:
stream - The output stream to which events will be written.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs constructing an event writer from the stream.

STAXEventWriter

public STAXEventWriter(javax.xml.stream.util.XMLEventConsumer consumer)
Constructs a STAXEventWriter that writes events to the provided event stream.

Parameters:
consumer - The event stream to which events will be written.
Method Detail

getConsumer

public javax.xml.stream.util.XMLEventConsumer getConsumer()
Returns a reference to the underlying event consumer to which events are written.

Returns:
The underlying event consumer to which events are written.

setConsumer

public void setConsumer(javax.xml.stream.util.XMLEventConsumer consumer)
Sets the underlying event consumer to which events are written.

Parameters:
consumer - The event consumer to which events should be written.

getEventFactory

public javax.xml.stream.XMLEventFactory getEventFactory()
Returns a reference to the event factory used to construct STAX events.

Returns:
The event factory used to construct STAX events.

setEventFactory

public void setEventFactory(javax.xml.stream.XMLEventFactory eventFactory)
Sets the event factory used to construct STAX events.

Parameters:
eventFactory - The new event factory.

writeNode

public void writeNode(Node n)
               throws javax.xml.stream.XMLStreamException
Writes a DOM4J Nodeto the stream. This method is simply a gateway to the overloaded methods such as .

Parameters:
n - The DOM4J Nodeto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

writeChildNodes

public void writeChildNodes(Branch branch)
                     throws javax.xml.stream.XMLStreamException
Writes each child node within the provided Branchinstance. This method simply iterates through the Branch's nodes and calls writeNode(Node).

Parameters:
branch - The node whose children will be written to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

writeElement

public void writeElement(Element elem)
                  throws javax.xml.stream.XMLStreamException
Writes a DOM4J Elementnode and its children to the stream.

Parameters:
elem - The Elementnode to write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createStartElement

public javax.xml.stream.events.StartElement createStartElement(Element elem)
Constructs a STAX StartElementevent from a DOM4J Element.

Parameters:
elem - The Elementfrom which to construct the event.
Returns:
The newly constructed StartElementevent.

createEndElement

public javax.xml.stream.events.EndElement createEndElement(Element elem)
Constructs a STAX EndElementevent from a DOM4J Element.

Parameters:
elem - The Elementfrom which to construct the event.
Returns:
The newly constructed EndElementevent.

writeAttribute

public void writeAttribute(Attribute attr)
                    throws javax.xml.stream.XMLStreamException
Writes a DOM4J Attributeto the stream.

Parameters:
attr - The Attributeto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createAttribute

public javax.xml.stream.events.Attribute createAttribute(Attribute attr)
Constructs a STAX Attributeevent from a DOM4J Attribute.

Parameters:
attr - The Attributefrom which to construct the event.
Returns:
The newly constructed Attribute event.

writeNamespace

public void writeNamespace(Namespace ns)
                    throws javax.xml.stream.XMLStreamException
Writes a DOM4J Namespaceto the stream.

Parameters:
ns - The Namespaceto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createNamespace

public javax.xml.stream.events.Namespace createNamespace(Namespace ns)
Constructs a STAX Namespaceevent from a DOM4J Namespace.

Parameters:
ns - The Namespacefrom which to construct the event.
Returns:
The constructed Namespaceevent.

writeText

public void writeText(Text text)
               throws javax.xml.stream.XMLStreamException
Writes a DOM4J Textto the stream.

Parameters:
text - The Textto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createCharacters

public javax.xml.stream.events.Characters createCharacters(Text text)
Constructs a STAX Charactersevent from a DOM4J Text.

Parameters:
text - The Textfrom which to construct the event.
Returns:
The constructed Charactersevent.

writeCDATA

public void writeCDATA(CDATA cdata)
                throws javax.xml.stream.XMLStreamException
Writes a DOM4J CDATAto the event stream.

Parameters:
cdata - The CDATAto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createCharacters

public javax.xml.stream.events.Characters createCharacters(CDATA cdata)
Constructs a STAX Charactersevent from a DOM4J CDATA.

Parameters:
cdata - The CDATAfrom which to construct the event.
Returns:
The newly constructed Charactersevent.

writeComment

public void writeComment(Comment comment)
                  throws javax.xml.stream.XMLStreamException
Writes a DOM4J Commentto the stream.

Parameters:
comment - The Commentto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createComment

public javax.xml.stream.events.Comment createComment(Comment comment)
Constructs a STAX Commentevent from a DOM4J Comment.

Parameters:
comment - The Commentfrom which to construct the event.
Returns:
The constructed Commentevent.

writeProcessingInstruction

public void writeProcessingInstruction(ProcessingInstruction pi)
                                throws javax.xml.stream.XMLStreamException
Writes a DOM4J ProcessingInstructionto the stream.

Parameters:
pi - The ProcessingInstructionto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createProcessingInstruction

public javax.xml.stream.events.ProcessingInstruction createProcessingInstruction(ProcessingInstruction pi)
Constructs a STAX ProcessingInstruction event from a DOM4J ProcessingInstruction.

Parameters:
pi - The ProcessingInstructionfrom which to construct the event.
Returns:
The constructed ProcessingInstruction event.

writeEntity

public void writeEntity(Entity entity)
                 throws javax.xml.stream.XMLStreamException
Writes a DOM4J Entityto the stream.

Parameters:
entity - The Entityto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

writeDocumentType

public void writeDocumentType(DocumentType docType)
                       throws javax.xml.stream.XMLStreamException
Writes a DOM4J DocumentTypeto the stream.

Parameters:
docType - The DocumentTypeto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createDTD

public javax.xml.stream.events.DTD createDTD(DocumentType docType)
Constructs a STAX DTDevent from a DOM4J DocumentType.

Parameters:
docType - The DocumentTypefrom which to construct the event.
Returns:
The constructed DTDevent.
Throws:
RuntimeException - DOCUMENT ME!

writeDocument

public void writeDocument(Document doc)
                   throws javax.xml.stream.XMLStreamException
Writes a DOM4J Documentnode, and all its contents, to the stream.

Parameters:
doc - The Documentto write to the stream.
Throws:
javax.xml.stream.XMLStreamException - If an error occurs writing to the stream.

createStartDocument

public javax.xml.stream.events.StartDocument createStartDocument(Document doc)
Constructs a STAX StartDocumentevent from a DOM4J Document.

Parameters:
doc - The Documentfrom which to construct the event.
Returns:
The constructed StartDocumentevent.

createEndDocument

public javax.xml.stream.events.EndDocument createEndDocument(Document doc)
Constructs a STAX EndDocumentevent from a DOM4J Document.

Parameters:
doc - The Documentfrom which to construct the event.
Returns:
The constructed EndDocumentevent.

createQName

public javax.xml.namespace.QName createQName(QName qname)
Constructs a STAX QNamefrom a DOM4J QName.

Parameters:
qname - The QNamefrom which to construct the STAX QName.
Returns:
The constructed QName.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XMLResult (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class XMLResult

java.lang.Object
    extended by javax.xml.transform.sax.SAXResult
        extended by org.dom4j.io.XMLResult
All Implemented Interfaces:
Result
public class XMLResult
extends SAXResult

XMLResult implements a JAXP SAXResultfor an output stream with support for pretty printing and control over how the XML is formatted.

Version:
$Revision: 1.9 $
Author:
James Strachan

Field Summary
Fields inherited from class javax.xml.transform.sax.SAXResult
FEATURE
Fields inherited from interface javax.xml.transform.Result
PI_DISABLE_OUTPUT_ESCAPING, PI_ENABLE_OUTPUT_ESCAPING
Constructor Summary
XMLResult()
XMLResult(OutputStream out)
XMLResult(OutputStream out, OutputFormat format)
XMLResult(Writer writer)
XMLResult(Writer writer, OutputFormat format)
XMLResult(XMLWriter xmlWriter)
Method Summary
ContentHandler | getHandler()
LexicalHandler | getLexicalHandler()
XMLWriter | getXMLWriter()
void | setXMLWriter(XMLWriter writer)
Methods inherited from class javax.xml.transform.sax.SAXResult
getSystemId, setHandler, setLexicalHandler, setSystemId
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XMLResult

public XMLResult()

XMLResult

public XMLResult(Writer writer)

XMLResult

public XMLResult(Writer writer,
                 OutputFormat format)

XMLResult

public XMLResult(OutputStream out)
          throws UnsupportedEncodingException

XMLResult

public XMLResult(OutputStream out,
                 OutputFormat format)
          throws UnsupportedEncodingException

XMLResult

public XMLResult(XMLWriter xmlWriter)
Method Detail

getXMLWriter

public XMLWriter getXMLWriter()

setXMLWriter

public void setXMLWriter(XMLWriter writer)

getHandler

public ContentHandler getHandler()

getLexicalHandler

public LexicalHandler getLexicalHandler()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XMLWriter (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class XMLWriter

java.lang.Object
    extended by org.xml.sax.helpers.XMLFilterImpl
        extended by org.dom4j.io.XMLWriter
All Implemented Interfaces:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler, LexicalHandler, XMLFilter, XMLReader
Direct Known Subclasses:
HTMLWriter
public class XMLWriter
extends XMLFilterImpl
implements LexicalHandler

XMLWriter takes a DOM4J tree and formats it to a stream as XML. It can also take SAX events too so can be used by SAX clients as this object implements the ContentHandlerand LexicalHandler interfaces. as well. This formatter performs typical document formatting. The XML declaration and processing instructions are always on their own lines. An OutputFormatobject can be used to define how whitespace is handled when printing and allows various configuration options, such as to allow suppression of the XML declaration, the encoding declaration or whether empty documents are collapsed.

There are write(...) methods to print any of the standard DOM4J classes, including Document and Element, to either a Writer or an OutputStream. Warning: using your own Writer may cause the writer's preferred character encoding to be ignored. If you use encodings other than UTF8, we recommend using the method that takes an OutputStream instead.

Version:
$Revision: 1.83.2.2 $
Author:
James Strachan , Joseph Bowbeer

Field Summary
protected static OutputFormat | DEFAULT_FORMAT
protected int | lastOutputNodeType Stores the last type of node written so algorithms can refer to the previous node type
protected static String[] | LEXICAL_HANDLER_NAMES
protected boolean | preserve Stores the xml:space attribute value of preserve for whitespace flag
protected Writer | writer The Writer used to output to
Constructor Summary
XMLWriter()
XMLWriter(OutputFormat format)
XMLWriter(OutputStream out)
XMLWriter(OutputStream out, OutputFormat format)
XMLWriter(Writer writer)
XMLWriter(Writer writer, OutputFormat format)
Method Summary
void | characters(char[] ch, int start, int length)
void | close() Closes the underlying Writer
void | comment(char[] ch, int start, int length)
protected Writer | createWriter(OutputStream outStream, String encoding) Get an OutputStreamWriter, use preferred encoding.
protected int | defaultMaximumAllowedCharacter() Returns the maximum allowed character code that should be allowed unescaped which defaults to 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit).
void | endCDATA()
void | endDocument()
void | endDTD()
void | endElement(String namespaceURI, String localName, String qName)
void | endEntity(String name)
void | endPrefixMapping(String prefix)
protected String | escapeAttributeEntities(String text) This will take the pre-defined entities in XML 1.0 and convert their character representation to the appropriate entity reference, suitable for XML attributes.
protected String | escapeElementEntities(String text) This will take the pre-defined entities in XML 1.0 and convert their character representation to the appropriate entity reference, suitable for XML attributes.
void | flush() Flushes the underlying Writer
LexicalHandler | getLexicalHandler()
int | getMaximumAllowedCharacter() Returns the maximum allowed character code that should be allowed unescaped which defaults to 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit).
protected OutputFormat | getOutputFormat() Lets subclasses get at the current format object, so they can call setTrimText, setNewLines, etc.
Object | getProperty(String name)
protected void | handleException(IOException e)
void | ignorableWhitespace(char[] ch, int start, int length)
protected void | indent()
protected void | installLexicalHandler()
protected boolean | isElementSpacePreserved(Element element) Determines if element is a special case of XML elements where it contains an xml:space attribute of "preserve".
boolean | isEscapeText() DOCUMENT ME!
protected boolean | isExpandEmptyElements()
protected boolean | isNamespaceDeclaration(Namespace ns)
void | notationDecl(String name, String publicID, String systemID)
void | parse(InputSource source)
void | println() Writes the new line text to the underlying Writer
void | processingInstruction(String target, String data)
boolean | resolveEntityRefs()
void | setDocumentLocator(Locator locator)
void | setEscapeText(boolean escapeText) Sets whether text output should be escaped or not.
void | setIndentLevel(int indentLevel) Set the initial indentation level.
void | setLexicalHandler(LexicalHandler handler)
void | setMaximumAllowedCharacter(int maximumAllowedCharacter) Sets the maximum allowed character code that should be allowed unescaped such as 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit) or -1 to not escape any characters (other than the special XML characters like < > &) If this is not explicitly set then it is defaulted from the encoding.
void | setOutputStream(OutputStream out)
void | setProperty(String name, Object value)
void | setResolveEntityRefs(boolean resolve)
void | setWriter(Writer writer)
protected boolean | shouldEncodeChar(char c) Should the given character be escaped.
void | startCDATA()
void | startDocument()
void | startDTD(String name, String publicID, String systemID)
void | startElement(String namespaceURI, String localName, String qName, Attributes attributes)
void | startEntity(String name)
void | startPrefixMapping(String prefix, String uri)
void | unparsedEntityDecl(String name, String publicID, String systemID, String notationName)
void | write(Attribute attribute) Writes the given Attribute.
void | write(CDATA cdata) Writes the given CDATA.
void | write(Comment comment) Writes the given Comment.
void | write(Document doc) This will print the Document to the current Writer.
void | write(DocumentType docType) Writes the given DocumentType.
void | write(Element element) Writes the Element, including its Attribute s, and its value, and all its content (child nodes) to the current Writer.
void | write(Entity entity) Writes the given Entity.
void | write(Namespace namespace) Writes the given Namespace.
void | write(Node node) Writes the given Node.
void | write(Object object) Writes the given object which should be a String, a Node or a List of Nodes.
void | write(ProcessingInstruction processingInstruction) Writes the given ProcessingInstruction.
void | write(String text) Print out a String, Perfoms the necessary entity escaping and whitespace stripping.
void | write(Text text) Writes the given Text.
protected void | writeAttribute(Attribute attribute)
protected void | writeAttribute(Attributes attributes, int index)
protected void | writeAttributes(Attributes attributes)
protected void | writeAttributes(Element element) Writes the attributes of the given element
protected void | writeCDATA(String text)
void | writeClose(Element element) Writes the closing tag of an Element
protected void | writeClose(String qualifiedName)
protected void | writeComment(String text)
protected void | writeDeclaration() This will write the declaration to the given Writer.
protected void | writeDocType(DocumentType docType)
protected void | writeDocType(String name, String publicID, String systemID)
protected void | writeElement(Element element)
protected void | writeElementContent(Element element) Outputs the content of the given element.
protected void | writeEmptyElementClose(String qualifiedName)
protected void | writeEntity(Entity entity)
protected void | writeEntityRef(String name)
protected void | writeEscapeAttributeEntities(String txt)
protected void | writeNamespace(Namespace namespace)
protected void | writeNamespace(String prefix, String uri) Writes the SAX namepsaces
protected void | writeNamespaces() Writes the SAX namepsaces
protected void | writeNode(Node node)
protected void | writeNodeText(Node node) This method is used to write out Nodes that contain text and still allow for xml:space to be handled properly.
void | writeOpen(Element element) Writes the opening tag of an Element, including its Attributes but without its content.
protected void | writePrintln() This will print a new line only if the newlines flag was set to true
protected void | writeProcessingInstruction(ProcessingInstruction pi)
protected void | writeString(String text)
Methods inherited from class org.xml.sax.helpers.XMLFilterImpl
error, fatalError, getContentHandler, getDTDHandler, getEntityResolver, getErrorHandler, getFeature, getParent, parse, resolveEntity, setContentHandler, setDTDHandler, setEntityResolver, setErrorHandler, setFeature, setParent, skippedEntity, warning
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

LEXICAL_HANDLER_NAMES

protected static final String[] LEXICAL_HANDLER_NAMES

DEFAULT_FORMAT

protected static final OutputFormat DEFAULT_FORMAT

lastOutputNodeType

protected int lastOutputNodeType
Stores the last type of node written so algorithms can refer to the previous node type

preserve

protected boolean preserve
Stores the xml:space attribute value of preserve for whitespace flag

writer

protected Writer writer
The Writer used to output to

Constructor Detail

XMLWriter

public XMLWriter(Writer writer)

XMLWriter

public XMLWriter(Writer writer,
                 OutputFormat format)

XMLWriter

public XMLWriter()

XMLWriter

public XMLWriter(OutputStream out)
          throws UnsupportedEncodingException

XMLWriter

public XMLWriter(OutputStream out,
                 OutputFormat format)
          throws UnsupportedEncodingException

XMLWriter

public XMLWriter(OutputFormat format)
          throws UnsupportedEncodingException
Method Detail

setWriter

public void setWriter(Writer writer)

setOutputStream

public void setOutputStream(OutputStream out)
                     throws UnsupportedEncodingException
Throws:
UnsupportedEncodingException

isEscapeText

public boolean isEscapeText()
DOCUMENT ME!

Returns:
true if text thats output should be escaped. This is enabled by default. It could be disabled if the output format is textual, like in XSLT where we can have xml, html or text output.

setEscapeText

public void setEscapeText(boolean escapeText)
Sets whether text output should be escaped or not. This is enabled by default. It could be disabled if the output format is textual, like in XSLT where we can have xml, html or text output.

Parameters:
escapeText - DOCUMENT ME!

setIndentLevel

public void setIndentLevel(int indentLevel)
Set the initial indentation level. This can be used to output a document (or, more likely, an element) starting at a given indent level, so it's not always flush against the left margin. Default: 0

Parameters:
indentLevel - the number of indents to start with

getMaximumAllowedCharacter

public int getMaximumAllowedCharacter()
Returns the maximum allowed character code that should be allowed unescaped which defaults to 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit).

Returns:
DOCUMENT ME!

setMaximumAllowedCharacter

public void setMaximumAllowedCharacter(int maximumAllowedCharacter)
Sets the maximum allowed character code that should be allowed unescaped such as 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit) or -1 to not escape any characters (other than the special XML characters like < > &) If this is not explicitly set then it is defaulted from the encoding.

Parameters:
maximumAllowedCharacter - The maximumAllowedCharacter to set

flush

public void flush()
           throws IOException
Flushes the underlying Writer

Throws:
IOException - DOCUMENT ME!

close

public void close()
           throws IOException
Closes the underlying Writer

Throws:
IOException - DOCUMENT ME!

println

public void println()
             throws IOException
Writes the new line text to the underlying Writer

Throws:
IOException - DOCUMENT ME!

write

public void write(Attribute attribute)
           throws IOException
Writes the given Attribute.

Parameters:
attribute - Attribute to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(Document doc)
           throws IOException

This will print the Document to the current Writer.

Warning: using your own Writer may cause the writer's preferred character encoding to be ignored. If you use encodings other than UTF8, we recommend using the method that takes an OutputStream instead.

Note: as with all Writers, you may need to flush() yours after this method returns.

Parameters:
doc - Document to format.
Throws:
IOException - if there's any problem writing.

write

public void write(Element element)
           throws IOException

Writes the Element, including its Attribute s, and its value, and all its content (child nodes) to the current Writer.

Parameters:
element - Element to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(CDATA cdata)
           throws IOException
Writes the given CDATA.

Parameters:
cdata - CDATA to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(Comment comment)
           throws IOException
Writes the given Comment.

Parameters:
comment - Comment to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(DocumentType docType)
           throws IOException
Writes the given DocumentType.

Parameters:
docType - DocumentType to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(Entity entity)
           throws IOException
Writes the given Entity.

Parameters:
entity - Entity to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(Namespace namespace)
           throws IOException
Writes the given Namespace.

Parameters:
namespace - Namespace to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(ProcessingInstruction processingInstruction)
           throws IOException
Writes the given ProcessingInstruction.

Parameters:
processingInstruction - ProcessingInstruction to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(String text)
           throws IOException

Print out a String, Perfoms the necessary entity escaping and whitespace stripping.

Parameters:
text - is the text to output
Throws:
IOException - DOCUMENT ME!

write

public void write(Text text)
           throws IOException
Writes the given Text.

Parameters:
text - Text to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(Node node)
           throws IOException
Writes the given Node.

Parameters:
node - Node to output.
Throws:
IOException - DOCUMENT ME!

write

public void write(Object object)
           throws IOException
Writes the given object which should be a String, a Node or a List of Nodes.

Parameters:
object - is the object to output.
Throws:
IOException - DOCUMENT ME!

writeOpen

public void writeOpen(Element element)
               throws IOException

Writes the opening tag of an Element, including its Attributes but without its content.

Parameters:
element - Element to output.
Throws:
IOException - DOCUMENT ME!

writeClose

public void writeClose(Element element)
                throws IOException

Writes the closing tag of an Element

Parameters:
element - Element to output.
Throws:
IOException - DOCUMENT ME!

parse

public void parse(InputSource source)
           throws IOException,
                  SAXException
Specified by:
parse in interface XMLReader
Throws:
IOException
SAXException

setProperty

public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
Specified by:
setProperty in interface XMLReader
Throws:
SAXNotRecognizedException
SAXNotSupportedException

getProperty

public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
Specified by:
getProperty in interface XMLReader
Throws:
SAXNotRecognizedException
SAXNotSupportedException

setLexicalHandler

public void setLexicalHandler(LexicalHandler handler)

getLexicalHandler

public LexicalHandler getLexicalHandler()

setDocumentLocator

public void setDocumentLocator(Locator locator)
Specified by:
setDocumentLocator in interface ContentHandler

startDocument

public void startDocument()
                   throws SAXException
Specified by:
startDocument in interface ContentHandler
Throws:
SAXException

endDocument

public void endDocument()
                 throws SAXException
Specified by:
endDocument in interface ContentHandler
Throws:
SAXException

startPrefixMapping

public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
Specified by:
startPrefixMapping in interface ContentHandler
Throws:
SAXException

endPrefixMapping

public void endPrefixMapping(String prefix)
                      throws SAXException
Specified by:
endPrefixMapping in interface ContentHandler
Throws:
SAXException

startElement

public void startElement(String namespaceURI,
                         String localName,
                         String qName,
                         Attributes attributes)
                  throws SAXException
Specified by:
startElement in interface ContentHandler
Throws:
SAXException

endElement

public void endElement(String namespaceURI,
                       String localName,
                       String qName)
                throws SAXException
Specified by:
endElement in interface ContentHandler
Throws:
SAXException

characters

public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
Specified by:
characters in interface ContentHandler
Throws:
SAXException

ignorableWhitespace

public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
Specified by:
ignorableWhitespace in interface ContentHandler
Throws:
SAXException

processingInstruction

public void processingInstruction(String target,
                                  String data)
                           throws SAXException
Specified by:
processingInstruction in interface ContentHandler
Throws:
SAXException

notationDecl

public void notationDecl(String name,
                         String publicID,
                         String systemID)
                  throws SAXException
Specified by:
notationDecl in interface DTDHandler
Throws:
SAXException

unparsedEntityDecl

public void unparsedEntityDecl(String name,
                               String publicID,
                               String systemID,
                               String notationName)
                        throws SAXException
Specified by:
unparsedEntityDecl in interface DTDHandler
Throws:
SAXException

startDTD

public void startDTD(String name,
                     String publicID,
                     String systemID)
              throws SAXException
Specified by:
startDTD in interface LexicalHandler
Throws:
SAXException

endDTD

public void endDTD()
            throws SAXException
Specified by:
endDTD in interface LexicalHandler
Throws:
SAXException

startCDATA

public void startCDATA()
                throws SAXException
Specified by:
startCDATA in interface LexicalHandler
Throws:
SAXException

endCDATA

public void endCDATA()
              throws SAXException
Specified by:
endCDATA in interface LexicalHandler
Throws:
SAXException

startEntity

public void startEntity(String name)
                 throws SAXException
Specified by:
startEntity in interface LexicalHandler
Throws:
SAXException

endEntity

public void endEntity(String name)
               throws SAXException
Specified by:
endEntity in interface LexicalHandler
Throws:
SAXException

comment

public void comment(char[] ch,
                    int start,
                    int length)
             throws SAXException
Specified by:
comment in interface LexicalHandler
Throws:
SAXException

writeElement

protected void writeElement(Element element)
                     throws IOException
Throws:
IOException

isElementSpacePreserved

protected final boolean isElementSpacePreserved(Element element)
Determines if element is a special case of XML elements where it contains an xml:space attribute of "preserve". If it does, then retain whitespace.

Parameters:
element - DOCUMENT ME!
Returns:
DOCUMENT ME!

writeElementContent

protected void writeElementContent(Element element)
                            throws IOException
Outputs the content of the given element. If whitespace trimming is enabled then all adjacent text nodes are appended together before the whitespace trimming occurs to avoid problems with multiple text nodes being created due to text content that spans parser buffers in a SAX parser.

Parameters:
element - DOCUMENT ME!
Throws:
IOException - DOCUMENT ME!

writeCDATA

protected void writeCDATA(String text)
                   throws IOException
Throws:
IOException

writeDocType

protected void writeDocType(DocumentType docType)
                     throws IOException
Throws:
IOException

writeNamespace

protected void writeNamespace(Namespace namespace)
                       throws IOException
Throws:
IOException

writeNamespaces

protected void writeNamespaces()
                        throws IOException
Writes the SAX namepsaces

Throws:
IOException - DOCUMENT ME!

writeNamespace

protected void writeNamespace(String prefix,
                              String uri)
                       throws IOException
Writes the SAX namepsaces

Parameters:
prefix - the prefix
uri - the namespace uri
Throws:
IOException

writeProcessingInstruction

protected void writeProcessingInstruction(ProcessingInstruction pi)
                                   throws IOException
Throws:
IOException

writeString

protected void writeString(String text)
                    throws IOException
Throws:
IOException

writeNodeText

protected void writeNodeText(Node node)
                      throws IOException
This method is used to write out Nodes that contain text and still allow for xml:space to be handled properly.

Parameters:
node - DOCUMENT ME!
Throws:
IOException - DOCUMENT ME!

writeNode

protected void writeNode(Node node)
                  throws IOException
Throws:
IOException

installLexicalHandler

protected void installLexicalHandler()

writeDocType

protected void writeDocType(String name,
                            String publicID,
                            String systemID)
                     throws IOException
Throws:
IOException

writeEntity

protected void writeEntity(Entity entity)
                    throws IOException
Throws:
IOException

writeEntityRef

protected void writeEntityRef(String name)
                       throws IOException
Throws:
IOException

writeComment

protected void writeComment(String text)
                     throws IOException
Throws:
IOException

writeAttributes

protected void writeAttributes(Element element)
                        throws IOException
Writes the attributes of the given element

Parameters:
element - DOCUMENT ME!
Throws:
IOException - DOCUMENT ME!

writeAttribute

protected void writeAttribute(Attribute attribute)
                       throws IOException
Throws:
IOException

writeAttributes

protected void writeAttributes(Attributes attributes)
                        throws IOException
Throws:
IOException

writeAttribute

protected void writeAttribute(Attributes attributes,
                              int index)
                       throws IOException
Throws:
IOException

indent

protected void indent()
               throws IOException
Throws:
IOException

writePrintln

protected void writePrintln()
                     throws IOException

This will print a new line only if the newlines flag was set to true

Throws:
IOException - DOCUMENT ME!

createWriter

protected Writer createWriter(OutputStream outStream,
                              String encoding)
                       throws UnsupportedEncodingException
Get an OutputStreamWriter, use preferred encoding.

Parameters:
outStream - DOCUMENT ME!
encoding - DOCUMENT ME!
Returns:
DOCUMENT ME!
Throws:
UnsupportedEncodingException - DOCUMENT ME!

writeDeclaration

protected void writeDeclaration()
                         throws IOException

This will write the declaration to the given Writer. Assumes XML version 1.0 since we don't directly know.

Throws:
IOException - DOCUMENT ME!

writeClose

protected void writeClose(String qualifiedName)
                   throws IOException
Throws:
IOException

writeEmptyElementClose

protected void writeEmptyElementClose(String qualifiedName)
                               throws IOException
Throws:
IOException

isExpandEmptyElements

protected boolean isExpandEmptyElements()

escapeElementEntities

protected String escapeElementEntities(String text)
This will take the pre-defined entities in XML 1.0 and convert their character representation to the appropriate entity reference, suitable for XML attributes.

Parameters:
text - DOCUMENT ME!
Returns:
DOCUMENT ME!

writeEscapeAttributeEntities

protected void writeEscapeAttributeEntities(String txt)
                                     throws IOException
Throws:
IOException

escapeAttributeEntities

protected String escapeAttributeEntities(String text)
This will take the pre-defined entities in XML 1.0 and convert their character representation to the appropriate entity reference, suitable for XML attributes.

Parameters:
text - DOCUMENT ME!
Returns:
DOCUMENT ME!

shouldEncodeChar

protected boolean shouldEncodeChar(char c)
Should the given character be escaped. This depends on the encoding of the document.

Parameters:
c - DOCUMENT ME!
Returns:
boolean

defaultMaximumAllowedCharacter

protected int defaultMaximumAllowedCharacter()
Returns the maximum allowed character code that should be allowed unescaped which defaults to 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit).

Returns:
DOCUMENT ME!

isNamespaceDeclaration

protected boolean isNamespaceDeclaration(Namespace ns)

handleException

protected void handleException(IOException e)
                        throws SAXException
Throws:
SAXException

getOutputFormat

protected OutputFormat getOutputFormat()
Lets subclasses get at the current format object, so they can call setTrimText, setNewLines, etc. Put in to support the HTMLWriter, in the way that it pushes the current newline/trim state onto a stack and overrides the state within preformatted tags.

Returns:
DOCUMENT ME!

resolveEntityRefs

public boolean resolveEntityRefs()

setResolveEntityRefs

public void setResolveEntityRefs(boolean resolve)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XPP3Reader (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class XPP3Reader

java.lang.Object
    extended by org.dom4j.io.XPP3Reader
public class XPP3Reader
extends Object

XPP3Reader is a Reader of DOM4J documents that uses the fast XML Pull Parser 3.x . It is very fast for use in SOAP style environments.

Version:
$Revision: 1.3 $
Author:
Pelle Braendgaard , James Strachan

Constructor Summary
XPP3Reader()
XPP3Reader(DocumentFactory factory)
Method Summary
void | addHandler(String path, ElementHandler handler) Adds the ElementHandler to be called when the specified path is encounted.
protected Reader | createReader(InputStream in) Factory method to create a Reader from the given InputStream.
protected org.dom4j.io.DispatchHandler | getDispatchHandler()
DocumentFactory | getDocumentFactory() DOCUMENT ME!
org.xmlpull.v1.XmlPullParserFactory | getXPPFactory()
org.xmlpull.v1.XmlPullParser | getXPPParser()
protected Document | parseDocument()
Document | read(char[] text) Reads a Document from the given array of characters
Document | read(File file) Reads a Document from the given File
Document | read(InputStream in) Reads a Document from the given stream
Document | read(InputStream in, String systemID) Reads a Document from the given stream
Document | read(Reader reader) Reads a Document from the given Reader
Document | read(Reader reader, String systemID) Reads a Document from the given Reader
Document | read(String systemID) Reads a Document from the given URL or filename.
Document | read(URL url) Reads a Document from the given URL
void | removeHandler(String path) Removes the ElementHandler from the event based processor, for the specified path.
void | setDefaultHandler(ElementHandler handler) When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.
protected void | setDispatchHandler(org.dom4j.io.DispatchHandler dispatchHandler)
void | setDocumentFactory(DocumentFactory documentFactory) This sets the DocumentFactory used to create new documents.
void | setXPPFactory(org.xmlpull.v1.XmlPullParserFactory xPPfactory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XPP3Reader

public XPP3Reader()

XPP3Reader

public XPP3Reader(DocumentFactory factory)
Method Detail

read

public Document read(File file)
              throws DocumentException,
                     IOException,
                     org.xmlpull.v1.XmlPullParserException

Reads a Document from the given File

Parameters:
file - is the File to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - if a URL could not be made for the given File
org.xmlpull.v1.XmlPullParserException - DOCUMENT ME!

read

public Document read(URL url)
              throws DocumentException,
                     IOException,
                     org.xmlpull.v1.XmlPullParserException

Reads a Document from the given URL

Parameters:
url - URL to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.xmlpull.v1.XmlPullParserException - DOCUMENT ME!

read

public Document read(String systemID)
              throws DocumentException,
                     IOException,
                     org.xmlpull.v1.XmlPullParserException

Reads a Document from the given URL or filename.

If the systemID contains a ':' character then it is assumed to be a URL otherwise its assumed to be a file name. If you want finer grained control over this mechansim then please explicitly pass in either a URLor a Fileinstance instead of a String to denote the source of the document.

Parameters:
systemID - is a URL for a document or a file name.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - if a URL could not be made for the given File
org.xmlpull.v1.XmlPullParserException - DOCUMENT ME!

read

public Document read(InputStream in)
              throws DocumentException,
                     IOException,
                     org.xmlpull.v1.XmlPullParserException

Reads a Document from the given stream

Parameters:
in - InputStream to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.xmlpull.v1.XmlPullParserException - DOCUMENT ME!

read

public Document read(Reader reader)
              throws DocumentException,
                     IOException,
                     org.xmlpull.v1.XmlPullParserException

Reads a Document from the given Reader

Parameters:
reader - is the reader for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.xmlpull.v1.XmlPullParserException - DOCUMENT ME!

read

public Document read(char[] text)
              throws DocumentException,
                     IOException,
                     org.xmlpull.v1.XmlPullParserException

Reads a Document from the given array of characters

Parameters:
text - is the text to parse
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.xmlpull.v1.XmlPullParserException - DOCUMENT ME!

read

public Document read(InputStream in,
                     String systemID)
              throws DocumentException,
                     IOException,
                     org.xmlpull.v1.XmlPullParserException

Reads a Document from the given stream

Parameters:
in - InputStream to read from.
systemID - is the URI for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.xmlpull.v1.XmlPullParserException - DOCUMENT ME!

read

public Document read(Reader reader,
                     String systemID)
              throws DocumentException,
                     IOException,
                     org.xmlpull.v1.XmlPullParserException

Reads a Document from the given Reader

Parameters:
reader - is the reader for the input
systemID - is the URI for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.xmlpull.v1.XmlPullParserException - DOCUMENT ME!

getXPPParser

public org.xmlpull.v1.XmlPullParser getXPPParser()
                                          throws org.xmlpull.v1.XmlPullParserException
Throws:
org.xmlpull.v1.XmlPullParserException

getXPPFactory

public org.xmlpull.v1.XmlPullParserFactory getXPPFactory()
                                                  throws org.xmlpull.v1.XmlPullParserException
Throws:
org.xmlpull.v1.XmlPullParserException

setXPPFactory

public void setXPPFactory(org.xmlpull.v1.XmlPullParserFactory xPPfactory)

getDocumentFactory

public DocumentFactory getDocumentFactory()
DOCUMENT ME!

Returns:
the DocumentFactory used to create document objects

setDocumentFactory

public void setDocumentFactory(DocumentFactory documentFactory)

This sets the DocumentFactory used to create new documents. This method allows the building of custom DOM4J tree objects to be implemented easily using a custom derivation of DocumentFactory

Parameters:
documentFactory - DocumentFactory used to create DOM4J objects

addHandler

public void addHandler(String path,
                       ElementHandler handler)
Adds the ElementHandler to be called when the specified path is encounted.

Parameters:
path - is the path to be handled
handler - is the ElementHandler to be called by the event based processor.

removeHandler

public void removeHandler(String path)
Removes the ElementHandler from the event based processor, for the specified path.

Parameters:
path - is the path to remove the ElementHandler for.

setDefaultHandler

public void setDefaultHandler(ElementHandler handler)
When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.

Parameters:
handler - is the ElementHandler to be called by the event based processor.

parseDocument

protected Document parseDocument()
                          throws DocumentException,
                                 IOException,
                                 org.xmlpull.v1.XmlPullParserException
Throws:
DocumentException
IOException
org.xmlpull.v1.XmlPullParserException

getDispatchHandler

protected org.dom4j.io.DispatchHandler getDispatchHandler()

setDispatchHandler

protected void setDispatchHandler(org.dom4j.io.DispatchHandler dispatchHandler)

createReader

protected Reader createReader(InputStream in)
                       throws IOException
Factory method to create a Reader from the given InputStream.

Parameters:
in - DOCUMENT ME!
Returns:
DOCUMENT ME!
Throws:
IOException - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XPPReader (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.io
Class XPPReader

java.lang.Object
    extended by org.dom4j.io.XPPReader
public class XPPReader
extends Object

XPPReader is a Reader of DOM4J documents that uses the fast XML Pull Parser 2.x . It does not currently support comments, CDATA or ProcessingInstructions or validation but it is very fast for use in SOAP style environments.

Version:
$Revision: 1.7 $
Author:
James Strachan

Constructor Summary
XPPReader()
XPPReader(DocumentFactory factory)
Method Summary
void | addHandler(String path, ElementHandler handler) Adds the ElementHandler to be called when the specified path is encounted.
protected Reader | createReader(InputStream in) Factory method to create a Reader from the given InputStream.
protected org.dom4j.io.DispatchHandler | getDispatchHandler()
DocumentFactory | getDocumentFactory() DOCUMENT ME!
org.gjt.xpp.XmlPullParserFactory | getXPPFactory()
org.gjt.xpp.XmlPullParser | getXPPParser()
protected Document | parseDocument()
Document | read(char[] text) Reads a Document from the given array of characters
Document | read(File file) Reads a Document from the given File
Document | read(InputStream in) Reads a Document from the given stream
Document | read(InputStream in, String systemID) Reads a Document from the given stream
Document | read(Reader reader) Reads a Document from the given Reader
Document | read(Reader reader, String systemID) Reads a Document from the given Reader
Document | read(String systemID) Reads a Document from the given URL or filename.
Document | read(URL url) Reads a Document from the given URL
void | removeHandler(String path) Removes the ElementHandler from the event based processor, for the specified path.
void | setDefaultHandler(ElementHandler handler) When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.
protected void | setDispatchHandler(org.dom4j.io.DispatchHandler dispatchHandler)
void | setDocumentFactory(DocumentFactory documentFactory) This sets the DocumentFactory used to create new documents.
void | setXPPFactory(org.gjt.xpp.XmlPullParserFactory xPPFactory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XPPReader

public XPPReader()

XPPReader

public XPPReader(DocumentFactory factory)
Method Detail

read

public Document read(File file)
              throws DocumentException,
                     IOException,
                     org.gjt.xpp.XmlPullParserException

Reads a Document from the given File

Parameters:
file - is the File to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - if a URL could not be made for the given File
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

read

public Document read(URL url)
              throws DocumentException,
                     IOException,
                     org.gjt.xpp.XmlPullParserException

Reads a Document from the given URL

Parameters:
url - URL to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

read

public Document read(String systemID)
              throws DocumentException,
                     IOException,
                     org.gjt.xpp.XmlPullParserException

Reads a Document from the given URL or filename.

If the systemID contains a ':' character then it is assumed to be a URL otherwise its assumed to be a file name. If you want finer grained control over this mechansim then please explicitly pass in either a URLor a Fileinstance instead of a String to denote the source of the document.

Parameters:
systemID - is a URL for a document or a file name.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - if a URL could not be made for the given File
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

read

public Document read(InputStream in)
              throws DocumentException,
                     IOException,
                     org.gjt.xpp.XmlPullParserException

Reads a Document from the given stream

Parameters:
in - InputStream to read from.
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

read

public Document read(Reader reader)
              throws DocumentException,
                     IOException,
                     org.gjt.xpp.XmlPullParserException

Reads a Document from the given Reader

Parameters:
reader - is the reader for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

read

public Document read(char[] text)
              throws DocumentException,
                     IOException,
                     org.gjt.xpp.XmlPullParserException

Reads a Document from the given array of characters

Parameters:
text - is the text to parse
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

read

public Document read(InputStream in,
                     String systemID)
              throws DocumentException,
                     IOException,
                     org.gjt.xpp.XmlPullParserException

Reads a Document from the given stream

Parameters:
in - InputStream to read from.
systemID - is the URI for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

read

public Document read(Reader reader,
                     String systemID)
              throws DocumentException,
                     IOException,
                     org.gjt.xpp.XmlPullParserException

Reads a Document from the given Reader

Parameters:
reader - is the reader for the input
systemID - is the URI for the input
Returns:
the newly created Document instance
Throws:
DocumentException - if an error occurs during parsing.
IOException - DOCUMENT ME!
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

getXPPParser

public org.gjt.xpp.XmlPullParser getXPPParser()
                                       throws org.gjt.xpp.XmlPullParserException
Throws:
org.gjt.xpp.XmlPullParserException

getXPPFactory

public org.gjt.xpp.XmlPullParserFactory getXPPFactory()
                                               throws org.gjt.xpp.XmlPullParserException
Throws:
org.gjt.xpp.XmlPullParserException

setXPPFactory

public void setXPPFactory(org.gjt.xpp.XmlPullParserFactory xPPFactory)

getDocumentFactory

public DocumentFactory getDocumentFactory()
DOCUMENT ME!

Returns:
the DocumentFactory used to create document objects

setDocumentFactory

public void setDocumentFactory(DocumentFactory documentFactory)

This sets the DocumentFactory used to create new documents. This method allows the building of custom DOM4J tree objects to be implemented easily using a custom derivation of DocumentFactory

Parameters:
documentFactory - DocumentFactory used to create DOM4J objects

addHandler

public void addHandler(String path,
                       ElementHandler handler)
Adds the ElementHandler to be called when the specified path is encounted.

Parameters:
path - is the path to be handled
handler - is the ElementHandler to be called by the event based processor.

removeHandler

public void removeHandler(String path)
Removes the ElementHandler from the event based processor, for the specified path.

Parameters:
path - is the path to remove the ElementHandler for.

setDefaultHandler

public void setDefaultHandler(ElementHandler handler)
When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.

Parameters:
handler - is the ElementHandler to be called by the event based processor.

parseDocument

protected Document parseDocument()
                          throws DocumentException,
                                 IOException,
                                 org.gjt.xpp.XmlPullParserException
Throws:
DocumentException
IOException
org.gjt.xpp.XmlPullParserException

getDispatchHandler

protected org.dom4j.io.DispatchHandler getDispatchHandler()

setDispatchHandler

protected void setDispatchHandler(org.dom4j.io.DispatchHandler dispatchHandler)

createReader

protected Reader createReader(InputStream in)
                       throws IOException
Factory method to create a Reader from the given InputStream.

Parameters:
in - DOCUMENT ME!
Returns:
DOCUMENT ME!
Throws:
IOException - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.jaxb (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.jaxb

Interface Summary
JAXBObjectHandler | JAXBObjectHandler implementations can be registered with the JAXB Reader in order to receive unmarshalled XML fragments.
JAXBObjectModifier | JAXBObjectHandler implementations can be registered with the JAXBModifier in order to change unmarshalled XML fragments.

Class Summary
JAXBModifier | Reads an XML document using SAX and writes its content to the provided XMLWriter.
JAXBReader | Reads an XML document and creates a DOM4J tree from SAX parsing events.
JAXBWriter | Writes Elementobjects to an XML stream.


org.dom4j.jaxb Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.jaxb

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.jaxb.JAXBSupport
      • class org.dom4j.jaxb.JAXBModifier
      • class org.dom4j.jaxb.JAXBReader
      • class org.dom4j.jaxb.JAXBWriter

Interface Hierarchy

  • interface org.dom4j.jaxb.JAXBObjectHandler
  • interface org.dom4j.jaxb.JAXBObjectModifier


Uses of Package org.dom4j.jaxb (dom4j 1.6.1 API)

Uses of Package
org.dom4j.jaxb

Packages that use org.dom4j.jaxb
org.dom4j.jaxb

Classes in org.dom4j.jaxb used by org.dom4j.jaxb
JAXBObjectHandler
JAXBObjectHandler implementations can be registered with the JAXB Reader in order to receive unmarshalled XML fragments.
JAXBObjectModifier
JAXBObjectHandler implementations can be registered with the JAXBModifier in order to change unmarshalled XML fragments.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


JAXBObjectHandler (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.jaxb
Interface JAXBObjectHandler

public interface JAXBObjectHandler

JAXBObjectHandler implementations can be registered with the JAXB Reader in order to receive unmarshalled XML fragments.

Author:
Wonne Keysers (Realsoftware.be)

Method Summary
 void handleObject(javax.xml.bind.Element jaxbElement)
Called when the JAXBReaderhas finished parsing the xml path the handler was registered for.

Method Detail

handleObject

public void handleObject(javax.xml.bind.Element jaxbElement)
                  throws Exception
Called when the JAXBReaderhas finished parsing the xml path the handler was registered for. The provided object is the unmarshalled representation of the XML path. It can be casted to the appropriate implementation class that is generated by the JAXB compiler.

Parameters:
jaxbElement - the unmarshalled JAXB object to handle
Throws:
Exception - of any kind, thrown by the implementation
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JAXBObjectModifier (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.jaxb
Interface JAXBObjectModifier

public interface JAXBObjectModifier

JAXBObjectHandler implementations can be registered with the JAXBModifier in order to change unmarshalled XML fragments.

Author:
Wonne Keysers (Realsoftware.be)

Method Summary
 javax.xml.bind.Element modifyObject(javax.xml.bind.Element jaxbElement)
Called when the JAXBModifierhas finished parsing the xml path the handler was registered for.

Method Detail

modifyObject

public javax.xml.bind.Element modifyObject(javax.xml.bind.Element jaxbElement)
                                    throws Exception
Called when the JAXBModifierhas finished parsing the xml path the handler was registered for. The provided object is the unmarshalled representation of the XML fragment. It can be casted to the appropriate implementation class that is generated by the JAXB compiler.
The modified JAXB element that returns from this method will be marshalled by the JAXBModifierand put in the DOM4J tree.

Parameters:
jaxbElement - the JAXB object to be modified
Returns:
the modified JAXB object, or null when it must be removed.
Throws:
Exception - possibly thrown by the implementation.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JAXBModifier (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.jaxb
Class JAXBModifier

java.lang.Object
    extended by org.dom4j.jaxb.JAXBSupport
        extended by org.dom4j.jaxb.JAXBModifier
public class JAXBModifier
extends org.dom4j.jaxb.JAXBSupport

Reads an XML document using SAX and writes its content to the provided XMLWriter. Modifications must be provided by JAXBObjectModifier objects, which are called prior to writing the XML fragment they are registered for.

Author:
Wonne Keysers (Realsoftware.be)
See Also:
SAXModifier

Constructor Summary
JAXBModifier(String contextPath)
Creates a new JAXBModifier for the given JAXB context path.
JAXBModifier(String contextPath, ClassLoader classloader)
Creates a new JAXBModifier for the given JAXB context path, using the given ClassLoader.
JAXBModifier(String contextPath, ClassLoader classloader, OutputFormat outputFormat)
Creates a new JAXBModifier for the given JAXB context path, using the specified Classloader.
JAXBModifier(String contextPath, OutputFormat outputFormat)
Creates a new JAXBModifier for the given JAXB context path.
Method Summary
void | addObjectModifier(String path, JAXBObjectModifier mod) Adds the JAXBObjectModifierto be called when the specified xml path is encounted while parsing the source.
boolean | isPruneElements() Returns true when the modified Documentis not kept in memory.
protected Element | marshal(javax.xml.bind.Element element) Marshals the given Elementin to its DOM4J counterpart.
Document | modify(File source) Parses the specified Filewith SAX
Document | modify(File source, java.nio.charset.Charset charset) Parses the specified Filewith SAX, using the given Charset.
Document | modify(InputSource source) Parses the specified InputSourcewith SAX.
Document | modify(InputStream source) Parses the specified InputStreamwith SAX.
Document | modify(InputStream source, String systemId) Parses the specified InputStreamwith SAX.
Document | modify(Reader r) Parses the specified Readerwith SAX.
Document | modify(Reader source, String systemId) Parses the specified Readerwith SAX.
Document | modify(String url) Parses the the given URL or filename.
Document | modify(URL source) Parses the the given URL.
void | removeObjectModifier(String path) Removes the JAXBObjectModifierfrom the event based processor, for the specified element path.
void | resetObjectModifiers() Removes all registered JAXBObjectModifierinstances from the event based processor.
void | setOutput(File file) Sets the Output to write the (modified) xml document to.
void | setOutput(OutputStream outputStream) Sets the Output to write the (modified) xml document to.
void | setOutput(Writer writer) Sets the Output to write the (modified) xml document to.
void | setPruneElements(boolean pruneElements) Define whether the modified Documentmust only be written to the output and pruned from the DOM4J tree.
protected javax.xml.bind.Element | unmarshal(Element element) Unmarshalls the specified DOM4J Elementinto a Element
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JAXBModifier

public JAXBModifier(String contextPath)
Creates a new JAXBModifier for the given JAXB context path. This is the Java package where JAXB can find the generated XML classes. This package MUST contain jaxb.properties!

Parameters:
contextPath - JAXB context path to be used
See Also:
JAXBContext

JAXBModifier

public JAXBModifier(String contextPath,
                    ClassLoader classloader)
Creates a new JAXBModifier for the given JAXB context path, using the given ClassLoader. This is the Java package where JAXB can find the generated XML classes. This package MUST contain jaxb.properties!

Parameters:
contextPath - JAXB context path to be used
classloader - the classloader to use
See Also:
JAXBContext

JAXBModifier

public JAXBModifier(String contextPath,
                    OutputFormat outputFormat)
Creates a new JAXBModifier for the given JAXB context path. The specified OutputFormatwill be used while writing the XML stream.

Parameters:
contextPath - JAXB context path to be used
outputFormat - the DOM4J OutputFormatto be used
See Also:
JAXBContext

JAXBModifier

public JAXBModifier(String contextPath,
                    ClassLoader classloader,
                    OutputFormat outputFormat)
Creates a new JAXBModifier for the given JAXB context path, using the specified Classloader. The specified OutputFormat will be used while writing the XML stream.

Parameters:
contextPath - JAXB context path to be used
classloader - the class loader to be used to load JAXB
outputFormat - the DOM4J OutputFormatto be used
See Also:
JAXBContext
Method Detail

modify

public Document modify(File source)
                throws DocumentException,
                       IOException
Parses the specified Filewith SAX

Parameters:
source - the file to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

modify

public Document modify(File source,
                       java.nio.charset.Charset charset)
                throws DocumentException,
                       IOException
Parses the specified Filewith SAX, using the given Charset.

Parameters:
source - the file to parse
charset - the character set to use
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

modify

public Document modify(InputSource source)
                throws DocumentException,
                       IOException
Parses the specified InputSourcewith SAX.

Parameters:
source - the input source to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

modify

public Document modify(InputStream source)
                throws DocumentException,
                       IOException
Parses the specified InputStreamwith SAX.

Parameters:
source - the inputstream to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

modify

public Document modify(InputStream source,
                       String systemId)
                throws DocumentException,
                       IOException
Parses the specified InputStreamwith SAX.

Parameters:
source - the inputstream to parse
systemId - the URI of the given inputstream
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

modify

public Document modify(Reader r)
                throws DocumentException,
                       IOException
Parses the specified Readerwith SAX.

Parameters:
r - the reader to use for parsing
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

modify

public Document modify(Reader source,
                       String systemId)
                throws DocumentException,
                       IOException
Parses the specified Readerwith SAX.

Parameters:
source - the reader to parse
systemId - the URI of the given reader
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

modify

public Document modify(String url)
                throws DocumentException,
                       IOException
Parses the the given URL or filename.

Parameters:
url - the URL or filename to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

modify

public Document modify(URL source)
                throws DocumentException,
                       IOException
Parses the the given URL.

Parameters:
source - the URL to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing
IOException - when an error occurs while writing to the XMLWriter

setOutput

public void setOutput(File file)
               throws IOException
Sets the Output to write the (modified) xml document to.

Parameters:
file - the Fileto write to
Throws:
IOException - when the file cannot be found or when the outputformat

setOutput

public void setOutput(OutputStream outputStream)
               throws IOException
Sets the Output to write the (modified) xml document to.

Parameters:
outputStream - the OutputStreamto write to
Throws:
IOException - when an error occurs

setOutput

public void setOutput(Writer writer)
               throws IOException
Sets the Output to write the (modified) xml document to.

Parameters:
writer - the Writerto write to
Throws:
IOException - when an error occurs

addObjectModifier

public void addObjectModifier(String path,
                              JAXBObjectModifier mod)
Adds the JAXBObjectModifierto be called when the specified xml path is encounted while parsing the source.

Parameters:
path - the element path to listen for
mod - the modifier to register

removeObjectModifier

public void removeObjectModifier(String path)
Removes the JAXBObjectModifierfrom the event based processor, for the specified element path.

Parameters:
path - the xml path to remove the modifier for

resetObjectModifiers

public void resetObjectModifiers()
Removes all registered JAXBObjectModifierinstances from the event based processor.

isPruneElements

public boolean isPruneElements()
Returns true when the modified Documentis not kept in memory.

Returns:
Returns true if elements are pruned.

setPruneElements

public void setPruneElements(boolean pruneElements)
Define whether the modified Documentmust only be written to the output and pruned from the DOM4J tree.

Parameters:
pruneElements - When true, elements will not be kept in memory

marshal

protected Element marshal(javax.xml.bind.Element element)
                   throws javax.xml.bind.JAXBException
Marshals the given Elementin to its DOM4J counterpart.

Parameters:
element - JAXB Element to be marshalled
Returns:
the marshalled DOM4J Element
Throws:
javax.xml.bind.JAXBException - when an error occurs

unmarshal

protected javax.xml.bind.Element unmarshal(Element element)
                                    throws javax.xml.bind.JAXBException
Unmarshalls the specified DOM4J Elementinto a Element

Parameters:
element - the DOM4J element to unmarshall
Returns:
the unmarshalled JAXB object
Throws:
javax.xml.bind.JAXBException - when an error occurs
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JAXBReader (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.jaxb
Class JAXBReader

java.lang.Object
    extended by org.dom4j.jaxb.JAXBSupport
        extended by org.dom4j.jaxb.JAXBReader
public class JAXBReader
extends org.dom4j.jaxb.JAXBSupport

Reads an XML document and creates a DOM4J tree from SAX parsing events. JAXBObjectHandlerobjects can be registered to automatically receive unmarshalled XML fragments. Registered implementations are notified when a certain element path is encountered

Author:
Wonne Keysers (Realsoftware.be)
See Also:
SAXReader, JAXBContext

Constructor Summary
JAXBReader(String contextPath)
Creates a new JAXBReader for the given JAXB context path.
JAXBReader(String contextPath, ClassLoader classloader)
Creates a new JAXBReader for the given JAXB context path, using the specified Classloader.
Method Summary
void | addHandler(String path, ElementHandler handler) Adds the ElementHandler to be called when the specified path is encounted.
void | addObjectHandler(String path, JAXBObjectHandler handler) Registers a JAXBObjectHandlerthat will be supplied with the unmarshalled representation of the xml fragment whenever the specified path is encounted.
boolean | isPruneElements() When 'true', the DOM4J document will not be kept in memory while parsing.
protected Element | marshal(javax.xml.bind.Element element) Marshals the given Elementin to its DOM4J counterpart.
Document | read(File source) Parses the specified File
Document | read(File file, java.nio.charset.Charset charset) Parses the specified File, using the given Charset.
Document | read(InputSource source) Parses the specified InputSource
Document | read(InputStream source) Parses the specified InputStream
Document | read(InputStream source, String systemId) Parses the specified InputStream
Document | read(Reader source) Parses the specified Reader
Document | read(Reader source, String systemId) Parses the specified Reader
Document | read(String source) Parses the the given URL or filename.
Document | read(URL source) Parses the the given URL.
void | removeHandler(String path) Removes the ElementHandler from the event based processor, for the specified path.
void | removeObjectHandler(String path) Removes the JAXBObjectHandlerfrom the event based processor, for the specified element path.
void | resetHandlers() Removes all registered JAXBObjectHandlerand ElementHandler instances from the event based processor.
void | setPruneElements(boolean pruneElements) Set to true when DOM4J elements must immediately be pruned from the tree.
protected javax.xml.bind.Element | unmarshal(Element element) Unmarshalls the specified DOM4J Elementinto a Element
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JAXBReader

public JAXBReader(String contextPath)
Creates a new JAXBReader for the given JAXB context path. This is the Java package where JAXB can find the generated XML classes. This package MUST contain jaxb.properties!

Parameters:
contextPath - context path to be used
See Also:
JAXBContext

JAXBReader

public JAXBReader(String contextPath,
                  ClassLoader classloader)
Creates a new JAXBReader for the given JAXB context path, using the specified Classloader. This is the Java package where JAXB can find the generated XML classes. This package MUST contain jaxb.properties!

Parameters:
contextPath - to be used
classloader - to be used
See Also:
JAXBContext
Method Detail

read

public Document read(File source)
              throws DocumentException
Parses the specified File

Parameters:
source - the file to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

read

public Document read(File file,
                     java.nio.charset.Charset charset)
              throws DocumentException
Parses the specified File, using the given Charset.

Parameters:
file - the file to parse
charset - the charset to be used
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

read

public Document read(InputSource source)
              throws DocumentException
Parses the specified InputSource

Parameters:
source - the source to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

read

public Document read(InputStream source)
              throws DocumentException
Parses the specified InputStream

Parameters:
source - the input stream to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

read

public Document read(InputStream source,
                     String systemId)
              throws DocumentException
Parses the specified InputStream

Parameters:
source - the input stream to parse
systemId - is the URI for the input
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

read

public Document read(Reader source)
              throws DocumentException
Parses the specified Reader

Parameters:
source - the input reader to use
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

read

public Document read(Reader source,
                     String systemId)
              throws DocumentException
Parses the specified Reader

Parameters:
source - the input reader to parse
systemId - is the URI for the input
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

read

public Document read(String source)
              throws DocumentException
Parses the the given URL or filename.

Parameters:
source - the location to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

read

public Document read(URL source)
              throws DocumentException
Parses the the given URL.

Parameters:
source - the URL to parse
Returns:
the resulting DOM4J document
Throws:
DocumentException - when an error occurs while parsing

addObjectHandler

public void addObjectHandler(String path,
                             JAXBObjectHandler handler)
Registers a JAXBObjectHandlerthat will be supplied with the unmarshalled representation of the xml fragment whenever the specified path is encounted.

Parameters:
path - the path to listen for
handler - the handler to be notified

removeObjectHandler

public void removeObjectHandler(String path)
Removes the JAXBObjectHandlerfrom the event based processor, for the specified element path.

Parameters:
path - The path to remove the JAXBObjectHandlerfor

addHandler

public void addHandler(String path,
                       ElementHandler handler)
Adds the ElementHandler to be called when the specified path is encounted.

Parameters:
path - is the path to be handled
handler - is the ElementHandler to be called by the event based processor.

removeHandler

public void removeHandler(String path)
Removes the ElementHandler from the event based processor, for the specified path.

Parameters:
path - is the path to remove the ElementHandler for.

resetHandlers

public void resetHandlers()
Removes all registered JAXBObjectHandlerand ElementHandler instances from the event based processor.

isPruneElements

public boolean isPruneElements()
When 'true', the DOM4J document will not be kept in memory while parsing.

Returns:
Returns the pruneElements.

setPruneElements

public void setPruneElements(boolean pruneElements)
Set to true when DOM4J elements must immediately be pruned from the tree. The Documentwill not be available afterwards!

Parameters:
pruneElements -

marshal

protected Element marshal(javax.xml.bind.Element element)
                   throws javax.xml.bind.JAXBException
Marshals the given Elementin to its DOM4J counterpart.

Parameters:
element - JAXB Element to be marshalled
Returns:
the marshalled DOM4J Element
Throws:
javax.xml.bind.JAXBException - when an error occurs

unmarshal

protected javax.xml.bind.Element unmarshal(Element element)
                                    throws javax.xml.bind.JAXBException
Unmarshalls the specified DOM4J Elementinto a Element

Parameters:
element - the DOM4J element to unmarshall
Returns:
the unmarshalled JAXB object
Throws:
javax.xml.bind.JAXBException - when an error occurs
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JAXBWriter (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.jaxb
Class JAXBWriter

java.lang.Object
    extended by org.dom4j.jaxb.JAXBSupport
        extended by org.dom4j.jaxb.JAXBWriter
public class JAXBWriter
extends org.dom4j.jaxb.JAXBSupport

Writes Elementobjects to an XML stream. Element instances can be created using the ObjectFactory that is generated by the JAXB compiler.

Author:
Wonne Keysers (Realsoftware.be)
See Also:
XMLWriter, JAXBContext

Constructor Summary
JAXBWriter(String contextPath)
Creates a new JAXBWriter for the given JAXB context path.
JAXBWriter(String contextPath, ClassLoader classloader)
Creates a new JAXBWriter for the given JAXB context path, using the specified Classloader.
JAXBWriter(String contextPath, ClassLoader classloader, OutputFormat outputFormat)
Creates a new JAXBWriter for the given JAXB context path, using the specified Classloader.
JAXBWriter(String contextPath, OutputFormat outputFormat)
Creates a new JAXBWriter for the given JAXB context path.
Method Summary
void | endDocument() Stop writing the document to the output.
OutputFormat | getOutputFormat() Returns the OutputFormat that will be used when writing the XML stream.
protected Element | marshal(javax.xml.bind.Element element) Marshals the given Elementin to its DOM4J counterpart.
void | setOutput(File file) Defines to write the resulting output to the specified File.
void | setOutput(OutputStream outputStream) Defines to write the resulting output to the specified OutputStream
void | setOutput(Writer writer) Defines to write the resulting output to the specified Writer.
void | startDocument() Start a document by writing the initial XML declaration to the output.
protected javax.xml.bind.Element | unmarshal(Element element) Unmarshalls the specified DOM4J Elementinto a Element
void | write(javax.xml.bind.Element jaxbObject) Writes the specified Elementto the document.
void | writeClose(javax.xml.bind.Element jaxbObject) Writes the closing tag of the specified Elementto the document.
void | writeCloseElement(Element element) Writes the closing tag of the specified Elementto the document.
void | writeElement(Element element) Writes the specified Elementto the document.
void | writeOpen(javax.xml.bind.Element jaxbObject) Writes the opening tag of the specified Elementto the document.
void | writeOpenElement(Element element) Writes the opening tag of the specified Elementto the document.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

JAXBWriter

public JAXBWriter(String contextPath)
Creates a new JAXBWriter for the given JAXB context path. This is the Java package where JAXB can find the generated XML classes. This package MUST contain jaxb.properties!

Parameters:
contextPath - JAXB context path to be used
See Also:
JAXBContext

JAXBWriter

public JAXBWriter(String contextPath,
                  OutputFormat outputFormat)
Creates a new JAXBWriter for the given JAXB context path. The specied OutputFormatwill be used for writing the XML stream.

Parameters:
contextPath - JAXB context path to be used
outputFormat - the DOM4J OutputFormatto be used
See Also:
JAXBContext

JAXBWriter

public JAXBWriter(String contextPath,
                  ClassLoader classloader)
Creates a new JAXBWriter for the given JAXB context path, using the specified Classloader. (This is the Java package where JAXB can find the generated XML classes. This package MUST contain jaxb.properties!)

Parameters:
contextPath - JAXB context path to be used
classloader - the classloader to be used for loading JAXB
See Also:
JAXBContext

JAXBWriter

public JAXBWriter(String contextPath,
                  ClassLoader classloader,
                  OutputFormat outputFormat)
Creates a new JAXBWriter for the given JAXB context path, using the specified Classloader. The specied OutputFormat will be used while writing the XML stream.

Parameters:
contextPath - JAXB context path to be used
classloader - the class loader to be used to load JAXB
outputFormat - the DOM4J OutputFormatto be used
See Also:
JAXBContext
Method Detail

getOutputFormat

public OutputFormat getOutputFormat()
Returns the OutputFormat that will be used when writing the XML stream.

Returns:
Returns the output format.

setOutput

public void setOutput(File file)
               throws IOException
Defines to write the resulting output to the specified File.

Parameters:
file - file to write to
Throws:
IOException - when the file cannot be found

setOutput

public void setOutput(OutputStream outputStream)
               throws IOException
Defines to write the resulting output to the specified OutputStream

Parameters:
outputStream - outputStream to write to.
Throws:
IOException - DOCUMENT ME!

setOutput

public void setOutput(Writer writer)
               throws IOException
Defines to write the resulting output to the specified Writer.

Parameters:
writer - writer to write to
Throws:
IOException

startDocument

public void startDocument()
                   throws IOException,
                          SAXException
Start a document by writing the initial XML declaration to the output. This must be done prior to writing any other elements.

Throws:
IOException - if an error occured while writing the output
SAXException - thrown by the underlying SAX driver

endDocument

public void endDocument()
                 throws IOException,
                        SAXException
Stop writing the document to the output. This must be done when all other elements are finished.

Throws:
IOException - if an error occured while writing the output
SAXException - thrown by the underlying SAX driver

write

public void write(javax.xml.bind.Element jaxbObject)
           throws IOException,
                  javax.xml.bind.JAXBException
Writes the specified Elementto the document. Elementinstances can be created using the ObjectFactory that is generated by the JAXB compiler.

Parameters:
jaxbObject -
Throws:
IOException - if an error occured while writing the output
javax.xml.bind.JAXBException - when an error occured while marshalling the jaxbObject

writeClose

public void writeClose(javax.xml.bind.Element jaxbObject)
                throws IOException,
                       javax.xml.bind.JAXBException
Writes the closing tag of the specified Elementto the document. This method can be used for writing Element instances can be created using the ObjectFactory that is generated by the JAXB compiler.

Parameters:
jaxbObject - the JAXB element to write
Throws:
IOException - if an error occured while writing the output
javax.xml.bind.JAXBException - when an error occured while marshalling the jaxbObject

writeOpen

public void writeOpen(javax.xml.bind.Element jaxbObject)
               throws IOException,
                      javax.xml.bind.JAXBException
Writes the opening tag of the specified Elementto the document. Elementinstances can be created using the ObjectFactory that is generated by the JAXB compiler.

Parameters:
jaxbObject - the JAXB element to write
Throws:
IOException - if an error occured while writing the output
javax.xml.bind.JAXBException - when an error occured while marshalling the jaxbObject

writeElement

public void writeElement(Element element)
                  throws IOException
Writes the specified Elementto the document.

Parameters:
element - the Elementto write
Throws:
IOException - if an error occured while writing the output

writeCloseElement

public void writeCloseElement(Element element)
                       throws IOException
Writes the closing tag of the specified Elementto the document.

Parameters:
element - the Elementto write
Throws:
IOException - if an error occured while writing the output

writeOpenElement

public void writeOpenElement(Element element)
                      throws IOException
Writes the opening tag of the specified Elementto the document.

Parameters:
element - the Elementto write
Throws:
IOException - if an error occured while writing the output

marshal

protected Element marshal(javax.xml.bind.Element element)
                   throws javax.xml.bind.JAXBException
Marshals the given Elementin to its DOM4J counterpart.

Parameters:
element - JAXB Element to be marshalled
Returns:
the marshalled DOM4J Element
Throws:
javax.xml.bind.JAXBException - when an error occurs

unmarshal

protected javax.xml.bind.Element unmarshal(Element element)
                                    throws javax.xml.bind.JAXBException
Unmarshalls the specified DOM4J Elementinto a Element

Parameters:
element - the DOM4J element to unmarshall
Returns:
the unmarshalled JAXB object
Throws:
javax.xml.bind.JAXBException - when an error occurs
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.rule (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.rule

A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.

See:
Description

Interface Summary
Action | Action represents some default action which should occur when a rule matches a node in the XSLT processing model.
Pattern | Pattern defines the behaviour for pattern in the XSLT processing model.

Class Summary
Mode | Mode manages a number of RuleSet instances for the mode in a stylesheet.
NullAction | NullAction represents an empty action that does nothing.
Rule | Rule matches against DOM4J Node so that some action can be performed such as in the XSLT processing model.
RuleManager | RuleManager manages a set of rules such that a rule can be found for a given DOM4J Node using the XSLT processing model.
RuleSet | RuleSet manages a set of rules which are sorted in order of relevance according to the XSLT defined conflict resolution policy.
Stylesheet | Stylesheet implements an XSLT stylesheet such that rules can be added to the stylesheet and the stylesheet can be applied to a source document or node.

Package org.dom4j.rule Description

A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches. This package can be used as a the base for a full XSLT implementation or alternatives, such as a JSP custom tag implementation of XSLT.


org.dom4j.rule Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.rule

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.rule.Mode
    • class org.dom4j.rule.NullAction (implements org.dom4j.rule.Action)
    • class org.dom4j.rule.Rule (implements java.lang.Comparable)
    • class org.dom4j.rule.RuleManager
    • class org.dom4j.rule.RuleSet
    • class org.dom4j.rule.Stylesheet

Interface Hierarchy

  • interface org.dom4j.rule.Action
  • interface org.dom4j.NodeFilter
    • interface org.dom4j.rule.Pattern


Uses of Package org.dom4j.rule (dom4j 1.6.1 API)

Uses of Package
org.dom4j.rule

Packages that use org.dom4j.rule
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.rule.pattern |
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.
org.dom4j.xpath | Provides the core tools needed to use the XPath library

Classes in org.dom4j.rule used by org.dom4j
Pattern
Pattern defines the behaviour for pattern in the XSLT processing model.

Classes in org.dom4j.rule used by org.dom4j.rule
Action
Action represents some default action which should occur when a rule matches a node in the XSLT processing model.
Mode
Mode manages a number of RuleSet instances for the mode in a stylesheet.
NullAction
NullAction represents an empty action that does nothing.
Pattern
Pattern defines the behaviour for pattern in the XSLT processing model.
Rule
Rule matches against DOM4J Node so that some action can be performed such as in the XSLT processing model.
RuleSet
RuleSet manages a set of rules which are sorted in order of relevance according to the XSLT defined conflict resolution policy.

Classes in org.dom4j.rule used by org.dom4j.rule.pattern
Pattern
Pattern defines the behaviour for pattern in the XSLT processing model.

Classes in org.dom4j.rule used by org.dom4j.tree
Pattern
Pattern defines the behaviour for pattern in the XSLT processing model.

Classes in org.dom4j.rule used by org.dom4j.util
Pattern
Pattern defines the behaviour for pattern in the XSLT processing model.

Classes in org.dom4j.rule used by org.dom4j.xpath
Pattern
Pattern defines the behaviour for pattern in the XSLT processing model.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Action (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule
Interface Action

All Known Implementing Classes:
NullAction
public interface Action

Action represents some default action which should occur when a rule matches a node in the XSLT processing model.

Version:
$Revision: 1.7 $
Author:
James Strachan

Method Summary
 void run(Node node)

Method Detail

run

public void run(Node node)
         throws Exception
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Pattern (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule
Interface Pattern

All Superinterfaces:
NodeFilter
All Known Implementing Classes:
DefaultPattern, NodeTypePattern, XPathPattern
public interface Pattern
extends NodeFilter

Pattern defines the behaviour for pattern in the XSLT processing model.

Version:
$Revision: 1.6 $
Author:
James Strachan

Field Summary
static short | ANY_NODE Matches any node
static double | DEFAULT_PRIORITY According to the spec we should return 0.5 if we cannot determine the priority
static short | NONE Matches no nodes
static short | NUMBER_OF_TYPES Count of the number of node types
Method Summary
String | getMatchesNodeName() For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches.
short | getMatchType() DOCUMENT ME!
double | getPriority() Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .
Pattern[] | getUnionPatterns() If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern.
boolean | matches(Node node) DOCUMENT ME!

Field Detail

ANY_NODE

public static final short ANY_NODE
Matches any node

See Also:
Constant Field Values

NONE

public static final short NONE
Matches no nodes

See Also:
Constant Field Values

NUMBER_OF_TYPES

public static final short NUMBER_OF_TYPES
Count of the number of node types

See Also:
Constant Field Values

DEFAULT_PRIORITY

public static final double DEFAULT_PRIORITY
According to the spec we should return 0.5 if we cannot determine the priority

See Also:
Constant Field Values
Method Detail

matches

public boolean matches(Node node)
DOCUMENT ME!

Specified by:
matches in interface NodeFilter
Parameters:
node - DOCUMENT ME!
Returns:
true if the pattern matches the given DOM4J node.

getPriority

public double getPriority()
Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .

Returns:
DOCUMENT ME!

getUnionPatterns

public Pattern[] getUnionPatterns()
If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern. Otherwise this method should return null.

Returns:
an array of the patterns which make up this union pattern or null if this pattern is not a union pattern

getMatchType

public short getMatchType()
DOCUMENT ME!

Returns:
the type of node the pattern matches which by default should return ANY_NODE if it can match any kind of node.

getMatchesNodeName

public String getMatchesNodeName()
For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches. This allows a more efficient rule matching algorithm to be performed, rather than a brute force approach of evaluating every pattern for a given Node.

Returns:
the name of the element or attribute this pattern matches or null if this pattern matches any or more than one name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Mode (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule
Class Mode

java.lang.Object
    extended by org.dom4j.rule.Mode
public class Mode
extends Object

Mode manages a number of RuleSet instances for the mode in a stylesheet. It is responsible for finding the correct rule for a given DOM4J Node using the XSLT processing model uses the smallest possible RuleSet to reduce the number of Rule evaluations.

Version:
$Revision: 1.9 $
Author:
James Strachan

Constructor Summary
Mode()
Method Summary
void | addRule(Rule rule)
protected Map | addToNameMap(Map map, String name, Rule rule) Adds the Rule to a RuleSet for the given name.
void | applyTemplates(Document document)
void | applyTemplates(Element element)
void | fireRule(Node node) Runs the actions associated with the given node
Rule | getMatchingRule(Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.
protected RuleSet | getRuleSet(int matchType) DOCUMENT ME!
protected void | removeFromNameMap(Map map, String name, Rule rule)
void | removeRule(Rule rule)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Mode

public Mode()
Method Detail

fireRule

public void fireRule(Node node)
              throws Exception
Runs the actions associated with the given node

Parameters:
node - DOCUMENT ME!
Throws:
Exception - DOCUMENT ME!

applyTemplates

public void applyTemplates(Element element)
                    throws Exception
Throws:
Exception

applyTemplates

public void applyTemplates(Document document)
                    throws Exception
Throws:
Exception

addRule

public void addRule(Rule rule)

removeRule

public void removeRule(Rule rule)

getMatchingRule

public Rule getMatchingRule(Node node)
Performs an XSLT processing model match for the rule which matches the given Node the best.

Parameters:
node - is the DOM4J Node to match against
Returns:
the matching Rule or no rule if none matched

getRuleSet

protected RuleSet getRuleSet(int matchType)
DOCUMENT ME!

Parameters:
matchType - DOCUMENT ME!
Returns:
the RuleSet for the given matching type. This method will never return null, a new instance will be created.

addToNameMap

protected Map addToNameMap(Map map,
                           String name,
                           Rule rule)
Adds the Rule to a RuleSet for the given name.

Parameters:
map - DOCUMENT ME!
name - DOCUMENT ME!
rule - DOCUMENT ME!
Returns:
the Map (which will be created if the given map was null

removeFromNameMap

protected void removeFromNameMap(Map map,
                                 String name,
                                 Rule rule)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NullAction (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule
Class NullAction

java.lang.Object
    extended by org.dom4j.rule.NullAction
All Implemented Interfaces:
Action
public class NullAction
extends Object
implements Action

NullAction represents an empty action that does nothing.

Version:
$Revision: 1.7 $
Author:
James Strachan

Field Summary
static NullAction SINGLETON
Singleton instance
Constructor Summary
NullAction()
Method Summary
 void run(Node node)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

SINGLETON

public static final NullAction SINGLETON
Singleton instance

Constructor Detail

NullAction

public NullAction()
Method Detail

run

public void run(Node node)
         throws Exception
Specified by:
run in interface Action
Throws:
Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Rule (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule
Class Rule

java.lang.Object
    extended by org.dom4j.rule.Rule
All Implemented Interfaces:
Comparable
public class Rule
extends Object
implements Comparable

Rule matches against DOM4J Node so that some action can be performed such as in the XSLT processing model.

Version:
$Revision: 1.7 $
Author:
James Strachan

Constructor Summary
Rule()
Rule(Pattern pattern)
Rule(Pattern pattern, Action action)
Rule(Rule that, Pattern pattern)
Constructs a new Rule with the same instance data as the given rule but a different pattern.
Method Summary
int | compareTo(Object that)
int | compareTo(Rule that) Compares two rules in XSLT processing model order assuming that the modes are equal.
boolean | equals(Object that)
Action | getAction() Getter for property action.
int | getAppearenceCount() Getter for property appearenceCount.
int | getImportPrecedence() Getter for property importPrecedence.
String | getMatchesNodeName() For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches.
short | getMatchType() DOCUMENT ME!
String | getMode() Getter for property mode.
Pattern | getPattern() Getter for property pattern.
double | getPriority() Getter for property priority.
Rule[] | getUnionRules() If this rule contains a union pattern then this method should return an array of Rules which describe the union rule, which should contain more than one rule.
int | hashCode()
boolean | matches(Node node) DOCUMENT ME!
void | setAction(Action action) Setter for property action.
void | setAppearenceCount(int appearenceCount) Setter for property appearenceCount.
void | setImportPrecedence(int importPrecedence) Setter for property importPrecedence.
void | setMode(String mode) Setter for property mode.
void | setPattern(Pattern pattern) Setter for property pattern.
void | setPriority(double priority) Setter for property priority.
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

Rule

public Rule()

Rule

public Rule(Pattern pattern)

Rule

public Rule(Pattern pattern,
            Action action)

Rule

public Rule(Rule that,
            Pattern pattern)
Constructs a new Rule with the same instance data as the given rule but a different pattern.

Parameters:
that - DOCUMENT ME!
pattern - DOCUMENT ME!
Method Detail

equals

public boolean equals(Object that)

hashCode

public int hashCode()

compareTo

public int compareTo(Object that)
Specified by:
compareTo in interface Comparable

compareTo

public int compareTo(Rule that)
Compares two rules in XSLT processing model order assuming that the modes are equal.

Parameters:
that - DOCUMENT ME!
Returns:
DOCUMENT ME!

toString

public String toString()

matches

public final boolean matches(Node node)
DOCUMENT ME!

Parameters:
node - DOCUMENT ME!
Returns:
true if the pattern matches the given DOM4J node.

getUnionRules

public Rule[] getUnionRules()
If this rule contains a union pattern then this method should return an array of Rules which describe the union rule, which should contain more than one rule. Otherwise this method should return null.

Returns:
an array of the rules which make up this union rule or null if this rule is not a union rule

getMatchType

public final short getMatchType()
DOCUMENT ME!

Returns:
the type of node the pattern matches which by default should return ANY_NODE if it can match any kind of node.

getMatchesNodeName

public final String getMatchesNodeName()
For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches. This allows a more efficient rule matching algorithm to be performed, rather than a brute force approach of evaluating every pattern for a given Node.

Returns:
the name of the element or attribute this pattern matches or null if this pattern matches any or more than one name.

getMode

public String getMode()
Getter for property mode.

Returns:
Value of property mode.

setMode

public void setMode(String mode)
Setter for property mode.

Parameters:
mode - New value of property mode.

getImportPrecedence

public int getImportPrecedence()
Getter for property importPrecedence.

Returns:
Value of property importPrecedence.

setImportPrecedence

public void setImportPrecedence(int importPrecedence)
Setter for property importPrecedence.

Parameters:
importPrecedence - New value of property importPrecedence.

getPriority

public double getPriority()
Getter for property priority.

Returns:
Value of property priority.

setPriority

public void setPriority(double priority)
Setter for property priority.

Parameters:
priority - New value of property priority.

getAppearenceCount

public int getAppearenceCount()
Getter for property appearenceCount.

Returns:
Value of property appearenceCount.

setAppearenceCount

public void setAppearenceCount(int appearenceCount)
Setter for property appearenceCount.

Parameters:
appearenceCount - New value of property appearenceCount.

getPattern

public Pattern getPattern()
Getter for property pattern.

Returns:
Value of property pattern.

setPattern

public void setPattern(Pattern pattern)
Setter for property pattern.

Parameters:
pattern - New value of property pattern.

getAction

public Action getAction()
Getter for property action.

Returns:
Value of property action.

setAction

public void setAction(Action action)
Setter for property action.

Parameters:
action - New value of property action.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RuleManager (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule
Class RuleManager

java.lang.Object
    extended by org.dom4j.rule.RuleManager
public class RuleManager
extends Object

RuleManager manages a set of rules such that a rule can be found for a given DOM4J Node using the XSLT processing model.

Version:
$Revision: 1.9 $
Author:
James Strachan

Constructor Summary
RuleManager()
Method Summary
protected void | addDefaultRule(Mode mode, Pattern pattern, Action action)
protected void | addDefaultRules(Mode mode) Adds the default stylesheet rules to the given Modeinstance
void | addRule(Rule rule)
void | clear()
protected Rule | createDefaultRule(Pattern pattern, Action action)
protected Mode | createMode() A factory method to return a new Modeinstance which should add the necessary default rules
Rule | getMatchingRule(String modeName, Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.
Mode | getMode(String modeName) DOCUMENT ME!
Action | getValueOfAction() DOCUMENT ME!
void | removeRule(Rule rule)
void | setValueOfAction(Action valueOfAction) Sets the default value-of action which is used in the default rules for the pattern "text()|@"
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RuleManager

public RuleManager()
Method Detail

getMode

public Mode getMode(String modeName)
DOCUMENT ME!

Parameters:
modeName - DOCUMENT ME!
Returns:
the Mode instance for the given mode name. If one does not exist then it will be created.

addRule

public void addRule(Rule rule)

removeRule

public void removeRule(Rule rule)

getMatchingRule

public Rule getMatchingRule(String modeName,
                            Node node)
Performs an XSLT processing model match for the rule which matches the given Node the best.

Parameters:
modeName - is the name of the mode associated with the rule if any
node - is the DOM4J Node to match against
Returns:
the matching Rule or no rule if none matched

clear

public void clear()

getValueOfAction

public Action getValueOfAction()
DOCUMENT ME!

Returns:
the default value-of action which is used in the default rules for the pattern "text()|@"

setValueOfAction

public void setValueOfAction(Action valueOfAction)
Sets the default value-of action which is used in the default rules for the pattern "text()|@"

Parameters:
valueOfAction - DOCUMENT ME!

createMode

protected Mode createMode()
A factory method to return a new Modeinstance which should add the necessary default rules

Returns:
DOCUMENT ME!

addDefaultRules

protected void addDefaultRules(Mode mode)
Adds the default stylesheet rules to the given Modeinstance

Parameters:
mode - DOCUMENT ME!

addDefaultRule

protected void addDefaultRule(Mode mode,
                              Pattern pattern,
                              Action action)

createDefaultRule

protected Rule createDefaultRule(Pattern pattern,
                                 Action action)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RuleSet (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule
Class RuleSet

java.lang.Object
    extended by org.dom4j.rule.RuleSet
public class RuleSet
extends Object

RuleSet manages a set of rules which are sorted in order of relevance according to the XSLT defined conflict resolution policy. This makes finding the correct rule for a DOM4J Node using the XSLT processing model efficient as the rules can be evaluated in order of priority.

Version:
$Revision: 1.10 $
Author:
James Strachan

Constructor Summary
RuleSet()
Method Summary
void | addAll(RuleSet that) Adds all the rules to this RuleSet from the given other rule set.
void | addRule(Rule rule)
Rule | getMatchingRule(Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.
protected Rule[] | getRuleArray() Returns an array of sorted rules.
void | removeRule(Rule rule)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

RuleSet

public RuleSet()
Method Detail

toString

public String toString()

getMatchingRule

public Rule getMatchingRule(Node node)
Performs an XSLT processing model match for the rule which matches the given Node the best.

Parameters:
node - is the DOM4J Node to match against
Returns:
the matching Rule or no rule if none matched

addRule

public void addRule(Rule rule)

removeRule

public void removeRule(Rule rule)

addAll

public void addAll(RuleSet that)
Adds all the rules to this RuleSet from the given other rule set.

Parameters:
that - DOCUMENT ME!

getRuleArray

protected Rule[] getRuleArray()
Returns an array of sorted rules.

Returns:
the rules as a sorted array in ascending precendence so that the rules at the end of the array should be used first
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Stylesheet (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule
Class Stylesheet

java.lang.Object
    extended by org.dom4j.rule.Stylesheet
public class Stylesheet
extends Object

Stylesheet implements an XSLT stylesheet such that rules can be added to the stylesheet and the stylesheet can be applied to a source document or node.

Version:
$Revision: 1.14 $
Author:
James Strachan

Constructor Summary
Stylesheet()
Creates a new empty stylesheet.
Method Summary
 void addRule(Rule rule)
Add a rule to this stylesheet.
 void applyTemplates(Object input)
If input is a Node, this will processes all of the children of that node.
 void applyTemplates(Object input, String mode)
Processes the input object in the given mode.
 void applyTemplates(Object input, XPath xpath)
Processes the result of the xpath expression.
 void applyTemplates(Object input, org.jaxen.XPath xpath)
Deprecated. Use applyTemplates(Object, XPath)instead.
 void applyTemplates(Object input, XPath xpath, String mode)
Processes the result of the xpath expression in the given mode.
 void applyTemplates(Object input, org.jaxen.XPath xpath, String mode)
Deprecated. Use applyTemplates(Object, XPath, String) instead.
 void clear()
 String getModeName()
DOCUMENT ME!
 Action getValueOfAction()
DOCUMENT ME!
 void removeRule(Rule rule)
Removes the specified rule from this stylesheet.
 void run(List list)
 void run(List list, String mode)
 void run(Node node)
 void run(Node node, String mode)
 void run(Object input)
Runs this stylesheet on the given input which should be either a Node or a List of Node objects.
 void run(Object input, String mode)
 void setModeName(String modeName)
Sets the name of the mode that the stylesheet uses by default.
 void setValueOfAction(Action valueOfAction)
Sets the default value-of action which is used in the default rules for the pattern "text()|@"
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Stylesheet

public Stylesheet()
Creates a new empty stylesheet.

Method Detail

addRule

public void addRule(Rule rule)
Add a rule to this stylesheet.

Parameters:
rule - the rule to add

removeRule

public void removeRule(Rule rule)
Removes the specified rule from this stylesheet.

Parameters:
rule - the rule to remove

run

public void run(Object input)
         throws Exception
Runs this stylesheet on the given input which should be either a Node or a List of Node objects.

Parameters:
input - the input to run this stylesheet on
Throws:
Exception - if something goes wrong

run

public void run(Object input,
                String mode)
         throws Exception
Throws:
Exception

run

public void run(List list)
         throws Exception
Throws:
Exception

run

public void run(List list,
                String mode)
         throws Exception
Throws:
Exception

run

public void run(Node node)
         throws Exception
Throws:
Exception

run

public void run(Node node,
                String mode)
         throws Exception
Throws:
Exception

applyTemplates

public void applyTemplates(Object input,
                           XPath xpath)
                    throws Exception
Processes the result of the xpath expression. The xpath expression is evaluated against the provided input object.

Parameters:
input - the input object
xpath - the xpath expression
Throws:
Exception - if something goes wrong

applyTemplates

public void applyTemplates(Object input,
                           XPath xpath,
                           String mode)
                    throws Exception
Processes the result of the xpath expression in the given mode. The xpath expression is evaluated against the provided input object.

Parameters:
input - the input object
xpath - the xpath expression
mode - the mode
Throws:
Exception - if something goes wrong

applyTemplates

public void applyTemplates(Object input,
                           org.jaxen.XPath xpath)
                    throws Exception
Deprecated. Use applyTemplates(Object, XPath)instead.

Processes the result of the xpath expression. The xpath expression is evaluated against the provided input object.

Parameters:
input - the input object
xpath - the xpath expression
Throws:
Exception - if something goes wrong

applyTemplates

public void applyTemplates(Object input,
                           org.jaxen.XPath xpath,
                           String mode)
                    throws Exception
Deprecated. Use applyTemplates(Object, XPath, String) instead.

Processes the result of the xpath expression in the given mode. The xpath expression is evaluated against the provided input object.

Parameters:
input - the input object
xpath - the xpath expression
mode - the mode
Throws:
Exception - if something goes wrong

applyTemplates

public void applyTemplates(Object input)
                    throws Exception
If input is a Node, this will processes all of the children of that node. If input is a List of Nodess, these nodes will be iterated and all children of each node will be processed.

Parameters:
input - the input object, this can either be a Node or a List
Throws:
Exception - if something goes wrong

applyTemplates

public void applyTemplates(Object input,
                           String mode)
                    throws Exception
Processes the input object in the given mode. If input is a Node, this will processes all of the children of that node. If input is a List of Nodess, these nodes will be iterated and all children of each node will be processed.

Parameters:
input - the input object, this can either be a Node or a List
mode - the mode
Throws:
Exception - if something goes wrong

clear

public void clear()

getModeName

public String getModeName()
DOCUMENT ME!

Returns:
the name of the mode the stylesheet uses by default

setModeName

public void setModeName(String modeName)
Sets the name of the mode that the stylesheet uses by default.

Parameters:
modeName - DOCUMENT ME!

getValueOfAction

public Action getValueOfAction()
DOCUMENT ME!

Returns:
the default value-of action which is used in the default rules for the pattern "text()|@"

setValueOfAction

public void setValueOfAction(Action valueOfAction)
Sets the default value-of action which is used in the default rules for the pattern "text()|@"

Parameters:
valueOfAction - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.rule.pattern (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.rule.pattern

Class Summary
DefaultPattern | DefaultPattern a default implementation of Pattern which can take any XPath implementation or NodeFilter for defining the pattern.
NodeTypePattern | NodeTypePattern implements a Pattern which matches any node of the given node type.


org.dom4j.rule.pattern Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.rule.pattern

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.rule.pattern.DefaultPattern (implements org.dom4j.rule.Pattern)
    • class org.dom4j.rule.pattern.NodeTypePattern (implements org.dom4j.rule.Pattern)


Uses of Package org.dom4j.rule.pattern (dom4j 1.6.1 API)

Uses of Package
org.dom4j.rule.pattern

Packages that use org.dom4j.rule.pattern
org.dom4j.rule.pattern

Classes in org.dom4j.rule.pattern used by org.dom4j.rule.pattern
NodeTypePattern
NodeTypePattern implements a Pattern which matches any node of the given node type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DefaultPattern (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule.pattern
Class DefaultPattern

java.lang.Object
    extended by org.dom4j.rule.pattern.DefaultPattern
All Implemented Interfaces:
NodeFilter, Pattern
public class DefaultPattern
extends Object
implements Pattern

DefaultPattern a default implementation of Pattern which can take any XPath implementation or NodeFilter for defining the pattern. WARNING this implementation causes a worst case, brute force XSLT rule evaluation to be performed. Wherever possible the methods getPriority(), getMatchType()and getMatchesNodeName()should be overloaded to allow more rule filtering to occur.

Version:
$Revision: 1.6 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.rule.Pattern
ANY_NODE, DEFAULT_PRIORITY, NONE, NUMBER_OF_TYPES
Constructor Summary
DefaultPattern(NodeFilter filter)
Method Summary
String | getMatchesNodeName() For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches.
short | getMatchType() DOCUMENT ME!
double | getPriority() Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .
Pattern[] | getUnionPatterns() If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern.
boolean | matches(Node node) DOCUMENT ME!
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultPattern

public DefaultPattern(NodeFilter filter)
Method Detail

matches

public boolean matches(Node node)
Description copied from interface: Pattern
DOCUMENT ME!

Specified by:
matches in interface Pattern
Parameters:
node - DOCUMENT ME!
Returns:
true if the pattern matches the given DOM4J node.

getPriority

public double getPriority()
Description copied from interface: Pattern
Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .

Specified by:
getPriority in interface Pattern
Returns:
DOCUMENT ME!

getUnionPatterns

public Pattern[] getUnionPatterns()
Description copied from interface: Pattern
If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern. Otherwise this method should return null.

Specified by:
getUnionPatterns in interface Pattern
Returns:
an array of the patterns which make up this union pattern or null if this pattern is not a union pattern

getMatchType

public short getMatchType()
Description copied from interface: Pattern
DOCUMENT ME!

Specified by:
getMatchType in interface Pattern
Returns:
the type of node the pattern matches which by default should return ANY_NODE if it can match any kind of node.

getMatchesNodeName

public String getMatchesNodeName()
Description copied from interface: Pattern
For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches. This allows a more efficient rule matching algorithm to be performed, rather than a brute force approach of evaluating every pattern for a given Node.

Specified by:
getMatchesNodeName in interface Pattern
Returns:
the name of the element or attribute this pattern matches or null if this pattern matches any or more than one name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


NodeTypePattern (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.rule.pattern
Class NodeTypePattern

java.lang.Object
    extended by org.dom4j.rule.pattern.NodeTypePattern
All Implemented Interfaces:
NodeFilter, Pattern
public class NodeTypePattern
extends Object
implements Pattern

NodeTypePattern implements a Pattern which matches any node of the given node type.

Version:
$Revision: 1.7 $
Author:
James Strachan

Field Summary
static NodeTypePattern | ANY_ATTRIBUTE A pattern which matches any Attribute node
static NodeTypePattern | ANY_COMMENT A pattern which matches any Comment node
static NodeTypePattern | ANY_DOCUMENT A pattern which matches any Document node
static NodeTypePattern | ANY_ELEMENT A pattern which matches any Element node
static NodeTypePattern | ANY_PROCESSING_INSTRUCTION A pattern which matches any ProcessingInstruction node
static NodeTypePattern | ANY_TEXT A pattern which matches any Text node
Fields inherited from interface org.dom4j.rule.Pattern
ANY_NODE, DEFAULT_PRIORITY, NONE, NUMBER_OF_TYPES
Constructor Summary
NodeTypePattern(short nodeType)
Method Summary
String | getMatchesNodeName() For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches.
short | getMatchType() DOCUMENT ME!
double | getPriority() Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .
Pattern[] | getUnionPatterns() If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern.
boolean | matches(Node node) DOCUMENT ME!
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ANY_ATTRIBUTE

public static final NodeTypePattern ANY_ATTRIBUTE
A pattern which matches any Attribute node

ANY_COMMENT

public static final NodeTypePattern ANY_COMMENT
A pattern which matches any Comment node

ANY_DOCUMENT

public static final NodeTypePattern ANY_DOCUMENT
A pattern which matches any Document node

ANY_ELEMENT

public static final NodeTypePattern ANY_ELEMENT
A pattern which matches any Element node

ANY_PROCESSING_INSTRUCTION

public static final NodeTypePattern ANY_PROCESSING_INSTRUCTION
A pattern which matches any ProcessingInstruction node

ANY_TEXT

public static final NodeTypePattern ANY_TEXT
A pattern which matches any Text node

Constructor Detail

NodeTypePattern

public NodeTypePattern(short nodeType)
Method Detail

matches

public boolean matches(Node node)
Description copied from interface: Pattern
DOCUMENT ME!

Specified by:
matches in interface Pattern
Parameters:
node - DOCUMENT ME!
Returns:
true if the pattern matches the given DOM4J node.

getPriority

public double getPriority()
Description copied from interface: Pattern
Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .

Specified by:
getPriority in interface Pattern
Returns:
DOCUMENT ME!

getUnionPatterns

public Pattern[] getUnionPatterns()
Description copied from interface: Pattern
If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern. Otherwise this method should return null.

Specified by:
getUnionPatterns in interface Pattern
Returns:
an array of the patterns which make up this union pattern or null if this pattern is not a union pattern

getMatchType

public short getMatchType()
Description copied from interface: Pattern
DOCUMENT ME!

Specified by:
getMatchType in interface Pattern
Returns:
the type of node the pattern matches which by default should return ANY_NODE if it can match any kind of node.

getMatchesNodeName

public String getMatchesNodeName()
Description copied from interface: Pattern
For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches. This allows a more efficient rule matching algorithm to be performed, rather than a brute force approach of evaluating every pattern for a given Node.

Specified by:
getMatchesNodeName in interface Pattern
Returns:
the name of the element or attribute this pattern matches or null if this pattern matches any or more than one name.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.swing (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.swing

A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.

See:
Description

Class Summary
BranchTreeNode | BranchTreeNode implements the Swing TreeNode interface to bind dom4j XML Branch nodes (i.e.
DocumentTreeModel | DocumentTreeModel implements a Swing TreeModel for a dom4j XML Document.
LeafTreeNode | LeafTreeNode implements the Swing TreeNode interface to bind a leaf XML nodes to a Swing TreeModel.
XMLTableColumnDefinition | XMLTableColumnDefinition a column within a table definition.
XMLTableDefinition | XMLTableDefinition represents a table definition based on XPath expression evaluated on an XML document.
XMLTableModel | XMLTableDefinition repro.

Package org.dom4j.swing Description

A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.


org.dom4j.swing Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.swing

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • class org.dom4j.swing.XMLTableModel
    • class javax.swing.tree.DefaultTreeModel (implements java.io.Serializable, javax.swing.tree.TreeModel)
      • class org.dom4j.swing.DocumentTreeModel
    • class org.dom4j.swing.LeafTreeNode (implements javax.swing.tree.TreeNode)
      • class org.dom4j.swing.BranchTreeNode
    • class org.dom4j.swing.XMLTableColumnDefinition (implements java.io.Serializable)
    • class org.dom4j.swing.XMLTableDefinition (implements java.io.Serializable, org.jaxen.VariableContext)


Uses of Package org.dom4j.swing (dom4j 1.6.1 API)

Uses of Package
org.dom4j.swing

Packages that use org.dom4j.swing
org.dom4j.swing A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.

Classes in org.dom4j.swing used by org.dom4j.swing
LeafTreeNode
LeafTreeNode implements the Swing TreeNode interface to bind a leaf XML nodes to a Swing TreeModel.
XMLTableColumnDefinition
XMLTableColumnDefinition a column within a table definition.
XMLTableDefinition
XMLTableDefinition represents a table definition based on XPath expression evaluated on an XML document.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


BranchTreeNode (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.swing
Class BranchTreeNode

java.lang.Object
    extended by org.dom4j.swing.LeafTreeNode
        extended by org.dom4j.swing.BranchTreeNode
All Implemented Interfaces:
TreeNode
public class BranchTreeNode
extends LeafTreeNode

BranchTreeNode implements the Swing TreeNode interface to bind dom4j XML Branch nodes (i.e. Document and Element nodes) to a Swing TreeModel.

Version:
$Revision: 1.10 $
Author:
James Strachan , Jakob Jenkov

Field Summary
protected  List children
Stores the child tree nodes
Fields inherited from class org.dom4j.swing.LeafTreeNode
EMPTY_ENUMERATION, xmlNode
Constructor Summary
BranchTreeNode()
BranchTreeNode(Branch xmlNode)
BranchTreeNode(TreeNode parent, Branch xmlNode)
Method Summary
Enumeration | children()
protected List | createChildList() Factory method to create List of children TreeNodes
protected TreeNode | createChildTreeNode(Node xmlNode) Factory method to create child tree nodes for a given XML node type
boolean | getAllowsChildren()
TreeNode | getChildAt(int childIndex)
int | getChildCount()
protected List | getChildList() Uses Lazy Initialization pattern to create a List of children
int | getIndex(TreeNode node)
protected Branch | getXmlBranch()
boolean | isLeaf()
String | toString()
Methods inherited from class org.dom4j.swing.LeafTreeNode
getParent, getXmlNode, setParent
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

children

protected List children
Stores the child tree nodes

Constructor Detail

BranchTreeNode

public BranchTreeNode()

BranchTreeNode

public BranchTreeNode(Branch xmlNode)

BranchTreeNode

public BranchTreeNode(TreeNode parent,
                      Branch xmlNode)
Method Detail

children

public Enumeration children()
Specified by:
children in interface TreeNode
Overrides:
children in class LeafTreeNode

getAllowsChildren

public boolean getAllowsChildren()
Specified by:
getAllowsChildren in interface TreeNode
Overrides:
getAllowsChildren in class LeafTreeNode

getChildAt

public TreeNode getChildAt(int childIndex)
Specified by:
getChildAt in interface TreeNode
Overrides:
getChildAt in class LeafTreeNode

getChildCount

public int getChildCount()
Specified by:
getChildCount in interface TreeNode
Overrides:
getChildCount in class LeafTreeNode

getIndex

public int getIndex(TreeNode node)
Specified by:
getIndex in interface TreeNode
Overrides:
getIndex in class LeafTreeNode

isLeaf

public boolean isLeaf()
Specified by:
isLeaf in interface TreeNode
Overrides:
isLeaf in class LeafTreeNode

toString

public String toString()
Overrides:
toString in class LeafTreeNode

getChildList

protected List getChildList()
Uses Lazy Initialization pattern to create a List of children

Returns:
DOCUMENT ME!

createChildList

protected List createChildList()
Factory method to create List of children TreeNodes

Returns:
DOCUMENT ME!

createChildTreeNode

protected TreeNode createChildTreeNode(Node xmlNode)
Factory method to create child tree nodes for a given XML node type

Parameters:
xmlNode - DOCUMENT ME!
Returns:
DOCUMENT ME!

getXmlBranch

protected Branch getXmlBranch()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DocumentTreeModel (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.swing
Class DocumentTreeModel

java.lang.Object
    extended by javax.swing.tree.DefaultTreeModel
        extended by org.dom4j.swing.DocumentTreeModel
All Implemented Interfaces:
Serializable, TreeModel
public class DocumentTreeModel
extends DefaultTreeModel

DocumentTreeModel implements a Swing TreeModel for a dom4j XML Document.

Version:
$Revision: 1.7 $
Author:
James Strachan , Jakob Jenkov
See Also:
Serialized Form

Field Summary
protected  Document document
The document for this model
Fields inherited from class javax.swing.tree.DefaultTreeModel
asksAllowsChildren, listenerList, root
Constructor Summary
DocumentTreeModel(Document document)
Method Summary
Document | getDocument() DOCUMENT ME!
void | setDocument(Document document) Sets the Document instance that this TreeModel is based on
Methods inherited from class javax.swing.tree.DefaultTreeModel
addTreeModelListener, asksAllowsChildren, fireTreeNodesChanged, fireTreeNodesInserted, fireTreeNodesRemoved, fireTreeStructureChanged, getChild, getChildCount, getIndexOfChild, getListeners, getPathToRoot, getPathToRoot, getRoot, getTreeModelListeners, insertNodeInto, isLeaf, nodeChanged, nodesChanged, nodeStructureChanged, nodesWereInserted, nodesWereRemoved, reload, reload, removeNodeFromParent, removeTreeModelListener, setAsksAllowsChildren, setRoot, valueForPathChanged
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

document

protected Document document
The document for this model

Constructor Detail

DocumentTreeModel

public DocumentTreeModel(Document document)
Method Detail

getDocument

public Document getDocument()
DOCUMENT ME!

Returns:
the Document instance that this TreeModel is based on

setDocument

public void setDocument(Document document)
Sets the Document instance that this TreeModel is based on

Parameters:
document - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


LeafTreeNode (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.swing
Class LeafTreeNode

java.lang.Object
    extended by org.dom4j.swing.LeafTreeNode
All Implemented Interfaces:
TreeNode
Direct Known Subclasses:
BranchTreeNode
public class LeafTreeNode
extends Object
implements TreeNode

LeafTreeNode implements the Swing TreeNode interface to bind a leaf XML nodes to a Swing TreeModel.

Version:
$Revision: 1.7 $
Author:
James Strachan , Jakob Jenkov

Field Summary
protected static Enumeration | EMPTY_ENUMERATION
protected Node | xmlNode The dom4j Node which contains the
Constructor Summary
LeafTreeNode()
LeafTreeNode(Node xmlNode)
LeafTreeNode(TreeNode parent, Node xmlNode)
Method Summary
Enumeration | children()
boolean | getAllowsChildren()
TreeNode | getChildAt(int childIndex)
int | getChildCount()
int | getIndex(TreeNode node)
TreeNode | getParent()
Node | getXmlNode()
boolean | isLeaf()
void | setParent(LeafTreeNode parent) Sets the parent of this node but doesn't change the parents children
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Field Detail

EMPTY_ENUMERATION

protected static final Enumeration EMPTY_ENUMERATION

xmlNode

protected Node xmlNode
The dom4j Node which contains the

Constructor Detail

LeafTreeNode

public LeafTreeNode()

LeafTreeNode

public LeafTreeNode(Node xmlNode)

LeafTreeNode

public LeafTreeNode(TreeNode parent,
                    Node xmlNode)
Method Detail

children

public Enumeration children()
Specified by:
children in interface TreeNode

getAllowsChildren

public boolean getAllowsChildren()
Specified by:
getAllowsChildren in interface TreeNode

getChildAt

public TreeNode getChildAt(int childIndex)
Specified by:
getChildAt in interface TreeNode

getChildCount

public int getChildCount()
Specified by:
getChildCount in interface TreeNode

getIndex

public int getIndex(TreeNode node)
Specified by:
getIndex in interface TreeNode

getParent

public TreeNode getParent()
Specified by:
getParent in interface TreeNode

isLeaf

public boolean isLeaf()
Specified by:
isLeaf in interface TreeNode

toString

public String toString()

setParent

public void setParent(LeafTreeNode parent)
Sets the parent of this node but doesn't change the parents children

Parameters:
parent - DOCUMENT ME!

getXmlNode

public Node getXmlNode()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XMLTableColumnDefinition (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.swing
Class XMLTableColumnDefinition

java.lang.Object
    extended by org.dom4j.swing.XMLTableColumnDefinition
All Implemented Interfaces:
Serializable
public class XMLTableColumnDefinition
extends Object
implements Serializable

XMLTableColumnDefinition a column within a table definition.

Version:
$Revision: 1.10 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
static int | NODE_TYPE
static int | NUMBER_TYPE
static int | OBJECT_TYPE
static int | STRING_TYPE
Constructor Summary
XMLTableColumnDefinition()
XMLTableColumnDefinition(String name, String expression, int type)
XMLTableColumnDefinition(String name, XPath xpath, int type)
XMLTableColumnDefinition(XPath columnXPath, XPath xpath, int type)
Method Summary
protected XPath | createXPath(String expression)
Class | getColumnClass()
XPath | getColumnNameXPath() DOCUMENT ME!
String | getName() Getter for property name.
int | getType() Getter for property type.
Object | getValue(Object row)
XPath | getXPath() Getter for property xpath.
protected void | handleException(Exception e)
static int | parseType(String typeName)
void | setColumnNameXPath(XPath columnNameXPath) Setter for property columnNameXPath.
void | setName(String name) Setter for property name.
void | setType(int type) Setter for property type.
void | setXPath(XPath xPath) Setter for property xpath.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

OBJECT_TYPE

public static final int OBJECT_TYPE
See Also:
Constant Field Values

STRING_TYPE

public static final int STRING_TYPE
See Also:
Constant Field Values

NUMBER_TYPE

public static final int NUMBER_TYPE
See Also:
Constant Field Values

NODE_TYPE

public static final int NODE_TYPE
See Also:
Constant Field Values
Constructor Detail

XMLTableColumnDefinition

public XMLTableColumnDefinition()

XMLTableColumnDefinition

public XMLTableColumnDefinition(String name,
                                String expression,
                                int type)

XMLTableColumnDefinition

public XMLTableColumnDefinition(String name,
                                XPath xpath,
                                int type)

XMLTableColumnDefinition

public XMLTableColumnDefinition(XPath columnXPath,
                                XPath xpath,
                                int type)
Method Detail

parseType

public static int parseType(String typeName)

getColumnClass

public Class getColumnClass()

getValue

public Object getValue(Object row)

getType

public int getType()
Getter for property type.

Returns:
Value of property type.

setType

public void setType(int type)
Setter for property type.

Parameters:
type - New value of property type.

getName

public String getName()
Getter for property name.

Returns:
Value of property name.

setName

public void setName(String name)
Setter for property name.

Parameters:
name - New value of property name.

getXPath

public XPath getXPath()
Getter for property xpath.

Returns:
Value of property xpath.

setXPath

public void setXPath(XPath xPath)
Setter for property xpath.

Parameters:
xPath - New value of property xpath.

getColumnNameXPath

public XPath getColumnNameXPath()
DOCUMENT ME!

Returns:
the XPath used to create the column name

setColumnNameXPath

public void setColumnNameXPath(XPath columnNameXPath)
Setter for property columnNameXPath.

Parameters:
columnNameXPath - New value of property xpath.

createXPath

protected XPath createXPath(String expression)

handleException

protected void handleException(Exception e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XMLTableDefinition (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.swing
Class XMLTableDefinition

java.lang.Object
    extended by org.dom4j.swing.XMLTableDefinition
All Implemented Interfaces:
Serializable, org.jaxen.VariableContext
public class XMLTableDefinition
extends Object
implements Serializable, org.jaxen.VariableContext

XMLTableDefinition represents a table definition based on XPath expression evaluated on an XML document.

Version:
$Revision: 1.8 $
Author:
James Strachan
See Also:
Serialized Form

Constructor Summary
XMLTableDefinition()
Method Summary
void | addColumn(String name, String expression)
void | addColumn(String name, String expression, int type)
void | addColumn(XMLTableColumnDefinition column)
void | addColumnWithXPathName(String columnNameXPathExpression, String expression, int type)
void | addNumberColumn(String name, String expression)
void | addStringColumn(String name, String expression)
void | clear()
protected void | clearCaches()
protected XPath | createColumnXPath(String expression)
protected XPath | createXPath(String expression)
XMLTableColumnDefinition | getColumn(int index)
XMLTableColumnDefinition | getColumn(String columnName)
Class | getColumnClass(int columnIndex)
int | getColumnCount()
String | getColumnName(int columnIndex) DOCUMENT ME!
XPath | getColumnNameXPath(int columnIndex) DOCUMENT ME!
XPath | getColumnXPath(int columnIndex) DOCUMENT ME!
XPath | getRowXPath() Getter for property rowXPath.
Object | getValueAt(Object row, int columnIndex)
Object | getVariableValue(String namespaceURI, String prefix, String localName)
protected void | handleException(Exception e)
static XMLTableDefinition | load(Document definition) Loads an XML table definition from an XML definition document
static XMLTableDefinition | load(Element definition) Loads an XML table definition from an XML definition document
void | removeColumn(XMLTableColumnDefinition column)
void | setRowExpression(String xpath)
void | setRowXPath(XPath rowXPath) Setter for property rowXPath.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XMLTableDefinition

public XMLTableDefinition()
Method Detail

load

public static XMLTableDefinition load(Document definition)
Loads an XML table definition from an XML definition document

Parameters:
definition - DOCUMENT ME!
Returns:
DOCUMENT ME!

load

public static XMLTableDefinition load(Element definition)
Loads an XML table definition from an XML definition document

Parameters:
definition - DOCUMENT ME!
Returns:
DOCUMENT ME!

getColumnClass

public Class getColumnClass(int columnIndex)

getColumnCount

public int getColumnCount()

getColumnName

public String getColumnName(int columnIndex)
DOCUMENT ME!

Parameters:
columnIndex - DOCUMENT ME!
Returns:
the static column name. This is used if there is no columnNameXPath

getColumnXPath

public XPath getColumnXPath(int columnIndex)
DOCUMENT ME!

Parameters:
columnIndex - DOCUMENT ME!
Returns:
the XPath expression used to evaluate the value of cells in this column

getColumnNameXPath

public XPath getColumnNameXPath(int columnIndex)
DOCUMENT ME!

Parameters:
columnIndex - DOCUMENT ME!
Returns:
the XPath expresssion used to create the column name, if there is one or null if there is no XPath expression to name the column.

getValueAt

public Object getValueAt(Object row,
                         int columnIndex)

addColumn

public void addColumn(String name,
                      String expression)

addColumn

public void addColumn(String name,
                      String expression,
                      int type)

addColumnWithXPathName

public void addColumnWithXPathName(String columnNameXPathExpression,
                                   String expression,
                                   int type)

addStringColumn

public void addStringColumn(String name,
                            String expression)

addNumberColumn

public void addNumberColumn(String name,
                            String expression)

addColumn

public void addColumn(XMLTableColumnDefinition column)

removeColumn

public void removeColumn(XMLTableColumnDefinition column)

clear

public void clear()

getColumn

public XMLTableColumnDefinition getColumn(int index)

getColumn

public XMLTableColumnDefinition getColumn(String columnName)

getRowXPath

public XPath getRowXPath()
Getter for property rowXPath.

Returns:
Value of property rowXPath.

setRowXPath

public void setRowXPath(XPath rowXPath)
Setter for property rowXPath.

Parameters:
rowXPath - New value of property rowXPath.

setRowExpression

public void setRowExpression(String xpath)

getVariableValue

public Object getVariableValue(String namespaceURI,
                               String prefix,
                               String localName)
Specified by:
getVariableValue in interface org.jaxen.VariableContext

createXPath

protected XPath createXPath(String expression)

createColumnXPath

protected XPath createColumnXPath(String expression)

clearCaches

protected void clearCaches()

handleException

protected void handleException(Exception e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XMLTableModel (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.swing
Class XMLTableModel

java.lang.Object
    extended by javax.swing.table.AbstractTableModel
        extended by org.dom4j.swing.XMLTableModel
All Implemented Interfaces:
Serializable, TableModel
public class XMLTableModel
extends AbstractTableModel

XMLTableDefinition repro.

Version:
$Revision: 1.8 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class javax.swing.table.AbstractTableModel
listenerList
Constructor Summary
XMLTableModel(Document tableDefinition, Object source)
Creates a TableModel from an XML table definition document and an XML source
XMLTableModel(Element tableDefinition, Object source)
Creates a TableModel from an XML table definition document and an XML source
XMLTableModel(XMLTableDefinition definition, Object source)
Method Summary
Class | getColumnClass(int columnIndex)
int | getColumnCount()
String | getColumnName(int columnIndex)
XMLTableDefinition | getDefinition() Getter for property definition.
int | getRowCount()
List | getRows()
Object | getRowValue(int rowIndex)
Object | getSource() Getter for the XML source, which is usually a Node or List of nodes.
Object | getValueAt(int rowIndex, int columnIndex)
protected void | handleException(Exception e)
void | setDefinition(XMLTableDefinition definition) Setter for property definition.
void | setSource(Object source) Setter for the XML source, which is usually a Node or List of nodes.
Methods inherited from class javax.swing.table.AbstractTableModel
addTableModelListener, findColumn, fireTableCellUpdated, fireTableChanged, fireTableDataChanged, fireTableRowsDeleted, fireTableRowsInserted, fireTableRowsUpdated, fireTableStructureChanged, getListeners, getTableModelListeners, isCellEditable, removeTableModelListener, setValueAt
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

XMLTableModel

public XMLTableModel(Element tableDefinition,
                     Object source)
Creates a TableModel from an XML table definition document and an XML source

Parameters:
tableDefinition - DOCUMENT ME!
source - DOCUMENT ME!

XMLTableModel

public XMLTableModel(Document tableDefinition,
                     Object source)
Creates a TableModel from an XML table definition document and an XML source

Parameters:
tableDefinition - DOCUMENT ME!
source - DOCUMENT ME!

XMLTableModel

public XMLTableModel(XMLTableDefinition definition,
                     Object source)
Method Detail

getRowValue

public Object getRowValue(int rowIndex)

getRows

public List getRows()

getColumnClass

public Class getColumnClass(int columnIndex)

getColumnCount

public int getColumnCount()

getColumnName

public String getColumnName(int columnIndex)

getValueAt

public Object getValueAt(int rowIndex,
                         int columnIndex)

getRowCount

public int getRowCount()

getDefinition

public XMLTableDefinition getDefinition()
Getter for property definition.

Returns:
Value of property definition.

setDefinition

public void setDefinition(XMLTableDefinition definition)
Setter for property definition.

Parameters:
definition - New value of property definition.

getSource

public Object getSource()
Getter for the XML source, which is usually a Node or List of nodes.

Returns:
Value of property source.

setSource

public void setSource(Object source)
Setter for the XML source, which is usually a Node or List of nodes.

Parameters:
source - New value of property source.

handleException

protected void handleException(Exception e)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.tree (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.tree

Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

See:
Description

Class Summary
AbstractAttribute | AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
AbstractBranch | AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
AbstractCDATA | AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
AbstractCharacterData | AbstractCharacterData is an abstract base class for tree implementors to use for implementation inheritence.
AbstractComment | AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
AbstractDocument | AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
AbstractDocumentType | AbstractDocumentType is an abstract base class for tree implementors to use for implementation inheritence.
AbstractElement | AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
AbstractEntity | AbstractEntity is an abstract base class for tree implementors to use for implementation inheritence.
AbstractNode | AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
AbstractProcessingInstruction | AbstractProcessingInstruction is an abstract base class for tree implementors to use for implementation inheritence.
AbstractText | AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
BackedList | BackedList represents a list of content of a Branch.
BaseElement | BaseElement is a useful base class for implemementation inheritence of an XML element.
ConcurrentReaderHashMap.BarrierLock | A Serializable class for barrier lock *
ConcurrentReaderHashMap.Entry | ConcurrentReaderHashMap collision list entry.
ContentListFacade | ContentListFacade represents a facade of the content of a Branch which is returned via calls to the Branch.content() method to allow users to modify the content of a Branch directly using the List interface.
DefaultAttribute | DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.
DefaultCDATA | DefaultCDATA is the default CDATA implementation.
DefaultComment | DefaultComment is the default Comment implementation.
DefaultDocument | DefaultDocument is the default DOM4J default implementation of an XML document.
DefaultDocumentType | DefaultDocumentType is the DOM4J default implementation of an XML document type.
DefaultElement | DefaultElement is the default DOM4J default implementation of an XML element.
DefaultEntity | DefaultEntity is the default Entity implementation.
DefaultNamespace | DefaultNamespace implements a doubly linked node which supports the parent relationship and is mutable.
DefaultProcessingInstruction | DefaultProcessingInstruction is the default Processing Instruction implementation.
DefaultText | DefaultText is the default Text implementation.
ElementIterator | Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
ElementNameIterator | Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
ElementQNameIterator | Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
FilterIterator | Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
FlyweightAttribute | FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.
FlyweightCDATA | FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.
FlyweightComment | FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.
FlyweightEntity | FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.
FlyweightProcessingInstruction | FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.
FlyweightText | FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.
NamespaceCache | NamespaceCache caches instances of DefaultNamespace for reuse both across documents and within documents.
NamespaceStack | NamespaceStack implements a stack of namespaces and optionally maintains a cache of all the fully qualified names (QName) which are in scope.
QNameCache | QNameCache caches instances of QName for reuse both across documents and within documents.
SingleIterator | SingleIterator is an Iteratorover a single object instance.

Package org.dom4j.tree Description

Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.


org.dom4j.tree Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.tree

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class org.dom4j.tree.BackedList
        • class org.dom4j.tree.ContentListFacade
    • class org.dom4j.tree.AbstractNode (implements java.lang.Cloneable, org.dom4j.Node, java.io.Serializable)
      • class org.dom4j.tree.AbstractAttribute (implements org.dom4j.Attribute)
        • class org.dom4j.tree.FlyweightAttribute
          • class org.dom4j.tree.DefaultAttribute
      • class org.dom4j.tree.AbstractBranch (implements org.dom4j.Branch)
        • class org.dom4j.tree.AbstractDocument (implements org.dom4j.Document)
          • class org.dom4j.tree.DefaultDocument
        • class org.dom4j.tree.AbstractElement (implements org.dom4j.Element)
          • class org.dom4j.tree.BaseElement
          • class org.dom4j.tree.DefaultElement
      • class org.dom4j.tree.AbstractCharacterData (implements org.dom4j.CharacterData)
        • class org.dom4j.tree.AbstractCDATA (implements org.dom4j.CDATA)
          • class org.dom4j.tree.FlyweightCDATA (implements org.dom4j.CDATA)
            • class org.dom4j.tree.DefaultCDATA
        • class org.dom4j.tree.AbstractComment (implements org.dom4j.Comment)
          • class org.dom4j.tree.FlyweightComment (implements org.dom4j.Comment)
            • class org.dom4j.tree.DefaultComment
        • class org.dom4j.tree.AbstractText (implements org.dom4j.Text)
          • class org.dom4j.tree.FlyweightText (implements org.dom4j.Text)
            • class org.dom4j.tree.DefaultText
      • class org.dom4j.tree.AbstractDocumentType (implements org.dom4j.DocumentType)
        • class org.dom4j.tree.DefaultDocumentType
      • class org.dom4j.tree.AbstractEntity (implements org.dom4j.Entity)
        • class org.dom4j.tree.FlyweightEntity
          • class org.dom4j.tree.DefaultEntity
      • class org.dom4j.tree.AbstractProcessingInstruction (implements org.dom4j.ProcessingInstruction)
        • class org.dom4j.tree.FlyweightProcessingInstruction
          • class org.dom4j.tree.DefaultProcessingInstruction
      • class org.dom4j.Namespace
        • class org.dom4j.tree.DefaultNamespace
    • class org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock (implements java.io.Serializable)
    • class org.dom4j.tree.ConcurrentReaderHashMap.Entry (implements java.util.Map.Entry)
    • class org.dom4j.tree.FilterIterator (implements java.util.Iterator)
      • class org.dom4j.tree.ElementIterator
      • class org.dom4j.tree.ElementNameIterator
      • class org.dom4j.tree.ElementQNameIterator
    • class org.dom4j.tree.NamespaceCache
    • class org.dom4j.tree.NamespaceStack
    • class org.dom4j.tree.QNameCache
    • class org.dom4j.tree.SingleIterator (implements java.util.Iterator)


Uses of Package org.dom4j.tree (dom4j 1.6.1 API)

Uses of Package
org.dom4j.tree

Packages that use org.dom4j.tree
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Classes in org.dom4j.tree used by org.dom4j
AbstractNode
AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
NamespaceCache
NamespaceCache caches instances of DefaultNamespace for reuse both across documents and within documents.
QNameCache
QNameCache caches instances of QName for reuse both across documents and within documents.

Classes in org.dom4j.tree used by org.dom4j.bean
AbstractAttribute
AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
AbstractBranch
AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
AbstractElement
AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
AbstractNode
AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
DefaultElement
DefaultElement is the default DOM4J default implementation of an XML element.
NamespaceStack
NamespaceStack implements a stack of namespaces and optionally maintains a cache of all the fully qualified names (QName) which are in scope.

Classes in org.dom4j.tree used by org.dom4j.datatype
AbstractAttribute
AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
AbstractBranch
AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
AbstractElement
AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
AbstractNode
AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
DefaultElement
DefaultElement is the default DOM4J default implementation of an XML element.

Classes in org.dom4j.tree used by org.dom4j.dom
AbstractAttribute
AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
AbstractBranch
AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
AbstractCDATA
AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
AbstractCharacterData
AbstractCharacterData is an abstract base class for tree implementors to use for implementation inheritence.
AbstractComment
AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
AbstractDocument
AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
AbstractDocumentType
AbstractDocumentType is an abstract base class for tree implementors to use for implementation inheritence.
AbstractElement
AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
AbstractEntity
AbstractEntity is an abstract base class for tree implementors to use for implementation inheritence.
AbstractNode
AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
AbstractProcessingInstruction
AbstractProcessingInstruction is an abstract base class for tree implementors to use for implementation inheritence.
AbstractText
AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
DefaultAttribute
DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.
DefaultCDATA
DefaultCDATA is the default CDATA implementation.
DefaultComment
DefaultComment is the default Comment implementation.
DefaultDocument
DefaultDocument is the default DOM4J default implementation of an XML document.
DefaultDocumentType
DefaultDocumentType is the DOM4J default implementation of an XML document type.
DefaultElement
DefaultElement is the default DOM4J default implementation of an XML element.
DefaultEntity
DefaultEntity is the default Entity implementation.
DefaultNamespace
DefaultNamespace implements a doubly linked node which supports the parent relationship and is mutable.
DefaultProcessingInstruction
DefaultProcessingInstruction is the default Processing Instruction implementation.
DefaultText
DefaultText is the default Text implementation.
FlyweightAttribute
FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.
FlyweightCDATA
FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.
FlyweightComment
FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.
FlyweightEntity
FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.
FlyweightProcessingInstruction
FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.
FlyweightText
FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.

Classes in org.dom4j.tree used by org.dom4j.io
NamespaceStack
NamespaceStack implements a stack of namespaces and optionally maintains a cache of all the fully qualified names (QName) which are in scope.

Classes in org.dom4j.tree used by org.dom4j.tree
AbstractAttribute
AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
AbstractBranch
AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
AbstractCDATA
AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
AbstractCharacterData
AbstractCharacterData is an abstract base class for tree implementors to use for implementation inheritence.
AbstractComment
AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
AbstractDocument
AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
AbstractDocumentType
AbstractDocumentType is an abstract base class for tree implementors to use for implementation inheritence.
AbstractElement
AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
AbstractEntity
AbstractEntity is an abstract base class for tree implementors to use for implementation inheritence.
AbstractNode
AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
AbstractProcessingInstruction
AbstractProcessingInstruction is an abstract base class for tree implementors to use for implementation inheritence.
AbstractText
AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
BackedList
BackedList represents a list of content of a Branch.
ConcurrentReaderHashMap.Entry
ConcurrentReaderHashMap collision list entry.
FilterIterator
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
FlyweightAttribute
FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.
FlyweightCDATA
FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.
FlyweightComment
FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.
FlyweightEntity
FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.
FlyweightProcessingInstruction
FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.
FlyweightText
FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.
NamespaceStack
NamespaceStack implements a stack of namespaces and optionally maintains a cache of all the fully qualified names (QName) which are in scope.

Classes in org.dom4j.tree used by org.dom4j.util
AbstractAttribute
AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
AbstractBranch
AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
AbstractElement
AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
AbstractNode
AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
BaseElement
BaseElement is a useful base class for implemementation inheritence of an XML element.
DefaultAttribute
DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.
DefaultElement
DefaultElement is the default DOM4J default implementation of an XML element.
FlyweightAttribute
FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


AbstractAttribute (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractAttribute

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractAttribute
All Implemented Interfaces:
Attribute, Cloneable, Node, Serializable
Direct Known Subclasses:
BeanAttribute, DatatypeAttribute, FlyweightAttribute
public abstract class AbstractAttribute
extends AbstractNode
implements Attribute

AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.21 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractAttribute()
Method Summary
 void accept(Visitor visitor)
accept is the method used in the Visitor Pattern.
 String asXML()
asXML returns the textual XML representation of this node.
protected  Node createXPathResult(Element parent)
 Object getData()
Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node.getText().
 String getName()
getName returns the name of this node.
 Namespace getNamespace()
Returns the Namespace of this element if one exists otherwise null is returned returned.
 String getNamespacePrefix()
Returns the namespace prefix of this element if one exists otherwise an empty String is returned.
 String getNamespaceURI()
Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.
 short getNodeType()
Returns the code according to the type of node.
 String getPath(Element context)
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
 String getQualifiedName()
Returns the fully qualified name of this element.
 String getText()
Returns the text of this node.
 String getUniquePath(Element context)
Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
 void setData(Object data)
Sets the data value of this attribute if this element supports data binding or calls Node.setText(String)if it doesn't.
 void setNamespace(Namespace namespace)
Sets the Namespace of this element or if this element is read only then an UnsupportedOperationException is thrown.
 void setText(String text)
Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
 void setValue(String value)
Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.
 String toString()
 void write(Writer writer)
write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Attribute
getQName, getValue
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, supportsParent, valueOf

Constructor Detail

AbstractAttribute

public AbstractAttribute()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

setNamespace

public void setNamespace(Namespace namespace)
Description copied from interface: Attribute

Sets the Namespace of this element or if this element is read only then an UnsupportedOperationException is thrown.

Specified by:
setNamespace in interface Attribute
Parameters:
namespace - is the Namespace to associate with this element

getText

public String getText()
Description copied from interface: Node

Returns the text of this node.

Specified by:
getText in interface Node
Overrides:
getText in class AbstractNode

setText

public void setText(String text)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setText in interface Node
Overrides:
setText in class AbstractNode

setValue

public void setValue(String value)
Description copied from interface: Attribute

Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setValue in interface Attribute
Parameters:
value - is the new value of this attribute

getData

public Object getData()
Description copied from interface: Attribute

Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node.getText().

Specified by:
getData in interface Attribute
Returns:
the attribute data

setData

public void setData(Object data)
Description copied from interface: Attribute

Sets the data value of this attribute if this element supports data binding or calls Node.setText(String)if it doesn't.

Specified by:
setData in interface Attribute
Parameters:
data - the attribute data

toString

public String toString()

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer writer)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)
Description copied from interface: Node

accept is the method used in the Visitor Pattern.

Specified by:
accept in interface Node
Parameters:
visitor - is the visitor in the Visitor Pattern

getNamespace

public Namespace getNamespace()
Description copied from interface: Attribute

Returns the Namespace of this element if one exists otherwise null is returned returned.

Specified by:
getNamespace in interface Attribute
Returns:
the Namespace associated with this node

getName

public String getName()
Description copied from interface: Node

getName returns the name of this node. This is the XML local name of the element, attribute, entity or processing instruction. For CDATA and Text nodes this method will return null.

Specified by:
getName in interface Node
Overrides:
getName in class AbstractNode

getNamespacePrefix

public String getNamespacePrefix()
Description copied from interface: Attribute

Returns the namespace prefix of this element if one exists otherwise an empty String is returned.

Specified by:
getNamespacePrefix in interface Attribute
Returns:
the prefix of the Namespace of this element or an empty String

getNamespaceURI

public String getNamespaceURI()
Description copied from interface: Attribute

Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.

Specified by:
getNamespaceURI in interface Attribute
Returns:
the URI for the Namespace of this element or an empty String

getQualifiedName

public String getQualifiedName()
Description copied from interface: Attribute

Returns the fully qualified name of this element.

This will be the same as the value returned from Node.getName() if this element has no namespace attached to this element or an expression of the form

 getNamespacePrefix() + ":" + getName()
will be returned.

Specified by:
getQualifiedName in interface Attribute
Returns:
the fully qualified name of the element

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

createXPathResult

protected Node createXPathResult(Element parent)
Overrides:
createXPathResult in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AbstractBranch (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractBranch

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
All Implemented Interfaces:
Branch, Cloneable, Node, Serializable
Direct Known Subclasses:
AbstractDocument, AbstractElement
public abstract class AbstractBranch
extends AbstractNode
implements Branch

AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.44 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static int DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractBranch()
Method Summary
void | add(Comment comment) Adds the given Comment to this branch.
void | add(Element element) Adds the given Element to this branch.
void | add(Node node) Adds the given Node or throws IllegalAddException if the given node is not of a valid type.
void | add(ProcessingInstruction pi) Adds the given ProcessingInstruction to this branch.
Element | addElement(QName qname) Adds a new Element node with the given QNameto this branch and returns a reference to the new node.
Element | addElement(String name) Adds a new Element node with the given name to this branch and returns a reference to the new node.
Element | addElement(String qualifiedName, String namespaceURI) Adds a new Element node with the given qualified name and namespace URI to this branch and returns a reference to the new node.
Element | addElement(String name, String prefix, String uri)
protected abstract void | addNode(int index, Node node)
protected abstract void | addNode(Node node)
void | appendContent(Branch branch) Appends the content of the given branch to this branch instance.
protected abstract void | childAdded(Node node) Called when a new child node has been added to me to allow any parent relationships to be created or events to be fired.
protected abstract void | childRemoved(Node node) Called when a child node has been removed to allow any parent relationships to be deleted or events to be fired.
List | content() Returns the content nodes of this branch as a backed Listso that the content of this branch may be modified directly using the Listinterface.
protected abstract List | contentList() DOCUMENT ME!
protected void | contentRemoved() Called when the given List content has been removed so each node should have its parent and document relationships cleared
protected List | createContentList() A Factory Method pattern which creates a List implementation used to store content
protected List | createContentList(int size) A Factory Method pattern which creates a List implementation used to store content
protected List | createEmptyList() A Factory Method pattern which creates an empty a BackedList implementation
protected BackedList | createResultList() A Factory Method pattern which creates a BackedList implementation used to store results of a filtered content query.
protected List | createSingleResultList(Object result) A Factory Method pattern which creates a BackedList implementation which contains a single result
Element | elementByID(String elementID) Returns the element of the given ID attribute value.
protected String | elementID(Element element) DOCUMENT ME!
protected String | getContentAsStringValue(Object content) DOCUMENT ME!
protected String | getContentAsText(Object content) DOCUMENT ME!
String | getText() Returns the text of this node.
String | getTextTrim()
boolean | hasContent() hasContent returns true if this node is a Branch (either an Element or a Document) and it contains at least one content node such as a child Element or Text node.
int | indexOf(Node node) Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.
protected void | invalidNodeTypeAddException(Node node) Called when an invalid node has been added.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
Node | node(int index) Returns the Node at the specified index position.
int | nodeCount() Returns the number of Node instances that this branch contains.
Iterator | nodeIterator() Returns an iterator through the content nodes of this branch
boolean | remove(Comment comment) Removes the given Comment if the node is an immediate child of this branch.
boolean | remove(Element element) Removes the given Element if the node is an immediate child of this branch.
boolean | remove(Node node) Removes the given Node if the node is an immediate child of this branch.
boolean | remove(ProcessingInstruction pi) Removes the given ProcessingInstruction if the node is an immediate child of this branch.
protected abstract boolean | removeNode(Node node)
void | setProcessingInstructions(List listOfPIs) Sets all the processing instructions for this branch
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getName, getNodeType, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.dom4j.Branch
clearContent, normalize, processingInstruction, processingInstructions, processingInstructions, removeProcessingInstruction, setContent
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getUniquePath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Field Detail

DEFAULT_CONTENT_LIST_SIZE

protected static final int DEFAULT_CONTENT_LIST_SIZE
See Also:
Constant Field Values
Constructor Detail

AbstractBranch

public AbstractBranch()
Method Detail

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode

hasContent

public boolean hasContent()
Description copied from interface: Node

hasContent returns true if this node is a Branch (either an Element or a Document) and it contains at least one content node such as a child Element or Text node.

Specified by:
hasContent in interface Node
Overrides:
hasContent in class AbstractNode

content

public List content()
Description copied from interface: Branch

Returns the content nodes of this branch as a backed Listso that the content of this branch may be modified directly using the Listinterface. The List is backed by the Branch so that changes to the list are reflected in the branch and vice versa.

Specified by:
content in interface Branch
Returns:
the nodes that this branch contains as a List

getText

public String getText()
Description copied from interface: Node

Returns the text of this node.

Specified by:
getText in interface Node
Overrides:
getText in class AbstractNode

getContentAsText

protected String getContentAsText(Object content)
DOCUMENT ME!

Parameters:
content - DOCUMENT ME!
Returns:
the text value of the given content object as text which returns the text value of CDATA, Entity or Text nodes

getContentAsStringValue

protected String getContentAsStringValue(Object content)
DOCUMENT ME!

Parameters:
content - DOCUMENT ME!
Returns:
the XPath defined string-value of the given content object

getTextTrim

public String getTextTrim()

setProcessingInstructions

public void setProcessingInstructions(List listOfPIs)
Description copied from interface: Branch
Sets all the processing instructions for this branch

Specified by:
setProcessingInstructions in interface Branch
Parameters:
listOfPIs - DOCUMENT ME!

addElement

public Element addElement(String name)
Description copied from interface: Branch
Adds a new Element node with the given name to this branch and returns a reference to the new node.

Specified by:
addElement in interface Branch
Parameters:
name - is the name for the Element node.
Returns:
the newly added Element node.

addElement

public Element addElement(String qualifiedName,
                          String namespaceURI)
Description copied from interface: Branch
Adds a new Element node with the given qualified name and namespace URI to this branch and returns a reference to the new node.

Specified by:
addElement in interface Branch
Parameters:
qualifiedName - is the fully qualified name of the Element
namespaceURI - is the URI of the namespace to use
Returns:
the newly added Element node.

addElement

public Element addElement(QName qname)
Description copied from interface: Branch
Adds a new Element node with the given QNameto this branch and returns a reference to the new node.

Specified by:
addElement in interface Branch
Parameters:
qname - is the qualified name for the Element node.
Returns:
the newly added Element node.

addElement

public Element addElement(String name,
                          String prefix,
                          String uri)

add

public void add(Node node)
Description copied from interface: Branch
Adds the given Node or throws IllegalAddException if the given node is not of a valid type. This is a polymorphic method which will call the typesafe method for the node type such as add(Element) or add(Comment).

Specified by:
add in interface Branch
Parameters:
node - is the given node to add

remove

public boolean remove(Node node)
Description copied from interface: Branch
Removes the given Node if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead. This is a polymorphic method which will call the typesafe method for the node type such as remove(Element) or remove(Comment).

Specified by:
remove in interface Branch
Parameters:
node - is the given node to be removed
Returns:
true if the node was removed

add

public void add(Comment comment)
Description copied from interface: Branch
Adds the given Comment to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Branch
Parameters:
comment - is the comment to be added

add

public void add(Element element)
Description copied from interface: Branch
Adds the given Element to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Branch
Parameters:
element - is the element to be added

add

public void add(ProcessingInstruction pi)
Description copied from interface: Branch
Adds the given ProcessingInstruction to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Branch
Parameters:
pi - is the processing instruction to be added

remove

public boolean remove(Comment comment)
Description copied from interface: Branch
Removes the given Comment if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Specified by:
remove in interface Branch
Parameters:
comment - is the comment to be removed
Returns:
true if the comment was removed

remove

public boolean remove(Element element)
Description copied from interface: Branch
Removes the given Element if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Specified by:
remove in interface Branch
Parameters:
element - is the element to be removed
Returns:
true if the element was removed

remove

public boolean remove(ProcessingInstruction pi)
Description copied from interface: Branch
Removes the given ProcessingInstruction if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Specified by:
remove in interface Branch
Parameters:
pi - is the processing instruction to be removed
Returns:
true if the processing instruction was removed

elementByID

public Element elementByID(String elementID)
Description copied from interface: Branch
Returns the element of the given ID attribute value. If this tree is capable of understanding which attribute value should be used for the ID then it should be used, otherwise this method should return null.

Specified by:
elementByID in interface Branch
Parameters:
elementID - DOCUMENT ME!
Returns:
DOCUMENT ME!

appendContent

public void appendContent(Branch branch)
Description copied from interface: Branch
Appends the content of the given branch to this branch instance. This method behaves like the Collection.addAll(java.util.Collection) method.

Specified by:
appendContent in interface Branch
Parameters:
branch - is the branch whose content will be added to me.

node

public Node node(int index)
Description copied from interface: Branch
Returns the Node at the specified index position.

Specified by:
node in interface Branch
Parameters:
index - the index of the node to return.
Returns:
the Node at the specified position.

nodeCount

public int nodeCount()
Description copied from interface: Branch
Returns the number of Node instances that this branch contains.

Specified by:
nodeCount in interface Branch
Returns:
the number of nodes this branch contains

indexOf

public int indexOf(Node node)
Description copied from interface: Branch
Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.

Specified by:
indexOf in interface Branch
Parameters:
node - the content child node to find.
Returns:
the index of the given node starting at 0 or -1 if the node is not a child node of this branch

nodeIterator

public Iterator nodeIterator()
Description copied from interface: Branch
Returns an iterator through the content nodes of this branch

Specified by:
nodeIterator in interface Branch
Returns:
an iterator through the content nodes of this branch

elementID

protected String elementID(Element element)
DOCUMENT ME!

Parameters:
element - DOCUMENT ME!
Returns:
the ID of the given Element

contentList

protected abstract List contentList()
DOCUMENT ME!

Returns:
the internal List used to manage the content

createContentList

protected List createContentList()
A Factory Method pattern which creates a List implementation used to store content

Returns:
DOCUMENT ME!

createContentList

protected List createContentList(int size)
A Factory Method pattern which creates a List implementation used to store content

Parameters:
size - DOCUMENT ME!
Returns:
DOCUMENT ME!

createResultList

protected BackedList createResultList()
A Factory Method pattern which creates a BackedList implementation used to store results of a filtered content query.

Returns:
DOCUMENT ME!

createSingleResultList

protected List createSingleResultList(Object result)
A Factory Method pattern which creates a BackedList implementation which contains a single result

Parameters:
result - DOCUMENT ME!
Returns:
DOCUMENT ME!

createEmptyList

protected List createEmptyList()
A Factory Method pattern which creates an empty a BackedList implementation

Returns:
DOCUMENT ME!

addNode

protected abstract void addNode(Node node)

addNode

protected abstract void addNode(int index,
                                Node node)

removeNode

protected abstract boolean removeNode(Node node)

childAdded

protected abstract void childAdded(Node node)
Called when a new child node has been added to me to allow any parent relationships to be created or events to be fired.

Parameters:
node - DOCUMENT ME!

childRemoved

protected abstract void childRemoved(Node node)
Called when a child node has been removed to allow any parent relationships to be deleted or events to be fired.

Parameters:
node - DOCUMENT ME!

contentRemoved

protected void contentRemoved()
Called when the given List content has been removed so each node should have its parent and document relationships cleared

invalidNodeTypeAddException

protected void invalidNodeTypeAddException(Node node)
Called when an invalid node has been added. Throws an IllegalAddException.

Parameters:
node - DOCUMENT ME!
Throws:
IllegalAddException - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractCDATA (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractCDATA

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractCDATA
All Implemented Interfaces:
CDATA, CharacterData, Cloneable, Node, Serializable
Direct Known Subclasses:
FlyweightCDATA
public abstract class AbstractCDATA
extends AbstractCharacterData
implements CDATA

AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractCDATA()
Method Summary
void | accept(Visitor visitor) accept is the method used in the Visitor Pattern.
String | asXML() asXML returns the textual XML representation of this node.
short | getNodeType() Returns the code according to the type of node.
String | toString()
void | write(Writer writer) write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText, getPath, getUniquePath
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getStringValue, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf

Constructor Detail

AbstractCDATA

public AbstractCDATA()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

toString

public String toString()

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer writer)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)
Description copied from interface: Node

accept is the method used in the Visitor Pattern.

Specified by:
accept in interface Node
Parameters:
visitor - is the visitor in the Visitor Pattern
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractCharacterData (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractCharacterData

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
All Implemented Interfaces:
CharacterData, Cloneable, Node, Serializable
Direct Known Subclasses:
AbstractCDATA, AbstractComment, AbstractText
public abstract class AbstractCharacterData
extends AbstractNode
implements CharacterData

AbstractCharacterData is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractCharacterData()
Method Summary
void | appendText(String text) Appends the given text to this nodes text value.
String | getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getName, getNodeType, getNodeTypeName, getParent, getPath, getStringValue, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getStringValue, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Constructor Detail

AbstractCharacterData

public AbstractCharacterData()
Method Detail

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

appendText

public void appendText(String text)
Description copied from interface: CharacterData
Appends the given text to this nodes text value. Calling this method is equivalent of the code node.setText(node.getText() + text) but allows for possible implementation optimisations (such as a text based node storing a StringBuffer internally

Specified by:
appendText in interface CharacterData
Parameters:
text - the text to append
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractComment (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractComment

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractComment
All Implemented Interfaces:
CharacterData, Cloneable, Comment, Node, Serializable
Direct Known Subclasses:
FlyweightComment
public abstract class AbstractComment
extends AbstractCharacterData
implements Comment

AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.13 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractComment()
Method Summary
void | accept(Visitor visitor) accept is the method used in the Visitor Pattern.
String | asXML() asXML returns the textual XML representation of this node.
short | getNodeType() Returns the code according to the type of node.
String | getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
String | toString()
void | write(Writer writer) write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getStringValue, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeTypeName, getParent, getPath, getStringValue, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf

Constructor Detail

AbstractComment

public AbstractComment()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Overrides:
getPath in class AbstractCharacterData

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Overrides:
getUniquePath in class AbstractCharacterData

toString

public String toString()

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer writer)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)
Description copied from interface: Node

accept is the method used in the Visitor Pattern.

Specified by:
accept in interface Node
Parameters:
visitor - is the visitor in the Visitor Pattern
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractDocument (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractDocument

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractDocument
All Implemented Interfaces:
Branch, Cloneable, Document, Node, Serializable
Direct Known Subclasses:
DefaultDocument
public abstract class AbstractDocument
extends AbstractBranch
implements Document

AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.33 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected  String encoding
The encoding of this document as stated in the XML declaration
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractDocument()
Method Summary
void | accept(Visitor visitor) accept method is the Visitor Pattern method.
void | add(Element element) Adds the given Element to this branch.
Document | addComment(String comment) Adds a new Comment node with the given text to this branch.
Element | addElement(QName qName) Adds a new Element node with the given QNameto this branch and returns a reference to the new node.
Element | addElement(String name) Adds a new Element node with the given name to this branch and returns a reference to the new node.
Element | addElement(String qualifiedName, String namespaceURI) Adds a new Element node with the given qualified name and namespace URI to this branch and returns a reference to the new node.
Document | addProcessingInstruction(String target, Map data) Adds a processing instruction for the given target
Document | addProcessingInstruction(String target, String data) Adds a processing instruction for the given target
String | asXML() asXML returns the textual XML representation of this node.
Node | asXPathResult(Element parent) asXPathResult returns a version of this node which is capable of being an XPath result.
protected void | checkAddElementAllowed(Element element)
protected void | childAdded(Node node) Called when a new child node has been added to me to allow any parent relationships to be created or events to be fired.
protected void | childRemoved(Node node) Called when a child node has been removed to allow any parent relationships to be deleted or events to be fired.
Document | getDocument() getDocument returns the Document that this Node is part of if this node supports the parent relationship.
short | getNodeType() Returns the code according to the type of node.
String | getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | getStringValue() Returns the XPath string-value of this node.
String | getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
String | getXMLEncoding() Return the encoding of this document, as part of the XML declaration This is null when unspecified or when it is not known (such as when the Document was created in memory) or when the implementation does not support this operation.
void | normalize() Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
boolean | remove(Element element) Removes the given Element if the node is an immediate child of this branch.
protected abstract void | rootElementAdded(Element rootElement) Called to set the root element variable
void | setRootElement(Element rootElement) Sets the root element for this document
void | setXMLEncoding(String enc) Sets the encoding of this document as it will appear in the XML declaration part of the document.
String | toString()
void | write(Writer out) write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractBranch
add, add, add, addElement, addNode, addNode, appendContent, content, contentList, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getText, getTextTrim, hasContent, indexOf, invalidNodeTypeAddException, isReadOnly, node, nodeCount, nodeIterator, remove, remove, remove, removeNode, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Document
addDocType, getDocType, getEntityResolver, getRootElement, setDocType, setEntityResolver
Methods inherited from interface org.dom4j.Branch
add, add, add, appendContent, clearContent, content, elementByID, indexOf, node, nodeCount, nodeIterator, processingInstruction, processingInstructions, processingInstructions, remove, remove, remove, removeProcessingInstruction, setContent, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
clone, createXPath, detach, getName, getNodeTypeName, getParent, getPath, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf

Field Detail

encoding

protected String encoding
The encoding of this document as stated in the XML declaration

Constructor Detail

AbstractDocument

public AbstractDocument()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

getDocument

public Document getDocument()
Description copied from interface: Node

getDocument returns the Document that this Node is part of if this node supports the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getDocument in interface Node
Overrides:
getDocument in class AbstractNode

getXMLEncoding

public String getXMLEncoding()
Description copied from interface: Document
Return the encoding of this document, as part of the XML declaration This is null when unspecified or when it is not known (such as when the Document was created in memory) or when the implementation does not support this operation.

The way this encoding is retrieved also depends on the way the XML source is parsed. For instance, if the SAXReader is used and if the underlying XMLReader implementation support the org.xml.sax.ext.Locator2 interface, the result returned by this method is specified by the getEncoding() method of that interface.

Specified by:
getXMLEncoding in interface Document
Returns:
The encoding of this document, as stated in the XML declaration, or null if unknown.

getStringValue

public String getStringValue()
Description copied from interface: Node
Returns the XPath string-value of this node. The behaviour of this method is defined in the XPath specification .

Specified by:
getStringValue in interface Node
Overrides:
getStringValue in class AbstractNode

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer out)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)

accept method is the Visitor Pattern method.

Specified by:
accept in interface Node
Parameters:
visitor - Visitor is the visitor.

toString

public String toString()

normalize

public void normalize()
Description copied from interface: Branch
Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes. This can be used to ensure that the DOM view of a document is the same as if it were saved and re-loaded, and is useful when operations (such as XPointer lookups) that depend on a particular document tree structure are to be used.In cases where the document contains CDATASections, the normalize operation alone may not be sufficient, since XPointers do not differentiate between Text nodes and CDATASection nodes.

Specified by:
normalize in interface Branch

addComment

public Document addComment(String comment)
Description copied from interface: Document
Adds a new Comment node with the given text to this branch.

Specified by:
addComment in interface Document
Parameters:
comment - is the text for the Comment node.
Returns:
this Document instance.

addProcessingInstruction

public Document addProcessingInstruction(String target,
                                         String data)
Description copied from interface: Document
Adds a processing instruction for the given target

Specified by:
addProcessingInstruction in interface Document
Parameters:
target - is the target of the processing instruction
data - is the textual data (key/value pairs) of the processing instruction
Returns:
this Document instance.

addProcessingInstruction

public Document addProcessingInstruction(String target,
                                         Map data)
Description copied from interface: Document
Adds a processing instruction for the given target

Specified by:
addProcessingInstruction in interface Document
Parameters:
target - is the target of the processing instruction
data - is a Map of the key / value pairs of the processing instruction
Returns:
this Document instance.

addElement

public Element addElement(String name)
Description copied from interface: Branch
Adds a new Element node with the given name to this branch and returns a reference to the new node.

Specified by:
addElement in interface Branch
Overrides:
addElement in class AbstractBranch

addElement

public Element addElement(String qualifiedName,
                          String namespaceURI)
Description copied from interface: Branch
Adds a new Element node with the given qualified name and namespace URI to this branch and returns a reference to the new node.

Specified by:
addElement in interface Branch
Overrides:
addElement in class AbstractBranch

addElement

public Element addElement(QName qName)
Description copied from interface: Branch
Adds a new Element node with the given QNameto this branch and returns a reference to the new node.

Specified by:
addElement in interface Branch
Overrides:
addElement in class AbstractBranch

setRootElement

public void setRootElement(Element rootElement)
Description copied from interface: Document
Sets the root element for this document

Specified by:
setRootElement in interface Document
Parameters:
rootElement - the new root element for this document

add

public void add(Element element)
Description copied from interface: Branch
Adds the given Element to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Branch
Overrides:
add in class AbstractBranch

remove

public boolean remove(Element element)
Description copied from interface: Branch
Removes the given Element if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Specified by:
remove in interface Branch
Overrides:
remove in class AbstractBranch

asXPathResult

public Node asXPathResult(Element parent)
Description copied from interface: Node

asXPathResult returns a version of this node which is capable of being an XPath result. The result of an XPath expression should always support the parent relationship, whether the original XML tree was singly or doubly linked. If the node does not support the parent relationship then a new node will be created which is linked to its parent and returned.

Specified by:
asXPathResult in interface Node
Overrides:
asXPathResult in class AbstractNode

childAdded

protected void childAdded(Node node)
Description copied from class: AbstractBranch
Called when a new child node has been added to me to allow any parent relationships to be created or events to be fired.

Specified by:
childAdded in class AbstractBranch
Parameters:
node - DOCUMENT ME!

childRemoved

protected void childRemoved(Node node)
Description copied from class: AbstractBranch
Called when a child node has been removed to allow any parent relationships to be deleted or events to be fired.

Specified by:
childRemoved in class AbstractBranch
Parameters:
node - DOCUMENT ME!

checkAddElementAllowed

protected void checkAddElementAllowed(Element element)

rootElementAdded

protected abstract void rootElementAdded(Element rootElement)
Called to set the root element variable

Parameters:
rootElement - DOCUMENT ME!

setXMLEncoding

public void setXMLEncoding(String enc)
Description copied from interface: Document
Sets the encoding of this document as it will appear in the XML declaration part of the document.

Specified by:
setXMLEncoding in interface Document
Parameters:
enc - the encoding of the document
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractDocumentType (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractDocumentType

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractDocumentType
All Implemented Interfaces:
Cloneable, DocumentType, Node, Serializable
Direct Known Subclasses:
DefaultDocumentType
public abstract class AbstractDocumentType
extends AbstractNode
implements DocumentType

AbstractDocumentType is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.17 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractDocumentType()
Method Summary
void | accept(Visitor visitor) accept is the method used in the Visitor Pattern.
String | asXML() asXML returns the textual XML representation of this node.
String | getName() getName returns the name of this node.
short | getNodeType() Returns the code according to the type of node.
String | getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | getText() Returns the text format of the declarations if applicable, or the empty String
String | getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
void | setName(String name) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
String | toString()
void | write(Writer writer) write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.DocumentType
getElementName, getExternalDeclarations, getInternalDeclarations, getPublicID, getSystemID, setElementName, setExternalDeclarations, setInternalDeclarations, setPublicID, setSystemID
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf

Constructor Detail

AbstractDocumentType

public AbstractDocumentType()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

getName

public String getName()
Description copied from interface: Node

getName returns the name of this node. This is the XML local name of the element, attribute, entity or processing instruction. For CDATA and Text nodes this method will return null.

Specified by:
getName in interface Node
Overrides:
getName in class AbstractNode

setName

public void setName(String name)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setName in interface Node
Overrides:
setName in class AbstractNode

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

getText

public String getText()
Returns the text format of the declarations if applicable, or the empty String

Specified by:
getText in interface Node
Overrides:
getText in class AbstractNode
Returns:
DOCUMENT ME!

toString

public String toString()

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer writer)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)
Description copied from interface: Node

accept is the method used in the Visitor Pattern.

Specified by:
accept in interface Node
Parameters:
visitor - is the visitor in the Visitor Pattern
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
All Implemented Interfaces:
Branch, Cloneable, Element, Node, Serializable
Direct Known Subclasses:
BaseElement, DefaultElement
public abstract class AbstractElement
extends AbstractBranch
implements Element

AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.80 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static Iterator | EMPTY_ITERATOR
protected static List | EMPTY_LIST
protected static boolean | USE_STRINGVALUE_SEPARATOR
protected static boolean | VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractElement()
Method Summary
 void accept(Visitor visitor)
accept method is the Visitor Pattern method.
 void add(Attribute attribute)
Adds the given Attribute to this element.
 void add(CDATA cdata)
Adds the given CDATA to this element.
 void add(Comment comment)
Adds the given Comment to this branch.
 void add(Element element)
Adds the given Element to this branch.
 void add(Entity entity)
Adds the given Entity to this element.
 void add(Namespace namespace)
Adds the given Namespace to this element.
 void add(Node node)
Adds the given Node or throws IllegalAddException if the given node is not of a valid type.
 void add(ProcessingInstruction pi)
Adds the given ProcessingInstruction to this branch.
 void add(Text text)
Adds the given Text to this element.
 Element addAttribute(QName qName, String value)
Adds the attribute value of the given fully qualified name.
 Element addAttribute(String name, String value)
Adds the attribute value of the given local name.
 Element addCDATA(String cdata)
Adds a new CDATA node with the given text to this element.
 Element addComment(String comment)
Adds a new Comment node with the given text to this element.
 Element addElement(String name)
Adds a new Element node with the given name to this branch and returns a reference to the new node.
 Element addEntity(String name, String text)
Adds a new Entity node with the given name and text to this element and returns a reference to the new node.
 List additionalNamespaces()
Returns any additional namespaces declarations for this element other than namespace returned via the getNamespace()method.
 List additionalNamespaces(String defaultNamespaceURI)
 Element addNamespace(String prefix, String uri)
Adds a namespace to this element for use by its child content
protected  void addNewNode(int index, Node node)
protected  void addNewNode(Node node)
Like addNode() but does not require a parent check
protected  void addNode(int index, Node node)
protected  void addNode(Node node)
 Element addProcessingInstruction(String target, Map data)
Adds a processing instruction for the given target
 Element addProcessingInstruction(String target, String data)
Adds a processing instruction for the given target
 Element addText(String text)
Adds a new Text node with the given text to this element.
 void appendAttributes(Element element)
Appends the attributes of the given element to me.
 String asXML()
asXML returns the textual XML representation of this node.
 Attribute attribute(int index)
Returns the attribute at the specified indexGets the
 Attribute attribute(QName qName)
DOCUMENT ME!
 Attribute attribute(String name)
Returns the attribute with the given name
 Attribute attribute(String name, Namespace namespace)
 int attributeCount()
DOCUMENT ME!
 Iterator attributeIterator()
DOCUMENT ME!
protected abstract  List attributeList()
DOCUMENT ME!
protected abstract  List attributeList(int attributeCount)
DOCUMENT ME!
 List attributes()
Returns the Attributeinstances this element contains as a backed Listso that the attributes may be modified directly using the Listinterface.
 String attributeValue(QName qName)
This returns the attribute value for the attribute with the given fully qualified name or null if there is no such attribute or the empty string if the attribute value is empty.
 String attributeValue(QName qName, String defaultValue)
This returns the attribute value for the attribute with the given fully qualified name or the default value if there is no such attribute value.
 String attributeValue(String name)
This returns the attribute value for the attribute with the given name and any namespace or null if there is no such attribute or the empty string if the attribute value is empty.
 String attributeValue(String name, String defaultValue)
This returns the attribute value for the attribute with the given name and any namespace or the default value if there is no such attribute value.
protected  void childAdded(Node node)
Called when a new child node is added to create any parent relationships
protected  void childRemoved(Node node)
Called when a child node has been removed to allow any parent relationships to be deleted or events to be fired.
protected  List createAttributeList()
A Factory Method pattern which creates a List implementation used to store attributes
protected  List createAttributeList(int size)
A Factory Method pattern which creates a List implementation used to store attributes
 Element createCopy()
This returns a deep clone of this element.
 Element createCopy(QName qName)
Creates a deep copy of this element with the given fully qualified name.
 Element createCopy(String name)
Creates a deep copy of this element with the given local name The new element is detached from its parent, and getParent() on the clone will return null.
protected  Element createElement(QName qName)
protected  Element createElement(String name)
protected  Iterator createSingleIterator(Object result)
 List declaredNamespaces()
Returns all the namespaces declared by this element.
 Element element(QName qName)
Returns the first element for the given fully qualified name.
 Element element(String name)
Returns the first element for the given local name and any namespace.
 Element element(String name, Namespace namespace)
 Iterator elementIterator()
Returns an iterator over all this elements child elements.
 Iterator elementIterator(QName qName)
Returns an iterator over the elements contained in this element which match the given fully qualified name.
 Iterator elementIterator(String name)
Returns an iterator over the elements contained in this element which match the given local name and any namespace.
 Iterator elementIterator(String name, Namespace ns)
 List elements()
Returns the elements contained in this element.
 List elements(QName qName)
Returns the elements contained in this element with the given fully qualified name.
 List elements(String name)
Returns the elements contained in this element with the given local name and any namespace.
 List elements(String name, Namespace namespace)
 String elementText(QName qName)
 String elementText(String name)
 String elementTextTrim(QName qName)
 String elementTextTrim(String name)
 void ensureAttributesCapacity(int minCapacity)
Ensures that the list of attributes has the given size
 Object getData()
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as AbstractBranch.getText()
protected  DocumentFactory getDocumentFactory()
 String getName()
getName returns the name of this node.
 Namespace getNamespace()
Returns the Namespace of this element if one exists otherwise Namespace.NO_NAMESPACE is returned.
 Namespace getNamespaceForPrefix(String prefix)
Returns the Namespace which is mapped to the given prefix or null if it could not be found.
 Namespace getNamespaceForURI(String uri)
Returns the Namespace which is mapped to the given URI or null if it could not be found.
 String getNamespacePrefix()
Returns the namespace prefix of this element if one exists otherwise an empty String is returned.
 List getNamespacesForURI(String uri)
Returns the all namespaces which are mapped to the given URI or an empty list if no such namespaces could be found.
 String getNamespaceURI()
Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.
 short getNodeType()
Returns the code according to the type of node.
 String getPath(Element context)
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
 QName getQName(String qualifiedName)
Returns the QName for the given qualified name, using the namespace URI in scope for the given prefix of the qualified name or the default namespace if the qualified name has no prefix.
 String getQualifiedName()
Returns the fully qualified name of this element.
 String getStringValue()
Returns the XPath string-value of this node.
 String getUniquePath(Element context)
Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
 String getXPathNameStep()
Returns the XPath expression to match this Elements name which is getQualifiedName() if there is a namespace prefix defined or if no namespace is present then it is getName() or if a namespace is defined with no prefix then the expression is [name()='X'] where X = getName().
 Node getXPathResult(int index)
Returns a node at the given index suitable for an XPath result set.
 boolean hasMixedContent()
Returns true if this Element has mixed content.
 int indexOf(Node node)
Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.
 boolean isRootElement()
DOCUMENT ME!
 boolean isTextOnly()
Returns true if this Element has text only content.
 Node node(int index)
Returns the Node at the specified index position.
 int nodeCount()
Returns the number of Node instances that this branch contains.
 Iterator nodeIterator()
Returns an iterator through the content nodes of this branch
 void normalize()
Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
 ProcessingInstruction processingInstruction(String target)
DOCUMENT ME!
 List processingInstructions()
Returns a list of all the processing instructions in this branch.
 List processingInstructions(String target)
Returns a list of the processing instructions for the given target.
 boolean remove(Attribute attribute)
Removes the given Attribute from this element.
 boolean remove(CDATA cdata)
Removes the given CDATA if the node is an immediate child of this element.
 boolean remove(Comment comment)
Removes the given Comment if the node is an immediate child of this branch.
 boolean remove(Element element)
Removes the given Element if the node is an immediate child of this branch.
 boolean remove(Entity entity)
Removes the given Entity if the node is an immediate child of this element.
 boolean remove(Namespace namespace)
Removes the given Namespace if the node is an immediate child of this element.
 boolean remove(Node node)
Removes the given Node if the node is an immediate child of this branch.
 boolean remove(ProcessingInstruction pi)
Removes the given ProcessingInstruction if the node is an immediate child of this branch.
 boolean remove(Text text)
Removes the given Text if the node is an immediate child of this element.
protected  boolean removeNode(Node node)
 boolean removeProcessingInstruction(String target)
Removes the processing instruction for the given target if it exists
 void setAttributes(Attributes attributes, NamespaceStack namespaceStack, boolean noNamespaceAttributes)
This method provides a more optimal way of setting all the attributes on an Element particularly for use in SAXReader.
 void setAttributeValue(QName qName, String value)
Deprecated. As of version 0.5. Please use addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
 void setAttributeValue(String name, String value)
Deprecated. As of version 0.5. Please use addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
 void setData(Object data)
Sets the data value of this element if this element supports data binding or calls setText(java.lang.String)if it doesn't
 void setName(String name)
Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
 void setNamespace(Namespace namespace)
 void setText(String text)
Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
 String toString()
 void write(Writer out)
write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentList, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getNodeTypeName, getParent, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Element
getQName, getText, getTextTrim, setAttributes, setQName
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, clearContent, content, elementByID, setContent, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, supportsParent, valueOf

Field Detail

EMPTY_LIST

protected static final List EMPTY_LIST

EMPTY_ITERATOR

protected static final Iterator EMPTY_ITERATOR

VERBOSE_TOSTRING

protected static final boolean VERBOSE_TOSTRING
See Also:
Constant Field Values

USE_STRINGVALUE_SEPARATOR

protected static final boolean USE_STRINGVALUE_SEPARATOR
See Also:
Constant Field Values
Constructor Detail

AbstractElement

public AbstractElement()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

isRootElement

public boolean isRootElement()
Description copied from interface: Element
DOCUMENT ME!

Specified by:
isRootElement in interface Element
Returns:
true if this element is the root element of a document and this element supports the parent relationship else false.

setName

public void setName(String name)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setName in interface Node
Overrides:
setName in class AbstractNode

setNamespace

public void setNamespace(Namespace namespace)

getXPathNameStep

public String getXPathNameStep()
Returns the XPath expression to match this Elements name which is getQualifiedName() if there is a namespace prefix defined or if no namespace is present then it is getName() or if a namespace is defined with no prefix then the expression is [name()='X'] where X = getName().

Returns:
DOCUMENT ME!

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer out)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)

accept method is the Visitor Pattern method.

Specified by:
accept in interface Node
Parameters:
visitor - Visitor is the visitor.

toString

public String toString()

getNamespace

public Namespace getNamespace()
Description copied from interface: Element

Returns the Namespace of this element if one exists otherwise Namespace.NO_NAMESPACE is returned.

Specified by:
getNamespace in interface Element
Returns:
the Namespace associated with this element

getName

public String getName()
Description copied from interface: Node

getName returns the name of this node. This is the XML local name of the element, attribute, entity or processing instruction. For CDATA and Text nodes this method will return null.

Specified by:
getName in interface Node
Overrides:
getName in class AbstractNode

getNamespacePrefix

public String getNamespacePrefix()
Description copied from interface: Element

Returns the namespace prefix of this element if one exists otherwise an empty String is returned.

Specified by:
getNamespacePrefix in interface Element
Returns:
the prefix of the Namespace of this element or an empty String

getNamespaceURI

public String getNamespaceURI()
Description copied from interface: Element

Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.

Specified by:
getNamespaceURI in interface Element
Returns:
the URI for the Namespace of this element or an empty String

getQualifiedName

public String getQualifiedName()
Description copied from interface: Element

Returns the fully qualified name of this element. This will be the same as the value returned from Node.getName()if this element has no namespace attached to this element or an expression of the form

 getNamespacePrefix() + ":" + getName()
will be returned.

Specified by:
getQualifiedName in interface Element
Returns:
the fully qualified name of the element.

getData

public Object getData()
Description copied from interface: Element
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Element.getText()

Specified by:
getData in interface Element
Returns:
DOCUMENT ME!

setData

public void setData(Object data)
Description copied from interface: Element
Sets the data value of this element if this element supports data binding or calls Node.setText(java.lang.String)if it doesn't

Specified by:
setData in interface Element
Parameters:
data - DOCUMENT ME!

node

public Node node(int index)
Description copied from interface: Branch
Returns the Node at the specified index position.

Specified by:
node in interface Branch
Overrides:
node in class AbstractBranch

indexOf

public int indexOf(Node node)
Description copied from interface: Branch
Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.

Specified by:
indexOf in interface Branch
Overrides:
indexOf in class AbstractBranch

nodeCount

public int nodeCount()
Description copied from interface: Branch
Returns the number of Node instances that this branch contains.

Specified by:
nodeCount in interface Branch
Overrides:
nodeCount in class AbstractBranch

nodeIterator

public Iterator nodeIterator()
Description copied from interface: Branch
Returns an iterator through the content nodes of this branch

Specified by:
nodeIterator in interface Branch
Overrides:
nodeIterator in class AbstractBranch

element

public Element element(String name)
Description copied from interface: Element
Returns the first element for the given local name and any namespace.

Specified by:
element in interface Element
Parameters:
name - DOCUMENT ME!
Returns:
the first element with the given local name

element

public Element element(QName qName)
Description copied from interface: Element
Returns the first element for the given fully qualified name.

Specified by:
element in interface Element
Parameters:
qName - is the fully qualified name to search for
Returns:
the first element with the given fully qualified name

element

public Element element(String name,
                       Namespace namespace)

elements

public List elements()
Description copied from interface: Element

Returns the elements contained in this element. If this element does not contain any elements then this method returns an empty list. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
elements in interface Element
Returns:
a list of all the elements in this element.

elements

public List elements(String name)
Description copied from interface: Element

Returns the elements contained in this element with the given local name and any namespace. If no elements are found then this method returns an empty list. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
elements in interface Element
Parameters:
name - DOCUMENT ME!
Returns:
a list of all the elements in this element for the given local name

elements

public List elements(QName qName)
Description copied from interface: Element

Returns the elements contained in this element with the given fully qualified name. If no elements are found then this method returns an empty list. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
elements in interface Element
Parameters:
qName - is the fully qualified name to search for
Returns:
a list of all the elements in this element for the given fully qualified name.

elements

public List elements(String name,
                     Namespace namespace)

elementIterator

public Iterator elementIterator()
Description copied from interface: Element
Returns an iterator over all this elements child elements.

Specified by:
elementIterator in interface Element
Returns:
an iterator over the contained elements

elementIterator

public Iterator elementIterator(String name)
Description copied from interface: Element
Returns an iterator over the elements contained in this element which match the given local name and any namespace.

Specified by:
elementIterator in interface Element
Parameters:
name - DOCUMENT ME!
Returns:
an iterator over the contained elements matching the given local name

elementIterator

public Iterator elementIterator(QName qName)
Description copied from interface: Element
Returns an iterator over the elements contained in this element which match the given fully qualified name.

Specified by:
elementIterator in interface Element
Parameters:
qName - is the fully qualified name to search for
Returns:
an iterator over the contained elements matching the given fully qualified name

elementIterator

public Iterator elementIterator(String name,
                                Namespace ns)

attributes

public List attributes()
Description copied from interface: Element

Returns the Attributeinstances this element contains as a backed Listso that the attributes may be modified directly using the Listinterface. The List is backed by the Element so that changes to the list are reflected in the element and vice versa.

Specified by:
attributes in interface Element
Returns:
the attributes that this element contains as a List

attributeIterator

public Iterator attributeIterator()
Description copied from interface: Element
DOCUMENT ME!

Specified by:
attributeIterator in interface Element
Returns:
an iterator over the attributes of this element

attribute

public Attribute attribute(int index)
Description copied from interface: Element
Returns the attribute at the specified indexGets the

Specified by:
attribute in interface Element
Parameters:
index - DOCUMENT ME!
Returns:
the attribute at the specified index where index >= 0 and index < number of attributes or throws an IndexOutOfBoundsException if the index is not within the allowable range

attributeCount

public int attributeCount()
Description copied from interface: Element
DOCUMENT ME!

Specified by:
attributeCount in interface Element
Returns:
the number of attributes this element contains

attribute

public Attribute attribute(String name)
Description copied from interface: Element
Returns the attribute with the given name

Specified by:
attribute in interface Element
Parameters:
name - DOCUMENT ME!
Returns:
the attribute for the given local name in any namespace. If there are more than one attributes with the given local name in different namespaces then the first one is returned.

attribute

public Attribute attribute(QName qName)
Description copied from interface: Element
DOCUMENT ME!

Specified by:
attribute in interface Element
Parameters:
qName - is the fully qualified name
Returns:
the attribute for the given fully qualified name or null if it could not be found.

attribute

public Attribute attribute(String name,
                           Namespace namespace)

setAttributes

public void setAttributes(Attributes attributes,
                          NamespaceStack namespaceStack,
                          boolean noNamespaceAttributes)
This method provides a more optimal way of setting all the attributes on an Element particularly for use in SAXReader.

Parameters:
attributes - DOCUMENT ME!
namespaceStack - DOCUMENT ME!
noNamespaceAttributes - DOCUMENT ME!

attributeValue

public String attributeValue(String name)
Description copied from interface: Element

This returns the attribute value for the attribute with the given name and any namespace or null if there is no such attribute or the empty string if the attribute value is empty.

Specified by:
attributeValue in interface Element
Parameters:
name - is the name of the attribute value to be returnd
Returns:
the value of the attribute, null if the attribute does not exist or the empty string

attributeValue

public String attributeValue(QName qName)
Description copied from interface: Element

This returns the attribute value for the attribute with the given fully qualified name or null if there is no such attribute or the empty string if the attribute value is empty.

Specified by:
attributeValue in interface Element
Parameters:
qName - is the fully qualified name
Returns:
the value of the attribute, null if the attribute does not exist or the empty string

attributeValue

public String attributeValue(String name,
                             String defaultValue)
Description copied from interface: Element

This returns the attribute value for the attribute with the given name and any namespace or the default value if there is no such attribute value.

Specified by:
attributeValue in interface Element
Parameters:
name - is the name of the attribute value to be returnd
defaultValue - is the default value to be returned if the attribute has no value defined.
Returns:
the value of the attribute or the defaultValue if the attribute has no value defined.

attributeValue

public String attributeValue(QName qName,
                             String defaultValue)
Description copied from interface: Element

This returns the attribute value for the attribute with the given fully qualified name or the default value if there is no such attribute value.

Specified by:
attributeValue in interface Element
Parameters:
qName - is the fully qualified name
defaultValue - is the default value to be returned if the attribute has no value defined.
Returns:
the value of the attribute or the defaultValue if the attribute has no value defined.

setAttributeValue

public void setAttributeValue(String name,
                              String value)
Deprecated. As of version 0.5. Please use addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!

DOCUMENT ME!

Specified by:
setAttributeValue in interface Element
Parameters:
name - DOCUMENT ME!
value - DOCUMENT ME!

setAttributeValue

public void setAttributeValue(QName qName,
                              String value)
Deprecated. As of version 0.5. Please use addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!

DOCUMENT ME!

Specified by:
setAttributeValue in interface Element
Parameters:
qName - DOCUMENT ME!
value - DOCUMENT ME!

add

public void add(Attribute attribute)
Description copied from interface: Element
Adds the given Attribute to this element. If the given node already has a parent defined then an IllegalAddException will be thrown. Attributes with null values are silently ignored.

If the value of the attribute is null then this method call will remove any attributes with the QName of this attribute.

Specified by:
add in interface Element
Parameters:
attribute - is the attribute to be added

remove

public boolean remove(Attribute attribute)
Description copied from interface: Element
Removes the given Attribute from this element.

Specified by:
remove in interface Element
Parameters:
attribute - is the attribute to be removed
Returns:
true if the attribute was removed

processingInstructions

public List processingInstructions()
Description copied from interface: Branch

Returns a list of all the processing instructions in this branch. The list is backed by this branch so that changes to the list will be reflected in the branch but the reverse is not the case.

Specified by:
processingInstructions in interface Branch
Returns:
a backed list of the processing instructions

processingInstructions

public List processingInstructions(String target)
Description copied from interface: Branch

Returns a list of the processing instructions for the given target. The list is backed by this branch so that changes to the list will be reflected in the branch but the reverse is not the case.

Specified by:
processingInstructions in interface Branch
Parameters:
target - DOCUMENT ME!
Returns:
a backed list of the processing instructions

processingInstruction

public ProcessingInstruction processingInstruction(String target)
Description copied from interface: Branch
DOCUMENT ME!

Specified by:
processingInstruction in interface Branch
Parameters:
target - DOCUMENT ME!
Returns:
the processing instruction for the given target

removeProcessingInstruction

public boolean removeProcessingInstruction(String target)
Description copied from interface: Branch
Removes the processing instruction for the given target if it exists

Specified by:
removeProcessingInstruction in interface Branch
Parameters:
target - DOCUMENT ME!
Returns:
true if a processing instruction was removed else false

getXPathResult

public Node getXPathResult(int index)
Description copied from interface: Element
Returns a node at the given index suitable for an XPath result set. This means the resulting Node will either be null or it will support the parent relationship.

Specified by:
getXPathResult in interface Element
Parameters:
index - DOCUMENT ME!
Returns:
the Node for the given index which will support the parent relationship or null if there is not a node at the given index.

addAttribute

public Element addAttribute(String name,
                            String value)
Description copied from interface: Element

Adds the attribute value of the given local name. If an attribute already exists for the given name it will be replaced. Attributes with null values are silently ignored. If the value of the attribute is null then this method call will remove any attributes with the given name.

Specified by:
addAttribute in interface Element
Parameters:
name - is the name of the attribute whose value is to be added or updated
value - is the attribute's value
Returns:
this Element instance.

addAttribute

public Element addAttribute(QName qName,
                            String value)
Description copied from interface: Element

Adds the attribute value of the given fully qualified name. If an attribute already exists for the given name it will be replaced. Attributes with null values are silently ignored. If the value of the attribute is null then this method call will remove any attributes with the given name.

Specified by:
addAttribute in interface Element
Parameters:
qName - is the fully qualified name of the attribute whose value is to be added or updated
value - is the attribute's value
Returns:
this Element instance.

addCDATA

public Element addCDATA(String cdata)
Description copied from interface: Element
Adds a new CDATA node with the given text to this element.

Specified by:
addCDATA in interface Element
Parameters:
cdata - is the text for the CDATA node.
Returns:
this Element instance.

addComment

public Element addComment(String comment)
Description copied from interface: Element
Adds a new Comment node with the given text to this element.

Specified by:
addComment in interface Element
Parameters:
comment - is the text for the Comment node.
Returns:
this Element instance.

addElement

public Element addElement(String name)
Description copied from interface: Branch
Adds a new Element node with the given name to this branch and returns a reference to the new node.

Specified by:
addElement in interface Branch
Overrides:
addElement in class AbstractBranch

addEntity

public Element addEntity(String name,
                         String text)
Description copied from interface: Element
Adds a new Entity node with the given name and text to this element and returns a reference to the new node.

Specified by:
addEntity in interface Element
Parameters:
name - is the name for the Entity node.
text - is the text for the Entity node.
Returns:
this Element instance.

addNamespace

public Element addNamespace(String prefix,
                            String uri)
Description copied from interface: Element
Adds a namespace to this element for use by its child content

Specified by:
addNamespace in interface Element
Parameters:
prefix - is the prefix to use, which should not be null or blank
uri - is the namespace URI
Returns:
this Element instance.

addProcessingInstruction

public Element addProcessingInstruction(String target,
                                        String data)
Description copied from interface: Element
Adds a processing instruction for the given target

Specified by:
addProcessingInstruction in interface Element
Parameters:
target - is the target of the processing instruction
data - is the textual data (key/value pairs) of the processing instruction
Returns:
this Element instance.

addProcessingInstruction

public Element addProcessingInstruction(String target,
                                        Map data)
Description copied from interface: Element
Adds a processing instruction for the given target

Specified by:
addProcessingInstruction in interface Element
Parameters:
target - is the target of the processing instruction
data - is a Map of the key / value pairs of the processing instruction
Returns:
this Element instance.

addText

public Element addText(String text)
Description copied from interface: Element
Adds a new Text node with the given text to this element.

Specified by:
addText in interface Element
Parameters:
text - is the text for the Text node.
Returns:
this Element instance.

add

public void add(Node node)
Description copied from interface: Branch
Adds the given Node or throws IllegalAddException if the given node is not of a valid type. This is a polymorphic method which will call the typesafe method for the node type such as add(Element) or add(Comment).

Specified by:
add in interface Branch
Overrides:
add in class AbstractBranch

remove

public boolean remove(Node node)
Description copied from interface: Branch
Removes the given Node if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead. This is a polymorphic method which will call the typesafe method for the node type such as remove(Element) or remove(Comment).

Specified by:
remove in interface Branch
Overrides:
remove in class AbstractBranch

add

public void add(CDATA cdata)
Description copied from interface: Element
Adds the given CDATA to this element. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Element
Parameters:
cdata - is the CDATA to be added

add

public void add(Comment comment)
Description copied from interface: Branch
Adds the given Comment to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Branch
Overrides:
add in class AbstractBranch

add

public void add(Element element)
Description copied from interface: Branch
Adds the given Element to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Branch
Overrides:
add in class AbstractBranch

add

public void add(Entity entity)
Description copied from interface: Element
Adds the given Entity to this element. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Element
Parameters:
entity - is the entity to be added

add

public void add(Namespace namespace)
Description copied from interface: Element
Adds the given Namespace to this element. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Element
Parameters:
namespace - is the namespace to be added

add

public void add(ProcessingInstruction pi)
Description copied from interface: Branch
Adds the given ProcessingInstruction to this branch. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Branch
Overrides:
add in class AbstractBranch

add

public void add(Text text)
Description copied from interface: Element
Adds the given Text to this element. If the given node already has a parent defined then an IllegalAddException will be thrown.

Specified by:
add in interface Element
Parameters:
text - is the text to be added

remove

public boolean remove(CDATA cdata)
Description copied from interface: Element
Removes the given CDATA if the node is an immediate child of this element. If the given node is not an immediate child of this element then the Node.detach()method should be used instead.

Specified by:
remove in interface Element
Parameters:
cdata - is the CDATA to be removed
Returns:
true if the cdata was removed

remove

public boolean remove(Comment comment)
Description copied from interface: Branch
Removes the given Comment if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Specified by:
remove in interface Branch
Overrides:
remove in class AbstractBranch

remove

public boolean remove(Element element)
Description copied from interface: Branch
Removes the given Element if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Specified by:
remove in interface Branch
Overrides:
remove in class AbstractBranch

remove

public boolean remove(Entity entity)
Description copied from interface: Element
Removes the given Entity if the node is an immediate child of this element. If the given node is not an immediate child of this element then the Node.detach()method should be used instead.

Specified by:
remove in interface Element
Parameters:
entity - is the entity to be removed
Returns:
true if the entity was removed

remove

public boolean remove(Namespace namespace)
Description copied from interface: Element
Removes the given Namespace if the node is an immediate child of this element. If the given node is not an immediate child of this element then the Node.detach()method should be used instead.

Specified by:
remove in interface Element
Parameters:
namespace - is the namespace to be removed
Returns:
true if the namespace was removed

remove

public boolean remove(ProcessingInstruction pi)
Description copied from interface: Branch
Removes the given ProcessingInstruction if the node is an immediate child of this branch. If the given node is not an immediate child of this branch then the Node.detach()method should be used instead.

Specified by:
remove in interface Branch
Overrides:
remove in class AbstractBranch

remove

public boolean remove(Text text)
Description copied from interface: Element
Removes the given Text if the node is an immediate child of this element. If the given node is not an immediate child of this element then the Node.detach()method should be used instead.

Specified by:
remove in interface Element
Parameters:
text - is the text to be removed
Returns:
true if the text was removed

hasMixedContent

public boolean hasMixedContent()
Description copied from interface: Element

Returns true if this Element has mixed content. Mixed content means that an element contains both textual data and child elements.

Specified by:
hasMixedContent in interface Element
Returns:
true if this element contains mixed content.

isTextOnly

public boolean isTextOnly()
Description copied from interface: Element

Returns true if this Element has text only content.

Specified by:
isTextOnly in interface Element
Returns:
true if this element is empty or only contains text content.

setText

public void setText(String text)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setText in interface Node
Overrides:
setText in class AbstractNode

getStringValue

public String getStringValue()
Description copied from interface: Element
Returns the XPath string-value of this node. The behaviour of this method is defined in the XPath specification . This method returns the string-value of all the contained Text,CDATA,Entityand Element nodes all appended together.

Specified by:
getStringValue in interface Element
Overrides:
getStringValue in class AbstractNode

normalize

public void normalize()
Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes. This can be used to ensure that the DOM view of a document is the same as if it were saved and re-loaded, and is useful when operations (such as XPointer lookups) that depend on a particular document tree structure are to be used.In cases where the document contains CDATASections, the normalize operation alone may not be sufficient, since XPointers do not differentiate between Text nodes and CDATASection nodes.

Specified by:
normalize in interface Branch
Since:
DOM Level 2

elementText

public String elementText(String name)
Specified by:
elementText in interface Element

elementText

public String elementText(QName qName)
Specified by:
elementText in interface Element

elementTextTrim

public String elementTextTrim(String name)
Specified by:
elementTextTrim in interface Element

elementTextTrim

public String elementTextTrim(QName qName)
Specified by:
elementTextTrim in interface Element

appendAttributes

public void appendAttributes(Element element)
Description copied from interface: Element
Appends the attributes of the given element to me. This method behaves like the Collection.addAll(java.util.Collection) method.

Specified by:
appendAttributes in interface Element
Parameters:
element - is the element whose attributes will be added to me.

createCopy

public Element createCopy()

This returns a deep clone of this element. The new element is detached from its parent, and getParent() on the clone will return null.

Specified by:
createCopy in interface Element
Returns:
the clone of this element

createCopy

public Element createCopy(String name)
Description copied from interface: Element

Creates a deep copy of this element with the given local name The new element is detached from its parent, and getParent() on the clone will return null.

Specified by:
createCopy in interface Element
Parameters:
name - DOCUMENT ME!
Returns:
a new deep copy Element

createCopy

public Element createCopy(QName qName)
Description copied from interface: Element

Creates a deep copy of this element with the given fully qualified name. The new element is detached from its parent, and getParent() on the clone will return null.

Specified by:
createCopy in interface Element
Parameters:
qName - DOCUMENT ME!
Returns:
a new deep copy Element

getQName

public QName getQName(String qualifiedName)
Description copied from interface: Element

Returns the QName for the given qualified name, using the namespace URI in scope for the given prefix of the qualified name or the default namespace if the qualified name has no prefix.

Specified by:
getQName in interface Element
Parameters:
qualifiedName - DOCUMENT ME!
Returns:
the QName for the given qualified name

getNamespaceForPrefix

public Namespace getNamespaceForPrefix(String prefix)
Description copied from interface: Element

Returns the Namespace which is mapped to the given prefix or null if it could not be found.

Specified by:
getNamespaceForPrefix in interface Element
Parameters:
prefix - DOCUMENT ME!
Returns:
the Namespace associated with the given prefix

getNamespaceForURI

public Namespace getNamespaceForURI(String uri)
Description copied from interface: Element

Returns the Namespace which is mapped to the given URI or null if it could not be found. If there is more than one Namespace mapped to the URI, which of them will be returned is undetermined.

Specified by:
getNamespaceForURI in interface Element
Parameters:
uri - DOCUMENT ME!
Returns:
the Namespace associated with the given URI

getNamespacesForURI

public List getNamespacesForURI(String uri)
Description copied from interface: Element

Returns the all namespaces which are mapped to the given URI or an empty list if no such namespaces could be found.

Specified by:
getNamespacesForURI in interface Element
Parameters:
uri - DOCUMENT ME!
Returns:
the namespaces associated with the given URI

declaredNamespaces

public List declaredNamespaces()
Description copied from interface: Element

Returns all the namespaces declared by this element. If no namespaces are declared for this element then an empty list will be returned. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
declaredNamespaces in interface Element
Returns:
a list of namespaces declared for this element.

additionalNamespaces

public List additionalNamespaces()
Description copied from interface: Element

Returns any additional namespaces declarations for this element other than namespace returned via the Element.getNamespace()method. If no additional namespace declarations are present for this element then an empty list will be returned. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
additionalNamespaces in interface Element
Returns:
a list of any additional namespace declarations.

additionalNamespaces

public List additionalNamespaces(String defaultNamespaceURI)

ensureAttributesCapacity

public void ensureAttributesCapacity(int minCapacity)
Ensures that the list of attributes has the given size

Parameters:
minCapacity - DOCUMENT ME!

createElement

protected Element createElement(String name)

createElement

protected Element createElement(QName qName)

addNode

protected void addNode(Node node)
Specified by:
addNode in class AbstractBranch

addNode

protected void addNode(int index,
                       Node node)
Specified by:
addNode in class AbstractBranch

addNewNode

protected void addNewNode(Node node)
Like addNode() but does not require a parent check

Parameters:
node - DOCUMENT ME!

addNewNode

protected void addNewNode(int index,
                          Node node)

removeNode

protected boolean removeNode(Node node)
Specified by:
removeNode in class AbstractBranch

childAdded

protected void childAdded(Node node)
Called when a new child node is added to create any parent relationships

Specified by:
childAdded in class AbstractBranch
Parameters:
node - DOCUMENT ME!

childRemoved

protected void childRemoved(Node node)
Description copied from class: AbstractBranch
Called when a child node has been removed to allow any parent relationships to be deleted or events to be fired.

Specified by:
childRemoved in class AbstractBranch
Parameters:
node - DOCUMENT ME!

attributeList

protected abstract List attributeList()
DOCUMENT ME!

Returns:
the internal List used to store attributes or creates one if one is not available

attributeList

protected abstract List attributeList(int attributeCount)
DOCUMENT ME!

Parameters:
attributeCount - DOCUMENT ME!
Returns:
the internal List used to store attributes or creates one with the specified size if one is not available

getDocumentFactory

protected DocumentFactory getDocumentFactory()
Overrides:
getDocumentFactory in class AbstractNode

createAttributeList

protected List createAttributeList()
A Factory Method pattern which creates a List implementation used to store attributes

Returns:
DOCUMENT ME!

createAttributeList

protected List createAttributeList(int size)
A Factory Method pattern which creates a List implementation used to store attributes

Parameters:
size - DOCUMENT ME!
Returns:
DOCUMENT ME!

createSingleIterator

protected Iterator createSingleIterator(Object result)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractEntity (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractEntity

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractEntity
All Implemented Interfaces:
Cloneable, Entity, Node, Serializable
Direct Known Subclasses:
FlyweightEntity
public abstract class AbstractEntity
extends AbstractNode
implements Entity

AbstractEntity is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.15 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractEntity()
Method Summary
void | accept(Visitor visitor) accept is the method used in the Visitor Pattern.
String | asXML() asXML returns the textual XML representation of this node.
short | getNodeType() Returns the code according to the type of node.
String | getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | getStringValue() Returns the XPath string-value of this node.
String | getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
String | toString()
void | write(Writer writer) write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeTypeName, getParent, getPath, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf

Constructor Detail

AbstractEntity

public AbstractEntity()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

toString

public String toString()

getStringValue

public String getStringValue()
Description copied from interface: Node
Returns the XPath string-value of this node. The behaviour of this method is defined in the XPath specification .

Specified by:
getStringValue in interface Node
Overrides:
getStringValue in class AbstractNode

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer writer)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)
Description copied from interface: Node

accept is the method used in the Visitor Pattern.

Specified by:
accept in interface Node
Parameters:
visitor - is the visitor in the Visitor Pattern
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractNode (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractNode

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
All Implemented Interfaces:
Cloneable, Node, Serializable
Direct Known Subclasses:
AbstractAttribute, AbstractBranch, AbstractCharacterData, AbstractDocumentType, AbstractEntity, AbstractProcessingInstruction, Namespace
public abstract class AbstractNode
extends Object
implements Node, Cloneable, Serializable

AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.31 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static String[] NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractNode()
Method Summary
Node | asXPathResult(Element parent) asXPathResult returns a version of this node which is capable of being an XPath result.
Object | clone() clone will return a deep clone or if this node is read-only then clone will return the same instance.
Pattern | createPattern(String patternText)
XPath | createXPath(String xpathExpression) createXPath creates an XPath object for the given xpathExpression.
NodeFilter | createXPathFilter(String patternText)
protected Node | createXPathResult(Element parent)
Node | detach() Removes this node from its parent if there is one.
Document | getDocument() getDocument returns the Document that this Node is part of if this node supports the parent relationship.
protected DocumentFactory | getDocumentFactory()
String | getName() getName returns the name of this node.
short | getNodeType() Returns the code according to the type of node.
String | getNodeTypeName() DOCUMENT ME!
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
String | getPath() Returns the XPath expression which will return a node set containing the given node such as /a/b/@c.
String | getStringValue() Returns the XPath string-value of this node.
String | getText() Returns the text of this node.
String | getUniquePath() Returns the XPath expression which will return a nodeset of one node which is the current node.
boolean | hasContent() hasContent returns true if this node is a Branch (either an Element or a Document) and it contains at least one content node such as a child Element or Text node.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
boolean | matches(String patternText) matches returns true if evaluating the given XPath expression on this node returns a non-empty node set containing this node.
Number | numberValueOf(String xpathExpression) numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results in a number, or null if the result is not a number.
List | selectNodes(String xpathExpression) selectNodes evaluates an XPath expression and returns the result as a List of Node instances or String instances depending on the XPath expression.
List | selectNodes(String xpathExpression, String comparisonXPathExpression) selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.
List | selectNodes(String xpathExpression, String comparisonXPathExpression, boolean removeDuplicates) selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.
Object | selectObject(String xpathExpression) selectObject evaluates an XPath expression and returns the result as an Object.
Node | selectSingleNode(String xpathExpression) selectSingleNode evaluates an XPath expression and returns the result as a single Node instance.
void | setDocument(Document document) setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setName(String name) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setText(String text) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
String | valueOf(String xpathExpression) valueOf evaluates an XPath expression and returns the textual representation of the results the XPath string-value of this node.
void | write(Writer writer) write writes this node as the default XML notation for this node.
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.dom4j.Node
accept, asXML, getPath, getUniquePath

Field Detail

NODE_TYPE_NAMES

protected static final String[] NODE_TYPE_NAMES
Constructor Detail

AbstractNode

public AbstractNode()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Returns:
a W3C DOM complient code for the node type such as ELEMENT_NODE or ATTRIBUTE_NODE

getNodeTypeName

public String getNodeTypeName()
Description copied from interface: Node
DOCUMENT ME!

Specified by:
getNodeTypeName in interface Node
Returns:
the name of the type of node such as "Document", "Element", "Attribute" or "Text"

getDocument

public Document getDocument()
Description copied from interface: Node

getDocument returns the Document that this Node is part of if this node supports the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getDocument in interface Node
Returns:
the document of this node or null if this feature is not supported or the node is not associated with a Document

setDocument

public void setDocument(Document document)
Description copied from interface: Node

setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside a Document implementation method and is not intended for general use.

Specified by:
setDocument in interface Node
Parameters:
document - is the new document of this node.

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Returns:
the parent of this node or null if it is the root of the tree or the parent relationship is not supported.

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Parameters:
parent - is the new parent of this node.

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Returns:
true if this node supports the parent relationship or false it is not supported

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Returns:
true if this Node is read only and cannot be modified otherwise false.

hasContent

public boolean hasContent()
Description copied from interface: Node

hasContent returns true if this node is a Branch (either an Element or a Document) and it contains at least one content node such as a child Element or Text node.

Specified by:
hasContent in interface Node
Returns:
true if this Node is a Branch with a nodeCount() of one or more.

getPath

public String getPath()
Description copied from interface: Node

Returns the XPath expression which will return a node set containing the given node such as /a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Returns:
the XPath expression which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath()
Description copied from interface: Node

Returns the XPath expression which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Returns:
the XPath expression which will return a nodeset containing just this node.

clone

public Object clone()
Description copied from interface: Node

clone will return a deep clone or if this node is read-only then clone will return the same instance.

Specified by:
clone in interface Node

detach

public Node detach()
Description copied from interface: Node

Removes this node from its parent if there is one. If this node is the root element of a document then it is removed from the document as well.

This method is useful if you want to remove a node from its source document and add it to another document. For example

Node node = ...; Element someOtherElement = ...; someOtherElement.add( node.detach() );

Specified by:
detach in interface Node
Returns:
the node that has been removed from its parent node if any and its document if any.

getName

public String getName()
Description copied from interface: Node

getName returns the name of this node. This is the XML local name of the element, attribute, entity or processing instruction. For CDATA and Text nodes this method will return null.

Specified by:
getName in interface Node
Returns:
the XML name of this node

setName

public void setName(String name)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setName in interface Node
Parameters:
name - is the new name of this node

getText

public String getText()
Description copied from interface: Node

Returns the text of this node.

Specified by:
getText in interface Node
Returns:
the text for this node.

getStringValue

public String getStringValue()
Description copied from interface: Node
Returns the XPath string-value of this node. The behaviour of this method is defined in the XPath specification .

Specified by:
getStringValue in interface Node
Returns:
the text from all the child Text and Element nodes appended together.

setText

public void setText(String text)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setText in interface Node
Parameters:
text - is the new textual value of this node

write

public void write(Writer writer)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Parameters:
writer - is the Writer to output the XML to
Throws:
IOException - DOCUMENT ME!

selectObject

public Object selectObject(String xpathExpression)
Description copied from interface: Node

selectObject evaluates an XPath expression and returns the result as an Object. The object returned can either be a List of one or more Nodeinstances or a scalar object like a Stringor a Numberinstance depending on the XPath expression.

Specified by:
selectObject in interface Node
Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the value of the XPath expression as a Listof Node instances, a Stringor a Numberinstance depending on the XPath expression.

selectNodes

public List selectNodes(String xpathExpression)
Description copied from interface: Node

selectNodes evaluates an XPath expression and returns the result as a List of Node instances or String instances depending on the XPath expression.

Specified by:
selectNodes in interface Node
Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the list of Node or String instances depending on the XPath expression

selectNodes

public List selectNodes(String xpathExpression,
                        String comparisonXPathExpression)
Description copied from interface: Node

selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.

Specified by:
selectNodes in interface Node
Parameters:
xpathExpression - is the XPath expression to be evaluated
comparisonXPathExpression - is the XPath expression used to compare the results by for sorting
Returns:
the list of Node instances sorted by the comparisonXPathExpression

selectNodes

public List selectNodes(String xpathExpression,
                        String comparisonXPathExpression,
                        boolean removeDuplicates)
Description copied from interface: Node

selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.

Specified by:
selectNodes in interface Node
Parameters:
xpathExpression - is the XPath expression to be evaluated
comparisonXPathExpression - is the XPath expression used to compare the results by for sorting
removeDuplicates - if this parameter is true then duplicate values (using the comparisonXPathExpression) are removed from the result List.
Returns:
the list of Node instances sorted by the comparisonXPathExpression

selectSingleNode

public Node selectSingleNode(String xpathExpression)
Description copied from interface: Node

selectSingleNode evaluates an XPath expression and returns the result as a single Node instance.

Specified by:
selectSingleNode in interface Node
Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the Node matching the XPath expression

valueOf

public String valueOf(String xpathExpression)
Description copied from interface: Node

valueOf evaluates an XPath expression and returns the textual representation of the results the XPath string-value of this node. The string-value for a given node type is defined in the XPath specification .

Specified by:
valueOf in interface Node
Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the string-value representation of the results of the XPath expression

numberValueOf

public Number numberValueOf(String xpathExpression)
Description copied from interface: Node

numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results in a number, or null if the result is not a number.

Specified by:
numberValueOf in interface Node
Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
the numeric result of the XPath expression or null if the result is not a number.

matches

public boolean matches(String patternText)
Description copied from interface: Node

matches returns true if evaluating the given XPath expression on this node returns a non-empty node set containing this node.

This method does not behave like the <xsl:if> element - if you want that behaviour, to evaluate if an XPath expression matches something, then you can use the following code to be equivalent...

if ( node.selectSingleNode( "/some/path" ) != nulll )

Specified by:
matches in interface Node
Parameters:
patternText - is an XPath expression
Returns:
true if this node is returned by the given XPath expression

createXPath

public XPath createXPath(String xpathExpression)
Description copied from interface: Node

createXPath creates an XPath object for the given xpathExpression. The XPath object allows the variable context to be specified.

Specified by:
createXPath in interface Node
Parameters:
xpathExpression - is the XPath expression to be evaluated
Returns:
an XPath object represeting the given expression

createXPathFilter

public NodeFilter createXPathFilter(String patternText)

createPattern

public Pattern createPattern(String patternText)

asXPathResult

public Node asXPathResult(Element parent)
Description copied from interface: Node

asXPathResult returns a version of this node which is capable of being an XPath result. The result of an XPath expression should always support the parent relationship, whether the original XML tree was singly or doubly linked. If the node does not support the parent relationship then a new node will be created which is linked to its parent and returned.

Specified by:
asXPathResult in interface Node
Parameters:
parent - DOCUMENT ME!
Returns:
a Node which supports the parent relationship

getDocumentFactory

protected DocumentFactory getDocumentFactory()

createXPathResult

protected Node createXPathResult(Element parent)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractProcessingInstruction (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractProcessingInstruction

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractProcessingInstruction
All Implemented Interfaces:
Cloneable, Node, ProcessingInstruction, Serializable
Direct Known Subclasses:
FlyweightProcessingInstruction
public abstract class AbstractProcessingInstruction
extends AbstractNode
implements ProcessingInstruction

AbstractProcessingInstruction is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.17 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractProcessingInstruction()
Method Summary
void | accept(Visitor visitor) accept is the method used in the Visitor Pattern.
String | asXML() asXML returns the textual XML representation of this node.
String | getName() getName returns the name of this node.
short | getNodeType() Returns the code according to the type of node.
String | getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
protected Map | parseValues(String text) Parses the raw data of PI as a Map.
boolean | removeValue(String name)
void | setName(String name) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
void | setValue(String name, String value)
void | setValues(Map data)
String | toString()
protected String | toString(Map values) This will convert the Map to a string representation.
void | write(Writer writer) write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getNodeTypeName, getParent, getPath, getStringValue, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.ProcessingInstruction
getTarget, getText, getValue, getValues, setTarget
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf

Constructor Detail

AbstractProcessingInstruction

public AbstractProcessingInstruction()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

getPath

public String getPath(Element context)
Description copied from interface: Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c. No indexing will be used to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getPath in interface Node
Parameters:
context - is the parent context from which the relative path should start. If the context is null or the context is not an ancestor of this node then the path will be absolute and start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing at least this node.

getUniquePath

public String getUniquePath(Element context)
Description copied from interface: Node

Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node. This method will use the XPath index operator to restrict the path if multiple elements with the same name occur on the path.

Specified by:
getUniquePath in interface Node
Parameters:
context - is the parent context from which the path should start. If the context is null or the context is not an ancestor of this node then the path will start from the document and so begin with the '/' character.
Returns:
the XPath expression relative to the given context which will return a nodeset containing just this node.

toString

public String toString()

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer writer)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)
Description copied from interface: Node

accept is the method used in the Visitor Pattern.

Specified by:
accept in interface Node
Parameters:
visitor - is the visitor in the Visitor Pattern

setValue

public void setValue(String name,
                     String value)
Specified by:
setValue in interface ProcessingInstruction

setValues

public void setValues(Map data)
Specified by:
setValues in interface ProcessingInstruction

getName

public String getName()
Description copied from interface: Node

getName returns the name of this node. This is the XML local name of the element, attribute, entity or processing instruction. For CDATA and Text nodes this method will return null.

Specified by:
getName in interface Node
Overrides:
getName in class AbstractNode

setName

public void setName(String name)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setName in interface Node
Overrides:
setName in class AbstractNode

removeValue

public boolean removeValue(String name)
Specified by:
removeValue in interface ProcessingInstruction

toString

protected String toString(Map values)

This will convert the Map to a string representation.

Parameters:
values - is a Map of PI data to convert
Returns:
DOCUMENT ME!

parseValues

protected Map parseValues(String text)

Parses the raw data of PI as a Map.

Parameters:
text - String PI data to parse
Returns:
DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


AbstractText (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class AbstractText

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractText
All Implemented Interfaces:
CharacterData, Cloneable, Node, Serializable, Text
Direct Known Subclasses:
FlyweightText
public abstract class AbstractText
extends AbstractCharacterData
implements Text

AbstractText is an abstract base class for tree implementors to use for implementation inheritence.

Version:
$Revision: 1.10 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
AbstractText()
Method Summary
void | accept(Visitor visitor) accept is the method used in the Visitor Pattern.
String | asXML() asXML returns the textual XML representation of this node.
short | getNodeType() Returns the code according to the type of node.
String | toString()
void | write(Writer writer) write writes this node as the default XML notation for this node.
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText, getPath, getUniquePath
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getStringValue, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeTypeName, getParent, getPath, getPath, getStringValue, getText, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf

Constructor Detail

AbstractText

public AbstractText()
Method Detail

getNodeType

public short getNodeType()
Description copied from interface: Node
Returns the code according to the type of node. This makes processing nodes polymorphically much easier as the switch statement can be used instead of multiple if (instanceof) statements.

Specified by:
getNodeType in interface Node
Overrides:
getNodeType in class AbstractNode

toString

public String toString()

asXML

public String asXML()
Description copied from interface: Node

asXML returns the textual XML representation of this node.

Specified by:
asXML in interface Node
Returns:
the XML representation of this node

write

public void write(Writer writer)
           throws IOException
Description copied from interface: Node

write writes this node as the default XML notation for this node. If you wish to control the XML output (such as for pretty printing, changing the indentation policy etc.) then please use XMLWriter or its derivations.

Specified by:
write in interface Node
Overrides:
write in class AbstractNode
Throws:
IOException

accept

public void accept(Visitor visitor)
Description copied from interface: Node

accept is the method used in the Visitor Pattern.

Specified by:
accept in interface Node
Parameters:
visitor - is the visitor in the Visitor Pattern
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BackedList (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class BackedList

java.lang.Object
    extended by java.util.AbstractCollection
        extended by java.util.AbstractList
            extended by java.util.ArrayList
                extended by org.dom4j.tree.BackedList
All Implemented Interfaces:
Cloneable, Collection, List, RandomAccess, Serializable
public class BackedList
extends ArrayList

BackedList represents a list of content of a Branch. Changes to the list will be reflected in the branch, though changes to the branch will not be reflected in this list.

Version:
$Revision: 1.14 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
BackedList(AbstractBranch branch, List branchContent)
BackedList(AbstractBranch branch, List branchContent, int capacity)
BackedList(AbstractBranch branch, List branchContent, List initialContent)
Method Summary
void | add(int index, Object object)
boolean | add(Object object)
boolean | addAll(Collection collection)
boolean | addAll(int index, Collection collection)
void | addLocal(Object object) Performs a local addition which is not forward through to the Branch or backing list
protected Node | asNode(Object object)
void | clear()
Object | remove(int index)
boolean | remove(Object object)
Object | set(int index, Object object)
Methods inherited from class java.util.ArrayList
clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, removeRange, size, toArray, toArray, trimToSize
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, subList
Methods inherited from class java.util.AbstractCollection
containsAll, removeAll, retainAll, toString
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

Constructor Detail

BackedList

public BackedList(AbstractBranch branch,
                  List branchContent)

BackedList

public BackedList(AbstractBranch branch,
                  List branchContent,
                  int capacity)

BackedList

public BackedList(AbstractBranch branch,
                  List branchContent,
                  List initialContent)
Method Detail

add

public boolean add(Object object)

add

public void add(int index,
                Object object)

set

public Object set(int index,
                  Object object)

remove

public boolean remove(Object object)

remove

public Object remove(int index)

addAll

public boolean addAll(Collection collection)

addAll

public boolean addAll(int index,
                      Collection collection)

clear

public void clear()

addLocal

public void addLocal(Object object)
Performs a local addition which is not forward through to the Branch or backing list

Parameters:
object - DOCUMENT ME!

asNode

protected Node asNode(Object object)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


BaseElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class BaseElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
                extended by org.dom4j.tree.BaseElement
All Implemented Interfaces:
Branch, Cloneable, Element, Node, Serializable
Direct Known Subclasses:
NonLazyElement
public class BaseElement
extends AbstractElement

BaseElement is a useful base class for implemementation inheritence of an XML element.

Version:
$Revision: 1.9 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected List | attributes list of attributes
protected List | content List of content nodes.
Fields inherited from class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR, EMPTY_LIST, USE_STRINGVALUE_SEPARATOR, VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
BaseElement(QName qname)
BaseElement(String name)
BaseElement(String name, Namespace namespace)
Method Summary
protected List | attributeList() DOCUMENT ME!
protected List | attributeList(int size) DOCUMENT ME!
void | clearContent() Clears the content for this branch, removing any Node instances this branch may contain.
protected List | contentList() DOCUMENT ME!
Document | getDocument() getDocument returns the Document that this Node is part of if this node supports the parent relationship.
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
QName | getQName() Returns the QName of this element which represents the local name, the qualified name and the Namespace.
protected void | setAttributeList(List attributeList)
void | setAttributes(List attributes) Sets the attributes that this element contains
void | setContent(List content) Sets the contents of this branch as a List of Node instances.
void | setDocument(Document document) setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setQName(QName name) Sets the QName of this element which represents the local name, the qualified name and the Namespace.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.tree.AbstractElement
accept, add, add, add, add, add, add, add, add, add, addAttribute, addAttribute, addCDATA, addComment, addElement, addEntity, additionalNamespaces, additionalNamespaces, addNamespace, addNewNode, addNewNode, addNode, addNode, addProcessingInstruction, addProcessingInstruction, addText, appendAttributes, asXML, attribute, attribute, attribute, attribute, attributeCount, attributeIterator, attributes, attributeValue, attributeValue, attributeValue, attributeValue, childAdded, childRemoved, createAttributeList, createAttributeList, createCopy, createCopy, createCopy, createElement, createElement, createSingleIterator, declaredNamespaces, element, element, element, elementIterator, elementIterator, elementIterator, elementIterator, elements, elements, elements, elements, elementText, elementText, elementTextTrim, elementTextTrim, ensureAttributesCapacity, getData, getDocumentFactory, getName, getNamespace, getNamespaceForPrefix, getNamespaceForURI, getNamespacePrefix, getNamespacesForURI, getNamespaceURI, getNodeType, getPath, getQName, getQualifiedName, getStringValue, getUniquePath, getXPathNameStep, getXPathResult, hasMixedContent, indexOf, isRootElement, isTextOnly, node, nodeCount, nodeIterator, normalize, processingInstruction, processingInstructions, processingInstructions, remove, remove, remove, remove, remove, remove, remove, remove, remove, removeNode, removeProcessingInstruction, setAttributes, setAttributeValue, setAttributeValue, setData, setName, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Element
getText, getTextTrim
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, content, elementByID, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getNodeTypeName, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf

Field Detail

content

protected List content
List of content nodes.

attributes

protected List attributes
list of attributes

Constructor Detail

BaseElement

public BaseElement(String name)

BaseElement

public BaseElement(QName qname)

BaseElement

public BaseElement(String name,
                   Namespace namespace)
Method Detail

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

getDocument

public Document getDocument()
Description copied from interface: Node

getDocument returns the Document that this Node is part of if this node supports the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getDocument in interface Node
Overrides:
getDocument in class AbstractNode

setDocument

public void setDocument(Document document)
Description copied from interface: Node

setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside a Document implementation method and is not intended for general use.

Specified by:
setDocument in interface Node
Overrides:
setDocument in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

getQName

public QName getQName()
Description copied from interface: Element

Returns the QName of this element which represents the local name, the qualified name and the Namespace.

Returns:
the QName associated with this element

setQName

public void setQName(QName name)
Description copied from interface: Element

Sets the QName of this element which represents the local name, the qualified name and the Namespace.

Parameters:
name - is the QName to be associated with this element

clearContent

public void clearContent()
Description copied from interface: Branch
Clears the content for this branch, removing any Node instances this branch may contain.

setContent

public void setContent(List content)
Description copied from interface: Branch
Sets the contents of this branch as a List of Node instances.

Parameters:
content - is the list of nodes to use as the content for this branch.

setAttributes

public void setAttributes(List attributes)
Description copied from interface: Element
Sets the attributes that this element contains

Parameters:
attributes - DOCUMENT ME!

contentList

protected List contentList()
Description copied from class: AbstractBranch
DOCUMENT ME!

Specified by:
contentList in class AbstractBranch
Returns:
the internal List used to manage the content

attributeList

protected List attributeList()
Description copied from class: AbstractElement
DOCUMENT ME!

Specified by:
attributeList in class AbstractElement
Returns:
the internal List used to store attributes or creates one if one is not available

attributeList

protected List attributeList(int size)
Description copied from class: AbstractElement
DOCUMENT ME!

Specified by:
attributeList in class AbstractElement
Parameters:
size - DOCUMENT ME!
Returns:
the internal List used to store attributes or creates one with the specified size if one is not available

setAttributeList

protected void setAttributeList(List attributeList)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ContentListFacade (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class ContentListFacade

java.lang.Object
    extended by java.util.AbstractCollection
        extended by java.util.AbstractList
            extended by org.dom4j.tree.ContentListFacade
All Implemented Interfaces:
Collection, List
public class ContentListFacade
extends AbstractList

ContentListFacade represents a facade of the content of a Branch which is returned via calls to the Branch.content() method to allow users to modify the content of a Branch directly using the List interface. This list is backed by the branch such that changes to the list will be reflected in the branch and changes to the branch will be reflected in this list.

Version:
$Revision: 1.11 $
Author:
James Strachan

Field Summary
Fields inherited from class java.util.AbstractList
modCount
Constructor Summary
ContentListFacade(AbstractBranch branch, List branchContent)
Method Summary
void | add(int index, Object object)
boolean | add(Object object)
boolean | addAll(Collection collection)
boolean | addAll(int index, Collection collection)
protected Node | asNode(Object object)
void | clear()
boolean | contains(Object o)
boolean | containsAll(Collection c)
Object | get(int index)
protected List | getBackingList()
int | indexOf(Object o)
boolean | isEmpty()
int | lastIndexOf(Object o)
Object | remove(int index)
boolean | remove(Object object)
boolean | removeAll(Collection c)
Object | set(int index, Object object)
int | size()
Object[] | toArray()
Object[] | toArray(Object[] a)
Methods inherited from class java.util.AbstractList
equals, hashCode, iterator, listIterator, listIterator, removeRange, subList
Methods inherited from class java.util.AbstractCollection
retainAll, toString
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
Methods inherited from interface java.util.List
retainAll

Constructor Detail

ContentListFacade

public ContentListFacade(AbstractBranch branch,
                         List branchContent)
Method Detail

add

public boolean add(Object object)

add

public void add(int index,
                Object object)

set

public Object set(int index,
                  Object object)

remove

public boolean remove(Object object)

remove

public Object remove(int index)

addAll

public boolean addAll(Collection collection)

addAll

public boolean addAll(int index,
                      Collection collection)

clear

public void clear()

removeAll

public boolean removeAll(Collection c)

size

public int size()

isEmpty

public boolean isEmpty()

contains

public boolean contains(Object o)

toArray

public Object[] toArray()

toArray

public Object[] toArray(Object[] a)

containsAll

public boolean containsAll(Collection c)

get

public Object get(int index)

indexOf

public int indexOf(Object o)

lastIndexOf

public int lastIndexOf(Object o)

asNode

protected Node asNode(Object object)

getBackingList

protected List getBackingList()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultAttribute (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultAttribute

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractAttribute
            extended by org.dom4j.tree.FlyweightAttribute
                extended by org.dom4j.tree.DefaultAttribute
All Implemented Interfaces:
Attribute, Cloneable, Node, Serializable
Direct Known Subclasses:
DOMAttribute, UserDataAttribute
public class DefaultAttribute
extends FlyweightAttribute

DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.

Version:
$Revision: 1.13 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightAttribute
value
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultAttribute(Element parent, QName qname, String value)
DefaultAttribute(Element parent, String name, String value, Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.
DefaultAttribute(QName qname)
DefaultAttribute(QName qname, String value)
DefaultAttribute(String name, String value)
Creates the Attribute with the specified local name and value.
DefaultAttribute(String name, String value, Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.
Method Summary
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setValue(String value) Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.tree.FlyweightAttribute
getQName, getValue
Methods inherited from class org.dom4j.tree.AbstractAttribute
accept, asXML, createXPathResult, getData, getName, getNamespace, getNamespacePrefix, getNamespaceURI, getNodeType, getPath, getQualifiedName, getText, getUniquePath, setData, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf

Constructor Detail

DefaultAttribute

public DefaultAttribute(QName qname)

DefaultAttribute

public DefaultAttribute(QName qname,
                        String value)

DefaultAttribute

public DefaultAttribute(Element parent,
                        QName qname,
                        String value)

DefaultAttribute

public DefaultAttribute(String name,
                        String value)
Creates the Attribute with the specified local name and value.

Parameters:
name - is the name of the attribute
value - is the value of the attribute

DefaultAttribute

public DefaultAttribute(String name,
                        String value,
                        Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.

Parameters:
name - is the name of the attribute
value - is the value of the attribute
namespace - is the namespace of the attribute

DefaultAttribute

public DefaultAttribute(Element parent,
                        String name,
                        String value,
                        Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.

Parameters:
parent - is the parent element
name - is the name of the attribute
value - is the value of the attribute
namespace - is the namespace of the attribute
Method Detail

setValue

public void setValue(String value)
Description copied from interface: Attribute

Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setValue in interface Attribute
Overrides:
setValue in class AbstractAttribute

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultCDATA (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultCDATA

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractCDATA
                extended by org.dom4j.tree.FlyweightCDATA
                    extended by org.dom4j.tree.DefaultCDATA
All Implemented Interfaces:
CDATA, CharacterData, Cloneable, Node, Serializable
Direct Known Subclasses:
DOMCDATA
public class DefaultCDATA
extends FlyweightCDATA

DefaultCDATA is the default CDATA implementation. It is a doubly linked node which supports the parent relationship and can be modified in place.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightCDATA
text
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultCDATA(Element parent, String text)
DOCUMENT ME!
DefaultCDATA(String text)
DOCUMENT ME!
Method Summary
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setText(String text) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.tree.FlyweightCDATA
createXPathResult, getText
Methods inherited from class org.dom4j.tree.AbstractCDATA
accept, asXML, getNodeType, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText, getPath, getUniquePath
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf, write

Constructor Detail

DefaultCDATA

public DefaultCDATA(String text)
DOCUMENT ME!

Parameters:
text - is the CDATA text

DefaultCDATA

public DefaultCDATA(Element parent,
                    String text)
DOCUMENT ME!

Parameters:
parent - is the parent element
text - is the CDATA text
Method Detail

setText

public void setText(String text)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setText in interface Node
Overrides:
setText in class AbstractNode

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultComment (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultComment

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractComment
                extended by org.dom4j.tree.FlyweightComment
                    extended by org.dom4j.tree.DefaultComment
All Implemented Interfaces:
CharacterData, Cloneable, Comment, Node, Serializable
Direct Known Subclasses:
DOMComment
public class DefaultComment
extends FlyweightComment

DefaultComment is the default Comment implementation. It is a doubly linked node which supports the parent relationship and can be modified in place.

Version:
$Revision: 1.11 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightComment
text
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultComment(Element parent, String text)
DOCUMENT ME!
DefaultComment(String text)
DOCUMENT ME!
Method Summary
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setText(String text) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.tree.FlyweightComment
createXPathResult, getText
Methods inherited from class org.dom4j.tree.AbstractComment
accept, asXML, getNodeType, getPath, getUniquePath, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf, write

Constructor Detail

DefaultComment

public DefaultComment(String text)
DOCUMENT ME!

Parameters:
text - is the Comment text

DefaultComment

public DefaultComment(Element parent,
                      String text)
DOCUMENT ME!

Parameters:
parent - is the parent element
text - is the Comment text
Method Detail

setText

public void setText(String text)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setText in interface Node
Overrides:
setText in class AbstractNode

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultDocument (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultDocument

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractDocument
                extended by org.dom4j.tree.DefaultDocument
All Implemented Interfaces:
Branch, Cloneable, Document, Node, Serializable
Direct Known Subclasses:
DOMDocument
public class DefaultDocument
extends AbstractDocument

DefaultDocument is the default DOM4J default implementation of an XML document.

Version:
$Revision: 1.34 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static Iterator | EMPTY_ITERATOR
protected static List | EMPTY_LIST
Fields inherited from class org.dom4j.tree.AbstractDocument
encoding
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultDocument()
DefaultDocument(DocumentType docType)
DefaultDocument(Element rootElement)
DefaultDocument(Element rootElement, DocumentType docType)
DefaultDocument(String name)
DefaultDocument(String name, Element rootElement, DocumentType docType)
Method Summary
Document | addDocType(String docTypeName, String publicId, String systemId) Adds a DOCTYPE declaration to this document
protected void | addNode(int index, Node node)
protected void | addNode(Node node)
void | clearContent() Clears the content for this branch, removing any Node instances this branch may contain.
Object | clone() clone will return a deep clone or if this node is read-only then clone will return the same instance.
protected List | contentList() DOCUMENT ME!
DocumentType | getDocType() DOCUMENT ME!
protected DocumentFactory | getDocumentFactory()
EntityResolver | getEntityResolver() DOCUMENT ME!
String | getName() getName returns the name of this node.
Element | getRootElement() Returns the root Elementfor this document.
String | getXMLEncoding() Return the encoding of this document, as part of the XML declaration This is null when unspecified or when it is not known (such as when the Document was created in memory) or when the implementation does not support this operation.
ProcessingInstruction | processingInstruction(String target) DOCUMENT ME!
List | processingInstructions() Returns a list of all the processing instructions in this branch.
List | processingInstructions(String target) Returns a list of the processing instructions for the given target.
protected boolean | removeNode(Node node)
boolean | removeProcessingInstruction(String target) Removes the processing instruction for the given target if it exists
protected void | rootElementAdded(Element element) Called to set the root element variable
void | setContent(List content) Sets the contents of this branch as a List of Node instances.
void | setDocType(DocumentType docType) Sets the DocumentType property
void | setDocumentFactory(DocumentFactory documentFactory)
void | setEntityResolver(EntityResolver entityResolver) Sets the EntityResolver used to find resolve URIs such as for DTDs, or XML Schema documents
void | setName(String name) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
Methods inherited from class org.dom4j.tree.AbstractDocument
accept, add, addComment, addElement, addElement, addElement, addProcessingInstruction, addProcessingInstruction, asXML, asXPathResult, checkAddElementAllowed, childAdded, childRemoved, getDocument, getNodeType, getPath, getStringValue, getUniquePath, normalize, remove, setRootElement, setXMLEncoding, toString, write
Methods inherited from class org.dom4j.tree.AbstractBranch
add, add, add, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getText, getTextTrim, hasContent, indexOf, invalidNodeTypeAddException, isReadOnly, node, nodeCount, nodeIterator, remove, remove, remove, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getParent, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Branch
add, add, add, appendContent, content, elementByID, indexOf, node, nodeCount, nodeIterator, remove, remove, remove, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
createXPath, detach, getNodeTypeName, getParent, getPath, getText, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf

Field Detail

EMPTY_LIST

protected static final List EMPTY_LIST

EMPTY_ITERATOR

protected static final Iterator EMPTY_ITERATOR
Constructor Detail

DefaultDocument

public DefaultDocument()

DefaultDocument

public DefaultDocument(String name)

DefaultDocument

public DefaultDocument(Element rootElement)

DefaultDocument

public DefaultDocument(DocumentType docType)

DefaultDocument

public DefaultDocument(Element rootElement,
                       DocumentType docType)

DefaultDocument

public DefaultDocument(String name,
                       Element rootElement,
                       DocumentType docType)
Method Detail

getName

public String getName()
Description copied from interface: Node

getName returns the name of this node. This is the XML local name of the element, attribute, entity or processing instruction. For CDATA and Text nodes this method will return null.

Specified by:
getName in interface Node
Overrides:
getName in class AbstractNode

setName

public void setName(String name)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setName in interface Node
Overrides:
setName in class AbstractNode

getRootElement

public Element getRootElement()
Description copied from interface: Document
Returns the root Elementfor this document.

Returns:
the root element for this document

getDocType

public DocumentType getDocType()
Description copied from interface: Document
DOCUMENT ME!

Returns:
the DocumentType property

setDocType

public void setDocType(DocumentType docType)
Description copied from interface: Document
Sets the DocumentType property

Parameters:
docType - DOCUMENT ME!

addDocType

public Document addDocType(String docTypeName,
                           String publicId,
                           String systemId)
Description copied from interface: Document
Adds a DOCTYPE declaration to this document

Parameters:
docTypeName - is the name of the root element
publicId - is the PUBLIC URI
systemId - is the SYSTEM URI
Returns:
this Document instance.

getXMLEncoding

public String getXMLEncoding()
Description copied from interface: Document
Return the encoding of this document, as part of the XML declaration This is null when unspecified or when it is not known (such as when the Document was created in memory) or when the implementation does not support this operation.

The way this encoding is retrieved also depends on the way the XML source is parsed. For instance, if the SAXReader is used and if the underlying XMLReader implementation support the org.xml.sax.ext.Locator2 interface, the result returned by this method is specified by the getEncoding() method of that interface.

Specified by:
getXMLEncoding in interface Document
Overrides:
getXMLEncoding in class AbstractDocument

getEntityResolver

public EntityResolver getEntityResolver()
Description copied from interface: Document
DOCUMENT ME!

Returns:
the EntityResolver used to find resolve URIs such as for DTDs, or XML Schema documents

setEntityResolver

public void setEntityResolver(EntityResolver entityResolver)
Description copied from interface: Document
Sets the EntityResolver used to find resolve URIs such as for DTDs, or XML Schema documents

Parameters:
entityResolver - DOCUMENT ME!

clone

public Object clone()
Description copied from interface: Node

clone will return a deep clone or if this node is read-only then clone will return the same instance.

Specified by:
clone in interface Node
Overrides:
clone in class AbstractNode

processingInstructions

public List processingInstructions()
Description copied from interface: Branch

Returns a list of all the processing instructions in this branch. The list is backed by this branch so that changes to the list will be reflected in the branch but the reverse is not the case.

Returns:
a backed list of the processing instructions

processingInstructions

public List processingInstructions(String target)
Description copied from interface: Branch

Returns a list of the processing instructions for the given target. The list is backed by this branch so that changes to the list will be reflected in the branch but the reverse is not the case.

Parameters:
target - DOCUMENT ME!
Returns:
a backed list of the processing instructions

processingInstruction

public ProcessingInstruction processingInstruction(String target)
Description copied from interface: Branch
DOCUMENT ME!

Parameters:
target - DOCUMENT ME!
Returns:
the processing instruction for the given target

removeProcessingInstruction

public boolean removeProcessingInstruction(String target)
Description copied from interface: Branch
Removes the processing instruction for the given target if it exists

Parameters:
target - DOCUMENT ME!
Returns:
true if a processing instruction was removed else false

setContent

public void setContent(List content)
Description copied from interface: Branch
Sets the contents of this branch as a List of Node instances.

Parameters:
content - is the list of nodes to use as the content for this branch.

clearContent

public void clearContent()
Description copied from interface: Branch
Clears the content for this branch, removing any Node instances this branch may contain.

setDocumentFactory

public void setDocumentFactory(DocumentFactory documentFactory)

contentList

protected List contentList()
Description copied from class: AbstractBranch
DOCUMENT ME!

Specified by:
contentList in class AbstractBranch
Returns:
the internal List used to manage the content

addNode

protected void addNode(Node node)
Specified by:
addNode in class AbstractBranch

addNode

protected void addNode(int index,
                       Node node)
Specified by:
addNode in class AbstractBranch

removeNode

protected boolean removeNode(Node node)
Specified by:
removeNode in class AbstractBranch

rootElementAdded

protected void rootElementAdded(Element element)
Description copied from class: AbstractDocument
Called to set the root element variable

Specified by:
rootElementAdded in class AbstractDocument
Parameters:
element - DOCUMENT ME!

getDocumentFactory

protected DocumentFactory getDocumentFactory()
Overrides:
getDocumentFactory in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultDocumentType (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultDocumentType

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractDocumentType
            extended by org.dom4j.tree.DefaultDocumentType
All Implemented Interfaces:
Cloneable, DocumentType, Node, Serializable
Direct Known Subclasses:
DOMDocumentType
public class DefaultDocumentType
extends AbstractDocumentType

DefaultDocumentType is the DOM4J default implementation of an XML document type.

Version:
$Revision: 1.10 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected  String elementName
The root element name of the document typ
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultDocumentType()
DefaultDocumentType(String elementName, String systemID)
This will create a new DocumentType with a reference to the external DTD
DefaultDocumentType(String elementName, String publicID, String systemID)
This will create a new DocumentType with a reference to the external DTD
Method Summary
 String getElementName()
This method is the equivalent to the AbstractDocumentType.getName()method.
 List getExternalDeclarations()
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
 List getInternalDeclarations()
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
 String getPublicID()
DOCUMENT ME!
 String getSystemID()
DOCUMENT ME!
 void setElementName(String elementName)
This method is the equivalent to the AbstractDocumentType.setName(java.lang.String)method.
 void setExternalDeclarations(List externalDeclarations)
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
 void setInternalDeclarations(List internalDeclarations)
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
 void setPublicID(String publicID)
Sets the public ID of the document type
 void setSystemID(String systemID)
Sets the system ID of the document type
Methods inherited from class org.dom4j.tree.AbstractDocumentType
accept, asXML, getName, getNodeType, getPath, getText, getUniquePath, setName, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getDocument, getDocumentFactory, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf

Field Detail

elementName

protected String elementName
The root element name of the document typ

Constructor Detail

DefaultDocumentType

public DefaultDocumentType()

DefaultDocumentType

public DefaultDocumentType(String elementName,
                           String systemID)

This will create a new DocumentType with a reference to the external DTD

Parameters:
elementName - is the root element name of the document type
systemID - is the system ID of the external DTD

DefaultDocumentType

public DefaultDocumentType(String elementName,
                           String publicID,
                           String systemID)

This will create a new DocumentType with a reference to the external DTD

Parameters:
elementName - is the root element name of the document type
publicID - is the public ID of the DTD
systemID - is the system ID of the DTD
Method Detail

getElementName

public String getElementName()
Description copied from interface: DocumentType
This method is the equivalent to the Node.getName()method. It is added for clarity.

Returns:
the root element name for the document type.

setElementName

public void setElementName(String elementName)
Description copied from interface: DocumentType
This method is the equivalent to the Node.setName(java.lang.String)method. It is added for clarity.

Parameters:
elementName - DOCUMENT ME!

getPublicID

public String getPublicID()
DOCUMENT ME!

Returns:
the public ID of the document type

setPublicID

public void setPublicID(String publicID)
Sets the public ID of the document type

Parameters:
publicID - DOCUMENT ME!

getSystemID

public String getSystemID()
DOCUMENT ME!

Returns:
the system ID of the document type

setSystemID

public void setSystemID(String systemID)
Sets the system ID of the document type

Parameters:
systemID - DOCUMENT ME!

getInternalDeclarations

public List getInternalDeclarations()
Description copied from interface: DocumentType
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage

Returns:
DOCUMENT ME!

setInternalDeclarations

public void setInternalDeclarations(List internalDeclarations)
Description copied from interface: DocumentType
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage

Parameters:
internalDeclarations - DOCUMENT ME!

getExternalDeclarations

public List getExternalDeclarations()
Description copied from interface: DocumentType
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage

Returns:
DOCUMENT ME!

setExternalDeclarations

public void setExternalDeclarations(List externalDeclarations)
Description copied from interface: DocumentType
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage

Parameters:
externalDeclarations - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
                extended by org.dom4j.tree.DefaultElement
All Implemented Interfaces:
Branch, Cloneable, Element, Node, Serializable
Direct Known Subclasses:
BeanElement, DatatypeElement, DOMElement, IndexedElement, UserDataElement
public class DefaultElement
extends AbstractElement

DefaultElement is the default DOM4J default implementation of an XML element.

Version:
$Revision: 1.59 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR, EMPTY_LIST, USE_STRINGVALUE_SEPARATOR, VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultElement(QName qname)
DefaultElement(QName qname, int attributeCount)
DefaultElement(String name)
DefaultElement(String name, Namespace namespace)
Method Summary
 void add(Attribute attribute)
Adds the given Attribute to this element.
 List additionalNamespaces()
Returns any additional namespaces declarations for this element other than namespace returned via the AbstractElement.getNamespace()method.
 List additionalNamespaces(String defaultNamespaceURI)
protected  void addNewNode(Node node)
Like addNode() but does not require a parent check
 Attribute attribute(int index)
Returns the attribute at the specified indexGets the
 Attribute attribute(QName qName)
DOCUMENT ME!
 Attribute attribute(String name)
Returns the attribute with the given name
 Attribute attribute(String name, Namespace namespace)
 int attributeCount()
DOCUMENT ME!
 Iterator attributeIterator()
DOCUMENT ME!
protected  List attributeList()
DOCUMENT ME!
protected  List attributeList(int size)
DOCUMENT ME!
 List attributes()
Returns the Attributeinstances this element contains as a backed Listso that the attributes may be modified directly using the Listinterface.
 void clearContent()
Clears the content for this branch, removing any Node instances this branch may contain.
 Object clone()
clone will return a deep clone or if this node is read-only then clone will return the same instance.
protected  List contentList()
DOCUMENT ME!
 List declaredNamespaces()
Returns all the namespaces declared by this element.
 Element element(QName qName)
Returns the first element for the given fully qualified name.
 Element element(String name)
Returns the first element for the given local name and any namespace.
 Element element(String name, Namespace namespace)
 Document getDocument()
getDocument returns the Document that this Node is part of if this node supports the parent relationship.
protected  DocumentFactory getDocumentFactory()
 Namespace getNamespaceForPrefix(String prefix)
Returns the Namespace which is mapped to the given prefix or null if it could not be found.
 Namespace getNamespaceForURI(String uri)
Returns the Namespace which is mapped to the given URI or null if it could not be found.
 Element getParent()
getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
 QName getQName()
Returns the QName of this element which represents the local name, the qualified name and the Namespace.
 String getStringValue()
Returns the XPath string-value of this node.
 String getText()
Returns the text value of this element without recursing through child elements.
 int indexOf(Node node)
Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.
 Node node(int index)
Returns the Node at the specified index position.
 int nodeCount()
Returns the number of Node instances that this branch contains.
 Iterator nodeIterator()
Returns an iterator through the content nodes of this branch
 ProcessingInstruction processingInstruction(String target)
DOCUMENT ME!
 List processingInstructions()
Returns a list of all the processing instructions in this branch.
 List processingInstructions(String target)
Returns a list of the processing instructions for the given target.
 boolean remove(Attribute attribute)
Removes the given Attribute from this element.
protected  boolean removeNode(Node node)
 boolean removeProcessingInstruction(String target)
Removes the processing instruction for the given target if it exists
protected  void setAttributeList(List attributeList)
 void setAttributes(List attributes)
Sets the attributes that this element contains
 void setContent(List content)
Sets the contents of this branch as a List of Node instances.
 void setDocument(Document document)
setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
 void setParent(Element parent)
setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
 void setQName(QName name)
Sets the QName of this element which represents the local name, the qualified name and the Namespace.
 boolean supportsParent()
supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.tree.AbstractElement
accept, add, add, add, add, add, add, add, add, addAttribute, addAttribute, addCDATA, addComment, addElement, addEntity, addNamespace, addNewNode, addNode, addNode, addProcessingInstruction, addProcessingInstruction, addText, appendAttributes, asXML, attributeValue, attributeValue, attributeValue, attributeValue, childAdded, childRemoved, createAttributeList, createAttributeList, createCopy, createCopy, createCopy, createElement, createElement, createSingleIterator, elementIterator, elementIterator, elementIterator, elementIterator, elements, elements, elements, elements, elementText, elementText, elementTextTrim, elementTextTrim, ensureAttributesCapacity, getData, getName, getNamespace, getNamespacePrefix, getNamespacesForURI, getNamespaceURI, getNodeType, getPath, getQName, getQualifiedName, getUniquePath, getXPathNameStep, getXPathResult, hasMixedContent, isRootElement, isTextOnly, normalize, remove, remove, remove, remove, remove, remove, remove, remove, setAttributes, setAttributeValue, setAttributeValue, setData, setName, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Element
getTextTrim
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, content, elementByID, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, createXPath, detach, getNodeTypeName, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf

Constructor Detail

DefaultElement

public DefaultElement(String name)

DefaultElement

public DefaultElement(QName qname)

DefaultElement

public DefaultElement(QName qname,
                      int attributeCount)

DefaultElement

public DefaultElement(String name,
                      Namespace namespace)
Method Detail

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

getDocument

public Document getDocument()
Description copied from interface: Node

getDocument returns the Document that this Node is part of if this node supports the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getDocument in interface Node
Overrides:
getDocument in class AbstractNode

setDocument

public void setDocument(Document document)
Description copied from interface: Node

setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside a Document implementation method and is not intended for general use.

Specified by:
setDocument in interface Node
Overrides:
setDocument in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

getQName

public QName getQName()
Description copied from interface: Element

Returns the QName of this element which represents the local name, the qualified name and the Namespace.

Returns:
the QName associated with this element

setQName

public void setQName(QName name)
Description copied from interface: Element

Sets the QName of this element which represents the local name, the qualified name and the Namespace.

Parameters:
name - is the QName to be associated with this element

getText

public String getText()
Description copied from interface: Element
Returns the text value of this element without recursing through child elements. This method iterates through all Text,CDATA and Entitynodes that this element contains and appends the text values together.

Specified by:
getText in interface Element
Overrides:
getText in class AbstractBranch

getStringValue

public String getStringValue()
Description copied from interface: Element
Returns the XPath string-value of this node. The behaviour of this method is defined in the XPath specification . This method returns the string-value of all the contained Text,CDATA,Entityand Element nodes all appended together.

Specified by:
getStringValue in interface Element
Overrides:
getStringValue in class AbstractElement

clone

public Object clone()
Description copied from interface: Node

clone will return a deep clone or if this node is read-only then clone will return the same instance.

Specified by:
clone in interface Node
Overrides:
clone in class AbstractNode

getNamespaceForPrefix

public Namespace getNamespaceForPrefix(String prefix)
Description copied from interface: Element

Returns the Namespace which is mapped to the given prefix or null if it could not be found.

Specified by:
getNamespaceForPrefix in interface Element
Overrides:
getNamespaceForPrefix in class AbstractElement

getNamespaceForURI

public Namespace getNamespaceForURI(String uri)
Description copied from interface: Element

Returns the Namespace which is mapped to the given URI or null if it could not be found. If there is more than one Namespace mapped to the URI, which of them will be returned is undetermined.

Specified by:
getNamespaceForURI in interface Element
Overrides:
getNamespaceForURI in class AbstractElement

declaredNamespaces

public List declaredNamespaces()
Description copied from interface: Element

Returns all the namespaces declared by this element. If no namespaces are declared for this element then an empty list will be returned. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
declaredNamespaces in interface Element
Overrides:
declaredNamespaces in class AbstractElement

additionalNamespaces

public List additionalNamespaces()
Description copied from interface: Element

Returns any additional namespaces declarations for this element other than namespace returned via the Element.getNamespace()method. If no additional namespace declarations are present for this element then an empty list will be returned. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
additionalNamespaces in interface Element
Overrides:
additionalNamespaces in class AbstractElement

additionalNamespaces

public List additionalNamespaces(String defaultNamespaceURI)
Overrides:
additionalNamespaces in class AbstractElement

processingInstructions

public List processingInstructions()
Description copied from interface: Branch

Returns a list of all the processing instructions in this branch. The list is backed by this branch so that changes to the list will be reflected in the branch but the reverse is not the case.

Specified by:
processingInstructions in interface Branch
Overrides:
processingInstructions in class AbstractElement

processingInstructions

public List processingInstructions(String target)
Description copied from interface: Branch

Returns a list of the processing instructions for the given target. The list is backed by this branch so that changes to the list will be reflected in the branch but the reverse is not the case.

Specified by:
processingInstructions in interface Branch
Overrides:
processingInstructions in class AbstractElement

processingInstruction

public ProcessingInstruction processingInstruction(String target)
Description copied from interface: Branch
DOCUMENT ME!

Specified by:
processingInstruction in interface Branch
Overrides:
processingInstruction in class AbstractElement

removeProcessingInstruction

public boolean removeProcessingInstruction(String target)
Description copied from interface: Branch
Removes the processing instruction for the given target if it exists

Specified by:
removeProcessingInstruction in interface Branch
Overrides:
removeProcessingInstruction in class AbstractElement

element

public Element element(String name)
Description copied from interface: Element
Returns the first element for the given local name and any namespace.

Specified by:
element in interface Element
Overrides:
element in class AbstractElement

element

public Element element(QName qName)
Description copied from interface: Element
Returns the first element for the given fully qualified name.

Specified by:
element in interface Element
Overrides:
element in class AbstractElement

element

public Element element(String name,
                       Namespace namespace)
Overrides:
element in class AbstractElement

setContent

public void setContent(List content)
Description copied from interface: Branch
Sets the contents of this branch as a List of Node instances.

Parameters:
content - is the list of nodes to use as the content for this branch.

clearContent

public void clearContent()
Description copied from interface: Branch
Clears the content for this branch, removing any Node instances this branch may contain.

node

public Node node(int index)
Description copied from interface: Branch
Returns the Node at the specified index position.

Specified by:
node in interface Branch
Overrides:
node in class AbstractElement

indexOf

public int indexOf(Node node)
Description copied from interface: Branch
Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.

Specified by:
indexOf in interface Branch
Overrides:
indexOf in class AbstractElement

nodeCount

public int nodeCount()
Description copied from interface: Branch
Returns the number of Node instances that this branch contains.

Specified by:
nodeCount in interface Branch
Overrides:
nodeCount in class AbstractElement

nodeIterator

public Iterator nodeIterator()
Description copied from interface: Branch
Returns an iterator through the content nodes of this branch

Specified by:
nodeIterator in interface Branch
Overrides:
nodeIterator in class AbstractElement

attributes

public List attributes()
Description copied from interface: Element

Returns the Attributeinstances this element contains as a backed Listso that the attributes may be modified directly using the Listinterface. The List is backed by the Element so that changes to the list are reflected in the element and vice versa.

Specified by:
attributes in interface Element
Overrides:
attributes in class AbstractElement

setAttributes

public void setAttributes(List attributes)
Description copied from interface: Element
Sets the attributes that this element contains

Parameters:
attributes - DOCUMENT ME!

attributeIterator

public Iterator attributeIterator()
Description copied from interface: Element
DOCUMENT ME!

Specified by:
attributeIterator in interface Element
Overrides:
attributeIterator in class AbstractElement

attribute

public Attribute attribute(int index)
Description copied from interface: Element
Returns the attribute at the specified indexGets the

Specified by:
attribute in interface Element
Overrides:
attribute in class AbstractElement

attributeCount

public int attributeCount()
Description copied from interface: Element
DOCUMENT ME!

Specified by:
attributeCount in interface Element
Overrides:
attributeCount in class AbstractElement

attribute

public Attribute attribute(String name)
Description copied from interface: Element
Returns the attribute with the given name

Specified by:
attribute in interface Element
Overrides:
attribute in class AbstractElement

attribute

public Attribute attribute(QName qName)
Description copied from interface: Element
DOCUMENT ME!

Specified by:
attribute in interface Element
Overrides:
attribute in class AbstractElement

attribute

public Attribute attribute(String name,
                           Namespace namespace)
Overrides:
attribute in class AbstractElement

add

public void add(Attribute attribute)
Description copied from interface: Element
Adds the given Attribute to this element. If the given node already has a parent defined then an IllegalAddException will be thrown. Attributes with null values are silently ignored.

If the value of the attribute is null then this method call will remove any attributes with the QName of this attribute.

Specified by:
add in interface Element
Overrides:
add in class AbstractElement

remove

public boolean remove(Attribute attribute)
Description copied from interface: Element
Removes the given Attribute from this element.

Specified by:
remove in interface Element
Overrides:
remove in class AbstractElement

addNewNode

protected void addNewNode(Node node)
Description copied from class: AbstractElement
Like addNode() but does not require a parent check

Overrides:
addNewNode in class AbstractElement
Parameters:
node - DOCUMENT ME!

removeNode

protected boolean removeNode(Node node)
Overrides:
removeNode in class AbstractElement

contentList

protected List contentList()
Description copied from class: AbstractBranch
DOCUMENT ME!

Specified by:
contentList in class AbstractBranch
Returns:
the internal List used to manage the content

attributeList

protected List attributeList()
Description copied from class: AbstractElement
DOCUMENT ME!

Specified by:
attributeList in class AbstractElement
Returns:
the internal List used to store attributes or creates one if one is not available

attributeList

protected List attributeList(int size)
Description copied from class: AbstractElement
DOCUMENT ME!

Specified by:
attributeList in class AbstractElement
Parameters:
size - DOCUMENT ME!
Returns:
the internal List used to store attributes or creates one with the specified size if one is not available

setAttributeList

protected void setAttributeList(List attributeList)

getDocumentFactory

protected DocumentFactory getDocumentFactory()
Overrides:
getDocumentFactory in class AbstractElement
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultEntity (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultEntity

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractEntity
            extended by org.dom4j.tree.FlyweightEntity
                extended by org.dom4j.tree.DefaultEntity
All Implemented Interfaces:
Cloneable, Entity, Node, Serializable
Direct Known Subclasses:
DOMEntityReference
public class DefaultEntity
extends FlyweightEntity

DefaultEntity is the default Entity implementation. It is a doubly linked node which supports the parent relationship and can be modified in place.

Version:
$Revision: 1.11 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightEntity
name, text
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultEntity(Element parent, String name, String text)
Creates the Entity with the specified name and text.
DefaultEntity(String name)
Creates the Entity with the specified name
DefaultEntity(String name, String text)
Creates the Entity with the specified name and text.
Method Summary
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
void | setName(String name) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setText(String text) sets the value of the entity if it is not defined yet otherwise an UnsupportedOperationException is thrown as this class is read only.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.tree.FlyweightEntity
createXPathResult, getName, getText
Methods inherited from class org.dom4j.tree.AbstractEntity
accept, asXML, getNodeType, getPath, getStringValue, getUniquePath, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, valueOf

Constructor Detail

DefaultEntity

public DefaultEntity(String name)
Creates the Entity with the specified name

Parameters:
name - is the name of the entity

DefaultEntity

public DefaultEntity(String name,
                     String text)
Creates the Entity with the specified name and text.

Parameters:
name - is the name of the entity
text - is the text of the entity

DefaultEntity

public DefaultEntity(Element parent,
                     String name,
                     String text)
Creates the Entity with the specified name and text.

Parameters:
parent - is the parent element
name - is the name of the entity
text - is the text of the entity
Method Detail

setName

public void setName(String name)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setName in interface Node
Overrides:
setName in class AbstractNode

setText

public void setText(String text)
Description copied from class: FlyweightEntity
sets the value of the entity if it is not defined yet otherwise an UnsupportedOperationException is thrown as this class is read only.

Specified by:
setText in interface Node
Overrides:
setText in class FlyweightEntity
Parameters:
text - DOCUMENT ME!

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultNamespace (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultNamespace

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.Namespace
            extended by org.dom4j.tree.DefaultNamespace
All Implemented Interfaces:
Cloneable, Node, Serializable
Direct Known Subclasses:
DOMNamespace
public class DefaultNamespace
extends Namespace

DefaultNamespace implements a doubly linked node which supports the parent relationship and is mutable. It is useful when returning results from XPath expressions.

Version:
$Revision: 1.16 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.Namespace
CACHE, NO_NAMESPACE, XML_NAMESPACE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultNamespace(Element parent, String prefix, String uri)
DOCUMENT ME!
DefaultNamespace(String prefix, String uri)
DOCUMENT ME!
Method Summary
protected int | createHashCode() DOCUMENT ME!
boolean | equals(Object object) Implements an identity based comparsion using the parent element as well as the prefix and URI
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
int | hashCode() DOCUMENT ME!
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.Namespace
accept, asXML, createXPathResult, get, get, getNodeType, getPath, getPrefix, getStringValue, getText, getUniquePath, getURI, getXPathNameStep, toString
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getPath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setText, valueOf, write
Methods inherited from class java.lang.Object
finalize, getClass, notify, notifyAll, wait, wait, wait

Constructor Detail

DefaultNamespace

public DefaultNamespace(String prefix,
                        String uri)
DOCUMENT ME!

Parameters:
prefix - is the prefix for this namespace
uri - is the URI for this namespace

DefaultNamespace

public DefaultNamespace(Element parent,
                        String prefix,
                        String uri)
DOCUMENT ME!

Parameters:
parent - is the parent element
prefix - is the prefix for this namespace
uri - is the URI for this namespace
Method Detail

createHashCode

protected int createHashCode()
DOCUMENT ME!

Overrides:
createHashCode in class Namespace
Returns:
the hash code based on the qualified name and the URI of the namespace and the hashCode() of the parent element.

equals

public boolean equals(Object object)
Implements an identity based comparsion using the parent element as well as the prefix and URI

Overrides:
equals in class Namespace
Parameters:
object - DOCUMENT ME!
Returns:
DOCUMENT ME!

hashCode

public int hashCode()
Description copied from class: Namespace
DOCUMENT ME!

Overrides:
hashCode in class Namespace
Returns:
the hash code based on the qualified name and the URI of the namespace.

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultProcessingInstruction (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultProcessingInstruction

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractProcessingInstruction
            extended by org.dom4j.tree.FlyweightProcessingInstruction
                extended by org.dom4j.tree.DefaultProcessingInstruction
All Implemented Interfaces:
Cloneable, Node, ProcessingInstruction, Serializable
Direct Known Subclasses:
DOMProcessingInstruction
public class DefaultProcessingInstruction
extends FlyweightProcessingInstruction

DefaultProcessingInstruction is the default Processing Instruction implementation. It is a doubly linked node which supports the parent relationship and can be modified in place.

Version:
$Revision: 1.13 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightProcessingInstruction
target, text, values
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultProcessingInstruction(Element parent, String target, String values)
This will create a new PI with the given target and values
DefaultProcessingInstruction(String target, Map values)
This will create a new PI with the given target and values
DefaultProcessingInstruction(String target, String values)
This will create a new PI with the given target and values
Method Summary
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setTarget(String target) This method is the equivalent to the AbstractProcessingInstruction.setName(java.lang.String)method.
void | setText(String text) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
void | setValue(String name, String value)
void | setValues(Map values)
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.tree.FlyweightProcessingInstruction
createXPathResult, getTarget, getText, getValue, getValues
Methods inherited from class org.dom4j.tree.AbstractProcessingInstruction
accept, asXML, getName, getNodeType, getPath, getUniquePath, parseValues, removeValue, setName, toString, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, valueOf

Constructor Detail

DefaultProcessingInstruction

public DefaultProcessingInstruction(String target,
                                    Map values)

This will create a new PI with the given target and values

Parameters:
target - is the name of the PI
values - is the Map values for the PI

DefaultProcessingInstruction

public DefaultProcessingInstruction(String target,
                                    String values)

This will create a new PI with the given target and values

Parameters:
target - is the name of the PI
values - is the values for the PI

DefaultProcessingInstruction

public DefaultProcessingInstruction(Element parent,
                                    String target,
                                    String values)

This will create a new PI with the given target and values

Parameters:
parent - is the parent element
target - is the name of the PI
values - is the values for the PI
Method Detail

setTarget

public void setTarget(String target)
Description copied from interface: ProcessingInstruction
This method is the equivalent to the Node.setName(java.lang.String)method. It is added for clarity.

Specified by:
setTarget in interface ProcessingInstruction
Overrides:
setTarget in class FlyweightProcessingInstruction

setText

public void setText(String text)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setText in interface Node
Overrides:
setText in class AbstractNode

setValues

public void setValues(Map values)
Specified by:
setValues in interface ProcessingInstruction
Overrides:
setValues in class AbstractProcessingInstruction

setValue

public void setValue(String name,
                     String value)
Specified by:
setValue in interface ProcessingInstruction
Overrides:
setValue in class AbstractProcessingInstruction

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DefaultText (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class DefaultText

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractText
                extended by org.dom4j.tree.FlyweightText
                    extended by org.dom4j.tree.DefaultText
All Implemented Interfaces:
CharacterData, Cloneable, Node, Serializable, Text
Direct Known Subclasses:
DOMText
public class DefaultText
extends FlyweightText

DefaultText is the default Text implementation. It is a doubly linked node which supports the parent relationship and can be modified in place.

Version:
$Revision: 1.11 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightText
text
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
DefaultText(Element parent, String text)
DOCUMENT ME!
DefaultText(String text)
DOCUMENT ME!
Method Summary
Element | getParent() getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
boolean | isReadOnly() isReadOnly returns true if this node is read only and cannot be modified.
void | setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
void | setText(String text) Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
boolean | supportsParent() supportsParent returns true if this node supports the parent relationship.
Methods inherited from class org.dom4j.tree.FlyweightText
createXPathResult, getText
Methods inherited from class org.dom4j.tree.AbstractText
accept, asXML, getNodeType, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText, getPath, getUniquePath
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf, write

Constructor Detail

DefaultText

public DefaultText(String text)
DOCUMENT ME!

Parameters:
text - is the Text text

DefaultText

public DefaultText(Element parent,
                   String text)
DOCUMENT ME!

Parameters:
parent - is the parent element
text - is the Text text
Method Detail

setText

public void setText(String text)
Description copied from interface: Node

Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.

Specified by:
setText in interface Node
Overrides:
setText in class AbstractNode

getParent

public Element getParent()
Description copied from interface: Node

getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.

This method is an optional feature and may not be supported for all Node implementations.

Specified by:
getParent in interface Node
Overrides:
getParent in class AbstractNode

setParent

public void setParent(Element parent)
Description copied from interface: Node

setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

This method should only be called from inside an Element implementation method and is not intended for general use.

Specified by:
setParent in interface Node
Overrides:
setParent in class AbstractNode

supportsParent

public boolean supportsParent()
Description copied from interface: Node

supportsParent returns true if this node supports the parent relationship.

Some XML tree implementations are singly linked and only support downward navigation through children relationships. The default case is that both parent and children relationships are supported though for memory and performance reasons the parent relationship may not be supported.

Specified by:
supportsParent in interface Node
Overrides:
supportsParent in class AbstractNode

isReadOnly

public boolean isReadOnly()
Description copied from interface: Node

isReadOnly returns true if this node is read only and cannot be modified. Any attempt to modify a read-only Node will result in an UnsupportedOperationException being thrown.

Specified by:
isReadOnly in interface Node
Overrides:
isReadOnly in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElementIterator (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class ElementIterator

java.lang.Object
    extended by org.dom4j.tree.FilterIterator
        extended by org.dom4j.tree.ElementIterator
All Implemented Interfaces:
Iterator
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!

public class ElementIterator
extends FilterIterator

ElementIterator is a filtering Iteratorwhich filters out objects which do not implement the Elementinterface.

Version:
$Revision: 1.8 $
Author:
James Strachan

Field Summary
Fields inherited from class org.dom4j.tree.FilterIterator
proxy
Constructor Summary
ElementIterator(Iterator proxy)
Deprecated.
Method Summary
protected  boolean matches(Object element)
Deprecated. DOCUMENT ME!
Methods inherited from class org.dom4j.tree.FilterIterator
findNext, hasNext, next, remove
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ElementIterator

public ElementIterator(Iterator proxy)
Deprecated.
Method Detail

matches

protected boolean matches(Object element)
Deprecated.
DOCUMENT ME!

Specified by:
matches in class FilterIterator
Parameters:
element - DOCUMENT ME!
Returns:
true if the given element implements the Element interface
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElementNameIterator (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class ElementNameIterator

java.lang.Object
    extended by org.dom4j.tree.FilterIterator
        extended by org.dom4j.tree.ElementNameIterator
All Implemented Interfaces:
Iterator
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!

public class ElementNameIterator
extends FilterIterator

ElementNameIterator is a filtering Iteratorwhich filters out objects which do not implement the Elementinterface and are not of the correct element name.

Version:
$Revision: 1.11 $
Author:
James Strachan

Field Summary
Fields inherited from class org.dom4j.tree.FilterIterator
proxy
Constructor Summary
ElementNameIterator(Iterator proxy, String name)
Deprecated.
Method Summary
protected  boolean matches(Object object)
Deprecated. DOCUMENT ME!
Methods inherited from class org.dom4j.tree.FilterIterator
findNext, hasNext, next, remove
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ElementNameIterator

public ElementNameIterator(Iterator proxy,
                           String name)
Deprecated.
Method Detail

matches

protected boolean matches(Object object)
Deprecated.
DOCUMENT ME!

Specified by:
matches in class FilterIterator
Parameters:
object - DOCUMENT ME!
Returns:
true if the given element implements the Element interface
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ElementQNameIterator (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class ElementQNameIterator

java.lang.Object
    extended by org.dom4j.tree.FilterIterator
        extended by org.dom4j.tree.ElementQNameIterator
All Implemented Interfaces:
Iterator
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!

public class ElementQNameIterator
extends FilterIterator

ElementQNameIterator is a filtering Iteratorwhich filters out objects which do not implement the Elementinterface and are not of the correct fully qualified element name.

Version:
$Revision: 1.7 $
Author:
James Strachan

Field Summary
Fields inherited from class org.dom4j.tree.FilterIterator
proxy
Constructor Summary
ElementQNameIterator(Iterator proxy, QName qName)
Deprecated.
Method Summary
protected  boolean matches(Object object)
Deprecated. DOCUMENT ME!
Methods inherited from class org.dom4j.tree.FilterIterator
findNext, hasNext, next, remove
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ElementQNameIterator

public ElementQNameIterator(Iterator proxy,
                            QName qName)
Deprecated.
Method Detail

matches

protected boolean matches(Object object)
Deprecated.
DOCUMENT ME!

Specified by:
matches in class FilterIterator
Parameters:
object - DOCUMENT ME!
Returns:
true if the given element implements the Element interface and matches the given QName
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FilterIterator (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class FilterIterator

java.lang.Object
    extended by org.dom4j.tree.FilterIterator
All Implemented Interfaces:
Iterator
Direct Known Subclasses:
ElementIterator, ElementNameIterator, ElementQNameIterator
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!

public abstract class FilterIterator
extends Object
implements Iterator

FilterIterator is an abstract base class which is useful for implementors of Iteratorwhich filter an existing iterator.

Version:
$Revision: 1.10 $
Author:
James Strachan

Field Summary
protected  Iterator proxy
Deprecated.
Constructor Summary
FilterIterator(Iterator proxy)
Deprecated.
Method Summary
protected Object | findNext() Deprecated.
boolean | hasNext() Deprecated.
protected abstract boolean | matches(Object element) Deprecated. Filter method to perform some matching on the given element.
Object | next() Deprecated.
void | remove() Deprecated. Always throws UnsupportedOperationException as this class does look-ahead with its internal iterator.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

proxy

protected Iterator proxy
Deprecated.
Constructor Detail

FilterIterator

public FilterIterator(Iterator proxy)
Deprecated.
Method Detail

hasNext

public boolean hasNext()
Deprecated.
Specified by:
hasNext in interface Iterator

next

public Object next()
            throws NoSuchElementException
Deprecated.
Specified by:
next in interface Iterator
Throws:
NoSuchElementException

remove

public void remove()
Deprecated.
Always throws UnsupportedOperationException as this class does look-ahead with its internal iterator.

Specified by:
remove in interface Iterator
Throws:
UnsupportedOperationException - always

matches

protected abstract boolean matches(Object element)
Deprecated.
Filter method to perform some matching on the given element.

Parameters:
element - DOCUMENT ME!
Returns:
true if the given element matches the filter and should be appear in the iteration

findNext

protected Object findNext()
Deprecated.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlyweightAttribute (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class FlyweightAttribute

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractAttribute
            extended by org.dom4j.tree.FlyweightAttribute
All Implemented Interfaces:
Attribute, Cloneable, Node, Serializable
Direct Known Subclasses:
DefaultAttribute
public class FlyweightAttribute
extends AbstractAttribute

FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.

This node could be shared across documents and elements though it does not support the parent relationship.

Version:
$Revision: 1.7 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected  String value
The value of the Attribute
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
FlyweightAttribute(QName qname)
FlyweightAttribute(QName qname, String value)
FlyweightAttribute(String name, String value)
Creates the Attribute with the specified local name and value.
FlyweightAttribute(String name, String value, Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.
Method Summary
QName | getQName() Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.
String | getValue() Returns the value of the attribute.
Methods inherited from class org.dom4j.tree.AbstractAttribute
accept, asXML, createXPathResult, getData, getName, getNamespace, getNamespacePrefix, getNamespaceURI, getNodeType, getPath, getQualifiedName, getText, getUniquePath, setData, setNamespace, setText, setValue, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, supportsParent, valueOf

Field Detail

value

protected String value
The value of the Attribute

Constructor Detail

FlyweightAttribute

public FlyweightAttribute(QName qname)

FlyweightAttribute

public FlyweightAttribute(QName qname,
                          String value)

FlyweightAttribute

public FlyweightAttribute(String name,
                          String value)
Creates the Attribute with the specified local name and value.

Parameters:
name - is the name of the attribute
value - is the value of the attribute

FlyweightAttribute

public FlyweightAttribute(String name,
                          String value,
                          Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.

Parameters:
name - is the name of the attribute
value - is the value of the attribute
namespace - is the namespace of the attribute
Method Detail

getValue

public String getValue()
Description copied from interface: Attribute

Returns the value of the attribute. This method returns the same value as the Node.getText()method.

Returns:
the value of the attribute

getQName

public QName getQName()
Description copied from interface: Attribute

Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.

Returns:
the QName associated with this attribute
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlyweightCDATA (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class FlyweightCDATA

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractCDATA
                extended by org.dom4j.tree.FlyweightCDATA
All Implemented Interfaces:
CDATA, CharacterData, Cloneable, Node, Serializable
Direct Known Subclasses:
DefaultCDATA
public class FlyweightCDATA
extends AbstractCDATA
implements CDATA

FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.

This node could be shared across documents and elements though it does not support the parent relationship.

Version:
$Revision: 1.8 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected  String text
Text of the CDATA node
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
FlyweightCDATA(String text)
DOCUMENT ME!
Method Summary
protected Node | createXPathResult(Element parent)
String | getText() Returns the text of this node.
Methods inherited from class org.dom4j.tree.AbstractCDATA
accept, asXML, getNodeType, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText, getPath, getUniquePath
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Field Detail

text

protected String text
Text of the CDATA node

Constructor Detail

FlyweightCDATA

public FlyweightCDATA(String text)
DOCUMENT ME!

Parameters:
text - is the CDATA text
Method Detail

getText

public String getText()
Description copied from interface: Node

Returns the text of this node.

Specified by:
getText in interface Node
Overrides:
getText in class AbstractNode

createXPathResult

protected Node createXPathResult(Element parent)
Overrides:
createXPathResult in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlyweightComment (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class FlyweightComment

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractComment
                extended by org.dom4j.tree.FlyweightComment
All Implemented Interfaces:
CharacterData, Cloneable, Comment, Node, Serializable
Direct Known Subclasses:
DefaultComment
public class FlyweightComment
extends AbstractComment
implements Comment

FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.

This node could be shared across documents and elements though it does not support the parent relationship.

Version:
$Revision: 1.7 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected  String text
Text of the Comment node
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
FlyweightComment(String text)
DOCUMENT ME!
Method Summary
protected Node | createXPathResult(Element parent)
String | getText() Returns the text of this node.
Methods inherited from class org.dom4j.tree.AbstractComment
accept, asXML, getNodeType, getPath, getUniquePath, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Field Detail

text

protected String text
Text of the Comment node

Constructor Detail

FlyweightComment

public FlyweightComment(String text)
DOCUMENT ME!

Parameters:
text - is the Comment text
Method Detail

getText

public String getText()
Description copied from interface: Node

Returns the text of this node.

Specified by:
getText in interface Node
Overrides:
getText in class AbstractNode

createXPathResult

protected Node createXPathResult(Element parent)
Overrides:
createXPathResult in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlyweightEntity (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class FlyweightEntity

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractEntity
            extended by org.dom4j.tree.FlyweightEntity
All Implemented Interfaces:
Cloneable, Entity, Node, Serializable
Direct Known Subclasses:
DefaultEntity
public class FlyweightEntity
extends AbstractEntity

FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.

This node could be shared across documents and elements though it does not support the parent relationship.

Often this node needs to be created and then the text content added later (for example in SAX) so this implementation allows a call to providing the entity has no text already.

Version:
$Revision: 1.6 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected String | name The name of the Entity
protected String | text The text of the Entity
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
protected | FlyweightEntity() A default constructor for implementors to use.
 | FlyweightEntity(String name) Creates the Entity with the specified name
 | FlyweightEntity(String name, String text) Creates the Entity with the specified name and text.
Method Summary
protected Node | createXPathResult(Element parent)
String | getName() DOCUMENT ME!
String | getText() DOCUMENT ME!
void | setText(String text) sets the value of the entity if it is not defined yet otherwise an UnsupportedOperationException is thrown as this class is read only.
Methods inherited from class org.dom4j.tree.AbstractEntity
accept, asXML, getNodeType, getPath, getStringValue, getUniquePath, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getParent, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, supportsParent, valueOf

Field Detail

name

protected String name
The name of the Entity

text

protected String text
The text of the Entity

Constructor Detail

FlyweightEntity

protected FlyweightEntity()
A default constructor for implementors to use.

FlyweightEntity

public FlyweightEntity(String name)
Creates the Entity with the specified name

Parameters:
name - is the name of the entity

FlyweightEntity

public FlyweightEntity(String name,
                       String text)
Creates the Entity with the specified name and text.

Parameters:
name - is the name of the entity
text - is the text of the entity
Method Detail

getName

public String getName()
DOCUMENT ME!

Specified by:
getName in interface Node
Overrides:
getName in class AbstractNode
Returns:
the name of the entity

getText

public String getText()
DOCUMENT ME!

Specified by:
getText in interface Node
Overrides:
getText in class AbstractNode
Returns:
the text of the entity

setText

public void setText(String text)
sets the value of the entity if it is not defined yet otherwise an UnsupportedOperationException is thrown as this class is read only.

Specified by:
setText in interface Node
Overrides:
setText in class AbstractNode
Parameters:
text - DOCUMENT ME!
Throws:
UnsupportedOperationException - DOCUMENT ME!

createXPathResult

protected Node createXPathResult(Element parent)
Overrides:
createXPathResult in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlyweightProcessingInstruction (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class FlyweightProcessingInstruction

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractProcessingInstruction
            extended by org.dom4j.tree.FlyweightProcessingInstruction
All Implemented Interfaces:
Cloneable, Node, ProcessingInstruction, Serializable
Direct Known Subclasses:
DefaultProcessingInstruction
public class FlyweightProcessingInstruction
extends AbstractProcessingInstruction

FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.

This node could be shared across documents and elements though it does not support the parent relationship.

Version:
$Revision: 1.7 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected String | target The target of the PI
protected String | text The values for the PI as a String
protected Map | values The values for the PI in name/value pairs
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
FlyweightProcessingInstruction()
A default constructor for implementors to use.
FlyweightProcessingInstruction(String target, Map values)
This will create a new PI with the given target and values
FlyweightProcessingInstruction(String target, String text)
This will create a new PI with the given target and values
Method Summary
protected  Node createXPathResult(Element parent)
 String getTarget()
This method is the equivalent to the AbstractProcessingInstruction.getName()method.
 String getText()
DOCUMENT ME!
 String getValue(String name)
Returns the value of a specific name in the PI.
 Map getValues()
DOCUMENT ME!
 void setTarget(String target)
This method is the equivalent to the AbstractProcessingInstruction.setName(java.lang.String)method.
Methods inherited from class org.dom4j.tree.AbstractProcessingInstruction
accept, asXML, getName, getNodeType, getPath, getUniquePath, parseValues, removeValue, setName, setValue, setValues, toString, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setParent, setText, supportsParent, valueOf

Field Detail

target

protected String target
The target of the PI

text

protected String text
The values for the PI as a String

values

protected Map values
The values for the PI in name/value pairs

Constructor Detail

FlyweightProcessingInstruction

public FlyweightProcessingInstruction()
A default constructor for implementors to use.

FlyweightProcessingInstruction

public FlyweightProcessingInstruction(String target,
                                      Map values)

This will create a new PI with the given target and values

Parameters:
target - is the name of the PI
values - is the Map of the values for the PI

FlyweightProcessingInstruction

public FlyweightProcessingInstruction(String target,
                                      String text)

This will create a new PI with the given target and values

Parameters:
target - is the name of the PI
text - is the values for the PI as text
Method Detail

getTarget

public String getTarget()
Description copied from interface: ProcessingInstruction
This method is the equivalent to the Node.getName()method. It is added for clarity.

Returns:
the target of this PI

setTarget

public void setTarget(String target)
Description copied from interface: ProcessingInstruction
This method is the equivalent to the Node.setName(java.lang.String)method. It is added for clarity.

Parameters:
target - DOCUMENT ME!

getText

public String getText()
Description copied from interface: ProcessingInstruction
DOCUMENT ME!

Specified by:
getText in interface ProcessingInstruction
Overrides:
getText in class AbstractNode

getValue

public String getValue(String name)
Description copied from interface: ProcessingInstruction

Returns the value of a specific name in the PI.

Parameters:
name - is the name of the attribute to lookup.
Returns:
the value of the named attribute

getValues

public Map getValues()
Description copied from interface: ProcessingInstruction
DOCUMENT ME!

Returns:
the values for this processing instruction as a Map

createXPathResult

protected Node createXPathResult(Element parent)
Overrides:
createXPathResult in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


FlyweightText (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class FlyweightText

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractCharacterData
            extended by org.dom4j.tree.AbstractText
                extended by org.dom4j.tree.FlyweightText
All Implemented Interfaces:
CharacterData, Cloneable, Node, Serializable, Text
Direct Known Subclasses:
DefaultText
public class FlyweightText
extends AbstractText
implements Text

FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.

This node could be shared across documents and elements though it does not support the parent relationship.

Version:
$Revision: 1.7 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected  String text
Text of the Text node
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
FlyweightText(String text)
DOCUMENT ME!
Method Summary
protected Node | createXPathResult(Element parent)
String | getText() Returns the text of this node.
Methods inherited from class org.dom4j.tree.AbstractText
accept, asXML, getNodeType, toString, write
Methods inherited from class org.dom4j.tree.AbstractCharacterData
appendText, getPath, getUniquePath
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getName, getNodeTypeName, getParent, getPath, getStringValue, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.CharacterData
appendText
Methods inherited from interface org.dom4j.Node
accept, asXML, asXPathResult, clone, createXPath, detach, getDocument, getName, getNodeType, getNodeTypeName, getParent, getPath, getPath, getStringValue, getUniquePath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, setParent, setText, supportsParent, valueOf, write

Field Detail

text

protected String text
Text of the Text node

Constructor Detail

FlyweightText

public FlyweightText(String text)
DOCUMENT ME!

Parameters:
text - is the Text text
Method Detail

getText

public String getText()
Description copied from interface: Node

Returns the text of this node.

Specified by:
getText in interface Node
Overrides:
getText in class AbstractNode

createXPathResult

protected Node createXPathResult(Element parent)
Overrides:
createXPathResult in class AbstractNode
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamespaceCache (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class NamespaceCache

java.lang.Object
    extended by org.dom4j.tree.NamespaceCache
public class NamespaceCache
extends Object

NamespaceCache caches instances of DefaultNamespace for reuse both across documents and within documents.

Version:
$Revision: 1.15 $
Author:
James Strachan , Maarten Coene, Brett Finnell

Field Summary
protected static Map | cache Cache of Mapinstances indexed by URI which contain caches of Namespacefor each prefix
protected static Map | noPrefixCache Cache of Namespaceinstances indexed by URI for default namespaces with no prefixes
Constructor Summary
NamespaceCache()
Method Summary
protected Namespace | createNamespace(String prefix, String uri) A factory method to create Namespaceinstance
Namespace | get(String uri) DOCUMENT ME!
Namespace | get(String prefix, String uri) DOCUMENT ME!
protected Map | getURICache(String uri) DOCUMENT ME!
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

cache

protected static Map cache
Cache of Mapinstances indexed by URI which contain caches of Namespacefor each prefix

noPrefixCache

protected static Map noPrefixCache
Cache of Namespaceinstances indexed by URI for default namespaces with no prefixes

Constructor Detail

NamespaceCache

public NamespaceCache()
Method Detail

get

public Namespace get(String prefix,
                     String uri)
DOCUMENT ME!

Parameters:
prefix - DOCUMENT ME!
uri - DOCUMENT ME!
Returns:
the namespace for the given prefix and uri

get

public Namespace get(String uri)
DOCUMENT ME!

Parameters:
uri - DOCUMENT ME!
Returns:
the name model for the given name and namepsace

getURICache

protected Map getURICache(String uri)
DOCUMENT ME!

Parameters:
uri - DOCUMENT ME!
Returns:
the cache for the given namespace URI. If one does not currently exist it is created.

createNamespace

protected Namespace createNamespace(String prefix,
                                    String uri)
A factory method to create Namespaceinstance

Parameters:
prefix - DOCUMENT ME!
uri - DOCUMENT ME!
Returns:
a newly created Namespaceinstance.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NamespaceStack (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class NamespaceStack

java.lang.Object
    extended by org.dom4j.tree.NamespaceStack
public class NamespaceStack
extends Object

NamespaceStack implements a stack of namespaces and optionally maintains a cache of all the fully qualified names (QName) which are in scope. This is useful when building or navigating a dom4j document.

Version:
$Revision: 1.13 $
Author:
James Strachan

Constructor Summary
NamespaceStack()
NamespaceStack(DocumentFactory documentFactory)
Method Summary
Namespace | addNamespace(String prefix, String uri) Adds a new namespace to the stack
void | clear() Clears the stack
boolean | contains(Namespace namespace) DOCUMENT ME!
protected Namespace | createNamespace(String prefix, String namespaceURI) Factory method to creeate new Namespace instances.
protected QName | createQName(String localName, String qualifiedName, Namespace namespace) Factory method to creeate new QName instances.
protected Namespace | findDefaultNamespace() Attempts to find the current default namespace on the stack right now or returns null if one could not be found
QName | getAttributeQName(String namespaceURI, String localName, String qualifiedName)
Namespace | getDefaultNamespace()
DocumentFactory | getDocumentFactory()
Namespace | getNamespace(int index) DOCUMENT ME!
protected Map | getNamespaceCache()
Namespace | getNamespaceForPrefix(String prefix) DOCUMENT ME!
QName | getQName(String namespaceURI, String localName, String qualifiedName)
String | getURI(String prefix) DOCUMENT ME!
Namespace | pop() Pops the most recently used Namespace from the stack
Namespace | pop(String prefix) Pops a namepace from the stack with the given prefix and URI
void | push(Namespace namespace) Pushes the given namespace onto the stack so that its prefix becomes available.
void | push(String prefix, String uri) Adds a namepace to the stack with the given prefix and URI
protected QName | pushQName(String localName, String qualifiedName, Namespace namespace, String prefix) Adds the QName to the stack of available QNames
protected Namespace | remove(int index) Removes the namespace at the given index of the stack
void | setDocumentFactory(DocumentFactory documentFactory)
int | size() DOCUMENT ME!
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

NamespaceStack

public NamespaceStack()

NamespaceStack

public NamespaceStack(DocumentFactory documentFactory)
Method Detail

push

public void push(Namespace namespace)
Pushes the given namespace onto the stack so that its prefix becomes available.

Parameters:
namespace - is the Namespace to add to the stack.

pop

public Namespace pop()
Pops the most recently used Namespace from the stack

Returns:
Namespace popped from the stack

size

public int size()
DOCUMENT ME!

Returns:
the number of namespaces on the stackce stack.

clear

public void clear()
Clears the stack

getNamespace

public Namespace getNamespace(int index)
DOCUMENT ME!

Parameters:
index - DOCUMENT ME!
Returns:
the namespace at the specified index on the stack

getNamespaceForPrefix

public Namespace getNamespaceForPrefix(String prefix)
DOCUMENT ME!

Parameters:
prefix - DOCUMENT ME!
Returns:
the namespace for the given prefix or null if it could not be found.

getURI

public String getURI(String prefix)
DOCUMENT ME!

Parameters:
prefix - DOCUMENT ME!
Returns:
the URI for the given prefix or null if it could not be found.

contains

public boolean contains(Namespace namespace)
DOCUMENT ME!

Parameters:
namespace - DOCUMENT ME!
Returns:
true if the given prefix is in the stack.

getQName

public QName getQName(String namespaceURI,
                      String localName,
                      String qualifiedName)

getAttributeQName

public QName getAttributeQName(String namespaceURI,
                               String localName,
                               String qualifiedName)

push

public void push(String prefix,
                 String uri)
Adds a namepace to the stack with the given prefix and URI

Parameters:
prefix - DOCUMENT ME!
uri - DOCUMENT ME!

addNamespace

public Namespace addNamespace(String prefix,
                              String uri)
Adds a new namespace to the stack

Parameters:
prefix - DOCUMENT ME!
uri - DOCUMENT ME!
Returns:
DOCUMENT ME!

pop

public Namespace pop(String prefix)
Pops a namepace from the stack with the given prefix and URI

Parameters:
prefix - DOCUMENT ME!
Returns:
DOCUMENT ME!

toString

public String toString()

getDocumentFactory

public DocumentFactory getDocumentFactory()

setDocumentFactory

public void setDocumentFactory(DocumentFactory documentFactory)

getDefaultNamespace

public Namespace getDefaultNamespace()

pushQName

protected QName pushQName(String localName,
                          String qualifiedName,
                          Namespace namespace,
                          String prefix)
Adds the QName to the stack of available QNames

Parameters:
localName - DOCUMENT ME!
qualifiedName - DOCUMENT ME!
namespace - DOCUMENT ME!
prefix - DOCUMENT ME!
Returns:
DOCUMENT ME!

createQName

protected QName createQName(String localName,
                            String qualifiedName,
                            Namespace namespace)
Factory method to creeate new QName instances. By default this method interns the QName

Parameters:
localName - DOCUMENT ME!
qualifiedName - DOCUMENT ME!
namespace - DOCUMENT ME!
Returns:
DOCUMENT ME!

createNamespace

protected Namespace createNamespace(String prefix,
                                    String namespaceURI)
Factory method to creeate new Namespace instances. By default this method interns the Namespace

Parameters:
prefix - DOCUMENT ME!
namespaceURI - DOCUMENT ME!
Returns:
DOCUMENT ME!

findDefaultNamespace

protected Namespace findDefaultNamespace()
Attempts to find the current default namespace on the stack right now or returns null if one could not be found

Returns:
DOCUMENT ME!

remove

protected Namespace remove(int index)
Removes the namespace at the given index of the stack

Parameters:
index - DOCUMENT ME!
Returns:
DOCUMENT ME!

getNamespaceCache

protected Map getNamespaceCache()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


QNameCache (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class QNameCache

java.lang.Object
    extended by org.dom4j.tree.QNameCache
public class QNameCache
extends Object

QNameCache caches instances of QName for reuse both across documents and within documents.

< < < < < < < QNameCache.java

Version:
$Revision: 1.16 $ =======, $Revision: 1.16 $ >>>>>>> 1.15
Author:
James Strachan , James Strachan

Field Summary
protected Map | namespaceCache Cache of Mapinstances indexed by namespace which contain caches of QNamefor each name
protected Map | noNamespaceCache Cache of QNameinstances with no namespace
Constructor Summary
QNameCache()
QNameCache(DocumentFactory documentFactory)
Method Summary
protected Map | createMap() A factory method
protected QName | createQName(String name) Factory method to create a new QName object which can be overloaded to create derived QName instances
protected QName | createQName(String name, Namespace namespace) Factory method to create a new QName object which can be overloaded to create derived QName instances
protected QName | createQName(String name, Namespace namespace, String qualifiedName) Factory method to create a new QName object which can be overloaded to create derived QName instances
QName | get(String name) DOCUMENT ME!
QName | get(String name, Namespace namespace) DOCUMENT ME!
QName | get(String localName, Namespace namespace, String qName) DOCUMENT ME!
QName | get(String qualifiedName, String uri)
protected Map | getNamespaceCache(Namespace namespace) DOCUMENT ME!
List | getQNames() Returns a list of all the QName instances currently used
QName | intern(QName qname) DOCUMENT ME!
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

noNamespaceCache

protected Map noNamespaceCache
Cache of QNameinstances with no namespace

namespaceCache

protected Map namespaceCache
Cache of Mapinstances indexed by namespace which contain caches of QNamefor each name

Constructor Detail

QNameCache

public QNameCache()

QNameCache

public QNameCache(DocumentFactory documentFactory)
Method Detail

getQNames

public List getQNames()
Returns a list of all the QName instances currently used

Returns:
DOCUMENT ME!

get

public QName get(String name)
DOCUMENT ME!

Parameters:
name - DOCUMENT ME!
Returns:
the QName for the given name and no namepsace

get

public QName get(String name,
                 Namespace namespace)
DOCUMENT ME!

Parameters:
name - DOCUMENT ME!
namespace - DOCUMENT ME!
Returns:
the QName for the given local name and namepsace

get

public QName get(String localName,
                 Namespace namespace,
                 String qName)
DOCUMENT ME!

Parameters:
localName - DOCUMENT ME!
namespace - DOCUMENT ME!
qName - DOCUMENT ME!
Returns:
the QName for the given local name, qualified name and namepsace

get

public QName get(String qualifiedName,
                 String uri)

intern

public QName intern(QName qname)
DOCUMENT ME!

Parameters:
qname - DOCUMENT ME!
Returns:
the cached QName instance if there is one or adds the given qname to the cache if not

getNamespaceCache

protected Map getNamespaceCache(Namespace namespace)
DOCUMENT ME!

Parameters:
namespace - DOCUMENT ME!
Returns:
the cache for the given namespace. If one does not currently exist it is created.

createMap

protected Map createMap()
A factory method

Returns:
a newly created Mapinstance.

createQName

protected QName createQName(String name)
Factory method to create a new QName object which can be overloaded to create derived QName instances

Parameters:
name - DOCUMENT ME!
Returns:
DOCUMENT ME!

createQName

protected QName createQName(String name,
                            Namespace namespace)
Factory method to create a new QName object which can be overloaded to create derived QName instances

Parameters:
name - DOCUMENT ME!
namespace - DOCUMENT ME!
Returns:
DOCUMENT ME!

createQName

protected QName createQName(String name,
                            Namespace namespace,
                            String qualifiedName)
Factory method to create a new QName object which can be overloaded to create derived QName instances

Parameters:
name - DOCUMENT ME!
namespace - DOCUMENT ME!
qualifiedName - DOCUMENT ME!
Returns:
DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SingleIterator (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class SingleIterator

java.lang.Object
    extended by org.dom4j.tree.SingleIterator
All Implemented Interfaces:
Iterator
public class SingleIterator
extends Object
implements Iterator

SingleIterator is an Iteratorover a single object instance.

Version:
$Revision: 1.9 $
Author:
James Strachan

Constructor Summary
SingleIterator(Object object)
Method Summary
boolean | hasNext()
Object | next()
void | remove()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SingleIterator

public SingleIterator(Object object)
Method Detail

hasNext

public boolean hasNext()
Specified by:
hasNext in interface Iterator

next

public Object next()
Specified by:
next in interface Iterator

remove

public void remove()
Specified by:
remove in interface Iterator
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.util (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.util

A collection of utility classes for the dom4j API.

See:
Description

Interface Summary
SingletonStrategy SingletonStrategy is an interface used to provide common factory access for the same object based on an implementation strategy for singleton.

Class Summary
AttributeHelper | AttributeHelper a number of helper methods for working with attribute values.
IndexedDocumentFactory | IndexedDocumentFactory is a factory of XML objects which create indexed Element implementations to allow quicker lookup via name of Element and Attributes though at the expense of more memory used to create the name indexes.
IndexedElement | IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
NodeComparator | NodeComparator is a Comparatorof Node instances which is capable of comparing Nodes for equality based on their values.
NonLazyDocumentFactory | NonLazyDocumentFactory is a factory of XML objects which avoid using the lazy creation pattern.
NonLazyElement | NonLazyElement is the default DOM4J default implementation of an XML element.
PerThreadSingleton | PerThreadSingleton is an implementation of the SingletonStrategy used to provide common factory access to a single object instance based on an implementation strategy for one object instance per thread.
ProxyDocumentFactory | ProxyDocumentFactory implements a proxy to a DocumentFactory which is useful for implementation inheritence, allowing the pipelining of various factory implementations.
SimpleSingleton | SimpleSingleton is an implementation of the SingletonStrategy interface used to provide common factory access for the same object instance.
UserDataAttribute | UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataAttribute.setData(Object)will get and set the values of a user data object.
UserDataDocumentFactory | UserDataDocumentFactory is a factory of XML objects which support the adornment of a user data object on an Element or Attribute instance such that the methods getData() and setData() will get and set the values of a user data object.
UserDataElement | UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.
XMLErrorHandler | XMLErrorHandler is a SAX ErrorHandlerwhich turns the SAX parsing errors into XML so that the output can be formatted using XSLT or the errors can be included in a SOAP message.

Package org.dom4j.util Description

A collection of utility classes for the dom4j API.


org.dom4j.util Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.util

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.tree.AbstractNode (implements java.lang.Cloneable, org.dom4j.Node, java.io.Serializable)
      • class org.dom4j.tree.AbstractAttribute (implements org.dom4j.Attribute)
        • class org.dom4j.tree.FlyweightAttribute
          • class org.dom4j.tree.DefaultAttribute
            • class org.dom4j.util.UserDataAttribute
      • class org.dom4j.tree.AbstractBranch (implements org.dom4j.Branch)
        • class org.dom4j.tree.AbstractElement (implements org.dom4j.Element)
          • class org.dom4j.tree.BaseElement
            • class org.dom4j.util.NonLazyElement
          • class org.dom4j.tree.DefaultElement
            • class org.dom4j.util.IndexedElement
            • class org.dom4j.util.UserDataElement
    • class org.dom4j.util.AttributeHelper
    • class org.dom4j.DocumentFactory (implements java.io.Serializable)
      • class org.dom4j.util.IndexedDocumentFactory
      • class org.dom4j.util.NonLazyDocumentFactory
      • class org.dom4j.util.UserDataDocumentFactory
    • class org.dom4j.util.NodeComparator (implements java.util.Comparator)
    • class org.dom4j.util.PerThreadSingleton (implements org.dom4j.util.SingletonStrategy)
    • class org.dom4j.util.ProxyDocumentFactory
    • class org.dom4j.util.SimpleSingleton (implements org.dom4j.util.SingletonStrategy)
    • class org.dom4j.util.XMLErrorHandler (implements org.xml.sax.ErrorHandler)

Interface Hierarchy

  • interface org.dom4j.util.SingletonStrategy


Uses of Package org.dom4j.util (dom4j 1.6.1 API)

Uses of Package
org.dom4j.util

Packages that use org.dom4j.util
org.dom4j.util A collection of utility classes for the dom4j API.

Classes in org.dom4j.util used by org.dom4j.util
IndexedDocumentFactory
IndexedDocumentFactory is a factory of XML objects which create indexed Element implementations to allow quicker lookup via name of Element and Attributes though at the expense of more memory used to create the name indexes.
NonLazyDocumentFactory
NonLazyDocumentFactory is a factory of XML objects which avoid using the lazy creation pattern.
SingletonStrategy
SingletonStrategy is an interface used to provide common factory access for the same object based on an implementation strategy for singleton.
UserDataDocumentFactory
UserDataDocumentFactory is a factory of XML objects which support the adornment of a user data object on an Element or Attribute instance such that the methods getData() and setData() will get and set the values of a user data object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


SingletonStrategy (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Interface SingletonStrategy

All Known Implementing Classes:
PerThreadSingleton, SimpleSingleton
public interface SingletonStrategy

SingletonStrategy is an interface used to provide common factory access for the same object based on an implementation strategy for singleton. Right now there are two that accompany this interface: SimpleSingleton and PerThreadSingleton. This will replace previous usage of ThreadLocal to allow for alternate strategies.

Version:
$Revision: 1.2 $
Author:
David Lucas

Method Summary
Object | instance() return a singleton instance of the class specified in setSingletonClass
void | reset() reset the instance to a new instance for the implemented strategy
void | setSingletonClassName(String singletonClassName) set a singleton class name that will be used to create the singleton based on the strategy implementation of this interface.

Method Detail

instance

public Object instance()
return a singleton instance of the class specified in setSingletonClass

reset

public void reset()
reset the instance to a new instance for the implemented strategy

setSingletonClassName

public void setSingletonClassName(String singletonClassName)
set a singleton class name that will be used to create the singleton based on the strategy implementation of this interface. The default constructor of the class will be used and must be public.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AttributeHelper (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class AttributeHelper

java.lang.Object
    extended by org.dom4j.util.AttributeHelper
public class AttributeHelper
extends Object

AttributeHelper a number of helper methods for working with attribute values.

Version:
$Revision: 1.7 $
Author:
James Strachan

Constructor Summary
protected AttributeHelper()
Method Summary
protected static boolean | booleanValue(Attribute attribute)
static boolean | booleanValue(Element element, QName attributeQName)
static boolean | booleanValue(Element element, String attributeName)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

AttributeHelper

protected AttributeHelper()
Method Detail

booleanValue

public static boolean booleanValue(Element element,
                                   String attributeName)

booleanValue

public static boolean booleanValue(Element element,
                                   QName attributeQName)

booleanValue

protected static boolean booleanValue(Attribute attribute)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


IndexedDocumentFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class IndexedDocumentFactory

java.lang.Object
    extended by org.dom4j.DocumentFactory
        extended by org.dom4j.util.IndexedDocumentFactory
All Implemented Interfaces:
Serializable
public class IndexedDocumentFactory
extends DocumentFactory

IndexedDocumentFactory is a factory of XML objects which create indexed Element implementations to allow quicker lookup via name of Element and Attributes though at the expense of more memory used to create the name indexes.

Version:
$Revision: 1.9 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static IndexedDocumentFactory singleton
The Singleton instance
Fields inherited from class org.dom4j.DocumentFactory
cache
Constructor Summary
IndexedDocumentFactory()
Method Summary
Element | createElement(QName qname)
Element | createElement(QName qname, int attributeCount)
static DocumentFactory | getInstance() Access to the singleton instance of this factory.
Methods inherited from class org.dom4j.DocumentFactory
createAttribute, createAttribute, createCDATA, createComment, createDocType, createDocument, createDocument, createDocument, createElement, createElement, createEntity, createNamespace, createPattern, createProcessingInstruction, createProcessingInstruction, createQName, createQName, createQName, createQName, createQNameCache, createSingleton, createText, createXPath, createXPath, createXPathFilter, createXPathFilter, getQNames, getXPathNamespaceURIs, init, intern, setXPathNamespaceURIs
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

singleton

protected static transient IndexedDocumentFactory singleton
The Singleton instance

Constructor Detail

IndexedDocumentFactory

public IndexedDocumentFactory()
Method Detail

getInstance

public static DocumentFactory getInstance()

Access to the singleton instance of this factory.

Returns:
the default singleon instance

createElement

public Element createElement(QName qname)
Overrides:
createElement in class DocumentFactory

createElement

public Element createElement(QName qname,
                             int attributeCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IndexedElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class IndexedElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
                extended by org.dom4j.tree.DefaultElement
                    extended by org.dom4j.util.IndexedElement
All Implemented Interfaces:
Branch, Cloneable, Element, Node, Serializable
public class IndexedElement
extends DefaultElement

IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.

Version:
$Revision: 1.10 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR, EMPTY_LIST, USE_STRINGVALUE_SEPARATOR, VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
IndexedElement(QName qname)
IndexedElement(QName qname, int attributeCount)
IndexedElement(String name)
Method Summary
protected void | addNode(Node node)
protected void | addToAttributeIndex(Attribute attribute)
protected void | addToAttributeIndex(Object key, Attribute value)
protected void | addToElementIndex(Element element)
protected void | addToElementIndex(Object key, Element value)
protected Element | asElement(Object object)
protected Iterator | asElementIterator(Object object) Deprecated. WILL BE REMOVED IN dom4j-1.6 !!
protected List | asElementList(Object object)
Attribute | attribute(QName qName) DOCUMENT ME!
Attribute | attribute(String name) Returns the attribute with the given name
protected Map | attributeIndex()
protected Map | createAttributeIndex() A Factory Method to create the index for attributes
protected Map | createElementIndex() A Factory Method to create the index for elements
protected Map | createIndex() Factory method to return a new map implementation for indices
protected List | createList() Factory method to return a list implementation for indices
Element | element(QName qName) Returns the first element for the given fully qualified name.
Element | element(String name) Returns the first element for the given local name and any namespace.
protected Map | elementIndex()
List | elements(QName qName) Returns the elements contained in this element with the given fully qualified name.
List | elements(String name) Returns the elements contained in this element with the given local name and any namespace.
protected void | removeFromAttributeIndex(Attribute attribute)
protected void | removeFromAttributeIndex(Object key, Attribute value)
protected void | removeFromElementIndex(Element element)
protected void | removeFromElementIndex(Object key, Element value)
protected boolean | removeNode(Node node)
Methods inherited from class org.dom4j.tree.DefaultElement
add, additionalNamespaces, additionalNamespaces, addNewNode, attribute, attribute, attributeCount, attributeIterator, attributeList, attributeList, attributes, clearContent, clone, contentList, declaredNamespaces, element, getDocument, getDocumentFactory, getNamespaceForPrefix, getNamespaceForURI, getParent, getQName, getStringValue, getText, indexOf, node, nodeCount, nodeIterator, processingInstruction, processingInstructions, processingInstructions, remove, removeProcessingInstruction, setAttributeList, setAttributes, setContent, setDocument, setParent, setQName, supportsParent
Methods inherited from class org.dom4j.tree.AbstractElement
accept, add, add, add, add, add, add, add, add, addAttribute, addAttribute, addCDATA, addComment, addElement, addEntity, addNamespace, addNewNode, addNode, addProcessingInstruction, addProcessingInstruction, addText, appendAttributes, asXML, attributeValue, attributeValue, attributeValue, attributeValue, childAdded, childRemoved, createAttributeList, createAttributeList, createCopy, createCopy, createCopy, createElement, createElement, createSingleIterator, elementIterator, elementIterator, elementIterator, elementIterator, elements, elements, elementText, elementText, elementTextTrim, elementTextTrim, ensureAttributesCapacity, getData, getName, getNamespace, getNamespacePrefix, getNamespacesForURI, getNamespaceURI, getNodeType, getPath, getQName, getQualifiedName, getUniquePath, getXPathNameStep, getXPathResult, hasMixedContent, isRootElement, isTextOnly, normalize, remove, remove, remove, remove, remove, remove, remove, remove, setAttributes, setAttributeValue, setAttributeValue, setData, setName, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Element
getTextTrim
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, content, elementByID, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, createXPath, detach, getNodeTypeName, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf

Constructor Detail

IndexedElement

public IndexedElement(String name)

IndexedElement

public IndexedElement(QName qname)

IndexedElement

public IndexedElement(QName qname,
                      int attributeCount)
Method Detail

attribute

public Attribute attribute(String name)
Description copied from interface: Element
Returns the attribute with the given name

Specified by:
attribute in interface Element
Overrides:
attribute in class DefaultElement

attribute

public Attribute attribute(QName qName)
Description copied from interface: Element
DOCUMENT ME!

Specified by:
attribute in interface Element
Overrides:
attribute in class DefaultElement

element

public Element element(String name)
Description copied from interface: Element
Returns the first element for the given local name and any namespace.

Specified by:
element in interface Element
Overrides:
element in class DefaultElement

element

public Element element(QName qName)
Description copied from interface: Element
Returns the first element for the given fully qualified name.

Specified by:
element in interface Element
Overrides:
element in class DefaultElement

elements

public List elements(String name)
Description copied from interface: Element

Returns the elements contained in this element with the given local name and any namespace. If no elements are found then this method returns an empty list. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
elements in interface Element
Overrides:
elements in class AbstractElement

elements

public List elements(QName qName)
Description copied from interface: Element

Returns the elements contained in this element with the given fully qualified name. If no elements are found then this method returns an empty list. The list is backed by the element such that changes to the list will be reflected in the element though the reverse is not the case.

Specified by:
elements in interface Element
Overrides:
elements in class AbstractElement

asElement

protected Element asElement(Object object)

asElementList

protected List asElementList(Object object)

asElementIterator

protected Iterator asElementIterator(Object object)
Deprecated. WILL BE REMOVED IN dom4j-1.6 !!

DOCUMENT ME!

Parameters:
object - DOCUMENT ME!
Returns:
DOCUMENT ME!

addNode

protected void addNode(Node node)
Overrides:
addNode in class AbstractElement

removeNode

protected boolean removeNode(Node node)
Overrides:
removeNode in class DefaultElement

attributeIndex

protected Map attributeIndex()

elementIndex

protected Map elementIndex()

createAttributeIndex

protected Map createAttributeIndex()
A Factory Method to create the index for attributes

Returns:
DOCUMENT ME!

createElementIndex

protected Map createElementIndex()
A Factory Method to create the index for elements

Returns:
DOCUMENT ME!

addToElementIndex

protected void addToElementIndex(Element element)

addToElementIndex

protected void addToElementIndex(Object key,
                                 Element value)

removeFromElementIndex

protected void removeFromElementIndex(Element element)

removeFromElementIndex

protected void removeFromElementIndex(Object key,
                                      Element value)

addToAttributeIndex

protected void addToAttributeIndex(Attribute attribute)

addToAttributeIndex

protected void addToAttributeIndex(Object key,
                                   Attribute value)

removeFromAttributeIndex

protected void removeFromAttributeIndex(Attribute attribute)

removeFromAttributeIndex

protected void removeFromAttributeIndex(Object key,
                                        Attribute value)

createIndex

protected Map createIndex()
Factory method to return a new map implementation for indices

Returns:
DOCUMENT ME!

createList

protected List createList()
Factory method to return a list implementation for indices

Returns:
DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NodeComparator (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class NodeComparator

java.lang.Object
    extended by org.dom4j.util.NodeComparator
All Implemented Interfaces:
Comparator
public class NodeComparator
extends Object
implements Comparator

NodeComparator is a Comparatorof Node instances which is capable of comparing Nodes for equality based on their values.

Version:
$Revision: 1.10 $
Author:
James Strachan

Constructor Summary
NodeComparator()
Method Summary
int | compare(Attribute n1, Attribute n2)
int | compare(CharacterData t1, CharacterData t2)
int | compare(Document n1, Document n2)
int | compare(DocumentType o1, DocumentType o2)
int | compare(Element n1, Element n2)
int | compare(Entity n1, Entity n2)
int | compare(Namespace n1, Namespace n2)
int | compare(Node n1, Node n2)
int | compare(Object o1, Object o2) Compares its two arguments for order.
int | compare(ProcessingInstruction n1, ProcessingInstruction n2)
int | compare(QName n1, QName n2)
int | compare(String o1, String o2)
int | compareContent(Branch b1, Branch b2)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface java.util.Comparator
equals

Constructor Detail

NodeComparator

public NodeComparator()
Method Detail

compare

public int compare(Object o1,
                   Object o2)
Compares its two arguments for order. Returns a negative integer, zero, or a positive integer as the first argument is less than, equal to, or greater than the second.

The implementor must ensure that sgn(compare(x, y)) == -sgn(compare(y, x)) for all x and y. (This implies that compare(x, y) must throw an exception if and only if compare(y, x) throws an exception.)

The implementor must also ensure that the relation is transitive: ((compare(x, y)>0) && (compare(y, z)>0)) implies compare(x, z)>0.

Finally, the implementer must ensure that compare(x, y)==0 implies that sgn(compare(x, z))==sgn(compare(y, z)) for all z.

It is generally the case, but not strictly required that (compare(x, y)==0) == (x.equals(y)). Generally speaking, any comparator that violates this condition should clearly indicate this fact. The recommended language is "Note: this comparator imposes orderings that are inconsistent with equals."

Specified by:
compare in interface Comparator
Parameters:
o1 - the first object to be compared.
o2 - the second object to be compared.
Returns:
a negative integer, zero, or a positive integer as the first argument is less than, equal to, or greater than the second.

compare

public int compare(Node n1,
                   Node n2)

compare

public int compare(Document n1,
                   Document n2)

compare

public int compare(Element n1,
                   Element n2)

compare

public int compare(Attribute n1,
                   Attribute n2)

compare

public int compare(QName n1,
                   QName n2)

compare

public int compare(Namespace n1,
                   Namespace n2)

compare

public int compare(CharacterData t1,
                   CharacterData t2)

compare

public int compare(DocumentType o1,
                   DocumentType o2)

compare

public int compare(Entity n1,
                   Entity n2)

compare

public int compare(ProcessingInstruction n1,
                   ProcessingInstruction n2)

compareContent

public int compareContent(Branch b1,
                          Branch b2)

compare

public int compare(String o1,
                   String o2)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonLazyDocumentFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class NonLazyDocumentFactory

java.lang.Object
    extended by org.dom4j.DocumentFactory
        extended by org.dom4j.util.NonLazyDocumentFactory
All Implemented Interfaces:
Serializable
public class NonLazyDocumentFactory
extends DocumentFactory

NonLazyDocumentFactory is a factory of XML objects which avoid using the lazy creation pattern. This results in a slower creation of a Document and uses more memory but it means that the same Document instance can be shared across threads provided it is not modified.

Version:
$Revision: 1.9 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static NonLazyDocumentFactory singleton
The Singleton instance
Fields inherited from class org.dom4j.DocumentFactory
cache
Constructor Summary
NonLazyDocumentFactory()
Method Summary
Element | createElement(QName qname)
static DocumentFactory | getInstance() Access to the singleton instance of this factory.
Methods inherited from class org.dom4j.DocumentFactory
createAttribute, createAttribute, createCDATA, createComment, createDocType, createDocument, createDocument, createDocument, createElement, createElement, createEntity, createNamespace, createPattern, createProcessingInstruction, createProcessingInstruction, createQName, createQName, createQName, createQName, createQNameCache, createSingleton, createText, createXPath, createXPath, createXPathFilter, createXPathFilter, getQNames, getXPathNamespaceURIs, init, intern, setXPathNamespaceURIs
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

singleton

protected static transient NonLazyDocumentFactory singleton
The Singleton instance

Constructor Detail

NonLazyDocumentFactory

public NonLazyDocumentFactory()
Method Detail

getInstance

public static DocumentFactory getInstance()

Access to the singleton instance of this factory.

Returns:
the default singleon instance

createElement

public Element createElement(QName qname)
Overrides:
createElement in class DocumentFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NonLazyElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class NonLazyElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
                extended by org.dom4j.tree.BaseElement
                    extended by org.dom4j.util.NonLazyElement
All Implemented Interfaces:
Branch, Cloneable, Element, Node, Serializable
public class NonLazyElement
extends BaseElement

NonLazyElement is the default DOM4J default implementation of an XML element.

Version:
$Revision: 1.8 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.BaseElement
attributes, content
Fields inherited from class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR, EMPTY_LIST, USE_STRINGVALUE_SEPARATOR, VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
NonLazyElement(QName qname)
NonLazyElement(QName qname, int attributeCount)
NonLazyElement(String name)
NonLazyElement(String name, Namespace namespace)
Methods inherited from class org.dom4j.tree.BaseElement
attributeList, attributeList, clearContent, contentList, getDocument, getParent, getQName, setAttributeList, setAttributes, setContent, setDocument, setParent, setQName, supportsParent
Methods inherited from class org.dom4j.tree.AbstractElement
accept, add, add, add, add, add, add, add, add, add, addAttribute, addAttribute, addCDATA, addComment, addElement, addEntity, additionalNamespaces, additionalNamespaces, addNamespace, addNewNode, addNewNode, addNode, addNode, addProcessingInstruction, addProcessingInstruction, addText, appendAttributes, asXML, attribute, attribute, attribute, attribute, attributeCount, attributeIterator, attributes, attributeValue, attributeValue, attributeValue, attributeValue, childAdded, childRemoved, createAttributeList, createAttributeList, createCopy, createCopy, createCopy, createElement, createElement, createSingleIterator, declaredNamespaces, element, element, element, elementIterator, elementIterator, elementIterator, elementIterator, elements, elements, elements, elements, elementText, elementText, elementTextTrim, elementTextTrim, ensureAttributesCapacity, getData, getDocumentFactory, getName, getNamespace, getNamespaceForPrefix, getNamespaceForURI, getNamespacePrefix, getNamespacesForURI, getNamespaceURI, getNodeType, getPath, getQName, getQualifiedName, getStringValue, getUniquePath, getXPathNameStep, getXPathResult, hasMixedContent, indexOf, isRootElement, isTextOnly, node, nodeCount, nodeIterator, normalize, processingInstruction, processingInstructions, processingInstructions, remove, remove, remove, remove, remove, remove, remove, remove, remove, removeNode, removeProcessingInstruction, setAttributes, setAttributeValue, setAttributeValue, setData, setName, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Element
getText, getTextTrim
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, content, elementByID, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getNodeTypeName, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf

Constructor Detail

NonLazyElement

public NonLazyElement(String name)

NonLazyElement

public NonLazyElement(QName qname)

NonLazyElement

public NonLazyElement(String name,
                      Namespace namespace)

NonLazyElement

public NonLazyElement(QName qname,
                      int attributeCount)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


PerThreadSingleton (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class PerThreadSingleton

java.lang.Object
    extended by org.dom4j.util.PerThreadSingleton
All Implemented Interfaces:
SingletonStrategy
public class PerThreadSingleton
extends Object
implements SingletonStrategy

PerThreadSingleton is an implementation of the SingletonStrategy used to provide common factory access to a single object instance based on an implementation strategy for one object instance per thread. This is useful in replace of the ThreadLocal usage.

Version:
$Revision: 1.3 $
Author:
David Lucas

Constructor Summary
PerThreadSingleton()
Method Summary
Object | instance() return a singleton instance of the class specified in setSingletonClass
void | reset() reset the instance to a new instance for the implemented strategy
void | setSingletonClassName(String singletonClassName) set a singleton class name that will be used to create the singleton based on the strategy implementation of this interface.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

PerThreadSingleton

public PerThreadSingleton()
Method Detail

reset

public void reset()
Description copied from interface: SingletonStrategy
reset the instance to a new instance for the implemented strategy

Specified by:
reset in interface SingletonStrategy

instance

public Object instance()
Description copied from interface: SingletonStrategy
return a singleton instance of the class specified in setSingletonClass

Specified by:
instance in interface SingletonStrategy

setSingletonClassName

public void setSingletonClassName(String singletonClassName)
Description copied from interface: SingletonStrategy
set a singleton class name that will be used to create the singleton based on the strategy implementation of this interface. The default constructor of the class will be used and must be public.

Specified by:
setSingletonClassName in interface SingletonStrategy
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProxyDocumentFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class ProxyDocumentFactory

java.lang.Object
    extended by org.dom4j.util.ProxyDocumentFactory
public abstract class ProxyDocumentFactory
extends Object

ProxyDocumentFactory implements a proxy to a DocumentFactory which is useful for implementation inheritence, allowing the pipelining of various factory implementations. For example an EncodingDocumentFactory which takes care of encoding strings outside of allowable XML ranges could be used with a DatatypeDocumentFactory which is XML Schema Data Type aware.

Version:
$Revision: 1.13 $
Author:
James Strachan

Constructor Summary
ProxyDocumentFactory()
ProxyDocumentFactory(DocumentFactory proxy)
Method Summary
Attribute | createAttribute(Element owner, QName qname, String value)
Attribute | createAttribute(Element owner, String name, String value)
CDATA | createCDATA(String text)
Comment | createComment(String text)
DocumentType | createDocType(String name, String publicId, String systemId)
Document | createDocument()
Document | createDocument(Element rootElement)
Element | createElement(QName qname)
Element | createElement(String name)
Entity | createEntity(String name, String text)
Namespace | createNamespace(String prefix, String uri)
Pattern | createPattern(String xpathPattern)
ProcessingInstruction | createProcessingInstruction(String target, Map data)
ProcessingInstruction | createProcessingInstruction(String target, String data)
QName | createQName(String localName)
QName | createQName(String localName, Namespace namespace)
QName | createQName(String qualifiedName, String uri)
QName | createQName(String name, String prefix, String uri)
Text | createText(String text)
XPath | createXPath(String xpathExpression)
XPath | createXPath(String xpathExpression, org.jaxen.VariableContext variableContext)
NodeFilter | createXPathFilter(String xpathFilterExpression)
NodeFilter | createXPathFilter(String xpathFilterExpression, org.jaxen.VariableContext variableContext)
protected DocumentFactory | getProxy()
protected void | setProxy(DocumentFactory proxy)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxyDocumentFactory

public ProxyDocumentFactory()

ProxyDocumentFactory

public ProxyDocumentFactory(DocumentFactory proxy)
Method Detail

createDocument

public Document createDocument()

createDocument

public Document createDocument(Element rootElement)

createDocType

public DocumentType createDocType(String name,
                                  String publicId,
                                  String systemId)

createElement

public Element createElement(QName qname)

createElement

public Element createElement(String name)

createAttribute

public Attribute createAttribute(Element owner,
                                 QName qname,
                                 String value)

createAttribute

public Attribute createAttribute(Element owner,
                                 String name,
                                 String value)

createCDATA

public CDATA createCDATA(String text)

createComment

public Comment createComment(String text)

createText

public Text createText(String text)

createEntity

public Entity createEntity(String name,
                           String text)

createNamespace

public Namespace createNamespace(String prefix,
                                 String uri)

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(String target,
                                                         String data)

createProcessingInstruction

public ProcessingInstruction createProcessingInstruction(String target,
                                                         Map data)

createQName

public QName createQName(String localName,
                         Namespace namespace)

createQName

public QName createQName(String localName)

createQName

public QName createQName(String name,
                         String prefix,
                         String uri)

createQName

public QName createQName(String qualifiedName,
                         String uri)

createXPath

public XPath createXPath(String xpathExpression)

createXPath

public XPath createXPath(String xpathExpression,
                         org.jaxen.VariableContext variableContext)

createXPathFilter

public NodeFilter createXPathFilter(String xpathFilterExpression,
                                    org.jaxen.VariableContext variableContext)

createXPathFilter

public NodeFilter createXPathFilter(String xpathFilterExpression)

createPattern

public Pattern createPattern(String xpathPattern)

getProxy

protected DocumentFactory getProxy()

setProxy

protected void setProxy(DocumentFactory proxy)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


SimpleSingleton (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class SimpleSingleton

java.lang.Object
    extended by org.dom4j.util.SimpleSingleton
All Implemented Interfaces:
SingletonStrategy
public class SimpleSingleton
extends Object
implements SingletonStrategy

SimpleSingleton is an implementation of the SingletonStrategy interface used to provide common factory access for the same object instance. This implementation will create a new instance from the class specified and will not create a new one unless it is reset.

Version:
$Revision: 1.3 $
Author:
David Lucas

Constructor Summary
SimpleSingleton()
Method Summary
Object | instance() return a singleton instance of the class specified in setSingletonClass
void | reset() reset the instance to a new instance for the implemented strategy
void | setSingletonClassName(String singletonClassName) set a singleton class name that will be used to create the singleton based on the strategy implementation of this interface.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

SimpleSingleton

public SimpleSingleton()
Method Detail

instance

public Object instance()
Description copied from interface: SingletonStrategy
return a singleton instance of the class specified in setSingletonClass

Specified by:
instance in interface SingletonStrategy

reset

public void reset()
Description copied from interface: SingletonStrategy
reset the instance to a new instance for the implemented strategy

Specified by:
reset in interface SingletonStrategy

setSingletonClassName

public void setSingletonClassName(String singletonClassName)
Description copied from interface: SingletonStrategy
set a singleton class name that will be used to create the singleton based on the strategy implementation of this interface. The default constructor of the class will be used and must be public.

Specified by:
setSingletonClassName in interface SingletonStrategy
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserDataAttribute (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class UserDataAttribute

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractAttribute
            extended by org.dom4j.tree.FlyweightAttribute
                extended by org.dom4j.tree.DefaultAttribute
                    extended by org.dom4j.util.UserDataAttribute
All Implemented Interfaces:
Attribute, Cloneable, Node, Serializable
public class UserDataAttribute
extends DefaultAttribute

UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods setData(Object)will get and set the values of a user data object. This can be useful for developers wishing to create XML trees and adorn the trees with user defined objects.

Version:
$Revision: 1.8 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.FlyweightAttribute
value
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
UserDataAttribute(QName qname)
UserDataAttribute(QName qname, String text)
Method Summary
 Object getData()
Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node#getText().
 void setData(Object data)
Sets the data value of this attribute if this element supports data binding or calls Node#setText(String)if it doesn't.
Methods inherited from class org.dom4j.tree.DefaultAttribute
getParent, isReadOnly, setParent, setValue, supportsParent
Methods inherited from class org.dom4j.tree.FlyweightAttribute
getQName, getValue
Methods inherited from class org.dom4j.tree.AbstractAttribute
accept, asXML, createXPathResult, getName, getNamespace, getNamespacePrefix, getNamespaceURI, getNodeType, getPath, getQualifiedName, getText, getUniquePath, setNamespace, setText, toString, write
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, clone, createPattern, createXPath, createXPathFilter, detach, getDocument, getDocumentFactory, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Node
asXPathResult, clone, createXPath, detach, getDocument, getNodeTypeName, getPath, getStringValue, getUniquePath, hasContent, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, setDocument, setName, valueOf

Constructor Detail

UserDataAttribute

public UserDataAttribute(QName qname)

UserDataAttribute

public UserDataAttribute(QName qname,
                         String text)
Method Detail

getData

public Object getData()
Description copied from interface: Attribute

Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node.getText().

Specified by:
getData in interface Attribute
Overrides:
getData in class AbstractAttribute

setData

public void setData(Object data)
Description copied from interface: Attribute

Sets the data value of this attribute if this element supports data binding or calls Node.setText(String)if it doesn't.

Specified by:
setData in interface Attribute
Overrides:
setData in class AbstractAttribute
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserDataDocumentFactory (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class UserDataDocumentFactory

java.lang.Object
    extended by org.dom4j.DocumentFactory
        extended by org.dom4j.util.UserDataDocumentFactory
All Implemented Interfaces:
Serializable
public class UserDataDocumentFactory
extends DocumentFactory

UserDataDocumentFactory is a factory of XML objects which support the adornment of a user data object on an Element or Attribute instance such that the methods getData() and setData() will get and set the values of a user data object. This can be useful for developers wishing to create XML trees and adorn the trees with user defined objects.

Version:
$Revision: 1.11 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
protected static UserDataDocumentFactory singleton
The Singleton instance
Fields inherited from class org.dom4j.DocumentFactory
cache
Constructor Summary
UserDataDocumentFactory()
Method Summary
Attribute | createAttribute(Element owner, QName qname, String value)
Element | createElement(QName qname)
static DocumentFactory | getInstance() Access to the singleton instance of this factory.
Methods inherited from class org.dom4j.DocumentFactory
createAttribute, createCDATA, createComment, createDocType, createDocument, createDocument, createDocument, createElement, createElement, createEntity, createNamespace, createPattern, createProcessingInstruction, createProcessingInstruction, createQName, createQName, createQName, createQName, createQNameCache, createSingleton, createText, createXPath, createXPath, createXPathFilter, createXPathFilter, getQNames, getXPathNamespaceURIs, init, intern, setXPathNamespaceURIs
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

singleton

protected static transient UserDataDocumentFactory singleton
The Singleton instance

Constructor Detail

UserDataDocumentFactory

public UserDataDocumentFactory()
Method Detail

getInstance

public static DocumentFactory getInstance()

Access to the singleton instance of this factory.

Returns:
the default singleon instance

createElement

public Element createElement(QName qname)
Overrides:
createElement in class DocumentFactory

createAttribute

public Attribute createAttribute(Element owner,
                                 QName qname,
                                 String value)
Overrides:
createAttribute in class DocumentFactory
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


UserDataElement (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class UserDataElement

java.lang.Object
    extended by org.dom4j.tree.AbstractNode
        extended by org.dom4j.tree.AbstractBranch
            extended by org.dom4j.tree.AbstractElement
                extended by org.dom4j.tree.DefaultElement
                    extended by org.dom4j.util.UserDataElement
All Implemented Interfaces:
Branch, Cloneable, Element, Node, Serializable
public class UserDataElement
extends DefaultElement

UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods setData(Object)will get and set the values of a user data object. This can be useful for developers wishing to create XML trees and adorn the trees with user defined objects.

Version:
$Revision: 1.12 $
Author:
James Strachan
See Also:
Serialized Form

Field Summary
Fields inherited from class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR, EMPTY_LIST, USE_STRINGVALUE_SEPARATOR, VERBOSE_TOSTRING
Fields inherited from class org.dom4j.tree.AbstractBranch
DEFAULT_CONTENT_LIST_SIZE
Fields inherited from class org.dom4j.tree.AbstractNode
NODE_TYPE_NAMES
Fields inherited from interface org.dom4j.Node
ANY_NODE, ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_NODE, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_REFERENCE_NODE, MAX_NODE_TYPE, NAMESPACE_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE, UNKNOWN_NODE
Constructor Summary
UserDataElement(QName qname)
UserDataElement(String name)
Method Summary
 Object clone()
clone will return a deep clone or if this node is read-only then clone will return the same instance.
protected  Element createElement(QName qName)
protected  Element createElement(String name)
protected  Object getCopyOfUserData()
If a deep copy of user data is required whenever the clone() or createCopy() methods are called on this element then this method should return a clone of the user data
 Object getData()
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as DefaultElement.getText()
 void setData(Object data)
Sets the data value of this element if this element supports data binding or calls AbstractElement.setText(java.lang.String)if it doesn't
 String toString()
Methods inherited from class org.dom4j.tree.DefaultElement
add, additionalNamespaces, additionalNamespaces, addNewNode, attribute, attribute, attribute, attribute, attributeCount, attributeIterator, attributeList, attributeList, attributes, clearContent, contentList, declaredNamespaces, element, element, element, getDocument, getDocumentFactory, getNamespaceForPrefix, getNamespaceForURI, getParent, getQName, getStringValue, getText, indexOf, node, nodeCount, nodeIterator, processingInstruction, processingInstructions, processingInstructions, remove, removeNode, removeProcessingInstruction, setAttributeList, setAttributes, setContent, setDocument, setParent, setQName, supportsParent
Methods inherited from class org.dom4j.tree.AbstractElement
accept, add, add, add, add, add, add, add, add, addAttribute, addAttribute, addCDATA, addComment, addElement, addEntity, addNamespace, addNewNode, addNode, addNode, addProcessingInstruction, addProcessingInstruction, addText, appendAttributes, asXML, attributeValue, attributeValue, attributeValue, attributeValue, childAdded, childRemoved, createAttributeList, createAttributeList, createCopy, createCopy, createCopy, createSingleIterator, elementIterator, elementIterator, elementIterator, elementIterator, elements, elements, elements, elements, elementText, elementText, elementTextTrim, elementTextTrim, ensureAttributesCapacity, getName, getNamespace, getNamespacePrefix, getNamespacesForURI, getNamespaceURI, getNodeType, getPath, getQName, getQualifiedName, getUniquePath, getXPathNameStep, getXPathResult, hasMixedContent, isRootElement, isTextOnly, normalize, remove, remove, remove, remove, remove, remove, remove, remove, setAttributes, setAttributeValue, setAttributeValue, setName, setNamespace, setText, write
Methods inherited from class org.dom4j.tree.AbstractBranch
addElement, addElement, addElement, appendContent, content, contentRemoved, createContentList, createContentList, createEmptyList, createResultList, createSingleResultList, elementByID, elementID, getContentAsStringValue, getContentAsText, getTextTrim, hasContent, invalidNodeTypeAddException, isReadOnly, setProcessingInstructions
Methods inherited from class org.dom4j.tree.AbstractNode
asXPathResult, createPattern, createXPath, createXPathFilter, createXPathResult, detach, getNodeTypeName, getPath, getUniquePath, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf
Methods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
Methods inherited from interface org.dom4j.Element
getTextTrim
Methods inherited from interface org.dom4j.Branch
addElement, addElement, appendContent, content, elementByID, setProcessingInstructions
Methods inherited from interface org.dom4j.Node
asXPathResult, createXPath, detach, getNodeTypeName, getPath, getUniquePath, hasContent, isReadOnly, matches, numberValueOf, selectNodes, selectNodes, selectNodes, selectObject, selectSingleNode, valueOf

Constructor Detail

UserDataElement

public UserDataElement(String name)

UserDataElement

public UserDataElement(QName qname)
Method Detail

getData

public Object getData()
Description copied from interface: Element
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Element.getText()

Specified by:
getData in interface Element
Overrides:
getData in class AbstractElement

setData

public void setData(Object data)
Description copied from interface: Element
Sets the data value of this element if this element supports data binding or calls Node.setText(java.lang.String)if it doesn't

Specified by:
setData in interface Element
Overrides:
setData in class AbstractElement

toString

public String toString()
Overrides:
toString in class AbstractElement

clone

public Object clone()
Description copied from interface: Node

clone will return a deep clone or if this node is read-only then clone will return the same instance.

Specified by:
clone in interface Node
Overrides:
clone in class DefaultElement

getCopyOfUserData

protected Object getCopyOfUserData()
If a deep copy of user data is required whenever the clone() or createCopy() methods are called on this element then this method should return a clone of the user data

Returns:
DOCUMENT ME!

createElement

protected Element createElement(String name)
Overrides:
createElement in class AbstractElement

createElement

protected Element createElement(QName qName)
Overrides:
createElement in class AbstractElement
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XMLErrorHandler (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.util
Class XMLErrorHandler

java.lang.Object
    extended by org.dom4j.util.XMLErrorHandler
All Implemented Interfaces:
ErrorHandler
public class XMLErrorHandler
extends Object
implements ErrorHandler

XMLErrorHandler is a SAX ErrorHandlerwhich turns the SAX parsing errors into XML so that the output can be formatted using XSLT or the errors can be included in a SOAP message.

Version:
$Revision: 1.7 $
Author:
James Strachan

Field Summary
protected static QName | ERROR_QNAME
protected static QName | FATALERROR_QNAME
protected static QName | WARNING_QNAME
Constructor Summary
XMLErrorHandler()
XMLErrorHandler(Element errors)
Method Summary
protected void | addException(Element element, SAXParseException e) Adds the given parse exception information to the given element instance
void | error(SAXParseException e)
void | fatalError(SAXParseException e)
QName | getErrorQName()
Element | getErrors()
QName | getFatalErrorQName()
QName | getWarningQName()
void | setErrorQName(QName errorQName)
void | setErrors(Element errors)
void | setFatalErrorQName(QName fatalErrorQName)
void | setWarningQName(QName warningQName)
void | warning(SAXParseException e)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Field Detail

ERROR_QNAME

protected static final QName ERROR_QNAME

FATALERROR_QNAME

protected static final QName FATALERROR_QNAME

WARNING_QNAME

protected static final QName WARNING_QNAME
Constructor Detail

XMLErrorHandler

public XMLErrorHandler()

XMLErrorHandler

public XMLErrorHandler(Element errors)
Method Detail

error

public void error(SAXParseException e)
Specified by:
error in interface ErrorHandler

fatalError

public void fatalError(SAXParseException e)
Specified by:
fatalError in interface ErrorHandler

warning

public void warning(SAXParseException e)
Specified by:
warning in interface ErrorHandler

getErrors

public Element getErrors()

setErrors

public void setErrors(Element errors)

getErrorQName

public QName getErrorQName()

setErrorQName

public void setErrorQName(QName errorQName)

getFatalErrorQName

public QName getFatalErrorQName()

setFatalErrorQName

public void setFatalErrorQName(QName fatalErrorQName)

getWarningQName

public QName getWarningQName()

setWarningQName

public void setWarningQName(QName warningQName)

addException

protected void addException(Element element,
                            SAXParseException e)
Adds the given parse exception information to the given element instance

Parameters:
element - DOCUMENT ME!
e - DOCUMENT ME!
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.xpath (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.xpath

Provides the core tools needed to use the XPath library

See:
Description

Class Summary
DefaultNamespaceContext | DefaultNamespaceContext implements a Jaxen NamespaceContext such that a context node is used to determine the current XPath namespace prefixes and namespace URIs available.
DefaultXPath | Default implementation of XPathwhich uses the Jaxen project.
XPathPattern | XPathPattern is an implementation of Pattern which uses an XPath xpath.

Package org.dom4j.xpath Description

Provides the core tools needed to use the XPath library


org.dom4j.xpath Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.xpath

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.xpath.DefaultNamespaceContext (implements org.jaxen.NamespaceContext, java.io.Serializable)
    • class org.dom4j.xpath.DefaultXPath (implements org.dom4j.NodeFilter, java.io.Serializable, org.dom4j.XPath)
    • class org.dom4j.xpath.XPathPattern (implements org.dom4j.rule.Pattern)


Uses of Package org.dom4j.xpath (dom4j 1.6.1 API)

Uses of Package
org.dom4j.xpath

Packages that use org.dom4j.xpath
org.dom4j.xpath Provides the core tools needed to use the XPath library

Classes in org.dom4j.xpath used by org.dom4j.xpath
DefaultNamespaceContext
DefaultNamespaceContext implements a Jaxen NamespaceContext such that a context node is used to determine the current XPath namespace prefixes and namespace URIs available.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


DefaultNamespaceContext (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.xpath
Class DefaultNamespaceContext

java.lang.Object
    extended by org.dom4j.xpath.DefaultNamespaceContext
All Implemented Interfaces:
org.jaxen.NamespaceContext, Serializable
public class DefaultNamespaceContext
extends Object
implements org.jaxen.NamespaceContext, Serializable

DefaultNamespaceContext implements a Jaxen NamespaceContext such that a context node is used to determine the current XPath namespace prefixes and namespace URIs available.

Author:
James Strachan
See Also:
Serialized Form

Constructor Summary
DefaultNamespaceContext(Element element)
Method Summary
static DefaultNamespaceContext | create(Object node)
String | translateNamespacePrefixToUri(String prefix)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

DefaultNamespaceContext

public DefaultNamespaceContext(Element element)
Method Detail

create

public static DefaultNamespaceContext create(Object node)

translateNamespacePrefixToUri

public String translateNamespacePrefixToUri(String prefix)
Specified by:
translateNamespacePrefixToUri in interface org.jaxen.NamespaceContext
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


DefaultXPath (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.xpath
Class DefaultXPath

java.lang.Object
    extended by org.dom4j.xpath.DefaultXPath
All Implemented Interfaces:
NodeFilter, Serializable, XPath
public class DefaultXPath
extends Object
implements XPath, NodeFilter, Serializable

Default implementation of XPathwhich uses the Jaxen project.

Author:
bob mcwhirter, James Strachan
See Also:
Serialized Form

Constructor Summary
DefaultXPath(String text)
Construct an XPath
Method Summary
boolean | booleanValueOf(Object context) Retrieve a boolean-value interpretation of this XPath expression when evaluated against a given context.
Object | evaluate(Object context) evaluate evaluates an XPath expression and returns the result as an Object.
protected Object | getCompareValue(Node node) DOCUMENT ME!
org.jaxen.FunctionContext | getFunctionContext() DOCUMENT ME!
org.jaxen.NamespaceContext | getNamespaceContext() DOCUMENT ME!
String | getText() Retrieve the textual XPath string used to initialize this Object
org.jaxen.VariableContext | getVariableContext() DOCUMENT ME!
protected void | handleJaxenException(org.jaxen.JaxenException exception)
boolean | matches(Node node) matches returns true if the given node matches the XPath expression.
Number | numberValueOf(Object context) numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results is a number, or null if the result is not a number.
protected static org.jaxen.XPath | parse(String text)
protected void | removeDuplicates(List list, Map sortValues) Removes items from the list which have duplicate values
List | selectNodes(Object context) selectNodes performs this XPath expression on the given Nodeor Listof Nodes instances appending all the results together into a single list.
List | selectNodes(Object context, XPath sortXPath) selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.
List | selectNodes(Object context, XPath sortXPath, boolean distinct) selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.
Object | selectObject(Object context) selectObject evaluates an XPath expression and returns the result as an Object.
Node | selectSingleNode(Object context) selectSingleNode evaluates this XPath expression on the given Nodeor Listof Nodes and returns the result as a single Node instance.
void | setFunctionContext(org.jaxen.FunctionContext functionContext) Sets the function context to be used when evaluating XPath expressions
void | setNamespaceContext(org.jaxen.NamespaceContext namespaceContext) Sets the namespace context to be used when evaluating XPath expressions
void | setNamespaceURIs(Map map) Sets the current NamespaceContext from a Map where the keys are the String namespace prefixes and the values are the namespace URIs.
protected void | setNSContext(Object context)
void | setVariableContext(org.jaxen.VariableContext variableContext) Sets the variable context to be used when evaluating XPath expressions
void | sort(List list) sort sorts the given List of Nodes using this XPath expression as a Comparator.
void | sort(List list, boolean distinct) sort sorts the given List of Nodes using this XPath expression as a Comparatorand optionally removing duplicates.
protected void | sort(List list, Map sortValues) Sorts the list based on the sortValues for each node
String | toString()
String | valueOf(Object context) valueOf evaluates this XPath expression and returns the textual representation of the results using the XPath string() function.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

DefaultXPath

public DefaultXPath(String text)
             throws InvalidXPathException
Construct an XPath

Parameters:
text - DOCUMENT ME!
Throws:
InvalidXPathException - DOCUMENT ME!
Method Detail

toString

public String toString()

getText

public String getText()
Retrieve the textual XPath string used to initialize this Object

Specified by:
getText in interface XPath
Returns:
The XPath string

getFunctionContext

public org.jaxen.FunctionContext getFunctionContext()
Description copied from interface: XPath
DOCUMENT ME!

Specified by:
getFunctionContext in interface XPath
Returns:
the current function context

setFunctionContext

public void setFunctionContext(org.jaxen.FunctionContext functionContext)
Description copied from interface: XPath
Sets the function context to be used when evaluating XPath expressions

Specified by:
setFunctionContext in interface XPath
Parameters:
functionContext - DOCUMENT ME!

getNamespaceContext

public org.jaxen.NamespaceContext getNamespaceContext()
Description copied from interface: XPath
DOCUMENT ME!

Specified by:
getNamespaceContext in interface XPath
Returns:
the current namespace context

setNamespaceURIs

public void setNamespaceURIs(Map map)
Description copied from interface: XPath

Sets the current NamespaceContext from a Map where the keys are the String namespace prefixes and the values are the namespace URIs.

For example:

 Map uris = new HashMap();
 uris.put("SOAP-ENV", "http://schemas.xmlsoap.org/soap/envelope/");
 uris.put("m", "urn:xmethodsBabelFish");
 XPath xpath = document
         .createXPath("SOAP-ENV:Envelope/SOAP-ENV:Body/m:BabelFish");
 xpath.setNamespaceURIs(uris);
 Node babelfish = xpath.selectSingleNode(document);

Specified by:
setNamespaceURIs in interface XPath
Parameters:
map - the map containing the namespace mappings

setNamespaceContext

public void setNamespaceContext(org.jaxen.NamespaceContext namespaceContext)
Description copied from interface: XPath
Sets the namespace context to be used when evaluating XPath expressions

Specified by:
setNamespaceContext in interface XPath
Parameters:
namespaceContext - DOCUMENT ME!

getVariableContext

public org.jaxen.VariableContext getVariableContext()
Description copied from interface: XPath
DOCUMENT ME!

Specified by:
getVariableContext in interface XPath
Returns:
the current variable context

setVariableContext

public void setVariableContext(org.jaxen.VariableContext variableContext)
Description copied from interface: XPath
Sets the variable context to be used when evaluating XPath expressions

Specified by:
setVariableContext in interface XPath
Parameters:
variableContext - DOCUMENT ME!

evaluate

public Object evaluate(Object context)
Description copied from interface: XPath

evaluate evaluates an XPath expression and returns the result as an Object. The object returned can either be a List of Nodeinstances, a Nodeinstance, a String or a Numberinstance depending on the XPath expression.

Specified by:
evaluate in interface XPath
Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the value of the XPath expression as a Listof Node instances, a Nodeinstance, a Stringor a Numberinstance depending on the XPath expression.

selectObject

public Object selectObject(Object context)
Description copied from interface: XPath

selectObject evaluates an XPath expression and returns the result as an Object. The object returned can either be a List of Nodeinstances, a Nodeinstance, a String or a Numberinstance depending on the XPath expression.

Specified by:
selectObject in interface XPath
Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the value of the XPath expression as a Listof Node instances, a Nodeinstance, a Stringor a Numberinstance depending on the XPath expression.

selectNodes

public List selectNodes(Object context)
Description copied from interface: XPath

selectNodes performs this XPath expression on the given Nodeor Listof Nodes instances appending all the results together into a single list.

Specified by:
selectNodes in interface XPath
Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the results of all the XPath evaluations as a single list

selectNodes

public List selectNodes(Object context,
                        XPath sortXPath)
Description copied from interface: XPath

selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.

Specified by:
selectNodes in interface XPath
Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
sortXPath - is the XPath expression to sort by
Returns:
a list of Node instances

selectNodes

public List selectNodes(Object context,
                        XPath sortXPath,
                        boolean distinct)
Description copied from interface: XPath

selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.

Specified by:
selectNodes in interface XPath
Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
sortXPath - is the XPath expression to sort by
distinct - specifies whether or not duplicate values of the sort expression are allowed. If this parameter is true then only distinct sort expressions values are included in the result
Returns:
a list of Node instances

selectSingleNode

public Node selectSingleNode(Object context)
Description copied from interface: XPath

selectSingleNode evaluates this XPath expression on the given Nodeor Listof Nodes and returns the result as a single Node instance.

Specified by:
selectSingleNode in interface XPath
Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
a single matching Node instance

valueOf

public String valueOf(Object context)
Description copied from interface: XPath

valueOf evaluates this XPath expression and returns the textual representation of the results using the XPath string() function.

Specified by:
valueOf in interface XPath
Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the string representation of the results of the XPath expression

numberValueOf

public Number numberValueOf(Object context)
Description copied from interface: XPath

numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results is a number, or null if the result is not a number.

Specified by:
numberValueOf in interface XPath
Parameters:
context - is either a node or a list of nodes on which to evalute the XPath
Returns:
the numeric result of the XPath expression or null if the result is not a number.

booleanValueOf

public boolean booleanValueOf(Object context)
Description copied from interface: XPath
Retrieve a boolean-value interpretation of this XPath expression when evaluated against a given context.

The boolean-value of the expression is determined per the boolean(..) core function as defined in the XPath specification. This means that an expression that selects zero nodes will return false, while an expression that selects one-or-more nodes will return true.

Specified by:
booleanValueOf in interface XPath
Parameters:
context - The node, nodeset or Context object for evaluation. This value can be null
Returns:
The boolean-value interpretation of this expression.

sort

public void sort(List list)

sort sorts the given List of Nodes using this XPath expression as a Comparator.

Specified by:
sort in interface XPath
Parameters:
list - is the list of Nodes to sort

sort

public void sort(List list,
                 boolean distinct)

sort sorts the given List of Nodes using this XPath expression as a Comparatorand optionally removing duplicates.

Specified by:
sort in interface XPath
Parameters:
list - is the list of Nodes to sort
distinct - if true then duplicate values (using the sortXPath for comparisions) will be removed from the List

matches

public boolean matches(Node node)
Description copied from interface: XPath

matches returns true if the given node matches the XPath expression. To be more precise when evaluating this XPath expression on the given node the result set must include the node.

Specified by:
matches in interface XPath
Parameters:
node - DOCUMENT ME!
Returns:
true if the given node matches this XPath expression

sort

protected void sort(List list,
                    Map sortValues)
Sorts the list based on the sortValues for each node

Parameters:
list - DOCUMENT ME!
sortValues - DOCUMENT ME!

removeDuplicates

protected void removeDuplicates(List list,
                                Map sortValues)
Removes items from the list which have duplicate values

Parameters:
list - DOCUMENT ME!
sortValues - DOCUMENT ME!

getCompareValue

protected Object getCompareValue(Node node)
DOCUMENT ME!

Parameters:
node - DOCUMENT ME!
Returns:
the node expression used for sorting comparisons

parse

protected static org.jaxen.XPath parse(String text)

setNSContext

protected void setNSContext(Object context)

handleJaxenException

protected void handleJaxenException(org.jaxen.JaxenException exception)
                             throws XPathException
Throws:
XPathException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


XPathPattern (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.xpath
Class XPathPattern

java.lang.Object
    extended by org.dom4j.xpath.XPathPattern
All Implemented Interfaces:
NodeFilter, Pattern
public class XPathPattern
extends Object
implements Pattern

XPathPattern is an implementation of Pattern which uses an XPath xpath.

Version:
$Revision: 1.18.2.1 $
Author:
James Strachan

Field Summary
Fields inherited from interface org.dom4j.rule.Pattern
ANY_NODE, DEFAULT_PRIORITY, NONE, NUMBER_OF_TYPES
Constructor Summary
XPathPattern(org.jaxen.pattern.Pattern pattern)
XPathPattern(String text)
Method Summary
protected org.jaxen.ContextSupport | getContextSupport()
String | getMatchesNodeName() For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches.
short | getMatchType() DOCUMENT ME!
double | getPriority() Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .
String | getText()
Pattern[] | getUnionPatterns() If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern.
protected void | handleJaxenException(org.jaxen.JaxenException exception)
boolean | matches(Node node) DOCUMENT ME!
void | setVariableContext(org.jaxen.VariableContext variableContext)
String | toString()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

XPathPattern

public XPathPattern(org.jaxen.pattern.Pattern pattern)

XPathPattern

public XPathPattern(String text)
Method Detail

matches

public boolean matches(Node node)
Description copied from interface: Pattern
DOCUMENT ME!

Specified by:
matches in interface Pattern
Parameters:
node - DOCUMENT ME!
Returns:
true if the pattern matches the given DOM4J node.

getText

public String getText()

getPriority

public double getPriority()
Description copied from interface: Pattern
Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .

Specified by:
getPriority in interface Pattern
Returns:
DOCUMENT ME!

getUnionPatterns

public Pattern[] getUnionPatterns()
Description copied from interface: Pattern
If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern. Otherwise this method should return null.

Specified by:
getUnionPatterns in interface Pattern
Returns:
an array of the patterns which make up this union pattern or null if this pattern is not a union pattern

getMatchType

public short getMatchType()
Description copied from interface: Pattern
DOCUMENT ME!

Specified by:
getMatchType in interface Pattern
Returns:
the type of node the pattern matches which by default should return ANY_NODE if it can match any kind of node.

getMatchesNodeName

public String getMatchesNodeName()
Description copied from interface: Pattern
For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches. This allows a more efficient rule matching algorithm to be performed, rather than a brute force approach of evaluating every pattern for a given Node.

Specified by:
getMatchesNodeName in interface Pattern
Returns:
the name of the element or attribute this pattern matches or null if this pattern matches any or more than one name.

setVariableContext

public void setVariableContext(org.jaxen.VariableContext variableContext)

toString

public String toString()

getContextSupport

protected org.jaxen.ContextSupport getContextSupport()

handleJaxenException

protected void handleJaxenException(org.jaxen.JaxenException exception)
                             throws XPathException
Throws:
XPathException
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.dom4j.xpp (dom4j 1.6.1 API)

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.dom4j.xpp

Provides implementation classes to cleanly integrate dom4j with the XML Pull Parser XPP

See:
Description

Class Summary
ProxyXmlStartTag ProxyXmlStartTag implements the XPP XmlSmartTag interface while creating a dom4j Element underneath.

Package org.dom4j.xpp Description

Provides implementation classes to cleanly integrate dom4j with the XML Pull Parser XPP

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


org.dom4j.xpp Class Hierarchy (dom4j 1.6.1 API)

Hierarchy For Package org.dom4j.xpp

Package Hierarchies:
All Packages

Class Hierarchy

  • class java.lang.Object
    • class org.dom4j.xpp.ProxyXmlStartTag (implements org.gjt.xpp.XmlStartTag)
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.dom4j.xpp (dom4j 1.6.1 API)

Uses of Package
org.dom4j.xpp

No usage of org.dom4j.xpp

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ProxyXmlStartTag (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.dom4j.xpp
Class ProxyXmlStartTag

java.lang.Object
    extended by org.dom4j.xpp.ProxyXmlStartTag
All Implemented Interfaces:
org.gjt.xpp.XmlStartTag, org.gjt.xpp.XmlTag
public class ProxyXmlStartTag
extends Object
implements org.gjt.xpp.XmlStartTag

ProxyXmlStartTag implements the XPP XmlSmartTag interface while creating a dom4j Element underneath.

Author:
James Strachan, Maarten Coene, Wolfgang Baer

Constructor Summary
ProxyXmlStartTag()
ProxyXmlStartTag(Element element)
Method Summary
 void addAttribute(String namespaceURI, String localName, String rawName, String value)
parameters modeled after SAX2 attribute approach
 void addAttribute(String namespaceURI, String localName, String rawName, String value, boolean isNamespaceDeclaration)
 void ensureAttributesCapacity(int minCapacity)
 int getAttributeCount()
 String getAttributeLocalName(int index)
 String getAttributeNamespaceUri(int index)
 String getAttributePrefix(int index)
 String getAttributeRawName(int index)
 String getAttributeValue(int index)
 String getAttributeValueFromName(String namespaceURI, String localName)
 String getAttributeValueFromRawName(String rawName)
 DocumentFactory getDocumentFactory()
 Element getElement()
 String getLocalName()
 String getNamespaceUri()
 String getPrefix()
 String getRawName()
 boolean isAttributeNamespaceDeclaration(int index)
 void modifyTag(String namespaceURI, String lName, String rawName)
 boolean removeAttributeByName(String namespaceURI, String localName)
 boolean removeAttributeByRawName(String rawName)
 void removeAttributes()
 void removeAtttributes()
Deprecated. Use removeAttributes() instead.
 void resetStartTag()
 void resetTag()
 void setDocumentFactory(DocumentFactory documentFactory)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ProxyXmlStartTag

public ProxyXmlStartTag()

ProxyXmlStartTag

public ProxyXmlStartTag(Element element)
Method Detail

resetStartTag

public void resetStartTag()
Specified by:
resetStartTag in interface org.gjt.xpp.XmlStartTag

getAttributeCount

public int getAttributeCount()
Specified by:
getAttributeCount in interface org.gjt.xpp.XmlStartTag

getAttributeNamespaceUri

public String getAttributeNamespaceUri(int index)
Specified by:
getAttributeNamespaceUri in interface org.gjt.xpp.XmlStartTag

getAttributeLocalName

public String getAttributeLocalName(int index)
Specified by:
getAttributeLocalName in interface org.gjt.xpp.XmlStartTag

getAttributePrefix

public String getAttributePrefix(int index)
Specified by:
getAttributePrefix in interface org.gjt.xpp.XmlStartTag

getAttributeRawName

public String getAttributeRawName(int index)
Specified by:
getAttributeRawName in interface org.gjt.xpp.XmlStartTag

getAttributeValue

public String getAttributeValue(int index)
Specified by:
getAttributeValue in interface org.gjt.xpp.XmlStartTag

getAttributeValueFromRawName

public String getAttributeValueFromRawName(String rawName)
Specified by:
getAttributeValueFromRawName in interface org.gjt.xpp.XmlStartTag

getAttributeValueFromName

public String getAttributeValueFromName(String namespaceURI,
                                        String localName)
Specified by:
getAttributeValueFromName in interface org.gjt.xpp.XmlStartTag

isAttributeNamespaceDeclaration

public boolean isAttributeNamespaceDeclaration(int index)
Specified by:
isAttributeNamespaceDeclaration in interface org.gjt.xpp.XmlStartTag

addAttribute

public void addAttribute(String namespaceURI,
                         String localName,
                         String rawName,
                         String value)
                  throws org.gjt.xpp.XmlPullParserException
parameters modeled after SAX2 attribute approach

Specified by:
addAttribute in interface org.gjt.xpp.XmlStartTag
Parameters:
namespaceURI - DOCUMENT ME!
localName - DOCUMENT ME!
rawName - DOCUMENT ME!
value - DOCUMENT ME!
Throws:
org.gjt.xpp.XmlPullParserException - DOCUMENT ME!

addAttribute

public void addAttribute(String namespaceURI,
                         String localName,
                         String rawName,
                         String value,
                         boolean isNamespaceDeclaration)
                  throws org.gjt.xpp.XmlPullParserException
Specified by:
addAttribute in interface org.gjt.xpp.XmlStartTag
Throws:
org.gjt.xpp.XmlPullParserException

ensureAttributesCapacity

public void ensureAttributesCapacity(int minCapacity)
                              throws org.gjt.xpp.XmlPullParserException
Specified by:
ensureAttributesCapacity in interface org.gjt.xpp.XmlStartTag
Throws:
org.gjt.xpp.XmlPullParserException

removeAtttributes

public void removeAtttributes()
                       throws org.gjt.xpp.XmlPullParserException
Deprecated. Use removeAttributes() instead.

Remove all atributes.

Throws:
org.gjt.xpp.XmlPullParserException

removeAttributes

public void removeAttributes()
                      throws org.gjt.xpp.XmlPullParserException
Specified by:
removeAttributes in interface org.gjt.xpp.XmlStartTag
Throws:
org.gjt.xpp.XmlPullParserException

getLocalName

public String getLocalName()
Specified by:
getLocalName in interface org.gjt.xpp.XmlTag

getNamespaceUri

public String getNamespaceUri()
Specified by:
getNamespaceUri in interface org.gjt.xpp.XmlTag

getPrefix

public String getPrefix()
Specified by:
getPrefix in interface org.gjt.xpp.XmlTag

getRawName

public String getRawName()
Specified by:
getRawName in interface org.gjt.xpp.XmlTag

modifyTag

public void modifyTag(String namespaceURI,
                      String lName,
                      String rawName)
Specified by:
modifyTag in interface org.gjt.xpp.XmlTag

resetTag

public void resetTag()
Specified by:
resetTag in interface org.gjt.xpp.XmlTag

removeAttributeByName

public boolean removeAttributeByName(String namespaceURI,
                                     String localName)
                              throws org.gjt.xpp.XmlPullParserException
Specified by:
removeAttributeByName in interface org.gjt.xpp.XmlStartTag
Throws:
org.gjt.xpp.XmlPullParserException

removeAttributeByRawName

public boolean removeAttributeByRawName(String rawName)
                                 throws org.gjt.xpp.XmlPullParserException
Specified by:
removeAttributeByRawName in interface org.gjt.xpp.XmlStartTag
Throws:
org.gjt.xpp.XmlPullParserException

getDocumentFactory

public DocumentFactory getDocumentFactory()

setDocumentFactory

public void setDocumentFactory(DocumentFactory documentFactory)

getElement

public Element getElement()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


All Classes (dom4j 1.6.1 API)

 All Classes
AbstractAttribute
AbstractBranch
AbstractCDATA
AbstractCharacterData
AbstractComment
AbstractDocument
AbstractDocumentType
AbstractElement
AbstractEntity
AbstractNode
AbstractProcessingInstruction
AbstractText
Action
Attribute
AttributeDecl
AttributeHelper
BackedList
BaseElement
BeanAttribute
BeanAttributeList
BeanDocumentFactory
BeanElement
BeanMetaData
Branch
BranchTreeNode
CDATA
CharacterData
Comment
ConcurrentReaderHashMap.BarrierLock
ConcurrentReaderHashMap.Entry
ContentListFacade
DOMAttribute
DOMAttributeNodeMap
DOMCDATA
DOMComment
DOMDocument
DOMDocumentFactory
DOMDocumentType
DOMElement
DOMEntityReference
DOMNamespace
DOMNodeHelper
DOMNodeHelper.EmptyNodeList
DOMProcessingInstruction
DOMReader
DOMText
DOMWriter
DatatypeAttribute
DatatypeDocumentFactory
DatatypeElement
DatatypeElementFactory
DefaultAttribute
DefaultCDATA
DefaultComment
DefaultDocument
DefaultDocumentType
DefaultElement
DefaultEntity
DefaultNamespace
DefaultNamespaceContext
DefaultPattern
DefaultProcessingInstruction
DefaultText
DefaultXPath
Document
DocumentException
DocumentFactory
DocumentHelper
DocumentResult
DocumentSource
DocumentTreeModel
DocumentType
Element
ElementDecl
ElementHandler
ElementIterator
ElementModifier
ElementNameIterator
ElementPath
ElementQNameIterator
Entity
ExternalEntityDecl
FilterIterator
FlyweightAttribute
FlyweightCDATA
FlyweightComment
FlyweightEntity
FlyweightProcessingInstruction
FlyweightText
HTMLWriter
IllegalAddException
IndexedDocumentFactory
IndexedElement
InternalEntityDecl
InvalidSchemaException
InvalidXPathException
JAXBModifier
JAXBObjectHandler
JAXBObjectModifier
JAXBReader
JAXBWriter
LeafTreeNode
Mode
Namespace
NamespaceCache
NamespaceStack
Node
NodeComparator
NodeFilter
NodeTypePattern
NonLazyDocumentFactory
NonLazyElement
NullAction
OutputFormat
Pattern
PerThreadSingleton
ProcessingInstruction
ProxyDocumentFactory
ProxyXmlStartTag
QName
QNameCache
Rule
RuleManager
RuleSet
SAXContentHandler
SAXEventRecorder
SAXModifier
SAXReader
SAXReader.SAXEntityResolver
SAXValidator
SAXWriter
STAXEventReader
STAXEventWriter
SchemaParser
SimpleSingleton
SingleIterator
SingletonStrategy
Stylesheet
Text
UserDataAttribute
UserDataDocumentFactory
UserDataElement
Visitor
VisitorSupport
XMLErrorHandler
XMLResult
XMLTableColumnDefinition
XMLTableDefinition
XMLTableModel
XMLWriter
XPP3Reader
XPPReader
XPath
XPathException
XPathPattern


Constant Field Values (dom4j 1.6.1 API)

Constant Field Values

Contents
  • org.dom4j.*
org.dom4j.*

org.dom4j.Node
public static final short | ANY_NODE | 0
public static final short | ATTRIBUTE_NODE | 2
public static final short | CDATA_SECTION_NODE | 4
public static final short | COMMENT_NODE | 8
public static final short | DOCUMENT_NODE | 9
public static final short | DOCUMENT_TYPE_NODE | 10
public static final short | ELEMENT_NODE | 1
public static final short | ENTITY_REFERENCE_NODE | 5
public static final short | MAX_NODE_TYPE | 14
public static final short | NAMESPACE_NODE | 13
public static final short | PROCESSING_INSTRUCTION_NODE | 7
public static final short | TEXT_NODE | 3
public static final short | UNKNOWN_NODE | 14

org.dom4j.io.DocumentSource
public static final String DOM4J_FEATURE "http://org.dom4j.io.DoucmentSource/feature"

org.dom4j.io.OutputFormat
protected static final String STANDARD_INDENT " "

org.dom4j.io.SAXEventRecorder
public static final long serialVersionUID 1l

org.dom4j.io.SAXWriter
protected static final String | FEATURE_NAMESPACE_PREFIXES | "http://xml.org/sax/features/namespace-prefixes"
protected static final String | FEATURE_NAMESPACES | "http://xml.org/sax/features/namespaces"

org.dom4j.rule.Pattern
public static final short | ANY_NODE | 0
public static final double | DEFAULT_PRIORITY | 0.5d
public static final short | NONE | 9999
public static final short | NUMBER_OF_TYPES | 14

org.dom4j.swing.XMLTableColumnDefinition
public static final int | NODE_TYPE | 3
public static final int | NUMBER_TYPE | 2
public static final int | OBJECT_TYPE | 0
public static final int | STRING_TYPE | 1

org.dom4j.tree.AbstractBranch
protected static final int DEFAULT_CONTENT_LIST_SIZE 5

org.dom4j.tree.AbstractElement
protected static final boolean | USE_STRINGVALUE_SEPARATOR | false
protected static final boolean | VERBOSE_TOSTRING | false

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Deprecated List (dom4j 1.6.1 API)

Deprecated API

Deprecated Classes
org.dom4j.tree.ElementIterator
THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
org.dom4j.tree.ElementNameIterator
THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
org.dom4j.tree.ElementQNameIterator
THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
org.dom4j.tree.FilterIterator
THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!

Deprecated Methods
org.dom4j.rule.Stylesheet.applyTemplates(Object, XPath)
Use Stylesheet.applyTemplates(Object, XPath)instead.
org.dom4j.rule.Stylesheet.applyTemplates(Object, XPath, String)
Use Stylesheet.applyTemplates(Object, XPath, String) instead.
org.dom4j.util.IndexedElement.asElementIterator(Object)
WILL BE REMOVED IN dom4j-1.6 !!
org.dom4j.xpp.ProxyXmlStartTag.removeAtttributes()
Use removeAttributes() instead.
org.dom4j.XPath.selectObject(Object)
please use evaluate(Object) instead. WILL BE REMOVED IN dom4j-1.6 !!
org.dom4j.Element.setAttributeValue(QName, String)
As of version 0.5. Please use Element.addAttribute(QName,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
org.dom4j.tree.AbstractElement.setAttributeValue(QName, String)
As of version 0.5. Please use AbstractElement.addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
org.dom4j.Element.setAttributeValue(String, String)
As of version 0.5. Please use Element.addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
org.dom4j.tree.AbstractElement.setAttributeValue(String, String)
As of version 0.5. Please use AbstractElement.addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help (dom4j 1.6.1 API)

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Exceptions
  • Errors

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


dom4j 1.6.1 API

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Index (dom4j 1.6.1 API)

A B C D E F G H I J K L M N O P Q R S T U V W X

A

ANY_ATTRIBUTE - Static variable in class org.dom4j.rule.pattern.NodeTypePattern
A pattern which matches any Attribute node
ANY_COMMENT - Static variable in class org.dom4j.rule.pattern.NodeTypePattern
A pattern which matches any Comment node
ANY_DOCUMENT - Static variable in class org.dom4j.rule.pattern.NodeTypePattern
A pattern which matches any Document node
ANY_ELEMENT - Static variable in class org.dom4j.rule.pattern.NodeTypePattern
A pattern which matches any Element node
ANY_NODE - Static variable in interface org.dom4j.Node
Matches Element nodes
ANY_NODE - Static variable in interface org.dom4j.rule.Pattern
Matches any node
ANY_PROCESSING_INSTRUCTION - Static variable in class org.dom4j.rule.pattern.NodeTypePattern
A pattern which matches any ProcessingInstruction node
ANY_TEXT - Static variable in class org.dom4j.rule.pattern.NodeTypePattern
A pattern which matches any Text node
ATTRIBUTE_NODE - Static variable in interface org.dom4j.Node
Matches elements nodes
AbstractAttribute - class org.dom4j.tree.AbstractAttribute.
AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
AbstractAttribute() - Constructor for class org.dom4j.tree.AbstractAttribute
AbstractBranch - class org.dom4j.tree.AbstractBranch.
AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
AbstractBranch() - Constructor for class org.dom4j.tree.AbstractBranch
AbstractCDATA - class org.dom4j.tree.AbstractCDATA.
AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
AbstractCDATA() - Constructor for class org.dom4j.tree.AbstractCDATA
AbstractCharacterData - class org.dom4j.tree.AbstractCharacterData.
AbstractCharacterData is an abstract base class for tree implementors to use for implementation inheritence.
AbstractCharacterData() - Constructor for class org.dom4j.tree.AbstractCharacterData
AbstractComment - class org.dom4j.tree.AbstractComment.
AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
AbstractComment() - Constructor for class org.dom4j.tree.AbstractComment
AbstractDocument - class org.dom4j.tree.AbstractDocument.
AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
AbstractDocument() - Constructor for class org.dom4j.tree.AbstractDocument
AbstractDocumentType - class org.dom4j.tree.AbstractDocumentType.
AbstractDocumentType is an abstract base class for tree implementors to use for implementation inheritence.
AbstractDocumentType() - Constructor for class org.dom4j.tree.AbstractDocumentType
AbstractElement - class org.dom4j.tree.AbstractElement.
AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
AbstractElement() - Constructor for class org.dom4j.tree.AbstractElement
AbstractEntity - class org.dom4j.tree.AbstractEntity.
AbstractEntity is an abstract base class for tree implementors to use for implementation inheritence.
AbstractEntity() - Constructor for class org.dom4j.tree.AbstractEntity
AbstractNode - class org.dom4j.tree.AbstractNode.
AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
AbstractNode() - Constructor for class org.dom4j.tree.AbstractNode
AbstractProcessingInstruction - class org.dom4j.tree.AbstractProcessingInstruction.
AbstractProcessingInstruction is an abstract base class for tree implementors to use for implementation inheritence.
AbstractProcessingInstruction() - Constructor for class org.dom4j.tree.AbstractProcessingInstruction
AbstractText - class org.dom4j.tree.AbstractText.
AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
AbstractText() - Constructor for class org.dom4j.tree.AbstractText
Action - interface org.dom4j.rule.Action.
Action represents some default action which should occur when a rule matches a node in the XSLT processing model.
Attribute - interface org.dom4j.Attribute.
Attribute defines an XML attribute.
AttributeDecl - class org.dom4j.dtd.AttributeDecl.
AttributeDecl represents an attribute declaration in a DTD.
AttributeDecl() - Constructor for class org.dom4j.dtd.AttributeDecl
AttributeDecl(String, String, String, String, String) - Constructor for class org.dom4j.dtd.AttributeDecl
AttributeHelper - class org.dom4j.util.AttributeHelper.
AttributeHelper a number of helper methods for working with attribute values.
AttributeHelper() - Constructor for class org.dom4j.util.AttributeHelper
accept(Visitor) - Method in class org.dom4j.Namespace
accept(Visitor) - Method in interface org.dom4j.Node
accept is the method used in the Visitor Pattern.
accept(Visitor) - Method in class org.dom4j.tree.AbstractAttribute
accept(Visitor) - Method in class org.dom4j.tree.AbstractCDATA
accept(Visitor) - Method in class org.dom4j.tree.AbstractComment
accept(Visitor) - Method in class org.dom4j.tree.AbstractDocument
accept method is the Visitor Pattern method.
accept(Visitor) - Method in class org.dom4j.tree.AbstractDocumentType
accept(Visitor) - Method in class org.dom4j.tree.AbstractElement
accept method is the Visitor Pattern method.
accept(Visitor) - Method in class org.dom4j.tree.AbstractEntity
accept(Visitor) - Method in class org.dom4j.tree.AbstractProcessingInstruction
accept(Visitor) - Method in class org.dom4j.tree.AbstractText
add(Node) - Method in interface org.dom4j.Branch
Adds the given Node or throws IllegalAddException if the given node is not of a valid type.
add(Comment) - Method in interface org.dom4j.Branch
Adds the given Comment to this branch.
add(Element) - Method in interface org.dom4j.Branch
Adds the given Element to this branch.
add(ProcessingInstruction) - Method in interface org.dom4j.Branch
Adds the given ProcessingInstruction to this branch.
add(Attribute) - Method in interface org.dom4j.Element
Adds the given Attribute to this element.
add(CDATA) - Method in interface org.dom4j.Element
Adds the given CDATA to this element.
add(Entity) - Method in interface org.dom4j.Element
Adds the given Entity to this element.
add(Text) - Method in interface org.dom4j.Element
Adds the given Text to this element.
add(Namespace) - Method in interface org.dom4j.Element
Adds the given Namespace to this element.
add(Object) - Method in class org.dom4j.bean.BeanAttributeList
add(int, Object) - Method in class org.dom4j.bean.BeanAttributeList
add(Node) - Method in class org.dom4j.tree.AbstractBranch
add(Comment) - Method in class org.dom4j.tree.AbstractBranch
add(Element) - Method in class org.dom4j.tree.AbstractBranch
add(ProcessingInstruction) - Method in class org.dom4j.tree.AbstractBranch
add(Element) - Method in class org.dom4j.tree.AbstractDocument
add(Attribute) - Method in class org.dom4j.tree.AbstractElement
add(Node) - Method in class org.dom4j.tree.AbstractElement
add(CDATA) - Method in class org.dom4j.tree.AbstractElement
add(Comment) - Method in class org.dom4j.tree.AbstractElement
add(Element) - Method in class org.dom4j.tree.AbstractElement
add(Entity) - Method in class org.dom4j.tree.AbstractElement
add(Namespace) - Method in class org.dom4j.tree.AbstractElement
add(ProcessingInstruction) - Method in class org.dom4j.tree.AbstractElement
add(Text) - Method in class org.dom4j.tree.AbstractElement
add(Object) - Method in class org.dom4j.tree.BackedList
add(int, Object) - Method in class org.dom4j.tree.BackedList
add(Object) - Method in class org.dom4j.tree.ContentListFacade
add(int, Object) - Method in class org.dom4j.tree.ContentListFacade
add(Attribute) - Method in class org.dom4j.tree.DefaultElement
addAll(RuleSet) - Method in class org.dom4j.rule.RuleSet
Adds all the rules to this RuleSet from the given other rule set.
addAll(Collection) - Method in class org.dom4j.tree.BackedList
addAll(int, Collection) - Method in class org.dom4j.tree.BackedList
addAll(Collection) - Method in class org.dom4j.tree.ContentListFacade
addAll(int, Collection) - Method in class org.dom4j.tree.ContentListFacade
addAttribute(String, String) - Method in interface org.dom4j.Element
Adds the attribute value of the given local name.
addAttribute(QName, String) - Method in interface org.dom4j.Element
Adds the attribute value of the given fully qualified name.
addAttribute(String, String) - Method in class org.dom4j.bean.BeanElement
addAttribute(QName, String) - Method in class org.dom4j.bean.BeanElement
addAttribute(String, String) - Method in class org.dom4j.tree.AbstractElement
addAttribute(QName, String) - Method in class org.dom4j.tree.AbstractElement
addAttribute(String, String, String, String) - Method in class org.dom4j.xpp.ProxyXmlStartTag
parameters modeled after SAX2 attribute approach
addAttribute(String, String, String, String, boolean) - Method in class org.dom4j.xpp.ProxyXmlStartTag
addAttributes(Element, Attributes) - Method in class org.dom4j.io.SAXContentHandler
Add all the attributes to the given elements
addCDATA(String) - Method in interface org.dom4j.Element
Adds a new CDATA node with the given text to this element.
addCDATA(String) - Method in class org.dom4j.tree.AbstractElement
addColumn(String, String) - Method in class org.dom4j.swing.XMLTableDefinition
addColumn(String, String, int) - Method in class org.dom4j.swing.XMLTableDefinition
addColumn(XMLTableColumnDefinition) - Method in class org.dom4j.swing.XMLTableDefinition
addColumnWithXPathName(String, String, int) - Method in class org.dom4j.swing.XMLTableDefinition
addComment(String) - Method in interface org.dom4j.Document
Adds a new Comment node with the given text to this branch.
addComment(String) - Method in interface org.dom4j.Element
Adds a new Comment node with the given text to this element.
addComment(String) - Method in class org.dom4j.tree.AbstractDocument
addComment(String) - Method in class org.dom4j.tree.AbstractElement
addDTDDeclaration(Object) - Method in class org.dom4j.io.SAXContentHandler
Adds an internal DTD declaration to the list of declarations
addDeclaredNamespaces(Element) - Method in class org.dom4j.io.SAXContentHandler
Add all namespaces declared before the startElement() SAX event to the current element so that they are available to child elements and attributes
addDefaultRule(Mode, Pattern, Action) - Method in class org.dom4j.rule.RuleManager
addDefaultRules(Mode) - Method in class org.dom4j.rule.RuleManager
Adds the default stylesheet rules to the given Modeinstance
addDocType(String, String, String) - Method in interface org.dom4j.Document
Adds a DOCTYPE declaration to this document
addDocType(String, String, String) - Method in class org.dom4j.tree.DefaultDocument
addElement(String) - Method in interface org.dom4j.Branch
Adds a new Element node with the given name to this branch and returns a reference to the new node.
addElement(QName) - Method in interface org.dom4j.Branch
Adds a new Element node with the given QNameto this branch and returns a reference to the new node.
addElement(String, String) - Method in interface org.dom4j.Branch
Adds a new Element node with the given qualified name and namespace URI to this branch and returns a reference to the new node.
addElement(String) - Method in class org.dom4j.tree.AbstractBranch
addElement(String, String) - Method in class org.dom4j.tree.AbstractBranch
addElement(QName) - Method in class org.dom4j.tree.AbstractBranch
addElement(String, String, String) - Method in class org.dom4j.tree.AbstractBranch
addElement(String) - Method in class org.dom4j.tree.AbstractDocument
addElement(String, String) - Method in class org.dom4j.tree.AbstractDocument
addElement(QName) - Method in class org.dom4j.tree.AbstractDocument
addElement(String) - Method in class org.dom4j.tree.AbstractElement
addEntity(String, String) - Method in interface org.dom4j.Element
Adds a new Entity node with the given name and text to this element and returns a reference to the new node.
addEntity(String, String) - Method in class org.dom4j.tree.AbstractElement
addException(Element, SAXParseException) - Method in class org.dom4j.util.XMLErrorHandler
Adds the given parse exception information to the given element instance
addExternalDTDDeclaration(Object) - Method in class org.dom4j.io.SAXContentHandler
Adds an external DTD declaration to the list of declarations
addHandler(String, ElementHandler) - Method in interface org.dom4j.ElementPath
Adds the ElementHandler to be called when the specified path is encounted.
addHandler(String, ElementHandler) - Method in class org.dom4j.io.SAXReader
Adds the ElementHandler to be called when the specified path is encounted.
addHandler(String, ElementHandler) - Method in class org.dom4j.io.XPP3Reader
Adds the ElementHandler to be called when the specified path is encounted.
addHandler(String, ElementHandler) - Method in class org.dom4j.io.XPPReader
Adds the ElementHandler to be called when the specified path is encounted.
addHandler(String, ElementHandler) - Method in class org.dom4j.jaxb.JAXBReader
Adds the ElementHandler to be called when the specified path is encounted.
addLocal(Object) - Method in class org.dom4j.tree.BackedList
Performs a local addition which is not forward through to the Branch or backing list
addModifier(String, ElementModifier) - Method in class org.dom4j.io.SAXModifier
Adds the ElementModifierto be called when the specified element path is encounted while parsing the source.
addNamespace(String, String) - Method in interface org.dom4j.Element
Adds a namespace to this element for use by its child content
addNamespace(String, String) - Method in class org.dom4j.tree.AbstractElement
addNamespace(String, String) - Method in class org.dom4j.tree.NamespaceStack
Adds a new namespace to the stack
addNamespaceAttribute(AttributesImpl, Namespace) - Method in class org.dom4j.io.SAXWriter
If isDelcareNamespaceAttributes() is enabled then this method will add the given namespace declaration to the supplied attributes object, creating one if it does not exist.
addNewNode(Node) - Method in class org.dom4j.tree.AbstractElement
Like addNode() but does not require a parent check
addNewNode(int, Node) - Method in class org.dom4j.tree.AbstractElement
addNewNode(Node) - Method in class org.dom4j.tree.DefaultElement
addNode(Node) - Method in class org.dom4j.tree.AbstractBranch
addNode(int, Node) - Method in class org.dom4j.tree.AbstractBranch
addNode(Node) - Method in class org.dom4j.tree.AbstractElement
addNode(int, Node) - Method in class org.dom4j.tree.AbstractElement
addNode(Node) - Method in class org.dom4j.tree.DefaultDocument
addNode(int, Node) - Method in class org.dom4j.tree.DefaultDocument
addNode(Node) - Method in class org.dom4j.util.IndexedElement
addNumberColumn(String, String) - Method in class org.dom4j.swing.XMLTableDefinition
addObjectHandler(String, JAXBObjectHandler) - Method in class org.dom4j.jaxb.JAXBReader
Registers a JAXBObjectHandlerthat will be supplied with the unmarshalled representation of the xml fragment whenever the specified path is encounted.
addObjectModifier(String, JAXBObjectModifier) - Method in class org.dom4j.jaxb.JAXBModifier
Adds the JAXBObjectModifierto be called when the specified xml path is encounted while parsing the source.
addProcessingInstruction(String, String) - Method in interface org.dom4j.Document
Adds a processing instruction for the given target
addProcessingInstruction(String, Map) - Method in interface org.dom4j.Document
Adds a processing instruction for the given target
addProcessingInstruction(String, String) - Method in interface org.dom4j.Element
Adds a processing instruction for the given target
addProcessingInstruction(String, Map) - Method in interface org.dom4j.Element
Adds a processing instruction for the given target
addProcessingInstruction(String, String) - Method in class org.dom4j.tree.AbstractDocument
addProcessingInstruction(String, Map) - Method in class org.dom4j.tree.AbstractDocument
addProcessingInstruction(String, String) - Method in class org.dom4j.tree.AbstractElement
addProcessingInstruction(String, Map) - Method in class org.dom4j.tree.AbstractElement
addRule(Rule) - Method in class org.dom4j.rule.Mode
addRule(Rule) - Method in class org.dom4j.rule.RuleManager
addRule(Rule) - Method in class org.dom4j.rule.RuleSet
addRule(Rule) - Method in class org.dom4j.rule.Stylesheet
Add a rule to this stylesheet.
addStringColumn(String, String) - Method in class org.dom4j.swing.XMLTableDefinition
addText(String) - Method in interface org.dom4j.Element
Adds a new Text node with the given text to this element.
addText(String) - Method in class org.dom4j.datatype.DatatypeElement
addText(String) - Method in class org.dom4j.tree.AbstractElement
addToAttributeIndex(Attribute) - Method in class org.dom4j.util.IndexedElement
addToAttributeIndex(Object, Attribute) - Method in class org.dom4j.util.IndexedElement
addToElementIndex(Element) - Method in class org.dom4j.util.IndexedElement
addToElementIndex(Object, Element) - Method in class org.dom4j.util.IndexedElement
addToNameMap(Map, String, Rule) - Method in class org.dom4j.rule.Mode
Adds the Rule to a RuleSet for the given name.
additionalNamespaces() - Method in interface org.dom4j.Element
Returns any additional namespaces declarations for this element other than namespace returned via the Element.getNamespace()method.
additionalNamespaces() - Method in class org.dom4j.tree.AbstractElement
additionalNamespaces(String) - Method in class org.dom4j.tree.AbstractElement
additionalNamespaces() - Method in class org.dom4j.tree.DefaultElement
additionalNamespaces(String) - Method in class org.dom4j.tree.DefaultElement
appendAttributes(Element) - Method in interface org.dom4j.Element
Appends the attributes of the given element to me.
appendAttributes(Element) - Method in class org.dom4j.tree.AbstractElement
appendChild(Node) - Method in class org.dom4j.dom.DOMAttribute
appendChild(Node) - Method in class org.dom4j.dom.DOMCDATA
appendChild(Node) - Method in class org.dom4j.dom.DOMComment
appendChild(Node) - Method in class org.dom4j.dom.DOMDocument
appendChild(Node) - Method in class org.dom4j.dom.DOMDocumentType
appendChild(Node) - Method in class org.dom4j.dom.DOMElement
appendChild(Node) - Method in class org.dom4j.dom.DOMEntityReference
appendChild(Node) - Method in class org.dom4j.dom.DOMNamespace
appendChild(Node, Node) - Static method in class org.dom4j.dom.DOMNodeHelper
appendChild(Node) - Method in class org.dom4j.dom.DOMProcessingInstruction
appendChild(Node) - Method in class org.dom4j.dom.DOMText
appendContent(Branch) - Method in interface org.dom4j.Branch
Appends the content of the given branch to this branch instance.
appendContent(Branch) - Method in class org.dom4j.tree.AbstractBranch
appendDOMTree(Document, Node, List) - Method in class org.dom4j.io.DOMWriter
appendDOMTree(Document, Node, Element) - Method in class org.dom4j.io.DOMWriter
appendDOMTree(Document, Node, CDATA) - Method in class org.dom4j.io.DOMWriter
appendDOMTree(Document, Node, Comment) - Method in class org.dom4j.io.DOMWriter
appendDOMTree(Document, Node, String) - Method in class org.dom4j.io.DOMWriter
appendDOMTree(Document, Node, Entity) - Method in class org.dom4j.io.DOMWriter
appendDOMTree(Document, Node, ProcessingInstruction) - Method in class org.dom4j.io.DOMWriter
appendData(String) - Method in class org.dom4j.dom.DOMCDATA
appendData(String) - Method in class org.dom4j.dom.DOMComment
appendData(CharacterData, String) - Static method in class org.dom4j.dom.DOMNodeHelper
appendData(String) - Method in class org.dom4j.dom.DOMText
appendElementsByTagName(List, Branch, String) - Static method in class org.dom4j.dom.DOMNodeHelper
appendElementsByTagNameNS(List, Branch, String, String) - Static method in class org.dom4j.dom.DOMNodeHelper
appendText(String) - Method in interface org.dom4j.CharacterData
Appends the given text to this nodes text value.
appendText(String) - Method in class org.dom4j.tree.AbstractCharacterData
applyTemplates(Element) - Method in class org.dom4j.rule.Mode
applyTemplates(Document) - Method in class org.dom4j.rule.Mode
applyTemplates(Object, XPath) - Method in class org.dom4j.rule.Stylesheet
Processes the result of the xpath expression.
applyTemplates(Object, XPath, String) - Method in class org.dom4j.rule.Stylesheet
Processes the result of the xpath expression in the given mode.
applyTemplates(Object, XPath) - Method in class org.dom4j.rule.Stylesheet
Deprecated. Use Stylesheet.applyTemplates(Object, XPath)instead.
applyTemplates(Object, XPath, String) - Method in class org.dom4j.rule.Stylesheet
Deprecated. Use Stylesheet.applyTemplates(Object, XPath, String) instead.
applyTemplates(Object) - Method in class org.dom4j.rule.Stylesheet
If input is a Node, this will processes all of the children of that node.
applyTemplates(Object, String) - Method in class org.dom4j.rule.Stylesheet
Processes the input object in the given mode.
asDOMAttr(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
asDOMDocument(Document) - Static method in class org.dom4j.dom.DOMNodeHelper
asDOMDocumentType(DocumentType) - Static method in class org.dom4j.dom.DOMNodeHelper
asDOMElement(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
asDOMNode(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
asDOMText(CharacterData) - Static method in class org.dom4j.dom.DOMNodeHelper
asDocumentType(DocumentType) - Method in class org.dom4j.dom.DOMDocumentFactory
asElement(Object) - Method in class org.dom4j.util.IndexedElement
asElementIterator(Object) - Method in class org.dom4j.util.IndexedElement
Deprecated. WILL BE REMOVED IN dom4j-1.6 !!
asElementList(Object) - Method in class org.dom4j.util.IndexedElement
asNode(Object) - Method in class org.dom4j.tree.BackedList
asNode(Object) - Method in class org.dom4j.tree.ContentListFacade
asXML() - Method in class org.dom4j.Namespace
asXML() - Method in interface org.dom4j.Node
asXML returns the textual XML representation of this node.
asXML() - Method in class org.dom4j.tree.AbstractAttribute
asXML() - Method in class org.dom4j.tree.AbstractCDATA
asXML() - Method in class org.dom4j.tree.AbstractComment
asXML() - Method in class org.dom4j.tree.AbstractDocument
asXML() - Method in class org.dom4j.tree.AbstractDocumentType
asXML() - Method in class org.dom4j.tree.AbstractElement
asXML() - Method in class org.dom4j.tree.AbstractEntity
asXML() - Method in class org.dom4j.tree.AbstractProcessingInstruction
asXML() - Method in class org.dom4j.tree.AbstractText
asXPathResult(Element) - Method in interface org.dom4j.Node
asXPathResult returns a version of this node which is capable of being an XPath result.
asXPathResult(Element) - Method in class org.dom4j.tree.AbstractDocument
asXPathResult(Element) - Method in class org.dom4j.tree.AbstractNode
attribute(int) - Method in interface org.dom4j.Element
Returns the attribute at the specified indexGets the
attribute(String) - Method in interface org.dom4j.Element
Returns the attribute with the given name
attribute(QName) - Method in interface org.dom4j.Element
DOCUMENT ME!
attribute(String) - Method in class org.dom4j.bean.BeanAttributeList
attribute(QName) - Method in class org.dom4j.bean.BeanAttributeList
attribute(int) - Method in class org.dom4j.bean.BeanAttributeList
attribute(String) - Method in class org.dom4j.bean.BeanElement
attribute(QName) - Method in class org.dom4j.bean.BeanElement
attribute(Attr) - Method in class org.dom4j.dom.DOMElement
attribute(String, String) - Method in class org.dom4j.dom.DOMElement
attribute(int) - Method in class org.dom4j.tree.AbstractElement
attribute(String) - Method in class org.dom4j.tree.AbstractElement
attribute(QName) - Method in class org.dom4j.tree.AbstractElement
attribute(String, Namespace) - Method in class org.dom4j.tree.AbstractElement
attribute(int) - Method in class org.dom4j.tree.DefaultElement
attribute(String) - Method in class org.dom4j.tree.DefaultElement
attribute(QName) - Method in class org.dom4j.tree.DefaultElement
attribute(String, Namespace) - Method in class org.dom4j.tree.DefaultElement
attribute(String) - Method in class org.dom4j.util.IndexedElement
attribute(QName) - Method in class org.dom4j.util.IndexedElement
attributeCount() - Method in interface org.dom4j.Element
DOCUMENT ME!
attributeCount() - Method in class org.dom4j.bean.BeanMetaData
DOCUMENT ME!
attributeCount() - Method in class org.dom4j.tree.AbstractElement
attributeCount() - Method in class org.dom4j.tree.DefaultElement
attributeDecl(String, String, String, String, String) - Method in class org.dom4j.io.SAXContentHandler
Report an attribute type declaration.
attributeDecl(String, String, String, String, String) - Method in class org.dom4j.io.SAXEventRecorder
attributeIndex() - Method in class org.dom4j.util.IndexedElement
attributeIterator() - Method in interface org.dom4j.Element
DOCUMENT ME!
attributeIterator() - Method in class org.dom4j.tree.AbstractElement
attributeIterator() - Method in class org.dom4j.tree.DefaultElement
attributeList() - Method in class org.dom4j.tree.AbstractElement
DOCUMENT ME!
attributeList(int) - Method in class org.dom4j.tree.AbstractElement
DOCUMENT ME!
attributeList() - Method in class org.dom4j.tree.BaseElement
attributeList(int) - Method in class org.dom4j.tree.BaseElement
attributeList() - Method in class org.dom4j.tree.DefaultElement
attributeList(int) - Method in class org.dom4j.tree.DefaultElement
attributeNameForNamespace(Namespace) - Method in class org.dom4j.io.DOMWriter
attributeValue(String) - Method in interface org.dom4j.Element
This returns the attribute value for the attribute with the given name and any namespace or null if there is no such attribute or the empty string if the attribute value is empty.
attributeValue(String, String) - Method in interface org.dom4j.Element
This returns the attribute value for the attribute with the given name and any namespace or the default value if there is no such attribute value.
attributeValue(QName) - Method in interface org.dom4j.Element
This returns the attribute value for the attribute with the given fully qualified name or null if there is no such attribute or the empty string if the attribute value is empty.
attributeValue(QName, String) - Method in interface org.dom4j.Element
This returns the attribute value for the attribute with the given fully qualified name or the default value if there is no such attribute value.
attributeValue(String) - Method in class org.dom4j.tree.AbstractElement
attributeValue(QName) - Method in class org.dom4j.tree.AbstractElement
attributeValue(String, String) - Method in class org.dom4j.tree.AbstractElement
attributeValue(QName, String) - Method in class org.dom4j.tree.AbstractElement
attributes() - Method in interface org.dom4j.Element
Returns the Attributeinstances this element contains as a backed Listso that the attributes may be modified directly using the Listinterface.
attributes() - Method in class org.dom4j.tree.AbstractElement
attributes - Variable in class org.dom4j.tree.BaseElement
list of attributes
attributes() - Method in class org.dom4j.tree.DefaultElement

B

BackedList - class org.dom4j.tree.BackedList.
BackedList represents a list of content of a Branch.
BackedList(AbstractBranch, List) - Constructor for class org.dom4j.tree.BackedList
BackedList(AbstractBranch, List, int) - Constructor for class org.dom4j.tree.BackedList
BackedList(AbstractBranch, List, List) - Constructor for class org.dom4j.tree.BackedList
BaseElement - class org.dom4j.tree.BaseElement.
BaseElement is a useful base class for implemementation inheritence of an XML element.
BaseElement(String) - Constructor for class org.dom4j.tree.BaseElement
BaseElement(QName) - Constructor for class org.dom4j.tree.BaseElement
BaseElement(String, Namespace) - Constructor for class org.dom4j.tree.BaseElement
BeanAttribute - class org.dom4j.bean.BeanAttribute.
BeanAttribute represents a mutable XML attribute which is backed by a property of the JavaBean of its parent element.
BeanAttribute(BeanAttributeList, int) - Constructor for class org.dom4j.bean.BeanAttribute
BeanAttributeList - class org.dom4j.bean.BeanAttributeList.
BeanAttributeList implements a list of Attributes which are the properties of a JavaBean.
BeanAttributeList(BeanElement, BeanMetaData) - Constructor for class org.dom4j.bean.BeanAttributeList
BeanAttributeList(BeanElement) - Constructor for class org.dom4j.bean.BeanAttributeList
BeanDocumentFactory - class org.dom4j.bean.BeanDocumentFactory.
BeanDocumentFactory is a factory of DOM4J objects which may be BeanElements which are backed by JavaBeans and their properties.
BeanDocumentFactory() - Constructor for class org.dom4j.bean.BeanDocumentFactory
BeanElement - class org.dom4j.bean.BeanElement.
BeanElement uses a Java Bean to store its attributes.
BeanElement(String, Object) - Constructor for class org.dom4j.bean.BeanElement
BeanElement(String, Namespace, Object) - Constructor for class org.dom4j.bean.BeanElement
BeanElement(QName, Object) - Constructor for class org.dom4j.bean.BeanElement
BeanElement(QName) - Constructor for class org.dom4j.bean.BeanElement
BeanMetaData - class org.dom4j.bean.BeanMetaData.
BeanMetaData contains metadata about a bean class.
BeanMetaData(Class) - Constructor for class org.dom4j.bean.BeanMetaData
Branch - interface org.dom4j.Branch.
Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
BranchTreeNode - class org.dom4j.swing.BranchTreeNode.
BranchTreeNode implements the Swing TreeNode interface to bind dom4j XML Branch nodes (i.e.
BranchTreeNode() - Constructor for class org.dom4j.swing.BranchTreeNode
BranchTreeNode(Branch) - Constructor for class org.dom4j.swing.BranchTreeNode
BranchTreeNode(TreeNode, Branch) - Constructor for class org.dom4j.swing.BranchTreeNode
booleanValue(Element, String) - Static method in class org.dom4j.util.AttributeHelper
booleanValue(Element, QName) - Static method in class org.dom4j.util.AttributeHelper
booleanValue(Attribute) - Static method in class org.dom4j.util.AttributeHelper
booleanValueOf(Object) - Method in interface org.dom4j.XPath
Retrieve a boolean-value interpretation of this XPath expression when evaluated against a given context.
booleanValueOf(Object) - Method in class org.dom4j.xpath.DefaultXPath
build(Document) - Method in class org.dom4j.datatype.SchemaParser
Parses the given schema document
build(Document, Namespace) - Method in class org.dom4j.datatype.SchemaParser

C

CACHE - Static variable in class org.dom4j.Namespace
Cache of Namespace instances
CDATA - interface org.dom4j.CDATA.
CDATA defines an XML CDATA section.
CDATA_SECTION_NODE - Static variable in interface org.dom4j.Node
Matches elements nodes
COMMENT_NODE - Static variable in interface org.dom4j.Node
Matches Comments nodes
CharacterData - interface org.dom4j.CharacterData.
CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.
Comment - interface org.dom4j.Comment.
Comment defines the behavior of an XML comment.
ConcurrentReaderHashMap.BarrierLock - class org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock.
A Serializable class for barrier lock *
ConcurrentReaderHashMap.BarrierLock() - Constructor for class org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock
ConcurrentReaderHashMap.Entry - class org.dom4j.tree.ConcurrentReaderHashMap.Entry.
ConcurrentReaderHashMap collision list entry.
ContentListFacade - class org.dom4j.tree.ContentListFacade.
ContentListFacade represents a facade of the content of a Branch which is returned via calls to the Branch.content() method to allow users to modify the content of a Branch directly using the List interface.
ContentListFacade(AbstractBranch, List) - Constructor for class org.dom4j.tree.ContentListFacade
cache - Variable in class org.dom4j.DocumentFactory
cache - Static variable in class org.dom4j.tree.NamespaceCache
Cache of Mapinstances indexed by URI which contain caches of Namespacefor each prefix
characters(char[], int, int) - Method in class org.dom4j.io.SAXContentHandler
characters(char[], int, int) - Method in class org.dom4j.io.SAXEventRecorder
characters(char[], int, int) - Method in class org.dom4j.io.XMLWriter
checkAddElementAllowed(Element) - Method in class org.dom4j.tree.AbstractDocument
checkForNullHandlers() - Method in class org.dom4j.io.SAXWriter
Ensures non-null content handlers?
childAdded(Node) - Method in class org.dom4j.datatype.DatatypeElement
Override to force lazy recreation of data object
childAdded(Node) - Method in class org.dom4j.tree.AbstractBranch
Called when a new child node has been added to me to allow any parent relationships to be created or events to be fired.
childAdded(Node) - Method in class org.dom4j.tree.AbstractDocument
childAdded(Node) - Method in class org.dom4j.tree.AbstractElement
Called when a new child node is added to create any parent relationships
childRemoved(Node) - Method in class org.dom4j.datatype.DatatypeElement
Override to force lazy recreation of data object
childRemoved(Node) - Method in class org.dom4j.tree.AbstractBranch
Called when a child node has been removed to allow any parent relationships to be deleted or events to be fired.
childRemoved(Node) - Method in class org.dom4j.tree.AbstractDocument
childRemoved(Node) - Method in class org.dom4j.tree.AbstractElement
children - Variable in class org.dom4j.swing.BranchTreeNode
Stores the child tree nodes
children() - Method in class org.dom4j.swing.BranchTreeNode
children() - Method in class org.dom4j.swing.LeafTreeNode
clear() - Method in class org.dom4j.bean.BeanAttributeList
clear() - Method in class org.dom4j.rule.RuleManager
clear() - Method in class org.dom4j.rule.Stylesheet
clear() - Method in class org.dom4j.swing.XMLTableDefinition
clear() - Method in class org.dom4j.tree.BackedList
clear() - Method in class org.dom4j.tree.ContentListFacade
clear() - Method in class org.dom4j.tree.NamespaceStack
Clears the stack
clearCaches() - Method in class org.dom4j.swing.XMLTableDefinition
clearContent() - Method in interface org.dom4j.Branch
Clears the content for this branch, removing any Node instances this branch may contain.
clearContent() - Method in class org.dom4j.tree.BaseElement
clearContent() - Method in class org.dom4j.tree.DefaultDocument
clearContent() - Method in class org.dom4j.tree.DefaultElement
clearNamespaceStack() - Method in class org.dom4j.io.DOMReader
clone() - Method in interface org.dom4j.Node
clone will return a deep clone or if this node is read-only then clone will return the same instance.
clone() - Method in class org.dom4j.tree.AbstractNode
clone() - Method in class org.dom4j.tree.DefaultDocument
clone() - Method in class org.dom4j.tree.DefaultElement
clone() - Method in class org.dom4j.util.UserDataElement
cloneNode(boolean) - Method in class org.dom4j.dom.DOMAttribute
cloneNode(boolean) - Method in class org.dom4j.dom.DOMCDATA
cloneNode(boolean) - Method in class org.dom4j.dom.DOMComment
cloneNode(boolean) - Method in class org.dom4j.dom.DOMDocument
cloneNode(boolean) - Method in class org.dom4j.dom.DOMDocumentType
cloneNode(boolean) - Method in class org.dom4j.dom.DOMElement
cloneNode(boolean) - Method in class org.dom4j.dom.DOMEntityReference
cloneNode(boolean) - Method in class org.dom4j.dom.DOMNamespace
cloneNode(Node, boolean) - Static method in class org.dom4j.dom.DOMNodeHelper
cloneNode(boolean) - Method in class org.dom4j.dom.DOMProcessingInstruction
cloneNode(boolean) - Method in class org.dom4j.dom.DOMText
close() - Method in class org.dom4j.io.XMLWriter
Closes the underlying Writer
comment(char[], int, int) - Method in class org.dom4j.io.SAXContentHandler
comment(char[], int, int) - Method in class org.dom4j.io.SAXEventRecorder
comment(char[], int, int) - Method in class org.dom4j.io.XMLWriter
compare(Object, Object) - Method in class org.dom4j.util.NodeComparator
Compares its two arguments for order.
compare(Node, Node) - Method in class org.dom4j.util.NodeComparator
compare(Document, Document) - Method in class org.dom4j.util.NodeComparator
compare(Element, Element) - Method in class org.dom4j.util.NodeComparator
compare(Attribute, Attribute) - Method in class org.dom4j.util.NodeComparator
compare(QName, QName) - Method in class org.dom4j.util.NodeComparator
compare(Namespace, Namespace) - Method in class org.dom4j.util.NodeComparator
compare(CharacterData, CharacterData) - Method in class org.dom4j.util.NodeComparator
compare(DocumentType, DocumentType) - Method in class org.dom4j.util.NodeComparator
compare(Entity, Entity) - Method in class org.dom4j.util.NodeComparator
compare(ProcessingInstruction, ProcessingInstruction) - Method in class org.dom4j.util.NodeComparator
compare(String, String) - Method in class org.dom4j.util.NodeComparator
compareContent(Branch, Branch) - Method in class org.dom4j.util.NodeComparator
compareTo(Object) - Method in class org.dom4j.rule.Rule
compareTo(Rule) - Method in class org.dom4j.rule.Rule
Compares two rules in XSLT processing model order assuming that the modes are equal.
completeCurrentTextNode() - Method in class org.dom4j.io.SAXContentHandler
If the current text buffer contains any text then create a new text node with it and add it to the current element
configureReader(XMLReader, DefaultHandler) - Method in class org.dom4j.io.SAXReader
Configures the XMLReader before use
configureReader() - Method in class org.dom4j.io.SAXValidator
Configures the XMLReader before use
contains(Object) - Method in class org.dom4j.tree.ContentListFacade
contains(Namespace) - Method in class org.dom4j.tree.NamespaceStack
DOCUMENT ME!
containsAll(Collection) - Method in class org.dom4j.tree.ContentListFacade
content() - Method in interface org.dom4j.Branch
Returns the content nodes of this branch as a backed Listso that the content of this branch may be modified directly using the Listinterface.
content() - Method in class org.dom4j.tree.AbstractBranch
content - Variable in class org.dom4j.tree.BaseElement
List of content nodes.
contentList() - Method in class org.dom4j.tree.AbstractBranch
DOCUMENT ME!
contentList() - Method in class org.dom4j.tree.BaseElement
contentList() - Method in class org.dom4j.tree.DefaultDocument
contentList() - Method in class org.dom4j.tree.DefaultElement
contentRemoved() - Method in class org.dom4j.tree.AbstractBranch
Called when the given List content has been removed so each node should have its parent and document relationships cleared
convertToValue(String) - Method in class org.dom4j.datatype.DatatypeAttribute
create(Object) - Static method in class org.dom4j.xpath.DefaultNamespaceContext
createAttribute(Element, QName, String) - Method in class org.dom4j.DocumentFactory
createAttribute(Element, String, String) - Method in class org.dom4j.DocumentFactory
createAttribute(Element, QName, String) - Static method in class org.dom4j.DocumentHelper
createAttribute(Element, String, String) - Static method in class org.dom4j.DocumentHelper
createAttribute(BeanElement, int) - Method in class org.dom4j.bean.BeanAttributeList
createAttribute(Element, QName, String) - Method in class org.dom4j.bean.BeanDocumentFactory
createAttribute(Element, QName, String) - Method in class org.dom4j.datatype.DatatypeDocumentFactory
createAttribute(Element, QName, String) - Method in class org.dom4j.datatype.DatatypeElementFactory
createAttribute(String) - Method in class org.dom4j.dom.DOMDocument
createAttribute(Element, QName, String) - Method in class org.dom4j.dom.DOMDocumentFactory
createAttribute(Attr) - Method in class org.dom4j.dom.DOMElement
createAttribute(Element, Attribute) - Method in class org.dom4j.io.STAXEventReader
Constructs a new DOM4J Attribute from the provided StAX Attribute event.
createAttribute(Attribute) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX Attributeevent from a DOM4J Attribute.
createAttribute(Element, QName, String) - Method in class org.dom4j.util.ProxyDocumentFactory
createAttribute(Element, String, String) - Method in class org.dom4j.util.ProxyDocumentFactory
createAttribute(Element, QName, String) - Method in class org.dom4j.util.UserDataDocumentFactory
createAttributeIndex() - Method in class org.dom4j.util.IndexedElement
A Factory Method to create the index for attributes
createAttributeList() - Method in class org.dom4j.bean.BeanElement
A Factory Method pattern which lazily creates a List implementation used to store content
createAttributeList(int) - Method in class org.dom4j.bean.BeanElement
createAttributeList(BeanElement) - Method in class org.dom4j.bean.BeanMetaData
createAttributeList() - Method in class org.dom4j.tree.AbstractElement
A Factory Method pattern which creates a List implementation used to store attributes
createAttributeList(int) - Method in class org.dom4j.tree.AbstractElement
A Factory Method pattern which creates a List implementation used to store attributes
createAttributeNS(String, String) - Method in class org.dom4j.dom.DOMDocument
createAttributes(Element, Attributes) - Method in class org.dom4j.io.SAXWriter
createBean(QName) - Method in class org.dom4j.bean.BeanDocumentFactory
createBean(QName, Attributes) - Method in class org.dom4j.bean.BeanDocumentFactory
createCDATA(String) - Method in class org.dom4j.DocumentFactory
createCDATA(String) - Static method in class org.dom4j.DocumentHelper
createCDATA(String) - Method in class org.dom4j.dom.DOMCDATA
createCDATA(String) - Method in class org.dom4j.dom.DOMDocumentFactory
createCDATA(String) - Method in class org.dom4j.util.ProxyDocumentFactory
createCDATASection(String) - Method in class org.dom4j.dom.DOMDocument
createCharacterData(Characters) - Method in class org.dom4j.io.STAXEventReader
Constructs a new DOM4J Text or CDATA object from the provided Characters event.
createCharacters(Text) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX Charactersevent from a DOM4J Text.
createCharacters(CDATA) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX Charactersevent from a DOM4J CDATA.
createChildList() - Method in class org.dom4j.swing.BranchTreeNode
Factory method to create List of children TreeNodes
createChildTreeNode(Node) - Method in class org.dom4j.swing.BranchTreeNode
Factory method to create child tree nodes for a given XML node type
createColumnXPath(String) - Method in class org.dom4j.swing.XMLTableDefinition
createComment(String) - Method in class org.dom4j.DocumentFactory
createComment(String) - Static method in class org.dom4j.DocumentHelper
createComment(String) - Method in class org.dom4j.dom.DOMDocument
createComment(String) - Method in class org.dom4j.dom.DOMDocumentFactory
createComment(Comment) - Method in class org.dom4j.io.STAXEventReader
Constructs a new DOM4J Comment from the provided StAX Comment event.
createComment(Comment) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX Commentevent from a DOM4J Comment.
createComment(String) - Method in class org.dom4j.util.ProxyDocumentFactory
createCompactFormat() - Static method in class org.dom4j.io.OutputFormat
A static helper method to create the default compact format.
createContentHandler(XMLReader) - Method in class org.dom4j.io.SAXReader
Factory Method to allow user derived SAXContentHandler objects to be used
createContentList() - Method in class org.dom4j.tree.AbstractBranch
A Factory Method pattern which creates a List implementation used to store content
createContentList(int) - Method in class org.dom4j.tree.AbstractBranch
A Factory Method pattern which creates a List implementation used to store content
createCopy() - Method in interface org.dom4j.Element
Creates a deep copy of this element The new element is detached from its parent, and getParent() on the clone will return null.
createCopy(String) - Method in interface org.dom4j.Element
Creates a deep copy of this element with the given local name The new element is detached from its parent, and getParent() on the clone will return null.
createCopy(QName) - Method in interface org.dom4j.Element
Creates a deep copy of this element with the given fully qualified name.
createCopy() - Method in class org.dom4j.tree.AbstractElement
This returns a deep clone of this element.
createCopy(String) - Method in class org.dom4j.tree.AbstractElement
createCopy(QName) - Method in class org.dom4j.tree.AbstractElement
createDTD(DocumentType) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX DTDevent from a DOM4J DocumentType.
createDefaultEntityResolver(String) - Method in class org.dom4j.io.SAXReader
createDefaultRule(Pattern, Action) - Method in class org.dom4j.rule.RuleManager
createDocType(String, String, String) - Method in class org.dom4j.DocumentFactory
createDocType(String, String, String) - Method in class org.dom4j.dom.DOMDocumentFactory
createDocType(String, String, String) - Method in class org.dom4j.util.ProxyDocumentFactory
createDocument() - Method in class org.dom4j.DocumentFactory
createDocument(String) - Method in class org.dom4j.DocumentFactory
DOCUMENT ME!
createDocument(Element) - Method in class org.dom4j.DocumentFactory
createDocument() - Static method in class org.dom4j.DocumentHelper
createDocument(Element) - Static method in class org.dom4j.DocumentHelper
createDocument() - Method in class org.dom4j.dom.DOMDocumentFactory
createDocument(String, String, DocumentType) - Method in class org.dom4j.dom.DOMDocumentFactory
createDocument() - Method in class org.dom4j.io.DOMReader
createDocument() - Method in class org.dom4j.io.SAXContentHandler
DOCUMENT ME!
createDocument() - Method in class org.dom4j.util.ProxyDocumentFactory
createDocument(Element) - Method in class org.dom4j.util.ProxyDocumentFactory
createDocumentFragment() - Method in class org.dom4j.dom.DOMDocument
createDocumentType(String, String, String) - Method in class org.dom4j.dom.DOMDocumentFactory
createDomDocument(Document) - Method in class org.dom4j.io.DOMWriter
createDomDocument(Document, DOMImplementation) - Method in class org.dom4j.io.DOMWriter
createDomDocumentViaJAXP() - Method in class org.dom4j.io.DOMWriter
createElement(QName) - Method in class org.dom4j.DocumentFactory
createElement(String) - Method in class org.dom4j.DocumentFactory
createElement(String, String) - Method in class org.dom4j.DocumentFactory
createElement(QName) - Static method in class org.dom4j.DocumentHelper
createElement(String) - Static method in class org.dom4j.DocumentHelper
createElement(QName) - Method in class org.dom4j.bean.BeanDocumentFactory
createElement(QName, Attributes) - Method in class org.dom4j.bean.BeanDocumentFactory
createElement(QName) - Method in class org.dom4j.datatype.DatatypeElementFactory
createElement(String) - Method in class org.dom4j.dom.DOMDocument
createElement(QName) - Method in class org.dom4j.dom.DOMDocumentFactory
createElement(QName, int) - Method in class org.dom4j.dom.DOMDocumentFactory
createElement(StartElement) - Method in class org.dom4j.io.STAXEventReader
Constructs a new DOM4J Element from the provided StartElement event.
createElement(String) - Method in class org.dom4j.tree.AbstractElement
createElement(QName) - Method in class org.dom4j.tree.AbstractElement
createElement(QName) - Method in class org.dom4j.util.IndexedDocumentFactory
createElement(QName, int) - Method in class org.dom4j.util.IndexedDocumentFactory
createElement(QName) - Method in class org.dom4j.util.NonLazyDocumentFactory
createElement(QName) - Method in class org.dom4j.util.ProxyDocumentFactory
createElement(String) - Method in class org.dom4j.util.ProxyDocumentFactory
createElement(QName) - Method in class org.dom4j.util.UserDataDocumentFactory
createElement(String) - Method in class org.dom4j.util.UserDataElement
createElement(QName) - Method in class org.dom4j.util.UserDataElement
createElementIndex() - Method in class org.dom4j.util.IndexedElement
A Factory Method to create the index for elements
createElementNS(String, String) - Method in class org.dom4j.dom.DOMDocument
createElementStack() - Method in class org.dom4j.io.SAXContentHandler
createEmptyList() - Method in class org.dom4j.tree.AbstractBranch
A Factory Method pattern which creates an empty a BackedList implementation
createEndDocument(Document) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX EndDocumentevent from a DOM4J Document.
createEndElement(Element) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX EndElementevent from a DOM4J Element.
createEntity(String, String) - Method in class org.dom4j.DocumentFactory
createEntity(String, String) - Static method in class org.dom4j.DocumentHelper
createEntity(String) - Method in class org.dom4j.dom.DOMDocumentFactory
createEntity(String, String) - Method in class org.dom4j.dom.DOMDocumentFactory
createEntity(EntityReference) - Method in class org.dom4j.io.STAXEventReader
Constructs a new DOM4J Entity from the provided StAX EntityReference event.
createEntity(String, String) - Method in class org.dom4j.util.ProxyDocumentFactory
createEntityReference(String) - Method in class org.dom4j.dom.DOMDocument
createHashCode() - Method in class org.dom4j.Namespace
Factory method to create the hashcode allowing derived classes to change the behaviour
createHashCode() - Method in class org.dom4j.tree.DefaultNamespace
DOCUMENT ME!
createIndex() - Method in class org.dom4j.util.IndexedElement
Factory method to return a new map implementation for indices
createList() - Method in class org.dom4j.util.IndexedElement
Factory method to return a list implementation for indices
createMap() - Method in class org.dom4j.tree.QNameCache
A factory method
createMode() - Method in class org.dom4j.rule.RuleManager
A factory method to return a new Modeinstance which should add the necessary default rules
createNamespace(String, String) - Method in class org.dom4j.DocumentFactory
createNamespace(String, String) - Static method in class org.dom4j.DocumentHelper
createNamespace(String, String) - Method in class org.dom4j.dom.DOMDocumentFactory
createNamespace(Namespace) - Method in class org.dom4j.io.STAXEventReader
Constructs a new DOM4J Namespace from the provided StAX Namespace event.
createNamespace(Namespace) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX Namespaceevent from a DOM4J Namespace.
createNamespace(String, String) - Method in class org.dom4j.tree.NamespaceCache
A factory method to create Namespaceinstance
createNamespace(String, String) - Method in class org.dom4j.tree.NamespaceStack
Factory method to creeate new Namespace instances.
createNamespace(String, String) - Method in class org.dom4j.util.ProxyDocumentFactory
createNodeList(List) - Static method in class org.dom4j.dom.DOMNodeHelper
createPattern(String) - Method in class org.dom4j.DocumentFactory
createPattern parses the given XPath expression to create an XSLT style Patterninstance which can then be used in an XSLT processing model.
createPattern(String) - Static method in class org.dom4j.DocumentHelper
createPattern parses the given XPath expression to create an XSLT style Patterninstance which can then be used in an XSLT processing model.
createPattern(String) - Method in class org.dom4j.tree.AbstractNode
createPattern(String) - Method in class org.dom4j.util.ProxyDocumentFactory
createPrettyPrint() - Static method in class org.dom4j.io.OutputFormat
A static helper method to create the default pretty printing format.
createProcessingInstruction(String, String) - Method in class org.dom4j.DocumentFactory
createProcessingInstruction(String, Map) - Method in class org.dom4j.DocumentFactory
createProcessingInstruction(String, String) - Static method in class org.dom4j.DocumentHelper
createProcessingInstruction(String, Map) - Static method in class org.dom4j.DocumentHelper
createProcessingInstruction(String, String) - Method in class org.dom4j.dom.DOMDocument
createProcessingInstruction(String, String) - Method in class org.dom4j.dom.DOMDocumentFactory
createProcessingInstruction(String, Map) - Method in class org.dom4j.dom.DOMDocumentFactory
createProcessingInstruction(ProcessingInstruction) - Method in class org.dom4j.io.STAXEventReader
Constructs a new DOM4J ProcessingInstruction from the provided StAX ProcessingInstruction event.
createProcessingInstruction(ProcessingInstruction) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX ProcessingInstruction event from a DOM4J ProcessingInstruction.
createProcessingInstruction(String, String) - Method in class org.dom4j.util.ProxyDocumentFactory
createProcessingInstruction(String, Map) - Method in class org.dom4j.util.ProxyDocumentFactory
createQName(String, Namespace) - Method in class org.dom4j.DocumentFactory
createQName(String) - Method in class org.dom4j.DocumentFactory
createQName(String, String, String) - Method in class org.dom4j.DocumentFactory
createQName(String, String) - Method in class org.dom4j.DocumentFactory
createQName(String, Namespace) - Static method in class org.dom4j.DocumentHelper
createQName(String) - Static method in class org.dom4j.DocumentHelper
createQName(QName) - Method in class org.dom4j.io.STAXEventReader
Constructs a new DOM4J QName from the provided JAXP QName.
createQName(QName) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX QNamefrom a DOM4J QName.
createQName(String, String, Namespace) - Method in class org.dom4j.tree.NamespaceStack
Factory method to creeate new QName instances.
createQName(String) - Method in class org.dom4j.tree.QNameCache
Factory method to create a new QName object which can be overloaded to create derived QName instances
createQName(String, Namespace) - Method in class org.dom4j.tree.QNameCache
Factory method to create a new QName object which can be overloaded to create derived QName instances
createQName(String, Namespace, String) - Method in class org.dom4j.tree.QNameCache
Factory method to create a new QName object which can be overloaded to create derived QName instances
createQName(String, Namespace) - Method in class org.dom4j.util.ProxyDocumentFactory
createQName(String) - Method in class org.dom4j.util.ProxyDocumentFactory
createQName(String, String, String) - Method in class org.dom4j.util.ProxyDocumentFactory
createQName(String, String) - Method in class org.dom4j.util.ProxyDocumentFactory
createQNameCache() - Method in class org.dom4j.DocumentFactory
Factory method to create the QNameCache.
createReader(InputStream) - Method in class org.dom4j.io.XPP3Reader
Factory method to create a Reader from the given InputStream.
createReader(InputStream) - Method in class org.dom4j.io.XPPReader
Factory method to create a Reader from the given InputStream.
createResultList() - Method in class org.dom4j.tree.AbstractBranch
A Factory Method pattern which creates a BackedList implementation used to store results of a filtered content query.
createSingleIterator(Object) - Method in class org.dom4j.tree.AbstractElement
createSingleResultList(Object) - Method in class org.dom4j.tree.AbstractBranch
A Factory Method pattern which creates a BackedList implementation which contains a single result
createSingleton(String) - Static method in class org.dom4j.DocumentFactory
createSingleton creates the singleton instance from the given class name.
createStartDocument(Document) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX StartDocumentevent from a DOM4J Document.
createStartElement(Element) - Method in class org.dom4j.io.STAXEventWriter
Constructs a STAX StartElementevent from a DOM4J Element.
createText(String) - Method in class org.dom4j.DocumentFactory
createText(String) - Static method in class org.dom4j.DocumentHelper
createText(String) - Method in class org.dom4j.dom.DOMDocumentFactory
createText(String) - Method in class org.dom4j.dom.DOMText
createText(String) - Method in class org.dom4j.util.ProxyDocumentFactory
createTextNode(String) - Method in class org.dom4j.dom.DOMDocument
createWriter(OutputStream, String) - Method in class org.dom4j.io.XMLWriter
Get an OutputStreamWriter, use preferred encoding.
createXMLReader() - Method in class org.dom4j.io.SAXReader
Factory Method to allow alternate methods of creating and configuring XMLReader objects
createXMLReader() - Method in class org.dom4j.io.SAXValidator
Factory Method to allow alternate methods of creating and configuring XMLReader objects
createXPath(String) - Method in class org.dom4j.DocumentFactory
createXPath parses an XPath expression and creates a new XPath XPath instance.
createXPath(String, VariableContext) - Method in class org.dom4j.DocumentFactory
createXPath parses an XPath expression and creates a new XPath XPath instance.
createXPath(String) - Static method in class org.dom4j.DocumentHelper
createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.
createXPath(String, VariableContext) - Static method in class org.dom4j.DocumentHelper
createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.
createXPath(String) - Method in interface org.dom4j.Node
createXPath creates an XPath object for the given xpathExpression.
createXPath(String) - Method in class org.dom4j.swing.XMLTableColumnDefinition
createXPath(String) - Method in class org.dom4j.swing.XMLTableDefinition
createXPath(String) - Method in class org.dom4j.tree.AbstractNode
createXPath(String) - Method in class org.dom4j.util.ProxyDocumentFactory
createXPath(String, VariableContext) - Method in class org.dom4j.util.ProxyDocumentFactory
createXPathFilter(String, VariableContext) - Method in class org.dom4j.DocumentFactory
createXPathFilter parses a NodeFilter from the given XPath filter expression.
createXPathFilter(String) - Method in class org.dom4j.DocumentFactory
createXPathFilter parses a NodeFilter from the given XPath filter expression.
createXPathFilter(String) - Static method in class org.dom4j.DocumentHelper
createXPathFilter parses a NodeFilter from the given XPath filter expression using the singleton DocumentFactory.
createXPathFilter(String) - Method in class org.dom4j.tree.AbstractNode
createXPathFilter(String, VariableContext) - Method in class org.dom4j.util.ProxyDocumentFactory
createXPathFilter(String) - Method in class org.dom4j.util.ProxyDocumentFactory
createXPathResult(Element) - Method in class org.dom4j.Namespace
createXPathResult(Element) - Method in class org.dom4j.tree.AbstractAttribute
createXPathResult(Element) - Method in class org.dom4j.tree.AbstractNode
createXPathResult(Element) - Method in class org.dom4j.tree.FlyweightCDATA
createXPathResult(Element) - Method in class org.dom4j.tree.FlyweightComment
createXPathResult(Element) - Method in class org.dom4j.tree.FlyweightEntity
createXPathResult(Element) - Method in class org.dom4j.tree.FlyweightProcessingInstruction
createXPathResult(Element) - Method in class org.dom4j.tree.FlyweightText

D

DEFAULT_CONTENT_LIST_SIZE - Static variable in class org.dom4j.tree.AbstractBranch
DEFAULT_FORMAT - Static variable in class org.dom4j.io.XMLWriter
DEFAULT_HTML_FORMAT - Static variable in class org.dom4j.io.HTMLWriter
DEFAULT_PREFORMATTED_TAGS - Static variable in class org.dom4j.io.HTMLWriter
DEFAULT_PRIORITY - Static variable in interface org.dom4j.rule.Pattern
According to the spec we should return 0.5 if we cannot determine the priority
DOCUMENT_NODE - Static variable in interface org.dom4j.Node
Matches Document nodes
DOCUMENT_TYPE_NODE - Static variable in interface org.dom4j.Node
Matches DocumentType nodes
DOM4J_FEATURE - Static variable in class org.dom4j.io.DocumentSource
If TransformerFactory.getFeature(java.lang.String)returns true when passed this value as an argument then the Transformer natively supports dom4j .
DOMAttribute - class org.dom4j.dom.DOMAttribute.
DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.
DOMAttribute(QName) - Constructor for class org.dom4j.dom.DOMAttribute
DOMAttribute(QName, String) - Constructor for class org.dom4j.dom.DOMAttribute
DOMAttribute(Element, QName, String) - Constructor for class org.dom4j.dom.DOMAttribute
DOMAttributeNodeMap - class org.dom4j.dom.DOMAttributeNodeMap.
DOMAttributeNodeMap implements a W3C NameNodeMap for the attributes of an element.
DOMAttributeNodeMap(DOMElement) - Constructor for class org.dom4j.dom.DOMAttributeNodeMap
DOMCDATA - class org.dom4j.dom.DOMCDATA.
DOMCDATA implements a CDATA Section which supports the W3C DOM API.
DOMCDATA(String) - Constructor for class org.dom4j.dom.DOMCDATA
DOMCDATA(Element, String) - Constructor for class org.dom4j.dom.DOMCDATA
DOMComment - class org.dom4j.dom.DOMComment.
DOMText implements a Text node which supports the W3C DOM API.
DOMComment(String) - Constructor for class org.dom4j.dom.DOMComment
DOMComment(Element, String) - Constructor for class org.dom4j.dom.DOMComment
DOMDocument - class org.dom4j.dom.DOMDocument.
DOMDocument implements an XML document which supports the W3C DOM API.
DOMDocument() - Constructor for class org.dom4j.dom.DOMDocument
DOMDocument(String) - Constructor for class org.dom4j.dom.DOMDocument
DOMDocument(DOMElement) - Constructor for class org.dom4j.dom.DOMDocument
DOMDocument(DOMDocumentType) - Constructor for class org.dom4j.dom.DOMDocument
DOMDocument(DOMElement, DOMDocumentType) - Constructor for class org.dom4j.dom.DOMDocument
DOMDocument(String, DOMElement, DOMDocumentType) - Constructor for class org.dom4j.dom.DOMDocument
DOMDocumentFactory - class org.dom4j.dom.DOMDocumentFactory.
DOMDocumentFactory is a factory of DOM4J objects which implement the W3C DOM API.
DOMDocumentFactory() - Constructor for class org.dom4j.dom.DOMDocumentFactory
DOMDocumentType - class org.dom4j.dom.DOMDocumentType.
DOMDocumentType implements a DocumentType node which supports the W3C DOM API.
DOMDocumentType() - Constructor for class org.dom4j.dom.DOMDocumentType
DOMDocumentType(String, String) - Constructor for class org.dom4j.dom.DOMDocumentType
DOMDocumentType(String, String, String) - Constructor for class org.dom4j.dom.DOMDocumentType
DOMElement - class org.dom4j.dom.DOMElement.
DOMElement implements an XML element which supports the W3C DOM API.
DOMElement(String) - Constructor for class org.dom4j.dom.DOMElement
DOMElement(QName) - Constructor for class org.dom4j.dom.DOMElement
DOMElement(QName, int) - Constructor for class org.dom4j.dom.DOMElement
DOMElement(String, Namespace) - Constructor for class org.dom4j.dom.DOMElement
DOMEntityReference - class org.dom4j.dom.DOMEntityReference.
DOMEntity implements a Entity node which supports the W3C DOM API.
DOMEntityReference(String) - Constructor for class org.dom4j.dom.DOMEntityReference
DOMEntityReference(String, String) - Constructor for class org.dom4j.dom.DOMEntityReference
DOMEntityReference(Element, String, String) - Constructor for class org.dom4j.dom.DOMEntityReference
DOMNamespace - class org.dom4j.dom.DOMNamespace.
DOMNamespace implements a Namespace that is compatable with the DOM API.
DOMNamespace(String, String) - Constructor for class org.dom4j.dom.DOMNamespace
DOMNamespace(Element, String, String) - Constructor for class org.dom4j.dom.DOMNamespace
DOMNodeHelper - class org.dom4j.dom.DOMNodeHelper.
DOMNodeHelper contains a collection of utility methods for use across Node implementations.
DOMNodeHelper() - Constructor for class org.dom4j.dom.DOMNodeHelper
DOMNodeHelper.EmptyNodeList - class org.dom4j.dom.DOMNodeHelper.EmptyNodeList.
DOMNodeHelper.EmptyNodeList() - Constructor for class org.dom4j.dom.DOMNodeHelper.EmptyNodeList
DOMProcessingInstruction - class org.dom4j.dom.DOMProcessingInstruction.
DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.
DOMProcessingInstruction(String, Map) - Constructor for class org.dom4j.dom.DOMProcessingInstruction
DOMProcessingInstruction(String, String) - Constructor for class org.dom4j.dom.DOMProcessingInstruction
DOMProcessingInstruction(Element, String, String) - Constructor for class org.dom4j.dom.DOMProcessingInstruction
DOMReader - class org.dom4j.io.DOMReader.
DOMReader navigates a W3C DOM tree and creates a DOM4J tree from it.
DOMReader() - Constructor for class org.dom4j.io.DOMReader
DOMReader(DocumentFactory) - Constructor for class org.dom4j.io.DOMReader
DOMText - class org.dom4j.dom.DOMText.
DOMText implements a Text node which supports the W3C DOM API.
DOMText(String) - Constructor for class org.dom4j.dom.DOMText
DOMText(Element, String) - Constructor for class org.dom4j.dom.DOMText
DOMWriter - class org.dom4j.io.DOMWriter.
DOMWriter takes a DOM4J tree and outputs it as a W3C DOM object
DOMWriter() - Constructor for class org.dom4j.io.DOMWriter
DOMWriter(Class) - Constructor for class org.dom4j.io.DOMWriter
DatatypeAttribute - class org.dom4j.datatype.DatatypeAttribute.
DatatypeAttribute represents an Attribute which supports the XML Schema Data Types specification.
DatatypeAttribute(QName, XSDatatype) - Constructor for class org.dom4j.datatype.DatatypeAttribute
DatatypeAttribute(QName, XSDatatype, String) - Constructor for class org.dom4j.datatype.DatatypeAttribute
DatatypeDocumentFactory - class org.dom4j.datatype.DatatypeDocumentFactory.
DatatypeDocumentFactory is a factory of XML objects which support the XML Schema Data Types specification.
DatatypeDocumentFactory() - Constructor for class org.dom4j.datatype.DatatypeDocumentFactory
DatatypeElement - class org.dom4j.datatype.DatatypeElement.
DatatypeElement represents an Element which supports the XML Schema Data Types specification.
DatatypeElement(QName, XSDatatype) - Constructor for class org.dom4j.datatype.DatatypeElement
DatatypeElement(QName, int, XSDatatype) - Constructor for class org.dom4j.datatype.DatatypeElement
DatatypeElementFactory - class org.dom4j.datatype.DatatypeElementFactory.
DatatypeElementFactory is a factory for a specific Element in an XML Schema.
DatatypeElementFactory(QName) - Constructor for class org.dom4j.datatype.DatatypeElementFactory
DefaultAttribute - class org.dom4j.tree.DefaultAttribute.
DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.
DefaultAttribute(QName) - Constructor for class org.dom4j.tree.DefaultAttribute
DefaultAttribute(QName, String) - Constructor for class org.dom4j.tree.DefaultAttribute
DefaultAttribute(Element, QName, String) - Constructor for class org.dom4j.tree.DefaultAttribute
DefaultAttribute(String, String) - Constructor for class org.dom4j.tree.DefaultAttribute
Creates the Attribute with the specified local name and value.
DefaultAttribute(String, String, Namespace) - Constructor for class org.dom4j.tree.DefaultAttribute
Creates the Attribute with the specified local name, value and Namespace.
DefaultAttribute(Element, String, String, Namespace) - Constructor for class org.dom4j.tree.DefaultAttribute
Creates the Attribute with the specified local name, value and Namespace.
DefaultCDATA - class org.dom4j.tree.DefaultCDATA.
DefaultCDATA is the default CDATA implementation.
DefaultCDATA(String) - Constructor for class org.dom4j.tree.DefaultCDATA
DOCUMENT ME!
DefaultCDATA(Element, String) - Constructor for class org.dom4j.tree.DefaultCDATA
DOCUMENT ME!
DefaultComment - class org.dom4j.tree.DefaultComment.
DefaultComment is the default Comment implementation.
DefaultComment(String) - Constructor for class org.dom4j.tree.DefaultComment
DOCUMENT ME!
DefaultComment(Element, String) - Constructor for class org.dom4j.tree.DefaultComment
DOCUMENT ME!
DefaultDocument - class org.dom4j.tree.DefaultDocument.
DefaultDocument is the default DOM4J default implementation of an XML document.
DefaultDocument() - Constructor for class org.dom4j.tree.DefaultDocument
DefaultDocument(String) - Constructor for class org.dom4j.tree.DefaultDocument
DefaultDocument(Element) - Constructor for class org.dom4j.tree.DefaultDocument
DefaultDocument(DocumentType) - Constructor for class org.dom4j.tree.DefaultDocument
DefaultDocument(Element, DocumentType) - Constructor for class org.dom4j.tree.DefaultDocument
DefaultDocument(String, Element, DocumentType) - Constructor for class org.dom4j.tree.DefaultDocument
DefaultDocumentType - class org.dom4j.tree.DefaultDocumentType.
DefaultDocumentType is the DOM4J default implementation of an XML document type.
DefaultDocumentType() - Constructor for class org.dom4j.tree.DefaultDocumentType
DefaultDocumentType(String, String) - Constructor for class org.dom4j.tree.DefaultDocumentType
This will create a new DocumentType with a reference to the external DTD
DefaultDocumentType(String, String, String) - Constructor for class org.dom4j.tree.DefaultDocumentType
This will create a new DocumentType with a reference to the external DTD
DefaultElement - class org.dom4j.tree.DefaultElement.
DefaultElement is the default DOM4J default implementation of an XML element.
DefaultElement(String) - Constructor for class org.dom4j.tree.DefaultElement
DefaultElement(QName) - Constructor for class org.dom4j.tree.DefaultElement
DefaultElement(QName, int) - Constructor for class org.dom4j.tree.DefaultElement
DefaultElement(String, Namespace) - Constructor for class org.dom4j.tree.DefaultElement
DefaultEntity - class org.dom4j.tree.DefaultEntity.
DefaultEntity is the default Entity implementation.
DefaultEntity(String) - Constructor for class org.dom4j.tree.DefaultEntity
Creates the Entity with the specified name
DefaultEntity(String, String) - Constructor for class org.dom4j.tree.DefaultEntity
Creates the Entity with the specified name and text.
DefaultEntity(Element, String, String) - Constructor for class org.dom4j.tree.DefaultEntity
Creates the Entity with the specified name and text.
DefaultNamespace - class org.dom4j.tree.DefaultNamespace.
DefaultNamespace implements a doubly linked node which supports the parent relationship and is mutable.
DefaultNamespace(String, String) - Constructor for class org.dom4j.tree.DefaultNamespace
DOCUMENT ME!
DefaultNamespace(Element, String, String) - Constructor for class org.dom4j.tree.DefaultNamespace
DOCUMENT ME!
DefaultNamespaceContext - class org.dom4j.xpath.DefaultNamespaceContext.
DefaultNamespaceContext implements a Jaxen NamespaceContext such that a context node is used to determine the current XPath namespace prefixes and namespace URIs available.
DefaultNamespaceContext(Element) - Constructor for class org.dom4j.xpath.DefaultNamespaceContext
DefaultPattern - class org.dom4j.rule.pattern.DefaultPattern.
DefaultPattern a default implementation of Pattern which can take any XPath implementation or NodeFilter for defining the pattern.
DefaultPattern(NodeFilter) - Constructor for class org.dom4j.rule.pattern.DefaultPattern
DefaultProcessingInstruction - class org.dom4j.tree.DefaultProcessingInstruction.
DefaultProcessingInstruction is the default Processing Instruction implementation.
DefaultProcessingInstruction(String, Map) - Constructor for class org.dom4j.tree.DefaultProcessingInstruction
This will create a new PI with the given target and values
DefaultProcessingInstruction(String, String) - Constructor for class org.dom4j.tree.DefaultProcessingInstruction
This will create a new PI with the given target and values
DefaultProcessingInstruction(Element, String, String) - Constructor for class org.dom4j.tree.DefaultProcessingInstruction
This will create a new PI with the given target and values
DefaultText - class org.dom4j.tree.DefaultText.
DefaultText is the default Text implementation.
DefaultText(String) - Constructor for class org.dom4j.tree.DefaultText
DOCUMENT ME!
DefaultText(Element, String) - Constructor for class org.dom4j.tree.DefaultText
DOCUMENT ME!
DefaultXPath - class org.dom4j.xpath.DefaultXPath.
Default implementation of XPathwhich uses the Jaxen project.
DefaultXPath(String) - Constructor for class org.dom4j.xpath.DefaultXPath
Construct an XPath
Document - interface org.dom4j.Document.
Document defines an XML Document.
DocumentException - exception org.dom4j.DocumentException.
DocumentException is a nested Exception which may be thrown during the processing of a DOM4J document.
DocumentException() - Constructor for class org.dom4j.DocumentException
DocumentException(String) - Constructor for class org.dom4j.DocumentException
DocumentException(Throwable) - Constructor for class org.dom4j.DocumentException
DocumentException(String, Throwable) - Constructor for class org.dom4j.DocumentException
DocumentFactory - class org.dom4j.DocumentFactory.
DocumentFactory is a collection of factory methods to allow easy custom building of DOM4J trees.
DocumentFactory() - Constructor for class org.dom4j.DocumentFactory
DocumentHelper - class org.dom4j.DocumentHelper.
DocumentHelper is a collection of helper methods for using DOM4J.
DocumentResult - class org.dom4j.io.DocumentResult.
DocumentResult implements a JAXP SAXResultfor a Document.
DocumentResult() - Constructor for class org.dom4j.io.DocumentResult
DocumentResult(SAXContentHandler) - Constructor for class org.dom4j.io.DocumentResult
DocumentSource - class org.dom4j.io.DocumentSource.
DocumentSource implements a JAXP SAXSourcefor a .
DocumentSource(Node) - Constructor for class org.dom4j.io.DocumentSource
Creates a JAXP SAXSourcefor the given Node.
DocumentSource(Document) - Constructor for class org.dom4j.io.DocumentSource
Creates a JAXP SAXSourcefor the given Document.
DocumentTreeModel - class org.dom4j.swing.DocumentTreeModel.
DocumentTreeModel implements a Swing TreeModel for a dom4j XML Document.
DocumentTreeModel(Document) - Constructor for class org.dom4j.swing.DocumentTreeModel
DocumentType - interface org.dom4j.DocumentType.
DocumentType defines an XML DOCTYPE declaration.
declaredNamespaces() - Method in interface org.dom4j.Element
Returns all the namespaces declared by this element.
declaredNamespaces() - Method in class org.dom4j.tree.AbstractElement
declaredNamespaces() - Method in class org.dom4j.tree.DefaultElement
defaultMaximumAllowedCharacter() - Method in class org.dom4j.io.XMLWriter
Returns the maximum allowed character code that should be allowed unescaped which defaults to 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit).
deleteData(int, int) - Method in class org.dom4j.dom.DOMCDATA
deleteData(int, int) - Method in class org.dom4j.dom.DOMComment
deleteData(CharacterData, int, int) - Static method in class org.dom4j.dom.DOMNodeHelper
deleteData(int, int) - Method in class org.dom4j.dom.DOMText
detach() - Method in interface org.dom4j.Node
Removes this node from its parent if there is one.
detach() - Method in class org.dom4j.tree.AbstractNode
document - Variable in class org.dom4j.swing.DocumentTreeModel
The document for this model
documentLocator(Document) - Method in class org.dom4j.io.SAXWriter
The Locatoris only really useful when parsing a textual document as its main purpose is to identify the line and column number.
dtdHandler(Document) - Method in class org.dom4j.io.SAXWriter
We do not yet support DTD or XML Schemas so this method does nothing right now.

E

ELEMENT_NODE - Static variable in interface org.dom4j.Node
Matches Element nodes
EMPTY_ENUMERATION - Static variable in class org.dom4j.swing.LeafTreeNode
EMPTY_ITERATOR - Static variable in class org.dom4j.tree.AbstractElement
EMPTY_ITERATOR - Static variable in class org.dom4j.tree.DefaultDocument
EMPTY_LIST - Static variable in class org.dom4j.tree.AbstractElement
EMPTY_LIST - Static variable in class org.dom4j.tree.DefaultDocument
EMPTY_NODE_LIST - Static variable in class org.dom4j.dom.DOMNodeHelper
ENTITY_REFERENCE_NODE - Static variable in interface org.dom4j.Node
Matches elements nodes
ERROR_QNAME - Static variable in class org.dom4j.util.XMLErrorHandler
Element - interface org.dom4j.Element.
Element interface defines an XML element.
ElementDecl - class org.dom4j.dtd.ElementDecl.
AttributeDecl represents an element declaration in a DTD.
ElementDecl() - Constructor for class org.dom4j.dtd.ElementDecl
ElementDecl(String, String) - Constructor for class org.dom4j.dtd.ElementDecl
ElementHandler - interface org.dom4j.ElementHandler.
ElementHandler interface defines a handler of Element objects.
ElementIterator - class org.dom4j.tree.ElementIterator.
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
ElementIterator(Iterator) - Constructor for class org.dom4j.tree.ElementIterator
Deprecated.
ElementModifier - interface org.dom4j.io.ElementModifier.
ElementModifier defines a modifier of Elementobjects.
ElementNameIterator - class org.dom4j.tree.ElementNameIterator.
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
ElementNameIterator(Iterator, String) - Constructor for class org.dom4j.tree.ElementNameIterator
Deprecated.
ElementPath - interface org.dom4j.ElementPath.
This interface is used by ElementHandlerinstances to retrieve information about the current path hierarchy they are to process.
ElementQNameIterator - class org.dom4j.tree.ElementQNameIterator.
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
ElementQNameIterator(Iterator, QName) - Constructor for class org.dom4j.tree.ElementQNameIterator
Deprecated.
Entity - interface org.dom4j.Entity.
Entity defines an XML entity.
ExternalEntityDecl - class org.dom4j.dtd.ExternalEntityDecl.
ExternalEntityDecl represents an external entity declaration in a DTD.
ExternalEntityDecl() - Constructor for class org.dom4j.dtd.ExternalEntityDecl
ExternalEntityDecl(String, String, String) - Constructor for class org.dom4j.dtd.ExternalEntityDecl
element(String) - Method in interface org.dom4j.Element
Returns the first element for the given local name and any namespace.
element(QName) - Method in interface org.dom4j.Element
Returns the first element for the given fully qualified name.
element(String) - Method in class org.dom4j.tree.AbstractElement
element(QName) - Method in class org.dom4j.tree.AbstractElement
element(String, Namespace) - Method in class org.dom4j.tree.AbstractElement
element(String) - Method in class org.dom4j.tree.DefaultElement
element(QName) - Method in class org.dom4j.tree.DefaultElement
element(String, Namespace) - Method in class org.dom4j.tree.DefaultElement
element(String) - Method in class org.dom4j.util.IndexedElement
element(QName) - Method in class org.dom4j.util.IndexedElement
elementByID(String) - Method in interface org.dom4j.Branch
Returns the element of the given ID attribute value.
elementByID(String) - Method in class org.dom4j.tree.AbstractBranch
elementDecl(String, String) - Method in class org.dom4j.io.SAXContentHandler
Report an element type declaration.
elementDecl(String, String) - Method in class org.dom4j.io.SAXEventRecorder
elementID(Element) - Method in class org.dom4j.tree.AbstractBranch
DOCUMENT ME!
elementIndex() - Method in class org.dom4j.util.IndexedElement
elementIterator() - Method in interface org.dom4j.Element
Returns an iterator over all this elements child elements.
elementIterator(String) - Method in interface org.dom4j.Element
Returns an iterator over the elements contained in this element which match the given local name and any namespace.
elementIterator(QName) - Method in interface org.dom4j.Element
Returns an iterator over the elements contained in this element which match the given fully qualified name.
elementIterator() - Method in class org.dom4j.tree.AbstractElement
elementIterator(String) - Method in class org.dom4j.tree.AbstractElement
elementIterator(QName) - Method in class org.dom4j.tree.AbstractElement
elementIterator(String, Namespace) - Method in class org.dom4j.tree.AbstractElement
elementName - Variable in class org.dom4j.tree.DefaultDocumentType
The root element name of the document typ
elementText(String) - Method in interface org.dom4j.Element
elementText(QName) - Method in interface org.dom4j.Element
elementText(String) - Method in class org.dom4j.tree.AbstractElement
elementText(QName) - Method in class org.dom4j.tree.AbstractElement
elementTextTrim(String) - Method in interface org.dom4j.Element
elementTextTrim(QName) - Method in interface org.dom4j.Element
elementTextTrim(String) - Method in class org.dom4j.tree.AbstractElement
elementTextTrim(QName) - Method in class org.dom4j.tree.AbstractElement
elements() - Method in interface org.dom4j.Element
Returns the elements contained in this element.
elements(String) - Method in interface org.dom4j.Element
Returns the elements contained in this element with the given local name and any namespace.
elements(QName) - Method in interface org.dom4j.Element
Returns the elements contained in this element with the given fully qualified name.
elements() - Method in class org.dom4j.tree.AbstractElement
elements(String) - Method in class org.dom4j.tree.AbstractElement
elements(QName) - Method in class org.dom4j.tree.AbstractElement
elements(String, Namespace) - Method in class org.dom4j.tree.AbstractElement
elements(String) - Method in class org.dom4j.util.IndexedElement
elements(QName) - Method in class org.dom4j.util.IndexedElement
encoding - Variable in class org.dom4j.tree.AbstractDocument
The encoding of this document as stated in the XML declaration
endCDATA() - Method in class org.dom4j.io.HTMLWriter
endCDATA() - Method in class org.dom4j.io.SAXContentHandler
endCDATA() - Method in class org.dom4j.io.SAXEventRecorder
endCDATA() - Method in class org.dom4j.io.XMLWriter
endDTD() - Method in class org.dom4j.io.SAXContentHandler
endDTD() - Method in class org.dom4j.io.SAXEventRecorder
endDTD() - Method in class org.dom4j.io.XMLWriter
endDocument() - Method in class org.dom4j.io.SAXContentHandler
endDocument() - Method in class org.dom4j.io.SAXEventRecorder
endDocument() - Method in class org.dom4j.io.SAXWriter
endDocument() - Method in class org.dom4j.io.XMLWriter
endDocument() - Method in class org.dom4j.jaxb.JAXBWriter
Stop writing the document to the output.
endElement(String, String, String) - Method in class org.dom4j.io.SAXContentHandler
endElement(String, String, String) - Method in class org.dom4j.io.SAXEventRecorder
endElement(Element) - Method in class org.dom4j.io.SAXWriter
endElement(String, String, String) - Method in class org.dom4j.io.XMLWriter
endEntity(String) - Method in class org.dom4j.io.SAXContentHandler
endEntity(String) - Method in class org.dom4j.io.SAXEventRecorder
endEntity(String) - Method in class org.dom4j.io.XMLWriter
endPrefixMapping(String) - Method in class org.dom4j.io.SAXContentHandler
endPrefixMapping(String) - Method in class org.dom4j.io.SAXEventRecorder
endPrefixMapping(NamespaceStack, int) - Method in class org.dom4j.io.SAXWriter
Fires a SAX endPrefixMapping event for all the namespaceStack which have gone out of scope
endPrefixMapping(String) - Method in class org.dom4j.io.XMLWriter
ensureAttributesCapacity(int) - Method in class org.dom4j.tree.AbstractElement
Ensures that the list of attributes has the given size
ensureAttributesCapacity(int) - Method in class org.dom4j.xpp.ProxyXmlStartTag
entityResolver(Document) - Method in class org.dom4j.io.SAXWriter
equals(Object) - Method in class org.dom4j.Namespace
Checks whether this Namespace equals the given Namespace.
equals(Object) - Method in class org.dom4j.QName
equals(Object) - Method in class org.dom4j.rule.Rule
equals(Object) - Method in class org.dom4j.tree.ConcurrentReaderHashMap.Entry
equals(Object) - Method in class org.dom4j.tree.DefaultNamespace
Implements an identity based comparsion using the parent element as well as the prefix and URI
error(SAXParseException) - Method in class org.dom4j.io.SAXContentHandler
This method is called when an error is detected during parsing such as a validation error.
error(SAXParseException) - Method in class org.dom4j.util.XMLErrorHandler
escapeAttributeEntities(String) - Method in class org.dom4j.io.XMLWriter
This will take the pre-defined entities in XML 1.0 and convert their character representation to the appropriate entity reference, suitable for XML attributes.
escapeElementEntities(String) - Method in class org.dom4j.io.XMLWriter
This will take the pre-defined entities in XML 1.0 and convert their character representation to the appropriate entity reference, suitable for XML attributes.
evaluate(Object) - Method in interface org.dom4j.XPath
evaluate evaluates an XPath expression and returns the result as an Object.
evaluate(Object) - Method in class org.dom4j.xpath.DefaultXPath
externalEntityDecl(String, String, String) - Method in class org.dom4j.io.SAXContentHandler
Report a parsed external entity declaration.
externalEntityDecl(String, String, String) - Method in class org.dom4j.io.SAXEventRecorder

F

FATALERROR_QNAME - Static variable in class org.dom4j.util.XMLErrorHandler
FEATURE_NAMESPACES - Static variable in class org.dom4j.io.SAXWriter
FEATURE_NAMESPACE_PREFIXES - Static variable in class org.dom4j.io.SAXWriter
FilterIterator - class org.dom4j.tree.FilterIterator.
Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
FilterIterator(Iterator) - Constructor for class org.dom4j.tree.FilterIterator
Deprecated.
FlyweightAttribute - class org.dom4j.tree.FlyweightAttribute.
FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.
FlyweightAttribute(QName) - Constructor for class org.dom4j.tree.FlyweightAttribute
FlyweightAttribute(QName, String) - Constructor for class org.dom4j.tree.FlyweightAttribute
FlyweightAttribute(String, String) - Constructor for class org.dom4j.tree.FlyweightAttribute
Creates the Attribute with the specified local name and value.
FlyweightAttribute(String, String, Namespace) - Constructor for class org.dom4j.tree.FlyweightAttribute
Creates the Attribute with the specified local name, value and Namespace.
FlyweightCDATA - class org.dom4j.tree.FlyweightCDATA.
FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.
FlyweightCDATA(String) - Constructor for class org.dom4j.tree.FlyweightCDATA
DOCUMENT ME!
FlyweightComment - class org.dom4j.tree.FlyweightComment.
FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.
FlyweightComment(String) - Constructor for class org.dom4j.tree.FlyweightComment
DOCUMENT ME!
FlyweightEntity - class org.dom4j.tree.FlyweightEntity.
FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.
FlyweightEntity() - Constructor for class org.dom4j.tree.FlyweightEntity
A default constructor for implementors to use.
FlyweightEntity(String) - Constructor for class org.dom4j.tree.FlyweightEntity
Creates the Entity with the specified name
FlyweightEntity(String, String) - Constructor for class org.dom4j.tree.FlyweightEntity
Creates the Entity with the specified name and text.
FlyweightProcessingInstruction - class org.dom4j.tree.FlyweightProcessingInstruction.
FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.
FlyweightProcessingInstruction() - Constructor for class org.dom4j.tree.FlyweightProcessingInstruction
A default constructor for implementors to use.
FlyweightProcessingInstruction(String, Map) - Constructor for class org.dom4j.tree.FlyweightProcessingInstruction
This will create a new PI with the given target and values
FlyweightProcessingInstruction(String, String) - Constructor for class org.dom4j.tree.FlyweightProcessingInstruction
This will create a new PI with the given target and values
FlyweightText - class org.dom4j.tree.FlyweightText.
FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.
FlyweightText(String) - Constructor for class org.dom4j.tree.FlyweightText
DOCUMENT ME!
fatalError(SAXParseException) - Method in class org.dom4j.io.SAXContentHandler
This method is called when a fatal error occurs during parsing.
fatalError(SAXParseException) - Method in class org.dom4j.util.XMLErrorHandler
findDefaultNamespace() - Method in class org.dom4j.tree.NamespaceStack
Attempts to find the current default namespace on the stack right now or returns null if one could not be found
findNext() - Method in class org.dom4j.tree.FilterIterator
Deprecated.
fireRule(Node) - Method in class org.dom4j.rule.Mode
Runs the actions associated with the given node
flush() - Method in class org.dom4j.io.XMLWriter
Flushes the underlying Writer
foo() - Method in class org.dom4j.dom.DOMAttributeNodeMap

G

get(String, String) - Static method in class org.dom4j.Namespace
A helper method to return the Namespace instance for the given prefix and URI
get(String) - Static method in class org.dom4j.Namespace
A helper method to return the Namespace instance for no prefix and the URI
get(String) - Static method in class org.dom4j.QName
get(String, Namespace) - Static method in class org.dom4j.QName
get(String, String, String) - Static method in class org.dom4j.QName
get(String, String) - Static method in class org.dom4j.QName
get(String, Namespace, String) - Static method in class org.dom4j.QName
get(int) - Method in class org.dom4j.bean.BeanAttributeList
get(Class) - Static method in class org.dom4j.bean.BeanMetaData
Static helper method to find and cache meta data objects for bean types
get(int) - Method in class org.dom4j.tree.ContentListFacade
get(String, String) - Method in class org.dom4j.tree.NamespaceCache
DOCUMENT ME!
get(String) - Method in class org.dom4j.tree.NamespaceCache
DOCUMENT ME!
get(String) - Method in class org.dom4j.tree.QNameCache
DOCUMENT ME!
get(String, Namespace) - Method in class org.dom4j.tree.QNameCache
DOCUMENT ME!
get(String, Namespace, String) - Method in class org.dom4j.tree.QNameCache
DOCUMENT ME!
get(String, String) - Method in class org.dom4j.tree.QNameCache
getAction() - Method in class org.dom4j.rule.Rule
Getter for property action.
getAllowsChildren() - Method in class org.dom4j.swing.BranchTreeNode
getAllowsChildren() - Method in class org.dom4j.swing.LeafTreeNode
getAppearenceCount() - Method in class org.dom4j.rule.Rule
Getter for property appearenceCount.
getAttribute(String) - Method in class org.dom4j.dom.DOMElement
getAttributeCount() - Method in class org.dom4j.xpp.ProxyXmlStartTag
getAttributeLocalName(int) - Method in class org.dom4j.xpp.ProxyXmlStartTag
getAttributeNS(String, String) - Method in class org.dom4j.dom.DOMElement
getAttributeName() - Method in class org.dom4j.dtd.AttributeDecl
Getter for property attributeName.
getAttributeNamespaceUri(int) - Method in class org.dom4j.xpp.ProxyXmlStartTag
getAttributeNode(String) - Method in class org.dom4j.dom.DOMElement
getAttributeNodeNS(String, String) - Method in class org.dom4j.dom.DOMElement
getAttributePrefix(int) - Method in class org.dom4j.xpp.ProxyXmlStartTag
getAttributeQName(String, String, String) - Method in class org.dom4j.tree.NamespaceStack
getAttributeQuoteCharacter() - Method in class org.dom4j.io.OutputFormat
getAttributeRawName(int) - Method in class org.dom4j.xpp.ProxyXmlStartTag
getAttributeValue(int) - Method in class org.dom4j.xpp.ProxyXmlStartTag
getAttributeValueFromName(String, String) - Method in class org.dom4j.xpp.ProxyXmlStartTag
getAttributeValueFromRawName(String) - Method in class org.dom4j.xpp.ProxyXmlStartTag
getAttributeXSDatatype(QName) - Method in class org.dom4j.datatype.DatatypeElementFactory
DOCUMENT ME!
getAttributes() - Method in class org.dom4j.dom.DOMAttribute
getAttributes() - Method in class org.dom4j.dom.DOMCDATA
getAttributes() - Method in class org.dom4j.dom.DOMComment
getAttributes() - Method in class org.dom4j.dom.DOMDocument
getAttributes() - Method in class org.dom4j.dom.DOMDocumentType
getAttributes() - Method in class org.dom4j.dom.DOMElement
getAttributes() - Method in class org.dom4j.dom.DOMEntityReference
getAttributes() - Method in class org.dom4j.dom.DOMNamespace
getAttributes(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getAttributes() - Method in class org.dom4j.dom.DOMProcessingInstruction
getAttributes() - Method in class org.dom4j.dom.DOMText
getBackingList() - Method in class org.dom4j.tree.ContentListFacade
getBaseUri() - Method in class org.dom4j.datatype.DatatypeAttribute
getBaseUri() - Method in class org.dom4j.datatype.DatatypeElement
getBeanAttributeList() - Method in class org.dom4j.bean.BeanElement
getChildAt(int) - Method in class org.dom4j.swing.BranchTreeNode
getChildAt(int) - Method in class org.dom4j.swing.LeafTreeNode
getChildCount() - Method in class org.dom4j.swing.BranchTreeNode
getChildCount() - Method in class org.dom4j.swing.LeafTreeNode
getChildElementXSDatatype(QName) - Method in class org.dom4j.datatype.DatatypeElementFactory
DOCUMENT ME!
getChildList() - Method in class org.dom4j.swing.BranchTreeNode
Uses Lazy Initialization pattern to create a List of children
getChildNodes() - Method in class org.dom4j.dom.DOMAttribute
getChildNodes() - Method in class org.dom4j.dom.DOMCDATA
getChildNodes() - Method in class org.dom4j.dom.DOMComment
getChildNodes() - Method in class org.dom4j.dom.DOMDocument
getChildNodes() - Method in class org.dom4j.dom.DOMDocumentType
getChildNodes() - Method in class org.dom4j.dom.DOMElement
getChildNodes() - Method in class org.dom4j.dom.DOMEntityReference
getChildNodes() - Method in class org.dom4j.dom.DOMNamespace
getChildNodes(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getChildNodes() - Method in class org.dom4j.dom.DOMProcessingInstruction
getChildNodes() - Method in class org.dom4j.dom.DOMText
getColumn(int) - Method in class org.dom4j.swing.XMLTableDefinition
getColumn(String) - Method in class org.dom4j.swing.XMLTableDefinition
getColumnClass() - Method in class org.dom4j.swing.XMLTableColumnDefinition
getColumnClass(int) - Method in class org.dom4j.swing.XMLTableDefinition
getColumnClass(int) - Method in class org.dom4j.swing.XMLTableModel
getColumnCount() - Method in class org.dom4j.swing.XMLTableDefinition
getColumnCount() - Method in class org.dom4j.swing.XMLTableModel
getColumnName(int) - Method in class org.dom4j.swing.XMLTableDefinition
DOCUMENT ME!
getColumnName(int) - Method in class org.dom4j.swing.XMLTableModel
getColumnNameXPath() - Method in class org.dom4j.swing.XMLTableColumnDefinition
DOCUMENT ME!
getColumnNameXPath(int) - Method in class org.dom4j.swing.XMLTableDefinition
DOCUMENT ME!
getColumnXPath(int) - Method in class org.dom4j.swing.XMLTableDefinition
DOCUMENT ME!
getCompareValue(Node) - Method in class org.dom4j.xpath.DefaultXPath
DOCUMENT ME!
getConsumer() - Method in class org.dom4j.io.STAXEventWriter
Returns a reference to the underlying event consumer to which events are written.
getContentAsStringValue(Object) - Method in class org.dom4j.tree.AbstractBranch
DOCUMENT ME!
getContentAsText(Object) - Method in class org.dom4j.tree.AbstractBranch
DOCUMENT ME!
getContentHandler() - Method in class org.dom4j.io.SAXWriter
DOCUMENT ME!
getContextSupport() - Method in class org.dom4j.xpath.XPathPattern
getCopyOfUserData() - Method in class org.dom4j.util.UserDataElement
If a deep copy of user data is required whenever the clone() or createCopy() methods are called on this element then this method should return a clone of the user data
getCurrent() - Method in interface org.dom4j.ElementPath
DOCUMENT ME!
getDTDHandler() - Method in class org.dom4j.io.SAXWriter
DOCUMENT ME!
getData() - Method in interface org.dom4j.Attribute
Accesses the data of this attribute which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Node.getText().
getData() - Method in interface org.dom4j.Element
Accesses the data of this element which may implement data typing bindings such as XML Schema or Java Bean bindings or will return the same value as Element.getText()
getData() - Method in class org.dom4j.bean.BeanAttribute
getData(int) - Method in class org.dom4j.bean.BeanAttributeList
getData() - Method in class org.dom4j.bean.BeanElement
DOCUMENT ME!
getData(int, Object) - Method in class org.dom4j.bean.BeanMetaData
getData() - Method in class org.dom4j.datatype.DatatypeAttribute
getData() - Method in class org.dom4j.datatype.DatatypeElement
getData() - Method in class org.dom4j.dom.DOMCDATA
getData() - Method in class org.dom4j.dom.DOMComment
getData(CharacterData) - Static method in class org.dom4j.dom.DOMNodeHelper
getData() - Method in class org.dom4j.dom.DOMProcessingInstruction
getData() - Method in class org.dom4j.dom.DOMText
getData() - Method in class org.dom4j.tree.AbstractAttribute
getData() - Method in class org.dom4j.tree.AbstractElement
getData() - Method in class org.dom4j.util.UserDataAttribute
getData() - Method in class org.dom4j.util.UserDataElement
getDefaultNamespace() - Method in class org.dom4j.tree.NamespaceStack
getDefinition() - Method in class org.dom4j.swing.XMLTableModel
Getter for property definition.
getDispatchHandler() - Method in class org.dom4j.io.SAXReader
getDispatchHandler() - Method in class org.dom4j.io.XPP3Reader
getDispatchHandler() - Method in class org.dom4j.io.XPPReader
getDocType() - Method in interface org.dom4j.Document
DOCUMENT ME!
getDocType() - Method in class org.dom4j.tree.DefaultDocument
getDoctype() - Method in class org.dom4j.dom.DOMDocument
getDocument() - Method in interface org.dom4j.Node
getDocument returns the Document that this Node is part of if this node supports the parent relationship.
getDocument() - Method in class org.dom4j.io.DocumentResult
DOCUMENT ME!
getDocument() - Method in class org.dom4j.io.DocumentSource
DOCUMENT ME!
getDocument() - Method in class org.dom4j.io.SAXContentHandler
DOCUMENT ME!
getDocument() - Method in class org.dom4j.swing.DocumentTreeModel
DOCUMENT ME!
getDocument() - Method in class org.dom4j.tree.AbstractDocument
getDocument() - Method in class org.dom4j.tree.AbstractNode
getDocument() - Method in class org.dom4j.tree.BaseElement
getDocument() - Method in class org.dom4j.tree.DefaultElement
getDocumentElement() - Method in class org.dom4j.dom.DOMDocument
getDocumentFactory() - Method in class org.dom4j.QName
DOCUMENT ME!
getDocumentFactory() - Method in class org.dom4j.bean.BeanElement
getDocumentFactory() - Method in class org.dom4j.dom.DOMDocument
getDocumentFactory() - Method in class org.dom4j.dom.DOMElement
getDocumentFactory() - Method in class org.dom4j.io.DOMReader
DOCUMENT ME!
getDocumentFactory() - Method in class org.dom4j.io.SAXModifier
Get the DocumentFactoryused to create the DOM4J document structure
getDocumentFactory() - Method in class org.dom4j.io.SAXReader
DOCUMENT ME!
getDocumentFactory() - Method in class org.dom4j.io.XPP3Reader
DOCUMENT ME!
getDocumentFactory() - Method in class org.dom4j.io.XPPReader
DOCUMENT ME!
getDocumentFactory() - Method in class org.dom4j.tree.AbstractElement
getDocumentFactory() - Method in class org.dom4j.tree.AbstractNode
getDocumentFactory() - Method in class org.dom4j.tree.DefaultDocument
getDocumentFactory() - Method in class org.dom4j.tree.DefaultElement
getDocumentFactory() - Method in class org.dom4j.tree.NamespaceStack
getDocumentFactory() - Method in class org.dom4j.xpp.ProxyXmlStartTag
getDomDocumentClass() - Method in class org.dom4j.io.DOMWriter
getElement(int) - Method in interface org.dom4j.ElementPath
DOCUMENT ME!
getElement() - Method in class org.dom4j.xpp.ProxyXmlStartTag
getElementById(String) - Method in class org.dom4j.dom.DOMDocument
getElementFactory(QName) - Method in class org.dom4j.datatype.DatatypeDocumentFactory
Registers the given DatatypeElementFactory for the given <element> schema element
getElementName() - Method in interface org.dom4j.DocumentType
This method is the equivalent to the Node.getName()method.
getElementName() - Method in class org.dom4j.dtd.AttributeDecl
Getter for property elementName.
getElementName() - Method in class org.dom4j.tree.DefaultDocumentType
getElementStack() - Method in class org.dom4j.io.SAXContentHandler
getElementsByTagName(String) - Method in class org.dom4j.dom.DOMDocument
getElementsByTagName(String) - Method in class org.dom4j.dom.DOMElement
getElementsByTagNameNS(String, String) - Method in class org.dom4j.dom.DOMDocument
getElementsByTagNameNS(String, String) - Method in class org.dom4j.dom.DOMElement
getEncoding() - Method in class org.dom4j.io.OutputFormat
getEncoding() - Method in class org.dom4j.io.SAXReader
Returns encoding used for InputSource (null means system default encoding)
getEntities() - Method in class org.dom4j.dom.DOMDocumentType
getEntityResolver() - Method in interface org.dom4j.Document
DOCUMENT ME!
getEntityResolver() - Method in class org.dom4j.io.SAXContentHandler
getEntityResolver() - Method in class org.dom4j.io.SAXReader
Returns the current entity resolver used to resolve entities
getEntityResolver() - Method in class org.dom4j.io.SAXWriter
DOCUMENT ME!
getEntityResolver() - Method in class org.dom4j.tree.DefaultDocument
getErrorHandler() - Method in class org.dom4j.io.SAXReader
DOCUMENT ME!
getErrorHandler() - Method in class org.dom4j.io.SAXValidator
DOCUMENT ME!
getErrorHandler() - Method in class org.dom4j.io.SAXWriter
DOCUMENT ME!
getErrorQName() - Method in class org.dom4j.util.XMLErrorHandler
getErrors() - Method in class org.dom4j.util.XMLErrorHandler
getEventFactory() - Method in class org.dom4j.io.STAXEventWriter
Returns a reference to the event factory used to construct STAX events.
getExternalDeclarations() - Method in interface org.dom4j.DocumentType
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
getExternalDeclarations() - Method in class org.dom4j.tree.DefaultDocumentType
getFatalErrorQName() - Method in class org.dom4j.util.XMLErrorHandler
getFeature(String) - Method in class org.dom4j.io.SAXWriter
Looks up the value of a feature.
getFirstChild() - Method in class org.dom4j.dom.DOMAttribute
getFirstChild() - Method in class org.dom4j.dom.DOMCDATA
getFirstChild() - Method in class org.dom4j.dom.DOMComment
getFirstChild() - Method in class org.dom4j.dom.DOMDocument
getFirstChild() - Method in class org.dom4j.dom.DOMDocumentType
getFirstChild() - Method in class org.dom4j.dom.DOMElement
getFirstChild() - Method in class org.dom4j.dom.DOMEntityReference
getFirstChild() - Method in class org.dom4j.dom.DOMNamespace
getFirstChild(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getFirstChild() - Method in class org.dom4j.dom.DOMProcessingInstruction
getFirstChild() - Method in class org.dom4j.dom.DOMText
getFunctionContext() - Method in interface org.dom4j.XPath
DOCUMENT ME!
getFunctionContext() - Method in class org.dom4j.xpath.DefaultXPath
getHandler() - Method in class org.dom4j.io.XMLResult
getImplementation() - Method in class org.dom4j.dom.DOMDocument
getImportPrecedence() - Method in class org.dom4j.rule.Rule
Getter for property importPrecedence.
getIndent() - Method in class org.dom4j.io.OutputFormat
getIndex(String) - Method in class org.dom4j.bean.BeanMetaData
getIndex(QName) - Method in class org.dom4j.bean.BeanMetaData
getIndex(TreeNode) - Method in class org.dom4j.swing.BranchTreeNode
getIndex(TreeNode) - Method in class org.dom4j.swing.LeafTreeNode
getInputSource() - Method in class org.dom4j.io.SAXContentHandler
getInstance() - Static method in class org.dom4j.DocumentFactory
Access to singleton implementation of DocumentFactory which is used if no DocumentFactory is specified when building using the standard builders.
getInstance() - Static method in class org.dom4j.bean.BeanDocumentFactory
Access to the singleton instance of this factory.
getInstance() - Static method in class org.dom4j.datatype.DatatypeDocumentFactory
Access to the singleton instance of this factory.
getInstance() - Static method in class org.dom4j.dom.DOMDocumentFactory
Access to the singleton instance of this factory.
getInstance() - Static method in class org.dom4j.util.IndexedDocumentFactory
Access to the singleton instance of this factory.
getInstance() - Static method in class org.dom4j.util.NonLazyDocumentFactory
Access to the singleton instance of this factory.
getInstance() - Static method in class org.dom4j.util.UserDataDocumentFactory
Access to the singleton instance of this factory.
getInternalDeclarations() - Method in interface org.dom4j.DocumentType
Returns a list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
getInternalDeclarations() - Method in class org.dom4j.tree.DefaultDocumentType
getInternalSubset() - Method in class org.dom4j.dom.DOMDocumentType
getKey() - Method in class org.dom4j.tree.ConcurrentReaderHashMap.Entry
getLastChild() - Method in class org.dom4j.dom.DOMAttribute
getLastChild() - Method in class org.dom4j.dom.DOMCDATA
getLastChild() - Method in class org.dom4j.dom.DOMComment
getLastChild() - Method in class org.dom4j.dom.DOMDocument
getLastChild() - Method in class org.dom4j.dom.DOMDocumentType
getLastChild() - Method in class org.dom4j.dom.DOMElement
getLastChild() - Method in class org.dom4j.dom.DOMEntityReference
getLastChild() - Method in class org.dom4j.dom.DOMNamespace
getLastChild(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getLastChild() - Method in class org.dom4j.dom.DOMProcessingInstruction
getLastChild() - Method in class org.dom4j.dom.DOMText
getLength() - Method in class org.dom4j.dom.DOMAttributeNodeMap
getLength() - Method in class org.dom4j.dom.DOMCDATA
getLength() - Method in class org.dom4j.dom.DOMComment
getLength() - Method in class org.dom4j.dom.DOMNodeHelper.EmptyNodeList
getLength(CharacterData) - Static method in class org.dom4j.dom.DOMNodeHelper
getLength() - Method in class org.dom4j.dom.DOMText
getLexicalHandler() - Method in class org.dom4j.io.SAXWriter
DOCUMENT ME!
getLexicalHandler() - Method in class org.dom4j.io.XMLResult
getLexicalHandler() - Method in class org.dom4j.io.XMLWriter
getLineSeparator() - Method in class org.dom4j.io.OutputFormat
getLocalName() - Method in class org.dom4j.dom.DOMAttribute
getLocalName() - Method in class org.dom4j.dom.DOMCDATA
getLocalName() - Method in class org.dom4j.dom.DOMComment
getLocalName() - Method in class org.dom4j.dom.DOMDocument
getLocalName() - Method in class org.dom4j.dom.DOMDocumentType
getLocalName() - Method in class org.dom4j.dom.DOMElement
getLocalName() - Method in class org.dom4j.dom.DOMEntityReference
getLocalName() - Method in class org.dom4j.dom.DOMNamespace
getLocalName(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getLocalName() - Method in class org.dom4j.dom.DOMProcessingInstruction
getLocalName() - Method in class org.dom4j.dom.DOMText
getLocalName() - Method in class org.dom4j.xpp.ProxyXmlStartTag
getMatchType() - Method in interface org.dom4j.rule.Pattern
DOCUMENT ME!
getMatchType() - Method in class org.dom4j.rule.Rule
DOCUMENT ME!
getMatchType() - Method in class org.dom4j.rule.pattern.DefaultPattern
getMatchType() - Method in class org.dom4j.rule.pattern.NodeTypePattern
getMatchType() - Method in class org.dom4j.xpath.XPathPattern
getMatchesNodeName() - Method in interface org.dom4j.rule.Pattern
For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches.
getMatchesNodeName() - Method in class org.dom4j.rule.Rule
For patterns which only match an ATTRIBUTE_NODE or an ELEMENT_NODE then this pattern may return the name of the element or attribute it matches.
getMatchesNodeName() - Method in class org.dom4j.rule.pattern.DefaultPattern
getMatchesNodeName() - Method in class org.dom4j.rule.pattern.NodeTypePattern
getMatchesNodeName() - Method in class org.dom4j.xpath.XPathPattern
getMatchingRule(Node) - Method in class org.dom4j.rule.Mode
Performs an XSLT processing model match for the rule which matches the given Node the best.
getMatchingRule(String, Node) - Method in class org.dom4j.rule.RuleManager
Performs an XSLT processing model match for the rule which matches the given Node the best.
getMatchingRule(Node) - Method in class org.dom4j.rule.RuleSet
Performs an XSLT processing model match for the rule which matches the given Node the best.
getMaximumAllowedCharacter() - Method in class org.dom4j.io.XMLWriter
Returns the maximum allowed character code that should be allowed unescaped which defaults to 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit).
getMessage() - Method in class org.dom4j.DocumentException
getMode() - Method in class org.dom4j.rule.Rule
Getter for property mode.
getMode(String) - Method in class org.dom4j.rule.RuleManager
DOCUMENT ME!
getModeName() - Method in class org.dom4j.rule.Stylesheet
DOCUMENT ME!
getModel() - Method in class org.dom4j.dtd.ElementDecl
Getter for property model.
getName() - Method in interface org.dom4j.Node
getName returns the name of this node.
getName() - Method in class org.dom4j.QName
DOCUMENT ME!
getName() - Method in class org.dom4j.dtd.ElementDecl
Getter for property name.
getName() - Method in class org.dom4j.dtd.ExternalEntityDecl
Getter for property name.
getName() - Method in class org.dom4j.dtd.InternalEntityDecl
Getter for property name.
getName() - Method in class org.dom4j.swing.XMLTableColumnDefinition
Getter for property name.
getName() - Method in class org.dom4j.tree.AbstractAttribute
getName() - Method in class org.dom4j.tree.AbstractDocumentType
getName() - Method in class org.dom4j.tree.AbstractElement
getName() - Method in class org.dom4j.tree.AbstractNode
getName() - Method in class org.dom4j.tree.AbstractProcessingInstruction
getName() - Method in class org.dom4j.tree.DefaultDocument
getName() - Method in class org.dom4j.tree.FlyweightEntity
DOCUMENT ME!
getNamedItem(String) - Method in class org.dom4j.dom.DOMAttributeNodeMap
getNamedItemNS(String, String) - Method in class org.dom4j.dom.DOMAttributeNodeMap
getNamespace() - Method in interface org.dom4j.Attribute
Returns the Namespace of this element if one exists otherwise null is returned returned.
getNamespace() - Method in interface org.dom4j.Element
Returns the Namespace of this element if one exists otherwise Namespace.NO_NAMESPACE is returned.
getNamespace() - Method in class org.dom4j.QName
DOCUMENT ME!
getNamespace(String, String) - Method in class org.dom4j.io.DOMReader
getNamespace() - Method in class org.dom4j.tree.AbstractAttribute
getNamespace() - Method in class org.dom4j.tree.AbstractElement
getNamespace(int) - Method in class org.dom4j.tree.NamespaceStack
DOCUMENT ME!
getNamespaceCache() - Method in class org.dom4j.tree.NamespaceStack
getNamespaceCache(Namespace) - Method in class org.dom4j.tree.QNameCache
DOCUMENT ME!
getNamespaceContext() - Method in interface org.dom4j.XPath
DOCUMENT ME!
getNamespaceContext() - Method in class org.dom4j.xpath.DefaultXPath
getNamespaceForPrefix(String) - Method in interface org.dom4j.Element
Returns the Namespace which is mapped to the given prefix or null if it could not be found.
getNamespaceForPrefix(String) - Method in class org.dom4j.tree.AbstractElement
getNamespaceForPrefix(String) - Method in class org.dom4j.tree.DefaultElement
getNamespaceForPrefix(String) - Method in class org.dom4j.tree.NamespaceStack
DOCUMENT ME!
getNamespaceForURI(String) - Method in interface org.dom4j.Element
Returns the Namespace which is mapped to the given URI or null if it could not be found.
getNamespaceForURI(String) - Method in class org.dom4j.tree.AbstractElement
getNamespaceForURI(String) - Method in class org.dom4j.tree.DefaultElement
getNamespacePrefix() - Method in interface org.dom4j.Attribute
Returns the namespace prefix of this element if one exists otherwise an empty String is returned.
getNamespacePrefix() - Method in interface org.dom4j.Element
Returns the namespace prefix of this element if one exists otherwise an empty String is returned.
getNamespacePrefix() - Method in class org.dom4j.QName
DOCUMENT ME!
getNamespacePrefix(String) - Method in class org.dom4j.datatype.DatatypeAttribute
getNamespacePrefix(String) - Method in class org.dom4j.datatype.DatatypeElement
getNamespacePrefix() - Method in class org.dom4j.tree.AbstractAttribute
getNamespacePrefix() - Method in class org.dom4j.tree.AbstractElement
getNamespaceURI() - Method in interface org.dom4j.Attribute
Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.
getNamespaceURI() - Method in interface org.dom4j.Element
Returns the URI mapped to the namespace of this element if one exists otherwise an empty String is returned.
getNamespaceURI() - Method in class org.dom4j.QName
DOCUMENT ME!
getNamespaceURI() - Method in class org.dom4j.dom.DOMAttribute
getNamespaceURI() - Method in class org.dom4j.dom.DOMCDATA
getNamespaceURI() - Method in class org.dom4j.dom.DOMComment
getNamespaceURI() - Method in class org.dom4j.dom.DOMDocument
getNamespaceURI() - Method in class org.dom4j.dom.DOMDocumentType
getNamespaceURI() - Method in class org.dom4j.dom.DOMElement
getNamespaceURI() - Method in class org.dom4j.dom.DOMEntityReference
getNamespaceURI() - Method in class org.dom4j.dom.DOMNamespace
getNamespaceURI(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getNamespaceURI() - Method in class org.dom4j.dom.DOMProcessingInstruction
getNamespaceURI() - Method in class org.dom4j.dom.DOMText
getNamespaceURI() - Method in class org.dom4j.tree.AbstractAttribute
getNamespaceURI() - Method in class org.dom4j.tree.AbstractElement
getNamespaceUri() - Method in class org.dom4j.xpp.ProxyXmlStartTag
getNamespacesForURI(String) - Method in interface org.dom4j.Element
Returns the all namespaces which are mapped to the given URI or an empty list if no such namespaces could be found.
getNamespacesForURI(String) - Method in class org.dom4j.tree.AbstractElement
getNestedException() - Method in class org.dom4j.DocumentException
getNewLineAfterNTags() - Method in class org.dom4j.io.OutputFormat
getNextSibling() - Method in class org.dom4j.dom.DOMAttribute
getNextSibling() - Method in class org.dom4j.dom.DOMCDATA
getNextSibling() - Method in class org.dom4j.dom.DOMComment
getNextSibling() - Method in class org.dom4j.dom.DOMDocument
getNextSibling() - Method in class org.dom4j.dom.DOMDocumentType
getNextSibling() - Method in class org.dom4j.dom.DOMElement
getNextSibling() - Method in class org.dom4j.dom.DOMEntityReference
getNextSibling() - Method in class org.dom4j.dom.DOMNamespace
getNextSibling(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getNextSibling() - Method in class org.dom4j.dom.DOMProcessingInstruction
getNextSibling() - Method in class org.dom4j.dom.DOMText
getNodeName() - Method in class org.dom4j.dom.DOMAttribute
getNodeName() - Method in class org.dom4j.dom.DOMCDATA
getNodeName() - Method in class org.dom4j.dom.DOMComment
getNodeName() - Method in class org.dom4j.dom.DOMDocument
getNodeName() - Method in class org.dom4j.dom.DOMDocumentType
getNodeName() - Method in class org.dom4j.dom.DOMElement
getNodeName() - Method in class org.dom4j.dom.DOMEntityReference
getNodeName() - Method in class org.dom4j.dom.DOMNamespace
getNodeName() - Method in class org.dom4j.dom.DOMProcessingInstruction
getNodeName() - Method in class org.dom4j.dom.DOMText
getNodeType() - Method in class org.dom4j.Namespace
getNodeType() - Method in interface org.dom4j.Node
Returns the code according to the type of node.
getNodeType() - Method in class org.dom4j.tree.AbstractAttribute
getNodeType() - Method in class org.dom4j.tree.AbstractCDATA
getNodeType() - Method in class org.dom4j.tree.AbstractComment
getNodeType() - Method in class org.dom4j.tree.AbstractDocument
getNodeType() - Method in class org.dom4j.tree.AbstractDocumentType
getNodeType() - Method in class org.dom4j.tree.AbstractElement
getNodeType() - Method in class org.dom4j.tree.AbstractEntity
getNodeType() - Method in class org.dom4j.tree.AbstractNode
getNodeType() - Method in class org.dom4j.tree.AbstractProcessingInstruction
getNodeType() - Method in class org.dom4j.tree.AbstractText
getNodeTypeName() - Method in interface org.dom4j.Node
DOCUMENT ME!
getNodeTypeName() - Method in class org.dom4j.tree.AbstractNode
getNodeValue() - Method in class org.dom4j.dom.DOMAttribute
getNodeValue() - Method in class org.dom4j.dom.DOMCDATA
getNodeValue() - Method in class org.dom4j.dom.DOMComment
getNodeValue() - Method in class org.dom4j.dom.DOMDocument
getNodeValue() - Method in class org.dom4j.dom.DOMDocumentType
getNodeValue() - Method in class org.dom4j.dom.DOMElement
getNodeValue() - Method in class org.dom4j.dom.DOMEntityReference
getNodeValue() - Method in class org.dom4j.dom.DOMNamespace
getNodeValue(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getNodeValue() - Method in class org.dom4j.dom.DOMProcessingInstruction
getNodeValue() - Method in class org.dom4j.dom.DOMText
getNotations() - Method in class org.dom4j.dom.DOMDocumentType
getOmitElementCloseSet() - Method in class org.dom4j.io.HTMLWriter
A clone of the Set of elements that can have their close-tags omitted.
getOutputFormat() - Method in class org.dom4j.io.XMLWriter
Lets subclasses get at the current format object, so they can call setTrimText, setNewLines, etc.
getOutputFormat() - Method in class org.dom4j.jaxb.JAXBWriter
Returns the OutputFormat that will be used when writing the XML stream.
getOwnerDocument() - Method in class org.dom4j.dom.DOMAttribute
getOwnerDocument() - Method in class org.dom4j.dom.DOMCDATA
getOwnerDocument() - Method in class org.dom4j.dom.DOMComment
getOwnerDocument() - Method in class org.dom4j.dom.DOMDocument
getOwnerDocument() - Method in class org.dom4j.dom.DOMDocumentType
getOwnerDocument() - Method in class org.dom4j.dom.DOMElement
getOwnerDocument() - Method in class org.dom4j.dom.DOMEntityReference
getOwnerDocument() - Method in class org.dom4j.dom.DOMNamespace
getOwnerDocument(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getOwnerDocument() - Method in class org.dom4j.dom.DOMProcessingInstruction
getOwnerDocument() - Method in class org.dom4j.dom.DOMText
getOwnerElement() - Method in class org.dom4j.dom.DOMAttribute
getParent() - Method in interface org.dom4j.Node
getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
getParent() - Method in class org.dom4j.bean.BeanAttribute
getParent() - Method in class org.dom4j.bean.BeanAttributeList
getParent() - Method in class org.dom4j.datatype.DatatypeAttribute
getParent() - Method in class org.dom4j.swing.LeafTreeNode
getParent() - Method in class org.dom4j.tree.AbstractNode
getParent() - Method in class org.dom4j.tree.BaseElement
getParent() - Method in class org.dom4j.tree.DefaultAttribute
getParent() - Method in class org.dom4j.tree.DefaultCDATA
getParent() - Method in class org.dom4j.tree.DefaultComment
getParent() - Method in class org.dom4j.tree.DefaultElement
getParent() - Method in class org.dom4j.tree.DefaultEntity
getParent() - Method in class org.dom4j.tree.DefaultNamespace
getParent() - Method in class org.dom4j.tree.DefaultProcessingInstruction
getParent() - Method in class org.dom4j.tree.DefaultText
getParentNode() - Method in class org.dom4j.dom.DOMAttribute
getParentNode() - Method in class org.dom4j.dom.DOMCDATA
getParentNode() - Method in class org.dom4j.dom.DOMComment
getParentNode() - Method in class org.dom4j.dom.DOMDocument
getParentNode() - Method in class org.dom4j.dom.DOMDocumentType
getParentNode() - Method in class org.dom4j.dom.DOMElement
getParentNode() - Method in class org.dom4j.dom.DOMEntityReference
getParentNode() - Method in class org.dom4j.dom.DOMNamespace
getParentNode(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getParentNode() - Method in class org.dom4j.dom.DOMProcessingInstruction
getParentNode() - Method in class org.dom4j.dom.DOMText
getPath() - Method in interface org.dom4j.ElementPath
DOCUMENT ME!
getPath(Element) - Method in class org.dom4j.Namespace
getPath() - Method in interface org.dom4j.Node
Returns the XPath expression which will return a node set containing the given node such as /a/b/@c.
getPath(Element) - Method in interface org.dom4j.Node
Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
getPath(Element) - Method in class org.dom4j.tree.AbstractAttribute
getPath(Element) - Method in class org.dom4j.tree.AbstractCharacterData
getPath(Element) - Method in class org.dom4j.tree.AbstractComment
getPath(Element) - Method in class org.dom4j.tree.AbstractDocument
getPath(Element) - Method in class org.dom4j.tree.AbstractDocumentType
getPath(Element) - Method in class org.dom4j.tree.AbstractElement
getPath(Element) - Method in class org.dom4j.tree.AbstractEntity
getPath() - Method in class org.dom4j.tree.AbstractNode
getPath(Element) - Method in class org.dom4j.tree.AbstractProcessingInstruction
getPattern() - Method in class org.dom4j.rule.Rule
Getter for property pattern.
getPrefix() - Method in class org.dom4j.Namespace
DOCUMENT ME!
getPrefix() - Method in class org.dom4j.dom.DOMAttribute
getPrefix() - Method in class org.dom4j.dom.DOMCDATA
getPrefix() - Method in class org.dom4j.dom.DOMComment
getPrefix() - Method in class org.dom4j.dom.DOMDocument
getPrefix() - Method in class org.dom4j.dom.DOMDocumentType
getPrefix() - Method in class org.dom4j.dom.DOMElement
getPrefix() - Method in class org.dom4j.dom.DOMEntityReference
getPrefix(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getPrefix() - Method in class org.dom4j.dom.DOMProcessingInstruction
getPrefix() - Method in class org.dom4j.dom.DOMText
getPrefix() - Method in class org.dom4j.xpp.ProxyXmlStartTag
getPreformattedTags() - Method in class org.dom4j.io.HTMLWriter
getPreviousSibling() - Method in class org.dom4j.dom.DOMAttribute
getPreviousSibling() - Method in class org.dom4j.dom.DOMCDATA
getPreviousSibling() - Method in class org.dom4j.dom.DOMComment
getPreviousSibling() - Method in class org.dom4j.dom.DOMDocument
getPreviousSibling() - Method in class org.dom4j.dom.DOMDocumentType
getPreviousSibling() - Method in class org.dom4j.dom.DOMElement
getPreviousSibling() - Method in class org.dom4j.dom.DOMEntityReference
getPreviousSibling() - Method in class org.dom4j.dom.DOMNamespace
getPreviousSibling(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
getPreviousSibling() - Method in class org.dom4j.dom.DOMProcessingInstruction
getPreviousSibling() - Method in class org.dom4j.dom.DOMText
getPriority() - Method in interface org.dom4j.rule.Pattern
Returns the default resolution policy of the pattern according to the XSLT conflict resolution spec .
getPriority() - Method in class org.dom4j.rule.Rule
Getter for property priority.
getPriority() - Method in class org.dom4j.rule.pattern.DefaultPattern
getPriority() - Method in class org.dom4j.rule.pattern.NodeTypePattern
getPriority() - Method in class org.dom4j.xpath.XPathPattern
getProperty(String) - Method in class org.dom4j.io.SAXWriter
Gets the given SAX property
getProperty(String) - Method in class org.dom4j.io.XMLWriter
getProxy() - Method in class org.dom4j.util.ProxyDocumentFactory
getPublicID() - Method in interface org.dom4j.DocumentType
getPublicID() - Method in class org.dom4j.dtd.ExternalEntityDecl
Getter for property publicID.
getPublicID() - Method in class org.dom4j.tree.DefaultDocumentType
DOCUMENT ME!
getPublicId() - Method in class org.dom4j.dom.DOMDocumentType
getQName() - Method in interface org.dom4j.Attribute
Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.
getQName() - Method in interface org.dom4j.Element
Returns the QName of this element which represents the local name, the qualified name and the Namespace.
getQName(String) - Method in interface org.dom4j.Element
Returns the QName for the given qualified name, using the namespace URI in scope for the given prefix of the qualified name or the default namespace if the qualified name has no prefix.
getQName() - Method in class org.dom4j.bean.BeanAttribute
getQName(int) - Method in class org.dom4j.bean.BeanAttributeList
getQName(int) - Method in class org.dom4j.bean.BeanMetaData
getQName() - Method in class org.dom4j.datatype.DatatypeAttribute
getQName() - Method in class org.dom4j.datatype.DatatypeElementFactory
DOCUMENT ME!
getQName(String, String) - Method in class org.dom4j.dom.DOMElement
getQName(String) - Method in class org.dom4j.tree.AbstractElement
getQName() - Method in class org.dom4j.tree.BaseElement
getQName() - Method in class org.dom4j.tree.DefaultElement
getQName() - Method in class org.dom4j.tree.FlyweightAttribute
getQName(String, String, String) - Method in class org.dom4j.tree.NamespaceStack
getQNames() - Method in class org.dom4j.DocumentFactory
Returns a list of all the QName instances currently used by this document factory
getQNames() - Method in class org.dom4j.tree.QNameCache
Returns a list of all the QName instances currently used
getQualifiedName() - Method in interface org.dom4j.Attribute
Returns the fully qualified name of this element.
getQualifiedName() - Method in interface org.dom4j.Element
Returns the fully qualified name of this element.
getQualifiedName() - Method in class org.dom4j.QName
DOCUMENT ME!
getQualifiedName() - Method in class org.dom4j.tree.AbstractAttribute
getQualifiedName() - Method in class org.dom4j.tree.AbstractElement
getRawName() - Method in class org.dom4j.xpp.ProxyXmlStartTag
getRootElement() - Method in interface org.dom4j.Document
Returns the root Elementfor this document.
getRootElement() - Method in class org.dom4j.tree.DefaultDocument
getRowCount() - Method in class org.dom4j.swing.XMLTableModel
getRowValue(int) - Method in class org.dom4j.swing.XMLTableModel
getRowXPath() - Method in class org.dom4j.swing.XMLTableDefinition
Getter for property rowXPath.
getRows() - Method in class org.dom4j.swing.XMLTableModel
getRuleArray() - Method in class org.dom4j.rule.RuleSet
Returns an array of sorted rules.
getRuleSet(int) - Method in class org.dom4j.rule.Mode
DOCUMENT ME!
getSource() - Method in class org.dom4j.swing.XMLTableModel
Getter for the XML source, which is usually a Node or List of nodes.
getSpecified() - Method in class org.dom4j.dom.DOMAttribute
getStringValue() - Method in interface org.dom4j.Element
Returns the XPath string-value of this node.
getStringValue() - Method in class org.dom4j.Namespace
getStringValue() - Method in interface org.dom4j.Node
Returns the XPath string-value of this node.
getStringValue() - Method in class org.dom4j.tree.AbstractDocument
getStringValue() - Method in class org.dom4j.tree.AbstractElement
getStringValue() - Method in class org.dom4j.tree.AbstractEntity
getStringValue() - Method in class org.dom4j.tree.AbstractNode
getStringValue() - Method in class org.dom4j.tree.DefaultElement
getSystemID() - Method in interface org.dom4j.DocumentType
getSystemID() - Method in class org.dom4j.dtd.ExternalEntityDecl
Getter for property systemID.
getSystemID() - Method in class org.dom4j.tree.DefaultDocumentType
DOCUMENT ME!
getSystemId() - Method in class org.dom4j.dom.DOMDocumentType
getTagName() - Method in class org.dom4j.dom.DOMElement
getTarget() - Method in interface org.dom4j.ProcessingInstruction
This method is the equivalent to the Node.getName()method.
getTarget() - Method in class org.dom4j.tree.FlyweightProcessingInstruction
getText() - Method in interface org.dom4j.Element
Returns the text value of this element without recursing through child elements.
getText() - Method in class org.dom4j.Namespace
getText() - Method in interface org.dom4j.Node
Returns the text of this node.
getText() - Method in interface org.dom4j.ProcessingInstruction
DOCUMENT ME!
getText() - Method in interface org.dom4j.XPath
getText will return the textual version of the XPath expression.
getText() - Method in class org.dom4j.tree.AbstractAttribute
getText() - Method in class org.dom4j.tree.AbstractBranch
getText() - Method in class org.dom4j.tree.AbstractDocumentType
Returns the text format of the declarations if applicable, or the empty String
getText() - Method in class org.dom4j.tree.AbstractNode
getText() - Method in class org.dom4j.tree.DefaultElement
getText() - Method in class org.dom4j.tree.FlyweightCDATA
getText() - Method in class org.dom4j.tree.FlyweightComment
getText() - Method in class org.dom4j.tree.FlyweightEntity
DOCUMENT ME!
getText() - Method in class org.dom4j.tree.FlyweightProcessingInstruction
getText() - Method in class org.dom4j.tree.FlyweightText
getText() - Method in class org.dom4j.xpath.DefaultXPath
Retrieve the textual XPath string used to initialize this Object
getText() - Method in class org.dom4j.xpath.XPathPattern
getTextTrim() - Method in interface org.dom4j.Element
DOCUMENT ME!
getTextTrim() - Method in class org.dom4j.tree.AbstractBranch
getType() - Method in class org.dom4j.dtd.AttributeDecl
Getter for property type.
getType() - Method in class org.dom4j.swing.XMLTableColumnDefinition
Getter for property type.
getURI() - Method in class org.dom4j.Namespace
DOCUMENT ME!
getURI(String) - Method in class org.dom4j.tree.NamespaceStack
DOCUMENT ME!
getURICache(String) - Method in class org.dom4j.tree.NamespaceCache
DOCUMENT ME!
getUnionPatterns() - Method in interface org.dom4j.rule.Pattern
If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern.
getUnionPatterns() - Method in class org.dom4j.rule.pattern.DefaultPattern
getUnionPatterns() - Method in class org.dom4j.rule.pattern.NodeTypePattern
getUnionPatterns() - Method in class org.dom4j.xpath.XPathPattern
getUnionRules() - Method in class org.dom4j.rule.Rule
If this rule contains a union pattern then this method should return an array of Rules which describe the union rule, which should contain more than one rule.
getUniquePath(Element) - Method in class org.dom4j.Namespace
getUniquePath() - Method in interface org.dom4j.Node
Returns the XPath expression which will return a nodeset of one node which is the current node.
getUniquePath(Element) - Method in interface org.dom4j.Node
Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
getUniquePath(Element) - Method in class org.dom4j.tree.AbstractAttribute
getUniquePath(Element) - Method in class org.dom4j.tree.AbstractCharacterData
getUniquePath(Element) - Method in class org.dom4j.tree.AbstractComment
getUniquePath(Element) - Method in class org.dom4j.tree.AbstractDocument
getUniquePath(Element) - Method in class org.dom4j.tree.AbstractDocumentType
getUniquePath(Element) - Method in class org.dom4j.tree.AbstractElement
getUniquePath(Element) - Method in class org.dom4j.tree.AbstractEntity
getUniquePath() - Method in class org.dom4j.tree.AbstractNode
getUniquePath(Element) - Method in class org.dom4j.tree.AbstractProcessingInstruction
getValue() - Method in interface org.dom4j.Attribute
Returns the value of the attribute.
getValue(String) - Method in interface org.dom4j.ProcessingInstruction
Returns the value of a specific name in the PI.
getValue() - Method in class org.dom4j.bean.BeanAttribute
getValue() - Method in class org.dom4j.datatype.DatatypeAttribute
getValue() - Method in class org.dom4j.dtd.AttributeDecl
Getter for property value.
getValue() - Method in class org.dom4j.dtd.InternalEntityDecl
Getter for property value.
getValue(Object) - Method in class org.dom4j.swing.XMLTableColumnDefinition
getValue() - Method in class org.dom4j.tree.ConcurrentReaderHashMap.Entry
Get the value.
getValue() - Method in class org.dom4j.tree.FlyweightAttribute
getValue(String) - Method in class org.dom4j.tree.FlyweightProcessingInstruction
getValueAt(Object, int) - Method in class org.dom4j.swing.XMLTableDefinition
getValueAt(int, int) - Method in class org.dom4j.swing.XMLTableModel
getValueDefault() - Method in class org.dom4j.dtd.AttributeDecl
Getter for property valueDefault.
getValueOfAction() - Method in class org.dom4j.rule.RuleManager
DOCUMENT ME!
getValueOfAction() - Method in class org.dom4j.rule.Stylesheet
DOCUMENT ME!
getValues() - Method in interface org.dom4j.ProcessingInstruction
DOCUMENT ME!
getValues() - Method in class org.dom4j.tree.FlyweightProcessingInstruction
getVariableContext() - Method in interface org.dom4j.XPath
DOCUMENT ME!
getVariableContext() - Method in class org.dom4j.xpath.DefaultXPath
getVariableValue(String, String, String) - Method in class org.dom4j.swing.XMLTableDefinition
getWarningQName() - Method in class org.dom4j.util.XMLErrorHandler
getXMLEncoding() - Method in interface org.dom4j.Document
Return the encoding of this document, as part of the XML declaration This is null when unspecified or when it is not known (such as when the Document was created in memory) or when the implementation does not support this operation.
getXMLEncoding() - Method in class org.dom4j.tree.AbstractDocument
getXMLEncoding() - Method in class org.dom4j.tree.DefaultDocument
getXMLFilter() - Method in class org.dom4j.io.SAXReader
Returns the SAX filter being used to filter SAX events.
getXMLReader() - Method in class org.dom4j.io.DocumentSource
DOCUMENT ME!
getXMLReader() - Method in class org.dom4j.io.SAXReader
DOCUMENT ME!
getXMLReader() - Method in class org.dom4j.io.SAXValidator
DOCUMENT ME!
getXMLWriter() - Method in class org.dom4j.io.SAXModifier
Returns the current XMLWriter.
getXMLWriter() - Method in class org.dom4j.io.XMLResult
getXPPFactory() - Method in class org.dom4j.io.XPP3Reader
getXPPFactory() - Method in class org.dom4j.io.XPPReader
getXPPParser() - Method in class org.dom4j.io.XPP3Reader
getXPPParser() - Method in class org.dom4j.io.XPPReader
getXPath() - Method in class org.dom4j.XPathException
Returns the XPath expression that caused the problem
getXPath() - Method in class org.dom4j.swing.XMLTableColumnDefinition
Getter for property xpath.
getXPathNameStep() - Method in class org.dom4j.Namespace
getXPathNameStep() - Method in class org.dom4j.tree.AbstractElement
Returns the XPath expression to match this Elements name which is getQualifiedName() if there is a namespace prefix defined or if no namespace is present then it is getName() or if a namespace is defined with no prefix then the expression is [name()='X'] where X = getName().
getXPathNamespaceURIs() - Method in class org.dom4j.DocumentFactory
DOCUMENT ME!
getXPathResult(int) - Method in interface org.dom4j.Element
Returns a node at the given index suitable for an XPath result set.
getXPathResult(int) - Method in class org.dom4j.tree.AbstractElement
getXSDatatype() - Method in class org.dom4j.datatype.DatatypeAttribute
Returns the MSV XSDatatype for this node
getXSDatatype() - Method in class org.dom4j.datatype.DatatypeElement
Returns the MSV XSDatatype for this node
getXmlBranch() - Method in class org.dom4j.swing.BranchTreeNode
getXmlNode() - Method in class org.dom4j.swing.LeafTreeNode

H

HTMLWriter - class org.dom4j.io.HTMLWriter.
HTMLWriter takes a DOM4J tree and formats it to a stream as HTML.
HTMLWriter(Writer) - Constructor for class org.dom4j.io.HTMLWriter
HTMLWriter(Writer, OutputFormat) - Constructor for class org.dom4j.io.HTMLWriter
HTMLWriter() - Constructor for class org.dom4j.io.HTMLWriter
HTMLWriter(OutputFormat) - Constructor for class org.dom4j.io.HTMLWriter
HTMLWriter(OutputStream) - Constructor for class org.dom4j.io.HTMLWriter
HTMLWriter(OutputStream, OutputFormat) - Constructor for class org.dom4j.io.HTMLWriter
handleException(Exception) - Method in class org.dom4j.bean.BeanDocumentFactory
handleException(Exception) - Method in class org.dom4j.bean.BeanMetaData
handleException(IOException) - Method in class org.dom4j.io.XMLWriter
handleException(Exception) - Method in class org.dom4j.swing.XMLTableColumnDefinition
handleException(Exception) - Method in class org.dom4j.swing.XMLTableDefinition
handleException(Exception) - Method in class org.dom4j.swing.XMLTableModel
handleJaxenException(JaxenException) - Method in class org.dom4j.xpath.DefaultXPath
handleJaxenException(JaxenException) - Method in class org.dom4j.xpath.XPathPattern
handleObject(Element) - Method in interface org.dom4j.jaxb.JAXBObjectHandler
Called when the JAXBReaderhas finished parsing the xml path the handler was registered for.
hasAttribute(String) - Method in class org.dom4j.dom.DOMElement
hasAttributeNS(String, String) - Method in class org.dom4j.dom.DOMElement
hasAttributes() - Method in class org.dom4j.dom.DOMAttribute
hasAttributes() - Method in class org.dom4j.dom.DOMCDATA
hasAttributes() - Method in class org.dom4j.dom.DOMComment
hasAttributes() - Method in class org.dom4j.dom.DOMDocument
hasAttributes() - Method in class org.dom4j.dom.DOMDocumentType
hasAttributes() - Method in class org.dom4j.dom.DOMElement
hasAttributes() - Method in class org.dom4j.dom.DOMEntityReference
hasAttributes() - Method in class org.dom4j.dom.DOMNamespace
hasAttributes(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
hasAttributes() - Method in class org.dom4j.dom.DOMProcessingInstruction
hasAttributes() - Method in class org.dom4j.dom.DOMText
hasChildNodes() - Method in class org.dom4j.dom.DOMAttribute
hasChildNodes() - Method in class org.dom4j.dom.DOMCDATA
hasChildNodes() - Method in class org.dom4j.dom.DOMComment
hasChildNodes() - Method in class org.dom4j.dom.DOMDocument
hasChildNodes() - Method in class org.dom4j.dom.DOMDocumentType
hasChildNodes() - Method in class org.dom4j.dom.DOMElement
hasChildNodes() - Method in class org.dom4j.dom.DOMEntityReference
hasChildNodes() - Method in class org.dom4j.dom.DOMNamespace
hasChildNodes(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
hasChildNodes() - Method in class org.dom4j.dom.DOMProcessingInstruction
hasChildNodes() - Method in class org.dom4j.dom.DOMText
hasContent() - Method in interface org.dom4j.Node
hasContent returns true if this node is a Branch (either an Element or a Document) and it contains at least one content node such as a child Element or Text node.
hasContent() - Method in class org.dom4j.tree.AbstractBranch
hasContent() - Method in class org.dom4j.tree.AbstractNode
hasFeature(String, String) - Method in class org.dom4j.dom.DOMDocumentFactory
hasMixedContent() - Method in interface org.dom4j.Element
Returns true if this Element has mixed content.
hasMixedContent() - Method in class org.dom4j.tree.AbstractElement
hasNext() - Method in class org.dom4j.tree.FilterIterator
Deprecated.
hasNext() - Method in class org.dom4j.tree.SingleIterator
hash - Variable in class org.dom4j.tree.ConcurrentReaderHashMap.Entry
hashCode() - Method in class org.dom4j.Namespace
DOCUMENT ME!
hashCode() - Method in class org.dom4j.QName
DOCUMENT ME!
hashCode() - Method in class org.dom4j.rule.Rule
hashCode() - Method in class org.dom4j.tree.ConcurrentReaderHashMap.Entry
hashCode() - Method in class org.dom4j.tree.DefaultNamespace

I

IllegalAddException - exception org.dom4j.IllegalAddException.
IllegalAddException is thrown when a node is added incorrectly to an Element
IllegalAddException(String) - Constructor for class org.dom4j.IllegalAddException
IllegalAddException(Element, Node, String) - Constructor for class org.dom4j.IllegalAddException
IllegalAddException(Branch, Node, String) - Constructor for class org.dom4j.IllegalAddException
IndexedDocumentFactory - class org.dom4j.util.IndexedDocumentFactory.
IndexedDocumentFactory is a factory of XML objects which create indexed Element implementations to allow quicker lookup via name of Element and Attributes though at the expense of more memory used to create the name indexes.
IndexedDocumentFactory() - Constructor for class org.dom4j.util.IndexedDocumentFactory
IndexedElement - class org.dom4j.util.IndexedElement.
IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
IndexedElement(String) - Constructor for class org.dom4j.util.IndexedElement
IndexedElement(QName) - Constructor for class org.dom4j.util.IndexedElement
IndexedElement(QName, int) - Constructor for class org.dom4j.util.IndexedElement
InternalEntityDecl - class org.dom4j.dtd.InternalEntityDecl.
InternalEntityDecl represents an internal entity declaration in a DTD.
InternalEntityDecl() - Constructor for class org.dom4j.dtd.InternalEntityDecl
InternalEntityDecl(String, String) - Constructor for class org.dom4j.dtd.InternalEntityDecl
InvalidSchemaException - exception org.dom4j.datatype.InvalidSchemaException.
InvalidSchemaException is thrown when an invalid XML Schema document is used
InvalidSchemaException(String) - Constructor for class org.dom4j.datatype.InvalidSchemaException
InvalidXPathException - exception org.dom4j.InvalidXPathException.
InvalidXPathException is thrown when an invalid XPath expression is used to traverse an XML document
InvalidXPathException(String) - Constructor for class org.dom4j.InvalidXPathException
InvalidXPathException(String, String) - Constructor for class org.dom4j.InvalidXPathException
InvalidXPathException(String, Throwable) - Constructor for class org.dom4j.InvalidXPathException
ignorableWhitespace(char[], int, int) - Method in class org.dom4j.io.XMLWriter
importNode(Node, boolean) - Method in class org.dom4j.dom.DOMDocument
indent() - Method in class org.dom4j.io.XMLWriter
indexOf(Node) - Method in interface org.dom4j.Branch
Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.
indexOf(Node) - Method in class org.dom4j.tree.AbstractBranch
indexOf(Node) - Method in class org.dom4j.tree.AbstractElement
indexOf(Object) - Method in class org.dom4j.tree.ContentListFacade
indexOf(Node) - Method in class org.dom4j.tree.DefaultElement
init() - Method in class org.dom4j.DocumentFactory
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMAttribute
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMCDATA
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMComment
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMDocument
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMDocumentType
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMElement
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMEntityReference
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMNamespace
insertBefore(Node, Node, Node) - Static method in class org.dom4j.dom.DOMNodeHelper
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMProcessingInstruction
insertBefore(Node, Node) - Method in class org.dom4j.dom.DOMText
insertData(int, String) - Method in class org.dom4j.dom.DOMCDATA
insertData(int, String) - Method in class org.dom4j.dom.DOMComment
insertData(CharacterData, int, String) - Static method in class org.dom4j.dom.DOMNodeHelper
insertData(int, String) - Method in class org.dom4j.dom.DOMText
installLexicalHandler() - Method in class org.dom4j.io.XMLWriter
installXMLFilter(XMLReader) - Method in class org.dom4j.io.SAXReader
Installs any XMLFilter objects required to allow the SAX event stream to be filtered and preprocessed before it gets to dom4j.
instance() - Method in class org.dom4j.util.PerThreadSingleton
instance() - Method in class org.dom4j.util.SimpleSingleton
instance() - Method in interface org.dom4j.util.SingletonStrategy
return a singleton instance of the class specified in setSingletonClass
intern(QName) - Method in class org.dom4j.DocumentFactory
DOCUMENT ME!
intern(QName) - Method in class org.dom4j.tree.QNameCache
DOCUMENT ME!
internalEntityDecl(String, String) - Method in class org.dom4j.io.SAXContentHandler
Report an internal entity declaration.
internalEntityDecl(String, String) - Method in class org.dom4j.io.SAXEventRecorder
invalidNodeTypeAddException(Node) - Method in class org.dom4j.tree.AbstractBranch
Called when an invalid node has been added.
isAttributeNamespaceDeclaration(int) - Method in class org.dom4j.xpp.ProxyXmlStartTag
isDeclareNamespaceAttributes() - Method in class org.dom4j.io.SAXWriter
Should namespace declarations be converted to "xmlns" attributes.
isElementSpacePreserved(Element) - Method in class org.dom4j.io.XMLWriter
Determines if element is a special case of XML elements where it contains an xml:space attribute of "preserve".
isEmpty() - Method in class org.dom4j.tree.ContentListFacade
isEscapeText() - Method in class org.dom4j.io.XMLWriter
DOCUMENT ME!
isExpandEmptyElements() - Method in class org.dom4j.io.OutputFormat
isExpandEmptyElements() - Method in class org.dom4j.io.XMLWriter
isIgnorableEntity(String) - Method in class org.dom4j.io.SAXContentHandler
a Strategy Method to determine if a given entity name is ignorable
isIgnoreComments() - Method in class org.dom4j.io.SAXContentHandler
Returns whether we should ignore comments or not.
isIgnoreComments() - Method in class org.dom4j.io.SAXReader
Returns whether we should ignore comments or not.
isIgnoreableNamespace(Namespace, NamespaceStack) - Method in class org.dom4j.io.SAXWriter
DOCUMENT ME!
isIncludeExternalDTDDeclarations() - Method in class org.dom4j.io.SAXContentHandler
DOCUMENT ME!
isIncludeExternalDTDDeclarations() - Method in class org.dom4j.io.SAXReader
DOCUMENT ME!
isIncludeInternalDTDDeclarations() - Method in class org.dom4j.io.SAXContentHandler
DOCUMENT ME!
isIncludeInternalDTDDeclarations() - Method in class org.dom4j.io.SAXReader
DOCUMENT ME!
isLeaf() - Method in class org.dom4j.swing.BranchTreeNode
isLeaf() - Method in class org.dom4j.swing.LeafTreeNode
isMergeAdjacentText() - Method in class org.dom4j.io.SAXContentHandler
Returns whether adjacent text nodes should be merged together.
isMergeAdjacentText() - Method in class org.dom4j.io.SAXReader
Returns whether adjacent text nodes should be merged together.
isNamespaceDeclaration(Namespace) - Method in class org.dom4j.io.DOMWriter
isNamespaceDeclaration(Namespace) - Method in class org.dom4j.io.XMLWriter
isNewLineAfterDeclaration() - Method in class org.dom4j.io.OutputFormat
DOCUMENT ME!
isNewlines() - Method in class org.dom4j.io.OutputFormat
isNotation(String) - Method in class org.dom4j.datatype.DatatypeAttribute
isNotation(String) - Method in class org.dom4j.datatype.DatatypeElement
isOmitEncoding() - Method in class org.dom4j.io.OutputFormat
isPadText() - Method in class org.dom4j.io.OutputFormat
isPreformattedTag(String) - Method in class org.dom4j.io.HTMLWriter
DOCUMENT ME!
isPruneElements() - Method in class org.dom4j.io.SAXModifier
Returns true when xml elements are not kept in memory while parsing.
isPruneElements() - Method in class org.dom4j.jaxb.JAXBModifier
Returns true when the modified Documentis not kept in memory.
isPruneElements() - Method in class org.dom4j.jaxb.JAXBReader
When 'true', the DOM4J document will not be kept in memory while parsing.
isReadOnly() - Method in interface org.dom4j.Node
isReadOnly returns true if this node is read only and cannot be modified.
isReadOnly() - Method in class org.dom4j.datatype.DatatypeAttribute
isReadOnly() - Method in class org.dom4j.tree.AbstractBranch
isReadOnly() - Method in class org.dom4j.tree.AbstractNode
isReadOnly() - Method in class org.dom4j.tree.DefaultAttribute
isReadOnly() - Method in class org.dom4j.tree.DefaultCDATA
isReadOnly() - Method in class org.dom4j.tree.DefaultComment
isReadOnly() - Method in class org.dom4j.tree.DefaultEntity
isReadOnly() - Method in class org.dom4j.tree.DefaultNamespace
isReadOnly() - Method in class org.dom4j.tree.DefaultProcessingInstruction
isReadOnly() - Method in class org.dom4j.tree.DefaultText
isRootElement() - Method in interface org.dom4j.Element
DOCUMENT ME!
isRootElement() - Method in class org.dom4j.tree.AbstractElement
isStringInternEnabled() - Method in class org.dom4j.io.SAXReader
Sets whether String interning is enabled or disabled for element & attribute names and namespace URIs.
isStripWhitespaceText() - Method in class org.dom4j.io.SAXContentHandler
Sets whether whitespace between element start and end tags should be ignored
isStripWhitespaceText() - Method in class org.dom4j.io.SAXReader
Sets whether whitespace between element start and end tags should be ignored
isSupported(String, String) - Method in class org.dom4j.dom.DOMAttribute
isSupported(String, String) - Method in class org.dom4j.dom.DOMCDATA
isSupported(String, String) - Method in class org.dom4j.dom.DOMComment
isSupported(String, String) - Method in class org.dom4j.dom.DOMDocument
isSupported(String, String) - Method in class org.dom4j.dom.DOMDocumentType
isSupported(String, String) - Method in class org.dom4j.dom.DOMElement
isSupported(String, String) - Method in class org.dom4j.dom.DOMEntityReference
isSupported(String, String) - Method in class org.dom4j.dom.DOMNamespace
isSupported(Node, String, String) - Static method in class org.dom4j.dom.DOMNodeHelper
isSupported(String, String) - Method in class org.dom4j.dom.DOMProcessingInstruction
isSupported(String, String) - Method in class org.dom4j.dom.DOMText
isSuppressDeclaration() - Method in class org.dom4j.io.OutputFormat
DOCUMENT ME!
isTextOnly() - Method in interface org.dom4j.Element
Returns true if this Element has text only content.
isTextOnly() - Method in class org.dom4j.tree.AbstractElement
isTrimText() - Method in class org.dom4j.io.OutputFormat
isUnparsedEntity(String) - Method in class org.dom4j.datatype.DatatypeAttribute
isUnparsedEntity(String) - Method in class org.dom4j.datatype.DatatypeElement
isValidating() - Method in class org.dom4j.io.SAXReader
DOCUMENT ME!
isXHTML() - Method in class org.dom4j.io.OutputFormat
Whether or not to use the XHTML standard: like HTML but passes an XML parser with real, closed tags.
item(int) - Method in class org.dom4j.dom.DOMAttributeNodeMap
item(int) - Method in class org.dom4j.dom.DOMNodeHelper.EmptyNodeList

J

JAXBModifier - class org.dom4j.jaxb.JAXBModifier.
Reads an XML document using SAX and writes its content to the provided XMLWriter.
JAXBModifier(String) - Constructor for class org.dom4j.jaxb.JAXBModifier
Creates a new JAXBModifier for the given JAXB context path.
JAXBModifier(String, ClassLoader) - Constructor for class org.dom4j.jaxb.JAXBModifier
Creates a new JAXBModifier for the given JAXB context path, using the given ClassLoader.
JAXBModifier(String, OutputFormat) - Constructor for class org.dom4j.jaxb.JAXBModifier
Creates a new JAXBModifier for the given JAXB context path.
JAXBModifier(String, ClassLoader, OutputFormat) - Constructor for class org.dom4j.jaxb.JAXBModifier
Creates a new JAXBModifier for the given JAXB context path, using the specified Classloader.
JAXBObjectHandler - interface org.dom4j.jaxb.JAXBObjectHandler.
JAXBObjectHandler implementations can be registered with the JAXB Reader in order to receive unmarshalled XML fragments.
JAXBObjectModifier - interface org.dom4j.jaxb.JAXBObjectModifier.
JAXBObjectHandler implementations can be registered with the JAXBModifier in order to change unmarshalled XML fragments.
JAXBReader - class org.dom4j.jaxb.JAXBReader.
Reads an XML document and creates a DOM4J tree from SAX parsing events.
JAXBReader(String) - Constructor for class org.dom4j.jaxb.JAXBReader
Creates a new JAXBReader for the given JAXB context path.
JAXBReader(String, ClassLoader) - Constructor for class org.dom4j.jaxb.JAXBReader
Creates a new JAXBReader for the given JAXB context path, using the specified Classloader.
JAXBWriter - class org.dom4j.jaxb.JAXBWriter.
Writes Elementobjects to an XML stream.
JAXBWriter(String) - Constructor for class org.dom4j.jaxb.JAXBWriter
Creates a new JAXBWriter for the given JAXB context path.
JAXBWriter(String, OutputFormat) - Constructor for class org.dom4j.jaxb.JAXBWriter
Creates a new JAXBWriter for the given JAXB context path.
JAXBWriter(String, ClassLoader) - Constructor for class org.dom4j.jaxb.JAXBWriter
Creates a new JAXBWriter for the given JAXB context path, using the specified Classloader.
JAXBWriter(String, ClassLoader, OutputFormat) - Constructor for class org.dom4j.jaxb.JAXBWriter
Creates a new JAXBWriter for the given JAXB context path, using the specified Classloader.

K

key - Variable in class org.dom4j.tree.ConcurrentReaderHashMap.Entry

L

LEXICAL_HANDLER_NAMES - Static variable in class org.dom4j.io.SAXWriter
LEXICAL_HANDLER_NAMES - Static variable in class org.dom4j.io.XMLWriter
LeafTreeNode - class org.dom4j.swing.LeafTreeNode.
LeafTreeNode implements the Swing TreeNode interface to bind a leaf XML nodes to a Swing TreeModel.
LeafTreeNode() - Constructor for class org.dom4j.swing.LeafTreeNode
LeafTreeNode(Node) - Constructor for class org.dom4j.swing.LeafTreeNode
LeafTreeNode(TreeNode, Node) - Constructor for class org.dom4j.swing.LeafTreeNode
lastIndexOf(Object) - Method in class org.dom4j.tree.ContentListFacade
lastOutputNodeType - Variable in class org.dom4j.io.XMLWriter
Stores the last type of node written so algorithms can refer to the previous node type
load(Document) - Static method in class org.dom4j.swing.XMLTableDefinition
Loads an XML table definition from an XML definition document
load(Element) - Static method in class org.dom4j.swing.XMLTableDefinition
Loads an XML table definition from an XML definition document
loadOmitElementCloseSet(Set) - Method in class org.dom4j.io.HTMLWriter
loadSchema(Document) - Method in class org.dom4j.datatype.DatatypeDocumentFactory
Loads the given XML Schema document into this factory so schema-aware Document, Elements and Attributes will be created by this factory.
loadSchema(Document, Namespace) - Method in class org.dom4j.datatype.DatatypeDocumentFactory
loadSchema(Document, String) - Method in class org.dom4j.datatype.DatatypeDocumentFactory
loadSchema(Document, String, Namespace) - Method in class org.dom4j.datatype.DatatypeDocumentFactory

M

MAX_NODE_TYPE - Static variable in interface org.dom4j.Node
The maximum number of node types for sizing purposes
Mode - class org.dom4j.rule.Mode.
Mode manages a number of RuleSet instances for the mode in a stylesheet.
Mode() - Constructor for class org.dom4j.rule.Mode
makeElement(Branch, String) - Static method in class org.dom4j.DocumentHelper
makeElement a helper method which navigates from the given Document or Element node to some Element using the path expression, creating any necessary elements along the way.
matches(String) - Method in interface org.dom4j.Node
matches returns true if evaluating the given XPath expression on this node returns a non-empty node set containing this node.
matches(Node) - Method in interface org.dom4j.NodeFilter
matches returns true if the given node matches the filter condition.
matches(Node) - Method in interface org.dom4j.XPath
matches returns true if the given node matches the XPath expression.
matches(Node) - Method in interface org.dom4j.rule.Pattern
DOCUMENT ME!
matches(Node) - Method in class org.dom4j.rule.Rule
DOCUMENT ME!
matches(Node) - Method in class org.dom4j.rule.pattern.DefaultPattern
matches(Node) - Method in class org.dom4j.rule.pattern.NodeTypePattern
matches(String) - Method in class org.dom4j.tree.AbstractNode
matches(Object) - Method in class org.dom4j.tree.ElementIterator
Deprecated. DOCUMENT ME!
matches(Object) - Method in class org.dom4j.tree.ElementNameIterator
Deprecated. DOCUMENT ME!
matches(Object) - Method in class org.dom4j.tree.ElementQNameIterator
Deprecated. DOCUMENT ME!
matches(Object) - Method in class org.dom4j.tree.FilterIterator
Deprecated. Filter method to perform some matching on the given element.
matches(Node) - Method in class org.dom4j.xpath.DefaultXPath
matches(Node) - Method in class org.dom4j.xpath.XPathPattern
modify(File) - Method in class org.dom4j.io.SAXModifier
Reads a Document from the given Fileand writes it to the specified XMLWriterusing SAX.
modify(InputSource) - Method in class org.dom4j.io.SAXModifier
Reads a Document from the given InputSourceand writes it to the specified XMLWriterusing SAX.
modify(InputStream) - Method in class org.dom4j.io.SAXModifier
Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX.
modify(InputStream, String) - Method in class org.dom4j.io.SAXModifier
Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX.
modify(Reader) - Method in class org.dom4j.io.SAXModifier
Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX.
modify(Reader, String) - Method in class org.dom4j.io.SAXModifier
Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX.
modify(URL) - Method in class org.dom4j.io.SAXModifier
Reads a Document from the given URLand writes it to the specified XMLWriterusing SAX.
modify(String) - Method in class org.dom4j.io.SAXModifier
Reads a Document from the given URL or filename and writes it to the specified XMLWriterusing SAX.
modify(File) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the specified Filewith SAX
modify(File, Charset) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the specified Filewith SAX, using the given Charset.
modify(InputSource) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the specified InputSourcewith SAX.
modify(InputStream) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the specified InputStreamwith SAX.
modify(InputStream, String) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the specified InputStreamwith SAX.
modify(Reader) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the specified Readerwith SAX.
modify(Reader, String) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the specified Readerwith SAX.
modify(String) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the the given URL or filename.
modify(URL) - Method in class org.dom4j.jaxb.JAXBModifier
Parses the the given URL.
modifyElement(Element) - Method in interface org.dom4j.io.ElementModifier
Called by an event based processor when an elements closing tag is encountered.
modifyObject(Element) - Method in interface org.dom4j.jaxb.JAXBObjectModifier
Called when the JAXBModifierhas finished parsing the xml path the handler was registered for.
modifyTag(String, String, String) - Method in class org.dom4j.xpp.ProxyXmlStartTag

N

NAMESPACE_NODE - Static variable in interface org.dom4j.Node
Matchs a Namespace Node - NOTE this differs from DOM
NODE_TYPE - Static variable in class org.dom4j.swing.XMLTableColumnDefinition
NODE_TYPE_NAMES - Static variable in class org.dom4j.tree.AbstractNode
NONE - Static variable in interface org.dom4j.rule.Pattern
Matches no nodes
NO_NAMESPACE - Static variable in class org.dom4j.Namespace
No Namespace present
NULL_ARGS - Static variable in class org.dom4j.bean.BeanMetaData
Empty arguments for reflection calls
NUMBER_OF_TYPES - Static variable in interface org.dom4j.rule.Pattern
Count of the number of node types
NUMBER_TYPE - Static variable in class org.dom4j.swing.XMLTableColumnDefinition
Namespace - class org.dom4j.Namespace.
Namespace is a Flyweight Namespace that can be shared amongst nodes.
Namespace(String, String) - Constructor for class org.dom4j.Namespace
DOCUMENT ME!
NamespaceCache - class org.dom4j.tree.NamespaceCache.
NamespaceCache caches instances of DefaultNamespace for reuse both across documents and within documents.
NamespaceCache() - Constructor for class org.dom4j.tree.NamespaceCache
NamespaceStack - class org.dom4j.tree.NamespaceStack.
NamespaceStack implements a stack of namespaces and optionally maintains a cache of all the fully qualified names (QName) which are in scope.
NamespaceStack() - Constructor for class org.dom4j.tree.NamespaceStack
NamespaceStack(DocumentFactory) - Constructor for class org.dom4j.tree.NamespaceStack
Node - interface org.dom4j.Node.
Node defines the polymorphic behavior for all XML nodes in a dom4j tree.
NodeComparator - class org.dom4j.util.NodeComparator.
NodeComparator is a Comparatorof Node instances which is capable of comparing Nodes for equality based on their values.
NodeComparator() - Constructor for class org.dom4j.util.NodeComparator
NodeFilter - interface org.dom4j.NodeFilter.
NodeFilter defines the behavior for a filter or predicate which acts on a DOM4J Node.
NodeTypePattern - class org.dom4j.rule.pattern.NodeTypePattern.
NodeTypePattern implements a Pattern which matches any node of the given node type.
NodeTypePattern(short) - Constructor for class org.dom4j.rule.pattern.NodeTypePattern
NonLazyDocumentFactory - class org.dom4j.util.NonLazyDocumentFactory.
NonLazyDocumentFactory is a factory of XML objects which avoid using the lazy creation pattern.
NonLazyDocumentFactory() - Constructor for class org.dom4j.util.NonLazyDocumentFactory
NonLazyElement - class org.dom4j.util.NonLazyElement.
NonLazyElement is the default DOM4J default implementation of an XML element.
NonLazyElement(String) - Constructor for class org.dom4j.util.NonLazyElement
NonLazyElement(QName) - Constructor for class org.dom4j.util.NonLazyElement
NonLazyElement(String, Namespace) - Constructor for class org.dom4j.util.NonLazyElement
NonLazyElement(QName, int) - Constructor for class org.dom4j.util.NonLazyElement
NullAction - class org.dom4j.rule.NullAction.
NullAction represents an empty action that does nothing.
NullAction() - Constructor for class org.dom4j.rule.NullAction
name - Variable in class org.dom4j.tree.FlyweightEntity
The name of the Entity
namespaceCache - Variable in class org.dom4j.tree.QNameCache
Cache of Mapinstances indexed by namespace which contain caches of QNamefor each name
next - Variable in class org.dom4j.tree.ConcurrentReaderHashMap.Entry
next() - Method in class org.dom4j.tree.FilterIterator
Deprecated.
next() - Method in class org.dom4j.tree.SingleIterator
noNamespaceCache - Variable in class org.dom4j.tree.QNameCache
Cache of QNameinstances with no namespace
noPrefixCache - Static variable in class org.dom4j.tree.NamespaceCache
Cache of Namespaceinstances indexed by URI for default namespaces with no prefixes
node(int) - Method in interface org.dom4j.Branch
Returns the Node at the specified index position.
node(int) - Method in class org.dom4j.tree.AbstractBranch
node(int) - Method in class org.dom4j.tree.AbstractElement
node(int) - Method in class org.dom4j.tree.DefaultElement
nodeCount() - Method in interface org.dom4j.Branch
Returns the number of Node instances that this branch contains.
nodeCount() - Method in class org.dom4j.tree.AbstractBranch
nodeCount() - Method in class org.dom4j.tree.AbstractElement
nodeCount() - Method in class org.dom4j.tree.DefaultElement
nodeIterator() - Method in interface org.dom4j.Branch
Returns an iterator through the content nodes of this branch
nodeIterator() - Method in class org.dom4j.tree.AbstractBranch
nodeIterator() - Method in class org.dom4j.tree.AbstractElement
nodeIterator() - Method in class org.dom4j.tree.DefaultElement
normalize() - Method in interface org.dom4j.Branch
Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
normalize() - Method in class org.dom4j.dom.DOMAttribute
normalize() - Method in class org.dom4j.dom.DOMCDATA
normalize() - Method in class org.dom4j.dom.DOMComment
normalize() - Method in class org.dom4j.dom.DOMDocumentType
normalize() - Method in class org.dom4j.dom.DOMEntityReference
normalize() - Method in class org.dom4j.dom.DOMNamespace
normalize(Node) - Static method in class org.dom4j.dom.DOMNodeHelper
normalize() - Method in class org.dom4j.dom.DOMProcessingInstruction
normalize() - Method in class org.dom4j.dom.DOMText
normalize() - Method in class org.dom4j.tree.AbstractDocument
normalize() - Method in class org.dom4j.tree.AbstractElement
Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
notSupported() - Static method in class org.dom4j.dom.DOMNodeHelper
Called when a method has not been implemented yet
notationDecl(String, String, String) - Method in class org.dom4j.io.SAXContentHandler
Receive notification of a notation declaration event.
notationDecl(String, String, String) - Method in class org.dom4j.io.XMLWriter
numberValueOf(String) - Method in interface org.dom4j.Node
numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results in a number, or null if the result is not a number.
numberValueOf(Object) - Method in interface org.dom4j.XPath
numberValueOf evaluates an XPath expression and returns the numeric value of the XPath expression if the XPath expression results is a number, or null if the result is not a number.
numberValueOf(String) - Method in class org.dom4j.tree.AbstractNode
numberValueOf(Object) - Method in class org.dom4j.xpath.DefaultXPath

O

OBJECT_TYPE - Static variable in class org.dom4j.swing.XMLTableColumnDefinition
OutputFormat - class org.dom4j.io.OutputFormat.
OutputFormat represents the format configuration used by and its base classes to format the XML output
OutputFormat() - Constructor for class org.dom4j.io.OutputFormat
Creates an OutputFormat with no additional whitespace (indent or new lines) added.
OutputFormat(String) - Constructor for class org.dom4j.io.OutputFormat
Creates an OutputFormat with the given indent added but no new lines added.
OutputFormat(String, boolean) - Constructor for class org.dom4j.io.OutputFormat
Creates an OutputFormat with the given indent added with optional newlines between the Elements.
OutputFormat(String, boolean, String) - Constructor for class org.dom4j.io.OutputFormat
Creates an OutputFormat with the given indent added with optional newlines between the Elements and the given encoding format.
omitElementClose(String) - Method in class org.dom4j.io.HTMLWriter
onEnd(ElementPath) - Method in interface org.dom4j.ElementHandler
Called by an event based processor when an elements closing tag is encountered.
onStart(ElementPath) - Method in interface org.dom4j.ElementHandler
Called by an event based processor when an elements openning tag is encountered.
org.dom4j - package org.dom4j
Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean - package org.dom4j.bean
An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype - package org.dom4j.datatype
An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom - package org.dom4j.dom
An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.dtd - package org.dom4j.dtd
Classes to represent the DTD declarations.
org.dom4j.io - package org.dom4j.io
Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.jaxb - package org.dom4j.jaxb
org.dom4j.rule - package org.dom4j.rule
A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.rule.pattern - package org.dom4j.rule.pattern
org.dom4j.swing - package org.dom4j.swing
A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.
org.dom4j.tree - package org.dom4j.tree
Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util - package org.dom4j.util
A collection of utility classes for the dom4j API.
org.dom4j.xpath - package org.dom4j.xpath
Provides the core tools needed to use the XPath library
org.dom4j.xpp - package org.dom4j.xpp
Provides implementation classes to cleanly integrate dom4j with the XML Pull Parser XPP

P

PROCESSING_INSTRUCTION_NODE - Static variable in interface org.dom4j.Node
Matches ProcessingInstruction
Pattern - interface org.dom4j.rule.Pattern.
Pattern defines the behaviour for pattern in the XSLT processing model.
PerThreadSingleton - class org.dom4j.util.PerThreadSingleton.
PerThreadSingleton is an implementation of the SingletonStrategy used to provide common factory access to a single object instance based on an implementation strategy for one object instance per thread.
PerThreadSingleton() - Constructor for class org.dom4j.util.PerThreadSingleton
ProcessingInstruction - interface org.dom4j.ProcessingInstruction.
ProcessingInstruction defines an XML processing instruction.
ProxyDocumentFactory - class org.dom4j.util.ProxyDocumentFactory.
ProxyDocumentFactory implements a proxy to a DocumentFactory which is useful for implementation inheritence, allowing the pipelining of various factory implementations.
ProxyDocumentFactory() - Constructor for class org.dom4j.util.ProxyDocumentFactory
ProxyDocumentFactory(DocumentFactory) - Constructor for class org.dom4j.util.ProxyDocumentFactory
ProxyXmlStartTag - class org.dom4j.xpp.ProxyXmlStartTag.
ProxyXmlStartTag implements the XPP XmlSmartTag interface while creating a dom4j Element underneath.
ProxyXmlStartTag() - Constructor for class org.dom4j.xpp.ProxyXmlStartTag
ProxyXmlStartTag(Element) - Constructor for class org.dom4j.xpp.ProxyXmlStartTag
parse(String) - Method in class org.dom4j.io.SAXWriter
This method is not supported.
parse(InputSource) - Method in class org.dom4j.io.SAXWriter
Parses an XML document.
parse(InputSource) - Method in class org.dom4j.io.XMLWriter
parse(String) - Static method in class org.dom4j.xpath.DefaultXPath
parseDocument() - Method in class org.dom4j.io.XPP3Reader
parseDocument() - Method in class org.dom4j.io.XPPReader
parseOptions(String[], int) - Method in class org.dom4j.io.OutputFormat
Parses command line arguments of the form -omitEncoding -indentSize 3 -newlines -trimText
parseText(String) - Static method in class org.dom4j.DocumentHelper
parseText parses the given text as an XML document and returns the newly created Document.
parseType(String) - Static method in class org.dom4j.swing.XMLTableColumnDefinition
parseValues(String) - Method in class org.dom4j.tree.AbstractProcessingInstruction
Parses the raw data of PI as a Map.
pop() - Method in class org.dom4j.tree.NamespaceStack
Pops the most recently used Namespace from the stack
pop(String) - Method in class org.dom4j.tree.NamespaceStack
Pops a namepace from the stack with the given prefix and URI
preserve - Variable in class org.dom4j.io.XMLWriter
Stores the xml:space attribute value of preserve for whitespace flag
prettyPrintHTML(String) - Static method in class org.dom4j.io.HTMLWriter
Convenience method to just get a String result.
prettyPrintHTML(String, boolean, boolean, boolean, boolean) - Static method in class org.dom4j.io.HTMLWriter
DOCUMENT ME!
prettyPrintXHTML(String) - Static method in class org.dom4j.io.HTMLWriter
Convenience method to just get a String result, but As XHTML .
printStackTrace() - Method in class org.dom4j.DocumentException
printStackTrace(PrintStream) - Method in class org.dom4j.DocumentException
printStackTrace(PrintWriter) - Method in class org.dom4j.DocumentException
println() - Method in class org.dom4j.io.XMLWriter
Writes the new line text to the underlying Writer
processingInstruction(String) - Method in interface org.dom4j.Branch
DOCUMENT ME!
processingInstruction(String, String) - Method in class org.dom4j.io.SAXContentHandler
processingInstruction(String, String) - Method in class org.dom4j.io.SAXEventRecorder
processingInstruction(String, String) - Method in class org.dom4j.io.XMLWriter
processingInstruction(String) - Method in class org.dom4j.tree.AbstractElement
processingInstruction(String) - Method in class org.dom4j.tree.DefaultDocument
processingInstruction(String) - Method in class org.dom4j.tree.DefaultElement
processingInstructions() - Method in interface org.dom4j.Branch
Returns a list of all the processing instructions in this branch.
processingInstructions(String) - Method in interface org.dom4j.Branch
Returns a list of the processing instructions for the given target.
processingInstructions() - Method in class org.dom4j.tree.AbstractElement
processingInstructions(String) - Method in class org.dom4j.tree.AbstractElement
processingInstructions() - Method in class org.dom4j.tree.DefaultDocument
processingInstructions(String) - Method in class org.dom4j.tree.DefaultDocument
processingInstructions() - Method in class org.dom4j.tree.DefaultElement
processingInstructions(String) - Method in class org.dom4j.tree.DefaultElement
proxy - Variable in class org.dom4j.tree.FilterIterator
Deprecated.
push(Namespace) - Method in class org.dom4j.tree.NamespaceStack
Pushes the given namespace onto the stack so that its prefix becomes available.
push(String, String) - Method in class org.dom4j.tree.NamespaceStack
Adds a namepace to the stack with the given prefix and URI
pushQName(String, String, Namespace, String) - Method in class org.dom4j.tree.NamespaceStack
Adds the QName to the stack of available QNames

Q

QName - class org.dom4j.QName.
QName represents a qualified name value of an XML element or attribute.
QName(String) - Constructor for class org.dom4j.QName
QName(String, Namespace) - Constructor for class org.dom4j.QName
QName(String, Namespace, String) - Constructor for class org.dom4j.QName
QNameCache - class org.dom4j.tree.QNameCache.
QNameCache caches instances of QName for reuse both across documents and within documents.
QNameCache() - Constructor for class org.dom4j.tree.QNameCache
QNameCache(DocumentFactory) - Constructor for class org.dom4j.tree.QNameCache

R

Rule - class org.dom4j.rule.Rule.
Rule matches against DOM4J Node so that some action can be performed such as in the XSLT processing model.
Rule() - Constructor for class org.dom4j.rule.Rule
Rule(Pattern) - Constructor for class org.dom4j.rule.Rule
Rule(Pattern, Action) - Constructor for class org.dom4j.rule.Rule
Rule(Rule, Pattern) - Constructor for class org.dom4j.rule.Rule
Constructs a new Rule with the same instance data as the given rule but a different pattern.
RuleManager - class org.dom4j.rule.RuleManager.
RuleManager manages a set of rules such that a rule can be found for a given DOM4J Node using the XSLT processing model.
RuleManager() - Constructor for class org.dom4j.rule.RuleManager
RuleSet - class org.dom4j.rule.RuleSet.
RuleSet manages a set of rules which are sorted in order of relevance according to the XSLT defined conflict resolution policy.
RuleSet() - Constructor for class org.dom4j.rule.RuleSet
read(Document) - Method in class org.dom4j.io.DOMReader
read(File) - Method in class org.dom4j.io.SAXReader
Reads a Document from the given File
read(URL) - Method in class org.dom4j.io.SAXReader
Reads a Document from the given URL using SAX
read(String) - Method in class org.dom4j.io.SAXReader
Reads a Document from the given URL or filename using SAX.
read(InputStream) - Method in class org.dom4j.io.SAXReader
Reads a Document from the given stream using SAX
read(Reader) - Method in class org.dom4j.io.SAXReader
Reads a Document from the given Reader using SAX
read(InputStream, String) - Method in class org.dom4j.io.SAXReader
Reads a Document from the given stream using SAX
read(Reader, String) - Method in class org.dom4j.io.SAXReader
Reads a Document from the given Reader using SAX
read(InputSource) - Method in class org.dom4j.io.SAXReader
Reads a Document from the given InputSource using SAX
read(File) - Method in class org.dom4j.io.XPP3Reader
Reads a Document from the given File
read(URL) - Method in class org.dom4j.io.XPP3Reader
Reads a Document from the given URL
read(String) - Method in class org.dom4j.io.XPP3Reader
Reads a Document from the given URL or filename.
read(InputStream) - Method in class org.dom4j.io.XPP3Reader
Reads a Document from the given stream
read(Reader) - Method in class org.dom4j.io.XPP3Reader
Reads a Document from the given Reader
read(char[]) - Method in class org.dom4j.io.XPP3Reader
Reads a Document from the given array of characters
read(InputStream, String) - Method in class org.dom4j.io.XPP3Reader
Reads a Document from the given stream
read(Reader, String) - Method in class org.dom4j.io.XPP3Reader
Reads a Document from the given Reader
read(File) - Method in class org.dom4j.io.XPPReader
Reads a Document from the given File
read(URL) - Method in class org.dom4j.io.XPPReader
Reads a Document from the given URL
read(String) - Method in class org.dom4j.io.XPPReader
Reads a Document from the given URL or filename.
read(InputStream) - Method in class org.dom4j.io.XPPReader
Reads a Document from the given stream
read(Reader) - Method in class org.dom4j.io.XPPReader
Reads a Document from the given Reader
read(char[]) - Method in class org.dom4j.io.XPPReader
Reads a Document from the given array of characters
read(InputStream, String) - Method in class org.dom4j.io.XPPReader
Reads a Document from the given stream
read(Reader, String) - Method in class org.dom4j.io.XPPReader
Reads a Document from the given Reader
read(File) - Method in class org.dom4j.jaxb.JAXBReader
Parses the specified File
read(File, Charset) - Method in class org.dom4j.jaxb.JAXBReader
Parses the specified File, using the given Charset.
read(InputSource) - Method in class org.dom4j.jaxb.JAXBReader
Parses the specified InputSource
read(InputStream) - Method in class org.dom4j.jaxb.JAXBReader
Parses the specified InputStream
read(InputStream, String) - Method in class org.dom4j.jaxb.JAXBReader
Parses the specified InputStream
read(Reader) - Method in class org.dom4j.jaxb.JAXBReader
Parses the specified Reader
read(Reader, String) - Method in class org.dom4j.jaxb.JAXBReader
Parses the specified Reader
read(String) - Method in class org.dom4j.jaxb.JAXBReader
Parses the the given URL or filename.
read(URL) - Method in class org.dom4j.jaxb.JAXBReader
Parses the the given URL.
readAttribute(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Constructs a DOM4J Attribute from the provided event stream.
readCharacters(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Constructs a DOM4J Text or CDATA section from the provided event stream.
readComment(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Constructs a DOM4J Comment from the provided event stream.
readDocument(InputStream) - Method in class org.dom4j.io.STAXEventReader
Constructs a StAX event stream from the provided I/O stream and reads a DOM4J document from it.
readDocument(Reader) - Method in class org.dom4j.io.STAXEventReader
Constructs a StAX event stream from the provided I/O character stream and reads a DOM4J document from it.
readDocument(InputStream, String) - Method in class org.dom4j.io.STAXEventReader
Constructs a StAX event stream from the provided I/O stream and reads a DOM4J document from it.
readDocument(Reader, String) - Method in class org.dom4j.io.STAXEventReader
Constructs a StAX event stream from the provided I/O character stream and reads a DOM4J document from it.
readDocument(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Reads a DOM4J Documentfrom the provided stream.
readElement(Node, Branch) - Method in class org.dom4j.io.DOMReader
readElement(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Reads a DOM4J Element from the provided event stream.
readEntityReference(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Constructs a DOM4J Entity from the provided event stream.
readExternal(ObjectInput) - Method in class org.dom4j.io.SAXEventRecorder
readNamespace(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Constructs a DOM4J Namespace from the provided event stream.
readNode(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Reads a Nodefrom the event stream.
readProcessingInstruction(XMLEventReader) - Method in class org.dom4j.io.STAXEventReader
Constructs a DOM4J ProcessingInstruction from the provided event stream.
readTree(Node, Branch) - Method in class org.dom4j.io.DOMReader
remove(Node) - Method in interface org.dom4j.Branch
Removes the given Node if the node is an immediate child of this branch.
remove(Comment) - Method in interface org.dom4j.Branch
Removes the given Comment if the node is an immediate child of this branch.
remove(Element) - Method in interface org.dom4j.Branch
Removes the given Element if the node is an immediate child of this branch.
remove(ProcessingInstruction) - Method in interface org.dom4j.Branch
Removes the given ProcessingInstruction if the node is an immediate child of this branch.
remove(Attribute) - Method in interface org.dom4j.Element
Removes the given Attribute from this element.
remove(CDATA) - Method in interface org.dom4j.Element
Removes the given CDATA if the node is an immediate child of this element.
remove(Entity) - Method in interface org.dom4j.Element
Removes the given Entity if the node is an immediate child of this element.
remove(Namespace) - Method in interface org.dom4j.Element
Removes the given Namespace if the node is an immediate child of this element.
remove(Text) - Method in interface org.dom4j.Element
Removes the given Text if the node is an immediate child of this element.
remove(Object) - Method in class org.dom4j.bean.BeanAttributeList
remove(int) - Method in class org.dom4j.bean.BeanAttributeList
remove(Node) - Method in class org.dom4j.tree.AbstractBranch
remove(Comment) - Method in class org.dom4j.tree.AbstractBranch
remove(Element) - Method in class org.dom4j.tree.AbstractBranch
remove(ProcessingInstruction) - Method in class org.dom4j.tree.AbstractBranch
remove(Element) - Method in class org.dom4j.tree.AbstractDocument
remove(Attribute) - Method in class org.dom4j.tree.AbstractElement
remove(Node) - Method in class org.dom4j.tree.AbstractElement
remove(CDATA) - Method in class org.dom4j.tree.AbstractElement
remove(Comment) - Method in class org.dom4j.tree.AbstractElement
remove(Element) - Method in class org.dom4j.tree.AbstractElement
remove(Entity) - Method in class org.dom4j.tree.AbstractElement
remove(Namespace) - Method in class org.dom4j.tree.AbstractElement
remove(ProcessingInstruction) - Method in class org.dom4j.tree.AbstractElement
remove(Text) - Method in class org.dom4j.tree.AbstractElement
remove(Object) - Method in class org.dom4j.tree.BackedList
remove(int) - Method in class org.dom4j.tree.BackedList
remove(Object) - Method in class org.dom4j.tree.ContentListFacade
remove(int) - Method in class org.dom4j.tree.ContentListFacade
remove(Attribute) - Method in class org.dom4j.tree.DefaultElement
remove() - Method in class org.dom4j.tree.FilterIterator
Deprecated. Always throws UnsupportedOperationException as this class does look-ahead with its internal iterator.
remove(int) - Method in class org.dom4j.tree.NamespaceStack
Removes the namespace at the given index of the stack
remove() - Method in class org.dom4j.tree.SingleIterator
removeAll(Collection) - Method in class org.dom4j.tree.ContentListFacade
removeAttribute(String) - Method in class org.dom4j.dom.DOMElement
removeAttributeByName(String, String) - Method in class org.dom4j.xpp.ProxyXmlStartTag
removeAttributeByRawName(String) - Method in class org.dom4j.xpp.ProxyXmlStartTag
removeAttributeNS(String, String) - Method in class org.dom4j.dom.DOMElement
removeAttributeNode(Attr) - Method in class org.dom4j.dom.DOMElement
removeAttributes() - Method in class org.dom4j.xpp.ProxyXmlStartTag
removeAtttributes() - Method in class org.dom4j.xpp.ProxyXmlStartTag
Deprecated. Use removeAttributes() instead.
removeChild(Node) - Method in class org.dom4j.dom.DOMAttribute
removeChild(Node) - Method in class org.dom4j.dom.DOMCDATA
removeChild(Node) - Method in class org.dom4j.dom.DOMComment
removeChild(Node) - Method in class org.dom4j.dom.DOMDocument
removeChild(Node) - Method in class org.dom4j.dom.DOMDocumentType
removeChild(Node) - Method in class org.dom4j.dom.DOMElement
removeChild(Node) - Method in class org.dom4j.dom.DOMEntityReference
removeChild(Node) - Method in class org.dom4j.dom.DOMNamespace
removeChild(Node, Node) - Static method in class org.dom4j.dom.DOMNodeHelper
removeChild(Node) - Method in class org.dom4j.dom.DOMProcessingInstruction
removeChild(Node) - Method in class org.dom4j.dom.DOMText
removeColumn(XMLTableColumnDefinition) - Method in class org.dom4j.swing.XMLTableDefinition
removeDuplicates(List, Map) - Method in class org.dom4j.xpath.DefaultXPath
Removes items from the list which have duplicate values
removeFromAttributeIndex(Attribute) - Method in class org.dom4j.util.IndexedElement
removeFromAttributeIndex(Object, Attribute) - Method in class org.dom4j.util.IndexedElement
removeFromElementIndex(Element) - Method in class org.dom4j.util.IndexedElement
removeFromElementIndex(Object, Element) - Method in class org.dom4j.util.IndexedElement
removeFromNameMap(Map, String, Rule) - Method in class org.dom4j.rule.Mode
removeHandler(String) - Method in interface org.dom4j.ElementPath
Removes the ElementHandler from the event based processor, for the specified path.
removeHandler(String) - Method in class org.dom4j.io.SAXReader
Removes the ElementHandler from the event based processor, for the specified path.
removeHandler(String) - Method in class org.dom4j.io.XPP3Reader
Removes the ElementHandler from the event based processor, for the specified path.
removeHandler(String) - Method in class org.dom4j.io.XPPReader
Removes the ElementHandler from the event based processor, for the specified path.
removeHandler(String) - Method in class org.dom4j.jaxb.JAXBReader
Removes the ElementHandler from the event based processor, for the specified path.
removeModifier(String) - Method in class org.dom4j.io.SAXModifier
Removes the ElementModifierfrom the event based processor, for the specified element path.
removeNamedItem(String) - Method in class org.dom4j.dom.DOMAttributeNodeMap
removeNamedItemNS(String, String) - Method in class org.dom4j.dom.DOMAttributeNodeMap
removeNode(Node) - Method in class org.dom4j.tree.AbstractBranch
removeNode(Node) - Method in class org.dom4j.tree.AbstractElement
removeNode(Node) - Method in class org.dom4j.tree.DefaultDocument
removeNode(Node) - Method in class org.dom4j.tree.DefaultElement
removeNode(Node) - Method in class org.dom4j.util.IndexedElement
removeObjectHandler(String) - Method in class org.dom4j.jaxb.JAXBReader
Removes the JAXBObjectHandlerfrom the event based processor, for the specified element path.
removeObjectModifier(String) - Method in class org.dom4j.jaxb.JAXBModifier
Removes the JAXBObjectModifierfrom the event based processor, for the specified element path.
removeProcessingInstruction(String) - Method in interface org.dom4j.Branch
Removes the processing instruction for the given target if it exists
removeProcessingInstruction(String) - Method in class org.dom4j.tree.AbstractElement
removeProcessingInstruction(String) - Method in class org.dom4j.tree.DefaultDocument
removeProcessingInstruction(String) - Method in class org.dom4j.tree.DefaultElement
removeRule(Rule) - Method in class org.dom4j.rule.Mode
removeRule(Rule) - Method in class org.dom4j.rule.RuleManager
removeRule(Rule) - Method in class org.dom4j.rule.RuleSet
removeRule(Rule) - Method in class org.dom4j.rule.Stylesheet
Removes the specified rule from this stylesheet.
removeValue(String) - Method in interface org.dom4j.ProcessingInstruction
removeValue(String) - Method in class org.dom4j.tree.AbstractProcessingInstruction
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMAttribute
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMCDATA
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMComment
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMDocument
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMDocumentType
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMElement
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMEntityReference
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMNamespace
replaceChild(Node, Node, Node) - Static method in class org.dom4j.dom.DOMNodeHelper
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMProcessingInstruction
replaceChild(Node, Node) - Method in class org.dom4j.dom.DOMText
replaceData(int, int, String) - Method in class org.dom4j.dom.DOMCDATA
replaceData(int, int, String) - Method in class org.dom4j.dom.DOMComment
replaceData(CharacterData, int, int, String) - Static method in class org.dom4j.dom.DOMNodeHelper
replaceData(int, int, String) - Method in class org.dom4j.dom.DOMText
replay(ContentHandler) - Method in class org.dom4j.io.SAXEventRecorder
reset() - Method in class org.dom4j.util.PerThreadSingleton
reset() - Method in class org.dom4j.util.SimpleSingleton
reset() - Method in interface org.dom4j.util.SingletonStrategy
reset the instance to a new instance for the implemented strategy
resetHandlers() - Method in class org.dom4j.io.SAXReader
This method clears out all the existing handlers and default handler setting things back as if no handler existed.
resetHandlers() - Method in class org.dom4j.jaxb.JAXBReader
Removes all registered JAXBObjectHandlerand ElementHandler instances from the event based processor.
resetModifiers() - Method in class org.dom4j.io.SAXModifier
Removes all registered ElementModifierinstances from the event based processor.
resetNamespaceStack() - Method in class org.dom4j.io.DOMWriter
resetObjectModifiers() - Method in class org.dom4j.jaxb.JAXBModifier
Removes all registered JAXBObjectModifierinstances from the event based processor.
resetStartTag() - Method in class org.dom4j.xpp.ProxyXmlStartTag
resetTag() - Method in class org.dom4j.xpp.ProxyXmlStartTag
resolveEntity(String, String) - Method in class org.dom4j.io.SAXReader.SAXEntityResolver
resolveEntityRefs() - Method in class org.dom4j.io.XMLWriter
resolveNamespacePrefix(String) - Method in class org.dom4j.datatype.DatatypeAttribute
resolveNamespacePrefix(String) - Method in class org.dom4j.datatype.DatatypeElement
rootElementAdded(Element) - Method in class org.dom4j.tree.AbstractDocument
Called to set the root element variable
rootElementAdded(Element) - Method in class org.dom4j.tree.DefaultDocument
run(Node) - Method in interface org.dom4j.rule.Action
run(Node) - Method in class org.dom4j.rule.NullAction
run(Object) - Method in class org.dom4j.rule.Stylesheet
Runs this stylesheet on the given input which should be either a Node or a List of Node objects.
run(Object, String) - Method in class org.dom4j.rule.Stylesheet
run(List) - Method in class org.dom4j.rule.Stylesheet
run(List, String) - Method in class org.dom4j.rule.Stylesheet
run(Node) - Method in class org.dom4j.rule.Stylesheet
run(Node, String) - Method in class org.dom4j.rule.Stylesheet

S

SAXContentHandler - class org.dom4j.io.SAXContentHandler.
SAXContentHandler builds a dom4j tree via SAX events.
SAXContentHandler() - Constructor for class org.dom4j.io.SAXContentHandler
SAXContentHandler(DocumentFactory) - Constructor for class org.dom4j.io.SAXContentHandler
SAXContentHandler(DocumentFactory, ElementHandler) - Constructor for class org.dom4j.io.SAXContentHandler
SAXContentHandler(DocumentFactory, ElementHandler, ElementStack) - Constructor for class org.dom4j.io.SAXContentHandler
SAXEventRecorder - class org.dom4j.io.SAXEventRecorder.
Records SAX events such that they may be "replayed" at a later time.
SAXEventRecorder() - Constructor for class org.dom4j.io.SAXEventRecorder
SAXModifier - class org.dom4j.io.SAXModifier.
The SAXModifier reads, modifies and writes XML documents using SAX.
SAXModifier() - Constructor for class org.dom4j.io.SAXModifier
Creates a new modifier.
SAXModifier(boolean) - Constructor for class org.dom4j.io.SAXModifier
Creates a new modifier.
SAXModifier(XMLReader) - Constructor for class org.dom4j.io.SAXModifier
Creates a new modifier that will the specified XMLReader to parse the source.
SAXModifier(XMLReader, boolean) - Constructor for class org.dom4j.io.SAXModifier
Creates a new modifier that will the specified XMLReader to parse the source.
SAXReader - class org.dom4j.io.SAXReader.
SAXReader creates a DOM4J tree from SAX parsing events.
SAXReader() - Constructor for class org.dom4j.io.SAXReader
SAXReader(boolean) - Constructor for class org.dom4j.io.SAXReader
SAXReader(DocumentFactory) - Constructor for class org.dom4j.io.SAXReader
SAXReader(DocumentFactory, boolean) - Constructor for class org.dom4j.io.SAXReader
SAXReader(XMLReader) - Constructor for class org.dom4j.io.SAXReader
SAXReader(XMLReader, boolean) - Constructor for class org.dom4j.io.SAXReader
SAXReader(String) - Constructor for class org.dom4j.io.SAXReader
SAXReader(String, boolean) - Constructor for class org.dom4j.io.SAXReader
SAXReader.SAXEntityResolver - class org.dom4j.io.SAXReader.SAXEntityResolver.
SAXReader.SAXEntityResolver(String) - Constructor for class org.dom4j.io.SAXReader.SAXEntityResolver
SAXValidator - class org.dom4j.io.SAXValidator.
SAXValidator validates an XML document by writing the document to a text buffer and parsing it with a validating SAX parser.
SAXValidator() - Constructor for class org.dom4j.io.SAXValidator
SAXValidator(XMLReader) - Constructor for class org.dom4j.io.SAXValidator
SAXWriter - class org.dom4j.io.SAXWriter.
SAXWriter writes a DOM4J tree to a SAX ContentHandler.
SAXWriter() - Constructor for class org.dom4j.io.SAXWriter
SAXWriter(ContentHandler) - Constructor for class org.dom4j.io.SAXWriter
SAXWriter(ContentHandler, LexicalHandler) - Constructor for class org.dom4j.io.SAXWriter
SAXWriter(ContentHandler, LexicalHandler, EntityResolver) - Constructor for class org.dom4j.io.SAXWriter
SINGLETON - Static variable in class org.dom4j.rule.NullAction
Singleton instance
STANDARD_INDENT - Static variable in class org.dom4j.io.OutputFormat
standard value to indent by, if we are indenting
STAXEventReader - class org.dom4j.io.STAXEventReader.
Reads a DOM4J Document, as well as other Nodes, from a StAX XMLEventReader.
STAXEventReader() - Constructor for class org.dom4j.io.STAXEventReader
Constructs a default STAXEventReader instance with a default DocumentFactory.
STAXEventReader(DocumentFactory) - Constructor for class org.dom4j.io.STAXEventReader
Constructs a STAXEventReader instance that uses the specified DocumentFactoryto construct DOM4J Nodes.
STAXEventWriter - class org.dom4j.io.STAXEventWriter.
Writes DOM4J Nodes to a StAX event stream.
STAXEventWriter() - Constructor for class org.dom4j.io.STAXEventWriter
STAXEventWriter(File) - Constructor for class org.dom4j.io.STAXEventWriter
Constructs a STAXEventWriter that writes events to the provided file.
STAXEventWriter(Writer) - Constructor for class org.dom4j.io.STAXEventWriter
Constructs a STAXEventWriter that writes events to the provided character stream.
STAXEventWriter(OutputStream) - Constructor for class org.dom4j.io.STAXEventWriter
Constructs a STAXEventWriter that writes events to the provided stream.
STAXEventWriter(XMLEventConsumer) - Constructor for class org.dom4j.io.STAXEventWriter
Constructs a STAXEventWriter that writes events to the provided event stream.
STRING_TYPE - Static variable in class org.dom4j.swing.XMLTableColumnDefinition
SchemaParser - class org.dom4j.datatype.SchemaParser.
SchemaParser reads an XML Schema Document.
SchemaParser() - Constructor for class org.dom4j.datatype.SchemaParser
SchemaParser(DatatypeDocumentFactory) - Constructor for class org.dom4j.datatype.SchemaParser
SimpleSingleton - class org.dom4j.util.SimpleSingleton.
SimpleSingleton is an implementation of the SingletonStrategy interface used to provide common factory access for the same object instance.
SimpleSingleton() - Constructor for class org.dom4j.util.SimpleSingleton
SingleIterator - class org.dom4j.tree.SingleIterator.
SingleIterator is an Iteratorover a single object instance.
SingleIterator(Object) - Constructor for class org.dom4j.tree.SingleIterator
SingletonStrategy - interface org.dom4j.util.SingletonStrategy.
SingletonStrategy is an interface used to provide common factory access for the same object based on an implementation strategy for singleton.
Stylesheet - class org.dom4j.rule.Stylesheet.
Stylesheet implements an XSLT stylesheet such that rules can be added to the stylesheet and the stylesheet can be applied to a source document or node.
Stylesheet() - Constructor for class org.dom4j.rule.Stylesheet
Creates a new empty stylesheet.
selectNodes(String, List) - Static method in class org.dom4j.DocumentHelper
selectNodes performs the given XPath expression on the Listof Nodeinstances appending all the results together into a single list.
selectNodes(String, Node) - Static method in class org.dom4j.DocumentHelper
selectNodes performs the given XPath expression on the Listof Nodeinstances appending all the results together into a single list.
selectNodes(String) - Method in interface org.dom4j.Node
selectNodes evaluates an XPath expression and returns the result as a List of Node instances or String instances depending on the XPath expression.
selectNodes(String, String) - Method in interface org.dom4j.Node
selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.
selectNodes(String, String, boolean) - Method in interface org.dom4j.Node
selectNodes evaluates an XPath expression then sorts the results using a secondary XPath expression Returns a sorted List of Node instances.
selectNodes(Object) - Method in interface org.dom4j.XPath
selectNodes performs this XPath expression on the given Nodeor Listof Nodes instances appending all the results together into a single list.
selectNodes(Object, XPath) - Method in interface org.dom4j.XPath
selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.
selectNodes(Object, XPath, boolean) - Method in interface org.dom4j.XPath
selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.
selectNodes(String) - Method in class org.dom4j.tree.AbstractNode
selectNodes(String, String) - Method in class org.dom4j.tree.AbstractNode
selectNodes(String, String, boolean) - Method in class org.dom4j.tree.AbstractNode
selectNodes(Object) - Method in class org.dom4j.xpath.DefaultXPath
selectNodes(Object, XPath) - Method in class org.dom4j.xpath.DefaultXPath
selectNodes(Object, XPath, boolean) - Method in class org.dom4j.xpath.DefaultXPath
selectObject(String) - Method in interface org.dom4j.Node
selectObject evaluates an XPath expression and returns the result as an Object.
selectObject(Object) - Method in interface org.dom4j.XPath
Deprecated. please use evaluate(Object) instead. WILL BE REMOVED IN dom4j-1.6 !!
selectObject(String) - Method in class org.dom4j.tree.AbstractNode
selectObject(Object) - Method in class org.dom4j.xpath.DefaultXPath
selectSingleNode(String) - Method in interface org.dom4j.Node
selectSingleNode evaluates an XPath expression and returns the result as a single Node instance.
selectSingleNode(Object) - Method in interface org.dom4j.XPath
selectSingleNode evaluates this XPath expression on the given Nodeor Listof Nodes and returns the result as a single Node instance.
selectSingleNode(String) - Method in class org.dom4j.tree.AbstractNode
selectSingleNode(Object) - Method in class org.dom4j.xpath.DefaultXPath
serialVersionUID - Static variable in class org.dom4j.io.SAXEventRecorder
set(int, Object) - Method in class org.dom4j.bean.BeanAttributeList
set(int, Object) - Method in class org.dom4j.tree.BackedList
set(int, Object) - Method in class org.dom4j.tree.ContentListFacade
setAction(Action) - Method in class org.dom4j.rule.Rule
Setter for property action.
setAppearenceCount(int) - Method in class org.dom4j.rule.Rule
Setter for property appearenceCount.
setAttribute(String, String) - Method in class org.dom4j.dom.DOMElement
setAttributeList(List) - Method in class org.dom4j.tree.BaseElement
setAttributeList(List) - Method in class org.dom4j.tree.DefaultElement
setAttributeNS(String, String, String) - Method in class org.dom4j.dom.DOMElement
setAttributeName(String) - Method in class org.dom4j.dtd.AttributeDecl
Setter for property attributeName.
setAttributeNode(Attr) - Method in class org.dom4j.dom.DOMElement
setAttributeNodeNS(Attr) - Method in class org.dom4j.dom.DOMElement
setAttributeQuoteCharacter(char) - Method in class org.dom4j.io.OutputFormat
Sets the character used to quote attribute values.
setAttributeValue(String, String) - Method in interface org.dom4j.Element
Deprecated. As of version 0.5. Please use Element.addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
setAttributeValue(QName, String) - Method in interface org.dom4j.Element
Deprecated. As of version 0.5. Please use Element.addAttribute(QName,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
setAttributeValue(String, String) - Method in class org.dom4j.tree.AbstractElement
Deprecated. As of version 0.5. Please use AbstractElement.addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
setAttributeValue(QName, String) - Method in class org.dom4j.tree.AbstractElement
Deprecated. As of version 0.5. Please use AbstractElement.addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
setAttributeXSDatatype(QName, XSDatatype) - Method in class org.dom4j.datatype.DatatypeElementFactory
Registers the given XSDatatype for the given <attribute> QNames
setAttributes(List) - Method in interface org.dom4j.Element
Sets the attributes that this element contains
setAttributes(List) - Method in class org.dom4j.bean.BeanElement
setAttributes(Attributes, NamespaceStack, boolean) - Method in class org.dom4j.bean.BeanElement
setAttributes(Attributes, NamespaceStack, boolean) - Method in class org.dom4j.tree.AbstractElement
This method provides a more optimal way of setting all the attributes on an Element particularly for use in SAXReader.
setAttributes(List) - Method in class org.dom4j.tree.BaseElement
setAttributes(List) - Method in class org.dom4j.tree.DefaultElement
setChildElementXSDatatype(QName, XSDatatype) - Method in class org.dom4j.datatype.DatatypeElementFactory
setColumnNameXPath(XPath) - Method in class org.dom4j.swing.XMLTableColumnDefinition
Setter for property columnNameXPath.
setConsumer(XMLEventConsumer) - Method in class org.dom4j.io.STAXEventWriter
Sets the underlying event consumer to which events are written.
setContent(List) - Method in interface org.dom4j.Branch
Sets the contents of this branch as a List of Node instances.
setContent(List) - Method in class org.dom4j.tree.BaseElement
setContent(List) - Method in class org.dom4j.tree.DefaultDocument
setContent(List) - Method in class org.dom4j.tree.DefaultElement
setContentHandler(ContentHandler) - Method in class org.dom4j.io.SAXWriter
Sets the ContentHandler called when SAX events are raised
setDTDHandler(DTDHandler) - Method in class org.dom4j.io.SAXWriter
Sets the DTDHandler.
setData(Object) - Method in interface org.dom4j.Attribute
Sets the data value of this attribute if this element supports data binding or calls Node.setText(String)if it doesn't.
setData(Object) - Method in interface org.dom4j.Element
Sets the data value of this element if this element supports data binding or calls Node.setText(java.lang.String)if it doesn't
setData(Object) - Method in class org.dom4j.bean.BeanAttribute
setData(int, Object) - Method in class org.dom4j.bean.BeanAttributeList
setData(Object) - Method in class org.dom4j.bean.BeanElement
setData(int, Object, Object) - Method in class org.dom4j.bean.BeanMetaData
setData(Object) - Method in class org.dom4j.datatype.DatatypeAttribute
setData(Object) - Method in class org.dom4j.datatype.DatatypeElement
setData(String) - Method in class org.dom4j.dom.DOMCDATA
setData(String) - Method in class org.dom4j.dom.DOMComment
setData(CharacterData, String) - Static method in class org.dom4j.dom.DOMNodeHelper
setData(String) - Method in class org.dom4j.dom.DOMProcessingInstruction
setData(String) - Method in class org.dom4j.dom.DOMText
setData(Object) - Method in class org.dom4j.tree.AbstractAttribute
setData(Object) - Method in class org.dom4j.tree.AbstractElement
setData(Object) - Method in class org.dom4j.util.UserDataAttribute
setData(Object) - Method in class org.dom4j.util.UserDataElement
setDeclareNamespaceAttributes(boolean) - Method in class org.dom4j.io.SAXWriter
Sets whether namespace declarations should be exported as "xmlns" attributes or not.
setDefaultHandler(ElementHandler) - Method in class org.dom4j.io.SAXReader
When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.
setDefaultHandler(ElementHandler) - Method in class org.dom4j.io.XPP3Reader
When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.
setDefaultHandler(ElementHandler) - Method in class org.dom4j.io.XPPReader
When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.
setDefinition(XMLTableDefinition) - Method in class org.dom4j.swing.XMLTableModel
Setter for property definition.
setDispatchHandler(DispatchHandler) - Method in class org.dom4j.io.SAXReader
setDispatchHandler(DispatchHandler) - Method in class org.dom4j.io.XPP3Reader
setDispatchHandler(DispatchHandler) - Method in class org.dom4j.io.XPPReader
setDocType(DocumentType) - Method in interface org.dom4j.Document
Sets the DocumentType property
setDocType(DocumentType) - Method in class org.dom4j.tree.DefaultDocument
setDocument(Document) - Method in interface org.dom4j.Node
setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
setDocument(Document) - Method in class org.dom4j.io.DocumentSource
Sets the document used as the JAXP SAXSource
setDocument(Document) - Method in class org.dom4j.swing.DocumentTreeModel
Sets the Document instance that this TreeModel is based on
setDocument(Document) - Method in class org.dom4j.tree.AbstractNode
setDocument(Document) - Method in class org.dom4j.tree.BaseElement
setDocument(Document) - Method in class org.dom4j.tree.DefaultElement
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.QName
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.io.DOMReader
This sets the DocumentFactory used to create new documents.
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.io.SAXModifier
Sets the DocumentFactoryused to create the DOM4J document tree.
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.io.SAXReader
This sets the DocumentFactory used to create new documents.
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.io.STAXEventReader
Sets the DocumentFactory to be used when constructing DOM4J nodes.
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.io.XPP3Reader
This sets the DocumentFactory used to create new documents.
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.io.XPPReader
This sets the DocumentFactory used to create new documents.
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.tree.DefaultDocument
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.tree.NamespaceStack
setDocumentFactory(DocumentFactory) - Method in class org.dom4j.xpp.ProxyXmlStartTag
setDocumentLocator(Locator) - Method in class org.dom4j.io.SAXContentHandler
setDocumentLocator(Locator) - Method in class org.dom4j.io.XMLWriter
setDomDocumentClass(Class) - Method in class org.dom4j.io.DOMWriter
Sets the DOM Documentimplementation class used by the writer when creating DOM documents.
setDomDocumentClassName(String) - Method in class org.dom4j.io.DOMWriter
Sets the DOM Documentimplementation class name used by the writer when creating DOM documents.
setElementName(String) - Method in interface org.dom4j.DocumentType
This method is the equivalent to the Node.setName(java.lang.String)method.
setElementName(String) - Method in class org.dom4j.dtd.AttributeDecl
Setter for property elementName.
setElementName(String) - Method in class org.dom4j.tree.DefaultDocumentType
setElementStack(ElementStack) - Method in class org.dom4j.io.SAXContentHandler
setEncoding(String) - Method in class org.dom4j.io.OutputFormat
DOCUMENT ME!
setEncoding(String) - Method in class org.dom4j.io.SAXReader
Sets encoding used for InputSource (null means system default encoding)
setEntityResolver(EntityResolver) - Method in interface org.dom4j.Document
Sets the EntityResolver used to find resolve URIs such as for DTDs, or XML Schema documents
setEntityResolver(EntityResolver) - Method in class org.dom4j.io.SAXContentHandler
setEntityResolver(EntityResolver) - Method in class org.dom4j.io.SAXReader
Sets the entity resolver used to resolve entities.
setEntityResolver(EntityResolver) - Method in class org.dom4j.io.SAXWriter
Sets the EntityResolver.
setEntityResolver(EntityResolver) - Method in class org.dom4j.tree.DefaultDocument
setErrorHandler(ErrorHandler) - Method in class org.dom4j.io.SAXReader
Sets the ErrorHandler used by the SAX XMLReader.
setErrorHandler(ErrorHandler) - Method in class org.dom4j.io.SAXValidator
Sets the ErrorHandler used by the SAX XMLReader.
setErrorHandler(ErrorHandler) - Method in class org.dom4j.io.SAXWriter
Sets the ErrorHandler.
setErrorQName(QName) - Method in class org.dom4j.util.XMLErrorHandler
setErrors(Element) - Method in class org.dom4j.util.XMLErrorHandler
setEscapeText(boolean) - Method in class org.dom4j.io.XMLWriter
Sets whether text output should be escaped or not.
setEventFactory(XMLEventFactory) - Method in class org.dom4j.io.STAXEventWriter
Sets the event factory used to construct STAX events.
setExpandEmptyElements(boolean) - Method in class org.dom4j.io.OutputFormat
This will set whether empty elements are expanded from <tagName> to <tagName></tagName>.
setExternalDeclarations(List) - Method in interface org.dom4j.DocumentType
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
setExternalDeclarations(List) - Method in class org.dom4j.tree.DefaultDocumentType
setFatalErrorQName(QName) - Method in class org.dom4j.util.XMLErrorHandler
setFeature(String, boolean) - Method in class org.dom4j.io.SAXReader
Sets a SAX feature on the underlying SAX parser.
setFeature(String, boolean) - Method in class org.dom4j.io.SAXWriter
This implementation does actually use any features but just stores them for later retrieval
setFunctionContext(FunctionContext) - Method in interface org.dom4j.XPath
Sets the function context to be used when evaluating XPath expressions
setFunctionContext(FunctionContext) - Method in class org.dom4j.xpath.DefaultXPath
setHandler(ContentHandler) - Method in class org.dom4j.io.DocumentResult
setIgnoreComments(boolean) - Method in class org.dom4j.io.SAXContentHandler
Sets whether we should ignore comments or not.
setIgnoreComments(boolean) - Method in class org.dom4j.io.SAXReader
Sets whether we should ignore comments or not.
setImportPrecedence(int) - Method in class org.dom4j.rule.Rule
Setter for property importPrecedence.
setIncludeExternalDTDDeclarations(boolean) - Method in class org.dom4j.io.SAXContentHandler
Sets whether DTD external declarations should be expanded into the DocumentType object or not.
setIncludeExternalDTDDeclarations(boolean) - Method in class org.dom4j.io.SAXReader
Sets whether DTD external declarations should be expanded into the DocumentType object or not.
setIncludeInternalDTDDeclarations(boolean) - Method in class org.dom4j.io.SAXContentHandler
Sets whether internal DTD declarations should be expanded into the DocumentType object or not.
setIncludeInternalDTDDeclarations(boolean) - Method in class org.dom4j.io.SAXReader
Sets whether internal DTD declarations should be expanded into the DocumentType object or not.
setIndent(String) - Method in class org.dom4j.io.OutputFormat
This will set the indent String to use; this is usually a String of empty spaces.
setIndent(boolean) - Method in class org.dom4j.io.OutputFormat
Set the indent on or off.
setIndentLevel(int) - Method in class org.dom4j.io.XMLWriter
Set the initial indentation level.
setIndentSize(int) - Method in class org.dom4j.io.OutputFormat
This will set the indent String's size; an indentSize of 4 would result in the indention being equivalent to the String " " (four space characters).
setInputSource(InputSource) - Method in class org.dom4j.io.DocumentSource
This method is not supported as this source is always a instance.
setInputSource(InputSource) - Method in class org.dom4j.io.SAXContentHandler
setInternalDeclarations(List) - Method in interface org.dom4j.DocumentType
Sets the list of internal DTD declaration objects, defined in the org.dom4j.dtdpackage
setInternalDeclarations(List) - Method in class org.dom4j.tree.DefaultDocumentType
setLexicalHandler(LexicalHandler) - Method in class org.dom4j.io.DocumentResult
setLexicalHandler(LexicalHandler) - Method in class org.dom4j.io.SAXWriter
Sets the LexicalHandler.
setLexicalHandler(LexicalHandler) - Method in class org.dom4j.io.XMLWriter
setLineSeparator(String) - Method in class org.dom4j.io.OutputFormat
This will set the new-line separator.
setMaximumAllowedCharacter(int) - Method in class org.dom4j.io.XMLWriter
Sets the maximum allowed character code that should be allowed unescaped such as 127 in US-ASCII (7 bit) or 255 in ISO- (8 bit) or -1 to not escape any characters (other than the special XML characters like < > &) If this is not explicitly set then it is defaulted from the encoding.
setMergeAdjacentText(boolean) - Method in class org.dom4j.io.SAXContentHandler
Sets whether or not adjacent text nodes should be merged together when parsing.
setMergeAdjacentText(boolean) - Method in class org.dom4j.io.SAXReader
Sets whether or not adjacent text nodes should be merged together when parsing.
setMode(String) - Method in class org.dom4j.rule.Rule
Setter for property mode.
setModeName(String) - Method in class org.dom4j.rule.Stylesheet
Sets the name of the mode that the stylesheet uses by default.
setModel(String) - Method in class org.dom4j.dtd.ElementDecl
Setter for property model.
setNSContext(Object) - Method in class org.dom4j.xpath.DefaultXPath
setName(String) - Method in interface org.dom4j.Node
Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
setName(String) - Method in class org.dom4j.dtd.ElementDecl
Setter for property name.
setName(String) - Method in class org.dom4j.dtd.ExternalEntityDecl
Setter for property name.
setName(String) - Method in class org.dom4j.dtd.InternalEntityDecl
Setter for property name.
setName(String) - Method in class org.dom4j.swing.XMLTableColumnDefinition
Setter for property name.
setName(String) - Method in class org.dom4j.tree.AbstractDocumentType
setName(String) - Method in class org.dom4j.tree.AbstractElement
setName(String) - Method in class org.dom4j.tree.AbstractNode
setName(String) - Method in class org.dom4j.tree.AbstractProcessingInstruction
setName(String) - Method in class org.dom4j.tree.DefaultDocument
setName(String) - Method in class org.dom4j.tree.DefaultEntity
setNamedItem(Node) - Method in class org.dom4j.dom.DOMAttributeNodeMap
setNamedItemNS(Node) - Method in class org.dom4j.dom.DOMAttributeNodeMap
setNamespace(Namespace) - Method in interface org.dom4j.Attribute
Sets the Namespace of this element or if this element is read only then an UnsupportedOperationException is thrown.
setNamespace(Namespace) - Method in class org.dom4j.tree.AbstractAttribute
setNamespace(Namespace) - Method in class org.dom4j.tree.AbstractElement
setNamespaceContext(NamespaceContext) - Method in interface org.dom4j.XPath
Sets the namespace context to be used when evaluating XPath expressions
setNamespaceContext(NamespaceContext) - Method in class org.dom4j.xpath.DefaultXPath
setNamespaceURIs(Map) - Method in interface org.dom4j.XPath
Sets the current NamespaceContext from a Map where the keys are the String namespace prefixes and the values are the namespace URIs.
setNamespaceURIs(Map) - Method in class org.dom4j.xpath.DefaultXPath
setNewLineAfterDeclaration(boolean) - Method in class org.dom4j.io.OutputFormat
This will set whether a new line is printed after the XML declaration (assuming it is not supressed.)
setNewLineAfterNTags(int) - Method in class org.dom4j.io.OutputFormat
Controls output of a line.separator every tagCount tags when isNewlines is false.
setNewlines(boolean) - Method in class org.dom4j.io.OutputFormat
DOCUMENT ME!
setNodeValue(String) - Method in class org.dom4j.dom.DOMAttribute
setNodeValue(String) - Method in class org.dom4j.dom.DOMCDATA
setNodeValue(String) - Method in class org.dom4j.dom.DOMComment
setNodeValue(String) - Method in class org.dom4j.dom.DOMDocument
setNodeValue(String) - Method in class org.dom4j.dom.DOMDocumentType
setNodeValue(String) - Method in class org.dom4j.dom.DOMElement
setNodeValue(String) - Method in class org.dom4j.dom.DOMEntityReference
setNodeValue(String) - Method in class org.dom4j.dom.DOMNamespace
setNodeValue(Node, String) - Static method in class org.dom4j.dom.DOMNodeHelper
setNodeValue(String) - Method in class org.dom4j.dom.DOMProcessingInstruction
setNodeValue(String) - Method in class org.dom4j.dom.DOMText
setOmitElementCloseSet(Set) - Method in class org.dom4j.io.HTMLWriter
To use the empty set, pass an empty Set, or null: setOmitElementCloseSet(new HashSet()); or setOmitElementCloseSet(null);
setOmitEncoding(boolean) - Method in class org.dom4j.io.OutputFormat
This will set whether the XML declaration (<?
setOutput(File) - Method in class org.dom4j.jaxb.JAXBModifier
Sets the Output to write the (modified) xml document to.
setOutput(OutputStream) - Method in class org.dom4j.jaxb.JAXBModifier
Sets the Output to write the (modified) xml document to.
setOutput(Writer) - Method in class org.dom4j.jaxb.JAXBModifier
Sets the Output to write the (modified) xml document to.
setOutput(File) - Method in class org.dom4j.jaxb.JAXBWriter
Defines to write the resulting output to the specified File.
setOutput(OutputStream) - Method in class org.dom4j.jaxb.JAXBWriter
Defines to write the resulting output to the specified OutputStream
setOutput(Writer) - Method in class org.dom4j.jaxb.JAXBWriter
Defines to write the resulting output to the specified Writer.
setOutputStream(OutputStream) - Method in class org.dom4j.io.XMLWriter

setPadText(boolean) - Method in class org.dom4j.io.OutputFormat
Ensure that text immediately preceded by or followed by an element will be "padded" with a single space.
setParent(Element) - Method in interface org.dom4j.Node
setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
setParent(Element) - Method in class org.dom4j.datatype.DatatypeAttribute

setParent(LeafTreeNode) - Method in class org.dom4j.swing.LeafTreeNode
Sets the parent of this node but doesn't change the parents children
setParent(Element) - Method in class org.dom4j.tree.AbstractNode

setParent(Element) - Method in class org.dom4j.tree.BaseElement

setParent(Element) - Method in class org.dom4j.tree.DefaultAttribute

setParent(Element) - Method in class org.dom4j.tree.DefaultCDATA

setParent(Element) - Method in class org.dom4j.tree.DefaultComment

setParent(Element) - Method in class org.dom4j.tree.DefaultElement

setParent(Element) - Method in class org.dom4j.tree.DefaultEntity

setParent(Element) - Method in class org.dom4j.tree.DefaultNamespace

setParent(Element) - Method in class org.dom4j.tree.DefaultProcessingInstruction

setParent(Element) - Method in class org.dom4j.tree.DefaultText

setPattern(Pattern) - Method in class org.dom4j.rule.Rule
Setter for property pattern.
setPrefix(String) - Method in class org.dom4j.dom.DOMAttribute

setPrefix(String) - Method in class org.dom4j.dom.DOMCDATA

setPrefix(String) - Method in class org.dom4j.dom.DOMComment

setPrefix(String) - Method in class org.dom4j.dom.DOMDocument

setPrefix(String) - Method in class org.dom4j.dom.DOMDocumentType

setPrefix(String) - Method in class org.dom4j.dom.DOMElement

setPrefix(String) - Method in class org.dom4j.dom.DOMEntityReference

setPrefix(String) - Method in class org.dom4j.dom.DOMNamespace

setPrefix(Node, String) - Static method in class org.dom4j.dom.DOMNodeHelper

setPrefix(String) - Method in class org.dom4j.dom.DOMProcessingInstruction

setPrefix(String) - Method in class org.dom4j.dom.DOMText

setPreformattedTags(Set) - Method in class org.dom4j.io.HTMLWriter
Override the default set, which includes PRE, SCRIPT, STYLE, and TEXTAREA, case insensitively.
setPriority(double) - Method in class org.dom4j.rule.Rule
Setter for property priority.
setProcessingInstructions(List) - Method in interface org.dom4j.Branch
Sets all the processing instructions for this branch
setProcessingInstructions(List) - Method in class org.dom4j.tree.AbstractBranch

setProperty(String, Object) - Method in class org.dom4j.io.SAXReader
Allows a SAX property to be set on the underlying SAX parser.
setProperty(String, Object) - Method in class org.dom4j.io.SAXWriter
Sets the given SAX property
setProperty(String, Object) - Method in class org.dom4j.io.XMLWriter

setProxy(DocumentFactory) - Method in class org.dom4j.util.ProxyDocumentFactory

setPruneElements(boolean) - Method in class org.dom4j.jaxb.JAXBModifier
Define whether the modified Documentmust only be written to the output and pruned from the DOM4J tree.
setPruneElements(boolean) - Method in class org.dom4j.jaxb.JAXBReader
Set to true when DOM4J elements must immediately be pruned from the tree.
setPublicID(String) - Method in interface org.dom4j.DocumentType

setPublicID(String) - Method in class org.dom4j.dtd.ExternalEntityDecl
Setter for property publicID.
setPublicID(String) - Method in class org.dom4j.tree.DefaultDocumentType
Sets the public ID of the document type
setQName(QName) - Method in interface org.dom4j.Element
Sets the QName of this element which represents the local name, the qualified name and the Namespace.
setQName(QName) - Method in class org.dom4j.tree.BaseElement

setQName(QName) - Method in class org.dom4j.tree.DefaultElement

setResolveEntityRefs(boolean) - Method in class org.dom4j.io.XMLWriter

setRootElement(Element) - Method in interface org.dom4j.Document
Sets the root element for this document
setRootElement(Element) - Method in class org.dom4j.tree.AbstractDocument

setRowExpression(String) - Method in class org.dom4j.swing.XMLTableDefinition

setRowXPath(XPath) - Method in class org.dom4j.swing.XMLTableDefinition
Setter for property rowXPath.
setSingletonClassName(String) - Method in class org.dom4j.util.PerThreadSingleton

setSingletonClassName(String) - Method in class org.dom4j.util.SimpleSingleton

setSingletonClassName(String) - Method in interface org.dom4j.util.SingletonStrategy
set a singleton class name that will be used to create the singleton based on the strategy implementation of this interface.
setSource(Object) - Method in class org.dom4j.swing.XMLTableModel
Setter for the XML source, which is usually a Node or List of nodes.
setStringInternEnabled(boolean) - Method in class org.dom4j.io.SAXReader
Sets whether String interning is enabled or disabled for element & attribute names and namespace URIs
setStripWhitespaceText(boolean) - Method in class org.dom4j.io.SAXContentHandler
Sets whether whitespace between element start and end tags should be ignored.
setStripWhitespaceText(boolean) - Method in class org.dom4j.io.SAXReader
Sets whether whitespace between element start and end tags should be ignored.
setSuppressDeclaration(boolean) - Method in class org.dom4j.io.OutputFormat
This will set whether the XML declaration (<?
setSystemID(String) - Method in interface org.dom4j.DocumentType

setSystemID(String) - Method in class org.dom4j.dtd.ExternalEntityDecl
Setter for property systemID.
setSystemID(String) - Method in class org.dom4j.tree.DefaultDocumentType
Sets the system ID of the document type
setTarget(String) - Method in interface org.dom4j.ProcessingInstruction
This method is the equivalent to the Node.setName(java.lang.String)method.
setTarget(String) - Method in class org.dom4j.tree.DefaultProcessingInstruction

setTarget(String) - Method in class org.dom4j.tree.FlyweightProcessingInstruction

setText(String) - Method in interface org.dom4j.Node
Sets the text data of this node or this method will throw an UnsupportedOperationException if it is read-only.
setText(String) - Method in class org.dom4j.datatype.DatatypeElement

setText(String) - Method in class org.dom4j.tree.AbstractAttribute

setText(String) - Method in class org.dom4j.tree.AbstractElement

setText(String) - Method in class org.dom4j.tree.AbstractNode

setText(String) - Method in class org.dom4j.tree.DefaultCDATA

setText(String) - Method in class org.dom4j.tree.DefaultComment

setText(String) - Method in class org.dom4j.tree.DefaultEntity

setText(String) - Method in class org.dom4j.tree.DefaultProcessingInstruction

setText(String) - Method in class org.dom4j.tree.DefaultText

setText(String) - Method in class org.dom4j.tree.FlyweightEntity
sets the value of the entity if it is not defined yet otherwise an UnsupportedOperationException is thrown as this class is read only.
setTrimText(boolean) - Method in class org.dom4j.io.OutputFormat
This will set whether the text is output verbatim (false) or with whitespace stripped as per Element.getTextTrim().
setType(String) - Method in class org.dom4j.dtd.AttributeDecl
Setter for property type.
setType(int) - Method in class org.dom4j.swing.XMLTableColumnDefinition
Setter for property type.
setValidation(boolean) - Method in class org.dom4j.io.SAXReader
Sets the validation mode.
setValue(String) - Method in interface org.dom4j.Attribute
Sets the value of this attribute or this method will throw an UnsupportedOperationException if it is read-only.
setValue(String, String) - Method in interface org.dom4j.ProcessingInstruction

setValue(String) - Method in class org.dom4j.bean.BeanAttribute

setValue(String) - Method in class org.dom4j.datatype.DatatypeAttribute

setValue(String) - Method in class org.dom4j.dtd.AttributeDecl
Setter for property value.
setValue(String) - Method in class org.dom4j.dtd.InternalEntityDecl
Setter for property value.
setValue(String) - Method in class org.dom4j.tree.AbstractAttribute

setValue(String, String) - Method in class org.dom4j.tree.AbstractProcessingInstruction

setValue(Object) - Method in class org.dom4j.tree.ConcurrentReaderHashMap.Entry
Set the value of this entry.
setValue(String) - Method in class org.dom4j.tree.DefaultAttribute

setValue(String, String) - Method in class org.dom4j.tree.DefaultProcessingInstruction

setValueDefault(String) - Method in class org.dom4j.dtd.AttributeDecl
Setter for property valueDefault.
setValueOfAction(Action) - Method in class org.dom4j.rule.RuleManager
Sets the default value-of action which is used in the default rules for the pattern "text()|@"
setValueOfAction(Action) - Method in class org.dom4j.rule.Stylesheet
Sets the default value-of action which is used in the default rules for the pattern "text()|@"
setValues(Map) - Method in interface org.dom4j.ProcessingInstruction

setValues(Map) - Method in class org.dom4j.tree.AbstractProcessingInstruction

setValues(Map) - Method in class org.dom4j.tree.DefaultProcessingInstruction

setVariableContext(VariableContext) - Method in interface org.dom4j.XPath
Sets the variable context to be used when evaluating XPath expressions
setVariableContext(VariableContext) - Method in class org.dom4j.xpath.DefaultXPath

setVariableContext(VariableContext) - Method in class org.dom4j.xpath.XPathPattern

setWarningQName(QName) - Method in class org.dom4j.util.XMLErrorHandler

setWriter(Writer) - Method in class org.dom4j.io.XMLWriter

setXHTML(boolean) - Method in class org.dom4j.io.OutputFormat
This will set whether or not to use the XHTML standard: like HTML but passes an XML parser with real, closed tags.
setXMLEncoding(String) - Method in interface org.dom4j.Document
Sets the encoding of this document as it will appear in the XML declaration part of the document.
setXMLEncoding(String) - Method in class org.dom4j.tree.AbstractDocument

setXMLFilter(XMLFilter) - Method in class org.dom4j.io.SAXReader
Sets the SAX filter to be used when filtering SAX events
setXMLReader(XMLReader) - Method in class org.dom4j.io.DocumentSource
Sets the XMLReader used for the JAXP SAXSource.
setXMLReader(XMLReader) - Method in class org.dom4j.io.SAXReader
Sets the XMLReader used to parse SAX events
setXMLReader(XMLReader) - Method in class org.dom4j.io.SAXValidator
Sets the XMLReader used to parse SAX events
setXMLReader(XMLReader) - Method in class org.dom4j.io.SAXWriter
Sets the XMLReader used to write SAX events to
setXMLReaderClassName(String) - Method in class org.dom4j.io.SAXReader
Sets the class name of the XMLReader to be used to parse SAX events.
setXMLWriter(XMLWriter) - Method in class org.dom4j.io.SAXModifier
Sets the XMLWriterused to write the modified document.
setXMLWriter(XMLWriter) - Method in class org.dom4j.io.XMLResult

setXPPFactory(XmlPullParserFactory) - Method in class org.dom4j.io.XPP3Reader

setXPPFactory(XmlPullParserFactory) - Method in class org.dom4j.io.XPPReader

setXPath(XPath) - Method in class org.dom4j.swing.XMLTableColumnDefinition
Setter for property xpath.
setXPathNamespaceURIs(Map) - Method in class org.dom4j.DocumentFactory
Sets the namespace URIs to be used by XPath expressions created by this factory or by nodes associated with this factory.
shouldEncodeChar(char) - Method in class org.dom4j.io.XMLWriter
Should the given character be escaped.
singleton - Static variable in class org.dom4j.datatype.DatatypeDocumentFactory
The Singleton instance
singleton - Static variable in class org.dom4j.util.IndexedDocumentFactory
The Singleton instance
singleton - Static variable in class org.dom4j.util.NonLazyDocumentFactory
The Singleton instance
singleton - Static variable in class org.dom4j.util.UserDataDocumentFactory
The Singleton instance
size() - Method in interface org.dom4j.ElementPath
DOCUMENT ME!
size() - Method in class org.dom4j.bean.BeanAttributeList

size() - Method in class org.dom4j.tree.ContentListFacade

size() - Method in class org.dom4j.tree.NamespaceStack
DOCUMENT ME!
sort(List, String) - Static method in class org.dom4j.DocumentHelper
sort sorts the given List of Nodes using an XPath expression as a Comparator.
sort(List, String, boolean) - Static method in class org.dom4j.DocumentHelper
sort sorts the given List of Nodes using an XPath expression as a Comparatorand optionally removing duplicates.
sort(List) - Method in interface org.dom4j.XPath
sort sorts the given List of Nodes using this XPath expression as a Comparator.
sort(List, boolean) - Method in interface org.dom4j.XPath
sort sorts the given List of Nodes using this XPath expression as a Comparatorand optionally removing duplicates.
sort(List) - Method in class org.dom4j.xpath.DefaultXPath
sort sorts the given List of Nodes using this XPath expression as a Comparator.
sort(List, boolean) - Method in class org.dom4j.xpath.DefaultXPath
sort sorts the given List of Nodes using this XPath expression as a Comparatorand optionally removing duplicates.
sort(List, Map) - Method in class org.dom4j.xpath.DefaultXPath
Sorts the list based on the sortValues for each node
splitText(int) - Method in class org.dom4j.dom.DOMCDATA

splitText(int) - Method in class org.dom4j.dom.DOMText

startCDATA() - Method in class org.dom4j.io.HTMLWriter

startCDATA() - Method in class org.dom4j.io.SAXContentHandler

startCDATA() - Method in class org.dom4j.io.SAXEventRecorder

startCDATA() - Method in class org.dom4j.io.XMLWriter

startDTD(String, String, String) - Method in class org.dom4j.io.SAXContentHandler

startDTD(String, String, String) - Method in class org.dom4j.io.SAXEventRecorder

startDTD(String, String, String) - Method in class org.dom4j.io.XMLWriter

startDocument() - Method in class org.dom4j.io.SAXContentHandler

startDocument() - Method in class org.dom4j.io.SAXEventRecorder

startDocument() - Method in class org.dom4j.io.SAXWriter

startDocument() - Method in class org.dom4j.io.XMLWriter

startDocument() - Method in class org.dom4j.jaxb.JAXBWriter
Start a document by writing the initial XML declaration to the output.
startElement(String, String, String, Attributes) - Method in class org.dom4j.io.SAXContentHandler

startElement(String, String, String, Attributes) - Method in class org.dom4j.io.SAXEventRecorder

startElement(Element, AttributesImpl) - Method in class org.dom4j.io.SAXWriter

startElement(String, String, String, Attributes) - Method in class org.dom4j.io.XMLWriter

startEntity(String) - Method in class org.dom4j.io.SAXContentHandler

startEntity(String) - Method in class org.dom4j.io.SAXEventRecorder

startEntity(String) - Method in class org.dom4j.io.XMLWriter

startPrefixMapping(String, String) - Method in class org.dom4j.io.SAXContentHandler

startPrefixMapping(String, String) - Method in class org.dom4j.io.SAXEventRecorder

startPrefixMapping(Element, NamespaceStack) - Method in class org.dom4j.io.SAXWriter
Fires a SAX startPrefixMapping event for all the namespaceStack which have just come into scope
startPrefixMapping(String, String) - Method in class org.dom4j.io.XMLWriter

substringData(int, int) - Method in class org.dom4j.dom.DOMCDATA

substringData(int, int) - Method in class org.dom4j.dom.DOMComment

substringData(CharacterData, int, int) - Static method in class org.dom4j.dom.DOMNodeHelper

substringData(int, int) - Method in class org.dom4j.dom.DOMText

supports(String, String) - Method in class org.dom4j.dom.DOMAttribute

supports(String, String) - Method in class org.dom4j.dom.DOMCDATA

supports(String, String) - Method in class org.dom4j.dom.DOMComment

supports(String, String) - Method in class org.dom4j.dom.DOMDocument

supports(String, String) - Method in class org.dom4j.dom.DOMDocumentType

supports(String, String) - Method in class org.dom4j.dom.DOMElement

supports(String, String) - Method in class org.dom4j.dom.DOMEntityReference

supports(String, String) - Method in class org.dom4j.dom.DOMNamespace

supports(Node, String, String) - Static method in class org.dom4j.dom.DOMNodeHelper

supports(String, String) - Method in class org.dom4j.dom.DOMProcessingInstruction

supports(String, String) - Method in class org.dom4j.dom.DOMText

supportsParent() - Method in interface org.dom4j.Node
supportsParent returns true if this node supports the parent relationship.
supportsParent() - Method in class org.dom4j.datatype.DatatypeAttribute

supportsParent() - Method in class org.dom4j.tree.AbstractNode

supportsParent() - Method in class org.dom4j.tree.BaseElement

supportsParent() - Method in class org.dom4j.tree.DefaultAttribute

supportsParent() - Method in class org.dom4j.tree.DefaultCDATA

supportsParent() - Method in class org.dom4j.tree.DefaultComment

supportsParent() - Method in class org.dom4j.tree.DefaultElement

supportsParent() - Method in class org.dom4j.tree.DefaultEntity

supportsParent() - Method in class org.dom4j.tree.DefaultNamespace

supportsParent() - Method in class org.dom4j.tree.DefaultProcessingInstruction

supportsParent() - Method in class org.dom4j.tree.DefaultText

T

TEXT_NODE - Static variable in interface org.dom4j.Node
Matches elements nodes
Text - interface org.dom4j.Text.
Text defines an XML Text node.
target - Variable in class org.dom4j.tree.FlyweightProcessingInstruction
The target of the PI
text - Variable in class org.dom4j.tree.FlyweightCDATA
Text of the CDATA node
text - Variable in class org.dom4j.tree.FlyweightComment
Text of the Comment node
text - Variable in class org.dom4j.tree.FlyweightEntity
The text of the Entity
text - Variable in class org.dom4j.tree.FlyweightProcessingInstruction
The values for the PI as a String
text - Variable in class org.dom4j.tree.FlyweightText
Text of the Text node
toArray() - Method in class org.dom4j.tree.ContentListFacade

toArray(Object[]) - Method in class org.dom4j.tree.ContentListFacade

toString() - Method in class org.dom4j.Namespace

toString() - Method in class org.dom4j.QName

toString() - Method in class org.dom4j.datatype.DatatypeAttribute

toString() - Method in class org.dom4j.datatype.DatatypeElement

toString() - Method in class org.dom4j.dtd.AttributeDecl

toString() - Method in class org.dom4j.dtd.ElementDecl

toString() - Method in class org.dom4j.dtd.ExternalEntityDecl

toString() - Method in class org.dom4j.dtd.InternalEntityDecl

toString() - Method in class org.dom4j.rule.Rule

toString() - Method in class org.dom4j.rule.RuleSet

toString() - Method in class org.dom4j.swing.BranchTreeNode

toString() - Method in class org.dom4j.swing.LeafTreeNode

toString() - Method in class org.dom4j.tree.AbstractAttribute

toString() - Method in class org.dom4j.tree.AbstractCDATA

toString() - Method in class org.dom4j.tree.AbstractComment

toString() - Method in class org.dom4j.tree.AbstractDocument

toString() - Method in class org.dom4j.tree.AbstractDocumentType

toString() - Method in class org.dom4j.tree.AbstractElement

toString() - Method in class org.dom4j.tree.AbstractEntity

toString() - Method in class org.dom4j.tree.AbstractProcessingInstruction

toString(Map) - Method in class org.dom4j.tree.AbstractProcessingInstruction
This will convert the Map to a string representation.
toString() - Method in class org.dom4j.tree.AbstractText

toString() - Method in class org.dom4j.tree.ConcurrentReaderHashMap.Entry

toString() - Method in class org.dom4j.tree.NamespaceStack

toString() - Method in class org.dom4j.util.UserDataElement

toString() - Method in class org.dom4j.xpath.DefaultXPath

toString() - Method in class org.dom4j.xpath.XPathPattern

translateNamespacePrefixToUri(String) - Method in class org.dom4j.xpath.DefaultNamespaceContext

U

UNKNOWN_NODE - Static variable in interface org.dom4j.Node
Does not match any valid node
USE_STRINGVALUE_SEPARATOR - Static variable in class org.dom4j.tree.AbstractElement

UserDataAttribute - class org.dom4j.util.UserDataAttribute.
UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataAttribute.setData(Object)will get and set the values of a user data object.
UserDataAttribute(QName) - Constructor for class org.dom4j.util.UserDataAttribute

UserDataAttribute(QName, String) - Constructor for class org.dom4j.util.UserDataAttribute

UserDataDocumentFactory - class org.dom4j.util.UserDataDocumentFactory.
UserDataDocumentFactory is a factory of XML objects which support the adornment of a user data object on an Element or Attribute instance such that the methods getData() and setData() will get and set the values of a user data object.
UserDataDocumentFactory() - Constructor for class org.dom4j.util.UserDataDocumentFactory

UserDataElement - class org.dom4j.util.UserDataElement.
UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.
UserDataElement(String) - Constructor for class org.dom4j.util.UserDataElement

UserDataElement(QName) - Constructor for class org.dom4j.util.UserDataElement

unparsedEntityDecl(String, String, String, String) - Method in class org.dom4j.io.SAXContentHandler
Receive notification of an unparsed entity declaration event.
unparsedEntityDecl(String, String, String, String) - Method in class org.dom4j.io.XMLWriter

uriPrefix - Variable in class org.dom4j.io.SAXReader.SAXEntityResolver

V

VERBOSE_TOSTRING - Static variable in class org.dom4j.tree.AbstractElement

Visitor - interface org.dom4j.Visitor.
Visitor is used to implement the Visitor pattern in DOM4J.
VisitorSupport - class org.dom4j.VisitorSupport.
VisitorSupport is an abstract base class which is useful for implementation inheritence or when using anonymous inner classes to create simple Visitor implementations.
VisitorSupport() - Constructor for class org.dom4j.VisitorSupport

validate(String) - Method in class org.dom4j.datatype.DatatypeAttribute

validate(String) - Method in class org.dom4j.datatype.DatatypeElement

validate(Document) - Method in class org.dom4j.io.SAXValidator
Validates the given Document by writing it to a validating SAX Parser.
value - Variable in class org.dom4j.tree.ConcurrentReaderHashMap.Entry

value - Variable in class org.dom4j.tree.FlyweightAttribute
The value of the Attribute
valueOf(String) - Method in interface org.dom4j.Node
valueOf evaluates an XPath expression and returns the textual representation of the results the XPath string-value of this node.
valueOf(Object) - Method in interface org.dom4j.XPath
valueOf evaluates this XPath expression and returns the textual representation of the results using the XPath string() function.
valueOf(String) - Method in class org.dom4j.tree.AbstractNode

valueOf(Object) - Method in class org.dom4j.xpath.DefaultXPath

values - Variable in class org.dom4j.tree.FlyweightProcessingInstruction
The values for the PI in name/value pairs
visit(Document) - Method in interface org.dom4j.Visitor
Visits the given Document
visit(DocumentType) - Method in interface org.dom4j.Visitor
Visits the given DocumentType
visit(Element) - Method in interface org.dom4j.Visitor
Visits the given Element
visit(Attribute) - Method in interface org.dom4j.Visitor
Visits the given Attribute
visit(CDATA) - Method in interface org.dom4j.Visitor
Visits the given CDATA
visit(Comment) - Method in interface org.dom4j.Visitor
Visits the given Comment
visit(Entity) - Method in interface org.dom4j.Visitor
Visits the given Entity
visit(Namespace) - Method in interface org.dom4j.Visitor
Visits the given Namespace
visit(ProcessingInstruction) - Method in interface org.dom4j.Visitor
Visits the given ProcessingInstruction
visit(Text) - Method in interface org.dom4j.Visitor
Visits the given Text
visit(Document) - Method in class org.dom4j.VisitorSupport

visit(DocumentType) - Method in class org.dom4j.VisitorSupport

visit(Element) - Method in class org.dom4j.VisitorSupport

visit(Attribute) - Method in class org.dom4j.VisitorSupport

visit(CDATA) - Method in class org.dom4j.VisitorSupport

visit(Comment) - Method in class org.dom4j.VisitorSupport

visit(Entity) - Method in class org.dom4j.VisitorSupport

visit(Namespace) - Method in class org.dom4j.VisitorSupport

visit(ProcessingInstruction) - Method in class org.dom4j.VisitorSupport

visit(Text) - Method in class org.dom4j.VisitorSupport

W

WARNING_QNAME - Static variable in class org.dom4j.util.XMLErrorHandler

warning(SAXParseException) - Method in class org.dom4j.io.SAXContentHandler
This method is called when a warning occurs during the parsing of the document.
warning(SAXParseException) - Method in class org.dom4j.util.XMLErrorHandler

write(Writer) - Method in interface org.dom4j.Node
write writes this node as the default XML notation for this node.
write(Document) - Method in class org.dom4j.io.DOMWriter

write(Document, DOMImplementation) - Method in class org.dom4j.io.DOMWriter

write(Node) - Method in class org.dom4j.io.SAXWriter
A polymorphic method to write any Node to this SAX stream
write(Document) - Method in class org.dom4j.io.SAXWriter
Generates SAX events for the given Document and all its content
write(Element) - Method in class org.dom4j.io.SAXWriter
Generates SAX events for the given Element and all its content
write(String) - Method in class org.dom4j.io.SAXWriter
Generates SAX events for the given text
write(CDATA) - Method in class org.dom4j.io.SAXWriter
Generates SAX events for the given CDATA
write(Comment) - Method in class org.dom4j.io.SAXWriter
Generates SAX events for the given Comment
write(Entity) - Method in class org.dom4j.io.SAXWriter
Generates SAX events for the given Entity
write(ProcessingInstruction) - Method in class org.dom4j.io.SAXWriter
Generates SAX events for the given ProcessingInstruction
write(Element, NamespaceStack) - Method in class org.dom4j.io.SAXWriter

write(Attribute) - Method in class org.dom4j.io.XMLWriter
Writes the given Attribute.
write(Document) - Method in class org.dom4j.io.XMLWriter
This will print the Document to the current Writer.
write(Element) - Method in class org.dom4j.io.XMLWriter
Writes the Element, including its Attribute s, and its value, and all its content (child nodes) to the current Writer.
write(CDATA) - Method in class org.dom4j.io.XMLWriter
Writes the given CDATA.
write(Comment) - Method in class org.dom4j.io.XMLWriter
Writes the given Comment.
write(DocumentType) - Method in class org.dom4j.io.XMLWriter
Writes the given DocumentType.
write(Entity) - Method in class org.dom4j.io.XMLWriter
Writes the given Entity.
write(Namespace) - Method in class org.dom4j.io.XMLWriter
Writes the given Namespace.
write(ProcessingInstruction) - Method in class org.dom4j.io.XMLWriter
Writes the given ProcessingInstruction.
write(String) - Method in class org.dom4j.io.XMLWriter
Print out a String, Perfoms the necessary entity escaping and whitespace stripping.
write(Text) - Method in class org.dom4j.io.XMLWriter
Writes the given Text.
write(Node) - Method in class org.dom4j.io.XMLWriter
Writes the given Node.
write(Object) - Method in class org.dom4j.io.XMLWriter
Writes the given object which should be a String, a Node or a List of Nodes.
write(Element) - Method in class org.dom4j.jaxb.JAXBWriter
Writes the specified Elementto the document.
write(Writer) - Method in class org.dom4j.tree.AbstractAttribute

write(Writer) - Method in class org.dom4j.tree.AbstractCDATA

write(Writer) - Method in class org.dom4j.tree.AbstractComment

write(Writer) - Method in class org.dom4j.tree.AbstractDocument

write(Writer) - Method in class org.dom4j.tree.AbstractDocumentType

write(Writer) - Method in class org.dom4j.tree.AbstractElement

write(Writer) - Method in class org.dom4j.tree.AbstractEntity

write(Writer) - Method in class org.dom4j.tree.AbstractNode

write(Writer) - Method in class org.dom4j.tree.AbstractProcessingInstruction

write(Writer) - Method in class org.dom4j.tree.AbstractText

writeAttribute(Attribute) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J Attributeto the stream.
writeAttribute(Attribute) - Method in class org.dom4j.io.XMLWriter

writeAttribute(Attributes, int) - Method in class org.dom4j.io.XMLWriter

writeAttributes(Element) - Method in class org.dom4j.io.XMLWriter
Writes the attributes of the given element
writeAttributes(Attributes) - Method in class org.dom4j.io.XMLWriter

writeCDATA(String) - Method in class org.dom4j.io.HTMLWriter

writeCDATA(CDATA) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J CDATAto the event stream.
writeCDATA(String) - Method in class org.dom4j.io.XMLWriter

writeChildNodes(Branch) - Method in class org.dom4j.io.STAXEventWriter
Writes each child node within the provided Branchinstance.
writeClose(String) - Method in class org.dom4j.io.HTMLWriter
Overriden method to not close certain element names to avoid wierd behaviour from browsers for versions up to 5.x
writeClose(Element) - Method in class org.dom4j.io.SAXWriter
Writes the closing tag of an Element
writeClose(Element) - Method in class org.dom4j.io.XMLWriter
Writes the closing tag of an Element
writeClose(String) - Method in class org.dom4j.io.XMLWriter

writeClose(Element) - Method in class org.dom4j.jaxb.JAXBWriter
Writes the closing tag of the specified Elementto the document.
writeCloseElement(Element) - Method in class org.dom4j.jaxb.JAXBWriter
Writes the closing tag of the specified Elementto the document.
writeComment(Comment) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J Commentto the stream.
writeComment(String) - Method in class org.dom4j.io.XMLWriter

writeContent(Branch, NamespaceStack) - Method in class org.dom4j.io.SAXWriter

writeDeclaration() - Method in class org.dom4j.io.HTMLWriter

writeDeclaration() - Method in class org.dom4j.io.XMLWriter
This will write the declaration to the given Writer.
writeDocType(DocumentType) - Method in class org.dom4j.io.XMLWriter

writeDocType(String, String, String) - Method in class org.dom4j.io.XMLWriter

writeDocument(Document) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J Documentnode, and all its contents, to the stream.
writeDocumentType(DocumentType) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J DocumentTypeto the stream.
writeElement(Element) - Method in class org.dom4j.io.HTMLWriter
This override handles any elements that should not remove whitespace, such as <PRE>, <SCRIPT>, <STYLE>, and <TEXTAREA>.
writeElement(Element) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J Elementnode and its children to the stream.
writeElement(Element) - Method in class org.dom4j.io.XMLWriter

writeElement(Element) - Method in class org.dom4j.jaxb.JAXBWriter
Writes the specified Elementto the document.
writeElementContent(Element) - Method in class org.dom4j.io.XMLWriter
Outputs the content of the given element.
writeEmptyElementClose(String) - Method in class org.dom4j.io.HTMLWriter

writeEmptyElementClose(String) - Method in class org.dom4j.io.XMLWriter

writeEntity(Entity) - Method in class org.dom4j.io.HTMLWriter

writeEntity(Entity) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J Entityto the stream.
writeEntity(Entity) - Method in class org.dom4j.io.XMLWriter

writeEntityRef(String) - Method in class org.dom4j.io.XMLWriter

writeEscapeAttributeEntities(String) - Method in class org.dom4j.io.XMLWriter

writeExternal(ObjectOutput) - Method in class org.dom4j.io.SAXEventRecorder

writeNamespace(Element, Namespace) - Method in class org.dom4j.io.DOMWriter

writeNamespace(Namespace) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J Namespaceto the stream.
writeNamespace(Namespace) - Method in class org.dom4j.io.XMLWriter

writeNamespace(String, String) - Method in class org.dom4j.io.XMLWriter
Writes the SAX namepsaces
writeNamespaces() - Method in class org.dom4j.io.XMLWriter
Writes the SAX namepsaces
writeNode(Node) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J Nodeto the stream.
writeNode(Node) - Method in class org.dom4j.io.XMLWriter

writeNodeText(Node) - Method in class org.dom4j.io.XMLWriter
This method is used to write out Nodes that contain text and still allow for xml:space to be handled properly.
writeOpen(Element) - Method in class org.dom4j.io.SAXWriter
Writes the opening tag of an Element, including its Attributes but without its content.
writeOpen(Element) - Method in class org.dom4j.io.XMLWriter
Writes the opening tag of an Element, including its Attributes but without its content.
writeOpen(Element) - Method in class org.dom4j.jaxb.JAXBWriter
Writes the opening tag of the specified Elementto the document.
writeOpenElement(Element) - Method in class org.dom4j.jaxb.JAXBWriter
Writes the opening tag of the specified Elementto the document.
writePrintln() - Method in class org.dom4j.io.XMLWriter
This will print a new line only if the newlines flag was set to true
writeProcessingInstruction(ProcessingInstruction) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J ProcessingInstructionto the stream.
writeProcessingInstruction(ProcessingInstruction) - Method in class org.dom4j.io.XMLWriter

writeString(String) - Method in class org.dom4j.io.HTMLWriter

writeString(String) - Method in class org.dom4j.io.XMLWriter

writeText(Text) - Method in class org.dom4j.io.STAXEventWriter
Writes a DOM4J Textto the stream.
writer - Variable in class org.dom4j.io.XMLWriter
The Writer used to output to

X

XMLErrorHandler - class org.dom4j.util.XMLErrorHandler.
XMLErrorHandler is a SAX ErrorHandlerwhich turns the SAX parsing errors into XML so that the output can be formatted using XSLT or the errors can be included in a SOAP message.
XMLErrorHandler() - Constructor for class org.dom4j.util.XMLErrorHandler

XMLErrorHandler(Element) - Constructor for class org.dom4j.util.XMLErrorHandler

XMLResult - class org.dom4j.io.XMLResult.
XMLResult implements a JAXP SAXResultfor an output stream with support for pretty printing and control over how the XML is formatted.
XMLResult() - Constructor for class org.dom4j.io.XMLResult

XMLResult(Writer) - Constructor for class org.dom4j.io.XMLResult

XMLResult(Writer, OutputFormat) - Constructor for class org.dom4j.io.XMLResult

XMLResult(OutputStream) - Constructor for class org.dom4j.io.XMLResult

XMLResult(OutputStream, OutputFormat) - Constructor for class org.dom4j.io.XMLResult

XMLResult(XMLWriter) - Constructor for class org.dom4j.io.XMLResult

XMLTableColumnDefinition - class org.dom4j.swing.XMLTableColumnDefinition.
XMLTableColumnDefinition a column within a table definition.
XMLTableColumnDefinition() - Constructor for class org.dom4j.swing.XMLTableColumnDefinition

XMLTableColumnDefinition(String, String, int) - Constructor for class org.dom4j.swing.XMLTableColumnDefinition

XMLTableColumnDefinition(String, XPath, int) - Constructor for class org.dom4j.swing.XMLTableColumnDefinition

XMLTableColumnDefinition(XPath, XPath, int) - Constructor for class org.dom4j.swing.XMLTableColumnDefinition

XMLTableDefinition - class org.dom4j.swing.XMLTableDefinition.
XMLTableDefinition represents a table definition based on XPath expression evaluated on an XML document.
XMLTableDefinition() - Constructor for class org.dom4j.swing.XMLTableDefinition

XMLTableModel - class org.dom4j.swing.XMLTableModel.
XMLTableDefinition repro.
XMLTableModel(Element, Object) - Constructor for class org.dom4j.swing.XMLTableModel
Creates a TableModel from an XML table definition document and an XML source
XMLTableModel(Document, Object) - Constructor for class org.dom4j.swing.XMLTableModel
Creates a TableModel from an XML table definition document and an XML source
XMLTableModel(XMLTableDefinition, Object) - Constructor for class org.dom4j.swing.XMLTableModel

XMLWriter - class org.dom4j.io.XMLWriter.
XMLWriter takes a DOM4J tree and formats it to a stream as XML.
XMLWriter(Writer) - Constructor for class org.dom4j.io.XMLWriter

XMLWriter(Writer, OutputFormat) - Constructor for class org.dom4j.io.XMLWriter

XMLWriter() - Constructor for class org.dom4j.io.XMLWriter

XMLWriter(OutputStream) - Constructor for class org.dom4j.io.XMLWriter

XMLWriter(OutputStream, OutputFormat) - Constructor for class org.dom4j.io.XMLWriter

XMLWriter(OutputFormat) - Constructor for class org.dom4j.io.XMLWriter

XML_NAMESPACE - Static variable in class org.dom4j.Namespace
XML Namespace
XPP3Reader - class org.dom4j.io.XPP3Reader.
XPP3Reader is a Reader of DOM4J documents that uses the fast XML Pull Parser 3.x .
XPP3Reader() - Constructor for class org.dom4j.io.XPP3Reader

XPP3Reader(DocumentFactory) - Constructor for class org.dom4j.io.XPP3Reader

XPPReader - class org.dom4j.io.XPPReader.
XPPReader is a Reader of DOM4J documents that uses the fast XML Pull Parser 2.x .
XPPReader() - Constructor for class org.dom4j.io.XPPReader

XPPReader(DocumentFactory) - Constructor for class org.dom4j.io.XPPReader

XPath - interface org.dom4j.XPath.
XPath represents an XPath expression after it has been parsed from a String.
XPathException - exception org.dom4j.XPathException.
XPathException is thrown when an exception occurs while evaluating an XPath expression, usually due to some function throwing an exception.
XPathException(String) - Constructor for class org.dom4j.XPathException

XPathException(String, String) - Constructor for class org.dom4j.XPathException

XPathException(String, Exception) - Constructor for class org.dom4j.XPathException

XPathPattern - class org.dom4j.xpath.XPathPattern.
XPathPattern is an implementation of Pattern which uses an XPath xpath.
XPathPattern(Pattern) - Constructor for class org.dom4j.xpath.XPathPattern

XPathPattern(String) - Constructor for class org.dom4j.xpath.XPathPattern

xmlNode - Variable in class org.dom4j.swing.LeafTreeNode
The dom4j Node which contains the
A B C D E F G H I J K L M N O P Q R S T U V W X
Overview  Package  Class  Use  Tree  Deprecated   Index  Help
 PREV   NEXT FRAMES    NO FRAMES


Overview (dom4j 1.6.1 API)

All Classes

Packages
org.dom4j
org.dom4j.bean
org.dom4j.datatype
org.dom4j.dom
org.dom4j.dtd
org.dom4j.io
org.dom4j.jaxb
org.dom4j.rule
org.dom4j.rule.pattern
org.dom4j.swing
org.dom4j.tree
org.dom4j.util
org.dom4j.xpath
org.dom4j.xpp


(dom4j 1.6.1 API)

The front page has been relocated.Please see:
Frame version
Non-frame version.


Serialized Form (dom4j 1.6.1 API)

Serialized Form

Package org.dom4j

Class org.dom4j.DocumentException extends Exception implements Serializable

Serialized Fields

nestedException

Throwable nestedException
A wrapped Throwable

Class org.dom4j.DocumentFactory extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Serialized Fields

xpathNamespaceURIs

Map xpathNamespaceURIs
Default namespace prefix -> URI mappings for XPath expressions to use

Class org.dom4j.IllegalAddException extends IllegalArgumentException implements Serializable

Class org.dom4j.InvalidXPathException extends IllegalArgumentException implements Serializable

serialVersionUID: 3257009869058881592l

Class org.dom4j.Namespace extends AbstractNode implements Serializable

Serialized Fields

prefix

String prefix
The prefix mapped to this namespace

uri

String uri
The URI for this namespace

hashCode

int hashCode
A cached version of the hashcode for efficiency

Class org.dom4j.QName extends Object implements Serializable

Serialization Methods

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serialized Fields

name

String name
The local name of the element or attribute

qualifiedName

String qualifiedName
The qualified name of the element or attribute

hashCode

int hashCode
A cached version of the hashcode for efficiency

documentFactory

DocumentFactory documentFactory
The document factory used for this QName if specified or null

Class org.dom4j.XPathException extends RuntimeException implements Serializable

Serialized Fields

xpath

String xpath
The XPath expression that caused the exception

Package org.dom4j.bean

Class org.dom4j.bean.BeanAttribute extends AbstractAttribute implements Serializable

Serialized Fields

beanList

BeanAttributeList beanList
The list of Bean attributes

index

int index
The index in the Bean attribute list

Class org.dom4j.bean.BeanDocumentFactory extends DocumentFactory implements Serializable

Class org.dom4j.bean.BeanElement extends DefaultElement implements Serializable

Serialized Fields

bean

Object bean
The JavaBean which defines my attributes

Package org.dom4j.datatype

Class org.dom4j.datatype.DatatypeAttribute extends AbstractAttribute implements Serializable

Serialized Fields

parent

Element parent
The parent Element of the Attribute

qname

QName qname
The QName for this element

datatype

com.sun.msv.datatype.xsd.XSDatatype datatype
The XSDatatype of the Attribute

data

Object data
The data (Object) value of the Attribute

text

String text
The text value of the Attribute

Class org.dom4j.datatype.DatatypeDocumentFactory extends DocumentFactory implements Serializable

Serialized Fields

schemaBuilder

SchemaParser schemaBuilder
The builder of XML Schemas

xmlSchemaReader

SAXReader xmlSchemaReader
reader of XML Schemas

autoLoadSchema

boolean autoLoadSchema
If schemas are automatically loaded when parsing instance documents

Class org.dom4j.datatype.DatatypeElement extends DefaultElement implements Serializable

Serialized Fields

datatype

com.sun.msv.datatype.xsd.XSDatatype datatype
The XSDatatype of the Attribute

data

Object data
The data (Object) value of the Attribute

Class org.dom4j.datatype.DatatypeElementFactory extends DocumentFactory implements Serializable

Serialized Fields

elementQName

QName elementQName

attributeXSDatatypes

Map attributeXSDatatypes
Cache of XSDatatype instances per Attribute QName

childrenXSDatatypes

Map childrenXSDatatypes
Cache of XSDatatype instances per child Element QName

Class org.dom4j.datatype.InvalidSchemaException extends IllegalArgumentException implements Serializable

Package org.dom4j.dom

Class org.dom4j.dom.DOMAttribute extends DefaultAttribute implements Serializable

Class org.dom4j.dom.DOMCDATA extends DefaultCDATA implements Serializable

Class org.dom4j.dom.DOMComment extends DefaultComment implements Serializable

Class org.dom4j.dom.DOMDocument extends DefaultDocument implements Serializable

Class org.dom4j.dom.DOMDocumentFactory extends DocumentFactory implements Serializable

Class org.dom4j.dom.DOMDocumentType extends DefaultDocumentType implements Serializable

Class org.dom4j.dom.DOMElement extends DefaultElement implements Serializable

Class org.dom4j.dom.DOMEntityReference extends DefaultEntity implements Serializable

Class org.dom4j.dom.DOMNamespace extends DefaultNamespace implements Serializable

Class org.dom4j.dom.DOMProcessingInstruction extends DefaultProcessingInstruction implements Serializable

Class org.dom4j.dom.DOMText extends DefaultText implements Serializable

Package org.dom4j.io

Class org.dom4j.io.SAXEventRecorder extends DefaultHandler implements Serializable

serialVersionUID: 1l

Serialization Methods

readExternal

public void readExternal(ObjectInput in)
                  throws ClassNotFoundException,
                         IOException

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException

Class org.dom4j.io.SAXReader.SAXEntityResolver extends Object implements Serializable

Serialized Fields

uriPrefix

String uriPrefix

Package org.dom4j.swing

Class org.dom4j.swing.DocumentTreeModel extends DefaultTreeModel implements Serializable

Serialized Fields

document

Document document
The document for this model

Class org.dom4j.swing.XMLTableColumnDefinition extends Object implements Serializable

Serialized Fields

type

int type
Holds value of property type.

name

String name
Holds value of property name.

xpath

XPath xpath
Holds value of property xpath.

columnNameXPath

XPath columnNameXPath
Holds the XPath used for the column name

Class org.dom4j.swing.XMLTableDefinition extends Object implements Serializable

Serialized Fields

rowXPath

XPath rowXPath
Holds value of property rowXPath.

columns

List columns
The columns to display in this table

columnArray

XMLTableColumnDefinition[] columnArray
integer index array cache

columnNameIndex

Map columnNameIndex
name index cache

variableContext

org.jaxen.VariableContext variableContext
for cross-row variables

rowValue

Object rowValue
stores the current row value for the variableContext

Class org.dom4j.swing.XMLTableModel extends AbstractTableModel implements Serializable

Serialized Fields

definition

XMLTableDefinition definition
Holds value of property definition.

source

Object source
Holds value of property source.

rows

List rows
The rows evaluated from the row XPath expression

Package org.dom4j.tree

Class org.dom4j.tree.AbstractAttribute extends AbstractNode implements Serializable

Class org.dom4j.tree.AbstractBranch extends AbstractNode implements Serializable

Class org.dom4j.tree.AbstractCDATA extends AbstractCharacterData implements Serializable

Class org.dom4j.tree.AbstractCharacterData extends AbstractNode implements Serializable

Class org.dom4j.tree.AbstractComment extends AbstractCharacterData implements Serializable

Class org.dom4j.tree.AbstractDocument extends AbstractBranch implements Serializable

Serialized Fields

encoding

String encoding
The encoding of this document as stated in the XML declaration

Class org.dom4j.tree.AbstractDocumentType extends AbstractNode implements Serializable

Class org.dom4j.tree.AbstractElement extends AbstractBranch implements Serializable

Class org.dom4j.tree.AbstractEntity extends AbstractNode implements Serializable

Class org.dom4j.tree.AbstractNode extends Object implements Serializable

Class org.dom4j.tree.AbstractProcessingInstruction extends AbstractNode implements Serializable

Class org.dom4j.tree.AbstractText extends AbstractCharacterData implements Serializable

Class org.dom4j.tree.BackedList extends ArrayList implements Serializable

Serialized Fields

branchContent

List branchContent
The content of the Branch which is modified if I am modified

branch

AbstractBranch branch
The AbstractBranch instance which owns the content

Class org.dom4j.tree.BaseElement extends AbstractElement implements Serializable

Serialized Fields

qname

QName qname
The QName for this element

parentBranch

Branch parentBranch
Stores the parent branch of this node which is either a Document if this element is the root element in a document, or another Element if it is a child of the root document, or null if it has not been added to a document yet.

content

List content
List of content nodes.

attributes

List attributes
list of attributes

Class org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock extends Object implements Serializable

Class org.dom4j.tree.DefaultAttribute extends FlyweightAttribute implements Serializable

Serialized Fields

parent

Element parent
The parent of this node

Class org.dom4j.tree.DefaultCDATA extends FlyweightCDATA implements Serializable

Serialized Fields

parent

Element parent
The parent of this node

Class org.dom4j.tree.DefaultComment extends FlyweightComment implements Serializable

Serialized Fields

parent

Element parent
The parent of this node

Class org.dom4j.tree.DefaultDocument extends AbstractDocument implements Serializable

Serialized Fields

name

String name
The name of the document

rootElement

Element rootElement
The root element of this document

content

List content
Store the contents of the document as a lazily created List

docType

DocumentType docType
The document type for this document

documentFactory

DocumentFactory documentFactory
The document factory used by default

Class org.dom4j.tree.DefaultDocumentType extends AbstractDocumentType implements Serializable

Serialized Fields

elementName

String elementName
The root element name of the document typ

publicID

String publicID
Holds value of property publicID.

systemID

String systemID
Holds value of property systemID.

internalDeclarations

List internalDeclarations
The internal DTD declarations

externalDeclarations

List externalDeclarations
The external DTD declarations

Class org.dom4j.tree.DefaultElement extends AbstractElement implements Serializable

Serialized Fields

qname

QName qname
The QName for this element

parentBranch

Branch parentBranch
Stores the parent branch of this node which is either a Document if this element is the root element in a document, or another Element if it is a child of the root document, or null if it has not been added to a document yet.

content

Object content
Stores null for no content, a Node for a single content node or a List for multiple content nodes. The List will be lazily constructed when required.

attributes

Object attributes
Lazily constructes list of attributes

Class org.dom4j.tree.DefaultEntity extends FlyweightEntity implements Serializable

Serialized Fields

parent

Element parent
The parent of this node

Class org.dom4j.tree.DefaultNamespace extends Namespace implements Serializable

Serialized Fields

parent

Element parent
The parent of this node

Class org.dom4j.tree.DefaultProcessingInstruction extends FlyweightProcessingInstruction implements Serializable

Serialized Fields

parent

Element parent
The parent of this node

Class org.dom4j.tree.DefaultText extends FlyweightText implements Serializable

Serialized Fields

parent

Element parent
The parent of this node

Class org.dom4j.tree.FlyweightAttribute extends AbstractAttribute implements Serializable

Serialized Fields

qname

QName qname
The QName for this element

value

String value
The value of the Attribute

Class org.dom4j.tree.FlyweightCDATA extends AbstractCDATA implements Serializable

Serialized Fields

text

String text
Text of the CDATA node

Class org.dom4j.tree.FlyweightComment extends AbstractComment implements Serializable

Serialized Fields

text

String text
Text of the Comment node

Class org.dom4j.tree.FlyweightEntity extends AbstractEntity implements Serializable

Serialized Fields

name

String name
The name of the Entity

text

String text
The text of the Entity

Class org.dom4j.tree.FlyweightProcessingInstruction extends AbstractProcessingInstruction implements Serializable

Serialized Fields

target

String target
The target of the PI

text

String text
The values for the PI as a String

values

Map values
The values for the PI in name/value pairs

Class org.dom4j.tree.FlyweightText extends AbstractText implements Serializable

Serialized Fields

text

String text
Text of the Text node

Package org.dom4j.util

Class org.dom4j.util.IndexedDocumentFactory extends DocumentFactory implements Serializable

Class org.dom4j.util.IndexedElement extends DefaultElement implements Serializable

Serialized Fields

elementIndex

Map elementIndex
Lazily constructed index for elements

attributeIndex

Map attributeIndex
Lazily constructed index for attributes

Class org.dom4j.util.NonLazyDocumentFactory extends DocumentFactory implements Serializable

Class org.dom4j.util.NonLazyElement extends BaseElement implements Serializable

Class org.dom4j.util.UserDataAttribute extends DefaultAttribute implements Serializable

Serialized Fields

data

Object data
The user data object

Class org.dom4j.util.UserDataDocumentFactory extends DocumentFactory implements Serializable

Class org.dom4j.util.UserDataElement extends DefaultElement implements Serializable

Serialized Fields

data

Object data
The user data object

Package org.dom4j.xpath

Class org.dom4j.xpath.DefaultNamespaceContext extends Object implements Serializable

Serialized Fields

element

Element element

Class org.dom4j.xpath.DefaultXPath extends Object implements Serializable

Serialized Fields

text

String text

xpath

org.jaxen.XPath xpath

namespaceContext

org.jaxen.NamespaceContext namespaceContext

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j (dom4j 1.6.1 API)

 org.dom4j
Interfaces
Attribute
Branch
CDATA
CharacterData
Comment
Document
DocumentType
Element
ElementHandler
ElementPath
Entity
Node
NodeFilter
ProcessingInstruction
Text
Visitor
XPath
Classes
DocumentFactory
DocumentHelper
Namespace
QName
VisitorSupport
Exceptions
DocumentException
IllegalAddException
InvalidXPathException
XPathException


org.dom4j.bean (dom4j 1.6.1 API)

 org.dom4j.bean
Classes
BeanAttribute
BeanAttributeList
BeanDocumentFactory
BeanElement
BeanMetaData


Uses of Class org.dom4j.bean.BeanAttribute (dom4j 1.6.1 API)

Uses of Class
org.dom4j.bean.BeanAttribute

Packages that use BeanAttribute
org.dom4j.bean An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.

Uses of BeanAttribute in org.dom4j.bean

Methods in org.dom4j.bean that return BeanAttribute
BeanAttribute | BeanAttributeList.attribute(int index)
protected BeanAttribute | BeanAttributeList.createAttribute(BeanElement element, int index)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.bean.BeanAttributeList (dom4j 1.6.1 API)

Uses of Class
org.dom4j.bean.BeanAttributeList

Packages that use BeanAttributeList
org.dom4j.bean An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.

Uses of BeanAttributeList in org.dom4j.bean

Methods in org.dom4j.bean that return BeanAttributeList
BeanAttributeList | BeanMetaData.createAttributeList(BeanElement parent)
protected BeanAttributeList | BeanElement.getBeanAttributeList()

Constructors in org.dom4j.bean with parameters of type BeanAttributeList
BeanAttribute(BeanAttributeList beanList, int index)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.bean.BeanDocumentFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.bean.BeanDocumentFactory

No usage of org.dom4j.bean.BeanDocumentFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.bean.BeanElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.bean.BeanElement

Packages that use BeanElement
org.dom4j.bean An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.

Uses of BeanElement in org.dom4j.bean

Methods in org.dom4j.bean that return BeanElement
 BeanElement BeanAttributeList.getParent()

Methods in org.dom4j.bean with parameters of type BeanElement
BeanAttributeList | BeanMetaData.createAttributeList(BeanElement parent)
protected BeanAttribute | BeanAttributeList.createAttribute(BeanElement element, int index)

Constructors in org.dom4j.bean with parameters of type BeanElement
BeanAttributeList(BeanElement parent, BeanMetaData beanMetaData)
BeanAttributeList(BeanElement parent)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.bean.BeanMetaData (dom4j 1.6.1 API)

Uses of Class
org.dom4j.bean.BeanMetaData

Packages that use BeanMetaData
org.dom4j.bean An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.

Uses of BeanMetaData in org.dom4j.bean

Methods in org.dom4j.bean that return BeanMetaData
static BeanMetaData BeanMetaData.get(Class beanClass)
Static helper method to find and cache meta data objects for bean types

Constructors in org.dom4j.bean with parameters of type BeanMetaData
BeanAttributeList(BeanElement parent, BeanMetaData beanMetaData)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Attribute (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Attribute

Packages that use Attribute
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of Attribute in org.dom4j

Methods in org.dom4j that return Attribute
Attribute | Element.attribute(int index) Returns the attribute at the specified indexGets the
Attribute | Element.attribute(String name) Returns the attribute with the given name
Attribute | Element.attribute(QName qName) DOCUMENT ME!
static Attribute | DocumentHelper.createAttribute(Element owner, QName qname, String value)
static Attribute | DocumentHelper.createAttribute(Element owner, String name, String value)
Attribute | DocumentFactory.createAttribute(Element owner, QName qname, String value)
Attribute | DocumentFactory.createAttribute(Element owner, String name, String value)

Methods in org.dom4j with parameters of type Attribute
void | VisitorSupport.visit(Attribute node)
void | Visitor.visit(Attribute node) Visits the given Attribute
void | Element.add(Attribute attribute) Adds the given Attribute to this element.
boolean | Element.remove(Attribute attribute) Removes the given Attribute from this element.

Uses of Attribute in org.dom4j.bean

Classes in org.dom4j.bean that implement Attribute
 class BeanAttribute
BeanAttribute represents a mutable XML attribute which is backed by a property of the JavaBean of its parent element.

Methods in org.dom4j.bean that return Attribute
Attribute | BeanElement.attribute(String name)
Attribute | BeanElement.attribute(QName qname)
Attribute | BeanDocumentFactory.createAttribute(Element owner, QName qname, String value)
Attribute | BeanAttributeList.attribute(String name)
Attribute | BeanAttributeList.attribute(QName qname)

Uses of Attribute in org.dom4j.datatype

Classes in org.dom4j.datatype that implement Attribute
 class DatatypeAttribute
DatatypeAttribute represents an Attribute which supports the XML Schema Data Types specification.

Methods in org.dom4j.datatype that return Attribute
Attribute | DatatypeElementFactory.createAttribute(Element owner, QName qname, String value)
Attribute | DatatypeDocumentFactory.createAttribute(Element owner, QName qname, String value)

Uses of Attribute in org.dom4j.dom

Classes in org.dom4j.dom that implement Attribute
 class DOMAttribute
DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.

Methods in org.dom4j.dom that return Attribute
protected Attribute | DOMElement.attribute(Attr attr)
protected Attribute | DOMElement.attribute(String namespaceURI, String localName)
protected Attribute | DOMElement.createAttribute(Attr newAttr)
Attribute | DOMDocumentFactory.createAttribute(Element owner, QName qname, String value)

Uses of Attribute in org.dom4j.io

Methods in org.dom4j.io that return Attribute
Attribute | STAXEventReader.readAttribute(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Attribute from the provided event stream.
Attribute | STAXEventReader.createAttribute(Element elem, javax.xml.stream.events.Attribute attr) Constructs a new DOM4J Attribute from the provided StAX Attribute event.

Methods in org.dom4j.io with parameters of type Attribute
void | XMLWriter.write(Attribute attribute) Writes the given Attribute.
protected void | XMLWriter.writeAttribute(Attribute attribute)
void | STAXEventWriter.writeAttribute(Attribute attr) Writes a DOM4J Attributeto the stream.
javax.xml.stream.events.Attribute | STAXEventWriter.createAttribute(Attribute attr) Constructs a STAX Attributeevent from a DOM4J Attribute.

Uses of Attribute in org.dom4j.tree

Classes in org.dom4j.tree that implement Attribute
class | AbstractAttribute AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultAttribute DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.
class | FlyweightAttribute FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.

Methods in org.dom4j.tree that return Attribute
Attribute | DefaultElement.attribute(int index)
Attribute | DefaultElement.attribute(String name)
Attribute | DefaultElement.attribute(QName qName)
Attribute | DefaultElement.attribute(String name, Namespace namespace)
Attribute | AbstractElement.attribute(int index)
Attribute | AbstractElement.attribute(String name)
Attribute | AbstractElement.attribute(QName qName)
Attribute | AbstractElement.attribute(String name, Namespace namespace)

Methods in org.dom4j.tree with parameters of type Attribute
void | DefaultElement.add(Attribute attribute)
boolean | DefaultElement.remove(Attribute attribute)
void | AbstractElement.add(Attribute attribute)
boolean | AbstractElement.remove(Attribute attribute)

Uses of Attribute in org.dom4j.util

Classes in org.dom4j.util that implement Attribute
 class UserDataAttribute
UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataAttribute.setData(Object)will get and set the values of a user data object.

Methods in org.dom4j.util that return Attribute
Attribute | UserDataDocumentFactory.createAttribute(Element owner, QName qname, String value)
Attribute | ProxyDocumentFactory.createAttribute(Element owner, QName qname, String value)
Attribute | ProxyDocumentFactory.createAttribute(Element owner, String name, String value)
Attribute | IndexedElement.attribute(String name)
Attribute | IndexedElement.attribute(QName qName)

Methods in org.dom4j.util with parameters of type Attribute
int | NodeComparator.compare(Attribute n1, Attribute n2)
protected void | IndexedElement.addToAttributeIndex(Attribute attribute)
protected void | IndexedElement.addToAttributeIndex(Object key, Attribute value)
protected void | IndexedElement.removeFromAttributeIndex(Attribute attribute)
protected void | IndexedElement.removeFromAttributeIndex(Object key, Attribute value)
protected static boolean | AttributeHelper.booleanValue(Attribute attribute)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Branch (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Branch

Packages that use Branch
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.swing | A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of Branch in org.dom4j

Subinterfaces of Branch in org.dom4j
interface | Document Document defines an XML Document.
interface | Element Element interface defines an XML element.

Methods in org.dom4j with parameters of type Branch
static Element | DocumentHelper.makeElement(Branch source, String path) makeElement a helper method which navigates from the given Document or Element node to some Element using the path expression, creating any necessary elements along the way.
void | Branch.appendContent(Branch branch) Appends the content of the given branch to this branch instance.

Constructors in org.dom4j with parameters of type Branch
IllegalAddException(Branch parent, Node node, String reason)

Uses of Branch in org.dom4j.bean

Classes in org.dom4j.bean that implement Branch
 class BeanElement
BeanElement uses a Java Bean to store its attributes.

Uses of Branch in org.dom4j.datatype

Classes in org.dom4j.datatype that implement Branch
 class DatatypeElement
DatatypeElement represents an Element which supports the XML Schema Data Types specification.

Uses of Branch in org.dom4j.dom

Classes in org.dom4j.dom that implement Branch
class | DOMDocument DOMDocument implements an XML document which supports the W3C DOM API.
class | DOMElement DOMElement implements an XML element which supports the W3C DOM API.

Methods in org.dom4j.dom with parameters of type Branch
static void | DOMNodeHelper.appendElementsByTagName(List list, Branch parent, String name)
static void | DOMNodeHelper.appendElementsByTagNameNS(List list, Branch parent, String namespace, String localName)

Uses of Branch in org.dom4j.io

Methods in org.dom4j.io with parameters of type Branch
void | STAXEventWriter.writeChildNodes(Branch branch) Writes each child node within the provided Branchinstance.
protected void | SAXWriter.writeContent(Branch branch, NamespaceStack namespaceStack)
protected void | DOMReader.readTree(Node node, Branch current)
protected void | DOMReader.readElement(Node node, Branch current)

Uses of Branch in org.dom4j.swing

Methods in org.dom4j.swing that return Branch
protected  Branch BranchTreeNode.getXmlBranch()

Constructors in org.dom4j.swing with parameters of type Branch
BranchTreeNode(Branch xmlNode)
BranchTreeNode(TreeNode parent, Branch xmlNode)

Uses of Branch in org.dom4j.tree

Classes in org.dom4j.tree that implement Branch
class | AbstractBranch AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractDocument AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractElement AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
class | BaseElement BaseElement is a useful base class for implemementation inheritence of an XML element.
class | DefaultDocument DefaultDocument is the default DOM4J default implementation of an XML document.
class | DefaultElement DefaultElement is the default DOM4J default implementation of an XML element.

Methods in org.dom4j.tree with parameters of type Branch
 void AbstractBranch.appendContent(Branch branch)

Uses of Branch in org.dom4j.util

Classes in org.dom4j.util that implement Branch
class | IndexedElement IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
class | NonLazyElement NonLazyElement is the default DOM4J default implementation of an XML element.
class | UserDataElement UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.

Methods in org.dom4j.util with parameters of type Branch
 int NodeComparator.compareContent(Branch b1, Branch b2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.CDATA (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.CDATA

Packages that use CDATA
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of CDATA in org.dom4j

Methods in org.dom4j that return CDATA
static CDATA | DocumentHelper.createCDATA(String text)
CDATA | DocumentFactory.createCDATA(String text)

Methods in org.dom4j with parameters of type CDATA
void | VisitorSupport.visit(CDATA node)
void | Visitor.visit(CDATA node) Visits the given CDATA
void | Element.add(CDATA cdata) Adds the given CDATA to this element.
boolean | Element.remove(CDATA cdata) Removes the given CDATA if the node is an immediate child of this element.

Uses of CDATA in org.dom4j.dom

Classes in org.dom4j.dom that implement CDATA
 class DOMCDATA
DOMCDATA implements a CDATA Section which supports the W3C DOM API.

Methods in org.dom4j.dom that return CDATA
CDATA | DOMDocumentFactory.createCDATA(String text)
protected CDATA | DOMCDATA.createCDATA(String text)

Uses of CDATA in org.dom4j.io

Methods in org.dom4j.io with parameters of type CDATA
void | XMLWriter.write(CDATA cdata) Writes the given CDATA.
void | STAXEventWriter.writeCDATA(CDATA cdata) Writes a DOM4J CDATAto the event stream.
javax.xml.stream.events.Characters | STAXEventWriter.createCharacters(CDATA cdata) Constructs a STAX Charactersevent from a DOM4J CDATA.
void | SAXWriter.write(CDATA cdata) Generates SAX events for the given CDATA
protected void | DOMWriter.appendDOMTree(Document domDocument, Node domCurrent, CDATA cdata)

Uses of CDATA in org.dom4j.tree

Classes in org.dom4j.tree that implement CDATA
class | AbstractCDATA AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultCDATA DefaultCDATA is the default CDATA implementation.
class | FlyweightCDATA FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.

Methods in org.dom4j.tree with parameters of type CDATA
void | AbstractElement.add(CDATA cdata)
boolean | AbstractElement.remove(CDATA cdata)

Uses of CDATA in org.dom4j.util

Methods in org.dom4j.util that return CDATA
 CDATA ProxyDocumentFactory.createCDATA(String text)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.CharacterData (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.CharacterData

Packages that use CharacterData
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of CharacterData in org.dom4j

Subinterfaces of CharacterData in org.dom4j
interface | CDATA CDATA defines an XML CDATA section.
interface | Comment Comment defines the behavior of an XML comment.
interface | Text Text defines an XML Text node.

Uses of CharacterData in org.dom4j.dom

Classes in org.dom4j.dom that implement CharacterData
class | DOMCDATA DOMCDATA implements a CDATA Section which supports the W3C DOM API.
class | DOMComment DOMText implements a Text node which supports the W3C DOM API.
class | DOMText DOMText implements a Text node which supports the W3C DOM API.

Methods in org.dom4j.dom with parameters of type CharacterData
static String | DOMNodeHelper.getData(CharacterData charData)
static void | DOMNodeHelper.setData(CharacterData charData, String data)
static int | DOMNodeHelper.getLength(CharacterData charData)
static String | DOMNodeHelper.substringData(CharacterData charData, int offset, int count)
static void | DOMNodeHelper.appendData(CharacterData charData, String arg)
static void | DOMNodeHelper.insertData(CharacterData data, int offset, String arg)
static void | DOMNodeHelper.deleteData(CharacterData charData, int offset, int count)
static void | DOMNodeHelper.replaceData(CharacterData charData, int offset, int count, String arg)
static Text | DOMNodeHelper.asDOMText(CharacterData text)

Uses of CharacterData in org.dom4j.io

Methods in org.dom4j.io that return CharacterData
CharacterData | STAXEventReader.readCharacters(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Text or CDATA section from the provided event stream.
CharacterData | STAXEventReader.createCharacterData(javax.xml.stream.events.Characters characters) Constructs a new DOM4J Text or CDATA object from the provided Characters event.

Uses of CharacterData in org.dom4j.tree

Classes in org.dom4j.tree that implement CharacterData
class | AbstractCDATA AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractCharacterData AbstractCharacterData is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractComment AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractText AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultCDATA DefaultCDATA is the default CDATA implementation.
class | DefaultComment DefaultComment is the default Comment implementation.
class | DefaultText DefaultText is the default Text implementation.
class | FlyweightCDATA FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.
class | FlyweightComment FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.
class | FlyweightText FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.

Uses of CharacterData in org.dom4j.util

Methods in org.dom4j.util with parameters of type CharacterData
 int NodeComparator.compare(CharacterData t1, CharacterData t2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Comment (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Comment

Packages that use Comment
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of Comment in org.dom4j

Methods in org.dom4j that return Comment
static Comment | DocumentHelper.createComment(String text)
Comment | DocumentFactory.createComment(String text)

Methods in org.dom4j with parameters of type Comment
void | VisitorSupport.visit(Comment node)
void | Visitor.visit(Comment node) Visits the given Comment
void | Branch.add(Comment comment) Adds the given Comment to this branch.
boolean | Branch.remove(Comment comment) Removes the given Comment if the node is an immediate child of this branch.

Uses of Comment in org.dom4j.dom

Classes in org.dom4j.dom that implement Comment
 class DOMComment
DOMText implements a Text node which supports the W3C DOM API.

Methods in org.dom4j.dom that return Comment
 Comment DOMDocumentFactory.createComment(String text)

Uses of Comment in org.dom4j.io

Methods in org.dom4j.io that return Comment
Comment | STAXEventReader.readComment(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Comment from the provided event stream.
Comment | STAXEventReader.createComment(javax.xml.stream.events.Comment comment) Constructs a new DOM4J Comment from the provided StAX Comment event.

Methods in org.dom4j.io with parameters of type Comment
void | XMLWriter.write(Comment comment) Writes the given Comment.
void | STAXEventWriter.writeComment(Comment comment) Writes a DOM4J Commentto the stream.
javax.xml.stream.events.Comment | STAXEventWriter.createComment(Comment comment) Constructs a STAX Commentevent from a DOM4J Comment.
void | SAXWriter.write(Comment comment) Generates SAX events for the given Comment
protected void | DOMWriter.appendDOMTree(Document domDocument, Node domCurrent, Comment comment)

Uses of Comment in org.dom4j.tree

Classes in org.dom4j.tree that implement Comment
class | AbstractComment AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultComment DefaultComment is the default Comment implementation.
class | FlyweightComment FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.

Methods in org.dom4j.tree with parameters of type Comment
void | AbstractElement.add(Comment comment)
boolean | AbstractElement.remove(Comment comment)
void | AbstractBranch.add(Comment comment)
boolean | AbstractBranch.remove(Comment comment)

Uses of Comment in org.dom4j.util

Methods in org.dom4j.util that return Comment
 Comment ProxyDocumentFactory.createComment(String text)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Document (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Document

Packages that use Document
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.jaxb |
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.swing | A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of Document in org.dom4j

Methods in org.dom4j that return Document
Document | Node.getDocument() getDocument returns the Document that this Node is part of if this node supports the parent relationship.
static Document | DocumentHelper.createDocument()
static Document | DocumentHelper.createDocument(Element rootElement)
static Document | DocumentHelper.parseText(String text) parseText parses the given text as an XML document and returns the newly created Document.
Document | DocumentFactory.createDocument()
Document | DocumentFactory.createDocument(String encoding) DOCUMENT ME!
Document | DocumentFactory.createDocument(Element rootElement)
Document | Document.addComment(String comment) Adds a new Comment node with the given text to this branch.
Document | Document.addProcessingInstruction(String target, String text) Adds a processing instruction for the given target
Document | Document.addProcessingInstruction(String target, Map data) Adds a processing instruction for the given target
Document | Document.addDocType(String name, String publicId, String systemId) Adds a DOCTYPE declaration to this document

Methods in org.dom4j with parameters of type Document
void | VisitorSupport.visit(Document document)
void | Visitor.visit(Document document) Visits the given Document
void | Node.setDocument(Document document) setDocument sets the document of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.

Uses of Document in org.dom4j.datatype

Methods in org.dom4j.datatype with parameters of type Document
void | SchemaParser.build(Document schemaDocument) Parses the given schema document
void | SchemaParser.build(Document schemaDocument, Namespace namespace)
void | DatatypeDocumentFactory.loadSchema(Document schemaDocument) Loads the given XML Schema document into this factory so schema-aware Document, Elements and Attributes will be created by this factory.
void | DatatypeDocumentFactory.loadSchema(Document schemaDocument, Namespace targetNamespace)
protected void | DatatypeDocumentFactory.loadSchema(Document document, String schemaInstanceURI)
protected void | DatatypeDocumentFactory.loadSchema(Document document, String schemaInstanceURI, Namespace namespace)

Uses of Document in org.dom4j.dom

Classes in org.dom4j.dom that implement Document
 class DOMDocument
DOMDocument implements an XML document which supports the W3C DOM API.

Methods in org.dom4j.dom that return Document
 Document DOMDocumentFactory.createDocument()

Methods in org.dom4j.dom with parameters of type Document
static Document DOMNodeHelper.asDOMDocument(Document document)

Uses of Document in org.dom4j.io

Methods in org.dom4j.io that return Document
Document | XPPReader.read(File file) Reads a Document from the given File
Document | XPPReader.read(URL url) Reads a Document from the given URL
Document | XPPReader.read(String systemID) Reads a Document from the given URL or filename.
Document | XPPReader.read(InputStream in) Reads a Document from the given stream
Document | XPPReader.read(Reader reader) Reads a Document from the given Reader
Document | XPPReader.read(char[] text) Reads a Document from the given array of characters
Document | XPPReader.read(InputStream in, String systemID) Reads a Document from the given stream
Document | XPPReader.read(Reader reader, String systemID) Reads a Document from the given Reader
protected Document | XPPReader.parseDocument()
Document | XPP3Reader.read(File file) Reads a Document from the given File
Document | XPP3Reader.read(URL url) Reads a Document from the given URL
Document | XPP3Reader.read(String systemID) Reads a Document from the given URL or filename.
Document | XPP3Reader.read(InputStream in) Reads a Document from the given stream
Document | XPP3Reader.read(Reader reader) Reads a Document from the given Reader
Document | XPP3Reader.read(char[] text) Reads a Document from the given array of characters
Document | XPP3Reader.read(InputStream in, String systemID) Reads a Document from the given stream
Document | XPP3Reader.read(Reader reader, String systemID) Reads a Document from the given Reader
protected Document | XPP3Reader.parseDocument()
Document | STAXEventReader.readDocument(InputStream is) Constructs a StAX event stream from the provided I/O stream and reads a DOM4J document from it.
Document | STAXEventReader.readDocument(Reader reader) Constructs a StAX event stream from the provided I/O character stream and reads a DOM4J document from it.
Document | STAXEventReader.readDocument(InputStream is, String systemId) Constructs a StAX event stream from the provided I/O stream and reads a DOM4J document from it.
Document | STAXEventReader.readDocument(Reader reader, String systemId) Constructs a StAX event stream from the provided I/O character stream and reads a DOM4J document from it.
Document | STAXEventReader.readDocument(javax.xml.stream.XMLEventReader reader) Reads a DOM4J Documentfrom the provided stream.
Document | SAXReader.read(File file) Reads a Document from the given File
Document | SAXReader.read(URL url) Reads a Document from the given URL using SAX
Document | SAXReader.read(String systemId) Reads a Document from the given URL or filename using SAX.
Document | SAXReader.read(InputStream in) Reads a Document from the given stream using SAX
Document | SAXReader.read(Reader reader) Reads a Document from the given Reader using SAX
Document | SAXReader.read(InputStream in, String systemId) Reads a Document from the given stream using SAX
Document | SAXReader.read(Reader reader, String systemId) Reads a Document from the given Reader using SAX
Document | SAXReader.read(InputSource in) Reads a Document from the given InputSource using SAX
Document | SAXModifier.modify(File source) Reads a Document from the given Fileand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(InputSource source) Reads a Document from the given InputSourceand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(InputStream source) Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(InputStream source, String systemId) Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(Reader source) Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(Reader source, String systemId) Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(URL source) Reads a Document from the given URLand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(String source) Reads a Document from the given URL or filename and writes it to the specified XMLWriterusing SAX.
Document | SAXContentHandler.getDocument() DOCUMENT ME!
protected Document | SAXContentHandler.createDocument() DOCUMENT ME!
Document | DOMReader.read(Document domDocument)
protected Document | DOMReader.createDocument()
Document | DocumentSource.getDocument() DOCUMENT ME!
Document | DocumentResult.getDocument() DOCUMENT ME!

Methods in org.dom4j.io with parameters of type Document
void | XMLWriter.write(Document doc) This will print the Document to the current Writer.
void | STAXEventWriter.writeDocument(Document doc) Writes a DOM4J Documentnode, and all its contents, to the stream.
javax.xml.stream.events.StartDocument | STAXEventWriter.createStartDocument(Document doc) Constructs a STAX StartDocumentevent from a DOM4J Document.
javax.xml.stream.events.EndDocument | STAXEventWriter.createEndDocument(Document doc) Constructs a STAX EndDocumentevent from a DOM4J Document.
void | SAXWriter.write(Document document) Generates SAX events for the given Document and all its content
protected void | SAXWriter.documentLocator(Document document) The Locatoris only really useful when parsing a textual document as its main purpose is to identify the line and column number.
protected void | SAXWriter.entityResolver(Document document)
protected void | SAXWriter.dtdHandler(Document document) We do not yet support DTD or XML Schemas so this method does nothing right now.
void | SAXValidator.validate(Document document) Validates the given Document by writing it to a validating SAX Parser.
Document | DOMWriter.write(Document document)
Document | DOMWriter.write(Document document, DOMImplementation domImpl)
protected Document | DOMWriter.createDomDocument(Document document)
protected Document | DOMWriter.createDomDocument(Document document, DOMImplementation domImpl)
void | DocumentSource.setDocument(Document document) Sets the document used as the JAXP SAXSource

Constructors in org.dom4j.io with parameters of type Document
DocumentSource(Document document)
Creates a JAXP SAXSourcefor the given Document.

Uses of Document in org.dom4j.jaxb

Methods in org.dom4j.jaxb that return Document
Document | JAXBReader.read(File source) Parses the specified File
Document | JAXBReader.read(File file, java.nio.charset.Charset charset) Parses the specified File, using the given Charset.
Document | JAXBReader.read(InputSource source) Parses the specified InputSource
Document | JAXBReader.read(InputStream source) Parses the specified InputStream
Document | JAXBReader.read(InputStream source, String systemId) Parses the specified InputStream
Document | JAXBReader.read(Reader source) Parses the specified Reader
Document | JAXBReader.read(Reader source, String systemId) Parses the specified Reader
Document | JAXBReader.read(String source) Parses the the given URL or filename.
Document | JAXBReader.read(URL source) Parses the the given URL.
Document | JAXBModifier.modify(File source) Parses the specified Filewith SAX
Document | JAXBModifier.modify(File source, java.nio.charset.Charset charset) Parses the specified Filewith SAX, using the given Charset.
Document | JAXBModifier.modify(InputSource source) Parses the specified InputSourcewith SAX.
Document | JAXBModifier.modify(InputStream source) Parses the specified InputStreamwith SAX.
Document | JAXBModifier.modify(InputStream source, String systemId) Parses the specified InputStreamwith SAX.
Document | JAXBModifier.modify(Reader r) Parses the specified Readerwith SAX.
Document | JAXBModifier.modify(Reader source, String systemId) Parses the specified Readerwith SAX.
Document | JAXBModifier.modify(String url) Parses the the given URL or filename.
Document | JAXBModifier.modify(URL source) Parses the the given URL.

Uses of Document in org.dom4j.rule

Methods in org.dom4j.rule with parameters of type Document
 void Mode.applyTemplates(Document document)

Uses of Document in org.dom4j.swing

Fields in org.dom4j.swing declared as Document
protected  Document DocumentTreeModel.document
The document for this model

Methods in org.dom4j.swing that return Document
 Document DocumentTreeModel.getDocument()
DOCUMENT ME!

Methods in org.dom4j.swing with parameters of type Document
static XMLTableDefinition | XMLTableDefinition.load(Document definition) Loads an XML table definition from an XML definition document
void | DocumentTreeModel.setDocument(Document document) Sets the Document instance that this TreeModel is based on

Constructors in org.dom4j.swing with parameters of type Document
XMLTableModel(Document tableDefinition, Object source)
Creates a TableModel from an XML table definition document and an XML source
DocumentTreeModel(Document document)

Uses of Document in org.dom4j.tree

Classes in org.dom4j.tree that implement Document
class | AbstractDocument AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultDocument DefaultDocument is the default DOM4J default implementation of an XML document.

Methods in org.dom4j.tree that return Document
Document | DefaultElement.getDocument()
Document | DefaultDocument.addDocType(String docTypeName, String publicId, String systemId)
Document | BaseElement.getDocument()
Document | AbstractNode.getDocument()
Document | AbstractDocument.getDocument()
Document | AbstractDocument.addComment(String comment)
Document | AbstractDocument.addProcessingInstruction(String target, String data)
Document | AbstractDocument.addProcessingInstruction(String target, Map data)

Methods in org.dom4j.tree with parameters of type Document
void | DefaultElement.setDocument(Document document)
void | BaseElement.setDocument(Document document)
void | AbstractNode.setDocument(Document document)

Uses of Document in org.dom4j.util

Methods in org.dom4j.util that return Document
Document | ProxyDocumentFactory.createDocument()
Document | ProxyDocumentFactory.createDocument(Element rootElement)

Methods in org.dom4j.util with parameters of type Document
 int NodeComparator.compare(Document n1, Document n2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.DocumentException (dom4j 1.6.1 API)

Uses of Class
org.dom4j.DocumentException

Packages that use DocumentException
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.jaxb |

Uses of DocumentException in org.dom4j

Methods in org.dom4j that throw DocumentException
static Document DocumentHelper.parseText(String text)
parseText parses the given text as an XML document and returns the newly created Document.

Uses of DocumentException in org.dom4j.io

Methods in org.dom4j.io that throw DocumentException
Document | XPPReader.read(File file) Reads a Document from the given File
Document | XPPReader.read(URL url) Reads a Document from the given URL
Document | XPPReader.read(String systemID) Reads a Document from the given URL or filename.
Document | XPPReader.read(InputStream in) Reads a Document from the given stream
Document | XPPReader.read(Reader reader) Reads a Document from the given Reader
Document | XPPReader.read(char[] text) Reads a Document from the given array of characters
Document | XPPReader.read(InputStream in, String systemID) Reads a Document from the given stream
Document | XPPReader.read(Reader reader, String systemID) Reads a Document from the given Reader
protected Document | XPPReader.parseDocument()
Document | XPP3Reader.read(File file) Reads a Document from the given File
Document | XPP3Reader.read(URL url) Reads a Document from the given URL
Document | XPP3Reader.read(String systemID) Reads a Document from the given URL or filename.
Document | XPP3Reader.read(InputStream in) Reads a Document from the given stream
Document | XPP3Reader.read(Reader reader) Reads a Document from the given Reader
Document | XPP3Reader.read(char[] text) Reads a Document from the given array of characters
Document | XPP3Reader.read(InputStream in, String systemID) Reads a Document from the given stream
Document | XPP3Reader.read(Reader reader, String systemID) Reads a Document from the given Reader
protected Document | XPP3Reader.parseDocument()
Document | SAXReader.read(File file) Reads a Document from the given File
Document | SAXReader.read(URL url) Reads a Document from the given URL using SAX
Document | SAXReader.read(String systemId) Reads a Document from the given URL or filename using SAX.
Document | SAXReader.read(InputStream in) Reads a Document from the given stream using SAX
Document | SAXReader.read(Reader reader) Reads a Document from the given Reader using SAX
Document | SAXReader.read(InputStream in, String systemId) Reads a Document from the given stream using SAX
Document | SAXReader.read(Reader reader, String systemId) Reads a Document from the given Reader using SAX
Document | SAXReader.read(InputSource in) Reads a Document from the given InputSource using SAX
protected void | SAXReader.configureReader(XMLReader reader, DefaultHandler handler) Configures the XMLReader before use
Document | SAXModifier.modify(File source) Reads a Document from the given Fileand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(InputSource source) Reads a Document from the given InputSourceand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(InputStream source) Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(InputStream source, String systemId) Reads a Document from the given InputStreamand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(Reader source) Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(Reader source, String systemId) Reads a Document from the given Readerand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(URL source) Reads a Document from the given URLand writes it to the specified XMLWriterusing SAX.
Document | SAXModifier.modify(String source) Reads a Document from the given URL or filename and writes it to the specified XMLWriterusing SAX.
static String | HTMLWriter.prettyPrintHTML(String html) Convenience method to just get a String result.
static String | HTMLWriter.prettyPrintXHTML(String html) Convenience method to just get a String result, but As XHTML .
static String | HTMLWriter.prettyPrintHTML(String html, boolean newlines, boolean trim, boolean isXHTML, boolean expandEmpty) DOCUMENT ME!
Class | DOMWriter.getDomDocumentClass()
void | DOMWriter.setDomDocumentClassName(String name) Sets the DOM Documentimplementation class name used by the writer when creating DOM documents.
Document | DOMWriter.write(Document document)
Document | DOMWriter.write(Document document, DOMImplementation domImpl)
protected Document | DOMWriter.createDomDocument(Document document)
protected Document | DOMWriter.createDomDocumentViaJAXP()
protected Document | DOMWriter.createDomDocument(Document document, DOMImplementation domImpl)

Uses of DocumentException in org.dom4j.jaxb

Methods in org.dom4j.jaxb that throw DocumentException
Document | JAXBReader.read(File source) Parses the specified File
Document | JAXBReader.read(File file, java.nio.charset.Charset charset) Parses the specified File, using the given Charset.
Document | JAXBReader.read(InputSource source) Parses the specified InputSource
Document | JAXBReader.read(InputStream source) Parses the specified InputStream
Document | JAXBReader.read(InputStream source, String systemId) Parses the specified InputStream
Document | JAXBReader.read(Reader source) Parses the specified Reader
Document | JAXBReader.read(Reader source, String systemId) Parses the specified Reader
Document | JAXBReader.read(String source) Parses the the given URL or filename.
Document | JAXBReader.read(URL source) Parses the the given URL.
Document | JAXBModifier.modify(File source) Parses the specified Filewith SAX
Document | JAXBModifier.modify(File source, java.nio.charset.Charset charset) Parses the specified Filewith SAX, using the given Charset.
Document | JAXBModifier.modify(InputSource source) Parses the specified InputSourcewith SAX.
Document | JAXBModifier.modify(InputStream source) Parses the specified InputStreamwith SAX.
Document | JAXBModifier.modify(InputStream source, String systemId) Parses the specified InputStreamwith SAX.
Document | JAXBModifier.modify(Reader r) Parses the specified Readerwith SAX.
Document | JAXBModifier.modify(Reader source, String systemId) Parses the specified Readerwith SAX.
Document | JAXBModifier.modify(String url) Parses the the given URL or filename.
Document | JAXBModifier.modify(URL source) Parses the the given URL.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.DocumentFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.DocumentFactory

Packages that use DocumentFactory
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.
org.dom4j.xpp | Provides implementation classes to cleanly integrate dom4j with the XML Pull Parser XPP

Uses of DocumentFactory in org.dom4j

Methods in org.dom4j that return DocumentFactory
DocumentFactory | QName.getDocumentFactory() DOCUMENT ME!
static DocumentFactory | DocumentFactory.getInstance() Access to singleton implementation of DocumentFactory which is used if no DocumentFactory is specified when building using the standard builders.
protected static DocumentFactory | DocumentFactory.createSingleton(String className) createSingleton creates the singleton instance from the given class name.

Methods in org.dom4j with parameters of type DocumentFactory
 void QName.setDocumentFactory(DocumentFactory documentFactory)

Uses of DocumentFactory in org.dom4j.bean

Subclasses of DocumentFactory in org.dom4j.bean
 class BeanDocumentFactory
BeanDocumentFactory is a factory of DOM4J objects which may be BeanElements which are backed by JavaBeans and their properties.

Methods in org.dom4j.bean that return DocumentFactory
protected DocumentFactory | BeanElement.getDocumentFactory()
static DocumentFactory | BeanDocumentFactory.getInstance() Access to the singleton instance of this factory.

Uses of DocumentFactory in org.dom4j.datatype

Subclasses of DocumentFactory in org.dom4j.datatype
class | DatatypeDocumentFactory DatatypeDocumentFactory is a factory of XML objects which support the XML Schema Data Types specification.
class | DatatypeElementFactory DatatypeElementFactory is a factory for a specific Element in an XML Schema.

Methods in org.dom4j.datatype that return DocumentFactory
static DocumentFactory DatatypeDocumentFactory.getInstance()
Access to the singleton instance of this factory.

Uses of DocumentFactory in org.dom4j.dom

Subclasses of DocumentFactory in org.dom4j.dom
 class DOMDocumentFactory
DOMDocumentFactory is a factory of DOM4J objects which implement the W3C DOM API.

Methods in org.dom4j.dom that return DocumentFactory
protected DocumentFactory | DOMElement.getDocumentFactory()
static DocumentFactory | DOMDocumentFactory.getInstance() Access to the singleton instance of this factory.
protected DocumentFactory | DOMDocument.getDocumentFactory()

Uses of DocumentFactory in org.dom4j.io

Methods in org.dom4j.io that return DocumentFactory
DocumentFactory | XPPReader.getDocumentFactory() DOCUMENT ME!
DocumentFactory | XPP3Reader.getDocumentFactory() DOCUMENT ME!
DocumentFactory | SAXReader.getDocumentFactory() DOCUMENT ME!
DocumentFactory | SAXModifier.getDocumentFactory() Get the DocumentFactoryused to create the DOM4J document structure
DocumentFactory | DOMReader.getDocumentFactory() DOCUMENT ME!

Methods in org.dom4j.io with parameters of type DocumentFactory
void | XPPReader.setDocumentFactory(DocumentFactory documentFactory) This sets the DocumentFactory used to create new documents.
void | XPP3Reader.setDocumentFactory(DocumentFactory documentFactory) This sets the DocumentFactory used to create new documents.
void | STAXEventReader.setDocumentFactory(DocumentFactory documentFactory) Sets the DocumentFactory to be used when constructing DOM4J nodes.
void | SAXReader.setDocumentFactory(DocumentFactory documentFactory) This sets the DocumentFactory used to create new documents.
void | SAXModifier.setDocumentFactory(DocumentFactory factory) Sets the DocumentFactoryused to create the DOM4J document tree.
void | DOMReader.setDocumentFactory(DocumentFactory docFactory) This sets the DocumentFactory used to create new documents.

Constructors in org.dom4j.io with parameters of type DocumentFactory
XPPReader(DocumentFactory factory)
XPP3Reader(DocumentFactory factory)
STAXEventReader(DocumentFactory factory)
Constructs a STAXEventReader instance that uses the specified DocumentFactoryto construct DOM4J Nodes.
SAXReader(DocumentFactory factory)
SAXReader(DocumentFactory factory, boolean validating)
SAXContentHandler(DocumentFactory documentFactory)
SAXContentHandler(DocumentFactory documentFactory, ElementHandler elementHandler)
SAXContentHandler(DocumentFactory documentFactory, ElementHandler elementHandler, org.dom4j.io.ElementStack elementStack)
DOMReader(DocumentFactory factory)

Uses of DocumentFactory in org.dom4j.tree

Methods in org.dom4j.tree that return DocumentFactory
DocumentFactory | NamespaceStack.getDocumentFactory()
protected DocumentFactory | DefaultElement.getDocumentFactory()
protected DocumentFactory | DefaultDocument.getDocumentFactory()
protected DocumentFactory | AbstractNode.getDocumentFactory()
protected DocumentFactory | AbstractElement.getDocumentFactory()

Methods in org.dom4j.tree with parameters of type DocumentFactory
void | NamespaceStack.setDocumentFactory(DocumentFactory documentFactory)
void | DefaultDocument.setDocumentFactory(DocumentFactory documentFactory)

Constructors in org.dom4j.tree with parameters of type DocumentFactory
QNameCache(DocumentFactory documentFactory)
NamespaceStack(DocumentFactory documentFactory)

Uses of DocumentFactory in org.dom4j.util

Subclasses of DocumentFactory in org.dom4j.util
class | IndexedDocumentFactory IndexedDocumentFactory is a factory of XML objects which create indexed Element implementations to allow quicker lookup via name of Element and Attributes though at the expense of more memory used to create the name indexes.
class | NonLazyDocumentFactory NonLazyDocumentFactory is a factory of XML objects which avoid using the lazy creation pattern.
class | UserDataDocumentFactory UserDataDocumentFactory is a factory of XML objects which support the adornment of a user data object on an Element or Attribute instance such that the methods getData() and setData() will get and set the values of a user data object.

Methods in org.dom4j.util that return DocumentFactory
static DocumentFactory | UserDataDocumentFactory.getInstance() Access to the singleton instance of this factory.
protected DocumentFactory | ProxyDocumentFactory.getProxy()
static DocumentFactory | NonLazyDocumentFactory.getInstance() Access to the singleton instance of this factory.
static DocumentFactory | IndexedDocumentFactory.getInstance() Access to the singleton instance of this factory.

Methods in org.dom4j.util with parameters of type DocumentFactory
protected  void ProxyDocumentFactory.setProxy(DocumentFactory proxy)

Constructors in org.dom4j.util with parameters of type DocumentFactory
ProxyDocumentFactory(DocumentFactory proxy)

Uses of DocumentFactory in org.dom4j.xpp

Methods in org.dom4j.xpp that return DocumentFactory
 DocumentFactory ProxyXmlStartTag.getDocumentFactory()

Methods in org.dom4j.xpp with parameters of type DocumentFactory
 void ProxyXmlStartTag.setDocumentFactory(DocumentFactory documentFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.DocumentHelper (dom4j 1.6.1 API)

Uses of Class
org.dom4j.DocumentHelper

No usage of org.dom4j.DocumentHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.DocumentType (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.DocumentType

Packages that use DocumentType
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of DocumentType in org.dom4j

Methods in org.dom4j that return DocumentType
DocumentType | DocumentFactory.createDocType(String name, String publicId, String systemId)
DocumentType | Document.getDocType() DOCUMENT ME!

Methods in org.dom4j with parameters of type DocumentType
void | VisitorSupport.visit(DocumentType documentType)
void | Visitor.visit(DocumentType documentType) Visits the given DocumentType
void | Document.setDocType(DocumentType docType) Sets the DocumentType property

Uses of DocumentType in org.dom4j.dom

Classes in org.dom4j.dom that implement DocumentType
 class DOMDocumentType
DOMDocumentType implements a DocumentType node which supports the W3C DOM API.

Methods in org.dom4j.dom that return DocumentType
 DocumentType DOMDocumentFactory.createDocType(String name, String publicId, String systemId)

Methods in org.dom4j.dom with parameters of type DocumentType
static DocumentType DOMNodeHelper.asDOMDocumentType(DocumentType dt)

Uses of DocumentType in org.dom4j.io

Methods in org.dom4j.io with parameters of type DocumentType
void | XMLWriter.write(DocumentType docType) Writes the given DocumentType.
protected void | XMLWriter.writeDocType(DocumentType docType)
void | STAXEventWriter.writeDocumentType(DocumentType docType) Writes a DOM4J DocumentTypeto the stream.
javax.xml.stream.events.DTD | STAXEventWriter.createDTD(DocumentType docType) Constructs a STAX DTDevent from a DOM4J DocumentType.

Uses of DocumentType in org.dom4j.tree

Classes in org.dom4j.tree that implement DocumentType
class | AbstractDocumentType AbstractDocumentType is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultDocumentType DefaultDocumentType is the DOM4J default implementation of an XML document type.

Methods in org.dom4j.tree that return DocumentType
 DocumentType DefaultDocument.getDocType()

Methods in org.dom4j.tree with parameters of type DocumentType
 void DefaultDocument.setDocType(DocumentType docType)

Constructors in org.dom4j.tree with parameters of type DocumentType
DefaultDocument(DocumentType docType)
DefaultDocument(Element rootElement, DocumentType docType)
DefaultDocument(String name, Element rootElement, DocumentType docType)

Uses of DocumentType in org.dom4j.util

Methods in org.dom4j.util that return DocumentType
 DocumentType ProxyDocumentFactory.createDocType(String name, String publicId, String systemId)

Methods in org.dom4j.util with parameters of type DocumentType
 int NodeComparator.compare(DocumentType o1, DocumentType o2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Element (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Element

Packages that use Element
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.jaxb |
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.swing | A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.
org.dom4j.xpath | Provides the core tools needed to use the XPath library
org.dom4j.xpp | Provides implementation classes to cleanly integrate dom4j with the XML Pull Parser XPP

Uses of Element in org.dom4j

Methods in org.dom4j that return Element
 Element Node.getParent()
getParent returns the parent Element if this node supports the parent relationship or null if it is the root element or does not support the parent relationship.
 Element ElementPath.getElement(int depth)
DOCUMENT ME!
 Element ElementPath.getCurrent()
DOCUMENT ME!
 Element Element.addAttribute(String name, String value)
Adds the attribute value of the given local name.
 Element Element.addAttribute(QName qName, String value)
Adds the attribute value of the given fully qualified name.
 Element Element.addComment(String comment)
Adds a new Comment node with the given text to this element.
 Element Element.addCDATA(String cdata)
Adds a new CDATA node with the given text to this element.
 Element Element.addEntity(String name, String text)
Adds a new Entity node with the given name and text to this element and returns a reference to the new node.
 Element Element.addNamespace(String prefix, String uri)
Adds a namespace to this element for use by its child content
 Element Element.addProcessingInstruction(String target, String text)
Adds a processing instruction for the given target
 Element Element.addProcessingInstruction(String target, Map data)
Adds a processing instruction for the given target
 Element Element.addText(String text)
Adds a new Text node with the given text to this element.
 Element Element.element(String name)
Returns the first element for the given local name and any namespace.
 Element Element.element(QName qName)
Returns the first element for the given fully qualified name.
 Element Element.createCopy()
Creates a deep copy of this element The new element is detached from its parent, and getParent() on the clone will return null.
 Element Element.createCopy(String name)
Creates a deep copy of this element with the given local name The new element is detached from its parent, and getParent() on the clone will return null.
 Element Element.createCopy(QName qName)
Creates a deep copy of this element with the given fully qualified name.
static Element DocumentHelper.createElement(QName qname)
static Element DocumentHelper.createElement(String name)
static Element DocumentHelper.makeElement(Branch source, String path)
makeElement a helper method which navigates from the given Document or Element node to some Element using the path expression, creating any necessary elements along the way.
 Element DocumentFactory.createElement(QName qname)
 Element DocumentFactory.createElement(String name)
 Element DocumentFactory.createElement(String qualifiedName, String namespaceURI)
 Element Document.getRootElement()
Returns the root Elementfor this document.
 Element Branch.elementByID(String elementID)
Returns the element of the given ID attribute value.
 Element Branch.addElement(String name)
Adds a new Element node with the given name to this branch and returns a reference to the new node.
 Element Branch.addElement(QName qname)
Adds a new Element node with the given QNameto this branch and returns a reference to the new node.
 Element Branch.addElement(String qualifiedName, String namespaceURI)
Adds a new Element node with the given qualified name and namespace URI to this branch and returns a reference to the new node.

Methods in org.dom4j with parameters of type Element
void | VisitorSupport.visit(Element node)
void | Visitor.visit(Element node) Visits the given Element
void | Node.setParent(Element parent) setParent sets the parent relationship of this node if the parent relationship is supported or does nothing if the parent relationship is not supported.
String | Node.getPath(Element context) Returns the relative XPath expression which will return a node set containing the given node such as a/b/@c.
String | Node.getUniquePath(Element context) Returns the relative unique XPath expression from the given context which will return a nodeset of one node which is the current node.
Node | Node.asXPathResult(Element parent) asXPathResult returns a version of this node which is capable of being an XPath result.
String | Namespace.getPath(Element context)
String | Namespace.getUniquePath(Element context)
protected Node | Namespace.createXPathResult(Element parent)
void | Element.appendAttributes(Element element) Appends the attributes of the given element to me.
static Document | DocumentHelper.createDocument(Element rootElement)
static Attribute | DocumentHelper.createAttribute(Element owner, QName qname, String value)
static Attribute | DocumentHelper.createAttribute(Element owner, String name, String value)
Document | DocumentFactory.createDocument(Element rootElement)
Attribute | DocumentFactory.createAttribute(Element owner, QName qname, String value)
Attribute | DocumentFactory.createAttribute(Element owner, String name, String value)
void | Document.setRootElement(Element rootElement) Sets the root element for this document
void | Branch.add(Element element) Adds the given Element to this branch.
boolean | Branch.remove(Element element) Removes the given Element if the node is an immediate child of this branch.

Constructors in org.dom4j with parameters of type Element
IllegalAddException(Element parent, Node node, String reason)

Uses of Element in org.dom4j.bean

Classes in org.dom4j.bean that implement Element
 class BeanElement
BeanElement uses a Java Bean to store its attributes.

Methods in org.dom4j.bean that return Element
Element | BeanElement.addAttribute(String name, String value)
Element | BeanElement.addAttribute(QName qName, String value)
Element | BeanDocumentFactory.createElement(QName qname)
Element | BeanDocumentFactory.createElement(QName qname, Attributes attributes)
Element | BeanAttribute.getParent()

Methods in org.dom4j.bean with parameters of type Element
 Attribute BeanDocumentFactory.createAttribute(Element owner, QName qname, String value)

Uses of Element in org.dom4j.datatype

Classes in org.dom4j.datatype that implement Element
 class DatatypeElement
DatatypeElement represents an Element which supports the XML Schema Data Types specification.

Methods in org.dom4j.datatype that return Element
Element | DatatypeElementFactory.createElement(QName qname)
Element | DatatypeElement.addText(String text)
Element | DatatypeAttribute.getParent()

Methods in org.dom4j.datatype with parameters of type Element
Attribute | DatatypeElementFactory.createAttribute(Element owner, QName qname, String value)
Attribute | DatatypeDocumentFactory.createAttribute(Element owner, QName qname, String value)
void | DatatypeAttribute.setParent(Element parent)

Uses of Element in org.dom4j.dom

Classes in org.dom4j.dom that implement Element
 class DOMElement
DOMElement implements an XML element which supports the W3C DOM API.

Methods in org.dom4j.dom that return Element
Element | DOMDocumentFactory.createElement(QName qname)
Element | DOMDocumentFactory.createElement(QName qname, int attributeCount)

Methods in org.dom4j.dom with parameters of type Element
 Attribute DOMDocumentFactory.createAttribute(Element owner, QName qname, String value)

Constructors in org.dom4j.dom with parameters of type Element
DOMText(Element parent, String text)
DOMProcessingInstruction(Element parent, String target, String val)
DOMNamespace(Element parent, String prefix, String uri)
DOMEntityReference(Element parent, String name, String text)
DOMComment(Element parent, String text)
DOMCDATA(Element parent, String text)
DOMAttribute(Element parent, QName qname, String value)

Uses of Element in org.dom4j.io

Methods in org.dom4j.io that return Element
Element | STAXEventReader.readElement(javax.xml.stream.XMLEventReader eventReader) Reads a DOM4J Element from the provided event stream.
Element | STAXEventReader.createElement(javax.xml.stream.events.StartElement startEvent) Constructs a new DOM4J Element from the provided StartElement event.
Element | ElementModifier.modifyElement(Element element) Called by an event based processor when an elements closing tag is encountered.

Methods in org.dom4j.io with parameters of type Element
 void XMLWriter.write(Element element)
Writes the Element, including its Attribute s, and its value, and all its content (child nodes) to the current Writer.
 void XMLWriter.writeOpen(Element element)
Writes the opening tag of an Element, including its Attributes but without its content.
 void XMLWriter.writeClose(Element element)
Writes the closing tag of an Element
protected  void XMLWriter.writeElement(Element element)
protected  boolean XMLWriter.isElementSpacePreserved(Element element)
Determines if element is a special case of XML elements where it contains an xml:space attribute of "preserve".
protected  void XMLWriter.writeElementContent(Element element)
Outputs the content of the given element.
protected  void XMLWriter.writeAttributes(Element element)
Writes the attributes of the given element
 void STAXEventWriter.writeElement(Element elem)
Writes a DOM4J Elementnode and its children to the stream.
 javax.xml.stream.events.StartElement STAXEventWriter.createStartElement(Element elem)
Constructs a STAX StartElementevent from a DOM4J Element.
 javax.xml.stream.events.EndElement STAXEventWriter.createEndElement(Element elem)
Constructs a STAX EndElementevent from a DOM4J Element.
 Attribute STAXEventReader.createAttribute(Element elem, javax.xml.stream.events.Attribute attr)
Constructs a new DOM4J Attribute from the provided StAX Attribute event.
 void SAXWriter.write(Element element)
Generates SAX events for the given Element and all its content
 void SAXWriter.writeOpen(Element element)
Writes the opening tag of an Element, including its Attributes but without its content.
 void SAXWriter.writeClose(Element element)
Writes the closing tag of an Element
protected  void SAXWriter.write(Element element, NamespaceStack namespaceStack)
protected  AttributesImpl SAXWriter.startPrefixMapping(Element element, NamespaceStack namespaceStack)
Fires a SAX startPrefixMapping event for all the namespaceStack which have just come into scope
protected  void SAXWriter.startElement(Element element, AttributesImpl namespaceAttributes)
protected  void SAXWriter.endElement(Element element)
protected  Attributes SAXWriter.createAttributes(Element element, Attributes namespaceAttributes)
protected  void SAXContentHandler.addDeclaredNamespaces(Element element)
Add all namespaces declared before the startElement() SAX event to the current element so that they are available to child elements and attributes
protected  void SAXContentHandler.addAttributes(Element element, Attributes attributes)
Add all the attributes to the given elements
protected  void HTMLWriter.writeElement(Element element)
This override handles any elements that should not remove whitespace, such as <PRE>, <SCRIPT>, <STYLE>, and <TEXTAREA>.
 Element ElementModifier.modifyElement(Element element)
Called by an event based processor when an elements closing tag is encountered.
protected  void DOMWriter.appendDOMTree(Document domDocument, Node domCurrent, Element element)

Uses of Element in org.dom4j.jaxb

Methods in org.dom4j.jaxb with parameters of type Element
void | JAXBWriter.writeElement(Element element) Writes the specified Elementto the document.
void | JAXBWriter.writeCloseElement(Element element) Writes the closing tag of the specified Elementto the document.
void | JAXBWriter.writeOpenElement(Element element) Writes the opening tag of the specified Elementto the document.

Uses of Element in org.dom4j.rule

Methods in org.dom4j.rule with parameters of type Element
 void Mode.applyTemplates(Element element)

Uses of Element in org.dom4j.swing

Methods in org.dom4j.swing with parameters of type Element
static XMLTableDefinition XMLTableDefinition.load(Element definition)
Loads an XML table definition from an XML definition document

Constructors in org.dom4j.swing with parameters of type Element
XMLTableModel(Element tableDefinition, Object source)
Creates a TableModel from an XML table definition document and an XML source

Uses of Element in org.dom4j.tree

Classes in org.dom4j.tree that implement Element
class | AbstractElement AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
class | BaseElement BaseElement is a useful base class for implemementation inheritence of an XML element.
class | DefaultElement DefaultElement is the default DOM4J default implementation of an XML element.

Methods in org.dom4j.tree that return Element
Element | DefaultText.getParent()
Element | DefaultProcessingInstruction.getParent()
Element | DefaultNamespace.getParent()
Element | DefaultEntity.getParent()
Element | DefaultElement.getParent()
Element | DefaultElement.element(String name)
Element | DefaultElement.element(QName qName)
Element | DefaultElement.element(String name, Namespace namespace)
Element | DefaultDocument.getRootElement()
Element | DefaultComment.getParent()
Element | DefaultCDATA.getParent()
Element | DefaultAttribute.getParent()
Element | BaseElement.getParent()
Element | AbstractNode.getParent()
Element | AbstractElement.element(String name)
Element | AbstractElement.element(QName qName)
Element | AbstractElement.element(String name, Namespace namespace)
Element | AbstractElement.addAttribute(String name, String value)
Element | AbstractElement.addAttribute(QName qName, String value)
Element | AbstractElement.addCDATA(String cdata)
Element | AbstractElement.addComment(String comment)
Element | AbstractElement.addElement(String name)
Element | AbstractElement.addEntity(String name, String text)
Element | AbstractElement.addNamespace(String prefix, String uri)
Element | AbstractElement.addProcessingInstruction(String target, String data)
Element | AbstractElement.addProcessingInstruction(String target, Map data)
Element | AbstractElement.addText(String text)
Element | AbstractElement.createCopy() This returns a deep clone of this element.
Element | AbstractElement.createCopy(String name)
Element | AbstractElement.createCopy(QName qName)
protected Element | AbstractElement.createElement(String name)
protected Element | AbstractElement.createElement(QName qName)
Element | AbstractDocument.addElement(String name)
Element | AbstractDocument.addElement(String qualifiedName, String namespaceURI)
Element | AbstractDocument.addElement(QName qName)
Element | AbstractBranch.addElement(String name)
Element | AbstractBranch.addElement(String qualifiedName, String namespaceURI)
Element | AbstractBranch.addElement(QName qname)
Element | AbstractBranch.addElement(String name, String prefix, String uri)
Element | AbstractBranch.elementByID(String elementID)

Methods in org.dom4j.tree with parameters of type Element
protected Node | FlyweightText.createXPathResult(Element parent)
protected Node | FlyweightProcessingInstruction.createXPathResult(Element parent)
protected Node | FlyweightEntity.createXPathResult(Element parent)
protected Node | FlyweightComment.createXPathResult(Element parent)
protected Node | FlyweightCDATA.createXPathResult(Element parent)
void | DefaultText.setParent(Element parent)
void | DefaultProcessingInstruction.setParent(Element parent)
void | DefaultNamespace.setParent(Element parent)
void | DefaultEntity.setParent(Element parent)
void | DefaultElement.setParent(Element parent)
protected void | DefaultDocument.rootElementAdded(Element element)
void | DefaultComment.setParent(Element parent)
void | DefaultCDATA.setParent(Element parent)
void | DefaultAttribute.setParent(Element parent)
void | BaseElement.setParent(Element parent)
String | AbstractProcessingInstruction.getPath(Element context)
String | AbstractProcessingInstruction.getUniquePath(Element context)
void | AbstractNode.setParent(Element parent)
Node | AbstractNode.asXPathResult(Element parent)
protected Node | AbstractNode.createXPathResult(Element parent)
String | AbstractEntity.getPath(Element context)
String | AbstractEntity.getUniquePath(Element context)
String | AbstractElement.getPath(Element context)
String | AbstractElement.getUniquePath(Element context)
void | AbstractElement.add(Element element)
boolean | AbstractElement.remove(Element element)
void | AbstractElement.appendAttributes(Element element)
String | AbstractDocumentType.getPath(Element context)
String | AbstractDocumentType.getUniquePath(Element context)
String | AbstractDocument.getPath(Element context)
String | AbstractDocument.getUniquePath(Element context)
void | AbstractDocument.setRootElement(Element rootElement)
void | AbstractDocument.add(Element element)
boolean | AbstractDocument.remove(Element element)
Node | AbstractDocument.asXPathResult(Element parent)
protected void | AbstractDocument.checkAddElementAllowed(Element element)
protected abstract void | AbstractDocument.rootElementAdded(Element rootElement) Called to set the root element variable
String | AbstractComment.getPath(Element context)
String | AbstractComment.getUniquePath(Element context)
String | AbstractCharacterData.getPath(Element context)
String | AbstractCharacterData.getUniquePath(Element context)
void | AbstractBranch.add(Element element)
boolean | AbstractBranch.remove(Element element)
protected String | AbstractBranch.elementID(Element element) DOCUMENT ME!
String | AbstractAttribute.getPath(Element context)
String | AbstractAttribute.getUniquePath(Element context)
protected Node | AbstractAttribute.createXPathResult(Element parent)

Constructors in org.dom4j.tree with parameters of type Element
DefaultText(Element parent, String text)
DOCUMENT ME!
DefaultProcessingInstruction(Element parent, String target, String values)
This will create a new PI with the given target and values
DefaultNamespace(Element parent, String prefix, String uri)
DOCUMENT ME!
DefaultEntity(Element parent, String name, String text)
Creates the Entity with the specified name and text.
DefaultDocument(Element rootElement)
DefaultDocument(Element rootElement, DocumentType docType)
DefaultDocument(String name, Element rootElement, DocumentType docType)
DefaultComment(Element parent, String text)
DOCUMENT ME!
DefaultCDATA(Element parent, String text)
DOCUMENT ME!
DefaultAttribute(Element parent, QName qname, String value)
DefaultAttribute(Element parent, String name, String value, Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.

Uses of Element in org.dom4j.util

Classes in org.dom4j.util that implement Element
class | IndexedElement IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
class | NonLazyElement NonLazyElement is the default DOM4J default implementation of an XML element.
class | UserDataElement UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.

Methods in org.dom4j.util that return Element
Element | XMLErrorHandler.getErrors()
protected Element | UserDataElement.createElement(String name)
protected Element | UserDataElement.createElement(QName qName)
Element | UserDataDocumentFactory.createElement(QName qname)
Element | ProxyDocumentFactory.createElement(QName qname)
Element | ProxyDocumentFactory.createElement(String name)
Element | NonLazyDocumentFactory.createElement(QName qname)
Element | IndexedElement.element(String name)
Element | IndexedElement.element(QName qName)
protected Element | IndexedElement.asElement(Object object)
Element | IndexedDocumentFactory.createElement(QName qname)
Element | IndexedDocumentFactory.createElement(QName qname, int attributeCount)

Methods in org.dom4j.util with parameters of type Element
void | XMLErrorHandler.setErrors(Element errors)
protected void | XMLErrorHandler.addException(Element element, SAXParseException e) Adds the given parse exception information to the given element instance
Attribute | UserDataDocumentFactory.createAttribute(Element owner, QName qname, String value)
Document | ProxyDocumentFactory.createDocument(Element rootElement)
Attribute | ProxyDocumentFactory.createAttribute(Element owner, QName qname, String value)
Attribute | ProxyDocumentFactory.createAttribute(Element owner, String name, String value)
int | NodeComparator.compare(Element n1, Element n2)
protected void | IndexedElement.addToElementIndex(Element element)
protected void | IndexedElement.addToElementIndex(Object key, Element value)
protected void | IndexedElement.removeFromElementIndex(Element element)
protected void | IndexedElement.removeFromElementIndex(Object key, Element value)
static boolean | AttributeHelper.booleanValue(Element element, String attributeName)
static boolean | AttributeHelper.booleanValue(Element element, QName attributeQName)

Constructors in org.dom4j.util with parameters of type Element
XMLErrorHandler(Element errors)

Uses of Element in org.dom4j.xpath

Constructors in org.dom4j.xpath with parameters of type Element
DefaultNamespaceContext(Element element)

Uses of Element in org.dom4j.xpp

Methods in org.dom4j.xpp that return Element
 Element ProxyXmlStartTag.getElement()

Constructors in org.dom4j.xpp with parameters of type Element
ProxyXmlStartTag(Element element)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.ElementHandler (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.ElementHandler

Packages that use ElementHandler
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.jaxb |

Uses of ElementHandler in org.dom4j

Methods in org.dom4j with parameters of type ElementHandler
 void ElementPath.addHandler(String path, ElementHandler handler)
Adds the ElementHandler to be called when the specified path is encounted.

Uses of ElementHandler in org.dom4j.io

Methods in org.dom4j.io with parameters of type ElementHandler
void | XPPReader.addHandler(String path, ElementHandler handler) Adds the ElementHandler to be called when the specified path is encounted.
void | XPPReader.setDefaultHandler(ElementHandler handler) When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.
void | XPP3Reader.addHandler(String path, ElementHandler handler) Adds the ElementHandler to be called when the specified path is encounted.
void | XPP3Reader.setDefaultHandler(ElementHandler handler) When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.
void | SAXReader.addHandler(String path, ElementHandler handler) Adds the ElementHandler to be called when the specified path is encounted.
void | SAXReader.setDefaultHandler(ElementHandler handler) When multiple ElementHandler instances have been registered, this will set a default ElementHandler to be called for any path which does NOT have a handler registered.

Constructors in org.dom4j.io with parameters of type ElementHandler
SAXContentHandler(DocumentFactory documentFactory, ElementHandler elementHandler)
SAXContentHandler(DocumentFactory documentFactory, ElementHandler elementHandler, org.dom4j.io.ElementStack elementStack)

Uses of ElementHandler in org.dom4j.jaxb

Methods in org.dom4j.jaxb with parameters of type ElementHandler
 void JAXBReader.addHandler(String path, ElementHandler handler)
Adds the ElementHandler to be called when the specified path is encounted.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.ElementPath (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.ElementPath

Packages that use ElementPath
org.dom4j Defines the XML Document Object Model in Java interfaces together with some helper classes.

Uses of ElementPath in org.dom4j

Methods in org.dom4j with parameters of type ElementPath
void | ElementHandler.onStart(ElementPath elementPath) Called by an event based processor when an elements openning tag is encountered.
void | ElementHandler.onEnd(ElementPath elementPath) Called by an event based processor when an elements closing tag is encountered.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Entity (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Entity

Packages that use Entity
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of Entity in org.dom4j

Methods in org.dom4j that return Entity
static Entity | DocumentHelper.createEntity(String name, String text)
Entity | DocumentFactory.createEntity(String name, String text)

Methods in org.dom4j with parameters of type Entity
void | VisitorSupport.visit(Entity node)
void | Visitor.visit(Entity node) Visits the given Entity
void | Element.add(Entity entity) Adds the given Entity to this element.
boolean | Element.remove(Entity entity) Removes the given Entity if the node is an immediate child of this element.

Uses of Entity in org.dom4j.dom

Classes in org.dom4j.dom that implement Entity
 class DOMEntityReference
DOMEntity implements a Entity node which supports the W3C DOM API.

Methods in org.dom4j.dom that return Entity
Entity | DOMDocumentFactory.createEntity(String name)
Entity | DOMDocumentFactory.createEntity(String name, String text)

Uses of Entity in org.dom4j.io

Methods in org.dom4j.io that return Entity
Entity | STAXEventReader.readEntityReference(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Entity from the provided event stream.
Entity | STAXEventReader.createEntity(javax.xml.stream.events.EntityReference entityRef) Constructs a new DOM4J Entity from the provided StAX EntityReference event.

Methods in org.dom4j.io with parameters of type Entity
void | XMLWriter.write(Entity entity) Writes the given Entity.
protected void | XMLWriter.writeEntity(Entity entity)
void | STAXEventWriter.writeEntity(Entity entity) Writes a DOM4J Entityto the stream.
void | SAXWriter.write(Entity entity) Generates SAX events for the given Entity
protected void | HTMLWriter.writeEntity(Entity entity)
protected void | DOMWriter.appendDOMTree(Document domDocument, Node domCurrent, Entity entity)

Uses of Entity in org.dom4j.tree

Classes in org.dom4j.tree that implement Entity
class | AbstractEntity AbstractEntity is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultEntity DefaultEntity is the default Entity implementation.
class | FlyweightEntity FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.

Methods in org.dom4j.tree with parameters of type Entity
void | AbstractElement.add(Entity entity)
boolean | AbstractElement.remove(Entity entity)

Uses of Entity in org.dom4j.util

Methods in org.dom4j.util that return Entity
 Entity ProxyDocumentFactory.createEntity(String name, String text)

Methods in org.dom4j.util with parameters of type Entity
 int NodeComparator.compare(Entity n1, Entity n2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.IllegalAddException (dom4j 1.6.1 API)

Uses of Class
org.dom4j.IllegalAddException

No usage of org.dom4j.IllegalAddException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.InvalidXPathException (dom4j 1.6.1 API)

Uses of Class
org.dom4j.InvalidXPathException

Packages that use InvalidXPathException
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.xpath | Provides the core tools needed to use the XPath library

Uses of InvalidXPathException in org.dom4j

Methods in org.dom4j that throw InvalidXPathException
XPath | Node.createXPath(String xpathExpression) createXPath creates an XPath object for the given xpathExpression.
static XPath | DocumentHelper.createXPath(String xpathExpression) createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.
static XPath | DocumentHelper.createXPath(String xpathExpression, org.jaxen.VariableContext context) createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.
XPath | DocumentFactory.createXPath(String xpathExpression) createXPath parses an XPath expression and creates a new XPath XPath instance.

Uses of InvalidXPathException in org.dom4j.xpath

Constructors in org.dom4j.xpath that throw InvalidXPathException
DefaultXPath(String text)
Construct an XPath

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.Namespace (dom4j 1.6.1 API)

Uses of Class
org.dom4j.Namespace

Packages that use Namespace
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of Namespace in org.dom4j

Fields in org.dom4j declared as Namespace
static Namespace | Namespace.XML_NAMESPACE XML Namespace
static Namespace | Namespace.NO_NAMESPACE No Namespace present

Methods in org.dom4j that return Namespace
Namespace | QName.getNamespace() DOCUMENT ME!
static Namespace | Namespace.get(String prefix, String uri) A helper method to return the Namespace instance for the given prefix and URI
static Namespace | Namespace.get(String uri) A helper method to return the Namespace instance for no prefix and the URI
Namespace | Element.getNamespace() Returns the Namespace of this element if one exists otherwise Namespace.NO_NAMESPACE is returned.
Namespace | Element.getNamespaceForPrefix(String prefix) Returns the Namespace which is mapped to the given prefix or null if it could not be found.
Namespace | Element.getNamespaceForURI(String uri) Returns the Namespace which is mapped to the given URI or null if it could not be found.
static Namespace | DocumentHelper.createNamespace(String prefix, String uri)
Namespace | DocumentFactory.createNamespace(String prefix, String uri)
Namespace | Attribute.getNamespace() Returns the Namespace of this element if one exists otherwise null is returned returned.

Methods in org.dom4j with parameters of type Namespace
void | VisitorSupport.visit(Namespace namespace)
void | Visitor.visit(Namespace namespace) Visits the given Namespace
static QName | QName.get(String name, Namespace namespace)
static QName | QName.get(String localName, Namespace namespace, String qualifiedName)
void | Element.add(Namespace namespace) Adds the given Namespace to this element.
boolean | Element.remove(Namespace namespace) Removes the given Namespace if the node is an immediate child of this element.
static QName | DocumentHelper.createQName(String localName, Namespace namespace)
QName | DocumentFactory.createQName(String localName, Namespace namespace)
void | Attribute.setNamespace(Namespace namespace) Sets the Namespace of this element or if this element is read only then an UnsupportedOperationException is thrown.

Constructors in org.dom4j with parameters of type Namespace
QName(String name, Namespace namespace)
QName(String name, Namespace namespace, String qualifiedName)

Uses of Namespace in org.dom4j.bean

Constructors in org.dom4j.bean with parameters of type Namespace
BeanElement(String name, Namespace namespace, Object bean)

Uses of Namespace in org.dom4j.datatype

Methods in org.dom4j.datatype with parameters of type Namespace
void | SchemaParser.build(Document schemaDocument, Namespace namespace)
void | DatatypeDocumentFactory.loadSchema(Document schemaDocument, Namespace targetNamespace)
protected void | DatatypeDocumentFactory.loadSchema(Document document, String schemaInstanceURI, Namespace namespace)

Uses of Namespace in org.dom4j.dom

Subclasses of Namespace in org.dom4j.dom
 class DOMNamespace
DOMNamespace implements a Namespace that is compatable with the DOM API.

Methods in org.dom4j.dom that return Namespace
 Namespace DOMDocumentFactory.createNamespace(String prefix, String uri)

Constructors in org.dom4j.dom with parameters of type Namespace
DOMElement(String name, Namespace namespace)

Uses of Namespace in org.dom4j.io

Methods in org.dom4j.io that return Namespace
Namespace | STAXEventReader.readNamespace(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J Namespace from the provided event stream.
Namespace | STAXEventReader.createNamespace(javax.xml.stream.events.Namespace ns) Constructs a new DOM4J Namespace from the provided StAX Namespace event.
protected Namespace | DOMReader.getNamespace(String prefix, String uri)

Methods in org.dom4j.io with parameters of type Namespace
 void XMLWriter.write(Namespace namespace)
Writes the given Namespace.
protected  void XMLWriter.writeNamespace(Namespace namespace)
protected  boolean XMLWriter.isNamespaceDeclaration(Namespace ns)
 void STAXEventWriter.writeNamespace(Namespace ns)
Writes a DOM4J Namespaceto the stream.
 javax.xml.stream.events.Namespace STAXEventWriter.createNamespace(Namespace ns)
Constructs a STAX Namespaceevent from a DOM4J Namespace.
protected  AttributesImpl SAXWriter.addNamespaceAttribute(AttributesImpl attrs, Namespace namespace)
If isDelcareNamespaceAttributes() is enabled then this method will add the given namespace declaration to the supplied attributes object, creating one if it does not exist.
protected  boolean SAXWriter.isIgnoreableNamespace(Namespace namespace, NamespaceStack namespaceStack)
DOCUMENT ME!
protected  void DOMWriter.writeNamespace(Element domElement, Namespace namespace)
protected  String DOMWriter.attributeNameForNamespace(Namespace namespace)
protected  boolean DOMWriter.isNamespaceDeclaration(Namespace ns)

Uses of Namespace in org.dom4j.tree

Subclasses of Namespace in org.dom4j.tree
 class DefaultNamespace
DefaultNamespace implements a doubly linked node which supports the parent relationship and is mutable.

Methods in org.dom4j.tree that return Namespace
Namespace | NamespaceStack.pop() Pops the most recently used Namespace from the stack
Namespace | NamespaceStack.getNamespace(int index) DOCUMENT ME!
Namespace | NamespaceStack.getNamespaceForPrefix(String prefix) DOCUMENT ME!
Namespace | NamespaceStack.addNamespace(String prefix, String uri) Adds a new namespace to the stack
Namespace | NamespaceStack.pop(String prefix) Pops a namepace from the stack with the given prefix and URI
Namespace | NamespaceStack.getDefaultNamespace()
protected Namespace | NamespaceStack.createNamespace(String prefix, String namespaceURI) Factory method to creeate new Namespace instances.
protected Namespace | NamespaceStack.findDefaultNamespace() Attempts to find the current default namespace on the stack right now or returns null if one could not be found
protected Namespace | NamespaceStack.remove(int index) Removes the namespace at the given index of the stack
Namespace | NamespaceCache.get(String prefix, String uri) DOCUMENT ME!
Namespace | NamespaceCache.get(String uri) DOCUMENT ME!
protected Namespace | NamespaceCache.createNamespace(String prefix, String uri) A factory method to create Namespaceinstance
Namespace | DefaultElement.getNamespaceForPrefix(String prefix)
Namespace | DefaultElement.getNamespaceForURI(String uri)
Namespace | AbstractElement.getNamespace()
Namespace | AbstractElement.getNamespaceForPrefix(String prefix)
Namespace | AbstractElement.getNamespaceForURI(String uri)
Namespace | AbstractAttribute.getNamespace()

Methods in org.dom4j.tree with parameters of type Namespace
QName | QNameCache.get(String name, Namespace namespace) DOCUMENT ME!
QName | QNameCache.get(String localName, Namespace namespace, String qName) DOCUMENT ME!
protected Map | QNameCache.getNamespaceCache(Namespace namespace) DOCUMENT ME!
protected QName | QNameCache.createQName(String name, Namespace namespace) Factory method to create a new QName object which can be overloaded to create derived QName instances
protected QName | QNameCache.createQName(String name, Namespace namespace, String qualifiedName) Factory method to create a new QName object which can be overloaded to create derived QName instances
void | NamespaceStack.push(Namespace namespace) Pushes the given namespace onto the stack so that its prefix becomes available.
boolean | NamespaceStack.contains(Namespace namespace) DOCUMENT ME!
protected QName | NamespaceStack.pushQName(String localName, String qualifiedName, Namespace namespace, String prefix) Adds the QName to the stack of available QNames
protected QName | NamespaceStack.createQName(String localName, String qualifiedName, Namespace namespace) Factory method to creeate new QName instances.
Element | DefaultElement.element(String name, Namespace namespace)
Attribute | DefaultElement.attribute(String name, Namespace namespace)
void | AbstractElement.setNamespace(Namespace namespace)
Element | AbstractElement.element(String name, Namespace namespace)
List | AbstractElement.elements(String name, Namespace namespace)
Iterator | AbstractElement.elementIterator(String name, Namespace ns)
Attribute | AbstractElement.attribute(String name, Namespace namespace)
void | AbstractElement.add(Namespace namespace)
boolean | AbstractElement.remove(Namespace namespace)
void | AbstractAttribute.setNamespace(Namespace namespace)

Constructors in org.dom4j.tree with parameters of type Namespace
FlyweightAttribute(String name, String value, Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.
DefaultElement(String name, Namespace namespace)
DefaultAttribute(String name, String value, Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.
DefaultAttribute(Element parent, String name, String value, Namespace namespace)
Creates the Attribute with the specified local name, value and Namespace.
BaseElement(String name, Namespace namespace)

Uses of Namespace in org.dom4j.util

Methods in org.dom4j.util that return Namespace
 Namespace ProxyDocumentFactory.createNamespace(String prefix, String uri)

Methods in org.dom4j.util with parameters of type Namespace
QName | ProxyDocumentFactory.createQName(String localName, Namespace namespace)
int | NodeComparator.compare(Namespace n1, Namespace n2)

Constructors in org.dom4j.util with parameters of type Namespace
NonLazyElement(String name, Namespace namespace)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Node (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Node

Packages that use Node
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.rule.pattern |
org.dom4j.swing | A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.
org.dom4j.xpath | Provides the core tools needed to use the XPath library

Uses of Node in org.dom4j

Subinterfaces of Node in org.dom4j
interface | Attribute Attribute defines an XML attribute.
interface | Branch Branch interface defines the common behaviour for Nodes which can contain child nodes (content) such as XML elements and documents.
interface | CDATA CDATA defines an XML CDATA section.
interface | CharacterData CharacterData is a marker interface for character based nodes such as the CDATA,Comment and Text nodes.
interface | Comment Comment defines the behavior of an XML comment.
interface | Document Document defines an XML Document.
interface | DocumentType DocumentType defines an XML DOCTYPE declaration.
interface | Element Element interface defines an XML element.
interface | Entity Entity defines an XML entity.
interface | ProcessingInstruction ProcessingInstruction defines an XML processing instruction.
interface | Text Text defines an XML Text node.

Classes in org.dom4j that implement Node
 class Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.

Methods in org.dom4j that return Node
Node | XPath.selectSingleNode(Object context) selectSingleNode evaluates this XPath expression on the given Nodeor Listof Nodes and returns the result as a single Node instance.
Node | Node.detach() Removes this node from its parent if there is one.
Node | Node.selectSingleNode(String xpathExpression) selectSingleNode evaluates an XPath expression and returns the result as a single Node instance.
Node | Node.asXPathResult(Element parent) asXPathResult returns a version of this node which is capable of being an XPath result.
protected Node | Namespace.createXPathResult(Element parent)
Node | Element.getXPathResult(int index) Returns a node at the given index suitable for an XPath result set.
Node | Branch.node(int index) Returns the Node at the specified index position.

Methods in org.dom4j with parameters of type Node
boolean | XPath.matches(Node node) matches returns true if the given node matches the XPath expression.
boolean | NodeFilter.matches(Node node) matches returns true if the given node matches the filter condition.
static List | DocumentHelper.selectNodes(String xpathFilterExpression, Node node) selectNodes performs the given XPath expression on the Listof Nodeinstances appending all the results together into a single list.
int | Branch.indexOf(Node node) Returns the index of the given node if it is a child node of this branch or -1 if the given node is not a child node.
void | Branch.add(Node node) Adds the given Node or throws IllegalAddException if the given node is not of a valid type.
boolean | Branch.remove(Node node) Removes the given Node if the node is an immediate child of this branch.

Constructors in org.dom4j with parameters of type Node
IllegalAddException(Element parent, Node node, String reason)
IllegalAddException(Branch parent, Node node, String reason)

Uses of Node in org.dom4j.bean

Classes in org.dom4j.bean that implement Node
class | BeanAttribute BeanAttribute represents a mutable XML attribute which is backed by a property of the JavaBean of its parent element.
class | BeanElement BeanElement uses a Java Bean to store its attributes.

Uses of Node in org.dom4j.datatype

Classes in org.dom4j.datatype that implement Node
class | DatatypeAttribute DatatypeAttribute represents an Attribute which supports the XML Schema Data Types specification.
class | DatatypeElement DatatypeElement represents an Element which supports the XML Schema Data Types specification.

Methods in org.dom4j.datatype with parameters of type Node
protected void | DatatypeElement.childAdded(Node node) Override to force lazy recreation of data object
protected void | DatatypeElement.childRemoved(Node node) Override to force lazy recreation of data object

Uses of Node in org.dom4j.dom

Classes in org.dom4j.dom that implement Node
class | DOMAttribute DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.
class | DOMCDATA DOMCDATA implements a CDATA Section which supports the W3C DOM API.
class | DOMComment DOMText implements a Text node which supports the W3C DOM API.
class | DOMDocument DOMDocument implements an XML document which supports the W3C DOM API.
class | DOMDocumentType DOMDocumentType implements a DocumentType node which supports the W3C DOM API.
class | DOMElement DOMElement implements an XML element which supports the W3C DOM API.
class | DOMEntityReference DOMEntity implements a Entity node which supports the W3C DOM API.
class | DOMNamespace DOMNamespace implements a Namespace that is compatable with the DOM API.
class | DOMProcessingInstruction DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.
class | DOMText DOMText implements a Text node which supports the W3C DOM API.

Methods in org.dom4j.dom with parameters of type Node
static boolean | DOMNodeHelper.supports(Node node, String feature, String version)
static String | DOMNodeHelper.getNamespaceURI(Node node)
static String | DOMNodeHelper.getPrefix(Node node)
static String | DOMNodeHelper.getLocalName(Node node)
static void | DOMNodeHelper.setPrefix(Node node, String prefix)
static String | DOMNodeHelper.getNodeValue(Node node)
static void | DOMNodeHelper.setNodeValue(Node node, String nodeValue)
static Node | DOMNodeHelper.getParentNode(Node node)
static NodeList | DOMNodeHelper.getChildNodes(Node node)
static Node | DOMNodeHelper.getFirstChild(Node node)
static Node | DOMNodeHelper.getLastChild(Node node)
static Node | DOMNodeHelper.getPreviousSibling(Node node)
static Node | DOMNodeHelper.getNextSibling(Node node)
static NamedNodeMap | DOMNodeHelper.getAttributes(Node node)
static Document | DOMNodeHelper.getOwnerDocument(Node node)
static Node | DOMNodeHelper.insertBefore(Node node, Node newChild, Node refChild)
static Node | DOMNodeHelper.replaceChild(Node node, Node newChild, Node oldChild)
static Node | DOMNodeHelper.removeChild(Node node, Node oldChild)
static Node | DOMNodeHelper.appendChild(Node node, Node newChild)
static boolean | DOMNodeHelper.hasChildNodes(Node node)
static Node | DOMNodeHelper.cloneNode(Node node, boolean deep)
static void | DOMNodeHelper.normalize(Node node)
static boolean | DOMNodeHelper.isSupported(Node n, String feature, String version)
static boolean | DOMNodeHelper.hasAttributes(Node node)
static Node | DOMNodeHelper.asDOMNode(Node node)
static Element | DOMNodeHelper.asDOMElement(Node element)
static Attr | DOMNodeHelper.asDOMAttr(Node attribute)

Uses of Node in org.dom4j.io

Methods in org.dom4j.io that return Node
 Node STAXEventReader.readNode(javax.xml.stream.XMLEventReader reader)
Reads a Nodefrom the event stream.

Methods in org.dom4j.io with parameters of type Node
void | XMLWriter.write(Node node) Writes the given Node.
protected void | XMLWriter.writeNodeText(Node node) This method is used to write out Nodes that contain text and still allow for xml:space to be handled properly.
protected void | XMLWriter.writeNode(Node node)
void | STAXEventWriter.writeNode(Node n) Writes a DOM4J Nodeto the stream.
void | SAXWriter.write(Node node) A polymorphic method to write any Node to this SAX stream

Constructors in org.dom4j.io with parameters of type Node
DocumentSource(Node node)
Creates a JAXP SAXSourcefor the given Node.

Uses of Node in org.dom4j.rule

Methods in org.dom4j.rule with parameters of type Node
void | Stylesheet.run(Node node)
void | Stylesheet.run(Node node, String mode)
Rule | RuleSet.getMatchingRule(Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.
Rule | RuleManager.getMatchingRule(String modeName, Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.
boolean | Rule.matches(Node node) DOCUMENT ME!
boolean | Pattern.matches(Node node) DOCUMENT ME!
void | NullAction.run(Node node)
void | Mode.fireRule(Node node) Runs the actions associated with the given node
Rule | Mode.getMatchingRule(Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.
void | Action.run(Node node)

Uses of Node in org.dom4j.rule.pattern

Methods in org.dom4j.rule.pattern with parameters of type Node
boolean | NodeTypePattern.matches(Node node)
boolean | DefaultPattern.matches(Node node)

Uses of Node in org.dom4j.swing

Fields in org.dom4j.swing declared as Node
protected  Node LeafTreeNode.xmlNode
The dom4j Node which contains the

Methods in org.dom4j.swing that return Node
 Node LeafTreeNode.getXmlNode()

Methods in org.dom4j.swing with parameters of type Node
protected  TreeNode BranchTreeNode.createChildTreeNode(Node xmlNode)
Factory method to create child tree nodes for a given XML node type

Constructors in org.dom4j.swing with parameters of type Node
LeafTreeNode(Node xmlNode)
LeafTreeNode(TreeNode parent, Node xmlNode)

Uses of Node in org.dom4j.tree

Classes in org.dom4j.tree that implement Node
class | AbstractAttribute AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractBranch AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractCDATA AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractCharacterData AbstractCharacterData is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractComment AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractDocument AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractDocumentType AbstractDocumentType is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractElement AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractEntity AbstractEntity is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractNode AbstractNode is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractProcessingInstruction AbstractProcessingInstruction is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractText AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
class | BaseElement BaseElement is a useful base class for implemementation inheritence of an XML element.
class | DefaultAttribute DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.
class | DefaultCDATA DefaultCDATA is the default CDATA implementation.
class | DefaultComment DefaultComment is the default Comment implementation.
class | DefaultDocument DefaultDocument is the default DOM4J default implementation of an XML document.
class | DefaultDocumentType DefaultDocumentType is the DOM4J default implementation of an XML document type.
class | DefaultElement DefaultElement is the default DOM4J default implementation of an XML element.
class | DefaultEntity DefaultEntity is the default Entity implementation.
class | DefaultNamespace DefaultNamespace implements a doubly linked node which supports the parent relationship and is mutable.
class | DefaultProcessingInstruction DefaultProcessingInstruction is the default Processing Instruction implementation.
class | DefaultText DefaultText is the default Text implementation.
class | FlyweightAttribute FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.
class | FlyweightCDATA FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.
class | FlyweightComment FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.
class | FlyweightEntity FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.
class | FlyweightProcessingInstruction FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.
class | FlyweightText FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.

Methods in org.dom4j.tree that return Node
protected Node | FlyweightText.createXPathResult(Element parent)
protected Node | FlyweightProcessingInstruction.createXPathResult(Element parent)
protected Node | FlyweightEntity.createXPathResult(Element parent)
protected Node | FlyweightComment.createXPathResult(Element parent)
protected Node | FlyweightCDATA.createXPathResult(Element parent)
Node | DefaultElement.node(int index)
protected Node | ContentListFacade.asNode(Object object)
protected Node | BackedList.asNode(Object object)
Node | AbstractNode.detach()
Node | AbstractNode.selectSingleNode(String xpathExpression)
Node | AbstractNode.asXPathResult(Element parent)
protected Node | AbstractNode.createXPathResult(Element parent)
Node | AbstractElement.node(int index)
Node | AbstractElement.getXPathResult(int index)
Node | AbstractDocument.asXPathResult(Element parent)
Node | AbstractBranch.node(int index)
protected Node | AbstractAttribute.createXPathResult(Element parent)

Methods in org.dom4j.tree with parameters of type Node
 int DefaultElement.indexOf(Node node)
protected  void DefaultElement.addNewNode(Node node)
protected  boolean DefaultElement.removeNode(Node node)
protected  void DefaultDocument.addNode(Node node)
protected  void DefaultDocument.addNode(int index, Node node)
protected  boolean DefaultDocument.removeNode(Node node)
 int AbstractElement.indexOf(Node node)
 void AbstractElement.add(Node node)
 boolean AbstractElement.remove(Node node)
protected  void AbstractElement.addNode(Node node)
protected  void AbstractElement.addNode(int index, Node node)
protected  void AbstractElement.addNewNode(Node node)
Like addNode() but does not require a parent check
protected  void AbstractElement.addNewNode(int index, Node node)
protected  boolean AbstractElement.removeNode(Node node)
protected  void AbstractElement.childAdded(Node node)
Called when a new child node is added to create any parent relationships
protected  void AbstractElement.childRemoved(Node node)
protected  void AbstractDocument.childAdded(Node node)
protected  void AbstractDocument.childRemoved(Node node)
 void AbstractBranch.add(Node node)
 boolean AbstractBranch.remove(Node node)
 int AbstractBranch.indexOf(Node node)
protected abstract  void AbstractBranch.addNode(Node node)
protected abstract  void AbstractBranch.addNode(int index, Node node)
protected abstract  boolean AbstractBranch.removeNode(Node node)
protected abstract  void AbstractBranch.childAdded(Node node)
Called when a new child node has been added to me to allow any parent relationships to be created or events to be fired.
protected abstract  void AbstractBranch.childRemoved(Node node)
Called when a child node has been removed to allow any parent relationships to be deleted or events to be fired.
protected  void AbstractBranch.invalidNodeTypeAddException(Node node)
Called when an invalid node has been added.

Uses of Node in org.dom4j.util

Classes in org.dom4j.util that implement Node
class | IndexedElement IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
class | NonLazyElement NonLazyElement is the default DOM4J default implementation of an XML element.
class | UserDataAttribute UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataAttribute.setData(Object)will get and set the values of a user data object.
class | UserDataElement UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.

Methods in org.dom4j.util with parameters of type Node
int | NodeComparator.compare(Node n1, Node n2)
protected void | IndexedElement.addNode(Node node)
protected boolean | IndexedElement.removeNode(Node node)

Uses of Node in org.dom4j.xpath

Methods in org.dom4j.xpath that return Node
 Node DefaultXPath.selectSingleNode(Object context)

Methods in org.dom4j.xpath with parameters of type Node
boolean | XPathPattern.matches(Node node)
boolean | DefaultXPath.matches(Node node)
protected Object | DefaultXPath.getCompareValue(Node node) DOCUMENT ME!

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.NodeFilter (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.NodeFilter

Packages that use NodeFilter
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.rule.pattern |
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.
org.dom4j.xpath | Provides the core tools needed to use the XPath library

Uses of NodeFilter in org.dom4j

Subinterfaces of NodeFilter in org.dom4j
 interface XPath
XPath represents an XPath expression after it has been parsed from a String.

Methods in org.dom4j that return NodeFilter
static NodeFilter | DocumentHelper.createXPathFilter(String xpathFilterExpression) createXPathFilter parses a NodeFilter from the given XPath filter expression using the singleton DocumentFactory.
NodeFilter | DocumentFactory.createXPathFilter(String xpathFilterExpression, org.jaxen.VariableContext variableContext) createXPathFilter parses a NodeFilter from the given XPath filter expression.
NodeFilter | DocumentFactory.createXPathFilter(String xpathFilterExpression) createXPathFilter parses a NodeFilter from the given XPath filter expression.

Uses of NodeFilter in org.dom4j.rule

Subinterfaces of NodeFilter in org.dom4j.rule
 interface Pattern
Pattern defines the behaviour for pattern in the XSLT processing model.

Uses of NodeFilter in org.dom4j.rule.pattern

Classes in org.dom4j.rule.pattern that implement NodeFilter
class | DefaultPattern DefaultPattern a default implementation of Pattern which can take any XPath implementation or NodeFilter for defining the pattern.
class | NodeTypePattern NodeTypePattern implements a Pattern which matches any node of the given node type.

Constructors in org.dom4j.rule.pattern with parameters of type NodeFilter
DefaultPattern(NodeFilter filter)

Uses of NodeFilter in org.dom4j.tree

Methods in org.dom4j.tree that return NodeFilter
 NodeFilter AbstractNode.createXPathFilter(String patternText)

Uses of NodeFilter in org.dom4j.util

Methods in org.dom4j.util that return NodeFilter
NodeFilter | ProxyDocumentFactory.createXPathFilter(String xpathFilterExpression, org.jaxen.VariableContext variableContext)
NodeFilter | ProxyDocumentFactory.createXPathFilter(String xpathFilterExpression)

Uses of NodeFilter in org.dom4j.xpath

Classes in org.dom4j.xpath that implement NodeFilter
class | DefaultXPath Default implementation of XPathwhich uses the Jaxen project.
class | XPathPattern XPathPattern is an implementation of Pattern which uses an XPath xpath.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.ProcessingInstruction (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.ProcessingInstruction

Packages that use ProcessingInstruction
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of ProcessingInstruction in org.dom4j

Methods in org.dom4j that return ProcessingInstruction
static ProcessingInstruction | DocumentHelper.createProcessingInstruction(String pi, String d)
static ProcessingInstruction | DocumentHelper.createProcessingInstruction(String pi, Map data)
ProcessingInstruction | DocumentFactory.createProcessingInstruction(String target, String data)
ProcessingInstruction | DocumentFactory.createProcessingInstruction(String target, Map data)
ProcessingInstruction | Branch.processingInstruction(String target) DOCUMENT ME!

Methods in org.dom4j with parameters of type ProcessingInstruction
void | VisitorSupport.visit(ProcessingInstruction node)
void | Visitor.visit(ProcessingInstruction node) Visits the given ProcessingInstruction
void | Branch.add(ProcessingInstruction pi) Adds the given ProcessingInstruction to this branch.
boolean | Branch.remove(ProcessingInstruction pi) Removes the given ProcessingInstruction if the node is an immediate child of this branch.

Uses of ProcessingInstruction in org.dom4j.dom

Classes in org.dom4j.dom that implement ProcessingInstruction
 class DOMProcessingInstruction
DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.

Methods in org.dom4j.dom that return ProcessingInstruction
ProcessingInstruction | DOMDocumentFactory.createProcessingInstruction(String target, String data)
ProcessingInstruction | DOMDocumentFactory.createProcessingInstruction(String target, Map data)

Uses of ProcessingInstruction in org.dom4j.io

Methods in org.dom4j.io that return ProcessingInstruction
ProcessingInstruction | STAXEventReader.readProcessingInstruction(javax.xml.stream.XMLEventReader reader) Constructs a DOM4J ProcessingInstruction from the provided event stream.
ProcessingInstruction | STAXEventReader.createProcessingInstruction(javax.xml.stream.events.ProcessingInstruction pi) Constructs a new DOM4J ProcessingInstruction from the provided StAX ProcessingInstruction event.

Methods in org.dom4j.io with parameters of type ProcessingInstruction
void | XMLWriter.write(ProcessingInstruction processingInstruction) Writes the given ProcessingInstruction.
protected void | XMLWriter.writeProcessingInstruction(ProcessingInstruction pi)
void | STAXEventWriter.writeProcessingInstruction(ProcessingInstruction pi) Writes a DOM4J ProcessingInstructionto the stream.
javax.xml.stream.events.ProcessingInstruction | STAXEventWriter.createProcessingInstruction(ProcessingInstruction pi) Constructs a STAX ProcessingInstruction event from a DOM4J ProcessingInstruction.
void | SAXWriter.write(ProcessingInstruction pi) Generates SAX events for the given ProcessingInstruction
protected void | DOMWriter.appendDOMTree(Document domDoc, Node domCurrent, ProcessingInstruction pi)

Uses of ProcessingInstruction in org.dom4j.tree

Classes in org.dom4j.tree that implement ProcessingInstruction
class | AbstractProcessingInstruction AbstractProcessingInstruction is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultProcessingInstruction DefaultProcessingInstruction is the default Processing Instruction implementation.
class | FlyweightProcessingInstruction FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.

Methods in org.dom4j.tree that return ProcessingInstruction
ProcessingInstruction | DefaultElement.processingInstruction(String target)
ProcessingInstruction | DefaultDocument.processingInstruction(String target)
ProcessingInstruction | AbstractElement.processingInstruction(String target)

Methods in org.dom4j.tree with parameters of type ProcessingInstruction
void | AbstractElement.add(ProcessingInstruction pi)
boolean | AbstractElement.remove(ProcessingInstruction pi)
void | AbstractBranch.add(ProcessingInstruction pi)
boolean | AbstractBranch.remove(ProcessingInstruction pi)

Uses of ProcessingInstruction in org.dom4j.util

Methods in org.dom4j.util that return ProcessingInstruction
ProcessingInstruction | ProxyDocumentFactory.createProcessingInstruction(String target, String data)
ProcessingInstruction | ProxyDocumentFactory.createProcessingInstruction(String target, Map data)

Methods in org.dom4j.util with parameters of type ProcessingInstruction
 int NodeComparator.compare(ProcessingInstruction n1, ProcessingInstruction n2)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.QName (dom4j 1.6.1 API)

Uses of Class
org.dom4j.QName

Packages that use QName
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of QName in org.dom4j

Methods in org.dom4j that return QName
static QName | QName.get(String name)
static QName | QName.get(String name, Namespace namespace)
static QName | QName.get(String name, String prefix, String uri)
static QName | QName.get(String qualifiedName, String uri)
static QName | QName.get(String localName, Namespace namespace, String qualifiedName)
QName | Element.getQName() Returns the QName of this element which represents the local name, the qualified name and the Namespace.
QName | Element.getQName(String qualifiedName) Returns the QName for the given qualified name, using the namespace URI in scope for the given prefix of the qualified name or the default namespace if the qualified name has no prefix.
static QName | DocumentHelper.createQName(String localName, Namespace namespace)
static QName | DocumentHelper.createQName(String localName)
QName | DocumentFactory.createQName(String localName, Namespace namespace)
QName | DocumentFactory.createQName(String localName)
QName | DocumentFactory.createQName(String name, String prefix, String uri)
QName | DocumentFactory.createQName(String qualifiedName, String uri)
protected QName | DocumentFactory.intern(QName qname) DOCUMENT ME!
QName | Attribute.getQName() Returns the QName of this attribute which represents the local name, the qualified name and the Namespace.

Methods in org.dom4j with parameters of type QName
 void Element.setQName(QName qname)
Sets the QName of this element which represents the local name, the qualified name and the Namespace.
 Element Element.addAttribute(QName qName, String value)
Adds the attribute value of the given fully qualified name.
 Attribute Element.attribute(QName qName)
DOCUMENT ME!
 String Element.attributeValue(QName qName)
This returns the attribute value for the attribute with the given fully qualified name or null if there is no such attribute or the empty string if the attribute value is empty.
 String Element.attributeValue(QName qName, String defaultValue)
This returns the attribute value for the attribute with the given fully qualified name or the default value if there is no such attribute value.
 void Element.setAttributeValue(QName qName, String value)
Deprecated. As of version 0.5. Please use Element.addAttribute(QName,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
 Element Element.element(QName qName)
Returns the first element for the given fully qualified name.
 List Element.elements(QName qName)
Returns the elements contained in this element with the given fully qualified name.
 Iterator Element.elementIterator(QName qName)
Returns an iterator over the elements contained in this element which match the given fully qualified name.
 Element Element.createCopy(QName qName)
Creates a deep copy of this element with the given fully qualified name.
 String Element.elementText(QName qname)
 String Element.elementTextTrim(QName qname)
static Element DocumentHelper.createElement(QName qname)
static Attribute DocumentHelper.createAttribute(Element owner, QName qname, String value)
 Element DocumentFactory.createElement(QName qname)
 Attribute DocumentFactory.createAttribute(Element owner, QName qname, String value)
protected  QName DocumentFactory.intern(QName qname)
DOCUMENT ME!
 Element Branch.addElement(QName qname)
Adds a new Element node with the given QNameto this branch and returns a reference to the new node.

Uses of QName in org.dom4j.bean

Methods in org.dom4j.bean that return QName
QName | BeanMetaData.getQName(int index)
QName | BeanAttributeList.getQName(int index)
QName | BeanAttribute.getQName()

Methods in org.dom4j.bean with parameters of type QName
int | BeanMetaData.getIndex(QName qName)
Attribute | BeanElement.attribute(QName qname)
Element | BeanElement.addAttribute(QName qName, String value)
Element | BeanDocumentFactory.createElement(QName qname)
Element | BeanDocumentFactory.createElement(QName qname, Attributes attributes)
Attribute | BeanDocumentFactory.createAttribute(Element owner, QName qname, String value)
protected Object | BeanDocumentFactory.createBean(QName qname)
protected Object | BeanDocumentFactory.createBean(QName qname, Attributes attributes)
Attribute | BeanAttributeList.attribute(QName qname)

Constructors in org.dom4j.bean with parameters of type QName
BeanElement(QName qname, Object bean)
BeanElement(QName qname)

Uses of QName in org.dom4j.datatype

Methods in org.dom4j.datatype that return QName
QName | DatatypeElementFactory.getQName() DOCUMENT ME!
QName | DatatypeAttribute.getQName()

Methods in org.dom4j.datatype with parameters of type QName
com.sun.msv.datatype.xsd.XSDatatype | DatatypeElementFactory.getAttributeXSDatatype(QName attributeQName) DOCUMENT ME!
void | DatatypeElementFactory.setAttributeXSDatatype(QName attributeQName, com.sun.msv.datatype.xsd.XSDatatype type) Registers the given XSDatatype for the given <attribute> QNames
com.sun.msv.datatype.xsd.XSDatatype | DatatypeElementFactory.getChildElementXSDatatype(QName qname) DOCUMENT ME!
void | DatatypeElementFactory.setChildElementXSDatatype(QName qname, com.sun.msv.datatype.xsd.XSDatatype dataType)
Element | DatatypeElementFactory.createElement(QName qname)
Attribute | DatatypeElementFactory.createAttribute(Element owner, QName qname, String value)
DatatypeElementFactory | DatatypeDocumentFactory.getElementFactory(QName elementQName) Registers the given DatatypeElementFactory for the given <element> schema element
Attribute | DatatypeDocumentFactory.createAttribute(Element owner, QName qname, String value)

Constructors in org.dom4j.datatype with parameters of type QName
DatatypeElementFactory(QName elementQName)
DatatypeElement(QName qname, com.sun.msv.datatype.xsd.XSDatatype datatype)
DatatypeElement(QName qname, int attributeCount, com.sun.msv.datatype.xsd.XSDatatype type)
DatatypeAttribute(QName qname, com.sun.msv.datatype.xsd.XSDatatype datatype)
DatatypeAttribute(QName qname, com.sun.msv.datatype.xsd.XSDatatype datatype, String text)

Uses of QName in org.dom4j.dom

Methods in org.dom4j.dom that return QName
protected  QName DOMElement.getQName(String namespace, String qualifiedName)

Methods in org.dom4j.dom with parameters of type QName
Element | DOMDocumentFactory.createElement(QName qname)
Element | DOMDocumentFactory.createElement(QName qname, int attributeCount)
Attribute | DOMDocumentFactory.createAttribute(Element owner, QName qname, String value)

Constructors in org.dom4j.dom with parameters of type QName
DOMElement(QName qname)
DOMElement(QName qname, int attributeCount)
DOMAttribute(QName qname)
DOMAttribute(QName qname, String value)
DOMAttribute(Element parent, QName qname, String value)

Uses of QName in org.dom4j.io

Methods in org.dom4j.io that return QName
 QName STAXEventReader.createQName(javax.xml.namespace.QName qname)
Constructs a new DOM4J QName from the provided JAXP QName.

Methods in org.dom4j.io with parameters of type QName
 javax.xml.namespace.QName STAXEventWriter.createQName(QName qname)
Constructs a STAX QNamefrom a DOM4J QName.

Uses of QName in org.dom4j.tree

Methods in org.dom4j.tree that return QName
QName | QNameCache.get(String name) DOCUMENT ME!
QName | QNameCache.get(String name, Namespace namespace) DOCUMENT ME!
QName | QNameCache.get(String localName, Namespace namespace, String qName) DOCUMENT ME!
QName | QNameCache.get(String qualifiedName, String uri)
QName | QNameCache.intern(QName qname) DOCUMENT ME!
protected QName | QNameCache.createQName(String name) Factory method to create a new QName object which can be overloaded to create derived QName instances
protected QName | QNameCache.createQName(String name, Namespace namespace) Factory method to create a new QName object which can be overloaded to create derived QName instances
protected QName | QNameCache.createQName(String name, Namespace namespace, String qualifiedName) Factory method to create a new QName object which can be overloaded to create derived QName instances
QName | NamespaceStack.getQName(String namespaceURI, String localName, String qualifiedName)
QName | NamespaceStack.getAttributeQName(String namespaceURI, String localName, String qualifiedName)
protected QName | NamespaceStack.pushQName(String localName, String qualifiedName, Namespace namespace, String prefix) Adds the QName to the stack of available QNames
protected QName | NamespaceStack.createQName(String localName, String qualifiedName, Namespace namespace) Factory method to creeate new QName instances.
QName | FlyweightAttribute.getQName()
QName | DefaultElement.getQName()
QName | BaseElement.getQName()
QName | AbstractElement.getQName(String qualifiedName)

Methods in org.dom4j.tree with parameters of type QName
 QName QNameCache.intern(QName qname)
DOCUMENT ME!
 void DefaultElement.setQName(QName name)
 Element DefaultElement.element(QName qName)
 Attribute DefaultElement.attribute(QName qName)
 void BaseElement.setQName(QName name)
 Element AbstractElement.element(QName qName)
 List AbstractElement.elements(QName qName)
 Iterator AbstractElement.elementIterator(QName qName)
 Attribute AbstractElement.attribute(QName qName)
 String AbstractElement.attributeValue(QName qName)
 String AbstractElement.attributeValue(QName qName, String defaultValue)
 void AbstractElement.setAttributeValue(QName qName, String value)
Deprecated. As of version 0.5. Please use AbstractElement.addAttribute(String,String) instead. WILL BE REMOVED IN dom4j-1.6 !!
 Element AbstractElement.addAttribute(QName qName, String value)
 String AbstractElement.elementText(QName qName)
 String AbstractElement.elementTextTrim(QName qName)
 Element AbstractElement.createCopy(QName qName)
protected  Element AbstractElement.createElement(QName qName)
 Element AbstractDocument.addElement(QName qName)
 Element AbstractBranch.addElement(QName qname)

Constructors in org.dom4j.tree with parameters of type QName
FlyweightAttribute(QName qname)
FlyweightAttribute(QName qname, String value)
ElementQNameIterator(Iterator proxy, QName qName)
Deprecated.
DefaultElement(QName qname)
DefaultElement(QName qname, int attributeCount)
DefaultAttribute(QName qname)
DefaultAttribute(QName qname, String value)
DefaultAttribute(Element parent, QName qname, String value)
BaseElement(QName qname)

Uses of QName in org.dom4j.util

Fields in org.dom4j.util declared as QName
protected static QName | XMLErrorHandler.ERROR_QNAME
protected static QName | XMLErrorHandler.FATALERROR_QNAME
protected static QName | XMLErrorHandler.WARNING_QNAME

Methods in org.dom4j.util that return QName
QName | XMLErrorHandler.getErrorQName()
QName | XMLErrorHandler.getFatalErrorQName()
QName | XMLErrorHandler.getWarningQName()
QName | ProxyDocumentFactory.createQName(String localName, Namespace namespace)
QName | ProxyDocumentFactory.createQName(String localName)
QName | ProxyDocumentFactory.createQName(String name, String prefix, String uri)
QName | ProxyDocumentFactory.createQName(String qualifiedName, String uri)

Methods in org.dom4j.util with parameters of type QName
void | XMLErrorHandler.setErrorQName(QName errorQName)
void | XMLErrorHandler.setFatalErrorQName(QName fatalErrorQName)
void | XMLErrorHandler.setWarningQName(QName warningQName)
protected Element | UserDataElement.createElement(QName qName)
Element | UserDataDocumentFactory.createElement(QName qname)
Attribute | UserDataDocumentFactory.createAttribute(Element owner, QName qname, String value)
Element | ProxyDocumentFactory.createElement(QName qname)
Attribute | ProxyDocumentFactory.createAttribute(Element owner, QName qname, String value)
Element | NonLazyDocumentFactory.createElement(QName qname)
int | NodeComparator.compare(QName n1, QName n2)
Attribute | IndexedElement.attribute(QName qName)
Element | IndexedElement.element(QName qName)
List | IndexedElement.elements(QName qName)
Element | IndexedDocumentFactory.createElement(QName qname)
Element | IndexedDocumentFactory.createElement(QName qname, int attributeCount)
static boolean | AttributeHelper.booleanValue(Element element, QName attributeQName)

Constructors in org.dom4j.util with parameters of type QName
UserDataElement(QName qname)
UserDataAttribute(QName qname)
UserDataAttribute(QName qname, String text)
NonLazyElement(QName qname)
NonLazyElement(QName qname, int attributeCount)
IndexedElement(QName qname)
IndexedElement(QName qname, int attributeCount)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Text (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Text

Packages that use Text
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of Text in org.dom4j

Methods in org.dom4j that return Text
static Text | DocumentHelper.createText(String text)
Text | DocumentFactory.createText(String text)

Methods in org.dom4j with parameters of type Text
void | VisitorSupport.visit(Text node)
void | Visitor.visit(Text node) Visits the given Text
void | Element.add(Text text) Adds the given Text to this element.
boolean | Element.remove(Text text) Removes the given Text if the node is an immediate child of this element.

Uses of Text in org.dom4j.dom

Classes in org.dom4j.dom that implement Text
 class DOMText
DOMText implements a Text node which supports the W3C DOM API.

Methods in org.dom4j.dom that return Text
protected Text | DOMText.createText(String text)
Text | DOMDocumentFactory.createText(String text)

Uses of Text in org.dom4j.io

Methods in org.dom4j.io with parameters of type Text
void | XMLWriter.write(Text text) Writes the given Text.
void | STAXEventWriter.writeText(Text text) Writes a DOM4J Textto the stream.
javax.xml.stream.events.Characters | STAXEventWriter.createCharacters(Text text) Constructs a STAX Charactersevent from a DOM4J Text.

Uses of Text in org.dom4j.tree

Classes in org.dom4j.tree that implement Text
class | AbstractText AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultText DefaultText is the default Text implementation.
class | FlyweightText FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.

Methods in org.dom4j.tree with parameters of type Text
void | AbstractElement.add(Text text)
boolean | AbstractElement.remove(Text text)

Uses of Text in org.dom4j.util

Methods in org.dom4j.util that return Text
 Text ProxyDocumentFactory.createText(String text)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.Visitor (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.Visitor

Packages that use Visitor
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of Visitor in org.dom4j

Classes in org.dom4j that implement Visitor
 class VisitorSupport
VisitorSupport is an abstract base class which is useful for implementation inheritence or when using anonymous inner classes to create simple Visitor implementations.

Methods in org.dom4j with parameters of type Visitor
void | Node.accept(Visitor visitor) accept is the method used in the Visitor Pattern.
void | Namespace.accept(Visitor visitor)

Uses of Visitor in org.dom4j.tree

Methods in org.dom4j.tree with parameters of type Visitor
void | AbstractText.accept(Visitor visitor)
void | AbstractProcessingInstruction.accept(Visitor visitor)
void | AbstractEntity.accept(Visitor visitor)
void | AbstractElement.accept(Visitor visitor) accept method is the Visitor Pattern method.
void | AbstractDocumentType.accept(Visitor visitor)
void | AbstractDocument.accept(Visitor visitor) accept method is the Visitor Pattern method.
void | AbstractComment.accept(Visitor visitor)
void | AbstractCDATA.accept(Visitor visitor)
void | AbstractAttribute.accept(Visitor visitor)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.VisitorSupport (dom4j 1.6.1 API)

Uses of Class
org.dom4j.VisitorSupport

No usage of org.dom4j.VisitorSupport

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.XPath (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.XPath

Packages that use XPath
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.swing | A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.
org.dom4j.xpath | Provides the core tools needed to use the XPath library

Uses of XPath in org.dom4j

Methods in org.dom4j that return XPath
XPath | Node.createXPath(String xpathExpression) createXPath creates an XPath object for the given xpathExpression.
static XPath | DocumentHelper.createXPath(String xpathExpression) createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.
static XPath | DocumentHelper.createXPath(String xpathExpression, org.jaxen.VariableContext context) createXPath parses an XPath expression and creates a new XPath XPath instance using the singleton DocumentFactory.
XPath | DocumentFactory.createXPath(String xpathExpression) createXPath parses an XPath expression and creates a new XPath XPath instance.
XPath | DocumentFactory.createXPath(String xpathExpression, org.jaxen.VariableContext variableContext) createXPath parses an XPath expression and creates a new XPath XPath instance.

Methods in org.dom4j with parameters of type XPath
List | XPath.selectNodes(Object context, XPath sortXPath) selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.
List | XPath.selectNodes(Object context, XPath sortXPath, boolean distinct) selectNodes evaluates the XPath expression on the given Nodeor Listof Nodes and returns the result as a List of Node s sorted by the sort XPath expression.

Uses of XPath in org.dom4j.rule

Methods in org.dom4j.rule with parameters of type XPath
void | Stylesheet.applyTemplates(Object input, XPath xpath) Processes the result of the xpath expression.
void | Stylesheet.applyTemplates(Object input, XPath xpath, String mode) Processes the result of the xpath expression in the given mode.

Uses of XPath in org.dom4j.swing

Methods in org.dom4j.swing that return XPath
XPath | XMLTableDefinition.getColumnXPath(int columnIndex) DOCUMENT ME!
XPath | XMLTableDefinition.getColumnNameXPath(int columnIndex) DOCUMENT ME!
XPath | XMLTableDefinition.getRowXPath() Getter for property rowXPath.
protected XPath | XMLTableDefinition.createXPath(String expression)
protected XPath | XMLTableDefinition.createColumnXPath(String expression)
XPath | XMLTableColumnDefinition.getXPath() Getter for property xpath.
XPath | XMLTableColumnDefinition.getColumnNameXPath() DOCUMENT ME!
protected XPath | XMLTableColumnDefinition.createXPath(String expression)

Methods in org.dom4j.swing with parameters of type XPath
void | XMLTableDefinition.setRowXPath(XPath rowXPath) Setter for property rowXPath.
void | XMLTableColumnDefinition.setXPath(XPath xPath) Setter for property xpath.
void | XMLTableColumnDefinition.setColumnNameXPath(XPath columnNameXPath) Setter for property columnNameXPath.

Constructors in org.dom4j.swing with parameters of type XPath
XMLTableColumnDefinition(String name, XPath xpath, int type)
XMLTableColumnDefinition(XPath columnXPath, XPath xpath, int type)

Uses of XPath in org.dom4j.tree

Methods in org.dom4j.tree that return XPath
 XPath AbstractNode.createXPath(String xpathExpression)

Uses of XPath in org.dom4j.util

Methods in org.dom4j.util that return XPath
XPath | ProxyDocumentFactory.createXPath(String xpathExpression)
XPath | ProxyDocumentFactory.createXPath(String xpathExpression, org.jaxen.VariableContext variableContext)

Uses of XPath in org.dom4j.xpath

Classes in org.dom4j.xpath that implement XPath
 class DefaultXPath
Default implementation of XPathwhich uses the Jaxen project.

Methods in org.dom4j.xpath with parameters of type XPath
List | DefaultXPath.selectNodes(Object context, XPath sortXPath)
List | DefaultXPath.selectNodes(Object context, XPath sortXPath, boolean distinct)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.XPathException (dom4j 1.6.1 API)

Uses of Class
org.dom4j.XPathException

Packages that use XPathException
org.dom4j.xpath Provides the core tools needed to use the XPath library

Uses of XPathException in org.dom4j.xpath

Methods in org.dom4j.xpath that throw XPathException
protected void | XPathPattern.handleJaxenException(org.jaxen.JaxenException exception)
protected void | DefaultXPath.handleJaxenException(org.jaxen.JaxenException exception)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.datatype (dom4j 1.6.1 API)

 org.dom4j.datatype
Classes
DatatypeAttribute
DatatypeDocumentFactory
DatatypeElement
DatatypeElementFactory
SchemaParser
Exceptions
InvalidSchemaException


Uses of Class org.dom4j.datatype.DatatypeAttribute (dom4j 1.6.1 API)

Uses of Class
org.dom4j.datatype.DatatypeAttribute

No usage of org.dom4j.datatype.DatatypeAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.datatype.DatatypeDocumentFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.datatype.DatatypeDocumentFactory

Packages that use DatatypeDocumentFactory
org.dom4j.datatype An implementation of the dom4j API which supports the XML Schema Data Types specification.

Uses of DatatypeDocumentFactory in org.dom4j.datatype

Fields in org.dom4j.datatype declared as DatatypeDocumentFactory
protected static DatatypeDocumentFactory DatatypeDocumentFactory.singleton
The Singleton instance

Constructors in org.dom4j.datatype with parameters of type DatatypeDocumentFactory
SchemaParser(DatatypeDocumentFactory documentFactory)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.datatype.DatatypeElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.datatype.DatatypeElement

No usage of org.dom4j.datatype.DatatypeElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.datatype.DatatypeElementFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.datatype.DatatypeElementFactory

Packages that use DatatypeElementFactory
org.dom4j.datatype An implementation of the dom4j API which supports the XML Schema Data Types specification.

Uses of DatatypeElementFactory in org.dom4j.datatype

Methods in org.dom4j.datatype that return DatatypeElementFactory
 DatatypeElementFactory DatatypeDocumentFactory.getElementFactory(QName elementQName)
Registers the given DatatypeElementFactory for the given <element> schema element

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.datatype.InvalidSchemaException (dom4j 1.6.1 API)

Uses of Class
org.dom4j.datatype.InvalidSchemaException

No usage of org.dom4j.datatype.InvalidSchemaException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.datatype.SchemaParser (dom4j 1.6.1 API)

Uses of Class
org.dom4j.datatype.SchemaParser

No usage of org.dom4j.datatype.SchemaParser

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.dom (dom4j 1.6.1 API)

 org.dom4j.dom
Classes
DOMAttribute
DOMAttributeNodeMap
DOMCDATA
DOMComment
DOMDocument
DOMDocumentFactory
DOMDocumentType
DOMElement
DOMEntityReference
DOMNamespace
DOMNodeHelper
DOMNodeHelper.EmptyNodeList
DOMProcessingInstruction
DOMText


Uses of Class org.dom4j.dom.DOMAttribute (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMAttribute

No usage of org.dom4j.dom.DOMAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMAttributeNodeMap (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMAttributeNodeMap

No usage of org.dom4j.dom.DOMAttributeNodeMap

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMCDATA (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMCDATA

No usage of org.dom4j.dom.DOMCDATA

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMComment (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMComment

No usage of org.dom4j.dom.DOMComment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMDocument (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMDocument

No usage of org.dom4j.dom.DOMDocument

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMDocumentFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMDocumentFactory

No usage of org.dom4j.dom.DOMDocumentFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMDocumentType (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMDocumentType

Packages that use DOMDocumentType
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DOMDocumentType in org.dom4j.dom

Methods in org.dom4j.dom that return DOMDocumentType
protected  DOMDocumentType DOMDocumentFactory.asDocumentType(DocumentType docType)

Constructors in org.dom4j.dom with parameters of type DOMDocumentType
DOMDocument(DOMDocumentType docType)
DOMDocument(DOMElement rootElement, DOMDocumentType docType)
DOMDocument(String name, DOMElement rootElement, DOMDocumentType docType)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMElement

Packages that use DOMElement
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DOMElement in org.dom4j.dom

Constructors in org.dom4j.dom with parameters of type DOMElement
DOMDocument(DOMElement rootElement)
DOMDocument(DOMElement rootElement, DOMDocumentType docType)
DOMDocument(String name, DOMElement rootElement, DOMDocumentType docType)
DOMAttributeNodeMap(DOMElement element)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMEntityReference (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMEntityReference

No usage of org.dom4j.dom.DOMEntityReference

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMNamespace (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMNamespace

No usage of org.dom4j.dom.DOMNamespace

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMNodeHelper (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMNodeHelper

No usage of org.dom4j.dom.DOMNodeHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMNodeHelper.EmptyNodeList (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMNodeHelper.EmptyNodeList

No usage of org.dom4j.dom.DOMNodeHelper.EmptyNodeList

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMProcessingInstruction (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMProcessingInstruction

No usage of org.dom4j.dom.DOMProcessingInstruction

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dom.DOMText (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dom.DOMText

No usage of org.dom4j.dom.DOMText

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.dtd (dom4j 1.6.1 API)

 org.dom4j.dtd
Classes
AttributeDecl
ElementDecl
ExternalEntityDecl
InternalEntityDecl


Uses of Class org.dom4j.dtd.AttributeDecl (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dtd.AttributeDecl

No usage of org.dom4j.dtd.AttributeDecl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dtd.ElementDecl (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dtd.ElementDecl

No usage of org.dom4j.dtd.ElementDecl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dtd.ExternalEntityDecl (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dtd.ExternalEntityDecl

No usage of org.dom4j.dtd.ExternalEntityDecl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.dtd.InternalEntityDecl (dom4j 1.6.1 API)

Uses of Class
org.dom4j.dtd.InternalEntityDecl

No usage of org.dom4j.dtd.InternalEntityDecl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.io (dom4j 1.6.1 API)

 org.dom4j.io
Interfaces
ElementModifier
Classes
DocumentResult
DocumentSource
DOMReader
DOMWriter
HTMLWriter
OutputFormat
SAXContentHandler
SAXEventRecorder
SAXModifier
SAXReader
SAXReader.SAXEntityResolver
SAXValidator
SAXWriter
STAXEventReader
STAXEventWriter
XMLResult
XMLWriter
XPP3Reader
XPPReader


Uses of Class org.dom4j.io.DocumentResult (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.DocumentResult

No usage of org.dom4j.io.DocumentResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.DocumentSource (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.DocumentSource

No usage of org.dom4j.io.DocumentSource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.DOMReader (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.DOMReader

No usage of org.dom4j.io.DOMReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.DOMWriter (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.DOMWriter

No usage of org.dom4j.io.DOMWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.io.ElementModifier (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.io.ElementModifier

Packages that use ElementModifier
org.dom4j.io Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.

Uses of ElementModifier in org.dom4j.io

Methods in org.dom4j.io with parameters of type ElementModifier
 void SAXModifier.addModifier(String path, ElementModifier modifier)
Adds the ElementModifierto be called when the specified element path is encounted while parsing the source.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.HTMLWriter (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.HTMLWriter

No usage of org.dom4j.io.HTMLWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.OutputFormat (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.OutputFormat

Packages that use OutputFormat
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.jaxb |

Uses of OutputFormat in org.dom4j.io

Fields in org.dom4j.io declared as OutputFormat
protected static OutputFormat | XMLWriter.DEFAULT_FORMAT
protected static OutputFormat | HTMLWriter.DEFAULT_HTML_FORMAT

Methods in org.dom4j.io that return OutputFormat
protected OutputFormat | XMLWriter.getOutputFormat() Lets subclasses get at the current format object, so they can call setTrimText, setNewLines, etc.
static OutputFormat | OutputFormat.createPrettyPrint() A static helper method to create the default pretty printing format.
static OutputFormat | OutputFormat.createCompactFormat() A static helper method to create the default compact format.

Constructors in org.dom4j.io with parameters of type OutputFormat
XMLWriter(Writer writer, OutputFormat format)
XMLWriter(OutputStream out, OutputFormat format)
XMLWriter(OutputFormat format)
XMLResult(Writer writer, OutputFormat format)
XMLResult(OutputStream out, OutputFormat format)
HTMLWriter(Writer writer, OutputFormat format)
HTMLWriter(OutputFormat format)
HTMLWriter(OutputStream out, OutputFormat format)

Uses of OutputFormat in org.dom4j.jaxb

Methods in org.dom4j.jaxb that return OutputFormat
 OutputFormat JAXBWriter.getOutputFormat()
Returns the OutputFormat that will be used when writing the XML stream.

Constructors in org.dom4j.jaxb with parameters of type OutputFormat
JAXBWriter(String contextPath, OutputFormat outputFormat)
Creates a new JAXBWriter for the given JAXB context path.
JAXBWriter(String contextPath, ClassLoader classloader, OutputFormat outputFormat)
Creates a new JAXBWriter for the given JAXB context path, using the specified Classloader.
JAXBModifier(String contextPath, OutputFormat outputFormat)
Creates a new JAXBModifier for the given JAXB context path.
JAXBModifier(String contextPath, ClassLoader classloader, OutputFormat outputFormat)
Creates a new JAXBModifier for the given JAXB context path, using the specified Classloader.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.SAXContentHandler (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.SAXContentHandler

Packages that use SAXContentHandler
org.dom4j.io Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.

Uses of SAXContentHandler in org.dom4j.io

Methods in org.dom4j.io that return SAXContentHandler
protected  SAXContentHandler SAXReader.createContentHandler(XMLReader reader)
Factory Method to allow user derived SAXContentHandler objects to be used

Constructors in org.dom4j.io with parameters of type SAXContentHandler
DocumentResult(SAXContentHandler contentHandler)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.SAXEventRecorder (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.SAXEventRecorder

No usage of org.dom4j.io.SAXEventRecorder

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.SAXModifier (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.SAXModifier

No usage of org.dom4j.io.SAXModifier

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.SAXReader (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.SAXReader

No usage of org.dom4j.io.SAXReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.SAXReader.SAXEntityResolver (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.SAXReader.SAXEntityResolver

No usage of org.dom4j.io.SAXReader.SAXEntityResolver

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.SAXValidator (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.SAXValidator

No usage of org.dom4j.io.SAXValidator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.SAXWriter (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.SAXWriter

No usage of org.dom4j.io.SAXWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.STAXEventReader (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.STAXEventReader

No usage of org.dom4j.io.STAXEventReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.STAXEventWriter (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.STAXEventWriter

No usage of org.dom4j.io.STAXEventWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.XMLResult (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.XMLResult

No usage of org.dom4j.io.XMLResult

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.XMLWriter (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.XMLWriter

Packages that use XMLWriter
org.dom4j.io Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.

Uses of XMLWriter in org.dom4j.io

Subclasses of XMLWriter in org.dom4j.io
 class HTMLWriter
HTMLWriter takes a DOM4J tree and formats it to a stream as HTML.

Methods in org.dom4j.io that return XMLWriter
XMLWriter | XMLResult.getXMLWriter()
XMLWriter | SAXModifier.getXMLWriter() Returns the current XMLWriter.

Methods in org.dom4j.io with parameters of type XMLWriter
void | XMLResult.setXMLWriter(XMLWriter writer)
void | SAXModifier.setXMLWriter(XMLWriter writer) Sets the XMLWriterused to write the modified document.

Constructors in org.dom4j.io with parameters of type XMLWriter
XMLResult(XMLWriter xmlWriter)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.XPP3Reader (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.XPP3Reader

No usage of org.dom4j.io.XPP3Reader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.io.XPPReader (dom4j 1.6.1 API)

Uses of Class
org.dom4j.io.XPPReader

No usage of org.dom4j.io.XPPReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.jaxb (dom4j 1.6.1 API)

 org.dom4j.jaxb
Interfaces
JAXBObjectHandler
JAXBObjectModifier
Classes
JAXBModifier
JAXBReader
JAXBWriter


Uses of Class org.dom4j.jaxb.JAXBModifier (dom4j 1.6.1 API)

Uses of Class
org.dom4j.jaxb.JAXBModifier

No usage of org.dom4j.jaxb.JAXBModifier

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.jaxb.JAXBObjectHandler (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.jaxb.JAXBObjectHandler

Packages that use JAXBObjectHandler
org.dom4j.jaxb

Uses of JAXBObjectHandler in org.dom4j.jaxb

Methods in org.dom4j.jaxb with parameters of type JAXBObjectHandler
 void JAXBReader.addObjectHandler(String path, JAXBObjectHandler handler)
Registers a JAXBObjectHandlerthat will be supplied with the unmarshalled representation of the xml fragment whenever the specified path is encounted.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.jaxb.JAXBObjectModifier (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.jaxb.JAXBObjectModifier

Packages that use JAXBObjectModifier
org.dom4j.jaxb

Uses of JAXBObjectModifier in org.dom4j.jaxb

Methods in org.dom4j.jaxb with parameters of type JAXBObjectModifier
 void JAXBModifier.addObjectModifier(String path, JAXBObjectModifier mod)
Adds the JAXBObjectModifierto be called when the specified xml path is encounted while parsing the source.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.jaxb.JAXBReader (dom4j 1.6.1 API)

Uses of Class
org.dom4j.jaxb.JAXBReader

No usage of org.dom4j.jaxb.JAXBReader

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.jaxb.JAXBWriter (dom4j 1.6.1 API)

Uses of Class
org.dom4j.jaxb.JAXBWriter

No usage of org.dom4j.jaxb.JAXBWriter

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.rule (dom4j 1.6.1 API)

 org.dom4j.rule
Interfaces
Action
Pattern
Classes
Mode
NullAction
Rule
RuleManager
RuleSet
Stylesheet


Uses of Interface org.dom4j.rule.Action (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.rule.Action

Packages that use Action
org.dom4j.rule A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.

Uses of Action in org.dom4j.rule

Classes in org.dom4j.rule that implement Action
 class NullAction
NullAction represents an empty action that does nothing.

Methods in org.dom4j.rule that return Action
Action | Stylesheet.getValueOfAction() DOCUMENT ME!
Action | RuleManager.getValueOfAction() DOCUMENT ME!
Action | Rule.getAction() Getter for property action.

Methods in org.dom4j.rule with parameters of type Action
 void Stylesheet.setValueOfAction(Action valueOfAction)
Sets the default value-of action which is used in the default rules for the pattern "text()|@"
 void RuleManager.setValueOfAction(Action valueOfAction)
Sets the default value-of action which is used in the default rules for the pattern "text()|@"
protected  void RuleManager.addDefaultRule(Mode mode, Pattern pattern, Action action)
protected  Rule RuleManager.createDefaultRule(Pattern pattern, Action action)
 void Rule.setAction(Action action)
Setter for property action.

Constructors in org.dom4j.rule with parameters of type Action
Rule(Pattern pattern, Action action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.rule.Mode (dom4j 1.6.1 API)

Uses of Class
org.dom4j.rule.Mode

Packages that use Mode
org.dom4j.rule A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.

Uses of Mode in org.dom4j.rule

Methods in org.dom4j.rule that return Mode
Mode | RuleManager.getMode(String modeName) DOCUMENT ME!
protected Mode | RuleManager.createMode() A factory method to return a new Modeinstance which should add the necessary default rules

Methods in org.dom4j.rule with parameters of type Mode
protected void | RuleManager.addDefaultRules(Mode mode) Adds the default stylesheet rules to the given Modeinstance
protected void | RuleManager.addDefaultRule(Mode mode, Pattern pattern, Action action)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.rule.NullAction (dom4j 1.6.1 API)

Uses of Class
org.dom4j.rule.NullAction

Packages that use NullAction
org.dom4j.rule A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.

Uses of NullAction in org.dom4j.rule

Fields in org.dom4j.rule declared as NullAction
static NullAction NullAction.SINGLETON
Singleton instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.rule.Pattern (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.rule.Pattern

Packages that use Pattern
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.rule | A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.
org.dom4j.rule.pattern |
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.
org.dom4j.xpath | Provides the core tools needed to use the XPath library

Uses of Pattern in org.dom4j

Methods in org.dom4j that return Pattern
static Pattern | DocumentHelper.createPattern(String xpathPattern) createPattern parses the given XPath expression to create an XSLT style Patterninstance which can then be used in an XSLT processing model.
Pattern | DocumentFactory.createPattern(String xpathPattern) createPattern parses the given XPath expression to create an XSLT style Patterninstance which can then be used in an XSLT processing model.

Uses of Pattern in org.dom4j.rule

Methods in org.dom4j.rule that return Pattern
Pattern | Rule.getPattern() Getter for property pattern.
Pattern[] | Pattern.getUnionPatterns() If this pattern is a union pattern then this method should return an array of patterns which describe the union pattern, which should contain more than one pattern.

Methods in org.dom4j.rule with parameters of type Pattern
protected void | RuleManager.addDefaultRule(Mode mode, Pattern pattern, Action action)
protected Rule | RuleManager.createDefaultRule(Pattern pattern, Action action)
void | Rule.setPattern(Pattern pattern) Setter for property pattern.

Constructors in org.dom4j.rule with parameters of type Pattern
Rule(Pattern pattern)
Rule(Pattern pattern, Action action)
Rule(Rule that, Pattern pattern)
Constructs a new Rule with the same instance data as the given rule but a different pattern.

Uses of Pattern in org.dom4j.rule.pattern

Classes in org.dom4j.rule.pattern that implement Pattern
class | DefaultPattern DefaultPattern a default implementation of Pattern which can take any XPath implementation or NodeFilter for defining the pattern.
class | NodeTypePattern NodeTypePattern implements a Pattern which matches any node of the given node type.

Methods in org.dom4j.rule.pattern that return Pattern
Pattern[] | NodeTypePattern.getUnionPatterns()
Pattern[] | DefaultPattern.getUnionPatterns()

Uses of Pattern in org.dom4j.tree

Methods in org.dom4j.tree that return Pattern
 Pattern AbstractNode.createPattern(String patternText)

Uses of Pattern in org.dom4j.util

Methods in org.dom4j.util that return Pattern
 Pattern ProxyDocumentFactory.createPattern(String xpathPattern)

Uses of Pattern in org.dom4j.xpath

Classes in org.dom4j.xpath that implement Pattern
 class XPathPattern
XPathPattern is an implementation of Pattern which uses an XPath xpath.

Methods in org.dom4j.xpath that return Pattern
 Pattern[] XPathPattern.getUnionPatterns()

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.rule.Rule (dom4j 1.6.1 API)

Uses of Class
org.dom4j.rule.Rule

Packages that use Rule
org.dom4j.rule A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.

Uses of Rule in org.dom4j.rule

Methods in org.dom4j.rule that return Rule
Rule | RuleSet.getMatchingRule(Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.
protected Rule[] | RuleSet.getRuleArray() Returns an array of sorted rules.
Rule | RuleManager.getMatchingRule(String modeName, Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.
protected Rule | RuleManager.createDefaultRule(Pattern pattern, Action action)
Rule[] | Rule.getUnionRules() If this rule contains a union pattern then this method should return an array of Rules which describe the union rule, which should contain more than one rule.
Rule | Mode.getMatchingRule(Node node) Performs an XSLT processing model match for the rule which matches the given Node the best.

Methods in org.dom4j.rule with parameters of type Rule
void | Stylesheet.addRule(Rule rule) Add a rule to this stylesheet.
void | Stylesheet.removeRule(Rule rule) Removes the specified rule from this stylesheet.
void | RuleSet.addRule(Rule rule)
void | RuleSet.removeRule(Rule rule)
void | RuleManager.addRule(Rule rule)
void | RuleManager.removeRule(Rule rule)
int | Rule.compareTo(Rule that) Compares two rules in XSLT processing model order assuming that the modes are equal.
void | Mode.addRule(Rule rule)
void | Mode.removeRule(Rule rule)
protected Map | Mode.addToNameMap(Map map, String name, Rule rule) Adds the Rule to a RuleSet for the given name.
protected void | Mode.removeFromNameMap(Map map, String name, Rule rule)

Constructors in org.dom4j.rule with parameters of type Rule
Rule(Rule that, Pattern pattern)
Constructs a new Rule with the same instance data as the given rule but a different pattern.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.rule.RuleManager (dom4j 1.6.1 API)

Uses of Class
org.dom4j.rule.RuleManager

No usage of org.dom4j.rule.RuleManager

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.rule.RuleSet (dom4j 1.6.1 API)

Uses of Class
org.dom4j.rule.RuleSet

Packages that use RuleSet
org.dom4j.rule A Pattern based XML rule engine which implements the full XSLT processing model while allowing any Action to be fired if a pattern matches.

Uses of RuleSet in org.dom4j.rule

Methods in org.dom4j.rule that return RuleSet
protected  RuleSet Mode.getRuleSet(int matchType)
DOCUMENT ME!

Methods in org.dom4j.rule with parameters of type RuleSet
 void RuleSet.addAll(RuleSet that)
Adds all the rules to this RuleSet from the given other rule set.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.rule.Stylesheet (dom4j 1.6.1 API)

Uses of Class
org.dom4j.rule.Stylesheet

No usage of org.dom4j.rule.Stylesheet

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.rule.pattern (dom4j 1.6.1 API)

 org.dom4j.rule.pattern
Classes
DefaultPattern
NodeTypePattern


Uses of Class org.dom4j.rule.pattern.DefaultPattern (dom4j 1.6.1 API)

Uses of Class
org.dom4j.rule.pattern.DefaultPattern

No usage of org.dom4j.rule.pattern.DefaultPattern

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.rule.pattern.NodeTypePattern (dom4j 1.6.1 API)

Uses of Class
org.dom4j.rule.pattern.NodeTypePattern

Packages that use NodeTypePattern
org.dom4j.rule.pattern

Uses of NodeTypePattern in org.dom4j.rule.pattern

Fields in org.dom4j.rule.pattern declared as NodeTypePattern
static NodeTypePattern | NodeTypePattern.ANY_ATTRIBUTE A pattern which matches any Attribute node
static NodeTypePattern | NodeTypePattern.ANY_COMMENT A pattern which matches any Comment node
static NodeTypePattern | NodeTypePattern.ANY_DOCUMENT A pattern which matches any Document node
static NodeTypePattern | NodeTypePattern.ANY_ELEMENT A pattern which matches any Element node
static NodeTypePattern | NodeTypePattern.ANY_PROCESSING_INSTRUCTION A pattern which matches any ProcessingInstruction node
static NodeTypePattern | NodeTypePattern.ANY_TEXT A pattern which matches any Text node

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.swing (dom4j 1.6.1 API)

 org.dom4j.swing
Classes
BranchTreeNode
DocumentTreeModel
LeafTreeNode
XMLTableColumnDefinition
XMLTableDefinition
XMLTableModel


Uses of Class org.dom4j.swing.BranchTreeNode (dom4j 1.6.1 API)

Uses of Class
org.dom4j.swing.BranchTreeNode

No usage of org.dom4j.swing.BranchTreeNode

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.swing.DocumentTreeModel (dom4j 1.6.1 API)

Uses of Class
org.dom4j.swing.DocumentTreeModel

No usage of org.dom4j.swing.DocumentTreeModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.swing.LeafTreeNode (dom4j 1.6.1 API)

Uses of Class
org.dom4j.swing.LeafTreeNode

Packages that use LeafTreeNode
org.dom4j.swing A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.

Uses of LeafTreeNode in org.dom4j.swing

Subclasses of LeafTreeNode in org.dom4j.swing
 class BranchTreeNode
BranchTreeNode implements the Swing TreeNode interface to bind dom4j XML Branch nodes (i.e.

Methods in org.dom4j.swing with parameters of type LeafTreeNode
 void LeafTreeNode.setParent(LeafTreeNode parent)
Sets the parent of this node but doesn't change the parents children

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.swing.XMLTableColumnDefinition (dom4j 1.6.1 API)

Uses of Class
org.dom4j.swing.XMLTableColumnDefinition

Packages that use XMLTableColumnDefinition
org.dom4j.swing A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.

Uses of XMLTableColumnDefinition in org.dom4j.swing

Methods in org.dom4j.swing that return XMLTableColumnDefinition
XMLTableColumnDefinition | XMLTableDefinition.getColumn(int index)
XMLTableColumnDefinition | XMLTableDefinition.getColumn(String columnName)

Methods in org.dom4j.swing with parameters of type XMLTableColumnDefinition
void | XMLTableDefinition.addColumn(XMLTableColumnDefinition column)
void | XMLTableDefinition.removeColumn(XMLTableColumnDefinition column)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.swing.XMLTableDefinition (dom4j 1.6.1 API)

Uses of Class
org.dom4j.swing.XMLTableDefinition

Packages that use XMLTableDefinition
org.dom4j.swing A collection of adapters to allow easy integration with dom4j XML documents and Swing such as TreeModels and TableModels.

Uses of XMLTableDefinition in org.dom4j.swing

Methods in org.dom4j.swing that return XMLTableDefinition
XMLTableDefinition | XMLTableModel.getDefinition() Getter for property definition.
static XMLTableDefinition | XMLTableDefinition.load(Document definition) Loads an XML table definition from an XML definition document
static XMLTableDefinition | XMLTableDefinition.load(Element definition) Loads an XML table definition from an XML definition document

Methods in org.dom4j.swing with parameters of type XMLTableDefinition
 void XMLTableModel.setDefinition(XMLTableDefinition definition)
Setter for property definition.

Constructors in org.dom4j.swing with parameters of type XMLTableDefinition
XMLTableModel(XMLTableDefinition definition, Object source)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.swing.XMLTableModel (dom4j 1.6.1 API)

Uses of Class
org.dom4j.swing.XMLTableModel

No usage of org.dom4j.swing.XMLTableModel

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


ConcurrentReaderHashMap.BarrierLock (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class ConcurrentReaderHashMap.BarrierLock

java.lang.Object
    extended by org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock
All Implemented Interfaces:
Serializable
Enclosing class:
org.dom4j.tree.ConcurrentReaderHashMap
protected static class ConcurrentReaderHashMap.BarrierLock
extends Object
implements Serializable

A Serializable class for barrier lock *

See Also:
Serialized Form

Constructor Summary
protected ConcurrentReaderHashMap.BarrierLock()
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

ConcurrentReaderHashMap.BarrierLock

protected ConcurrentReaderHashMap.BarrierLock()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ConcurrentReaderHashMap.Entry (dom4j 1.6.1 API)

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.dom4j.tree
Class ConcurrentReaderHashMap.Entry

java.lang.Object
    extended by org.dom4j.tree.ConcurrentReaderHashMap.Entry
All Implemented Interfaces:
Map.Entry
Enclosing class:
org.dom4j.tree.ConcurrentReaderHashMap
protected static class ConcurrentReaderHashMap.Entry
extends Object
implements Map.Entry

ConcurrentReaderHashMap collision list entry.

Field Summary
protected int | hash
protected Object | key
protected ConcurrentReaderHashMap.Entry | next
protected Object | value
Method Summary
boolean | equals(Object o)
Object | getKey()
Object | getValue() Get the value.
int | hashCode()
Object | setValue(Object value) Set the value of this entry.
String | toString()
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

Field Detail

hash

protected final int hash

key

protected final Object key

next

protected final ConcurrentReaderHashMap.Entry next

value

protected volatile Object value
Method Detail

getKey

public Object getKey()
Specified by:
getKey in interface Map.Entry

getValue

public Object getValue()
Get the value. Note: In an entrySet or entrySet.iterator, unless the set or iterator is used under synchronization of the table as a whole (or you can otherwise guarantee lack of concurrent modification), getValue might return null, reflecting the fact that the entry has been concurrently removed. However, there are no assurances that concurrent removals will be reflected using this method.

Specified by:
getValue in interface Map.Entry
Returns:
the current value, or null if the entry has been detectably removed.

setValue

public Object setValue(Object value)
Set the value of this entry. Note: In an entrySet or entrySet.iterator), unless the set or iterator is used under synchronization of the table as a whole (or you can otherwise guarantee lack of concurrent modification), setValue is not strictly guaranteed to actually replace the value field obtained via the get operation of the underlying hash table in multithreaded applications. If iterator-wide synchronization is not used, and any other concurrent put or remove operations occur, sometimes even to other entries, then this change is not guaranteed to be reflected in the hash table. (It might, or it might not. There are no assurances either way.)

Specified by:
setValue in interface Map.Entry
Parameters:
value - the new value.
Returns:
the previous value, or null if entry has been detectably removed.
Throws:
NullPointerException - if the value is null.

equals

public boolean equals(Object o)
Specified by:
equals in interface Map.Entry

hashCode

public int hashCode()
Specified by:
hashCode in interface Map.Entry

toString

public String toString()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.dom4j.tree (dom4j 1.6.1 API)

 org.dom4j.tree
Classes
AbstractAttribute
AbstractBranch
AbstractCDATA
AbstractCharacterData
AbstractComment
AbstractDocument
AbstractDocumentType
AbstractElement
AbstractEntity
AbstractNode
AbstractProcessingInstruction
AbstractText
BackedList
BaseElement
ConcurrentReaderHashMap.BarrierLock
ConcurrentReaderHashMap.Entry
ContentListFacade
DefaultAttribute
DefaultCDATA
DefaultComment
DefaultDocument
DefaultDocumentType
DefaultElement
DefaultEntity
DefaultNamespace
DefaultProcessingInstruction
DefaultText
ElementIterator
ElementNameIterator
ElementQNameIterator
FilterIterator
FlyweightAttribute
FlyweightCDATA
FlyweightComment
FlyweightEntity
FlyweightProcessingInstruction
FlyweightText
NamespaceCache
NamespaceStack
QNameCache
SingleIterator


Uses of Class org.dom4j.tree.AbstractAttribute (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractAttribute

Packages that use AbstractAttribute
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of AbstractAttribute in org.dom4j.bean

Subclasses of AbstractAttribute in org.dom4j.bean
 class BeanAttribute
BeanAttribute represents a mutable XML attribute which is backed by a property of the JavaBean of its parent element.

Uses of AbstractAttribute in org.dom4j.datatype

Subclasses of AbstractAttribute in org.dom4j.datatype
 class DatatypeAttribute
DatatypeAttribute represents an Attribute which supports the XML Schema Data Types specification.

Uses of AbstractAttribute in org.dom4j.dom

Subclasses of AbstractAttribute in org.dom4j.dom
 class DOMAttribute
DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.

Uses of AbstractAttribute in org.dom4j.tree

Subclasses of AbstractAttribute in org.dom4j.tree
class | DefaultAttribute DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.
class | FlyweightAttribute FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.

Uses of AbstractAttribute in org.dom4j.util

Subclasses of AbstractAttribute in org.dom4j.util
 class UserDataAttribute
UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataAttribute.setData(Object)will get and set the values of a user data object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractBranch (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractBranch

Packages that use AbstractBranch
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of AbstractBranch in org.dom4j.bean

Subclasses of AbstractBranch in org.dom4j.bean
 class BeanElement
BeanElement uses a Java Bean to store its attributes.

Uses of AbstractBranch in org.dom4j.datatype

Subclasses of AbstractBranch in org.dom4j.datatype
 class DatatypeElement
DatatypeElement represents an Element which supports the XML Schema Data Types specification.

Uses of AbstractBranch in org.dom4j.dom

Subclasses of AbstractBranch in org.dom4j.dom
class | DOMDocument DOMDocument implements an XML document which supports the W3C DOM API.
class | DOMElement DOMElement implements an XML element which supports the W3C DOM API.

Uses of AbstractBranch in org.dom4j.tree

Subclasses of AbstractBranch in org.dom4j.tree
class | AbstractDocument AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractElement AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
class | BaseElement BaseElement is a useful base class for implemementation inheritence of an XML element.
class | DefaultDocument DefaultDocument is the default DOM4J default implementation of an XML document.
class | DefaultElement DefaultElement is the default DOM4J default implementation of an XML element.

Constructors in org.dom4j.tree with parameters of type AbstractBranch
ContentListFacade(AbstractBranch branch, List branchContent)
BackedList(AbstractBranch branch, List branchContent)
BackedList(AbstractBranch branch, List branchContent, int capacity)
BackedList(AbstractBranch branch, List branchContent, List initialContent)

Uses of AbstractBranch in org.dom4j.util

Subclasses of AbstractBranch in org.dom4j.util
class | IndexedElement IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
class | NonLazyElement NonLazyElement is the default DOM4J default implementation of an XML element.
class | UserDataElement UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractCDATA (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractCDATA

Packages that use AbstractCDATA
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of AbstractCDATA in org.dom4j.dom

Subclasses of AbstractCDATA in org.dom4j.dom
 class DOMCDATA
DOMCDATA implements a CDATA Section which supports the W3C DOM API.

Uses of AbstractCDATA in org.dom4j.tree

Subclasses of AbstractCDATA in org.dom4j.tree
class | DefaultCDATA DefaultCDATA is the default CDATA implementation.
class | FlyweightCDATA FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractCharacterData (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractCharacterData

Packages that use AbstractCharacterData
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of AbstractCharacterData in org.dom4j.dom

Subclasses of AbstractCharacterData in org.dom4j.dom
class | DOMCDATA DOMCDATA implements a CDATA Section which supports the W3C DOM API.
class | DOMComment DOMText implements a Text node which supports the W3C DOM API.
class | DOMText DOMText implements a Text node which supports the W3C DOM API.

Uses of AbstractCharacterData in org.dom4j.tree

Subclasses of AbstractCharacterData in org.dom4j.tree
class | AbstractCDATA AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractComment AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractText AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
class | DefaultCDATA DefaultCDATA is the default CDATA implementation.
class | DefaultComment DefaultComment is the default Comment implementation.
class | DefaultText DefaultText is the default Text implementation.
class | FlyweightCDATA FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.
class | FlyweightComment FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.
class | FlyweightText FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractComment (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractComment

Packages that use AbstractComment
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of AbstractComment in org.dom4j.dom

Subclasses of AbstractComment in org.dom4j.dom
 class DOMComment
DOMText implements a Text node which supports the W3C DOM API.

Uses of AbstractComment in org.dom4j.tree

Subclasses of AbstractComment in org.dom4j.tree
class | DefaultComment DefaultComment is the default Comment implementation.
class | FlyweightComment FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractDocument (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractDocument

Packages that use AbstractDocument
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of AbstractDocument in org.dom4j.dom

Subclasses of AbstractDocument in org.dom4j.dom
 class DOMDocument
DOMDocument implements an XML document which supports the W3C DOM API.

Uses of AbstractDocument in org.dom4j.tree

Subclasses of AbstractDocument in org.dom4j.tree
 class DefaultDocument
DefaultDocument is the default DOM4J default implementation of an XML document.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractDocumentType (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractDocumentType

Packages that use AbstractDocumentType
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of AbstractDocumentType in org.dom4j.dom

Subclasses of AbstractDocumentType in org.dom4j.dom
 class DOMDocumentType
DOMDocumentType implements a DocumentType node which supports the W3C DOM API.

Uses of AbstractDocumentType in org.dom4j.tree

Subclasses of AbstractDocumentType in org.dom4j.tree
 class DefaultDocumentType
DefaultDocumentType is the DOM4J default implementation of an XML document type.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractElement

Packages that use AbstractElement
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of AbstractElement in org.dom4j.bean

Subclasses of AbstractElement in org.dom4j.bean
 class BeanElement
BeanElement uses a Java Bean to store its attributes.

Uses of AbstractElement in org.dom4j.datatype

Subclasses of AbstractElement in org.dom4j.datatype
 class DatatypeElement
DatatypeElement represents an Element which supports the XML Schema Data Types specification.

Uses of AbstractElement in org.dom4j.dom

Subclasses of AbstractElement in org.dom4j.dom
 class DOMElement
DOMElement implements an XML element which supports the W3C DOM API.

Uses of AbstractElement in org.dom4j.tree

Subclasses of AbstractElement in org.dom4j.tree
class | BaseElement BaseElement is a useful base class for implemementation inheritence of an XML element.
class | DefaultElement DefaultElement is the default DOM4J default implementation of an XML element.

Uses of AbstractElement in org.dom4j.util

Subclasses of AbstractElement in org.dom4j.util
class | IndexedElement IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
class | NonLazyElement NonLazyElement is the default DOM4J default implementation of an XML element.
class | UserDataElement UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractEntity (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractEntity

Packages that use AbstractEntity
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of AbstractEntity in org.dom4j.dom

Subclasses of AbstractEntity in org.dom4j.dom
 class DOMEntityReference
DOMEntity implements a Entity node which supports the W3C DOM API.

Uses of AbstractEntity in org.dom4j.tree

Subclasses of AbstractEntity in org.dom4j.tree
class | DefaultEntity DefaultEntity is the default Entity implementation.
class | FlyweightEntity FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractNode (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractNode

Packages that use AbstractNode
org.dom4j | Defines the XML Document Object Model in Java interfaces together with some helper classes.
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of AbstractNode in org.dom4j

Subclasses of AbstractNode in org.dom4j
 class Namespace
Namespace is a Flyweight Namespace that can be shared amongst nodes.

Uses of AbstractNode in org.dom4j.bean

Subclasses of AbstractNode in org.dom4j.bean
class | BeanAttribute BeanAttribute represents a mutable XML attribute which is backed by a property of the JavaBean of its parent element.
class | BeanElement BeanElement uses a Java Bean to store its attributes.

Uses of AbstractNode in org.dom4j.datatype

Subclasses of AbstractNode in org.dom4j.datatype
class | DatatypeAttribute DatatypeAttribute represents an Attribute which supports the XML Schema Data Types specification.
class | DatatypeElement DatatypeElement represents an Element which supports the XML Schema Data Types specification.

Uses of AbstractNode in org.dom4j.dom

Subclasses of AbstractNode in org.dom4j.dom
class | DOMAttribute DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.
class | DOMCDATA DOMCDATA implements a CDATA Section which supports the W3C DOM API.
class | DOMComment DOMText implements a Text node which supports the W3C DOM API.
class | DOMDocument DOMDocument implements an XML document which supports the W3C DOM API.
class | DOMDocumentType DOMDocumentType implements a DocumentType node which supports the W3C DOM API.
class | DOMElement DOMElement implements an XML element which supports the W3C DOM API.
class | DOMEntityReference DOMEntity implements a Entity node which supports the W3C DOM API.
class | DOMNamespace DOMNamespace implements a Namespace that is compatable with the DOM API.
class | DOMProcessingInstruction DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.
class | DOMText DOMText implements a Text node which supports the W3C DOM API.

Uses of AbstractNode in org.dom4j.tree

Subclasses of AbstractNode in org.dom4j.tree
class | AbstractAttribute AbstractNamespace is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractBranch AbstractBranch is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractCDATA AbstractCDATA is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractCharacterData AbstractCharacterData is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractComment AbstractComment is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractDocument AbstractDocument is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractDocumentType AbstractDocumentType is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractElement AbstractElement is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractEntity AbstractEntity is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractProcessingInstruction AbstractProcessingInstruction is an abstract base class for tree implementors to use for implementation inheritence.
class | AbstractText AbstractText is an abstract base class for tree implementors to use for implementation inheritence.
class | BaseElement BaseElement is a useful base class for implemementation inheritence of an XML element.
class | DefaultAttribute DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.
class | DefaultCDATA DefaultCDATA is the default CDATA implementation.
class | DefaultComment DefaultComment is the default Comment implementation.
class | DefaultDocument DefaultDocument is the default DOM4J default implementation of an XML document.
class | DefaultDocumentType DefaultDocumentType is the DOM4J default implementation of an XML document type.
class | DefaultElement DefaultElement is the default DOM4J default implementation of an XML element.
class | DefaultEntity DefaultEntity is the default Entity implementation.
class | DefaultNamespace DefaultNamespace implements a doubly linked node which supports the parent relationship and is mutable.
class | DefaultProcessingInstruction DefaultProcessingInstruction is the default Processing Instruction implementation.
class | DefaultText DefaultText is the default Text implementation.
class | FlyweightAttribute FlyweightAttribute is a Flyweight pattern implementation of a singly linked, read-only XML Attribute.
class | FlyweightCDATA FlyweightCDATA is a Flyweight pattern implementation of a singly linked, read-only XML CDATA.
class | FlyweightComment FlyweightComment is a Flyweight pattern implementation of a singly linked, read-only XML Comment.
class | FlyweightEntity FlyweightEntity is a Flyweight pattern implementation of a singly linked, read-only XML entity.
class | FlyweightProcessingInstruction FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.
class | FlyweightText FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.

Uses of AbstractNode in org.dom4j.util

Subclasses of AbstractNode in org.dom4j.util
class | IndexedElement IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
class | NonLazyElement NonLazyElement is the default DOM4J default implementation of an XML element.
class | UserDataAttribute UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataAttribute.setData(Object)will get and set the values of a user data object.
class | UserDataElement UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractProcessingInstruction (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractProcessingInstruction

Packages that use AbstractProcessingInstruction
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of AbstractProcessingInstruction in org.dom4j.dom

Subclasses of AbstractProcessingInstruction in org.dom4j.dom
 class DOMProcessingInstruction
DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.

Uses of AbstractProcessingInstruction in org.dom4j.tree

Subclasses of AbstractProcessingInstruction in org.dom4j.tree
class | DefaultProcessingInstruction DefaultProcessingInstruction is the default Processing Instruction implementation.
class | FlyweightProcessingInstruction FlyweightProcessingInstruction is a Flyweight pattern implementation of a singly linked, read-only XML Processing Instruction.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.AbstractText (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.AbstractText

Packages that use AbstractText
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of AbstractText in org.dom4j.dom

Subclasses of AbstractText in org.dom4j.dom
 class DOMText
DOMText implements a Text node which supports the W3C DOM API.

Uses of AbstractText in org.dom4j.tree

Subclasses of AbstractText in org.dom4j.tree
class | DefaultText DefaultText is the default Text implementation.
class | FlyweightText FlyweightText is a Flyweight pattern implementation of a singly linked, read-only XML Text.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.BackedList (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.BackedList

Packages that use BackedList
org.dom4j.tree Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of BackedList in org.dom4j.tree

Methods in org.dom4j.tree that return BackedList
protected  BackedList AbstractBranch.createResultList()
A Factory Method pattern which creates a BackedList implementation used to store results of a filtered content query.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.BaseElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.BaseElement

Packages that use BaseElement
org.dom4j.util A collection of utility classes for the dom4j API.

Uses of BaseElement in org.dom4j.util

Subclasses of BaseElement in org.dom4j.util
 class NonLazyElement
NonLazyElement is the default DOM4J default implementation of an XML element.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock

No usage of org.dom4j.tree.ConcurrentReaderHashMap.BarrierLock

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.ConcurrentReaderHashMap.Entry (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.ConcurrentReaderHashMap.Entry

Packages that use ConcurrentReaderHashMap.Entry
org.dom4j.tree Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of ConcurrentReaderHashMap.Entry in org.dom4j.tree

Fields in org.dom4j.tree declared as ConcurrentReaderHashMap.Entry
protected  ConcurrentReaderHashMap.Entry ConcurrentReaderHashMap.Entry.next

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.ContentListFacade (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.ContentListFacade

No usage of org.dom4j.tree.ContentListFacade

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultAttribute (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultAttribute

Packages that use DefaultAttribute
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of DefaultAttribute in org.dom4j.dom

Subclasses of DefaultAttribute in org.dom4j.dom
 class DOMAttribute
DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.

Uses of DefaultAttribute in org.dom4j.util

Subclasses of DefaultAttribute in org.dom4j.util
 class UserDataAttribute
UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataAttribute.setData(Object)will get and set the values of a user data object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultCDATA (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultCDATA

Packages that use DefaultCDATA
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DefaultCDATA in org.dom4j.dom

Subclasses of DefaultCDATA in org.dom4j.dom
 class DOMCDATA
DOMCDATA implements a CDATA Section which supports the W3C DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultComment (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultComment

Packages that use DefaultComment
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DefaultComment in org.dom4j.dom

Subclasses of DefaultComment in org.dom4j.dom
 class DOMComment
DOMText implements a Text node which supports the W3C DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultDocument (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultDocument

Packages that use DefaultDocument
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DefaultDocument in org.dom4j.dom

Subclasses of DefaultDocument in org.dom4j.dom
 class DOMDocument
DOMDocument implements an XML document which supports the W3C DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultDocumentType (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultDocumentType

Packages that use DefaultDocumentType
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DefaultDocumentType in org.dom4j.dom

Subclasses of DefaultDocumentType in org.dom4j.dom
 class DOMDocumentType
DOMDocumentType implements a DocumentType node which supports the W3C DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultElement

Packages that use DefaultElement
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.datatype | An implementation of the dom4j API which supports the XML Schema Data Types specification.
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of DefaultElement in org.dom4j.bean

Subclasses of DefaultElement in org.dom4j.bean
 class BeanElement
BeanElement uses a Java Bean to store its attributes.

Uses of DefaultElement in org.dom4j.datatype

Subclasses of DefaultElement in org.dom4j.datatype
 class DatatypeElement
DatatypeElement represents an Element which supports the XML Schema Data Types specification.

Uses of DefaultElement in org.dom4j.dom

Subclasses of DefaultElement in org.dom4j.dom
 class DOMElement
DOMElement implements an XML element which supports the W3C DOM API.

Uses of DefaultElement in org.dom4j.util

Subclasses of DefaultElement in org.dom4j.util
class | IndexedElement IndexedElement is an implementation of Elementwhich maintains an index of the attributes and elements it contains to optimise lookups via name.
class | UserDataElement UserDataElement support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataElement.setData(Object)will get and set the values of a user data object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultEntity (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultEntity

Packages that use DefaultEntity
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DefaultEntity in org.dom4j.dom

Subclasses of DefaultEntity in org.dom4j.dom
 class DOMEntityReference
DOMEntity implements a Entity node which supports the W3C DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultNamespace (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultNamespace

Packages that use DefaultNamespace
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DefaultNamespace in org.dom4j.dom

Subclasses of DefaultNamespace in org.dom4j.dom
 class DOMNamespace
DOMNamespace implements a Namespace that is compatable with the DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultProcessingInstruction (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultProcessingInstruction

Packages that use DefaultProcessingInstruction
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DefaultProcessingInstruction in org.dom4j.dom

Subclasses of DefaultProcessingInstruction in org.dom4j.dom
 class DOMProcessingInstruction
DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.DefaultText (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.DefaultText

Packages that use DefaultText
org.dom4j.dom An implementation of the dom4j API which also supports the W3C object model.

Uses of DefaultText in org.dom4j.dom

Subclasses of DefaultText in org.dom4j.dom
 class DOMText
DOMText implements a Text node which supports the W3C DOM API.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.ElementIterator (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.ElementIterator

No usage of org.dom4j.tree.ElementIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.ElementNameIterator (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.ElementNameIterator

No usage of org.dom4j.tree.ElementNameIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.ElementQNameIterator (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.ElementQNameIterator

No usage of org.dom4j.tree.ElementQNameIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.FilterIterator (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.FilterIterator

Packages that use FilterIterator
org.dom4j.tree Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of FilterIterator in org.dom4j.tree

Subclasses of FilterIterator in org.dom4j.tree
class | ElementIterator Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
class | ElementNameIterator Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!
class | ElementQNameIterator Deprecated. THIS CLASS WILL BE REMOVED IN dom4j-1.6 !!

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.FlyweightAttribute (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.FlyweightAttribute

Packages that use FlyweightAttribute
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.
org.dom4j.util | A collection of utility classes for the dom4j API.

Uses of FlyweightAttribute in org.dom4j.dom

Subclasses of FlyweightAttribute in org.dom4j.dom
 class DOMAttribute
DOMAttribute implements a doubly linked attribute which supports the W3C DOM API.

Uses of FlyweightAttribute in org.dom4j.tree

Subclasses of FlyweightAttribute in org.dom4j.tree
 class DefaultAttribute
DefaultAttribute implements a doubly linked node which supports the parent relationship and is mutable.

Uses of FlyweightAttribute in org.dom4j.util

Subclasses of FlyweightAttribute in org.dom4j.util
 class UserDataAttribute
UserDataAttribute support the adornment of a user data object on an Element or Attribute instance such that the methods UserDataAttribute.setData(Object)will get and set the values of a user data object.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.FlyweightCDATA (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.FlyweightCDATA

Packages that use FlyweightCDATA
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of FlyweightCDATA in org.dom4j.dom

Subclasses of FlyweightCDATA in org.dom4j.dom
 class DOMCDATA
DOMCDATA implements a CDATA Section which supports the W3C DOM API.

Uses of FlyweightCDATA in org.dom4j.tree

Subclasses of FlyweightCDATA in org.dom4j.tree
 class DefaultCDATA
DefaultCDATA is the default CDATA implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.FlyweightComment (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.FlyweightComment

Packages that use FlyweightComment
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of FlyweightComment in org.dom4j.dom

Subclasses of FlyweightComment in org.dom4j.dom
 class DOMComment
DOMText implements a Text node which supports the W3C DOM API.

Uses of FlyweightComment in org.dom4j.tree

Subclasses of FlyweightComment in org.dom4j.tree
 class DefaultComment
DefaultComment is the default Comment implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.FlyweightEntity (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.FlyweightEntity

Packages that use FlyweightEntity
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of FlyweightEntity in org.dom4j.dom

Subclasses of FlyweightEntity in org.dom4j.dom
 class DOMEntityReference
DOMEntity implements a Entity node which supports the W3C DOM API.

Uses of FlyweightEntity in org.dom4j.tree

Subclasses of FlyweightEntity in org.dom4j.tree
 class DefaultEntity
DefaultEntity is the default Entity implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.FlyweightProcessingInstruction (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.FlyweightProcessingInstruction

Packages that use FlyweightProcessingInstruction
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of FlyweightProcessingInstruction in org.dom4j.dom

Subclasses of FlyweightProcessingInstruction in org.dom4j.dom
 class DOMProcessingInstruction
DOMProcessingInstruction implements a ProcessingInstruction node which supports the W3C DOM API.

Uses of FlyweightProcessingInstruction in org.dom4j.tree

Subclasses of FlyweightProcessingInstruction in org.dom4j.tree
 class DefaultProcessingInstruction
DefaultProcessingInstruction is the default Processing Instruction implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.FlyweightText (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.FlyweightText

Packages that use FlyweightText
org.dom4j.dom | An implementation of the dom4j API which also supports the W3C object model.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of FlyweightText in org.dom4j.dom

Subclasses of FlyweightText in org.dom4j.dom
 class DOMText
DOMText implements a Text node which supports the W3C DOM API.

Uses of FlyweightText in org.dom4j.tree

Subclasses of FlyweightText in org.dom4j.tree
 class DefaultText
DefaultText is the default Text implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.NamespaceCache (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.NamespaceCache

Packages that use NamespaceCache
org.dom4j Defines the XML Document Object Model in Java interfaces together with some helper classes.

Uses of NamespaceCache in org.dom4j

Fields in org.dom4j declared as NamespaceCache
protected static NamespaceCache Namespace.CACHE
Cache of Namespace instances

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.NamespaceStack (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.NamespaceStack

Packages that use NamespaceStack
org.dom4j.bean | An implementation of the dom4j API which allows JavaBeans to be used to store and retrieve attribute values from Element.
org.dom4j.io | Provides input and output via SAX and DOM together with writing dom4j objects to streams as XML text.
org.dom4j.tree | Contains the default implementations of the dom4j Document Object Model together with some helpful base classes for those wishing to implement their own document object model.

Uses of NamespaceStack in org.dom4j.bean

Methods in org.dom4j.bean with parameters of type NamespaceStack
 void BeanElement.setAttributes(Attributes attributes, NamespaceStack namespaceStack, boolean noNamespaceAttributes)

Uses of NamespaceStack in org.dom4j.io

Methods in org.dom4j.io with parameters of type NamespaceStack
protected void | SAXWriter.writeContent(Branch branch, NamespaceStack namespaceStack)
protected void | SAXWriter.write(Element element, NamespaceStack namespaceStack)
protected AttributesImpl | SAXWriter.startPrefixMapping(Element element, NamespaceStack namespaceStack) Fires a SAX startPrefixMapping event for all the namespaceStack which have just come into scope
protected void | SAXWriter.endPrefixMapping(NamespaceStack stack, int stackSize) Fires a SAX endPrefixMapping event for all the namespaceStack which have gone out of scope
protected boolean | SAXWriter.isIgnoreableNamespace(Namespace namespace, NamespaceStack namespaceStack) DOCUMENT ME!

Uses of NamespaceStack in org.dom4j.tree

Methods in org.dom4j.tree with parameters of type NamespaceStack
 void AbstractElement.setAttributes(Attributes attributes, NamespaceStack namespaceStack, boolean noNamespaceAttributes)
This method provides a more optimal way of setting all the attributes on an Element particularly for use in SAXReader.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.QNameCache (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.QNameCache

Packages that use QNameCache
org.dom4j Defines the XML Document Object Model in Java interfaces together with some helper classes.

Uses of QNameCache in org.dom4j

Fields in org.dom4j declared as QNameCache
protected  QNameCache DocumentFactory.cache

Methods in org.dom4j that return QNameCache
protected  QNameCache DocumentFactory.createQNameCache()
Factory method to create the QNameCache.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.tree.SingleIterator (dom4j 1.6.1 API)

Uses of Class
org.dom4j.tree.SingleIterator

No usage of org.dom4j.tree.SingleIterator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.util (dom4j 1.6.1 API)

 org.dom4j.util
Interfaces
SingletonStrategy
Classes
AttributeHelper
IndexedDocumentFactory
IndexedElement
NodeComparator
NonLazyDocumentFactory
NonLazyElement
PerThreadSingleton
ProxyDocumentFactory
SimpleSingleton
UserDataAttribute
UserDataDocumentFactory
UserDataElement
XMLErrorHandler


Uses of Class org.dom4j.util.AttributeHelper (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.AttributeHelper

No usage of org.dom4j.util.AttributeHelper

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.IndexedDocumentFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.IndexedDocumentFactory

Packages that use IndexedDocumentFactory
org.dom4j.util A collection of utility classes for the dom4j API.

Uses of IndexedDocumentFactory in org.dom4j.util

Fields in org.dom4j.util declared as IndexedDocumentFactory
protected static IndexedDocumentFactory IndexedDocumentFactory.singleton
The Singleton instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.IndexedElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.IndexedElement

No usage of org.dom4j.util.IndexedElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.NodeComparator (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.NodeComparator

No usage of org.dom4j.util.NodeComparator

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.NonLazyDocumentFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.NonLazyDocumentFactory

Packages that use NonLazyDocumentFactory
org.dom4j.util A collection of utility classes for the dom4j API.

Uses of NonLazyDocumentFactory in org.dom4j.util

Fields in org.dom4j.util declared as NonLazyDocumentFactory
protected static NonLazyDocumentFactory NonLazyDocumentFactory.singleton
The Singleton instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.NonLazyElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.NonLazyElement

No usage of org.dom4j.util.NonLazyElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.PerThreadSingleton (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.PerThreadSingleton

No usage of org.dom4j.util.PerThreadSingleton

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.ProxyDocumentFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.ProxyDocumentFactory

No usage of org.dom4j.util.ProxyDocumentFactory

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.SimpleSingleton (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.SimpleSingleton

No usage of org.dom4j.util.SimpleSingleton

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.dom4j.util.SingletonStrategy (dom4j 1.6.1 API)

Uses of Interface
org.dom4j.util.SingletonStrategy

Packages that use SingletonStrategy
org.dom4j.util A collection of utility classes for the dom4j API.

Uses of SingletonStrategy in org.dom4j.util

Classes in org.dom4j.util that implement SingletonStrategy
class | PerThreadSingleton PerThreadSingleton is an implementation of the SingletonStrategy used to provide common factory access to a single object instance based on an implementation strategy for one object instance per thread.
class | SimpleSingleton SimpleSingleton is an implementation of the SingletonStrategy interface used to provide common factory access for the same object instance.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.UserDataAttribute (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.UserDataAttribute

No usage of org.dom4j.util.UserDataAttribute

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.UserDataDocumentFactory (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.UserDataDocumentFactory

Packages that use UserDataDocumentFactory
org.dom4j.util A collection of utility classes for the dom4j API.

Uses of UserDataDocumentFactory in org.dom4j.util

Fields in org.dom4j.util declared as UserDataDocumentFactory
protected static UserDataDocumentFactory UserDataDocumentFactory.singleton
The Singleton instance

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.UserDataElement (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.UserDataElement

No usage of org.dom4j.util.UserDataElement

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.util.XMLErrorHandler (dom4j 1.6.1 API)

Uses of Class
org.dom4j.util.XMLErrorHandler

No usage of org.dom4j.util.XMLErrorHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.xpath (dom4j 1.6.1 API)

 org.dom4j.xpath
Classes
DefaultNamespaceContext
DefaultXPath
XPathPattern


Uses of Class org.dom4j.xpath.DefaultNamespaceContext (dom4j 1.6.1 API)

Uses of Class
org.dom4j.xpath.DefaultNamespaceContext

Packages that use DefaultNamespaceContext
org.dom4j.xpath Provides the core tools needed to use the XPath library

Uses of DefaultNamespaceContext in org.dom4j.xpath

Methods in org.dom4j.xpath that return DefaultNamespaceContext
static DefaultNamespaceContext DefaultNamespaceContext.create(Object node)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.xpath.DefaultXPath (dom4j 1.6.1 API)

Uses of Class
org.dom4j.xpath.DefaultXPath

No usage of org.dom4j.xpath.DefaultXPath

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.dom4j.xpath.XPathPattern (dom4j 1.6.1 API)

Uses of Class
org.dom4j.xpath.XPathPattern

No usage of org.dom4j.xpath.XPathPattern

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


org.dom4j.xpp (dom4j 1.6.1 API)

 org.dom4j.xpp
Classes
ProxyXmlStartTag


Uses of Class org.dom4j.xpp.ProxyXmlStartTag (dom4j 1.6.1 API)

Uses of Class
org.dom4j.xpp.ProxyXmlStartTag

No usage of org.dom4j.xpp.ProxyXmlStartTag

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES