Overview

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES

jBPM 4.4 API

Packages
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.activity | interfaces for implementing customized runtime behaviour of activities.
org.jbpm.api.cmd |
org.jbpm.api.history | interfaces related to the HistoryService.
org.jbpm.api.identity | User and Group interfaces related to the IdentityService
org.jbpm.api.job | Job, Message and Timer interfaces related to the ManagementService
org.jbpm.api.jpdl | specific jPDL interfaces
org.jbpm.api.listener | interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.
org.jbpm.api.model | common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.
org.jbpm.api.task | interfaces related to the TaskService

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES
Copyright © 2010 JBoss Community. All Rights Reserved.


org.jbpm.api

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api

the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

See:
Description

Interface Summary
Deployment | represents an existing deployment in the repository.
DeploymentQuery | find existing deployments in the repository.
Execution | a runtime path of execution.
ExecutionService | manages runtime process executions.
HistoryService | exposes the history information for ongoing and past process instances.
IdentityService | interface to expose the (configurable) identity component that is used by jBPM.
JobQuery | query for jBPM related messages and timers.
ManagementService | operations targeted to system operators that need to keep the process engine up and running.
NewDeployment | extends a Deployment with method for creating a new deployment.
ProcessDefinition | a graphical process which is deployed in the RepositoryService.
ProcessDefinitionQuery | query for process definitions.
ProcessEngine | central starting point for all process engine API interactions.
ProcessInstance | a process instance is one execution of a process definition.
ProcessInstanceQuery | query for ongoing process instances exclusively. refer to HistoryProcessInstanceQuery for queries that include finished process instances.
RepositoryService | exposes the repository of deployments.
TaskQuery | query for tasks.
TaskService | task management.

Class Summary
Configuration process engine configuration.

Exception Summary
JbpmException all exceptions that jBPM throws are JbpmException's (extends RuntimeException).

Package org.jbpm.api Description

the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


Deployment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface Deployment

All Known Subinterfaces:
NewDeployment
public interface Deployment

represents an existing deployment in the repository.

Author:
Tom Baeyens

Field Summary
static java.lang.String | STATE_ACTIVE normal deployments for which contained process definitions can be executed.
static java.lang.String | STATE_SUSPENDED invisible for all operations except delete or resume.
Method Summary
java.lang.String | getId() unique identification of this deployment that is used as a reference in the service methods
java.lang.String | getName() typically correspond to the file name or url or some other form of identifying the source archive file for this deployment.
java.lang.String | getState() STATE_ACTIVE or STATE_SUSPENDED
long | getTimestamp() the timestamp can optionally be given and represents the last updated timestamp of the archive file that is being deployed.

Field Detail

STATE_ACTIVE

static final java.lang.String STATE_ACTIVE
normal deployments for which contained process definitions can be executed.

See Also:
Constant Field Values

STATE_SUSPENDED

static final java.lang.String STATE_SUSPENDED
invisible for all operations except delete or resume. This is to have a kind of undoable delete operation.

See Also:
Constant Field Values
Method Detail

getId

java.lang.String getId()
unique identification of this deployment that is used as a reference in the service methods

getName

java.lang.String getName()
typically correspond to the file name or url or some other form of identifying the source archive file for this deployment.

getTimestamp

long getTimestamp()
the timestamp can optionally be given and represents the last updated timestamp of the archive file that is being deployed. JBoss deployer makes use of this to remember if a file is already deployed or not.

getState

java.lang.String getState()
STATE_ACTIVE or STATE_SUSPENDED

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


DeploymentQuery

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface DeploymentQuery

public interface DeploymentQuery

find existing deployments in the repository.

Author:
Tom Baeyens

Field Summary
static java.lang.String | PROPERTY_STATE
static java.lang.String | PROPERTY_TIMESTAMP
Method Summary
long | count() execute a count(*) query and returns number of results
DeploymentQuery | deploymentId(java.lang.String id) only include a specific deployment by id
java.util.List<Deployment> | list() execute the query and get the result list
DeploymentQuery | notSuspended() only select non-suspended deployments
DeploymentQuery | orderAsc(java.lang.String property) order results ascending for property PROPERTY_TIMESTAMP or PROPERTY_STATE
DeploymentQuery | orderDesc(java.lang.String property) order results descending for property PROPERTY_TIMESTAMP or PROPERTY_STATE
DeploymentQuery | page(int firstResult, int maxResults) only select a specific page
DeploymentQuery | suspended() only select suspended deployments
Deployment | uniqueResult() execute the query and get the unique result

Field Detail

PROPERTY_TIMESTAMP

static final java.lang.String PROPERTY_TIMESTAMP
See Also:
Constant Field Values

PROPERTY_STATE

static final java.lang.String PROPERTY_STATE
See Also:
Constant Field Values
Method Detail

deploymentId

DeploymentQuery deploymentId(java.lang.String id)
only include a specific deployment by id

suspended

DeploymentQuery suspended()
only select suspended deployments

notSuspended

DeploymentQuery notSuspended()
only select non-suspended deployments

orderAsc

DeploymentQuery orderAsc(java.lang.String property)
order results ascending for property PROPERTY_TIMESTAMP or PROPERTY_STATE

orderDesc

DeploymentQuery orderDesc(java.lang.String property)
order results descending for property PROPERTY_TIMESTAMP or PROPERTY_STATE

page

DeploymentQuery page(int firstResult,
                     int maxResults)
only select a specific page

list

java.util.List<Deployment> list()
execute the query and get the result list

uniqueResult

Deployment uniqueResult()
execute the query and get the unique result

count

long count()
execute a count(*) query and returns number of results

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Execution

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface Execution

All Superinterfaces:
java.io.Serializable
All Known Subinterfaces:
ActivityExecution, EventListenerExecution, OpenExecution, OpenProcessInstance, ProcessInstance
public interface Execution
extends java.io.Serializable

a runtime path of execution.

State of an execution

The state of an execution is either active or locked. An active execution is either executing or waiting for an external trigger. If an execution is not in STATE_ACTIVE_ROOT or STATE_ACTIVE_CONCURRENT then it is locked. A locked execution is read only.

When a new execution is created, it is in STATE_ACTIVE_ROOT. Some STATE_* constants are provided that represent the most commonly used locked states. But the state '...' in the picture indicates that any string can be provided as the state in the lock method.

If an execution is locked, methods that change the execution will throw a JbpmException and the message will reference the actual locking state. updating variables, updating priority are not considered to change an execution.

Make sure that comparisons between getState() and the STATE_* constants are done with .equals and not with '==' because if executions are loaded from persistent storage, a new string is created instead of the constants.

Comments

Author:
Tom Baeyens

Field Summary
static java.lang.String | STATE_ACTIVE_CONCURRENT concurrent path of execution that is an active indicator of the current position in the diagram.
static java.lang.String | STATE_ACTIVE_ROOT single (non-concurrent) path of execution that is an active indicator of the current position in the diagram.
static java.lang.String | STATE_ASYNC indicates that this execution is doing an asynchronous continuation.
static java.lang.String | STATE_CREATED between creation of a new process instance and the start of that process instance.
static java.lang.String | STATE_ENDED this execution has ended.
static java.lang.String | STATE_INACTIVE_CONCURRENT_ROOT parent of concurrent child executions.
static java.lang.String | STATE_INACTIVE_JOIN concurrent execution that is inactively waiting in a join until other concurrent executions arrive.
static java.lang.String | STATE_INACTIVE_SCOPE parent of a scoped execution.
static java.lang.String | STATE_SUSPENDED indicates that this execution is temporary suspended.
Method Summary
java.util.Set<java.lang.String> | findActiveActivityNames() get the set of all activities that are active.
Execution | findActiveExecutionIn(java.lang.String activityName) search for an execution that is active and in the given activityName.
Execution | getExecution(java.lang.String name) the child execution for the given name or null in case such execution doesn't exist.
java.util.Collection<? extends Execution> | getExecutions() the child executions in the execution structure.
java.util.Map<java.lang.String,? extends Execution> | getExecutionsMap() maps child execution names to execution objects.
java.lang.String | getId() a globally unique identifier for this execution that is used as a reference in the service methods.
boolean | getIsProcessInstance() Returns whether this execution is a process instance.
java.lang.String | getKey() the optional user provided business key that is unique within one process definition.
java.lang.String | getName() the externally given name or id of this execution.
Execution | getParent() the parent execution in the execution structure.
int | getPriority() indicates low priorities with negative values and high priorities with positive values.
java.lang.String | getProcessDefinitionId() id of the process definition used for this execution
Execution | getProcessInstance() the main path of execution in the execution structure.
java.lang.String | getState() the state of this execution.
Execution | getSubProcessInstance() the sub path of execution in the execution structure.
boolean | hasExecution(java.lang.String executionName) indicates if this execution has a child execution with the given executionName
boolean | isActive(java.lang.String activityName) is the given activity active.
boolean | isEnded() is this execution ended
boolean | isSuspended() is this execution suspended ?

Field Detail

STATE_CREATED

static final java.lang.String STATE_CREATED
between creation of a new process instance and the start of that process instance. Typically this is only a very short period that is not observable thourgh the service interfaces.

See Also:
Constant Field Values

STATE_ACTIVE_ROOT

static final java.lang.String STATE_ACTIVE_ROOT
single (non-concurrent) path of execution that is an active indicator of the current position in the diagram. jBPM can be executing automatic activities or some external entity might be responsible for continuing the execution (wait state for jBPM). An active execution is always a leaf in the execution tree. This is the normal state of an execution and the initial state when creating a new execution. Make sure that comparisons are done with .equals and not with '==' because if executions are loaded from persistent storage, a new string is created instead of the constants.

See Also:
Constant Field Values

STATE_ACTIVE_CONCURRENT

static final java.lang.String STATE_ACTIVE_CONCURRENT
concurrent path of execution that is an active indicator of the current position in the diagram. The parent of an active concurrent execution is always an inactive concurrent root. jBPM can be executing automatic activities or some external entity might be responsible for continuing the execution (wait state for jBPM). Make sure that comparisons are done with .equals and not with '==' because if executions are loaded from persistent storage, a new string is created instead of the constants.

See Also:
Constant Field Values

STATE_INACTIVE_CONCURRENT_ROOT

static final java.lang.String STATE_INACTIVE_CONCURRENT_ROOT
parent of concurrent child executions. When an execution has concurrent child executions, it implies that this execution can't be active. For example, at a fork, the parent execution can wait inactively in the fork being till all the child executions are joined. Only leaves of the execution tree can be active. Make sure that comparisons are done with .equals and not with '==' because if executions are loaded from persistent storage, a new string is created instead of the constants.

See Also:
Constant Field Values

STATE_INACTIVE_SCOPE

static final java.lang.String STATE_INACTIVE_SCOPE
parent of a scoped execution. This execution is inactive, but points to the parent scope like e.g. a group. This execution has exactly 1 child execution. That indicates the state inside of the scope. Make sure that comparisons are done with .equals and not with '==' because if executions are loaded from persistent storage, a new string is created instead of the constants.

See Also:
Constant Field Values

STATE_INACTIVE_JOIN

static final java.lang.String STATE_INACTIVE_JOIN
concurrent execution that is inactively waiting in a join until other concurrent executions arrive. Make sure that comparisons are done with .equals and not with '==' because if executions are loaded from persistent storage, a new string is created instead of the constants.

See Also:
Constant Field Values

STATE_SUSPENDED

static final java.lang.String STATE_SUSPENDED
indicates that this execution is temporary suspended. Human tasks of a suspended execution shouldn't show up in people's task list and timers of suspended executions shouldn't fire and the execution is locked. Make sure that comparisons are done with .equals and not with '==' because if executions are loaded from persistent storage, a new string is created instead of the constants.

See Also:
Constant Field Values

STATE_ASYNC

static final java.lang.String STATE_ASYNC
indicates that this execution is doing an asynchronous continuation.

See Also:
Constant Field Values

STATE_ENDED

static final java.lang.String STATE_ENDED
this execution has ended. Make sure that comparisons are done with .equals and not with '==' because if executions are loaded from persistent storage, a new string is created instead of the constants.

See Also:
Constant Field Values
Method Detail

getName

java.lang.String getName()
the externally given name or id of this execution. The id of a main path of execution is null. Can be used to differentiate concurrent paths of execution e.g. the shipping and billing paths.

getKey

java.lang.String getKey()
the optional user provided business key that is unique within one process definition. This could be for instance the order number. It's a user defined identifier for one execution within the scope of a single process definition.

getId

java.lang.String getId()
a globally unique identifier for this execution that is used as a reference in the service methods.

getState

java.lang.String getState()
the state of this execution.

getIsProcessInstance

boolean getIsProcessInstance()
Returns whether this execution is a process instance. Note that we cannot use 'isProcessInstance', since this would clash with 'getProcessInstance()' when using expressions. (see JBPM-2494)

isEnded

boolean isEnded()
is this execution ended

isSuspended

boolean isSuspended()
is this execution suspended ?

getPriority

int getPriority()
indicates low priorities with negative values and high priorities with positive values. The default priority is 0, which means NORMAL. Other recognized named priorities are HIGHEST (2), HIGH (1), LOW (-1) and LOWEST (-2). For the rest, the user can set any other priority integer value, but then, the UI will have to display it as an integer and not the named value.

getProcessInstance

Execution getProcessInstance()
the main path of execution in the execution structure. Null will be returned in case this execution itself is the main execution path.

getSubProcessInstance

Execution getSubProcessInstance()
the sub path of execution in the execution structure. Null will be returned in case there is no sub process execution.

getParent

Execution getParent()
the parent execution in the execution structure. Null will be returned in case this execution itself is the main execution path.

getExecutions

java.util.Collection<? extends Execution> getExecutions()
the child executions in the execution structure. Can be null and can be an empty collection.

getExecutionsMap

java.util.Map<java.lang.String,? extends Execution> getExecutionsMap()
maps child execution names to execution objects. In case multiple executions have the same name, the first one is taken. Can be null or can be an empty map. The first execution without a name is also included with null as the key.

getExecution

Execution getExecution(java.lang.String name)
the child execution for the given name or null in case such execution doesn't exist.

hasExecution

boolean hasExecution(java.lang.String executionName)
indicates if this execution has a child execution with the given executionName

findActiveExecutionIn

Execution findActiveExecutionIn(java.lang.String activityName)
search for an execution that is active and in the given activityName. Returns null in case there is no such execution.

See Also:
findActiveActivityNames()

findActiveActivityNames

java.util.Set<java.lang.String> findActiveActivityNames()
get the set of all activities that are active. Returns an empty set in case there are no activities active.

See Also:
findActiveExecutionIn(String)

isActive

boolean isActive(java.lang.String activityName)
is the given activity active. This execution and its child executions are searched. If this is a process instance, this means that the whole process instance is searched.

getProcessDefinitionId

java.lang.String getProcessDefinitionId()
id of the process definition used for this execution

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExecutionService

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface ExecutionService

public interface ExecutionService

manages runtime process executions.

Author:
Tom Baeyens

Method Summary
ProcessInstanceQuery | createProcessInstanceQuery() search for process instances with criteria.
void | createVariable(java.lang.String executionId, java.lang.String name, java.lang.Object value, boolean historyEnabled) creates a variable value in the referenced execution. optionally enables variable history tracking.
void | createVariables(java.lang.String executionId, java.util.Map<java.lang.String,?> variables, boolean historyEnabled) creates variable values in the referenced execution. optionally enables variable history tracking.
void | deleteProcessInstance(java.lang.String processInstanceId) delete a process instance.
void | deleteProcessInstanceCascade(java.lang.String processInstanceId) delete a process instance, including the history information.
void | endProcessInstance(java.lang.String processInstanceId, java.lang.String state) end a process instance
Execution | findExecutionById(java.lang.String executionId) the path of execution that is uniquely defined by the execution id.
ProcessInstance | findProcessInstanceById(java.lang.String processInstanceId) the process instance that is uniquely defined by the process execution id.
java.lang.Object | getVariable(java.lang.String executionId, java.lang.String variableName) retrieves a variable
java.util.Set<java.lang.String> | getVariableNames(java.lang.String executionId) all the variables visible in the given execution scope
java.util.Map<java.lang.String,java.lang.Object> | getVariables(java.lang.String executionId, java.util.Set<java.lang.String> variableNames) retrieves a map of variables
void | setVariable(java.lang.String executionId, java.lang.String name, java.lang.Object value) creates or overwrites a variable value in the referenced execution
void | setVariables(java.lang.String executionId, java.util.Map<java.lang.String,?> variables) creates or overwrites variable values in the referenced execution
ProcessInstance | signalExecutionById(java.lang.String executionId) provides an external trigger to an execution.
ProcessInstance | signalExecutionById(java.lang.String executionId, java.util.Map<java.lang.String,?> parameters) provides a external trigger to an execution with parameters.
ProcessInstance | signalExecutionById(java.lang.String executionId, java.lang.String signalName) provides a named external trigger to an execution.
ProcessInstance | signalExecutionById(java.lang.String executionId, java.lang.String signalName, java.util.Map<java.lang.String,?> parameters) provides a named external trigger to an execution with parameters.
ProcessInstance | startProcessInstanceById(java.lang.String processDefinitionId) starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
ProcessInstance | startProcessInstanceById(java.lang.String processDefinitionId, java.util.Map<java.lang.String,?> variables) starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
ProcessInstance | startProcessInstanceById(java.lang.String processDefinitionId, java.util.Map<java.lang.String,?> variables, java.lang.String processInstanceKey) starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
ProcessInstance | startProcessInstanceById(java.lang.String processDefinitionId, java.lang.String processInstanceKey) starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
ProcessInstance | startProcessInstanceByKey(java.lang.String processDefinitionKey) starts a new process instance in the latest version of the given process definition.
ProcessInstance | startProcessInstanceByKey(java.lang.String processDefinitionKey, java.util.Map<java.lang.String,?> variables) starts a new process instance in the latest version of the given processDefinitionName.
ProcessInstance | startProcessInstanceByKey(java.lang.String processDefinitionKey, java.util.Map<java.lang.String,?> variables, java.lang.String processInstanceKey) starts a new process instance in the latest version of the given processDefinitionName.
ProcessInstance | startProcessInstanceByKey(java.lang.String processDefinitionKey, java.lang.String processInstanceKey) starts a new process instance in the latest version of the given processDefinitionName.

Method Detail

startProcessInstanceById

ProcessInstance startProcessInstanceById(java.lang.String processDefinitionId)
starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.

Parameters:
processDefinitionId - the unique id of the process definition.

startProcessInstanceById

ProcessInstance startProcessInstanceById(java.lang.String processDefinitionId,
                                         java.lang.String processInstanceKey)
starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.

Parameters:
processDefinitionId - the unique id of the process definition.
processInstanceKey - is a user provided reference for the new process instance that must be unique over all process definition versions with the same name.

startProcessInstanceById

ProcessInstance startProcessInstanceById(java.lang.String processDefinitionId,
                                         java.util.Map<java.lang.String,?> variables)
starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.

Parameters:
processDefinitionId - the unique id of the process definition.
variables - are the initial values of the process variables that will be set before the execution starts.

startProcessInstanceById

ProcessInstance startProcessInstanceById(java.lang.String processDefinitionId,
                                         java.util.Map<java.lang.String,?> variables,
                                         java.lang.String processInstanceKey)
starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.

Parameters:
processDefinitionId - the unique id of the process definition.
variables - are the initial values of the process variables that will be set before the execution starts.
processInstanceKey - is a user provided reference for the new process instance that must be unique over all process versions with the same name.

startProcessInstanceByKey

ProcessInstance startProcessInstanceByKey(java.lang.String processDefinitionKey)
starts a new process instance in the latest version of the given process definition.

Parameters:
processDefinitionKey - is the key of the process definition for which the latest version will be taken.

startProcessInstanceByKey

ProcessInstance startProcessInstanceByKey(java.lang.String processDefinitionKey,
                                          java.lang.String processInstanceKey)
starts a new process instance in the latest version of the given processDefinitionName.

Parameters:
processDefinitionKey - is the key of the process definition for which the latest version will be taken.
processInstanceKey - is a user provided reference for the new process instance that must be unique over all process versions with the same name.

startProcessInstanceByKey

ProcessInstance startProcessInstanceByKey(java.lang.String processDefinitionKey,
                                          java.util.Map<java.lang.String,?> variables)
starts a new process instance in the latest version of the given processDefinitionName.

Parameters:
processDefinitionKey - is the key of the process definition for which the latest version will be taken.
variables - are the initial values of the process variables that will be set before the execution starts (read: before the initial activity is executed).

startProcessInstanceByKey

ProcessInstance startProcessInstanceByKey(java.lang.String processDefinitionKey,
                                          java.util.Map<java.lang.String,?> variables,
                                          java.lang.String processInstanceKey)
starts a new process instance in the latest version of the given processDefinitionName.

Parameters:
processDefinitionKey - is the key of the process definition for which the latest version will be taken.
variables - are the initial values of the process variables that will be set before the execution starts.
processInstanceKey - is a user provided reference for the new execution that must be unique over all process versions with the same name.

findExecutionById

Execution findExecutionById(java.lang.String executionId)
the path of execution that is uniquely defined by the execution id.

findProcessInstanceById

ProcessInstance findProcessInstanceById(java.lang.String processInstanceId)
the process instance that is uniquely defined by the process execution id.

signalExecutionById

ProcessInstance signalExecutionById(java.lang.String executionId)
provides an external trigger to an execution.

signalExecutionById

ProcessInstance signalExecutionById(java.lang.String executionId,
                                    java.lang.String signalName)
provides a named external trigger to an execution.

signalExecutionById

ProcessInstance signalExecutionById(java.lang.String executionId,
                                    java.lang.String signalName,
                                    java.util.Map<java.lang.String,?> parameters)
provides a named external trigger to an execution with parameters.

signalExecutionById

ProcessInstance signalExecutionById(java.lang.String executionId,
                                    java.util.Map<java.lang.String,?> parameters)
provides a external trigger to an execution with parameters.

createProcessInstanceQuery

ProcessInstanceQuery createProcessInstanceQuery()
search for process instances with criteria. be aware that this query only sees ongoing process instances. refer to HistoryService.createHistoryTaskQuery() for queries that include finished process instances.

setVariable

void setVariable(java.lang.String executionId,
                 java.lang.String name,
                 java.lang.Object value)
creates or overwrites a variable value in the referenced execution

setVariables

void setVariables(java.lang.String executionId,
                  java.util.Map<java.lang.String,?> variables)
creates or overwrites variable values in the referenced execution

createVariable

void createVariable(java.lang.String executionId,
                    java.lang.String name,
                    java.lang.Object value,
                    boolean historyEnabled)
creates a variable value in the referenced execution. optionally enables variable history tracking.

createVariables

void createVariables(java.lang.String executionId,
                     java.util.Map<java.lang.String,?> variables,
                     boolean historyEnabled)
creates variable values in the referenced execution. optionally enables variable history tracking.

getVariable

java.lang.Object getVariable(java.lang.String executionId,
                             java.lang.String variableName)
retrieves a variable

getVariableNames

java.util.Set<java.lang.String> getVariableNames(java.lang.String executionId)
all the variables visible in the given execution scope

getVariables

java.util.Map<java.lang.String,java.lang.Object> getVariables(java.lang.String executionId,
                                                              java.util.Set<java.lang.String> variableNames)
retrieves a map of variables

endProcessInstance

void endProcessInstance(java.lang.String processInstanceId,
                        java.lang.String state)
end a process instance

deleteProcessInstance

void deleteProcessInstance(java.lang.String processInstanceId)
delete a process instance. The history information will still be in the database.

Throws:
JbpmException - if the given processInstanceId doesn't exist

deleteProcessInstanceCascade

void deleteProcessInstanceCascade(java.lang.String processInstanceId)
delete a process instance, including the history information.

Throws:
JbpmException - if the given processInstanceId doesn't exist
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoryService

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface HistoryService

public interface HistoryService

exposes the history information for ongoing and past process instances.

Author:
Tom Baeyens, Maciej Swiderski

Method Summary
java.util.Map<java.lang.String,java.lang.Number> | avgDurationPerActivity(java.lang.String processDefinitionId) returns the average duration in milliseconds for each activity in the given process definition
java.util.Map<java.lang.String,java.lang.Number> | choiceDistribution(java.lang.String processDefinitionId, java.lang.String activityName) returns for each transitionName, the number of times that transition was taken
HistoryActivityInstanceQuery | createHistoryActivityInstanceQuery() search in history activity instance information
HistoryDetailQuery | createHistoryDetailQuery() search in history details
HistoryProcessInstanceQuery | createHistoryProcessInstanceQuery() search for process instances in the history
HistoryTaskQuery | createHistoryTaskQuery() search in history task information
java.lang.Object | getVariable(java.lang.String processInstanceId, java.lang.String variableName) retrieves a map of variables
java.util.Set<java.lang.String> | getVariableNames(java.lang.String processInstanceId) retrieves a variable
java.util.Map<java.lang.String,?> | getVariables(java.lang.String processInstanceId, java.util.Set<java.lang.String> variableNames) all the variables visible in the given history execution scope

Method Detail

createHistoryProcessInstanceQuery

HistoryProcessInstanceQuery createHistoryProcessInstanceQuery()
search for process instances in the history

createHistoryActivityInstanceQuery

HistoryActivityInstanceQuery createHistoryActivityInstanceQuery()
search in history activity instance information

createHistoryTaskQuery

HistoryTaskQuery createHistoryTaskQuery()
search in history task information

createHistoryDetailQuery

HistoryDetailQuery createHistoryDetailQuery()
search in history details

avgDurationPerActivity

java.util.Map<java.lang.String,java.lang.Number> avgDurationPerActivity(java.lang.String processDefinitionId)
returns the average duration in milliseconds for each activity in the given process definition

choiceDistribution

java.util.Map<java.lang.String,java.lang.Number> choiceDistribution(java.lang.String processDefinitionId,
                                                                    java.lang.String activityName)
returns for each transitionName, the number of times that transition was taken

getVariableNames

java.util.Set<java.lang.String> getVariableNames(java.lang.String processInstanceId)
retrieves a variable

getVariable

java.lang.Object getVariable(java.lang.String processInstanceId,
                             java.lang.String variableName)
retrieves a map of variables

getVariables

java.util.Map<java.lang.String,?> getVariables(java.lang.String processInstanceId,
                                               java.util.Set<java.lang.String> variableNames)
all the variables visible in the given history execution scope

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


IdentityService

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface IdentityService

public interface IdentityService

interface to expose the (configurable) identity component that is used by jBPM.

Author:
Tom Baeyens

Method Summary
java.lang.String | createGroup(java.lang.String groupName) create a group new group
java.lang.String | createGroup(java.lang.String groupName, java.lang.String groupType) create a group new group
java.lang.String | createGroup(java.lang.String groupName, java.lang.String groupType, java.lang.String parentGroupId) create a group new group
void | createMembership(java.lang.String userId, java.lang.String groupId) makes the given user a member of the given group.
void | createMembership(java.lang.String userId, java.lang.String groupId, java.lang.String role) makes the given user a member of the given group with the given role.
void | createUser(java.lang.String userId, java.lang.String givenName, java.lang.String familyName) create a new user.
void | createUser(java.lang.String userId, java.lang.String givenName, java.lang.String familyName, java.lang.String businessEmail) create a new user, providing an email address
void | deleteGroup(java.lang.String groupId) deletes the given group.
void | deleteMembership(java.lang.String userId, java.lang.String groupId, java.lang.String role) deletes the identified relation between a user and a group.
void | deleteUser(java.lang.String userId) delete the given user.
Group | findGroupById(java.lang.String groupId) lookup a group.
java.util.List<java.lang.String> | findGroupIdsByUser(java.lang.String userId) all group ids (String) for which this user is a member.
java.util.List<Group> | findGroupsByUser(java.lang.String userId) all group ids (String) for which this user is a member.
java.util.List<Group> | findGroupsByUserAndGroupType(java.lang.String userId, java.lang.String groupType) groups of the given groupType for which the given user is a member.
User | findUserById(java.lang.String userId) lookup a user
java.util.List<User> | findUsers() get all the users in the system.

Method Detail

createUser

void createUser(java.lang.String userId,
                java.lang.String givenName,
                java.lang.String familyName)
create a new user.

createUser

void createUser(java.lang.String userId,
                java.lang.String givenName,
                java.lang.String familyName,
                java.lang.String businessEmail)
create a new user, providing an email address

findUserById

User findUserById(java.lang.String userId)
lookup a user

Returns:
the user or null if no such user exists

findUsers

java.util.List<User> findUsers()
get all the users in the system. Returns an empty list if no users exist.

deleteUser

void deleteUser(java.lang.String userId)
delete the given user. No effect (no exception) if the user does not exist. Deletes also the memberships related to the given user, but does not delete the associated groups.

createGroup

java.lang.String createGroup(java.lang.String groupName)
create a group new group

Returns:
the generated id for this group.

createGroup

java.lang.String createGroup(java.lang.String groupName,
                             java.lang.String groupType)
create a group new group

Returns:
the generated id for this group.

createGroup

java.lang.String createGroup(java.lang.String groupName,
                             java.lang.String groupType,
                             java.lang.String parentGroupId)
create a group new group

Returns:
the generated id for this group.

findGroupById

Group findGroupById(java.lang.String groupId)
lookup a group.

Returns:
the user or null if no such user exists

findGroupsByUserAndGroupType

java.util.List<Group> findGroupsByUserAndGroupType(java.lang.String userId,
                                                   java.lang.String groupType)
groups of the given groupType for which the given user is a member. Returns an empty list if no such groups exist.

findGroupsByUser

java.util.List<Group> findGroupsByUser(java.lang.String userId)
all group ids (String) for which this user is a member. Returns an empty list if no such groups exist.

findGroupIdsByUser

java.util.List<java.lang.String> findGroupIdsByUser(java.lang.String userId)
all group ids (String) for which this user is a member. Returns an empty list if no such groups exist.

deleteGroup

void deleteGroup(java.lang.String groupId)
deletes the given group. No effect (no exception) if the group does not exist. Deleting a group also deletes all the memberships associated to that group, but not the associated users.

createMembership

void createMembership(java.lang.String userId,
                      java.lang.String groupId)
makes the given user a member of the given group.

createMembership

void createMembership(java.lang.String userId,
                      java.lang.String groupId,
                      java.lang.String role)
makes the given user a member of the given group with the given role. Role can be null.

deleteMembership

void deleteMembership(java.lang.String userId,
                      java.lang.String groupId,
                      java.lang.String role)
deletes the identified relation between a user and a group. Role can be null. If no such membership exists, this method will not throw an exception and have no effect.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


JobQuery

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface JobQuery

public interface JobQuery

query for jBPM related messages and timers.

Both messages and timers are jobs.

Author:
Tom Baeyens

Field Summary
static java.lang.String | PROPERTY_DUEDATE duedate property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_STATE state property to be used as property in orderAsc(String) and orderDesc(String)
Method Summary
long | count() execute a count(*) query and returns number of results
JobQuery | exception(boolean hasException) only select jobs that were rolled back due to an exception
java.util.List<Job> | list() execute the query and get the result list
JobQuery | messages() only select messages
JobQuery | orderAsc(java.lang.String property) order ascending for property PROPERTY_STATE or PROPERTY_DUEDATE
JobQuery | orderDesc(java.lang.String property) order descending for property PROPERTY_STATE or PROPERTY_DUEDATE
JobQuery | page(int firstResult, int maxResults) only select a specific page
JobQuery | processInstanceId(java.lang.String processInstanceId) only select jobs related to the given process instance
JobQuery | timers() only select timers
Job | uniqueResult() execute the query and get the unique result

Field Detail

PROPERTY_DUEDATE

static final java.lang.String PROPERTY_DUEDATE
duedate property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_STATE

static final java.lang.String PROPERTY_STATE
state property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values
Method Detail

messages

JobQuery messages()
only select messages

timers

JobQuery timers()
only select timers

processInstanceId

JobQuery processInstanceId(java.lang.String processInstanceId)
only select jobs related to the given process instance

exception

JobQuery exception(boolean hasException)
only select jobs that were rolled back due to an exception

orderAsc

JobQuery orderAsc(java.lang.String property)
order ascending for property PROPERTY_STATE or PROPERTY_DUEDATE

orderDesc

JobQuery orderDesc(java.lang.String property)
order descending for property PROPERTY_STATE or PROPERTY_DUEDATE

page

JobQuery page(int firstResult,
              int maxResults)
only select a specific page

list

java.util.List<Job> list()
execute the query and get the result list

uniqueResult

Job uniqueResult()
execute the query and get the unique result

count

long count()
execute a count(*) query and returns number of results

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ManagementService

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface ManagementService

public interface ManagementService

operations targeted to system operators that need to keep the process engine up and running. This functionality is typically exposed through a management web console.

Author:
Tom Baeyens

Method Summary
JobQuery | createJobQuery() search for jobs
boolean | deleteJob(long jobId) Deletes the job with the given id.
void | executeJob(java.lang.String jobId) resets the retry count, clears the exception and executes the job.

Method Detail

executeJob

void executeJob(java.lang.String jobId)
resets the retry count, clears the exception and executes the job. An exception is thrown out of this method in case the execution of the job fails. In case the async command executor is configured for this service, failing job execution will not result into an exception coming out of this method.

createJobQuery

JobQuery createJobQuery()
search for jobs

deleteJob

boolean deleteJob(long jobId)
Deletes the job with the given id.

Returns:
True if the deletion was succesful.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


NewDeployment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface NewDeployment

All Superinterfaces:
Deployment
public interface NewDeployment
extends Deployment

extends a Deployment with method for creating a new deployment.

Author:
Tom Baeyens
See Also:
RepositoryService.createDeployment()

Field Summary
Fields inherited from interface org.jbpm.api.Deployment
STATE_ACTIVE, STATE_SUSPENDED
Method Summary
NewDeployment | addResourceFromClasspath(java.lang.String resourceName) adds a resource as a resource from the classpath
NewDeployment | addResourceFromFile(java.io.File file) adds a resource from a file
NewDeployment | addResourceFromInputStream(java.lang.String resourceName, java.io.InputStream inputStream) adds a resource as a string
NewDeployment | addResourceFromString(java.lang.String resourceName, java.lang.String string) adds a resource as a string
NewDeployment | addResourceFromUrl(java.net.URL url) adds a resource as a url
NewDeployment | addResourcesFromZipInputStream(java.util.zip.ZipInputStream zipInputStream) adds a resource as a zip stream
java.lang.String | deploy() after adding resources, this will perform the actual deployment.
NewDeployment | setName(java.lang.String name) typically correspond to the file name or url or some other form of identifying the source archive file for this deployment.
NewDeployment | setTimestamp(long timestamp) the timestamp can optionally be given and represents the last updated timestamp of the archive file that is being deployed.
Methods inherited from interface org.jbpm.api.Deployment
getId, getName, getState, getTimestamp

Method Detail

setName

NewDeployment setName(java.lang.String name)
typically correspond to the file name or url or some other form of identifying the source archive file for this deployment.

setTimestamp

NewDeployment setTimestamp(long timestamp)
the timestamp can optionally be given and represents the last updated timestamp of the archive file that is being deployed. JBoss deployer makes use of this to remember if a file is already deployed or not.

addResourceFromString

NewDeployment addResourceFromString(java.lang.String resourceName,
                                    java.lang.String string)
adds a resource as a string

addResourceFromInputStream

NewDeployment addResourceFromInputStream(java.lang.String resourceName,
                                         java.io.InputStream inputStream)
adds a resource as a string

addResourceFromClasspath

NewDeployment addResourceFromClasspath(java.lang.String resourceName)
adds a resource as a resource from the classpath

addResourceFromUrl

NewDeployment addResourceFromUrl(java.net.URL url)
adds a resource as a url

addResourcesFromZipInputStream

NewDeployment addResourcesFromZipInputStream(java.util.zip.ZipInputStream zipInputStream)
adds a resource as a zip stream

addResourceFromFile

NewDeployment addResourceFromFile(java.io.File file)
adds a resource from a file

deploy

java.lang.String deploy()
after adding resources, this will perform the actual deployment.

Returns:
the generated deploymentId identification for this deployment in the repository.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProcessDefinition

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface ProcessDefinition

All Superinterfaces:
java.io.Serializable
public interface ProcessDefinition
extends java.io.Serializable

a graphical process which is deployed in the RepositoryService.

Author:
Tom Baeyens

Method Summary
java.lang.String | getDeploymentId() references the deployment in which this process definition is deployed.
java.lang.String | getDescription() description of the process definition
java.lang.String | getId() the unique id for this process definition that is used as a reference in the service methods.
java.lang.String | getImageResourceName() the name of the resource in the deployment which contains the image file for this process
java.lang.String | getKey() the user defined short representation of the name.
java.lang.String | getName() the short display name given to this process definition.
int | getVersion() automatically assigned during deployment of a process that represents the sequence number for process definitions with the same name.
boolean | isSuspended() Returns whether this process definition is currently suspended.

Method Detail

getName

java.lang.String getName()
the short display name given to this process definition. Multiple process definitions can have the same as long as they are given a different version.

getKey

java.lang.String getKey()
the user defined short representation of the name. Just like the name, multiple versions of a process definition can have the same key.

getId

java.lang.String getId()
the unique id for this process definition that is used as a reference in the service methods.

getVersion

int getVersion()
automatically assigned during deployment of a process that represents the sequence number for process definitions with the same name.

getDeploymentId

java.lang.String getDeploymentId()
references the deployment in which this process definition is deployed.

getImageResourceName

java.lang.String getImageResourceName()
the name of the resource in the deployment which contains the image file for this process

getDescription

java.lang.String getDescription()
description of the process definition

isSuspended

boolean isSuspended()
Returns whether this process definition is currently suspended.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProcessDefinitionQuery

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface ProcessDefinitionQuery

public interface ProcessDefinitionQuery

query for process definitions.

Author:
Tom Baeyens

Field Summary
static java.lang.String | PROPERTY_DEPLOYMENT_TIMESTAMP timestamp property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_ID id property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_KEY key property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_NAME name property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_VERSION version property to be used as property in orderAsc(String) and orderDesc(String)
Method Summary
long | count() execute a count(*) query and returns number of results
ProcessDefinitionQuery | deploymentId(java.lang.String deploymentId) select only process definitions within the given deployment
java.util.List<ProcessDefinition> | list() execute the query and obtain the list of ProcessDefinitions
ProcessDefinitionQuery | notSuspended() select only process definitions that are not suspended
ProcessDefinitionQuery | orderAsc(java.lang.String property) order selected process definitions ascending for certain properties
ProcessDefinitionQuery | orderDesc(java.lang.String property) order selected process definitions descending for certain properties
ProcessDefinitionQuery | page(int firstResult, int maxResults) select a specific page in the result set
ProcessDefinitionQuery | processDefinitionId(java.lang.String processDefinitionId) select only the process definition with the given id
ProcessDefinitionQuery | processDefinitionKey(java.lang.String key) select only process definitions with the given key
ProcessDefinitionQuery | processDefinitionName(java.lang.String name) select only process definitions with an exact match for the given name
ProcessDefinitionQuery | processDefinitionNameLike(java.lang.String name) select only process definitions with a name like the given name (name can include % signs to act as wildcard))
ProcessDefinitionQuery | suspended() select only suspended process definitions
ProcessDefinition | uniqueResult() execute the query and obtain the unique ProcessDefinition

Field Detail

PROPERTY_ID

static final java.lang.String PROPERTY_ID
id property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_KEY

static final java.lang.String PROPERTY_KEY
key property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_NAME

static final java.lang.String PROPERTY_NAME
name property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_VERSION

static final java.lang.String PROPERTY_VERSION
version property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_DEPLOYMENT_TIMESTAMP

static final java.lang.String PROPERTY_DEPLOYMENT_TIMESTAMP
timestamp property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values
Method Detail

processDefinitionId

ProcessDefinitionQuery processDefinitionId(java.lang.String processDefinitionId)
select only the process definition with the given id

processDefinitionKey

ProcessDefinitionQuery processDefinitionKey(java.lang.String key)
select only process definitions with the given key

processDefinitionNameLike

ProcessDefinitionQuery processDefinitionNameLike(java.lang.String name)
select only process definitions with a name like the given name (name can include % signs to act as wildcard))

processDefinitionName

ProcessDefinitionQuery processDefinitionName(java.lang.String name)
select only process definitions with an exact match for the given name

deploymentId

ProcessDefinitionQuery deploymentId(java.lang.String deploymentId)
select only process definitions within the given deployment

suspended

ProcessDefinitionQuery suspended()
select only suspended process definitions

notSuspended

ProcessDefinitionQuery notSuspended()
select only process definitions that are not suspended

orderAsc

ProcessDefinitionQuery orderAsc(java.lang.String property)
order selected process definitions ascending for certain properties

orderDesc

ProcessDefinitionQuery orderDesc(java.lang.String property)
order selected process definitions descending for certain properties

page

ProcessDefinitionQuery page(int firstResult,
                            int maxResults)
select a specific page in the result set

list

java.util.List<ProcessDefinition> list()
execute the query and obtain the list of ProcessDefinitions

uniqueResult

ProcessDefinition uniqueResult()
execute the query and obtain the unique ProcessDefinition

count

long count()
execute a count(*) query and returns number of results

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProcessEngine

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface ProcessEngine

public interface ProcessEngine

central starting point for all process engine API interactions. This is a thread safe object so it can be kept in a static member field or in JNDI or something similar from which all threads (requests) will fetch the same ProcessEngine object.

Author:
Tom Baeyens

Method Summary
 void close()
clean shutdown of the engine.
<T> T
execute(Command<T> command)
perform a user command.
<T> T
get(java.lang.Class<T> type)
retrieve and object defined in the process engine by type
 java.lang.Object get(java.lang.String name)
retrieve and object defined in the process engine by name
 ExecutionService getExecutionService()
the execution service that provides access to the runtime executions repository.
 HistoryService getHistoryService()
the history service that provides access to the history executions repository.
 IdentityService getIdentityService()
the identity service that exposes the user and group operations management operations.
 ManagementService getManagementService()
the management service that exposes the management operations to operators that have to keep the jBPM system up and running.
 RepositoryService getRepositoryService()
the repository service that provides access to the process repository.
 TaskService getTaskService()
the task service that exposes the runtime human task lists.
 ProcessEngine setAuthenticatedUserId(java.lang.String authenticatedUserId)
sets the authenticated user's id for the next invocation of a service method in the same thread.
 ProcessEngine setHibernateSession(java.lang.Object hibernateSession)
sets the hibernate session for the next invocation of a service method in the same thread.
 ProcessEngine setJdbcConnection(java.sql.Connection jdbcConnection)
sets the hibernate session for the next invocation of a service method in the same thread.

Method Detail

getRepositoryService

RepositoryService getRepositoryService()
the repository service that provides access to the process repository.

getExecutionService

ExecutionService getExecutionService()
the execution service that provides access to the runtime executions repository.

getHistoryService

HistoryService getHistoryService()
the history service that provides access to the history executions repository.

getTaskService

TaskService getTaskService()
the task service that exposes the runtime human task lists.

getIdentityService

IdentityService getIdentityService()
the identity service that exposes the user and group operations management operations.

getManagementService

ManagementService getManagementService()
the management service that exposes the management operations to operators that have to keep the jBPM system up and running.

get

<T> T get(java.lang.Class<T> type)
retrieve and object defined in the process engine by type

get

java.lang.Object get(java.lang.String name)
retrieve and object defined in the process engine by name

setAuthenticatedUserId

ProcessEngine setAuthenticatedUserId(java.lang.String authenticatedUserId)
sets the authenticated user's id for the next invocation of a service method in the same thread. This method returns the process engine for convenient method concatenations.

setHibernateSession

ProcessEngine setHibernateSession(java.lang.Object hibernateSession)
sets the hibernate session for the next invocation of a service method in the same thread. The hibernateSession parameter is of type Object to prevent a dependency of the API on hibernate directly. This method returns the process engine for convenient method concatenations.

setJdbcConnection

ProcessEngine setJdbcConnection(java.sql.Connection jdbcConnection)
sets the hibernate session for the next invocation of a service method in the same thread. This method returns the process engine for convenient method concatenations.

execute

<T> T execute(Command<T> command)
perform a user command. that allows users to span a transaction over their own updates, as well as the jbpm operations.

close

void close()
clean shutdown of the engine.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProcessInstance

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface ProcessInstance

All Superinterfaces:
Execution, java.io.Serializable
All Known Subinterfaces:
OpenProcessInstance
public interface ProcessInstance
extends Execution

a process instance is one execution of a process definition. One process instance can have many concurrent executions. Executions are structured in a tree of which the ProcessInstance is the root.

Author:
Tom Baeyens

Field Summary
Fields inherited from interface org.jbpm.api.Execution
STATE_ACTIVE_CONCURRENT, STATE_ACTIVE_ROOT, STATE_ASYNC, STATE_CREATED, STATE_ENDED, STATE_INACTIVE_CONCURRENT_ROOT, STATE_INACTIVE_JOIN, STATE_INACTIVE_SCOPE, STATE_SUSPENDED
Method Summary
Methods inherited from interface org.jbpm.api.Execution
findActiveActivityNames, findActiveExecutionIn, getExecution, getExecutions, getExecutionsMap, getId, getIsProcessInstance, getKey, getName, getParent, getPriority, getProcessDefinitionId, getProcessInstance, getState, getSubProcessInstance, hasExecution, isActive, isEnded, isSuspended

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ProcessInstanceQuery

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface ProcessInstanceQuery

public interface ProcessInstanceQuery

query for ongoing process instances exclusively. refer to HistoryProcessInstanceQuery for queries that include finished process instances.

Author:
Tom Baeyens

Field Summary
static java.lang.String PROPERTY_KEY
key property to be used as property in orderAsc(String) and orderDesc(String)
Method Summary
long | count() execute a count(*) query and returns number of results
java.util.List<ProcessInstance> | list() execute the query and obtain the list of ProcessInstances
ProcessInstanceQuery | notSuspended() select only process definitions that are not suspended
ProcessInstanceQuery | orderAsc(java.lang.String property) order selected process instances ascending for certain properties
ProcessInstanceQuery | orderDesc(java.lang.String property) order selected process instances descending for certain properties
ProcessInstanceQuery | page(int firstResult, int maxResults) select a specific page in the result set
ProcessInstanceQuery | processDefinitionId(java.lang.String processDefinitionId) select only process instances for the given process definition
ProcessInstanceQuery | processInstanceId(java.lang.String processInstanceId) select only a specific process instances using the process instance id
ProcessInstanceQuery | processInstanceKey(java.lang.String processInstanceKey) select only specific process instances using a business key
ProcessInstanceQuery | suspended() select only suspended process definitions
ProcessInstance | uniqueResult() execute the query and obtain the unique ProcessInstance

Field Detail

PROPERTY_KEY

static final java.lang.String PROPERTY_KEY
key property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values
Method Detail

processDefinitionId

ProcessInstanceQuery processDefinitionId(java.lang.String processDefinitionId)
select only process instances for the given process definition

processInstanceId

ProcessInstanceQuery processInstanceId(java.lang.String processInstanceId)
select only a specific process instances using the process instance id

processInstanceKey

ProcessInstanceQuery processInstanceKey(java.lang.String processInstanceKey)
select only specific process instances using a business key

suspended

ProcessInstanceQuery suspended()
select only suspended process definitions

notSuspended

ProcessInstanceQuery notSuspended()
select only process definitions that are not suspended

orderAsc

ProcessInstanceQuery orderAsc(java.lang.String property)
order selected process instances ascending for certain properties

orderDesc

ProcessInstanceQuery orderDesc(java.lang.String property)
order selected process instances descending for certain properties

page

ProcessInstanceQuery page(int firstResult,
                          int maxResults)
select a specific page in the result set

list

java.util.List<ProcessInstance> list()
execute the query and obtain the list of ProcessInstances

uniqueResult

ProcessInstance uniqueResult()
execute the query and obtain the unique ProcessInstance

count

long count()
execute a count(*) query and returns number of results

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RepositoryService

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface RepositoryService

public interface RepositoryService

exposes the repository of deployments.

Deployments contain a set of named resources. Those resources can represent process definitions, forms, images and so on.

The repository contains and manages the process definitions.

Author:
Tom Baeyens

Method Summary
NewDeployment | createDeployment() create a new deployment.
DeploymentQuery | createDeploymentQuery() create a query for deployments
ProcessDefinitionQuery | createProcessDefinitionQuery() create a query for process definitions
void | deleteDeployment(java.lang.String deploymentId) deletes a deployment if the process definitions don't have running executions.
void | deleteDeploymentCascade(java.lang.String deploymentId) deletes deployment, contained process definitions, related process instances and their history information
ActivityCoordinates | getActivityCoordinates(java.lang.String processDefinitionId, java.lang.String activityName) the coordinates for the activity on the process image.
java.io.InputStream | getResourceAsStream(java.lang.String deploymentId, java.lang.String resourceName) obtain an InputStream to a resource in a deployment
java.util.Set<java.lang.String> | getResourceNames(java.lang.String deploymentId) Returns all the resources stored in the deployment with the given id.
java.util.List<java.lang.String> | getStartActivityNames(java.lang.String processDefinitionId) find all the activity names of the start activities for a given process definition.
java.lang.String | getStartFormResourceName(java.lang.String processDefinitionId, java.lang.String activityName) the resource name for the given start activity.
void | resumeDeployment(java.lang.String deploymentId) resume a suspended deployment.
void | suspendDeployment(java.lang.String deploymentId) similar to deleting a deployment.

Method Detail

createDeployment

NewDeployment createDeployment()
create a new deployment. The deployment will only be deployed into the repository after invoking the NewDeployment.deploy().

suspendDeployment

void suspendDeployment(java.lang.String deploymentId)
similar to deleting a deployment. The difference is that all the data remains in the database. So that the suspending can be undone with resumeDeployment(String).

resumeDeployment

void resumeDeployment(java.lang.String deploymentId)
resume a suspended deployment.

deleteDeployment

void deleteDeployment(java.lang.String deploymentId)
deletes a deployment if the process definitions don't have running executions. history information (if any) remains in the database.

deleteDeploymentCascade

void deleteDeploymentCascade(java.lang.String deploymentId)
deletes deployment, contained process definitions, related process instances and their history information

getResourceNames

java.util.Set<java.lang.String> getResourceNames(java.lang.String deploymentId)
Returns all the resources stored in the deployment with the given id.

getResourceAsStream

java.io.InputStream getResourceAsStream(java.lang.String deploymentId,
                                        java.lang.String resourceName)
obtain an InputStream to a resource in a deployment

createProcessDefinitionQuery

ProcessDefinitionQuery createProcessDefinitionQuery()
create a query for process definitions

createDeploymentQuery

DeploymentQuery createDeploymentQuery()
create a query for deployments

getStartActivityNames

java.util.List<java.lang.String> getStartActivityNames(java.lang.String processDefinitionId)
find all the activity names of the start activities for a given process definition. Only top level activities are scanned. Every activity that doesn't have incoming transitions is considered a start activity. For the moment, jPDL only supports one start activity. Start activity names can be null.

getStartFormResourceName

java.lang.String getStartFormResourceName(java.lang.String processDefinitionId,
                                          java.lang.String activityName)
the resource name for the given start activity. It is assumed that the ProcessDefinition is already retrieved. From the ProcessDefinition, the ProcessDefinition.getId() and the ProcessDefinition.getDeploymentId() can be retrieved. The activityName can be obtained via getStartActivityNames(String). An InputStream for the resource can be obtained with getResourceAsStream(String, String)

getActivityCoordinates

ActivityCoordinates getActivityCoordinates(java.lang.String processDefinitionId,
                                           java.lang.String activityName)
the coordinates for the activity on the process image.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TaskQuery

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface TaskQuery

public interface TaskQuery

query for tasks.

Author:
Tom Baeyens, Heiko Braun

Field Summary
static java.lang.String | PROPERTY_ASSIGNEE assignee property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_CREATEDATE createdate property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_DUEDATE duedate property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_NAME name property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_PRIORITY priority property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_PROGRESS progress property to be used as property in orderAsc(String) and orderDesc(String)
Method Summary
TaskQuery | activityName(java.lang.String activityName) only select tasks that are associated to the given activity name.
TaskQuery | assignee(java.lang.String userId) only select tasks for which the given user is the assignee
TaskQuery | candidate(java.lang.String userId) only query for tasks for which the given user is a candidate.
long | count() execute a count(*) query and returns number of results
TaskQuery | executionId(java.lang.String executionId) only select tasks that are associated to the given execution
java.util.List<Task> | list() execute the query and obtain the list of Tasks
TaskQuery | notSuspended() only select tasks that are not suspended
TaskQuery | orderAsc(java.lang.String property) order selected tasks ascending for certain properties
TaskQuery | orderDesc(java.lang.String property) order selected tasks descending for certain properties
TaskQuery | page(int firstResult, int maxResults) select a specific page in the result set
TaskQuery | processDefinitionId(java.lang.String processDefinitionId) only select tasks that are associated to the given process definition
TaskQuery | processInstanceId(java.lang.String processInstanceId) only select tasks that are associated to the given process instance
TaskQuery | suspended() only select suspended tasks
TaskQuery | unassigned() only select tasks that are unassigned.
Task | uniqueResult() execute the query and obtain the unique Task

Field Detail

PROPERTY_NAME

static final java.lang.String PROPERTY_NAME
name property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_ASSIGNEE

static final java.lang.String PROPERTY_ASSIGNEE
assignee property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_CREATEDATE

static final java.lang.String PROPERTY_CREATEDATE
createdate property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_DUEDATE

static final java.lang.String PROPERTY_DUEDATE
duedate property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_PRIORITY

static final java.lang.String PROPERTY_PRIORITY
priority property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_PROGRESS

static final java.lang.String PROPERTY_PROGRESS
progress property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values
Method Detail

assignee

TaskQuery assignee(java.lang.String userId)
only select tasks for which the given user is the assignee

unassigned

TaskQuery unassigned()
only select tasks that are unassigned. These tasks can still potentially have candidates.

candidate

TaskQuery candidate(java.lang.String userId)
only query for tasks for which the given user is a candidate. The user could be associated directly as a candidate participant to the task or the user could be a member of a group that is associated as a candidate group to the task.

executionId

TaskQuery executionId(java.lang.String executionId)
only select tasks that are associated to the given execution

processInstanceId

TaskQuery processInstanceId(java.lang.String processInstanceId)
only select tasks that are associated to the given process instance

processDefinitionId

TaskQuery processDefinitionId(java.lang.String processDefinitionId)
only select tasks that are associated to the given process definition

activityName

TaskQuery activityName(java.lang.String activityName)
only select tasks that are associated to the given activity name. This can be used in combination with the processDefinitionId(String)

suspended

TaskQuery suspended()
only select suspended tasks

notSuspended

TaskQuery notSuspended()
only select tasks that are not suspended

page

TaskQuery page(int firstResult,
               int maxResults)
select a specific page in the result set

orderAsc

TaskQuery orderAsc(java.lang.String property)
order selected tasks ascending for certain properties

orderDesc

TaskQuery orderDesc(java.lang.String property)
order selected tasks descending for certain properties

count

long count()
execute a count(*) query and returns number of results

list

java.util.List<Task> list()
execute the query and obtain the list of Tasks

uniqueResult

Task uniqueResult()
execute the query and obtain the unique Task

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


TaskService

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Interface TaskService

public interface TaskService

task management.

Author:
Tom Baeyens, Alejandro Guizar, Heiko Braun

Method Summary
HistoryComment | addReplyComment(java.lang.String commentId, java.lang.String message) add a reply to another comment
HistoryComment | addTaskComment(java.lang.String taskId, java.lang.String message) add a comment to a task
void | addTaskParticipatingGroup(java.lang.String taskId, java.lang.String groupId, java.lang.String participationType) add a role to a given task.
void | addTaskParticipatingUser(java.lang.String taskId, java.lang.String userId, java.lang.String participationType) add a role to a given task.
void | assignTask(java.lang.String taskId, java.lang.String userId) assigns this task to the given assignee.
void | completeTask(java.lang.String taskId) Deletes this task, marks the related history task as completed.
void | completeTask(java.lang.String taskId, java.util.Map<java.lang.String,?> variables) Deletes this task and marks the related history task as completed.
void | completeTask(java.lang.String taskId, java.lang.String outcome) Deletes this task, marks the related history task as completed with the specified outcome.
void | completeTask(java.lang.String taskId, java.lang.String outcome, java.util.Map<java.lang.String,?> variables) Deletes this task, marks the related history task as completed with the specified outcome.
TaskQuery | createTaskQuery() create a new query for tasks
void | deleteComment(java.lang.String commentId) delete a comment.
void | deleteTask(java.lang.String taskId) Deletes the task without completing it.
void | deleteTask(java.lang.String taskId, java.lang.String reason) Deletes the task without completing indicating the reason.
void | deleteTaskCascade(java.lang.String taskId) deletes this task, including all history information
java.util.List<Task> | findGroupTasks(java.lang.String userId) list of tasks that can be taken by the given user.
java.util.List<Task> | findPersonalTasks(java.lang.String userId) list of tasks that are assigned to the given user.
java.util.Set<java.lang.String> | getOutcomes(java.lang.String taskId) the set of possible valid outcomes for this task.
java.util.List<Task> | getSubTasks(java.lang.String taskId) get the subtasks for this task.
Task | getTask(java.lang.String taskId) Retrieves the task with the given identifier from persistent storage.
java.util.List<HistoryComment> | getTaskComments(java.lang.String taskId) get the list of comments made to a task.
java.util.List<Participation> | getTaskParticipations(java.lang.String taskId) get roles related to a given task.
java.lang.Object | getVariable(java.lang.String taskId, java.lang.String variableName) retrieves a variable
java.util.Set<java.lang.String> | getVariableNames(java.lang.String taskId) all the variables visible in the given task
java.util.Map<java.lang.String,java.lang.Object> | getVariables(java.lang.String taskId, java.util.Set<java.lang.String> variableNames) retrieves a map of variables
Task | newTask() Creates a task.
Task | newTask(java.lang.String parentTaskId) Creates a new subtask for the given task.
void | removeTaskParticipatingGroup(java.lang.String taskId, java.lang.String groupId, java.lang.String participationType) removes a role to a given task.
void | removeTaskParticipatingUser(java.lang.String taskId, java.lang.String userId, java.lang.String participationType) removes a role to a given task.
java.lang.String | saveTask(Task task) Saves the given task to persistent storage.
void | setVariables(java.lang.String taskId, java.util.Map<java.lang.String,?> variables) creates or overwrites the variable values on the given task
void | takeTask(java.lang.String taskId, java.lang.String userId) taking this task will prevent all other candidates from taking and working on this task.

Method Detail

newTask

Task newTask()
Creates a task. The returned task will be transient. Use saveTask(Task) to persist the task. Only after the invocation of saveTask(Task), the Task.getId() property will be initialized.

newTask

Task newTask(java.lang.String parentTaskId)
Creates a new subtask for the given task. Make sure that the parent task is saved before the Id is taken. The returned task will be transient. Use saveTask(Task) to persist the task.

saveTask

java.lang.String saveTask(Task task)
Saves the given task to persistent storage.

Returns:
the taskId

getTask

Task getTask(java.lang.String taskId)
Retrieves the task with the given identifier from persistent storage. If no task with the given identifier exists, the call returns null.

assignTask

void assignTask(java.lang.String taskId,
                java.lang.String userId)
assigns this task to the given assignee.

takeTask

void takeTask(java.lang.String taskId,
              java.lang.String userId)
taking this task will prevent all other candidates from taking and working on this task. The inverse operation of putting the task back into the group for someone else to take it, can be done by providing a null value for userId in the assignTask(String, String) method: taskService.assignTask(taskId, null);

Throws:
JbpmException - if this task already has been taken.

completeTask

void completeTask(java.lang.String taskId)
Deletes this task, marks the related history task as completed. If the task was created in the context of a process execution, this operation may result in a process instance being triggered.

completeTask

void completeTask(java.lang.String taskId,
                  java.util.Map<java.lang.String,?> variables)
Deletes this task and marks the related history task as completed. The given variables are created (or they overwrite existing values) as task variables. If the task was created in the context of a process execution, this operation may result in a process instance being triggered to continue.

completeTask

void completeTask(java.lang.String taskId,
                  java.lang.String outcome)
Deletes this task, marks the related history task as completed with the specified outcome. If the task was created in the context of a process execution, this operation may result in a process instance being triggered. The outcome in that case corresponds to an outgoing transition in the process.

completeTask

void completeTask(java.lang.String taskId,
                  java.lang.String outcome,
                  java.util.Map<java.lang.String,?> variables)
Deletes this task, marks the related history task as completed with the specified outcome. The given variables are created (or they overwrite existing values) as task variables. If the task was created in the context of a process execution, this operation may result in a process instance being triggered. The outcome in that case corresponds to an outgoing transition in the process.

deleteTask

void deleteTask(java.lang.String taskId)
Deletes the task without completing it. The history information is kept in the DB. If this task was created in the context of a process execution, the execution remains active and the ExecutionService.signalExecutionById(String) is to be given explicitly.

deleteTaskCascade

void deleteTaskCascade(java.lang.String taskId)
deletes this task, including all history information

deleteTask

void deleteTask(java.lang.String taskId,
                java.lang.String reason)
Deletes the task without completing indicating the reason. Example reasons could be: "failed", "error", "exited", "obsolete" or "deleted". The history information is kept in the DB. The reason ends up as the state in the HistoryActivityInstance. If this task was created in the context of a process execution, the execution remains active and the ExecutionService.signalExecutionById(String) is to be given explicitly.

addTaskParticipatingUser

void addTaskParticipatingUser(java.lang.String taskId,
                              java.lang.String userId,
                              java.lang.String participationType)
add a role to a given task.

Parameters:
participationType - specifies the kind of involvement of the participatingUser in this task. see Participation for default constants.

addTaskParticipatingGroup

void addTaskParticipatingGroup(java.lang.String taskId,
                               java.lang.String groupId,
                               java.lang.String participationType)
add a role to a given task.

Parameters:
participationType - specifies the kind of involvement of the participatingUser in this task. see Participation for default constants.

getTaskParticipations

java.util.List<Participation> getTaskParticipations(java.lang.String taskId)
get roles related to a given task.

removeTaskParticipatingUser

void removeTaskParticipatingUser(java.lang.String taskId,
                                 java.lang.String userId,
                                 java.lang.String participationType)
removes a role to a given task. Nothing happens (no exception) if the role does not exist.

Parameters:
participationType - specifies the kind of involvement of the participatingUser in this task. see Participation for default constants.

removeTaskParticipatingGroup

void removeTaskParticipatingGroup(java.lang.String taskId,
                                  java.lang.String groupId,
                                  java.lang.String participationType)
removes a role to a given task. Nothing happens (no exception) if the role does not exist.

Parameters:
participationType - specifies the kind of involvement of the participatingUser in this task. see Participation for default constants.

createTaskQuery

TaskQuery createTaskQuery()
create a new query for tasks

findPersonalTasks

java.util.List<Task> findPersonalTasks(java.lang.String userId)
list of tasks that are assigned to the given user. Returns an empty list in case no such tasks exist.

findGroupTasks

java.util.List<Task> findGroupTasks(java.lang.String userId)
list of tasks that can be taken by the given user. Returns an empty list in case no such tasks exist.

getSubTasks

java.util.List<Task> getSubTasks(java.lang.String taskId)
get the subtasks for this task. Only goes one level deep at a time.

addTaskComment

HistoryComment addTaskComment(java.lang.String taskId,
                              java.lang.String message)
add a comment to a task

getTaskComments

java.util.List<HistoryComment> getTaskComments(java.lang.String taskId)
get the list of comments made to a task. this will fetch all the comments and recursively all replies to those comments.

addReplyComment

HistoryComment addReplyComment(java.lang.String commentId,
                               java.lang.String message)
add a reply to another comment

deleteComment

void deleteComment(java.lang.String commentId)
delete a comment. this will recursively delete all replies to this comment.

setVariables

void setVariables(java.lang.String taskId,
                  java.util.Map<java.lang.String,?> variables)
creates or overwrites the variable values on the given task

getVariable

java.lang.Object getVariable(java.lang.String taskId,
                             java.lang.String variableName)
retrieves a variable

getVariableNames

java.util.Set<java.lang.String> getVariableNames(java.lang.String taskId)
all the variables visible in the given task

getVariables

java.util.Map<java.lang.String,java.lang.Object> getVariables(java.lang.String taskId,
                                                              java.util.Set<java.lang.String> variableNames)
retrieves a map of variables

getOutcomes

java.util.Set<java.lang.String> getOutcomes(java.lang.String taskId)
the set of possible valid outcomes for this task. An empty set means that any value is possible.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Configuration

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Class Configuration

java.lang.Object
    extended by  org.jbpm.api.Configuration

public class Configuration
extends java.lang.Object

process engine configuration.

Author:
Tom Baeyens

Constructor Summary
 | Configuration() default constructor
protected | Configuration(java.lang.Object o)
Method Summary
ProcessEngine | buildProcessEngine() after specifying the configuration resources with the other methods, a process engine can be created.
protected java.lang.ClassLoader | getClassLoader()
static ProcessEngine | getProcessEngine() get the singleton ProcessEngine that is created from the default configuration file 'jbpm.cfg.xml'.
protected Configuration | instantiate(java.lang.String className)
Configuration | setFile(java.io.File file) provide a File as the configuration file
Configuration | setHibernateSessionFactory(java.lang.Object hibernateSessionFactory) provides the hibernate session factory programmatically.
Configuration | setInputSource(org.xml.sax.InputSource inputSource) provide a sax input source as the configuration resource
Configuration | setInputStream(java.io.InputStream inputStream) provide an input stream as the configuration resource
Configuration | setResource(java.lang.String resource) provide an classpath resource as the configuration file
Configuration | setUrl(java.net.URL url) point with a url to the configuration file
Configuration | setXmlString(java.lang.String xmlString) provide an xml string as the configuration resource
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

Configuration

public Configuration()
default constructor

Configuration

protected Configuration(java.lang.Object o)
Method Detail

instantiate

protected Configuration instantiate(java.lang.String className)

getClassLoader

protected java.lang.ClassLoader getClassLoader()

setXmlString

public Configuration setXmlString(java.lang.String xmlString)
provide an xml string as the configuration resource

setResource

public Configuration setResource(java.lang.String resource)
provide an classpath resource as the configuration file

setInputStream

public Configuration setInputStream(java.io.InputStream inputStream)
provide an input stream as the configuration resource

setInputSource

public Configuration setInputSource(org.xml.sax.InputSource inputSource)
provide a sax input source as the configuration resource

setUrl

public Configuration setUrl(java.net.URL url)
point with a url to the configuration file

setFile

public Configuration setFile(java.io.File file)
provide a File as the configuration file

buildProcessEngine

public ProcessEngine buildProcessEngine()
after specifying the configuration resources with the other methods, a process engine can be created.

setHibernateSessionFactory

public Configuration setHibernateSessionFactory(java.lang.Object hibernateSessionFactory)
provides the hibernate session factory programmatically. The hibernateSessionFactory parameter is of type Object to prevent a dependency of the API on hibernate directly.

getProcessEngine

public static ProcessEngine getProcessEngine()
get the singleton ProcessEngine that is created from the default configuration file 'jbpm.cfg.xml'.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


JbpmException

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api
Class JbpmException

java.lang.Object
    extended by  java.lang.Throwable
        extended by  java.lang.Exception
            extended by  java.lang.RuntimeException
                extended by  org.jbpm.api.JbpmException
All Implemented Interfaces:
java.io.Serializable
public class JbpmException
extends java.lang.RuntimeException

all exceptions that jBPM throws are JbpmException's (extends RuntimeException).

See Also:
Serialized Form

Constructor Summary
JbpmException()
JbpmException(java.lang.String msg)
JbpmException(java.lang.String msg, java.lang.Throwable cause)
JbpmException(java.lang.Throwable cause)
Method Summary
Methods inherited from class java.lang.Throwable
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

Constructor Detail

JbpmException

public JbpmException()

JbpmException

public JbpmException(java.lang.String msg,
                     java.lang.Throwable cause)

JbpmException

public JbpmException(java.lang.String msg)

JbpmException

public JbpmException(java.lang.Throwable cause)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.activity

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.activity

interfaces for implementing customized runtime behaviour of activities.

See:
Description

Interface Summary
ActivityBehaviour | implements the runtime behaviour of an activity.
ActivityExecution | view upon an Execution exposed to ActivityBehaviour implementations.
ExternalActivityBehaviour | extends ActivityBehaviour for handling external triggers after a wait state.

Package org.jbpm.api.activity Description

interfaces for implementing customized runtime behaviour of activities.

Overview Package Class Use Tree Deprecated Index Help


ActivityBehaviour

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.activity
Interface ActivityBehaviour

All Superinterfaces:
java.io.Serializable
All Known Subinterfaces:
ExternalActivityBehaviour
public interface ActivityBehaviour
extends java.io.Serializable

implements the runtime behaviour of an activity.

Author:
Tom Baeyens

Method Summary
 void execute(ActivityExecution execution)
invoked when an execution arrives in an activity.

Method Detail

execute

void execute(ActivityExecution execution)
             throws java.lang.Exception
invoked when an execution arrives in an activity.

An ActivityBehaviour can control the propagation of execution. ActivityBehaviour's can become external activities when they invoke ActivityExecution.waitForSignal(). That means the activity will become a wait state. In that case, ExternalActivityBehaviour should be implemented to also handle the external signals.

Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActivityExecution

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.activity
Interface ActivityExecution

All Superinterfaces:
Execution, OpenExecution, java.io.Serializable
public interface ActivityExecution
extends OpenExecution

view upon an Execution exposed to ActivityBehaviour implementations.

Author:
Tom Baeyens

Field Summary
Fields inherited from interface org.jbpm.api.Execution
STATE_ACTIVE_CONCURRENT, STATE_ACTIVE_ROOT, STATE_ASYNC, STATE_CREATED, STATE_ENDED, STATE_INACTIVE_CONCURRENT_ROOT, STATE_INACTIVE_JOIN, STATE_INACTIVE_SCOPE, STATE_SUSPENDED
Method Summary
void | end() ends this execution and all of its child executions.
void | end(java.lang.String state) ends this execution and all it's child executions with a user defined status.
void | execute(java.lang.String activityName) executes the given nested activity.
java.lang.String | getActivityName() represents the current position in the process by indicating the name of the current activity.
void | setPriority(int priority) setter for the priority.
void | take(java.lang.String transitionName) takes the outgoing transition with the given name.
void | takeDefaultTransition() takes the default transition.
void | waitForSignal() makes this execution wait in the current activity until an external trigger is given with one of the signal methods.
Methods inherited from interface org.jbpm.api.model.OpenExecution
createVariable, findActiveExecutionIn, getActivity, getExecution, getParent, getProcessInstance, getSubProcessInstance, getVariable, getVariableKeys, getVariables, hasVariable, hasVariables, removeVariable, removeVariables, setState, setVariable, setVariables
Methods inherited from interface org.jbpm.api.Execution
findActiveActivityNames, getExecutions, getExecutionsMap, getId, getIsProcessInstance, getKey, getName, getPriority, getProcessDefinitionId, getState, hasExecution, isActive, isEnded, isSuspended

Method Detail

getActivityName

java.lang.String getActivityName()
represents the current position in the process by indicating the name of the current activity.

waitForSignal

void waitForSignal()
makes this execution wait in the current activity until an external trigger is given with one of the signal methods.

takeDefaultTransition

void takeDefaultTransition()
takes the default transition.

This method can only be called from inside ExternalActivityBehaviour implementations.

Throws:
JbpmException - in case there is no default transition in the current activity or in case this method is called from inside an ActivityBehaviour

take

void take(java.lang.String transitionName)
takes the outgoing transition with the given name.

This method can only be called from inside ExternalActivityBehaviour implementations.

Transitions will be looked up recursively starting from the current activity and then up the activity-parent-hierarchy

Parameters:
transitionName - is the name of the transition to take. A null value will match the first unnamed transition.
Throws:
JbpmException - in case no such transition is found in the current activity or in case this method is called from inside an ActivityBehaviour.

execute

void execute(java.lang.String activityName)
executes the given nested activity.

The activityName is looked up in the current activity's nested activities.

This method can only be called from inside ExternalActivityBehaviour implementations.

end

void end()
ends this execution and all of its child executions.

The execution will be removed from it's parent. Potentially this can cause a parent execution to start executing in case this is the last concurrent execution for which the parent is waiting.

end

void end(java.lang.String state)
ends this execution and all it's child executions with a user defined status.

It is not recommended to use any of the defined statuses in Execution as that may case unpredictable side effects.

The execution will be removed from it's parent.

setPriority

void setPriority(int priority)
setter for the priority. The default priority is 0, which means NORMAL. Other recognized named priorities are HIGHEST (2), HIGH (1), LOW (-1) and LOWEST (-2). For the rest, the user can set any other priority integer value, but then, the UI will have to display it as an integer and not the named value.

Specified by:
setPriority in interface OpenExecution
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ExternalActivityBehaviour

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.activity
Interface ExternalActivityBehaviour

All Superinterfaces:
ActivityBehaviour, java.io.Serializable
public interface ExternalActivityBehaviour
extends ActivityBehaviour

extends ActivityBehaviour for handling external triggers after a wait state.

Author:
Tom Baeyens

Method Summary
 void signal(ActivityExecution execution, java.lang.String signalName, java.util.Map<java.lang.String,?> parameters)
handles an external signal.
Methods inherited from interface org.jbpm.api.activity.ActivityBehaviour
execute

Method Detail

signal

void signal(ActivityExecution execution,
            java.lang.String signalName,
            java.util.Map<java.lang.String,?> parameters)
            throws java.lang.Exception
handles an external signal.

An external signal that comes into an execution through one of the ExecutionService.signalExecutionById(String) methods. It will be delegated to the activity in which the execution is positioned when it receives the external trigger.

The signal method implements how the activity will react on that signal. For example, the outgoing transition could be taken that corresponds with the given signal.

Parameters:
execution - the Execution for which the signal is given
signalName - is an abstract text that can be associated with a signal. this corresponds to e.g. a method name in a java class interface. The implementation can decide e.g. to use the signal to identify the outgoing transition.
parameters - is extra information that can be provided with a signal. In this way, it is somewhat similar to the parameters that can be fed into a method invocation through reflection.
Throws:
java.lang.Exception - to indicate any kind of failure. Note that exceptions are considered non recoverable. After an Exception, the execution should not be used any more and if this is during a transaction, the transaction should be rolled back.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.cmd

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.cmd

Interface Summary
Command<T> | commands that can be executed by the process engine.
Environment | exposes configured process engine scope objects and transaction scope objects to command implementations.

Class Summary
ParamCommand<T> | command with support for parameter passing from the client to the implementation.
VoidCommand | convenience for commands without return value.


Command

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.cmd
Interface Command<T>

All Superinterfaces:
java.io.Serializable
All Known Implementing Classes:
ParamCommand, VoidCommand
public interface Command<T>
extends java.io.Serializable

commands that can be executed by the process engine.

Author:
Tom Baeyens

Method Summary
 T execute(Environment environment)

Method Detail

execute

T execute(Environment environment)
          throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Environment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.cmd
Interface Environment

public interface Environment

exposes configured process engine scope objects and transaction scope objects to command implementations.

Author:
Tom Baeyens

Method Summary
<T> T
get(java.lang.Class<T> type)
searches an object based on type.
 java.lang.Object get(java.lang.String name)
searches a named object in all the contexts in the default search order.

Method Detail

get

java.lang.Object get(java.lang.String name)
searches a named object in all the contexts in the default search order.

Returns:
the object if it exists in the environment, null if there is no object with the given name in the environment.

get

<T> T get(java.lang.Class<T> type)
searches an object based on type. The search doesn take superclasses of the context elements into account.

Returns:
the first object of the given type or null in case no such element was found.
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


ParamCommand

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.cmd
Class ParamCommand<T>

java.lang.Object
    extended by  org.jbpm.api.cmd.ParamCommand<T>
All Implemented Interfaces:
java.io.Serializable, Command<T>
public abstract class ParamCommand<T>
extends java.lang.Object
implements Command<T>

command with support for parameter passing from the client to the implementation.

Author:
Tom Baeyens
See Also:
Serialized Form

Field Summary
protected  java.util.Map<java.lang.String,java.lang.Object> params
Constructor Summary
ParamCommand()
Method Summary
 ParamCommand<T> setParam(java.lang.String name, java.lang.Object value)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
Methods inherited from interface org.jbpm.api.cmd.Command
execute

Field Detail

params

protected java.util.Map<java.lang.String,java.lang.Object> params
Constructor Detail

ParamCommand

public ParamCommand()
Method Detail

setParam

public ParamCommand<T> setParam(java.lang.String name,
                                java.lang.Object value)
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


VoidCommand

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.cmd
Class VoidCommand

java.lang.Object
    extended by  org.jbpm.api.cmd.VoidCommand
All Implemented Interfaces:
java.io.Serializable, Command<java.lang.Void>
public abstract class VoidCommand
extends java.lang.Object
implements Command<java.lang.Void>

convenience for commands without return value.

Author:
Tom Baeyens
See Also:
Serialized Form

Constructor Summary
VoidCommand()
Method Summary
java.lang.Void | execute(Environment environment)
protected abstract void | executeVoid(Environment environment)
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

VoidCommand

public VoidCommand()
Method Detail

execute

public java.lang.Void execute(Environment environment)
                       throws java.lang.Exception
Specified by:
execute in interface Command<java.lang.Void>
Throws:
java.lang.Exception

executeVoid

protected abstract void executeVoid(Environment environment)
                             throws java.lang.Exception
Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.history

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.history

interfaces related to the HistoryService.

See:
Description

Interface Summary
HistoryActivityInstance | represents one occurrence of an activity during a process instance.
HistoryActivityInstanceQuery | query for activity occurrences.
HistoryComment | a free text comment that can be made to an Execution or a task.
HistoryDetail | base type for all history details.
HistoryDetailQuery | query for task comments, task assignments and so on.
HistoryProcessInstance | one particular instance of a process definition.
HistoryProcessInstanceQuery | query for ongoing and finished process instances.
HistoryTask | history record for a task instance.
HistoryTaskQuery | query for history tasks.

Package org.jbpm.api.history Description

interfaces related to the HistoryService.


HistoryActivityInstance

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryActivityInstance

public interface HistoryActivityInstance

represents one occurrence of an activity during a process instance.

Author:
Tom Baeyens

Method Summary
java.lang.String | getActivityName() name of the activity that was executed
long | getDuration() duration in milleseconds
java.util.Date | getEndTime() might be null in case the activity is still active
java.lang.String | getExecutionId() the execution that was related to this activity occurrence
java.util.Date | getStartTime() time when the activity was entered
java.util.List<java.lang.String> | getTransitionNames() The names of the transitions that were selected as outgoing transitions for the execution.

Method Detail

getActivityName

java.lang.String getActivityName()
name of the activity that was executed

getStartTime

java.util.Date getStartTime()
time when the activity was entered

getEndTime

java.util.Date getEndTime()
might be null in case the activity is still active

getDuration

long getDuration()
duration in milleseconds

getExecutionId

java.lang.String getExecutionId()
the execution that was related to this activity occurrence

getTransitionNames

java.util.List<java.lang.String> getTransitionNames()
The names of the transitions that were selected as outgoing transitions for the execution.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


HistoryActivityInstanceQuery

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryActivityInstanceQuery

public interface HistoryActivityInstanceQuery

query for activity occurrences.

Author:
Tom Baeyens

Field Summary
static java.lang.String | PROPERTY_ACTIVITYNAME activityName property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_DURATION duration property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_ENDTIME endtime property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_EXECUTIONID executionId property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_STARTTIME starttime property to be used as property in orderAsc(String) and orderDesc(String)
Method Summary
HistoryActivityInstanceQuery | activityName(java.lang.String activityName) only select activity instances for the given activity (this usually used in combination with processDefinitionId(String))
long | count() execute a count(*) query and returns number of results
HistoryActivityInstanceQuery | executionId(java.lang.String executionId) only select activity instances for the given execution
java.util.List<HistoryActivityInstance> | list() execute the query and obtain the list of HistoryActivityInstances
HistoryActivityInstanceQuery | orderAsc(java.lang.String property) order selected activity instances ascending for certain properties
HistoryActivityInstanceQuery | orderDesc(java.lang.String property) order selected process definitions descending for certain properties
HistoryActivityInstanceQuery | page(int firstResult, int maxResults) select a specific page in the result set
HistoryActivityInstanceQuery | processDefinitionId(java.lang.String processDefinitionId) only select activity instances for the given process definition
HistoryActivityInstanceQuery | processInstanceId(java.lang.String processInstanceId) only select activity instances for the given process instance id
HistoryActivityInstanceQuery | startedAfter(java.util.Date time) only select activity instances started after the given time
HistoryActivityInstanceQuery | startedBefore(java.util.Date time) only select activity instances started before the given time
HistoryActivityInstanceQuery | tookLessThen(long durationInMillis) only select activity instances that took less then the given duration in milliseconds
HistoryActivityInstanceQuery | tookLongerThen(long durationInMillis) only select activity instances that took longer then the given duration in milliseconds
HistoryActivityInstance | uniqueResult() execute the query and obtain the unique HistoryActivityInstance

Field Detail

PROPERTY_STARTTIME

static final java.lang.String PROPERTY_STARTTIME
starttime property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_ENDTIME

static final java.lang.String PROPERTY_ENDTIME
endtime property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_EXECUTIONID

static final java.lang.String PROPERTY_EXECUTIONID
executionId property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_ACTIVITYNAME

static final java.lang.String PROPERTY_ACTIVITYNAME
activityName property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_DURATION

static final java.lang.String PROPERTY_DURATION
duration property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values
Method Detail

processDefinitionId

HistoryActivityInstanceQuery processDefinitionId(java.lang.String processDefinitionId)
only select activity instances for the given process definition

executionId

HistoryActivityInstanceQuery executionId(java.lang.String executionId)
only select activity instances for the given execution

processInstanceId

HistoryActivityInstanceQuery processInstanceId(java.lang.String processInstanceId)
only select activity instances for the given process instance id

startedAfter

HistoryActivityInstanceQuery startedAfter(java.util.Date time)
only select activity instances started after the given time

startedBefore

HistoryActivityInstanceQuery startedBefore(java.util.Date time)
only select activity instances started before the given time

activityName

HistoryActivityInstanceQuery activityName(java.lang.String activityName)
only select activity instances for the given activity (this usually used in combination with processDefinitionId(String))

tookLongerThen

HistoryActivityInstanceQuery tookLongerThen(long durationInMillis)
only select activity instances that took longer then the given duration in milliseconds

tookLessThen

HistoryActivityInstanceQuery tookLessThen(long durationInMillis)
only select activity instances that took less then the given duration in milliseconds

orderAsc

HistoryActivityInstanceQuery orderAsc(java.lang.String property)
order selected activity instances ascending for certain properties

orderDesc

HistoryActivityInstanceQuery orderDesc(java.lang.String property)
order selected process definitions descending for certain properties

page

HistoryActivityInstanceQuery page(int firstResult,
                                  int maxResults)
select a specific page in the result set

list

java.util.List<HistoryActivityInstance> list()
execute the query and obtain the list of HistoryActivityInstances

uniqueResult

HistoryActivityInstance uniqueResult()
execute the query and obtain the unique HistoryActivityInstance

count

long count()
execute a count(*) query and returns number of results

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoryComment

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryComment

All Superinterfaces:
HistoryDetail, java.io.Serializable
public interface HistoryComment
extends HistoryDetail

a free text comment that can be made to an Execution or a task. This class also supports threaded discussions with the getReplies().

Author:
Tom Baeyens

Method Summary
java.lang.String | getMessage() the actual message.
java.util.List<? extends HistoryComment> | getReplies() threaded replies to this comment
Methods inherited from interface org.jbpm.api.history.HistoryDetail
getId, getTime, getUserId

Method Detail

getMessage

java.lang.String getMessage()
the actual message. Both plain text as well as HTML can be stored as the message.

getReplies

java.util.List<? extends HistoryComment> getReplies()
threaded replies to this comment

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoryDetail

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryDetail

All Superinterfaces:
java.io.Serializable
All Known Subinterfaces:
HistoryComment
public interface HistoryDetail
extends java.io.Serializable

base type for all history details.

Author:
Tom Baeyens

Method Summary
java.lang.String | getId() the unique id for this comment that is used as a reference in the service methods
java.util.Date | getTime() time that specifies when the comment was made
java.lang.String | getUserId() the id of the user that made this comment.

Method Detail

getId

java.lang.String getId()
the unique id for this comment that is used as a reference in the service methods

getUserId

java.lang.String getUserId()
the id of the user that made this comment. The term actorId is an abstract reference to an entity in an external identity component.

getTime

java.util.Date getTime()
time that specifies when the comment was made

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoryDetailQuery

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryDetailQuery

public interface HistoryDetailQuery

query for task comments, task assignments and so on.

Author:
Tom Baeyens

Field Summary
static java.lang.String | PROPERTY_TIME time property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_USERID userId property to be used as property in orderAsc(String) and orderDesc(String)
Method Summary
HistoryDetailQuery | activityInstanceId(java.lang.String activityInstanceId) only select details for the given activityInstanceId
HistoryDetailQuery | comments() only select details of type comment (this usually used in combination with #processDefinitionId(String))
long | count() execute a count(*) query and returns number of results
java.util.List<HistoryDetail> | list() execute the query and obtain the list of HistoryDetails
HistoryDetailQuery | orderAsc(java.lang.String property) order selected process definitions ascending
HistoryDetailQuery | orderDesc(java.lang.String property) order selected process definitions descending
HistoryDetailQuery | page(int firstResult, int maxResults) select a specific page in the result set
HistoryDetailQuery | processInstanceId(java.lang.String processInstanceId) only select details for the given processInstanceId
HistoryDetailQuery | taskId(java.lang.String taskId) only select details for the given taskId
HistoryDetailQuery | timeAfter(java.util.Date time) only select details after the given time
HistoryDetailQuery | timeBefore(java.util.Date time) only select details before the given time
HistoryDetail | uniqueResult() execute the query and obtain the unique HistoryDetail

Field Detail

PROPERTY_USERID

static final java.lang.String PROPERTY_USERID
userId property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_TIME

static final java.lang.String PROPERTY_TIME
time property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values
Method Detail

processInstanceId

HistoryDetailQuery processInstanceId(java.lang.String processInstanceId)
only select details for the given processInstanceId

activityInstanceId

HistoryDetailQuery activityInstanceId(java.lang.String activityInstanceId)
only select details for the given activityInstanceId

taskId

HistoryDetailQuery taskId(java.lang.String taskId)
only select details for the given taskId

timeAfter

HistoryDetailQuery timeAfter(java.util.Date time)
only select details after the given time

timeBefore

HistoryDetailQuery timeBefore(java.util.Date time)
only select details before the given time

comments

HistoryDetailQuery comments()
only select details of type comment (this usually used in combination with #processDefinitionId(String))

orderAsc

HistoryDetailQuery orderAsc(java.lang.String property)
order selected process definitions ascending

orderDesc

HistoryDetailQuery orderDesc(java.lang.String property)
order selected process definitions descending

page

HistoryDetailQuery page(int firstResult,
                        int maxResults)
select a specific page in the result set

list

java.util.List<HistoryDetail> list()
execute the query and obtain the list of HistoryDetails

uniqueResult

HistoryDetail uniqueResult()
execute the query and obtain the unique HistoryDetail

count

long count()
execute a count(*) query and returns number of results

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoryProcessInstance

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryProcessInstance

public interface HistoryProcessInstance

one particular instance of a process definition. Every ProcessInstance will have one HistoryProcessInstance associated. The difference is that the ProcessInstance will be deleted when it is ended, whereas the history information will remain in the DB. That keeps the runtime DB healthy and performing well.

Author:
Tom Baeyens

Field Summary
static java.lang.String | STATE_ACTIVE when the full process instance is still active
static java.lang.String | STATE_ENDED when the full process instance has come to an end
Method Summary
 java.lang.Long getDuration()
duration of the process instance in milliseconds or null if the process instance has not yet ended
 java.lang.String getEndActivityName()
Returns the name of the end state that was reached when the process was ended.
 java.util.Date getEndTime()
when the process instance ended (only not null if the process instance already ended)
 java.lang.String getKey()
unique user provided business key (could be null if no such key is provided in ExecutionService.startProcessInstanceById(String, java.util.Map, String))
 java.lang.String getProcessDefinitionId()
reference to the process definition
 java.lang.String getProcessInstanceId()
the process instance id (== the root execution id)
 java.util.Date getStartTime()
when the process instance started
 java.lang.String getState()
STATE_ACTIVE or STATE_ENDED (this more coarse grained state then Execution.getState())

Field Detail

STATE_ENDED

static final java.lang.String STATE_ENDED
when the full process instance has come to an end

See Also:
Constant Field Values

STATE_ACTIVE

static final java.lang.String STATE_ACTIVE
when the full process instance is still active

See Also:
Constant Field Values
Method Detail

getProcessInstanceId

java.lang.String getProcessInstanceId()
the process instance id (== the root execution id)

getProcessDefinitionId

java.lang.String getProcessDefinitionId()
reference to the process definition

getKey

java.lang.String getKey()
unique user provided business key (could be null if no such key is provided in ExecutionService.startProcessInstanceById(String, java.util.Map, String))

getState

java.lang.String getState()
STATE_ACTIVE or STATE_ENDED (this more coarse grained state then Execution.getState())

getStartTime

java.util.Date getStartTime()
when the process instance started

getEndTime

java.util.Date getEndTime()
when the process instance ended (only not null if the process instance already ended)

getDuration

java.lang.Long getDuration()
duration of the process instance in milliseconds or null if the process instance has not yet ended

getEndActivityName

java.lang.String getEndActivityName()
Returns the name of the end state that was reached when the process was ended.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoryProcessInstanceQuery

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryProcessInstanceQuery

public interface HistoryProcessInstanceQuery

query for ongoing and finished process instances.

Author:
Tom Baeyens

Field Summary
static java.lang.String | PROPERTY_DURATION duration property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_ENDTIME endtime property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_ID id property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_KEY Key propertu to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_STARTTIME starttime property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_STATE state property to be used as property in orderAsc(String) and orderDesc(String)
Method Summary
long | count() execute a count(*) query and returns number of results
HistoryProcessInstanceQuery | ended() select only process instances that have ended.
HistoryProcessInstanceQuery | endedAfter(java.util.Date threshold) select only process instances that have ended on or after the given date.
HistoryProcessInstanceQuery | endedBefore(java.util.Date threshold) select only process instances that have ended before the given date.
java.util.List<HistoryProcessInstance> | list() execute the query and obtain the list of HistoryProcessInstances
HistoryProcessInstanceQuery | orderAsc(java.lang.String property) order selected process instances ascending for certain properties
HistoryProcessInstanceQuery | orderDesc(java.lang.String property) order selected process instances ascending for certain properties
HistoryProcessInstanceQuery | page(int firstResult, int maxResults) select a specific page in the result set
HistoryProcessInstanceQuery | processDefinitionId(java.lang.String processDefinitionId) select only process instances with the given process definition
HistoryProcessInstanceQuery | processInstanceId(java.lang.String processInstanceId) select only the process instances with the given id
HistoryProcessInstanceQuery | processInstanceKey(java.lang.String processInstanceKey) select only process instances with the given business key
HistoryProcessInstanceQuery | state(java.lang.String state) select only process instances in the given state
HistoryProcessInstance | uniqueResult() execute the query and obtain the unique HistoryProcessInstance

Field Detail

PROPERTY_STARTTIME

static final java.lang.String PROPERTY_STARTTIME
starttime property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_ENDTIME

static final java.lang.String PROPERTY_ENDTIME
endtime property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_ID

static final java.lang.String PROPERTY_ID
id property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_STATE

static final java.lang.String PROPERTY_STATE
state property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_DURATION

static final java.lang.String PROPERTY_DURATION
duration property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_KEY

static final java.lang.String PROPERTY_KEY
Key propertu to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values
Method Detail

processInstanceId

HistoryProcessInstanceQuery processInstanceId(java.lang.String processInstanceId)
select only the process instances with the given id

processDefinitionId

HistoryProcessInstanceQuery processDefinitionId(java.lang.String processDefinitionId)
select only process instances with the given process definition

processInstanceKey

HistoryProcessInstanceQuery processInstanceKey(java.lang.String processInstanceKey)
select only process instances with the given business key

state

HistoryProcessInstanceQuery state(java.lang.String state)
select only process instances in the given state

orderAsc

HistoryProcessInstanceQuery orderAsc(java.lang.String property)
order selected process instances ascending for certain properties

orderDesc

HistoryProcessInstanceQuery orderDesc(java.lang.String property)
order selected process instances ascending for certain properties

page

HistoryProcessInstanceQuery page(int firstResult,
                                 int maxResults)
select a specific page in the result set

ended

HistoryProcessInstanceQuery ended()
select only process instances that have ended. cancels bounds previously set by endedBefore(Date) or endedAfter(Date)

endedBefore

HistoryProcessInstanceQuery endedBefore(java.util.Date threshold)
select only process instances that have ended before the given date. combine with endedAfter(Date) to specify a finite interval

Throws:
java.lang.IllegalArgumentException - if the given threshold is later than the end-after date (if set), thus yielding an empty interval

endedAfter

HistoryProcessInstanceQuery endedAfter(java.util.Date threshold)
select only process instances that have ended on or after the given date. combine with endedBefore(Date) to specify a finite interval

Throws:
java.lang.IllegalArgumentException - if the given threshold is earlier than the end-before date (if set), thus yielding an empty interval

list

java.util.List<HistoryProcessInstance> list()
execute the query and obtain the list of HistoryProcessInstances

uniqueResult

HistoryProcessInstance uniqueResult()
execute the query and obtain the unique HistoryProcessInstance

count

long count()
execute a count(*) query and returns number of results

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoryTask

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryTask

public interface HistoryTask

history record for a task instance. In contrast to the Task, this entity will remain after the task has been completed for history purposes.

Author:
Tom Baeyens

Field Summary
static java.lang.String | STATE_COMPLETED
static java.lang.String | STATE_OBSOLETE
Method Summary
java.lang.String | getAssignee() userId of the person that is responsible for this task
java.util.Date | getCreateTime() time when the activity was entered
long | getDuration() duration in milliseconds
java.util.Date | getEndTime() might be null in case the activity is still active
java.lang.String | getExecutionId() the execution that was related to this activity occurrence
java.lang.String | getId() the unique id for this task that is used as a reference in the service methods
java.lang.String | getOutcome() the outcome of this task
java.lang.String | getState() history task state

Field Detail

STATE_COMPLETED

static final java.lang.String STATE_COMPLETED
See Also:
Constant Field Values

STATE_OBSOLETE

static final java.lang.String STATE_OBSOLETE
See Also:
Constant Field Values
Method Detail

getId

java.lang.String getId()
the unique id for this task that is used as a reference in the service methods

getExecutionId

java.lang.String getExecutionId()
the execution that was related to this activity occurrence

getCreateTime

java.util.Date getCreateTime()
time when the activity was entered

getEndTime

java.util.Date getEndTime()
might be null in case the activity is still active

getDuration

long getDuration()
duration in milliseconds

getState

java.lang.String getState()
history task state

getAssignee

java.lang.String getAssignee()
userId of the person that is responsible for this task

getOutcome

java.lang.String getOutcome()
the outcome of this task

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


HistoryTaskQuery

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.history
Interface HistoryTaskQuery

public interface HistoryTaskQuery

query for history tasks.

Author:
Tom Baeyens

Field Summary
static java.lang.String | PROPERTY_ASSIGNEE outcome property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_CREATETIME starttime property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_DURATION duration property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_ENDTIME endtime property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_EXECUTIONID executionId property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_ID id property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_OUTCOME outcome property to be used as property in orderAsc(String) and orderDesc(String)
static java.lang.String | PROPERTY_STATE state property to be used as property in orderAsc(String) and orderDesc(String)
Method Summary
HistoryTaskQuery | assignee(java.lang.String assignee) only select history tasks for the given assignee
long | count() execute a count(*) query and returns number of results
HistoryTaskQuery | executionId(java.lang.String executionId) only select history tasks within the given execution
java.util.List<HistoryTask> | list() execute the query and obtain the list of HistoryTasks
HistoryTaskQuery | orderAsc(java.lang.String property) order selected history tasks ascending for certain properties
HistoryTaskQuery | orderDesc(java.lang.String property) order selected process definitions descending for certain properties
HistoryTaskQuery | outcome(java.lang.String outcome) only select history tasks that have the given outcome
HistoryTaskQuery | page(int firstResult, int maxResults) select a specific page in the result set
HistoryTaskQuery | startedAfter(java.util.Date time) only select history tasks started after the given time
HistoryTaskQuery | startedBefore(java.util.Date time) only select history tasks started before the given time
HistoryTaskQuery | state(java.lang.String state) only select history tasks in the given state
HistoryTaskQuery | taskId(java.lang.String taskId) only select the history task for the given id
HistoryTaskQuery | tookLessThen(long durationInMillis) only select history tasks that took less then the given duration in milliseconds
HistoryTaskQuery | tookLongerThen(long durationInMillis) only select history tasks that took longer then the given duration in milliseconds
HistoryTask | uniqueResult() execute the query and obtain the unique HistoryTask

Field Detail

PROPERTY_ID

static final java.lang.String PROPERTY_ID
id property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_CREATETIME

static final java.lang.String PROPERTY_CREATETIME
starttime property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_ENDTIME

static final java.lang.String PROPERTY_ENDTIME
endtime property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_EXECUTIONID

static final java.lang.String PROPERTY_EXECUTIONID
executionId property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_OUTCOME

static final java.lang.String PROPERTY_OUTCOME
outcome property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_ASSIGNEE

static final java.lang.String PROPERTY_ASSIGNEE
outcome property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_STATE

static final java.lang.String PROPERTY_STATE
state property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values

PROPERTY_DURATION

static final java.lang.String PROPERTY_DURATION
duration property to be used as property in orderAsc(String) and orderDesc(String)

See Also:
Constant Field Values
Method Detail

taskId

HistoryTaskQuery taskId(java.lang.String taskId)
only select the history task for the given id

executionId

HistoryTaskQuery executionId(java.lang.String executionId)
only select history tasks within the given execution

assignee

HistoryTaskQuery assignee(java.lang.String assignee)
only select history tasks for the given assignee

state

HistoryTaskQuery state(java.lang.String state)
only select history tasks in the given state

outcome

HistoryTaskQuery outcome(java.lang.String outcome)
only select history tasks that have the given outcome

orderAsc

HistoryTaskQuery orderAsc(java.lang.String property)
order selected history tasks ascending for certain properties

orderDesc

HistoryTaskQuery orderDesc(java.lang.String property)
order selected process definitions descending for certain properties

page

HistoryTaskQuery page(int firstResult,
                      int maxResults)
select a specific page in the result set

startedAfter

HistoryTaskQuery startedAfter(java.util.Date time)
only select history tasks started after the given time

startedBefore

HistoryTaskQuery startedBefore(java.util.Date time)
only select history tasks started before the given time

tookLessThen

HistoryTaskQuery tookLessThen(long durationInMillis)
only select history tasks that took less then the given duration in milliseconds

tookLongerThen

HistoryTaskQuery tookLongerThen(long durationInMillis)
only select history tasks that took longer then the given duration in milliseconds

list

java.util.List<HistoryTask> list()
execute the query and obtain the list of HistoryTasks

uniqueResult

HistoryTask uniqueResult()
execute the query and obtain the unique HistoryTask

count

long count()
execute a count(*) query and returns number of results

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.identity

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.identity

User and Group interfaces related to the IdentityService

See:
Description

Interface Summary
Group | a group of users.
User | a user.

Package org.jbpm.api.identity Description

User and Group interfaces related to the IdentityService


Group

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.identity
Interface Group

public interface Group

a group of users.

Author:
Tom Baeyens

Method Summary
java.lang.String | getId() unique id for the group that is used as a reference in the service methods
java.lang.String | getName() name for the group (should be unique within one group type)
java.lang.String | getType() type or category of the group

Method Detail

getId

java.lang.String getId()
unique id for the group that is used as a reference in the service methods

getName

java.lang.String getName()
name for the group (should be unique within one group type)

getType

java.lang.String getType()
type or category of the group

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


User

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.identity
Interface User

public interface User

a user.

Author:
Tom Baeyens

Method Summary
java.lang.String | getBusinessEmail() the email address for the user
java.lang.String | getFamilyName() given name (aka last name)
java.lang.String | getGivenName() given name (aka first name)
java.lang.String | getId() unique id for the user that is used as a reference in the service methods

Method Detail

getId

java.lang.String getId()
unique id for the user that is used as a reference in the service methods

getGivenName

java.lang.String getGivenName()
given name (aka first name)

getFamilyName

java.lang.String getFamilyName()
given name (aka last name)

getBusinessEmail

java.lang.String getBusinessEmail()
the email address for the user

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.job

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.job

Job, Message and Timer interfaces related to the ManagementService

See:
Description

Interface Summary
Job | base class for timers and messages.
Message | an asynchronous message.
Timer | a timer.

Package org.jbpm.api.job Description

Job, Message and Timer interfaces related to the ManagementService


Job

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.job
Interface Job

All Known Subinterfaces:
Message, Timer
public interface Job

base class for timers and messages.

Author:
Tom Baeyens

Method Summary
 java.util.Date getDuedate()
Deprecated. call getDueDate() instead
 java.util.Date getDueDate()
in case this is a timer, it is the time that the timer should fire, in case this is a message, it is null.
 java.lang.String getException()
exception that occurred during the last execution of this job.
 Execution getExecution()
the related execution
 java.lang.String getId()
unique id for this job that is used as a reference in the service methods
 java.util.Date getLockExpirationTime()
 java.lang.String getLockOwner()
job executor identification that has acquired this job and is going to execute it
 Execution getProcessInstance()
the related process instance
 int getRetries()
number of retries left.
 boolean isExclusive()
indicates if this job should be executed separate from any other job in the same process instance

Method Detail

getId

java.lang.String getId()
unique id for this job that is used as a reference in the service methods

getLockOwner

java.lang.String getLockOwner()
job executor identification that has acquired this job and is going to execute it

getDueDate

java.util.Date getDueDate()
in case this is a timer, it is the time that the timer should fire, in case this is a message, it is null.

getDuedate

@Deprecated
java.util.Date getDuedate()
Deprecated. call getDueDate() instead

in case this is a timer, it is the time that the timer should fire, in case this is a message, it is null.

getException

java.lang.String getException()
exception that occurred during the last execution of this job. The transaction of the job execution is rolled back. A synchronization is used to create a separate transaction to update the exception and decrement the retries.

getRetries

int getRetries()
number of retries left. This is only decremented when an exception occurs during job execution. The transaction of the job execution is rolled back. A synchronization is used to create a separate transaction to update the exception and decrement the retries.

isExclusive

boolean isExclusive()
indicates if this job should be executed separate from any other job in the same process instance

getExecution

Execution getExecution()
the related execution

getProcessInstance

Execution getProcessInstance()
the related process instance

getLockExpirationTime

java.util.Date getLockExpirationTime()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


Message

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.job
Interface Message

All Superinterfaces:
Job
public interface Message
extends Job

an asynchronous message.

Author:
Tom Baeyens

Method Summary
Methods inherited from interface org.jbpm.api.job.Job
getDuedate, getDueDate, getException, getExecution, getId, getLockExpirationTime, getLockOwner, getProcessInstance, getRetries, isExclusive

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Timer

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.job
Interface Timer

All Superinterfaces:
Job
public interface Timer
extends Job

a timer.

Author:
Tom Baeyens

Method Summary
java.lang.String | getEventName() the name of the event that is fired on the execution when the timer fires
java.lang.String | getRepeat() indicates the delay for repeating this timer after successful execution
java.lang.String | getSignalName() the signal that sent to the execution when the timer fires
Methods inherited from interface org.jbpm.api.job.Job
getDuedate, getDueDate, getException, getExecution, getId, getLockExpirationTime, getLockOwner, getProcessInstance, getRetries, isExclusive

Method Detail

getSignalName

java.lang.String getSignalName()
the signal that sent to the execution when the timer fires

getEventName

java.lang.String getEventName()
the name of the event that is fired on the execution when the timer fires

getRepeat

java.lang.String getRepeat()
indicates the delay for repeating this timer after successful execution

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.jpdl

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.jpdl

specific jPDL interfaces

See:
Description

Interface Summary
DecisionHandler interface for supplying user programmed decisions.

Package org.jbpm.api.jpdl Description

specific jPDL interfaces


DecisionHandler

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.jpdl
Interface DecisionHandler

All Superinterfaces:
java.io.Serializable
public interface DecisionHandler
extends java.io.Serializable

interface for supplying user programmed decisions.

Author:
Tom Baeyens

Method Summary
 java.lang.String decide(OpenExecution execution)
the name of the selected outgoing transition

Method Detail

decide

java.lang.String decide(OpenExecution execution)
the name of the selected outgoing transition

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.listener

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.listener

interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.

See:
Description

Interface Summary
EventListener | listener to process execution events.
EventListenerExecution | view upon an path of execution exposed to EventListener implementations.

Package org.jbpm.api.listener Description

interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.


EventListener

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.listener
Interface EventListener

All Superinterfaces:
java.io.Serializable
public interface EventListener
extends java.io.Serializable

listener to process execution events.

Author:
Tom Baeyens

Method Summary
 void notify(EventListenerExecution execution)
is invoked when an execution crosses the event on which this listener is registered

Method Detail

notify

void notify(EventListenerExecution execution)
            throws java.lang.Exception
is invoked when an execution crosses the event on which this listener is registered

Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


EventListenerExecution

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.listener
Interface EventListenerExecution

All Superinterfaces:
Execution, OpenExecution, java.io.Serializable
public interface EventListenerExecution
extends OpenExecution

view upon an path of execution exposed to EventListener implementations.

Author:
Tom Baeyens

Field Summary
Fields inherited from interface org.jbpm.api.Execution
STATE_ACTIVE_CONCURRENT, STATE_ACTIVE_ROOT, STATE_ASYNC, STATE_CREATED, STATE_ENDED, STATE_INACTIVE_CONCURRENT_ROOT, STATE_INACTIVE_JOIN, STATE_INACTIVE_SCOPE, STATE_SUSPENDED
Method Summary
 void setPriority(int priority)
setter for the priority.
Methods inherited from interface org.jbpm.api.model.OpenExecution
createVariable, findActiveExecutionIn, getActivity, getExecution, getParent, getProcessInstance, getSubProcessInstance, getVariable, getVariableKeys, getVariables, hasVariable, hasVariables, removeVariable, removeVariables, setState, setVariable, setVariables
Methods inherited from interface org.jbpm.api.Execution
findActiveActivityNames, getExecutions, getExecutionsMap, getId, getIsProcessInstance, getKey, getName, getPriority, getProcessDefinitionId, getState, hasExecution, isActive, isEnded, isSuspended

Method Detail

setPriority

void setPriority(int priority)
setter for the priority. The default priority is 0, which means NORMAL. Other recognized named priorities are HIGHEST (2), HIGH (1), LOW (-1) and LOWEST (-2). For the rest, the user can set any other priority integer value, but then, the UI will have to display it as an integer and not the named value.

Specified by:
setPriority in interface OpenExecution
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.model

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.model

common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.

See:
Description

Interface Summary
Activity | a activity in a OpenProcessDefinition graph.
ActivityCoordinates | activity coordinates indicating the graphical position in the diagram.
Event | event constants.
OpenExecution | execution that opens up access to the related objects in the execution and process definition model.
OpenProcessInstance | process instance for which the relations are exposed.
Transition | a transition in a OpenProcessDefinition graph.

Package org.jbpm.api.model Description

common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.


Activity

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.model
Interface Activity

public interface Activity

a activity in a OpenProcessDefinition graph.

The activity supports both graph based process models as well as block structured (tree based) process models. First we describe tranisions that can be used to formResourceName graph based process structures and then we'll describe activity composition to formResourceName block structured process models. Both models can be combined as well.

Activities have incoming and outgoing transitions. These are lists of transitions.

Optionally, transitions can have names. In that case the transition names are associated to activity's outgoing transitions. The map of outgoing transitions provides easy access to the named transitions.

One of the outgoing transitions can optionally be marked as the default transition.

Block structured process languages have composite activities that can be modeled with the parent-child relation.

Author:
Tom Baeyens

Method Summary
Activity | findActivity(java.lang.String activityName) searches for the given activity in this element recursively, including this activity and all child activities.
Transition | findOutgoingTransition(java.lang.String transitionName) searches for the given transitionName in this activity and then up the parent chain.
java.util.List<? extends Activity> | getActivities() the list of direct composite activities.
java.util.Map<java.lang.String,? extends Activity> | getActivitiesMap() the composite activities, keyed by activity name.
Activity | getActivity(java.lang.String activityName) the first composite activity with the given name or null of no such activity exists.
Transition | getDefaultOutgoingTransition() the default outgoing transition.
java.util.List<? extends Transition> | getIncomingTransitions() the list of arriving transitions.
java.lang.String | getName() the short display name given to this element.
Transition | getOutgoingTransition(java.lang.String transitionName) the first leaving transition with the given name or null of no such leaving transition exists.
java.util.List<? extends Transition> | getOutgoingTransitions() the list of outgoing transitions.
java.util.Map<java.lang.String,? extends Transition> | getOutgoingTransitionsMap() the leaving transitions, keyed by transition name.
Activity | getParentActivity() retrieve the parent activity in the composite activity structure.
java.lang.String | getType() the type of this activity which corresponds to the xml tag
boolean | hasActivities() indicates if this processDefinition has activities.
boolean | hasActivity(java.lang.String activityName) indicates if an activity with the given name exists directly in this element.
boolean | hasIncomingTransitions() indicates if this activity has arriving transitions
boolean | hasOutgoingTransition(java.lang.String transitionName) indicates if a leaving transition with the given transitionName exists.
boolean | hasOutgoingTransitions() indicates if this activity has leaving transitions

Method Detail

getName

java.lang.String getName()
the short display name given to this element.

getOutgoingTransitions

java.util.List<? extends Transition> getOutgoingTransitions()
the list of outgoing transitions. Caution: the actual member is returned. No copy is made.

getDefaultOutgoingTransition

Transition getDefaultOutgoingTransition()
the default outgoing transition.

getOutgoingTransition

Transition getOutgoingTransition(java.lang.String transitionName)
the first leaving transition with the given name or null of no such leaving transition exists. If the multiple transitions have the given transition name, the first (in order of getOutgoingTransitions()) will be returned.

Parameters:
transitionName - is the name of the transition to take. A null value will match the first unnamed transition.

hasOutgoingTransition

boolean hasOutgoingTransition(java.lang.String transitionName)
indicates if a leaving transition with the given transitionName exists. A null value matches an unnamed transition.

hasOutgoingTransitions

boolean hasOutgoingTransitions()
indicates if this activity has leaving transitions

getOutgoingTransitionsMap

java.util.Map<java.lang.String,? extends Transition> getOutgoingTransitionsMap()
the leaving transitions, keyed by transition name. If a transition with the same name occurs mutltiple times, the first one is returned. Leaving transitions with a null value for their name are not included in the map. Beware: the actual member is returned. No copy is made. In fact, the returned map is maintained as a cache. So updates to the map will influence subsequent retrievals of outgoing transitions by name.

findOutgoingTransition

Transition findOutgoingTransition(java.lang.String transitionName)
searches for the given transitionName in this activity and then up the parent chain. Returns null if no such transition is found.

getIncomingTransitions

java.util.List<? extends Transition> getIncomingTransitions()
the list of arriving transitions. Beware: the actual member is returned. No copy is made.

hasIncomingTransitions

boolean hasIncomingTransitions()
indicates if this activity has arriving transitions

getParentActivity

Activity getParentActivity()
retrieve the parent activity in the composite activity structure. This is different from ObservableElement#getParent() in that it is restricted to the parent activities. It doesn't take into account the process definition.

hasActivities

boolean hasActivities()
indicates if this processDefinition has activities.

getActivities

java.util.List<? extends Activity> getActivities()
the list of direct composite activities. Recursively contained activities are not included in the list. Beware: the actual member is returned. No copy is made.

hasActivity

boolean hasActivity(java.lang.String activityName)
indicates if an activity with the given name exists directly in this element. Only the direct contained activities are searched. No recursive search is made.

getActivity

Activity getActivity(java.lang.String activityName)
the first composite activity with the given name or null of no such activity exists. Only the direct contained activities are searched. No recursive search is made.

findActivity

Activity findActivity(java.lang.String activityName)
searches for the given activity in this element recursively, including this activity and all child activities. The search is done depth-first. A null value for activityName matches a activity without a name.

getActivitiesMap

java.util.Map<java.lang.String,? extends Activity> getActivitiesMap()
the composite activities, keyed by activity name. If an activity with the same name occurs mutltiple times, the first in the list is included in the map. Activities with a null value for their name are not included in the map. Beware: the actual member is returned. No copy is made. In fact, the returned map is maintained as a cache. So updates to the map will influence subsequent retrievals of activities by name.

getType

java.lang.String getType()
the type of this activity which corresponds to the xml tag

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


ActivityCoordinates

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.model
Interface ActivityCoordinates

public interface ActivityCoordinates

activity coordinates indicating the graphical position in the diagram.

Author:
Tom Baeyens
See Also:
RepositoryService.getActivityCoordinates(String, String)

Method Summary
int | getHeight()
int | getWidth()
int | getX()
int | getY()

Method Detail

getX

int getX()

getY

int getY()

getWidth

int getWidth()

getHeight

int getHeight()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Event

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.model
Interface Event

public interface Event

event constants.

Author:
Tom Baeyens

Field Summary
static java.lang.String | ASSIGN fired when a task is assigned
static java.lang.String | END fired when a process or an activity ends
static java.lang.String | REMIND fired when an assignee is reminded of a task
static java.lang.String | START fired when a process or an activity starts
static java.lang.String | TAKE fired when a transition is being taken

Field Detail

TAKE

static final java.lang.String TAKE
fired when a transition is being taken

See Also:
Constant Field Values

START

static final java.lang.String START
fired when a process or an activity starts

See Also:
Constant Field Values

END

static final java.lang.String END
fired when a process or an activity ends

See Also:
Constant Field Values

ASSIGN

static final java.lang.String ASSIGN
fired when a task is assigned

See Also:
Constant Field Values

REMIND

static final java.lang.String REMIND
fired when an assignee is reminded of a task

See Also:
Constant Field Values
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OpenExecution

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.model
Interface OpenExecution

All Superinterfaces:
Execution, java.io.Serializable
All Known Subinterfaces:
ActivityExecution, EventListenerExecution, OpenProcessInstance
public interface OpenExecution
extends Execution

execution that opens up access to the related objects in the execution and process definition model. This execution exposes the execution hierarchy, variable access and associated timers. Open refers to the relations being accessible. This is related to hibernate's lazy loading capabilities. That requires an active session. Inside process execution, there is such an active session and hence the relations can be exposed. But for the client of the service methods, it's not sure if the session is still active. That is why the relations are not exposed in the return values of service methods.

Author:
Tom Baeyens

Field Summary
Fields inherited from interface org.jbpm.api.Execution
STATE_ACTIVE_CONCURRENT, STATE_ACTIVE_ROOT, STATE_ASYNC, STATE_CREATED, STATE_ENDED, STATE_INACTIVE_CONCURRENT_ROOT, STATE_INACTIVE_JOIN, STATE_INACTIVE_SCOPE, STATE_SUSPENDED
Method Summary
void | createVariable(java.lang.String key, java.lang.Object value) create a new variable in this execution scope and determine the type automagically.
OpenExecution | findActiveExecutionIn(java.lang.String activityName) find the execution in the given activity or null if no such activity exists
Activity | getActivity() the current activity
OpenExecution | getExecution(java.lang.String name) the child execution for the given name or null in case such execution doesn't exist.
OpenExecution | getParent() the parent execution in the execution structure.
OpenProcessInstance | getProcessInstance() the main path of execution in the execution tree structure.
OpenExecution | getSubProcessInstance() the related sub process execution.
java.lang.Object | getVariable(java.lang.String key) retrieve the value for the given key.
java.util.Set<java.lang.String> | getVariableKeys() a non-null set that contains all the keys present in this scope.
java.util.Map<java.lang.String,?> | getVariables() a non-null map containing all the key-value pairs in this scope.
boolean | hasVariable(java.lang.String key) indicates presenve of the given key.
boolean | hasVariables() indicates if there are keys in this scope.
boolean | removeVariable(java.lang.String key) remove the key-value pair for the given key from this scope.
void | removeVariables() removes all variables in this scope
void | setPriority(int priority) setter for the priority.
void | setState(java.lang.String state) update the state
void | setVariable(java.lang.String key, java.lang.Object value) updates or creates a variable for the given value.
void | setVariables(java.util.Map<java.lang.String,?> variables) sets all given variables.
Methods inherited from interface org.jbpm.api.Execution
findActiveActivityNames, getExecutions, getExecutionsMap, getId, getIsProcessInstance, getKey, getName, getPriority, getProcessDefinitionId, getState, hasExecution, isActive, isEnded, isSuspended

Method Detail

getActivity

Activity getActivity()
the current activity

setState

void setState(java.lang.String state)
update the state

getSubProcessInstance

OpenExecution getSubProcessInstance()
the related sub process execution.

Specified by:
getSubProcessInstance in interface Execution

getVariable

java.lang.Object getVariable(java.lang.String key)
retrieve the value for the given key. The value can be null. If there is no value for the given key, the returned value will also be null. The value for key null will always be null as null keys are not allowed.

setVariable

void setVariable(java.lang.String key,
                 java.lang.Object value)
updates or creates a variable for the given value. Values are allowed to be null.

Throws:
JbpmException - if key is null.

setVariables

void setVariables(java.util.Map<java.lang.String,?> variables)
sets all given variables. Existing key-value pairs for which there is no key in the provided variables will not be removed.

Throws:
JbpmException - is variables is not null and if null is present as a key in the provided variables map.

hasVariable

boolean hasVariable(java.lang.String key)
indicates presenve of the given key. No exception will be thrown if key is null.

Returns:
true if the key is present and false if the key doesn't exist or if key is null.

removeVariable

boolean removeVariable(java.lang.String key)
remove the key-value pair for the given key from this scope. No exception will be thrown when the variable is not present.

Returns:
whether a variable was actually found and removed.

removeVariables

void removeVariables()
removes all variables in this scope

hasVariables

boolean hasVariables()
indicates if there are keys in this scope.

getVariableKeys

java.util.Set<java.lang.String> getVariableKeys()
a non-null set that contains all the keys present in this scope. Even if there are no variable keys, an empty, non-null set will be returned.

getVariables

java.util.Map<java.lang.String,?> getVariables()
a non-null map containing all the key-value pairs in this scope. Even if there are no variable keys, an empty, non-null map will be returned.

createVariable

void createVariable(java.lang.String key,
                    java.lang.Object value)
create a new variable in this execution scope and determine the type automagically.

setPriority

void setPriority(int priority)
setter for the priority. The default priority is 0, which means NORMAL. Other recognized named priorities are HIGHEST (2), HIGH (1), LOW (-1) and LOWEST (-2). For the rest, the user can set any other priority integer value, but then, the UI will have to display it as an integer and not the named value.

getProcessInstance

OpenProcessInstance getProcessInstance()
the main path of execution in the execution tree structure. The process instance is the root of the execution tree.

Specified by:
getProcessInstance in interface Execution

getParent

OpenExecution getParent()
the parent execution in the execution structure. Null will be returned in case this execution itself is the process instance.

Specified by:
getParent in interface Execution

getExecution

OpenExecution getExecution(java.lang.String name)
the child execution for the given name or null in case such execution doesn't exist.

Specified by:
getExecution in interface Execution

findActiveExecutionIn

OpenExecution findActiveExecutionIn(java.lang.String activityName)
find the execution in the given activity or null if no such activity exists

Specified by:
findActiveExecutionIn in interface Execution
See Also:
Execution.findActiveActivityNames()
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


OpenProcessInstance

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.model
Interface OpenProcessInstance

All Superinterfaces:
Execution, OpenExecution, ProcessInstance, java.io.Serializable
public interface OpenProcessInstance
extends OpenExecution, ProcessInstance

process instance for which the relations are exposed. Open refers to the relations being accessible. This is related to hibernate's lazy loading capabilities. That requires an active session. Inside process execution, there is such an active session and hence the relations can be exposed. But for the client of the service methods, it's not sure if the session is still active. That is why the relations are not exposed in the return values of service methods.

Author:
Tom Baeyens

Field Summary
Fields inherited from interface org.jbpm.api.Execution
STATE_ACTIVE_CONCURRENT, STATE_ACTIVE_ROOT, STATE_ASYNC, STATE_CREATED, STATE_ENDED, STATE_INACTIVE_CONCURRENT_ROOT, STATE_INACTIVE_JOIN, STATE_INACTIVE_SCOPE, STATE_SUSPENDED
Method Summary
Methods inherited from interface org.jbpm.api.model.OpenExecution
createVariable, findActiveExecutionIn, getActivity, getExecution, getParent, getProcessInstance, getSubProcessInstance, getVariable, getVariableKeys, getVariables, hasVariable, hasVariables, removeVariable, removeVariables, setPriority, setState, setVariable, setVariables
Methods inherited from interface org.jbpm.api.Execution
findActiveActivityNames, getExecutions, getExecutionsMap, getId, getIsProcessInstance, getKey, getName, getPriority, getProcessDefinitionId, getState, hasExecution, isActive, isEnded, isSuspended

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Transition

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.model
Interface Transition

public interface Transition

a transition in a OpenProcessDefinition graph.

Guard conditions

TODO

Transitions as wait states

A wait condition indicates wether a transition is to be taken synchronously or wether the transition will behave as a wait state.

Transitions that are wait states can occur when an analyst has an actual state (e.g. 'making loss') and a desired state (e.g. 'making profit') and models a transition between those states. In that case the transition might take a long time and hence it results into a wait state for the system.

If the wait condition is null or if it returns false, then the transition will be taking synchronously. Otherwise the transition will behave as a wait state and wait for a signal on the execution.

Transitions as wait states has every thing to do with matching the process graph to transactions on the server. If the transition is taken in one (the current) transaction, then the async condition should be empty or evaluate to false. If the arrival of the execution in the destination activity should occur in a separate execution

Author:
Tom Baeyens

Method Summary
Activity | getDestination() the activity in which this transition arrives.
java.lang.String | getName() the short display name given to this element.
Activity | getSource() the activity from which this transition leaves.

Method Detail

getName

java.lang.String getName()
the short display name given to this element.

getSource

Activity getSource()
the activity from which this transition leaves.

getDestination

Activity getDestination()
the activity in which this transition arrives.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


org.jbpm.api.task

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package org.jbpm.api.task

interfaces related to the TaskService

See:
Description

Interface Summary
Assignable | tasks or swimlanes can be assigned.
AssignmentHandler | interface to delegate Task or Swimlane assignment.
Participation | a link to a participating identity (user or group) and the type of involvement.
Swimlane | a runtime process role that can store an assignment so that multiple related tasks are assigned to the same actor.
Task | a runtime task.

Package org.jbpm.api.task Description

interfaces related to the TaskService

Overview Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


Assignable

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.task
Interface Assignable

public interface Assignable

tasks or swimlanes can be assigned.

Author:
Tom Baeyens
See Also:
AssignmentHandler

Method Summary
void | addCandidateGroup(java.lang.String groupId) add the members of the given group as candidates to the task or swimlane
void | addCandidateUser(java.lang.String userId) add the given user as a candidate to the task or swimlane
void | setAssignee(java.lang.String userId) assign the task or swimlane to the given user

Method Detail

setAssignee

void setAssignee(java.lang.String userId)
assign the task or swimlane to the given user

addCandidateUser

void addCandidateUser(java.lang.String userId)
add the given user as a candidate to the task or swimlane

addCandidateGroup

void addCandidateGroup(java.lang.String groupId)
add the members of the given group as candidates to the task or swimlane

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


AssignmentHandler

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.task
Interface AssignmentHandler

All Superinterfaces:
java.io.Serializable
public interface AssignmentHandler
extends java.io.Serializable

interface to delegate Task or Swimlane assignment.

Author:
Tom Baeyens

Method Summary
 void assign(Assignable assignable, OpenExecution execution)
sets the actorId and candidates for the given task.

Method Detail

assign

void assign(Assignable assignable,
            OpenExecution execution)
            throws java.lang.Exception
sets the actorId and candidates for the given task.

Throws:
java.lang.Exception
Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Participation

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.task
Interface Participation

public interface Participation

a link to a participating identity (user or group) and the type of involvement.

Author:
Tom Baeyens, Heiko Braun

Field Summary
static java.lang.String | CANDIDATE alternative owner, but as long as this person is not the owner.
static java.lang.String | CLIENT person that will be using the result of this task.
static java.lang.String | OWNER the person with ultimate responsibility over a task.
static java.lang.String | REPLACED_ASSIGNEE a person that was assigned to a task, but got replaced because of absence or another reason.
static java.lang.String | VIEWER person that is allowed to watch-but-not-touch this task
Method Summary
java.lang.String | getGroupId() groupId for this participation.
java.lang.String | getId() the unique id for this participation that is used as a reference in the service methods
java.lang.String | getType() see constants for default participations
java.lang.String | getUserId() userId for this participation.

Field Detail

CANDIDATE

static final java.lang.String CANDIDATE
alternative owner, but as long as this person is not the owner. This person is allowed to make comments, but nothing else.

See Also:
Constant Field Values

OWNER

static final java.lang.String OWNER
the person with ultimate responsibility over a task.

See Also:
Constant Field Values

CLIENT

static final java.lang.String CLIENT
person that will be using the result of this task. This person is allowed to make comments, but nothing else.

See Also:
Constant Field Values

VIEWER

static final java.lang.String VIEWER
person that is allowed to watch-but-not-touch this task

See Also:
Constant Field Values

REPLACED_ASSIGNEE

static final java.lang.String REPLACED_ASSIGNEE
a person that was assigned to a task, but got replaced because of absence or another reason. This way, a trace can be left in case this person returns and wants to take back his tasks that got reassigned.

See Also:
Constant Field Values
Method Detail

getId

java.lang.String getId()
the unique id for this participation that is used as a reference in the service methods

getUserId

java.lang.String getUserId()
userId for this participation. null in case this is a group participation.

getGroupId

java.lang.String getGroupId()
groupId for this participation. null in case this is a user participation.

getType

java.lang.String getType()
see constants for default participations

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Swimlane

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.task
Interface Swimlane

All Superinterfaces:
java.io.Serializable
public interface Swimlane
extends java.io.Serializable

a runtime process role that can store an assignment so that multiple related tasks are assigned to the same actor.

Author:
Tom Baeyens

Method Summary
java.lang.String | getAssignee() the userId of the person that is assigned to this swimlane.
java.lang.String | getId() the unique id for this swimlane that is used as a reference in the service methods
java.lang.String | getName() the name of the swimlane as defined in the process file

Method Detail

getId

java.lang.String getId()
the unique id for this swimlane that is used as a reference in the service methods

getName

java.lang.String getName()
the name of the swimlane as defined in the process file

getAssignee

java.lang.String getAssignee()
the userId of the person that is assigned to this swimlane.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


Task

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

org.jbpm.api.task
Interface Task

All Superinterfaces:
java.io.Serializable
public interface Task
extends java.io.Serializable

a runtime task. In contrast to HistoryTask, a Task only represents the runtime state of a task and hence it will be deleted after it is completed.

Author:
Tom Baeyens

Field Summary
static java.lang.String | STATE_COMPLETED task is done
static java.lang.String | STATE_OPEN task is waiting for someone to work on it and completed it
static java.lang.String | STATE_SUSPENDED task doesn't show up in task lists as something is wrong with the related process instance that requires manual intervention first.
Method Summary
java.lang.String | getActivityName() reference to the activity or null if this task is unrelated to an activity
java.lang.String | getAssignee() the person responsible for completion of this task.
java.util.Date | getCreateTime() date and time when this task was created
java.lang.String | getDescription() longer description of this task
java.util.Date | getDuedate() date and time when this task must be completed.
java.lang.String | getExecutionId() reference to the execution or null if this task is unrelated to an execution
java.lang.String | getFormResourceName() name of the resource in the deployment for the form that is associated to this task.
java.lang.String | getId() the unique id for this task that is used as a reference in the service methods
java.lang.String | getName() the short display name of this task.
int | getPriority() the priority of this task.
java.lang.Integer | getProgress() The progress of this task.
void | setAssignee(java.lang.String assignee) update the assignee of this task.
void | setDescription(java.lang.String description) update the longer description of this task.
void | setDuedate(java.util.Date duedate) update the date and time when this task must be completed.
void | setName(java.lang.String name) change the short display name of this tasks.
void | setPriority(int priority) update the priority.
void | setProgress(java.lang.Integer progress) Change the progress of this task.

Field Detail

STATE_OPEN

static final java.lang.String STATE_OPEN
task is waiting for someone to work on it and completed it

See Also:
Constant Field Values

STATE_COMPLETED

static final java.lang.String STATE_COMPLETED
task is done

See Also:
Constant Field Values

STATE_SUSPENDED

static final java.lang.String STATE_SUSPENDED
task doesn't show up in task lists as something is wrong with the related process instance that requires manual intervention first.

See Also:
Constant Field Values
Method Detail

getId

java.lang.String getId()
the unique id for this task that is used as a reference in the service methods

getName

java.lang.String getName()
the short display name of this task. Originally, this might come from the process file, but it can be changed at runtime for individual tasks.

setName

void setName(java.lang.String name)
change the short display name of this tasks. Updates require you to invoke TaskService.saveTask(Task) afterwards.

getDescription

java.lang.String getDescription()
longer description of this task

setDescription

void setDescription(java.lang.String description)
update the longer description of this task. Updates like this require you to invoke TaskService.saveTask(Task) afterwards.

getAssignee

java.lang.String getAssignee()
the person responsible for completion of this task.

setAssignee

void setAssignee(java.lang.String assignee)
update the assignee of this task. Updates like this require you to invoke TaskService.saveTask(Task) afterwards.

getCreateTime

java.util.Date getCreateTime()
date and time when this task was created

getDuedate

java.util.Date getDuedate()
date and time when this task must be completed. This might be null.

setDuedate

void setDuedate(java.util.Date duedate)
update the date and time when this task must be completed. Updates like this require you to invoke TaskService.saveTask(Task) afterwards.

getPriority

int getPriority()
the priority of this task. This is only a data item for user purposes. The engine doesn't do anything different for different priorities.

setPriority

void setPriority(int priority)
update the priority. Updates like this require you to invoke TaskService.saveTask(Task) afterwards.

getProgress

java.lang.Integer getProgress()
The progress of this task. This is a data item for user purposes and doesn't influence the functionality of the engine.

setProgress

void setProgress(java.lang.Integer progress)
Change the progress of this task. Updates like this require you to invoke TaskService.saveTask(Task) afterwards. IMPORTANT: Only values between 0 and 100 are accepted. Using other values will cause a JbpmException.

getExecutionId

java.lang.String getExecutionId()
reference to the execution or null if this task is unrelated to an execution

getActivityName

java.lang.String getActivityName()
reference to the activity or null if this task is unrelated to an activity

getFormResourceName

java.lang.String getFormResourceName()
name of the resource in the deployment for the form that is associated to this task.

Overview Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


 All Classes
Activity
ActivityBehaviour
ActivityCoordinates
ActivityExecution
Assignable
AssignmentHandler
Command
Configuration
DecisionHandler
Deployment
DeploymentQuery
Environment
Event
EventListener
EventListenerExecution
Execution
ExecutionService
ExternalActivityBehaviour
Group
HistoryActivityInstance
HistoryActivityInstanceQuery
HistoryComment
HistoryDetail
HistoryDetailQuery
HistoryProcessInstance
HistoryProcessInstanceQuery
HistoryService
HistoryTask
HistoryTaskQuery
IdentityService
JbpmException
Job
JobQuery
ManagementService
Message
NewDeployment
OpenExecution
OpenProcessInstance
ParamCommand
Participation
ProcessDefinition
ProcessDefinitionQuery
ProcessEngine
ProcessInstance
ProcessInstanceQuery
RepositoryService
Swimlane
Task
TaskQuery
TaskService
Timer
Transition
User
VoidCommand


Constant Field Values

Contents
  • org.jbpm.*
org.jbpm.*

org.jbpm.api.Deployment
public static final java.lang.String | STATE_ACTIVE | "active"
public static final java.lang.String | STATE_SUSPENDED | "suspended"

org.jbpm.api.DeploymentQuery
public static final java.lang.String | PROPERTY_STATE | "state"
public static final java.lang.String | PROPERTY_TIMESTAMP | "timestamp"

org.jbpm.api.Execution
public static final java.lang.String | STATE_ACTIVE_CONCURRENT | "active-concurrent"
public static final java.lang.String | STATE_ACTIVE_ROOT | "active-root"
public static final java.lang.String | STATE_ASYNC | "async"
public static final java.lang.String | STATE_CREATED | "created"
public static final java.lang.String | STATE_ENDED | "ended"
public static final java.lang.String | STATE_INACTIVE_CONCURRENT_ROOT | "inactive-concurrent-root"
public static final java.lang.String | STATE_INACTIVE_JOIN | "inactive-join"
public static final java.lang.String | STATE_INACTIVE_SCOPE | "inactive-scope"
public static final java.lang.String | STATE_SUSPENDED | "suspended"

org.jbpm.api.JobQuery
public static final java.lang.String | PROPERTY_DUEDATE | "dueDate"
public static final java.lang.String | PROPERTY_STATE | "state"

org.jbpm.api.ProcessDefinitionQuery
public static final java.lang.String | PROPERTY_DEPLOYMENT_TIMESTAMP | "deployment.timestamp"
public static final java.lang.String | PROPERTY_ID | "idProperty.stringValue"
public static final java.lang.String | PROPERTY_KEY | "keyProperty.stringValue"
public static final java.lang.String | PROPERTY_NAME | "idProperty.objectName"
public static final java.lang.String | PROPERTY_VERSION | "versionProperty.longValue"

org.jbpm.api.ProcessInstanceQuery
public static final java.lang.String PROPERTY_KEY "key"

org.jbpm.api.TaskQuery
public static final java.lang.String | PROPERTY_ASSIGNEE | "assignee"
public static final java.lang.String | PROPERTY_CREATEDATE | "createTime"
public static final java.lang.String | PROPERTY_DUEDATE | "duedate"
public static final java.lang.String | PROPERTY_NAME | "name"
public static final java.lang.String | PROPERTY_PRIORITY | "priority"
public static final java.lang.String | PROPERTY_PROGRESS | "progress"

org.jbpm.api.history.HistoryActivityInstanceQuery
public static final java.lang.String | PROPERTY_ACTIVITYNAME | "activityName"
public static final java.lang.String | PROPERTY_DURATION | "duration"
public static final java.lang.String | PROPERTY_ENDTIME | "endTime"
public static final java.lang.String | PROPERTY_EXECUTIONID | "executionId"
public static final java.lang.String | PROPERTY_STARTTIME | "startTime"

org.jbpm.api.history.HistoryDetailQuery
public static final java.lang.String | PROPERTY_TIME | "time"
public static final java.lang.String | PROPERTY_USERID | "userId"

org.jbpm.api.history.HistoryProcessInstance
public static final java.lang.String | STATE_ACTIVE | "active"
public static final java.lang.String | STATE_ENDED | "ended"

org.jbpm.api.history.HistoryProcessInstanceQuery
public static final java.lang.String | PROPERTY_DURATION | "duration"
public static final java.lang.String | PROPERTY_ENDTIME | "endTime"
public static final java.lang.String | PROPERTY_ID | "id"
public static final java.lang.String | PROPERTY_KEY | "key"
public static final java.lang.String | PROPERTY_STARTTIME | "startTime"
public static final java.lang.String | PROPERTY_STATE | "state"

org.jbpm.api.history.HistoryTask
public static final java.lang.String | STATE_COMPLETED | "completed"
public static final java.lang.String | STATE_OBSOLETE | "obsolete"

org.jbpm.api.history.HistoryTaskQuery
public static final java.lang.String | PROPERTY_ASSIGNEE | "assignee"
public static final java.lang.String | PROPERTY_CREATETIME | "createTime"
public static final java.lang.String | PROPERTY_DURATION | "duration"
public static final java.lang.String | PROPERTY_ENDTIME | "endTime"
public static final java.lang.String | PROPERTY_EXECUTIONID | "executionId"
public static final java.lang.String | PROPERTY_ID | "dbid"
public static final java.lang.String | PROPERTY_OUTCOME | "outcome"
public static final java.lang.String | PROPERTY_STATE | "state"

org.jbpm.api.model.Event
public static final java.lang.String | ASSIGN | "assign"
public static final java.lang.String | END | "end"
public static final java.lang.String | REMIND | "remind"
public static final java.lang.String | START | "start"
public static final java.lang.String | TAKE | "take"

org.jbpm.api.task.Participation
public static final java.lang.String | CANDIDATE | "candidate"
public static final java.lang.String | CLIENT | "client"
public static final java.lang.String | OWNER | "owner"
public static final java.lang.String | REPLACED_ASSIGNEE | "replaced-assignee"
public static final java.lang.String | VIEWER | "viewer"

org.jbpm.api.task.Task
public static final java.lang.String | STATE_COMPLETED | "completed"
public static final java.lang.String | STATE_OPEN | "open"
public static final java.lang.String | STATE_SUSPENDED | "suspended"

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Deprecated List

Deprecated API

Contents
  • Deprecated Methods
Deprecated Methods
org.jbpm.api.job.Job.getDuedate()
call Job.getDueDate() instead

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this API document and provides a list of all packages with a summary for each. This page can also contain an overall description of the set of packages.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


jBPM 4 - API 4.4 API

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Index

A B C D E F G H I J L M N O P R S T U V W

A

Activity - Interface in org.jbpm.api.model
a activity in a OpenProcessDefinition graph.
ActivityBehaviour - Interface in org.jbpm.api.activity
implements the runtime behaviour of an activity.
ActivityCoordinates - Interface in org.jbpm.api.model
activity coordinates indicating the graphical position in the diagram.
ActivityExecution - Interface in org.jbpm.api.activity
view upon an Execution exposed to ActivityBehaviour implementations.
activityInstanceId(String) - Method in interface org.jbpm.api.history.HistoryDetailQuery
only select details for the given activityInstanceId
activityName(String) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
only select activity instances for the given activity (this usually used in combination with HistoryActivityInstanceQuery.processDefinitionId(String))
activityName(String) - Method in interface org.jbpm.api.TaskQuery
only select tasks that are associated to the given activity name.
addCandidateGroup(String) - Method in interface org.jbpm.api.task.Assignable
add the members of the given group as candidates to the task or swimlane
addCandidateUser(String) - Method in interface org.jbpm.api.task.Assignable
add the given user as a candidate to the task or swimlane
addReplyComment(String, String) - Method in interface org.jbpm.api.TaskService
add a reply to another comment
addResourceFromClasspath(String) - Method in interface org.jbpm.api.NewDeployment
adds a resource as a resource from the classpath
addResourceFromFile(File) - Method in interface org.jbpm.api.NewDeployment
adds a resource from a file
addResourceFromInputStream(String, InputStream) - Method in interface org.jbpm.api.NewDeployment
adds a resource as a string
addResourceFromString(String, String) - Method in interface org.jbpm.api.NewDeployment
adds a resource as a string
addResourceFromUrl(URL) - Method in interface org.jbpm.api.NewDeployment
adds a resource as a url
addResourcesFromZipInputStream(ZipInputStream) - Method in interface org.jbpm.api.NewDeployment
adds a resource as a zip stream
addTaskComment(String, String) - Method in interface org.jbpm.api.TaskService
add a comment to a task
addTaskParticipatingGroup(String, String, String) - Method in interface org.jbpm.api.TaskService
add a role to a given task.
addTaskParticipatingUser(String, String, String) - Method in interface org.jbpm.api.TaskService
add a role to a given task.
ASSIGN - Static variable in interface org.jbpm.api.model.Event
fired when a task is assigned
assign(Assignable, OpenExecution) - Method in interface org.jbpm.api.task.AssignmentHandler
sets the actorId and candidates for the given task.
Assignable - Interface in org.jbpm.api.task
tasks or swimlanes can be assigned.
assignee(String) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select history tasks for the given assignee
assignee(String) - Method in interface org.jbpm.api.TaskQuery
only select tasks for which the given user is the assignee
AssignmentHandler - Interface in org.jbpm.api.task
interface to delegate Task or Swimlane assignment.
assignTask(String, String) - Method in interface org.jbpm.api.TaskService
assigns this task to the given assignee.
avgDurationPerActivity(String) - Method in interface org.jbpm.api.HistoryService
returns the average duration in milliseconds for each activity in the given process definition

B

buildProcessEngine() - Method in class org.jbpm.api.Configuration
after specifying the configuration resources with the other methods, a process engine can be created.

C

CANDIDATE - Static variable in interface org.jbpm.api.task.Participation
alternative owner, but as long as this person is not the owner.
candidate(String) - Method in interface org.jbpm.api.TaskQuery
only query for tasks for which the given user is a candidate.
choiceDistribution(String, String) - Method in interface org.jbpm.api.HistoryService
returns for each transitionName, the number of times that transition was taken
CLIENT - Static variable in interface org.jbpm.api.task.Participation
person that will be using the result of this task.
close() - Method in interface org.jbpm.api.ProcessEngine
clean shutdown of the engine.
Command<T> - Interface in org.jbpm.api.cmd
commands that can be executed by the process engine.
comments() - Method in interface org.jbpm.api.history.HistoryDetailQuery
only select details of type comment (this usually used in combination with #processDefinitionId(String))
completeTask(String) - Method in interface org.jbpm.api.TaskService
Deletes this task, marks the related history task as completed.
completeTask(String, Map<String, ?>) - Method in interface org.jbpm.api.TaskService
Deletes this task and marks the related history task as completed.
completeTask(String, String) - Method in interface org.jbpm.api.TaskService
Deletes this task, marks the related history task as completed with the specified outcome.
completeTask(String, String, Map<String, ?>) - Method in interface org.jbpm.api.TaskService
Deletes this task, marks the related history task as completed with the specified outcome.
Configuration - Class in org.jbpm.api
process engine configuration.
Configuration() - Constructor for class org.jbpm.api.Configuration
default constructor
Configuration(Object) - Constructor for class org.jbpm.api.Configuration
count() - Method in interface org.jbpm.api.DeploymentQuery
execute a count(*) query and returns number of results
count() - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
execute a count(*) query and returns number of results
count() - Method in interface org.jbpm.api.history.HistoryDetailQuery
execute a count(*) query and returns number of results
count() - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
execute a count(*) query and returns number of results
count() - Method in interface org.jbpm.api.history.HistoryTaskQuery
execute a count(*) query and returns number of results
count() - Method in interface org.jbpm.api.JobQuery
execute a count(*) query and returns number of results
count() - Method in interface org.jbpm.api.ProcessDefinitionQuery
execute a count(*) query and returns number of results
count() - Method in interface org.jbpm.api.ProcessInstanceQuery
execute a count(*) query and returns number of results
count() - Method in interface org.jbpm.api.TaskQuery
execute a count(*) query and returns number of results
createDeployment() - Method in interface org.jbpm.api.RepositoryService
create a new deployment.
createDeploymentQuery() - Method in interface org.jbpm.api.RepositoryService
create a query for deployments
createGroup(String) - Method in interface org.jbpm.api.IdentityService
create a group new group
createGroup(String, String) - Method in interface org.jbpm.api.IdentityService
create a group new group
createGroup(String, String, String) - Method in interface org.jbpm.api.IdentityService
create a group new group
createHistoryActivityInstanceQuery() - Method in interface org.jbpm.api.HistoryService
search in history activity instance information
createHistoryDetailQuery() - Method in interface org.jbpm.api.HistoryService
search in history details
createHistoryProcessInstanceQuery() - Method in interface org.jbpm.api.HistoryService
search for process instances in the history
createHistoryTaskQuery() - Method in interface org.jbpm.api.HistoryService
search in history task information
createJobQuery() - Method in interface org.jbpm.api.ManagementService
search for jobs
createMembership(String, String) - Method in interface org.jbpm.api.IdentityService
makes the given user a member of the given group.
createMembership(String, String, String) - Method in interface org.jbpm.api.IdentityService
makes the given user a member of the given group with the given role.
createProcessDefinitionQuery() - Method in interface org.jbpm.api.RepositoryService
create a query for process definitions
createProcessInstanceQuery() - Method in interface org.jbpm.api.ExecutionService
search for process instances with criteria.
createTaskQuery() - Method in interface org.jbpm.api.TaskService
create a new query for tasks
createUser(String, String, String) - Method in interface org.jbpm.api.IdentityService
create a new user.
createUser(String, String, String, String) - Method in interface org.jbpm.api.IdentityService
create a new user, providing an email address
createVariable(String, String, Object, boolean) - Method in interface org.jbpm.api.ExecutionService
creates a variable value in the referenced execution. optionally enables variable history tracking.
createVariable(String, Object) - Method in interface org.jbpm.api.model.OpenExecution
create a new variable in this execution scope and determine the type automagically.
createVariables(String, Map<String, ?>, boolean) - Method in interface org.jbpm.api.ExecutionService
creates variable values in the referenced execution. optionally enables variable history tracking.

D

decide(OpenExecution) - Method in interface org.jbpm.api.jpdl.DecisionHandler
the name of the selected outgoing transition
DecisionHandler - Interface in org.jbpm.api.jpdl
interface for supplying user programmed decisions.
deleteComment(String) - Method in interface org.jbpm.api.TaskService
delete a comment.
deleteDeployment(String) - Method in interface org.jbpm.api.RepositoryService
deletes a deployment if the process definitions don't have running executions.
deleteDeploymentCascade(String) - Method in interface org.jbpm.api.RepositoryService
deletes deployment, contained process definitions, related process instances and their history information
deleteGroup(String) - Method in interface org.jbpm.api.IdentityService
deletes the given group.
deleteJob(long) - Method in interface org.jbpm.api.ManagementService
Deletes the job with the given id.
deleteMembership(String, String, String) - Method in interface org.jbpm.api.IdentityService
deletes the identified relation between a user and a group.
deleteProcessInstance(String) - Method in interface org.jbpm.api.ExecutionService
delete a process instance.
deleteProcessInstanceCascade(String) - Method in interface org.jbpm.api.ExecutionService
delete a process instance, including the history information.
deleteTask(String) - Method in interface org.jbpm.api.TaskService
Deletes the task without completing it.
deleteTask(String, String) - Method in interface org.jbpm.api.TaskService
Deletes the task without completing indicating the reason.
deleteTaskCascade(String) - Method in interface org.jbpm.api.TaskService
deletes this task, including all history information
deleteUser(String) - Method in interface org.jbpm.api.IdentityService
delete the given user.
deploy() - Method in interface org.jbpm.api.NewDeployment
after adding resources, this will perform the actual deployment.
Deployment - Interface in org.jbpm.api
represents an existing deployment in the repository.
deploymentId(String) - Method in interface org.jbpm.api.DeploymentQuery
only include a specific deployment by id
deploymentId(String) - Method in interface org.jbpm.api.ProcessDefinitionQuery
select only process definitions within the given deployment
DeploymentQuery - Interface in org.jbpm.api
find existing deployments in the repository.

E

end() - Method in interface org.jbpm.api.activity.ActivityExecution
ends this execution and all of its child executions.
end(String) - Method in interface org.jbpm.api.activity.ActivityExecution
ends this execution and all it's child executions with a user defined status.
END - Static variable in interface org.jbpm.api.model.Event
fired when a process or an activity ends
ended() - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
select only process instances that have ended.
endedAfter(Date) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
select only process instances that have ended on or after the given date.
endedBefore(Date) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
select only process instances that have ended before the given date.
endProcessInstance(String, String) - Method in interface org.jbpm.api.ExecutionService
end a process instance
Environment - Interface in org.jbpm.api.cmd
exposes configured process engine scope objects and transaction scope objects to command implementations.
Event - Interface in org.jbpm.api.model
event constants.
EventListener - Interface in org.jbpm.api.listener
listener to process execution events.
EventListenerExecution - Interface in org.jbpm.api.listener
view upon an path of execution exposed to EventListener implementations.
exception(boolean) - Method in interface org.jbpm.api.JobQuery
only select jobs that were rolled back due to an exception
execute(ActivityExecution) - Method in interface org.jbpm.api.activity.ActivityBehaviour
invoked when an execution arrives in an activity.
execute(String) - Method in interface org.jbpm.api.activity.ActivityExecution
executes the given nested activity.
execute(Environment) - Method in interface org.jbpm.api.cmd.Command
execute(Environment) - Method in class org.jbpm.api.cmd.VoidCommand
execute(Command<T>) - Method in interface org.jbpm.api.ProcessEngine
perform a user command.
executeJob(String) - Method in interface org.jbpm.api.ManagementService
resets the retry count, clears the exception and executes the job.
executeVoid(Environment) - Method in class org.jbpm.api.cmd.VoidCommand
Execution - Interface in org.jbpm.api
a runtime path of execution.
executionId(String) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
only select activity instances for the given execution
executionId(String) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select history tasks within the given execution
executionId(String) - Method in interface org.jbpm.api.TaskQuery
only select tasks that are associated to the given execution
ExecutionService - Interface in org.jbpm.api
manages runtime process executions.
ExternalActivityBehaviour - Interface in org.jbpm.api.activity
extends ActivityBehaviour for handling external triggers after a wait state.

F

findActiveActivityNames() - Method in interface org.jbpm.api.Execution
get the set of all activities that are active.
findActiveExecutionIn(String) - Method in interface org.jbpm.api.Execution
search for an execution that is active and in the given activityName.
findActiveExecutionIn(String) - Method in interface org.jbpm.api.model.OpenExecution
find the execution in the given activity or null if no such activity exists
findActivity(String) - Method in interface org.jbpm.api.model.Activity
searches for the given activity in this element recursively, including this activity and all child activities.
findExecutionById(String) - Method in interface org.jbpm.api.ExecutionService
the path of execution that is uniquely defined by the execution id.
findGroupById(String) - Method in interface org.jbpm.api.IdentityService
lookup a group.
findGroupIdsByUser(String) - Method in interface org.jbpm.api.IdentityService
all group ids (String) for which this user is a member.
findGroupsByUser(String) - Method in interface org.jbpm.api.IdentityService
all group ids (String) for which this user is a member.
findGroupsByUserAndGroupType(String, String) - Method in interface org.jbpm.api.IdentityService
groups of the given groupType for which the given user is a member.
findGroupTasks(String) - Method in interface org.jbpm.api.TaskService
list of tasks that can be taken by the given user.
findOutgoingTransition(String) - Method in interface org.jbpm.api.model.Activity
searches for the given transitionName in this activity and then up the parent chain.
findPersonalTasks(String) - Method in interface org.jbpm.api.TaskService
list of tasks that are assigned to the given user.
findProcessInstanceById(String) - Method in interface org.jbpm.api.ExecutionService
the process instance that is uniquely defined by the process execution id.
findUserById(String) - Method in interface org.jbpm.api.IdentityService
lookup a user
findUsers() - Method in interface org.jbpm.api.IdentityService
get all the users in the system.

G

get(String) - Method in interface org.jbpm.api.cmd.Environment
searches a named object in all the contexts in the default search order.
get(Class<T>) - Method in interface org.jbpm.api.cmd.Environment
searches an object based on type.
get(Class<T>) - Method in interface org.jbpm.api.ProcessEngine
retrieve and object defined in the process engine by type
get(String) - Method in interface org.jbpm.api.ProcessEngine
retrieve and object defined in the process engine by name
getActivities() - Method in interface org.jbpm.api.model.Activity
the list of direct composite activities.
getActivitiesMap() - Method in interface org.jbpm.api.model.Activity
the composite activities, keyed by activity name.
getActivity(String) - Method in interface org.jbpm.api.model.Activity
the first composite activity with the given name or null of no such activity exists.
getActivity() - Method in interface org.jbpm.api.model.OpenExecution
the current activity
getActivityCoordinates(String, String) - Method in interface org.jbpm.api.RepositoryService
the coordinates for the activity on the process image.
getActivityName() - Method in interface org.jbpm.api.activity.ActivityExecution
represents the current position in the process by indicating the name of the current activity.
getActivityName() - Method in interface org.jbpm.api.history.HistoryActivityInstance
name of the activity that was executed
getActivityName() - Method in interface org.jbpm.api.task.Task
reference to the activity or null if this task is unrelated to an activity
getAssignee() - Method in interface org.jbpm.api.history.HistoryTask
userId of the person that is responsible for this task
getAssignee() - Method in interface org.jbpm.api.task.Swimlane
the userId of the person that is assigned to this swimlane.
getAssignee() - Method in interface org.jbpm.api.task.Task
the person responsible for completion of this task.
getBusinessEmail() - Method in interface org.jbpm.api.identity.User
the email address for the user
getClassLoader() - Method in class org.jbpm.api.Configuration
getCreateTime() - Method in interface org.jbpm.api.history.HistoryTask
time when the activity was entered
getCreateTime() - Method in interface org.jbpm.api.task.Task
date and time when this task was created
getDefaultOutgoingTransition() - Method in interface org.jbpm.api.model.Activity
the default outgoing transition.
getDeploymentId() - Method in interface org.jbpm.api.ProcessDefinition
references the deployment in which this process definition is deployed.
getDescription() - Method in interface org.jbpm.api.ProcessDefinition
description of the process definition
getDescription() - Method in interface org.jbpm.api.task.Task
longer description of this task
getDestination() - Method in interface org.jbpm.api.model.Transition
the activity in which this transition arrives.
getDueDate() - Method in interface org.jbpm.api.job.Job
in case this is a timer, it is the time that the timer should fire, in case this is a message, it is null.
getDuedate() - Method in interface org.jbpm.api.job.Job
Deprecated. call Job.getDueDate() instead
getDuedate() - Method in interface org.jbpm.api.task.Task
date and time when this task must be completed.
getDuration() - Method in interface org.jbpm.api.history.HistoryActivityInstance
duration in milleseconds
getDuration() - Method in interface org.jbpm.api.history.HistoryProcessInstance
duration of the process instance in milliseconds or null if the process instance has not yet ended
getDuration() - Method in interface org.jbpm.api.history.HistoryTask
duration in milliseconds
getEndActivityName() - Method in interface org.jbpm.api.history.HistoryProcessInstance
Returns the name of the end state that was reached when the process was ended.
getEndTime() - Method in interface org.jbpm.api.history.HistoryActivityInstance
might be null in case the activity is still active
getEndTime() - Method in interface org.jbpm.api.history.HistoryProcessInstance
when the process instance ended (only not null if the process instance already ended)
getEndTime() - Method in interface org.jbpm.api.history.HistoryTask
might be null in case the activity is still active
getEventName() - Method in interface org.jbpm.api.job.Timer
the name of the event that is fired on the execution when the timer fires
getException() - Method in interface org.jbpm.api.job.Job
exception that occurred during the last execution of this job.
getExecution(String) - Method in interface org.jbpm.api.Execution
the child execution for the given name or null in case such execution doesn't exist.
getExecution() - Method in interface org.jbpm.api.job.Job
the related execution
getExecution(String) - Method in interface org.jbpm.api.model.OpenExecution
the child execution for the given name or null in case such execution doesn't exist.
getExecutionId() - Method in interface org.jbpm.api.history.HistoryActivityInstance
the execution that was related to this activity occurrence
getExecutionId() - Method in interface org.jbpm.api.history.HistoryTask
the execution that was related to this activity occurrence
getExecutionId() - Method in interface org.jbpm.api.task.Task
reference to the execution or null if this task is unrelated to an execution
getExecutions() - Method in interface org.jbpm.api.Execution
the child executions in the execution structure.
getExecutionService() - Method in interface org.jbpm.api.ProcessEngine
the execution service that provides access to the runtime executions repository.
getExecutionsMap() - Method in interface org.jbpm.api.Execution
maps child execution names to execution objects.
getFamilyName() - Method in interface org.jbpm.api.identity.User
given name (aka last name)
getFormResourceName() - Method in interface org.jbpm.api.task.Task
name of the resource in the deployment for the form that is associated to this task.
getGivenName() - Method in interface org.jbpm.api.identity.User
given name (aka first name)
getGroupId() - Method in interface org.jbpm.api.task.Participation
groupId for this participation.
getHeight() - Method in interface org.jbpm.api.model.ActivityCoordinates
getHistoryService() - Method in interface org.jbpm.api.ProcessEngine
the history service that provides access to the history executions repository.
getId() - Method in interface org.jbpm.api.Deployment
unique identification of this deployment that is used as a reference in the service methods
getId() - Method in interface org.jbpm.api.Execution
a globally unique identifier for this execution that is used as a reference in the service methods.
getId() - Method in interface org.jbpm.api.history.HistoryDetail
the unique id for this comment that is used as a reference in the service methods
getId() - Method in interface org.jbpm.api.history.HistoryTask
the unique id for this task that is used as a reference in the service methods
getId() - Method in interface org.jbpm.api.identity.Group
unique id for the group that is used as a reference in the service methods
getId() - Method in interface org.jbpm.api.identity.User
unique id for the user that is used as a reference in the service methods
getId() - Method in interface org.jbpm.api.job.Job
unique id for this job that is used as a reference in the service methods
getId() - Method in interface org.jbpm.api.ProcessDefinition
the unique id for this process definition that is used as a reference in the service methods.
getId() - Method in interface org.jbpm.api.task.Participation
the unique id for this participation that is used as a reference in the service methods
getId() - Method in interface org.jbpm.api.task.Swimlane
the unique id for this swimlane that is used as a reference in the service methods
getId() - Method in interface org.jbpm.api.task.Task
the unique id for this task that is used as a reference in the service methods
getIdentityService() - Method in interface org.jbpm.api.ProcessEngine
the identity service that exposes the user and group operations management operations.
getImageResourceName() - Method in interface org.jbpm.api.ProcessDefinition
the name of the resource in the deployment which contains the image file for this process
getIncomingTransitions() - Method in interface org.jbpm.api.model.Activity
the list of arriving transitions.
getIsProcessInstance() - Method in interface org.jbpm.api.Execution
Returns whether this execution is a process instance.
getKey() - Method in interface org.jbpm.api.Execution
the optional user provided business key that is unique within one process definition.
getKey() - Method in interface org.jbpm.api.history.HistoryProcessInstance
unique user provided business key (could be null if no such key is provided in ExecutionService.startProcessInstanceById(String, java.util.Map, String))
getKey() - Method in interface org.jbpm.api.ProcessDefinition
the user defined short representation of the name.
getLockExpirationTime() - Method in interface org.jbpm.api.job.Job
getLockOwner() - Method in interface org.jbpm.api.job.Job
job executor identification that has acquired this job and is going to execute it
getManagementService() - Method in interface org.jbpm.api.ProcessEngine
the management service that exposes the management operations to operators that have to keep the jBPM system up and running.
getMessage() - Method in interface org.jbpm.api.history.HistoryComment
the actual message.
getName() - Method in interface org.jbpm.api.Deployment
typically correspond to the file name or url or some other form of identifying the source archive file for this deployment.
getName() - Method in interface org.jbpm.api.Execution
the externally given name or id of this execution.
getName() - Method in interface org.jbpm.api.identity.Group
name for the group (should be unique within one group type)
getName() - Method in interface org.jbpm.api.model.Activity
the short display name given to this element.
getName() - Method in interface org.jbpm.api.model.Transition
the short display name given to this element.
getName() - Method in interface org.jbpm.api.ProcessDefinition
the short display name given to this process definition.
getName() - Method in interface org.jbpm.api.task.Swimlane
the name of the swimlane as defined in the process file
getName() - Method in interface org.jbpm.api.task.Task
the short display name of this task.
getOutcome() - Method in interface org.jbpm.api.history.HistoryTask
the outcome of this task
getOutcomes(String) - Method in interface org.jbpm.api.TaskService
the set of possible valid outcomes for this task.
getOutgoingTransition(String) - Method in interface org.jbpm.api.model.Activity
the first leaving transition with the given name or null of no such leaving transition exists.
getOutgoingTransitions() - Method in interface org.jbpm.api.model.Activity
the list of outgoing transitions.
getOutgoingTransitionsMap() - Method in interface org.jbpm.api.model.Activity
the leaving transitions, keyed by transition name.
getParent() - Method in interface org.jbpm.api.Execution
the parent execution in the execution structure.
getParent() - Method in interface org.jbpm.api.model.OpenExecution
the parent execution in the execution structure.
getParentActivity() - Method in interface org.jbpm.api.model.Activity
retrieve the parent activity in the composite activity structure.
getPriority() - Method in interface org.jbpm.api.Execution
indicates low priorities with negative values and high priorities with positive values.
getPriority() - Method in interface org.jbpm.api.task.Task
the priority of this task.
getProcessDefinitionId() - Method in interface org.jbpm.api.Execution
id of the process definition used for this execution
getProcessDefinitionId() - Method in interface org.jbpm.api.history.HistoryProcessInstance
reference to the process definition
getProcessEngine() - Static method in class org.jbpm.api.Configuration
get the singleton ProcessEngine that is created from the default configuration file 'jbpm.cfg.xml'.
getProcessInstance() - Method in interface org.jbpm.api.Execution
the main path of execution in the execution structure.
getProcessInstance() - Method in interface org.jbpm.api.job.Job
the related process instance
getProcessInstance() - Method in interface org.jbpm.api.model.OpenExecution
the main path of execution in the execution tree structure.
getProcessInstanceId() - Method in interface org.jbpm.api.history.HistoryProcessInstance
the process instance id (== the root execution id)
getProgress() - Method in interface org.jbpm.api.task.Task
The progress of this task.
getRepeat() - Method in interface org.jbpm.api.job.Timer
indicates the delay for repeating this timer after successful execution
getReplies() - Method in interface org.jbpm.api.history.HistoryComment
threaded replies to this comment
getRepositoryService() - Method in interface org.jbpm.api.ProcessEngine
the repository service that provides access to the process repository.
getResourceAsStream(String, String) - Method in interface org.jbpm.api.RepositoryService
obtain an InputStream to a resource in a deployment
getResourceNames(String) - Method in interface org.jbpm.api.RepositoryService
Returns all the resources stored in the deployment with the given id.
getRetries() - Method in interface org.jbpm.api.job.Job
number of retries left.
getSignalName() - Method in interface org.jbpm.api.job.Timer
the signal that sent to the execution when the timer fires
getSource() - Method in interface org.jbpm.api.model.Transition
the activity from which this transition leaves.
getStartActivityNames(String) - Method in interface org.jbpm.api.RepositoryService
find all the activity names of the start activities for a given process definition.
getStartFormResourceName(String, String) - Method in interface org.jbpm.api.RepositoryService
the resource name for the given start activity.
getStartTime() - Method in interface org.jbpm.api.history.HistoryActivityInstance
time when the activity was entered
getStartTime() - Method in interface org.jbpm.api.history.HistoryProcessInstance
when the process instance started
getState() - Method in interface org.jbpm.api.Deployment
Deployment.STATE_ACTIVE or Deployment.STATE_SUSPENDED
getState() - Method in interface org.jbpm.api.Execution
the state of this execution.
getState() - Method in interface org.jbpm.api.history.HistoryProcessInstance
HistoryProcessInstance.STATE_ACTIVE or HistoryProcessInstance.STATE_ENDED (this more coarse grained state then Execution.getState())
getState() - Method in interface org.jbpm.api.history.HistoryTask
history task state
getSubProcessInstance() - Method in interface org.jbpm.api.Execution
the sub path of execution in the execution structure.
getSubProcessInstance() - Method in interface org.jbpm.api.model.OpenExecution
the related sub process execution.
getSubTasks(String) - Method in interface org.jbpm.api.TaskService
get the subtasks for this task.
getTask(String) - Method in interface org.jbpm.api.TaskService
Retrieves the task with the given identifier from persistent storage.
getTaskComments(String) - Method in interface org.jbpm.api.TaskService
get the list of comments made to a task.
getTaskParticipations(String) - Method in interface org.jbpm.api.TaskService
get roles related to a given task.
getTaskService() - Method in interface org.jbpm.api.ProcessEngine
the task service that exposes the runtime human task lists.
getTime() - Method in interface org.jbpm.api.history.HistoryDetail
time that specifies when the comment was made
getTimestamp() - Method in interface org.jbpm.api.Deployment
the timestamp can optionally be given and represents the last updated timestamp of the archive file that is being deployed.
getTransitionNames() - Method in interface org.jbpm.api.history.HistoryActivityInstance
The names of the transitions that were selected as outgoing transitions for the execution.
getType() - Method in interface org.jbpm.api.identity.Group
type or category of the group
getType() - Method in interface org.jbpm.api.model.Activity
the type of this activity which corresponds to the xml tag
getType() - Method in interface org.jbpm.api.task.Participation
see constants for default participations
getUserId() - Method in interface org.jbpm.api.history.HistoryDetail
the id of the user that made this comment.
getUserId() - Method in interface org.jbpm.api.task.Participation
userId for this participation.
getVariable(String, String) - Method in interface org.jbpm.api.ExecutionService
retrieves a variable
getVariable(String, String) - Method in interface org.jbpm.api.HistoryService
retrieves a map of variables
getVariable(String) - Method in interface org.jbpm.api.model.OpenExecution
retrieve the value for the given key.
getVariable(String, String) - Method in interface org.jbpm.api.TaskService
retrieves a variable
getVariableKeys() - Method in interface org.jbpm.api.model.OpenExecution
a non-null set that contains all the keys present in this scope.
getVariableNames(String) - Method in interface org.jbpm.api.ExecutionService
all the variables visible in the given execution scope
getVariableNames(String) - Method in interface org.jbpm.api.HistoryService
retrieves a variable
getVariableNames(String) - Method in interface org.jbpm.api.TaskService
all the variables visible in the given task
getVariables(String, Set<String>) - Method in interface org.jbpm.api.ExecutionService
retrieves a map of variables
getVariables(String, Set<String>) - Method in interface org.jbpm.api.HistoryService
all the variables visible in the given history execution scope
getVariables() - Method in interface org.jbpm.api.model.OpenExecution
a non-null map containing all the key-value pairs in this scope.
getVariables(String, Set<String>) - Method in interface org.jbpm.api.TaskService
retrieves a map of variables
getVersion() - Method in interface org.jbpm.api.ProcessDefinition
automatically assigned during deployment of a process that represents the sequence number for process definitions with the same name.
getWidth() - Method in interface org.jbpm.api.model.ActivityCoordinates
getX() - Method in interface org.jbpm.api.model.ActivityCoordinates
getY() - Method in interface org.jbpm.api.model.ActivityCoordinates
Group - Interface in org.jbpm.api.identity
a group of users.

H

hasActivities() - Method in interface org.jbpm.api.model.Activity
indicates if this processDefinition has activities.
hasActivity(String) - Method in interface org.jbpm.api.model.Activity
indicates if an activity with the given name exists directly in this element.
hasExecution(String) - Method in interface org.jbpm.api.Execution
indicates if this execution has a child execution with the given executionName
hasIncomingTransitions() - Method in interface org.jbpm.api.model.Activity
indicates if this activity has arriving transitions
hasOutgoingTransition(String) - Method in interface org.jbpm.api.model.Activity
indicates if a leaving transition with the given transitionName exists.
hasOutgoingTransitions() - Method in interface org.jbpm.api.model.Activity
indicates if this activity has leaving transitions
hasVariable(String) - Method in interface org.jbpm.api.model.OpenExecution
indicates presenve of the given key.
hasVariables() - Method in interface org.jbpm.api.model.OpenExecution
indicates if there are keys in this scope.
HistoryActivityInstance - Interface in org.jbpm.api.history
represents one occurrence of an activity during a process instance.
HistoryActivityInstanceQuery - Interface in org.jbpm.api.history
query for activity occurrences.
HistoryComment - Interface in org.jbpm.api.history
a free text comment that can be made to an Execution or a task.
HistoryDetail - Interface in org.jbpm.api.history
base type for all history details.
HistoryDetailQuery - Interface in org.jbpm.api.history
query for task comments, task assignments and so on.
HistoryProcessInstance - Interface in org.jbpm.api.history
one particular instance of a process definition.
HistoryProcessInstanceQuery - Interface in org.jbpm.api.history
query for ongoing and finished process instances.
HistoryService - Interface in org.jbpm.api
exposes the history information for ongoing and past process instances.
HistoryTask - Interface in org.jbpm.api.history
history record for a task instance.
HistoryTaskQuery - Interface in org.jbpm.api.history
query for history tasks.

I

IdentityService - Interface in org.jbpm.api
interface to expose the (configurable) identity component that is used by jBPM.
instantiate(String) - Method in class org.jbpm.api.Configuration
isActive(String) - Method in interface org.jbpm.api.Execution
is the given activity active.
isEnded() - Method in interface org.jbpm.api.Execution
is this execution ended
isExclusive() - Method in interface org.jbpm.api.job.Job
indicates if this job should be executed separate from any other job in the same process instance
isSuspended() - Method in interface org.jbpm.api.Execution
is this execution suspended ?
isSuspended() - Method in interface org.jbpm.api.ProcessDefinition
Returns whether this process definition is currently suspended.

J

JbpmException - Exception in org.jbpm.api
all exceptions that jBPM throws are JbpmException's (extends RuntimeException).
JbpmException() - Constructor for exception org.jbpm.api.JbpmException
JbpmException(String, Throwable) - Constructor for exception org.jbpm.api.JbpmException
JbpmException(String) - Constructor for exception org.jbpm.api.JbpmException
JbpmException(Throwable) - Constructor for exception org.jbpm.api.JbpmException
Job - Interface in org.jbpm.api.job
base class for timers and messages.
JobQuery - Interface in org.jbpm.api
query for jBPM related messages and timers.

L

list() - Method in interface org.jbpm.api.DeploymentQuery
execute the query and get the result list
list() - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
execute the query and obtain the list of HistoryActivityInstances
list() - Method in interface org.jbpm.api.history.HistoryDetailQuery
execute the query and obtain the list of HistoryDetails
list() - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
execute the query and obtain the list of HistoryProcessInstances
list() - Method in interface org.jbpm.api.history.HistoryTaskQuery
execute the query and obtain the list of HistoryTasks
list() - Method in interface org.jbpm.api.JobQuery
execute the query and get the result list
list() - Method in interface org.jbpm.api.ProcessDefinitionQuery
execute the query and obtain the list of ProcessDefinitions
list() - Method in interface org.jbpm.api.ProcessInstanceQuery
execute the query and obtain the list of ProcessInstances
list() - Method in interface org.jbpm.api.TaskQuery
execute the query and obtain the list of Tasks

M

ManagementService - Interface in org.jbpm.api
operations targeted to system operators that need to keep the process engine up and running.
Message - Interface in org.jbpm.api.job
an asynchronous message.
messages() - Method in interface org.jbpm.api.JobQuery
only select messages

N

NewDeployment - Interface in org.jbpm.api
extends a Deployment with method for creating a new deployment.
newTask() - Method in interface org.jbpm.api.TaskService
Creates a task.
newTask(String) - Method in interface org.jbpm.api.TaskService
Creates a new subtask for the given task.
notify(EventListenerExecution) - Method in interface org.jbpm.api.listener.EventListener
is invoked when an execution crosses the event on which this listener is registered
notSuspended() - Method in interface org.jbpm.api.DeploymentQuery
only select non-suspended deployments
notSuspended() - Method in interface org.jbpm.api.ProcessDefinitionQuery
select only process definitions that are not suspended
notSuspended() - Method in interface org.jbpm.api.ProcessInstanceQuery
select only process definitions that are not suspended
notSuspended() - Method in interface org.jbpm.api.TaskQuery
only select tasks that are not suspended

O

OpenExecution - Interface in org.jbpm.api.model
execution that opens up access to the related objects in the execution and process definition model.
OpenProcessInstance - Interface in org.jbpm.api.model
process instance for which the relations are exposed.
orderAsc(String) - Method in interface org.jbpm.api.DeploymentQuery
order results ascending for property DeploymentQuery.PROPERTY_TIMESTAMP or DeploymentQuery.PROPERTY_STATE
orderAsc(String) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
order selected activity instances ascending for certain properties
orderAsc(String) - Method in interface org.jbpm.api.history.HistoryDetailQuery
order selected process definitions ascending
orderAsc(String) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
order selected process instances ascending for certain properties
orderAsc(String) - Method in interface org.jbpm.api.history.HistoryTaskQuery
order selected history tasks ascending for certain properties
orderAsc(String) - Method in interface org.jbpm.api.JobQuery
order ascending for property JobQuery.PROPERTY_STATE or JobQuery.PROPERTY_DUEDATE
orderAsc(String) - Method in interface org.jbpm.api.ProcessDefinitionQuery
order selected process definitions ascending for certain properties
orderAsc(String) - Method in interface org.jbpm.api.ProcessInstanceQuery
order selected process instances ascending for certain properties
orderAsc(String) - Method in interface org.jbpm.api.TaskQuery
order selected tasks ascending for certain properties
orderDesc(String) - Method in interface org.jbpm.api.DeploymentQuery
order results descending for property DeploymentQuery.PROPERTY_TIMESTAMP or DeploymentQuery.PROPERTY_STATE
orderDesc(String) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
order selected process definitions descending for certain properties
orderDesc(String) - Method in interface org.jbpm.api.history.HistoryDetailQuery
order selected process definitions descending
orderDesc(String) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
order selected process instances ascending for certain properties
orderDesc(String) - Method in interface org.jbpm.api.history.HistoryTaskQuery
order selected process definitions descending for certain properties
orderDesc(String) - Method in interface org.jbpm.api.JobQuery
order descending for property JobQuery.PROPERTY_STATE or JobQuery.PROPERTY_DUEDATE
orderDesc(String) - Method in interface org.jbpm.api.ProcessDefinitionQuery
order selected process definitions descending for certain properties
orderDesc(String) - Method in interface org.jbpm.api.ProcessInstanceQuery
order selected process instances descending for certain properties
orderDesc(String) - Method in interface org.jbpm.api.TaskQuery
order selected tasks descending for certain properties
org.jbpm.api - package org.jbpm.api
the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.activity - package org.jbpm.api.activity
interfaces for implementing customized runtime behaviour of activities.
org.jbpm.api.cmd - package org.jbpm.api.cmd
org.jbpm.api.history - package org.jbpm.api.history
interfaces related to the HistoryService.
org.jbpm.api.identity - package org.jbpm.api.identity
User and Group interfaces related to the IdentityService
org.jbpm.api.job - package org.jbpm.api.job
Job, Message and Timer interfaces related to the ManagementService
org.jbpm.api.jpdl - package org.jbpm.api.jpdl
specific jPDL interfaces
org.jbpm.api.listener - package org.jbpm.api.listener
interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.
org.jbpm.api.model - package org.jbpm.api.model
common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.
org.jbpm.api.task - package org.jbpm.api.task
interfaces related to the TaskService
outcome(String) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select history tasks that have the given outcome
OWNER - Static variable in interface org.jbpm.api.task.Participation
the person with ultimate responsibility over a task.

P

page(int, int) - Method in interface org.jbpm.api.DeploymentQuery
only select a specific page
page(int, int) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
select a specific page in the result set
page(int, int) - Method in interface org.jbpm.api.history.HistoryDetailQuery
select a specific page in the result set
page(int, int) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
select a specific page in the result set
page(int, int) - Method in interface org.jbpm.api.history.HistoryTaskQuery
select a specific page in the result set
page(int, int) - Method in interface org.jbpm.api.JobQuery
only select a specific page
page(int, int) - Method in interface org.jbpm.api.ProcessDefinitionQuery
select a specific page in the result set
page(int, int) - Method in interface org.jbpm.api.ProcessInstanceQuery
select a specific page in the result set
page(int, int) - Method in interface org.jbpm.api.TaskQuery
select a specific page in the result set
ParamCommand<T> - Class in org.jbpm.api.cmd
command with support for parameter passing from the client to the implementation.
ParamCommand() - Constructor for class org.jbpm.api.cmd.ParamCommand
params - Variable in class org.jbpm.api.cmd.ParamCommand
Participation - Interface in org.jbpm.api.task
a link to a participating identity (user or group) and the type of involvement.
ProcessDefinition - Interface in org.jbpm.api
a graphical process which is deployed in the RepositoryService.
processDefinitionId(String) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
only select activity instances for the given process definition
processDefinitionId(String) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
select only process instances with the given process definition
processDefinitionId(String) - Method in interface org.jbpm.api.ProcessDefinitionQuery
select only the process definition with the given id
processDefinitionId(String) - Method in interface org.jbpm.api.ProcessInstanceQuery
select only process instances for the given process definition
processDefinitionId(String) - Method in interface org.jbpm.api.TaskQuery
only select tasks that are associated to the given process definition
processDefinitionKey(String) - Method in interface org.jbpm.api.ProcessDefinitionQuery
select only process definitions with the given key
processDefinitionName(String) - Method in interface org.jbpm.api.ProcessDefinitionQuery
select only process definitions with an exact match for the given name
processDefinitionNameLike(String) - Method in interface org.jbpm.api.ProcessDefinitionQuery
select only process definitions with a name like the given name (name can include % signs to act as wildcard))
ProcessDefinitionQuery - Interface in org.jbpm.api
query for process definitions.
ProcessEngine - Interface in org.jbpm.api
central starting point for all process engine API interactions.
ProcessInstance - Interface in org.jbpm.api
a process instance is one execution of a process definition.
processInstanceId(String) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
only select activity instances for the given process instance id
processInstanceId(String) - Method in interface org.jbpm.api.history.HistoryDetailQuery
only select details for the given processInstanceId
processInstanceId(String) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
select only the process instances with the given id
processInstanceId(String) - Method in interface org.jbpm.api.JobQuery
only select jobs related to the given process instance
processInstanceId(String) - Method in interface org.jbpm.api.ProcessInstanceQuery
select only a specific process instances using the process instance id
processInstanceId(String) - Method in interface org.jbpm.api.TaskQuery
only select tasks that are associated to the given process instance
processInstanceKey(String) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
select only process instances with the given business key
processInstanceKey(String) - Method in interface org.jbpm.api.ProcessInstanceQuery
select only specific process instances using a business key
ProcessInstanceQuery - Interface in org.jbpm.api
query for ongoing process instances exclusively. refer to HistoryProcessInstanceQuery for queries that include finished process instances.
PROPERTY_ACTIVITYNAME - Static variable in interface org.jbpm.api.history.HistoryActivityInstanceQuery
activityName property to be used as property in HistoryActivityInstanceQuery.orderAsc(String) and HistoryActivityInstanceQuery.orderDesc(String)
PROPERTY_ASSIGNEE - Static variable in interface org.jbpm.api.history.HistoryTaskQuery
outcome property to be used as property in orderAsc(String) and orderDesc(String)
PROPERTY_ASSIGNEE - Static variable in interface org.jbpm.api.TaskQuery
assignee property to be used as property in TaskQuery.orderAsc(String) and TaskQuery.orderDesc(String)
PROPERTY_CREATEDATE - Static variable in interface org.jbpm.api.TaskQuery
createdate property to be used as property in TaskQuery.orderAsc(String) and TaskQuery.orderDesc(String)
PROPERTY_CREATETIME - Static variable in interface org.jbpm.api.history.HistoryTaskQuery
starttime property to be used as property in orderAsc(String) and orderDesc(String)
PROPERTY_DEPLOYMENT_TIMESTAMP - Static variable in interface org.jbpm.api.ProcessDefinitionQuery
timestamp property to be used as property in ProcessDefinitionQuery.orderAsc(String) and ProcessDefinitionQuery.orderDesc(String)
PROPERTY_DUEDATE - Static variable in interface org.jbpm.api.JobQuery
duedate property to be used as property in JobQuery.orderAsc(String) and JobQuery.orderDesc(String)
PROPERTY_DUEDATE - Static variable in interface org.jbpm.api.TaskQuery
duedate property to be used as property in TaskQuery.orderAsc(String) and TaskQuery.orderDesc(String)
PROPERTY_DURATION - Static variable in interface org.jbpm.api.history.HistoryActivityInstanceQuery
duration property to be used as property in HistoryActivityInstanceQuery.orderAsc(String) and HistoryActivityInstanceQuery.orderDesc(String)
PROPERTY_DURATION - Static variable in interface org.jbpm.api.history.HistoryProcessInstanceQuery
duration property to be used as property in HistoryProcessInstanceQuery.orderAsc(String) and HistoryProcessInstanceQuery.orderDesc(String)
PROPERTY_DURATION - Static variable in interface org.jbpm.api.history.HistoryTaskQuery
duration property to be used as property in orderAsc(String) and orderDesc(String)
PROPERTY_ENDTIME - Static variable in interface org.jbpm.api.history.HistoryActivityInstanceQuery
endtime property to be used as property in HistoryActivityInstanceQuery.orderAsc(String) and HistoryActivityInstanceQuery.orderDesc(String)
PROPERTY_ENDTIME - Static variable in interface org.jbpm.api.history.HistoryProcessInstanceQuery
endtime property to be used as property in HistoryProcessInstanceQuery.orderAsc(String) and HistoryProcessInstanceQuery.orderDesc(String)
PROPERTY_ENDTIME - Static variable in interface org.jbpm.api.history.HistoryTaskQuery
endtime property to be used as property in orderAsc(String) and orderDesc(String)
PROPERTY_EXECUTIONID - Static variable in interface org.jbpm.api.history.HistoryActivityInstanceQuery
executionId property to be used as property in HistoryActivityInstanceQuery.orderAsc(String) and HistoryActivityInstanceQuery.orderDesc(String)
PROPERTY_EXECUTIONID - Static variable in interface org.jbpm.api.history.HistoryTaskQuery
executionId property to be used as property in orderAsc(String) and orderDesc(String)
PROPERTY_ID - Static variable in interface org.jbpm.api.history.HistoryProcessInstanceQuery
id property to be used as property in HistoryProcessInstanceQuery.orderAsc(String) and HistoryProcessInstanceQuery.orderDesc(String)
PROPERTY_ID - Static variable in interface org.jbpm.api.history.HistoryTaskQuery
id property to be used as property in orderAsc(String) and orderDesc(String)
PROPERTY_ID - Static variable in interface org.jbpm.api.ProcessDefinitionQuery
id property to be used as property in ProcessDefinitionQuery.orderAsc(String) and ProcessDefinitionQuery.orderDesc(String)
PROPERTY_KEY - Static variable in interface org.jbpm.api.history.HistoryProcessInstanceQuery
Key propertu to be used as property in HistoryProcessInstanceQuery.orderAsc(String) and HistoryProcessInstanceQuery.orderDesc(String)
PROPERTY_KEY - Static variable in interface org.jbpm.api.ProcessDefinitionQuery
key property to be used as property in ProcessDefinitionQuery.orderAsc(String) and ProcessDefinitionQuery.orderDesc(String)
PROPERTY_KEY - Static variable in interface org.jbpm.api.ProcessInstanceQuery
key property to be used as property in ProcessInstanceQuery.orderAsc(String) and ProcessInstanceQuery.orderDesc(String)
PROPERTY_NAME - Static variable in interface org.jbpm.api.ProcessDefinitionQuery
name property to be used as property in ProcessDefinitionQuery.orderAsc(String) and ProcessDefinitionQuery.orderDesc(String)
PROPERTY_NAME - Static variable in interface org.jbpm.api.TaskQuery
name property to be used as property in TaskQuery.orderAsc(String) and TaskQuery.orderDesc(String)
PROPERTY_OUTCOME - Static variable in interface org.jbpm.api.history.HistoryTaskQuery
outcome property to be used as property in orderAsc(String) and orderDesc(String)
PROPERTY_PRIORITY - Static variable in interface org.jbpm.api.TaskQuery
priority property to be used as property in TaskQuery.orderAsc(String) and TaskQuery.orderDesc(String)
PROPERTY_PROGRESS - Static variable in interface org.jbpm.api.TaskQuery
progress property to be used as property in TaskQuery.orderAsc(String) and TaskQuery.orderDesc(String)
PROPERTY_STARTTIME - Static variable in interface org.jbpm.api.history.HistoryActivityInstanceQuery
starttime property to be used as property in HistoryActivityInstanceQuery.orderAsc(String) and HistoryActivityInstanceQuery.orderDesc(String)
PROPERTY_STARTTIME - Static variable in interface org.jbpm.api.history.HistoryProcessInstanceQuery
starttime property to be used as property in HistoryProcessInstanceQuery.orderAsc(String) and HistoryProcessInstanceQuery.orderDesc(String)
PROPERTY_STATE - Static variable in interface org.jbpm.api.DeploymentQuery
PROPERTY_STATE - Static variable in interface org.jbpm.api.history.HistoryProcessInstanceQuery
state property to be used as property in HistoryProcessInstanceQuery.orderAsc(String) and HistoryProcessInstanceQuery.orderDesc(String)
PROPERTY_STATE - Static variable in interface org.jbpm.api.history.HistoryTaskQuery
state property to be used as property in orderAsc(String) and orderDesc(String)
PROPERTY_STATE - Static variable in interface org.jbpm.api.JobQuery
state property to be used as property in JobQuery.orderAsc(String) and JobQuery.orderDesc(String)
PROPERTY_TIME - Static variable in interface org.jbpm.api.history.HistoryDetailQuery
time property to be used as property in HistoryDetailQuery.orderAsc(String) and HistoryDetailQuery.orderDesc(String)
PROPERTY_TIMESTAMP - Static variable in interface org.jbpm.api.DeploymentQuery
PROPERTY_USERID - Static variable in interface org.jbpm.api.history.HistoryDetailQuery
userId property to be used as property in HistoryDetailQuery.orderAsc(String) and HistoryDetailQuery.orderDesc(String)
PROPERTY_VERSION - Static variable in interface org.jbpm.api.ProcessDefinitionQuery
version property to be used as property in ProcessDefinitionQuery.orderAsc(String) and ProcessDefinitionQuery.orderDesc(String)

R

REMIND - Static variable in interface org.jbpm.api.model.Event
fired when an assignee is reminded of a task
removeTaskParticipatingGroup(String, String, String) - Method in interface org.jbpm.api.TaskService
removes a role to a given task.
removeTaskParticipatingUser(String, String, String) - Method in interface org.jbpm.api.TaskService
removes a role to a given task.
removeVariable(String) - Method in interface org.jbpm.api.model.OpenExecution
remove the key-value pair for the given key from this scope.
removeVariables() - Method in interface org.jbpm.api.model.OpenExecution
removes all variables in this scope
REPLACED_ASSIGNEE - Static variable in interface org.jbpm.api.task.Participation
a person that was assigned to a task, but got replaced because of absence or another reason.
RepositoryService - Interface in org.jbpm.api
exposes the repository of deployments.
resumeDeployment(String) - Method in interface org.jbpm.api.RepositoryService
resume a suspended deployment.

S

saveTask(Task) - Method in interface org.jbpm.api.TaskService
Saves the given task to persistent storage.
setAssignee(String) - Method in interface org.jbpm.api.task.Assignable
assign the task or swimlane to the given user
setAssignee(String) - Method in interface org.jbpm.api.task.Task
update the assignee of this task.
setAuthenticatedUserId(String) - Method in interface org.jbpm.api.ProcessEngine
sets the authenticated user's id for the next invocation of a service method in the same thread.
setDescription(String) - Method in interface org.jbpm.api.task.Task
update the longer description of this task.
setDuedate(Date) - Method in interface org.jbpm.api.task.Task
update the date and time when this task must be completed.
setFile(File) - Method in class org.jbpm.api.Configuration
provide a File as the configuration file
setHibernateSession(Object) - Method in interface org.jbpm.api.ProcessEngine
sets the hibernate session for the next invocation of a service method in the same thread.
setHibernateSessionFactory(Object) - Method in class org.jbpm.api.Configuration
provides the hibernate session factory programmatically.
setInputSource(InputSource) - Method in class org.jbpm.api.Configuration
provide a sax input source as the configuration resource
setInputStream(InputStream) - Method in class org.jbpm.api.Configuration
provide an input stream as the configuration resource
setJdbcConnection(Connection) - Method in interface org.jbpm.api.ProcessEngine
sets the hibernate session for the next invocation of a service method in the same thread.
setName(String) - Method in interface org.jbpm.api.NewDeployment
typically correspond to the file name or url or some other form of identifying the source archive file for this deployment.
setName(String) - Method in interface org.jbpm.api.task.Task
change the short display name of this tasks.
setParam(String, Object) - Method in class org.jbpm.api.cmd.ParamCommand
setPriority(int) - Method in interface org.jbpm.api.activity.ActivityExecution
setter for the priority.
setPriority(int) - Method in interface org.jbpm.api.listener.EventListenerExecution
setter for the priority.
setPriority(int) - Method in interface org.jbpm.api.model.OpenExecution
setter for the priority.
setPriority(int) - Method in interface org.jbpm.api.task.Task
update the priority.
setProgress(Integer) - Method in interface org.jbpm.api.task.Task
Change the progress of this task.
setResource(String) - Method in class org.jbpm.api.Configuration
provide an classpath resource as the configuration file
setState(String) - Method in interface org.jbpm.api.model.OpenExecution
update the state
setTimestamp(long) - Method in interface org.jbpm.api.NewDeployment
the timestamp can optionally be given and represents the last updated timestamp of the archive file that is being deployed.
setUrl(URL) - Method in class org.jbpm.api.Configuration
point with a url to the configuration file
setVariable(String, String, Object) - Method in interface org.jbpm.api.ExecutionService
creates or overwrites a variable value in the referenced execution
setVariable(String, Object) - Method in interface org.jbpm.api.model.OpenExecution
updates or creates a variable for the given value.
setVariables(String, Map<String, ?>) - Method in interface org.jbpm.api.ExecutionService
creates or overwrites variable values in the referenced execution
setVariables(Map<String, ?>) - Method in interface org.jbpm.api.model.OpenExecution
sets all given variables.
setVariables(String, Map<String, ?>) - Method in interface org.jbpm.api.TaskService
creates or overwrites the variable values on the given task
setXmlString(String) - Method in class org.jbpm.api.Configuration
provide an xml string as the configuration resource
signal(ActivityExecution, String, Map<String, ?>) - Method in interface org.jbpm.api.activity.ExternalActivityBehaviour
handles an external signal.
signalExecutionById(String) - Method in interface org.jbpm.api.ExecutionService
provides an external trigger to an execution.
signalExecutionById(String, String) - Method in interface org.jbpm.api.ExecutionService
provides a named external trigger to an execution.
signalExecutionById(String, String, Map<String, ?>) - Method in interface org.jbpm.api.ExecutionService
provides a named external trigger to an execution with parameters.
signalExecutionById(String, Map<String, ?>) - Method in interface org.jbpm.api.ExecutionService
provides a external trigger to an execution with parameters.
START - Static variable in interface org.jbpm.api.model.Event
fired when a process or an activity starts
startedAfter(Date) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
only select activity instances started after the given time
startedAfter(Date) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select history tasks started after the given time
startedBefore(Date) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
only select activity instances started before the given time
startedBefore(Date) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select history tasks started before the given time
startProcessInstanceById(String) - Method in interface org.jbpm.api.ExecutionService
starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
startProcessInstanceById(String, String) - Method in interface org.jbpm.api.ExecutionService
starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
startProcessInstanceById(String, Map<String, ?>) - Method in interface org.jbpm.api.ExecutionService
starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
startProcessInstanceById(String, Map<String, ?>, String) - Method in interface org.jbpm.api.ExecutionService
starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
startProcessInstanceByKey(String) - Method in interface org.jbpm.api.ExecutionService
starts a new process instance in the latest version of the given process definition.
startProcessInstanceByKey(String, String) - Method in interface org.jbpm.api.ExecutionService
starts a new process instance in the latest version of the given processDefinitionName.
startProcessInstanceByKey(String, Map<String, ?>) - Method in interface org.jbpm.api.ExecutionService
starts a new process instance in the latest version of the given processDefinitionName.
startProcessInstanceByKey(String, Map<String, ?>, String) - Method in interface org.jbpm.api.ExecutionService
starts a new process instance in the latest version of the given processDefinitionName.
state(String) - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
select only process instances in the given state
state(String) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select history tasks in the given state
STATE_ACTIVE - Static variable in interface org.jbpm.api.Deployment
normal deployments for which contained process definitions can be executed.
STATE_ACTIVE - Static variable in interface org.jbpm.api.history.HistoryProcessInstance
when the full process instance is still active
STATE_ACTIVE_CONCURRENT - Static variable in interface org.jbpm.api.Execution
concurrent path of execution that is an active indicator of the current position in the diagram.
STATE_ACTIVE_ROOT - Static variable in interface org.jbpm.api.Execution
single (non-concurrent) path of execution that is an active indicator of the current position in the diagram.
STATE_ASYNC - Static variable in interface org.jbpm.api.Execution
indicates that this execution is doing an asynchronous continuation.
STATE_COMPLETED - Static variable in interface org.jbpm.api.history.HistoryTask
STATE_COMPLETED - Static variable in interface org.jbpm.api.task.Task
task is done
STATE_CREATED - Static variable in interface org.jbpm.api.Execution
between creation of a new process instance and the start of that process instance.
STATE_ENDED - Static variable in interface org.jbpm.api.Execution
this execution has ended.
STATE_ENDED - Static variable in interface org.jbpm.api.history.HistoryProcessInstance
when the full process instance has come to an end
STATE_INACTIVE_CONCURRENT_ROOT - Static variable in interface org.jbpm.api.Execution
parent of concurrent child executions.
STATE_INACTIVE_JOIN - Static variable in interface org.jbpm.api.Execution
concurrent execution that is inactively waiting in a join until other concurrent executions arrive.
STATE_INACTIVE_SCOPE - Static variable in interface org.jbpm.api.Execution
parent of a scoped execution.
STATE_OBSOLETE - Static variable in interface org.jbpm.api.history.HistoryTask
STATE_OPEN - Static variable in interface org.jbpm.api.task.Task
task is waiting for someone to work on it and completed it
STATE_SUSPENDED - Static variable in interface org.jbpm.api.Deployment
invisible for all operations except delete or resume.
STATE_SUSPENDED - Static variable in interface org.jbpm.api.Execution
indicates that this execution is temporary suspended.
STATE_SUSPENDED - Static variable in interface org.jbpm.api.task.Task
task doesn't show up in task lists as something is wrong with the related process instance that requires manual intervention first.
suspendDeployment(String) - Method in interface org.jbpm.api.RepositoryService
similar to deleting a deployment.
suspended() - Method in interface org.jbpm.api.DeploymentQuery
only select suspended deployments
suspended() - Method in interface org.jbpm.api.ProcessDefinitionQuery
select only suspended process definitions
suspended() - Method in interface org.jbpm.api.ProcessInstanceQuery
select only suspended process definitions
suspended() - Method in interface org.jbpm.api.TaskQuery
only select suspended tasks
Swimlane - Interface in org.jbpm.api.task
a runtime process role that can store an assignment so that multiple related tasks are assigned to the same actor.

T

take(String) - Method in interface org.jbpm.api.activity.ActivityExecution
takes the outgoing transition with the given name.
TAKE - Static variable in interface org.jbpm.api.model.Event
fired when a transition is being taken
takeDefaultTransition() - Method in interface org.jbpm.api.activity.ActivityExecution
takes the default transition.
takeTask(String, String) - Method in interface org.jbpm.api.TaskService
taking this task will prevent all other candidates from taking and working on this task.
Task - Interface in org.jbpm.api.task
a runtime task.
taskId(String) - Method in interface org.jbpm.api.history.HistoryDetailQuery
only select details for the given taskId
taskId(String) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select the history task for the given id
TaskQuery - Interface in org.jbpm.api
query for tasks.
TaskService - Interface in org.jbpm.api
task management.
timeAfter(Date) - Method in interface org.jbpm.api.history.HistoryDetailQuery
only select details after the given time
timeBefore(Date) - Method in interface org.jbpm.api.history.HistoryDetailQuery
only select details before the given time
Timer - Interface in org.jbpm.api.job
a timer.
timers() - Method in interface org.jbpm.api.JobQuery
only select timers
tookLessThen(long) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
only select activity instances that took less then the given duration in milliseconds
tookLessThen(long) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select history tasks that took less then the given duration in milliseconds
tookLongerThen(long) - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
only select activity instances that took longer then the given duration in milliseconds
tookLongerThen(long) - Method in interface org.jbpm.api.history.HistoryTaskQuery
only select history tasks that took longer then the given duration in milliseconds
Transition - Interface in org.jbpm.api.model
a transition in a OpenProcessDefinition graph.

U

unassigned() - Method in interface org.jbpm.api.TaskQuery
only select tasks that are unassigned.
uniqueResult() - Method in interface org.jbpm.api.DeploymentQuery
execute the query and get the unique result
uniqueResult() - Method in interface org.jbpm.api.history.HistoryActivityInstanceQuery
execute the query and obtain the unique HistoryActivityInstance
uniqueResult() - Method in interface org.jbpm.api.history.HistoryDetailQuery
execute the query and obtain the unique HistoryDetail
uniqueResult() - Method in interface org.jbpm.api.history.HistoryProcessInstanceQuery
execute the query and obtain the unique HistoryProcessInstance
uniqueResult() - Method in interface org.jbpm.api.history.HistoryTaskQuery
execute the query and obtain the unique HistoryTask
uniqueResult() - Method in interface org.jbpm.api.JobQuery
execute the query and get the unique result
uniqueResult() - Method in interface org.jbpm.api.ProcessDefinitionQuery
execute the query and obtain the unique ProcessDefinition
uniqueResult() - Method in interface org.jbpm.api.ProcessInstanceQuery
execute the query and obtain the unique ProcessInstance
uniqueResult() - Method in interface org.jbpm.api.TaskQuery
execute the query and obtain the unique Task
User - Interface in org.jbpm.api.identity
a user.

V

VIEWER - Static variable in interface org.jbpm.api.task.Participation
person that is allowed to watch-but-not-touch this task
VoidCommand - Class in org.jbpm.api.cmd
convenience for commands without return value.
VoidCommand() - Constructor for class org.jbpm.api.cmd.VoidCommand

W

waitForSignal() - Method in interface org.jbpm.api.activity.ActivityExecution
makes this execution wait in the current activity until an external trigger is given with one of the signal methods.
A B C D E F G H I J L M N O P R S T U V W
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Overview List

All Classes

Packages
org.jbpm.api
org.jbpm.api.activity
org.jbpm.api.cmd
org.jbpm.api.history
org.jbpm.api.identity
org.jbpm.api.job
org.jbpm.api.jpdl
org.jbpm.api.listener
org.jbpm.api.model
org.jbpm.api.task


Hierarchy For All Packages

Package Hierarchies:
org.jbpm.api, org.jbpm.api.activity, org.jbpm.api.cmd, org.jbpm.api.history, org.jbpm.api.identity, org.jbpm.api.job, org.jbpm.api.jpdl, org.jbpm.api.listener, org.jbpm.api.model, org.jbpm.api.task

Class Hierarchy

  • java.lang.Object
    • org.jbpm.api.Configuration
    • org.jbpm.api.cmd.ParamCommand<T> (implements org.jbpm.api.cmd.Command<T>)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.jbpm.api.JbpmException
    • org.jbpm.api.cmd.VoidCommand (implements org.jbpm.api.cmd.Command<T>)

Interface Hierarchy

  • org.jbpm.api.model.Activity
  • org.jbpm.api.model.ActivityCoordinates
  • org.jbpm.api.task.Assignable
  • org.jbpm.api.Deployment
    • org.jbpm.api.NewDeployment
  • org.jbpm.api.DeploymentQuery
  • org.jbpm.api.cmd.Environment
  • org.jbpm.api.model.Event
  • org.jbpm.api.ExecutionService
  • org.jbpm.api.identity.Group
  • org.jbpm.api.history.HistoryActivityInstance
  • org.jbpm.api.history.HistoryActivityInstanceQuery
  • org.jbpm.api.history.HistoryDetailQuery
  • org.jbpm.api.history.HistoryProcessInstance
  • org.jbpm.api.history.HistoryProcessInstanceQuery
  • org.jbpm.api.HistoryService
  • org.jbpm.api.history.HistoryTask
  • org.jbpm.api.history.HistoryTaskQuery
  • org.jbpm.api.IdentityService
  • org.jbpm.api.job.Job
    • org.jbpm.api.job.Message
    • org.jbpm.api.job.Timer
  • org.jbpm.api.JobQuery
  • org.jbpm.api.ManagementService
  • org.jbpm.api.task.Participation
  • org.jbpm.api.ProcessDefinitionQuery
  • org.jbpm.api.ProcessEngine
  • org.jbpm.api.ProcessInstanceQuery
  • org.jbpm.api.RepositoryService
  • java.io.Serializable
    • org.jbpm.api.activity.ActivityBehaviour
      • org.jbpm.api.activity.ExternalActivityBehaviour
    • org.jbpm.api.activity.ActivityExecution
    • org.jbpm.api.task.AssignmentHandler
    • org.jbpm.api.cmd.Command<T>
    • org.jbpm.api.jpdl.DecisionHandler
    • org.jbpm.api.listener.EventListener
    • org.jbpm.api.listener.EventListenerExecution
    • org.jbpm.api.Execution
      • org.jbpm.api.activity.ActivityExecution
      • org.jbpm.api.listener.EventListenerExecution
      • org.jbpm.api.model.OpenExecution
        • org.jbpm.api.activity.ActivityExecution
        • org.jbpm.api.listener.EventListenerExecution
        • org.jbpm.api.model.OpenProcessInstance (also extends org.jbpm.api.ProcessInstance)
      • org.jbpm.api.model.OpenProcessInstance (also extends org.jbpm.api.model.OpenExecution, org.jbpm.api.ProcessInstance)
      • org.jbpm.api.ProcessInstance
        • org.jbpm.api.model.OpenProcessInstance (also extends org.jbpm.api.model.OpenExecution)
    • org.jbpm.api.activity.ExternalActivityBehaviour
    • org.jbpm.api.history.HistoryComment
    • org.jbpm.api.history.HistoryDetail
      • org.jbpm.api.history.HistoryComment
    • org.jbpm.api.model.OpenExecution
      • org.jbpm.api.activity.ActivityExecution
      • org.jbpm.api.listener.EventListenerExecution
      • org.jbpm.api.model.OpenProcessInstance (also extends org.jbpm.api.ProcessInstance)
    • org.jbpm.api.model.OpenProcessInstance (also extends org.jbpm.api.model.OpenExecution, org.jbpm.api.ProcessInstance)
    • org.jbpm.api.ProcessDefinition
    • org.jbpm.api.ProcessInstance
      • org.jbpm.api.model.OpenProcessInstance (also extends org.jbpm.api.model.OpenExecution)
    • org.jbpm.api.task.Swimlane
    • org.jbpm.api.task.Task
  • org.jbpm.api.TaskQuery
  • org.jbpm.api.TaskService
  • org.jbpm.api.model.Transition
  • org.jbpm.api.identity.User
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Serialized Form

Package org.jbpm.api

Class org.jbpm.api.JbpmException extends java.lang.RuntimeException implements Serializable

serialVersionUID: 1L

Package org.jbpm.api.activity
Package org.jbpm.api.cmd

Class org.jbpm.api.cmd.ParamCommand extends java.lang.Object implements Serializable

serialVersionUID: 1L

Serialized Fields

params

java.util.Map<K,V> params

Class org.jbpm.api.cmd.VoidCommand extends java.lang.Object implements Serializable

serialVersionUID: 1L

Package org.jbpm.api.history
Package org.jbpm.api.jpdl
Package org.jbpm.api.listener
Package org.jbpm.api.model
Package org.jbpm.api.task

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api
Interfaces
Deployment
DeploymentQuery
Execution
ExecutionService
HistoryService
IdentityService
JobQuery
ManagementService
NewDeployment
ProcessDefinition
ProcessDefinitionQuery
ProcessEngine
ProcessInstance
ProcessInstanceQuery
RepositoryService
TaskQuery
TaskService
Classes
Configuration
Exceptions
JbpmException


org.jbpm.api Class Hierarchy

Hierarchy For Package org.jbpm.api

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.jbpm.api.Configuration
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.jbpm.api.JbpmException

Interface Hierarchy

  • org.jbpm.api.Deployment
    • org.jbpm.api.NewDeployment
  • org.jbpm.api.DeploymentQuery
  • org.jbpm.api.ExecutionService
  • org.jbpm.api.HistoryService
  • org.jbpm.api.IdentityService
  • org.jbpm.api.JobQuery
  • org.jbpm.api.ManagementService
  • org.jbpm.api.ProcessDefinitionQuery
  • org.jbpm.api.ProcessEngine
  • org.jbpm.api.ProcessInstanceQuery
  • org.jbpm.api.RepositoryService
  • java.io.Serializable
    • org.jbpm.api.Execution
      • org.jbpm.api.ProcessInstance
    • org.jbpm.api.ProcessDefinition
  • org.jbpm.api.TaskQuery
  • org.jbpm.api.TaskService
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.jbpm.api

Uses of Package
org.jbpm.api

Packages that use org.jbpm.api
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.activity | interfaces for implementing customized runtime behaviour of activities.
org.jbpm.api.job | Job, Message and Timer interfaces related to the ManagementService
org.jbpm.api.listener | interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.
org.jbpm.api.model | common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.

Classes in org.jbpm.api used by org.jbpm.api
Configuration
process engine configuration.
Deployment
represents an existing deployment in the repository.
DeploymentQuery
find existing deployments in the repository.
Execution
a runtime path of execution.
ExecutionService
manages runtime process executions.
HistoryService
exposes the history information for ongoing and past process instances.
IdentityService
interface to expose the (configurable) identity component that is used by jBPM.
JobQuery
query for jBPM related messages and timers.
ManagementService
operations targeted to system operators that need to keep the process engine up and running.
NewDeployment
extends a Deployment with method for creating a new deployment.
ProcessDefinition
a graphical process which is deployed in the RepositoryService.
ProcessDefinitionQuery
query for process definitions.
ProcessEngine
central starting point for all process engine API interactions.
ProcessInstance
a process instance is one execution of a process definition.
ProcessInstanceQuery
query for ongoing process instances exclusively. refer to HistoryProcessInstanceQuery for queries that include finished process instances.
RepositoryService
exposes the repository of deployments.
TaskQuery
query for tasks.
TaskService
task management.

Classes in org.jbpm.api used by org.jbpm.api.activity
Execution
a runtime path of execution.

Classes in org.jbpm.api used by org.jbpm.api.job
Execution
a runtime path of execution.

Classes in org.jbpm.api used by org.jbpm.api.listener
Execution
a runtime path of execution.

Classes in org.jbpm.api used by org.jbpm.api.model
Execution
a runtime path of execution.
ProcessInstance
a process instance is one execution of a process definition.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.activity
Interfaces
ActivityBehaviour
ActivityExecution
ExternalActivityBehaviour


org.jbpm.api.activity Class Hierarchy

Hierarchy For Package org.jbpm.api.activity

Package Hierarchies:
All Packages

Interface Hierarchy

  • java.io.Serializable
    • org.jbpm.api.activity.ActivityBehaviour
      • org.jbpm.api.activity.ExternalActivityBehaviour
    • org.jbpm.api.Execution
      • org.jbpm.api.model.OpenExecution
        • org.jbpm.api.activity.ActivityExecution


Uses of Package org.jbpm.api.activity

Uses of Package
org.jbpm.api.activity

Packages that use org.jbpm.api.activity
org.jbpm.api.activity interfaces for implementing customized runtime behaviour of activities.

Classes in org.jbpm.api.activity used by org.jbpm.api.activity
ActivityBehaviour
implements the runtime behaviour of an activity.
ActivityExecution
view upon an Execution exposed to ActivityBehaviour implementations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.activity.ActivityBehaviour

Uses of Interface
org.jbpm.api.activity.ActivityBehaviour

Packages that use ActivityBehaviour
org.jbpm.api.activity interfaces for implementing customized runtime behaviour of activities.

Uses of ActivityBehaviour in org.jbpm.api.activity

Subinterfaces of ActivityBehaviour in org.jbpm.api.activity
 interface ExternalActivityBehaviour
extends ActivityBehaviour for handling external triggers after a wait state.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.activity.ActivityExecution

Uses of Interface
org.jbpm.api.activity.ActivityExecution

Packages that use ActivityExecution
org.jbpm.api.activity interfaces for implementing customized runtime behaviour of activities.

Uses of ActivityExecution in org.jbpm.api.activity

Methods in org.jbpm.api.activity with parameters of type ActivityExecution
void | ActivityBehaviour.execute(ActivityExecution execution) invoked when an execution arrives in an activity.
void | ExternalActivityBehaviour.signal(ActivityExecution execution, java.lang.String signalName, java.util.Map<java.lang.String,?> parameters) handles an external signal.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.activity.ExternalActivityBehaviour

Uses of Interface
org.jbpm.api.activity.ExternalActivityBehaviour

No usage of org.jbpm.api.activity.ExternalActivityBehaviour

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.jbpm.api.Configuration

Uses of Class
org.jbpm.api.Configuration

Packages that use Configuration
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of Configuration in org.jbpm.api

Methods in org.jbpm.api that return Configuration
protected Configuration | Configuration.instantiate(java.lang.String className)
Configuration | Configuration.setFile(java.io.File file) provide a File as the configuration file
Configuration | Configuration.setHibernateSessionFactory(java.lang.Object hibernateSessionFactory) provides the hibernate session factory programmatically.
Configuration | Configuration.setInputSource(org.xml.sax.InputSource inputSource) provide a sax input source as the configuration resource
Configuration | Configuration.setInputStream(java.io.InputStream inputStream) provide an input stream as the configuration resource
Configuration | Configuration.setResource(java.lang.String resource) provide an classpath resource as the configuration file
Configuration | Configuration.setUrl(java.net.URL url) point with a url to the configuration file
Configuration | Configuration.setXmlString(java.lang.String xmlString) provide an xml string as the configuration resource

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.Deployment

Uses of Interface
org.jbpm.api.Deployment

Packages that use Deployment
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of Deployment in org.jbpm.api

Subinterfaces of Deployment in org.jbpm.api
 interface NewDeployment
extends a Deployment with method for creating a new deployment.

Methods in org.jbpm.api that return Deployment
 Deployment DeploymentQuery.uniqueResult()
execute the query and get the unique result

Methods in org.jbpm.api that return types with arguments of type Deployment
 java.util.List<Deployment> DeploymentQuery.list()
execute the query and get the result list

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.DeploymentQuery

Uses of Interface
org.jbpm.api.DeploymentQuery

Packages that use DeploymentQuery
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of DeploymentQuery in org.jbpm.api

Methods in org.jbpm.api that return DeploymentQuery
DeploymentQuery | RepositoryService.createDeploymentQuery() create a query for deployments
DeploymentQuery | DeploymentQuery.deploymentId(java.lang.String id) only include a specific deployment by id
DeploymentQuery | DeploymentQuery.notSuspended() only select non-suspended deployments
DeploymentQuery | DeploymentQuery.orderAsc(java.lang.String property) order results ascending for property PROPERTY_TIMESTAMP or PROPERTY_STATE
DeploymentQuery | DeploymentQuery.orderDesc(java.lang.String property) order results descending for property PROPERTY_TIMESTAMP or PROPERTY_STATE
DeploymentQuery | DeploymentQuery.page(int firstResult, int maxResults) only select a specific page
DeploymentQuery | DeploymentQuery.suspended() only select suspended deployments

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.Execution

Uses of Interface
org.jbpm.api.Execution

Packages that use Execution
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.activity | interfaces for implementing customized runtime behaviour of activities.
org.jbpm.api.job | Job, Message and Timer interfaces related to the ManagementService
org.jbpm.api.listener | interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.
org.jbpm.api.model | common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.

Uses of Execution in org.jbpm.api

Subinterfaces of Execution in org.jbpm.api
 interface ProcessInstance
a process instance is one execution of a process definition.

Methods in org.jbpm.api that return Execution
Execution | Execution.findActiveExecutionIn(java.lang.String activityName) search for an execution that is active and in the given activityName.
Execution | ExecutionService.findExecutionById(java.lang.String executionId) the path of execution that is uniquely defined by the execution id.
Execution | Execution.getExecution(java.lang.String name) the child execution for the given name or null in case such execution doesn't exist.
Execution | Execution.getParent() the parent execution in the execution structure.
Execution | Execution.getProcessInstance() the main path of execution in the execution structure.
Execution | Execution.getSubProcessInstance() the sub path of execution in the execution structure.

Methods in org.jbpm.api that return types with arguments of type Execution
java.util.Collection<? extends Execution> | Execution.getExecutions() the child executions in the execution structure.
java.util.Map<java.lang.String,? extends Execution> | Execution.getExecutionsMap() maps child execution names to execution objects.

Uses of Execution in org.jbpm.api.activity

Subinterfaces of Execution in org.jbpm.api.activity
 interface ActivityExecution
view upon an Execution exposed to ActivityBehaviour implementations.

Uses of Execution in org.jbpm.api.job

Methods in org.jbpm.api.job that return Execution
Execution | Job.getExecution() the related execution
Execution | Job.getProcessInstance() the related process instance

Uses of Execution in org.jbpm.api.listener

Subinterfaces of Execution in org.jbpm.api.listener
 interface EventListenerExecution
view upon an path of execution exposed to EventListener implementations.

Uses of Execution in org.jbpm.api.model

Subinterfaces of Execution in org.jbpm.api.model
interface | OpenExecution execution that opens up access to the related objects in the execution and process definition model.
interface | OpenProcessInstance process instance for which the relations are exposed.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.ExecutionService

Uses of Interface
org.jbpm.api.ExecutionService

Packages that use ExecutionService
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of ExecutionService in org.jbpm.api

Methods in org.jbpm.api that return ExecutionService
 ExecutionService ProcessEngine.getExecutionService()
the execution service that provides access to the runtime executions repository.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.HistoryService

Uses of Interface
org.jbpm.api.HistoryService

Packages that use HistoryService
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of HistoryService in org.jbpm.api

Methods in org.jbpm.api that return HistoryService
 HistoryService ProcessEngine.getHistoryService()
the history service that provides access to the history executions repository.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.IdentityService

Uses of Interface
org.jbpm.api.IdentityService

Packages that use IdentityService
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of IdentityService in org.jbpm.api

Methods in org.jbpm.api that return IdentityService
 IdentityService ProcessEngine.getIdentityService()
the identity service that exposes the user and group operations management operations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.jbpm.api.JbpmException

Uses of Class
org.jbpm.api.JbpmException

No usage of org.jbpm.api.JbpmException

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.JobQuery

Uses of Interface
org.jbpm.api.JobQuery

Packages that use JobQuery
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of JobQuery in org.jbpm.api

Methods in org.jbpm.api that return JobQuery
JobQuery | ManagementService.createJobQuery() search for jobs
JobQuery | JobQuery.exception(boolean hasException) only select jobs that were rolled back due to an exception
JobQuery | JobQuery.messages() only select messages
JobQuery | JobQuery.orderAsc(java.lang.String property) order ascending for property PROPERTY_STATE or PROPERTY_DUEDATE
JobQuery | JobQuery.orderDesc(java.lang.String property) order descending for property PROPERTY_STATE or PROPERTY_DUEDATE
JobQuery | JobQuery.page(int firstResult, int maxResults) only select a specific page
JobQuery | JobQuery.processInstanceId(java.lang.String processInstanceId) only select jobs related to the given process instance
JobQuery | JobQuery.timers() only select timers

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.ManagementService

Uses of Interface
org.jbpm.api.ManagementService

Packages that use ManagementService
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of ManagementService in org.jbpm.api

Methods in org.jbpm.api that return ManagementService
 ManagementService ProcessEngine.getManagementService()
the management service that exposes the management operations to operators that have to keep the jBPM system up and running.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.NewDeployment

Uses of Interface
org.jbpm.api.NewDeployment

Packages that use NewDeployment
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of NewDeployment in org.jbpm.api

Methods in org.jbpm.api that return NewDeployment
NewDeployment | NewDeployment.addResourceFromClasspath(java.lang.String resourceName) adds a resource as a resource from the classpath
NewDeployment | NewDeployment.addResourceFromFile(java.io.File file) adds a resource from a file
NewDeployment | NewDeployment.addResourceFromInputStream(java.lang.String resourceName, java.io.InputStream inputStream) adds a resource as a string
NewDeployment | NewDeployment.addResourceFromString(java.lang.String resourceName, java.lang.String string) adds a resource as a string
NewDeployment | NewDeployment.addResourceFromUrl(java.net.URL url) adds a resource as a url
NewDeployment | NewDeployment.addResourcesFromZipInputStream(java.util.zip.ZipInputStream zipInputStream) adds a resource as a zip stream
NewDeployment | RepositoryService.createDeployment() create a new deployment.
NewDeployment | NewDeployment.setName(java.lang.String name) typically correspond to the file name or url or some other form of identifying the source archive file for this deployment.
NewDeployment | NewDeployment.setTimestamp(long timestamp) the timestamp can optionally be given and represents the last updated timestamp of the archive file that is being deployed.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.ProcessDefinition

Uses of Interface
org.jbpm.api.ProcessDefinition

Packages that use ProcessDefinition
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of ProcessDefinition in org.jbpm.api

Methods in org.jbpm.api that return ProcessDefinition
 ProcessDefinition ProcessDefinitionQuery.uniqueResult()
execute the query and obtain the unique ProcessDefinition

Methods in org.jbpm.api that return types with arguments of type ProcessDefinition
 java.util.List<ProcessDefinition> ProcessDefinitionQuery.list()
execute the query and obtain the list of ProcessDefinitions

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.ProcessDefinitionQuery

Uses of Interface
org.jbpm.api.ProcessDefinitionQuery

Packages that use ProcessDefinitionQuery
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of ProcessDefinitionQuery in org.jbpm.api

Methods in org.jbpm.api that return ProcessDefinitionQuery
ProcessDefinitionQuery | RepositoryService.createProcessDefinitionQuery() create a query for process definitions
ProcessDefinitionQuery | ProcessDefinitionQuery.deploymentId(java.lang.String deploymentId) select only process definitions within the given deployment
ProcessDefinitionQuery | ProcessDefinitionQuery.notSuspended() select only process definitions that are not suspended
ProcessDefinitionQuery | ProcessDefinitionQuery.orderAsc(java.lang.String property) order selected process definitions ascending for certain properties
ProcessDefinitionQuery | ProcessDefinitionQuery.orderDesc(java.lang.String property) order selected process definitions descending for certain properties
ProcessDefinitionQuery | ProcessDefinitionQuery.page(int firstResult, int maxResults) select a specific page in the result set
ProcessDefinitionQuery | ProcessDefinitionQuery.processDefinitionId(java.lang.String processDefinitionId) select only the process definition with the given id
ProcessDefinitionQuery | ProcessDefinitionQuery.processDefinitionKey(java.lang.String key) select only process definitions with the given key
ProcessDefinitionQuery | ProcessDefinitionQuery.processDefinitionName(java.lang.String name) select only process definitions with an exact match for the given name
ProcessDefinitionQuery | ProcessDefinitionQuery.processDefinitionNameLike(java.lang.String name) select only process definitions with a name like the given name (name can include % signs to act as wildcard))
ProcessDefinitionQuery | ProcessDefinitionQuery.suspended() select only suspended process definitions

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.ProcessEngine

Uses of Interface
org.jbpm.api.ProcessEngine

Packages that use ProcessEngine
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of ProcessEngine in org.jbpm.api

Methods in org.jbpm.api that return ProcessEngine
ProcessEngine | Configuration.buildProcessEngine() after specifying the configuration resources with the other methods, a process engine can be created.
static ProcessEngine | Configuration.getProcessEngine() get the singleton ProcessEngine that is created from the default configuration file 'jbpm.cfg.xml'.
ProcessEngine | ProcessEngine.setAuthenticatedUserId(java.lang.String authenticatedUserId) sets the authenticated user's id for the next invocation of a service method in the same thread.
ProcessEngine | ProcessEngine.setHibernateSession(java.lang.Object hibernateSession) sets the hibernate session for the next invocation of a service method in the same thread.
ProcessEngine | ProcessEngine.setJdbcConnection(java.sql.Connection jdbcConnection) sets the hibernate session for the next invocation of a service method in the same thread.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.ProcessInstance

Uses of Interface
org.jbpm.api.ProcessInstance

Packages that use ProcessInstance
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.model | common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.

Uses of ProcessInstance in org.jbpm.api

Methods in org.jbpm.api that return ProcessInstance
ProcessInstance | ExecutionService.findProcessInstanceById(java.lang.String processInstanceId) the process instance that is uniquely defined by the process execution id.
ProcessInstance | ExecutionService.signalExecutionById(java.lang.String executionId) provides an external trigger to an execution.
ProcessInstance | ExecutionService.signalExecutionById(java.lang.String executionId, java.util.Map<java.lang.String,?> parameters) provides a external trigger to an execution with parameters.
ProcessInstance | ExecutionService.signalExecutionById(java.lang.String executionId, java.lang.String signalName) provides a named external trigger to an execution.
ProcessInstance | ExecutionService.signalExecutionById(java.lang.String executionId, java.lang.String signalName, java.util.Map<java.lang.String,?> parameters) provides a named external trigger to an execution with parameters.
ProcessInstance | ExecutionService.startProcessInstanceById(java.lang.String processDefinitionId) starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
ProcessInstance | ExecutionService.startProcessInstanceById(java.lang.String processDefinitionId, java.util.Map<java.lang.String,?> variables) starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
ProcessInstance | ExecutionService.startProcessInstanceById(java.lang.String processDefinitionId, java.util.Map<java.lang.String,?> variables, java.lang.String processInstanceKey) starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
ProcessInstance | ExecutionService.startProcessInstanceById(java.lang.String processDefinitionId, java.lang.String processInstanceKey) starts a new process instance for the ProcessDefinition with the given processDefinitionDbid.
ProcessInstance | ExecutionService.startProcessInstanceByKey(java.lang.String processDefinitionKey) starts a new process instance in the latest version of the given process definition.
ProcessInstance | ExecutionService.startProcessInstanceByKey(java.lang.String processDefinitionKey, java.util.Map<java.lang.String,?> variables) starts a new process instance in the latest version of the given processDefinitionName.
ProcessInstance | ExecutionService.startProcessInstanceByKey(java.lang.String processDefinitionKey, java.util.Map<java.lang.String,?> variables, java.lang.String processInstanceKey) starts a new process instance in the latest version of the given processDefinitionName.
ProcessInstance | ExecutionService.startProcessInstanceByKey(java.lang.String processDefinitionKey, java.lang.String processInstanceKey) starts a new process instance in the latest version of the given processDefinitionName.
ProcessInstance | ProcessInstanceQuery.uniqueResult() execute the query and obtain the unique ProcessInstance

Methods in org.jbpm.api that return types with arguments of type ProcessInstance
 java.util.List<ProcessInstance> ProcessInstanceQuery.list()
execute the query and obtain the list of ProcessInstances

Uses of ProcessInstance in org.jbpm.api.model

Subinterfaces of ProcessInstance in org.jbpm.api.model
 interface OpenProcessInstance
process instance for which the relations are exposed.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.ProcessInstanceQuery

Uses of Interface
org.jbpm.api.ProcessInstanceQuery

Packages that use ProcessInstanceQuery
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of ProcessInstanceQuery in org.jbpm.api

Methods in org.jbpm.api that return ProcessInstanceQuery
ProcessInstanceQuery | ExecutionService.createProcessInstanceQuery() search for process instances with criteria.
ProcessInstanceQuery | ProcessInstanceQuery.notSuspended() select only process definitions that are not suspended
ProcessInstanceQuery | ProcessInstanceQuery.orderAsc(java.lang.String property) order selected process instances ascending for certain properties
ProcessInstanceQuery | ProcessInstanceQuery.orderDesc(java.lang.String property) order selected process instances descending for certain properties
ProcessInstanceQuery | ProcessInstanceQuery.page(int firstResult, int maxResults) select a specific page in the result set
ProcessInstanceQuery | ProcessInstanceQuery.processDefinitionId(java.lang.String processDefinitionId) select only process instances for the given process definition
ProcessInstanceQuery | ProcessInstanceQuery.processInstanceId(java.lang.String processInstanceId) select only a specific process instances using the process instance id
ProcessInstanceQuery | ProcessInstanceQuery.processInstanceKey(java.lang.String processInstanceKey) select only specific process instances using a business key
ProcessInstanceQuery | ProcessInstanceQuery.suspended() select only suspended process definitions

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.RepositoryService

Uses of Interface
org.jbpm.api.RepositoryService

Packages that use RepositoryService
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of RepositoryService in org.jbpm.api

Methods in org.jbpm.api that return RepositoryService
 RepositoryService ProcessEngine.getRepositoryService()
the repository service that provides access to the process repository.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.TaskQuery

Uses of Interface
org.jbpm.api.TaskQuery

Packages that use TaskQuery
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of TaskQuery in org.jbpm.api

Methods in org.jbpm.api that return TaskQuery
TaskQuery | TaskQuery.activityName(java.lang.String activityName) only select tasks that are associated to the given activity name.
TaskQuery | TaskQuery.assignee(java.lang.String userId) only select tasks for which the given user is the assignee
TaskQuery | TaskQuery.candidate(java.lang.String userId) only query for tasks for which the given user is a candidate.
TaskQuery | TaskService.createTaskQuery() create a new query for tasks
TaskQuery | TaskQuery.executionId(java.lang.String executionId) only select tasks that are associated to the given execution
TaskQuery | TaskQuery.notSuspended() only select tasks that are not suspended
TaskQuery | TaskQuery.orderAsc(java.lang.String property) order selected tasks ascending for certain properties
TaskQuery | TaskQuery.orderDesc(java.lang.String property) order selected tasks descending for certain properties
TaskQuery | TaskQuery.page(int firstResult, int maxResults) select a specific page in the result set
TaskQuery | TaskQuery.processDefinitionId(java.lang.String processDefinitionId) only select tasks that are associated to the given process definition
TaskQuery | TaskQuery.processInstanceId(java.lang.String processInstanceId) only select tasks that are associated to the given process instance
TaskQuery | TaskQuery.suspended() only select suspended tasks
TaskQuery | TaskQuery.unassigned() only select tasks that are unassigned.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.TaskService

Uses of Interface
org.jbpm.api.TaskService

Packages that use TaskService
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of TaskService in org.jbpm.api

Methods in org.jbpm.api that return TaskService
 TaskService ProcessEngine.getTaskService()
the task service that exposes the runtime human task lists.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.cmd
Interfaces
Command
Environment
Classes
ParamCommand
VoidCommand


org.jbpm.api.cmd Class Hierarchy

Hierarchy For Package org.jbpm.api.cmd

Package Hierarchies:
All Packages

Class Hierarchy

  • java.lang.Object
    • org.jbpm.api.cmd.ParamCommand<T> (implements org.jbpm.api.cmd.Command<T>)
    • org.jbpm.api.cmd.VoidCommand (implements org.jbpm.api.cmd.Command<T>)

Interface Hierarchy

  • org.jbpm.api.cmd.Environment
  • java.io.Serializable
    • org.jbpm.api.cmd.Command<T>


Uses of Package org.jbpm.api.cmd

Uses of Package
org.jbpm.api.cmd

Packages that use org.jbpm.api.cmd
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.cmd |

Classes in org.jbpm.api.cmd used by org.jbpm.api
Command
commands that can be executed by the process engine.

Classes in org.jbpm.api.cmd used by org.jbpm.api.cmd
Command
commands that can be executed by the process engine.
Environment
exposes configured process engine scope objects and transaction scope objects to command implementations.
ParamCommand
command with support for parameter passing from the client to the implementation.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.cmd.Command

Uses of Interface
org.jbpm.api.cmd.Command

Packages that use Command
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.cmd |

Uses of Command in org.jbpm.api

Methods in org.jbpm.api with parameters of type Command
<T> T
ProcessEngine.execute(Command<T> command)
perform a user command.

Uses of Command in org.jbpm.api.cmd

Classes in org.jbpm.api.cmd that implement Command
class | ParamCommand<T> command with support for parameter passing from the client to the implementation.
class | VoidCommand convenience for commands without return value.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.cmd.Environment

Uses of Interface
org.jbpm.api.cmd.Environment

Packages that use Environment
org.jbpm.api.cmd

Uses of Environment in org.jbpm.api.cmd

Methods in org.jbpm.api.cmd with parameters of type Environment
java.lang.Void | VoidCommand.execute(Environment environment)
T | Command.execute(Environment environment)
protected abstract void | VoidCommand.executeVoid(Environment environment)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.jbpm.api.cmd.ParamCommand

Uses of Class
org.jbpm.api.cmd.ParamCommand

Packages that use ParamCommand
org.jbpm.api.cmd

Uses of ParamCommand in org.jbpm.api.cmd

Methods in org.jbpm.api.cmd that return ParamCommand
 ParamCommand<T> ParamCommand.setParam(java.lang.String name, java.lang.Object value)

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class org.jbpm.api.cmd.VoidCommand

Uses of Class
org.jbpm.api.cmd.VoidCommand

No usage of org.jbpm.api.cmd.VoidCommand

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.history
Interfaces
HistoryActivityInstance
HistoryActivityInstanceQuery
HistoryComment
HistoryDetail
HistoryDetailQuery
HistoryProcessInstance
HistoryProcessInstanceQuery
HistoryTask
HistoryTaskQuery


org.jbpm.api.history Class Hierarchy

Hierarchy For Package org.jbpm.api.history

Package Hierarchies:
All Packages

Interface Hierarchy

  • org.jbpm.api.history.HistoryActivityInstance
  • org.jbpm.api.history.HistoryActivityInstanceQuery
  • org.jbpm.api.history.HistoryDetailQuery
  • org.jbpm.api.history.HistoryProcessInstance
  • org.jbpm.api.history.HistoryProcessInstanceQuery
  • org.jbpm.api.history.HistoryTask
  • org.jbpm.api.history.HistoryTaskQuery
  • java.io.Serializable
    • org.jbpm.api.history.HistoryDetail
      • org.jbpm.api.history.HistoryComment


Uses of Package org.jbpm.api.history

Uses of Package
org.jbpm.api.history

Packages that use org.jbpm.api.history
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.history | interfaces related to the HistoryService.

Classes in org.jbpm.api.history used by org.jbpm.api
HistoryActivityInstanceQuery
query for activity occurrences.
HistoryComment
a free text comment that can be made to an Execution or a task.
HistoryDetailQuery
query for task comments, task assignments and so on.
HistoryProcessInstanceQuery
query for ongoing and finished process instances.
HistoryTaskQuery
query for history tasks.

Classes in org.jbpm.api.history used by org.jbpm.api.history
HistoryActivityInstance
represents one occurrence of an activity during a process instance.
HistoryActivityInstanceQuery
query for activity occurrences.
HistoryComment
a free text comment that can be made to an Execution or a task.
HistoryDetail
base type for all history details.
HistoryDetailQuery
query for task comments, task assignments and so on.
HistoryProcessInstance
one particular instance of a process definition.
HistoryProcessInstanceQuery
query for ongoing and finished process instances.
HistoryTask
history record for a task instance.
HistoryTaskQuery
query for history tasks.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryActivityInstance

Uses of Interface
org.jbpm.api.history.HistoryActivityInstance

Packages that use HistoryActivityInstance
org.jbpm.api.history interfaces related to the HistoryService.

Uses of HistoryActivityInstance in org.jbpm.api.history

Methods in org.jbpm.api.history that return HistoryActivityInstance
 HistoryActivityInstance HistoryActivityInstanceQuery.uniqueResult()
execute the query and obtain the unique HistoryActivityInstance

Methods in org.jbpm.api.history that return types with arguments of type HistoryActivityInstance
 java.util.List<HistoryActivityInstance> HistoryActivityInstanceQuery.list()
execute the query and obtain the list of HistoryActivityInstances

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryActivityInstanceQuery

Uses of Interface
org.jbpm.api.history.HistoryActivityInstanceQuery

Packages that use HistoryActivityInstanceQuery
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.history | interfaces related to the HistoryService.

Uses of HistoryActivityInstanceQuery in org.jbpm.api

Methods in org.jbpm.api that return HistoryActivityInstanceQuery
 HistoryActivityInstanceQuery HistoryService.createHistoryActivityInstanceQuery()
search in history activity instance information

Uses of HistoryActivityInstanceQuery in org.jbpm.api.history

Methods in org.jbpm.api.history that return HistoryActivityInstanceQuery
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.activityName(java.lang.String activityName) only select activity instances for the given activity (this usually used in combination with processDefinitionId(String))
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.executionId(java.lang.String executionId) only select activity instances for the given execution
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.orderAsc(java.lang.String property) order selected activity instances ascending for certain properties
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.orderDesc(java.lang.String property) order selected process definitions descending for certain properties
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.page(int firstResult, int maxResults) select a specific page in the result set
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.processDefinitionId(java.lang.String processDefinitionId) only select activity instances for the given process definition
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.processInstanceId(java.lang.String processInstanceId) only select activity instances for the given process instance id
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.startedAfter(java.util.Date time) only select activity instances started after the given time
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.startedBefore(java.util.Date time) only select activity instances started before the given time
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.tookLessThen(long durationInMillis) only select activity instances that took less then the given duration in milliseconds
HistoryActivityInstanceQuery | HistoryActivityInstanceQuery.tookLongerThen(long durationInMillis) only select activity instances that took longer then the given duration in milliseconds

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryComment

Uses of Interface
org.jbpm.api.history.HistoryComment

Packages that use HistoryComment
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.history | interfaces related to the HistoryService.

Uses of HistoryComment in org.jbpm.api

Methods in org.jbpm.api that return HistoryComment
HistoryComment | TaskService.addReplyComment(java.lang.String commentId, java.lang.String message) add a reply to another comment
HistoryComment | TaskService.addTaskComment(java.lang.String taskId, java.lang.String message) add a comment to a task

Methods in org.jbpm.api that return types with arguments of type HistoryComment
 java.util.List<HistoryComment> TaskService.getTaskComments(java.lang.String taskId)
get the list of comments made to a task.

Uses of HistoryComment in org.jbpm.api.history

Methods in org.jbpm.api.history that return types with arguments of type HistoryComment
 java.util.List<? extends HistoryComment> HistoryComment.getReplies()
threaded replies to this comment

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryDetail

Uses of Interface
org.jbpm.api.history.HistoryDetail

Packages that use HistoryDetail
org.jbpm.api.history interfaces related to the HistoryService.

Uses of HistoryDetail in org.jbpm.api.history

Subinterfaces of HistoryDetail in org.jbpm.api.history
 interface HistoryComment
a free text comment that can be made to an Execution or a task.

Methods in org.jbpm.api.history that return HistoryDetail
 HistoryDetail HistoryDetailQuery.uniqueResult()
execute the query and obtain the unique HistoryDetail

Methods in org.jbpm.api.history that return types with arguments of type HistoryDetail
 java.util.List<HistoryDetail> HistoryDetailQuery.list()
execute the query and obtain the list of HistoryDetails

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryDetailQuery

Uses of Interface
org.jbpm.api.history.HistoryDetailQuery

Packages that use HistoryDetailQuery
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.history | interfaces related to the HistoryService.

Uses of HistoryDetailQuery in org.jbpm.api

Methods in org.jbpm.api that return HistoryDetailQuery
 HistoryDetailQuery HistoryService.createHistoryDetailQuery()
search in history details

Uses of HistoryDetailQuery in org.jbpm.api.history

Methods in org.jbpm.api.history that return HistoryDetailQuery
HistoryDetailQuery | HistoryDetailQuery.activityInstanceId(java.lang.String activityInstanceId) only select details for the given activityInstanceId
HistoryDetailQuery | HistoryDetailQuery.comments() only select details of type comment (this usually used in combination with #processDefinitionId(String))
HistoryDetailQuery | HistoryDetailQuery.orderAsc(java.lang.String property) order selected process definitions ascending
HistoryDetailQuery | HistoryDetailQuery.orderDesc(java.lang.String property) order selected process definitions descending
HistoryDetailQuery | HistoryDetailQuery.page(int firstResult, int maxResults) select a specific page in the result set
HistoryDetailQuery | HistoryDetailQuery.processInstanceId(java.lang.String processInstanceId) only select details for the given processInstanceId
HistoryDetailQuery | HistoryDetailQuery.taskId(java.lang.String taskId) only select details for the given taskId
HistoryDetailQuery | HistoryDetailQuery.timeAfter(java.util.Date time) only select details after the given time
HistoryDetailQuery | HistoryDetailQuery.timeBefore(java.util.Date time) only select details before the given time

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryProcessInstance

Uses of Interface
org.jbpm.api.history.HistoryProcessInstance

Packages that use HistoryProcessInstance
org.jbpm.api.history interfaces related to the HistoryService.

Uses of HistoryProcessInstance in org.jbpm.api.history

Methods in org.jbpm.api.history that return HistoryProcessInstance
 HistoryProcessInstance HistoryProcessInstanceQuery.uniqueResult()
execute the query and obtain the unique HistoryProcessInstance

Methods in org.jbpm.api.history that return types with arguments of type HistoryProcessInstance
 java.util.List<HistoryProcessInstance> HistoryProcessInstanceQuery.list()
execute the query and obtain the list of HistoryProcessInstances

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryProcessInstanceQuery

Uses of Interface
org.jbpm.api.history.HistoryProcessInstanceQuery

Packages that use HistoryProcessInstanceQuery
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.history | interfaces related to the HistoryService.

Uses of HistoryProcessInstanceQuery in org.jbpm.api

Methods in org.jbpm.api that return HistoryProcessInstanceQuery
 HistoryProcessInstanceQuery HistoryService.createHistoryProcessInstanceQuery()
search for process instances in the history

Uses of HistoryProcessInstanceQuery in org.jbpm.api.history

Methods in org.jbpm.api.history that return HistoryProcessInstanceQuery
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.ended() select only process instances that have ended.
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.endedAfter(java.util.Date threshold) select only process instances that have ended on or after the given date.
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.endedBefore(java.util.Date threshold) select only process instances that have ended before the given date.
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.orderAsc(java.lang.String property) order selected process instances ascending for certain properties
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.orderDesc(java.lang.String property) order selected process instances ascending for certain properties
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.page(int firstResult, int maxResults) select a specific page in the result set
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.processDefinitionId(java.lang.String processDefinitionId) select only process instances with the given process definition
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.processInstanceId(java.lang.String processInstanceId) select only the process instances with the given id
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.processInstanceKey(java.lang.String processInstanceKey) select only process instances with the given business key
HistoryProcessInstanceQuery | HistoryProcessInstanceQuery.state(java.lang.String state) select only process instances in the given state

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryTask

Uses of Interface
org.jbpm.api.history.HistoryTask

Packages that use HistoryTask
org.jbpm.api.history interfaces related to the HistoryService.

Uses of HistoryTask in org.jbpm.api.history

Methods in org.jbpm.api.history that return HistoryTask
 HistoryTask HistoryTaskQuery.uniqueResult()
execute the query and obtain the unique HistoryTask

Methods in org.jbpm.api.history that return types with arguments of type HistoryTask
 java.util.List<HistoryTask> HistoryTaskQuery.list()
execute the query and obtain the list of HistoryTasks

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.history.HistoryTaskQuery

Uses of Interface
org.jbpm.api.history.HistoryTaskQuery

Packages that use HistoryTaskQuery
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.history | interfaces related to the HistoryService.

Uses of HistoryTaskQuery in org.jbpm.api

Methods in org.jbpm.api that return HistoryTaskQuery
 HistoryTaskQuery HistoryService.createHistoryTaskQuery()
search in history task information

Uses of HistoryTaskQuery in org.jbpm.api.history

Methods in org.jbpm.api.history that return HistoryTaskQuery
HistoryTaskQuery | HistoryTaskQuery.assignee(java.lang.String assignee) only select history tasks for the given assignee
HistoryTaskQuery | HistoryTaskQuery.executionId(java.lang.String executionId) only select history tasks within the given execution
HistoryTaskQuery | HistoryTaskQuery.orderAsc(java.lang.String property) order selected history tasks ascending for certain properties
HistoryTaskQuery | HistoryTaskQuery.orderDesc(java.lang.String property) order selected process definitions descending for certain properties
HistoryTaskQuery | HistoryTaskQuery.outcome(java.lang.String outcome) only select history tasks that have the given outcome
HistoryTaskQuery | HistoryTaskQuery.page(int firstResult, int maxResults) select a specific page in the result set
HistoryTaskQuery | HistoryTaskQuery.startedAfter(java.util.Date time) only select history tasks started after the given time
HistoryTaskQuery | HistoryTaskQuery.startedBefore(java.util.Date time) only select history tasks started before the given time
HistoryTaskQuery | HistoryTaskQuery.state(java.lang.String state) only select history tasks in the given state
HistoryTaskQuery | HistoryTaskQuery.taskId(java.lang.String taskId) only select the history task for the given id
HistoryTaskQuery | HistoryTaskQuery.tookLessThen(long durationInMillis) only select history tasks that took less then the given duration in milliseconds
HistoryTaskQuery | HistoryTaskQuery.tookLongerThen(long durationInMillis) only select history tasks that took longer then the given duration in milliseconds

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.identity
Interfaces
Group
User


org.jbpm.api.identity Class Hierarchy

Hierarchy For Package org.jbpm.api.identity

Package Hierarchies:
All Packages

Interface Hierarchy

  • org.jbpm.api.identity.Group
  • org.jbpm.api.identity.User


Uses of Package org.jbpm.api.identity

Uses of Package
org.jbpm.api.identity

Packages that use org.jbpm.api.identity
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Classes in org.jbpm.api.identity used by org.jbpm.api
Group
a group of users.
User
a user.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.identity.Group

Uses of Interface
org.jbpm.api.identity.Group

Packages that use Group
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of Group in org.jbpm.api

Methods in org.jbpm.api that return Group
 Group IdentityService.findGroupById(java.lang.String groupId)
lookup a group.

Methods in org.jbpm.api that return types with arguments of type Group
java.util.List<Group> | IdentityService.findGroupsByUser(java.lang.String userId) all group ids (String) for which this user is a member.
java.util.List<Group> | IdentityService.findGroupsByUserAndGroupType(java.lang.String userId, java.lang.String groupType) groups of the given groupType for which the given user is a member.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.identity.User

Uses of Interface
org.jbpm.api.identity.User

Packages that use User
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of User in org.jbpm.api

Methods in org.jbpm.api that return User
 User IdentityService.findUserById(java.lang.String userId)
lookup a user

Methods in org.jbpm.api that return types with arguments of type User
 java.util.List<User> IdentityService.findUsers()
get all the users in the system.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.job
Interfaces
Job
Message
Timer


org.jbpm.api.job Class Hierarchy

Hierarchy For Package org.jbpm.api.job

Package Hierarchies:
All Packages

Interface Hierarchy

  • org.jbpm.api.job.Job
    • org.jbpm.api.job.Message
    • org.jbpm.api.job.Timer


Uses of Package org.jbpm.api.job

Uses of Package
org.jbpm.api.job

Packages that use org.jbpm.api.job
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.job | Job, Message and Timer interfaces related to the ManagementService

Classes in org.jbpm.api.job used by org.jbpm.api
Job
base class for timers and messages.

Classes in org.jbpm.api.job used by org.jbpm.api.job
Job
base class for timers and messages.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.job.Job

Uses of Interface
org.jbpm.api.job.Job

Packages that use Job
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.job | Job, Message and Timer interfaces related to the ManagementService

Uses of Job in org.jbpm.api

Methods in org.jbpm.api that return Job
 Job JobQuery.uniqueResult()
execute the query and get the unique result

Methods in org.jbpm.api that return types with arguments of type Job
 java.util.List<Job> JobQuery.list()
execute the query and get the result list

Uses of Job in org.jbpm.api.job

Subinterfaces of Job in org.jbpm.api.job
interface | Message an asynchronous message.
interface | Timer a timer.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.job.Message

Uses of Interface
org.jbpm.api.job.Message

No usage of org.jbpm.api.job.Message

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.job.Timer

Uses of Interface
org.jbpm.api.job.Timer

No usage of org.jbpm.api.job.Timer

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.jpdl
Interfaces
DecisionHandler


org.jbpm.api.jpdl Class Hierarchy

Hierarchy For Package org.jbpm.api.jpdl

Package Hierarchies:
All Packages

Interface Hierarchy

  • java.io.Serializable
    • org.jbpm.api.jpdl.DecisionHandler


Uses of Package org.jbpm.api.jpdl

Uses of Package
org.jbpm.api.jpdl

No usage of org.jbpm.api.jpdl

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.jpdl.DecisionHandler

Uses of Interface
org.jbpm.api.jpdl.DecisionHandler

No usage of org.jbpm.api.jpdl.DecisionHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.listener
Interfaces
EventListener
EventListenerExecution


org.jbpm.api.listener Class Hierarchy

Hierarchy For Package org.jbpm.api.listener

Package Hierarchies:
All Packages

Interface Hierarchy

  • java.io.Serializable
    • org.jbpm.api.listener.EventListener
    • org.jbpm.api.Execution
      • org.jbpm.api.model.OpenExecution
        • org.jbpm.api.listener.EventListenerExecution


Uses of Package org.jbpm.api.listener

Uses of Package
org.jbpm.api.listener

Packages that use org.jbpm.api.listener
org.jbpm.api.listener interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.

Classes in org.jbpm.api.listener used by org.jbpm.api.listener
EventListenerExecution
view upon an path of execution exposed to EventListener implementations.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.listener.EventListener

Uses of Interface
org.jbpm.api.listener.EventListener

No usage of org.jbpm.api.listener.EventListener

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.listener.EventListenerExecution

Uses of Interface
org.jbpm.api.listener.EventListenerExecution

Packages that use EventListenerExecution
org.jbpm.api.listener interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.

Uses of EventListenerExecution in org.jbpm.api.listener

Methods in org.jbpm.api.listener with parameters of type EventListenerExecution
 void EventListener.notify(EventListenerExecution execution)
is invoked when an execution crosses the event on which this listener is registered

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.model
Interfaces
Activity
ActivityCoordinates
Event
OpenExecution
OpenProcessInstance
Transition


org.jbpm.api.model Class Hierarchy

Hierarchy For Package org.jbpm.api.model

Package Hierarchies:
All Packages

Interface Hierarchy

  • org.jbpm.api.model.Activity
  • org.jbpm.api.model.ActivityCoordinates
  • org.jbpm.api.model.Event
  • java.io.Serializable
    • org.jbpm.api.Execution
      • org.jbpm.api.model.OpenExecution
        • org.jbpm.api.model.OpenProcessInstance (also extends org.jbpm.api.ProcessInstance)
      • org.jbpm.api.ProcessInstance
        • org.jbpm.api.model.OpenProcessInstance (also extends org.jbpm.api.model.OpenExecution)
  • org.jbpm.api.model.Transition


Uses of Package org.jbpm.api.model

Uses of Package
org.jbpm.api.model

Packages that use org.jbpm.api.model
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.activity | interfaces for implementing customized runtime behaviour of activities.
org.jbpm.api.jpdl | specific jPDL interfaces
org.jbpm.api.listener | interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.
org.jbpm.api.model | common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.
org.jbpm.api.task | interfaces related to the TaskService

Classes in org.jbpm.api.model used by org.jbpm.api
ActivityCoordinates
activity coordinates indicating the graphical position in the diagram.

Classes in org.jbpm.api.model used by org.jbpm.api.activity
OpenExecution
execution that opens up access to the related objects in the execution and process definition model.

Classes in org.jbpm.api.model used by org.jbpm.api.jpdl
OpenExecution
execution that opens up access to the related objects in the execution and process definition model.

Classes in org.jbpm.api.model used by org.jbpm.api.listener
OpenExecution
execution that opens up access to the related objects in the execution and process definition model.

Classes in org.jbpm.api.model used by org.jbpm.api.model
Activity
a activity in a OpenProcessDefinition graph.
OpenExecution
execution that opens up access to the related objects in the execution and process definition model.
OpenProcessInstance
process instance for which the relations are exposed.
Transition
a transition in a OpenProcessDefinition graph.

Classes in org.jbpm.api.model used by org.jbpm.api.task
OpenExecution
execution that opens up access to the related objects in the execution and process definition model.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.model.Activity

Uses of Interface
org.jbpm.api.model.Activity

Packages that use Activity
org.jbpm.api.model common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.

Uses of Activity in org.jbpm.api.model

Methods in org.jbpm.api.model that return Activity
Activity | Activity.findActivity(java.lang.String activityName) searches for the given activity in this element recursively, including this activity and all child activities.
Activity | OpenExecution.getActivity() the current activity
Activity | Activity.getActivity(java.lang.String activityName) the first composite activity with the given name or null of no such activity exists.
Activity | Transition.getDestination() the activity in which this transition arrives.
Activity | Activity.getParentActivity() retrieve the parent activity in the composite activity structure.
Activity | Transition.getSource() the activity from which this transition leaves.

Methods in org.jbpm.api.model that return types with arguments of type Activity
java.util.List<? extends Activity> | Activity.getActivities() the list of direct composite activities.
java.util.Map<java.lang.String,? extends Activity> | Activity.getActivitiesMap() the composite activities, keyed by activity name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.model.ActivityCoordinates

Uses of Interface
org.jbpm.api.model.ActivityCoordinates

Packages that use ActivityCoordinates
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of ActivityCoordinates in org.jbpm.api

Methods in org.jbpm.api that return ActivityCoordinates
 ActivityCoordinates RepositoryService.getActivityCoordinates(java.lang.String processDefinitionId, java.lang.String activityName)
the coordinates for the activity on the process image.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.model.Event

Uses of Interface
org.jbpm.api.model.Event

No usage of org.jbpm.api.model.Event

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.model.OpenExecution

Uses of Interface
org.jbpm.api.model.OpenExecution

Packages that use OpenExecution
org.jbpm.api.activity | interfaces for implementing customized runtime behaviour of activities.
org.jbpm.api.jpdl | specific jPDL interfaces
org.jbpm.api.listener | interfaces for implementing event listeners, which represent runtime behaviour that can be associated as listeners to process events.
org.jbpm.api.model | common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.
org.jbpm.api.task | interfaces related to the TaskService

Uses of OpenExecution in org.jbpm.api.activity

Subinterfaces of OpenExecution in org.jbpm.api.activity
 interface ActivityExecution
view upon an Execution exposed to ActivityBehaviour implementations.

Uses of OpenExecution in org.jbpm.api.jpdl

Methods in org.jbpm.api.jpdl with parameters of type OpenExecution
 java.lang.String DecisionHandler.decide(OpenExecution execution)
the name of the selected outgoing transition

Uses of OpenExecution in org.jbpm.api.listener

Subinterfaces of OpenExecution in org.jbpm.api.listener
 interface EventListenerExecution
view upon an path of execution exposed to EventListener implementations.

Uses of OpenExecution in org.jbpm.api.model

Subinterfaces of OpenExecution in org.jbpm.api.model
 interface OpenProcessInstance
process instance for which the relations are exposed.

Methods in org.jbpm.api.model that return OpenExecution
OpenExecution | OpenExecution.findActiveExecutionIn(java.lang.String activityName) find the execution in the given activity or null if no such activity exists
OpenExecution | OpenExecution.getExecution(java.lang.String name) the child execution for the given name or null in case such execution doesn't exist.
OpenExecution | OpenExecution.getParent() the parent execution in the execution structure.
OpenExecution | OpenExecution.getSubProcessInstance() the related sub process execution.

Uses of OpenExecution in org.jbpm.api.task

Methods in org.jbpm.api.task with parameters of type OpenExecution
 void AssignmentHandler.assign(Assignable assignable, OpenExecution execution)
sets the actorId and candidates for the given task.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.model.OpenProcessInstance

Uses of Interface
org.jbpm.api.model.OpenProcessInstance

Packages that use OpenProcessInstance
org.jbpm.api.model common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.

Uses of OpenProcessInstance in org.jbpm.api.model

Methods in org.jbpm.api.model that return OpenProcessInstance
 OpenProcessInstance OpenExecution.getProcessInstance()
the main path of execution in the execution tree structure.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.model.Transition

Uses of Interface
org.jbpm.api.model.Transition

Packages that use Transition
org.jbpm.api.model common process execution model interfaces used in services and delegation interfaces like ActivityBehaviour and EventListener.

Uses of Transition in org.jbpm.api.model

Methods in org.jbpm.api.model that return Transition
Transition | Activity.findOutgoingTransition(java.lang.String transitionName) searches for the given transitionName in this activity and then up the parent chain.
Transition | Activity.getDefaultOutgoingTransition() the default outgoing transition.
Transition | Activity.getOutgoingTransition(java.lang.String transitionName) the first leaving transition with the given name or null of no such leaving transition exists.

Methods in org.jbpm.api.model that return types with arguments of type Transition
java.util.List<? extends Transition> | Activity.getIncomingTransitions() the list of arriving transitions.
java.util.List<? extends Transition> | Activity.getOutgoingTransitions() the list of outgoing transitions.
java.util.Map<java.lang.String,? extends Transition> | Activity.getOutgoingTransitionsMap() the leaving transitions, keyed by transition name.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


 org.jbpm.api.task
Interfaces
Assignable
AssignmentHandler
Participation
Swimlane
Task


org.jbpm.api.task Class Hierarchy

Hierarchy For Package org.jbpm.api.task

Package Hierarchies:
All Packages

Interface Hierarchy

  • org.jbpm.api.task.Assignable
  • org.jbpm.api.task.Participation
  • java.io.Serializable
    • org.jbpm.api.task.AssignmentHandler
    • org.jbpm.api.task.Swimlane
    • org.jbpm.api.task.Task
Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package org.jbpm.api.task

Uses of Package
org.jbpm.api.task

Packages that use org.jbpm.api.task
org.jbpm.api | the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.
org.jbpm.api.task | interfaces related to the TaskService

Classes in org.jbpm.api.task used by org.jbpm.api
Participation
a link to a participating identity (user or group) and the type of involvement.
Task
a runtime task.

Classes in org.jbpm.api.task used by org.jbpm.api.task
Assignable
tasks or swimlanes can be assigned.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.task.Assignable

Uses of Interface
org.jbpm.api.task.Assignable

Packages that use Assignable
org.jbpm.api.task interfaces related to the TaskService

Uses of Assignable in org.jbpm.api.task

Methods in org.jbpm.api.task with parameters of type Assignable
 void AssignmentHandler.assign(Assignable assignable, OpenExecution execution)
sets the actorId and candidates for the given task.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.task.AssignmentHandler

Uses of Interface
org.jbpm.api.task.AssignmentHandler

No usage of org.jbpm.api.task.AssignmentHandler

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.task.Participation

Uses of Interface
org.jbpm.api.task.Participation

Packages that use Participation
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of Participation in org.jbpm.api

Methods in org.jbpm.api that return types with arguments of type Participation
 java.util.List<Participation> TaskService.getTaskParticipations(java.lang.String taskId)
get roles related to a given task.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.task.Swimlane

Uses of Interface
org.jbpm.api.task.Swimlane

No usage of org.jbpm.api.task.Swimlane

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Interface org.jbpm.api.task.Task

Uses of Interface
org.jbpm.api.task.Task

Packages that use Task
org.jbpm.api the jBPM API, Start by creating a Configuration, build a ProcessEngine from that, and then you can find the workflow methods on the services like ExecutionService, TaskService.

Uses of Task in org.jbpm.api

Methods in org.jbpm.api that return Task
Task | TaskService.getTask(java.lang.String taskId) Retrieves the task with the given identifier from persistent storage.
Task | TaskService.newTask() Creates a task.
Task | TaskService.newTask(java.lang.String parentTaskId) Creates a new subtask for the given task.
Task | TaskQuery.uniqueResult() execute the query and obtain the unique Task

Methods in org.jbpm.api that return types with arguments of type Task
java.util.List<Task> | TaskService.findGroupTasks(java.lang.String userId) list of tasks that can be taken by the given user.
java.util.List<Task> | TaskService.findPersonalTasks(java.lang.String userId) list of tasks that are assigned to the given user.
java.util.List<Task> | TaskService.getSubTasks(java.lang.String taskId) get the subtasks for this task.
java.util.List<Task> | TaskQuery.list() execute the query and obtain the list of Tasks

Methods in org.jbpm.api with parameters of type Task
 java.lang.String TaskService.saveTask(Task task)
Saves the given task to persistent storage.

Overview Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES